Aspose.Email

Aspose.Email Namespace

Namespace hierarchy

Classes

Class | Description
ActiveSyncException | Represents errors that occur during ActiveSync protocol execution.
ActiveSyncNotSupportedException | Represents errors that occur during ActiveSync protocol execution.
AsposeArgumentException | The exception that is thrown when one of the arguments provided to a method is not valid.
AsposeArgumentNullException | The ArgumentException is thrown when an argument is null when it shouldn't be.
AsposeException | Base exceptioon type for Aspose.Email Represents errors that occur during application execution.
AsposeInvalidDataException | The exception that is thrown when one of the arguments provided to a method is not valid.
BuildVersionInfo | Provides information about the current product name and version.
ComparisonField | Base class that represents one search field.
CredentialsByHostClient | Represents the client that creates server connection by using the host credentials.
DateComparisonField | Represents the date search field.
FileCorruptedException | Exception that is thrown during file reading, when the file appears to be corrupted and impossible to read.
FormatNotSupportedException | Exception that is thrown during document load, when the document format is not recognized or not supported by the component.
GoogleClientException | Represents errors that occur during ActiveSync protocol execution.
IntComparisonField | Represents the integer search field.
License | Provides methods to license the component.
MailQuery | Represents the search criteria, that are used to match several message properties in the mailbox.
MailQueryBuilder | Represents the builder of search expression.
NetworkException | Thrown if there is a network connection failure.
QueryField | Base class for query fields.
StringComparisonField | Represents the string search field.

Enumerations

Enumeration | Description
ConnectionState | Describes the current state of the connection.

Generated:2014-05-31 01:32:13,version:1.3.49.0


ActiveSyncException Class

Represents errors that occur during ActiveSync protocol execution.

For a list of all members of this type, see ActiveSyncException Members.

System.Object
System.Exception
Aspose.Email.AsposeException
Aspose.Email.ActiveSyncException

public class ActiveSyncException : AsposeException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ActiveSyncException Members | Aspose.Email Namespace


ActiveSyncException Members

ActiveSyncException overview

Public Instance Constructors

ActiveSyncException Overloaded. Initializes a new instance of the ActiveSyncException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorCode | Returns a code of error.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from AsposeException) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from AsposeException) | Returns a string that represents the current object.

Protected Instance Constructors

ActiveSyncException Overloaded. Initializes a new instance of the ActiveSyncException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

_message (inherited from AsposeException)
Exception_EndOfInnerExceptionStack (inherited from AsposeException)

See Also

ActiveSyncException Class | Aspose.Email Namespace


ActiveSyncException Constructor

Initializes a new instance of the ActiveSyncException class with a specified error message.

Overload List

Initializes a new instance of the ActiveSyncException class.

public ActiveSyncException();

Initializes a new instance of the ActiveSyncException class with a reference to the inner exception that is the cause of this exception.

public ActiveSyncException(Exception);

Initializes a new instance of the ActiveSyncException class with serialized data.

protected ActiveSyncException(SerializationInfo,StreamingContext);

Initializes a new instance of the ActiveSyncException class with a specified error message.

public ActiveSyncException(string);

Initializes a new instance of the ActiveSyncException class with a specified error message and a reference to the inner exception that is the cause of this exception.

public ActiveSyncException(string,Exception);

See Also

ActiveSyncException Class | Aspose.Email Namespace


ActiveSyncException Constructor (String)

Initializes a new instance of the ActiveSyncException class with a specified error message.

public ActiveSyncException(
string message
);

Parameters

message
A message that describes the error.

See Also

ActiveSyncException Class | Aspose.Email Namespace | ActiveSyncException Constructor Overload List


ActiveSyncException Constructor ()

Initializes a new instance of the ActiveSyncException class.

public ActiveSyncException();

See Also

ActiveSyncException Class | Aspose.Email Namespace | ActiveSyncException Constructor Overload List


ActiveSyncException Constructor (String, Exception)

Initializes a new instance of the ActiveSyncException class with a specified error message and a reference to the inner exception that is the cause of this exception.

public ActiveSyncException(
string message,
Exception innerException
);

Parameters

message
The error message that explains the reason for the exception.
innerException
The exception that is the cause of the current exception, or a null reference (Nothing in Visual Basic) if no inner exception is specified.

See Also

ActiveSyncException Class | Aspose.Email Namespace | ActiveSyncException Constructor Overload List


ActiveSyncException Constructor (Exception)

Initializes a new instance of the ActiveSyncException class with a reference to the inner exception that is the cause of this exception.

public ActiveSyncException(
Exception innerException
);

Parameters

innerException
The exception that is the cause of the current exception, or a null reference (Nothing in Visual Basic) if no inner exception is specified.

See Also

ActiveSyncException Class | Aspose.Email Namespace | ActiveSyncException Constructor Overload List


ActiveSyncException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the ActiveSyncException class with serialized data.

protected ActiveSyncException(
SerializationInfo info,
StreamingContext context
);

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception Type | Condition
ArgumentNullException | The info parameter is null.
SerializationException | The class name is null or HResult is zero (0).

See Also

ActiveSyncException Class | Aspose.Email Namespace | ActiveSyncException Constructor Overload List


ActiveSyncException Properties

The properties of the ActiveSyncException class are listed below. For a complete list of ActiveSyncException class members, see the ActiveSyncException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorCode | Returns a code of error.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from AsposeException) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

ActiveSyncException Class | Aspose.Email Namespace


ErrorCode Property

Aspose.Email

ActiveSyncException.ErrorCode Property

Returns a code of error.

public int ErrorCode {get;}

See Also

ActiveSyncException Class | Aspose.Email Namespace


ActiveSyncNotSupportedException Class

Represents errors that occur during ActiveSync protocol execution.

For a list of all members of this type, see ActiveSyncNotSupportedException Members.

System.Object
System.Exception
Aspose.Email.AsposeException
Aspose.Email.ActiveSyncNotSupportedException

public class ActiveSyncNotSupportedException : AsposeException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ActiveSyncNotSupportedException Members | Aspose.Email Namespace


ActiveSyncNotSupportedException Members

ActiveSyncNotSupportedException overview

Public Instance Constructors

ActiveSyncNotSupportedException Overloaded. Initializes a new instance of the ActiveSyncNotSupportedException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorCode | Returns a code of error.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from AsposeException) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from AsposeException) | Returns a string that represents the current object.

Protected Instance Constructors

ActiveSyncNotSupportedException Overloaded. Initializes a new instance of the ActiveSyncNotSupportedException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

_message (inherited from AsposeException)
Exception_EndOfInnerExceptionStack (inherited from AsposeException)

See Also

ActiveSyncNotSupportedException Class | Aspose.Email Namespace


ActiveSyncNotSupportedException Constructor

Initializes a new instance of the ActiveSyncNotSupportedException class with a specified error message.

Overload List

Initializes a new instance of the ActiveSyncNotSupportedException class.

public ActiveSyncNotSupportedException();

Initializes a new instance of the ActiveSyncNotSupportedException class with a reference to the inner exception that is the cause of this exception.

public ActiveSyncNotSupportedException(Exception);

Initializes a new instance of the ActiveSyncNotSupportedException class with serialized data.

protected ActiveSyncNotSupportedException(SerializationInfo,StreamingContext);

Initializes a new instance of the ActiveSyncNotSupportedException class with a specified error message.

public ActiveSyncNotSupportedException(string);

Initializes a new instance of the ActiveSyncNotSupportedException class with a specified error message and a reference to the inner exception that is the cause of this exception.

public ActiveSyncNotSupportedException(string,Exception);

See Also

ActiveSyncNotSupportedException Class | Aspose.Email Namespace


ActiveSyncNotSupportedException Constructor (String)

Initializes a new instance of the ActiveSyncNotSupportedException class with a specified error message.

public ActiveSyncNotSupportedException(
string message
);

Parameters

message
A message that describes the error.

See Also

ActiveSyncNotSupportedException Class | Aspose.Email Namespace | ActiveSyncNotSupportedException Constructor Overload List


ActiveSyncNotSupportedException Constructor ()

Initializes a new instance of the ActiveSyncNotSupportedException class.

public ActiveSyncNotSupportedException();

See Also

ActiveSyncNotSupportedException Class | Aspose.Email Namespace | ActiveSyncNotSupportedException Constructor Overload List


ActiveSyncNotSupportedException Constructor (String, Exception)

Initializes a new instance of the ActiveSyncNotSupportedException class with a specified error message and a reference to the inner exception that is the cause of this exception.

public ActiveSyncNotSupportedException(
string message,
Exception innerException
);

Parameters

message
The error message that explains the reason for the exception.
innerException
The exception that is the cause of the current exception, or a null reference (Nothing in Visual Basic) if no inner exception is specified.

See Also

ActiveSyncNotSupportedException Class | Aspose.Email Namespace | ActiveSyncNotSupportedException Constructor Overload List


ActiveSyncNotSupportedException Constructor (Exception)

Initializes a new instance of the ActiveSyncNotSupportedException class with a reference to the inner exception that is the cause of this exception.

public ActiveSyncNotSupportedException(
Exception innerException
);

Parameters

innerException
The exception that is the cause of the current exception, or a null reference (Nothing in Visual Basic) if no inner exception is specified.

See Also

ActiveSyncNotSupportedException Class | Aspose.Email Namespace | ActiveSyncNotSupportedException Constructor Overload List


ActiveSyncNotSupportedException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the ActiveSyncNotSupportedException class with serialized data.

protected ActiveSyncNotSupportedException(
SerializationInfo info,
StreamingContext context
);

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception Type | Condition
ArgumentNullException | The info parameter is null.
SerializationException | The class name is null or HResult is zero (0).

See Also

ActiveSyncNotSupportedException Class | Aspose.Email Namespace | ActiveSyncNotSupportedException Constructor Overload List


ActiveSyncNotSupportedException Properties

The properties of the ActiveSyncNotSupportedException class are listed below. For a complete list of ActiveSyncNotSupportedException class members, see the ActiveSyncNotSupportedException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorCode | Returns a code of error.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from AsposeException) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

ActiveSyncNotSupportedException Class | Aspose.Email Namespace


ErrorCode Property

Aspose.Email

ActiveSyncNotSupportedException.ErrorCode Property

Returns a code of error.

public int ErrorCode {get;}

See Also

ActiveSyncNotSupportedException Class | Aspose.Email Namespace


AsposeArgumentException Class

The exception that is thrown when one of the arguments provided to a method is not valid.

For a list of all members of this type, see AsposeArgumentException Members.

System.Object
System.Exception
Aspose.Email.AsposeException
Aspose.Email.AsposeArgumentException

public class AsposeArgumentException : AsposeException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AsposeArgumentException Members | Aspose.Email Namespace


AsposeArgumentException Members

AsposeArgumentException overview

Public Instance Constructors

AsposeArgumentException Overloaded. Initializes a new instance of the AsposeArgumentException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from AsposeException) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from AsposeException) | Returns a string that represents the current object.

Protected Instance Constructors

AsposeArgumentException Overloaded. Initializes a new instance of the AsposeArgumentException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

_message (inherited from AsposeException)
Exception_EndOfInnerExceptionStack (inherited from AsposeException)

See Also

AsposeArgumentException Class | Aspose.Email Namespace


AsposeArgumentException Constructor

Initializes a new instance of the AsposeArgumentException class.

Overload List

Initializes a new instance of the AsposeArgumentException class.

public AsposeArgumentException();

Initializes a new instance of the AsposeArgumentException class with a reference to the inner exception that is the cause of this exception.

public AsposeArgumentException(Exception);

Initializes a new instance of the AsposeArgumentException class with serialized data.

protected AsposeArgumentException(SerializationInfo,StreamingContext);

Initializes a new instance of the AsposeArgumentException class with a specified error message.

public AsposeArgumentException(string);

Initializes a new instance of the AsposeArgumentException class with a specified error message and a reference to the inner exception that is the cause of this exception.

public AsposeArgumentException(string,Exception);

See Also

AsposeArgumentException Class | Aspose.Email Namespace


AsposeArgumentException Constructor ()

Initializes a new instance of the AsposeArgumentException class.

public AsposeArgumentException();

See Also

AsposeArgumentException Class | Aspose.Email Namespace | AsposeArgumentException Constructor Overload List


AsposeArgumentException Constructor (String)

Initializes a new instance of the AsposeArgumentException class with a specified error message.

public AsposeArgumentException(
string message
);

Parameters

message
The message that describes the error.

See Also

AsposeArgumentException Class | Aspose.Email Namespace | AsposeArgumentException Constructor Overload List


AsposeArgumentException Constructor (String, Exception)

Initializes a new instance of the AsposeArgumentException class with a specified error message and a reference to the inner exception that is the cause of this exception.

public AsposeArgumentException(
string message,
Exception innerException
);

Parameters

message
The error message that explains the reason for the exception.
innerException
The exception that is the cause of the current exception, or a null reference (Nothing in Visual Basic) if no inner exception is specified.

See Also

AsposeArgumentException Class | Aspose.Email Namespace | AsposeArgumentException Constructor Overload List


AsposeArgumentException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the AsposeArgumentException class with serialized data.

protected AsposeArgumentException(
SerializationInfo info,
StreamingContext context
);

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception Type | Condition
ArgumentNullException | The info parameter is null.
SerializationException | The class name is null or HResult is zero (0).

See Also

AsposeArgumentException Class | Aspose.Email Namespace | AsposeArgumentException Constructor Overload List


AsposeArgumentException Constructor (Exception)

Initializes a new instance of the AsposeArgumentException class with a reference to the inner exception that is the cause of this exception.

public AsposeArgumentException(
Exception innerException
);

Parameters

innerException
The exception that is the cause of the current exception, or a null reference (Nothing in Visual Basic) if no inner exception is specified.

See Also

AsposeArgumentException Class | Aspose.Email Namespace | AsposeArgumentException Constructor Overload List


AsposeArgumentNullException Class

The ArgumentException is thrown when an argument is null when it shouldn't be.

For a list of all members of this type, see AsposeArgumentNullException Members.

System.Object
System.Exception
Aspose.Email.AsposeException
Aspose.Email.AsposeArgumentNullException

public class AsposeArgumentNullException : AsposeException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AsposeArgumentNullException Members | Aspose.Email Namespace


AsposeArgumentNullException Members

AsposeArgumentNullException overview

Public Instance Constructors

AsposeArgumentNullException Overloaded. Initializes a new instance of the AsposeArgumentNullException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from AsposeException) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from AsposeException) | Returns a string that represents the current object.

Protected Instance Constructors

AsposeArgumentNullException Overloaded. Initializes a new instance of the AsposeArgumentNullException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

_message (inherited from AsposeException)
Exception_EndOfInnerExceptionStack (inherited from AsposeException)

See Also

AsposeArgumentNullException Class | Aspose.Email Namespace


AsposeArgumentNullException Constructor

Initializes a new instance of the AsposeArgumentNullException class.

Overload List

Initializes a new instance of the AsposeArgumentNullException class.

public AsposeArgumentNullException();

Initializes a new instance of the AsposeArgumentNullException class with a reference to the inner exception that is the cause of this exception.

public AsposeArgumentNullException(Exception);

Initializes a new instance of the AsposeArgumentNullException class with serialized data.

protected AsposeArgumentNullException(SerializationInfo,StreamingContext);

Initializes a new instance of the AsposeArgumentNullException class with a specified error message.

public AsposeArgumentNullException(string);

Initializes a new instance of the AsposeException class with a specified error message and a reference to the inner exception that is the cause of this exception.

public AsposeArgumentNullException(string,Exception);

See Also

AsposeArgumentNullException Class | Aspose.Email Namespace


AsposeArgumentNullException Constructor ()

Initializes a new instance of the AsposeArgumentNullException class.

public AsposeArgumentNullException();

See Also

AsposeArgumentNullException Class | Aspose.Email Namespace | AsposeArgumentNullException Constructor Overload List


AsposeArgumentNullException Constructor (String)

Initializes a new instance of the AsposeArgumentNullException class with a specified error message.

public AsposeArgumentNullException(
string message
);

Parameters

message
The message that describes the error.

See Also

AsposeArgumentNullException Class | Aspose.Email Namespace | AsposeArgumentNullException Constructor Overload List


AsposeArgumentNullException Constructor (String, Exception)

Initializes a new instance of the AsposeException class with a specified error message and a reference to the inner exception that is the cause of this exception.

public AsposeArgumentNullException(
string message,
Exception innerException
);

Parameters

message
The error message that explains the reason for the exception.
innerException
The exception that is the cause of the current exception, or a null reference (Nothing in Visual Basic) if no inner exception is specified.

See Also

AsposeArgumentNullException Class | Aspose.Email Namespace | AsposeArgumentNullException Constructor Overload List


AsposeArgumentNullException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the AsposeArgumentNullException class with serialized data.

protected AsposeArgumentNullException(
SerializationInfo info,
StreamingContext context
);

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception Type | Condition
ArgumentNullException | The info parameter is null.
SerializationException | The class name is null or HResult is zero (0).

See Also

AsposeArgumentNullException Class | Aspose.Email Namespace | AsposeArgumentNullException Constructor Overload List


AsposeArgumentNullException Constructor (Exception)

Initializes a new instance of the AsposeArgumentNullException class with a reference to the inner exception that is the cause of this exception.

public AsposeArgumentNullException(
Exception innerException
);

Parameters

innerException
The exception that is the cause of the current exception, or a null reference (Nothing in Visual Basic) if no inner exception is specified.

See Also

AsposeArgumentNullException Class | Aspose.Email Namespace | AsposeArgumentNullException Constructor Overload List


AsposeException Class

Base exceptioon type for Aspose.Email Represents errors that occur during application execution.

For a list of all members of this type, see AsposeException Members.

System.Object
System.Exception
Aspose.Email.AsposeException
Derived types

public class AsposeException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AsposeException Members | Aspose.Email Namespace


AsposeException Members

AsposeException overview

Public Instance Constructors

AsposeException Overloaded. Initializes a new instance of the AsposeException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Returns a string that represents the current object.

Protected Instance Constructors

AsposeException Overloaded. Initializes a new instance of the AsposeException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

_message
Exception_EndOfInnerExceptionStack

See Also

AsposeException Class | Aspose.Email Namespace


AsposeException Constructor

Initializes a new instance of the AsposeException class.

Overload List

Initializes a new instance of the AsposeException class.

public AsposeException();

Initializes a new instance of the AsposeException class with a reference to the inner exception that is the cause of this exception.

public AsposeException(Exception);

Initializes a new instance of the AsposeException class with serialized data.

protected AsposeException(SerializationInfo,StreamingContext);

Initializes a new instance of the AsposeException class with a specified error message.

public AsposeException(string);

Initializes a new instance of the AsposeException class with a specified error message and a reference to the inner exception that is the cause of this exception.

public AsposeException(string,Exception);

See Also

AsposeException Class | Aspose.Email Namespace


AsposeException Constructor ()

Initializes a new instance of the AsposeException class.

public AsposeException();

See Also

AsposeException Class | Aspose.Email Namespace | AsposeException Constructor Overload List


AsposeException Constructor (String)

Initializes a new instance of the AsposeException class with a specified error message.

public AsposeException(
string message
);

Parameters

message
The message that describes the error.

See Also

AsposeException Class | Aspose.Email Namespace | AsposeException Constructor Overload List


AsposeException Constructor (String, Exception)

Initializes a new instance of the AsposeException class with a specified error message and a reference to the inner exception that is the cause of this exception.

public AsposeException(
string message,
Exception innerException
);

Parameters

message
The error message that explains the reason for the exception.
innerException
The exception that is the cause of the current exception, or a null reference (Nothing in Visual Basic) if no inner exception is specified.

See Also

AsposeException Class | Aspose.Email Namespace | AsposeException Constructor Overload List


AsposeException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the AsposeException class with serialized data.

protected AsposeException(
SerializationInfo info,
StreamingContext context
);

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception Type | Condition
ArgumentNullException | The info parameter is null.
SerializationException | The class name is null or HResult is zero (0).

See Also

AsposeException Class | Aspose.Email Namespace | AsposeException Constructor Overload List


AsposeException Constructor (Exception)

Initializes a new instance of the AsposeException class with a reference to the inner exception that is the cause of this exception.

public AsposeException(
Exception innerException
);

Parameters

innerException
The exception that is the cause of the current exception, or a null reference (Nothing in Visual Basic) if no inner exception is specified.

See Also

AsposeException Class | Aspose.Email Namespace | AsposeException Constructor Overload List


AsposeException Fields

The fields of the AsposeException class are listed below. For a complete list of AsposeException class members, see the AsposeException Members topic.

Protected Internal Instance Fields

_message
Exception_EndOfInnerExceptionStack

See Also

AsposeException Class | Aspose.Email Namespace


AsposeException._message Field

new protected internal string _message;

See Also

AsposeException Class | Aspose.Email Namespace


AsposeException.Exception_EndOfInnerExceptionStack Field

protected internal string Exception_EndOfInnerExceptionStack;

See Also

AsposeException Class | Aspose.Email Namespace


AsposeException Properties

The properties of the AsposeException class are listed below. For a complete list of AsposeException class members, see the AsposeException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

AsposeException Class | Aspose.Email Namespace


Message Property

Aspose.Email

AsposeException.Message Property

Gets a message that describes the current exception.

public override string Message {get;}

See Also

AsposeException Class | Aspose.Email Namespace


AsposeException Methods

The methods of the AsposeException class are listed below. For a complete list of AsposeException class members, see the AsposeException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString | Returns a string that represents the current object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AsposeException Class | Aspose.Email Namespace


AsposeException.ToString Method

Returns a string that represents the current object.

public override string ToString();

Return Value

A string that represents the current object.

See Also

AsposeException Class | Aspose.Email Namespace


AsposeInvalidDataException Class

The exception that is thrown when one of the arguments provided to a method is not valid.

For a list of all members of this type, see AsposeInvalidDataException Members.

System.Object
System.Exception
Aspose.Email.AsposeException
Aspose.Email.AsposeInvalidDataException

public class AsposeInvalidDataException : AsposeException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AsposeInvalidDataException Members | Aspose.Email Namespace


AsposeInvalidDataException Members

AsposeInvalidDataException overview

Public Instance Constructors

AsposeInvalidDataException Overloaded. Initializes a new instance of the AsposeInvalidDataException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from AsposeException) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from AsposeException) | Returns a string that represents the current object.

Protected Instance Constructors

AsposeInvalidDataException Overloaded. Initializes a new instance of the AsposeInvalidDataException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

_message (inherited from AsposeException)
Exception_EndOfInnerExceptionStack (inherited from AsposeException)

See Also

AsposeInvalidDataException Class | Aspose.Email Namespace


AsposeInvalidDataException Constructor

Initializes a new instance of the AsposeInvalidDataException class.

Overload List

Initializes a new instance of the AsposeInvalidDataException class.

public AsposeInvalidDataException();

Initializes a new instance of the AsposeInvalidDataException class with a reference to the inner exception that is the cause of this exception.

public AsposeInvalidDataException(Exception);

Initializes a new instance of the AsposeInvalidDataException class with serialized data.

protected AsposeInvalidDataException(SerializationInfo,StreamingContext);

Initializes a new instance of the AsposeInvalidDataException class with a specified error message.

public AsposeInvalidDataException(string);

Initializes a new instance of the AsposeInvalidDataException class with a specified error message and a reference to the inner exception that is the cause of this exception.

public AsposeInvalidDataException(string,Exception);

See Also

AsposeInvalidDataException Class | Aspose.Email Namespace


AsposeInvalidDataException Constructor ()

Initializes a new instance of the AsposeInvalidDataException class.

public AsposeInvalidDataException();

See Also

AsposeInvalidDataException Class | Aspose.Email Namespace | AsposeInvalidDataException Constructor Overload List


AsposeInvalidDataException Constructor (String)

Initializes a new instance of the AsposeInvalidDataException class with a specified error message.

public AsposeInvalidDataException(
string message
);

Parameters

message
The message that describes the error.

See Also

AsposeInvalidDataException Class | Aspose.Email Namespace | AsposeInvalidDataException Constructor Overload List


AsposeInvalidDataException Constructor (String, Exception)

Initializes a new instance of the AsposeInvalidDataException class with a specified error message and a reference to the inner exception that is the cause of this exception.

public AsposeInvalidDataException(
string message,
Exception innerException
);

Parameters

message
The error message that explains the reason for the exception.
innerException
The exception that is the cause of the current exception, or a null reference (Nothing in Visual Basic) if no inner exception is specified.

See Also

AsposeInvalidDataException Class | Aspose.Email Namespace | AsposeInvalidDataException Constructor Overload List


AsposeInvalidDataException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the AsposeInvalidDataException class with serialized data.

protected AsposeInvalidDataException(
SerializationInfo info,
StreamingContext context
);

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception Type | Condition
ArgumentNullException | The info parameter is null.
SerializationException | The class name is null or HResult is zero (0).

See Also

AsposeInvalidDataException Class | Aspose.Email Namespace | AsposeInvalidDataException Constructor Overload List


AsposeInvalidDataException Constructor (Exception)

Initializes a new instance of the AsposeInvalidDataException class with a reference to the inner exception that is the cause of this exception.

public AsposeInvalidDataException(
Exception innerException
);

Parameters

innerException
The exception that is the cause of the current exception, or a null reference (Nothing in Visual Basic) if no inner exception is specified.

See Also

AsposeInvalidDataException Class | Aspose.Email Namespace | AsposeInvalidDataException Constructor Overload List


BuildVersionInfo Class

Provides information about the current product name and version.

For a list of all members of this type, see BuildVersionInfo Members.

System.Object
Aspose.Email.BuildVersionInfo

public sealed class BuildVersionInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

BuildVersionInfo Members | Aspose.Email Namespace


BuildVersionInfo Members

BuildVersionInfo overview

Public Static Fields

AssemblyVersion | Gets the version number of the assembly.
FileVersion | Gets the file version number.
Product | Gets the product name.
ProductMajor | Gets the product major version.
ProductMinor | Gets the the product minor version.
ReleaseDate | Gets the date of release.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

BuildVersionInfo Class | Aspose.Email Namespace


BuildVersionInfo Fields

The fields of the BuildVersionInfo class are listed below. For a complete list of BuildVersionInfo class members, see the BuildVersionInfo Members topic.

Public Static Fields

AssemblyVersion | Gets the version number of the assembly.
FileVersion | Gets the file version number.
Product | Gets the product name.
ProductMajor | Gets the product major version.
ProductMinor | Gets the the product minor version.
ReleaseDate | Gets the date of release.

See Also

BuildVersionInfo Class | Aspose.Email Namespace


BuildVersionInfo.AssemblyVersion Field

Gets the version number of the assembly.

public static readonly string AssemblyVersion;

See Also

BuildVersionInfo Class | Aspose.Email Namespace


BuildVersionInfo.FileVersion Field

Gets the file version number.

public static readonly string FileVersion;

See Also

BuildVersionInfo Class | Aspose.Email Namespace


BuildVersionInfo.Product Field

Gets the product name.

public static readonly string Product;

See Also

BuildVersionInfo Class | Aspose.Email Namespace


BuildVersionInfo.ProductMajor Field

Gets the product major version.

public static readonly int ProductMajor;

See Also

BuildVersionInfo Class | Aspose.Email Namespace


BuildVersionInfo.ProductMinor Field

Gets the the product minor version.

public static readonly int ProductMinor;

See Also

BuildVersionInfo Class | Aspose.Email Namespace


BuildVersionInfo.ReleaseDate Field

Gets the date of release.

public static readonly DateTime ReleaseDate;

See Also

BuildVersionInfo Class | Aspose.Email Namespace


ComparisonField Class

Base class that represents one search field.

For a list of all members of this type, see ComparisonField Members.

System.Object
Aspose.Email.QueryField
Aspose.Email.ComparisonField
Aspose.Email.DateComparisonField
Aspose.Email.IntComparisonField
Aspose.Email.StringComparisonField

public abstract class ComparisonField : QueryField

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ComparisonField Members | Aspose.Email Namespace


ComparisonField Members

ComparisonField overview

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

ComparisonField Constructor

Protected Instance Fields

FieldName (inherited from QueryField)
owner (inherited from QueryField)

Protected Instance Methods

CreateKey |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ComparisonField Class | Aspose.Email Namespace


ComparisonField Constructor

protected ComparisonField(
string fieldName,
MailQueryBuilder owner
);

See Also

ComparisonField Class | Aspose.Email Namespace


ComparisonField Methods

The methods of the ComparisonField class are listed below. For a complete list of ComparisonField class members, see the ComparisonField Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CreateKey |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ComparisonField Class | Aspose.Email Namespace


ComparisonField.CreateKey Method

protected MailQuery CreateKey(
string name,
string value,
string comparsionOperator
);

See Also

ComparisonField Class | Aspose.Email Namespace


ConnectionState Enumeration

Describes the current state of the connection.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum ConnectionState

Members

Member Name | Description | Value
Closed | The connection is closed. | 0
Open | The connection is open. | 1
Connecting | The connection object is connecting. | 2
Executing | The connection object is executing a command. | 4
Fetching | The connection object is retrieving data. | 8
Broken | The connection is broken. | 16

Requirements

Namespace: Aspose.Email

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email Namespace


CredentialsByHostClient Class

Represents the client that creates server connection by using the host credentials.

For a list of all members of this type, see CredentialsByHostClient Members.

System.Object
Aspose.Email.CredentialsByHostClient
Aspose.Email.Imap.ImapClient
Aspose.Email.Mail.SmtpClient
Aspose.Email.Pop3.Pop3Client

public abstract class CredentialsByHostClient : IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CredentialsByHostClient Members | Aspose.Email Namespace


CredentialsByHostClient Members

CredentialsByHostClient overview

Public Instance Properties

AccessToken | Gets or sets the access token.
ConnectionCheckupPeriod | Period of connection checking up in milliseconds. Default value is 5 min.
EnableSsl | Set to true if we need SSL
Host | Gets or sets the host name.
Password | Gets or sets the password.
Port | Gets or sets the port.
SocksProxy | Gets or sets SOCKS proxy for the client
Timeout | Gets or sets the timeout
TokenProvider | Gets or sets TokenProvider allowing to retrieve access token.
UseAuthentication | Indicates whether authentication is used.
UseDefaultCredentials | Gets or sets a Boolean value that controls whether the DefaultCredentials are sent with requests.
Username | Gets or sets the username.

Public Instance Methods

Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCapabilities |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnConnect The OnConnect event occurs when the clent establishes connection.

Protected Instance Constructors

CredentialsByHostClient Overloaded. Initializes a new instance of the CredentialsByHostClient class.

Protected Instance Methods

Dispose | Overloaded. Releases unmanaged and - optionally - managed resources
Finalize |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

_accessToken
_inCall
_password
_tokenProvider
_username

Protected Internal Instance Properties

InCall

Protected Internal Instance Methods

CheckCredentials
Initialize

See Also

CredentialsByHostClient Class | Aspose.Email Namespace


CredentialsByHostClient Constructor

Initializes a new instance of the CredentialsByHostClient class.

Overload List

Initializes a new instance of the CredentialsByHostClient class.

protected CredentialsByHostClient();

protected CredentialsByHostClient(string);

protected CredentialsByHostClient(string,int);

protected CredentialsByHostClient(string,int,string,ITokenProvider);

protected CredentialsByHostClient(string,int,string,string);

protected CredentialsByHostClient(string,int,string,string,bool);

protected CredentialsByHostClient(string,string,ITokenProvider);

protected CredentialsByHostClient(string,string,string);

protected CredentialsByHostClient(string,string,string,bool);

See Also

CredentialsByHostClient Class | Aspose.Email Namespace


CredentialsByHostClient Constructor ()

Initializes a new instance of the CredentialsByHostClient class.

protected CredentialsByHostClient();

See Also

CredentialsByHostClient Class | Aspose.Email Namespace | CredentialsByHostClient Constructor Overload List


CredentialsByHostClient Constructor (String)

protected CredentialsByHostClient(
string host
);

See Also

CredentialsByHostClient Class | Aspose.Email Namespace | CredentialsByHostClient Constructor Overload List


CredentialsByHostClient Constructor (String, Int32)

protected CredentialsByHostClient(
string host,
int port
);

See Also

CredentialsByHostClient Class | Aspose.Email Namespace | CredentialsByHostClient Constructor Overload List


CredentialsByHostClient Constructor (String, String, String)

protected CredentialsByHostClient(
string host,
string username,
string password
);

See Also

CredentialsByHostClient Class | Aspose.Email Namespace | CredentialsByHostClient Constructor Overload List


CredentialsByHostClient Constructor (String, Int32, String, String)

protected CredentialsByHostClient(
string host,
int port,
string username,
string password
);

See Also

CredentialsByHostClient Class | Aspose.Email Namespace | CredentialsByHostClient Constructor Overload List


CredentialsByHostClient Constructor (String, String, String, Boolean)

protected CredentialsByHostClient(
string host,
string username,
string authInfo,
bool useOAuth
);

See Also

CredentialsByHostClient Class | Aspose.Email Namespace | CredentialsByHostClient Constructor Overload List


CredentialsByHostClient Constructor (String, Int32, String, String, Boolean)

protected CredentialsByHostClient(
string host,
int port,
string username,
string authInfo,
bool useOAuth
);

See Also

CredentialsByHostClient Class | Aspose.Email Namespace | CredentialsByHostClient Constructor Overload List


CredentialsByHostClient Constructor (String, String, ITokenProvider)

protected CredentialsByHostClient(
string host,
string username,
ITokenProvider tokenProvider
);

See Also

CredentialsByHostClient Class | Aspose.Email Namespace | CredentialsByHostClient Constructor Overload List


CredentialsByHostClient Constructor (String, Int32, String, ITokenProvider)

protected CredentialsByHostClient(
string host,
int port,
string username,
ITokenProvider tokenProvider
);

See Also

CredentialsByHostClient Class | Aspose.Email Namespace | CredentialsByHostClient Constructor Overload List


CredentialsByHostClient Fields

The fields of the CredentialsByHostClient class are listed below. For a complete list of CredentialsByHostClient class members, see the CredentialsByHostClient Members topic.

Protected Internal Instance Fields

_accessToken
_inCall
_password
_tokenProvider
_username

See Also

CredentialsByHostClient Class | Aspose.Email Namespace


CredentialsByHostClient._accessToken Field

protected internal string _accessToken;

See Also

CredentialsByHostClient Class | Aspose.Email Namespace


CredentialsByHostClient._inCall Field

protected internal bool _inCall;

See Also

CredentialsByHostClient Class | Aspose.Email Namespace


CredentialsByHostClient._password Field

protected internal string _password;

See Also

CredentialsByHostClient Class | Aspose.Email Namespace


CredentialsByHostClient._tokenProvider Field

protected internal ITokenProvider _tokenProvider;

See Also

CredentialsByHostClient Class | Aspose.Email Namespace


CredentialsByHostClient._username Field

protected internal string _username;

See Also

CredentialsByHostClient Class | Aspose.Email Namespace


CredentialsByHostClient Properties

The properties of the CredentialsByHostClient class are listed below. For a complete list of CredentialsByHostClient class members, see the CredentialsByHostClient Members topic.

Public Instance Properties

AccessToken | Gets or sets the access token.
ConnectionCheckupPeriod | Period of connection checking up in milliseconds. Default value is 5 min.
EnableSsl | Set to true if we need SSL
Host | Gets or sets the host name.
Password | Gets or sets the password.
Port | Gets or sets the port.
SocksProxy | Gets or sets SOCKS proxy for the client
Timeout | Gets or sets the timeout
TokenProvider | Gets or sets TokenProvider allowing to retrieve access token.
UseAuthentication | Indicates whether authentication is used.
UseDefaultCredentials | Gets or sets a Boolean value that controls whether the DefaultCredentials are sent with requests.
Username | Gets or sets the username.

Protected Internal Instance Properties

InCall

See Also

CredentialsByHostClient Class | Aspose.Email Namespace


AccessToken Property

Aspose.Email

CredentialsByHostClient.AccessToken Property

Gets or sets the access token.

public virtual string AccessToken {get; set;}

Property Value

The string that represents access token.

See Also

CredentialsByHostClient Class | Aspose.Email Namespace


ConnectionCheckupPeriod Property

Aspose.Email

CredentialsByHostClient.ConnectionCheckupPeriod Property

Period of connection checking up in milliseconds. Default value is 5 min.

public virtual int ConnectionCheckupPeriod {get; set;}

See Also

CredentialsByHostClient Class | Aspose.Email Namespace


EnableSsl Property

Aspose.Email

CredentialsByHostClient.EnableSsl Property

Set to true if we need SSL

public virtual bool EnableSsl {get; set;}

See Also

CredentialsByHostClient Class | Aspose.Email Namespace


Host Property

Aspose.Email

CredentialsByHostClient.Host Property

Gets or sets the host name.

public virtual string Host {get; set;}

Property Value

The host name.

See Also

CredentialsByHostClient Class | Aspose.Email Namespace


InCall Property

Aspose.Email

CredentialsByHostClient.InCall Property

protected internal virtual bool InCall {get; set;}

See Also

CredentialsByHostClient Class | Aspose.Email Namespace


Password Property

Aspose.Email

CredentialsByHostClient.Password Property

Gets or sets the password.

public virtual string Password {get; set;}

Property Value

The string that represents the password.

See Also

CredentialsByHostClient Class | Aspose.Email Namespace


Port Property

Aspose.Email

CredentialsByHostClient.Port Property

Gets or sets the port.

public virtual int Port {get; set;}

Property Value

The port number.

See Also

CredentialsByHostClient Class | Aspose.Email Namespace


SocksProxy Property

Aspose.Email

CredentialsByHostClient.SocksProxy Property

Gets or sets SOCKS proxy for the client

public virtual SocksProxy SocksProxy {get; set;}

See Also

CredentialsByHostClient Class | Aspose.Email Namespace


Timeout Property

Aspose.Email

CredentialsByHostClient.Timeout Property

Gets or sets the timeout

public int Timeout {get; set;}

Property Value

The timeout in milliseconds

See Also

CredentialsByHostClient Class | Aspose.Email Namespace


TokenProvider Property

Aspose.Email

CredentialsByHostClient.TokenProvider Property

Gets or sets TokenProvider allowing to retrieve access token.

public ITokenProvider TokenProvider {get; set;}

See Also

CredentialsByHostClient Class | Aspose.Email Namespace


UseAuthentication Property

Aspose.Email

CredentialsByHostClient.UseAuthentication Property

Indicates whether authentication is used.

public virtual bool UseAuthentication {get; set;}

See Also

CredentialsByHostClient Class | Aspose.Email Namespace


UseDefaultCredentials Property

Aspose.Email

CredentialsByHostClient.UseDefaultCredentials Property

Gets or sets a Boolean value that controls whether the DefaultCredentials are sent with requests.

public virtual bool UseDefaultCredentials {get; set;}

See Also

CredentialsByHostClient Class | Aspose.Email Namespace


Username Property

Aspose.Email

CredentialsByHostClient.Username Property

Gets or sets the username.

public virtual string Username {get; set;}

Property Value

The username string.

See Also

CredentialsByHostClient Class | Aspose.Email Namespace


CredentialsByHostClient Methods

The methods of the CredentialsByHostClient class are listed below. For a complete list of CredentialsByHostClient class members, see the CredentialsByHostClient Members topic.

Public Instance Methods

Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCapabilities |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Dispose | Overloaded. Releases unmanaged and - optionally - managed resources
Finalize |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

CheckCredentials
Initialize

See Also

CredentialsByHostClient Class | Aspose.Email Namespace


CredentialsByHostClient.CheckCredentials Method

protected internal virtual void CheckCredentials();

See Also

CredentialsByHostClient Class | Aspose.Email Namespace


Dispose Method

Aspose.Email

CredentialsByHostClient.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Overload List

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

public void Dispose();

Releases unmanaged and - optionally - managed resources

protected virtual void Dispose(bool);

See Also

CredentialsByHostClient Class | Aspose.Email Namespace


CredentialsByHostClient.Dispose Method ()

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

public void Dispose();

Implements

IDisposable.Dispose

See Also

CredentialsByHostClient Class | Aspose.Email Namespace | CredentialsByHostClient.Dispose Overload List


CredentialsByHostClient.Dispose Method (Boolean)

Releases unmanaged and - optionally - managed resources

protected virtual void Dispose(
bool disposing
);

Parameters

disposing
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

CredentialsByHostClient Class | Aspose.Email Namespace | CredentialsByHostClient.Dispose Overload List


CredentialsByHostClient.Finalize Method

protected override void Finalize();

See Also

CredentialsByHostClient Class | Aspose.Email Namespace


CredentialsByHostClient.GetCapabilities Method

public virtual string[] GetCapabilities();

See Also

CredentialsByHostClient Class | Aspose.Email Namespace


CredentialsByHostClient.Initialize Method

protected internal virtual void Initialize();

See Also

CredentialsByHostClient Class | Aspose.Email Namespace


CredentialsByHostClient Events

The events of the CredentialsByHostClient class are listed below. For a complete list of CredentialsByHostClient class members, see the CredentialsByHostClient Members topic.

Public Instance Events

OnConnect The OnConnect event occurs when the clent establishes connection.

See Also

CredentialsByHostClient Class | Aspose.Email Namespace


CredentialsByHostClient.OnConnect Event

The OnConnect event occurs when the clent establishes connection.

public event EventHandler OnConnect;

See Also

CredentialsByHostClient Class | Aspose.Email Namespace


DateComparisonField Class

Represents the date search field.

For a list of all members of this type, see DateComparisonField Members.

System.Object
Aspose.Email.QueryField
Aspose.Email.ComparisonField
Aspose.Email.DateComparisonField

public sealed class DateComparisonField : ComparisonField

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DateComparisonField Members | Aspose.Email Namespace


DateComparisonField Members

DateComparisonField overview

Public Instance Methods

Before | Indicates that the date in message must be earlier than the specified date.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
NotOn | Indicates that the date in message must not be in the specified date.
On | Indicates that the date in message must be within the specified date.
Since | Indicates that date in message must be within or later than the specified date.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DateComparisonField Class | Aspose.Email Namespace


DateComparisonField Methods

The methods of the DateComparisonField class are listed below. For a complete list of DateComparisonField class members, see the DateComparisonField Members topic.

Public Instance Methods

Before | Indicates that the date in message must be earlier than the specified date.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
NotOn | Indicates that the date in message must not be in the specified date.
On | Indicates that the date in message must be within the specified date.
Since | Indicates that date in message must be within or later than the specified date.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DateComparisonField Class | Aspose.Email Namespace


DateComparisonField.Before Method

Indicates that the date in message must be earlier than the specified date.

public MailQuery Before(
DateTime value
);

Parameters

value
The value.

Return Value

MailQuery that represents search query (one searching criterion).

See Also

DateComparisonField Class | Aspose.Email Namespace


DateComparisonField.NotOn Method

Indicates that the date in message must not be in the specified date.

public MailQuery NotOn(
DateTime value
);

Parameters

value
The value.

Return Value

MailQuery that represents search query (one searching criterion).

See Also

DateComparisonField Class | Aspose.Email Namespace


DateComparisonField.On Method

Indicates that the date in message must be within the specified date.

public MailQuery On(
DateTime value
);

Parameters

value
The value.

Return Value

MailQuery that represents search query (one searching criterion).

See Also

DateComparisonField Class | Aspose.Email Namespace


DateComparisonField.Since Method

Indicates that date in message must be within or later than the specified date.

public MailQuery Since(
DateTime value
);

Parameters

value
The value.

Return Value

MailQuery that represents search query (one searching criterion).

See Also

DateComparisonField Class | Aspose.Email Namespace


FileCorruptedException Class

Exception that is thrown during file reading, when the file appears to be corrupted and impossible to read.

For a list of all members of this type, see FileCorruptedException Members.

System.Object
System.Exception
Aspose.Email.AsposeException
Aspose.Email.FileCorruptedException

public class FileCorruptedException : AsposeException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FileCorruptedException Members | Aspose.Email Namespace


FileCorruptedException Members

FileCorruptedException overview

Public Instance Constructors

FileCorruptedException Overloaded. Initializes a new instance of the FileCorruptedException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from AsposeException) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from AsposeException) | Returns a string that represents the current object.

Protected Instance Constructors

FileCorruptedException Overloaded. Initializes a new instance of the FileCorruptedException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

_message (inherited from AsposeException)
Exception_EndOfInnerExceptionStack (inherited from AsposeException)

See Also

FileCorruptedException Class | Aspose.Email Namespace


FileCorruptedException Constructor

Initializes a new instance of the FileCorruptedException class.

Overload List

Initializes a new instance of the FileCorruptedException class.

public FileCorruptedException();

Initializes a new instance of the FileCorruptedException class with a serialized data.

protected FileCorruptedException(SerializationInfo,StreamingContext);

Initializes a new instance of the FileCorruptedException class with a specified error message.

public FileCorruptedException(string);

Initializes a new instance of the FileCorruptedException class with a specified error message.

public FileCorruptedException(string,Exception);

See Also

FileCorruptedException Class | Aspose.Email Namespace


FileCorruptedException Constructor ()

Initializes a new instance of the FileCorruptedException class.

public FileCorruptedException();

See Also

FileCorruptedException Class | Aspose.Email Namespace | FileCorruptedException Constructor Overload List


FileCorruptedException Constructor (String)

Initializes a new instance of the FileCorruptedException class with a specified error message.

public FileCorruptedException(
string message
);

Parameters

message
A message that describes the error.

See Also

FileCorruptedException Class | Aspose.Email Namespace | FileCorruptedException Constructor Overload List


FileCorruptedException Constructor (String, Exception)

Initializes a new instance of the FileCorruptedException class with a specified error message.

public FileCorruptedException(
string message,
Exception inner
);

Parameters

message
A message that describes the error.
inner
The exception causing the current exception.

See Also

FileCorruptedException Class | Aspose.Email Namespace | FileCorruptedException Constructor Overload List


FileCorruptedException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the FileCorruptedException class with a serialized data.

protected FileCorruptedException(
SerializationInfo info,
StreamingContext context
);

Parameters

info
The SerializationInfo that hold data about exception being thrown.
context
The StreamingContext that contains information about the source or destination.

See Also

FileCorruptedException Class | Aspose.Email Namespace | FileCorruptedException Constructor Overload List


FormatNotSupportedException Class

Exception that is thrown during document load, when the document format is not recognized or not supported by the component.

For a list of all members of this type, see FormatNotSupportedException Members.

System.Object
System.Exception
Aspose.Email.AsposeException
Aspose.Email.FormatNotSupportedException

public class FormatNotSupportedException : AsposeException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FormatNotSupportedException Members | Aspose.Email Namespace


FormatNotSupportedException Members

FormatNotSupportedException overview

Public Instance Constructors

FormatNotSupportedException Overloaded. Initializes a new instance of the FormatNotSupportedException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from AsposeException) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from AsposeException) | Returns a string that represents the current object.

Protected Instance Constructors

FormatNotSupportedException Overloaded. Initializes a new instance of the FormatNotSupportedException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

_message (inherited from AsposeException)
Exception_EndOfInnerExceptionStack (inherited from AsposeException)

See Also

FormatNotSupportedException Class | Aspose.Email Namespace


FormatNotSupportedException Constructor

Initializes a new instance of the FormatNotSupportedException class.

Overload List

Initializes a new instance of the FormatNotSupportedException class.

public FormatNotSupportedException();

Initializes a new instance of the FormatNotSupportedException class with a serialized data.

protected FormatNotSupportedException(SerializationInfo,StreamingContext);

Initializes a new instance of the FormatNotSupportedException class with a specified error message.

public FormatNotSupportedException(string);

Initializes a new instance of the FormatNotSupportedException class with a specified error message.

public FormatNotSupportedException(string,Exception);

See Also

FormatNotSupportedException Class | Aspose.Email Namespace


FormatNotSupportedException Constructor ()

Initializes a new instance of the FormatNotSupportedException class.

public FormatNotSupportedException();

See Also

FormatNotSupportedException Class | Aspose.Email Namespace | FormatNotSupportedException Constructor Overload List


FormatNotSupportedException Constructor (String)

Initializes a new instance of the FormatNotSupportedException class with a specified error message.

public FormatNotSupportedException(
string message
);

Parameters

message
A message that describes the error.

See Also

FormatNotSupportedException Class | Aspose.Email Namespace | FormatNotSupportedException Constructor Overload List


FormatNotSupportedException Constructor (String, Exception)

Initializes a new instance of the FormatNotSupportedException class with a specified error message.

public FormatNotSupportedException(
string message,
Exception inner
);

Parameters

message
A message that describes the error.
inner
The exception causing the current exception.

See Also

FormatNotSupportedException Class | Aspose.Email Namespace | FormatNotSupportedException Constructor Overload List


FormatNotSupportedException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the FormatNotSupportedException class with a serialized data.

protected FormatNotSupportedException(
SerializationInfo info,
StreamingContext context
);

Parameters

info
The SerializationInfo that hold data about exception being thrown.
context
The StreamingContext that contains information about the source or destination.

See Also

FormatNotSupportedException Class | Aspose.Email Namespace | FormatNotSupportedException Constructor Overload List


GoogleClientException Class

Represents errors that occur during ActiveSync protocol execution.

For a list of all members of this type, see GoogleClientException Members.

System.Object
System.Exception
Aspose.Email.AsposeException
Aspose.Email.GoogleClientException

public class GoogleClientException : AsposeException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GoogleClientException Members | Aspose.Email Namespace


GoogleClientException Members

GoogleClientException overview

Public Instance Constructors

GoogleClientException Overloaded. Initializes a new instance of the GoogleClientException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorCode | Returns a code of error.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from AsposeException) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from AsposeException) | Returns a string that represents the current object.

Protected Instance Constructors

GoogleClientException Overloaded. Initializes a new instance of the GoogleClientException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

Exception_EndOfInnerExceptionStack (inherited from AsposeException)

See Also

GoogleClientException Class | Aspose.Email Namespace


GoogleClientException Constructor

Initializes a new instance of the GoogleClientException class with a specified error message.

Overload List

Initializes a new instance of the GoogleClientException class.

public GoogleClientException();

Initializes a new instance of the GoogleClientException class with a reference to the inner exception that is the cause of this exception.

public GoogleClientException(Exception);

Initializes a new instance of the GoogleClientException class with serialized data.

protected GoogleClientException(SerializationInfo,StreamingContext);

Initializes a new instance of the GoogleClientException class with a specified error message.

public GoogleClientException(string);

Initializes a new instance of the GoogleClientException class with a specified error message and a reference to the inner exception that is the cause of this exception.

public GoogleClientException(string,Exception);

See Also

GoogleClientException Class | Aspose.Email Namespace


GoogleClientException Constructor (String)

Initializes a new instance of the GoogleClientException class with a specified error message.

public GoogleClientException(
string message
);

Parameters

message
A message that describes the error.

See Also

GoogleClientException Class | Aspose.Email Namespace | GoogleClientException Constructor Overload List


GoogleClientException Constructor ()

Initializes a new instance of the GoogleClientException class.

public GoogleClientException();

See Also

GoogleClientException Class | Aspose.Email Namespace | GoogleClientException Constructor Overload List


GoogleClientException Constructor (String, Exception)

Initializes a new instance of the GoogleClientException class with a specified error message and a reference to the inner exception that is the cause of this exception.

public GoogleClientException(
string message,
Exception innerException
);

Parameters

message
The error message that explains the reason for the exception.
innerException
The exception that is the cause of the current exception, or a null reference (Nothing in Visual Basic) if no inner exception is specified.

See Also

GoogleClientException Class | Aspose.Email Namespace | GoogleClientException Constructor Overload List


GoogleClientException Constructor (Exception)

Initializes a new instance of the GoogleClientException class with a reference to the inner exception that is the cause of this exception.

public GoogleClientException(
Exception innerException
);

Parameters

innerException
The exception that is the cause of the current exception, or a null reference (Nothing in Visual Basic) if no inner exception is specified.

See Also

GoogleClientException Class | Aspose.Email Namespace | GoogleClientException Constructor Overload List


GoogleClientException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the GoogleClientException class with serialized data.

protected GoogleClientException(
SerializationInfo info,
StreamingContext context
);

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception Type | Condition
ArgumentNullException | The info parameter is null.
SerializationException | The class name is null or HResult is zero (0).

See Also

GoogleClientException Class | Aspose.Email Namespace | GoogleClientException Constructor Overload List


GoogleClientException Properties

The properties of the GoogleClientException class are listed below. For a complete list of GoogleClientException class members, see the GoogleClientException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
ErrorCode | Returns a code of error.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from AsposeException) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

GoogleClientException Class | Aspose.Email Namespace


ErrorCode Property

Aspose.Email

GoogleClientException.ErrorCode Property

Returns a code of error.

public int ErrorCode {get;}

See Also

GoogleClientException Class | Aspose.Email Namespace


IntComparisonField Class

Represents the integer search field.

For a list of all members of this type, see IntComparisonField Members.

System.Object
Aspose.Email.QueryField
Aspose.Email.ComparisonField
Aspose.Email.IntComparisonField

public sealed class IntComparisonField : ComparisonField

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

IntComparisonField Members | Aspose.Email Namespace


IntComparisonField Members

IntComparisonField overview

Public Instance Methods

Equals | Overloaded. Indicates that field must be equal to the specified value.
Equals (inherited from Object) | Overloaded. Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Greater | Indicates that field must be greater than the specified value.
GreaterOrEqual | Indicates that field must be greater or equal to the specified value.
Less | Indicates that field must be less than the specified value.
LessOrEqual | Indicates that field must be less or equal to the specified value.
NotEquals | Indicates that field must not be equal to the specified value.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

IntComparisonField Class | Aspose.Email Namespace


IntComparisonField Methods

The methods of the IntComparisonField class are listed below. For a complete list of IntComparisonField class members, see the IntComparisonField Members topic.

Public Instance Methods

Equals | Overloaded. Indicates that field must be equal to the specified value.
Equals (inherited from Object) | Overloaded. Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Greater | Indicates that field must be greater than the specified value.
GreaterOrEqual | Indicates that field must be greater or equal to the specified value.
Less | Indicates that field must be less than the specified value.
LessOrEqual | Indicates that field must be less or equal to the specified value.
NotEquals | Indicates that field must not be equal to the specified value.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

IntComparisonField Class | Aspose.Email Namespace


Equals Method

Aspose.Email

IntComparisonField.Equals Method

Indicates that field must be equal to the specified value.

Overload List

Indicates that field must be equal to the specified value.

public MailQuery Equals(int);

Inherited from Object.

public virtual bool Equals(object);

See Also

IntComparisonField Class | Aspose.Email Namespace


IntComparisonField.Equals Method (Int32)

Indicates that field must be equal to the specified value.

public MailQuery Equals(
int value
);

Parameters

value
The value.

Return Value

MailQuery that represents search query (one searching criterion).

See Also

IntComparisonField Class | Aspose.Email Namespace | IntComparisonField.Equals Overload List


IntComparisonField.Greater Method

Indicates that field must be greater than the specified value.

public MailQuery Greater(
int value
);

Parameters

value
The value.

Return Value

MailQuery that represents search query (one searching criterion).

See Also

IntComparisonField Class | Aspose.Email Namespace


IntComparisonField.GreaterOrEqual Method

Indicates that field must be greater or equal to the specified value.

public MailQuery GreaterOrEqual(
int value
);

Parameters

value
The value.

Return Value

MailQuery that represents search query (one searching criterion).

See Also

IntComparisonField Class | Aspose.Email Namespace


IntComparisonField.Less Method

Indicates that field must be less than the specified value.

public MailQuery Less(
int value
);

Parameters

value
The value.

Return Value

MailQuery that represents search query (one searching criterion).

See Also

IntComparisonField Class | Aspose.Email Namespace


IntComparisonField.LessOrEqual Method

Indicates that field must be less or equal to the specified value.

public MailQuery LessOrEqual(
int value
);

Parameters

value
The value.

Return Value

MailQuery that represents search query (one searching criterion).

See Also

IntComparisonField Class | Aspose.Email Namespace


IntComparisonField.NotEquals Method

Indicates that field must not be equal to the specified value.

public MailQuery NotEquals(
int value
);

Parameters

value
The value.

Return Value

MailQuery that represents search query (one searching criterion).

See Also

IntComparisonField Class | Aspose.Email Namespace


License Class

Provides methods to license the component.

For a list of all members of this type, see License Members.

System.Object
Aspose.Email.License

public class License

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

In this example, an attempt will be made to find a license file named MyLicense.lic in the folder that contains the component, in the folder that contains the calling assembly, in the folder of the entry assembly and then in the embedded resources of the calling assembly.

[C#]

License license = new License();
license.SetLicense("MyLicense.lic");

[Visual Basic]

Dim license As license = New license
License.SetLicense("MyLicense.lic")

Requirements

Namespace: Aspose.Email

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

License Members | Aspose.Email Namespace


License Members

License overview

Public Instance Constructors

License Constructor Initializes a new instance of this class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetLicense | Overloaded. Licenses the component.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

License Class | Aspose.Email Namespace


License Constructor

Initializes a new instance of this class.

public License();

Example

In this example, an attempt will be made to find a license file named MyLicense.lic in the folder that contains the component, in the folder that contains the calling assembly, in the folder of the entry assembly and then in the embedded resources of the calling assembly.

[C#]

License license = new License();
license.SetLicense("MyLicense.lic");

[Visual Basic]

Dim license As license = New license
License.SetLicense("MyLicense.lic")

See Also

License Class | Aspose.Email Namespace


License Methods

The methods of the License class are listed below. For a complete list of License class members, see the License Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetLicense | Overloaded. Licenses the component.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

License Class | Aspose.Email Namespace


SetLicense Method

Aspose.Email

License.SetLicense Method

Licenses the component.

Overload List

Licenses the component.

public void SetLicense(FileInfo);

Licenses the component.

public void SetLicense(Stream);

Licenses the component.

public void SetLicense(string);

See Also

License Class | Aspose.Email Namespace


License.SetLicense Method (FileInfo)

Licenses the component.

public void SetLicense(
FileInfo licenseFile
);

Parameters

licenseFile
File of licenseFileInfo.

Exceptions

Exception Type | Condition
ArgumentNullException | licenseFile is null.
FileNotFoundException | The file is not found.
UnauthorizedAccessException | The file is read-only or is a directory.
DirectoryNotFoundException | The specified path is invalid, such as being on an unmapped drive.
IOException | The file is already open.

See Also

License Class | Aspose.Email Namespace | License.SetLicense Overload List


License.SetLicense Method (Stream)

Licenses the component.

public void SetLicense(
Stream stream
);

Parameters

stream
A stream that contains the license.

Remarks

Use this method to load a license from a stream.

Example

[C#]

License license = new License();
license.SetLicense(myStream);

[Visual Basic]

Dim license as License = new License
license.SetLicense(myStream)

See Also

License Class | Aspose.Email Namespace | License.SetLicense Overload List


License.SetLicense Method (String)

Licenses the component.

public void SetLicense(
string licenseName
);

Remarks

Tries to find the license in the following locations:

1. Explicit path.

2. The folder of the component assembly.

3. The folder of the client's calling assembly.

4. The folder of the entry assembly.

5. An embedded resource in the client's calling assembly.

Note:On the .NET Compact Framework, tries to find the license only in these locations:

1. Explicit path.

2. An embedded resource in the client's calling assembly.

Example

In this example, an attempt will be made to find a license file named MyLicense.lic in the folder that contains the component, in the folder that contains the calling assembly, in the folder of the entry assembly and then in the embedded resources of the calling assembly.

[C#]

License license = new License();
license.SetLicense("MyLicense.lic");

[Visual Basic]

Dim license As License = New License
license.SetLicense("MyLicense.lic")
Can be a full or short file name or name of an embedded resource. Use an empty string to switch to evaluation mode.

See Also

License Class | Aspose.Email Namespace | License.SetLicense Overload List


MailQuery Class

Represents the search criteria, that are used to match several message properties in the mailbox.

For a list of all members of this type, see MailQuery Members.

System.Object
Aspose.Email.MailQuery

public sealed class MailQuery : 0, Culture=neutral, PublicKeyToken=null]], IXmlSerializable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MailQuery Members | Aspose.Email Namespace


MailQuery Members

MailQuery overview

Public Instance Constructors

MailQuery Constructor Initializes a new instance of the MailQuery class.

Public Instance Methods

Equals | Overloaded. Indicates whether the current object is equal to another object of the same type.
Equals (inherited from Object) | Overloaded. Determines whether the specified Object is equal to the current Object.
GetHashCode | Returns a hash code for this instance.
GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the XmlSchemaProviderAttribute to the class.
GetType (inherited from Object) | Gets the Type of the current instance.
ReadXml | Generates an object from its XML representation.
ToString | Returns a String that represents this instance.
WriteXml | Converts an object into its XML representation.

See Also

MailQuery Class | Aspose.Email Namespace


MailQuery Constructor

Initializes a new instance of the MailQuery class.

public MailQuery(
string queryString
);

Parameters

queryString
The query string.

Remarks

The query string should have the following view.

The example of a simple expression:

'<Field name>' <Comparison operator> '<Field value>',

where <Field Name> - the name of a message field through which filtering is made, <Comparison operator> - comparison operators, as their name implies, allow to compare message field and specified value, <Field value> - value to be compared with a message field.

The number of simple expressions can make a compound one, ex.: (<Simple expression 1> & <Simple expression 2>) | <Simple expression 3>,

where "&" - logical-AND operator, "|" - logical-OR operator

At present the following values are allowed as a field name (<Field name>):

"To" - represents a TO field of message, "Text" - represents string in the header or body of the message, "Bcc" - represents a BCC field of message, "Body" - represents a string in the body of message, "Cc" - represents a CC field of message, "From" - represents a From field of message, "Subject" - represents a string in the subject of message, "InternalDate" - represents an internal date of message, "SentDate" - represents a sent date of message

Additionally, the following field names are allowed for IMAP-protocol:

"Answered" - represents an /Answered flag of message "Seen" - represents a /Seen flag of message "Flagged" - represents a /Flagged flag of message "Draft" - represents a /Draft flag of message "Deleted" - represents a Deleted/ flag of message "Recent" - represents a Deleted/ flag of message "MessageSize" - represents a size (in bytes) of message

Additionally, the following field names are allowed for Exchange:

"IsRead" - Indicates whether the message has been read "HasAttachment" - Indicates whether or not the message has attachments "IsSubmitted" - Indicates whether the message has been submitted to the Outbox "ContentClass" - represents a content class of item

Additionally, the following field names are allowed for pst/ost files:

"MessageClass" - Represents a message class "ContainerClass" - Represents a folder container class "Importance" - Represents a message importance "MessageSize" - represents a size (in bytes) of message "FolderName" - represents a folder name "ContentsCount" - represents a total number of items in the folder "UnreadContentsCount" - represents the number of unread items in the folder. "Subfolders" - Indicates whether or not the folder has subfolders "Read" - the message is marked as having been read "HasAttachment" - the message has at least one attachment "Unsent" - the message is still being composed "Unmodified" - the message has not been modified since it was first saved (if unsent) or it was delivered (if sent) "FromMe" - the user receiving the message was also the user who sent the message "Resend" - the message includes a request for a resend operation with a non-delivery report "NotifyRead" - the user who sent the message has requested notification when a recipient first reads it "NotifyUnread" - the user who sent the message has requested notification when a recipient deletes it before reading or the Message object expires "EverRead" - the message has been read at least once

The field value (<Field value>) can take the following values: For text fields - any string, For date type fields - the string of "d-MMM-yyy" format, ex. "10-Feb-2009", For flags (fields of boolean type) - either "True", or "False"

Example

See Also
MailQuery Class | Aspose.Email Namespace


MailQuery Methods

The methods of the MailQuery class are listed below. For a complete list of MailQuery class members, see the MailQuery Members topic.

Public Instance Methods

Equals | Overloaded. Indicates whether the current object is equal to another object of the same type.
Equals (inherited from Object) | Overloaded. Determines whether the specified Object is equal to the current Object.
GetHashCode | Returns a hash code for this instance.
GetSchema | This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the XmlSchemaProviderAttribute to the class.
GetType (inherited from Object) | Gets the Type of the current instance.
ReadXml | Generates an object from its XML representation.
ToString | Returns a String that represents this instance.
WriteXml | Converts an object into its XML representation.

See Also

MailQuery Class | Aspose.Email Namespace


Equals Method

Aspose.Email

MailQuery.Equals Method

Indicates whether the current object is equal to another object of the same type.

Overload List

Indicates whether the current object is equal to another object of the same type.

public bool Equals(MailQuery);

Inherited from Object.

public virtual bool Equals(object);

See Also

MailQuery Class | Aspose.Email Namespace


MailQuery.Equals Method (MailQuery)

Indicates whether the current object is equal to another object of the same type.

public bool Equals(
MailQuery other
);

Parameters

other
An object to compare with this object.

Return Value

true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatable`1.Equals

See Also

MailQuery Class | Aspose.Email Namespace | MailQuery.Equals Overload List


MailQuery.GetHashCode Method

Returns a hash code for this instance.

public override int GetHashCode();

Return Value

A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.

See Also

MailQuery Class | Aspose.Email Namespace


MailQuery.GetSchema Method

This method is reserved and should not be used. When implementing the IXmlSerializable interface, you should return null (Nothing in Visual Basic) from this method, and instead, if specifying a custom schema is required, apply the XmlSchemaProviderAttribute to the class.

public XmlSchema GetSchema();

Return Value

An XmlSchema that describes the XML representation of the object that is produced by the WriteXml method and consumed by the ReadXml method.

Implements

IXmlSerializable.GetSchema

See Also

MailQuery Class | Aspose.Email Namespace


MailQuery.ReadXml Method

Generates an object from its XML representation.

public void ReadXml(
XmlReader reader
);

Parameters

reader
The XmlReader stream from which the object is deserialized.

Implements

IXmlSerializable.ReadXml

See Also

MailQuery Class | Aspose.Email Namespace


MailQuery.ToString Method

Returns a String that represents this instance.

public override string ToString();

Return Value

A query string that represents this instance.

See Also

MailQuery Class | Aspose.Email Namespace


MailQuery.WriteXml Method

Converts an object into its XML representation.

public void WriteXml(
XmlWriter writer
);

Parameters

writer
The XmlWriter stream to which the object is serialized.

Implements

IXmlSerializable.WriteXml

See Also

MailQuery Class | Aspose.Email Namespace


MailQueryBuilder Class

Represents the builder of search expression.

For a list of all members of this type, see MailQueryBuilder Members.

System.Object
Aspose.Email.MailQueryBuilder
Aspose.Email.Exchange.ExchangeQueryBuilder
Aspose.Email.Imap.ImapQueryBuilder
Aspose.Email.Outlook.Pst.PersonalStorageQueryBuilder

public class MailQueryBuilder

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Note: By default, the result is the intersection (AND function) of all the messages that match those keys. To join keys by OR function, please, use Or() method of this class

Requirements

Namespace: Aspose.Email

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MailQueryBuilder Members | Aspose.Email Namespace


MailQueryBuilder Members

MailQueryBuilder overview

Public Instance Constructors

MailQueryBuilder Constructor Initializes a new instance of the MailQueryBuilder class.

Public Instance Properties

Bcc | Gets the field that allows to find messages that contain the specified string in the envelope structure's BCC field.
Body | Gets the field that allows to find messages that contain the specified string in the body of the message.
Cc | Gets the field that allows to find messages that contain the specified string in the envelope structure's CC field.
From | Gets the field that allows to find messages that contain the specified string in the envelope structure's FROM field.
InternalDate | Gets the field that allows to find messages by internal date.
MessageId | Gets the field that allows to find messages that contain the specified string in the envelope structure's MessageId field.
SentDate | Gets the field that allows to find messages by sent date.
Subject | Gets the field that allows to find messages that contain the specified string in the envelope structure's SUBJECT field.
Text | Gets the field that allows to find the messages that contain the specified string in the header or body of the message.
To | Gets the field that allows to find messages that contain the specified string in the envelope structure's TO field.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetQuery | Gets the query.
GetType (inherited from Object) | Gets the Type of the current instance.
Or | Search messages that match either search key. Provides disjunction between two expressions (OR).
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MailQueryBuilder Class | Aspose.Email Namespace


MailQueryBuilder Constructor

Initializes a new instance of the MailQueryBuilder class.

public MailQueryBuilder();

See Also

MailQueryBuilder Class | Aspose.Email Namespace


MailQueryBuilder Properties

The properties of the MailQueryBuilder class are listed below. For a complete list of MailQueryBuilder class members, see the MailQueryBuilder Members topic.

Public Instance Properties

Bcc | Gets the field that allows to find messages that contain the specified string in the envelope structure's BCC field.
Body | Gets the field that allows to find messages that contain the specified string in the body of the message.
Cc | Gets the field that allows to find messages that contain the specified string in the envelope structure's CC field.
From | Gets the field that allows to find messages that contain the specified string in the envelope structure's FROM field.
InternalDate | Gets the field that allows to find messages by internal date.
MessageId | Gets the field that allows to find messages that contain the specified string in the envelope structure's MessageId field.
SentDate | Gets the field that allows to find messages by sent date.
Subject | Gets the field that allows to find messages that contain the specified string in the envelope structure's SUBJECT field.
Text | Gets the field that allows to find the messages that contain the specified string in the header or body of the message.
To | Gets the field that allows to find messages that contain the specified string in the envelope structure's TO field.

See Also

MailQueryBuilder Class | Aspose.Email Namespace


Bcc Property

Aspose.Email

MailQueryBuilder.Bcc Property

Gets the field that allows to find messages that contain the specified string in the envelope structure's BCC field.

public StringComparisonField Bcc {get;}

Property Value

The DateComparisonField that represents BCC search field.

See Also

MailQueryBuilder Class | Aspose.Email Namespace


Body Property

Aspose.Email

MailQueryBuilder.Body Property

Gets the field that allows to find messages that contain the specified string in the body of the message.

public StringComparisonField Body {get;}

Property Value

The DateComparisonField that represents body search field.

See Also

MailQueryBuilder Class | Aspose.Email Namespace


Cc Property

Aspose.Email

MailQueryBuilder.Cc Property

Gets the field that allows to find messages that contain the specified string in the envelope structure's CC field.

public StringComparisonField Cc {get;}

Property Value

The DateComparisonField that represents cc search field.

See Also

MailQueryBuilder Class | Aspose.Email Namespace


From Property

Aspose.Email

MailQueryBuilder.From Property

Gets the field that allows to find messages that contain the specified string in the envelope structure's FROM field.

public StringComparisonField From {get;}

Property Value

The DateComparisonField that represents from search field.

See Also

MailQueryBuilder Class | Aspose.Email Namespace


InternalDate Property

Aspose.Email

MailQueryBuilder.InternalDate Property

Gets the field that allows to find messages by internal date.

public DateComparisonField InternalDate {get;}

Property Value

The DateComparisonField that represents internal date search field.

See Also

MailQueryBuilder Class | Aspose.Email Namespace


MessageId Property

Aspose.Email

MailQueryBuilder.MessageId Property

Gets the field that allows to find messages that contain the specified string in the envelope structure's MessageId field.

public StringComparisonField MessageId {get;}

Property Value

The DateComparisonField that represents MessageId search field.

See Also

MailQueryBuilder Class | Aspose.Email Namespace


SentDate Property

Aspose.Email

MailQueryBuilder.SentDate Property

Gets the field that allows to find messages by sent date.

public DateComparisonField SentDate {get;}

Property Value

The DateComparisonField that represents sent date search field.

See Also

MailQueryBuilder Class | Aspose.Email Namespace


Subject Property

Aspose.Email

MailQueryBuilder.Subject Property

Gets the field that allows to find messages that contain the specified string in the envelope structure's SUBJECT field.

public StringComparisonField Subject {get;}

Property Value

The DateComparisonField that represents subject search field.

See Also

MailQueryBuilder Class | Aspose.Email Namespace


Text Property

Aspose.Email

MailQueryBuilder.Text Property

Gets the field that allows to find the messages that contain the specified string in the header or body of the message.

public StringComparisonField Text {get;}

Property Value

The DateComparisonField that represents text header or body search fields.

See Also

MailQueryBuilder Class | Aspose.Email Namespace


To Property

Aspose.Email

MailQueryBuilder.To Property

Gets the field that allows to find messages that contain the specified string in the envelope structure's TO field.

public StringComparisonField To {get;}

Property Value

The DateComparisonField that represents TO search field.

See Also

MailQueryBuilder Class | Aspose.Email Namespace


MailQueryBuilder Methods

The methods of the MailQueryBuilder class are listed below. For a complete list of MailQueryBuilder class members, see the MailQueryBuilder Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetQuery | Gets the query.
GetType (inherited from Object) | Gets the Type of the current instance.
Or | Search messages that match either search key. Provides disjunction between two expressions (OR).
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MailQueryBuilder Class | Aspose.Email Namespace


MailQueryBuilder.GetQuery Method

Gets the query.

public MailQuery GetQuery();

Return Value

MailQuery that represents search query.

See Also

MailQueryBuilder Class | Aspose.Email Namespace


MailQueryBuilder.Or Method

Search messages that match either search key. Provides disjunction between two expressions (OR).

public MailQuery Or(
MailQuery query1,
MailQuery query2
);

Parameters

query1
The query1.
query2
The query2.

Return Value

MailQuery that represents search query (one searching criterion).

See Also

MailQueryBuilder Class | Aspose.Email Namespace


NetworkException Class

Thrown if there is a network connection failure.

For a list of all members of this type, see NetworkException Members.

System.Object
System.Exception
Aspose.Email.NetworkException

public class NetworkException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

NetworkException Members | Aspose.Email Namespace


NetworkException Members

NetworkException overview

Public Instance Constructors

NetworkException Overloaded. Initializes a new instance of the NetworkException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

NetworkException Overloaded. Initializes a new instance of the NetworkException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NetworkException Class | Aspose.Email Namespace


NetworkException Constructor

Initializes a new instance of the NetworkException class.

Overload List

Initializes a new instance of the NetworkException class.

public NetworkException();

Initializes a new instance of the NetworkException class.

protected NetworkException(SerializationInfo,StreamingContext);

Initializes a new instance of the NetworkException class.

public NetworkException(string);

Initializes a new instance of the NetworkException class.

public NetworkException(string,Exception);

See Also

NetworkException Class | Aspose.Email Namespace


NetworkException Constructor ()

Initializes a new instance of the NetworkException class.

public NetworkException();

See Also

NetworkException Class | Aspose.Email Namespace | NetworkException Constructor Overload List


NetworkException Constructor (String)

Initializes a new instance of the NetworkException class.

public NetworkException(
string message
);

Parameters

message
The error message.

See Also

NetworkException Class | Aspose.Email Namespace | NetworkException Constructor Overload List


NetworkException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the NetworkException class.

protected NetworkException(
SerializationInfo info,
StreamingContext context
);

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception Type | Condition
ArgumentNullException | The info parameter is null.
SerializationException | The class name is null or HResult is zero (0).

See Also

NetworkException Class | Aspose.Email Namespace | NetworkException Constructor Overload List


NetworkException Constructor (String, Exception)

Initializes a new instance of the NetworkException class.

public NetworkException(
string message,
Exception inner
);

Parameters

message
The error message.
inner
The inner exception.

See Also

NetworkException Class | Aspose.Email Namespace | NetworkException Constructor Overload List


QueryField Class

Base class for query fields.

For a list of all members of this type, see QueryField Members.

System.Object
Aspose.Email.QueryField
Aspose.Email.ComparisonField
Aspose.Email.Imap.SequenceSetField

public abstract class QueryField

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

QueryField Members | Aspose.Email Namespace


QueryField Members

QueryField overview

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

QueryField Constructor

Protected Instance Fields

FieldName
owner

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

QueryField Class | Aspose.Email Namespace


QueryField Constructor

protected QueryField(
string fieldName,
MailQueryBuilder owner
);

See Also

QueryField Class | Aspose.Email Namespace


QueryField Fields

The fields of the QueryField class are listed below. For a complete list of QueryField class members, see the QueryField Members topic.

Protected Instance Fields

FieldName
owner

See Also

QueryField Class | Aspose.Email Namespace


QueryField.FieldName Field

protected readonly string FieldName;

See Also

QueryField Class | Aspose.Email Namespace


QueryField.owner Field

protected MailQueryBuilder owner;

See Also

QueryField Class | Aspose.Email Namespace


StringComparisonField Class

Represents the string search field.

For a list of all members of this type, see StringComparisonField Members.

System.Object
Aspose.Email.QueryField
Aspose.Email.ComparisonField
Aspose.Email.StringComparisonField

public sealed class StringComparisonField : ComparisonField

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

StringComparisonField Members | Aspose.Email Namespace


StringComparisonField Members

StringComparisonField overview

Public Instance Methods

Contains | Indicates that field in message must contain the specified value.
Empty | Indicates that field in message must be empty.
Equals | Overloaded. Indicates that field in message must be equal to the specified value.
Equals (inherited from Object) | Overloaded. Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
NotContains | Indicates that field in message must not contain the specified value.
NotEmpty | Indicates that field in message must not be empty.
NotEquals | Indicates that field in message must not be equal to the specified value.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

StringComparisonField Class | Aspose.Email Namespace


StringComparisonField Methods

The methods of the StringComparisonField class are listed below. For a complete list of StringComparisonField class members, see the StringComparisonField Members topic.

Public Instance Methods

Contains | Indicates that field in message must contain the specified value.
Empty | Indicates that field in message must be empty.
Equals | Overloaded. Indicates that field in message must be equal to the specified value.
Equals (inherited from Object) | Overloaded. Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
NotContains | Indicates that field in message must not contain the specified value.
NotEmpty | Indicates that field in message must not be empty.
NotEquals | Indicates that field in message must not be equal to the specified value.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

StringComparisonField Class | Aspose.Email Namespace


StringComparisonField.Contains Method

Indicates that field in message must contain the specified value.

public MailQuery Contains(
string value
);

Parameters

value
The value.

Return Value

MailQuery that represents search query (one searching criterion).

See Also

StringComparisonField Class | Aspose.Email Namespace


StringComparisonField.Empty Method

Indicates that field in message must be empty.

public MailQuery Empty();

Return Value

MailQuery that represents search query (one searching criterion).

See Also

StringComparisonField Class | Aspose.Email Namespace


Equals Method

Aspose.Email

StringComparisonField.Equals Method

Indicates that field in message must be equal to the specified value.

Overload List

Inherited from Object.

public virtual bool Equals(object);

Indicates that field in message must be equal to the specified value.

public MailQuery Equals(string);

See Also

StringComparisonField Class | Aspose.Email Namespace


StringComparisonField.Equals Method (String)

Indicates that field in message must be equal to the specified value.

public MailQuery Equals(
string value
);

Parameters

value
The value.

Return Value

MailQuery that represents search query (one searching criterion).

See Also

StringComparisonField Class | Aspose.Email Namespace | StringComparisonField.Equals Overload List


StringComparisonField.NotContains Method

Indicates that field in message must not contain the specified value.

public MailQuery NotContains(
string value
);

Parameters

value
The value.

Return Value

MailQuery that represents search query (one searching criterion).

See Also

StringComparisonField Class | Aspose.Email Namespace


StringComparisonField.NotEmpty Method

Indicates that field in message must not be empty.

public MailQuery NotEmpty();

Return Value

MailQuery that represents search query (one searching criterion).

See Also

StringComparisonField Class | Aspose.Email Namespace


StringComparisonField.NotEquals Method

Indicates that field in message must not be equal to the specified value.

public MailQuery NotEquals(
string value
);

Parameters

value
The value.

Return Value

MailQuery that represents search query (one searching criterion).

See Also

StringComparisonField Class | Aspose.Email Namespace


Aspose.Email.Common.Commands

Aspose.Email

Aspose.Email.Common.Commands Namespace

Namespace hierarchy

Classes

Class | Description
AsyncCommandResultEventArgs | AsyncCommandResultEventArgs is containing event data.
BaseAsyncCommand | Defines an asynchronous base command.
BaseCommand | Defines a base command.
CommandStatus | Indicates the result of an operation.

Interfaces

Interface | Description
IAsyncCommand | Defines an asynchronous command.
ICommand | Defines a command.

Enumerations

Enumeration | Description
AsyncCommandResults |


AsyncCommandResultEventArgs Class

AsyncCommandResultEventArgs is containing event data.

For a list of all members of this type, see AsyncCommandResultEventArgs Members.

System.Object
System.EventArgs
Aspose.Email.Common.Commands.AsyncCommandResultEventArgs

public class AsyncCommandResultEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Common.Commands

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AsyncCommandResultEventArgs Members | Aspose.Email.Common.Commands Namespace


AsyncCommandResultEventArgs Members

AsyncCommandResultEventArgs overview

Public Instance Constructors

AsyncCommandResultEventArgs Overloaded. Initializes a new instance of the AsyncCommandResultEventArgs class.

Public Instance Properties

Error | Operation error
Result | Operation state

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AsyncCommandResultEventArgs Class | Aspose.Email.Common.Commands Namespace


AsyncCommandResultEventArgs Constructor

Initializes a new instance of the AsyncCommandResultEventArgs class.

Overload List

Initializes a new instance of the AsyncCommandResultEventArgs class.

public AsyncCommandResultEventArgs();

Initializes a new instance of the AsyncCommandResultEventArgs class.

public AsyncCommandResultEventArgs(AsyncCommandResults);

Initializes a new instance of the AsyncCommandResultEventArgs class.

public AsyncCommandResultEventArgs(AsyncCommandResults,Exception);

See Also

AsyncCommandResultEventArgs Class | Aspose.Email.Common.Commands Namespace


AsyncCommandResultEventArgs Constructor ()

Initializes a new instance of the AsyncCommandResultEventArgs class.

public AsyncCommandResultEventArgs();

See Also

AsyncCommandResultEventArgs Class | Aspose.Email.Common.Commands Namespace | AsyncCommandResultEventArgs Constructor Overload List


AsyncCommandResultEventArgs Constructor (AsyncCommandResults)

Initializes a new instance of the AsyncCommandResultEventArgs class.

public AsyncCommandResultEventArgs(
AsyncCommandResults result
);

Parameters

result
Contains operation result

See Also

AsyncCommandResultEventArgs Class | Aspose.Email.Common.Commands Namespace | AsyncCommandResultEventArgs Constructor Overload List


AsyncCommandResultEventArgs Constructor (AsyncCommandResults, Exception)

Initializes a new instance of the AsyncCommandResultEventArgs class.

public AsyncCommandResultEventArgs(
AsyncCommandResults result,
Exception error
);

Parameters

result
Contains operation state
error
Contains operation error

See Also

AsyncCommandResultEventArgs Class | Aspose.Email.Common.Commands Namespace | AsyncCommandResultEventArgs Constructor Overload List


AsyncCommandResultEventArgs Properties

The properties of the AsyncCommandResultEventArgs class are listed below. For a complete list of AsyncCommandResultEventArgs class members, see the AsyncCommandResultEventArgs Members topic.

Public Instance Properties

Error | Operation error
Result | Operation state

See Also

AsyncCommandResultEventArgs Class | Aspose.Email.Common.Commands Namespace


Error Property

Aspose.Email

AsyncCommandResultEventArgs.Error Property

Operation error

public Exception Error {get;}

See Also

AsyncCommandResultEventArgs Class | Aspose.Email.Common.Commands Namespace


Result Property

Aspose.Email

AsyncCommandResultEventArgs.Result Property

Operation state

public AsyncCommandResults Result {get;}

See Also

AsyncCommandResultEventArgs Class | Aspose.Email.Common.Commands Namespace


AsyncCommandResults Enumeration

public enum AsyncCommandResults

Members

Member Name | Description | Value
Undefined |  | 0
Successfully |  | 1
Failed |  | 2
Cancelled |  | 3

Requirements

Namespace: Aspose.Email.Common.Commands

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Common.Commands Namespace


BaseAsyncCommand Class

Defines an asynchronous base command.

For a list of all members of this type, see BaseAsyncCommand Members.

System.Object
Aspose.Email.Common.Commands.BaseCommand
Aspose.Email.Common.Commands.BaseAsyncCommand

public abstract class BaseAsyncCommand : BaseCommand, IAsyncCommand

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Common.Commands

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

BaseAsyncCommand Members | Aspose.Email.Common.Commands Namespace


BaseAsyncCommand Members

BaseAsyncCommand overview

Public Instance Properties

CanExecute (inherited from BaseCommand) Defines the operator that determines whether the command can execute in its current state.

Public Instance Methods

Cancel | Cancels an execution of a command.
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from BaseCommand) | Defines the method to be called when the command is invoked. Method will be invoked taking in account CanExecute property.
ExecuteAsync | Executes a command asynchronously.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

CanExecuteChanged (inherited from BaseCommand) | Occurs when changes occur that affect whether or not the command should execute.
ExecutionCompleted | Occurs when execution is completed.

Protected Instance Constructors

BaseAsyncCommand Constructor Initializes a new instance of the BaseAsyncCommand class.

Protected Instance Methods

executingOperation (inherited from BaseCommand) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

canExecuteChanged (inherited from BaseCommand)

See Also

BaseAsyncCommand Class | Aspose.Email.Common.Commands Namespace


BaseAsyncCommand Constructor

Initializes a new instance of the BaseAsyncCommand class.

protected BaseAsyncCommand();

See Also

BaseAsyncCommand Class | Aspose.Email.Common.Commands Namespace


BaseAsyncCommand Methods

The methods of the BaseAsyncCommand class are listed below. For a complete list of BaseAsyncCommand class members, see the BaseAsyncCommand Members topic.

Public Instance Methods

Cancel | Cancels an execution of a command.
Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute (inherited from BaseCommand) | Defines the method to be called when the command is invoked. Method will be invoked taking in account CanExecute property.
ExecuteAsync | Executes a command asynchronously.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

executingOperation (inherited from BaseCommand) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

canExecuteChanged (inherited from BaseCommand)

See Also

BaseAsyncCommand Class | Aspose.Email.Common.Commands Namespace


BaseAsyncCommand.Cancel Method

Cancels an execution of a command.

public void Cancel();

Implements

IAsyncCommand.Cancel

See Also

BaseAsyncCommand Class | Aspose.Email.Common.Commands Namespace


BaseAsyncCommand.Dispose Method

Performs tasks associated with freeing, releasing, or resetting unmanaged resources.

public override void Dispose();

Implements

IDisposable.Dispose

See Also

BaseAsyncCommand Class | Aspose.Email.Common.Commands Namespace


BaseAsyncCommand.ExecuteAsync Method

Executes a command asynchronously.

public void ExecuteAsync();

Implements

IAsyncCommand.ExecuteAsync

See Also

BaseAsyncCommand Class | Aspose.Email.Common.Commands Namespace


BaseAsyncCommand Events

The events of the BaseAsyncCommand class are listed below. For a complete list of BaseAsyncCommand class members, see the BaseAsyncCommand Members topic.

Public Instance Events

CanExecuteChanged (inherited from BaseCommand) | Occurs when changes occur that affect whether or not the command should execute.
ExecutionCompleted | Occurs when execution is completed.

See Also

BaseAsyncCommand Class | Aspose.Email.Common.Commands Namespace


BaseAsyncCommand.ExecutionCompleted Event

Occurs when execution is completed.

public event AsyncCommandResultEventArgs} ExecutionCompleted;

Implements

IAsyncCommand.ExecutionCompleted

See Also

BaseAsyncCommand Class | Aspose.Email.Common.Commands Namespace


BaseCommand Class

Defines a base command.

For a list of all members of this type, see BaseCommand Members.

System.Object
Aspose.Email.Common.Commands.BaseCommand
Aspose.Email.Common.Commands.BaseAsyncCommand

public abstract class BaseCommand : ICommand, IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Common.Commands

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

BaseCommand Members | Aspose.Email.Common.Commands Namespace


BaseCommand Members

BaseCommand overview

Public Instance Properties

CanExecute Defines the operator that determines whether the command can execute in its current state.

Public Instance Methods

Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute | Defines the method to be called when the command is invoked. Method will be invoked taking in account CanExecute property.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

CanExecuteChanged Occurs when changes occur that affect whether or not the command should execute.

Protected Instance Constructors

BaseCommand Constructor Initializes a new instance of the BaseCommand class.

Protected Instance Methods

executingOperation |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

canExecuteChanged

See Also

BaseCommand Class | Aspose.Email.Common.Commands Namespace


BaseCommand Constructor

Initializes a new instance of the BaseCommand class.

protected BaseCommand();

See Also

BaseCommand Class | Aspose.Email.Common.Commands Namespace


BaseCommand Properties

The properties of the BaseCommand class are listed below. For a complete list of BaseCommand class members, see the BaseCommand Members topic.

Public Instance Properties

CanExecute Defines the operator that determines whether the command can execute in its current state.

See Also

BaseCommand Class | Aspose.Email.Common.Commands Namespace


CanExecute Property

Aspose.Email

BaseCommand.CanExecute Property

Defines the operator that determines whether the command can execute in its current state.

public virtual bool CanExecute {get; set;}

Implements

ICommand.CanExecute

See Also

BaseCommand Class | Aspose.Email.Common.Commands Namespace


BaseCommand Methods

The methods of the BaseCommand class are listed below. For a complete list of BaseCommand class members, see the BaseCommand Members topic.

Public Instance Methods

Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Execute | Defines the method to be called when the command is invoked. Method will be invoked taking in account CanExecute property.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

executingOperation |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

canExecuteChanged

See Also

BaseCommand Class | Aspose.Email.Common.Commands Namespace


BaseCommand.CanExecuteChanged Event

Occurs when changes occur that affect whether or not the command should execute.

public event EventHandler CanExecuteChanged;

Implements

ICommand.CanExecuteChanged

See Also

BaseCommand Class | Aspose.Email.Common.Commands Namespace


BaseCommand.Dispose Method

Performs tasks associated with freeing, releasing, or resetting unmanaged resources.

public virtual void Dispose();

Implements

IDisposable.Dispose

See Also

BaseCommand Class | Aspose.Email.Common.Commands Namespace


BaseCommand.Execute Method

Defines the method to be called when the command is invoked. Method will be invoked taking in account CanExecute property.

public ICommand Execute();

Return Value

Returns next command to execute. By default returns itself.

Implements

ICommand.Execute

See Also

BaseCommand Class | Aspose.Email.Common.Commands Namespace


BaseCommand.executingOperation Method

protected abstract void executingOperation();

See Also

BaseCommand Class | Aspose.Email.Common.Commands Namespace


BaseCommand Events

The events of the BaseCommand class are listed below. For a complete list of BaseCommand class members, see the BaseCommand Members topic.

Public Instance Events

CanExecuteChanged Occurs when changes occur that affect whether or not the command should execute.

See Also

BaseCommand Class | Aspose.Email.Common.Commands Namespace


CommandStatus Class

Indicates the result of an operation.

For a list of all members of this type, see CommandStatus Members.

System.Object
Aspose.Email.Common.Commands.CommandStatus
Aspose.Email.Protocols.ActiveSync.TransportLayer.Status

public class CommandStatus

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Common.Commands

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CommandStatus Members | Aspose.Email.Common.Commands Namespace


CommandStatus Members

CommandStatus overview

Public Instance Constructors

CommandStatus Constructor Initializes a new instance of the Status class.

Public Instance Properties

Description | Contains status description
StatusCode | Contains status code

Public Instance Methods

Equals | Determines whether the specified object is equal to the current object.
GetHashCode | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a string that represents the current object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

_description
_statusCode

See Also

CommandStatus Class | Aspose.Email.Common.Commands Namespace


CommandStatus Constructor

Initializes a new instance of the Status class.

public CommandStatus(
int statusCode,
string description
);

Parameters

statusCode
Contains status code
description
Contains status description

See Also

CommandStatus Class | Aspose.Email.Common.Commands Namespace


CommandStatus Fields

The fields of the CommandStatus class are listed below. For a complete list of CommandStatus class members, see the CommandStatus Members topic.

Protected Internal Instance Fields

_description
_statusCode

See Also

CommandStatus Class | Aspose.Email.Common.Commands Namespace


CommandStatus._description Field

protected internal string _description;

See Also

CommandStatus Class | Aspose.Email.Common.Commands Namespace


CommandStatus._statusCode Field

protected internal int _statusCode;

See Also

CommandStatus Class | Aspose.Email.Common.Commands Namespace


CommandStatus Properties

The properties of the CommandStatus class are listed below. For a complete list of CommandStatus class members, see the CommandStatus Members topic.

Public Instance Properties

Description | Contains status description
StatusCode | Contains status code

See Also

CommandStatus Class | Aspose.Email.Common.Commands Namespace


Description Property

Aspose.Email

CommandStatus.Description Property

Contains status description

public virtual string Description {get;}

See Also

CommandStatus Class | Aspose.Email.Common.Commands Namespace


StatusCode Property

Aspose.Email

CommandStatus.StatusCode Property

Contains status code

public virtual int StatusCode {get;}

See Also

CommandStatus Class | Aspose.Email.Common.Commands Namespace


CommandStatus Methods

The methods of the CommandStatus class are listed below. For a complete list of CommandStatus class members, see the CommandStatus Members topic.

Public Instance Methods

Equals | Determines whether the specified object is equal to the current object.
GetHashCode | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a string that represents the current object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CommandStatus Class | Aspose.Email.Common.Commands Namespace


CommandStatus.Equals Method

Determines whether the specified object is equal to the current object.

public override bool Equals(
object obj
);

Parameters

obj
The object to compare with the current object.

Return Value

true if the specified object is equal to the current object; otherwise, false.

See Also

CommandStatus Class | Aspose.Email.Common.Commands Namespace


CommandStatus.GetHashCode Method

Serves as a hash function for a particular type.

public override int GetHashCode();

Return Value

A hash code for the current Object.

See Also

CommandStatus Class | Aspose.Email.Common.Commands Namespace


CommandStatus.ToString Method

Returns a string that represents the current object.

public override string ToString();

Return Value

A string that represents the current object.

See Also

CommandStatus Class | Aspose.Email.Common.Commands Namespace


IAsyncCommand Interface

Defines an asynchronous command.

For a list of all members of this type, see IAsyncCommand Members.

public interface IAsyncCommand : ICommand, IDisposable

Types that implement IAsyncCommand

Type | Description
BaseAsyncCommand | Defines an asynchronous base command.

Requirements

Namespace: Aspose.Email.Common.Commands

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

IAsyncCommand Members | Aspose.Email.Common.Commands Namespace


IAsyncCommand Members

IAsyncCommand overview

Public Instance Methods

Cancel | Cancels an execution of a command.
ExecuteAsync | Executes a command asynchronously.

Public Instance Events

ExecutionCompleted Occurs when execution is completed.

See Also

IAsyncCommand Interface | Aspose.Email.Common.Commands Namespace


IAsyncCommand Methods

The methods of the IAsyncCommand interface are listed below. For a complete list of IAsyncCommand interface members, see the IAsyncCommand Members topic.

Public Instance Methods

Cancel | Cancels an execution of a command.
ExecuteAsync | Executes a command asynchronously.

See Also

IAsyncCommand Interface | Aspose.Email.Common.Commands Namespace


IAsyncCommand.Cancel Method

Cancels an execution of a command.

void Cancel();

See Also

IAsyncCommand Interface | Aspose.Email.Common.Commands Namespace


IAsyncCommand.ExecuteAsync Method

Executes a command asynchronously.

void ExecuteAsync();

See Also

IAsyncCommand Interface | Aspose.Email.Common.Commands Namespace


IAsyncCommand Events

The events of the IAsyncCommand interface are listed below. For a complete list of IAsyncCommand interface members, see the IAsyncCommand Members topic.

Public Instance Events

ExecutionCompleted Occurs when execution is completed.

See Also

IAsyncCommand Interface | Aspose.Email.Common.Commands Namespace


IAsyncCommand.ExecutionCompleted Event

Occurs when execution is completed.

event AsyncCommandResultEventArgs} ExecutionCompleted;

See Also

IAsyncCommand Interface | Aspose.Email.Common.Commands Namespace


ICommand Interface

Defines a command.

For a list of all members of this type, see ICommand Members.

Aspose.Email.Common.Commands.ICommand
Aspose.Email.Common.Commands.IAsyncCommand

public interface ICommand : IDisposable

Types that implement ICommand

Type | Description
BaseAsyncCommand | Defines an asynchronous base command.
BaseCommand | Defines a base command.

Requirements

Namespace: Aspose.Email.Common.Commands

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ICommand Members | Aspose.Email.Common.Commands Namespace


ICommand Members

ICommand overview

Public Instance Properties

CanExecute Defines the operator that determines whether the command can execute in its current state.

Public Instance Methods

Execute Defines the method to be called when the command is invoked.

Public Instance Events

CanExecuteChanged Occurs when changes occur that affect whether or not the command should execute.

See Also

ICommand Interface | Aspose.Email.Common.Commands Namespace


ICommand Properties

The properties of the ICommand interface are listed below. For a complete list of ICommand interface members, see the ICommand Members topic.

Public Instance Properties

CanExecute Defines the operator that determines whether the command can execute in its current state.

See Also

ICommand Interface | Aspose.Email.Common.Commands Namespace


CanExecute Property

Aspose.Email

ICommand.CanExecute Property

Defines the operator that determines whether the command can execute in its current state.

bool CanExecute {get;}

See Also

ICommand Interface | Aspose.Email.Common.Commands Namespace


ICommand Methods

The methods of the ICommand interface are listed below. For a complete list of ICommand interface members, see the ICommand Members topic.

Public Instance Methods

Execute Defines the method to be called when the command is invoked.

See Also

ICommand Interface | Aspose.Email.Common.Commands Namespace


ICommand.Execute Method

Defines the method to be called when the command is invoked.

ICommand Execute();

Return Value

Returns next command to execute. By default returns itself.

See Also

ICommand Interface | Aspose.Email.Common.Commands Namespace


ICommand Events

The events of the ICommand interface are listed below. For a complete list of ICommand interface members, see the ICommand Members topic.

Public Instance Events

CanExecuteChanged Occurs when changes occur that affect whether or not the command should execute.

See Also

ICommand Interface | Aspose.Email.Common.Commands Namespace


ICommand.CanExecuteChanged Event

Occurs when changes occur that affect whether or not the command should execute.

event EventHandler CanExecuteChanged;

See Also

ICommand Interface | Aspose.Email.Common.Commands Namespace


Aspose.Email.Exchange

Aspose.Email

Aspose.Email.Exchange Namespace

Namespace hierarchy

Classes

Class | Description
CallInformation | Phone call information
ContentClassType | Represents the content class of item.
DateRange | Represents the date range
EWSClient | Provides access to MS Exchange Server by using Exchange Web Services (EWS).
ExchangeAttachmentInfo | Represents an attachment information transmitted over exchange protocols
ExchangeAttachmentInfoCollection | Represents the collection of ExchangeAttachmentInfo
ExchangeBasePermission | Provides abstract base class for permissions to folders on Exchange Server.
ExchangeCalendarEvent | Represents the event in the user's calendar
ExchangeCalendarEventCollection | Represents the collection of ExchangeCalendarEvent
ExchangeCalendarPermission | Represents a permission on a calendar folder.
ExchangeClient | The ExchangeClient class allows applications to manage E-Mail box in Microsoft Exchange Server by using WebDav Exchange Store Protocol.
ExchangeClientBase | Provides the abstract base class to MS Exchange Server access.
ExchangeConversation | Represents a single conversation.
ExchangeDelegatePermissions | Represents the folder permissions for the delegate user
ExchangeDelegateUser | Represents a user who is granted access to the principal mailbox
ExchangeDelegateUserCollection | Represents the collection of ExchangeDelegateUser
ExchangeException | Thrown if there is a MS Exchange communication failure.
ExchangeFolderInfo | Provides information about an MS Exchange folder.
ExchangeFolderInfoCollection | Represents a collection of ExchangeMessageInfo objects.
ExchangeFolderPermission | Represents a permission on a folder.
ExchangeFolderPermissionCollection | Represents the collection of ExchangeFolderPermission
ExchangeFolderUserInfo | Represents a user who has folder access permissions
ExchangeMailboxInfo | Represents the mail box information of an exchange server.
ExchangeMessageInfo | The ExchangeMessageInfo represents the E-Mail message info fetched from the Exchange Store.
ExchangeMessageInfoCollection | Represents a collection of ExchangeMessageInfo objects.
ExchangePermissionCollection | Represents the collection of ExchangeBasePermission
ExchangeQueryBuilder | Represents the builder of search expression that used by Exchange protocol.
ExchangeStreamedItem | Represents the item received in ExportItems response
ExchangeTask | Represents the exchange task information.
ExchangeUploadItemResult | Represents a result of updating or creating a streamed item
ExchangeUserAvailability | Represents user availability information
ExchangeUserAvailabilityCollection | Represents the collection of ExchangeUserAvailability
ExchangeUserWorkingHours | Represents the user working hours.
ExchangeUserWorkingHoursCollection | Represents the collection of ExchangeUserWorkingHours
ExchangeWebServiceClient | Obsolete. Provides access to MS Exchange Server by using Exchange Web Services (EWS).
FindMessageTrackingReportOptions | Represents options for FindMessageTrackingReport operation
GetMailTipsOptions | Represents options for GetMailTips
GetMessageTrackingReportOptions | Represents options for GetMessageTrackingReport operation
InboxRule | Represents a inbox rule
MailTips | Represents values for the Mail Tips
MessageTrackingReport | Represents the information to be included in the report.
MessageTrackingReportInfo | Represents an information about the message that was found by using the FindMessageTrackingReport
OutOfOfficeMailTip | Represents OOF mail tip
RecipientTrackingEvent | Represents details for a specific event in the tracking report.
ReplyBody | Represents the OOF message response.
RuleActions | Represents the set of actions that are available to a rule.
RulePredicates | Represents rule predicate
ServerNotificationEventArgs | Contains event data for server notification.
SizeRange | Represents the size range
TaskRegeneratingPattern | Represents the regenerating recurrence pattern that specifies how many days, weeks, months or years after the completion of the current task the next occurrence will be due.
UnifiedMessagingConfiguration | Unified messaging configuration
UserConfiguration | Represents user configuration
UserConfigurationName | Represents user configuration name

Interfaces

Interface | Description
IEWSClient | Represents the interface for Exchange client.
IExchangeClientBase | Represents the interface for base Exchange clients.

Enumerations

Enumeration | Description
CalendarItemCreateOrDeleteOperation | Represents options for create and delete operations
ConnectionFailureCause | Connection failure cause
DeleteTaskOptions | Enumerates delete task options.
EmptyFolderOptions | Enumerates the empty folder options
EventTypes | Specifies event type
ExchangeCalendarPermissionLevel | Specifies the permission level that a user has on a calendar folder.
ExchangeCalendarPermissionReadAccess | Sspecifies whether a user has permission to read items in a folder.
ExchangeConversationFlagStatus | Enumerates the flag status for conversation.
ExchangeDelegateFolderPermissionLevel | Enumerates the permissions levels which a delegate user can have on folder
ExchangeDelegateOptions | Enumerates delegation options
ExchangeFolderPermissionAction | Defines which items in a folder a user has permission to edit or delete.
ExchangeFolderPermissionLevel | Specifies the permission level that a user has on a folder.
ExchangeFolderPermissionReadAccess | Sspecifies whether a user has permission to read items in a folder.
ExchangeFolderUserType | Enumerates the distinguished user accounts
ExchangeListContactsOptions | Enumerates the list contacts options
ExchangeListMessagesOptions | Enumerates the list messages options
ExchangeMessageFlag | Represents a flags of message.
ExchangeTaskStatus | Enumerates the task statuses.
ExchangeUserBusyness | Enumerates the user free/busy statuses
ExchangeVersion | Exchange server versions
FlaggedForAction | Enumerates flagged for action
ImportanceChoices | Enumerates the levels of importance for an item
ItemChoice | Specifies property type which should be used for Exchange impersonation.
KnownFolderTypes | Specifies the known Exchange server folders.
MailTipsType | Enumerates the types of mail tips
MessageTrackingReportTemplate | Enumerates the types of report to display.
PhoneCallState | Phone call statuses.
RulePredicateFlags | Represents the RulePredicate flags
SensitivityChoices | Enumerates the sensitivity level types that are available for an item.
TaskRegeneratingType | Enumerates the types of regenerating pattern.
UpdateTaskOptions | Enumerates update task options.


CalendarItemCreateOrDeleteOperation Enumeration

Represents options for create and delete operations

public enum CalendarItemCreateOrDeleteOperation

Members

Member Name | Description | Value
SendToNone | Don't send mail | 0
SendOnlyToAll | Send email to participants. | 1
SendToAllAndSaveCopy | Send email to participants and save copy. | 2

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange Namespace


CallInformation Class

Phone call information

For a list of all members of this type, see CallInformation Members.

System.Object
Aspose.Email.Exchange.CallInformation

public class CallInformation

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CallInformation Members | Aspose.Email.Exchange Namespace


CallInformation Members

CallInformation overview

Public Instance Properties

CallState | Phone call statuses.
FailureCause | Connection failure cause
SIPResponse | SIP response
SIPResponseCode | SIP response code This list details all the SIP response codes defined in IETF RFCs and registered with the IANA as of 18 April 2013. It also includes SIP response codes defined in obsolete SIP RFCs (specifically, RFC 2543), which are therefore not registered with the IANA; these are explicitly noted as such. 1xx—Provisional Responses 2xx—Successful Responses 3xx—Redirection Responses 4xx—Client Failure Responses 5xx—Server Failure Responses 6xx—Global Failure Responses

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CallInformation Class | Aspose.Email.Exchange Namespace


CallInformation Properties

The properties of the CallInformation class are listed below. For a complete list of CallInformation class members, see the CallInformation Members topic.

Public Instance Properties

CallState | Phone call statuses.
FailureCause | Connection failure cause
SIPResponse | SIP response
SIPResponseCode | SIP response code This list details all the SIP response codes defined in IETF RFCs and registered with the IANA as of 18 April 2013. It also includes SIP response codes defined in obsolete SIP RFCs (specifically, RFC 2543), which are therefore not registered with the IANA; these are explicitly noted as such. 1xx—Provisional Responses 2xx—Successful Responses 3xx—Redirection Responses 4xx—Client Failure Responses 5xx—Server Failure Responses 6xx—Global Failure Responses

See Also

CallInformation Class | Aspose.Email.Exchange Namespace


CallState Property

Aspose.Email

CallInformation.CallState Property

Phone call statuses.

public PhoneCallState CallState {get; set;}

See Also

CallInformation Class | Aspose.Email.Exchange Namespace


FailureCause Property

Aspose.Email

CallInformation.FailureCause Property

Connection failure cause

public ConnectionFailureCause FailureCause {get; set;}

See Also

CallInformation Class | Aspose.Email.Exchange Namespace


SIPResponse Property

Aspose.Email

CallInformation.SIPResponse Property

SIP response

public string SIPResponse {get; set;}

See Also

CallInformation Class | Aspose.Email.Exchange Namespace


SIPResponseCode Property

Aspose.Email

CallInformation.SIPResponseCode Property

SIP response code This list details all the SIP response codes defined in IETF RFCs and registered with the IANA as of 18 April 2013. It also includes SIP response codes defined in obsolete SIP RFCs (specifically, RFC 2543), which are therefore not registered with the IANA; these are explicitly noted as such. 1xx—Provisional Responses 2xx—Successful Responses 3xx—Redirection Responses 4xx—Client Failure Responses 5xx—Server Failure Responses 6xx—Global Failure Responses

public int SIPResponseCode {get; set;}

See Also

CallInformation Class | Aspose.Email.Exchange Namespace


ConnectionFailureCause Enumeration

Connection failure cause

public enum ConnectionFailureCause

Members

Member Name | Description | Value
None | Failure cause is absent | 0
UserBusy | Addressee is busy | 1
NoAnswer | No answer | 2
Unavailable | Addressee is unavailable. | 3
Other | Other reason | 4

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange Namespace


ContentClassType Class

Represents the content class of item.

For a list of all members of this type, see ContentClassType Members.

System.Object
Aspose.Email.Exchange.ContentClassType

public sealed class ContentClassType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ContentClassType Members | Aspose.Email.Exchange Namespace


ContentClassType Members

ContentClassType overview

Public Static Properties

Activity | Gets the urn:content-classes:activity content class that defines a set of properties for an item that is a Journal. This maps to IPM.Activity.
Appointment | Gets the urn:content-classes:appointment content class that defines properties for items that are appointments.
CalendarFolder | Gets the The urn:content-classes:calendarfolder content class that defines a set of properties for a folder that primarily contains appointment items.
CalendarMessage | Gets the urn:content-classes:calendarmessage content class that defines a set of properties for message items that contain meeting requests.
ContactFolder | Gets the The urn:content-classes:contactfolder content class that defines a set of properties for a folder that primarily contains contact items.
Document | Gets the urn:content-classes:document content class that defines a set of properties for an item that is a document such as a Microsoft® Word file.
DSN | Gets the the urn:content-classes:dsn content class that defines a set of properties for an item that is a Delivery Status Notification (DSN) message.
Folder | Gets the urn:content-classes:folder content class that defines a set of properties for a folder in the Exchange store.
Group | Gets the value that represents the content class urn:content-classes:group.
JournalFolder | Gets the urn:content-classes:journalfolder content class that defines a set of properties for a folder that primarily contains journal items.
MailFolder | Gets the urn:content-classes:mailfolder content class that defines a set of properties for a folder that primarily contains messages.
MDN | Gets the urn:content-classes:mdn content class that defines a set of properties for an item that is a Mail Delivery Notification (MDN) message.
Message | Gets the urn:content-classes:message content class that defines a set of properties for an item that is a message.
Note | Gets the value that represents the content class urn:content-classes:note.
NoteFolder | Gets the urn:content-classes:notesfolder content class that defines a set of properties for a folder that primarily contains note items.
Person | Gets the urn:content-classes:person content class that defines a set of properties for an item that is a contact.
RecallMesage | Gets the urn:content-classes:recallmessage content class that defines a set of properties for a recall message.
RecallReport | Gets the urn:content-classes:recallreport content class that defines a set of properties for an item that is a recall report message.
ReportMessage | Gets the value that represents the content class urn:content-classes:reportmessage.
Task | Gets the value that represents the content class urn:content-classes:task.
TaskFolder | Gets the urn:content-classes:taskfolder content class that defines a set of properties for a folder that primarily contains task items.

Public Instance Constructors

ContentClassType Constructor Initializes a new instance of the ContentClassType class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents this instance.

See Also

ContentClassType Class | Aspose.Email.Exchange Namespace


ContentClassType Constructor

Initializes a new instance of the ContentClassType class.

public ContentClassType(
string value
);

Parameters

value
The value.

See Also

ContentClassType Class | Aspose.Email.Exchange Namespace


ContentClassType Properties

The properties of the ContentClassType class are listed below. For a complete list of ContentClassType class members, see the ContentClassType Members topic.

Public Static Properties

Activity | Gets the urn:content-classes:activity content class that defines a set of properties for an item that is a Journal. This maps to IPM.Activity.
Appointment | Gets the urn:content-classes:appointment content class that defines properties for items that are appointments.
CalendarFolder | Gets the The urn:content-classes:calendarfolder content class that defines a set of properties for a folder that primarily contains appointment items.
CalendarMessage | Gets the urn:content-classes:calendarmessage content class that defines a set of properties for message items that contain meeting requests.
ContactFolder | Gets the The urn:content-classes:contactfolder content class that defines a set of properties for a folder that primarily contains contact items.
Document | Gets the urn:content-classes:document content class that defines a set of properties for an item that is a document such as a Microsoft® Word file.
DSN | Gets the the urn:content-classes:dsn content class that defines a set of properties for an item that is a Delivery Status Notification (DSN) message.
Folder | Gets the urn:content-classes:folder content class that defines a set of properties for a folder in the Exchange store.
Group | Gets the value that represents the content class urn:content-classes:group.
JournalFolder | Gets the urn:content-classes:journalfolder content class that defines a set of properties for a folder that primarily contains journal items.
MailFolder | Gets the urn:content-classes:mailfolder content class that defines a set of properties for a folder that primarily contains messages.
MDN | Gets the urn:content-classes:mdn content class that defines a set of properties for an item that is a Mail Delivery Notification (MDN) message.
Message | Gets the urn:content-classes:message content class that defines a set of properties for an item that is a message.
Note | Gets the value that represents the content class urn:content-classes:note.
NoteFolder | Gets the urn:content-classes:notesfolder content class that defines a set of properties for a folder that primarily contains note items.
Person | Gets the urn:content-classes:person content class that defines a set of properties for an item that is a contact.
RecallMesage | Gets the urn:content-classes:recallmessage content class that defines a set of properties for a recall message.
RecallReport | Gets the urn:content-classes:recallreport content class that defines a set of properties for an item that is a recall report message.
ReportMessage | Gets the value that represents the content class urn:content-classes:reportmessage.
Task | Gets the value that represents the content class urn:content-classes:task.
TaskFolder | Gets the urn:content-classes:taskfolder content class that defines a set of properties for a folder that primarily contains task items.

See Also

ContentClassType Class | Aspose.Email.Exchange Namespace


Activity Property

Aspose.Email

ContentClassType.Activity Property

Gets the urn:content-classes:activity content class that defines a set of properties for an item that is a Journal. This maps to IPM.Activity.

public static ContentClassType Activity {get;}

Property Value

The activity content class.

See Also

ContentClassType Class | Aspose.Email.Exchange Namespace


Appointment Property

Aspose.Email

ContentClassType.Appointment Property

Gets the urn:content-classes:appointment content class that defines properties for items that are appointments.

public static ContentClassType Appointment {get;}

Property Value

The appointment content class.

See Also

ContentClassType Class | Aspose.Email.Exchange Namespace


CalendarFolder Property

Aspose.Email

ContentClassType.CalendarFolder Property

Gets the The urn:content-classes:calendarfolder content class that defines a set of properties for a folder that primarily contains appointment items.

public static ContentClassType CalendarFolder {get;}

Property Value

The calendar folder content calss.

See Also

ContentClassType Class | Aspose.Email.Exchange Namespace


CalendarMessage Property

Aspose.Email

ContentClassType.CalendarMessage Property

Gets the urn:content-classes:calendarmessage content class that defines a set of properties for message items that contain meeting requests.

public static ContentClassType CalendarMessage {get;}

Property Value

The calendar message content class.

See Also

ContentClassType Class | Aspose.Email.Exchange Namespace


ContactFolder Property

Aspose.Email

ContentClassType.ContactFolder Property

Gets the The urn:content-classes:contactfolder content class that defines a set of properties for a folder that primarily contains contact items.

public static ContentClassType ContactFolder {get;}

Property Value

The contact folder content class.

See Also

ContentClassType Class | Aspose.Email.Exchange Namespace


Document Property

Aspose.Email

ContentClassType.Document Property

Gets the urn:content-classes:document content class that defines a set of properties for an item that is a document such as a Microsoft® Word file.

public static ContentClassType Document {get;}

Property Value

The document content class.

See Also

ContentClassType Class | Aspose.Email.Exchange Namespace


DSN Property

Aspose.Email

ContentClassType.DSN Property

Gets the the urn:content-classes:dsn content class that defines a set of properties for an item that is a Delivery Status Notification (DSN) message.

public static ContentClassType DSN {get;}

Property Value

The DSN content class.

See Also

ContentClassType Class | Aspose.Email.Exchange Namespace


Folder Property

Aspose.Email

ContentClassType.Folder Property

Gets the urn:content-classes:folder content class that defines a set of properties for a folder in the Exchange store.

public static ContentClassType Folder {get;}

Property Value

The folder content class.

See Also

ContentClassType Class | Aspose.Email.Exchange Namespace


Group Property

Aspose.Email

ContentClassType.Group Property

Gets the value that represents the content class urn:content-classes:group.

public static ContentClassType Group {get;}

Property Value

The group content class.

See Also

ContentClassType Class | Aspose.Email.Exchange Namespace


JournalFolder Property

Aspose.Email

ContentClassType.JournalFolder Property

Gets the urn:content-classes:journalfolder content class that defines a set of properties for a folder that primarily contains journal items.

public static ContentClassType JournalFolder {get;}

Property Value

The journal folder content class.

See Also

ContentClassType Class | Aspose.Email.Exchange Namespace


MailFolder Property

Aspose.Email

ContentClassType.MailFolder Property

Gets the urn:content-classes:mailfolder content class that defines a set of properties for a folder that primarily contains messages.

public static ContentClassType MailFolder {get;}

Property Value

The mail folder content class.

See Also

ContentClassType Class | Aspose.Email.Exchange Namespace


MDN Property

Aspose.Email

ContentClassType.MDN Property

Gets the urn:content-classes:mdn content class that defines a set of properties for an item that is a Mail Delivery Notification (MDN) message.

public static ContentClassType MDN {get;}

Property Value

The MDN content class.

See Also

ContentClassType Class | Aspose.Email.Exchange Namespace


Message Property

Aspose.Email

ContentClassType.Message Property

Gets the urn:content-classes:message content class that defines a set of properties for an item that is a message.

public static ContentClassType Message {get;}

Property Value

The message content class.

See Also

ContentClassType Class | Aspose.Email.Exchange Namespace


Note Property

Aspose.Email

ContentClassType.Note Property

Gets the value that represents the content class urn:content-classes:note.

public static ContentClassType Note {get;}

Property Value

The note content class.

See Also

ContentClassType Class | Aspose.Email.Exchange Namespace


NoteFolder Property

Aspose.Email

ContentClassType.NoteFolder Property

Gets the urn:content-classes:notesfolder content class that defines a set of properties for a folder that primarily contains note items.

public static ContentClassType NoteFolder {get;}

Property Value

The note folder content class.

See Also

ContentClassType Class | Aspose.Email.Exchange Namespace


Person Property

Aspose.Email

ContentClassType.Person Property

Gets the urn:content-classes:person content class that defines a set of properties for an item that is a contact.

public static ContentClassType Person {get;}

Property Value

The person content class.

See Also

ContentClassType Class | Aspose.Email.Exchange Namespace


RecallMesage Property

Aspose.Email

ContentClassType.RecallMesage Property

Gets the urn:content-classes:recallmessage content class that defines a set of properties for a recall message.

public static ContentClassType RecallMesage {get;}

Property Value

The recall mesage content class.

See Also

ContentClassType Class | Aspose.Email.Exchange Namespace


RecallReport Property

Aspose.Email

ContentClassType.RecallReport Property

Gets the urn:content-classes:recallreport content class that defines a set of properties for an item that is a recall report message.

public static ContentClassType RecallReport {get;}

Property Value

The recall report content class.

See Also

ContentClassType Class | Aspose.Email.Exchange Namespace


ReportMessage Property

Aspose.Email

ContentClassType.ReportMessage Property

Gets the value that represents the content class urn:content-classes:reportmessage.

public static ContentClassType ReportMessage {get;}

Property Value

The report message content class.

See Also

ContentClassType Class | Aspose.Email.Exchange Namespace


Task Property

Aspose.Email

ContentClassType.Task Property

Gets the value that represents the content class urn:content-classes:task.

public static ContentClassType Task {get;}

Property Value

The task content class.

See Also

ContentClassType Class | Aspose.Email.Exchange Namespace


TaskFolder Property

Aspose.Email

ContentClassType.TaskFolder Property

Gets the urn:content-classes:taskfolder content class that defines a set of properties for a folder that primarily contains task items.

public static ContentClassType TaskFolder {get;}

Property Value

The task folder content class.

See Also

ContentClassType Class | Aspose.Email.Exchange Namespace


ContentClassType Methods

The methods of the ContentClassType class are listed below. For a complete list of ContentClassType class members, see the ContentClassType Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents this instance.

See Also

ContentClassType Class | Aspose.Email.Exchange Namespace


ContentClassType.ToString Method

Returns a String that represents this instance.

public override string ToString();

Return Value

A String that represents this instance.

See Also

ContentClassType Class | Aspose.Email.Exchange Namespace


DateRange Class

Represents the date range

For a list of all members of this type, see DateRange Members.

System.Object
Aspose.Email.Exchange.DateRange

public sealed class DateRange

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DateRange Members | Aspose.Email.Exchange Namespace


DateRange Members

DateRange overview

Public Instance Constructors

DateRange Overloaded. Initializes a new instance of the DateRange class.

Public Instance Properties

EndTime | Gets or sets the end of a time period.
StartTime | Gets or sets the start of a time period.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DateRange Class | Aspose.Email.Exchange Namespace


DateRange Constructor

Initializes a new instance of the DateRange class

Overload List

Initializes a new instance of the DateRange class

public DateRange();

Initializes a new instance of the DateRange class

public DateRange(DateTime,DateTime);

See Also

DateRange Class | Aspose.Email.Exchange Namespace


DateRange Constructor (DateTime, DateTime)

Initializes a new instance of the DateRange class

public DateRange(
DateTime startTime,
DateTime endTime
);

Parameters

startTime
Specifies the start of a time period.
endTime
Specifies the end of a time period.

See Also

DateRange Class | Aspose.Email.Exchange Namespace | DateRange Constructor Overload List


DateRange Constructor ()

Initializes a new instance of the DateRange class

public DateRange();

See Also

DateRange Class | Aspose.Email.Exchange Namespace | DateRange Constructor Overload List


DateRange Properties

The properties of the DateRange class are listed below. For a complete list of DateRange class members, see the DateRange Members topic.

Public Instance Properties

EndTime | Gets or sets the end of a time period.
StartTime | Gets or sets the start of a time period.

See Also

DateRange Class | Aspose.Email.Exchange Namespace


EndTime Property

Aspose.Email

DateRange.EndTime Property

Gets or sets the end of a time period.

public DateTime EndTime {get; set;}

See Also

DateRange Class | Aspose.Email.Exchange Namespace


StartTime Property

Aspose.Email

DateRange.StartTime Property

Gets or sets the start of a time period.

public DateTime StartTime {get; set;}

See Also

DateRange Class | Aspose.Email.Exchange Namespace


DeleteTaskOptions Enumeration

Enumerates delete task options.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum DeleteTaskOptions

Members

Member Name | Description | Value
None | Specifies that task should be moved into DeletedItems folder. | 0
DeletePermanently | Specifies that task should be deleted permanently. | 1

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange Namespace


EmptyFolderOptions Enumeration

Enumerates the empty folder options

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum EmptyFolderOptions

Members

Member Name | Description | Value
None | If DeletePermanently flag is not set, move folder contents excluding subfolders to DeletedItems folder. | 0
DeleteSubfolders | Include subfolders into deletion operation. | 1
DeletePermanently | Indicates that items should be deleted permanently. | 2

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange Namespace


EventTypes Enumeration

Specifies event type

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum EventTypes

Members

Member Name | Description | Value
None | Not defined | 0
Copied | Event arises when item is copied | 1
Created | Event arises when item is created | 2
Deleted | Event arises when item is deleted | 4
FreeBusyChanged | Event arises when FreeBusy state is changed | 8
Modified | Event arises when item is changed | 16
Moved | Event arises when item is moved | 32
NewMail | Event arises when new mail is received | 64

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange Namespace


EWSClient Class

Provides access to MS Exchange Server by using Exchange Web Services (EWS).

For a list of all members of this type, see EWSClient Members.

System.Object
Aspose.Email.Exchange.ExchangeClientBase
Aspose.Email.Exchange.EWSClient

public abstract class EWSClient : ExchangeClientBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

EWSClient Members | Aspose.Email.Exchange Namespace


EWSClient Members

EWSClient overview

Public Static Methods

GetEWSClient Overloaded. Initializes a new instance of the EWSClient based class

Public Instance Properties

Credentials (inherited from ExchangeClientBase) | Gets or sets the credentials.
MailboxInfo (inherited from ExchangeClientBase) | Gets the mailbox info.
MailboxUri (inherited from ExchangeClientBase) | Gets or sets the mailbox uri.
Proxy (inherited from ExchangeClientBase) | Gets or sets the proxy.
Timeout (inherited from ExchangeClientBase) | Gets or sets the number of milliseconds to wait before the operation times out. The default value is 100,000 milliseconds (100 seconds).

Public Instance Methods

AppendMessage (inherited from ExchangeClientBase) | Overloaded. Uploads the mail message to the specified folder
Backup (inherited from ExchangeClientBase) | Overloaded. Backups the content of the specified folders
CreateContact (inherited from ExchangeClientBase) | Creates a contact item in the Exchange store.
CreateFolder (inherited from ExchangeClientBase) | Creates the new folder with the specified name in the specified parent folder.
DeleteContact (inherited from ExchangeClientBase) | Overloaded. Deletes the contact.
DeleteFolder (inherited from ExchangeClientBase) | Deletes the folder
DeleteMessage (inherited from ExchangeClientBase) | Deletes the mail message.
Dispose (inherited from ExchangeClientBase) | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FetchAttachment (inherited from ExchangeClientBase) | Fetches the attachment
FetchMessage (inherited from ExchangeClientBase) | Fetches the message.
FolderExists (inherited from ExchangeClientBase) | Overloaded. Checks whether the specified folder exists.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetMailboxInfo (inherited from ExchangeClientBase) | Overloaded. Gets the mailbox info.
GetMailboxSize (inherited from ExchangeClientBase) | Overloaded. Gets the size of the mailbox.
GetType (inherited from Object) | Gets the Type of the current instance.
GetVersionInfo (inherited from ExchangeClientBase) | Returns exchange server version info
ListContacts (inherited from ExchangeClientBase) | Lists contacts located in the specified folder on server
ListMailboxes (inherited from ExchangeClientBase) | Lists mailboxes.
ListMessages (inherited from ExchangeClientBase) | Overloaded. Lists the messages.
ListPublicFolders (inherited from ExchangeClientBase) | Gets collection of public folders from root public folder
ListSubFolders (inherited from ExchangeClientBase) | Overloaded. Gets collection of child folders from parent
ResolveContact (inherited from ExchangeClientBase) | Resolves ambiguous mailbox names.
Restore (inherited from ExchangeClientBase) | Overloaded. Restores exchange folders from the specified personal storage file.
SaveMessage (inherited from ExchangeClientBase) | Overloaded. Saves the message.
Send (inherited from ExchangeClientBase) | Sends the specified message.
SetReadFlag (inherited from ExchangeClientBase) | Sets the read flag.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

EWSClient Constructor Initializes a new instance of the EWSClient class.

Protected Instance Methods

Dispose (inherited from ExchangeClientBase) | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EWSClient Class | Aspose.Email.Exchange Namespace


EWSClient Constructor

Initializes a new instance of the EWSClient class.

protected EWSClient();

See Also

EWSClient Class | Aspose.Email.Exchange Namespace


EWSClient Methods

The methods of the EWSClient class are listed below. For a complete list of EWSClient class members, see the EWSClient Members topic.

Public Static Methods

GetEWSClient Overloaded. Initializes a new instance of the EWSClient based class

Public Instance Methods

AppendMessage (inherited from ExchangeClientBase) | Overloaded. Uploads the mail message to the specified folder
Backup (inherited from ExchangeClientBase) | Overloaded. Backups the content of the specified folders
CreateContact (inherited from ExchangeClientBase) | Creates a contact item in the Exchange store.
CreateFolder (inherited from ExchangeClientBase) | Creates the new folder with the specified name in the specified parent folder.
DeleteContact (inherited from ExchangeClientBase) | Overloaded. Deletes the contact.
DeleteFolder (inherited from ExchangeClientBase) | Deletes the folder
DeleteMessage (inherited from ExchangeClientBase) | Deletes the mail message.
Dispose (inherited from ExchangeClientBase) | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FetchAttachment (inherited from ExchangeClientBase) | Fetches the attachment
FetchMessage (inherited from ExchangeClientBase) | Fetches the message.
FolderExists (inherited from ExchangeClientBase) | Overloaded. Checks whether the specified folder exists.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetMailboxInfo (inherited from ExchangeClientBase) | Overloaded. Gets the mailbox info.
GetMailboxSize (inherited from ExchangeClientBase) | Overloaded. Gets the size of the mailbox.
GetType (inherited from Object) | Gets the Type of the current instance.
GetVersionInfo (inherited from ExchangeClientBase) | Returns exchange server version info
ListContacts (inherited from ExchangeClientBase) | Lists contacts located in the specified folder on server
ListMailboxes (inherited from ExchangeClientBase) | Lists mailboxes.
ListMessages (inherited from ExchangeClientBase) | Overloaded. Lists the messages.
ListPublicFolders (inherited from ExchangeClientBase) | Gets collection of public folders from root public folder
ListSubFolders (inherited from ExchangeClientBase) | Overloaded. Gets collection of child folders from parent
ResolveContact (inherited from ExchangeClientBase) | Resolves ambiguous mailbox names.
Restore (inherited from ExchangeClientBase) | Overloaded. Restores exchange folders from the specified personal storage file.
SaveMessage (inherited from ExchangeClientBase) | Overloaded. Saves the message.
Send (inherited from ExchangeClientBase) | Sends the specified message.
SetReadFlag (inherited from ExchangeClientBase) | Sets the read flag.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Dispose (inherited from ExchangeClientBase) | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EWSClient Class | Aspose.Email.Exchange Namespace


GetEWSClient Method

Aspose.Email

EWSClient.GetEWSClient Method

Initializes a new instance of the EWSClient based class

Overload List

Initializes a new instance of the EWSClient based class

public static IEWSClient GetEWSClient(string,ICredentials);

Initializes a new instance of the EWSClient based class

public static IEWSClient GetEWSClient(string,ICredentials,WebProxy);

Initializes a new instance of the EWSClient based class

public static IEWSClient GetEWSClient(string,string,string);

Initializes a new instance of the EWSClient based class

public static IEWSClient GetEWSClient(string,string,string,WebProxy);

Initializes a new instance of the EWSClient based class

public static IEWSClient GetEWSClient(string,string,string,string);

Initializes a new instance of the EWSClient based class

public static IEWSClient GetEWSClient(string,string,string,string,WebProxy);

See Also

EWSClient Class | Aspose.Email.Exchange Namespace


EWSClient.GetEWSClient Method (String, ICredentials)

Initializes a new instance of the EWSClient based class

public static IEWSClient GetEWSClient(
string mailboxUri,
ICredentials credentials
);

Parameters

mailboxUri
The URI of mailbox
credentials
Contains the credentials for authentication.

Return Value

Instance of the class based on the EWSClient class.

See Also

EWSClient Class | Aspose.Email.Exchange Namespace | EWSClient.GetEWSClient Overload List


EWSClient.GetEWSClient Method (String, ICredentials, WebProxy)

Initializes a new instance of the EWSClient based class

public static IEWSClient GetEWSClient(
string mailboxUri,
ICredentials credentials,
WebProxy proxy
);

Parameters

mailboxUri
The URI of mailbox
credentials
Contains the credentials for authentication.
proxy
Contains HTTP proxy settings

Return Value

Instance of the class based on the EWSClient class.

See Also

EWSClient Class | Aspose.Email.Exchange Namespace | EWSClient.GetEWSClient Overload List


EWSClient.GetEWSClient Method (String, String, String)

Initializes a new instance of the EWSClient based class

public static IEWSClient GetEWSClient(
string mailboxUri,
string username,
string password
);

Parameters

mailboxUri
The URI of mailbox
username
The username
password
The password

Return Value

Instance of the class based on the EWSClient class.

See Also

EWSClient Class | Aspose.Email.Exchange Namespace | EWSClient.GetEWSClient Overload List


EWSClient.GetEWSClient Method (String, String, String, WebProxy)

Initializes a new instance of the EWSClient based class

public static IEWSClient GetEWSClient(
string mailboxUri,
string username,
string password,
WebProxy proxy
);

Parameters

mailboxUri
The URI of mailbox
username
The username
password
The password
proxy
Contains HTTP proxy settings

Return Value

Instance of the class based on the EWSClient class.

See Also

EWSClient Class | Aspose.Email.Exchange Namespace | EWSClient.GetEWSClient Overload List


EWSClient.GetEWSClient Method (String, String, String, String)

Initializes a new instance of the EWSClient based class

public static IEWSClient GetEWSClient(
string mailboxUri,
string username,
string password,
string domain
);

Parameters

mailboxUri
The URI of mailbox
username
The username
password
The password
domain
The domain name

Return Value

Instance of the class based on the EWSClient class.

See Also

EWSClient Class | Aspose.Email.Exchange Namespace | EWSClient.GetEWSClient Overload List


EWSClient.GetEWSClient Method (String, String, String, String, WebProxy)

Initializes a new instance of the EWSClient based class

public static IEWSClient GetEWSClient(
string mailboxUri,
string username,
string password,
string domain,
WebProxy proxy
);

Parameters

mailboxUri
The URI of mailbox
username
The username
password
The password
domain
The domain name
proxy
Contains HTTP proxy settings

Return Value

Instance of the class based on the EWSClient class.

See Also

EWSClient Class | Aspose.Email.Exchange Namespace | EWSClient.GetEWSClient Overload List


ExchangeAttachmentInfo Class

Represents an attachment information transmitted over exchange protocols

For a list of all members of this type, see ExchangeAttachmentInfo Members.

System.Object
Aspose.Email.Exchange.ExchangeAttachmentInfo

public sealed class ExchangeAttachmentInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExchangeAttachmentInfo Members | Aspose.Email.Exchange Namespace


ExchangeAttachmentInfo Members

ExchangeAttachmentInfo overview

Public Instance Constructors

ExchangeAttachmentInfo Constructor Initializes a new instance of the ExchangeAttachmentInfo class.

Public Instance Properties

AttachmentUri | Gets an attachment uri
Name | Gets an attachment name
Size | Gets an attachment size (in bytes)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ExchangeAttachmentInfo Class | Aspose.Email.Exchange Namespace


ExchangeAttachmentInfo Constructor

Initializes a new instance of the ExchangeAttachmentInfo class.

public ExchangeAttachmentInfo();

See Also

ExchangeAttachmentInfo Class | Aspose.Email.Exchange Namespace


ExchangeAttachmentInfo Properties

The properties of the ExchangeAttachmentInfo class are listed below. For a complete list of ExchangeAttachmentInfo class members, see the ExchangeAttachmentInfo Members topic.

Public Instance Properties

AttachmentUri | Gets an attachment uri
Name | Gets an attachment name
Size | Gets an attachment size (in bytes)

See Also

ExchangeAttachmentInfo Class | Aspose.Email.Exchange Namespace


AttachmentUri Property

Aspose.Email

ExchangeAttachmentInfo.AttachmentUri Property

Gets an attachment uri

public string AttachmentUri {get;}

See Also

ExchangeAttachmentInfo Class | Aspose.Email.Exchange Namespace


Name Property

Aspose.Email

ExchangeAttachmentInfo.Name Property

Gets an attachment name

public string Name {get;}

See Also

ExchangeAttachmentInfo Class | Aspose.Email.Exchange Namespace


Size Property

Aspose.Email

ExchangeAttachmentInfo.Size Property

Gets an attachment size (in bytes)

public int Size {get;}

See Also

ExchangeAttachmentInfo Class | Aspose.Email.Exchange Namespace


ExchangeAttachmentInfoCollection Class

Represents the collection of ExchangeAttachmentInfo

For a list of all members of this type, see ExchangeAttachmentInfoCollection Members.

System.Object
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Exchange.ExchangeAttachmentInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]]
Aspose.Email.Exchange.ExchangeAttachmentInfoCollection

public sealed class ExchangeAttachmentInfoCollection : Collection`1

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExchangeAttachmentInfoCollection Members | Aspose.Email.Exchange Namespace


ExchangeAttachmentInfoCollection Members

ExchangeAttachmentInfoCollection overview

Public Instance Constructors

ExchangeAttachmentInfoCollection Constructor Initializes a new instance of the ExchangeAttachmentInfoCollection class.

Public Instance Properties

Count (inherited from 0, Culture=neutral, PublicKeyToken=null]])
Item (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ExchangeAttachmentInfoCollection Class | Aspose.Email.Exchange Namespace


ExchangeAttachmentInfoCollection Constructor

Initializes a new instance of the ExchangeAttachmentInfoCollection class.

public ExchangeAttachmentInfoCollection();

See Also

ExchangeAttachmentInfoCollection Class | Aspose.Email.Exchange Namespace


ExchangeBasePermission Class

Provides abstract base class for permissions to folders on Exchange Server.

For a list of all members of this type, see ExchangeBasePermission Members.

System.Object
Aspose.Email.Exchange.ExchangeBasePermission
Aspose.Email.Exchange.ExchangeCalendarPermission
Aspose.Email.Exchange.ExchangeFolderPermission

public abstract class ExchangeBasePermission

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExchangeBasePermission Members | Aspose.Email.Exchange Namespace


ExchangeBasePermission Members

ExchangeBasePermission overview

Public Instance Properties

CanCreateItems | Gets or sets a value indicating whether a client can create items in a folder.
CanCreateSubFolders | Gets or sets a value indicating whether the client can create subfolders.
DeleteItems | Gets or sets a value indicating whether the client can delete items.
EditItems | Gets or sets a value indicating whether a client can edit items.
IsFolderContact | Gets or sets a value indicating whether a user is a contact for a folder.
IsFolderOwner | Gets or sets a value indicating whether the user is the owner of a folder.
IsFolderVisible | Gets or sets a value indicating whether a user can view a folder.
UserInfo | Gets or sets a user or a delegate user who has folder access permissions

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

ExchangeBasePermission Constructor

Protected Instance Fields

permissionSet

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExchangeBasePermission Class | Aspose.Email.Exchange Namespace


ExchangeBasePermission Constructor

protected ExchangeBasePermission(
ExchangeFolderUserInfo userInfo
);

See Also

ExchangeBasePermission Class | Aspose.Email.Exchange Namespace


ExchangeBasePermission Fields

The fields of the ExchangeBasePermission class are listed below. For a complete list of ExchangeBasePermission class members, see the ExchangeBasePermission Members topic.

Protected Instance Fields

permissionSet

See Also

ExchangeBasePermission Class | Aspose.Email.Exchange Namespace


ExchangeBasePermission.permissionSet Field

protected int permissionSet;

See Also

ExchangeBasePermission Class | Aspose.Email.Exchange Namespace


ExchangeBasePermission Properties

The properties of the ExchangeBasePermission class are listed below. For a complete list of ExchangeBasePermission class members, see the ExchangeBasePermission Members topic.

Public Instance Properties

CanCreateItems | Gets or sets a value indicating whether a client can create items in a folder.
CanCreateSubFolders | Gets or sets a value indicating whether the client can create subfolders.
DeleteItems | Gets or sets a value indicating whether the client can delete items.
EditItems | Gets or sets a value indicating whether a client can edit items.
IsFolderContact | Gets or sets a value indicating whether a user is a contact for a folder.
IsFolderOwner | Gets or sets a value indicating whether the user is the owner of a folder.
IsFolderVisible | Gets or sets a value indicating whether a user can view a folder.
UserInfo | Gets or sets a user or a delegate user who has folder access permissions

See Also

ExchangeBasePermission Class | Aspose.Email.Exchange Namespace


CanCreateItems Property

Aspose.Email

ExchangeBasePermission.CanCreateItems Property

Gets or sets a value indicating whether a client can create items in a folder.

public bool CanCreateItems {get; set;}

See Also

ExchangeBasePermission Class | Aspose.Email.Exchange Namespace


CanCreateSubFolders Property

Aspose.Email

ExchangeBasePermission.CanCreateSubFolders Property

Gets or sets a value indicating whether the client can create subfolders.

public bool CanCreateSubFolders {get; set;}

See Also

ExchangeBasePermission Class | Aspose.Email.Exchange Namespace


DeleteItems Property

Aspose.Email

ExchangeBasePermission.DeleteItems Property

Gets or sets a value indicating whether the client can delete items.

public ExchangeFolderPermissionAction DeleteItems {get; set;}

See Also

ExchangeBasePermission Class | Aspose.Email.Exchange Namespace


EditItems Property

Aspose.Email

ExchangeBasePermission.EditItems Property

Gets or sets a value indicating whether a client can edit items.

public ExchangeFolderPermissionAction EditItems {get; set;}

See Also

ExchangeBasePermission Class | Aspose.Email.Exchange Namespace


IsFolderContact Property

Aspose.Email

ExchangeBasePermission.IsFolderContact Property

Gets or sets a value indicating whether a user is a contact for a folder.

public bool IsFolderContact {get; set;}

See Also

ExchangeBasePermission Class | Aspose.Email.Exchange Namespace


IsFolderOwner Property

Aspose.Email

ExchangeBasePermission.IsFolderOwner Property

Gets or sets a value indicating whether the user is the owner of a folder.

public bool IsFolderOwner {get; set;}

See Also

ExchangeBasePermission Class | Aspose.Email.Exchange Namespace


IsFolderVisible Property

Aspose.Email

ExchangeBasePermission.IsFolderVisible Property

Gets or sets a value indicating whether a user can view a folder.

public bool IsFolderVisible {get; set;}

See Also

ExchangeBasePermission Class | Aspose.Email.Exchange Namespace


UserInfo Property

Aspose.Email

ExchangeBasePermission.UserInfo Property

Gets or sets a user or a delegate user who has folder access permissions

public ExchangeFolderUserInfo UserInfo {get; set;}

Exceptions

Exception Type | Condition
ArgumentNullException | value is null

See Also

ExchangeBasePermission Class | Aspose.Email.Exchange Namespace


ExchangeCalendarEvent Class

Represents the event in the user's calendar

For a list of all members of this type, see ExchangeCalendarEvent Members.

System.Object
Aspose.Email.Exchange.ExchangeCalendarEvent

public sealed class ExchangeCalendarEvent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExchangeCalendarEvent Members | Aspose.Email.Exchange Namespace


ExchangeCalendarEvent Members

ExchangeCalendarEvent overview

Public Instance Constructors

ExchangeCalendarEvent Constructor Initializes a new instance of the ExchangeCalendarEvent class.

Public Instance Properties

Busyness | Gets the user busyness.
Duration | Gets the event duration.
Location | Gets the appointment location.
Subject | Gets the calendar event subject.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ExchangeCalendarEvent Class | Aspose.Email.Exchange Namespace


ExchangeCalendarEvent Constructor

Initializes a new instance of the ExchangeCalendarEvent class.

public ExchangeCalendarEvent();

See Also

ExchangeCalendarEvent Class | Aspose.Email.Exchange Namespace


ExchangeCalendarEvent Properties

The properties of the ExchangeCalendarEvent class are listed below. For a complete list of ExchangeCalendarEvent class members, see the ExchangeCalendarEvent Members topic.

Public Instance Properties

Busyness | Gets the user busyness.
Duration | Gets the event duration.
Location | Gets the appointment location.
Subject | Gets the calendar event subject.

See Also

ExchangeCalendarEvent Class | Aspose.Email.Exchange Namespace


Busyness Property

Aspose.Email

ExchangeCalendarEvent.Busyness Property

Gets the user busyness.

public ExchangeUserBusyness Busyness {get; set;}

See Also

ExchangeCalendarEvent Class | Aspose.Email.Exchange Namespace


Duration Property

Aspose.Email

ExchangeCalendarEvent.Duration Property

Gets the event duration.

public DateRange Duration {get; set;}

See Also

ExchangeCalendarEvent Class | Aspose.Email.Exchange Namespace


Location Property

Aspose.Email

ExchangeCalendarEvent.Location Property

Gets the appointment location.

public string Location {get; set;}

See Also

ExchangeCalendarEvent Class | Aspose.Email.Exchange Namespace


Subject Property

Aspose.Email

ExchangeCalendarEvent.Subject Property

Gets the calendar event subject.

public string Subject {get; set;}

See Also

ExchangeCalendarEvent Class | Aspose.Email.Exchange Namespace


ExchangeCalendarEventCollection Class

Represents the collection of ExchangeCalendarEvent

For a list of all members of this type, see ExchangeCalendarEventCollection Members.

System.Object
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Exchange.ExchangeCalendarEvent, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]]
Aspose.Email.Exchange.ExchangeCalendarEventCollection

public sealed class ExchangeCalendarEventCollection : Collection`1

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExchangeCalendarEventCollection Members | Aspose.Email.Exchange Namespace


ExchangeCalendarEventCollection Members

ExchangeCalendarEventCollection overview

Public Instance Constructors

ExchangeCalendarEventCollection Constructor Initializes a new instance of the ExchangeCalendarEventCollection class.

Public Instance Properties

Count (inherited from 0, Culture=neutral, PublicKeyToken=null]])
Item (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ExchangeCalendarEventCollection Class | Aspose.Email.Exchange Namespace


ExchangeCalendarEventCollection Constructor

Initializes a new instance of the ExchangeCalendarEventCollection class.

public ExchangeCalendarEventCollection();

See Also

ExchangeCalendarEventCollection Class | Aspose.Email.Exchange Namespace


ExchangeCalendarPermission Class

Represents a permission on a calendar folder.

For a list of all members of this type, see ExchangeCalendarPermission Members.

System.Object
Aspose.Email.Exchange.ExchangeBasePermission
Aspose.Email.Exchange.ExchangeCalendarPermission

public sealed class ExchangeCalendarPermission : ExchangeBasePermission

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExchangeCalendarPermission Members | Aspose.Email.Exchange Namespace


ExchangeCalendarPermission Members

ExchangeCalendarPermission overview

Public Static Type Conversions

Implicit CalendarPermissionType to ExchangeCalendarPermission Conversion Performs an implicit conversion from CalendarPermissionType to ExchangeCalendarPermission.

Public Instance Constructors

ExchangeCalendarPermission Constructor Initializes a new instance of the ExchangeFolderPermission class

Public Instance Properties

CanCreateItems (inherited from ExchangeBasePermission) | Gets or sets a value indicating whether a client can create items in a folder.
CanCreateSubFolders (inherited from ExchangeBasePermission) | Gets or sets a value indicating whether the client can create subfolders.
DeleteItems (inherited from ExchangeBasePermission) | Gets or sets a value indicating whether the client can delete items.
EditItems (inherited from ExchangeBasePermission) | Gets or sets a value indicating whether a client can edit items.
IsFolderContact (inherited from ExchangeBasePermission) | Gets or sets a value indicating whether a user is a contact for a folder.
IsFolderOwner (inherited from ExchangeBasePermission) | Gets or sets a value indicating whether the user is the owner of a folder.
IsFolderVisible (inherited from ExchangeBasePermission) | Gets or sets a value indicating whether a user can view a folder.
PermissionLevel | Gets or sets the combination of permissions that a user has on a folder.
ReadItems | Gets or sets a value indicating whether a user has permission to read items in a folder.
UserInfo (inherited from ExchangeBasePermission) | Gets or sets a user or a delegate user who has folder access permissions

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ExchangeCalendarPermission Class | Aspose.Email.Exchange Namespace


ExchangeCalendarPermission Constructor

Initializes a new instance of the ExchangeFolderPermission class

public ExchangeCalendarPermission(
ExchangeFolderUserInfo userInfo
);

Parameters

userInfo
Specifies a user or a delegate user who has folder access permissions

Exceptions

Exception Type | Condition
ArgumentNullException | userInfo is null

See Also

ExchangeCalendarPermission Class | Aspose.Email.Exchange Namespace


ExchangeCalendarPermission Properties

The properties of the ExchangeCalendarPermission class are listed below. For a complete list of ExchangeCalendarPermission class members, see the ExchangeCalendarPermission Members topic.

Public Instance Properties

CanCreateItems (inherited from ExchangeBasePermission) | Gets or sets a value indicating whether a client can create items in a folder.
CanCreateSubFolders (inherited from ExchangeBasePermission) | Gets or sets a value indicating whether the client can create subfolders.
DeleteItems (inherited from ExchangeBasePermission) | Gets or sets a value indicating whether the client can delete items.
EditItems (inherited from ExchangeBasePermission) | Gets or sets a value indicating whether a client can edit items.
IsFolderContact (inherited from ExchangeBasePermission) | Gets or sets a value indicating whether a user is a contact for a folder.
IsFolderOwner (inherited from ExchangeBasePermission) | Gets or sets a value indicating whether the user is the owner of a folder.
IsFolderVisible (inherited from ExchangeBasePermission) | Gets or sets a value indicating whether a user can view a folder.
PermissionLevel | Gets or sets the combination of permissions that a user has on a folder.
ReadItems | Gets or sets a value indicating whether a user has permission to read items in a folder.
UserInfo (inherited from ExchangeBasePermission) | Gets or sets a user or a delegate user who has folder access permissions

See Also

ExchangeCalendarPermission Class | Aspose.Email.Exchange Namespace


PermissionLevel Property

Aspose.Email

ExchangeCalendarPermission.PermissionLevel Property

Gets or sets the combination of permissions that a user has on a folder.

public ExchangeCalendarPermissionLevel PermissionLevel {get; set;}

See Also

ExchangeCalendarPermission Class | Aspose.Email.Exchange Namespace


ReadItems Property

Aspose.Email

ExchangeCalendarPermission.ReadItems Property

Gets or sets a value indicating whether a user has permission to read items in a folder.

public ExchangeCalendarPermissionReadAccess ReadItems {get; set;}

See Also

ExchangeCalendarPermission Class | Aspose.Email.Exchange Namespace


ExchangeCalendarPermission Type Conversions

The type conversions of the ExchangeCalendarPermission class are listed below. For a complete list of ExchangeCalendarPermission class members, see the ExchangeCalendarPermission Members topic.

Public Static Type Conversions

Implicit CalendarPermissionType to ExchangeCalendarPermission Conversion Performs an implicit conversion from CalendarPermissionType to ExchangeCalendarPermission.

See Also

ExchangeCalendarPermission Class | ExchangeCalendarPermission Members | Aspose.Email.Exchange Namespace


ExchangeCalendarPermission Implicit CalendarPermissionType to ExchangeCalendarPermission Conversion

Performs an implicit conversion from CalendarPermissionType to ExchangeCalendarPermission.

public static implicit operator ExchangeCalendarPermission(
CalendarPermissionType permission
);

Parameters

permission
The CalendarPermissionType that defines the access that a user has to a calendar folder.

Return Value

The result of the conversion.

See Also

ExchangeCalendarPermission Class | Aspose.Email.Exchange Namespace


ExchangeCalendarPermissionLevel Enumeration

Specifies the permission level that a user has on a calendar folder.

public enum ExchangeCalendarPermissionLevel

Members

Member Name | Description | Value
None | The user has no permissions on the folder. | 0
Owner | The user can create, read, edit, and delete all items in the folder and create subfolders. The user is both folder owner and folder contact. | 983
PublishingEditor | The user can create, read, edit, and delete all items in the folder, and create subfolders. | 215
Editor | The user can create, read, edit, and delete all items in the folder. | 87
PublishingAuthor | The user can create and read all items in the folder, edit and delete only items that the user creates, and create subfolders. | 175
Author | The user can create and read all items in the folder, and edit and delete only items that the user creates. | 47
NoneditingAuthor | The user can create and read all items in the folder, and delete only items that the user creates. | 15
Reviewer | The user can read all items in the folder. | 3
Contributor | The user can create items in the folder. The contents of the folder do not appear. | 5
FreeBusyTimeOnly | The user can view only free/busy time within the calendar. | 1024
FreeBusyTimeAndSubjectAndLocation | The user can view free/busy time within the calendar and the subject and location of appointments. | 2048
Custom | The user has custom access permissions on the folder. | 1073741824

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange Namespace


ExchangeCalendarPermissionReadAccess Enumeration

Sspecifies whether a user has permission to read items in a folder.

public enum ExchangeCalendarPermissionReadAccess

Members

Member Name | Description | Value
None | The user does not have permission to read items in the folder. | 0
FullDetails | The user has permission to read all items in the folder. | 1
TimeOnly | The user can view only free/busy time within the calendar. | 2
TimeAndSubjectAndLocation | The user can view free/busy time within the calendar and the subject and location of appointments. | 4

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange Namespace


ExchangeClient Class

The ExchangeClient class allows applications to manage E-Mail box in Microsoft Exchange Server by using WebDav Exchange Store Protocol.

For a list of all members of this type, see ExchangeClient Members.

System.Object
Aspose.Email.Exchange.ExchangeClientBase
Aspose.Email.Exchange.ExchangeClient

public sealed class ExchangeClient : ExchangeClientBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

The following exmaple demonstrates how to use ExchangeClient class to fetch e-mail messages from the Exchange Server.

[C#]

[Visual Basic]

Requirements
Namespace:  Aspose.Email.Exchange
Assembly: Aspose.Email (in Aspose.Email.dll)

See Also
ExchangeClient Members | Aspose.Email.Exchange Namespace


ExchangeClient Members

ExchangeClient overview

Public Instance Constructors

ExchangeClient Overloaded. Initializes a new instance of the ExchangeClient class.

Public Instance Properties

ClientCertificate | Gets or sets the client certificate.
CookieContainer | Gets or sets the cookie container.
Credentials | Gets or sets the credentials.
Encoding | Gets or sets the encoding.
KeepAlive | Indicates whether to keep alive.
MailboxInfo | Gets the mailbox information.
MailboxUri | Gets or sets the mailbox uri.
PreAuthenticate | Indicates whether to do pre-authentication.
Proxy | Gets or sets the proxy.
SendChunked | Gets or sets a value indicating whether [send chunked].
Timeout | Gets or sets the number of milliseconds to wait before the operation times out. The default value is 100,000 milliseconds (100 seconds).

Public Instance Methods

AppendMessage | Overloaded. Uploads the mail message to the specified folder
Backup | Overloaded. Backups the content of the specified folders
CreateContact | Creates a contact item in the Exchange store.
CreateFolder | Creates the new folder with the specified name in the specified parent folder.
DeleteContact | Overloaded. Deletes the contact.
DeleteFolder | Deletes the folder
DeleteMessage | Overloaded. Deletes the mail message.
Dispose (inherited from ExchangeClientBase) | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FetchAttachment | Fetches the attachment
FetchMapiMessage | Fetches the mapi message with specified uri.
FetchMessage | Fetches the mail message with specified uri.
FolderExists | Overloaded.
FolderExists (inherited from ExchangeClientBase) | Overloaded. Checks whether the specified folder exists.
GetFolderInfo | Gets the folder information.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetMailboxInfo | Overloaded. Get the information of the mailbox
GetMailboxSize | Overloaded. Get the size of the maibox
GetType (inherited from Object) | Gets the Type of the current instance.
GetVersionInfo | Returns exchange server version info
ListContacts | Lists contacts located in the specified folder on server
ListMailboxes | Lists mailboxes in the global address list.
ListMessages | Overloaded. Lists the messages.
ListMessages (inherited from ExchangeClientBase) | Overloaded. Lists the messages.
ListMessagesById | Lists the messages by id.
ListPublicFolders | Gets collection of public folders from root public folder
ListSubFolders | Overloaded. Gets collection of child folders from parent
ListSubFolders (inherited from ExchangeClientBase) | Overloaded. Gets collection of child folders from parent
MoveItem | Moves the item.
MoveMessage | Overloaded. Moves the message.
ResolveContact | Resolves ambiguous mailbox display names. Note: the maximum count of returned contacts is 100. This is a restriction of used exchange command.
Restore | Overloaded. Restores exchange folders from the specified personal storage file.
SaveMessage | Overloaded. Saves mail message specified by the uri to local file system. The mail message file is RFC 822 compliant format (EML). if you want to parse the mail message files, use MailMessage.
Send | Sends the mail message.
SetReadFlag | Overloaded. Marks the specifeid message as read.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace


ExchangeClient Constructor

Initialize a new instance of the class ExchageClient

Overload List

Initialize a new instance of the class ExchageClient

public ExchangeClient(string,ICredentials);

Initialize a new instance of the class ExchageClient

public ExchangeClient(string,string,string);

Initialize a new instance of the class ExchageClient

public ExchangeClient(string,string,string,string);

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace


ExchangeClient Constructor (String, String, String)

Initialize a new instance of the class ExchageClient

public ExchangeClient(
string mailboxUri,
string username,
string password
);

Parameters

mailboxUri
The url of the mailbox
username
The username of the mailbox
password
The password of the mailbox

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace | ExchangeClient Constructor Overload List


ExchangeClient Constructor (String, String, String, String)

Initialize a new instance of the class ExchageClient

public ExchangeClient(
string mailboxUri,
string username,
string password,
string domain
);

Parameters

mailboxUri
The url of the mailbox
username
The username of the mailbox
password
The password of the mailbox
domain
The domain of the user

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace | ExchangeClient Constructor Overload List


ExchangeClient Constructor (String, ICredentials)

Initialize a new instance of the class ExchageClient

public ExchangeClient(
string mailboxUri,
ICredentials credentials
);

Parameters

mailboxUri
The url of the mailbox
credentials
The credentials used to log in

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace | ExchangeClient Constructor Overload List


ExchangeClient Properties

The properties of the ExchangeClient class are listed below. For a complete list of ExchangeClient class members, see the ExchangeClient Members topic.

Public Instance Properties

ClientCertificate | Gets or sets the client certificate.
CookieContainer | Gets or sets the cookie container.
Credentials | Gets or sets the credentials.
Encoding | Gets or sets the encoding.
KeepAlive | Indicates whether to keep alive.
MailboxInfo | Gets the mailbox information.
MailboxUri | Gets or sets the mailbox uri.
PreAuthenticate | Indicates whether to do pre-authentication.
Proxy | Gets or sets the proxy.
SendChunked | Gets or sets a value indicating whether [send chunked].
Timeout | Gets or sets the number of milliseconds to wait before the operation times out. The default value is 100,000 milliseconds (100 seconds).

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace


ClientCertificate Property

Aspose.Email

ExchangeClient.ClientCertificate Property

Gets or sets the client certificate.

public X509Certificate ClientCertificate {get; set;}

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace


CookieContainer Property

Aspose.Email

ExchangeClient.CookieContainer Property

Gets or sets the cookie container.

public CookieContainer CookieContainer {get; set;}

Property Value

The cookie container.

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace


Credentials Property

Aspose.Email

ExchangeClient.Credentials Property

Gets or sets the credentials.

public override ICredentials Credentials {get; set;}

Implements

IExchangeClientBase.Credentials

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace


Encoding Property

Aspose.Email

ExchangeClient.Encoding Property

Gets or sets the encoding.

public Encoding Encoding {get; set;}

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace


KeepAlive Property

Aspose.Email

ExchangeClient.KeepAlive Property

Indicates whether to keep alive.

public bool KeepAlive {get; set;}

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace


MailboxInfo Property

Aspose.Email

ExchangeClient.MailboxInfo Property

Gets the mailbox information.

public override ExchangeMailboxInfo MailboxInfo {get;}

Implements

IExchangeClientBase.MailboxInfo

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace


MailboxUri Property

Aspose.Email

ExchangeClient.MailboxUri Property

Gets or sets the mailbox uri.

public override string MailboxUri {get; set;}

Implements

IExchangeClientBase.MailboxUri

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace


PreAuthenticate Property

Aspose.Email

ExchangeClient.PreAuthenticate Property

Indicates whether to do pre-authentication.

public bool PreAuthenticate {get; set;}

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace


Proxy Property

Aspose.Email

ExchangeClient.Proxy Property

Gets or sets the proxy.

public override WebProxy Proxy {get; set;}

Implements

IExchangeClientBase.Proxy

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace


SendChunked Property

Aspose.Email

ExchangeClient.SendChunked Property

Gets or sets a value indicating whether [send chunked].

public bool SendChunked {get; set;}

Property Value

true if [send chunked]; otherwise, false.

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace


Timeout Property

Aspose.Email

ExchangeClient.Timeout Property

Gets or sets the number of milliseconds to wait before the operation times out. The default value is 100,000 milliseconds (100 seconds).

public override int Timeout {get; set;}

Implements

IExchangeClientBase.Timeout

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace


ExchangeClient Methods

The methods of the ExchangeClient class are listed below. For a complete list of ExchangeClient class members, see the ExchangeClient Members topic.

Public Instance Methods

AppendMessage | Overloaded. Uploads the mail message to the specified folder
Backup | Overloaded. Backups the content of the specified folders
CreateContact | Creates a contact item in the Exchange store.
CreateFolder | Creates the new folder with the specified name in the specified parent folder.
DeleteContact | Overloaded. Deletes the contact.
DeleteFolder | Deletes the folder
DeleteMessage | Overloaded. Deletes the mail message.
Dispose (inherited from ExchangeClientBase) | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FetchAttachment | Fetches the attachment
FetchMapiMessage | Fetches the mapi message with specified uri.
FetchMessage | Fetches the mail message with specified uri.
FolderExists | Overloaded.
FolderExists (inherited from ExchangeClientBase) | Overloaded. Checks whether the specified folder exists.
GetFolderInfo | Gets the folder information.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetMailboxInfo | Overloaded. Get the information of the mailbox
GetMailboxSize | Overloaded. Get the size of the maibox
GetType (inherited from Object) | Gets the Type of the current instance.
GetVersionInfo | Returns exchange server version info
ListContacts | Lists contacts located in the specified folder on server
ListMailboxes | Lists mailboxes in the global address list.
ListMessages | Overloaded. Lists the messages.
ListMessages (inherited from ExchangeClientBase) | Overloaded. Lists the messages.
ListMessagesById | Lists the messages by id.
ListPublicFolders | Gets collection of public folders from root public folder
ListSubFolders | Overloaded. Gets collection of child folders from parent
ListSubFolders (inherited from ExchangeClientBase) | Overloaded. Gets collection of child folders from parent
MoveItem | Moves the item.
MoveMessage | Overloaded. Moves the message.
ResolveContact | Resolves ambiguous mailbox display names. Note: the maximum count of returned contacts is 100. This is a restriction of used exchange command.
Restore | Overloaded. Restores exchange folders from the specified personal storage file.
SaveMessage | Overloaded. Saves mail message specified by the uri to local file system. The mail message file is RFC 822 compliant format (EML). if you want to parse the mail message files, use MailMessage.
Send | Sends the mail message.
SetReadFlag | Overloaded. Marks the specifeid message as read.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace


AppendMessage Method

Aspose.Email

ExchangeClient.AppendMessage Method

Uploads the mail message to the specified folder

Overload List

Uploads the mail message to the specified folder

public override string AppendMessage(string,MailMessage);

Uploads the mail message to the specified folder

public override string AppendMessage(string,MailMessage,bool);

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace


ExchangeClient.AppendMessage Method (String, MailMessage)

Uploads the mail message to the specified folder

public override string AppendMessage(
string folder,
MailMessage message
);

Parameters

folder
A folder to which message is uploaded
message
A message to upload

Return Value

An uri of created message

Implements

IExchangeClientBase.AppendMessage

Exceptions

Exception Type | Condition
ArgumentException | A folder is not specified
ArgumentNullException | message is null

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace | ExchangeClient.AppendMessage Overload List


ExchangeClient.AppendMessage Method (String, MailMessage, Boolean)

Uploads the mail message to the specified folder

public override string AppendMessage(
string folder,
MailMessage message,
bool markAsSent
);

Parameters

folder
An uri of folder to which message is uploaded
message
A message to upload
markAsSent
A value indicating whether the message should be appended as a sent message or a draft.

Return Value

An uri of created message

Implements

IExchangeClientBase.AppendMessage

Exceptions

Exception Type | Condition
ArgumentException | A folder is not specified
ArgumentNullException | message is null

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace | ExchangeClient.AppendMessage Overload List


Backup Method

Aspose.Email

ExchangeClient.Backup Method

Backups the content of the specified folders

Overload List

Backups the content of the specified folders

public override void Backup(ExchangeFolderInfoCollection,Stream,BackupOptions);

Backups the content of the specified folders

public override void Backup(ExchangeFolderInfoCollection,string,BackupOptions);

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace


ExchangeClient.Backup Method (ExchangeFolderInfoCollection, Stream, BackupOptions)

Backups the content of the specified folders

public override void Backup(
ExchangeFolderInfoCollection folders,
Stream stream,
BackupOptions options
);

Parameters

folders
A folders to backup
stream
A stream to write into
options
A backup options

Implements

IExchangeClientBase.Backup

Exceptions

Exception Type | Condition
NotSupportedException | The given stream does not support writting
ArgumentNullException | folders or stream is null

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace | ExchangeClient.Backup Overload List


ExchangeClient.Backup Method (ExchangeFolderInfoCollection, String, BackupOptions)

Backups the content of the specified folders

public override void Backup(
ExchangeFolderInfoCollection folders,
string fileName,
BackupOptions options
);

Parameters

folders
A folders to backup
fileName
A path to the presonal storage file
options
A backup options

Implements

IExchangeClientBase.Backup

Exceptions

Exception Type | Condition
ArgumentException | A fileName is null or empty
ArgumentNullException | folders is null

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace | ExchangeClient.Backup Overload List


ExchangeClient.CreateContact Method

Creates a contact item in the Exchange store.

public override string CreateContact(
MapiContact contact
);

Parameters

contact
Contact item

Return Value

The contact Uri

Implements

IExchangeClientBase.CreateContact

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace


ExchangeClient.CreateFolder Method

Creates the new folder with the specified name in the specified parent folder.

public override void CreateFolder(
string parentFolderUri,
string name
);

Parameters

parentFolderUri
An uri of parent folder.
name
A name of folder to be created.

Implements

IExchangeClientBase.CreateFolder

Exceptions

Exception Type | Condition
ArgumentException | parentFolderUri or name is null or empty.

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace


DeleteContact Method

Aspose.Email

ExchangeClient.DeleteContact Method

Deletes the contact.

Overload List

Deletes the contact.

public override void DeleteContact(MapiContact);

Deletes the contact.

public override void DeleteContact(string);

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace


ExchangeClient.DeleteContact Method (MapiContact)

Deletes the contact.

public override void DeleteContact(
MapiContact contact
);

Parameters

contact
Contact

Implements

IExchangeClientBase.DeleteContact

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace | ExchangeClient.DeleteContact Overload List


ExchangeClient.DeleteContact Method (String)

Deletes the contact.

public override void DeleteContact(
string id
);

Parameters

id
The contact identifier.

Implements

IExchangeClientBase.DeleteContact

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace | ExchangeClient.DeleteContact Overload List


ExchangeClient.DeleteFolder Method

Deletes the folder

public override void DeleteFolder(
string folderUri
);

Parameters

folderUri
The folder Uri

Implements

IExchangeClientBase.DeleteFolder

Exceptions

Exception Type | Condition
ArgumentException | folderUri is null or empty

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace


DeleteMessage Method

Aspose.Email

ExchangeClient.DeleteMessage Method

Deletes the mail message.

Overload List

Deletes the mail message.

public override void DeleteMessage(string);

Deletes the mail message.

public void DeleteMessage(string,bool);

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace


ExchangeClient.DeleteMessage Method (String)

Deletes the mail message.

public override void DeleteMessage(
string messageUri
);

Parameters

messageUri
The message uri.

Implements

IExchangeClientBase.DeleteMessage

Exceptions

Exception Type | Condition
ArgumentException | messageUri is empty.
ArgumentNullException | messageUri is null.

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace | ExchangeClient.DeleteMessage Overload List


ExchangeClient.DeleteMessage Method (String, Boolean)

Deletes the mail message.

public void DeleteMessage(
string messageUri,
bool suppressReceipt
);

Parameters

messageUri
The message uri.
suppressReceipt
A value indicating whether the sending a non-read report should be suppressed.

Exceptions

Exception Type | Condition
ArgumentException | messageUri is empty.
ArgumentNullException | messageUri is null.

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace | ExchangeClient.DeleteMessage Overload List


ExchangeClient.FetchAttachment Method

Fetches the attachment

public override Attachment FetchAttachment(
string attachmentUri
);

Parameters

attachmentUri
The attachment uri. (Attachment uri can be retrieved using ListMessages(folder, ExchangeListMessagesOptions.FetchAttachmentInformation) method)

Return Value

Attachment that represents fetched attachment

Implements

IExchangeClientBase.FetchAttachment

Exceptions

Exception Type | Condition
ArgumentException | attachmentUri is null or empty

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace


ExchangeClient.FetchMapiMessage Method

Fetches the mapi message with specified uri.

public MapiMessage FetchMapiMessage(
string messageUri
);

Parameters

messageUri
The message uri.

Return Value

A MapiMessage object contains the message.

Exceptions

Exception Type | Condition
ArgumentNullException | messageUri is null
ArgumentException | messageUri is empty string

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace


ExchangeClient.FetchMessage Method

Fetches the mail message with specified uri.

public override MailMessage FetchMessage(
string messageUri
);

Parameters

messageUri
The message uri.

Return Value

A MailMessage object contains the message.

Implements

IExchangeClientBase.FetchMessage

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace


FolderExists Method

Aspose.Email

ExchangeClient.FolderExists Method

Overload List

Inherited from ExchangeClientBase.

public bool FolderExists(string,string);

public override bool FolderExists(string,string,out ExchangeFolderInfo);

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace


ExchangeClient.FolderExists Method (String, String, ExchangeFolderInfo)

public override bool FolderExists(
string parentFolderUri,
string folderName,
out ExchangeFolderInfo folder
);

Implements

IExchangeClientBase.FolderExists

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace | ExchangeClient.FolderExists Overload List


ExchangeClient.GetFolderInfo Method

Gets the folder information.

public ExchangeFolderInfo GetFolderInfo(
string folderUri
);

Parameters

folderUri
A folder uri.

Return Value

A ExchangeFolderInfo that represents the folder information.

Exceptions

Exception Type | Condition
ArgumentException | folderUri is null or empty.
ExchangeException | Server responded an error message.

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace


GetMailboxInfo Method

Aspose.Email

ExchangeClient.GetMailboxInfo Method

Get the information of the mailbox

Overload List

Get the information of the mailbox

public override ExchangeMailboxInfo GetMailboxInfo();

Gets the mailbox information

public override ExchangeMailboxInfo GetMailboxInfo(string);

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace


ExchangeClient.GetMailboxInfo Method ()

Get the information of the mailbox

public override ExchangeMailboxInfo GetMailboxInfo();

Return Value

The information of the mailbox

Implements

IExchangeClientBase.GetMailboxInfo

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace | ExchangeClient.GetMailboxInfo Overload List


ExchangeClient.GetMailboxInfo Method (String)

Gets the mailbox information

public override ExchangeMailboxInfo GetMailboxInfo(
string mailbox
);

Parameters

mailbox
A mailbox to read from. Note: if mailbox is set to null or empty the default mailbox will be used

Return Value

ExchangeMailboxInfo that represents mailbox information

Implements

IExchangeClientBase.GetMailboxInfo

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace | ExchangeClient.GetMailboxInfo Overload List


GetMailboxSize Method

Aspose.Email

ExchangeClient.GetMailboxSize Method

Get the size of the maibox

Overload List

Get the size of the maibox

public override long GetMailboxSize();

Get the size of the maibox

public override long GetMailboxSize(string);

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace


ExchangeClient.GetMailboxSize Method ()

Get the size of the maibox

public override long GetMailboxSize();

Return Value

The size of the mailbox

Implements

IExchangeClientBase.GetMailboxSize

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace | ExchangeClient.GetMailboxSize Overload List


ExchangeClient.GetMailboxSize Method (String)

Get the size of the maibox

public override long GetMailboxSize(
string mailbox
);

Parameters

mailbox
A mailbox. Note: if it is set to null or empty the default mailbox will be used

Return Value

The size of the mailbox

Implements

IExchangeClientBase.GetMailboxSize

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace | ExchangeClient.GetMailboxSize Overload List


ExchangeClient.GetVersionInfo Method

Returns exchange server version info

public override string GetVersionInfo();

Return Value

Returns exchange server version info

Implements

IExchangeClientBase.GetVersionInfo

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace


ExchangeClient.ListContacts Method

Lists contacts located in the specified folder on server

public override MapiContact[] ListContacts(
string folderUri
);

Parameters

folderUri
The URI of folder

Return Value

An array of read MapiContact that represents contact information

Implements

IExchangeClientBase.ListContacts

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace


ExchangeClient.ListMailboxes Method

Lists mailboxes in the global address list.

public override MapiContactCollection ListMailboxes();

Return Value

A MapiContactCollection that represents contact information.

Implements

IExchangeClientBase.ListMailboxes

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace


ListMessages Method

Aspose.Email

ExchangeClient.ListMessages Method

Lists the mail message in the specified folder.

Overload List

Inherited from ExchangeClientBase.

public ExchangeMessageInfoCollection ListMessages(string);

Lists the mail message in the specified folder.

public override ExchangeMessageInfoCollection ListMessages(string,ExchangeListMessagesOptions);

Lists the messages.

public ExchangeMessageInfoCollection ListMessages(string,MailQuery,bool);

List the messages in the specified folder

public ExchangeMessageInfoCollection ListMessages(string,bool);

Inherited from ExchangeClientBase.

public ExchangeMessageInfoCollection ListMessages(string,int);

List the messages in the specified folder

public override ExchangeMessageInfoCollection ListMessages(string,int,ExchangeListMessagesOptions);

Lists the messages.

public ExchangeMessageInfoCollection ListMessages(string,string);

Lists the messages.

public ExchangeMessageInfoCollection ListMessages(string,string,bool);

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace


ExchangeClient.ListMessages Method (String, ExchangeListMessagesOptions)

Lists the mail message in the specified folder.

public override ExchangeMessageInfoCollection ListMessages(
string folder,
ExchangeListMessagesOptions options
);

Parameters

folder
The folder url
options
Specifies the settings of listing

Return Value

A ExchangeMessageInfoCollection collection.

Implements

IExchangeClientBase.ListMessages

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace | ExchangeClient.ListMessages Overload List


ExchangeClient.ListMessages Method (String, MailQuery, Boolean)

Lists the messages.

public ExchangeMessageInfoCollection ListMessages(
string folder,
MailQuery query,
bool recursive
);

Parameters

folder
The Uri of folder that contains messages.
query
The MailQuery that represents search criteria.
recursive
Indicates whether recursive listing or not.

Return Value

The message info collection.

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace | ExchangeClient.ListMessages Overload List


ExchangeClient.ListMessages Method (String, Boolean)

List the messages in the specified folder

public ExchangeMessageInfoCollection ListMessages(
string folder,
bool recursive
);

Parameters

folder
The folder Uri
recursive
Indicates whether recursive listing or not.

Return Value

A collection of message info

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace | ExchangeClient.ListMessages Overload List


ExchangeClient.ListMessages Method (String, Int32, ExchangeListMessagesOptions)

List the messages in the specified folder

public override ExchangeMessageInfoCollection ListMessages(
string folder,
int maxNumberOfMessages,
ExchangeListMessagesOptions options
);

Parameters

folder
The folder Uri
maxNumberOfMessages
Maximum number of messages
options
Specifies the settings of listing

Return Value

A collection of message info

Implements

IExchangeClientBase.ListMessages

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace | ExchangeClient.ListMessages Overload List


ExchangeClient.ListMessages Method (String, String)

Lists the messages.

public ExchangeMessageInfoCollection ListMessages(
string folder,
string query
);

Parameters

folder
The folder.
query
The query.

Return Value

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace | ExchangeClient.ListMessages Overload List


ExchangeClient.ListMessages Method (String, String, Boolean)

Lists the messages.

public ExchangeMessageInfoCollection ListMessages(
string folder,
string messageClass,
bool recursive
);

Parameters

folder
The folder.
messageClass
The message class.
recursive
if set to true [recursive].

Return Value

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace | ExchangeClient.ListMessages Overload List


ExchangeClient.ListMessagesById Method

Lists the messages by id.

public ExchangeMessageInfoCollection ListMessagesById(
string folder,
string messageId
);

Parameters

folder
The folder.
messageId
The message id.

Return Value

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace


ExchangeClient.ListPublicFolders Method

Gets collection of public folders from root public folder

public override ExchangeFolderInfoCollection ListPublicFolders();

Return Value

ExchangeFolderInfoCollection that contains subfolders from the root public folder

Implements

IExchangeClientBase.ListPublicFolders

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace


ListSubFolders Method

Aspose.Email

ExchangeClient.ListSubFolders Method

Gets collection of child folders from parent

Overload List

Inherited from ExchangeClientBase.

public ExchangeFolderInfoCollection ListSubFolders(ExchangeFolderInfo);

Gets collection of child folders from parent

public override ExchangeFolderInfoCollection ListSubFolders(string);

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace


ExchangeClient.ListSubFolders Method (String)

Gets collection of child folders from parent

public override ExchangeFolderInfoCollection ListSubFolders(
string parentFolderUri
);

Parameters

parentFolderUri
The uri of the parent folder

Return Value

ExchangeFolderInfoCollection that contains subfolders from the parent folder

Implements

IExchangeClientBase.ListSubFolders

Exceptions

Exception Type | Condition
ArgumentException | parentFolderUri is null or empty

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace | ExchangeClient.ListSubFolders Overload List


ExchangeClient.MoveItem Method

Moves the item.

public void MoveItem(
string source,
string destination
);

Parameters

source
The source.
destination
The destination.

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace


MoveMessage Method

Aspose.Email

ExchangeClient.MoveMessage Method

Moves the message.

Overload List

Moves the message.

public void MoveMessage(ExchangeMessageInfo,string);

Moves the message.

public void MoveMessage(ExchangeMessageInfo,string,bool);

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace


ExchangeClient.MoveMessage Method (ExchangeMessageInfo, String)

Moves the message.

public void MoveMessage(
ExchangeMessageInfo msgInfo,
string destinationFolderUri
);

Parameters

msgInfo
Represents the E-Mail message info fetched from the Exchange Store.
destinationFolderUri
An URI of a destination folder.

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace | ExchangeClient.MoveMessage Overload List


ExchangeClient.MoveMessage Method (ExchangeMessageInfo, String, Boolean)

Moves the message.

public void MoveMessage(
ExchangeMessageInfo msgInfo,
string destinationFolderUri,
bool overwrite
);

Parameters

msgInfo
Represents the E-Mail message info fetched from the Exchange Store.
destinationFolderUri
An URI of a destination folder.
overwrite
Specifies whether the server should overwrite a existing message while processing a MOVE operation.

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace | ExchangeClient.MoveMessage Overload List


ExchangeClient.ResolveContact Method

Resolves ambiguous mailbox display names. Note: the maximum count of returned contacts is 100. This is a restriction of used exchange command.

public override MapiContactCollection ResolveContact(
string unresolvedEntry
);

Parameters

unresolvedEntry
A name of contact to resolve.

Return Value

A MapiContactCollection that represents contacts information.

Implements

IExchangeClientBase.ResolveContact

Exceptions

Exception Type | Condition
ArgumentException | unresolvedEntry is null or empty.

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace


Restore Method

Aspose.Email

ExchangeClient.Restore Method

Restores the specified exchange folders from the given personal storage.

Overload List

Restores the specified exchange folders from the given personal storage.

public override void Restore(PersonalStorage,ExchangeFolderInfoCollection,RestoreOptions);

Restores exchange folders from the given personal storage.

public override void Restore(PersonalStorage,RestoreOptions);

Restores the specified exchange folders from the given personal storage.

public override void Restore(Stream,ExchangeFolderInfoCollection,RestoreOptions);

Restores exchange folders from the given personal storage.

public override void Restore(Stream,RestoreOptions);

Restores the specified exchange folders from the specified personal storage file.

public override void Restore(string,ExchangeFolderInfoCollection,RestoreOptions);

Restores exchange folders from the specified personal storage file.

public override void Restore(string,RestoreOptions);

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace


ExchangeClient.Restore Method (PersonalStorage, ExchangeFolderInfoCollection, RestoreOptions)

Restores the specified exchange folders from the given personal storage.

public override void Restore(
PersonalStorage pst,
ExchangeFolderInfoCollection folders,
RestoreOptions options
);

Parameters

pst
A personal storage containing the backuped exchange folders.
folders
A folders to be restored.
options
Restore options.

Implements

IExchangeClientBase.Restore

Exceptions

Exception Type | Condition
ArgumentNullException | pst or folders is null.

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace | ExchangeClient.Restore Overload List


ExchangeClient.Restore Method (PersonalStorage, RestoreOptions)

Restores exchange folders from the given personal storage.

public override void Restore(
PersonalStorage pst,
RestoreOptions options
);

Parameters

pst
A personal storage containing the backuped imap folders.
options
Restore options.

Implements

IExchangeClientBase.Restore

Exceptions

Exception Type | Condition
ArgumentNullException | pst is null.

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace | ExchangeClient.Restore Overload List


ExchangeClient.Restore Method (Stream, ExchangeFolderInfoCollection, RestoreOptions)

Restores the specified exchange folders from the given personal storage.

public override void Restore(
Stream stream,
ExchangeFolderInfoCollection folders,
RestoreOptions options
);

Parameters

stream
A stream containing personal storage.
folders
A folders to be restored.
options
Restore options.

Implements

IExchangeClientBase.Restore

Exceptions

Exception Type | Condition
NotSupportedException | The stream does not support reading.
ArgumentNullException | stream or folders is null.

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace | ExchangeClient.Restore Overload List


ExchangeClient.Restore Method (Stream, RestoreOptions)

Restores exchange folders from the given personal storage.

public override void Restore(
Stream stream,
RestoreOptions options
);

Parameters

stream
A stream containing personal storage.
options
Restore options.

Implements

IExchangeClientBase.Restore

Exceptions

Exception Type | Condition
NotSupportedException | The stream does not support reading.
ArgumentNullException | stream is null.

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace | ExchangeClient.Restore Overload List


ExchangeClient.Restore Method (String, ExchangeFolderInfoCollection, RestoreOptions)

Restores the specified exchange folders from the specified personal storage file.

public override void Restore(
string fileName,
ExchangeFolderInfoCollection folders,
RestoreOptions options
);

Parameters

fileName
A path to personal storage file.
folders
A folders to be restored.
options
Restore options.

Implements

IExchangeClientBase.Restore

Exceptions

Exception Type | Condition
ArgumentException | fileName is not specified.
ArgumentNullException | folders is null.

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace | ExchangeClient.Restore Overload List


ExchangeClient.Restore Method (String, RestoreOptions)

Restores exchange folders from the specified personal storage file.

public override void Restore(
string fileName,
RestoreOptions options
);

Parameters

fileName
A path to personal storage file.
options
Restore options.

Implements

IExchangeClientBase.Restore

Exceptions

Exception Type | Condition
ArgumentException | fileName is not specified.

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace | ExchangeClient.Restore Overload List


SaveMessage Method

Aspose.Email

ExchangeClient.SaveMessage Method

Saves the message.

Overload List

Saves the message.

public override void SaveMessage(string,Stream);

Saves mail message specified by the uri to local file system. The mail message file is RFC 822 compliant format (EML). if you want to parse the mail message files, use MailMessage.

public override void SaveMessage(string,string);

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace


ExchangeClient.SaveMessage Method (String, Stream)

Saves the message.

public override void SaveMessage(
string messageUri,
Stream stream
);

Parameters

messageUri
The message URI.
stream
The stream.

Implements

IExchangeClientBase.SaveMessage

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace | ExchangeClient.SaveMessage Overload List


ExchangeClient.SaveMessage Method (String, String)

Saves mail message specified by the uri to local file system. The mail message file is RFC 822 compliant format (EML). if you want to parse the mail message files, use MailMessage.

public override void SaveMessage(
string messageUri,
string path
);

Parameters

messageUri
The Uri of the mail message
path
The target path to save the message

Implements

IExchangeClientBase.SaveMessage

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace | ExchangeClient.SaveMessage Overload List


ExchangeClient.Send Method

Sends the mail message.

public override void Send(
MailMessage message
);

Parameters

message
The mail message to be sent.

Implements

IExchangeClientBase.Send

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace


SetReadFlag Method

Aspose.Email

ExchangeClient.SetReadFlag Method

Marks the specifeid message as read.

Overload List

Marks the specifeid message as read.

public override void SetReadFlag(string);

Marks the specifeid message as read.

public void SetReadFlag(string,bool);

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace


ExchangeClient.SetReadFlag Method (String)

Marks the specifeid message as read.

public override void SetReadFlag(
string messageUri
);

Parameters

messageUri
A message uri.

Implements

IExchangeClientBase.SetReadFlag

Exceptions

Exception Type | Condition
ArgumentException | messageUri is null or empty.

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace | ExchangeClient.SetReadFlag Overload List


ExchangeClient.SetReadFlag Method (String, Boolean)

Marks the specifeid message as read.

public void SetReadFlag(
string messageUri,
bool suppressReceipt
);

Parameters

messageUri
A message uri.
suppressReceipt
A value indicating whether the sending a read receipt should be suppressed.

Exceptions

Exception Type | Condition
ArgumentException | messageUri is null or empty.

See Also

ExchangeClient Class | Aspose.Email.Exchange Namespace | ExchangeClient.SetReadFlag Overload List


ExchangeClientBase Class

Provides the abstract base class to MS Exchange Server access.

For a list of all members of this type, see ExchangeClientBase Members.

System.Object
Aspose.Email.Exchange.ExchangeClientBase
Aspose.Email.Exchange.EWSClient
Aspose.Email.Exchange.ExchangeClient
Aspose.Email.Exchange.ExchangeWebServiceClient

public abstract class ExchangeClientBase : IExchangeClientBase, IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExchangeClientBase Members | Aspose.Email.Exchange Namespace


ExchangeClientBase Members

ExchangeClientBase overview

Protected Internal Static Fields

MAX_ENTRIES_RETURNED

Public Instance Properties

Credentials | Gets or sets the credentials.
MailboxInfo | Gets the mailbox info.
MailboxUri | Gets or sets the mailbox uri.
Proxy | Gets or sets the proxy.
Timeout | Gets or sets the number of milliseconds to wait before the operation times out. The default value is 100,000 milliseconds (100 seconds).

Public Instance Methods

AppendMessage | Overloaded. Uploads the mail message to the specified folder
Backup | Overloaded. Backups the content of the specified folders
CreateContact | Creates a contact item in the Exchange store.
CreateFolder | Creates the new folder with the specified name in the specified parent folder.
DeleteContact | Overloaded. Deletes the contact.
DeleteFolder | Deletes the folder
DeleteMessage | Deletes the mail message.
Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FetchAttachment | Fetches the attachment
FetchMessage | Fetches the message.
FolderExists | Overloaded. Checks whether the specified folder exists.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetMailboxInfo | Overloaded. Gets the mailbox info.
GetMailboxSize | Overloaded. Gets the size of the mailbox.
GetType (inherited from Object) | Gets the Type of the current instance.
GetVersionInfo | Returns exchange server version info
ListContacts | Lists contacts located in the specified folder on server
ListMailboxes | Lists mailboxes.
ListMessages | Overloaded. Lists the messages.
ListPublicFolders | Gets collection of public folders from root public folder
ListSubFolders | Overloaded. Gets collection of child folders from parent
ResolveContact | Resolves ambiguous mailbox names.
Restore | Overloaded. Restores exchange folders from the specified personal storage file.
SaveMessage | Overloaded. Saves the message.
Send | Sends the specified message.
SetReadFlag | Sets the read flag.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

ExchangeClientBase Constructor Initializes a new instance of the ExchangeClientBase class.

Protected Instance Methods

Dispose | Overloaded. Releases unmanaged and - optionally - managed resources
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace


ExchangeClientBase Constructor

Initializes a new instance of the ExchangeClientBase class.

protected ExchangeClientBase();

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace


ExchangeClientBase Fields

The fields of the ExchangeClientBase class are listed below. For a complete list of ExchangeClientBase class members, see the ExchangeClientBase Members topic.

Protected Internal Static Fields

MAX_ENTRIES_RETURNED

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace


ExchangeClientBase.MAX_ENTRIES_RETURNED Field

protected internal const int MAX_ENTRIES_RETURNED = 20;

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace


ExchangeClientBase Properties

The properties of the ExchangeClientBase class are listed below. For a complete list of ExchangeClientBase class members, see the ExchangeClientBase Members topic.

Public Instance Properties

Credentials | Gets or sets the credentials.
MailboxInfo | Gets the mailbox info.
MailboxUri | Gets or sets the mailbox uri.
Proxy | Gets or sets the proxy.
Timeout | Gets or sets the number of milliseconds to wait before the operation times out. The default value is 100,000 milliseconds (100 seconds).

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace


Credentials Property

Aspose.Email

ExchangeClientBase.Credentials Property

Gets or sets the credentials.

public abstract ICredentials Credentials {get; set;}

Implements

IExchangeClientBase.Credentials

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace


MailboxInfo Property

Aspose.Email

ExchangeClientBase.MailboxInfo Property

Gets the mailbox info.

public abstract ExchangeMailboxInfo MailboxInfo {get;}

Property Value

The mailbox info.

Implements

IExchangeClientBase.MailboxInfo

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace


MailboxUri Property

Aspose.Email

ExchangeClientBase.MailboxUri Property

Gets or sets the mailbox uri.

public abstract string MailboxUri {get; set;}

Implements

IExchangeClientBase.MailboxUri

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace


Proxy Property

Aspose.Email

ExchangeClientBase.Proxy Property

Gets or sets the proxy.

public abstract WebProxy Proxy {get; set;}

Implements

IExchangeClientBase.Proxy

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace


Timeout Property

Aspose.Email

ExchangeClientBase.Timeout Property

Gets or sets the number of milliseconds to wait before the operation times out. The default value is 100,000 milliseconds (100 seconds).

public abstract int Timeout {get; set;}

Implements

IExchangeClientBase.Timeout

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace


ExchangeClientBase Methods

The methods of the ExchangeClientBase class are listed below. For a complete list of ExchangeClientBase class members, see the ExchangeClientBase Members topic.

Public Instance Methods

AppendMessage | Overloaded. Uploads the mail message to the specified folder
Backup | Overloaded. Backups the content of the specified folders
CreateContact | Creates a contact item in the Exchange store.
CreateFolder | Creates the new folder with the specified name in the specified parent folder.
DeleteContact | Overloaded. Deletes the contact.
DeleteFolder | Deletes the folder
DeleteMessage | Deletes the mail message.
Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FetchAttachment | Fetches the attachment
FetchMessage | Fetches the message.
FolderExists | Overloaded. Checks whether the specified folder exists.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetMailboxInfo | Overloaded. Gets the mailbox info.
GetMailboxSize | Overloaded. Gets the size of the mailbox.
GetType (inherited from Object) | Gets the Type of the current instance.
GetVersionInfo | Returns exchange server version info
ListContacts | Lists contacts located in the specified folder on server
ListMailboxes | Lists mailboxes.
ListMessages | Overloaded. Lists the messages.
ListPublicFolders | Gets collection of public folders from root public folder
ListSubFolders | Overloaded. Gets collection of child folders from parent
ResolveContact | Resolves ambiguous mailbox names.
Restore | Overloaded. Restores exchange folders from the specified personal storage file.
SaveMessage | Overloaded. Saves the message.
Send | Sends the specified message.
SetReadFlag | Sets the read flag.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Dispose | Overloaded. Releases unmanaged and - optionally - managed resources
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace


AppendMessage Method

Aspose.Email

ExchangeClientBase.AppendMessage Method

Uploads the mail message to the specified folder

Overload List

Uploads the mail message to the specified folder

public abstract string AppendMessage(string,MailMessage);

Uploads the mail message to the specified folder

public abstract string AppendMessage(string,MailMessage,bool);

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace


ExchangeClientBase.AppendMessage Method (String, MailMessage)

Uploads the mail message to the specified folder

public abstract string AppendMessage(
string folder,
MailMessage message
);

Parameters

folder
A folder to which message is uploaded
message
A message to upload

Return Value

An uri of created message

Implements

IExchangeClientBase.AppendMessage

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace | ExchangeClientBase.AppendMessage Overload List


ExchangeClientBase.AppendMessage Method (String, MailMessage, Boolean)

Uploads the mail message to the specified folder

public abstract string AppendMessage(
string folder,
MailMessage message,
bool markAsSent
);

Parameters

folder
An uri of folder to which message is uploaded
message
A message to upload
markAsSent
A value indicating whether the message should be appended as a sent message or a draft.

Return Value

An uri of created message

Implements

IExchangeClientBase.AppendMessage

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace | ExchangeClientBase.AppendMessage Overload List


Backup Method

Aspose.Email

ExchangeClientBase.Backup Method

Backups the content of the specified folders

Overload List

Backups the content of the specified folders

public abstract void Backup(ExchangeFolderInfoCollection,Stream,BackupOptions);

Backups the content of the specified folders

public abstract void Backup(ExchangeFolderInfoCollection,string,BackupOptions);

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace


ExchangeClientBase.Backup Method (ExchangeFolderInfoCollection, Stream, BackupOptions)

Backups the content of the specified folders

public abstract void Backup(
ExchangeFolderInfoCollection folders,
Stream stream,
BackupOptions options
);

Parameters

folders
A folders to backup
stream
A stream to write into
options
A backup options

Implements

IExchangeClientBase.Backup

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace | ExchangeClientBase.Backup Overload List


ExchangeClientBase.Backup Method (ExchangeFolderInfoCollection, String, BackupOptions)

Backups the content of the specified folders

public abstract void Backup(
ExchangeFolderInfoCollection folders,
string fileName,
BackupOptions options
);

Parameters

folders
A folders to backup
fileName
A path to the presonal storage file
options
A backup options

Implements

IExchangeClientBase.Backup

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace | ExchangeClientBase.Backup Overload List


ExchangeClientBase.CreateContact Method

Creates a contact item in the Exchange store.

public abstract string CreateContact(
MapiContact contact
);

Parameters

contact
Contact item

Return Value

The contact Uri

Implements

IExchangeClientBase.CreateContact

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace


ExchangeClientBase.CreateFolder Method

Creates the new folder with the specified name in the specified parent folder.

public abstract void CreateFolder(
string parentFolderUri,
string name
);

Parameters

parentFolderUri
An uri of parent folder.
name
A name of folder to be created.

Implements

IExchangeClientBase.CreateFolder

Exceptions

Exception Type | Condition
ArgumentException | parentFolderUri or name is null or empty.

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace


DeleteContact Method

Aspose.Email

ExchangeClientBase.DeleteContact Method

Deletes the contact.

Overload List

Deletes the contact.

public abstract void DeleteContact(MapiContact);

Deletes the contact.

public abstract void DeleteContact(string);

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace


ExchangeClientBase.DeleteContact Method (MapiContact)

Deletes the contact.

public abstract void DeleteContact(
MapiContact contact
);

Parameters

contact
Contact for deleting

Implements

IExchangeClientBase.DeleteContact

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace | ExchangeClientBase.DeleteContact Overload List


ExchangeClientBase.DeleteContact Method (String)

Deletes the contact.

public abstract void DeleteContact(
string id
);

Parameters

id
The contact identifier.

Implements

IExchangeClientBase.DeleteContact

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace | ExchangeClientBase.DeleteContact Overload List


ExchangeClientBase.DeleteFolder Method

Deletes the folder

public abstract void DeleteFolder(
string folderUri
);

Parameters

folderUri
The folder Uri

Implements

IExchangeClientBase.DeleteFolder

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace


ExchangeClientBase.DeleteMessage Method

Deletes the mail message.

public abstract void DeleteMessage(
string messageUri
);

Parameters

messageUri
The message uri.

Implements

IExchangeClientBase.DeleteMessage

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace


Dispose Method

Aspose.Email

ExchangeClientBase.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Overload List

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

public void Dispose();

Releases unmanaged and - optionally - managed resources

protected virtual void Dispose(bool);

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace


ExchangeClientBase.Dispose Method ()

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

public void Dispose();

Implements

IDisposable.Dispose

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace | ExchangeClientBase.Dispose Overload List


ExchangeClientBase.Dispose Method (Boolean)

Releases unmanaged and - optionally - managed resources

protected virtual void Dispose(
bool disposing
);

Parameters

disposing
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace | ExchangeClientBase.Dispose Overload List


ExchangeClientBase.FetchAttachment Method

Fetches the attachment

public abstract Attachment FetchAttachment(
string attachmentUri
);

Parameters

attachmentUri
The attachment uri

Return Value

Attachment that represents fetched attachment

Implements

IExchangeClientBase.FetchAttachment

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace


ExchangeClientBase.FetchMessage Method

Fetches the message.

public abstract MailMessage FetchMessage(
string messageUri
);

Parameters

messageUri
The message URI.

Return Value

Returns a message

Implements

IExchangeClientBase.FetchMessage

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace


FolderExists Method

Aspose.Email

ExchangeClientBase.FolderExists Method

Checks whether the specified folder exists.

Overload List

Checks whether the specified folder exists.

public bool FolderExists(string,string);

public abstract bool FolderExists(string,string,out ExchangeFolderInfo);

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace


ExchangeClientBase.FolderExists Method (String, String)

Checks whether the specified folder exists.

public bool FolderExists(
string parentFolderUri,
string folderName
);

Parameters

parentFolderUri
An uri of parent folder.
folderName
A folder name.

Return Value

true if the specified folder exists in the specified parent folder; otherwise, false.

Implements

IExchangeClientBase.FolderExists

Exceptions

Exception Type | Condition
ArgumentException | parentFolderUri or folderName is null or empty

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace | ExchangeClientBase.FolderExists Overload List


ExchangeClientBase.FolderExists Method (String, String, ExchangeFolderInfo)

public abstract bool FolderExists(
string parentFolderUri,
string folderName,
out ExchangeFolderInfo folder
);

Implements

IExchangeClientBase.FolderExists

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace | ExchangeClientBase.FolderExists Overload List


GetMailboxInfo Method

Aspose.Email

ExchangeClientBase.GetMailboxInfo Method

Gets the mailbox info.

Overload List

Gets the mailbox info.

public abstract ExchangeMailboxInfo GetMailboxInfo();

Gets the mailbox information

public abstract ExchangeMailboxInfo GetMailboxInfo(string);

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace


ExchangeClientBase.GetMailboxInfo Method ()

Gets the mailbox info.

public abstract ExchangeMailboxInfo GetMailboxInfo();

Return Value

ExchangeMailboxInfo that represents mailbox information

Implements

IExchangeClientBase.GetMailboxInfo

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace | ExchangeClientBase.GetMailboxInfo Overload List


ExchangeClientBase.GetMailboxInfo Method (String)

Gets the mailbox information

public abstract ExchangeMailboxInfo GetMailboxInfo(
string mailbox
);

Parameters

mailbox
A mailbox to read from.

Return Value

ExchangeMailboxInfo that represents mailbox information

Implements

IExchangeClientBase.GetMailboxInfo

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace | ExchangeClientBase.GetMailboxInfo Overload List


GetMailboxSize Method

Aspose.Email

ExchangeClientBase.GetMailboxSize Method

Gets the size of the mailbox.

Overload List

Gets the size of the mailbox.

public abstract long GetMailboxSize();

Gets the size of the mailbox

public abstract long GetMailboxSize(string);

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace


ExchangeClientBase.GetMailboxSize Method ()

Gets the size of the mailbox.

public abstract long GetMailboxSize();

Return Value

size of the mailbox in bytes

Implements

IExchangeClientBase.GetMailboxSize

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace | ExchangeClientBase.GetMailboxSize Overload List


ExchangeClientBase.GetMailboxSize Method (String)

Gets the size of the mailbox

public abstract long GetMailboxSize(
string mailbox
);

Parameters

mailbox
A mailbox.

Return Value

size of the mailbox in bytes

Implements

IExchangeClientBase.GetMailboxSize

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace | ExchangeClientBase.GetMailboxSize Overload List


ExchangeClientBase.GetVersionInfo Method

Returns exchange server version info

public abstract string GetVersionInfo();

Return Value

Returns exchange server version info

Implements

IExchangeClientBase.GetVersionInfo

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace


ExchangeClientBase.ListContacts Method

Lists contacts located in the specified folder on server

public abstract MapiContact[] ListContacts(
string folderUri
);

Parameters

folderUri
The URI of folder

Return Value

An array of read MapiContact that represents contact information

Implements

IExchangeClientBase.ListContacts

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace


ExchangeClientBase.ListMailboxes Method

Lists mailboxes.

public abstract MapiContactCollection ListMailboxes();

Return Value

A MapiContactCollection that represents contact information.

Implements

IExchangeClientBase.ListMailboxes

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace


ListMessages Method

Aspose.Email

ExchangeClientBase.ListMessages Method

Lists the messages.

Overload List

Lists the messages.

public ExchangeMessageInfoCollection ListMessages(string);

Lists the messages.

public abstract ExchangeMessageInfoCollection ListMessages(string,ExchangeListMessagesOptions);

Lists the messages.

public ExchangeMessageInfoCollection ListMessages(string,int);

Lists the messages.

public abstract ExchangeMessageInfoCollection ListMessages(string,int,ExchangeListMessagesOptions);

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace


ExchangeClientBase.ListMessages Method (String)

Lists the messages.

public ExchangeMessageInfoCollection ListMessages(
string folder
);

Parameters

folder
The folder.

Return Value

A ExchangeMessageInfoCollection

Implements

IExchangeClientBase.ListMessages

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace | ExchangeClientBase.ListMessages Overload List


ExchangeClientBase.ListMessages Method (String, ExchangeListMessagesOptions)

Lists the messages.

public abstract ExchangeMessageInfoCollection ListMessages(
string folder,
ExchangeListMessagesOptions options
);

Parameters

folder
The folder.
options
Specifies the settings of listing

Return Value

A ExchangeMessageInfoCollection

Implements

IExchangeClientBase.ListMessages

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace | ExchangeClientBase.ListMessages Overload List


ExchangeClientBase.ListMessages Method (String, Int32)

Lists the messages.

public ExchangeMessageInfoCollection ListMessages(
string folder,
int maxNumberOfMessages
);

Parameters

folder
The folder.
maxNumberOfMessages
Maximum number of messages

Return Value

A ExchangeMessageInfoCollection

Implements

IExchangeClientBase.ListMessages

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace | ExchangeClientBase.ListMessages Overload List


ExchangeClientBase.ListMessages Method (String, Int32, ExchangeListMessagesOptions)

Lists the messages.

public abstract ExchangeMessageInfoCollection ListMessages(
string folder,
int maxNumberOfMessages,
ExchangeListMessagesOptions options
);

Parameters

folder
The folder.
maxNumberOfMessages
Maximum number of messages
options
Specifies the settings of listing

Return Value

A ExchangeMessageInfoCollection

Implements

IExchangeClientBase.ListMessages

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace | ExchangeClientBase.ListMessages Overload List


ExchangeClientBase.ListPublicFolders Method

Gets collection of public folders from root public folder

public abstract ExchangeFolderInfoCollection ListPublicFolders();

Return Value

ExchangeFolderInfoCollection that contains subfolders from the root public folder

Implements

IExchangeClientBase.ListPublicFolders

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace


ListSubFolders Method

Aspose.Email

ExchangeClientBase.ListSubFolders Method

Gets collection of child public folders from parent

Overload List

Gets collection of child public folders from parent

public ExchangeFolderInfoCollection ListSubFolders(ExchangeFolderInfo);

Gets collection of child folders from parent

public abstract ExchangeFolderInfoCollection ListSubFolders(string);

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace


ExchangeClientBase.ListSubFolders Method (ExchangeFolderInfo)

Gets collection of child public folders from parent

public ExchangeFolderInfoCollection ListSubFolders(
ExchangeFolderInfo parentFolder
);

Parameters

parentFolder
The parent ExchangeFolderInfo

Return Value

ExchangeFolderInfoCollection that contains subfolders from the parent folder

Implements

IExchangeClientBase.ListSubFolders

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace | ExchangeClientBase.ListSubFolders Overload List


ExchangeClientBase.ListSubFolders Method (String)

Gets collection of child folders from parent

public abstract ExchangeFolderInfoCollection ListSubFolders(
string parentFolderUri
);

Parameters

parentFolderUri
The uri of the parent folder

Return Value

ExchangeFolderInfoCollection that contains subfolders from the parent folder

Implements

IExchangeClientBase.ListSubFolders

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace | ExchangeClientBase.ListSubFolders Overload List


ExchangeClientBase.ResolveContact Method

Resolves ambiguous mailbox names.

public abstract MapiContactCollection ResolveContact(
string unresolvedEntry
);

Parameters

unresolvedEntry
A name of contact to resolve.

Return Value

A MapiContactCollection that represents contacts information.

Implements

IExchangeClientBase.ResolveContact

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace


Restore Method

Aspose.Email

ExchangeClientBase.Restore Method

Restores the specified exchange folders from the given personal storage.

Overload List

Restores the specified exchange folders from the given personal storage.

public abstract void Restore(PersonalStorage,ExchangeFolderInfoCollection,RestoreOptions);

Restores exchange folders from the given personal storage.

public abstract void Restore(PersonalStorage,RestoreOptions);

Restores the specified exchange folders from the given personal storage.

public abstract void Restore(Stream,ExchangeFolderInfoCollection,RestoreOptions);

Restores exchange folders from the given personal storage.

public abstract void Restore(Stream,RestoreOptions);

Restores the specified exchange folders from the specified personal storage file.

public abstract void Restore(string,ExchangeFolderInfoCollection,RestoreOptions);

Restores exchange folders from the specified personal storage file.

public abstract void Restore(string,RestoreOptions);

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace


ExchangeClientBase.Restore Method (PersonalStorage, ExchangeFolderInfoCollection, RestoreOptions)

Restores the specified exchange folders from the given personal storage.

public abstract void Restore(
PersonalStorage pst,
ExchangeFolderInfoCollection folders,
RestoreOptions options
);

Parameters

pst
A personal storage containing the backuped exchange folders.
folders
A folders to be restored.
options
Restore options.

Implements

IExchangeClientBase.Restore

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace | ExchangeClientBase.Restore Overload List


ExchangeClientBase.Restore Method (PersonalStorage, RestoreOptions)

Restores exchange folders from the given personal storage.

public abstract void Restore(
PersonalStorage pst,
RestoreOptions options
);

Parameters

pst
A personal storage containing the backuped imap folders.
options
Restore options.

Implements

IExchangeClientBase.Restore

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace | ExchangeClientBase.Restore Overload List


ExchangeClientBase.Restore Method (Stream, ExchangeFolderInfoCollection, RestoreOptions)

Restores the specified exchange folders from the given personal storage.

public abstract void Restore(
Stream stream,
ExchangeFolderInfoCollection folders,
RestoreOptions options
);

Parameters

stream
A stream containing personal storage.
folders
A folders to be restored.
options
Restore options.

Implements

IExchangeClientBase.Restore

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace | ExchangeClientBase.Restore Overload List


ExchangeClientBase.Restore Method (Stream, RestoreOptions)

Restores exchange folders from the given personal storage.

public abstract void Restore(
Stream stream,
RestoreOptions options
);

Parameters

stream
A stream containing personal storage.
options
Restore options.

Implements

IExchangeClientBase.Restore

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace | ExchangeClientBase.Restore Overload List


ExchangeClientBase.Restore Method (String, ExchangeFolderInfoCollection, RestoreOptions)

Restores the specified exchange folders from the specified personal storage file.

public abstract void Restore(
string fileName,
ExchangeFolderInfoCollection folders,
RestoreOptions options
);

Parameters

fileName
A path to personal storage file.
folders
A folders to be restored.
options
Restore options.

Implements

IExchangeClientBase.Restore

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace | ExchangeClientBase.Restore Overload List


ExchangeClientBase.Restore Method (String, RestoreOptions)

Restores exchange folders from the specified personal storage file.

public abstract void Restore(
string fileName,
RestoreOptions options
);

Parameters

fileName
A path to personal storage file.
options
Restore options.

Implements

IExchangeClientBase.Restore

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace | ExchangeClientBase.Restore Overload List


SaveMessage Method

Aspose.Email

ExchangeClientBase.SaveMessage Method

Saves the message.

Overload List

Saves the message.

public abstract void SaveMessage(string,Stream);

Saves the message.

public abstract void SaveMessage(string,string);

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace


ExchangeClientBase.SaveMessage Method (String, Stream)

Saves the message.

public abstract void SaveMessage(
string messageUri,
Stream stream
);

Parameters

messageUri
The message URI.
stream
The stream.

Implements

IExchangeClientBase.SaveMessage

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace | ExchangeClientBase.SaveMessage Overload List


ExchangeClientBase.SaveMessage Method (String, String)

Saves the message.

public abstract void SaveMessage(
string messageUri,
string path
);

Parameters

messageUri
The message URI.
path
The path to save message.

Implements

IExchangeClientBase.SaveMessage

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace | ExchangeClientBase.SaveMessage Overload List


ExchangeClientBase.Send Method

Sends the specified message.

public abstract void Send(
MailMessage message
);

Parameters

message
The message.

Implements

IExchangeClientBase.Send

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace


ExchangeClientBase.SetReadFlag Method

Sets the read flag.

public abstract void SetReadFlag(
string messageUri
);

Parameters

messageUri
The message URI.

Implements

IExchangeClientBase.SetReadFlag

See Also

ExchangeClientBase Class | Aspose.Email.Exchange Namespace


ExchangeConversation Class

Represents a single conversation.

For a list of all members of this type, see ExchangeConversation Members.

System.Object
Aspose.Email.Exchange.ExchangeConversation

public sealed class ExchangeConversation

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExchangeConversation Members | Aspose.Email.Exchange Namespace


ExchangeConversation Members

ExchangeConversation overview

Public Instance Properties

Categories | Gets the category list for conversation items in the current folder.
ConversationId | Gets the conversation identifier.
ConversationTopic | Gets the conversation topic.
FlagStatus | Gets the aggregated flag status for conversation items in the current folder.
GlobalCategories | Gets the category list for all conversation items in a mamailboxilbox.
GlobalFlagStatus | Gets the aggregated flag status for all conversation items in a mailbox.
GlobalHasAttachments | Gets a value indicating whether at least one conversation item in a mailbox has an attachment.
GlobalImportance | Gets the aggregated importance for all conversation items in a mailbox.
GlobalItemClasses | Gets a list of item classes that represents all the item classes of the conversation items in a mailbox.
GlobalItemIds | Gets the collection of item identifiers for all conversation items in a mailbox.
GlobalLastDeliveryTime | Gets the delivery time of the message that was last received in this conversation across all folders in the mailbox.
GlobalMessageCount | Gets the total number of conversation items in the mailbox.
GlobalSize | Gets the size of the conversation calculated from the size of all conversation items in the mailbox.
GlobalUniqueRecipients | Gets a list of all the people who have received messages in this conversation across all folders in the mailbox.
GlobalUniqueSenders | Gets a list of all the senders of conversation items in the mailbox.
GlobalUniqueUnreadSenders | Gets a list of all the people who have sent messages that are currently unread in this conversation across all folders in the mailbox.
GlobalUnreadCount | Gets a count of all the unread conversation items in the mailbox.
HasAttachments | Gets a value indicating whether at least one conversation item in the current folder has an attachment.
Importance | Gets the aggregated importance for all conversation items in the current folder.
ItemClasses | Gets a list of item classes that represents all the item classes of the conversation items in the current folder
ItemIds | Gets the collection of item identifiers for all conversation items in the current folder.
LastDeliveryTime | Gets the delivery time of the message that was last received in this conversation in the current folder.
MessageCount | Gets the total number of conversation items in the current folder.
Size | Gets the size of the conversation calculated from the size of all conversation items in the current folder.
UniqueRecipients | Gets the list of all the people who have received messages in this conversation for messages in the current folder.
UniqueSenders | Gets a list of all the senders of conversation items in the current folder.
UniqueUnreadSenders | Gets a list of all the people who have sent messages that are currently unread in this conversation in the current folder.
UnreadCount | Gets a count of all the unread conversation items in the current folder.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ExchangeConversation Class | Aspose.Email.Exchange Namespace


ExchangeConversation Properties

The properties of the ExchangeConversation class are listed below. For a complete list of ExchangeConversation class members, see the ExchangeConversation Members topic.

Public Instance Properties

Categories | Gets the category list for conversation items in the current folder.
ConversationId | Gets the conversation identifier.
ConversationTopic | Gets the conversation topic.
FlagStatus | Gets the aggregated flag status for conversation items in the current folder.
GlobalCategories | Gets the category list for all conversation items in a mamailboxilbox.
GlobalFlagStatus | Gets the aggregated flag status for all conversation items in a mailbox.
GlobalHasAttachments | Gets a value indicating whether at least one conversation item in a mailbox has an attachment.
GlobalImportance | Gets the aggregated importance for all conversation items in a mailbox.
GlobalItemClasses | Gets a list of item classes that represents all the item classes of the conversation items in a mailbox.
GlobalItemIds | Gets the collection of item identifiers for all conversation items in a mailbox.
GlobalLastDeliveryTime | Gets the delivery time of the message that was last received in this conversation across all folders in the mailbox.
GlobalMessageCount | Gets the total number of conversation items in the mailbox.
GlobalSize | Gets the size of the conversation calculated from the size of all conversation items in the mailbox.
GlobalUniqueRecipients | Gets a list of all the people who have received messages in this conversation across all folders in the mailbox.
GlobalUniqueSenders | Gets a list of all the senders of conversation items in the mailbox.
GlobalUniqueUnreadSenders | Gets a list of all the people who have sent messages that are currently unread in this conversation across all folders in the mailbox.
GlobalUnreadCount | Gets a count of all the unread conversation items in the mailbox.
HasAttachments | Gets a value indicating whether at least one conversation item in the current folder has an attachment.
Importance | Gets the aggregated importance for all conversation items in the current folder.
ItemClasses | Gets a list of item classes that represents all the item classes of the conversation items in the current folder
ItemIds | Gets the collection of item identifiers for all conversation items in the current folder.
LastDeliveryTime | Gets the delivery time of the message that was last received in this conversation in the current folder.
MessageCount | Gets the total number of conversation items in the current folder.
Size | Gets the size of the conversation calculated from the size of all conversation items in the current folder.
UniqueRecipients | Gets the list of all the people who have received messages in this conversation for messages in the current folder.
UniqueSenders | Gets a list of all the senders of conversation items in the current folder.
UniqueUnreadSenders | Gets a list of all the people who have sent messages that are currently unread in this conversation in the current folder.
UnreadCount | Gets a count of all the unread conversation items in the current folder.

See Also

ExchangeConversation Class | Aspose.Email.Exchange Namespace


Categories Property

Aspose.Email

ExchangeConversation.Categories Property

Gets the category list for conversation items in the current folder.

public StringCollection Categories {get;}

See Also

ExchangeConversation Class | Aspose.Email.Exchange Namespace


ConversationId Property

Aspose.Email

ExchangeConversation.ConversationId Property

Gets the conversation identifier.

public string ConversationId {get; set;}

See Also

ExchangeConversation Class | Aspose.Email.Exchange Namespace


ConversationTopic Property

Aspose.Email

ExchangeConversation.ConversationTopic Property

Gets the conversation topic.

public string ConversationTopic {get; set;}

See Also

ExchangeConversation Class | Aspose.Email.Exchange Namespace


FlagStatus Property

Aspose.Email

ExchangeConversation.FlagStatus Property

Gets the aggregated flag status for conversation items in the current folder.

public ExchangeConversationFlagStatus FlagStatus {get; set;}

See Also

ExchangeConversation Class | Aspose.Email.Exchange Namespace


GlobalCategories Property

Aspose.Email

ExchangeConversation.GlobalCategories Property

Gets the category list for all conversation items in a mamailboxilbox.

public StringCollection GlobalCategories {get;}

See Also

ExchangeConversation Class | Aspose.Email.Exchange Namespace


GlobalFlagStatus Property

Aspose.Email

ExchangeConversation.GlobalFlagStatus Property

Gets the aggregated flag status for all conversation items in a mailbox.

public ExchangeConversationFlagStatus GlobalFlagStatus {get; set;}

See Also

ExchangeConversation Class | Aspose.Email.Exchange Namespace


GlobalHasAttachments Property

Aspose.Email

ExchangeConversation.GlobalHasAttachments Property

Gets a value indicating whether at least one conversation item in a mailbox has an attachment.

public bool GlobalHasAttachments {get; set;}

See Also

ExchangeConversation Class | Aspose.Email.Exchange Namespace


GlobalImportance Property

Aspose.Email

ExchangeConversation.GlobalImportance Property

Gets the aggregated importance for all conversation items in a mailbox.

public ImportanceChoices GlobalImportance {get; set;}

See Also

ExchangeConversation Class | Aspose.Email.Exchange Namespace


GlobalItemClasses Property

Aspose.Email

ExchangeConversation.GlobalItemClasses Property

Gets a list of item classes that represents all the item classes of the conversation items in a mailbox.

public StringCollection GlobalItemClasses {get;}

See Also

ExchangeConversation Class | Aspose.Email.Exchange Namespace


GlobalItemIds Property

Aspose.Email

ExchangeConversation.GlobalItemIds Property

Gets the collection of item identifiers for all conversation items in a mailbox.

public StringCollection GlobalItemIds {get;}

See Also

ExchangeConversation Class | Aspose.Email.Exchange Namespace


GlobalLastDeliveryTime Property

Aspose.Email

ExchangeConversation.GlobalLastDeliveryTime Property

Gets the delivery time of the message that was last received in this conversation across all folders in the mailbox.

public DateTime GlobalLastDeliveryTime {get; set;}

See Also

ExchangeConversation Class | Aspose.Email.Exchange Namespace


GlobalMessageCount Property

Aspose.Email

ExchangeConversation.GlobalMessageCount Property

Gets the total number of conversation items in the mailbox.

public int GlobalMessageCount {get; set;}

See Also

ExchangeConversation Class | Aspose.Email.Exchange Namespace


GlobalSize Property

Aspose.Email

ExchangeConversation.GlobalSize Property

Gets the size of the conversation calculated from the size of all conversation items in the mailbox.

public int GlobalSize {get; set;}

See Also

ExchangeConversation Class | Aspose.Email.Exchange Namespace


GlobalUniqueRecipients Property

Aspose.Email

ExchangeConversation.GlobalUniqueRecipients Property

Gets a list of all the people who have received messages in this conversation across all folders in the mailbox.

public StringCollection GlobalUniqueRecipients {get;}

See Also

ExchangeConversation Class | Aspose.Email.Exchange Namespace


GlobalUniqueSenders Property

Aspose.Email

ExchangeConversation.GlobalUniqueSenders Property

Gets a list of all the senders of conversation items in the mailbox.

public StringCollection GlobalUniqueSenders {get;}

See Also

ExchangeConversation Class | Aspose.Email.Exchange Namespace


GlobalUniqueUnreadSenders Property

Aspose.Email

ExchangeConversation.GlobalUniqueUnreadSenders Property

Gets a list of all the people who have sent messages that are currently unread in this conversation across all folders in the mailbox.

public StringCollection GlobalUniqueUnreadSenders {get;}

See Also

ExchangeConversation Class | Aspose.Email.Exchange Namespace


GlobalUnreadCount Property

Aspose.Email

ExchangeConversation.GlobalUnreadCount Property

Gets a count of all the unread conversation items in the mailbox.

public int GlobalUnreadCount {get; set;}

See Also

ExchangeConversation Class | Aspose.Email.Exchange Namespace


HasAttachments Property

Aspose.Email

ExchangeConversation.HasAttachments Property

Gets a value indicating whether at least one conversation item in the current folder has an attachment.

public bool HasAttachments {get; set;}

See Also

ExchangeConversation Class | Aspose.Email.Exchange Namespace


Importance Property

Aspose.Email

ExchangeConversation.Importance Property

Gets the aggregated importance for all conversation items in the current folder.

public ImportanceChoices Importance {get; set;}

See Also

ExchangeConversation Class | Aspose.Email.Exchange Namespace


ItemClasses Property

Aspose.Email

ExchangeConversation.ItemClasses Property

Gets a list of item classes that represents all the item classes of the conversation items in the current folder

public StringCollection ItemClasses {get;}

See Also

ExchangeConversation Class | Aspose.Email.Exchange Namespace


ItemIds Property

Aspose.Email

ExchangeConversation.ItemIds Property

Gets the collection of item identifiers for all conversation items in the current folder.

public StringCollection ItemIds {get;}

See Also

ExchangeConversation Class | Aspose.Email.Exchange Namespace


LastDeliveryTime Property

Aspose.Email

ExchangeConversation.LastDeliveryTime Property

Gets the delivery time of the message that was last received in this conversation in the current folder.

public DateTime LastDeliveryTime {get; set;}

See Also

ExchangeConversation Class | Aspose.Email.Exchange Namespace


MessageCount Property

Aspose.Email

ExchangeConversation.MessageCount Property

Gets the total number of conversation items in the current folder.

public int MessageCount {get; set;}

See Also

ExchangeConversation Class | Aspose.Email.Exchange Namespace


Size Property

Aspose.Email

ExchangeConversation.Size Property

Gets the size of the conversation calculated from the size of all conversation items in the current folder.

public int Size {get; set;}

See Also

ExchangeConversation Class | Aspose.Email.Exchange Namespace


UniqueRecipients Property

Aspose.Email

ExchangeConversation.UniqueRecipients Property

Gets the list of all the people who have received messages in this conversation for messages in the current folder.

public StringCollection UniqueRecipients {get;}

See Also

ExchangeConversation Class | Aspose.Email.Exchange Namespace


UniqueSenders Property

Aspose.Email

ExchangeConversation.UniqueSenders Property

Gets a list of all the senders of conversation items in the current folder.

public StringCollection UniqueSenders {get;}

See Also

ExchangeConversation Class | Aspose.Email.Exchange Namespace


UniqueUnreadSenders Property

Aspose.Email

ExchangeConversation.UniqueUnreadSenders Property

Gets a list of all the people who have sent messages that are currently unread in this conversation in the current folder.

public StringCollection UniqueUnreadSenders {get;}

See Also

ExchangeConversation Class | Aspose.Email.Exchange Namespace


UnreadCount Property

Aspose.Email

ExchangeConversation.UnreadCount Property

Gets a count of all the unread conversation items in the current folder.

public int UnreadCount {get; set;}

See Also

ExchangeConversation Class | Aspose.Email.Exchange Namespace


ExchangeConversationFlagStatus Enumeration

Enumerates the flag status for conversation.

public enum ExchangeConversationFlagStatus

Members

Member Name | Description | Value
Undefined | Undefined status | -1
NotFlagged | Specifies the not-flagged status. | 0
Flagged | Specifies the flagged flag status. | 1
Complete | Specifies the complete flag status. | 2

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange Namespace


ExchangeDelegateFolderPermissionLevel Enumeration

Enumerates the permissions levels which a delegate user can have on folder

public enum ExchangeDelegateFolderPermissionLevel

Members

Member Name | Description | Value
NotSpecified | Indicates that permission level is not specified | -1
None | Indicates that the delegate user has no permissions on the folder | 0
Reviewer | Indicates that the delegate user can read items in the folder | 2
Author | Indicates that the delegate user can read and create items in the folder | 3
Editor | Indicates that the delegate user can create, read and modify items in the folder | 1
Custom | Indicates that the delegate user has custom permission on the folder | 4

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange Namespace


ExchangeDelegateOptions Enumeration

Enumerates delegation options

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum ExchangeDelegateOptions

Members

Member Name | Description | Value
None | Indicates that no additional options are specified | 0
ReceiveCopiesOfMeetingMessages | Indicates that the delegate receives copies of meeting-related messages that are addressed to the principal. | 1
ViewPrivateItems | Indicates that the delegate can view private calendar items on the principal’s calendar. | 2

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange Namespace


ExchangeDelegatePermissions Class

Represents the folder permissions for the delegate user

For a list of all members of this type, see ExchangeDelegatePermissions Members.

System.Object
Aspose.Email.Exchange.ExchangeDelegatePermissions

public class ExchangeDelegatePermissions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExchangeDelegatePermissions Members | Aspose.Email.Exchange Namespace


ExchangeDelegatePermissions Members

ExchangeDelegatePermissions overview

Public Instance Constructors

ExchangeDelegatePermissions Constructor Initializes a new instance of the ExchangeDelegatePermissions class

Public Instance Properties

CalendarFolderPermissionLevel | Gets or sets the permissions which the delegate user has on the default Calendar folder
ContactsFolderPermissionLevel | Gets or sets the permissions which the delegate user has on the default Contacts folder
InboxFolderPermissionLevel | Gets or sets the permissions which the delegate user has on the default Inbox folder
JournalFolderPermissionLevel | Gets or sets the permissions which the delegate user has on the default Journal folder
NotesFolderPermissionLevel | Gets or sets the permissions which the delegate user has on the default Notes folder
TasksFolderPermissionLevel | Gets or sets the permissions which the delegate user has on the default Tasks folder

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetPermissionLevel | Sets the permission level on all folders to the specified value
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExchangeDelegatePermissions Class | Aspose.Email.Exchange Namespace


ExchangeDelegatePermissions Constructor

Initializes a new instance of the ExchangeDelegatePermissions class

public ExchangeDelegatePermissions();

See Also

ExchangeDelegatePermissions Class | Aspose.Email.Exchange Namespace


ExchangeDelegatePermissions Properties

The properties of the ExchangeDelegatePermissions class are listed below. For a complete list of ExchangeDelegatePermissions class members, see the ExchangeDelegatePermissions Members topic.

Public Instance Properties

CalendarFolderPermissionLevel | Gets or sets the permissions which the delegate user has on the default Calendar folder
ContactsFolderPermissionLevel | Gets or sets the permissions which the delegate user has on the default Contacts folder
InboxFolderPermissionLevel | Gets or sets the permissions which the delegate user has on the default Inbox folder
JournalFolderPermissionLevel | Gets or sets the permissions which the delegate user has on the default Journal folder
NotesFolderPermissionLevel | Gets or sets the permissions which the delegate user has on the default Notes folder
TasksFolderPermissionLevel | Gets or sets the permissions which the delegate user has on the default Tasks folder

See Also

ExchangeDelegatePermissions Class | Aspose.Email.Exchange Namespace


CalendarFolderPermissionLevel Property

Aspose.Email

ExchangeDelegatePermissions.CalendarFolderPermissionLevel Property

Gets or sets the permissions which the delegate user has on the default Calendar folder

public ExchangeDelegateFolderPermissionLevel CalendarFolderPermissionLevel {get; set;}

See Also

ExchangeDelegatePermissions Class | Aspose.Email.Exchange Namespace


ContactsFolderPermissionLevel Property

Aspose.Email

ExchangeDelegatePermissions.ContactsFolderPermissionLevel Property

Gets or sets the permissions which the delegate user has on the default Contacts folder

public ExchangeDelegateFolderPermissionLevel ContactsFolderPermissionLevel {get; set;}

See Also

ExchangeDelegatePermissions Class | Aspose.Email.Exchange Namespace


InboxFolderPermissionLevel Property

Aspose.Email

ExchangeDelegatePermissions.InboxFolderPermissionLevel Property

Gets or sets the permissions which the delegate user has on the default Inbox folder

public ExchangeDelegateFolderPermissionLevel InboxFolderPermissionLevel {get; set;}

See Also

ExchangeDelegatePermissions Class | Aspose.Email.Exchange Namespace


JournalFolderPermissionLevel Property

Aspose.Email

ExchangeDelegatePermissions.JournalFolderPermissionLevel Property

Gets or sets the permissions which the delegate user has on the default Journal folder

public ExchangeDelegateFolderPermissionLevel JournalFolderPermissionLevel {get; set;}

See Also

ExchangeDelegatePermissions Class | Aspose.Email.Exchange Namespace


NotesFolderPermissionLevel Property

Aspose.Email

ExchangeDelegatePermissions.NotesFolderPermissionLevel Property

Gets or sets the permissions which the delegate user has on the default Notes folder

public ExchangeDelegateFolderPermissionLevel NotesFolderPermissionLevel {get; set;}

See Also

ExchangeDelegatePermissions Class | Aspose.Email.Exchange Namespace


TasksFolderPermissionLevel Property

Aspose.Email

ExchangeDelegatePermissions.TasksFolderPermissionLevel Property

Gets or sets the permissions which the delegate user has on the default Tasks folder

public ExchangeDelegateFolderPermissionLevel TasksFolderPermissionLevel {get; set;}

See Also

ExchangeDelegatePermissions Class | Aspose.Email.Exchange Namespace


ExchangeDelegatePermissions Methods

The methods of the ExchangeDelegatePermissions class are listed below. For a complete list of ExchangeDelegatePermissions class members, see the ExchangeDelegatePermissions Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetPermissionLevel | Sets the permission level on all folders to the specified value
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExchangeDelegatePermissions Class | Aspose.Email.Exchange Namespace


ExchangeDelegatePermissions.SetPermissionLevel Method

Sets the permission level on all folders to the specified value

public void SetPermissionLevel(
ExchangeDelegateFolderPermissionLevel permissionLevel
);

Parameters

permissionLevel
A premission level on all folders

See Also

ExchangeDelegatePermissions Class | Aspose.Email.Exchange Namespace


ExchangeDelegateUser Class

Represents a user who is granted access to the principal mailbox

For a list of all members of this type, see ExchangeDelegateUser Members.

System.Object
Aspose.Email.Exchange.ExchangeDelegateUser

public sealed class ExchangeDelegateUser

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExchangeDelegateUser Members | Aspose.Email.Exchange Namespace


ExchangeDelegateUser Members

ExchangeDelegateUser overview

Public Instance Constructors

ExchangeDelegateUser Overloaded. Initializes a new instance of the ExchangeDelegateUser class.

Public Instance Properties

FolderPermissions | Gets or sets the folder permissions for the delegate user
Options | Gets or sets additional options
UserInfo | Gets or sets the user information

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ExchangeDelegateUser Class | Aspose.Email.Exchange Namespace


ExchangeDelegateUser Constructor

Initializes a new instance of the ExchangeDelegateUser class

Overload List

Initializes a new instance of the ExchangeDelegateUser class

public ExchangeDelegateUser();

Initializes a new instance of the ExchangeDelegateUser class for the specified user and sets the specified permission level on all folders

public ExchangeDelegateUser(string,ExchangeDelegateFolderPermissionLevel);

See Also

ExchangeDelegateUser Class | Aspose.Email.Exchange Namespace


ExchangeDelegateUser Constructor ()

Initializes a new instance of the ExchangeDelegateUser class

public ExchangeDelegateUser();

See Also

ExchangeDelegateUser Class | Aspose.Email.Exchange Namespace | ExchangeDelegateUser Constructor Overload List


ExchangeDelegateUser Constructor (String, ExchangeDelegateFolderPermissionLevel)

Initializes a new instance of the ExchangeDelegateUser class for the specified user and sets the specified permission level on all folders

public ExchangeDelegateUser(
string primarySmtpAddress,
ExchangeDelegateFolderPermissionLevel permissionLevel
);

Parameters

primarySmtpAddress
A user primary smtp address
permissionLevel
A permission level that is granted to the user on all folders

See Also

ExchangeDelegateUser Class | Aspose.Email.Exchange Namespace | ExchangeDelegateUser Constructor Overload List


ExchangeDelegateUser Properties

The properties of the ExchangeDelegateUser class are listed below. For a complete list of ExchangeDelegateUser class members, see the ExchangeDelegateUser Members topic.

Public Instance Properties

FolderPermissions | Gets or sets the folder permissions for the delegate user
Options | Gets or sets additional options
UserInfo | Gets or sets the user information

See Also

ExchangeDelegateUser Class | Aspose.Email.Exchange Namespace


FolderPermissions Property

Aspose.Email

ExchangeDelegateUser.FolderPermissions Property

Gets or sets the folder permissions for the delegate user

public ExchangeDelegatePermissions FolderPermissions {get; set;}

See Also

ExchangeDelegateUser Class | Aspose.Email.Exchange Namespace


Options Property

Aspose.Email

ExchangeDelegateUser.Options Property

Gets or sets additional options

public ExchangeDelegateOptions Options {get; set;}

See Also

ExchangeDelegateUser Class | Aspose.Email.Exchange Namespace


UserInfo Property

Aspose.Email

ExchangeDelegateUser.UserInfo Property

Gets or sets the user information

public ExchangeFolderUserInfo UserInfo {get; set;}

See Also

ExchangeDelegateUser Class | Aspose.Email.Exchange Namespace


ExchangeDelegateUserCollection Class

Represents the collection of ExchangeDelegateUser

For a list of all members of this type, see ExchangeDelegateUserCollection Members.

System.Object
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Exchange.ExchangeDelegateUser, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]]
Aspose.Email.Exchange.ExchangeDelegateUserCollection

public sealed class ExchangeDelegateUserCollection : Collection`1

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExchangeDelegateUserCollection Members | Aspose.Email.Exchange Namespace


ExchangeDelegateUserCollection Members

ExchangeDelegateUserCollection overview

Public Instance Constructors

ExchangeDelegateUserCollection Constructor Initializes a new instance of the ExchangeDelegateUserCollection class.

Public Instance Properties

Count (inherited from 0, Culture=neutral, PublicKeyToken=null]])
Item (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ExchangeDelegateUserCollection Class | Aspose.Email.Exchange Namespace


ExchangeDelegateUserCollection Constructor

Initializes a new instance of the ExchangeDelegateUserCollection class.

public ExchangeDelegateUserCollection();

See Also

ExchangeDelegateUserCollection Class | Aspose.Email.Exchange Namespace


ExchangeException Class

Thrown if there is a MS Exchange communication failure.

For a list of all members of this type, see ExchangeException Members.

System.Object
System.Exception
Aspose.Email.AsposeException
Aspose.Email.Exchange.ExchangeException

public class ExchangeException : AsposeException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExchangeException Members | Aspose.Email.Exchange Namespace


ExchangeException Members

ExchangeException overview

Public Instance Constructors

ExchangeException Overloaded. Initializes a new instance of the ExchangeException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from AsposeException) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from AsposeException) | Returns a string that represents the current object.

Protected Instance Constructors

ExchangeException Overloaded. Initializes a new instance of the ExchangeException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

_message (inherited from AsposeException)
Exception_EndOfInnerExceptionStack (inherited from AsposeException)

See Also

ExchangeException Class | Aspose.Email.Exchange Namespace


ExchangeException Constructor

Initializes a new instance of the ExchangeException class.

Overload List

Initializes a new instance of the ExchangeException class.

public ExchangeException();

protected ExchangeException(SerializationInfo,StreamingContext);

Initializes a new instance of the ExchangeException class.

public ExchangeException(string);

Initializes a new instance of the ExchangeException class.

public ExchangeException(string,Exception);

See Also

ExchangeException Class | Aspose.Email.Exchange Namespace


ExchangeException Constructor ()

Initializes a new instance of the ExchangeException class.

public ExchangeException();

See Also

ExchangeException Class | Aspose.Email.Exchange Namespace | ExchangeException Constructor Overload List


ExchangeException Constructor (String)

Initializes a new instance of the ExchangeException class.

public ExchangeException(
string message
);

Parameters

message
The error message.

See Also

ExchangeException Class | Aspose.Email.Exchange Namespace | ExchangeException Constructor Overload List


ExchangeException Constructor (String, Exception)

Initializes a new instance of the ExchangeException class.

public ExchangeException(
string message,
Exception innerException
);

Parameters

message
The error message.
innerException
The inner exception.

See Also

ExchangeException Class | Aspose.Email.Exchange Namespace | ExchangeException Constructor Overload List


ExchangeException Constructor (SerializationInfo, StreamingContext)

protected ExchangeException(
SerializationInfo info,
StreamingContext context
);

See Also

ExchangeException Class | Aspose.Email.Exchange Namespace | ExchangeException Constructor Overload List


ExchangeFolderInfo Class

Provides information about an MS Exchange folder.

For a list of all members of this type, see ExchangeFolderInfo Members.

System.Object
Aspose.Email.Exchange.ExchangeFolderInfo

public class ExchangeFolderInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExchangeFolderInfo Members | Aspose.Email.Exchange Namespace


ExchangeFolderInfo Members

ExchangeFolderInfo overview

Public Instance Constructors

ExchangeFolderInfo Constructor Initializes a new instance of the ExchangeFolderInfo class

Public Instance Properties

ChildFolderCount | Count of child folders
DisplayName | Display name of folder
ParentUri | Parent folder uri
TotaCount | Obsolete. Gets the total count of items.
TotalCount | Gets the total count of items.
UnreadCount | Gets the count of unread items.
Uri | Folder Uri

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExchangeFolderInfo Class | Aspose.Email.Exchange Namespace


ExchangeFolderInfo Constructor

Initializes a new instance of the ExchangeFolderInfo class

public ExchangeFolderInfo();

See Also

ExchangeFolderInfo Class | Aspose.Email.Exchange Namespace


ExchangeFolderInfo Properties

The properties of the ExchangeFolderInfo class are listed below. For a complete list of ExchangeFolderInfo class members, see the ExchangeFolderInfo Members topic.

Public Instance Properties

ChildFolderCount | Count of child folders
DisplayName | Display name of folder
ParentUri | Parent folder uri
TotaCount | Obsolete. Gets the total count of items.
TotalCount | Gets the total count of items.
UnreadCount | Gets the count of unread items.
Uri | Folder Uri

See Also

ExchangeFolderInfo Class | Aspose.Email.Exchange Namespace


ChildFolderCount Property

Aspose.Email

ExchangeFolderInfo.ChildFolderCount Property

Count of child folders

public int ChildFolderCount {get; set;}

See Also

ExchangeFolderInfo Class | Aspose.Email.Exchange Namespace


DisplayName Property

Aspose.Email

ExchangeFolderInfo.DisplayName Property

Display name of folder

public string DisplayName {get; set;}

See Also

ExchangeFolderInfo Class | Aspose.Email.Exchange Namespace


ParentUri Property

Aspose.Email

ExchangeFolderInfo.ParentUri Property

Parent folder uri

public string ParentUri {get; set;}

See Also

ExchangeFolderInfo Class | Aspose.Email.Exchange Namespace


TotaCount Property

Aspose.Email

ExchangeFolderInfo.TotaCount Property

NOTE: This property is now obsolete.

Use TotalCount property instead.

Gets the total count of items.

public int TotaCount {get; set;}

Property Value

The total count.

See Also

ExchangeFolderInfo Class | Aspose.Email.Exchange Namespace


TotalCount Property

Aspose.Email

ExchangeFolderInfo.TotalCount Property

Gets the total count of items.

public int TotalCount {get; set;}

Property Value

The total count.

See Also

ExchangeFolderInfo Class | Aspose.Email.Exchange Namespace


UnreadCount Property

Aspose.Email

ExchangeFolderInfo.UnreadCount Property

Gets the count of unread items.

public int UnreadCount {get; set;}

Property Value

The unread items count.

See Also

ExchangeFolderInfo Class | Aspose.Email.Exchange Namespace


Uri Property

Aspose.Email

ExchangeFolderInfo.Uri Property

Folder Uri

public string Uri {get; set;}

See Also

ExchangeFolderInfo Class | Aspose.Email.Exchange Namespace


ExchangeFolderInfoCollection Class

Represents a collection of ExchangeMessageInfo objects.

For a list of all members of this type, see ExchangeFolderInfoCollection Members.

System.Object
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Exchange.ExchangeFolderInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]]
Aspose.Email.Exchange.ExchangeFolderInfoCollection

public class ExchangeFolderInfoCollection : Collection`1

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExchangeFolderInfoCollection Members | Aspose.Email.Exchange Namespace


ExchangeFolderInfoCollection Members

ExchangeFolderInfoCollection overview

Public Instance Constructors

ExchangeFolderInfoCollection Constructor Initializes a new instance of the ExchangeFolderInfoCollection class.

Public Instance Properties

Count (inherited from 0, Culture=neutral, PublicKeyToken=null]])
Item (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Items (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Protected Instance Methods

ClearItems (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
InsertItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RemoveItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
SetItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |

See Also

ExchangeFolderInfoCollection Class | Aspose.Email.Exchange Namespace


ExchangeFolderInfoCollection Constructor

Initializes a new instance of the ExchangeFolderInfoCollection class.

public ExchangeFolderInfoCollection();

See Also

ExchangeFolderInfoCollection Class | Aspose.Email.Exchange Namespace


ExchangeFolderPermission Class

Represents a permission on a folder.

For a list of all members of this type, see ExchangeFolderPermission Members.

System.Object
Aspose.Email.Exchange.ExchangeBasePermission
Aspose.Email.Exchange.ExchangeFolderPermission

public sealed class ExchangeFolderPermission : ExchangeBasePermission

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExchangeFolderPermission Members | Aspose.Email.Exchange Namespace


ExchangeFolderPermission Members

ExchangeFolderPermission overview

Public Static Type Conversions

Implicit ExchangeFolderPermission to PermissionType Conversion | Converts this instance into PermissionType
Implicit PermissionType to ExchangeFolderPermission Conversion | Performs an implicit conversion from PermissionType to ExchangeFolderPermission.

Public Instance Constructors

ExchangeFolderPermission Constructor Initializes a new instance of the ExchangeFolderPermission class

Public Instance Properties

CanCreateItems (inherited from ExchangeBasePermission) | Gets or sets a value indicating whether a client can create items in a folder.
CanCreateSubFolders (inherited from ExchangeBasePermission) | Gets or sets a value indicating whether the client can create subfolders.
DeleteItems (inherited from ExchangeBasePermission) | Gets or sets a value indicating whether the client can delete items.
EditItems (inherited from ExchangeBasePermission) | Gets or sets a value indicating whether a client can edit items.
IsFolderContact (inherited from ExchangeBasePermission) | Gets or sets a value indicating whether a user is a contact for a folder.
IsFolderOwner (inherited from ExchangeBasePermission) | Gets or sets a value indicating whether the user is the owner of a folder.
IsFolderVisible (inherited from ExchangeBasePermission) | Gets or sets a value indicating whether a user can view a folder.
PermissionLevel | Gets or sets the combination of permissions that a user has on a folder.
ReadItems | Gets or sets a value indicating whether a user has permission to read items in a folder.
UserInfo (inherited from ExchangeBasePermission) | Gets or sets a user or a delegate user who has folder access permissions

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ExchangeFolderPermission Class | Aspose.Email.Exchange Namespace


ExchangeFolderPermission Constructor

Initializes a new instance of the ExchangeFolderPermission class

public ExchangeFolderPermission(
ExchangeFolderUserInfo userInfo
);

Parameters

userInfo
Specifies a user or a delegate user who has folder access permissions

Exceptions

Exception Type | Condition
ArgumentNullException | userInfo is null

See Also

ExchangeFolderPermission Class | Aspose.Email.Exchange Namespace


ExchangeFolderPermission Properties

The properties of the ExchangeFolderPermission class are listed below. For a complete list of ExchangeFolderPermission class members, see the ExchangeFolderPermission Members topic.

Public Instance Properties

CanCreateItems (inherited from ExchangeBasePermission) | Gets or sets a value indicating whether a client can create items in a folder.
CanCreateSubFolders (inherited from ExchangeBasePermission) | Gets or sets a value indicating whether the client can create subfolders.
DeleteItems (inherited from ExchangeBasePermission) | Gets or sets a value indicating whether the client can delete items.
EditItems (inherited from ExchangeBasePermission) | Gets or sets a value indicating whether a client can edit items.
IsFolderContact (inherited from ExchangeBasePermission) | Gets or sets a value indicating whether a user is a contact for a folder.
IsFolderOwner (inherited from ExchangeBasePermission) | Gets or sets a value indicating whether the user is the owner of a folder.
IsFolderVisible (inherited from ExchangeBasePermission) | Gets or sets a value indicating whether a user can view a folder.
PermissionLevel | Gets or sets the combination of permissions that a user has on a folder.
ReadItems | Gets or sets a value indicating whether a user has permission to read items in a folder.
UserInfo (inherited from ExchangeBasePermission) | Gets or sets a user or a delegate user who has folder access permissions

See Also

ExchangeFolderPermission Class | Aspose.Email.Exchange Namespace


PermissionLevel Property

Aspose.Email

ExchangeFolderPermission.PermissionLevel Property

Gets or sets the combination of permissions that a user has on a folder.

public ExchangeFolderPermissionLevel PermissionLevel {get; set;}

See Also

ExchangeFolderPermission Class | Aspose.Email.Exchange Namespace


ReadItems Property

Aspose.Email

ExchangeFolderPermission.ReadItems Property

Gets or sets a value indicating whether a user has permission to read items in a folder.

public ExchangeFolderPermissionReadAccess ReadItems {get; set;}

See Also

ExchangeFolderPermission Class | Aspose.Email.Exchange Namespace


ExchangeFolderPermission Type Conversions

The type conversions of the ExchangeFolderPermission class are listed below. For a complete list of ExchangeFolderPermission class members, see the ExchangeFolderPermission Members topic.

Public Static Type Conversions

Implicit ExchangeFolderPermission to PermissionType Conversion | Converts this instance into PermissionType
Implicit PermissionType to ExchangeFolderPermission Conversion | Performs an implicit conversion from PermissionType to ExchangeFolderPermission.

See Also

ExchangeFolderPermission Class | ExchangeFolderPermission Members | Aspose.Email.Exchange Namespace


ExchangeFolderPermission Implicit ExchangeFolderPermission to PermissionType Conversion

NOTE: This operator is now obsolete.

Converts this instance into PermissionType

public static implicit operator PermissionType(
ExchangeFolderPermission permission
);

Parameters

permission
An instance of the ExchangeFolderPermission class

Return Value

A created PermissionType

See Also

ExchangeFolderPermission Class | Aspose.Email.Exchange Namespace


ExchangeFolderPermission Implicit PermissionType to ExchangeFolderPermission Conversion

NOTE: This operator is now obsolete.

Performs an implicit conversion from PermissionType to ExchangeFolderPermission.

public static implicit operator ExchangeFolderPermission(
PermissionType permission
);

Parameters

permission
The PermissionType that defines the access that a user has to a folder.

Return Value

The result of the conversion.

See Also

ExchangeFolderPermission Class | Aspose.Email.Exchange Namespace


ExchangeFolderPermissionAction Enumeration

Defines which items in a folder a user has permission to edit or delete.

public enum ExchangeFolderPermissionAction

Members

Member Name | Description | Value
None | Indicates that the user does not have permission to perform the action on any items in the folder. | 0
Owned | Indicates that the user has permission to perform the action on the items in the folder that the user owns. | 1
All | Indicates that the user has permission to perform the action on all items in the folder. | 2

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange Namespace


ExchangeFolderPermissionCollection Class

Represents the collection of ExchangeFolderPermission

For a list of all members of this type, see ExchangeFolderPermissionCollection Members.

System.Object
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Exchange.ExchangeFolderPermission, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]]
Aspose.Email.Exchange.ExchangeFolderPermissionCollection

public sealed class ExchangeFolderPermissionCollection : Collection`1

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExchangeFolderPermissionCollection Members | Aspose.Email.Exchange Namespace


ExchangeFolderPermissionCollection Members

ExchangeFolderPermissionCollection overview

Public Instance Constructors

ExchangeFolderPermissionCollection Constructor Initializes a new instance of the ExchangeFolderPermissionCollection class.

Public Instance Properties

Count (inherited from 0, Culture=neutral, PublicKeyToken=null]])
Item (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ExchangeFolderPermissionCollection Class | Aspose.Email.Exchange Namespace


ExchangeFolderPermissionCollection Constructor

Initializes a new instance of the ExchangeFolderPermissionCollection class.

public ExchangeFolderPermissionCollection();

See Also

ExchangeFolderPermissionCollection Class | Aspose.Email.Exchange Namespace


ExchangeFolderPermissionLevel Enumeration

Specifies the permission level that a user has on a folder.

public enum ExchangeFolderPermissionLevel

Members

Member Name | Description | Value
None | The user has no permissions on the folder. | 0
Owner | The user can create, read, edit, and delete all items in the folder and create subfolders. The user is both folder owner and folder contact. | 983
PublishingEditor | The user can create, read, edit, and delete all items in the folder, and create subfolders. | 215
Editor | The user can create, read, edit, and delete all items in the folder. | 87
PublishingAuthor | The user can create and read all items in the folder, edit and delete only items that the user creates, and create subfolders. | 175
Author | The user can create and read all items in the folder, and edit and delete only items that the user creates. | 47
NoneditingAuthor | The user can create and read all items in the folder, and delete only items that the user creates. | 15
Reviewer | The user can read all items in the folder. | 3
Contributor | The user can create items in the folder. The contents of the folder do not appear. | 5
Custom | The user has custom access permissions on the folder. | 1073741824

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange Namespace


ExchangeFolderPermissionReadAccess Enumeration

Sspecifies whether a user has permission to read items in a folder.

public enum ExchangeFolderPermissionReadAccess

Members

Member Name | Description | Value
None | The user does not have permission to read items in the folder. | 0
FullDetails | The user has permission to read all items in the folder. | 1

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange Namespace


ExchangeFolderUserInfo Class

Represents a user who has folder access permissions

For a list of all members of this type, see ExchangeFolderUserInfo Members.

System.Object
Aspose.Email.Exchange.ExchangeFolderUserInfo

public sealed class ExchangeFolderUserInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExchangeFolderUserInfo Members | Aspose.Email.Exchange Namespace


ExchangeFolderUserInfo Members

ExchangeFolderUserInfo overview

Public Static Properties

AnonymousUser | Gets Anonymous user account
DefaultUser | Gets Default user account

Public Instance Constructors

ExchangeFolderUserInfo Constructor Initializes a new instance of the ExchangeFolderUserInfo class

Public Instance Properties

DisplayName | Gets or sets the user name for display.
PrimarySmtpAddress | Gets or sets the primary SMTP address of an account.
Sid | Gets or sets the security descriptor definition language (SSDL) form of the security identifier (SID) for a user.
UserAccountType | Gets or sets a value that identifies the Anonymous and Default user accounts for delegate access.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ExchangeFolderUserInfo Class | Aspose.Email.Exchange Namespace


ExchangeFolderUserInfo Constructor

Initializes a new instance of the ExchangeFolderUserInfo class

public ExchangeFolderUserInfo();

See Also

ExchangeFolderUserInfo Class | Aspose.Email.Exchange Namespace


ExchangeFolderUserInfo Properties

The properties of the ExchangeFolderUserInfo class are listed below. For a complete list of ExchangeFolderUserInfo class members, see the ExchangeFolderUserInfo Members topic.

Public Static Properties

AnonymousUser | Gets Anonymous user account
DefaultUser | Gets Default user account

Public Instance Properties

DisplayName | Gets or sets the user name for display.
PrimarySmtpAddress | Gets or sets the primary SMTP address of an account.
Sid | Gets or sets the security descriptor definition language (SSDL) form of the security identifier (SID) for a user.
UserAccountType | Gets or sets a value that identifies the Anonymous and Default user accounts for delegate access.

See Also

ExchangeFolderUserInfo Class | Aspose.Email.Exchange Namespace


AnonymousUser Property

Aspose.Email

ExchangeFolderUserInfo.AnonymousUser Property

Gets Anonymous user account

public static ExchangeFolderUserInfo AnonymousUser {get;}

See Also

ExchangeFolderUserInfo Class | Aspose.Email.Exchange Namespace


DefaultUser Property

Aspose.Email

ExchangeFolderUserInfo.DefaultUser Property

Gets Default user account

public static ExchangeFolderUserInfo DefaultUser {get;}

See Also

ExchangeFolderUserInfo Class | Aspose.Email.Exchange Namespace


DisplayName Property

Aspose.Email

ExchangeFolderUserInfo.DisplayName Property

Gets or sets the user name for display.

public string DisplayName {get; set;}

See Also

ExchangeFolderUserInfo Class | Aspose.Email.Exchange Namespace


PrimarySmtpAddress Property

Aspose.Email

ExchangeFolderUserInfo.PrimarySmtpAddress Property

Gets or sets the primary SMTP address of an account.

public string PrimarySmtpAddress {get; set;}

See Also

ExchangeFolderUserInfo Class | Aspose.Email.Exchange Namespace


Sid Property

Aspose.Email

ExchangeFolderUserInfo.Sid Property

Gets or sets the security descriptor definition language (SSDL) form of the security identifier (SID) for a user.

public string Sid {get; set;}

See Also

ExchangeFolderUserInfo Class | Aspose.Email.Exchange Namespace


UserAccountType Property

Aspose.Email

ExchangeFolderUserInfo.UserAccountType Property

Gets or sets a value that identifies the Anonymous and Default user accounts for delegate access.

public ExchangeFolderUserType UserAccountType {get; set;}

See Also

ExchangeFolderUserInfo Class | Aspose.Email.Exchange Namespace


ExchangeFolderUserType Enumeration

Enumerates the distinguished user accounts

public enum ExchangeFolderUserType

Members

Member Name | Description | Value
Default | Specifies the default user account. | 0
Anonymous | Specifies the anonymous user account. | 1
Undistinguished | Specifies the undistinguished user account. | 2

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange Namespace


ExchangeListContactsOptions Enumeration

Enumerates the list contacts options

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum ExchangeListContactsOptions

Members

Member Name | Description | Value
None | No specific options are defined | 0
FetchAttachmentAndPhotoInformation | Determines that the attachment and photo information should be fetched | 1
FetchAttachmentAndFullPhotoInformation | Determines that the attachment and full photo information should be fetched | 2

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange Namespace


ExchangeListMessagesOptions Enumeration

Enumerates the list messages options

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum ExchangeListMessagesOptions

Members

Member Name | Description | Value
None | No specific options are defined | 0
ListRecursive | Indicates recursive listing | 1
FetchAttachmentInformation | Determines that the attachment information should be fetched | 2

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange Namespace


ExchangeMailboxInfo Class

Represents the mail box information of an exchange server.

For a list of all members of this type, see ExchangeMailboxInfo Members.

System.Object
Aspose.Email.Exchange.ExchangeMailboxInfo

public abstract class ExchangeMailboxInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExchangeMailboxInfo Members | Aspose.Email.Exchange Namespace


ExchangeMailboxInfo Members

ExchangeMailboxInfo overview

Public Instance Properties

CalendarUri | Gets the calendar uri.
ContactsUri | Gets the contracts uri.
DeletedItemsUri | Gets the deleted items uri.
DraftsUri | Gets the drafts uri.
InboxUri | Gets the inbox uri.
JournalUri | Gets the journal uri.
JunkeMailsUri | Gets or sets the junke mails uri.
MailboxUri | Gets the mailbox uri.
NotesUri | Gets the notes uri.
OutboxUri | Gets the outbox uri.
RootUri | Gets the root uri.
SentItemsUri | Gets the sent items uri.
SubmissionUri | Gets the submission uri.
TasksUri | Gets the tasks uri.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

ExchangeMailboxInfo Overloaded. Initializes a new instance of the ExchangeMailboxInfo class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExchangeMailboxInfo Class | Aspose.Email.Exchange Namespace


ExchangeMailboxInfo Constructor

Initializes a new instance of the ExchangeMailboxInfo class.

Overload List

Initializes a new instance of the ExchangeMailboxInfo class.

protected ExchangeMailboxInfo();

protected ExchangeMailboxInfo(string);

See Also

ExchangeMailboxInfo Class | Aspose.Email.Exchange Namespace


ExchangeMailboxInfo Constructor ()

Initializes a new instance of the ExchangeMailboxInfo class.

protected ExchangeMailboxInfo();

See Also

ExchangeMailboxInfo Class | Aspose.Email.Exchange Namespace | ExchangeMailboxInfo Constructor Overload List


ExchangeMailboxInfo Constructor (String)

protected ExchangeMailboxInfo(
string mailBoxUri
);

See Also

ExchangeMailboxInfo Class | Aspose.Email.Exchange Namespace | ExchangeMailboxInfo Constructor Overload List


ExchangeMailboxInfo Properties

The properties of the ExchangeMailboxInfo class are listed below. For a complete list of ExchangeMailboxInfo class members, see the ExchangeMailboxInfo Members topic.

Public Instance Properties

CalendarUri | Gets the calendar uri.
ContactsUri | Gets the contracts uri.
DeletedItemsUri | Gets the deleted items uri.
DraftsUri | Gets the drafts uri.
InboxUri | Gets the inbox uri.
JournalUri | Gets the journal uri.
JunkeMailsUri | Gets or sets the junke mails uri.
MailboxUri | Gets the mailbox uri.
NotesUri | Gets the notes uri.
OutboxUri | Gets the outbox uri.
RootUri | Gets the root uri.
SentItemsUri | Gets the sent items uri.
SubmissionUri | Gets the submission uri.
TasksUri | Gets the tasks uri.

See Also

ExchangeMailboxInfo Class | Aspose.Email.Exchange Namespace


CalendarUri Property

Aspose.Email

ExchangeMailboxInfo.CalendarUri Property

Gets the calendar uri.

public abstract string CalendarUri {get; set;}

See Also

ExchangeMailboxInfo Class | Aspose.Email.Exchange Namespace


ContactsUri Property

Aspose.Email

ExchangeMailboxInfo.ContactsUri Property

Gets the contracts uri.

public abstract string ContactsUri {get; set;}

See Also

ExchangeMailboxInfo Class | Aspose.Email.Exchange Namespace


DeletedItemsUri Property

Aspose.Email

ExchangeMailboxInfo.DeletedItemsUri Property

Gets the deleted items uri.

public abstract string DeletedItemsUri {get; set;}

See Also

ExchangeMailboxInfo Class | Aspose.Email.Exchange Namespace


DraftsUri Property

Aspose.Email

ExchangeMailboxInfo.DraftsUri Property

Gets the drafts uri.

public abstract string DraftsUri {get; set;}

See Also

ExchangeMailboxInfo Class | Aspose.Email.Exchange Namespace


InboxUri Property

Aspose.Email

ExchangeMailboxInfo.InboxUri Property

Gets the inbox uri.

public abstract string InboxUri {get; set;}

See Also

ExchangeMailboxInfo Class | Aspose.Email.Exchange Namespace


JournalUri Property

Aspose.Email

ExchangeMailboxInfo.JournalUri Property

Gets the journal uri.

public abstract string JournalUri {get; set;}

See Also

ExchangeMailboxInfo Class | Aspose.Email.Exchange Namespace


JunkeMailsUri Property

Aspose.Email

ExchangeMailboxInfo.JunkeMailsUri Property

Gets or sets the junke mails uri.

public abstract string JunkeMailsUri {get; set;}

See Also

ExchangeMailboxInfo Class | Aspose.Email.Exchange Namespace


MailboxUri Property

Aspose.Email

ExchangeMailboxInfo.MailboxUri Property

Gets the mailbox uri.

public virtual string MailboxUri {get; set;}

See Also

ExchangeMailboxInfo Class | Aspose.Email.Exchange Namespace


NotesUri Property

Aspose.Email

ExchangeMailboxInfo.NotesUri Property

Gets the notes uri.

public abstract string NotesUri {get; set;}

See Also

ExchangeMailboxInfo Class | Aspose.Email.Exchange Namespace


OutboxUri Property

Aspose.Email

ExchangeMailboxInfo.OutboxUri Property

Gets the outbox uri.

public abstract string OutboxUri {get; set;}

See Also

ExchangeMailboxInfo Class | Aspose.Email.Exchange Namespace


RootUri Property

Aspose.Email

ExchangeMailboxInfo.RootUri Property

Gets the root uri.

public abstract string RootUri {get; set;}

See Also

ExchangeMailboxInfo Class | Aspose.Email.Exchange Namespace


SentItemsUri Property

Aspose.Email

ExchangeMailboxInfo.SentItemsUri Property

Gets the sent items uri.

public abstract string SentItemsUri {get; set;}

See Also

ExchangeMailboxInfo Class | Aspose.Email.Exchange Namespace


SubmissionUri Property

Aspose.Email

ExchangeMailboxInfo.SubmissionUri Property

Gets the submission uri.

public abstract string SubmissionUri {get; set;}

See Also

ExchangeMailboxInfo Class | Aspose.Email.Exchange Namespace


TasksUri Property

Aspose.Email

ExchangeMailboxInfo.TasksUri Property

Gets the tasks uri.

public abstract string TasksUri {get; set;}

See Also

ExchangeMailboxInfo Class | Aspose.Email.Exchange Namespace


ExchangeMessageFlag Enumeration

Represents a flags of message.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum ExchangeMessageFlag

Members

Member Name | Description | Value
IsRead | Indicates whether the message has been read. | 1
HasAttachment | Indicates whether or not the message has attachments. | 2
IsSubmitted | Indicates whether the message has been submitted to the Outbox. | 4

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange Namespace


ExchangeMessageInfo Class

The ExchangeMessageInfo represents the E-Mail message info fetched from the Exchange Store.

For a list of all members of this type, see ExchangeMessageInfo Members.

System.Object
Aspose.Email.Exchange.ExchangeMessageInfo

public abstract class ExchangeMessageInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExchangeMessageInfo Members | Aspose.Email.Exchange Namespace


ExchangeMessageInfo Members

ExchangeMessageInfo overview

Public Instance Properties

Attachments | Gets message attachments
CC | Gets CC of the E-Mail message.
Date | Gets the sent date
From | Gets the From of the E-Mail message.
HasAttachments | Gets a value indicating whether the message contains at least one attachment.
IsRead | Gets a value that specifies whether the message has been read
MessageId | Gets the message id.
Subject | Gets the Subject of the E-Mail message.
To | Gets the receiptants of the E-Mail message.
UniqueUri | Gets the unique URI of message.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

ExchangeMessageInfo Constructor Initializes a new instance of the ExchangeMessageInfo class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExchangeMessageInfo Class | Aspose.Email.Exchange Namespace


ExchangeMessageInfo Constructor

Initializes a new instance of the ExchangeMessageInfo class.

protected ExchangeMessageInfo();

See Also

ExchangeMessageInfo Class | Aspose.Email.Exchange Namespace


ExchangeMessageInfo Properties

The properties of the ExchangeMessageInfo class are listed below. For a complete list of ExchangeMessageInfo class members, see the ExchangeMessageInfo Members topic.

Public Instance Properties

Attachments | Gets message attachments
CC | Gets CC of the E-Mail message.
Date | Gets the sent date
From | Gets the From of the E-Mail message.
HasAttachments | Gets a value indicating whether the message contains at least one attachment.
IsRead | Gets a value that specifies whether the message has been read
MessageId | Gets the message id.
Subject | Gets the Subject of the E-Mail message.
To | Gets the receiptants of the E-Mail message.
UniqueUri | Gets the unique URI of message.

See Also

ExchangeMessageInfo Class | Aspose.Email.Exchange Namespace


Attachments Property

Aspose.Email

ExchangeMessageInfo.Attachments Property

Gets message attachments

public virtual ExchangeAttachmentInfoCollection Attachments {get;}

See Also

ExchangeMessageInfo Class | Aspose.Email.Exchange Namespace


CC Property

Aspose.Email

ExchangeMessageInfo.CC Property

Gets CC of the E-Mail message.

public virtual MailAddressCollection CC {get;}

See Also

ExchangeMessageInfo Class | Aspose.Email.Exchange Namespace


Date Property

Aspose.Email

ExchangeMessageInfo.Date Property

Gets the sent date

public virtual DateTime Date {get;}

Property Value

The sent date

See Also

ExchangeMessageInfo Class | Aspose.Email.Exchange Namespace


From Property

Aspose.Email

ExchangeMessageInfo.From Property

Gets the From of the E-Mail message.

public virtual MailAddress From {get;}

See Also

ExchangeMessageInfo Class | Aspose.Email.Exchange Namespace


HasAttachments Property

Aspose.Email

ExchangeMessageInfo.HasAttachments Property

Gets a value indicating whether the message contains at least one attachment.

public abstract bool HasAttachments {get; set;}

See Also

ExchangeMessageInfo Class | Aspose.Email.Exchange Namespace


IsRead Property

Aspose.Email

ExchangeMessageInfo.IsRead Property

Gets a value that specifies whether the message has been read

public abstract bool IsRead {get; set;}

See Also

ExchangeMessageInfo Class | Aspose.Email.Exchange Namespace


MessageId Property

Aspose.Email

ExchangeMessageInfo.MessageId Property

Gets the message id.

public virtual string MessageId {get;}

Property Value

The message id.

See Also

ExchangeMessageInfo Class | Aspose.Email.Exchange Namespace


Subject Property

Aspose.Email

ExchangeMessageInfo.Subject Property

Gets the Subject of the E-Mail message.

public string Subject {get;}

See Also

ExchangeMessageInfo Class | Aspose.Email.Exchange Namespace


To Property

Aspose.Email

ExchangeMessageInfo.To Property

Gets the receiptants of the E-Mail message.

public virtual MailAddressCollection To {get;}

See Also

ExchangeMessageInfo Class | Aspose.Email.Exchange Namespace


UniqueUri Property

Aspose.Email

ExchangeMessageInfo.UniqueUri Property

Gets the unique URI of message.

public abstract string UniqueUri {get; set;}

Property Value

The string that represents the unique URI.

See Also

ExchangeMessageInfo Class | Aspose.Email.Exchange Namespace


ExchangeMessageInfoCollection Class

Represents a collection of ExchangeMessageInfo objects.

For a list of all members of this type, see ExchangeMessageInfoCollection Members.

System.Object
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Exchange.ExchangeMessageInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]]
Aspose.Email.Exchange.ExchangeMessageInfoCollection

public class ExchangeMessageInfoCollection : Collection`1

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExchangeMessageInfoCollection Members | Aspose.Email.Exchange Namespace


ExchangeMessageInfoCollection Members

ExchangeMessageInfoCollection overview

Public Instance Constructors

ExchangeMessageInfoCollection Constructor Initializes a new instance of the ExchangeMessageInfoCollection class.

Public Instance Properties

Count (inherited from 0, Culture=neutral, PublicKeyToken=null]])
Item (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Items (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Protected Instance Methods

ClearItems (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
InsertItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RemoveItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
SetItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |

See Also

ExchangeMessageInfoCollection Class | Aspose.Email.Exchange Namespace


ExchangeMessageInfoCollection Constructor

Initializes a new instance of the ExchangeMessageInfoCollection class.

public ExchangeMessageInfoCollection();

See Also

ExchangeMessageInfoCollection Class | Aspose.Email.Exchange Namespace


ExchangePermissionCollection Class

Represents the collection of ExchangeBasePermission

For a list of all members of this type, see ExchangePermissionCollection Members.

System.Object
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Exchange.ExchangeBasePermission, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]]
Aspose.Email.Exchange.ExchangePermissionCollection

public sealed class ExchangePermissionCollection : Collection`1

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExchangePermissionCollection Members | Aspose.Email.Exchange Namespace


ExchangePermissionCollection Members

ExchangePermissionCollection overview

Public Instance Constructors

ExchangePermissionCollection Constructor Initializes a new instance of the ExchangePermissionCollection class.

Public Instance Properties

Count (inherited from 0, Culture=neutral, PublicKeyToken=null]])
Item (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ExchangePermissionCollection Class | Aspose.Email.Exchange Namespace


ExchangePermissionCollection Constructor

Initializes a new instance of the ExchangePermissionCollection class.

public ExchangePermissionCollection();

See Also

ExchangePermissionCollection Class | Aspose.Email.Exchange Namespace


ExchangeQueryBuilder Class

Represents the builder of search expression that used by Exchange protocol.

For a list of all members of this type, see ExchangeQueryBuilder Members.

System.Object
Aspose.Email.MailQueryBuilder
Aspose.Email.Exchange.ExchangeQueryBuilder

public sealed class ExchangeQueryBuilder : MailQueryBuilder

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExchangeQueryBuilder Members | Aspose.Email.Exchange Namespace


ExchangeQueryBuilder Members

ExchangeQueryBuilder overview

Public Instance Constructors

ExchangeQueryBuilder Constructor Initializes a new instance of the ExchangeQueryBuilder class.

Public Instance Properties

Bcc (inherited from MailQueryBuilder) | Gets the field that allows to find messages that contain the specified string in the envelope structure's BCC field.
Body (inherited from MailQueryBuilder) | Gets the field that allows to find messages that contain the specified string in the body of the message.
Cc (inherited from MailQueryBuilder) | Gets the field that allows to find messages that contain the specified string in the envelope structure's CC field.
ContentClass | Gets items with an specified content class.
From (inherited from MailQueryBuilder) | Gets the field that allows to find messages that contain the specified string in the envelope structure's FROM field.
InternalDate (inherited from MailQueryBuilder) | Gets the field that allows to find messages by internal date.
MessageId (inherited from MailQueryBuilder) | Gets the field that allows to find messages that contain the specified string in the envelope structure's MessageId field.
SentDate (inherited from MailQueryBuilder) | Gets the field that allows to find messages by sent date.
Subject (inherited from MailQueryBuilder) | Gets the field that allows to find messages that contain the specified string in the envelope structure's SUBJECT field.
Text (inherited from MailQueryBuilder) | Gets the field that allows to find the messages that contain the specified string in the header or body of the message.
To (inherited from MailQueryBuilder) | Gets the field that allows to find messages that contain the specified string in the envelope structure's TO field.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetQuery (inherited from MailQueryBuilder) | Gets the query.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFlags | Search messages with the specified flags.
HasNoFlags | Search messages with the unspecified flags.
Or (inherited from MailQueryBuilder) | Search messages that match either search key. Provides disjunction between two expressions (OR).
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ExchangeQueryBuilder Class | Aspose.Email.Exchange Namespace


ExchangeQueryBuilder Constructor

Initializes a new instance of the ExchangeQueryBuilder class.

public ExchangeQueryBuilder();

See Also

ExchangeQueryBuilder Class | Aspose.Email.Exchange Namespace


ExchangeQueryBuilder Properties

The properties of the ExchangeQueryBuilder class are listed below. For a complete list of ExchangeQueryBuilder class members, see the ExchangeQueryBuilder Members topic.

Public Instance Properties

Bcc (inherited from MailQueryBuilder) | Gets the field that allows to find messages that contain the specified string in the envelope structure's BCC field.
Body (inherited from MailQueryBuilder) | Gets the field that allows to find messages that contain the specified string in the body of the message.
Cc (inherited from MailQueryBuilder) | Gets the field that allows to find messages that contain the specified string in the envelope structure's CC field.
ContentClass | Gets items with an specified content class.
From (inherited from MailQueryBuilder) | Gets the field that allows to find messages that contain the specified string in the envelope structure's FROM field.
InternalDate (inherited from MailQueryBuilder) | Gets the field that allows to find messages by internal date.
MessageId (inherited from MailQueryBuilder) | Gets the field that allows to find messages that contain the specified string in the envelope structure's MessageId field.
SentDate (inherited from MailQueryBuilder) | Gets the field that allows to find messages by sent date.
Subject (inherited from MailQueryBuilder) | Gets the field that allows to find messages that contain the specified string in the envelope structure's SUBJECT field.
Text (inherited from MailQueryBuilder) | Gets the field that allows to find the messages that contain the specified string in the header or body of the message.
To (inherited from MailQueryBuilder) | Gets the field that allows to find messages that contain the specified string in the envelope structure's TO field.

See Also

ExchangeQueryBuilder Class | Aspose.Email.Exchange Namespace


ContentClass Property

Aspose.Email

ExchangeQueryBuilder.ContentClass Property

Gets items with an specified content class.

public StringComparisonField ContentClass {get;}

Property Value

The StringComparisonField that represents a content class.

See Also

ExchangeQueryBuilder Class | Aspose.Email.Exchange Namespace


ExchangeQueryBuilder Methods

The methods of the ExchangeQueryBuilder class are listed below. For a complete list of ExchangeQueryBuilder class members, see the ExchangeQueryBuilder Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetQuery (inherited from MailQueryBuilder) | Gets the query.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFlags | Search messages with the specified flags.
HasNoFlags | Search messages with the unspecified flags.
Or (inherited from MailQueryBuilder) | Search messages that match either search key. Provides disjunction between two expressions (OR).
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ExchangeQueryBuilder Class | Aspose.Email.Exchange Namespace


ExchangeQueryBuilder.HasFlags Method

Search messages with the specified flags.

public MailQuery HasFlags(
ExchangeMessageFlag flags
);

Parameters

flags
The flags.

Return Value

MailQuery that represents search query (one searching criteria).

See Also

ExchangeQueryBuilder Class | Aspose.Email.Exchange Namespace


ExchangeQueryBuilder.HasNoFlags Method

Search messages with the unspecified flags.

public MailQuery HasNoFlags(
ExchangeMessageFlag flags
);

Parameters

flags
The flags.

Return Value

MailQuery that represents search query (one searching criteria).

See Also

ExchangeQueryBuilder Class | Aspose.Email.Exchange Namespace


ExchangeStreamedItem Class

Represents the item received in ExportItems response

For a list of all members of this type, see ExchangeStreamedItem Members.

System.Object
Aspose.Email.Exchange.ExchangeStreamedItem

public sealed class ExchangeStreamedItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExchangeStreamedItem Members | Aspose.Email.Exchange Namespace


ExchangeStreamedItem Members

ExchangeStreamedItem overview

Public Instance Constructors

ExchangeStreamedItem Constructor Initializes a new instance of the ExchangeStreamedItem class

Public Instance Properties

Data | Gets or sets the item data
ItemId | Gets or sets the item identifier

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ExchangeStreamedItem Class | Aspose.Email.Exchange Namespace


ExchangeStreamedItem Constructor

Initializes a new instance of the ExchangeStreamedItem class

public ExchangeStreamedItem();

See Also

ExchangeStreamedItem Class | Aspose.Email.Exchange Namespace


ExchangeStreamedItem Properties

The properties of the ExchangeStreamedItem class are listed below. For a complete list of ExchangeStreamedItem class members, see the ExchangeStreamedItem Members topic.

Public Instance Properties

Data | Gets or sets the item data
ItemId | Gets or sets the item identifier

See Also

ExchangeStreamedItem Class | Aspose.Email.Exchange Namespace


Data Property

Aspose.Email

ExchangeStreamedItem.Data Property

Gets or sets the item data

public byte[] Data {get; set;}

Exceptions

Exception Type | Condition
ArgumentNullException | value is null

See Also

ExchangeStreamedItem Class | Aspose.Email.Exchange Namespace


ItemId Property

Aspose.Email

ExchangeStreamedItem.ItemId Property

Gets or sets the item identifier

public string ItemId {get; set;}

See Also

ExchangeStreamedItem Class | Aspose.Email.Exchange Namespace


ExchangeTask Class

Represents the exchange task information.

For a list of all members of this type, see ExchangeTask Members.

System.Object
Aspose.Email.Mail.Task
Aspose.Email.Exchange.ExchangeTask

public sealed class ExchangeTask : Task

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExchangeTask Members | Aspose.Email.Exchange Namespace


ExchangeTask Members

ExchangeTask overview

Public Instance Constructors

ExchangeTask Constructor Initializes a new instance of the ExchangeTask class.

Public Instance Properties

ActualWork | Gets or sets an actual amount of time that is spent on a task (minutes).
Attachments (inherited from Task) | Gets or sets a collection of file attached to the task.
Attendees (inherited from Task) | Gets or sets the attendees.
BillingInformation | Gets or sets a billing information for the task.
Body (inherited from Task) | Gets or sets a task body.
Companies | Gets or sets a collection of companies that are associated with a task.
CompletionDate | Gets or sets a date on which a task was completed.
DueDate (inherited from Task) | Gets or sets a date when the task is due.
IsBodyHtml | Gets or sets a value indicating whether the task body is html-formatted.
Method (inherited from Task) | Gets or sets iTIP methods associated with an task.
Mileage | Gets or sets a mileage for a task.
Organizer (inherited from Task) | Gets or sets the organizer.
PercentComplete (inherited from Task) | Gets or sets a pecent of task completion.
Priority (inherited from Task) | Gets or sets a task priority.
Recurrence | Gets or sets a recurrence information for a recurring task.
RelatedTo (inherited from Task) | Gets or sets a related UID
ReminderDate | Gets or sets a task reminder date.
SequenceId (inherited from Task) | Gets or sets the sequence id.
StartDate (inherited from Task) | Gets or sets a start date of task.
Status | Gets or sets a task status.
Subject (inherited from Task) | Gets or sets a task subject.
TotalWork | Gets or sets a total amount of work that is associated with the task (minutes).
UniqueId (inherited from Task) | Gets or sets unique identifier
UniqueUri | Gets or sets an unique uri of the task.

Public Instance Methods

Dispose (inherited from Task) | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Request (inherited from Task) | Requests the object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Internal Instance Fields

_attachments (inherited from Task)
_attendees (inherited from Task)
_body (inherited from Task)
_dueDate (inherited from Task)
_method (inherited from Task)
_organizer (inherited from Task)
_percentComplete (inherited from Task)
_priority (inherited from Task)
_relatedTo (inherited from Task)
_sequeneId (inherited from Task)
_startDate (inherited from Task)
_subject (inherited from Task)
_uid (inherited from Task)

See Also

ExchangeTask Class | Aspose.Email.Exchange Namespace


ExchangeTask Constructor

Initializes a new instance of the ExchangeTask class.

public ExchangeTask();

See Also

ExchangeTask Class | Aspose.Email.Exchange Namespace


ExchangeTask Properties

The properties of the ExchangeTask class are listed below. For a complete list of ExchangeTask class members, see the ExchangeTask Members topic.

Public Instance Properties

ActualWork | Gets or sets an actual amount of time that is spent on a task (minutes).
Attachments (inherited from Task) | Gets or sets a collection of file attached to the task.
Attendees (inherited from Task) | Gets or sets the attendees.
BillingInformation | Gets or sets a billing information for the task.
Body (inherited from Task) | Gets or sets a task body.
Companies | Gets or sets a collection of companies that are associated with a task.
CompletionDate | Gets or sets a date on which a task was completed.
DueDate (inherited from Task) | Gets or sets a date when the task is due.
IsBodyHtml | Gets or sets a value indicating whether the task body is html-formatted.
Method (inherited from Task) | Gets or sets iTIP methods associated with an task.
Mileage | Gets or sets a mileage for a task.
Organizer (inherited from Task) | Gets or sets the organizer.
PercentComplete (inherited from Task) | Gets or sets a pecent of task completion.
Priority (inherited from Task) | Gets or sets a task priority.
Recurrence | Gets or sets a recurrence information for a recurring task.
RelatedTo (inherited from Task) | Gets or sets a related UID
ReminderDate | Gets or sets a task reminder date.
SequenceId (inherited from Task) | Gets or sets the sequence id.
StartDate (inherited from Task) | Gets or sets a start date of task.
Status | Gets or sets a task status.
Subject (inherited from Task) | Gets or sets a task subject.
TotalWork | Gets or sets a total amount of work that is associated with the task (minutes).
UniqueId (inherited from Task) | Gets or sets unique identifier
UniqueUri | Gets or sets an unique uri of the task.

See Also

ExchangeTask Class | Aspose.Email.Exchange Namespace


ActualWork Property

Aspose.Email

ExchangeTask.ActualWork Property

Gets or sets an actual amount of time that is spent on a task (minutes).

public int ActualWork {get; set;}

See Also

ExchangeTask Class | Aspose.Email.Exchange Namespace


BillingInformation Property

Aspose.Email

ExchangeTask.BillingInformation Property

Gets or sets a billing information for the task.

public string BillingInformation {get; set;}

See Also

ExchangeTask Class | Aspose.Email.Exchange Namespace


Companies Property

Aspose.Email

ExchangeTask.Companies Property

Gets or sets a collection of companies that are associated with a task.

public StringCollection Companies {get; set;}

See Also

ExchangeTask Class | Aspose.Email.Exchange Namespace


CompletionDate Property

Aspose.Email

ExchangeTask.CompletionDate Property

Gets or sets a date on which a task was completed.

public DateTime CompletionDate {get; set;}

See Also

ExchangeTask Class | Aspose.Email.Exchange Namespace


IsBodyHtml Property

Aspose.Email

ExchangeTask.IsBodyHtml Property

Gets or sets a value indicating whether the task body is html-formatted.

public bool IsBodyHtml {get; set;}

See Also

ExchangeTask Class | Aspose.Email.Exchange Namespace


Mileage Property

Aspose.Email

ExchangeTask.Mileage Property

Gets or sets a mileage for a task.

public string Mileage {get; set;}

See Also

ExchangeTask Class | Aspose.Email.Exchange Namespace


Recurrence Property

Aspose.Email

ExchangeTask.Recurrence Property

Gets or sets a recurrence information for a recurring task.

public RecurrencePattern Recurrence {get; set;}

See Also

ExchangeTask Class | Aspose.Email.Exchange Namespace


ReminderDate Property

Aspose.Email

ExchangeTask.ReminderDate Property

Gets or sets a task reminder date.

public DateTime ReminderDate {get; set;}

See Also

ExchangeTask Class | Aspose.Email.Exchange Namespace


Status Property

Aspose.Email

ExchangeTask.Status Property

Gets or sets a task status.

public ExchangeTaskStatus Status {get; set;}

See Also

ExchangeTask Class | Aspose.Email.Exchange Namespace


TotalWork Property

Aspose.Email

ExchangeTask.TotalWork Property

Gets or sets a total amount of work that is associated with the task (minutes).

public int TotalWork {get; set;}

See Also

ExchangeTask Class | Aspose.Email.Exchange Namespace


UniqueUri Property

Aspose.Email

ExchangeTask.UniqueUri Property

Gets or sets an unique uri of the task.

public string UniqueUri {get; set;}

See Also

ExchangeTask Class | Aspose.Email.Exchange Namespace


ExchangeTaskStatus Enumeration

Enumerates the task statuses.

public enum ExchangeTaskStatus

Members

Member Name | Description | Value
NotStarted | Specifies that the task is not started. | 0
Completed | Specifies that the task is completed. | 1
Deferred | Specifies that the task is deferred. | 2
InProgress | Specifies that the task is in progress. | 3
WaitingOnOthers | Specifies that the task is waiting on others. | 4

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange Namespace


ExchangeUploadItemResult Class

Represents a result of updating or creating a streamed item

For a list of all members of this type, see ExchangeUploadItemResult Members.

System.Object
Aspose.Email.Exchange.ExchangeUploadItemResult

public sealed class ExchangeUploadItemResult

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExchangeUploadItemResult Members | Aspose.Email.Exchange Namespace


ExchangeUploadItemResult Members

ExchangeUploadItemResult overview

Public Instance Properties

ErrorMessage | Gets the error message (if the uploading item failed)
IsSuccessful | Gets a value indicating whether the item is uploaded successfully
ItemId | Gets the item id

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ExchangeUploadItemResult Class | Aspose.Email.Exchange Namespace


ExchangeUploadItemResult Properties

The properties of the ExchangeUploadItemResult class are listed below. For a complete list of ExchangeUploadItemResult class members, see the ExchangeUploadItemResult Members topic.

Public Instance Properties

ErrorMessage | Gets the error message (if the uploading item failed)
IsSuccessful | Gets a value indicating whether the item is uploaded successfully
ItemId | Gets the item id

See Also

ExchangeUploadItemResult Class | Aspose.Email.Exchange Namespace


ErrorMessage Property

Aspose.Email

ExchangeUploadItemResult.ErrorMessage Property

Gets the error message (if the uploading item failed)

public string ErrorMessage {get; set;}

See Also

ExchangeUploadItemResult Class | Aspose.Email.Exchange Namespace


IsSuccessful Property

Aspose.Email

ExchangeUploadItemResult.IsSuccessful Property

Gets a value indicating whether the item is uploaded successfully

public bool IsSuccessful {get; set;}

See Also

ExchangeUploadItemResult Class | Aspose.Email.Exchange Namespace


ItemId Property

Aspose.Email

ExchangeUploadItemResult.ItemId Property

Gets the item id

public string ItemId {get; set;}

See Also

ExchangeUploadItemResult Class | Aspose.Email.Exchange Namespace


ExchangeUserAvailability Class

Represents user availability information

For a list of all members of this type, see ExchangeUserAvailability Members.

System.Object
Aspose.Email.Exchange.ExchangeUserAvailability

public sealed class ExchangeUserAvailability

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExchangeUserAvailability Members | Aspose.Email.Exchange Namespace


ExchangeUserAvailability Members

ExchangeUserAvailability overview

Public Instance Constructors

ExchangeUserAvailability Constructor Initializes a new instance of the ExchangeUserAvailability class.

Public Instance Properties

CalendarAppointments | Gets the calendar appointments in the user's calendar.
User | Gets the user smtp address.
WorkingHours | Gets the working hours.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetWorkingHours | Gets the working hours in the specified date taking into account the user's timezone.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ExchangeUserAvailability Class | Aspose.Email.Exchange Namespace


ExchangeUserAvailability Constructor

Initializes a new instance of the ExchangeUserAvailability class.

public ExchangeUserAvailability();

See Also

ExchangeUserAvailability Class | Aspose.Email.Exchange Namespace


ExchangeUserAvailability Properties

The properties of the ExchangeUserAvailability class are listed below. For a complete list of ExchangeUserAvailability class members, see the ExchangeUserAvailability Members topic.

Public Instance Properties

CalendarAppointments | Gets the calendar appointments in the user's calendar.
User | Gets the user smtp address.
WorkingHours | Gets the working hours.

See Also

ExchangeUserAvailability Class | Aspose.Email.Exchange Namespace


CalendarAppointments Property

Aspose.Email

ExchangeUserAvailability.CalendarAppointments Property

Gets the calendar appointments in the user's calendar.

public ExchangeCalendarEventCollection CalendarAppointments {get;}

See Also

ExchangeUserAvailability Class | Aspose.Email.Exchange Namespace


User Property

Aspose.Email

ExchangeUserAvailability.User Property

Gets the user smtp address.

public string User {get; set;}

See Also

ExchangeUserAvailability Class | Aspose.Email.Exchange Namespace


WorkingHours Property

Aspose.Email

ExchangeUserAvailability.WorkingHours Property

Gets the working hours.

public ExchangeUserWorkingHoursCollection WorkingHours {get;}

See Also

ExchangeUserAvailability Class | Aspose.Email.Exchange Namespace


ExchangeUserAvailability Methods

The methods of the ExchangeUserAvailability class are listed below. For a complete list of ExchangeUserAvailability class members, see the ExchangeUserAvailability Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetWorkingHours | Gets the working hours in the specified date taking into account the user's timezone.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ExchangeUserAvailability Class | Aspose.Email.Exchange Namespace


ExchangeUserAvailability.GetWorkingHours Method

Gets the working hours in the specified date taking into account the user's timezone.

public DateRange GetWorkingHours(
DateTime date
);

Parameters

date
The date to get information for.

Return Value

A start and end time of the working day for the specified date.

See Also

ExchangeUserAvailability Class | Aspose.Email.Exchange Namespace


ExchangeUserAvailabilityCollection Class

Represents the collection of ExchangeUserAvailability

For a list of all members of this type, see ExchangeUserAvailabilityCollection Members.

System.Object
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Exchange.ExchangeUserAvailability, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]]
Aspose.Email.Exchange.ExchangeUserAvailabilityCollection

public sealed class ExchangeUserAvailabilityCollection : Collection`1

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExchangeUserAvailabilityCollection Members | Aspose.Email.Exchange Namespace


ExchangeUserAvailabilityCollection Members

ExchangeUserAvailabilityCollection overview

Public Instance Constructors

ExchangeUserAvailabilityCollection Constructor Initializes a new instance of the ExchangeUserAvailabilityCollection class.

Public Instance Properties

Count (inherited from 0, Culture=neutral, PublicKeyToken=null]])
Item (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ExchangeUserAvailabilityCollection Class | Aspose.Email.Exchange Namespace


ExchangeUserAvailabilityCollection Constructor

Initializes a new instance of the ExchangeUserAvailabilityCollection class.

public ExchangeUserAvailabilityCollection();

See Also

ExchangeUserAvailabilityCollection Class | Aspose.Email.Exchange Namespace


ExchangeUserBusyness Enumeration

Enumerates the user free/busy statuses

public enum ExchangeUserBusyness

Members

Member Name | Description | Value
Busy | Specifies the status as busy. | 0
Free | Specifies the status as free. | 1
NoData | Specifies that there is no data for that recipient. | 2
OOF | Specifies the status as Out of Office (OOF). | 3
Tentative | Specifies the status as tentative. | 4
WorkingElsewhere | Specifies the status as working elsewhere. | 5

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange Namespace


ExchangeUserWorkingHours Class

Represents the user working hours.

For a list of all members of this type, see ExchangeUserWorkingHours Members.

System.Object
Aspose.Email.Exchange.ExchangeUserWorkingHours

public sealed class ExchangeUserWorkingHours

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExchangeUserWorkingHours Members | Aspose.Email.Exchange Namespace


ExchangeUserWorkingHours Members

ExchangeUserWorkingHours overview

Public Instance Constructors

ExchangeUserWorkingHours Constructor Initializes a new instance of the ExchangeUserWorkingHours class.

Public Instance Properties

DayOfWeek | Gets the day of week.
EndTime | Gets the end time of the working day.
StartTime | Gets the start time of the working day.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ExchangeUserWorkingHours Class | Aspose.Email.Exchange Namespace


ExchangeUserWorkingHours Constructor

Initializes a new instance of the ExchangeUserWorkingHours class.

public ExchangeUserWorkingHours();

See Also

ExchangeUserWorkingHours Class | Aspose.Email.Exchange Namespace


ExchangeUserWorkingHours Properties

The properties of the ExchangeUserWorkingHours class are listed below. For a complete list of ExchangeUserWorkingHours class members, see the ExchangeUserWorkingHours Members topic.

Public Instance Properties

DayOfWeek | Gets the day of week.
EndTime | Gets the end time of the working day.
StartTime | Gets the start time of the working day.

See Also

ExchangeUserWorkingHours Class | Aspose.Email.Exchange Namespace


DayOfWeek Property

Aspose.Email

ExchangeUserWorkingHours.DayOfWeek Property

Gets the day of week.

public DayOfWeek DayOfWeek {get;}

See Also

ExchangeUserWorkingHours Class | Aspose.Email.Exchange Namespace


EndTime Property

Aspose.Email

ExchangeUserWorkingHours.EndTime Property

Gets the end time of the working day.

public TimeSpan EndTime {get;}

See Also

ExchangeUserWorkingHours Class | Aspose.Email.Exchange Namespace


StartTime Property

Aspose.Email

ExchangeUserWorkingHours.StartTime Property

Gets the start time of the working day.

public TimeSpan StartTime {get;}

See Also

ExchangeUserWorkingHours Class | Aspose.Email.Exchange Namespace


ExchangeUserWorkingHoursCollection Class

Represents the collection of ExchangeUserWorkingHours

For a list of all members of this type, see ExchangeUserWorkingHoursCollection Members.

System.Object
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Exchange.ExchangeUserWorkingHours, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]]
Aspose.Email.Exchange.ExchangeUserWorkingHoursCollection

public sealed class ExchangeUserWorkingHoursCollection : Collection`1

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExchangeUserWorkingHoursCollection Members | Aspose.Email.Exchange Namespace


ExchangeUserWorkingHoursCollection Members

ExchangeUserWorkingHoursCollection overview

Public Instance Constructors

ExchangeUserWorkingHoursCollection Constructor Initializes a new instance of the ExchangeUserWorkingHoursCollection class.

Public Instance Properties

Count (inherited from 0, Culture=neutral, PublicKeyToken=null]])
Item (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ExchangeUserWorkingHoursCollection Class | Aspose.Email.Exchange Namespace


ExchangeUserWorkingHoursCollection Constructor

Initializes a new instance of the ExchangeUserWorkingHoursCollection class.

public ExchangeUserWorkingHoursCollection();

See Also

ExchangeUserWorkingHoursCollection Class | Aspose.Email.Exchange Namespace


ExchangeVersion Enumeration

Exchange server versions

public enum ExchangeVersion

Members

Member Name | Description | Value
Exchange2007 | MS Exchange server 2007 | 0
Exchange2007_SP1 | MS Exchange server 2007 SP1 | 1
Exchange2010 | MS Exchange server 2010 | 2
Exchange2010_SP1 | MS Exchange server 2010 SP1 | 3
Exchange2010_SP2 | MS Exchange server 2010 SP2 | 4
Exchange2013 | MS Exchange server 2013 | 5

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange Namespace


ExchangeWebServiceClient Class

NOTE: This class is now obsolete.

ExchangeWebServiceClient and related classes are obsolete and will be removed soon. Please uses new EWSClient.

Provides access to MS Exchange Server by using Exchange Web Services (EWS).

For a list of all members of this type, see ExchangeWebServiceClient Members.

System.Object
Aspose.Email.Exchange.ExchangeClientBase
Aspose.Email.Exchange.ExchangeWebServiceClient

public class ExchangeWebServiceClient : ExchangeClientBase, IEWSClient

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExchangeWebServiceClient Members | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient Members

ExchangeWebServiceClient overview

Public Instance Constructors

ExchangeWebServiceClient Overloaded. Initializes a new instance of the ExchangeWebServiceClient class.

Public Instance Properties

Credentials | Gets or sets the credentials
MailboxInfo | Gets the mailbox information
MailboxUri | Gets or sets the mailbox uri
Proxy | Gets or sets the proxy.
Timeout | Gets or sets the number of milliseconds to wait before the operation times out. The default value is 100,000 milliseconds (100 seconds).

Public Instance Methods

AppendMessage | Overloaded. Uploads the mail message to the specified folder
Backup | Overloaded. Backups the content of the specified folders
CheckUserAvailability | Overloaded. Checks user availability within the specified time window.
CloseAccess | Overloaded. Closes access on the specified mailbox for the specified user.
CopyConversationItems | Overloaded. Copies the conversation items into the specified target folder
CopyItem | Copies the item to specified folder
CreateContact | Creates a contact item in the Exchange store.
CreateFolder | Overloaded. This functionality is not supported for obsolete classes. Creates the new folder
CreateInboxRule | Overloaded. Creates the specified inbox rule
CreateItems | Creates the specified items in the speciifed folder
CreatePublicFolder | Overloaded. Creates the specified public folder in the root public folder
CreateTask | Creates the given task in the specified folder.
CreateUserConfiguration | Creates the specified user configuration
DelegateAccess | Overloaded. Delegates access on the principal mailbox to the specified user.
DeleteContact | Overloaded. Deletes the contact.
DeleteContacts | Overloaded. Deletes the contacts.
DeleteConversationItems | Overloaded. Deletes all items of the specified conversation
DeleteFolder | Overloaded. Deletes the folder
DeleteFolders | Overloaded. Deletes the specified folders
DeleteInboxRule | Overloaded. Deletes the specified inbox rule
DeleteMessage | Overloaded. Deletes the mail message
DeleteMessages | Overloaded. Deletes the specified mail messages
DeleteTask | Overloaded. Deletes the specified task.
DeleteUserConfiguration | Deletes the specified user configuration
DisconnectPhoneCall | Disconnects a phone call specified by id.
Dispose (inherited from ExchangeClientBase) | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
EmptyFolder | Overloaded. Empties the specified folder. Subfolders will not be deleted; deleted items will be moved into DeletedItems folder
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExportItems | Exports the specified items from mailbox
FetchAppointment | Fetch the specified appointment from server.
FetchAttachment | Fetches the attachment
FetchMapiAttachments |
FetchMessage | Overloaded. Fetches the message from server
FetchMessages | Overloaded. Fetches the speciifed messages
FetchTask | Fetches the specified task.
FindConversations | Finds conversations in the specified folder
FindMessages | Gets the collection of messages from specified folder
FindMessageTrackingReport | Finds messages that meet the specified criteria.
FolderExists | Overloaded.
FolderExists (inherited from ExchangeClientBase) | Overloaded. Checks whether the specified folder exists.
Forward |
GetCallInfo | Retrieves phone call information by call id This functionality is not supported for obsolete classes.
GetExchangeType | Gets the information about the current version of MS Exchange.
GetFolderInfo | Gets the folder information
GetFolderPermissions | Gets the folder permissions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInboxRules | Overloaded. Gets inbox rules
GetMailboxInfo | Overloaded. Gets the mailbox information
GetMailboxSize | Overloaded. Gets the size of the mailbox
GetMailTips | Gets mail tips
GetMessageTrackingReport | Gets message tracking report
GetServerTimeZoneIds | Overloaded. The GetServerTimeZoneIds returns information from time zone id that are available on an Exchange server. This functionality is not supported for obsolete classes.
GetType (inherited from Object) | Gets the Type of the current instance.
GetUMConfiguration | Retrieves unified messaging configuration This functionality is not supported for obsolete classes.
GetUserConfiguration | Gets the specified user configuration
GetVersionInfo | Returns exchange server version info
ImpersonateUser | Overloaded. Impersonates the user.
ListContacts | Overloaded. Lists contacts located in the specified folder on server
ListDelegates | Lists the users who are granted access on the specified mailbox.
ListMailboxes | Lists mailboxes having smtp addresses. Note: the maximum count of returned contacts is 100. This is a restriction of used EWS operation.
ListMessages | Overloaded. List the messages in the specified folder
ListMessages (inherited from ExchangeClientBase) | Overloaded. Lists the messages.
ListMessagesFromPublicFolder | Overloaded. Get collection of messages from public folder
ListPublicFolders | Gets collection of public folders from root public folder
ListSubFolders | Overloaded. Gets collection of child folders from parent
ListSubFolders (inherited from ExchangeClientBase) | Overloaded. Gets collection of child folders from parent
LoadContactPhoto |
MailDisablePublicFolder | Mail-disable a public folder
MailEnablePublicFolder | Mail-enable a public folder
MarkAllItems | Overloaded. Marks all items in specified folders. This functionality is not supported for obsolete classes.
MarkAllItemsAsRead | Overloaded. Marks all items in inbox folder as read without receipts. This functionality is not supported for obsolete classes.
MarkAllItemsAsUnread | Overloaded. Marks all items in inbox folder as unread.
MarkAsJunk | Overloaded. The MarkAsJunk method moves mail messages to the junk mail folder and blocks message sender. This functionality is not supported for obsolete classes.
MoveConversationItems | Overloaded. Moves the conversation items into the specified target folder
MoveItem | Moves the item to specified folder
PlayOnPhone | The PlayOnPhone operation initiates an outbound call and plays a message over the telephone. This functionality is not supported for obsolete classes.
Reply |
ReplyAll |
ResetImpersonation | Makes the impersonation reset.
ResolveContact | Resolves ambiguous e-mail addresses and display names Note: the maximum count of returned contacts is 100. This is a restriction of used EWS operation.
Restore | Overloaded. Restores exchange folders from the specified personal storage file.
SaveMessage | Overloaded. Downloads the message with the specified uri and writes its data into a supplied stream
Send | Overloaded. Sends the specified message
SetConversationReadState | Overloaded. Set read state of the conversation items to the specified value
SetReadFlag | Overloaded. Marks the specifeid message as read.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateDelegate | Updates the delegate user settings who is granted access on the specified mailbox.
UpdateDelegates | Updates the delegate users settings who are granted access on the specified mailbox.
UpdateInboxRule | Overloaded. Updates the specified inbox rule
UpdateItems | Updates the specified items in to a mailbox
UpdateTask | Overloaded. Updates the specified task.
UpdateUserConfiguration | Updates the specified user configuration

Protected Instance Methods

Dispose | Overloaded. Releases unmanaged and - optionally - managed resources
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient Constructor

Initializes a new instance of the ExchangeWebServiceClient class

Overload List

Initializes a new instance of the ExchangeWebServiceClient class

public ExchangeWebServiceClient();

Initializes a new instance of the ExchangeWebServiceClient class

public ExchangeWebServiceClient(ExchangeServiceBinding);

Initializes a new instance of the ExchangeWebServiceClient class

public ExchangeWebServiceClient(string,ICredentials);

Initializes a new instance of the ExchangeWebServiceClient class

public ExchangeWebServiceClient(string,ICredentials,WebProxy);

Initializes a new instance of the ExchangeWebServiceClient class

public ExchangeWebServiceClient(string,string,string);

Initializes a new instance of the ExchangeWebServiceClient class

public ExchangeWebServiceClient(string,string,string,WebProxy);

Initializes a new instance of the ExchangeWebServiceClient class

public ExchangeWebServiceClient(string,string,string,string);

Initializes a new instance of the ExchangeWebServiceClient class

public ExchangeWebServiceClient(string,string,string,string,WebProxy);

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient Constructor ()

Initializes a new instance of the ExchangeWebServiceClient class

public ExchangeWebServiceClient();

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient Constructor Overload List


ExchangeWebServiceClient Constructor (ExchangeServiceBinding)

Initializes a new instance of the ExchangeWebServiceClient class

public ExchangeWebServiceClient(
ExchangeServiceBinding binding
);

Parameters

binding
ExchangeServiceBinding

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient Constructor Overload List


ExchangeWebServiceClient Constructor (String, String, String)

Initializes a new instance of the ExchangeWebServiceClient class

public ExchangeWebServiceClient(
string mailboxUri,
string username,
string password
);

Parameters

mailboxUri
The URI of mailbox
username
The username
password
The password

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient Constructor Overload List


ExchangeWebServiceClient Constructor (String, String, String, WebProxy)

Initializes a new instance of the ExchangeWebServiceClient class

public ExchangeWebServiceClient(
string mailboxUri,
string username,
string password,
WebProxy proxy
);

Parameters

mailboxUri
The URI of mailbox
username
The username
password
The password
proxy
Contains HTTP proxy settings

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient Constructor Overload List


ExchangeWebServiceClient Constructor (String, String, String, String)

Initializes a new instance of the ExchangeWebServiceClient class

public ExchangeWebServiceClient(
string mailboxUri,
string username,
string password,
string domain
);

Parameters

mailboxUri
The URI of mailbox
username
The username
password
The password
domain
The domain name

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient Constructor Overload List


ExchangeWebServiceClient Constructor (String, String, String, String, WebProxy)

Initializes a new instance of the ExchangeWebServiceClient class

public ExchangeWebServiceClient(
string mailboxUri,
string username,
string password,
string domain,
WebProxy proxy
);

Parameters

mailboxUri
The URI of mailbox
username
The username
password
The password
domain
The domain name
proxy
Contains HTTP proxy settings

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient Constructor Overload List


ExchangeWebServiceClient Constructor (String, ICredentials)

Initializes a new instance of the ExchangeWebServiceClient class

public ExchangeWebServiceClient(
string mailboxUri,
ICredentials credentials
);

Parameters

mailboxUri
The URI of mailbox
credentials
System.Net.ICredentials

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient Constructor Overload List


ExchangeWebServiceClient Constructor (String, ICredentials, WebProxy)

Initializes a new instance of the ExchangeWebServiceClient class

public ExchangeWebServiceClient(
string mailboxUri,
ICredentials credentials,
WebProxy proxy
);

Parameters

mailboxUri
The URI of mailbox
credentials
System.Net.ICredentials
proxy
Contains HTTP proxy settings

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient Constructor Overload List


ExchangeWebServiceClient Properties

The properties of the ExchangeWebServiceClient class are listed below. For a complete list of ExchangeWebServiceClient class members, see the ExchangeWebServiceClient Members topic.

Public Instance Properties

Credentials | Gets or sets the credentials
MailboxInfo | Gets the mailbox information
MailboxUri | Gets or sets the mailbox uri
Proxy | Gets or sets the proxy.
Timeout | Gets or sets the number of milliseconds to wait before the operation times out. The default value is 100,000 milliseconds (100 seconds).

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


Credentials Property

Aspose.Email

ExchangeWebServiceClient.Credentials Property

Gets or sets the credentials

public override ICredentials Credentials {get; set;}

Property Value

ICredentials

Implements

IExchangeClientBase.Credentials

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


MailboxInfo Property

Aspose.Email

ExchangeWebServiceClient.MailboxInfo Property

Gets the mailbox information

public override ExchangeMailboxInfo MailboxInfo {get;}

Implements

IExchangeClientBase.MailboxInfo

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


MailboxUri Property

Aspose.Email

ExchangeWebServiceClient.MailboxUri Property

Gets or sets the mailbox uri

public override string MailboxUri {get; set;}

Property Value

Uri of the mailbox

Implements

IExchangeClientBase.MailboxUri

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


Proxy Property

Aspose.Email

ExchangeWebServiceClient.Proxy Property

Gets or sets the proxy.

public override WebProxy Proxy {get; set;}

Implements

IExchangeClientBase.Proxy

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


Timeout Property

Aspose.Email

ExchangeWebServiceClient.Timeout Property

Gets or sets the number of milliseconds to wait before the operation times out. The default value is 100,000 milliseconds (100 seconds).

public override int Timeout {get; set;}

Property Value

Timeout in milliseconds

Implements

IExchangeClientBase.Timeout

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient Methods

The methods of the ExchangeWebServiceClient class are listed below. For a complete list of ExchangeWebServiceClient class members, see the ExchangeWebServiceClient Members topic.

Public Instance Methods

AppendMessage | Overloaded. Uploads the mail message to the specified folder
Backup | Overloaded. Backups the content of the specified folders
CheckUserAvailability | Overloaded. Checks user availability within the specified time window.
CloseAccess | Overloaded. Closes access on the specified mailbox for the specified user.
CopyConversationItems | Overloaded. Copies the conversation items into the specified target folder
CopyItem | Copies the item to specified folder
CreateContact | Creates a contact item in the Exchange store.
CreateFolder | Overloaded. This functionality is not supported for obsolete classes. Creates the new folder
CreateInboxRule | Overloaded. Creates the specified inbox rule
CreateItems | Creates the specified items in the speciifed folder
CreatePublicFolder | Overloaded. Creates the specified public folder in the root public folder
CreateTask | Creates the given task in the specified folder.
CreateUserConfiguration | Creates the specified user configuration
DelegateAccess | Overloaded. Delegates access on the principal mailbox to the specified user.
DeleteContact | Overloaded. Deletes the contact.
DeleteContacts | Overloaded. Deletes the contacts.
DeleteConversationItems | Overloaded. Deletes all items of the specified conversation
DeleteFolder | Overloaded. Deletes the folder
DeleteFolders | Overloaded. Deletes the specified folders
DeleteInboxRule | Overloaded. Deletes the specified inbox rule
DeleteMessage | Overloaded. Deletes the mail message
DeleteMessages | Overloaded. Deletes the specified mail messages
DeleteTask | Overloaded. Deletes the specified task.
DeleteUserConfiguration | Deletes the specified user configuration
DisconnectPhoneCall | Disconnects a phone call specified by id.
Dispose (inherited from ExchangeClientBase) | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
EmptyFolder | Overloaded. Empties the specified folder. Subfolders will not be deleted; deleted items will be moved into DeletedItems folder
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExportItems | Exports the specified items from mailbox
FetchAppointment | Fetch the specified appointment from server.
FetchAttachment | Fetches the attachment
FetchMapiAttachments |
FetchMessage | Overloaded. Fetches the message from server
FetchMessages | Overloaded. Fetches the speciifed messages
FetchTask | Fetches the specified task.
FindConversations | Finds conversations in the specified folder
FindMessages | Gets the collection of messages from specified folder
FindMessageTrackingReport | Finds messages that meet the specified criteria.
FolderExists | Overloaded.
FolderExists (inherited from ExchangeClientBase) | Overloaded. Checks whether the specified folder exists.
Forward |
GetCallInfo | Retrieves phone call information by call id This functionality is not supported for obsolete classes.
GetExchangeType | Gets the information about the current version of MS Exchange.
GetFolderInfo | Gets the folder information
GetFolderPermissions | Gets the folder permissions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInboxRules | Overloaded. Gets inbox rules
GetMailboxInfo | Overloaded. Gets the mailbox information
GetMailboxSize | Overloaded. Gets the size of the mailbox
GetMailTips | Gets mail tips
GetMessageTrackingReport | Gets message tracking report
GetServerTimeZoneIds | Overloaded. The GetServerTimeZoneIds returns information from time zone id that are available on an Exchange server. This functionality is not supported for obsolete classes.
GetType (inherited from Object) | Gets the Type of the current instance.
GetUMConfiguration | Retrieves unified messaging configuration This functionality is not supported for obsolete classes.
GetUserConfiguration | Gets the specified user configuration
GetVersionInfo | Returns exchange server version info
ImpersonateUser | Overloaded. Impersonates the user.
ListContacts | Overloaded. Lists contacts located in the specified folder on server
ListDelegates | Lists the users who are granted access on the specified mailbox.
ListMailboxes | Lists mailboxes having smtp addresses. Note: the maximum count of returned contacts is 100. This is a restriction of used EWS operation.
ListMessages | Overloaded. List the messages in the specified folder
ListMessages (inherited from ExchangeClientBase) | Overloaded. Lists the messages.
ListMessagesFromPublicFolder | Overloaded. Get collection of messages from public folder
ListPublicFolders | Gets collection of public folders from root public folder
ListSubFolders | Overloaded. Gets collection of child folders from parent
ListSubFolders (inherited from ExchangeClientBase) | Overloaded. Gets collection of child folders from parent
LoadContactPhoto |
MailDisablePublicFolder | Mail-disable a public folder
MailEnablePublicFolder | Mail-enable a public folder
MarkAllItems | Overloaded. Marks all items in specified folders. This functionality is not supported for obsolete classes.
MarkAllItemsAsRead | Overloaded. Marks all items in inbox folder as read without receipts. This functionality is not supported for obsolete classes.
MarkAllItemsAsUnread | Overloaded. Marks all items in inbox folder as unread.
MarkAsJunk | Overloaded. The MarkAsJunk method moves mail messages to the junk mail folder and blocks message sender. This functionality is not supported for obsolete classes.
MoveConversationItems | Overloaded. Moves the conversation items into the specified target folder
MoveItem | Moves the item to specified folder
PlayOnPhone | The PlayOnPhone operation initiates an outbound call and plays a message over the telephone. This functionality is not supported for obsolete classes.
Reply |
ReplyAll |
ResetImpersonation | Makes the impersonation reset.
ResolveContact | Resolves ambiguous e-mail addresses and display names Note: the maximum count of returned contacts is 100. This is a restriction of used EWS operation.
Restore | Overloaded. Restores exchange folders from the specified personal storage file.
SaveMessage | Overloaded. Downloads the message with the specified uri and writes its data into a supplied stream
Send | Overloaded. Sends the specified message
SetConversationReadState | Overloaded. Set read state of the conversation items to the specified value
SetReadFlag | Overloaded. Marks the specifeid message as read.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateDelegate | Updates the delegate user settings who is granted access on the specified mailbox.
UpdateDelegates | Updates the delegate users settings who are granted access on the specified mailbox.
UpdateInboxRule | Overloaded. Updates the specified inbox rule
UpdateItems | Updates the specified items in to a mailbox
UpdateTask | Overloaded. Updates the specified task.
UpdateUserConfiguration | Updates the specified user configuration

Protected Instance Methods

Dispose | Overloaded. Releases unmanaged and - optionally - managed resources
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


AppendMessage Method

Aspose.Email

ExchangeWebServiceClient.AppendMessage Method

Uploads the mail message to the specified folder

Overload List

Uploads the mail message to the specified folder

public override string AppendMessage(string,MailMessage);

Uploads the mail message to the specified folder

public override string AppendMessage(string,MailMessage,bool);

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.AppendMessage Method (String, MailMessage)

Uploads the mail message to the specified folder

public override string AppendMessage(
string folder,
MailMessage message
);

Parameters

folder
A folder to which message is uploaded
message
A message to upload

Return Value

An uri of created message

Implements

IExchangeClientBase.AppendMessage

Exceptions

Exception Type | Condition
ArgumentException | A folder is not specified
ArgumentNullException | message is null

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.AppendMessage Overload List


ExchangeWebServiceClient.AppendMessage Method (String, MailMessage, Boolean)

Uploads the mail message to the specified folder

public override string AppendMessage(
string folder,
MailMessage message,
bool markAsSent
);

Parameters

folder
A folder to which message is uploaded
message
A message to upload
markAsSent
A value indicating whether the message should be appended as a sent message or a draft.

Return Value

An uri of created message

Implements

IExchangeClientBase.AppendMessage

Exceptions

Exception Type | Condition
ArgumentException | A folder is not specified
ArgumentNullException | message is null

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.AppendMessage Overload List


Backup Method

Aspose.Email

ExchangeWebServiceClient.Backup Method

Backups the content of the specified folders

Overload List

Backups the content of the specified folders

public override void Backup(ExchangeFolderInfoCollection,Stream,BackupOptions);

Backups the content of the specified folders

public override void Backup(ExchangeFolderInfoCollection,string,BackupOptions);

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.Backup Method (ExchangeFolderInfoCollection, Stream, BackupOptions)

Backups the content of the specified folders

public override void Backup(
ExchangeFolderInfoCollection folders,
Stream stream,
BackupOptions options
);

Parameters

folders
A folders to backup
stream
A stream to write into
options
A backup options

Implements

IExchangeClientBase.Backup

Exceptions

Exception Type | Condition
NotSupportedException | The given stream does not support writting
ArgumentNullException | folders or stream is null

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.Backup Overload List


ExchangeWebServiceClient.Backup Method (ExchangeFolderInfoCollection, String, BackupOptions)

Backups the content of the specified folders

public override void Backup(
ExchangeFolderInfoCollection folders,
string fileName,
BackupOptions options
);

Parameters

folders
A folders to backup
fileName
A path to the presonal storage file
options
A backup options

Implements

IExchangeClientBase.Backup

Exceptions

Exception Type | Condition
ArgumentException | A fileName is null or empty
ArgumentNullException | folders is null

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.Backup Overload List


CheckUserAvailability Method

Aspose.Email

ExchangeWebServiceClient.CheckUserAvailability Method

Checks users availability within the specified time window.

Overload List

Checks users availability within the specified time window.

public virtual ExchangeUserAvailabilityCollection CheckUserAvailability(StringCollection,DateRange);

Checks user availability within the specified time window.

public virtual ExchangeUserAvailability CheckUserAvailability(string,DateRange);

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.CheckUserAvailability Method (StringCollection, DateRange)

Checks users availability within the specified time window.

public virtual ExchangeUserAvailabilityCollection CheckUserAvailability(
StringCollection users,
DateRange timeWindow
);

Parameters

users
An users smtp addresses.
timeWindow
A time span for the queried user's availability.

Return Value

ExchangeUserAvailabilityCollection containing the users availability informaiton.

Implements

IEWSClient.CheckUserAvailability

Exceptions

Exception Type | Condition
ArgumentNullException | timeWindow or users is null.

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.CheckUserAvailability Overload List


ExchangeWebServiceClient.CheckUserAvailability Method (String, DateRange)

Checks user availability within the specified time window.

public virtual ExchangeUserAvailability CheckUserAvailability(
string user,
DateRange timeWindow
);

Parameters

user
An user smtp address.
timeWindow
A time span for the queried user's availability.

Return Value

ExchangeUserAvailability containing user availability information.

Implements

IEWSClient.CheckUserAvailability

Exceptions

Exception Type | Condition
ArgumentException | user is null or empty.
ArgumentNullException | timeWindow is null.

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.CheckUserAvailability Overload List


CloseAccess Method

Aspose.Email

ExchangeWebServiceClient.CloseAccess Method

Closes access on the specified mailbox for the specified user.

Overload List

Closes access on the specified mailbox for the specified user.

public virtual void CloseAccess(ExchangeDelegateUser,string);

Closes access on the specified mailbox for the specified user.

public virtual void CloseAccess(ExchangeDelegateUserCollection,string);

Closes access on the specified mailbox for the specified user.

public virtual void CloseAccess(ExchangeFolderUserInfo,string);

Closes access on the specified mailbox for the specified user.

public virtual void CloseAccess(string,string);

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.CloseAccess Method (ExchangeDelegateUser, String)

Closes access on the specified mailbox for the specified user.

public virtual void CloseAccess(
ExchangeDelegateUser delegateUser,
string mailbox
);

Parameters

delegateUser
A delegate user.
mailbox
A mailbox.

Implements

IEWSClient.CloseAccess

Exceptions

Exception Type | Condition
ArgumentNullException | delegateUser is null.
ArgumentException | mailbox is null or empty.

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.CloseAccess Overload List


ExchangeWebServiceClient.CloseAccess Method (ExchangeDelegateUserCollection, String)

Closes access on the specified mailbox for the specified user.

public virtual void CloseAccess(
ExchangeDelegateUserCollection delegateUsers,
string mailbox
);

Parameters

delegateUsers
A delegate users.
mailbox
A mailbox.

Implements

IEWSClient.CloseAccess

Exceptions

Exception Type | Condition
ArgumentNullException | delegateUsers is null.
ArgumentException | mailbox is null or empty.

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.CloseAccess Overload List


ExchangeWebServiceClient.CloseAccess Method (ExchangeFolderUserInfo, String)

Closes access on the specified mailbox for the specified user.

public virtual void CloseAccess(
ExchangeFolderUserInfo userInfo,
string mailbox
);

Parameters

userInfo
A user information.
mailbox
A mailbox.

Implements

IEWSClient.CloseAccess

Exceptions

Exception Type | Condition
ArgumentNullException | userInfo is null.
ArgumentException | mailbox is null or empty.

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.CloseAccess Overload List


ExchangeWebServiceClient.CloseAccess Method (String, String)

Closes access on the specified mailbox for the specified user.

public virtual void CloseAccess(
string delegateSmtpAddress,
string mailbox
);

Parameters

delegateSmtpAddress
A primary smtp address of delegate user.
mailbox
A mailbox.

Implements

IEWSClient.CloseAccess

Exceptions

Exception Type | Condition
ArgumentException | delegateSmtpAddress or mailbox is null or empty.

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.CloseAccess Overload List


CopyConversationItems Method

Aspose.Email

ExchangeWebServiceClient.CopyConversationItems Method

Copies the conversation items into the specified target folder

Overload List

Copies the conversation items into the specified target folder

public virtual void CopyConversationItems(string,string);

Copies the conversation items, which are located in the specified folder, into the specified target folder

public virtual void CopyConversationItems(string,string,string);

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.CopyConversationItems Method (String, String)

Copies the conversation items into the specified target folder

public virtual void CopyConversationItems(
string conversationId,
string destinationFolderId
);

Parameters

conversationId
Id of conversation to copy
destinationFolderId
Id of folder into which copy items

Implements

IEWSClient.CopyConversationItems

Exceptions

Exception Type | Condition
ArgumentException | conversationId is null or empty
ArgumentException | destinationFolderId is null or empty

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.CopyConversationItems Overload List


ExchangeWebServiceClient.CopyConversationItems Method (String, String, String)

Copies the conversation items, which are located in the specified folder, into the specified target folder

public virtual void CopyConversationItems(
string conversationId,
string contextFolderId,
string destinationFolderId
);

Parameters

conversationId
Id of conversation to copy
contextFolderId
Id of folder in which conversation items are located. Note: If it's set to null(or empty), all conversation items will be copied
destinationFolderId
Id of folder into which copy items

Implements

IEWSClient.CopyConversationItems

Exceptions

Exception Type | Condition
ArgumentException | conversationId is null or empty
ArgumentException | destinationFolderId is null or empty

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.CopyConversationItems Overload List


ExchangeWebServiceClient.CopyItem Method

Copies the item to specified folder

public virtual void CopyItem(
string itemUri,
string destinationFolderUri
);

Parameters

itemUri
The item URI
destinationFolderUri
The destination folder URI

Implements

IEWSClient.CopyItem

Exceptions

Exception Type | Condition
ArgumentException | itemUri is null or empty
ArgumentException | destinationFolderUri is null or empty

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.CreateContact Method

Creates a contact item in the Exchange store.

public override string CreateContact(
MapiContact contact
);

Parameters

contact

Return Value

The contact Uri

Implements

IExchangeClientBase.CreateContact

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


CreateFolder Method

Aspose.Email

ExchangeWebServiceClient.CreateFolder Method

Creates new folder in the root folder. This functionality is not supported for obsolete classes.

Overload List

Creates new folder in the root folder. This functionality is not supported for obsolete classes.

public virtual void CreateFolder(string);

Creates the new folder

public override void CreateFolder(string,string);

This functionality is not supported for obsolete classes. Creates the new folder

public virtual void CreateFolder(string,string,ExchangeFolderPermissionCollection);

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.CreateFolder Method (String)

Creates new folder in the root folder. This functionality is not supported for obsolete classes.

public virtual void CreateFolder(
string name
);

Parameters

name
The name of new folder

Implements

IEWSClient.CreateFolder

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.CreateFolder Overload List


ExchangeWebServiceClient.CreateFolder Method (String, String)

Creates the new folder

public override void CreateFolder(
string parentFolderUri,
string name
);

Parameters

parentFolderUri
The URI of parent folder
name
The name of new folder

Implements

IExchangeClientBase.CreateFolder

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.CreateFolder Overload List


ExchangeWebServiceClient.CreateFolder Method (String, String, ExchangeFolderPermissionCollection)

This functionality is not supported for obsolete classes. Creates the new folder

public virtual void CreateFolder(
string parentFolderUri,
string name,
ExchangeFolderPermissionCollection permissions
);

Parameters

parentFolderUri
The URI of parent folder
name
The name of new folder
permissions
A permission on new folder

Implements

IEWSClient.CreateFolder

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.CreateFolder Overload List


CreateInboxRule Method

Aspose.Email

ExchangeWebServiceClient.CreateInboxRule Method

Creates the specified inbox rule

Overload List

Creates the specified inbox rule

public virtual void CreateInboxRule(InboxRule);

Creates the specified inbox rule

public virtual void CreateInboxRule(InboxRule,string);

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.CreateInboxRule Method (InboxRule)

Creates the specified inbox rule

public virtual void CreateInboxRule(
InboxRule rule
);

Parameters

rule
A inbox rule to create

Implements

IEWSClient.CreateInboxRule

Exceptions

Exception Type | Condition
ArgumentNullException | throws when rule is null

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.CreateInboxRule Overload List


ExchangeWebServiceClient.CreateInboxRule Method (InboxRule, String)

Creates the specified inbox rule

public virtual void CreateInboxRule(
InboxRule rule,
string mailbox
);

Parameters

rule
A inbox rule to create
mailbox
A mailbox to create rule for. Note: if it is set to null or empty, the rule will be created in the default mailbox

Implements

IEWSClient.CreateInboxRule

Exceptions

Exception Type | Condition
ArgumentNullException | throws when rule is null

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.CreateInboxRule Overload List


ExchangeWebServiceClient.CreateItems Method

Creates the specified items in the speciifed folder

public virtual ExchangeUploadItemResult[] CreateItems(
ExchangeStreamedItem[] items,
string parentFolderUri
);

Parameters

items
An items to be uploaded
parentFolderUri
Specifies the folder in which to place the items

Return Value

An array of ExchangeUploadItemResult

Implements

IEWSClient.CreateItems

Exceptions

Exception Type | Condition
ArgumentNullException | items is null
ArgumentException | items is empty
ArgumentException | parentFolderUri is null or empty

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


CreatePublicFolder Method

Aspose.Email

ExchangeWebServiceClient.CreatePublicFolder Method

Creates the specified public folder in the root public folder

Overload List

Creates the specified public folder in the root public folder

public virtual void CreatePublicFolder(string,ExchangeFolderPermissionCollection);

Creates the specified public folder in the root public folder

public virtual void CreatePublicFolder(string,string,ExchangeFolderPermissionCollection);

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.CreatePublicFolder Method (String, ExchangeFolderPermissionCollection)

Creates the specified public folder in the root public folder

public virtual void CreatePublicFolder(
string name,
ExchangeFolderPermissionCollection permissions
);

Parameters

name
A name of new folder
permissions
A permission on new folder

Implements

IEWSClient.CreatePublicFolder

Exceptions

Exception Type | Condition
ArgumentException | A name is empty
ArgumentNullException | A name or permissions is null

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.CreatePublicFolder Overload List


ExchangeWebServiceClient.CreatePublicFolder Method (String, String, ExchangeFolderPermissionCollection)

Creates the specified public folder in the root public folder

public virtual void CreatePublicFolder(
string parentFolderUri,
string name,
ExchangeFolderPermissionCollection permissions
);

Parameters

parentFolderUri
The URI of parent folder
name
A name of new folder
permissions
A permission on new folder

Implements

IEWSClient.CreatePublicFolder

Exceptions

Exception Type | Condition
ArgumentException | A name or parentFolderUri is null or empty
ArgumentNullException | A name or permissions or parentFolderUri is null

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.CreatePublicFolder Overload List


ExchangeWebServiceClient.CreateTask Method

Creates the given task in the specified folder.

public virtual void CreateTask(
string folder,
ExchangeTask task
);

Parameters

folder
A folder where task should be created.
task
A task to create.

Implements

IEWSClient.CreateTask

Exceptions

Exception Type | Condition
ArgumentException | folder is null or empty.
ArgumentNullException | task is null.

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.CreateUserConfiguration Method

Creates the specified user configuration

public virtual void CreateUserConfiguration(
UserConfiguration userConfiguration
);

Parameters

userConfiguration
UserConfiguration to be created

Implements

IEWSClient.CreateUserConfiguration

Exceptions

Exception Type | Condition
ArgumentNullException | throws when userConfiguration is null

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


DelegateAccess Method

Aspose.Email

ExchangeWebServiceClient.DelegateAccess Method

Delegates access on the specified mailbox to the specified user.

Overload List

Delegates access on the specified mailbox to the specified user.

public virtual void DelegateAccess(ExchangeDelegateUser,string);

Delegates access on the mailbox to the specified users.

public virtual void DelegateAccess(ExchangeDelegateUserCollection,string);

Delegates access on the principal mailbox to the specified user.

public virtual void DelegateAccess(string,ExchangeDelegateFolderPermissionLevel,string);

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.DelegateAccess Method (ExchangeDelegateUser, String)

Delegates access on the specified mailbox to the specified user.

public virtual void DelegateAccess(
ExchangeDelegateUser delegateUser,
string mailbox
);

Parameters

delegateUser
A ExchangeDelegateUser containing user information and delegation settings.
mailbox
A mailbox to grant access on.

Implements

IEWSClient.DelegateAccess

Exceptions

Exception Type | Condition
ArgumentNullException | delegateUser is null.
ArgumentException | mailbox is null or empty.

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.DelegateAccess Overload List


ExchangeWebServiceClient.DelegateAccess Method (ExchangeDelegateUserCollection, String)

Delegates access on the mailbox to the specified users.

public virtual void DelegateAccess(
ExchangeDelegateUserCollection delegateUsers,
string mailbox
);

Parameters

delegateUsers
A ExchangeDelegateUserCollection containing the users information and delegation settings.
mailbox
A mailbox to grant access on.

Implements

IEWSClient.DelegateAccess

Exceptions

Exception Type | Condition
ArgumentNullException | delegateUsers is null.
ArgumentException | mailbox is null or empty.

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.DelegateAccess Overload List


ExchangeWebServiceClient.DelegateAccess Method (String, ExchangeDelegateFolderPermissionLevel, String)

Delegates access on the principal mailbox to the specified user.

public virtual void DelegateAccess(
string delegateSmtpAddress,
ExchangeDelegateFolderPermissionLevel permissionLevel,
string mailbox
);

Parameters

delegateSmtpAddress
A primary smtp address of user.
permissionLevel
A permission level that is granted to the user on all folders.
mailbox
A mailbox to grant access on.

Implements

IEWSClient.DelegateAccess

Exceptions

Exception Type | Condition
ArgumentException | delegateSmtpAddress or mailbox is null or empty.

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.DelegateAccess Overload List


DeleteContact Method

Aspose.Email

ExchangeWebServiceClient.DeleteContact Method

Deletes the contact.

Overload List

Deletes the contact.

public override void DeleteContact(MapiContact);

Deletes the contact.

public virtual void DeleteContact(MapiContact,bool);

Deletes the contact.

public override void DeleteContact(string);

Deletes the contact.

public virtual void DeleteContact(string,bool);

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.DeleteContact Method (MapiContact)

Deletes the contact.

public override void DeleteContact(
MapiContact contact
);

Parameters

contact
Contact

Implements

IExchangeClientBase.DeleteContact

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.DeleteContact Overload List


ExchangeWebServiceClient.DeleteContact Method (MapiContact, Boolean)

Deletes the contact.

public virtual void DeleteContact(
MapiContact contact,
bool deletePermanently
);

Parameters

contact
Contact
deletePermanently
Indicates whether the specified contact should be deleted permanently or should be moved into DeletedItems folder

Implements

IEWSClient.DeleteContact

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.DeleteContact Overload List


ExchangeWebServiceClient.DeleteContact Method (String)

Deletes the contact.

public override void DeleteContact(
string id
);

Parameters

id
The contact identifier.

Implements

IExchangeClientBase.DeleteContact

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.DeleteContact Overload List


ExchangeWebServiceClient.DeleteContact Method (String, Boolean)

Deletes the contact.

public virtual void DeleteContact(
string id,
bool deletePermanently
);

Parameters

id
The contact identifier.
deletePermanently
Indicates whether the specified contact should be deleted permanently or should be moved into DeletedItems folder

Implements

IEWSClient.DeleteContact

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.DeleteContact Overload List


DeleteContacts Method

Aspose.Email

ExchangeWebServiceClient.DeleteContacts Method

Deletes the contacts.

Overload List

Deletes the contacts.

public virtual void DeleteContacts(StringCollection);

Deletes the contacts.

public virtual void DeleteContacts(StringCollection,bool);

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.DeleteContacts Method (StringCollection)

Deletes the contacts.

public virtual void DeleteContacts(
StringCollection contactIds
);

Parameters

contactIds
The contact identifiers.

Implements

IEWSClient.DeleteContacts

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.DeleteContacts Overload List


ExchangeWebServiceClient.DeleteContacts Method (StringCollection, Boolean)

Deletes the contacts.

public virtual void DeleteContacts(
StringCollection contactIds,
bool deletePermanently
);

Parameters

contactIds
The contact identifiers.
deletePermanently
Indicates whether the specified contact should be deleted permanently or should be moved into DeletedItems folder

Implements

IEWSClient.DeleteContacts

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.DeleteContacts Overload List


DeleteConversationItems Method

Aspose.Email

ExchangeWebServiceClient.DeleteConversationItems Method

Deletes all items of the specified conversation

Overload List

Deletes all items of the specified conversation

public virtual void DeleteConversationItems(string);

Deletes the conversation items, which are located in the specified folder

public virtual void DeleteConversationItems(string,string);

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.DeleteConversationItems Method (String)

Deletes all items of the specified conversation

public virtual void DeleteConversationItems(
string conversationId
);

Parameters

conversationId
Id of conversation to delete

Implements

IEWSClient.DeleteConversationItems

Exceptions

Exception Type | Condition
ArgumentException | conversationId is null or empty

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.DeleteConversationItems Overload List


ExchangeWebServiceClient.DeleteConversationItems Method (String, String)

Deletes the conversation items, which are located in the specified folder

public virtual void DeleteConversationItems(
string conversationId,
string contextFolderId
);

Parameters

conversationId
Id of conversation to delete
contextFolderId
Id of folder in which delete conversation items. Note: If it's set to null(or empty), all conversation items will be deleted

Implements

IEWSClient.DeleteConversationItems

Exceptions

Exception Type | Condition
ArgumentException | conversationId is null or empty

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.DeleteConversationItems Overload List


DeleteFolder Method

Aspose.Email

ExchangeWebServiceClient.DeleteFolder Method

Deletes the folder

Overload List

Deletes the folder

public override void DeleteFolder(string);

Deletes the folder

public virtual void DeleteFolder(string,bool);

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.DeleteFolder Method (String)

Deletes the folder

public override void DeleteFolder(
string folderUri
);

Parameters

folderUri
The folder Uri

Implements

IExchangeClientBase.DeleteFolder

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.DeleteFolder Overload List


ExchangeWebServiceClient.DeleteFolder Method (String, Boolean)

Deletes the folder

public virtual void DeleteFolder(
string folderUri,
bool deletePermanently
);

Parameters

folderUri
The folder Uri
deletePermanently
Indicates whether the folder should be deleted permanently or should be moved into DeletedItems folder

Implements

IEWSClient.DeleteFolder

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.DeleteFolder Overload List


DeleteFolders Method

Aspose.Email

ExchangeWebServiceClient.DeleteFolders Method

Deletes the specified folders

Overload List

Deletes the specified folders

public virtual void DeleteFolders(ExchangeFolderInfoCollection);

Deletes the specified folders

public virtual void DeleteFolders(ExchangeFolderInfoCollection,bool);

Deletes the specified folders

public virtual void DeleteFolders(StringCollection);

Deletes the folder

public virtual void DeleteFolders(StringCollection,bool);

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.DeleteFolders Method (ExchangeFolderInfoCollection)

Deletes the specified folders

public virtual void DeleteFolders(
ExchangeFolderInfoCollection folders
);

Parameters

folders
A ExchangeFolderInfoCollection containing information about folders to delete

Implements

IEWSClient.DeleteFolders

Exceptions

Exception Type | Condition
ArgumentNullException | folders is null

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.DeleteFolders Overload List


ExchangeWebServiceClient.DeleteFolders Method (ExchangeFolderInfoCollection, Boolean)

Deletes the specified folders

public virtual void DeleteFolders(
ExchangeFolderInfoCollection folders,
bool deletePermanently
);

Parameters

folders
A ExchangeFolderInfoCollection containing information about folders to delete
deletePermanently
Indicates whether the folder should be deleted permanently or should be moved into DeletedItems folder

Implements

IEWSClient.DeleteFolders

Exceptions

Exception Type | Condition
ArgumentNullException | folders is null

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.DeleteFolders Overload List


ExchangeWebServiceClient.DeleteFolders Method (StringCollection)

Deletes the specified folders

public virtual void DeleteFolders(
StringCollection folderUris
);

Parameters

folderUris
The folder uris

Implements

IEWSClient.DeleteFolders

Exceptions

Exception Type | Condition
ArgumentNullException | folderUris is null

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.DeleteFolders Overload List


ExchangeWebServiceClient.DeleteFolders Method (StringCollection, Boolean)

Deletes the folder

public virtual void DeleteFolders(
StringCollection folderUris,
bool deletePermanently
);

Parameters

folderUris
The folder Uri
deletePermanently
Indicates whether the folder should be deleted permanently or should be moved into DeletedItems folder

Implements

IEWSClient.DeleteFolders

Exceptions

Exception Type | Condition
ArgumentNullException | folderUris is null

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.DeleteFolders Overload List


DeleteInboxRule Method

Aspose.Email

ExchangeWebServiceClient.DeleteInboxRule Method

Deletes the specified inbox rule

Overload List

Deletes the specified inbox rule

public virtual void DeleteInboxRule(string);

Deletes the specified inbox rule

public virtual void DeleteInboxRule(string,string);

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.DeleteInboxRule Method (String)

Deletes the specified inbox rule

public virtual void DeleteInboxRule(
string ruleId
);

Parameters

ruleId
An id of inbox rule to delete

Implements

IEWSClient.DeleteInboxRule

Exceptions

Exception Type | Condition
ArgumentException | throws when ruleId is null or empty

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.DeleteInboxRule Overload List


ExchangeWebServiceClient.DeleteInboxRule Method (String, String)

Deletes the specified inbox rule

public virtual void DeleteInboxRule(
string ruleId,
string mailbox
);

Parameters

ruleId
An id of inbox rule to delete
mailbox
A mailbox where rule is located. Note: if it is set to null or empty, the rule will be searched in the default mailbox

Implements

IEWSClient.DeleteInboxRule

Exceptions

Exception Type | Condition
ArgumentException | throws when ruleId is null or empty

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.DeleteInboxRule Overload List


DeleteMessage Method

Aspose.Email

ExchangeWebServiceClient.DeleteMessage Method

Deletes the mail message

Overload List

Deletes the mail message

public override void DeleteMessage(string);

Deletes the mail message

public virtual void DeleteMessage(string,bool);

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.DeleteMessage Method (String)

Deletes the mail message

public override void DeleteMessage(
string messageUri
);

Parameters

messageUri
The message uri

Implements

IExchangeClientBase.DeleteMessage

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.DeleteMessage Overload List


ExchangeWebServiceClient.DeleteMessage Method (String, Boolean)

Deletes the mail message

public virtual void DeleteMessage(
string messageUri,
bool deletePermanently
);

Parameters

messageUri
The message uri
deletePermanently
Indicates whether the specified message should be deleted permanently or should be moved into DeletedItems folder

Implements

IEWSClient.DeleteMessage

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.DeleteMessage Overload List


DeleteMessages Method

Aspose.Email

ExchangeWebServiceClient.DeleteMessages Method

Deletes the specified mail messages

Overload List

Deletes the specified mail messages

public virtual void DeleteMessages(ExchangeMessageInfoCollection);

Deletes the specified mail messages

public virtual void DeleteMessages(ExchangeMessageInfoCollection,bool);

Deletes the specified mail messages

public virtual void DeleteMessages(StringCollection);

Deletes the specified mail messages

public virtual void DeleteMessages(StringCollection,bool);

Deletes the specified mail messages

public virtual void DeleteMessages(StringCollection,bool,CalendarItemCreateOrDeleteOperation);

Deletes the specified mail messages

public virtual void DeleteMessages(StringCollection,bool,CalendarItemCreateOrDeleteOperationType);

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.DeleteMessages Method (ExchangeMessageInfoCollection)

Deletes the specified mail messages

public virtual void DeleteMessages(
ExchangeMessageInfoCollection messages
);

Parameters

messages
A ExchangeMessageInfoCollection containing message informations

Implements

IEWSClient.DeleteMessages

Exceptions

Exception Type | Condition
ArgumentNullException | messages is null

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.DeleteMessages Overload List


ExchangeWebServiceClient.DeleteMessages Method (ExchangeMessageInfoCollection, Boolean)

Deletes the specified mail messages

public virtual void DeleteMessages(
ExchangeMessageInfoCollection messages,
bool deletePermanently
);

Parameters

messages
A ExchangeMessageInfoCollection containing message informations
deletePermanently
Indicates whether the specified message should be deleted permanently or should be moved into DeletedItems folder

Implements

IEWSClient.DeleteMessages

Exceptions

Exception Type | Condition
ArgumentNullException | messages is null

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.DeleteMessages Overload List


ExchangeWebServiceClient.DeleteMessages Method (StringCollection)

Deletes the specified mail messages

public virtual void DeleteMessages(
StringCollection messageUris
);

Parameters

messageUris
The message uris

Implements

IEWSClient.DeleteMessages

Exceptions

Exception Type | Condition
ArgumentNullException | messageUris is null

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.DeleteMessages Overload List


ExchangeWebServiceClient.DeleteMessages Method (StringCollection, Boolean)

Deletes the specified mail messages

public virtual void DeleteMessages(
StringCollection messageUris,
bool deletePermanently
);

Parameters

messageUris
The message uris
deletePermanently
Indicates whether the specified message should be deleted permanently or should be moved into DeletedItems folder

Implements

IEWSClient.DeleteMessages

Exceptions

Exception Type | Condition
ArgumentNullException | messageUris is null

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.DeleteMessages Overload List


ExchangeWebServiceClient.DeleteMessages Method (StringCollection, Boolean, CalendarItemCreateOrDeleteOperation)

Deletes the specified mail messages

public virtual void DeleteMessages(
StringCollection messageUris,
bool deletePermanently,
CalendarItemCreateOrDeleteOperation options
);

Parameters

messageUris
The message uris
deletePermanently
Indicates whether the specified message should be deleted permanently or should be moved into DeletedItems folder
options
Describes how meeting requests and cancellations are handled.

Implements

IEWSClient.DeleteMessages

Exceptions

Exception Type | Condition
ArgumentNullException | messageUris is null

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.DeleteMessages Overload List


ExchangeWebServiceClient.DeleteMessages Method (StringCollection, Boolean, CalendarItemCreateOrDeleteOperationType)

Deletes the specified mail messages

public virtual void DeleteMessages(
StringCollection messageUris,
bool deletePermanently,
CalendarItemCreateOrDeleteOperationType options
);

Parameters

messageUris
The message uris
deletePermanently
Indicates whether the specified message should be deleted permanently or should be moved into DeletedItems folder
options
Describes how meeting requests and cancellations are handled.

Exceptions

Exception Type | Condition
ArgumentNullException | messageUris is null

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.DeleteMessages Overload List


DeleteTask Method

Aspose.Email

ExchangeWebServiceClient.DeleteTask Method

Deletes the specified task.

Overload List

Deletes the specified task.

public virtual void DeleteTask(string);

Deletes the specified task.

public virtual void DeleteTask(string,DeleteTaskOptions);

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.DeleteTask Method (String)

Deletes the specified task.

public virtual void DeleteTask(
string taskUri
);

Parameters

taskUri
Uri of task to be deleted.

Implements

IEWSClient.DeleteTask

Exceptions

Exception Type | Condition
ArgumentException | taskUri is null or empty.

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.DeleteTask Overload List


ExchangeWebServiceClient.DeleteTask Method (String, DeleteTaskOptions)

Deletes the specified task.

public virtual void DeleteTask(
string taskUri,
DeleteTaskOptions options
);

Parameters

taskUri
Uri of task to be deleted.
options
A deletion options.

Implements

IEWSClient.DeleteTask

Exceptions

Exception Type | Condition
ArgumentException | taskUri is null or empty.

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.DeleteTask Overload List


ExchangeWebServiceClient.DeleteUserConfiguration Method

Deletes the specified user configuration

public virtual void DeleteUserConfiguration(
UserConfigurationName userConfigurationName
);

Parameters

userConfigurationName
Specifies a user configuration to delete

Implements

IEWSClient.DeleteUserConfiguration

Exceptions

Exception Type | Condition
ArgumentNullException | throws when userConfigurationName is null

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.DisconnectPhoneCall Method

Disconnects a phone call specified by id.

public virtual void DisconnectPhoneCall(
string callId
);

Parameters

callId
Phone call id.

Implements

IEWSClient.DisconnectPhoneCall

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


Dispose Method

Aspose.Email

ExchangeWebServiceClient.Dispose Method

Releases unmanaged and - optionally - managed resources

Overload List

Inherited from ExchangeClientBase.

public void Dispose();

Releases unmanaged and - optionally - managed resources

protected override void Dispose(bool);

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.Dispose Method (Boolean)

Releases unmanaged and - optionally - managed resources

protected override void Dispose(
bool disposing
);

Parameters

disposing
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.Dispose Overload List


EmptyFolder Method

Aspose.Email

ExchangeWebServiceClient.EmptyFolder Method

Empties the specified folder. Subfolders will not be deleted; deleted items will be moved into DeletedItems folder

Overload List

Empties the specified folder. Subfolders will not be deleted; deleted items will be moved into DeletedItems folder

public virtual void EmptyFolder(string);

Empties the specified folder

public virtual void EmptyFolder(string,EmptyFolderOptions);

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.EmptyFolder Method (String)

Empties the specified folder. Subfolders will not be deleted; deleted items will be moved into DeletedItems folder

public virtual void EmptyFolder(
string folderUri
);

Parameters

folderUri
Specifies the folder to be empty

Implements

IEWSClient.EmptyFolder

Exceptions

Exception Type | Condition
ExchangeException | EmptyFolder operation failed
ArgumentException | folderUri is null or empty

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.EmptyFolder Overload List


ExchangeWebServiceClient.EmptyFolder Method (String, EmptyFolderOptions)

Empties the specified folder

public virtual void EmptyFolder(
string folderUri,
EmptyFolderOptions options
);

Parameters

folderUri
Specifies the folder to be empty
options
Specifies the options of clearing folder

Implements

IEWSClient.EmptyFolder

Exceptions

Exception Type | Condition
ExchangeException | EmptyFolder operation failed
ArgumentException | folderUri is null or empty

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.EmptyFolder Overload List


ExchangeWebServiceClient.ExportItems Method

Exports the specified items from mailbox

public virtual ExchangeStreamedItem[] ExportItems(
string[] itemIds
);

Parameters

itemIds
Ids of itmes to be exported

Return Value

An array of ExchangeStreamedItem

Implements

IEWSClient.ExportItems

Exceptions

Exception Type | Condition
ArgumentNullException | itemIds is null
ArgumentException | itemIds is empty

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.FetchAppointment Method

Fetch the specified appointment from server.

public virtual Appointment FetchAppointment(
string appointmentUri
);

Parameters

appointmentUri
An uri of appointment to be fetched.

Return Value

A fetched Appointment.

Implements

IEWSClient.FetchAppointment

Exceptions

Exception Type | Condition
ArgumentException | appointmentUri is null or empty.

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.FetchAttachment Method

Fetches the attachment

public override Attachment FetchAttachment(
string attachmentUri
);

Parameters

attachmentUri
The attachment uri. (Attachment uri can be retrieved using ListMessages(folder, ExchangeListMessagesOptions.FetchAttachmentInformation) method)

Return Value

Attachment that represents fetched attachment

Implements

IExchangeClientBase.FetchAttachment

Exceptions

Exception Type | Condition
ArgumentException | attachmentUri is null or empty

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.FetchMapiAttachments Method

public virtual MapiAttachmentCollection FetchMapiAttachments(
IEnumerable<string> ids
);

Implements

IEWSClient.FetchMapiAttachments

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


FetchMessage Method

Aspose.Email

ExchangeWebServiceClient.FetchMessage Method

Fetches the message from server

Overload List

Fetches the message from server

public override MailMessage FetchMessage(string);

Fetches the message from server

public virtual MailMessage FetchMessage(string,string[]);

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.FetchMessage Method (String)

Fetches the message from server

public override MailMessage FetchMessage(
string messageUri
);

Parameters

messageUri
The URI of the message

Return Value

MailMessage that represents e-mail message, custom properties won't be returned using this method, you have to use an overloaded version to get them.

Implements

IExchangeClientBase.FetchMessage

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.FetchMessage Overload List


ExchangeWebServiceClient.FetchMessage Method (String, String[])

Fetches the message from server

public virtual MailMessage FetchMessage(
string messageUri,
string[] extendedProperties
);

Parameters

messageUri
The URI of the message
extendedProperties
An array of extended properties names

Return Value

MailMessage that represents e-mail message, if custom properties have been found and set you can access them using Headers collection.

Implements

IEWSClient.FetchMessage

Exceptions

Exception Type | Condition
ArgumentException | messageUri is null or empty
ExchangeException | Message can not be fetched

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.FetchMessage Overload List


FetchMessages Method

Aspose.Email

ExchangeWebServiceClient.FetchMessages Method

Fetches the speciifed messages

Overload List

Fetches the speciifed messages

public virtual MailMessageCollection FetchMessages(ExchangeMessageInfoCollection);

Fetches the speciifed messages

public virtual MailMessageCollection FetchMessages(StringCollection);

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.FetchMessages Method (ExchangeMessageInfoCollection)

Fetches the speciifed messages

public virtual MailMessageCollection FetchMessages(
ExchangeMessageInfoCollection messageInfos
);

Parameters

messageInfos
A ExchangeMessageInfoCollection of messages to be retrieved

Return Value

A MailMessageCollection containing fetched messages

Implements

IEWSClient.FetchMessages

Exceptions

Exception Type | Condition
ArgumentNullException | messageInfos is null

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.FetchMessages Overload List


ExchangeWebServiceClient.FetchMessages Method (StringCollection)

Fetches the speciifed messages

public virtual MailMessageCollection FetchMessages(
StringCollection messageUris
);

Parameters

messageUris
A StringCollection containing message uris to be retrieved

Return Value

A MailMessageCollection containing fetched messages

Implements

IEWSClient.FetchMessages

Exceptions

Exception Type | Condition
ArgumentNullException | messageUris is null

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.FetchMessages Overload List


ExchangeWebServiceClient.FetchTask Method

Fetches the specified task.

public virtual ExchangeTask FetchTask(
string taskUri
);

Parameters

taskUri
A task uri.

Return Value

A fetched ExchangeTask

Implements

IEWSClient.FetchTask

Exceptions

Exception Type | Condition
ArgumentException | taskUri is null or empty.

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.FindConversations Method

Finds conversations in the specified folder

public virtual ExchangeConversation[] FindConversations(
string folderId
);

Parameters

folderId
An id of folder in which search

Return Value

An array of found ExchangeConversation

Implements

IEWSClient.FindConversations

Exceptions

Exception Type | Condition
ArgumentException | folderId is null or empty

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.FindMessages Method

Gets the collection of messages from specified folder

public virtual ExchangeMessageInfoCollection FindMessages(
string uri
);

Parameters

uri
The URI of folder

Return Value

ExchangeMessageInfoCollection that contains messages from the specified folder

Implements

IEWSClient.FindMessages

Remarks

To retrieve messages faster, please, use ListMessages method. But note that ListMessages method doesn't return sender's and recipient's address in ExchangeMessageInfo object.

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.FindMessageTrackingReport Method

Finds messages that meet the specified criteria.

public virtual MessageTrackingReportInfo[] FindMessageTrackingReport(
FindMessageTrackingReportOptions options
);

Parameters

options
Options specifying a search criteria

Return Value

An array of MessageTrackingReportInfo that represents message tracking report information

Implements

IEWSClient.FindMessageTrackingReport

Exceptions

Exception Type | Condition
ArgumentNullException | throws when options is null

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


FolderExists Method

Aspose.Email

ExchangeWebServiceClient.FolderExists Method

Overload List

Inherited from ExchangeClientBase.

public bool FolderExists(string,string);

public override bool FolderExists(string,string,out ExchangeFolderInfo);

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.FolderExists Method (String, String, ExchangeFolderInfo)

public override bool FolderExists(
string parentFolderUri,
string folderName,
out ExchangeFolderInfo folder
);

Implements

IExchangeClientBase.FolderExists

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.FolderExists Overload List


ExchangeWebServiceClient.Forward Method

public virtual void Forward(
MailMessage message,
ExchangeMessageInfo messageInfo
);

Implements

IEWSClient.Forward

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.GetCallInfo Method

Retrieves phone call information by call id This functionality is not supported for obsolete classes.

public virtual CallInformation GetCallInfo(
string callId
);

Parameters

callId
call id

Return Value

Returns phone call information object

Implements

IEWSClient.GetCallInfo

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.GetExchangeType Method

Gets the information about the current version of MS Exchange.

public virtual ExchangeVersionType GetExchangeType();

Return Value

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.GetFolderInfo Method

Gets the folder information

public virtual ExchangeFolderInfo GetFolderInfo(
string folder
);

Parameters

folder
A folder uri or distinguished folder name

Return Value

A ExchangeFolderInfo that represents the folder information

Implements

IEWSClient.GetFolderInfo

Exceptions

Exception Type | Condition
ArgumentException | folder is null or empty
ExchangeException | Server responded an error message

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.GetFolderPermissions Method

Gets the folder permissions.

public virtual ExchangePermissionCollection GetFolderPermissions(
string folderUrl
);

Parameters

folderUrl
The folder URL.

Return Value

The ExchangePermissionCollection

Implements

IEWSClient.GetFolderPermissions

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


GetInboxRules Method

Aspose.Email

ExchangeWebServiceClient.GetInboxRules Method

Gets inbox rules

Overload List

Gets inbox rules

public virtual InboxRule[] GetInboxRules();

Gets inbox rules

public virtual InboxRule[] GetInboxRules(string);

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.GetInboxRules Method ()

Gets inbox rules

public virtual InboxRule[] GetInboxRules();

Return Value

An array of InboxRule

Implements

IEWSClient.GetInboxRules

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.GetInboxRules Overload List


ExchangeWebServiceClient.GetInboxRules Method (String)

Gets inbox rules

public virtual InboxRule[] GetInboxRules(
string mailbox
);

Parameters

mailbox
A mailbox to read inbox rule from. Note: if it is set to null or empty, the rules will be read from the default mailbox

Return Value

An array of InboxRule

Implements

IEWSClient.GetInboxRules

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.GetInboxRules Overload List


GetMailboxInfo Method

Aspose.Email

ExchangeWebServiceClient.GetMailboxInfo Method

Gets the mailbox information

Overload List

Gets the mailbox information

public override ExchangeMailboxInfo GetMailboxInfo();

Gets the mailbox information

public override ExchangeMailboxInfo GetMailboxInfo(string);

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.GetMailboxInfo Method ()

Gets the mailbox information

public override ExchangeMailboxInfo GetMailboxInfo();

Return Value

ExchangeMailboxInfo that represents mailbox information

Implements

IExchangeClientBase.GetMailboxInfo

Exceptions

Exception Type | Condition
ExchangeException | Mailbox information can not be read.

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.GetMailboxInfo Overload List


ExchangeWebServiceClient.GetMailboxInfo Method (String)

Gets the mailbox information

public override ExchangeMailboxInfo GetMailboxInfo(
string mailbox
);

Parameters

mailbox
A mailbox to read from. Note: if mailbox is set to null or empty the default mailbox will be used

Return Value

ExchangeMailboxInfo that represents mailbox information

Implements

IExchangeClientBase.GetMailboxInfo

Exceptions

Exception Type | Condition
ExchangeException | Mailbox information can not be read.

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.GetMailboxInfo Overload List


GetMailboxSize Method

Aspose.Email

ExchangeWebServiceClient.GetMailboxSize Method

Gets the size of the mailbox

Overload List

Gets the size of the mailbox

public override long GetMailboxSize();

Gets the size of the mailbox

public override long GetMailboxSize(string);

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.GetMailboxSize Method ()

Gets the size of the mailbox

public override long GetMailboxSize();

Return Value

size of the mailbox in bytes

Implements

IExchangeClientBase.GetMailboxSize

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.GetMailboxSize Overload List


ExchangeWebServiceClient.GetMailboxSize Method (String)

Gets the size of the mailbox

public override long GetMailboxSize(
string mailbox
);

Parameters

mailbox
A mailbox. Note: if it is set to null or empty the default mailbox will be used

Return Value

size of the mailbox in bytes

Implements

IExchangeClientBase.GetMailboxSize

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.GetMailboxSize Overload List


ExchangeWebServiceClient.GetMailTips Method

Gets mail tips

public virtual MailTips[] GetMailTips(
GetMailTipsOptions options
);

Parameters

options
Options specifying a search criteria

Return Value

An array of read MapiContact that represents contact information

Implements

IEWSClient.GetMailTips

Exceptions

Exception Type | Condition
ArgumentNullException | throws when options is null

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.GetMessageTrackingReport Method

Gets message tracking report

public virtual MessageTrackingReport GetMessageTrackingReport(
GetMessageTrackingReportOptions options
);

Parameters

options
Options specifying a search criteria

Return Value

A found MessageTrackingReport or null if no message tracking report was found

Implements

IEWSClient.GetMessageTrackingReport

Exceptions

Exception Type | Condition
ArgumentNullException | throws when options is null

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


GetServerTimeZoneIds Method

Aspose.Email

ExchangeWebServiceClient.GetServerTimeZoneIds Method

The GetServerTimeZoneIds returns information from time zone id that are available on an Exchange server. This functionality is not supported for obsolete classes.

Overload List

The GetServerTimeZoneIds returns information from time zone id that are available on an Exchange server. This functionality is not supported for obsolete classes.

public virtual string[] GetServerTimeZoneIds();

The GetServerTimeZoneIds returns information from time zone id that are available on an Exchange server.

public virtual string[] GetServerTimeZoneIds(String});

The GetServerTimeZoneIds returns information from time zone id that are available on an Exchange server. This functionality is not supported for obsolete classes.

public virtual string[] GetServerTimeZoneIds(params string[]);

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.GetServerTimeZoneIds Method ()

The GetServerTimeZoneIds returns information from time zone id that are available on an Exchange server. This functionality is not supported for obsolete classes.

public virtual string[] GetServerTimeZoneIds();

Return Value

Returns an array of time zone id that are available on an Exchange server.

Implements

IEWSClient.GetServerTimeZoneIds

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.GetServerTimeZoneIds Overload List


ExchangeWebServiceClient.GetServerTimeZoneIds Method (String})

The GetServerTimeZoneIds returns information from time zone id that are available on an Exchange server.

public virtual string[] GetServerTimeZoneIds(
IEnumerable<string> timeZoneIds
);

Parameters

timeZoneIds
Identifiers of time zones for checking existence on the server.

Return Value

Returns an array of time zone id that are available on an Exchange server.

Implements

IEWSClient.GetServerTimeZoneIds

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.GetServerTimeZoneIds Overload List


ExchangeWebServiceClient.GetServerTimeZoneIds Method (String[])

The GetServerTimeZoneIds returns information from time zone id that are available on an Exchange server. This functionality is not supported for obsolete classes.

public virtual string[] GetServerTimeZoneIds(
params string[] timeZoneIds
);

Parameters

timeZoneIds
Identifiers of time zones for checking existence on the server.

Return Value

Returns an array of time zone id that are available on an Exchange server.

Implements

IEWSClient.GetServerTimeZoneIds

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.GetServerTimeZoneIds Overload List


ExchangeWebServiceClient.GetUMConfiguration Method

Retrieves unified messaging configuration This functionality is not supported for obsolete classes.

public virtual UnifiedMessagingConfiguration GetUMConfiguration();

Return Value

Returns unified messaging configuration

Implements

IEWSClient.GetUMConfiguration

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.GetUserConfiguration Method

Gets the specified user configuration

public virtual UserConfiguration GetUserConfiguration(
UserConfigurationName userConfigurationName
);

Parameters

userConfigurationName
Specifies a user configuration to search

Return Value

A received UserConfiguration

Implements

IEWSClient.GetUserConfiguration

Exceptions

Exception Type | Condition
ArgumentNullException | throws when userConfigurationName is null

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.GetVersionInfo Method

Returns exchange server version info

public override string GetVersionInfo();

Return Value

Returns exchange server version info

Implements

IExchangeClientBase.GetVersionInfo

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ImpersonateUser Method

Aspose.Email

ExchangeWebServiceClient.ImpersonateUser Method

Impersonates the user.

Overload List

Impersonates the user.

public virtual void ImpersonateUser(ItemChoice,string);

Impersonates the user.

public virtual void ImpersonateUser(ItemChoiceType,string);

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.ImpersonateUser Method (ItemChoice, String)

Impersonates the user.

public virtual void ImpersonateUser(
ItemChoice valueType,
string value
);

Parameters

valueType
The ItemChoice enumeration value to use for impersonation.
value
The item name.

Implements

IEWSClient.ImpersonateUser

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.ImpersonateUser Overload List


ExchangeWebServiceClient.ImpersonateUser Method (ItemChoiceType, String)

Impersonates the user.

public virtual void ImpersonateUser(
ItemChoiceType valueType,
string value
);

Parameters

valueType
The ItemChoiceType enumeration value to use for impersonation.
value
The item name.

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.ImpersonateUser Overload List


ListContacts Method

Aspose.Email

ExchangeWebServiceClient.ListContacts Method

Lists contacts located in the specified folder on server

Overload List

Lists contacts located in the specified folder on server

public override MapiContact[] ListContacts(string);

Lists contacts located in the specified folder on server

public virtual MapiContact[] ListContacts(string,ExchangeListContactsOptions);

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.ListContacts Method (String)

Lists contacts located in the specified folder on server

public override MapiContact[] ListContacts(
string folder
);

Parameters

folder
A folder to search contacts in

Return Value

An array of read MapiContact that represents contact information

Implements

IExchangeClientBase.ListContacts

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.ListContacts Overload List


ExchangeWebServiceClient.ListContacts Method (String, ExchangeListContactsOptions)

Lists contacts located in the specified folder on server

public virtual MapiContact[] ListContacts(
string folder,
ExchangeListContactsOptions options
);

Parameters

folder
A folder to search contacts in
options
Enumerates the list contacts options

Return Value

An array of read MapiContact that represents contact information

Implements

IEWSClient.ListContacts

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.ListContacts Overload List


ExchangeWebServiceClient.ListDelegates Method

Lists the users who are granted access on the specified mailbox.

public virtual ExchangeDelegateUserCollection ListDelegates(
string mailbox
);

Parameters

mailbox
A mailbox.

Return Value

A ExchangeDelegateUserCollection representing the delegate users.

Implements

IEWSClient.ListDelegates

Exceptions

Exception Type | Condition
ArgumentException | mailbox is null or empty.

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.ListMailboxes Method

Lists mailboxes having smtp addresses. Note: the maximum count of returned contacts is 100. This is a restriction of used EWS operation.

public override MapiContactCollection ListMailboxes();

Return Value

A MapiContactCollection that represents contact information

Implements

IExchangeClientBase.ListMailboxes

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ListMessages Method

Aspose.Email

ExchangeWebServiceClient.ListMessages Method

Gets the collection of messages from specified folder

Overload List

Inherited from ExchangeClientBase.

public ExchangeMessageInfoCollection ListMessages(string);

Gets the collection of messages from specified folder

public override ExchangeMessageInfoCollection ListMessages(string,ExchangeListMessagesOptions);

List the messages in the specified folder.

public virtual ExchangeMessageInfoCollection ListMessages(string,MailQuery);

List the messages in the specified folder.

public virtual ExchangeMessageInfoCollection ListMessages(string,MailQuery,bool);

List the messages in the specified folder

public virtual ExchangeMessageInfoCollection ListMessages(string,bool);

Inherited from ExchangeClientBase.

public ExchangeMessageInfoCollection ListMessages(string,int);

Gets the collection of messages from specified folder

public override ExchangeMessageInfoCollection ListMessages(string,int,ExchangeListMessagesOptions);

List the messages in the specified folder.

public virtual ExchangeMessageInfoCollection ListMessages(string,int,MailQuery);

List the messages in the specified folder.

public virtual ExchangeMessageInfoCollection ListMessages(string,int,MailQuery,bool);

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.ListMessages Method (String, ExchangeListMessagesOptions)

Gets the collection of messages from specified folder

public override ExchangeMessageInfoCollection ListMessages(
string folder,
ExchangeListMessagesOptions options
);

Parameters

folder
A folder to search messages in
options
Specifies the settings of listing

Return Value

ExchangeMessageInfoCollection that contains messages from the specified folder

Implements

IExchangeClientBase.ListMessages

Remarks

This method doesn't return sender's and recipient's address in ExchangeMessageInfo object. To retrieve them, please, use FindMessages method. Note that FindMessages method works slower.

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.ListMessages Overload List


ExchangeWebServiceClient.ListMessages Method (String, MailQuery)

List the messages in the specified folder.

public virtual ExchangeMessageInfoCollection ListMessages(
string folder,
MailQuery query
);

Parameters

folder
A folder to search messages in.
query
MailQuery that represents message search criteria.

Return Value

ExchangeMessageInfoCollection that contains messages from the specified folder.

Implements

IEWSClient.ListMessages

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.ListMessages Overload List


ExchangeWebServiceClient.ListMessages Method (String, MailQuery, Boolean)

List the messages in the specified folder.

public virtual ExchangeMessageInfoCollection ListMessages(
string folder,
MailQuery query,
bool recursive
);

Parameters

folder
A folder to search messages in.
query
MailQuery that represents message search criteria.
recursive
Indicates whether recursive listing or not.

Return Value

ExchangeMessageInfoCollection that contains messages from the specified folder.

Implements

IEWSClient.ListMessages

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.ListMessages Overload List


ExchangeWebServiceClient.ListMessages Method (String, Boolean)

List the messages in the specified folder

public virtual ExchangeMessageInfoCollection ListMessages(
string folder,
bool recursive
);

Parameters

folder
A folder to search messages in
recursive
Indicates whether recursive listing or not

Return Value

ExchangeMessageInfoCollection that contains messages from the specified folder

Implements

IEWSClient.ListMessages

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.ListMessages Overload List


ExchangeWebServiceClient.ListMessages Method (String, Int32, ExchangeListMessagesOptions)

Gets the collection of messages from specified folder

public override ExchangeMessageInfoCollection ListMessages(
string folder,
int maxNumberOfMessages,
ExchangeListMessagesOptions options
);

Parameters

folder
A folder to search messages in
maxNumberOfMessages
A maximum number of messages
options
Specifies the settings of listing

Return Value

ExchangeMessageInfoCollection that contains messages from the specified folder

Implements

IExchangeClientBase.ListMessages

Remarks

This method doesn't return sender's and recipient's address in ExchangeMessageInfo object. To retrieve them, please, use FindMessages method. Note that FindMessages method works slower.

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.ListMessages Overload List


ExchangeWebServiceClient.ListMessages Method (String, Int32, MailQuery)

List the messages in the specified folder.

public virtual ExchangeMessageInfoCollection ListMessages(
string folder,
int maxNumberOfMessages,
MailQuery query
);

Parameters

folder
A folder to search messages in.
maxNumberOfMessages
Maximum number of messages.
query
MailQuery that represents message search criteria.

Return Value

ExchangeMessageInfoCollection that contains messages from the specified folder.

Implements

IEWSClient.ListMessages

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.ListMessages Overload List


ExchangeWebServiceClient.ListMessages Method (String, Int32, MailQuery, Boolean)

List the messages in the specified folder.

public virtual ExchangeMessageInfoCollection ListMessages(
string folder,
int maxNumberOfMessages,
MailQuery query,
bool recursive
);

Parameters

folder
A folder to search messages in.
maxNumberOfMessages
Maximum number of messages.
query
MailQuery that represents message search criteria.
recursive
Indicates whether recursive listing or not.

Return Value

ExchangeMessageInfoCollection that contains messages from the specified folder.

Implements

IEWSClient.ListMessages

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.ListMessages Overload List


ListMessagesFromPublicFolder Method

Aspose.Email

ExchangeWebServiceClient.ListMessagesFromPublicFolder Method

Get collection of messages from public folder

Overload List

Get collection of messages from public folder

public virtual ExchangeMessageInfoCollection ListMessagesFromPublicFolder(ExchangeFolderInfo);

Get collection of messages from public folder

public virtual ExchangeMessageInfoCollection ListMessagesFromPublicFolder(string);

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.ListMessagesFromPublicFolder Method (ExchangeFolderInfo)

Get collection of messages from public folder

public virtual ExchangeMessageInfoCollection ListMessagesFromPublicFolder(
ExchangeFolderInfo folder
);

Parameters

folder
ExchangeFolderInfo that represents information about folder

Return Value

ExchangeMessageInfoCollection that contains messages from the specified folder

Implements

IEWSClient.ListMessagesFromPublicFolder

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.ListMessagesFromPublicFolder Overload List


ExchangeWebServiceClient.ListMessagesFromPublicFolder Method (String)

Get collection of messages from public folder

public virtual ExchangeMessageInfoCollection ListMessagesFromPublicFolder(
string folderUri
);

Parameters

folderUri
The uri of folder

Return Value

ExchangeMessageInfoCollection that contains messages from the specified folder

Implements

IEWSClient.ListMessagesFromPublicFolder

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.ListMessagesFromPublicFolder Overload List


ExchangeWebServiceClient.ListPublicFolders Method

Gets collection of public folders from root public folder

public override ExchangeFolderInfoCollection ListPublicFolders();

Return Value

ExchangeFolderInfoCollection that contains subfolders from the root public folder

Implements

IExchangeClientBase.ListPublicFolders

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ListSubFolders Method

Aspose.Email

ExchangeWebServiceClient.ListSubFolders Method

Gets collection of child folders from parent

Overload List

Inherited from ExchangeClientBase.

public ExchangeFolderInfoCollection ListSubFolders(ExchangeFolderInfo);

Gets collection of child folders from parent

public override ExchangeFolderInfoCollection ListSubFolders(string);

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.ListSubFolders Method (String)

Gets collection of child folders from parent

public override ExchangeFolderInfoCollection ListSubFolders(
string parentFolder
);

Parameters

parentFolder
A parent folder

Return Value

ExchangeFolderInfoCollection that contains subfolders from the parent folder

Implements

IExchangeClientBase.ListSubFolders

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.ListSubFolders Overload List


ExchangeWebServiceClient.LoadContactPhoto Method

public virtual void LoadContactPhoto(
MapiContactPhoto photo
);

Implements

IEWSClient.LoadContactPhoto

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.MailDisablePublicFolder Method

Mail-disable a public folder

public virtual void MailDisablePublicFolder(
string folderUri
);

Parameters

folderUri
A folder uri

Implements

IEWSClient.MailDisablePublicFolder

Exceptions

Exception Type | Condition
ArgumentException | folderUri is null or empty

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.MailEnablePublicFolder Method

Mail-enable a public folder

public virtual void MailEnablePublicFolder(
string folderUri
);

Parameters

folderUri
A folder uri

Implements

IEWSClient.MailEnablePublicFolder

Exceptions

Exception Type | Condition
ArgumentException | folderUri is null or empty

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


MarkAllItems Method

Aspose.Email

ExchangeWebServiceClient.MarkAllItems Method

Marks all items in specified folders. This functionality is not supported for obsolete classes.

Overload List

Marks all items in specified folders. This functionality is not supported for obsolete classes.

public void MarkAllItems(bool,bool,String});

Marks all items in specified folders. This functionality is not supported for obsolete classes.

public void MarkAllItems(bool,bool,params string[]);

Marks all items in specified folders. This functionality is not supported for obsolete classes.

public void MarkAllItems(bool,params string[]);

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.MarkAllItems Method (Boolean, Boolean, String})

Marks all items in specified folders. This functionality is not supported for obsolete classes.

public void MarkAllItems(
bool read,
bool suppressReadReceipts,
IEnumerable<string> folderIds
);

Parameters

read
Sets the read/unread state to messages in specified folder. True to mark messages in the folder as read. False to mark messages as unread.
suppressReadReceipts
True to suppress sending read receipts for messages; otherwise, false.
folderIds
List of folder uri for processing.

Implements

IEWSClient.MarkAllItems

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.MarkAllItems Overload List


ExchangeWebServiceClient.MarkAllItems Method (Boolean, Boolean, String[])

Marks all items in specified folders. This functionality is not supported for obsolete classes.

public void MarkAllItems(
bool read,
bool suppressReadReceipts,
params string[] folderIds
);

Parameters

read
Sets the read/unread state to messages in specified folder. True to mark messages in the folder as read. False to mark messages as unread.
suppressReadReceipts
True to suppress sending read receipts for messages; otherwise, false.
folderIds
List of folder uri for processing.

Implements

IEWSClient.MarkAllItems

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.MarkAllItems Overload List


ExchangeWebServiceClient.MarkAllItems Method (Boolean, String[])

Marks all items in specified folders. This functionality is not supported for obsolete classes.

public void MarkAllItems(
bool read,
params string[] folderIds
);

Parameters

read
Sets the read/unread state to messages in specified folder. True to mark messages in the folder as read. False to mark messages as unread.
folderIds
List of folder uri for processing.

Implements

IEWSClient.MarkAllItems

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.MarkAllItems Overload List


MarkAllItemsAsRead Method

Aspose.Email

ExchangeWebServiceClient.MarkAllItemsAsRead Method

Marks all items in inbox folder as read without receipts. This functionality is not supported for obsolete classes.

Overload List

Marks all items in inbox folder as read without receipts. This functionality is not supported for obsolete classes.

public void MarkAllItemsAsRead();

Marks all items in specified folders as read without receipts. This functionality is not supported for obsolete classes.

public void MarkAllItemsAsRead(String});

Marks all items in specified folders as read without receipts. This functionality is not supported for obsolete classes.

public void MarkAllItemsAsRead(params string[]);

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.MarkAllItemsAsRead Method ()

Marks all items in inbox folder as read without receipts. This functionality is not supported for obsolete classes.

public void MarkAllItemsAsRead();

Implements

IEWSClient.MarkAllItemsAsRead

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.MarkAllItemsAsRead Overload List


ExchangeWebServiceClient.MarkAllItemsAsRead Method (String})

Marks all items in specified folders as read without receipts. This functionality is not supported for obsolete classes.

public void MarkAllItemsAsRead(
IEnumerable<string> folderIds
);

Parameters

folderIds
List of folder uri for processing.

Implements

IEWSClient.MarkAllItemsAsRead

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.MarkAllItemsAsRead Overload List


ExchangeWebServiceClient.MarkAllItemsAsRead Method (String[])

Marks all items in specified folders as read without receipts. This functionality is not supported for obsolete classes.

public void MarkAllItemsAsRead(
params string[] folderIds
);

Parameters

folderIds
List of folder uri for processing.

Implements

IEWSClient.MarkAllItemsAsRead

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.MarkAllItemsAsRead Overload List


MarkAllItemsAsUnread Method

Aspose.Email

ExchangeWebServiceClient.MarkAllItemsAsUnread Method

Marks all items in inbox folder as unread.

Overload List

Marks all items in inbox folder as unread.

public void MarkAllItemsAsUnread();

Marks all items in specified folders as unread. This functionality is not supported for obsolete classes.

public void MarkAllItemsAsUnread(String});

Marks all items in specified folders as unread. This functionality is not supported for obsolete classes.

public void MarkAllItemsAsUnread(params string[]);

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.MarkAllItemsAsUnread Method ()

Marks all items in inbox folder as unread.

public void MarkAllItemsAsUnread();

Implements

IEWSClient.MarkAllItemsAsUnread

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.MarkAllItemsAsUnread Overload List


ExchangeWebServiceClient.MarkAllItemsAsUnread Method (String})

Marks all items in specified folders as unread. This functionality is not supported for obsolete classes.

public void MarkAllItemsAsUnread(
IEnumerable<string> folderIds
);

Parameters

folderIds
List of folder uri for processing.

Implements

IEWSClient.MarkAllItemsAsUnread

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.MarkAllItemsAsUnread Overload List


ExchangeWebServiceClient.MarkAllItemsAsUnread Method (String[])

Marks all items in specified folders as unread. This functionality is not supported for obsolete classes.

public void MarkAllItemsAsUnread(
params string[] folderIds
);

Parameters

folderIds
List of folder uri for processing.

Implements

IEWSClient.MarkAllItemsAsUnread

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.MarkAllItemsAsUnread Overload List


MarkAsJunk Method

Aspose.Email

ExchangeWebServiceClient.MarkAsJunk Method

The MarkAsJunk method moves mail messages to the junk mail folder and blocks message sender. This functionality is not supported for obsolete classes.

Overload List

The MarkAsJunk method moves mail messages to the junk mail folder and blocks message sender. This functionality is not supported for obsolete classes.

public virtual string[] MarkAsJunk(bool,bool,String});

public virtual void MarkAsJunk(bool,bool,String},out string[],out string[],out string[]);

The MarkAsJunk method moves mail messages to the junk mail folder and blocks message sender. This functionality is not supported for obsolete classes.

public virtual string[] MarkAsJunk(bool,bool,params string[]);

The MarkAsJunk method moves mail messages to the junk mail folder and blocks message sender. This functionality is not supported for obsolete classes.

public virtual string[] MarkAsJunk(bool,String});

The MarkAsJunk method moves mail messages to the junk mail folder and blocks message sender. This functionality is not supported for obsolete classes.

public virtual string[] MarkAsJunk(bool,params string[]);

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.MarkAsJunk Method (Boolean, Boolean, String})

The MarkAsJunk method moves mail messages to the junk mail folder and blocks message sender. This functionality is not supported for obsolete classes.

public virtual string[] MarkAsJunk(
bool isJunk,
bool moveItem,
IEnumerable<string> messageUriEn
);

Parameters

isJunk
Indicates, whether messages is marked as junk mail. If value of true adds message sender to the block-list. If value of false removes message sender from the block-list.
moveItem
Indicates, whether messages is moved to the junk mail folder.
messageUriEn
Enumeration of message uri

Return Value

Returns the array of message ID which are moved to the junk mail folder.

Implements

IEWSClient.MarkAsJunk

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.MarkAsJunk Overload List


ExchangeWebServiceClient.MarkAsJunk Method (Boolean, Boolean, String}, String[], String[], String[])

public virtual void MarkAsJunk(
bool isJunk,
bool moveItem,
IEnumerable<string> messageUriEn,
out string[] movedMessageIds,
out string[] failedMessageIds,
out string[] errorMessages
);

Implements

IEWSClient.MarkAsJunk

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.MarkAsJunk Overload List


ExchangeWebServiceClient.MarkAsJunk Method (Boolean, Boolean, String[])

The MarkAsJunk method moves mail messages to the junk mail folder and blocks message sender. This functionality is not supported for obsolete classes.

public virtual string[] MarkAsJunk(
bool isJunk,
bool moveItem,
params string[] messageUriEn
);

Parameters

isJunk
Indicates, whether messages is marked as junk mail. If value of true adds message sender to the block-list. If value of false removes message sender from the block-list.
moveItem
Indicates, whether messages is moved to the junk mail folder.
messageUriEn
Array of message uri

Return Value

Returns the array of message ID which are moved to the junk mail folder.

Implements

IEWSClient.MarkAsJunk

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.MarkAsJunk Overload List


ExchangeWebServiceClient.MarkAsJunk Method (Boolean, String})

The MarkAsJunk method moves mail messages to the junk mail folder and blocks message sender. This functionality is not supported for obsolete classes.

public virtual string[] MarkAsJunk(
bool isJunk,
IEnumerable<string> messageUriEn
);

Parameters

isJunk
Indicates, whether messages is marked as junk mail. If value of true adds message sender to the block-list. If value of false removes message sender from the block-list.
messageUriEn
Enumeration of message uri

Return Value

Returns the item ID of the message marked as junk mail.

Implements

IEWSClient.MarkAsJunk

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.MarkAsJunk Overload List


ExchangeWebServiceClient.MarkAsJunk Method (Boolean, String[])

The MarkAsJunk method moves mail messages to the junk mail folder and blocks message sender. This functionality is not supported for obsolete classes.

public virtual string[] MarkAsJunk(
bool isJunk,
params string[] messageUriEn
);

Parameters

isJunk
Indicates, whether messages is marked as junk mail. If value of true adds message sender to the block-list. If value of false removes message sender from the block-list.
messageUriEn
Array of message uri

Return Value

Returns the array of message ID which are moved to the junk mail folder.

Implements

IEWSClient.MarkAsJunk

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.MarkAsJunk Overload List


MoveConversationItems Method

Aspose.Email

ExchangeWebServiceClient.MoveConversationItems Method

Moves the conversation items into the specified target folder

Overload List

Moves the conversation items into the specified target folder

public virtual void MoveConversationItems(string,string);

Moves the conversation items, which are located in the specified folder, into the specified target folder

public virtual void MoveConversationItems(string,string,string);

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.MoveConversationItems Method (String, String)

Moves the conversation items into the specified target folder

public virtual void MoveConversationItems(
string conversationId,
string destinationFolderId
);

Parameters

conversationId
Id of conversation to delete
destinationFolderId
Id of folder into which move items

Implements

IEWSClient.MoveConversationItems

Exceptions

Exception Type | Condition
ArgumentException | conversationId is null or empty
ArgumentException | destinationFolderId is null or empty

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.MoveConversationItems Overload List


ExchangeWebServiceClient.MoveConversationItems Method (String, String, String)

Moves the conversation items, which are located in the specified folder, into the specified target folder

public virtual void MoveConversationItems(
string conversationId,
string contextFolderId,
string destinationFolderId
);

Parameters

conversationId
Id of conversation to move
contextFolderId
Id of folder from which move conversation items. Note: If it's set to null(or empty), all conversation items will be moved
destinationFolderId
Id of folder into which move items

Implements

IEWSClient.MoveConversationItems

Exceptions

Exception Type | Condition
ArgumentException | conversationId is null or empty
ArgumentException | destinationFolderId is null or empty

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.MoveConversationItems Overload List


ExchangeWebServiceClient.MoveItem Method

Moves the item to specified folder

public virtual void MoveItem(
string itemUri,
string destinationFolderUri
);

Parameters

itemUri
The item URI
destinationFolderUri
The destination folder URI

Implements

IEWSClient.MoveItem

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.PlayOnPhone Method

The PlayOnPhone operation initiates an outbound call and plays a message over the telephone. This functionality is not supported for obsolete classes.

public virtual string PlayOnPhone(
string messageId,
string dialString
);

Parameters

messageId
dialString
Specifies telephone to play message.

Return Value

Returns phone call id

Implements

IEWSClient.PlayOnPhone

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.Reply Method

public virtual void Reply(
MailMessage message,
ExchangeMessageInfo referencedMessageInfo
);

Parameters

message
referencedMessageInfo

Implements

IEWSClient.Reply

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.ReplyAll Method

public virtual void ReplyAll(
MailMessage message,
ExchangeMessageInfo referencedMessageInfo
);

Parameters

message
referencedMessageInfo

Implements

IEWSClient.ReplyAll

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.ResetImpersonation Method

Makes the impersonation reset.

public virtual void ResetImpersonation();

Implements

IEWSClient.ResetImpersonation

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.ResolveContact Method

Resolves ambiguous e-mail addresses and display names Note: the maximum count of returned contacts is 100. This is a restriction of used EWS operation.

public override MapiContactCollection ResolveContact(
string unresolvedEntry
);

Parameters

unresolvedEntry
A name of contact to resolve

Return Value

A MapiContactCollection that represents contacts information

Implements

IExchangeClientBase.ResolveContact

Exceptions

Exception Type | Condition
ArgumentException | unresolvedEntry is null or empty

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


Restore Method

Aspose.Email

ExchangeWebServiceClient.Restore Method

Restores the specified exchange folders from the given personal storage.

Overload List

Restores the specified exchange folders from the given personal storage.

public override void Restore(PersonalStorage,ExchangeFolderInfoCollection,RestoreOptions);

Restores exchange folders from the given personal storage.

public override void Restore(PersonalStorage,RestoreOptions);

Restores the specified exchange folders from the given personal storage.

public override void Restore(Stream,ExchangeFolderInfoCollection,RestoreOptions);

Restores exchange folders from the given personal storage.

public override void Restore(Stream,RestoreOptions);

Restores the specified exchange folders from the specified personal storage file.

public override void Restore(string,ExchangeFolderInfoCollection,RestoreOptions);

Restores exchange folders from the specified personal storage file.

public override void Restore(string,RestoreOptions);

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.Restore Method (PersonalStorage, ExchangeFolderInfoCollection, RestoreOptions)

Restores the specified exchange folders from the given personal storage.

public override void Restore(
PersonalStorage pst,
ExchangeFolderInfoCollection folders,
RestoreOptions options
);

Parameters

pst
A personal storage containing the backuped exchange folders.
folders
A folders to be restored.
options
Restore options.

Implements

IExchangeClientBase.Restore

Exceptions

Exception Type | Condition
ArgumentNullException | pst or folders is null.

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.Restore Overload List


ExchangeWebServiceClient.Restore Method (PersonalStorage, RestoreOptions)

Restores exchange folders from the given personal storage.

public override void Restore(
PersonalStorage pst,
RestoreOptions options
);

Parameters

pst
A personal storage containing the backuped imap folders.
options
Restore options.

Implements

IExchangeClientBase.Restore

Exceptions

Exception Type | Condition
ArgumentNullException | pst is null.

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.Restore Overload List


ExchangeWebServiceClient.Restore Method (Stream, ExchangeFolderInfoCollection, RestoreOptions)

Restores the specified exchange folders from the given personal storage.

public override void Restore(
Stream stream,
ExchangeFolderInfoCollection folders,
RestoreOptions options
);

Parameters

stream
A stream containing personal storage.
folders
A folders to be restored.
options
Restore options.

Implements

IExchangeClientBase.Restore

Exceptions

Exception Type | Condition
NotSupportedException | The stream does not support reading.
ArgumentNullException | stream or folders is null.

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.Restore Overload List


ExchangeWebServiceClient.Restore Method (Stream, RestoreOptions)

Restores exchange folders from the given personal storage.

public override void Restore(
Stream stream,
RestoreOptions options
);

Parameters

stream
A stream containing personal storage.
options
Restore options.

Implements

IExchangeClientBase.Restore

Exceptions

Exception Type | Condition
NotSupportedException | The stream does not support reading.
ArgumentNullException | stream is null.

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.Restore Overload List


ExchangeWebServiceClient.Restore Method (String, ExchangeFolderInfoCollection, RestoreOptions)

Restores the specified exchange folders from the specified personal storage file.

public override void Restore(
string fileName,
ExchangeFolderInfoCollection folders,
RestoreOptions options
);

Parameters

fileName
A path to personal storage file.
folders
A folders to be restored.
options
Restore options.

Implements

IExchangeClientBase.Restore

Exceptions

Exception Type | Condition
ArgumentException | fileName is not specified.
ArgumentNullException | folders is null.

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.Restore Overload List


ExchangeWebServiceClient.Restore Method (String, RestoreOptions)

Restores exchange folders from the specified personal storage file.

public override void Restore(
string fileName,
RestoreOptions options
);

Parameters

fileName
A path to personal storage file.
options
Restore options.

Implements

IExchangeClientBase.Restore

Exceptions

Exception Type | Condition
ArgumentException | fileName is not specified.

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.Restore Overload List


SaveMessage Method

Aspose.Email

ExchangeWebServiceClient.SaveMessage Method

Downloads the message with the specified uri and writes its data into a supplied stream

Overload List

Downloads the message with the specified uri and writes its data into a supplied stream

public override void SaveMessage(string,Stream);

Downloads the message with the specified uri and writes its data into a local file

public override void SaveMessage(string,string);

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.SaveMessage Method (String, Stream)

Downloads the message with the specified uri and writes its data into a supplied stream

public override void SaveMessage(
string messageUri,
Stream stream
);

Parameters

messageUri
The URI of message
stream
Stream that will receive the message

Implements

IExchangeClientBase.SaveMessage

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.SaveMessage Overload List


ExchangeWebServiceClient.SaveMessage Method (String, String)

Downloads the message with the specified uri and writes its data into a local file

public override void SaveMessage(
string messageUri,
string path
);

Parameters

messageUri
The URI of message
path
The path of the local file. This cannot be a directory

Implements

IExchangeClientBase.SaveMessage

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.SaveMessage Overload List


Send Method

Aspose.Email

ExchangeWebServiceClient.Send Method

Sends the specified message

Overload List

Sends the specified message

public override void Send(MailMessage);

public virtual void Send(MailMessage,FollowUpOptions);

Sends the specified message

public virtual void Send(string,string,string,string);

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.Send Method (MailMessage)

Sends the specified message

public override void Send(
MailMessage message
);

Parameters

message
MailMessage that represents e-mail message

Implements

IExchangeClientBase.Send

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.Send Overload List


ExchangeWebServiceClient.Send Method (MailMessage, FollowUpOptions)

public virtual void Send(
MailMessage message,
FollowUpOptions messageOptions
);

Implements

IEWSClient.Send

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.Send Overload List


ExchangeWebServiceClient.Send Method (String, String, String, String)

Sends the specified message

public virtual void Send(
string from,
string to,
string subject,
string body
);

Parameters

from
From address
to
To address
subject
The subject of message
body
The body of message

Implements

IEWSClient.Send

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.Send Overload List


SetConversationReadState Method

Aspose.Email

ExchangeWebServiceClient.SetConversationReadState Method

Set read state of the conversation items to the specified value

Overload List

Set read state of the conversation items to the specified value

public virtual void SetConversationReadState(string,bool);

Set read state of the conversation items, which are located in the specified folder, to the specified value

public virtual void SetConversationReadState(string,string,bool);

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.SetConversationReadState Method (String, Boolean)

Set read state of the conversation items to the specified value

public virtual void SetConversationReadState(
string conversationId,
bool isRead
);

Parameters

conversationId
Id of conversation to be changed
isRead
A flag that enables setting the read state of items in a conversation.

Implements

IEWSClient.SetConversationReadState

Exceptions

Exception Type | Condition
ArgumentException | conversationId is null or empty

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.SetConversationReadState Overload List


ExchangeWebServiceClient.SetConversationReadState Method (String, String, Boolean)

Set read state of the conversation items, which are located in the specified folder, to the specified value

public virtual void SetConversationReadState(
string conversationId,
string contextFolderId,
bool isRead
);

Parameters

conversationId
Id of conversation to be changed
contextFolderId
Id of folder in which conversation items are located. Note: If it's set to null(or empty), all conversation items will be copied
isRead
A flag that enables setting the read state of items in a conversation.

Implements

IEWSClient.SetConversationReadState

Exceptions

Exception Type | Condition
ArgumentException | conversationId is null or empty

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.SetConversationReadState Overload List


SetReadFlag Method

Aspose.Email

ExchangeWebServiceClient.SetReadFlag Method

Marks the specifeid message as read.

Overload List

Marks the specifeid message as read.

public override void SetReadFlag(string);

Marks the specifeid message as read.

public virtual void SetReadFlag(string,bool);

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.SetReadFlag Method (String)

Marks the specifeid message as read.

public override void SetReadFlag(
string messageUri
);

Parameters

messageUri
A message uri.

Implements

IExchangeClientBase.SetReadFlag

Exceptions

Exception Type | Condition
ArgumentException | messageUri is null or empty.

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.SetReadFlag Overload List


ExchangeWebServiceClient.SetReadFlag Method (String, Boolean)

Marks the specifeid message as read.

public virtual void SetReadFlag(
string messageUri,
bool isRead
);

Parameters

messageUri
A message uri.
isRead
A value indicating whether the message was read

Implements

IEWSClient.SetReadFlag

Exceptions

Exception Type | Condition
ArgumentException | messageUri is null or empty.

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.SetReadFlag Overload List


ExchangeWebServiceClient.UpdateDelegate Method

Updates the delegate user settings who is granted access on the specified mailbox.

public virtual void UpdateDelegate(
ExchangeDelegateUser delegateUser,
string mailbox
);

Parameters

delegateUser
A new settings of delegate user.
mailbox
A mailbox on which the delegate user is granted access.

Implements

IEWSClient.UpdateDelegate

Exceptions

Exception Type | Condition
ArgumentNullException | delegateUser is null.
ArgumentException | mailbox is null or empty.

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.UpdateDelegates Method

Updates the delegate users settings who are granted access on the specified mailbox.

public virtual void UpdateDelegates(
ExchangeDelegateUserCollection delegateUsers,
string mailbox
);

Parameters

delegateUsers
A ExchangeDelegateUserCollection containing the new settings of delegates.
mailbox
A mailbox on which the delegate users are granted access.

Implements

IEWSClient.UpdateDelegates

Exceptions

Exception Type | Condition
ArgumentNullException | delegateUsers is null.
ArgumentException | mailbox is null or empty.

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


UpdateInboxRule Method

Aspose.Email

ExchangeWebServiceClient.UpdateInboxRule Method

Updates the specified inbox rule

Overload List

Updates the specified inbox rule

public virtual void UpdateInboxRule(InboxRule);

Updates the specified inbox rule

public virtual void UpdateInboxRule(InboxRule,string);

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.UpdateInboxRule Method (InboxRule)

Updates the specified inbox rule

public virtual void UpdateInboxRule(
InboxRule rule
);

Parameters

rule
A inbox rule to update

Implements

IEWSClient.UpdateInboxRule

Exceptions

Exception Type | Condition
ArgumentNullException | throws when rule is null

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.UpdateInboxRule Overload List


ExchangeWebServiceClient.UpdateInboxRule Method (InboxRule, String)

Updates the specified inbox rule

public virtual void UpdateInboxRule(
InboxRule rule,
string mailbox
);

Parameters

rule
A inbox rule to update
mailbox
A mailbox where rule is located. Note: if it is set to null or empty, the rule will be searched in the default mailbox

Implements

IEWSClient.UpdateInboxRule

Exceptions

Exception Type | Condition
ArgumentNullException | throws when rule is null

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.UpdateInboxRule Overload List


ExchangeWebServiceClient.UpdateItems Method

Updates the specified items in to a mailbox

public virtual ExchangeUploadItemResult[] UpdateItems(
ExchangeStreamedItem[] items,
string parentFolderUri
);

Parameters

items
An items to be updated
parentFolderUri
Specifies the folder that contains the items to update

Return Value

An array of ExchangeUploadItemResult

Implements

IEWSClient.UpdateItems

Exceptions

Exception Type | Condition
ArgumentNullException | items is null
ArgumentException | items is empty
ArgumentException | parentFolderUri is null or empty

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


UpdateTask Method

Aspose.Email

ExchangeWebServiceClient.UpdateTask Method

Updates the specified task.

Overload List

Updates the specified task.

public virtual void UpdateTask(ExchangeTask);

Updates the specified task.

public virtual void UpdateTask(ExchangeTask,UpdateTaskOptions);

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


ExchangeWebServiceClient.UpdateTask Method (ExchangeTask)

Updates the specified task.

public virtual void UpdateTask(
ExchangeTask task
);

Parameters

task
An ExchangeTask containing the task information.

Implements

IEWSClient.UpdateTask

Exceptions

Exception Type | Condition
ArgumentException | An UniqueUri property of task is null or empty.
ArgumentNullException | task is null.

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.UpdateTask Overload List


ExchangeWebServiceClient.UpdateTask Method (ExchangeTask, UpdateTaskOptions)

Updates the specified task.

public virtual void UpdateTask(
ExchangeTask task,
UpdateTaskOptions options
);

Parameters

task
An ExchangeTask containing the task information.
options
An updation options.

Implements

IEWSClient.UpdateTask

Exceptions

Exception Type | Condition
ArgumentException | An UniqueUri property of task is null or empty.
ArgumentNullException | task is null.

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace | ExchangeWebServiceClient.UpdateTask Overload List


ExchangeWebServiceClient.UpdateUserConfiguration Method

Updates the specified user configuration

public virtual void UpdateUserConfiguration(
UserConfiguration userConfiguration
);

Parameters

userConfiguration
UserConfiguration to update

Implements

IEWSClient.UpdateUserConfiguration

Exceptions

Exception Type | Condition
ArgumentNullException | throws when userConfiguration is null

See Also

ExchangeWebServiceClient Class | Aspose.Email.Exchange Namespace


FindMessageTrackingReportOptions Class

Represents options for FindMessageTrackingReport operation

For a list of all members of this type, see FindMessageTrackingReportOptions Members.

System.Object
Aspose.Email.Exchange.FindMessageTrackingReportOptions

public sealed class FindMessageTrackingReportOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FindMessageTrackingReportOptions Members | Aspose.Email.Exchange Namespace


FindMessageTrackingReportOptions Members

FindMessageTrackingReportOptions overview

Public Instance Constructors

FindMessageTrackingReportOptions Constructor Initializes a new instance of the FindMessageTrackingReportOptions class

Public Instance Properties

DiagnosticsLevel | Gets or sets diagnostics level specifying how detailed the tracing report should be.
Domain | Gets or sets the domain to search for.
EndDateTime | Gets or sets the search time period, indicating that the message was sent before this value.
FederatedDeliveryMailbox | Gets or sets the mailbox to which a cross-premise message was sent.
MessageId | Gets or sets the message identification to search for.
Recipient | Gets or sets the e-mail addresses of the people who are receiving the message.
Scope | Gets or sets the search scope (non-empty string)
Sender | Gets or sets the e-mail address of the person who is sending the message.
StartDateTime | Gets or sets the search time period, indicating that the message was sent after this value.
Subject | Gets or sets the subject filter to search for.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FindMessageTrackingReportOptions Class | Aspose.Email.Exchange Namespace


FindMessageTrackingReportOptions Constructor

Initializes a new instance of the FindMessageTrackingReportOptions class

public FindMessageTrackingReportOptions(
string scope,
string domain
);

Parameters

scope
Specifies where to perform the search.
domain
Specified the domain to search for.

Exceptions

Exception Type | Condition
ArgumentException | scope is null or empty
ArgumentException | domain is null or empty

See Also

FindMessageTrackingReportOptions Class | Aspose.Email.Exchange Namespace


FindMessageTrackingReportOptions Properties

The properties of the FindMessageTrackingReportOptions class are listed below. For a complete list of FindMessageTrackingReportOptions class members, see the FindMessageTrackingReportOptions Members topic.

Public Instance Properties

DiagnosticsLevel | Gets or sets diagnostics level specifying how detailed the tracing report should be.
Domain | Gets or sets the domain to search for.
EndDateTime | Gets or sets the search time period, indicating that the message was sent before this value.
FederatedDeliveryMailbox | Gets or sets the mailbox to which a cross-premise message was sent.
MessageId | Gets or sets the message identification to search for.
Recipient | Gets or sets the e-mail addresses of the people who are receiving the message.
Scope | Gets or sets the search scope (non-empty string)
Sender | Gets or sets the e-mail address of the person who is sending the message.
StartDateTime | Gets or sets the search time period, indicating that the message was sent after this value.
Subject | Gets or sets the subject filter to search for.

See Also

FindMessageTrackingReportOptions Class | Aspose.Email.Exchange Namespace


DiagnosticsLevel Property

Aspose.Email

FindMessageTrackingReportOptions.DiagnosticsLevel Property

Gets or sets diagnostics level specifying how detailed the tracing report should be.

public string DiagnosticsLevel {get; set;}

See Also

FindMessageTrackingReportOptions Class | Aspose.Email.Exchange Namespace


Domain Property

Aspose.Email

FindMessageTrackingReportOptions.Domain Property

Gets or sets the domain to search for.

public string Domain {get; set;}

Exceptions

Exception Type | Condition
ArgumentException | value is null or empty

See Also

FindMessageTrackingReportOptions Class | Aspose.Email.Exchange Namespace


EndDateTime Property

Aspose.Email

FindMessageTrackingReportOptions.EndDateTime Property

Gets or sets the search time period, indicating that the message was sent before this value.

public DateTime EndDateTime {get; set;}

See Also

FindMessageTrackingReportOptions Class | Aspose.Email.Exchange Namespace


FederatedDeliveryMailbox Property

Aspose.Email

FindMessageTrackingReportOptions.FederatedDeliveryMailbox Property

Gets or sets the mailbox to which a cross-premise message was sent.

public MailAddress FederatedDeliveryMailbox {get; set;}

See Also

FindMessageTrackingReportOptions Class | Aspose.Email.Exchange Namespace


MessageId Property

Aspose.Email

FindMessageTrackingReportOptions.MessageId Property

Gets or sets the message identification to search for.

public string MessageId {get; set;}

See Also

FindMessageTrackingReportOptions Class | Aspose.Email.Exchange Namespace


Recipient Property

Aspose.Email

FindMessageTrackingReportOptions.Recipient Property

Gets or sets the e-mail addresses of the people who are receiving the message.

public MailAddress Recipient {get; set;}

See Also

FindMessageTrackingReportOptions Class | Aspose.Email.Exchange Namespace


Scope Property

Aspose.Email

FindMessageTrackingReportOptions.Scope Property

Gets or sets the search scope (non-empty string)

public string Scope {get; set;}

Exceptions

Exception Type | Condition
ArgumentException | value is null or empty

See Also

FindMessageTrackingReportOptions Class | Aspose.Email.Exchange Namespace


Sender Property

Aspose.Email

FindMessageTrackingReportOptions.Sender Property

Gets or sets the e-mail address of the person who is sending the message.

public MailAddress Sender {get; set;}

See Also

FindMessageTrackingReportOptions Class | Aspose.Email.Exchange Namespace


StartDateTime Property

Aspose.Email

FindMessageTrackingReportOptions.StartDateTime Property

Gets or sets the search time period, indicating that the message was sent after this value.

public DateTime StartDateTime {get; set;}

See Also

FindMessageTrackingReportOptions Class | Aspose.Email.Exchange Namespace


Subject Property

Aspose.Email

FindMessageTrackingReportOptions.Subject Property

Gets or sets the subject filter to search for.

public string Subject {get; set;}

See Also

FindMessageTrackingReportOptions Class | Aspose.Email.Exchange Namespace


FlaggedForAction Enumeration

Enumerates flagged for action

public enum FlaggedForAction

Members

Member Name | Description | Value
Undefined | Flagged for action is not specified | -1
Any | The message is flagged with any action. | 0
Call | The recipient is requested to call the sender. | 1
DoNotForward | The recipient is requested not to forward the message. | 2
FollowUp | The recipient is requested to follow up on the message. | 3
FYI | The recipient received the message for information. | 4
Forward | The recipient is requested to forward the message. | 5
NoResponseNecessary | The recipient is informed that a response to the messageis not required. | 6
Read | The recipient is requested to read the message. | 7
Reply | The recipient is requested to reply to the sender of the message. | 8
ReplyToAll | The recipient is requested to reply to everyone the message was sent to. | 9
Review | The recipient is requested to review the message. | 10

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange Namespace


GetMailTipsOptions Class

Represents options for GetMailTips

For a list of all members of this type, see GetMailTipsOptions Members.

System.Object
Aspose.Email.Exchange.GetMailTipsOptions

public sealed class GetMailTipsOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetMailTipsOptions Members | Aspose.Email.Exchange Namespace


GetMailTipsOptions Members

GetMailTipsOptions overview

Public Instance Constructors

GetMailTipsOptions Constructor Initializes a new instance of the GetMailTipsOptions class

Public Instance Properties

MailTipsRequested | Gets or sets the types of mail tips requested from the service.
Recipients | Gets or sets a list of recipients to check for mail tips.
SendingAs | Gets or sets an e-mail address that a user is trying to send as.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

GetMailTipsOptions Class | Aspose.Email.Exchange Namespace


GetMailTipsOptions Constructor

Initializes a new instance of the GetMailTipsOptions class

public GetMailTipsOptions(
MailAddress sendingAs,
MailAddressCollection recipients,
MailTipsType mailTipsRequested
);

Parameters

sendingAs
Specifies an e-mail address that a user is trying to send as.
recipients
Specifies a list of recipients to check for mail tips.
mailTipsRequested
Specifies the types of mail tips requested from the service.

See Also

GetMailTipsOptions Class | Aspose.Email.Exchange Namespace


GetMailTipsOptions Properties

The properties of the GetMailTipsOptions class are listed below. For a complete list of GetMailTipsOptions class members, see the GetMailTipsOptions Members topic.

Public Instance Properties

MailTipsRequested | Gets or sets the types of mail tips requested from the service.
Recipients | Gets or sets a list of recipients to check for mail tips.
SendingAs | Gets or sets an e-mail address that a user is trying to send as.

See Also

GetMailTipsOptions Class | Aspose.Email.Exchange Namespace


MailTipsRequested Property

Aspose.Email

GetMailTipsOptions.MailTipsRequested Property

Gets or sets the types of mail tips requested from the service.

public MailTipsType MailTipsRequested {get; set;}

See Also

GetMailTipsOptions Class | Aspose.Email.Exchange Namespace


Recipients Property

Aspose.Email

GetMailTipsOptions.Recipients Property

Gets or sets a list of recipients to check for mail tips.

public MailAddressCollection Recipients {get; set;}

Exceptions

Exception Type | Condition
ArgumentNullException | value is null

See Also

GetMailTipsOptions Class | Aspose.Email.Exchange Namespace


SendingAs Property

Aspose.Email

GetMailTipsOptions.SendingAs Property

Gets or sets an e-mail address that a user is trying to send as.

public MailAddress SendingAs {get; set;}

Exceptions

Exception Type | Condition
ArgumentNullException | value is null

See Also

GetMailTipsOptions Class | Aspose.Email.Exchange Namespace


GetMessageTrackingReportOptions Class

Represents options for GetMessageTrackingReport operation

For a list of all members of this type, see GetMessageTrackingReportOptions Members.

System.Object
Aspose.Email.Exchange.GetMessageTrackingReportOptions

public sealed class GetMessageTrackingReportOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetMessageTrackingReportOptions Members | Aspose.Email.Exchange Namespace


GetMessageTrackingReportOptions Members

GetMessageTrackingReportOptions overview

Public Instance Constructors

GetMessageTrackingReportOptions Constructor Initializes a new instance of the GetMessageTrackingReportOptions class

Public Instance Properties

DiagnosticsLevel | Gets or sets a timing and performance information that will be used to derive the report.
MessageTrackingReportId | Gets or sets an identity string that was obtained from the FindMessageTrackingReport operation (non-empty string)
RecipientFilter | Gets or sets a recipient address to use with the specified report.
ReportTemplate | Gets or sets the type of report to get.
ReturnQueueEvents | Gets or sets a value indicating whether the person who is running the task is in a privileged role.
Scope | Gets or sets the search scope (non-empty string)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

GetMessageTrackingReportOptions Class | Aspose.Email.Exchange Namespace


GetMessageTrackingReportOptions Constructor

Initializes a new instance of the GetMessageTrackingReportOptions class

public GetMessageTrackingReportOptions(
string scope,
string messageTrackingReportId
);

Parameters

scope
Specifies where to perform the search
messageTrackingReportId
Specifies an identity string that was obtained from the FindMessageTrackingReport operation

Exceptions

Exception Type | Condition
ArgumentException | scope is null or empty
ArgumentException | messageTrackingReportId is null or empty

See Also

GetMessageTrackingReportOptions Class | Aspose.Email.Exchange Namespace


GetMessageTrackingReportOptions Properties

The properties of the GetMessageTrackingReportOptions class are listed below. For a complete list of GetMessageTrackingReportOptions class members, see the GetMessageTrackingReportOptions Members topic.

Public Instance Properties

DiagnosticsLevel | Gets or sets a timing and performance information that will be used to derive the report.
MessageTrackingReportId | Gets or sets an identity string that was obtained from the FindMessageTrackingReport operation (non-empty string)
RecipientFilter | Gets or sets a recipient address to use with the specified report.
ReportTemplate | Gets or sets the type of report to get.
ReturnQueueEvents | Gets or sets a value indicating whether the person who is running the task is in a privileged role.
Scope | Gets or sets the search scope (non-empty string)

See Also

GetMessageTrackingReportOptions Class | Aspose.Email.Exchange Namespace


DiagnosticsLevel Property

Aspose.Email

GetMessageTrackingReportOptions.DiagnosticsLevel Property

Gets or sets a timing and performance information that will be used to derive the report.

public string DiagnosticsLevel {get; set;}

See Also

GetMessageTrackingReportOptions Class | Aspose.Email.Exchange Namespace


MessageTrackingReportId Property

Aspose.Email

GetMessageTrackingReportOptions.MessageTrackingReportId Property

Gets or sets an identity string that was obtained from the FindMessageTrackingReport operation (non-empty string)

public string MessageTrackingReportId {get; set;}

Exceptions

Exception Type | Condition
ArgumentException | value is null or empty

See Also

GetMessageTrackingReportOptions Class | Aspose.Email.Exchange Namespace


RecipientFilter Property

Aspose.Email

GetMessageTrackingReportOptions.RecipientFilter Property

Gets or sets a recipient address to use with the specified report.

public MailAddress RecipientFilter {get; set;}

See Also

GetMessageTrackingReportOptions Class | Aspose.Email.Exchange Namespace


ReportTemplate Property

Aspose.Email

GetMessageTrackingReportOptions.ReportTemplate Property

Gets or sets the type of report to get.

public MessageTrackingReportTemplate ReportTemplate {get; set;}

See Also

GetMessageTrackingReportOptions Class | Aspose.Email.Exchange Namespace


ReturnQueueEvents Property

Aspose.Email

GetMessageTrackingReportOptions.ReturnQueueEvents Property

Gets or sets a value indicating whether the person who is running the task is in a privileged role.

public bool ReturnQueueEvents {get; set;}

See Also

GetMessageTrackingReportOptions Class | Aspose.Email.Exchange Namespace


Scope Property

Aspose.Email

GetMessageTrackingReportOptions.Scope Property

Gets or sets the search scope (non-empty string)

public string Scope {get; set;}

Exceptions

Exception Type | Condition
ArgumentException | value is null or empty

See Also

GetMessageTrackingReportOptions Class | Aspose.Email.Exchange Namespace


IEWSClient Interface

Represents the interface for Exchange client.

For a list of all members of this type, see IEWSClient Members.

public interface IEWSClient : IExchangeClientBase, IDisposable

Types that implement IEWSClient

Type | Description
ExchangeWebServiceClient | Obsolete. Provides access to MS Exchange Server by using Exchange Web Services (EWS).

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

IEWSClient Members | Aspose.Email.Exchange Namespace


IEWSClient Members

IEWSClient overview

Public Instance Properties

CalendarFolderEventFilter | Specifies event types for Calendar folder
ContactsFolderEventFilter | Specifies event types for Contacts folder
DeletedItemsFolderEventFilter | Specifies event types for DeletedItems folder
DraftsFolderEventFilter | Specifies event types for Drafts folder
InboxFolderEventFilter | Specifies event types for Inbox folder
JournalFolderEventFilter | Specifies event types for Journal folder
NotesFolderEventFilter | Specifies event types for Notes folder
NotificationsCheckInterval | Defines interval for notification check
NotificationTimeout | Defines timeout for server notifications
OutboxFolderEventFilter | Specifies event types for Outbox folder
RootFolderEventFilter | Specifies event types for Root folder
SentItemsFolderEventFilter | Specifies event types for SentItems folder
TasksFolderEventFilter | Specifies event types for Tasks folder

Public Instance Methods

CancelAppointment | Overloaded. Cancels appointment.
CheckUserAvailability | Overloaded. Checks user availability within the specified time window.
CloseAccess | Overloaded. Closes access on the specified mailbox for the specified user.
CopyConversationItems | Overloaded. Copies the conversation items into the specified target folder
CopyItem | Copies the item to specified folder
CreateAppointment | Creates appointment.
CreateFolder | Overloaded. Creates new folder in the root folder.
CreateInboxRule | Overloaded. Creates the specified inbox rule
CreateItems | Creates the specified items in the speciifed folder
CreatePublicFolder | Overloaded. Creates the specified public folder in the root public folder
CreateTask | Creates the given task in the specified folder.
CreateUserConfiguration | Creates the specified user configuration
DelegateAccess | Overloaded. Delegates access on the principal mailbox to the specified user.
DeleteContact | Overloaded. Deletes the contact.
DeleteContacts | Overloaded. Deletes the contacts.
DeleteConversationItems | Overloaded. Deletes the conversation items, which are located in the specified folder
DeleteFolder | Deletes the folder
DeleteFolders | Overloaded. Deletes the specified folders
DeleteInboxRule | Overloaded. Deletes the specified inbox rule
DeleteMessage | Deletes the mail message
DeleteMessages | Overloaded. Deletes the specified mail messages
DeleteTask | Overloaded. Deletes the specified task.
DeleteUserConfiguration | Deletes the specified user configuration
DisconnectPhoneCall | Disconnects a phone call specified by id.
EmptyFolder | Overloaded. Empties the specified folder. Subfolders will not be deleted; deleted items will be moved into DeletedItems folder
ExportItems | Exports the specified items from mailbox
FetchAppointment | Fetch the specified appointment from server.
FetchMapiAttachments | Fetches the attachment
FetchMessage | Fetches the message from server
FetchMessages | Overloaded. Fetches the speciifed messages
FetchTask | Fetches the specified task.
FindConversations | Finds conversations in the specified folder
FindMessages | Gets the collection of messages from specified folder
FindMessageTrackingReport | Finds messages that meet the specified criteria.
Forward | Forward a message.
GetCallInfo | Retrieves phone call information by call id
GetExchangeType | Gets the information about the current version of MS Exchange.
GetFolderInfo | Gets the folder information
GetFolderPermissions | Gets the folder permissions.
GetInboxRules | Overloaded. Gets inbox rules
GetMailTips | Gets mail tips
GetMessageTrackingReport | Gets message tracking report
GetServerTimeZoneIds | Overloaded. The GetServerTimeZoneIds returns information from time zone id that are available on an Exchange server.
GetUMConfiguration | Retrieves unified messaging configuration
GetUserConfiguration | Gets the specified user configuration
ImpersonateUser | Impersonates the user.
ListAppointments | Overloaded. Retrieves list of appointments for default calendar folder
ListContacts | Lists contacts located in the specified folder on server
ListDelegates | Lists the users who are granted access on the specified mailbox.
ListMessages | Overloaded. List the messages in the specified folder
ListMessagesFromPublicFolder | Overloaded. Get collection of messages from public folder
LoadContactPhoto | Loads contact photo binary data
MailDisablePublicFolder | Mail-disable a public folder
MailEnablePublicFolder | Mail-enable a public folder
MarkAllItems | Overloaded. Marks all items in specified folders.
MarkAllItemsAsRead | Overloaded. Marks all items in inbox folder as read without receipts.
MarkAllItemsAsUnread | Overloaded. Marks all items in inbox folder as unread.
MarkAsJunk | Overloaded. The MarkAsJunk method moves mail messages to the junk mail folder and blocks message sender.
MoveConversationItems | Overloaded. Moves the conversation items into the specified target folder
MoveItem | Moves the item to specified folder
PlayOnPhone | The PlayOnPhone operation initiates an outbound call and plays a message over the telephone.
Reply | Reply to the sender's message.
ReplyAll | Reply to the sender and all recipients of a message.
ResetImpersonation | Makes the impersonation reset.
ResetSubscription | Reset all subscriptions
Send | Overloaded. Sends the specified message
SetConversationReadState | Overloaded. Set read state of the conversation items to the specified value
SetReadFlag | Marks the specifeid message as read.
UpdateAppointment | Updates appointment.
UpdateContact | Updates a contact item in the Exchange store.
UpdateDelegate | Updates the delegate user settings who is granted access on the specified mailbox.
UpdateDelegates | Updates the delegate users settings who are granted access on the specified mailbox.
UpdateInboxRule | Overloaded. Updates the specified inbox rule
UpdateItems | Updates the specified items in to a mailbox
UpdateSubscription | Updates subscriptions
UpdateTask | Overloaded. Updates the specified task.
UpdateUserConfiguration | Updates the specified user configuration

Public Instance Events

CalendarFolderServerNotifications | Occurs when arises specified event type for Calendar folder.
ContactsFolderServerNotifications | Occurs when arises specified event type for Contacts folder.
DeletedItemsFolderServerNotifications | Occurs when arises specified event type for DeletedItems folder.
DraftsFolderServerNotifications | Occurs when arises specified event type for Drafts folder.
InboxFolderServerNotifications | Occurs when arises specified event type for Inbox folder.
JournalFolderServerNotifications | Occurs when arises specified event type for Journal folder.
NotesFolderServerNotifications | Occurs when arises specified event type for Notes folder.
OutboxFolderServerNotifications | Occurs when arises specified event type for Outbox folder.
RootFolderServerNotifications | Occurs when arises specified event type for Root folder.
SentItemsFolderServerNotifications | Occurs when arises specified event type for SentItems folder.
TasksFolderServerNotifications | Occurs when arises specified event type for Tasks folder.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient Properties

The properties of the IEWSClient interface are listed below. For a complete list of IEWSClient interface members, see the IEWSClient Members topic.

Public Instance Properties

CalendarFolderEventFilter | Specifies event types for Calendar folder
ContactsFolderEventFilter | Specifies event types for Contacts folder
DeletedItemsFolderEventFilter | Specifies event types for DeletedItems folder
DraftsFolderEventFilter | Specifies event types for Drafts folder
InboxFolderEventFilter | Specifies event types for Inbox folder
JournalFolderEventFilter | Specifies event types for Journal folder
NotesFolderEventFilter | Specifies event types for Notes folder
NotificationsCheckInterval | Defines interval for notification check
NotificationTimeout | Defines timeout for server notifications
OutboxFolderEventFilter | Specifies event types for Outbox folder
RootFolderEventFilter | Specifies event types for Root folder
SentItemsFolderEventFilter | Specifies event types for SentItems folder
TasksFolderEventFilter | Specifies event types for Tasks folder

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


CalendarFolderEventFilter Property

Aspose.Email

IEWSClient.CalendarFolderEventFilter Property

Specifies event types for Calendar folder

EventTypes CalendarFolderEventFilter {get; set;}

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


ContactsFolderEventFilter Property

Aspose.Email

IEWSClient.ContactsFolderEventFilter Property

Specifies event types for Contacts folder

EventTypes ContactsFolderEventFilter {get; set;}

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


DeletedItemsFolderEventFilter Property

Aspose.Email

IEWSClient.DeletedItemsFolderEventFilter Property

Specifies event types for DeletedItems folder

EventTypes DeletedItemsFolderEventFilter {get; set;}

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


DraftsFolderEventFilter Property

Aspose.Email

IEWSClient.DraftsFolderEventFilter Property

Specifies event types for Drafts folder

EventTypes DraftsFolderEventFilter {get; set;}

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


InboxFolderEventFilter Property

Aspose.Email

IEWSClient.InboxFolderEventFilter Property

Specifies event types for Inbox folder

EventTypes InboxFolderEventFilter {get; set;}

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


JournalFolderEventFilter Property

Aspose.Email

IEWSClient.JournalFolderEventFilter Property

Specifies event types for Journal folder

EventTypes JournalFolderEventFilter {get; set;}

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


NotesFolderEventFilter Property

Aspose.Email

IEWSClient.NotesFolderEventFilter Property

Specifies event types for Notes folder

EventTypes NotesFolderEventFilter {get; set;}

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


NotificationsCheckInterval Property

Aspose.Email

IEWSClient.NotificationsCheckInterval Property

Defines interval for notification check

int NotificationsCheckInterval {get; set;}

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


NotificationTimeout Property

Aspose.Email

IEWSClient.NotificationTimeout Property

Defines timeout for server notifications

int NotificationTimeout {get; set;}

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


OutboxFolderEventFilter Property

Aspose.Email

IEWSClient.OutboxFolderEventFilter Property

Specifies event types for Outbox folder

EventTypes OutboxFolderEventFilter {get; set;}

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


RootFolderEventFilter Property

Aspose.Email

IEWSClient.RootFolderEventFilter Property

Specifies event types for Root folder

EventTypes RootFolderEventFilter {get; set;}

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


SentItemsFolderEventFilter Property

Aspose.Email

IEWSClient.SentItemsFolderEventFilter Property

Specifies event types for SentItems folder

EventTypes SentItemsFolderEventFilter {get; set;}

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


TasksFolderEventFilter Property

Aspose.Email

IEWSClient.TasksFolderEventFilter Property

Specifies event types for Tasks folder

EventTypes TasksFolderEventFilter {get; set;}

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient Methods

The methods of the IEWSClient interface are listed below. For a complete list of IEWSClient interface members, see the IEWSClient Members topic.

Public Instance Methods

CancelAppointment | Overloaded. Cancels appointment.
CheckUserAvailability | Overloaded. Checks user availability within the specified time window.
CloseAccess | Overloaded. Closes access on the specified mailbox for the specified user.
CopyConversationItems | Overloaded. Copies the conversation items into the specified target folder
CopyItem | Copies the item to specified folder
CreateAppointment | Creates appointment.
CreateFolder | Overloaded. Creates new folder in the root folder.
CreateInboxRule | Overloaded. Creates the specified inbox rule
CreateItems | Creates the specified items in the speciifed folder
CreatePublicFolder | Overloaded. Creates the specified public folder in the root public folder
CreateTask | Creates the given task in the specified folder.
CreateUserConfiguration | Creates the specified user configuration
DelegateAccess | Overloaded. Delegates access on the principal mailbox to the specified user.
DeleteContact | Overloaded. Deletes the contact.
DeleteContacts | Overloaded. Deletes the contacts.
DeleteConversationItems | Overloaded. Deletes the conversation items, which are located in the specified folder
DeleteFolder | Deletes the folder
DeleteFolders | Overloaded. Deletes the specified folders
DeleteInboxRule | Overloaded. Deletes the specified inbox rule
DeleteMessage | Deletes the mail message
DeleteMessages | Overloaded. Deletes the specified mail messages
DeleteTask | Overloaded. Deletes the specified task.
DeleteUserConfiguration | Deletes the specified user configuration
DisconnectPhoneCall | Disconnects a phone call specified by id.
EmptyFolder | Overloaded. Empties the specified folder. Subfolders will not be deleted; deleted items will be moved into DeletedItems folder
ExportItems | Exports the specified items from mailbox
FetchAppointment | Fetch the specified appointment from server.
FetchMapiAttachments | Fetches the attachment
FetchMessage | Fetches the message from server
FetchMessages | Overloaded. Fetches the speciifed messages
FetchTask | Fetches the specified task.
FindConversations | Finds conversations in the specified folder
FindMessages | Gets the collection of messages from specified folder
FindMessageTrackingReport | Finds messages that meet the specified criteria.
Forward | Forward a message.
GetCallInfo | Retrieves phone call information by call id
GetExchangeType | Gets the information about the current version of MS Exchange.
GetFolderInfo | Gets the folder information
GetFolderPermissions | Gets the folder permissions.
GetInboxRules | Overloaded. Gets inbox rules
GetMailTips | Gets mail tips
GetMessageTrackingReport | Gets message tracking report
GetServerTimeZoneIds | Overloaded. The GetServerTimeZoneIds returns information from time zone id that are available on an Exchange server.
GetUMConfiguration | Retrieves unified messaging configuration
GetUserConfiguration | Gets the specified user configuration
ImpersonateUser | Impersonates the user.
ListAppointments | Overloaded. Retrieves list of appointments for default calendar folder
ListContacts | Lists contacts located in the specified folder on server
ListDelegates | Lists the users who are granted access on the specified mailbox.
ListMessages | Overloaded. List the messages in the specified folder
ListMessagesFromPublicFolder | Overloaded. Get collection of messages from public folder
LoadContactPhoto | Loads contact photo binary data
MailDisablePublicFolder | Mail-disable a public folder
MailEnablePublicFolder | Mail-enable a public folder
MarkAllItems | Overloaded. Marks all items in specified folders.
MarkAllItemsAsRead | Overloaded. Marks all items in inbox folder as read without receipts.
MarkAllItemsAsUnread | Overloaded. Marks all items in inbox folder as unread.
MarkAsJunk | Overloaded. The MarkAsJunk method moves mail messages to the junk mail folder and blocks message sender.
MoveConversationItems | Overloaded. Moves the conversation items into the specified target folder
MoveItem | Moves the item to specified folder
PlayOnPhone | The PlayOnPhone operation initiates an outbound call and plays a message over the telephone.
Reply | Reply to the sender's message.
ReplyAll | Reply to the sender and all recipients of a message.
ResetImpersonation | Makes the impersonation reset.
ResetSubscription | Reset all subscriptions
Send | Overloaded. Sends the specified message
SetConversationReadState | Overloaded. Set read state of the conversation items to the specified value
SetReadFlag | Marks the specifeid message as read.
UpdateAppointment | Updates appointment.
UpdateContact | Updates a contact item in the Exchange store.
UpdateDelegate | Updates the delegate user settings who is granted access on the specified mailbox.
UpdateDelegates | Updates the delegate users settings who are granted access on the specified mailbox.
UpdateInboxRule | Overloaded. Updates the specified inbox rule
UpdateItems | Updates the specified items in to a mailbox
UpdateSubscription | Updates subscriptions
UpdateTask | Overloaded. Updates the specified task.
UpdateUserConfiguration | Updates the specified user configuration

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


CancelAppointment Method

Aspose.Email

IEWSClient.CancelAppointment Method

Cancels appointment.

Overload List

Cancels appointment.

void CancelAppointment(Appointment);

Cancels an exiting meeting on an organizers calendar

void CancelAppointment(string);

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.CancelAppointment Method (Appointment)

Cancels appointment.

void CancelAppointment(
Appointment appointment
);

Parameters

appointment
Calendar appointment.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.CancelAppointment Overload List


IEWSClient.CancelAppointment Method (String)

Cancels an exiting meeting on an organizers calendar

void CancelAppointment(
string uniqueId
);

Parameters

uniqueId
Unique identifier

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.CancelAppointment Overload List


CheckUserAvailability Method

Aspose.Email

IEWSClient.CheckUserAvailability Method

Checks users availability within the specified time window.

Overload List

Checks users availability within the specified time window.

ExchangeUserAvailabilityCollection CheckUserAvailability(StringCollection,DateRange);

Checks user availability within the specified time window.

ExchangeUserAvailability CheckUserAvailability(string,DateRange);

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.CheckUserAvailability Method (StringCollection, DateRange)

Checks users availability within the specified time window.

ExchangeUserAvailabilityCollection CheckUserAvailability(
StringCollection users,
DateRange timeWindow
);

Parameters

users
An users smtp addresses.
timeWindow
A time span for the queried user's availability.

Return Value

ExchangeUserAvailabilityCollection containing the users availability informaiton.

Exceptions

Exception Type | Condition
ArgumentNullException | timeWindow or users is null.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.CheckUserAvailability Overload List


IEWSClient.CheckUserAvailability Method (String, DateRange)

Checks user availability within the specified time window.

ExchangeUserAvailability CheckUserAvailability(
string user,
DateRange timeWindow
);

Parameters

user
An user smtp address.
timeWindow
A time span for the queried user's availability.

Return Value

ExchangeUserAvailability containing user availability information.

Exceptions

Exception Type | Condition
ArgumentException | user is null or empty.
ArgumentNullException | timeWindow is null.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.CheckUserAvailability Overload List


CloseAccess Method

Aspose.Email

IEWSClient.CloseAccess Method

Closes access on the specified mailbox for the specified user.

Overload List

Closes access on the specified mailbox for the specified user.

void CloseAccess(ExchangeDelegateUser,string);

Closes access on the specified mailbox for the specified user.

void CloseAccess(ExchangeDelegateUserCollection,string);

Closes access on the specified mailbox for the specified user.

void CloseAccess(ExchangeFolderUserInfo,string);

Closes access on the specified mailbox for the specified user.

void CloseAccess(string,string);

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.CloseAccess Method (ExchangeDelegateUser, String)

Closes access on the specified mailbox for the specified user.

void CloseAccess(
ExchangeDelegateUser delegateUser,
string mailbox
);

Parameters

delegateUser
A delegate user.
mailbox
A mailbox.

Exceptions

Exception Type | Condition
ArgumentNullException | delegateUser is null.
ArgumentException | mailbox is null or empty.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.CloseAccess Overload List


IEWSClient.CloseAccess Method (ExchangeDelegateUserCollection, String)

Closes access on the specified mailbox for the specified user.

void CloseAccess(
ExchangeDelegateUserCollection delegateUsers,
string mailbox
);

Parameters

delegateUsers
A delegate users.
mailbox
A mailbox.

Exceptions

Exception Type | Condition
ArgumentNullException | delegateUsers is null.
ArgumentException | mailbox is null or empty.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.CloseAccess Overload List


IEWSClient.CloseAccess Method (ExchangeFolderUserInfo, String)

Closes access on the specified mailbox for the specified user.

void CloseAccess(
ExchangeFolderUserInfo userInfo,
string mailbox
);

Parameters

userInfo
A user information.
mailbox
A mailbox.

Exceptions

Exception Type | Condition
ArgumentNullException | userInfo is null.
ArgumentException | mailbox is null or empty.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.CloseAccess Overload List


IEWSClient.CloseAccess Method (String, String)

Closes access on the specified mailbox for the specified user.

void CloseAccess(
string delegateSmtpAddress,
string mailbox
);

Parameters

delegateSmtpAddress
A primary smtp address of delegate user.
mailbox
A mailbox.

Exceptions

Exception Type | Condition
ArgumentException | delegateSmtpAddress or mailbox is null or empty.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.CloseAccess Overload List


CopyConversationItems Method

Aspose.Email

IEWSClient.CopyConversationItems Method

Copies the conversation items into the specified target folder

Overload List

Copies the conversation items into the specified target folder

void CopyConversationItems(string,string);

Copies the conversation items, which are located in the specified folder, into the specified target folder

void CopyConversationItems(string,string,string);

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.CopyConversationItems Method (String, String)

Copies the conversation items into the specified target folder

void CopyConversationItems(
string conversationId,
string destinationFolderId
);

Parameters

conversationId
Id of conversation to copy
destinationFolderId
Id of folder into which copy items

Exceptions

Exception Type | Condition
ArgumentException | conversationId is null or empty
ArgumentException | destinationFolderId is null or empty

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.CopyConversationItems Overload List


IEWSClient.CopyConversationItems Method (String, String, String)

Copies the conversation items, which are located in the specified folder, into the specified target folder

void CopyConversationItems(
string conversationId,
string contextFolderId,
string destinationFolderId
);

Parameters

conversationId
Id of conversation to copy
contextFolderId
Id of folder in which conversation items are located. Note: If it's set to null(or empty), all conversation items will be copied
destinationFolderId
Id of folder into which copy items

Exceptions

Exception Type | Condition
ArgumentException | conversationId is null or empty
ArgumentException | destinationFolderId is null or empty

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.CopyConversationItems Overload List


IEWSClient.CopyItem Method

Copies the item to specified folder

void CopyItem(
string itemUri,
string destinationFolderUri
);

Parameters

itemUri
The item URI
destinationFolderUri
The destination folder URI

Exceptions

Exception Type | Condition
ArgumentException | itemUri is null or empty
ArgumentException | destinationFolderUri is null or empty

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.CreateAppointment Method

Creates appointment.

string CreateAppointment(
Appointment appointment
);

Parameters

appointment
Calendar appointment.

Return Value

Returns appointment UID

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


CreateFolder Method

Aspose.Email

IEWSClient.CreateFolder Method

Creates new folder in the root folder.

Overload List

Creates new folder in the root folder.

void CreateFolder(string);

Creates the new folder

void CreateFolder(string,string,ExchangeFolderPermissionCollection);

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.CreateFolder Method (String)

Creates new folder in the root folder.

void CreateFolder(
string name
);

Parameters

name
The name of new folder

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.CreateFolder Overload List


IEWSClient.CreateFolder Method (String, String, ExchangeFolderPermissionCollection)

Creates the new folder

void CreateFolder(
string parentFolderUri,
string name,
ExchangeFolderPermissionCollection permissions
);

Parameters

parentFolderUri
The URI of parent folder
name
The name of new folder
permissions
A permission on new folder

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.CreateFolder Overload List


CreateInboxRule Method

Aspose.Email

IEWSClient.CreateInboxRule Method

Creates the specified inbox rule

Overload List

Creates the specified inbox rule

void CreateInboxRule(InboxRule);

Creates the specified inbox rule

void CreateInboxRule(InboxRule,string);

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.CreateInboxRule Method (InboxRule)

Creates the specified inbox rule

void CreateInboxRule(
InboxRule rule
);

Parameters

rule
A inbox rule to create

Exceptions

Exception Type | Condition
ArgumentNullException | throws when rule is null

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.CreateInboxRule Overload List


IEWSClient.CreateInboxRule Method (InboxRule, String)

Creates the specified inbox rule

void CreateInboxRule(
InboxRule rule,
string mailbox
);

Parameters

rule
A inbox rule to create
mailbox
A mailbox to create rule for. Note: if it is set to null or empty, the rule will be created in the default mailbox

Exceptions

Exception Type | Condition
ArgumentNullException | throws when rule is null

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.CreateInboxRule Overload List


IEWSClient.CreateItems Method

Creates the specified items in the speciifed folder

ExchangeUploadItemResult[] CreateItems(
ExchangeStreamedItem[] items,
string parentFolderUri
);

Parameters

items
An items to be uploaded
parentFolderUri
Specifies the folder in which to place the items

Return Value

An array of ExchangeUploadItemResult

Exceptions

Exception Type | Condition
ArgumentNullException | items is null
ArgumentException | items is empty
ArgumentException | parentFolderUri is null or empty

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


CreatePublicFolder Method

Aspose.Email

IEWSClient.CreatePublicFolder Method

Creates the specified public folder in the root public folder

Overload List

Creates the specified public folder in the root public folder

void CreatePublicFolder(string,ExchangeFolderPermissionCollection);

Creates the specified public folder in the root public folder

void CreatePublicFolder(string,string,ExchangeFolderPermissionCollection);

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.CreatePublicFolder Method (String, ExchangeFolderPermissionCollection)

Creates the specified public folder in the root public folder

void CreatePublicFolder(
string name,
ExchangeFolderPermissionCollection permissions
);

Parameters

name
A name of new folder
permissions
A permission on new folder

Exceptions

Exception Type | Condition
ArgumentException | A name is empty
ArgumentNullException | A name or permissions is null

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.CreatePublicFolder Overload List


IEWSClient.CreatePublicFolder Method (String, String, ExchangeFolderPermissionCollection)

Creates the specified public folder in the root public folder

void CreatePublicFolder(
string parentFolderUri,
string name,
ExchangeFolderPermissionCollection permissions
);

Parameters

parentFolderUri
The URI of parent folder
name
A name of new folder
permissions
A permission on new folder

Exceptions

Exception Type | Condition
ArgumentException | A name or parentFolderUri is null or empty
ArgumentNullException | A name or permissions or parentFolderUri is null

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.CreatePublicFolder Overload List


IEWSClient.CreateTask Method

Creates the given task in the specified folder.

void CreateTask(
string folder,
ExchangeTask task
);

Parameters

folder
A folder where task should be created.
task
A task to create.

Exceptions

Exception Type | Condition
ArgumentException | folder is null or empty.
ArgumentNullException | task is null.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.CreateUserConfiguration Method

Creates the specified user configuration

void CreateUserConfiguration(
UserConfiguration userConfiguration
);

Parameters

userConfiguration
UserConfiguration to be created

Exceptions

Exception Type | Condition
ArgumentNullException | throws when userConfiguration is null

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


DelegateAccess Method

Aspose.Email

IEWSClient.DelegateAccess Method

Delegates access on the specified mailbox to the specified user.

Overload List

Delegates access on the specified mailbox to the specified user.

void DelegateAccess(ExchangeDelegateUser,string);

Delegates access on the mailbox to the specified users.

void DelegateAccess(ExchangeDelegateUserCollection,string);

Delegates access on the principal mailbox to the specified user.

void DelegateAccess(string,ExchangeDelegateFolderPermissionLevel,string);

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.DelegateAccess Method (ExchangeDelegateUser, String)

Delegates access on the specified mailbox to the specified user.

void DelegateAccess(
ExchangeDelegateUser delegateUser,
string mailbox
);

Parameters

delegateUser
A ExchangeDelegateUser containing user information and delegation settings.
mailbox
A mailbox to grant access on.

Exceptions

Exception Type | Condition
ArgumentNullException | delegateUser is null.
ArgumentException | mailbox is null or empty.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.DelegateAccess Overload List


IEWSClient.DelegateAccess Method (ExchangeDelegateUserCollection, String)

Delegates access on the mailbox to the specified users.

void DelegateAccess(
ExchangeDelegateUserCollection delegateUsers,
string mailbox
);

Parameters

delegateUsers
A ExchangeDelegateUserCollection containing the users information and delegation settings.
mailbox
A mailbox to grant access on.

Exceptions

Exception Type | Condition
ArgumentNullException | delegateUsers is null.
ArgumentException | mailbox is null or empty.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.DelegateAccess Overload List


IEWSClient.DelegateAccess Method (String, ExchangeDelegateFolderPermissionLevel, String)

Delegates access on the principal mailbox to the specified user.

void DelegateAccess(
string delegateSmtpAddress,
ExchangeDelegateFolderPermissionLevel permissionLevel,
string mailbox
);

Parameters

delegateSmtpAddress
A primary smtp address of user.
permissionLevel
A permission level that is granted to the user on all folders.
mailbox
A mailbox to grant access on.

Exceptions

Exception Type | Condition
ArgumentException | delegateSmtpAddress or mailbox is null or empty.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.DelegateAccess Overload List


DeleteContact Method

Aspose.Email

IEWSClient.DeleteContact Method

Deletes the contact.

Overload List

Deletes the contact.

void DeleteContact(MapiContact,bool);

Deletes the contact.

void DeleteContact(string,bool);

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.DeleteContact Method (MapiContact, Boolean)

Deletes the contact.

void DeleteContact(
MapiContact contact,
bool deletePermanently
);

Parameters

contact
Contact for deleting
deletePermanently
Indicates whether the specified contact should be deleted permanently or should be moved into DeletedItems folder

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.DeleteContact Overload List


IEWSClient.DeleteContact Method (String, Boolean)

Deletes the contact.

void DeleteContact(
string id,
bool deletePermanently
);

Parameters

id
The contact identifier.
deletePermanently
Indicates whether the specified contact should be deleted permanently or should be moved into DeletedItems folder

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.DeleteContact Overload List


DeleteContacts Method

Aspose.Email

IEWSClient.DeleteContacts Method

Deletes the contacts.

Overload List

Deletes the contacts.

void DeleteContacts(StringCollection);

Deletes the contacts.

void DeleteContacts(StringCollection,bool);

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.DeleteContacts Method (StringCollection)

Deletes the contacts.

void DeleteContacts(
StringCollection contactIds
);

Parameters

contactIds
The contact identifiers.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.DeleteContacts Overload List


IEWSClient.DeleteContacts Method (StringCollection, Boolean)

Deletes the contacts.

void DeleteContacts(
StringCollection contactIds,
bool deletePermanently
);

Parameters

contactIds
The contact identifiers.
deletePermanently
Indicates whether the specified contact should be deleted permanently or should be moved into DeletedItems folder

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.DeleteContacts Overload List


DeleteConversationItems Method

Aspose.Email

IEWSClient.DeleteConversationItems Method

Deletes all items of the specified conversation

Overload List

Deletes all items of the specified conversation

void DeleteConversationItems(string);

Deletes the conversation items, which are located in the specified folder

void DeleteConversationItems(string,string);

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.DeleteConversationItems Method (String)

Deletes all items of the specified conversation

void DeleteConversationItems(
string conversationId
);

Parameters

conversationId
Id of conversation to delete

Exceptions

Exception Type | Condition
ArgumentException | conversationId is null or empty

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.DeleteConversationItems Overload List


IEWSClient.DeleteConversationItems Method (String, String)

Deletes the conversation items, which are located in the specified folder

void DeleteConversationItems(
string conversationId,
string contextFolderId
);

Parameters

conversationId
Id of conversation to delete
contextFolderId
Id of folder in which delete conversation items. Note: If it's set to null(or empty), all conversation items will be deleted

Exceptions

Exception Type | Condition
ArgumentException | conversationId is null or empty

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.DeleteConversationItems Overload List


IEWSClient.DeleteFolder Method

Deletes the folder

void DeleteFolder(
string folderUri,
bool deletePermanently
);

Parameters

folderUri
The folder Uri
deletePermanently
Indicates whether the folder should be deleted permanently or should be moved into DeletedItems folder

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


DeleteFolders Method

Aspose.Email

IEWSClient.DeleteFolders Method

Deletes the specified folders

Overload List

Deletes the specified folders

void DeleteFolders(ExchangeFolderInfoCollection);

Deletes the specified folders

void DeleteFolders(ExchangeFolderInfoCollection,bool);

Deletes the specified folders

void DeleteFolders(StringCollection);

Deletes the folder

void DeleteFolders(StringCollection,bool);

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.DeleteFolders Method (ExchangeFolderInfoCollection)

Deletes the specified folders

void DeleteFolders(
ExchangeFolderInfoCollection folders
);

Parameters

folders
A ExchangeFolderInfoCollection containing information about folders to delete

Exceptions

Exception Type | Condition
ArgumentNullException | folders is null

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.DeleteFolders Overload List


IEWSClient.DeleteFolders Method (ExchangeFolderInfoCollection, Boolean)

Deletes the specified folders

void DeleteFolders(
ExchangeFolderInfoCollection folders,
bool deletePermanently
);

Parameters

folders
A ExchangeFolderInfoCollection containing information about folders to delete
deletePermanently
Indicates whether the folder should be deleted permanently or should be moved into DeletedItems folder

Exceptions

Exception Type | Condition
ArgumentNullException | folders is null

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.DeleteFolders Overload List


IEWSClient.DeleteFolders Method (StringCollection)

Deletes the specified folders

void DeleteFolders(
StringCollection folderUris
);

Parameters

folderUris
The folder uris

Exceptions

Exception Type | Condition
ArgumentNullException | folderUris is null

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.DeleteFolders Overload List


IEWSClient.DeleteFolders Method (StringCollection, Boolean)

Deletes the folder

void DeleteFolders(
StringCollection folderUris,
bool deletePermanently
);

Parameters

folderUris
The folder Uri
deletePermanently
Indicates whether the folder should be deleted permanently or should be moved into DeletedItems folder

Exceptions

Exception Type | Condition
ArgumentNullException | folderUris is null

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.DeleteFolders Overload List


DeleteInboxRule Method

Aspose.Email

IEWSClient.DeleteInboxRule Method

Deletes the specified inbox rule

Overload List

Deletes the specified inbox rule

void DeleteInboxRule(string);

Deletes the specified inbox rule

void DeleteInboxRule(string,string);

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.DeleteInboxRule Method (String)

Deletes the specified inbox rule

void DeleteInboxRule(
string ruleId
);

Parameters

ruleId
An id of inbox rule to delete

Exceptions

Exception Type | Condition
ArgumentException | throws when ruleId is null or empty

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.DeleteInboxRule Overload List


IEWSClient.DeleteInboxRule Method (String, String)

Deletes the specified inbox rule

void DeleteInboxRule(
string ruleId,
string mailbox
);

Parameters

ruleId
An id of inbox rule to delete
mailbox
A mailbox where rule is located. Note: if it is set to null or empty, the rule will be searched in the default mailbox

Exceptions

Exception Type | Condition
ArgumentException | throws when ruleId is null or empty

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.DeleteInboxRule Overload List


IEWSClient.DeleteMessage Method

Deletes the mail message

void DeleteMessage(
string messageUri,
bool deletePermanently
);

Parameters

messageUri
The message uri
deletePermanently
Indicates whether the specified message should be deleted permanently or should be moved into DeletedItems folder

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


DeleteMessages Method

Aspose.Email

IEWSClient.DeleteMessages Method

Deletes the specified mail messages

Overload List

Deletes the specified mail messages

void DeleteMessages(ExchangeMessageInfoCollection);

Deletes the specified mail messages

void DeleteMessages(ExchangeMessageInfoCollection,bool);

Deletes the specified mail messages

void DeleteMessages(StringCollection);

Deletes the specified mail messages

void DeleteMessages(StringCollection,bool);

Deletes the specified mail messages

void DeleteMessages(StringCollection,bool,CalendarItemCreateOrDeleteOperation);

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.DeleteMessages Method (ExchangeMessageInfoCollection)

Deletes the specified mail messages

void DeleteMessages(
ExchangeMessageInfoCollection messages
);

Parameters

messages
A ExchangeMessageInfoCollection containing message informations

Exceptions

Exception Type | Condition
ArgumentNullException | messages is null

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.DeleteMessages Overload List


IEWSClient.DeleteMessages Method (ExchangeMessageInfoCollection, Boolean)

Deletes the specified mail messages

void DeleteMessages(
ExchangeMessageInfoCollection messages,
bool deletePermanently
);

Parameters

messages
A ExchangeMessageInfoCollection containing message informations
deletePermanently
Indicates whether the specified message should be deleted permanently or should be moved into DeletedItems folder

Exceptions

Exception Type | Condition
ArgumentNullException | messages is null

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.DeleteMessages Overload List


IEWSClient.DeleteMessages Method (StringCollection)

Deletes the specified mail messages

void DeleteMessages(
StringCollection messageUris
);

Parameters

messageUris
The message uris

Exceptions

Exception Type | Condition
ArgumentNullException | messageUris is null

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.DeleteMessages Overload List


IEWSClient.DeleteMessages Method (StringCollection, Boolean)

Deletes the specified mail messages

void DeleteMessages(
StringCollection messageUris,
bool deletePermanently
);

Parameters

messageUris
The message uris
deletePermanently
Indicates whether the specified message should be deleted permanently or should be moved into DeletedItems folder

Exceptions

Exception Type | Condition
ArgumentNullException | messageUris is null

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.DeleteMessages Overload List


IEWSClient.DeleteMessages Method (StringCollection, Boolean, CalendarItemCreateOrDeleteOperation)

Deletes the specified mail messages

void DeleteMessages(
StringCollection messageUris,
bool deletePermanently,
CalendarItemCreateOrDeleteOperation options
);

Parameters

messageUris
The message uris
deletePermanently
Indicates whether the specified message should be deleted permanently or should be moved into DeletedItems folder
options
Describes how meeting requests and cancellations are handled.

Exceptions

Exception Type | Condition
ArgumentNullException | messageUris is null

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.DeleteMessages Overload List


DeleteTask Method

Aspose.Email

IEWSClient.DeleteTask Method

Deletes the specified task.

Overload List

Deletes the specified task.

void DeleteTask(string);

Deletes the specified task.

void DeleteTask(string,DeleteTaskOptions);

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.DeleteTask Method (String)

Deletes the specified task.

void DeleteTask(
string taskUri
);

Parameters

taskUri
Uri of task to be deleted.

Exceptions

Exception Type | Condition
ArgumentException | taskUri is null or empty.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.DeleteTask Overload List


IEWSClient.DeleteTask Method (String, DeleteTaskOptions)

Deletes the specified task.

void DeleteTask(
string taskUri,
DeleteTaskOptions options
);

Parameters

taskUri
Uri of task to be deleted.
options
A deletion options.

Exceptions

Exception Type | Condition
ArgumentException | taskUri is null or empty.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.DeleteTask Overload List


IEWSClient.DeleteUserConfiguration Method

Deletes the specified user configuration

void DeleteUserConfiguration(
UserConfigurationName userConfigurationName
);

Parameters

userConfigurationName
Specifies a user configuration to delete

Exceptions

Exception Type | Condition
ArgumentNullException | throws when userConfigurationName is null

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.DisconnectPhoneCall Method

Disconnects a phone call specified by id.

void DisconnectPhoneCall(
string callId
);

Parameters

callId
Phone call id.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


EmptyFolder Method

Aspose.Email

IEWSClient.EmptyFolder Method

Empties the specified folder. Subfolders will not be deleted; deleted items will be moved into DeletedItems folder

Overload List

Empties the specified folder. Subfolders will not be deleted; deleted items will be moved into DeletedItems folder

void EmptyFolder(string);

Empties the specified folder

void EmptyFolder(string,EmptyFolderOptions);

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.EmptyFolder Method (String)

Empties the specified folder. Subfolders will not be deleted; deleted items will be moved into DeletedItems folder

void EmptyFolder(
string folderUri
);

Parameters

folderUri
Specifies the folder to be empty

Exceptions

Exception Type | Condition
ExchangeException | EmptyFolder operation failed
ArgumentException | folderUri is null or empty

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.EmptyFolder Overload List


IEWSClient.EmptyFolder Method (String, EmptyFolderOptions)

Empties the specified folder

void EmptyFolder(
string folderUri,
EmptyFolderOptions options
);

Parameters

folderUri
Specifies the folder to be empty
options
Specifies the options of clearing folder

Exceptions

Exception Type | Condition
ExchangeException | EmptyFolder operation failed
ArgumentException | folderUri is null or empty

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.EmptyFolder Overload List


IEWSClient.ExportItems Method

Exports the specified items from mailbox

ExchangeStreamedItem[] ExportItems(
string[] itemIds
);

Parameters

itemIds
Ids of itmes to be exported

Return Value

An array of ExchangeStreamedItem

Exceptions

Exception Type | Condition
ArgumentNullException | itemIds is null
ArgumentException | itemIds is empty

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.FetchAppointment Method

Fetch the specified appointment from server.

Appointment FetchAppointment(
string appointmentUri
);

Parameters

appointmentUri
An uri of appointment to be fetched.

Return Value

A fetched Appointment.

Exceptions

Exception Type | Condition
ArgumentException | appointmentUri is null or empty.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.FetchMapiAttachments Method

Fetches the attachment

MapiAttachmentCollection FetchMapiAttachments(
IEnumerable<string> ids
);

Parameters

ids
The attachments uri enumeration. (Attachment uri can be retrieved using ListContacts(string folder, ExchangeListContactsOptions options) method)

Return Value

MapiAttachmentCollection that represents fetched attachments

Exceptions

Exception Type | Condition
ArgumentNullException | ids is null or empty

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.FetchMessage Method

Fetches the message from server

MailMessage FetchMessage(
string messageUri,
string[] extendedProperties
);

Parameters

messageUri
The URI of the message
extendedProperties
An array of extended properties names

Return Value

MailMessage that represents e-mail message, if custom properties have been found and set you can access them using Headers collection.

Exceptions

Exception Type | Condition
ArgumentException | messageUri is null or empty
ExchangeException | Message can not be fetched

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


FetchMessages Method

Aspose.Email

IEWSClient.FetchMessages Method

Fetches the speciifed messages

Overload List

Fetches the speciifed messages

MailMessageCollection FetchMessages(ExchangeMessageInfoCollection);

Fetches the speciifed messages

MailMessageCollection FetchMessages(StringCollection);

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.FetchMessages Method (ExchangeMessageInfoCollection)

Fetches the speciifed messages

MailMessageCollection FetchMessages(
ExchangeMessageInfoCollection messageInfos
);

Parameters

messageInfos
A ExchangeMessageInfoCollection of messages to be retrieved

Return Value

A MailMessageCollection containing fetched messages

Exceptions

Exception Type | Condition
ArgumentNullException | messageInfos is null

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.FetchMessages Overload List


IEWSClient.FetchMessages Method (StringCollection)

Fetches the speciifed messages

MailMessageCollection FetchMessages(
StringCollection messageUris
);

Parameters

messageUris
A StringCollection containing message uris to be retrieved

Return Value

A MailMessageCollection containing fetched messages

Exceptions

Exception Type | Condition
ArgumentNullException | messageUris is null

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.FetchMessages Overload List


IEWSClient.FetchTask Method

Fetches the specified task.

ExchangeTask FetchTask(
string taskUri
);

Parameters

taskUri
A task uri.

Return Value

A fetched ExchangeTask

Exceptions

Exception Type | Condition
ArgumentException | taskUri is null or empty.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.FindConversations Method

Finds conversations in the specified folder

ExchangeConversation[] FindConversations(
string folderId
);

Parameters

folderId
An id of folder in which search

Return Value

An array of found ExchangeConversation

Exceptions

Exception Type | Condition
ArgumentException | folderId is null or empty

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.FindMessages Method

Gets the collection of messages from specified folder

ExchangeMessageInfoCollection FindMessages(
string uri
);

Parameters

uri
The URI of folder

Return Value

ExchangeMessageInfoCollection that contains messages from the specified folder

Remarks

To retrieve messages faster, please, use ListMessages method. But note that ListMessages method doesn't return sender's and recipient's address in ExchangeMessageInfo object.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.FindMessageTrackingReport Method

Finds messages that meet the specified criteria.

MessageTrackingReportInfo[] FindMessageTrackingReport(
FindMessageTrackingReportOptions options
);

Parameters

options
Options specifying a search criteria

Return Value

An array of MessageTrackingReportInfo that represents message tracking report information

Exceptions

Exception Type | Condition
ArgumentNullException | throws when options is null

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.Forward Method

Forward a message.

void Forward(
MailMessage message,
ExchangeMessageInfo referencedMessage
);

Parameters

message
The MailMessage that represents the precomposed forward message.
referencedMessage
The ExchangeMessageInfo that represents the original message.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.GetCallInfo Method

Retrieves phone call information by call id

CallInformation GetCallInfo(
string callId
);

Parameters

callId
call id

Return Value

Returns phone call information object

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.GetExchangeType Method

Gets the information about the current version of MS Exchange.

ExchangeVersion GetExchangeType();

Return Value

Returns Exchange server version

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.GetFolderInfo Method

Gets the folder information

ExchangeFolderInfo GetFolderInfo(
string folder
);

Parameters

folder
A folder uri or distinguished folder name

Return Value

A ExchangeFolderInfo that represents the folder information

Exceptions

Exception Type | Condition
ArgumentException | folder is null or empty
ExchangeException | Server responded an error message

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.GetFolderPermissions Method

Gets the folder permissions.

ExchangePermissionCollection GetFolderPermissions(
string folderUrl
);

Parameters

folderUrl
The folder URL.

Return Value

The ExchangePermissionCollection

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


GetInboxRules Method

Aspose.Email

IEWSClient.GetInboxRules Method

Gets inbox rules

Overload List

Gets inbox rules

InboxRule[] GetInboxRules();

Gets inbox rules

InboxRule[] GetInboxRules(string);

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.GetInboxRules Method ()

Gets inbox rules

InboxRule[] GetInboxRules();

Return Value

An array of InboxRule

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.GetInboxRules Overload List


IEWSClient.GetInboxRules Method (String)

Gets inbox rules

InboxRule[] GetInboxRules(
string mailbox
);

Parameters

mailbox
A mailbox to read inbox rule from. Note: if it is set to null or empty, the rules will be read from the default mailbox

Return Value

An array of InboxRule

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.GetInboxRules Overload List


IEWSClient.GetMailTips Method

Gets mail tips

MailTips[] GetMailTips(
GetMailTipsOptions options
);

Parameters

options
Options specifying a search criteria

Return Value

An array of read MapiContact that represents contact information

Exceptions

Exception Type | Condition
ArgumentNullException | throws when options is null

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.GetMessageTrackingReport Method

Gets message tracking report

MessageTrackingReport GetMessageTrackingReport(
GetMessageTrackingReportOptions options
);

Parameters

options
Options specifying a search criteria

Return Value

A found MessageTrackingReport or null if no message tracking report was found

Exceptions

Exception Type | Condition
ArgumentNullException | throws when options is null

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


GetServerTimeZoneIds Method

Aspose.Email

IEWSClient.GetServerTimeZoneIds Method

The GetServerTimeZoneIds returns information from time zone id that are available on an Exchange server.

Overload List

The GetServerTimeZoneIds returns information from time zone id that are available on an Exchange server.

string[] GetServerTimeZoneIds();

The GetServerTimeZoneIds returns information from time zone id that are available on an Exchange server.

string[] GetServerTimeZoneIds(String});

The GetServerTimeZoneIds returns information from time zone id that are available on an Exchange server.

string[] GetServerTimeZoneIds(params string[]);

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.GetServerTimeZoneIds Method ()

The GetServerTimeZoneIds returns information from time zone id that are available on an Exchange server.

string[] GetServerTimeZoneIds();

Return Value

Returns an array of time zone id that are available on an Exchange server.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.GetServerTimeZoneIds Overload List


IEWSClient.GetServerTimeZoneIds Method (String})

The GetServerTimeZoneIds returns information from time zone id that are available on an Exchange server.

string[] GetServerTimeZoneIds(
IEnumerable<string> timeZoneIds
);

Parameters

timeZoneIds
Identifiers of time zones for checking existence on the server.

Return Value

Returns an array of time zone id that are available on an Exchange server.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.GetServerTimeZoneIds Overload List


IEWSClient.GetServerTimeZoneIds Method (String[])

The GetServerTimeZoneIds returns information from time zone id that are available on an Exchange server.

string[] GetServerTimeZoneIds(
params string[] timeZoneIds
);

Parameters

timeZoneIds
Identifiers of time zones for checking existence on the server.

Return Value

Returns an array of time zone id that are available on an Exchange server.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.GetServerTimeZoneIds Overload List


IEWSClient.GetUMConfiguration Method

Retrieves unified messaging configuration

UnifiedMessagingConfiguration GetUMConfiguration();

Return Value

Returns unified messaging configuration

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.GetUserConfiguration Method

Gets the specified user configuration

UserConfiguration GetUserConfiguration(
UserConfigurationName userConfigurationName
);

Parameters

userConfigurationName
Specifies a user configuration to search

Return Value

A received UserConfiguration

Exceptions

Exception Type | Condition
ArgumentNullException | throws when userConfigurationName is null

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.ImpersonateUser Method

Impersonates the user.

void ImpersonateUser(
ItemChoice valueType,
string value
);

Parameters

valueType
The ItemChoiceType enumeration value to use for impersonation.
value
The item name.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


ListAppointments Method

Aspose.Email

IEWSClient.ListAppointments Method

Retrieves list of appointments for default calendar folder

Overload List

Retrieves list of appointments for default calendar folder

Appointment[] ListAppointments();

Retrieves list of appointments for default calendar folder

Appointment[] ListAppointments(MailQuery);

Retrieves list of appointments for default calendar folder

Appointment[] ListAppointments(MailQuery,bool);

Retrieves list of appointments for default calendar folder

Appointment[] ListAppointments(bool);

Retrieves list of appointments for specified calendar folder

Appointment[] ListAppointments(string);

Retrieves list of appointments for specified calendar folder

Appointment[] ListAppointments(string,MailQuery);

Retrieves list of appointments for specified calendar folder

Appointment[] ListAppointments(string,MailQuery,bool);

Retrieves list of appointments for specified calendar folder

Appointment[] ListAppointments(string,bool);

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.ListAppointments Method ()

Retrieves list of appointments for default calendar folder

Appointment[] ListAppointments();

Return Value

Returns array of appointments

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.ListAppointments Overload List


IEWSClient.ListAppointments Method (MailQuery)

Retrieves list of appointments for default calendar folder

Appointment[] ListAppointments(
MailQuery query
);

Parameters

query
MailQuery that represents appointments search criteria.

Return Value

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.ListAppointments Overload List


IEWSClient.ListAppointments Method (MailQuery, Boolean)

Retrieves list of appointments for default calendar folder

Appointment[] ListAppointments(
MailQuery query,
bool recursive
);

Parameters

query
MailQuery that represents appointments search criteria.
recursive
Indicates whether recursive listing or not.

Return Value

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.ListAppointments Overload List


IEWSClient.ListAppointments Method (Boolean)

Retrieves list of appointments for default calendar folder

Appointment[] ListAppointments(
bool recursive
);

Parameters

recursive
Indicates whether recursive listing or not.

Return Value

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.ListAppointments Overload List


IEWSClient.ListAppointments Method (String)

Retrieves list of appointments for specified calendar folder

Appointment[] ListAppointments(
string folderUri
);

Parameters

folderUri
A folder to search appointments in.

Return Value

Returns array of appointments

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.ListAppointments Overload List


IEWSClient.ListAppointments Method (String, MailQuery)

Retrieves list of appointments for specified calendar folder

Appointment[] ListAppointments(
string folderUri,
MailQuery query
);

Parameters

folderUri
A folder to search appointments in.
query
MailQuery that represents appointments search criteria.

Return Value

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.ListAppointments Overload List


IEWSClient.ListAppointments Method (String, MailQuery, Boolean)

Retrieves list of appointments for specified calendar folder

Appointment[] ListAppointments(
string folderUri,
MailQuery query,
bool recursive
);

Parameters

folderUri
A folder to search appointments in.
query
MailQuery that represents appointments search criteria.
recursive
Indicates whether recursive listing or not.

Return Value

Returns array of appointments

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.ListAppointments Overload List


IEWSClient.ListAppointments Method (String, Boolean)

Retrieves list of appointments for specified calendar folder

Appointment[] ListAppointments(
string folderUri,
bool recursive
);

Parameters

folderUri
A folder to search appointments in.
recursive
Indicates whether recursive listing or not.

Return Value

Returns array of appointments

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.ListAppointments Overload List


IEWSClient.ListContacts Method

Lists contacts located in the specified folder on server

MapiContact[] ListContacts(
string folder,
ExchangeListContactsOptions options
);

Parameters

folder
A folder to search contacts in
options
Enumerates the list contacts options

Return Value

An array of read MapiContact that represents contact information

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.ListDelegates Method

Lists the users who are granted access on the specified mailbox.

ExchangeDelegateUserCollection ListDelegates(
string mailbox
);

Parameters

mailbox
A mailbox.

Return Value

A ExchangeDelegateUserCollection representing the delegate users.

Exceptions

Exception Type | Condition
ArgumentException | mailbox is null or empty.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


ListMessages Method

Aspose.Email

IEWSClient.ListMessages Method

List the messages in the specified folder.

Overload List

List the messages in the specified folder.

ExchangeMessageInfoCollection ListMessages(string,MailQuery);

List the messages in the specified folder.

ExchangeMessageInfoCollection ListMessages(string,MailQuery,bool);

List the messages in the specified folder

ExchangeMessageInfoCollection ListMessages(string,bool);

List the messages in the specified folder.

ExchangeMessageInfoCollection ListMessages(string,int,MailQuery);

List the messages in the specified folder.

ExchangeMessageInfoCollection ListMessages(string,int,MailQuery,bool);

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.ListMessages Method (String, MailQuery)

List the messages in the specified folder.

ExchangeMessageInfoCollection ListMessages(
string folder,
MailQuery query
);

Parameters

folder
A folder to search messages in.
query
MailQuery that represents message search criteria.

Return Value

ExchangeMessageInfoCollection that contains messages from the specified folder.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.ListMessages Overload List


IEWSClient.ListMessages Method (String, MailQuery, Boolean)

List the messages in the specified folder.

ExchangeMessageInfoCollection ListMessages(
string folder,
MailQuery query,
bool recursive
);

Parameters

folder
A folder to search messages in.
query
MailQuery that represents message search criteria.
recursive
Indicates whether recursive listing or not.

Return Value

ExchangeMessageInfoCollection that contains messages from the specified folder.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.ListMessages Overload List


IEWSClient.ListMessages Method (String, Boolean)

List the messages in the specified folder

ExchangeMessageInfoCollection ListMessages(
string folder,
bool recursive
);

Parameters

folder
A folder to search messages in
recursive
Indicates whether recursive listing or not

Return Value

ExchangeMessageInfoCollection that contains messages from the specified folder

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.ListMessages Overload List


IEWSClient.ListMessages Method (String, Int32, MailQuery)

List the messages in the specified folder.

ExchangeMessageInfoCollection ListMessages(
string folder,
int maxNumberOfMessages,
MailQuery query
);

Parameters

folder
A folder to search messages in.
maxNumberOfMessages
Maximum number of messages.
query
MailQuery that represents message search criteria.

Return Value

ExchangeMessageInfoCollection that contains messages from the specified folder.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.ListMessages Overload List


IEWSClient.ListMessages Method (String, Int32, MailQuery, Boolean)

List the messages in the specified folder.

ExchangeMessageInfoCollection ListMessages(
string folder,
int maxNumberOfMessages,
MailQuery query,
bool recursive
);

Parameters

folder
A folder to search messages in.
maxNumberOfMessages
Maximum number of messages.
query
MailQuery that represents message search criteria.
recursive
Indicates whether recursive listing or not.

Return Value

ExchangeMessageInfoCollection that contains messages from the specified folder.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.ListMessages Overload List


ListMessagesFromPublicFolder Method

Aspose.Email

IEWSClient.ListMessagesFromPublicFolder Method

Get collection of messages from public folder

Overload List

Get collection of messages from public folder

ExchangeMessageInfoCollection ListMessagesFromPublicFolder(ExchangeFolderInfo);

Get collection of messages from public folder

ExchangeMessageInfoCollection ListMessagesFromPublicFolder(string);

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.ListMessagesFromPublicFolder Method (ExchangeFolderInfo)

Get collection of messages from public folder

ExchangeMessageInfoCollection ListMessagesFromPublicFolder(
ExchangeFolderInfo folder
);

Parameters

folder
ExchangeFolderInfo that represents information about folder

Return Value

ExchangeMessageInfoCollection that contains messages from the specified folder

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.ListMessagesFromPublicFolder Overload List


IEWSClient.ListMessagesFromPublicFolder Method (String)

Get collection of messages from public folder

ExchangeMessageInfoCollection ListMessagesFromPublicFolder(
string folderUri
);

Parameters

folderUri
The uri of folder

Return Value

ExchangeMessageInfoCollection that contains messages from the specified folder

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.ListMessagesFromPublicFolder Overload List


IEWSClient.LoadContactPhoto Method

Loads contact photo binary data

void LoadContactPhoto(
MapiContactPhoto photo
);

Parameters

photo
contact photo

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.MailDisablePublicFolder Method

Mail-disable a public folder

void MailDisablePublicFolder(
string folderUri
);

Parameters

folderUri
A folder uri

Exceptions

Exception Type | Condition
ArgumentException | folderUri is null or empty

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.MailEnablePublicFolder Method

Mail-enable a public folder

void MailEnablePublicFolder(
string folderUri
);

Parameters

folderUri
A folder uri

Exceptions

Exception Type | Condition
ArgumentException | folderUri is null or empty

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


MarkAllItems Method

Aspose.Email

IEWSClient.MarkAllItems Method

Marks all items in specified folders.

Overload List

Marks all items in specified folders.

void MarkAllItems(bool,bool,String});

Marks all items in specified folders.

void MarkAllItems(bool,bool,params string[]);

Marks all items in specified folders.

void MarkAllItems(bool,params string[]);

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.MarkAllItems Method (Boolean, Boolean, String})

Marks all items in specified folders.

void MarkAllItems(
bool read,
bool suppressReadReceipts,
IEnumerable<string> folderIds
);

Parameters

read
Sets the read/unread state to messages in specified folder. True to mark messages in the folder as read. False to mark messages as unread.
suppressReadReceipts
True to suppress sending read receipts for messages; otherwise, false.
folderIds
List of folder uri for processing.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.MarkAllItems Overload List


IEWSClient.MarkAllItems Method (Boolean, Boolean, String[])

Marks all items in specified folders.

void MarkAllItems(
bool read,
bool suppressReadReceipts,
params string[] folderIds
);

Parameters

read
Sets the read/unread state to messages in specified folder. True to mark messages in the folder as read. False to mark messages as unread.
suppressReadReceipts
True to suppress sending read receipts for messages; otherwise, false.
folderIds
List of folder uri for processing.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.MarkAllItems Overload List


IEWSClient.MarkAllItems Method (Boolean, String[])

Marks all items in specified folders.

void MarkAllItems(
bool read,
params string[] folderIds
);

Parameters

read
Sets the read/unread state to messages in specified folder. True to mark messages in the folder as read. False to mark messages as unread.
folderIds
List of folder uri for processing.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.MarkAllItems Overload List


MarkAllItemsAsRead Method

Aspose.Email

IEWSClient.MarkAllItemsAsRead Method

Marks all items in inbox folder as read without receipts.

Overload List

Marks all items in inbox folder as read without receipts.

void MarkAllItemsAsRead();

Marks all items in specified folders as read without receipts.

void MarkAllItemsAsRead(String});

Marks all items in specified folders as read without receipts.

void MarkAllItemsAsRead(params string[]);

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.MarkAllItemsAsRead Method ()

Marks all items in inbox folder as read without receipts.

void MarkAllItemsAsRead();

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.MarkAllItemsAsRead Overload List


IEWSClient.MarkAllItemsAsRead Method (String})

Marks all items in specified folders as read without receipts.

void MarkAllItemsAsRead(
IEnumerable<string> folderIds
);

Parameters

folderIds
List of folder uri for processing.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.MarkAllItemsAsRead Overload List


IEWSClient.MarkAllItemsAsRead Method (String[])

Marks all items in specified folders as read without receipts.

void MarkAllItemsAsRead(
params string[] folderIds
);

Parameters

folderIds
List of folder uri for processing.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.MarkAllItemsAsRead Overload List


MarkAllItemsAsUnread Method

Aspose.Email

IEWSClient.MarkAllItemsAsUnread Method

Marks all items in inbox folder as unread.

Overload List

Marks all items in inbox folder as unread.

void MarkAllItemsAsUnread();

Marks all items in specified folders as unread.

void MarkAllItemsAsUnread(String});

Marks all items in specified folders as unread.

void MarkAllItemsAsUnread(params string[]);

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.MarkAllItemsAsUnread Method ()

Marks all items in inbox folder as unread.

void MarkAllItemsAsUnread();

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.MarkAllItemsAsUnread Overload List


IEWSClient.MarkAllItemsAsUnread Method (String})

Marks all items in specified folders as unread.

void MarkAllItemsAsUnread(
IEnumerable<string> folderIds
);

Parameters

folderIds
List of folder uri for processing.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.MarkAllItemsAsUnread Overload List


IEWSClient.MarkAllItemsAsUnread Method (String[])

Marks all items in specified folders as unread.

void MarkAllItemsAsUnread(
params string[] folderIds
);

Parameters

folderIds
List of folder uri for processing.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.MarkAllItemsAsUnread Overload List


MarkAsJunk Method

Aspose.Email

IEWSClient.MarkAsJunk Method

The MarkAsJunk method moves mail messages to the junk mail folder and blocks message sender.

Overload List

The MarkAsJunk method moves mail messages to the junk mail folder and blocks message sender.

string[] MarkAsJunk(bool,bool,String});

void MarkAsJunk(bool,bool,String},out string[],out string[],out string[]);

The MarkAsJunk method moves mail messages to the junk mail folder and blocks message sender.

string[] MarkAsJunk(bool,bool,params string[]);

The MarkAsJunk method moves mail messages to the junk mail folder and blocks message sender.

string[] MarkAsJunk(bool,String});

The MarkAsJunk method moves mail messages to the junk mail folder and blocks message sender.

string[] MarkAsJunk(bool,params string[]);

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.MarkAsJunk Method (Boolean, Boolean, String})

The MarkAsJunk method moves mail messages to the junk mail folder and blocks message sender.

string[] MarkAsJunk(
bool isJunk,
bool moveItem,
IEnumerable<string> messageUriEn
);

Parameters

isJunk
Indicates, whether messages is marked as junk mail. If value of true adds message sender to the block-list. If value of false removes message sender from the block-list.
moveItem
Indicates, whether messages is moved to the junk mail folder.
messageUriEn
Enumeration of message uri

Return Value

Returns the array of message ID which are moved to the junk mail folder.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.MarkAsJunk Overload List


IEWSClient.MarkAsJunk Method (Boolean, Boolean, String}, String[], String[], String[])

void MarkAsJunk(
bool isJunk,
bool moveItem,
IEnumerable<string> messageUriEn,
out string[] movedMessageIds,
out string[] failedMessageIds,
out string[] errorMessages
);

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.MarkAsJunk Overload List


IEWSClient.MarkAsJunk Method (Boolean, Boolean, String[])

The MarkAsJunk method moves mail messages to the junk mail folder and blocks message sender.

string[] MarkAsJunk(
bool isJunk,
bool moveItem,
params string[] messageUriEn
);

Parameters

isJunk
Indicates, whether messages is marked as junk mail. If value of true adds message sender to the block-list. If value of false removes message sender from the block-list.
moveItem
Indicates, whether messages is moved to the junk mail folder.
messageUriEn
Array of message uri

Return Value

Returns the array of message ID which are moved to the junk mail folder.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.MarkAsJunk Overload List


IEWSClient.MarkAsJunk Method (Boolean, String})

The MarkAsJunk method moves mail messages to the junk mail folder and blocks message sender.

string[] MarkAsJunk(
bool isJunk,
IEnumerable<string> messageUriEn
);

Parameters

isJunk
Indicates, whether messages is marked as junk mail. If value of true adds message sender to the block-list. If value of false removes message sender from the block-list.
messageUriEn
Enumeration of message uri

Return Value

Returns the item ID of the message marked as junk mail.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.MarkAsJunk Overload List


IEWSClient.MarkAsJunk Method (Boolean, String[])

The MarkAsJunk method moves mail messages to the junk mail folder and blocks message sender.

string[] MarkAsJunk(
bool isJunk,
params string[] messageUriEn
);

Parameters

isJunk
Indicates, whether messages is marked as junk mail. If value of true adds message sender to the block-list. If value of false removes message sender from the block-list.
messageUriEn
Array of message uri

Return Value

Returns the array of message ID which are moved to the junk mail folder.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.MarkAsJunk Overload List


MoveConversationItems Method

Aspose.Email

IEWSClient.MoveConversationItems Method

Moves the conversation items into the specified target folder

Overload List

Moves the conversation items into the specified target folder

void MoveConversationItems(string,string);

Moves the conversation items, which are located in the specified folder, into the specified target folder

void MoveConversationItems(string,string,string);

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.MoveConversationItems Method (String, String)

Moves the conversation items into the specified target folder

void MoveConversationItems(
string conversationId,
string destinationFolderId
);

Parameters

conversationId
Id of conversation to delete
destinationFolderId
Id of folder into which move items

Exceptions

Exception Type | Condition
ArgumentException | conversationId is null or empty
ArgumentException | destinationFolderId is null or empty

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.MoveConversationItems Overload List


IEWSClient.MoveConversationItems Method (String, String, String)

Moves the conversation items, which are located in the specified folder, into the specified target folder

void MoveConversationItems(
string conversationId,
string contextFolderId,
string destinationFolderId
);

Parameters

conversationId
Id of conversation to move
contextFolderId
Id of folder from which move conversation items. Note: If it's set to null(or empty), all conversation items will be moved
destinationFolderId
Id of folder into which move items

Exceptions

Exception Type | Condition
ArgumentException | conversationId is null or empty
ArgumentException | destinationFolderId is null or empty

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.MoveConversationItems Overload List


IEWSClient.MoveItem Method

Moves the item to specified folder

void MoveItem(
string itemUri,
string destinationFolderUri
);

Parameters

itemUri
The item URI
destinationFolderUri
The destination folder URI

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.PlayOnPhone Method

The PlayOnPhone operation initiates an outbound call and plays a message over the telephone.

string PlayOnPhone(
string messageId,
string dialString
);

Parameters

messageId
dialString
Specifies telephone to play message.

Return Value

Returns phone call id

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.Reply Method

Reply to the sender's message.

void Reply(
MailMessage message,
ExchangeMessageInfo referencedMessage
);

Parameters

message
The MailMessage that represents the precomposed reply message.
referencedMessage
The ExchangeMessageInfo that represents the original message.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.ReplyAll Method

Reply to the sender and all recipients of a message.

void ReplyAll(
MailMessage message,
ExchangeMessageInfo referencedMessage
);

Parameters

message
The MailMessage that represents the precomposed reply message.
referencedMessage
The ExchangeMessageInfo that represents the original message.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.ResetImpersonation Method

Makes the impersonation reset.

void ResetImpersonation();

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.ResetSubscription Method

Reset all subscriptions

void ResetSubscription();

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


Send Method

Aspose.Email

IEWSClient.Send Method

Sends the message.

Overload List

Sends the message.

void Send(MailMessage,FollowUpOptions);

Sends the specified message

void Send(string,string,string,string);

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.Send Method (MailMessage, FollowUpOptions)

Sends the message.

void Send(
MailMessage message,
FollowUpOptions messageOptions
);

Parameters

message
The MailMessage to be sent.
messageOptions
The FollowUpOptions that represents additional options for using follow-up flags and voting buttons.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.Send Overload List


IEWSClient.Send Method (String, String, String, String)

Sends the specified message

void Send(
string from,
string to,
string subject,
string body
);

Parameters

from
From address
to
To address
subject
The subject of message
body
The body of message

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.Send Overload List


SetConversationReadState Method

Aspose.Email

IEWSClient.SetConversationReadState Method

Set read state of the conversation items to the specified value

Overload List

Set read state of the conversation items to the specified value

void SetConversationReadState(string,bool);

Set read state of the conversation items, which are located in the specified folder, to the specified value

void SetConversationReadState(string,string,bool);

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.SetConversationReadState Method (String, Boolean)

Set read state of the conversation items to the specified value

void SetConversationReadState(
string conversationId,
bool isRead
);

Parameters

conversationId
Id of conversation to be changed
isRead
A flag that enables setting the read state of items in a conversation.

Exceptions

Exception Type | Condition
ArgumentException | conversationId is null or empty

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.SetConversationReadState Overload List


IEWSClient.SetConversationReadState Method (String, String, Boolean)

Set read state of the conversation items, which are located in the specified folder, to the specified value

void SetConversationReadState(
string conversationId,
string contextFolderId,
bool isRead
);

Parameters

conversationId
Id of conversation to be changed
contextFolderId
Id of folder in which conversation items are located. Note: If it's set to null(or empty), all conversation items will be copied
isRead
A flag that enables setting the read state of items in a conversation.

Exceptions

Exception Type | Condition
ArgumentException | conversationId is null or empty

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.SetConversationReadState Overload List


IEWSClient.SetReadFlag Method

Marks the specifeid message as read.

void SetReadFlag(
string messageUri,
bool isRead
);

Parameters

messageUri
A message uri.
isRead
A value indicating whether the message was read

Exceptions

Exception Type | Condition
ArgumentException | messageUri is null or empty.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.UpdateAppointment Method

Updates appointment.

void UpdateAppointment(
Appointment appointment
);

Parameters

appointment
Calendar appointment.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.UpdateContact Method

Updates a contact item in the Exchange store.

void UpdateContact(
MapiContact contact
);

Parameters

contact
Contact item

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.UpdateDelegate Method

Updates the delegate user settings who is granted access on the specified mailbox.

void UpdateDelegate(
ExchangeDelegateUser delegateUser,
string mailbox
);

Parameters

delegateUser
A new settings of delegate user.
mailbox
A mailbox on which the delegate user is granted access.

Exceptions

Exception Type | Condition
ArgumentNullException | delegateUser is null.
ArgumentException | mailbox is null or empty.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.UpdateDelegates Method

Updates the delegate users settings who are granted access on the specified mailbox.

void UpdateDelegates(
ExchangeDelegateUserCollection delegateUsers,
string mailbox
);

Parameters

delegateUsers
A ExchangeDelegateUserCollection containing the new settings of delegates.
mailbox
A mailbox on which the delegate users are granted access.

Exceptions

Exception Type | Condition
ArgumentNullException | delegateUsers is null.
ArgumentException | mailbox is null or empty.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


UpdateInboxRule Method

Aspose.Email

IEWSClient.UpdateInboxRule Method

Updates the specified inbox rule

Overload List

Updates the specified inbox rule

void UpdateInboxRule(InboxRule);

Updates the specified inbox rule

void UpdateInboxRule(InboxRule,string);

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.UpdateInboxRule Method (InboxRule)

Updates the specified inbox rule

void UpdateInboxRule(
InboxRule rule
);

Parameters

rule
A inbox rule to update

Exceptions

Exception Type | Condition
ArgumentNullException | throws when rule is null

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.UpdateInboxRule Overload List


IEWSClient.UpdateInboxRule Method (InboxRule, String)

Updates the specified inbox rule

void UpdateInboxRule(
InboxRule rule,
string mailbox
);

Parameters

rule
A inbox rule to update
mailbox
A mailbox where rule is located. Note: if it is set to null or empty, the rule will be searched in the default mailbox

Exceptions

Exception Type | Condition
ArgumentNullException | throws when rule is null

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.UpdateInboxRule Overload List


IEWSClient.UpdateItems Method

Updates the specified items in to a mailbox

ExchangeUploadItemResult[] UpdateItems(
ExchangeStreamedItem[] items,
string parentFolderUri
);

Parameters

items
An items to be updated
parentFolderUri
Specifies the folder that contains the items to update

Return Value

An array of ExchangeUploadItemResult

Exceptions

Exception Type | Condition
ArgumentNullException | items is null
ArgumentException | items is empty
ArgumentException | parentFolderUri is null or empty

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.UpdateSubscription Method

Updates subscriptions

void UpdateSubscription();

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


UpdateTask Method

Aspose.Email

IEWSClient.UpdateTask Method

Updates the specified task.

Overload List

Updates the specified task.

void UpdateTask(ExchangeTask);

Updates the specified task.

void UpdateTask(ExchangeTask,UpdateTaskOptions);

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.UpdateTask Method (ExchangeTask)

Updates the specified task.

void UpdateTask(
ExchangeTask task
);

Parameters

task
An ExchangeTask containing the task information.

Exceptions

Exception Type | Condition
ArgumentException | An UniqueUri property of task is null or empty.
ArgumentNullException | task is null.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.UpdateTask Overload List


IEWSClient.UpdateTask Method (ExchangeTask, UpdateTaskOptions)

Updates the specified task.

void UpdateTask(
ExchangeTask task,
UpdateTaskOptions options
);

Parameters

task
An ExchangeTask containing the task information.
options
An updation options.

Exceptions

Exception Type | Condition
ArgumentException | An UniqueUri property of task is null or empty.
ArgumentNullException | task is null.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace | IEWSClient.UpdateTask Overload List


IEWSClient.UpdateUserConfiguration Method

Updates the specified user configuration

void UpdateUserConfiguration(
UserConfiguration userConfiguration
);

Parameters

userConfiguration
UserConfiguration to update

Exceptions

Exception Type | Condition
ArgumentNullException | throws when userConfiguration is null

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient Events

The events of the IEWSClient interface are listed below. For a complete list of IEWSClient interface members, see the IEWSClient Members topic.

Public Instance Events

CalendarFolderServerNotifications | Occurs when arises specified event type for Calendar folder.
ContactsFolderServerNotifications | Occurs when arises specified event type for Contacts folder.
DeletedItemsFolderServerNotifications | Occurs when arises specified event type for DeletedItems folder.
DraftsFolderServerNotifications | Occurs when arises specified event type for Drafts folder.
InboxFolderServerNotifications | Occurs when arises specified event type for Inbox folder.
JournalFolderServerNotifications | Occurs when arises specified event type for Journal folder.
NotesFolderServerNotifications | Occurs when arises specified event type for Notes folder.
OutboxFolderServerNotifications | Occurs when arises specified event type for Outbox folder.
RootFolderServerNotifications | Occurs when arises specified event type for Root folder.
SentItemsFolderServerNotifications | Occurs when arises specified event type for SentItems folder.
TasksFolderServerNotifications | Occurs when arises specified event type for Tasks folder.

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.CalendarFolderServerNotifications Event

Occurs when arises specified event type for Calendar folder.

event ServerNotificationEventArgs} CalendarFolderServerNotifications;

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.ContactsFolderServerNotifications Event

Occurs when arises specified event type for Contacts folder.

event ServerNotificationEventArgs} ContactsFolderServerNotifications;

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.DeletedItemsFolderServerNotifications Event

Occurs when arises specified event type for DeletedItems folder.

event ServerNotificationEventArgs} DeletedItemsFolderServerNotifications;

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.DraftsFolderServerNotifications Event

Occurs when arises specified event type for Drafts folder.

event ServerNotificationEventArgs} DraftsFolderServerNotifications;

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.InboxFolderServerNotifications Event

Occurs when arises specified event type for Inbox folder.

event ServerNotificationEventArgs} InboxFolderServerNotifications;

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.JournalFolderServerNotifications Event

Occurs when arises specified event type for Journal folder.

event ServerNotificationEventArgs} JournalFolderServerNotifications;

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.NotesFolderServerNotifications Event

Occurs when arises specified event type for Notes folder.

event ServerNotificationEventArgs} NotesFolderServerNotifications;

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.OutboxFolderServerNotifications Event

Occurs when arises specified event type for Outbox folder.

event ServerNotificationEventArgs} OutboxFolderServerNotifications;

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.RootFolderServerNotifications Event

Occurs when arises specified event type for Root folder.

event ServerNotificationEventArgs} RootFolderServerNotifications;

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.SentItemsFolderServerNotifications Event

Occurs when arises specified event type for SentItems folder.

event ServerNotificationEventArgs} SentItemsFolderServerNotifications;

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IEWSClient.TasksFolderServerNotifications Event

Occurs when arises specified event type for Tasks folder.

event ServerNotificationEventArgs} TasksFolderServerNotifications;

See Also

IEWSClient Interface | Aspose.Email.Exchange Namespace


IExchangeClientBase Interface

Represents the interface for base Exchange clients.

For a list of all members of this type, see IExchangeClientBase Members.

Aspose.Email.Exchange.IExchangeClientBase
Aspose.Email.Exchange.IEWSClient

public interface IExchangeClientBase : IDisposable

Types that implement IExchangeClientBase

Type | Description
EWSClient | Provides access to MS Exchange Server by using Exchange Web Services (EWS).
ExchangeClient | The ExchangeClient class allows applications to manage E-Mail box in Microsoft Exchange Server by using WebDav Exchange Store Protocol.
ExchangeClientBase | Provides the abstract base class to MS Exchange Server access.
ExchangeWebServiceClient | Obsolete. Provides access to MS Exchange Server by using Exchange Web Services (EWS).

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

IExchangeClientBase Members | Aspose.Email.Exchange Namespace


IExchangeClientBase Members

IExchangeClientBase overview

Public Instance Properties

Credentials | Gets or sets the credentials.
MailboxInfo | Gets the mailbox info.
MailboxUri | Gets or sets the mailbox uri.
Proxy | Gets or sets the proxy.
Timeout | Gets or sets the number of milliseconds to wait before the operation times out. The default value is 100,000 milliseconds (100 seconds).

Public Instance Methods

AppendMessage | Overloaded. Uploads the mail message to the specified folder
Backup | Overloaded. Backups the content of the specified folders
CreateContact | Creates a contact item in the Exchange store.
CreateFolder | Creates the new folder with the specified name in the specified parent folder.
DeleteContact | Overloaded. Deletes the contact.
DeleteFolder | Deletes the folder
DeleteMessage | Deletes the mail message.
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
FetchAttachment | Fetches the attachment
FetchMessage | Fetches the message.
FolderExists | Overloaded.
GetMailboxInfo | Overloaded. Gets the mailbox info.
GetMailboxSize | Overloaded. Gets the size of the mailbox.
GetVersionInfo | Returns exchange server version info
ListContacts | Lists contacts located in the specified folder on server
ListMailboxes | Lists mailboxes.
ListMessages | Overloaded. Lists the messages.
ListPublicFolders | Gets collection of public folders from root public folder
ListSubFolders | Overloaded. Gets collection of child folders from parent
ResolveContact | Resolves ambiguous mailbox names.
Restore | Overloaded. Restores exchange folders from the specified personal storage file.
SaveMessage | Overloaded. Saves the message.
Send | Sends the specified message.
SetReadFlag | Sets the read flag.

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace


IExchangeClientBase Properties

The properties of the IExchangeClientBase interface are listed below. For a complete list of IExchangeClientBase interface members, see the IExchangeClientBase Members topic.

Public Instance Properties

Credentials | Gets or sets the credentials.
MailboxInfo | Gets the mailbox info.
MailboxUri | Gets or sets the mailbox uri.
Proxy | Gets or sets the proxy.
Timeout | Gets or sets the number of milliseconds to wait before the operation times out. The default value is 100,000 milliseconds (100 seconds).

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace


Credentials Property

Aspose.Email

IExchangeClientBase.Credentials Property

Gets or sets the credentials.

ICredentials Credentials {get; set;}

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace


MailboxInfo Property

Aspose.Email

IExchangeClientBase.MailboxInfo Property

Gets the mailbox info.

ExchangeMailboxInfo MailboxInfo {get;}

Property Value

The mailbox info.

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace


MailboxUri Property

Aspose.Email

IExchangeClientBase.MailboxUri Property

Gets or sets the mailbox uri.

string MailboxUri {get; set;}

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace


Proxy Property

Aspose.Email

IExchangeClientBase.Proxy Property

Gets or sets the proxy.

WebProxy Proxy {get; set;}

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace


Timeout Property

Aspose.Email

IExchangeClientBase.Timeout Property

Gets or sets the number of milliseconds to wait before the operation times out. The default value is 100,000 milliseconds (100 seconds).

int Timeout {get; set;}

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace


IExchangeClientBase Methods

The methods of the IExchangeClientBase interface are listed below. For a complete list of IExchangeClientBase interface members, see the IExchangeClientBase Members topic.

Public Instance Methods

AppendMessage | Overloaded. Uploads the mail message to the specified folder
Backup | Overloaded. Backups the content of the specified folders
CreateContact | Creates a contact item in the Exchange store.
CreateFolder | Creates the new folder with the specified name in the specified parent folder.
DeleteContact | Overloaded. Deletes the contact.
DeleteFolder | Deletes the folder
DeleteMessage | Deletes the mail message.
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
FetchAttachment | Fetches the attachment
FetchMessage | Fetches the message.
FolderExists | Overloaded.
GetMailboxInfo | Overloaded. Gets the mailbox info.
GetMailboxSize | Overloaded. Gets the size of the mailbox.
GetVersionInfo | Returns exchange server version info
ListContacts | Lists contacts located in the specified folder on server
ListMailboxes | Lists mailboxes.
ListMessages | Overloaded. Lists the messages.
ListPublicFolders | Gets collection of public folders from root public folder
ListSubFolders | Overloaded. Gets collection of child folders from parent
ResolveContact | Resolves ambiguous mailbox names.
Restore | Overloaded. Restores exchange folders from the specified personal storage file.
SaveMessage | Overloaded. Saves the message.
Send | Sends the specified message.
SetReadFlag | Sets the read flag.

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace


AppendMessage Method

Aspose.Email

IExchangeClientBase.AppendMessage Method

Uploads the mail message to the specified folder

Overload List

Uploads the mail message to the specified folder

string AppendMessage(string,MailMessage);

Uploads the mail message to the specified folder

string AppendMessage(string,MailMessage,bool);

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace


IExchangeClientBase.AppendMessage Method (String, MailMessage)

Uploads the mail message to the specified folder

string AppendMessage(
string folder,
MailMessage message
);

Parameters

folder
A folder to which message is uploaded
message
A message to upload

Return Value

An uri of created message

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace | IExchangeClientBase.AppendMessage Overload List


IExchangeClientBase.AppendMessage Method (String, MailMessage, Boolean)

Uploads the mail message to the specified folder

string AppendMessage(
string folder,
MailMessage message,
bool markAsSent
);

Parameters

folder
An uri of folder to which message is uploaded
message
A message to upload
markAsSent
A value indicating whether the message should be appended as a sent message or a draft.

Return Value

An uri of created message

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace | IExchangeClientBase.AppendMessage Overload List


Backup Method

Aspose.Email

IExchangeClientBase.Backup Method

Backups the content of the specified folders

Overload List

Backups the content of the specified folders

void Backup(ExchangeFolderInfoCollection,Stream,BackupOptions);

Backups the content of the specified folders

void Backup(ExchangeFolderInfoCollection,string,BackupOptions);

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace


IExchangeClientBase.Backup Method (ExchangeFolderInfoCollection, Stream, BackupOptions)

Backups the content of the specified folders

void Backup(
ExchangeFolderInfoCollection folders,
Stream stream,
BackupOptions options
);

Parameters

folders
A folders to backup
stream
A stream to write into
options
A backup options

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace | IExchangeClientBase.Backup Overload List


IExchangeClientBase.Backup Method (ExchangeFolderInfoCollection, String, BackupOptions)

Backups the content of the specified folders

void Backup(
ExchangeFolderInfoCollection folders,
string fileName,
BackupOptions options
);

Parameters

folders
A folders to backup
fileName
A path to the presonal storage file
options
A backup options

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace | IExchangeClientBase.Backup Overload List


IExchangeClientBase.CreateContact Method

Creates a contact item in the Exchange store.

string CreateContact(
MapiContact contact
);

Parameters

contact
Contact item

Return Value

The contact Uri

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace


IExchangeClientBase.CreateFolder Method

Creates the new folder with the specified name in the specified parent folder.

void CreateFolder(
string parentFolderUri,
string name
);

Parameters

parentFolderUri
An uri of parent folder.
name
A name of folder to be created.

Exceptions

Exception Type | Condition
ArgumentException | parentFolderUri or name is null or empty.

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace


DeleteContact Method

Aspose.Email

IExchangeClientBase.DeleteContact Method

Deletes the contact.

Overload List

Deletes the contact.

void DeleteContact(MapiContact);

Deletes the contact.

void DeleteContact(string);

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace


IExchangeClientBase.DeleteContact Method (MapiContact)

Deletes the contact.

void DeleteContact(
MapiContact contact
);

Parameters

contact
Contact for deleting

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace | IExchangeClientBase.DeleteContact Overload List


IExchangeClientBase.DeleteContact Method (String)

Deletes the contact.

void DeleteContact(
string id
);

Parameters

id
The contact identifier.

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace | IExchangeClientBase.DeleteContact Overload List


IExchangeClientBase.DeleteFolder Method

Deletes the folder

void DeleteFolder(
string folderUri
);

Parameters

folderUri
The folder Uri

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace


IExchangeClientBase.DeleteMessage Method

Deletes the mail message.

void DeleteMessage(
string messageUri
);

Parameters

messageUri
The message uri.

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace


IExchangeClientBase.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

void Dispose();

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace


IExchangeClientBase.FetchAttachment Method

Fetches the attachment

Attachment FetchAttachment(
string attachmentUri
);

Parameters

attachmentUri
The attachment uri

Return Value

Attachment that represents fetched attachment

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace


IExchangeClientBase.FetchMessage Method

Fetches the message.

MailMessage FetchMessage(
string messageUri
);

Parameters

messageUri
The message URI.

Return Value

Returns a message

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace


FolderExists Method

Aspose.Email

IExchangeClientBase.FolderExists Method

Checks whether the specified folder exists.

Overload List

Checks whether the specified folder exists.

bool FolderExists(string,string);

bool FolderExists(string,string,out ExchangeFolderInfo);

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace


IExchangeClientBase.FolderExists Method (String, String)

Checks whether the specified folder exists.

bool FolderExists(
string parentFolderUri,
string folderName
);

Parameters

parentFolderUri
An uri of parent folder.
folderName
A folder name.

Return Value

true if the specified folder exists in the specified parent folder; otherwise, false.

Exceptions

Exception Type | Condition
ArgumentException | parentFolderUri or folderName is null or empty

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace | IExchangeClientBase.FolderExists Overload List


IExchangeClientBase.FolderExists Method (String, String, ExchangeFolderInfo)

bool FolderExists(
string parentFolderUri,
string folderName,
out ExchangeFolderInfo folder
);

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace | IExchangeClientBase.FolderExists Overload List


GetMailboxInfo Method

Aspose.Email

IExchangeClientBase.GetMailboxInfo Method

Gets the mailbox info.

Overload List

Gets the mailbox info.

ExchangeMailboxInfo GetMailboxInfo();

Gets the mailbox information

ExchangeMailboxInfo GetMailboxInfo(string);

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace


IExchangeClientBase.GetMailboxInfo Method ()

Gets the mailbox info.

ExchangeMailboxInfo GetMailboxInfo();

Return Value

ExchangeMailboxInfo that represents mailbox information

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace | IExchangeClientBase.GetMailboxInfo Overload List


IExchangeClientBase.GetMailboxInfo Method (String)

Gets the mailbox information

ExchangeMailboxInfo GetMailboxInfo(
string mailbox
);

Parameters

mailbox
A mailbox to read from.

Return Value

ExchangeMailboxInfo that represents mailbox information

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace | IExchangeClientBase.GetMailboxInfo Overload List


GetMailboxSize Method

Aspose.Email

IExchangeClientBase.GetMailboxSize Method

Gets the size of the mailbox.

Overload List

Gets the size of the mailbox.

long GetMailboxSize();

Gets the size of the mailbox

long GetMailboxSize(string);

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace


IExchangeClientBase.GetMailboxSize Method ()

Gets the size of the mailbox.

long GetMailboxSize();

Return Value

size of the mailbox in bytes

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace | IExchangeClientBase.GetMailboxSize Overload List


IExchangeClientBase.GetMailboxSize Method (String)

Gets the size of the mailbox

long GetMailboxSize(
string mailbox
);

Parameters

mailbox
A mailbox.

Return Value

size of the mailbox in bytes

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace | IExchangeClientBase.GetMailboxSize Overload List


IExchangeClientBase.GetVersionInfo Method

Returns exchange server version info

string GetVersionInfo();

Return Value

Returns exchange server version info

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace


IExchangeClientBase.ListContacts Method

Lists contacts located in the specified folder on server

MapiContact[] ListContacts(
string folderUri
);

Parameters

folderUri
The URI of folder

Return Value

An array of read MapiContact that represents contact information

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace


IExchangeClientBase.ListMailboxes Method

Lists mailboxes.

MapiContactCollection ListMailboxes();

Return Value

A MapiContactCollection that represents contact information.

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace


ListMessages Method

Aspose.Email

IExchangeClientBase.ListMessages Method

Lists the messages.

Overload List

Lists the messages.

ExchangeMessageInfoCollection ListMessages(string);

Lists the messages.

ExchangeMessageInfoCollection ListMessages(string,ExchangeListMessagesOptions);

Lists the messages.

ExchangeMessageInfoCollection ListMessages(string,int);

Lists the messages.

ExchangeMessageInfoCollection ListMessages(string,int,ExchangeListMessagesOptions);

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace


IExchangeClientBase.ListMessages Method (String)

Lists the messages.

ExchangeMessageInfoCollection ListMessages(
string folder
);

Parameters

folder
The folder.

Return Value

A ExchangeMessageInfoCollection

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace | IExchangeClientBase.ListMessages Overload List


IExchangeClientBase.ListMessages Method (String, ExchangeListMessagesOptions)

Lists the messages.

ExchangeMessageInfoCollection ListMessages(
string folder,
ExchangeListMessagesOptions options
);

Parameters

folder
The folder.
options
Specifies the settings of listing

Return Value

A ExchangeMessageInfoCollection

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace | IExchangeClientBase.ListMessages Overload List


IExchangeClientBase.ListMessages Method (String, Int32)

Lists the messages.

ExchangeMessageInfoCollection ListMessages(
string folder,
int maxNumberOfMessages
);

Parameters

folder
The folder.
maxNumberOfMessages
Maximum number of messages

Return Value

A ExchangeMessageInfoCollection

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace | IExchangeClientBase.ListMessages Overload List


IExchangeClientBase.ListMessages Method (String, Int32, ExchangeListMessagesOptions)

Lists the messages.

ExchangeMessageInfoCollection ListMessages(
string folder,
int maxNumberOfMessages,
ExchangeListMessagesOptions options
);

Parameters

folder
The folder.
maxNumberOfMessages
Maximum number of messages
options
Specifies the settings of listing

Return Value

A ExchangeMessageInfoCollection

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace | IExchangeClientBase.ListMessages Overload List


IExchangeClientBase.ListPublicFolders Method

Gets collection of public folders from root public folder

ExchangeFolderInfoCollection ListPublicFolders();

Return Value

ExchangeFolderInfoCollection that contains subfolders from the root public folder

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace


ListSubFolders Method

Aspose.Email

IExchangeClientBase.ListSubFolders Method

Gets collection of child public folders from parent

Overload List

Gets collection of child public folders from parent

ExchangeFolderInfoCollection ListSubFolders(ExchangeFolderInfo);

Gets collection of child folders from parent

ExchangeFolderInfoCollection ListSubFolders(string);

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace


IExchangeClientBase.ListSubFolders Method (ExchangeFolderInfo)

Gets collection of child public folders from parent

ExchangeFolderInfoCollection ListSubFolders(
ExchangeFolderInfo parentFolder
);

Parameters

parentFolder
The parent ExchangeFolderInfo

Return Value

ExchangeFolderInfoCollection that contains subfolders from the parent folder

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace | IExchangeClientBase.ListSubFolders Overload List


IExchangeClientBase.ListSubFolders Method (String)

Gets collection of child folders from parent

ExchangeFolderInfoCollection ListSubFolders(
string parentFolderUri
);

Parameters

parentFolderUri
The uri of the parent folder

Return Value

ExchangeFolderInfoCollection that contains subfolders from the parent folder

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace | IExchangeClientBase.ListSubFolders Overload List


IExchangeClientBase.ResolveContact Method

Resolves ambiguous mailbox names.

MapiContactCollection ResolveContact(
string unresolvedEntry
);

Parameters

unresolvedEntry
A name of contact to resolve.

Return Value

A MapiContactCollection that represents contacts information.

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace


Restore Method

Aspose.Email

IExchangeClientBase.Restore Method

Restores the specified exchange folders from the given personal storage.

Overload List

Restores the specified exchange folders from the given personal storage.

void Restore(PersonalStorage,ExchangeFolderInfoCollection,RestoreOptions);

Restores exchange folders from the given personal storage.

void Restore(PersonalStorage,RestoreOptions);

Restores the specified exchange folders from the given personal storage.

void Restore(Stream,ExchangeFolderInfoCollection,RestoreOptions);

Restores exchange folders from the given personal storage.

void Restore(Stream,RestoreOptions);

Restores the specified exchange folders from the specified personal storage file.

void Restore(string,ExchangeFolderInfoCollection,RestoreOptions);

Restores exchange folders from the specified personal storage file.

void Restore(string,RestoreOptions);

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace


IExchangeClientBase.Restore Method (PersonalStorage, ExchangeFolderInfoCollection, RestoreOptions)

Restores the specified exchange folders from the given personal storage.

void Restore(
PersonalStorage pst,
ExchangeFolderInfoCollection folders,
RestoreOptions options
);

Parameters

pst
A personal storage containing the backuped exchange folders.
folders
A folders to be restored.
options
Restore options.

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace | IExchangeClientBase.Restore Overload List


IExchangeClientBase.Restore Method (PersonalStorage, RestoreOptions)

Restores exchange folders from the given personal storage.

void Restore(
PersonalStorage pst,
RestoreOptions options
);

Parameters

pst
A personal storage containing the backuped imap folders.
options
Restore options.

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace | IExchangeClientBase.Restore Overload List


IExchangeClientBase.Restore Method (Stream, ExchangeFolderInfoCollection, RestoreOptions)

Restores the specified exchange folders from the given personal storage.

void Restore(
Stream stream,
ExchangeFolderInfoCollection folders,
RestoreOptions options
);

Parameters

stream
A stream containing personal storage.
folders
A folders to be restored.
options
Restore options.

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace | IExchangeClientBase.Restore Overload List


IExchangeClientBase.Restore Method (Stream, RestoreOptions)

Restores exchange folders from the given personal storage.

void Restore(
Stream stream,
RestoreOptions options
);

Parameters

stream
A stream containing personal storage.
options
Restore options.

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace | IExchangeClientBase.Restore Overload List


IExchangeClientBase.Restore Method (String, ExchangeFolderInfoCollection, RestoreOptions)

Restores the specified exchange folders from the specified personal storage file.

void Restore(
string fileName,
ExchangeFolderInfoCollection folders,
RestoreOptions options
);

Parameters

fileName
A path to personal storage file.
folders
A folders to be restored.
options
Restore options.

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace | IExchangeClientBase.Restore Overload List


IExchangeClientBase.Restore Method (String, RestoreOptions)

Restores exchange folders from the specified personal storage file.

void Restore(
string fileName,
RestoreOptions options
);

Parameters

fileName
A path to personal storage file.
options
Restore options.

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace | IExchangeClientBase.Restore Overload List


SaveMessage Method

Aspose.Email

IExchangeClientBase.SaveMessage Method

Saves the message.

Overload List

Saves the message.

void SaveMessage(string,Stream);

Saves the message.

void SaveMessage(string,string);

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace


IExchangeClientBase.SaveMessage Method (String, Stream)

Saves the message.

void SaveMessage(
string messageUri,
Stream stream
);

Parameters

messageUri
The message URI.
stream
The stream.

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace | IExchangeClientBase.SaveMessage Overload List


IExchangeClientBase.SaveMessage Method (String, String)

Saves the message.

void SaveMessage(
string messageUri,
string path
);

Parameters

messageUri
The message URI.
path
The path to save message.

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace | IExchangeClientBase.SaveMessage Overload List


IExchangeClientBase.Send Method

Sends the specified message.

void Send(
MailMessage message
);

Parameters

message
The message.

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace


IExchangeClientBase.SetReadFlag Method

Sets the read flag.

void SetReadFlag(
string messageUri
);

Parameters

messageUri
The message URI.

See Also

IExchangeClientBase Interface | Aspose.Email.Exchange Namespace


ImportanceChoices Enumeration

Enumerates the levels of importance for an item

public enum ImportanceChoices

Members

Member Name | Description | Value
Undefined | The importance is not specified | -1
Low | Specifies low importance. | 0
Normal | Specifies normal importance. | 1
High | Specifies high importance. | 2

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange Namespace


InboxRule Class

Represents a inbox rule

For a list of all members of this type, see InboxRule Members.

System.Object
Aspose.Email.Exchange.InboxRule

public sealed class InboxRule

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

InboxRule Members | Aspose.Email.Exchange Namespace


InboxRule Members

InboxRule overview

Public Static Methods

CreateRuleDeleteContaining | Creates inbox rule that deletes messages containing the specified strings in either the body or the subject
CreateRuleDeleteFrom | Creates inbox rule that deletes messages from specified senders
CreateRuleMoveContaining | Creates inbox rule that moves messages containing the specified strings in either the body or the subject into the specified folder
CreateRuleMoveFrom | Creates inbox rule that moves messages from specified senders into the specified folder

Public Instance Constructors

InboxRule Constructor Initializes a new instance of the InboxRule class

Public Instance Properties

Actions | Gets or sets the actions to be taken on a message when the conditions are fulfilled.
Conditions | Gets or sets the conditions that, when fulfilled, will trigger the rule actions for that rule.
DisplayName | Gets or sets the display name of a rule.
Exceptions | Gets or sets the exceptions that represent all the available rule exception conditions for the inbox rule.
IsEnabled | Gets or sets a value indicating whether the rule is enabled.
IsInError | Gets a value indicating whether the rule is in an error condition.
IsNotSupported | Gets a value indicating whether the rule cannot be modified with the managed code APIs.
Priority | Gets or sets a value that indicates the order in which a rule is to be run.
RuleId | Gets or sets the rule identifier.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

InboxRule Class | Aspose.Email.Exchange Namespace


InboxRule Constructor

Initializes a new instance of the InboxRule class

public InboxRule();

See Also

InboxRule Class | Aspose.Email.Exchange Namespace


InboxRule Properties

The properties of the InboxRule class are listed below. For a complete list of InboxRule class members, see the InboxRule Members topic.

Public Instance Properties

Actions | Gets or sets the actions to be taken on a message when the conditions are fulfilled.
Conditions | Gets or sets the conditions that, when fulfilled, will trigger the rule actions for that rule.
DisplayName | Gets or sets the display name of a rule.
Exceptions | Gets or sets the exceptions that represent all the available rule exception conditions for the inbox rule.
IsEnabled | Gets or sets a value indicating whether the rule is enabled.
IsInError | Gets a value indicating whether the rule is in an error condition.
IsNotSupported | Gets a value indicating whether the rule cannot be modified with the managed code APIs.
Priority | Gets or sets a value that indicates the order in which a rule is to be run.
RuleId | Gets or sets the rule identifier.

See Also

InboxRule Class | Aspose.Email.Exchange Namespace


Actions Property

Aspose.Email

InboxRule.Actions Property

Gets or sets the actions to be taken on a message when the conditions are fulfilled.

public RuleActions Actions {get; set;}

See Also

InboxRule Class | Aspose.Email.Exchange Namespace


Conditions Property

Aspose.Email

InboxRule.Conditions Property

Gets or sets the conditions that, when fulfilled, will trigger the rule actions for that rule.

public RulePredicates Conditions {get; set;}

See Also

InboxRule Class | Aspose.Email.Exchange Namespace


DisplayName Property

Aspose.Email

InboxRule.DisplayName Property

Gets or sets the display name of a rule.

public string DisplayName {get; set;}

See Also

InboxRule Class | Aspose.Email.Exchange Namespace


Exceptions Property

Aspose.Email

InboxRule.Exceptions Property

Gets or sets the exceptions that represent all the available rule exception conditions for the inbox rule.

public RulePredicates Exceptions {get; set;}

See Also

InboxRule Class | Aspose.Email.Exchange Namespace


IsEnabled Property

Aspose.Email

InboxRule.IsEnabled Property

Gets or sets a value indicating whether the rule is enabled.

public bool IsEnabled {get; set;}

See Also

InboxRule Class | Aspose.Email.Exchange Namespace


IsInError Property

Aspose.Email

InboxRule.IsInError Property

Gets a value indicating whether the rule is in an error condition.

public bool IsInError {get; set;}

See Also

InboxRule Class | Aspose.Email.Exchange Namespace


IsNotSupported Property

Aspose.Email

InboxRule.IsNotSupported Property

Gets a value indicating whether the rule cannot be modified with the managed code APIs.

public bool IsNotSupported {get; set;}

See Also

InboxRule Class | Aspose.Email.Exchange Namespace


Priority Property

Aspose.Email

InboxRule.Priority Property

Gets or sets a value that indicates the order in which a rule is to be run.

public int Priority {get; set;}

See Also

InboxRule Class | Aspose.Email.Exchange Namespace


RuleId Property

Aspose.Email

InboxRule.RuleId Property

Gets or sets the rule identifier.

public string RuleId {get; set;}

See Also

InboxRule Class | Aspose.Email.Exchange Namespace


InboxRule Methods

The methods of the InboxRule class are listed below. For a complete list of InboxRule class members, see the InboxRule Members topic.

Public Static Methods

CreateRuleDeleteContaining | Creates inbox rule that deletes messages containing the specified strings in either the body or the subject
CreateRuleDeleteFrom | Creates inbox rule that deletes messages from specified senders
CreateRuleMoveContaining | Creates inbox rule that moves messages containing the specified strings in either the body or the subject into the specified folder
CreateRuleMoveFrom | Creates inbox rule that moves messages from specified senders into the specified folder

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

InboxRule Class | Aspose.Email.Exchange Namespace


InboxRule.CreateRuleDeleteContaining Method

Creates inbox rule that deletes messages containing the specified strings in either the body or the subject

public static InboxRule CreateRuleDeleteContaining(
string[] filter
);

Parameters

filter
A strings to search

Return Value

A created InboxRule

Exceptions

Exception Type | Condition
ArgumentException | filter is null or empty

See Also

InboxRule Class | Aspose.Email.Exchange Namespace


InboxRule.CreateRuleDeleteFrom Method

Creates inbox rule that deletes messages from specified senders

public static InboxRule CreateRuleDeleteFrom(
MailAddress from
);

Parameters

from
A EmailAddress of sender

Return Value

A created InboxRule

Exceptions

Exception Type | Condition
ArgumentNullException | from is null

See Also

InboxRule Class | Aspose.Email.Exchange Namespace


InboxRule.CreateRuleMoveContaining Method

Creates inbox rule that moves messages containing the specified strings in either the body or the subject into the specified folder

public static InboxRule CreateRuleMoveContaining(
string[] filter,
string destinationFolderId
);

Parameters

filter
A strings to search
destinationFolderId
An id of folder in which messages will be moved

Return Value

A created InboxRule

Exceptions

Exception Type | Condition
ArgumentException | filter is null or empty
ArgumentException | destinationFolderId is null or empty

See Also

InboxRule Class | Aspose.Email.Exchange Namespace


InboxRule.CreateRuleMoveFrom Method

Creates inbox rule that moves messages from specified senders into the specified folder

public static InboxRule CreateRuleMoveFrom(
MailAddress from,
string destinationFolderId
);

Parameters

from
A EmailAddress of sender
destinationFolderId
An id of folder in which messages will be moved

Return Value

A created InboxRule

Exceptions

Exception Type | Condition
ArgumentNullException | from is null
ArgumentException | destinationFolderId is null or empty

See Also

InboxRule Class | Aspose.Email.Exchange Namespace


ItemChoice Enumeration

Specifies property type which should be used for Exchange impersonation.

public enum ItemChoice

Members

Member Name | Description | Value
PrimarySmtpAddress | Specifies that primary Simple Mail Transfer Protocol (SMTP) address of the account should be used for Exchange impersonation. | 0
PrincipalName | Specifies that user principal name (UPN) of the account should be used for Exchange impersonation. | 1
SID | Specifies that security descriptor definition language (SDDL) form of the security identifier (SID) for the account should be used for Exchange impersonation. | 2
SmtpAddress | Specifies that Simple Mail Transfer Protocol (SMTP) address of the account should be used for Exchange impersonation. | 3

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange Namespace


KnownFolderTypes Enumeration

Specifies the known Exchange server folders.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum KnownFolderTypes

Members

Member Name | Description | Value
Unknown | Not specified | 0
Root | The Root folder. | 1
Calendar | The Calendar folder. | 2
Contacts | The Contacts folder. | 3
DeletedItems | The DeletedItems folder. | 4
Drafts | The Drafts folder. | 5
Inbox | The Inbox folder. | 6
Journal | The Journal folder. | 7
Notes | The Notes folder. | 8
Outbox | The Outbox folder. | 9
SentItems | The SentItems folder. | 10
Tasks | The Tasks folder. | 11

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange Namespace


MailTips Class

Represents values for the Mail Tips

For a list of all members of this type, see MailTips Members.

System.Object
Aspose.Email.Exchange.MailTips

public sealed class MailTips

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MailTips Members | Aspose.Email.Exchange Namespace


MailTips Members

MailTips overview

Public Instance Properties

CustomMailTip | Gets a custom mail tip.
DeliveryRestricted | Gets a value indicating whether delivery restrictions will prevent the sender's message from reaching the recipient.
ExternalMemberCount | Gets the number of external members in a group.
InvalidRecipient | Gets a value indicating whether the recipient is invalid.
IsDeliveryRestrictedSpecified | Gets a value indicating whether DeliveryRestricted is specified
IsInvalidRecipientSpecified | Gets a value indicating whether InvalidRecipient is specified
IsMailboxFullSpecified | Gets a value indicating whether the MailboxFull is specified
IsModerated | Gets a value indicating whether the recipient's mailbox is being moderated.
IsModeratedSpecified | Gets a value indicating whether the IsModerated is specified
MailboxFull | Gets a value indicating whether the mailbox for the recipient is full.
MaxMessageSize | Gets the maximum message size the recipient can accept
OutOfOffice | Gets the response message for OOF and the duration for sending this message.
PendingMailTips | Gets a value indicating whether the mail tips in this element could not be evaluated before the server's processing timeout expired.
RecipientAddress | Gets the mailbox of the recipient.
TotalMemberCount | Gets the total number of members in a group.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MailTips Class | Aspose.Email.Exchange Namespace


MailTips Properties

The properties of the MailTips class are listed below. For a complete list of MailTips class members, see the MailTips Members topic.

Public Instance Properties

CustomMailTip | Gets a custom mail tip.
DeliveryRestricted | Gets a value indicating whether delivery restrictions will prevent the sender's message from reaching the recipient.
ExternalMemberCount | Gets the number of external members in a group.
InvalidRecipient | Gets a value indicating whether the recipient is invalid.
IsDeliveryRestrictedSpecified | Gets a value indicating whether DeliveryRestricted is specified
IsInvalidRecipientSpecified | Gets a value indicating whether InvalidRecipient is specified
IsMailboxFullSpecified | Gets a value indicating whether the MailboxFull is specified
IsModerated | Gets a value indicating whether the recipient's mailbox is being moderated.
IsModeratedSpecified | Gets a value indicating whether the IsModerated is specified
MailboxFull | Gets a value indicating whether the mailbox for the recipient is full.
MaxMessageSize | Gets the maximum message size the recipient can accept
OutOfOffice | Gets the response message for OOF and the duration for sending this message.
PendingMailTips | Gets a value indicating whether the mail tips in this element could not be evaluated before the server's processing timeout expired.
RecipientAddress | Gets the mailbox of the recipient.
TotalMemberCount | Gets the total number of members in a group.

See Also

MailTips Class | Aspose.Email.Exchange Namespace


CustomMailTip Property

Aspose.Email

MailTips.CustomMailTip Property

Gets a custom mail tip.

public string CustomMailTip {get; set;}

See Also

MailTips Class | Aspose.Email.Exchange Namespace


DeliveryRestricted Property

Aspose.Email

MailTips.DeliveryRestricted Property

Gets a value indicating whether delivery restrictions will prevent the sender's message from reaching the recipient.

public bool DeliveryRestricted {get; set;}

See Also

MailTips Class | Aspose.Email.Exchange Namespace


ExternalMemberCount Property

Aspose.Email

MailTips.ExternalMemberCount Property

Gets the number of external members in a group.

public uint ExternalMemberCount {get; set;}

See Also

MailTips Class | Aspose.Email.Exchange Namespace


InvalidRecipient Property

Aspose.Email

MailTips.InvalidRecipient Property

Gets a value indicating whether the recipient is invalid.

public bool InvalidRecipient {get; set;}

See Also

MailTips Class | Aspose.Email.Exchange Namespace


IsDeliveryRestrictedSpecified Property

Aspose.Email

MailTips.IsDeliveryRestrictedSpecified Property

Gets a value indicating whether DeliveryRestricted is specified

public bool IsDeliveryRestrictedSpecified {get; set;}

See Also

MailTips Class | Aspose.Email.Exchange Namespace


IsInvalidRecipientSpecified Property

Aspose.Email

MailTips.IsInvalidRecipientSpecified Property

Gets a value indicating whether InvalidRecipient is specified

public bool IsInvalidRecipientSpecified {get; set;}

See Also

MailTips Class | Aspose.Email.Exchange Namespace


IsMailboxFullSpecified Property

Aspose.Email

MailTips.IsMailboxFullSpecified Property

Gets a value indicating whether the MailboxFull is specified

public bool IsMailboxFullSpecified {get; set;}

See Also

MailTips Class | Aspose.Email.Exchange Namespace


IsModerated Property

Aspose.Email

MailTips.IsModerated Property

Gets a value indicating whether the recipient's mailbox is being moderated.

public bool IsModerated {get; set;}

See Also

MailTips Class | Aspose.Email.Exchange Namespace


IsModeratedSpecified Property

Aspose.Email

MailTips.IsModeratedSpecified Property

Gets a value indicating whether the IsModerated is specified

public bool IsModeratedSpecified {get; set;}

See Also

MailTips Class | Aspose.Email.Exchange Namespace


MailboxFull Property

Aspose.Email

MailTips.MailboxFull Property

Gets a value indicating whether the mailbox for the recipient is full.

public bool MailboxFull {get; set;}

See Also

MailTips Class | Aspose.Email.Exchange Namespace


MaxMessageSize Property

Aspose.Email

MailTips.MaxMessageSize Property

Gets the maximum message size the recipient can accept

public uint MaxMessageSize {get; set;}

See Also

MailTips Class | Aspose.Email.Exchange Namespace


OutOfOffice Property

Aspose.Email

MailTips.OutOfOffice Property

Gets the response message for OOF and the duration for sending this message.

public OutOfOfficeMailTip OutOfOffice {get; set;}

See Also

MailTips Class | Aspose.Email.Exchange Namespace


PendingMailTips Property

Aspose.Email

MailTips.PendingMailTips Property

Gets a value indicating whether the mail tips in this element could not be evaluated before the server's processing timeout expired.

public MailTipsType PendingMailTips {get; set;}

See Also

MailTips Class | Aspose.Email.Exchange Namespace


RecipientAddress Property

Aspose.Email

MailTips.RecipientAddress Property

Gets the mailbox of the recipient.

public MailAddress RecipientAddress {get; set;}

See Also

MailTips Class | Aspose.Email.Exchange Namespace


TotalMemberCount Property

Aspose.Email

MailTips.TotalMemberCount Property

Gets the total number of members in a group.

public uint TotalMemberCount {get; set;}

See Also

MailTips Class | Aspose.Email.Exchange Namespace


MailTipsType Enumeration

Enumerates the types of mail tips

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum MailTipsType

Members

Member Name | Description | Value
All | Represents all available mail tips. | 1
OutOfOfficeMessage | Represents the Out of Office (OOF) message. | 2
MailboxFullStatus | Represents the status for a mailbox that is full. | 4
CustomMailTip | Represents a custom mail tip. | 8
ExternalMemberCount | Represents the count of external members. | 16
TotalMemberCount | Represents the count of all members. | 32
MaxMessageSize | Represents the maximum message size a recipient can accept. | 64
DeliveryRestriction | Indicates whether delivery restrictions will prevent the sender's message from reaching the recipient. | 128
ModerationStatus | Indicates whether the sender's message will be reviewed by a moderator. | 256
InvalidRecipient | Indicates whether the recipient is invalid. | 512
Scope |  | 1024

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange Namespace


MessageTrackingReport Class

Represents the information to be included in the report.

For a list of all members of this type, see MessageTrackingReport Members.

System.Object
Aspose.Email.Exchange.MessageTrackingReport

public sealed class MessageTrackingReport

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MessageTrackingReport Members | Aspose.Email.Exchange Namespace


MessageTrackingReport Members

MessageTrackingReport overview

Public Instance Properties

OriginalRecipients | Gets the e-mail addresses of the message recipients.
RecipientTrackingEvents | Gets the type of events to report.
Sender | Gets the e-mail address for the sender of the message.
Subject | Gets the subject of the message.
SubmitTime | Gets the time at which the message was sent to the server.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MessageTrackingReport Class | Aspose.Email.Exchange Namespace


MessageTrackingReport Properties

The properties of the MessageTrackingReport class are listed below. For a complete list of MessageTrackingReport class members, see the MessageTrackingReport Members topic.

Public Instance Properties

OriginalRecipients | Gets the e-mail addresses of the message recipients.
RecipientTrackingEvents | Gets the type of events to report.
Sender | Gets the e-mail address for the sender of the message.
Subject | Gets the subject of the message.
SubmitTime | Gets the time at which the message was sent to the server.

See Also

MessageTrackingReport Class | Aspose.Email.Exchange Namespace


OriginalRecipients Property

Aspose.Email

MessageTrackingReport.OriginalRecipients Property

Gets the e-mail addresses of the message recipients.

public MailAddressCollection OriginalRecipients {get; set;}

See Also

MessageTrackingReport Class | Aspose.Email.Exchange Namespace


RecipientTrackingEvents Property

Aspose.Email

MessageTrackingReport.RecipientTrackingEvents Property

Gets the type of events to report.

public RecipientTrackingEvent[] RecipientTrackingEvents {get; set;}

See Also

MessageTrackingReport Class | Aspose.Email.Exchange Namespace


Sender Property

Aspose.Email

MessageTrackingReport.Sender Property

Gets the e-mail address for the sender of the message.

public MailAddress Sender {get; set;}

See Also

MessageTrackingReport Class | Aspose.Email.Exchange Namespace


Subject Property

Aspose.Email

MessageTrackingReport.Subject Property

Gets the subject of the message.

public string Subject {get; set;}

See Also

MessageTrackingReport Class | Aspose.Email.Exchange Namespace


SubmitTime Property

Aspose.Email

MessageTrackingReport.SubmitTime Property

Gets the time at which the message was sent to the server.

public DateTime SubmitTime {get; set;}

See Also

MessageTrackingReport Class | Aspose.Email.Exchange Namespace


MessageTrackingReportInfo Class

Represents an information about the message that was found by using the FindMessageTrackingReport

For a list of all members of this type, see MessageTrackingReportInfo Members.

System.Object
Aspose.Email.Exchange.MessageTrackingReportInfo

public sealed class MessageTrackingReportInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MessageTrackingReportInfo Members | Aspose.Email.Exchange Namespace


MessageTrackingReportInfo Members

MessageTrackingReportInfo overview

Public Instance Properties

MessageTrackingReportId | Gets the value specifying message by its message-id, the organization where the message was found, the server on which the message was submitted, and an internal ID that uniquely identifies the message.
PreviousHopServer | Gets the previous server name, when available, that submitted the message.
Recipients | Gets the e-mail addresses of the recipients for the message that was found.
Sender | Gets the e-mail address of the sender for the message that was found.
Subject | Gets the subject of the message that was found.
SubmittedTime | Gets the time that the message entered the server.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MessageTrackingReportInfo Class | Aspose.Email.Exchange Namespace


MessageTrackingReportInfo Properties

The properties of the MessageTrackingReportInfo class are listed below. For a complete list of MessageTrackingReportInfo class members, see the MessageTrackingReportInfo Members topic.

Public Instance Properties

MessageTrackingReportId | Gets the value specifying message by its message-id, the organization where the message was found, the server on which the message was submitted, and an internal ID that uniquely identifies the message.
PreviousHopServer | Gets the previous server name, when available, that submitted the message.
Recipients | Gets the e-mail addresses of the recipients for the message that was found.
Sender | Gets the e-mail address of the sender for the message that was found.
Subject | Gets the subject of the message that was found.
SubmittedTime | Gets the time that the message entered the server.

See Also

MessageTrackingReportInfo Class | Aspose.Email.Exchange Namespace


MessageTrackingReportId Property

Aspose.Email

MessageTrackingReportInfo.MessageTrackingReportId Property

Gets the value specifying message by its message-id, the organization where the message was found, the server on which the message was submitted, and an internal ID that uniquely identifies the message.

public string MessageTrackingReportId {get; set;}

See Also

MessageTrackingReportInfo Class | Aspose.Email.Exchange Namespace


PreviousHopServer Property

Aspose.Email

MessageTrackingReportInfo.PreviousHopServer Property

Gets the previous server name, when available, that submitted the message.

public string PreviousHopServer {get; set;}

See Also

MessageTrackingReportInfo Class | Aspose.Email.Exchange Namespace


Recipients Property

Aspose.Email

MessageTrackingReportInfo.Recipients Property

Gets the e-mail addresses of the recipients for the message that was found.

public MailAddressCollection Recipients {get;}

See Also

MessageTrackingReportInfo Class | Aspose.Email.Exchange Namespace


Sender Property

Aspose.Email

MessageTrackingReportInfo.Sender Property

Gets the e-mail address of the sender for the message that was found.

public MailAddress Sender {get; set;}

See Also

MessageTrackingReportInfo Class | Aspose.Email.Exchange Namespace


Subject Property

Aspose.Email

MessageTrackingReportInfo.Subject Property

Gets the subject of the message that was found.

public string Subject {get; set;}

See Also

MessageTrackingReportInfo Class | Aspose.Email.Exchange Namespace


SubmittedTime Property

Aspose.Email

MessageTrackingReportInfo.SubmittedTime Property

Gets the time that the message entered the server.

public DateTime SubmittedTime {get; set;}

See Also

MessageTrackingReportInfo Class | Aspose.Email.Exchange Namespace


MessageTrackingReportTemplate Enumeration

Enumerates the types of report to display.

public enum MessageTrackingReportTemplate

Members

Member Name | Description | Value
Summary | Specifies that the report will display all the recipients of the message and the delivery status of the message to each recipient. | 0
RecipientPath | Specifies that for a single recipient, the report will display a full history of the events that occurred. | 1

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange Namespace


OutOfOfficeMailTip Class

Represents OOF mail tip

For a list of all members of this type, see OutOfOfficeMailTip Members.

System.Object
Aspose.Email.Exchange.OutOfOfficeMailTip

public sealed class OutOfOfficeMailTip

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

OutOfOfficeMailTip Members | Aspose.Email.Exchange Namespace


OutOfOfficeMailTip Members

OutOfOfficeMailTip overview

Public Instance Properties

Duration | Gets the start and end time for sending OOF messages
ReplyBody | Gets the OOF message response.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

OutOfOfficeMailTip Class | Aspose.Email.Exchange Namespace


OutOfOfficeMailTip Properties

The properties of the OutOfOfficeMailTip class are listed below. For a complete list of OutOfOfficeMailTip class members, see the OutOfOfficeMailTip Members topic.

Public Instance Properties

Duration | Gets the start and end time for sending OOF messages
ReplyBody | Gets the OOF message response.

See Also

OutOfOfficeMailTip Class | Aspose.Email.Exchange Namespace


Duration Property

Aspose.Email

OutOfOfficeMailTip.Duration Property

Gets the start and end time for sending OOF messages

public DateRange Duration {get;}

See Also

OutOfOfficeMailTip Class | Aspose.Email.Exchange Namespace


ReplyBody Property

Aspose.Email

OutOfOfficeMailTip.ReplyBody Property

Gets the OOF message response.

public ReplyBody ReplyBody {get;}

See Also

OutOfOfficeMailTip Class | Aspose.Email.Exchange Namespace


PhoneCallState Enumeration

Phone call statuses.

public enum PhoneCallState

Members

Member Name | Description | Value
Idle | Phone call is idle | 0
Connecting | Phone call is connecting | 1
Alerted | Alerted call. | 2
Connected | Phone call is connected | 3
Disconnected | Phone call is disconnected | 4
Incoming | Incoming call | 5
Transferring | Transferred call. | 6
Forwarding | Phone call is forwarding | 7

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange Namespace


RecipientTrackingEvent Class

Represents details for a specific event in the tracking report.

For a list of all members of this type, see RecipientTrackingEvent Members.

System.Object
Aspose.Email.Exchange.RecipientTrackingEvent

public sealed class RecipientTrackingEvent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RecipientTrackingEvent Members | Aspose.Email.Exchange Namespace


RecipientTrackingEvent Members

RecipientTrackingEvent overview

Public Instance Properties

BccRecipient | Gets a value indicating whether the recipient was addressed as a blind carbon copy (BCC) recipient.
Date | Gets the time at which the event occurred.
DeliveryStatus | Gets the status for the message.
EventData | Gets data that is associated with the processing step for the event.
EventDescription | Gets the processing step for the event
HiddenRecipient | Gets a value indicating whether the recipient was added by an organization policy that should be hidden from unprivileged users
InternalId | Gets an integer value for the event.
Recipient | Gets the recipient for whom the event occurred.
Server | Gets the physical server where the event occurred.
UniquePathId | Gets a string that is different for each path.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

RecipientTrackingEvent Class | Aspose.Email.Exchange Namespace


RecipientTrackingEvent Properties

The properties of the RecipientTrackingEvent class are listed below. For a complete list of RecipientTrackingEvent class members, see the RecipientTrackingEvent Members topic.

Public Instance Properties

BccRecipient | Gets a value indicating whether the recipient was addressed as a blind carbon copy (BCC) recipient.
Date | Gets the time at which the event occurred.
DeliveryStatus | Gets the status for the message.
EventData | Gets data that is associated with the processing step for the event.
EventDescription | Gets the processing step for the event
HiddenRecipient | Gets a value indicating whether the recipient was added by an organization policy that should be hidden from unprivileged users
InternalId | Gets an integer value for the event.
Recipient | Gets the recipient for whom the event occurred.
Server | Gets the physical server where the event occurred.
UniquePathId | Gets a string that is different for each path.

See Also

RecipientTrackingEvent Class | Aspose.Email.Exchange Namespace


BccRecipient Property

Aspose.Email

RecipientTrackingEvent.BccRecipient Property

Gets a value indicating whether the recipient was addressed as a blind carbon copy (BCC) recipient.

public bool BccRecipient {get; set;}

See Also

RecipientTrackingEvent Class | Aspose.Email.Exchange Namespace


Date Property

Aspose.Email

RecipientTrackingEvent.Date Property

Gets the time at which the event occurred.

public DateTime Date {get; set;}

See Also

RecipientTrackingEvent Class | Aspose.Email.Exchange Namespace


DeliveryStatus Property

Aspose.Email

RecipientTrackingEvent.DeliveryStatus Property

Gets the status for the message.

public string DeliveryStatus {get; set;}

See Also

RecipientTrackingEvent Class | Aspose.Email.Exchange Namespace


EventData Property

Aspose.Email

RecipientTrackingEvent.EventData Property

Gets data that is associated with the processing step for the event.

public StringCollection EventData {get; set;}

See Also

RecipientTrackingEvent Class | Aspose.Email.Exchange Namespace


EventDescription Property

Aspose.Email

RecipientTrackingEvent.EventDescription Property

Gets the processing step for the event

public string EventDescription {get; set;}

See Also

RecipientTrackingEvent Class | Aspose.Email.Exchange Namespace


HiddenRecipient Property

Aspose.Email

RecipientTrackingEvent.HiddenRecipient Property

Gets a value indicating whether the recipient was added by an organization policy that should be hidden from unprivileged users

public bool HiddenRecipient {get; set;}

See Also

RecipientTrackingEvent Class | Aspose.Email.Exchange Namespace


InternalId Property

Aspose.Email

RecipientTrackingEvent.InternalId Property

Gets an integer value for the event.

public uint InternalId {get; set;}

See Also

RecipientTrackingEvent Class | Aspose.Email.Exchange Namespace


Recipient Property

Aspose.Email

RecipientTrackingEvent.Recipient Property

Gets the recipient for whom the event occurred.

public MailAddress Recipient {get; set;}

See Also

RecipientTrackingEvent Class | Aspose.Email.Exchange Namespace


Server Property

Aspose.Email

RecipientTrackingEvent.Server Property

Gets the physical server where the event occurred.

public string Server {get; set;}

See Also

RecipientTrackingEvent Class | Aspose.Email.Exchange Namespace


UniquePathId Property

Aspose.Email

RecipientTrackingEvent.UniquePathId Property

Gets a string that is different for each path.

public string UniquePathId {get; set;}

See Also

RecipientTrackingEvent Class | Aspose.Email.Exchange Namespace


ReplyBody Class

Represents the OOF message response.

For a list of all members of this type, see ReplyBody Members.

System.Object
Aspose.Email.Exchange.ReplyBody

public sealed class ReplyBody

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ReplyBody Members | Aspose.Email.Exchange Namespace


ReplyBody Members

ReplyBody overview

Public Instance Properties

Language | Gets the language that the OOF message was written in.
Message | Gets the OOF message response.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ReplyBody Class | Aspose.Email.Exchange Namespace


ReplyBody Properties

The properties of the ReplyBody class are listed below. For a complete list of ReplyBody class members, see the ReplyBody Members topic.

Public Instance Properties

Language | Gets the language that the OOF message was written in.
Message | Gets the OOF message response.

See Also

ReplyBody Class | Aspose.Email.Exchange Namespace


Language Property

Aspose.Email

ReplyBody.Language Property

Gets the language that the OOF message was written in.

public string Language {get;}

See Also

ReplyBody Class | Aspose.Email.Exchange Namespace


Message Property

Aspose.Email

ReplyBody.Message Property

Gets the OOF message response.

public string Message {get;}

See Also

ReplyBody Class | Aspose.Email.Exchange Namespace


RuleActions Class

Represents the set of actions that are available to a rule.

For a list of all members of this type, see RuleActions Members.

System.Object
Aspose.Email.Exchange.RuleActions

public sealed class RuleActions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RuleActions Members | Aspose.Email.Exchange Namespace


RuleActions Members

RuleActions overview

Public Instance Constructors

RuleActions Constructor Initializes a new instance of the RuleActions class

Public Instance Properties

AssignCategories | Gets or sets the categories that are stamped on e-mail messages.
CopyToFolder | Gets or sets the folder that e-mail items will be copied to.
Delete | Gets or sets a value indicating whether messages are to be moved to the Deleted Items folder.
ForwardAsAttachmentToRecipients | Gets or sets the e-mail addresses to which messages are to be forwarded as attachments.
ForwardToRecipients | Gets or sets the e-mail addresses to which messages are to be forwarded.
MarkAsRead | Gets or sets a value indicating whether messages are to be marked as read.
MarkImportance | Gets or sets the importance that is to be stamped on messages.
MoveToFolder | Gets or sets the ID of the folder that e-mail items will be moved to.
PermanentDelete | Gets or sets a value indicating whether messages are to be permanently deleted and not saved to the Deleted Items folder.
RedirectToRecipients | Gets or sets the e-mail addresses to which messages are to be redirected.
SendSMSAlertToRecipients | Gets or sets the mobile phone numbers to which a Short Message Service (SMS) alert is to be sent.
ServerReplyWithMessage | Gets or sets the ID of the template message that is to be sent as a reply to incoming messages.
StopProcessingRules | Gets or sets a value indicating whether subsequent rules are to be evaluated.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

RuleActions Class | Aspose.Email.Exchange Namespace


RuleActions Constructor

Initializes a new instance of the RuleActions class

public RuleActions();

See Also

RuleActions Class | Aspose.Email.Exchange Namespace


RuleActions Properties

The properties of the RuleActions class are listed below. For a complete list of RuleActions class members, see the RuleActions Members topic.

Public Instance Properties

AssignCategories | Gets or sets the categories that are stamped on e-mail messages.
CopyToFolder | Gets or sets the folder that e-mail items will be copied to.
Delete | Gets or sets a value indicating whether messages are to be moved to the Deleted Items folder.
ForwardAsAttachmentToRecipients | Gets or sets the e-mail addresses to which messages are to be forwarded as attachments.
ForwardToRecipients | Gets or sets the e-mail addresses to which messages are to be forwarded.
MarkAsRead | Gets or sets a value indicating whether messages are to be marked as read.
MarkImportance | Gets or sets the importance that is to be stamped on messages.
MoveToFolder | Gets or sets the ID of the folder that e-mail items will be moved to.
PermanentDelete | Gets or sets a value indicating whether messages are to be permanently deleted and not saved to the Deleted Items folder.
RedirectToRecipients | Gets or sets the e-mail addresses to which messages are to be redirected.
SendSMSAlertToRecipients | Gets or sets the mobile phone numbers to which a Short Message Service (SMS) alert is to be sent.
ServerReplyWithMessage | Gets or sets the ID of the template message that is to be sent as a reply to incoming messages.
StopProcessingRules | Gets or sets a value indicating whether subsequent rules are to be evaluated.

See Also

RuleActions Class | Aspose.Email.Exchange Namespace


AssignCategories Property

Aspose.Email

RuleActions.AssignCategories Property

Gets or sets the categories that are stamped on e-mail messages.

public StringCollection AssignCategories {get; set;}

See Also

RuleActions Class | Aspose.Email.Exchange Namespace


CopyToFolder Property

Aspose.Email

RuleActions.CopyToFolder Property

Gets or sets the folder that e-mail items will be copied to.

public string CopyToFolder {get; set;}

See Also

RuleActions Class | Aspose.Email.Exchange Namespace


Delete Property

Aspose.Email

RuleActions.Delete Property

Gets or sets a value indicating whether messages are to be moved to the Deleted Items folder.

public bool Delete {get; set;}

See Also

RuleActions Class | Aspose.Email.Exchange Namespace


ForwardAsAttachmentToRecipients Property

Aspose.Email

RuleActions.ForwardAsAttachmentToRecipients Property

Gets or sets the e-mail addresses to which messages are to be forwarded as attachments.

public MailAddressCollection ForwardAsAttachmentToRecipients {get; set;}

See Also

RuleActions Class | Aspose.Email.Exchange Namespace


ForwardToRecipients Property

Aspose.Email

RuleActions.ForwardToRecipients Property

Gets or sets the e-mail addresses to which messages are to be forwarded.

public MailAddressCollection ForwardToRecipients {get; set;}

See Also

RuleActions Class | Aspose.Email.Exchange Namespace


MarkAsRead Property

Aspose.Email

RuleActions.MarkAsRead Property

Gets or sets a value indicating whether messages are to be marked as read.

public bool MarkAsRead {get; set;}

See Also

RuleActions Class | Aspose.Email.Exchange Namespace


MarkImportance Property

Aspose.Email

RuleActions.MarkImportance Property

Gets or sets the importance that is to be stamped on messages.

public ImportanceChoices MarkImportance {get; set;}

See Also

RuleActions Class | Aspose.Email.Exchange Namespace


MoveToFolder Property

Aspose.Email

RuleActions.MoveToFolder Property

Gets or sets the ID of the folder that e-mail items will be moved to.

public string MoveToFolder {get; set;}

See Also

RuleActions Class | Aspose.Email.Exchange Namespace


PermanentDelete Property

Aspose.Email

RuleActions.PermanentDelete Property

Gets or sets a value indicating whether messages are to be permanently deleted and not saved to the Deleted Items folder.

public bool PermanentDelete {get; set;}

See Also

RuleActions Class | Aspose.Email.Exchange Namespace


RedirectToRecipients Property

Aspose.Email

RuleActions.RedirectToRecipients Property

Gets or sets the e-mail addresses to which messages are to be redirected.

public MailAddressCollection RedirectToRecipients {get; set;}

See Also

RuleActions Class | Aspose.Email.Exchange Namespace


SendSMSAlertToRecipients Property

Aspose.Email

RuleActions.SendSMSAlertToRecipients Property

Gets or sets the mobile phone numbers to which a Short Message Service (SMS) alert is to be sent.

public MailAddressCollection SendSMSAlertToRecipients {get; set;}

See Also

RuleActions Class | Aspose.Email.Exchange Namespace


ServerReplyWithMessage Property

Aspose.Email

RuleActions.ServerReplyWithMessage Property

Gets or sets the ID of the template message that is to be sent as a reply to incoming messages.

public string ServerReplyWithMessage {get; set;}

See Also

RuleActions Class | Aspose.Email.Exchange Namespace


StopProcessingRules Property

Aspose.Email

RuleActions.StopProcessingRules Property

Gets or sets a value indicating whether subsequent rules are to be evaluated.

public bool StopProcessingRules {get; set;}

See Also

RuleActions Class | Aspose.Email.Exchange Namespace


RulePredicateFlags Enumeration

Represents the RulePredicate flags

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum RulePredicateFlags

Members

Member Name | Description | Value
None | No flags are specified | 0
ApprovalRequest | Incoming messages must be approval requests in order for the condition or exception to apply. | 1
NotApprovalRequest | Incoming messages must NOT be approval requests in order for the condition or exception to apply. | 2
AutomaticForward | Incoming messages must be automatic forwards in order for the condition or exception to apply. | 4
NotAutomaticForward | Incoming messages must NOT be automatic forwards in order for the condition or exception to apply. | 8
AutomaticReply | Incoming messages must be automatic replies in order for the condition or exception to apply. | 16
NotAutomaticReply | Incoming messages must NOT be automatic replies in order for the condition or exception to apply. | 32
Encrypted | Incoming messages must be S/MIME encrypted in order for the condition or exception to apply. | 64
NotEncrypted | Incoming messages must not be S/MIME encrypted in order for the condition or exception to apply. | 128
MeetingRequest | Incoming messages must be meeting requests in order for the condition or exception to apply. | 256
NotMeetingRequest | Incoming messages must NOT be meeting requests in order for the condition or exception to apply. | 512
MeetingResponse | Incoming messages must be meeting responses in order for the condition or exception to apply. | 1024
NotMeetingResponse | Incoming messages must NOT be meeting responses in order for the condition or exception to apply. | 2048
Ndr | Incoming messages must be non-delivery reports (NDRs) in order for the condition or exception to apply. | 4096
NotNdr | Incoming messages must NOT be non-delivery reports (NDRs) in order for the condition or exception to apply. | 8192
PermissionControlled | Incoming messages must be permission controlled (RMS protected) in order for the condition or exception to apply. | 16384
NotPermissionControlled | Incoming messages must NOT be permission controlled (RMS protected) in order for the condition or exception to apply. | 32768
HasAttachment | An incoming messages have to have attachments in order for the condition or exception to apply | 65536
HasNotAttachment | An incoming messages have to have NOT attachments in order for the condition or exception to apply | 131072
ReadReceipt | Incoming messages must be read receipts in order for the condition or exception to apply | 262144
NotReadReceipt | Incoming messages must NOT be read receipts in order for the condition or exception to apply | 524288
Signed | Incoming messages must be S/MIME signed in order for the condition or exception to apply. | 1048576
NotSigned | Incoming messages must NOT be S/MIME signed in order for the condition or exception to apply. | 2097152
Voicemail | Incoming messages must be voice mails in order for the condition or exception to apply. | 4194304
NotVoicemail | Incoming messages cant NOT be voice mails in order for the condition or exception to apply. | 8388608
SentToMe | The owner of the mailbox has to be in the ToRecipients property of incoming messages in order for the condition or exception to apply. | 16777216
NotSentToMe | The owner of the mailbox cannot be in the ToRecipients property of the incoming messages in order for the condition or exception to apply. | 33554432
SentCcMe | The owner of the mailbox has to be in the CcRecipients property of incoming messages in order for the condition or exception to apply. | 67108864
NotSentCcMe | The owner of the mailbox cannot be in the CcRecipients property of incoming messages in order for the condition or exception to apply. | 134217728
SentOnlyToMe | The owner of the mailbox has to be the only one in the ToRecipients property of incoming messages in order for the condition or exception to apply. | 268435456
NotSentOnlyToMe | The owner of the mailbox cannot to be the only one in the ToRecipients property of incoming messages in order for the condition or exception to apply. | 536870912
SentToOrCcMe | The owner of the mailbox has to be in either a ToRecipients or CcRecipients property of incoming messages in order for the condition or exception to apply | 1073741824

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange Namespace


RulePredicates Class

Represents rule predicate

For a list of all members of this type, see RulePredicates Members.

System.Object
Aspose.Email.Exchange.RulePredicates

public sealed class RulePredicates

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RulePredicates Members | Aspose.Email.Exchange Namespace


RulePredicates Members

RulePredicates overview

Public Instance Constructors

RulePredicates Constructor Initializes a new instance of the RulePredicates class

Public Instance Properties

Categories | Gets or sets the categories that an incoming message is labeled with in order for the condition or exception to apply.
ContainsBodyStrings | Gets or sets the strings that appear in the body of incoming messages in order for the condition or exception to apply.
ContainsHeaderStrings | Gets or sets the strings that appear in the headers of incoming messages in order for the condition or exception to apply.
ContainsRecipientStrings | Gets or sets the strings that appear in either the ToRecipients or CcRecipients properties of incoming messages in order for the condition or exception to apply.
ContainsSenderStrings | Gets or sets the strings that appears in the From property of incoming messages in order for the condition or exception to apply
ContainsSubjectOrBodyStrings | Gets or sets the strings that appear in either the body or the subject of incoming messages in order for the condition or exception to apply.
ContainsSubjectStrings | Gets or sets the strings that appear in the subject of incoming messages in order for the condition or exception to apply.
FlaggedForAction | Gets or sets the flag for action value that appears on incoming messages in order for the condition or exception to apply.
FromAddresses | Gets or sets the e-mail addresses of the senders of incoming messages in order for the condition or exception to apply.
FromConnectedAccounts | Gets or sets the e-mail account names from which incoming messages have to have been aggregated in order for the condition or exception to apply.
Importance | Gets or sets the importance that is stamped on incoming messages in order for the condition or exception to apply.
ItemClasses | Gets or sets the item classes that must be stamped on incoming messages in order for the condition or exception to apply.
MessageClassifications | Gets or sets the message classifications that must be stamped on incoming messages in order for the condition or exception to apply.
RulePredicateFlags | Gets or sets rule predicate flags
Sensitivity | Gets or sets the sensitivity that must be stamped on incoming messages in order for the condition or exception to apply.
SentToAddresses | Gets or sets the e-mail addresses that incoming messages have to have been sent to in order for the condition or exception to apply.
WithinDateRange | Gets or sets the date range within which incoming messages have to have been received in order for the condition or exception to apply.
WithinSizeRange | Gets or sets the minimum and maximum sizes that incoming messages have to have in order for the condition or exception to apply.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

RulePredicates Class | Aspose.Email.Exchange Namespace


RulePredicates Constructor

Initializes a new instance of the RulePredicates class

public RulePredicates();

See Also

RulePredicates Class | Aspose.Email.Exchange Namespace


RulePredicates Properties

The properties of the RulePredicates class are listed below. For a complete list of RulePredicates class members, see the RulePredicates Members topic.

Public Instance Properties

Categories | Gets or sets the categories that an incoming message is labeled with in order for the condition or exception to apply.
ContainsBodyStrings | Gets or sets the strings that appear in the body of incoming messages in order for the condition or exception to apply.
ContainsHeaderStrings | Gets or sets the strings that appear in the headers of incoming messages in order for the condition or exception to apply.
ContainsRecipientStrings | Gets or sets the strings that appear in either the ToRecipients or CcRecipients properties of incoming messages in order for the condition or exception to apply.
ContainsSenderStrings | Gets or sets the strings that appears in the From property of incoming messages in order for the condition or exception to apply
ContainsSubjectOrBodyStrings | Gets or sets the strings that appear in either the body or the subject of incoming messages in order for the condition or exception to apply.
ContainsSubjectStrings | Gets or sets the strings that appear in the subject of incoming messages in order for the condition or exception to apply.
FlaggedForAction | Gets or sets the flag for action value that appears on incoming messages in order for the condition or exception to apply.
FromAddresses | Gets or sets the e-mail addresses of the senders of incoming messages in order for the condition or exception to apply.
FromConnectedAccounts | Gets or sets the e-mail account names from which incoming messages have to have been aggregated in order for the condition or exception to apply.
Importance | Gets or sets the importance that is stamped on incoming messages in order for the condition or exception to apply.
ItemClasses | Gets or sets the item classes that must be stamped on incoming messages in order for the condition or exception to apply.
MessageClassifications | Gets or sets the message classifications that must be stamped on incoming messages in order for the condition or exception to apply.
RulePredicateFlags | Gets or sets rule predicate flags
Sensitivity | Gets or sets the sensitivity that must be stamped on incoming messages in order for the condition or exception to apply.
SentToAddresses | Gets or sets the e-mail addresses that incoming messages have to have been sent to in order for the condition or exception to apply.
WithinDateRange | Gets or sets the date range within which incoming messages have to have been received in order for the condition or exception to apply.
WithinSizeRange | Gets or sets the minimum and maximum sizes that incoming messages have to have in order for the condition or exception to apply.

See Also

RulePredicates Class | Aspose.Email.Exchange Namespace


Categories Property

Aspose.Email

RulePredicates.Categories Property

Gets or sets the categories that an incoming message is labeled with in order for the condition or exception to apply.

public StringCollection Categories {get; set;}

See Also

RulePredicates Class | Aspose.Email.Exchange Namespace


ContainsBodyStrings Property

Aspose.Email

RulePredicates.ContainsBodyStrings Property

Gets or sets the strings that appear in the body of incoming messages in order for the condition or exception to apply.

public StringCollection ContainsBodyStrings {get; set;}

See Also

RulePredicates Class | Aspose.Email.Exchange Namespace


ContainsHeaderStrings Property

Aspose.Email

RulePredicates.ContainsHeaderStrings Property

Gets or sets the strings that appear in the headers of incoming messages in order for the condition or exception to apply.

public StringCollection ContainsHeaderStrings {get; set;}

See Also

RulePredicates Class | Aspose.Email.Exchange Namespace


ContainsRecipientStrings Property

Aspose.Email

RulePredicates.ContainsRecipientStrings Property

Gets or sets the strings that appear in either the ToRecipients or CcRecipients properties of incoming messages in order for the condition or exception to apply.

public StringCollection ContainsRecipientStrings {get; set;}

See Also

RulePredicates Class | Aspose.Email.Exchange Namespace


ContainsSenderStrings Property

Aspose.Email

RulePredicates.ContainsSenderStrings Property

Gets or sets the strings that appears in the From property of incoming messages in order for the condition or exception to apply

public StringCollection ContainsSenderStrings {get; set;}

See Also

RulePredicates Class | Aspose.Email.Exchange Namespace


ContainsSubjectOrBodyStrings Property

Aspose.Email

RulePredicates.ContainsSubjectOrBodyStrings Property

Gets or sets the strings that appear in either the body or the subject of incoming messages in order for the condition or exception to apply.

public StringCollection ContainsSubjectOrBodyStrings {get; set;}

See Also

RulePredicates Class | Aspose.Email.Exchange Namespace


ContainsSubjectStrings Property

Aspose.Email

RulePredicates.ContainsSubjectStrings Property

Gets or sets the strings that appear in the subject of incoming messages in order for the condition or exception to apply.

public StringCollection ContainsSubjectStrings {get; set;}

See Also

RulePredicates Class | Aspose.Email.Exchange Namespace


FlaggedForAction Property

Aspose.Email

RulePredicates.FlaggedForAction Property

Gets or sets the flag for action value that appears on incoming messages in order for the condition or exception to apply.

public FlaggedForAction FlaggedForAction {get; set;}

See Also

RulePredicates Class | Aspose.Email.Exchange Namespace


FromAddresses Property

Aspose.Email

RulePredicates.FromAddresses Property

Gets or sets the e-mail addresses of the senders of incoming messages in order for the condition or exception to apply.

public MailAddressCollection FromAddresses {get; set;}

See Also

RulePredicates Class | Aspose.Email.Exchange Namespace


FromConnectedAccounts Property

Aspose.Email

RulePredicates.FromConnectedAccounts Property

Gets or sets the e-mail account names from which incoming messages have to have been aggregated in order for the condition or exception to apply.

public StringCollection FromConnectedAccounts {get; set;}

See Also

RulePredicates Class | Aspose.Email.Exchange Namespace


Importance Property

Aspose.Email

RulePredicates.Importance Property

Gets or sets the importance that is stamped on incoming messages in order for the condition or exception to apply.

public ImportanceChoices Importance {get; set;}

See Also

RulePredicates Class | Aspose.Email.Exchange Namespace


ItemClasses Property

Aspose.Email

RulePredicates.ItemClasses Property

Gets or sets the item classes that must be stamped on incoming messages in order for the condition or exception to apply.

public StringCollection ItemClasses {get; set;}

See Also

RulePredicates Class | Aspose.Email.Exchange Namespace


MessageClassifications Property

Aspose.Email

RulePredicates.MessageClassifications Property

Gets or sets the message classifications that must be stamped on incoming messages in order for the condition or exception to apply.

public StringCollection MessageClassifications {get; set;}

See Also

RulePredicates Class | Aspose.Email.Exchange Namespace


RulePredicateFlags Property

Aspose.Email

RulePredicates.RulePredicateFlags Property

Gets or sets rule predicate flags

public RulePredicateFlags RulePredicateFlags {get; set;}

See Also

RulePredicates Class | Aspose.Email.Exchange Namespace


Sensitivity Property

Aspose.Email

RulePredicates.Sensitivity Property

Gets or sets the sensitivity that must be stamped on incoming messages in order for the condition or exception to apply.

public SensitivityChoices Sensitivity {get; set;}

See Also

RulePredicates Class | Aspose.Email.Exchange Namespace


SentToAddresses Property

Aspose.Email

RulePredicates.SentToAddresses Property

Gets or sets the e-mail addresses that incoming messages have to have been sent to in order for the condition or exception to apply.

public MailAddressCollection SentToAddresses {get; set;}

See Also

RulePredicates Class | Aspose.Email.Exchange Namespace


WithinDateRange Property

Aspose.Email

RulePredicates.WithinDateRange Property

Gets or sets the date range within which incoming messages have to have been received in order for the condition or exception to apply.

public DateRange WithinDateRange {get; set;}

See Also

RulePredicates Class | Aspose.Email.Exchange Namespace


WithinSizeRange Property

Aspose.Email

RulePredicates.WithinSizeRange Property

Gets or sets the minimum and maximum sizes that incoming messages have to have in order for the condition or exception to apply.

public SizeRange WithinSizeRange {get; set;}

See Also

RulePredicates Class | Aspose.Email.Exchange Namespace


SensitivityChoices Enumeration

Enumerates the sensitivity level types that are available for an item.

public enum SensitivityChoices

Members

Member Name | Description | Value
Undefined | Sensitivity level is not specified | -1
Normal | Specifies the item as normal. | 0
Personal | Specifies the item as personal. | 1
Private | Specifies the item as private. | 2
Confidential | Specifies the item as confidential. | 3

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange Namespace


ServerNotificationEventArgs Class

Contains event data for server notification.

For a list of all members of this type, see ServerNotificationEventArgs Members.

System.Object
System.EventArgs
Aspose.Email.Exchange.ServerNotificationEventArgs

public class ServerNotificationEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ServerNotificationEventArgs Members | Aspose.Email.Exchange Namespace


ServerNotificationEventArgs Members

ServerNotificationEventArgs overview

Public Instance Constructors

ServerNotificationEventArgs Constructor Initializes a new instance of the ServerNotificationEventArgs class

Public Instance Properties

EventTypes | Specifies event type
FolderType | Specifies the known Exchange server folders.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ServerNotificationEventArgs Class | Aspose.Email.Exchange Namespace


ServerNotificationEventArgs Constructor

Initializes a new instance of the ServerNotificationEventArgs class

public ServerNotificationEventArgs(
KnownFolderTypes folderType,
EventTypes eventTypes
);

Parameters

folderType
Specifies the known Exchange server folders.
eventTypes
Specifies event type

See Also

ServerNotificationEventArgs Class | Aspose.Email.Exchange Namespace


ServerNotificationEventArgs Properties

The properties of the ServerNotificationEventArgs class are listed below. For a complete list of ServerNotificationEventArgs class members, see the ServerNotificationEventArgs Members topic.

Public Instance Properties

EventTypes | Specifies event type
FolderType | Specifies the known Exchange server folders.

See Also

ServerNotificationEventArgs Class | Aspose.Email.Exchange Namespace


EventTypes Property

Aspose.Email

ServerNotificationEventArgs.EventTypes Property

Specifies event type

public EventTypes EventTypes {get; set;}

See Also

ServerNotificationEventArgs Class | Aspose.Email.Exchange Namespace


FolderType Property

Aspose.Email

ServerNotificationEventArgs.FolderType Property

Specifies the known Exchange server folders.

public KnownFolderTypes FolderType {get; set;}

See Also

ServerNotificationEventArgs Class | Aspose.Email.Exchange Namespace


SizeRange Class

Represents the size range

For a list of all members of this type, see SizeRange Members.

System.Object
Aspose.Email.Exchange.SizeRange

public class SizeRange

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SizeRange Members | Aspose.Email.Exchange Namespace


SizeRange Members

SizeRange overview

Public Instance Constructors

SizeRange Constructor Initializes a new instance of the SizeRange class

Public Instance Properties

MaximumSize | Gets or sets the maximum size.
MinimumSize | Gets or sets the minimum size.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SizeRange Class | Aspose.Email.Exchange Namespace


SizeRange Constructor

Initializes a new instance of the SizeRange class

public SizeRange();

See Also

SizeRange Class | Aspose.Email.Exchange Namespace


SizeRange Properties

The properties of the SizeRange class are listed below. For a complete list of SizeRange class members, see the SizeRange Members topic.

Public Instance Properties

MaximumSize | Gets or sets the maximum size.
MinimumSize | Gets or sets the minimum size.

See Also

SizeRange Class | Aspose.Email.Exchange Namespace


MaximumSize Property

Aspose.Email

SizeRange.MaximumSize Property

Gets or sets the maximum size.

public int MaximumSize {get; set;}

See Also

SizeRange Class | Aspose.Email.Exchange Namespace


MinimumSize Property

Aspose.Email

SizeRange.MinimumSize Property

Gets or sets the minimum size.

public int MinimumSize {get; set;}

See Also

SizeRange Class | Aspose.Email.Exchange Namespace


TaskRegeneratingPattern Class

Represents the regenerating recurrence pattern that specifies how many days, weeks, months or years after the completion of the current task the next occurrence will be due.

For a list of all members of this type, see TaskRegeneratingPattern Members.

System.Object
Aspose.Email.Mail.Calendaring.RecurrencePattern
Aspose.Email.Exchange.TaskRegeneratingPattern

public sealed class TaskRegeneratingPattern : RecurrencePattern

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

TaskRegeneratingPattern Members | Aspose.Email.Exchange Namespace


TaskRegeneratingPattern Members

TaskRegeneratingPattern overview

Public Instance Constructors

TaskRegeneratingPattern Constructor Initializes a new instance of the TaskRegeneratingPattern class.

Public Instance Properties

EndDate (inherited from RecurrencePattern) | Gets or sets the end date.
Interval (inherited from RecurrencePattern) | Gets or sets the number of recurrence units.
Occurs (inherited from RecurrencePattern) | Gets or sets the number of occurrences of the recurrence pattern.
RegeneratingType | Gets or sets a type of regenerating pattern.
WeekStart (inherited from RecurrencePattern) | Gets or sets the week start.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

TaskRegeneratingPattern Class | Aspose.Email.Exchange Namespace


TaskRegeneratingPattern Constructor

Initializes a new instance of the TaskRegeneratingPattern class.

public TaskRegeneratingPattern(
TaskRegeneratingType type,
int interval
);

Parameters

type
Specifies the type of regenerating pattern.
interval
Specifies how many days, weeks, months or years after the completion of the current task the next occurrence will be due.

See Also

TaskRegeneratingPattern Class | Aspose.Email.Exchange Namespace


TaskRegeneratingPattern Properties

The properties of the TaskRegeneratingPattern class are listed below. For a complete list of TaskRegeneratingPattern class members, see the TaskRegeneratingPattern Members topic.

Public Instance Properties

EndDate (inherited from RecurrencePattern) | Gets or sets the end date.
Interval (inherited from RecurrencePattern) | Gets or sets the number of recurrence units.
Occurs (inherited from RecurrencePattern) | Gets or sets the number of occurrences of the recurrence pattern.
RegeneratingType | Gets or sets a type of regenerating pattern.
WeekStart (inherited from RecurrencePattern) | Gets or sets the week start.

See Also

TaskRegeneratingPattern Class | Aspose.Email.Exchange Namespace


RegeneratingType Property

Aspose.Email

TaskRegeneratingPattern.RegeneratingType Property

Gets or sets a type of regenerating pattern.

public TaskRegeneratingType RegeneratingType {get; set;}

See Also

TaskRegeneratingPattern Class | Aspose.Email.Exchange Namespace


TaskRegeneratingType Enumeration

Enumerates the types of regenerating pattern.

public enum TaskRegeneratingType

Members

Member Name | Description | Value
Daily | Indicates the daily regenerating pattern. | 0
Weekly | Indicates the weekly regenerating pattern. | 1
Monthly | Indicates the monthly regenerating pattern. | 2
Yearly | Indicates the yearly regenerating pattern. | 3

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange Namespace


UnifiedMessagingConfiguration Class

Unified messaging configuration

For a list of all members of this type, see UnifiedMessagingConfiguration Members.

System.Object
Aspose.Email.Exchange.UnifiedMessagingConfiguration

public class UnifiedMessagingConfiguration

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UnifiedMessagingConfiguration Members | Aspose.Email.Exchange Namespace


UnifiedMessagingConfiguration Members

UnifiedMessagingConfiguration overview

Public Instance Properties

PlayOnPhoneDialString | Play On Phone dial string
PlayOnPhoneEnabled | Indicates whether Play On Phone enabled
UMEnabled | The UMEnabled determines whether a mailbox is enabled for Unified Messaging.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a string which represents the object instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UnifiedMessagingConfiguration Class | Aspose.Email.Exchange Namespace


UnifiedMessagingConfiguration Properties

The properties of the UnifiedMessagingConfiguration class are listed below. For a complete list of UnifiedMessagingConfiguration class members, see the UnifiedMessagingConfiguration Members topic.

Public Instance Properties

PlayOnPhoneDialString | Play On Phone dial string
PlayOnPhoneEnabled | Indicates whether Play On Phone enabled
UMEnabled | The UMEnabled determines whether a mailbox is enabled for Unified Messaging.

See Also

UnifiedMessagingConfiguration Class | Aspose.Email.Exchange Namespace


PlayOnPhoneDialString Property

Aspose.Email

UnifiedMessagingConfiguration.PlayOnPhoneDialString Property

Play On Phone dial string

public string PlayOnPhoneDialString {get; set;}

See Also

UnifiedMessagingConfiguration Class | Aspose.Email.Exchange Namespace


PlayOnPhoneEnabled Property

Aspose.Email

UnifiedMessagingConfiguration.PlayOnPhoneEnabled Property

Indicates whether Play On Phone enabled

public bool PlayOnPhoneEnabled {get; set;}

See Also

UnifiedMessagingConfiguration Class | Aspose.Email.Exchange Namespace


UMEnabled Property

Aspose.Email

UnifiedMessagingConfiguration.UMEnabled Property

The UMEnabled determines whether a mailbox is enabled for Unified Messaging.

public bool UMEnabled {get; set;}

See Also

UnifiedMessagingConfiguration Class | Aspose.Email.Exchange Namespace


UnifiedMessagingConfiguration Methods

The methods of the UnifiedMessagingConfiguration class are listed below. For a complete list of UnifiedMessagingConfiguration class members, see the UnifiedMessagingConfiguration Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a string which represents the object instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UnifiedMessagingConfiguration Class | Aspose.Email.Exchange Namespace


UnifiedMessagingConfiguration.ToString Method

Returns a string which represents the object instance.

public override string ToString();

Return Value

Returns a string which represents the object instance.

See Also

UnifiedMessagingConfiguration Class | Aspose.Email.Exchange Namespace


UpdateTaskOptions Enumeration

Enumerates update task options.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum UpdateTaskOptions

Members

Member Name | Description | Value
None | No specific options are specified. | 0
ForceRewrite | Specifies that the task should be rewritten in any way even if some changes were made after the last operation with the task. | 1

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange Namespace


UserConfiguration Class

Represents user configuration

For a list of all members of this type, see UserConfiguration Members.

System.Object
Aspose.Email.Exchange.UserConfiguration

public sealed class UserConfiguration

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UserConfiguration Members | Aspose.Email.Exchange Namespace


UserConfiguration Members

UserConfiguration overview

Public Instance Constructors

UserConfiguration Constructor Initializes a new instance of the UserConfiguration class

Public Instance Properties

BinaryData | Gets or sets binary data property content.
Dictionary | Gets or sets a set of dictionary property entries.
Id | Gets or sets the user configuration object item identifier.
UserConfigurationName | Gets or sets the user configuration object name.
XmlData | Gets or sets XML data property content.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

UserConfiguration Class | Aspose.Email.Exchange Namespace


UserConfiguration Constructor

Initializes a new instance of the UserConfiguration class

public UserConfiguration(
UserConfigurationName userConfigurationName
);

Parameters

userConfigurationName
A user configuration name

Exceptions

Exception Type | Condition
ArgumentNullException | userConfigurationName is null

See Also

UserConfiguration Class | Aspose.Email.Exchange Namespace


UserConfiguration Properties

The properties of the UserConfiguration class are listed below. For a complete list of UserConfiguration class members, see the UserConfiguration Members topic.

Public Instance Properties

BinaryData | Gets or sets binary data property content.
Dictionary | Gets or sets a set of dictionary property entries.
Id | Gets or sets the user configuration object item identifier.
UserConfigurationName | Gets or sets the user configuration object name.
XmlData | Gets or sets XML data property content.

See Also

UserConfiguration Class | Aspose.Email.Exchange Namespace


BinaryData Property

Aspose.Email

UserConfiguration.BinaryData Property

Gets or sets binary data property content.

public byte[] BinaryData {get; set;}

See Also

UserConfiguration Class | Aspose.Email.Exchange Namespace


Dictionary Property

Aspose.Email

UserConfiguration.Dictionary Property

Gets or sets a set of dictionary property entries.

public Hashtable Dictionary {get;}

See Also

UserConfiguration Class | Aspose.Email.Exchange Namespace


Id Property

Aspose.Email

UserConfiguration.Id Property

Gets or sets the user configuration object item identifier.

public string Id {get; set;}

See Also

UserConfiguration Class | Aspose.Email.Exchange Namespace


UserConfigurationName Property

Aspose.Email

UserConfiguration.UserConfigurationName Property

Gets or sets the user configuration object name.

public UserConfigurationName UserConfigurationName {get; set;}

Exceptions

Exception Type | Condition
ArgumentNullException | value is null

See Also

UserConfiguration Class | Aspose.Email.Exchange Namespace


XmlData Property

Aspose.Email

UserConfiguration.XmlData Property

Gets or sets XML data property content.

public byte[] XmlData {get; set;}

See Also

UserConfiguration Class | Aspose.Email.Exchange Namespace


UserConfigurationName Class

Represents user configuration name

For a list of all members of this type, see UserConfigurationName Members.

System.Object
Aspose.Email.Exchange.UserConfigurationName

public sealed class UserConfigurationName

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UserConfigurationName Members | Aspose.Email.Exchange Namespace


UserConfigurationName Members

UserConfigurationName overview

Public Instance Constructors

UserConfigurationName Constructor Initializes a new instance of the UserConfigurationName class

Public Instance Properties

FolderId | Gets or sets the identifier of folder containing the user configuration object.
Name | Gets or sets the user configuration object name.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

UserConfigurationName Class | Aspose.Email.Exchange Namespace


UserConfigurationName Constructor

Initializes a new instance of the UserConfigurationName class

public UserConfigurationName(
string name,
string folderId
);

Parameters

name
Specifies user configuration name
folderId
Specifies the associated folder for a user configuration object

Exceptions

Exception Type | Condition
ArgumentException | name is null or empty

See Also

UserConfigurationName Class | Aspose.Email.Exchange Namespace


UserConfigurationName Properties

The properties of the UserConfigurationName class are listed below. For a complete list of UserConfigurationName class members, see the UserConfigurationName Members topic.

Public Instance Properties

FolderId | Gets or sets the identifier of folder containing the user configuration object.
Name | Gets or sets the user configuration object name.

See Also

UserConfigurationName Class | Aspose.Email.Exchange Namespace


FolderId Property

Aspose.Email

UserConfigurationName.FolderId Property

Gets or sets the identifier of folder containing the user configuration object.

public string FolderId {get; set;}

Exceptions

Exception Type | Condition
ArgumentException | value is null or empty

See Also

UserConfigurationName Class | Aspose.Email.Exchange Namespace


Name Property

Aspose.Email

UserConfigurationName.Name Property

Gets or sets the user configuration object name.

public string Name {get; set;}

Exceptions

Exception Type | Condition
ArgumentException | value is null or empty

See Also

UserConfigurationName Class | Aspose.Email.Exchange Namespace


Aspose.Email.Exchange.Schema

Aspose.Email

Aspose.Email.Exchange.Schema Namespace

Namespace hierarchy

Classes

Class | Description
AbsoluteDateTransitionType |
AbsoluteMonthlyRecurrencePatternType | Represents a monthly recurrence pattern.
AbsoluteYearlyRecurrencePatternType | Represents a yearly recurrence pattern.
AcceptItemType |
AcceptSharingInvitationType |
AddDelegateCompletedEventArgs |
AddDelegateResponseMessageType |
AddDelegateType |
AggregateOnType |
AlternateIdBaseType |
AlternateIdType |
AlternatePublicFolderIdType |
AlternatePublicFolderItemIdType |
AndType |
AppendToFolderFieldType |
AppendToItemFieldType |
ApplyConversationActionCompletedEventArgs | Provides data for the event
ApplyConversationActionResponseType | Represents the contents of a response that contains the results of an attempt to apply conversation actions to a conversation in a mailbox.
ApplyConversationActionType | Represents the contents of a request to apply actions to a conversation in a mailbox.
ArrayOfDLExpansionType |
ArrayOfGroupedItemsType |
ArrayOfRealItemsType |
ArrayOfResolutionType |
ArrayOfResponseMessagesType |
ArrayOfTimeZoneDefinitionType |
ArrayOfTrackingPropertiesType |
ArrayOfTransitionsType |
AttachmentIdType |
AttachmentInfoResponseMessageType |
AttachmentResponseShapeType |
AttachmentType |
AttendeeConflictData |
AttendeeType |
BaseDelegateResponseMessageType |
BaseDelegateType |
BaseEmailAddressType |
BaseFolderIdType |
BaseFolderType |
BaseGroupByType |
BaseItemIdType |
BaseMoveCopyFolderType |
BaseMoveCopyItemType |
BaseNotificationEventType |
BaseObjectChangedEventType |
BasePagingType |
BasePathToElementType |
BasePermissionType |
BaseRequestType |
BaseResponseMessageType |
BaseSubscriptionRequestType |
BodyType |
CalendarEvent |
CalendarEventDetails |
CalendarFolderType |
CalendarItemType |
CalendarPermissionSetType |
CalendarPermissionType |
CalendarViewType |
CancelCalendarItemType |
ChangeDescriptionType |
CompleteNameType |
ConflictResultsType |
ConnectingSIDType |
ConstantValueType |
ContactItemType |
ContactsFolderType |
ContactsViewType |
ContainsExpressionType |
ConversationActionType | Represents a single action to be applied to a conversation.
ConversationType | Represents a single conversation
ConvertIdCompletedEventArgs |
ConvertIdResponseMessageType |
ConvertIdResponseType |
ConvertIdType |
CopyFolderCompletedEventArgs |
CopyFolderResponseType |
CopyFolderType |
CopyItemCompletedEventArgs |
CopyItemResponseType |
CopyItemType |
CreateAttachmentCompletedEventArgs |
CreateAttachmentResponseType |
CreateAttachmentType |
CreateFolderCompletedEventArgs |
CreateFolderResponseType |
CreateFolderType |
CreateItemCompletedEventArgs |
CreateItemResponseType |
CreateItemType |
CreateManagedFolderCompletedEventArgs |
CreateManagedFolderRequestType |
CreateManagedFolderResponseType |
CreateRuleOperationType | Represents a create rule operation type
CreateUserConfigurationCompletedEventArgs |
CreateUserConfigurationResponseType |
CreateUserConfigurationType |
DailyRecurrencePatternType | Class describes the frequency, in days, in which a calendar item or a task recurs.
DailyRegeneratingPatternType | Class describes the frequency, in days, in which a task is regenerated.
DeclineItemType |
DelegatePermissionsType |
DelegateUserResponseMessageType |
DelegateUserType |
DeleteAttachmentCompletedEventArgs |
DeleteAttachmentResponseMessageType |
DeleteAttachmentResponseType |
DeleteAttachmentType |
DeletedOccurrenceInfoType |
DeleteFolderCompletedEventArgs |
DeleteFolderFieldType |
DeleteFolderResponseType |
DeleteFolderType |
DeleteItemCompletedEventArgs |
DeleteItemFieldType |
DeleteItemResponseType |
DeleteItemType |
DeleteRuleOperationType | Represents a delete rule operation type
DeleteUserConfigurationCompletedEventArgs |
DeleteUserConfigurationResponseType |
DeleteUserConfigurationType |
DirectoryEntryType |
DisconnectPhoneCallCompletedEventArgs |
DisconnectPhoneCallResponseMessageType |
DisconnectPhoneCallType |
DistinguishedFolderIdType |
DistinguishedGroupByType |
DistributionListType |
Duration |
EffectiveRightsType |
EmailAddress |
EmailAddressDictionaryEntryType |
EmailAddressType |
EmptyFolderCompletedEventArgs | Provides data for the event
EmptyFolderResponseType | Represents the results of an attempt to empty folder.
EmptyFolderType | Represents the EmptyFolder request
EncryptedSharedFolderDataType |
EndDateRecurrenceRangeType |
ExchangeImpersonationType |
ExchangeServiceBinding | Obsolete. The ExchangeServiceBinding class contains the methods and properties that are used to send and receive the SOAP messages, set up Exchange impersonation, maintain user credentials, and identify the Exchange Web Services endpoint.
ExcludesType |
ExcludesValueType |
ExistsType |
ExpandDLCompletedEventArgs |
ExpandDLResponseMessageType |
ExpandDLResponseType |
ExpandDLType |
ExportItemsCompletedEventArgs | Provides data for the event
ExportItemsResponseMessageType | Represents a single exported item
ExportItemsResponseType | Represents a response to export items from a mailbox
ExportItemsType | Represents a request to export items out of a mailbox.
ExtendedPropertyType |
FieldOrderType |
FieldURIOrConstantType |
FileAttachmentType |
FindConversationCompletedEventArgs | Provides data for the event
FindConversationResponseMessageType | Represents the results of an attempt to find conversations in folder.
FindConversationType | Represents the search options to use when searching for conversations.
FindFolderCompletedEventArgs |
FindFolderParentType |
FindFolderResponseMessageType |
FindFolderResponseType |
FindFolderType |
FindItemCompletedEventArgs |
FindItemParentType |
FindItemResponseMessageType |
FindItemResponseType |
FindItemType |
FindMailboxStatisticsByKeywordsResponseMessageType |
FindMailboxStatisticsByKeywordsResponseType |
FindMailboxStatisticsByKeywordsType |
FindMessageTrackingReportCompletedEventArgs |
FindMessageTrackingReportRequestType |
FindMessageTrackingReportResponseMessageType |
FindMessageTrackingSearchResultType |
FolderChangeDescriptionType |
FolderChangeType |
FolderIdType | The FolderIdType class identifies a folder.
FolderInfoResponseMessageType |
FolderResponseShapeType |
FolderType |
ForwardItemType |
FractionalPageViewType |
FreeBusyResponseType |
FreeBusyView |
FreeBusyViewOptionsType |
GetAttachmentCompletedEventArgs |
GetAttachmentResponseType |
GetAttachmentType |
GetDelegateCompletedEventArgs |
GetDelegateResponseMessageType |
GetDelegateType |
GetEventsCompletedEventArgs |
GetEventsResponseMessageType |
GetEventsResponseType |
GetEventsType |
GetFolderCompletedEventArgs |
GetFolderResponseType |
GetFolderType |
GetInboxRulesCompletedEventArgs | Provides data for the event
GetInboxRulesRequestType | Represents GetInboxRules request type
GetInboxRulesResponseType | Represents GetInboxRules response type
GetItemCompletedEventArgs |
GetItemResponseType |
GetItemType |
GetMailTipsCompletedEventArgs |
GetMailTipsResponseMessageType |
GetMailTipsType |
GetMessageTrackingReportCompletedEventArgs |
GetMessageTrackingReportRequestType |
GetMessageTrackingReportResponseMessageType |
GetPhoneCallInformationCompletedEventArgs |
GetPhoneCallInformationResponseMessageType |
GetPhoneCallInformationType |
GetRoomListsCompletedEventArgs |
GetRoomListsResponseMessageType |
GetRoomListsType |
GetRoomsCompletedEventArgs |
GetRoomsResponseMessageType |
GetRoomsType |
GetServerTimeZonesCompletedEventArgs |
GetServerTimeZonesResponseMessageType |
GetServerTimeZonesResponseType |
GetServerTimeZonesType |
GetServiceConfigurationCompletedEventArgs |
GetServiceConfigurationResponseMessageType |
GetServiceConfigurationType |
GetSharingFolderCompletedEventArgs |
GetSharingFolderResponseMessageType |
GetSharingFolderType |
GetSharingMetadataCompletedEventArgs |
GetSharingMetadataResponseMessageType |
GetSharingMetadataType |
GetStreamingEventsCompletedEventArgs |
GetStreamingEventsResponseMessageType |
GetStreamingEventsResponseType |
GetStreamingEventsType |
GetUserAvailabilityCompletedEventArgs |
GetUserAvailabilityRequestType |
GetUserAvailabilityResponseType |
GetUserConfigurationCompletedEventArgs |
GetUserConfigurationResponseMessageType |
GetUserConfigurationResponseType |
GetUserConfigurationType |
GetUserOofSettingsCompletedEventArgs |
GetUserOofSettingsRequest |
GetUserOofSettingsResponse |
GroupAttendeeConflictData |
GroupByType |
GroupedItemsType |
ImAddressDictionaryEntryType |
IndexedPageViewType |
IndividualAttendeeConflictData |
InternetHeaderType |
IntervalRecurrencePatternBaseType |
InvalidRecipientType |
IsEqualToType |
IsGreaterThanOrEqualToType |
IsGreaterThanType |
IsLessThanOrEqualToType |
IsLessThanType |
IsNotEqualToType |
ItemAttachmentType |
ItemChangeDescriptionType |
ItemChangeType |
ItemIdType | The ItemIdType class represents an item identifier of an item in an Exchange mailbox.
ItemInfoResponseMessageType |
ItemResponseShapeType |
ItemType |
KeywordStatisticsSearchResultType |
MailboxCultureType |
MailboxData |
MailboxStatisticsSearchResultType |
MailTips |
MailTipsResponseMessageType |
MailTipsServiceConfiguration |
ManagedFolderInformationType |
MeetingCancellationMessageType |
MeetingMessageType |
MeetingRequestMessageType |
MeetingResponseMessageType |
MemberType |
MessageTrackingReportType |
MessageType |
MimeContentType |
ModifiedEventType |
MonthlyRegeneratingPatternType | Class describes the interval, in months, in which a task is regenerated.
MovedCopiedEventType |
MoveFolderCompletedEventArgs |
MoveFolderResponseType |
MoveFolderType |
MoveItemCompletedEventArgs |
MoveItemResponseType |
MoveItemType |
MultipleOperandBooleanExpressionType |
NoEndRecurrenceRangeType |
NonEmptyArrayOfAllItemsType |
NonEmptyArrayOfPropertyValuesType |
NotificationType |
NotType |
NumberedRecurrenceRangeType |
OccurrenceInfoType |
OccurrenceItemIdType |
OrType |
OutOfOfficeMailTip |
PathToExceptionFieldType |
PathToExtendedFieldType |
PathToIndexedFieldType |
PathToUnindexedFieldType |
PeriodType |
PermissionSetType |
PermissionType |
PhoneCallIdType |
PhoneCallInformationType |
PhoneNumberDictionaryEntryType |
PhysicalAddressDictionaryEntryType |
PlayOnPhoneCompletedEventArgs |
PlayOnPhoneResponseMessageType |
PlayOnPhoneType |
PostItemType |
PostReplyItemBaseType |
PostReplyItemType |
ProtectionRuleActionType |
ProtectionRuleAndType |
ProtectionRuleArgumentType |
ProtectionRuleConditionType |
ProtectionRuleRecipientIsType |
ProtectionRuleSenderDepartmentsType |
ProtectionRulesServiceConfiguration |
ProtectionRuleType |
PullSubscriptionRequestType |
PushSubscriptionRequestType |
RecipientTrackingEventType |
RecurrencePatternBaseType | Class is the abstract base class for all recurrence patterns.
RecurrenceRangeBaseType |
RecurrenceType |
RecurringDateTransitionType |
RecurringDayTransitionType |
RecurringMasterItemIdType |
RecurringTimeTransitionType |
ReferenceItemResponseType |
RefreshSharingFolderCompletedEventArgs |
RefreshSharingFolderResponseMessageType |
RefreshSharingFolderType |
RegeneratingPatternBaseType |
RelativeMonthlyRecurrencePatternType | Class describes a relative monthly recurrence pattern.
RelativeYearlyRecurrencePatternType | Class describes a relative yearly recurrence pattern.
RemoveDelegateCompletedEventArgs |
RemoveDelegateResponseMessageType |
RemoveDelegateType |
RemoveItemType |
ReplyAllToItemType |
ReplyBody |
ReplyToItemType |
RequestAttachmentIdType |
RequestServerVersion |
ResolutionType |
ResolveNamesCompletedEventArgs |
ResolveNamesResponseMessageType |
ResolveNamesResponseType |
ResolveNamesType |
ResponseMessageType |
ResponseMessageTypeMessageXml |
ResponseObjectCoreType |
ResponseObjectType |
RestrictionType |
RoomType |
RootItemIdType |
RuleActionsType | Represents RuleActionType
RuleOperationErrorType | Represents a rule operation error.
RuleOperationType | Represents the base rule operation type
RulePredicateDateRangeType | Represents RulePredicateDateRangeType class
RulePredicateSizeRangeType | Represents RulePredicateSizeRangeType class
RulePredicatesType | Represents RulePredicatesType
RuleType | Represents RuleType
RuleValidationErrorType | Represents a single validation error on a particular rule property value, predicate property value, or action property value
SearchExpressionType |
SearchFolderType |
SearchParametersType |
SendItemCompletedEventArgs |
SendItemResponseType |
SendItemType |
SendNotificationResponseMessageType |
SendNotificationResponseType |
SerializableTimeZone |
SerializableTimeZoneTime | Specifies a time and a time zone for a meeting suggestion.
ServerVersionInfo | The ServerVersionInfo class contains the Microsoft Exchange Server version number.
ServiceConfiguration |
ServiceConfigurationResponseMessageType |
SetFolderFieldType |
SetItemFieldType |
SetRuleOperationType | Represents a update rule operation type
SetUserOofSettingsCompletedEventArgs |
SetUserOofSettingsRequest |
SetUserOofSettingsResponse |
SingleRecipientType |
SmartResponseBaseType |
SmartResponseType |
SmtpDomain |
StreamingSubscriptionRequestType |
SubscribeCompletedEventArgs |
SubscribeResponseMessageType |
SubscribeResponseType |
SubscribeType |
Suggestion |
SuggestionDayResult |
SuggestionsResponseType |
SuggestionsViewOptionsType |
SuppressReadReceiptType |
SyncFolderHierarchyChangesType |
SyncFolderHierarchyCompletedEventArgs |
SyncFolderHierarchyCreateOrUpdateType |
SyncFolderHierarchyDeleteType |
SyncFolderHierarchyResponseMessageType |
SyncFolderHierarchyResponseType |
SyncFolderHierarchyType |
SyncFolderItemsChangesType |
SyncFolderItemsCompletedEventArgs |
SyncFolderItemsCreateOrUpdateType |
SyncFolderItemsDeleteType |
SyncFolderItemsReadFlagType |
SyncFolderItemsResponseMessageType |
SyncFolderItemsResponseType |
SyncFolderItemsType |
TargetFolderIdType |
TaskRecurrenceType | Class contains the recurrence pattern for tasks.
TasksFolderType |
TaskType |
TentativelyAcceptItemType |
TimeChangeType |
TimeZoneContextType |
TimeZoneDefinitionType |
TimeZoneType |
TooBigGroupAttendeeConflictData |
TrackingPropertyType |
TransitionTargetType |
TransitionType |
TwoOperandExpressionType |
UnifiedMessageServiceConfiguration |
UnknownAttendeeConflictData |
UnsubscribeCompletedEventArgs |
UnsubscribeResponseType |
UnsubscribeType |
UpdateDelegateCompletedEventArgs |
UpdateDelegateResponseMessageType |
UpdateDelegateType |
UpdateFolderCompletedEventArgs |
UpdateFolderResponseType |
UpdateFolderType |
UpdateInboxRulesCompletedEventArgs | Provides data for the event
UpdateInboxRulesRequestType | Represents update inbox rules request
UpdateInboxRulesResponseType | Represents the update inbox rules response type
UpdateItemCompletedEventArgs |
UpdateItemResponseMessageType |
UpdateItemResponseType |
UpdateItemType |
UpdateUserConfigurationCompletedEventArgs |
UpdateUserConfigurationResponseType |
UpdateUserConfigurationType |
UploadItemsCompletedEventArgs | Provides data for the event
UploadItemsResponseMessageType | Represents the item identifier of an item that was uploaded into a mailbox.
UploadItemsResponseType | Represents the response messages for which an attempt was made to update into a mailbox.
UploadItemsType | Represents the contents of a request to upload items in to a mailbox.
UploadItemType | Represents the contents of a single item to upload in to a mailbox.
UserConfigurationDictionaryEntryType |
UserConfigurationDictionaryObjectType |
UserConfigurationNameType |
UserConfigurationType |
UserIdType |
UserMailboxType |
UserOofSettings |
WeeklyRecurrencePatternType | Class describes the frequency, in weeks, in which an item recurs, and the days on which the item recurs.
WeeklyRegeneratingPatternType | Class describes the interval, in weeks, in which a task is regenerated.
WellKnownResponseObjectType |
WorkingHours |
WorkingPeriod |
YearlyRegeneratingPatternType | Class describes the interval, in years, in which a task is regenerated.

Delegates

Delegate | Description
AddDelegateCompletedEventHandler |
ApplyConversationActionCompletedEventHandler | Represents the method that will handle the ApplyConversationActionCompleted event
ConvertIdCompletedEventHandler |
CopyFolderCompletedEventHandler |
CopyItemCompletedEventHandler |
CreateAttachmentCompletedEventHandler |
CreateFolderCompletedEventHandler |
CreateItemCompletedEventHandler |
CreateManagedFolderCompletedEventHandler |
CreateUserConfigurationCompletedEventHandler |
DeleteAttachmentCompletedEventHandler |
DeleteFolderCompletedEventHandler |
DeleteItemCompletedEventHandler |
DeleteUserConfigurationCompletedEventHandler |
DisconnectPhoneCallCompletedEventHandler |
EmptyFolderCompletedEventHandler | Represents the method that will handle the EmptyFolderCompleted event
ExpandDLCompletedEventHandler |
ExportItemsCompletedEventHandler | Represents the method that will handle the ExportItemsCompleted event
FindConversationCompletedEventHandler | Represents the method that will handle the FindConversationCompleted event
FindFolderCompletedEventHandler |
FindItemCompletedEventHandler |
FindMessageTrackingReportCompletedEventHandler |
GetAttachmentCompletedEventHandler |
GetDelegateCompletedEventHandler |
GetEventsCompletedEventHandler |
GetFolderCompletedEventHandler |
GetInboxRulesCompletedEventHandler | Represents the method that will handle the UpdateInboxRulesCompleted event
GetItemCompletedEventHandler |
GetMailTipsCompletedEventHandler |
GetMessageTrackingReportCompletedEventHandler |
GetPhoneCallInformationCompletedEventHandler |
GetRoomListsCompletedEventHandler |
GetRoomsCompletedEventHandler |
GetServerTimeZonesCompletedEventHandler |
GetServiceConfigurationCompletedEventHandler |
GetSharingFolderCompletedEventHandler |
GetSharingMetadataCompletedEventHandler |
GetStreamingEventsCompletedEventHandler |
GetUserAvailabilityCompletedEventHandler |
GetUserConfigurationCompletedEventHandler |
GetUserOofSettingsCompletedEventHandler |
MoveFolderCompletedEventHandler |
MoveItemCompletedEventHandler |
PlayOnPhoneCompletedEventHandler |
RefreshSharingFolderCompletedEventHandler |
RemoveDelegateCompletedEventHandler |
ResolveNamesCompletedEventHandler |
SendItemCompletedEventHandler |
SetUserOofSettingsCompletedEventHandler |
SubscribeCompletedEventHandler |
SyncFolderHierarchyCompletedEventHandler |
SyncFolderItemsCompletedEventHandler |
UnsubscribeCompletedEventHandler |
UpdateDelegateCompletedEventHandler |
UpdateFolderCompletedEventHandler |
UpdateInboxRulesCompletedEventHandler | Represents the method that will handle the GetInboxRulesCompleted event
UpdateItemCompletedEventHandler |
UpdateUserConfigurationCompletedEventHandler |
UploadItemsCompletedEventHandler | Represents the method that will handle the UploadItemsCompleted event

Enumerations

Enumeration | Description
AffectedTaskOccurrencesType |
AggregateType |
BodyTypeResponseType |
BodyTypeType |
CalendarItemCreateOrDeleteOperationType |
CalendarItemTypeType |
CalendarItemUpdateOperationType |
CalendarPermissionLevelType |
CalendarPermissionReadAccessType |
ConflictResolutionType |
ConnectionFailureCauseType |
ConnectionStatusType |
ContactSourceType |
ContainmentComparisonType |
ContainmentModeType |
ConversationActionTypeType | Enumerates the action to apply to items in a conversation.
CreateActionType | Obsolete. Enumerates the action for uploading items into a mailbox
DayOfWeekIndexType |
DayOfWeekType |
DefaultShapeNamesType |
DelegateFolderPermissionLevelType |
DeliverMeetingRequestsType |
DictionaryURIType |
DisposalType |
DistinguishedFolderIdNameType |
DistinguishedPropertySetType |
DistinguishedUserType |
EmailAddressKeyType |
ExceptionPropertyURIType |
ExchangeVersionType |
ExternalAudience |
FileAsMappingType |
FlaggedForActionType | Enumerates FlaggedForActionType
FlagStatusType | Enumerates the flag status for conversation items.
FolderQueryTraversalType |
FreeBusyViewType |
IdFormatType |
ImAddressKeyType |
ImportanceChoicesType |
IndexBasePointType |
InvalidRecipientResponseCodeType |
ItemChoiceType |
ItemChoiceType1 |
ItemQueryTraversalType |
ItemsChoiceType |
ItemsChoiceType1 |
ItemsChoiceType2 |
ItemsChoiceType3 |
ItemsChoiceType4 |
LegacyFreeBusyType |
MailboxTypeType |
MailTipTypes |
MapiPropertyTypeType |
MeetingAttendeeType |
MeetingRequestTypeType |
MemberStatusType |
MessageDispositionType |
MessageTrackingDeliveryStatusType |
MessageTrackingEventDescriptionType |
MessageTrackingReportTemplateType |
MessageTrackingScopeType |
MonthNamesType |
NotificationEventTypeType |
OofState |
PermissionActionType |
PermissionLevelType |
PermissionReadAccessType |
PhoneCallStateType |
PhoneNumberKeyType |
PhysicalAddressIndexType |
PhysicalAddressKeyType |
ProtectionRuleActionKindType |
ResolveNamesSearchScopeType |
ResponseClassType |
ResponseCodeType |
ResponseTypeType |
RuleFieldURIType | Enumerates all possible rule fields that could trigger a validation error.
RuleValidationErrorCodeType | Enumerates rule validation error codes
SearchFolderTraversalType |
SearchItemKindType |
SensitivityChoicesType |
ServiceConfigurationType |
SharingDataType |
SortDirectionType |
StandardGroupByType |
SuggestionQuality |
SyncFolderItemsScopeType |
TaskDelegateStateType |
TaskStatusType |
TransitionTargetKindType |
UnindexedFieldURIType |
UserConfigurationDictionaryObjectTypesType |
UserConfigurationPropertyType |


AbsoluteDateTransitionType Class

For a list of all members of this type, see AbsoluteDateTransitionType Members.

System.Object
Aspose.Email.Exchange.Schema.TransitionType
Aspose.Email.Exchange.Schema.AbsoluteDateTransitionType

public class AbsoluteDateTransitionType : TransitionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AbsoluteDateTransitionType Members | Aspose.Email.Exchange.Schema Namespace


AbsoluteDateTransitionType Members

AbsoluteDateTransitionType overview

Public Instance Constructors

AbsoluteDateTransitionType Constructor Initializes a new instance of the AbsoluteDateTransitionType class.

Public Instance Properties

DateTime
To (inherited from TransitionType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AbsoluteDateTransitionType Class | Aspose.Email.Exchange.Schema Namespace


AbsoluteDateTransitionType Constructor

Initializes a new instance of the AbsoluteDateTransitionType class.

public AbsoluteDateTransitionType();

See Also

AbsoluteDateTransitionType Class | Aspose.Email.Exchange.Schema Namespace


AbsoluteDateTransitionType Properties

The properties of the AbsoluteDateTransitionType class are listed below. For a complete list of AbsoluteDateTransitionType class members, see the AbsoluteDateTransitionType Members topic.

Public Instance Properties

DateTime
To (inherited from TransitionType)

See Also

AbsoluteDateTransitionType Class | Aspose.Email.Exchange.Schema Namespace


DateTime Property

Aspose.Email

AbsoluteDateTransitionType.DateTime Property

public DateTime DateTime {get; set;}

Remarks

See Also

AbsoluteDateTransitionType Class | Aspose.Email.Exchange.Schema Namespace


AbsoluteMonthlyRecurrencePatternType Class

Represents a monthly recurrence pattern.

For a list of all members of this type, see AbsoluteMonthlyRecurrencePatternType Members.

System.Object
Aspose.Email.Exchange.Schema.RecurrencePatternBaseType
Aspose.Email.Exchange.Schema.IntervalRecurrencePatternBaseType
Aspose.Email.Exchange.Schema.AbsoluteMonthlyRecurrencePatternType

public class AbsoluteMonthlyRecurrencePatternType : IntervalRecurrencePatternBaseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AbsoluteMonthlyRecurrencePatternType Members | Aspose.Email.Exchange.Schema Namespace


AbsoluteMonthlyRecurrencePatternType Members

AbsoluteMonthlyRecurrencePatternType overview

Public Instance Constructors

AbsoluteMonthlyRecurrencePatternType Constructor Initializes a new instance of the AbsoluteMonthlyRecurrencePatternType class.

Public Instance Properties

DayOfMonth
Interval (inherited from IntervalRecurrencePatternBaseType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AbsoluteMonthlyRecurrencePatternType Class | Aspose.Email.Exchange.Schema Namespace


AbsoluteMonthlyRecurrencePatternType Constructor

Initializes a new instance of the AbsoluteMonthlyRecurrencePatternType class.

public AbsoluteMonthlyRecurrencePatternType();

See Also

AbsoluteMonthlyRecurrencePatternType Class | Aspose.Email.Exchange.Schema Namespace


AbsoluteMonthlyRecurrencePatternType Properties

The properties of the AbsoluteMonthlyRecurrencePatternType class are listed below. For a complete list of AbsoluteMonthlyRecurrencePatternType class members, see the AbsoluteMonthlyRecurrencePatternType Members topic.

Public Instance Properties

DayOfMonth
Interval (inherited from IntervalRecurrencePatternBaseType)

See Also

AbsoluteMonthlyRecurrencePatternType Class | Aspose.Email.Exchange.Schema Namespace


DayOfMonth Property

Aspose.Email

AbsoluteMonthlyRecurrencePatternType.DayOfMonth Property

public int DayOfMonth {get; set;}

Remarks

See Also

AbsoluteMonthlyRecurrencePatternType Class | Aspose.Email.Exchange.Schema Namespace


AbsoluteYearlyRecurrencePatternType Class

Represents a yearly recurrence pattern.

For a list of all members of this type, see AbsoluteYearlyRecurrencePatternType Members.

System.Object
Aspose.Email.Exchange.Schema.RecurrencePatternBaseType
Aspose.Email.Exchange.Schema.AbsoluteYearlyRecurrencePatternType

public class AbsoluteYearlyRecurrencePatternType : RecurrencePatternBaseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AbsoluteYearlyRecurrencePatternType Members | Aspose.Email.Exchange.Schema Namespace


AbsoluteYearlyRecurrencePatternType Members

AbsoluteYearlyRecurrencePatternType overview

Public Instance Constructors

AbsoluteYearlyRecurrencePatternType Constructor Initializes a new instance of the AbsoluteYearlyRecurrencePatternType class.

Public Instance Properties

DayOfMonth
Month

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AbsoluteYearlyRecurrencePatternType Class | Aspose.Email.Exchange.Schema Namespace


AbsoluteYearlyRecurrencePatternType Constructor

Initializes a new instance of the AbsoluteYearlyRecurrencePatternType class.

public AbsoluteYearlyRecurrencePatternType();

See Also

AbsoluteYearlyRecurrencePatternType Class | Aspose.Email.Exchange.Schema Namespace


AbsoluteYearlyRecurrencePatternType Properties

The properties of the AbsoluteYearlyRecurrencePatternType class are listed below. For a complete list of AbsoluteYearlyRecurrencePatternType class members, see the AbsoluteYearlyRecurrencePatternType Members topic.

Public Instance Properties

DayOfMonth
Month

See Also

AbsoluteYearlyRecurrencePatternType Class | Aspose.Email.Exchange.Schema Namespace


DayOfMonth Property

Aspose.Email

AbsoluteYearlyRecurrencePatternType.DayOfMonth Property

public int DayOfMonth {get; set;}

Remarks

See Also

AbsoluteYearlyRecurrencePatternType Class | Aspose.Email.Exchange.Schema Namespace


Month Property

Aspose.Email

AbsoluteYearlyRecurrencePatternType.Month Property

public MonthNamesType Month {get; set;}

Remarks

See Also

AbsoluteYearlyRecurrencePatternType Class | Aspose.Email.Exchange.Schema Namespace


AcceptItemType Class

For a list of all members of this type, see AcceptItemType Members.

System.Object
Aspose.Email.Exchange.Schema.ItemType
Aspose.Email.Exchange.Schema.MessageType
Aspose.Email.Exchange.Schema.ResponseObjectCoreType
Aspose.Email.Exchange.Schema.ResponseObjectType
Aspose.Email.Exchange.Schema.WellKnownResponseObjectType
Aspose.Email.Exchange.Schema.AcceptItemType

public class AcceptItemType : WellKnownResponseObjectType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AcceptItemType Members | Aspose.Email.Exchange.Schema Namespace


AcceptItemType Members

AcceptItemType overview

Public Instance Constructors

AcceptItemType Constructor Initializes a new instance of the AcceptItemType class.

Public Instance Properties

Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
From (inherited from MessageType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
ObjectName (inherited from ResponseObjectType)
ParentFolderId (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
ReferenceItemId (inherited from ResponseObjectCoreType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
Subject (inherited from ItemType)
ToRecipients (inherited from MessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AcceptItemType Class | Aspose.Email.Exchange.Schema Namespace


AcceptItemType Constructor

Initializes a new instance of the AcceptItemType class.

public AcceptItemType();

See Also

AcceptItemType Class | Aspose.Email.Exchange.Schema Namespace


AcceptSharingInvitationType Class

For a list of all members of this type, see AcceptSharingInvitationType Members.

System.Object
Aspose.Email.Exchange.Schema.ItemType
Aspose.Email.Exchange.Schema.MessageType
Aspose.Email.Exchange.Schema.ResponseObjectCoreType
Aspose.Email.Exchange.Schema.ResponseObjectType
Aspose.Email.Exchange.Schema.ReferenceItemResponseType
Aspose.Email.Exchange.Schema.AcceptSharingInvitationType

public class AcceptSharingInvitationType : ReferenceItemResponseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AcceptSharingInvitationType Members | Aspose.Email.Exchange.Schema Namespace


AcceptSharingInvitationType Members

AcceptSharingInvitationType overview

Public Instance Constructors

AcceptSharingInvitationType Constructor Initializes a new instance of the AcceptSharingInvitationType class.

Public Instance Properties

Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
From (inherited from MessageType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
ObjectName (inherited from ResponseObjectType)
ParentFolderId (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
ReferenceItemId (inherited from ResponseObjectCoreType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
Subject (inherited from ItemType)
ToRecipients (inherited from MessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AcceptSharingInvitationType Class | Aspose.Email.Exchange.Schema Namespace


AcceptSharingInvitationType Constructor

Initializes a new instance of the AcceptSharingInvitationType class.

public AcceptSharingInvitationType();

See Also

AcceptSharingInvitationType Class | Aspose.Email.Exchange.Schema Namespace


AddDelegateCompletedEventArgs Class

For a list of all members of this type, see AddDelegateCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.AddDelegateCompletedEventArgs

public class AddDelegateCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AddDelegateCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


AddDelegateCompletedEventArgs Members

AddDelegateCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

AddDelegateCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


AddDelegateCompletedEventArgs Properties

The properties of the AddDelegateCompletedEventArgs class are listed below. For a complete list of AddDelegateCompletedEventArgs class members, see the AddDelegateCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

AddDelegateCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

AddDelegateCompletedEventArgs.Result Property

public AddDelegateResponseMessageType Result {get;}

Remarks

See Also

AddDelegateCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


AddDelegateCompletedEventHandler Delegate

public delegate void AddDelegateCompletedEventHandler(
object sender,
AddDelegateCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


AddDelegateResponseMessageType Class

For a list of all members of this type, see AddDelegateResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ResponseMessageType
Aspose.Email.Exchange.Schema.BaseDelegateResponseMessageType
Aspose.Email.Exchange.Schema.AddDelegateResponseMessageType

public class AddDelegateResponseMessageType : BaseDelegateResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AddDelegateResponseMessageType Members | Aspose.Email.Exchange.Schema Namespace


AddDelegateResponseMessageType Members

AddDelegateResponseMessageType overview

Public Instance Constructors

AddDelegateResponseMessageType Constructor Initializes a new instance of the AddDelegateResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
ResponseMessages (inherited from BaseDelegateResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AddDelegateResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


AddDelegateResponseMessageType Constructor

Initializes a new instance of the AddDelegateResponseMessageType class.

public AddDelegateResponseMessageType();

See Also

AddDelegateResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


AddDelegateType Class

For a list of all members of this type, see AddDelegateType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.BaseDelegateType
Aspose.Email.Exchange.Schema.AddDelegateType

public class AddDelegateType : BaseDelegateType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AddDelegateType Members | Aspose.Email.Exchange.Schema Namespace


AddDelegateType Members

AddDelegateType overview

Public Instance Constructors

AddDelegateType Constructor Initializes a new instance of the AddDelegateType class.

Public Instance Properties

DelegateUsers
DeliverMeetingRequests
DeliverMeetingRequestsSpecified
Mailbox (inherited from BaseDelegateType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AddDelegateType Class | Aspose.Email.Exchange.Schema Namespace


AddDelegateType Constructor

Initializes a new instance of the AddDelegateType class.

public AddDelegateType();

See Also

AddDelegateType Class | Aspose.Email.Exchange.Schema Namespace


AddDelegateType Properties

The properties of the AddDelegateType class are listed below. For a complete list of AddDelegateType class members, see the AddDelegateType Members topic.

Public Instance Properties

DelegateUsers
DeliverMeetingRequests
DeliverMeetingRequestsSpecified
Mailbox (inherited from BaseDelegateType)

See Also

AddDelegateType Class | Aspose.Email.Exchange.Schema Namespace


DelegateUsers Property

Aspose.Email

AddDelegateType.DelegateUsers Property

public DelegateUserType[] DelegateUsers {get; set;}

Remarks

See Also

AddDelegateType Class | Aspose.Email.Exchange.Schema Namespace


DeliverMeetingRequests Property

Aspose.Email

AddDelegateType.DeliverMeetingRequests Property

public DeliverMeetingRequestsType DeliverMeetingRequests {get; set;}

Remarks

See Also

AddDelegateType Class | Aspose.Email.Exchange.Schema Namespace


DeliverMeetingRequestsSpecified Property

Aspose.Email

AddDelegateType.DeliverMeetingRequestsSpecified Property

public bool DeliverMeetingRequestsSpecified {get; set;}

Remarks

See Also

AddDelegateType Class | Aspose.Email.Exchange.Schema Namespace


AffectedTaskOccurrencesType Enumeration

public enum AffectedTaskOccurrencesType

Remarks

Members

Member Name | Description | Value
AllOccurrences |  | 0
SpecifiedOccurrenceOnly |  | 1

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


AggregateOnType Class

For a list of all members of this type, see AggregateOnType Members.

System.Object
Aspose.Email.Exchange.Schema.AggregateOnType

public class AggregateOnType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AggregateOnType Members | Aspose.Email.Exchange.Schema Namespace


AggregateOnType Members

AggregateOnType overview

Public Instance Constructors

AggregateOnType Constructor Initializes a new instance of the AggregateOnType class.

Public Instance Properties

Aggregate
Item

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AggregateOnType Class | Aspose.Email.Exchange.Schema Namespace


AggregateOnType Constructor

Initializes a new instance of the AggregateOnType class.

public AggregateOnType();

See Also

AggregateOnType Class | Aspose.Email.Exchange.Schema Namespace


AggregateOnType Properties

The properties of the AggregateOnType class are listed below. For a complete list of AggregateOnType class members, see the AggregateOnType Members topic.

Public Instance Properties

Aggregate
Item

See Also

AggregateOnType Class | Aspose.Email.Exchange.Schema Namespace


Aggregate Property

Aspose.Email

AggregateOnType.Aggregate Property

public AggregateType Aggregate {get; set;}

Remarks

See Also

AggregateOnType Class | Aspose.Email.Exchange.Schema Namespace


Item Property

Aspose.Email

AggregateOnType.Item Property

public BasePathToElementType Item {get; set;}

Remarks

See Also

AggregateOnType Class | Aspose.Email.Exchange.Schema Namespace


AggregateType Enumeration

public enum AggregateType

Remarks

Members

Member Name | Description | Value
Minimum |  | 0
Maximum |  | 1

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


AlternateIdBaseType Class

For a list of all members of this type, see AlternateIdBaseType Members.

System.Object
Aspose.Email.Exchange.Schema.AlternateIdBaseType
Aspose.Email.Exchange.Schema.AlternateIdType
Aspose.Email.Exchange.Schema.AlternatePublicFolderIdType

public abstract class AlternateIdBaseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AlternateIdBaseType Members | Aspose.Email.Exchange.Schema Namespace


AlternateIdBaseType Members

AlternateIdBaseType overview

Public Instance Properties

Format

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

AlternateIdBaseType Constructor Initializes a new instance of the AlternateIdBaseType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AlternateIdBaseType Class | Aspose.Email.Exchange.Schema Namespace


AlternateIdBaseType Constructor

Initializes a new instance of the AlternateIdBaseType class.

protected AlternateIdBaseType();

See Also

AlternateIdBaseType Class | Aspose.Email.Exchange.Schema Namespace


AlternateIdBaseType Properties

The properties of the AlternateIdBaseType class are listed below. For a complete list of AlternateIdBaseType class members, see the AlternateIdBaseType Members topic.

Public Instance Properties

Format

See Also

AlternateIdBaseType Class | Aspose.Email.Exchange.Schema Namespace


Format Property

Aspose.Email

AlternateIdBaseType.Format Property

public IdFormatType Format {get; set;}

Remarks

See Also

AlternateIdBaseType Class | Aspose.Email.Exchange.Schema Namespace


AlternateIdType Class

For a list of all members of this type, see AlternateIdType Members.

System.Object
Aspose.Email.Exchange.Schema.AlternateIdBaseType
Aspose.Email.Exchange.Schema.AlternateIdType

public class AlternateIdType : AlternateIdBaseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AlternateIdType Members | Aspose.Email.Exchange.Schema Namespace


AlternateIdType Members

AlternateIdType overview

Public Instance Constructors

AlternateIdType Constructor Initializes a new instance of the AlternateIdType class.

Public Instance Properties

Format (inherited from AlternateIdBaseType)
Id
IsArchive
IsArchiveSpecified
Mailbox

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AlternateIdType Class | Aspose.Email.Exchange.Schema Namespace


AlternateIdType Constructor

Initializes a new instance of the AlternateIdType class.

public AlternateIdType();

See Also

AlternateIdType Class | Aspose.Email.Exchange.Schema Namespace


AlternateIdType Properties

The properties of the AlternateIdType class are listed below. For a complete list of AlternateIdType class members, see the AlternateIdType Members topic.

Public Instance Properties

Format (inherited from AlternateIdBaseType)
Id
IsArchive
IsArchiveSpecified
Mailbox

See Also

AlternateIdType Class | Aspose.Email.Exchange.Schema Namespace


Id Property

Aspose.Email

AlternateIdType.Id Property

public string Id {get; set;}

Remarks

See Also

AlternateIdType Class | Aspose.Email.Exchange.Schema Namespace


IsArchive Property

Aspose.Email

AlternateIdType.IsArchive Property

public bool IsArchive {get; set;}

Remarks

See Also

AlternateIdType Class | Aspose.Email.Exchange.Schema Namespace


IsArchiveSpecified Property

Aspose.Email

AlternateIdType.IsArchiveSpecified Property

public bool IsArchiveSpecified {get; set;}

Remarks

See Also

AlternateIdType Class | Aspose.Email.Exchange.Schema Namespace


Mailbox Property

Aspose.Email

AlternateIdType.Mailbox Property

public string Mailbox {get; set;}

Remarks

See Also

AlternateIdType Class | Aspose.Email.Exchange.Schema Namespace


AlternatePublicFolderIdType Class

For a list of all members of this type, see AlternatePublicFolderIdType Members.

System.Object
Aspose.Email.Exchange.Schema.AlternateIdBaseType
Aspose.Email.Exchange.Schema.AlternatePublicFolderIdType
Aspose.Email.Exchange.Schema.AlternatePublicFolderItemIdType

public class AlternatePublicFolderIdType : AlternateIdBaseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AlternatePublicFolderIdType Members | Aspose.Email.Exchange.Schema Namespace


AlternatePublicFolderIdType Members

AlternatePublicFolderIdType overview

Public Instance Constructors

AlternatePublicFolderIdType Constructor Initializes a new instance of the AlternatePublicFolderIdType class.

Public Instance Properties

FolderId
Format (inherited from AlternateIdBaseType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AlternatePublicFolderIdType Class | Aspose.Email.Exchange.Schema Namespace


AlternatePublicFolderIdType Constructor

Initializes a new instance of the AlternatePublicFolderIdType class.

public AlternatePublicFolderIdType();

See Also

AlternatePublicFolderIdType Class | Aspose.Email.Exchange.Schema Namespace


AlternatePublicFolderIdType Properties

The properties of the AlternatePublicFolderIdType class are listed below. For a complete list of AlternatePublicFolderIdType class members, see the AlternatePublicFolderIdType Members topic.

Public Instance Properties

FolderId
Format (inherited from AlternateIdBaseType)

See Also

AlternatePublicFolderIdType Class | Aspose.Email.Exchange.Schema Namespace


FolderId Property

Aspose.Email

AlternatePublicFolderIdType.FolderId Property

public string FolderId {get; set;}

Remarks

See Also

AlternatePublicFolderIdType Class | Aspose.Email.Exchange.Schema Namespace


AlternatePublicFolderItemIdType Class

For a list of all members of this type, see AlternatePublicFolderItemIdType Members.

System.Object
Aspose.Email.Exchange.Schema.AlternateIdBaseType
Aspose.Email.Exchange.Schema.AlternatePublicFolderIdType
Aspose.Email.Exchange.Schema.AlternatePublicFolderItemIdType

public class AlternatePublicFolderItemIdType : AlternatePublicFolderIdType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AlternatePublicFolderItemIdType Members | Aspose.Email.Exchange.Schema Namespace


AlternatePublicFolderItemIdType Members

AlternatePublicFolderItemIdType overview

Public Instance Constructors

AlternatePublicFolderItemIdType Constructor Initializes a new instance of the AlternatePublicFolderItemIdType class.

Public Instance Properties

FolderId (inherited from AlternatePublicFolderIdType)
Format (inherited from AlternateIdBaseType)
ItemId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AlternatePublicFolderItemIdType Class | Aspose.Email.Exchange.Schema Namespace


AlternatePublicFolderItemIdType Constructor

Initializes a new instance of the AlternatePublicFolderItemIdType class.

public AlternatePublicFolderItemIdType();

See Also

AlternatePublicFolderItemIdType Class | Aspose.Email.Exchange.Schema Namespace


AlternatePublicFolderItemIdType Properties

The properties of the AlternatePublicFolderItemIdType class are listed below. For a complete list of AlternatePublicFolderItemIdType class members, see the AlternatePublicFolderItemIdType Members topic.

Public Instance Properties

FolderId (inherited from AlternatePublicFolderIdType)
Format (inherited from AlternateIdBaseType)
ItemId

See Also

AlternatePublicFolderItemIdType Class | Aspose.Email.Exchange.Schema Namespace


ItemId Property

Aspose.Email

AlternatePublicFolderItemIdType.ItemId Property

public string ItemId {get; set;}

Remarks

See Also

AlternatePublicFolderItemIdType Class | Aspose.Email.Exchange.Schema Namespace


AndType Class

For a list of all members of this type, see AndType Members.

System.Object
Aspose.Email.Exchange.Schema.SearchExpressionType
Aspose.Email.Exchange.Schema.MultipleOperandBooleanExpressionType
Aspose.Email.Exchange.Schema.AndType

public class AndType : MultipleOperandBooleanExpressionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AndType Members | Aspose.Email.Exchange.Schema Namespace


AndType Members

AndType overview

Public Instance Constructors

AndType Constructor Initializes a new instance of the AndType class.

Public Instance Properties

Items (inherited from MultipleOperandBooleanExpressionType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AndType Class | Aspose.Email.Exchange.Schema Namespace


AndType Constructor

Initializes a new instance of the AndType class.

public AndType();

See Also

AndType Class | Aspose.Email.Exchange.Schema Namespace


AppendToFolderFieldType Class

For a list of all members of this type, see AppendToFolderFieldType Members.

System.Object
Aspose.Email.Exchange.Schema.ChangeDescriptionType
Aspose.Email.Exchange.Schema.FolderChangeDescriptionType
Aspose.Email.Exchange.Schema.AppendToFolderFieldType

public class AppendToFolderFieldType : FolderChangeDescriptionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AppendToFolderFieldType Members | Aspose.Email.Exchange.Schema Namespace


AppendToFolderFieldType Members

AppendToFolderFieldType overview

Public Instance Constructors

AppendToFolderFieldType Constructor Initializes a new instance of the AppendToFolderFieldType class.

Public Instance Properties

Item (inherited from ChangeDescriptionType)
Item1

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AppendToFolderFieldType Class | Aspose.Email.Exchange.Schema Namespace


AppendToFolderFieldType Constructor

Initializes a new instance of the AppendToFolderFieldType class.

public AppendToFolderFieldType();

See Also

AppendToFolderFieldType Class | Aspose.Email.Exchange.Schema Namespace


AppendToFolderFieldType Properties

The properties of the AppendToFolderFieldType class are listed below. For a complete list of AppendToFolderFieldType class members, see the AppendToFolderFieldType Members topic.

Public Instance Properties

Item (inherited from ChangeDescriptionType)
Item1

See Also

AppendToFolderFieldType Class | Aspose.Email.Exchange.Schema Namespace


Item1 Property

Aspose.Email

AppendToFolderFieldType.Item1 Property

public BaseFolderType Item1 {get; set;}

Remarks

See Also

AppendToFolderFieldType Class | Aspose.Email.Exchange.Schema Namespace


AppendToItemFieldType Class

For a list of all members of this type, see AppendToItemFieldType Members.

System.Object
Aspose.Email.Exchange.Schema.ChangeDescriptionType
Aspose.Email.Exchange.Schema.ItemChangeDescriptionType
Aspose.Email.Exchange.Schema.AppendToItemFieldType

public class AppendToItemFieldType : ItemChangeDescriptionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AppendToItemFieldType Members | Aspose.Email.Exchange.Schema Namespace


AppendToItemFieldType Members

AppendToItemFieldType overview

Public Instance Constructors

AppendToItemFieldType Constructor Initializes a new instance of the AppendToItemFieldType class.

Public Instance Properties

Item (inherited from ChangeDescriptionType)
Item1

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AppendToItemFieldType Class | Aspose.Email.Exchange.Schema Namespace


AppendToItemFieldType Constructor

Initializes a new instance of the AppendToItemFieldType class.

public AppendToItemFieldType();

See Also

AppendToItemFieldType Class | Aspose.Email.Exchange.Schema Namespace


AppendToItemFieldType Properties

The properties of the AppendToItemFieldType class are listed below. For a complete list of AppendToItemFieldType class members, see the AppendToItemFieldType Members topic.

Public Instance Properties

Item (inherited from ChangeDescriptionType)
Item1

See Also

AppendToItemFieldType Class | Aspose.Email.Exchange.Schema Namespace


Item1 Property

Aspose.Email

AppendToItemFieldType.Item1 Property

public ItemType Item1 {get; set;}

Remarks

See Also

AppendToItemFieldType Class | Aspose.Email.Exchange.Schema Namespace


ApplyConversationActionCompletedEventArgs Class

Provides data for the event

For a list of all members of this type, see ApplyConversationActionCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.ApplyConversationActionCompletedEventArgs

public class ApplyConversationActionCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ApplyConversationActionCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace | ApplyConversationActionCompleted


ApplyConversationActionCompletedEventArgs Members

ApplyConversationActionCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result | Gets the result of operation
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

ApplyConversationActionCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace | ApplyConversationActionCompleted


ApplyConversationActionCompletedEventArgs Properties

The properties of the ApplyConversationActionCompletedEventArgs class are listed below. For a complete list of ApplyConversationActionCompletedEventArgs class members, see the ApplyConversationActionCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result | Gets the result of operation
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

ApplyConversationActionCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace | ApplyConversationActionCompleted


Result Property

Aspose.Email

ApplyConversationActionCompletedEventArgs.Result Property

Gets the result of operation

public ApplyConversationActionResponseType Result {get;}

See Also

ApplyConversationActionCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


ApplyConversationActionCompletedEventHandler Delegate

Represents the method that will handle the ApplyConversationActionCompleted event

public delegate void ApplyConversationActionCompletedEventHandler(
object sender,
ApplyConversationActionCompletedEventArgs e
);

Parameters

sender
The sender of event
e
A ApplyConversationActionCompletedEventArgs arguments

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


ApplyConversationActionResponseType Class

Represents the contents of a response that contains the results of an attempt to apply conversation actions to a conversation in a mailbox.

For a list of all members of this type, see ApplyConversationActionResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseResponseMessageType
Aspose.Email.Exchange.Schema.ApplyConversationActionResponseType

public class ApplyConversationActionResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ApplyConversationActionResponseType Members | Aspose.Email.Exchange.Schema Namespace


ApplyConversationActionResponseType Members

ApplyConversationActionResponseType overview

Public Instance Constructors

ApplyConversationActionResponseType Constructor Initializes a new instance of the ApplyConversationActionResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ApplyConversationActionResponseType Class | Aspose.Email.Exchange.Schema Namespace


ApplyConversationActionResponseType Constructor

Initializes a new instance of the ApplyConversationActionResponseType class.

public ApplyConversationActionResponseType();

See Also

ApplyConversationActionResponseType Class | Aspose.Email.Exchange.Schema Namespace


ApplyConversationActionType Class

Represents the contents of a request to apply actions to a conversation in a mailbox.

For a list of all members of this type, see ApplyConversationActionType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.ApplyConversationActionType

public class ApplyConversationActionType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ApplyConversationActionType Members | Aspose.Email.Exchange.Schema Namespace


ApplyConversationActionType Members

ApplyConversationActionType overview

Public Instance Constructors

ApplyConversationActionType Constructor Initializes a new instance of the ApplyConversationActionType class.

Public Instance Properties

ConversationActions Gets or sets a collection of conversations and the actions to apply to them.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ApplyConversationActionType Class | Aspose.Email.Exchange.Schema Namespace


ApplyConversationActionType Constructor

Initializes a new instance of the ApplyConversationActionType class.

public ApplyConversationActionType();

See Also

ApplyConversationActionType Class | Aspose.Email.Exchange.Schema Namespace


ApplyConversationActionType Properties

The properties of the ApplyConversationActionType class are listed below. For a complete list of ApplyConversationActionType class members, see the ApplyConversationActionType Members topic.

Public Instance Properties

ConversationActions Gets or sets a collection of conversations and the actions to apply to them.

See Also

ApplyConversationActionType Class | Aspose.Email.Exchange.Schema Namespace


ConversationActions Property

Aspose.Email

ApplyConversationActionType.ConversationActions Property

Gets or sets a collection of conversations and the actions to apply to them.

public ConversationActionType[] ConversationActions {get; set;}

See Also

ApplyConversationActionType Class | Aspose.Email.Exchange.Schema Namespace


ArrayOfDLExpansionType Class

For a list of all members of this type, see ArrayOfDLExpansionType Members.

System.Object
Aspose.Email.Exchange.Schema.ArrayOfDLExpansionType

public class ArrayOfDLExpansionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ArrayOfDLExpansionType Members | Aspose.Email.Exchange.Schema Namespace


ArrayOfDLExpansionType Members

ArrayOfDLExpansionType overview

Public Instance Constructors

ArrayOfDLExpansionType Constructor Initializes a new instance of the ArrayOfDLExpansionType class.

Public Instance Properties

AbsoluteDenominator
AbsoluteDenominatorSpecified
IncludesLastItemInRange
IncludesLastItemInRangeSpecified
IndexedPagingOffset
IndexedPagingOffsetSpecified
Mailbox
NumeratorOffset
NumeratorOffsetSpecified
TotalItemsInView
TotalItemsInViewSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ArrayOfDLExpansionType Class | Aspose.Email.Exchange.Schema Namespace


ArrayOfDLExpansionType Constructor

Initializes a new instance of the ArrayOfDLExpansionType class.

public ArrayOfDLExpansionType();

See Also

ArrayOfDLExpansionType Class | Aspose.Email.Exchange.Schema Namespace


ArrayOfDLExpansionType Properties

The properties of the ArrayOfDLExpansionType class are listed below. For a complete list of ArrayOfDLExpansionType class members, see the ArrayOfDLExpansionType Members topic.

Public Instance Properties

AbsoluteDenominator
AbsoluteDenominatorSpecified
IncludesLastItemInRange
IncludesLastItemInRangeSpecified
IndexedPagingOffset
IndexedPagingOffsetSpecified
Mailbox
NumeratorOffset
NumeratorOffsetSpecified
TotalItemsInView
TotalItemsInViewSpecified

See Also

ArrayOfDLExpansionType Class | Aspose.Email.Exchange.Schema Namespace


AbsoluteDenominator Property

Aspose.Email

ArrayOfDLExpansionType.AbsoluteDenominator Property

public int AbsoluteDenominator {get; set;}

Remarks

See Also

ArrayOfDLExpansionType Class | Aspose.Email.Exchange.Schema Namespace


AbsoluteDenominatorSpecified Property

Aspose.Email

ArrayOfDLExpansionType.AbsoluteDenominatorSpecified Property

public bool AbsoluteDenominatorSpecified {get; set;}

Remarks

See Also

ArrayOfDLExpansionType Class | Aspose.Email.Exchange.Schema Namespace


IncludesLastItemInRange Property

Aspose.Email

ArrayOfDLExpansionType.IncludesLastItemInRange Property

public bool IncludesLastItemInRange {get; set;}

Remarks

See Also

ArrayOfDLExpansionType Class | Aspose.Email.Exchange.Schema Namespace


IncludesLastItemInRangeSpecified Property

Aspose.Email

ArrayOfDLExpansionType.IncludesLastItemInRangeSpecified Property

public bool IncludesLastItemInRangeSpecified {get; set;}

Remarks

See Also

ArrayOfDLExpansionType Class | Aspose.Email.Exchange.Schema Namespace


IndexedPagingOffset Property

Aspose.Email

ArrayOfDLExpansionType.IndexedPagingOffset Property

public int IndexedPagingOffset {get; set;}

Remarks

See Also

ArrayOfDLExpansionType Class | Aspose.Email.Exchange.Schema Namespace


IndexedPagingOffsetSpecified Property

Aspose.Email

ArrayOfDLExpansionType.IndexedPagingOffsetSpecified Property

public bool IndexedPagingOffsetSpecified {get; set;}

Remarks

See Also

ArrayOfDLExpansionType Class | Aspose.Email.Exchange.Schema Namespace


Mailbox Property

Aspose.Email

ArrayOfDLExpansionType.Mailbox Property

public EmailAddressType[] Mailbox {get; set;}

Remarks

See Also

ArrayOfDLExpansionType Class | Aspose.Email.Exchange.Schema Namespace


NumeratorOffset Property

Aspose.Email

ArrayOfDLExpansionType.NumeratorOffset Property

public int NumeratorOffset {get; set;}

Remarks

See Also

ArrayOfDLExpansionType Class | Aspose.Email.Exchange.Schema Namespace


NumeratorOffsetSpecified Property

Aspose.Email

ArrayOfDLExpansionType.NumeratorOffsetSpecified Property

public bool NumeratorOffsetSpecified {get; set;}

Remarks

See Also

ArrayOfDLExpansionType Class | Aspose.Email.Exchange.Schema Namespace


TotalItemsInView Property

Aspose.Email

ArrayOfDLExpansionType.TotalItemsInView Property

public int TotalItemsInView {get; set;}

Remarks

See Also

ArrayOfDLExpansionType Class | Aspose.Email.Exchange.Schema Namespace


TotalItemsInViewSpecified Property

Aspose.Email

ArrayOfDLExpansionType.TotalItemsInViewSpecified Property

public bool TotalItemsInViewSpecified {get; set;}

Remarks

See Also

ArrayOfDLExpansionType Class | Aspose.Email.Exchange.Schema Namespace


ArrayOfGroupedItemsType Class

For a list of all members of this type, see ArrayOfGroupedItemsType Members.

System.Object
Aspose.Email.Exchange.Schema.ArrayOfGroupedItemsType

public class ArrayOfGroupedItemsType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ArrayOfGroupedItemsType Members | Aspose.Email.Exchange.Schema Namespace


ArrayOfGroupedItemsType Members

ArrayOfGroupedItemsType overview

Public Instance Constructors

ArrayOfGroupedItemsType Constructor Initializes a new instance of the ArrayOfGroupedItemsType class.

Public Instance Properties

Items

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ArrayOfGroupedItemsType Class | Aspose.Email.Exchange.Schema Namespace


ArrayOfGroupedItemsType Constructor

Initializes a new instance of the ArrayOfGroupedItemsType class.

public ArrayOfGroupedItemsType();

See Also

ArrayOfGroupedItemsType Class | Aspose.Email.Exchange.Schema Namespace


ArrayOfGroupedItemsType Properties

The properties of the ArrayOfGroupedItemsType class are listed below. For a complete list of ArrayOfGroupedItemsType class members, see the ArrayOfGroupedItemsType Members topic.

Public Instance Properties

Items

See Also

ArrayOfGroupedItemsType Class | Aspose.Email.Exchange.Schema Namespace


Items Property

Aspose.Email

ArrayOfGroupedItemsType.Items Property

public GroupedItemsType[] Items {get; set;}

Remarks

See Also

ArrayOfGroupedItemsType Class | Aspose.Email.Exchange.Schema Namespace


ArrayOfRealItemsType Class

For a list of all members of this type, see ArrayOfRealItemsType Members.

System.Object
Aspose.Email.Exchange.Schema.ArrayOfRealItemsType

public class ArrayOfRealItemsType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ArrayOfRealItemsType Members | Aspose.Email.Exchange.Schema Namespace


ArrayOfRealItemsType Members

ArrayOfRealItemsType overview

Public Instance Constructors

ArrayOfRealItemsType Constructor Initializes a new instance of the ArrayOfRealItemsType class.

Public Instance Properties

Items

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ArrayOfRealItemsType Class | Aspose.Email.Exchange.Schema Namespace


ArrayOfRealItemsType Constructor

Initializes a new instance of the ArrayOfRealItemsType class.

public ArrayOfRealItemsType();

See Also

ArrayOfRealItemsType Class | Aspose.Email.Exchange.Schema Namespace


ArrayOfRealItemsType Properties

The properties of the ArrayOfRealItemsType class are listed below. For a complete list of ArrayOfRealItemsType class members, see the ArrayOfRealItemsType Members topic.

Public Instance Properties

Items

See Also

ArrayOfRealItemsType Class | Aspose.Email.Exchange.Schema Namespace


Items Property

Aspose.Email

ArrayOfRealItemsType.Items Property

public ItemType[] Items {get; set;}

Remarks

See Also

ArrayOfRealItemsType Class | Aspose.Email.Exchange.Schema Namespace


ArrayOfResolutionType Class

For a list of all members of this type, see ArrayOfResolutionType Members.

System.Object
Aspose.Email.Exchange.Schema.ArrayOfResolutionType

public class ArrayOfResolutionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ArrayOfResolutionType Members | Aspose.Email.Exchange.Schema Namespace


ArrayOfResolutionType Members

ArrayOfResolutionType overview

Public Instance Constructors

ArrayOfResolutionType Constructor Initializes a new instance of the ArrayOfResolutionType class.

Public Instance Properties

AbsoluteDenominator
AbsoluteDenominatorSpecified
IncludesLastItemInRange
IncludesLastItemInRangeSpecified
IndexedPagingOffset
IndexedPagingOffsetSpecified
NumeratorOffset
NumeratorOffsetSpecified
Resolution
TotalItemsInView
TotalItemsInViewSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ArrayOfResolutionType Class | Aspose.Email.Exchange.Schema Namespace


ArrayOfResolutionType Constructor

Initializes a new instance of the ArrayOfResolutionType class.

public ArrayOfResolutionType();

See Also

ArrayOfResolutionType Class | Aspose.Email.Exchange.Schema Namespace


ArrayOfResolutionType Properties

The properties of the ArrayOfResolutionType class are listed below. For a complete list of ArrayOfResolutionType class members, see the ArrayOfResolutionType Members topic.

Public Instance Properties

AbsoluteDenominator
AbsoluteDenominatorSpecified
IncludesLastItemInRange
IncludesLastItemInRangeSpecified
IndexedPagingOffset
IndexedPagingOffsetSpecified
NumeratorOffset
NumeratorOffsetSpecified
Resolution
TotalItemsInView
TotalItemsInViewSpecified

See Also

ArrayOfResolutionType Class | Aspose.Email.Exchange.Schema Namespace


AbsoluteDenominator Property

Aspose.Email

ArrayOfResolutionType.AbsoluteDenominator Property

public int AbsoluteDenominator {get; set;}

Remarks

See Also

ArrayOfResolutionType Class | Aspose.Email.Exchange.Schema Namespace


AbsoluteDenominatorSpecified Property

Aspose.Email

ArrayOfResolutionType.AbsoluteDenominatorSpecified Property

public bool AbsoluteDenominatorSpecified {get; set;}

Remarks

See Also

ArrayOfResolutionType Class | Aspose.Email.Exchange.Schema Namespace


IncludesLastItemInRange Property

Aspose.Email

ArrayOfResolutionType.IncludesLastItemInRange Property

public bool IncludesLastItemInRange {get; set;}

Remarks

See Also

ArrayOfResolutionType Class | Aspose.Email.Exchange.Schema Namespace


IncludesLastItemInRangeSpecified Property

Aspose.Email

ArrayOfResolutionType.IncludesLastItemInRangeSpecified Property

public bool IncludesLastItemInRangeSpecified {get; set;}

Remarks

See Also

ArrayOfResolutionType Class | Aspose.Email.Exchange.Schema Namespace


IndexedPagingOffset Property

Aspose.Email

ArrayOfResolutionType.IndexedPagingOffset Property

public int IndexedPagingOffset {get; set;}

Remarks

See Also

ArrayOfResolutionType Class | Aspose.Email.Exchange.Schema Namespace


IndexedPagingOffsetSpecified Property

Aspose.Email

ArrayOfResolutionType.IndexedPagingOffsetSpecified Property

public bool IndexedPagingOffsetSpecified {get; set;}

Remarks

See Also

ArrayOfResolutionType Class | Aspose.Email.Exchange.Schema Namespace


NumeratorOffset Property

Aspose.Email

ArrayOfResolutionType.NumeratorOffset Property

public int NumeratorOffset {get; set;}

Remarks

See Also

ArrayOfResolutionType Class | Aspose.Email.Exchange.Schema Namespace


NumeratorOffsetSpecified Property

Aspose.Email

ArrayOfResolutionType.NumeratorOffsetSpecified Property

public bool NumeratorOffsetSpecified {get; set;}

Remarks

See Also

ArrayOfResolutionType Class | Aspose.Email.Exchange.Schema Namespace


Resolution Property

Aspose.Email

ArrayOfResolutionType.Resolution Property

public ResolutionType[] Resolution {get; set;}

Remarks

See Also

ArrayOfResolutionType Class | Aspose.Email.Exchange.Schema Namespace


TotalItemsInView Property

Aspose.Email

ArrayOfResolutionType.TotalItemsInView Property

public int TotalItemsInView {get; set;}

Remarks

See Also

ArrayOfResolutionType Class | Aspose.Email.Exchange.Schema Namespace


TotalItemsInViewSpecified Property

Aspose.Email

ArrayOfResolutionType.TotalItemsInViewSpecified Property

public bool TotalItemsInViewSpecified {get; set;}

Remarks

See Also

ArrayOfResolutionType Class | Aspose.Email.Exchange.Schema Namespace


ArrayOfResponseMessagesType Class

For a list of all members of this type, see ArrayOfResponseMessagesType Members.

System.Object
Aspose.Email.Exchange.Schema.ArrayOfResponseMessagesType

public class ArrayOfResponseMessagesType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ArrayOfResponseMessagesType Members | Aspose.Email.Exchange.Schema Namespace


ArrayOfResponseMessagesType Members

ArrayOfResponseMessagesType overview

Public Instance Constructors

ArrayOfResponseMessagesType Constructor Initializes a new instance of the ArrayOfResponseMessagesType class.

Public Instance Properties

Items
ItemsElementName

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ArrayOfResponseMessagesType Class | Aspose.Email.Exchange.Schema Namespace


ArrayOfResponseMessagesType Constructor

Initializes a new instance of the ArrayOfResponseMessagesType class.

public ArrayOfResponseMessagesType();

See Also

ArrayOfResponseMessagesType Class | Aspose.Email.Exchange.Schema Namespace


ArrayOfResponseMessagesType Properties

The properties of the ArrayOfResponseMessagesType class are listed below. For a complete list of ArrayOfResponseMessagesType class members, see the ArrayOfResponseMessagesType Members topic.

Public Instance Properties

Items
ItemsElementName

See Also

ArrayOfResponseMessagesType Class | Aspose.Email.Exchange.Schema Namespace


Items Property

Aspose.Email

ArrayOfResponseMessagesType.Items Property

public ResponseMessageType[] Items {get; set;}

Remarks

See Also

ArrayOfResponseMessagesType Class | Aspose.Email.Exchange.Schema Namespace


ItemsElementName Property

Aspose.Email

ArrayOfResponseMessagesType.ItemsElementName Property

public ItemsChoiceType4[] ItemsElementName {get; set;}

Remarks

See Also

ArrayOfResponseMessagesType Class | Aspose.Email.Exchange.Schema Namespace


ArrayOfTimeZoneDefinitionType Class

For a list of all members of this type, see ArrayOfTimeZoneDefinitionType Members.

System.Object
Aspose.Email.Exchange.Schema.ArrayOfTimeZoneDefinitionType

public class ArrayOfTimeZoneDefinitionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ArrayOfTimeZoneDefinitionType Members | Aspose.Email.Exchange.Schema Namespace


ArrayOfTimeZoneDefinitionType Members

ArrayOfTimeZoneDefinitionType overview

Public Instance Constructors

ArrayOfTimeZoneDefinitionType Constructor Initializes a new instance of the ArrayOfTimeZoneDefinitionType class.

Public Instance Properties

TimeZoneDefinition

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ArrayOfTimeZoneDefinitionType Class | Aspose.Email.Exchange.Schema Namespace


ArrayOfTimeZoneDefinitionType Constructor

Initializes a new instance of the ArrayOfTimeZoneDefinitionType class.

public ArrayOfTimeZoneDefinitionType();

See Also

ArrayOfTimeZoneDefinitionType Class | Aspose.Email.Exchange.Schema Namespace


ArrayOfTimeZoneDefinitionType Properties

The properties of the ArrayOfTimeZoneDefinitionType class are listed below. For a complete list of ArrayOfTimeZoneDefinitionType class members, see the ArrayOfTimeZoneDefinitionType Members topic.

Public Instance Properties

TimeZoneDefinition

See Also

ArrayOfTimeZoneDefinitionType Class | Aspose.Email.Exchange.Schema Namespace


TimeZoneDefinition Property

Aspose.Email

ArrayOfTimeZoneDefinitionType.TimeZoneDefinition Property

public TimeZoneDefinitionType[] TimeZoneDefinition {get; set;}

Remarks

See Also

ArrayOfTimeZoneDefinitionType Class | Aspose.Email.Exchange.Schema Namespace


ArrayOfTrackingPropertiesType Class

For a list of all members of this type, see ArrayOfTrackingPropertiesType Members.

System.Object
Aspose.Email.Exchange.Schema.ArrayOfTrackingPropertiesType

public class ArrayOfTrackingPropertiesType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ArrayOfTrackingPropertiesType Members | Aspose.Email.Exchange.Schema Namespace


ArrayOfTrackingPropertiesType Members

ArrayOfTrackingPropertiesType overview

Public Instance Constructors

ArrayOfTrackingPropertiesType Constructor Initializes a new instance of the ArrayOfTrackingPropertiesType class.

Public Instance Properties

Items

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ArrayOfTrackingPropertiesType Class | Aspose.Email.Exchange.Schema Namespace


ArrayOfTrackingPropertiesType Constructor

Initializes a new instance of the ArrayOfTrackingPropertiesType class.

public ArrayOfTrackingPropertiesType();

See Also

ArrayOfTrackingPropertiesType Class | Aspose.Email.Exchange.Schema Namespace


ArrayOfTrackingPropertiesType Properties

The properties of the ArrayOfTrackingPropertiesType class are listed below. For a complete list of ArrayOfTrackingPropertiesType class members, see the ArrayOfTrackingPropertiesType Members topic.

Public Instance Properties

Items

See Also

ArrayOfTrackingPropertiesType Class | Aspose.Email.Exchange.Schema Namespace


Items Property

Aspose.Email

ArrayOfTrackingPropertiesType.Items Property

public TrackingPropertyType[] Items {get; set;}

Remarks

See Also

ArrayOfTrackingPropertiesType Class | Aspose.Email.Exchange.Schema Namespace


ArrayOfTransitionsType Class

For a list of all members of this type, see ArrayOfTransitionsType Members.

System.Object
Aspose.Email.Exchange.Schema.ArrayOfTransitionsType

public class ArrayOfTransitionsType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ArrayOfTransitionsType Members | Aspose.Email.Exchange.Schema Namespace


ArrayOfTransitionsType Members

ArrayOfTransitionsType overview

Public Instance Constructors

ArrayOfTransitionsType Constructor Initializes a new instance of the ArrayOfTransitionsType class.

Public Instance Properties

Id
Items

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ArrayOfTransitionsType Class | Aspose.Email.Exchange.Schema Namespace


ArrayOfTransitionsType Constructor

Initializes a new instance of the ArrayOfTransitionsType class.

public ArrayOfTransitionsType();

See Also

ArrayOfTransitionsType Class | Aspose.Email.Exchange.Schema Namespace


ArrayOfTransitionsType Properties

The properties of the ArrayOfTransitionsType class are listed below. For a complete list of ArrayOfTransitionsType class members, see the ArrayOfTransitionsType Members topic.

Public Instance Properties

Id
Items

See Also

ArrayOfTransitionsType Class | Aspose.Email.Exchange.Schema Namespace


Id Property

Aspose.Email

ArrayOfTransitionsType.Id Property

public string Id {get; set;}

Remarks

See Also

ArrayOfTransitionsType Class | Aspose.Email.Exchange.Schema Namespace


Items Property

Aspose.Email

ArrayOfTransitionsType.Items Property

public TransitionType[] Items {get; set;}

Remarks

See Also

ArrayOfTransitionsType Class | Aspose.Email.Exchange.Schema Namespace


AttachmentIdType Class

For a list of all members of this type, see AttachmentIdType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseItemIdType
Aspose.Email.Exchange.Schema.RequestAttachmentIdType
Aspose.Email.Exchange.Schema.AttachmentIdType

public class AttachmentIdType : RequestAttachmentIdType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AttachmentIdType Members | Aspose.Email.Exchange.Schema Namespace


AttachmentIdType Members

AttachmentIdType overview

Public Instance Constructors

AttachmentIdType Constructor Initializes a new instance of the AttachmentIdType class.

Public Instance Properties

Id (inherited from RequestAttachmentIdType)
RootItemChangeKey
RootItemId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AttachmentIdType Class | Aspose.Email.Exchange.Schema Namespace


AttachmentIdType Constructor

Initializes a new instance of the AttachmentIdType class.

public AttachmentIdType();

See Also

AttachmentIdType Class | Aspose.Email.Exchange.Schema Namespace


AttachmentIdType Properties

The properties of the AttachmentIdType class are listed below. For a complete list of AttachmentIdType class members, see the AttachmentIdType Members topic.

Public Instance Properties

Id (inherited from RequestAttachmentIdType)
RootItemChangeKey
RootItemId

See Also

AttachmentIdType Class | Aspose.Email.Exchange.Schema Namespace


RootItemChangeKey Property

Aspose.Email

AttachmentIdType.RootItemChangeKey Property

public string RootItemChangeKey {get; set;}

Remarks

See Also

AttachmentIdType Class | Aspose.Email.Exchange.Schema Namespace


RootItemId Property

Aspose.Email

AttachmentIdType.RootItemId Property

public string RootItemId {get; set;}

Remarks

See Also

AttachmentIdType Class | Aspose.Email.Exchange.Schema Namespace


AttachmentInfoResponseMessageType Class

For a list of all members of this type, see AttachmentInfoResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ResponseMessageType
Aspose.Email.Exchange.Schema.AttachmentInfoResponseMessageType

public class AttachmentInfoResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AttachmentInfoResponseMessageType Members | Aspose.Email.Exchange.Schema Namespace


AttachmentInfoResponseMessageType Members

AttachmentInfoResponseMessageType overview

Public Instance Constructors

AttachmentInfoResponseMessageType Constructor Initializes a new instance of the AttachmentInfoResponseMessageType class.

Public Instance Properties

Attachments
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AttachmentInfoResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


AttachmentInfoResponseMessageType Constructor

Initializes a new instance of the AttachmentInfoResponseMessageType class.

public AttachmentInfoResponseMessageType();

See Also

AttachmentInfoResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


AttachmentInfoResponseMessageType Properties

The properties of the AttachmentInfoResponseMessageType class are listed below. For a complete list of AttachmentInfoResponseMessageType class members, see the AttachmentInfoResponseMessageType Members topic.

Public Instance Properties

Attachments
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

AttachmentInfoResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


Attachments Property

Aspose.Email

AttachmentInfoResponseMessageType.Attachments Property

public AttachmentType[] Attachments {get; set;}

Remarks

See Also

AttachmentInfoResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


AttachmentResponseShapeType Class

For a list of all members of this type, see AttachmentResponseShapeType Members.

System.Object
Aspose.Email.Exchange.Schema.AttachmentResponseShapeType

public class AttachmentResponseShapeType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AttachmentResponseShapeType Members | Aspose.Email.Exchange.Schema Namespace


AttachmentResponseShapeType Members

AttachmentResponseShapeType overview

Public Instance Constructors

AttachmentResponseShapeType Constructor Initializes a new instance of the AttachmentResponseShapeType class.

Public Instance Properties

AdditionalProperties
BodyType
BodyTypeSpecified
FilterHtmlContent
FilterHtmlContentSpecified
IncludeMimeContent
IncludeMimeContentSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AttachmentResponseShapeType Class | Aspose.Email.Exchange.Schema Namespace


AttachmentResponseShapeType Constructor

Initializes a new instance of the AttachmentResponseShapeType class.

public AttachmentResponseShapeType();

See Also

AttachmentResponseShapeType Class | Aspose.Email.Exchange.Schema Namespace


AttachmentResponseShapeType Properties

The properties of the AttachmentResponseShapeType class are listed below. For a complete list of AttachmentResponseShapeType class members, see the AttachmentResponseShapeType Members topic.

Public Instance Properties

AdditionalProperties
BodyType
BodyTypeSpecified
FilterHtmlContent
FilterHtmlContentSpecified
IncludeMimeContent
IncludeMimeContentSpecified

See Also

AttachmentResponseShapeType Class | Aspose.Email.Exchange.Schema Namespace


AdditionalProperties Property

Aspose.Email

AttachmentResponseShapeType.AdditionalProperties Property

public BasePathToElementType[] AdditionalProperties {get; set;}

Remarks

See Also

AttachmentResponseShapeType Class | Aspose.Email.Exchange.Schema Namespace


BodyType Property

Aspose.Email

AttachmentResponseShapeType.BodyType Property

public BodyTypeResponseType BodyType {get; set;}

Remarks

See Also

AttachmentResponseShapeType Class | Aspose.Email.Exchange.Schema Namespace


BodyTypeSpecified Property

Aspose.Email

AttachmentResponseShapeType.BodyTypeSpecified Property

public bool BodyTypeSpecified {get; set;}

Remarks

See Also

AttachmentResponseShapeType Class | Aspose.Email.Exchange.Schema Namespace


FilterHtmlContent Property

Aspose.Email

AttachmentResponseShapeType.FilterHtmlContent Property

public bool FilterHtmlContent {get; set;}

Remarks

See Also

AttachmentResponseShapeType Class | Aspose.Email.Exchange.Schema Namespace


FilterHtmlContentSpecified Property

Aspose.Email

AttachmentResponseShapeType.FilterHtmlContentSpecified Property

public bool FilterHtmlContentSpecified {get; set;}

Remarks

See Also

AttachmentResponseShapeType Class | Aspose.Email.Exchange.Schema Namespace


IncludeMimeContent Property

Aspose.Email

AttachmentResponseShapeType.IncludeMimeContent Property

public bool IncludeMimeContent {get; set;}

Remarks

See Also

AttachmentResponseShapeType Class | Aspose.Email.Exchange.Schema Namespace


IncludeMimeContentSpecified Property

Aspose.Email

AttachmentResponseShapeType.IncludeMimeContentSpecified Property

public bool IncludeMimeContentSpecified {get; set;}

Remarks

See Also

AttachmentResponseShapeType Class | Aspose.Email.Exchange.Schema Namespace


AttachmentType Class

For a list of all members of this type, see AttachmentType Members.

System.Object
Aspose.Email.Exchange.Schema.AttachmentType
Aspose.Email.Exchange.Schema.FileAttachmentType
Aspose.Email.Exchange.Schema.ItemAttachmentType

public class AttachmentType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AttachmentType Members | Aspose.Email.Exchange.Schema Namespace


AttachmentType Members

AttachmentType overview

Public Instance Constructors

AttachmentType Constructor Initializes a new instance of the AttachmentType class.

Public Instance Properties

AttachmentId
ContentId
ContentLocation
ContentType
IsInline
IsInlineSpecified
LastModifiedTime
LastModifiedTimeSpecified
Name
Size
SizeSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AttachmentType Class | Aspose.Email.Exchange.Schema Namespace


AttachmentType Constructor

Initializes a new instance of the AttachmentType class.

public AttachmentType();

See Also

AttachmentType Class | Aspose.Email.Exchange.Schema Namespace


AttachmentType Properties

The properties of the AttachmentType class are listed below. For a complete list of AttachmentType class members, see the AttachmentType Members topic.

Public Instance Properties

AttachmentId
ContentId
ContentLocation
ContentType
IsInline
IsInlineSpecified
LastModifiedTime
LastModifiedTimeSpecified
Name
Size
SizeSpecified

See Also

AttachmentType Class | Aspose.Email.Exchange.Schema Namespace


AttachmentId Property

Aspose.Email

AttachmentType.AttachmentId Property

public AttachmentIdType AttachmentId {get; set;}

Remarks

See Also

AttachmentType Class | Aspose.Email.Exchange.Schema Namespace


ContentId Property

Aspose.Email

AttachmentType.ContentId Property

public string ContentId {get; set;}

Remarks

See Also

AttachmentType Class | Aspose.Email.Exchange.Schema Namespace


ContentLocation Property

Aspose.Email

AttachmentType.ContentLocation Property

public string ContentLocation {get; set;}

Remarks

See Also

AttachmentType Class | Aspose.Email.Exchange.Schema Namespace


ContentType Property

Aspose.Email

AttachmentType.ContentType Property

public string ContentType {get; set;}

Remarks

See Also

AttachmentType Class | Aspose.Email.Exchange.Schema Namespace


IsInline Property

Aspose.Email

AttachmentType.IsInline Property

public bool IsInline {get; set;}

Remarks

See Also

AttachmentType Class | Aspose.Email.Exchange.Schema Namespace


IsInlineSpecified Property

Aspose.Email

AttachmentType.IsInlineSpecified Property

public bool IsInlineSpecified {get; set;}

Remarks

See Also

AttachmentType Class | Aspose.Email.Exchange.Schema Namespace


LastModifiedTime Property

Aspose.Email

AttachmentType.LastModifiedTime Property

public DateTime LastModifiedTime {get; set;}

Remarks

See Also

AttachmentType Class | Aspose.Email.Exchange.Schema Namespace


LastModifiedTimeSpecified Property

Aspose.Email

AttachmentType.LastModifiedTimeSpecified Property

public bool LastModifiedTimeSpecified {get; set;}

Remarks

See Also

AttachmentType Class | Aspose.Email.Exchange.Schema Namespace


Name Property

Aspose.Email

AttachmentType.Name Property

public string Name {get; set;}

Remarks

See Also

AttachmentType Class | Aspose.Email.Exchange.Schema Namespace


Size Property

Aspose.Email

AttachmentType.Size Property

public int Size {get; set;}

Remarks

See Also

AttachmentType Class | Aspose.Email.Exchange.Schema Namespace


SizeSpecified Property

Aspose.Email

AttachmentType.SizeSpecified Property

public bool SizeSpecified {get; set;}

Remarks

See Also

AttachmentType Class | Aspose.Email.Exchange.Schema Namespace


AttendeeConflictData Class

For a list of all members of this type, see AttendeeConflictData Members.

System.Object
Aspose.Email.Exchange.Schema.AttendeeConflictData
Aspose.Email.Exchange.Schema.GroupAttendeeConflictData
Aspose.Email.Exchange.Schema.IndividualAttendeeConflictData
Aspose.Email.Exchange.Schema.TooBigGroupAttendeeConflictData
Aspose.Email.Exchange.Schema.UnknownAttendeeConflictData

public abstract class AttendeeConflictData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AttendeeConflictData Members | Aspose.Email.Exchange.Schema Namespace


AttendeeConflictData Members

AttendeeConflictData overview

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

AttendeeConflictData Constructor Initializes a new instance of the AttendeeConflictData class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AttendeeConflictData Class | Aspose.Email.Exchange.Schema Namespace


AttendeeConflictData Constructor

Initializes a new instance of the AttendeeConflictData class.

protected AttendeeConflictData();

See Also

AttendeeConflictData Class | Aspose.Email.Exchange.Schema Namespace


AttendeeType Class

For a list of all members of this type, see AttendeeType Members.

System.Object
Aspose.Email.Exchange.Schema.AttendeeType

public class AttendeeType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AttendeeType Members | Aspose.Email.Exchange.Schema Namespace


AttendeeType Members

AttendeeType overview

Public Instance Constructors

AttendeeType Constructor Initializes a new instance of the AttendeeType class.

Public Instance Properties

LastResponseTime
LastResponseTimeSpecified
Mailbox
ResponseType
ResponseTypeSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AttendeeType Class | Aspose.Email.Exchange.Schema Namespace


AttendeeType Constructor

Initializes a new instance of the AttendeeType class.

public AttendeeType();

See Also

AttendeeType Class | Aspose.Email.Exchange.Schema Namespace


AttendeeType Properties

The properties of the AttendeeType class are listed below. For a complete list of AttendeeType class members, see the AttendeeType Members topic.

Public Instance Properties

LastResponseTime
LastResponseTimeSpecified
Mailbox
ResponseType
ResponseTypeSpecified

See Also

AttendeeType Class | Aspose.Email.Exchange.Schema Namespace


LastResponseTime Property

Aspose.Email

AttendeeType.LastResponseTime Property

public DateTime LastResponseTime {get; set;}

Remarks

See Also

AttendeeType Class | Aspose.Email.Exchange.Schema Namespace


LastResponseTimeSpecified Property

Aspose.Email

AttendeeType.LastResponseTimeSpecified Property

public bool LastResponseTimeSpecified {get; set;}

Remarks

See Also

AttendeeType Class | Aspose.Email.Exchange.Schema Namespace


Mailbox Property

Aspose.Email

AttendeeType.Mailbox Property

public EmailAddressType Mailbox {get; set;}

Remarks

See Also

AttendeeType Class | Aspose.Email.Exchange.Schema Namespace


ResponseType Property

Aspose.Email

AttendeeType.ResponseType Property

public ResponseTypeType ResponseType {get; set;}

Remarks

See Also

AttendeeType Class | Aspose.Email.Exchange.Schema Namespace


ResponseTypeSpecified Property

Aspose.Email

AttendeeType.ResponseTypeSpecified Property

public bool ResponseTypeSpecified {get; set;}

Remarks

See Also

AttendeeType Class | Aspose.Email.Exchange.Schema Namespace


BaseDelegateResponseMessageType Class

For a list of all members of this type, see BaseDelegateResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ResponseMessageType
Aspose.Email.Exchange.Schema.BaseDelegateResponseMessageType
Aspose.Email.Exchange.Schema.AddDelegateResponseMessageType
Aspose.Email.Exchange.Schema.GetDelegateResponseMessageType
Aspose.Email.Exchange.Schema.RemoveDelegateResponseMessageType
Aspose.Email.Exchange.Schema.UpdateDelegateResponseMessageType

public abstract class BaseDelegateResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

BaseDelegateResponseMessageType Members | Aspose.Email.Exchange.Schema Namespace


BaseDelegateResponseMessageType Members

BaseDelegateResponseMessageType overview

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
ResponseMessages

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

BaseDelegateResponseMessageType Constructor Initializes a new instance of the BaseDelegateResponseMessageType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BaseDelegateResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


BaseDelegateResponseMessageType Constructor

Initializes a new instance of the BaseDelegateResponseMessageType class.

protected BaseDelegateResponseMessageType();

See Also

BaseDelegateResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


BaseDelegateResponseMessageType Properties

The properties of the BaseDelegateResponseMessageType class are listed below. For a complete list of BaseDelegateResponseMessageType class members, see the BaseDelegateResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
ResponseMessages

See Also

BaseDelegateResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


ResponseMessages Property

Aspose.Email

BaseDelegateResponseMessageType.ResponseMessages Property

public DelegateUserResponseMessageType[] ResponseMessages {get; set;}

Remarks

See Also

BaseDelegateResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


BaseDelegateType Class

For a list of all members of this type, see BaseDelegateType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.BaseDelegateType
Aspose.Email.Exchange.Schema.AddDelegateType
Aspose.Email.Exchange.Schema.GetDelegateType
Aspose.Email.Exchange.Schema.RemoveDelegateType
Aspose.Email.Exchange.Schema.UpdateDelegateType

public abstract class BaseDelegateType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

BaseDelegateType Members | Aspose.Email.Exchange.Schema Namespace


BaseDelegateType Members

BaseDelegateType overview

Public Instance Properties

Mailbox

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

BaseDelegateType Constructor Initializes a new instance of the BaseDelegateType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BaseDelegateType Class | Aspose.Email.Exchange.Schema Namespace


BaseDelegateType Constructor

Initializes a new instance of the BaseDelegateType class.

protected BaseDelegateType();

See Also

BaseDelegateType Class | Aspose.Email.Exchange.Schema Namespace


BaseDelegateType Properties

The properties of the BaseDelegateType class are listed below. For a complete list of BaseDelegateType class members, see the BaseDelegateType Members topic.

Public Instance Properties

Mailbox

See Also

BaseDelegateType Class | Aspose.Email.Exchange.Schema Namespace


Mailbox Property

Aspose.Email

BaseDelegateType.Mailbox Property

public EmailAddressType Mailbox {get; set;}

Remarks

See Also

BaseDelegateType Class | Aspose.Email.Exchange.Schema Namespace


BaseEmailAddressType Class

For a list of all members of this type, see BaseEmailAddressType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseEmailAddressType
Aspose.Email.Exchange.Schema.EmailAddressType

public class BaseEmailAddressType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

BaseEmailAddressType Members | Aspose.Email.Exchange.Schema Namespace


BaseEmailAddressType Members

BaseEmailAddressType overview

Public Instance Constructors

BaseEmailAddressType Constructor Initializes a new instance of the BaseEmailAddressType class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BaseEmailAddressType Class | Aspose.Email.Exchange.Schema Namespace


BaseEmailAddressType Constructor

Initializes a new instance of the BaseEmailAddressType class.

public BaseEmailAddressType();

See Also

BaseEmailAddressType Class | Aspose.Email.Exchange.Schema Namespace


BaseFolderIdType Class

For a list of all members of this type, see BaseFolderIdType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseFolderIdType
Aspose.Email.Exchange.Schema.DistinguishedFolderIdType
Aspose.Email.Exchange.Schema.FolderIdType

public abstract class BaseFolderIdType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

BaseFolderIdType Members | Aspose.Email.Exchange.Schema Namespace


BaseFolderIdType Members

BaseFolderIdType overview

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

BaseFolderIdType Constructor Initializes a new instance of the BaseFolderIdType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BaseFolderIdType Class | Aspose.Email.Exchange.Schema Namespace


BaseFolderIdType Constructor

Initializes a new instance of the BaseFolderIdType class.

protected BaseFolderIdType();

See Also

BaseFolderIdType Class | Aspose.Email.Exchange.Schema Namespace


BaseFolderType Class

For a list of all members of this type, see BaseFolderType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseFolderType
Aspose.Email.Exchange.Schema.CalendarFolderType
Aspose.Email.Exchange.Schema.ContactsFolderType
Aspose.Email.Exchange.Schema.FolderType

public abstract class BaseFolderType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

BaseFolderType Members | Aspose.Email.Exchange.Schema Namespace


BaseFolderType Members

BaseFolderType overview

Public Instance Properties

ChildFolderCount
ChildFolderCountSpecified
DisplayName
EffectiveRights
ExtendedProperty
FolderClass
FolderId
ManagedFolderInformation
ParentFolderId
TotalCount
TotalCountSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

BaseFolderType Constructor Initializes a new instance of the BaseFolderType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BaseFolderType Class | Aspose.Email.Exchange.Schema Namespace


BaseFolderType Constructor

Initializes a new instance of the BaseFolderType class.

protected BaseFolderType();

See Also

BaseFolderType Class | Aspose.Email.Exchange.Schema Namespace


BaseFolderType Properties

The properties of the BaseFolderType class are listed below. For a complete list of BaseFolderType class members, see the BaseFolderType Members topic.

Public Instance Properties

ChildFolderCount
ChildFolderCountSpecified
DisplayName
EffectiveRights
ExtendedProperty
FolderClass
FolderId
ManagedFolderInformation
ParentFolderId
TotalCount
TotalCountSpecified

See Also

BaseFolderType Class | Aspose.Email.Exchange.Schema Namespace


ChildFolderCount Property

Aspose.Email

BaseFolderType.ChildFolderCount Property

public int ChildFolderCount {get; set;}

Remarks

See Also

BaseFolderType Class | Aspose.Email.Exchange.Schema Namespace


ChildFolderCountSpecified Property

Aspose.Email

BaseFolderType.ChildFolderCountSpecified Property

public bool ChildFolderCountSpecified {get; set;}

Remarks

See Also

BaseFolderType Class | Aspose.Email.Exchange.Schema Namespace


DisplayName Property

Aspose.Email

BaseFolderType.DisplayName Property

public string DisplayName {get; set;}

Remarks

See Also

BaseFolderType Class | Aspose.Email.Exchange.Schema Namespace


EffectiveRights Property

Aspose.Email

BaseFolderType.EffectiveRights Property

public EffectiveRightsType EffectiveRights {get; set;}

Remarks

See Also

BaseFolderType Class | Aspose.Email.Exchange.Schema Namespace


ExtendedProperty Property

Aspose.Email

BaseFolderType.ExtendedProperty Property

public ExtendedPropertyType[] ExtendedProperty {get; set;}

Remarks

See Also

BaseFolderType Class | Aspose.Email.Exchange.Schema Namespace


FolderClass Property

Aspose.Email

BaseFolderType.FolderClass Property

public string FolderClass {get; set;}

Remarks

See Also

BaseFolderType Class | Aspose.Email.Exchange.Schema Namespace


FolderId Property

Aspose.Email

BaseFolderType.FolderId Property

public FolderIdType FolderId {get; set;}

Remarks

See Also

BaseFolderType Class | Aspose.Email.Exchange.Schema Namespace


ManagedFolderInformation Property

Aspose.Email

BaseFolderType.ManagedFolderInformation Property

public ManagedFolderInformationType ManagedFolderInformation {get; set;}

Remarks

See Also

BaseFolderType Class | Aspose.Email.Exchange.Schema Namespace


ParentFolderId Property

Aspose.Email

BaseFolderType.ParentFolderId Property

public FolderIdType ParentFolderId {get; set;}

Remarks

See Also

BaseFolderType Class | Aspose.Email.Exchange.Schema Namespace


TotalCount Property

Aspose.Email

BaseFolderType.TotalCount Property

public int TotalCount {get; set;}

Remarks

See Also

BaseFolderType Class | Aspose.Email.Exchange.Schema Namespace


TotalCountSpecified Property

Aspose.Email

BaseFolderType.TotalCountSpecified Property

public bool TotalCountSpecified {get; set;}

Remarks

See Also

BaseFolderType Class | Aspose.Email.Exchange.Schema Namespace


BaseGroupByType Class

For a list of all members of this type, see BaseGroupByType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseGroupByType
Aspose.Email.Exchange.Schema.DistinguishedGroupByType
Aspose.Email.Exchange.Schema.GroupByType

public abstract class BaseGroupByType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

BaseGroupByType Members | Aspose.Email.Exchange.Schema Namespace


BaseGroupByType Members

BaseGroupByType overview

Public Instance Properties

Order

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

BaseGroupByType Constructor Initializes a new instance of the BaseGroupByType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BaseGroupByType Class | Aspose.Email.Exchange.Schema Namespace


BaseGroupByType Constructor

Initializes a new instance of the BaseGroupByType class.

protected BaseGroupByType();

See Also

BaseGroupByType Class | Aspose.Email.Exchange.Schema Namespace


BaseGroupByType Properties

The properties of the BaseGroupByType class are listed below. For a complete list of BaseGroupByType class members, see the BaseGroupByType Members topic.

Public Instance Properties

Order

See Also

BaseGroupByType Class | Aspose.Email.Exchange.Schema Namespace


Order Property

Aspose.Email

BaseGroupByType.Order Property

public SortDirectionType Order {get; set;}

Remarks

See Also

BaseGroupByType Class | Aspose.Email.Exchange.Schema Namespace


BaseItemIdType Class

For a list of all members of this type, see BaseItemIdType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseItemIdType
Aspose.Email.Exchange.Schema.ItemIdType
Aspose.Email.Exchange.Schema.OccurrenceItemIdType
Aspose.Email.Exchange.Schema.RecurringMasterItemIdType
Aspose.Email.Exchange.Schema.RequestAttachmentIdType
Aspose.Email.Exchange.Schema.RootItemIdType

public abstract class BaseItemIdType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

BaseItemIdType Members | Aspose.Email.Exchange.Schema Namespace


BaseItemIdType Members

BaseItemIdType overview

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

BaseItemIdType Constructor Initializes a new instance of the BaseItemIdType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BaseItemIdType Class | Aspose.Email.Exchange.Schema Namespace


BaseItemIdType Constructor

Initializes a new instance of the BaseItemIdType class.

protected BaseItemIdType();

See Also

BaseItemIdType Class | Aspose.Email.Exchange.Schema Namespace


BaseMoveCopyFolderType Class

For a list of all members of this type, see BaseMoveCopyFolderType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.BaseMoveCopyFolderType
Aspose.Email.Exchange.Schema.CopyFolderType
Aspose.Email.Exchange.Schema.MoveFolderType

public class BaseMoveCopyFolderType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

BaseMoveCopyFolderType Members | Aspose.Email.Exchange.Schema Namespace


BaseMoveCopyFolderType Members

BaseMoveCopyFolderType overview

Public Instance Constructors

BaseMoveCopyFolderType Constructor Initializes a new instance of the BaseMoveCopyFolderType class.

Public Instance Properties

FolderIds
ToFolderId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BaseMoveCopyFolderType Class | Aspose.Email.Exchange.Schema Namespace


BaseMoveCopyFolderType Constructor

Initializes a new instance of the BaseMoveCopyFolderType class.

public BaseMoveCopyFolderType();

See Also

BaseMoveCopyFolderType Class | Aspose.Email.Exchange.Schema Namespace


BaseMoveCopyFolderType Properties

The properties of the BaseMoveCopyFolderType class are listed below. For a complete list of BaseMoveCopyFolderType class members, see the BaseMoveCopyFolderType Members topic.

Public Instance Properties

FolderIds
ToFolderId

See Also

BaseMoveCopyFolderType Class | Aspose.Email.Exchange.Schema Namespace


FolderIds Property

Aspose.Email

BaseMoveCopyFolderType.FolderIds Property

public BaseFolderIdType[] FolderIds {get; set;}

Remarks

See Also

BaseMoveCopyFolderType Class | Aspose.Email.Exchange.Schema Namespace


ToFolderId Property

Aspose.Email

BaseMoveCopyFolderType.ToFolderId Property

public TargetFolderIdType ToFolderId {get; set;}

Remarks

See Also

BaseMoveCopyFolderType Class | Aspose.Email.Exchange.Schema Namespace


BaseMoveCopyItemType Class

For a list of all members of this type, see BaseMoveCopyItemType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.BaseMoveCopyItemType
Aspose.Email.Exchange.Schema.CopyItemType
Aspose.Email.Exchange.Schema.MoveItemType

public class BaseMoveCopyItemType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

BaseMoveCopyItemType Members | Aspose.Email.Exchange.Schema Namespace


BaseMoveCopyItemType Members

BaseMoveCopyItemType overview

Public Instance Constructors

BaseMoveCopyItemType Constructor Initializes a new instance of the BaseMoveCopyItemType class.

Public Instance Properties

ItemIds
ReturnNewItemIds
ReturnNewItemIdsSpecified
ToFolderId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BaseMoveCopyItemType Class | Aspose.Email.Exchange.Schema Namespace


BaseMoveCopyItemType Constructor

Initializes a new instance of the BaseMoveCopyItemType class.

public BaseMoveCopyItemType();

See Also

BaseMoveCopyItemType Class | Aspose.Email.Exchange.Schema Namespace


BaseMoveCopyItemType Properties

The properties of the BaseMoveCopyItemType class are listed below. For a complete list of BaseMoveCopyItemType class members, see the BaseMoveCopyItemType Members topic.

Public Instance Properties

ItemIds
ReturnNewItemIds
ReturnNewItemIdsSpecified
ToFolderId

See Also

BaseMoveCopyItemType Class | Aspose.Email.Exchange.Schema Namespace


ItemIds Property

Aspose.Email

BaseMoveCopyItemType.ItemIds Property

public BaseItemIdType[] ItemIds {get; set;}

Remarks

See Also

BaseMoveCopyItemType Class | Aspose.Email.Exchange.Schema Namespace


ReturnNewItemIds Property

Aspose.Email

BaseMoveCopyItemType.ReturnNewItemIds Property

public bool ReturnNewItemIds {get; set;}

Remarks

See Also

BaseMoveCopyItemType Class | Aspose.Email.Exchange.Schema Namespace


ReturnNewItemIdsSpecified Property

Aspose.Email

BaseMoveCopyItemType.ReturnNewItemIdsSpecified Property

public bool ReturnNewItemIdsSpecified {get; set;}

Remarks

See Also

BaseMoveCopyItemType Class | Aspose.Email.Exchange.Schema Namespace


ToFolderId Property

Aspose.Email

BaseMoveCopyItemType.ToFolderId Property

public TargetFolderIdType ToFolderId {get; set;}

Remarks

See Also

BaseMoveCopyItemType Class | Aspose.Email.Exchange.Schema Namespace


BaseNotificationEventType Class

For a list of all members of this type, see BaseNotificationEventType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseNotificationEventType
Aspose.Email.Exchange.Schema.BaseObjectChangedEventType

public class BaseNotificationEventType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

BaseNotificationEventType Members | Aspose.Email.Exchange.Schema Namespace


BaseNotificationEventType Members

BaseNotificationEventType overview

Public Instance Constructors

BaseNotificationEventType Constructor Initializes a new instance of the BaseNotificationEventType class.

Public Instance Properties

Watermark

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BaseNotificationEventType Class | Aspose.Email.Exchange.Schema Namespace


BaseNotificationEventType Constructor

Initializes a new instance of the BaseNotificationEventType class.

public BaseNotificationEventType();

See Also

BaseNotificationEventType Class | Aspose.Email.Exchange.Schema Namespace


BaseNotificationEventType Properties

The properties of the BaseNotificationEventType class are listed below. For a complete list of BaseNotificationEventType class members, see the BaseNotificationEventType Members topic.

Public Instance Properties

Watermark

See Also

BaseNotificationEventType Class | Aspose.Email.Exchange.Schema Namespace


Watermark Property

Aspose.Email

BaseNotificationEventType.Watermark Property

public string Watermark {get; set;}

Remarks

See Also

BaseNotificationEventType Class | Aspose.Email.Exchange.Schema Namespace


BaseObjectChangedEventType Class

For a list of all members of this type, see BaseObjectChangedEventType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseNotificationEventType
Aspose.Email.Exchange.Schema.BaseObjectChangedEventType
Aspose.Email.Exchange.Schema.ModifiedEventType
Aspose.Email.Exchange.Schema.MovedCopiedEventType

public class BaseObjectChangedEventType : BaseNotificationEventType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

BaseObjectChangedEventType Members | Aspose.Email.Exchange.Schema Namespace


BaseObjectChangedEventType Members

BaseObjectChangedEventType overview

Public Instance Constructors

BaseObjectChangedEventType Constructor Initializes a new instance of the BaseObjectChangedEventType class.

Public Instance Properties

Item
ParentFolderId
TimeStamp
Watermark (inherited from BaseNotificationEventType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BaseObjectChangedEventType Class | Aspose.Email.Exchange.Schema Namespace


BaseObjectChangedEventType Constructor

Initializes a new instance of the BaseObjectChangedEventType class.

public BaseObjectChangedEventType();

See Also

BaseObjectChangedEventType Class | Aspose.Email.Exchange.Schema Namespace


BaseObjectChangedEventType Properties

The properties of the BaseObjectChangedEventType class are listed below. For a complete list of BaseObjectChangedEventType class members, see the BaseObjectChangedEventType Members topic.

Public Instance Properties

Item
ParentFolderId
TimeStamp
Watermark (inherited from BaseNotificationEventType)

See Also

BaseObjectChangedEventType Class | Aspose.Email.Exchange.Schema Namespace


Item Property

Aspose.Email

BaseObjectChangedEventType.Item Property

public object Item {get; set;}

Remarks

See Also

BaseObjectChangedEventType Class | Aspose.Email.Exchange.Schema Namespace


ParentFolderId Property

Aspose.Email

BaseObjectChangedEventType.ParentFolderId Property

public FolderIdType ParentFolderId {get; set;}

Remarks

See Also

BaseObjectChangedEventType Class | Aspose.Email.Exchange.Schema Namespace


TimeStamp Property

Aspose.Email

BaseObjectChangedEventType.TimeStamp Property

public DateTime TimeStamp {get; set;}

Remarks

See Also

BaseObjectChangedEventType Class | Aspose.Email.Exchange.Schema Namespace


BasePagingType Class

For a list of all members of this type, see BasePagingType Members.

System.Object
Aspose.Email.Exchange.Schema.BasePagingType
Aspose.Email.Exchange.Schema.CalendarViewType
Aspose.Email.Exchange.Schema.ContactsViewType
Aspose.Email.Exchange.Schema.FractionalPageViewType
Aspose.Email.Exchange.Schema.IndexedPageViewType

public abstract class BasePagingType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

BasePagingType Members | Aspose.Email.Exchange.Schema Namespace


BasePagingType Members

BasePagingType overview

Public Instance Properties

MaxEntriesReturned
MaxEntriesReturnedSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

BasePagingType Constructor Initializes a new instance of the BasePagingType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BasePagingType Class | Aspose.Email.Exchange.Schema Namespace


BasePagingType Constructor

Initializes a new instance of the BasePagingType class.

protected BasePagingType();

See Also

BasePagingType Class | Aspose.Email.Exchange.Schema Namespace


BasePagingType Properties

The properties of the BasePagingType class are listed below. For a complete list of BasePagingType class members, see the BasePagingType Members topic.

Public Instance Properties

MaxEntriesReturned
MaxEntriesReturnedSpecified

See Also

BasePagingType Class | Aspose.Email.Exchange.Schema Namespace


MaxEntriesReturned Property

Aspose.Email

BasePagingType.MaxEntriesReturned Property

public int MaxEntriesReturned {get; set;}

Remarks

See Also

BasePagingType Class | Aspose.Email.Exchange.Schema Namespace


MaxEntriesReturnedSpecified Property

Aspose.Email

BasePagingType.MaxEntriesReturnedSpecified Property

public bool MaxEntriesReturnedSpecified {get; set;}

Remarks

See Also

BasePagingType Class | Aspose.Email.Exchange.Schema Namespace


BasePathToElementType Class

For a list of all members of this type, see BasePathToElementType Members.

System.Object
Aspose.Email.Exchange.Schema.BasePathToElementType
Aspose.Email.Exchange.Schema.PathToExceptionFieldType
Aspose.Email.Exchange.Schema.PathToExtendedFieldType
Aspose.Email.Exchange.Schema.PathToIndexedFieldType
Aspose.Email.Exchange.Schema.PathToUnindexedFieldType

public abstract class BasePathToElementType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

BasePathToElementType Members | Aspose.Email.Exchange.Schema Namespace


BasePathToElementType Members

BasePathToElementType overview

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

BasePathToElementType Constructor Initializes a new instance of the BasePathToElementType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BasePathToElementType Class | Aspose.Email.Exchange.Schema Namespace


BasePathToElementType Constructor

Initializes a new instance of the BasePathToElementType class.

protected BasePathToElementType();

See Also

BasePathToElementType Class | Aspose.Email.Exchange.Schema Namespace


BasePermissionType Class

For a list of all members of this type, see BasePermissionType Members.

System.Object
Aspose.Email.Exchange.Schema.BasePermissionType
Aspose.Email.Exchange.Schema.CalendarPermissionType
Aspose.Email.Exchange.Schema.PermissionType

public abstract class BasePermissionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

BasePermissionType Members | Aspose.Email.Exchange.Schema Namespace


BasePermissionType Members

BasePermissionType overview

Public Instance Properties

CanCreateItems
CanCreateItemsSpecified
CanCreateSubFolders
CanCreateSubFoldersSpecified
DeleteItems
DeleteItemsSpecified
EditItems
EditItemsSpecified
IsFolderContact
IsFolderContactSpecified
IsFolderOwner
IsFolderOwnerSpecified
IsFolderVisible
IsFolderVisibleSpecified
UserId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

BasePermissionType Constructor Initializes a new instance of the BasePermissionType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BasePermissionType Class | Aspose.Email.Exchange.Schema Namespace


BasePermissionType Constructor

Initializes a new instance of the BasePermissionType class.

protected BasePermissionType();

See Also

BasePermissionType Class | Aspose.Email.Exchange.Schema Namespace


BasePermissionType Properties

The properties of the BasePermissionType class are listed below. For a complete list of BasePermissionType class members, see the BasePermissionType Members topic.

Public Instance Properties

CanCreateItems
CanCreateItemsSpecified
CanCreateSubFolders
CanCreateSubFoldersSpecified
DeleteItems
DeleteItemsSpecified
EditItems
EditItemsSpecified
IsFolderContact
IsFolderContactSpecified
IsFolderOwner
IsFolderOwnerSpecified
IsFolderVisible
IsFolderVisibleSpecified
UserId

See Also

BasePermissionType Class | Aspose.Email.Exchange.Schema Namespace


CanCreateItems Property

Aspose.Email

BasePermissionType.CanCreateItems Property

public bool CanCreateItems {get; set;}

Remarks

See Also

BasePermissionType Class | Aspose.Email.Exchange.Schema Namespace


CanCreateItemsSpecified Property

Aspose.Email

BasePermissionType.CanCreateItemsSpecified Property

public bool CanCreateItemsSpecified {get; set;}

Remarks

See Also

BasePermissionType Class | Aspose.Email.Exchange.Schema Namespace


CanCreateSubFolders Property

Aspose.Email

BasePermissionType.CanCreateSubFolders Property

public bool CanCreateSubFolders {get; set;}

Remarks

See Also

BasePermissionType Class | Aspose.Email.Exchange.Schema Namespace


CanCreateSubFoldersSpecified Property

Aspose.Email

BasePermissionType.CanCreateSubFoldersSpecified Property

public bool CanCreateSubFoldersSpecified {get; set;}

Remarks

See Also

BasePermissionType Class | Aspose.Email.Exchange.Schema Namespace


DeleteItems Property

Aspose.Email

BasePermissionType.DeleteItems Property

public PermissionActionType DeleteItems {get; set;}

Remarks

See Also

BasePermissionType Class | Aspose.Email.Exchange.Schema Namespace


DeleteItemsSpecified Property

Aspose.Email

BasePermissionType.DeleteItemsSpecified Property

public bool DeleteItemsSpecified {get; set;}

Remarks

See Also

BasePermissionType Class | Aspose.Email.Exchange.Schema Namespace


EditItems Property

Aspose.Email

BasePermissionType.EditItems Property

public PermissionActionType EditItems {get; set;}

Remarks

See Also

BasePermissionType Class | Aspose.Email.Exchange.Schema Namespace


EditItemsSpecified Property

Aspose.Email

BasePermissionType.EditItemsSpecified Property

public bool EditItemsSpecified {get; set;}

Remarks

See Also

BasePermissionType Class | Aspose.Email.Exchange.Schema Namespace


IsFolderContact Property

Aspose.Email

BasePermissionType.IsFolderContact Property

public bool IsFolderContact {get; set;}

Remarks

See Also

BasePermissionType Class | Aspose.Email.Exchange.Schema Namespace


IsFolderContactSpecified Property

Aspose.Email

BasePermissionType.IsFolderContactSpecified Property

public bool IsFolderContactSpecified {get; set;}

Remarks

See Also

BasePermissionType Class | Aspose.Email.Exchange.Schema Namespace


IsFolderOwner Property

Aspose.Email

BasePermissionType.IsFolderOwner Property

public bool IsFolderOwner {get; set;}

Remarks

See Also

BasePermissionType Class | Aspose.Email.Exchange.Schema Namespace


IsFolderOwnerSpecified Property

Aspose.Email

BasePermissionType.IsFolderOwnerSpecified Property

public bool IsFolderOwnerSpecified {get; set;}

Remarks

See Also

BasePermissionType Class | Aspose.Email.Exchange.Schema Namespace


IsFolderVisible Property

Aspose.Email

BasePermissionType.IsFolderVisible Property

public bool IsFolderVisible {get; set;}

Remarks

See Also

BasePermissionType Class | Aspose.Email.Exchange.Schema Namespace


IsFolderVisibleSpecified Property

Aspose.Email

BasePermissionType.IsFolderVisibleSpecified Property

public bool IsFolderVisibleSpecified {get; set;}

Remarks

See Also

BasePermissionType Class | Aspose.Email.Exchange.Schema Namespace


UserId Property

Aspose.Email

BasePermissionType.UserId Property

public UserIdType UserId {get; set;}

Remarks

See Also

BasePermissionType Class | Aspose.Email.Exchange.Schema Namespace


BaseRequestType Class

For a list of all members of this type, see BaseRequestType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Derived types

public abstract class BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

BaseRequestType Members | Aspose.Email.Exchange.Schema Namespace


BaseRequestType Members

BaseRequestType overview

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

BaseRequestType Constructor Initializes a new instance of the BaseRequestType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BaseRequestType Class | Aspose.Email.Exchange.Schema Namespace


BaseRequestType Constructor

Initializes a new instance of the BaseRequestType class.

protected BaseRequestType();

See Also

BaseRequestType Class | Aspose.Email.Exchange.Schema Namespace


BaseResponseMessageType Class

For a list of all members of this type, see BaseResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseResponseMessageType
Derived types

public class BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

BaseResponseMessageType Members | Aspose.Email.Exchange.Schema Namespace


BaseResponseMessageType Members

BaseResponseMessageType overview

Public Instance Constructors

BaseResponseMessageType Constructor Initializes a new instance of the BaseResponseMessageType class.

Public Instance Properties

ResponseMessages

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BaseResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


BaseResponseMessageType Constructor

Initializes a new instance of the BaseResponseMessageType class.

public BaseResponseMessageType();

See Also

BaseResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


BaseResponseMessageType Properties

The properties of the BaseResponseMessageType class are listed below. For a complete list of BaseResponseMessageType class members, see the BaseResponseMessageType Members topic.

Public Instance Properties

ResponseMessages

See Also

BaseResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


ResponseMessages Property

Aspose.Email

BaseResponseMessageType.ResponseMessages Property

public ArrayOfResponseMessagesType ResponseMessages {get; set;}

Remarks

See Also

BaseResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


BaseSubscriptionRequestType Class

For a list of all members of this type, see BaseSubscriptionRequestType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseSubscriptionRequestType
Aspose.Email.Exchange.Schema.PullSubscriptionRequestType
Aspose.Email.Exchange.Schema.PushSubscriptionRequestType

public abstract class BaseSubscriptionRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

BaseSubscriptionRequestType Members | Aspose.Email.Exchange.Schema Namespace


BaseSubscriptionRequestType Members

BaseSubscriptionRequestType overview

Public Instance Properties

EventTypes
FolderIds
SubscribeToAllFolders
SubscribeToAllFoldersSpecified
Watermark

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

BaseSubscriptionRequestType Constructor Initializes a new instance of the BaseSubscriptionRequestType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BaseSubscriptionRequestType Class | Aspose.Email.Exchange.Schema Namespace


BaseSubscriptionRequestType Constructor

Initializes a new instance of the BaseSubscriptionRequestType class.

protected BaseSubscriptionRequestType();

See Also

BaseSubscriptionRequestType Class | Aspose.Email.Exchange.Schema Namespace


BaseSubscriptionRequestType Properties

The properties of the BaseSubscriptionRequestType class are listed below. For a complete list of BaseSubscriptionRequestType class members, see the BaseSubscriptionRequestType Members topic.

Public Instance Properties

EventTypes
FolderIds
SubscribeToAllFolders
SubscribeToAllFoldersSpecified
Watermark

See Also

BaseSubscriptionRequestType Class | Aspose.Email.Exchange.Schema Namespace


EventTypes Property

Aspose.Email

BaseSubscriptionRequestType.EventTypes Property

public NotificationEventTypeType[] EventTypes {get; set;}

Remarks

See Also

BaseSubscriptionRequestType Class | Aspose.Email.Exchange.Schema Namespace


FolderIds Property

Aspose.Email

BaseSubscriptionRequestType.FolderIds Property

public BaseFolderIdType[] FolderIds {get; set;}

Remarks

See Also

BaseSubscriptionRequestType Class | Aspose.Email.Exchange.Schema Namespace


SubscribeToAllFolders Property

Aspose.Email

BaseSubscriptionRequestType.SubscribeToAllFolders Property

public bool SubscribeToAllFolders {get; set;}

Remarks

See Also

BaseSubscriptionRequestType Class | Aspose.Email.Exchange.Schema Namespace


SubscribeToAllFoldersSpecified Property

Aspose.Email

BaseSubscriptionRequestType.SubscribeToAllFoldersSpecified Property

public bool SubscribeToAllFoldersSpecified {get; set;}

Remarks

See Also

BaseSubscriptionRequestType Class | Aspose.Email.Exchange.Schema Namespace


Watermark Property

Aspose.Email

BaseSubscriptionRequestType.Watermark Property

public string Watermark {get; set;}

Remarks

See Also

BaseSubscriptionRequestType Class | Aspose.Email.Exchange.Schema Namespace


BodyType Class

For a list of all members of this type, see BodyType Members.

System.Object
Aspose.Email.Exchange.Schema.BodyType

public class BodyType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

BodyType Members | Aspose.Email.Exchange.Schema Namespace


BodyType Members

BodyType overview

Public Instance Constructors

BodyType Constructor Initializes a new instance of the BodyType class.

Public Instance Properties

BodyType1
Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BodyType Class | Aspose.Email.Exchange.Schema Namespace


BodyType Constructor

Initializes a new instance of the BodyType class.

public BodyType();

See Also

BodyType Class | Aspose.Email.Exchange.Schema Namespace


BodyType Properties

The properties of the BodyType class are listed below. For a complete list of BodyType class members, see the BodyType Members topic.

Public Instance Properties

BodyType1
Value

See Also

BodyType Class | Aspose.Email.Exchange.Schema Namespace


BodyType1 Property

Aspose.Email

BodyType.BodyType1 Property

public BodyTypeType BodyType1 {get; set;}

Remarks

See Also

BodyType Class | Aspose.Email.Exchange.Schema Namespace


Value Property

Aspose.Email

BodyType.Value Property

public string Value {get; set;}

Remarks

See Also

BodyType Class | Aspose.Email.Exchange.Schema Namespace


BodyTypeResponseType Enumeration

public enum BodyTypeResponseType

Remarks

Members

Member Name | Description | Value
Best |  | 0
HTML |  | 1
Text |  | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


BodyTypeType Enumeration

public enum BodyTypeType

Remarks

Members

Member Name | Description | Value
HTML |  | 0
Text |  | 1

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


CalendarEvent Class

For a list of all members of this type, see CalendarEvent Members.

System.Object
Aspose.Email.Exchange.Schema.CalendarEvent

public class CalendarEvent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CalendarEvent Members | Aspose.Email.Exchange.Schema Namespace


CalendarEvent Members

CalendarEvent overview

Public Instance Constructors

CalendarEvent Constructor Initializes a new instance of the CalendarEvent class.

Public Instance Properties

BusyType
CalendarEventDetails
EndTime
StartTime

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CalendarEvent Class | Aspose.Email.Exchange.Schema Namespace


CalendarEvent Constructor

Initializes a new instance of the CalendarEvent class.

public CalendarEvent();

See Also

CalendarEvent Class | Aspose.Email.Exchange.Schema Namespace


CalendarEvent Properties

The properties of the CalendarEvent class are listed below. For a complete list of CalendarEvent class members, see the CalendarEvent Members topic.

Public Instance Properties

BusyType
CalendarEventDetails
EndTime
StartTime

See Also

CalendarEvent Class | Aspose.Email.Exchange.Schema Namespace


BusyType Property

Aspose.Email

CalendarEvent.BusyType Property

public LegacyFreeBusyType BusyType {get; set;}

Remarks

See Also

CalendarEvent Class | Aspose.Email.Exchange.Schema Namespace


CalendarEventDetails Property

Aspose.Email

CalendarEvent.CalendarEventDetails Property

public CalendarEventDetails CalendarEventDetails {get; set;}

Remarks

See Also

CalendarEvent Class | Aspose.Email.Exchange.Schema Namespace


EndTime Property

Aspose.Email

CalendarEvent.EndTime Property

public DateTime EndTime {get; set;}

Remarks

See Also

CalendarEvent Class | Aspose.Email.Exchange.Schema Namespace


StartTime Property

Aspose.Email

CalendarEvent.StartTime Property

public DateTime StartTime {get; set;}

Remarks

See Also

CalendarEvent Class | Aspose.Email.Exchange.Schema Namespace


CalendarEventDetails Class

For a list of all members of this type, see CalendarEventDetails Members.

System.Object
Aspose.Email.Exchange.Schema.CalendarEventDetails

public class CalendarEventDetails

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CalendarEventDetails Members | Aspose.Email.Exchange.Schema Namespace


CalendarEventDetails Members

CalendarEventDetails overview

Public Instance Constructors

CalendarEventDetails Constructor Initializes a new instance of the CalendarEventDetails class.

Public Instance Properties

ID
IsException
IsMeeting
IsPrivate
IsRecurring
IsReminderSet
Location
Subject

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CalendarEventDetails Class | Aspose.Email.Exchange.Schema Namespace


CalendarEventDetails Constructor

Initializes a new instance of the CalendarEventDetails class.

public CalendarEventDetails();

See Also

CalendarEventDetails Class | Aspose.Email.Exchange.Schema Namespace


CalendarEventDetails Properties

The properties of the CalendarEventDetails class are listed below. For a complete list of CalendarEventDetails class members, see the CalendarEventDetails Members topic.

Public Instance Properties

ID
IsException
IsMeeting
IsPrivate
IsRecurring
IsReminderSet
Location
Subject

See Also

CalendarEventDetails Class | Aspose.Email.Exchange.Schema Namespace


ID Property

Aspose.Email

CalendarEventDetails.ID Property

public string ID {get; set;}

Remarks

See Also

CalendarEventDetails Class | Aspose.Email.Exchange.Schema Namespace


IsException Property

Aspose.Email

CalendarEventDetails.IsException Property

public bool IsException {get; set;}

Remarks

See Also

CalendarEventDetails Class | Aspose.Email.Exchange.Schema Namespace


IsMeeting Property

Aspose.Email

CalendarEventDetails.IsMeeting Property

public bool IsMeeting {get; set;}

Remarks

See Also

CalendarEventDetails Class | Aspose.Email.Exchange.Schema Namespace


IsPrivate Property

Aspose.Email

CalendarEventDetails.IsPrivate Property

public bool IsPrivate {get; set;}

Remarks

See Also

CalendarEventDetails Class | Aspose.Email.Exchange.Schema Namespace


IsRecurring Property

Aspose.Email

CalendarEventDetails.IsRecurring Property

public bool IsRecurring {get; set;}

Remarks

See Also

CalendarEventDetails Class | Aspose.Email.Exchange.Schema Namespace


IsReminderSet Property

Aspose.Email

CalendarEventDetails.IsReminderSet Property

public bool IsReminderSet {get; set;}

Remarks

See Also

CalendarEventDetails Class | Aspose.Email.Exchange.Schema Namespace


Location Property

Aspose.Email

CalendarEventDetails.Location Property

public string Location {get; set;}

Remarks

See Also

CalendarEventDetails Class | Aspose.Email.Exchange.Schema Namespace


Subject Property

Aspose.Email

CalendarEventDetails.Subject Property

public string Subject {get; set;}

Remarks

See Also

CalendarEventDetails Class | Aspose.Email.Exchange.Schema Namespace


CalendarFolderType Class

For a list of all members of this type, see CalendarFolderType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseFolderType
Aspose.Email.Exchange.Schema.CalendarFolderType

public class CalendarFolderType : BaseFolderType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CalendarFolderType Members | Aspose.Email.Exchange.Schema Namespace


CalendarFolderType Members

CalendarFolderType overview

Public Instance Constructors

CalendarFolderType Constructor Initializes a new instance of the CalendarFolderType class.

Public Instance Properties

ChildFolderCount (inherited from BaseFolderType)
ChildFolderCountSpecified (inherited from BaseFolderType)
DisplayName (inherited from BaseFolderType)
EffectiveRights (inherited from BaseFolderType)
ExtendedProperty (inherited from BaseFolderType)
FolderClass (inherited from BaseFolderType)
FolderId (inherited from BaseFolderType)
ManagedFolderInformation (inherited from BaseFolderType)
ParentFolderId (inherited from BaseFolderType)
PermissionSet
SharingEffectiveRights
SharingEffectiveRightsSpecified
TotalCount (inherited from BaseFolderType)
TotalCountSpecified (inherited from BaseFolderType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CalendarFolderType Class | Aspose.Email.Exchange.Schema Namespace


CalendarFolderType Constructor

Initializes a new instance of the CalendarFolderType class.

public CalendarFolderType();

See Also

CalendarFolderType Class | Aspose.Email.Exchange.Schema Namespace


CalendarFolderType Properties

The properties of the CalendarFolderType class are listed below. For a complete list of CalendarFolderType class members, see the CalendarFolderType Members topic.

Public Instance Properties

ChildFolderCount (inherited from BaseFolderType)
ChildFolderCountSpecified (inherited from BaseFolderType)
DisplayName (inherited from BaseFolderType)
EffectiveRights (inherited from BaseFolderType)
ExtendedProperty (inherited from BaseFolderType)
FolderClass (inherited from BaseFolderType)
FolderId (inherited from BaseFolderType)
ManagedFolderInformation (inherited from BaseFolderType)
ParentFolderId (inherited from BaseFolderType)
PermissionSet
SharingEffectiveRights
SharingEffectiveRightsSpecified
TotalCount (inherited from BaseFolderType)
TotalCountSpecified (inherited from BaseFolderType)

See Also

CalendarFolderType Class | Aspose.Email.Exchange.Schema Namespace


PermissionSet Property

Aspose.Email

CalendarFolderType.PermissionSet Property

public CalendarPermissionSetType PermissionSet {get; set;}

Remarks

See Also

CalendarFolderType Class | Aspose.Email.Exchange.Schema Namespace


SharingEffectiveRights Property

Aspose.Email

CalendarFolderType.SharingEffectiveRights Property

public CalendarPermissionReadAccessType SharingEffectiveRights {get; set;}

Remarks

See Also

CalendarFolderType Class | Aspose.Email.Exchange.Schema Namespace


SharingEffectiveRightsSpecified Property

Aspose.Email

CalendarFolderType.SharingEffectiveRightsSpecified Property

public bool SharingEffectiveRightsSpecified {get; set;}

Remarks

See Also

CalendarFolderType Class | Aspose.Email.Exchange.Schema Namespace


CalendarItemCreateOrDeleteOperationType Enumeration

public enum CalendarItemCreateOrDeleteOperationType

Remarks

Members

Member Name | Description | Value
SendToNone |  | 0
SendOnlyToAll |  | 1
SendToAllAndSaveCopy |  | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


CalendarItemType Class

For a list of all members of this type, see CalendarItemType Members.

System.Object
Aspose.Email.Exchange.Schema.ItemType
Aspose.Email.Exchange.Schema.CalendarItemType

public class CalendarItemType : ItemType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CalendarItemType Members | Aspose.Email.Exchange.Schema Namespace


CalendarItemType Members

CalendarItemType overview

Public Instance Constructors

CalendarItemType Constructor Initializes a new instance of the CalendarItemType class.

Public Instance Properties

AdjacentMeetingCount
AdjacentMeetingCountSpecified
AdjacentMeetings
AllowNewTimeProposal
AllowNewTimeProposalSpecified
AppointmentReplyTime
AppointmentReplyTimeSpecified
AppointmentSequenceNumber
AppointmentSequenceNumberSpecified
AppointmentState
AppointmentStateSpecified
Attachments (inherited from ItemType)
Body (inherited from ItemType)
CalendarItemType1
CalendarItemType1Specified
Categories (inherited from ItemType)
ConferenceType
ConferenceTypeSpecified
ConflictingMeetingCount
ConflictingMeetingCountSpecified
ConflictingMeetings
ConversationId (inherited from ItemType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DateTimeStamp
DateTimeStampSpecified
DeletedOccurrences
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
Duration
EffectiveRights (inherited from ItemType)
End
EndSpecified
EndTimeZone
ExtendedProperty (inherited from ItemType)
FirstOccurrence
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
IsAllDayEvent
IsAllDayEventSpecified
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsCancelled
IsCancelledSpecified
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsMeeting
IsMeetingSpecified
IsOnlineMeeting
IsOnlineMeetingSpecified
IsRecurring
IsRecurringSpecified
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested
IsResponseRequestedSpecified
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
LastOccurrence
LegacyFreeBusyStatus
LegacyFreeBusyStatusSpecified
Location
MeetingRequestWasSent
MeetingRequestWasSentSpecified
MeetingTimeZone
MeetingWorkspaceUrl
MimeContent (inherited from ItemType)
ModifiedOccurrences
MyResponseType
MyResponseTypeSpecified
NetShowUrl
OptionalAttendees
Organizer
OriginalStart
OriginalStartSpecified
ParentFolderId (inherited from ItemType)
Recurrence
RecurrenceId
RecurrenceIdSpecified
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
RequiredAttendees
Resources
ResponseObjects (inherited from ItemType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
Start
StartSpecified
StartTimeZone
Subject (inherited from ItemType)
TimeZone
UID
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)
When

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


CalendarItemType Constructor

Initializes a new instance of the CalendarItemType class.

public CalendarItemType();

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


CalendarItemType Properties

The properties of the CalendarItemType class are listed below. For a complete list of CalendarItemType class members, see the CalendarItemType Members topic.

Public Instance Properties

AdjacentMeetingCount
AdjacentMeetingCountSpecified
AdjacentMeetings
AllowNewTimeProposal
AllowNewTimeProposalSpecified
AppointmentReplyTime
AppointmentReplyTimeSpecified
AppointmentSequenceNumber
AppointmentSequenceNumberSpecified
AppointmentState
AppointmentStateSpecified
Attachments (inherited from ItemType)
Body (inherited from ItemType)
CalendarItemType1
CalendarItemType1Specified
Categories (inherited from ItemType)
ConferenceType
ConferenceTypeSpecified
ConflictingMeetingCount
ConflictingMeetingCountSpecified
ConflictingMeetings
ConversationId (inherited from ItemType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DateTimeStamp
DateTimeStampSpecified
DeletedOccurrences
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
Duration
EffectiveRights (inherited from ItemType)
End
EndSpecified
EndTimeZone
ExtendedProperty (inherited from ItemType)
FirstOccurrence
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
IsAllDayEvent
IsAllDayEventSpecified
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsCancelled
IsCancelledSpecified
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsMeeting
IsMeetingSpecified
IsOnlineMeeting
IsOnlineMeetingSpecified
IsRecurring
IsRecurringSpecified
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested
IsResponseRequestedSpecified
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
LastOccurrence
LegacyFreeBusyStatus
LegacyFreeBusyStatusSpecified
Location
MeetingRequestWasSent
MeetingRequestWasSentSpecified
MeetingTimeZone
MeetingWorkspaceUrl
MimeContent (inherited from ItemType)
ModifiedOccurrences
MyResponseType
MyResponseTypeSpecified
NetShowUrl
OptionalAttendees
Organizer
OriginalStart
OriginalStartSpecified
ParentFolderId (inherited from ItemType)
Recurrence
RecurrenceId
RecurrenceIdSpecified
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
RequiredAttendees
Resources
ResponseObjects (inherited from ItemType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
Start
StartSpecified
StartTimeZone
Subject (inherited from ItemType)
TimeZone
UID
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)
When

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


AdjacentMeetingCount Property

Aspose.Email

CalendarItemType.AdjacentMeetingCount Property

public int AdjacentMeetingCount {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


AdjacentMeetingCountSpecified Property

Aspose.Email

CalendarItemType.AdjacentMeetingCountSpecified Property

public bool AdjacentMeetingCountSpecified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


AdjacentMeetings Property

Aspose.Email

CalendarItemType.AdjacentMeetings Property

public NonEmptyArrayOfAllItemsType AdjacentMeetings {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


AllowNewTimeProposal Property

Aspose.Email

CalendarItemType.AllowNewTimeProposal Property

public bool AllowNewTimeProposal {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


AllowNewTimeProposalSpecified Property

Aspose.Email

CalendarItemType.AllowNewTimeProposalSpecified Property

public bool AllowNewTimeProposalSpecified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


AppointmentReplyTime Property

Aspose.Email

CalendarItemType.AppointmentReplyTime Property

public DateTime AppointmentReplyTime {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


AppointmentReplyTimeSpecified Property

Aspose.Email

CalendarItemType.AppointmentReplyTimeSpecified Property

public bool AppointmentReplyTimeSpecified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


AppointmentSequenceNumber Property

Aspose.Email

CalendarItemType.AppointmentSequenceNumber Property

public int AppointmentSequenceNumber {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


AppointmentSequenceNumberSpecified Property

Aspose.Email

CalendarItemType.AppointmentSequenceNumberSpecified Property

public bool AppointmentSequenceNumberSpecified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


AppointmentState Property

Aspose.Email

CalendarItemType.AppointmentState Property

public int AppointmentState {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


AppointmentStateSpecified Property

Aspose.Email

CalendarItemType.AppointmentStateSpecified Property

public bool AppointmentStateSpecified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


CalendarItemType1 Property

Aspose.Email

CalendarItemType.CalendarItemType1 Property

public CalendarItemTypeType CalendarItemType1 {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


CalendarItemType1Specified Property

Aspose.Email

CalendarItemType.CalendarItemType1Specified Property

public bool CalendarItemType1Specified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


ConferenceType Property

Aspose.Email

CalendarItemType.ConferenceType Property

public int ConferenceType {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


ConferenceTypeSpecified Property

Aspose.Email

CalendarItemType.ConferenceTypeSpecified Property

public bool ConferenceTypeSpecified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


ConflictingMeetingCount Property

Aspose.Email

CalendarItemType.ConflictingMeetingCount Property

public int ConflictingMeetingCount {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


ConflictingMeetingCountSpecified Property

Aspose.Email

CalendarItemType.ConflictingMeetingCountSpecified Property

public bool ConflictingMeetingCountSpecified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


ConflictingMeetings Property

Aspose.Email

CalendarItemType.ConflictingMeetings Property

public NonEmptyArrayOfAllItemsType ConflictingMeetings {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


DateTimeStamp Property

Aspose.Email

CalendarItemType.DateTimeStamp Property

public DateTime DateTimeStamp {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


DateTimeStampSpecified Property

Aspose.Email

CalendarItemType.DateTimeStampSpecified Property

public bool DateTimeStampSpecified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


DeletedOccurrences Property

Aspose.Email

CalendarItemType.DeletedOccurrences Property

public DeletedOccurrenceInfoType[] DeletedOccurrences {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


Duration Property

Aspose.Email

CalendarItemType.Duration Property

public string Duration {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


End Property

Aspose.Email

CalendarItemType.End Property

public DateTime End {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


EndSpecified Property

Aspose.Email

CalendarItemType.EndSpecified Property

public bool EndSpecified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


EndTimeZone Property

Aspose.Email

CalendarItemType.EndTimeZone Property

public TimeZoneDefinitionType EndTimeZone {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


FirstOccurrence Property

Aspose.Email

CalendarItemType.FirstOccurrence Property

public OccurrenceInfoType FirstOccurrence {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


IsAllDayEvent Property

Aspose.Email

CalendarItemType.IsAllDayEvent Property

public bool IsAllDayEvent {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


IsAllDayEventSpecified Property

Aspose.Email

CalendarItemType.IsAllDayEventSpecified Property

public bool IsAllDayEventSpecified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


IsCancelled Property

Aspose.Email

CalendarItemType.IsCancelled Property

public bool IsCancelled {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


IsCancelledSpecified Property

Aspose.Email

CalendarItemType.IsCancelledSpecified Property

public bool IsCancelledSpecified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


IsMeeting Property

Aspose.Email

CalendarItemType.IsMeeting Property

public bool IsMeeting {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


IsMeetingSpecified Property

Aspose.Email

CalendarItemType.IsMeetingSpecified Property

public bool IsMeetingSpecified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


IsOnlineMeeting Property

Aspose.Email

CalendarItemType.IsOnlineMeeting Property

public bool IsOnlineMeeting {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


IsOnlineMeetingSpecified Property

Aspose.Email

CalendarItemType.IsOnlineMeetingSpecified Property

public bool IsOnlineMeetingSpecified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


IsRecurring Property

Aspose.Email

CalendarItemType.IsRecurring Property

public bool IsRecurring {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


IsRecurringSpecified Property

Aspose.Email

CalendarItemType.IsRecurringSpecified Property

public bool IsRecurringSpecified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


IsResponseRequested Property

Aspose.Email

CalendarItemType.IsResponseRequested Property

public bool IsResponseRequested {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


IsResponseRequestedSpecified Property

Aspose.Email

CalendarItemType.IsResponseRequestedSpecified Property

public bool IsResponseRequestedSpecified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


LastOccurrence Property

Aspose.Email

CalendarItemType.LastOccurrence Property

public OccurrenceInfoType LastOccurrence {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


LegacyFreeBusyStatus Property

Aspose.Email

CalendarItemType.LegacyFreeBusyStatus Property

public LegacyFreeBusyType LegacyFreeBusyStatus {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


LegacyFreeBusyStatusSpecified Property

Aspose.Email

CalendarItemType.LegacyFreeBusyStatusSpecified Property

public bool LegacyFreeBusyStatusSpecified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


Location Property

Aspose.Email

CalendarItemType.Location Property

public string Location {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


MeetingRequestWasSent Property

Aspose.Email

CalendarItemType.MeetingRequestWasSent Property

public bool MeetingRequestWasSent {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


MeetingRequestWasSentSpecified Property

Aspose.Email

CalendarItemType.MeetingRequestWasSentSpecified Property

public bool MeetingRequestWasSentSpecified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


MeetingTimeZone Property

Aspose.Email

CalendarItemType.MeetingTimeZone Property

public TimeZoneType MeetingTimeZone {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


MeetingWorkspaceUrl Property

Aspose.Email

CalendarItemType.MeetingWorkspaceUrl Property

public string MeetingWorkspaceUrl {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


ModifiedOccurrences Property

Aspose.Email

CalendarItemType.ModifiedOccurrences Property

public OccurrenceInfoType[] ModifiedOccurrences {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


MyResponseType Property

Aspose.Email

CalendarItemType.MyResponseType Property

public ResponseTypeType MyResponseType {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


MyResponseTypeSpecified Property

Aspose.Email

CalendarItemType.MyResponseTypeSpecified Property

public bool MyResponseTypeSpecified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


NetShowUrl Property

Aspose.Email

CalendarItemType.NetShowUrl Property

public string NetShowUrl {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


OptionalAttendees Property

Aspose.Email

CalendarItemType.OptionalAttendees Property

public AttendeeType[] OptionalAttendees {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


Organizer Property

Aspose.Email

CalendarItemType.Organizer Property

public SingleRecipientType Organizer {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


OriginalStart Property

Aspose.Email

CalendarItemType.OriginalStart Property

public DateTime OriginalStart {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


OriginalStartSpecified Property

Aspose.Email

CalendarItemType.OriginalStartSpecified Property

public bool OriginalStartSpecified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


Recurrence Property

Aspose.Email

CalendarItemType.Recurrence Property

public RecurrenceType Recurrence {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


RecurrenceId Property

Aspose.Email

CalendarItemType.RecurrenceId Property

public DateTime RecurrenceId {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


RecurrenceIdSpecified Property

Aspose.Email

CalendarItemType.RecurrenceIdSpecified Property

public bool RecurrenceIdSpecified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


RequiredAttendees Property

Aspose.Email

CalendarItemType.RequiredAttendees Property

public AttendeeType[] RequiredAttendees {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


Resources Property

Aspose.Email

CalendarItemType.Resources Property

public AttendeeType[] Resources {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


Start Property

Aspose.Email

CalendarItemType.Start Property

public DateTime Start {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


StartSpecified Property

Aspose.Email

CalendarItemType.StartSpecified Property

public bool StartSpecified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


StartTimeZone Property

Aspose.Email

CalendarItemType.StartTimeZone Property

public TimeZoneDefinitionType StartTimeZone {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


TimeZone Property

Aspose.Email

CalendarItemType.TimeZone Property

public string TimeZone {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


UID Property

Aspose.Email

CalendarItemType.UID Property

public string UID {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


When Property

Aspose.Email

CalendarItemType.When Property

public string When {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


CalendarItemTypeType Enumeration

public enum CalendarItemTypeType

Remarks

Members

Member Name | Description | Value
Single |  | 0
Occurrence |  | 1
Exception |  | 2
RecurringMaster |  | 3

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


CalendarItemUpdateOperationType Enumeration

public enum CalendarItemUpdateOperationType

Remarks

Members

Member Name | Description | Value
SendToNone |  | 0
SendOnlyToAll |  | 1
SendOnlyToChanged |  | 2
SendToAllAndSaveCopy |  | 3
SendToChangedAndSaveCopy |  | 4

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


CalendarPermissionLevelType Enumeration

public enum CalendarPermissionLevelType

Remarks

Members

Member Name | Description | Value
None |  | 0
Owner |  | 1
PublishingEditor |  | 2
Editor |  | 3
PublishingAuthor |  | 4
Author |  | 5
NoneditingAuthor |  | 6
Reviewer |  | 7
Contributor |  | 8
FreeBusyTimeOnly |  | 9
FreeBusyTimeAndSubjectAndLocation |  | 10
Custom |  | 11

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


CalendarPermissionReadAccessType Enumeration

public enum CalendarPermissionReadAccessType

Remarks

Members

Member Name | Description | Value
None |  | 0
TimeOnly |  | 1
TimeAndSubjectAndLocation |  | 2
FullDetails |  | 3

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


CalendarPermissionSetType Class

For a list of all members of this type, see CalendarPermissionSetType Members.

System.Object
Aspose.Email.Exchange.Schema.CalendarPermissionSetType

public class CalendarPermissionSetType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CalendarPermissionSetType Members | Aspose.Email.Exchange.Schema Namespace


CalendarPermissionSetType Members

CalendarPermissionSetType overview

Public Instance Constructors

CalendarPermissionSetType Constructor Initializes a new instance of the CalendarPermissionSetType class.

Public Instance Properties

CalendarPermissions
UnknownEntries

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CalendarPermissionSetType Class | Aspose.Email.Exchange.Schema Namespace


CalendarPermissionSetType Constructor

Initializes a new instance of the CalendarPermissionSetType class.

public CalendarPermissionSetType();

See Also

CalendarPermissionSetType Class | Aspose.Email.Exchange.Schema Namespace


CalendarPermissionSetType Properties

The properties of the CalendarPermissionSetType class are listed below. For a complete list of CalendarPermissionSetType class members, see the CalendarPermissionSetType Members topic.

Public Instance Properties

CalendarPermissions
UnknownEntries

See Also

CalendarPermissionSetType Class | Aspose.Email.Exchange.Schema Namespace


CalendarPermissions Property

Aspose.Email

CalendarPermissionSetType.CalendarPermissions Property

public CalendarPermissionType[] CalendarPermissions {get; set;}

Remarks

See Also

CalendarPermissionSetType Class | Aspose.Email.Exchange.Schema Namespace


UnknownEntries Property

Aspose.Email

CalendarPermissionSetType.UnknownEntries Property

public string[] UnknownEntries {get; set;}

Remarks

See Also

CalendarPermissionSetType Class | Aspose.Email.Exchange.Schema Namespace


CalendarPermissionType Class

For a list of all members of this type, see CalendarPermissionType Members.

System.Object
Aspose.Email.Exchange.Schema.BasePermissionType
Aspose.Email.Exchange.Schema.CalendarPermissionType

public class CalendarPermissionType : BasePermissionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CalendarPermissionType Members | Aspose.Email.Exchange.Schema Namespace


CalendarPermissionType Members

CalendarPermissionType overview

Public Instance Constructors

CalendarPermissionType Constructor Initializes a new instance of the CalendarPermissionType class.

Public Instance Properties

CalendarPermissionLevel
CanCreateItems (inherited from BasePermissionType)
CanCreateItemsSpecified (inherited from BasePermissionType)
CanCreateSubFolders (inherited from BasePermissionType)
CanCreateSubFoldersSpecified (inherited from BasePermissionType)
DeleteItems (inherited from BasePermissionType)
DeleteItemsSpecified (inherited from BasePermissionType)
EditItems (inherited from BasePermissionType)
EditItemsSpecified (inherited from BasePermissionType)
IsFolderContact (inherited from BasePermissionType)
IsFolderContactSpecified (inherited from BasePermissionType)
IsFolderOwner (inherited from BasePermissionType)
IsFolderOwnerSpecified (inherited from BasePermissionType)
IsFolderVisible (inherited from BasePermissionType)
IsFolderVisibleSpecified (inherited from BasePermissionType)
ReadItems
ReadItemsSpecified
UserId (inherited from BasePermissionType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CalendarPermissionType Class | Aspose.Email.Exchange.Schema Namespace


CalendarPermissionType Constructor

Initializes a new instance of the CalendarPermissionType class.

public CalendarPermissionType();

See Also

CalendarPermissionType Class | Aspose.Email.Exchange.Schema Namespace


CalendarPermissionType Properties

The properties of the CalendarPermissionType class are listed below. For a complete list of CalendarPermissionType class members, see the CalendarPermissionType Members topic.

Public Instance Properties

CalendarPermissionLevel
CanCreateItems (inherited from BasePermissionType)
CanCreateItemsSpecified (inherited from BasePermissionType)
CanCreateSubFolders (inherited from BasePermissionType)
CanCreateSubFoldersSpecified (inherited from BasePermissionType)
DeleteItems (inherited from BasePermissionType)
DeleteItemsSpecified (inherited from BasePermissionType)
EditItems (inherited from BasePermissionType)
EditItemsSpecified (inherited from BasePermissionType)
IsFolderContact (inherited from BasePermissionType)
IsFolderContactSpecified (inherited from BasePermissionType)
IsFolderOwner (inherited from BasePermissionType)
IsFolderOwnerSpecified (inherited from BasePermissionType)
IsFolderVisible (inherited from BasePermissionType)
IsFolderVisibleSpecified (inherited from BasePermissionType)
ReadItems
ReadItemsSpecified
UserId (inherited from BasePermissionType)

See Also

CalendarPermissionType Class | Aspose.Email.Exchange.Schema Namespace


CalendarPermissionLevel Property

Aspose.Email

CalendarPermissionType.CalendarPermissionLevel Property

public CalendarPermissionLevelType CalendarPermissionLevel {get; set;}

Remarks

See Also

CalendarPermissionType Class | Aspose.Email.Exchange.Schema Namespace


ReadItems Property

Aspose.Email

CalendarPermissionType.ReadItems Property

public CalendarPermissionReadAccessType ReadItems {get; set;}

Remarks

See Also

CalendarPermissionType Class | Aspose.Email.Exchange.Schema Namespace


ReadItemsSpecified Property

Aspose.Email

CalendarPermissionType.ReadItemsSpecified Property

public bool ReadItemsSpecified {get; set;}

Remarks

See Also

CalendarPermissionType Class | Aspose.Email.Exchange.Schema Namespace


CalendarViewType Class

For a list of all members of this type, see CalendarViewType Members.

System.Object
Aspose.Email.Exchange.Schema.BasePagingType
Aspose.Email.Exchange.Schema.CalendarViewType

public class CalendarViewType : BasePagingType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CalendarViewType Members | Aspose.Email.Exchange.Schema Namespace


CalendarViewType Members

CalendarViewType overview

Public Instance Constructors

CalendarViewType Constructor Initializes a new instance of the CalendarViewType class.

Public Instance Properties

EndDate
MaxEntriesReturned (inherited from BasePagingType)
MaxEntriesReturnedSpecified (inherited from BasePagingType)
StartDate

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CalendarViewType Class | Aspose.Email.Exchange.Schema Namespace


CalendarViewType Constructor

Initializes a new instance of the CalendarViewType class.

public CalendarViewType();

See Also

CalendarViewType Class | Aspose.Email.Exchange.Schema Namespace


CalendarViewType Properties

The properties of the CalendarViewType class are listed below. For a complete list of CalendarViewType class members, see the CalendarViewType Members topic.

Public Instance Properties

EndDate
MaxEntriesReturned (inherited from BasePagingType)
MaxEntriesReturnedSpecified (inherited from BasePagingType)
StartDate

See Also

CalendarViewType Class | Aspose.Email.Exchange.Schema Namespace


EndDate Property

Aspose.Email

CalendarViewType.EndDate Property

public DateTime EndDate {get; set;}

Remarks

See Also

CalendarViewType Class | Aspose.Email.Exchange.Schema Namespace


StartDate Property

Aspose.Email

CalendarViewType.StartDate Property

public DateTime StartDate {get; set;}

Remarks

See Also

CalendarViewType Class | Aspose.Email.Exchange.Schema Namespace


CancelCalendarItemType Class

For a list of all members of this type, see CancelCalendarItemType Members.

System.Object
Aspose.Email.Exchange.Schema.ItemType
Aspose.Email.Exchange.Schema.MessageType
Aspose.Email.Exchange.Schema.ResponseObjectCoreType
Aspose.Email.Exchange.Schema.ResponseObjectType
Aspose.Email.Exchange.Schema.SmartResponseBaseType
Aspose.Email.Exchange.Schema.SmartResponseType
Aspose.Email.Exchange.Schema.CancelCalendarItemType

public class CancelCalendarItemType : SmartResponseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CancelCalendarItemType Members | Aspose.Email.Exchange.Schema Namespace


CancelCalendarItemType Members

CancelCalendarItemType overview

Public Instance Constructors

CancelCalendarItemType Constructor Initializes a new instance of the CancelCalendarItemType class.

Public Instance Properties

Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
From (inherited from MessageType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
NewBodyContent (inherited from SmartResponseType)
ObjectName (inherited from ResponseObjectType)
ParentFolderId (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
ReferenceItemId (inherited from ResponseObjectCoreType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
Subject (inherited from ItemType)
ToRecipients (inherited from MessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CancelCalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


CancelCalendarItemType Constructor

Initializes a new instance of the CancelCalendarItemType class.

public CancelCalendarItemType();

See Also

CancelCalendarItemType Class | Aspose.Email.Exchange.Schema Namespace


ChangeDescriptionType Class

For a list of all members of this type, see ChangeDescriptionType Members.

System.Object
Aspose.Email.Exchange.Schema.ChangeDescriptionType
Aspose.Email.Exchange.Schema.FolderChangeDescriptionType
Aspose.Email.Exchange.Schema.ItemChangeDescriptionType

public abstract class ChangeDescriptionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ChangeDescriptionType Members | Aspose.Email.Exchange.Schema Namespace


ChangeDescriptionType Members

ChangeDescriptionType overview

Public Instance Properties

Item

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

ChangeDescriptionType Constructor Initializes a new instance of the ChangeDescriptionType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ChangeDescriptionType Class | Aspose.Email.Exchange.Schema Namespace


ChangeDescriptionType Constructor

Initializes a new instance of the ChangeDescriptionType class.

protected ChangeDescriptionType();

See Also

ChangeDescriptionType Class | Aspose.Email.Exchange.Schema Namespace


ChangeDescriptionType Properties

The properties of the ChangeDescriptionType class are listed below. For a complete list of ChangeDescriptionType class members, see the ChangeDescriptionType Members topic.

Public Instance Properties

Item

See Also

ChangeDescriptionType Class | Aspose.Email.Exchange.Schema Namespace


Item Property

Aspose.Email

ChangeDescriptionType.Item Property

public BasePathToElementType Item {get; set;}

Remarks

See Also

ChangeDescriptionType Class | Aspose.Email.Exchange.Schema Namespace


CompleteNameType Class

For a list of all members of this type, see CompleteNameType Members.

System.Object
Aspose.Email.Exchange.Schema.CompleteNameType

public class CompleteNameType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CompleteNameType Members | Aspose.Email.Exchange.Schema Namespace


CompleteNameType Members

CompleteNameType overview

Public Instance Constructors

CompleteNameType Constructor Initializes a new instance of the CompleteNameType class.

Public Instance Properties

FirstName
FullName
Initials
LastName
MiddleName
Nickname
Suffix
Title
YomiFirstName
YomiLastName

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CompleteNameType Class | Aspose.Email.Exchange.Schema Namespace


CompleteNameType Constructor

Initializes a new instance of the CompleteNameType class.

public CompleteNameType();

See Also

CompleteNameType Class | Aspose.Email.Exchange.Schema Namespace


CompleteNameType Properties

The properties of the CompleteNameType class are listed below. For a complete list of CompleteNameType class members, see the CompleteNameType Members topic.

Public Instance Properties

FirstName
FullName
Initials
LastName
MiddleName
Nickname
Suffix
Title
YomiFirstName
YomiLastName

See Also

CompleteNameType Class | Aspose.Email.Exchange.Schema Namespace


FirstName Property

Aspose.Email

CompleteNameType.FirstName Property

public string FirstName {get; set;}

Remarks

See Also

CompleteNameType Class | Aspose.Email.Exchange.Schema Namespace


FullName Property

Aspose.Email

CompleteNameType.FullName Property

public string FullName {get; set;}

Remarks

See Also

CompleteNameType Class | Aspose.Email.Exchange.Schema Namespace


Initials Property

Aspose.Email

CompleteNameType.Initials Property

public string Initials {get; set;}

Remarks

See Also

CompleteNameType Class | Aspose.Email.Exchange.Schema Namespace


LastName Property

Aspose.Email

CompleteNameType.LastName Property

public string LastName {get; set;}

Remarks

See Also

CompleteNameType Class | Aspose.Email.Exchange.Schema Namespace


MiddleName Property

Aspose.Email

CompleteNameType.MiddleName Property

public string MiddleName {get; set;}

Remarks

See Also

CompleteNameType Class | Aspose.Email.Exchange.Schema Namespace


Nickname Property

Aspose.Email

CompleteNameType.Nickname Property

public string Nickname {get; set;}

Remarks

See Also

CompleteNameType Class | Aspose.Email.Exchange.Schema Namespace


Suffix Property

Aspose.Email

CompleteNameType.Suffix Property

public string Suffix {get; set;}

Remarks

See Also

CompleteNameType Class | Aspose.Email.Exchange.Schema Namespace


Title Property

Aspose.Email

CompleteNameType.Title Property

public string Title {get; set;}

Remarks

See Also

CompleteNameType Class | Aspose.Email.Exchange.Schema Namespace


YomiFirstName Property

Aspose.Email

CompleteNameType.YomiFirstName Property

public string YomiFirstName {get; set;}

Remarks

See Also

CompleteNameType Class | Aspose.Email.Exchange.Schema Namespace


YomiLastName Property

Aspose.Email

CompleteNameType.YomiLastName Property

public string YomiLastName {get; set;}

Remarks

See Also

CompleteNameType Class | Aspose.Email.Exchange.Schema Namespace


ConflictResolutionType Enumeration

public enum ConflictResolutionType

Remarks

Members

Member Name | Description | Value
NeverOverwrite |  | 0
AutoResolve |  | 1
AlwaysOverwrite |  | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


ConflictResultsType Class

For a list of all members of this type, see ConflictResultsType Members.

System.Object
Aspose.Email.Exchange.Schema.ConflictResultsType

public class ConflictResultsType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ConflictResultsType Members | Aspose.Email.Exchange.Schema Namespace


ConflictResultsType Members

ConflictResultsType overview

Public Instance Constructors

ConflictResultsType Constructor Initializes a new instance of the ConflictResultsType class.

Public Instance Properties

Count

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConflictResultsType Class | Aspose.Email.Exchange.Schema Namespace


ConflictResultsType Constructor

Initializes a new instance of the ConflictResultsType class.

public ConflictResultsType();

See Also

ConflictResultsType Class | Aspose.Email.Exchange.Schema Namespace


ConflictResultsType Properties

The properties of the ConflictResultsType class are listed below. For a complete list of ConflictResultsType class members, see the ConflictResultsType Members topic.

Public Instance Properties

Count

See Also

ConflictResultsType Class | Aspose.Email.Exchange.Schema Namespace


Count Property

Aspose.Email

ConflictResultsType.Count Property

public int Count {get; set;}

Remarks

See Also

ConflictResultsType Class | Aspose.Email.Exchange.Schema Namespace


ConnectingSIDType Class

For a list of all members of this type, see ConnectingSIDType Members.

System.Object
Aspose.Email.Exchange.Schema.ConnectingSIDType

public class ConnectingSIDType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ConnectingSIDType Members | Aspose.Email.Exchange.Schema Namespace


ConnectingSIDType Members

ConnectingSIDType overview

Public Instance Constructors

ConnectingSIDType Constructor Initializes a new instance of the ConnectingSIDType class.

Public Instance Properties

Item
ItemElementName

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConnectingSIDType Class | Aspose.Email.Exchange.Schema Namespace


ConnectingSIDType Constructor

Initializes a new instance of the ConnectingSIDType class.

public ConnectingSIDType();

See Also

ConnectingSIDType Class | Aspose.Email.Exchange.Schema Namespace


ConnectingSIDType Properties

The properties of the ConnectingSIDType class are listed below. For a complete list of ConnectingSIDType class members, see the ConnectingSIDType Members topic.

Public Instance Properties

Item
ItemElementName

See Also

ConnectingSIDType Class | Aspose.Email.Exchange.Schema Namespace


Item Property

Aspose.Email

ConnectingSIDType.Item Property

public string Item {get; set;}

Remarks

See Also

ConnectingSIDType Class | Aspose.Email.Exchange.Schema Namespace


ItemElementName Property

Aspose.Email

ConnectingSIDType.ItemElementName Property

public ItemChoiceType ItemElementName {get; set;}

Remarks

See Also

ConnectingSIDType Class | Aspose.Email.Exchange.Schema Namespace


ConnectionFailureCauseType Enumeration

public enum ConnectionFailureCauseType

Remarks

Members

Member Name | Description | Value
None |  | 0
UserBusy |  | 1
NoAnswer |  | 2
Unavailable |  | 3
Other |  | 4

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


ConnectionStatusType Enumeration

public enum ConnectionStatusType

Remarks

Members

Member Name | Description | Value
OK |  | 0
Closed |  | 1

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


ConstantValueType Class

For a list of all members of this type, see ConstantValueType Members.

System.Object
Aspose.Email.Exchange.Schema.ConstantValueType

public class ConstantValueType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ConstantValueType Members | Aspose.Email.Exchange.Schema Namespace


ConstantValueType Members

ConstantValueType overview

Public Instance Constructors

ConstantValueType Constructor Initializes a new instance of the ConstantValueType class.

Public Instance Properties

Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConstantValueType Class | Aspose.Email.Exchange.Schema Namespace


ConstantValueType Constructor

Initializes a new instance of the ConstantValueType class.

public ConstantValueType();

See Also

ConstantValueType Class | Aspose.Email.Exchange.Schema Namespace


ConstantValueType Properties

The properties of the ConstantValueType class are listed below. For a complete list of ConstantValueType class members, see the ConstantValueType Members topic.

Public Instance Properties

Value

See Also

ConstantValueType Class | Aspose.Email.Exchange.Schema Namespace


Value Property

Aspose.Email

ConstantValueType.Value Property

public string Value {get; set;}

Remarks

See Also

ConstantValueType Class | Aspose.Email.Exchange.Schema Namespace


ContactItemType Class

For a list of all members of this type, see ContactItemType Members.

System.Object
Aspose.Email.Exchange.Schema.ItemType
Aspose.Email.Exchange.Schema.ContactItemType

public class ContactItemType : ItemType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ContactItemType Members | Aspose.Email.Exchange.Schema Namespace


ContactItemType Members

ContactItemType overview

Public Instance Constructors

ContactItemType Constructor Initializes a new instance of the ContactItemType class.

Public Instance Properties

AssistantName
Attachments (inherited from ItemType)
Birthday
BirthdaySpecified
Body (inherited from ItemType)
BusinessHomePage
Categories (inherited from ItemType)
Children
Companies
CompanyName
CompleteName
ContactSource
ContactSourceSpecified
ConversationId (inherited from ItemType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
Department
DisplayCc (inherited from ItemType)
DisplayName
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
EmailAddresses
ExtendedProperty (inherited from ItemType)
FileAs
FileAsMapping
FileAsMappingSpecified
Generation
GivenName
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasPicture
HasPictureSpecified
ImAddresses
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
Initials
InReplyTo (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
JobTitle
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
Manager
MiddleName
Mileage
MimeContent (inherited from ItemType)
Nickname
OfficeLocation
ParentFolderId (inherited from ItemType)
PhoneNumbers
PhysicalAddresses
PostalAddressIndex
PostalAddressIndexSpecified
Profession
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ResponseObjects (inherited from ItemType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
SpouseName
Subject (inherited from ItemType)
Surname
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)
WeddingAnniversary
WeddingAnniversarySpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema Namespace


ContactItemType Constructor

Initializes a new instance of the ContactItemType class.

public ContactItemType();

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema Namespace


ContactItemType Properties

The properties of the ContactItemType class are listed below. For a complete list of ContactItemType class members, see the ContactItemType Members topic.

Public Instance Properties

AssistantName
Attachments (inherited from ItemType)
Birthday
BirthdaySpecified
Body (inherited from ItemType)
BusinessHomePage
Categories (inherited from ItemType)
Children
Companies
CompanyName
CompleteName
ContactSource
ContactSourceSpecified
ConversationId (inherited from ItemType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
Department
DisplayCc (inherited from ItemType)
DisplayName
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
EmailAddresses
ExtendedProperty (inherited from ItemType)
FileAs
FileAsMapping
FileAsMappingSpecified
Generation
GivenName
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasPicture
HasPictureSpecified
ImAddresses
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
Initials
InReplyTo (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
JobTitle
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
Manager
MiddleName
Mileage
MimeContent (inherited from ItemType)
Nickname
OfficeLocation
ParentFolderId (inherited from ItemType)
PhoneNumbers
PhysicalAddresses
PostalAddressIndex
PostalAddressIndexSpecified
Profession
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ResponseObjects (inherited from ItemType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
SpouseName
Subject (inherited from ItemType)
Surname
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)
WeddingAnniversary
WeddingAnniversarySpecified

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema Namespace


AssistantName Property

Aspose.Email

ContactItemType.AssistantName Property

public string AssistantName {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema Namespace


Birthday Property

Aspose.Email

ContactItemType.Birthday Property

public DateTime Birthday {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema Namespace


BirthdaySpecified Property

Aspose.Email

ContactItemType.BirthdaySpecified Property

public bool BirthdaySpecified {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema Namespace


BusinessHomePage Property

Aspose.Email

ContactItemType.BusinessHomePage Property

public string BusinessHomePage {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema Namespace


Children Property

Aspose.Email

ContactItemType.Children Property

public string[] Children {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema Namespace


Companies Property

Aspose.Email

ContactItemType.Companies Property

public string[] Companies {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema Namespace


CompanyName Property

Aspose.Email

ContactItemType.CompanyName Property

public string CompanyName {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema Namespace


CompleteName Property

Aspose.Email

ContactItemType.CompleteName Property

public CompleteNameType CompleteName {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema Namespace


ContactSource Property

Aspose.Email

ContactItemType.ContactSource Property

public ContactSourceType ContactSource {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema Namespace


ContactSourceSpecified Property

Aspose.Email

ContactItemType.ContactSourceSpecified Property

public bool ContactSourceSpecified {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema Namespace


Department Property

Aspose.Email

ContactItemType.Department Property

public string Department {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema Namespace


DisplayName Property

Aspose.Email

ContactItemType.DisplayName Property

public string DisplayName {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema Namespace


EmailAddresses Property

Aspose.Email

ContactItemType.EmailAddresses Property

public EmailAddressDictionaryEntryType[] EmailAddresses {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema Namespace


FileAs Property

Aspose.Email

ContactItemType.FileAs Property

public string FileAs {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema Namespace


FileAsMapping Property

Aspose.Email

ContactItemType.FileAsMapping Property

public FileAsMappingType FileAsMapping {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema Namespace


FileAsMappingSpecified Property

Aspose.Email

ContactItemType.FileAsMappingSpecified Property

public bool FileAsMappingSpecified {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema Namespace


Generation Property

Aspose.Email

ContactItemType.Generation Property

public string Generation {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema Namespace


GivenName Property

Aspose.Email

ContactItemType.GivenName Property

public string GivenName {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema Namespace


HasPicture Property

Aspose.Email

ContactItemType.HasPicture Property

public bool HasPicture {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema Namespace


HasPictureSpecified Property

Aspose.Email

ContactItemType.HasPictureSpecified Property

public bool HasPictureSpecified {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema Namespace


ImAddresses Property

Aspose.Email

ContactItemType.ImAddresses Property

public ImAddressDictionaryEntryType[] ImAddresses {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema Namespace


Initials Property

Aspose.Email

ContactItemType.Initials Property

public string Initials {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema Namespace


JobTitle Property

Aspose.Email

ContactItemType.JobTitle Property

public string JobTitle {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema Namespace


Manager Property

Aspose.Email

ContactItemType.Manager Property

public string Manager {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema Namespace


MiddleName Property

Aspose.Email

ContactItemType.MiddleName Property

public string MiddleName {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema Namespace


Mileage Property

Aspose.Email

ContactItemType.Mileage Property

public string Mileage {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema Namespace


Nickname Property

Aspose.Email

ContactItemType.Nickname Property

public string Nickname {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema Namespace


OfficeLocation Property

Aspose.Email

ContactItemType.OfficeLocation Property

public string OfficeLocation {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema Namespace


PhoneNumbers Property

Aspose.Email

ContactItemType.PhoneNumbers Property

public PhoneNumberDictionaryEntryType[] PhoneNumbers {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema Namespace


PhysicalAddresses Property

Aspose.Email

ContactItemType.PhysicalAddresses Property

public PhysicalAddressDictionaryEntryType[] PhysicalAddresses {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema Namespace


PostalAddressIndex Property

Aspose.Email

ContactItemType.PostalAddressIndex Property

public PhysicalAddressIndexType PostalAddressIndex {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema Namespace


PostalAddressIndexSpecified Property

Aspose.Email

ContactItemType.PostalAddressIndexSpecified Property

public bool PostalAddressIndexSpecified {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema Namespace


Profession Property

Aspose.Email

ContactItemType.Profession Property

public string Profession {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema Namespace


SpouseName Property

Aspose.Email

ContactItemType.SpouseName Property

public string SpouseName {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema Namespace


Surname Property

Aspose.Email

ContactItemType.Surname Property

public string Surname {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema Namespace


WeddingAnniversary Property

Aspose.Email

ContactItemType.WeddingAnniversary Property

public DateTime WeddingAnniversary {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema Namespace


WeddingAnniversarySpecified Property

Aspose.Email

ContactItemType.WeddingAnniversarySpecified Property

public bool WeddingAnniversarySpecified {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema Namespace


ContactsFolderType Class

For a list of all members of this type, see ContactsFolderType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseFolderType
Aspose.Email.Exchange.Schema.ContactsFolderType

public class ContactsFolderType : BaseFolderType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ContactsFolderType Members | Aspose.Email.Exchange.Schema Namespace


ContactsFolderType Members

ContactsFolderType overview

Public Instance Constructors

ContactsFolderType Constructor Initializes a new instance of the ContactsFolderType class.

Public Instance Properties

ChildFolderCount (inherited from BaseFolderType)
ChildFolderCountSpecified (inherited from BaseFolderType)
DisplayName (inherited from BaseFolderType)
EffectiveRights (inherited from BaseFolderType)
ExtendedProperty (inherited from BaseFolderType)
FolderClass (inherited from BaseFolderType)
FolderId (inherited from BaseFolderType)
ManagedFolderInformation (inherited from BaseFolderType)
ParentFolderId (inherited from BaseFolderType)
PermissionSet
SharingEffectiveRights
SharingEffectiveRightsSpecified
TotalCount (inherited from BaseFolderType)
TotalCountSpecified (inherited from BaseFolderType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ContactsFolderType Class | Aspose.Email.Exchange.Schema Namespace


ContactsFolderType Constructor

Initializes a new instance of the ContactsFolderType class.

public ContactsFolderType();

See Also

ContactsFolderType Class | Aspose.Email.Exchange.Schema Namespace


ContactsFolderType Properties

The properties of the ContactsFolderType class are listed below. For a complete list of ContactsFolderType class members, see the ContactsFolderType Members topic.

Public Instance Properties

ChildFolderCount (inherited from BaseFolderType)
ChildFolderCountSpecified (inherited from BaseFolderType)
DisplayName (inherited from BaseFolderType)
EffectiveRights (inherited from BaseFolderType)
ExtendedProperty (inherited from BaseFolderType)
FolderClass (inherited from BaseFolderType)
FolderId (inherited from BaseFolderType)
ManagedFolderInformation (inherited from BaseFolderType)
ParentFolderId (inherited from BaseFolderType)
PermissionSet
SharingEffectiveRights
SharingEffectiveRightsSpecified
TotalCount (inherited from BaseFolderType)
TotalCountSpecified (inherited from BaseFolderType)

See Also

ContactsFolderType Class | Aspose.Email.Exchange.Schema Namespace


PermissionSet Property

Aspose.Email

ContactsFolderType.PermissionSet Property

public PermissionSetType PermissionSet {get; set;}

Remarks

See Also

ContactsFolderType Class | Aspose.Email.Exchange.Schema Namespace


SharingEffectiveRights Property

Aspose.Email

ContactsFolderType.SharingEffectiveRights Property

public PermissionReadAccessType SharingEffectiveRights {get; set;}

Remarks

See Also

ContactsFolderType Class | Aspose.Email.Exchange.Schema Namespace


SharingEffectiveRightsSpecified Property

Aspose.Email

ContactsFolderType.SharingEffectiveRightsSpecified Property

public bool SharingEffectiveRightsSpecified {get; set;}

Remarks

See Also

ContactsFolderType Class | Aspose.Email.Exchange.Schema Namespace


ContactSourceType Enumeration

public enum ContactSourceType

Remarks

Members

Member Name | Description | Value
ActiveDirectory |  | 0
Store |  | 1

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


ContactsViewType Class

For a list of all members of this type, see ContactsViewType Members.

System.Object
Aspose.Email.Exchange.Schema.BasePagingType
Aspose.Email.Exchange.Schema.ContactsViewType

public class ContactsViewType : BasePagingType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ContactsViewType Members | Aspose.Email.Exchange.Schema Namespace


ContactsViewType Members

ContactsViewType overview

Public Instance Constructors

ContactsViewType Constructor Initializes a new instance of the ContactsViewType class.

Public Instance Properties

FinalName
InitialName
MaxEntriesReturned (inherited from BasePagingType)
MaxEntriesReturnedSpecified (inherited from BasePagingType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ContactsViewType Class | Aspose.Email.Exchange.Schema Namespace


ContactsViewType Constructor

Initializes a new instance of the ContactsViewType class.

public ContactsViewType();

See Also

ContactsViewType Class | Aspose.Email.Exchange.Schema Namespace


ContactsViewType Properties

The properties of the ContactsViewType class are listed below. For a complete list of ContactsViewType class members, see the ContactsViewType Members topic.

Public Instance Properties

FinalName
InitialName
MaxEntriesReturned (inherited from BasePagingType)
MaxEntriesReturnedSpecified (inherited from BasePagingType)

See Also

ContactsViewType Class | Aspose.Email.Exchange.Schema Namespace


FinalName Property

Aspose.Email

ContactsViewType.FinalName Property

public string FinalName {get; set;}

Remarks

See Also

ContactsViewType Class | Aspose.Email.Exchange.Schema Namespace


InitialName Property

Aspose.Email

ContactsViewType.InitialName Property

public string InitialName {get; set;}

Remarks

See Also

ContactsViewType Class | Aspose.Email.Exchange.Schema Namespace


ContainmentComparisonType Enumeration

public enum ContainmentComparisonType

Remarks

Members

Member Name | Description | Value
Exact |  | 0
IgnoreCase |  | 1
IgnoreNonSpacingCharacters |  | 2
Loose |  | 3
IgnoreCaseAndNonSpacingCharacters |  | 4
LooseAndIgnoreCase |  | 5
LooseAndIgnoreNonSpace |  | 6
LooseAndIgnoreCaseAndIgnoreNonSpace |  | 7

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


ContainmentModeType Enumeration

public enum ContainmentModeType

Remarks

Members

Member Name | Description | Value
FullString |  | 0
Prefixed |  | 1
Substring |  | 2
PrefixOnWords |  | 3
ExactPhrase |  | 4

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


ContainsExpressionType Class

For a list of all members of this type, see ContainsExpressionType Members.

System.Object
Aspose.Email.Exchange.Schema.SearchExpressionType
Aspose.Email.Exchange.Schema.ContainsExpressionType

public class ContainsExpressionType : SearchExpressionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ContainsExpressionType Members | Aspose.Email.Exchange.Schema Namespace


ContainsExpressionType Members

ContainsExpressionType overview

Public Instance Constructors

ContainsExpressionType Constructor Initializes a new instance of the ContainsExpressionType class.

Public Instance Properties

Constant
ContainmentComparison
ContainmentComparisonSpecified
ContainmentMode
ContainmentModeSpecified
Item

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ContainsExpressionType Class | Aspose.Email.Exchange.Schema Namespace


ContainsExpressionType Constructor

Initializes a new instance of the ContainsExpressionType class.

public ContainsExpressionType();

See Also

ContainsExpressionType Class | Aspose.Email.Exchange.Schema Namespace


ContainsExpressionType Properties

The properties of the ContainsExpressionType class are listed below. For a complete list of ContainsExpressionType class members, see the ContainsExpressionType Members topic.

Public Instance Properties

Constant
ContainmentComparison
ContainmentComparisonSpecified
ContainmentMode
ContainmentModeSpecified
Item

See Also

ContainsExpressionType Class | Aspose.Email.Exchange.Schema Namespace


Constant Property

Aspose.Email

ContainsExpressionType.Constant Property

public ConstantValueType Constant {get; set;}

Remarks

See Also

ContainsExpressionType Class | Aspose.Email.Exchange.Schema Namespace


ContainmentComparison Property

Aspose.Email

ContainsExpressionType.ContainmentComparison Property

public ContainmentComparisonType ContainmentComparison {get; set;}

Remarks

See Also

ContainsExpressionType Class | Aspose.Email.Exchange.Schema Namespace


ContainmentComparisonSpecified Property

Aspose.Email

ContainsExpressionType.ContainmentComparisonSpecified Property

public bool ContainmentComparisonSpecified {get; set;}

Remarks

See Also

ContainsExpressionType Class | Aspose.Email.Exchange.Schema Namespace


ContainmentMode Property

Aspose.Email

ContainsExpressionType.ContainmentMode Property

public ContainmentModeType ContainmentMode {get; set;}

Remarks

See Also

ContainsExpressionType Class | Aspose.Email.Exchange.Schema Namespace


ContainmentModeSpecified Property

Aspose.Email

ContainsExpressionType.ContainmentModeSpecified Property

public bool ContainmentModeSpecified {get; set;}

Remarks

See Also

ContainsExpressionType Class | Aspose.Email.Exchange.Schema Namespace


Item Property

Aspose.Email

ContainsExpressionType.Item Property

public BasePathToElementType Item {get; set;}

Remarks

See Also

ContainsExpressionType Class | Aspose.Email.Exchange.Schema Namespace


ConversationActionType Class

Represents a single action to be applied to a conversation.

For a list of all members of this type, see ConversationActionType Members.

System.Object
Aspose.Email.Exchange.Schema.ConversationActionType

public class ConversationActionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ConversationActionType Members | Aspose.Email.Exchange.Schema Namespace


ConversationActionType Members

ConversationActionType overview

Public Instance Constructors

ConversationActionType Constructor Initializes a new instance of the ConversationActionType class.

Public Instance Properties

Action | Gets or sets the action to perform on the conversation
Categories | Specifies the categories to set on items in a conversation.
ContextFolderId | Gets or sets the folder that is targeted for actions that use folders.
ConversationId | Gets or sets the conversation identifier of the targeted conversation for applying an action.
ConversationLastSyncTime | Gets or sets the date and time that a conversation was last synchronized.
ConversationLastSyncTimeSpecified | Gets or sets a value indicating whether the ConversationLastSyncTime is specified
DeleteType | Gets or sets how items in a conversation are deleted.
DeleteTypeSpecified | Gets or sets a value indicating whether the DeleteType is specified
DestinationFolderId | Gets or sets the destination folder for copy and move actions.
EnableAlwaysDelete | Gets or sts a value indicating whether the deletion for all new items in a conversation is enabled.
EnableAlwaysDeleteSpecified | Gets or sets a value indicating whether the EnableAlwaysDelete is specified
IsRead | Gets or sets a value indicating whether enables setting the read state of items in a conversation.
IsReadSpecified | Gets or sets a value indicating whether the IsRead is specified
ProcessRightAway | Gets or set a value indicating whether the response is sent as soon as the action starts processing on the server or whether the response is sent after the action has completed.
ProcessRightAwaySpecified | Gets or sets a value indicating whether the ProcessRightAway is specified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConversationActionType Class | Aspose.Email.Exchange.Schema Namespace


ConversationActionType Constructor

Initializes a new instance of the ConversationActionType class.

public ConversationActionType();

See Also

ConversationActionType Class | Aspose.Email.Exchange.Schema Namespace


ConversationActionType Properties

The properties of the ConversationActionType class are listed below. For a complete list of ConversationActionType class members, see the ConversationActionType Members topic.

Public Instance Properties

Action | Gets or sets the action to perform on the conversation
Categories | Specifies the categories to set on items in a conversation.
ContextFolderId | Gets or sets the folder that is targeted for actions that use folders.
ConversationId | Gets or sets the conversation identifier of the targeted conversation for applying an action.
ConversationLastSyncTime | Gets or sets the date and time that a conversation was last synchronized.
ConversationLastSyncTimeSpecified | Gets or sets a value indicating whether the ConversationLastSyncTime is specified
DeleteType | Gets or sets how items in a conversation are deleted.
DeleteTypeSpecified | Gets or sets a value indicating whether the DeleteType is specified
DestinationFolderId | Gets or sets the destination folder for copy and move actions.
EnableAlwaysDelete | Gets or sts a value indicating whether the deletion for all new items in a conversation is enabled.
EnableAlwaysDeleteSpecified | Gets or sets a value indicating whether the EnableAlwaysDelete is specified
IsRead | Gets or sets a value indicating whether enables setting the read state of items in a conversation.
IsReadSpecified | Gets or sets a value indicating whether the IsRead is specified
ProcessRightAway | Gets or set a value indicating whether the response is sent as soon as the action starts processing on the server or whether the response is sent after the action has completed.
ProcessRightAwaySpecified | Gets or sets a value indicating whether the ProcessRightAway is specified

See Also

ConversationActionType Class | Aspose.Email.Exchange.Schema Namespace


Action Property

Aspose.Email

ConversationActionType.Action Property

Gets or sets the action to perform on the conversation

public ConversationActionTypeType Action {get; set;}

See Also

ConversationActionType Class | Aspose.Email.Exchange.Schema Namespace


Categories Property

Aspose.Email

ConversationActionType.Categories Property

Specifies the categories to set on items in a conversation.

public string[] Categories {get; set;}

See Also

ConversationActionType Class | Aspose.Email.Exchange.Schema Namespace


ContextFolderId Property

Aspose.Email

ConversationActionType.ContextFolderId Property

Gets or sets the folder that is targeted for actions that use folders.

public TargetFolderIdType ContextFolderId {get; set;}

See Also

ConversationActionType Class | Aspose.Email.Exchange.Schema Namespace


ConversationId Property

Aspose.Email

ConversationActionType.ConversationId Property

Gets or sets the conversation identifier of the targeted conversation for applying an action.

public ItemIdType ConversationId {get; set;}

See Also

ConversationActionType Class | Aspose.Email.Exchange.Schema Namespace


ConversationLastSyncTime Property

Aspose.Email

ConversationActionType.ConversationLastSyncTime Property

Gets or sets the date and time that a conversation was last synchronized.

public DateTime ConversationLastSyncTime {get; set;}

See Also

ConversationActionType Class | Aspose.Email.Exchange.Schema Namespace


ConversationLastSyncTimeSpecified Property

Aspose.Email

ConversationActionType.ConversationLastSyncTimeSpecified Property

Gets or sets a value indicating whether the ConversationLastSyncTime is specified

public bool ConversationLastSyncTimeSpecified {get; set;}

See Also

ConversationActionType Class | Aspose.Email.Exchange.Schema Namespace


DeleteType Property

Aspose.Email

ConversationActionType.DeleteType Property

Gets or sets how items in a conversation are deleted.

public DisposalType DeleteType {get; set;}

See Also

ConversationActionType Class | Aspose.Email.Exchange.Schema Namespace


DeleteTypeSpecified Property

Aspose.Email

ConversationActionType.DeleteTypeSpecified Property

Gets or sets a value indicating whether the DeleteType is specified

public bool DeleteTypeSpecified {get; set;}

See Also

ConversationActionType Class | Aspose.Email.Exchange.Schema Namespace


DestinationFolderId Property

Aspose.Email

ConversationActionType.DestinationFolderId Property

Gets or sets the destination folder for copy and move actions.

public TargetFolderIdType DestinationFolderId {get; set;}

See Also

ConversationActionType Class | Aspose.Email.Exchange.Schema Namespace


EnableAlwaysDelete Property

Aspose.Email

ConversationActionType.EnableAlwaysDelete Property

Gets or sts a value indicating whether the deletion for all new items in a conversation is enabled.

public bool EnableAlwaysDelete {get; set;}

See Also

ConversationActionType Class | Aspose.Email.Exchange.Schema Namespace


EnableAlwaysDeleteSpecified Property

Aspose.Email

ConversationActionType.EnableAlwaysDeleteSpecified Property

Gets or sets a value indicating whether the EnableAlwaysDelete is specified

public bool EnableAlwaysDeleteSpecified {get; set;}

See Also

ConversationActionType Class | Aspose.Email.Exchange.Schema Namespace


IsRead Property

Aspose.Email

ConversationActionType.IsRead Property

Gets or sets a value indicating whether enables setting the read state of items in a conversation.

public bool IsRead {get; set;}

See Also

ConversationActionType Class | Aspose.Email.Exchange.Schema Namespace


IsReadSpecified Property

Aspose.Email

ConversationActionType.IsReadSpecified Property

Gets or sets a value indicating whether the IsRead is specified

public bool IsReadSpecified {get; set;}

See Also

ConversationActionType Class | Aspose.Email.Exchange.Schema Namespace


ProcessRightAway Property

Aspose.Email

ConversationActionType.ProcessRightAway Property

Gets or set a value indicating whether the response is sent as soon as the action starts processing on the server or whether the response is sent after the action has completed.

public bool ProcessRightAway {get; set;}

See Also

ConversationActionType Class | Aspose.Email.Exchange.Schema Namespace


ProcessRightAwaySpecified Property

Aspose.Email

ConversationActionType.ProcessRightAwaySpecified Property

Gets or sets a value indicating whether the ProcessRightAway is specified

public bool ProcessRightAwaySpecified {get; set;}

See Also

ConversationActionType Class | Aspose.Email.Exchange.Schema Namespace


ConversationActionTypeType Enumeration

Enumerates the action to apply to items in a conversation.

public enum ConversationActionTypeType

Members

Member Name | Description | Value
AlwaysCategorize | Specifies that items in the conversation are always categorized. | 0
AlwaysDelete | Specifies that items in the conversation are always deleted. | 1
AlwaysMove | Specifies that items in the conversation are always moved. | 2
Delete | Specifies that items in the conversation are to be deleted. | 3
Move | Specifies that items in the conversation are to be moved. | 4
Copy | Specifies that items in the conversation are to be copied. | 5
SetReadState | Specifies that items in the conversation are to have the read state set. | 6

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


ConversationType Class

Represents a single conversation

For a list of all members of this type, see ConversationType Members.

System.Object
Aspose.Email.Exchange.Schema.ConversationType

public class ConversationType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ConversationType Members | Aspose.Email.Exchange.Schema Namespace


ConversationType Members

ConversationType overview

Public Instance Constructors

ConversationType Constructor Initializes a new instance of the ConversationType class.

Public Instance Properties

Categories | Gets or sets the category list for conversation items in the current folder.
ConversationId | Gets or sets the conversation identifier.
ConversationTopic | Gets or sets the conversation topic.
FlagStatus | Gets or sets the aggregated flag status for conversation items in the current folder.
FlagStatusSpecified | Gets or sets a value indicating whether the FlagStatus is specified
GlobalCategories | Gets or sets the category list for all conversation items in a mamailboxilbox.
GlobalFlagStatus | Gets or sets the aggregated flag status for all conversation items in a mailbox.
GlobalFlagStatusSpecified | Gets or sets a value indicating whether the GlobalFlagStatus is specified
GlobalHasAttachments | Gets or sets a value indicating whether at least one conversation item in a mailbox has an attachment.
GlobalHasAttachmentsSpecified | Gets or sets a value indicating whether the GlobalHasAttachments is specified
GlobalImportance | Gets or sets the aggregated importance for all conversation items in a mailbox.
GlobalImportanceSpecified | Gets or sets a value indicating whether the GlobalImportance is specified
GlobalItemClasses | Gets or sets a list of item classes that represents all the item classes of the conversation items in a mailbox.
GlobalItemIds | Gets or sets the collection of item identifiers for all conversation items in a mailbox.
GlobalLastDeliveryTime | Gets or sets the delivery time of the message that was last received in this conversation across all folders in the mailbox.
GlobalLastDeliveryTimeSpecified | Gets or sets a value indicating whether the GlobalLastDeliveryTime is specified
GlobalMessageCount | Gets or sets the total number of conversation items in the mailbox.
GlobalMessageCountSpecified | Gets or sets a value indicating whether the GlobalMessageCount is specified
GlobalSize | Gets or sets the size of the conversation calculated from the size of all conversation items in the mailbox.
GlobalSizeSpecified | Gets or sets a value indicating whether the GlobalSize is specified
GlobalUniqueRecipients | Gets or sets a list of all the people who have received messages in this conversation across all folders in the mailbox.
GlobalUniqueSenders | Gets or sets a list of all the senders of conversation items in the mailbox.
GlobalUniqueUnreadSenders | Gets or sets a list of all the people who have sent messages that are currently unread in this conversation across all folders in the mailbox.
GlobalUnreadCount | Gets or sets a count of all the unread conversation items in the mailbox.
GlobalUnreadCountSpecified | Gets or sets a value indicating whether the GlobalUnreadCount is specified
HasAttachments | Gets or sets a value indicating whether at least one conversation item in the current folder has an attachment.
HasAttachmentsSpecified | Gets or sets a value indicating whether the GlobalFlagStatus is specified
Importance | Gets or sets the aggregated importance for all conversation items in the current folder.
ImportanceSpecified | Gets or sets a value indicating whether the Importance is specified
ItemClasses | Gets or sets a list of item classes that represents all the item classes of the conversation items in the current folder
ItemIds | Gets or sets the collection of item identifiers for all conversation items in the current folder.
LastDeliveryTime | Gets or sets the delivery time of the message that was last received in this conversation in the current folder.
LastDeliveryTimeSpecified | Gets or sets a value indicating whether the LastDeliveryTime is specified
MessageCount | Gets or sets the total number of conversation items in the current folder.
MessageCountSpecified | Gets or sets a value indicating whether the MessageCount is specified
Size | Gets or sets the size of the conversation calculated from the size of all conversation items in the current folder.
SizeSpecified | Gets or sets a value indicating whether the Size is specified
UniqueRecipients | Gets or sets the list of all the people who have received messages in this conversation for messages in the current folder.
UniqueSenders | Gets or sets a list of all the senders of conversation items in the current folder.
UniqueUnreadSenders | Gets or sets a list of all the people who have sent messages that are currently unread in this conversation in the current folder.
UnreadCount | Gets or sets a count of all the unread conversation items in the current folder.
UnreadCountSpecified | Gets or sets a value indicating whether the UnreadCount is specified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConversationType Class | Aspose.Email.Exchange.Schema Namespace


ConversationType Constructor

Initializes a new instance of the ConversationType class.

public ConversationType();

See Also

ConversationType Class | Aspose.Email.Exchange.Schema Namespace


ConversationType Properties

The properties of the ConversationType class are listed below. For a complete list of ConversationType class members, see the ConversationType Members topic.

Public Instance Properties

Categories | Gets or sets the category list for conversation items in the current folder.
ConversationId | Gets or sets the conversation identifier.
ConversationTopic | Gets or sets the conversation topic.
FlagStatus | Gets or sets the aggregated flag status for conversation items in the current folder.
FlagStatusSpecified | Gets or sets a value indicating whether the FlagStatus is specified
GlobalCategories | Gets or sets the category list for all conversation items in a mamailboxilbox.
GlobalFlagStatus | Gets or sets the aggregated flag status for all conversation items in a mailbox.
GlobalFlagStatusSpecified | Gets or sets a value indicating whether the GlobalFlagStatus is specified
GlobalHasAttachments | Gets or sets a value indicating whether at least one conversation item in a mailbox has an attachment.
GlobalHasAttachmentsSpecified | Gets or sets a value indicating whether the GlobalHasAttachments is specified
GlobalImportance | Gets or sets the aggregated importance for all conversation items in a mailbox.
GlobalImportanceSpecified | Gets or sets a value indicating whether the GlobalImportance is specified
GlobalItemClasses | Gets or sets a list of item classes that represents all the item classes of the conversation items in a mailbox.
GlobalItemIds | Gets or sets the collection of item identifiers for all conversation items in a mailbox.
GlobalLastDeliveryTime | Gets or sets the delivery time of the message that was last received in this conversation across all folders in the mailbox.
GlobalLastDeliveryTimeSpecified | Gets or sets a value indicating whether the GlobalLastDeliveryTime is specified
GlobalMessageCount | Gets or sets the total number of conversation items in the mailbox.
GlobalMessageCountSpecified | Gets or sets a value indicating whether the GlobalMessageCount is specified
GlobalSize | Gets or sets the size of the conversation calculated from the size of all conversation items in the mailbox.
GlobalSizeSpecified | Gets or sets a value indicating whether the GlobalSize is specified
GlobalUniqueRecipients | Gets or sets a list of all the people who have received messages in this conversation across all folders in the mailbox.
GlobalUniqueSenders | Gets or sets a list of all the senders of conversation items in the mailbox.
GlobalUniqueUnreadSenders | Gets or sets a list of all the people who have sent messages that are currently unread in this conversation across all folders in the mailbox.
GlobalUnreadCount | Gets or sets a count of all the unread conversation items in the mailbox.
GlobalUnreadCountSpecified | Gets or sets a value indicating whether the GlobalUnreadCount is specified
HasAttachments | Gets or sets a value indicating whether at least one conversation item in the current folder has an attachment.
HasAttachmentsSpecified | Gets or sets a value indicating whether the GlobalFlagStatus is specified
Importance | Gets or sets the aggregated importance for all conversation items in the current folder.
ImportanceSpecified | Gets or sets a value indicating whether the Importance is specified
ItemClasses | Gets or sets a list of item classes that represents all the item classes of the conversation items in the current folder
ItemIds | Gets or sets the collection of item identifiers for all conversation items in the current folder.
LastDeliveryTime | Gets or sets the delivery time of the message that was last received in this conversation in the current folder.
LastDeliveryTimeSpecified | Gets or sets a value indicating whether the LastDeliveryTime is specified
MessageCount | Gets or sets the total number of conversation items in the current folder.
MessageCountSpecified | Gets or sets a value indicating whether the MessageCount is specified
Size | Gets or sets the size of the conversation calculated from the size of all conversation items in the current folder.
SizeSpecified | Gets or sets a value indicating whether the Size is specified
UniqueRecipients | Gets or sets the list of all the people who have received messages in this conversation for messages in the current folder.
UniqueSenders | Gets or sets a list of all the senders of conversation items in the current folder.
UniqueUnreadSenders | Gets or sets a list of all the people who have sent messages that are currently unread in this conversation in the current folder.
UnreadCount | Gets or sets a count of all the unread conversation items in the current folder.
UnreadCountSpecified | Gets or sets a value indicating whether the UnreadCount is specified

See Also

ConversationType Class | Aspose.Email.Exchange.Schema Namespace


Categories Property

Aspose.Email

ConversationType.Categories Property

Gets or sets the category list for conversation items in the current folder.

public string[] Categories {get; set;}

See Also

ConversationType Class | Aspose.Email.Exchange.Schema Namespace


ConversationId Property

Aspose.Email

ConversationType.ConversationId Property

Gets or sets the conversation identifier.

public ItemIdType ConversationId {get; set;}

See Also

ConversationType Class | Aspose.Email.Exchange.Schema Namespace


ConversationTopic Property

Aspose.Email

ConversationType.ConversationTopic Property

Gets or sets the conversation topic.

public string ConversationTopic {get; set;}

See Also

ConversationType Class | Aspose.Email.Exchange.Schema Namespace


FlagStatus Property

Aspose.Email

ConversationType.FlagStatus Property

Gets or sets the aggregated flag status for conversation items in the current folder.

public FlagStatusType FlagStatus {get; set;}

See Also

ConversationType Class | Aspose.Email.Exchange.Schema Namespace


FlagStatusSpecified Property

Aspose.Email

ConversationType.FlagStatusSpecified Property

Gets or sets a value indicating whether the FlagStatus is specified

public bool FlagStatusSpecified {get; set;}

See Also

ConversationType Class | Aspose.Email.Exchange.Schema Namespace


GlobalCategories Property

Aspose.Email

ConversationType.GlobalCategories Property

Gets or sets the category list for all conversation items in a mamailboxilbox.

public string[] GlobalCategories {get; set;}

See Also

ConversationType Class | Aspose.Email.Exchange.Schema Namespace


GlobalFlagStatus Property

Aspose.Email

ConversationType.GlobalFlagStatus Property

Gets or sets the aggregated flag status for all conversation items in a mailbox.

public FlagStatusType GlobalFlagStatus {get; set;}

See Also

ConversationType Class | Aspose.Email.Exchange.Schema Namespace


GlobalFlagStatusSpecified Property

Aspose.Email

ConversationType.GlobalFlagStatusSpecified Property

Gets or sets a value indicating whether the GlobalFlagStatus is specified

public bool GlobalFlagStatusSpecified {get; set;}

See Also

ConversationType Class | Aspose.Email.Exchange.Schema Namespace


GlobalHasAttachments Property

Aspose.Email

ConversationType.GlobalHasAttachments Property

Gets or sets a value indicating whether at least one conversation item in a mailbox has an attachment.

public bool GlobalHasAttachments {get; set;}

See Also

ConversationType Class | Aspose.Email.Exchange.Schema Namespace


GlobalHasAttachmentsSpecified Property

Aspose.Email

ConversationType.GlobalHasAttachmentsSpecified Property

Gets or sets a value indicating whether the GlobalHasAttachments is specified

public bool GlobalHasAttachmentsSpecified {get; set;}

See Also

ConversationType Class | Aspose.Email.Exchange.Schema Namespace


GlobalImportance Property

Aspose.Email

ConversationType.GlobalImportance Property

Gets or sets the aggregated importance for all conversation items in a mailbox.

public ImportanceChoicesType GlobalImportance {get; set;}

See Also

ConversationType Class | Aspose.Email.Exchange.Schema Namespace


GlobalImportanceSpecified Property

Aspose.Email

ConversationType.GlobalImportanceSpecified Property

Gets or sets a value indicating whether the GlobalImportance is specified

public bool GlobalImportanceSpecified {get; set;}

See Also

ConversationType Class | Aspose.Email.Exchange.Schema Namespace


GlobalItemClasses Property

Aspose.Email

ConversationType.GlobalItemClasses Property

Gets or sets a list of item classes that represents all the item classes of the conversation items in a mailbox.

public string[] GlobalItemClasses {get; set;}

See Also

ConversationType Class | Aspose.Email.Exchange.Schema Namespace


GlobalItemIds Property

Aspose.Email

ConversationType.GlobalItemIds Property

Gets or sets the collection of item identifiers for all conversation items in a mailbox.

public BaseItemIdType[] GlobalItemIds {get; set;}

See Also

ConversationType Class | Aspose.Email.Exchange.Schema Namespace


GlobalLastDeliveryTime Property

Aspose.Email

ConversationType.GlobalLastDeliveryTime Property

Gets or sets the delivery time of the message that was last received in this conversation across all folders in the mailbox.

public DateTime GlobalLastDeliveryTime {get; set;}

See Also

ConversationType Class | Aspose.Email.Exchange.Schema Namespace


GlobalLastDeliveryTimeSpecified Property

Aspose.Email

ConversationType.GlobalLastDeliveryTimeSpecified Property

Gets or sets a value indicating whether the GlobalLastDeliveryTime is specified

public bool GlobalLastDeliveryTimeSpecified {get; set;}

See Also

ConversationType Class | Aspose.Email.Exchange.Schema Namespace


GlobalMessageCount Property

Aspose.Email

ConversationType.GlobalMessageCount Property

Gets or sets the total number of conversation items in the mailbox.

public int GlobalMessageCount {get; set;}

See Also

ConversationType Class | Aspose.Email.Exchange.Schema Namespace


GlobalMessageCountSpecified Property

Aspose.Email

ConversationType.GlobalMessageCountSpecified Property

Gets or sets a value indicating whether the GlobalMessageCount is specified

public bool GlobalMessageCountSpecified {get; set;}

See Also

ConversationType Class | Aspose.Email.Exchange.Schema Namespace


GlobalSize Property

Aspose.Email

ConversationType.GlobalSize Property

Gets or sets the size of the conversation calculated from the size of all conversation items in the mailbox.

public int GlobalSize {get; set;}

See Also

ConversationType Class | Aspose.Email.Exchange.Schema Namespace


GlobalSizeSpecified Property

Aspose.Email

ConversationType.GlobalSizeSpecified Property

Gets or sets a value indicating whether the GlobalSize is specified

public bool GlobalSizeSpecified {get; set;}

See Also

ConversationType Class | Aspose.Email.Exchange.Schema Namespace


GlobalUniqueRecipients Property

Aspose.Email

ConversationType.GlobalUniqueRecipients Property

Gets or sets a list of all the people who have received messages in this conversation across all folders in the mailbox.

public string[] GlobalUniqueRecipients {get; set;}

See Also

ConversationType Class | Aspose.Email.Exchange.Schema Namespace


GlobalUniqueSenders Property

Aspose.Email

ConversationType.GlobalUniqueSenders Property

Gets or sets a list of all the senders of conversation items in the mailbox.

public string[] GlobalUniqueSenders {get; set;}

See Also

ConversationType Class | Aspose.Email.Exchange.Schema Namespace


GlobalUniqueUnreadSenders Property

Aspose.Email

ConversationType.GlobalUniqueUnreadSenders Property

Gets or sets a list of all the people who have sent messages that are currently unread in this conversation across all folders in the mailbox.

public string[] GlobalUniqueUnreadSenders {get; set;}

See Also

ConversationType Class | Aspose.Email.Exchange.Schema Namespace


GlobalUnreadCount Property

Aspose.Email

ConversationType.GlobalUnreadCount Property

Gets or sets a count of all the unread conversation items in the mailbox.

public int GlobalUnreadCount {get; set;}

See Also

ConversationType Class | Aspose.Email.Exchange.Schema Namespace


GlobalUnreadCountSpecified Property

Aspose.Email

ConversationType.GlobalUnreadCountSpecified Property

Gets or sets a value indicating whether the GlobalUnreadCount is specified

public bool GlobalUnreadCountSpecified {get; set;}

See Also

ConversationType Class | Aspose.Email.Exchange.Schema Namespace


HasAttachments Property

Aspose.Email

ConversationType.HasAttachments Property

Gets or sets a value indicating whether at least one conversation item in the current folder has an attachment.

public bool HasAttachments {get; set;}

See Also

ConversationType Class | Aspose.Email.Exchange.Schema Namespace


HasAttachmentsSpecified Property

Aspose.Email

ConversationType.HasAttachmentsSpecified Property

Gets or sets a value indicating whether the GlobalFlagStatus is specified

public bool HasAttachmentsSpecified {get; set;}

See Also

ConversationType Class | Aspose.Email.Exchange.Schema Namespace


Importance Property

Aspose.Email

ConversationType.Importance Property

Gets or sets the aggregated importance for all conversation items in the current folder.

public ImportanceChoicesType Importance {get; set;}

See Also

ConversationType Class | Aspose.Email.Exchange.Schema Namespace


ImportanceSpecified Property

Aspose.Email

ConversationType.ImportanceSpecified Property

Gets or sets a value indicating whether the Importance is specified

public bool ImportanceSpecified {get; set;}

See Also

ConversationType Class | Aspose.Email.Exchange.Schema Namespace


ItemClasses Property

Aspose.Email

ConversationType.ItemClasses Property

Gets or sets a list of item classes that represents all the item classes of the conversation items in the current folder

public string[] ItemClasses {get; set;}

See Also

ConversationType Class | Aspose.Email.Exchange.Schema Namespace


ItemIds Property

Aspose.Email

ConversationType.ItemIds Property

Gets or sets the collection of item identifiers for all conversation items in the current folder.

public BaseItemIdType[] ItemIds {get; set;}

See Also

ConversationType Class | Aspose.Email.Exchange.Schema Namespace


LastDeliveryTime Property

Aspose.Email

ConversationType.LastDeliveryTime Property

Gets or sets the delivery time of the message that was last received in this conversation in the current folder.

public DateTime LastDeliveryTime {get; set;}

See Also

ConversationType Class | Aspose.Email.Exchange.Schema Namespace


LastDeliveryTimeSpecified Property

Aspose.Email

ConversationType.LastDeliveryTimeSpecified Property

Gets or sets a value indicating whether the LastDeliveryTime is specified

public bool LastDeliveryTimeSpecified {get; set;}

See Also

ConversationType Class | Aspose.Email.Exchange.Schema Namespace


MessageCount Property

Aspose.Email

ConversationType.MessageCount Property

Gets or sets the total number of conversation items in the current folder.

public int MessageCount {get; set;}

See Also

ConversationType Class | Aspose.Email.Exchange.Schema Namespace


MessageCountSpecified Property

Aspose.Email

ConversationType.MessageCountSpecified Property

Gets or sets a value indicating whether the MessageCount is specified

public bool MessageCountSpecified {get; set;}

See Also

ConversationType Class | Aspose.Email.Exchange.Schema Namespace


Size Property

Aspose.Email

ConversationType.Size Property

Gets or sets the size of the conversation calculated from the size of all conversation items in the current folder.

public int Size {get; set;}

See Also

ConversationType Class | Aspose.Email.Exchange.Schema Namespace


SizeSpecified Property

Aspose.Email

ConversationType.SizeSpecified Property

Gets or sets a value indicating whether the Size is specified

public bool SizeSpecified {get; set;}

See Also

ConversationType Class | Aspose.Email.Exchange.Schema Namespace


UniqueRecipients Property

Aspose.Email

ConversationType.UniqueRecipients Property

Gets or sets the list of all the people who have received messages in this conversation for messages in the current folder.

public string[] UniqueRecipients {get; set;}

See Also

ConversationType Class | Aspose.Email.Exchange.Schema Namespace


UniqueSenders Property

Aspose.Email

ConversationType.UniqueSenders Property

Gets or sets a list of all the senders of conversation items in the current folder.

public string[] UniqueSenders {get; set;}

See Also

ConversationType Class | Aspose.Email.Exchange.Schema Namespace


UniqueUnreadSenders Property

Aspose.Email

ConversationType.UniqueUnreadSenders Property

Gets or sets a list of all the people who have sent messages that are currently unread in this conversation in the current folder.

public string[] UniqueUnreadSenders {get; set;}

See Also

ConversationType Class | Aspose.Email.Exchange.Schema Namespace


UnreadCount Property

Aspose.Email

ConversationType.UnreadCount Property

Gets or sets a count of all the unread conversation items in the current folder.

public int UnreadCount {get; set;}

See Also

ConversationType Class | Aspose.Email.Exchange.Schema Namespace


UnreadCountSpecified Property

Aspose.Email

ConversationType.UnreadCountSpecified Property

Gets or sets a value indicating whether the UnreadCount is specified

public bool UnreadCountSpecified {get; set;}

See Also

ConversationType Class | Aspose.Email.Exchange.Schema Namespace


ConvertIdCompletedEventArgs Class

For a list of all members of this type, see ConvertIdCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.ConvertIdCompletedEventArgs

public class ConvertIdCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ConvertIdCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


ConvertIdCompletedEventArgs Members

ConvertIdCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

ConvertIdCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


ConvertIdCompletedEventArgs Properties

The properties of the ConvertIdCompletedEventArgs class are listed below. For a complete list of ConvertIdCompletedEventArgs class members, see the ConvertIdCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

ConvertIdCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

ConvertIdCompletedEventArgs.Result Property

public ConvertIdResponseType Result {get;}

Remarks

See Also

ConvertIdCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


ConvertIdCompletedEventHandler Delegate

public delegate void ConvertIdCompletedEventHandler(
object sender,
ConvertIdCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


ConvertIdResponseMessageType Class

For a list of all members of this type, see ConvertIdResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ResponseMessageType
Aspose.Email.Exchange.Schema.ConvertIdResponseMessageType

public class ConvertIdResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ConvertIdResponseMessageType Members | Aspose.Email.Exchange.Schema Namespace


ConvertIdResponseMessageType Members

ConvertIdResponseMessageType overview

Public Instance Constructors

ConvertIdResponseMessageType Constructor Initializes a new instance of the ConvertIdResponseMessageType class.

Public Instance Properties

AlternateId
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConvertIdResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


ConvertIdResponseMessageType Constructor

Initializes a new instance of the ConvertIdResponseMessageType class.

public ConvertIdResponseMessageType();

See Also

ConvertIdResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


ConvertIdResponseMessageType Properties

The properties of the ConvertIdResponseMessageType class are listed below. For a complete list of ConvertIdResponseMessageType class members, see the ConvertIdResponseMessageType Members topic.

Public Instance Properties

AlternateId
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

ConvertIdResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


AlternateId Property

Aspose.Email

ConvertIdResponseMessageType.AlternateId Property

public AlternateIdBaseType AlternateId {get; set;}

Remarks

See Also

ConvertIdResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


ConvertIdResponseType Class

For a list of all members of this type, see ConvertIdResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseResponseMessageType
Aspose.Email.Exchange.Schema.ConvertIdResponseType

public class ConvertIdResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ConvertIdResponseType Members | Aspose.Email.Exchange.Schema Namespace


ConvertIdResponseType Members

ConvertIdResponseType overview

Public Instance Constructors

ConvertIdResponseType Constructor Initializes a new instance of the ConvertIdResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConvertIdResponseType Class | Aspose.Email.Exchange.Schema Namespace


ConvertIdResponseType Constructor

Initializes a new instance of the ConvertIdResponseType class.

public ConvertIdResponseType();

See Also

ConvertIdResponseType Class | Aspose.Email.Exchange.Schema Namespace


ConvertIdType Class

For a list of all members of this type, see ConvertIdType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.ConvertIdType

public class ConvertIdType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ConvertIdType Members | Aspose.Email.Exchange.Schema Namespace


ConvertIdType Members

ConvertIdType overview

Public Instance Constructors

ConvertIdType Constructor Initializes a new instance of the ConvertIdType class.

Public Instance Properties

DestinationFormat
SourceIds

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConvertIdType Class | Aspose.Email.Exchange.Schema Namespace


ConvertIdType Constructor

Initializes a new instance of the ConvertIdType class.

public ConvertIdType();

See Also

ConvertIdType Class | Aspose.Email.Exchange.Schema Namespace


ConvertIdType Properties

The properties of the ConvertIdType class are listed below. For a complete list of ConvertIdType class members, see the ConvertIdType Members topic.

Public Instance Properties

DestinationFormat
SourceIds

See Also

ConvertIdType Class | Aspose.Email.Exchange.Schema Namespace


DestinationFormat Property

Aspose.Email

ConvertIdType.DestinationFormat Property

public IdFormatType DestinationFormat {get; set;}

Remarks

See Also

ConvertIdType Class | Aspose.Email.Exchange.Schema Namespace


SourceIds Property

Aspose.Email

ConvertIdType.SourceIds Property

public AlternateIdBaseType[] SourceIds {get; set;}

Remarks

See Also

ConvertIdType Class | Aspose.Email.Exchange.Schema Namespace


CopyFolderCompletedEventArgs Class

For a list of all members of this type, see CopyFolderCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.CopyFolderCompletedEventArgs

public class CopyFolderCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CopyFolderCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


CopyFolderCompletedEventArgs Members

CopyFolderCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

CopyFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


CopyFolderCompletedEventArgs Properties

The properties of the CopyFolderCompletedEventArgs class are listed below. For a complete list of CopyFolderCompletedEventArgs class members, see the CopyFolderCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

CopyFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

CopyFolderCompletedEventArgs.Result Property

public CopyFolderResponseType Result {get;}

Remarks

See Also

CopyFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


CopyFolderCompletedEventHandler Delegate

public delegate void CopyFolderCompletedEventHandler(
object sender,
CopyFolderCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


CopyFolderResponseType Class

For a list of all members of this type, see CopyFolderResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseResponseMessageType
Aspose.Email.Exchange.Schema.CopyFolderResponseType

public class CopyFolderResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CopyFolderResponseType Members | Aspose.Email.Exchange.Schema Namespace


CopyFolderResponseType Members

CopyFolderResponseType overview

Public Instance Constructors

CopyFolderResponseType Constructor Initializes a new instance of the CopyFolderResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CopyFolderResponseType Class | Aspose.Email.Exchange.Schema Namespace


CopyFolderResponseType Constructor

Initializes a new instance of the CopyFolderResponseType class.

public CopyFolderResponseType();

See Also

CopyFolderResponseType Class | Aspose.Email.Exchange.Schema Namespace


CopyFolderType Class

For a list of all members of this type, see CopyFolderType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.BaseMoveCopyFolderType
Aspose.Email.Exchange.Schema.CopyFolderType

public class CopyFolderType : BaseMoveCopyFolderType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CopyFolderType Members | Aspose.Email.Exchange.Schema Namespace


CopyFolderType Members

CopyFolderType overview

Public Instance Constructors

CopyFolderType Constructor Initializes a new instance of the CopyFolderType class.

Public Instance Properties

FolderIds (inherited from BaseMoveCopyFolderType)
ToFolderId (inherited from BaseMoveCopyFolderType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CopyFolderType Class | Aspose.Email.Exchange.Schema Namespace


CopyFolderType Constructor

Initializes a new instance of the CopyFolderType class.

public CopyFolderType();

See Also

CopyFolderType Class | Aspose.Email.Exchange.Schema Namespace


CopyItemCompletedEventArgs Class

For a list of all members of this type, see CopyItemCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.CopyItemCompletedEventArgs

public class CopyItemCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CopyItemCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


CopyItemCompletedEventArgs Members

CopyItemCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

CopyItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


CopyItemCompletedEventArgs Properties

The properties of the CopyItemCompletedEventArgs class are listed below. For a complete list of CopyItemCompletedEventArgs class members, see the CopyItemCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

CopyItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

CopyItemCompletedEventArgs.Result Property

public CopyItemResponseType Result {get;}

Remarks

See Also

CopyItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


CopyItemCompletedEventHandler Delegate

public delegate void CopyItemCompletedEventHandler(
object sender,
CopyItemCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


CopyItemResponseType Class

For a list of all members of this type, see CopyItemResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseResponseMessageType
Aspose.Email.Exchange.Schema.CopyItemResponseType

public class CopyItemResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CopyItemResponseType Members | Aspose.Email.Exchange.Schema Namespace


CopyItemResponseType Members

CopyItemResponseType overview

Public Instance Constructors

CopyItemResponseType Constructor Initializes a new instance of the CopyItemResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CopyItemResponseType Class | Aspose.Email.Exchange.Schema Namespace


CopyItemResponseType Constructor

Initializes a new instance of the CopyItemResponseType class.

public CopyItemResponseType();

See Also

CopyItemResponseType Class | Aspose.Email.Exchange.Schema Namespace


CopyItemType Class

For a list of all members of this type, see CopyItemType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.BaseMoveCopyItemType
Aspose.Email.Exchange.Schema.CopyItemType

public class CopyItemType : BaseMoveCopyItemType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CopyItemType Members | Aspose.Email.Exchange.Schema Namespace


CopyItemType Members

CopyItemType overview

Public Instance Constructors

CopyItemType Constructor Initializes a new instance of the CopyItemType class.

Public Instance Properties

ItemIds (inherited from BaseMoveCopyItemType)
ReturnNewItemIds (inherited from BaseMoveCopyItemType)
ReturnNewItemIdsSpecified (inherited from BaseMoveCopyItemType)
ToFolderId (inherited from BaseMoveCopyItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CopyItemType Class | Aspose.Email.Exchange.Schema Namespace


CopyItemType Constructor

Initializes a new instance of the CopyItemType class.

public CopyItemType();

See Also

CopyItemType Class | Aspose.Email.Exchange.Schema Namespace


CreateActionType Enumeration

NOTE: This enumeration is now obsolete.

ExchangeWebServiceClient and related classes are obsolete and will be removed soon. Please uses new EWSClient.

Enumerates the action for uploading items into a mailbox

public enum CreateActionType

Members

Member Name | Description | Value
CreateNew | Specifies that a new copy of the original item is uploaded to the mailbox. | 0
Update | Specifies that the upload will update an item that is already present in the mailbox. | 1
UpdateOrCreate | Specifies an attempt to first update the item. | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


CreateAttachmentCompletedEventArgs Class

For a list of all members of this type, see CreateAttachmentCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.CreateAttachmentCompletedEventArgs

public class CreateAttachmentCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CreateAttachmentCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


CreateAttachmentCompletedEventArgs Members

CreateAttachmentCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

CreateAttachmentCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


CreateAttachmentCompletedEventArgs Properties

The properties of the CreateAttachmentCompletedEventArgs class are listed below. For a complete list of CreateAttachmentCompletedEventArgs class members, see the CreateAttachmentCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

CreateAttachmentCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

CreateAttachmentCompletedEventArgs.Result Property

public CreateAttachmentResponseType Result {get;}

Remarks

See Also

CreateAttachmentCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


CreateAttachmentCompletedEventHandler Delegate

public delegate void CreateAttachmentCompletedEventHandler(
object sender,
CreateAttachmentCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


CreateAttachmentResponseType Class

For a list of all members of this type, see CreateAttachmentResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseResponseMessageType
Aspose.Email.Exchange.Schema.CreateAttachmentResponseType

public class CreateAttachmentResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CreateAttachmentResponseType Members | Aspose.Email.Exchange.Schema Namespace


CreateAttachmentResponseType Members

CreateAttachmentResponseType overview

Public Instance Constructors

CreateAttachmentResponseType Constructor Initializes a new instance of the CreateAttachmentResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CreateAttachmentResponseType Class | Aspose.Email.Exchange.Schema Namespace


CreateAttachmentResponseType Constructor

Initializes a new instance of the CreateAttachmentResponseType class.

public CreateAttachmentResponseType();

See Also

CreateAttachmentResponseType Class | Aspose.Email.Exchange.Schema Namespace


CreateAttachmentType Class

For a list of all members of this type, see CreateAttachmentType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.CreateAttachmentType

public class CreateAttachmentType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CreateAttachmentType Members | Aspose.Email.Exchange.Schema Namespace


CreateAttachmentType Members

CreateAttachmentType overview

Public Instance Constructors

CreateAttachmentType Constructor Initializes a new instance of the CreateAttachmentType class.

Public Instance Properties

Attachments
ParentItemId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CreateAttachmentType Class | Aspose.Email.Exchange.Schema Namespace


CreateAttachmentType Constructor

Initializes a new instance of the CreateAttachmentType class.

public CreateAttachmentType();

See Also

CreateAttachmentType Class | Aspose.Email.Exchange.Schema Namespace


CreateAttachmentType Properties

The properties of the CreateAttachmentType class are listed below. For a complete list of CreateAttachmentType class members, see the CreateAttachmentType Members topic.

Public Instance Properties

Attachments
ParentItemId

See Also

CreateAttachmentType Class | Aspose.Email.Exchange.Schema Namespace


Attachments Property

Aspose.Email

CreateAttachmentType.Attachments Property

public AttachmentType[] Attachments {get; set;}

Remarks

See Also

CreateAttachmentType Class | Aspose.Email.Exchange.Schema Namespace


ParentItemId Property

Aspose.Email

CreateAttachmentType.ParentItemId Property

public ItemIdType ParentItemId {get; set;}

Remarks

See Also

CreateAttachmentType Class | Aspose.Email.Exchange.Schema Namespace


CreateFolderCompletedEventArgs Class

For a list of all members of this type, see CreateFolderCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.CreateFolderCompletedEventArgs

public class CreateFolderCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CreateFolderCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


CreateFolderCompletedEventArgs Members

CreateFolderCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

CreateFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


CreateFolderCompletedEventArgs Properties

The properties of the CreateFolderCompletedEventArgs class are listed below. For a complete list of CreateFolderCompletedEventArgs class members, see the CreateFolderCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

CreateFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

CreateFolderCompletedEventArgs.Result Property

public CreateFolderResponseType Result {get;}

Remarks

See Also

CreateFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


CreateFolderCompletedEventHandler Delegate

public delegate void CreateFolderCompletedEventHandler(
object sender,
CreateFolderCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


CreateFolderResponseType Class

For a list of all members of this type, see CreateFolderResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseResponseMessageType
Aspose.Email.Exchange.Schema.CreateFolderResponseType

public class CreateFolderResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CreateFolderResponseType Members | Aspose.Email.Exchange.Schema Namespace


CreateFolderResponseType Members

CreateFolderResponseType overview

Public Instance Constructors

CreateFolderResponseType Constructor Initializes a new instance of the CreateFolderResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CreateFolderResponseType Class | Aspose.Email.Exchange.Schema Namespace


CreateFolderResponseType Constructor

Initializes a new instance of the CreateFolderResponseType class.

public CreateFolderResponseType();

See Also

CreateFolderResponseType Class | Aspose.Email.Exchange.Schema Namespace


CreateFolderType Class

For a list of all members of this type, see CreateFolderType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.CreateFolderType

public class CreateFolderType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CreateFolderType Members | Aspose.Email.Exchange.Schema Namespace


CreateFolderType Members

CreateFolderType overview

Public Instance Constructors

CreateFolderType Constructor Initializes a new instance of the CreateFolderType class.

Public Instance Properties

Folders
ParentFolderId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CreateFolderType Class | Aspose.Email.Exchange.Schema Namespace


CreateFolderType Constructor

Initializes a new instance of the CreateFolderType class.

public CreateFolderType();

See Also

CreateFolderType Class | Aspose.Email.Exchange.Schema Namespace


CreateFolderType Properties

The properties of the CreateFolderType class are listed below. For a complete list of CreateFolderType class members, see the CreateFolderType Members topic.

Public Instance Properties

Folders
ParentFolderId

See Also

CreateFolderType Class | Aspose.Email.Exchange.Schema Namespace


Folders Property

Aspose.Email

CreateFolderType.Folders Property

public BaseFolderType[] Folders {get; set;}

Remarks

See Also

CreateFolderType Class | Aspose.Email.Exchange.Schema Namespace


ParentFolderId Property

Aspose.Email

CreateFolderType.ParentFolderId Property

public TargetFolderIdType ParentFolderId {get; set;}

Remarks

See Also

CreateFolderType Class | Aspose.Email.Exchange.Schema Namespace


CreateItemCompletedEventArgs Class

For a list of all members of this type, see CreateItemCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.CreateItemCompletedEventArgs

public class CreateItemCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CreateItemCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


CreateItemCompletedEventArgs Members

CreateItemCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

CreateItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


CreateItemCompletedEventArgs Properties

The properties of the CreateItemCompletedEventArgs class are listed below. For a complete list of CreateItemCompletedEventArgs class members, see the CreateItemCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

CreateItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

CreateItemCompletedEventArgs.Result Property

public CreateItemResponseType Result {get;}

Remarks

See Also

CreateItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


CreateItemCompletedEventHandler Delegate

public delegate void CreateItemCompletedEventHandler(
object sender,
CreateItemCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


CreateItemResponseType Class

For a list of all members of this type, see CreateItemResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseResponseMessageType
Aspose.Email.Exchange.Schema.CreateItemResponseType

public class CreateItemResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CreateItemResponseType Members | Aspose.Email.Exchange.Schema Namespace


CreateItemResponseType Members

CreateItemResponseType overview

Public Instance Constructors

CreateItemResponseType Constructor Initializes a new instance of the CreateItemResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CreateItemResponseType Class | Aspose.Email.Exchange.Schema Namespace


CreateItemResponseType Constructor

Initializes a new instance of the CreateItemResponseType class.

public CreateItemResponseType();

See Also

CreateItemResponseType Class | Aspose.Email.Exchange.Schema Namespace


CreateItemType Class

For a list of all members of this type, see CreateItemType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.CreateItemType

public class CreateItemType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CreateItemType Members | Aspose.Email.Exchange.Schema Namespace


CreateItemType Members

CreateItemType overview

Public Instance Constructors

CreateItemType Constructor Initializes a new instance of the CreateItemType class.

Public Instance Properties

Items
MessageDisposition
MessageDispositionSpecified
SavedItemFolderId
SendMeetingInvitations
SendMeetingInvitationsSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CreateItemType Class | Aspose.Email.Exchange.Schema Namespace


CreateItemType Constructor

Initializes a new instance of the CreateItemType class.

public CreateItemType();

See Also

CreateItemType Class | Aspose.Email.Exchange.Schema Namespace


CreateItemType Properties

The properties of the CreateItemType class are listed below. For a complete list of CreateItemType class members, see the CreateItemType Members topic.

Public Instance Properties

Items
MessageDisposition
MessageDispositionSpecified
SavedItemFolderId
SendMeetingInvitations
SendMeetingInvitationsSpecified

See Also

CreateItemType Class | Aspose.Email.Exchange.Schema Namespace


Items Property

Aspose.Email

CreateItemType.Items Property

public NonEmptyArrayOfAllItemsType Items {get; set;}

Remarks

See Also

CreateItemType Class | Aspose.Email.Exchange.Schema Namespace


MessageDisposition Property

Aspose.Email

CreateItemType.MessageDisposition Property

public MessageDispositionType MessageDisposition {get; set;}

Remarks

See Also

CreateItemType Class | Aspose.Email.Exchange.Schema Namespace


MessageDispositionSpecified Property

Aspose.Email

CreateItemType.MessageDispositionSpecified Property

public bool MessageDispositionSpecified {get; set;}

Remarks

See Also

CreateItemType Class | Aspose.Email.Exchange.Schema Namespace


SavedItemFolderId Property

Aspose.Email

CreateItemType.SavedItemFolderId Property

public TargetFolderIdType SavedItemFolderId {get; set;}

Remarks

See Also

CreateItemType Class | Aspose.Email.Exchange.Schema Namespace


SendMeetingInvitations Property

Aspose.Email

CreateItemType.SendMeetingInvitations Property

public CalendarItemCreateOrDeleteOperationType SendMeetingInvitations {get; set;}

Remarks

See Also

CreateItemType Class | Aspose.Email.Exchange.Schema Namespace


SendMeetingInvitationsSpecified Property

Aspose.Email

CreateItemType.SendMeetingInvitationsSpecified Property

public bool SendMeetingInvitationsSpecified {get; set;}

Remarks

See Also

CreateItemType Class | Aspose.Email.Exchange.Schema Namespace


CreateManagedFolderCompletedEventArgs Class

For a list of all members of this type, see CreateManagedFolderCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.CreateManagedFolderCompletedEventArgs

public class CreateManagedFolderCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CreateManagedFolderCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


CreateManagedFolderCompletedEventArgs Members

CreateManagedFolderCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

CreateManagedFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


CreateManagedFolderCompletedEventArgs Properties

The properties of the CreateManagedFolderCompletedEventArgs class are listed below. For a complete list of CreateManagedFolderCompletedEventArgs class members, see the CreateManagedFolderCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

CreateManagedFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

CreateManagedFolderCompletedEventArgs.Result Property

public CreateManagedFolderResponseType Result {get;}

Remarks

See Also

CreateManagedFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


CreateManagedFolderCompletedEventHandler Delegate

public delegate void CreateManagedFolderCompletedEventHandler(
object sender,
CreateManagedFolderCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


CreateManagedFolderRequestType Class

For a list of all members of this type, see CreateManagedFolderRequestType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.CreateManagedFolderRequestType

public class CreateManagedFolderRequestType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CreateManagedFolderRequestType Members | Aspose.Email.Exchange.Schema Namespace


CreateManagedFolderRequestType Members

CreateManagedFolderRequestType overview

Public Instance Constructors

CreateManagedFolderRequestType Constructor Initializes a new instance of the CreateManagedFolderRequestType class.

Public Instance Properties

FolderNames
Mailbox

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CreateManagedFolderRequestType Class | Aspose.Email.Exchange.Schema Namespace


CreateManagedFolderRequestType Constructor

Initializes a new instance of the CreateManagedFolderRequestType class.

public CreateManagedFolderRequestType();

See Also

CreateManagedFolderRequestType Class | Aspose.Email.Exchange.Schema Namespace


CreateManagedFolderRequestType Properties

The properties of the CreateManagedFolderRequestType class are listed below. For a complete list of CreateManagedFolderRequestType class members, see the CreateManagedFolderRequestType Members topic.

Public Instance Properties

FolderNames
Mailbox

See Also

CreateManagedFolderRequestType Class | Aspose.Email.Exchange.Schema Namespace


FolderNames Property

Aspose.Email

CreateManagedFolderRequestType.FolderNames Property

public string[] FolderNames {get; set;}

Remarks

See Also

CreateManagedFolderRequestType Class | Aspose.Email.Exchange.Schema Namespace


Mailbox Property

Aspose.Email

CreateManagedFolderRequestType.Mailbox Property

public EmailAddressType Mailbox {get; set;}

Remarks

See Also

CreateManagedFolderRequestType Class | Aspose.Email.Exchange.Schema Namespace


CreateManagedFolderResponseType Class

For a list of all members of this type, see CreateManagedFolderResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseResponseMessageType
Aspose.Email.Exchange.Schema.CreateManagedFolderResponseType

public class CreateManagedFolderResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CreateManagedFolderResponseType Members | Aspose.Email.Exchange.Schema Namespace


CreateManagedFolderResponseType Members

CreateManagedFolderResponseType overview

Public Instance Constructors

CreateManagedFolderResponseType Constructor Initializes a new instance of the CreateManagedFolderResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CreateManagedFolderResponseType Class | Aspose.Email.Exchange.Schema Namespace


CreateManagedFolderResponseType Constructor

Initializes a new instance of the CreateManagedFolderResponseType class.

public CreateManagedFolderResponseType();

See Also

CreateManagedFolderResponseType Class | Aspose.Email.Exchange.Schema Namespace


CreateRuleOperationType Class

Represents a create rule operation type

For a list of all members of this type, see CreateRuleOperationType Members.

System.Object
Aspose.Email.Exchange.Schema.RuleOperationType
Aspose.Email.Exchange.Schema.CreateRuleOperationType

public class CreateRuleOperationType : RuleOperationType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CreateRuleOperationType Members | Aspose.Email.Exchange.Schema Namespace


CreateRuleOperationType Members

CreateRuleOperationType overview

Public Instance Constructors

CreateRuleOperationType Constructor Initializes a new instance of the CreateRuleOperationType class.

Public Instance Properties

Rule Gets or sets the rule to create.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CreateRuleOperationType Class | Aspose.Email.Exchange.Schema Namespace


CreateRuleOperationType Constructor

Initializes a new instance of the CreateRuleOperationType class.

public CreateRuleOperationType();

See Also

CreateRuleOperationType Class | Aspose.Email.Exchange.Schema Namespace


CreateRuleOperationType Properties

The properties of the CreateRuleOperationType class are listed below. For a complete list of CreateRuleOperationType class members, see the CreateRuleOperationType Members topic.

Public Instance Properties

Rule Gets or sets the rule to create.

See Also

CreateRuleOperationType Class | Aspose.Email.Exchange.Schema Namespace


Rule Property

Aspose.Email

CreateRuleOperationType.Rule Property

Gets or sets the rule to create.

public RuleType Rule {get; set;}

See Also

CreateRuleOperationType Class | Aspose.Email.Exchange.Schema Namespace


CreateUserConfigurationCompletedEventArgs Class

For a list of all members of this type, see CreateUserConfigurationCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.CreateUserConfigurationCompletedEventArgs

public class CreateUserConfigurationCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CreateUserConfigurationCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


CreateUserConfigurationCompletedEventArgs Members

CreateUserConfigurationCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

CreateUserConfigurationCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


CreateUserConfigurationCompletedEventArgs Properties

The properties of the CreateUserConfigurationCompletedEventArgs class are listed below. For a complete list of CreateUserConfigurationCompletedEventArgs class members, see the CreateUserConfigurationCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

CreateUserConfigurationCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

CreateUserConfigurationCompletedEventArgs.Result Property

public CreateUserConfigurationResponseType Result {get;}

Remarks

See Also

CreateUserConfigurationCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


CreateUserConfigurationCompletedEventHandler Delegate

public delegate void CreateUserConfigurationCompletedEventHandler(
object sender,
CreateUserConfigurationCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


CreateUserConfigurationResponseType Class

For a list of all members of this type, see CreateUserConfigurationResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseResponseMessageType
Aspose.Email.Exchange.Schema.CreateUserConfigurationResponseType

public class CreateUserConfigurationResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CreateUserConfigurationResponseType Members | Aspose.Email.Exchange.Schema Namespace


CreateUserConfigurationResponseType Members

CreateUserConfigurationResponseType overview

Public Instance Constructors

CreateUserConfigurationResponseType Constructor Initializes a new instance of the CreateUserConfigurationResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CreateUserConfigurationResponseType Class | Aspose.Email.Exchange.Schema Namespace


CreateUserConfigurationResponseType Constructor

Initializes a new instance of the CreateUserConfigurationResponseType class.

public CreateUserConfigurationResponseType();

See Also

CreateUserConfigurationResponseType Class | Aspose.Email.Exchange.Schema Namespace


CreateUserConfigurationType Class

For a list of all members of this type, see CreateUserConfigurationType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.CreateUserConfigurationType

public class CreateUserConfigurationType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CreateUserConfigurationType Members | Aspose.Email.Exchange.Schema Namespace


CreateUserConfigurationType Members

CreateUserConfigurationType overview

Public Instance Constructors

CreateUserConfigurationType Constructor Initializes a new instance of the CreateUserConfigurationType class.

Public Instance Properties

UserConfiguration

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CreateUserConfigurationType Class | Aspose.Email.Exchange.Schema Namespace


CreateUserConfigurationType Constructor

Initializes a new instance of the CreateUserConfigurationType class.

public CreateUserConfigurationType();

See Also

CreateUserConfigurationType Class | Aspose.Email.Exchange.Schema Namespace


CreateUserConfigurationType Properties

The properties of the CreateUserConfigurationType class are listed below. For a complete list of CreateUserConfigurationType class members, see the CreateUserConfigurationType Members topic.

Public Instance Properties

UserConfiguration

See Also

CreateUserConfigurationType Class | Aspose.Email.Exchange.Schema Namespace


UserConfiguration Property

Aspose.Email

CreateUserConfigurationType.UserConfiguration Property

public UserConfigurationType UserConfiguration {get; set;}

Remarks

See Also

CreateUserConfigurationType Class | Aspose.Email.Exchange.Schema Namespace


DailyRecurrencePatternType Class

Class describes the frequency, in days, in which a calendar item or a task recurs.

For a list of all members of this type, see DailyRecurrencePatternType Members.

System.Object
Aspose.Email.Exchange.Schema.RecurrencePatternBaseType
Aspose.Email.Exchange.Schema.IntervalRecurrencePatternBaseType
Aspose.Email.Exchange.Schema.DailyRecurrencePatternType

public class DailyRecurrencePatternType : IntervalRecurrencePatternBaseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DailyRecurrencePatternType Members | Aspose.Email.Exchange.Schema Namespace


DailyRecurrencePatternType Members

DailyRecurrencePatternType overview

Public Instance Constructors

DailyRecurrencePatternType Constructor Initializes a new instance of the DailyRecurrencePatternType class.

Public Instance Properties

Interval (inherited from IntervalRecurrencePatternBaseType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DailyRecurrencePatternType Class | Aspose.Email.Exchange.Schema Namespace


DailyRecurrencePatternType Constructor

Initializes a new instance of the DailyRecurrencePatternType class.

public DailyRecurrencePatternType();

See Also

DailyRecurrencePatternType Class | Aspose.Email.Exchange.Schema Namespace


DailyRegeneratingPatternType Class

Class describes the frequency, in days, in which a task is regenerated.

For a list of all members of this type, see DailyRegeneratingPatternType Members.

System.Object
Aspose.Email.Exchange.Schema.RecurrencePatternBaseType
Aspose.Email.Exchange.Schema.IntervalRecurrencePatternBaseType
Aspose.Email.Exchange.Schema.RegeneratingPatternBaseType
Aspose.Email.Exchange.Schema.DailyRegeneratingPatternType

public class DailyRegeneratingPatternType : RegeneratingPatternBaseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DailyRegeneratingPatternType Members | Aspose.Email.Exchange.Schema Namespace


DailyRegeneratingPatternType Members

DailyRegeneratingPatternType overview

Public Instance Constructors

DailyRegeneratingPatternType Constructor Initializes a new instance of the DailyRegeneratingPatternType class.

Public Instance Properties

Interval (inherited from IntervalRecurrencePatternBaseType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DailyRegeneratingPatternType Class | Aspose.Email.Exchange.Schema Namespace


DailyRegeneratingPatternType Constructor

Initializes a new instance of the DailyRegeneratingPatternType class.

public DailyRegeneratingPatternType();

See Also

DailyRegeneratingPatternType Class | Aspose.Email.Exchange.Schema Namespace


DayOfWeekIndexType Enumeration

public enum DayOfWeekIndexType

Remarks

Members

Member Name | Description | Value
First |  | 0
Second |  | 1
Third |  | 2
Fourth |  | 3
Last |  | 4

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


DayOfWeekType Enumeration

public enum DayOfWeekType

Remarks

Members

Member Name | Description | Value
Sunday |  | 0
Monday |  | 1
Tuesday |  | 2
Wednesday |  | 3
Thursday |  | 4
Friday |  | 5
Saturday |  | 6
Day |  | 7
Weekday |  | 8
WeekendDay |  | 9

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


DeclineItemType Class

For a list of all members of this type, see DeclineItemType Members.

System.Object
Aspose.Email.Exchange.Schema.ItemType
Aspose.Email.Exchange.Schema.MessageType
Aspose.Email.Exchange.Schema.ResponseObjectCoreType
Aspose.Email.Exchange.Schema.ResponseObjectType
Aspose.Email.Exchange.Schema.WellKnownResponseObjectType
Aspose.Email.Exchange.Schema.DeclineItemType

public class DeclineItemType : WellKnownResponseObjectType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DeclineItemType Members | Aspose.Email.Exchange.Schema Namespace


DeclineItemType Members

DeclineItemType overview

Public Instance Constructors

DeclineItemType Constructor Initializes a new instance of the DeclineItemType class.

Public Instance Properties

Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
From (inherited from MessageType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
ObjectName (inherited from ResponseObjectType)
ParentFolderId (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
ReferenceItemId (inherited from ResponseObjectCoreType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
Subject (inherited from ItemType)
ToRecipients (inherited from MessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DeclineItemType Class | Aspose.Email.Exchange.Schema Namespace


DeclineItemType Constructor

Initializes a new instance of the DeclineItemType class.

public DeclineItemType();

See Also

DeclineItemType Class | Aspose.Email.Exchange.Schema Namespace


DefaultShapeNamesType Enumeration

public enum DefaultShapeNamesType

Remarks

Members

Member Name | Description | Value
IdOnly |  | 0
Default |  | 1
AllProperties |  | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


DelegateFolderPermissionLevelType Enumeration

public enum DelegateFolderPermissionLevelType

Remarks

Members

Member Name | Description | Value
None |  | 0
Editor |  | 1
Reviewer |  | 2
Author |  | 3
Custom |  | 4

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


DelegatePermissionsType Class

For a list of all members of this type, see DelegatePermissionsType Members.

System.Object
Aspose.Email.Exchange.Schema.DelegatePermissionsType

public class DelegatePermissionsType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DelegatePermissionsType Members | Aspose.Email.Exchange.Schema Namespace


DelegatePermissionsType Members

DelegatePermissionsType overview

Public Instance Constructors

DelegatePermissionsType Constructor Initializes a new instance of the DelegatePermissionsType class.

Public Instance Properties

CalendarFolderPermissionLevel
CalendarFolderPermissionLevelSpecified
ContactsFolderPermissionLevel
ContactsFolderPermissionLevelSpecified
InboxFolderPermissionLevel
InboxFolderPermissionLevelSpecified
JournalFolderPermissionLevel
JournalFolderPermissionLevelSpecified
NotesFolderPermissionLevel
NotesFolderPermissionLevelSpecified
TasksFolderPermissionLevel
TasksFolderPermissionLevelSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DelegatePermissionsType Class | Aspose.Email.Exchange.Schema Namespace


DelegatePermissionsType Constructor

Initializes a new instance of the DelegatePermissionsType class.

public DelegatePermissionsType();

See Also

DelegatePermissionsType Class | Aspose.Email.Exchange.Schema Namespace


DelegatePermissionsType Properties

The properties of the DelegatePermissionsType class are listed below. For a complete list of DelegatePermissionsType class members, see the DelegatePermissionsType Members topic.

Public Instance Properties

CalendarFolderPermissionLevel
CalendarFolderPermissionLevelSpecified
ContactsFolderPermissionLevel
ContactsFolderPermissionLevelSpecified
InboxFolderPermissionLevel
InboxFolderPermissionLevelSpecified
JournalFolderPermissionLevel
JournalFolderPermissionLevelSpecified
NotesFolderPermissionLevel
NotesFolderPermissionLevelSpecified
TasksFolderPermissionLevel
TasksFolderPermissionLevelSpecified

See Also

DelegatePermissionsType Class | Aspose.Email.Exchange.Schema Namespace


CalendarFolderPermissionLevel Property

Aspose.Email

DelegatePermissionsType.CalendarFolderPermissionLevel Property

public DelegateFolderPermissionLevelType CalendarFolderPermissionLevel {get; set;}

Remarks

See Also

DelegatePermissionsType Class | Aspose.Email.Exchange.Schema Namespace


CalendarFolderPermissionLevelSpecified Property

Aspose.Email

DelegatePermissionsType.CalendarFolderPermissionLevelSpecified Property

public bool CalendarFolderPermissionLevelSpecified {get; set;}

Remarks

See Also

DelegatePermissionsType Class | Aspose.Email.Exchange.Schema Namespace


ContactsFolderPermissionLevel Property

Aspose.Email

DelegatePermissionsType.ContactsFolderPermissionLevel Property

public DelegateFolderPermissionLevelType ContactsFolderPermissionLevel {get; set;}

Remarks

See Also

DelegatePermissionsType Class | Aspose.Email.Exchange.Schema Namespace


ContactsFolderPermissionLevelSpecified Property

Aspose.Email

DelegatePermissionsType.ContactsFolderPermissionLevelSpecified Property

public bool ContactsFolderPermissionLevelSpecified {get; set;}

Remarks

See Also

DelegatePermissionsType Class | Aspose.Email.Exchange.Schema Namespace


InboxFolderPermissionLevel Property

Aspose.Email

DelegatePermissionsType.InboxFolderPermissionLevel Property

public DelegateFolderPermissionLevelType InboxFolderPermissionLevel {get; set;}

Remarks

See Also

DelegatePermissionsType Class | Aspose.Email.Exchange.Schema Namespace


InboxFolderPermissionLevelSpecified Property

Aspose.Email

DelegatePermissionsType.InboxFolderPermissionLevelSpecified Property

public bool InboxFolderPermissionLevelSpecified {get; set;}

Remarks

See Also

DelegatePermissionsType Class | Aspose.Email.Exchange.Schema Namespace


JournalFolderPermissionLevel Property

Aspose.Email

DelegatePermissionsType.JournalFolderPermissionLevel Property

public DelegateFolderPermissionLevelType JournalFolderPermissionLevel {get; set;}

Remarks

See Also

DelegatePermissionsType Class | Aspose.Email.Exchange.Schema Namespace


JournalFolderPermissionLevelSpecified Property

Aspose.Email

DelegatePermissionsType.JournalFolderPermissionLevelSpecified Property

public bool JournalFolderPermissionLevelSpecified {get; set;}

Remarks

See Also

DelegatePermissionsType Class | Aspose.Email.Exchange.Schema Namespace


NotesFolderPermissionLevel Property

Aspose.Email

DelegatePermissionsType.NotesFolderPermissionLevel Property

public DelegateFolderPermissionLevelType NotesFolderPermissionLevel {get; set;}

Remarks

See Also

DelegatePermissionsType Class | Aspose.Email.Exchange.Schema Namespace


NotesFolderPermissionLevelSpecified Property

Aspose.Email

DelegatePermissionsType.NotesFolderPermissionLevelSpecified Property

public bool NotesFolderPermissionLevelSpecified {get; set;}

Remarks

See Also

DelegatePermissionsType Class | Aspose.Email.Exchange.Schema Namespace


TasksFolderPermissionLevel Property

Aspose.Email

DelegatePermissionsType.TasksFolderPermissionLevel Property

public DelegateFolderPermissionLevelType TasksFolderPermissionLevel {get; set;}

Remarks

See Also

DelegatePermissionsType Class | Aspose.Email.Exchange.Schema Namespace


TasksFolderPermissionLevelSpecified Property

Aspose.Email

DelegatePermissionsType.TasksFolderPermissionLevelSpecified Property

public bool TasksFolderPermissionLevelSpecified {get; set;}

Remarks

See Also

DelegatePermissionsType Class | Aspose.Email.Exchange.Schema Namespace


DelegateUserResponseMessageType Class

For a list of all members of this type, see DelegateUserResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ResponseMessageType
Aspose.Email.Exchange.Schema.DelegateUserResponseMessageType

public class DelegateUserResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DelegateUserResponseMessageType Members | Aspose.Email.Exchange.Schema Namespace


DelegateUserResponseMessageType Members

DelegateUserResponseMessageType overview

Public Instance Constructors

DelegateUserResponseMessageType Constructor Initializes a new instance of the DelegateUserResponseMessageType class.

Public Instance Properties

DelegateUser
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DelegateUserResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


DelegateUserResponseMessageType Constructor

Initializes a new instance of the DelegateUserResponseMessageType class.

public DelegateUserResponseMessageType();

See Also

DelegateUserResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


DelegateUserResponseMessageType Properties

The properties of the DelegateUserResponseMessageType class are listed below. For a complete list of DelegateUserResponseMessageType class members, see the DelegateUserResponseMessageType Members topic.

Public Instance Properties

DelegateUser
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

DelegateUserResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


DelegateUser Property

Aspose.Email

DelegateUserResponseMessageType.DelegateUser Property

public DelegateUserType DelegateUser {get; set;}

Remarks

See Also

DelegateUserResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


DelegateUserType Class

For a list of all members of this type, see DelegateUserType Members.

System.Object
Aspose.Email.Exchange.Schema.DelegateUserType

public class DelegateUserType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DelegateUserType Members | Aspose.Email.Exchange.Schema Namespace


DelegateUserType Members

DelegateUserType overview

Public Instance Constructors

DelegateUserType Constructor Initializes a new instance of the DelegateUserType class.

Public Instance Properties

DelegatePermissions
ReceiveCopiesOfMeetingMessages
ReceiveCopiesOfMeetingMessagesSpecified
UserId
ViewPrivateItems
ViewPrivateItemsSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DelegateUserType Class | Aspose.Email.Exchange.Schema Namespace


DelegateUserType Constructor

Initializes a new instance of the DelegateUserType class.

public DelegateUserType();

See Also

DelegateUserType Class | Aspose.Email.Exchange.Schema Namespace


DelegateUserType Properties

The properties of the DelegateUserType class are listed below. For a complete list of DelegateUserType class members, see the DelegateUserType Members topic.

Public Instance Properties

DelegatePermissions
ReceiveCopiesOfMeetingMessages
ReceiveCopiesOfMeetingMessagesSpecified
UserId
ViewPrivateItems
ViewPrivateItemsSpecified

See Also

DelegateUserType Class | Aspose.Email.Exchange.Schema Namespace


DelegatePermissions Property

Aspose.Email

DelegateUserType.DelegatePermissions Property

public DelegatePermissionsType DelegatePermissions {get; set;}

Remarks

See Also

DelegateUserType Class | Aspose.Email.Exchange.Schema Namespace


ReceiveCopiesOfMeetingMessages Property

Aspose.Email

DelegateUserType.ReceiveCopiesOfMeetingMessages Property

public bool ReceiveCopiesOfMeetingMessages {get; set;}

Remarks

See Also

DelegateUserType Class | Aspose.Email.Exchange.Schema Namespace


ReceiveCopiesOfMeetingMessagesSpecified Property

Aspose.Email

DelegateUserType.ReceiveCopiesOfMeetingMessagesSpecified Property

public bool ReceiveCopiesOfMeetingMessagesSpecified {get; set;}

Remarks

See Also

DelegateUserType Class | Aspose.Email.Exchange.Schema Namespace


UserId Property

Aspose.Email

DelegateUserType.UserId Property

public UserIdType UserId {get; set;}

Remarks

See Also

DelegateUserType Class | Aspose.Email.Exchange.Schema Namespace


ViewPrivateItems Property

Aspose.Email

DelegateUserType.ViewPrivateItems Property

public bool ViewPrivateItems {get; set;}

Remarks

See Also

DelegateUserType Class | Aspose.Email.Exchange.Schema Namespace


ViewPrivateItemsSpecified Property

Aspose.Email

DelegateUserType.ViewPrivateItemsSpecified Property

public bool ViewPrivateItemsSpecified {get; set;}

Remarks

See Also

DelegateUserType Class | Aspose.Email.Exchange.Schema Namespace


DeleteAttachmentCompletedEventArgs Class

For a list of all members of this type, see DeleteAttachmentCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.DeleteAttachmentCompletedEventArgs

public class DeleteAttachmentCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DeleteAttachmentCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


DeleteAttachmentCompletedEventArgs Members

DeleteAttachmentCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

DeleteAttachmentCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


DeleteAttachmentCompletedEventArgs Properties

The properties of the DeleteAttachmentCompletedEventArgs class are listed below. For a complete list of DeleteAttachmentCompletedEventArgs class members, see the DeleteAttachmentCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

DeleteAttachmentCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

DeleteAttachmentCompletedEventArgs.Result Property

public DeleteAttachmentResponseType Result {get;}

Remarks

See Also

DeleteAttachmentCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


DeleteAttachmentCompletedEventHandler Delegate

public delegate void DeleteAttachmentCompletedEventHandler(
object sender,
DeleteAttachmentCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


DeleteAttachmentResponseMessageType Class

For a list of all members of this type, see DeleteAttachmentResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ResponseMessageType
Aspose.Email.Exchange.Schema.DeleteAttachmentResponseMessageType

public class DeleteAttachmentResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DeleteAttachmentResponseMessageType Members | Aspose.Email.Exchange.Schema Namespace


DeleteAttachmentResponseMessageType Members

DeleteAttachmentResponseMessageType overview

Public Instance Constructors

DeleteAttachmentResponseMessageType Constructor Initializes a new instance of the DeleteAttachmentResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
RootItemId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DeleteAttachmentResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


DeleteAttachmentResponseMessageType Constructor

Initializes a new instance of the DeleteAttachmentResponseMessageType class.

public DeleteAttachmentResponseMessageType();

See Also

DeleteAttachmentResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


DeleteAttachmentResponseMessageType Properties

The properties of the DeleteAttachmentResponseMessageType class are listed below. For a complete list of DeleteAttachmentResponseMessageType class members, see the DeleteAttachmentResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
RootItemId

See Also

DeleteAttachmentResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


RootItemId Property

Aspose.Email

DeleteAttachmentResponseMessageType.RootItemId Property

public RootItemIdType RootItemId {get; set;}

Remarks

See Also

DeleteAttachmentResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


DeleteAttachmentResponseType Class

For a list of all members of this type, see DeleteAttachmentResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseResponseMessageType
Aspose.Email.Exchange.Schema.DeleteAttachmentResponseType

public class DeleteAttachmentResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DeleteAttachmentResponseType Members | Aspose.Email.Exchange.Schema Namespace


DeleteAttachmentResponseType Members

DeleteAttachmentResponseType overview

Public Instance Constructors

DeleteAttachmentResponseType Constructor Initializes a new instance of the DeleteAttachmentResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DeleteAttachmentResponseType Class | Aspose.Email.Exchange.Schema Namespace


DeleteAttachmentResponseType Constructor

Initializes a new instance of the DeleteAttachmentResponseType class.

public DeleteAttachmentResponseType();

See Also

DeleteAttachmentResponseType Class | Aspose.Email.Exchange.Schema Namespace


DeleteAttachmentType Class

For a list of all members of this type, see DeleteAttachmentType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.DeleteAttachmentType

public class DeleteAttachmentType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DeleteAttachmentType Members | Aspose.Email.Exchange.Schema Namespace


DeleteAttachmentType Members

DeleteAttachmentType overview

Public Instance Constructors

DeleteAttachmentType Constructor Initializes a new instance of the DeleteAttachmentType class.

Public Instance Properties

AttachmentIds

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DeleteAttachmentType Class | Aspose.Email.Exchange.Schema Namespace


DeleteAttachmentType Constructor

Initializes a new instance of the DeleteAttachmentType class.

public DeleteAttachmentType();

See Also

DeleteAttachmentType Class | Aspose.Email.Exchange.Schema Namespace


DeleteAttachmentType Properties

The properties of the DeleteAttachmentType class are listed below. For a complete list of DeleteAttachmentType class members, see the DeleteAttachmentType Members topic.

Public Instance Properties

AttachmentIds

See Also

DeleteAttachmentType Class | Aspose.Email.Exchange.Schema Namespace


AttachmentIds Property

Aspose.Email

DeleteAttachmentType.AttachmentIds Property

public RequestAttachmentIdType[] AttachmentIds {get; set;}

Remarks

See Also

DeleteAttachmentType Class | Aspose.Email.Exchange.Schema Namespace


DeletedOccurrenceInfoType Class

For a list of all members of this type, see DeletedOccurrenceInfoType Members.

System.Object
Aspose.Email.Exchange.Schema.DeletedOccurrenceInfoType

public class DeletedOccurrenceInfoType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DeletedOccurrenceInfoType Members | Aspose.Email.Exchange.Schema Namespace


DeletedOccurrenceInfoType Members

DeletedOccurrenceInfoType overview

Public Instance Constructors

DeletedOccurrenceInfoType Constructor Initializes a new instance of the DeletedOccurrenceInfoType class.

Public Instance Properties

Start

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DeletedOccurrenceInfoType Class | Aspose.Email.Exchange.Schema Namespace


DeletedOccurrenceInfoType Constructor

Initializes a new instance of the DeletedOccurrenceInfoType class.

public DeletedOccurrenceInfoType();

See Also

DeletedOccurrenceInfoType Class | Aspose.Email.Exchange.Schema Namespace


DeletedOccurrenceInfoType Properties

The properties of the DeletedOccurrenceInfoType class are listed below. For a complete list of DeletedOccurrenceInfoType class members, see the DeletedOccurrenceInfoType Members topic.

Public Instance Properties

Start

See Also

DeletedOccurrenceInfoType Class | Aspose.Email.Exchange.Schema Namespace


Start Property

Aspose.Email

DeletedOccurrenceInfoType.Start Property

public DateTime Start {get; set;}

Remarks

See Also

DeletedOccurrenceInfoType Class | Aspose.Email.Exchange.Schema Namespace


DeleteFolderCompletedEventArgs Class

For a list of all members of this type, see DeleteFolderCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.DeleteFolderCompletedEventArgs

public class DeleteFolderCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DeleteFolderCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


DeleteFolderCompletedEventArgs Members

DeleteFolderCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

DeleteFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


DeleteFolderCompletedEventArgs Properties

The properties of the DeleteFolderCompletedEventArgs class are listed below. For a complete list of DeleteFolderCompletedEventArgs class members, see the DeleteFolderCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

DeleteFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

DeleteFolderCompletedEventArgs.Result Property

public DeleteFolderResponseType Result {get;}

Remarks

See Also

DeleteFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


DeleteFolderCompletedEventHandler Delegate

public delegate void DeleteFolderCompletedEventHandler(
object sender,
DeleteFolderCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


DeleteFolderFieldType Class

For a list of all members of this type, see DeleteFolderFieldType Members.

System.Object
Aspose.Email.Exchange.Schema.ChangeDescriptionType
Aspose.Email.Exchange.Schema.FolderChangeDescriptionType
Aspose.Email.Exchange.Schema.DeleteFolderFieldType

public class DeleteFolderFieldType : FolderChangeDescriptionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DeleteFolderFieldType Members | Aspose.Email.Exchange.Schema Namespace


DeleteFolderFieldType Members

DeleteFolderFieldType overview

Public Instance Constructors

DeleteFolderFieldType Constructor Initializes a new instance of the DeleteFolderFieldType class.

Public Instance Properties

Item (inherited from ChangeDescriptionType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DeleteFolderFieldType Class | Aspose.Email.Exchange.Schema Namespace


DeleteFolderFieldType Constructor

Initializes a new instance of the DeleteFolderFieldType class.

public DeleteFolderFieldType();

See Also

DeleteFolderFieldType Class | Aspose.Email.Exchange.Schema Namespace


DeleteFolderResponseType Class

For a list of all members of this type, see DeleteFolderResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseResponseMessageType
Aspose.Email.Exchange.Schema.DeleteFolderResponseType

public class DeleteFolderResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DeleteFolderResponseType Members | Aspose.Email.Exchange.Schema Namespace


DeleteFolderResponseType Members

DeleteFolderResponseType overview

Public Instance Constructors

DeleteFolderResponseType Constructor Initializes a new instance of the DeleteFolderResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DeleteFolderResponseType Class | Aspose.Email.Exchange.Schema Namespace


DeleteFolderResponseType Constructor

Initializes a new instance of the DeleteFolderResponseType class.

public DeleteFolderResponseType();

See Also

DeleteFolderResponseType Class | Aspose.Email.Exchange.Schema Namespace


DeleteFolderType Class

For a list of all members of this type, see DeleteFolderType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.DeleteFolderType

public class DeleteFolderType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DeleteFolderType Members | Aspose.Email.Exchange.Schema Namespace


DeleteFolderType Members

DeleteFolderType overview

Public Instance Constructors

DeleteFolderType Constructor Initializes a new instance of the DeleteFolderType class.

Public Instance Properties

DeleteType
FolderIds

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DeleteFolderType Class | Aspose.Email.Exchange.Schema Namespace


DeleteFolderType Constructor

Initializes a new instance of the DeleteFolderType class.

public DeleteFolderType();

See Also

DeleteFolderType Class | Aspose.Email.Exchange.Schema Namespace


DeleteFolderType Properties

The properties of the DeleteFolderType class are listed below. For a complete list of DeleteFolderType class members, see the DeleteFolderType Members topic.

Public Instance Properties

DeleteType
FolderIds

See Also

DeleteFolderType Class | Aspose.Email.Exchange.Schema Namespace


DeleteType Property

Aspose.Email

DeleteFolderType.DeleteType Property

public DisposalType DeleteType {get; set;}

Remarks

See Also

DeleteFolderType Class | Aspose.Email.Exchange.Schema Namespace


FolderIds Property

Aspose.Email

DeleteFolderType.FolderIds Property

public BaseFolderIdType[] FolderIds {get; set;}

Remarks

See Also

DeleteFolderType Class | Aspose.Email.Exchange.Schema Namespace


DeleteItemCompletedEventArgs Class

For a list of all members of this type, see DeleteItemCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.DeleteItemCompletedEventArgs

public class DeleteItemCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DeleteItemCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


DeleteItemCompletedEventArgs Members

DeleteItemCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

DeleteItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


DeleteItemCompletedEventArgs Properties

The properties of the DeleteItemCompletedEventArgs class are listed below. For a complete list of DeleteItemCompletedEventArgs class members, see the DeleteItemCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

DeleteItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

DeleteItemCompletedEventArgs.Result Property

public DeleteItemResponseType Result {get;}

Remarks

See Also

DeleteItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


DeleteItemCompletedEventHandler Delegate

public delegate void DeleteItemCompletedEventHandler(
object sender,
DeleteItemCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


DeleteItemFieldType Class

For a list of all members of this type, see DeleteItemFieldType Members.

System.Object
Aspose.Email.Exchange.Schema.ChangeDescriptionType
Aspose.Email.Exchange.Schema.ItemChangeDescriptionType
Aspose.Email.Exchange.Schema.DeleteItemFieldType

public class DeleteItemFieldType : ItemChangeDescriptionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DeleteItemFieldType Members | Aspose.Email.Exchange.Schema Namespace


DeleteItemFieldType Members

DeleteItemFieldType overview

Public Instance Constructors

DeleteItemFieldType Constructor Initializes a new instance of the DeleteItemFieldType class.

Public Instance Properties

Item (inherited from ChangeDescriptionType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DeleteItemFieldType Class | Aspose.Email.Exchange.Schema Namespace


DeleteItemFieldType Constructor

Initializes a new instance of the DeleteItemFieldType class.

public DeleteItemFieldType();

See Also

DeleteItemFieldType Class | Aspose.Email.Exchange.Schema Namespace


DeleteItemResponseType Class

For a list of all members of this type, see DeleteItemResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseResponseMessageType
Aspose.Email.Exchange.Schema.DeleteItemResponseType

public class DeleteItemResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DeleteItemResponseType Members | Aspose.Email.Exchange.Schema Namespace


DeleteItemResponseType Members

DeleteItemResponseType overview

Public Instance Constructors

DeleteItemResponseType Constructor Initializes a new instance of the DeleteItemResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DeleteItemResponseType Class | Aspose.Email.Exchange.Schema Namespace


DeleteItemResponseType Constructor

Initializes a new instance of the DeleteItemResponseType class.

public DeleteItemResponseType();

See Also

DeleteItemResponseType Class | Aspose.Email.Exchange.Schema Namespace


DeleteItemType Class

For a list of all members of this type, see DeleteItemType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.DeleteItemType

public class DeleteItemType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DeleteItemType Members | Aspose.Email.Exchange.Schema Namespace


DeleteItemType Members

DeleteItemType overview

Public Instance Constructors

DeleteItemType Constructor Initializes a new instance of the DeleteItemType class.

Public Instance Properties

AffectedTaskOccurrences
AffectedTaskOccurrencesSpecified
DeleteType
ItemIds
SendMeetingCancellations
SendMeetingCancellationsSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DeleteItemType Class | Aspose.Email.Exchange.Schema Namespace


DeleteItemType Constructor

Initializes a new instance of the DeleteItemType class.

public DeleteItemType();

See Also

DeleteItemType Class | Aspose.Email.Exchange.Schema Namespace


DeleteItemType Properties

The properties of the DeleteItemType class are listed below. For a complete list of DeleteItemType class members, see the DeleteItemType Members topic.

Public Instance Properties

AffectedTaskOccurrences
AffectedTaskOccurrencesSpecified
DeleteType
ItemIds
SendMeetingCancellations
SendMeetingCancellationsSpecified

See Also

DeleteItemType Class | Aspose.Email.Exchange.Schema Namespace


AffectedTaskOccurrences Property

Aspose.Email

DeleteItemType.AffectedTaskOccurrences Property

public AffectedTaskOccurrencesType AffectedTaskOccurrences {get; set;}

Remarks

See Also

DeleteItemType Class | Aspose.Email.Exchange.Schema Namespace


AffectedTaskOccurrencesSpecified Property

Aspose.Email

DeleteItemType.AffectedTaskOccurrencesSpecified Property

public bool AffectedTaskOccurrencesSpecified {get; set;}

Remarks

See Also

DeleteItemType Class | Aspose.Email.Exchange.Schema Namespace


DeleteType Property

Aspose.Email

DeleteItemType.DeleteType Property

public DisposalType DeleteType {get; set;}

Remarks

See Also

DeleteItemType Class | Aspose.Email.Exchange.Schema Namespace


ItemIds Property

Aspose.Email

DeleteItemType.ItemIds Property

public BaseItemIdType[] ItemIds {get; set;}

Remarks

See Also

DeleteItemType Class | Aspose.Email.Exchange.Schema Namespace


SendMeetingCancellations Property

Aspose.Email

DeleteItemType.SendMeetingCancellations Property

public CalendarItemCreateOrDeleteOperationType SendMeetingCancellations {get; set;}

Remarks

See Also

DeleteItemType Class | Aspose.Email.Exchange.Schema Namespace


SendMeetingCancellationsSpecified Property

Aspose.Email

DeleteItemType.SendMeetingCancellationsSpecified Property

public bool SendMeetingCancellationsSpecified {get; set;}

Remarks

See Also

DeleteItemType Class | Aspose.Email.Exchange.Schema Namespace


DeleteRuleOperationType Class

Represents a delete rule operation type

For a list of all members of this type, see DeleteRuleOperationType Members.

System.Object
Aspose.Email.Exchange.Schema.RuleOperationType
Aspose.Email.Exchange.Schema.DeleteRuleOperationType

public class DeleteRuleOperationType : RuleOperationType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DeleteRuleOperationType Members | Aspose.Email.Exchange.Schema Namespace


DeleteRuleOperationType Members

DeleteRuleOperationType overview

Public Instance Constructors

DeleteRuleOperationType Constructor Initializes a new instance of the DeleteRuleOperationType class.

Public Instance Properties

RuleId Gets or sets the rule ID of the Inbox rule to be deleted.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DeleteRuleOperationType Class | Aspose.Email.Exchange.Schema Namespace


DeleteRuleOperationType Constructor

Initializes a new instance of the DeleteRuleOperationType class.

public DeleteRuleOperationType();

See Also

DeleteRuleOperationType Class | Aspose.Email.Exchange.Schema Namespace


DeleteRuleOperationType Properties

The properties of the DeleteRuleOperationType class are listed below. For a complete list of DeleteRuleOperationType class members, see the DeleteRuleOperationType Members topic.

Public Instance Properties

RuleId Gets or sets the rule ID of the Inbox rule to be deleted.

See Also

DeleteRuleOperationType Class | Aspose.Email.Exchange.Schema Namespace


RuleId Property

Aspose.Email

DeleteRuleOperationType.RuleId Property

Gets or sets the rule ID of the Inbox rule to be deleted.

public string RuleId {get; set;}

See Also

DeleteRuleOperationType Class | Aspose.Email.Exchange.Schema Namespace


DeleteUserConfigurationCompletedEventArgs Class

For a list of all members of this type, see DeleteUserConfigurationCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.DeleteUserConfigurationCompletedEventArgs

public class DeleteUserConfigurationCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DeleteUserConfigurationCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


DeleteUserConfigurationCompletedEventArgs Members

DeleteUserConfigurationCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

DeleteUserConfigurationCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


DeleteUserConfigurationCompletedEventArgs Properties

The properties of the DeleteUserConfigurationCompletedEventArgs class are listed below. For a complete list of DeleteUserConfigurationCompletedEventArgs class members, see the DeleteUserConfigurationCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

DeleteUserConfigurationCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

DeleteUserConfigurationCompletedEventArgs.Result Property

public DeleteUserConfigurationResponseType Result {get;}

Remarks

See Also

DeleteUserConfigurationCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


DeleteUserConfigurationCompletedEventHandler Delegate

public delegate void DeleteUserConfigurationCompletedEventHandler(
object sender,
DeleteUserConfigurationCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


DeleteUserConfigurationResponseType Class

For a list of all members of this type, see DeleteUserConfigurationResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseResponseMessageType
Aspose.Email.Exchange.Schema.DeleteUserConfigurationResponseType

public class DeleteUserConfigurationResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DeleteUserConfigurationResponseType Members | Aspose.Email.Exchange.Schema Namespace


DeleteUserConfigurationResponseType Members

DeleteUserConfigurationResponseType overview

Public Instance Constructors

DeleteUserConfigurationResponseType Constructor Initializes a new instance of the DeleteUserConfigurationResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DeleteUserConfigurationResponseType Class | Aspose.Email.Exchange.Schema Namespace


DeleteUserConfigurationResponseType Constructor

Initializes a new instance of the DeleteUserConfigurationResponseType class.

public DeleteUserConfigurationResponseType();

See Also

DeleteUserConfigurationResponseType Class | Aspose.Email.Exchange.Schema Namespace


DeleteUserConfigurationType Class

For a list of all members of this type, see DeleteUserConfigurationType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.DeleteUserConfigurationType

public class DeleteUserConfigurationType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DeleteUserConfigurationType Members | Aspose.Email.Exchange.Schema Namespace


DeleteUserConfigurationType Members

DeleteUserConfigurationType overview

Public Instance Constructors

DeleteUserConfigurationType Constructor Initializes a new instance of the DeleteUserConfigurationType class.

Public Instance Properties

UserConfigurationName

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DeleteUserConfigurationType Class | Aspose.Email.Exchange.Schema Namespace


DeleteUserConfigurationType Constructor

Initializes a new instance of the DeleteUserConfigurationType class.

public DeleteUserConfigurationType();

See Also

DeleteUserConfigurationType Class | Aspose.Email.Exchange.Schema Namespace


DeleteUserConfigurationType Properties

The properties of the DeleteUserConfigurationType class are listed below. For a complete list of DeleteUserConfigurationType class members, see the DeleteUserConfigurationType Members topic.

Public Instance Properties

UserConfigurationName

See Also

DeleteUserConfigurationType Class | Aspose.Email.Exchange.Schema Namespace


UserConfigurationName Property

Aspose.Email

DeleteUserConfigurationType.UserConfigurationName Property

public UserConfigurationNameType UserConfigurationName {get; set;}

Remarks

See Also

DeleteUserConfigurationType Class | Aspose.Email.Exchange.Schema Namespace


DeliverMeetingRequestsType Enumeration

public enum DeliverMeetingRequestsType

Remarks

Members

Member Name | Description | Value
DelegatesOnly |  | 0
DelegatesAndMe |  | 1
DelegatesAndSendInformationToMe |  | 2
NoForward |  | 3

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


DictionaryURIType Enumeration

public enum DictionaryURIType

Remarks

Members

Member Name | Description | Value
itemInternetMessageHeader |  | 0
contactsImAddress |  | 1
contactsPhysicalAddressStreet |  | 2
contactsPhysicalAddressCity |  | 3
contactsPhysicalAddressState |  | 4
contactsPhysicalAddressCountryOrRegion |  | 5
contactsPhysicalAddressPostalCode |  | 6
contactsPhoneNumber |  | 7
contactsEmailAddress |  | 8
distributionlistMembersMember |  | 9

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


DirectoryEntryType Class

For a list of all members of this type, see DirectoryEntryType Members.

System.Object
Aspose.Email.Exchange.Schema.DirectoryEntryType
Aspose.Email.Exchange.Schema.RoomType

public class DirectoryEntryType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DirectoryEntryType Members | Aspose.Email.Exchange.Schema Namespace


DirectoryEntryType Members

DirectoryEntryType overview

Public Instance Constructors

DirectoryEntryType Constructor Initializes a new instance of the DirectoryEntryType class.

Public Instance Properties

Id

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DirectoryEntryType Class | Aspose.Email.Exchange.Schema Namespace


DirectoryEntryType Constructor

Initializes a new instance of the DirectoryEntryType class.

public DirectoryEntryType();

See Also

DirectoryEntryType Class | Aspose.Email.Exchange.Schema Namespace


DirectoryEntryType Properties

The properties of the DirectoryEntryType class are listed below. For a complete list of DirectoryEntryType class members, see the DirectoryEntryType Members topic.

Public Instance Properties

Id

See Also

DirectoryEntryType Class | Aspose.Email.Exchange.Schema Namespace


Id Property

Aspose.Email

DirectoryEntryType.Id Property

public EmailAddressType Id {get; set;}

Remarks

See Also

DirectoryEntryType Class | Aspose.Email.Exchange.Schema Namespace


DisconnectPhoneCallCompletedEventArgs Class

For a list of all members of this type, see DisconnectPhoneCallCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.DisconnectPhoneCallCompletedEventArgs

public class DisconnectPhoneCallCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DisconnectPhoneCallCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


DisconnectPhoneCallCompletedEventArgs Members

DisconnectPhoneCallCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

DisconnectPhoneCallCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


DisconnectPhoneCallCompletedEventArgs Properties

The properties of the DisconnectPhoneCallCompletedEventArgs class are listed below. For a complete list of DisconnectPhoneCallCompletedEventArgs class members, see the DisconnectPhoneCallCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

DisconnectPhoneCallCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

DisconnectPhoneCallCompletedEventArgs.Result Property

public DisconnectPhoneCallResponseMessageType Result {get;}

Remarks

See Also

DisconnectPhoneCallCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


DisconnectPhoneCallCompletedEventHandler Delegate

public delegate void DisconnectPhoneCallCompletedEventHandler(
object sender,
DisconnectPhoneCallCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


DisconnectPhoneCallResponseMessageType Class

For a list of all members of this type, see DisconnectPhoneCallResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ResponseMessageType
Aspose.Email.Exchange.Schema.DisconnectPhoneCallResponseMessageType

public class DisconnectPhoneCallResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DisconnectPhoneCallResponseMessageType Members | Aspose.Email.Exchange.Schema Namespace


DisconnectPhoneCallResponseMessageType Members

DisconnectPhoneCallResponseMessageType overview

Public Instance Constructors

DisconnectPhoneCallResponseMessageType Constructor Initializes a new instance of the DisconnectPhoneCallResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DisconnectPhoneCallResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


DisconnectPhoneCallResponseMessageType Constructor

Initializes a new instance of the DisconnectPhoneCallResponseMessageType class.

public DisconnectPhoneCallResponseMessageType();

See Also

DisconnectPhoneCallResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


DisconnectPhoneCallType Class

For a list of all members of this type, see DisconnectPhoneCallType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.DisconnectPhoneCallType

public class DisconnectPhoneCallType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DisconnectPhoneCallType Members | Aspose.Email.Exchange.Schema Namespace


DisconnectPhoneCallType Members

DisconnectPhoneCallType overview

Public Instance Constructors

DisconnectPhoneCallType Constructor Initializes a new instance of the DisconnectPhoneCallType class.

Public Instance Properties

PhoneCallId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DisconnectPhoneCallType Class | Aspose.Email.Exchange.Schema Namespace


DisconnectPhoneCallType Constructor

Initializes a new instance of the DisconnectPhoneCallType class.

public DisconnectPhoneCallType();

See Also

DisconnectPhoneCallType Class | Aspose.Email.Exchange.Schema Namespace


DisconnectPhoneCallType Properties

The properties of the DisconnectPhoneCallType class are listed below. For a complete list of DisconnectPhoneCallType class members, see the DisconnectPhoneCallType Members topic.

Public Instance Properties

PhoneCallId

See Also

DisconnectPhoneCallType Class | Aspose.Email.Exchange.Schema Namespace


PhoneCallId Property

Aspose.Email

DisconnectPhoneCallType.PhoneCallId Property

public PhoneCallIdType PhoneCallId {get; set;}

Remarks

See Also

DisconnectPhoneCallType Class | Aspose.Email.Exchange.Schema Namespace


DisposalType Enumeration

public enum DisposalType

Remarks

Members

Member Name | Description | Value
HardDelete |  | 0
SoftDelete |  | 1
MoveToDeletedItems |  | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


DistinguishedFolderIdNameType Enumeration

public enum DistinguishedFolderIdNameType

Remarks

Members

Member Name | Description | Value
calendar |  | 0
contacts |  | 1
deleteditems |  | 2
drafts |  | 3
inbox |  | 4
journal |  | 5
notes |  | 6
outbox |  | 7
sentitems |  | 8
tasks |  | 9
msgfolderroot |  | 10
publicfoldersroot |  | 11
root |  | 12
junkemail |  | 13
searchfolders |  | 14
voicemail |  | 15
recoverableitemsroot |  | 16
recoverableitemsdeletions |  | 17
recoverableitemsversions |  | 18
recoverableitemspurges |  | 19
archiveroot |  | 20
archivemsgfolderroot |  | 21
archivedeleteditems |  | 22
archiverecoverableitemsroot |  | 23
archiverecoverableitemsdeletions |  | 24
archiverecoverableitemsversions |  | 25
archiverecoverableitemspurges |  | 26

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


DistinguishedFolderIdType Class

For a list of all members of this type, see DistinguishedFolderIdType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseFolderIdType
Aspose.Email.Exchange.Schema.DistinguishedFolderIdType

public class DistinguishedFolderIdType : BaseFolderIdType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DistinguishedFolderIdType Members | Aspose.Email.Exchange.Schema Namespace


DistinguishedFolderIdType Members

DistinguishedFolderIdType overview

Public Instance Constructors

DistinguishedFolderIdType Constructor Initializes a new instance of the DistinguishedFolderIdType class.

Public Instance Properties

ChangeKey
Id
Mailbox

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DistinguishedFolderIdType Class | Aspose.Email.Exchange.Schema Namespace


DistinguishedFolderIdType Constructor

Initializes a new instance of the DistinguishedFolderIdType class.

public DistinguishedFolderIdType();

See Also

DistinguishedFolderIdType Class | Aspose.Email.Exchange.Schema Namespace


DistinguishedFolderIdType Properties

The properties of the DistinguishedFolderIdType class are listed below. For a complete list of DistinguishedFolderIdType class members, see the DistinguishedFolderIdType Members topic.

Public Instance Properties

ChangeKey
Id
Mailbox

See Also

DistinguishedFolderIdType Class | Aspose.Email.Exchange.Schema Namespace


ChangeKey Property

Aspose.Email

DistinguishedFolderIdType.ChangeKey Property

public string ChangeKey {get; set;}

Remarks

See Also

DistinguishedFolderIdType Class | Aspose.Email.Exchange.Schema Namespace


Id Property

Aspose.Email

DistinguishedFolderIdType.Id Property

public DistinguishedFolderIdNameType Id {get; set;}

Remarks

See Also

DistinguishedFolderIdType Class | Aspose.Email.Exchange.Schema Namespace


Mailbox Property

Aspose.Email

DistinguishedFolderIdType.Mailbox Property

public EmailAddressType Mailbox {get; set;}

Remarks

See Also

DistinguishedFolderIdType Class | Aspose.Email.Exchange.Schema Namespace


DistinguishedGroupByType Class

For a list of all members of this type, see DistinguishedGroupByType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseGroupByType
Aspose.Email.Exchange.Schema.DistinguishedGroupByType

public class DistinguishedGroupByType : BaseGroupByType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DistinguishedGroupByType Members | Aspose.Email.Exchange.Schema Namespace


DistinguishedGroupByType Members

DistinguishedGroupByType overview

Public Instance Constructors

DistinguishedGroupByType Constructor Initializes a new instance of the DistinguishedGroupByType class.

Public Instance Properties

Order (inherited from BaseGroupByType)
StandardGroupBy

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DistinguishedGroupByType Class | Aspose.Email.Exchange.Schema Namespace


DistinguishedGroupByType Constructor

Initializes a new instance of the DistinguishedGroupByType class.

public DistinguishedGroupByType();

See Also

DistinguishedGroupByType Class | Aspose.Email.Exchange.Schema Namespace


DistinguishedGroupByType Properties

The properties of the DistinguishedGroupByType class are listed below. For a complete list of DistinguishedGroupByType class members, see the DistinguishedGroupByType Members topic.

Public Instance Properties

Order (inherited from BaseGroupByType)
StandardGroupBy

See Also

DistinguishedGroupByType Class | Aspose.Email.Exchange.Schema Namespace


StandardGroupBy Property

Aspose.Email

DistinguishedGroupByType.StandardGroupBy Property

public StandardGroupByType StandardGroupBy {get; set;}

Remarks

See Also

DistinguishedGroupByType Class | Aspose.Email.Exchange.Schema Namespace


DistinguishedPropertySetType Enumeration

public enum DistinguishedPropertySetType

Remarks

Members

Member Name | Description | Value
Meeting |  | 0
Appointment |  | 1
Common |  | 2
PublicStrings |  | 3
Address |  | 4
InternetHeaders |  | 5
CalendarAssistant |  | 6
UnifiedMessaging |  | 7
Task |  | 8

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


DistinguishedUserType Enumeration

public enum DistinguishedUserType

Remarks

Members

Member Name | Description | Value
Default |  | 0
Anonymous |  | 1

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


DistributionListType Class

For a list of all members of this type, see DistributionListType Members.

System.Object
Aspose.Email.Exchange.Schema.ItemType
Aspose.Email.Exchange.Schema.DistributionListType

public class DistributionListType : ItemType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DistributionListType Members | Aspose.Email.Exchange.Schema Namespace


DistributionListType Members

DistributionListType overview

Public Instance Constructors

DistributionListType Constructor Initializes a new instance of the DistributionListType class.

Public Instance Properties

Attachments (inherited from ItemType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
ContactSource
ContactSourceSpecified
ConversationId (inherited from ItemType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayName
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
FileAs
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
Members
MimeContent (inherited from ItemType)
ParentFolderId (inherited from ItemType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ResponseObjects (inherited from ItemType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
Subject (inherited from ItemType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DistributionListType Class | Aspose.Email.Exchange.Schema Namespace


DistributionListType Constructor

Initializes a new instance of the DistributionListType class.

public DistributionListType();

See Also

DistributionListType Class | Aspose.Email.Exchange.Schema Namespace


DistributionListType Properties

The properties of the DistributionListType class are listed below. For a complete list of DistributionListType class members, see the DistributionListType Members topic.

Public Instance Properties

Attachments (inherited from ItemType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
ContactSource
ContactSourceSpecified
ConversationId (inherited from ItemType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayName
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
FileAs
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
Members
MimeContent (inherited from ItemType)
ParentFolderId (inherited from ItemType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ResponseObjects (inherited from ItemType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
Subject (inherited from ItemType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

See Also

DistributionListType Class | Aspose.Email.Exchange.Schema Namespace


ContactSource Property

Aspose.Email

DistributionListType.ContactSource Property

public ContactSourceType ContactSource {get; set;}

Remarks

See Also

DistributionListType Class | Aspose.Email.Exchange.Schema Namespace


ContactSourceSpecified Property

Aspose.Email

DistributionListType.ContactSourceSpecified Property

public bool ContactSourceSpecified {get; set;}

Remarks

See Also

DistributionListType Class | Aspose.Email.Exchange.Schema Namespace


DisplayName Property

Aspose.Email

DistributionListType.DisplayName Property

public string DisplayName {get; set;}

Remarks

See Also

DistributionListType Class | Aspose.Email.Exchange.Schema Namespace


FileAs Property

Aspose.Email

DistributionListType.FileAs Property

public string FileAs {get; set;}

Remarks

See Also

DistributionListType Class | Aspose.Email.Exchange.Schema Namespace


Members Property

Aspose.Email

DistributionListType.Members Property

public MemberType[] Members {get; set;}

Remarks

See Also

DistributionListType Class | Aspose.Email.Exchange.Schema Namespace


Duration Class

For a list of all members of this type, see Duration Members.

System.Object
Aspose.Email.Exchange.Schema.Duration

public class Duration

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Duration Members | Aspose.Email.Exchange.Schema Namespace


Duration Members

Duration overview

Public Instance Constructors

Duration Constructor Initializes a new instance of the Duration class.

Public Instance Properties

EndTime
StartTime

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Duration Class | Aspose.Email.Exchange.Schema Namespace


Duration Constructor

Initializes a new instance of the Duration class.

public Duration();

See Also

Duration Class | Aspose.Email.Exchange.Schema Namespace


Duration Properties

The properties of the Duration class are listed below. For a complete list of Duration class members, see the Duration Members topic.

Public Instance Properties

EndTime
StartTime

See Also

Duration Class | Aspose.Email.Exchange.Schema Namespace


EndTime Property

Aspose.Email

Duration.EndTime Property

public DateTime EndTime {get; set;}

Remarks

See Also

Duration Class | Aspose.Email.Exchange.Schema Namespace


StartTime Property

Aspose.Email

Duration.StartTime Property

public DateTime StartTime {get; set;}

Remarks

See Also

Duration Class | Aspose.Email.Exchange.Schema Namespace


EffectiveRightsType Class

For a list of all members of this type, see EffectiveRightsType Members.

System.Object
Aspose.Email.Exchange.Schema.EffectiveRightsType

public class EffectiveRightsType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

EffectiveRightsType Members | Aspose.Email.Exchange.Schema Namespace


EffectiveRightsType Members

EffectiveRightsType overview

Public Instance Constructors

EffectiveRightsType Constructor Initializes a new instance of the EffectiveRightsType class.

Public Instance Properties

CreateAssociated
CreateContents
CreateHierarchy
Delete
Modify
Read
ViewPrivateItems
ViewPrivateItemsSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EffectiveRightsType Class | Aspose.Email.Exchange.Schema Namespace


EffectiveRightsType Constructor

Initializes a new instance of the EffectiveRightsType class.

public EffectiveRightsType();

See Also

EffectiveRightsType Class | Aspose.Email.Exchange.Schema Namespace


EffectiveRightsType Properties

The properties of the EffectiveRightsType class are listed below. For a complete list of EffectiveRightsType class members, see the EffectiveRightsType Members topic.

Public Instance Properties

CreateAssociated
CreateContents
CreateHierarchy
Delete
Modify
Read
ViewPrivateItems
ViewPrivateItemsSpecified

See Also

EffectiveRightsType Class | Aspose.Email.Exchange.Schema Namespace


CreateAssociated Property

Aspose.Email

EffectiveRightsType.CreateAssociated Property

public bool CreateAssociated {get; set;}

Remarks

See Also

EffectiveRightsType Class | Aspose.Email.Exchange.Schema Namespace


CreateContents Property

Aspose.Email

EffectiveRightsType.CreateContents Property

public bool CreateContents {get; set;}

Remarks

See Also

EffectiveRightsType Class | Aspose.Email.Exchange.Schema Namespace


CreateHierarchy Property

Aspose.Email

EffectiveRightsType.CreateHierarchy Property

public bool CreateHierarchy {get; set;}

Remarks

See Also

EffectiveRightsType Class | Aspose.Email.Exchange.Schema Namespace


Delete Property

Aspose.Email

EffectiveRightsType.Delete Property

public bool Delete {get; set;}

Remarks

See Also

EffectiveRightsType Class | Aspose.Email.Exchange.Schema Namespace


Modify Property

Aspose.Email

EffectiveRightsType.Modify Property

public bool Modify {get; set;}

Remarks

See Also

EffectiveRightsType Class | Aspose.Email.Exchange.Schema Namespace


Read Property

Aspose.Email

EffectiveRightsType.Read Property

public bool Read {get; set;}

Remarks

See Also

EffectiveRightsType Class | Aspose.Email.Exchange.Schema Namespace


ViewPrivateItems Property

Aspose.Email

EffectiveRightsType.ViewPrivateItems Property

public bool ViewPrivateItems {get; set;}

Remarks

See Also

EffectiveRightsType Class | Aspose.Email.Exchange.Schema Namespace


ViewPrivateItemsSpecified Property

Aspose.Email

EffectiveRightsType.ViewPrivateItemsSpecified Property

public bool ViewPrivateItemsSpecified {get; set;}

Remarks

See Also

EffectiveRightsType Class | Aspose.Email.Exchange.Schema Namespace


EmailAddress Class

For a list of all members of this type, see EmailAddress Members.

System.Object
Aspose.Email.Exchange.Schema.EmailAddress

public class EmailAddress

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

EmailAddress Members | Aspose.Email.Exchange.Schema Namespace


EmailAddress Members

EmailAddress overview

Public Instance Constructors

EmailAddress Constructor Initializes a new instance of the EmailAddress class.

Public Instance Properties

Address
Name
RoutingType

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EmailAddress Class | Aspose.Email.Exchange.Schema Namespace


EmailAddress Constructor

Initializes a new instance of the EmailAddress class.

public EmailAddress();

See Also

EmailAddress Class | Aspose.Email.Exchange.Schema Namespace


EmailAddress Properties

The properties of the EmailAddress class are listed below. For a complete list of EmailAddress class members, see the EmailAddress Members topic.

Public Instance Properties

Address
Name
RoutingType

See Also

EmailAddress Class | Aspose.Email.Exchange.Schema Namespace


Address Property

Aspose.Email

EmailAddress.Address Property

public string Address {get; set;}

Remarks

See Also

EmailAddress Class | Aspose.Email.Exchange.Schema Namespace


Name Property

Aspose.Email

EmailAddress.Name Property

public string Name {get; set;}

Remarks

See Also

EmailAddress Class | Aspose.Email.Exchange.Schema Namespace


RoutingType Property

Aspose.Email

EmailAddress.RoutingType Property

public string RoutingType {get; set;}

Remarks

See Also

EmailAddress Class | Aspose.Email.Exchange.Schema Namespace


EmailAddressDictionaryEntryType Class

For a list of all members of this type, see EmailAddressDictionaryEntryType Members.

System.Object
Aspose.Email.Exchange.Schema.EmailAddressDictionaryEntryType

public class EmailAddressDictionaryEntryType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

EmailAddressDictionaryEntryType Members | Aspose.Email.Exchange.Schema Namespace


EmailAddressDictionaryEntryType Members

EmailAddressDictionaryEntryType overview

Public Instance Constructors

EmailAddressDictionaryEntryType Constructor Initializes a new instance of the EmailAddressDictionaryEntryType class.

Public Instance Properties

Key
MailboxType
MailboxTypeSpecified
Name
RoutingType
Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EmailAddressDictionaryEntryType Class | Aspose.Email.Exchange.Schema Namespace


EmailAddressDictionaryEntryType Constructor

Initializes a new instance of the EmailAddressDictionaryEntryType class.

public EmailAddressDictionaryEntryType();

See Also

EmailAddressDictionaryEntryType Class | Aspose.Email.Exchange.Schema Namespace


EmailAddressDictionaryEntryType Properties

The properties of the EmailAddressDictionaryEntryType class are listed below. For a complete list of EmailAddressDictionaryEntryType class members, see the EmailAddressDictionaryEntryType Members topic.

Public Instance Properties

Key
MailboxType
MailboxTypeSpecified
Name
RoutingType
Value

See Also

EmailAddressDictionaryEntryType Class | Aspose.Email.Exchange.Schema Namespace


Key Property

Aspose.Email

EmailAddressDictionaryEntryType.Key Property

public EmailAddressKeyType Key {get; set;}

Remarks

See Also

EmailAddressDictionaryEntryType Class | Aspose.Email.Exchange.Schema Namespace


MailboxType Property

Aspose.Email

EmailAddressDictionaryEntryType.MailboxType Property

public MailboxTypeType MailboxType {get; set;}

Remarks

See Also

EmailAddressDictionaryEntryType Class | Aspose.Email.Exchange.Schema Namespace


MailboxTypeSpecified Property

Aspose.Email

EmailAddressDictionaryEntryType.MailboxTypeSpecified Property

public bool MailboxTypeSpecified {get; set;}

Remarks

See Also

EmailAddressDictionaryEntryType Class | Aspose.Email.Exchange.Schema Namespace


Name Property

Aspose.Email

EmailAddressDictionaryEntryType.Name Property

public string Name {get; set;}

Remarks

See Also

EmailAddressDictionaryEntryType Class | Aspose.Email.Exchange.Schema Namespace


RoutingType Property

Aspose.Email

EmailAddressDictionaryEntryType.RoutingType Property

public string RoutingType {get; set;}

Remarks

See Also

EmailAddressDictionaryEntryType Class | Aspose.Email.Exchange.Schema Namespace


Value Property

Aspose.Email

EmailAddressDictionaryEntryType.Value Property

public string Value {get; set;}

Remarks

See Also

EmailAddressDictionaryEntryType Class | Aspose.Email.Exchange.Schema Namespace


EmailAddressKeyType Enumeration

public enum EmailAddressKeyType

Remarks

Members

Member Name | Description | Value
EmailAddress1 |  | 0
EmailAddress2 |  | 1
EmailAddress3 |  | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


EmailAddressType Class

For a list of all members of this type, see EmailAddressType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseEmailAddressType
Aspose.Email.Exchange.Schema.EmailAddressType

public class EmailAddressType : BaseEmailAddressType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

EmailAddressType Members | Aspose.Email.Exchange.Schema Namespace


EmailAddressType Members

EmailAddressType overview

Public Instance Constructors

EmailAddressType Constructor Initializes a new instance of the EmailAddressType class.

Public Instance Properties

EmailAddress
ItemId
MailboxType
MailboxTypeSpecified
Name
RoutingType

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EmailAddressType Class | Aspose.Email.Exchange.Schema Namespace


EmailAddressType Constructor

Initializes a new instance of the EmailAddressType class.

public EmailAddressType();

See Also

EmailAddressType Class | Aspose.Email.Exchange.Schema Namespace


EmailAddressType Properties

The properties of the EmailAddressType class are listed below. For a complete list of EmailAddressType class members, see the EmailAddressType Members topic.

Public Instance Properties

EmailAddress
ItemId
MailboxType
MailboxTypeSpecified
Name
RoutingType

See Also

EmailAddressType Class | Aspose.Email.Exchange.Schema Namespace


EmailAddress Property

Aspose.Email

EmailAddressType.EmailAddress Property

public string EmailAddress {get; set;}

Remarks

See Also

EmailAddressType Class | Aspose.Email.Exchange.Schema Namespace


ItemId Property

Aspose.Email

EmailAddressType.ItemId Property

public ItemIdType ItemId {get; set;}

Remarks

See Also

EmailAddressType Class | Aspose.Email.Exchange.Schema Namespace


MailboxType Property

Aspose.Email

EmailAddressType.MailboxType Property

public MailboxTypeType MailboxType {get; set;}

Remarks

See Also

EmailAddressType Class | Aspose.Email.Exchange.Schema Namespace


MailboxTypeSpecified Property

Aspose.Email

EmailAddressType.MailboxTypeSpecified Property

public bool MailboxTypeSpecified {get; set;}

Remarks

See Also

EmailAddressType Class | Aspose.Email.Exchange.Schema Namespace


Name Property

Aspose.Email

EmailAddressType.Name Property

public string Name {get; set;}

Remarks

See Also

EmailAddressType Class | Aspose.Email.Exchange.Schema Namespace


RoutingType Property

Aspose.Email

EmailAddressType.RoutingType Property

public string RoutingType {get; set;}

Remarks

See Also

EmailAddressType Class | Aspose.Email.Exchange.Schema Namespace


EmptyFolderCompletedEventArgs Class

Provides data for the event

For a list of all members of this type, see EmptyFolderCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.EmptyFolderCompletedEventArgs

public class EmptyFolderCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

EmptyFolderCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace | EmptyFolderCompleted


EmptyFolderCompletedEventArgs Members

EmptyFolderCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result | Gets the result of operation
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

EmptyFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace | EmptyFolderCompleted


EmptyFolderCompletedEventArgs Properties

The properties of the EmptyFolderCompletedEventArgs class are listed below. For a complete list of EmptyFolderCompletedEventArgs class members, see the EmptyFolderCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result | Gets the result of operation
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

EmptyFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace | EmptyFolderCompleted


Result Property

Aspose.Email

EmptyFolderCompletedEventArgs.Result Property

Gets the result of operation

public EmptyFolderResponseType Result {get;}

See Also

EmptyFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


EmptyFolderCompletedEventHandler Delegate

Represents the method that will handle the EmptyFolderCompleted event

public delegate void EmptyFolderCompletedEventHandler(
object sender,
EmptyFolderCompletedEventArgs e
);

Parameters

sender
The sender of event
e
A EmptyFolderCompletedEventArgs arguments

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


EmptyFolderResponseType Class

Represents the results of an attempt to empty folder.

For a list of all members of this type, see EmptyFolderResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseResponseMessageType
Aspose.Email.Exchange.Schema.EmptyFolderResponseType

public class EmptyFolderResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

EmptyFolderResponseType Members | Aspose.Email.Exchange.Schema Namespace


EmptyFolderResponseType Members

EmptyFolderResponseType overview

Public Instance Constructors

EmptyFolderResponseType Constructor Initializes a new instance of the EmptyFolderResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EmptyFolderResponseType Class | Aspose.Email.Exchange.Schema Namespace


EmptyFolderResponseType Constructor

Initializes a new instance of the EmptyFolderResponseType class.

public EmptyFolderResponseType();

See Also

EmptyFolderResponseType Class | Aspose.Email.Exchange.Schema Namespace


EmptyFolderType Class

Represents the EmptyFolder request

For a list of all members of this type, see EmptyFolderType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.EmptyFolderType

public class EmptyFolderType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

EmptyFolderType Members | Aspose.Email.Exchange.Schema Namespace


EmptyFolderType Members

EmptyFolderType overview

Public Instance Constructors

EmptyFolderType Constructor Initializes a new instance of the EmptyFolderType class.

Public Instance Properties

DeleteSubFolders | Gets or sets a value indicating whether the subfolders to also be deleted. True if the subfolders are to be deleted; otherwise, false.
DeleteType | Gets or sets an enumeration value that describes how an item is deleted.
FolderIds | Gets or sets the collection of items and folders to delete.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EmptyFolderType Class | Aspose.Email.Exchange.Schema Namespace


EmptyFolderType Constructor

Initializes a new instance of the EmptyFolderType class.

public EmptyFolderType();

See Also

EmptyFolderType Class | Aspose.Email.Exchange.Schema Namespace


EmptyFolderType Properties

The properties of the EmptyFolderType class are listed below. For a complete list of EmptyFolderType class members, see the EmptyFolderType Members topic.

Public Instance Properties

DeleteSubFolders | Gets or sets a value indicating whether the subfolders to also be deleted. True if the subfolders are to be deleted; otherwise, false.
DeleteType | Gets or sets an enumeration value that describes how an item is deleted.
FolderIds | Gets or sets the collection of items and folders to delete.

See Also

EmptyFolderType Class | Aspose.Email.Exchange.Schema Namespace


DeleteSubFolders Property

Aspose.Email

EmptyFolderType.DeleteSubFolders Property

Gets or sets a value indicating whether the subfolders to also be deleted. True if the subfolders are to be deleted; otherwise, false.

public bool DeleteSubFolders {get; set;}

See Also

EmptyFolderType Class | Aspose.Email.Exchange.Schema Namespace


DeleteType Property

Aspose.Email

EmptyFolderType.DeleteType Property

Gets or sets an enumeration value that describes how an item is deleted.

public DisposalType DeleteType {get; set;}

See Also

EmptyFolderType Class | Aspose.Email.Exchange.Schema Namespace


FolderIds Property

Aspose.Email

EmptyFolderType.FolderIds Property

Gets or sets the collection of items and folders to delete.

public BaseFolderIdType[] FolderIds {get; set;}

See Also

EmptyFolderType Class | Aspose.Email.Exchange.Schema Namespace


EncryptedSharedFolderDataType Class

For a list of all members of this type, see EncryptedSharedFolderDataType Members.

System.Object
Aspose.Email.Exchange.Schema.EncryptedSharedFolderDataType

public class EncryptedSharedFolderDataType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

EncryptedSharedFolderDataType Members | Aspose.Email.Exchange.Schema Namespace


EncryptedSharedFolderDataType Members

EncryptedSharedFolderDataType overview

Public Instance Constructors

EncryptedSharedFolderDataType Constructor Initializes a new instance of the EncryptedSharedFolderDataType class.

Public Instance Properties

Data
Token

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EncryptedSharedFolderDataType Class | Aspose.Email.Exchange.Schema Namespace


EncryptedSharedFolderDataType Constructor

Initializes a new instance of the EncryptedSharedFolderDataType class.

public EncryptedSharedFolderDataType();

See Also

EncryptedSharedFolderDataType Class | Aspose.Email.Exchange.Schema Namespace


EncryptedSharedFolderDataType Properties

The properties of the EncryptedSharedFolderDataType class are listed below. For a complete list of EncryptedSharedFolderDataType class members, see the EncryptedSharedFolderDataType Members topic.

Public Instance Properties

Data
Token

See Also

EncryptedSharedFolderDataType Class | Aspose.Email.Exchange.Schema Namespace


Data Property

Aspose.Email

EncryptedSharedFolderDataType.Data Property

public XmlElement Data {get; set;}

Remarks

See Also

EncryptedSharedFolderDataType Class | Aspose.Email.Exchange.Schema Namespace


Token Property

Aspose.Email

EncryptedSharedFolderDataType.Token Property

public XmlElement Token {get; set;}

Remarks

See Also

EncryptedSharedFolderDataType Class | Aspose.Email.Exchange.Schema Namespace


EndDateRecurrenceRangeType Class

For a list of all members of this type, see EndDateRecurrenceRangeType Members.

System.Object
Aspose.Email.Exchange.Schema.RecurrenceRangeBaseType
Aspose.Email.Exchange.Schema.EndDateRecurrenceRangeType

public class EndDateRecurrenceRangeType : RecurrenceRangeBaseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

EndDateRecurrenceRangeType Members | Aspose.Email.Exchange.Schema Namespace


EndDateRecurrenceRangeType Members

EndDateRecurrenceRangeType overview

Public Instance Constructors

EndDateRecurrenceRangeType Constructor Initializes a new instance of the EndDateRecurrenceRangeType class.

Public Instance Properties

EndDate
StartDate (inherited from RecurrenceRangeBaseType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EndDateRecurrenceRangeType Class | Aspose.Email.Exchange.Schema Namespace


EndDateRecurrenceRangeType Constructor

Initializes a new instance of the EndDateRecurrenceRangeType class.

public EndDateRecurrenceRangeType();

See Also

EndDateRecurrenceRangeType Class | Aspose.Email.Exchange.Schema Namespace


EndDateRecurrenceRangeType Properties

The properties of the EndDateRecurrenceRangeType class are listed below. For a complete list of EndDateRecurrenceRangeType class members, see the EndDateRecurrenceRangeType Members topic.

Public Instance Properties

EndDate
StartDate (inherited from RecurrenceRangeBaseType)

See Also

EndDateRecurrenceRangeType Class | Aspose.Email.Exchange.Schema Namespace


EndDate Property

Aspose.Email

EndDateRecurrenceRangeType.EndDate Property

public DateTime EndDate {get; set;}

Remarks

See Also

EndDateRecurrenceRangeType Class | Aspose.Email.Exchange.Schema Namespace


ExceptionPropertyURIType Enumeration

public enum ExceptionPropertyURIType

Remarks

Members

Member Name | Description | Value
attachmentName |  | 0
attachmentContentType |  | 1
attachmentContent |  | 2
recurrenceMonth |  | 3
recurrenceDayOfWeekIndex |  | 4
recurrenceDaysOfWeek |  | 5
recurrenceDayOfMonth |  | 6
recurrenceInterval |  | 7
recurrenceNumberOfOccurrences |  | 8
timezoneOffset |  | 9

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


ExchangeImpersonationType Class

For a list of all members of this type, see ExchangeImpersonationType Members.

System.Object
System.Web.Services.Protocols.SoapHeader
Aspose.Email.Exchange.Schema.ExchangeImpersonationType

public class ExchangeImpersonationType : SoapHeader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExchangeImpersonationType Members | Aspose.Email.Exchange.Schema Namespace


ExchangeImpersonationType Members

ExchangeImpersonationType overview

Public Instance Constructors

ExchangeImpersonationType Constructor Initializes a new instance of the ExchangeImpersonationType class.

Public Instance Properties

Actor (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.
AnyAttr |
ConnectingSID |
DidUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether an XML Web service method properly processed a SOAP header.
EncodedMustUnderstand (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.1.
EncodedMustUnderstand12 (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.2.
EncodedRelay (inherited from SoapHeader) | Gets or sets the relay attribute of the SOAP 1.2 header.
MustUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether the SoapHeader must be understood.
Relay (inherited from SoapHeader) | Gets or sets a value that indicates whether the SOAP header is to be relayed to the next SOAP node if the current node does not understand the header.
Role (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExchangeImpersonationType Class | Aspose.Email.Exchange.Schema Namespace


ExchangeImpersonationType Constructor

Initializes a new instance of the ExchangeImpersonationType class.

public ExchangeImpersonationType();

See Also

ExchangeImpersonationType Class | Aspose.Email.Exchange.Schema Namespace


ExchangeImpersonationType Properties

The properties of the ExchangeImpersonationType class are listed below. For a complete list of ExchangeImpersonationType class members, see the ExchangeImpersonationType Members topic.

Public Instance Properties

Actor (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.
AnyAttr |
ConnectingSID |
DidUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether an XML Web service method properly processed a SOAP header.
EncodedMustUnderstand (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.1.
EncodedMustUnderstand12 (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.2.
EncodedRelay (inherited from SoapHeader) | Gets or sets the relay attribute of the SOAP 1.2 header.
MustUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether the SoapHeader must be understood.
Relay (inherited from SoapHeader) | Gets or sets a value that indicates whether the SOAP header is to be relayed to the next SOAP node if the current node does not understand the header.
Role (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.

See Also

ExchangeImpersonationType Class | Aspose.Email.Exchange.Schema Namespace


AnyAttr Property

Aspose.Email

ExchangeImpersonationType.AnyAttr Property

public XmlAttribute[] AnyAttr {get; set;}

Remarks

See Also

ExchangeImpersonationType Class | Aspose.Email.Exchange.Schema Namespace


ConnectingSID Property

Aspose.Email

ExchangeImpersonationType.ConnectingSID Property

public ConnectingSIDType ConnectingSID {get; set;}

Remarks

See Also

ExchangeImpersonationType Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding Class

NOTE: This class is now obsolete.

ExchangeWebServiceClient and related classes are obsolete and will be removed soon. Please uses new EWSClient.

The ExchangeServiceBinding class contains the methods and properties that are used to send and receive the SOAP messages, set up Exchange impersonation, maintain user credentials, and identify the Exchange Web Services endpoint.

For a list of all members of this type, see ExchangeServiceBinding Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Web.Services.Protocols.WebClientProtocol
System.Web.Services.Protocols.HttpWebClientProtocol
System.Web.Services.Protocols.SoapHttpClientProtocol
Aspose.Email.Exchange.Schema.ExchangeServiceBinding

public class ExchangeServiceBinding : SoapHttpClientProtocol

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExchangeServiceBinding Members | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding Members

ExchangeServiceBinding overview

Public Instance Constructors

ExchangeServiceBinding Constructor The ExchangeServiceBinding constructor initializes a new instance of the ExchangeServiceBinding class.

Public Instance Properties

AllowAutoRedirect (inherited from HttpWebClientProtocol) | Gets or sets whether the client automatically follows server redirects.
ClientCertificates (inherited from HttpWebClientProtocol) | Gets the collection of client certificates.
ConnectionGroupName (inherited from WebClientProtocol) | Gets or sets the name of the connection group for the request.
Container (inherited from Component) | Gets the IContainer that contains the Component.
CookieContainer (inherited from HttpWebClientProtocol) | Gets or sets the collection of cookies.
Credentials (inherited from WebClientProtocol) | Gets or sets security credentials for XML Web service client authentication.
EnableDecompression (inherited from HttpWebClientProtocol) | Gets or sets a Boolean that indicates whether decompression is enabled for this HttpWebClientProtocol. The default is true.
ExchangeImpersonation | The ExchangeImpersonation property gets or sets an ExchangeImpersonationType object that contains the identifier of the account to impersonate.
MailboxCulture | The MailboxCulture property gets or sets the mailbox culture that is used when a mailbox is opened.
PreAuthenticate (inherited from WebClientProtocol) | Gets or sets whether pre-authentication is enabled.
Proxy (inherited from HttpWebClientProtocol) | Gets or sets proxy information for making an XML Web service request through a firewall.
RequestEncoding (inherited from WebClientProtocol) | The Encoding used to make the client request to the XML Web service.
RequestServerVersionValue | The RequestServerVersionValue property gets or sets the target Microsoft Exchange Server version for the request.
ServerVersionInfoValue | The ServerVersionInfoValue property gets the server version from a Web service response.
Site (inherited from Component) | Gets or sets the ISite of the Component.
SoapVersion (inherited from SoapHttpClientProtocol) | Gets or sets the version of the SOAP protocol used to make the SOAP request to the XML Web service.
Timeout (inherited from WebClientProtocol) | Indicates the time an XML Web service client waits for a synchronous XML Web service request to complete (in milliseconds).
TimeZoneContext | Gets or sets the time zone definition that is to be used as the default when assigning the time zone for the DateTime properties of objects that are created, updated, and retrieved.
UnsafeAuthenticatedConnectionSharing (inherited from HttpWebClientProtocol) | Gets or sets a value that indicates whether connection sharing is enabled when the client uses NTLM authentication to connect to the Web server that hosts the XML Web service.
Url | Gets or sets the base URL of the XML Web service the client is requesting.
UseDefaultCredentials | Gets or sets a value that indicates whether to set the Credentials property to the value of the CredentialCache.DefaultCredentials property.
UserAgent (inherited from HttpWebClientProtocol) | Gets or sets the value for the user agent header that is sent with each request.

Public Instance Methods

Abort (inherited from WebClientProtocol) | Cancels a request to an XML Web service method.
AddDelegate | The AddDelegate method sends the request to and gets the response from an AddDelegate operation.
AddDelegateAsync | Overloaded. The AddDelegateAsync method provides asynchronous access to the AddDelegate operation.
ApplyConversationAction | Invokes ApplyConversation operation for the specified items
ApplyConversationActionAsync | Overloaded. Invokes ApplyConversation operation for the specified items asynchronously
CancelAsync | The CancelAsync method cancels an asynchronous call.
ConvertId | The ConvertId method sends the request to and gets the response from a ConvertId operation.
ConvertIdAsync | Overloaded. The ConvertIdAsync method sends the request to and gets the response from a ConvertId operation.
CopyFolder | The CopyFolder method sends the request to and gets the response from a CopyFolder operation.
CopyFolderAsync | Overloaded. The CopyFolderAsync method provides asynchronous access to the CopyFolder Web service method.
CopyItem | The CopyItem method sends the request to and gets the response from a CopyItem operation.
CopyItemAsync | Overloaded. The CopyItemAsync method provides asynchronous access to the CopyItem Web service method.
CreateAttachment | The CreateAttachment method sends the request to and gets the response from a CreateAttachment operation.
CreateAttachmentAsync | Overloaded. The CreateAttachmentAsync method provides asynchronous access to the CreateAttachment Web service method.
CreateFolder | The CreateFolder method sends the request and gets the response to a CreateFolder operation.
CreateFolderAsync | Overloaded. The CreateFolderAsync method sends the request and gets the response to a CreateFolder operation.
CreateItem | The CreateItem method sends the request to and gets the response from a CreateItem operation.
CreateItemAsync | Overloaded. The CreateItemAsync method provides asynchronous access to the CreateItem Web service method.
CreateManagedFolder | The CreateManagedFolder method sends the request to and gets the response from a CreateManagedFolder operation.
CreateManagedFolderAsync | Overloaded. The CreateManagedFolderAsync method provides asynchronous access to the CreateManagedFolder Web service method.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
CreateUserConfiguration | The CreateUserConfiguration method sends the request to and gets the response from an CreateUserConfiguration operation.
CreateUserConfigurationAsync | Overloaded. The CreateUserConfigurationAsync method provides asynchronous access to the CreateUserConfiguration operation.
DeleteAttachment | The DeleteAttachment method sends the request to and gets the response from a DeleteAttachment operation.
DeleteAttachmentAsync | Overloaded. The DeleteAttachmentAsync method provides asynchronous access to the DeleteAttachment Web service method.
DeleteFolder | The DeleteFolder method sends the request to and gets the response from a DeleteFolder operation.
DeleteFolderAsync | Overloaded. The DeleteFolderAsync method provides asynchronous access to the DeleteFolder Web service method.
DeleteItem | The DeleteItem method sends the request to and gets the response from a DeleteItem operation.
DeleteItemAsync | Overloaded. The DeleteItemAsync method provides asynchronous access to the DeleteItem Web service method.
DeleteUserConfiguration | The DeleteUserConfiguration method sends the request to and gets the response from an DeleteUserConfiguration operation.
DeleteUserConfigurationAsync | Overloaded. The DeleteUserConfigurationAsync method provides asynchronous access to the DeleteUserConfiguration operation.
DisconnectPhoneCall | The DisconnectPhoneCall method terminates the telephone call.
DisconnectPhoneCallAsync | Overloaded. The DisconnectPhoneCallAsync method terminates the telephone call asynchronously.
Discover (inherited from SoapHttpClientProtocol) | Dynamically binds to an XML Web service described in the discovery document at Url.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
EmptyFolder | Invokes EmptyFolder operation for the specified items
EmptyFolderAsync | Overloaded. Invokes EmptyFolder operation for the specified items asynchronously
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExpandDL | The ExpandDL method sends the request and gets the response to an ExpandDL operation.
ExpandDLAsync | Overloaded. The ExpandDLAsync method provides asynchronous access to the ExpandDL Web service method.
ExportItems | Invokes ExportItems operation for the specified items
ExportItemsAsync | Overloaded. Invokes ExportItems operation for the specified items asynchronously
FindConversation | Invokes FindConversationType operation for the specified items
FindConversationAsync | Overloaded. Invokes FindConversationType operation for the specified items asynchronously
FindFolder | The FindFolder method sends the request to and gets the response from a FindFolder operation.
FindFolderAsync | Overloaded. The FindFolderAsync method sends the request to and gets the response from a FindFolder operation.
FindItem | The FindItem method sends the request to and gets the response from a FindItem operation.
FindItemAsync | Overloaded. The FindItemAsync method sends the request to and gets the response from a FindItem operation.
FindMessageTrackingReport | The FindMessageTrackingReport method finds messages that meet the specified criteria.
FindMessageTrackingReportAsync | Overloaded. The FindMessageTrackingReportAsync method finds messages that meet the specified criteria asynchronously.
GetAttachment | The GetAttachment method sends the request to and gets the response from a GetAttachment operation.
GetAttachmentAsync | Overloaded. The GetAttachmentAsync method provides asynchronous access to the GetAttachment Web service method.
GetDelegate | The GetDelegate method sends the request to and gets the response from a GetDelegate operation.
GetDelegateAsync | Overloaded. The GetDelegateAsync method provides asynchronous access to the GetDelegate operation.
GetEvents | The GetEvents method sends the request to and gets the response from a GetEvents operation.
GetEventsAsync | Overloaded. The GetEventsAsync method provides asynchronous access to the GetEvents Web service method.
GetFolder | The GetFolder method sends the request to and gets the response from a GetFolder operation.
GetFolderAsync | Overloaded. The GetFolderAsync method sends the request to and gets the response from a GetFolder operation.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInboxRules | Invokes GetInboxRules operation for the specified inbox rule
GetInboxRulesAsync | Overloaded. Invokes GetInboxRules operation for the specified inbox rule asynchronously
GetItem | The GetItem method sends the request to and gets the response from a GetItem operation.
GetItemAsync | Overloaded. The GetItemAsync method provides asynchronous access to the GetItem Web service method.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetMailTips | The GetMailTips method gets the mail tips information for the specified mailbox.
GetMailTipsAsync | Overloaded. The GetMailTipsAsync method provides asynchronous access to mail tips information for the specified mailbox.
GetMessageTrackingReport | The GetMessageTrackingReport method gets tracking information about the specified messages.
GetMessageTrackingReportAsync | Overloaded. The GetMessageTrackingReportAsync method gets tracking information about the specified messages asynchronously.
GetPhoneCallInformation | The GetPhoneCallInformation method gets information about a telephone call.
GetPhoneCallInformationAsync | Overloaded. The GetPhoneCallInformationAsync method gets information about a telephone call asynchronously.
GetRoomLists | The GetRoomLists operation gets the room lists that are available within the Exchange organization.
GetRoomListsAsync | Overloaded. The GetRoomListsAsync operation gets the room lists that are available within the Exchange organization asynchronously.
GetRooms | The GetRooms operation gets the rooms within the specified room list.
GetRoomsAsync | Overloaded. The GetRoomsAsync operation gets the rooms within the specified room list asynchronously.
GetServerTimeZones | The GetServerTimeZones method provides asynchronous access to the GetServerTimeZones Web service method.
GetServerTimeZonesAsync | Overloaded. The GetServerTimeZonesAsync method provides asynchronous access to the GetServerTimeZones Web service method.
GetServiceConfiguration | The GetServiceConfiguration operation gets configuration information for the specified type of service.
GetServiceConfigurationAsync | Overloaded. The GetServiceConfigurationAsync operation gets configuration information for the specified type of service.
GetSharingFolder | The GetSharingFolder operation gets the local folder identifier of a specified shared folder.
GetSharingFolderAsync | Overloaded. The GetSharingFolderAsync operation gets the local folder identifier of a specified shared folder asynchronously.
GetSharingMetadata | The GetSharingMetadata method gets an opaque authentication token that identifies a sharing invitation.
GetSharingMetadataAsync | Overloaded. The GetSharingMetadataAsync method gets an opaque authentication token that identifies a sharing invitation asynchronously.
GetStreamingEvents | The GetStreamingEvents method sends the request to and gets the response from a GetStreamingEvents operation.
GetStreamingEventsAsync | Overloaded. The GetStreamingEventsAsync method provides asynchronous access to the GetStreamingEvents Web service method.
GetType (inherited from Object) | Gets the Type of the current instance.
GetUserAvailability | The GetUserAvailability method sends the request to and gets the response from a GetUserAvailability operation.
GetUserAvailabilityAsync | Overloaded. The GetUserAvailabilityAsync method provides asynchronous access to the GetUserAvailability Web service method.
GetUserConfiguration | The GetUserConfiguration method sends the request to and gets the response from an GetUserConfiguration operation.
GetUserConfigurationAsync | Overloaded. The GetUserConfigurationAsync method provides asynchronous access to the GetUserConfiguration operation.
GetUserOofSettings | The GetUserOofSettings method sends the request to and gets the response from a GetUserOofSettings operation.
GetUserOofSettingsAsync | Overloaded. The GetUserOofSettingsAsync method provides asynchronous access to the GetUserOofSettings Web service method.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
MoveFolder | The MoveFolder method sends the request to and gets the response from a MoveFolder operation.
MoveFolderAsync | Overloaded. The MoveFolderAsync method provides asynchronous access to the MoveFolder Web service method.
MoveItem | The MoveItem method sends the request to and gets the response from a MoveItem operation.
MoveItemAsync | Overloaded. The MoveItemAsync method provides asynchronous access to the MoveItem Web service method.
PlayOnPhone | The PlayOnPhone method initiates an outbound call and plays a message over the telephone.
PlayOnPhoneAsync | Overloaded. The PlayOnPhoneAsync method initiates an outbound call and plays a message over the telephone asynchronously.
RefreshSharingFolder | The RefreshSharingFolder method refreshes the specified local folder with the latest data from the folder that is being shared.
RefreshSharingFolderAsync | Overloaded. The RefreshSharingFolderAsync method refreshes the specified local folder with the latest data from the folder that is being shared asynchronously.
RemoveDelegate | The RemoveDelegate method sends the request to and gets the response from a RemoveDelegate operation.
RemoveDelegateAsync | Overloaded. The RemoveDelegateAsync method provides asynchronous access to the RemoveDelegate operation.
ResolveNames | The ResolveNames method sends the request to and returns the response from a MoveFolder operation.
ResolveNamesAsync | Overloaded. The ResolveNamesAsync methods provide an event-based method for handling asynchronous ResolveNames calls.
SendItem | The SendItem method sends the request to and returns the response from a SendItem operation.
SendItemAsync | Overloaded. The SendItemAsync method provides asynchronous access to the SendItem Web service method.
SetUserOofSettings | The SetUserOofSettings method sends the request to and returns the response from a SetUserOofSettings operation.
SetUserOofSettingsAsync | Overloaded. The SetUserOofSettingsAsync method provides asynchronous access to the SetUserOofSettings Web service method.
Subscribe | The Subscribe method sends the request to and returns the response from a Subscribe operation.
SubscribeAsync | Overloaded. The SubscribeAsync method provides asynchronous access to the Subscribe Web service method.
SyncFolderHierarchy | The SyncFolderHierarchy method sends the request to and returns the response from a SyncFolderHierarchy operation.
SyncFolderHierarchyAsync | Overloaded. The SyncFolderHierarchyAsync method provides asynchronous access to the SyncFolderHierarchy Web service method.
SyncFolderItems | The SyncFolderItems method sends the request to and returns the response from a SyncFolderItems operation.
SyncFolderItemsAsync | Overloaded. The SyncFolderItemsAsync method provides asynchronous access to the SyncFolderItems Web service method.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Unsubscribe | The Unsubscribe method sends the request to and returns the response from an Unsubscribe operation.
UnsubscribeAsync | Overloaded. The UnsubscribeAsync method provides asynchronous access to the Unsubscribe Web service method.
UpdateDelegate | The UpdateDelegate method sends the request to and gets the response from an UpdateDelegate operation.
UpdateDelegateAsync | Overloaded. The UpdateDelegateAsync method provides asynchronous access to the UpdateDelegateType operation.
UpdateFolder | The UpdateFolder method sends the request to and returns the response from an UpdateFolder operation.
UpdateFolderAsync | Overloaded. The UpdateFolderAsync method provides asynchronous access to the UpdateFolder Web service method.
UpdateInboxRules | Invokes UpdateInboxRules operation for the specified inbox rule
UpdateInboxRulesAsync | Overloaded. Invokes UpdateInboxRules operation for the specified inbox rule asynchronously
UpdateItem | The UpdateItem method sends the request to and returns the response from an UpdateItem operation.
UpdateItemAsync | Overloaded. The UpdateItemAsync method provides asynchronous access to the UpdateItem Web service method.
UpdateUserConfiguration | The UpdateUserConfiguration method sends the request to and gets the response from an UpdateUserConfiguration operation.
UpdateUserConfigurationAsync | Overloaded. The UpdateUserConfigurationAsync method provides asynchronous access to the UpdateUserConfiguration operation.
UploadItems | Invokes UploadItems operation for the specified items
UploadItemsAsync | Overloaded. Invokes UploadItems operation for the specified items asynchronously

Public Instance Events

AddDelegateCompleted | Occurs when an asynchronous AddDelegate operation is complete.
ApplyConversationActionCompleted | Occurs when the apply conversation operation has been completed
ConvertIdCompleted | Occurs when an asynchronous ConvertId operation is complete.
CopyFolderCompleted | Occurs when an asynchronous CopyFolder operation is complete.
CopyItemCompleted | Occurs when an asynchronous CopyItem operation is complete.
CreateAttachmentCompleted | Occurs when an asynchronous CreateAttachment operation is complete.
CreateFolderCompleted | Occurs when an asynchronous CreateFolder operation is complete.
CreateItemCompleted | Occurs when an asynchronous CreateItem operation is complete.
CreateManagedFolderCompleted | Occurs when an asynchronous CreateManagedFolder operation is complete.
CreateUserConfigurationCompleted | Occurs when an asynchronous CreateUserConfiguration operation is complete.
DeleteAttachmentCompleted | Occurs when an asynchronous DeleteAttachment operation is complete.
DeleteFolderCompleted | Occurs when an asynchronous DeleteFolder operation is complete.
DeleteItemCompleted | Occurs when an asynchronous DeleteItem operation is complete.
DeleteUserConfigurationCompleted | Occurs when an asynchronous DeleteUserConfiguration operation is complete.
DisconnectPhoneCallCompleted | Occurs when an asynchronous DisconnectPhoneCall operation is complete.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
EmptyFolderCompleted | Occurs when the empty folder operation has been completed
ExpandDLCompleted | Occurs when an asynchronous ExpandDL operation is complete.
ExportItemsCompleted | Occurs when the export items operation has been completed
FindConversationCompleted | Occurs when the find conversation operation has been completed
FindFolderCompleted | Occurs when an asynchronous FindFolder operation is complete.
FindItemCompleted | Occurs when an asynchronous FindItem operation is complete.
FindMessageTrackingReportCompleted | Occurs when an asynchronous FindMessageTrackingReport operation is complete.
GetAttachmentCompleted | Occurs when an asynchronous GetAttachment operation is complete.
GetDelegateCompleted | Occurs when an asynchronous GetDelegate operation is complete.
GetEventsCompleted | Occurs when an asynchronous GetEvents operation is complete.
GetFolderCompleted | Occurs when an asynchronous GetFolder operation is complete.
GetInboxRulesCompleted | Occurs when the get inbox rules operation has been completed
GetItemCompleted | Occurs when an asynchronous GetItem operation is complete.
GetMailTipsCompleted | Occurs when an asynchronous GetMailTips operation is complete.
GetMessageTrackingReportCompleted | Occurs when an asynchronous GetMessageTrackingReport operation is complete.
GetPhoneCallInformationCompleted | Occurs when an asynchronous GetPhoneCallInformation operation is complete.
GetRoomListsCompleted | Occurs when an asynchronous GetRoomLists operation is complete.
GetRoomsCompleted | Occurs when an asynchronous GetRooms operation is complete.
GetServerTimeZonesCompleted | Occurs when an asynchronous GetServerTimeZones operation is complete.
GetServiceConfigurationCompleted | Occurs when an asynchronous GetServiceConfiguration operation is complete.
GetSharingFolderCompleted | Occurs when an asynchronous GetSharingFolder operation is complete.
GetSharingMetadataCompleted | Occurs when an asynchronous GetSharingMetadata operation is complete.
GetStreamingEventsCompleted | Occurs when an asynchronous GetStreamingEvents operation is complete.
GetUserAvailabilityCompleted | Occurs when an asynchronous GetUserAvailability operation is complete.
GetUserConfigurationCompleted | Occurs when an asynchronous GetUserConfiguration operation is complete.
GetUserOofSettingsCompleted | Occurs when an asynchronous GetUserOofSettings operation is complete.
MoveFolderCompleted | Occurs when an asynchronous MoveFolder operation is complete.
MoveItemCompleted | Occurs when an asynchronous MoveItem operation is complete.
PlayOnPhoneCompleted | Occurs when an asynchronous GetMailTips operation is complete.
RefreshSharingFolderCompleted | Occurs when an asynchronous RefreshSharingFolder operation is complete.
RemoveDelegateCompleted | Occurs when an asynchronous RemoveDelegate operation is complete.
ResolveNamesCompleted | Occurs when an asynchronous ResolveNames operation is complete.
SendItemCompleted | Occurs when an asynchronous SendItem operation is complete.
SetUserOofSettingsCompleted | Occurs when an asynchronous SetUserOofSettings operation is complete.
SubscribeCompleted | Occurs when an asynchronous Subscribe operation is complete.
SyncFolderHierarchyCompleted | Occurs when an asynchronous SyncFolderHierarchy operation is complete.
SyncFolderItemsCompleted | Occurs when an asynchronous SyncFolderItems operation is complete.
UnsubscribeCompleted | Occurs when an asynchronous Unsubscribe operation is complete.
UpdateDelegateCompleted | Occurs when an asynchronous UpdateDelegate operation is complete.
UpdateFolderCompleted | Occurs when an asynchronous UpdateFolder operation is complete.
UpdateInboxRulesCompleted | Occurs when the update inbox rules operation has been completed
UpdateItemCompleted | Occurs when an asynchronous UpdateItem operation is complete.
UpdateUserConfigurationCompleted | Occurs when an asynchronous UpdateUserConfiguration operation is complete.
UploadItemsCompleted | Occurs when the upload items operation has been completed

Protected Instance Properties

CanRaiseEvents (inherited from Component) | Gets a value indicating whether the component can raise an event.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.

Protected Instance Methods

BeginInvoke (inherited from SoapHttpClientProtocol) | Starts an asynchronous invocation of an XML Web service method using SOAP.
Dispose (inherited from Component) | Overloaded. Releases the unmanaged resources used by the Component and optionally releases the managed resources.
EndInvoke (inherited from SoapHttpClientProtocol) | Ends an asynchronous invocation of an XML Web service method using SOAP.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetReaderForMessage (inherited from SoapHttpClientProtocol) | Returns an XmlReader initialized with the Stream property of the SoapClientMessage parameter.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetWebRequest (inherited from SoapHttpClientProtocol) | Creates a WebRequest for the specified uri.
GetWebResponse (inherited from HttpWebClientProtocol) | Overloaded. Returns a response from a synchronous request to an XML Web service method.
GetWriterForMessage (inherited from SoapHttpClientProtocol) | Returns a XmlWriter initialized with the Stream property of the SoapClientMessage parameter.
Invoke (inherited from SoapHttpClientProtocol) | Invokes an XML Web service method synchronously using SOAP.
InvokeAsync (inherited from SoapHttpClientProtocol) | Overloaded. Invokes the specified method asynchronously.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding Constructor

The ExchangeServiceBinding constructor initializes a new instance of the ExchangeServiceBinding class.

public ExchangeServiceBinding();

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding Properties

The properties of the ExchangeServiceBinding class are listed below. For a complete list of ExchangeServiceBinding class members, see the ExchangeServiceBinding Members topic.

Public Instance Properties

AllowAutoRedirect (inherited from HttpWebClientProtocol) | Gets or sets whether the client automatically follows server redirects.
ClientCertificates (inherited from HttpWebClientProtocol) | Gets the collection of client certificates.
ConnectionGroupName (inherited from WebClientProtocol) | Gets or sets the name of the connection group for the request.
Container (inherited from Component) | Gets the IContainer that contains the Component.
CookieContainer (inherited from HttpWebClientProtocol) | Gets or sets the collection of cookies.
Credentials (inherited from WebClientProtocol) | Gets or sets security credentials for XML Web service client authentication.
EnableDecompression (inherited from HttpWebClientProtocol) | Gets or sets a Boolean that indicates whether decompression is enabled for this HttpWebClientProtocol. The default is true.
ExchangeImpersonation | The ExchangeImpersonation property gets or sets an ExchangeImpersonationType object that contains the identifier of the account to impersonate.
MailboxCulture | The MailboxCulture property gets or sets the mailbox culture that is used when a mailbox is opened.
PreAuthenticate (inherited from WebClientProtocol) | Gets or sets whether pre-authentication is enabled.
Proxy (inherited from HttpWebClientProtocol) | Gets or sets proxy information for making an XML Web service request through a firewall.
RequestEncoding (inherited from WebClientProtocol) | The Encoding used to make the client request to the XML Web service.
RequestServerVersionValue | The RequestServerVersionValue property gets or sets the target Microsoft Exchange Server version for the request.
ServerVersionInfoValue | The ServerVersionInfoValue property gets the server version from a Web service response.
Site (inherited from Component) | Gets or sets the ISite of the Component.
SoapVersion (inherited from SoapHttpClientProtocol) | Gets or sets the version of the SOAP protocol used to make the SOAP request to the XML Web service.
Timeout (inherited from WebClientProtocol) | Indicates the time an XML Web service client waits for a synchronous XML Web service request to complete (in milliseconds).
TimeZoneContext | Gets or sets the time zone definition that is to be used as the default when assigning the time zone for the DateTime properties of objects that are created, updated, and retrieved.
UnsafeAuthenticatedConnectionSharing (inherited from HttpWebClientProtocol) | Gets or sets a value that indicates whether connection sharing is enabled when the client uses NTLM authentication to connect to the Web server that hosts the XML Web service.
Url | Gets or sets the base URL of the XML Web service the client is requesting.
UseDefaultCredentials | Gets or sets a value that indicates whether to set the Credentials property to the value of the CredentialCache.DefaultCredentials property.
UserAgent (inherited from HttpWebClientProtocol) | Gets or sets the value for the user agent header that is sent with each request.

Protected Instance Properties

CanRaiseEvents (inherited from Component) | Gets a value indicating whether the component can raise an event.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeImpersonation Property

Aspose.Email

ExchangeServiceBinding.ExchangeImpersonation Property

The ExchangeImpersonation property gets or sets an ExchangeImpersonationType object that contains the identifier of the account to impersonate.

public ExchangeImpersonationType ExchangeImpersonation {get; set;}

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


MailboxCulture Property

Aspose.Email

ExchangeServiceBinding.MailboxCulture Property

The MailboxCulture property gets or sets the mailbox culture that is used when a mailbox is opened.

public MailboxCultureType MailboxCulture {get; set;}

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


RequestServerVersionValue Property

Aspose.Email

ExchangeServiceBinding.RequestServerVersionValue Property

The RequestServerVersionValue property gets or sets the target Microsoft Exchange Server version for the request.

public RequestServerVersion RequestServerVersionValue {get; set;}

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ServerVersionInfoValue Property

Aspose.Email

ExchangeServiceBinding.ServerVersionInfoValue Property

The ServerVersionInfoValue property gets the server version from a Web service response.

public ServerVersionInfo ServerVersionInfoValue {get; set;}

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


TimeZoneContext Property

Aspose.Email

ExchangeServiceBinding.TimeZoneContext Property

Gets or sets the time zone definition that is to be used as the default when assigning the time zone for the DateTime properties of objects that are created, updated, and retrieved.

public TimeZoneContextType TimeZoneContext {get; set;}

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


Url Property

Aspose.Email

ExchangeServiceBinding.Url Property

Gets or sets the base URL of the XML Web service the client is requesting.

new public string Url {get; set;}

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


UseDefaultCredentials Property

Aspose.Email

ExchangeServiceBinding.UseDefaultCredentials Property

Gets or sets a value that indicates whether to set the Credentials property to the value of the CredentialCache.DefaultCredentials property.

new public bool UseDefaultCredentials {get; set;}

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding Methods

The methods of the ExchangeServiceBinding class are listed below. For a complete list of ExchangeServiceBinding class members, see the ExchangeServiceBinding Members topic.

Public Instance Methods

Abort (inherited from WebClientProtocol) | Cancels a request to an XML Web service method.
AddDelegate | The AddDelegate method sends the request to and gets the response from an AddDelegate operation.
AddDelegateAsync | Overloaded. The AddDelegateAsync method provides asynchronous access to the AddDelegate operation.
ApplyConversationAction | Invokes ApplyConversation operation for the specified items
ApplyConversationActionAsync | Overloaded. Invokes ApplyConversation operation for the specified items asynchronously
CancelAsync | The CancelAsync method cancels an asynchronous call.
ConvertId | The ConvertId method sends the request to and gets the response from a ConvertId operation.
ConvertIdAsync | Overloaded. The ConvertIdAsync method sends the request to and gets the response from a ConvertId operation.
CopyFolder | The CopyFolder method sends the request to and gets the response from a CopyFolder operation.
CopyFolderAsync | Overloaded. The CopyFolderAsync method provides asynchronous access to the CopyFolder Web service method.
CopyItem | The CopyItem method sends the request to and gets the response from a CopyItem operation.
CopyItemAsync | Overloaded. The CopyItemAsync method provides asynchronous access to the CopyItem Web service method.
CreateAttachment | The CreateAttachment method sends the request to and gets the response from a CreateAttachment operation.
CreateAttachmentAsync | Overloaded. The CreateAttachmentAsync method provides asynchronous access to the CreateAttachment Web service method.
CreateFolder | The CreateFolder method sends the request and gets the response to a CreateFolder operation.
CreateFolderAsync | Overloaded. The CreateFolderAsync method sends the request and gets the response to a CreateFolder operation.
CreateItem | The CreateItem method sends the request to and gets the response from a CreateItem operation.
CreateItemAsync | Overloaded. The CreateItemAsync method provides asynchronous access to the CreateItem Web service method.
CreateManagedFolder | The CreateManagedFolder method sends the request to and gets the response from a CreateManagedFolder operation.
CreateManagedFolderAsync | Overloaded. The CreateManagedFolderAsync method provides asynchronous access to the CreateManagedFolder Web service method.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
CreateUserConfiguration | The CreateUserConfiguration method sends the request to and gets the response from an CreateUserConfiguration operation.
CreateUserConfigurationAsync | Overloaded. The CreateUserConfigurationAsync method provides asynchronous access to the CreateUserConfiguration operation.
DeleteAttachment | The DeleteAttachment method sends the request to and gets the response from a DeleteAttachment operation.
DeleteAttachmentAsync | Overloaded. The DeleteAttachmentAsync method provides asynchronous access to the DeleteAttachment Web service method.
DeleteFolder | The DeleteFolder method sends the request to and gets the response from a DeleteFolder operation.
DeleteFolderAsync | Overloaded. The DeleteFolderAsync method provides asynchronous access to the DeleteFolder Web service method.
DeleteItem | The DeleteItem method sends the request to and gets the response from a DeleteItem operation.
DeleteItemAsync | Overloaded. The DeleteItemAsync method provides asynchronous access to the DeleteItem Web service method.
DeleteUserConfiguration | The DeleteUserConfiguration method sends the request to and gets the response from an DeleteUserConfiguration operation.
DeleteUserConfigurationAsync | Overloaded. The DeleteUserConfigurationAsync method provides asynchronous access to the DeleteUserConfiguration operation.
DisconnectPhoneCall | The DisconnectPhoneCall method terminates the telephone call.
DisconnectPhoneCallAsync | Overloaded. The DisconnectPhoneCallAsync method terminates the telephone call asynchronously.
Discover (inherited from SoapHttpClientProtocol) | Dynamically binds to an XML Web service described in the discovery document at Url.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
EmptyFolder | Invokes EmptyFolder operation for the specified items
EmptyFolderAsync | Overloaded. Invokes EmptyFolder operation for the specified items asynchronously
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExpandDL | The ExpandDL method sends the request and gets the response to an ExpandDL operation.
ExpandDLAsync | Overloaded. The ExpandDLAsync method provides asynchronous access to the ExpandDL Web service method.
ExportItems | Invokes ExportItems operation for the specified items
ExportItemsAsync | Overloaded. Invokes ExportItems operation for the specified items asynchronously
FindConversation | Invokes FindConversationType operation for the specified items
FindConversationAsync | Overloaded. Invokes FindConversationType operation for the specified items asynchronously
FindFolder | The FindFolder method sends the request to and gets the response from a FindFolder operation.
FindFolderAsync | Overloaded. The FindFolderAsync method sends the request to and gets the response from a FindFolder operation.
FindItem | The FindItem method sends the request to and gets the response from a FindItem operation.
FindItemAsync | Overloaded. The FindItemAsync method sends the request to and gets the response from a FindItem operation.
FindMessageTrackingReport | The FindMessageTrackingReport method finds messages that meet the specified criteria.
FindMessageTrackingReportAsync | Overloaded. The FindMessageTrackingReportAsync method finds messages that meet the specified criteria asynchronously.
GetAttachment | The GetAttachment method sends the request to and gets the response from a GetAttachment operation.
GetAttachmentAsync | Overloaded. The GetAttachmentAsync method provides asynchronous access to the GetAttachment Web service method.
GetDelegate | The GetDelegate method sends the request to and gets the response from a GetDelegate operation.
GetDelegateAsync | Overloaded. The GetDelegateAsync method provides asynchronous access to the GetDelegate operation.
GetEvents | The GetEvents method sends the request to and gets the response from a GetEvents operation.
GetEventsAsync | Overloaded. The GetEventsAsync method provides asynchronous access to the GetEvents Web service method.
GetFolder | The GetFolder method sends the request to and gets the response from a GetFolder operation.
GetFolderAsync | Overloaded. The GetFolderAsync method sends the request to and gets the response from a GetFolder operation.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInboxRules | Invokes GetInboxRules operation for the specified inbox rule
GetInboxRulesAsync | Overloaded. Invokes GetInboxRules operation for the specified inbox rule asynchronously
GetItem | The GetItem method sends the request to and gets the response from a GetItem operation.
GetItemAsync | Overloaded. The GetItemAsync method provides asynchronous access to the GetItem Web service method.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetMailTips | The GetMailTips method gets the mail tips information for the specified mailbox.
GetMailTipsAsync | Overloaded. The GetMailTipsAsync method provides asynchronous access to mail tips information for the specified mailbox.
GetMessageTrackingReport | The GetMessageTrackingReport method gets tracking information about the specified messages.
GetMessageTrackingReportAsync | Overloaded. The GetMessageTrackingReportAsync method gets tracking information about the specified messages asynchronously.
GetPhoneCallInformation | The GetPhoneCallInformation method gets information about a telephone call.
GetPhoneCallInformationAsync | Overloaded. The GetPhoneCallInformationAsync method gets information about a telephone call asynchronously.
GetRoomLists | The GetRoomLists operation gets the room lists that are available within the Exchange organization.
GetRoomListsAsync | Overloaded. The GetRoomListsAsync operation gets the room lists that are available within the Exchange organization asynchronously.
GetRooms | The GetRooms operation gets the rooms within the specified room list.
GetRoomsAsync | Overloaded. The GetRoomsAsync operation gets the rooms within the specified room list asynchronously.
GetServerTimeZones | The GetServerTimeZones method provides asynchronous access to the GetServerTimeZones Web service method.
GetServerTimeZonesAsync | Overloaded. The GetServerTimeZonesAsync method provides asynchronous access to the GetServerTimeZones Web service method.
GetServiceConfiguration | The GetServiceConfiguration operation gets configuration information for the specified type of service.
GetServiceConfigurationAsync | Overloaded. The GetServiceConfigurationAsync operation gets configuration information for the specified type of service.
GetSharingFolder | The GetSharingFolder operation gets the local folder identifier of a specified shared folder.
GetSharingFolderAsync | Overloaded. The GetSharingFolderAsync operation gets the local folder identifier of a specified shared folder asynchronously.
GetSharingMetadata | The GetSharingMetadata method gets an opaque authentication token that identifies a sharing invitation.
GetSharingMetadataAsync | Overloaded. The GetSharingMetadataAsync method gets an opaque authentication token that identifies a sharing invitation asynchronously.
GetStreamingEvents | The GetStreamingEvents method sends the request to and gets the response from a GetStreamingEvents operation.
GetStreamingEventsAsync | Overloaded. The GetStreamingEventsAsync method provides asynchronous access to the GetStreamingEvents Web service method.
GetType (inherited from Object) | Gets the Type of the current instance.
GetUserAvailability | The GetUserAvailability method sends the request to and gets the response from a GetUserAvailability operation.
GetUserAvailabilityAsync | Overloaded. The GetUserAvailabilityAsync method provides asynchronous access to the GetUserAvailability Web service method.
GetUserConfiguration | The GetUserConfiguration method sends the request to and gets the response from an GetUserConfiguration operation.
GetUserConfigurationAsync | Overloaded. The GetUserConfigurationAsync method provides asynchronous access to the GetUserConfiguration operation.
GetUserOofSettings | The GetUserOofSettings method sends the request to and gets the response from a GetUserOofSettings operation.
GetUserOofSettingsAsync | Overloaded. The GetUserOofSettingsAsync method provides asynchronous access to the GetUserOofSettings Web service method.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
MoveFolder | The MoveFolder method sends the request to and gets the response from a MoveFolder operation.
MoveFolderAsync | Overloaded. The MoveFolderAsync method provides asynchronous access to the MoveFolder Web service method.
MoveItem | The MoveItem method sends the request to and gets the response from a MoveItem operation.
MoveItemAsync | Overloaded. The MoveItemAsync method provides asynchronous access to the MoveItem Web service method.
PlayOnPhone | The PlayOnPhone method initiates an outbound call and plays a message over the telephone.
PlayOnPhoneAsync | Overloaded. The PlayOnPhoneAsync method initiates an outbound call and plays a message over the telephone asynchronously.
RefreshSharingFolder | The RefreshSharingFolder method refreshes the specified local folder with the latest data from the folder that is being shared.
RefreshSharingFolderAsync | Overloaded. The RefreshSharingFolderAsync method refreshes the specified local folder with the latest data from the folder that is being shared asynchronously.
RemoveDelegate | The RemoveDelegate method sends the request to and gets the response from a RemoveDelegate operation.
RemoveDelegateAsync | Overloaded. The RemoveDelegateAsync method provides asynchronous access to the RemoveDelegate operation.
ResolveNames | The ResolveNames method sends the request to and returns the response from a MoveFolder operation.
ResolveNamesAsync | Overloaded. The ResolveNamesAsync methods provide an event-based method for handling asynchronous ResolveNames calls.
SendItem | The SendItem method sends the request to and returns the response from a SendItem operation.
SendItemAsync | Overloaded. The SendItemAsync method provides asynchronous access to the SendItem Web service method.
SetUserOofSettings | The SetUserOofSettings method sends the request to and returns the response from a SetUserOofSettings operation.
SetUserOofSettingsAsync | Overloaded. The SetUserOofSettingsAsync method provides asynchronous access to the SetUserOofSettings Web service method.
Subscribe | The Subscribe method sends the request to and returns the response from a Subscribe operation.
SubscribeAsync | Overloaded. The SubscribeAsync method provides asynchronous access to the Subscribe Web service method.
SyncFolderHierarchy | The SyncFolderHierarchy method sends the request to and returns the response from a SyncFolderHierarchy operation.
SyncFolderHierarchyAsync | Overloaded. The SyncFolderHierarchyAsync method provides asynchronous access to the SyncFolderHierarchy Web service method.
SyncFolderItems | The SyncFolderItems method sends the request to and returns the response from a SyncFolderItems operation.
SyncFolderItemsAsync | Overloaded. The SyncFolderItemsAsync method provides asynchronous access to the SyncFolderItems Web service method.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
Unsubscribe | The Unsubscribe method sends the request to and returns the response from an Unsubscribe operation.
UnsubscribeAsync | Overloaded. The UnsubscribeAsync method provides asynchronous access to the Unsubscribe Web service method.
UpdateDelegate | The UpdateDelegate method sends the request to and gets the response from an UpdateDelegate operation.
UpdateDelegateAsync | Overloaded. The UpdateDelegateAsync method provides asynchronous access to the UpdateDelegateType operation.
UpdateFolder | The UpdateFolder method sends the request to and returns the response from an UpdateFolder operation.
UpdateFolderAsync | Overloaded. The UpdateFolderAsync method provides asynchronous access to the UpdateFolder Web service method.
UpdateInboxRules | Invokes UpdateInboxRules operation for the specified inbox rule
UpdateInboxRulesAsync | Overloaded. Invokes UpdateInboxRules operation for the specified inbox rule asynchronously
UpdateItem | The UpdateItem method sends the request to and returns the response from an UpdateItem operation.
UpdateItemAsync | Overloaded. The UpdateItemAsync method provides asynchronous access to the UpdateItem Web service method.
UpdateUserConfiguration | The UpdateUserConfiguration method sends the request to and gets the response from an UpdateUserConfiguration operation.
UpdateUserConfigurationAsync | Overloaded. The UpdateUserConfigurationAsync method provides asynchronous access to the UpdateUserConfiguration operation.
UploadItems | Invokes UploadItems operation for the specified items
UploadItemsAsync | Overloaded. Invokes UploadItems operation for the specified items asynchronously

Protected Instance Methods

BeginInvoke (inherited from SoapHttpClientProtocol) | Starts an asynchronous invocation of an XML Web service method using SOAP.
Dispose (inherited from Component) | Overloaded. Releases the unmanaged resources used by the Component and optionally releases the managed resources.
EndInvoke (inherited from SoapHttpClientProtocol) | Ends an asynchronous invocation of an XML Web service method using SOAP.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetReaderForMessage (inherited from SoapHttpClientProtocol) | Returns an XmlReader initialized with the Stream property of the SoapClientMessage parameter.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetWebRequest (inherited from SoapHttpClientProtocol) | Creates a WebRequest for the specified uri.
GetWebResponse (inherited from HttpWebClientProtocol) | Overloaded. Returns a response from a synchronous request to an XML Web service method.
GetWriterForMessage (inherited from SoapHttpClientProtocol) | Returns a XmlWriter initialized with the Stream property of the SoapClientMessage parameter.
Invoke (inherited from SoapHttpClientProtocol) | Invokes an XML Web service method synchronously using SOAP.
InvokeAsync (inherited from SoapHttpClientProtocol) | Overloaded. Invokes the specified method asynchronously.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.AddDelegate Method

The AddDelegate method sends the request to and gets the response from an AddDelegate operation.

public AddDelegateResponseMessageType AddDelegate(
AddDelegateType AddDelegate1
);

Parameters

AddDelegate1
An instance of the AddDelegateType class that represents the delegates to add to a mailbox.

Return Value

The AddDelegate class returns a AddDelegateResponseMessageType object that contains the status of the AddDelegate operation.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


AddDelegateAsync Method

Aspose.Email

ExchangeServiceBinding.AddDelegateAsync Method

The AddDelegateAsync method provides asynchronous access to the AddDelegate operation.

Overload List

The AddDelegateAsync method provides asynchronous access to the AddDelegate operation.

public void AddDelegateAsync(AddDelegateType);

The AddDelegateAsync method provides asynchronous access to the AddDelegate operation.

public void AddDelegateAsync(AddDelegateType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.AddDelegateAsync Method (AddDelegateType)

The AddDelegateAsync method provides asynchronous access to the AddDelegate operation.

public void AddDelegateAsync(
AddDelegateType AddDelegate1
);

Parameters

AddDelegate1
An instance of the AddDelegateType class that represents the delegates to add to a mailbox.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.AddDelegateAsync Overload List


ExchangeServiceBinding.AddDelegateAsync Method (AddDelegateType, Object)

The AddDelegateAsync method provides asynchronous access to the AddDelegate operation.

public void AddDelegateAsync(
AddDelegateType AddDelegate1,
object userState
);

Parameters

AddDelegate1
An instance of the AddDelegateType class that represents the delegates to add to a mailbox.
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.AddDelegateAsync Overload List


ExchangeServiceBinding.ApplyConversationAction Method

Invokes ApplyConversation operation for the specified items

public ApplyConversationActionResponseType ApplyConversationAction(
ApplyConversationActionType ApplyConversationAction1
);

Parameters

ApplyConversationAction1
A ApplyConversationActionType request

Return Value

A received ApplyConversationActionResponseType response

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ApplyConversationActionAsync Method

Aspose.Email

ExchangeServiceBinding.ApplyConversationActionAsync Method

Invokes ApplyConversation operation for the specified items asynchronously

Overload List

Invokes ApplyConversation operation for the specified items asynchronously

public void ApplyConversationActionAsync(ApplyConversationActionType);

Invokes ApplyConversation operation for the specified items asynchronously

public void ApplyConversationActionAsync(ApplyConversationActionType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.ApplyConversationActionAsync Method (ApplyConversationActionType)

Invokes ApplyConversation operation for the specified items asynchronously

public void ApplyConversationActionAsync(
ApplyConversationActionType ApplyConversationAction1
);

Parameters

ApplyConversationAction1
A ApplyConversationActionType request

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.ApplyConversationActionAsync Overload List


ExchangeServiceBinding.ApplyConversationActionAsync Method (ApplyConversationActionType, Object)

Invokes ApplyConversation operation for the specified items asynchronously

public void ApplyConversationActionAsync(
ApplyConversationActionType ApplyConversationAction1,
object userState
);

Parameters

ApplyConversationAction1
A ApplyConversationActionType request
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.ApplyConversationActionAsync Overload List


ExchangeServiceBinding.CancelAsync Method

The CancelAsync method cancels an asynchronous call.

new public void CancelAsync(
object userState
);

Parameters

userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.ConvertId Method

The ConvertId method sends the request to and gets the response from a ConvertId operation.

public ConvertIdResponseType ConvertId(
ConvertIdType ConvertId1
);

Parameters

ConvertId1
An instance of the ConvertIdType class that represents the identifiers to convert.

Return Value

The ConvertId method returns a ConvertIdResponseType object that contains the status of a ConvertId operation and the converted identifiers.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ConvertIdAsync Method

Aspose.Email

ExchangeServiceBinding.ConvertIdAsync Method

The ConvertIdAsync method sends the request to and gets the response from a ConvertId operation.

Overload List

The ConvertIdAsync method sends the request to and gets the response from a ConvertId operation.

public void ConvertIdAsync(ConvertIdType);

The ConvertIdAsync method sends the request to and gets the response from a ConvertId operation.

public void ConvertIdAsync(ConvertIdType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.ConvertIdAsync Method (ConvertIdType)

The ConvertIdAsync method sends the request to and gets the response from a ConvertId operation.

public void ConvertIdAsync(
ConvertIdType ConvertId1
);

Parameters

ConvertId1
An instance of the ConvertIdType class that represents the identifiers to convert.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.ConvertIdAsync Overload List


ExchangeServiceBinding.ConvertIdAsync Method (ConvertIdType, Object)

The ConvertIdAsync method sends the request to and gets the response from a ConvertId operation.

public void ConvertIdAsync(
ConvertIdType ConvertId1,
object userState
);

Parameters

ConvertId1
An instance of the ConvertIdType class that represents the identifiers to convert.
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.ConvertIdAsync Overload List


ExchangeServiceBinding.CopyFolder Method

The CopyFolder method sends the request to and gets the response from a CopyFolder operation.

public CopyFolderResponseType CopyFolder(
CopyFolderType CopyFolder1
);

Parameters

CopyFolder1
An instance of the CopyFolderType class that represents the folders to copy and the destination folder that contains the copies.

Return Value

The CopyFolder method returns a CopyFolderResponseType object that contains the status of the CopyFolder operation and the identifiers of the new folders.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


CopyFolderAsync Method

Aspose.Email

ExchangeServiceBinding.CopyFolderAsync Method

The CopyFolderAsync method provides asynchronous access to the CopyFolder Web service method.

Overload List

The CopyFolderAsync method provides asynchronous access to the CopyFolder Web service method.

public void CopyFolderAsync(CopyFolderType);

The CopyFolderAsync method provides asynchronous access to the CopyFolder Web service method.

public void CopyFolderAsync(CopyFolderType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.CopyFolderAsync Method (CopyFolderType)

The CopyFolderAsync method provides asynchronous access to the CopyFolder Web service method.

public void CopyFolderAsync(
CopyFolderType CopyFolder1
);

Parameters

CopyFolder1
An instance of the CopyFolderType class that represents the folders to copy and the destination folder that contains the copies.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.CopyFolderAsync Overload List


ExchangeServiceBinding.CopyFolderAsync Method (CopyFolderType, Object)

The CopyFolderAsync method provides asynchronous access to the CopyFolder Web service method.

public void CopyFolderAsync(
CopyFolderType CopyFolder1,
object userState
);

Parameters

CopyFolder1
An instance of the CopyFolderType class that represents the folders to copy and the destination folder that contains the copies.
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.CopyFolderAsync Overload List


ExchangeServiceBinding.CopyItem Method

The CopyItem method sends the request to and gets the response from a CopyItem operation.

public CopyItemResponseType CopyItem(
CopyItemType CopyItem1
);

Parameters

CopyItem1
An instance of the CopyItemType class that represents the items to copy and the destination folder that contains the copies.

Return Value

The CopyItem method returns a CopyItemResponseType object that contains the status of the CopyItem operation and the identifiers of the new items.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


CopyItemAsync Method

Aspose.Email

ExchangeServiceBinding.CopyItemAsync Method

The CopyItemAsync method provides asynchronous access to the CopyItem Web service method.

Overload List

The CopyItemAsync method provides asynchronous access to the CopyItem Web service method.

public void CopyItemAsync(CopyItemType);

The CopyItemAsync method provides asynchronous access to the CopyItem Web service method.

public void CopyItemAsync(CopyItemType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.CopyItemAsync Method (CopyItemType)

The CopyItemAsync method provides asynchronous access to the CopyItem Web service method.

public void CopyItemAsync(
CopyItemType CopyItem1
);

Parameters

CopyItem1
An instance of the CopyItemType class that represents the items to copy and the destination folder that contains the copies.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.CopyItemAsync Overload List


ExchangeServiceBinding.CopyItemAsync Method (CopyItemType, Object)

The CopyItemAsync method provides asynchronous access to the CopyItem Web service method.

public void CopyItemAsync(
CopyItemType CopyItem1,
object userState
);

Parameters

CopyItem1
An instance of the CopyItemType class that represents the items to copy and the destination folder that contains the copies.
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.CopyItemAsync Overload List


ExchangeServiceBinding.CreateAttachment Method

The CreateAttachment method sends the request to and gets the response from a CreateAttachment operation.

public CreateAttachmentResponseType CreateAttachment(
CreateAttachmentType CreateAttachment1
);

Parameters

CreateAttachment1
An instance of the CreateAttachmentType class that represents the attachments to associate with a parent item.

Return Value

The CreateAttachment method returns a CreateAttachmentType object that contains the status of the CreateAttachment operation.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


CreateAttachmentAsync Method

Aspose.Email

ExchangeServiceBinding.CreateAttachmentAsync Method

The CreateAttachmentAsync method provides asynchronous access to the CreateAttachment Web service method.

Overload List

The CreateAttachmentAsync method provides asynchronous access to the CreateAttachment Web service method.

public void CreateAttachmentAsync(CreateAttachmentType);

The CreateAttachmentAsync method provides asynchronous access to the CreateAttachment Web service method.

public void CreateAttachmentAsync(CreateAttachmentType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.CreateAttachmentAsync Method (CreateAttachmentType)

The CreateAttachmentAsync method provides asynchronous access to the CreateAttachment Web service method.

public void CreateAttachmentAsync(
CreateAttachmentType CreateAttachment1
);

Parameters

CreateAttachment1
An instance of the CreateAttachmentType class that represents the attachments to associate with a parent item.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.CreateAttachmentAsync Overload List


ExchangeServiceBinding.CreateAttachmentAsync Method (CreateAttachmentType, Object)

The CreateAttachmentAsync method provides asynchronous access to the CreateAttachment Web service method.

public void CreateAttachmentAsync(
CreateAttachmentType CreateAttachment1,
object userState
);

Parameters

CreateAttachment1
An instance of the CreateAttachmentType class that represents the attachments to associate with a parent item.
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.CreateAttachmentAsync Overload List


ExchangeServiceBinding.CreateFolder Method

The CreateFolder method sends the request and gets the response to a CreateFolder operation.

public CreateFolderResponseType CreateFolder(
CreateFolderType CreateFolder1
);

Parameters

CreateFolder1
An instance of the CreateFolderType class that represents the folders to create.

Return Value

The CreateFolder method returns a CreateFolderResponseType object that contains the identifiers of the created folders.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


CreateFolderAsync Method

Aspose.Email

ExchangeServiceBinding.CreateFolderAsync Method

The CreateFolderAsync method sends the request and gets the response to a CreateFolder operation.

Overload List

The CreateFolderAsync method sends the request and gets the response to a CreateFolder operation.

public void CreateFolderAsync(CreateFolderType);

The CreateFolderAsync method sends the request and gets the response to a CreateFolder operation.

public void CreateFolderAsync(CreateFolderType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.CreateFolderAsync Method (CreateFolderType)

The CreateFolderAsync method sends the request and gets the response to a CreateFolder operation.

public void CreateFolderAsync(
CreateFolderType CreateFolder1
);

Parameters

CreateFolder1
An instance of the CreateFolderType class that represents the folders to create.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.CreateFolderAsync Overload List


ExchangeServiceBinding.CreateFolderAsync Method (CreateFolderType, Object)

The CreateFolderAsync method sends the request and gets the response to a CreateFolder operation.

public void CreateFolderAsync(
CreateFolderType CreateFolder1,
object userState
);

Parameters

CreateFolder1
An instance of the CreateFolderType class that represents the folders to create.
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.CreateFolderAsync Overload List


ExchangeServiceBinding.CreateItem Method

The CreateItem method sends the request to and gets the response from a CreateItem operation.

public CreateItemResponseType CreateItem(
CreateItemType CreateItem1
);

Parameters

CreateItem1
An instance of the CreateItemType class that represents a set of items to create.

Return Value

The CreateItem method returns a CreateItemResponseType object that contains the status of the CreateItem operation and in many scenarios, the identifiers of the new items.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


CreateItemAsync Method

Aspose.Email

ExchangeServiceBinding.CreateItemAsync Method

The CreateItemAsync method provides asynchronous access to the CreateItem Web service method.

Overload List

The CreateItemAsync method provides asynchronous access to the CreateItem Web service method.

public void CreateItemAsync(CreateItemType);

The CreateItemAsync method provides asynchronous access to the CreateItem Web service method.

public void CreateItemAsync(CreateItemType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.CreateItemAsync Method (CreateItemType)

The CreateItemAsync method provides asynchronous access to the CreateItem Web service method.

public void CreateItemAsync(
CreateItemType CreateItem1
);

Parameters

CreateItem1
An instance of the CreateItemType class that represents a set of items to create.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.CreateItemAsync Overload List


ExchangeServiceBinding.CreateItemAsync Method (CreateItemType, Object)

The CreateItemAsync method provides asynchronous access to the CreateItem Web service method.

public void CreateItemAsync(
CreateItemType CreateItem1,
object userState
);

Parameters

CreateItem1
An instance of the CreateItemType class that represents a set of items to create.
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.CreateItemAsync Overload List


ExchangeServiceBinding.CreateManagedFolder Method

The CreateManagedFolder method sends the request to and gets the response from a CreateManagedFolder operation.

public CreateManagedFolderResponseType CreateManagedFolder(
CreateManagedFolderRequestType CreateManagedFolder1
);

Parameters

CreateManagedFolder1
An instance of the CreateManagedFolderRequestType class that represents the managed folders to add to a mailbox.

Return Value

The CreateManagedFolder method returns a CreateManagedFolderResponseType object that contains the status of the CreateManagedFolder operation.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


CreateManagedFolderAsync Method

Aspose.Email

ExchangeServiceBinding.CreateManagedFolderAsync Method

The CreateManagedFolderAsync method provides asynchronous access to the CreateManagedFolder Web service method.

Overload List

The CreateManagedFolderAsync method provides asynchronous access to the CreateManagedFolder Web service method.

public void CreateManagedFolderAsync(CreateManagedFolderRequestType);

The CreateManagedFolderAsync method provides asynchronous access to the CreateManagedFolder Web service method.

public void CreateManagedFolderAsync(CreateManagedFolderRequestType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.CreateManagedFolderAsync Method (CreateManagedFolderRequestType)

The CreateManagedFolderAsync method provides asynchronous access to the CreateManagedFolder Web service method.

public void CreateManagedFolderAsync(
CreateManagedFolderRequestType CreateManagedFolder1
);

Parameters

CreateManagedFolder1
An instance of the CreateManagedFolderRequestType class that represents the managed folders to add to a mailbox.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.CreateManagedFolderAsync Overload List


ExchangeServiceBinding.CreateManagedFolderAsync Method (CreateManagedFolderRequestType, Object)

The CreateManagedFolderAsync method provides asynchronous access to the CreateManagedFolder Web service method.

public void CreateManagedFolderAsync(
CreateManagedFolderRequestType CreateManagedFolder1,
object userState
);

Parameters

CreateManagedFolder1
An instance of the CreateManagedFolderRequestType class that represents the managed folders to add to a mailbox.
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.CreateManagedFolderAsync Overload List


ExchangeServiceBinding.CreateUserConfiguration Method

The CreateUserConfiguration method sends the request to and gets the response from an CreateUserConfiguration operation.

public CreateUserConfigurationResponseType CreateUserConfiguration(
CreateUserConfigurationType CreateUserConfiguration1
);

Parameters

CreateUserConfiguration1
An instance of the CreateUserConfigurationType class that represents the request to create user configuration.

Return Value

The CreateUserConfiguration method returns a CreateUserConfigurationResponseType object.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


CreateUserConfigurationAsync Method

Aspose.Email

ExchangeServiceBinding.CreateUserConfigurationAsync Method

The CreateUserConfigurationAsync method provides asynchronous access to the CreateUserConfiguration operation.

Overload List

The CreateUserConfigurationAsync method provides asynchronous access to the CreateUserConfiguration operation.

public void CreateUserConfigurationAsync(CreateUserConfigurationType);

The CreateUserConfigurationAsync method provides asynchronous access to the CreateUserConfiguration operation.

public void CreateUserConfigurationAsync(CreateUserConfigurationType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.CreateUserConfigurationAsync Method (CreateUserConfigurationType)

The CreateUserConfigurationAsync method provides asynchronous access to the CreateUserConfiguration operation.

public void CreateUserConfigurationAsync(
CreateUserConfigurationType CreateUserConfiguration1
);

Parameters

CreateUserConfiguration1
An instance of the CreateUserConfigurationType class that represents the request to create user configuration.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.CreateUserConfigurationAsync Overload List


ExchangeServiceBinding.CreateUserConfigurationAsync Method (CreateUserConfigurationType, Object)

The CreateUserConfigurationAsync method provides asynchronous access to the CreateUserConfiguration operation.

public void CreateUserConfigurationAsync(
CreateUserConfigurationType CreateUserConfiguration1,
object userState
);

Parameters

CreateUserConfiguration1
An instance of the CreateUserConfigurationType class that represents the request to create user configuration.
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.CreateUserConfigurationAsync Overload List


ExchangeServiceBinding.DeleteAttachment Method

The DeleteAttachment method sends the request to and gets the response from a DeleteAttachment operation.

public DeleteAttachmentResponseType DeleteAttachment(
DeleteAttachmentType DeleteAttachment1
);

Parameters

DeleteAttachment1
An instance of the DeleteAttachmentType class that represents the set of attachments to delete.

Return Value

The DeleteAttachment method returns a DeleteAttachmentResponseType object that contains the status of the DeleteAttachment operation.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


DeleteAttachmentAsync Method

Aspose.Email

ExchangeServiceBinding.DeleteAttachmentAsync Method

The DeleteAttachmentAsync method provides asynchronous access to the DeleteAttachment Web service method.

Overload List

The DeleteAttachmentAsync method provides asynchronous access to the DeleteAttachment Web service method.

public void DeleteAttachmentAsync(DeleteAttachmentType);

The DeleteAttachmentAsync method provides asynchronous access to the DeleteAttachment Web service method.

public void DeleteAttachmentAsync(DeleteAttachmentType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.DeleteAttachmentAsync Method (DeleteAttachmentType)

The DeleteAttachmentAsync method provides asynchronous access to the DeleteAttachment Web service method.

public void DeleteAttachmentAsync(
DeleteAttachmentType DeleteAttachment1
);

Parameters

DeleteAttachment1
An instance of the DeleteAttachmentType class that represents the set of attachments to delete.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.DeleteAttachmentAsync Overload List


ExchangeServiceBinding.DeleteAttachmentAsync Method (DeleteAttachmentType, Object)

The DeleteAttachmentAsync method provides asynchronous access to the DeleteAttachment Web service method.

public void DeleteAttachmentAsync(
DeleteAttachmentType DeleteAttachment1,
object userState
);

Parameters

DeleteAttachment1
An instance of the DeleteAttachmentType class that represents the set of attachments to delete.
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.DeleteAttachmentAsync Overload List


ExchangeServiceBinding.DeleteFolder Method

The DeleteFolder method sends the request to and gets the response from a DeleteFolder operation.

public DeleteFolderResponseType DeleteFolder(
DeleteFolderType DeleteFolder1
);

Parameters

DeleteFolder1
An instance of the DeleteFolderType class that represents a set of folders to delete.

Return Value

The DeleteFolder method returns a DeleteFolderResponseType object that contains the status of the DeleteFolder operation.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


DeleteFolderAsync Method

Aspose.Email

ExchangeServiceBinding.DeleteFolderAsync Method

The DeleteFolderAsync method provides asynchronous access to the DeleteFolder Web service method.

Overload List

The DeleteFolderAsync method provides asynchronous access to the DeleteFolder Web service method.

public void DeleteFolderAsync(DeleteFolderType);

The DeleteFolderAsync method provides asynchronous access to the DeleteFolder Web service method.

public void DeleteFolderAsync(DeleteFolderType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.DeleteFolderAsync Method (DeleteFolderType)

The DeleteFolderAsync method provides asynchronous access to the DeleteFolder Web service method.

public void DeleteFolderAsync(
DeleteFolderType DeleteFolder1
);

Parameters

DeleteFolder1
An instance of the DeleteFolderType class that represents a set of folders to delete.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.DeleteFolderAsync Overload List


ExchangeServiceBinding.DeleteFolderAsync Method (DeleteFolderType, Object)

The DeleteFolderAsync method provides asynchronous access to the DeleteFolder Web service method.

public void DeleteFolderAsync(
DeleteFolderType DeleteFolder1,
object userState
);

Parameters

DeleteFolder1
An instance of the DeleteFolderType class that represents a set of folders to delete.
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.DeleteFolderAsync Overload List


ExchangeServiceBinding.DeleteItem Method

The DeleteItem method sends the request to and gets the response from a DeleteItem operation.

public DeleteItemResponseType DeleteItem(
DeleteItemType DeleteItem1
);

Parameters

DeleteItem1
An instance of the DeleteItemType class that represents the items to delete.

Return Value

The DeleteItem method returns a DeleteItemResponseType object that contains the status of the DeleteItem operation.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


DeleteItemAsync Method

Aspose.Email

ExchangeServiceBinding.DeleteItemAsync Method

The DeleteItemAsync method provides asynchronous access to the DeleteItem Web service method.

Overload List

The DeleteItemAsync method provides asynchronous access to the DeleteItem Web service method.

public void DeleteItemAsync(DeleteItemType);

The DeleteItemAsync method provides asynchronous access to the DeleteItem Web service method.

public void DeleteItemAsync(DeleteItemType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.DeleteItemAsync Method (DeleteItemType)

The DeleteItemAsync method provides asynchronous access to the DeleteItem Web service method.

public void DeleteItemAsync(
DeleteItemType DeleteItem1
);

Parameters

DeleteItem1
An instance of the DeleteItemType class that represents the items to delete.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.DeleteItemAsync Overload List


ExchangeServiceBinding.DeleteItemAsync Method (DeleteItemType, Object)

The DeleteItemAsync method provides asynchronous access to the DeleteItem Web service method.

public void DeleteItemAsync(
DeleteItemType DeleteItem1,
object userState
);

Parameters

DeleteItem1
An instance of the DeleteItemType class that represents the items to delete.
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.DeleteItemAsync Overload List


ExchangeServiceBinding.DeleteUserConfiguration Method

The DeleteUserConfiguration method sends the request to and gets the response from an DeleteUserConfiguration operation.

public DeleteUserConfigurationResponseType DeleteUserConfiguration(
DeleteUserConfigurationType DeleteUserConfiguration1
);

Parameters

DeleteUserConfiguration1
An instance of the DeleteUserConfigurationType class that represents the request to delete user configuration.

Return Value

The DeleteUserConfiguration method returns a DeleteUserConfigurationResponseType object.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


DeleteUserConfigurationAsync Method

Aspose.Email

ExchangeServiceBinding.DeleteUserConfigurationAsync Method

The DeleteUserConfigurationAsync method provides asynchronous access to the DeleteUserConfiguration operation.

Overload List

The DeleteUserConfigurationAsync method provides asynchronous access to the DeleteUserConfiguration operation.

public void DeleteUserConfigurationAsync(DeleteUserConfigurationType);

The DeleteUserConfigurationAsync method provides asynchronous access to the DeleteUserConfiguration operation.

public void DeleteUserConfigurationAsync(DeleteUserConfigurationType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.DeleteUserConfigurationAsync Method (DeleteUserConfigurationType)

The DeleteUserConfigurationAsync method provides asynchronous access to the DeleteUserConfiguration operation.

public void DeleteUserConfigurationAsync(
DeleteUserConfigurationType DeleteUserConfiguration1
);

Parameters

DeleteUserConfiguration1
An instance of the DeleteUserConfigurationType class that represents the request to delete user configuration.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.DeleteUserConfigurationAsync Overload List


ExchangeServiceBinding.DeleteUserConfigurationAsync Method (DeleteUserConfigurationType, Object)

The DeleteUserConfigurationAsync method provides asynchronous access to the DeleteUserConfiguration operation.

public void DeleteUserConfigurationAsync(
DeleteUserConfigurationType DeleteUserConfiguration1,
object userState
);

Parameters

DeleteUserConfiguration1
An instance of the DeleteUserConfigurationType class that represents the request to delete user configuration.
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.DeleteUserConfigurationAsync Overload List


ExchangeServiceBinding.DisconnectPhoneCall Method

The DisconnectPhoneCall method terminates the telephone call.

public DisconnectPhoneCallResponseMessageType DisconnectPhoneCall(
DisconnectPhoneCallType DisconnectPhoneCall1
);

Parameters

DisconnectPhoneCall1
An instance of the DisconnectPhoneCallType class

Return Value

Returns result code of operation

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


DisconnectPhoneCallAsync Method

Aspose.Email

ExchangeServiceBinding.DisconnectPhoneCallAsync Method

The DisconnectPhoneCallAsync method terminates the telephone call asynchronously.

Overload List

The DisconnectPhoneCallAsync method terminates the telephone call asynchronously.

public void DisconnectPhoneCallAsync(DisconnectPhoneCallType);

The DisconnectPhoneCallAsync method terminates the telephone call asynchronously.

public void DisconnectPhoneCallAsync(DisconnectPhoneCallType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.DisconnectPhoneCallAsync Method (DisconnectPhoneCallType)

The DisconnectPhoneCallAsync method terminates the telephone call asynchronously.

public void DisconnectPhoneCallAsync(
DisconnectPhoneCallType DisconnectPhoneCall1
);

Parameters

DisconnectPhoneCall1
An instance of the DisconnectPhoneCallType class

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.DisconnectPhoneCallAsync Overload List


ExchangeServiceBinding.DisconnectPhoneCallAsync Method (DisconnectPhoneCallType, Object)

The DisconnectPhoneCallAsync method terminates the telephone call asynchronously.

public void DisconnectPhoneCallAsync(
DisconnectPhoneCallType DisconnectPhoneCall1,
object userState
);

Parameters

DisconnectPhoneCall1
An instance of the DisconnectPhoneCallType class
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.DisconnectPhoneCallAsync Overload List


ExchangeServiceBinding.EmptyFolder Method

Invokes EmptyFolder operation for the specified items

public EmptyFolderResponseType EmptyFolder(
EmptyFolderType EmptyFolder1
);

Parameters

EmptyFolder1
A EmptyFolderType request

Return Value

A received EmptyFolderResponseType response

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


EmptyFolderAsync Method

Aspose.Email

ExchangeServiceBinding.EmptyFolderAsync Method

Invokes EmptyFolder operation for the specified items asynchronously

Overload List

Invokes EmptyFolder operation for the specified items asynchronously

public void EmptyFolderAsync(EmptyFolderType);

Invokes EmptyFolder operation for the specified items asynchronously

public void EmptyFolderAsync(EmptyFolderType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.EmptyFolderAsync Method (EmptyFolderType)

Invokes EmptyFolder operation for the specified items asynchronously

public void EmptyFolderAsync(
EmptyFolderType EmptyFolder1
);

Parameters

EmptyFolder1
A EmptyFolderType request

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.EmptyFolderAsync Overload List


ExchangeServiceBinding.EmptyFolderAsync Method (EmptyFolderType, Object)

Invokes EmptyFolder operation for the specified items asynchronously

public void EmptyFolderAsync(
EmptyFolderType EmptyFolder1,
object userState
);

Parameters

EmptyFolder1
A EmptyFolderType request
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.EmptyFolderAsync Overload List


ExchangeServiceBinding.ExpandDL Method

The ExpandDL method sends the request and gets the response to an ExpandDL operation.

public ExpandDLResponseType ExpandDL(
ExpandDLType ExpandDL1
);

Parameters

ExpandDL1
An instance of the ExpandDLType class that represents the distribution list to expand.

Return Value

The ExpandDL method returns an ExpandDLResponseType object that contains the status of the ExpandDL operation.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExpandDLAsync Method

Aspose.Email

ExchangeServiceBinding.ExpandDLAsync Method

The ExpandDLAsync method provides asynchronous access to the ExpandDL Web service method.

Overload List

The ExpandDLAsync method provides asynchronous access to the ExpandDL Web service method.

public void ExpandDLAsync(ExpandDLType);

The ExpandDLAsync method provides asynchronous access to the ExpandDL Web service method.

public void ExpandDLAsync(ExpandDLType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.ExpandDLAsync Method (ExpandDLType)

The ExpandDLAsync method provides asynchronous access to the ExpandDL Web service method.

public void ExpandDLAsync(
ExpandDLType ExpandDL1
);

Parameters

ExpandDL1
The ExpandDL request.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.ExpandDLAsync Overload List


ExchangeServiceBinding.ExpandDLAsync Method (ExpandDLType, Object)

The ExpandDLAsync method provides asynchronous access to the ExpandDL Web service method.

public void ExpandDLAsync(
ExpandDLType ExpandDL1,
object userState
);

Parameters

ExpandDL1
The ExpandDL request.
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.ExpandDLAsync Overload List


ExchangeServiceBinding.ExportItems Method

Invokes ExportItems operation for the specified items

public ExportItemsResponseType ExportItems(
ExportItemsType ExportItems1
);

Parameters

ExportItems1
A ExportItemsType request

Return Value

A received ExportItemsResponseType response

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExportItemsAsync Method

Aspose.Email

ExchangeServiceBinding.ExportItemsAsync Method

Invokes ExportItems operation for the specified items asynchronously

Overload List

Invokes ExportItems operation for the specified items asynchronously

public void ExportItemsAsync(ExportItemsType);

Invokes ExportItems operation for the specified items asynchronously

public void ExportItemsAsync(ExportItemsType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.ExportItemsAsync Method (ExportItemsType)

Invokes ExportItems operation for the specified items asynchronously

public void ExportItemsAsync(
ExportItemsType ExportItems1
);

Parameters

ExportItems1
A ExportItemsType request

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.ExportItemsAsync Overload List


ExchangeServiceBinding.ExportItemsAsync Method (ExportItemsType, Object)

Invokes ExportItems operation for the specified items asynchronously

public void ExportItemsAsync(
ExportItemsType ExportItems1,
object userState
);

Parameters

ExportItems1
A ExportItemsType request
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.ExportItemsAsync Overload List


ExchangeServiceBinding.FindConversation Method

Invokes FindConversationType operation for the specified items

public FindConversationResponseMessageType FindConversation(
FindConversationType FindConversation1
);

Parameters

FindConversation1
A FindConversationType request

Return Value

A received FindConversationResponseMessageType response

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


FindConversationAsync Method

Aspose.Email

ExchangeServiceBinding.FindConversationAsync Method

Invokes FindConversationType operation for the specified items asynchronously

Overload List

Invokes FindConversationType operation for the specified items asynchronously

public void FindConversationAsync(FindConversationType);

Invokes FindConversationType operation for the specified items asynchronously

public void FindConversationAsync(FindConversationType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.FindConversationAsync Method (FindConversationType)

Invokes FindConversationType operation for the specified items asynchronously

public void FindConversationAsync(
FindConversationType FindConversation1
);

Parameters

FindConversation1
A FindConversationType request

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.FindConversationAsync Overload List


ExchangeServiceBinding.FindConversationAsync Method (FindConversationType, Object)

Invokes FindConversationType operation for the specified items asynchronously

public void FindConversationAsync(
FindConversationType FindConversation1,
object userState
);

Parameters

FindConversation1
A FindConversationType request
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.FindConversationAsync Overload List


ExchangeServiceBinding.FindFolder Method

The FindFolder method sends the request to and gets the response from a FindFolder operation.

public FindFolderResponseType FindFolder(
FindFolderType FindFolder1
);

Parameters

FindFolder1
An instance of the FindFolderType class that represents the query that is used to search for folders.

Return Value

The FindFolder method returns a FindFolderResponseType object that contains the query result of the FindFolder operation.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


FindFolderAsync Method

Aspose.Email

ExchangeServiceBinding.FindFolderAsync Method

The FindFolderAsync method sends the request to and gets the response from a FindFolder operation.

Overload List

The FindFolderAsync method sends the request to and gets the response from a FindFolder operation.

public void FindFolderAsync(FindFolderType);

The FindFolderAsync method sends the request to and gets the response from a FindFolder operation.

public void FindFolderAsync(FindFolderType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.FindFolderAsync Method (FindFolderType)

The FindFolderAsync method sends the request to and gets the response from a FindFolder operation.

public void FindFolderAsync(
FindFolderType FindFolder1
);

Parameters

FindFolder1
An instance of the FindFolderType class that represents the query that is used to search for folders.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.FindFolderAsync Overload List


ExchangeServiceBinding.FindFolderAsync Method (FindFolderType, Object)

The FindFolderAsync method sends the request to and gets the response from a FindFolder operation.

public void FindFolderAsync(
FindFolderType FindFolder1,
object userState
);

Parameters

FindFolder1
An instance of the FindFolderType class that represents the query that is used to search for folders.
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.FindFolderAsync Overload List


ExchangeServiceBinding.FindItem Method

The FindItem method sends the request to and gets the response from a FindItem operation.

public FindItemResponseType FindItem(
FindItemType FindItem1
);

Parameters

FindItem1
An instance of the FindItemType class that represents the query that is used to search for items.

Return Value

The FindItem method returns a FindItemResponseType object that contains the query result of the FindItem operation.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


FindItemAsync Method

Aspose.Email

ExchangeServiceBinding.FindItemAsync Method

The FindItemAsync method sends the request to and gets the response from a FindItem operation.

Overload List

The FindItemAsync method sends the request to and gets the response from a FindItem operation.

public void FindItemAsync(FindItemType);

The FindItemAsync method sends the request to and gets the response from a FindItem operation.

public void FindItemAsync(FindItemType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.FindItemAsync Method (FindItemType)

The FindItemAsync method sends the request to and gets the response from a FindItem operation.

public void FindItemAsync(
FindItemType FindItem1
);

Parameters

FindItem1
An instance of the FindItemType class that represents the query that is used to search for items.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.FindItemAsync Overload List


ExchangeServiceBinding.FindItemAsync Method (FindItemType, Object)

The FindItemAsync method sends the request to and gets the response from a FindItem operation.

public void FindItemAsync(
FindItemType FindItem1,
object userState
);

Parameters

FindItem1
An instance of the FindItemType class that represents the query that is used to search for items.
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.FindItemAsync Overload List


ExchangeServiceBinding.FindMessageTrackingReport Method

The FindMessageTrackingReport method finds messages that meet the specified criteria.

public FindMessageTrackingReportResponseMessageType FindMessageTrackingReport(
FindMessageTrackingReportRequestType FindMessageTrackingReport1
);

Parameters

FindMessageTrackingReport1
An instance of the FindMessageTrackingReportRequestType class

Return Value

Returns messages that meet the specified criteria

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


FindMessageTrackingReportAsync Method

Aspose.Email

ExchangeServiceBinding.FindMessageTrackingReportAsync Method

The FindMessageTrackingReportAsync method finds messages that meet the specified criteria asynchronously.

Overload List

The FindMessageTrackingReportAsync method finds messages that meet the specified criteria asynchronously.

public void FindMessageTrackingReportAsync(FindMessageTrackingReportRequestType);

The FindMessageTrackingReportAsync method finds messages that meet the specified criteria asynchronously.

public void FindMessageTrackingReportAsync(FindMessageTrackingReportRequestType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.FindMessageTrackingReportAsync Method (FindMessageTrackingReportRequestType)

The FindMessageTrackingReportAsync method finds messages that meet the specified criteria asynchronously.

public void FindMessageTrackingReportAsync(
FindMessageTrackingReportRequestType FindMessageTrackingReport1
);

Parameters

FindMessageTrackingReport1
An instance of the FindMessageTrackingReportRequestType class

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.FindMessageTrackingReportAsync Overload List


ExchangeServiceBinding.FindMessageTrackingReportAsync Method (FindMessageTrackingReportRequestType, Object)

The FindMessageTrackingReportAsync method finds messages that meet the specified criteria asynchronously.

public void FindMessageTrackingReportAsync(
FindMessageTrackingReportRequestType FindMessageTrackingReport1,
object userState
);

Parameters

FindMessageTrackingReport1
An instance of the FindMessageTrackingReportRequestType class
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.FindMessageTrackingReportAsync Overload List


ExchangeServiceBinding.GetAttachment Method

The GetAttachment method sends the request to and gets the response from a GetAttachment operation.

public GetAttachmentResponseType GetAttachment(
GetAttachmentType GetAttachment1
);

Parameters

GetAttachment1
An instance of the GetAttachmentType class that represents the set of attachments to get.

Return Value

The GetAttachment method returns a GetAttachmentResponseType object that contains the status of the GetAttachment operation and the set of requested attachments.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


GetAttachmentAsync Method

Aspose.Email

ExchangeServiceBinding.GetAttachmentAsync Method

The GetAttachmentAsync method provides asynchronous access to the GetAttachment Web service method.

Overload List

The GetAttachmentAsync method provides asynchronous access to the GetAttachment Web service method.

public void GetAttachmentAsync(GetAttachmentType);

The GetAttachmentAsync method provides asynchronous access to the GetAttachment Web service method.

public void GetAttachmentAsync(GetAttachmentType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.GetAttachmentAsync Method (GetAttachmentType)

The GetAttachmentAsync method provides asynchronous access to the GetAttachment Web service method.

public void GetAttachmentAsync(
GetAttachmentType GetAttachment1
);

Parameters

GetAttachment1
An instance of the GetAttachmentType class that represents the set of attachments to get.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.GetAttachmentAsync Overload List


ExchangeServiceBinding.GetAttachmentAsync Method (GetAttachmentType, Object)

The GetAttachmentAsync method provides asynchronous access to the GetAttachment Web service method.

public void GetAttachmentAsync(
GetAttachmentType GetAttachment1,
object userState
);

Parameters

GetAttachment1
An instance of the GetAttachmentType class that represents the set of attachments to get.
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.GetAttachmentAsync Overload List


ExchangeServiceBinding.GetDelegate Method

The GetDelegate method sends the request to and gets the response from a GetDelegate operation.

public GetDelegateResponseMessageType GetDelegate(
GetDelegateType GetDelegate1
);

Parameters

GetDelegate1
An instance of the GetDelegateType class that represents the request to get a delegate.

Return Value

The GetDelegate method returns a GetDelegateResponseMessageType object that contains a delegate.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


GetDelegateAsync Method

Aspose.Email

ExchangeServiceBinding.GetDelegateAsync Method

The GetDelegateAsync method provides asynchronous access to the GetDelegate operation.

Overload List

The GetDelegateAsync method provides asynchronous access to the GetDelegate operation.

public void GetDelegateAsync(GetDelegateType);

The GetDelegateAsync method provides asynchronous access to the GetDelegate operation.

public void GetDelegateAsync(GetDelegateType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.GetDelegateAsync Method (GetDelegateType)

The GetDelegateAsync method provides asynchronous access to the GetDelegate operation.

public void GetDelegateAsync(
GetDelegateType GetDelegate1
);

Parameters

GetDelegate1
An instance of the GetDelegateType class that represents the request to get a delegate.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.GetDelegateAsync Overload List


ExchangeServiceBinding.GetDelegateAsync Method (GetDelegateType, Object)

The GetDelegateAsync method provides asynchronous access to the GetDelegate operation.

public void GetDelegateAsync(
GetDelegateType GetDelegate1,
object userState
);

Parameters

GetDelegate1
An instance of the GetDelegateType class that represents the request to get a delegate.
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.GetDelegateAsync Overload List


ExchangeServiceBinding.GetEvents Method

The GetEvents method sends the request to and gets the response from a GetEvents operation.

public GetEventsResponseType GetEvents(
GetEventsType GetEvents1
);

Parameters

GetEvents1
An instance of the GetEventsType class that contains the identifier for a pull subscription and a specific watermark.

Return Value

The GetEvents method returns a GetEventsResponseType object that contains the status of the GetEvents operation and a notification that may contain a set of events for a subscription.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


GetEventsAsync Method

Aspose.Email

ExchangeServiceBinding.GetEventsAsync Method

The GetEventsAsync method provides asynchronous access to the GetEvents Web service method.

Overload List

The GetEventsAsync method provides asynchronous access to the GetEvents Web service method.

public void GetEventsAsync(GetEventsType);

The GetEventsAsync method provides asynchronous access to the GetEvents Web service method.

public void GetEventsAsync(GetEventsType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.GetEventsAsync Method (GetEventsType)

The GetEventsAsync method provides asynchronous access to the GetEvents Web service method.

public void GetEventsAsync(
GetEventsType GetEvents1
);

Parameters

GetEvents1
An instance of the GetEventsType class that contains the identifier for a pull subscription and a specific watermark.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.GetEventsAsync Overload List


ExchangeServiceBinding.GetEventsAsync Method (GetEventsType, Object)

The GetEventsAsync method provides asynchronous access to the GetEvents Web service method.

public void GetEventsAsync(
GetEventsType GetEvents1,
object userState
);

Parameters

GetEvents1
An instance of the GetEventsType class that contains the identifier for a pull subscription and a specific watermark.
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.GetEventsAsync Overload List


ExchangeServiceBinding.GetFolder Method

The GetFolder method sends the request to and gets the response from a GetFolder operation.

public GetFolderResponseType GetFolder(
GetFolderType GetFolder1
);

Parameters

GetFolder1
An instance of the GetFolderType class that represents the set of folders to get.

Return Value

The GetFolder method returns a GetFolderResponseType object that contains the status of the GetFolder operation and a set of folders.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


GetFolderAsync Method

Aspose.Email

ExchangeServiceBinding.GetFolderAsync Method

The GetFolderAsync method sends the request to and gets the response from a GetFolder operation.

Overload List

The GetFolderAsync method sends the request to and gets the response from a GetFolder operation.

public void GetFolderAsync(GetFolderType);

The GetFolderAsync method sends the request to and gets the response from a GetFolder operation.

public void GetFolderAsync(GetFolderType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.GetFolderAsync Method (GetFolderType)

The GetFolderAsync method sends the request to and gets the response from a GetFolder operation.

public void GetFolderAsync(
GetFolderType GetFolder1
);

Parameters

GetFolder1
An instance of the GetFolderType class that represents the set of folders to get.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.GetFolderAsync Overload List


ExchangeServiceBinding.GetFolderAsync Method (GetFolderType, Object)

The GetFolderAsync method sends the request to and gets the response from a GetFolder operation.

public void GetFolderAsync(
GetFolderType GetFolder1,
object userState
);

Parameters

GetFolder1
An instance of the GetFolderType class that represents the set of folders to get.
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.GetFolderAsync Overload List


ExchangeServiceBinding.GetInboxRules Method

Invokes GetInboxRules operation for the specified inbox rule

public GetInboxRulesResponseType GetInboxRules(
GetInboxRulesRequestType GetInboxRules1
);

Parameters

GetInboxRules1
A GetInboxRulesRequestType request

Return Value

A received GetInboxRulesResponseType response

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


GetInboxRulesAsync Method

Aspose.Email

ExchangeServiceBinding.GetInboxRulesAsync Method

Invokes GetInboxRules operation for the specified inbox rule asynchronously

Overload List

Invokes GetInboxRules operation for the specified inbox rule asynchronously

public void GetInboxRulesAsync(GetInboxRulesRequestType);

Invokes GetInboxRules operation for the specified inbox rule asynchronously

public void GetInboxRulesAsync(GetInboxRulesRequestType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.GetInboxRulesAsync Method (GetInboxRulesRequestType)

Invokes GetInboxRules operation for the specified inbox rule asynchronously

public void GetInboxRulesAsync(
GetInboxRulesRequestType GetInboxRules1
);

Parameters

GetInboxRules1
A GetInboxRulesRequestType request

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.GetInboxRulesAsync Overload List


ExchangeServiceBinding.GetInboxRulesAsync Method (GetInboxRulesRequestType, Object)

Invokes GetInboxRules operation for the specified inbox rule asynchronously

public void GetInboxRulesAsync(
GetInboxRulesRequestType GetInboxRules1,
object userState
);

Parameters

GetInboxRules1
A GetInboxRulesRequestType request
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.GetInboxRulesAsync Overload List


ExchangeServiceBinding.GetItem Method

The GetItem method sends the request to and gets the response from a GetItem operation.

public GetItemResponseType GetItem(
GetItemType GetItem1
);

Parameters

GetItem1
An instance of the GetItemType class that represents the set of items to get.

Return Value

The GetItem method returns a GetItemResponseType object that contains the status of the GetItem operation and the set of items.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


GetItemAsync Method

Aspose.Email

ExchangeServiceBinding.GetItemAsync Method

The GetItemAsync method provides asynchronous access to the GetItem Web service method.

Overload List

The GetItemAsync method provides asynchronous access to the GetItem Web service method.

public void GetItemAsync(GetItemType);

The GetItemAsync method provides asynchronous access to the GetItem Web service method.

public void GetItemAsync(GetItemType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.GetItemAsync Method (GetItemType)

The GetItemAsync method provides asynchronous access to the GetItem Web service method.

public void GetItemAsync(
GetItemType GetItem1
);

Parameters

GetItem1
An instance of the GetItemType class that represents the set of items to get.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.GetItemAsync Overload List


ExchangeServiceBinding.GetItemAsync Method (GetItemType, Object)

The GetItemAsync method provides asynchronous access to the GetItem Web service method.

public void GetItemAsync(
GetItemType GetItem1,
object userState
);

Parameters

GetItem1
An instance of the GetItemType class that represents the set of items to get.
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.GetItemAsync Overload List


ExchangeServiceBinding.GetMailTips Method

The GetMailTips method gets the mail tips information for the specified mailbox.

public GetMailTipsResponseMessageType GetMailTips(
GetMailTipsType GetMailTips1
);

Parameters

GetMailTips1
An instance of the GetMailTipsType class

Return Value

Returns mail tips information for the specified mailbox

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


GetMailTipsAsync Method

Aspose.Email

ExchangeServiceBinding.GetMailTipsAsync Method

The GetMailTipsAsync method provides asynchronous access to mail tips information for the specified mailbox.

Overload List

The GetMailTipsAsync method provides asynchronous access to mail tips information for the specified mailbox.

public void GetMailTipsAsync(GetMailTipsType);

The GetMailTipsAsync method provides asynchronous access to mail tips information for the specified mailbox.

public void GetMailTipsAsync(GetMailTipsType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.GetMailTipsAsync Method (GetMailTipsType)

The GetMailTipsAsync method provides asynchronous access to mail tips information for the specified mailbox.

public void GetMailTipsAsync(
GetMailTipsType GetMailTips1
);

Parameters

GetMailTips1
An instance of the GetMailTipsType class

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.GetMailTipsAsync Overload List


ExchangeServiceBinding.GetMailTipsAsync Method (GetMailTipsType, Object)

The GetMailTipsAsync method provides asynchronous access to mail tips information for the specified mailbox.

public void GetMailTipsAsync(
GetMailTipsType GetMailTips1,
object userState
);

Parameters

GetMailTips1
An instance of the GetMailTipsType class
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.GetMailTipsAsync Overload List


ExchangeServiceBinding.GetMessageTrackingReport Method

The GetMessageTrackingReport method gets tracking information about the specified messages.

public GetMessageTrackingReportResponseMessageType GetMessageTrackingReport(
GetMessageTrackingReportRequestType GetMessageTrackingReport1
);

Parameters

GetMessageTrackingReport1
An instance of the GetMessageTrackingReportRequestType class

Return Value

Returns tracking information about the specified messages.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


GetMessageTrackingReportAsync Method

Aspose.Email

ExchangeServiceBinding.GetMessageTrackingReportAsync Method

The GetMessageTrackingReportAsync method gets tracking information about the specified messages asynchronously.

Overload List

The GetMessageTrackingReportAsync method gets tracking information about the specified messages asynchronously.

public void GetMessageTrackingReportAsync(GetMessageTrackingReportRequestType);

The GetMessageTrackingReportAsync method gets tracking information about the specified messages asynchronously.

public void GetMessageTrackingReportAsync(GetMessageTrackingReportRequestType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.GetMessageTrackingReportAsync Method (GetMessageTrackingReportRequestType)

The GetMessageTrackingReportAsync method gets tracking information about the specified messages asynchronously.

public void GetMessageTrackingReportAsync(
GetMessageTrackingReportRequestType GetMessageTrackingReport1
);

Parameters

GetMessageTrackingReport1
An instance of the GetMessageTrackingReportRequestType class

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.GetMessageTrackingReportAsync Overload List


ExchangeServiceBinding.GetMessageTrackingReportAsync Method (GetMessageTrackingReportRequestType, Object)

The GetMessageTrackingReportAsync method gets tracking information about the specified messages asynchronously.

public void GetMessageTrackingReportAsync(
GetMessageTrackingReportRequestType GetMessageTrackingReport1,
object userState
);

Parameters

GetMessageTrackingReport1
An instance of the GetMessageTrackingReportRequestType class
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.GetMessageTrackingReportAsync Overload List


ExchangeServiceBinding.GetPhoneCallInformation Method

The GetPhoneCallInformation method gets information about a telephone call.

public GetPhoneCallInformationResponseMessageType GetPhoneCallInformation(
GetPhoneCallInformationType GetPhoneCallInformation1
);

Parameters

GetPhoneCallInformation1
An instance of the GetPhoneCallInformationType class

Return Value

Returns phone call information

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


GetPhoneCallInformationAsync Method

Aspose.Email

ExchangeServiceBinding.GetPhoneCallInformationAsync Method

The GetPhoneCallInformationAsync method gets information about a telephone call asynchronously.

Overload List

The GetPhoneCallInformationAsync method gets information about a telephone call asynchronously.

public void GetPhoneCallInformationAsync(GetPhoneCallInformationType);

The GetPhoneCallInformationAsync method gets information about a telephone call asynchronously.

public void GetPhoneCallInformationAsync(GetPhoneCallInformationType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.GetPhoneCallInformationAsync Method (GetPhoneCallInformationType)

The GetPhoneCallInformationAsync method gets information about a telephone call asynchronously.

public void GetPhoneCallInformationAsync(
GetPhoneCallInformationType GetPhoneCallInformation1
);

Parameters

GetPhoneCallInformation1
An instance of the GetPhoneCallInformationType class

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.GetPhoneCallInformationAsync Overload List


ExchangeServiceBinding.GetPhoneCallInformationAsync Method (GetPhoneCallInformationType, Object)

The GetPhoneCallInformationAsync method gets information about a telephone call asynchronously.

public void GetPhoneCallInformationAsync(
GetPhoneCallInformationType GetPhoneCallInformation1,
object userState
);

Parameters

GetPhoneCallInformation1
An instance of the GetPhoneCallInformationType class
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.GetPhoneCallInformationAsync Overload List


ExchangeServiceBinding.GetRoomLists Method

The GetRoomLists operation gets the room lists that are available within the Exchange organization.

public GetRoomListsResponseMessageType GetRoomLists(
GetRoomListsType GetRoomLists1
);

Parameters

GetRoomLists1
An instance of the GetRoomsType class

Return Value

Returns the room lists that are available within the Exchange organization.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


GetRoomListsAsync Method

Aspose.Email

ExchangeServiceBinding.GetRoomListsAsync Method

The GetRoomListsAsync operation gets the room lists that are available within the Exchange organization asynchronously.

Overload List

The GetRoomListsAsync operation gets the room lists that are available within the Exchange organization asynchronously.

public void GetRoomListsAsync(GetRoomListsType);

The GetRoomListsAsync operation gets the room lists that are available within the Exchange organization asynchronously.

public void GetRoomListsAsync(GetRoomListsType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.GetRoomListsAsync Method (GetRoomListsType)

The GetRoomListsAsync operation gets the room lists that are available within the Exchange organization asynchronously.

public void GetRoomListsAsync(
GetRoomListsType GetRoomLists1
);

Parameters

GetRoomLists1
An instance of the GetRoomListsType class

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.GetRoomListsAsync Overload List


ExchangeServiceBinding.GetRoomListsAsync Method (GetRoomListsType, Object)

The GetRoomListsAsync operation gets the room lists that are available within the Exchange organization asynchronously.

public void GetRoomListsAsync(
GetRoomListsType GetRoomLists1,
object userState
);

Parameters

GetRoomLists1
An instance of the GetRoomListsType class
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.GetRoomListsAsync Overload List


ExchangeServiceBinding.GetRooms Method

The GetRooms operation gets the rooms within the specified room list.

public GetRoomsResponseMessageType GetRooms(
GetRoomsType GetRooms1
);

Parameters

GetRooms1
An instance of the GetRoomsType class

Return Value

Returns the rooms within the specified room list.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


GetRoomsAsync Method

Aspose.Email

ExchangeServiceBinding.GetRoomsAsync Method

The GetRoomsAsync operation gets the rooms within the specified room list asynchronously.

Overload List

The GetRoomsAsync operation gets the rooms within the specified room list asynchronously.

public void GetRoomsAsync(GetRoomsType);

The GetRoomsAsync operation gets the rooms within the specified room list asynchronously.

public void GetRoomsAsync(GetRoomsType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.GetRoomsAsync Method (GetRoomsType)

The GetRoomsAsync operation gets the rooms within the specified room list asynchronously.

public void GetRoomsAsync(
GetRoomsType GetRooms1
);

Parameters

GetRooms1
An instance of the GetRoomsType class

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.GetRoomsAsync Overload List


ExchangeServiceBinding.GetRoomsAsync Method (GetRoomsType, Object)

The GetRoomsAsync operation gets the rooms within the specified room list asynchronously.

public void GetRoomsAsync(
GetRoomsType GetRooms1,
object userState
);

Parameters

GetRooms1
An instance of the GetRoomsType class
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.GetRoomsAsync Overload List


ExchangeServiceBinding.GetServerTimeZones Method

The GetServerTimeZones method provides asynchronous access to the GetServerTimeZones Web service method.

public GetServerTimeZonesResponseType GetServerTimeZones(
GetServerTimeZonesType GetServerTimeZones1
);

Parameters

GetServerTimeZones1
The GetServerTimeZones request.

Return Value

Returns GetServerTimeZonesResponseType object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


GetServerTimeZonesAsync Method

Aspose.Email

ExchangeServiceBinding.GetServerTimeZonesAsync Method

The GetServerTimeZonesAsync method provides asynchronous access to the GetServerTimeZones Web service method.

Overload List

The GetServerTimeZonesAsync method provides asynchronous access to the GetServerTimeZones Web service method.

public void GetServerTimeZonesAsync(GetServerTimeZonesType);

The GetServerTimeZonesAsync method provides asynchronous access to the GetServerTimeZones Web service method.

public void GetServerTimeZonesAsync(GetServerTimeZonesType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.GetServerTimeZonesAsync Method (GetServerTimeZonesType)

The GetServerTimeZonesAsync method provides asynchronous access to the GetServerTimeZones Web service method.

public void GetServerTimeZonesAsync(
GetServerTimeZonesType GetServerTimeZones1
);

Parameters

GetServerTimeZones1
The GetServerTimeZones request.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.GetServerTimeZonesAsync Overload List


ExchangeServiceBinding.GetServerTimeZonesAsync Method (GetServerTimeZonesType, Object)

The GetServerTimeZonesAsync method provides asynchronous access to the GetServerTimeZones Web service method.

public void GetServerTimeZonesAsync(
GetServerTimeZonesType GetServerTimeZones1,
object userState
);

Parameters

GetServerTimeZones1
The GetServerTimeZones request.
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.GetServerTimeZonesAsync Overload List


ExchangeServiceBinding.GetServiceConfiguration Method

The GetServiceConfiguration operation gets configuration information for the specified type of service.

public GetServiceConfigurationResponseMessageType GetServiceConfiguration(
GetServiceConfigurationType GetServiceConfiguration1
);

Parameters

GetServiceConfiguration1
An instance of the GetServiceConfigurationType class

Return Value

Returns configuration settings for the Unified Messaging, Protection Rules, and Mail Tips services.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


GetServiceConfigurationAsync Method

Aspose.Email

ExchangeServiceBinding.GetServiceConfigurationAsync Method

The GetServiceConfigurationAsync operation gets configuration information for the specified type of service.

Overload List

The GetServiceConfigurationAsync operation gets configuration information for the specified type of service.

public void GetServiceConfigurationAsync(GetServiceConfigurationType);

The GetServiceConfigurationAsync operation gets configuration information for the specified type of service.

public void GetServiceConfigurationAsync(GetServiceConfigurationType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.GetServiceConfigurationAsync Method (GetServiceConfigurationType)

The GetServiceConfigurationAsync operation gets configuration information for the specified type of service.

public void GetServiceConfigurationAsync(
GetServiceConfigurationType GetServiceConfiguration1
);

Parameters

GetServiceConfiguration1
An instance of the GetServiceConfigurationType class

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.GetServiceConfigurationAsync Overload List


ExchangeServiceBinding.GetServiceConfigurationAsync Method (GetServiceConfigurationType, Object)

The GetServiceConfigurationAsync operation gets configuration information for the specified type of service.

public void GetServiceConfigurationAsync(
GetServiceConfigurationType GetServiceConfiguration1,
object userState
);

Parameters

GetServiceConfiguration1
An instance of the GetServiceConfigurationType class
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.GetServiceConfigurationAsync Overload List


ExchangeServiceBinding.GetSharingFolder Method

The GetSharingFolder operation gets the local folder identifier of a specified shared folder.

public GetSharingFolderResponseMessageType GetSharingFolder(
GetSharingFolderType GetSharingFolder1
);

Parameters

GetSharingFolder1
An instance of the GetSharingFolderType class

Return Value

Returns local folder identifier of a specified shared folder.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


GetSharingFolderAsync Method

Aspose.Email

ExchangeServiceBinding.GetSharingFolderAsync Method

The GetSharingFolderAsync operation gets the local folder identifier of a specified shared folder asynchronously.

Overload List

The GetSharingFolderAsync operation gets the local folder identifier of a specified shared folder asynchronously.

public void GetSharingFolderAsync(GetSharingFolderType);

The GetSharingFolderAsync operation gets the local folder identifier of a specified shared folder asynchronously.

public void GetSharingFolderAsync(GetSharingFolderType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.GetSharingFolderAsync Method (GetSharingFolderType)

The GetSharingFolderAsync operation gets the local folder identifier of a specified shared folder asynchronously.

public void GetSharingFolderAsync(
GetSharingFolderType GetSharingFolder1
);

Parameters

GetSharingFolder1
An instance of the GetSharingFolderType class

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.GetSharingFolderAsync Overload List


ExchangeServiceBinding.GetSharingFolderAsync Method (GetSharingFolderType, Object)

The GetSharingFolderAsync operation gets the local folder identifier of a specified shared folder asynchronously.

public void GetSharingFolderAsync(
GetSharingFolderType GetSharingFolder1,
object userState
);

Parameters

GetSharingFolder1
An instance of the GetSharingFolderType class
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.GetSharingFolderAsync Overload List


ExchangeServiceBinding.GetSharingMetadata Method

The GetSharingMetadata method gets an opaque authentication token that identifies a sharing invitation.

public GetSharingMetadataResponseMessageType GetSharingMetadata(
GetSharingMetadataType GetSharingMetadata1
);

Parameters

GetSharingMetadata1
An instance of the GetSharingMetadataType class

Return Value

Returns opaque authentication token that identifies a sharing invitation

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


GetSharingMetadataAsync Method

Aspose.Email

ExchangeServiceBinding.GetSharingMetadataAsync Method

The GetSharingMetadataAsync method gets an opaque authentication token that identifies a sharing invitation asynchronously.

Overload List

The GetSharingMetadataAsync method gets an opaque authentication token that identifies a sharing invitation asynchronously.

public void GetSharingMetadataAsync(GetSharingMetadataType);

The GetSharingMetadataAsync method gets an opaque authentication token that identifies a sharing invitation asynchronously.

public void GetSharingMetadataAsync(GetSharingMetadataType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.GetSharingMetadataAsync Method (GetSharingMetadataType)

The GetSharingMetadataAsync method gets an opaque authentication token that identifies a sharing invitation asynchronously.

public void GetSharingMetadataAsync(
GetSharingMetadataType GetSharingMetadata1
);

Parameters

GetSharingMetadata1
An instance of the GetSharingMetadataType class

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.GetSharingMetadataAsync Overload List


ExchangeServiceBinding.GetSharingMetadataAsync Method (GetSharingMetadataType, Object)

The GetSharingMetadataAsync method gets an opaque authentication token that identifies a sharing invitation asynchronously.

public void GetSharingMetadataAsync(
GetSharingMetadataType GetSharingMetadata1,
object userState
);

Parameters

GetSharingMetadata1
An instance of the GetSharingMetadataType class
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.GetSharingMetadataAsync Overload List


ExchangeServiceBinding.GetStreamingEvents Method

The GetStreamingEvents method sends the request to and gets the response from a GetStreamingEvents operation.

public GetStreamingEventsResponseType GetStreamingEvents(
GetStreamingEventsType GetStreamingEvents1
);

Parameters

GetStreamingEvents1
An instance of the GetStreamingEventsType class.

Return Value

The GetStreamingEvents method returns a GetStreamingEventsResponseType object that contains the status of the GetStreamingEvents operation.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


GetStreamingEventsAsync Method

Aspose.Email

ExchangeServiceBinding.GetStreamingEventsAsync Method

The GetStreamingEventsAsync method provides asynchronous access to the GetStreamingEvents Web service method.

Overload List

The GetStreamingEventsAsync method provides asynchronous access to the GetStreamingEvents Web service method.

public void GetStreamingEventsAsync(GetStreamingEventsType);

The GetStreamingEventsAsync method provides asynchronous access to the GetStreamingEvents Web service method.

public void GetStreamingEventsAsync(GetStreamingEventsType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.GetStreamingEventsAsync Method (GetStreamingEventsType)

The GetStreamingEventsAsync method provides asynchronous access to the GetStreamingEvents Web service method.

public void GetStreamingEventsAsync(
GetStreamingEventsType GetStreamingEvents1
);

Parameters

GetStreamingEvents1
An instance of the GetStreamingEventsType class.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.GetStreamingEventsAsync Overload List


ExchangeServiceBinding.GetStreamingEventsAsync Method (GetStreamingEventsType, Object)

The GetStreamingEventsAsync method provides asynchronous access to the GetStreamingEvents Web service method.

public void GetStreamingEventsAsync(
GetStreamingEventsType GetStreamingEvents1,
object userState
);

Parameters

GetStreamingEvents1
An instance of the GetStreamingEventsType class.
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.GetStreamingEventsAsync Overload List


ExchangeServiceBinding.GetUserAvailability Method

The GetUserAvailability method sends the request to and gets the response from a GetUserAvailability operation.

public GetUserAvailabilityResponseType GetUserAvailability(
GetUserAvailabilityRequestType GetUserAvailabilityRequest
);

Parameters

GetUserAvailabilityRequest
An instance of the GetUserAvailabilityRequestType class that represents the GetUserAvailability query.

Return Value

The GetUserAvailability method returns a GetUserAvailabilityResponseType object that contains the status of the GetUserAvailability operation and the availability information for requested users.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


GetUserAvailabilityAsync Method

Aspose.Email

ExchangeServiceBinding.GetUserAvailabilityAsync Method

The GetUserAvailabilityAsync method provides asynchronous access to the GetUserAvailability Web service method.

Overload List

The GetUserAvailabilityAsync method provides asynchronous access to the GetUserAvailability Web service method.

public void GetUserAvailabilityAsync(GetUserAvailabilityRequestType);

The GetUserAvailabilityAsync method provides asynchronous access to the GetUserAvailability Web service method.

public void GetUserAvailabilityAsync(GetUserAvailabilityRequestType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.GetUserAvailabilityAsync Method (GetUserAvailabilityRequestType)

The GetUserAvailabilityAsync method provides asynchronous access to the GetUserAvailability Web service method.

public void GetUserAvailabilityAsync(
GetUserAvailabilityRequestType GetUserAvailabilityRequest
);

Parameters

GetUserAvailabilityRequest
An instance of the GetUserAvailabilityRequestType class that represents the GetUserAvailability query.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.GetUserAvailabilityAsync Overload List


ExchangeServiceBinding.GetUserAvailabilityAsync Method (GetUserAvailabilityRequestType, Object)

The GetUserAvailabilityAsync method provides asynchronous access to the GetUserAvailability Web service method.

public void GetUserAvailabilityAsync(
GetUserAvailabilityRequestType GetUserAvailabilityRequest,
object userState
);

Parameters

GetUserAvailabilityRequest
An instance of the GetUserAvailabilityRequestType class that represents the GetUserAvailability query.
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.GetUserAvailabilityAsync Overload List


ExchangeServiceBinding.GetUserConfiguration Method

The GetUserConfiguration method sends the request to and gets the response from an GetUserConfiguration operation.

public GetUserConfigurationResponseType GetUserConfiguration(
GetUserConfigurationType GetUserConfiguration1
);

Parameters

GetUserConfiguration1
An instance of the GetUserConfigurationType class that represents the request to get user configuration.

Return Value

The GetUserConfiguration method returns a GetUserConfigurationResponseType object.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


GetUserConfigurationAsync Method

Aspose.Email

ExchangeServiceBinding.GetUserConfigurationAsync Method

The GetUserConfigurationAsync method provides asynchronous access to the GetUserConfiguration operation.

Overload List

The GetUserConfigurationAsync method provides asynchronous access to the GetUserConfiguration operation.

public void GetUserConfigurationAsync(GetUserConfigurationType);

The GetUserConfigurationAsync method provides asynchronous access to the GetUserConfiguration operation.

public void GetUserConfigurationAsync(GetUserConfigurationType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.GetUserConfigurationAsync Method (GetUserConfigurationType)

The GetUserConfigurationAsync method provides asynchronous access to the GetUserConfiguration operation.

public void GetUserConfigurationAsync(
GetUserConfigurationType GetUserConfiguration1
);

Parameters

GetUserConfiguration1
An instance of the GetUserConfigurationType class that represents the request to get user configuration.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.GetUserConfigurationAsync Overload List


ExchangeServiceBinding.GetUserConfigurationAsync Method (GetUserConfigurationType, Object)

The GetUserConfigurationAsync method provides asynchronous access to the GetUserConfiguration operation.

public void GetUserConfigurationAsync(
GetUserConfigurationType GetUserConfiguration1,
object userState
);

Parameters

GetUserConfiguration1
An instance of the GetUserConfigurationType class that represents the request to get user configuration.
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.GetUserConfigurationAsync Overload List


ExchangeServiceBinding.GetUserOofSettings Method

The GetUserOofSettings method sends the request to and gets the response from a GetUserOofSettings operation.

public GetUserOofSettingsResponse GetUserOofSettings(
GetUserOofSettingsRequest GetUserOofSettingsRequest
);

Parameters

GetUserOofSettingsRequest
An instance of the GetUserOofSettingsRequest class that represents the query for a user's OOF status.

Return Value

The GetUserOofSettings method returns a GetUserOofSettingsResponse object that contains the status of the GetUserOofSettingsRequest and the user's OOF settings.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


GetUserOofSettingsAsync Method

Aspose.Email

ExchangeServiceBinding.GetUserOofSettingsAsync Method

The GetUserOofSettingsAsync method provides asynchronous access to the GetUserOofSettings Web service method.

Overload List

The GetUserOofSettingsAsync method provides asynchronous access to the GetUserOofSettings Web service method.

public void GetUserOofSettingsAsync(GetUserOofSettingsRequest);

The GetUserOofSettingsAsync method provides asynchronous access to the GetUserOofSettings Web service method.

public void GetUserOofSettingsAsync(GetUserOofSettingsRequest,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.GetUserOofSettingsAsync Method (GetUserOofSettingsRequest)

The GetUserOofSettingsAsync method provides asynchronous access to the GetUserOofSettings Web service method.

public void GetUserOofSettingsAsync(
GetUserOofSettingsRequest GetUserOofSettingsRequest
);

Parameters

GetUserOofSettingsRequest
An instance of the GetUserOofSettingsRequest class that represents the query for a user's OOF status.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.GetUserOofSettingsAsync Overload List


ExchangeServiceBinding.GetUserOofSettingsAsync Method (GetUserOofSettingsRequest, Object)

The GetUserOofSettingsAsync method provides asynchronous access to the GetUserOofSettings Web service method.

public void GetUserOofSettingsAsync(
GetUserOofSettingsRequest GetUserOofSettingsRequest,
object userState
);

Parameters

GetUserOofSettingsRequest
An instance of the GetUserOofSettingsRequest class that represents the query for a user's OOF status.
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.GetUserOofSettingsAsync Overload List


ExchangeServiceBinding.MoveFolder Method

The MoveFolder method sends the request to and gets the response from a MoveFolder operation.

public MoveFolderResponseType MoveFolder(
MoveFolderType MoveFolder1
);

Parameters

MoveFolder1
An instance of the MoveFolderType class that represents the set of folders to move.

Return Value

The MoveFolder method returns a MoveFolderResponseType object that contains the status of the MoveFolder operation and the new identifiers of the moved folders.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


MoveFolderAsync Method

Aspose.Email

ExchangeServiceBinding.MoveFolderAsync Method

The MoveFolderAsync method provides asynchronous access to the MoveFolder Web service method.

Overload List

The MoveFolderAsync method provides asynchronous access to the MoveFolder Web service method.

public void MoveFolderAsync(MoveFolderType);

The MoveFolderAsync method provides asynchronous access to the MoveFolder Web service method.

public void MoveFolderAsync(MoveFolderType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.MoveFolderAsync Method (MoveFolderType)

The MoveFolderAsync method provides asynchronous access to the MoveFolder Web service method.

public void MoveFolderAsync(
MoveFolderType MoveFolder1
);

Parameters

MoveFolder1
An instance of the MoveFolderType class that represents the set of folders to move.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.MoveFolderAsync Overload List


ExchangeServiceBinding.MoveFolderAsync Method (MoveFolderType, Object)

The MoveFolderAsync method provides asynchronous access to the MoveFolder Web service method.

public void MoveFolderAsync(
MoveFolderType MoveFolder1,
object userState
);

Parameters

MoveFolder1
An instance of the MoveFolderType class that represents the set of folders to move.
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.MoveFolderAsync Overload List


ExchangeServiceBinding.MoveItem Method

The MoveItem method sends the request to and gets the response from a MoveItem operation.

public MoveItemResponseType MoveItem(
MoveItemType MoveItem1
);

Parameters

MoveItem1
An instance of the MoveItemType class that represents the set of items to move.

Return Value

The MoveItem method returns a MoveItemResponseType object that contains the status of the MoveItem operation and the new identifiers of the moved items.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


MoveItemAsync Method

Aspose.Email

ExchangeServiceBinding.MoveItemAsync Method

The MoveItemAsync method provides asynchronous access to the MoveItem Web service method.

Overload List

The MoveItemAsync method provides asynchronous access to the MoveItem Web service method.

public void MoveItemAsync(MoveItemType);

The MoveItemAsync method provides asynchronous access to the MoveItem Web service method.

public void MoveItemAsync(MoveItemType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.MoveItemAsync Method (MoveItemType)

The MoveItemAsync method provides asynchronous access to the MoveItem Web service method.

public void MoveItemAsync(
MoveItemType MoveItem1
);

Parameters

MoveItem1
An instance of the MoveItemType class that represents the set of items to move.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.MoveItemAsync Overload List


ExchangeServiceBinding.MoveItemAsync Method (MoveItemType, Object)

The MoveItemAsync method provides asynchronous access to the MoveItem Web service method.

public void MoveItemAsync(
MoveItemType MoveItem1,
object userState
);

Parameters

MoveItem1
An instance of the MoveItemType class that represents the set of items to move.
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.MoveItemAsync Overload List


ExchangeServiceBinding.PlayOnPhone Method

The PlayOnPhone method initiates an outbound call and plays a message over the telephone.

public PlayOnPhoneResponseMessageType PlayOnPhone(
PlayOnPhoneType PlayOnPhone1
);

Parameters

PlayOnPhone1
An instance of the PlayOnPhoneType class

Return Value

Returns responce with code of operation and call id

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


PlayOnPhoneAsync Method

Aspose.Email

ExchangeServiceBinding.PlayOnPhoneAsync Method

The PlayOnPhoneAsync method initiates an outbound call and plays a message over the telephone asynchronously.

Overload List

The PlayOnPhoneAsync method initiates an outbound call and plays a message over the telephone asynchronously.

public void PlayOnPhoneAsync(PlayOnPhoneType);

The PlayOnPhoneAsync method initiates an outbound call and plays a message over the telephone asynchronously.

public void PlayOnPhoneAsync(PlayOnPhoneType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.PlayOnPhoneAsync Method (PlayOnPhoneType)

The PlayOnPhoneAsync method initiates an outbound call and plays a message over the telephone asynchronously.

public void PlayOnPhoneAsync(
PlayOnPhoneType PlayOnPhone1
);

Parameters

PlayOnPhone1
An instance of the PlayOnPhoneType class

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.PlayOnPhoneAsync Overload List


ExchangeServiceBinding.PlayOnPhoneAsync Method (PlayOnPhoneType, Object)

The PlayOnPhoneAsync method initiates an outbound call and plays a message over the telephone asynchronously.

public void PlayOnPhoneAsync(
PlayOnPhoneType PlayOnPhone1,
object userState
);

Parameters

PlayOnPhone1
An instance of the PlayOnPhoneType class
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.PlayOnPhoneAsync Overload List


ExchangeServiceBinding.RefreshSharingFolder Method

The RefreshSharingFolder method refreshes the specified local folder with the latest data from the folder that is being shared.

public RefreshSharingFolderResponseMessageType RefreshSharingFolder(
RefreshSharingFolderType RefreshSharingFolder1
);

Parameters

RefreshSharingFolder1
An instance of the RefreshSharingFolderType class

Return Value

Returns operation status

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


RefreshSharingFolderAsync Method

Aspose.Email

ExchangeServiceBinding.RefreshSharingFolderAsync Method

The RefreshSharingFolderAsync method refreshes the specified local folder with the latest data from the folder that is being shared asynchronously.

Overload List

The RefreshSharingFolderAsync method refreshes the specified local folder with the latest data from the folder that is being shared asynchronously.

public void RefreshSharingFolderAsync(RefreshSharingFolderType);

The RefreshSharingFolderAsync method refreshes the specified local folder with the latest data from the folder that is being shared asynchronously.

public void RefreshSharingFolderAsync(RefreshSharingFolderType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.RefreshSharingFolderAsync Method (RefreshSharingFolderType)

The RefreshSharingFolderAsync method refreshes the specified local folder with the latest data from the folder that is being shared asynchronously.

public void RefreshSharingFolderAsync(
RefreshSharingFolderType RefreshSharingFolder1
);

Parameters

RefreshSharingFolder1
An instance of the RefreshSharingFolderType class

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.RefreshSharingFolderAsync Overload List


ExchangeServiceBinding.RefreshSharingFolderAsync Method (RefreshSharingFolderType, Object)

The RefreshSharingFolderAsync method refreshes the specified local folder with the latest data from the folder that is being shared asynchronously.

public void RefreshSharingFolderAsync(
RefreshSharingFolderType RefreshSharingFolder1,
object userState
);

Parameters

RefreshSharingFolder1
An instance of the RefreshSharingFolderType class
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.RefreshSharingFolderAsync Overload List


ExchangeServiceBinding.RemoveDelegate Method

The RemoveDelegate method sends the request to and gets the response from a RemoveDelegate operation.

public RemoveDelegateResponseMessageType RemoveDelegate(
RemoveDelegateType RemoveDelegate1
);

Parameters

RemoveDelegate1
An instance of the RemoveDelegateType class that represents the request to remove a delegate.

Return Value

The RemoveDelegate method returns a RemoveDelegateResponseMessageType object.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


RemoveDelegateAsync Method

Aspose.Email

ExchangeServiceBinding.RemoveDelegateAsync Method

The RemoveDelegateAsync method provides asynchronous access to the RemoveDelegate operation.

Overload List

The RemoveDelegateAsync method provides asynchronous access to the RemoveDelegate operation.

public void RemoveDelegateAsync(RemoveDelegateType);

The RemoveDelegateAsync method provides asynchronous access to the RemoveDelegate operation.

public void RemoveDelegateAsync(RemoveDelegateType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.RemoveDelegateAsync Method (RemoveDelegateType)

The RemoveDelegateAsync method provides asynchronous access to the RemoveDelegate operation.

public void RemoveDelegateAsync(
RemoveDelegateType RemoveDelegate1
);

Parameters

RemoveDelegate1
An instance of the RemoveDelegateType class that represents the request to remove a delegate.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.RemoveDelegateAsync Overload List


ExchangeServiceBinding.RemoveDelegateAsync Method (RemoveDelegateType, Object)

The RemoveDelegateAsync method provides asynchronous access to the RemoveDelegate operation.

public void RemoveDelegateAsync(
RemoveDelegateType RemoveDelegate1,
object userState
);

Parameters

RemoveDelegate1
An instance of the RemoveDelegateType class that represents the request to remove a delegate.
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.RemoveDelegateAsync Overload List


ExchangeServiceBinding.ResolveNames Method

The ResolveNames method sends the request to and returns the response from a MoveFolder operation.

public ResolveNamesResponseType ResolveNames(
ResolveNamesType ResolveNames1
);

Parameters

ResolveNames1
An instance of the ResolveNamesType class that represents the set of ambiguous names to resolve.

Return Value

The ResolveNames method returns a ResolveNamesResponseType object that contains the status of the ResolveNames operation and the results of the resolution attempts.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ResolveNamesAsync Method

Aspose.Email

ExchangeServiceBinding.ResolveNamesAsync Method

The ResolveNamesAsync methods provide an event-based method for handling asynchronous ResolveNames calls.

Overload List

The ResolveNamesAsync methods provide an event-based method for handling asynchronous ResolveNames calls.

public void ResolveNamesAsync(ResolveNamesType);

The ResolveNamesAsync methods provide an event-based method for handling asynchronous ResolveNames calls.

public void ResolveNamesAsync(ResolveNamesType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.ResolveNamesAsync Method (ResolveNamesType)

The ResolveNamesAsync methods provide an event-based method for handling asynchronous ResolveNames calls.

public void ResolveNamesAsync(
ResolveNamesType ResolveNames1
);

Parameters

ResolveNames1
The ResolveNames request.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.ResolveNamesAsync Overload List


ExchangeServiceBinding.ResolveNamesAsync Method (ResolveNamesType, Object)

The ResolveNamesAsync methods provide an event-based method for handling asynchronous ResolveNames calls.

public void ResolveNamesAsync(
ResolveNamesType ResolveNames1,
object userState
);

Parameters

ResolveNames1
The ResolveNames request.
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.ResolveNamesAsync Overload List


ExchangeServiceBinding.SendItem Method

The SendItem method sends the request to and returns the response from a SendItem operation.

public SendItemResponseType SendItem(
SendItemType SendItem1
);

Parameters

SendItem1
An instance of the SendItemType class that represents the set of items to send.

Return Value

The SendItem method returns a SendItemResponseType object that contains the status of the SendItem operation.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


SendItemAsync Method

Aspose.Email

ExchangeServiceBinding.SendItemAsync Method

The SendItemAsync method provides asynchronous access to the SendItem Web service method.

Overload List

The SendItemAsync method provides asynchronous access to the SendItem Web service method.

public void SendItemAsync(SendItemType);

The SendItemAsync method provides asynchronous access to the SendItem Web service method.

public void SendItemAsync(SendItemType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.SendItemAsync Method (SendItemType)

The SendItemAsync method provides asynchronous access to the SendItem Web service method.

public void SendItemAsync(
SendItemType SendItem1
);

Parameters

SendItem1
An instance of the SendItemType class that represents the set of items to send.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.SendItemAsync Overload List


ExchangeServiceBinding.SendItemAsync Method (SendItemType, Object)

The SendItemAsync method provides asynchronous access to the SendItem Web service method.

public void SendItemAsync(
SendItemType SendItem1,
object userState
);

Parameters

SendItem1
An instance of the SendItemType class that represents the set of items to send.
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.SendItemAsync Overload List


ExchangeServiceBinding.SetUserOofSettings Method

The SetUserOofSettings method sends the request to and returns the response from a SetUserOofSettings operation.

public SetUserOofSettingsResponse SetUserOofSettings(
SetUserOofSettingsRequest SetUserOofSettingsRequest
);

Parameters

SetUserOofSettingsRequest
An instance of the SetUserOofSettingsRequest class that represents the Out of Office (OOF) setting to set.

Return Value

The SetUserOofSettings method returns a SetUserOofSettingsResponse object that contains the status of the SetUserOofSettings operation.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


SetUserOofSettingsAsync Method

Aspose.Email

ExchangeServiceBinding.SetUserOofSettingsAsync Method

The SetUserOofSettingsAsync method provides asynchronous access to the SetUserOofSettings Web service method.

Overload List

The SetUserOofSettingsAsync method provides asynchronous access to the SetUserOofSettings Web service method.

public void SetUserOofSettingsAsync(SetUserOofSettingsRequest);

The SetUserOofSettingsAsync method provides asynchronous access to the SetUserOofSettings Web service method.

public void SetUserOofSettingsAsync(SetUserOofSettingsRequest,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.SetUserOofSettingsAsync Method (SetUserOofSettingsRequest)

The SetUserOofSettingsAsync method provides asynchronous access to the SetUserOofSettings Web service method.

public void SetUserOofSettingsAsync(
SetUserOofSettingsRequest SetUserOofSettingsRequest
);

Parameters

SetUserOofSettingsRequest
An instance of the SetUserOofSettingsRequest class that represents the Out of Office (OOF) setting to set.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.SetUserOofSettingsAsync Overload List


ExchangeServiceBinding.SetUserOofSettingsAsync Method (SetUserOofSettingsRequest, Object)

The SetUserOofSettingsAsync method provides asynchronous access to the SetUserOofSettings Web service method.

public void SetUserOofSettingsAsync(
SetUserOofSettingsRequest SetUserOofSettingsRequest,
object userState
);

Parameters

SetUserOofSettingsRequest
An instance of the SetUserOofSettingsRequest class that represents the Out of Office (OOF) setting to set.
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.SetUserOofSettingsAsync Overload List


ExchangeServiceBinding.Subscribe Method

The Subscribe method sends the request to and returns the response from a Subscribe operation.

public SubscribeResponseType Subscribe(
SubscribeType Subscribe1
);

Parameters

Subscribe1
An instance of the SubscribeType class that represents the folders and events to monitor.

Return Value

The Subscribe method returns a SubscribeResponseType object that contains the status of the Subscribe operation, the subscription identifier, and the latest watermark for the subscription.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


SubscribeAsync Method

Aspose.Email

ExchangeServiceBinding.SubscribeAsync Method

The SubscribeAsync method provides asynchronous access to the Subscribe Web service method.

Overload List

The SubscribeAsync method provides asynchronous access to the Subscribe Web service method.

public void SubscribeAsync(SubscribeType);

The SubscribeAsync method provides asynchronous access to the Subscribe Web service method.

public void SubscribeAsync(SubscribeType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.SubscribeAsync Method (SubscribeType)

The SubscribeAsync method provides asynchronous access to the Subscribe Web service method.

public void SubscribeAsync(
SubscribeType Subscribe1
);

Parameters

Subscribe1
An instance of the SubscribeType class that represents the folders and events to monitor.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.SubscribeAsync Overload List


ExchangeServiceBinding.SubscribeAsync Method (SubscribeType, Object)

The SubscribeAsync method provides asynchronous access to the Subscribe Web service method.

public void SubscribeAsync(
SubscribeType Subscribe1,
object userState
);

Parameters

Subscribe1
An instance of the SubscribeType class that represents the folders and events to monitor.
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.SubscribeAsync Overload List


ExchangeServiceBinding.SyncFolderHierarchy Method

The SyncFolderHierarchy method sends the request to and returns the response from a SyncFolderHierarchy operation.

public SyncFolderHierarchyResponseType SyncFolderHierarchy(
SyncFolderHierarchyType SyncFolderHierarchy1
);

Parameters

SyncFolderHierarchy1
An instance of the SyncFolderHierarchyType class that represents the type of information to synchronize for a folder hierarchy.

Return Value

The SyncFolderHierarchy method returns a SyncFolderHierarchyResponseType object that contains the set of changes to a folder hierarchy.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


SyncFolderHierarchyAsync Method

Aspose.Email

ExchangeServiceBinding.SyncFolderHierarchyAsync Method

The SyncFolderHierarchyAsync method provides asynchronous access to the SyncFolderHierarchy Web service method.

Overload List

The SyncFolderHierarchyAsync method provides asynchronous access to the SyncFolderHierarchy Web service method.

public void SyncFolderHierarchyAsync(SyncFolderHierarchyType);

The SyncFolderHierarchyAsync method provides asynchronous access to the SyncFolderHierarchy Web service method.

public void SyncFolderHierarchyAsync(SyncFolderHierarchyType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.SyncFolderHierarchyAsync Method (SyncFolderHierarchyType)

The SyncFolderHierarchyAsync method provides asynchronous access to the SyncFolderHierarchy Web service method.

public void SyncFolderHierarchyAsync(
SyncFolderHierarchyType SyncFolderHierarchy1
);

Parameters

SyncFolderHierarchy1
An instance of the SyncFolderHierarchyType class that represents the type of information to synchronize for a folder hierarchy.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.SyncFolderHierarchyAsync Overload List


ExchangeServiceBinding.SyncFolderHierarchyAsync Method (SyncFolderHierarchyType, Object)

The SyncFolderHierarchyAsync method provides asynchronous access to the SyncFolderHierarchy Web service method.

public void SyncFolderHierarchyAsync(
SyncFolderHierarchyType SyncFolderHierarchy1,
object userState
);

Parameters

SyncFolderHierarchy1
An instance of the SyncFolderHierarchyType class that represents the type of information to synchronize for a folder hierarchy.
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.SyncFolderHierarchyAsync Overload List


ExchangeServiceBinding.SyncFolderItems Method

The SyncFolderItems method sends the request to and returns the response from a SyncFolderItems operation.

public SyncFolderItemsResponseType SyncFolderItems(
SyncFolderItemsType SyncFolderItems1
);

Parameters

SyncFolderItems1
An instance of the SyncFolderItemsType class that represents the type of information to synchronize for a set of items in a folder.

Return Value

The SyncFolderItems method returns a SyncFolderItemsResponseType object that contains the set of changes that were made to items.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


SyncFolderItemsAsync Method

Aspose.Email

ExchangeServiceBinding.SyncFolderItemsAsync Method

The SyncFolderItemsAsync method provides asynchronous access to the SyncFolderItems Web service method.

Overload List

The SyncFolderItemsAsync method provides asynchronous access to the SyncFolderItems Web service method.

public void SyncFolderItemsAsync(SyncFolderItemsType);

The SyncFolderItemsAsync method provides asynchronous access to the SyncFolderItems Web service method.

public void SyncFolderItemsAsync(SyncFolderItemsType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.SyncFolderItemsAsync Method (SyncFolderItemsType)

The SyncFolderItemsAsync method provides asynchronous access to the SyncFolderItems Web service method.

public void SyncFolderItemsAsync(
SyncFolderItemsType SyncFolderItems1
);

Parameters

SyncFolderItems1
An instance of the SyncFolderItemsType class that represents the type of information to synchronize for a set of items in a folder.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.SyncFolderItemsAsync Overload List


ExchangeServiceBinding.SyncFolderItemsAsync Method (SyncFolderItemsType, Object)

The SyncFolderItemsAsync method provides asynchronous access to the SyncFolderItems Web service method.

public void SyncFolderItemsAsync(
SyncFolderItemsType SyncFolderItems1,
object userState
);

Parameters

SyncFolderItems1
An instance of the SyncFolderItemsType class that represents the type of information to synchronize for a set of items in a folder.
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.SyncFolderItemsAsync Overload List


ExchangeServiceBinding.Unsubscribe Method

The Unsubscribe method sends the request to and returns the response from an Unsubscribe operation.

public UnsubscribeResponseType Unsubscribe(
UnsubscribeType Unsubscribe1
);

Parameters

Unsubscribe1
An instance of the UnsubscribeType class that represents the subscription to cancel.

Return Value

The Unsubscribe method returns an UnsubscribeResponseType object that contains the result of the Unsubscribe operation.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


UnsubscribeAsync Method

Aspose.Email

ExchangeServiceBinding.UnsubscribeAsync Method

The UnsubscribeAsync method provides asynchronous access to the Unsubscribe Web service method.

Overload List

The UnsubscribeAsync method provides asynchronous access to the Unsubscribe Web service method.

public void UnsubscribeAsync(UnsubscribeType);

The UnsubscribeAsync method provides asynchronous access to the Unsubscribe Web service method.

public void UnsubscribeAsync(UnsubscribeType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.UnsubscribeAsync Method (UnsubscribeType)

The UnsubscribeAsync method provides asynchronous access to the Unsubscribe Web service method.

public void UnsubscribeAsync(
UnsubscribeType Unsubscribe1
);

Parameters

Unsubscribe1
An instance of the UnsubscribeType class that represents the subscription to cancel.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.UnsubscribeAsync Overload List


ExchangeServiceBinding.UnsubscribeAsync Method (UnsubscribeType, Object)

The UnsubscribeAsync method provides asynchronous access to the Unsubscribe Web service method.

public void UnsubscribeAsync(
UnsubscribeType Unsubscribe1,
object userState
);

Parameters

Unsubscribe1
An instance of the UnsubscribeType class that represents the subscription to cancel.
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.UnsubscribeAsync Overload List


ExchangeServiceBinding.UpdateDelegate Method

The UpdateDelegate method sends the request to and gets the response from an UpdateDelegate operation.

public UpdateDelegateResponseMessageType UpdateDelegate(
UpdateDelegateType UpdateDelegate1
);

Parameters

UpdateDelegate1
An instance of the UpdateDelegateType class that represents the request to update a delegate.

Return Value

The UpdateDelegate method returns a UpdateDelegateResponseMessageType object.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


UpdateDelegateAsync Method

Aspose.Email

ExchangeServiceBinding.UpdateDelegateAsync Method

The UpdateDelegateAsync method provides asynchronous access to the UpdateDelegateType operation.

Overload List

The UpdateDelegateAsync method provides asynchronous access to the UpdateDelegateType operation.

public void UpdateDelegateAsync(UpdateDelegateType);

The UpdateDelegateAsync method provides asynchronous access to the UpdateDelegateType operation.

public void UpdateDelegateAsync(UpdateDelegateType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.UpdateDelegateAsync Method (UpdateDelegateType)

The UpdateDelegateAsync method provides asynchronous access to the UpdateDelegateType operation.

public void UpdateDelegateAsync(
UpdateDelegateType UpdateDelegate1
);

Parameters

UpdateDelegate1
An instance of the UpdateDelegateType class that represents the request to update a delegate.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.UpdateDelegateAsync Overload List


ExchangeServiceBinding.UpdateDelegateAsync Method (UpdateDelegateType, Object)

The UpdateDelegateAsync method provides asynchronous access to the UpdateDelegateType operation.

public void UpdateDelegateAsync(
UpdateDelegateType UpdateDelegate1,
object userState
);

Parameters

UpdateDelegate1
An instance of the UpdateDelegateType class that represents the request to update a delegate.
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.UpdateDelegateAsync Overload List


ExchangeServiceBinding.UpdateFolder Method

The UpdateFolder method sends the request to and returns the response from an UpdateFolder operation.

public UpdateFolderResponseType UpdateFolder(
UpdateFolderType UpdateFolder1
);

Parameters

UpdateFolder1
An instance of the UpdateFolderType class that represents the updates to be performed on a set of folders.

Return Value

The UpdateFolder method returns an UpdateFolderResponseType object that contains the updated folder identifiers.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


UpdateFolderAsync Method

Aspose.Email

ExchangeServiceBinding.UpdateFolderAsync Method

The UpdateFolderAsync method provides asynchronous access to the UpdateFolder Web service method.

Overload List

The UpdateFolderAsync method provides asynchronous access to the UpdateFolder Web service method.

public void UpdateFolderAsync(UpdateFolderType);

The UpdateFolderAsync method provides asynchronous access to the UpdateFolder Web service method.

public void UpdateFolderAsync(UpdateFolderType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.UpdateFolderAsync Method (UpdateFolderType)

The UpdateFolderAsync method provides asynchronous access to the UpdateFolder Web service method.

public void UpdateFolderAsync(
UpdateFolderType UpdateFolder1
);

Parameters

UpdateFolder1
An instance of the UpdateFolderType class that represents the updates to be performed on a set of folders.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.UpdateFolderAsync Overload List


ExchangeServiceBinding.UpdateFolderAsync Method (UpdateFolderType, Object)

The UpdateFolderAsync method provides asynchronous access to the UpdateFolder Web service method.

public void UpdateFolderAsync(
UpdateFolderType UpdateFolder1,
object userState
);

Parameters

UpdateFolder1
An instance of the UpdateFolderType class that represents the updates to be performed on a set of folders.
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.UpdateFolderAsync Overload List


ExchangeServiceBinding.UpdateInboxRules Method

Invokes UpdateInboxRules operation for the specified inbox rule

public UpdateInboxRulesResponseType UpdateInboxRules(
UpdateInboxRulesRequestType UpdateInboxRules1
);

Parameters

UpdateInboxRules1
A UpdateInboxRulesRequestType request

Return Value

A received UpdateInboxRulesResponseType response

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


UpdateInboxRulesAsync Method

Aspose.Email

ExchangeServiceBinding.UpdateInboxRulesAsync Method

Invokes UpdateInboxRules operation for the specified inbox rule asynchronously

Overload List

Invokes UpdateInboxRules operation for the specified inbox rule asynchronously

public void UpdateInboxRulesAsync(UpdateInboxRulesRequestType);

Invokes UpdateInboxRules operation for the specified inbox rule asynchronously

public void UpdateInboxRulesAsync(UpdateInboxRulesRequestType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.UpdateInboxRulesAsync Method (UpdateInboxRulesRequestType)

Invokes UpdateInboxRules operation for the specified inbox rule asynchronously

public void UpdateInboxRulesAsync(
UpdateInboxRulesRequestType UpdateInboxRules1
);

Parameters

UpdateInboxRules1
A UpdateInboxRulesRequestType request

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.UpdateInboxRulesAsync Overload List


ExchangeServiceBinding.UpdateInboxRulesAsync Method (UpdateInboxRulesRequestType, Object)

Invokes UpdateInboxRules operation for the specified inbox rule asynchronously

public void UpdateInboxRulesAsync(
UpdateInboxRulesRequestType UpdateInboxRules1,
object userState
);

Parameters

UpdateInboxRules1
A UpdateInboxRulesRequestType request
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.UpdateInboxRulesAsync Overload List


ExchangeServiceBinding.UpdateItem Method

The UpdateItem method sends the request to and returns the response from an UpdateItem operation.

public UpdateItemResponseType UpdateItem(
UpdateItemType UpdateItem1
);

Parameters

UpdateItem1
An instance of the UpdateItemType class that represents the updates to be performed on a set of items.

Return Value

The UpdateItem method returns an UpdateItemResponseType object that contains the updated item identifiers.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


UpdateItemAsync Method

Aspose.Email

ExchangeServiceBinding.UpdateItemAsync Method

The UpdateItemAsync method provides asynchronous access to the UpdateItem Web service method.

Overload List

The UpdateItemAsync method provides asynchronous access to the UpdateItem Web service method.

public void UpdateItemAsync(UpdateItemType);

The UpdateItemAsync method provides asynchronous access to the UpdateItem Web service method.

public void UpdateItemAsync(UpdateItemType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.UpdateItemAsync Method (UpdateItemType)

The UpdateItemAsync method provides asynchronous access to the UpdateItem Web service method.

public void UpdateItemAsync(
UpdateItemType UpdateItem1
);

Parameters

UpdateItem1
An instance of the UpdateItemType class that represents the updates to be performed on a set of items.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.UpdateItemAsync Overload List


ExchangeServiceBinding.UpdateItemAsync Method (UpdateItemType, Object)

The UpdateItemAsync method provides asynchronous access to the UpdateItem Web service method.

public void UpdateItemAsync(
UpdateItemType UpdateItem1,
object userState
);

Parameters

UpdateItem1
An instance of the UpdateItemType class that represents the updates to be performed on a set of items.
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.UpdateItemAsync Overload List


ExchangeServiceBinding.UpdateUserConfiguration Method

The UpdateUserConfiguration method sends the request to and gets the response from an UpdateUserConfiguration operation.

public UpdateUserConfigurationResponseType UpdateUserConfiguration(
UpdateUserConfigurationType UpdateUserConfiguration1
);

Parameters

UpdateUserConfiguration1
An instance of the UpdateUserConfigurationType class that represents the request to update user configuration.

Return Value

The UpdateUserConfiguration method returns a UpdateUserConfigurationResponseType object.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


UpdateUserConfigurationAsync Method

Aspose.Email

ExchangeServiceBinding.UpdateUserConfigurationAsync Method

The UpdateUserConfigurationAsync method provides asynchronous access to the UpdateUserConfiguration operation.

Overload List

The UpdateUserConfigurationAsync method provides asynchronous access to the UpdateUserConfiguration operation.

public void UpdateUserConfigurationAsync(UpdateUserConfigurationType);

The UpdateUserConfigurationAsync method provides asynchronous access to the UpdateUserConfiguration operation.

public void UpdateUserConfigurationAsync(UpdateUserConfigurationType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.UpdateUserConfigurationAsync Method (UpdateUserConfigurationType)

The UpdateUserConfigurationAsync method provides asynchronous access to the UpdateUserConfiguration operation.

public void UpdateUserConfigurationAsync(
UpdateUserConfigurationType UpdateUserConfiguration1
);

Parameters

UpdateUserConfiguration1
An instance of the UpdateUserConfigurationType class that represents the request to update user configuration.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.UpdateUserConfigurationAsync Overload List


ExchangeServiceBinding.UpdateUserConfigurationAsync Method (UpdateUserConfigurationType, Object)

The UpdateUserConfigurationAsync method provides asynchronous access to the UpdateUserConfiguration operation.

public void UpdateUserConfigurationAsync(
UpdateUserConfigurationType UpdateUserConfiguration1,
object userState
);

Parameters

UpdateUserConfiguration1
An instance of the UpdateUserConfigurationType class that represents the request to update user configuration.
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.UpdateUserConfigurationAsync Overload List


ExchangeServiceBinding.UploadItems Method

Invokes UploadItems operation for the specified items

public UploadItemsResponseType UploadItems(
UploadItemsType UploadItems1
);

Parameters

UploadItems1
A UploadItemsType request

Return Value

A received UploadItemsResponseType response

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


UploadItemsAsync Method

Aspose.Email

ExchangeServiceBinding.UploadItemsAsync Method

Invokes UploadItems operation for the specified items asynchronously

Overload List

Invokes UploadItems operation for the specified items asynchronously

public void UploadItemsAsync(UploadItemsType);

Invokes UploadItems operation for the specified items asynchronously

public void UploadItemsAsync(UploadItemsType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.UploadItemsAsync Method (UploadItemsType)

Invokes UploadItems operation for the specified items asynchronously

public void UploadItemsAsync(
UploadItemsType UploadItems1
);

Parameters

UploadItems1
A UploadItemsType request

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.UploadItemsAsync Overload List


ExchangeServiceBinding.UploadItemsAsync Method (UploadItemsType, Object)

Invokes UploadItems operation for the specified items asynchronously

public void UploadItemsAsync(
UploadItemsType UploadItems1,
object userState
);

Parameters

UploadItems1
A UploadItemsType request
userState
User state object

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace | ExchangeServiceBinding.UploadItemsAsync Overload List


ExchangeServiceBinding Events

The events of the ExchangeServiceBinding class are listed below. For a complete list of ExchangeServiceBinding class members, see the ExchangeServiceBinding Members topic.

Public Instance Events

AddDelegateCompleted | Occurs when an asynchronous AddDelegate operation is complete.
ApplyConversationActionCompleted | Occurs when the apply conversation operation has been completed
ConvertIdCompleted | Occurs when an asynchronous ConvertId operation is complete.
CopyFolderCompleted | Occurs when an asynchronous CopyFolder operation is complete.
CopyItemCompleted | Occurs when an asynchronous CopyItem operation is complete.
CreateAttachmentCompleted | Occurs when an asynchronous CreateAttachment operation is complete.
CreateFolderCompleted | Occurs when an asynchronous CreateFolder operation is complete.
CreateItemCompleted | Occurs when an asynchronous CreateItem operation is complete.
CreateManagedFolderCompleted | Occurs when an asynchronous CreateManagedFolder operation is complete.
CreateUserConfigurationCompleted | Occurs when an asynchronous CreateUserConfiguration operation is complete.
DeleteAttachmentCompleted | Occurs when an asynchronous DeleteAttachment operation is complete.
DeleteFolderCompleted | Occurs when an asynchronous DeleteFolder operation is complete.
DeleteItemCompleted | Occurs when an asynchronous DeleteItem operation is complete.
DeleteUserConfigurationCompleted | Occurs when an asynchronous DeleteUserConfiguration operation is complete.
DisconnectPhoneCallCompleted | Occurs when an asynchronous DisconnectPhoneCall operation is complete.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
EmptyFolderCompleted | Occurs when the empty folder operation has been completed
ExpandDLCompleted | Occurs when an asynchronous ExpandDL operation is complete.
ExportItemsCompleted | Occurs when the export items operation has been completed
FindConversationCompleted | Occurs when the find conversation operation has been completed
FindFolderCompleted | Occurs when an asynchronous FindFolder operation is complete.
FindItemCompleted | Occurs when an asynchronous FindItem operation is complete.
FindMessageTrackingReportCompleted | Occurs when an asynchronous FindMessageTrackingReport operation is complete.
GetAttachmentCompleted | Occurs when an asynchronous GetAttachment operation is complete.
GetDelegateCompleted | Occurs when an asynchronous GetDelegate operation is complete.
GetEventsCompleted | Occurs when an asynchronous GetEvents operation is complete.
GetFolderCompleted | Occurs when an asynchronous GetFolder operation is complete.
GetInboxRulesCompleted | Occurs when the get inbox rules operation has been completed
GetItemCompleted | Occurs when an asynchronous GetItem operation is complete.
GetMailTipsCompleted | Occurs when an asynchronous GetMailTips operation is complete.
GetMessageTrackingReportCompleted | Occurs when an asynchronous GetMessageTrackingReport operation is complete.
GetPhoneCallInformationCompleted | Occurs when an asynchronous GetPhoneCallInformation operation is complete.
GetRoomListsCompleted | Occurs when an asynchronous GetRoomLists operation is complete.
GetRoomsCompleted | Occurs when an asynchronous GetRooms operation is complete.
GetServerTimeZonesCompleted | Occurs when an asynchronous GetServerTimeZones operation is complete.
GetServiceConfigurationCompleted | Occurs when an asynchronous GetServiceConfiguration operation is complete.
GetSharingFolderCompleted | Occurs when an asynchronous GetSharingFolder operation is complete.
GetSharingMetadataCompleted | Occurs when an asynchronous GetSharingMetadata operation is complete.
GetStreamingEventsCompleted | Occurs when an asynchronous GetStreamingEvents operation is complete.
GetUserAvailabilityCompleted | Occurs when an asynchronous GetUserAvailability operation is complete.
GetUserConfigurationCompleted | Occurs when an asynchronous GetUserConfiguration operation is complete.
GetUserOofSettingsCompleted | Occurs when an asynchronous GetUserOofSettings operation is complete.
MoveFolderCompleted | Occurs when an asynchronous MoveFolder operation is complete.
MoveItemCompleted | Occurs when an asynchronous MoveItem operation is complete.
PlayOnPhoneCompleted | Occurs when an asynchronous GetMailTips operation is complete.
RefreshSharingFolderCompleted | Occurs when an asynchronous RefreshSharingFolder operation is complete.
RemoveDelegateCompleted | Occurs when an asynchronous RemoveDelegate operation is complete.
ResolveNamesCompleted | Occurs when an asynchronous ResolveNames operation is complete.
SendItemCompleted | Occurs when an asynchronous SendItem operation is complete.
SetUserOofSettingsCompleted | Occurs when an asynchronous SetUserOofSettings operation is complete.
SubscribeCompleted | Occurs when an asynchronous Subscribe operation is complete.
SyncFolderHierarchyCompleted | Occurs when an asynchronous SyncFolderHierarchy operation is complete.
SyncFolderItemsCompleted | Occurs when an asynchronous SyncFolderItems operation is complete.
UnsubscribeCompleted | Occurs when an asynchronous Unsubscribe operation is complete.
UpdateDelegateCompleted | Occurs when an asynchronous UpdateDelegate operation is complete.
UpdateFolderCompleted | Occurs when an asynchronous UpdateFolder operation is complete.
UpdateInboxRulesCompleted | Occurs when the update inbox rules operation has been completed
UpdateItemCompleted | Occurs when an asynchronous UpdateItem operation is complete.
UpdateUserConfigurationCompleted | Occurs when an asynchronous UpdateUserConfiguration operation is complete.
UploadItemsCompleted | Occurs when the upload items operation has been completed

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.AddDelegateCompleted Event

Occurs when an asynchronous AddDelegate operation is complete.

public event AddDelegateCompletedEventHandler AddDelegateCompleted;

Event Data

The event handler receives an argument of type AddDelegateCompletedEventArgs containing data related to this event. The following AddDelegateCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.ApplyConversationActionCompleted Event

Occurs when the apply conversation operation has been completed

public event ApplyConversationActionCompletedEventHandler ApplyConversationActionCompleted;

Event Data

The event handler receives an argument of type ApplyConversationActionCompletedEventArgs containing data related to this event. The following ApplyConversationActionCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result | Gets the result of operation
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.ConvertIdCompleted Event

Occurs when an asynchronous ConvertId operation is complete.

public event ConvertIdCompletedEventHandler ConvertIdCompleted;

Event Data

The event handler receives an argument of type ConvertIdCompletedEventArgs containing data related to this event. The following ConvertIdCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.CopyFolderCompleted Event

Occurs when an asynchronous CopyFolder operation is complete.

public event CopyFolderCompletedEventHandler CopyFolderCompleted;

Event Data

The event handler receives an argument of type CopyFolderCompletedEventArgs containing data related to this event. The following CopyFolderCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.CopyItemCompleted Event

Occurs when an asynchronous CopyItem operation is complete.

public event CopyItemCompletedEventHandler CopyItemCompleted;

Event Data

The event handler receives an argument of type CopyItemCompletedEventArgs containing data related to this event. The following CopyItemCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.CreateAttachmentCompleted Event

Occurs when an asynchronous CreateAttachment operation is complete.

public event CreateAttachmentCompletedEventHandler CreateAttachmentCompleted;

Event Data

The event handler receives an argument of type CreateAttachmentCompletedEventArgs containing data related to this event. The following CreateAttachmentCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.CreateFolderCompleted Event

Occurs when an asynchronous CreateFolder operation is complete.

public event CreateFolderCompletedEventHandler CreateFolderCompleted;

Event Data

The event handler receives an argument of type CreateFolderCompletedEventArgs containing data related to this event. The following CreateFolderCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.CreateItemCompleted Event

Occurs when an asynchronous CreateItem operation is complete.

public event CreateItemCompletedEventHandler CreateItemCompleted;

Event Data

The event handler receives an argument of type CreateItemCompletedEventArgs containing data related to this event. The following CreateItemCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.CreateManagedFolderCompleted Event

Occurs when an asynchronous CreateManagedFolder operation is complete.

public event CreateManagedFolderCompletedEventHandler CreateManagedFolderCompleted;

Event Data

The event handler receives an argument of type CreateManagedFolderCompletedEventArgs containing data related to this event. The following CreateManagedFolderCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.CreateUserConfigurationCompleted Event

Occurs when an asynchronous CreateUserConfiguration operation is complete.

public event CreateUserConfigurationCompletedEventHandler CreateUserConfigurationCompleted;

Event Data

The event handler receives an argument of type CreateUserConfigurationCompletedEventArgs containing data related to this event. The following CreateUserConfigurationCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.DeleteAttachmentCompleted Event

Occurs when an asynchronous DeleteAttachment operation is complete.

public event DeleteAttachmentCompletedEventHandler DeleteAttachmentCompleted;

Event Data

The event handler receives an argument of type DeleteAttachmentCompletedEventArgs containing data related to this event. The following DeleteAttachmentCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.DeleteFolderCompleted Event

Occurs when an asynchronous DeleteFolder operation is complete.

public event DeleteFolderCompletedEventHandler DeleteFolderCompleted;

Event Data

The event handler receives an argument of type DeleteFolderCompletedEventArgs containing data related to this event. The following DeleteFolderCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.DeleteItemCompleted Event

Occurs when an asynchronous DeleteItem operation is complete.

public event DeleteItemCompletedEventHandler DeleteItemCompleted;

Event Data

The event handler receives an argument of type DeleteItemCompletedEventArgs containing data related to this event. The following DeleteItemCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.DeleteUserConfigurationCompleted Event

Occurs when an asynchronous DeleteUserConfiguration operation is complete.

public event DeleteUserConfigurationCompletedEventHandler DeleteUserConfigurationCompleted;

Event Data

The event handler receives an argument of type DeleteUserConfigurationCompletedEventArgs containing data related to this event. The following DeleteUserConfigurationCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.DisconnectPhoneCallCompleted Event

Occurs when an asynchronous DisconnectPhoneCall operation is complete.

public event DisconnectPhoneCallCompletedEventHandler DisconnectPhoneCallCompleted;

Event Data

The event handler receives an argument of type DisconnectPhoneCallCompletedEventArgs containing data related to this event. The following DisconnectPhoneCallCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.EmptyFolderCompleted Event

Occurs when the empty folder operation has been completed

public event EmptyFolderCompletedEventHandler EmptyFolderCompleted;

Event Data

The event handler receives an argument of type EmptyFolderCompletedEventArgs containing data related to this event. The following EmptyFolderCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result | Gets the result of operation
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.ExpandDLCompleted Event

Occurs when an asynchronous ExpandDL operation is complete.

public event ExpandDLCompletedEventHandler ExpandDLCompleted;

Event Data

The event handler receives an argument of type ExpandDLCompletedEventArgs containing data related to this event. The following ExpandDLCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.ExportItemsCompleted Event

Occurs when the export items operation has been completed

public event ExportItemsCompletedEventHandler ExportItemsCompleted;

Event Data

The event handler receives an argument of type ExportItemsCompletedEventArgs containing data related to this event. The following ExportItemsCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result | Gets the result of operation
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.FindConversationCompleted Event

Occurs when the find conversation operation has been completed

public event FindConversationCompletedEventHandler FindConversationCompleted;

Event Data

The event handler receives an argument of type FindConversationCompletedEventArgs containing data related to this event. The following FindConversationCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result | Gets the result of operation
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.FindFolderCompleted Event

Occurs when an asynchronous FindFolder operation is complete.

public event FindFolderCompletedEventHandler FindFolderCompleted;

Event Data

The event handler receives an argument of type FindFolderCompletedEventArgs containing data related to this event. The following FindFolderCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.FindItemCompleted Event

Occurs when an asynchronous FindItem operation is complete.

public event FindItemCompletedEventHandler FindItemCompleted;

Event Data

The event handler receives an argument of type FindItemCompletedEventArgs containing data related to this event. The following FindItemCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.FindMessageTrackingReportCompleted Event

Occurs when an asynchronous FindMessageTrackingReport operation is complete.

public event FindMessageTrackingReportCompletedEventHandler FindMessageTrackingReportCompleted;

Event Data

The event handler receives an argument of type FindMessageTrackingReportCompletedEventArgs containing data related to this event. The following FindMessageTrackingReportCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.GetAttachmentCompleted Event

Occurs when an asynchronous GetAttachment operation is complete.

public event GetAttachmentCompletedEventHandler GetAttachmentCompleted;

Event Data

The event handler receives an argument of type GetAttachmentCompletedEventArgs containing data related to this event. The following GetAttachmentCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.GetDelegateCompleted Event

Occurs when an asynchronous GetDelegate operation is complete.

public event GetDelegateCompletedEventHandler GetDelegateCompleted;

Event Data

The event handler receives an argument of type GetDelegateCompletedEventArgs containing data related to this event. The following GetDelegateCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.GetEventsCompleted Event

Occurs when an asynchronous GetEvents operation is complete.

public event GetEventsCompletedEventHandler GetEventsCompleted;

Event Data

The event handler receives an argument of type GetEventsCompletedEventArgs containing data related to this event. The following GetEventsCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.GetFolderCompleted Event

Occurs when an asynchronous GetFolder operation is complete.

public event GetFolderCompletedEventHandler GetFolderCompleted;

Event Data

The event handler receives an argument of type GetFolderCompletedEventArgs containing data related to this event. The following GetFolderCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.GetInboxRulesCompleted Event

Occurs when the get inbox rules operation has been completed

public event GetInboxRulesCompletedEventHandler GetInboxRulesCompleted;

Event Data

The event handler receives an argument of type GetInboxRulesCompletedEventArgs containing data related to this event. The following GetInboxRulesCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result | Gets the result of operation
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.GetItemCompleted Event

Occurs when an asynchronous GetItem operation is complete.

public event GetItemCompletedEventHandler GetItemCompleted;

Event Data

The event handler receives an argument of type GetItemCompletedEventArgs containing data related to this event. The following GetItemCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.GetMailTipsCompleted Event

Occurs when an asynchronous GetMailTips operation is complete.

public event GetMailTipsCompletedEventHandler GetMailTipsCompleted;

Event Data

The event handler receives an argument of type GetMailTipsCompletedEventArgs containing data related to this event. The following GetMailTipsCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.GetMessageTrackingReportCompleted Event

Occurs when an asynchronous GetMessageTrackingReport operation is complete.

public event GetMessageTrackingReportCompletedEventHandler GetMessageTrackingReportCompleted;

Event Data

The event handler receives an argument of type GetMessageTrackingReportCompletedEventArgs containing data related to this event. The following GetMessageTrackingReportCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.GetPhoneCallInformationCompleted Event

Occurs when an asynchronous GetPhoneCallInformation operation is complete.

public event GetPhoneCallInformationCompletedEventHandler GetPhoneCallInformationCompleted;

Event Data

The event handler receives an argument of type GetPhoneCallInformationCompletedEventArgs containing data related to this event. The following GetPhoneCallInformationCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.GetRoomListsCompleted Event

Occurs when an asynchronous GetRoomLists operation is complete.

public event GetRoomListsCompletedEventHandler GetRoomListsCompleted;

Event Data

The event handler receives an argument of type GetRoomListsCompletedEventArgs containing data related to this event. The following GetRoomListsCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.GetRoomsCompleted Event

Occurs when an asynchronous GetRooms operation is complete.

public event GetRoomsCompletedEventHandler GetRoomsCompleted;

Event Data

The event handler receives an argument of type GetRoomsCompletedEventArgs containing data related to this event. The following GetRoomsCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.GetServerTimeZonesCompleted Event

Occurs when an asynchronous GetServerTimeZones operation is complete.

public event GetServerTimeZonesCompletedEventHandler GetServerTimeZonesCompleted;

Event Data

The event handler receives an argument of type GetServerTimeZonesCompletedEventArgs containing data related to this event. The following GetServerTimeZonesCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.GetServiceConfigurationCompleted Event

Occurs when an asynchronous GetServiceConfiguration operation is complete.

public event GetServiceConfigurationCompletedEventHandler GetServiceConfigurationCompleted;

Event Data

The event handler receives an argument of type GetServiceConfigurationCompletedEventArgs containing data related to this event. The following GetServiceConfigurationCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.GetSharingFolderCompleted Event

Occurs when an asynchronous GetSharingFolder operation is complete.

public event GetSharingFolderCompletedEventHandler GetSharingFolderCompleted;

Event Data

The event handler receives an argument of type GetSharingFolderCompletedEventArgs containing data related to this event. The following GetSharingFolderCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.GetSharingMetadataCompleted Event

Occurs when an asynchronous GetSharingMetadata operation is complete.

public event GetSharingMetadataCompletedEventHandler GetSharingMetadataCompleted;

Event Data

The event handler receives an argument of type GetSharingMetadataCompletedEventArgs containing data related to this event. The following GetSharingMetadataCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.GetStreamingEventsCompleted Event

Occurs when an asynchronous GetStreamingEvents operation is complete.

public event GetStreamingEventsCompletedEventHandler GetStreamingEventsCompleted;

Event Data

The event handler receives an argument of type GetStreamingEventsCompletedEventArgs containing data related to this event. The following GetStreamingEventsCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.GetUserAvailabilityCompleted Event

Occurs when an asynchronous GetUserAvailability operation is complete.

public event GetUserAvailabilityCompletedEventHandler GetUserAvailabilityCompleted;

Event Data

The event handler receives an argument of type GetUserAvailabilityCompletedEventArgs containing data related to this event. The following GetUserAvailabilityCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.GetUserConfigurationCompleted Event

Occurs when an asynchronous GetUserConfiguration operation is complete.

public event GetUserConfigurationCompletedEventHandler GetUserConfigurationCompleted;

Event Data

The event handler receives an argument of type GetUserConfigurationCompletedEventArgs containing data related to this event. The following GetUserConfigurationCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.GetUserOofSettingsCompleted Event

Occurs when an asynchronous GetUserOofSettings operation is complete.

public event GetUserOofSettingsCompletedEventHandler GetUserOofSettingsCompleted;

Event Data

The event handler receives an argument of type GetUserOofSettingsCompletedEventArgs containing data related to this event. The following GetUserOofSettingsCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.MoveFolderCompleted Event

Occurs when an asynchronous MoveFolder operation is complete.

public event MoveFolderCompletedEventHandler MoveFolderCompleted;

Event Data

The event handler receives an argument of type MoveFolderCompletedEventArgs containing data related to this event. The following MoveFolderCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.MoveItemCompleted Event

Occurs when an asynchronous MoveItem operation is complete.

public event MoveItemCompletedEventHandler MoveItemCompleted;

Event Data

The event handler receives an argument of type MoveItemCompletedEventArgs containing data related to this event. The following MoveItemCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.PlayOnPhoneCompleted Event

Occurs when an asynchronous GetMailTips operation is complete.

public event PlayOnPhoneCompletedEventHandler PlayOnPhoneCompleted;

Event Data

The event handler receives an argument of type PlayOnPhoneCompletedEventArgs containing data related to this event. The following PlayOnPhoneCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.RefreshSharingFolderCompleted Event

Occurs when an asynchronous RefreshSharingFolder operation is complete.

public event RefreshSharingFolderCompletedEventHandler RefreshSharingFolderCompleted;

Event Data

The event handler receives an argument of type RefreshSharingFolderCompletedEventArgs containing data related to this event. The following RefreshSharingFolderCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.RemoveDelegateCompleted Event

Occurs when an asynchronous RemoveDelegate operation is complete.

public event RemoveDelegateCompletedEventHandler RemoveDelegateCompleted;

Event Data

The event handler receives an argument of type RemoveDelegateCompletedEventArgs containing data related to this event. The following RemoveDelegateCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.ResolveNamesCompleted Event

Occurs when an asynchronous ResolveNames operation is complete.

public event ResolveNamesCompletedEventHandler ResolveNamesCompleted;

Event Data

The event handler receives an argument of type ResolveNamesCompletedEventArgs containing data related to this event. The following ResolveNamesCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.SendItemCompleted Event

Occurs when an asynchronous SendItem operation is complete.

public event SendItemCompletedEventHandler SendItemCompleted;

Event Data

The event handler receives an argument of type SendItemCompletedEventArgs containing data related to this event. The following SendItemCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.SetUserOofSettingsCompleted Event

Occurs when an asynchronous SetUserOofSettings operation is complete.

public event SetUserOofSettingsCompletedEventHandler SetUserOofSettingsCompleted;

Event Data

The event handler receives an argument of type SetUserOofSettingsCompletedEventArgs containing data related to this event. The following SetUserOofSettingsCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.SubscribeCompleted Event

Occurs when an asynchronous Subscribe operation is complete.

public event SubscribeCompletedEventHandler SubscribeCompleted;

Event Data

The event handler receives an argument of type SubscribeCompletedEventArgs containing data related to this event. The following SubscribeCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.SyncFolderHierarchyCompleted Event

Occurs when an asynchronous SyncFolderHierarchy operation is complete.

public event SyncFolderHierarchyCompletedEventHandler SyncFolderHierarchyCompleted;

Event Data

The event handler receives an argument of type SyncFolderHierarchyCompletedEventArgs containing data related to this event. The following SyncFolderHierarchyCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.SyncFolderItemsCompleted Event

Occurs when an asynchronous SyncFolderItems operation is complete.

public event SyncFolderItemsCompletedEventHandler SyncFolderItemsCompleted;

Event Data

The event handler receives an argument of type SyncFolderItemsCompletedEventArgs containing data related to this event. The following SyncFolderItemsCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.UnsubscribeCompleted Event

Occurs when an asynchronous Unsubscribe operation is complete.

public event UnsubscribeCompletedEventHandler UnsubscribeCompleted;

Event Data

The event handler receives an argument of type UnsubscribeCompletedEventArgs containing data related to this event. The following UnsubscribeCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.UpdateDelegateCompleted Event

Occurs when an asynchronous UpdateDelegate operation is complete.

public event UpdateDelegateCompletedEventHandler UpdateDelegateCompleted;

Event Data

The event handler receives an argument of type UpdateDelegateCompletedEventArgs containing data related to this event. The following UpdateDelegateCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.UpdateFolderCompleted Event

Occurs when an asynchronous UpdateFolder operation is complete.

public event UpdateFolderCompletedEventHandler UpdateFolderCompleted;

Event Data

The event handler receives an argument of type UpdateFolderCompletedEventArgs containing data related to this event. The following UpdateFolderCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.UpdateInboxRulesCompleted Event

Occurs when the update inbox rules operation has been completed

public event UpdateInboxRulesCompletedEventHandler UpdateInboxRulesCompleted;

Event Data

The event handler receives an argument of type UpdateInboxRulesCompletedEventArgs containing data related to this event. The following UpdateInboxRulesCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result | Gets the result of operation
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.UpdateItemCompleted Event

Occurs when an asynchronous UpdateItem operation is complete.

public event UpdateItemCompletedEventHandler UpdateItemCompleted;

Event Data

The event handler receives an argument of type UpdateItemCompletedEventArgs containing data related to this event. The following UpdateItemCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.UpdateUserConfigurationCompleted Event

Occurs when an asynchronous UpdateUserConfiguration operation is complete.

public event UpdateUserConfigurationCompletedEventHandler UpdateUserConfigurationCompleted;

Event Data

The event handler receives an argument of type UpdateUserConfigurationCompletedEventArgs containing data related to this event. The following UpdateUserConfigurationCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeServiceBinding.UploadItemsCompleted Event

Occurs when the upload items operation has been completed

public event UploadItemsCompletedEventHandler UploadItemsCompleted;

Event Data

The event handler receives an argument of type UploadItemsCompletedEventArgs containing data related to this event. The following UploadItemsCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result | Gets the result of operation
UserState | Gets the unique identifier for the asynchronous task.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema Namespace


ExchangeVersionType Enumeration

public enum ExchangeVersionType

Remarks

Members

Member Name | Description | Value
Exchange2007 |  | 0
Exchange2007_SP1 |  | 1
Exchange2010 |  | 2
Exchange2010_SP1 |  | 3
Exchange2010_SP2 |  | 4

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


ExcludesType Class

For a list of all members of this type, see ExcludesType Members.

System.Object
Aspose.Email.Exchange.Schema.SearchExpressionType
Aspose.Email.Exchange.Schema.ExcludesType

public class ExcludesType : SearchExpressionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExcludesType Members | Aspose.Email.Exchange.Schema Namespace


ExcludesType Members

ExcludesType overview

Public Instance Constructors

ExcludesType Constructor Initializes a new instance of the ExcludesType class.

Public Instance Properties

Bitmask
Item

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExcludesType Class | Aspose.Email.Exchange.Schema Namespace


ExcludesType Constructor

Initializes a new instance of the ExcludesType class.

public ExcludesType();

See Also

ExcludesType Class | Aspose.Email.Exchange.Schema Namespace


ExcludesType Properties

The properties of the ExcludesType class are listed below. For a complete list of ExcludesType class members, see the ExcludesType Members topic.

Public Instance Properties

Bitmask
Item

See Also

ExcludesType Class | Aspose.Email.Exchange.Schema Namespace


Bitmask Property

Aspose.Email

ExcludesType.Bitmask Property

public ExcludesValueType Bitmask {get; set;}

Remarks

See Also

ExcludesType Class | Aspose.Email.Exchange.Schema Namespace


Item Property

Aspose.Email

ExcludesType.Item Property

public BasePathToElementType Item {get; set;}

Remarks

See Also

ExcludesType Class | Aspose.Email.Exchange.Schema Namespace


ExcludesValueType Class

For a list of all members of this type, see ExcludesValueType Members.

System.Object
Aspose.Email.Exchange.Schema.ExcludesValueType

public class ExcludesValueType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExcludesValueType Members | Aspose.Email.Exchange.Schema Namespace


ExcludesValueType Members

ExcludesValueType overview

Public Instance Constructors

ExcludesValueType Constructor Initializes a new instance of the ExcludesValueType class.

Public Instance Properties

Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExcludesValueType Class | Aspose.Email.Exchange.Schema Namespace


ExcludesValueType Constructor

Initializes a new instance of the ExcludesValueType class.

public ExcludesValueType();

See Also

ExcludesValueType Class | Aspose.Email.Exchange.Schema Namespace


ExcludesValueType Properties

The properties of the ExcludesValueType class are listed below. For a complete list of ExcludesValueType class members, see the ExcludesValueType Members topic.

Public Instance Properties

Value

See Also

ExcludesValueType Class | Aspose.Email.Exchange.Schema Namespace


Value Property

Aspose.Email

ExcludesValueType.Value Property

public string Value {get; set;}

Remarks

See Also

ExcludesValueType Class | Aspose.Email.Exchange.Schema Namespace


ExistsType Class

For a list of all members of this type, see ExistsType Members.

System.Object
Aspose.Email.Exchange.Schema.SearchExpressionType
Aspose.Email.Exchange.Schema.ExistsType

public class ExistsType : SearchExpressionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExistsType Members | Aspose.Email.Exchange.Schema Namespace


ExistsType Members

ExistsType overview

Public Instance Constructors

ExistsType Constructor Initializes a new instance of the ExistsType class.

Public Instance Properties

Item

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExistsType Class | Aspose.Email.Exchange.Schema Namespace


ExistsType Constructor

Initializes a new instance of the ExistsType class.

public ExistsType();

See Also

ExistsType Class | Aspose.Email.Exchange.Schema Namespace


ExistsType Properties

The properties of the ExistsType class are listed below. For a complete list of ExistsType class members, see the ExistsType Members topic.

Public Instance Properties

Item

See Also

ExistsType Class | Aspose.Email.Exchange.Schema Namespace


Item Property

Aspose.Email

ExistsType.Item Property

public BasePathToElementType Item {get; set;}

Remarks

See Also

ExistsType Class | Aspose.Email.Exchange.Schema Namespace


ExpandDLCompletedEventArgs Class

For a list of all members of this type, see ExpandDLCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.ExpandDLCompletedEventArgs

public class ExpandDLCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExpandDLCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


ExpandDLCompletedEventArgs Members

ExpandDLCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

ExpandDLCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


ExpandDLCompletedEventArgs Properties

The properties of the ExpandDLCompletedEventArgs class are listed below. For a complete list of ExpandDLCompletedEventArgs class members, see the ExpandDLCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

ExpandDLCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

ExpandDLCompletedEventArgs.Result Property

public ExpandDLResponseType Result {get;}

Remarks

See Also

ExpandDLCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


ExpandDLCompletedEventHandler Delegate

public delegate void ExpandDLCompletedEventHandler(
object sender,
ExpandDLCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


ExpandDLResponseMessageType Class

For a list of all members of this type, see ExpandDLResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ResponseMessageType
Aspose.Email.Exchange.Schema.ExpandDLResponseMessageType

public class ExpandDLResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExpandDLResponseMessageType Members | Aspose.Email.Exchange.Schema Namespace


ExpandDLResponseMessageType Members

ExpandDLResponseMessageType overview

Public Instance Constructors

ExpandDLResponseMessageType Constructor Initializes a new instance of the ExpandDLResponseMessageType class.

Public Instance Properties

AbsoluteDenominator
AbsoluteDenominatorSpecified
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
DLExpansion
IncludesLastItemInRange
IncludesLastItemInRangeSpecified
IndexedPagingOffset
IndexedPagingOffsetSpecified
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
NumeratorOffset
NumeratorOffsetSpecified
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
TotalItemsInView
TotalItemsInViewSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExpandDLResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


ExpandDLResponseMessageType Constructor

Initializes a new instance of the ExpandDLResponseMessageType class.

public ExpandDLResponseMessageType();

See Also

ExpandDLResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


ExpandDLResponseMessageType Properties

The properties of the ExpandDLResponseMessageType class are listed below. For a complete list of ExpandDLResponseMessageType class members, see the ExpandDLResponseMessageType Members topic.

Public Instance Properties

AbsoluteDenominator
AbsoluteDenominatorSpecified
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
DLExpansion
IncludesLastItemInRange
IncludesLastItemInRangeSpecified
IndexedPagingOffset
IndexedPagingOffsetSpecified
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
NumeratorOffset
NumeratorOffsetSpecified
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
TotalItemsInView
TotalItemsInViewSpecified

See Also

ExpandDLResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


AbsoluteDenominator Property

Aspose.Email

ExpandDLResponseMessageType.AbsoluteDenominator Property

public int AbsoluteDenominator {get; set;}

Remarks

See Also

ExpandDLResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


AbsoluteDenominatorSpecified Property

Aspose.Email

ExpandDLResponseMessageType.AbsoluteDenominatorSpecified Property

public bool AbsoluteDenominatorSpecified {get; set;}

Remarks

See Also

ExpandDLResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


DLExpansion Property

Aspose.Email

ExpandDLResponseMessageType.DLExpansion Property

public ArrayOfDLExpansionType DLExpansion {get; set;}

Remarks

See Also

ExpandDLResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


IncludesLastItemInRange Property

Aspose.Email

ExpandDLResponseMessageType.IncludesLastItemInRange Property

public bool IncludesLastItemInRange {get; set;}

Remarks

See Also

ExpandDLResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


IncludesLastItemInRangeSpecified Property

Aspose.Email

ExpandDLResponseMessageType.IncludesLastItemInRangeSpecified Property

public bool IncludesLastItemInRangeSpecified {get; set;}

Remarks

See Also

ExpandDLResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


IndexedPagingOffset Property

Aspose.Email

ExpandDLResponseMessageType.IndexedPagingOffset Property

public int IndexedPagingOffset {get; set;}

Remarks

See Also

ExpandDLResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


IndexedPagingOffsetSpecified Property

Aspose.Email

ExpandDLResponseMessageType.IndexedPagingOffsetSpecified Property

public bool IndexedPagingOffsetSpecified {get; set;}

Remarks

See Also

ExpandDLResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


NumeratorOffset Property

Aspose.Email

ExpandDLResponseMessageType.NumeratorOffset Property

public int NumeratorOffset {get; set;}

Remarks

See Also

ExpandDLResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


NumeratorOffsetSpecified Property

Aspose.Email

ExpandDLResponseMessageType.NumeratorOffsetSpecified Property

public bool NumeratorOffsetSpecified {get; set;}

Remarks

See Also

ExpandDLResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


TotalItemsInView Property

Aspose.Email

ExpandDLResponseMessageType.TotalItemsInView Property

public int TotalItemsInView {get; set;}

Remarks

See Also

ExpandDLResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


TotalItemsInViewSpecified Property

Aspose.Email

ExpandDLResponseMessageType.TotalItemsInViewSpecified Property

public bool TotalItemsInViewSpecified {get; set;}

Remarks

See Also

ExpandDLResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


ExpandDLResponseType Class

For a list of all members of this type, see ExpandDLResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseResponseMessageType
Aspose.Email.Exchange.Schema.ExpandDLResponseType

public class ExpandDLResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExpandDLResponseType Members | Aspose.Email.Exchange.Schema Namespace


ExpandDLResponseType Members

ExpandDLResponseType overview

Public Instance Constructors

ExpandDLResponseType Constructor Initializes a new instance of the ExpandDLResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExpandDLResponseType Class | Aspose.Email.Exchange.Schema Namespace


ExpandDLResponseType Constructor

Initializes a new instance of the ExpandDLResponseType class.

public ExpandDLResponseType();

See Also

ExpandDLResponseType Class | Aspose.Email.Exchange.Schema Namespace


ExpandDLType Class

For a list of all members of this type, see ExpandDLType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.ExpandDLType

public class ExpandDLType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExpandDLType Members | Aspose.Email.Exchange.Schema Namespace


ExpandDLType Members

ExpandDLType overview

Public Instance Constructors

ExpandDLType Constructor Initializes a new instance of the ExpandDLType class.

Public Instance Properties

Mailbox

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExpandDLType Class | Aspose.Email.Exchange.Schema Namespace


ExpandDLType Constructor

Initializes a new instance of the ExpandDLType class.

public ExpandDLType();

See Also

ExpandDLType Class | Aspose.Email.Exchange.Schema Namespace


ExpandDLType Properties

The properties of the ExpandDLType class are listed below. For a complete list of ExpandDLType class members, see the ExpandDLType Members topic.

Public Instance Properties

Mailbox

See Also

ExpandDLType Class | Aspose.Email.Exchange.Schema Namespace


Mailbox Property

Aspose.Email

ExpandDLType.Mailbox Property

public EmailAddressType Mailbox {get; set;}

Remarks

See Also

ExpandDLType Class | Aspose.Email.Exchange.Schema Namespace


ExportItemsCompletedEventArgs Class

Provides data for the event

For a list of all members of this type, see ExportItemsCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.ExportItemsCompletedEventArgs

public class ExportItemsCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExportItemsCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace | ExportItemsCompleted


ExportItemsCompletedEventArgs Members

ExportItemsCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result | Gets the result of operation
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

ExportItemsCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace | ExportItemsCompleted


ExportItemsCompletedEventArgs Properties

The properties of the ExportItemsCompletedEventArgs class are listed below. For a complete list of ExportItemsCompletedEventArgs class members, see the ExportItemsCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result | Gets the result of operation
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

ExportItemsCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace | ExportItemsCompleted


Result Property

Aspose.Email

ExportItemsCompletedEventArgs.Result Property

Gets the result of operation

public ExportItemsResponseType Result {get;}

See Also

ExportItemsCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


ExportItemsCompletedEventHandler Delegate

Represents the method that will handle the ExportItemsCompleted event

public delegate void ExportItemsCompletedEventHandler(
object sender,
ExportItemsCompletedEventArgs e
);

Parameters

sender
The sender of event
e
A ExportItemsCompletedEventArgs arguments

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


ExportItemsResponseMessageType Class

Represents a single exported item

For a list of all members of this type, see ExportItemsResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ResponseMessageType
Aspose.Email.Exchange.Schema.ExportItemsResponseMessageType

public class ExportItemsResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExportItemsResponseMessageType Members | Aspose.Email.Exchange.Schema Namespace


ExportItemsResponseMessageType Members

ExportItemsResponseMessageType overview

Public Instance Constructors

ExportItemsResponseMessageType Constructor Initializes a new instance of the ExportItemsResponseMessageType class.

Public Instance Properties

Data | Gets or sets the data of a single exported item.
DescriptiveLinkKey (inherited from ResponseMessageType) |
DescriptiveLinkKeySpecified (inherited from ResponseMessageType) |
ItemId | Gets or sets the item identifier of a single exported item.
MessageText (inherited from ResponseMessageType) |
MessageXml (inherited from ResponseMessageType) |
ResponseClass (inherited from ResponseMessageType) |
ResponseCode (inherited from ResponseMessageType) |
ResponseCodeSpecified (inherited from ResponseMessageType) |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExportItemsResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


ExportItemsResponseMessageType Constructor

Initializes a new instance of the ExportItemsResponseMessageType class.

public ExportItemsResponseMessageType();

See Also

ExportItemsResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


ExportItemsResponseMessageType Properties

The properties of the ExportItemsResponseMessageType class are listed below. For a complete list of ExportItemsResponseMessageType class members, see the ExportItemsResponseMessageType Members topic.

Public Instance Properties

Data | Gets or sets the data of a single exported item.
DescriptiveLinkKey (inherited from ResponseMessageType) |
DescriptiveLinkKeySpecified (inherited from ResponseMessageType) |
ItemId | Gets or sets the item identifier of a single exported item.
MessageText (inherited from ResponseMessageType) |
MessageXml (inherited from ResponseMessageType) |
ResponseClass (inherited from ResponseMessageType) |
ResponseCode (inherited from ResponseMessageType) |
ResponseCodeSpecified (inherited from ResponseMessageType) |

See Also

ExportItemsResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


Data Property

Aspose.Email

ExportItemsResponseMessageType.Data Property

Gets or sets the data of a single exported item.

public byte[] Data {get; set;}

See Also

ExportItemsResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


ItemId Property

Aspose.Email

ExportItemsResponseMessageType.ItemId Property

Gets or sets the item identifier of a single exported item.

public ItemIdType ItemId {get; set;}

See Also

ExportItemsResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


ExportItemsResponseType Class

Represents a response to export items from a mailbox

For a list of all members of this type, see ExportItemsResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseResponseMessageType
Aspose.Email.Exchange.Schema.ExportItemsResponseType

public class ExportItemsResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExportItemsResponseType Members | Aspose.Email.Exchange.Schema Namespace


ExportItemsResponseType Members

ExportItemsResponseType overview

Public Instance Constructors

ExportItemsResponseType Constructor Initializes a new instance of the ExportItemsResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExportItemsResponseType Class | Aspose.Email.Exchange.Schema Namespace


ExportItemsResponseType Constructor

Initializes a new instance of the ExportItemsResponseType class.

public ExportItemsResponseType();

See Also

ExportItemsResponseType Class | Aspose.Email.Exchange.Schema Namespace


ExportItemsType Class

Represents a request to export items out of a mailbox.

For a list of all members of this type, see ExportItemsType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.ExportItemsType

public class ExportItemsType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExportItemsType Members | Aspose.Email.Exchange.Schema Namespace


ExportItemsType Members

ExportItemsType overview

Public Instance Constructors

ExportItemsType Constructor Initializes a new instance of the ExportItemsType class.

Public Instance Properties

ItemIds Gets or sets the item identifier array of the items to export.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExportItemsType Class | Aspose.Email.Exchange.Schema Namespace


ExportItemsType Constructor

Initializes a new instance of the ExportItemsType class.

public ExportItemsType();

See Also

ExportItemsType Class | Aspose.Email.Exchange.Schema Namespace


ExportItemsType Properties

The properties of the ExportItemsType class are listed below. For a complete list of ExportItemsType class members, see the ExportItemsType Members topic.

Public Instance Properties

ItemIds Gets or sets the item identifier array of the items to export.

See Also

ExportItemsType Class | Aspose.Email.Exchange.Schema Namespace


ItemIds Property

Aspose.Email

ExportItemsType.ItemIds Property

Gets or sets the item identifier array of the items to export.

public ItemIdType[] ItemIds {get; set;}

See Also

ExportItemsType Class | Aspose.Email.Exchange.Schema Namespace


ExtendedPropertyType Class

For a list of all members of this type, see ExtendedPropertyType Members.

System.Object
Aspose.Email.Exchange.Schema.ExtendedPropertyType

public class ExtendedPropertyType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExtendedPropertyType Members | Aspose.Email.Exchange.Schema Namespace


ExtendedPropertyType Members

ExtendedPropertyType overview

Public Instance Constructors

ExtendedPropertyType Constructor Initializes a new instance of the ExtendedPropertyType class.

Public Instance Properties

ExtendedFieldURI
Item

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExtendedPropertyType Class | Aspose.Email.Exchange.Schema Namespace


ExtendedPropertyType Constructor

Initializes a new instance of the ExtendedPropertyType class.

public ExtendedPropertyType();

See Also

ExtendedPropertyType Class | Aspose.Email.Exchange.Schema Namespace


ExtendedPropertyType Properties

The properties of the ExtendedPropertyType class are listed below. For a complete list of ExtendedPropertyType class members, see the ExtendedPropertyType Members topic.

Public Instance Properties

ExtendedFieldURI
Item

See Also

ExtendedPropertyType Class | Aspose.Email.Exchange.Schema Namespace


ExtendedFieldURI Property

Aspose.Email

ExtendedPropertyType.ExtendedFieldURI Property

public PathToExtendedFieldType ExtendedFieldURI {get; set;}

Remarks

See Also

ExtendedPropertyType Class | Aspose.Email.Exchange.Schema Namespace


Item Property

Aspose.Email

ExtendedPropertyType.Item Property

public object Item {get; set;}

Remarks

See Also

ExtendedPropertyType Class | Aspose.Email.Exchange.Schema Namespace


ExternalAudience Enumeration

public enum ExternalAudience

Remarks

Members

Member Name | Description | Value
None |  | 0
Known |  | 1
All |  | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


FieldOrderType Class

For a list of all members of this type, see FieldOrderType Members.

System.Object
Aspose.Email.Exchange.Schema.FieldOrderType

public class FieldOrderType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FieldOrderType Members | Aspose.Email.Exchange.Schema Namespace


FieldOrderType Members

FieldOrderType overview

Public Instance Constructors

FieldOrderType Constructor Initializes a new instance of the FieldOrderType class.

Public Instance Properties

Item
Order

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FieldOrderType Class | Aspose.Email.Exchange.Schema Namespace


FieldOrderType Constructor

Initializes a new instance of the FieldOrderType class.

public FieldOrderType();

See Also

FieldOrderType Class | Aspose.Email.Exchange.Schema Namespace


FieldOrderType Properties

The properties of the FieldOrderType class are listed below. For a complete list of FieldOrderType class members, see the FieldOrderType Members topic.

Public Instance Properties

Item
Order

See Also

FieldOrderType Class | Aspose.Email.Exchange.Schema Namespace


Item Property

Aspose.Email

FieldOrderType.Item Property

public BasePathToElementType Item {get; set;}

Remarks

See Also

FieldOrderType Class | Aspose.Email.Exchange.Schema Namespace


Order Property

Aspose.Email

FieldOrderType.Order Property

public SortDirectionType Order {get; set;}

Remarks

See Also

FieldOrderType Class | Aspose.Email.Exchange.Schema Namespace


FieldURIOrConstantType Class

For a list of all members of this type, see FieldURIOrConstantType Members.

System.Object
Aspose.Email.Exchange.Schema.FieldURIOrConstantType

public class FieldURIOrConstantType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FieldURIOrConstantType Members | Aspose.Email.Exchange.Schema Namespace


FieldURIOrConstantType Members

FieldURIOrConstantType overview

Public Instance Constructors

FieldURIOrConstantType Constructor Initializes a new instance of the FieldURIOrConstantType class.

Public Instance Properties

Item

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FieldURIOrConstantType Class | Aspose.Email.Exchange.Schema Namespace


FieldURIOrConstantType Constructor

Initializes a new instance of the FieldURIOrConstantType class.

public FieldURIOrConstantType();

See Also

FieldURIOrConstantType Class | Aspose.Email.Exchange.Schema Namespace


FieldURIOrConstantType Properties

The properties of the FieldURIOrConstantType class are listed below. For a complete list of FieldURIOrConstantType class members, see the FieldURIOrConstantType Members topic.

Public Instance Properties

Item

See Also

FieldURIOrConstantType Class | Aspose.Email.Exchange.Schema Namespace


Item Property

Aspose.Email

FieldURIOrConstantType.Item Property

public object Item {get; set;}

Remarks

See Also

FieldURIOrConstantType Class | Aspose.Email.Exchange.Schema Namespace


FileAsMappingType Enumeration

public enum FileAsMappingType

Remarks

Members

Member Name | Description | Value
None |  | 0
LastCommaFirst |  | 1
FirstSpaceLast |  | 2
Company |  | 3
LastCommaFirstCompany |  | 4
CompanyLastFirst |  | 5
LastFirst |  | 6
LastFirstCompany |  | 7
CompanyLastCommaFirst |  | 8
LastFirstSuffix |  | 9
LastSpaceFirstCompany |  | 10
CompanyLastSpaceFirst |  | 11
LastSpaceFirst |  | 12
DisplayName |  | 13
FirstName |  | 14
LastFirstMiddleSuffix |  | 15
LastName |  | 16
Empty |  | 17

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


FileAttachmentType Class

For a list of all members of this type, see FileAttachmentType Members.

System.Object
Aspose.Email.Exchange.Schema.AttachmentType
Aspose.Email.Exchange.Schema.FileAttachmentType

public class FileAttachmentType : AttachmentType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FileAttachmentType Members | Aspose.Email.Exchange.Schema Namespace


FileAttachmentType Members

FileAttachmentType overview

Public Instance Constructors

FileAttachmentType Constructor Initializes a new instance of the FileAttachmentType class.

Public Instance Properties

AttachmentId (inherited from AttachmentType)
Content
ContentId (inherited from AttachmentType)
ContentLocation (inherited from AttachmentType)
ContentType (inherited from AttachmentType)
IsContactPhoto
IsContactPhotoSpecified
IsInline (inherited from AttachmentType)
IsInlineSpecified (inherited from AttachmentType)
LastModifiedTime (inherited from AttachmentType)
LastModifiedTimeSpecified (inherited from AttachmentType)
Name (inherited from AttachmentType)
Size (inherited from AttachmentType)
SizeSpecified (inherited from AttachmentType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FileAttachmentType Class | Aspose.Email.Exchange.Schema Namespace


FileAttachmentType Constructor

Initializes a new instance of the FileAttachmentType class.

public FileAttachmentType();

See Also

FileAttachmentType Class | Aspose.Email.Exchange.Schema Namespace


FileAttachmentType Properties

The properties of the FileAttachmentType class are listed below. For a complete list of FileAttachmentType class members, see the FileAttachmentType Members topic.

Public Instance Properties

AttachmentId (inherited from AttachmentType)
Content
ContentId (inherited from AttachmentType)
ContentLocation (inherited from AttachmentType)
ContentType (inherited from AttachmentType)
IsContactPhoto
IsContactPhotoSpecified
IsInline (inherited from AttachmentType)
IsInlineSpecified (inherited from AttachmentType)
LastModifiedTime (inherited from AttachmentType)
LastModifiedTimeSpecified (inherited from AttachmentType)
Name (inherited from AttachmentType)
Size (inherited from AttachmentType)
SizeSpecified (inherited from AttachmentType)

See Also

FileAttachmentType Class | Aspose.Email.Exchange.Schema Namespace


Content Property

Aspose.Email

FileAttachmentType.Content Property

public byte[] Content {get; set;}

Remarks

See Also

FileAttachmentType Class | Aspose.Email.Exchange.Schema Namespace


IsContactPhoto Property

Aspose.Email

FileAttachmentType.IsContactPhoto Property

public bool IsContactPhoto {get; set;}

Remarks

See Also

FileAttachmentType Class | Aspose.Email.Exchange.Schema Namespace


IsContactPhotoSpecified Property

Aspose.Email

FileAttachmentType.IsContactPhotoSpecified Property

public bool IsContactPhotoSpecified {get; set;}

Remarks

See Also

FileAttachmentType Class | Aspose.Email.Exchange.Schema Namespace


FindConversationCompletedEventArgs Class

Provides data for the event

For a list of all members of this type, see FindConversationCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.FindConversationCompletedEventArgs

public class FindConversationCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FindConversationCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace | FindConversationCompleted


FindConversationCompletedEventArgs Members

FindConversationCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result | Gets the result of operation
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

FindConversationCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace | FindConversationCompleted


FindConversationCompletedEventArgs Properties

The properties of the FindConversationCompletedEventArgs class are listed below. For a complete list of FindConversationCompletedEventArgs class members, see the FindConversationCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result | Gets the result of operation
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

FindConversationCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace | FindConversationCompleted


Result Property

Aspose.Email

FindConversationCompletedEventArgs.Result Property

Gets the result of operation

public FindConversationResponseMessageType Result {get;}

See Also

FindConversationCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


FindConversationCompletedEventHandler Delegate

Represents the method that will handle the FindConversationCompleted event

public delegate void FindConversationCompletedEventHandler(
object sender,
FindConversationCompletedEventArgs e
);

Parameters

sender
The sender of event
e
A FindConversationCompletedEventArgs arguments

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


FindConversationResponseMessageType Class

Represents the results of an attempt to find conversations in folder.

For a list of all members of this type, see FindConversationResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ResponseMessageType
Aspose.Email.Exchange.Schema.FindConversationResponseMessageType

public class FindConversationResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FindConversationResponseMessageType Members | Aspose.Email.Exchange.Schema Namespace


FindConversationResponseMessageType Members

FindConversationResponseMessageType overview

Public Instance Constructors

FindConversationResponseMessageType Constructor Initializes a new instance of the FindConversationResponseMessageType class.

Public Instance Properties

Conversations | Gets or sets an array of conversations that is returned in a response.
DescriptiveLinkKey (inherited from ResponseMessageType) |
DescriptiveLinkKeySpecified (inherited from ResponseMessageType) |
MessageText (inherited from ResponseMessageType) |
MessageXml (inherited from ResponseMessageType) |
ResponseClass (inherited from ResponseMessageType) |
ResponseCode (inherited from ResponseMessageType) |
ResponseCodeSpecified (inherited from ResponseMessageType) |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FindConversationResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


FindConversationResponseMessageType Constructor

Initializes a new instance of the FindConversationResponseMessageType class.

public FindConversationResponseMessageType();

See Also

FindConversationResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


FindConversationResponseMessageType Properties

The properties of the FindConversationResponseMessageType class are listed below. For a complete list of FindConversationResponseMessageType class members, see the FindConversationResponseMessageType Members topic.

Public Instance Properties

Conversations | Gets or sets an array of conversations that is returned in a response.
DescriptiveLinkKey (inherited from ResponseMessageType) |
DescriptiveLinkKeySpecified (inherited from ResponseMessageType) |
MessageText (inherited from ResponseMessageType) |
MessageXml (inherited from ResponseMessageType) |
ResponseClass (inherited from ResponseMessageType) |
ResponseCode (inherited from ResponseMessageType) |
ResponseCodeSpecified (inherited from ResponseMessageType) |

See Also

FindConversationResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


Conversations Property

Aspose.Email

FindConversationResponseMessageType.Conversations Property

Gets or sets an array of conversations that is returned in a response.

public ConversationType[] Conversations {get; set;}

See Also

FindConversationResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


FindConversationType Class

Represents the search options to use when searching for conversations.

For a list of all members of this type, see FindConversationType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.FindConversationType

public class FindConversationType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FindConversationType Members | Aspose.Email.Exchange.Schema Namespace


FindConversationType Members

FindConversationType overview

Public Instance Constructors

FindConversationType Constructor Initializes a new instance of the FindConversationType class.

Public Instance Properties

IndexedPageItemView | Gets or sets how conversation search results are returned in the response.
ParentFolderId | Gets or sets the folder that is searched for conversations. This element MUST be present.
SortOrder | Gets or sets the property and sort order direction that is used to sort conversations in the response.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FindConversationType Class | Aspose.Email.Exchange.Schema Namespace


FindConversationType Constructor

Initializes a new instance of the FindConversationType class.

public FindConversationType();

See Also

FindConversationType Class | Aspose.Email.Exchange.Schema Namespace


FindConversationType Properties

The properties of the FindConversationType class are listed below. For a complete list of FindConversationType class members, see the FindConversationType Members topic.

Public Instance Properties

IndexedPageItemView | Gets or sets how conversation search results are returned in the response.
ParentFolderId | Gets or sets the folder that is searched for conversations. This element MUST be present.
SortOrder | Gets or sets the property and sort order direction that is used to sort conversations in the response.

See Also

FindConversationType Class | Aspose.Email.Exchange.Schema Namespace


IndexedPageItemView Property

Aspose.Email

FindConversationType.IndexedPageItemView Property

Gets or sets how conversation search results are returned in the response.

public IndexedPageViewType IndexedPageItemView {get; set;}

See Also

FindConversationType Class | Aspose.Email.Exchange.Schema Namespace


ParentFolderId Property

Aspose.Email

FindConversationType.ParentFolderId Property

Gets or sets the folder that is searched for conversations. This element MUST be present.

public TargetFolderIdType ParentFolderId {get; set;}

See Also

FindConversationType Class | Aspose.Email.Exchange.Schema Namespace


SortOrder Property

Aspose.Email

FindConversationType.SortOrder Property

Gets or sets the property and sort order direction that is used to sort conversations in the response.

public FieldOrderType[] SortOrder {get; set;}

See Also

FindConversationType Class | Aspose.Email.Exchange.Schema Namespace


FindFolderCompletedEventArgs Class

For a list of all members of this type, see FindFolderCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.FindFolderCompletedEventArgs

public class FindFolderCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FindFolderCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


FindFolderCompletedEventArgs Members

FindFolderCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

FindFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


FindFolderCompletedEventArgs Properties

The properties of the FindFolderCompletedEventArgs class are listed below. For a complete list of FindFolderCompletedEventArgs class members, see the FindFolderCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

FindFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

FindFolderCompletedEventArgs.Result Property

public FindFolderResponseType Result {get;}

Remarks

See Also

FindFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


FindFolderCompletedEventHandler Delegate

public delegate void FindFolderCompletedEventHandler(
object sender,
FindFolderCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


FindFolderParentType Class

For a list of all members of this type, see FindFolderParentType Members.

System.Object
Aspose.Email.Exchange.Schema.FindFolderParentType

public class FindFolderParentType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FindFolderParentType Members | Aspose.Email.Exchange.Schema Namespace


FindFolderParentType Members

FindFolderParentType overview

Public Instance Constructors

FindFolderParentType Constructor Initializes a new instance of the FindFolderParentType class.

Public Instance Properties

AbsoluteDenominator
AbsoluteDenominatorSpecified
Folders
IncludesLastItemInRange
IncludesLastItemInRangeSpecified
IndexedPagingOffset
IndexedPagingOffsetSpecified
NumeratorOffset
NumeratorOffsetSpecified
TotalItemsInView
TotalItemsInViewSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FindFolderParentType Class | Aspose.Email.Exchange.Schema Namespace


FindFolderParentType Constructor

Initializes a new instance of the FindFolderParentType class.

public FindFolderParentType();

See Also

FindFolderParentType Class | Aspose.Email.Exchange.Schema Namespace


FindFolderParentType Properties

The properties of the FindFolderParentType class are listed below. For a complete list of FindFolderParentType class members, see the FindFolderParentType Members topic.

Public Instance Properties

AbsoluteDenominator
AbsoluteDenominatorSpecified
Folders
IncludesLastItemInRange
IncludesLastItemInRangeSpecified
IndexedPagingOffset
IndexedPagingOffsetSpecified
NumeratorOffset
NumeratorOffsetSpecified
TotalItemsInView
TotalItemsInViewSpecified

See Also

FindFolderParentType Class | Aspose.Email.Exchange.Schema Namespace


AbsoluteDenominator Property

Aspose.Email

FindFolderParentType.AbsoluteDenominator Property

public int AbsoluteDenominator {get; set;}

Remarks

See Also

FindFolderParentType Class | Aspose.Email.Exchange.Schema Namespace


AbsoluteDenominatorSpecified Property

Aspose.Email

FindFolderParentType.AbsoluteDenominatorSpecified Property

public bool AbsoluteDenominatorSpecified {get; set;}

Remarks

See Also

FindFolderParentType Class | Aspose.Email.Exchange.Schema Namespace


Folders Property

Aspose.Email

FindFolderParentType.Folders Property

public BaseFolderType[] Folders {get; set;}

Remarks

See Also

FindFolderParentType Class | Aspose.Email.Exchange.Schema Namespace


IncludesLastItemInRange Property

Aspose.Email

FindFolderParentType.IncludesLastItemInRange Property

public bool IncludesLastItemInRange {get; set;}

Remarks

See Also

FindFolderParentType Class | Aspose.Email.Exchange.Schema Namespace


IncludesLastItemInRangeSpecified Property

Aspose.Email

FindFolderParentType.IncludesLastItemInRangeSpecified Property

public bool IncludesLastItemInRangeSpecified {get; set;}

Remarks

See Also

FindFolderParentType Class | Aspose.Email.Exchange.Schema Namespace


IndexedPagingOffset Property

Aspose.Email

FindFolderParentType.IndexedPagingOffset Property

public int IndexedPagingOffset {get; set;}

Remarks

See Also

FindFolderParentType Class | Aspose.Email.Exchange.Schema Namespace


IndexedPagingOffsetSpecified Property

Aspose.Email

FindFolderParentType.IndexedPagingOffsetSpecified Property

public bool IndexedPagingOffsetSpecified {get; set;}

Remarks

See Also

FindFolderParentType Class | Aspose.Email.Exchange.Schema Namespace


NumeratorOffset Property

Aspose.Email

FindFolderParentType.NumeratorOffset Property

public int NumeratorOffset {get; set;}

Remarks

See Also

FindFolderParentType Class | Aspose.Email.Exchange.Schema Namespace


NumeratorOffsetSpecified Property

Aspose.Email

FindFolderParentType.NumeratorOffsetSpecified Property

public bool NumeratorOffsetSpecified {get; set;}

Remarks

See Also

FindFolderParentType Class | Aspose.Email.Exchange.Schema Namespace


TotalItemsInView Property

Aspose.Email

FindFolderParentType.TotalItemsInView Property

public int TotalItemsInView {get; set;}

Remarks

See Also

FindFolderParentType Class | Aspose.Email.Exchange.Schema Namespace


TotalItemsInViewSpecified Property

Aspose.Email

FindFolderParentType.TotalItemsInViewSpecified Property

public bool TotalItemsInViewSpecified {get; set;}

Remarks

See Also

FindFolderParentType Class | Aspose.Email.Exchange.Schema Namespace


FindFolderResponseMessageType Class

For a list of all members of this type, see FindFolderResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ResponseMessageType
Aspose.Email.Exchange.Schema.FindFolderResponseMessageType

public class FindFolderResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FindFolderResponseMessageType Members | Aspose.Email.Exchange.Schema Namespace


FindFolderResponseMessageType Members

FindFolderResponseMessageType overview

Public Instance Constructors

FindFolderResponseMessageType Constructor Initializes a new instance of the FindFolderResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
RootFolder

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FindFolderResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


FindFolderResponseMessageType Constructor

Initializes a new instance of the FindFolderResponseMessageType class.

public FindFolderResponseMessageType();

See Also

FindFolderResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


FindFolderResponseMessageType Properties

The properties of the FindFolderResponseMessageType class are listed below. For a complete list of FindFolderResponseMessageType class members, see the FindFolderResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
RootFolder

See Also

FindFolderResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


RootFolder Property

Aspose.Email

FindFolderResponseMessageType.RootFolder Property

public FindFolderParentType RootFolder {get; set;}

Remarks

See Also

FindFolderResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


FindFolderResponseType Class

For a list of all members of this type, see FindFolderResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseResponseMessageType
Aspose.Email.Exchange.Schema.FindFolderResponseType

public class FindFolderResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FindFolderResponseType Members | Aspose.Email.Exchange.Schema Namespace


FindFolderResponseType Members

FindFolderResponseType overview

Public Instance Constructors

FindFolderResponseType Constructor Initializes a new instance of the FindFolderResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FindFolderResponseType Class | Aspose.Email.Exchange.Schema Namespace


FindFolderResponseType Constructor

Initializes a new instance of the FindFolderResponseType class.

public FindFolderResponseType();

See Also

FindFolderResponseType Class | Aspose.Email.Exchange.Schema Namespace


FindFolderType Class

For a list of all members of this type, see FindFolderType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.FindFolderType

public class FindFolderType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FindFolderType Members | Aspose.Email.Exchange.Schema Namespace


FindFolderType Members

FindFolderType overview

Public Instance Constructors

FindFolderType Constructor Initializes a new instance of the FindFolderType class.

Public Instance Properties

FolderShape
Item
ParentFolderIds
Restriction
Traversal

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FindFolderType Class | Aspose.Email.Exchange.Schema Namespace


FindFolderType Constructor

Initializes a new instance of the FindFolderType class.

public FindFolderType();

See Also

FindFolderType Class | Aspose.Email.Exchange.Schema Namespace


FindFolderType Properties

The properties of the FindFolderType class are listed below. For a complete list of FindFolderType class members, see the FindFolderType Members topic.

Public Instance Properties

FolderShape
Item
ParentFolderIds
Restriction
Traversal

See Also

FindFolderType Class | Aspose.Email.Exchange.Schema Namespace


FolderShape Property

Aspose.Email

FindFolderType.FolderShape Property

public FolderResponseShapeType FolderShape {get; set;}

Remarks

See Also

FindFolderType Class | Aspose.Email.Exchange.Schema Namespace


Item Property

Aspose.Email

FindFolderType.Item Property

public BasePagingType Item {get; set;}

Remarks

See Also

FindFolderType Class | Aspose.Email.Exchange.Schema Namespace


ParentFolderIds Property

Aspose.Email

FindFolderType.ParentFolderIds Property

public BaseFolderIdType[] ParentFolderIds {get; set;}

Remarks

See Also

FindFolderType Class | Aspose.Email.Exchange.Schema Namespace


Restriction Property

Aspose.Email

FindFolderType.Restriction Property

public RestrictionType Restriction {get; set;}

Remarks

See Also

FindFolderType Class | Aspose.Email.Exchange.Schema Namespace


Traversal Property

Aspose.Email

FindFolderType.Traversal Property

public FolderQueryTraversalType Traversal {get; set;}

Remarks

See Also

FindFolderType Class | Aspose.Email.Exchange.Schema Namespace


FindItemCompletedEventArgs Class

For a list of all members of this type, see FindItemCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.FindItemCompletedEventArgs

public class FindItemCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FindItemCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


FindItemCompletedEventArgs Members

FindItemCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

FindItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


FindItemCompletedEventArgs Properties

The properties of the FindItemCompletedEventArgs class are listed below. For a complete list of FindItemCompletedEventArgs class members, see the FindItemCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

FindItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

FindItemCompletedEventArgs.Result Property

public FindItemResponseType Result {get;}

Remarks

See Also

FindItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


FindItemCompletedEventHandler Delegate

public delegate void FindItemCompletedEventHandler(
object sender,
FindItemCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


FindItemParentType Class

For a list of all members of this type, see FindItemParentType Members.

System.Object
Aspose.Email.Exchange.Schema.FindItemParentType

public class FindItemParentType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FindItemParentType Members | Aspose.Email.Exchange.Schema Namespace


FindItemParentType Members

FindItemParentType overview

Public Instance Constructors

FindItemParentType Constructor Initializes a new instance of the FindItemParentType class.

Public Instance Properties

AbsoluteDenominator
AbsoluteDenominatorSpecified
IncludesLastItemInRange
IncludesLastItemInRangeSpecified
IndexedPagingOffset
IndexedPagingOffsetSpecified
Item
NumeratorOffset
NumeratorOffsetSpecified
TotalItemsInView
TotalItemsInViewSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FindItemParentType Class | Aspose.Email.Exchange.Schema Namespace


FindItemParentType Constructor

Initializes a new instance of the FindItemParentType class.

public FindItemParentType();

See Also

FindItemParentType Class | Aspose.Email.Exchange.Schema Namespace


FindItemParentType Properties

The properties of the FindItemParentType class are listed below. For a complete list of FindItemParentType class members, see the FindItemParentType Members topic.

Public Instance Properties

AbsoluteDenominator
AbsoluteDenominatorSpecified
IncludesLastItemInRange
IncludesLastItemInRangeSpecified
IndexedPagingOffset
IndexedPagingOffsetSpecified
Item
NumeratorOffset
NumeratorOffsetSpecified
TotalItemsInView
TotalItemsInViewSpecified

See Also

FindItemParentType Class | Aspose.Email.Exchange.Schema Namespace


AbsoluteDenominator Property

Aspose.Email

FindItemParentType.AbsoluteDenominator Property

public int AbsoluteDenominator {get; set;}

Remarks

See Also

FindItemParentType Class | Aspose.Email.Exchange.Schema Namespace


AbsoluteDenominatorSpecified Property

Aspose.Email

FindItemParentType.AbsoluteDenominatorSpecified Property

public bool AbsoluteDenominatorSpecified {get; set;}

Remarks

See Also

FindItemParentType Class | Aspose.Email.Exchange.Schema Namespace


IncludesLastItemInRange Property

Aspose.Email

FindItemParentType.IncludesLastItemInRange Property

public bool IncludesLastItemInRange {get; set;}

Remarks

See Also

FindItemParentType Class | Aspose.Email.Exchange.Schema Namespace


IncludesLastItemInRangeSpecified Property

Aspose.Email

FindItemParentType.IncludesLastItemInRangeSpecified Property

public bool IncludesLastItemInRangeSpecified {get; set;}

Remarks

See Also

FindItemParentType Class | Aspose.Email.Exchange.Schema Namespace


IndexedPagingOffset Property

Aspose.Email

FindItemParentType.IndexedPagingOffset Property

public int IndexedPagingOffset {get; set;}

Remarks

See Also

FindItemParentType Class | Aspose.Email.Exchange.Schema Namespace


IndexedPagingOffsetSpecified Property

Aspose.Email

FindItemParentType.IndexedPagingOffsetSpecified Property

public bool IndexedPagingOffsetSpecified {get; set;}

Remarks

See Also

FindItemParentType Class | Aspose.Email.Exchange.Schema Namespace


Item Property

Aspose.Email

FindItemParentType.Item Property

public object Item {get; set;}

Remarks

See Also

FindItemParentType Class | Aspose.Email.Exchange.Schema Namespace


NumeratorOffset Property

Aspose.Email

FindItemParentType.NumeratorOffset Property

public int NumeratorOffset {get; set;}

Remarks

See Also

FindItemParentType Class | Aspose.Email.Exchange.Schema Namespace


NumeratorOffsetSpecified Property

Aspose.Email

FindItemParentType.NumeratorOffsetSpecified Property

public bool NumeratorOffsetSpecified {get; set;}

Remarks

See Also

FindItemParentType Class | Aspose.Email.Exchange.Schema Namespace


TotalItemsInView Property

Aspose.Email

FindItemParentType.TotalItemsInView Property

public int TotalItemsInView {get; set;}

Remarks

See Also

FindItemParentType Class | Aspose.Email.Exchange.Schema Namespace


TotalItemsInViewSpecified Property

Aspose.Email

FindItemParentType.TotalItemsInViewSpecified Property

public bool TotalItemsInViewSpecified {get; set;}

Remarks

See Also

FindItemParentType Class | Aspose.Email.Exchange.Schema Namespace


FindItemResponseMessageType Class

For a list of all members of this type, see FindItemResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ResponseMessageType
Aspose.Email.Exchange.Schema.FindItemResponseMessageType

public class FindItemResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FindItemResponseMessageType Members | Aspose.Email.Exchange.Schema Namespace


FindItemResponseMessageType Members

FindItemResponseMessageType overview

Public Instance Constructors

FindItemResponseMessageType Constructor Initializes a new instance of the FindItemResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
RootFolder

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FindItemResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


FindItemResponseMessageType Constructor

Initializes a new instance of the FindItemResponseMessageType class.

public FindItemResponseMessageType();

See Also

FindItemResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


FindItemResponseMessageType Properties

The properties of the FindItemResponseMessageType class are listed below. For a complete list of FindItemResponseMessageType class members, see the FindItemResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
RootFolder

See Also

FindItemResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


RootFolder Property

Aspose.Email

FindItemResponseMessageType.RootFolder Property

public FindItemParentType RootFolder {get; set;}

Remarks

See Also

FindItemResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


FindItemResponseType Class

For a list of all members of this type, see FindItemResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseResponseMessageType
Aspose.Email.Exchange.Schema.FindItemResponseType

public class FindItemResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FindItemResponseType Members | Aspose.Email.Exchange.Schema Namespace


FindItemResponseType Members

FindItemResponseType overview

Public Instance Constructors

FindItemResponseType Constructor Initializes a new instance of the FindItemResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FindItemResponseType Class | Aspose.Email.Exchange.Schema Namespace


FindItemResponseType Constructor

Initializes a new instance of the FindItemResponseType class.

public FindItemResponseType();

See Also

FindItemResponseType Class | Aspose.Email.Exchange.Schema Namespace


FindItemType Class

For a list of all members of this type, see FindItemType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.FindItemType

public class FindItemType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FindItemType Members | Aspose.Email.Exchange.Schema Namespace


FindItemType Members

FindItemType overview

Public Instance Constructors

FindItemType Constructor Initializes a new instance of the FindItemType class.

Public Instance Properties

Item
Item1
ItemShape
ParentFolderIds
QueryString
Restriction
SortOrder
Traversal

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FindItemType Class | Aspose.Email.Exchange.Schema Namespace


FindItemType Constructor

Initializes a new instance of the FindItemType class.

public FindItemType();

See Also

FindItemType Class | Aspose.Email.Exchange.Schema Namespace


FindItemType Properties

The properties of the FindItemType class are listed below. For a complete list of FindItemType class members, see the FindItemType Members topic.

Public Instance Properties

Item
Item1
ItemShape
ParentFolderIds
QueryString
Restriction
SortOrder
Traversal

See Also

FindItemType Class | Aspose.Email.Exchange.Schema Namespace


Item Property

Aspose.Email

FindItemType.Item Property

public BasePagingType Item {get; set;}

Remarks

See Also

FindItemType Class | Aspose.Email.Exchange.Schema Namespace


Item1 Property

Aspose.Email

FindItemType.Item1 Property

public BaseGroupByType Item1 {get; set;}

Remarks

See Also

FindItemType Class | Aspose.Email.Exchange.Schema Namespace


ItemShape Property

Aspose.Email

FindItemType.ItemShape Property

public ItemResponseShapeType ItemShape {get; set;}

Remarks

See Also

FindItemType Class | Aspose.Email.Exchange.Schema Namespace


ParentFolderIds Property

Aspose.Email

FindItemType.ParentFolderIds Property

public BaseFolderIdType[] ParentFolderIds {get; set;}

Remarks

See Also

FindItemType Class | Aspose.Email.Exchange.Schema Namespace


QueryString Property

Aspose.Email

FindItemType.QueryString Property

public string QueryString {get; set;}

Remarks

See Also

FindItemType Class | Aspose.Email.Exchange.Schema Namespace


Restriction Property

Aspose.Email

FindItemType.Restriction Property

public RestrictionType Restriction {get; set;}

Remarks

See Also

FindItemType Class | Aspose.Email.Exchange.Schema Namespace


SortOrder Property

Aspose.Email

FindItemType.SortOrder Property

public FieldOrderType[] SortOrder {get; set;}

Remarks

See Also

FindItemType Class | Aspose.Email.Exchange.Schema Namespace


Traversal Property

Aspose.Email

FindItemType.Traversal Property

public ItemQueryTraversalType Traversal {get; set;}

Remarks

See Also

FindItemType Class | Aspose.Email.Exchange.Schema Namespace


FindMailboxStatisticsByKeywordsResponseMessageType Class

For a list of all members of this type, see FindMailboxStatisticsByKeywordsResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ResponseMessageType
Aspose.Email.Exchange.Schema.FindMailboxStatisticsByKeywordsResponseMessageType

public class FindMailboxStatisticsByKeywordsResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FindMailboxStatisticsByKeywordsResponseMessageType Members | Aspose.Email.Exchange.Schema Namespace


FindMailboxStatisticsByKeywordsResponseMessageType Members

FindMailboxStatisticsByKeywordsResponseMessageType overview

Public Instance Constructors

FindMailboxStatisticsByKeywordsResponseMessageType Constructor Initializes a new instance of the FindMailboxStatisticsByKeywordsResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MailboxStatisticsSearchResult
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FindMailboxStatisticsByKeywordsResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


FindMailboxStatisticsByKeywordsResponseMessageType Constructor

Initializes a new instance of the FindMailboxStatisticsByKeywordsResponseMessageType class.

public FindMailboxStatisticsByKeywordsResponseMessageType();

See Also

FindMailboxStatisticsByKeywordsResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


FindMailboxStatisticsByKeywordsResponseMessageType Properties

The properties of the FindMailboxStatisticsByKeywordsResponseMessageType class are listed below. For a complete list of FindMailboxStatisticsByKeywordsResponseMessageType class members, see the FindMailboxStatisticsByKeywordsResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MailboxStatisticsSearchResult
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

FindMailboxStatisticsByKeywordsResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


MailboxStatisticsSearchResult Property

Aspose.Email

FindMailboxStatisticsByKeywordsResponseMessageType.MailboxStatisticsSearchResult Property

public MailboxStatisticsSearchResultType MailboxStatisticsSearchResult {get; set;}

Remarks

See Also

FindMailboxStatisticsByKeywordsResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


FindMailboxStatisticsByKeywordsResponseType Class

For a list of all members of this type, see FindMailboxStatisticsByKeywordsResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseResponseMessageType
Aspose.Email.Exchange.Schema.FindMailboxStatisticsByKeywordsResponseType

public class FindMailboxStatisticsByKeywordsResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FindMailboxStatisticsByKeywordsResponseType Members | Aspose.Email.Exchange.Schema Namespace


FindMailboxStatisticsByKeywordsResponseType Members

FindMailboxStatisticsByKeywordsResponseType overview

Public Instance Constructors

FindMailboxStatisticsByKeywordsResponseType Constructor Initializes a new instance of the FindMailboxStatisticsByKeywordsResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FindMailboxStatisticsByKeywordsResponseType Class | Aspose.Email.Exchange.Schema Namespace


FindMailboxStatisticsByKeywordsResponseType Constructor

Initializes a new instance of the FindMailboxStatisticsByKeywordsResponseType class.

public FindMailboxStatisticsByKeywordsResponseType();

See Also

FindMailboxStatisticsByKeywordsResponseType Class | Aspose.Email.Exchange.Schema Namespace


FindMailboxStatisticsByKeywordsType Class

For a list of all members of this type, see FindMailboxStatisticsByKeywordsType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.FindMailboxStatisticsByKeywordsType

public class FindMailboxStatisticsByKeywordsType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FindMailboxStatisticsByKeywordsType Members | Aspose.Email.Exchange.Schema Namespace


FindMailboxStatisticsByKeywordsType Members

FindMailboxStatisticsByKeywordsType overview

Public Instance Constructors

FindMailboxStatisticsByKeywordsType Constructor Initializes a new instance of the FindMailboxStatisticsByKeywordsType class.

Public Instance Properties

FromDate
FromDateSpecified
IncludePersonalArchive
IncludePersonalArchiveSpecified
IncludeUnsearchableItems
IncludeUnsearchableItemsSpecified
Keywords
Language
Mailboxes
MessageTypes
Recipients
SearchDumpster
SearchDumpsterSpecified
Senders
ToDate
ToDateSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FindMailboxStatisticsByKeywordsType Class | Aspose.Email.Exchange.Schema Namespace


FindMailboxStatisticsByKeywordsType Constructor

Initializes a new instance of the FindMailboxStatisticsByKeywordsType class.

public FindMailboxStatisticsByKeywordsType();

See Also

FindMailboxStatisticsByKeywordsType Class | Aspose.Email.Exchange.Schema Namespace


FindMailboxStatisticsByKeywordsType Properties

The properties of the FindMailboxStatisticsByKeywordsType class are listed below. For a complete list of FindMailboxStatisticsByKeywordsType class members, see the FindMailboxStatisticsByKeywordsType Members topic.

Public Instance Properties

FromDate
FromDateSpecified
IncludePersonalArchive
IncludePersonalArchiveSpecified
IncludeUnsearchableItems
IncludeUnsearchableItemsSpecified
Keywords
Language
Mailboxes
MessageTypes
Recipients
SearchDumpster
SearchDumpsterSpecified
Senders
ToDate
ToDateSpecified

See Also

FindMailboxStatisticsByKeywordsType Class | Aspose.Email.Exchange.Schema Namespace


FromDate Property

Aspose.Email

FindMailboxStatisticsByKeywordsType.FromDate Property

public DateTime FromDate {get; set;}

Remarks

See Also

FindMailboxStatisticsByKeywordsType Class | Aspose.Email.Exchange.Schema Namespace


FromDateSpecified Property

Aspose.Email

FindMailboxStatisticsByKeywordsType.FromDateSpecified Property

public bool FromDateSpecified {get; set;}

Remarks

See Also

FindMailboxStatisticsByKeywordsType Class | Aspose.Email.Exchange.Schema Namespace


IncludePersonalArchive Property

Aspose.Email

FindMailboxStatisticsByKeywordsType.IncludePersonalArchive Property

public bool IncludePersonalArchive {get; set;}

Remarks

See Also

FindMailboxStatisticsByKeywordsType Class | Aspose.Email.Exchange.Schema Namespace


IncludePersonalArchiveSpecified Property

Aspose.Email

FindMailboxStatisticsByKeywordsType.IncludePersonalArchiveSpecified Property

public bool IncludePersonalArchiveSpecified {get; set;}

Remarks

See Also

FindMailboxStatisticsByKeywordsType Class | Aspose.Email.Exchange.Schema Namespace


IncludeUnsearchableItems Property

Aspose.Email

FindMailboxStatisticsByKeywordsType.IncludeUnsearchableItems Property

public bool IncludeUnsearchableItems {get; set;}

Remarks

See Also

FindMailboxStatisticsByKeywordsType Class | Aspose.Email.Exchange.Schema Namespace


IncludeUnsearchableItemsSpecified Property

Aspose.Email

FindMailboxStatisticsByKeywordsType.IncludeUnsearchableItemsSpecified Property

public bool IncludeUnsearchableItemsSpecified {get; set;}

Remarks

See Also

FindMailboxStatisticsByKeywordsType Class | Aspose.Email.Exchange.Schema Namespace


Keywords Property

Aspose.Email

FindMailboxStatisticsByKeywordsType.Keywords Property

public string[] Keywords {get; set;}

Remarks

See Also

FindMailboxStatisticsByKeywordsType Class | Aspose.Email.Exchange.Schema Namespace


Language Property

Aspose.Email

FindMailboxStatisticsByKeywordsType.Language Property

public string Language {get; set;}

Remarks

See Also

FindMailboxStatisticsByKeywordsType Class | Aspose.Email.Exchange.Schema Namespace


Mailboxes Property

Aspose.Email

FindMailboxStatisticsByKeywordsType.Mailboxes Property

public UserMailboxType[] Mailboxes {get; set;}

Remarks

See Also

FindMailboxStatisticsByKeywordsType Class | Aspose.Email.Exchange.Schema Namespace


MessageTypes Property

Aspose.Email

FindMailboxStatisticsByKeywordsType.MessageTypes Property

public SearchItemKindType[] MessageTypes {get; set;}

Remarks

See Also

FindMailboxStatisticsByKeywordsType Class | Aspose.Email.Exchange.Schema Namespace


Recipients Property

Aspose.Email

FindMailboxStatisticsByKeywordsType.Recipients Property

public string[] Recipients {get; set;}

Remarks

See Also

FindMailboxStatisticsByKeywordsType Class | Aspose.Email.Exchange.Schema Namespace


SearchDumpster Property

Aspose.Email

FindMailboxStatisticsByKeywordsType.SearchDumpster Property

public bool SearchDumpster {get; set;}

Remarks

See Also

FindMailboxStatisticsByKeywordsType Class | Aspose.Email.Exchange.Schema Namespace


SearchDumpsterSpecified Property

Aspose.Email

FindMailboxStatisticsByKeywordsType.SearchDumpsterSpecified Property

public bool SearchDumpsterSpecified {get; set;}

Remarks

See Also

FindMailboxStatisticsByKeywordsType Class | Aspose.Email.Exchange.Schema Namespace


Senders Property

Aspose.Email

FindMailboxStatisticsByKeywordsType.Senders Property

public string[] Senders {get; set;}

Remarks

See Also

FindMailboxStatisticsByKeywordsType Class | Aspose.Email.Exchange.Schema Namespace


ToDate Property

Aspose.Email

FindMailboxStatisticsByKeywordsType.ToDate Property

public DateTime ToDate {get; set;}

Remarks

See Also

FindMailboxStatisticsByKeywordsType Class | Aspose.Email.Exchange.Schema Namespace


ToDateSpecified Property

Aspose.Email

FindMailboxStatisticsByKeywordsType.ToDateSpecified Property

public bool ToDateSpecified {get; set;}

Remarks

See Also

FindMailboxStatisticsByKeywordsType Class | Aspose.Email.Exchange.Schema Namespace


FindMessageTrackingReportCompletedEventArgs Class

For a list of all members of this type, see FindMessageTrackingReportCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.FindMessageTrackingReportCompletedEventArgs

public class FindMessageTrackingReportCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FindMessageTrackingReportCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


FindMessageTrackingReportCompletedEventArgs Members

FindMessageTrackingReportCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

FindMessageTrackingReportCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


FindMessageTrackingReportCompletedEventArgs Properties

The properties of the FindMessageTrackingReportCompletedEventArgs class are listed below. For a complete list of FindMessageTrackingReportCompletedEventArgs class members, see the FindMessageTrackingReportCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

FindMessageTrackingReportCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

FindMessageTrackingReportCompletedEventArgs.Result Property

public FindMessageTrackingReportResponseMessageType Result {get;}

Remarks

See Also

FindMessageTrackingReportCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


FindMessageTrackingReportCompletedEventHandler Delegate

public delegate void FindMessageTrackingReportCompletedEventHandler(
object sender,
FindMessageTrackingReportCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


FindMessageTrackingReportRequestType Class

For a list of all members of this type, see FindMessageTrackingReportRequestType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.FindMessageTrackingReportRequestType

public class FindMessageTrackingReportRequestType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FindMessageTrackingReportRequestType Members | Aspose.Email.Exchange.Schema Namespace


FindMessageTrackingReportRequestType Members

FindMessageTrackingReportRequestType overview

Public Instance Constructors

FindMessageTrackingReportRequestType Constructor Initializes a new instance of the FindMessageTrackingReportRequestType class.

Public Instance Properties

DiagnosticsLevel
Domain
EndDateTime
EndDateTimeSpecified
FederatedDeliveryMailbox
MessageId
Properties
PurportedSender
Recipient
Scope
Sender
ServerHint
StartDateTime
StartDateTimeSpecified
Subject

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FindMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema Namespace


FindMessageTrackingReportRequestType Constructor

Initializes a new instance of the FindMessageTrackingReportRequestType class.

public FindMessageTrackingReportRequestType();

See Also

FindMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema Namespace


FindMessageTrackingReportRequestType Properties

The properties of the FindMessageTrackingReportRequestType class are listed below. For a complete list of FindMessageTrackingReportRequestType class members, see the FindMessageTrackingReportRequestType Members topic.

Public Instance Properties

DiagnosticsLevel
Domain
EndDateTime
EndDateTimeSpecified
FederatedDeliveryMailbox
MessageId
Properties
PurportedSender
Recipient
Scope
Sender
ServerHint
StartDateTime
StartDateTimeSpecified
Subject

See Also

FindMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema Namespace


DiagnosticsLevel Property

Aspose.Email

FindMessageTrackingReportRequestType.DiagnosticsLevel Property

public string DiagnosticsLevel {get; set;}

Remarks

See Also

FindMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema Namespace


Domain Property

Aspose.Email

FindMessageTrackingReportRequestType.Domain Property

public string Domain {get; set;}

Remarks

See Also

FindMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema Namespace


EndDateTime Property

Aspose.Email

FindMessageTrackingReportRequestType.EndDateTime Property

public DateTime EndDateTime {get; set;}

Remarks

See Also

FindMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema Namespace


EndDateTimeSpecified Property

Aspose.Email

FindMessageTrackingReportRequestType.EndDateTimeSpecified Property

public bool EndDateTimeSpecified {get; set;}

Remarks

See Also

FindMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema Namespace


FederatedDeliveryMailbox Property

Aspose.Email

FindMessageTrackingReportRequestType.FederatedDeliveryMailbox Property

public EmailAddressType FederatedDeliveryMailbox {get; set;}

Remarks

See Also

FindMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema Namespace


MessageId Property

Aspose.Email

FindMessageTrackingReportRequestType.MessageId Property

public string MessageId {get; set;}

Remarks

See Also

FindMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema Namespace


Properties Property

Aspose.Email

FindMessageTrackingReportRequestType.Properties Property

public TrackingPropertyType[] Properties {get; set;}

Remarks

See Also

FindMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema Namespace


PurportedSender Property

Aspose.Email

FindMessageTrackingReportRequestType.PurportedSender Property

public EmailAddressType PurportedSender {get; set;}

Remarks

See Also

FindMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema Namespace


Recipient Property

Aspose.Email

FindMessageTrackingReportRequestType.Recipient Property

public EmailAddressType Recipient {get; set;}

Remarks

See Also

FindMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema Namespace


Scope Property

Aspose.Email

FindMessageTrackingReportRequestType.Scope Property

public string Scope {get; set;}

Remarks

See Also

FindMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema Namespace


Sender Property

Aspose.Email

FindMessageTrackingReportRequestType.Sender Property

public EmailAddressType Sender {get; set;}

Remarks

See Also

FindMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema Namespace


ServerHint Property

Aspose.Email

FindMessageTrackingReportRequestType.ServerHint Property

public string ServerHint {get; set;}

Remarks

See Also

FindMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema Namespace


StartDateTime Property

Aspose.Email

FindMessageTrackingReportRequestType.StartDateTime Property

public DateTime StartDateTime {get; set;}

Remarks

See Also

FindMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema Namespace


StartDateTimeSpecified Property

Aspose.Email

FindMessageTrackingReportRequestType.StartDateTimeSpecified Property

public bool StartDateTimeSpecified {get; set;}

Remarks

See Also

FindMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema Namespace


Subject Property

Aspose.Email

FindMessageTrackingReportRequestType.Subject Property

public string Subject {get; set;}

Remarks

See Also

FindMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema Namespace


FindMessageTrackingReportResponseMessageType Class

For a list of all members of this type, see FindMessageTrackingReportResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ResponseMessageType
Aspose.Email.Exchange.Schema.FindMessageTrackingReportResponseMessageType

public class FindMessageTrackingReportResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FindMessageTrackingReportResponseMessageType Members | Aspose.Email.Exchange.Schema Namespace


FindMessageTrackingReportResponseMessageType Members

FindMessageTrackingReportResponseMessageType overview

Public Instance Constructors

FindMessageTrackingReportResponseMessageType Constructor Initializes a new instance of the FindMessageTrackingReportResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
Diagnostics
Errors
ExecutedSearchScope
MessageText (inherited from ResponseMessageType)
MessageTrackingSearchResults
MessageXml (inherited from ResponseMessageType)
Properties
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FindMessageTrackingReportResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


FindMessageTrackingReportResponseMessageType Constructor

Initializes a new instance of the FindMessageTrackingReportResponseMessageType class.

public FindMessageTrackingReportResponseMessageType();

See Also

FindMessageTrackingReportResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


FindMessageTrackingReportResponseMessageType Properties

The properties of the FindMessageTrackingReportResponseMessageType class are listed below. For a complete list of FindMessageTrackingReportResponseMessageType class members, see the FindMessageTrackingReportResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
Diagnostics
Errors
ExecutedSearchScope
MessageText (inherited from ResponseMessageType)
MessageTrackingSearchResults
MessageXml (inherited from ResponseMessageType)
Properties
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

FindMessageTrackingReportResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


Diagnostics Property

Aspose.Email

FindMessageTrackingReportResponseMessageType.Diagnostics Property

public string[] Diagnostics {get; set;}

Remarks

See Also

FindMessageTrackingReportResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


Errors Property

Aspose.Email

FindMessageTrackingReportResponseMessageType.Errors Property

public ArrayOfTrackingPropertiesType[] Errors {get; set;}

Remarks

See Also

FindMessageTrackingReportResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


ExecutedSearchScope Property

Aspose.Email

FindMessageTrackingReportResponseMessageType.ExecutedSearchScope Property

public string ExecutedSearchScope {get; set;}

Remarks

See Also

FindMessageTrackingReportResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


MessageTrackingSearchResults Property

Aspose.Email

FindMessageTrackingReportResponseMessageType.MessageTrackingSearchResults Property

public FindMessageTrackingSearchResultType[] MessageTrackingSearchResults {get; set;}

Remarks

See Also

FindMessageTrackingReportResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


Properties Property

Aspose.Email

FindMessageTrackingReportResponseMessageType.Properties Property

public TrackingPropertyType[] Properties {get; set;}

Remarks

See Also

FindMessageTrackingReportResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


FindMessageTrackingSearchResultType Class

For a list of all members of this type, see FindMessageTrackingSearchResultType Members.

System.Object
Aspose.Email.Exchange.Schema.FindMessageTrackingSearchResultType

public class FindMessageTrackingSearchResultType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FindMessageTrackingSearchResultType Members | Aspose.Email.Exchange.Schema Namespace


FindMessageTrackingSearchResultType Members

FindMessageTrackingSearchResultType overview

Public Instance Constructors

FindMessageTrackingSearchResultType Constructor Initializes a new instance of the FindMessageTrackingSearchResultType class.

Public Instance Properties

FirstHopServer
MessageTrackingReportId
PreviousHopServer
Properties
PurportedSender
Recipients
Sender
Subject
SubmittedTime

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FindMessageTrackingSearchResultType Class | Aspose.Email.Exchange.Schema Namespace


FindMessageTrackingSearchResultType Constructor

Initializes a new instance of the FindMessageTrackingSearchResultType class.

public FindMessageTrackingSearchResultType();

See Also

FindMessageTrackingSearchResultType Class | Aspose.Email.Exchange.Schema Namespace


FindMessageTrackingSearchResultType Properties

The properties of the FindMessageTrackingSearchResultType class are listed below. For a complete list of FindMessageTrackingSearchResultType class members, see the FindMessageTrackingSearchResultType Members topic.

Public Instance Properties

FirstHopServer
MessageTrackingReportId
PreviousHopServer
Properties
PurportedSender
Recipients
Sender
Subject
SubmittedTime

See Also

FindMessageTrackingSearchResultType Class | Aspose.Email.Exchange.Schema Namespace


FirstHopServer Property

Aspose.Email

FindMessageTrackingSearchResultType.FirstHopServer Property

public string FirstHopServer {get; set;}

Remarks

See Also

FindMessageTrackingSearchResultType Class | Aspose.Email.Exchange.Schema Namespace


MessageTrackingReportId Property

Aspose.Email

FindMessageTrackingSearchResultType.MessageTrackingReportId Property

public string MessageTrackingReportId {get; set;}

Remarks

See Also

FindMessageTrackingSearchResultType Class | Aspose.Email.Exchange.Schema Namespace


PreviousHopServer Property

Aspose.Email

FindMessageTrackingSearchResultType.PreviousHopServer Property

public string PreviousHopServer {get; set;}

Remarks

See Also

FindMessageTrackingSearchResultType Class | Aspose.Email.Exchange.Schema Namespace


Properties Property

Aspose.Email

FindMessageTrackingSearchResultType.Properties Property

public TrackingPropertyType[] Properties {get; set;}

Remarks

See Also

FindMessageTrackingSearchResultType Class | Aspose.Email.Exchange.Schema Namespace


PurportedSender Property

Aspose.Email

FindMessageTrackingSearchResultType.PurportedSender Property

public EmailAddressType PurportedSender {get; set;}

Remarks

See Also

FindMessageTrackingSearchResultType Class | Aspose.Email.Exchange.Schema Namespace


Recipients Property

Aspose.Email

FindMessageTrackingSearchResultType.Recipients Property

public EmailAddressType[] Recipients {get; set;}

Remarks

See Also

FindMessageTrackingSearchResultType Class | Aspose.Email.Exchange.Schema Namespace


Sender Property

Aspose.Email

FindMessageTrackingSearchResultType.Sender Property

public EmailAddressType Sender {get; set;}

Remarks

See Also

FindMessageTrackingSearchResultType Class | Aspose.Email.Exchange.Schema Namespace


Subject Property

Aspose.Email

FindMessageTrackingSearchResultType.Subject Property

public string Subject {get; set;}

Remarks

See Also

FindMessageTrackingSearchResultType Class | Aspose.Email.Exchange.Schema Namespace


SubmittedTime Property

Aspose.Email

FindMessageTrackingSearchResultType.SubmittedTime Property

public DateTime SubmittedTime {get; set;}

Remarks

See Also

FindMessageTrackingSearchResultType Class | Aspose.Email.Exchange.Schema Namespace


FlaggedForActionType Enumeration

Enumerates FlaggedForActionType

public enum FlaggedForActionType

Members

Member Name | Description | Value
Any | The message is flagged with any action. | 0
Call | The recipient is requested to call the sender. | 1
DoNotForward | The recipient is requested not to forward the message. | 2
FollowUp | The recipient is requested to follow up on the message. | 3
FYI | The recipient received the message for information. | 4
Forward | The recipient is requested to forward the message. | 5
NoResponseNecessary | The recipient is informed that a response to the messageis not required. | 6
Read | The recipient is requested to read the message. | 7
Reply | The recipient is requested to reply to the sender of the message. | 8
ReplyToAll | The recipient is requested to reply to everyone the message was sent to. | 9
Review | The recipient is requested to review the message. | 10

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


FlagStatusType Enumeration

Enumerates the flag status for conversation items.

public enum FlagStatusType

Members

Member Name | Description | Value
NotFlagged | Specifies the not-flagged status. | 0
Flagged | Specifies the flagged flag status. | 1
Complete | Specifies the complete flag status. | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


FolderChangeDescriptionType Class

For a list of all members of this type, see FolderChangeDescriptionType Members.

System.Object
Aspose.Email.Exchange.Schema.ChangeDescriptionType
Aspose.Email.Exchange.Schema.FolderChangeDescriptionType
Aspose.Email.Exchange.Schema.AppendToFolderFieldType
Aspose.Email.Exchange.Schema.DeleteFolderFieldType
Aspose.Email.Exchange.Schema.SetFolderFieldType

public class FolderChangeDescriptionType : ChangeDescriptionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FolderChangeDescriptionType Members | Aspose.Email.Exchange.Schema Namespace


FolderChangeDescriptionType Members

FolderChangeDescriptionType overview

Public Instance Constructors

FolderChangeDescriptionType Constructor Initializes a new instance of the FolderChangeDescriptionType class.

Public Instance Properties

Item (inherited from ChangeDescriptionType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FolderChangeDescriptionType Class | Aspose.Email.Exchange.Schema Namespace


FolderChangeDescriptionType Constructor

Initializes a new instance of the FolderChangeDescriptionType class.

public FolderChangeDescriptionType();

See Also

FolderChangeDescriptionType Class | Aspose.Email.Exchange.Schema Namespace


FolderChangeType Class

For a list of all members of this type, see FolderChangeType Members.

System.Object
Aspose.Email.Exchange.Schema.FolderChangeType

public class FolderChangeType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FolderChangeType Members | Aspose.Email.Exchange.Schema Namespace


FolderChangeType Members

FolderChangeType overview

Public Instance Constructors

FolderChangeType Constructor Initializes a new instance of the FolderChangeType class.

Public Instance Properties

Item
Updates

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FolderChangeType Class | Aspose.Email.Exchange.Schema Namespace


FolderChangeType Constructor

Initializes a new instance of the FolderChangeType class.

public FolderChangeType();

See Also

FolderChangeType Class | Aspose.Email.Exchange.Schema Namespace


FolderChangeType Properties

The properties of the FolderChangeType class are listed below. For a complete list of FolderChangeType class members, see the FolderChangeType Members topic.

Public Instance Properties

Item
Updates

See Also

FolderChangeType Class | Aspose.Email.Exchange.Schema Namespace


Item Property

Aspose.Email

FolderChangeType.Item Property

public BaseFolderIdType Item {get; set;}

Remarks

See Also

FolderChangeType Class | Aspose.Email.Exchange.Schema Namespace


Updates Property

Aspose.Email

FolderChangeType.Updates Property

public FolderChangeDescriptionType[] Updates {get; set;}

Remarks

See Also

FolderChangeType Class | Aspose.Email.Exchange.Schema Namespace


FolderIdType Class

The FolderIdType class identifies a folder.

For a list of all members of this type, see FolderIdType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseFolderIdType
Aspose.Email.Exchange.Schema.FolderIdType

public class FolderIdType : BaseFolderIdType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FolderIdType Members | Aspose.Email.Exchange.Schema Namespace


FolderIdType Members

FolderIdType overview

Public Instance Constructors

FolderIdType Constructor Initializes a new instance of the FolderIdType class.

Public Instance Properties

ChangeKey
Id

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FolderIdType Class | Aspose.Email.Exchange.Schema Namespace


FolderIdType Constructor

Initializes a new instance of the FolderIdType class.

public FolderIdType();

See Also

FolderIdType Class | Aspose.Email.Exchange.Schema Namespace


FolderIdType Properties

The properties of the FolderIdType class are listed below. For a complete list of FolderIdType class members, see the FolderIdType Members topic.

Public Instance Properties

ChangeKey
Id

See Also

FolderIdType Class | Aspose.Email.Exchange.Schema Namespace


ChangeKey Property

Aspose.Email

FolderIdType.ChangeKey Property

public string ChangeKey {get; set;}

Remarks

See Also

FolderIdType Class | Aspose.Email.Exchange.Schema Namespace


Id Property

Aspose.Email

FolderIdType.Id Property

public string Id {get; set;}

Remarks

See Also

FolderIdType Class | Aspose.Email.Exchange.Schema Namespace


FolderInfoResponseMessageType Class

For a list of all members of this type, see FolderInfoResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ResponseMessageType
Aspose.Email.Exchange.Schema.FolderInfoResponseMessageType

public class FolderInfoResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FolderInfoResponseMessageType Members | Aspose.Email.Exchange.Schema Namespace


FolderInfoResponseMessageType Members

FolderInfoResponseMessageType overview

Public Instance Constructors

FolderInfoResponseMessageType Constructor Initializes a new instance of the FolderInfoResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
Folders
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FolderInfoResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


FolderInfoResponseMessageType Constructor

Initializes a new instance of the FolderInfoResponseMessageType class.

public FolderInfoResponseMessageType();

See Also

FolderInfoResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


FolderInfoResponseMessageType Properties

The properties of the FolderInfoResponseMessageType class are listed below. For a complete list of FolderInfoResponseMessageType class members, see the FolderInfoResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
Folders
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

FolderInfoResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


Folders Property

Aspose.Email

FolderInfoResponseMessageType.Folders Property

public BaseFolderType[] Folders {get; set;}

Remarks

See Also

FolderInfoResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


FolderQueryTraversalType Enumeration

public enum FolderQueryTraversalType

Remarks

Members

Member Name | Description | Value
Shallow |  | 0
Deep |  | 1
SoftDeleted |  | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


FolderResponseShapeType Class

For a list of all members of this type, see FolderResponseShapeType Members.

System.Object
Aspose.Email.Exchange.Schema.FolderResponseShapeType

public class FolderResponseShapeType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FolderResponseShapeType Members | Aspose.Email.Exchange.Schema Namespace


FolderResponseShapeType Members

FolderResponseShapeType overview

Public Instance Constructors

FolderResponseShapeType Constructor Initializes a new instance of the FolderResponseShapeType class.

Public Instance Properties

AdditionalProperties
BaseShape

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FolderResponseShapeType Class | Aspose.Email.Exchange.Schema Namespace


FolderResponseShapeType Constructor

Initializes a new instance of the FolderResponseShapeType class.

public FolderResponseShapeType();

See Also

FolderResponseShapeType Class | Aspose.Email.Exchange.Schema Namespace


FolderResponseShapeType Properties

The properties of the FolderResponseShapeType class are listed below. For a complete list of FolderResponseShapeType class members, see the FolderResponseShapeType Members topic.

Public Instance Properties

AdditionalProperties
BaseShape

See Also

FolderResponseShapeType Class | Aspose.Email.Exchange.Schema Namespace


AdditionalProperties Property

Aspose.Email

FolderResponseShapeType.AdditionalProperties Property

public BasePathToElementType[] AdditionalProperties {get; set;}

Remarks

See Also

FolderResponseShapeType Class | Aspose.Email.Exchange.Schema Namespace


BaseShape Property

Aspose.Email

FolderResponseShapeType.BaseShape Property

public DefaultShapeNamesType BaseShape {get; set;}

Remarks

See Also

FolderResponseShapeType Class | Aspose.Email.Exchange.Schema Namespace


FolderType Class

For a list of all members of this type, see FolderType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseFolderType
Aspose.Email.Exchange.Schema.FolderType
Aspose.Email.Exchange.Schema.SearchFolderType
Aspose.Email.Exchange.Schema.TasksFolderType

public class FolderType : BaseFolderType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FolderType Members | Aspose.Email.Exchange.Schema Namespace


FolderType Members

FolderType overview

Public Instance Constructors

FolderType Constructor Initializes a new instance of the FolderType class.

Public Instance Properties

ChildFolderCount (inherited from BaseFolderType)
ChildFolderCountSpecified (inherited from BaseFolderType)
DisplayName (inherited from BaseFolderType)
EffectiveRights (inherited from BaseFolderType)
ExtendedProperty (inherited from BaseFolderType)
FolderClass (inherited from BaseFolderType)
FolderId (inherited from BaseFolderType)
ManagedFolderInformation (inherited from BaseFolderType)
ParentFolderId (inherited from BaseFolderType)
PermissionSet
TotalCount (inherited from BaseFolderType)
TotalCountSpecified (inherited from BaseFolderType)
UnreadCount
UnreadCountSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FolderType Class | Aspose.Email.Exchange.Schema Namespace


FolderType Constructor

Initializes a new instance of the FolderType class.

public FolderType();

See Also

FolderType Class | Aspose.Email.Exchange.Schema Namespace


FolderType Properties

The properties of the FolderType class are listed below. For a complete list of FolderType class members, see the FolderType Members topic.

Public Instance Properties

ChildFolderCount (inherited from BaseFolderType)
ChildFolderCountSpecified (inherited from BaseFolderType)
DisplayName (inherited from BaseFolderType)
EffectiveRights (inherited from BaseFolderType)
ExtendedProperty (inherited from BaseFolderType)
FolderClass (inherited from BaseFolderType)
FolderId (inherited from BaseFolderType)
ManagedFolderInformation (inherited from BaseFolderType)
ParentFolderId (inherited from BaseFolderType)
PermissionSet
TotalCount (inherited from BaseFolderType)
TotalCountSpecified (inherited from BaseFolderType)
UnreadCount
UnreadCountSpecified

See Also

FolderType Class | Aspose.Email.Exchange.Schema Namespace


PermissionSet Property

Aspose.Email

FolderType.PermissionSet Property

public PermissionSetType PermissionSet {get; set;}

Remarks

See Also

FolderType Class | Aspose.Email.Exchange.Schema Namespace


UnreadCount Property

Aspose.Email

FolderType.UnreadCount Property

public int UnreadCount {get; set;}

Remarks

See Also

FolderType Class | Aspose.Email.Exchange.Schema Namespace


UnreadCountSpecified Property

Aspose.Email

FolderType.UnreadCountSpecified Property

public bool UnreadCountSpecified {get; set;}

Remarks

See Also

FolderType Class | Aspose.Email.Exchange.Schema Namespace


ForwardItemType Class

For a list of all members of this type, see ForwardItemType Members.

System.Object
Aspose.Email.Exchange.Schema.ItemType
Aspose.Email.Exchange.Schema.MessageType
Aspose.Email.Exchange.Schema.ResponseObjectCoreType
Aspose.Email.Exchange.Schema.ResponseObjectType
Aspose.Email.Exchange.Schema.SmartResponseBaseType
Aspose.Email.Exchange.Schema.SmartResponseType
Aspose.Email.Exchange.Schema.ForwardItemType

public class ForwardItemType : SmartResponseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ForwardItemType Members | Aspose.Email.Exchange.Schema Namespace


ForwardItemType Members

ForwardItemType overview

Public Instance Constructors

ForwardItemType Constructor Initializes a new instance of the ForwardItemType class.

Public Instance Properties

Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
From (inherited from MessageType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
NewBodyContent (inherited from SmartResponseType)
ObjectName (inherited from ResponseObjectType)
ParentFolderId (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
ReferenceItemId (inherited from ResponseObjectCoreType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
Subject (inherited from ItemType)
ToRecipients (inherited from MessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ForwardItemType Class | Aspose.Email.Exchange.Schema Namespace


ForwardItemType Constructor

Initializes a new instance of the ForwardItemType class.

public ForwardItemType();

See Also

ForwardItemType Class | Aspose.Email.Exchange.Schema Namespace


FractionalPageViewType Class

For a list of all members of this type, see FractionalPageViewType Members.

System.Object
Aspose.Email.Exchange.Schema.BasePagingType
Aspose.Email.Exchange.Schema.FractionalPageViewType

public class FractionalPageViewType : BasePagingType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FractionalPageViewType Members | Aspose.Email.Exchange.Schema Namespace


FractionalPageViewType Members

FractionalPageViewType overview

Public Instance Constructors

FractionalPageViewType Constructor Initializes a new instance of the FractionalPageViewType class.

Public Instance Properties

Denominator
MaxEntriesReturned (inherited from BasePagingType)
MaxEntriesReturnedSpecified (inherited from BasePagingType)
Numerator

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FractionalPageViewType Class | Aspose.Email.Exchange.Schema Namespace


FractionalPageViewType Constructor

Initializes a new instance of the FractionalPageViewType class.

public FractionalPageViewType();

See Also

FractionalPageViewType Class | Aspose.Email.Exchange.Schema Namespace


FractionalPageViewType Properties

The properties of the FractionalPageViewType class are listed below. For a complete list of FractionalPageViewType class members, see the FractionalPageViewType Members topic.

Public Instance Properties

Denominator
MaxEntriesReturned (inherited from BasePagingType)
MaxEntriesReturnedSpecified (inherited from BasePagingType)
Numerator

See Also

FractionalPageViewType Class | Aspose.Email.Exchange.Schema Namespace


Denominator Property

Aspose.Email

FractionalPageViewType.Denominator Property

public int Denominator {get; set;}

Remarks

See Also

FractionalPageViewType Class | Aspose.Email.Exchange.Schema Namespace


Numerator Property

Aspose.Email

FractionalPageViewType.Numerator Property

public int Numerator {get; set;}

Remarks

See Also

FractionalPageViewType Class | Aspose.Email.Exchange.Schema Namespace


FreeBusyResponseType Class

For a list of all members of this type, see FreeBusyResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.FreeBusyResponseType

public class FreeBusyResponseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FreeBusyResponseType Members | Aspose.Email.Exchange.Schema Namespace


FreeBusyResponseType Members

FreeBusyResponseType overview

Public Instance Constructors

FreeBusyResponseType Constructor Initializes a new instance of the FreeBusyResponseType class.

Public Instance Properties

FreeBusyView
ResponseMessage

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FreeBusyResponseType Class | Aspose.Email.Exchange.Schema Namespace


FreeBusyResponseType Constructor

Initializes a new instance of the FreeBusyResponseType class.

public FreeBusyResponseType();

See Also

FreeBusyResponseType Class | Aspose.Email.Exchange.Schema Namespace


FreeBusyResponseType Properties

The properties of the FreeBusyResponseType class are listed below. For a complete list of FreeBusyResponseType class members, see the FreeBusyResponseType Members topic.

Public Instance Properties

FreeBusyView
ResponseMessage

See Also

FreeBusyResponseType Class | Aspose.Email.Exchange.Schema Namespace


FreeBusyView Property

Aspose.Email

FreeBusyResponseType.FreeBusyView Property

public FreeBusyView FreeBusyView {get; set;}

Remarks

See Also

FreeBusyResponseType Class | Aspose.Email.Exchange.Schema Namespace


ResponseMessage Property

Aspose.Email

FreeBusyResponseType.ResponseMessage Property

public ResponseMessageType ResponseMessage {get; set;}

Remarks

See Also

FreeBusyResponseType Class | Aspose.Email.Exchange.Schema Namespace


FreeBusyView Class

For a list of all members of this type, see FreeBusyView Members.

System.Object
Aspose.Email.Exchange.Schema.FreeBusyView

public class FreeBusyView

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FreeBusyView Members | Aspose.Email.Exchange.Schema Namespace


FreeBusyView Members

FreeBusyView overview

Public Instance Constructors

FreeBusyView Constructor Initializes a new instance of the FreeBusyView class.

Public Instance Properties

CalendarEventArray
FreeBusyViewType
MergedFreeBusy
WorkingHours

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FreeBusyView Class | Aspose.Email.Exchange.Schema Namespace


FreeBusyView Constructor

Initializes a new instance of the FreeBusyView class.

public FreeBusyView();

See Also

FreeBusyView Class | Aspose.Email.Exchange.Schema Namespace


FreeBusyView Properties

The properties of the FreeBusyView class are listed below. For a complete list of FreeBusyView class members, see the FreeBusyView Members topic.

Public Instance Properties

CalendarEventArray
FreeBusyViewType
MergedFreeBusy
WorkingHours

See Also

FreeBusyView Class | Aspose.Email.Exchange.Schema Namespace


CalendarEventArray Property

Aspose.Email

FreeBusyView.CalendarEventArray Property

public CalendarEvent[] CalendarEventArray {get; set;}

Remarks

See Also

FreeBusyView Class | Aspose.Email.Exchange.Schema Namespace


FreeBusyViewType Property

Aspose.Email

FreeBusyView.FreeBusyViewType Property

public FreeBusyViewType FreeBusyViewType {get; set;}

Remarks

See Also

FreeBusyView Class | Aspose.Email.Exchange.Schema Namespace


MergedFreeBusy Property

Aspose.Email

FreeBusyView.MergedFreeBusy Property

public string MergedFreeBusy {get; set;}

Remarks

See Also

FreeBusyView Class | Aspose.Email.Exchange.Schema Namespace


WorkingHours Property

Aspose.Email

FreeBusyView.WorkingHours Property

public WorkingHours WorkingHours {get; set;}

Remarks

See Also

FreeBusyView Class | Aspose.Email.Exchange.Schema Namespace


FreeBusyViewOptionsType Class

For a list of all members of this type, see FreeBusyViewOptionsType Members.

System.Object
Aspose.Email.Exchange.Schema.FreeBusyViewOptionsType

public class FreeBusyViewOptionsType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FreeBusyViewOptionsType Members | Aspose.Email.Exchange.Schema Namespace


FreeBusyViewOptionsType Members

FreeBusyViewOptionsType overview

Public Instance Constructors

FreeBusyViewOptionsType Constructor Initializes a new instance of the FreeBusyViewOptionsType class.

Public Instance Properties

MergedFreeBusyIntervalInMinutes
MergedFreeBusyIntervalInMinutesSpecified
RequestedView
RequestedViewSpecified
TimeWindow

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FreeBusyViewOptionsType Class | Aspose.Email.Exchange.Schema Namespace


FreeBusyViewOptionsType Constructor

Initializes a new instance of the FreeBusyViewOptionsType class.

public FreeBusyViewOptionsType();

See Also

FreeBusyViewOptionsType Class | Aspose.Email.Exchange.Schema Namespace


FreeBusyViewOptionsType Properties

The properties of the FreeBusyViewOptionsType class are listed below. For a complete list of FreeBusyViewOptionsType class members, see the FreeBusyViewOptionsType Members topic.

Public Instance Properties

MergedFreeBusyIntervalInMinutes
MergedFreeBusyIntervalInMinutesSpecified
RequestedView
RequestedViewSpecified
TimeWindow

See Also

FreeBusyViewOptionsType Class | Aspose.Email.Exchange.Schema Namespace


MergedFreeBusyIntervalInMinutes Property

Aspose.Email

FreeBusyViewOptionsType.MergedFreeBusyIntervalInMinutes Property

public int MergedFreeBusyIntervalInMinutes {get; set;}

Remarks

See Also

FreeBusyViewOptionsType Class | Aspose.Email.Exchange.Schema Namespace


MergedFreeBusyIntervalInMinutesSpecified Property

Aspose.Email

FreeBusyViewOptionsType.MergedFreeBusyIntervalInMinutesSpecified Property

public bool MergedFreeBusyIntervalInMinutesSpecified {get; set;}

Remarks

See Also

FreeBusyViewOptionsType Class | Aspose.Email.Exchange.Schema Namespace


RequestedView Property

Aspose.Email

FreeBusyViewOptionsType.RequestedView Property

public FreeBusyViewType RequestedView {get; set;}

Remarks

See Also

FreeBusyViewOptionsType Class | Aspose.Email.Exchange.Schema Namespace


RequestedViewSpecified Property

Aspose.Email

FreeBusyViewOptionsType.RequestedViewSpecified Property

public bool RequestedViewSpecified {get; set;}

Remarks

See Also

FreeBusyViewOptionsType Class | Aspose.Email.Exchange.Schema Namespace


TimeWindow Property

Aspose.Email

FreeBusyViewOptionsType.TimeWindow Property

public Duration TimeWindow {get; set;}

Remarks

See Also

FreeBusyViewOptionsType Class | Aspose.Email.Exchange.Schema Namespace


FreeBusyViewType Enumeration

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum FreeBusyViewType

Remarks

Members

Member Name | Description | Value
None |  | 1
MergedOnly |  | 2
FreeBusy |  | 4
FreeBusyMerged |  | 8
Detailed |  | 16
DetailedMerged |  | 32

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


GetAttachmentCompletedEventArgs Class

For a list of all members of this type, see GetAttachmentCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.GetAttachmentCompletedEventArgs

public class GetAttachmentCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetAttachmentCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


GetAttachmentCompletedEventArgs Members

GetAttachmentCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetAttachmentCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


GetAttachmentCompletedEventArgs Properties

The properties of the GetAttachmentCompletedEventArgs class are listed below. For a complete list of GetAttachmentCompletedEventArgs class members, see the GetAttachmentCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetAttachmentCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

GetAttachmentCompletedEventArgs.Result Property

public GetAttachmentResponseType Result {get;}

Remarks

See Also

GetAttachmentCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


GetAttachmentCompletedEventHandler Delegate

public delegate void GetAttachmentCompletedEventHandler(
object sender,
GetAttachmentCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


GetAttachmentResponseType Class

For a list of all members of this type, see GetAttachmentResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseResponseMessageType
Aspose.Email.Exchange.Schema.GetAttachmentResponseType

public class GetAttachmentResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetAttachmentResponseType Members | Aspose.Email.Exchange.Schema Namespace


GetAttachmentResponseType Members

GetAttachmentResponseType overview

Public Instance Constructors

GetAttachmentResponseType Constructor Initializes a new instance of the GetAttachmentResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetAttachmentResponseType Class | Aspose.Email.Exchange.Schema Namespace


GetAttachmentResponseType Constructor

Initializes a new instance of the GetAttachmentResponseType class.

public GetAttachmentResponseType();

See Also

GetAttachmentResponseType Class | Aspose.Email.Exchange.Schema Namespace


GetAttachmentType Class

For a list of all members of this type, see GetAttachmentType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.GetAttachmentType

public class GetAttachmentType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetAttachmentType Members | Aspose.Email.Exchange.Schema Namespace


GetAttachmentType Members

GetAttachmentType overview

Public Instance Constructors

GetAttachmentType Constructor Initializes a new instance of the GetAttachmentType class.

Public Instance Properties

AttachmentIds
AttachmentShape

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetAttachmentType Class | Aspose.Email.Exchange.Schema Namespace


GetAttachmentType Constructor

Initializes a new instance of the GetAttachmentType class.

public GetAttachmentType();

See Also

GetAttachmentType Class | Aspose.Email.Exchange.Schema Namespace


GetAttachmentType Properties

The properties of the GetAttachmentType class are listed below. For a complete list of GetAttachmentType class members, see the GetAttachmentType Members topic.

Public Instance Properties

AttachmentIds
AttachmentShape

See Also

GetAttachmentType Class | Aspose.Email.Exchange.Schema Namespace


AttachmentIds Property

Aspose.Email

GetAttachmentType.AttachmentIds Property

public RequestAttachmentIdType[] AttachmentIds {get; set;}

Remarks

See Also

GetAttachmentType Class | Aspose.Email.Exchange.Schema Namespace


AttachmentShape Property

Aspose.Email

GetAttachmentType.AttachmentShape Property

public AttachmentResponseShapeType AttachmentShape {get; set;}

Remarks

See Also

GetAttachmentType Class | Aspose.Email.Exchange.Schema Namespace


GetDelegateCompletedEventArgs Class

For a list of all members of this type, see GetDelegateCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.GetDelegateCompletedEventArgs

public class GetDelegateCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetDelegateCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


GetDelegateCompletedEventArgs Members

GetDelegateCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetDelegateCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


GetDelegateCompletedEventArgs Properties

The properties of the GetDelegateCompletedEventArgs class are listed below. For a complete list of GetDelegateCompletedEventArgs class members, see the GetDelegateCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetDelegateCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

GetDelegateCompletedEventArgs.Result Property

public GetDelegateResponseMessageType Result {get;}

Remarks

See Also

GetDelegateCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


GetDelegateCompletedEventHandler Delegate

public delegate void GetDelegateCompletedEventHandler(
object sender,
GetDelegateCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


GetDelegateResponseMessageType Class

For a list of all members of this type, see GetDelegateResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ResponseMessageType
Aspose.Email.Exchange.Schema.BaseDelegateResponseMessageType
Aspose.Email.Exchange.Schema.GetDelegateResponseMessageType

public class GetDelegateResponseMessageType : BaseDelegateResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetDelegateResponseMessageType Members | Aspose.Email.Exchange.Schema Namespace


GetDelegateResponseMessageType Members

GetDelegateResponseMessageType overview

Public Instance Constructors

GetDelegateResponseMessageType Constructor Initializes a new instance of the GetDelegateResponseMessageType class.

Public Instance Properties

DeliverMeetingRequests
DeliverMeetingRequestsSpecified
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
ResponseMessages (inherited from BaseDelegateResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetDelegateResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


GetDelegateResponseMessageType Constructor

Initializes a new instance of the GetDelegateResponseMessageType class.

public GetDelegateResponseMessageType();

See Also

GetDelegateResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


GetDelegateResponseMessageType Properties

The properties of the GetDelegateResponseMessageType class are listed below. For a complete list of GetDelegateResponseMessageType class members, see the GetDelegateResponseMessageType Members topic.

Public Instance Properties

DeliverMeetingRequests
DeliverMeetingRequestsSpecified
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
ResponseMessages (inherited from BaseDelegateResponseMessageType)

See Also

GetDelegateResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


DeliverMeetingRequests Property

Aspose.Email

GetDelegateResponseMessageType.DeliverMeetingRequests Property

public DeliverMeetingRequestsType DeliverMeetingRequests {get; set;}

Remarks

See Also

GetDelegateResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


DeliverMeetingRequestsSpecified Property

Aspose.Email

GetDelegateResponseMessageType.DeliverMeetingRequestsSpecified Property

public bool DeliverMeetingRequestsSpecified {get; set;}

Remarks

See Also

GetDelegateResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


GetDelegateType Class

For a list of all members of this type, see GetDelegateType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.BaseDelegateType
Aspose.Email.Exchange.Schema.GetDelegateType

public class GetDelegateType : BaseDelegateType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetDelegateType Members | Aspose.Email.Exchange.Schema Namespace


GetDelegateType Members

GetDelegateType overview

Public Instance Constructors

GetDelegateType Constructor Initializes a new instance of the GetDelegateType class.

Public Instance Properties

IncludePermissions
Mailbox (inherited from BaseDelegateType)
UserIds

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetDelegateType Class | Aspose.Email.Exchange.Schema Namespace


GetDelegateType Constructor

Initializes a new instance of the GetDelegateType class.

public GetDelegateType();

See Also

GetDelegateType Class | Aspose.Email.Exchange.Schema Namespace


GetDelegateType Properties

The properties of the GetDelegateType class are listed below. For a complete list of GetDelegateType class members, see the GetDelegateType Members topic.

Public Instance Properties

IncludePermissions
Mailbox (inherited from BaseDelegateType)
UserIds

See Also

GetDelegateType Class | Aspose.Email.Exchange.Schema Namespace


IncludePermissions Property

Aspose.Email

GetDelegateType.IncludePermissions Property

public bool IncludePermissions {get; set;}

Remarks

See Also

GetDelegateType Class | Aspose.Email.Exchange.Schema Namespace


UserIds Property

Aspose.Email

GetDelegateType.UserIds Property

public UserIdType[] UserIds {get; set;}

Remarks

See Also

GetDelegateType Class | Aspose.Email.Exchange.Schema Namespace


GetEventsCompletedEventArgs Class

For a list of all members of this type, see GetEventsCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.GetEventsCompletedEventArgs

public class GetEventsCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetEventsCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


GetEventsCompletedEventArgs Members

GetEventsCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetEventsCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


GetEventsCompletedEventArgs Properties

The properties of the GetEventsCompletedEventArgs class are listed below. For a complete list of GetEventsCompletedEventArgs class members, see the GetEventsCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetEventsCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

GetEventsCompletedEventArgs.Result Property

public GetEventsResponseType Result {get;}

Remarks

See Also

GetEventsCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


GetEventsCompletedEventHandler Delegate

public delegate void GetEventsCompletedEventHandler(
object sender,
GetEventsCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


GetEventsResponseMessageType Class

For a list of all members of this type, see GetEventsResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ResponseMessageType
Aspose.Email.Exchange.Schema.GetEventsResponseMessageType

public class GetEventsResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetEventsResponseMessageType Members | Aspose.Email.Exchange.Schema Namespace


GetEventsResponseMessageType Members

GetEventsResponseMessageType overview

Public Instance Constructors

GetEventsResponseMessageType Constructor Initializes a new instance of the GetEventsResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
Notification
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetEventsResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


GetEventsResponseMessageType Constructor

Initializes a new instance of the GetEventsResponseMessageType class.

public GetEventsResponseMessageType();

See Also

GetEventsResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


GetEventsResponseMessageType Properties

The properties of the GetEventsResponseMessageType class are listed below. For a complete list of GetEventsResponseMessageType class members, see the GetEventsResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
Notification
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

GetEventsResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


Notification Property

Aspose.Email

GetEventsResponseMessageType.Notification Property

public NotificationType Notification {get; set;}

Remarks

See Also

GetEventsResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


GetEventsResponseType Class

For a list of all members of this type, see GetEventsResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseResponseMessageType
Aspose.Email.Exchange.Schema.GetEventsResponseType

public class GetEventsResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetEventsResponseType Members | Aspose.Email.Exchange.Schema Namespace


GetEventsResponseType Members

GetEventsResponseType overview

Public Instance Constructors

GetEventsResponseType Constructor Initializes a new instance of the GetEventsResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetEventsResponseType Class | Aspose.Email.Exchange.Schema Namespace


GetEventsResponseType Constructor

Initializes a new instance of the GetEventsResponseType class.

public GetEventsResponseType();

See Also

GetEventsResponseType Class | Aspose.Email.Exchange.Schema Namespace


GetEventsType Class

For a list of all members of this type, see GetEventsType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.GetEventsType

public class GetEventsType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetEventsType Members | Aspose.Email.Exchange.Schema Namespace


GetEventsType Members

GetEventsType overview

Public Instance Constructors

GetEventsType Constructor Initializes a new instance of the GetEventsType class.

Public Instance Properties

SubscriptionId
Watermark

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetEventsType Class | Aspose.Email.Exchange.Schema Namespace


GetEventsType Constructor

Initializes a new instance of the GetEventsType class.

public GetEventsType();

See Also

GetEventsType Class | Aspose.Email.Exchange.Schema Namespace


GetEventsType Properties

The properties of the GetEventsType class are listed below. For a complete list of GetEventsType class members, see the GetEventsType Members topic.

Public Instance Properties

SubscriptionId
Watermark

See Also

GetEventsType Class | Aspose.Email.Exchange.Schema Namespace


SubscriptionId Property

Aspose.Email

GetEventsType.SubscriptionId Property

public string SubscriptionId {get; set;}

Remarks

See Also

GetEventsType Class | Aspose.Email.Exchange.Schema Namespace


Watermark Property

Aspose.Email

GetEventsType.Watermark Property

public string Watermark {get; set;}

Remarks

See Also

GetEventsType Class | Aspose.Email.Exchange.Schema Namespace


GetFolderCompletedEventArgs Class

For a list of all members of this type, see GetFolderCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.GetFolderCompletedEventArgs

public class GetFolderCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetFolderCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


GetFolderCompletedEventArgs Members

GetFolderCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


GetFolderCompletedEventArgs Properties

The properties of the GetFolderCompletedEventArgs class are listed below. For a complete list of GetFolderCompletedEventArgs class members, see the GetFolderCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

GetFolderCompletedEventArgs.Result Property

public GetFolderResponseType Result {get;}

Remarks

See Also

GetFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


GetFolderCompletedEventHandler Delegate

public delegate void GetFolderCompletedEventHandler(
object sender,
GetFolderCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


GetFolderResponseType Class

For a list of all members of this type, see GetFolderResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseResponseMessageType
Aspose.Email.Exchange.Schema.GetFolderResponseType

public class GetFolderResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetFolderResponseType Members | Aspose.Email.Exchange.Schema Namespace


GetFolderResponseType Members

GetFolderResponseType overview

Public Instance Constructors

GetFolderResponseType Constructor Initializes a new instance of the GetFolderResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetFolderResponseType Class | Aspose.Email.Exchange.Schema Namespace


GetFolderResponseType Constructor

Initializes a new instance of the GetFolderResponseType class.

public GetFolderResponseType();

See Also

GetFolderResponseType Class | Aspose.Email.Exchange.Schema Namespace


GetFolderType Class

For a list of all members of this type, see GetFolderType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.GetFolderType

public class GetFolderType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetFolderType Members | Aspose.Email.Exchange.Schema Namespace


GetFolderType Members

GetFolderType overview

Public Instance Constructors

GetFolderType Constructor Initializes a new instance of the GetFolderType class.

Public Instance Properties

FolderIds
FolderShape

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetFolderType Class | Aspose.Email.Exchange.Schema Namespace


GetFolderType Constructor

Initializes a new instance of the GetFolderType class.

public GetFolderType();

See Also

GetFolderType Class | Aspose.Email.Exchange.Schema Namespace


GetFolderType Properties

The properties of the GetFolderType class are listed below. For a complete list of GetFolderType class members, see the GetFolderType Members topic.

Public Instance Properties

FolderIds
FolderShape

See Also

GetFolderType Class | Aspose.Email.Exchange.Schema Namespace


FolderIds Property

Aspose.Email

GetFolderType.FolderIds Property

public BaseFolderIdType[] FolderIds {get; set;}

Remarks

See Also

GetFolderType Class | Aspose.Email.Exchange.Schema Namespace


FolderShape Property

Aspose.Email

GetFolderType.FolderShape Property

public FolderResponseShapeType FolderShape {get; set;}

Remarks

See Also

GetFolderType Class | Aspose.Email.Exchange.Schema Namespace


GetInboxRulesCompletedEventArgs Class

Provides data for the event

For a list of all members of this type, see GetInboxRulesCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.GetInboxRulesCompletedEventArgs

public class GetInboxRulesCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetInboxRulesCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace | GetInboxRulesCompleted


GetInboxRulesCompletedEventArgs Members

GetInboxRulesCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result | Gets the result of operation
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetInboxRulesCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace | GetInboxRulesCompleted


GetInboxRulesCompletedEventArgs Properties

The properties of the GetInboxRulesCompletedEventArgs class are listed below. For a complete list of GetInboxRulesCompletedEventArgs class members, see the GetInboxRulesCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result | Gets the result of operation
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetInboxRulesCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace | GetInboxRulesCompleted


Result Property

Aspose.Email

GetInboxRulesCompletedEventArgs.Result Property

Gets the result of operation

public GetInboxRulesResponseType Result {get;}

See Also

GetInboxRulesCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


GetInboxRulesCompletedEventHandler Delegate

Represents the method that will handle the UpdateInboxRulesCompleted event

public delegate void GetInboxRulesCompletedEventHandler(
object sender,
GetInboxRulesCompletedEventArgs e
);

Parameters

sender
The sender of event
e
A UpdateInboxRulesCompletedEventArgs arguments

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


GetInboxRulesRequestType Class

Represents GetInboxRules request type

For a list of all members of this type, see GetInboxRulesRequestType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.GetInboxRulesRequestType

public class GetInboxRulesRequestType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetInboxRulesRequestType Members | Aspose.Email.Exchange.Schema Namespace


GetInboxRulesRequestType Members

GetInboxRulesRequestType overview

Public Instance Constructors

GetInboxRulesRequestType Constructor Initializes a new instance of the GetInboxRulesRequestType class.

Public Instance Properties

MailboxSmtpAddress Gets or sets the SMTP address of the user whose Inbox rules are to be retrieved.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetInboxRulesRequestType Class | Aspose.Email.Exchange.Schema Namespace


GetInboxRulesRequestType Constructor

Initializes a new instance of the GetInboxRulesRequestType class.

public GetInboxRulesRequestType();

See Also

GetInboxRulesRequestType Class | Aspose.Email.Exchange.Schema Namespace


GetInboxRulesRequestType Properties

The properties of the GetInboxRulesRequestType class are listed below. For a complete list of GetInboxRulesRequestType class members, see the GetInboxRulesRequestType Members topic.

Public Instance Properties

MailboxSmtpAddress Gets or sets the SMTP address of the user whose Inbox rules are to be retrieved.

See Also

GetInboxRulesRequestType Class | Aspose.Email.Exchange.Schema Namespace


MailboxSmtpAddress Property

Aspose.Email

GetInboxRulesRequestType.MailboxSmtpAddress Property

Gets or sets the SMTP address of the user whose Inbox rules are to be retrieved.

public string MailboxSmtpAddress {get; set;}

See Also

GetInboxRulesRequestType Class | Aspose.Email.Exchange.Schema Namespace


GetInboxRulesResponseType Class

Represents GetInboxRules response type

For a list of all members of this type, see GetInboxRulesResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.ResponseMessageType
Aspose.Email.Exchange.Schema.GetInboxRulesResponseType

public class GetInboxRulesResponseType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetInboxRulesResponseType Members | Aspose.Email.Exchange.Schema Namespace


GetInboxRulesResponseType Members

GetInboxRulesResponseType overview

Public Instance Constructors

GetInboxRulesResponseType Constructor Initializes a new instance of the GetInboxRulesResponseType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType) |
DescriptiveLinkKeySpecified (inherited from ResponseMessageType) |
InboxRules | Gets or sets an array of the rules in the user's mailbox.
MessageText (inherited from ResponseMessageType) |
MessageXml (inherited from ResponseMessageType) |
OutlookRuleBlobExists | Gets or sets a value indicating whether a BLOB that contains all rules exists in the user's mailbox.
OutlookRuleBlobExistsSpecified | Gets or sets a value indicating whether the OutlookRuleBlobExists proeprty is specified
ResponseClass (inherited from ResponseMessageType) |
ResponseCode (inherited from ResponseMessageType) |
ResponseCodeSpecified (inherited from ResponseMessageType) |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetInboxRulesResponseType Class | Aspose.Email.Exchange.Schema Namespace


GetInboxRulesResponseType Constructor

Initializes a new instance of the GetInboxRulesResponseType class.

public GetInboxRulesResponseType();

See Also

GetInboxRulesResponseType Class | Aspose.Email.Exchange.Schema Namespace


GetInboxRulesResponseType Properties

The properties of the GetInboxRulesResponseType class are listed below. For a complete list of GetInboxRulesResponseType class members, see the GetInboxRulesResponseType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType) |
DescriptiveLinkKeySpecified (inherited from ResponseMessageType) |
InboxRules | Gets or sets an array of the rules in the user's mailbox.
MessageText (inherited from ResponseMessageType) |
MessageXml (inherited from ResponseMessageType) |
OutlookRuleBlobExists | Gets or sets a value indicating whether a BLOB that contains all rules exists in the user's mailbox.
OutlookRuleBlobExistsSpecified | Gets or sets a value indicating whether the OutlookRuleBlobExists proeprty is specified
ResponseClass (inherited from ResponseMessageType) |
ResponseCode (inherited from ResponseMessageType) |
ResponseCodeSpecified (inherited from ResponseMessageType) |

See Also

GetInboxRulesResponseType Class | Aspose.Email.Exchange.Schema Namespace


InboxRules Property

Aspose.Email

GetInboxRulesResponseType.InboxRules Property

Gets or sets an array of the rules in the user's mailbox.

public RuleType[] InboxRules {get; set;}

See Also

GetInboxRulesResponseType Class | Aspose.Email.Exchange.Schema Namespace


OutlookRuleBlobExists Property

Aspose.Email

GetInboxRulesResponseType.OutlookRuleBlobExists Property

Gets or sets a value indicating whether a BLOB that contains all rules exists in the user's mailbox.

public bool OutlookRuleBlobExists {get; set;}

See Also

GetInboxRulesResponseType Class | Aspose.Email.Exchange.Schema Namespace


OutlookRuleBlobExistsSpecified Property

Aspose.Email

GetInboxRulesResponseType.OutlookRuleBlobExistsSpecified Property

Gets or sets a value indicating whether the OutlookRuleBlobExists proeprty is specified

public bool OutlookRuleBlobExistsSpecified {get; set;}

See Also

GetInboxRulesResponseType Class | Aspose.Email.Exchange.Schema Namespace


GetItemCompletedEventArgs Class

For a list of all members of this type, see GetItemCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.GetItemCompletedEventArgs

public class GetItemCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetItemCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


GetItemCompletedEventArgs Members

GetItemCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


GetItemCompletedEventArgs Properties

The properties of the GetItemCompletedEventArgs class are listed below. For a complete list of GetItemCompletedEventArgs class members, see the GetItemCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

GetItemCompletedEventArgs.Result Property

public GetItemResponseType Result {get;}

Remarks

See Also

GetItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


GetItemCompletedEventHandler Delegate

public delegate void GetItemCompletedEventHandler(
object sender,
GetItemCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


GetItemResponseType Class

For a list of all members of this type, see GetItemResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseResponseMessageType
Aspose.Email.Exchange.Schema.GetItemResponseType

public class GetItemResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetItemResponseType Members | Aspose.Email.Exchange.Schema Namespace


GetItemResponseType Members

GetItemResponseType overview

Public Instance Constructors

GetItemResponseType Constructor Initializes a new instance of the GetItemResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetItemResponseType Class | Aspose.Email.Exchange.Schema Namespace


GetItemResponseType Constructor

Initializes a new instance of the GetItemResponseType class.

public GetItemResponseType();

See Also

GetItemResponseType Class | Aspose.Email.Exchange.Schema Namespace


GetItemType Class

For a list of all members of this type, see GetItemType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.GetItemType

public class GetItemType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetItemType Members | Aspose.Email.Exchange.Schema Namespace


GetItemType Members

GetItemType overview

Public Instance Constructors

GetItemType Constructor Initializes a new instance of the GetItemType class.

Public Instance Properties

ItemIds
ItemShape

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetItemType Class | Aspose.Email.Exchange.Schema Namespace


GetItemType Constructor

Initializes a new instance of the GetItemType class.

public GetItemType();

See Also

GetItemType Class | Aspose.Email.Exchange.Schema Namespace


GetItemType Properties

The properties of the GetItemType class are listed below. For a complete list of GetItemType class members, see the GetItemType Members topic.

Public Instance Properties

ItemIds
ItemShape

See Also

GetItemType Class | Aspose.Email.Exchange.Schema Namespace


ItemIds Property

Aspose.Email

GetItemType.ItemIds Property

public BaseItemIdType[] ItemIds {get; set;}

Remarks

See Also

GetItemType Class | Aspose.Email.Exchange.Schema Namespace


ItemShape Property

Aspose.Email

GetItemType.ItemShape Property

public ItemResponseShapeType ItemShape {get; set;}

Remarks

See Also

GetItemType Class | Aspose.Email.Exchange.Schema Namespace


GetMailTipsCompletedEventArgs Class

For a list of all members of this type, see GetMailTipsCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.GetMailTipsCompletedEventArgs

public class GetMailTipsCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetMailTipsCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


GetMailTipsCompletedEventArgs Members

GetMailTipsCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetMailTipsCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


GetMailTipsCompletedEventArgs Properties

The properties of the GetMailTipsCompletedEventArgs class are listed below. For a complete list of GetMailTipsCompletedEventArgs class members, see the GetMailTipsCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetMailTipsCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

GetMailTipsCompletedEventArgs.Result Property

public GetMailTipsResponseMessageType Result {get;}

Remarks

See Also

GetMailTipsCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


GetMailTipsCompletedEventHandler Delegate

public delegate void GetMailTipsCompletedEventHandler(
object sender,
GetMailTipsCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


GetMailTipsResponseMessageType Class

For a list of all members of this type, see GetMailTipsResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ResponseMessageType
Aspose.Email.Exchange.Schema.GetMailTipsResponseMessageType

public class GetMailTipsResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetMailTipsResponseMessageType Members | Aspose.Email.Exchange.Schema Namespace


GetMailTipsResponseMessageType Members

GetMailTipsResponseMessageType overview

Public Instance Constructors

GetMailTipsResponseMessageType Constructor Initializes a new instance of the GetMailTipsResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
ResponseMessages

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetMailTipsResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


GetMailTipsResponseMessageType Constructor

Initializes a new instance of the GetMailTipsResponseMessageType class.

public GetMailTipsResponseMessageType();

See Also

GetMailTipsResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


GetMailTipsResponseMessageType Properties

The properties of the GetMailTipsResponseMessageType class are listed below. For a complete list of GetMailTipsResponseMessageType class members, see the GetMailTipsResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
ResponseMessages

See Also

GetMailTipsResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


ResponseMessages Property

Aspose.Email

GetMailTipsResponseMessageType.ResponseMessages Property

public MailTipsResponseMessageType[] ResponseMessages {get; set;}

Remarks

See Also

GetMailTipsResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


GetMailTipsType Class

For a list of all members of this type, see GetMailTipsType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.GetMailTipsType

public class GetMailTipsType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetMailTipsType Members | Aspose.Email.Exchange.Schema Namespace


GetMailTipsType Members

GetMailTipsType overview

Public Instance Constructors

GetMailTipsType Constructor Initializes a new instance of the GetMailTipsType class.

Public Instance Properties

MailTipsRequested
Recipients
SendingAs

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetMailTipsType Class | Aspose.Email.Exchange.Schema Namespace


GetMailTipsType Constructor

Initializes a new instance of the GetMailTipsType class.

public GetMailTipsType();

See Also

GetMailTipsType Class | Aspose.Email.Exchange.Schema Namespace


GetMailTipsType Properties

The properties of the GetMailTipsType class are listed below. For a complete list of GetMailTipsType class members, see the GetMailTipsType Members topic.

Public Instance Properties

MailTipsRequested
Recipients
SendingAs

See Also

GetMailTipsType Class | Aspose.Email.Exchange.Schema Namespace


MailTipsRequested Property

Aspose.Email

GetMailTipsType.MailTipsRequested Property

public MailTipTypes MailTipsRequested {get; set;}

Remarks

See Also

GetMailTipsType Class | Aspose.Email.Exchange.Schema Namespace


Recipients Property

Aspose.Email

GetMailTipsType.Recipients Property

public EmailAddressType[] Recipients {get; set;}

Remarks

See Also

GetMailTipsType Class | Aspose.Email.Exchange.Schema Namespace


SendingAs Property

Aspose.Email

GetMailTipsType.SendingAs Property

public EmailAddressType SendingAs {get; set;}

Remarks

See Also

GetMailTipsType Class | Aspose.Email.Exchange.Schema Namespace


GetMessageTrackingReportCompletedEventArgs Class

For a list of all members of this type, see GetMessageTrackingReportCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.GetMessageTrackingReportCompletedEventArgs

public class GetMessageTrackingReportCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetMessageTrackingReportCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


GetMessageTrackingReportCompletedEventArgs Members

GetMessageTrackingReportCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetMessageTrackingReportCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


GetMessageTrackingReportCompletedEventArgs Properties

The properties of the GetMessageTrackingReportCompletedEventArgs class are listed below. For a complete list of GetMessageTrackingReportCompletedEventArgs class members, see the GetMessageTrackingReportCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetMessageTrackingReportCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

GetMessageTrackingReportCompletedEventArgs.Result Property

public GetMessageTrackingReportResponseMessageType Result {get;}

Remarks

See Also

GetMessageTrackingReportCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


GetMessageTrackingReportCompletedEventHandler Delegate

public delegate void GetMessageTrackingReportCompletedEventHandler(
object sender,
GetMessageTrackingReportCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


GetMessageTrackingReportRequestType Class

For a list of all members of this type, see GetMessageTrackingReportRequestType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.GetMessageTrackingReportRequestType

public class GetMessageTrackingReportRequestType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetMessageTrackingReportRequestType Members | Aspose.Email.Exchange.Schema Namespace


GetMessageTrackingReportRequestType Members

GetMessageTrackingReportRequestType overview

Public Instance Constructors

GetMessageTrackingReportRequestType Constructor Initializes a new instance of the GetMessageTrackingReportRequestType class.

Public Instance Properties

DiagnosticsLevel
MessageTrackingReportId
Properties
RecipientFilter
ReportTemplate
ReturnQueueEvents
ReturnQueueEventsSpecified
Scope

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema Namespace


GetMessageTrackingReportRequestType Constructor

Initializes a new instance of the GetMessageTrackingReportRequestType class.

public GetMessageTrackingReportRequestType();

See Also

GetMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema Namespace


GetMessageTrackingReportRequestType Properties

The properties of the GetMessageTrackingReportRequestType class are listed below. For a complete list of GetMessageTrackingReportRequestType class members, see the GetMessageTrackingReportRequestType Members topic.

Public Instance Properties

DiagnosticsLevel
MessageTrackingReportId
Properties
RecipientFilter
ReportTemplate
ReturnQueueEvents
ReturnQueueEventsSpecified
Scope

See Also

GetMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema Namespace


DiagnosticsLevel Property

Aspose.Email

GetMessageTrackingReportRequestType.DiagnosticsLevel Property

public string DiagnosticsLevel {get; set;}

Remarks

See Also

GetMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema Namespace


MessageTrackingReportId Property

Aspose.Email

GetMessageTrackingReportRequestType.MessageTrackingReportId Property

public string MessageTrackingReportId {get; set;}

Remarks

See Also

GetMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema Namespace


Properties Property

Aspose.Email

GetMessageTrackingReportRequestType.Properties Property

public TrackingPropertyType[] Properties {get; set;}

Remarks

See Also

GetMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema Namespace


RecipientFilter Property

Aspose.Email

GetMessageTrackingReportRequestType.RecipientFilter Property

public EmailAddressType RecipientFilter {get; set;}

Remarks

See Also

GetMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema Namespace


ReportTemplate Property

Aspose.Email

GetMessageTrackingReportRequestType.ReportTemplate Property

public MessageTrackingReportTemplateType ReportTemplate {get; set;}

Remarks

See Also

GetMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema Namespace


ReturnQueueEvents Property

Aspose.Email

GetMessageTrackingReportRequestType.ReturnQueueEvents Property

public bool ReturnQueueEvents {get; set;}

Remarks

See Also

GetMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema Namespace


ReturnQueueEventsSpecified Property

Aspose.Email

GetMessageTrackingReportRequestType.ReturnQueueEventsSpecified Property

public bool ReturnQueueEventsSpecified {get; set;}

Remarks

See Also

GetMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema Namespace


Scope Property

Aspose.Email

GetMessageTrackingReportRequestType.Scope Property

public string Scope {get; set;}

Remarks

See Also

GetMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema Namespace


GetMessageTrackingReportResponseMessageType Class

For a list of all members of this type, see GetMessageTrackingReportResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ResponseMessageType
Aspose.Email.Exchange.Schema.GetMessageTrackingReportResponseMessageType

public class GetMessageTrackingReportResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetMessageTrackingReportResponseMessageType Members | Aspose.Email.Exchange.Schema Namespace


GetMessageTrackingReportResponseMessageType Members

GetMessageTrackingReportResponseMessageType overview

Public Instance Constructors

GetMessageTrackingReportResponseMessageType Constructor Initializes a new instance of the GetMessageTrackingReportResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
Diagnostics
Errors
MessageText (inherited from ResponseMessageType)
MessageTrackingReport
MessageXml (inherited from ResponseMessageType)
Properties
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
Warnings

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetMessageTrackingReportResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


GetMessageTrackingReportResponseMessageType Constructor

Initializes a new instance of the GetMessageTrackingReportResponseMessageType class.

public GetMessageTrackingReportResponseMessageType();

See Also

GetMessageTrackingReportResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


GetMessageTrackingReportResponseMessageType Properties

The properties of the GetMessageTrackingReportResponseMessageType class are listed below. For a complete list of GetMessageTrackingReportResponseMessageType class members, see the GetMessageTrackingReportResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
Diagnostics
Errors
MessageText (inherited from ResponseMessageType)
MessageTrackingReport
MessageXml (inherited from ResponseMessageType)
Properties
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
Warnings

See Also

GetMessageTrackingReportResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


Diagnostics Property

Aspose.Email

GetMessageTrackingReportResponseMessageType.Diagnostics Property

public string[] Diagnostics {get; set;}

Remarks

See Also

GetMessageTrackingReportResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


Errors Property

Aspose.Email

GetMessageTrackingReportResponseMessageType.Errors Property

public ArrayOfTrackingPropertiesType[] Errors {get; set;}

Remarks

See Also

GetMessageTrackingReportResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


MessageTrackingReport Property

Aspose.Email

GetMessageTrackingReportResponseMessageType.MessageTrackingReport Property

public MessageTrackingReportType MessageTrackingReport {get; set;}

Remarks

See Also

GetMessageTrackingReportResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


Properties Property

Aspose.Email

GetMessageTrackingReportResponseMessageType.Properties Property

public TrackingPropertyType[] Properties {get; set;}

Remarks

See Also

GetMessageTrackingReportResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


Warnings Property

Aspose.Email

GetMessageTrackingReportResponseMessageType.Warnings Property

public string[] Warnings {get; set;}

Remarks

See Also

GetMessageTrackingReportResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


GetPhoneCallInformationCompletedEventArgs Class

For a list of all members of this type, see GetPhoneCallInformationCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.GetPhoneCallInformationCompletedEventArgs

public class GetPhoneCallInformationCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetPhoneCallInformationCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


GetPhoneCallInformationCompletedEventArgs Members

GetPhoneCallInformationCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetPhoneCallInformationCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


GetPhoneCallInformationCompletedEventArgs Properties

The properties of the GetPhoneCallInformationCompletedEventArgs class are listed below. For a complete list of GetPhoneCallInformationCompletedEventArgs class members, see the GetPhoneCallInformationCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetPhoneCallInformationCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

GetPhoneCallInformationCompletedEventArgs.Result Property

public GetPhoneCallInformationResponseMessageType Result {get;}

Remarks

See Also

GetPhoneCallInformationCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


GetPhoneCallInformationCompletedEventHandler Delegate

public delegate void GetPhoneCallInformationCompletedEventHandler(
object sender,
GetPhoneCallInformationCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


GetPhoneCallInformationResponseMessageType Class

For a list of all members of this type, see GetPhoneCallInformationResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ResponseMessageType
Aspose.Email.Exchange.Schema.GetPhoneCallInformationResponseMessageType

public class GetPhoneCallInformationResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetPhoneCallInformationResponseMessageType Members | Aspose.Email.Exchange.Schema Namespace


GetPhoneCallInformationResponseMessageType Members

GetPhoneCallInformationResponseMessageType overview

Public Instance Constructors

GetPhoneCallInformationResponseMessageType Constructor Initializes a new instance of the GetPhoneCallInformationResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
PhoneCallInformation
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetPhoneCallInformationResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


GetPhoneCallInformationResponseMessageType Constructor

Initializes a new instance of the GetPhoneCallInformationResponseMessageType class.

public GetPhoneCallInformationResponseMessageType();

See Also

GetPhoneCallInformationResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


GetPhoneCallInformationResponseMessageType Properties

The properties of the GetPhoneCallInformationResponseMessageType class are listed below. For a complete list of GetPhoneCallInformationResponseMessageType class members, see the GetPhoneCallInformationResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
PhoneCallInformation
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

GetPhoneCallInformationResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


PhoneCallInformation Property

Aspose.Email

GetPhoneCallInformationResponseMessageType.PhoneCallInformation Property

public PhoneCallInformationType PhoneCallInformation {get; set;}

Remarks

See Also

GetPhoneCallInformationResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


GetPhoneCallInformationType Class

For a list of all members of this type, see GetPhoneCallInformationType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.GetPhoneCallInformationType

public class GetPhoneCallInformationType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetPhoneCallInformationType Members | Aspose.Email.Exchange.Schema Namespace


GetPhoneCallInformationType Members

GetPhoneCallInformationType overview

Public Instance Constructors

GetPhoneCallInformationType Constructor Initializes a new instance of the GetPhoneCallInformationType class.

Public Instance Properties

PhoneCallId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetPhoneCallInformationType Class | Aspose.Email.Exchange.Schema Namespace


GetPhoneCallInformationType Constructor

Initializes a new instance of the GetPhoneCallInformationType class.

public GetPhoneCallInformationType();

See Also

GetPhoneCallInformationType Class | Aspose.Email.Exchange.Schema Namespace


GetPhoneCallInformationType Properties

The properties of the GetPhoneCallInformationType class are listed below. For a complete list of GetPhoneCallInformationType class members, see the GetPhoneCallInformationType Members topic.

Public Instance Properties

PhoneCallId

See Also

GetPhoneCallInformationType Class | Aspose.Email.Exchange.Schema Namespace


PhoneCallId Property

Aspose.Email

GetPhoneCallInformationType.PhoneCallId Property

public PhoneCallIdType PhoneCallId {get; set;}

Remarks

See Also

GetPhoneCallInformationType Class | Aspose.Email.Exchange.Schema Namespace


GetRoomListsCompletedEventArgs Class

For a list of all members of this type, see GetRoomListsCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.GetRoomListsCompletedEventArgs

public class GetRoomListsCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetRoomListsCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


GetRoomListsCompletedEventArgs Members

GetRoomListsCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetRoomListsCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


GetRoomListsCompletedEventArgs Properties

The properties of the GetRoomListsCompletedEventArgs class are listed below. For a complete list of GetRoomListsCompletedEventArgs class members, see the GetRoomListsCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetRoomListsCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

GetRoomListsCompletedEventArgs.Result Property

public GetRoomListsResponseMessageType Result {get;}

Remarks

See Also

GetRoomListsCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


GetRoomListsCompletedEventHandler Delegate

public delegate void GetRoomListsCompletedEventHandler(
object sender,
GetRoomListsCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


GetRoomListsResponseMessageType Class

For a list of all members of this type, see GetRoomListsResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ResponseMessageType
Aspose.Email.Exchange.Schema.GetRoomListsResponseMessageType

public class GetRoomListsResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetRoomListsResponseMessageType Members | Aspose.Email.Exchange.Schema Namespace


GetRoomListsResponseMessageType Members

GetRoomListsResponseMessageType overview

Public Instance Constructors

GetRoomListsResponseMessageType Constructor Initializes a new instance of the GetRoomListsResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
RoomLists

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetRoomListsResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


GetRoomListsResponseMessageType Constructor

Initializes a new instance of the GetRoomListsResponseMessageType class.

public GetRoomListsResponseMessageType();

See Also

GetRoomListsResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


GetRoomListsResponseMessageType Properties

The properties of the GetRoomListsResponseMessageType class are listed below. For a complete list of GetRoomListsResponseMessageType class members, see the GetRoomListsResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
RoomLists

See Also

GetRoomListsResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


RoomLists Property

Aspose.Email

GetRoomListsResponseMessageType.RoomLists Property

public EmailAddressType[] RoomLists {get; set;}

Remarks

See Also

GetRoomListsResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


GetRoomListsType Class

For a list of all members of this type, see GetRoomListsType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.GetRoomListsType

public class GetRoomListsType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetRoomListsType Members | Aspose.Email.Exchange.Schema Namespace


GetRoomListsType Members

GetRoomListsType overview

Public Instance Constructors

GetRoomListsType Constructor Initializes a new instance of the GetRoomListsType class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetRoomListsType Class | Aspose.Email.Exchange.Schema Namespace


GetRoomListsType Constructor

Initializes a new instance of the GetRoomListsType class.

public GetRoomListsType();

See Also

GetRoomListsType Class | Aspose.Email.Exchange.Schema Namespace


GetRoomsCompletedEventArgs Class

For a list of all members of this type, see GetRoomsCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.GetRoomsCompletedEventArgs

public class GetRoomsCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetRoomsCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


GetRoomsCompletedEventArgs Members

GetRoomsCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetRoomsCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


GetRoomsCompletedEventArgs Properties

The properties of the GetRoomsCompletedEventArgs class are listed below. For a complete list of GetRoomsCompletedEventArgs class members, see the GetRoomsCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetRoomsCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

GetRoomsCompletedEventArgs.Result Property

public GetRoomsResponseMessageType Result {get;}

Remarks

See Also

GetRoomsCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


GetRoomsCompletedEventHandler Delegate

public delegate void GetRoomsCompletedEventHandler(
object sender,
GetRoomsCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


GetRoomsResponseMessageType Class

For a list of all members of this type, see GetRoomsResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ResponseMessageType
Aspose.Email.Exchange.Schema.GetRoomsResponseMessageType

public class GetRoomsResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetRoomsResponseMessageType Members | Aspose.Email.Exchange.Schema Namespace


GetRoomsResponseMessageType Members

GetRoomsResponseMessageType overview

Public Instance Constructors

GetRoomsResponseMessageType Constructor Initializes a new instance of the GetRoomsResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
Rooms

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetRoomsResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


GetRoomsResponseMessageType Constructor

Initializes a new instance of the GetRoomsResponseMessageType class.

public GetRoomsResponseMessageType();

See Also

GetRoomsResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


GetRoomsResponseMessageType Properties

The properties of the GetRoomsResponseMessageType class are listed below. For a complete list of GetRoomsResponseMessageType class members, see the GetRoomsResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
Rooms

See Also

GetRoomsResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


Rooms Property

Aspose.Email

GetRoomsResponseMessageType.Rooms Property

public RoomType[] Rooms {get; set;}

Remarks

See Also

GetRoomsResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


GetRoomsType Class

For a list of all members of this type, see GetRoomsType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.GetRoomsType

public class GetRoomsType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetRoomsType Members | Aspose.Email.Exchange.Schema Namespace


GetRoomsType Members

GetRoomsType overview

Public Instance Constructors

GetRoomsType Constructor Initializes a new instance of the GetRoomsType class.

Public Instance Properties

RoomList

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetRoomsType Class | Aspose.Email.Exchange.Schema Namespace


GetRoomsType Constructor

Initializes a new instance of the GetRoomsType class.

public GetRoomsType();

See Also

GetRoomsType Class | Aspose.Email.Exchange.Schema Namespace


GetRoomsType Properties

The properties of the GetRoomsType class are listed below. For a complete list of GetRoomsType class members, see the GetRoomsType Members topic.

Public Instance Properties

RoomList

See Also

GetRoomsType Class | Aspose.Email.Exchange.Schema Namespace


RoomList Property

Aspose.Email

GetRoomsType.RoomList Property

public EmailAddressType RoomList {get; set;}

Remarks

See Also

GetRoomsType Class | Aspose.Email.Exchange.Schema Namespace


GetServerTimeZonesCompletedEventArgs Class

For a list of all members of this type, see GetServerTimeZonesCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.GetServerTimeZonesCompletedEventArgs

public class GetServerTimeZonesCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetServerTimeZonesCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


GetServerTimeZonesCompletedEventArgs Members

GetServerTimeZonesCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetServerTimeZonesCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


GetServerTimeZonesCompletedEventArgs Properties

The properties of the GetServerTimeZonesCompletedEventArgs class are listed below. For a complete list of GetServerTimeZonesCompletedEventArgs class members, see the GetServerTimeZonesCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetServerTimeZonesCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

GetServerTimeZonesCompletedEventArgs.Result Property

public GetServerTimeZonesResponseType Result {get;}

Remarks

See Also

GetServerTimeZonesCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


GetServerTimeZonesCompletedEventHandler Delegate

public delegate void GetServerTimeZonesCompletedEventHandler(
object sender,
GetServerTimeZonesCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


GetServerTimeZonesResponseMessageType Class

For a list of all members of this type, see GetServerTimeZonesResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ResponseMessageType
Aspose.Email.Exchange.Schema.GetServerTimeZonesResponseMessageType

public class GetServerTimeZonesResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetServerTimeZonesResponseMessageType Members | Aspose.Email.Exchange.Schema Namespace


GetServerTimeZonesResponseMessageType Members

GetServerTimeZonesResponseMessageType overview

Public Instance Constructors

GetServerTimeZonesResponseMessageType Constructor Initializes a new instance of the GetServerTimeZonesResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
TimeZoneDefinitions

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetServerTimeZonesResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


GetServerTimeZonesResponseMessageType Constructor

Initializes a new instance of the GetServerTimeZonesResponseMessageType class.

public GetServerTimeZonesResponseMessageType();

See Also

GetServerTimeZonesResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


GetServerTimeZonesResponseMessageType Properties

The properties of the GetServerTimeZonesResponseMessageType class are listed below. For a complete list of GetServerTimeZonesResponseMessageType class members, see the GetServerTimeZonesResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
TimeZoneDefinitions

See Also

GetServerTimeZonesResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


TimeZoneDefinitions Property

Aspose.Email

GetServerTimeZonesResponseMessageType.TimeZoneDefinitions Property

public ArrayOfTimeZoneDefinitionType TimeZoneDefinitions {get; set;}

Remarks

See Also

GetServerTimeZonesResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


GetServerTimeZonesResponseType Class

For a list of all members of this type, see GetServerTimeZonesResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseResponseMessageType
Aspose.Email.Exchange.Schema.GetServerTimeZonesResponseType

public class GetServerTimeZonesResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetServerTimeZonesResponseType Members | Aspose.Email.Exchange.Schema Namespace


GetServerTimeZonesResponseType Members

GetServerTimeZonesResponseType overview

Public Instance Constructors

GetServerTimeZonesResponseType Constructor Initializes a new instance of the GetServerTimeZonesResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetServerTimeZonesResponseType Class | Aspose.Email.Exchange.Schema Namespace


GetServerTimeZonesResponseType Constructor

Initializes a new instance of the GetServerTimeZonesResponseType class.

public GetServerTimeZonesResponseType();

See Also

GetServerTimeZonesResponseType Class | Aspose.Email.Exchange.Schema Namespace


GetServerTimeZonesType Class

For a list of all members of this type, see GetServerTimeZonesType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.GetServerTimeZonesType

public class GetServerTimeZonesType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetServerTimeZonesType Members | Aspose.Email.Exchange.Schema Namespace


GetServerTimeZonesType Members

GetServerTimeZonesType overview

Public Instance Constructors

GetServerTimeZonesType Constructor Initializes a new instance of the GetServerTimeZonesType class.

Public Instance Properties

Ids
ReturnFullTimeZoneData
ReturnFullTimeZoneDataSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetServerTimeZonesType Class | Aspose.Email.Exchange.Schema Namespace


GetServerTimeZonesType Constructor

Initializes a new instance of the GetServerTimeZonesType class.

public GetServerTimeZonesType();

See Also

GetServerTimeZonesType Class | Aspose.Email.Exchange.Schema Namespace


GetServerTimeZonesType Properties

The properties of the GetServerTimeZonesType class are listed below. For a complete list of GetServerTimeZonesType class members, see the GetServerTimeZonesType Members topic.

Public Instance Properties

Ids
ReturnFullTimeZoneData
ReturnFullTimeZoneDataSpecified

See Also

GetServerTimeZonesType Class | Aspose.Email.Exchange.Schema Namespace


Ids Property

Aspose.Email

GetServerTimeZonesType.Ids Property

public string[] Ids {get; set;}

Remarks

See Also

GetServerTimeZonesType Class | Aspose.Email.Exchange.Schema Namespace


ReturnFullTimeZoneData Property

Aspose.Email

GetServerTimeZonesType.ReturnFullTimeZoneData Property

public bool ReturnFullTimeZoneData {get; set;}

Remarks

See Also

GetServerTimeZonesType Class | Aspose.Email.Exchange.Schema Namespace


ReturnFullTimeZoneDataSpecified Property

Aspose.Email

GetServerTimeZonesType.ReturnFullTimeZoneDataSpecified Property

public bool ReturnFullTimeZoneDataSpecified {get; set;}

Remarks

See Also

GetServerTimeZonesType Class | Aspose.Email.Exchange.Schema Namespace


GetServiceConfigurationCompletedEventArgs Class

For a list of all members of this type, see GetServiceConfigurationCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.GetServiceConfigurationCompletedEventArgs

public class GetServiceConfigurationCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetServiceConfigurationCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


GetServiceConfigurationCompletedEventArgs Members

GetServiceConfigurationCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetServiceConfigurationCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


GetServiceConfigurationCompletedEventArgs Properties

The properties of the GetServiceConfigurationCompletedEventArgs class are listed below. For a complete list of GetServiceConfigurationCompletedEventArgs class members, see the GetServiceConfigurationCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetServiceConfigurationCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

GetServiceConfigurationCompletedEventArgs.Result Property

public GetServiceConfigurationResponseMessageType Result {get;}

Remarks

See Also

GetServiceConfigurationCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


GetServiceConfigurationCompletedEventHandler Delegate

public delegate void GetServiceConfigurationCompletedEventHandler(
object sender,
GetServiceConfigurationCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


GetServiceConfigurationResponseMessageType Class

For a list of all members of this type, see GetServiceConfigurationResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ResponseMessageType
Aspose.Email.Exchange.Schema.GetServiceConfigurationResponseMessageType

public class GetServiceConfigurationResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetServiceConfigurationResponseMessageType Members | Aspose.Email.Exchange.Schema Namespace


GetServiceConfigurationResponseMessageType Members

GetServiceConfigurationResponseMessageType overview

Public Instance Constructors

GetServiceConfigurationResponseMessageType Constructor Initializes a new instance of the GetServiceConfigurationResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
ResponseMessages

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetServiceConfigurationResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


GetServiceConfigurationResponseMessageType Constructor

Initializes a new instance of the GetServiceConfigurationResponseMessageType class.

public GetServiceConfigurationResponseMessageType();

See Also

GetServiceConfigurationResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


GetServiceConfigurationResponseMessageType Properties

The properties of the GetServiceConfigurationResponseMessageType class are listed below. For a complete list of GetServiceConfigurationResponseMessageType class members, see the GetServiceConfigurationResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
ResponseMessages

See Also

GetServiceConfigurationResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


ResponseMessages Property

Aspose.Email

GetServiceConfigurationResponseMessageType.ResponseMessages Property

public ServiceConfigurationResponseMessageType[] ResponseMessages {get; set;}

Remarks

See Also

GetServiceConfigurationResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


GetServiceConfigurationType Class

For a list of all members of this type, see GetServiceConfigurationType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.GetServiceConfigurationType

public class GetServiceConfigurationType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetServiceConfigurationType Members | Aspose.Email.Exchange.Schema Namespace


GetServiceConfigurationType Members

GetServiceConfigurationType overview

Public Instance Constructors

GetServiceConfigurationType Constructor Initializes a new instance of the GetServiceConfigurationType class.

Public Instance Properties

ActingAs
RequestedConfiguration

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetServiceConfigurationType Class | Aspose.Email.Exchange.Schema Namespace


GetServiceConfigurationType Constructor

Initializes a new instance of the GetServiceConfigurationType class.

public GetServiceConfigurationType();

See Also

GetServiceConfigurationType Class | Aspose.Email.Exchange.Schema Namespace


GetServiceConfigurationType Properties

The properties of the GetServiceConfigurationType class are listed below. For a complete list of GetServiceConfigurationType class members, see the GetServiceConfigurationType Members topic.

Public Instance Properties

ActingAs
RequestedConfiguration

See Also

GetServiceConfigurationType Class | Aspose.Email.Exchange.Schema Namespace


ActingAs Property

Aspose.Email

GetServiceConfigurationType.ActingAs Property

public EmailAddressType ActingAs {get; set;}

Remarks

See Also

GetServiceConfigurationType Class | Aspose.Email.Exchange.Schema Namespace


RequestedConfiguration Property

Aspose.Email

GetServiceConfigurationType.RequestedConfiguration Property

public ServiceConfigurationType[] RequestedConfiguration {get; set;}

Remarks

See Also

GetServiceConfigurationType Class | Aspose.Email.Exchange.Schema Namespace


GetSharingFolderCompletedEventArgs Class

For a list of all members of this type, see GetSharingFolderCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.GetSharingFolderCompletedEventArgs

public class GetSharingFolderCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetSharingFolderCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


GetSharingFolderCompletedEventArgs Members

GetSharingFolderCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetSharingFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


GetSharingFolderCompletedEventArgs Properties

The properties of the GetSharingFolderCompletedEventArgs class are listed below. For a complete list of GetSharingFolderCompletedEventArgs class members, see the GetSharingFolderCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetSharingFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

GetSharingFolderCompletedEventArgs.Result Property

public GetSharingFolderResponseMessageType Result {get;}

Remarks

See Also

GetSharingFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


GetSharingFolderCompletedEventHandler Delegate

public delegate void GetSharingFolderCompletedEventHandler(
object sender,
GetSharingFolderCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


GetSharingFolderResponseMessageType Class

For a list of all members of this type, see GetSharingFolderResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ResponseMessageType
Aspose.Email.Exchange.Schema.GetSharingFolderResponseMessageType

public class GetSharingFolderResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetSharingFolderResponseMessageType Members | Aspose.Email.Exchange.Schema Namespace


GetSharingFolderResponseMessageType Members

GetSharingFolderResponseMessageType overview

Public Instance Constructors

GetSharingFolderResponseMessageType Constructor Initializes a new instance of the GetSharingFolderResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
SharingFolderId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetSharingFolderResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


GetSharingFolderResponseMessageType Constructor

Initializes a new instance of the GetSharingFolderResponseMessageType class.

public GetSharingFolderResponseMessageType();

See Also

GetSharingFolderResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


GetSharingFolderResponseMessageType Properties

The properties of the GetSharingFolderResponseMessageType class are listed below. For a complete list of GetSharingFolderResponseMessageType class members, see the GetSharingFolderResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
SharingFolderId

See Also

GetSharingFolderResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


SharingFolderId Property

Aspose.Email

GetSharingFolderResponseMessageType.SharingFolderId Property

public FolderIdType SharingFolderId {get; set;}

Remarks

See Also

GetSharingFolderResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


GetSharingFolderType Class

For a list of all members of this type, see GetSharingFolderType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.GetSharingFolderType

public class GetSharingFolderType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetSharingFolderType Members | Aspose.Email.Exchange.Schema Namespace


GetSharingFolderType Members

GetSharingFolderType overview

Public Instance Constructors

GetSharingFolderType Constructor Initializes a new instance of the GetSharingFolderType class.

Public Instance Properties

DataType
DataTypeSpecified
SharedFolderId
SmtpAddress

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetSharingFolderType Class | Aspose.Email.Exchange.Schema Namespace


GetSharingFolderType Constructor

Initializes a new instance of the GetSharingFolderType class.

public GetSharingFolderType();

See Also

GetSharingFolderType Class | Aspose.Email.Exchange.Schema Namespace


GetSharingFolderType Properties

The properties of the GetSharingFolderType class are listed below. For a complete list of GetSharingFolderType class members, see the GetSharingFolderType Members topic.

Public Instance Properties

DataType
DataTypeSpecified
SharedFolderId
SmtpAddress

See Also

GetSharingFolderType Class | Aspose.Email.Exchange.Schema Namespace


DataType Property

Aspose.Email

GetSharingFolderType.DataType Property

public SharingDataType DataType {get; set;}

Remarks

See Also

GetSharingFolderType Class | Aspose.Email.Exchange.Schema Namespace


DataTypeSpecified Property

Aspose.Email

GetSharingFolderType.DataTypeSpecified Property

public bool DataTypeSpecified {get; set;}

Remarks

See Also

GetSharingFolderType Class | Aspose.Email.Exchange.Schema Namespace


SharedFolderId Property

Aspose.Email

GetSharingFolderType.SharedFolderId Property

public string SharedFolderId {get; set;}

Remarks

See Also

GetSharingFolderType Class | Aspose.Email.Exchange.Schema Namespace


SmtpAddress Property

Aspose.Email

GetSharingFolderType.SmtpAddress Property

public string SmtpAddress {get; set;}

Remarks

See Also

GetSharingFolderType Class | Aspose.Email.Exchange.Schema Namespace


GetSharingMetadataCompletedEventArgs Class

For a list of all members of this type, see GetSharingMetadataCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.GetSharingMetadataCompletedEventArgs

public class GetSharingMetadataCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetSharingMetadataCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


GetSharingMetadataCompletedEventArgs Members

GetSharingMetadataCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetSharingMetadataCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


GetSharingMetadataCompletedEventArgs Properties

The properties of the GetSharingMetadataCompletedEventArgs class are listed below. For a complete list of GetSharingMetadataCompletedEventArgs class members, see the GetSharingMetadataCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetSharingMetadataCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

GetSharingMetadataCompletedEventArgs.Result Property

public GetSharingMetadataResponseMessageType Result {get;}

Remarks

See Also

GetSharingMetadataCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


GetSharingMetadataCompletedEventHandler Delegate

public delegate void GetSharingMetadataCompletedEventHandler(
object sender,
GetSharingMetadataCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


GetSharingMetadataResponseMessageType Class

For a list of all members of this type, see GetSharingMetadataResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ResponseMessageType
Aspose.Email.Exchange.Schema.GetSharingMetadataResponseMessageType

public class GetSharingMetadataResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetSharingMetadataResponseMessageType Members | Aspose.Email.Exchange.Schema Namespace


GetSharingMetadataResponseMessageType Members

GetSharingMetadataResponseMessageType overview

Public Instance Constructors

GetSharingMetadataResponseMessageType Constructor Initializes a new instance of the GetSharingMetadataResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
EncryptedSharedFolderDataCollection
InvalidRecipients
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetSharingMetadataResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


GetSharingMetadataResponseMessageType Constructor

Initializes a new instance of the GetSharingMetadataResponseMessageType class.

public GetSharingMetadataResponseMessageType();

See Also

GetSharingMetadataResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


GetSharingMetadataResponseMessageType Properties

The properties of the GetSharingMetadataResponseMessageType class are listed below. For a complete list of GetSharingMetadataResponseMessageType class members, see the GetSharingMetadataResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
EncryptedSharedFolderDataCollection
InvalidRecipients
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

GetSharingMetadataResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


EncryptedSharedFolderDataCollection Property

Aspose.Email

GetSharingMetadataResponseMessageType.EncryptedSharedFolderDataCollection Property

public EncryptedSharedFolderDataType[] EncryptedSharedFolderDataCollection {get; set;}

Remarks

See Also

GetSharingMetadataResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


InvalidRecipients Property

Aspose.Email

GetSharingMetadataResponseMessageType.InvalidRecipients Property

public InvalidRecipientType[] InvalidRecipients {get; set;}

Remarks

See Also

GetSharingMetadataResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


GetSharingMetadataType Class

For a list of all members of this type, see GetSharingMetadataType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.GetSharingMetadataType

public class GetSharingMetadataType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetSharingMetadataType Members | Aspose.Email.Exchange.Schema Namespace


GetSharingMetadataType Members

GetSharingMetadataType overview

Public Instance Constructors

GetSharingMetadataType Constructor Initializes a new instance of the GetSharingMetadataType class.

Public Instance Properties

IdOfFolderToShare
Recipients
SenderSmtpAddress

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetSharingMetadataType Class | Aspose.Email.Exchange.Schema Namespace


GetSharingMetadataType Constructor

Initializes a new instance of the GetSharingMetadataType class.

public GetSharingMetadataType();

See Also

GetSharingMetadataType Class | Aspose.Email.Exchange.Schema Namespace


GetSharingMetadataType Properties

The properties of the GetSharingMetadataType class are listed below. For a complete list of GetSharingMetadataType class members, see the GetSharingMetadataType Members topic.

Public Instance Properties

IdOfFolderToShare
Recipients
SenderSmtpAddress

See Also

GetSharingMetadataType Class | Aspose.Email.Exchange.Schema Namespace


IdOfFolderToShare Property

Aspose.Email

GetSharingMetadataType.IdOfFolderToShare Property

public FolderIdType IdOfFolderToShare {get; set;}

Remarks

See Also

GetSharingMetadataType Class | Aspose.Email.Exchange.Schema Namespace


Recipients Property

Aspose.Email

GetSharingMetadataType.Recipients Property

public string[] Recipients {get; set;}

Remarks

See Also

GetSharingMetadataType Class | Aspose.Email.Exchange.Schema Namespace


SenderSmtpAddress Property

Aspose.Email

GetSharingMetadataType.SenderSmtpAddress Property

public string SenderSmtpAddress {get; set;}

Remarks

See Also

GetSharingMetadataType Class | Aspose.Email.Exchange.Schema Namespace


GetStreamingEventsCompletedEventArgs Class

For a list of all members of this type, see GetStreamingEventsCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.GetStreamingEventsCompletedEventArgs

public class GetStreamingEventsCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetStreamingEventsCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


GetStreamingEventsCompletedEventArgs Members

GetStreamingEventsCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetStreamingEventsCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


GetStreamingEventsCompletedEventArgs Properties

The properties of the GetStreamingEventsCompletedEventArgs class are listed below. For a complete list of GetStreamingEventsCompletedEventArgs class members, see the GetStreamingEventsCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetStreamingEventsCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

GetStreamingEventsCompletedEventArgs.Result Property

public GetStreamingEventsResponseType Result {get;}

Remarks

See Also

GetStreamingEventsCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


GetStreamingEventsCompletedEventHandler Delegate

public delegate void GetStreamingEventsCompletedEventHandler(
object sender,
GetStreamingEventsCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


GetStreamingEventsResponseMessageType Class

For a list of all members of this type, see GetStreamingEventsResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ResponseMessageType
Aspose.Email.Exchange.Schema.GetStreamingEventsResponseMessageType

public class GetStreamingEventsResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetStreamingEventsResponseMessageType Members | Aspose.Email.Exchange.Schema Namespace


GetStreamingEventsResponseMessageType Members

GetStreamingEventsResponseMessageType overview

Public Instance Constructors

GetStreamingEventsResponseMessageType Constructor Initializes a new instance of the GetStreamingEventsResponseMessageType class.

Public Instance Properties

ConnectionStatus
ConnectionStatusSpecified
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
ErrorSubscriptionIds
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
Notifications
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetStreamingEventsResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


GetStreamingEventsResponseMessageType Constructor

Initializes a new instance of the GetStreamingEventsResponseMessageType class.

public GetStreamingEventsResponseMessageType();

See Also

GetStreamingEventsResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


GetStreamingEventsResponseMessageType Properties

The properties of the GetStreamingEventsResponseMessageType class are listed below. For a complete list of GetStreamingEventsResponseMessageType class members, see the GetStreamingEventsResponseMessageType Members topic.

Public Instance Properties

ConnectionStatus
ConnectionStatusSpecified
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
ErrorSubscriptionIds
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
Notifications
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

GetStreamingEventsResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


ConnectionStatus Property

Aspose.Email

GetStreamingEventsResponseMessageType.ConnectionStatus Property

public ConnectionStatusType ConnectionStatus {get; set;}

Remarks

See Also

GetStreamingEventsResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


ConnectionStatusSpecified Property

Aspose.Email

GetStreamingEventsResponseMessageType.ConnectionStatusSpecified Property

public bool ConnectionStatusSpecified {get; set;}

Remarks

See Also

GetStreamingEventsResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


ErrorSubscriptionIds Property

Aspose.Email

GetStreamingEventsResponseMessageType.ErrorSubscriptionIds Property

public string[] ErrorSubscriptionIds {get; set;}

Remarks

See Also

GetStreamingEventsResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


Notifications Property

Aspose.Email

GetStreamingEventsResponseMessageType.Notifications Property

public NotificationType[] Notifications {get; set;}

Remarks

See Also

GetStreamingEventsResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


GetStreamingEventsResponseType Class

For a list of all members of this type, see GetStreamingEventsResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseResponseMessageType
Aspose.Email.Exchange.Schema.GetStreamingEventsResponseType

public class GetStreamingEventsResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetStreamingEventsResponseType Members | Aspose.Email.Exchange.Schema Namespace


GetStreamingEventsResponseType Members

GetStreamingEventsResponseType overview

Public Instance Constructors

GetStreamingEventsResponseType Constructor Initializes a new instance of the GetStreamingEventsResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetStreamingEventsResponseType Class | Aspose.Email.Exchange.Schema Namespace


GetStreamingEventsResponseType Constructor

Initializes a new instance of the GetStreamingEventsResponseType class.

public GetStreamingEventsResponseType();

See Also

GetStreamingEventsResponseType Class | Aspose.Email.Exchange.Schema Namespace


GetStreamingEventsType Class

For a list of all members of this type, see GetStreamingEventsType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.GetStreamingEventsType

public class GetStreamingEventsType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetStreamingEventsType Members | Aspose.Email.Exchange.Schema Namespace


GetStreamingEventsType Members

GetStreamingEventsType overview

Public Instance Constructors

GetStreamingEventsType Constructor Initializes a new instance of the GetStreamingEventsType class.

Public Instance Properties

ConnectionTimeout
SubscriptionIds

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetStreamingEventsType Class | Aspose.Email.Exchange.Schema Namespace


GetStreamingEventsType Constructor

Initializes a new instance of the GetStreamingEventsType class.

public GetStreamingEventsType();

See Also

GetStreamingEventsType Class | Aspose.Email.Exchange.Schema Namespace


GetStreamingEventsType Properties

The properties of the GetStreamingEventsType class are listed below. For a complete list of GetStreamingEventsType class members, see the GetStreamingEventsType Members topic.

Public Instance Properties

ConnectionTimeout
SubscriptionIds

See Also

GetStreamingEventsType Class | Aspose.Email.Exchange.Schema Namespace


ConnectionTimeout Property

Aspose.Email

GetStreamingEventsType.ConnectionTimeout Property

public int ConnectionTimeout {get; set;}

Remarks

See Also

GetStreamingEventsType Class | Aspose.Email.Exchange.Schema Namespace


SubscriptionIds Property

Aspose.Email

GetStreamingEventsType.SubscriptionIds Property

public string[] SubscriptionIds {get; set;}

Remarks

See Also

GetStreamingEventsType Class | Aspose.Email.Exchange.Schema Namespace


GetUserAvailabilityCompletedEventArgs Class

For a list of all members of this type, see GetUserAvailabilityCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.GetUserAvailabilityCompletedEventArgs

public class GetUserAvailabilityCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetUserAvailabilityCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


GetUserAvailabilityCompletedEventArgs Members

GetUserAvailabilityCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetUserAvailabilityCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


GetUserAvailabilityCompletedEventArgs Properties

The properties of the GetUserAvailabilityCompletedEventArgs class are listed below. For a complete list of GetUserAvailabilityCompletedEventArgs class members, see the GetUserAvailabilityCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetUserAvailabilityCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

GetUserAvailabilityCompletedEventArgs.Result Property

public GetUserAvailabilityResponseType Result {get;}

Remarks

See Also

GetUserAvailabilityCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


GetUserAvailabilityCompletedEventHandler Delegate

public delegate void GetUserAvailabilityCompletedEventHandler(
object sender,
GetUserAvailabilityCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


GetUserAvailabilityRequestType Class

For a list of all members of this type, see GetUserAvailabilityRequestType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.GetUserAvailabilityRequestType

public class GetUserAvailabilityRequestType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetUserAvailabilityRequestType Members | Aspose.Email.Exchange.Schema Namespace


GetUserAvailabilityRequestType Members

GetUserAvailabilityRequestType overview

Public Instance Constructors

GetUserAvailabilityRequestType Constructor Initializes a new instance of the GetUserAvailabilityRequestType class.

Public Instance Properties

FreeBusyViewOptions
MailboxDataArray
SuggestionsViewOptions
TimeZone

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetUserAvailabilityRequestType Class | Aspose.Email.Exchange.Schema Namespace


GetUserAvailabilityRequestType Constructor

Initializes a new instance of the GetUserAvailabilityRequestType class.

public GetUserAvailabilityRequestType();

See Also

GetUserAvailabilityRequestType Class | Aspose.Email.Exchange.Schema Namespace


GetUserAvailabilityRequestType Properties

The properties of the GetUserAvailabilityRequestType class are listed below. For a complete list of GetUserAvailabilityRequestType class members, see the GetUserAvailabilityRequestType Members topic.

Public Instance Properties

FreeBusyViewOptions
MailboxDataArray
SuggestionsViewOptions
TimeZone

See Also

GetUserAvailabilityRequestType Class | Aspose.Email.Exchange.Schema Namespace


FreeBusyViewOptions Property

Aspose.Email

GetUserAvailabilityRequestType.FreeBusyViewOptions Property

public FreeBusyViewOptionsType FreeBusyViewOptions {get; set;}

Remarks

See Also

GetUserAvailabilityRequestType Class | Aspose.Email.Exchange.Schema Namespace


MailboxDataArray Property

Aspose.Email

GetUserAvailabilityRequestType.MailboxDataArray Property

public MailboxData[] MailboxDataArray {get; set;}

Remarks

See Also

GetUserAvailabilityRequestType Class | Aspose.Email.Exchange.Schema Namespace


SuggestionsViewOptions Property

Aspose.Email

GetUserAvailabilityRequestType.SuggestionsViewOptions Property

public SuggestionsViewOptionsType SuggestionsViewOptions {get; set;}

Remarks

See Also

GetUserAvailabilityRequestType Class | Aspose.Email.Exchange.Schema Namespace


TimeZone Property

Aspose.Email

GetUserAvailabilityRequestType.TimeZone Property

public SerializableTimeZone TimeZone {get; set;}

Remarks

See Also

GetUserAvailabilityRequestType Class | Aspose.Email.Exchange.Schema Namespace


GetUserAvailabilityResponseType Class

For a list of all members of this type, see GetUserAvailabilityResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.GetUserAvailabilityResponseType

public class GetUserAvailabilityResponseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetUserAvailabilityResponseType Members | Aspose.Email.Exchange.Schema Namespace


GetUserAvailabilityResponseType Members

GetUserAvailabilityResponseType overview

Public Instance Constructors

GetUserAvailabilityResponseType Constructor Initializes a new instance of the GetUserAvailabilityResponseType class.

Public Instance Properties

FreeBusyResponseArray
SuggestionsResponse

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetUserAvailabilityResponseType Class | Aspose.Email.Exchange.Schema Namespace


GetUserAvailabilityResponseType Constructor

Initializes a new instance of the GetUserAvailabilityResponseType class.

public GetUserAvailabilityResponseType();

See Also

GetUserAvailabilityResponseType Class | Aspose.Email.Exchange.Schema Namespace


GetUserAvailabilityResponseType Properties

The properties of the GetUserAvailabilityResponseType class are listed below. For a complete list of GetUserAvailabilityResponseType class members, see the GetUserAvailabilityResponseType Members topic.

Public Instance Properties

FreeBusyResponseArray
SuggestionsResponse

See Also

GetUserAvailabilityResponseType Class | Aspose.Email.Exchange.Schema Namespace


FreeBusyResponseArray Property

Aspose.Email

GetUserAvailabilityResponseType.FreeBusyResponseArray Property

public FreeBusyResponseType[] FreeBusyResponseArray {get; set;}

Remarks

See Also

GetUserAvailabilityResponseType Class | Aspose.Email.Exchange.Schema Namespace


SuggestionsResponse Property

Aspose.Email

GetUserAvailabilityResponseType.SuggestionsResponse Property

public SuggestionsResponseType SuggestionsResponse {get; set;}

Remarks

See Also

GetUserAvailabilityResponseType Class | Aspose.Email.Exchange.Schema Namespace


GetUserConfigurationCompletedEventArgs Class

For a list of all members of this type, see GetUserConfigurationCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.GetUserConfigurationCompletedEventArgs

public class GetUserConfigurationCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetUserConfigurationCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


GetUserConfigurationCompletedEventArgs Members

GetUserConfigurationCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetUserConfigurationCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


GetUserConfigurationCompletedEventArgs Properties

The properties of the GetUserConfigurationCompletedEventArgs class are listed below. For a complete list of GetUserConfigurationCompletedEventArgs class members, see the GetUserConfigurationCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetUserConfigurationCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

GetUserConfigurationCompletedEventArgs.Result Property

public GetUserConfigurationResponseType Result {get;}

Remarks

See Also

GetUserConfigurationCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


GetUserConfigurationCompletedEventHandler Delegate

public delegate void GetUserConfigurationCompletedEventHandler(
object sender,
GetUserConfigurationCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


GetUserConfigurationResponseMessageType Class

For a list of all members of this type, see GetUserConfigurationResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ResponseMessageType
Aspose.Email.Exchange.Schema.GetUserConfigurationResponseMessageType

public class GetUserConfigurationResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetUserConfigurationResponseMessageType Members | Aspose.Email.Exchange.Schema Namespace


GetUserConfigurationResponseMessageType Members

GetUserConfigurationResponseMessageType overview

Public Instance Constructors

GetUserConfigurationResponseMessageType Constructor Initializes a new instance of the GetUserConfigurationResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
UserConfiguration

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetUserConfigurationResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


GetUserConfigurationResponseMessageType Constructor

Initializes a new instance of the GetUserConfigurationResponseMessageType class.

public GetUserConfigurationResponseMessageType();

See Also

GetUserConfigurationResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


GetUserConfigurationResponseMessageType Properties

The properties of the GetUserConfigurationResponseMessageType class are listed below. For a complete list of GetUserConfigurationResponseMessageType class members, see the GetUserConfigurationResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
UserConfiguration

See Also

GetUserConfigurationResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


UserConfiguration Property

Aspose.Email

GetUserConfigurationResponseMessageType.UserConfiguration Property

public UserConfigurationType UserConfiguration {get; set;}

Remarks

See Also

GetUserConfigurationResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


GetUserConfigurationResponseType Class

For a list of all members of this type, see GetUserConfigurationResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseResponseMessageType
Aspose.Email.Exchange.Schema.GetUserConfigurationResponseType

public class GetUserConfigurationResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetUserConfigurationResponseType Members | Aspose.Email.Exchange.Schema Namespace


GetUserConfigurationResponseType Members

GetUserConfigurationResponseType overview

Public Instance Constructors

GetUserConfigurationResponseType Constructor Initializes a new instance of the GetUserConfigurationResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetUserConfigurationResponseType Class | Aspose.Email.Exchange.Schema Namespace


GetUserConfigurationResponseType Constructor

Initializes a new instance of the GetUserConfigurationResponseType class.

public GetUserConfigurationResponseType();

See Also

GetUserConfigurationResponseType Class | Aspose.Email.Exchange.Schema Namespace


GetUserConfigurationType Class

For a list of all members of this type, see GetUserConfigurationType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.GetUserConfigurationType

public class GetUserConfigurationType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetUserConfigurationType Members | Aspose.Email.Exchange.Schema Namespace


GetUserConfigurationType Members

GetUserConfigurationType overview

Public Instance Constructors

GetUserConfigurationType Constructor Initializes a new instance of the GetUserConfigurationType class.

Public Instance Properties

UserConfigurationName
UserConfigurationProperties

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetUserConfigurationType Class | Aspose.Email.Exchange.Schema Namespace


GetUserConfigurationType Constructor

Initializes a new instance of the GetUserConfigurationType class.

public GetUserConfigurationType();

See Also

GetUserConfigurationType Class | Aspose.Email.Exchange.Schema Namespace


GetUserConfigurationType Properties

The properties of the GetUserConfigurationType class are listed below. For a complete list of GetUserConfigurationType class members, see the GetUserConfigurationType Members topic.

Public Instance Properties

UserConfigurationName
UserConfigurationProperties

See Also

GetUserConfigurationType Class | Aspose.Email.Exchange.Schema Namespace


UserConfigurationName Property

Aspose.Email

GetUserConfigurationType.UserConfigurationName Property

public UserConfigurationNameType UserConfigurationName {get; set;}

Remarks

See Also

GetUserConfigurationType Class | Aspose.Email.Exchange.Schema Namespace


UserConfigurationProperties Property

Aspose.Email

GetUserConfigurationType.UserConfigurationProperties Property

public UserConfigurationPropertyType UserConfigurationProperties {get; set;}

Remarks

See Also

GetUserConfigurationType Class | Aspose.Email.Exchange.Schema Namespace


GetUserOofSettingsCompletedEventArgs Class

For a list of all members of this type, see GetUserOofSettingsCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.GetUserOofSettingsCompletedEventArgs

public class GetUserOofSettingsCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetUserOofSettingsCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


GetUserOofSettingsCompletedEventArgs Members

GetUserOofSettingsCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetUserOofSettingsCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


GetUserOofSettingsCompletedEventArgs Properties

The properties of the GetUserOofSettingsCompletedEventArgs class are listed below. For a complete list of GetUserOofSettingsCompletedEventArgs class members, see the GetUserOofSettingsCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetUserOofSettingsCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

GetUserOofSettingsCompletedEventArgs.Result Property

public GetUserOofSettingsResponse Result {get;}

Remarks

See Also

GetUserOofSettingsCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


GetUserOofSettingsCompletedEventHandler Delegate

public delegate void GetUserOofSettingsCompletedEventHandler(
object sender,
GetUserOofSettingsCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


GetUserOofSettingsRequest Class

For a list of all members of this type, see GetUserOofSettingsRequest Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.GetUserOofSettingsRequest

public class GetUserOofSettingsRequest : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetUserOofSettingsRequest Members | Aspose.Email.Exchange.Schema Namespace


GetUserOofSettingsRequest Members

GetUserOofSettingsRequest overview

Public Instance Constructors

GetUserOofSettingsRequest Constructor Initializes a new instance of the GetUserOofSettingsRequest class.

Public Instance Properties

Mailbox

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetUserOofSettingsRequest Class | Aspose.Email.Exchange.Schema Namespace


GetUserOofSettingsRequest Constructor

Initializes a new instance of the GetUserOofSettingsRequest class.

public GetUserOofSettingsRequest();

See Also

GetUserOofSettingsRequest Class | Aspose.Email.Exchange.Schema Namespace


GetUserOofSettingsRequest Properties

The properties of the GetUserOofSettingsRequest class are listed below. For a complete list of GetUserOofSettingsRequest class members, see the GetUserOofSettingsRequest Members topic.

Public Instance Properties

Mailbox

See Also

GetUserOofSettingsRequest Class | Aspose.Email.Exchange.Schema Namespace


Mailbox Property

Aspose.Email

GetUserOofSettingsRequest.Mailbox Property

public EmailAddress Mailbox {get; set;}

Remarks

See Also

GetUserOofSettingsRequest Class | Aspose.Email.Exchange.Schema Namespace


GetUserOofSettingsResponse Class

For a list of all members of this type, see GetUserOofSettingsResponse Members.

System.Object
Aspose.Email.Exchange.Schema.GetUserOofSettingsResponse

public class GetUserOofSettingsResponse

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetUserOofSettingsResponse Members | Aspose.Email.Exchange.Schema Namespace


GetUserOofSettingsResponse Members

GetUserOofSettingsResponse overview

Public Instance Constructors

GetUserOofSettingsResponse Constructor Initializes a new instance of the GetUserOofSettingsResponse class.

Public Instance Properties

AllowExternalOof
AllowExternalOofSpecified
OofSettings
ResponseMessage

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetUserOofSettingsResponse Class | Aspose.Email.Exchange.Schema Namespace


GetUserOofSettingsResponse Constructor

Initializes a new instance of the GetUserOofSettingsResponse class.

public GetUserOofSettingsResponse();

See Also

GetUserOofSettingsResponse Class | Aspose.Email.Exchange.Schema Namespace


GetUserOofSettingsResponse Properties

The properties of the GetUserOofSettingsResponse class are listed below. For a complete list of GetUserOofSettingsResponse class members, see the GetUserOofSettingsResponse Members topic.

Public Instance Properties

AllowExternalOof
AllowExternalOofSpecified
OofSettings
ResponseMessage

See Also

GetUserOofSettingsResponse Class | Aspose.Email.Exchange.Schema Namespace


AllowExternalOof Property

Aspose.Email

GetUserOofSettingsResponse.AllowExternalOof Property

public ExternalAudience AllowExternalOof {get; set;}

Remarks

See Also

GetUserOofSettingsResponse Class | Aspose.Email.Exchange.Schema Namespace


AllowExternalOofSpecified Property

Aspose.Email

GetUserOofSettingsResponse.AllowExternalOofSpecified Property

public bool AllowExternalOofSpecified {get; set;}

Remarks

See Also

GetUserOofSettingsResponse Class | Aspose.Email.Exchange.Schema Namespace


OofSettings Property

Aspose.Email

GetUserOofSettingsResponse.OofSettings Property

public UserOofSettings OofSettings {get; set;}

Remarks

See Also

GetUserOofSettingsResponse Class | Aspose.Email.Exchange.Schema Namespace


ResponseMessage Property

Aspose.Email

GetUserOofSettingsResponse.ResponseMessage Property

public ResponseMessageType ResponseMessage {get; set;}

Remarks

See Also

GetUserOofSettingsResponse Class | Aspose.Email.Exchange.Schema Namespace


GroupAttendeeConflictData Class

For a list of all members of this type, see GroupAttendeeConflictData Members.

System.Object
Aspose.Email.Exchange.Schema.AttendeeConflictData
Aspose.Email.Exchange.Schema.GroupAttendeeConflictData

public class GroupAttendeeConflictData : AttendeeConflictData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GroupAttendeeConflictData Members | Aspose.Email.Exchange.Schema Namespace


GroupAttendeeConflictData Members

GroupAttendeeConflictData overview

Public Instance Constructors

GroupAttendeeConflictData Constructor Initializes a new instance of the GroupAttendeeConflictData class.

Public Instance Properties

NumberOfMembers
NumberOfMembersAvailable
NumberOfMembersWithConflict
NumberOfMembersWithNoData

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GroupAttendeeConflictData Class | Aspose.Email.Exchange.Schema Namespace


GroupAttendeeConflictData Constructor

Initializes a new instance of the GroupAttendeeConflictData class.

public GroupAttendeeConflictData();

See Also

GroupAttendeeConflictData Class | Aspose.Email.Exchange.Schema Namespace


GroupAttendeeConflictData Properties

The properties of the GroupAttendeeConflictData class are listed below. For a complete list of GroupAttendeeConflictData class members, see the GroupAttendeeConflictData Members topic.

Public Instance Properties

NumberOfMembers
NumberOfMembersAvailable
NumberOfMembersWithConflict
NumberOfMembersWithNoData

See Also

GroupAttendeeConflictData Class | Aspose.Email.Exchange.Schema Namespace


NumberOfMembers Property

Aspose.Email

GroupAttendeeConflictData.NumberOfMembers Property

public int NumberOfMembers {get; set;}

Remarks

See Also

GroupAttendeeConflictData Class | Aspose.Email.Exchange.Schema Namespace


NumberOfMembersAvailable Property

Aspose.Email

GroupAttendeeConflictData.NumberOfMembersAvailable Property

public int NumberOfMembersAvailable {get; set;}

Remarks

See Also

GroupAttendeeConflictData Class | Aspose.Email.Exchange.Schema Namespace


NumberOfMembersWithConflict Property

Aspose.Email

GroupAttendeeConflictData.NumberOfMembersWithConflict Property

public int NumberOfMembersWithConflict {get; set;}

Remarks

See Also

GroupAttendeeConflictData Class | Aspose.Email.Exchange.Schema Namespace


NumberOfMembersWithNoData Property

Aspose.Email

GroupAttendeeConflictData.NumberOfMembersWithNoData Property

public int NumberOfMembersWithNoData {get; set;}

Remarks

See Also

GroupAttendeeConflictData Class | Aspose.Email.Exchange.Schema Namespace


GroupByType Class

For a list of all members of this type, see GroupByType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseGroupByType
Aspose.Email.Exchange.Schema.GroupByType

public class GroupByType : BaseGroupByType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GroupByType Members | Aspose.Email.Exchange.Schema Namespace


GroupByType Members

GroupByType overview

Public Instance Constructors

GroupByType Constructor Initializes a new instance of the GroupByType class.

Public Instance Properties

AggregateOn
Item
Order (inherited from BaseGroupByType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GroupByType Class | Aspose.Email.Exchange.Schema Namespace


GroupByType Constructor

Initializes a new instance of the GroupByType class.

public GroupByType();

See Also

GroupByType Class | Aspose.Email.Exchange.Schema Namespace


GroupByType Properties

The properties of the GroupByType class are listed below. For a complete list of GroupByType class members, see the GroupByType Members topic.

Public Instance Properties

AggregateOn
Item
Order (inherited from BaseGroupByType)

See Also

GroupByType Class | Aspose.Email.Exchange.Schema Namespace


AggregateOn Property

Aspose.Email

GroupByType.AggregateOn Property

public AggregateOnType AggregateOn {get; set;}

Remarks

See Also

GroupByType Class | Aspose.Email.Exchange.Schema Namespace


Item Property

Aspose.Email

GroupByType.Item Property

public BasePathToElementType Item {get; set;}

Remarks

See Also

GroupByType Class | Aspose.Email.Exchange.Schema Namespace


GroupedItemsType Class

For a list of all members of this type, see GroupedItemsType Members.

System.Object
Aspose.Email.Exchange.Schema.GroupedItemsType

public class GroupedItemsType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GroupedItemsType Members | Aspose.Email.Exchange.Schema Namespace


GroupedItemsType Members

GroupedItemsType overview

Public Instance Constructors

GroupedItemsType Constructor Initializes a new instance of the GroupedItemsType class.

Public Instance Properties

GroupIndex
Items

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GroupedItemsType Class | Aspose.Email.Exchange.Schema Namespace


GroupedItemsType Constructor

Initializes a new instance of the GroupedItemsType class.

public GroupedItemsType();

See Also

GroupedItemsType Class | Aspose.Email.Exchange.Schema Namespace


GroupedItemsType Properties

The properties of the GroupedItemsType class are listed below. For a complete list of GroupedItemsType class members, see the GroupedItemsType Members topic.

Public Instance Properties

GroupIndex
Items

See Also

GroupedItemsType Class | Aspose.Email.Exchange.Schema Namespace


GroupIndex Property

Aspose.Email

GroupedItemsType.GroupIndex Property

public string GroupIndex {get; set;}

Remarks

See Also

GroupedItemsType Class | Aspose.Email.Exchange.Schema Namespace


Items Property

Aspose.Email

GroupedItemsType.Items Property

public ArrayOfRealItemsType Items {get; set;}

Remarks

See Also

GroupedItemsType Class | Aspose.Email.Exchange.Schema Namespace


IdFormatType Enumeration

public enum IdFormatType

Remarks

Members

Member Name | Description | Value
EwsLegacyId |  | 0
EwsId |  | 1
EntryId |  | 2
HexEntryId |  | 3
StoreId |  | 4
OwaId |  | 5

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


ImAddressDictionaryEntryType Class

For a list of all members of this type, see ImAddressDictionaryEntryType Members.

System.Object
Aspose.Email.Exchange.Schema.ImAddressDictionaryEntryType

public class ImAddressDictionaryEntryType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ImAddressDictionaryEntryType Members | Aspose.Email.Exchange.Schema Namespace


ImAddressDictionaryEntryType Members

ImAddressDictionaryEntryType overview

Public Instance Constructors

ImAddressDictionaryEntryType Constructor Initializes a new instance of the ImAddressDictionaryEntryType class.

Public Instance Properties

Key
Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ImAddressDictionaryEntryType Class | Aspose.Email.Exchange.Schema Namespace


ImAddressDictionaryEntryType Constructor

Initializes a new instance of the ImAddressDictionaryEntryType class.

public ImAddressDictionaryEntryType();

See Also

ImAddressDictionaryEntryType Class | Aspose.Email.Exchange.Schema Namespace


ImAddressDictionaryEntryType Properties

The properties of the ImAddressDictionaryEntryType class are listed below. For a complete list of ImAddressDictionaryEntryType class members, see the ImAddressDictionaryEntryType Members topic.

Public Instance Properties

Key
Value

See Also

ImAddressDictionaryEntryType Class | Aspose.Email.Exchange.Schema Namespace


Key Property

Aspose.Email

ImAddressDictionaryEntryType.Key Property

public ImAddressKeyType Key {get; set;}

Remarks

See Also

ImAddressDictionaryEntryType Class | Aspose.Email.Exchange.Schema Namespace


Value Property

Aspose.Email

ImAddressDictionaryEntryType.Value Property

public string Value {get; set;}

Remarks

See Also

ImAddressDictionaryEntryType Class | Aspose.Email.Exchange.Schema Namespace


ImAddressKeyType Enumeration

public enum ImAddressKeyType

Remarks

Members

Member Name | Description | Value
ImAddress1 |  | 0
ImAddress2 |  | 1
ImAddress3 |  | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


ImportanceChoicesType Enumeration

public enum ImportanceChoicesType

Remarks

Members

Member Name | Description | Value
Low |  | 0
Normal |  | 1
High |  | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


IndexBasePointType Enumeration

public enum IndexBasePointType

Remarks

Members

Member Name | Description | Value
Beginning |  | 0
End |  | 1

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


IndexedPageViewType Class

For a list of all members of this type, see IndexedPageViewType Members.

System.Object
Aspose.Email.Exchange.Schema.BasePagingType
Aspose.Email.Exchange.Schema.IndexedPageViewType

public class IndexedPageViewType : BasePagingType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

IndexedPageViewType Members | Aspose.Email.Exchange.Schema Namespace


IndexedPageViewType Members

IndexedPageViewType overview

Public Instance Constructors

IndexedPageViewType Constructor Initializes a new instance of the IndexedPageViewType class.

Public Instance Properties

BasePoint
MaxEntriesReturned (inherited from BasePagingType)
MaxEntriesReturnedSpecified (inherited from BasePagingType)
Offset

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IndexedPageViewType Class | Aspose.Email.Exchange.Schema Namespace


IndexedPageViewType Constructor

Initializes a new instance of the IndexedPageViewType class.

public IndexedPageViewType();

See Also

IndexedPageViewType Class | Aspose.Email.Exchange.Schema Namespace


IndexedPageViewType Properties

The properties of the IndexedPageViewType class are listed below. For a complete list of IndexedPageViewType class members, see the IndexedPageViewType Members topic.

Public Instance Properties

BasePoint
MaxEntriesReturned (inherited from BasePagingType)
MaxEntriesReturnedSpecified (inherited from BasePagingType)
Offset

See Also

IndexedPageViewType Class | Aspose.Email.Exchange.Schema Namespace


BasePoint Property

Aspose.Email

IndexedPageViewType.BasePoint Property

public IndexBasePointType BasePoint {get; set;}

Remarks

See Also

IndexedPageViewType Class | Aspose.Email.Exchange.Schema Namespace


Offset Property

Aspose.Email

IndexedPageViewType.Offset Property

public int Offset {get; set;}

Remarks

See Also

IndexedPageViewType Class | Aspose.Email.Exchange.Schema Namespace


IndividualAttendeeConflictData Class

For a list of all members of this type, see IndividualAttendeeConflictData Members.

System.Object
Aspose.Email.Exchange.Schema.AttendeeConflictData
Aspose.Email.Exchange.Schema.IndividualAttendeeConflictData

public class IndividualAttendeeConflictData : AttendeeConflictData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

IndividualAttendeeConflictData Members | Aspose.Email.Exchange.Schema Namespace


IndividualAttendeeConflictData Members

IndividualAttendeeConflictData overview

Public Instance Constructors

IndividualAttendeeConflictData Constructor Initializes a new instance of the IndividualAttendeeConflictData class.

Public Instance Properties

BusyType

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IndividualAttendeeConflictData Class | Aspose.Email.Exchange.Schema Namespace


IndividualAttendeeConflictData Constructor

Initializes a new instance of the IndividualAttendeeConflictData class.

public IndividualAttendeeConflictData();

See Also

IndividualAttendeeConflictData Class | Aspose.Email.Exchange.Schema Namespace


IndividualAttendeeConflictData Properties

The properties of the IndividualAttendeeConflictData class are listed below. For a complete list of IndividualAttendeeConflictData class members, see the IndividualAttendeeConflictData Members topic.

Public Instance Properties

BusyType

See Also

IndividualAttendeeConflictData Class | Aspose.Email.Exchange.Schema Namespace


BusyType Property

Aspose.Email

IndividualAttendeeConflictData.BusyType Property

public LegacyFreeBusyType BusyType {get; set;}

Remarks

See Also

IndividualAttendeeConflictData Class | Aspose.Email.Exchange.Schema Namespace


InternetHeaderType Class

For a list of all members of this type, see InternetHeaderType Members.

System.Object
Aspose.Email.Exchange.Schema.InternetHeaderType

public class InternetHeaderType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

InternetHeaderType Members | Aspose.Email.Exchange.Schema Namespace


InternetHeaderType Members

InternetHeaderType overview

Public Instance Constructors

InternetHeaderType Constructor Initializes a new instance of the InternetHeaderType class.

Public Instance Properties

HeaderName
Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InternetHeaderType Class | Aspose.Email.Exchange.Schema Namespace


InternetHeaderType Constructor

Initializes a new instance of the InternetHeaderType class.

public InternetHeaderType();

See Also

InternetHeaderType Class | Aspose.Email.Exchange.Schema Namespace


InternetHeaderType Properties

The properties of the InternetHeaderType class are listed below. For a complete list of InternetHeaderType class members, see the InternetHeaderType Members topic.

Public Instance Properties

HeaderName
Value

See Also

InternetHeaderType Class | Aspose.Email.Exchange.Schema Namespace


HeaderName Property

Aspose.Email

InternetHeaderType.HeaderName Property

public string HeaderName {get; set;}

Remarks

See Also

InternetHeaderType Class | Aspose.Email.Exchange.Schema Namespace


Value Property

Aspose.Email

InternetHeaderType.Value Property

public string Value {get; set;}

Remarks

See Also

InternetHeaderType Class | Aspose.Email.Exchange.Schema Namespace


IntervalRecurrencePatternBaseType Class

For a list of all members of this type, see IntervalRecurrencePatternBaseType Members.

System.Object
Aspose.Email.Exchange.Schema.RecurrencePatternBaseType
Aspose.Email.Exchange.Schema.IntervalRecurrencePatternBaseType
Aspose.Email.Exchange.Schema.AbsoluteMonthlyRecurrencePatternType
Aspose.Email.Exchange.Schema.DailyRecurrencePatternType
Aspose.Email.Exchange.Schema.RegeneratingPatternBaseType
Aspose.Email.Exchange.Schema.RelativeMonthlyRecurrencePatternType
Aspose.Email.Exchange.Schema.WeeklyRecurrencePatternType

public abstract class IntervalRecurrencePatternBaseType : RecurrencePatternBaseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

IntervalRecurrencePatternBaseType Members | Aspose.Email.Exchange.Schema Namespace


IntervalRecurrencePatternBaseType Members

IntervalRecurrencePatternBaseType overview

Public Instance Properties

Interval

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

IntervalRecurrencePatternBaseType Constructor Initializes a new instance of the IntervalRecurrencePatternBaseType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IntervalRecurrencePatternBaseType Class | Aspose.Email.Exchange.Schema Namespace


IntervalRecurrencePatternBaseType Constructor

Initializes a new instance of the IntervalRecurrencePatternBaseType class.

protected IntervalRecurrencePatternBaseType();

See Also

IntervalRecurrencePatternBaseType Class | Aspose.Email.Exchange.Schema Namespace


IntervalRecurrencePatternBaseType Properties

The properties of the IntervalRecurrencePatternBaseType class are listed below. For a complete list of IntervalRecurrencePatternBaseType class members, see the IntervalRecurrencePatternBaseType Members topic.

Public Instance Properties

Interval

See Also

IntervalRecurrencePatternBaseType Class | Aspose.Email.Exchange.Schema Namespace


Interval Property

Aspose.Email

IntervalRecurrencePatternBaseType.Interval Property

public int Interval {get; set;}

Remarks

See Also

IntervalRecurrencePatternBaseType Class | Aspose.Email.Exchange.Schema Namespace


InvalidRecipientResponseCodeType Enumeration

public enum InvalidRecipientResponseCodeType

Remarks

Members

Member Name | Description | Value
OtherError |  | 0
RecipientOrganizationNotFederated |  | 1
CannotObtainTokenFromSTS |  | 2
SystemPolicyBlocksSharingWithThisRecipient |  | 3
RecipientOrganizationFederatedWithUnknownTokenIssuer |  | 4

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


InvalidRecipientType Class

For a list of all members of this type, see InvalidRecipientType Members.

System.Object
Aspose.Email.Exchange.Schema.InvalidRecipientType

public class InvalidRecipientType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

InvalidRecipientType Members | Aspose.Email.Exchange.Schema Namespace


InvalidRecipientType Members

InvalidRecipientType overview

Public Instance Constructors

InvalidRecipientType Constructor Initializes a new instance of the InvalidRecipientType class.

Public Instance Properties

MessageText
ResponseCode
SmtpAddress

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InvalidRecipientType Class | Aspose.Email.Exchange.Schema Namespace


InvalidRecipientType Constructor

Initializes a new instance of the InvalidRecipientType class.

public InvalidRecipientType();

See Also

InvalidRecipientType Class | Aspose.Email.Exchange.Schema Namespace


InvalidRecipientType Properties

The properties of the InvalidRecipientType class are listed below. For a complete list of InvalidRecipientType class members, see the InvalidRecipientType Members topic.

Public Instance Properties

MessageText
ResponseCode
SmtpAddress

See Also

InvalidRecipientType Class | Aspose.Email.Exchange.Schema Namespace


MessageText Property

Aspose.Email

InvalidRecipientType.MessageText Property

public string MessageText {get; set;}

Remarks

See Also

InvalidRecipientType Class | Aspose.Email.Exchange.Schema Namespace


ResponseCode Property

Aspose.Email

InvalidRecipientType.ResponseCode Property

public InvalidRecipientResponseCodeType ResponseCode {get; set;}

Remarks

See Also

InvalidRecipientType Class | Aspose.Email.Exchange.Schema Namespace


SmtpAddress Property

Aspose.Email

InvalidRecipientType.SmtpAddress Property

public string SmtpAddress {get; set;}

Remarks

See Also

InvalidRecipientType Class | Aspose.Email.Exchange.Schema Namespace


IsEqualToType Class

For a list of all members of this type, see IsEqualToType Members.

System.Object
Aspose.Email.Exchange.Schema.SearchExpressionType
Aspose.Email.Exchange.Schema.TwoOperandExpressionType
Aspose.Email.Exchange.Schema.IsEqualToType

public class IsEqualToType : TwoOperandExpressionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

IsEqualToType Members | Aspose.Email.Exchange.Schema Namespace


IsEqualToType Members

IsEqualToType overview

Public Instance Constructors

IsEqualToType Constructor Initializes a new instance of the IsEqualToType class.

Public Instance Properties

FieldURIOrConstant (inherited from TwoOperandExpressionType)
Item (inherited from TwoOperandExpressionType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IsEqualToType Class | Aspose.Email.Exchange.Schema Namespace


IsEqualToType Constructor

Initializes a new instance of the IsEqualToType class.

public IsEqualToType();

See Also

IsEqualToType Class | Aspose.Email.Exchange.Schema Namespace


IsGreaterThanOrEqualToType Class

For a list of all members of this type, see IsGreaterThanOrEqualToType Members.

System.Object
Aspose.Email.Exchange.Schema.SearchExpressionType
Aspose.Email.Exchange.Schema.TwoOperandExpressionType
Aspose.Email.Exchange.Schema.IsGreaterThanOrEqualToType

public class IsGreaterThanOrEqualToType : TwoOperandExpressionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

IsGreaterThanOrEqualToType Members | Aspose.Email.Exchange.Schema Namespace


IsGreaterThanOrEqualToType Members

IsGreaterThanOrEqualToType overview

Public Instance Constructors

IsGreaterThanOrEqualToType Constructor Initializes a new instance of the IsGreaterThanOrEqualToType class.

Public Instance Properties

FieldURIOrConstant (inherited from TwoOperandExpressionType)
Item (inherited from TwoOperandExpressionType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IsGreaterThanOrEqualToType Class | Aspose.Email.Exchange.Schema Namespace


IsGreaterThanOrEqualToType Constructor

Initializes a new instance of the IsGreaterThanOrEqualToType class.

public IsGreaterThanOrEqualToType();

See Also

IsGreaterThanOrEqualToType Class | Aspose.Email.Exchange.Schema Namespace


IsGreaterThanType Class

For a list of all members of this type, see IsGreaterThanType Members.

System.Object
Aspose.Email.Exchange.Schema.SearchExpressionType
Aspose.Email.Exchange.Schema.TwoOperandExpressionType
Aspose.Email.Exchange.Schema.IsGreaterThanType

public class IsGreaterThanType : TwoOperandExpressionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

IsGreaterThanType Members | Aspose.Email.Exchange.Schema Namespace


IsGreaterThanType Members

IsGreaterThanType overview

Public Instance Constructors

IsGreaterThanType Constructor Initializes a new instance of the IsGreaterThanType class.

Public Instance Properties

FieldURIOrConstant (inherited from TwoOperandExpressionType)
Item (inherited from TwoOperandExpressionType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IsGreaterThanType Class | Aspose.Email.Exchange.Schema Namespace


IsGreaterThanType Constructor

Initializes a new instance of the IsGreaterThanType class.

public IsGreaterThanType();

See Also

IsGreaterThanType Class | Aspose.Email.Exchange.Schema Namespace


IsLessThanOrEqualToType Class

For a list of all members of this type, see IsLessThanOrEqualToType Members.

System.Object
Aspose.Email.Exchange.Schema.SearchExpressionType
Aspose.Email.Exchange.Schema.TwoOperandExpressionType
Aspose.Email.Exchange.Schema.IsLessThanOrEqualToType

public class IsLessThanOrEqualToType : TwoOperandExpressionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

IsLessThanOrEqualToType Members | Aspose.Email.Exchange.Schema Namespace


IsLessThanOrEqualToType Members

IsLessThanOrEqualToType overview

Public Instance Constructors

IsLessThanOrEqualToType Constructor Initializes a new instance of the IsLessThanOrEqualToType class.

Public Instance Properties

FieldURIOrConstant (inherited from TwoOperandExpressionType)
Item (inherited from TwoOperandExpressionType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IsLessThanOrEqualToType Class | Aspose.Email.Exchange.Schema Namespace


IsLessThanOrEqualToType Constructor

Initializes a new instance of the IsLessThanOrEqualToType class.

public IsLessThanOrEqualToType();

See Also

IsLessThanOrEqualToType Class | Aspose.Email.Exchange.Schema Namespace


IsLessThanType Class

For a list of all members of this type, see IsLessThanType Members.

System.Object
Aspose.Email.Exchange.Schema.SearchExpressionType
Aspose.Email.Exchange.Schema.TwoOperandExpressionType
Aspose.Email.Exchange.Schema.IsLessThanType

public class IsLessThanType : TwoOperandExpressionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

IsLessThanType Members | Aspose.Email.Exchange.Schema Namespace


IsLessThanType Members

IsLessThanType overview

Public Instance Constructors

IsLessThanType Constructor Initializes a new instance of the IsLessThanType class.

Public Instance Properties

FieldURIOrConstant (inherited from TwoOperandExpressionType)
Item (inherited from TwoOperandExpressionType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IsLessThanType Class | Aspose.Email.Exchange.Schema Namespace


IsLessThanType Constructor

Initializes a new instance of the IsLessThanType class.

public IsLessThanType();

See Also

IsLessThanType Class | Aspose.Email.Exchange.Schema Namespace


IsNotEqualToType Class

For a list of all members of this type, see IsNotEqualToType Members.

System.Object
Aspose.Email.Exchange.Schema.SearchExpressionType
Aspose.Email.Exchange.Schema.TwoOperandExpressionType
Aspose.Email.Exchange.Schema.IsNotEqualToType

public class IsNotEqualToType : TwoOperandExpressionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

IsNotEqualToType Members | Aspose.Email.Exchange.Schema Namespace


IsNotEqualToType Members

IsNotEqualToType overview

Public Instance Constructors

IsNotEqualToType Constructor Initializes a new instance of the IsNotEqualToType class.

Public Instance Properties

FieldURIOrConstant (inherited from TwoOperandExpressionType)
Item (inherited from TwoOperandExpressionType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IsNotEqualToType Class | Aspose.Email.Exchange.Schema Namespace


IsNotEqualToType Constructor

Initializes a new instance of the IsNotEqualToType class.

public IsNotEqualToType();

See Also

IsNotEqualToType Class | Aspose.Email.Exchange.Schema Namespace


ItemAttachmentType Class

For a list of all members of this type, see ItemAttachmentType Members.

System.Object
Aspose.Email.Exchange.Schema.AttachmentType
Aspose.Email.Exchange.Schema.ItemAttachmentType

public class ItemAttachmentType : AttachmentType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ItemAttachmentType Members | Aspose.Email.Exchange.Schema Namespace


ItemAttachmentType Members

ItemAttachmentType overview

Public Instance Constructors

ItemAttachmentType Constructor Initializes a new instance of the ItemAttachmentType class.

Public Instance Properties

AttachmentId (inherited from AttachmentType)
ContentId (inherited from AttachmentType)
ContentLocation (inherited from AttachmentType)
ContentType (inherited from AttachmentType)
IsInline (inherited from AttachmentType)
IsInlineSpecified (inherited from AttachmentType)
Item
LastModifiedTime (inherited from AttachmentType)
LastModifiedTimeSpecified (inherited from AttachmentType)
Name (inherited from AttachmentType)
Size (inherited from AttachmentType)
SizeSpecified (inherited from AttachmentType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ItemAttachmentType Class | Aspose.Email.Exchange.Schema Namespace


ItemAttachmentType Constructor

Initializes a new instance of the ItemAttachmentType class.

public ItemAttachmentType();

See Also

ItemAttachmentType Class | Aspose.Email.Exchange.Schema Namespace


ItemAttachmentType Properties

The properties of the ItemAttachmentType class are listed below. For a complete list of ItemAttachmentType class members, see the ItemAttachmentType Members topic.

Public Instance Properties

AttachmentId (inherited from AttachmentType)
ContentId (inherited from AttachmentType)
ContentLocation (inherited from AttachmentType)
ContentType (inherited from AttachmentType)
IsInline (inherited from AttachmentType)
IsInlineSpecified (inherited from AttachmentType)
Item
LastModifiedTime (inherited from AttachmentType)
LastModifiedTimeSpecified (inherited from AttachmentType)
Name (inherited from AttachmentType)
Size (inherited from AttachmentType)
SizeSpecified (inherited from AttachmentType)

See Also

ItemAttachmentType Class | Aspose.Email.Exchange.Schema Namespace


Item Property

Aspose.Email

ItemAttachmentType.Item Property

public ItemType Item {get; set;}

Remarks

See Also

ItemAttachmentType Class | Aspose.Email.Exchange.Schema Namespace


ItemChangeDescriptionType Class

For a list of all members of this type, see ItemChangeDescriptionType Members.

System.Object
Aspose.Email.Exchange.Schema.ChangeDescriptionType
Aspose.Email.Exchange.Schema.ItemChangeDescriptionType
Aspose.Email.Exchange.Schema.AppendToItemFieldType
Aspose.Email.Exchange.Schema.DeleteItemFieldType
Aspose.Email.Exchange.Schema.SetItemFieldType

public class ItemChangeDescriptionType : ChangeDescriptionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ItemChangeDescriptionType Members | Aspose.Email.Exchange.Schema Namespace


ItemChangeDescriptionType Members

ItemChangeDescriptionType overview

Public Instance Constructors

ItemChangeDescriptionType Constructor Initializes a new instance of the ItemChangeDescriptionType class.

Public Instance Properties

Item (inherited from ChangeDescriptionType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ItemChangeDescriptionType Class | Aspose.Email.Exchange.Schema Namespace


ItemChangeDescriptionType Constructor

Initializes a new instance of the ItemChangeDescriptionType class.

public ItemChangeDescriptionType();

See Also

ItemChangeDescriptionType Class | Aspose.Email.Exchange.Schema Namespace


ItemChangeType Class

For a list of all members of this type, see ItemChangeType Members.

System.Object
Aspose.Email.Exchange.Schema.ItemChangeType

public class ItemChangeType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ItemChangeType Members | Aspose.Email.Exchange.Schema Namespace


ItemChangeType Members

ItemChangeType overview

Public Instance Constructors

ItemChangeType Constructor Initializes a new instance of the ItemChangeType class.

Public Instance Properties

Item
Updates

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ItemChangeType Class | Aspose.Email.Exchange.Schema Namespace


ItemChangeType Constructor

Initializes a new instance of the ItemChangeType class.

public ItemChangeType();

See Also

ItemChangeType Class | Aspose.Email.Exchange.Schema Namespace


ItemChangeType Properties

The properties of the ItemChangeType class are listed below. For a complete list of ItemChangeType class members, see the ItemChangeType Members topic.

Public Instance Properties

Item
Updates

See Also

ItemChangeType Class | Aspose.Email.Exchange.Schema Namespace


Item Property

Aspose.Email

ItemChangeType.Item Property

public BaseItemIdType Item {get; set;}

Remarks

See Also

ItemChangeType Class | Aspose.Email.Exchange.Schema Namespace


Updates Property

Aspose.Email

ItemChangeType.Updates Property

public ItemChangeDescriptionType[] Updates {get; set;}

Remarks

See Also

ItemChangeType Class | Aspose.Email.Exchange.Schema Namespace


ItemChoiceType Enumeration

public enum ItemChoiceType

Remarks

Members

Member Name | Description | Value
PrimarySmtpAddress |  | 0
PrincipalName |  | 1
SID |  | 2
SmtpAddress |  | 3

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


ItemChoiceType1 Enumeration

public enum ItemChoiceType1

Remarks

Members

Member Name | Description | Value
AllInternal |  | 0
And |  | 1
RecipientIs |  | 2
SenderDepartments |  | 3
True |  | 4

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


ItemIdType Class

The ItemIdType class represents an item identifier of an item in an Exchange mailbox.

For a list of all members of this type, see ItemIdType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseItemIdType
Aspose.Email.Exchange.Schema.ItemIdType

public class ItemIdType : BaseItemIdType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ItemIdType Members | Aspose.Email.Exchange.Schema Namespace


ItemIdType Members

ItemIdType overview

Public Instance Constructors

ItemIdType Constructor Initializes a new instance of the ItemIdType class.

Public Instance Properties

ChangeKey
Id

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ItemIdType Class | Aspose.Email.Exchange.Schema Namespace


ItemIdType Constructor

Initializes a new instance of the ItemIdType class.

public ItemIdType();

See Also

ItemIdType Class | Aspose.Email.Exchange.Schema Namespace


ItemIdType Properties

The properties of the ItemIdType class are listed below. For a complete list of ItemIdType class members, see the ItemIdType Members topic.

Public Instance Properties

ChangeKey
Id

See Also

ItemIdType Class | Aspose.Email.Exchange.Schema Namespace


ChangeKey Property

Aspose.Email

ItemIdType.ChangeKey Property

public string ChangeKey {get; set;}

Remarks

See Also

ItemIdType Class | Aspose.Email.Exchange.Schema Namespace


Id Property

Aspose.Email

ItemIdType.Id Property

public string Id {get; set;}

Remarks

See Also

ItemIdType Class | Aspose.Email.Exchange.Schema Namespace


ItemInfoResponseMessageType Class

For a list of all members of this type, see ItemInfoResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ResponseMessageType
Aspose.Email.Exchange.Schema.ItemInfoResponseMessageType
Aspose.Email.Exchange.Schema.UpdateItemResponseMessageType

public class ItemInfoResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ItemInfoResponseMessageType Members | Aspose.Email.Exchange.Schema Namespace


ItemInfoResponseMessageType Members

ItemInfoResponseMessageType overview

Public Instance Constructors

ItemInfoResponseMessageType Constructor Initializes a new instance of the ItemInfoResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
Items
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ItemInfoResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


ItemInfoResponseMessageType Constructor

Initializes a new instance of the ItemInfoResponseMessageType class.

public ItemInfoResponseMessageType();

See Also

ItemInfoResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


ItemInfoResponseMessageType Properties

The properties of the ItemInfoResponseMessageType class are listed below. For a complete list of ItemInfoResponseMessageType class members, see the ItemInfoResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
Items
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

ItemInfoResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


Items Property

Aspose.Email

ItemInfoResponseMessageType.Items Property

public ArrayOfRealItemsType Items {get; set;}

Remarks

See Also

ItemInfoResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


ItemQueryTraversalType Enumeration

public enum ItemQueryTraversalType

Remarks

Members

Member Name | Description | Value
Shallow |  | 0
SoftDeleted |  | 1
Associated |  | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


ItemResponseShapeType Class

For a list of all members of this type, see ItemResponseShapeType Members.

System.Object
Aspose.Email.Exchange.Schema.ItemResponseShapeType

public class ItemResponseShapeType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ItemResponseShapeType Members | Aspose.Email.Exchange.Schema Namespace


ItemResponseShapeType Members

ItemResponseShapeType overview

Public Instance Constructors

ItemResponseShapeType Constructor Initializes a new instance of the ItemResponseShapeType class.

Public Instance Properties

AdditionalProperties
BaseShape
BodyType
BodyTypeSpecified
ConvertHtmlCodePageToUTF8
ConvertHtmlCodePageToUTF8Specified
FilterHtmlContent
FilterHtmlContentSpecified
IncludeMimeContent
IncludeMimeContentSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ItemResponseShapeType Class | Aspose.Email.Exchange.Schema Namespace


ItemResponseShapeType Constructor

Initializes a new instance of the ItemResponseShapeType class.

public ItemResponseShapeType();

See Also

ItemResponseShapeType Class | Aspose.Email.Exchange.Schema Namespace


ItemResponseShapeType Properties

The properties of the ItemResponseShapeType class are listed below. For a complete list of ItemResponseShapeType class members, see the ItemResponseShapeType Members topic.

Public Instance Properties

AdditionalProperties
BaseShape
BodyType
BodyTypeSpecified
ConvertHtmlCodePageToUTF8
ConvertHtmlCodePageToUTF8Specified
FilterHtmlContent
FilterHtmlContentSpecified
IncludeMimeContent
IncludeMimeContentSpecified

See Also

ItemResponseShapeType Class | Aspose.Email.Exchange.Schema Namespace


AdditionalProperties Property

Aspose.Email

ItemResponseShapeType.AdditionalProperties Property

public BasePathToElementType[] AdditionalProperties {get; set;}

Remarks

See Also

ItemResponseShapeType Class | Aspose.Email.Exchange.Schema Namespace


BaseShape Property

Aspose.Email

ItemResponseShapeType.BaseShape Property

public DefaultShapeNamesType BaseShape {get; set;}

Remarks

See Also

ItemResponseShapeType Class | Aspose.Email.Exchange.Schema Namespace


BodyType Property

Aspose.Email

ItemResponseShapeType.BodyType Property

public BodyTypeResponseType BodyType {get; set;}

Remarks

See Also

ItemResponseShapeType Class | Aspose.Email.Exchange.Schema Namespace


BodyTypeSpecified Property

Aspose.Email

ItemResponseShapeType.BodyTypeSpecified Property

public bool BodyTypeSpecified {get; set;}

Remarks

See Also

ItemResponseShapeType Class | Aspose.Email.Exchange.Schema Namespace


ConvertHtmlCodePageToUTF8 Property

Aspose.Email

ItemResponseShapeType.ConvertHtmlCodePageToUTF8 Property

public bool ConvertHtmlCodePageToUTF8 {get; set;}

Remarks

See Also

ItemResponseShapeType Class | Aspose.Email.Exchange.Schema Namespace


ConvertHtmlCodePageToUTF8Specified Property

Aspose.Email

ItemResponseShapeType.ConvertHtmlCodePageToUTF8Specified Property

public bool ConvertHtmlCodePageToUTF8Specified {get; set;}

Remarks

See Also

ItemResponseShapeType Class | Aspose.Email.Exchange.Schema Namespace


FilterHtmlContent Property

Aspose.Email

ItemResponseShapeType.FilterHtmlContent Property

public bool FilterHtmlContent {get; set;}

Remarks

See Also

ItemResponseShapeType Class | Aspose.Email.Exchange.Schema Namespace


FilterHtmlContentSpecified Property

Aspose.Email

ItemResponseShapeType.FilterHtmlContentSpecified Property

public bool FilterHtmlContentSpecified {get; set;}

Remarks

See Also

ItemResponseShapeType Class | Aspose.Email.Exchange.Schema Namespace


IncludeMimeContent Property

Aspose.Email

ItemResponseShapeType.IncludeMimeContent Property

public bool IncludeMimeContent {get; set;}

Remarks

See Also

ItemResponseShapeType Class | Aspose.Email.Exchange.Schema Namespace


IncludeMimeContentSpecified Property

Aspose.Email

ItemResponseShapeType.IncludeMimeContentSpecified Property

public bool IncludeMimeContentSpecified {get; set;}

Remarks

See Also

ItemResponseShapeType Class | Aspose.Email.Exchange.Schema Namespace


ItemsChoiceType Enumeration

public enum ItemsChoiceType

Remarks

Members

Member Name | Description | Value
CopiedEvent |  | 0
CreatedEvent |  | 1
DeletedEvent |  | 2
FreeBusyChangedEvent |  | 3
ModifiedEvent |  | 4
MovedEvent |  | 5
NewMailEvent |  | 6
StatusEvent |  | 7

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


ItemsChoiceType1 Enumeration

public enum ItemsChoiceType1

Remarks

Members

Member Name | Description | Value
Create |  | 0
Delete |  | 1
Update |  | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


ItemsChoiceType2 Enumeration

public enum ItemsChoiceType2

Remarks

Members

Member Name | Description | Value
Create |  | 0
Delete |  | 1
ReadFlagChange |  | 2
Update |  | 3

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


ItemsChoiceType3 Enumeration

public enum ItemsChoiceType3

Remarks

Members

Member Name | Description | Value
AllInternal |  | 0
And |  | 1
RecipientIs |  | 2
SenderDepartments |  | 3
True |  | 4

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


ItemsChoiceType4 Enumeration

public enum ItemsChoiceType4

Remarks

Members

Member Name | Description | Value
ConvertIdResponseMessage |  | 0
CopyFolderResponseMessage |  | 1
CopyItemResponseMessage |  | 2
CreateAttachmentResponseMessage |  | 3
CreateFolderResponseMessage |  | 4
CreateItemResponseMessage |  | 5
CreateManagedFolderResponseMessage |  | 6
CreateUserConfigurationResponseMessage |  | 7
DeleteAttachmentResponseMessage |  | 8
DeleteFolderResponseMessage |  | 9
DeleteItemResponseMessage |  | 10
DeleteUserConfigurationResponseMessage |  | 11
ExpandDLResponseMessage |  | 12
FindFolderResponseMessage |  | 13
FindItemResponseMessage |  | 14
FindMailboxStatisticsByKeywordsResponseMessage |  | 15
GetAttachmentResponseMessage |  | 16
GetEventsResponseMessage |  | 17
GetFolderResponseMessage |  | 18
GetItemResponseMessage |  | 19
GetRoomListsResponse |  | 20
GetRoomsResponse |  | 21
GetServerTimeZonesResponseMessage |  | 22
GetSharingFolderResponseMessage |  | 23
GetSharingMetadataResponseMessage |  | 24
GetStreamingEventsResponseMessage |  | 25
GetUserConfigurationResponseMessage |  | 26
MoveFolderResponseMessage |  | 27
MoveItemResponseMessage |  | 28
RefreshSharingFolderResponseMessage |  | 29
ResolveNamesResponseMessage |  | 30
SendItemResponseMessage |  | 31
SendNotificationResponseMessage |  | 32
SubscribeResponseMessage |  | 33
SyncFolderHierarchyResponseMessage |  | 34
SyncFolderItemsResponseMessage |  | 35
UnsubscribeResponseMessage |  | 36
UpdateFolderResponseMessage |  | 37
UpdateItemResponseMessage |  | 38
UpdateUserConfigurationResponseMessage |  | 39
UploadItemsResponseMessage | Specifies the response message for the UploadItems operation | 40
ExportItemsResponseMessage | Specifies the response message for the ExportItems operation | 41
ApplyConversationActionResponseMessage | Specifies the response message for the ApplyConversationAction operation | 42
EmptyFolderResponseMessage | Specifies the response message for the EmptyFolder operation | 43

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


ItemType Class

For a list of all members of this type, see ItemType Members.

System.Object
Aspose.Email.Exchange.Schema.ItemType
Derived types

public class ItemType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ItemType Members | Aspose.Email.Exchange.Schema Namespace


ItemType Members

ItemType overview

Public Instance Constructors

ItemType Constructor Initializes a new instance of the ItemType class.

Public Instance Properties

Attachments
Body
Categories
ConversationId
Culture
DateTimeCreated
DateTimeCreatedSpecified
DateTimeReceived
DateTimeReceivedSpecified
DateTimeSent
DateTimeSentSpecified
DisplayCc
DisplayTo
EffectiveRights
ExtendedProperty
HasAttachments
HasAttachmentsSpecified
Importance
ImportanceSpecified
InReplyTo
InternetMessageHeaders
IsAssociated
IsAssociatedSpecified
IsDraft
IsDraftSpecified
IsFromMe
IsFromMeSpecified
IsResend
IsResendSpecified
IsSubmitted
IsSubmittedSpecified
IsUnmodified
IsUnmodifiedSpecified
ItemClass
ItemId
LastModifiedName
LastModifiedTime
LastModifiedTimeSpecified
MimeContent
ParentFolderId
ReminderDueBy
ReminderDueBySpecified
ReminderIsSet
ReminderIsSetSpecified
ReminderMinutesBeforeStart
ResponseObjects
Sensitivity
SensitivitySpecified
Size
SizeSpecified
Subject
UniqueBody
WebClientEditFormQueryString
WebClientReadFormQueryString

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


ItemType Constructor

Initializes a new instance of the ItemType class.

public ItemType();

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


ItemType Properties

The properties of the ItemType class are listed below. For a complete list of ItemType class members, see the ItemType Members topic.

Public Instance Properties

Attachments
Body
Categories
ConversationId
Culture
DateTimeCreated
DateTimeCreatedSpecified
DateTimeReceived
DateTimeReceivedSpecified
DateTimeSent
DateTimeSentSpecified
DisplayCc
DisplayTo
EffectiveRights
ExtendedProperty
HasAttachments
HasAttachmentsSpecified
Importance
ImportanceSpecified
InReplyTo
InternetMessageHeaders
IsAssociated
IsAssociatedSpecified
IsDraft
IsDraftSpecified
IsFromMe
IsFromMeSpecified
IsResend
IsResendSpecified
IsSubmitted
IsSubmittedSpecified
IsUnmodified
IsUnmodifiedSpecified
ItemClass
ItemId
LastModifiedName
LastModifiedTime
LastModifiedTimeSpecified
MimeContent
ParentFolderId
ReminderDueBy
ReminderDueBySpecified
ReminderIsSet
ReminderIsSetSpecified
ReminderMinutesBeforeStart
ResponseObjects
Sensitivity
SensitivitySpecified
Size
SizeSpecified
Subject
UniqueBody
WebClientEditFormQueryString
WebClientReadFormQueryString

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


Attachments Property

Aspose.Email

ItemType.Attachments Property

public AttachmentType[] Attachments {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


Body Property

Aspose.Email

ItemType.Body Property

public BodyType Body {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


Categories Property

Aspose.Email

ItemType.Categories Property

public string[] Categories {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


ConversationId Property

Aspose.Email

ItemType.ConversationId Property

public ItemIdType ConversationId {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


Culture Property

Aspose.Email

ItemType.Culture Property

public string Culture {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


DateTimeCreated Property

Aspose.Email

ItemType.DateTimeCreated Property

public DateTime DateTimeCreated {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


DateTimeCreatedSpecified Property

Aspose.Email

ItemType.DateTimeCreatedSpecified Property

public bool DateTimeCreatedSpecified {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


DateTimeReceived Property

Aspose.Email

ItemType.DateTimeReceived Property

public DateTime DateTimeReceived {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


DateTimeReceivedSpecified Property

Aspose.Email

ItemType.DateTimeReceivedSpecified Property

public bool DateTimeReceivedSpecified {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


DateTimeSent Property

Aspose.Email

ItemType.DateTimeSent Property

public DateTime DateTimeSent {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


DateTimeSentSpecified Property

Aspose.Email

ItemType.DateTimeSentSpecified Property

public bool DateTimeSentSpecified {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


DisplayCc Property

Aspose.Email

ItemType.DisplayCc Property

public string DisplayCc {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


DisplayTo Property

Aspose.Email

ItemType.DisplayTo Property

public string DisplayTo {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


EffectiveRights Property

Aspose.Email

ItemType.EffectiveRights Property

public EffectiveRightsType EffectiveRights {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


ExtendedProperty Property

Aspose.Email

ItemType.ExtendedProperty Property

public ExtendedPropertyType[] ExtendedProperty {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


HasAttachments Property

Aspose.Email

ItemType.HasAttachments Property

public bool HasAttachments {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


HasAttachmentsSpecified Property

Aspose.Email

ItemType.HasAttachmentsSpecified Property

public bool HasAttachmentsSpecified {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


Importance Property

Aspose.Email

ItemType.Importance Property

public ImportanceChoicesType Importance {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


ImportanceSpecified Property

Aspose.Email

ItemType.ImportanceSpecified Property

public bool ImportanceSpecified {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


InReplyTo Property

Aspose.Email

ItemType.InReplyTo Property

public string InReplyTo {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


InternetMessageHeaders Property

Aspose.Email

ItemType.InternetMessageHeaders Property

public InternetHeaderType[] InternetMessageHeaders {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


IsAssociated Property

Aspose.Email

ItemType.IsAssociated Property

public bool IsAssociated {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


IsAssociatedSpecified Property

Aspose.Email

ItemType.IsAssociatedSpecified Property

public bool IsAssociatedSpecified {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


IsDraft Property

Aspose.Email

ItemType.IsDraft Property

public bool IsDraft {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


IsDraftSpecified Property

Aspose.Email

ItemType.IsDraftSpecified Property

public bool IsDraftSpecified {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


IsFromMe Property

Aspose.Email

ItemType.IsFromMe Property

public bool IsFromMe {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


IsFromMeSpecified Property

Aspose.Email

ItemType.IsFromMeSpecified Property

public bool IsFromMeSpecified {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


IsResend Property

Aspose.Email

ItemType.IsResend Property

public bool IsResend {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


IsResendSpecified Property

Aspose.Email

ItemType.IsResendSpecified Property

public bool IsResendSpecified {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


IsSubmitted Property

Aspose.Email

ItemType.IsSubmitted Property

public bool IsSubmitted {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


IsSubmittedSpecified Property

Aspose.Email

ItemType.IsSubmittedSpecified Property

public bool IsSubmittedSpecified {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


IsUnmodified Property

Aspose.Email

ItemType.IsUnmodified Property

public bool IsUnmodified {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


IsUnmodifiedSpecified Property

Aspose.Email

ItemType.IsUnmodifiedSpecified Property

public bool IsUnmodifiedSpecified {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


ItemClass Property

Aspose.Email

ItemType.ItemClass Property

public string ItemClass {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


ItemId Property

Aspose.Email

ItemType.ItemId Property

public ItemIdType ItemId {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


LastModifiedName Property

Aspose.Email

ItemType.LastModifiedName Property

public string LastModifiedName {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


LastModifiedTime Property

Aspose.Email

ItemType.LastModifiedTime Property

public DateTime LastModifiedTime {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


LastModifiedTimeSpecified Property

Aspose.Email

ItemType.LastModifiedTimeSpecified Property

public bool LastModifiedTimeSpecified {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


MimeContent Property

Aspose.Email

ItemType.MimeContent Property

public MimeContentType MimeContent {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


ParentFolderId Property

Aspose.Email

ItemType.ParentFolderId Property

public FolderIdType ParentFolderId {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


ReminderDueBy Property

Aspose.Email

ItemType.ReminderDueBy Property

public DateTime ReminderDueBy {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


ReminderDueBySpecified Property

Aspose.Email

ItemType.ReminderDueBySpecified Property

public bool ReminderDueBySpecified {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


ReminderIsSet Property

Aspose.Email

ItemType.ReminderIsSet Property

public bool ReminderIsSet {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


ReminderIsSetSpecified Property

Aspose.Email

ItemType.ReminderIsSetSpecified Property

public bool ReminderIsSetSpecified {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


ReminderMinutesBeforeStart Property

Aspose.Email

ItemType.ReminderMinutesBeforeStart Property

public string ReminderMinutesBeforeStart {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


ResponseObjects Property

Aspose.Email

ItemType.ResponseObjects Property

public ResponseObjectType[] ResponseObjects {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


Sensitivity Property

Aspose.Email

ItemType.Sensitivity Property

public SensitivityChoicesType Sensitivity {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


SensitivitySpecified Property

Aspose.Email

ItemType.SensitivitySpecified Property

public bool SensitivitySpecified {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


Size Property

Aspose.Email

ItemType.Size Property

public int Size {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


SizeSpecified Property

Aspose.Email

ItemType.SizeSpecified Property

public bool SizeSpecified {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


Subject Property

Aspose.Email

ItemType.Subject Property

public string Subject {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


UniqueBody Property

Aspose.Email

ItemType.UniqueBody Property

public BodyType UniqueBody {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


WebClientEditFormQueryString Property

Aspose.Email

ItemType.WebClientEditFormQueryString Property

public string WebClientEditFormQueryString {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


WebClientReadFormQueryString Property

Aspose.Email

ItemType.WebClientReadFormQueryString Property

public string WebClientReadFormQueryString {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema Namespace


KeywordStatisticsSearchResultType Class

For a list of all members of this type, see KeywordStatisticsSearchResultType Members.

System.Object
Aspose.Email.Exchange.Schema.KeywordStatisticsSearchResultType

public class KeywordStatisticsSearchResultType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

KeywordStatisticsSearchResultType Members | Aspose.Email.Exchange.Schema Namespace


KeywordStatisticsSearchResultType Members

KeywordStatisticsSearchResultType overview

Public Instance Constructors

KeywordStatisticsSearchResultType Constructor Initializes a new instance of the KeywordStatisticsSearchResultType class.

Public Instance Properties

ItemHits
Keyword
Size

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

KeywordStatisticsSearchResultType Class | Aspose.Email.Exchange.Schema Namespace


KeywordStatisticsSearchResultType Constructor

Initializes a new instance of the KeywordStatisticsSearchResultType class.

public KeywordStatisticsSearchResultType();

See Also

KeywordStatisticsSearchResultType Class | Aspose.Email.Exchange.Schema Namespace


KeywordStatisticsSearchResultType Properties

The properties of the KeywordStatisticsSearchResultType class are listed below. For a complete list of KeywordStatisticsSearchResultType class members, see the KeywordStatisticsSearchResultType Members topic.

Public Instance Properties

ItemHits
Keyword
Size

See Also

KeywordStatisticsSearchResultType Class | Aspose.Email.Exchange.Schema Namespace


ItemHits Property

Aspose.Email

KeywordStatisticsSearchResultType.ItemHits Property

public int ItemHits {get; set;}

Remarks

See Also

KeywordStatisticsSearchResultType Class | Aspose.Email.Exchange.Schema Namespace


Keyword Property

Aspose.Email

KeywordStatisticsSearchResultType.Keyword Property

public string Keyword {get; set;}

Remarks

See Also

KeywordStatisticsSearchResultType Class | Aspose.Email.Exchange.Schema Namespace


Size Property

Aspose.Email

KeywordStatisticsSearchResultType.Size Property

public long Size {get; set;}

Remarks

See Also

KeywordStatisticsSearchResultType Class | Aspose.Email.Exchange.Schema Namespace


LegacyFreeBusyType Enumeration

public enum LegacyFreeBusyType

Remarks

Members

Member Name | Description | Value
Free |  | 0
Tentative |  | 1
Busy |  | 2
OOF |  | 3
NoData |  | 4

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


MailboxCultureType Class

For a list of all members of this type, see MailboxCultureType Members.

System.Object
System.Web.Services.Protocols.SoapHeader
Aspose.Email.Exchange.Schema.MailboxCultureType

public class MailboxCultureType : SoapHeader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MailboxCultureType Members | Aspose.Email.Exchange.Schema Namespace


MailboxCultureType Members

MailboxCultureType overview

Public Instance Constructors

MailboxCultureType Constructor Initializes a new instance of the MailboxCultureType class.

Public Instance Properties

Actor (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.
AnyAttr |
DidUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether an XML Web service method properly processed a SOAP header.
EncodedMustUnderstand (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.1.
EncodedMustUnderstand12 (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.2.
EncodedRelay (inherited from SoapHeader) | Gets or sets the relay attribute of the SOAP 1.2 header.
MustUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether the SoapHeader must be understood.
Relay (inherited from SoapHeader) | Gets or sets a value that indicates whether the SOAP header is to be relayed to the next SOAP node if the current node does not understand the header.
Role (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.
Value |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MailboxCultureType Class | Aspose.Email.Exchange.Schema Namespace


MailboxCultureType Constructor

Initializes a new instance of the MailboxCultureType class.

public MailboxCultureType();

See Also

MailboxCultureType Class | Aspose.Email.Exchange.Schema Namespace


MailboxCultureType Properties

The properties of the MailboxCultureType class are listed below. For a complete list of MailboxCultureType class members, see the MailboxCultureType Members topic.

Public Instance Properties

Actor (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.
AnyAttr |
DidUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether an XML Web service method properly processed a SOAP header.
EncodedMustUnderstand (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.1.
EncodedMustUnderstand12 (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.2.
EncodedRelay (inherited from SoapHeader) | Gets or sets the relay attribute of the SOAP 1.2 header.
MustUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether the SoapHeader must be understood.
Relay (inherited from SoapHeader) | Gets or sets a value that indicates whether the SOAP header is to be relayed to the next SOAP node if the current node does not understand the header.
Role (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.
Value |

See Also

MailboxCultureType Class | Aspose.Email.Exchange.Schema Namespace


AnyAttr Property

Aspose.Email

MailboxCultureType.AnyAttr Property

public XmlAttribute[] AnyAttr {get; set;}

Remarks

See Also

MailboxCultureType Class | Aspose.Email.Exchange.Schema Namespace


Value Property

Aspose.Email

MailboxCultureType.Value Property

public string Value {get; set;}

Remarks

See Also

MailboxCultureType Class | Aspose.Email.Exchange.Schema Namespace


MailboxData Class

For a list of all members of this type, see MailboxData Members.

System.Object
Aspose.Email.Exchange.Schema.MailboxData

public class MailboxData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MailboxData Members | Aspose.Email.Exchange.Schema Namespace


MailboxData Members

MailboxData overview

Public Instance Constructors

MailboxData Constructor Initializes a new instance of the MailboxData class.

Public Instance Properties

AttendeeType
Email
ExcludeConflicts
ExcludeConflictsSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MailboxData Class | Aspose.Email.Exchange.Schema Namespace


MailboxData Constructor

Initializes a new instance of the MailboxData class.

public MailboxData();

See Also

MailboxData Class | Aspose.Email.Exchange.Schema Namespace


MailboxData Properties

The properties of the MailboxData class are listed below. For a complete list of MailboxData class members, see the MailboxData Members topic.

Public Instance Properties

AttendeeType
Email
ExcludeConflicts
ExcludeConflictsSpecified

See Also

MailboxData Class | Aspose.Email.Exchange.Schema Namespace


AttendeeType Property

Aspose.Email

MailboxData.AttendeeType Property

public MeetingAttendeeType AttendeeType {get; set;}

Remarks

See Also

MailboxData Class | Aspose.Email.Exchange.Schema Namespace


Email Property

Aspose.Email

MailboxData.Email Property

public EmailAddress Email {get; set;}

Remarks

See Also

MailboxData Class | Aspose.Email.Exchange.Schema Namespace


ExcludeConflicts Property

Aspose.Email

MailboxData.ExcludeConflicts Property

public bool ExcludeConflicts {get; set;}

Remarks

See Also

MailboxData Class | Aspose.Email.Exchange.Schema Namespace


ExcludeConflictsSpecified Property

Aspose.Email

MailboxData.ExcludeConflictsSpecified Property

public bool ExcludeConflictsSpecified {get; set;}

Remarks

See Also

MailboxData Class | Aspose.Email.Exchange.Schema Namespace


MailboxStatisticsSearchResultType Class

For a list of all members of this type, see MailboxStatisticsSearchResultType Members.

System.Object
Aspose.Email.Exchange.Schema.MailboxStatisticsSearchResultType

public class MailboxStatisticsSearchResultType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MailboxStatisticsSearchResultType Members | Aspose.Email.Exchange.Schema Namespace


MailboxStatisticsSearchResultType Members

MailboxStatisticsSearchResultType overview

Public Instance Constructors

MailboxStatisticsSearchResultType Constructor Initializes a new instance of the MailboxStatisticsSearchResultType class.

Public Instance Properties

KeywordStatisticsSearchResult
UserMailbox

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MailboxStatisticsSearchResultType Class | Aspose.Email.Exchange.Schema Namespace


MailboxStatisticsSearchResultType Constructor

Initializes a new instance of the MailboxStatisticsSearchResultType class.

public MailboxStatisticsSearchResultType();

See Also

MailboxStatisticsSearchResultType Class | Aspose.Email.Exchange.Schema Namespace


MailboxStatisticsSearchResultType Properties

The properties of the MailboxStatisticsSearchResultType class are listed below. For a complete list of MailboxStatisticsSearchResultType class members, see the MailboxStatisticsSearchResultType Members topic.

Public Instance Properties

KeywordStatisticsSearchResult
UserMailbox

See Also

MailboxStatisticsSearchResultType Class | Aspose.Email.Exchange.Schema Namespace


KeywordStatisticsSearchResult Property

Aspose.Email

MailboxStatisticsSearchResultType.KeywordStatisticsSearchResult Property

public KeywordStatisticsSearchResultType KeywordStatisticsSearchResult {get; set;}

Remarks

See Also

MailboxStatisticsSearchResultType Class | Aspose.Email.Exchange.Schema Namespace


UserMailbox Property

Aspose.Email

MailboxStatisticsSearchResultType.UserMailbox Property

public UserMailboxType UserMailbox {get; set;}

Remarks

See Also

MailboxStatisticsSearchResultType Class | Aspose.Email.Exchange.Schema Namespace


MailboxTypeType Enumeration

public enum MailboxTypeType

Remarks

Members

Member Name | Description | Value
Unknown |  | 0
OneOff |  | 1
Mailbox |  | 2
PublicDL |  | 3
PrivateDL |  | 4
Contact |  | 5
PublicFolder |  | 6

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


MailTips Class

For a list of all members of this type, see MailTips Members.

System.Object
Aspose.Email.Exchange.Schema.MailTips

public class MailTips

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MailTips Members | Aspose.Email.Exchange.Schema Namespace


MailTips Members

MailTips overview

Public Instance Constructors

MailTips Constructor Initializes a new instance of the MailTips class.

Public Instance Properties

CustomMailTip
DeliveryRestricted
DeliveryRestrictedSpecified
ExternalMemberCount
ExternalMemberCountSpecified
InvalidRecipient
InvalidRecipientSpecified
IsModerated
IsModeratedSpecified
MailboxFull
MailboxFullSpecified
MaxMessageSize
MaxMessageSizeSpecified
OutOfOffice
PendingMailTips
RecipientAddress
TotalMemberCount
TotalMemberCountSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MailTips Class | Aspose.Email.Exchange.Schema Namespace


MailTips Constructor

Initializes a new instance of the MailTips class.

public MailTips();

See Also

MailTips Class | Aspose.Email.Exchange.Schema Namespace


MailTips Properties

The properties of the MailTips class are listed below. For a complete list of MailTips class members, see the MailTips Members topic.

Public Instance Properties

CustomMailTip
DeliveryRestricted
DeliveryRestrictedSpecified
ExternalMemberCount
ExternalMemberCountSpecified
InvalidRecipient
InvalidRecipientSpecified
IsModerated
IsModeratedSpecified
MailboxFull
MailboxFullSpecified
MaxMessageSize
MaxMessageSizeSpecified
OutOfOffice
PendingMailTips
RecipientAddress
TotalMemberCount
TotalMemberCountSpecified

See Also

MailTips Class | Aspose.Email.Exchange.Schema Namespace


CustomMailTip Property

Aspose.Email

MailTips.CustomMailTip Property

public string CustomMailTip {get; set;}

Remarks

See Also

MailTips Class | Aspose.Email.Exchange.Schema Namespace


DeliveryRestricted Property

Aspose.Email

MailTips.DeliveryRestricted Property

public bool DeliveryRestricted {get; set;}

Remarks

See Also

MailTips Class | Aspose.Email.Exchange.Schema Namespace


DeliveryRestrictedSpecified Property

Aspose.Email

MailTips.DeliveryRestrictedSpecified Property

public bool DeliveryRestrictedSpecified {get; set;}

Remarks

See Also

MailTips Class | Aspose.Email.Exchange.Schema Namespace


ExternalMemberCount Property

Aspose.Email

MailTips.ExternalMemberCount Property

public int ExternalMemberCount {get; set;}

Remarks

See Also

MailTips Class | Aspose.Email.Exchange.Schema Namespace


ExternalMemberCountSpecified Property

Aspose.Email

MailTips.ExternalMemberCountSpecified Property

public bool ExternalMemberCountSpecified {get; set;}

Remarks

See Also

MailTips Class | Aspose.Email.Exchange.Schema Namespace


InvalidRecipient Property

Aspose.Email

MailTips.InvalidRecipient Property

public bool InvalidRecipient {get; set;}

Remarks

See Also

MailTips Class | Aspose.Email.Exchange.Schema Namespace


InvalidRecipientSpecified Property

Aspose.Email

MailTips.InvalidRecipientSpecified Property

public bool InvalidRecipientSpecified {get; set;}

Remarks

See Also

MailTips Class | Aspose.Email.Exchange.Schema Namespace


IsModerated Property

Aspose.Email

MailTips.IsModerated Property

public bool IsModerated {get; set;}

Remarks

See Also

MailTips Class | Aspose.Email.Exchange.Schema Namespace


IsModeratedSpecified Property

Aspose.Email

MailTips.IsModeratedSpecified Property

public bool IsModeratedSpecified {get; set;}

Remarks

See Also

MailTips Class | Aspose.Email.Exchange.Schema Namespace


MailboxFull Property

Aspose.Email

MailTips.MailboxFull Property

public bool MailboxFull {get; set;}

Remarks

See Also

MailTips Class | Aspose.Email.Exchange.Schema Namespace


MailboxFullSpecified Property

Aspose.Email

MailTips.MailboxFullSpecified Property

public bool MailboxFullSpecified {get; set;}

Remarks

See Also

MailTips Class | Aspose.Email.Exchange.Schema Namespace


MaxMessageSize Property

Aspose.Email

MailTips.MaxMessageSize Property

public int MaxMessageSize {get; set;}

Remarks

See Also

MailTips Class | Aspose.Email.Exchange.Schema Namespace


MaxMessageSizeSpecified Property

Aspose.Email

MailTips.MaxMessageSizeSpecified Property

public bool MaxMessageSizeSpecified {get; set;}

Remarks

See Also

MailTips Class | Aspose.Email.Exchange.Schema Namespace


OutOfOffice Property

Aspose.Email

MailTips.OutOfOffice Property

public OutOfOfficeMailTip OutOfOffice {get; set;}

Remarks

See Also

MailTips Class | Aspose.Email.Exchange.Schema Namespace


PendingMailTips Property

Aspose.Email

MailTips.PendingMailTips Property

public MailTipTypes PendingMailTips {get; set;}

Remarks

See Also

MailTips Class | Aspose.Email.Exchange.Schema Namespace


RecipientAddress Property

Aspose.Email

MailTips.RecipientAddress Property

public EmailAddressType RecipientAddress {get; set;}

Remarks

See Also

MailTips Class | Aspose.Email.Exchange.Schema Namespace


TotalMemberCount Property

Aspose.Email

MailTips.TotalMemberCount Property

public int TotalMemberCount {get; set;}

Remarks

See Also

MailTips Class | Aspose.Email.Exchange.Schema Namespace


TotalMemberCountSpecified Property

Aspose.Email

MailTips.TotalMemberCountSpecified Property

public bool TotalMemberCountSpecified {get; set;}

Remarks

See Also

MailTips Class | Aspose.Email.Exchange.Schema Namespace


MailTipsResponseMessageType Class

For a list of all members of this type, see MailTipsResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ResponseMessageType
Aspose.Email.Exchange.Schema.MailTipsResponseMessageType

public class MailTipsResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MailTipsResponseMessageType Members | Aspose.Email.Exchange.Schema Namespace


MailTipsResponseMessageType Members

MailTipsResponseMessageType overview

Public Instance Constructors

MailTipsResponseMessageType Constructor Initializes a new instance of the MailTipsResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MailTips
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MailTipsResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


MailTipsResponseMessageType Constructor

Initializes a new instance of the MailTipsResponseMessageType class.

public MailTipsResponseMessageType();

See Also

MailTipsResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


MailTipsResponseMessageType Properties

The properties of the MailTipsResponseMessageType class are listed below. For a complete list of MailTipsResponseMessageType class members, see the MailTipsResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MailTips
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

MailTipsResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


MailTips Property

Aspose.Email

MailTipsResponseMessageType.MailTips Property

public MailTips MailTips {get; set;}

Remarks

See Also

MailTipsResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


MailTipsServiceConfiguration Class

For a list of all members of this type, see MailTipsServiceConfiguration Members.

System.Object
Aspose.Email.Exchange.Schema.ServiceConfiguration
Aspose.Email.Exchange.Schema.MailTipsServiceConfiguration

public class MailTipsServiceConfiguration : ServiceConfiguration

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MailTipsServiceConfiguration Members | Aspose.Email.Exchange.Schema Namespace


MailTipsServiceConfiguration Members

MailTipsServiceConfiguration overview

Public Instance Constructors

MailTipsServiceConfiguration Constructor Initializes a new instance of the MailTipsServiceConfiguration class.

Public Instance Properties

InternalDomains
LargeAudienceThreshold
MailTipsEnabled
MaxMessageSize
MaxRecipientsPerGetMailTipsRequest
ShowExternalRecipientCount

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MailTipsServiceConfiguration Class | Aspose.Email.Exchange.Schema Namespace


MailTipsServiceConfiguration Constructor

Initializes a new instance of the MailTipsServiceConfiguration class.

public MailTipsServiceConfiguration();

See Also

MailTipsServiceConfiguration Class | Aspose.Email.Exchange.Schema Namespace


MailTipsServiceConfiguration Properties

The properties of the MailTipsServiceConfiguration class are listed below. For a complete list of MailTipsServiceConfiguration class members, see the MailTipsServiceConfiguration Members topic.

Public Instance Properties

InternalDomains
LargeAudienceThreshold
MailTipsEnabled
MaxMessageSize
MaxRecipientsPerGetMailTipsRequest
ShowExternalRecipientCount

See Also

MailTipsServiceConfiguration Class | Aspose.Email.Exchange.Schema Namespace


InternalDomains Property

Aspose.Email

MailTipsServiceConfiguration.InternalDomains Property

public SmtpDomain[] InternalDomains {get; set;}

Remarks

See Also

MailTipsServiceConfiguration Class | Aspose.Email.Exchange.Schema Namespace


LargeAudienceThreshold Property

Aspose.Email

MailTipsServiceConfiguration.LargeAudienceThreshold Property

public int LargeAudienceThreshold {get; set;}

Remarks

See Also

MailTipsServiceConfiguration Class | Aspose.Email.Exchange.Schema Namespace


MailTipsEnabled Property

Aspose.Email

MailTipsServiceConfiguration.MailTipsEnabled Property

public bool MailTipsEnabled {get; set;}

Remarks

See Also

MailTipsServiceConfiguration Class | Aspose.Email.Exchange.Schema Namespace


MaxMessageSize Property

Aspose.Email

MailTipsServiceConfiguration.MaxMessageSize Property

public int MaxMessageSize {get; set;}

Remarks

See Also

MailTipsServiceConfiguration Class | Aspose.Email.Exchange.Schema Namespace


MaxRecipientsPerGetMailTipsRequest Property

Aspose.Email

MailTipsServiceConfiguration.MaxRecipientsPerGetMailTipsRequest Property

public int MaxRecipientsPerGetMailTipsRequest {get; set;}

Remarks

See Also

MailTipsServiceConfiguration Class | Aspose.Email.Exchange.Schema Namespace


ShowExternalRecipientCount Property

Aspose.Email

MailTipsServiceConfiguration.ShowExternalRecipientCount Property

public bool ShowExternalRecipientCount {get; set;}

Remarks

See Also

MailTipsServiceConfiguration Class | Aspose.Email.Exchange.Schema Namespace


MailTipTypes Enumeration

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum MailTipTypes

Remarks

Members

Member Name | Description | Value
All |  | 1
OutOfOfficeMessage |  | 2
MailboxFullStatus |  | 4
CustomMailTip |  | 8
ExternalMemberCount |  | 16
TotalMemberCount |  | 32
MaxMessageSize |  | 64
DeliveryRestriction |  | 128
ModerationStatus |  | 256
InvalidRecipient |  | 512

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


ManagedFolderInformationType Class

For a list of all members of this type, see ManagedFolderInformationType Members.

System.Object
Aspose.Email.Exchange.Schema.ManagedFolderInformationType

public class ManagedFolderInformationType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ManagedFolderInformationType Members | Aspose.Email.Exchange.Schema Namespace


ManagedFolderInformationType Members

ManagedFolderInformationType overview

Public Instance Constructors

ManagedFolderInformationType Constructor Initializes a new instance of the ManagedFolderInformationType class.

Public Instance Properties

CanDelete
CanDeleteSpecified
CanRenameOrMove
CanRenameOrMoveSpecified
Comment
FolderSize
FolderSizeSpecified
HasQuota
HasQuotaSpecified
HomePage
IsManagedFoldersRoot
IsManagedFoldersRootSpecified
ManagedFolderId
MustDisplayComment
MustDisplayCommentSpecified
StorageQuota
StorageQuotaSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ManagedFolderInformationType Class | Aspose.Email.Exchange.Schema Namespace


ManagedFolderInformationType Constructor

Initializes a new instance of the ManagedFolderInformationType class.

public ManagedFolderInformationType();

See Also

ManagedFolderInformationType Class | Aspose.Email.Exchange.Schema Namespace


ManagedFolderInformationType Properties

The properties of the ManagedFolderInformationType class are listed below. For a complete list of ManagedFolderInformationType class members, see the ManagedFolderInformationType Members topic.

Public Instance Properties

CanDelete
CanDeleteSpecified
CanRenameOrMove
CanRenameOrMoveSpecified
Comment
FolderSize
FolderSizeSpecified
HasQuota
HasQuotaSpecified
HomePage
IsManagedFoldersRoot
IsManagedFoldersRootSpecified
ManagedFolderId
MustDisplayComment
MustDisplayCommentSpecified
StorageQuota
StorageQuotaSpecified

See Also

ManagedFolderInformationType Class | Aspose.Email.Exchange.Schema Namespace


CanDelete Property

Aspose.Email

ManagedFolderInformationType.CanDelete Property

public bool CanDelete {get; set;}

Remarks

See Also

ManagedFolderInformationType Class | Aspose.Email.Exchange.Schema Namespace


CanDeleteSpecified Property

Aspose.Email

ManagedFolderInformationType.CanDeleteSpecified Property

public bool CanDeleteSpecified {get; set;}

Remarks

See Also

ManagedFolderInformationType Class | Aspose.Email.Exchange.Schema Namespace


CanRenameOrMove Property

Aspose.Email

ManagedFolderInformationType.CanRenameOrMove Property

public bool CanRenameOrMove {get; set;}

Remarks

See Also

ManagedFolderInformationType Class | Aspose.Email.Exchange.Schema Namespace


CanRenameOrMoveSpecified Property

Aspose.Email

ManagedFolderInformationType.CanRenameOrMoveSpecified Property

public bool CanRenameOrMoveSpecified {get; set;}

Remarks

See Also

ManagedFolderInformationType Class | Aspose.Email.Exchange.Schema Namespace


Comment Property

Aspose.Email

ManagedFolderInformationType.Comment Property

public string Comment {get; set;}

Remarks

See Also

ManagedFolderInformationType Class | Aspose.Email.Exchange.Schema Namespace


FolderSize Property

Aspose.Email

ManagedFolderInformationType.FolderSize Property

public int FolderSize {get; set;}

Remarks

See Also

ManagedFolderInformationType Class | Aspose.Email.Exchange.Schema Namespace


FolderSizeSpecified Property

Aspose.Email

ManagedFolderInformationType.FolderSizeSpecified Property

public bool FolderSizeSpecified {get; set;}

Remarks

See Also

ManagedFolderInformationType Class | Aspose.Email.Exchange.Schema Namespace


HasQuota Property

Aspose.Email

ManagedFolderInformationType.HasQuota Property

public bool HasQuota {get; set;}

Remarks

See Also

ManagedFolderInformationType Class | Aspose.Email.Exchange.Schema Namespace


HasQuotaSpecified Property

Aspose.Email

ManagedFolderInformationType.HasQuotaSpecified Property

public bool HasQuotaSpecified {get; set;}

Remarks

See Also

ManagedFolderInformationType Class | Aspose.Email.Exchange.Schema Namespace


HomePage Property

Aspose.Email

ManagedFolderInformationType.HomePage Property

public string HomePage {get; set;}

Remarks

See Also

ManagedFolderInformationType Class | Aspose.Email.Exchange.Schema Namespace


IsManagedFoldersRoot Property

Aspose.Email

ManagedFolderInformationType.IsManagedFoldersRoot Property

public bool IsManagedFoldersRoot {get; set;}

Remarks

See Also

ManagedFolderInformationType Class | Aspose.Email.Exchange.Schema Namespace


IsManagedFoldersRootSpecified Property

Aspose.Email

ManagedFolderInformationType.IsManagedFoldersRootSpecified Property

public bool IsManagedFoldersRootSpecified {get; set;}

Remarks

See Also

ManagedFolderInformationType Class | Aspose.Email.Exchange.Schema Namespace


ManagedFolderId Property

Aspose.Email

ManagedFolderInformationType.ManagedFolderId Property

public string ManagedFolderId {get; set;}

Remarks

See Also

ManagedFolderInformationType Class | Aspose.Email.Exchange.Schema Namespace


MustDisplayComment Property

Aspose.Email

ManagedFolderInformationType.MustDisplayComment Property

public bool MustDisplayComment {get; set;}

Remarks

See Also

ManagedFolderInformationType Class | Aspose.Email.Exchange.Schema Namespace


MustDisplayCommentSpecified Property

Aspose.Email

ManagedFolderInformationType.MustDisplayCommentSpecified Property

public bool MustDisplayCommentSpecified {get; set;}

Remarks

See Also

ManagedFolderInformationType Class | Aspose.Email.Exchange.Schema Namespace


StorageQuota Property

Aspose.Email

ManagedFolderInformationType.StorageQuota Property

public int StorageQuota {get; set;}

Remarks

See Also

ManagedFolderInformationType Class | Aspose.Email.Exchange.Schema Namespace


StorageQuotaSpecified Property

Aspose.Email

ManagedFolderInformationType.StorageQuotaSpecified Property

public bool StorageQuotaSpecified {get; set;}

Remarks

See Also

ManagedFolderInformationType Class | Aspose.Email.Exchange.Schema Namespace


MapiPropertyTypeType Enumeration

public enum MapiPropertyTypeType

Remarks

Members

Member Name | Description | Value
ApplicationTime |  | 0
ApplicationTimeArray |  | 1
Binary |  | 2
BinaryArray |  | 3
Boolean |  | 4
CLSID |  | 5
CLSIDArray |  | 6
Currency |  | 7
CurrencyArray |  | 8
Double |  | 9
DoubleArray |  | 10
Error |  | 11
Float |  | 12
FloatArray |  | 13
Integer |  | 14
IntegerArray |  | 15
Long |  | 16
LongArray |  | 17
Null |  | 18
Object |  | 19
ObjectArray |  | 20
Short |  | 21
ShortArray |  | 22
SystemTime |  | 23
SystemTimeArray |  | 24
String |  | 25
StringArray |  | 26

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


MeetingAttendeeType Enumeration

public enum MeetingAttendeeType

Remarks

Members

Member Name | Description | Value
Organizer |  | 0
Required |  | 1
Optional |  | 2
Room |  | 3
Resource |  | 4

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


MeetingCancellationMessageType Class

For a list of all members of this type, see MeetingCancellationMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ItemType
Aspose.Email.Exchange.Schema.MessageType
Aspose.Email.Exchange.Schema.MeetingMessageType
Aspose.Email.Exchange.Schema.MeetingCancellationMessageType

public class MeetingCancellationMessageType : MeetingMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MeetingCancellationMessageType Members | Aspose.Email.Exchange.Schema Namespace


MeetingCancellationMessageType Members

MeetingCancellationMessageType overview

Public Instance Constructors

MeetingCancellationMessageType Constructor Initializes a new instance of the MeetingCancellationMessageType class.

Public Instance Properties

AssociatedCalendarItemId (inherited from MeetingMessageType)
Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DateTimeStamp (inherited from MeetingMessageType)
DateTimeStampSpecified (inherited from MeetingMessageType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
From (inherited from MessageType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBeenProcessed (inherited from MeetingMessageType)
HasBeenProcessedSpecified (inherited from MeetingMessageType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDelegated (inherited from MeetingMessageType)
IsDelegatedSpecified (inherited from MeetingMessageType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsOutOfDate (inherited from MeetingMessageType)
IsOutOfDateSpecified (inherited from MeetingMessageType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
ParentFolderId (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
RecurrenceId (inherited from MeetingMessageType)
RecurrenceIdSpecified (inherited from MeetingMessageType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
ResponseType (inherited from MeetingMessageType)
ResponseTypeSpecified (inherited from MeetingMessageType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
Subject (inherited from ItemType)
ToRecipients (inherited from MessageType)
UID (inherited from MeetingMessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MeetingCancellationMessageType Class | Aspose.Email.Exchange.Schema Namespace


MeetingCancellationMessageType Constructor

Initializes a new instance of the MeetingCancellationMessageType class.

public MeetingCancellationMessageType();

See Also

MeetingCancellationMessageType Class | Aspose.Email.Exchange.Schema Namespace


MeetingMessageType Class

For a list of all members of this type, see MeetingMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ItemType
Aspose.Email.Exchange.Schema.MessageType
Aspose.Email.Exchange.Schema.MeetingMessageType
Aspose.Email.Exchange.Schema.MeetingCancellationMessageType
Aspose.Email.Exchange.Schema.MeetingRequestMessageType
Aspose.Email.Exchange.Schema.MeetingResponseMessageType

public class MeetingMessageType : MessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MeetingMessageType Members | Aspose.Email.Exchange.Schema Namespace


MeetingMessageType Members

MeetingMessageType overview

Public Instance Constructors

MeetingMessageType Constructor Initializes a new instance of the MeetingMessageType class.

Public Instance Properties

AssociatedCalendarItemId
Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DateTimeStamp
DateTimeStampSpecified
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
From (inherited from MessageType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBeenProcessed
HasBeenProcessedSpecified
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDelegated
IsDelegatedSpecified
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsOutOfDate
IsOutOfDateSpecified
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
ParentFolderId (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
RecurrenceId
RecurrenceIdSpecified
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
ResponseType
ResponseTypeSpecified
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
Subject (inherited from ItemType)
ToRecipients (inherited from MessageType)
UID
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MeetingMessageType Class | Aspose.Email.Exchange.Schema Namespace


MeetingMessageType Constructor

Initializes a new instance of the MeetingMessageType class.

public MeetingMessageType();

See Also

MeetingMessageType Class | Aspose.Email.Exchange.Schema Namespace


MeetingMessageType Properties

The properties of the MeetingMessageType class are listed below. For a complete list of MeetingMessageType class members, see the MeetingMessageType Members topic.

Public Instance Properties

AssociatedCalendarItemId
Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DateTimeStamp
DateTimeStampSpecified
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
From (inherited from MessageType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBeenProcessed
HasBeenProcessedSpecified
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDelegated
IsDelegatedSpecified
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsOutOfDate
IsOutOfDateSpecified
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
ParentFolderId (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
RecurrenceId
RecurrenceIdSpecified
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
ResponseType
ResponseTypeSpecified
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
Subject (inherited from ItemType)
ToRecipients (inherited from MessageType)
UID
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

See Also

MeetingMessageType Class | Aspose.Email.Exchange.Schema Namespace


AssociatedCalendarItemId Property

Aspose.Email

MeetingMessageType.AssociatedCalendarItemId Property

public ItemIdType AssociatedCalendarItemId {get; set;}

Remarks

See Also

MeetingMessageType Class | Aspose.Email.Exchange.Schema Namespace


DateTimeStamp Property

Aspose.Email

MeetingMessageType.DateTimeStamp Property

public DateTime DateTimeStamp {get; set;}

Remarks

See Also

MeetingMessageType Class | Aspose.Email.Exchange.Schema Namespace


DateTimeStampSpecified Property

Aspose.Email

MeetingMessageType.DateTimeStampSpecified Property

public bool DateTimeStampSpecified {get; set;}

Remarks

See Also

MeetingMessageType Class | Aspose.Email.Exchange.Schema Namespace


HasBeenProcessed Property

Aspose.Email

MeetingMessageType.HasBeenProcessed Property

public bool HasBeenProcessed {get; set;}

Remarks

See Also

MeetingMessageType Class | Aspose.Email.Exchange.Schema Namespace


HasBeenProcessedSpecified Property

Aspose.Email

MeetingMessageType.HasBeenProcessedSpecified Property

public bool HasBeenProcessedSpecified {get; set;}

Remarks

See Also

MeetingMessageType Class | Aspose.Email.Exchange.Schema Namespace


IsDelegated Property

Aspose.Email

MeetingMessageType.IsDelegated Property

public bool IsDelegated {get; set;}

Remarks

See Also

MeetingMessageType Class | Aspose.Email.Exchange.Schema Namespace


IsDelegatedSpecified Property

Aspose.Email

MeetingMessageType.IsDelegatedSpecified Property

public bool IsDelegatedSpecified {get; set;}

Remarks

See Also

MeetingMessageType Class | Aspose.Email.Exchange.Schema Namespace


IsOutOfDate Property

Aspose.Email

MeetingMessageType.IsOutOfDate Property

public bool IsOutOfDate {get; set;}

Remarks

See Also

MeetingMessageType Class | Aspose.Email.Exchange.Schema Namespace


IsOutOfDateSpecified Property

Aspose.Email

MeetingMessageType.IsOutOfDateSpecified Property

public bool IsOutOfDateSpecified {get; set;}

Remarks

See Also

MeetingMessageType Class | Aspose.Email.Exchange.Schema Namespace


RecurrenceId Property

Aspose.Email

MeetingMessageType.RecurrenceId Property

public DateTime RecurrenceId {get; set;}

Remarks

See Also

MeetingMessageType Class | Aspose.Email.Exchange.Schema Namespace


RecurrenceIdSpecified Property

Aspose.Email

MeetingMessageType.RecurrenceIdSpecified Property

public bool RecurrenceIdSpecified {get; set;}

Remarks

See Also

MeetingMessageType Class | Aspose.Email.Exchange.Schema Namespace


ResponseType Property

Aspose.Email

MeetingMessageType.ResponseType Property

public ResponseTypeType ResponseType {get; set;}

Remarks

See Also

MeetingMessageType Class | Aspose.Email.Exchange.Schema Namespace


ResponseTypeSpecified Property

Aspose.Email

MeetingMessageType.ResponseTypeSpecified Property

public bool ResponseTypeSpecified {get; set;}

Remarks

See Also

MeetingMessageType Class | Aspose.Email.Exchange.Schema Namespace


UID Property

Aspose.Email

MeetingMessageType.UID Property

public string UID {get; set;}

Remarks

See Also

MeetingMessageType Class | Aspose.Email.Exchange.Schema Namespace


MeetingRequestMessageType Class

For a list of all members of this type, see MeetingRequestMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ItemType
Aspose.Email.Exchange.Schema.MessageType
Aspose.Email.Exchange.Schema.MeetingMessageType
Aspose.Email.Exchange.Schema.MeetingRequestMessageType

public class MeetingRequestMessageType : MeetingMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MeetingRequestMessageType Members | Aspose.Email.Exchange.Schema Namespace


MeetingRequestMessageType Members

MeetingRequestMessageType overview

Public Instance Constructors

MeetingRequestMessageType Constructor Initializes a new instance of the MeetingRequestMessageType class.

Public Instance Properties

AdjacentMeetingCount
AdjacentMeetingCountSpecified
AdjacentMeetings
AllowNewTimeProposal
AllowNewTimeProposalSpecified
AppointmentReplyTime
AppointmentReplyTimeSpecified
AppointmentSequenceNumber
AppointmentSequenceNumberSpecified
AppointmentState
AppointmentStateSpecified
AssociatedCalendarItemId (inherited from MeetingMessageType)
Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
Body (inherited from ItemType)
CalendarItemType
CalendarItemTypeSpecified
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConferenceType
ConferenceTypeSpecified
ConflictingMeetingCount
ConflictingMeetingCountSpecified
ConflictingMeetings
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DateTimeStamp (inherited from MeetingMessageType)
DateTimeStampSpecified (inherited from MeetingMessageType)
DeletedOccurrences
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
Duration
EffectiveRights (inherited from ItemType)
End
EndSpecified
EndTimeZone
ExtendedProperty (inherited from ItemType)
FirstOccurrence
From (inherited from MessageType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBeenProcessed (inherited from MeetingMessageType)
HasBeenProcessedSpecified (inherited from MeetingMessageType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
IntendedFreeBusyStatus
IntendedFreeBusyStatusSpecified
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAllDayEvent
IsAllDayEventSpecified
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsCancelled
IsCancelledSpecified
IsDelegated (inherited from MeetingMessageType)
IsDelegatedSpecified (inherited from MeetingMessageType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsMeeting
IsMeetingSpecified
IsOnlineMeeting
IsOnlineMeetingSpecified
IsOutOfDate (inherited from MeetingMessageType)
IsOutOfDateSpecified (inherited from MeetingMessageType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsRecurring
IsRecurringSpecified
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
LastOccurrence
LegacyFreeBusyStatus
LegacyFreeBusyStatusSpecified
Location
MeetingRequestType
MeetingRequestTypeSpecified
MeetingRequestWasSent
MeetingRequestWasSentSpecified
MeetingTimeZone
MeetingWorkspaceUrl
MimeContent (inherited from ItemType)
ModifiedOccurrences
MyResponseType
MyResponseTypeSpecified
NetShowUrl
OptionalAttendees
Organizer
OriginalStart
OriginalStartSpecified
ParentFolderId (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
Recurrence
RecurrenceId (inherited from MeetingMessageType)
RecurrenceIdSpecified (inherited from MeetingMessageType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReplyTo (inherited from MessageType)
RequiredAttendees
Resources
ResponseObjects (inherited from ItemType)
ResponseType (inherited from MeetingMessageType)
ResponseTypeSpecified (inherited from MeetingMessageType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
Start
StartSpecified
StartTimeZone
Subject (inherited from ItemType)
TimeZone
ToRecipients (inherited from MessageType)
UID (inherited from MeetingMessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)
When

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


MeetingRequestMessageType Constructor

Initializes a new instance of the MeetingRequestMessageType class.

public MeetingRequestMessageType();

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


MeetingRequestMessageType Properties

The properties of the MeetingRequestMessageType class are listed below. For a complete list of MeetingRequestMessageType class members, see the MeetingRequestMessageType Members topic.

Public Instance Properties

AdjacentMeetingCount
AdjacentMeetingCountSpecified
AdjacentMeetings
AllowNewTimeProposal
AllowNewTimeProposalSpecified
AppointmentReplyTime
AppointmentReplyTimeSpecified
AppointmentSequenceNumber
AppointmentSequenceNumberSpecified
AppointmentState
AppointmentStateSpecified
AssociatedCalendarItemId (inherited from MeetingMessageType)
Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
Body (inherited from ItemType)
CalendarItemType
CalendarItemTypeSpecified
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConferenceType
ConferenceTypeSpecified
ConflictingMeetingCount
ConflictingMeetingCountSpecified
ConflictingMeetings
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DateTimeStamp (inherited from MeetingMessageType)
DateTimeStampSpecified (inherited from MeetingMessageType)
DeletedOccurrences
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
Duration
EffectiveRights (inherited from ItemType)
End
EndSpecified
EndTimeZone
ExtendedProperty (inherited from ItemType)
FirstOccurrence
From (inherited from MessageType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBeenProcessed (inherited from MeetingMessageType)
HasBeenProcessedSpecified (inherited from MeetingMessageType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
IntendedFreeBusyStatus
IntendedFreeBusyStatusSpecified
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAllDayEvent
IsAllDayEventSpecified
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsCancelled
IsCancelledSpecified
IsDelegated (inherited from MeetingMessageType)
IsDelegatedSpecified (inherited from MeetingMessageType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsMeeting
IsMeetingSpecified
IsOnlineMeeting
IsOnlineMeetingSpecified
IsOutOfDate (inherited from MeetingMessageType)
IsOutOfDateSpecified (inherited from MeetingMessageType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsRecurring
IsRecurringSpecified
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
LastOccurrence
LegacyFreeBusyStatus
LegacyFreeBusyStatusSpecified
Location
MeetingRequestType
MeetingRequestTypeSpecified
MeetingRequestWasSent
MeetingRequestWasSentSpecified
MeetingTimeZone
MeetingWorkspaceUrl
MimeContent (inherited from ItemType)
ModifiedOccurrences
MyResponseType
MyResponseTypeSpecified
NetShowUrl
OptionalAttendees
Organizer
OriginalStart
OriginalStartSpecified
ParentFolderId (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
Recurrence
RecurrenceId (inherited from MeetingMessageType)
RecurrenceIdSpecified (inherited from MeetingMessageType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReplyTo (inherited from MessageType)
RequiredAttendees
Resources
ResponseObjects (inherited from ItemType)
ResponseType (inherited from MeetingMessageType)
ResponseTypeSpecified (inherited from MeetingMessageType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
Start
StartSpecified
StartTimeZone
Subject (inherited from ItemType)
TimeZone
ToRecipients (inherited from MessageType)
UID (inherited from MeetingMessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)
When

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


AdjacentMeetingCount Property

Aspose.Email

MeetingRequestMessageType.AdjacentMeetingCount Property

public int AdjacentMeetingCount {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


AdjacentMeetingCountSpecified Property

Aspose.Email

MeetingRequestMessageType.AdjacentMeetingCountSpecified Property

public bool AdjacentMeetingCountSpecified {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


AdjacentMeetings Property

Aspose.Email

MeetingRequestMessageType.AdjacentMeetings Property

public NonEmptyArrayOfAllItemsType AdjacentMeetings {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


AllowNewTimeProposal Property

Aspose.Email

MeetingRequestMessageType.AllowNewTimeProposal Property

public bool AllowNewTimeProposal {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


AllowNewTimeProposalSpecified Property

Aspose.Email

MeetingRequestMessageType.AllowNewTimeProposalSpecified Property

public bool AllowNewTimeProposalSpecified {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


AppointmentReplyTime Property

Aspose.Email

MeetingRequestMessageType.AppointmentReplyTime Property

public DateTime AppointmentReplyTime {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


AppointmentReplyTimeSpecified Property

Aspose.Email

MeetingRequestMessageType.AppointmentReplyTimeSpecified Property

public bool AppointmentReplyTimeSpecified {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


AppointmentSequenceNumber Property

Aspose.Email

MeetingRequestMessageType.AppointmentSequenceNumber Property

public int AppointmentSequenceNumber {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


AppointmentSequenceNumberSpecified Property

Aspose.Email

MeetingRequestMessageType.AppointmentSequenceNumberSpecified Property

public bool AppointmentSequenceNumberSpecified {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


AppointmentState Property

Aspose.Email

MeetingRequestMessageType.AppointmentState Property

public int AppointmentState {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


AppointmentStateSpecified Property

Aspose.Email

MeetingRequestMessageType.AppointmentStateSpecified Property

public bool AppointmentStateSpecified {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


CalendarItemType Property

Aspose.Email

MeetingRequestMessageType.CalendarItemType Property

public CalendarItemTypeType CalendarItemType {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


CalendarItemTypeSpecified Property

Aspose.Email

MeetingRequestMessageType.CalendarItemTypeSpecified Property

public bool CalendarItemTypeSpecified {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


ConferenceType Property

Aspose.Email

MeetingRequestMessageType.ConferenceType Property

public int ConferenceType {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


ConferenceTypeSpecified Property

Aspose.Email

MeetingRequestMessageType.ConferenceTypeSpecified Property

public bool ConferenceTypeSpecified {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


ConflictingMeetingCount Property

Aspose.Email

MeetingRequestMessageType.ConflictingMeetingCount Property

public int ConflictingMeetingCount {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


ConflictingMeetingCountSpecified Property

Aspose.Email

MeetingRequestMessageType.ConflictingMeetingCountSpecified Property

public bool ConflictingMeetingCountSpecified {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


ConflictingMeetings Property

Aspose.Email

MeetingRequestMessageType.ConflictingMeetings Property

public NonEmptyArrayOfAllItemsType ConflictingMeetings {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


DeletedOccurrences Property

Aspose.Email

MeetingRequestMessageType.DeletedOccurrences Property

public DeletedOccurrenceInfoType[] DeletedOccurrences {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


Duration Property

Aspose.Email

MeetingRequestMessageType.Duration Property

public string Duration {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


End Property

Aspose.Email

MeetingRequestMessageType.End Property

public DateTime End {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


EndSpecified Property

Aspose.Email

MeetingRequestMessageType.EndSpecified Property

public bool EndSpecified {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


EndTimeZone Property

Aspose.Email

MeetingRequestMessageType.EndTimeZone Property

public TimeZoneDefinitionType EndTimeZone {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


FirstOccurrence Property

Aspose.Email

MeetingRequestMessageType.FirstOccurrence Property

public OccurrenceInfoType FirstOccurrence {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


IntendedFreeBusyStatus Property

Aspose.Email

MeetingRequestMessageType.IntendedFreeBusyStatus Property

public LegacyFreeBusyType IntendedFreeBusyStatus {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


IntendedFreeBusyStatusSpecified Property

Aspose.Email

MeetingRequestMessageType.IntendedFreeBusyStatusSpecified Property

public bool IntendedFreeBusyStatusSpecified {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


IsAllDayEvent Property

Aspose.Email

MeetingRequestMessageType.IsAllDayEvent Property

public bool IsAllDayEvent {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


IsAllDayEventSpecified Property

Aspose.Email

MeetingRequestMessageType.IsAllDayEventSpecified Property

public bool IsAllDayEventSpecified {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


IsCancelled Property

Aspose.Email

MeetingRequestMessageType.IsCancelled Property

public bool IsCancelled {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


IsCancelledSpecified Property

Aspose.Email

MeetingRequestMessageType.IsCancelledSpecified Property

public bool IsCancelledSpecified {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


IsMeeting Property

Aspose.Email

MeetingRequestMessageType.IsMeeting Property

public bool IsMeeting {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


IsMeetingSpecified Property

Aspose.Email

MeetingRequestMessageType.IsMeetingSpecified Property

public bool IsMeetingSpecified {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


IsOnlineMeeting Property

Aspose.Email

MeetingRequestMessageType.IsOnlineMeeting Property

public bool IsOnlineMeeting {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


IsOnlineMeetingSpecified Property

Aspose.Email

MeetingRequestMessageType.IsOnlineMeetingSpecified Property

public bool IsOnlineMeetingSpecified {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


IsRecurring Property

Aspose.Email

MeetingRequestMessageType.IsRecurring Property

public bool IsRecurring {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


IsRecurringSpecified Property

Aspose.Email

MeetingRequestMessageType.IsRecurringSpecified Property

public bool IsRecurringSpecified {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


LastOccurrence Property

Aspose.Email

MeetingRequestMessageType.LastOccurrence Property

public OccurrenceInfoType LastOccurrence {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


LegacyFreeBusyStatus Property

Aspose.Email

MeetingRequestMessageType.LegacyFreeBusyStatus Property

public LegacyFreeBusyType LegacyFreeBusyStatus {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


LegacyFreeBusyStatusSpecified Property

Aspose.Email

MeetingRequestMessageType.LegacyFreeBusyStatusSpecified Property

public bool LegacyFreeBusyStatusSpecified {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


Location Property

Aspose.Email

MeetingRequestMessageType.Location Property

public string Location {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


MeetingRequestType Property

Aspose.Email

MeetingRequestMessageType.MeetingRequestType Property

public MeetingRequestTypeType MeetingRequestType {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


MeetingRequestTypeSpecified Property

Aspose.Email

MeetingRequestMessageType.MeetingRequestTypeSpecified Property

public bool MeetingRequestTypeSpecified {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


MeetingRequestWasSent Property

Aspose.Email

MeetingRequestMessageType.MeetingRequestWasSent Property

public bool MeetingRequestWasSent {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


MeetingRequestWasSentSpecified Property

Aspose.Email

MeetingRequestMessageType.MeetingRequestWasSentSpecified Property

public bool MeetingRequestWasSentSpecified {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


MeetingTimeZone Property

Aspose.Email

MeetingRequestMessageType.MeetingTimeZone Property

public TimeZoneType MeetingTimeZone {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


MeetingWorkspaceUrl Property

Aspose.Email

MeetingRequestMessageType.MeetingWorkspaceUrl Property

public string MeetingWorkspaceUrl {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


ModifiedOccurrences Property

Aspose.Email

MeetingRequestMessageType.ModifiedOccurrences Property

public OccurrenceInfoType[] ModifiedOccurrences {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


MyResponseType Property

Aspose.Email

MeetingRequestMessageType.MyResponseType Property

public ResponseTypeType MyResponseType {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


MyResponseTypeSpecified Property

Aspose.Email

MeetingRequestMessageType.MyResponseTypeSpecified Property

public bool MyResponseTypeSpecified {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


NetShowUrl Property

Aspose.Email

MeetingRequestMessageType.NetShowUrl Property

public string NetShowUrl {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


OptionalAttendees Property

Aspose.Email

MeetingRequestMessageType.OptionalAttendees Property

public AttendeeType[] OptionalAttendees {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


Organizer Property

Aspose.Email

MeetingRequestMessageType.Organizer Property

public SingleRecipientType Organizer {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


OriginalStart Property

Aspose.Email

MeetingRequestMessageType.OriginalStart Property

public DateTime OriginalStart {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


OriginalStartSpecified Property

Aspose.Email

MeetingRequestMessageType.OriginalStartSpecified Property

public bool OriginalStartSpecified {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


Recurrence Property

Aspose.Email

MeetingRequestMessageType.Recurrence Property

public RecurrenceType Recurrence {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


RequiredAttendees Property

Aspose.Email

MeetingRequestMessageType.RequiredAttendees Property

public AttendeeType[] RequiredAttendees {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


Resources Property

Aspose.Email

MeetingRequestMessageType.Resources Property

public AttendeeType[] Resources {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


Start Property

Aspose.Email

MeetingRequestMessageType.Start Property

public DateTime Start {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


StartSpecified Property

Aspose.Email

MeetingRequestMessageType.StartSpecified Property

public bool StartSpecified {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


StartTimeZone Property

Aspose.Email

MeetingRequestMessageType.StartTimeZone Property

public TimeZoneDefinitionType StartTimeZone {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


TimeZone Property

Aspose.Email

MeetingRequestMessageType.TimeZone Property

public string TimeZone {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


When Property

Aspose.Email

MeetingRequestMessageType.When Property

public string When {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema Namespace


MeetingRequestTypeType Enumeration

public enum MeetingRequestTypeType

Remarks

Members

Member Name | Description | Value
None |  | 0
FullUpdate |  | 1
InformationalUpdate |  | 2
NewMeetingRequest |  | 3
Outdated |  | 4
SilentUpdate |  | 5
PrincipalWantsCopy |  | 6

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


MeetingResponseMessageType Class

For a list of all members of this type, see MeetingResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ItemType
Aspose.Email.Exchange.Schema.MessageType
Aspose.Email.Exchange.Schema.MeetingMessageType
Aspose.Email.Exchange.Schema.MeetingResponseMessageType

public class MeetingResponseMessageType : MeetingMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MeetingResponseMessageType Members | Aspose.Email.Exchange.Schema Namespace


MeetingResponseMessageType Members

MeetingResponseMessageType overview

Public Instance Constructors

MeetingResponseMessageType Constructor Initializes a new instance of the MeetingResponseMessageType class.

Public Instance Properties

AssociatedCalendarItemId (inherited from MeetingMessageType)
Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DateTimeStamp (inherited from MeetingMessageType)
DateTimeStampSpecified (inherited from MeetingMessageType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
From (inherited from MessageType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBeenProcessed (inherited from MeetingMessageType)
HasBeenProcessedSpecified (inherited from MeetingMessageType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDelegated (inherited from MeetingMessageType)
IsDelegatedSpecified (inherited from MeetingMessageType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsOutOfDate (inherited from MeetingMessageType)
IsOutOfDateSpecified (inherited from MeetingMessageType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
ParentFolderId (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
RecurrenceId (inherited from MeetingMessageType)
RecurrenceIdSpecified (inherited from MeetingMessageType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
ResponseType (inherited from MeetingMessageType)
ResponseTypeSpecified (inherited from MeetingMessageType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
Subject (inherited from ItemType)
ToRecipients (inherited from MessageType)
UID (inherited from MeetingMessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MeetingResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


MeetingResponseMessageType Constructor

Initializes a new instance of the MeetingResponseMessageType class.

public MeetingResponseMessageType();

See Also

MeetingResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


MemberStatusType Enumeration

public enum MemberStatusType

Remarks

Members

Member Name | Description | Value
Unrecognized |  | 0
Normal |  | 1
Demoted |  | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


MemberType Class

For a list of all members of this type, see MemberType Members.

System.Object
Aspose.Email.Exchange.Schema.MemberType

public class MemberType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MemberType Members | Aspose.Email.Exchange.Schema Namespace


MemberType Members

MemberType overview

Public Instance Constructors

MemberType Constructor Initializes a new instance of the MemberType class.

Public Instance Properties

Key
Mailbox
Status
StatusSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MemberType Class | Aspose.Email.Exchange.Schema Namespace


MemberType Constructor

Initializes a new instance of the MemberType class.

public MemberType();

See Also

MemberType Class | Aspose.Email.Exchange.Schema Namespace


MemberType Properties

The properties of the MemberType class are listed below. For a complete list of MemberType class members, see the MemberType Members topic.

Public Instance Properties

Key
Mailbox
Status
StatusSpecified

See Also

MemberType Class | Aspose.Email.Exchange.Schema Namespace


Key Property

Aspose.Email

MemberType.Key Property

public string Key {get; set;}

Remarks

See Also

MemberType Class | Aspose.Email.Exchange.Schema Namespace


Mailbox Property

Aspose.Email

MemberType.Mailbox Property

public EmailAddressType Mailbox {get; set;}

Remarks

See Also

MemberType Class | Aspose.Email.Exchange.Schema Namespace


Status Property

Aspose.Email

MemberType.Status Property

public MemberStatusType Status {get; set;}

Remarks

See Also

MemberType Class | Aspose.Email.Exchange.Schema Namespace


StatusSpecified Property

Aspose.Email

MemberType.StatusSpecified Property

public bool StatusSpecified {get; set;}

Remarks

See Also

MemberType Class | Aspose.Email.Exchange.Schema Namespace


MessageDispositionType Enumeration

public enum MessageDispositionType

Remarks

Members

Member Name | Description | Value
SaveOnly |  | 0
SendOnly |  | 1
SendAndSaveCopy |  | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


MessageTrackingDeliveryStatusType Enumeration

public enum MessageTrackingDeliveryStatusType

Remarks

Members

Member Name | Description | Value
Unsuccessful |  | 0
Pending |  | 1
Delivered |  | 2
Transferred |  | 3
Read |  | 4

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


MessageTrackingEventDescriptionType Enumeration

public enum MessageTrackingEventDescriptionType

Remarks

Members

Member Name | Description | Value
Submitted |  | 0
Resolved |  | 1
Expanded |  | 2
Delivered |  | 3
MovedToFolderByInboxRule |  | 4
RulesCc |  | 5
FailedGeneral |  | 6
FailedModeration |  | 7
FailedTransportRules |  | 8
SmtpSend |  | 9
SmtpSendCrossSite |  | 10
SmtpSendCrossForest |  | 11
SmtpReceive |  | 12
Forwarded |  | 13
Pending |  | 14
PendingModeration |  | 15
ApprovedModeration |  | 16
QueueRetry |  | 17
QueueRetryNoRetryTime |  | 18
MessageDefer |  | 19
TransferredToForeignOrg |  | 20
TransferredToPartnerOrg |  | 21
TransferredToLegacyExchangeServer |  | 22
DelayedAfterTransferToPartnerOrg |  | 23
Read |  | 24
NotRead |  | 25

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


MessageTrackingReportTemplateType Enumeration

public enum MessageTrackingReportTemplateType

Remarks

Members

Member Name | Description | Value
Summary |  | 0
RecipientPath |  | 1

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


MessageTrackingReportType Class

For a list of all members of this type, see MessageTrackingReportType Members.

System.Object
Aspose.Email.Exchange.Schema.MessageTrackingReportType

public class MessageTrackingReportType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MessageTrackingReportType Members | Aspose.Email.Exchange.Schema Namespace


MessageTrackingReportType Members

MessageTrackingReportType overview

Public Instance Constructors

MessageTrackingReportType Constructor Initializes a new instance of the MessageTrackingReportType class.

Public Instance Properties

OriginalRecipients
Properties
PurportedSender
RecipientTrackingEvents
Sender
Subject
SubmitTime
SubmitTimeSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MessageTrackingReportType Class | Aspose.Email.Exchange.Schema Namespace


MessageTrackingReportType Constructor

Initializes a new instance of the MessageTrackingReportType class.

public MessageTrackingReportType();

See Also

MessageTrackingReportType Class | Aspose.Email.Exchange.Schema Namespace


MessageTrackingReportType Properties

The properties of the MessageTrackingReportType class are listed below. For a complete list of MessageTrackingReportType class members, see the MessageTrackingReportType Members topic.

Public Instance Properties

OriginalRecipients
Properties
PurportedSender
RecipientTrackingEvents
Sender
Subject
SubmitTime
SubmitTimeSpecified

See Also

MessageTrackingReportType Class | Aspose.Email.Exchange.Schema Namespace


OriginalRecipients Property

Aspose.Email

MessageTrackingReportType.OriginalRecipients Property

public EmailAddressType[] OriginalRecipients {get; set;}

Remarks

See Also

MessageTrackingReportType Class | Aspose.Email.Exchange.Schema Namespace


Properties Property

Aspose.Email

MessageTrackingReportType.Properties Property

public TrackingPropertyType[] Properties {get; set;}

Remarks

See Also

MessageTrackingReportType Class | Aspose.Email.Exchange.Schema Namespace


PurportedSender Property

Aspose.Email

MessageTrackingReportType.PurportedSender Property

public EmailAddressType PurportedSender {get; set;}

Remarks

See Also

MessageTrackingReportType Class | Aspose.Email.Exchange.Schema Namespace


RecipientTrackingEvents Property

Aspose.Email

MessageTrackingReportType.RecipientTrackingEvents Property

public RecipientTrackingEventType[] RecipientTrackingEvents {get; set;}

Remarks

See Also

MessageTrackingReportType Class | Aspose.Email.Exchange.Schema Namespace


Sender Property

Aspose.Email

MessageTrackingReportType.Sender Property

public EmailAddressType Sender {get; set;}

Remarks

See Also

MessageTrackingReportType Class | Aspose.Email.Exchange.Schema Namespace


Subject Property

Aspose.Email

MessageTrackingReportType.Subject Property

public string Subject {get; set;}

Remarks

See Also

MessageTrackingReportType Class | Aspose.Email.Exchange.Schema Namespace


SubmitTime Property

Aspose.Email

MessageTrackingReportType.SubmitTime Property

public DateTime SubmitTime {get; set;}

Remarks

See Also

MessageTrackingReportType Class | Aspose.Email.Exchange.Schema Namespace


SubmitTimeSpecified Property

Aspose.Email

MessageTrackingReportType.SubmitTimeSpecified Property

public bool SubmitTimeSpecified {get; set;}

Remarks

See Also

MessageTrackingReportType Class | Aspose.Email.Exchange.Schema Namespace


MessageTrackingScopeType Enumeration

public enum MessageTrackingScopeType

Remarks

Members

Member Name | Description | Value
Organization |  | 0
Forest |  | 1
Site |  | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


MessageType Class

For a list of all members of this type, see MessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ItemType
Aspose.Email.Exchange.Schema.MessageType
Aspose.Email.Exchange.Schema.MeetingMessageType
Aspose.Email.Exchange.Schema.ResponseObjectCoreType

public class MessageType : ItemType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MessageType Members | Aspose.Email.Exchange.Schema Namespace


MessageType Members

MessageType overview

Public Instance Constructors

MessageType Constructor Initializes a new instance of the MessageType class.

Public Instance Properties

Attachments (inherited from ItemType)
BccRecipients
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients
ConversationId (inherited from ItemType)
ConversationIndex
ConversationTopic
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
From
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested
IsDeliveryReceiptRequestedSpecified
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead
IsReadReceiptRequested
IsReadReceiptRequestedSpecified
IsReadSpecified
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested
IsResponseRequestedSpecified
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
ParentFolderId (inherited from ItemType)
ReceivedBy
ReceivedRepresenting
References
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReplyTo
ResponseObjects (inherited from ItemType)
Sender
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
Subject (inherited from ItemType)
ToRecipients
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MessageType Class | Aspose.Email.Exchange.Schema Namespace


MessageType Constructor

Initializes a new instance of the MessageType class.

public MessageType();

See Also

MessageType Class | Aspose.Email.Exchange.Schema Namespace


MessageType Properties

The properties of the MessageType class are listed below. For a complete list of MessageType class members, see the MessageType Members topic.

Public Instance Properties

Attachments (inherited from ItemType)
BccRecipients
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients
ConversationId (inherited from ItemType)
ConversationIndex
ConversationTopic
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
From
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested
IsDeliveryReceiptRequestedSpecified
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead
IsReadReceiptRequested
IsReadReceiptRequestedSpecified
IsReadSpecified
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested
IsResponseRequestedSpecified
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
ParentFolderId (inherited from ItemType)
ReceivedBy
ReceivedRepresenting
References
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReplyTo
ResponseObjects (inherited from ItemType)
Sender
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
Subject (inherited from ItemType)
ToRecipients
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

See Also

MessageType Class | Aspose.Email.Exchange.Schema Namespace


BccRecipients Property

Aspose.Email

MessageType.BccRecipients Property

public EmailAddressType[] BccRecipients {get; set;}

Remarks

See Also

MessageType Class | Aspose.Email.Exchange.Schema Namespace


CcRecipients Property

Aspose.Email

MessageType.CcRecipients Property

public EmailAddressType[] CcRecipients {get; set;}

Remarks

See Also

MessageType Class | Aspose.Email.Exchange.Schema Namespace


ConversationIndex Property

Aspose.Email

MessageType.ConversationIndex Property

public byte[] ConversationIndex {get; set;}

Remarks

See Also

MessageType Class | Aspose.Email.Exchange.Schema Namespace


ConversationTopic Property

Aspose.Email

MessageType.ConversationTopic Property

public string ConversationTopic {get; set;}

Remarks

See Also

MessageType Class | Aspose.Email.Exchange.Schema Namespace


From Property

Aspose.Email

MessageType.From Property

public SingleRecipientType From {get; set;}

Remarks

See Also

MessageType Class | Aspose.Email.Exchange.Schema Namespace


InternetMessageId Property

Aspose.Email

MessageType.InternetMessageId Property

public string InternetMessageId {get; set;}

Remarks

See Also

MessageType Class | Aspose.Email.Exchange.Schema Namespace


IsDeliveryReceiptRequested Property

Aspose.Email

MessageType.IsDeliveryReceiptRequested Property

public bool IsDeliveryReceiptRequested {get; set;}

Remarks

See Also

MessageType Class | Aspose.Email.Exchange.Schema Namespace


IsDeliveryReceiptRequestedSpecified Property

Aspose.Email

MessageType.IsDeliveryReceiptRequestedSpecified Property

public bool IsDeliveryReceiptRequestedSpecified {get; set;}

Remarks

See Also

MessageType Class | Aspose.Email.Exchange.Schema Namespace


IsRead Property

Aspose.Email

MessageType.IsRead Property

public bool IsRead {get; set;}

Remarks

See Also

MessageType Class | Aspose.Email.Exchange.Schema Namespace


IsReadReceiptRequested Property

Aspose.Email

MessageType.IsReadReceiptRequested Property

public bool IsReadReceiptRequested {get; set;}

Remarks

See Also

MessageType Class | Aspose.Email.Exchange.Schema Namespace


IsReadReceiptRequestedSpecified Property

Aspose.Email

MessageType.IsReadReceiptRequestedSpecified Property

public bool IsReadReceiptRequestedSpecified {get; set;}

Remarks

See Also

MessageType Class | Aspose.Email.Exchange.Schema Namespace


IsReadSpecified Property

Aspose.Email

MessageType.IsReadSpecified Property

public bool IsReadSpecified {get; set;}

Remarks

See Also

MessageType Class | Aspose.Email.Exchange.Schema Namespace


IsResponseRequested Property

Aspose.Email

MessageType.IsResponseRequested Property

public bool IsResponseRequested {get; set;}

Remarks

See Also

MessageType Class | Aspose.Email.Exchange.Schema Namespace


IsResponseRequestedSpecified Property

Aspose.Email

MessageType.IsResponseRequestedSpecified Property

public bool IsResponseRequestedSpecified {get; set;}

Remarks

See Also

MessageType Class | Aspose.Email.Exchange.Schema Namespace


ReceivedBy Property

Aspose.Email

MessageType.ReceivedBy Property

public SingleRecipientType ReceivedBy {get; set;}

Remarks

See Also

MessageType Class | Aspose.Email.Exchange.Schema Namespace


ReceivedRepresenting Property

Aspose.Email

MessageType.ReceivedRepresenting Property

public SingleRecipientType ReceivedRepresenting {get; set;}

Remarks

See Also

MessageType Class | Aspose.Email.Exchange.Schema Namespace


References Property

Aspose.Email

MessageType.References Property

public string References {get; set;}

Remarks

See Also

MessageType Class | Aspose.Email.Exchange.Schema Namespace


ReplyTo Property

Aspose.Email

MessageType.ReplyTo Property

public EmailAddressType[] ReplyTo {get; set;}

Remarks

See Also

MessageType Class | Aspose.Email.Exchange.Schema Namespace


Sender Property

Aspose.Email

MessageType.Sender Property

public SingleRecipientType Sender {get; set;}

Remarks

See Also

MessageType Class | Aspose.Email.Exchange.Schema Namespace


ToRecipients Property

Aspose.Email

MessageType.ToRecipients Property

public EmailAddressType[] ToRecipients {get; set;}

Remarks

See Also

MessageType Class | Aspose.Email.Exchange.Schema Namespace


MimeContentType Class

For a list of all members of this type, see MimeContentType Members.

System.Object
Aspose.Email.Exchange.Schema.MimeContentType

public class MimeContentType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MimeContentType Members | Aspose.Email.Exchange.Schema Namespace


MimeContentType Members

MimeContentType overview

Public Instance Constructors

MimeContentType Constructor Initializes a new instance of the MimeContentType class.

Public Instance Properties

CharacterSet
Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MimeContentType Class | Aspose.Email.Exchange.Schema Namespace


MimeContentType Constructor

Initializes a new instance of the MimeContentType class.

public MimeContentType();

See Also

MimeContentType Class | Aspose.Email.Exchange.Schema Namespace


MimeContentType Properties

The properties of the MimeContentType class are listed below. For a complete list of MimeContentType class members, see the MimeContentType Members topic.

Public Instance Properties

CharacterSet
Value

See Also

MimeContentType Class | Aspose.Email.Exchange.Schema Namespace


CharacterSet Property

Aspose.Email

MimeContentType.CharacterSet Property

public string CharacterSet {get; set;}

Remarks

See Also

MimeContentType Class | Aspose.Email.Exchange.Schema Namespace


Value Property

Aspose.Email

MimeContentType.Value Property

public string Value {get; set;}

Remarks

See Also

MimeContentType Class | Aspose.Email.Exchange.Schema Namespace


ModifiedEventType Class

For a list of all members of this type, see ModifiedEventType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseNotificationEventType
Aspose.Email.Exchange.Schema.BaseObjectChangedEventType
Aspose.Email.Exchange.Schema.ModifiedEventType

public class ModifiedEventType : BaseObjectChangedEventType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ModifiedEventType Members | Aspose.Email.Exchange.Schema Namespace


ModifiedEventType Members

ModifiedEventType overview

Public Instance Constructors

ModifiedEventType Constructor Initializes a new instance of the ModifiedEventType class.

Public Instance Properties

Item (inherited from BaseObjectChangedEventType)
ParentFolderId (inherited from BaseObjectChangedEventType)
TimeStamp (inherited from BaseObjectChangedEventType)
UnreadCount
UnreadCountSpecified
Watermark (inherited from BaseNotificationEventType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ModifiedEventType Class | Aspose.Email.Exchange.Schema Namespace


ModifiedEventType Constructor

Initializes a new instance of the ModifiedEventType class.

public ModifiedEventType();

See Also

ModifiedEventType Class | Aspose.Email.Exchange.Schema Namespace


ModifiedEventType Properties

The properties of the ModifiedEventType class are listed below. For a complete list of ModifiedEventType class members, see the ModifiedEventType Members topic.

Public Instance Properties

Item (inherited from BaseObjectChangedEventType)
ParentFolderId (inherited from BaseObjectChangedEventType)
TimeStamp (inherited from BaseObjectChangedEventType)
UnreadCount
UnreadCountSpecified
Watermark (inherited from BaseNotificationEventType)

See Also

ModifiedEventType Class | Aspose.Email.Exchange.Schema Namespace


UnreadCount Property

Aspose.Email

ModifiedEventType.UnreadCount Property

public int UnreadCount {get; set;}

Remarks

See Also

ModifiedEventType Class | Aspose.Email.Exchange.Schema Namespace


UnreadCountSpecified Property

Aspose.Email

ModifiedEventType.UnreadCountSpecified Property

public bool UnreadCountSpecified {get; set;}

Remarks

See Also

ModifiedEventType Class | Aspose.Email.Exchange.Schema Namespace


MonthlyRegeneratingPatternType Class

Class describes the interval, in months, in which a task is regenerated.

For a list of all members of this type, see MonthlyRegeneratingPatternType Members.

System.Object
Aspose.Email.Exchange.Schema.RecurrencePatternBaseType
Aspose.Email.Exchange.Schema.IntervalRecurrencePatternBaseType
Aspose.Email.Exchange.Schema.RegeneratingPatternBaseType
Aspose.Email.Exchange.Schema.MonthlyRegeneratingPatternType

public class MonthlyRegeneratingPatternType : RegeneratingPatternBaseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MonthlyRegeneratingPatternType Members | Aspose.Email.Exchange.Schema Namespace


MonthlyRegeneratingPatternType Members

MonthlyRegeneratingPatternType overview

Public Instance Constructors

MonthlyRegeneratingPatternType Constructor Initializes a new instance of the MonthlyRegeneratingPatternType class.

Public Instance Properties

Interval (inherited from IntervalRecurrencePatternBaseType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MonthlyRegeneratingPatternType Class | Aspose.Email.Exchange.Schema Namespace


MonthlyRegeneratingPatternType Constructor

Initializes a new instance of the MonthlyRegeneratingPatternType class.

public MonthlyRegeneratingPatternType();

See Also

MonthlyRegeneratingPatternType Class | Aspose.Email.Exchange.Schema Namespace


MonthNamesType Enumeration

public enum MonthNamesType

Remarks

Members

Member Name | Description | Value
January |  | 0
February |  | 1
March |  | 2
April |  | 3
May |  | 4
June |  | 5
July |  | 6
August |  | 7
September |  | 8
October |  | 9
November |  | 10
December |  | 11

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


MovedCopiedEventType Class

For a list of all members of this type, see MovedCopiedEventType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseNotificationEventType
Aspose.Email.Exchange.Schema.BaseObjectChangedEventType
Aspose.Email.Exchange.Schema.MovedCopiedEventType

public class MovedCopiedEventType : BaseObjectChangedEventType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MovedCopiedEventType Members | Aspose.Email.Exchange.Schema Namespace


MovedCopiedEventType Members

MovedCopiedEventType overview

Public Instance Constructors

MovedCopiedEventType Constructor Initializes a new instance of the MovedCopiedEventType class.

Public Instance Properties

Item (inherited from BaseObjectChangedEventType)
Item1
OldParentFolderId
ParentFolderId (inherited from BaseObjectChangedEventType)
TimeStamp (inherited from BaseObjectChangedEventType)
Watermark (inherited from BaseNotificationEventType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MovedCopiedEventType Class | Aspose.Email.Exchange.Schema Namespace


MovedCopiedEventType Constructor

Initializes a new instance of the MovedCopiedEventType class.

public MovedCopiedEventType();

See Also

MovedCopiedEventType Class | Aspose.Email.Exchange.Schema Namespace


MovedCopiedEventType Properties

The properties of the MovedCopiedEventType class are listed below. For a complete list of MovedCopiedEventType class members, see the MovedCopiedEventType Members topic.

Public Instance Properties

Item (inherited from BaseObjectChangedEventType)
Item1
OldParentFolderId
ParentFolderId (inherited from BaseObjectChangedEventType)
TimeStamp (inherited from BaseObjectChangedEventType)
Watermark (inherited from BaseNotificationEventType)

See Also

MovedCopiedEventType Class | Aspose.Email.Exchange.Schema Namespace


Item1 Property

Aspose.Email

MovedCopiedEventType.Item1 Property

public object Item1 {get; set;}

Remarks

See Also

MovedCopiedEventType Class | Aspose.Email.Exchange.Schema Namespace


OldParentFolderId Property

Aspose.Email

MovedCopiedEventType.OldParentFolderId Property

public FolderIdType OldParentFolderId {get; set;}

Remarks

See Also

MovedCopiedEventType Class | Aspose.Email.Exchange.Schema Namespace


MoveFolderCompletedEventArgs Class

For a list of all members of this type, see MoveFolderCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.MoveFolderCompletedEventArgs

public class MoveFolderCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MoveFolderCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


MoveFolderCompletedEventArgs Members

MoveFolderCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

MoveFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


MoveFolderCompletedEventArgs Properties

The properties of the MoveFolderCompletedEventArgs class are listed below. For a complete list of MoveFolderCompletedEventArgs class members, see the MoveFolderCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

MoveFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

MoveFolderCompletedEventArgs.Result Property

public MoveFolderResponseType Result {get;}

Remarks

See Also

MoveFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


MoveFolderCompletedEventHandler Delegate

public delegate void MoveFolderCompletedEventHandler(
object sender,
MoveFolderCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


MoveFolderResponseType Class

For a list of all members of this type, see MoveFolderResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseResponseMessageType
Aspose.Email.Exchange.Schema.MoveFolderResponseType

public class MoveFolderResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MoveFolderResponseType Members | Aspose.Email.Exchange.Schema Namespace


MoveFolderResponseType Members

MoveFolderResponseType overview

Public Instance Constructors

MoveFolderResponseType Constructor Initializes a new instance of the MoveFolderResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MoveFolderResponseType Class | Aspose.Email.Exchange.Schema Namespace


MoveFolderResponseType Constructor

Initializes a new instance of the MoveFolderResponseType class.

public MoveFolderResponseType();

See Also

MoveFolderResponseType Class | Aspose.Email.Exchange.Schema Namespace


MoveFolderType Class

For a list of all members of this type, see MoveFolderType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.BaseMoveCopyFolderType
Aspose.Email.Exchange.Schema.MoveFolderType

public class MoveFolderType : BaseMoveCopyFolderType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MoveFolderType Members | Aspose.Email.Exchange.Schema Namespace


MoveFolderType Members

MoveFolderType overview

Public Instance Constructors

MoveFolderType Constructor Initializes a new instance of the MoveFolderType class.

Public Instance Properties

FolderIds (inherited from BaseMoveCopyFolderType)
ToFolderId (inherited from BaseMoveCopyFolderType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MoveFolderType Class | Aspose.Email.Exchange.Schema Namespace


MoveFolderType Constructor

Initializes a new instance of the MoveFolderType class.

public MoveFolderType();

See Also

MoveFolderType Class | Aspose.Email.Exchange.Schema Namespace


MoveItemCompletedEventArgs Class

For a list of all members of this type, see MoveItemCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.MoveItemCompletedEventArgs

public class MoveItemCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MoveItemCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


MoveItemCompletedEventArgs Members

MoveItemCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

MoveItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


MoveItemCompletedEventArgs Properties

The properties of the MoveItemCompletedEventArgs class are listed below. For a complete list of MoveItemCompletedEventArgs class members, see the MoveItemCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

MoveItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

MoveItemCompletedEventArgs.Result Property

public MoveItemResponseType Result {get;}

Remarks

See Also

MoveItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


MoveItemCompletedEventHandler Delegate

public delegate void MoveItemCompletedEventHandler(
object sender,
MoveItemCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


MoveItemResponseType Class

For a list of all members of this type, see MoveItemResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseResponseMessageType
Aspose.Email.Exchange.Schema.MoveItemResponseType

public class MoveItemResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MoveItemResponseType Members | Aspose.Email.Exchange.Schema Namespace


MoveItemResponseType Members

MoveItemResponseType overview

Public Instance Constructors

MoveItemResponseType Constructor Initializes a new instance of the MoveItemResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MoveItemResponseType Class | Aspose.Email.Exchange.Schema Namespace


MoveItemResponseType Constructor

Initializes a new instance of the MoveItemResponseType class.

public MoveItemResponseType();

See Also

MoveItemResponseType Class | Aspose.Email.Exchange.Schema Namespace


MoveItemType Class

For a list of all members of this type, see MoveItemType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.BaseMoveCopyItemType
Aspose.Email.Exchange.Schema.MoveItemType

public class MoveItemType : BaseMoveCopyItemType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MoveItemType Members | Aspose.Email.Exchange.Schema Namespace


MoveItemType Members

MoveItemType overview

Public Instance Constructors

MoveItemType Constructor Initializes a new instance of the MoveItemType class.

Public Instance Properties

ItemIds (inherited from BaseMoveCopyItemType)
ReturnNewItemIds (inherited from BaseMoveCopyItemType)
ReturnNewItemIdsSpecified (inherited from BaseMoveCopyItemType)
ToFolderId (inherited from BaseMoveCopyItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MoveItemType Class | Aspose.Email.Exchange.Schema Namespace


MoveItemType Constructor

Initializes a new instance of the MoveItemType class.

public MoveItemType();

See Also

MoveItemType Class | Aspose.Email.Exchange.Schema Namespace


MultipleOperandBooleanExpressionType Class

For a list of all members of this type, see MultipleOperandBooleanExpressionType Members.

System.Object
Aspose.Email.Exchange.Schema.SearchExpressionType
Aspose.Email.Exchange.Schema.MultipleOperandBooleanExpressionType
Aspose.Email.Exchange.Schema.AndType
Aspose.Email.Exchange.Schema.OrType

public abstract class MultipleOperandBooleanExpressionType : SearchExpressionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MultipleOperandBooleanExpressionType Members | Aspose.Email.Exchange.Schema Namespace


MultipleOperandBooleanExpressionType Members

MultipleOperandBooleanExpressionType overview

Public Instance Properties

Items

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

MultipleOperandBooleanExpressionType Constructor Initializes a new instance of the MultipleOperandBooleanExpressionType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MultipleOperandBooleanExpressionType Class | Aspose.Email.Exchange.Schema Namespace


MultipleOperandBooleanExpressionType Constructor

Initializes a new instance of the MultipleOperandBooleanExpressionType class.

protected MultipleOperandBooleanExpressionType();

See Also

MultipleOperandBooleanExpressionType Class | Aspose.Email.Exchange.Schema Namespace


MultipleOperandBooleanExpressionType Properties

The properties of the MultipleOperandBooleanExpressionType class are listed below. For a complete list of MultipleOperandBooleanExpressionType class members, see the MultipleOperandBooleanExpressionType Members topic.

Public Instance Properties

Items

See Also

MultipleOperandBooleanExpressionType Class | Aspose.Email.Exchange.Schema Namespace


Items Property

Aspose.Email

MultipleOperandBooleanExpressionType.Items Property

public SearchExpressionType[] Items {get; set;}

Remarks

See Also

MultipleOperandBooleanExpressionType Class | Aspose.Email.Exchange.Schema Namespace


NoEndRecurrenceRangeType Class

For a list of all members of this type, see NoEndRecurrenceRangeType Members.

System.Object
Aspose.Email.Exchange.Schema.RecurrenceRangeBaseType
Aspose.Email.Exchange.Schema.NoEndRecurrenceRangeType

public class NoEndRecurrenceRangeType : RecurrenceRangeBaseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

NoEndRecurrenceRangeType Members | Aspose.Email.Exchange.Schema Namespace


NoEndRecurrenceRangeType Members

NoEndRecurrenceRangeType overview

Public Instance Constructors

NoEndRecurrenceRangeType Constructor Initializes a new instance of the NoEndRecurrenceRangeType class.

Public Instance Properties

StartDate (inherited from RecurrenceRangeBaseType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NoEndRecurrenceRangeType Class | Aspose.Email.Exchange.Schema Namespace


NoEndRecurrenceRangeType Constructor

Initializes a new instance of the NoEndRecurrenceRangeType class.

public NoEndRecurrenceRangeType();

See Also

NoEndRecurrenceRangeType Class | Aspose.Email.Exchange.Schema Namespace


NonEmptyArrayOfAllItemsType Class

For a list of all members of this type, see NonEmptyArrayOfAllItemsType Members.

System.Object
Aspose.Email.Exchange.Schema.NonEmptyArrayOfAllItemsType

public class NonEmptyArrayOfAllItemsType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

NonEmptyArrayOfAllItemsType Members | Aspose.Email.Exchange.Schema Namespace


NonEmptyArrayOfAllItemsType Members

NonEmptyArrayOfAllItemsType overview

Public Instance Constructors

NonEmptyArrayOfAllItemsType Constructor Initializes a new instance of the NonEmptyArrayOfAllItemsType class.

Public Instance Properties

Items

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NonEmptyArrayOfAllItemsType Class | Aspose.Email.Exchange.Schema Namespace


NonEmptyArrayOfAllItemsType Constructor

Initializes a new instance of the NonEmptyArrayOfAllItemsType class.

public NonEmptyArrayOfAllItemsType();

See Also

NonEmptyArrayOfAllItemsType Class | Aspose.Email.Exchange.Schema Namespace


NonEmptyArrayOfAllItemsType Properties

The properties of the NonEmptyArrayOfAllItemsType class are listed below. For a complete list of NonEmptyArrayOfAllItemsType class members, see the NonEmptyArrayOfAllItemsType Members topic.

Public Instance Properties

Items

See Also

NonEmptyArrayOfAllItemsType Class | Aspose.Email.Exchange.Schema Namespace


Items Property

Aspose.Email

NonEmptyArrayOfAllItemsType.Items Property

public ItemType[] Items {get; set;}

Remarks

See Also

NonEmptyArrayOfAllItemsType Class | Aspose.Email.Exchange.Schema Namespace


NonEmptyArrayOfPropertyValuesType Class

For a list of all members of this type, see NonEmptyArrayOfPropertyValuesType Members.

System.Object
Aspose.Email.Exchange.Schema.NonEmptyArrayOfPropertyValuesType

public class NonEmptyArrayOfPropertyValuesType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

NonEmptyArrayOfPropertyValuesType Members | Aspose.Email.Exchange.Schema Namespace


NonEmptyArrayOfPropertyValuesType Members

NonEmptyArrayOfPropertyValuesType overview

Public Instance Constructors

NonEmptyArrayOfPropertyValuesType Constructor Initializes a new instance of the NonEmptyArrayOfPropertyValuesType class.

Public Instance Properties

Items

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NonEmptyArrayOfPropertyValuesType Class | Aspose.Email.Exchange.Schema Namespace


NonEmptyArrayOfPropertyValuesType Constructor

Initializes a new instance of the NonEmptyArrayOfPropertyValuesType class.

public NonEmptyArrayOfPropertyValuesType();

See Also

NonEmptyArrayOfPropertyValuesType Class | Aspose.Email.Exchange.Schema Namespace


NonEmptyArrayOfPropertyValuesType Properties

The properties of the NonEmptyArrayOfPropertyValuesType class are listed below. For a complete list of NonEmptyArrayOfPropertyValuesType class members, see the NonEmptyArrayOfPropertyValuesType Members topic.

Public Instance Properties

Items

See Also

NonEmptyArrayOfPropertyValuesType Class | Aspose.Email.Exchange.Schema Namespace


Items Property

Aspose.Email

NonEmptyArrayOfPropertyValuesType.Items Property

public string[] Items {get; set;}

Remarks

See Also

NonEmptyArrayOfPropertyValuesType Class | Aspose.Email.Exchange.Schema Namespace


NotificationEventTypeType Enumeration

public enum NotificationEventTypeType

Remarks

Members

Member Name | Description | Value
CopiedEvent |  | 0
CreatedEvent |  | 1
DeletedEvent |  | 2
ModifiedEvent |  | 3
MovedEvent |  | 4
NewMailEvent |  | 5
FreeBusyChangedEvent |  | 6

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


NotificationType Class

For a list of all members of this type, see NotificationType Members.

System.Object
Aspose.Email.Exchange.Schema.NotificationType

public class NotificationType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

NotificationType Members | Aspose.Email.Exchange.Schema Namespace


NotificationType Members

NotificationType overview

Public Instance Constructors

NotificationType Constructor Initializes a new instance of the NotificationType class.

Public Instance Properties

Items
ItemsElementName
MoreEvents
MoreEventsSpecified
PreviousWatermark
SubscriptionId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NotificationType Class | Aspose.Email.Exchange.Schema Namespace


NotificationType Constructor

Initializes a new instance of the NotificationType class.

public NotificationType();

See Also

NotificationType Class | Aspose.Email.Exchange.Schema Namespace


NotificationType Properties

The properties of the NotificationType class are listed below. For a complete list of NotificationType class members, see the NotificationType Members topic.

Public Instance Properties

Items
ItemsElementName
MoreEvents
MoreEventsSpecified
PreviousWatermark
SubscriptionId

See Also

NotificationType Class | Aspose.Email.Exchange.Schema Namespace


Items Property

Aspose.Email

NotificationType.Items Property

public BaseNotificationEventType[] Items {get; set;}

Remarks

See Also

NotificationType Class | Aspose.Email.Exchange.Schema Namespace


ItemsElementName Property

Aspose.Email

NotificationType.ItemsElementName Property

public ItemsChoiceType[] ItemsElementName {get; set;}

Remarks

See Also

NotificationType Class | Aspose.Email.Exchange.Schema Namespace


MoreEvents Property

Aspose.Email

NotificationType.MoreEvents Property

public bool MoreEvents {get; set;}

Remarks

See Also

NotificationType Class | Aspose.Email.Exchange.Schema Namespace


MoreEventsSpecified Property

Aspose.Email

NotificationType.MoreEventsSpecified Property

public bool MoreEventsSpecified {get; set;}

Remarks

See Also

NotificationType Class | Aspose.Email.Exchange.Schema Namespace


PreviousWatermark Property

Aspose.Email

NotificationType.PreviousWatermark Property

public string PreviousWatermark {get; set;}

Remarks

See Also

NotificationType Class | Aspose.Email.Exchange.Schema Namespace


SubscriptionId Property

Aspose.Email

NotificationType.SubscriptionId Property

public string SubscriptionId {get; set;}

Remarks

See Also

NotificationType Class | Aspose.Email.Exchange.Schema Namespace


NotType Class

For a list of all members of this type, see NotType Members.

System.Object
Aspose.Email.Exchange.Schema.SearchExpressionType
Aspose.Email.Exchange.Schema.NotType

public class NotType : SearchExpressionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

NotType Members | Aspose.Email.Exchange.Schema Namespace


NotType Members

NotType overview

Public Instance Constructors

NotType Constructor Initializes a new instance of the NotType class.

Public Instance Properties

Item

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NotType Class | Aspose.Email.Exchange.Schema Namespace


NotType Constructor

Initializes a new instance of the NotType class.

public NotType();

See Also

NotType Class | Aspose.Email.Exchange.Schema Namespace


NotType Properties

The properties of the NotType class are listed below. For a complete list of NotType class members, see the NotType Members topic.

Public Instance Properties

Item

See Also

NotType Class | Aspose.Email.Exchange.Schema Namespace


Item Property

Aspose.Email

NotType.Item Property

public SearchExpressionType Item {get; set;}

Remarks

See Also

NotType Class | Aspose.Email.Exchange.Schema Namespace


NumberedRecurrenceRangeType Class

For a list of all members of this type, see NumberedRecurrenceRangeType Members.

System.Object
Aspose.Email.Exchange.Schema.RecurrenceRangeBaseType
Aspose.Email.Exchange.Schema.NumberedRecurrenceRangeType

public class NumberedRecurrenceRangeType : RecurrenceRangeBaseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

NumberedRecurrenceRangeType Members | Aspose.Email.Exchange.Schema Namespace


NumberedRecurrenceRangeType Members

NumberedRecurrenceRangeType overview

Public Instance Constructors

NumberedRecurrenceRangeType Constructor Initializes a new instance of the NumberedRecurrenceRangeType class.

Public Instance Properties

NumberOfOccurrences
StartDate (inherited from RecurrenceRangeBaseType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NumberedRecurrenceRangeType Class | Aspose.Email.Exchange.Schema Namespace


NumberedRecurrenceRangeType Constructor

Initializes a new instance of the NumberedRecurrenceRangeType class.

public NumberedRecurrenceRangeType();

See Also

NumberedRecurrenceRangeType Class | Aspose.Email.Exchange.Schema Namespace


NumberedRecurrenceRangeType Properties

The properties of the NumberedRecurrenceRangeType class are listed below. For a complete list of NumberedRecurrenceRangeType class members, see the NumberedRecurrenceRangeType Members topic.

Public Instance Properties

NumberOfOccurrences
StartDate (inherited from RecurrenceRangeBaseType)

See Also

NumberedRecurrenceRangeType Class | Aspose.Email.Exchange.Schema Namespace


NumberOfOccurrences Property

Aspose.Email

NumberedRecurrenceRangeType.NumberOfOccurrences Property

public int NumberOfOccurrences {get; set;}

Remarks

See Also

NumberedRecurrenceRangeType Class | Aspose.Email.Exchange.Schema Namespace


OccurrenceInfoType Class

For a list of all members of this type, see OccurrenceInfoType Members.

System.Object
Aspose.Email.Exchange.Schema.OccurrenceInfoType

public class OccurrenceInfoType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

OccurrenceInfoType Members | Aspose.Email.Exchange.Schema Namespace


OccurrenceInfoType Members

OccurrenceInfoType overview

Public Instance Constructors

OccurrenceInfoType Constructor Initializes a new instance of the OccurrenceInfoType class.

Public Instance Properties

End
ItemId
OriginalStart
Start

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OccurrenceInfoType Class | Aspose.Email.Exchange.Schema Namespace


OccurrenceInfoType Constructor

Initializes a new instance of the OccurrenceInfoType class.

public OccurrenceInfoType();

See Also

OccurrenceInfoType Class | Aspose.Email.Exchange.Schema Namespace


OccurrenceInfoType Properties

The properties of the OccurrenceInfoType class are listed below. For a complete list of OccurrenceInfoType class members, see the OccurrenceInfoType Members topic.

Public Instance Properties

End
ItemId
OriginalStart
Start

See Also

OccurrenceInfoType Class | Aspose.Email.Exchange.Schema Namespace


End Property

Aspose.Email

OccurrenceInfoType.End Property

public DateTime End {get; set;}

Remarks

See Also

OccurrenceInfoType Class | Aspose.Email.Exchange.Schema Namespace


ItemId Property

Aspose.Email

OccurrenceInfoType.ItemId Property

public ItemIdType ItemId {get; set;}

Remarks

See Also

OccurrenceInfoType Class | Aspose.Email.Exchange.Schema Namespace


OriginalStart Property

Aspose.Email

OccurrenceInfoType.OriginalStart Property

public DateTime OriginalStart {get; set;}

Remarks

See Also

OccurrenceInfoType Class | Aspose.Email.Exchange.Schema Namespace


Start Property

Aspose.Email

OccurrenceInfoType.Start Property

public DateTime Start {get; set;}

Remarks

See Also

OccurrenceInfoType Class | Aspose.Email.Exchange.Schema Namespace


OccurrenceItemIdType Class

For a list of all members of this type, see OccurrenceItemIdType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseItemIdType
Aspose.Email.Exchange.Schema.OccurrenceItemIdType

public class OccurrenceItemIdType : BaseItemIdType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

OccurrenceItemIdType Members | Aspose.Email.Exchange.Schema Namespace


OccurrenceItemIdType Members

OccurrenceItemIdType overview

Public Instance Constructors

OccurrenceItemIdType Constructor Initializes a new instance of the OccurrenceItemIdType class.

Public Instance Properties

ChangeKey
InstanceIndex
RecurringMasterId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OccurrenceItemIdType Class | Aspose.Email.Exchange.Schema Namespace


OccurrenceItemIdType Constructor

Initializes a new instance of the OccurrenceItemIdType class.

public OccurrenceItemIdType();

See Also

OccurrenceItemIdType Class | Aspose.Email.Exchange.Schema Namespace


OccurrenceItemIdType Properties

The properties of the OccurrenceItemIdType class are listed below. For a complete list of OccurrenceItemIdType class members, see the OccurrenceItemIdType Members topic.

Public Instance Properties

ChangeKey
InstanceIndex
RecurringMasterId

See Also

OccurrenceItemIdType Class | Aspose.Email.Exchange.Schema Namespace


ChangeKey Property

Aspose.Email

OccurrenceItemIdType.ChangeKey Property

public string ChangeKey {get; set;}

Remarks

See Also

OccurrenceItemIdType Class | Aspose.Email.Exchange.Schema Namespace


InstanceIndex Property

Aspose.Email

OccurrenceItemIdType.InstanceIndex Property

public int InstanceIndex {get; set;}

Remarks

See Also

OccurrenceItemIdType Class | Aspose.Email.Exchange.Schema Namespace


RecurringMasterId Property

Aspose.Email

OccurrenceItemIdType.RecurringMasterId Property

public string RecurringMasterId {get; set;}

Remarks

See Also

OccurrenceItemIdType Class | Aspose.Email.Exchange.Schema Namespace


OofState Enumeration

public enum OofState

Remarks

Members

Member Name | Description | Value
Disabled |  | 0
Enabled |  | 1
Scheduled |  | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


OrType Class

For a list of all members of this type, see OrType Members.

System.Object
Aspose.Email.Exchange.Schema.SearchExpressionType
Aspose.Email.Exchange.Schema.MultipleOperandBooleanExpressionType
Aspose.Email.Exchange.Schema.OrType

public class OrType : MultipleOperandBooleanExpressionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

OrType Members | Aspose.Email.Exchange.Schema Namespace


OrType Members

OrType overview

Public Instance Constructors

OrType Constructor Initializes a new instance of the OrType class.

Public Instance Properties

Items (inherited from MultipleOperandBooleanExpressionType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OrType Class | Aspose.Email.Exchange.Schema Namespace


OrType Constructor

Initializes a new instance of the OrType class.

public OrType();

See Also

OrType Class | Aspose.Email.Exchange.Schema Namespace


OutOfOfficeMailTip Class

For a list of all members of this type, see OutOfOfficeMailTip Members.

System.Object
Aspose.Email.Exchange.Schema.OutOfOfficeMailTip

public class OutOfOfficeMailTip

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

OutOfOfficeMailTip Members | Aspose.Email.Exchange.Schema Namespace


OutOfOfficeMailTip Members

OutOfOfficeMailTip overview

Public Instance Constructors

OutOfOfficeMailTip Constructor Initializes a new instance of the OutOfOfficeMailTip class.

Public Instance Properties

Duration
ReplyBody

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OutOfOfficeMailTip Class | Aspose.Email.Exchange.Schema Namespace


OutOfOfficeMailTip Constructor

Initializes a new instance of the OutOfOfficeMailTip class.

public OutOfOfficeMailTip();

See Also

OutOfOfficeMailTip Class | Aspose.Email.Exchange.Schema Namespace


OutOfOfficeMailTip Properties

The properties of the OutOfOfficeMailTip class are listed below. For a complete list of OutOfOfficeMailTip class members, see the OutOfOfficeMailTip Members topic.

Public Instance Properties

Duration
ReplyBody

See Also

OutOfOfficeMailTip Class | Aspose.Email.Exchange.Schema Namespace


Duration Property

Aspose.Email

OutOfOfficeMailTip.Duration Property

public Duration Duration {get; set;}

Remarks

See Also

OutOfOfficeMailTip Class | Aspose.Email.Exchange.Schema Namespace


ReplyBody Property

Aspose.Email

OutOfOfficeMailTip.ReplyBody Property

public ReplyBody ReplyBody {get; set;}

Remarks

See Also

OutOfOfficeMailTip Class | Aspose.Email.Exchange.Schema Namespace


PathToExceptionFieldType Class

For a list of all members of this type, see PathToExceptionFieldType Members.

System.Object
Aspose.Email.Exchange.Schema.BasePathToElementType
Aspose.Email.Exchange.Schema.PathToExceptionFieldType

public class PathToExceptionFieldType : BasePathToElementType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PathToExceptionFieldType Members | Aspose.Email.Exchange.Schema Namespace


PathToExceptionFieldType Members

PathToExceptionFieldType overview

Public Instance Constructors

PathToExceptionFieldType Constructor Initializes a new instance of the PathToExceptionFieldType class.

Public Instance Properties

FieldURI

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PathToExceptionFieldType Class | Aspose.Email.Exchange.Schema Namespace


PathToExceptionFieldType Constructor

Initializes a new instance of the PathToExceptionFieldType class.

public PathToExceptionFieldType();

See Also

PathToExceptionFieldType Class | Aspose.Email.Exchange.Schema Namespace


PathToExceptionFieldType Properties

The properties of the PathToExceptionFieldType class are listed below. For a complete list of PathToExceptionFieldType class members, see the PathToExceptionFieldType Members topic.

Public Instance Properties

FieldURI

See Also

PathToExceptionFieldType Class | Aspose.Email.Exchange.Schema Namespace


FieldURI Property

Aspose.Email

PathToExceptionFieldType.FieldURI Property

public ExceptionPropertyURIType FieldURI {get; set;}

Remarks

See Also

PathToExceptionFieldType Class | Aspose.Email.Exchange.Schema Namespace


PathToExtendedFieldType Class

For a list of all members of this type, see PathToExtendedFieldType Members.

System.Object
Aspose.Email.Exchange.Schema.BasePathToElementType
Aspose.Email.Exchange.Schema.PathToExtendedFieldType

public class PathToExtendedFieldType : BasePathToElementType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PathToExtendedFieldType Members | Aspose.Email.Exchange.Schema Namespace


PathToExtendedFieldType Members

PathToExtendedFieldType overview

Public Instance Constructors

PathToExtendedFieldType Constructor Initializes a new instance of the PathToExtendedFieldType class.

Public Instance Properties

DistinguishedPropertySetId
DistinguishedPropertySetIdSpecified
PropertyId
PropertyIdSpecified
PropertyName
PropertySetId
PropertyTag
PropertyType

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PathToExtendedFieldType Class | Aspose.Email.Exchange.Schema Namespace


PathToExtendedFieldType Constructor

Initializes a new instance of the PathToExtendedFieldType class.

public PathToExtendedFieldType();

See Also

PathToExtendedFieldType Class | Aspose.Email.Exchange.Schema Namespace


PathToExtendedFieldType Properties

The properties of the PathToExtendedFieldType class are listed below. For a complete list of PathToExtendedFieldType class members, see the PathToExtendedFieldType Members topic.

Public Instance Properties

DistinguishedPropertySetId
DistinguishedPropertySetIdSpecified
PropertyId
PropertyIdSpecified
PropertyName
PropertySetId
PropertyTag
PropertyType

See Also

PathToExtendedFieldType Class | Aspose.Email.Exchange.Schema Namespace


DistinguishedPropertySetId Property

Aspose.Email

PathToExtendedFieldType.DistinguishedPropertySetId Property

public DistinguishedPropertySetType DistinguishedPropertySetId {get; set;}

Remarks

See Also

PathToExtendedFieldType Class | Aspose.Email.Exchange.Schema Namespace


DistinguishedPropertySetIdSpecified Property

Aspose.Email

PathToExtendedFieldType.DistinguishedPropertySetIdSpecified Property

public bool DistinguishedPropertySetIdSpecified {get; set;}

Remarks

See Also

PathToExtendedFieldType Class | Aspose.Email.Exchange.Schema Namespace


PropertyId Property

Aspose.Email

PathToExtendedFieldType.PropertyId Property

public int PropertyId {get; set;}

Remarks

See Also

PathToExtendedFieldType Class | Aspose.Email.Exchange.Schema Namespace


PropertyIdSpecified Property

Aspose.Email

PathToExtendedFieldType.PropertyIdSpecified Property

public bool PropertyIdSpecified {get; set;}

Remarks

See Also

PathToExtendedFieldType Class | Aspose.Email.Exchange.Schema Namespace


PropertyName Property

Aspose.Email

PathToExtendedFieldType.PropertyName Property

public string PropertyName {get; set;}

Remarks

See Also

PathToExtendedFieldType Class | Aspose.Email.Exchange.Schema Namespace


PropertySetId Property

Aspose.Email

PathToExtendedFieldType.PropertySetId Property

public string PropertySetId {get; set;}

Remarks

See Also

PathToExtendedFieldType Class | Aspose.Email.Exchange.Schema Namespace


PropertyTag Property

Aspose.Email

PathToExtendedFieldType.PropertyTag Property

public string PropertyTag {get; set;}

Remarks

See Also

PathToExtendedFieldType Class | Aspose.Email.Exchange.Schema Namespace


PropertyType Property

Aspose.Email

PathToExtendedFieldType.PropertyType Property

public MapiPropertyTypeType PropertyType {get; set;}

Remarks

See Also

PathToExtendedFieldType Class | Aspose.Email.Exchange.Schema Namespace


PathToIndexedFieldType Class

For a list of all members of this type, see PathToIndexedFieldType Members.

System.Object
Aspose.Email.Exchange.Schema.BasePathToElementType
Aspose.Email.Exchange.Schema.PathToIndexedFieldType

public class PathToIndexedFieldType : BasePathToElementType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PathToIndexedFieldType Members | Aspose.Email.Exchange.Schema Namespace


PathToIndexedFieldType Members

PathToIndexedFieldType overview

Public Instance Constructors

PathToIndexedFieldType Constructor Initializes a new instance of the PathToIndexedFieldType class.

Public Instance Properties

FieldIndex
FieldURI

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PathToIndexedFieldType Class | Aspose.Email.Exchange.Schema Namespace


PathToIndexedFieldType Constructor

Initializes a new instance of the PathToIndexedFieldType class.

public PathToIndexedFieldType();

See Also

PathToIndexedFieldType Class | Aspose.Email.Exchange.Schema Namespace


PathToIndexedFieldType Properties

The properties of the PathToIndexedFieldType class are listed below. For a complete list of PathToIndexedFieldType class members, see the PathToIndexedFieldType Members topic.

Public Instance Properties

FieldIndex
FieldURI

See Also

PathToIndexedFieldType Class | Aspose.Email.Exchange.Schema Namespace


FieldIndex Property

Aspose.Email

PathToIndexedFieldType.FieldIndex Property

public string FieldIndex {get; set;}

Remarks

See Also

PathToIndexedFieldType Class | Aspose.Email.Exchange.Schema Namespace


FieldURI Property

Aspose.Email

PathToIndexedFieldType.FieldURI Property

public DictionaryURIType FieldURI {get; set;}

Remarks

See Also

PathToIndexedFieldType Class | Aspose.Email.Exchange.Schema Namespace


PathToUnindexedFieldType Class

For a list of all members of this type, see PathToUnindexedFieldType Members.

System.Object
Aspose.Email.Exchange.Schema.BasePathToElementType
Aspose.Email.Exchange.Schema.PathToUnindexedFieldType

public class PathToUnindexedFieldType : BasePathToElementType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PathToUnindexedFieldType Members | Aspose.Email.Exchange.Schema Namespace


PathToUnindexedFieldType Members

PathToUnindexedFieldType overview

Public Instance Constructors

PathToUnindexedFieldType Constructor Initializes a new instance of the PathToUnindexedFieldType class.

Public Instance Properties

FieldURI

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PathToUnindexedFieldType Class | Aspose.Email.Exchange.Schema Namespace


PathToUnindexedFieldType Constructor

Initializes a new instance of the PathToUnindexedFieldType class.

public PathToUnindexedFieldType();

See Also

PathToUnindexedFieldType Class | Aspose.Email.Exchange.Schema Namespace


PathToUnindexedFieldType Properties

The properties of the PathToUnindexedFieldType class are listed below. For a complete list of PathToUnindexedFieldType class members, see the PathToUnindexedFieldType Members topic.

Public Instance Properties

FieldURI

See Also

PathToUnindexedFieldType Class | Aspose.Email.Exchange.Schema Namespace


FieldURI Property

Aspose.Email

PathToUnindexedFieldType.FieldURI Property

public UnindexedFieldURIType FieldURI {get; set;}

Remarks

See Also

PathToUnindexedFieldType Class | Aspose.Email.Exchange.Schema Namespace


PeriodType Class

For a list of all members of this type, see PeriodType Members.

System.Object
Aspose.Email.Exchange.Schema.PeriodType

public class PeriodType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PeriodType Members | Aspose.Email.Exchange.Schema Namespace


PeriodType Members

PeriodType overview

Public Instance Constructors

PeriodType Constructor Initializes a new instance of the PeriodType class.

Public Instance Properties

Bias
Id
Name

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PeriodType Class | Aspose.Email.Exchange.Schema Namespace


PeriodType Constructor

Initializes a new instance of the PeriodType class.

public PeriodType();

See Also

PeriodType Class | Aspose.Email.Exchange.Schema Namespace


PeriodType Properties

The properties of the PeriodType class are listed below. For a complete list of PeriodType class members, see the PeriodType Members topic.

Public Instance Properties

Bias
Id
Name

See Also

PeriodType Class | Aspose.Email.Exchange.Schema Namespace


Bias Property

Aspose.Email

PeriodType.Bias Property

public string Bias {get; set;}

Remarks

See Also

PeriodType Class | Aspose.Email.Exchange.Schema Namespace


Id Property

Aspose.Email

PeriodType.Id Property

public string Id {get; set;}

Remarks

See Also

PeriodType Class | Aspose.Email.Exchange.Schema Namespace


Name Property

Aspose.Email

PeriodType.Name Property

public string Name {get; set;}

Remarks

See Also

PeriodType Class | Aspose.Email.Exchange.Schema Namespace


PermissionActionType Enumeration

public enum PermissionActionType

Remarks

Members

Member Name | Description | Value
None |  | 0
Owned |  | 1
All |  | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


PermissionLevelType Enumeration

public enum PermissionLevelType

Remarks

Members

Member Name | Description | Value
None |  | 0
Owner |  | 1
PublishingEditor |  | 2
Editor |  | 3
PublishingAuthor |  | 4
Author |  | 5
NoneditingAuthor |  | 6
Reviewer |  | 7
Contributor |  | 8
Custom |  | 9

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


PermissionReadAccessType Enumeration

public enum PermissionReadAccessType

Remarks

Members

Member Name | Description | Value
None |  | 0
FullDetails |  | 1

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


PermissionSetType Class

For a list of all members of this type, see PermissionSetType Members.

System.Object
Aspose.Email.Exchange.Schema.PermissionSetType

public class PermissionSetType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PermissionSetType Members | Aspose.Email.Exchange.Schema Namespace


PermissionSetType Members

PermissionSetType overview

Public Instance Constructors

PermissionSetType Constructor Initializes a new instance of the PermissionSetType class.

Public Instance Properties

Permissions
UnknownEntries

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PermissionSetType Class | Aspose.Email.Exchange.Schema Namespace


PermissionSetType Constructor

Initializes a new instance of the PermissionSetType class.

public PermissionSetType();

See Also

PermissionSetType Class | Aspose.Email.Exchange.Schema Namespace


PermissionSetType Properties

The properties of the PermissionSetType class are listed below. For a complete list of PermissionSetType class members, see the PermissionSetType Members topic.

Public Instance Properties

Permissions
UnknownEntries

See Also

PermissionSetType Class | Aspose.Email.Exchange.Schema Namespace


Permissions Property

Aspose.Email

PermissionSetType.Permissions Property

public PermissionType[] Permissions {get; set;}

Remarks

See Also

PermissionSetType Class | Aspose.Email.Exchange.Schema Namespace


UnknownEntries Property

Aspose.Email

PermissionSetType.UnknownEntries Property

public string[] UnknownEntries {get; set;}

Remarks

See Also

PermissionSetType Class | Aspose.Email.Exchange.Schema Namespace


PermissionType Class

For a list of all members of this type, see PermissionType Members.

System.Object
Aspose.Email.Exchange.Schema.BasePermissionType
Aspose.Email.Exchange.Schema.PermissionType

public class PermissionType : BasePermissionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PermissionType Members | Aspose.Email.Exchange.Schema Namespace


PermissionType Members

PermissionType overview

Public Instance Constructors

PermissionType Constructor Initializes a new instance of the PermissionType class.

Public Instance Properties

CanCreateItems (inherited from BasePermissionType)
CanCreateItemsSpecified (inherited from BasePermissionType)
CanCreateSubFolders (inherited from BasePermissionType)
CanCreateSubFoldersSpecified (inherited from BasePermissionType)
DeleteItems (inherited from BasePermissionType)
DeleteItemsSpecified (inherited from BasePermissionType)
EditItems (inherited from BasePermissionType)
EditItemsSpecified (inherited from BasePermissionType)
IsFolderContact (inherited from BasePermissionType)
IsFolderContactSpecified (inherited from BasePermissionType)
IsFolderOwner (inherited from BasePermissionType)
IsFolderOwnerSpecified (inherited from BasePermissionType)
IsFolderVisible (inherited from BasePermissionType)
IsFolderVisibleSpecified (inherited from BasePermissionType)
PermissionLevel
ReadItems
ReadItemsSpecified
UserId (inherited from BasePermissionType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PermissionType Class | Aspose.Email.Exchange.Schema Namespace


PermissionType Constructor

Initializes a new instance of the PermissionType class.

public PermissionType();

See Also

PermissionType Class | Aspose.Email.Exchange.Schema Namespace


PermissionType Properties

The properties of the PermissionType class are listed below. For a complete list of PermissionType class members, see the PermissionType Members topic.

Public Instance Properties

CanCreateItems (inherited from BasePermissionType)
CanCreateItemsSpecified (inherited from BasePermissionType)
CanCreateSubFolders (inherited from BasePermissionType)
CanCreateSubFoldersSpecified (inherited from BasePermissionType)
DeleteItems (inherited from BasePermissionType)
DeleteItemsSpecified (inherited from BasePermissionType)
EditItems (inherited from BasePermissionType)
EditItemsSpecified (inherited from BasePermissionType)
IsFolderContact (inherited from BasePermissionType)
IsFolderContactSpecified (inherited from BasePermissionType)
IsFolderOwner (inherited from BasePermissionType)
IsFolderOwnerSpecified (inherited from BasePermissionType)
IsFolderVisible (inherited from BasePermissionType)
IsFolderVisibleSpecified (inherited from BasePermissionType)
PermissionLevel
ReadItems
ReadItemsSpecified
UserId (inherited from BasePermissionType)

See Also

PermissionType Class | Aspose.Email.Exchange.Schema Namespace


PermissionLevel Property

Aspose.Email

PermissionType.PermissionLevel Property

public PermissionLevelType PermissionLevel {get; set;}

Remarks

See Also

PermissionType Class | Aspose.Email.Exchange.Schema Namespace


ReadItems Property

Aspose.Email

PermissionType.ReadItems Property

public PermissionReadAccessType ReadItems {get; set;}

Remarks

See Also

PermissionType Class | Aspose.Email.Exchange.Schema Namespace


ReadItemsSpecified Property

Aspose.Email

PermissionType.ReadItemsSpecified Property

public bool ReadItemsSpecified {get; set;}

Remarks

See Also

PermissionType Class | Aspose.Email.Exchange.Schema Namespace


PhoneCallIdType Class

For a list of all members of this type, see PhoneCallIdType Members.

System.Object
Aspose.Email.Exchange.Schema.PhoneCallIdType

public class PhoneCallIdType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PhoneCallIdType Members | Aspose.Email.Exchange.Schema Namespace


PhoneCallIdType Members

PhoneCallIdType overview

Public Instance Constructors

PhoneCallIdType Constructor Initializes a new instance of the PhoneCallIdType class.

Public Instance Properties

Id

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PhoneCallIdType Class | Aspose.Email.Exchange.Schema Namespace


PhoneCallIdType Constructor

Initializes a new instance of the PhoneCallIdType class.

public PhoneCallIdType();

See Also

PhoneCallIdType Class | Aspose.Email.Exchange.Schema Namespace


PhoneCallIdType Properties

The properties of the PhoneCallIdType class are listed below. For a complete list of PhoneCallIdType class members, see the PhoneCallIdType Members topic.

Public Instance Properties

Id

See Also

PhoneCallIdType Class | Aspose.Email.Exchange.Schema Namespace


Id Property

Aspose.Email

PhoneCallIdType.Id Property

public string Id {get; set;}

Remarks

See Also

PhoneCallIdType Class | Aspose.Email.Exchange.Schema Namespace


PhoneCallInformationType Class

For a list of all members of this type, see PhoneCallInformationType Members.

System.Object
Aspose.Email.Exchange.Schema.PhoneCallInformationType

public class PhoneCallInformationType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PhoneCallInformationType Members | Aspose.Email.Exchange.Schema Namespace


PhoneCallInformationType Members

PhoneCallInformationType overview

Public Instance Constructors

PhoneCallInformationType Constructor Initializes a new instance of the PhoneCallInformationType class.

Public Instance Properties

ConnectionFailureCause
PhoneCallState
SIPResponseCode
SIPResponseCodeSpecified
SIPResponseText

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PhoneCallInformationType Class | Aspose.Email.Exchange.Schema Namespace


PhoneCallInformationType Constructor

Initializes a new instance of the PhoneCallInformationType class.

public PhoneCallInformationType();

See Also

PhoneCallInformationType Class | Aspose.Email.Exchange.Schema Namespace


PhoneCallInformationType Properties

The properties of the PhoneCallInformationType class are listed below. For a complete list of PhoneCallInformationType class members, see the PhoneCallInformationType Members topic.

Public Instance Properties

ConnectionFailureCause
PhoneCallState
SIPResponseCode
SIPResponseCodeSpecified
SIPResponseText

See Also

PhoneCallInformationType Class | Aspose.Email.Exchange.Schema Namespace


ConnectionFailureCause Property

Aspose.Email

PhoneCallInformationType.ConnectionFailureCause Property

public ConnectionFailureCauseType ConnectionFailureCause {get; set;}

Remarks

See Also

PhoneCallInformationType Class | Aspose.Email.Exchange.Schema Namespace


PhoneCallState Property

Aspose.Email

PhoneCallInformationType.PhoneCallState Property

public PhoneCallStateType PhoneCallState {get; set;}

Remarks

See Also

PhoneCallInformationType Class | Aspose.Email.Exchange.Schema Namespace


SIPResponseCode Property

Aspose.Email

PhoneCallInformationType.SIPResponseCode Property

public int SIPResponseCode {get; set;}

Remarks

See Also

PhoneCallInformationType Class | Aspose.Email.Exchange.Schema Namespace


SIPResponseCodeSpecified Property

Aspose.Email

PhoneCallInformationType.SIPResponseCodeSpecified Property

public bool SIPResponseCodeSpecified {get; set;}

Remarks

See Also

PhoneCallInformationType Class | Aspose.Email.Exchange.Schema Namespace


SIPResponseText Property

Aspose.Email

PhoneCallInformationType.SIPResponseText Property

public string SIPResponseText {get; set;}

Remarks

See Also

PhoneCallInformationType Class | Aspose.Email.Exchange.Schema Namespace


PhoneCallStateType Enumeration

public enum PhoneCallStateType

Remarks

Members

Member Name | Description | Value
Idle |  | 0
Connecting |  | 1
Alerted |  | 2
Connected |  | 3
Disconnected |  | 4
Incoming |  | 5
Transferring |  | 6
Forwarding |  | 7

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


PhoneNumberDictionaryEntryType Class

For a list of all members of this type, see PhoneNumberDictionaryEntryType Members.

System.Object
Aspose.Email.Exchange.Schema.PhoneNumberDictionaryEntryType

public class PhoneNumberDictionaryEntryType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PhoneNumberDictionaryEntryType Members | Aspose.Email.Exchange.Schema Namespace


PhoneNumberDictionaryEntryType Members

PhoneNumberDictionaryEntryType overview

Public Instance Constructors

PhoneNumberDictionaryEntryType Constructor Initializes a new instance of the PhoneNumberDictionaryEntryType class.

Public Instance Properties

Key
Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PhoneNumberDictionaryEntryType Class | Aspose.Email.Exchange.Schema Namespace


PhoneNumberDictionaryEntryType Constructor

Initializes a new instance of the PhoneNumberDictionaryEntryType class.

public PhoneNumberDictionaryEntryType();

See Also

PhoneNumberDictionaryEntryType Class | Aspose.Email.Exchange.Schema Namespace


PhoneNumberDictionaryEntryType Properties

The properties of the PhoneNumberDictionaryEntryType class are listed below. For a complete list of PhoneNumberDictionaryEntryType class members, see the PhoneNumberDictionaryEntryType Members topic.

Public Instance Properties

Key
Value

See Also

PhoneNumberDictionaryEntryType Class | Aspose.Email.Exchange.Schema Namespace


Key Property

Aspose.Email

PhoneNumberDictionaryEntryType.Key Property

public PhoneNumberKeyType Key {get; set;}

Remarks

See Also

PhoneNumberDictionaryEntryType Class | Aspose.Email.Exchange.Schema Namespace


Value Property

Aspose.Email

PhoneNumberDictionaryEntryType.Value Property

public string Value {get; set;}

Remarks

See Also

PhoneNumberDictionaryEntryType Class | Aspose.Email.Exchange.Schema Namespace


PhoneNumberKeyType Enumeration

public enum PhoneNumberKeyType

Remarks

Members

Member Name | Description | Value
AssistantPhone |  | 0
BusinessFax |  | 1
BusinessPhone |  | 2
BusinessPhone2 |  | 3
Callback |  | 4
CarPhone |  | 5
CompanyMainPhone |  | 6
HomeFax |  | 7
HomePhone |  | 8
HomePhone2 |  | 9
Isdn |  | 10
MobilePhone |  | 11
OtherFax |  | 12
OtherTelephone |  | 13
Pager |  | 14
PrimaryPhone |  | 15
RadioPhone |  | 16
Telex |  | 17
TtyTddPhone |  | 18

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


PhysicalAddressDictionaryEntryType Class

For a list of all members of this type, see PhysicalAddressDictionaryEntryType Members.

System.Object
Aspose.Email.Exchange.Schema.PhysicalAddressDictionaryEntryType

public class PhysicalAddressDictionaryEntryType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PhysicalAddressDictionaryEntryType Members | Aspose.Email.Exchange.Schema Namespace


PhysicalAddressDictionaryEntryType Members

PhysicalAddressDictionaryEntryType overview

Public Instance Constructors

PhysicalAddressDictionaryEntryType Constructor Initializes a new instance of the PhysicalAddressDictionaryEntryType class.

Public Instance Properties

City
CountryOrRegion
Key
PostalCode
State
Street

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PhysicalAddressDictionaryEntryType Class | Aspose.Email.Exchange.Schema Namespace


PhysicalAddressDictionaryEntryType Constructor

Initializes a new instance of the PhysicalAddressDictionaryEntryType class.

public PhysicalAddressDictionaryEntryType();

See Also

PhysicalAddressDictionaryEntryType Class | Aspose.Email.Exchange.Schema Namespace


PhysicalAddressDictionaryEntryType Properties

The properties of the PhysicalAddressDictionaryEntryType class are listed below. For a complete list of PhysicalAddressDictionaryEntryType class members, see the PhysicalAddressDictionaryEntryType Members topic.

Public Instance Properties

City
CountryOrRegion
Key
PostalCode
State
Street

See Also

PhysicalAddressDictionaryEntryType Class | Aspose.Email.Exchange.Schema Namespace


City Property

Aspose.Email

PhysicalAddressDictionaryEntryType.City Property

public string City {get; set;}

Remarks

See Also

PhysicalAddressDictionaryEntryType Class | Aspose.Email.Exchange.Schema Namespace


CountryOrRegion Property

Aspose.Email

PhysicalAddressDictionaryEntryType.CountryOrRegion Property

public string CountryOrRegion {get; set;}

Remarks

See Also

PhysicalAddressDictionaryEntryType Class | Aspose.Email.Exchange.Schema Namespace


Key Property

Aspose.Email

PhysicalAddressDictionaryEntryType.Key Property

public PhysicalAddressKeyType Key {get; set;}

Remarks

See Also

PhysicalAddressDictionaryEntryType Class | Aspose.Email.Exchange.Schema Namespace


PostalCode Property

Aspose.Email

PhysicalAddressDictionaryEntryType.PostalCode Property

public string PostalCode {get; set;}

Remarks

See Also

PhysicalAddressDictionaryEntryType Class | Aspose.Email.Exchange.Schema Namespace


State Property

Aspose.Email

PhysicalAddressDictionaryEntryType.State Property

public string State {get; set;}

Remarks

See Also

PhysicalAddressDictionaryEntryType Class | Aspose.Email.Exchange.Schema Namespace


Street Property

Aspose.Email

PhysicalAddressDictionaryEntryType.Street Property

public string Street {get; set;}

Remarks

See Also

PhysicalAddressDictionaryEntryType Class | Aspose.Email.Exchange.Schema Namespace


PhysicalAddressIndexType Enumeration

public enum PhysicalAddressIndexType

Remarks

Members

Member Name | Description | Value
None |  | 0
Business |  | 1
Home |  | 2
Other |  | 3

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


PhysicalAddressKeyType Enumeration

public enum PhysicalAddressKeyType

Remarks

Members

Member Name | Description | Value
Business |  | 0
Home |  | 1
Other |  | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


PlayOnPhoneCompletedEventArgs Class

For a list of all members of this type, see PlayOnPhoneCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.PlayOnPhoneCompletedEventArgs

public class PlayOnPhoneCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PlayOnPhoneCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


PlayOnPhoneCompletedEventArgs Members

PlayOnPhoneCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

PlayOnPhoneCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


PlayOnPhoneCompletedEventArgs Properties

The properties of the PlayOnPhoneCompletedEventArgs class are listed below. For a complete list of PlayOnPhoneCompletedEventArgs class members, see the PlayOnPhoneCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

PlayOnPhoneCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

PlayOnPhoneCompletedEventArgs.Result Property

public PlayOnPhoneResponseMessageType Result {get;}

Remarks

See Also

PlayOnPhoneCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


PlayOnPhoneCompletedEventHandler Delegate

public delegate void PlayOnPhoneCompletedEventHandler(
object sender,
PlayOnPhoneCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


PlayOnPhoneResponseMessageType Class

For a list of all members of this type, see PlayOnPhoneResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ResponseMessageType
Aspose.Email.Exchange.Schema.PlayOnPhoneResponseMessageType

public class PlayOnPhoneResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PlayOnPhoneResponseMessageType Members | Aspose.Email.Exchange.Schema Namespace


PlayOnPhoneResponseMessageType Members

PlayOnPhoneResponseMessageType overview

Public Instance Constructors

PlayOnPhoneResponseMessageType Constructor Initializes a new instance of the PlayOnPhoneResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
PhoneCallId
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PlayOnPhoneResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


PlayOnPhoneResponseMessageType Constructor

Initializes a new instance of the PlayOnPhoneResponseMessageType class.

public PlayOnPhoneResponseMessageType();

See Also

PlayOnPhoneResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


PlayOnPhoneResponseMessageType Properties

The properties of the PlayOnPhoneResponseMessageType class are listed below. For a complete list of PlayOnPhoneResponseMessageType class members, see the PlayOnPhoneResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
PhoneCallId
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

PlayOnPhoneResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


PhoneCallId Property

Aspose.Email

PlayOnPhoneResponseMessageType.PhoneCallId Property

public PhoneCallIdType PhoneCallId {get; set;}

Remarks

See Also

PlayOnPhoneResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


PlayOnPhoneType Class

For a list of all members of this type, see PlayOnPhoneType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.PlayOnPhoneType

public class PlayOnPhoneType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PlayOnPhoneType Members | Aspose.Email.Exchange.Schema Namespace


PlayOnPhoneType Members

PlayOnPhoneType overview

Public Instance Constructors

PlayOnPhoneType Constructor Initializes a new instance of the PlayOnPhoneType class.

Public Instance Properties

DialString
ItemId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PlayOnPhoneType Class | Aspose.Email.Exchange.Schema Namespace


PlayOnPhoneType Constructor

Initializes a new instance of the PlayOnPhoneType class.

public PlayOnPhoneType();

See Also

PlayOnPhoneType Class | Aspose.Email.Exchange.Schema Namespace


PlayOnPhoneType Properties

The properties of the PlayOnPhoneType class are listed below. For a complete list of PlayOnPhoneType class members, see the PlayOnPhoneType Members topic.

Public Instance Properties

DialString
ItemId

See Also

PlayOnPhoneType Class | Aspose.Email.Exchange.Schema Namespace


DialString Property

Aspose.Email

PlayOnPhoneType.DialString Property

public string DialString {get; set;}

Remarks

See Also

PlayOnPhoneType Class | Aspose.Email.Exchange.Schema Namespace


ItemId Property

Aspose.Email

PlayOnPhoneType.ItemId Property

public ItemIdType ItemId {get; set;}

Remarks

See Also

PlayOnPhoneType Class | Aspose.Email.Exchange.Schema Namespace


PostItemType Class

For a list of all members of this type, see PostItemType Members.

System.Object
Aspose.Email.Exchange.Schema.ItemType
Aspose.Email.Exchange.Schema.PostItemType

public class PostItemType : ItemType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PostItemType Members | Aspose.Email.Exchange.Schema Namespace


PostItemType Members

PostItemType overview

Public Instance Constructors

PostItemType Constructor Initializes a new instance of the PostItemType class.

Public Instance Properties

Attachments (inherited from ItemType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
ConversationId (inherited from ItemType)
ConversationIndex
ConversationTopic
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
From
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead
IsReadSpecified
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
ParentFolderId (inherited from ItemType)
PostedTime
PostedTimeSpecified
References
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ResponseObjects (inherited from ItemType)
Sender
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
Subject (inherited from ItemType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PostItemType Class | Aspose.Email.Exchange.Schema Namespace


PostItemType Constructor

Initializes a new instance of the PostItemType class.

public PostItemType();

See Also

PostItemType Class | Aspose.Email.Exchange.Schema Namespace


PostItemType Properties

The properties of the PostItemType class are listed below. For a complete list of PostItemType class members, see the PostItemType Members topic.

Public Instance Properties

Attachments (inherited from ItemType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
ConversationId (inherited from ItemType)
ConversationIndex
ConversationTopic
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
From
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead
IsReadSpecified
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
ParentFolderId (inherited from ItemType)
PostedTime
PostedTimeSpecified
References
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ResponseObjects (inherited from ItemType)
Sender
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
Subject (inherited from ItemType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

See Also

PostItemType Class | Aspose.Email.Exchange.Schema Namespace


ConversationIndex Property

Aspose.Email

PostItemType.ConversationIndex Property

public byte[] ConversationIndex {get; set;}

Remarks

See Also

PostItemType Class | Aspose.Email.Exchange.Schema Namespace


ConversationTopic Property

Aspose.Email

PostItemType.ConversationTopic Property

public string ConversationTopic {get; set;}

Remarks

See Also

PostItemType Class | Aspose.Email.Exchange.Schema Namespace


From Property

Aspose.Email

PostItemType.From Property

public SingleRecipientType From {get; set;}

Remarks

See Also

PostItemType Class | Aspose.Email.Exchange.Schema Namespace


InternetMessageId Property

Aspose.Email

PostItemType.InternetMessageId Property

public string InternetMessageId {get; set;}

Remarks

See Also

PostItemType Class | Aspose.Email.Exchange.Schema Namespace


IsRead Property

Aspose.Email

PostItemType.IsRead Property

public bool IsRead {get; set;}

Remarks

See Also

PostItemType Class | Aspose.Email.Exchange.Schema Namespace


IsReadSpecified Property

Aspose.Email

PostItemType.IsReadSpecified Property

public bool IsReadSpecified {get; set;}

Remarks

See Also

PostItemType Class | Aspose.Email.Exchange.Schema Namespace


PostedTime Property

Aspose.Email

PostItemType.PostedTime Property

public DateTime PostedTime {get; set;}

Remarks

See Also

PostItemType Class | Aspose.Email.Exchange.Schema Namespace


PostedTimeSpecified Property

Aspose.Email

PostItemType.PostedTimeSpecified Property

public bool PostedTimeSpecified {get; set;}

Remarks

See Also

PostItemType Class | Aspose.Email.Exchange.Schema Namespace


References Property

Aspose.Email

PostItemType.References Property

public string References {get; set;}

Remarks

See Also

PostItemType Class | Aspose.Email.Exchange.Schema Namespace


Sender Property

Aspose.Email

PostItemType.Sender Property

public SingleRecipientType Sender {get; set;}

Remarks

See Also

PostItemType Class | Aspose.Email.Exchange.Schema Namespace


PostReplyItemBaseType Class

For a list of all members of this type, see PostReplyItemBaseType Members.

System.Object
Aspose.Email.Exchange.Schema.ItemType
Aspose.Email.Exchange.Schema.MessageType
Aspose.Email.Exchange.Schema.ResponseObjectCoreType
Aspose.Email.Exchange.Schema.ResponseObjectType
Aspose.Email.Exchange.Schema.PostReplyItemBaseType
Aspose.Email.Exchange.Schema.PostReplyItemType

public class PostReplyItemBaseType : ResponseObjectType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PostReplyItemBaseType Members | Aspose.Email.Exchange.Schema Namespace


PostReplyItemBaseType Members

PostReplyItemBaseType overview

Public Instance Constructors

PostReplyItemBaseType Constructor Initializes a new instance of the PostReplyItemBaseType class.

Public Instance Properties

Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
From (inherited from MessageType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
ObjectName (inherited from ResponseObjectType)
ParentFolderId (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
ReferenceItemId (inherited from ResponseObjectCoreType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
Subject (inherited from ItemType)
ToRecipients (inherited from MessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PostReplyItemBaseType Class | Aspose.Email.Exchange.Schema Namespace


PostReplyItemBaseType Constructor

Initializes a new instance of the PostReplyItemBaseType class.

public PostReplyItemBaseType();

See Also

PostReplyItemBaseType Class | Aspose.Email.Exchange.Schema Namespace


PostReplyItemType Class

For a list of all members of this type, see PostReplyItemType Members.

System.Object
Aspose.Email.Exchange.Schema.ItemType
Aspose.Email.Exchange.Schema.MessageType
Aspose.Email.Exchange.Schema.ResponseObjectCoreType
Aspose.Email.Exchange.Schema.ResponseObjectType
Aspose.Email.Exchange.Schema.PostReplyItemBaseType
Aspose.Email.Exchange.Schema.PostReplyItemType

public class PostReplyItemType : PostReplyItemBaseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PostReplyItemType Members | Aspose.Email.Exchange.Schema Namespace


PostReplyItemType Members

PostReplyItemType overview

Public Instance Constructors

PostReplyItemType Constructor Initializes a new instance of the PostReplyItemType class.

Public Instance Properties

Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
From (inherited from MessageType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
NewBodyContent
ObjectName (inherited from ResponseObjectType)
ParentFolderId (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
ReferenceItemId (inherited from ResponseObjectCoreType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
Subject (inherited from ItemType)
ToRecipients (inherited from MessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PostReplyItemType Class | Aspose.Email.Exchange.Schema Namespace


PostReplyItemType Constructor

Initializes a new instance of the PostReplyItemType class.

public PostReplyItemType();

See Also

PostReplyItemType Class | Aspose.Email.Exchange.Schema Namespace


PostReplyItemType Properties

The properties of the PostReplyItemType class are listed below. For a complete list of PostReplyItemType class members, see the PostReplyItemType Members topic.

Public Instance Properties

Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
From (inherited from MessageType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
NewBodyContent
ObjectName (inherited from ResponseObjectType)
ParentFolderId (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
ReferenceItemId (inherited from ResponseObjectCoreType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
Subject (inherited from ItemType)
ToRecipients (inherited from MessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

See Also

PostReplyItemType Class | Aspose.Email.Exchange.Schema Namespace


NewBodyContent Property

Aspose.Email

PostReplyItemType.NewBodyContent Property

public BodyType NewBodyContent {get; set;}

Remarks

See Also

PostReplyItemType Class | Aspose.Email.Exchange.Schema Namespace


ProtectionRuleActionKindType Enumeration

public enum ProtectionRuleActionKindType

Remarks

Members

Member Name | Description | Value
RightsProtectMessage |  | 0

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


ProtectionRuleActionType Class

For a list of all members of this type, see ProtectionRuleActionType Members.

System.Object
Aspose.Email.Exchange.Schema.ProtectionRuleActionType

public class ProtectionRuleActionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ProtectionRuleActionType Members | Aspose.Email.Exchange.Schema Namespace


ProtectionRuleActionType Members

ProtectionRuleActionType overview

Public Instance Constructors

ProtectionRuleActionType Constructor Initializes a new instance of the ProtectionRuleActionType class.

Public Instance Properties

Argument
Name

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProtectionRuleActionType Class | Aspose.Email.Exchange.Schema Namespace


ProtectionRuleActionType Constructor

Initializes a new instance of the ProtectionRuleActionType class.

public ProtectionRuleActionType();

See Also

ProtectionRuleActionType Class | Aspose.Email.Exchange.Schema Namespace


ProtectionRuleActionType Properties

The properties of the ProtectionRuleActionType class are listed below. For a complete list of ProtectionRuleActionType class members, see the ProtectionRuleActionType Members topic.

Public Instance Properties

Argument
Name

See Also

ProtectionRuleActionType Class | Aspose.Email.Exchange.Schema Namespace


Argument Property

Aspose.Email

ProtectionRuleActionType.Argument Property

public ProtectionRuleArgumentType[] Argument {get; set;}

Remarks

See Also

ProtectionRuleActionType Class | Aspose.Email.Exchange.Schema Namespace


Name Property

Aspose.Email

ProtectionRuleActionType.Name Property

public ProtectionRuleActionKindType Name {get; set;}

Remarks

See Also

ProtectionRuleActionType Class | Aspose.Email.Exchange.Schema Namespace


ProtectionRuleAndType Class

For a list of all members of this type, see ProtectionRuleAndType Members.

System.Object
Aspose.Email.Exchange.Schema.ProtectionRuleAndType

public class ProtectionRuleAndType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ProtectionRuleAndType Members | Aspose.Email.Exchange.Schema Namespace


ProtectionRuleAndType Members

ProtectionRuleAndType overview

Public Instance Constructors

ProtectionRuleAndType Constructor Initializes a new instance of the ProtectionRuleAndType class.

Public Instance Properties

Items
ItemsElementName

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProtectionRuleAndType Class | Aspose.Email.Exchange.Schema Namespace


ProtectionRuleAndType Constructor

Initializes a new instance of the ProtectionRuleAndType class.

public ProtectionRuleAndType();

See Also

ProtectionRuleAndType Class | Aspose.Email.Exchange.Schema Namespace


ProtectionRuleAndType Properties

The properties of the ProtectionRuleAndType class are listed below. For a complete list of ProtectionRuleAndType class members, see the ProtectionRuleAndType Members topic.

Public Instance Properties

Items
ItemsElementName

See Also

ProtectionRuleAndType Class | Aspose.Email.Exchange.Schema Namespace


Items Property

Aspose.Email

ProtectionRuleAndType.Items Property

public object[] Items {get; set;}

Remarks

See Also

ProtectionRuleAndType Class | Aspose.Email.Exchange.Schema Namespace


ItemsElementName Property

Aspose.Email

ProtectionRuleAndType.ItemsElementName Property

public ItemsChoiceType3[] ItemsElementName {get; set;}

Remarks

See Also

ProtectionRuleAndType Class | Aspose.Email.Exchange.Schema Namespace


ProtectionRuleArgumentType Class

For a list of all members of this type, see ProtectionRuleArgumentType Members.

System.Object
Aspose.Email.Exchange.Schema.ProtectionRuleArgumentType

public class ProtectionRuleArgumentType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ProtectionRuleArgumentType Members | Aspose.Email.Exchange.Schema Namespace


ProtectionRuleArgumentType Members

ProtectionRuleArgumentType overview

Public Instance Constructors

ProtectionRuleArgumentType Constructor Initializes a new instance of the ProtectionRuleArgumentType class.

Public Instance Properties

Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProtectionRuleArgumentType Class | Aspose.Email.Exchange.Schema Namespace


ProtectionRuleArgumentType Constructor

Initializes a new instance of the ProtectionRuleArgumentType class.

public ProtectionRuleArgumentType();

See Also

ProtectionRuleArgumentType Class | Aspose.Email.Exchange.Schema Namespace


ProtectionRuleArgumentType Properties

The properties of the ProtectionRuleArgumentType class are listed below. For a complete list of ProtectionRuleArgumentType class members, see the ProtectionRuleArgumentType Members topic.

Public Instance Properties

Value

See Also

ProtectionRuleArgumentType Class | Aspose.Email.Exchange.Schema Namespace


Value Property

Aspose.Email

ProtectionRuleArgumentType.Value Property

public string Value {get; set;}

Remarks

See Also

ProtectionRuleArgumentType Class | Aspose.Email.Exchange.Schema Namespace


ProtectionRuleConditionType Class

For a list of all members of this type, see ProtectionRuleConditionType Members.

System.Object
Aspose.Email.Exchange.Schema.ProtectionRuleConditionType

public class ProtectionRuleConditionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ProtectionRuleConditionType Members | Aspose.Email.Exchange.Schema Namespace


ProtectionRuleConditionType Members

ProtectionRuleConditionType overview

Public Instance Constructors

ProtectionRuleConditionType Constructor Initializes a new instance of the ProtectionRuleConditionType class.

Public Instance Properties

Item
ItemElementName

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProtectionRuleConditionType Class | Aspose.Email.Exchange.Schema Namespace


ProtectionRuleConditionType Constructor

Initializes a new instance of the ProtectionRuleConditionType class.

public ProtectionRuleConditionType();

See Also

ProtectionRuleConditionType Class | Aspose.Email.Exchange.Schema Namespace


ProtectionRuleConditionType Properties

The properties of the ProtectionRuleConditionType class are listed below. For a complete list of ProtectionRuleConditionType class members, see the ProtectionRuleConditionType Members topic.

Public Instance Properties

Item
ItemElementName

See Also

ProtectionRuleConditionType Class | Aspose.Email.Exchange.Schema Namespace


Item Property

Aspose.Email

ProtectionRuleConditionType.Item Property

public object Item {get; set;}

Remarks

See Also

ProtectionRuleConditionType Class | Aspose.Email.Exchange.Schema Namespace


ItemElementName Property

Aspose.Email

ProtectionRuleConditionType.ItemElementName Property

public ItemChoiceType1 ItemElementName {get; set;}

Remarks

See Also

ProtectionRuleConditionType Class | Aspose.Email.Exchange.Schema Namespace


ProtectionRuleRecipientIsType Class

For a list of all members of this type, see ProtectionRuleRecipientIsType Members.

System.Object
Aspose.Email.Exchange.Schema.ProtectionRuleRecipientIsType

public class ProtectionRuleRecipientIsType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ProtectionRuleRecipientIsType Members | Aspose.Email.Exchange.Schema Namespace


ProtectionRuleRecipientIsType Members

ProtectionRuleRecipientIsType overview

Public Instance Constructors

ProtectionRuleRecipientIsType Constructor Initializes a new instance of the ProtectionRuleRecipientIsType class.

Public Instance Properties

Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProtectionRuleRecipientIsType Class | Aspose.Email.Exchange.Schema Namespace


ProtectionRuleRecipientIsType Constructor

Initializes a new instance of the ProtectionRuleRecipientIsType class.

public ProtectionRuleRecipientIsType();

See Also

ProtectionRuleRecipientIsType Class | Aspose.Email.Exchange.Schema Namespace


ProtectionRuleRecipientIsType Properties

The properties of the ProtectionRuleRecipientIsType class are listed below. For a complete list of ProtectionRuleRecipientIsType class members, see the ProtectionRuleRecipientIsType Members topic.

Public Instance Properties

Value

See Also

ProtectionRuleRecipientIsType Class | Aspose.Email.Exchange.Schema Namespace


Value Property

Aspose.Email

ProtectionRuleRecipientIsType.Value Property

public string[] Value {get; set;}

Remarks

See Also

ProtectionRuleRecipientIsType Class | Aspose.Email.Exchange.Schema Namespace


ProtectionRuleSenderDepartmentsType Class

For a list of all members of this type, see ProtectionRuleSenderDepartmentsType Members.

System.Object
Aspose.Email.Exchange.Schema.ProtectionRuleSenderDepartmentsType

public class ProtectionRuleSenderDepartmentsType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ProtectionRuleSenderDepartmentsType Members | Aspose.Email.Exchange.Schema Namespace


ProtectionRuleSenderDepartmentsType Members

ProtectionRuleSenderDepartmentsType overview

Public Instance Constructors

ProtectionRuleSenderDepartmentsType Constructor Initializes a new instance of the ProtectionRuleSenderDepartmentsType class.

Public Instance Properties

Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProtectionRuleSenderDepartmentsType Class | Aspose.Email.Exchange.Schema Namespace


ProtectionRuleSenderDepartmentsType Constructor

Initializes a new instance of the ProtectionRuleSenderDepartmentsType class.

public ProtectionRuleSenderDepartmentsType();

See Also

ProtectionRuleSenderDepartmentsType Class | Aspose.Email.Exchange.Schema Namespace


ProtectionRuleSenderDepartmentsType Properties

The properties of the ProtectionRuleSenderDepartmentsType class are listed below. For a complete list of ProtectionRuleSenderDepartmentsType class members, see the ProtectionRuleSenderDepartmentsType Members topic.

Public Instance Properties

Value

See Also

ProtectionRuleSenderDepartmentsType Class | Aspose.Email.Exchange.Schema Namespace


Value Property

Aspose.Email

ProtectionRuleSenderDepartmentsType.Value Property

public string[] Value {get; set;}

Remarks

See Also

ProtectionRuleSenderDepartmentsType Class | Aspose.Email.Exchange.Schema Namespace


ProtectionRulesServiceConfiguration Class

For a list of all members of this type, see ProtectionRulesServiceConfiguration Members.

System.Object
Aspose.Email.Exchange.Schema.ServiceConfiguration
Aspose.Email.Exchange.Schema.ProtectionRulesServiceConfiguration

public class ProtectionRulesServiceConfiguration : ServiceConfiguration

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ProtectionRulesServiceConfiguration Members | Aspose.Email.Exchange.Schema Namespace


ProtectionRulesServiceConfiguration Members

ProtectionRulesServiceConfiguration overview

Public Instance Constructors

ProtectionRulesServiceConfiguration Constructor Initializes a new instance of the ProtectionRulesServiceConfiguration class.

Public Instance Properties

InternalDomains
RefreshInterval
Rules

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProtectionRulesServiceConfiguration Class | Aspose.Email.Exchange.Schema Namespace


ProtectionRulesServiceConfiguration Constructor

Initializes a new instance of the ProtectionRulesServiceConfiguration class.

public ProtectionRulesServiceConfiguration();

See Also

ProtectionRulesServiceConfiguration Class | Aspose.Email.Exchange.Schema Namespace


ProtectionRulesServiceConfiguration Properties

The properties of the ProtectionRulesServiceConfiguration class are listed below. For a complete list of ProtectionRulesServiceConfiguration class members, see the ProtectionRulesServiceConfiguration Members topic.

Public Instance Properties

InternalDomains
RefreshInterval
Rules

See Also

ProtectionRulesServiceConfiguration Class | Aspose.Email.Exchange.Schema Namespace


InternalDomains Property

Aspose.Email

ProtectionRulesServiceConfiguration.InternalDomains Property

public SmtpDomain[] InternalDomains {get; set;}

Remarks

See Also

ProtectionRulesServiceConfiguration Class | Aspose.Email.Exchange.Schema Namespace


RefreshInterval Property

Aspose.Email

ProtectionRulesServiceConfiguration.RefreshInterval Property

public int RefreshInterval {get; set;}

Remarks

See Also

ProtectionRulesServiceConfiguration Class | Aspose.Email.Exchange.Schema Namespace


Rules Property

Aspose.Email

ProtectionRulesServiceConfiguration.Rules Property

public ProtectionRuleType[] Rules {get; set;}

Remarks

See Also

ProtectionRulesServiceConfiguration Class | Aspose.Email.Exchange.Schema Namespace


ProtectionRuleType Class

For a list of all members of this type, see ProtectionRuleType Members.

System.Object
Aspose.Email.Exchange.Schema.ProtectionRuleType

public class ProtectionRuleType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ProtectionRuleType Members | Aspose.Email.Exchange.Schema Namespace


ProtectionRuleType Members

ProtectionRuleType overview

Public Instance Constructors

ProtectionRuleType Constructor Initializes a new instance of the ProtectionRuleType class.

Public Instance Properties

Action
Condition
Name
Priority
UserOverridable

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProtectionRuleType Class | Aspose.Email.Exchange.Schema Namespace


ProtectionRuleType Constructor

Initializes a new instance of the ProtectionRuleType class.

public ProtectionRuleType();

See Also

ProtectionRuleType Class | Aspose.Email.Exchange.Schema Namespace


ProtectionRuleType Properties

The properties of the ProtectionRuleType class are listed below. For a complete list of ProtectionRuleType class members, see the ProtectionRuleType Members topic.

Public Instance Properties

Action
Condition
Name
Priority
UserOverridable

See Also

ProtectionRuleType Class | Aspose.Email.Exchange.Schema Namespace


Action Property

Aspose.Email

ProtectionRuleType.Action Property

public ProtectionRuleActionType Action {get; set;}

Remarks

See Also

ProtectionRuleType Class | Aspose.Email.Exchange.Schema Namespace


Condition Property

Aspose.Email

ProtectionRuleType.Condition Property

public ProtectionRuleConditionType Condition {get; set;}

Remarks

See Also

ProtectionRuleType Class | Aspose.Email.Exchange.Schema Namespace


Name Property

Aspose.Email

ProtectionRuleType.Name Property

public string Name {get; set;}

Remarks

See Also

ProtectionRuleType Class | Aspose.Email.Exchange.Schema Namespace


Priority Property

Aspose.Email

ProtectionRuleType.Priority Property

public int Priority {get; set;}

Remarks

See Also

ProtectionRuleType Class | Aspose.Email.Exchange.Schema Namespace


UserOverridable Property

Aspose.Email

ProtectionRuleType.UserOverridable Property

public bool UserOverridable {get; set;}

Remarks

See Also

ProtectionRuleType Class | Aspose.Email.Exchange.Schema Namespace


PullSubscriptionRequestType Class

For a list of all members of this type, see PullSubscriptionRequestType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseSubscriptionRequestType
Aspose.Email.Exchange.Schema.PullSubscriptionRequestType

public class PullSubscriptionRequestType : BaseSubscriptionRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PullSubscriptionRequestType Members | Aspose.Email.Exchange.Schema Namespace


PullSubscriptionRequestType Members

PullSubscriptionRequestType overview

Public Instance Constructors

PullSubscriptionRequestType Constructor Initializes a new instance of the PullSubscriptionRequestType class.

Public Instance Properties

EventTypes (inherited from BaseSubscriptionRequestType) |
FolderIds (inherited from BaseSubscriptionRequestType) |
SubscribeToAllFolders (inherited from BaseSubscriptionRequestType) |
SubscribeToAllFoldersSpecified (inherited from BaseSubscriptionRequestType) |
Timeout | The Timeout property gets or sets the duration that a subscription can remain idle without a GetEvents request from the client. The Timeout property returns an integer that represents the number of minutes that a subscription can remain idle without a GetEvents request from the client. The possible values for this property are 1 to 1440, inclusive.
Watermark (inherited from BaseSubscriptionRequestType) |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PullSubscriptionRequestType Class | Aspose.Email.Exchange.Schema Namespace


PullSubscriptionRequestType Constructor

Initializes a new instance of the PullSubscriptionRequestType class.

public PullSubscriptionRequestType();

See Also

PullSubscriptionRequestType Class | Aspose.Email.Exchange.Schema Namespace


PullSubscriptionRequestType Properties

The properties of the PullSubscriptionRequestType class are listed below. For a complete list of PullSubscriptionRequestType class members, see the PullSubscriptionRequestType Members topic.

Public Instance Properties

EventTypes (inherited from BaseSubscriptionRequestType) |
FolderIds (inherited from BaseSubscriptionRequestType) |
SubscribeToAllFolders (inherited from BaseSubscriptionRequestType) |
SubscribeToAllFoldersSpecified (inherited from BaseSubscriptionRequestType) |
Timeout | The Timeout property gets or sets the duration that a subscription can remain idle without a GetEvents request from the client. The Timeout property returns an integer that represents the number of minutes that a subscription can remain idle without a GetEvents request from the client. The possible values for this property are 1 to 1440, inclusive.
Watermark (inherited from BaseSubscriptionRequestType) |

See Also

PullSubscriptionRequestType Class | Aspose.Email.Exchange.Schema Namespace


Timeout Property

Aspose.Email

PullSubscriptionRequestType.Timeout Property

The Timeout property gets or sets the duration that a subscription can remain idle without a GetEvents request from the client. The Timeout property returns an integer that represents the number of minutes that a subscription can remain idle without a GetEvents request from the client. The possible values for this property are 1 to 1440, inclusive.

public int Timeout {get; set;}

See Also

PullSubscriptionRequestType Class | Aspose.Email.Exchange.Schema Namespace


PushSubscriptionRequestType Class

For a list of all members of this type, see PushSubscriptionRequestType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseSubscriptionRequestType
Aspose.Email.Exchange.Schema.PushSubscriptionRequestType

public class PushSubscriptionRequestType : BaseSubscriptionRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PushSubscriptionRequestType Members | Aspose.Email.Exchange.Schema Namespace


PushSubscriptionRequestType Members

PushSubscriptionRequestType overview

Public Instance Constructors

PushSubscriptionRequestType Constructor Initializes a new instance of the PushSubscriptionRequestType class.

Public Instance Properties

EventTypes (inherited from BaseSubscriptionRequestType)
FolderIds (inherited from BaseSubscriptionRequestType)
StatusFrequency
SubscribeToAllFolders (inherited from BaseSubscriptionRequestType)
SubscribeToAllFoldersSpecified (inherited from BaseSubscriptionRequestType)
URL
Watermark (inherited from BaseSubscriptionRequestType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PushSubscriptionRequestType Class | Aspose.Email.Exchange.Schema Namespace


PushSubscriptionRequestType Constructor

Initializes a new instance of the PushSubscriptionRequestType class.

public PushSubscriptionRequestType();

See Also

PushSubscriptionRequestType Class | Aspose.Email.Exchange.Schema Namespace


PushSubscriptionRequestType Properties

The properties of the PushSubscriptionRequestType class are listed below. For a complete list of PushSubscriptionRequestType class members, see the PushSubscriptionRequestType Members topic.

Public Instance Properties

EventTypes (inherited from BaseSubscriptionRequestType)
FolderIds (inherited from BaseSubscriptionRequestType)
StatusFrequency
SubscribeToAllFolders (inherited from BaseSubscriptionRequestType)
SubscribeToAllFoldersSpecified (inherited from BaseSubscriptionRequestType)
URL
Watermark (inherited from BaseSubscriptionRequestType)

See Also

PushSubscriptionRequestType Class | Aspose.Email.Exchange.Schema Namespace


StatusFrequency Property

Aspose.Email

PushSubscriptionRequestType.StatusFrequency Property

public int StatusFrequency {get; set;}

Remarks

See Also

PushSubscriptionRequestType Class | Aspose.Email.Exchange.Schema Namespace


URL Property

Aspose.Email

PushSubscriptionRequestType.URL Property

public string URL {get; set;}

Remarks

See Also

PushSubscriptionRequestType Class | Aspose.Email.Exchange.Schema Namespace


RecipientTrackingEventType Class

For a list of all members of this type, see RecipientTrackingEventType Members.

System.Object
Aspose.Email.Exchange.Schema.RecipientTrackingEventType

public class RecipientTrackingEventType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RecipientTrackingEventType Members | Aspose.Email.Exchange.Schema Namespace


RecipientTrackingEventType Members

RecipientTrackingEventType overview

Public Instance Constructors

RecipientTrackingEventType Constructor Initializes a new instance of the RecipientTrackingEventType class.

Public Instance Properties

BccRecipient
BccRecipientSpecified
Date
DeliveryStatus
EventData
EventDescription
HiddenRecipient
HiddenRecipientSpecified
InternalId
Properties
Recipient
RootAddress
Server
UniquePathId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RecipientTrackingEventType Class | Aspose.Email.Exchange.Schema Namespace


RecipientTrackingEventType Constructor

Initializes a new instance of the RecipientTrackingEventType class.

public RecipientTrackingEventType();

See Also

RecipientTrackingEventType Class | Aspose.Email.Exchange.Schema Namespace


RecipientTrackingEventType Properties

The properties of the RecipientTrackingEventType class are listed below. For a complete list of RecipientTrackingEventType class members, see the RecipientTrackingEventType Members topic.

Public Instance Properties

BccRecipient
BccRecipientSpecified
Date
DeliveryStatus
EventData
EventDescription
HiddenRecipient
HiddenRecipientSpecified
InternalId
Properties
Recipient
RootAddress
Server
UniquePathId

See Also

RecipientTrackingEventType Class | Aspose.Email.Exchange.Schema Namespace


BccRecipient Property

Aspose.Email

RecipientTrackingEventType.BccRecipient Property

public bool BccRecipient {get; set;}

Remarks

See Also

RecipientTrackingEventType Class | Aspose.Email.Exchange.Schema Namespace


BccRecipientSpecified Property

Aspose.Email

RecipientTrackingEventType.BccRecipientSpecified Property

public bool BccRecipientSpecified {get; set;}

Remarks

See Also

RecipientTrackingEventType Class | Aspose.Email.Exchange.Schema Namespace


Date Property

Aspose.Email

RecipientTrackingEventType.Date Property

public DateTime Date {get; set;}

Remarks

See Also

RecipientTrackingEventType Class | Aspose.Email.Exchange.Schema Namespace


DeliveryStatus Property

Aspose.Email

RecipientTrackingEventType.DeliveryStatus Property

public string DeliveryStatus {get; set;}

Remarks

See Also

RecipientTrackingEventType Class | Aspose.Email.Exchange.Schema Namespace


EventData Property

Aspose.Email

RecipientTrackingEventType.EventData Property

public string[] EventData {get; set;}

Remarks

See Also

RecipientTrackingEventType Class | Aspose.Email.Exchange.Schema Namespace


EventDescription Property

Aspose.Email

RecipientTrackingEventType.EventDescription Property

public string EventDescription {get; set;}

Remarks

See Also

RecipientTrackingEventType Class | Aspose.Email.Exchange.Schema Namespace


HiddenRecipient Property

Aspose.Email

RecipientTrackingEventType.HiddenRecipient Property

public bool HiddenRecipient {get; set;}

Remarks

See Also

RecipientTrackingEventType Class | Aspose.Email.Exchange.Schema Namespace


HiddenRecipientSpecified Property

Aspose.Email

RecipientTrackingEventType.HiddenRecipientSpecified Property

public bool HiddenRecipientSpecified {get; set;}

Remarks

See Also

RecipientTrackingEventType Class | Aspose.Email.Exchange.Schema Namespace


InternalId Property

Aspose.Email

RecipientTrackingEventType.InternalId Property

public string InternalId {get; set;}

Remarks

See Also

RecipientTrackingEventType Class | Aspose.Email.Exchange.Schema Namespace


Properties Property

Aspose.Email

RecipientTrackingEventType.Properties Property

public TrackingPropertyType[] Properties {get; set;}

Remarks

See Also

RecipientTrackingEventType Class | Aspose.Email.Exchange.Schema Namespace


Recipient Property

Aspose.Email

RecipientTrackingEventType.Recipient Property

public EmailAddressType Recipient {get; set;}

Remarks

See Also

RecipientTrackingEventType Class | Aspose.Email.Exchange.Schema Namespace


RootAddress Property

Aspose.Email

RecipientTrackingEventType.RootAddress Property

public string RootAddress {get; set;}

Remarks

See Also

RecipientTrackingEventType Class | Aspose.Email.Exchange.Schema Namespace


Server Property

Aspose.Email

RecipientTrackingEventType.Server Property

public string Server {get; set;}

Remarks

See Also

RecipientTrackingEventType Class | Aspose.Email.Exchange.Schema Namespace


UniquePathId Property

Aspose.Email

RecipientTrackingEventType.UniquePathId Property

public string UniquePathId {get; set;}

Remarks

See Also

RecipientTrackingEventType Class | Aspose.Email.Exchange.Schema Namespace


RecurrencePatternBaseType Class

Class is the abstract base class for all recurrence patterns.

For a list of all members of this type, see RecurrencePatternBaseType Members.

System.Object
Aspose.Email.Exchange.Schema.RecurrencePatternBaseType
Aspose.Email.Exchange.Schema.AbsoluteYearlyRecurrencePatternType
Aspose.Email.Exchange.Schema.IntervalRecurrencePatternBaseType
Aspose.Email.Exchange.Schema.RelativeYearlyRecurrencePatternType

public abstract class RecurrencePatternBaseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RecurrencePatternBaseType Members | Aspose.Email.Exchange.Schema Namespace


RecurrencePatternBaseType Members

RecurrencePatternBaseType overview

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

RecurrencePatternBaseType Constructor Initializes a new instance of the RecurrencePatternBaseType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RecurrencePatternBaseType Class | Aspose.Email.Exchange.Schema Namespace


RecurrencePatternBaseType Constructor

Initializes a new instance of the RecurrencePatternBaseType class.

protected RecurrencePatternBaseType();

See Also

RecurrencePatternBaseType Class | Aspose.Email.Exchange.Schema Namespace


RecurrenceRangeBaseType Class

For a list of all members of this type, see RecurrenceRangeBaseType Members.

System.Object
Aspose.Email.Exchange.Schema.RecurrenceRangeBaseType
Aspose.Email.Exchange.Schema.EndDateRecurrenceRangeType
Aspose.Email.Exchange.Schema.NoEndRecurrenceRangeType
Aspose.Email.Exchange.Schema.NumberedRecurrenceRangeType

public abstract class RecurrenceRangeBaseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RecurrenceRangeBaseType Members | Aspose.Email.Exchange.Schema Namespace


RecurrenceRangeBaseType Members

RecurrenceRangeBaseType overview

Public Instance Properties

StartDate

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

RecurrenceRangeBaseType Constructor Initializes a new instance of the RecurrenceRangeBaseType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RecurrenceRangeBaseType Class | Aspose.Email.Exchange.Schema Namespace


RecurrenceRangeBaseType Constructor

Initializes a new instance of the RecurrenceRangeBaseType class.

protected RecurrenceRangeBaseType();

See Also

RecurrenceRangeBaseType Class | Aspose.Email.Exchange.Schema Namespace


RecurrenceRangeBaseType Properties

The properties of the RecurrenceRangeBaseType class are listed below. For a complete list of RecurrenceRangeBaseType class members, see the RecurrenceRangeBaseType Members topic.

Public Instance Properties

StartDate

See Also

RecurrenceRangeBaseType Class | Aspose.Email.Exchange.Schema Namespace


StartDate Property

Aspose.Email

RecurrenceRangeBaseType.StartDate Property

public DateTime StartDate {get; set;}

Remarks

See Also

RecurrenceRangeBaseType Class | Aspose.Email.Exchange.Schema Namespace


RecurrenceType Class

For a list of all members of this type, see RecurrenceType Members.

System.Object
Aspose.Email.Exchange.Schema.RecurrenceType

public class RecurrenceType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RecurrenceType Members | Aspose.Email.Exchange.Schema Namespace


RecurrenceType Members

RecurrenceType overview

Public Instance Constructors

RecurrenceType Constructor Initializes a new instance of the RecurrenceType class.

Public Instance Properties

Item
Item1

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RecurrenceType Class | Aspose.Email.Exchange.Schema Namespace


RecurrenceType Constructor

Initializes a new instance of the RecurrenceType class.

public RecurrenceType();

See Also

RecurrenceType Class | Aspose.Email.Exchange.Schema Namespace


RecurrenceType Properties

The properties of the RecurrenceType class are listed below. For a complete list of RecurrenceType class members, see the RecurrenceType Members topic.

Public Instance Properties

Item
Item1

See Also

RecurrenceType Class | Aspose.Email.Exchange.Schema Namespace


Item Property

Aspose.Email

RecurrenceType.Item Property

public RecurrencePatternBaseType Item {get; set;}

Remarks

See Also

RecurrenceType Class | Aspose.Email.Exchange.Schema Namespace


Item1 Property

Aspose.Email

RecurrenceType.Item1 Property

public RecurrenceRangeBaseType Item1 {get; set;}

Remarks

See Also

RecurrenceType Class | Aspose.Email.Exchange.Schema Namespace


RecurringDateTransitionType Class

For a list of all members of this type, see RecurringDateTransitionType Members.

System.Object
Aspose.Email.Exchange.Schema.TransitionType
Aspose.Email.Exchange.Schema.RecurringTimeTransitionType
Aspose.Email.Exchange.Schema.RecurringDateTransitionType

public class RecurringDateTransitionType : RecurringTimeTransitionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RecurringDateTransitionType Members | Aspose.Email.Exchange.Schema Namespace


RecurringDateTransitionType Members

RecurringDateTransitionType overview

Public Instance Constructors

RecurringDateTransitionType Constructor Initializes a new instance of the RecurringDateTransitionType class.

Public Instance Properties

Day
Month (inherited from RecurringTimeTransitionType)
TimeOffset (inherited from RecurringTimeTransitionType)
To (inherited from TransitionType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RecurringDateTransitionType Class | Aspose.Email.Exchange.Schema Namespace


RecurringDateTransitionType Constructor

Initializes a new instance of the RecurringDateTransitionType class.

public RecurringDateTransitionType();

See Also

RecurringDateTransitionType Class | Aspose.Email.Exchange.Schema Namespace


RecurringDateTransitionType Properties

The properties of the RecurringDateTransitionType class are listed below. For a complete list of RecurringDateTransitionType class members, see the RecurringDateTransitionType Members topic.

Public Instance Properties

Day
Month (inherited from RecurringTimeTransitionType)
TimeOffset (inherited from RecurringTimeTransitionType)
To (inherited from TransitionType)

See Also

RecurringDateTransitionType Class | Aspose.Email.Exchange.Schema Namespace


Day Property

Aspose.Email

RecurringDateTransitionType.Day Property

public int Day {get; set;}

Remarks

See Also

RecurringDateTransitionType Class | Aspose.Email.Exchange.Schema Namespace


RecurringDayTransitionType Class

For a list of all members of this type, see RecurringDayTransitionType Members.

System.Object
Aspose.Email.Exchange.Schema.TransitionType
Aspose.Email.Exchange.Schema.RecurringTimeTransitionType
Aspose.Email.Exchange.Schema.RecurringDayTransitionType

public class RecurringDayTransitionType : RecurringTimeTransitionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RecurringDayTransitionType Members | Aspose.Email.Exchange.Schema Namespace


RecurringDayTransitionType Members

RecurringDayTransitionType overview

Public Instance Constructors

RecurringDayTransitionType Constructor Initializes a new instance of the RecurringDayTransitionType class.

Public Instance Properties

DayOfWeek
Month (inherited from RecurringTimeTransitionType)
Occurrence
TimeOffset (inherited from RecurringTimeTransitionType)
To (inherited from TransitionType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RecurringDayTransitionType Class | Aspose.Email.Exchange.Schema Namespace


RecurringDayTransitionType Constructor

Initializes a new instance of the RecurringDayTransitionType class.

public RecurringDayTransitionType();

See Also

RecurringDayTransitionType Class | Aspose.Email.Exchange.Schema Namespace


RecurringDayTransitionType Properties

The properties of the RecurringDayTransitionType class are listed below. For a complete list of RecurringDayTransitionType class members, see the RecurringDayTransitionType Members topic.

Public Instance Properties

DayOfWeek
Month (inherited from RecurringTimeTransitionType)
Occurrence
TimeOffset (inherited from RecurringTimeTransitionType)
To (inherited from TransitionType)

See Also

RecurringDayTransitionType Class | Aspose.Email.Exchange.Schema Namespace


DayOfWeek Property

Aspose.Email

RecurringDayTransitionType.DayOfWeek Property

public string DayOfWeek {get; set;}

Remarks

See Also

RecurringDayTransitionType Class | Aspose.Email.Exchange.Schema Namespace


Occurrence Property

Aspose.Email

RecurringDayTransitionType.Occurrence Property

public int Occurrence {get; set;}

Remarks

See Also

RecurringDayTransitionType Class | Aspose.Email.Exchange.Schema Namespace


RecurringMasterItemIdType Class

For a list of all members of this type, see RecurringMasterItemIdType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseItemIdType
Aspose.Email.Exchange.Schema.RecurringMasterItemIdType

public class RecurringMasterItemIdType : BaseItemIdType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RecurringMasterItemIdType Members | Aspose.Email.Exchange.Schema Namespace


RecurringMasterItemIdType Members

RecurringMasterItemIdType overview

Public Instance Constructors

RecurringMasterItemIdType Constructor Initializes a new instance of the RecurringMasterItemIdType class.

Public Instance Properties

ChangeKey
OccurrenceId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RecurringMasterItemIdType Class | Aspose.Email.Exchange.Schema Namespace


RecurringMasterItemIdType Constructor

Initializes a new instance of the RecurringMasterItemIdType class.

public RecurringMasterItemIdType();

See Also

RecurringMasterItemIdType Class | Aspose.Email.Exchange.Schema Namespace


RecurringMasterItemIdType Properties

The properties of the RecurringMasterItemIdType class are listed below. For a complete list of RecurringMasterItemIdType class members, see the RecurringMasterItemIdType Members topic.

Public Instance Properties

ChangeKey
OccurrenceId

See Also

RecurringMasterItemIdType Class | Aspose.Email.Exchange.Schema Namespace


ChangeKey Property

Aspose.Email

RecurringMasterItemIdType.ChangeKey Property

public string ChangeKey {get; set;}

Remarks

See Also

RecurringMasterItemIdType Class | Aspose.Email.Exchange.Schema Namespace


OccurrenceId Property

Aspose.Email

RecurringMasterItemIdType.OccurrenceId Property

public string OccurrenceId {get; set;}

Remarks

See Also

RecurringMasterItemIdType Class | Aspose.Email.Exchange.Schema Namespace


RecurringTimeTransitionType Class

For a list of all members of this type, see RecurringTimeTransitionType Members.

System.Object
Aspose.Email.Exchange.Schema.TransitionType
Aspose.Email.Exchange.Schema.RecurringTimeTransitionType
Aspose.Email.Exchange.Schema.RecurringDateTransitionType
Aspose.Email.Exchange.Schema.RecurringDayTransitionType

public abstract class RecurringTimeTransitionType : TransitionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RecurringTimeTransitionType Members | Aspose.Email.Exchange.Schema Namespace


RecurringTimeTransitionType Members

RecurringTimeTransitionType overview

Public Instance Properties

Month
TimeOffset
To (inherited from TransitionType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

RecurringTimeTransitionType Constructor Initializes a new instance of the RecurringTimeTransitionType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RecurringTimeTransitionType Class | Aspose.Email.Exchange.Schema Namespace


RecurringTimeTransitionType Constructor

Initializes a new instance of the RecurringTimeTransitionType class.

protected RecurringTimeTransitionType();

See Also

RecurringTimeTransitionType Class | Aspose.Email.Exchange.Schema Namespace


RecurringTimeTransitionType Properties

The properties of the RecurringTimeTransitionType class are listed below. For a complete list of RecurringTimeTransitionType class members, see the RecurringTimeTransitionType Members topic.

Public Instance Properties

Month
TimeOffset
To (inherited from TransitionType)

See Also

RecurringTimeTransitionType Class | Aspose.Email.Exchange.Schema Namespace


Month Property

Aspose.Email

RecurringTimeTransitionType.Month Property

public int Month {get; set;}

Remarks

See Also

RecurringTimeTransitionType Class | Aspose.Email.Exchange.Schema Namespace


TimeOffset Property

Aspose.Email

RecurringTimeTransitionType.TimeOffset Property

public string TimeOffset {get; set;}

Remarks

See Also

RecurringTimeTransitionType Class | Aspose.Email.Exchange.Schema Namespace


ReferenceItemResponseType Class

For a list of all members of this type, see ReferenceItemResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.ItemType
Aspose.Email.Exchange.Schema.MessageType
Aspose.Email.Exchange.Schema.ResponseObjectCoreType
Aspose.Email.Exchange.Schema.ResponseObjectType
Aspose.Email.Exchange.Schema.ReferenceItemResponseType
Aspose.Email.Exchange.Schema.AcceptSharingInvitationType
Aspose.Email.Exchange.Schema.SuppressReadReceiptType

public class ReferenceItemResponseType : ResponseObjectType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ReferenceItemResponseType Members | Aspose.Email.Exchange.Schema Namespace


ReferenceItemResponseType Members

ReferenceItemResponseType overview

Public Instance Constructors

ReferenceItemResponseType Constructor Initializes a new instance of the ReferenceItemResponseType class.

Public Instance Properties

Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
From (inherited from MessageType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
ObjectName (inherited from ResponseObjectType)
ParentFolderId (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
ReferenceItemId (inherited from ResponseObjectCoreType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
Subject (inherited from ItemType)
ToRecipients (inherited from MessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ReferenceItemResponseType Class | Aspose.Email.Exchange.Schema Namespace


ReferenceItemResponseType Constructor

Initializes a new instance of the ReferenceItemResponseType class.

public ReferenceItemResponseType();

See Also

ReferenceItemResponseType Class | Aspose.Email.Exchange.Schema Namespace


RefreshSharingFolderCompletedEventArgs Class

For a list of all members of this type, see RefreshSharingFolderCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.RefreshSharingFolderCompletedEventArgs

public class RefreshSharingFolderCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RefreshSharingFolderCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


RefreshSharingFolderCompletedEventArgs Members

RefreshSharingFolderCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

RefreshSharingFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


RefreshSharingFolderCompletedEventArgs Properties

The properties of the RefreshSharingFolderCompletedEventArgs class are listed below. For a complete list of RefreshSharingFolderCompletedEventArgs class members, see the RefreshSharingFolderCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

RefreshSharingFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

RefreshSharingFolderCompletedEventArgs.Result Property

public RefreshSharingFolderResponseMessageType Result {get;}

Remarks

See Also

RefreshSharingFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


RefreshSharingFolderCompletedEventHandler Delegate

public delegate void RefreshSharingFolderCompletedEventHandler(
object sender,
RefreshSharingFolderCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


RefreshSharingFolderResponseMessageType Class

For a list of all members of this type, see RefreshSharingFolderResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ResponseMessageType
Aspose.Email.Exchange.Schema.RefreshSharingFolderResponseMessageType

public class RefreshSharingFolderResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RefreshSharingFolderResponseMessageType Members | Aspose.Email.Exchange.Schema Namespace


RefreshSharingFolderResponseMessageType Members

RefreshSharingFolderResponseMessageType overview

Public Instance Constructors

RefreshSharingFolderResponseMessageType Constructor Initializes a new instance of the RefreshSharingFolderResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RefreshSharingFolderResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


RefreshSharingFolderResponseMessageType Constructor

Initializes a new instance of the RefreshSharingFolderResponseMessageType class.

public RefreshSharingFolderResponseMessageType();

See Also

RefreshSharingFolderResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


RefreshSharingFolderType Class

For a list of all members of this type, see RefreshSharingFolderType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.RefreshSharingFolderType

public class RefreshSharingFolderType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RefreshSharingFolderType Members | Aspose.Email.Exchange.Schema Namespace


RefreshSharingFolderType Members

RefreshSharingFolderType overview

Public Instance Constructors

RefreshSharingFolderType Constructor Initializes a new instance of the RefreshSharingFolderType class.

Public Instance Properties

SharingFolderId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RefreshSharingFolderType Class | Aspose.Email.Exchange.Schema Namespace


RefreshSharingFolderType Constructor

Initializes a new instance of the RefreshSharingFolderType class.

public RefreshSharingFolderType();

See Also

RefreshSharingFolderType Class | Aspose.Email.Exchange.Schema Namespace


RefreshSharingFolderType Properties

The properties of the RefreshSharingFolderType class are listed below. For a complete list of RefreshSharingFolderType class members, see the RefreshSharingFolderType Members topic.

Public Instance Properties

SharingFolderId

See Also

RefreshSharingFolderType Class | Aspose.Email.Exchange.Schema Namespace


SharingFolderId Property

Aspose.Email

RefreshSharingFolderType.SharingFolderId Property

public FolderIdType SharingFolderId {get; set;}

Remarks

See Also

RefreshSharingFolderType Class | Aspose.Email.Exchange.Schema Namespace


RegeneratingPatternBaseType Class

For a list of all members of this type, see RegeneratingPatternBaseType Members.

System.Object
Aspose.Email.Exchange.Schema.RecurrencePatternBaseType
Aspose.Email.Exchange.Schema.IntervalRecurrencePatternBaseType
Aspose.Email.Exchange.Schema.RegeneratingPatternBaseType
Aspose.Email.Exchange.Schema.DailyRegeneratingPatternType
Aspose.Email.Exchange.Schema.MonthlyRegeneratingPatternType
Aspose.Email.Exchange.Schema.WeeklyRegeneratingPatternType
Aspose.Email.Exchange.Schema.YearlyRegeneratingPatternType

public abstract class RegeneratingPatternBaseType : IntervalRecurrencePatternBaseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RegeneratingPatternBaseType Members | Aspose.Email.Exchange.Schema Namespace


RegeneratingPatternBaseType Members

RegeneratingPatternBaseType overview

Public Instance Properties

Interval (inherited from IntervalRecurrencePatternBaseType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

RegeneratingPatternBaseType Constructor Initializes a new instance of the RegeneratingPatternBaseType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RegeneratingPatternBaseType Class | Aspose.Email.Exchange.Schema Namespace


RegeneratingPatternBaseType Constructor

Initializes a new instance of the RegeneratingPatternBaseType class.

protected RegeneratingPatternBaseType();

See Also

RegeneratingPatternBaseType Class | Aspose.Email.Exchange.Schema Namespace


RelativeMonthlyRecurrencePatternType Class

Class describes a relative monthly recurrence pattern.

For a list of all members of this type, see RelativeMonthlyRecurrencePatternType Members.

System.Object
Aspose.Email.Exchange.Schema.RecurrencePatternBaseType
Aspose.Email.Exchange.Schema.IntervalRecurrencePatternBaseType
Aspose.Email.Exchange.Schema.RelativeMonthlyRecurrencePatternType

public class RelativeMonthlyRecurrencePatternType : IntervalRecurrencePatternBaseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RelativeMonthlyRecurrencePatternType Members | Aspose.Email.Exchange.Schema Namespace


RelativeMonthlyRecurrencePatternType Members

RelativeMonthlyRecurrencePatternType overview

Public Instance Constructors

RelativeMonthlyRecurrencePatternType Constructor Initializes a new instance of the RelativeMonthlyRecurrencePatternType class.

Public Instance Properties

DayOfWeekIndex
DaysOfWeek
Interval (inherited from IntervalRecurrencePatternBaseType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RelativeMonthlyRecurrencePatternType Class | Aspose.Email.Exchange.Schema Namespace


RelativeMonthlyRecurrencePatternType Constructor

Initializes a new instance of the RelativeMonthlyRecurrencePatternType class.

public RelativeMonthlyRecurrencePatternType();

See Also

RelativeMonthlyRecurrencePatternType Class | Aspose.Email.Exchange.Schema Namespace


RelativeMonthlyRecurrencePatternType Properties

The properties of the RelativeMonthlyRecurrencePatternType class are listed below. For a complete list of RelativeMonthlyRecurrencePatternType class members, see the RelativeMonthlyRecurrencePatternType Members topic.

Public Instance Properties

DayOfWeekIndex
DaysOfWeek
Interval (inherited from IntervalRecurrencePatternBaseType)

See Also

RelativeMonthlyRecurrencePatternType Class | Aspose.Email.Exchange.Schema Namespace


DayOfWeekIndex Property

Aspose.Email

RelativeMonthlyRecurrencePatternType.DayOfWeekIndex Property

public DayOfWeekIndexType DayOfWeekIndex {get; set;}

Remarks

See Also

RelativeMonthlyRecurrencePatternType Class | Aspose.Email.Exchange.Schema Namespace


DaysOfWeek Property

Aspose.Email

RelativeMonthlyRecurrencePatternType.DaysOfWeek Property

public DayOfWeekType DaysOfWeek {get; set;}

Remarks

See Also

RelativeMonthlyRecurrencePatternType Class | Aspose.Email.Exchange.Schema Namespace


RelativeYearlyRecurrencePatternType Class

Class describes a relative yearly recurrence pattern.

For a list of all members of this type, see RelativeYearlyRecurrencePatternType Members.

System.Object
Aspose.Email.Exchange.Schema.RecurrencePatternBaseType
Aspose.Email.Exchange.Schema.RelativeYearlyRecurrencePatternType

public class RelativeYearlyRecurrencePatternType : RecurrencePatternBaseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RelativeYearlyRecurrencePatternType Members | Aspose.Email.Exchange.Schema Namespace


RelativeYearlyRecurrencePatternType Members

RelativeYearlyRecurrencePatternType overview

Public Instance Constructors

RelativeYearlyRecurrencePatternType Constructor Initializes a new instance of the RelativeYearlyRecurrencePatternType class.

Public Instance Properties

DayOfWeekIndex
DaysOfWeek
Month

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RelativeYearlyRecurrencePatternType Class | Aspose.Email.Exchange.Schema Namespace


RelativeYearlyRecurrencePatternType Constructor

Initializes a new instance of the RelativeYearlyRecurrencePatternType class.

public RelativeYearlyRecurrencePatternType();

See Also

RelativeYearlyRecurrencePatternType Class | Aspose.Email.Exchange.Schema Namespace


RelativeYearlyRecurrencePatternType Properties

The properties of the RelativeYearlyRecurrencePatternType class are listed below. For a complete list of RelativeYearlyRecurrencePatternType class members, see the RelativeYearlyRecurrencePatternType Members topic.

Public Instance Properties

DayOfWeekIndex
DaysOfWeek
Month

See Also

RelativeYearlyRecurrencePatternType Class | Aspose.Email.Exchange.Schema Namespace


DayOfWeekIndex Property

Aspose.Email

RelativeYearlyRecurrencePatternType.DayOfWeekIndex Property

public DayOfWeekIndexType DayOfWeekIndex {get; set;}

Remarks

See Also

RelativeYearlyRecurrencePatternType Class | Aspose.Email.Exchange.Schema Namespace


DaysOfWeek Property

Aspose.Email

RelativeYearlyRecurrencePatternType.DaysOfWeek Property

public string DaysOfWeek {get; set;}

Remarks

See Also

RelativeYearlyRecurrencePatternType Class | Aspose.Email.Exchange.Schema Namespace


Month Property

Aspose.Email

RelativeYearlyRecurrencePatternType.Month Property

public MonthNamesType Month {get; set;}

Remarks

See Also

RelativeYearlyRecurrencePatternType Class | Aspose.Email.Exchange.Schema Namespace


RemoveDelegateCompletedEventArgs Class

For a list of all members of this type, see RemoveDelegateCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.RemoveDelegateCompletedEventArgs

public class RemoveDelegateCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RemoveDelegateCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


RemoveDelegateCompletedEventArgs Members

RemoveDelegateCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

RemoveDelegateCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


RemoveDelegateCompletedEventArgs Properties

The properties of the RemoveDelegateCompletedEventArgs class are listed below. For a complete list of RemoveDelegateCompletedEventArgs class members, see the RemoveDelegateCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

RemoveDelegateCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

RemoveDelegateCompletedEventArgs.Result Property

public RemoveDelegateResponseMessageType Result {get;}

Remarks

See Also

RemoveDelegateCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


RemoveDelegateCompletedEventHandler Delegate

public delegate void RemoveDelegateCompletedEventHandler(
object sender,
RemoveDelegateCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


RemoveDelegateResponseMessageType Class

For a list of all members of this type, see RemoveDelegateResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ResponseMessageType
Aspose.Email.Exchange.Schema.BaseDelegateResponseMessageType
Aspose.Email.Exchange.Schema.RemoveDelegateResponseMessageType

public class RemoveDelegateResponseMessageType : BaseDelegateResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RemoveDelegateResponseMessageType Members | Aspose.Email.Exchange.Schema Namespace


RemoveDelegateResponseMessageType Members

RemoveDelegateResponseMessageType overview

Public Instance Constructors

RemoveDelegateResponseMessageType Constructor Initializes a new instance of the RemoveDelegateResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
ResponseMessages (inherited from BaseDelegateResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RemoveDelegateResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


RemoveDelegateResponseMessageType Constructor

Initializes a new instance of the RemoveDelegateResponseMessageType class.

public RemoveDelegateResponseMessageType();

See Also

RemoveDelegateResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


RemoveDelegateType Class

For a list of all members of this type, see RemoveDelegateType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.BaseDelegateType
Aspose.Email.Exchange.Schema.RemoveDelegateType

public class RemoveDelegateType : BaseDelegateType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RemoveDelegateType Members | Aspose.Email.Exchange.Schema Namespace


RemoveDelegateType Members

RemoveDelegateType overview

Public Instance Constructors

RemoveDelegateType Constructor Initializes a new instance of the RemoveDelegateType class.

Public Instance Properties

Mailbox (inherited from BaseDelegateType)
UserIds

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RemoveDelegateType Class | Aspose.Email.Exchange.Schema Namespace


RemoveDelegateType Constructor

Initializes a new instance of the RemoveDelegateType class.

public RemoveDelegateType();

See Also

RemoveDelegateType Class | Aspose.Email.Exchange.Schema Namespace


RemoveDelegateType Properties

The properties of the RemoveDelegateType class are listed below. For a complete list of RemoveDelegateType class members, see the RemoveDelegateType Members topic.

Public Instance Properties

Mailbox (inherited from BaseDelegateType)
UserIds

See Also

RemoveDelegateType Class | Aspose.Email.Exchange.Schema Namespace


UserIds Property

Aspose.Email

RemoveDelegateType.UserIds Property

public UserIdType[] UserIds {get; set;}

Remarks

See Also

RemoveDelegateType Class | Aspose.Email.Exchange.Schema Namespace


RemoveItemType Class

For a list of all members of this type, see RemoveItemType Members.

System.Object
Aspose.Email.Exchange.Schema.ItemType
Aspose.Email.Exchange.Schema.MessageType
Aspose.Email.Exchange.Schema.ResponseObjectCoreType
Aspose.Email.Exchange.Schema.ResponseObjectType
Aspose.Email.Exchange.Schema.RemoveItemType

public class RemoveItemType : ResponseObjectType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RemoveItemType Members | Aspose.Email.Exchange.Schema Namespace


RemoveItemType Members

RemoveItemType overview

Public Instance Constructors

RemoveItemType Constructor Initializes a new instance of the RemoveItemType class.

Public Instance Properties

Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
From (inherited from MessageType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
ObjectName (inherited from ResponseObjectType)
ParentFolderId (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
ReferenceItemId (inherited from ResponseObjectCoreType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
Subject (inherited from ItemType)
ToRecipients (inherited from MessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RemoveItemType Class | Aspose.Email.Exchange.Schema Namespace


RemoveItemType Constructor

Initializes a new instance of the RemoveItemType class.

public RemoveItemType();

See Also

RemoveItemType Class | Aspose.Email.Exchange.Schema Namespace


ReplyAllToItemType Class

For a list of all members of this type, see ReplyAllToItemType Members.

System.Object
Aspose.Email.Exchange.Schema.ItemType
Aspose.Email.Exchange.Schema.MessageType
Aspose.Email.Exchange.Schema.ResponseObjectCoreType
Aspose.Email.Exchange.Schema.ResponseObjectType
Aspose.Email.Exchange.Schema.SmartResponseBaseType
Aspose.Email.Exchange.Schema.SmartResponseType
Aspose.Email.Exchange.Schema.ReplyAllToItemType

public class ReplyAllToItemType : SmartResponseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ReplyAllToItemType Members | Aspose.Email.Exchange.Schema Namespace


ReplyAllToItemType Members

ReplyAllToItemType overview

Public Instance Constructors

ReplyAllToItemType Constructor Initializes a new instance of the ReplyAllToItemType class.

Public Instance Properties

Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
From (inherited from MessageType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
NewBodyContent (inherited from SmartResponseType)
ObjectName (inherited from ResponseObjectType)
ParentFolderId (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
ReferenceItemId (inherited from ResponseObjectCoreType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
Subject (inherited from ItemType)
ToRecipients (inherited from MessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ReplyAllToItemType Class | Aspose.Email.Exchange.Schema Namespace


ReplyAllToItemType Constructor

Initializes a new instance of the ReplyAllToItemType class.

public ReplyAllToItemType();

See Also

ReplyAllToItemType Class | Aspose.Email.Exchange.Schema Namespace


ReplyBody Class

For a list of all members of this type, see ReplyBody Members.

System.Object
Aspose.Email.Exchange.Schema.ReplyBody

public class ReplyBody

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ReplyBody Members | Aspose.Email.Exchange.Schema Namespace


ReplyBody Members

ReplyBody overview

Public Instance Constructors

ReplyBody Constructor Initializes a new instance of the ReplyBody class.

Public Instance Properties

lang
Message

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ReplyBody Class | Aspose.Email.Exchange.Schema Namespace


ReplyBody Constructor

Initializes a new instance of the ReplyBody class.

public ReplyBody();

See Also

ReplyBody Class | Aspose.Email.Exchange.Schema Namespace


ReplyBody Properties

The properties of the ReplyBody class are listed below. For a complete list of ReplyBody class members, see the ReplyBody Members topic.

Public Instance Properties

lang
Message

See Also

ReplyBody Class | Aspose.Email.Exchange.Schema Namespace


lang Property

Aspose.Email

ReplyBody.lang Property

public string lang {get; set;}

Remarks

See Also

ReplyBody Class | Aspose.Email.Exchange.Schema Namespace


Message Property

Aspose.Email

ReplyBody.Message Property

public string Message {get; set;}

Remarks

See Also

ReplyBody Class | Aspose.Email.Exchange.Schema Namespace


ReplyToItemType Class

For a list of all members of this type, see ReplyToItemType Members.

System.Object
Aspose.Email.Exchange.Schema.ItemType
Aspose.Email.Exchange.Schema.MessageType
Aspose.Email.Exchange.Schema.ResponseObjectCoreType
Aspose.Email.Exchange.Schema.ResponseObjectType
Aspose.Email.Exchange.Schema.SmartResponseBaseType
Aspose.Email.Exchange.Schema.SmartResponseType
Aspose.Email.Exchange.Schema.ReplyToItemType

public class ReplyToItemType : SmartResponseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ReplyToItemType Members | Aspose.Email.Exchange.Schema Namespace


ReplyToItemType Members

ReplyToItemType overview

Public Instance Constructors

ReplyToItemType Constructor Initializes a new instance of the ReplyToItemType class.

Public Instance Properties

Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
From (inherited from MessageType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
NewBodyContent (inherited from SmartResponseType)
ObjectName (inherited from ResponseObjectType)
ParentFolderId (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
ReferenceItemId (inherited from ResponseObjectCoreType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
Subject (inherited from ItemType)
ToRecipients (inherited from MessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ReplyToItemType Class | Aspose.Email.Exchange.Schema Namespace


ReplyToItemType Constructor

Initializes a new instance of the ReplyToItemType class.

public ReplyToItemType();

See Also

ReplyToItemType Class | Aspose.Email.Exchange.Schema Namespace


RequestAttachmentIdType Class

For a list of all members of this type, see RequestAttachmentIdType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseItemIdType
Aspose.Email.Exchange.Schema.RequestAttachmentIdType
Aspose.Email.Exchange.Schema.AttachmentIdType

public class RequestAttachmentIdType : BaseItemIdType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RequestAttachmentIdType Members | Aspose.Email.Exchange.Schema Namespace


RequestAttachmentIdType Members

RequestAttachmentIdType overview

Public Instance Constructors

RequestAttachmentIdType Constructor Initializes a new instance of the RequestAttachmentIdType class.

Public Instance Properties

Id

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RequestAttachmentIdType Class | Aspose.Email.Exchange.Schema Namespace


RequestAttachmentIdType Constructor

Initializes a new instance of the RequestAttachmentIdType class.

public RequestAttachmentIdType();

See Also

RequestAttachmentIdType Class | Aspose.Email.Exchange.Schema Namespace


RequestAttachmentIdType Properties

The properties of the RequestAttachmentIdType class are listed below. For a complete list of RequestAttachmentIdType class members, see the RequestAttachmentIdType Members topic.

Public Instance Properties

Id

See Also

RequestAttachmentIdType Class | Aspose.Email.Exchange.Schema Namespace


Id Property

Aspose.Email

RequestAttachmentIdType.Id Property

public string Id {get; set;}

Remarks

See Also

RequestAttachmentIdType Class | Aspose.Email.Exchange.Schema Namespace


RequestServerVersion Class

For a list of all members of this type, see RequestServerVersion Members.

System.Object
System.Web.Services.Protocols.SoapHeader
Aspose.Email.Exchange.Schema.RequestServerVersion

public class RequestServerVersion : SoapHeader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RequestServerVersion Members | Aspose.Email.Exchange.Schema Namespace


RequestServerVersion Members

RequestServerVersion overview

Public Instance Constructors

RequestServerVersion Constructor Initializes a new instance of the RequestServerVersion class.

Public Instance Properties

Actor (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.
AnyAttr |
DidUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether an XML Web service method properly processed a SOAP header.
EncodedMustUnderstand (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.1.
EncodedMustUnderstand12 (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.2.
EncodedRelay (inherited from SoapHeader) | Gets or sets the relay attribute of the SOAP 1.2 header.
MustUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether the SoapHeader must be understood.
Relay (inherited from SoapHeader) | Gets or sets a value that indicates whether the SOAP header is to be relayed to the next SOAP node if the current node does not understand the header.
Role (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.
Version |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RequestServerVersion Class | Aspose.Email.Exchange.Schema Namespace


RequestServerVersion Constructor

Initializes a new instance of the RequestServerVersion class.

public RequestServerVersion();

See Also

RequestServerVersion Class | Aspose.Email.Exchange.Schema Namespace


RequestServerVersion Properties

The properties of the RequestServerVersion class are listed below. For a complete list of RequestServerVersion class members, see the RequestServerVersion Members topic.

Public Instance Properties

Actor (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.
AnyAttr |
DidUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether an XML Web service method properly processed a SOAP header.
EncodedMustUnderstand (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.1.
EncodedMustUnderstand12 (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.2.
EncodedRelay (inherited from SoapHeader) | Gets or sets the relay attribute of the SOAP 1.2 header.
MustUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether the SoapHeader must be understood.
Relay (inherited from SoapHeader) | Gets or sets a value that indicates whether the SOAP header is to be relayed to the next SOAP node if the current node does not understand the header.
Role (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.
Version |

See Also

RequestServerVersion Class | Aspose.Email.Exchange.Schema Namespace


AnyAttr Property

Aspose.Email

RequestServerVersion.AnyAttr Property

public XmlAttribute[] AnyAttr {get; set;}

Remarks

See Also

RequestServerVersion Class | Aspose.Email.Exchange.Schema Namespace


Version Property

Aspose.Email

RequestServerVersion.Version Property

public ExchangeVersionType Version {get; set;}

Remarks

See Also

RequestServerVersion Class | Aspose.Email.Exchange.Schema Namespace


ResolutionType Class

For a list of all members of this type, see ResolutionType Members.

System.Object
Aspose.Email.Exchange.Schema.ResolutionType

public class ResolutionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ResolutionType Members | Aspose.Email.Exchange.Schema Namespace


ResolutionType Members

ResolutionType overview

Public Instance Constructors

ResolutionType Constructor Initializes a new instance of the ResolutionType class.

Public Instance Properties

Contact
Mailbox

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ResolutionType Class | Aspose.Email.Exchange.Schema Namespace


ResolutionType Constructor

Initializes a new instance of the ResolutionType class.

public ResolutionType();

See Also

ResolutionType Class | Aspose.Email.Exchange.Schema Namespace


ResolutionType Properties

The properties of the ResolutionType class are listed below. For a complete list of ResolutionType class members, see the ResolutionType Members topic.

Public Instance Properties

Contact
Mailbox

See Also

ResolutionType Class | Aspose.Email.Exchange.Schema Namespace


Contact Property

Aspose.Email

ResolutionType.Contact Property

public ContactItemType Contact {get; set;}

Remarks

See Also

ResolutionType Class | Aspose.Email.Exchange.Schema Namespace


Mailbox Property

Aspose.Email

ResolutionType.Mailbox Property

public EmailAddressType Mailbox {get; set;}

Remarks

See Also

ResolutionType Class | Aspose.Email.Exchange.Schema Namespace


ResolveNamesCompletedEventArgs Class

For a list of all members of this type, see ResolveNamesCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.ResolveNamesCompletedEventArgs

public class ResolveNamesCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ResolveNamesCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


ResolveNamesCompletedEventArgs Members

ResolveNamesCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

ResolveNamesCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


ResolveNamesCompletedEventArgs Properties

The properties of the ResolveNamesCompletedEventArgs class are listed below. For a complete list of ResolveNamesCompletedEventArgs class members, see the ResolveNamesCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

ResolveNamesCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

ResolveNamesCompletedEventArgs.Result Property

public ResolveNamesResponseType Result {get;}

Remarks

See Also

ResolveNamesCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


ResolveNamesCompletedEventHandler Delegate

public delegate void ResolveNamesCompletedEventHandler(
object sender,
ResolveNamesCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


ResolveNamesResponseMessageType Class

For a list of all members of this type, see ResolveNamesResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ResponseMessageType
Aspose.Email.Exchange.Schema.ResolveNamesResponseMessageType

public class ResolveNamesResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ResolveNamesResponseMessageType Members | Aspose.Email.Exchange.Schema Namespace


ResolveNamesResponseMessageType Members

ResolveNamesResponseMessageType overview

Public Instance Constructors

ResolveNamesResponseMessageType Constructor Initializes a new instance of the ResolveNamesResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResolutionSet
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ResolveNamesResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


ResolveNamesResponseMessageType Constructor

Initializes a new instance of the ResolveNamesResponseMessageType class.

public ResolveNamesResponseMessageType();

See Also

ResolveNamesResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


ResolveNamesResponseMessageType Properties

The properties of the ResolveNamesResponseMessageType class are listed below. For a complete list of ResolveNamesResponseMessageType class members, see the ResolveNamesResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResolutionSet
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

ResolveNamesResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


ResolutionSet Property

Aspose.Email

ResolveNamesResponseMessageType.ResolutionSet Property

public ArrayOfResolutionType ResolutionSet {get; set;}

Remarks

See Also

ResolveNamesResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


ResolveNamesResponseType Class

For a list of all members of this type, see ResolveNamesResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseResponseMessageType
Aspose.Email.Exchange.Schema.ResolveNamesResponseType

public class ResolveNamesResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ResolveNamesResponseType Members | Aspose.Email.Exchange.Schema Namespace


ResolveNamesResponseType Members

ResolveNamesResponseType overview

Public Instance Constructors

ResolveNamesResponseType Constructor Initializes a new instance of the ResolveNamesResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ResolveNamesResponseType Class | Aspose.Email.Exchange.Schema Namespace


ResolveNamesResponseType Constructor

Initializes a new instance of the ResolveNamesResponseType class.

public ResolveNamesResponseType();

See Also

ResolveNamesResponseType Class | Aspose.Email.Exchange.Schema Namespace


ResolveNamesSearchScopeType Enumeration

public enum ResolveNamesSearchScopeType

Remarks

Members

Member Name | Description | Value
ActiveDirectory |  | 0
ActiveDirectoryContacts |  | 1
Contacts |  | 2
ContactsActiveDirectory |  | 3

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


ResolveNamesType Class

For a list of all members of this type, see ResolveNamesType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.ResolveNamesType

public class ResolveNamesType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ResolveNamesType Members | Aspose.Email.Exchange.Schema Namespace


ResolveNamesType Members

ResolveNamesType overview

Public Instance Constructors

ResolveNamesType Constructor Initializes a new instance of the ResolveNamesType class.

Public Instance Properties

ParentFolderIds
ReturnFullContactData
SearchScope
UnresolvedEntry

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ResolveNamesType Class | Aspose.Email.Exchange.Schema Namespace


ResolveNamesType Constructor

Initializes a new instance of the ResolveNamesType class.

public ResolveNamesType();

See Also

ResolveNamesType Class | Aspose.Email.Exchange.Schema Namespace


ResolveNamesType Properties

The properties of the ResolveNamesType class are listed below. For a complete list of ResolveNamesType class members, see the ResolveNamesType Members topic.

Public Instance Properties

ParentFolderIds
ReturnFullContactData
SearchScope
UnresolvedEntry

See Also

ResolveNamesType Class | Aspose.Email.Exchange.Schema Namespace


ParentFolderIds Property

Aspose.Email

ResolveNamesType.ParentFolderIds Property

public BaseFolderIdType[] ParentFolderIds {get; set;}

Remarks

See Also

ResolveNamesType Class | Aspose.Email.Exchange.Schema Namespace


ReturnFullContactData Property

Aspose.Email

ResolveNamesType.ReturnFullContactData Property

public bool ReturnFullContactData {get; set;}

Remarks

See Also

ResolveNamesType Class | Aspose.Email.Exchange.Schema Namespace


SearchScope Property

Aspose.Email

ResolveNamesType.SearchScope Property

public ResolveNamesSearchScopeType SearchScope {get; set;}

Remarks

See Also

ResolveNamesType Class | Aspose.Email.Exchange.Schema Namespace


UnresolvedEntry Property

Aspose.Email

ResolveNamesType.UnresolvedEntry Property

public string UnresolvedEntry {get; set;}

Remarks

See Also

ResolveNamesType Class | Aspose.Email.Exchange.Schema Namespace


ResponseClassType Enumeration

public enum ResponseClassType

Remarks

Members

Member Name | Description | Value
Success |  | 0
Warning |  | 1
Error |  | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


ResponseCodeType Enumeration

public enum ResponseCodeType

Remarks

Members

Member Name | Description | Value
NoError |  | 0
ErrorAccessDenied |  | 1
ErrorAccessModeSpecified |  | 2
ErrorAccountDisabled |  | 3
ErrorAddDelegatesFailed |  | 4
ErrorAddressSpaceNotFound |  | 5
ErrorADOperation |  | 6
ErrorADSessionFilter |  | 7
ErrorADUnavailable |  | 8
ErrorAutoDiscoverFailed |  | 9
ErrorAffectedTaskOccurrencesRequired |  | 10
ErrorAttachmentSizeLimitExceeded |  | 11
ErrorAvailabilityConfigNotFound |  | 12
ErrorBatchProcessingStopped |  | 13
ErrorCalendarCannotMoveOrCopyOccurrence |  | 14
ErrorCalendarCannotUpdateDeletedItem |  | 15
ErrorCalendarCannotUseIdForOccurrenceId |  | 16
ErrorCalendarCannotUseIdForRecurringMasterId |  | 17
ErrorCalendarDurationIsTooLong |  | 18
ErrorCalendarEndDateIsEarlierThanStartDate |  | 19
ErrorCalendarFolderIsInvalidForCalendarView |  | 20
ErrorCalendarInvalidAttributeValue |  | 21
ErrorCalendarInvalidDayForTimeChangePattern |  | 22
ErrorCalendarInvalidDayForWeeklyRecurrence |  | 23
ErrorCalendarInvalidPropertyState |  | 24
ErrorCalendarInvalidPropertyValue |  | 25
ErrorCalendarInvalidRecurrence |  | 26
ErrorCalendarInvalidTimeZone |  | 27
ErrorCalendarIsCancelledForAccept |  | 28
ErrorCalendarIsCancelledForDecline |  | 29
ErrorCalendarIsCancelledForRemove |  | 30
ErrorCalendarIsCancelledForTentative |  | 31
ErrorCalendarIsDelegatedForAccept |  | 32
ErrorCalendarIsDelegatedForDecline |  | 33
ErrorCalendarIsDelegatedForRemove |  | 34
ErrorCalendarIsDelegatedForTentative |  | 35
ErrorCalendarIsNotOrganizer |  | 36
ErrorCalendarIsOrganizerForAccept |  | 37
ErrorCalendarIsOrganizerForDecline |  | 38
ErrorCalendarIsOrganizerForRemove |  | 39
ErrorCalendarIsOrganizerForTentative |  | 40
ErrorCalendarOccurrenceIndexIsOutOfRecurrenceRange |  | 41
ErrorCalendarOccurrenceIsDeletedFromRecurrence |  | 42
ErrorCalendarOutOfRange |  | 43
ErrorCalendarMeetingRequestIsOutOfDate |  | 44
ErrorCalendarViewRangeTooBig |  | 45
ErrorCallerIsInvalidADAccount |  | 46
ErrorCannotCreateCalendarItemInNonCalendarFolder |  | 47
ErrorCannotCreateContactInNonContactFolder |  | 48
ErrorCannotCreatePostItemInNonMailFolder |  | 49
ErrorCannotCreateTaskInNonTaskFolder |  | 50
ErrorCannotDeleteObject |  | 51
ErrorCannotOpenFileAttachment |  | 52
ErrorCannotDeleteTaskOccurrence |  | 53
ErrorCannotSetCalendarPermissionOnNonCalendarFolder |  | 54
ErrorCannotSetNonCalendarPermissionOnCalendarFolder |  | 55
ErrorCannotSetPermissionUnknownEntries |  | 56
ErrorCannotUseFolderIdForItemId |  | 57
ErrorCannotUseItemIdForFolderId |  | 58
ErrorChangeKeyRequired |  | 59
ErrorChangeKeyRequiredForWriteOperations |  | 60
ErrorConnectionFailed |  | 61
ErrorContainsFilterWrongType |  | 62
ErrorContentConversionFailed |  | 63
ErrorCorruptData |  | 64
ErrorCreateItemAccessDenied |  | 65
ErrorCreateManagedFolderPartialCompletion |  | 66
ErrorCreateSubfolderAccessDenied |  | 67
ErrorCrossMailboxMoveCopy |  | 68
ErrorCrossSiteRequest |  | 69
ErrorDataSizeLimitExceeded |  | 70
ErrorDataSourceOperation |  | 71
ErrorDelegateAlreadyExists |  | 72
ErrorDelegateCannotAddOwner |  | 73
ErrorDelegateMissingConfiguration |  | 74
ErrorDelegateNoUser |  | 75
ErrorDelegateValidationFailed |  | 76
ErrorDeleteDistinguishedFolder |  | 77
ErrorDeleteItemsFailed |  | 78
ErrorDistinguishedUserNotSupported |  | 79
ErrorDistributionListMemberNotExist |  | 80
ErrorDuplicateInputFolderNames |  | 81
ErrorDuplicateUserIdsSpecified |  | 82
ErrorEmailAddressMismatch |  | 83
ErrorEventNotFound |  | 84
ErrorExceededConnectionCount |  | 85
ErrorExceededSubscriptionCount |  | 86
ErrorExceededFindCountLimit |  | 87
ErrorExpiredSubscription |  | 88
ErrorFolderCorrupt |  | 89
ErrorFolderNotFound |  | 90
ErrorFolderPropertRequestFailed |  | 91
ErrorFolderSave |  | 92
ErrorFolderSaveFailed |  | 93
ErrorFolderSavePropertyError |  | 94
ErrorFolderExists |  | 95
ErrorFreeBusyGenerationFailed |  | 96
ErrorGetServerSecurityDescriptorFailed |  | 97
ErrorImpersonateUserDenied |  | 98
ErrorImpersonationDenied |  | 99
ErrorImpersonationFailed |  | 100
ErrorIncorrectSchemaVersion |  | 101
ErrorIncorrectUpdatePropertyCount |  | 102
ErrorIndividualMailboxLimitReached |  | 103
ErrorInsufficientResources |  | 104
ErrorInternalServerError |  | 105
ErrorInternalServerTransientError |  | 106
ErrorInvalidAccessLevel |  | 107
ErrorInvalidArgument |  | 108
ErrorInvalidAttachmentId |  | 109
ErrorInvalidAttachmentSubfilter |  | 110
ErrorInvalidAttachmentSubfilterTextFilter |  | 111
ErrorInvalidAuthorizationContext |  | 112
ErrorInvalidChangeKey |  | 113
ErrorInvalidClientSecurityContext |  | 114
ErrorInvalidCompleteDate |  | 115
ErrorInvalidContactEmailAddress |  | 116
ErrorInvalidContactEmailIndex |  | 117
ErrorInvalidCrossForestCredentials |  | 118
ErrorInvalidDelegatePermission |  | 119
ErrorInvalidDelegateUserId |  | 120
ErrorInvalidExcludesRestriction |  | 121
ErrorInvalidExpressionTypeForSubFilter |  | 122
ErrorInvalidExtendedProperty |  | 123
ErrorInvalidExtendedPropertyValue |  | 124
ErrorInvalidFolderId |  | 125
ErrorInvalidFolderTypeForOperation |  | 126
ErrorInvalidFractionalPagingParameters |  | 127
ErrorInvalidFreeBusyViewType |  | 128
ErrorInvalidId |  | 129
ErrorInvalidIdEmpty |  | 130
ErrorInvalidIdMalformed |  | 131
ErrorInvalidIdMalformedEwsLegacyIdFormat |  | 132
ErrorInvalidIdMonikerTooLong |  | 133
ErrorInvalidIdNotAnItemAttachmentId |  | 134
ErrorInvalidIdReturnedByResolveNames |  | 135
ErrorInvalidIdStoreObjectIdTooLong |  | 136
ErrorInvalidIdTooManyAttachmentLevels |  | 137
ErrorInvalidIdXml |  | 138
ErrorInvalidIndexedPagingParameters |  | 139
ErrorInvalidInternetHeaderChildNodes |  | 140
ErrorInvalidItemForOperationCreateItemAttachment |  | 141
ErrorInvalidItemForOperationCreateItem |  | 142
ErrorInvalidItemForOperationAcceptItem |  | 143
ErrorInvalidItemForOperationDeclineItem |  | 144
ErrorInvalidItemForOperationCancelItem |  | 145
ErrorInvalidItemForOperationExpandDL |  | 146
ErrorInvalidItemForOperationRemoveItem |  | 147
ErrorInvalidItemForOperationSendItem |  | 148
ErrorInvalidItemForOperationTentative |  | 149
ErrorInvalidLogonType |  | 150
ErrorInvalidMailbox |  | 151
ErrorInvalidManagedFolderProperty |  | 152
ErrorInvalidManagedFolderQuota |  | 153
ErrorInvalidManagedFolderSize |  | 154
ErrorInvalidMergedFreeBusyInterval |  | 155
ErrorInvalidNameForNameResolution |  | 156
ErrorInvalidOperation |  | 157
ErrorInvalidNetworkServiceContext |  | 158
ErrorInvalidOofParameter |  | 159
ErrorInvalidPagingMaxRows |  | 160
ErrorInvalidParentFolder |  | 161
ErrorInvalidPercentCompleteValue |  | 162
ErrorInvalidPermissionSettings |  | 163
ErrorInvalidPhoneCallId |  | 164
ErrorInvalidPhoneNumber |  | 165
ErrorInvalidUserInfo |  | 166
ErrorInvalidPropertyAppend |  | 167
ErrorInvalidPropertyDelete |  | 168
ErrorInvalidPropertyForExists |  | 169
ErrorInvalidPropertyForOperation |  | 170
ErrorInvalidPropertyRequest |  | 171
ErrorInvalidPropertySet |  | 172
ErrorInvalidPropertyUpdateSentMessage |  | 173
ErrorInvalidProxySecurityContext |  | 174
ErrorInvalidPullSubscriptionId |  | 175
ErrorInvalidPushSubscriptionUrl |  | 176
ErrorInvalidRecipients |  | 177
ErrorInvalidRecipientSubfilter |  | 178
ErrorInvalidRecipientSubfilterComparison |  | 179
ErrorInvalidRecipientSubfilterOrder |  | 180
ErrorInvalidRecipientSubfilterTextFilter |  | 181
ErrorInvalidReferenceItem |  | 182
ErrorInvalidRequest |  | 183
ErrorInvalidRestriction |  | 184
ErrorInvalidRoutingType |  | 185
ErrorInvalidScheduledOofDuration |  | 186
ErrorInvalidSchemaVersionForMailboxVersion |  | 187
ErrorInvalidSecurityDescriptor |  | 188
ErrorInvalidSendItemSaveSettings |  | 189
ErrorInvalidSerializedAccessToken |  | 190
ErrorInvalidServerVersion |  | 191
ErrorInvalidSid |  | 192
ErrorInvalidSIPUri |  | 193
ErrorInvalidSmtpAddress |  | 194
ErrorInvalidSubfilterType |  | 195
ErrorInvalidSubfilterTypeNotAttendeeType |  | 196
ErrorInvalidSubfilterTypeNotRecipientType |  | 197
ErrorInvalidSubscription |  | 198
ErrorInvalidSubscriptionRequest |  | 199
ErrorInvalidSyncStateData |  | 200
ErrorInvalidTimeInterval |  | 201
ErrorInvalidUserOofSettings |  | 202
ErrorInvalidUserPrincipalName |  | 203
ErrorInvalidUserSid |  | 204
ErrorInvalidUserSidMissingUPN |  | 205
ErrorInvalidValueForProperty |  | 206
ErrorInvalidWatermark |  | 207
ErrorIPGatewayNotFound |  | 208
ErrorIrresolvableConflict |  | 209
ErrorItemCorrupt |  | 210
ErrorItemNotFound |  | 211
ErrorItemPropertyRequestFailed |  | 212
ErrorItemSave |  | 213
ErrorItemSavePropertyError |  | 214
ErrorLegacyMailboxFreeBusyViewTypeNotMerged |  | 215
ErrorLocalServerObjectNotFound |  | 216
ErrorLogonAsNetworkServiceFailed |  | 217
ErrorMailboxConfiguration |  | 218
ErrorMailboxDataArrayEmpty |  | 219
ErrorMailboxDataArrayTooBig |  | 220
ErrorMailboxLogonFailed |  | 221
ErrorMailboxMoveInProgress |  | 222
ErrorMailboxStoreUnavailable |  | 223
ErrorMailRecipientNotFound |  | 224
ErrorMailTipsDisabled |  | 225
ErrorManagedFolderAlreadyExists |  | 226
ErrorManagedFolderNotFound |  | 227
ErrorManagedFoldersRootFailure |  | 228
ErrorMeetingSuggestionGenerationFailed |  | 229
ErrorMessageDispositionRequired |  | 230
ErrorMessageSizeExceeded |  | 231
ErrorMimeContentConversionFailed |  | 232
ErrorMimeContentInvalid |  | 233
ErrorMimeContentInvalidBase64String |  | 234
ErrorMissingArgument |  | 235
ErrorMissingEmailAddress |  | 236
ErrorMissingEmailAddressForManagedFolder |  | 237
ErrorMissingInformationEmailAddress |  | 238
ErrorMissingInformationReferenceItemId |  | 239
ErrorMissingItemForCreateItemAttachment |  | 240
ErrorMissingManagedFolderId |  | 241
ErrorMissingRecipients |  | 242
ErrorMissingUserIdInformation |  | 243
ErrorMoreThanOneAccessModeSpecified |  | 244
ErrorMoveCopyFailed |  | 245
ErrorMoveDistinguishedFolder |  | 246
ErrorNameResolutionMultipleResults |  | 247
ErrorNameResolutionNoMailbox |  | 248
ErrorNameResolutionNoResults |  | 249
ErrorNoCalendar |  | 250
ErrorNoDestinationCASDueToKerberosRequirements |  | 251
ErrorNoDestinationCASDueToSSLRequirements |  | 252
ErrorNoDestinationCASDueToVersionMismatch |  | 253
ErrorNoFolderClassOverride |  | 254
ErrorNoFreeBusyAccess |  | 255
ErrorNonExistentMailbox |  | 256
ErrorNonPrimarySmtpAddress |  | 257
ErrorNoPropertyTagForCustomProperties |  | 258
ErrorNoPublicFolderReplicaAvailable |  | 259
ErrorNoRespondingCASInDestinationSite |  | 260
ErrorNotDelegate |  | 261
ErrorNotEnoughMemory |  | 262
ErrorObjectTypeChanged |  | 263
ErrorOccurrenceCrossingBoundary |  | 264
ErrorOccurrenceTimeSpanTooBig |  | 265
ErrorOperationNotAllowedWithPublicFolderRoot |  | 266
ErrorParentFolderIdRequired |  | 267
ErrorParentFolderNotFound |  | 268
ErrorPasswordChangeRequired |  | 269
ErrorPasswordExpired |  | 270
ErrorPhoneNumberNotDialable |  | 271
ErrorPropertyUpdate |  | 272
ErrorPropertyValidationFailure |  | 273
ErrorProxiedSubscriptionCallFailure |  | 274
ErrorProxyCallFailed |  | 275
ErrorProxyGroupSidLimitExceeded |  | 276
ErrorProxyRequestNotAllowed |  | 277
ErrorProxyRequestProcessingFailed |  | 278
ErrorProxyTokenExpired |  | 279
ErrorPublicFolderRequestProcessingFailed |  | 280
ErrorPublicFolderServerNotFound |  | 281
ErrorQueryFilterTooLong |  | 282
ErrorQuotaExceeded |  | 283
ErrorReadEventsFailed |  | 284
ErrorReadReceiptNotPending |  | 285
ErrorRecurrenceEndDateTooBig |  | 286
ErrorRecurrenceHasNoOccurrence |  | 287
ErrorRemoveDelegatesFailed |  | 288
ErrorRequestAborted |  | 289
ErrorRequestStreamTooBig |  | 290
ErrorRequiredPropertyMissing |  | 291
ErrorResolveNamesInvalidFolderType |  | 292
ErrorResolveNamesOnlyOneContactsFolderAllowed |  | 293
ErrorResponseSchemaValidation |  | 294
ErrorRestrictionTooLong |  | 295
ErrorRestrictionTooComplex |  | 296
ErrorResultSetTooBig |  | 297
ErrorInvalidExchangeImpersonationHeaderData |  | 298
ErrorSavedItemFolderNotFound |  | 299
ErrorSchemaValidation |  | 300
ErrorSearchFolderNotInitialized |  | 301
ErrorSendAsDenied |  | 302
ErrorSendMeetingCancellationsRequired |  | 303
ErrorSendMeetingInvitationsOrCancellationsRequired |  | 304
ErrorSendMeetingInvitationsRequired |  | 305
ErrorSentMeetingRequestUpdate |  | 306
ErrorSentTaskRequestUpdate |  | 307
ErrorServerBusy |  | 308
ErrorServiceDiscoveryFailed |  | 309
ErrorStaleObject |  | 310
ErrorSubmissionQuotaExceeded |  | 311
ErrorSubscriptionAccessDenied |  | 312
ErrorSubscriptionDelegateAccessNotSupported |  | 313
ErrorSubscriptionNotFound |  | 314
ErrorSyncFolderNotFound |  | 315
ErrorTimeIntervalTooBig |  | 316
ErrorTimeoutExpired |  | 317
ErrorTimeZone |  | 318
ErrorToFolderNotFound |  | 319
ErrorTokenSerializationDenied |  | 320
ErrorUpdatePropertyMismatch |  | 321
ErrorUnifiedMessagingDialPlanNotFound |  | 322
ErrorUnifiedMessagingRequestFailed |  | 323
ErrorUnifiedMessagingServerNotFound |  | 324
ErrorUnableToGetUserOofSettings |  | 325
ErrorUnsupportedSubFilter |  | 326
ErrorUnsupportedCulture |  | 327
ErrorUnsupportedMapiPropertyType |  | 328
ErrorUnsupportedMimeConversion |  | 329
ErrorUnsupportedPathForQuery |  | 330
ErrorUnsupportedPathForSortGroup |  | 331
ErrorUnsupportedPropertyDefinition |  | 332
ErrorUnsupportedQueryFilter |  | 333
ErrorUnsupportedRecurrence |  | 334
ErrorUnsupportedTypeForConversion |  | 335
ErrorUpdateDelegatesFailed |  | 336
ErrorUserNotUnifiedMessagingEnabled |  | 337
ErrorVoiceMailNotImplemented |  | 338
ErrorValueOutOfRange |  | 339
ErrorVirusDetected |  | 340
ErrorVirusMessageDeleted |  | 341
ErrorWebRequestInInvalidState |  | 342
ErrorWin32InteropError |  | 343
ErrorWorkingHoursSaveFailed |  | 344
ErrorWorkingHoursXmlMalformed |  | 345
ErrorWrongServerVersion |  | 346
ErrorWrongServerVersionDelegate |  | 347
ErrorMissingInformationSharingFolderId |  | 348
ErrorDuplicateSOAPHeader |  | 349
ErrorSharingSynchronizationFailed |  | 350
ErrorSharingNoExternalEwsAvailable |  | 351
ErrorFreeBusyDLLimitReached |  | 352
ErrorInvalidGetSharingFolderRequest |  | 353
ErrorNotAllowedExternalSharingByPolicy |  | 354
ErrorUserNotAllowedByPolicy |  | 355
ErrorPermissionNotAllowedByPolicy |  | 356
ErrorOrganizationNotFederated |  | 357
ErrorMailboxFailover |  | 358
ErrorInvalidExternalSharingInitiator |  | 359
ErrorMessageTrackingPermanentError |  | 360
ErrorMessageTrackingTransientError |  | 361
ErrorMessageTrackingNoSuchDomain |  | 362
ErrorUserWithoutFederatedProxyAddress |  | 363
ErrorInvalidOrganizationRelationshipForFreeBusy |  | 364
ErrorInvalidFederatedOrganizationId |  | 365
ErrorCannotEmptyFolder | This error is returned when the server cannot empty a folder. | 366
ErrorClientDisconnected | Specifies that the client was disconnected. | 367
ErrorNoApplicableProxyCASServersAvailable | This error code is returned when the Web service cannot find a server to handle the request. | 368
ErrorNoPublicFolderServerAvailable | This error code is returned if no public folder server is available or if the caller does not have a home public server. | 369
ErrorProxyServiceDiscoveryFailed | This error code is returned if the Web service cannot determine whether the request is to run on the target server or will be proxied to another server. | 370
ErrorSubscriptionUnsubscribed | This error code is returned when a request is made for a subscription that has been unsubscribed. | 371
ErrorOutlookRuleBlobExists | This error is returned when an attempt to manage Inbox rules occurs after another client has accessed the Inbox rules. | 372
ErrorRulesOverQuota | This error is returned when a user's rule quota has been exceeded. | 373
ErrorInboxRulesValidationError | This error is returned if any rule does not validate. | 374
ErrorNewEventStreamConnectionOpened | This error is returned to the first subscription connection if a second subscription connection is opened. | 375
ErrorMissedNotifcationEvents | This error is returned when event notifications are missed. | 376
ErrorApplyConversationActionFailed | This error is returned if an action cannot be applied to one or more items in the conversation. | 377
ErrorInvalidExternalSharingSubscriber |  | 378
ErrorInvalidSharingData |  | 379
ErrorInvalidSharingMessage |  | 380
ErrorNotSupportedSharingMessage |  | 381

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


ResponseMessageType Class

For a list of all members of this type, see ResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ResponseMessageType
Derived types

public class ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ResponseMessageType Members | Aspose.Email.Exchange.Schema Namespace


ResponseMessageType Members

ResponseMessageType overview

Public Instance Constructors

ResponseMessageType Constructor Initializes a new instance of the ResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey
DescriptiveLinkKeySpecified
MessageText
MessageXml
ResponseClass
ResponseCode
ResponseCodeSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


ResponseMessageType Constructor

Initializes a new instance of the ResponseMessageType class.

public ResponseMessageType();

See Also

ResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


ResponseMessageType Properties

The properties of the ResponseMessageType class are listed below. For a complete list of ResponseMessageType class members, see the ResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey
DescriptiveLinkKeySpecified
MessageText
MessageXml
ResponseClass
ResponseCode
ResponseCodeSpecified

See Also

ResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


DescriptiveLinkKey Property

Aspose.Email

ResponseMessageType.DescriptiveLinkKey Property

public int DescriptiveLinkKey {get; set;}

Remarks

See Also

ResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


DescriptiveLinkKeySpecified Property

Aspose.Email

ResponseMessageType.DescriptiveLinkKeySpecified Property

public bool DescriptiveLinkKeySpecified {get; set;}

Remarks

See Also

ResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


MessageText Property

Aspose.Email

ResponseMessageType.MessageText Property

public string MessageText {get; set;}

Remarks

See Also

ResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


MessageXml Property

Aspose.Email

ResponseMessageType.MessageXml Property

public ResponseMessageTypeMessageXml MessageXml {get; set;}

Remarks

See Also

ResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


ResponseClass Property

Aspose.Email

ResponseMessageType.ResponseClass Property

public ResponseClassType ResponseClass {get; set;}

Remarks

See Also

ResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


ResponseCode Property

Aspose.Email

ResponseMessageType.ResponseCode Property

public ResponseCodeType ResponseCode {get; set;}

Remarks

See Also

ResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


ResponseCodeSpecified Property

Aspose.Email

ResponseMessageType.ResponseCodeSpecified Property

public bool ResponseCodeSpecified {get; set;}

Remarks

See Also

ResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


ResponseMessageTypeMessageXml Class

For a list of all members of this type, see ResponseMessageTypeMessageXml Members.

System.Object
Aspose.Email.Exchange.Schema.ResponseMessageTypeMessageXml

public class ResponseMessageTypeMessageXml

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ResponseMessageTypeMessageXml Members | Aspose.Email.Exchange.Schema Namespace


ResponseMessageTypeMessageXml Members

ResponseMessageTypeMessageXml overview

Public Instance Constructors

ResponseMessageTypeMessageXml Constructor Initializes a new instance of the ResponseMessageTypeMessageXml class.

Public Instance Properties

Any

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ResponseMessageTypeMessageXml Class | Aspose.Email.Exchange.Schema Namespace


ResponseMessageTypeMessageXml Constructor

Initializes a new instance of the ResponseMessageTypeMessageXml class.

public ResponseMessageTypeMessageXml();

See Also

ResponseMessageTypeMessageXml Class | Aspose.Email.Exchange.Schema Namespace


ResponseMessageTypeMessageXml Properties

The properties of the ResponseMessageTypeMessageXml class are listed below. For a complete list of ResponseMessageTypeMessageXml class members, see the ResponseMessageTypeMessageXml Members topic.

Public Instance Properties

Any

See Also

ResponseMessageTypeMessageXml Class | Aspose.Email.Exchange.Schema Namespace


Any Property

Aspose.Email

ResponseMessageTypeMessageXml.Any Property

public XmlElement[] Any {get; set;}

Remarks

See Also

ResponseMessageTypeMessageXml Class | Aspose.Email.Exchange.Schema Namespace


ResponseObjectCoreType Class

For a list of all members of this type, see ResponseObjectCoreType Members.

System.Object
Aspose.Email.Exchange.Schema.ItemType
Aspose.Email.Exchange.Schema.MessageType
Aspose.Email.Exchange.Schema.ResponseObjectCoreType
Aspose.Email.Exchange.Schema.ResponseObjectType

public abstract class ResponseObjectCoreType : MessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ResponseObjectCoreType Members | Aspose.Email.Exchange.Schema Namespace


ResponseObjectCoreType Members

ResponseObjectCoreType overview

Public Instance Properties

Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
From (inherited from MessageType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
ParentFolderId (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
ReferenceItemId
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
Subject (inherited from ItemType)
ToRecipients (inherited from MessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

ResponseObjectCoreType Constructor Initializes a new instance of the ResponseObjectCoreType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ResponseObjectCoreType Class | Aspose.Email.Exchange.Schema Namespace


ResponseObjectCoreType Constructor

Initializes a new instance of the ResponseObjectCoreType class.

protected ResponseObjectCoreType();

See Also

ResponseObjectCoreType Class | Aspose.Email.Exchange.Schema Namespace


ResponseObjectCoreType Properties

The properties of the ResponseObjectCoreType class are listed below. For a complete list of ResponseObjectCoreType class members, see the ResponseObjectCoreType Members topic.

Public Instance Properties

Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
From (inherited from MessageType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
ParentFolderId (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
ReferenceItemId
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
Subject (inherited from ItemType)
ToRecipients (inherited from MessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

See Also

ResponseObjectCoreType Class | Aspose.Email.Exchange.Schema Namespace


ReferenceItemId Property

Aspose.Email

ResponseObjectCoreType.ReferenceItemId Property

public ItemIdType ReferenceItemId {get; set;}

Remarks

See Also

ResponseObjectCoreType Class | Aspose.Email.Exchange.Schema Namespace


ResponseObjectType Class

For a list of all members of this type, see ResponseObjectType Members.

System.Object
Aspose.Email.Exchange.Schema.ItemType
Aspose.Email.Exchange.Schema.MessageType
Aspose.Email.Exchange.Schema.ResponseObjectCoreType
Aspose.Email.Exchange.Schema.ResponseObjectType
Aspose.Email.Exchange.Schema.PostReplyItemBaseType
Aspose.Email.Exchange.Schema.ReferenceItemResponseType
Aspose.Email.Exchange.Schema.RemoveItemType
Aspose.Email.Exchange.Schema.SmartResponseBaseType
Aspose.Email.Exchange.Schema.WellKnownResponseObjectType

public abstract class ResponseObjectType : ResponseObjectCoreType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ResponseObjectType Members | Aspose.Email.Exchange.Schema Namespace


ResponseObjectType Members

ResponseObjectType overview

Public Instance Properties

Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
From (inherited from MessageType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
ObjectName
ParentFolderId (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
ReferenceItemId (inherited from ResponseObjectCoreType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
Subject (inherited from ItemType)
ToRecipients (inherited from MessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

ResponseObjectType Constructor Initializes a new instance of the ResponseObjectType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ResponseObjectType Class | Aspose.Email.Exchange.Schema Namespace


ResponseObjectType Constructor

Initializes a new instance of the ResponseObjectType class.

protected ResponseObjectType();

See Also

ResponseObjectType Class | Aspose.Email.Exchange.Schema Namespace


ResponseObjectType Properties

The properties of the ResponseObjectType class are listed below. For a complete list of ResponseObjectType class members, see the ResponseObjectType Members topic.

Public Instance Properties

Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
From (inherited from MessageType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
ObjectName
ParentFolderId (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
ReferenceItemId (inherited from ResponseObjectCoreType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
Subject (inherited from ItemType)
ToRecipients (inherited from MessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

See Also

ResponseObjectType Class | Aspose.Email.Exchange.Schema Namespace


ObjectName Property

Aspose.Email

ResponseObjectType.ObjectName Property

public string ObjectName {get; set;}

Remarks

See Also

ResponseObjectType Class | Aspose.Email.Exchange.Schema Namespace


ResponseTypeType Enumeration

public enum ResponseTypeType

Remarks

Members

Member Name | Description | Value
Unknown |  | 0
Organizer |  | 1
Tentative |  | 2
Accept |  | 3
Decline |  | 4
NoResponseReceived |  | 5

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


RestrictionType Class

For a list of all members of this type, see RestrictionType Members.

System.Object
Aspose.Email.Exchange.Schema.RestrictionType

public class RestrictionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RestrictionType Members | Aspose.Email.Exchange.Schema Namespace


RestrictionType Members

RestrictionType overview

Public Instance Constructors

RestrictionType Constructor Initializes a new instance of the RestrictionType class.

Public Instance Properties

Item

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RestrictionType Class | Aspose.Email.Exchange.Schema Namespace


RestrictionType Constructor

Initializes a new instance of the RestrictionType class.

public RestrictionType();

See Also

RestrictionType Class | Aspose.Email.Exchange.Schema Namespace


RestrictionType Properties

The properties of the RestrictionType class are listed below. For a complete list of RestrictionType class members, see the RestrictionType Members topic.

Public Instance Properties

Item

See Also

RestrictionType Class | Aspose.Email.Exchange.Schema Namespace


Item Property

Aspose.Email

RestrictionType.Item Property

public SearchExpressionType Item {get; set;}

Remarks

See Also

RestrictionType Class | Aspose.Email.Exchange.Schema Namespace


RoomType Class

For a list of all members of this type, see RoomType Members.

System.Object
Aspose.Email.Exchange.Schema.DirectoryEntryType
Aspose.Email.Exchange.Schema.RoomType

public class RoomType : DirectoryEntryType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RoomType Members | Aspose.Email.Exchange.Schema Namespace


RoomType Members

RoomType overview

Public Instance Constructors

RoomType Constructor Initializes a new instance of the RoomType class.

Public Instance Properties

Id (inherited from DirectoryEntryType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RoomType Class | Aspose.Email.Exchange.Schema Namespace


RoomType Constructor

Initializes a new instance of the RoomType class.

public RoomType();

See Also

RoomType Class | Aspose.Email.Exchange.Schema Namespace


RootItemIdType Class

For a list of all members of this type, see RootItemIdType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseItemIdType
Aspose.Email.Exchange.Schema.RootItemIdType

public class RootItemIdType : BaseItemIdType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RootItemIdType Members | Aspose.Email.Exchange.Schema Namespace


RootItemIdType Members

RootItemIdType overview

Public Instance Constructors

RootItemIdType Constructor Initializes a new instance of the RootItemIdType class.

Public Instance Properties

RootItemChangeKey
RootItemId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RootItemIdType Class | Aspose.Email.Exchange.Schema Namespace


RootItemIdType Constructor

Initializes a new instance of the RootItemIdType class.

public RootItemIdType();

See Also

RootItemIdType Class | Aspose.Email.Exchange.Schema Namespace


RootItemIdType Properties

The properties of the RootItemIdType class are listed below. For a complete list of RootItemIdType class members, see the RootItemIdType Members topic.

Public Instance Properties

RootItemChangeKey
RootItemId

See Also

RootItemIdType Class | Aspose.Email.Exchange.Schema Namespace


RootItemChangeKey Property

Aspose.Email

RootItemIdType.RootItemChangeKey Property

public string RootItemChangeKey {get; set;}

Remarks

See Also

RootItemIdType Class | Aspose.Email.Exchange.Schema Namespace


RootItemId Property

Aspose.Email

RootItemIdType.RootItemId Property

public string RootItemId {get; set;}

Remarks

See Also

RootItemIdType Class | Aspose.Email.Exchange.Schema Namespace


RuleActionsType Class

Represents RuleActionType

For a list of all members of this type, see RuleActionsType Members.

System.Object
Aspose.Email.Exchange.Schema.RuleActionsType

public class RuleActionsType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RuleActionsType Members | Aspose.Email.Exchange.Schema Namespace


RuleActionsType Members

RuleActionsType overview

Public Instance Constructors

RuleActionsType Constructor Initializes a new instance of the RuleActionsType class.

Public Instance Properties

AssignCategories | Gets or sets the categories that are stamped on e-mail messages.
CopyToFolder | Gets or sets the ID of the folder that e-mail items will be copied to.
Delete | Gets or sets a value indicating whether messages are to be moved to the Deleted Items folder.
DeleteSpecified | Gets or sets a value indicating whether the Delete property is specified
ForwardAsAttachmentToRecipients | Gets or sets the e-mail addresses to which messages are to be forwarded as attachments.
ForwardToRecipients | Gets or sets the e-mail addresses to which messages are to be forwarded.
MarkAsRead | Gets or sets a value indicating whether messages are to be marked as read.
MarkAsReadSpecified | Gets or sets a value indicating whether the MarkAsRead property is specified
MarkImportance | Gets or sets the importance that is to be stamped on messages.
MarkImportanceSpecified | Gets or sets a value indicating whether the MarkImportance property is specified
MoveToFolder | Gets or sets the ID of the folder that e-mail items will be moved to.
PermanentDelete | Gets or sets a value indicating whether messages are to be permanently deleted and not saved to the Deleted Items folder.
PermanentDeleteSpecified | Gets or sets a value indicating whether the PermanentDelete property is specified
RedirectToRecipients | Gets or sets the e-mail addresses to which messages are to be redirected.
SendSMSAlertToRecipients | Gets or sets the mobile phone numbers to which a Short Message Service (SMS) alert is to be sent.
ServerReplyWithMessage | Gets or sets the ID of the template message that is to be sent as a reply to incoming messages.
StopProcessingRules | Gets or sets a value indicating whether subsequent rules are to be evaluated.
StopProcessingRulesSpecified | Gets or sets a value indicating whether the StopProcessingRules property is specified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RuleActionsType Class | Aspose.Email.Exchange.Schema Namespace


RuleActionsType Constructor

Initializes a new instance of the RuleActionsType class.

public RuleActionsType();

See Also

RuleActionsType Class | Aspose.Email.Exchange.Schema Namespace


RuleActionsType Properties

The properties of the RuleActionsType class are listed below. For a complete list of RuleActionsType class members, see the RuleActionsType Members topic.

Public Instance Properties

AssignCategories | Gets or sets the categories that are stamped on e-mail messages.
CopyToFolder | Gets or sets the ID of the folder that e-mail items will be copied to.
Delete | Gets or sets a value indicating whether messages are to be moved to the Deleted Items folder.
DeleteSpecified | Gets or sets a value indicating whether the Delete property is specified
ForwardAsAttachmentToRecipients | Gets or sets the e-mail addresses to which messages are to be forwarded as attachments.
ForwardToRecipients | Gets or sets the e-mail addresses to which messages are to be forwarded.
MarkAsRead | Gets or sets a value indicating whether messages are to be marked as read.
MarkAsReadSpecified | Gets or sets a value indicating whether the MarkAsRead property is specified
MarkImportance | Gets or sets the importance that is to be stamped on messages.
MarkImportanceSpecified | Gets or sets a value indicating whether the MarkImportance property is specified
MoveToFolder | Gets or sets the ID of the folder that e-mail items will be moved to.
PermanentDelete | Gets or sets a value indicating whether messages are to be permanently deleted and not saved to the Deleted Items folder.
PermanentDeleteSpecified | Gets or sets a value indicating whether the PermanentDelete property is specified
RedirectToRecipients | Gets or sets the e-mail addresses to which messages are to be redirected.
SendSMSAlertToRecipients | Gets or sets the mobile phone numbers to which a Short Message Service (SMS) alert is to be sent.
ServerReplyWithMessage | Gets or sets the ID of the template message that is to be sent as a reply to incoming messages.
StopProcessingRules | Gets or sets a value indicating whether subsequent rules are to be evaluated.
StopProcessingRulesSpecified | Gets or sets a value indicating whether the StopProcessingRules property is specified

See Also

RuleActionsType Class | Aspose.Email.Exchange.Schema Namespace


AssignCategories Property

Aspose.Email

RuleActionsType.AssignCategories Property

Gets or sets the categories that are stamped on e-mail messages.

public string[] AssignCategories {get; set;}

See Also

RuleActionsType Class | Aspose.Email.Exchange.Schema Namespace


CopyToFolder Property

Aspose.Email

RuleActionsType.CopyToFolder Property

Gets or sets the ID of the folder that e-mail items will be copied to.

public TargetFolderIdType CopyToFolder {get; set;}

See Also

RuleActionsType Class | Aspose.Email.Exchange.Schema Namespace


Delete Property

Aspose.Email

RuleActionsType.Delete Property

Gets or sets a value indicating whether messages are to be moved to the Deleted Items folder.

public bool Delete {get; set;}

See Also

RuleActionsType Class | Aspose.Email.Exchange.Schema Namespace


DeleteSpecified Property

Aspose.Email

RuleActionsType.DeleteSpecified Property

Gets or sets a value indicating whether the Delete property is specified

public bool DeleteSpecified {get; set;}

See Also

RuleActionsType Class | Aspose.Email.Exchange.Schema Namespace


ForwardAsAttachmentToRecipients Property

Aspose.Email

RuleActionsType.ForwardAsAttachmentToRecipients Property

Gets or sets the e-mail addresses to which messages are to be forwarded as attachments.

public EmailAddressType[] ForwardAsAttachmentToRecipients {get; set;}

See Also

RuleActionsType Class | Aspose.Email.Exchange.Schema Namespace


ForwardToRecipients Property

Aspose.Email

RuleActionsType.ForwardToRecipients Property

Gets or sets the e-mail addresses to which messages are to be forwarded.

public EmailAddressType[] ForwardToRecipients {get; set;}

See Also

RuleActionsType Class | Aspose.Email.Exchange.Schema Namespace


MarkAsRead Property

Aspose.Email

RuleActionsType.MarkAsRead Property

Gets or sets a value indicating whether messages are to be marked as read.

public bool MarkAsRead {get; set;}

See Also

RuleActionsType Class | Aspose.Email.Exchange.Schema Namespace


MarkAsReadSpecified Property

Aspose.Email

RuleActionsType.MarkAsReadSpecified Property

Gets or sets a value indicating whether the MarkAsRead property is specified

public bool MarkAsReadSpecified {get; set;}

See Also

RuleActionsType Class | Aspose.Email.Exchange.Schema Namespace


MarkImportance Property

Aspose.Email

RuleActionsType.MarkImportance Property

Gets or sets the importance that is to be stamped on messages.

public ImportanceChoicesType MarkImportance {get; set;}

See Also

RuleActionsType Class | Aspose.Email.Exchange.Schema Namespace


MarkImportanceSpecified Property

Aspose.Email

RuleActionsType.MarkImportanceSpecified Property

Gets or sets a value indicating whether the MarkImportance property is specified

public bool MarkImportanceSpecified {get; set;}

See Also

RuleActionsType Class | Aspose.Email.Exchange.Schema Namespace


MoveToFolder Property

Aspose.Email

RuleActionsType.MoveToFolder Property

Gets or sets the ID of the folder that e-mail items will be moved to.

public TargetFolderIdType MoveToFolder {get; set;}

See Also

RuleActionsType Class | Aspose.Email.Exchange.Schema Namespace


PermanentDelete Property

Aspose.Email

RuleActionsType.PermanentDelete Property

Gets or sets a value indicating whether messages are to be permanently deleted and not saved to the Deleted Items folder.

public bool PermanentDelete {get; set;}

See Also

RuleActionsType Class | Aspose.Email.Exchange.Schema Namespace


PermanentDeleteSpecified Property

Aspose.Email

RuleActionsType.PermanentDeleteSpecified Property

Gets or sets a value indicating whether the PermanentDelete property is specified

public bool PermanentDeleteSpecified {get; set;}

See Also

RuleActionsType Class | Aspose.Email.Exchange.Schema Namespace


RedirectToRecipients Property

Aspose.Email

RuleActionsType.RedirectToRecipients Property

Gets or sets the e-mail addresses to which messages are to be redirected.

public EmailAddressType[] RedirectToRecipients {get; set;}

See Also

RuleActionsType Class | Aspose.Email.Exchange.Schema Namespace


SendSMSAlertToRecipients Property

Aspose.Email

RuleActionsType.SendSMSAlertToRecipients Property

Gets or sets the mobile phone numbers to which a Short Message Service (SMS) alert is to be sent.

public EmailAddressType[] SendSMSAlertToRecipients {get; set;}

See Also

RuleActionsType Class | Aspose.Email.Exchange.Schema Namespace


ServerReplyWithMessage Property

Aspose.Email

RuleActionsType.ServerReplyWithMessage Property

Gets or sets the ID of the template message that is to be sent as a reply to incoming messages.

public ItemIdType ServerReplyWithMessage {get; set;}

See Also

RuleActionsType Class | Aspose.Email.Exchange.Schema Namespace


StopProcessingRules Property

Aspose.Email

RuleActionsType.StopProcessingRules Property

Gets or sets a value indicating whether subsequent rules are to be evaluated.

public bool StopProcessingRules {get; set;}

See Also

RuleActionsType Class | Aspose.Email.Exchange.Schema Namespace


StopProcessingRulesSpecified Property

Aspose.Email

RuleActionsType.StopProcessingRulesSpecified Property

Gets or sets a value indicating whether the StopProcessingRules property is specified

public bool StopProcessingRulesSpecified {get; set;}

See Also

RuleActionsType Class | Aspose.Email.Exchange.Schema Namespace


RuleFieldURIType Enumeration

Enumerates all possible rule fields that could trigger a validation error.

public enum RuleFieldURIType

Members

Member Name | Description | Value
RuleId | The rule ID. | 0
DisplayName | The rule display name. | 1
Priority | The rule priority. | 2
IsNotSupported | The rule is not supported. | 3
Actions | The rule actions. | 4
ConditionCategories | The categories condition. | 5
ConditionContainsBodyStrings | The contains body strings condition. | 6
ConditionContainsHeaderStrings | The contains header strings condition. | 7
ConditionContainsRecipientStrings | The contains recipient strings condition. | 8
ConditionContainsSenderStrings | The contains sender strings condition. | 9
ConditionContainsSubjectOrBodyStrings | The contains subject or body strings condition. | 10
ConditionContainsSubjectStrings | The contains subject strings condition. | 11
ConditionFlaggedForAction | The flagged for action condition. | 12
ConditionFromAddresses | The from addresses condition. | 13
ConditionFromConnectedAccounts | The from connected accounts condition. | 14
ConditionHasAttachments | The has attachments condition. | 15
ConditionImportance | The importance condition property of a rule's set of conditions. | 16
ConditionIsApprovalRequest | The is approval request condition. | 17
ConditionIsAutomaticForward | The is automatic forward condition. | 18
ConditionIsAutomaticReply | The is automatic reply condition. | 19
ConditionIsEncrypted | The is encrypted condition. | 20
ConditionIsMeetingRequest | The is meeting request condition. | 21
ConditionIsMeetingResponse | The is meeting response condition. | 22
ConditionIsNDR | The non-delivery report (NDR) condition. | 23
ConditionIsPermissionControlled | The is permission controlled condition. | 24
ConditionIsReadReceipt | The is read condition. | 25
ConditionIsSigned | The is signed condition. | 26
ConditionIsVoicemail | The is voicemail condition. | 27
ConditionItemClasses | The item class condition. | 28
ConditionMessageClassifications | The message classifications condition. | 29
ConditionNotSentToMe | The not sent to me condition. | 30
ConditionSentCcMe | The sent Cc me condition. | 31
ConditionSentOnlyToMe | The sent only to me condition. | 32
ConditionSentToAddresses | The sent to addresses condition. | 33
ConditionSentToMe | The sent to me condition. | 34
ConditionSentToOrCcMe | The sent to or Cc me condition. | 35
ConditionSensitivity | The sensitivity condition. | 36
ConditionWithinDateRange | The within date range condition. | 37
ConditionWithinSizeRange | The within size range condition. | 38
ExceptionCategories | The categories exception. | 39
ExceptionContainsBodyStrings | The contains body strings exception. | 40
ExceptionContainsHeaderStrings | The contains header strings exception. | 41
ExceptionContainsRecipientStrings | The contains recipient strings exception. | 42
ExceptionContainsSenderStrings | The contains sender strings exception. | 43
ExceptionContainsSubjectOrBodyStrings | The contains subject or body strings exception. | 44
ExceptionContainsSubjectStrings | The contains subject strings exception. | 45
ExceptionFlaggedForAction | The flagged for action exception. | 46
ExceptionFromAddresses | The from addresses exception. | 47
ExceptionFromConnectedAccounts | The from connected accounts exception. | 48
ExceptionHasAttachments | The has attachments exception. | 49
ExceptionImportance | The importance exception. | 50
ExceptionIsApprovalRequest | The is approval request exception. | 51
ExceptionIsAutomaticForward | The is automatic forward exception | 52
ExceptionIsAutomaticReply | The is automatic reply exception. | 53
ExceptionIsEncrypted | The is encrypted exception. | 54
ExceptionIsMeetingRequest | The is meeting request exception. | 55
ExceptionIsMeetingResponse | The is meeting response exception. | 56
ExceptionIsNDR | The NDR exception. | 57
ExceptionIsPermissionControlled | The is permission controlled exception. | 58
ExceptionIsReadReceipt | The is read exception. | 59
ExceptionIsSigned | The is signed exception. | 60
ExceptionIsVoicemail | The is voice mail exception. | 61
ExceptionItemClasses | The item class exception. | 62
ExceptionMessageClassifications | The message classifications exception. | 63
ExceptionNotSentToMe | The not sent to me exception. | 64
ExceptionSentCcMe | The sent to me exception. | 65
ExceptionSentOnlyToMe | The sent only to me exception. | 66
ExceptionSentToAddresses | The sent to addresses exception. | 67
ExceptionSentToMe | The sent to me exception. | 68
ExceptionSentToOrCcMe | The sent to or Cc me exception. | 69
ExceptionSensitivity | The sensitivity exception. | 70
ExceptionWithinDateRange | The within date range exception. | 71
ExceptionWithinSizeRange | The within size range exception. | 72
ActionAssignCategories | The assign categories action. | 73
ActionCopyToFolder | The copy to folder action. | 74
ActionDelete | The delete action. | 75
ActionForwardAsAttachmentToRecipients | The forward as attachment to recipients action. | 76
ActionForwardToRecipients | The forward to recipients action. | 77
ActionMarkImportance | The mark importance action. | 78
ActionMarkAsRead | The mark as read action. | 79
ActionMoveToFolder | The move to folder action. | 80
ActionPermanentDelete | The permanent delete action. | 81
ActionRedirectToRecipients | The redirect to recipients action. | 82
ActionSendSMSAlertToRecipients | The send SMS alert to recipients action. | 83
ActionServerReplyWithMessage | The server reply with message action. | 84
ActionStopProcessingRules | The stop processing rules action. | 85
IsEnabled | Indicates whether the rule is enabled. | 86
IsInError | Indicates whether the rule is in error. | 87
Conditions | Contains all conditions of the rule. | 88
Exceptions | Contains all the exceptions for the rule. | 89

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


RuleOperationErrorType Class

Represents a rule operation error.

For a list of all members of this type, see RuleOperationErrorType Members.

System.Object
Aspose.Email.Exchange.Schema.RuleOperationErrorType

public class RuleOperationErrorType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RuleOperationErrorType Members | Aspose.Email.Exchange.Schema Namespace


RuleOperationErrorType Members

RuleOperationErrorType overview

Public Instance Constructors

RuleOperationErrorType Constructor Initializes a new instance of the RuleOperationErrorType class.

Public Instance Properties

OperationIndex | Gets or sets the index of the operation in the request that caused the rule operation error.
ValidationErrors | Gets or sets an array of rule validation errors on each rule field that has an error.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RuleOperationErrorType Class | Aspose.Email.Exchange.Schema Namespace


RuleOperationErrorType Constructor

Initializes a new instance of the RuleOperationErrorType class.

public RuleOperationErrorType();

See Also

RuleOperationErrorType Class | Aspose.Email.Exchange.Schema Namespace


RuleOperationErrorType Properties

The properties of the RuleOperationErrorType class are listed below. For a complete list of RuleOperationErrorType class members, see the RuleOperationErrorType Members topic.

Public Instance Properties

OperationIndex | Gets or sets the index of the operation in the request that caused the rule operation error.
ValidationErrors | Gets or sets an array of rule validation errors on each rule field that has an error.

See Also

RuleOperationErrorType Class | Aspose.Email.Exchange.Schema Namespace


OperationIndex Property

Aspose.Email

RuleOperationErrorType.OperationIndex Property

Gets or sets the index of the operation in the request that caused the rule operation error.

public int OperationIndex {get; set;}

See Also

RuleOperationErrorType Class | Aspose.Email.Exchange.Schema Namespace


ValidationErrors Property

Aspose.Email

RuleOperationErrorType.ValidationErrors Property

Gets or sets an array of rule validation errors on each rule field that has an error.

public RuleValidationErrorType[] ValidationErrors {get; set;}

See Also

RuleOperationErrorType Class | Aspose.Email.Exchange.Schema Namespace


RuleOperationType Class

Represents the base rule operation type

For a list of all members of this type, see RuleOperationType Members.

System.Object
Aspose.Email.Exchange.Schema.RuleOperationType
Aspose.Email.Exchange.Schema.CreateRuleOperationType
Aspose.Email.Exchange.Schema.DeleteRuleOperationType
Aspose.Email.Exchange.Schema.SetRuleOperationType

public abstract class RuleOperationType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RuleOperationType Members | Aspose.Email.Exchange.Schema Namespace


RuleOperationType Members

RuleOperationType overview

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

RuleOperationType Constructor Initializes a new instance of the RuleOperationType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RuleOperationType Class | Aspose.Email.Exchange.Schema Namespace


RuleOperationType Constructor

Initializes a new instance of the RuleOperationType class.

protected RuleOperationType();

See Also

RuleOperationType Class | Aspose.Email.Exchange.Schema Namespace


RulePredicateDateRangeType Class

Represents RulePredicateDateRangeType class

For a list of all members of this type, see RulePredicateDateRangeType Members.

System.Object
Aspose.Email.Exchange.Schema.RulePredicateDateRangeType

public class RulePredicateDateRangeType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RulePredicateDateRangeType Members | Aspose.Email.Exchange.Schema Namespace


RulePredicateDateRangeType Members

RulePredicateDateRangeType overview

Public Instance Constructors

RulePredicateDateRangeType Constructor Initializes a new instance of the RulePredicateDateRangeType class.

Public Instance Properties

EndDateTime | Gets or sets the end date
EndDateTimeSpecified | Gets or sets a value indicating whether the EndDateTime is specified
StartDateTime | Gets or sets the start date
StartDateTimeSpecified | Gets or sets a value indicating whether the StartDateTime is specified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RulePredicateDateRangeType Class | Aspose.Email.Exchange.Schema Namespace


RulePredicateDateRangeType Constructor

Initializes a new instance of the RulePredicateDateRangeType class.

public RulePredicateDateRangeType();

See Also

RulePredicateDateRangeType Class | Aspose.Email.Exchange.Schema Namespace


RulePredicateDateRangeType Properties

The properties of the RulePredicateDateRangeType class are listed below. For a complete list of RulePredicateDateRangeType class members, see the RulePredicateDateRangeType Members topic.

Public Instance Properties

EndDateTime | Gets or sets the end date
EndDateTimeSpecified | Gets or sets a value indicating whether the EndDateTime is specified
StartDateTime | Gets or sets the start date
StartDateTimeSpecified | Gets or sets a value indicating whether the StartDateTime is specified

See Also

RulePredicateDateRangeType Class | Aspose.Email.Exchange.Schema Namespace


EndDateTime Property

Aspose.Email

RulePredicateDateRangeType.EndDateTime Property

Gets or sets the end date

public DateTime EndDateTime {get; set;}

See Also

RulePredicateDateRangeType Class | Aspose.Email.Exchange.Schema Namespace


EndDateTimeSpecified Property

Aspose.Email

RulePredicateDateRangeType.EndDateTimeSpecified Property

Gets or sets a value indicating whether the EndDateTime is specified

public bool EndDateTimeSpecified {get; set;}

See Also

RulePredicateDateRangeType Class | Aspose.Email.Exchange.Schema Namespace


StartDateTime Property

Aspose.Email

RulePredicateDateRangeType.StartDateTime Property

Gets or sets the start date

public DateTime StartDateTime {get; set;}

See Also

RulePredicateDateRangeType Class | Aspose.Email.Exchange.Schema Namespace


StartDateTimeSpecified Property

Aspose.Email

RulePredicateDateRangeType.StartDateTimeSpecified Property

Gets or sets a value indicating whether the StartDateTime is specified

public bool StartDateTimeSpecified {get; set;}

See Also

RulePredicateDateRangeType Class | Aspose.Email.Exchange.Schema Namespace


RulePredicateSizeRangeType Class

Represents RulePredicateSizeRangeType class

For a list of all members of this type, see RulePredicateSizeRangeType Members.

System.Object
Aspose.Email.Exchange.Schema.RulePredicateSizeRangeType

public class RulePredicateSizeRangeType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RulePredicateSizeRangeType Members | Aspose.Email.Exchange.Schema Namespace


RulePredicateSizeRangeType Members

RulePredicateSizeRangeType overview

Public Instance Constructors

RulePredicateSizeRangeType Constructor Initializes a new instance of the RulePredicateSizeRangeType class.

Public Instance Properties

MaximumSize | Gets or sets the maximum size of a message for the conditions or exception to apply.
MaximumSizeSpecified | Gets or sets a value indicating whether teh MaximumSize property is specified
MinimumSize | Gets or sets the minimum size of a message for the conditions or exception to apply.
MinimumSizeSpecified | Gets or sets a value indicating whether teh MinimumSize property is specified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RulePredicateSizeRangeType Class | Aspose.Email.Exchange.Schema Namespace


RulePredicateSizeRangeType Constructor

Initializes a new instance of the RulePredicateSizeRangeType class.

public RulePredicateSizeRangeType();

See Also

RulePredicateSizeRangeType Class | Aspose.Email.Exchange.Schema Namespace


RulePredicateSizeRangeType Properties

The properties of the RulePredicateSizeRangeType class are listed below. For a complete list of RulePredicateSizeRangeType class members, see the RulePredicateSizeRangeType Members topic.

Public Instance Properties

MaximumSize | Gets or sets the maximum size of a message for the conditions or exception to apply.
MaximumSizeSpecified | Gets or sets a value indicating whether teh MaximumSize property is specified
MinimumSize | Gets or sets the minimum size of a message for the conditions or exception to apply.
MinimumSizeSpecified | Gets or sets a value indicating whether teh MinimumSize property is specified

See Also

RulePredicateSizeRangeType Class | Aspose.Email.Exchange.Schema Namespace


MaximumSize Property

Aspose.Email

RulePredicateSizeRangeType.MaximumSize Property

Gets or sets the maximum size of a message for the conditions or exception to apply.

public int MaximumSize {get; set;}

See Also

RulePredicateSizeRangeType Class | Aspose.Email.Exchange.Schema Namespace


MaximumSizeSpecified Property

Aspose.Email

RulePredicateSizeRangeType.MaximumSizeSpecified Property

Gets or sets a value indicating whether teh MaximumSize property is specified

public bool MaximumSizeSpecified {get; set;}

See Also

RulePredicateSizeRangeType Class | Aspose.Email.Exchange.Schema Namespace


MinimumSize Property

Aspose.Email

RulePredicateSizeRangeType.MinimumSize Property

Gets or sets the minimum size of a message for the conditions or exception to apply.

public int MinimumSize {get; set;}

See Also

RulePredicateSizeRangeType Class | Aspose.Email.Exchange.Schema Namespace


MinimumSizeSpecified Property

Aspose.Email

RulePredicateSizeRangeType.MinimumSizeSpecified Property

Gets or sets a value indicating whether teh MinimumSize property is specified

public bool MinimumSizeSpecified {get; set;}

See Also

RulePredicateSizeRangeType Class | Aspose.Email.Exchange.Schema Namespace


RulePredicatesType Class

Represents RulePredicatesType

For a list of all members of this type, see RulePredicatesType Members.

System.Object
Aspose.Email.Exchange.Schema.RulePredicatesType

public class RulePredicatesType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RulePredicatesType Members | Aspose.Email.Exchange.Schema Namespace


RulePredicatesType Members

RulePredicatesType overview

Public Instance Constructors

RulePredicatesType Constructor Initializes a new instance of the RulePredicatesType class.

Public Instance Properties

Categories | Gets or sets the categories that an incoming message is labeled with in order for the condition or exception to apply.
ContainsBodyStrings | Gets or sets the strings that appear in the body of incoming messages in order for the condition or exception to apply.
ContainsHeaderStrings | Gets or sets the strings that appear in the headers of incoming messages in order for the condition or exception to apply.
ContainsRecipientStrings | Gets or sets the strings that appear in either the ToRecipients or CcRecipients properties of incoming messages in order for the condition or exception to apply.
ContainsSenderStrings | Gets or sets the strings that appears in the From property of incoming messages in order for the condition or exception to apply
ContainsSubjectOrBodyStrings | Gets or sets the strings that appear in either the body or the subject of incoming messages in order for the condition or exception to apply.
ContainsSubjectStrings | Gets or sets the strings that appear in the subject of incoming messages in order for the condition or exception to apply.
FlaggedForAction | Gets or sets the flag for action value that appears on incoming messages in order for the condition or exception to apply.
FlaggedForActionSpecified | Gets or sets a value indicating whether the FlaggedForAction is specified
FromAddresses | Gets or sets the e-mail addresses of the senders of incoming messages in order for the condition or exception to apply.
FromConnectedAccounts | Gets or sets the e-mail account names from which incoming messages have to have been aggregated in order for the condition or exception to apply.
HasAttachments | Gets or sets a value indicating whether incoming messages have to have attachments in order for the condition or exception to apply.
HasAttachmentsSpecified | Gets or sets a value indicating whether the HasAttachments is specified
Importance | Gets or sets the importance that is stamped on incoming messages in order for the condition or exception to apply.
ImportanceSpecified | Gets or sets a value indicating whether the Importance is specified
IsApprovalRequest | Gets or sets a value indicating whether incoming messages must be approval requests in order for the condition or exception to apply.
IsApprovalRequestSpecified | Gets or sets a value indicating whether the IsApprovalRequest is specified
IsAutomaticForward | Gets or sets a value indicating whether incoming messages must be automatic forwards in order for the condition or exception to apply.
IsAutomaticForwardSpecified | Gets or sets a value indicating whether the IsAutomaticForward is specified
IsAutomaticReply | Gets or sets a value indicating whether incoming messages must be automatic replies in order for the condition or exception to apply.
IsAutomaticReplySpecified | Gets or sets a value indicating whether the IsAutomaticReply is specified
IsEncrypted | Gets or sets a value indicating whether incoming messages must be S/MIME encrypted in order for the condition or exception to apply.
IsEncryptedSpecified | Gets or sets a value indicating whether the IsEncrypted is specified
IsMeetingRequest | Gets or sets a value indicating whether incoming messages must be meeting requests in order for the condition or exception to apply.
IsMeetingRequestSpecified | Gets or sets a value indicating whether the IsMeetingRequest is specified
IsMeetingResponse | Gets or sets a value indicating whether incoming messages must be meeting responses in order for the condition or exception to apply.
IsMeetingResponseSpecified | Gets or sets a value indicating whether the IsMeetingResponse is specified
IsNDR | Gets or sets a value indicating whether incoming messages must be non-delivery reports (NDRs) in order for the condition or exception to apply.
IsNDRSpecified | Gets or sets a value indicating whether the IsNDR is specified
IsPermissionControlled | Gets or sets a value indicating whether incoming messages must be permission controlled (RMS protected) in order for the condition or exception to apply.
IsPermissionControlledSpecified | Gets or sets a value indicating whether the IsPermissionControlled is specified
IsReadReceipt | Gets or sets a value indicating whether incoming messages must be read receipts in order for the condition or exception to apply
IsReadReceiptSpecified | Gets or sets a value indicating whether the IsReadReceipt is specified
IsSigned | Gets or sets a value indicating whether incoming messages must be S/MIME signed in order for the condition or exception to apply.
IsSignedSpecified | Gets or sets a value indicating whether the IsSignedSpecified is specified
IsVoicemail | Gets or sets a value indicating whether incoming messages must be voice mails in order for the condition or exception to apply.
IsVoicemailSpecified | Gets or sets a value indicating whether the IsVoicemail is specified
ItemClasses | Gets or sets the item classes that must be stamped on incoming messages in order for the condition or exception to apply.
MessageClassifications | Gets or sets the message classifications that must be stamped on incoming messages in order for the condition or exception to apply.
NotSentToMe | Gets or sets a value indicating whether the owner of the mailbox cannot be in the ToRecipients property of the incoming messages in order for the condition or exception to apply.
NotSentToMeSpecified | Gets or sets a value indicating whether the NotSentToMe is specified
Sensitivity | Gets or sets the sensitivity that must be stamped on incoming messages in order for the condition or exception to apply.
SensitivitySpecified | Gets or sets a value indicating whether the Sensitivity is specified
SentCcMe | Gets or sets a value indicating whether the owner of the mailbox has to be in the CcRecipients property of incoming messages in order for the condition or exception to apply.
SentCcMeSpecified | Gets or sets a value indicating whether the SentCcMe is specified
SentOnlyToMe | Gets or sets a value indicating whether the owner of the mailbox has to be the only one in the ToRecipients property of incoming messages in order for the condition or exception to apply.
SentOnlyToMeSpecified | Gets or sets a value indicating whether the SentOnlyToMe is specified
SentToAddresses | Gets or sets the e-mail addresses that incoming messages have to have been sent to in order for the condition or exception to apply.
SentToMe | Gets or sets a value indicating whether the owner of the mailbox has to be in the ToRecipients property of incoming messages in order for the condition or exception to apply.
SentToMeSpecified | Gets or sets a value indicating whether the SentToMe is specified
SentToOrCcMe | Gets or sets a value indicating whether the owner of the mailbox has to be in either a ToRecipients or CcRecipients property of incoming messages in order for the condition or exception to apply
SentToOrCcMeSpecified | Gets or sets a value indicating whether the SentToOrCcMe is specified
WithinDateRange | Gets or sets the date range within which incoming messages have to have been received in order for the condition or exception to apply.
WithinSizeRange | Gets or sets the minimum and maximum sizes that incoming messages have to have in order for the condition or exception to apply.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


RulePredicatesType Constructor

Initializes a new instance of the RulePredicatesType class.

public RulePredicatesType();

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


RulePredicatesType Properties

The properties of the RulePredicatesType class are listed below. For a complete list of RulePredicatesType class members, see the RulePredicatesType Members topic.

Public Instance Properties

Categories | Gets or sets the categories that an incoming message is labeled with in order for the condition or exception to apply.
ContainsBodyStrings | Gets or sets the strings that appear in the body of incoming messages in order for the condition or exception to apply.
ContainsHeaderStrings | Gets or sets the strings that appear in the headers of incoming messages in order for the condition or exception to apply.
ContainsRecipientStrings | Gets or sets the strings that appear in either the ToRecipients or CcRecipients properties of incoming messages in order for the condition or exception to apply.
ContainsSenderStrings | Gets or sets the strings that appears in the From property of incoming messages in order for the condition or exception to apply
ContainsSubjectOrBodyStrings | Gets or sets the strings that appear in either the body or the subject of incoming messages in order for the condition or exception to apply.
ContainsSubjectStrings | Gets or sets the strings that appear in the subject of incoming messages in order for the condition or exception to apply.
FlaggedForAction | Gets or sets the flag for action value that appears on incoming messages in order for the condition or exception to apply.
FlaggedForActionSpecified | Gets or sets a value indicating whether the FlaggedForAction is specified
FromAddresses | Gets or sets the e-mail addresses of the senders of incoming messages in order for the condition or exception to apply.
FromConnectedAccounts | Gets or sets the e-mail account names from which incoming messages have to have been aggregated in order for the condition or exception to apply.
HasAttachments | Gets or sets a value indicating whether incoming messages have to have attachments in order for the condition or exception to apply.
HasAttachmentsSpecified | Gets or sets a value indicating whether the HasAttachments is specified
Importance | Gets or sets the importance that is stamped on incoming messages in order for the condition or exception to apply.
ImportanceSpecified | Gets or sets a value indicating whether the Importance is specified
IsApprovalRequest | Gets or sets a value indicating whether incoming messages must be approval requests in order for the condition or exception to apply.
IsApprovalRequestSpecified | Gets or sets a value indicating whether the IsApprovalRequest is specified
IsAutomaticForward | Gets or sets a value indicating whether incoming messages must be automatic forwards in order for the condition or exception to apply.
IsAutomaticForwardSpecified | Gets or sets a value indicating whether the IsAutomaticForward is specified
IsAutomaticReply | Gets or sets a value indicating whether incoming messages must be automatic replies in order for the condition or exception to apply.
IsAutomaticReplySpecified | Gets or sets a value indicating whether the IsAutomaticReply is specified
IsEncrypted | Gets or sets a value indicating whether incoming messages must be S/MIME encrypted in order for the condition or exception to apply.
IsEncryptedSpecified | Gets or sets a value indicating whether the IsEncrypted is specified
IsMeetingRequest | Gets or sets a value indicating whether incoming messages must be meeting requests in order for the condition or exception to apply.
IsMeetingRequestSpecified | Gets or sets a value indicating whether the IsMeetingRequest is specified
IsMeetingResponse | Gets or sets a value indicating whether incoming messages must be meeting responses in order for the condition or exception to apply.
IsMeetingResponseSpecified | Gets or sets a value indicating whether the IsMeetingResponse is specified
IsNDR | Gets or sets a value indicating whether incoming messages must be non-delivery reports (NDRs) in order for the condition or exception to apply.
IsNDRSpecified | Gets or sets a value indicating whether the IsNDR is specified
IsPermissionControlled | Gets or sets a value indicating whether incoming messages must be permission controlled (RMS protected) in order for the condition or exception to apply.
IsPermissionControlledSpecified | Gets or sets a value indicating whether the IsPermissionControlled is specified
IsReadReceipt | Gets or sets a value indicating whether incoming messages must be read receipts in order for the condition or exception to apply
IsReadReceiptSpecified | Gets or sets a value indicating whether the IsReadReceipt is specified
IsSigned | Gets or sets a value indicating whether incoming messages must be S/MIME signed in order for the condition or exception to apply.
IsSignedSpecified | Gets or sets a value indicating whether the IsSignedSpecified is specified
IsVoicemail | Gets or sets a value indicating whether incoming messages must be voice mails in order for the condition or exception to apply.
IsVoicemailSpecified | Gets or sets a value indicating whether the IsVoicemail is specified
ItemClasses | Gets or sets the item classes that must be stamped on incoming messages in order for the condition or exception to apply.
MessageClassifications | Gets or sets the message classifications that must be stamped on incoming messages in order for the condition or exception to apply.
NotSentToMe | Gets or sets a value indicating whether the owner of the mailbox cannot be in the ToRecipients property of the incoming messages in order for the condition or exception to apply.
NotSentToMeSpecified | Gets or sets a value indicating whether the NotSentToMe is specified
Sensitivity | Gets or sets the sensitivity that must be stamped on incoming messages in order for the condition or exception to apply.
SensitivitySpecified | Gets or sets a value indicating whether the Sensitivity is specified
SentCcMe | Gets or sets a value indicating whether the owner of the mailbox has to be in the CcRecipients property of incoming messages in order for the condition or exception to apply.
SentCcMeSpecified | Gets or sets a value indicating whether the SentCcMe is specified
SentOnlyToMe | Gets or sets a value indicating whether the owner of the mailbox has to be the only one in the ToRecipients property of incoming messages in order for the condition or exception to apply.
SentOnlyToMeSpecified | Gets or sets a value indicating whether the SentOnlyToMe is specified
SentToAddresses | Gets or sets the e-mail addresses that incoming messages have to have been sent to in order for the condition or exception to apply.
SentToMe | Gets or sets a value indicating whether the owner of the mailbox has to be in the ToRecipients property of incoming messages in order for the condition or exception to apply.
SentToMeSpecified | Gets or sets a value indicating whether the SentToMe is specified
SentToOrCcMe | Gets or sets a value indicating whether the owner of the mailbox has to be in either a ToRecipients or CcRecipients property of incoming messages in order for the condition or exception to apply
SentToOrCcMeSpecified | Gets or sets a value indicating whether the SentToOrCcMe is specified
WithinDateRange | Gets or sets the date range within which incoming messages have to have been received in order for the condition or exception to apply.
WithinSizeRange | Gets or sets the minimum and maximum sizes that incoming messages have to have in order for the condition or exception to apply.

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


Categories Property

Aspose.Email

RulePredicatesType.Categories Property

Gets or sets the categories that an incoming message is labeled with in order for the condition or exception to apply.

public string[] Categories {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


ContainsBodyStrings Property

Aspose.Email

RulePredicatesType.ContainsBodyStrings Property

Gets or sets the strings that appear in the body of incoming messages in order for the condition or exception to apply.

public string[] ContainsBodyStrings {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


ContainsHeaderStrings Property

Aspose.Email

RulePredicatesType.ContainsHeaderStrings Property

Gets or sets the strings that appear in the headers of incoming messages in order for the condition or exception to apply.

public string[] ContainsHeaderStrings {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


ContainsRecipientStrings Property

Aspose.Email

RulePredicatesType.ContainsRecipientStrings Property

Gets or sets the strings that appear in either the ToRecipients or CcRecipients properties of incoming messages in order for the condition or exception to apply.

public string[] ContainsRecipientStrings {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


ContainsSenderStrings Property

Aspose.Email

RulePredicatesType.ContainsSenderStrings Property

Gets or sets the strings that appears in the From property of incoming messages in order for the condition or exception to apply

public string[] ContainsSenderStrings {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


ContainsSubjectOrBodyStrings Property

Aspose.Email

RulePredicatesType.ContainsSubjectOrBodyStrings Property

Gets or sets the strings that appear in either the body or the subject of incoming messages in order for the condition or exception to apply.

public string[] ContainsSubjectOrBodyStrings {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


ContainsSubjectStrings Property

Aspose.Email

RulePredicatesType.ContainsSubjectStrings Property

Gets or sets the strings that appear in the subject of incoming messages in order for the condition or exception to apply.

public string[] ContainsSubjectStrings {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


FlaggedForAction Property

Aspose.Email

RulePredicatesType.FlaggedForAction Property

Gets or sets the flag for action value that appears on incoming messages in order for the condition or exception to apply.

public FlaggedForActionType FlaggedForAction {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


FlaggedForActionSpecified Property

Aspose.Email

RulePredicatesType.FlaggedForActionSpecified Property

Gets or sets a value indicating whether the FlaggedForAction is specified

public bool FlaggedForActionSpecified {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


FromAddresses Property

Aspose.Email

RulePredicatesType.FromAddresses Property

Gets or sets the e-mail addresses of the senders of incoming messages in order for the condition or exception to apply.

public EmailAddressType[] FromAddresses {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


FromConnectedAccounts Property

Aspose.Email

RulePredicatesType.FromConnectedAccounts Property

Gets or sets the e-mail account names from which incoming messages have to have been aggregated in order for the condition or exception to apply.

public string[] FromConnectedAccounts {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


HasAttachments Property

Aspose.Email

RulePredicatesType.HasAttachments Property

Gets or sets a value indicating whether incoming messages have to have attachments in order for the condition or exception to apply.

public bool HasAttachments {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


HasAttachmentsSpecified Property

Aspose.Email

RulePredicatesType.HasAttachmentsSpecified Property

Gets or sets a value indicating whether the HasAttachments is specified

public bool HasAttachmentsSpecified {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


Importance Property

Aspose.Email

RulePredicatesType.Importance Property

Gets or sets the importance that is stamped on incoming messages in order for the condition or exception to apply.

public ImportanceChoicesType Importance {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


ImportanceSpecified Property

Aspose.Email

RulePredicatesType.ImportanceSpecified Property

Gets or sets a value indicating whether the Importance is specified

public bool ImportanceSpecified {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


IsApprovalRequest Property

Aspose.Email

RulePredicatesType.IsApprovalRequest Property

Gets or sets a value indicating whether incoming messages must be approval requests in order for the condition or exception to apply.

public bool IsApprovalRequest {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


IsApprovalRequestSpecified Property

Aspose.Email

RulePredicatesType.IsApprovalRequestSpecified Property

Gets or sets a value indicating whether the IsApprovalRequest is specified

public bool IsApprovalRequestSpecified {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


IsAutomaticForward Property

Aspose.Email

RulePredicatesType.IsAutomaticForward Property

Gets or sets a value indicating whether incoming messages must be automatic forwards in order for the condition or exception to apply.

public bool IsAutomaticForward {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


IsAutomaticForwardSpecified Property

Aspose.Email

RulePredicatesType.IsAutomaticForwardSpecified Property

Gets or sets a value indicating whether the IsAutomaticForward is specified

public bool IsAutomaticForwardSpecified {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


IsAutomaticReply Property

Aspose.Email

RulePredicatesType.IsAutomaticReply Property

Gets or sets a value indicating whether incoming messages must be automatic replies in order for the condition or exception to apply.

public bool IsAutomaticReply {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


IsAutomaticReplySpecified Property

Aspose.Email

RulePredicatesType.IsAutomaticReplySpecified Property

Gets or sets a value indicating whether the IsAutomaticReply is specified

public bool IsAutomaticReplySpecified {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


IsEncrypted Property

Aspose.Email

RulePredicatesType.IsEncrypted Property

Gets or sets a value indicating whether incoming messages must be S/MIME encrypted in order for the condition or exception to apply.

public bool IsEncrypted {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


IsEncryptedSpecified Property

Aspose.Email

RulePredicatesType.IsEncryptedSpecified Property

Gets or sets a value indicating whether the IsEncrypted is specified

public bool IsEncryptedSpecified {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


IsMeetingRequest Property

Aspose.Email

RulePredicatesType.IsMeetingRequest Property

Gets or sets a value indicating whether incoming messages must be meeting requests in order for the condition or exception to apply.

public bool IsMeetingRequest {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


IsMeetingRequestSpecified Property

Aspose.Email

RulePredicatesType.IsMeetingRequestSpecified Property

Gets or sets a value indicating whether the IsMeetingRequest is specified

public bool IsMeetingRequestSpecified {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


IsMeetingResponse Property

Aspose.Email

RulePredicatesType.IsMeetingResponse Property

Gets or sets a value indicating whether incoming messages must be meeting responses in order for the condition or exception to apply.

public bool IsMeetingResponse {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


IsMeetingResponseSpecified Property

Aspose.Email

RulePredicatesType.IsMeetingResponseSpecified Property

Gets or sets a value indicating whether the IsMeetingResponse is specified

public bool IsMeetingResponseSpecified {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


IsNDR Property

Aspose.Email

RulePredicatesType.IsNDR Property

Gets or sets a value indicating whether incoming messages must be non-delivery reports (NDRs) in order for the condition or exception to apply.

public bool IsNDR {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


IsNDRSpecified Property

Aspose.Email

RulePredicatesType.IsNDRSpecified Property

Gets or sets a value indicating whether the IsNDR is specified

public bool IsNDRSpecified {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


IsPermissionControlled Property

Aspose.Email

RulePredicatesType.IsPermissionControlled Property

Gets or sets a value indicating whether incoming messages must be permission controlled (RMS protected) in order for the condition or exception to apply.

public bool IsPermissionControlled {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


IsPermissionControlledSpecified Property

Aspose.Email

RulePredicatesType.IsPermissionControlledSpecified Property

Gets or sets a value indicating whether the IsPermissionControlled is specified

public bool IsPermissionControlledSpecified {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


IsReadReceipt Property

Aspose.Email

RulePredicatesType.IsReadReceipt Property

Gets or sets a value indicating whether incoming messages must be read receipts in order for the condition or exception to apply

public bool IsReadReceipt {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


IsReadReceiptSpecified Property

Aspose.Email

RulePredicatesType.IsReadReceiptSpecified Property

Gets or sets a value indicating whether the IsReadReceipt is specified

public bool IsReadReceiptSpecified {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


IsSigned Property

Aspose.Email

RulePredicatesType.IsSigned Property

Gets or sets a value indicating whether incoming messages must be S/MIME signed in order for the condition or exception to apply.

public bool IsSigned {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


IsSignedSpecified Property

Aspose.Email

RulePredicatesType.IsSignedSpecified Property

Gets or sets a value indicating whether the IsSignedSpecified is specified

public bool IsSignedSpecified {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


IsVoicemail Property

Aspose.Email

RulePredicatesType.IsVoicemail Property

Gets or sets a value indicating whether incoming messages must be voice mails in order for the condition or exception to apply.

public bool IsVoicemail {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


IsVoicemailSpecified Property

Aspose.Email

RulePredicatesType.IsVoicemailSpecified Property

Gets or sets a value indicating whether the IsVoicemail is specified

public bool IsVoicemailSpecified {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


ItemClasses Property

Aspose.Email

RulePredicatesType.ItemClasses Property

Gets or sets the item classes that must be stamped on incoming messages in order for the condition or exception to apply.

public string[] ItemClasses {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


MessageClassifications Property

Aspose.Email

RulePredicatesType.MessageClassifications Property

Gets or sets the message classifications that must be stamped on incoming messages in order for the condition or exception to apply.

public string[] MessageClassifications {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


NotSentToMe Property

Aspose.Email

RulePredicatesType.NotSentToMe Property

Gets or sets a value indicating whether the owner of the mailbox cannot be in the ToRecipients property of the incoming messages in order for the condition or exception to apply.

public bool NotSentToMe {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


NotSentToMeSpecified Property

Aspose.Email

RulePredicatesType.NotSentToMeSpecified Property

Gets or sets a value indicating whether the NotSentToMe is specified

public bool NotSentToMeSpecified {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


Sensitivity Property

Aspose.Email

RulePredicatesType.Sensitivity Property

Gets or sets the sensitivity that must be stamped on incoming messages in order for the condition or exception to apply.

public SensitivityChoicesType Sensitivity {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


SensitivitySpecified Property

Aspose.Email

RulePredicatesType.SensitivitySpecified Property

Gets or sets a value indicating whether the Sensitivity is specified

public bool SensitivitySpecified {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


SentCcMe Property

Aspose.Email

RulePredicatesType.SentCcMe Property

Gets or sets a value indicating whether the owner of the mailbox has to be in the CcRecipients property of incoming messages in order for the condition or exception to apply.

public bool SentCcMe {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


SentCcMeSpecified Property

Aspose.Email

RulePredicatesType.SentCcMeSpecified Property

Gets or sets a value indicating whether the SentCcMe is specified

public bool SentCcMeSpecified {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


SentOnlyToMe Property

Aspose.Email

RulePredicatesType.SentOnlyToMe Property

Gets or sets a value indicating whether the owner of the mailbox has to be the only one in the ToRecipients property of incoming messages in order for the condition or exception to apply.

public bool SentOnlyToMe {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


SentOnlyToMeSpecified Property

Aspose.Email

RulePredicatesType.SentOnlyToMeSpecified Property

Gets or sets a value indicating whether the SentOnlyToMe is specified

public bool SentOnlyToMeSpecified {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


SentToAddresses Property

Aspose.Email

RulePredicatesType.SentToAddresses Property

Gets or sets the e-mail addresses that incoming messages have to have been sent to in order for the condition or exception to apply.

public EmailAddressType[] SentToAddresses {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


SentToMe Property

Aspose.Email

RulePredicatesType.SentToMe Property

Gets or sets a value indicating whether the owner of the mailbox has to be in the ToRecipients property of incoming messages in order for the condition or exception to apply.

public bool SentToMe {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


SentToMeSpecified Property

Aspose.Email

RulePredicatesType.SentToMeSpecified Property

Gets or sets a value indicating whether the SentToMe is specified

public bool SentToMeSpecified {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


SentToOrCcMe Property

Aspose.Email

RulePredicatesType.SentToOrCcMe Property

Gets or sets a value indicating whether the owner of the mailbox has to be in either a ToRecipients or CcRecipients property of incoming messages in order for the condition or exception to apply

public bool SentToOrCcMe {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


SentToOrCcMeSpecified Property

Aspose.Email

RulePredicatesType.SentToOrCcMeSpecified Property

Gets or sets a value indicating whether the SentToOrCcMe is specified

public bool SentToOrCcMeSpecified {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


WithinDateRange Property

Aspose.Email

RulePredicatesType.WithinDateRange Property

Gets or sets the date range within which incoming messages have to have been received in order for the condition or exception to apply.

public RulePredicateDateRangeType WithinDateRange {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


WithinSizeRange Property

Aspose.Email

RulePredicatesType.WithinSizeRange Property

Gets or sets the minimum and maximum sizes that incoming messages have to have in order for the condition or exception to apply.

public RulePredicateSizeRangeType WithinSizeRange {get; set;}

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema Namespace


RuleType Class

Represents RuleType

For a list of all members of this type, see RuleType Members.

System.Object
Aspose.Email.Exchange.Schema.RuleType

public class RuleType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RuleType Members | Aspose.Email.Exchange.Schema Namespace


RuleType Members

RuleType overview

Public Instance Constructors

RuleType Constructor Initializes a new instance of the RuleType class.

Public Instance Properties

Actions | Gets or sets the actions to be taken on a message when the conditions are fulfilled.
Conditions | Gets or sets the conditions that, when fulfilled, will trigger the rule actions for that rule.
DisplayName | Gets or sets the display name of a rule.
Exceptions | Gets or sets the exceptions that represent all the available rule exception conditions for the inbox rule.
IsEnabled | Gets or sets a value indicating whether the rule is enabled.
IsInError | Gets or sets a value indicating whether the rule is in an error condition.
IsInErrorSpecified | Gets or sets a value indicating whether the IsInError is specified
IsNotSupported | Gets or sets a value indicating whether the rule cannot be modified with the managed code APIs.
IsNotSupportedSpecified | Gets or sets a value indicating whether the isNotSupportedField is specified
Priority | Gets or sets a value that indicates the order in which a rule is to be run.
RuleId | Gets or sets the rule identifier.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RuleType Class | Aspose.Email.Exchange.Schema Namespace


RuleType Constructor

Initializes a new instance of the RuleType class.

public RuleType();

See Also

RuleType Class | Aspose.Email.Exchange.Schema Namespace


RuleType Properties

The properties of the RuleType class are listed below. For a complete list of RuleType class members, see the RuleType Members topic.

Public Instance Properties

Actions | Gets or sets the actions to be taken on a message when the conditions are fulfilled.
Conditions | Gets or sets the conditions that, when fulfilled, will trigger the rule actions for that rule.
DisplayName | Gets or sets the display name of a rule.
Exceptions | Gets or sets the exceptions that represent all the available rule exception conditions for the inbox rule.
IsEnabled | Gets or sets a value indicating whether the rule is enabled.
IsInError | Gets or sets a value indicating whether the rule is in an error condition.
IsInErrorSpecified | Gets or sets a value indicating whether the IsInError is specified
IsNotSupported | Gets or sets a value indicating whether the rule cannot be modified with the managed code APIs.
IsNotSupportedSpecified | Gets or sets a value indicating whether the isNotSupportedField is specified
Priority | Gets or sets a value that indicates the order in which a rule is to be run.
RuleId | Gets or sets the rule identifier.

See Also

RuleType Class | Aspose.Email.Exchange.Schema Namespace


Actions Property

Aspose.Email

RuleType.Actions Property

Gets or sets the actions to be taken on a message when the conditions are fulfilled.

public RuleActionsType Actions {get; set;}

See Also

RuleType Class | Aspose.Email.Exchange.Schema Namespace


Conditions Property

Aspose.Email

RuleType.Conditions Property

Gets or sets the conditions that, when fulfilled, will trigger the rule actions for that rule.

public RulePredicatesType Conditions {get; set;}

See Also

RuleType Class | Aspose.Email.Exchange.Schema Namespace


DisplayName Property

Aspose.Email

RuleType.DisplayName Property

Gets or sets the display name of a rule.

public string DisplayName {get; set;}

See Also

RuleType Class | Aspose.Email.Exchange.Schema Namespace


Exceptions Property

Aspose.Email

RuleType.Exceptions Property

Gets or sets the exceptions that represent all the available rule exception conditions for the inbox rule.

public RulePredicatesType Exceptions {get; set;}

See Also

RuleType Class | Aspose.Email.Exchange.Schema Namespace


IsEnabled Property

Aspose.Email

RuleType.IsEnabled Property

Gets or sets a value indicating whether the rule is enabled.

public bool IsEnabled {get; set;}

See Also

RuleType Class | Aspose.Email.Exchange.Schema Namespace


IsInError Property

Aspose.Email

RuleType.IsInError Property

Gets or sets a value indicating whether the rule is in an error condition.

public bool IsInError {get; set;}

See Also

RuleType Class | Aspose.Email.Exchange.Schema Namespace


IsInErrorSpecified Property

Aspose.Email

RuleType.IsInErrorSpecified Property

Gets or sets a value indicating whether the IsInError is specified

public bool IsInErrorSpecified {get; set;}

See Also

RuleType Class | Aspose.Email.Exchange.Schema Namespace


IsNotSupported Property

Aspose.Email

RuleType.IsNotSupported Property

Gets or sets a value indicating whether the rule cannot be modified with the managed code APIs.

public bool IsNotSupported {get; set;}

See Also

RuleType Class | Aspose.Email.Exchange.Schema Namespace


IsNotSupportedSpecified Property

Aspose.Email

RuleType.IsNotSupportedSpecified Property

Gets or sets a value indicating whether the isNotSupportedField is specified

public bool IsNotSupportedSpecified {get; set;}

See Also

RuleType Class | Aspose.Email.Exchange.Schema Namespace


Priority Property

Aspose.Email

RuleType.Priority Property

Gets or sets a value that indicates the order in which a rule is to be run.

public int Priority {get; set;}

See Also

RuleType Class | Aspose.Email.Exchange.Schema Namespace


RuleId Property

Aspose.Email

RuleType.RuleId Property

Gets or sets the rule identifier.

public string RuleId {get; set;}

See Also

RuleType Class | Aspose.Email.Exchange.Schema Namespace


RuleValidationErrorCodeType Enumeration

Enumerates rule validation error codes

public enum RuleValidationErrorCodeType

Members

Member Name | Description | Value
ADOperationFailure | The Active Directory operation failed. | 0
ConnectedAccountNotFound | The specified e-mail account was not found. | 1
CreateWithRuleId | An attempt was made to create a rule with an ID. The IDs of new rules are generated by the server and are not provided by the client. | 2
EmptyValueFound | The Value field is empty. An empty Value field is not allowed. | 3
DuplicatedPriority | There are multiple rules with the same priority. A priority can have only one rule. | 4
DuplicatedOperationOnTheSameRule | There are multiple operations against the same rule. Only one operation per rule is allowed. | 5
FolderDoesNotExist | The folder does not exist in the user's mailbox. | 6
InvalidAddress | The e-mail address is invalid. | 7
InvalidDateRange | The specified date range is invalid. | 8
InvalidFolderId | The specified folder ID is invalid. | 9
InvalidSizeRange | The size range is invalid. | 10
InvalidValue | The specified value is invalid. | 11
MessageClassificationNotFound | The message classification was not found. | 12
MissingAction | No action was specified. At least one rule action has to be specified for validation. | 13
MissingParameter | The required parameter is missing. | 14
MissingRangeValue | The range value is missing. | 15
NotSettable | The property cannot be modified. | 16
RecipientDoesNotExist | The recipient does not exist. | 17
RuleNotFound | The rule was not found. No rules were found that match the criteria. | 18
SizeLessThanZero | The specified size is less than zero. | 19
StringValueTooBig | The string value is too big. | 20
UnsupportedAddress | The address is not supported. For example, Inbox rules do not support MAPIPDL address types. | 21
UnexpectedError | An unexpected error occurred. | 22
UnsupportedRule | The rule is unsupported. | 23

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


RuleValidationErrorType Class

Represents a single validation error on a particular rule property value, predicate property value, or action property value

For a list of all members of this type, see RuleValidationErrorType Members.

System.Object
Aspose.Email.Exchange.Schema.RuleValidationErrorType

public class RuleValidationErrorType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RuleValidationErrorType Members | Aspose.Email.Exchange.Schema Namespace


RuleValidationErrorType Members

RuleValidationErrorType overview

Public Instance Constructors

RuleValidationErrorType Constructor Initializes a new instance of the RuleValidationErrorType class.

Public Instance Properties

ErrorCode | Gets or sets the error code that was triggered on the field.
ErrorMessage | Gets or sets the reason for the validation error.
FieldURI | Gets or sets the URI to the rule field that caused the validation error.
FieldValue | Gets or sets the value of the field that caused the validation error.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RuleValidationErrorType Class | Aspose.Email.Exchange.Schema Namespace


RuleValidationErrorType Constructor

Initializes a new instance of the RuleValidationErrorType class.

public RuleValidationErrorType();

See Also

RuleValidationErrorType Class | Aspose.Email.Exchange.Schema Namespace


RuleValidationErrorType Properties

The properties of the RuleValidationErrorType class are listed below. For a complete list of RuleValidationErrorType class members, see the RuleValidationErrorType Members topic.

Public Instance Properties

ErrorCode | Gets or sets the error code that was triggered on the field.
ErrorMessage | Gets or sets the reason for the validation error.
FieldURI | Gets or sets the URI to the rule field that caused the validation error.
FieldValue | Gets or sets the value of the field that caused the validation error.

See Also

RuleValidationErrorType Class | Aspose.Email.Exchange.Schema Namespace


ErrorCode Property

Aspose.Email

RuleValidationErrorType.ErrorCode Property

Gets or sets the error code that was triggered on the field.

public RuleValidationErrorCodeType ErrorCode {get; set;}

See Also

RuleValidationErrorType Class | Aspose.Email.Exchange.Schema Namespace


ErrorMessage Property

Aspose.Email

RuleValidationErrorType.ErrorMessage Property

Gets or sets the reason for the validation error.

public string ErrorMessage {get; set;}

See Also

RuleValidationErrorType Class | Aspose.Email.Exchange.Schema Namespace


FieldURI Property

Aspose.Email

RuleValidationErrorType.FieldURI Property

Gets or sets the URI to the rule field that caused the validation error.

public RuleFieldURIType FieldURI {get; set;}

See Also

RuleValidationErrorType Class | Aspose.Email.Exchange.Schema Namespace


FieldValue Property

Aspose.Email

RuleValidationErrorType.FieldValue Property

Gets or sets the value of the field that caused the validation error.

public string FieldValue {get; set;}

See Also

RuleValidationErrorType Class | Aspose.Email.Exchange.Schema Namespace


SearchExpressionType Class

For a list of all members of this type, see SearchExpressionType Members.

System.Object
Aspose.Email.Exchange.Schema.SearchExpressionType
Derived types

public abstract class SearchExpressionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SearchExpressionType Members | Aspose.Email.Exchange.Schema Namespace


SearchExpressionType Members

SearchExpressionType overview

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

SearchExpressionType Constructor Initializes a new instance of the SearchExpressionType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SearchExpressionType Class | Aspose.Email.Exchange.Schema Namespace


SearchExpressionType Constructor

Initializes a new instance of the SearchExpressionType class.

protected SearchExpressionType();

See Also

SearchExpressionType Class | Aspose.Email.Exchange.Schema Namespace


SearchFolderTraversalType Enumeration

public enum SearchFolderTraversalType

Remarks

Members

Member Name | Description | Value
Shallow |  | 0
Deep |  | 1

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


SearchFolderType Class

For a list of all members of this type, see SearchFolderType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseFolderType
Aspose.Email.Exchange.Schema.FolderType
Aspose.Email.Exchange.Schema.SearchFolderType

public class SearchFolderType : FolderType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SearchFolderType Members | Aspose.Email.Exchange.Schema Namespace


SearchFolderType Members

SearchFolderType overview

Public Instance Constructors

SearchFolderType Constructor Initializes a new instance of the SearchFolderType class.

Public Instance Properties

ChildFolderCount (inherited from BaseFolderType)
ChildFolderCountSpecified (inherited from BaseFolderType)
DisplayName (inherited from BaseFolderType)
EffectiveRights (inherited from BaseFolderType)
ExtendedProperty (inherited from BaseFolderType)
FolderClass (inherited from BaseFolderType)
FolderId (inherited from BaseFolderType)
ManagedFolderInformation (inherited from BaseFolderType)
ParentFolderId (inherited from BaseFolderType)
PermissionSet (inherited from FolderType)
SearchParameters
TotalCount (inherited from BaseFolderType)
TotalCountSpecified (inherited from BaseFolderType)
UnreadCount (inherited from FolderType)
UnreadCountSpecified (inherited from FolderType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SearchFolderType Class | Aspose.Email.Exchange.Schema Namespace


SearchFolderType Constructor

Initializes a new instance of the SearchFolderType class.

public SearchFolderType();

See Also

SearchFolderType Class | Aspose.Email.Exchange.Schema Namespace


SearchFolderType Properties

The properties of the SearchFolderType class are listed below. For a complete list of SearchFolderType class members, see the SearchFolderType Members topic.

Public Instance Properties

ChildFolderCount (inherited from BaseFolderType)
ChildFolderCountSpecified (inherited from BaseFolderType)
DisplayName (inherited from BaseFolderType)
EffectiveRights (inherited from BaseFolderType)
ExtendedProperty (inherited from BaseFolderType)
FolderClass (inherited from BaseFolderType)
FolderId (inherited from BaseFolderType)
ManagedFolderInformation (inherited from BaseFolderType)
ParentFolderId (inherited from BaseFolderType)
PermissionSet (inherited from FolderType)
SearchParameters
TotalCount (inherited from BaseFolderType)
TotalCountSpecified (inherited from BaseFolderType)
UnreadCount (inherited from FolderType)
UnreadCountSpecified (inherited from FolderType)

See Also

SearchFolderType Class | Aspose.Email.Exchange.Schema Namespace


SearchParameters Property

Aspose.Email

SearchFolderType.SearchParameters Property

public SearchParametersType SearchParameters {get; set;}

Remarks

See Also

SearchFolderType Class | Aspose.Email.Exchange.Schema Namespace


SearchItemKindType Enumeration

public enum SearchItemKindType

Remarks

Members

Member Name | Description | Value
Email |  | 0
Meetings |  | 1
Tasks |  | 2
Notes |  | 3
Docs |  | 4
Journals |  | 5
Contacts |  | 6
Im |  | 7
Voicemail |  | 8
Faxes |  | 9
Posts |  | 10
Rssfeeds |  | 11

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


SearchParametersType Class

For a list of all members of this type, see SearchParametersType Members.

System.Object
Aspose.Email.Exchange.Schema.SearchParametersType

public class SearchParametersType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SearchParametersType Members | Aspose.Email.Exchange.Schema Namespace


SearchParametersType Members

SearchParametersType overview

Public Instance Constructors

SearchParametersType Constructor Initializes a new instance of the SearchParametersType class.

Public Instance Properties

BaseFolderIds
Restriction
Traversal
TraversalSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SearchParametersType Class | Aspose.Email.Exchange.Schema Namespace


SearchParametersType Constructor

Initializes a new instance of the SearchParametersType class.

public SearchParametersType();

See Also

SearchParametersType Class | Aspose.Email.Exchange.Schema Namespace


SearchParametersType Properties

The properties of the SearchParametersType class are listed below. For a complete list of SearchParametersType class members, see the SearchParametersType Members topic.

Public Instance Properties

BaseFolderIds
Restriction
Traversal
TraversalSpecified

See Also

SearchParametersType Class | Aspose.Email.Exchange.Schema Namespace


BaseFolderIds Property

Aspose.Email

SearchParametersType.BaseFolderIds Property

public BaseFolderIdType[] BaseFolderIds {get; set;}

Remarks

See Also

SearchParametersType Class | Aspose.Email.Exchange.Schema Namespace


Restriction Property

Aspose.Email

SearchParametersType.Restriction Property

public RestrictionType Restriction {get; set;}

Remarks

See Also

SearchParametersType Class | Aspose.Email.Exchange.Schema Namespace


Traversal Property

Aspose.Email

SearchParametersType.Traversal Property

public SearchFolderTraversalType Traversal {get; set;}

Remarks

See Also

SearchParametersType Class | Aspose.Email.Exchange.Schema Namespace


TraversalSpecified Property

Aspose.Email

SearchParametersType.TraversalSpecified Property

public bool TraversalSpecified {get; set;}

Remarks

See Also

SearchParametersType Class | Aspose.Email.Exchange.Schema Namespace


SendItemCompletedEventArgs Class

For a list of all members of this type, see SendItemCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.SendItemCompletedEventArgs

public class SendItemCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SendItemCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


SendItemCompletedEventArgs Members

SendItemCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

SendItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


SendItemCompletedEventArgs Properties

The properties of the SendItemCompletedEventArgs class are listed below. For a complete list of SendItemCompletedEventArgs class members, see the SendItemCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

SendItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

SendItemCompletedEventArgs.Result Property

public SendItemResponseType Result {get;}

Remarks

See Also

SendItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


SendItemCompletedEventHandler Delegate

public delegate void SendItemCompletedEventHandler(
object sender,
SendItemCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


SendItemResponseType Class

For a list of all members of this type, see SendItemResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseResponseMessageType
Aspose.Email.Exchange.Schema.SendItemResponseType

public class SendItemResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SendItemResponseType Members | Aspose.Email.Exchange.Schema Namespace


SendItemResponseType Members

SendItemResponseType overview

Public Instance Constructors

SendItemResponseType Constructor Initializes a new instance of the SendItemResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SendItemResponseType Class | Aspose.Email.Exchange.Schema Namespace


SendItemResponseType Constructor

Initializes a new instance of the SendItemResponseType class.

public SendItemResponseType();

See Also

SendItemResponseType Class | Aspose.Email.Exchange.Schema Namespace


SendItemType Class

For a list of all members of this type, see SendItemType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.SendItemType

public class SendItemType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SendItemType Members | Aspose.Email.Exchange.Schema Namespace


SendItemType Members

SendItemType overview

Public Instance Constructors

SendItemType Constructor Initializes a new instance of the SendItemType class.

Public Instance Properties

ItemIds
SavedItemFolderId
SaveItemToFolder

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SendItemType Class | Aspose.Email.Exchange.Schema Namespace


SendItemType Constructor

Initializes a new instance of the SendItemType class.

public SendItemType();

See Also

SendItemType Class | Aspose.Email.Exchange.Schema Namespace


SendItemType Properties

The properties of the SendItemType class are listed below. For a complete list of SendItemType class members, see the SendItemType Members topic.

Public Instance Properties

ItemIds
SavedItemFolderId
SaveItemToFolder

See Also

SendItemType Class | Aspose.Email.Exchange.Schema Namespace


ItemIds Property

Aspose.Email

SendItemType.ItemIds Property

public BaseItemIdType[] ItemIds {get; set;}

Remarks

See Also

SendItemType Class | Aspose.Email.Exchange.Schema Namespace


SavedItemFolderId Property

Aspose.Email

SendItemType.SavedItemFolderId Property

public TargetFolderIdType SavedItemFolderId {get; set;}

Remarks

See Also

SendItemType Class | Aspose.Email.Exchange.Schema Namespace


SaveItemToFolder Property

Aspose.Email

SendItemType.SaveItemToFolder Property

public bool SaveItemToFolder {get; set;}

Remarks

See Also

SendItemType Class | Aspose.Email.Exchange.Schema Namespace


SendNotificationResponseMessageType Class

For a list of all members of this type, see SendNotificationResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ResponseMessageType
Aspose.Email.Exchange.Schema.SendNotificationResponseMessageType

public class SendNotificationResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SendNotificationResponseMessageType Members | Aspose.Email.Exchange.Schema Namespace


SendNotificationResponseMessageType Members

SendNotificationResponseMessageType overview

Public Instance Constructors

SendNotificationResponseMessageType Constructor Initializes a new instance of the SendNotificationResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
Notification
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SendNotificationResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


SendNotificationResponseMessageType Constructor

Initializes a new instance of the SendNotificationResponseMessageType class.

public SendNotificationResponseMessageType();

See Also

SendNotificationResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


SendNotificationResponseMessageType Properties

The properties of the SendNotificationResponseMessageType class are listed below. For a complete list of SendNotificationResponseMessageType class members, see the SendNotificationResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
Notification
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

SendNotificationResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


Notification Property

Aspose.Email

SendNotificationResponseMessageType.Notification Property

public NotificationType Notification {get; set;}

Remarks

See Also

SendNotificationResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


SendNotificationResponseType Class

For a list of all members of this type, see SendNotificationResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseResponseMessageType
Aspose.Email.Exchange.Schema.SendNotificationResponseType

public class SendNotificationResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SendNotificationResponseType Members | Aspose.Email.Exchange.Schema Namespace


SendNotificationResponseType Members

SendNotificationResponseType overview

Public Instance Constructors

SendNotificationResponseType Constructor Initializes a new instance of the SendNotificationResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SendNotificationResponseType Class | Aspose.Email.Exchange.Schema Namespace


SendNotificationResponseType Constructor

Initializes a new instance of the SendNotificationResponseType class.

public SendNotificationResponseType();

See Also

SendNotificationResponseType Class | Aspose.Email.Exchange.Schema Namespace


SensitivityChoicesType Enumeration

public enum SensitivityChoicesType

Remarks

Members

Member Name | Description | Value
Normal |  | 0
Personal |  | 1
Private |  | 2
Confidential |  | 3

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


SerializableTimeZone Class

For a list of all members of this type, see SerializableTimeZone Members.

System.Object
Aspose.Email.Exchange.Schema.SerializableTimeZone

public class SerializableTimeZone

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SerializableTimeZone Members | Aspose.Email.Exchange.Schema Namespace


SerializableTimeZone Members

SerializableTimeZone overview

Public Instance Constructors

SerializableTimeZone Constructor Initializes a new instance of the SerializableTimeZone class.

Public Instance Properties

Bias
DaylightTime
StandardTime

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SerializableTimeZone Class | Aspose.Email.Exchange.Schema Namespace


SerializableTimeZone Constructor

Initializes a new instance of the SerializableTimeZone class.

public SerializableTimeZone();

See Also

SerializableTimeZone Class | Aspose.Email.Exchange.Schema Namespace


SerializableTimeZone Properties

The properties of the SerializableTimeZone class are listed below. For a complete list of SerializableTimeZone class members, see the SerializableTimeZone Members topic.

Public Instance Properties

Bias
DaylightTime
StandardTime

See Also

SerializableTimeZone Class | Aspose.Email.Exchange.Schema Namespace


Bias Property

Aspose.Email

SerializableTimeZone.Bias Property

public int Bias {get; set;}

Remarks

See Also

SerializableTimeZone Class | Aspose.Email.Exchange.Schema Namespace


DaylightTime Property

Aspose.Email

SerializableTimeZone.DaylightTime Property

public SerializableTimeZoneTime DaylightTime {get; set;}

Remarks

See Also

SerializableTimeZone Class | Aspose.Email.Exchange.Schema Namespace


StandardTime Property

Aspose.Email

SerializableTimeZone.StandardTime Property

public SerializableTimeZoneTime StandardTime {get; set;}

Remarks

See Also

SerializableTimeZone Class | Aspose.Email.Exchange.Schema Namespace


SerializableTimeZoneTime Class

Specifies a time and a time zone for a meeting suggestion.

For a list of all members of this type, see SerializableTimeZoneTime Members.

System.Object
Aspose.Email.Exchange.Schema.SerializableTimeZoneTime

public class SerializableTimeZoneTime

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SerializableTimeZoneTime Members | Aspose.Email.Exchange.Schema Namespace


SerializableTimeZoneTime Members

SerializableTimeZoneTime overview

Public Instance Constructors

SerializableTimeZoneTime Constructor Initializes a new instance of the SerializableTimeZoneTime class.

Public Instance Properties

Bias
DayOfWeek
DayOrder
Month
Time
Year

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SerializableTimeZoneTime Class | Aspose.Email.Exchange.Schema Namespace


SerializableTimeZoneTime Constructor

Initializes a new instance of the SerializableTimeZoneTime class.

public SerializableTimeZoneTime();

See Also

SerializableTimeZoneTime Class | Aspose.Email.Exchange.Schema Namespace


SerializableTimeZoneTime Properties

The properties of the SerializableTimeZoneTime class are listed below. For a complete list of SerializableTimeZoneTime class members, see the SerializableTimeZoneTime Members topic.

Public Instance Properties

Bias
DayOfWeek
DayOrder
Month
Time
Year

See Also

SerializableTimeZoneTime Class | Aspose.Email.Exchange.Schema Namespace


Bias Property

Aspose.Email

SerializableTimeZoneTime.Bias Property

public int Bias {get; set;}

Remarks

See Also

SerializableTimeZoneTime Class | Aspose.Email.Exchange.Schema Namespace


DayOfWeek Property

Aspose.Email

SerializableTimeZoneTime.DayOfWeek Property

public string DayOfWeek {get; set;}

Remarks

See Also

SerializableTimeZoneTime Class | Aspose.Email.Exchange.Schema Namespace


DayOrder Property

Aspose.Email

SerializableTimeZoneTime.DayOrder Property

public short DayOrder {get; set;}

Remarks

See Also

SerializableTimeZoneTime Class | Aspose.Email.Exchange.Schema Namespace


Month Property

Aspose.Email

SerializableTimeZoneTime.Month Property

public short Month {get; set;}

Remarks

See Also

SerializableTimeZoneTime Class | Aspose.Email.Exchange.Schema Namespace


Time Property

Aspose.Email

SerializableTimeZoneTime.Time Property

public string Time {get; set;}

Remarks

See Also

SerializableTimeZoneTime Class | Aspose.Email.Exchange.Schema Namespace


Year Property

Aspose.Email

SerializableTimeZoneTime.Year Property

public string Year {get; set;}

Remarks

See Also

SerializableTimeZoneTime Class | Aspose.Email.Exchange.Schema Namespace


ServerVersionInfo Class

The ServerVersionInfo class contains the Microsoft Exchange Server version number.

For a list of all members of this type, see ServerVersionInfo Members.

System.Object
System.Web.Services.Protocols.SoapHeader
Aspose.Email.Exchange.Schema.ServerVersionInfo

public class ServerVersionInfo : SoapHeader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ServerVersionInfo Members | Aspose.Email.Exchange.Schema Namespace


ServerVersionInfo Members

ServerVersionInfo overview

Public Instance Constructors

ServerVersionInfo Constructor Initializes a new instance of the ServerVersionInfo class.

Public Instance Properties

Actor (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.
DidUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether an XML Web service method properly processed a SOAP header.
EncodedMustUnderstand (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.1.
EncodedMustUnderstand12 (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.2.
EncodedRelay (inherited from SoapHeader) | Gets or sets the relay attribute of the SOAP 1.2 header.
MajorBuildNumber |
MajorBuildNumberSpecified |
MajorVersion |
MajorVersionSpecified |
MinorBuildNumber |
MinorBuildNumberSpecified |
MinorVersion |
MinorVersionSpecified |
MustUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether the SoapHeader must be understood.
Relay (inherited from SoapHeader) | Gets or sets a value that indicates whether the SOAP header is to be relayed to the next SOAP node if the current node does not understand the header.
Role (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.
Version |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | ToString converts an object to its string representation so that it is suitable for display.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ServerVersionInfo Class | Aspose.Email.Exchange.Schema Namespace


ServerVersionInfo Constructor

Initializes a new instance of the ServerVersionInfo class.

public ServerVersionInfo();

See Also

ServerVersionInfo Class | Aspose.Email.Exchange.Schema Namespace


ServerVersionInfo Properties

The properties of the ServerVersionInfo class are listed below. For a complete list of ServerVersionInfo class members, see the ServerVersionInfo Members topic.

Public Instance Properties

Actor (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.
DidUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether an XML Web service method properly processed a SOAP header.
EncodedMustUnderstand (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.1.
EncodedMustUnderstand12 (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.2.
EncodedRelay (inherited from SoapHeader) | Gets or sets the relay attribute of the SOAP 1.2 header.
MajorBuildNumber |
MajorBuildNumberSpecified |
MajorVersion |
MajorVersionSpecified |
MinorBuildNumber |
MinorBuildNumberSpecified |
MinorVersion |
MinorVersionSpecified |
MustUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether the SoapHeader must be understood.
Relay (inherited from SoapHeader) | Gets or sets a value that indicates whether the SOAP header is to be relayed to the next SOAP node if the current node does not understand the header.
Role (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.
Version |

See Also

ServerVersionInfo Class | Aspose.Email.Exchange.Schema Namespace


MajorBuildNumber Property

Aspose.Email

ServerVersionInfo.MajorBuildNumber Property

public int MajorBuildNumber {get; set;}

Remarks

See Also

ServerVersionInfo Class | Aspose.Email.Exchange.Schema Namespace


MajorBuildNumberSpecified Property

Aspose.Email

ServerVersionInfo.MajorBuildNumberSpecified Property

public bool MajorBuildNumberSpecified {get; set;}

Remarks

See Also

ServerVersionInfo Class | Aspose.Email.Exchange.Schema Namespace


MajorVersion Property

Aspose.Email

ServerVersionInfo.MajorVersion Property

public int MajorVersion {get; set;}

Remarks

See Also

ServerVersionInfo Class | Aspose.Email.Exchange.Schema Namespace


MajorVersionSpecified Property

Aspose.Email

ServerVersionInfo.MajorVersionSpecified Property

public bool MajorVersionSpecified {get; set;}

Remarks

See Also

ServerVersionInfo Class | Aspose.Email.Exchange.Schema Namespace


MinorBuildNumber Property

Aspose.Email

ServerVersionInfo.MinorBuildNumber Property

public int MinorBuildNumber {get; set;}

Remarks

See Also

ServerVersionInfo Class | Aspose.Email.Exchange.Schema Namespace


MinorBuildNumberSpecified Property

Aspose.Email

ServerVersionInfo.MinorBuildNumberSpecified Property

public bool MinorBuildNumberSpecified {get; set;}

Remarks

See Also

ServerVersionInfo Class | Aspose.Email.Exchange.Schema Namespace


MinorVersion Property

Aspose.Email

ServerVersionInfo.MinorVersion Property

public int MinorVersion {get; set;}

Remarks

See Also

ServerVersionInfo Class | Aspose.Email.Exchange.Schema Namespace


MinorVersionSpecified Property

Aspose.Email

ServerVersionInfo.MinorVersionSpecified Property

public bool MinorVersionSpecified {get; set;}

Remarks

See Also

ServerVersionInfo Class | Aspose.Email.Exchange.Schema Namespace


Version Property

Aspose.Email

ServerVersionInfo.Version Property

public string Version {get; set;}

Remarks

See Also

ServerVersionInfo Class | Aspose.Email.Exchange.Schema Namespace


ServerVersionInfo Methods

The methods of the ServerVersionInfo class are listed below. For a complete list of ServerVersionInfo class members, see the ServerVersionInfo Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | ToString converts an object to its string representation so that it is suitable for display.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ServerVersionInfo Class | Aspose.Email.Exchange.Schema Namespace


ServerVersionInfo.ToString Method

ToString converts an object to its string representation so that it is suitable for display.

public override string ToString();

Return Value

Returns a string that represents the current object.

See Also

ServerVersionInfo Class | Aspose.Email.Exchange.Schema Namespace


ServiceConfiguration Class

For a list of all members of this type, see ServiceConfiguration Members.

System.Object
Aspose.Email.Exchange.Schema.ServiceConfiguration
Aspose.Email.Exchange.Schema.MailTipsServiceConfiguration
Aspose.Email.Exchange.Schema.ProtectionRulesServiceConfiguration
Aspose.Email.Exchange.Schema.UnifiedMessageServiceConfiguration

public class ServiceConfiguration

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ServiceConfiguration Members | Aspose.Email.Exchange.Schema Namespace


ServiceConfiguration Members

ServiceConfiguration overview

Public Instance Constructors

ServiceConfiguration Constructor Initializes a new instance of the ServiceConfiguration class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ServiceConfiguration Class | Aspose.Email.Exchange.Schema Namespace


ServiceConfiguration Constructor

Initializes a new instance of the ServiceConfiguration class.

public ServiceConfiguration();

See Also

ServiceConfiguration Class | Aspose.Email.Exchange.Schema Namespace


ServiceConfigurationResponseMessageType Class

For a list of all members of this type, see ServiceConfigurationResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ResponseMessageType
Aspose.Email.Exchange.Schema.ServiceConfigurationResponseMessageType

public class ServiceConfigurationResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ServiceConfigurationResponseMessageType Members | Aspose.Email.Exchange.Schema Namespace


ServiceConfigurationResponseMessageType Members

ServiceConfigurationResponseMessageType overview

Public Instance Constructors

ServiceConfigurationResponseMessageType Constructor Initializes a new instance of the ServiceConfigurationResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MailTipsConfiguration
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ProtectionRulesConfiguration
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
UnifiedMessagingConfiguration

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ServiceConfigurationResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


ServiceConfigurationResponseMessageType Constructor

Initializes a new instance of the ServiceConfigurationResponseMessageType class.

public ServiceConfigurationResponseMessageType();

See Also

ServiceConfigurationResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


ServiceConfigurationResponseMessageType Properties

The properties of the ServiceConfigurationResponseMessageType class are listed below. For a complete list of ServiceConfigurationResponseMessageType class members, see the ServiceConfigurationResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MailTipsConfiguration
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ProtectionRulesConfiguration
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
UnifiedMessagingConfiguration

See Also

ServiceConfigurationResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


MailTipsConfiguration Property

Aspose.Email

ServiceConfigurationResponseMessageType.MailTipsConfiguration Property

public MailTipsServiceConfiguration MailTipsConfiguration {get; set;}

Remarks

See Also

ServiceConfigurationResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


ProtectionRulesConfiguration Property

Aspose.Email

ServiceConfigurationResponseMessageType.ProtectionRulesConfiguration Property

public ProtectionRulesServiceConfiguration ProtectionRulesConfiguration {get; set;}

Remarks

See Also

ServiceConfigurationResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


UnifiedMessagingConfiguration Property

Aspose.Email

ServiceConfigurationResponseMessageType.UnifiedMessagingConfiguration Property

public UnifiedMessageServiceConfiguration UnifiedMessagingConfiguration {get; set;}

Remarks

See Also

ServiceConfigurationResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


ServiceConfigurationType Enumeration

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum ServiceConfigurationType

Remarks

Members

Member Name | Description | Value
MailTips |  | 1
UnifiedMessagingConfiguration |  | 2
ProtectionRules |  | 4

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


SetFolderFieldType Class

For a list of all members of this type, see SetFolderFieldType Members.

System.Object
Aspose.Email.Exchange.Schema.ChangeDescriptionType
Aspose.Email.Exchange.Schema.FolderChangeDescriptionType
Aspose.Email.Exchange.Schema.SetFolderFieldType

public class SetFolderFieldType : FolderChangeDescriptionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SetFolderFieldType Members | Aspose.Email.Exchange.Schema Namespace


SetFolderFieldType Members

SetFolderFieldType overview

Public Instance Constructors

SetFolderFieldType Constructor Initializes a new instance of the SetFolderFieldType class.

Public Instance Properties

Item (inherited from ChangeDescriptionType)
Item1

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SetFolderFieldType Class | Aspose.Email.Exchange.Schema Namespace


SetFolderFieldType Constructor

Initializes a new instance of the SetFolderFieldType class.

public SetFolderFieldType();

See Also

SetFolderFieldType Class | Aspose.Email.Exchange.Schema Namespace


SetFolderFieldType Properties

The properties of the SetFolderFieldType class are listed below. For a complete list of SetFolderFieldType class members, see the SetFolderFieldType Members topic.

Public Instance Properties

Item (inherited from ChangeDescriptionType)
Item1

See Also

SetFolderFieldType Class | Aspose.Email.Exchange.Schema Namespace


Item1 Property

Aspose.Email

SetFolderFieldType.Item1 Property

public BaseFolderType Item1 {get; set;}

Remarks

See Also

SetFolderFieldType Class | Aspose.Email.Exchange.Schema Namespace


SetItemFieldType Class

For a list of all members of this type, see SetItemFieldType Members.

System.Object
Aspose.Email.Exchange.Schema.ChangeDescriptionType
Aspose.Email.Exchange.Schema.ItemChangeDescriptionType
Aspose.Email.Exchange.Schema.SetItemFieldType

public class SetItemFieldType : ItemChangeDescriptionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SetItemFieldType Members | Aspose.Email.Exchange.Schema Namespace


SetItemFieldType Members

SetItemFieldType overview

Public Instance Constructors

SetItemFieldType Constructor Initializes a new instance of the SetItemFieldType class.

Public Instance Properties

Item (inherited from ChangeDescriptionType)
Item1

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SetItemFieldType Class | Aspose.Email.Exchange.Schema Namespace


SetItemFieldType Constructor

Initializes a new instance of the SetItemFieldType class.

public SetItemFieldType();

See Also

SetItemFieldType Class | Aspose.Email.Exchange.Schema Namespace


SetItemFieldType Properties

The properties of the SetItemFieldType class are listed below. For a complete list of SetItemFieldType class members, see the SetItemFieldType Members topic.

Public Instance Properties

Item (inherited from ChangeDescriptionType)
Item1

See Also

SetItemFieldType Class | Aspose.Email.Exchange.Schema Namespace


Item1 Property

Aspose.Email

SetItemFieldType.Item1 Property

public ItemType Item1 {get; set;}

Remarks

See Also

SetItemFieldType Class | Aspose.Email.Exchange.Schema Namespace


SetRuleOperationType Class

Represents a update rule operation type

For a list of all members of this type, see SetRuleOperationType Members.

System.Object
Aspose.Email.Exchange.Schema.RuleOperationType
Aspose.Email.Exchange.Schema.SetRuleOperationType

public class SetRuleOperationType : RuleOperationType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SetRuleOperationType Members | Aspose.Email.Exchange.Schema Namespace


SetRuleOperationType Members

SetRuleOperationType overview

Public Instance Constructors

SetRuleOperationType Constructor Initializes a new instance of the SetRuleOperationType class.

Public Instance Properties

Rule Gets or sets the rule to update

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SetRuleOperationType Class | Aspose.Email.Exchange.Schema Namespace


SetRuleOperationType Constructor

Initializes a new instance of the SetRuleOperationType class.

public SetRuleOperationType();

See Also

SetRuleOperationType Class | Aspose.Email.Exchange.Schema Namespace


SetRuleOperationType Properties

The properties of the SetRuleOperationType class are listed below. For a complete list of SetRuleOperationType class members, see the SetRuleOperationType Members topic.

Public Instance Properties

Rule Gets or sets the rule to update

See Also

SetRuleOperationType Class | Aspose.Email.Exchange.Schema Namespace


Rule Property

Aspose.Email

SetRuleOperationType.Rule Property

Gets or sets the rule to update

public RuleType Rule {get; set;}

See Also

SetRuleOperationType Class | Aspose.Email.Exchange.Schema Namespace


SetUserOofSettingsCompletedEventArgs Class

For a list of all members of this type, see SetUserOofSettingsCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.SetUserOofSettingsCompletedEventArgs

public class SetUserOofSettingsCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SetUserOofSettingsCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


SetUserOofSettingsCompletedEventArgs Members

SetUserOofSettingsCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

SetUserOofSettingsCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


SetUserOofSettingsCompletedEventArgs Properties

The properties of the SetUserOofSettingsCompletedEventArgs class are listed below. For a complete list of SetUserOofSettingsCompletedEventArgs class members, see the SetUserOofSettingsCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

SetUserOofSettingsCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

SetUserOofSettingsCompletedEventArgs.Result Property

public SetUserOofSettingsResponse Result {get;}

Remarks

See Also

SetUserOofSettingsCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


SetUserOofSettingsCompletedEventHandler Delegate

public delegate void SetUserOofSettingsCompletedEventHandler(
object sender,
SetUserOofSettingsCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


SetUserOofSettingsRequest Class

For a list of all members of this type, see SetUserOofSettingsRequest Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.SetUserOofSettingsRequest

public class SetUserOofSettingsRequest : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SetUserOofSettingsRequest Members | Aspose.Email.Exchange.Schema Namespace


SetUserOofSettingsRequest Members

SetUserOofSettingsRequest overview

Public Instance Constructors

SetUserOofSettingsRequest Constructor Initializes a new instance of the SetUserOofSettingsRequest class.

Public Instance Properties

Mailbox
UserOofSettings

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SetUserOofSettingsRequest Class | Aspose.Email.Exchange.Schema Namespace


SetUserOofSettingsRequest Constructor

Initializes a new instance of the SetUserOofSettingsRequest class.

public SetUserOofSettingsRequest();

See Also

SetUserOofSettingsRequest Class | Aspose.Email.Exchange.Schema Namespace


SetUserOofSettingsRequest Properties

The properties of the SetUserOofSettingsRequest class are listed below. For a complete list of SetUserOofSettingsRequest class members, see the SetUserOofSettingsRequest Members topic.

Public Instance Properties

Mailbox
UserOofSettings

See Also

SetUserOofSettingsRequest Class | Aspose.Email.Exchange.Schema Namespace


Mailbox Property

Aspose.Email

SetUserOofSettingsRequest.Mailbox Property

public EmailAddress Mailbox {get; set;}

Remarks

See Also

SetUserOofSettingsRequest Class | Aspose.Email.Exchange.Schema Namespace


UserOofSettings Property

Aspose.Email

SetUserOofSettingsRequest.UserOofSettings Property

public UserOofSettings UserOofSettings {get; set;}

Remarks

See Also

SetUserOofSettingsRequest Class | Aspose.Email.Exchange.Schema Namespace


SetUserOofSettingsResponse Class

For a list of all members of this type, see SetUserOofSettingsResponse Members.

System.Object
Aspose.Email.Exchange.Schema.SetUserOofSettingsResponse

public class SetUserOofSettingsResponse

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SetUserOofSettingsResponse Members | Aspose.Email.Exchange.Schema Namespace


SetUserOofSettingsResponse Members

SetUserOofSettingsResponse overview

Public Instance Constructors

SetUserOofSettingsResponse Constructor Initializes a new instance of the SetUserOofSettingsResponse class.

Public Instance Properties

ResponseMessage

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SetUserOofSettingsResponse Class | Aspose.Email.Exchange.Schema Namespace


SetUserOofSettingsResponse Constructor

Initializes a new instance of the SetUserOofSettingsResponse class.

public SetUserOofSettingsResponse();

See Also

SetUserOofSettingsResponse Class | Aspose.Email.Exchange.Schema Namespace


SetUserOofSettingsResponse Properties

The properties of the SetUserOofSettingsResponse class are listed below. For a complete list of SetUserOofSettingsResponse class members, see the SetUserOofSettingsResponse Members topic.

Public Instance Properties

ResponseMessage

See Also

SetUserOofSettingsResponse Class | Aspose.Email.Exchange.Schema Namespace


ResponseMessage Property

Aspose.Email

SetUserOofSettingsResponse.ResponseMessage Property

public ResponseMessageType ResponseMessage {get; set;}

Remarks

See Also

SetUserOofSettingsResponse Class | Aspose.Email.Exchange.Schema Namespace


SharingDataType Enumeration

public enum SharingDataType

Remarks

Members

Member Name | Description | Value
Calendar |  | 0
Contacts |  | 1

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


SingleRecipientType Class

For a list of all members of this type, see SingleRecipientType Members.

System.Object
Aspose.Email.Exchange.Schema.SingleRecipientType

public class SingleRecipientType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SingleRecipientType Members | Aspose.Email.Exchange.Schema Namespace


SingleRecipientType Members

SingleRecipientType overview

Public Instance Constructors

SingleRecipientType Constructor Initializes a new instance of the SingleRecipientType class.

Public Instance Properties

Item

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SingleRecipientType Class | Aspose.Email.Exchange.Schema Namespace


SingleRecipientType Constructor

Initializes a new instance of the SingleRecipientType class.

public SingleRecipientType();

See Also

SingleRecipientType Class | Aspose.Email.Exchange.Schema Namespace


SingleRecipientType Properties

The properties of the SingleRecipientType class are listed below. For a complete list of SingleRecipientType class members, see the SingleRecipientType Members topic.

Public Instance Properties

Item

See Also

SingleRecipientType Class | Aspose.Email.Exchange.Schema Namespace


Item Property

Aspose.Email

SingleRecipientType.Item Property

public EmailAddressType Item {get; set;}

Remarks

See Also

SingleRecipientType Class | Aspose.Email.Exchange.Schema Namespace


SmartResponseBaseType Class

For a list of all members of this type, see SmartResponseBaseType Members.

System.Object
Aspose.Email.Exchange.Schema.ItemType
Aspose.Email.Exchange.Schema.MessageType
Aspose.Email.Exchange.Schema.ResponseObjectCoreType
Aspose.Email.Exchange.Schema.ResponseObjectType
Aspose.Email.Exchange.Schema.SmartResponseBaseType
Aspose.Email.Exchange.Schema.SmartResponseType

public class SmartResponseBaseType : ResponseObjectType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SmartResponseBaseType Members | Aspose.Email.Exchange.Schema Namespace


SmartResponseBaseType Members

SmartResponseBaseType overview

Public Instance Constructors

SmartResponseBaseType Constructor Initializes a new instance of the SmartResponseBaseType class.

Public Instance Properties

Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
From (inherited from MessageType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
ObjectName (inherited from ResponseObjectType)
ParentFolderId (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
ReferenceItemId (inherited from ResponseObjectCoreType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
Subject (inherited from ItemType)
ToRecipients (inherited from MessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SmartResponseBaseType Class | Aspose.Email.Exchange.Schema Namespace


SmartResponseBaseType Constructor

Initializes a new instance of the SmartResponseBaseType class.

public SmartResponseBaseType();

See Also

SmartResponseBaseType Class | Aspose.Email.Exchange.Schema Namespace


SmartResponseType Class

For a list of all members of this type, see SmartResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.ItemType
Aspose.Email.Exchange.Schema.MessageType
Aspose.Email.Exchange.Schema.ResponseObjectCoreType
Aspose.Email.Exchange.Schema.ResponseObjectType
Aspose.Email.Exchange.Schema.SmartResponseBaseType
Aspose.Email.Exchange.Schema.SmartResponseType
Aspose.Email.Exchange.Schema.CancelCalendarItemType
Aspose.Email.Exchange.Schema.ForwardItemType
Aspose.Email.Exchange.Schema.ReplyAllToItemType
Aspose.Email.Exchange.Schema.ReplyToItemType

public class SmartResponseType : SmartResponseBaseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SmartResponseType Members | Aspose.Email.Exchange.Schema Namespace


SmartResponseType Members

SmartResponseType overview

Public Instance Constructors

SmartResponseType Constructor Initializes a new instance of the SmartResponseType class.

Public Instance Properties

Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
From (inherited from MessageType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
NewBodyContent
ObjectName (inherited from ResponseObjectType)
ParentFolderId (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
ReferenceItemId (inherited from ResponseObjectCoreType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
Subject (inherited from ItemType)
ToRecipients (inherited from MessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SmartResponseType Class | Aspose.Email.Exchange.Schema Namespace


SmartResponseType Constructor

Initializes a new instance of the SmartResponseType class.

public SmartResponseType();

See Also

SmartResponseType Class | Aspose.Email.Exchange.Schema Namespace


SmartResponseType Properties

The properties of the SmartResponseType class are listed below. For a complete list of SmartResponseType class members, see the SmartResponseType Members topic.

Public Instance Properties

Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
From (inherited from MessageType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
NewBodyContent
ObjectName (inherited from ResponseObjectType)
ParentFolderId (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
ReferenceItemId (inherited from ResponseObjectCoreType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
Subject (inherited from ItemType)
ToRecipients (inherited from MessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

See Also

SmartResponseType Class | Aspose.Email.Exchange.Schema Namespace


NewBodyContent Property

Aspose.Email

SmartResponseType.NewBodyContent Property

public BodyType NewBodyContent {get; set;}

Remarks

See Also

SmartResponseType Class | Aspose.Email.Exchange.Schema Namespace


SmtpDomain Class

For a list of all members of this type, see SmtpDomain Members.

System.Object
Aspose.Email.Exchange.Schema.SmtpDomain

public class SmtpDomain

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SmtpDomain Members | Aspose.Email.Exchange.Schema Namespace


SmtpDomain Members

SmtpDomain overview

Public Instance Constructors

SmtpDomain Constructor Initializes a new instance of the SmtpDomain class.

Public Instance Properties

IncludeSubdomains
IncludeSubdomainsSpecified
Name

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SmtpDomain Class | Aspose.Email.Exchange.Schema Namespace


SmtpDomain Constructor

Initializes a new instance of the SmtpDomain class.

public SmtpDomain();

See Also

SmtpDomain Class | Aspose.Email.Exchange.Schema Namespace


SmtpDomain Properties

The properties of the SmtpDomain class are listed below. For a complete list of SmtpDomain class members, see the SmtpDomain Members topic.

Public Instance Properties

IncludeSubdomains
IncludeSubdomainsSpecified
Name

See Also

SmtpDomain Class | Aspose.Email.Exchange.Schema Namespace


IncludeSubdomains Property

Aspose.Email

SmtpDomain.IncludeSubdomains Property

public bool IncludeSubdomains {get; set;}

Remarks

See Also

SmtpDomain Class | Aspose.Email.Exchange.Schema Namespace


IncludeSubdomainsSpecified Property

Aspose.Email

SmtpDomain.IncludeSubdomainsSpecified Property

public bool IncludeSubdomainsSpecified {get; set;}

Remarks

See Also

SmtpDomain Class | Aspose.Email.Exchange.Schema Namespace


Name Property

Aspose.Email

SmtpDomain.Name Property

public string Name {get; set;}

Remarks

See Also

SmtpDomain Class | Aspose.Email.Exchange.Schema Namespace


SortDirectionType Enumeration

public enum SortDirectionType

Remarks

Members

Member Name | Description | Value
Ascending |  | 0
Descending |  | 1

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


StandardGroupByType Enumeration

public enum StandardGroupByType

Remarks

Members

Member Name | Description | Value
ConversationTopic |  | 0

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


StreamingSubscriptionRequestType Class

For a list of all members of this type, see StreamingSubscriptionRequestType Members.

System.Object
Aspose.Email.Exchange.Schema.StreamingSubscriptionRequestType

public class StreamingSubscriptionRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

StreamingSubscriptionRequestType Members | Aspose.Email.Exchange.Schema Namespace


StreamingSubscriptionRequestType Members

StreamingSubscriptionRequestType overview

Public Instance Constructors

StreamingSubscriptionRequestType Constructor Initializes a new instance of the StreamingSubscriptionRequestType class.

Public Instance Properties

EventTypes
FolderIds
SubscribeToAllFolders
SubscribeToAllFoldersSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StreamingSubscriptionRequestType Class | Aspose.Email.Exchange.Schema Namespace


StreamingSubscriptionRequestType Constructor

Initializes a new instance of the StreamingSubscriptionRequestType class.

public StreamingSubscriptionRequestType();

See Also

StreamingSubscriptionRequestType Class | Aspose.Email.Exchange.Schema Namespace


StreamingSubscriptionRequestType Properties

The properties of the StreamingSubscriptionRequestType class are listed below. For a complete list of StreamingSubscriptionRequestType class members, see the StreamingSubscriptionRequestType Members topic.

Public Instance Properties

EventTypes
FolderIds
SubscribeToAllFolders
SubscribeToAllFoldersSpecified

See Also

StreamingSubscriptionRequestType Class | Aspose.Email.Exchange.Schema Namespace


EventTypes Property

Aspose.Email

StreamingSubscriptionRequestType.EventTypes Property

public NotificationEventTypeType[] EventTypes {get; set;}

Remarks

See Also

StreamingSubscriptionRequestType Class | Aspose.Email.Exchange.Schema Namespace


FolderIds Property

Aspose.Email

StreamingSubscriptionRequestType.FolderIds Property

public BaseFolderIdType[] FolderIds {get; set;}

Remarks

See Also

StreamingSubscriptionRequestType Class | Aspose.Email.Exchange.Schema Namespace


SubscribeToAllFolders Property

Aspose.Email

StreamingSubscriptionRequestType.SubscribeToAllFolders Property

public bool SubscribeToAllFolders {get; set;}

Remarks

See Also

StreamingSubscriptionRequestType Class | Aspose.Email.Exchange.Schema Namespace


SubscribeToAllFoldersSpecified Property

Aspose.Email

StreamingSubscriptionRequestType.SubscribeToAllFoldersSpecified Property

public bool SubscribeToAllFoldersSpecified {get; set;}

Remarks

See Also

StreamingSubscriptionRequestType Class | Aspose.Email.Exchange.Schema Namespace


SubscribeCompletedEventArgs Class

For a list of all members of this type, see SubscribeCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.SubscribeCompletedEventArgs

public class SubscribeCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SubscribeCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


SubscribeCompletedEventArgs Members

SubscribeCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

SubscribeCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


SubscribeCompletedEventArgs Properties

The properties of the SubscribeCompletedEventArgs class are listed below. For a complete list of SubscribeCompletedEventArgs class members, see the SubscribeCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

SubscribeCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

SubscribeCompletedEventArgs.Result Property

public SubscribeResponseType Result {get;}

Remarks

See Also

SubscribeCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


SubscribeCompletedEventHandler Delegate

public delegate void SubscribeCompletedEventHandler(
object sender,
SubscribeCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


SubscribeResponseMessageType Class

For a list of all members of this type, see SubscribeResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ResponseMessageType
Aspose.Email.Exchange.Schema.SubscribeResponseMessageType

public class SubscribeResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SubscribeResponseMessageType Members | Aspose.Email.Exchange.Schema Namespace


SubscribeResponseMessageType Members

SubscribeResponseMessageType overview

Public Instance Constructors

SubscribeResponseMessageType Constructor Initializes a new instance of the SubscribeResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
SubscriptionId
Watermark

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SubscribeResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


SubscribeResponseMessageType Constructor

Initializes a new instance of the SubscribeResponseMessageType class.

public SubscribeResponseMessageType();

See Also

SubscribeResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


SubscribeResponseMessageType Properties

The properties of the SubscribeResponseMessageType class are listed below. For a complete list of SubscribeResponseMessageType class members, see the SubscribeResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
SubscriptionId
Watermark

See Also

SubscribeResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


SubscriptionId Property

Aspose.Email

SubscribeResponseMessageType.SubscriptionId Property

public string SubscriptionId {get; set;}

Remarks

See Also

SubscribeResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


Watermark Property

Aspose.Email

SubscribeResponseMessageType.Watermark Property

public string Watermark {get; set;}

Remarks

See Also

SubscribeResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


SubscribeResponseType Class

For a list of all members of this type, see SubscribeResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseResponseMessageType
Aspose.Email.Exchange.Schema.SubscribeResponseType

public class SubscribeResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SubscribeResponseType Members | Aspose.Email.Exchange.Schema Namespace


SubscribeResponseType Members

SubscribeResponseType overview

Public Instance Constructors

SubscribeResponseType Constructor Initializes a new instance of the SubscribeResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SubscribeResponseType Class | Aspose.Email.Exchange.Schema Namespace


SubscribeResponseType Constructor

Initializes a new instance of the SubscribeResponseType class.

public SubscribeResponseType();

See Also

SubscribeResponseType Class | Aspose.Email.Exchange.Schema Namespace


SubscribeType Class

For a list of all members of this type, see SubscribeType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.SubscribeType

public class SubscribeType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SubscribeType Members | Aspose.Email.Exchange.Schema Namespace


SubscribeType Members

SubscribeType overview

Public Instance Constructors

SubscribeType Constructor Initializes a new instance of the SubscribeType class.

Public Instance Properties

Item

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SubscribeType Class | Aspose.Email.Exchange.Schema Namespace


SubscribeType Constructor

Initializes a new instance of the SubscribeType class.

public SubscribeType();

See Also

SubscribeType Class | Aspose.Email.Exchange.Schema Namespace


SubscribeType Properties

The properties of the SubscribeType class are listed below. For a complete list of SubscribeType class members, see the SubscribeType Members topic.

Public Instance Properties

Item

See Also

SubscribeType Class | Aspose.Email.Exchange.Schema Namespace


Item Property

Aspose.Email

SubscribeType.Item Property

public object Item {get; set;}

Remarks

See Also

SubscribeType Class | Aspose.Email.Exchange.Schema Namespace


Suggestion Class

For a list of all members of this type, see Suggestion Members.

System.Object
Aspose.Email.Exchange.Schema.Suggestion

public class Suggestion

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Suggestion Members | Aspose.Email.Exchange.Schema Namespace


Suggestion Members

Suggestion overview

Public Instance Constructors

Suggestion Constructor Initializes a new instance of the Suggestion class.

Public Instance Properties

AttendeeConflictDataArray
IsWorkTime
MeetingTime
SuggestionQuality

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Suggestion Class | Aspose.Email.Exchange.Schema Namespace


Suggestion Constructor

Initializes a new instance of the Suggestion class.

public Suggestion();

See Also

Suggestion Class | Aspose.Email.Exchange.Schema Namespace


Suggestion Properties

The properties of the Suggestion class are listed below. For a complete list of Suggestion class members, see the Suggestion Members topic.

Public Instance Properties

AttendeeConflictDataArray
IsWorkTime
MeetingTime
SuggestionQuality

See Also

Suggestion Class | Aspose.Email.Exchange.Schema Namespace


AttendeeConflictDataArray Property

Aspose.Email

Suggestion.AttendeeConflictDataArray Property

public AttendeeConflictData[] AttendeeConflictDataArray {get; set;}

Remarks

See Also

Suggestion Class | Aspose.Email.Exchange.Schema Namespace


IsWorkTime Property

Aspose.Email

Suggestion.IsWorkTime Property

public bool IsWorkTime {get; set;}

Remarks

See Also

Suggestion Class | Aspose.Email.Exchange.Schema Namespace


MeetingTime Property

Aspose.Email

Suggestion.MeetingTime Property

public DateTime MeetingTime {get; set;}

Remarks

See Also

Suggestion Class | Aspose.Email.Exchange.Schema Namespace


SuggestionQuality Property

Aspose.Email

Suggestion.SuggestionQuality Property

public SuggestionQuality SuggestionQuality {get; set;}

Remarks

See Also

Suggestion Class | Aspose.Email.Exchange.Schema Namespace


SuggestionDayResult Class

For a list of all members of this type, see SuggestionDayResult Members.

System.Object
Aspose.Email.Exchange.Schema.SuggestionDayResult

public class SuggestionDayResult

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SuggestionDayResult Members | Aspose.Email.Exchange.Schema Namespace


SuggestionDayResult Members

SuggestionDayResult overview

Public Instance Constructors

SuggestionDayResult Constructor Initializes a new instance of the SuggestionDayResult class.

Public Instance Properties

Date
DayQuality
SuggestionArray

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SuggestionDayResult Class | Aspose.Email.Exchange.Schema Namespace


SuggestionDayResult Constructor

Initializes a new instance of the SuggestionDayResult class.

public SuggestionDayResult();

See Also

SuggestionDayResult Class | Aspose.Email.Exchange.Schema Namespace


SuggestionDayResult Properties

The properties of the SuggestionDayResult class are listed below. For a complete list of SuggestionDayResult class members, see the SuggestionDayResult Members topic.

Public Instance Properties

Date
DayQuality
SuggestionArray

See Also

SuggestionDayResult Class | Aspose.Email.Exchange.Schema Namespace


Date Property

Aspose.Email

SuggestionDayResult.Date Property

public DateTime Date {get; set;}

Remarks

See Also

SuggestionDayResult Class | Aspose.Email.Exchange.Schema Namespace


DayQuality Property

Aspose.Email

SuggestionDayResult.DayQuality Property

public SuggestionQuality DayQuality {get; set;}

Remarks

See Also

SuggestionDayResult Class | Aspose.Email.Exchange.Schema Namespace


SuggestionArray Property

Aspose.Email

SuggestionDayResult.SuggestionArray Property

public Suggestion[] SuggestionArray {get; set;}

Remarks

See Also

SuggestionDayResult Class | Aspose.Email.Exchange.Schema Namespace


SuggestionQuality Enumeration

public enum SuggestionQuality

Remarks

Members

Member Name | Description | Value
Excellent |  | 0
Good |  | 1
Fair |  | 2
Poor |  | 3

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


SuggestionsResponseType Class

For a list of all members of this type, see SuggestionsResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.SuggestionsResponseType

public class SuggestionsResponseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SuggestionsResponseType Members | Aspose.Email.Exchange.Schema Namespace


SuggestionsResponseType Members

SuggestionsResponseType overview

Public Instance Constructors

SuggestionsResponseType Constructor Initializes a new instance of the SuggestionsResponseType class.

Public Instance Properties

ResponseMessage
SuggestionDayResultArray

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SuggestionsResponseType Class | Aspose.Email.Exchange.Schema Namespace


SuggestionsResponseType Constructor

Initializes a new instance of the SuggestionsResponseType class.

public SuggestionsResponseType();

See Also

SuggestionsResponseType Class | Aspose.Email.Exchange.Schema Namespace


SuggestionsResponseType Properties

The properties of the SuggestionsResponseType class are listed below. For a complete list of SuggestionsResponseType class members, see the SuggestionsResponseType Members topic.

Public Instance Properties

ResponseMessage
SuggestionDayResultArray

See Also

SuggestionsResponseType Class | Aspose.Email.Exchange.Schema Namespace


ResponseMessage Property

Aspose.Email

SuggestionsResponseType.ResponseMessage Property

public ResponseMessageType ResponseMessage {get; set;}

Remarks

See Also

SuggestionsResponseType Class | Aspose.Email.Exchange.Schema Namespace


SuggestionDayResultArray Property

Aspose.Email

SuggestionsResponseType.SuggestionDayResultArray Property

public SuggestionDayResult[] SuggestionDayResultArray {get; set;}

Remarks

See Also

SuggestionsResponseType Class | Aspose.Email.Exchange.Schema Namespace


SuggestionsViewOptionsType Class

For a list of all members of this type, see SuggestionsViewOptionsType Members.

System.Object
Aspose.Email.Exchange.Schema.SuggestionsViewOptionsType

public class SuggestionsViewOptionsType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SuggestionsViewOptionsType Members | Aspose.Email.Exchange.Schema Namespace


SuggestionsViewOptionsType Members

SuggestionsViewOptionsType overview

Public Instance Constructors

SuggestionsViewOptionsType Constructor Initializes a new instance of the SuggestionsViewOptionsType class.

Public Instance Properties

CurrentMeetingTime
CurrentMeetingTimeSpecified
DetailedSuggestionsWindow
GlobalObjectId
GoodThreshold
GoodThresholdSpecified
MaximumNonWorkHourResultsByDay
MaximumNonWorkHourResultsByDaySpecified
MaximumResultsByDay
MaximumResultsByDaySpecified
MeetingDurationInMinutes
MeetingDurationInMinutesSpecified
MinimumSuggestionQuality
MinimumSuggestionQualitySpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SuggestionsViewOptionsType Class | Aspose.Email.Exchange.Schema Namespace


SuggestionsViewOptionsType Constructor

Initializes a new instance of the SuggestionsViewOptionsType class.

public SuggestionsViewOptionsType();

See Also

SuggestionsViewOptionsType Class | Aspose.Email.Exchange.Schema Namespace


SuggestionsViewOptionsType Properties

The properties of the SuggestionsViewOptionsType class are listed below. For a complete list of SuggestionsViewOptionsType class members, see the SuggestionsViewOptionsType Members topic.

Public Instance Properties

CurrentMeetingTime
CurrentMeetingTimeSpecified
DetailedSuggestionsWindow
GlobalObjectId
GoodThreshold
GoodThresholdSpecified
MaximumNonWorkHourResultsByDay
MaximumNonWorkHourResultsByDaySpecified
MaximumResultsByDay
MaximumResultsByDaySpecified
MeetingDurationInMinutes
MeetingDurationInMinutesSpecified
MinimumSuggestionQuality
MinimumSuggestionQualitySpecified

See Also

SuggestionsViewOptionsType Class | Aspose.Email.Exchange.Schema Namespace


CurrentMeetingTime Property

Aspose.Email

SuggestionsViewOptionsType.CurrentMeetingTime Property

public DateTime CurrentMeetingTime {get; set;}

Remarks

See Also

SuggestionsViewOptionsType Class | Aspose.Email.Exchange.Schema Namespace


CurrentMeetingTimeSpecified Property

Aspose.Email

SuggestionsViewOptionsType.CurrentMeetingTimeSpecified Property

public bool CurrentMeetingTimeSpecified {get; set;}

Remarks

See Also

SuggestionsViewOptionsType Class | Aspose.Email.Exchange.Schema Namespace


DetailedSuggestionsWindow Property

Aspose.Email

SuggestionsViewOptionsType.DetailedSuggestionsWindow Property

public Duration DetailedSuggestionsWindow {get; set;}

Remarks

See Also

SuggestionsViewOptionsType Class | Aspose.Email.Exchange.Schema Namespace


GlobalObjectId Property

Aspose.Email

SuggestionsViewOptionsType.GlobalObjectId Property

public string GlobalObjectId {get; set;}

Remarks

See Also

SuggestionsViewOptionsType Class | Aspose.Email.Exchange.Schema Namespace


GoodThreshold Property

Aspose.Email

SuggestionsViewOptionsType.GoodThreshold Property

public int GoodThreshold {get; set;}

Remarks

See Also

SuggestionsViewOptionsType Class | Aspose.Email.Exchange.Schema Namespace


GoodThresholdSpecified Property

Aspose.Email

SuggestionsViewOptionsType.GoodThresholdSpecified Property

public bool GoodThresholdSpecified {get; set;}

Remarks

See Also

SuggestionsViewOptionsType Class | Aspose.Email.Exchange.Schema Namespace


MaximumNonWorkHourResultsByDay Property

Aspose.Email

SuggestionsViewOptionsType.MaximumNonWorkHourResultsByDay Property

public int MaximumNonWorkHourResultsByDay {get; set;}

Remarks

See Also

SuggestionsViewOptionsType Class | Aspose.Email.Exchange.Schema Namespace


MaximumNonWorkHourResultsByDaySpecified Property

Aspose.Email

SuggestionsViewOptionsType.MaximumNonWorkHourResultsByDaySpecified Property

public bool MaximumNonWorkHourResultsByDaySpecified {get; set;}

Remarks

See Also

SuggestionsViewOptionsType Class | Aspose.Email.Exchange.Schema Namespace


MaximumResultsByDay Property

Aspose.Email

SuggestionsViewOptionsType.MaximumResultsByDay Property

public int MaximumResultsByDay {get; set;}

Remarks

See Also

SuggestionsViewOptionsType Class | Aspose.Email.Exchange.Schema Namespace


MaximumResultsByDaySpecified Property

Aspose.Email

SuggestionsViewOptionsType.MaximumResultsByDaySpecified Property

public bool MaximumResultsByDaySpecified {get; set;}

Remarks

See Also

SuggestionsViewOptionsType Class | Aspose.Email.Exchange.Schema Namespace


MeetingDurationInMinutes Property

Aspose.Email

SuggestionsViewOptionsType.MeetingDurationInMinutes Property

public int MeetingDurationInMinutes {get; set;}

Remarks

See Also

SuggestionsViewOptionsType Class | Aspose.Email.Exchange.Schema Namespace


MeetingDurationInMinutesSpecified Property

Aspose.Email

SuggestionsViewOptionsType.MeetingDurationInMinutesSpecified Property

public bool MeetingDurationInMinutesSpecified {get; set;}

Remarks

See Also

SuggestionsViewOptionsType Class | Aspose.Email.Exchange.Schema Namespace


MinimumSuggestionQuality Property

Aspose.Email

SuggestionsViewOptionsType.MinimumSuggestionQuality Property

public SuggestionQuality MinimumSuggestionQuality {get; set;}

Remarks

See Also

SuggestionsViewOptionsType Class | Aspose.Email.Exchange.Schema Namespace


MinimumSuggestionQualitySpecified Property

Aspose.Email

SuggestionsViewOptionsType.MinimumSuggestionQualitySpecified Property

public bool MinimumSuggestionQualitySpecified {get; set;}

Remarks

See Also

SuggestionsViewOptionsType Class | Aspose.Email.Exchange.Schema Namespace


SuppressReadReceiptType Class

For a list of all members of this type, see SuppressReadReceiptType Members.

System.Object
Aspose.Email.Exchange.Schema.ItemType
Aspose.Email.Exchange.Schema.MessageType
Aspose.Email.Exchange.Schema.ResponseObjectCoreType
Aspose.Email.Exchange.Schema.ResponseObjectType
Aspose.Email.Exchange.Schema.ReferenceItemResponseType
Aspose.Email.Exchange.Schema.SuppressReadReceiptType

public class SuppressReadReceiptType : ReferenceItemResponseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SuppressReadReceiptType Members | Aspose.Email.Exchange.Schema Namespace


SuppressReadReceiptType Members

SuppressReadReceiptType overview

Public Instance Constructors

SuppressReadReceiptType Constructor Initializes a new instance of the SuppressReadReceiptType class.

Public Instance Properties

Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
From (inherited from MessageType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
ObjectName (inherited from ResponseObjectType)
ParentFolderId (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
ReferenceItemId (inherited from ResponseObjectCoreType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
Subject (inherited from ItemType)
ToRecipients (inherited from MessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SuppressReadReceiptType Class | Aspose.Email.Exchange.Schema Namespace


SuppressReadReceiptType Constructor

Initializes a new instance of the SuppressReadReceiptType class.

public SuppressReadReceiptType();

See Also

SuppressReadReceiptType Class | Aspose.Email.Exchange.Schema Namespace


SyncFolderHierarchyChangesType Class

For a list of all members of this type, see SyncFolderHierarchyChangesType Members.

System.Object
Aspose.Email.Exchange.Schema.SyncFolderHierarchyChangesType

public class SyncFolderHierarchyChangesType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SyncFolderHierarchyChangesType Members | Aspose.Email.Exchange.Schema Namespace


SyncFolderHierarchyChangesType Members

SyncFolderHierarchyChangesType overview

Public Instance Constructors

SyncFolderHierarchyChangesType Constructor Initializes a new instance of the SyncFolderHierarchyChangesType class.

Public Instance Properties

Items
ItemsElementName

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyncFolderHierarchyChangesType Class | Aspose.Email.Exchange.Schema Namespace


SyncFolderHierarchyChangesType Constructor

Initializes a new instance of the SyncFolderHierarchyChangesType class.

public SyncFolderHierarchyChangesType();

See Also

SyncFolderHierarchyChangesType Class | Aspose.Email.Exchange.Schema Namespace


SyncFolderHierarchyChangesType Properties

The properties of the SyncFolderHierarchyChangesType class are listed below. For a complete list of SyncFolderHierarchyChangesType class members, see the SyncFolderHierarchyChangesType Members topic.

Public Instance Properties

Items
ItemsElementName

See Also

SyncFolderHierarchyChangesType Class | Aspose.Email.Exchange.Schema Namespace


Items Property

Aspose.Email

SyncFolderHierarchyChangesType.Items Property

public object[] Items {get; set;}

Remarks

See Also

SyncFolderHierarchyChangesType Class | Aspose.Email.Exchange.Schema Namespace


ItemsElementName Property

Aspose.Email

SyncFolderHierarchyChangesType.ItemsElementName Property

public ItemsChoiceType1[] ItemsElementName {get; set;}

Remarks

See Also

SyncFolderHierarchyChangesType Class | Aspose.Email.Exchange.Schema Namespace


SyncFolderHierarchyCompletedEventArgs Class

For a list of all members of this type, see SyncFolderHierarchyCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.SyncFolderHierarchyCompletedEventArgs

public class SyncFolderHierarchyCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SyncFolderHierarchyCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


SyncFolderHierarchyCompletedEventArgs Members

SyncFolderHierarchyCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

SyncFolderHierarchyCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


SyncFolderHierarchyCompletedEventArgs Properties

The properties of the SyncFolderHierarchyCompletedEventArgs class are listed below. For a complete list of SyncFolderHierarchyCompletedEventArgs class members, see the SyncFolderHierarchyCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

SyncFolderHierarchyCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

SyncFolderHierarchyCompletedEventArgs.Result Property

public SyncFolderHierarchyResponseType Result {get;}

Remarks

See Also

SyncFolderHierarchyCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


SyncFolderHierarchyCompletedEventHandler Delegate

public delegate void SyncFolderHierarchyCompletedEventHandler(
object sender,
SyncFolderHierarchyCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


SyncFolderHierarchyCreateOrUpdateType Class

For a list of all members of this type, see SyncFolderHierarchyCreateOrUpdateType Members.

System.Object
Aspose.Email.Exchange.Schema.SyncFolderHierarchyCreateOrUpdateType

public class SyncFolderHierarchyCreateOrUpdateType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SyncFolderHierarchyCreateOrUpdateType Members | Aspose.Email.Exchange.Schema Namespace


SyncFolderHierarchyCreateOrUpdateType Members

SyncFolderHierarchyCreateOrUpdateType overview

Public Instance Constructors

SyncFolderHierarchyCreateOrUpdateType Constructor Initializes a new instance of the SyncFolderHierarchyCreateOrUpdateType class.

Public Instance Properties

Item

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyncFolderHierarchyCreateOrUpdateType Class | Aspose.Email.Exchange.Schema Namespace


SyncFolderHierarchyCreateOrUpdateType Constructor

Initializes a new instance of the SyncFolderHierarchyCreateOrUpdateType class.

public SyncFolderHierarchyCreateOrUpdateType();

See Also

SyncFolderHierarchyCreateOrUpdateType Class | Aspose.Email.Exchange.Schema Namespace


SyncFolderHierarchyCreateOrUpdateType Properties

The properties of the SyncFolderHierarchyCreateOrUpdateType class are listed below. For a complete list of SyncFolderHierarchyCreateOrUpdateType class members, see the SyncFolderHierarchyCreateOrUpdateType Members topic.

Public Instance Properties

Item

See Also

SyncFolderHierarchyCreateOrUpdateType Class | Aspose.Email.Exchange.Schema Namespace


Item Property

Aspose.Email

SyncFolderHierarchyCreateOrUpdateType.Item Property

public BaseFolderType Item {get; set;}

Remarks

See Also

SyncFolderHierarchyCreateOrUpdateType Class | Aspose.Email.Exchange.Schema Namespace


SyncFolderHierarchyDeleteType Class

For a list of all members of this type, see SyncFolderHierarchyDeleteType Members.

System.Object
Aspose.Email.Exchange.Schema.SyncFolderHierarchyDeleteType

public class SyncFolderHierarchyDeleteType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SyncFolderHierarchyDeleteType Members | Aspose.Email.Exchange.Schema Namespace


SyncFolderHierarchyDeleteType Members

SyncFolderHierarchyDeleteType overview

Public Instance Constructors

SyncFolderHierarchyDeleteType Constructor Initializes a new instance of the SyncFolderHierarchyDeleteType class.

Public Instance Properties

FolderId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyncFolderHierarchyDeleteType Class | Aspose.Email.Exchange.Schema Namespace


SyncFolderHierarchyDeleteType Constructor

Initializes a new instance of the SyncFolderHierarchyDeleteType class.

public SyncFolderHierarchyDeleteType();

See Also

SyncFolderHierarchyDeleteType Class | Aspose.Email.Exchange.Schema Namespace


SyncFolderHierarchyDeleteType Properties

The properties of the SyncFolderHierarchyDeleteType class are listed below. For a complete list of SyncFolderHierarchyDeleteType class members, see the SyncFolderHierarchyDeleteType Members topic.

Public Instance Properties

FolderId

See Also

SyncFolderHierarchyDeleteType Class | Aspose.Email.Exchange.Schema Namespace


FolderId Property

Aspose.Email

SyncFolderHierarchyDeleteType.FolderId Property

public FolderIdType FolderId {get; set;}

Remarks

See Also

SyncFolderHierarchyDeleteType Class | Aspose.Email.Exchange.Schema Namespace


SyncFolderHierarchyResponseMessageType Class

For a list of all members of this type, see SyncFolderHierarchyResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ResponseMessageType
Aspose.Email.Exchange.Schema.SyncFolderHierarchyResponseMessageType

public class SyncFolderHierarchyResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SyncFolderHierarchyResponseMessageType Members | Aspose.Email.Exchange.Schema Namespace


SyncFolderHierarchyResponseMessageType Members

SyncFolderHierarchyResponseMessageType overview

Public Instance Constructors

SyncFolderHierarchyResponseMessageType Constructor Initializes a new instance of the SyncFolderHierarchyResponseMessageType class.

Public Instance Properties

Changes
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
IncludesLastFolderInRange
IncludesLastFolderInRangeSpecified
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
SyncState

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyncFolderHierarchyResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


SyncFolderHierarchyResponseMessageType Constructor

Initializes a new instance of the SyncFolderHierarchyResponseMessageType class.

public SyncFolderHierarchyResponseMessageType();

See Also

SyncFolderHierarchyResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


SyncFolderHierarchyResponseMessageType Properties

The properties of the SyncFolderHierarchyResponseMessageType class are listed below. For a complete list of SyncFolderHierarchyResponseMessageType class members, see the SyncFolderHierarchyResponseMessageType Members topic.

Public Instance Properties

Changes
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
IncludesLastFolderInRange
IncludesLastFolderInRangeSpecified
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
SyncState

See Also

SyncFolderHierarchyResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


Changes Property

Aspose.Email

SyncFolderHierarchyResponseMessageType.Changes Property

public SyncFolderHierarchyChangesType Changes {get; set;}

Remarks

See Also

SyncFolderHierarchyResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


IncludesLastFolderInRange Property

Aspose.Email

SyncFolderHierarchyResponseMessageType.IncludesLastFolderInRange Property

public bool IncludesLastFolderInRange {get; set;}

Remarks

See Also

SyncFolderHierarchyResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


IncludesLastFolderInRangeSpecified Property

Aspose.Email

SyncFolderHierarchyResponseMessageType.IncludesLastFolderInRangeSpecified Property

public bool IncludesLastFolderInRangeSpecified {get; set;}

Remarks

See Also

SyncFolderHierarchyResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


SyncState Property

Aspose.Email

SyncFolderHierarchyResponseMessageType.SyncState Property

public string SyncState {get; set;}

Remarks

See Also

SyncFolderHierarchyResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


SyncFolderHierarchyResponseType Class

For a list of all members of this type, see SyncFolderHierarchyResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseResponseMessageType
Aspose.Email.Exchange.Schema.SyncFolderHierarchyResponseType

public class SyncFolderHierarchyResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SyncFolderHierarchyResponseType Members | Aspose.Email.Exchange.Schema Namespace


SyncFolderHierarchyResponseType Members

SyncFolderHierarchyResponseType overview

Public Instance Constructors

SyncFolderHierarchyResponseType Constructor Initializes a new instance of the SyncFolderHierarchyResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyncFolderHierarchyResponseType Class | Aspose.Email.Exchange.Schema Namespace


SyncFolderHierarchyResponseType Constructor

Initializes a new instance of the SyncFolderHierarchyResponseType class.

public SyncFolderHierarchyResponseType();

See Also

SyncFolderHierarchyResponseType Class | Aspose.Email.Exchange.Schema Namespace


SyncFolderHierarchyType Class

For a list of all members of this type, see SyncFolderHierarchyType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.SyncFolderHierarchyType

public class SyncFolderHierarchyType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SyncFolderHierarchyType Members | Aspose.Email.Exchange.Schema Namespace


SyncFolderHierarchyType Members

SyncFolderHierarchyType overview

Public Instance Constructors

SyncFolderHierarchyType Constructor Initializes a new instance of the SyncFolderHierarchyType class.

Public Instance Properties

FolderShape
SyncFolderId
SyncState

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyncFolderHierarchyType Class | Aspose.Email.Exchange.Schema Namespace


SyncFolderHierarchyType Constructor

Initializes a new instance of the SyncFolderHierarchyType class.

public SyncFolderHierarchyType();

See Also

SyncFolderHierarchyType Class | Aspose.Email.Exchange.Schema Namespace


SyncFolderHierarchyType Properties

The properties of the SyncFolderHierarchyType class are listed below. For a complete list of SyncFolderHierarchyType class members, see the SyncFolderHierarchyType Members topic.

Public Instance Properties

FolderShape
SyncFolderId
SyncState

See Also

SyncFolderHierarchyType Class | Aspose.Email.Exchange.Schema Namespace


FolderShape Property

Aspose.Email

SyncFolderHierarchyType.FolderShape Property

public FolderResponseShapeType FolderShape {get; set;}

Remarks

See Also

SyncFolderHierarchyType Class | Aspose.Email.Exchange.Schema Namespace


SyncFolderId Property

Aspose.Email

SyncFolderHierarchyType.SyncFolderId Property

public TargetFolderIdType SyncFolderId {get; set;}

Remarks

See Also

SyncFolderHierarchyType Class | Aspose.Email.Exchange.Schema Namespace


SyncState Property

Aspose.Email

SyncFolderHierarchyType.SyncState Property

public string SyncState {get; set;}

Remarks

See Also

SyncFolderHierarchyType Class | Aspose.Email.Exchange.Schema Namespace


SyncFolderItemsChangesType Class

For a list of all members of this type, see SyncFolderItemsChangesType Members.

System.Object
Aspose.Email.Exchange.Schema.SyncFolderItemsChangesType

public class SyncFolderItemsChangesType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SyncFolderItemsChangesType Members | Aspose.Email.Exchange.Schema Namespace


SyncFolderItemsChangesType Members

SyncFolderItemsChangesType overview

Public Instance Constructors

SyncFolderItemsChangesType Constructor Initializes a new instance of the SyncFolderItemsChangesType class.

Public Instance Properties

Items
ItemsElementName

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyncFolderItemsChangesType Class | Aspose.Email.Exchange.Schema Namespace


SyncFolderItemsChangesType Constructor

Initializes a new instance of the SyncFolderItemsChangesType class.

public SyncFolderItemsChangesType();

See Also

SyncFolderItemsChangesType Class | Aspose.Email.Exchange.Schema Namespace


SyncFolderItemsChangesType Properties

The properties of the SyncFolderItemsChangesType class are listed below. For a complete list of SyncFolderItemsChangesType class members, see the SyncFolderItemsChangesType Members topic.

Public Instance Properties

Items
ItemsElementName

See Also

SyncFolderItemsChangesType Class | Aspose.Email.Exchange.Schema Namespace


Items Property

Aspose.Email

SyncFolderItemsChangesType.Items Property

public object[] Items {get; set;}

Remarks

See Also

SyncFolderItemsChangesType Class | Aspose.Email.Exchange.Schema Namespace


ItemsElementName Property

Aspose.Email

SyncFolderItemsChangesType.ItemsElementName Property

public ItemsChoiceType2[] ItemsElementName {get; set;}

Remarks

See Also

SyncFolderItemsChangesType Class | Aspose.Email.Exchange.Schema Namespace


SyncFolderItemsCompletedEventArgs Class

For a list of all members of this type, see SyncFolderItemsCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.SyncFolderItemsCompletedEventArgs

public class SyncFolderItemsCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SyncFolderItemsCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


SyncFolderItemsCompletedEventArgs Members

SyncFolderItemsCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

SyncFolderItemsCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


SyncFolderItemsCompletedEventArgs Properties

The properties of the SyncFolderItemsCompletedEventArgs class are listed below. For a complete list of SyncFolderItemsCompletedEventArgs class members, see the SyncFolderItemsCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

SyncFolderItemsCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

SyncFolderItemsCompletedEventArgs.Result Property

public SyncFolderItemsResponseType Result {get;}

Remarks

See Also

SyncFolderItemsCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


SyncFolderItemsCompletedEventHandler Delegate

public delegate void SyncFolderItemsCompletedEventHandler(
object sender,
SyncFolderItemsCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


SyncFolderItemsCreateOrUpdateType Class

For a list of all members of this type, see SyncFolderItemsCreateOrUpdateType Members.

System.Object
Aspose.Email.Exchange.Schema.SyncFolderItemsCreateOrUpdateType

public class SyncFolderItemsCreateOrUpdateType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SyncFolderItemsCreateOrUpdateType Members | Aspose.Email.Exchange.Schema Namespace


SyncFolderItemsCreateOrUpdateType Members

SyncFolderItemsCreateOrUpdateType overview

Public Instance Constructors

SyncFolderItemsCreateOrUpdateType Constructor Initializes a new instance of the SyncFolderItemsCreateOrUpdateType class.

Public Instance Properties

Item

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyncFolderItemsCreateOrUpdateType Class | Aspose.Email.Exchange.Schema Namespace


SyncFolderItemsCreateOrUpdateType Constructor

Initializes a new instance of the SyncFolderItemsCreateOrUpdateType class.

public SyncFolderItemsCreateOrUpdateType();

See Also

SyncFolderItemsCreateOrUpdateType Class | Aspose.Email.Exchange.Schema Namespace


SyncFolderItemsCreateOrUpdateType Properties

The properties of the SyncFolderItemsCreateOrUpdateType class are listed below. For a complete list of SyncFolderItemsCreateOrUpdateType class members, see the SyncFolderItemsCreateOrUpdateType Members topic.

Public Instance Properties

Item

See Also

SyncFolderItemsCreateOrUpdateType Class | Aspose.Email.Exchange.Schema Namespace


Item Property

Aspose.Email

SyncFolderItemsCreateOrUpdateType.Item Property

public ItemType Item {get; set;}

Remarks

See Also

SyncFolderItemsCreateOrUpdateType Class | Aspose.Email.Exchange.Schema Namespace


SyncFolderItemsDeleteType Class

For a list of all members of this type, see SyncFolderItemsDeleteType Members.

System.Object
Aspose.Email.Exchange.Schema.SyncFolderItemsDeleteType

public class SyncFolderItemsDeleteType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SyncFolderItemsDeleteType Members | Aspose.Email.Exchange.Schema Namespace


SyncFolderItemsDeleteType Members

SyncFolderItemsDeleteType overview

Public Instance Constructors

SyncFolderItemsDeleteType Constructor Initializes a new instance of the SyncFolderItemsDeleteType class.

Public Instance Properties

ItemId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyncFolderItemsDeleteType Class | Aspose.Email.Exchange.Schema Namespace


SyncFolderItemsDeleteType Constructor

Initializes a new instance of the SyncFolderItemsDeleteType class.

public SyncFolderItemsDeleteType();

See Also

SyncFolderItemsDeleteType Class | Aspose.Email.Exchange.Schema Namespace


SyncFolderItemsDeleteType Properties

The properties of the SyncFolderItemsDeleteType class are listed below. For a complete list of SyncFolderItemsDeleteType class members, see the SyncFolderItemsDeleteType Members topic.

Public Instance Properties

ItemId

See Also

SyncFolderItemsDeleteType Class | Aspose.Email.Exchange.Schema Namespace


ItemId Property

Aspose.Email

SyncFolderItemsDeleteType.ItemId Property

public ItemIdType ItemId {get; set;}

Remarks

See Also

SyncFolderItemsDeleteType Class | Aspose.Email.Exchange.Schema Namespace


SyncFolderItemsReadFlagType Class

For a list of all members of this type, see SyncFolderItemsReadFlagType Members.

System.Object
Aspose.Email.Exchange.Schema.SyncFolderItemsReadFlagType

public class SyncFolderItemsReadFlagType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SyncFolderItemsReadFlagType Members | Aspose.Email.Exchange.Schema Namespace


SyncFolderItemsReadFlagType Members

SyncFolderItemsReadFlagType overview

Public Instance Constructors

SyncFolderItemsReadFlagType Constructor Initializes a new instance of the SyncFolderItemsReadFlagType class.

Public Instance Properties

IsRead
ItemId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyncFolderItemsReadFlagType Class | Aspose.Email.Exchange.Schema Namespace


SyncFolderItemsReadFlagType Constructor

Initializes a new instance of the SyncFolderItemsReadFlagType class.

public SyncFolderItemsReadFlagType();

See Also

SyncFolderItemsReadFlagType Class | Aspose.Email.Exchange.Schema Namespace


SyncFolderItemsReadFlagType Properties

The properties of the SyncFolderItemsReadFlagType class are listed below. For a complete list of SyncFolderItemsReadFlagType class members, see the SyncFolderItemsReadFlagType Members topic.

Public Instance Properties

IsRead
ItemId

See Also

SyncFolderItemsReadFlagType Class | Aspose.Email.Exchange.Schema Namespace


IsRead Property

Aspose.Email

SyncFolderItemsReadFlagType.IsRead Property

public bool IsRead {get; set;}

Remarks

See Also

SyncFolderItemsReadFlagType Class | Aspose.Email.Exchange.Schema Namespace


ItemId Property

Aspose.Email

SyncFolderItemsReadFlagType.ItemId Property

public ItemIdType ItemId {get; set;}

Remarks

See Also

SyncFolderItemsReadFlagType Class | Aspose.Email.Exchange.Schema Namespace


SyncFolderItemsResponseMessageType Class

For a list of all members of this type, see SyncFolderItemsResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ResponseMessageType
Aspose.Email.Exchange.Schema.SyncFolderItemsResponseMessageType

public class SyncFolderItemsResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SyncFolderItemsResponseMessageType Members | Aspose.Email.Exchange.Schema Namespace


SyncFolderItemsResponseMessageType Members

SyncFolderItemsResponseMessageType overview

Public Instance Constructors

SyncFolderItemsResponseMessageType Constructor Initializes a new instance of the SyncFolderItemsResponseMessageType class.

Public Instance Properties

Changes
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
IncludesLastItemInRange
IncludesLastItemInRangeSpecified
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
SyncState

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyncFolderItemsResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


SyncFolderItemsResponseMessageType Constructor

Initializes a new instance of the SyncFolderItemsResponseMessageType class.

public SyncFolderItemsResponseMessageType();

See Also

SyncFolderItemsResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


SyncFolderItemsResponseMessageType Properties

The properties of the SyncFolderItemsResponseMessageType class are listed below. For a complete list of SyncFolderItemsResponseMessageType class members, see the SyncFolderItemsResponseMessageType Members topic.

Public Instance Properties

Changes
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
IncludesLastItemInRange
IncludesLastItemInRangeSpecified
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
SyncState

See Also

SyncFolderItemsResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


Changes Property

Aspose.Email

SyncFolderItemsResponseMessageType.Changes Property

public SyncFolderItemsChangesType Changes {get; set;}

Remarks

See Also

SyncFolderItemsResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


IncludesLastItemInRange Property

Aspose.Email

SyncFolderItemsResponseMessageType.IncludesLastItemInRange Property

public bool IncludesLastItemInRange {get; set;}

Remarks

See Also

SyncFolderItemsResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


IncludesLastItemInRangeSpecified Property

Aspose.Email

SyncFolderItemsResponseMessageType.IncludesLastItemInRangeSpecified Property

public bool IncludesLastItemInRangeSpecified {get; set;}

Remarks

See Also

SyncFolderItemsResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


SyncState Property

Aspose.Email

SyncFolderItemsResponseMessageType.SyncState Property

public string SyncState {get; set;}

Remarks

See Also

SyncFolderItemsResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


SyncFolderItemsResponseType Class

For a list of all members of this type, see SyncFolderItemsResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseResponseMessageType
Aspose.Email.Exchange.Schema.SyncFolderItemsResponseType

public class SyncFolderItemsResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SyncFolderItemsResponseType Members | Aspose.Email.Exchange.Schema Namespace


SyncFolderItemsResponseType Members

SyncFolderItemsResponseType overview

Public Instance Constructors

SyncFolderItemsResponseType Constructor Initializes a new instance of the SyncFolderItemsResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyncFolderItemsResponseType Class | Aspose.Email.Exchange.Schema Namespace


SyncFolderItemsResponseType Constructor

Initializes a new instance of the SyncFolderItemsResponseType class.

public SyncFolderItemsResponseType();

See Also

SyncFolderItemsResponseType Class | Aspose.Email.Exchange.Schema Namespace


SyncFolderItemsScopeType Enumeration

public enum SyncFolderItemsScopeType

Remarks

Members

Member Name | Description | Value
NormalItems |  | 0
NormalAndAssociatedItems |  | 1

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


SyncFolderItemsType Class

For a list of all members of this type, see SyncFolderItemsType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.SyncFolderItemsType

public class SyncFolderItemsType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SyncFolderItemsType Members | Aspose.Email.Exchange.Schema Namespace


SyncFolderItemsType Members

SyncFolderItemsType overview

Public Instance Constructors

SyncFolderItemsType Constructor Initializes a new instance of the SyncFolderItemsType class.

Public Instance Properties

Ignore
ItemShape
MaxChangesReturned
SyncFolderId
SyncScope
SyncScopeSpecified
SyncState

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyncFolderItemsType Class | Aspose.Email.Exchange.Schema Namespace


SyncFolderItemsType Constructor

Initializes a new instance of the SyncFolderItemsType class.

public SyncFolderItemsType();

See Also

SyncFolderItemsType Class | Aspose.Email.Exchange.Schema Namespace


SyncFolderItemsType Properties

The properties of the SyncFolderItemsType class are listed below. For a complete list of SyncFolderItemsType class members, see the SyncFolderItemsType Members topic.

Public Instance Properties

Ignore
ItemShape
MaxChangesReturned
SyncFolderId
SyncScope
SyncScopeSpecified
SyncState

See Also

SyncFolderItemsType Class | Aspose.Email.Exchange.Schema Namespace


Ignore Property

Aspose.Email

SyncFolderItemsType.Ignore Property

public ItemIdType[] Ignore {get; set;}

Remarks

See Also

SyncFolderItemsType Class | Aspose.Email.Exchange.Schema Namespace


ItemShape Property

Aspose.Email

SyncFolderItemsType.ItemShape Property

public ItemResponseShapeType ItemShape {get; set;}

Remarks

See Also

SyncFolderItemsType Class | Aspose.Email.Exchange.Schema Namespace


MaxChangesReturned Property

Aspose.Email

SyncFolderItemsType.MaxChangesReturned Property

public int MaxChangesReturned {get; set;}

Remarks

See Also

SyncFolderItemsType Class | Aspose.Email.Exchange.Schema Namespace


SyncFolderId Property

Aspose.Email

SyncFolderItemsType.SyncFolderId Property

public TargetFolderIdType SyncFolderId {get; set;}

Remarks

See Also

SyncFolderItemsType Class | Aspose.Email.Exchange.Schema Namespace


SyncScope Property

Aspose.Email

SyncFolderItemsType.SyncScope Property

public SyncFolderItemsScopeType SyncScope {get; set;}

Remarks

See Also

SyncFolderItemsType Class | Aspose.Email.Exchange.Schema Namespace


SyncScopeSpecified Property

Aspose.Email

SyncFolderItemsType.SyncScopeSpecified Property

public bool SyncScopeSpecified {get; set;}

Remarks

See Also

SyncFolderItemsType Class | Aspose.Email.Exchange.Schema Namespace


SyncState Property

Aspose.Email

SyncFolderItemsType.SyncState Property

public string SyncState {get; set;}

Remarks

See Also

SyncFolderItemsType Class | Aspose.Email.Exchange.Schema Namespace


TargetFolderIdType Class

For a list of all members of this type, see TargetFolderIdType Members.

System.Object
Aspose.Email.Exchange.Schema.TargetFolderIdType
Aspose.Email.Exchange.Schema.UserConfigurationNameType

public class TargetFolderIdType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

TargetFolderIdType Members | Aspose.Email.Exchange.Schema Namespace


TargetFolderIdType Members

TargetFolderIdType overview

Public Instance Constructors

TargetFolderIdType Constructor Initializes a new instance of the TargetFolderIdType class.

Public Instance Properties

Item

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TargetFolderIdType Class | Aspose.Email.Exchange.Schema Namespace


TargetFolderIdType Constructor

Initializes a new instance of the TargetFolderIdType class.

public TargetFolderIdType();

See Also

TargetFolderIdType Class | Aspose.Email.Exchange.Schema Namespace


TargetFolderIdType Properties

The properties of the TargetFolderIdType class are listed below. For a complete list of TargetFolderIdType class members, see the TargetFolderIdType Members topic.

Public Instance Properties

Item

See Also

TargetFolderIdType Class | Aspose.Email.Exchange.Schema Namespace


Item Property

Aspose.Email

TargetFolderIdType.Item Property

public BaseFolderIdType Item {get; set;}

Remarks

See Also

TargetFolderIdType Class | Aspose.Email.Exchange.Schema Namespace


TaskDelegateStateType Enumeration

public enum TaskDelegateStateType

Remarks

Members

Member Name | Description | Value
NoMatch |  | 0
OwnNew |  | 1
Owned |  | 2
Accepted |  | 3
Declined |  | 4
Max |  | 5

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


TaskRecurrenceType Class

Class contains the recurrence pattern for tasks.

For a list of all members of this type, see TaskRecurrenceType Members.

System.Object
Aspose.Email.Exchange.Schema.TaskRecurrenceType

public class TaskRecurrenceType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

TaskRecurrenceType Members | Aspose.Email.Exchange.Schema Namespace


TaskRecurrenceType Members

TaskRecurrenceType overview

Public Instance Constructors

TaskRecurrenceType Constructor Initializes a new instance of the TaskRecurrenceType class.

Public Instance Properties

Item
Item1

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TaskRecurrenceType Class | Aspose.Email.Exchange.Schema Namespace


TaskRecurrenceType Constructor

Initializes a new instance of the TaskRecurrenceType class.

public TaskRecurrenceType();

See Also

TaskRecurrenceType Class | Aspose.Email.Exchange.Schema Namespace


TaskRecurrenceType Properties

The properties of the TaskRecurrenceType class are listed below. For a complete list of TaskRecurrenceType class members, see the TaskRecurrenceType Members topic.

Public Instance Properties

Item
Item1

See Also

TaskRecurrenceType Class | Aspose.Email.Exchange.Schema Namespace


Item Property

Aspose.Email

TaskRecurrenceType.Item Property

public RecurrencePatternBaseType Item {get; set;}

Remarks

See Also

TaskRecurrenceType Class | Aspose.Email.Exchange.Schema Namespace


Item1 Property

Aspose.Email

TaskRecurrenceType.Item1 Property

public RecurrenceRangeBaseType Item1 {get; set;}

Remarks

See Also

TaskRecurrenceType Class | Aspose.Email.Exchange.Schema Namespace


TasksFolderType Class

For a list of all members of this type, see TasksFolderType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseFolderType
Aspose.Email.Exchange.Schema.FolderType
Aspose.Email.Exchange.Schema.TasksFolderType

public class TasksFolderType : FolderType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

TasksFolderType Members | Aspose.Email.Exchange.Schema Namespace


TasksFolderType Members

TasksFolderType overview

Public Instance Constructors

TasksFolderType Constructor Initializes a new instance of the TasksFolderType class.

Public Instance Properties

ChildFolderCount (inherited from BaseFolderType)
ChildFolderCountSpecified (inherited from BaseFolderType)
DisplayName (inherited from BaseFolderType)
EffectiveRights (inherited from BaseFolderType)
ExtendedProperty (inherited from BaseFolderType)
FolderClass (inherited from BaseFolderType)
FolderId (inherited from BaseFolderType)
ManagedFolderInformation (inherited from BaseFolderType)
ParentFolderId (inherited from BaseFolderType)
PermissionSet (inherited from FolderType)
TotalCount (inherited from BaseFolderType)
TotalCountSpecified (inherited from BaseFolderType)
UnreadCount (inherited from FolderType)
UnreadCountSpecified (inherited from FolderType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TasksFolderType Class | Aspose.Email.Exchange.Schema Namespace


TasksFolderType Constructor

Initializes a new instance of the TasksFolderType class.

public TasksFolderType();

See Also

TasksFolderType Class | Aspose.Email.Exchange.Schema Namespace


TaskStatusType Enumeration

public enum TaskStatusType

Remarks

Members

Member Name | Description | Value
NotStarted |  | 0
InProgress |  | 1
Completed |  | 2
WaitingOnOthers |  | 3
Deferred |  | 4

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


TaskType Class

For a list of all members of this type, see TaskType Members.

System.Object
Aspose.Email.Exchange.Schema.ItemType
Aspose.Email.Exchange.Schema.TaskType

public class TaskType : ItemType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

TaskType Members | Aspose.Email.Exchange.Schema Namespace


TaskType Members

TaskType overview

Public Instance Constructors

TaskType Constructor Initializes a new instance of the TaskType class.

Public Instance Properties

ActualWork
ActualWorkSpecified
AssignedTime
AssignedTimeSpecified
Attachments (inherited from ItemType)
BillingInformation
Body (inherited from ItemType)
Categories (inherited from ItemType)
ChangeCount
ChangeCountSpecified
Companies
CompleteDate
CompleteDateSpecified
Contacts
ConversationId (inherited from ItemType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DelegationState
DelegationStateSpecified
Delegator
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
DueDate
DueDateSpecified
EffectiveRights (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
IsAssignmentEditable
IsAssignmentEditableSpecified
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsComplete
IsCompleteSpecified
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRecurring
IsRecurringSpecified
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsTeamTask
IsTeamTaskSpecified
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
Mileage
MimeContent (inherited from ItemType)
Owner
ParentFolderId (inherited from ItemType)
PercentComplete
PercentCompleteSpecified
Recurrence
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ResponseObjects (inherited from ItemType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
StartDate
StartDateSpecified
Status
StatusDescription
StatusSpecified
Subject (inherited from ItemType)
TotalWork
TotalWorkSpecified
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TaskType Class | Aspose.Email.Exchange.Schema Namespace


TaskType Constructor

Initializes a new instance of the TaskType class.

public TaskType();

See Also

TaskType Class | Aspose.Email.Exchange.Schema Namespace


TaskType Properties

The properties of the TaskType class are listed below. For a complete list of TaskType class members, see the TaskType Members topic.

Public Instance Properties

ActualWork
ActualWorkSpecified
AssignedTime
AssignedTimeSpecified
Attachments (inherited from ItemType)
BillingInformation
Body (inherited from ItemType)
Categories (inherited from ItemType)
ChangeCount
ChangeCountSpecified
Companies
CompleteDate
CompleteDateSpecified
Contacts
ConversationId (inherited from ItemType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DelegationState
DelegationStateSpecified
Delegator
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
DueDate
DueDateSpecified
EffectiveRights (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
IsAssignmentEditable
IsAssignmentEditableSpecified
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsComplete
IsCompleteSpecified
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRecurring
IsRecurringSpecified
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsTeamTask
IsTeamTaskSpecified
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
Mileage
MimeContent (inherited from ItemType)
Owner
ParentFolderId (inherited from ItemType)
PercentComplete
PercentCompleteSpecified
Recurrence
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ResponseObjects (inherited from ItemType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
StartDate
StartDateSpecified
Status
StatusDescription
StatusSpecified
Subject (inherited from ItemType)
TotalWork
TotalWorkSpecified
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

See Also

TaskType Class | Aspose.Email.Exchange.Schema Namespace


ActualWork Property

Aspose.Email

TaskType.ActualWork Property

public int ActualWork {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema Namespace


ActualWorkSpecified Property

Aspose.Email

TaskType.ActualWorkSpecified Property

public bool ActualWorkSpecified {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema Namespace


AssignedTime Property

Aspose.Email

TaskType.AssignedTime Property

public DateTime AssignedTime {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema Namespace


AssignedTimeSpecified Property

Aspose.Email

TaskType.AssignedTimeSpecified Property

public bool AssignedTimeSpecified {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema Namespace


BillingInformation Property

Aspose.Email

TaskType.BillingInformation Property

public string BillingInformation {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema Namespace


ChangeCount Property

Aspose.Email

TaskType.ChangeCount Property

public int ChangeCount {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema Namespace


ChangeCountSpecified Property

Aspose.Email

TaskType.ChangeCountSpecified Property

public bool ChangeCountSpecified {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema Namespace


Companies Property

Aspose.Email

TaskType.Companies Property

public string[] Companies {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema Namespace


CompleteDate Property

Aspose.Email

TaskType.CompleteDate Property

public DateTime CompleteDate {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema Namespace


CompleteDateSpecified Property

Aspose.Email

TaskType.CompleteDateSpecified Property

public bool CompleteDateSpecified {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema Namespace


Contacts Property

Aspose.Email

TaskType.Contacts Property

public string[] Contacts {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema Namespace


DelegationState Property

Aspose.Email

TaskType.DelegationState Property

public TaskDelegateStateType DelegationState {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema Namespace


DelegationStateSpecified Property

Aspose.Email

TaskType.DelegationStateSpecified Property

public bool DelegationStateSpecified {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema Namespace


Delegator Property

Aspose.Email

TaskType.Delegator Property

public string Delegator {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema Namespace


DueDate Property

Aspose.Email

TaskType.DueDate Property

public DateTime DueDate {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema Namespace


DueDateSpecified Property

Aspose.Email

TaskType.DueDateSpecified Property

public bool DueDateSpecified {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema Namespace


IsAssignmentEditable Property

Aspose.Email

TaskType.IsAssignmentEditable Property

public int IsAssignmentEditable {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema Namespace


IsAssignmentEditableSpecified Property

Aspose.Email

TaskType.IsAssignmentEditableSpecified Property

public bool IsAssignmentEditableSpecified {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema Namespace


IsComplete Property

Aspose.Email

TaskType.IsComplete Property

public bool IsComplete {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema Namespace


IsCompleteSpecified Property

Aspose.Email

TaskType.IsCompleteSpecified Property

public bool IsCompleteSpecified {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema Namespace


IsRecurring Property

Aspose.Email

TaskType.IsRecurring Property

public bool IsRecurring {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema Namespace


IsRecurringSpecified Property

Aspose.Email

TaskType.IsRecurringSpecified Property

public bool IsRecurringSpecified {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema Namespace


IsTeamTask Property

Aspose.Email

TaskType.IsTeamTask Property

public bool IsTeamTask {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema Namespace


IsTeamTaskSpecified Property

Aspose.Email

TaskType.IsTeamTaskSpecified Property

public bool IsTeamTaskSpecified {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema Namespace


Mileage Property

Aspose.Email

TaskType.Mileage Property

public string Mileage {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema Namespace


Owner Property

Aspose.Email

TaskType.Owner Property

public string Owner {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema Namespace


PercentComplete Property

Aspose.Email

TaskType.PercentComplete Property

public double PercentComplete {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema Namespace


PercentCompleteSpecified Property

Aspose.Email

TaskType.PercentCompleteSpecified Property

public bool PercentCompleteSpecified {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema Namespace


Recurrence Property

Aspose.Email

TaskType.Recurrence Property

public TaskRecurrenceType Recurrence {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema Namespace


StartDate Property

Aspose.Email

TaskType.StartDate Property

public DateTime StartDate {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema Namespace


StartDateSpecified Property

Aspose.Email

TaskType.StartDateSpecified Property

public bool StartDateSpecified {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema Namespace


Status Property

Aspose.Email

TaskType.Status Property

public TaskStatusType Status {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema Namespace


StatusDescription Property

Aspose.Email

TaskType.StatusDescription Property

public string StatusDescription {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema Namespace


StatusSpecified Property

Aspose.Email

TaskType.StatusSpecified Property

public bool StatusSpecified {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema Namespace


TotalWork Property

Aspose.Email

TaskType.TotalWork Property

public int TotalWork {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema Namespace


TotalWorkSpecified Property

Aspose.Email

TaskType.TotalWorkSpecified Property

public bool TotalWorkSpecified {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema Namespace


TentativelyAcceptItemType Class

For a list of all members of this type, see TentativelyAcceptItemType Members.

System.Object
Aspose.Email.Exchange.Schema.ItemType
Aspose.Email.Exchange.Schema.MessageType
Aspose.Email.Exchange.Schema.ResponseObjectCoreType
Aspose.Email.Exchange.Schema.ResponseObjectType
Aspose.Email.Exchange.Schema.WellKnownResponseObjectType
Aspose.Email.Exchange.Schema.TentativelyAcceptItemType

public class TentativelyAcceptItemType : WellKnownResponseObjectType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

TentativelyAcceptItemType Members | Aspose.Email.Exchange.Schema Namespace


TentativelyAcceptItemType Members

TentativelyAcceptItemType overview

Public Instance Constructors

TentativelyAcceptItemType Constructor Initializes a new instance of the TentativelyAcceptItemType class.

Public Instance Properties

Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
From (inherited from MessageType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
ObjectName (inherited from ResponseObjectType)
ParentFolderId (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
ReferenceItemId (inherited from ResponseObjectCoreType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
Subject (inherited from ItemType)
ToRecipients (inherited from MessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TentativelyAcceptItemType Class | Aspose.Email.Exchange.Schema Namespace


TentativelyAcceptItemType Constructor

Initializes a new instance of the TentativelyAcceptItemType class.

public TentativelyAcceptItemType();

See Also

TentativelyAcceptItemType Class | Aspose.Email.Exchange.Schema Namespace


TimeChangeType Class

For a list of all members of this type, see TimeChangeType Members.

System.Object
Aspose.Email.Exchange.Schema.TimeChangeType

public class TimeChangeType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

TimeChangeType Members | Aspose.Email.Exchange.Schema Namespace


TimeChangeType Members

TimeChangeType overview

Public Instance Constructors

TimeChangeType Constructor Initializes a new instance of the TimeChangeType class.

Public Instance Properties

Item
Offset
Time
TimeZoneName

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TimeChangeType Class | Aspose.Email.Exchange.Schema Namespace


TimeChangeType Constructor

Initializes a new instance of the TimeChangeType class.

public TimeChangeType();

See Also

TimeChangeType Class | Aspose.Email.Exchange.Schema Namespace


TimeChangeType Properties

The properties of the TimeChangeType class are listed below. For a complete list of TimeChangeType class members, see the TimeChangeType Members topic.

Public Instance Properties

Item
Offset
Time
TimeZoneName

See Also

TimeChangeType Class | Aspose.Email.Exchange.Schema Namespace


Item Property

Aspose.Email

TimeChangeType.Item Property

public object Item {get; set;}

Remarks

See Also

TimeChangeType Class | Aspose.Email.Exchange.Schema Namespace


Offset Property

Aspose.Email

TimeChangeType.Offset Property

public string Offset {get; set;}

Remarks

See Also

TimeChangeType Class | Aspose.Email.Exchange.Schema Namespace


Time Property

Aspose.Email

TimeChangeType.Time Property

public DateTime Time {get; set;}

Remarks

See Also

TimeChangeType Class | Aspose.Email.Exchange.Schema Namespace


TimeZoneName Property

Aspose.Email

TimeChangeType.TimeZoneName Property

public string TimeZoneName {get; set;}

Remarks

See Also

TimeChangeType Class | Aspose.Email.Exchange.Schema Namespace


TimeZoneContextType Class

For a list of all members of this type, see TimeZoneContextType Members.

System.Object
System.Web.Services.Protocols.SoapHeader
Aspose.Email.Exchange.Schema.TimeZoneContextType

public class TimeZoneContextType : SoapHeader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

TimeZoneContextType Members | Aspose.Email.Exchange.Schema Namespace


TimeZoneContextType Members

TimeZoneContextType overview

Public Instance Constructors

TimeZoneContextType Constructor Initializes a new instance of the TimeZoneContextType class.

Public Instance Properties

Actor (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.
AnyAttr |
DidUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether an XML Web service method properly processed a SOAP header.
EncodedMustUnderstand (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.1.
EncodedMustUnderstand12 (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.2.
EncodedRelay (inherited from SoapHeader) | Gets or sets the relay attribute of the SOAP 1.2 header.
MustUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether the SoapHeader must be understood.
Relay (inherited from SoapHeader) | Gets or sets a value that indicates whether the SOAP header is to be relayed to the next SOAP node if the current node does not understand the header.
Role (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.
TimeZoneDefinition |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TimeZoneContextType Class | Aspose.Email.Exchange.Schema Namespace


TimeZoneContextType Constructor

Initializes a new instance of the TimeZoneContextType class.

public TimeZoneContextType();

See Also

TimeZoneContextType Class | Aspose.Email.Exchange.Schema Namespace


TimeZoneContextType Properties

The properties of the TimeZoneContextType class are listed below. For a complete list of TimeZoneContextType class members, see the TimeZoneContextType Members topic.

Public Instance Properties

Actor (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.
AnyAttr |
DidUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether an XML Web service method properly processed a SOAP header.
EncodedMustUnderstand (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.1.
EncodedMustUnderstand12 (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.2.
EncodedRelay (inherited from SoapHeader) | Gets or sets the relay attribute of the SOAP 1.2 header.
MustUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether the SoapHeader must be understood.
Relay (inherited from SoapHeader) | Gets or sets a value that indicates whether the SOAP header is to be relayed to the next SOAP node if the current node does not understand the header.
Role (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.
TimeZoneDefinition |

See Also

TimeZoneContextType Class | Aspose.Email.Exchange.Schema Namespace


AnyAttr Property

Aspose.Email

TimeZoneContextType.AnyAttr Property

public XmlAttribute[] AnyAttr {get; set;}

Remarks

See Also

TimeZoneContextType Class | Aspose.Email.Exchange.Schema Namespace


TimeZoneDefinition Property

Aspose.Email

TimeZoneContextType.TimeZoneDefinition Property

public TimeZoneDefinitionType TimeZoneDefinition {get; set;}

Remarks

See Also

TimeZoneContextType Class | Aspose.Email.Exchange.Schema Namespace


TimeZoneDefinitionType Class

For a list of all members of this type, see TimeZoneDefinitionType Members.

System.Object
Aspose.Email.Exchange.Schema.TimeZoneDefinitionType

public class TimeZoneDefinitionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

TimeZoneDefinitionType Members | Aspose.Email.Exchange.Schema Namespace


TimeZoneDefinitionType Members

TimeZoneDefinitionType overview

Public Instance Constructors

TimeZoneDefinitionType Constructor Initializes a new instance of the TimeZoneDefinitionType class.

Public Instance Properties

Id
Name
Periods
Transitions
TransitionsGroups

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TimeZoneDefinitionType Class | Aspose.Email.Exchange.Schema Namespace


TimeZoneDefinitionType Constructor

Initializes a new instance of the TimeZoneDefinitionType class.

public TimeZoneDefinitionType();

See Also

TimeZoneDefinitionType Class | Aspose.Email.Exchange.Schema Namespace


TimeZoneDefinitionType Properties

The properties of the TimeZoneDefinitionType class are listed below. For a complete list of TimeZoneDefinitionType class members, see the TimeZoneDefinitionType Members topic.

Public Instance Properties

Id
Name
Periods
Transitions
TransitionsGroups

See Also

TimeZoneDefinitionType Class | Aspose.Email.Exchange.Schema Namespace


Id Property

Aspose.Email

TimeZoneDefinitionType.Id Property

public string Id {get; set;}

Remarks

See Also

TimeZoneDefinitionType Class | Aspose.Email.Exchange.Schema Namespace


Name Property

Aspose.Email

TimeZoneDefinitionType.Name Property

public string Name {get; set;}

Remarks

See Also

TimeZoneDefinitionType Class | Aspose.Email.Exchange.Schema Namespace


Periods Property

Aspose.Email

TimeZoneDefinitionType.Periods Property

public PeriodType[] Periods {get; set;}

Remarks

See Also

TimeZoneDefinitionType Class | Aspose.Email.Exchange.Schema Namespace


Transitions Property

Aspose.Email

TimeZoneDefinitionType.Transitions Property

public ArrayOfTransitionsType Transitions {get; set;}

Remarks

See Also

TimeZoneDefinitionType Class | Aspose.Email.Exchange.Schema Namespace


TransitionsGroups Property

Aspose.Email

TimeZoneDefinitionType.TransitionsGroups Property

public ArrayOfTransitionsType[] TransitionsGroups {get; set;}

Remarks

See Also

TimeZoneDefinitionType Class | Aspose.Email.Exchange.Schema Namespace


TimeZoneType Class

For a list of all members of this type, see TimeZoneType Members.

System.Object
Aspose.Email.Exchange.Schema.TimeZoneType

public class TimeZoneType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

TimeZoneType Members | Aspose.Email.Exchange.Schema Namespace


TimeZoneType Members

TimeZoneType overview

Public Instance Constructors

TimeZoneType Constructor Initializes a new instance of the TimeZoneType class.

Public Instance Properties

BaseOffset
Daylight
Standard
TimeZoneName

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TimeZoneType Class | Aspose.Email.Exchange.Schema Namespace


TimeZoneType Constructor

Initializes a new instance of the TimeZoneType class.

public TimeZoneType();

See Also

TimeZoneType Class | Aspose.Email.Exchange.Schema Namespace


TimeZoneType Properties

The properties of the TimeZoneType class are listed below. For a complete list of TimeZoneType class members, see the TimeZoneType Members topic.

Public Instance Properties

BaseOffset
Daylight
Standard
TimeZoneName

See Also

TimeZoneType Class | Aspose.Email.Exchange.Schema Namespace


BaseOffset Property

Aspose.Email

TimeZoneType.BaseOffset Property

public string BaseOffset {get; set;}

Remarks

See Also

TimeZoneType Class | Aspose.Email.Exchange.Schema Namespace


Daylight Property

Aspose.Email

TimeZoneType.Daylight Property

public TimeChangeType Daylight {get; set;}

Remarks

See Also

TimeZoneType Class | Aspose.Email.Exchange.Schema Namespace


Standard Property

Aspose.Email

TimeZoneType.Standard Property

public TimeChangeType Standard {get; set;}

Remarks

See Also

TimeZoneType Class | Aspose.Email.Exchange.Schema Namespace


TimeZoneName Property

Aspose.Email

TimeZoneType.TimeZoneName Property

public string TimeZoneName {get; set;}

Remarks

See Also

TimeZoneType Class | Aspose.Email.Exchange.Schema Namespace


TooBigGroupAttendeeConflictData Class

For a list of all members of this type, see TooBigGroupAttendeeConflictData Members.

System.Object
Aspose.Email.Exchange.Schema.AttendeeConflictData
Aspose.Email.Exchange.Schema.TooBigGroupAttendeeConflictData

public class TooBigGroupAttendeeConflictData : AttendeeConflictData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

TooBigGroupAttendeeConflictData Members | Aspose.Email.Exchange.Schema Namespace


TooBigGroupAttendeeConflictData Members

TooBigGroupAttendeeConflictData overview

Public Instance Constructors

TooBigGroupAttendeeConflictData Constructor Initializes a new instance of the TooBigGroupAttendeeConflictData class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TooBigGroupAttendeeConflictData Class | Aspose.Email.Exchange.Schema Namespace


TooBigGroupAttendeeConflictData Constructor

Initializes a new instance of the TooBigGroupAttendeeConflictData class.

public TooBigGroupAttendeeConflictData();

See Also

TooBigGroupAttendeeConflictData Class | Aspose.Email.Exchange.Schema Namespace


TrackingPropertyType Class

For a list of all members of this type, see TrackingPropertyType Members.

System.Object
Aspose.Email.Exchange.Schema.TrackingPropertyType

public class TrackingPropertyType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

TrackingPropertyType Members | Aspose.Email.Exchange.Schema Namespace


TrackingPropertyType Members

TrackingPropertyType overview

Public Instance Constructors

TrackingPropertyType Constructor Initializes a new instance of the TrackingPropertyType class.

Public Instance Properties

Name
Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TrackingPropertyType Class | Aspose.Email.Exchange.Schema Namespace


TrackingPropertyType Constructor

Initializes a new instance of the TrackingPropertyType class.

public TrackingPropertyType();

See Also

TrackingPropertyType Class | Aspose.Email.Exchange.Schema Namespace


TrackingPropertyType Properties

The properties of the TrackingPropertyType class are listed below. For a complete list of TrackingPropertyType class members, see the TrackingPropertyType Members topic.

Public Instance Properties

Name
Value

See Also

TrackingPropertyType Class | Aspose.Email.Exchange.Schema Namespace


Name Property

Aspose.Email

TrackingPropertyType.Name Property

public string Name {get; set;}

Remarks

See Also

TrackingPropertyType Class | Aspose.Email.Exchange.Schema Namespace


Value Property

Aspose.Email

TrackingPropertyType.Value Property

public string Value {get; set;}

Remarks

See Also

TrackingPropertyType Class | Aspose.Email.Exchange.Schema Namespace


TransitionTargetKindType Enumeration

public enum TransitionTargetKindType

Remarks

Members

Member Name | Description | Value
Period |  | 0
Group |  | 1

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


TransitionTargetType Class

For a list of all members of this type, see TransitionTargetType Members.

System.Object
Aspose.Email.Exchange.Schema.TransitionTargetType

public class TransitionTargetType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

TransitionTargetType Members | Aspose.Email.Exchange.Schema Namespace


TransitionTargetType Members

TransitionTargetType overview

Public Instance Constructors

TransitionTargetType Constructor Initializes a new instance of the TransitionTargetType class.

Public Instance Properties

Kind
Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TransitionTargetType Class | Aspose.Email.Exchange.Schema Namespace


TransitionTargetType Constructor

Initializes a new instance of the TransitionTargetType class.

public TransitionTargetType();

See Also

TransitionTargetType Class | Aspose.Email.Exchange.Schema Namespace


TransitionTargetType Properties

The properties of the TransitionTargetType class are listed below. For a complete list of TransitionTargetType class members, see the TransitionTargetType Members topic.

Public Instance Properties

Kind
Value

See Also

TransitionTargetType Class | Aspose.Email.Exchange.Schema Namespace


Kind Property

Aspose.Email

TransitionTargetType.Kind Property

public TransitionTargetKindType Kind {get; set;}

Remarks

See Also

TransitionTargetType Class | Aspose.Email.Exchange.Schema Namespace


Value Property

Aspose.Email

TransitionTargetType.Value Property

public string Value {get; set;}

Remarks

See Also

TransitionTargetType Class | Aspose.Email.Exchange.Schema Namespace


TransitionType Class

For a list of all members of this type, see TransitionType Members.

System.Object
Aspose.Email.Exchange.Schema.TransitionType
Aspose.Email.Exchange.Schema.AbsoluteDateTransitionType
Aspose.Email.Exchange.Schema.RecurringTimeTransitionType

public class TransitionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

TransitionType Members | Aspose.Email.Exchange.Schema Namespace


TransitionType Members

TransitionType overview

Public Instance Constructors

TransitionType Constructor Initializes a new instance of the TransitionType class.

Public Instance Properties

To

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TransitionType Class | Aspose.Email.Exchange.Schema Namespace


TransitionType Constructor

Initializes a new instance of the TransitionType class.

public TransitionType();

See Also

TransitionType Class | Aspose.Email.Exchange.Schema Namespace


TransitionType Properties

The properties of the TransitionType class are listed below. For a complete list of TransitionType class members, see the TransitionType Members topic.

Public Instance Properties

To

See Also

TransitionType Class | Aspose.Email.Exchange.Schema Namespace


To Property

Aspose.Email

TransitionType.To Property

public TransitionTargetType To {get; set;}

Remarks

See Also

TransitionType Class | Aspose.Email.Exchange.Schema Namespace


TwoOperandExpressionType Class

For a list of all members of this type, see TwoOperandExpressionType Members.

System.Object
Aspose.Email.Exchange.Schema.SearchExpressionType
Aspose.Email.Exchange.Schema.TwoOperandExpressionType
Derived types

public abstract class TwoOperandExpressionType : SearchExpressionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

TwoOperandExpressionType Members | Aspose.Email.Exchange.Schema Namespace


TwoOperandExpressionType Members

TwoOperandExpressionType overview

Public Instance Properties

FieldURIOrConstant
Item

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

TwoOperandExpressionType Constructor Initializes a new instance of the TwoOperandExpressionType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TwoOperandExpressionType Class | Aspose.Email.Exchange.Schema Namespace


TwoOperandExpressionType Constructor

Initializes a new instance of the TwoOperandExpressionType class.

protected TwoOperandExpressionType();

See Also

TwoOperandExpressionType Class | Aspose.Email.Exchange.Schema Namespace


TwoOperandExpressionType Properties

The properties of the TwoOperandExpressionType class are listed below. For a complete list of TwoOperandExpressionType class members, see the TwoOperandExpressionType Members topic.

Public Instance Properties

FieldURIOrConstant
Item

See Also

TwoOperandExpressionType Class | Aspose.Email.Exchange.Schema Namespace


FieldURIOrConstant Property

Aspose.Email

TwoOperandExpressionType.FieldURIOrConstant Property

public FieldURIOrConstantType FieldURIOrConstant {get; set;}

Remarks

See Also

TwoOperandExpressionType Class | Aspose.Email.Exchange.Schema Namespace


Item Property

Aspose.Email

TwoOperandExpressionType.Item Property

public BasePathToElementType Item {get; set;}

Remarks

See Also

TwoOperandExpressionType Class | Aspose.Email.Exchange.Schema Namespace


UnifiedMessageServiceConfiguration Class

For a list of all members of this type, see UnifiedMessageServiceConfiguration Members.

System.Object
Aspose.Email.Exchange.Schema.ServiceConfiguration
Aspose.Email.Exchange.Schema.UnifiedMessageServiceConfiguration

public class UnifiedMessageServiceConfiguration : ServiceConfiguration

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UnifiedMessageServiceConfiguration Members | Aspose.Email.Exchange.Schema Namespace


UnifiedMessageServiceConfiguration Members

UnifiedMessageServiceConfiguration overview

Public Instance Constructors

UnifiedMessageServiceConfiguration Constructor Initializes a new instance of the UnifiedMessageServiceConfiguration class.

Public Instance Properties

PlayOnPhoneDialString
PlayOnPhoneEnabled
UmEnabled

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UnifiedMessageServiceConfiguration Class | Aspose.Email.Exchange.Schema Namespace


UnifiedMessageServiceConfiguration Constructor

Initializes a new instance of the UnifiedMessageServiceConfiguration class.

public UnifiedMessageServiceConfiguration();

See Also

UnifiedMessageServiceConfiguration Class | Aspose.Email.Exchange.Schema Namespace


UnifiedMessageServiceConfiguration Properties

The properties of the UnifiedMessageServiceConfiguration class are listed below. For a complete list of UnifiedMessageServiceConfiguration class members, see the UnifiedMessageServiceConfiguration Members topic.

Public Instance Properties

PlayOnPhoneDialString
PlayOnPhoneEnabled
UmEnabled

See Also

UnifiedMessageServiceConfiguration Class | Aspose.Email.Exchange.Schema Namespace


PlayOnPhoneDialString Property

Aspose.Email

UnifiedMessageServiceConfiguration.PlayOnPhoneDialString Property

public string PlayOnPhoneDialString {get; set;}

Remarks

See Also

UnifiedMessageServiceConfiguration Class | Aspose.Email.Exchange.Schema Namespace


PlayOnPhoneEnabled Property

Aspose.Email

UnifiedMessageServiceConfiguration.PlayOnPhoneEnabled Property

public bool PlayOnPhoneEnabled {get; set;}

Remarks

See Also

UnifiedMessageServiceConfiguration Class | Aspose.Email.Exchange.Schema Namespace


UmEnabled Property

Aspose.Email

UnifiedMessageServiceConfiguration.UmEnabled Property

public bool UmEnabled {get; set;}

Remarks

See Also

UnifiedMessageServiceConfiguration Class | Aspose.Email.Exchange.Schema Namespace


UnindexedFieldURIType Enumeration

public enum UnindexedFieldURIType

Remarks

Members

Member Name | Description | Value
folderFolderId |  | 0
folderParentFolderId |  | 1
folderDisplayName |  | 2
folderUnreadCount |  | 3
folderTotalCount |  | 4
folderChildFolderCount |  | 5
folderFolderClass |  | 6
folderSearchParameters |  | 7
folderManagedFolderInformation |  | 8
folderPermissionSet |  | 9
folderEffectiveRights |  | 10
folderSharingEffectiveRights |  | 11
itemItemId |  | 12
itemParentFolderId |  | 13
itemItemClass |  | 14
itemMimeContent |  | 15
itemAttachments |  | 16
itemSubject |  | 17
itemDateTimeReceived |  | 18
itemSize |  | 19
itemCategories |  | 20
itemHasAttachments |  | 21
itemImportance |  | 22
itemInReplyTo |  | 23
itemInternetMessageHeaders |  | 24
itemIsAssociated |  | 25
itemIsDraft |  | 26
itemIsFromMe |  | 27
itemIsResend |  | 28
itemIsSubmitted |  | 29
itemIsUnmodified |  | 30
itemDateTimeSent |  | 31
itemDateTimeCreated |  | 32
itemBody |  | 33
itemResponseObjects |  | 34
itemSensitivity |  | 35
itemReminderDueBy |  | 36
itemReminderIsSet |  | 37
itemReminderMinutesBeforeStart |  | 38
itemDisplayTo |  | 39
itemDisplayCc |  | 40
itemCulture |  | 41
itemEffectiveRights |  | 42
itemLastModifiedName |  | 43
itemLastModifiedTime |  | 44
itemConversationId |  | 45
itemUniqueBody |  | 46
itemWebClientReadFormQueryString |  | 47
itemWebClientEditFormQueryString |  | 48
messageConversationIndex |  | 49
messageConversationTopic |  | 50
messageInternetMessageId |  | 51
messageIsRead |  | 52
messageIsResponseRequested |  | 53
messageIsReadReceiptRequested |  | 54
messageIsDeliveryReceiptRequested |  | 55
messageReceivedBy |  | 56
messageReceivedRepresenting |  | 57
messageReferences |  | 58
messageReplyTo |  | 59
messageFrom |  | 60
messageSender |  | 61
messageToRecipients |  | 62
messageCcRecipients |  | 63
messageBccRecipients |  | 64
meetingAssociatedCalendarItemId |  | 65
meetingIsDelegated |  | 66
meetingIsOutOfDate |  | 67
meetingHasBeenProcessed |  | 68
meetingResponseType |  | 69
meetingRequestMeetingRequestType |  | 70
meetingRequestIntendedFreeBusyStatus |  | 71
calendarStart |  | 72
calendarEnd |  | 73
calendarOriginalStart |  | 74
calendarIsAllDayEvent |  | 75
calendarLegacyFreeBusyStatus |  | 76
calendarLocation |  | 77
calendarWhen |  | 78
calendarIsMeeting |  | 79
calendarIsCancelled |  | 80
calendarIsRecurring |  | 81
calendarMeetingRequestWasSent |  | 82
calendarIsResponseRequested |  | 83
calendarCalendarItemType |  | 84
calendarMyResponseType |  | 85
calendarOrganizer |  | 86
calendarRequiredAttendees |  | 87
calendarOptionalAttendees |  | 88
calendarResources |  | 89
calendarConflictingMeetingCount |  | 90
calendarAdjacentMeetingCount |  | 91
calendarConflictingMeetings |  | 92
calendarAdjacentMeetings |  | 93
calendarDuration |  | 94
calendarTimeZone |  | 95
calendarAppointmentReplyTime |  | 96
calendarAppointmentSequenceNumber |  | 97
calendarAppointmentState |  | 98
calendarRecurrence |  | 99
calendarFirstOccurrence |  | 100
calendarLastOccurrence |  | 101
calendarModifiedOccurrences |  | 102
calendarDeletedOccurrences |  | 103
calendarMeetingTimeZone |  | 104
calendarConferenceType |  | 105
calendarAllowNewTimeProposal |  | 106
calendarIsOnlineMeeting |  | 107
calendarMeetingWorkspaceUrl |  | 108
calendarNetShowUrl |  | 109
calendarUID |  | 110
calendarRecurrenceId |  | 111
calendarDateTimeStamp |  | 112
calendarStartTimeZone |  | 113
calendarEndTimeZone |  | 114
taskActualWork |  | 115
taskAssignedTime |  | 116
taskBillingInformation |  | 117
taskChangeCount |  | 118
taskCompanies |  | 119
taskCompleteDate |  | 120
taskContacts |  | 121
taskDelegationState |  | 122
taskDelegator |  | 123
taskDueDate |  | 124
taskIsAssignmentEditable |  | 125
taskIsComplete |  | 126
taskIsRecurring |  | 127
taskIsTeamTask |  | 128
taskMileage |  | 129
taskOwner |  | 130
taskPercentComplete |  | 131
taskRecurrence |  | 132
taskStartDate |  | 133
taskStatus |  | 134
taskStatusDescription |  | 135
taskTotalWork |  | 136
contactsAssistantName |  | 137
contactsBirthday |  | 138
contactsBusinessHomePage |  | 139
contactsChildren |  | 140
contactsCompanies |  | 141
contactsCompanyName |  | 142
contactsCompleteName |  | 143
contactsContactSource |  | 144
contactsCulture |  | 145
contactsDepartment |  | 146
contactsDisplayName |  | 147
contactsEmailAddresses |  | 148
contactsFileAs |  | 149
contactsFileAsMapping |  | 150
contactsGeneration |  | 151
contactsGivenName |  | 152
contactsImAddresses |  | 153
contactsInitials |  | 154
contactsJobTitle |  | 155
contactsManager |  | 156
contactsMiddleName |  | 157
contactsMileage |  | 158
contactsNickname |  | 159
contactsOfficeLocation |  | 160
contactsPhoneNumbers |  | 161
contactsPhysicalAddresses |  | 162
contactsPostalAddressIndex |  | 163
contactsProfession |  | 164
contactsSpouseName |  | 165
contactsSurname |  | 166
contactsWeddingAnniversary |  | 167
contactsHasPicture |  | 168
distributionlistMembers |  | 169
postitemPostedTime |  | 170
conversationConversationId |  | 171
conversationConversationTopic |  | 172
conversationUniqueRecipients |  | 173
conversationGlobalUniqueRecipients |  | 174
conversationUniqueUnreadSenders |  | 175
conversationGlobalUniqueUnreadSenders |  | 176
conversationUniqueSenders |  | 177
conversationGlobalUniqueSenders |  | 178
conversationLastDeliveryTime |  | 179
conversationGlobalLastDeliveryTime |  | 180
conversationCategories |  | 181
conversationGlobalCategories |  | 182
conversationFlagStatus |  | 183
conversationGlobalFlagStatus |  | 184
conversationHasAttachments |  | 185
conversationGlobalHasAttachments |  | 186
conversationMessageCount |  | 187
conversationGlobalMessageCount |  | 188
conversationUnreadCount |  | 189
conversationGlobalUnreadCount |  | 190
conversationSize |  | 191
conversationGlobalSize |  | 192
conversationItemClasses |  | 193
conversationGlobalItemClasses |  | 194
conversationImportance |  | 195
conversationGlobalImportance |  | 196
conversationItemIds |  | 197
conversationGlobalItemIds |  | 198

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


UnknownAttendeeConflictData Class

For a list of all members of this type, see UnknownAttendeeConflictData Members.

System.Object
Aspose.Email.Exchange.Schema.AttendeeConflictData
Aspose.Email.Exchange.Schema.UnknownAttendeeConflictData

public class UnknownAttendeeConflictData : AttendeeConflictData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UnknownAttendeeConflictData Members | Aspose.Email.Exchange.Schema Namespace


UnknownAttendeeConflictData Members

UnknownAttendeeConflictData overview

Public Instance Constructors

UnknownAttendeeConflictData Constructor Initializes a new instance of the UnknownAttendeeConflictData class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UnknownAttendeeConflictData Class | Aspose.Email.Exchange.Schema Namespace


UnknownAttendeeConflictData Constructor

Initializes a new instance of the UnknownAttendeeConflictData class.

public UnknownAttendeeConflictData();

See Also

UnknownAttendeeConflictData Class | Aspose.Email.Exchange.Schema Namespace


UnsubscribeCompletedEventArgs Class

For a list of all members of this type, see UnsubscribeCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.UnsubscribeCompletedEventArgs

public class UnsubscribeCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UnsubscribeCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


UnsubscribeCompletedEventArgs Members

UnsubscribeCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

UnsubscribeCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


UnsubscribeCompletedEventArgs Properties

The properties of the UnsubscribeCompletedEventArgs class are listed below. For a complete list of UnsubscribeCompletedEventArgs class members, see the UnsubscribeCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

UnsubscribeCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

UnsubscribeCompletedEventArgs.Result Property

public UnsubscribeResponseType Result {get;}

Remarks

See Also

UnsubscribeCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


UnsubscribeCompletedEventHandler Delegate

public delegate void UnsubscribeCompletedEventHandler(
object sender,
UnsubscribeCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


UnsubscribeResponseType Class

For a list of all members of this type, see UnsubscribeResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseResponseMessageType
Aspose.Email.Exchange.Schema.UnsubscribeResponseType

public class UnsubscribeResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UnsubscribeResponseType Members | Aspose.Email.Exchange.Schema Namespace


UnsubscribeResponseType Members

UnsubscribeResponseType overview

Public Instance Constructors

UnsubscribeResponseType Constructor Initializes a new instance of the UnsubscribeResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UnsubscribeResponseType Class | Aspose.Email.Exchange.Schema Namespace


UnsubscribeResponseType Constructor

Initializes a new instance of the UnsubscribeResponseType class.

public UnsubscribeResponseType();

See Also

UnsubscribeResponseType Class | Aspose.Email.Exchange.Schema Namespace


UnsubscribeType Class

For a list of all members of this type, see UnsubscribeType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.UnsubscribeType

public class UnsubscribeType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UnsubscribeType Members | Aspose.Email.Exchange.Schema Namespace


UnsubscribeType Members

UnsubscribeType overview

Public Instance Constructors

UnsubscribeType Constructor Initializes a new instance of the UnsubscribeType class.

Public Instance Properties

SubscriptionId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UnsubscribeType Class | Aspose.Email.Exchange.Schema Namespace


UnsubscribeType Constructor

Initializes a new instance of the UnsubscribeType class.

public UnsubscribeType();

See Also

UnsubscribeType Class | Aspose.Email.Exchange.Schema Namespace


UnsubscribeType Properties

The properties of the UnsubscribeType class are listed below. For a complete list of UnsubscribeType class members, see the UnsubscribeType Members topic.

Public Instance Properties

SubscriptionId

See Also

UnsubscribeType Class | Aspose.Email.Exchange.Schema Namespace


SubscriptionId Property

Aspose.Email

UnsubscribeType.SubscriptionId Property

public string SubscriptionId {get; set;}

Remarks

See Also

UnsubscribeType Class | Aspose.Email.Exchange.Schema Namespace


UpdateDelegateCompletedEventArgs Class

For a list of all members of this type, see UpdateDelegateCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.UpdateDelegateCompletedEventArgs

public class UpdateDelegateCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UpdateDelegateCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


UpdateDelegateCompletedEventArgs Members

UpdateDelegateCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

UpdateDelegateCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


UpdateDelegateCompletedEventArgs Properties

The properties of the UpdateDelegateCompletedEventArgs class are listed below. For a complete list of UpdateDelegateCompletedEventArgs class members, see the UpdateDelegateCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

UpdateDelegateCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

UpdateDelegateCompletedEventArgs.Result Property

public UpdateDelegateResponseMessageType Result {get;}

Remarks

See Also

UpdateDelegateCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


UpdateDelegateCompletedEventHandler Delegate

public delegate void UpdateDelegateCompletedEventHandler(
object sender,
UpdateDelegateCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


UpdateDelegateResponseMessageType Class

For a list of all members of this type, see UpdateDelegateResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ResponseMessageType
Aspose.Email.Exchange.Schema.BaseDelegateResponseMessageType
Aspose.Email.Exchange.Schema.UpdateDelegateResponseMessageType

public class UpdateDelegateResponseMessageType : BaseDelegateResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UpdateDelegateResponseMessageType Members | Aspose.Email.Exchange.Schema Namespace


UpdateDelegateResponseMessageType Members

UpdateDelegateResponseMessageType overview

Public Instance Constructors

UpdateDelegateResponseMessageType Constructor Initializes a new instance of the UpdateDelegateResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
ResponseMessages (inherited from BaseDelegateResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UpdateDelegateResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


UpdateDelegateResponseMessageType Constructor

Initializes a new instance of the UpdateDelegateResponseMessageType class.

public UpdateDelegateResponseMessageType();

See Also

UpdateDelegateResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


UpdateDelegateType Class

For a list of all members of this type, see UpdateDelegateType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.BaseDelegateType
Aspose.Email.Exchange.Schema.UpdateDelegateType

public class UpdateDelegateType : BaseDelegateType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UpdateDelegateType Members | Aspose.Email.Exchange.Schema Namespace


UpdateDelegateType Members

UpdateDelegateType overview

Public Instance Constructors

UpdateDelegateType Constructor Initializes a new instance of the UpdateDelegateType class.

Public Instance Properties

DelegateUsers
DeliverMeetingRequests
DeliverMeetingRequestsSpecified
Mailbox (inherited from BaseDelegateType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UpdateDelegateType Class | Aspose.Email.Exchange.Schema Namespace


UpdateDelegateType Constructor

Initializes a new instance of the UpdateDelegateType class.

public UpdateDelegateType();

See Also

UpdateDelegateType Class | Aspose.Email.Exchange.Schema Namespace


UpdateDelegateType Properties

The properties of the UpdateDelegateType class are listed below. For a complete list of UpdateDelegateType class members, see the UpdateDelegateType Members topic.

Public Instance Properties

DelegateUsers
DeliverMeetingRequests
DeliverMeetingRequestsSpecified
Mailbox (inherited from BaseDelegateType)

See Also

UpdateDelegateType Class | Aspose.Email.Exchange.Schema Namespace


DelegateUsers Property

Aspose.Email

UpdateDelegateType.DelegateUsers Property

public DelegateUserType[] DelegateUsers {get; set;}

Remarks

See Also

UpdateDelegateType Class | Aspose.Email.Exchange.Schema Namespace


DeliverMeetingRequests Property

Aspose.Email

UpdateDelegateType.DeliverMeetingRequests Property

public DeliverMeetingRequestsType DeliverMeetingRequests {get; set;}

Remarks

See Also

UpdateDelegateType Class | Aspose.Email.Exchange.Schema Namespace


DeliverMeetingRequestsSpecified Property

Aspose.Email

UpdateDelegateType.DeliverMeetingRequestsSpecified Property

public bool DeliverMeetingRequestsSpecified {get; set;}

Remarks

See Also

UpdateDelegateType Class | Aspose.Email.Exchange.Schema Namespace


UpdateFolderCompletedEventArgs Class

For a list of all members of this type, see UpdateFolderCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.UpdateFolderCompletedEventArgs

public class UpdateFolderCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UpdateFolderCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


UpdateFolderCompletedEventArgs Members

UpdateFolderCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

UpdateFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


UpdateFolderCompletedEventArgs Properties

The properties of the UpdateFolderCompletedEventArgs class are listed below. For a complete list of UpdateFolderCompletedEventArgs class members, see the UpdateFolderCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

UpdateFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

UpdateFolderCompletedEventArgs.Result Property

public UpdateFolderResponseType Result {get;}

Remarks

See Also

UpdateFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


UpdateFolderCompletedEventHandler Delegate

public delegate void UpdateFolderCompletedEventHandler(
object sender,
UpdateFolderCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


UpdateFolderResponseType Class

For a list of all members of this type, see UpdateFolderResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseResponseMessageType
Aspose.Email.Exchange.Schema.UpdateFolderResponseType

public class UpdateFolderResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UpdateFolderResponseType Members | Aspose.Email.Exchange.Schema Namespace


UpdateFolderResponseType Members

UpdateFolderResponseType overview

Public Instance Constructors

UpdateFolderResponseType Constructor Initializes a new instance of the UpdateFolderResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UpdateFolderResponseType Class | Aspose.Email.Exchange.Schema Namespace


UpdateFolderResponseType Constructor

Initializes a new instance of the UpdateFolderResponseType class.

public UpdateFolderResponseType();

See Also

UpdateFolderResponseType Class | Aspose.Email.Exchange.Schema Namespace


UpdateFolderType Class

For a list of all members of this type, see UpdateFolderType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.UpdateFolderType

public class UpdateFolderType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UpdateFolderType Members | Aspose.Email.Exchange.Schema Namespace


UpdateFolderType Members

UpdateFolderType overview

Public Instance Constructors

UpdateFolderType Constructor Initializes a new instance of the UpdateFolderType class.

Public Instance Properties

FolderChanges

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UpdateFolderType Class | Aspose.Email.Exchange.Schema Namespace


UpdateFolderType Constructor

Initializes a new instance of the UpdateFolderType class.

public UpdateFolderType();

See Also

UpdateFolderType Class | Aspose.Email.Exchange.Schema Namespace


UpdateFolderType Properties

The properties of the UpdateFolderType class are listed below. For a complete list of UpdateFolderType class members, see the UpdateFolderType Members topic.

Public Instance Properties

FolderChanges

See Also

UpdateFolderType Class | Aspose.Email.Exchange.Schema Namespace


FolderChanges Property

Aspose.Email

UpdateFolderType.FolderChanges Property

public FolderChangeType[] FolderChanges {get; set;}

Remarks

See Also

UpdateFolderType Class | Aspose.Email.Exchange.Schema Namespace


UpdateInboxRulesCompletedEventArgs Class

Provides data for the event

For a list of all members of this type, see UpdateInboxRulesCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.UpdateInboxRulesCompletedEventArgs

public class UpdateInboxRulesCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UpdateInboxRulesCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace | UpdateInboxRulesCompleted


UpdateInboxRulesCompletedEventArgs Members

UpdateInboxRulesCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result | Gets the result of operation
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

UpdateInboxRulesCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace | UpdateInboxRulesCompleted


UpdateInboxRulesCompletedEventArgs Properties

The properties of the UpdateInboxRulesCompletedEventArgs class are listed below. For a complete list of UpdateInboxRulesCompletedEventArgs class members, see the UpdateInboxRulesCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result | Gets the result of operation
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

UpdateInboxRulesCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace | UpdateInboxRulesCompleted


Result Property

Aspose.Email

UpdateInboxRulesCompletedEventArgs.Result Property

Gets the result of operation

public UpdateInboxRulesResponseType Result {get;}

See Also

UpdateInboxRulesCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


UpdateInboxRulesCompletedEventHandler Delegate

Represents the method that will handle the GetInboxRulesCompleted event

public delegate void UpdateInboxRulesCompletedEventHandler(
object sender,
UpdateInboxRulesCompletedEventArgs e
);

Parameters

sender
The sender of event
e
A GetInboxRulesCompletedEventArgs arguments

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


UpdateInboxRulesRequestType Class

Represents update inbox rules request

For a list of all members of this type, see UpdateInboxRulesRequestType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.UpdateInboxRulesRequestType

public class UpdateInboxRulesRequestType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UpdateInboxRulesRequestType Members | Aspose.Email.Exchange.Schema Namespace


UpdateInboxRulesRequestType Members

UpdateInboxRulesRequestType overview

Public Instance Constructors

UpdateInboxRulesRequestType Constructor Initializes a new instance of the UpdateInboxRulesRequestType class.

Public Instance Properties

MailboxSmtpAddress | Gets or sets the SMTP address of the user whose Inbox rules are to be updated.
Operations | Gets or sets the operations that are to be applied to the user's Inbox rules.
RemoveOutlookRuleBlob | Gets or sets a value indicating whether to remove the BLOB that contains all rules.
RemoveOutlookRuleBlobSpecified | Gets or sets a value indicating whether the RemoveOutlookRuleBlob is specified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UpdateInboxRulesRequestType Class | Aspose.Email.Exchange.Schema Namespace


UpdateInboxRulesRequestType Constructor

Initializes a new instance of the UpdateInboxRulesRequestType class.

public UpdateInboxRulesRequestType();

See Also

UpdateInboxRulesRequestType Class | Aspose.Email.Exchange.Schema Namespace


UpdateInboxRulesRequestType Properties

The properties of the UpdateInboxRulesRequestType class are listed below. For a complete list of UpdateInboxRulesRequestType class members, see the UpdateInboxRulesRequestType Members topic.

Public Instance Properties

MailboxSmtpAddress | Gets or sets the SMTP address of the user whose Inbox rules are to be updated.
Operations | Gets or sets the operations that are to be applied to the user's Inbox rules.
RemoveOutlookRuleBlob | Gets or sets a value indicating whether to remove the BLOB that contains all rules.
RemoveOutlookRuleBlobSpecified | Gets or sets a value indicating whether the RemoveOutlookRuleBlob is specified

See Also

UpdateInboxRulesRequestType Class | Aspose.Email.Exchange.Schema Namespace


MailboxSmtpAddress Property

Aspose.Email

UpdateInboxRulesRequestType.MailboxSmtpAddress Property

Gets or sets the SMTP address of the user whose Inbox rules are to be updated.

public string MailboxSmtpAddress {get; set;}

See Also

UpdateInboxRulesRequestType Class | Aspose.Email.Exchange.Schema Namespace


Operations Property

Aspose.Email

UpdateInboxRulesRequestType.Operations Property

Gets or sets the operations that are to be applied to the user's Inbox rules.

public RuleOperationType[] Operations {get; set;}

See Also

UpdateInboxRulesRequestType Class | Aspose.Email.Exchange.Schema Namespace


RemoveOutlookRuleBlob Property

Aspose.Email

UpdateInboxRulesRequestType.RemoveOutlookRuleBlob Property

Gets or sets a value indicating whether to remove the BLOB that contains all rules.

public bool RemoveOutlookRuleBlob {get; set;}

See Also

UpdateInboxRulesRequestType Class | Aspose.Email.Exchange.Schema Namespace


RemoveOutlookRuleBlobSpecified Property

Aspose.Email

UpdateInboxRulesRequestType.RemoveOutlookRuleBlobSpecified Property

Gets or sets a value indicating whether the RemoveOutlookRuleBlob is specified

public bool RemoveOutlookRuleBlobSpecified {get; set;}

See Also

UpdateInboxRulesRequestType Class | Aspose.Email.Exchange.Schema Namespace


UpdateInboxRulesResponseType Class

Represents the update inbox rules response type

For a list of all members of this type, see UpdateInboxRulesResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.ResponseMessageType
Aspose.Email.Exchange.Schema.UpdateInboxRulesResponseType

public class UpdateInboxRulesResponseType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UpdateInboxRulesResponseType Members | Aspose.Email.Exchange.Schema Namespace


UpdateInboxRulesResponseType Members

UpdateInboxRulesResponseType overview

Public Instance Constructors

UpdateInboxRulesResponseType Constructor Initializes a new instance of the UpdateInboxRulesResponseType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType) |
DescriptiveLinkKeySpecified (inherited from ResponseMessageType) |
MessageText (inherited from ResponseMessageType) |
MessageXml (inherited from ResponseMessageType) |
ResponseClass (inherited from ResponseMessageType) |
ResponseCode (inherited from ResponseMessageType) |
ResponseCodeSpecified (inherited from ResponseMessageType) |
RuleOperationErrors | Gets or sets an array rule operation errors

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UpdateInboxRulesResponseType Class | Aspose.Email.Exchange.Schema Namespace


UpdateInboxRulesResponseType Constructor

Initializes a new instance of the UpdateInboxRulesResponseType class.

public UpdateInboxRulesResponseType();

See Also

UpdateInboxRulesResponseType Class | Aspose.Email.Exchange.Schema Namespace


UpdateInboxRulesResponseType Properties

The properties of the UpdateInboxRulesResponseType class are listed below. For a complete list of UpdateInboxRulesResponseType class members, see the UpdateInboxRulesResponseType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType) |
DescriptiveLinkKeySpecified (inherited from ResponseMessageType) |
MessageText (inherited from ResponseMessageType) |
MessageXml (inherited from ResponseMessageType) |
ResponseClass (inherited from ResponseMessageType) |
ResponseCode (inherited from ResponseMessageType) |
ResponseCodeSpecified (inherited from ResponseMessageType) |
RuleOperationErrors | Gets or sets an array rule operation errors

See Also

UpdateInboxRulesResponseType Class | Aspose.Email.Exchange.Schema Namespace


RuleOperationErrors Property

Aspose.Email

UpdateInboxRulesResponseType.RuleOperationErrors Property

Gets or sets an array rule operation errors

public RuleOperationErrorType[] RuleOperationErrors {get; set;}

See Also

UpdateInboxRulesResponseType Class | Aspose.Email.Exchange.Schema Namespace


UpdateItemCompletedEventArgs Class

For a list of all members of this type, see UpdateItemCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.UpdateItemCompletedEventArgs

public class UpdateItemCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UpdateItemCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


UpdateItemCompletedEventArgs Members

UpdateItemCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

UpdateItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


UpdateItemCompletedEventArgs Properties

The properties of the UpdateItemCompletedEventArgs class are listed below. For a complete list of UpdateItemCompletedEventArgs class members, see the UpdateItemCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

UpdateItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

UpdateItemCompletedEventArgs.Result Property

public UpdateItemResponseType Result {get;}

Remarks

See Also

UpdateItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


UpdateItemCompletedEventHandler Delegate

public delegate void UpdateItemCompletedEventHandler(
object sender,
UpdateItemCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


UpdateItemResponseMessageType Class

For a list of all members of this type, see UpdateItemResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ResponseMessageType
Aspose.Email.Exchange.Schema.ItemInfoResponseMessageType
Aspose.Email.Exchange.Schema.UpdateItemResponseMessageType

public class UpdateItemResponseMessageType : ItemInfoResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UpdateItemResponseMessageType Members | Aspose.Email.Exchange.Schema Namespace


UpdateItemResponseMessageType Members

UpdateItemResponseMessageType overview

Public Instance Constructors

UpdateItemResponseMessageType Constructor Initializes a new instance of the UpdateItemResponseMessageType class.

Public Instance Properties

ConflictResults
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
Items (inherited from ItemInfoResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UpdateItemResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


UpdateItemResponseMessageType Constructor

Initializes a new instance of the UpdateItemResponseMessageType class.

public UpdateItemResponseMessageType();

See Also

UpdateItemResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


UpdateItemResponseMessageType Properties

The properties of the UpdateItemResponseMessageType class are listed below. For a complete list of UpdateItemResponseMessageType class members, see the UpdateItemResponseMessageType Members topic.

Public Instance Properties

ConflictResults
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
Items (inherited from ItemInfoResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

UpdateItemResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


ConflictResults Property

Aspose.Email

UpdateItemResponseMessageType.ConflictResults Property

public ConflictResultsType ConflictResults {get; set;}

Remarks

See Also

UpdateItemResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


UpdateItemResponseType Class

For a list of all members of this type, see UpdateItemResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseResponseMessageType
Aspose.Email.Exchange.Schema.UpdateItemResponseType

public class UpdateItemResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UpdateItemResponseType Members | Aspose.Email.Exchange.Schema Namespace


UpdateItemResponseType Members

UpdateItemResponseType overview

Public Instance Constructors

UpdateItemResponseType Constructor Initializes a new instance of the UpdateItemResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UpdateItemResponseType Class | Aspose.Email.Exchange.Schema Namespace


UpdateItemResponseType Constructor

Initializes a new instance of the UpdateItemResponseType class.

public UpdateItemResponseType();

See Also

UpdateItemResponseType Class | Aspose.Email.Exchange.Schema Namespace


UpdateItemType Class

For a list of all members of this type, see UpdateItemType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.UpdateItemType

public class UpdateItemType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UpdateItemType Members | Aspose.Email.Exchange.Schema Namespace


UpdateItemType Members

UpdateItemType overview

Public Instance Constructors

UpdateItemType Constructor Initializes a new instance of the UpdateItemType class.

Public Instance Properties

ConflictResolution
ItemChanges
MessageDisposition
MessageDispositionSpecified
SavedItemFolderId
SendMeetingInvitationsOrCancellations
SendMeetingInvitationsOrCancellationsSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UpdateItemType Class | Aspose.Email.Exchange.Schema Namespace


UpdateItemType Constructor

Initializes a new instance of the UpdateItemType class.

public UpdateItemType();

See Also

UpdateItemType Class | Aspose.Email.Exchange.Schema Namespace


UpdateItemType Properties

The properties of the UpdateItemType class are listed below. For a complete list of UpdateItemType class members, see the UpdateItemType Members topic.

Public Instance Properties

ConflictResolution
ItemChanges
MessageDisposition
MessageDispositionSpecified
SavedItemFolderId
SendMeetingInvitationsOrCancellations
SendMeetingInvitationsOrCancellationsSpecified

See Also

UpdateItemType Class | Aspose.Email.Exchange.Schema Namespace


ConflictResolution Property

Aspose.Email

UpdateItemType.ConflictResolution Property

public ConflictResolutionType ConflictResolution {get; set;}

Remarks

See Also

UpdateItemType Class | Aspose.Email.Exchange.Schema Namespace


ItemChanges Property

Aspose.Email

UpdateItemType.ItemChanges Property

public ItemChangeType[] ItemChanges {get; set;}

Remarks

See Also

UpdateItemType Class | Aspose.Email.Exchange.Schema Namespace


MessageDisposition Property

Aspose.Email

UpdateItemType.MessageDisposition Property

public MessageDispositionType MessageDisposition {get; set;}

Remarks

See Also

UpdateItemType Class | Aspose.Email.Exchange.Schema Namespace


MessageDispositionSpecified Property

Aspose.Email

UpdateItemType.MessageDispositionSpecified Property

public bool MessageDispositionSpecified {get; set;}

Remarks

See Also

UpdateItemType Class | Aspose.Email.Exchange.Schema Namespace


SavedItemFolderId Property

Aspose.Email

UpdateItemType.SavedItemFolderId Property

public TargetFolderIdType SavedItemFolderId {get; set;}

Remarks

See Also

UpdateItemType Class | Aspose.Email.Exchange.Schema Namespace


SendMeetingInvitationsOrCancellations Property

Aspose.Email

UpdateItemType.SendMeetingInvitationsOrCancellations Property

public CalendarItemUpdateOperationType SendMeetingInvitationsOrCancellations {get; set;}

Remarks

See Also

UpdateItemType Class | Aspose.Email.Exchange.Schema Namespace


SendMeetingInvitationsOrCancellationsSpecified Property

Aspose.Email

UpdateItemType.SendMeetingInvitationsOrCancellationsSpecified Property

public bool SendMeetingInvitationsOrCancellationsSpecified {get; set;}

Remarks

See Also

UpdateItemType Class | Aspose.Email.Exchange.Schema Namespace


UpdateUserConfigurationCompletedEventArgs Class

For a list of all members of this type, see UpdateUserConfigurationCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.UpdateUserConfigurationCompletedEventArgs

public class UpdateUserConfigurationCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UpdateUserConfigurationCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace


UpdateUserConfigurationCompletedEventArgs Members

UpdateUserConfigurationCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

UpdateUserConfigurationCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


UpdateUserConfigurationCompletedEventArgs Properties

The properties of the UpdateUserConfigurationCompletedEventArgs class are listed below. For a complete list of UpdateUserConfigurationCompletedEventArgs class members, see the UpdateUserConfigurationCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

UpdateUserConfigurationCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


Result Property

Aspose.Email

UpdateUserConfigurationCompletedEventArgs.Result Property

public UpdateUserConfigurationResponseType Result {get;}

Remarks

See Also

UpdateUserConfigurationCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


UpdateUserConfigurationCompletedEventHandler Delegate

public delegate void UpdateUserConfigurationCompletedEventHandler(
object sender,
UpdateUserConfigurationCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


UpdateUserConfigurationResponseType Class

For a list of all members of this type, see UpdateUserConfigurationResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseResponseMessageType
Aspose.Email.Exchange.Schema.UpdateUserConfigurationResponseType

public class UpdateUserConfigurationResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UpdateUserConfigurationResponseType Members | Aspose.Email.Exchange.Schema Namespace


UpdateUserConfigurationResponseType Members

UpdateUserConfigurationResponseType overview

Public Instance Constructors

UpdateUserConfigurationResponseType Constructor Initializes a new instance of the UpdateUserConfigurationResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UpdateUserConfigurationResponseType Class | Aspose.Email.Exchange.Schema Namespace


UpdateUserConfigurationResponseType Constructor

Initializes a new instance of the UpdateUserConfigurationResponseType class.

public UpdateUserConfigurationResponseType();

See Also

UpdateUserConfigurationResponseType Class | Aspose.Email.Exchange.Schema Namespace


UpdateUserConfigurationType Class

For a list of all members of this type, see UpdateUserConfigurationType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.UpdateUserConfigurationType

public class UpdateUserConfigurationType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UpdateUserConfigurationType Members | Aspose.Email.Exchange.Schema Namespace


UpdateUserConfigurationType Members

UpdateUserConfigurationType overview

Public Instance Constructors

UpdateUserConfigurationType Constructor Initializes a new instance of the UpdateUserConfigurationType class.

Public Instance Properties

UserConfiguration

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UpdateUserConfigurationType Class | Aspose.Email.Exchange.Schema Namespace


UpdateUserConfigurationType Constructor

Initializes a new instance of the UpdateUserConfigurationType class.

public UpdateUserConfigurationType();

See Also

UpdateUserConfigurationType Class | Aspose.Email.Exchange.Schema Namespace


UpdateUserConfigurationType Properties

The properties of the UpdateUserConfigurationType class are listed below. For a complete list of UpdateUserConfigurationType class members, see the UpdateUserConfigurationType Members topic.

Public Instance Properties

UserConfiguration

See Also

UpdateUserConfigurationType Class | Aspose.Email.Exchange.Schema Namespace


UserConfiguration Property

Aspose.Email

UpdateUserConfigurationType.UserConfiguration Property

public UserConfigurationType UserConfiguration {get; set;}

Remarks

See Also

UpdateUserConfigurationType Class | Aspose.Email.Exchange.Schema Namespace


UploadItemsCompletedEventArgs Class

Provides data for the event

For a list of all members of this type, see UploadItemsCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.UploadItemsCompletedEventArgs

public class UploadItemsCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UploadItemsCompletedEventArgs Members | Aspose.Email.Exchange.Schema Namespace | UploadItemsCompleted


UploadItemsCompletedEventArgs Members

UploadItemsCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result | Gets the result of operation
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

UploadItemsCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace | UploadItemsCompleted


UploadItemsCompletedEventArgs Properties

The properties of the UploadItemsCompletedEventArgs class are listed below. For a complete list of UploadItemsCompletedEventArgs class members, see the UploadItemsCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result | Gets the result of operation
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

UploadItemsCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace | UploadItemsCompleted


Result Property

Aspose.Email

UploadItemsCompletedEventArgs.Result Property

Gets the result of operation

public UploadItemsResponseType Result {get;}

See Also

UploadItemsCompletedEventArgs Class | Aspose.Email.Exchange.Schema Namespace


UploadItemsCompletedEventHandler Delegate

Represents the method that will handle the UploadItemsCompleted event

public delegate void UploadItemsCompletedEventHandler(
object sender,
UploadItemsCompletedEventArgs e
);

Parameters

sender
The sender of event
e
A UploadItemsCompletedEventArgs arguments

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


UploadItemsResponseMessageType Class

Represents the item identifier of an item that was uploaded into a mailbox.

For a list of all members of this type, see UploadItemsResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.ResponseMessageType
Aspose.Email.Exchange.Schema.UploadItemsResponseMessageType

public class UploadItemsResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UploadItemsResponseMessageType Members | Aspose.Email.Exchange.Schema Namespace


UploadItemsResponseMessageType Members

UploadItemsResponseMessageType overview

Public Instance Constructors

UploadItemsResponseMessageType Constructor Initializes a new instance of the UploadItemsResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType) |
DescriptiveLinkKeySpecified (inherited from ResponseMessageType) |
ItemId | Gets or sets the item identifier of an item that was uploaded into a mailbox.
MessageText (inherited from ResponseMessageType) |
MessageXml (inherited from ResponseMessageType) |
ResponseClass (inherited from ResponseMessageType) |
ResponseCode (inherited from ResponseMessageType) |
ResponseCodeSpecified (inherited from ResponseMessageType) |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UploadItemsResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


UploadItemsResponseMessageType Constructor

Initializes a new instance of the UploadItemsResponseMessageType class.

public UploadItemsResponseMessageType();

See Also

UploadItemsResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


UploadItemsResponseMessageType Properties

The properties of the UploadItemsResponseMessageType class are listed below. For a complete list of UploadItemsResponseMessageType class members, see the UploadItemsResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType) |
DescriptiveLinkKeySpecified (inherited from ResponseMessageType) |
ItemId | Gets or sets the item identifier of an item that was uploaded into a mailbox.
MessageText (inherited from ResponseMessageType) |
MessageXml (inherited from ResponseMessageType) |
ResponseClass (inherited from ResponseMessageType) |
ResponseCode (inherited from ResponseMessageType) |
ResponseCodeSpecified (inherited from ResponseMessageType) |

See Also

UploadItemsResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


ItemId Property

Aspose.Email

UploadItemsResponseMessageType.ItemId Property

Gets or sets the item identifier of an item that was uploaded into a mailbox.

public ItemIdType ItemId {get; set;}

See Also

UploadItemsResponseMessageType Class | Aspose.Email.Exchange.Schema Namespace


UploadItemsResponseType Class

Represents the response messages for which an attempt was made to update into a mailbox.

For a list of all members of this type, see UploadItemsResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseResponseMessageType
Aspose.Email.Exchange.Schema.UploadItemsResponseType

public class UploadItemsResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UploadItemsResponseType Members | Aspose.Email.Exchange.Schema Namespace


UploadItemsResponseType Members

UploadItemsResponseType overview

Public Instance Constructors

UploadItemsResponseType Constructor Initializes a new instance of the UploadItemsResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UploadItemsResponseType Class | Aspose.Email.Exchange.Schema Namespace


UploadItemsResponseType Constructor

Initializes a new instance of the UploadItemsResponseType class.

public UploadItemsResponseType();

See Also

UploadItemsResponseType Class | Aspose.Email.Exchange.Schema Namespace


UploadItemsType Class

Represents the contents of a request to upload items in to a mailbox.

For a list of all members of this type, see UploadItemsType Members.

System.Object
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.UploadItemsType

public class UploadItemsType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UploadItemsType Members | Aspose.Email.Exchange.Schema Namespace


UploadItemsType Members

UploadItemsType overview

Public Instance Constructors

UploadItemsType Constructor Initializes a new instance of the UploadItemsType class.

Public Instance Properties

Items Gets or sets the collection of items to upload into a mailbox.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UploadItemsType Class | Aspose.Email.Exchange.Schema Namespace


UploadItemsType Constructor

Initializes a new instance of the UploadItemsType class.

public UploadItemsType();

See Also

UploadItemsType Class | Aspose.Email.Exchange.Schema Namespace


UploadItemsType Properties

The properties of the UploadItemsType class are listed below. For a complete list of UploadItemsType class members, see the UploadItemsType Members topic.

Public Instance Properties

Items Gets or sets the collection of items to upload into a mailbox.

See Also

UploadItemsType Class | Aspose.Email.Exchange.Schema Namespace


Items Property

Aspose.Email

UploadItemsType.Items Property

Gets or sets the collection of items to upload into a mailbox.

public UploadItemType[] Items {get; set;}

See Also

UploadItemsType Class | Aspose.Email.Exchange.Schema Namespace


UploadItemType Class

Represents the contents of a single item to upload in to a mailbox.

For a list of all members of this type, see UploadItemType Members.

System.Object
Aspose.Email.Exchange.Schema.UploadItemType

public class UploadItemType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UploadItemType Members | Aspose.Email.Exchange.Schema Namespace


UploadItemType Members

UploadItemType overview

Public Instance Constructors

UploadItemType Constructor Initializes a new instance of the UploadItemType class.

Public Instance Properties

CreateAction | Gets or sets the action for uploading items into a mailbox.
Data | Gets or sets the data of the upload item.
IsAssociated | Gets or sets whether the item is a folder associated item.
IsAssociatedSpecified | Gets or sets a value indicating whether the IsAssociated is specified
ItemId | Gets or sets the item identifier of the upload item.
ParentFolderId | Gets or sets the target folder in which to place the upload item.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UploadItemType Class | Aspose.Email.Exchange.Schema Namespace


UploadItemType Constructor

Initializes a new instance of the UploadItemType class.

public UploadItemType();

See Also

UploadItemType Class | Aspose.Email.Exchange.Schema Namespace


UploadItemType Properties

The properties of the UploadItemType class are listed below. For a complete list of UploadItemType class members, see the UploadItemType Members topic.

Public Instance Properties

CreateAction | Gets or sets the action for uploading items into a mailbox.
Data | Gets or sets the data of the upload item.
IsAssociated | Gets or sets whether the item is a folder associated item.
IsAssociatedSpecified | Gets or sets a value indicating whether the IsAssociated is specified
ItemId | Gets or sets the item identifier of the upload item.
ParentFolderId | Gets or sets the target folder in which to place the upload item.

See Also

UploadItemType Class | Aspose.Email.Exchange.Schema Namespace


CreateAction Property

Aspose.Email

UploadItemType.CreateAction Property

Gets or sets the action for uploading items into a mailbox.

public CreateActionType CreateAction {get; set;}

See Also

UploadItemType Class | Aspose.Email.Exchange.Schema Namespace


Data Property

Aspose.Email

UploadItemType.Data Property

Gets or sets the data of the upload item.

public byte[] Data {get; set;}

See Also

UploadItemType Class | Aspose.Email.Exchange.Schema Namespace


IsAssociated Property

Aspose.Email

UploadItemType.IsAssociated Property

Gets or sets whether the item is a folder associated item.

public bool IsAssociated {get; set;}

See Also

UploadItemType Class | Aspose.Email.Exchange.Schema Namespace


IsAssociatedSpecified Property

Aspose.Email

UploadItemType.IsAssociatedSpecified Property

Gets or sets a value indicating whether the IsAssociated is specified

public bool IsAssociatedSpecified {get; set;}

See Also

UploadItemType Class | Aspose.Email.Exchange.Schema Namespace


ItemId Property

Aspose.Email

UploadItemType.ItemId Property

Gets or sets the item identifier of the upload item.

public ItemIdType ItemId {get; set;}

See Also

UploadItemType Class | Aspose.Email.Exchange.Schema Namespace


ParentFolderId Property

Aspose.Email

UploadItemType.ParentFolderId Property

Gets or sets the target folder in which to place the upload item.

public FolderIdType ParentFolderId {get; set;}

See Also

UploadItemType Class | Aspose.Email.Exchange.Schema Namespace


UserConfigurationDictionaryEntryType Class

For a list of all members of this type, see UserConfigurationDictionaryEntryType Members.

System.Object
Aspose.Email.Exchange.Schema.UserConfigurationDictionaryEntryType

public class UserConfigurationDictionaryEntryType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UserConfigurationDictionaryEntryType Members | Aspose.Email.Exchange.Schema Namespace


UserConfigurationDictionaryEntryType Members

UserConfigurationDictionaryEntryType overview

Public Instance Constructors

UserConfigurationDictionaryEntryType Constructor Initializes a new instance of the UserConfigurationDictionaryEntryType class.

Public Instance Properties

DictionaryKey
DictionaryValue

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UserConfigurationDictionaryEntryType Class | Aspose.Email.Exchange.Schema Namespace


UserConfigurationDictionaryEntryType Constructor

Initializes a new instance of the UserConfigurationDictionaryEntryType class.

public UserConfigurationDictionaryEntryType();

See Also

UserConfigurationDictionaryEntryType Class | Aspose.Email.Exchange.Schema Namespace


UserConfigurationDictionaryEntryType Properties

The properties of the UserConfigurationDictionaryEntryType class are listed below. For a complete list of UserConfigurationDictionaryEntryType class members, see the UserConfigurationDictionaryEntryType Members topic.

Public Instance Properties

DictionaryKey
DictionaryValue

See Also

UserConfigurationDictionaryEntryType Class | Aspose.Email.Exchange.Schema Namespace


DictionaryKey Property

Aspose.Email

UserConfigurationDictionaryEntryType.DictionaryKey Property

public UserConfigurationDictionaryObjectType DictionaryKey {get; set;}

Remarks

See Also

UserConfigurationDictionaryEntryType Class | Aspose.Email.Exchange.Schema Namespace


DictionaryValue Property

Aspose.Email

UserConfigurationDictionaryEntryType.DictionaryValue Property

public UserConfigurationDictionaryObjectType DictionaryValue {get; set;}

Remarks

See Also

UserConfigurationDictionaryEntryType Class | Aspose.Email.Exchange.Schema Namespace


UserConfigurationDictionaryObjectType Class

For a list of all members of this type, see UserConfigurationDictionaryObjectType Members.

System.Object
Aspose.Email.Exchange.Schema.UserConfigurationDictionaryObjectType

public class UserConfigurationDictionaryObjectType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UserConfigurationDictionaryObjectType Members | Aspose.Email.Exchange.Schema Namespace


UserConfigurationDictionaryObjectType Members

UserConfigurationDictionaryObjectType overview

Public Instance Constructors

UserConfigurationDictionaryObjectType Constructor Initializes a new instance of the UserConfigurationDictionaryObjectType class.

Public Instance Properties

Type
Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UserConfigurationDictionaryObjectType Class | Aspose.Email.Exchange.Schema Namespace


UserConfigurationDictionaryObjectType Constructor

Initializes a new instance of the UserConfigurationDictionaryObjectType class.

public UserConfigurationDictionaryObjectType();

See Also

UserConfigurationDictionaryObjectType Class | Aspose.Email.Exchange.Schema Namespace


UserConfigurationDictionaryObjectType Properties

The properties of the UserConfigurationDictionaryObjectType class are listed below. For a complete list of UserConfigurationDictionaryObjectType class members, see the UserConfigurationDictionaryObjectType Members topic.

Public Instance Properties

Type
Value

See Also

UserConfigurationDictionaryObjectType Class | Aspose.Email.Exchange.Schema Namespace


Type Property

Aspose.Email

UserConfigurationDictionaryObjectType.Type Property

public UserConfigurationDictionaryObjectTypesType Type {get; set;}

Remarks

See Also

UserConfigurationDictionaryObjectType Class | Aspose.Email.Exchange.Schema Namespace


Value Property

Aspose.Email

UserConfigurationDictionaryObjectType.Value Property

public string[] Value {get; set;}

Remarks

See Also

UserConfigurationDictionaryObjectType Class | Aspose.Email.Exchange.Schema Namespace


UserConfigurationDictionaryObjectTypesType Enumeration

public enum UserConfigurationDictionaryObjectTypesType

Remarks

Members

Member Name | Description | Value
DateTime |  | 0
Boolean |  | 1
Byte |  | 2
String |  | 3
Integer32 |  | 4
UnsignedInteger32 |  | 5
Integer64 |  | 6
UnsignedInteger64 |  | 7
StringArray |  | 8
ByteArray |  | 9

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


UserConfigurationNameType Class

For a list of all members of this type, see UserConfigurationNameType Members.

System.Object
Aspose.Email.Exchange.Schema.TargetFolderIdType
Aspose.Email.Exchange.Schema.UserConfigurationNameType

public class UserConfigurationNameType : TargetFolderIdType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UserConfigurationNameType Members | Aspose.Email.Exchange.Schema Namespace


UserConfigurationNameType Members

UserConfigurationNameType overview

Public Instance Constructors

UserConfigurationNameType Constructor Initializes a new instance of the UserConfigurationNameType class.

Public Instance Properties

Item (inherited from TargetFolderIdType)
Name

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UserConfigurationNameType Class | Aspose.Email.Exchange.Schema Namespace


UserConfigurationNameType Constructor

Initializes a new instance of the UserConfigurationNameType class.

public UserConfigurationNameType();

See Also

UserConfigurationNameType Class | Aspose.Email.Exchange.Schema Namespace


UserConfigurationNameType Properties

The properties of the UserConfigurationNameType class are listed below. For a complete list of UserConfigurationNameType class members, see the UserConfigurationNameType Members topic.

Public Instance Properties

Item (inherited from TargetFolderIdType)
Name

See Also

UserConfigurationNameType Class | Aspose.Email.Exchange.Schema Namespace


Name Property

Aspose.Email

UserConfigurationNameType.Name Property

public string Name {get; set;}

Remarks

See Also

UserConfigurationNameType Class | Aspose.Email.Exchange.Schema Namespace


UserConfigurationPropertyType Enumeration

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum UserConfigurationPropertyType

Remarks

Members

Member Name | Description | Value
Id |  | 1
Dictionary |  | 2
XmlData |  | 4
BinaryData |  | 8
All |  | 16

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema Namespace


UserConfigurationType Class

For a list of all members of this type, see UserConfigurationType Members.

System.Object
Aspose.Email.Exchange.Schema.UserConfigurationType

public class UserConfigurationType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UserConfigurationType Members | Aspose.Email.Exchange.Schema Namespace


UserConfigurationType Members

UserConfigurationType overview

Public Instance Constructors

UserConfigurationType Constructor Initializes a new instance of the UserConfigurationType class.

Public Instance Properties

BinaryData
Dictionary
ItemId
UserConfigurationName
XmlData

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UserConfigurationType Class | Aspose.Email.Exchange.Schema Namespace


UserConfigurationType Constructor

Initializes a new instance of the UserConfigurationType class.

public UserConfigurationType();

See Also

UserConfigurationType Class | Aspose.Email.Exchange.Schema Namespace


UserConfigurationType Properties

The properties of the UserConfigurationType class are listed below. For a complete list of UserConfigurationType class members, see the UserConfigurationType Members topic.

Public Instance Properties

BinaryData
Dictionary
ItemId
UserConfigurationName
XmlData

See Also

UserConfigurationType Class | Aspose.Email.Exchange.Schema Namespace


BinaryData Property

Aspose.Email

UserConfigurationType.BinaryData Property

public byte[] BinaryData {get; set;}

Remarks

See Also

UserConfigurationType Class | Aspose.Email.Exchange.Schema Namespace


Dictionary Property

Aspose.Email

UserConfigurationType.Dictionary Property

public UserConfigurationDictionaryEntryType[] Dictionary {get; set;}

Remarks

See Also

UserConfigurationType Class | Aspose.Email.Exchange.Schema Namespace


ItemId Property

Aspose.Email

UserConfigurationType.ItemId Property

public ItemIdType ItemId {get; set;}

Remarks

See Also

UserConfigurationType Class | Aspose.Email.Exchange.Schema Namespace


UserConfigurationName Property

Aspose.Email

UserConfigurationType.UserConfigurationName Property

public UserConfigurationNameType UserConfigurationName {get; set;}

Remarks

See Also

UserConfigurationType Class | Aspose.Email.Exchange.Schema Namespace


XmlData Property

Aspose.Email

UserConfigurationType.XmlData Property

public byte[] XmlData {get; set;}

Remarks

See Also

UserConfigurationType Class | Aspose.Email.Exchange.Schema Namespace


UserIdType Class

For a list of all members of this type, see UserIdType Members.

System.Object
Aspose.Email.Exchange.Schema.UserIdType

public class UserIdType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UserIdType Members | Aspose.Email.Exchange.Schema Namespace


UserIdType Members

UserIdType overview

Public Instance Constructors

UserIdType Constructor Initializes a new instance of the UserIdType class.

Public Instance Properties

DisplayName
DistinguishedUser
DistinguishedUserSpecified
ExternalUserIdentity
PrimarySmtpAddress
SID

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UserIdType Class | Aspose.Email.Exchange.Schema Namespace


UserIdType Constructor

Initializes a new instance of the UserIdType class.

public UserIdType();

See Also

UserIdType Class | Aspose.Email.Exchange.Schema Namespace


UserIdType Properties

The properties of the UserIdType class are listed below. For a complete list of UserIdType class members, see the UserIdType Members topic.

Public Instance Properties

DisplayName
DistinguishedUser
DistinguishedUserSpecified
ExternalUserIdentity
PrimarySmtpAddress
SID

See Also

UserIdType Class | Aspose.Email.Exchange.Schema Namespace


DisplayName Property

Aspose.Email

UserIdType.DisplayName Property

public string DisplayName {get; set;}

Remarks

See Also

UserIdType Class | Aspose.Email.Exchange.Schema Namespace


DistinguishedUser Property

Aspose.Email

UserIdType.DistinguishedUser Property

public DistinguishedUserType DistinguishedUser {get; set;}

Remarks

See Also

UserIdType Class | Aspose.Email.Exchange.Schema Namespace


DistinguishedUserSpecified Property

Aspose.Email

UserIdType.DistinguishedUserSpecified Property

public bool DistinguishedUserSpecified {get; set;}

Remarks

See Also

UserIdType Class | Aspose.Email.Exchange.Schema Namespace


ExternalUserIdentity Property

Aspose.Email

UserIdType.ExternalUserIdentity Property

public string ExternalUserIdentity {get; set;}

Remarks

See Also

UserIdType Class | Aspose.Email.Exchange.Schema Namespace


PrimarySmtpAddress Property

Aspose.Email

UserIdType.PrimarySmtpAddress Property

public string PrimarySmtpAddress {get; set;}

Remarks

See Also

UserIdType Class | Aspose.Email.Exchange.Schema Namespace


SID Property

Aspose.Email

UserIdType.SID Property

public string SID {get; set;}

Remarks

See Also

UserIdType Class | Aspose.Email.Exchange.Schema Namespace


UserMailboxType Class

For a list of all members of this type, see UserMailboxType Members.

System.Object
Aspose.Email.Exchange.Schema.UserMailboxType

public class UserMailboxType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UserMailboxType Members | Aspose.Email.Exchange.Schema Namespace


UserMailboxType Members

UserMailboxType overview

Public Instance Constructors

UserMailboxType Constructor Initializes a new instance of the UserMailboxType class.

Public Instance Properties

Id
IsArchive

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UserMailboxType Class | Aspose.Email.Exchange.Schema Namespace


UserMailboxType Constructor

Initializes a new instance of the UserMailboxType class.

public UserMailboxType();

See Also

UserMailboxType Class | Aspose.Email.Exchange.Schema Namespace


UserMailboxType Properties

The properties of the UserMailboxType class are listed below. For a complete list of UserMailboxType class members, see the UserMailboxType Members topic.

Public Instance Properties

Id
IsArchive

See Also

UserMailboxType Class | Aspose.Email.Exchange.Schema Namespace


Id Property

Aspose.Email

UserMailboxType.Id Property

public string Id {get; set;}

Remarks

See Also

UserMailboxType Class | Aspose.Email.Exchange.Schema Namespace


IsArchive Property

Aspose.Email

UserMailboxType.IsArchive Property

public bool IsArchive {get; set;}

Remarks

See Also

UserMailboxType Class | Aspose.Email.Exchange.Schema Namespace


UserOofSettings Class

For a list of all members of this type, see UserOofSettings Members.

System.Object
Aspose.Email.Exchange.Schema.UserOofSettings

public class UserOofSettings

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UserOofSettings Members | Aspose.Email.Exchange.Schema Namespace


UserOofSettings Members

UserOofSettings overview

Public Instance Constructors

UserOofSettings Constructor Initializes a new instance of the UserOofSettings class.

Public Instance Properties

Duration
ExternalAudience
ExternalReply
InternalReply
OofState

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UserOofSettings Class | Aspose.Email.Exchange.Schema Namespace


UserOofSettings Constructor

Initializes a new instance of the UserOofSettings class.

public UserOofSettings();

See Also

UserOofSettings Class | Aspose.Email.Exchange.Schema Namespace


UserOofSettings Properties

The properties of the UserOofSettings class are listed below. For a complete list of UserOofSettings class members, see the UserOofSettings Members topic.

Public Instance Properties

Duration
ExternalAudience
ExternalReply
InternalReply
OofState

See Also

UserOofSettings Class | Aspose.Email.Exchange.Schema Namespace


Duration Property

Aspose.Email

UserOofSettings.Duration Property

public Duration Duration {get; set;}

Remarks

See Also

UserOofSettings Class | Aspose.Email.Exchange.Schema Namespace


ExternalAudience Property

Aspose.Email

UserOofSettings.ExternalAudience Property

public ExternalAudience ExternalAudience {get; set;}

Remarks

See Also

UserOofSettings Class | Aspose.Email.Exchange.Schema Namespace


ExternalReply Property

Aspose.Email

UserOofSettings.ExternalReply Property

public ReplyBody ExternalReply {get; set;}

Remarks

See Also

UserOofSettings Class | Aspose.Email.Exchange.Schema Namespace


InternalReply Property

Aspose.Email

UserOofSettings.InternalReply Property

public ReplyBody InternalReply {get; set;}

Remarks

See Also

UserOofSettings Class | Aspose.Email.Exchange.Schema Namespace


OofState Property

Aspose.Email

UserOofSettings.OofState Property

public OofState OofState {get; set;}

Remarks

See Also

UserOofSettings Class | Aspose.Email.Exchange.Schema Namespace


WeeklyRecurrencePatternType Class

Class describes the frequency, in weeks, in which an item recurs, and the days on which the item recurs.

For a list of all members of this type, see WeeklyRecurrencePatternType Members.

System.Object
Aspose.Email.Exchange.Schema.RecurrencePatternBaseType
Aspose.Email.Exchange.Schema.IntervalRecurrencePatternBaseType
Aspose.Email.Exchange.Schema.WeeklyRecurrencePatternType

public class WeeklyRecurrencePatternType : IntervalRecurrencePatternBaseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

WeeklyRecurrencePatternType Members | Aspose.Email.Exchange.Schema Namespace


WeeklyRecurrencePatternType Members

WeeklyRecurrencePatternType overview

Public Instance Constructors

WeeklyRecurrencePatternType Constructor Initializes a new instance of the WeeklyRecurrencePatternType class.

Public Instance Properties

DaysOfWeek
FirstDayOfWeek
Interval (inherited from IntervalRecurrencePatternBaseType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WeeklyRecurrencePatternType Class | Aspose.Email.Exchange.Schema Namespace


WeeklyRecurrencePatternType Constructor

Initializes a new instance of the WeeklyRecurrencePatternType class.

public WeeklyRecurrencePatternType();

See Also

WeeklyRecurrencePatternType Class | Aspose.Email.Exchange.Schema Namespace


WeeklyRecurrencePatternType Properties

The properties of the WeeklyRecurrencePatternType class are listed below. For a complete list of WeeklyRecurrencePatternType class members, see the WeeklyRecurrencePatternType Members topic.

Public Instance Properties

DaysOfWeek
FirstDayOfWeek
Interval (inherited from IntervalRecurrencePatternBaseType)

See Also

WeeklyRecurrencePatternType Class | Aspose.Email.Exchange.Schema Namespace


DaysOfWeek Property

Aspose.Email

WeeklyRecurrencePatternType.DaysOfWeek Property

public string DaysOfWeek {get; set;}

Remarks

See Also

WeeklyRecurrencePatternType Class | Aspose.Email.Exchange.Schema Namespace


FirstDayOfWeek Property

Aspose.Email

WeeklyRecurrencePatternType.FirstDayOfWeek Property

public string FirstDayOfWeek {get; set;}

Remarks

See Also

WeeklyRecurrencePatternType Class | Aspose.Email.Exchange.Schema Namespace


WeeklyRegeneratingPatternType Class

Class describes the interval, in weeks, in which a task is regenerated.

For a list of all members of this type, see WeeklyRegeneratingPatternType Members.

System.Object
Aspose.Email.Exchange.Schema.RecurrencePatternBaseType
Aspose.Email.Exchange.Schema.IntervalRecurrencePatternBaseType
Aspose.Email.Exchange.Schema.RegeneratingPatternBaseType
Aspose.Email.Exchange.Schema.WeeklyRegeneratingPatternType

public class WeeklyRegeneratingPatternType : RegeneratingPatternBaseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

WeeklyRegeneratingPatternType Members | Aspose.Email.Exchange.Schema Namespace


WeeklyRegeneratingPatternType Members

WeeklyRegeneratingPatternType overview

Public Instance Constructors

WeeklyRegeneratingPatternType Constructor Initializes a new instance of the WeeklyRegeneratingPatternType class.

Public Instance Properties

Interval (inherited from IntervalRecurrencePatternBaseType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WeeklyRegeneratingPatternType Class | Aspose.Email.Exchange.Schema Namespace


WeeklyRegeneratingPatternType Constructor

Initializes a new instance of the WeeklyRegeneratingPatternType class.

public WeeklyRegeneratingPatternType();

See Also

WeeklyRegeneratingPatternType Class | Aspose.Email.Exchange.Schema Namespace


WellKnownResponseObjectType Class

For a list of all members of this type, see WellKnownResponseObjectType Members.

System.Object
Aspose.Email.Exchange.Schema.ItemType
Aspose.Email.Exchange.Schema.MessageType
Aspose.Email.Exchange.Schema.ResponseObjectCoreType
Aspose.Email.Exchange.Schema.ResponseObjectType
Aspose.Email.Exchange.Schema.WellKnownResponseObjectType
Aspose.Email.Exchange.Schema.AcceptItemType
Aspose.Email.Exchange.Schema.DeclineItemType
Aspose.Email.Exchange.Schema.TentativelyAcceptItemType

public class WellKnownResponseObjectType : ResponseObjectType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

WellKnownResponseObjectType Members | Aspose.Email.Exchange.Schema Namespace


WellKnownResponseObjectType Members

WellKnownResponseObjectType overview

Public Instance Constructors

WellKnownResponseObjectType Constructor Initializes a new instance of the WellKnownResponseObjectType class.

Public Instance Properties

Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
From (inherited from MessageType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
ObjectName (inherited from ResponseObjectType)
ParentFolderId (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
ReferenceItemId (inherited from ResponseObjectCoreType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
Subject (inherited from ItemType)
ToRecipients (inherited from MessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WellKnownResponseObjectType Class | Aspose.Email.Exchange.Schema Namespace


WellKnownResponseObjectType Constructor

Initializes a new instance of the WellKnownResponseObjectType class.

public WellKnownResponseObjectType();

See Also

WellKnownResponseObjectType Class | Aspose.Email.Exchange.Schema Namespace


WorkingHours Class

For a list of all members of this type, see WorkingHours Members.

System.Object
Aspose.Email.Exchange.Schema.WorkingHours

public class WorkingHours

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

WorkingHours Members | Aspose.Email.Exchange.Schema Namespace


WorkingHours Members

WorkingHours overview

Public Instance Constructors

WorkingHours Constructor Initializes a new instance of the WorkingHours class.

Public Instance Properties

TimeZone
WorkingPeriodArray

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WorkingHours Class | Aspose.Email.Exchange.Schema Namespace


WorkingHours Constructor

Initializes a new instance of the WorkingHours class.

public WorkingHours();

See Also

WorkingHours Class | Aspose.Email.Exchange.Schema Namespace


WorkingHours Properties

The properties of the WorkingHours class are listed below. For a complete list of WorkingHours class members, see the WorkingHours Members topic.

Public Instance Properties

TimeZone
WorkingPeriodArray

See Also

WorkingHours Class | Aspose.Email.Exchange.Schema Namespace


TimeZone Property

Aspose.Email

WorkingHours.TimeZone Property

public SerializableTimeZone TimeZone {get; set;}

Remarks

See Also

WorkingHours Class | Aspose.Email.Exchange.Schema Namespace


WorkingPeriodArray Property

Aspose.Email

WorkingHours.WorkingPeriodArray Property

public WorkingPeriod[] WorkingPeriodArray {get; set;}

Remarks

See Also

WorkingHours Class | Aspose.Email.Exchange.Schema Namespace


WorkingPeriod Class

For a list of all members of this type, see WorkingPeriod Members.

System.Object
Aspose.Email.Exchange.Schema.WorkingPeriod

public class WorkingPeriod

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

WorkingPeriod Members | Aspose.Email.Exchange.Schema Namespace


WorkingPeriod Members

WorkingPeriod overview

Public Instance Constructors

WorkingPeriod Constructor Initializes a new instance of the WorkingPeriod class.

Public Instance Properties

DayOfWeek
EndTimeInMinutes
StartTimeInMinutes

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WorkingPeriod Class | Aspose.Email.Exchange.Schema Namespace


WorkingPeriod Constructor

Initializes a new instance of the WorkingPeriod class.

public WorkingPeriod();

See Also

WorkingPeriod Class | Aspose.Email.Exchange.Schema Namespace


WorkingPeriod Properties

The properties of the WorkingPeriod class are listed below. For a complete list of WorkingPeriod class members, see the WorkingPeriod Members topic.

Public Instance Properties

DayOfWeek
EndTimeInMinutes
StartTimeInMinutes

See Also

WorkingPeriod Class | Aspose.Email.Exchange.Schema Namespace


DayOfWeek Property

Aspose.Email

WorkingPeriod.DayOfWeek Property

public string DayOfWeek {get; set;}

Remarks

See Also

WorkingPeriod Class | Aspose.Email.Exchange.Schema Namespace


EndTimeInMinutes Property

Aspose.Email

WorkingPeriod.EndTimeInMinutes Property

public int EndTimeInMinutes {get; set;}

Remarks

See Also

WorkingPeriod Class | Aspose.Email.Exchange.Schema Namespace


StartTimeInMinutes Property

Aspose.Email

WorkingPeriod.StartTimeInMinutes Property

public int StartTimeInMinutes {get; set;}

Remarks

See Also

WorkingPeriod Class | Aspose.Email.Exchange.Schema Namespace


YearlyRegeneratingPatternType Class

Class describes the interval, in years, in which a task is regenerated.

For a list of all members of this type, see YearlyRegeneratingPatternType Members.

System.Object
Aspose.Email.Exchange.Schema.RecurrencePatternBaseType
Aspose.Email.Exchange.Schema.IntervalRecurrencePatternBaseType
Aspose.Email.Exchange.Schema.RegeneratingPatternBaseType
Aspose.Email.Exchange.Schema.YearlyRegeneratingPatternType

public class YearlyRegeneratingPatternType : RegeneratingPatternBaseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

YearlyRegeneratingPatternType Members | Aspose.Email.Exchange.Schema Namespace


YearlyRegeneratingPatternType Members

YearlyRegeneratingPatternType overview

Public Instance Constructors

YearlyRegeneratingPatternType Constructor Initializes a new instance of the YearlyRegeneratingPatternType class.

Public Instance Properties

Interval (inherited from IntervalRecurrencePatternBaseType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

YearlyRegeneratingPatternType Class | Aspose.Email.Exchange.Schema Namespace


YearlyRegeneratingPatternType Constructor

Initializes a new instance of the YearlyRegeneratingPatternType class.

public YearlyRegeneratingPatternType();

See Also

YearlyRegeneratingPatternType Class | Aspose.Email.Exchange.Schema Namespace


Aspose.Email.Exchange.Schema.Exchange_2013

Aspose.Email

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace

Namespace hierarchy

Classes

Class | Description
AbsoluteDateTransitionType |
AbsoluteMonthlyRecurrencePatternType |
AbsoluteYearlyRecurrencePatternType |
AcceptItemType |
AcceptSharingInvitationType |
AddDelegateCompletedEventArgs |
AddDelegateResponseMessageType |
AddDelegateType |
AddDistributionGroupToImListCompletedEventArgs |
AddDistributionGroupToImListResponseMessageType |
AddDistributionGroupToImListType |
AddImContactToGroupCompletedEventArgs |
AddImContactToGroupResponseMessageType |
AddImContactToGroupType |
AddImGroupCompletedEventArgs |
AddImGroupResponseMessageType |
AddImGroupType |
AddNewImContactToGroupCompletedEventArgs |
AddNewImContactToGroupResponseMessageType |
AddNewImContactToGroupType |
AddNewTelUriContactToGroupCompletedEventArgs |
AddNewTelUriContactToGroupResponseMessageType |
AddNewTelUriContactToGroupType |
AddressEntityType |
AddressListIdType |
AggregateOnType |
AlternateIdBaseType |
AlternateIdType |
AlternatePublicFolderIdType |
AlternatePublicFolderItemIdType |
AndType |
AppendToFolderFieldType |
AppendToItemFieldType |
ApplyConversationActionCompletedEventArgs |
ApplyConversationActionResponseType |
ApplyConversationActionType |
ArchiveItemCompletedEventArgs |
ArchiveItemResponseType |
ArchiveItemType |
ArrayOfDLExpansionType |
ArrayOfGroupedItemsType |
ArrayOfRealItemsType |
ArrayOfResolutionType |
ArrayOfResponseMessagesType |
ArrayOfTimeZoneDefinitionType |
ArrayOfTrackingPropertiesType |
ArrayOfTransitionsType |
AttachmentIdType |
AttachmentInfoResponseMessageType |
AttachmentResponseShapeType |
AttachmentType |
AttendeeConflictData |
AttendeeType |
AudioMetricsAverageType |
AudioQualityType |
BaseCalendarItemStateDefinitionType |
BaseDelegateResponseMessageType |
BaseDelegateType |
BaseEmailAddressType |
BaseFolderIdType |
BaseFolderType |
BaseGroupByType |
BaseItemIdType |
BaseMoveCopyFolderType |
BaseMoveCopyItemType |
BaseNotificationEventType |
BaseObjectChangedEventType |
BasePagingType |
BasePathToElementType |
BasePermissionType |
BaseRequestType |
BaseResponseMessageType |
BaseSubscriptionRequestType |
BodyContentAttributedValueType |
BodyContentType |
BodyType |
CalendarEvent |
CalendarEventDetails |
CalendarFolderType |
CalendarItemType |
CalendarPermissionSetType |
CalendarPermissionType |
CalendarViewType |
CancelCalendarItemType |
CDRDataType |
ChangeDescriptionType |
ChangeHighlightsType |
ClientAccessTokenRequestType |
ClientAccessTokenType |
ClientExtensionResponseType |
ClientExtensionType |
ClientIntentType |
CompleteFindInGALSpeechRecognitionResponseMessageType |
CompleteFindInGALSpeechRecognitionType |
CompleteNameType |
ConfigurationRequestDetailsType |
ConflictResultsType |
ConnectingSIDType |
ConstantValueType |
ContactItemType |
ContactsFolderType |
ContactsViewType |
ContactType |
ContainsExpressionType |
ConversationActionType |
ConversationNodeType |
ConversationRequestType |
ConversationResponseShapeType |
ConversationResponseType |
ConversationType |
ConvertIdCompletedEventArgs |
ConvertIdResponseMessageType |
ConvertIdResponseType |
ConvertIdType |
CopyFolderCompletedEventArgs |
CopyFolderResponseType |
CopyFolderType |
CopyItemCompletedEventArgs |
CopyItemResponseType |
CopyItemType |
CreateAttachmentCompletedEventArgs |
CreateAttachmentResponseType |
CreateAttachmentType |
CreateFolderCompletedEventArgs |
CreateFolderPathCompletedEventArgs |
CreateFolderPathResponseType |
CreateFolderPathType |
CreateFolderResponseType |
CreateFolderType |
CreateItemCompletedEventArgs |
CreateItemResponseType |
CreateItemType |
CreateManagedFolderCompletedEventArgs |
CreateManagedFolderRequestType |
CreateManagedFolderResponseType |
CreateRuleOperationType |
CreateUMCallDataRecordResponseMessageType |
CreateUMCallDataRecordType |
CreateUMPromptResponseMessageType |
CreateUMPromptType |
CreateUserConfigurationCompletedEventArgs |
CreateUserConfigurationResponseType |
CreateUserConfigurationType |
DailyRecurrencePatternType |
DailyRegeneratingPatternType |
DateTimePrecisionType |
DeclineItemType |
DelegatePermissionsType |
DelegateUserResponseMessageType |
DelegateUserType |
DeleteAttachmentCompletedEventArgs |
DeleteAttachmentResponseMessageType |
DeleteAttachmentResponseType |
DeleteAttachmentType |
DeletedOccurrenceInfoType |
DeletedOccurrenceStateDefinitionType |
DeleteFolderCompletedEventArgs |
DeleteFolderFieldType |
DeleteFolderResponseType |
DeleteFolderType |
DeleteFromFolderStateDefinitionType |
DeleteItemCompletedEventArgs |
DeleteItemFieldType |
DeleteItemResponseType |
DeleteItemType |
DeleteRuleOperationType |
DeleteUMPromptsResponseMessageType |
DeleteUMPromptsType |
DeleteUserConfigurationCompletedEventArgs |
DeleteUserConfigurationResponseType |
DeleteUserConfigurationType |
DirectoryEntryType |
DisableAppCompletedEventArgs |
DisableAppResponseType |
DisableAppType |
DisconnectPhoneCallCompletedEventArgs |
DisconnectPhoneCallResponseMessageType |
DisconnectPhoneCallType |
DiscoverySearchConfigurationType |
DistinguishedFolderIdType |
DistinguishedGroupByType |
DistributionListType |
Duration |
EffectiveRightsType |
EmailAddress |
EmailAddressAttributedValueType |
EmailAddressDictionaryEntryType |
EmailAddressEntityType |
EmailAddressType |
EmailUserType |
EmptyFolderCompletedEventArgs |
EmptyFolderResponseType |
EmptyFolderType |
EncryptedSharedFolderDataType |
EndDateRecurrenceRangeType |
EnhancedLocationType |
EntityExtractionResultType |
EntityType |
ExchangeImpersonationType |
ExchangeServiceBinding |
ExcludesType |
ExcludesValueType |
ExistsType |
ExpandDLCompletedEventArgs |
ExpandDLResponseMessageType |
ExpandDLResponseType |
ExpandDLType |
ExportItemsCompletedEventArgs |
ExportItemsResponseMessageType |
ExportItemsResponseType |
ExportItemsType |
ExtendedPropertyAttributedValueType |
ExtendedPropertyType |
FailedSearchMailboxType |
FieldOrderType |
FieldURIOrConstantType |
FileAttachmentType |
FindConversationCompletedEventArgs |
FindConversationResponseMessageType |
FindConversationType |
FindFolderCompletedEventArgs |
FindFolderParentType |
FindFolderResponseMessageType |
FindFolderResponseType |
FindFolderType |
FindItemCompletedEventArgs |
FindItemParentType |
FindItemResponseMessageType |
FindItemResponseType |
FindItemType |
FindMailboxStatisticsByKeywordsResponseMessageType |
FindMailboxStatisticsByKeywordsResponseType |
FindMailboxStatisticsByKeywordsType |
FindMessageTrackingReportCompletedEventArgs |
FindMessageTrackingReportRequestType |
FindMessageTrackingReportResponseMessageType |
FindMessageTrackingSearchResultType |
FindPeopleCompletedEventArgs |
FindPeopleResponseMessageType |
FindPeopleType |
FlagType |
FolderChangeDescriptionType |
FolderChangeType |
FolderIdType |
FolderInfoResponseMessageType |
FolderResponseShapeType |
FolderType |
ForwardItemType |
FractionalPageViewType |
FreeBusyResponseType |
FreeBusyView |
FreeBusyViewOptionsType |
GetAppManifestsCompletedEventArgs |
GetAppManifestsResponseType |
GetAppManifestsType |
GetAppMarketplaceUrlCompletedEventArgs |
GetAppMarketplaceUrlResponseMessageType |
GetAppMarketplaceUrlType |
GetAttachmentCompletedEventArgs |
GetAttachmentResponseType |
GetAttachmentType |
GetClientAccessTokenCompletedEventArgs |
GetClientAccessTokenResponseMessageType |
GetClientAccessTokenResponseType |
GetClientAccessTokenType |
GetClientExtensionType |
GetClientExtensionUserParametersType |
GetClientIntentResponseMessageType |
GetClientIntentType |
GetConversationItemsCompletedEventArgs |
GetConversationItemsResponseMessageType |
GetConversationItemsResponseType |
GetConversationItemsType |
GetDelegateCompletedEventArgs |
GetDelegateResponseMessageType |
GetDelegateType |
GetDiscoverySearchConfigurationCompletedEventArgs |
GetDiscoverySearchConfigurationResponseMessageType |
GetDiscoverySearchConfigurationType |
GetEventsCompletedEventArgs |
GetEventsResponseMessageType |
GetEventsResponseType |
GetEventsType |
GetFolderCompletedEventArgs |
GetFolderResponseType |
GetFolderType |
GetHoldOnMailboxesCompletedEventArgs |
GetHoldOnMailboxesResponseMessageType |
GetHoldOnMailboxesType |
GetImItemListCompletedEventArgs |
GetImItemListResponseMessageType |
GetImItemListType |
GetImItemsCompletedEventArgs |
GetImItemsResponseMessageType |
GetImItemsType |
GetInboxRulesCompletedEventArgs |
GetInboxRulesRequestType |
GetInboxRulesResponseType |
GetItemCompletedEventArgs |
GetItemResponseType |
GetItemType |
GetMailTipsCompletedEventArgs |
GetMailTipsResponseMessageType |
GetMailTipsType |
GetMessageTrackingReportCompletedEventArgs |
GetMessageTrackingReportRequestType |
GetMessageTrackingReportResponseMessageType |
GetNonIndexableItemDetailsCompletedEventArgs |
GetNonIndexableItemDetailsResponseMessageType |
GetNonIndexableItemDetailsType |
GetNonIndexableItemStatisticsCompletedEventArgs |
GetNonIndexableItemStatisticsResponseMessageType |
GetNonIndexableItemStatisticsType |
GetPasswordExpirationDateCompletedEventArgs |
GetPasswordExpirationDateResponseMessageType |
GetPasswordExpirationDateType |
GetPersonaCompletedEventArgs |
GetPersonaResponseMessageType |
GetPersonaType |
GetPhoneCallInformationCompletedEventArgs |
GetPhoneCallInformationResponseMessageType |
GetPhoneCallInformationType |
GetRemindersResponseMessageType |
GetRemindersType |
GetRoomListsCompletedEventArgs |
GetRoomListsResponseMessageType |
GetRoomListsType |
GetRoomsCompletedEventArgs |
GetRoomsResponseMessageType |
GetRoomsType |
GetSearchableMailboxesCompletedEventArgs |
GetSearchableMailboxesResponseMessageType |
GetSearchableMailboxesType |
GetServerTimeZonesCompletedEventArgs |
GetServerTimeZonesResponseMessageType |
GetServerTimeZonesResponseType |
GetServerTimeZonesType |
GetServiceConfigurationCompletedEventArgs |
GetServiceConfigurationResponseMessageType |
GetServiceConfigurationType |
GetSharingFolderCompletedEventArgs |
GetSharingFolderResponseMessageType |
GetSharingFolderType |
GetSharingMetadataCompletedEventArgs |
GetSharingMetadataResponseMessageType |
GetSharingMetadataType |
GetStreamingEventsCompletedEventArgs |
GetStreamingEventsResponseMessageType |
GetStreamingEventsResponseType |
GetStreamingEventsType |
GetUMCallDataRecordsResponseMessageType |
GetUMCallDataRecordsType |
GetUMCallSummaryResponseMessageType |
GetUMCallSummaryType |
GetUMPinResponseMessageType |
GetUMPinType |
GetUMPromptNamesResponseMessageType |
GetUMPromptNamesType |
GetUMPromptResponseMessageType |
GetUMPromptType |
GetUMSubscriberCallAnsweringDataResponseMessageType |
GetUMSubscriberCallAnsweringDataType |
GetUserAvailabilityCompletedEventArgs |
GetUserAvailabilityRequestType |
GetUserAvailabilityResponseType |
GetUserConfigurationCompletedEventArgs |
GetUserConfigurationResponseMessageType |
GetUserConfigurationResponseType |
GetUserConfigurationType |
GetUserOofSettingsCompletedEventArgs |
GetUserOofSettingsRequest |
GetUserOofSettingsResponse |
GetUserPhotoCompletedEventArgs |
GetUserPhotoResponseMessageType |
GetUserPhotoResponseType |
GetUserPhotoType |
GetUserRetentionPolicyTagsCompletedEventArgs |
GetUserRetentionPolicyTagsResponseMessageType |
GetUserRetentionPolicyTagsType |
GroupAttendeeConflictData |
GroupByType |
GroupedItemsType |
HighlightTermType |
ImAddressDictionaryEntryType |
ImGroupType |
ImItemListType |
IndexedPageViewType |
IndividualAttendeeConflictData |
InitUMMailboxResponseMessageType |
InitUMMailboxType |
InstallAppCompletedEventArgs |
InstallAppResponseType |
InstallAppType |
InternetHeaderType |
IntervalRecurrencePatternBaseType |
InvalidRecipientType |
IsEqualToType |
IsGreaterThanOrEqualToType |
IsGreaterThanType |
IsLessThanOrEqualToType |
IsLessThanType |
IsNotEqualToType |
ItemAttachmentType |
ItemChangeDescriptionType |
ItemChangeType |
ItemIdType |
ItemInfoResponseMessageType |
ItemResponseShapeType |
ItemType |
KeywordStatisticsSearchResultType |
LocationBasedStateDefinitionType |
MailboxCultureType |
MailboxData |
MailboxHoldResultType |
MailboxHoldStatusType |
MailboxQueryType |
MailboxSearchScopeType |
MailboxStatisticsItemType |
MailboxStatisticsSearchResultType |
MailTips |
MailTipsResponseMessageType |
MailTipsServiceConfiguration |
ManagedFolderInformationType |
ManagementRoleType |
MarkAllItemsAsReadCompletedEventArgs |
MarkAllItemsAsReadResponseType |
MarkAllItemsAsReadType |
MarkAsJunkCompletedEventArgs |
MarkAsJunkResponseMessageType |
MarkAsJunkResponseType |
MarkAsJunkType |
MeetingCancellationMessageType |
MeetingMessageType |
MeetingRequestMessageType |
MeetingResponseMessageType |
MeetingSuggestionType |
MemberType |
MessageTrackingReportType |
MessageType |
MimeContentType |
ModifiedEventType |
MonthlyRegeneratingPatternType |
MovedCopiedEventType |
MoveFolderCompletedEventArgs |
MoveFolderResponseType |
MoveFolderType |
MoveItemCompletedEventArgs |
MoveItemResponseType |
MoveItemType |
MultipleOperandBooleanExpressionType |
NoEndRecurrenceRangeType |
NonEmptyArrayOfAllItemsType |
NonEmptyArrayOfExtendedPropertyType |
NonEmptyArrayOfPropertyValuesType |
NonEmptyStateDefinitionType |
NonIndexableItemDetailResultType |
NonIndexableItemDetailType |
NonIndexableItemStatisticType |
NotificationType |
NotType |
NumberedRecurrenceRangeType |
OccurrenceInfoType |
OccurrenceItemIdType |
OccurrencesRangeType |
OnlineMeetingSettingsType |
OrType |
OutOfOfficeMailTip |
PathToExceptionFieldType |
PathToExtendedFieldType |
PathToIndexedFieldType |
PathToUnindexedFieldType |
PerformReminderActionResponseMessageType |
PerformReminderActionType |
PeriodType |
PermissionSetType |
PermissionType |
PersonaAttributionType |
PersonaPhoneNumberType |
PersonaPostalAddressType |
PersonaResponseShapeType |
PersonaType |
PhoneCallIdType |
PhoneCallInformationType |
PhoneEntityType |
PhoneNumberAttributedValueType |
PhoneNumberDictionaryEntryType |
PhoneType |
PhysicalAddressDictionaryEntryType |
PinInfoType |
PlayOnPhoneCompletedEventArgs |
PlayOnPhoneResponseMessageType |
PlayOnPhoneType |
PolicyNudgeRulesServiceConfiguration |
PostalAddressAttributedValueType |
PostItemType |
PostReplyItemBaseType |
PostReplyItemType |
PreviewItemMailboxType |
PreviewItemResponseShapeType |
ProtectionRuleActionType |
ProtectionRuleAndType |
ProtectionRuleArgumentType |
ProtectionRuleConditionType |
ProtectionRuleRecipientIsType |
ProtectionRuleSenderDepartmentsType |
ProtectionRulesServiceConfiguration |
ProtectionRuleType |
PullSubscriptionRequestType |
PushSubscriptionRequestType |
QueryStringType |
RecipientTrackingEventType |
RecognitionIdType |
RecognitionResultType |
RecurrencePatternBaseType |
RecurrenceRangeBaseType |
RecurrenceType |
RecurringDateTransitionType |
RecurringDayTransitionType |
RecurringMasterItemIdRangesType |
RecurringMasterItemIdType |
RecurringTimeTransitionType |
ReferenceItemResponseType |
RefreshSharingFolderCompletedEventArgs |
RefreshSharingFolderResponseMessageType |
RefreshSharingFolderType |
RegeneratingPatternBaseType |
RelativeMonthlyRecurrencePatternType |
RelativeYearlyRecurrencePatternType |
ReminderItemActionType |
ReminderType |
RemoveContactFromImListCompletedEventArgs |
RemoveContactFromImListResponseMessageType |
RemoveContactFromImListType |
RemoveDelegateCompletedEventArgs |
RemoveDelegateResponseMessageType |
RemoveDelegateType |
RemoveDistributionGroupFromImListCompletedEventArgs |
RemoveDistributionGroupFromImListResponseMessageType |
RemoveDistributionGroupFromImListType |
RemoveImContactFromGroupCompletedEventArgs |
RemoveImContactFromGroupResponseMessageType |
RemoveImContactFromGroupType |
RemoveImGroupCompletedEventArgs |
RemoveImGroupResponseMessageType |
RemoveImGroupType |
RemoveItemType |
ReplyAllToItemType |
ReplyBody |
ReplyToItemType |
RequestAttachmentIdType |
RequestServerVersion |
ResetUMMailboxResponseMessageType |
ResetUMMailboxType |
ResolutionType |
ResolveNamesCompletedEventArgs |
ResolveNamesResponseMessageType |
ResolveNamesResponseType |
ResolveNamesType |
ResponseMessageType |
ResponseMessageTypeMessageXml |
ResponseObjectCoreType |
ResponseObjectType |
RestrictionType |
RetentionPolicyTagType |
RetentionTagType |
RightsManagementLicenseDataType |
RoomType |
RootItemIdType |
RuleActionsType |
RuleOperationErrorType |
RuleOperationType |
RulePredicateDateRangeType |
RulePredicateSizeRangeType |
RulePredicatesType |
RuleType |
RuleValidationErrorType |
SaveUMPinResponseMessageType |
SaveUMPinType |
SearchableMailboxType |
SearchExpressionType |
SearchFolderType |
SearchMailboxesCompletedEventArgs |
SearchMailboxesResponseMessageType |
SearchMailboxesResponseType |
SearchMailboxesResultType |
SearchMailboxesType |
SearchParametersType |
SearchPreviewItemType |
SearchRefinerItemType |
SeekToConditionPageViewType |
SendItemCompletedEventArgs |
SendItemResponseType |
SendItemType |
SendNotificationResponseMessageType |
SendNotificationResponseType |
SerializableTimeZone |
SerializableTimeZoneTime |
ServerVersionInfo |
ServiceConfiguration |
ServiceConfigurationResponseMessageType |
SetClientExtensionActionType |
SetClientExtensionResponseType |
SetClientExtensionType |
SetFolderFieldType |
SetHoldOnMailboxesCompletedEventArgs |
SetHoldOnMailboxesResponseMessageType |
SetHoldOnMailboxesType |
SetImGroupCompletedEventArgs |
SetImGroupResponseMessageType |
SetImGroupType |
SetImListMigrationCompletedCompletedEventArgs |
SetImListMigrationCompletedResponseMessageType |
SetImListMigrationCompletedType |
SetItemFieldType |
SetRuleOperationType |
SetTeamMailboxCompletedEventArgs |
SetTeamMailboxRequestType |
SetTeamMailboxResponseMessageType |
SetUserOofSettingsCompletedEventArgs |
SetUserOofSettingsRequest |
SetUserOofSettingsResponse |
SingleRecipientType |
SmartResponseBaseType |
SmartResponseType |
SmtpDomain |
StartFindInGALSpeechRecognitionResponseMessageType |
StartFindInGALSpeechRecognitionType |
StreamingSubscriptionRequestType |
StringArrayAttributedValueType |
StringAttributedValueType |
SubscribeCompletedEventArgs |
SubscribeResponseMessageType |
SubscribeResponseType |
SubscribeType |
Suggestion |
SuggestionDayResult |
SuggestionsResponseType |
SuggestionsViewOptionsType |
SuppressReadReceiptType |
SyncFolderHierarchyChangesType |
SyncFolderHierarchyCompletedEventArgs |
SyncFolderHierarchyCreateOrUpdateType |
SyncFolderHierarchyDeleteType |
SyncFolderHierarchyResponseMessageType |
SyncFolderHierarchyResponseType |
SyncFolderHierarchyType |
SyncFolderItemsChangesType |
SyncFolderItemsCompletedEventArgs |
SyncFolderItemsCreateOrUpdateType |
SyncFolderItemsDeleteType |
SyncFolderItemsReadFlagType |
SyncFolderItemsResponseMessageType |
SyncFolderItemsResponseType |
SyncFolderItemsType |
TargetFolderIdType |
TaskRecurrenceType |
TasksFolderType |
TaskSuggestionType |
TaskType |
TentativelyAcceptItemType |
TimeChangeType |
TimeZoneContextType |
TimeZoneDefinitionType |
TimeZoneType |
TooBigGroupAttendeeConflictData |
TrackingPropertyType |
TransitionTargetType |
TransitionType |
TwoOperandExpressionType |
UMReportAudioMetricsAverageCountersType |
UMReportRawCountersType |
UnifiedMessageServiceConfiguration |
UninstallAppCompletedEventArgs |
UninstallAppResponseType |
UninstallAppType |
UnknownAttendeeConflictData |
UnpinTeamMailboxCompletedEventArgs |
UnpinTeamMailboxRequestType |
UnpinTeamMailboxResponseMessageType |
UnsubscribeCompletedEventArgs |
UnsubscribeResponseType |
UnsubscribeType |
UpdateDelegateCompletedEventArgs |
UpdateDelegateResponseMessageType |
UpdateDelegateType |
UpdateFolderCompletedEventArgs |
UpdateFolderResponseType |
UpdateFolderType |
UpdateInboxRulesCompletedEventArgs |
UpdateInboxRulesRequestType |
UpdateInboxRulesResponseType |
UpdateItemCompletedEventArgs |
UpdateItemInRecoverableItemsCompletedEventArgs |
UpdateItemInRecoverableItemsResponseMessageType |
UpdateItemInRecoverableItemsResponseType |
UpdateItemInRecoverableItemsType |
UpdateItemResponseMessageType |
UpdateItemResponseType |
UpdateItemType |
UpdateUserConfigurationCompletedEventArgs |
UpdateUserConfigurationResponseType |
UpdateUserConfigurationType |
UploadItemsCompletedEventArgs |
UploadItemsResponseMessageType |
UploadItemsResponseType |
UploadItemsType |
UploadItemType |
UrlEntityType |
UserConfigurationDictionaryEntryType |
UserConfigurationDictionaryObjectType |
UserConfigurationNameType |
UserConfigurationType |
UserIdType |
UserMailboxType |
UserOofSettings |
ValidateUMPinResponseMessageType |
ValidateUMPinType |
WeeklyRecurrencePatternType |
WeeklyRegeneratingPatternType |
WellKnownResponseObjectType |
WorkingHours |
WorkingPeriod |
YearlyRegeneratingPatternType |

Delegates

Delegate | Description
AddDelegateCompletedEventHandler |
AddDistributionGroupToImListCompletedEventHandler |
AddImContactToGroupCompletedEventHandler |
AddImGroupCompletedEventHandler |
AddNewImContactToGroupCompletedEventHandler |
AddNewTelUriContactToGroupCompletedEventHandler |
ApplyConversationActionCompletedEventHandler |
ArchiveItemCompletedEventHandler |
ConvertIdCompletedEventHandler |
CopyFolderCompletedEventHandler |
CopyItemCompletedEventHandler |
CreateAttachmentCompletedEventHandler |
CreateFolderCompletedEventHandler |
CreateFolderPathCompletedEventHandler |
CreateItemCompletedEventHandler |
CreateManagedFolderCompletedEventHandler |
CreateUserConfigurationCompletedEventHandler |
DeleteAttachmentCompletedEventHandler |
DeleteFolderCompletedEventHandler |
DeleteItemCompletedEventHandler |
DeleteUserConfigurationCompletedEventHandler |
DisableAppCompletedEventHandler |
DisconnectPhoneCallCompletedEventHandler |
EmptyFolderCompletedEventHandler |
ExpandDLCompletedEventHandler |
ExportItemsCompletedEventHandler |
FindConversationCompletedEventHandler |
FindFolderCompletedEventHandler |
FindItemCompletedEventHandler |
FindMessageTrackingReportCompletedEventHandler |
FindPeopleCompletedEventHandler |
GetAppManifestsCompletedEventHandler |
GetAppMarketplaceUrlCompletedEventHandler |
GetAttachmentCompletedEventHandler |
GetClientAccessTokenCompletedEventHandler |
GetConversationItemsCompletedEventHandler |
GetDelegateCompletedEventHandler |
GetDiscoverySearchConfigurationCompletedEventHandler |
GetEventsCompletedEventHandler |
GetFolderCompletedEventHandler |
GetHoldOnMailboxesCompletedEventHandler |
GetImItemListCompletedEventHandler |
GetImItemsCompletedEventHandler |
GetInboxRulesCompletedEventHandler |
GetItemCompletedEventHandler |
GetMailTipsCompletedEventHandler |
GetMessageTrackingReportCompletedEventHandler |
GetNonIndexableItemDetailsCompletedEventHandler |
GetNonIndexableItemStatisticsCompletedEventHandler |
GetPasswordExpirationDateCompletedEventHandler |
GetPersonaCompletedEventHandler |
GetPhoneCallInformationCompletedEventHandler |
GetRoomListsCompletedEventHandler |
GetRoomsCompletedEventHandler |
GetSearchableMailboxesCompletedEventHandler |
GetServerTimeZonesCompletedEventHandler |
GetServiceConfigurationCompletedEventHandler |
GetSharingFolderCompletedEventHandler |
GetSharingMetadataCompletedEventHandler |
GetStreamingEventsCompletedEventHandler |
GetUserAvailabilityCompletedEventHandler |
GetUserConfigurationCompletedEventHandler |
GetUserOofSettingsCompletedEventHandler |
GetUserPhotoCompletedEventHandler |
GetUserRetentionPolicyTagsCompletedEventHandler |
InstallAppCompletedEventHandler |
MarkAllItemsAsReadCompletedEventHandler |
MarkAsJunkCompletedEventHandler |
MoveFolderCompletedEventHandler |
MoveItemCompletedEventHandler |
PlayOnPhoneCompletedEventHandler |
RefreshSharingFolderCompletedEventHandler |
RemoveContactFromImListCompletedEventHandler |
RemoveDelegateCompletedEventHandler |
RemoveDistributionGroupFromImListCompletedEventHandler |
RemoveImContactFromGroupCompletedEventHandler |
RemoveImGroupCompletedEventHandler |
ResolveNamesCompletedEventHandler |
SearchMailboxesCompletedEventHandler |
SendItemCompletedEventHandler |
SetHoldOnMailboxesCompletedEventHandler |
SetImGroupCompletedEventHandler |
SetImListMigrationCompletedCompletedEventHandler |
SetTeamMailboxCompletedEventHandler |
SetUserOofSettingsCompletedEventHandler |
SubscribeCompletedEventHandler |
SyncFolderHierarchyCompletedEventHandler |
SyncFolderItemsCompletedEventHandler |
UninstallAppCompletedEventHandler |
UnpinTeamMailboxCompletedEventHandler |
UnsubscribeCompletedEventHandler |
UpdateDelegateCompletedEventHandler |
UpdateFolderCompletedEventHandler |
UpdateInboxRulesCompletedEventHandler |
UpdateItemCompletedEventHandler |
UpdateItemInRecoverableItemsCompletedEventHandler |
UpdateUserConfigurationCompletedEventHandler |
UploadItemsCompletedEventHandler |

Enumerations

Enumeration | Description
AffectedTaskOccurrencesType |
AggregateType |
BodyTypeResponseType |
BodyTypeType |
CalendarItemCreateOrDeleteOperationType |
CalendarItemTypeType |
CalendarItemUpdateOperationType |
CalendarPermissionLevelType |
CalendarPermissionReadAccessType |
ClientAccessTokenTypeType |
ClientExtensionProvidedToType |
ClientExtensionScopeType |
ClientExtensionTypeType |
ClientIntentMeetingInquiryActionType |
ConflictResolutionType |
ConnectionFailureCauseType |
ConnectionStatusType |
ContactSourceType |
ContainmentComparisonType |
ContainmentModeType |
ConversationActionTypeType |
ConversationNodeSortOrder |
ConversationQueryTraversalType |
CreateActionType |
DayOfWeekIndexType |
DayOfWeekType |
DefaultShapeNamesType |
DelegateFolderPermissionLevelType |
DeliverMeetingRequestsType |
DictionaryURIType |
DisableReasonType |
DisposalType |
DistinguishedFolderIdNameType |
DistinguishedPropertySetType |
DistinguishedUserType |
ElcFolderType |
EmailAddressKeyType |
EmailPositionType |
ExceptionPropertyURIType |
ExchangeVersionType |
ExternalAudience |
FileAsMappingType |
FlaggedForActionType |
FlagStatusType |
FolderQueryTraversalType |
FreeBusyViewType |
GetRemindersTypeReminderType |
HoldActionType |
HoldStatusType |
IconIndexType |
IdFormatType |
ImAddressKeyType |
ImportanceChoicesType |
IndexBasePointType |
InvalidRecipientResponseCodeType |
ItemChoiceType |
ItemChoiceType1 |
ItemIndexErrorType |
ItemQueryTraversalType |
ItemsChoiceType |
ItemsChoiceType1 |
ItemsChoiceType2 |
ItemsChoiceType3 |
ItemsChoiceType4 |
LegacyFreeBusyType |
LobbyBypassType |
LocationSourceType |
MailboxSearchLocationType |
MailboxTypeType |
MailTipTypes |
MapiPropertyTypeType |
MeetingAttendeeType |
MeetingRequestTypeType |
MemberStatusType |
MessageDispositionType |
MessageTrackingReportTemplateType |
MonthNamesType |
NotificationEventTypeType |
OnlineMeetingAccessLevelType |
OofState |
PermissionActionType |
PermissionLevelType |
PermissionReadAccessType |
PhoneCallStateType |
PhoneNumberKeyType |
PhysicalAddressIndexType |
PhysicalAddressKeyType |
PredictedMessageActionType |
PresentersType |
PreviewItemBaseShapeType |
ProtectionRuleActionKindType |
ReminderActionType |
ReminderGroupType |
ResolveNamesSearchScopeType |
ResponseClassType |
ResponseCodeType |
ResponseTypeType |
RetentionActionType |
RetentionType |
RuleFieldURIType |
RuleValidationErrorCodeType |
SearchFolderTraversalType |
SearchItemKindType |
SearchPageDirectionType |
SearchResultType |
SensitivityChoicesType |
ServiceConfigurationType |
SetClientExtensionActionIdType |
SharingDataType |
SortDirectionType |
StandardGroupByType |
SuggestionQuality |
SyncFolderItemsScopeType |
TaskDelegateStateType |
TaskStatusType |
TeamMailboxLifecycleStateType |
TransitionTargetKindType |
UMCDRFilterByType |
UMCDRGroupByType |
UMMailboxTranscriptionEnabledSetting |
UnindexedFieldURIType |
UserConfigurationDictionaryObjectTypesType |
UserConfigurationPropertyType |
UserPhotoSizeType |
ViewFilterType |


AbsoluteDateTransitionType Class

For a list of all members of this type, see AbsoluteDateTransitionType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.TransitionType
Aspose.Email.Exchange.Schema.Exchange_2013.AbsoluteDateTransitionType

public class AbsoluteDateTransitionType : TransitionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AbsoluteDateTransitionType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AbsoluteDateTransitionType Members

AbsoluteDateTransitionType overview

Public Instance Constructors

AbsoluteDateTransitionType Constructor Initializes a new instance of the AbsoluteDateTransitionType class.

Public Instance Properties

DateTime
To (inherited from TransitionType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AbsoluteDateTransitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AbsoluteDateTransitionType Constructor

Initializes a new instance of the AbsoluteDateTransitionType class.

public AbsoluteDateTransitionType();

See Also

AbsoluteDateTransitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AbsoluteDateTransitionType Properties

The properties of the AbsoluteDateTransitionType class are listed below. For a complete list of AbsoluteDateTransitionType class members, see the AbsoluteDateTransitionType Members topic.

Public Instance Properties

DateTime
To (inherited from TransitionType)

See Also

AbsoluteDateTransitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DateTime Property

Aspose.Email

AbsoluteDateTransitionType.DateTime Property

public DateTime DateTime {get; set;}

Remarks

See Also

AbsoluteDateTransitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AbsoluteMonthlyRecurrencePatternType Class

For a list of all members of this type, see AbsoluteMonthlyRecurrencePatternType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.RecurrencePatternBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.IntervalRecurrencePatternBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.AbsoluteMonthlyRecurrencePatternType

public class AbsoluteMonthlyRecurrencePatternType : IntervalRecurrencePatternBaseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AbsoluteMonthlyRecurrencePatternType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AbsoluteMonthlyRecurrencePatternType Members

AbsoluteMonthlyRecurrencePatternType overview

Public Instance Constructors

AbsoluteMonthlyRecurrencePatternType Constructor Initializes a new instance of the AbsoluteMonthlyRecurrencePatternType class.

Public Instance Properties

DayOfMonth
Interval (inherited from IntervalRecurrencePatternBaseType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AbsoluteMonthlyRecurrencePatternType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AbsoluteMonthlyRecurrencePatternType Constructor

Initializes a new instance of the AbsoluteMonthlyRecurrencePatternType class.

public AbsoluteMonthlyRecurrencePatternType();

See Also

AbsoluteMonthlyRecurrencePatternType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AbsoluteMonthlyRecurrencePatternType Properties

The properties of the AbsoluteMonthlyRecurrencePatternType class are listed below. For a complete list of AbsoluteMonthlyRecurrencePatternType class members, see the AbsoluteMonthlyRecurrencePatternType Members topic.

Public Instance Properties

DayOfMonth
Interval (inherited from IntervalRecurrencePatternBaseType)

See Also

AbsoluteMonthlyRecurrencePatternType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DayOfMonth Property

Aspose.Email

AbsoluteMonthlyRecurrencePatternType.DayOfMonth Property

public int DayOfMonth {get; set;}

Remarks

See Also

AbsoluteMonthlyRecurrencePatternType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AbsoluteYearlyRecurrencePatternType Class

For a list of all members of this type, see AbsoluteYearlyRecurrencePatternType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.RecurrencePatternBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.AbsoluteYearlyRecurrencePatternType

public class AbsoluteYearlyRecurrencePatternType : RecurrencePatternBaseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AbsoluteYearlyRecurrencePatternType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AbsoluteYearlyRecurrencePatternType Members

AbsoluteYearlyRecurrencePatternType overview

Public Instance Constructors

AbsoluteYearlyRecurrencePatternType Constructor Initializes a new instance of the AbsoluteYearlyRecurrencePatternType class.

Public Instance Properties

DayOfMonth
Month

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AbsoluteYearlyRecurrencePatternType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AbsoluteYearlyRecurrencePatternType Constructor

Initializes a new instance of the AbsoluteYearlyRecurrencePatternType class.

public AbsoluteYearlyRecurrencePatternType();

See Also

AbsoluteYearlyRecurrencePatternType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AbsoluteYearlyRecurrencePatternType Properties

The properties of the AbsoluteYearlyRecurrencePatternType class are listed below. For a complete list of AbsoluteYearlyRecurrencePatternType class members, see the AbsoluteYearlyRecurrencePatternType Members topic.

Public Instance Properties

DayOfMonth
Month

See Also

AbsoluteYearlyRecurrencePatternType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DayOfMonth Property

Aspose.Email

AbsoluteYearlyRecurrencePatternType.DayOfMonth Property

public int DayOfMonth {get; set;}

Remarks

See Also

AbsoluteYearlyRecurrencePatternType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Month Property

Aspose.Email

AbsoluteYearlyRecurrencePatternType.Month Property

public MonthNamesType Month {get; set;}

Remarks

See Also

AbsoluteYearlyRecurrencePatternType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AcceptItemType Class

For a list of all members of this type, see AcceptItemType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ItemType
Aspose.Email.Exchange.Schema.Exchange_2013.MessageType
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseObjectCoreType
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseObjectType
Aspose.Email.Exchange.Schema.Exchange_2013.WellKnownResponseObjectType
Aspose.Email.Exchange.Schema.Exchange_2013.AcceptItemType

public class AcceptItemType : WellKnownResponseObjectType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AcceptItemType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AcceptItemType Members

AcceptItemType overview

Public Instance Constructors

AcceptItemType Constructor Initializes a new instance of the AcceptItemType class.

Public Instance Properties

ArchiveTag (inherited from ItemType)
Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
BlockStatus (inherited from ItemType)
BlockStatusSpecified (inherited from ItemType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
EntityExtractionResult (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
Flag (inherited from ItemType)
From (inherited from MessageType)
GroupingAction (inherited from ItemType)
GroupingActionSpecified (inherited from ItemType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBlockedImages (inherited from ItemType)
HasBlockedImagesSpecified (inherited from ItemType)
IconIndex (inherited from ItemType)
IconIndexSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InstanceKey (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
NextPredictedAction (inherited from ItemType)
NextPredictedActionSpecified (inherited from ItemType)
NormalizedBody (inherited from ItemType)
ObjectName (inherited from ResponseObjectType)
ParentFolderId (inherited from ItemType)
PolicyTag (inherited from ItemType)
Preview (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
ReferenceItemId (inherited from ResponseObjectCoreType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReminderNextTime (inherited from ItemType)
ReminderNextTimeSpecified (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
RetentionDate (inherited from ItemType)
RetentionDateSpecified (inherited from ItemType)
RightsManagementLicenseData (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
StoreEntryId (inherited from ItemType)
Subject (inherited from ItemType)
TextBody (inherited from ItemType)
ToRecipients (inherited from MessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AcceptItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AcceptItemType Constructor

Initializes a new instance of the AcceptItemType class.

public AcceptItemType();

See Also

AcceptItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AcceptSharingInvitationType Class

For a list of all members of this type, see AcceptSharingInvitationType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ItemType
Aspose.Email.Exchange.Schema.Exchange_2013.MessageType
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseObjectCoreType
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseObjectType
Aspose.Email.Exchange.Schema.Exchange_2013.ReferenceItemResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.AcceptSharingInvitationType

public class AcceptSharingInvitationType : ReferenceItemResponseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AcceptSharingInvitationType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AcceptSharingInvitationType Members

AcceptSharingInvitationType overview

Public Instance Constructors

AcceptSharingInvitationType Constructor Initializes a new instance of the AcceptSharingInvitationType class.

Public Instance Properties

ArchiveTag (inherited from ItemType)
Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
BlockStatus (inherited from ItemType)
BlockStatusSpecified (inherited from ItemType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
EntityExtractionResult (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
Flag (inherited from ItemType)
From (inherited from MessageType)
GroupingAction (inherited from ItemType)
GroupingActionSpecified (inherited from ItemType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBlockedImages (inherited from ItemType)
HasBlockedImagesSpecified (inherited from ItemType)
IconIndex (inherited from ItemType)
IconIndexSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InstanceKey (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
NextPredictedAction (inherited from ItemType)
NextPredictedActionSpecified (inherited from ItemType)
NormalizedBody (inherited from ItemType)
ObjectName (inherited from ResponseObjectType)
ParentFolderId (inherited from ItemType)
PolicyTag (inherited from ItemType)
Preview (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
ReferenceItemId (inherited from ResponseObjectCoreType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReminderNextTime (inherited from ItemType)
ReminderNextTimeSpecified (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
RetentionDate (inherited from ItemType)
RetentionDateSpecified (inherited from ItemType)
RightsManagementLicenseData (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
StoreEntryId (inherited from ItemType)
Subject (inherited from ItemType)
TextBody (inherited from ItemType)
ToRecipients (inherited from MessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AcceptSharingInvitationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AcceptSharingInvitationType Constructor

Initializes a new instance of the AcceptSharingInvitationType class.

public AcceptSharingInvitationType();

See Also

AcceptSharingInvitationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddDelegateCompletedEventArgs Class

For a list of all members of this type, see AddDelegateCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.AddDelegateCompletedEventArgs

public class AddDelegateCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AddDelegateCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddDelegateCompletedEventArgs Members

AddDelegateCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

AddDelegateCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddDelegateCompletedEventArgs Properties

The properties of the AddDelegateCompletedEventArgs class are listed below. For a complete list of AddDelegateCompletedEventArgs class members, see the AddDelegateCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

AddDelegateCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

AddDelegateCompletedEventArgs.Result Property

public AddDelegateResponseMessageType Result {get;}

Remarks

See Also

AddDelegateCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddDelegateCompletedEventHandler Delegate

public delegate void AddDelegateCompletedEventHandler(
object sender,
AddDelegateCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddDelegateResponseMessageType Class

For a list of all members of this type, see AddDelegateResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.BaseDelegateResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.AddDelegateResponseMessageType

public class AddDelegateResponseMessageType : BaseDelegateResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AddDelegateResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddDelegateResponseMessageType Members

AddDelegateResponseMessageType overview

Public Instance Constructors

AddDelegateResponseMessageType Constructor Initializes a new instance of the AddDelegateResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
ResponseMessages (inherited from BaseDelegateResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AddDelegateResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddDelegateResponseMessageType Constructor

Initializes a new instance of the AddDelegateResponseMessageType class.

public AddDelegateResponseMessageType();

See Also

AddDelegateResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddDelegateType Class

For a list of all members of this type, see AddDelegateType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.BaseDelegateType
Aspose.Email.Exchange.Schema.Exchange_2013.AddDelegateType

public class AddDelegateType : BaseDelegateType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AddDelegateType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddDelegateType Members

AddDelegateType overview

Public Instance Constructors

AddDelegateType Constructor Initializes a new instance of the AddDelegateType class.

Public Instance Properties

DelegateUsers
DeliverMeetingRequests
DeliverMeetingRequestsSpecified
Mailbox (inherited from BaseDelegateType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AddDelegateType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddDelegateType Constructor

Initializes a new instance of the AddDelegateType class.

public AddDelegateType();

See Also

AddDelegateType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddDelegateType Properties

The properties of the AddDelegateType class are listed below. For a complete list of AddDelegateType class members, see the AddDelegateType Members topic.

Public Instance Properties

DelegateUsers
DeliverMeetingRequests
DeliverMeetingRequestsSpecified
Mailbox (inherited from BaseDelegateType)

See Also

AddDelegateType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DelegateUsers Property

Aspose.Email

AddDelegateType.DelegateUsers Property

public DelegateUserType[] DelegateUsers {get; set;}

Remarks

See Also

AddDelegateType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeliverMeetingRequests Property

Aspose.Email

AddDelegateType.DeliverMeetingRequests Property

public DeliverMeetingRequestsType DeliverMeetingRequests {get; set;}

Remarks

See Also

AddDelegateType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeliverMeetingRequestsSpecified Property

Aspose.Email

AddDelegateType.DeliverMeetingRequestsSpecified Property

public bool DeliverMeetingRequestsSpecified {get; set;}

Remarks

See Also

AddDelegateType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddDistributionGroupToImListCompletedEventArgs Class

For a list of all members of this type, see AddDistributionGroupToImListCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.AddDistributionGroupToImListCompletedEventArgs

public class AddDistributionGroupToImListCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AddDistributionGroupToImListCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddDistributionGroupToImListCompletedEventArgs Members

AddDistributionGroupToImListCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

AddDistributionGroupToImListCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddDistributionGroupToImListCompletedEventArgs Properties

The properties of the AddDistributionGroupToImListCompletedEventArgs class are listed below. For a complete list of AddDistributionGroupToImListCompletedEventArgs class members, see the AddDistributionGroupToImListCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

AddDistributionGroupToImListCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

AddDistributionGroupToImListCompletedEventArgs.Result Property

public AddDistributionGroupToImListResponseMessageType Result {get;}

Remarks

See Also

AddDistributionGroupToImListCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddDistributionGroupToImListCompletedEventHandler Delegate

public delegate void AddDistributionGroupToImListCompletedEventHandler(
object sender,
AddDistributionGroupToImListCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddDistributionGroupToImListResponseMessageType Class

For a list of all members of this type, see AddDistributionGroupToImListResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.AddDistributionGroupToImListResponseMessageType

public class AddDistributionGroupToImListResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AddDistributionGroupToImListResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddDistributionGroupToImListResponseMessageType Members

AddDistributionGroupToImListResponseMessageType overview

Public Instance Constructors

AddDistributionGroupToImListResponseMessageType Constructor Initializes a new instance of the AddDistributionGroupToImListResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
ImGroup
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AddDistributionGroupToImListResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddDistributionGroupToImListResponseMessageType Constructor

Initializes a new instance of the AddDistributionGroupToImListResponseMessageType class.

public AddDistributionGroupToImListResponseMessageType();

See Also

AddDistributionGroupToImListResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddDistributionGroupToImListResponseMessageType Properties

The properties of the AddDistributionGroupToImListResponseMessageType class are listed below. For a complete list of AddDistributionGroupToImListResponseMessageType class members, see the AddDistributionGroupToImListResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
ImGroup
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

AddDistributionGroupToImListResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ImGroup Property

Aspose.Email

AddDistributionGroupToImListResponseMessageType.ImGroup Property

public ImGroupType ImGroup {get; set;}

Remarks

See Also

AddDistributionGroupToImListResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddDistributionGroupToImListType Class

For a list of all members of this type, see AddDistributionGroupToImListType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.AddDistributionGroupToImListType

public class AddDistributionGroupToImListType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AddDistributionGroupToImListType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddDistributionGroupToImListType Members

AddDistributionGroupToImListType overview

Public Instance Constructors

AddDistributionGroupToImListType Constructor Initializes a new instance of the AddDistributionGroupToImListType class.

Public Instance Properties

DisplayName
SmtpAddress

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AddDistributionGroupToImListType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddDistributionGroupToImListType Constructor

Initializes a new instance of the AddDistributionGroupToImListType class.

public AddDistributionGroupToImListType();

See Also

AddDistributionGroupToImListType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddDistributionGroupToImListType Properties

The properties of the AddDistributionGroupToImListType class are listed below. For a complete list of AddDistributionGroupToImListType class members, see the AddDistributionGroupToImListType Members topic.

Public Instance Properties

DisplayName
SmtpAddress

See Also

AddDistributionGroupToImListType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisplayName Property

Aspose.Email

AddDistributionGroupToImListType.DisplayName Property

public string DisplayName {get; set;}

Remarks

See Also

AddDistributionGroupToImListType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SmtpAddress Property

Aspose.Email

AddDistributionGroupToImListType.SmtpAddress Property

public string SmtpAddress {get; set;}

Remarks

See Also

AddDistributionGroupToImListType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddImContactToGroupCompletedEventArgs Class

For a list of all members of this type, see AddImContactToGroupCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.AddImContactToGroupCompletedEventArgs

public class AddImContactToGroupCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AddImContactToGroupCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddImContactToGroupCompletedEventArgs Members

AddImContactToGroupCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

AddImContactToGroupCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddImContactToGroupCompletedEventArgs Properties

The properties of the AddImContactToGroupCompletedEventArgs class are listed below. For a complete list of AddImContactToGroupCompletedEventArgs class members, see the AddImContactToGroupCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

AddImContactToGroupCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

AddImContactToGroupCompletedEventArgs.Result Property

public AddImContactToGroupResponseMessageType Result {get;}

Remarks

See Also

AddImContactToGroupCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddImContactToGroupCompletedEventHandler Delegate

public delegate void AddImContactToGroupCompletedEventHandler(
object sender,
AddImContactToGroupCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddImContactToGroupResponseMessageType Class

For a list of all members of this type, see AddImContactToGroupResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.AddImContactToGroupResponseMessageType

public class AddImContactToGroupResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AddImContactToGroupResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddImContactToGroupResponseMessageType Members

AddImContactToGroupResponseMessageType overview

Public Instance Constructors

AddImContactToGroupResponseMessageType Constructor Initializes a new instance of the AddImContactToGroupResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AddImContactToGroupResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddImContactToGroupResponseMessageType Constructor

Initializes a new instance of the AddImContactToGroupResponseMessageType class.

public AddImContactToGroupResponseMessageType();

See Also

AddImContactToGroupResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddImContactToGroupType Class

For a list of all members of this type, see AddImContactToGroupType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.AddImContactToGroupType

public class AddImContactToGroupType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AddImContactToGroupType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddImContactToGroupType Members

AddImContactToGroupType overview

Public Instance Constructors

AddImContactToGroupType Constructor Initializes a new instance of the AddImContactToGroupType class.

Public Instance Properties

ContactId
GroupId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AddImContactToGroupType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddImContactToGroupType Constructor

Initializes a new instance of the AddImContactToGroupType class.

public AddImContactToGroupType();

See Also

AddImContactToGroupType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddImContactToGroupType Properties

The properties of the AddImContactToGroupType class are listed below. For a complete list of AddImContactToGroupType class members, see the AddImContactToGroupType Members topic.

Public Instance Properties

ContactId
GroupId

See Also

AddImContactToGroupType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContactId Property

Aspose.Email

AddImContactToGroupType.ContactId Property

public ItemIdType ContactId {get; set;}

Remarks

See Also

AddImContactToGroupType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GroupId Property

Aspose.Email

AddImContactToGroupType.GroupId Property

public ItemIdType GroupId {get; set;}

Remarks

See Also

AddImContactToGroupType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddImGroupCompletedEventArgs Class

For a list of all members of this type, see AddImGroupCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.AddImGroupCompletedEventArgs

public class AddImGroupCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AddImGroupCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddImGroupCompletedEventArgs Members

AddImGroupCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

AddImGroupCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddImGroupCompletedEventArgs Properties

The properties of the AddImGroupCompletedEventArgs class are listed below. For a complete list of AddImGroupCompletedEventArgs class members, see the AddImGroupCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

AddImGroupCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

AddImGroupCompletedEventArgs.Result Property

public AddImGroupResponseMessageType Result {get;}

Remarks

See Also

AddImGroupCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddImGroupCompletedEventHandler Delegate

public delegate void AddImGroupCompletedEventHandler(
object sender,
AddImGroupCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddImGroupResponseMessageType Class

For a list of all members of this type, see AddImGroupResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.AddImGroupResponseMessageType

public class AddImGroupResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AddImGroupResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddImGroupResponseMessageType Members

AddImGroupResponseMessageType overview

Public Instance Constructors

AddImGroupResponseMessageType Constructor Initializes a new instance of the AddImGroupResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
ImGroup
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AddImGroupResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddImGroupResponseMessageType Constructor

Initializes a new instance of the AddImGroupResponseMessageType class.

public AddImGroupResponseMessageType();

See Also

AddImGroupResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddImGroupResponseMessageType Properties

The properties of the AddImGroupResponseMessageType class are listed below. For a complete list of AddImGroupResponseMessageType class members, see the AddImGroupResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
ImGroup
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

AddImGroupResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ImGroup Property

Aspose.Email

AddImGroupResponseMessageType.ImGroup Property

public ImGroupType ImGroup {get; set;}

Remarks

See Also

AddImGroupResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddImGroupType Class

For a list of all members of this type, see AddImGroupType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.AddImGroupType

public class AddImGroupType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AddImGroupType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddImGroupType Members

AddImGroupType overview

Public Instance Constructors

AddImGroupType Constructor Initializes a new instance of the AddImGroupType class.

Public Instance Properties

DisplayName

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AddImGroupType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddImGroupType Constructor

Initializes a new instance of the AddImGroupType class.

public AddImGroupType();

See Also

AddImGroupType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddImGroupType Properties

The properties of the AddImGroupType class are listed below. For a complete list of AddImGroupType class members, see the AddImGroupType Members topic.

Public Instance Properties

DisplayName

See Also

AddImGroupType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisplayName Property

Aspose.Email

AddImGroupType.DisplayName Property

public string DisplayName {get; set;}

Remarks

See Also

AddImGroupType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddNewImContactToGroupCompletedEventArgs Class

For a list of all members of this type, see AddNewImContactToGroupCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.AddNewImContactToGroupCompletedEventArgs

public class AddNewImContactToGroupCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AddNewImContactToGroupCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddNewImContactToGroupCompletedEventArgs Members

AddNewImContactToGroupCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

AddNewImContactToGroupCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddNewImContactToGroupCompletedEventArgs Properties

The properties of the AddNewImContactToGroupCompletedEventArgs class are listed below. For a complete list of AddNewImContactToGroupCompletedEventArgs class members, see the AddNewImContactToGroupCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

AddNewImContactToGroupCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

AddNewImContactToGroupCompletedEventArgs.Result Property

public AddNewImContactToGroupResponseMessageType Result {get;}

Remarks

See Also

AddNewImContactToGroupCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddNewImContactToGroupCompletedEventHandler Delegate

public delegate void AddNewImContactToGroupCompletedEventHandler(
object sender,
AddNewImContactToGroupCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddNewImContactToGroupResponseMessageType Class

For a list of all members of this type, see AddNewImContactToGroupResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.AddNewImContactToGroupResponseMessageType

public class AddNewImContactToGroupResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AddNewImContactToGroupResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddNewImContactToGroupResponseMessageType Members

AddNewImContactToGroupResponseMessageType overview

Public Instance Constructors

AddNewImContactToGroupResponseMessageType Constructor Initializes a new instance of the AddNewImContactToGroupResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
Persona
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AddNewImContactToGroupResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddNewImContactToGroupResponseMessageType Constructor

Initializes a new instance of the AddNewImContactToGroupResponseMessageType class.

public AddNewImContactToGroupResponseMessageType();

See Also

AddNewImContactToGroupResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddNewImContactToGroupResponseMessageType Properties

The properties of the AddNewImContactToGroupResponseMessageType class are listed below. For a complete list of AddNewImContactToGroupResponseMessageType class members, see the AddNewImContactToGroupResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
Persona
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

AddNewImContactToGroupResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Persona Property

Aspose.Email

AddNewImContactToGroupResponseMessageType.Persona Property

public PersonaType Persona {get; set;}

Remarks

See Also

AddNewImContactToGroupResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddNewImContactToGroupType Class

For a list of all members of this type, see AddNewImContactToGroupType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.AddNewImContactToGroupType

public class AddNewImContactToGroupType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AddNewImContactToGroupType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddNewImContactToGroupType Members

AddNewImContactToGroupType overview

Public Instance Constructors

AddNewImContactToGroupType Constructor Initializes a new instance of the AddNewImContactToGroupType class.

Public Instance Properties

DisplayName
GroupId
ImAddress

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AddNewImContactToGroupType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddNewImContactToGroupType Constructor

Initializes a new instance of the AddNewImContactToGroupType class.

public AddNewImContactToGroupType();

See Also

AddNewImContactToGroupType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddNewImContactToGroupType Properties

The properties of the AddNewImContactToGroupType class are listed below. For a complete list of AddNewImContactToGroupType class members, see the AddNewImContactToGroupType Members topic.

Public Instance Properties

DisplayName
GroupId
ImAddress

See Also

AddNewImContactToGroupType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisplayName Property

Aspose.Email

AddNewImContactToGroupType.DisplayName Property

public string DisplayName {get; set;}

Remarks

See Also

AddNewImContactToGroupType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GroupId Property

Aspose.Email

AddNewImContactToGroupType.GroupId Property

public ItemIdType GroupId {get; set;}

Remarks

See Also

AddNewImContactToGroupType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ImAddress Property

Aspose.Email

AddNewImContactToGroupType.ImAddress Property

public string ImAddress {get; set;}

Remarks

See Also

AddNewImContactToGroupType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddNewTelUriContactToGroupCompletedEventArgs Class

For a list of all members of this type, see AddNewTelUriContactToGroupCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.AddNewTelUriContactToGroupCompletedEventArgs

public class AddNewTelUriContactToGroupCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AddNewTelUriContactToGroupCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddNewTelUriContactToGroupCompletedEventArgs Members

AddNewTelUriContactToGroupCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

AddNewTelUriContactToGroupCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddNewTelUriContactToGroupCompletedEventArgs Properties

The properties of the AddNewTelUriContactToGroupCompletedEventArgs class are listed below. For a complete list of AddNewTelUriContactToGroupCompletedEventArgs class members, see the AddNewTelUriContactToGroupCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

AddNewTelUriContactToGroupCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

AddNewTelUriContactToGroupCompletedEventArgs.Result Property

public AddNewTelUriContactToGroupResponseMessageType Result {get;}

Remarks

See Also

AddNewTelUriContactToGroupCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddNewTelUriContactToGroupCompletedEventHandler Delegate

public delegate void AddNewTelUriContactToGroupCompletedEventHandler(
object sender,
AddNewTelUriContactToGroupCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddNewTelUriContactToGroupResponseMessageType Class

For a list of all members of this type, see AddNewTelUriContactToGroupResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.AddNewTelUriContactToGroupResponseMessageType

public class AddNewTelUriContactToGroupResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AddNewTelUriContactToGroupResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddNewTelUriContactToGroupResponseMessageType Members

AddNewTelUriContactToGroupResponseMessageType overview

Public Instance Constructors

AddNewTelUriContactToGroupResponseMessageType Constructor Initializes a new instance of the AddNewTelUriContactToGroupResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
Persona
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AddNewTelUriContactToGroupResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddNewTelUriContactToGroupResponseMessageType Constructor

Initializes a new instance of the AddNewTelUriContactToGroupResponseMessageType class.

public AddNewTelUriContactToGroupResponseMessageType();

See Also

AddNewTelUriContactToGroupResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddNewTelUriContactToGroupResponseMessageType Properties

The properties of the AddNewTelUriContactToGroupResponseMessageType class are listed below. For a complete list of AddNewTelUriContactToGroupResponseMessageType class members, see the AddNewTelUriContactToGroupResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
Persona
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

AddNewTelUriContactToGroupResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Persona Property

Aspose.Email

AddNewTelUriContactToGroupResponseMessageType.Persona Property

public PersonaType Persona {get; set;}

Remarks

See Also

AddNewTelUriContactToGroupResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddNewTelUriContactToGroupType Class

For a list of all members of this type, see AddNewTelUriContactToGroupType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.AddNewTelUriContactToGroupType

public class AddNewTelUriContactToGroupType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AddNewTelUriContactToGroupType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddNewTelUriContactToGroupType Members

AddNewTelUriContactToGroupType overview

Public Instance Constructors

AddNewTelUriContactToGroupType Constructor Initializes a new instance of the AddNewTelUriContactToGroupType class.

Public Instance Properties

GroupId
ImContactSipUriAddress
ImTelephoneNumber
TelUriAddress

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AddNewTelUriContactToGroupType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddNewTelUriContactToGroupType Constructor

Initializes a new instance of the AddNewTelUriContactToGroupType class.

public AddNewTelUriContactToGroupType();

See Also

AddNewTelUriContactToGroupType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddNewTelUriContactToGroupType Properties

The properties of the AddNewTelUriContactToGroupType class are listed below. For a complete list of AddNewTelUriContactToGroupType class members, see the AddNewTelUriContactToGroupType Members topic.

Public Instance Properties

GroupId
ImContactSipUriAddress
ImTelephoneNumber
TelUriAddress

See Also

AddNewTelUriContactToGroupType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GroupId Property

Aspose.Email

AddNewTelUriContactToGroupType.GroupId Property

public ItemIdType GroupId {get; set;}

Remarks

See Also

AddNewTelUriContactToGroupType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ImContactSipUriAddress Property

Aspose.Email

AddNewTelUriContactToGroupType.ImContactSipUriAddress Property

public string ImContactSipUriAddress {get; set;}

Remarks

See Also

AddNewTelUriContactToGroupType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ImTelephoneNumber Property

Aspose.Email

AddNewTelUriContactToGroupType.ImTelephoneNumber Property

public string ImTelephoneNumber {get; set;}

Remarks

See Also

AddNewTelUriContactToGroupType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TelUriAddress Property

Aspose.Email

AddNewTelUriContactToGroupType.TelUriAddress Property

public string TelUriAddress {get; set;}

Remarks

See Also

AddNewTelUriContactToGroupType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddressEntityType Class

For a list of all members of this type, see AddressEntityType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.EntityType
Aspose.Email.Exchange.Schema.Exchange_2013.AddressEntityType

public class AddressEntityType : EntityType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AddressEntityType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddressEntityType Members

AddressEntityType overview

Public Instance Constructors

AddressEntityType Constructor Initializes a new instance of the AddressEntityType class.

Public Instance Properties

Address
Position (inherited from EntityType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AddressEntityType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddressEntityType Constructor

Initializes a new instance of the AddressEntityType class.

public AddressEntityType();

See Also

AddressEntityType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddressEntityType Properties

The properties of the AddressEntityType class are listed below. For a complete list of AddressEntityType class members, see the AddressEntityType Members topic.

Public Instance Properties

Address
Position (inherited from EntityType)

See Also

AddressEntityType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Address Property

Aspose.Email

AddressEntityType.Address Property

public string Address {get; set;}

Remarks

See Also

AddressEntityType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddressListIdType Class

For a list of all members of this type, see AddressListIdType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseFolderIdType
Aspose.Email.Exchange.Schema.Exchange_2013.AddressListIdType

public class AddressListIdType : BaseFolderIdType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AddressListIdType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddressListIdType Members

AddressListIdType overview

Public Instance Constructors

AddressListIdType Constructor Initializes a new instance of the AddressListIdType class.

Public Instance Properties

Id

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AddressListIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddressListIdType Constructor

Initializes a new instance of the AddressListIdType class.

public AddressListIdType();

See Also

AddressListIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddressListIdType Properties

The properties of the AddressListIdType class are listed below. For a complete list of AddressListIdType class members, see the AddressListIdType Members topic.

Public Instance Properties

Id

See Also

AddressListIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Id Property

Aspose.Email

AddressListIdType.Id Property

public string Id {get; set;}

Remarks

See Also

AddressListIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AffectedTaskOccurrencesType Enumeration

public enum AffectedTaskOccurrencesType

Remarks

Members

Member Name | Description | Value
AllOccurrences |  | 0
SpecifiedOccurrenceOnly |  | 1

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AggregateOnType Class

For a list of all members of this type, see AggregateOnType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.AggregateOnType

public class AggregateOnType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AggregateOnType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AggregateOnType Members

AggregateOnType overview

Public Instance Constructors

AggregateOnType Constructor Initializes a new instance of the AggregateOnType class.

Public Instance Properties

Aggregate
Item

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AggregateOnType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AggregateOnType Constructor

Initializes a new instance of the AggregateOnType class.

public AggregateOnType();

See Also

AggregateOnType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AggregateOnType Properties

The properties of the AggregateOnType class are listed below. For a complete list of AggregateOnType class members, see the AggregateOnType Members topic.

Public Instance Properties

Aggregate
Item

See Also

AggregateOnType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Aggregate Property

Aspose.Email

AggregateOnType.Aggregate Property

public AggregateType Aggregate {get; set;}

Remarks

See Also

AggregateOnType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Item Property

Aspose.Email

AggregateOnType.Item Property

public BasePathToElementType Item {get; set;}

Remarks

See Also

AggregateOnType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AggregateType Enumeration

public enum AggregateType

Remarks

Members

Member Name | Description | Value
Minimum |  | 0
Maximum |  | 1

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AlternateIdBaseType Class

For a list of all members of this type, see AlternateIdBaseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.AlternateIdBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.AlternateIdType
Aspose.Email.Exchange.Schema.Exchange_2013.AlternatePublicFolderIdType

public abstract class AlternateIdBaseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AlternateIdBaseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AlternateIdBaseType Members

AlternateIdBaseType overview

Public Instance Properties

Format

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

AlternateIdBaseType Constructor Initializes a new instance of the AlternateIdBaseType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AlternateIdBaseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AlternateIdBaseType Constructor

Initializes a new instance of the AlternateIdBaseType class.

protected AlternateIdBaseType();

See Also

AlternateIdBaseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AlternateIdBaseType Properties

The properties of the AlternateIdBaseType class are listed below. For a complete list of AlternateIdBaseType class members, see the AlternateIdBaseType Members topic.

Public Instance Properties

Format

See Also

AlternateIdBaseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Format Property

Aspose.Email

AlternateIdBaseType.Format Property

public IdFormatType Format {get; set;}

Remarks

See Also

AlternateIdBaseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AlternateIdType Class

For a list of all members of this type, see AlternateIdType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.AlternateIdBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.AlternateIdType

public class AlternateIdType : AlternateIdBaseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AlternateIdType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AlternateIdType Members

AlternateIdType overview

Public Instance Constructors

AlternateIdType Constructor Initializes a new instance of the AlternateIdType class.

Public Instance Properties

Format (inherited from AlternateIdBaseType)
Id
IsArchive
IsArchiveSpecified
Mailbox

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AlternateIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AlternateIdType Constructor

Initializes a new instance of the AlternateIdType class.

public AlternateIdType();

See Also

AlternateIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AlternateIdType Properties

The properties of the AlternateIdType class are listed below. For a complete list of AlternateIdType class members, see the AlternateIdType Members topic.

Public Instance Properties

Format (inherited from AlternateIdBaseType)
Id
IsArchive
IsArchiveSpecified
Mailbox

See Also

AlternateIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Id Property

Aspose.Email

AlternateIdType.Id Property

public string Id {get; set;}

Remarks

See Also

AlternateIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsArchive Property

Aspose.Email

AlternateIdType.IsArchive Property

public bool IsArchive {get; set;}

Remarks

See Also

AlternateIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsArchiveSpecified Property

Aspose.Email

AlternateIdType.IsArchiveSpecified Property

public bool IsArchiveSpecified {get; set;}

Remarks

See Also

AlternateIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Mailbox Property

Aspose.Email

AlternateIdType.Mailbox Property

public string Mailbox {get; set;}

Remarks

See Also

AlternateIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AlternatePublicFolderIdType Class

For a list of all members of this type, see AlternatePublicFolderIdType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.AlternateIdBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.AlternatePublicFolderIdType
Aspose.Email.Exchange.Schema.Exchange_2013.AlternatePublicFolderItemIdType

public class AlternatePublicFolderIdType : AlternateIdBaseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AlternatePublicFolderIdType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AlternatePublicFolderIdType Members

AlternatePublicFolderIdType overview

Public Instance Constructors

AlternatePublicFolderIdType Constructor Initializes a new instance of the AlternatePublicFolderIdType class.

Public Instance Properties

FolderId
Format (inherited from AlternateIdBaseType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AlternatePublicFolderIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AlternatePublicFolderIdType Constructor

Initializes a new instance of the AlternatePublicFolderIdType class.

public AlternatePublicFolderIdType();

See Also

AlternatePublicFolderIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AlternatePublicFolderIdType Properties

The properties of the AlternatePublicFolderIdType class are listed below. For a complete list of AlternatePublicFolderIdType class members, see the AlternatePublicFolderIdType Members topic.

Public Instance Properties

FolderId
Format (inherited from AlternateIdBaseType)

See Also

AlternatePublicFolderIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FolderId Property

Aspose.Email

AlternatePublicFolderIdType.FolderId Property

public string FolderId {get; set;}

Remarks

See Also

AlternatePublicFolderIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AlternatePublicFolderItemIdType Class

For a list of all members of this type, see AlternatePublicFolderItemIdType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.AlternateIdBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.AlternatePublicFolderIdType
Aspose.Email.Exchange.Schema.Exchange_2013.AlternatePublicFolderItemIdType

public class AlternatePublicFolderItemIdType : AlternatePublicFolderIdType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AlternatePublicFolderItemIdType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AlternatePublicFolderItemIdType Members

AlternatePublicFolderItemIdType overview

Public Instance Constructors

AlternatePublicFolderItemIdType Constructor Initializes a new instance of the AlternatePublicFolderItemIdType class.

Public Instance Properties

FolderId (inherited from AlternatePublicFolderIdType)
Format (inherited from AlternateIdBaseType)
ItemId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AlternatePublicFolderItemIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AlternatePublicFolderItemIdType Constructor

Initializes a new instance of the AlternatePublicFolderItemIdType class.

public AlternatePublicFolderItemIdType();

See Also

AlternatePublicFolderItemIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AlternatePublicFolderItemIdType Properties

The properties of the AlternatePublicFolderItemIdType class are listed below. For a complete list of AlternatePublicFolderItemIdType class members, see the AlternatePublicFolderItemIdType Members topic.

Public Instance Properties

FolderId (inherited from AlternatePublicFolderIdType)
Format (inherited from AlternateIdBaseType)
ItemId

See Also

AlternatePublicFolderItemIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemId Property

Aspose.Email

AlternatePublicFolderItemIdType.ItemId Property

public string ItemId {get; set;}

Remarks

See Also

AlternatePublicFolderItemIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AndType Class

For a list of all members of this type, see AndType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.SearchExpressionType
Aspose.Email.Exchange.Schema.Exchange_2013.MultipleOperandBooleanExpressionType
Aspose.Email.Exchange.Schema.Exchange_2013.AndType

public class AndType : MultipleOperandBooleanExpressionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AndType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AndType Members

AndType overview

Public Instance Constructors

AndType Constructor Initializes a new instance of the AndType class.

Public Instance Properties

Items (inherited from MultipleOperandBooleanExpressionType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AndType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AndType Constructor

Initializes a new instance of the AndType class.

public AndType();

See Also

AndType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AppendToFolderFieldType Class

For a list of all members of this type, see AppendToFolderFieldType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ChangeDescriptionType
Aspose.Email.Exchange.Schema.Exchange_2013.FolderChangeDescriptionType
Aspose.Email.Exchange.Schema.Exchange_2013.AppendToFolderFieldType

public class AppendToFolderFieldType : FolderChangeDescriptionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AppendToFolderFieldType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AppendToFolderFieldType Members

AppendToFolderFieldType overview

Public Instance Constructors

AppendToFolderFieldType Constructor Initializes a new instance of the AppendToFolderFieldType class.

Public Instance Properties

Item (inherited from ChangeDescriptionType)
Item1

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AppendToFolderFieldType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AppendToFolderFieldType Constructor

Initializes a new instance of the AppendToFolderFieldType class.

public AppendToFolderFieldType();

See Also

AppendToFolderFieldType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AppendToFolderFieldType Properties

The properties of the AppendToFolderFieldType class are listed below. For a complete list of AppendToFolderFieldType class members, see the AppendToFolderFieldType Members topic.

Public Instance Properties

Item (inherited from ChangeDescriptionType)
Item1

See Also

AppendToFolderFieldType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Item1 Property

Aspose.Email

AppendToFolderFieldType.Item1 Property

public BaseFolderType Item1 {get; set;}

Remarks

See Also

AppendToFolderFieldType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AppendToItemFieldType Class

For a list of all members of this type, see AppendToItemFieldType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ChangeDescriptionType
Aspose.Email.Exchange.Schema.Exchange_2013.ItemChangeDescriptionType
Aspose.Email.Exchange.Schema.Exchange_2013.AppendToItemFieldType

public class AppendToItemFieldType : ItemChangeDescriptionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AppendToItemFieldType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AppendToItemFieldType Members

AppendToItemFieldType overview

Public Instance Constructors

AppendToItemFieldType Constructor Initializes a new instance of the AppendToItemFieldType class.

Public Instance Properties

Item (inherited from ChangeDescriptionType)
Item1

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AppendToItemFieldType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AppendToItemFieldType Constructor

Initializes a new instance of the AppendToItemFieldType class.

public AppendToItemFieldType();

See Also

AppendToItemFieldType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AppendToItemFieldType Properties

The properties of the AppendToItemFieldType class are listed below. For a complete list of AppendToItemFieldType class members, see the AppendToItemFieldType Members topic.

Public Instance Properties

Item (inherited from ChangeDescriptionType)
Item1

See Also

AppendToItemFieldType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Item1 Property

Aspose.Email

AppendToItemFieldType.Item1 Property

public ItemType Item1 {get; set;}

Remarks

See Also

AppendToItemFieldType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ApplyConversationActionCompletedEventArgs Class

For a list of all members of this type, see ApplyConversationActionCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.ApplyConversationActionCompletedEventArgs

public class ApplyConversationActionCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ApplyConversationActionCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ApplyConversationActionCompletedEventArgs Members

ApplyConversationActionCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

ApplyConversationActionCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ApplyConversationActionCompletedEventArgs Properties

The properties of the ApplyConversationActionCompletedEventArgs class are listed below. For a complete list of ApplyConversationActionCompletedEventArgs class members, see the ApplyConversationActionCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

ApplyConversationActionCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

ApplyConversationActionCompletedEventArgs.Result Property

public ApplyConversationActionResponseType Result {get;}

Remarks

See Also

ApplyConversationActionCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ApplyConversationActionCompletedEventHandler Delegate

public delegate void ApplyConversationActionCompletedEventHandler(
object sender,
ApplyConversationActionCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ApplyConversationActionResponseType Class

For a list of all members of this type, see ApplyConversationActionResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.ApplyConversationActionResponseType

public class ApplyConversationActionResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ApplyConversationActionResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ApplyConversationActionResponseType Members

ApplyConversationActionResponseType overview

Public Instance Constructors

ApplyConversationActionResponseType Constructor Initializes a new instance of the ApplyConversationActionResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ApplyConversationActionResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ApplyConversationActionResponseType Constructor

Initializes a new instance of the ApplyConversationActionResponseType class.

public ApplyConversationActionResponseType();

See Also

ApplyConversationActionResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ApplyConversationActionType Class

For a list of all members of this type, see ApplyConversationActionType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.ApplyConversationActionType

public class ApplyConversationActionType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ApplyConversationActionType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ApplyConversationActionType Members

ApplyConversationActionType overview

Public Instance Constructors

ApplyConversationActionType Constructor Initializes a new instance of the ApplyConversationActionType class.

Public Instance Properties

ConversationActions

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ApplyConversationActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ApplyConversationActionType Constructor

Initializes a new instance of the ApplyConversationActionType class.

public ApplyConversationActionType();

See Also

ApplyConversationActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ApplyConversationActionType Properties

The properties of the ApplyConversationActionType class are listed below. For a complete list of ApplyConversationActionType class members, see the ApplyConversationActionType Members topic.

Public Instance Properties

ConversationActions

See Also

ApplyConversationActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConversationActions Property

Aspose.Email

ApplyConversationActionType.ConversationActions Property

public ConversationActionType[] ConversationActions {get; set;}

Remarks

See Also

ApplyConversationActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ArchiveItemCompletedEventArgs Class

For a list of all members of this type, see ArchiveItemCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.ArchiveItemCompletedEventArgs

public class ArchiveItemCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ArchiveItemCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ArchiveItemCompletedEventArgs Members

ArchiveItemCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

ArchiveItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ArchiveItemCompletedEventArgs Properties

The properties of the ArchiveItemCompletedEventArgs class are listed below. For a complete list of ArchiveItemCompletedEventArgs class members, see the ArchiveItemCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

ArchiveItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

ArchiveItemCompletedEventArgs.Result Property

public ArchiveItemResponseType Result {get;}

Remarks

See Also

ArchiveItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ArchiveItemCompletedEventHandler Delegate

public delegate void ArchiveItemCompletedEventHandler(
object sender,
ArchiveItemCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ArchiveItemResponseType Class

For a list of all members of this type, see ArchiveItemResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.ArchiveItemResponseType

public class ArchiveItemResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ArchiveItemResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ArchiveItemResponseType Members

ArchiveItemResponseType overview

Public Instance Constructors

ArchiveItemResponseType Constructor Initializes a new instance of the ArchiveItemResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ArchiveItemResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ArchiveItemResponseType Constructor

Initializes a new instance of the ArchiveItemResponseType class.

public ArchiveItemResponseType();

See Also

ArchiveItemResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ArchiveItemType Class

For a list of all members of this type, see ArchiveItemType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.ArchiveItemType

public class ArchiveItemType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ArchiveItemType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ArchiveItemType Members

ArchiveItemType overview

Public Instance Constructors

ArchiveItemType Constructor Initializes a new instance of the ArchiveItemType class.

Public Instance Properties

ArchiveSourceFolderId
ItemIds

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ArchiveItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ArchiveItemType Constructor

Initializes a new instance of the ArchiveItemType class.

public ArchiveItemType();

See Also

ArchiveItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ArchiveItemType Properties

The properties of the ArchiveItemType class are listed below. For a complete list of ArchiveItemType class members, see the ArchiveItemType Members topic.

Public Instance Properties

ArchiveSourceFolderId
ItemIds

See Also

ArchiveItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ArchiveSourceFolderId Property

Aspose.Email

ArchiveItemType.ArchiveSourceFolderId Property

public TargetFolderIdType ArchiveSourceFolderId {get; set;}

Remarks

See Also

ArchiveItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemIds Property

Aspose.Email

ArchiveItemType.ItemIds Property

public BaseItemIdType[] ItemIds {get; set;}

Remarks

See Also

ArchiveItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ArrayOfDLExpansionType Class

For a list of all members of this type, see ArrayOfDLExpansionType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ArrayOfDLExpansionType

public class ArrayOfDLExpansionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ArrayOfDLExpansionType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ArrayOfDLExpansionType Members

ArrayOfDLExpansionType overview

Public Instance Constructors

ArrayOfDLExpansionType Constructor Initializes a new instance of the ArrayOfDLExpansionType class.

Public Instance Properties

AbsoluteDenominator
AbsoluteDenominatorSpecified
IncludesLastItemInRange
IncludesLastItemInRangeSpecified
IndexedPagingOffset
IndexedPagingOffsetSpecified
Mailbox
NumeratorOffset
NumeratorOffsetSpecified
TotalItemsInView
TotalItemsInViewSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ArrayOfDLExpansionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ArrayOfDLExpansionType Constructor

Initializes a new instance of the ArrayOfDLExpansionType class.

public ArrayOfDLExpansionType();

See Also

ArrayOfDLExpansionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ArrayOfDLExpansionType Properties

The properties of the ArrayOfDLExpansionType class are listed below. For a complete list of ArrayOfDLExpansionType class members, see the ArrayOfDLExpansionType Members topic.

Public Instance Properties

AbsoluteDenominator
AbsoluteDenominatorSpecified
IncludesLastItemInRange
IncludesLastItemInRangeSpecified
IndexedPagingOffset
IndexedPagingOffsetSpecified
Mailbox
NumeratorOffset
NumeratorOffsetSpecified
TotalItemsInView
TotalItemsInViewSpecified

See Also

ArrayOfDLExpansionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AbsoluteDenominator Property

Aspose.Email

ArrayOfDLExpansionType.AbsoluteDenominator Property

public int AbsoluteDenominator {get; set;}

Remarks

See Also

ArrayOfDLExpansionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AbsoluteDenominatorSpecified Property

Aspose.Email

ArrayOfDLExpansionType.AbsoluteDenominatorSpecified Property

public bool AbsoluteDenominatorSpecified {get; set;}

Remarks

See Also

ArrayOfDLExpansionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IncludesLastItemInRange Property

Aspose.Email

ArrayOfDLExpansionType.IncludesLastItemInRange Property

public bool IncludesLastItemInRange {get; set;}

Remarks

See Also

ArrayOfDLExpansionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IncludesLastItemInRangeSpecified Property

Aspose.Email

ArrayOfDLExpansionType.IncludesLastItemInRangeSpecified Property

public bool IncludesLastItemInRangeSpecified {get; set;}

Remarks

See Also

ArrayOfDLExpansionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IndexedPagingOffset Property

Aspose.Email

ArrayOfDLExpansionType.IndexedPagingOffset Property

public int IndexedPagingOffset {get; set;}

Remarks

See Also

ArrayOfDLExpansionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IndexedPagingOffsetSpecified Property

Aspose.Email

ArrayOfDLExpansionType.IndexedPagingOffsetSpecified Property

public bool IndexedPagingOffsetSpecified {get; set;}

Remarks

See Also

ArrayOfDLExpansionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Mailbox Property

Aspose.Email

ArrayOfDLExpansionType.Mailbox Property

public EmailAddressType[] Mailbox {get; set;}

Remarks

See Also

ArrayOfDLExpansionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NumeratorOffset Property

Aspose.Email

ArrayOfDLExpansionType.NumeratorOffset Property

public int NumeratorOffset {get; set;}

Remarks

See Also

ArrayOfDLExpansionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NumeratorOffsetSpecified Property

Aspose.Email

ArrayOfDLExpansionType.NumeratorOffsetSpecified Property

public bool NumeratorOffsetSpecified {get; set;}

Remarks

See Also

ArrayOfDLExpansionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TotalItemsInView Property

Aspose.Email

ArrayOfDLExpansionType.TotalItemsInView Property

public int TotalItemsInView {get; set;}

Remarks

See Also

ArrayOfDLExpansionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TotalItemsInViewSpecified Property

Aspose.Email

ArrayOfDLExpansionType.TotalItemsInViewSpecified Property

public bool TotalItemsInViewSpecified {get; set;}

Remarks

See Also

ArrayOfDLExpansionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ArrayOfGroupedItemsType Class

For a list of all members of this type, see ArrayOfGroupedItemsType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ArrayOfGroupedItemsType

public class ArrayOfGroupedItemsType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ArrayOfGroupedItemsType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ArrayOfGroupedItemsType Members

ArrayOfGroupedItemsType overview

Public Instance Constructors

ArrayOfGroupedItemsType Constructor Initializes a new instance of the ArrayOfGroupedItemsType class.

Public Instance Properties

Items

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ArrayOfGroupedItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ArrayOfGroupedItemsType Constructor

Initializes a new instance of the ArrayOfGroupedItemsType class.

public ArrayOfGroupedItemsType();

See Also

ArrayOfGroupedItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ArrayOfGroupedItemsType Properties

The properties of the ArrayOfGroupedItemsType class are listed below. For a complete list of ArrayOfGroupedItemsType class members, see the ArrayOfGroupedItemsType Members topic.

Public Instance Properties

Items

See Also

ArrayOfGroupedItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Items Property

Aspose.Email

ArrayOfGroupedItemsType.Items Property

public GroupedItemsType[] Items {get; set;}

Remarks

See Also

ArrayOfGroupedItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ArrayOfRealItemsType Class

For a list of all members of this type, see ArrayOfRealItemsType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ArrayOfRealItemsType

public class ArrayOfRealItemsType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ArrayOfRealItemsType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ArrayOfRealItemsType Members

ArrayOfRealItemsType overview

Public Instance Constructors

ArrayOfRealItemsType Constructor Initializes a new instance of the ArrayOfRealItemsType class.

Public Instance Properties

Items

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ArrayOfRealItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ArrayOfRealItemsType Constructor

Initializes a new instance of the ArrayOfRealItemsType class.

public ArrayOfRealItemsType();

See Also

ArrayOfRealItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ArrayOfRealItemsType Properties

The properties of the ArrayOfRealItemsType class are listed below. For a complete list of ArrayOfRealItemsType class members, see the ArrayOfRealItemsType Members topic.

Public Instance Properties

Items

See Also

ArrayOfRealItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Items Property

Aspose.Email

ArrayOfRealItemsType.Items Property

public ItemType[] Items {get; set;}

Remarks

See Also

ArrayOfRealItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ArrayOfResolutionType Class

For a list of all members of this type, see ArrayOfResolutionType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ArrayOfResolutionType

public class ArrayOfResolutionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ArrayOfResolutionType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ArrayOfResolutionType Members

ArrayOfResolutionType overview

Public Instance Constructors

ArrayOfResolutionType Constructor Initializes a new instance of the ArrayOfResolutionType class.

Public Instance Properties

AbsoluteDenominator
AbsoluteDenominatorSpecified
IncludesLastItemInRange
IncludesLastItemInRangeSpecified
IndexedPagingOffset
IndexedPagingOffsetSpecified
NumeratorOffset
NumeratorOffsetSpecified
Resolution
TotalItemsInView
TotalItemsInViewSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ArrayOfResolutionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ArrayOfResolutionType Constructor

Initializes a new instance of the ArrayOfResolutionType class.

public ArrayOfResolutionType();

See Also

ArrayOfResolutionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ArrayOfResolutionType Properties

The properties of the ArrayOfResolutionType class are listed below. For a complete list of ArrayOfResolutionType class members, see the ArrayOfResolutionType Members topic.

Public Instance Properties

AbsoluteDenominator
AbsoluteDenominatorSpecified
IncludesLastItemInRange
IncludesLastItemInRangeSpecified
IndexedPagingOffset
IndexedPagingOffsetSpecified
NumeratorOffset
NumeratorOffsetSpecified
Resolution
TotalItemsInView
TotalItemsInViewSpecified

See Also

ArrayOfResolutionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AbsoluteDenominator Property

Aspose.Email

ArrayOfResolutionType.AbsoluteDenominator Property

public int AbsoluteDenominator {get; set;}

Remarks

See Also

ArrayOfResolutionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AbsoluteDenominatorSpecified Property

Aspose.Email

ArrayOfResolutionType.AbsoluteDenominatorSpecified Property

public bool AbsoluteDenominatorSpecified {get; set;}

Remarks

See Also

ArrayOfResolutionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IncludesLastItemInRange Property

Aspose.Email

ArrayOfResolutionType.IncludesLastItemInRange Property

public bool IncludesLastItemInRange {get; set;}

Remarks

See Also

ArrayOfResolutionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IncludesLastItemInRangeSpecified Property

Aspose.Email

ArrayOfResolutionType.IncludesLastItemInRangeSpecified Property

public bool IncludesLastItemInRangeSpecified {get; set;}

Remarks

See Also

ArrayOfResolutionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IndexedPagingOffset Property

Aspose.Email

ArrayOfResolutionType.IndexedPagingOffset Property

public int IndexedPagingOffset {get; set;}

Remarks

See Also

ArrayOfResolutionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IndexedPagingOffsetSpecified Property

Aspose.Email

ArrayOfResolutionType.IndexedPagingOffsetSpecified Property

public bool IndexedPagingOffsetSpecified {get; set;}

Remarks

See Also

ArrayOfResolutionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NumeratorOffset Property

Aspose.Email

ArrayOfResolutionType.NumeratorOffset Property

public int NumeratorOffset {get; set;}

Remarks

See Also

ArrayOfResolutionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NumeratorOffsetSpecified Property

Aspose.Email

ArrayOfResolutionType.NumeratorOffsetSpecified Property

public bool NumeratorOffsetSpecified {get; set;}

Remarks

See Also

ArrayOfResolutionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Resolution Property

Aspose.Email

ArrayOfResolutionType.Resolution Property

public ResolutionType[] Resolution {get; set;}

Remarks

See Also

ArrayOfResolutionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TotalItemsInView Property

Aspose.Email

ArrayOfResolutionType.TotalItemsInView Property

public int TotalItemsInView {get; set;}

Remarks

See Also

ArrayOfResolutionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TotalItemsInViewSpecified Property

Aspose.Email

ArrayOfResolutionType.TotalItemsInViewSpecified Property

public bool TotalItemsInViewSpecified {get; set;}

Remarks

See Also

ArrayOfResolutionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ArrayOfResponseMessagesType Class

For a list of all members of this type, see ArrayOfResponseMessagesType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ArrayOfResponseMessagesType

public class ArrayOfResponseMessagesType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ArrayOfResponseMessagesType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ArrayOfResponseMessagesType Members

ArrayOfResponseMessagesType overview

Public Instance Constructors

ArrayOfResponseMessagesType Constructor Initializes a new instance of the ArrayOfResponseMessagesType class.

Public Instance Properties

Items
ItemsElementName

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ArrayOfResponseMessagesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ArrayOfResponseMessagesType Constructor

Initializes a new instance of the ArrayOfResponseMessagesType class.

public ArrayOfResponseMessagesType();

See Also

ArrayOfResponseMessagesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ArrayOfResponseMessagesType Properties

The properties of the ArrayOfResponseMessagesType class are listed below. For a complete list of ArrayOfResponseMessagesType class members, see the ArrayOfResponseMessagesType Members topic.

Public Instance Properties

Items
ItemsElementName

See Also

ArrayOfResponseMessagesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Items Property

Aspose.Email

ArrayOfResponseMessagesType.Items Property

public ResponseMessageType[] Items {get; set;}

Remarks

See Also

ArrayOfResponseMessagesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemsElementName Property

Aspose.Email

ArrayOfResponseMessagesType.ItemsElementName Property

public ItemsChoiceType4[] ItemsElementName {get; set;}

Remarks

See Also

ArrayOfResponseMessagesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ArrayOfTimeZoneDefinitionType Class

For a list of all members of this type, see ArrayOfTimeZoneDefinitionType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ArrayOfTimeZoneDefinitionType

public class ArrayOfTimeZoneDefinitionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ArrayOfTimeZoneDefinitionType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ArrayOfTimeZoneDefinitionType Members

ArrayOfTimeZoneDefinitionType overview

Public Instance Constructors

ArrayOfTimeZoneDefinitionType Constructor Initializes a new instance of the ArrayOfTimeZoneDefinitionType class.

Public Instance Properties

TimeZoneDefinition

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ArrayOfTimeZoneDefinitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ArrayOfTimeZoneDefinitionType Constructor

Initializes a new instance of the ArrayOfTimeZoneDefinitionType class.

public ArrayOfTimeZoneDefinitionType();

See Also

ArrayOfTimeZoneDefinitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ArrayOfTimeZoneDefinitionType Properties

The properties of the ArrayOfTimeZoneDefinitionType class are listed below. For a complete list of ArrayOfTimeZoneDefinitionType class members, see the ArrayOfTimeZoneDefinitionType Members topic.

Public Instance Properties

TimeZoneDefinition

See Also

ArrayOfTimeZoneDefinitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TimeZoneDefinition Property

Aspose.Email

ArrayOfTimeZoneDefinitionType.TimeZoneDefinition Property

public TimeZoneDefinitionType[] TimeZoneDefinition {get; set;}

Remarks

See Also

ArrayOfTimeZoneDefinitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ArrayOfTrackingPropertiesType Class

For a list of all members of this type, see ArrayOfTrackingPropertiesType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ArrayOfTrackingPropertiesType

public class ArrayOfTrackingPropertiesType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ArrayOfTrackingPropertiesType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ArrayOfTrackingPropertiesType Members

ArrayOfTrackingPropertiesType overview

Public Instance Constructors

ArrayOfTrackingPropertiesType Constructor Initializes a new instance of the ArrayOfTrackingPropertiesType class.

Public Instance Properties

Items

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ArrayOfTrackingPropertiesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ArrayOfTrackingPropertiesType Constructor

Initializes a new instance of the ArrayOfTrackingPropertiesType class.

public ArrayOfTrackingPropertiesType();

See Also

ArrayOfTrackingPropertiesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ArrayOfTrackingPropertiesType Properties

The properties of the ArrayOfTrackingPropertiesType class are listed below. For a complete list of ArrayOfTrackingPropertiesType class members, see the ArrayOfTrackingPropertiesType Members topic.

Public Instance Properties

Items

See Also

ArrayOfTrackingPropertiesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Items Property

Aspose.Email

ArrayOfTrackingPropertiesType.Items Property

public TrackingPropertyType[] Items {get; set;}

Remarks

See Also

ArrayOfTrackingPropertiesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ArrayOfTransitionsType Class

For a list of all members of this type, see ArrayOfTransitionsType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ArrayOfTransitionsType

public class ArrayOfTransitionsType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ArrayOfTransitionsType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ArrayOfTransitionsType Members

ArrayOfTransitionsType overview

Public Instance Constructors

ArrayOfTransitionsType Constructor Initializes a new instance of the ArrayOfTransitionsType class.

Public Instance Properties

Id
Items

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ArrayOfTransitionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ArrayOfTransitionsType Constructor

Initializes a new instance of the ArrayOfTransitionsType class.

public ArrayOfTransitionsType();

See Also

ArrayOfTransitionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ArrayOfTransitionsType Properties

The properties of the ArrayOfTransitionsType class are listed below. For a complete list of ArrayOfTransitionsType class members, see the ArrayOfTransitionsType Members topic.

Public Instance Properties

Id
Items

See Also

ArrayOfTransitionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Id Property

Aspose.Email

ArrayOfTransitionsType.Id Property

public string Id {get; set;}

Remarks

See Also

ArrayOfTransitionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Items Property

Aspose.Email

ArrayOfTransitionsType.Items Property

public TransitionType[] Items {get; set;}

Remarks

See Also

ArrayOfTransitionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AttachmentIdType Class

For a list of all members of this type, see AttachmentIdType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseItemIdType
Aspose.Email.Exchange.Schema.Exchange_2013.RequestAttachmentIdType
Aspose.Email.Exchange.Schema.Exchange_2013.AttachmentIdType

public class AttachmentIdType : RequestAttachmentIdType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AttachmentIdType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AttachmentIdType Members

AttachmentIdType overview

Public Instance Constructors

AttachmentIdType Constructor Initializes a new instance of the AttachmentIdType class.

Public Instance Properties

Id (inherited from RequestAttachmentIdType)
RootItemChangeKey
RootItemId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AttachmentIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AttachmentIdType Constructor

Initializes a new instance of the AttachmentIdType class.

public AttachmentIdType();

See Also

AttachmentIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AttachmentIdType Properties

The properties of the AttachmentIdType class are listed below. For a complete list of AttachmentIdType class members, see the AttachmentIdType Members topic.

Public Instance Properties

Id (inherited from RequestAttachmentIdType)
RootItemChangeKey
RootItemId

See Also

AttachmentIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RootItemChangeKey Property

Aspose.Email

AttachmentIdType.RootItemChangeKey Property

public string RootItemChangeKey {get; set;}

Remarks

See Also

AttachmentIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RootItemId Property

Aspose.Email

AttachmentIdType.RootItemId Property

public string RootItemId {get; set;}

Remarks

See Also

AttachmentIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AttachmentInfoResponseMessageType Class

For a list of all members of this type, see AttachmentInfoResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.AttachmentInfoResponseMessageType

public class AttachmentInfoResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AttachmentInfoResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AttachmentInfoResponseMessageType Members

AttachmentInfoResponseMessageType overview

Public Instance Constructors

AttachmentInfoResponseMessageType Constructor Initializes a new instance of the AttachmentInfoResponseMessageType class.

Public Instance Properties

Attachments
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AttachmentInfoResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AttachmentInfoResponseMessageType Constructor

Initializes a new instance of the AttachmentInfoResponseMessageType class.

public AttachmentInfoResponseMessageType();

See Also

AttachmentInfoResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AttachmentInfoResponseMessageType Properties

The properties of the AttachmentInfoResponseMessageType class are listed below. For a complete list of AttachmentInfoResponseMessageType class members, see the AttachmentInfoResponseMessageType Members topic.

Public Instance Properties

Attachments
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

AttachmentInfoResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Attachments Property

Aspose.Email

AttachmentInfoResponseMessageType.Attachments Property

public AttachmentType[] Attachments {get; set;}

Remarks

See Also

AttachmentInfoResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AttachmentResponseShapeType Class

For a list of all members of this type, see AttachmentResponseShapeType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.AttachmentResponseShapeType

public class AttachmentResponseShapeType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AttachmentResponseShapeType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AttachmentResponseShapeType Members

AttachmentResponseShapeType overview

Public Instance Constructors

AttachmentResponseShapeType Constructor Initializes a new instance of the AttachmentResponseShapeType class.

Public Instance Properties

AdditionalProperties
BodyType
BodyTypeSpecified
FilterHtmlContent
FilterHtmlContentSpecified
IncludeMimeContent
IncludeMimeContentSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AttachmentResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AttachmentResponseShapeType Constructor

Initializes a new instance of the AttachmentResponseShapeType class.

public AttachmentResponseShapeType();

See Also

AttachmentResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AttachmentResponseShapeType Properties

The properties of the AttachmentResponseShapeType class are listed below. For a complete list of AttachmentResponseShapeType class members, see the AttachmentResponseShapeType Members topic.

Public Instance Properties

AdditionalProperties
BodyType
BodyTypeSpecified
FilterHtmlContent
FilterHtmlContentSpecified
IncludeMimeContent
IncludeMimeContentSpecified

See Also

AttachmentResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AdditionalProperties Property

Aspose.Email

AttachmentResponseShapeType.AdditionalProperties Property

public BasePathToElementType[] AdditionalProperties {get; set;}

Remarks

See Also

AttachmentResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BodyType Property

Aspose.Email

AttachmentResponseShapeType.BodyType Property

public BodyTypeResponseType BodyType {get; set;}

Remarks

See Also

AttachmentResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BodyTypeSpecified Property

Aspose.Email

AttachmentResponseShapeType.BodyTypeSpecified Property

public bool BodyTypeSpecified {get; set;}

Remarks

See Also

AttachmentResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FilterHtmlContent Property

Aspose.Email

AttachmentResponseShapeType.FilterHtmlContent Property

public bool FilterHtmlContent {get; set;}

Remarks

See Also

AttachmentResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FilterHtmlContentSpecified Property

Aspose.Email

AttachmentResponseShapeType.FilterHtmlContentSpecified Property

public bool FilterHtmlContentSpecified {get; set;}

Remarks

See Also

AttachmentResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IncludeMimeContent Property

Aspose.Email

AttachmentResponseShapeType.IncludeMimeContent Property

public bool IncludeMimeContent {get; set;}

Remarks

See Also

AttachmentResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IncludeMimeContentSpecified Property

Aspose.Email

AttachmentResponseShapeType.IncludeMimeContentSpecified Property

public bool IncludeMimeContentSpecified {get; set;}

Remarks

See Also

AttachmentResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AttachmentType Class

For a list of all members of this type, see AttachmentType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.AttachmentType
Aspose.Email.Exchange.Schema.Exchange_2013.FileAttachmentType
Aspose.Email.Exchange.Schema.Exchange_2013.ItemAttachmentType

public class AttachmentType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AttachmentType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AttachmentType Members

AttachmentType overview

Public Instance Constructors

AttachmentType Constructor Initializes a new instance of the AttachmentType class.

Public Instance Properties

AttachmentId
ContentId
ContentLocation
ContentType
IsInline
IsInlineSpecified
LastModifiedTime
LastModifiedTimeSpecified
Name
Size
SizeSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AttachmentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AttachmentType Constructor

Initializes a new instance of the AttachmentType class.

public AttachmentType();

See Also

AttachmentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AttachmentType Properties

The properties of the AttachmentType class are listed below. For a complete list of AttachmentType class members, see the AttachmentType Members topic.

Public Instance Properties

AttachmentId
ContentId
ContentLocation
ContentType
IsInline
IsInlineSpecified
LastModifiedTime
LastModifiedTimeSpecified
Name
Size
SizeSpecified

See Also

AttachmentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AttachmentId Property

Aspose.Email

AttachmentType.AttachmentId Property

public AttachmentIdType AttachmentId {get; set;}

Remarks

See Also

AttachmentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContentId Property

Aspose.Email

AttachmentType.ContentId Property

public string ContentId {get; set;}

Remarks

See Also

AttachmentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContentLocation Property

Aspose.Email

AttachmentType.ContentLocation Property

public string ContentLocation {get; set;}

Remarks

See Also

AttachmentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContentType Property

Aspose.Email

AttachmentType.ContentType Property

public string ContentType {get; set;}

Remarks

See Also

AttachmentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsInline Property

Aspose.Email

AttachmentType.IsInline Property

public bool IsInline {get; set;}

Remarks

See Also

AttachmentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsInlineSpecified Property

Aspose.Email

AttachmentType.IsInlineSpecified Property

public bool IsInlineSpecified {get; set;}

Remarks

See Also

AttachmentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


LastModifiedTime Property

Aspose.Email

AttachmentType.LastModifiedTime Property

public DateTime LastModifiedTime {get; set;}

Remarks

See Also

AttachmentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


LastModifiedTimeSpecified Property

Aspose.Email

AttachmentType.LastModifiedTimeSpecified Property

public bool LastModifiedTimeSpecified {get; set;}

Remarks

See Also

AttachmentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Name Property

Aspose.Email

AttachmentType.Name Property

public string Name {get; set;}

Remarks

See Also

AttachmentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Size Property

Aspose.Email

AttachmentType.Size Property

public int Size {get; set;}

Remarks

See Also

AttachmentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SizeSpecified Property

Aspose.Email

AttachmentType.SizeSpecified Property

public bool SizeSpecified {get; set;}

Remarks

See Also

AttachmentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AttendeeConflictData Class

For a list of all members of this type, see AttendeeConflictData Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.AttendeeConflictData
Aspose.Email.Exchange.Schema.Exchange_2013.GroupAttendeeConflictData
Aspose.Email.Exchange.Schema.Exchange_2013.IndividualAttendeeConflictData
Aspose.Email.Exchange.Schema.Exchange_2013.TooBigGroupAttendeeConflictData
Aspose.Email.Exchange.Schema.Exchange_2013.UnknownAttendeeConflictData

public abstract class AttendeeConflictData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AttendeeConflictData Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AttendeeConflictData Members

AttendeeConflictData overview

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

AttendeeConflictData Constructor Initializes a new instance of the AttendeeConflictData class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AttendeeConflictData Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AttendeeConflictData Constructor

Initializes a new instance of the AttendeeConflictData class.

protected AttendeeConflictData();

See Also

AttendeeConflictData Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AttendeeType Class

For a list of all members of this type, see AttendeeType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.AttendeeType

public class AttendeeType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AttendeeType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AttendeeType Members

AttendeeType overview

Public Instance Constructors

AttendeeType Constructor Initializes a new instance of the AttendeeType class.

Public Instance Properties

LastResponseTime
LastResponseTimeSpecified
Mailbox
ResponseType
ResponseTypeSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AttendeeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AttendeeType Constructor

Initializes a new instance of the AttendeeType class.

public AttendeeType();

See Also

AttendeeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AttendeeType Properties

The properties of the AttendeeType class are listed below. For a complete list of AttendeeType class members, see the AttendeeType Members topic.

Public Instance Properties

LastResponseTime
LastResponseTimeSpecified
Mailbox
ResponseType
ResponseTypeSpecified

See Also

AttendeeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


LastResponseTime Property

Aspose.Email

AttendeeType.LastResponseTime Property

public DateTime LastResponseTime {get; set;}

Remarks

See Also

AttendeeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


LastResponseTimeSpecified Property

Aspose.Email

AttendeeType.LastResponseTimeSpecified Property

public bool LastResponseTimeSpecified {get; set;}

Remarks

See Also

AttendeeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Mailbox Property

Aspose.Email

AttendeeType.Mailbox Property

public EmailAddressType Mailbox {get; set;}

Remarks

See Also

AttendeeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResponseType Property

Aspose.Email

AttendeeType.ResponseType Property

public ResponseTypeType ResponseType {get; set;}

Remarks

See Also

AttendeeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResponseTypeSpecified Property

Aspose.Email

AttendeeType.ResponseTypeSpecified Property

public bool ResponseTypeSpecified {get; set;}

Remarks

See Also

AttendeeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AudioMetricsAverageType Class

For a list of all members of this type, see AudioMetricsAverageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.AudioMetricsAverageType

public class AudioMetricsAverageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AudioMetricsAverageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AudioMetricsAverageType Members

AudioMetricsAverageType overview

Public Instance Constructors

AudioMetricsAverageType Constructor Initializes a new instance of the AudioMetricsAverageType class.

Public Instance Properties

TotalCount
TotalValue

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AudioMetricsAverageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AudioMetricsAverageType Constructor

Initializes a new instance of the AudioMetricsAverageType class.

public AudioMetricsAverageType();

See Also

AudioMetricsAverageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AudioMetricsAverageType Properties

The properties of the AudioMetricsAverageType class are listed below. For a complete list of AudioMetricsAverageType class members, see the AudioMetricsAverageType Members topic.

Public Instance Properties

TotalCount
TotalValue

See Also

AudioMetricsAverageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TotalCount Property

Aspose.Email

AudioMetricsAverageType.TotalCount Property

public double TotalCount {get; set;}

Remarks

See Also

AudioMetricsAverageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TotalValue Property

Aspose.Email

AudioMetricsAverageType.TotalValue Property

public double TotalValue {get; set;}

Remarks

See Also

AudioMetricsAverageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AudioQualityType Class

For a list of all members of this type, see AudioQualityType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.AudioQualityType

public class AudioQualityType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AudioQualityType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AudioQualityType Members

AudioQualityType overview

Public Instance Constructors

AudioQualityType Constructor Initializes a new instance of the AudioQualityType class.

Public Instance Properties

AudioCodec
BurstDensity
BurstDuration
Jitter
NMOS
NMOSDegradation
NMOSDegradationJitter
NMOSDegradationPacketLoss
PacketLoss
RoundTrip

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AudioQualityType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AudioQualityType Constructor

Initializes a new instance of the AudioQualityType class.

public AudioQualityType();

See Also

AudioQualityType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AudioQualityType Properties

The properties of the AudioQualityType class are listed below. For a complete list of AudioQualityType class members, see the AudioQualityType Members topic.

Public Instance Properties

AudioCodec
BurstDensity
BurstDuration
Jitter
NMOS
NMOSDegradation
NMOSDegradationJitter
NMOSDegradationPacketLoss
PacketLoss
RoundTrip

See Also

AudioQualityType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AudioCodec Property

Aspose.Email

AudioQualityType.AudioCodec Property

public string AudioCodec {get; set;}

Remarks

See Also

AudioQualityType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BurstDensity Property

Aspose.Email

AudioQualityType.BurstDensity Property

public float BurstDensity {get; set;}

Remarks

See Also

AudioQualityType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BurstDuration Property

Aspose.Email

AudioQualityType.BurstDuration Property

public float BurstDuration {get; set;}

Remarks

See Also

AudioQualityType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Jitter Property

Aspose.Email

AudioQualityType.Jitter Property

public float Jitter {get; set;}

Remarks

See Also

AudioQualityType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NMOS Property

Aspose.Email

AudioQualityType.NMOS Property

public float NMOS {get; set;}

Remarks

See Also

AudioQualityType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NMOSDegradation Property

Aspose.Email

AudioQualityType.NMOSDegradation Property

public float NMOSDegradation {get; set;}

Remarks

See Also

AudioQualityType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NMOSDegradationJitter Property

Aspose.Email

AudioQualityType.NMOSDegradationJitter Property

public float NMOSDegradationJitter {get; set;}

Remarks

See Also

AudioQualityType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NMOSDegradationPacketLoss Property

Aspose.Email

AudioQualityType.NMOSDegradationPacketLoss Property

public float NMOSDegradationPacketLoss {get; set;}

Remarks

See Also

AudioQualityType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PacketLoss Property

Aspose.Email

AudioQualityType.PacketLoss Property

public float PacketLoss {get; set;}

Remarks

See Also

AudioQualityType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RoundTrip Property

Aspose.Email

AudioQualityType.RoundTrip Property

public float RoundTrip {get; set;}

Remarks

See Also

AudioQualityType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseCalendarItemStateDefinitionType Class

For a list of all members of this type, see BaseCalendarItemStateDefinitionType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseCalendarItemStateDefinitionType
Aspose.Email.Exchange.Schema.Exchange_2013.DeletedOccurrenceStateDefinitionType
Aspose.Email.Exchange.Schema.Exchange_2013.DeleteFromFolderStateDefinitionType
Aspose.Email.Exchange.Schema.Exchange_2013.LocationBasedStateDefinitionType

public class BaseCalendarItemStateDefinitionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

BaseCalendarItemStateDefinitionType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseCalendarItemStateDefinitionType Members

BaseCalendarItemStateDefinitionType overview

Public Instance Constructors

BaseCalendarItemStateDefinitionType Constructor Initializes a new instance of the BaseCalendarItemStateDefinitionType class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BaseCalendarItemStateDefinitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseCalendarItemStateDefinitionType Constructor

Initializes a new instance of the BaseCalendarItemStateDefinitionType class.

public BaseCalendarItemStateDefinitionType();

See Also

BaseCalendarItemStateDefinitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseDelegateResponseMessageType Class

For a list of all members of this type, see BaseDelegateResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.BaseDelegateResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.AddDelegateResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetDelegateResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.RemoveDelegateResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateDelegateResponseMessageType

public abstract class BaseDelegateResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

BaseDelegateResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseDelegateResponseMessageType Members

BaseDelegateResponseMessageType overview

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
ResponseMessages

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

BaseDelegateResponseMessageType Constructor Initializes a new instance of the BaseDelegateResponseMessageType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BaseDelegateResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseDelegateResponseMessageType Constructor

Initializes a new instance of the BaseDelegateResponseMessageType class.

protected BaseDelegateResponseMessageType();

See Also

BaseDelegateResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseDelegateResponseMessageType Properties

The properties of the BaseDelegateResponseMessageType class are listed below. For a complete list of BaseDelegateResponseMessageType class members, see the BaseDelegateResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
ResponseMessages

See Also

BaseDelegateResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResponseMessages Property

Aspose.Email

BaseDelegateResponseMessageType.ResponseMessages Property

public DelegateUserResponseMessageType[] ResponseMessages {get; set;}

Remarks

See Also

BaseDelegateResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseDelegateType Class

For a list of all members of this type, see BaseDelegateType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.BaseDelegateType
Aspose.Email.Exchange.Schema.Exchange_2013.AddDelegateType
Aspose.Email.Exchange.Schema.Exchange_2013.GetDelegateType
Aspose.Email.Exchange.Schema.Exchange_2013.RemoveDelegateType
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateDelegateType

public abstract class BaseDelegateType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

BaseDelegateType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseDelegateType Members

BaseDelegateType overview

Public Instance Properties

Mailbox

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

BaseDelegateType Constructor Initializes a new instance of the BaseDelegateType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BaseDelegateType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseDelegateType Constructor

Initializes a new instance of the BaseDelegateType class.

protected BaseDelegateType();

See Also

BaseDelegateType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseDelegateType Properties

The properties of the BaseDelegateType class are listed below. For a complete list of BaseDelegateType class members, see the BaseDelegateType Members topic.

Public Instance Properties

Mailbox

See Also

BaseDelegateType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Mailbox Property

Aspose.Email

BaseDelegateType.Mailbox Property

public EmailAddressType Mailbox {get; set;}

Remarks

See Also

BaseDelegateType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseEmailAddressType Class

For a list of all members of this type, see BaseEmailAddressType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseEmailAddressType
Aspose.Email.Exchange.Schema.Exchange_2013.EmailAddressType

public class BaseEmailAddressType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

BaseEmailAddressType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseEmailAddressType Members

BaseEmailAddressType overview

Public Instance Constructors

BaseEmailAddressType Constructor Initializes a new instance of the BaseEmailAddressType class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BaseEmailAddressType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseEmailAddressType Constructor

Initializes a new instance of the BaseEmailAddressType class.

public BaseEmailAddressType();

See Also

BaseEmailAddressType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseFolderIdType Class

For a list of all members of this type, see BaseFolderIdType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseFolderIdType
Aspose.Email.Exchange.Schema.Exchange_2013.AddressListIdType
Aspose.Email.Exchange.Schema.Exchange_2013.DistinguishedFolderIdType
Aspose.Email.Exchange.Schema.Exchange_2013.FolderIdType

public abstract class BaseFolderIdType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

BaseFolderIdType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseFolderIdType Members

BaseFolderIdType overview

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

BaseFolderIdType Constructor Initializes a new instance of the BaseFolderIdType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BaseFolderIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseFolderIdType Constructor

Initializes a new instance of the BaseFolderIdType class.

protected BaseFolderIdType();

See Also

BaseFolderIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseFolderType Class

For a list of all members of this type, see BaseFolderType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseFolderType
Aspose.Email.Exchange.Schema.Exchange_2013.CalendarFolderType
Aspose.Email.Exchange.Schema.Exchange_2013.ContactsFolderType
Aspose.Email.Exchange.Schema.Exchange_2013.FolderType

public abstract class BaseFolderType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

BaseFolderType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseFolderType Members

BaseFolderType overview

Public Instance Properties

ArchiveTag
ChildFolderCount
ChildFolderCountSpecified
DisplayName
DistinguishedFolderId
DistinguishedFolderIdSpecified
EffectiveRights
ExtendedProperty
FolderClass
FolderId
ManagedFolderInformation
ParentFolderId
PolicyTag
TotalCount
TotalCountSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

BaseFolderType Constructor Initializes a new instance of the BaseFolderType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BaseFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseFolderType Constructor

Initializes a new instance of the BaseFolderType class.

protected BaseFolderType();

See Also

BaseFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseFolderType Properties

The properties of the BaseFolderType class are listed below. For a complete list of BaseFolderType class members, see the BaseFolderType Members topic.

Public Instance Properties

ArchiveTag
ChildFolderCount
ChildFolderCountSpecified
DisplayName
DistinguishedFolderId
DistinguishedFolderIdSpecified
EffectiveRights
ExtendedProperty
FolderClass
FolderId
ManagedFolderInformation
ParentFolderId
PolicyTag
TotalCount
TotalCountSpecified

See Also

BaseFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ArchiveTag Property

Aspose.Email

BaseFolderType.ArchiveTag Property

public RetentionTagType ArchiveTag {get; set;}

Remarks

See Also

BaseFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ChildFolderCount Property

Aspose.Email

BaseFolderType.ChildFolderCount Property

public int ChildFolderCount {get; set;}

Remarks

See Also

BaseFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ChildFolderCountSpecified Property

Aspose.Email

BaseFolderType.ChildFolderCountSpecified Property

public bool ChildFolderCountSpecified {get; set;}

Remarks

See Also

BaseFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisplayName Property

Aspose.Email

BaseFolderType.DisplayName Property

public string DisplayName {get; set;}

Remarks

See Also

BaseFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DistinguishedFolderId Property

Aspose.Email

BaseFolderType.DistinguishedFolderId Property

public DistinguishedFolderIdNameType DistinguishedFolderId {get; set;}

Remarks

See Also

BaseFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DistinguishedFolderIdSpecified Property

Aspose.Email

BaseFolderType.DistinguishedFolderIdSpecified Property

public bool DistinguishedFolderIdSpecified {get; set;}

Remarks

See Also

BaseFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EffectiveRights Property

Aspose.Email

BaseFolderType.EffectiveRights Property

public EffectiveRightsType EffectiveRights {get; set;}

Remarks

See Also

BaseFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExtendedProperty Property

Aspose.Email

BaseFolderType.ExtendedProperty Property

public ExtendedPropertyType[] ExtendedProperty {get; set;}

Remarks

See Also

BaseFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FolderClass Property

Aspose.Email

BaseFolderType.FolderClass Property

public string FolderClass {get; set;}

Remarks

See Also

BaseFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FolderId Property

Aspose.Email

BaseFolderType.FolderId Property

public FolderIdType FolderId {get; set;}

Remarks

See Also

BaseFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ManagedFolderInformation Property

Aspose.Email

BaseFolderType.ManagedFolderInformation Property

public ManagedFolderInformationType ManagedFolderInformation {get; set;}

Remarks

See Also

BaseFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ParentFolderId Property

Aspose.Email

BaseFolderType.ParentFolderId Property

public FolderIdType ParentFolderId {get; set;}

Remarks

See Also

BaseFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PolicyTag Property

Aspose.Email

BaseFolderType.PolicyTag Property

public RetentionTagType PolicyTag {get; set;}

Remarks

See Also

BaseFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TotalCount Property

Aspose.Email

BaseFolderType.TotalCount Property

public int TotalCount {get; set;}

Remarks

See Also

BaseFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TotalCountSpecified Property

Aspose.Email

BaseFolderType.TotalCountSpecified Property

public bool TotalCountSpecified {get; set;}

Remarks

See Also

BaseFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseGroupByType Class

For a list of all members of this type, see BaseGroupByType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseGroupByType
Aspose.Email.Exchange.Schema.Exchange_2013.DistinguishedGroupByType
Aspose.Email.Exchange.Schema.Exchange_2013.GroupByType

public abstract class BaseGroupByType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

BaseGroupByType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseGroupByType Members

BaseGroupByType overview

Public Instance Properties

Order

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

BaseGroupByType Constructor Initializes a new instance of the BaseGroupByType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BaseGroupByType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseGroupByType Constructor

Initializes a new instance of the BaseGroupByType class.

protected BaseGroupByType();

See Also

BaseGroupByType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseGroupByType Properties

The properties of the BaseGroupByType class are listed below. For a complete list of BaseGroupByType class members, see the BaseGroupByType Members topic.

Public Instance Properties

Order

See Also

BaseGroupByType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Order Property

Aspose.Email

BaseGroupByType.Order Property

public SortDirectionType Order {get; set;}

Remarks

See Also

BaseGroupByType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseItemIdType Class

For a list of all members of this type, see BaseItemIdType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseItemIdType
Aspose.Email.Exchange.Schema.Exchange_2013.ItemIdType
Aspose.Email.Exchange.Schema.Exchange_2013.OccurrenceItemIdType
Aspose.Email.Exchange.Schema.Exchange_2013.RecurringMasterItemIdType
Aspose.Email.Exchange.Schema.Exchange_2013.RequestAttachmentIdType
Aspose.Email.Exchange.Schema.Exchange_2013.RootItemIdType

public abstract class BaseItemIdType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

BaseItemIdType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseItemIdType Members

BaseItemIdType overview

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

BaseItemIdType Constructor Initializes a new instance of the BaseItemIdType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BaseItemIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseItemIdType Constructor

Initializes a new instance of the BaseItemIdType class.

protected BaseItemIdType();

See Also

BaseItemIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseMoveCopyFolderType Class

For a list of all members of this type, see BaseMoveCopyFolderType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.BaseMoveCopyFolderType
Aspose.Email.Exchange.Schema.Exchange_2013.CopyFolderType
Aspose.Email.Exchange.Schema.Exchange_2013.MoveFolderType

public class BaseMoveCopyFolderType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

BaseMoveCopyFolderType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseMoveCopyFolderType Members

BaseMoveCopyFolderType overview

Public Instance Constructors

BaseMoveCopyFolderType Constructor Initializes a new instance of the BaseMoveCopyFolderType class.

Public Instance Properties

FolderIds
ToFolderId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BaseMoveCopyFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseMoveCopyFolderType Constructor

Initializes a new instance of the BaseMoveCopyFolderType class.

public BaseMoveCopyFolderType();

See Also

BaseMoveCopyFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseMoveCopyFolderType Properties

The properties of the BaseMoveCopyFolderType class are listed below. For a complete list of BaseMoveCopyFolderType class members, see the BaseMoveCopyFolderType Members topic.

Public Instance Properties

FolderIds
ToFolderId

See Also

BaseMoveCopyFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FolderIds Property

Aspose.Email

BaseMoveCopyFolderType.FolderIds Property

public BaseFolderIdType[] FolderIds {get; set;}

Remarks

See Also

BaseMoveCopyFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ToFolderId Property

Aspose.Email

BaseMoveCopyFolderType.ToFolderId Property

public TargetFolderIdType ToFolderId {get; set;}

Remarks

See Also

BaseMoveCopyFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseMoveCopyItemType Class

For a list of all members of this type, see BaseMoveCopyItemType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.BaseMoveCopyItemType
Aspose.Email.Exchange.Schema.Exchange_2013.CopyItemType
Aspose.Email.Exchange.Schema.Exchange_2013.MoveItemType

public class BaseMoveCopyItemType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

BaseMoveCopyItemType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseMoveCopyItemType Members

BaseMoveCopyItemType overview

Public Instance Constructors

BaseMoveCopyItemType Constructor Initializes a new instance of the BaseMoveCopyItemType class.

Public Instance Properties

ItemIds
ReturnNewItemIds
ReturnNewItemIdsSpecified
ToFolderId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BaseMoveCopyItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseMoveCopyItemType Constructor

Initializes a new instance of the BaseMoveCopyItemType class.

public BaseMoveCopyItemType();

See Also

BaseMoveCopyItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseMoveCopyItemType Properties

The properties of the BaseMoveCopyItemType class are listed below. For a complete list of BaseMoveCopyItemType class members, see the BaseMoveCopyItemType Members topic.

Public Instance Properties

ItemIds
ReturnNewItemIds
ReturnNewItemIdsSpecified
ToFolderId

See Also

BaseMoveCopyItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemIds Property

Aspose.Email

BaseMoveCopyItemType.ItemIds Property

public BaseItemIdType[] ItemIds {get; set;}

Remarks

See Also

BaseMoveCopyItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReturnNewItemIds Property

Aspose.Email

BaseMoveCopyItemType.ReturnNewItemIds Property

public bool ReturnNewItemIds {get; set;}

Remarks

See Also

BaseMoveCopyItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReturnNewItemIdsSpecified Property

Aspose.Email

BaseMoveCopyItemType.ReturnNewItemIdsSpecified Property

public bool ReturnNewItemIdsSpecified {get; set;}

Remarks

See Also

BaseMoveCopyItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ToFolderId Property

Aspose.Email

BaseMoveCopyItemType.ToFolderId Property

public TargetFolderIdType ToFolderId {get; set;}

Remarks

See Also

BaseMoveCopyItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseNotificationEventType Class

For a list of all members of this type, see BaseNotificationEventType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseNotificationEventType
Aspose.Email.Exchange.Schema.Exchange_2013.BaseObjectChangedEventType

public class BaseNotificationEventType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

BaseNotificationEventType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseNotificationEventType Members

BaseNotificationEventType overview

Public Instance Constructors

BaseNotificationEventType Constructor Initializes a new instance of the BaseNotificationEventType class.

Public Instance Properties

Watermark

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BaseNotificationEventType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseNotificationEventType Constructor

Initializes a new instance of the BaseNotificationEventType class.

public BaseNotificationEventType();

See Also

BaseNotificationEventType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseNotificationEventType Properties

The properties of the BaseNotificationEventType class are listed below. For a complete list of BaseNotificationEventType class members, see the BaseNotificationEventType Members topic.

Public Instance Properties

Watermark

See Also

BaseNotificationEventType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Watermark Property

Aspose.Email

BaseNotificationEventType.Watermark Property

public string Watermark {get; set;}

Remarks

See Also

BaseNotificationEventType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseObjectChangedEventType Class

For a list of all members of this type, see BaseObjectChangedEventType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseNotificationEventType
Aspose.Email.Exchange.Schema.Exchange_2013.BaseObjectChangedEventType
Aspose.Email.Exchange.Schema.Exchange_2013.ModifiedEventType
Aspose.Email.Exchange.Schema.Exchange_2013.MovedCopiedEventType

public class BaseObjectChangedEventType : BaseNotificationEventType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

BaseObjectChangedEventType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseObjectChangedEventType Members

BaseObjectChangedEventType overview

Public Instance Constructors

BaseObjectChangedEventType Constructor Initializes a new instance of the BaseObjectChangedEventType class.

Public Instance Properties

Item
ParentFolderId
TimeStamp
Watermark (inherited from BaseNotificationEventType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BaseObjectChangedEventType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseObjectChangedEventType Constructor

Initializes a new instance of the BaseObjectChangedEventType class.

public BaseObjectChangedEventType();

See Also

BaseObjectChangedEventType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseObjectChangedEventType Properties

The properties of the BaseObjectChangedEventType class are listed below. For a complete list of BaseObjectChangedEventType class members, see the BaseObjectChangedEventType Members topic.

Public Instance Properties

Item
ParentFolderId
TimeStamp
Watermark (inherited from BaseNotificationEventType)

See Also

BaseObjectChangedEventType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Item Property

Aspose.Email

BaseObjectChangedEventType.Item Property

public object Item {get; set;}

Remarks

See Also

BaseObjectChangedEventType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ParentFolderId Property

Aspose.Email

BaseObjectChangedEventType.ParentFolderId Property

public FolderIdType ParentFolderId {get; set;}

Remarks

See Also

BaseObjectChangedEventType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TimeStamp Property

Aspose.Email

BaseObjectChangedEventType.TimeStamp Property

public DateTime TimeStamp {get; set;}

Remarks

See Also

BaseObjectChangedEventType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BasePagingType Class

For a list of all members of this type, see BasePagingType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BasePagingType
Aspose.Email.Exchange.Schema.Exchange_2013.CalendarViewType
Aspose.Email.Exchange.Schema.Exchange_2013.ContactsViewType
Aspose.Email.Exchange.Schema.Exchange_2013.FractionalPageViewType
Aspose.Email.Exchange.Schema.Exchange_2013.IndexedPageViewType
Aspose.Email.Exchange.Schema.Exchange_2013.SeekToConditionPageViewType

public abstract class BasePagingType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

BasePagingType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BasePagingType Members

BasePagingType overview

Public Instance Properties

MaxEntriesReturned
MaxEntriesReturnedSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

BasePagingType Constructor Initializes a new instance of the BasePagingType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BasePagingType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BasePagingType Constructor

Initializes a new instance of the BasePagingType class.

protected BasePagingType();

See Also

BasePagingType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BasePagingType Properties

The properties of the BasePagingType class are listed below. For a complete list of BasePagingType class members, see the BasePagingType Members topic.

Public Instance Properties

MaxEntriesReturned
MaxEntriesReturnedSpecified

See Also

BasePagingType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MaxEntriesReturned Property

Aspose.Email

BasePagingType.MaxEntriesReturned Property

public int MaxEntriesReturned {get; set;}

Remarks

See Also

BasePagingType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MaxEntriesReturnedSpecified Property

Aspose.Email

BasePagingType.MaxEntriesReturnedSpecified Property

public bool MaxEntriesReturnedSpecified {get; set;}

Remarks

See Also

BasePagingType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BasePathToElementType Class

For a list of all members of this type, see BasePathToElementType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BasePathToElementType
Aspose.Email.Exchange.Schema.Exchange_2013.PathToExceptionFieldType
Aspose.Email.Exchange.Schema.Exchange_2013.PathToExtendedFieldType
Aspose.Email.Exchange.Schema.Exchange_2013.PathToIndexedFieldType
Aspose.Email.Exchange.Schema.Exchange_2013.PathToUnindexedFieldType

public abstract class BasePathToElementType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

BasePathToElementType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BasePathToElementType Members

BasePathToElementType overview

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

BasePathToElementType Constructor Initializes a new instance of the BasePathToElementType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BasePathToElementType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BasePathToElementType Constructor

Initializes a new instance of the BasePathToElementType class.

protected BasePathToElementType();

See Also

BasePathToElementType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BasePermissionType Class

For a list of all members of this type, see BasePermissionType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BasePermissionType
Aspose.Email.Exchange.Schema.Exchange_2013.CalendarPermissionType
Aspose.Email.Exchange.Schema.Exchange_2013.PermissionType

public abstract class BasePermissionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

BasePermissionType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BasePermissionType Members

BasePermissionType overview

Public Instance Properties

CanCreateItems
CanCreateItemsSpecified
CanCreateSubFolders
CanCreateSubFoldersSpecified
DeleteItems
DeleteItemsSpecified
EditItems
EditItemsSpecified
IsFolderContact
IsFolderContactSpecified
IsFolderOwner
IsFolderOwnerSpecified
IsFolderVisible
IsFolderVisibleSpecified
UserId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

BasePermissionType Constructor Initializes a new instance of the BasePermissionType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BasePermissionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BasePermissionType Constructor

Initializes a new instance of the BasePermissionType class.

protected BasePermissionType();

See Also

BasePermissionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BasePermissionType Properties

The properties of the BasePermissionType class are listed below. For a complete list of BasePermissionType class members, see the BasePermissionType Members topic.

Public Instance Properties

CanCreateItems
CanCreateItemsSpecified
CanCreateSubFolders
CanCreateSubFoldersSpecified
DeleteItems
DeleteItemsSpecified
EditItems
EditItemsSpecified
IsFolderContact
IsFolderContactSpecified
IsFolderOwner
IsFolderOwnerSpecified
IsFolderVisible
IsFolderVisibleSpecified
UserId

See Also

BasePermissionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CanCreateItems Property

Aspose.Email

BasePermissionType.CanCreateItems Property

public bool CanCreateItems {get; set;}

Remarks

See Also

BasePermissionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CanCreateItemsSpecified Property

Aspose.Email

BasePermissionType.CanCreateItemsSpecified Property

public bool CanCreateItemsSpecified {get; set;}

Remarks

See Also

BasePermissionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CanCreateSubFolders Property

Aspose.Email

BasePermissionType.CanCreateSubFolders Property

public bool CanCreateSubFolders {get; set;}

Remarks

See Also

BasePermissionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CanCreateSubFoldersSpecified Property

Aspose.Email

BasePermissionType.CanCreateSubFoldersSpecified Property

public bool CanCreateSubFoldersSpecified {get; set;}

Remarks

See Also

BasePermissionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteItems Property

Aspose.Email

BasePermissionType.DeleteItems Property

public PermissionActionType DeleteItems {get; set;}

Remarks

See Also

BasePermissionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteItemsSpecified Property

Aspose.Email

BasePermissionType.DeleteItemsSpecified Property

public bool DeleteItemsSpecified {get; set;}

Remarks

See Also

BasePermissionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EditItems Property

Aspose.Email

BasePermissionType.EditItems Property

public PermissionActionType EditItems {get; set;}

Remarks

See Also

BasePermissionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EditItemsSpecified Property

Aspose.Email

BasePermissionType.EditItemsSpecified Property

public bool EditItemsSpecified {get; set;}

Remarks

See Also

BasePermissionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsFolderContact Property

Aspose.Email

BasePermissionType.IsFolderContact Property

public bool IsFolderContact {get; set;}

Remarks

See Also

BasePermissionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsFolderContactSpecified Property

Aspose.Email

BasePermissionType.IsFolderContactSpecified Property

public bool IsFolderContactSpecified {get; set;}

Remarks

See Also

BasePermissionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsFolderOwner Property

Aspose.Email

BasePermissionType.IsFolderOwner Property

public bool IsFolderOwner {get; set;}

Remarks

See Also

BasePermissionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsFolderOwnerSpecified Property

Aspose.Email

BasePermissionType.IsFolderOwnerSpecified Property

public bool IsFolderOwnerSpecified {get; set;}

Remarks

See Also

BasePermissionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsFolderVisible Property

Aspose.Email

BasePermissionType.IsFolderVisible Property

public bool IsFolderVisible {get; set;}

Remarks

See Also

BasePermissionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsFolderVisibleSpecified Property

Aspose.Email

BasePermissionType.IsFolderVisibleSpecified Property

public bool IsFolderVisibleSpecified {get; set;}

Remarks

See Also

BasePermissionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserId Property

Aspose.Email

BasePermissionType.UserId Property

public UserIdType UserId {get; set;}

Remarks

See Also

BasePermissionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseRequestType Class

For a list of all members of this type, see BaseRequestType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Derived types

public abstract class BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

BaseRequestType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseRequestType Members

BaseRequestType overview

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

BaseRequestType Constructor Initializes a new instance of the BaseRequestType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BaseRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseRequestType Constructor

Initializes a new instance of the BaseRequestType class.

protected BaseRequestType();

See Also

BaseRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseResponseMessageType Class

For a list of all members of this type, see BaseResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Derived types

public class BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

BaseResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseResponseMessageType Members

BaseResponseMessageType overview

Public Instance Constructors

BaseResponseMessageType Constructor Initializes a new instance of the BaseResponseMessageType class.

Public Instance Properties

ResponseMessages

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BaseResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseResponseMessageType Constructor

Initializes a new instance of the BaseResponseMessageType class.

public BaseResponseMessageType();

See Also

BaseResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseResponseMessageType Properties

The properties of the BaseResponseMessageType class are listed below. For a complete list of BaseResponseMessageType class members, see the BaseResponseMessageType Members topic.

Public Instance Properties

ResponseMessages

See Also

BaseResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResponseMessages Property

Aspose.Email

BaseResponseMessageType.ResponseMessages Property

public ArrayOfResponseMessagesType ResponseMessages {get; set;}

Remarks

See Also

BaseResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseSubscriptionRequestType Class

For a list of all members of this type, see BaseSubscriptionRequestType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseSubscriptionRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.PullSubscriptionRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.PushSubscriptionRequestType

public abstract class BaseSubscriptionRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

BaseSubscriptionRequestType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseSubscriptionRequestType Members

BaseSubscriptionRequestType overview

Public Instance Properties

EventTypes
FolderIds
SubscribeToAllFolders
SubscribeToAllFoldersSpecified
Watermark

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

BaseSubscriptionRequestType Constructor Initializes a new instance of the BaseSubscriptionRequestType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BaseSubscriptionRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseSubscriptionRequestType Constructor

Initializes a new instance of the BaseSubscriptionRequestType class.

protected BaseSubscriptionRequestType();

See Also

BaseSubscriptionRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseSubscriptionRequestType Properties

The properties of the BaseSubscriptionRequestType class are listed below. For a complete list of BaseSubscriptionRequestType class members, see the BaseSubscriptionRequestType Members topic.

Public Instance Properties

EventTypes
FolderIds
SubscribeToAllFolders
SubscribeToAllFoldersSpecified
Watermark

See Also

BaseSubscriptionRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EventTypes Property

Aspose.Email

BaseSubscriptionRequestType.EventTypes Property

public NotificationEventTypeType[] EventTypes {get; set;}

Remarks

See Also

BaseSubscriptionRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FolderIds Property

Aspose.Email

BaseSubscriptionRequestType.FolderIds Property

public BaseFolderIdType[] FolderIds {get; set;}

Remarks

See Also

BaseSubscriptionRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SubscribeToAllFolders Property

Aspose.Email

BaseSubscriptionRequestType.SubscribeToAllFolders Property

public bool SubscribeToAllFolders {get; set;}

Remarks

See Also

BaseSubscriptionRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SubscribeToAllFoldersSpecified Property

Aspose.Email

BaseSubscriptionRequestType.SubscribeToAllFoldersSpecified Property

public bool SubscribeToAllFoldersSpecified {get; set;}

Remarks

See Also

BaseSubscriptionRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Watermark Property

Aspose.Email

BaseSubscriptionRequestType.Watermark Property

public string Watermark {get; set;}

Remarks

See Also

BaseSubscriptionRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BodyContentAttributedValueType Class

For a list of all members of this type, see BodyContentAttributedValueType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BodyContentAttributedValueType

public class BodyContentAttributedValueType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

BodyContentAttributedValueType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BodyContentAttributedValueType Members

BodyContentAttributedValueType overview

Public Instance Constructors

BodyContentAttributedValueType Constructor Initializes a new instance of the BodyContentAttributedValueType class.

Public Instance Properties

Attributions
Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BodyContentAttributedValueType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BodyContentAttributedValueType Constructor

Initializes a new instance of the BodyContentAttributedValueType class.

public BodyContentAttributedValueType();

See Also

BodyContentAttributedValueType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BodyContentAttributedValueType Properties

The properties of the BodyContentAttributedValueType class are listed below. For a complete list of BodyContentAttributedValueType class members, see the BodyContentAttributedValueType Members topic.

Public Instance Properties

Attributions
Value

See Also

BodyContentAttributedValueType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Attributions Property

Aspose.Email

BodyContentAttributedValueType.Attributions Property

public string[] Attributions {get; set;}

Remarks

See Also

BodyContentAttributedValueType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Value Property

Aspose.Email

BodyContentAttributedValueType.Value Property

public BodyContentType Value {get; set;}

Remarks

See Also

BodyContentAttributedValueType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BodyContentType Class

For a list of all members of this type, see BodyContentType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BodyContentType

public class BodyContentType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

BodyContentType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BodyContentType Members

BodyContentType overview

Public Instance Constructors

BodyContentType Constructor Initializes a new instance of the BodyContentType class.

Public Instance Properties

BodyType
Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BodyContentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BodyContentType Constructor

Initializes a new instance of the BodyContentType class.

public BodyContentType();

See Also

BodyContentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BodyContentType Properties

The properties of the BodyContentType class are listed below. For a complete list of BodyContentType class members, see the BodyContentType Members topic.

Public Instance Properties

BodyType
Value

See Also

BodyContentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BodyType Property

Aspose.Email

BodyContentType.BodyType Property

public BodyTypeType BodyType {get; set;}

Remarks

See Also

BodyContentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Value Property

Aspose.Email

BodyContentType.Value Property

public string Value {get; set;}

Remarks

See Also

BodyContentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BodyType Class

For a list of all members of this type, see BodyType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BodyType

public class BodyType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

BodyType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BodyType Members

BodyType overview

Public Instance Constructors

BodyType Constructor Initializes a new instance of the BodyType class.

Public Instance Properties

BodyType1
IsTruncated
IsTruncatedSpecified
Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BodyType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BodyType Constructor

Initializes a new instance of the BodyType class.

public BodyType();

See Also

BodyType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BodyType Properties

The properties of the BodyType class are listed below. For a complete list of BodyType class members, see the BodyType Members topic.

Public Instance Properties

BodyType1
IsTruncated
IsTruncatedSpecified
Value

See Also

BodyType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BodyType1 Property

Aspose.Email

BodyType.BodyType1 Property

public BodyTypeType BodyType1 {get; set;}

Remarks

See Also

BodyType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsTruncated Property

Aspose.Email

BodyType.IsTruncated Property

public bool IsTruncated {get; set;}

Remarks

See Also

BodyType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsTruncatedSpecified Property

Aspose.Email

BodyType.IsTruncatedSpecified Property

public bool IsTruncatedSpecified {get; set;}

Remarks

See Also

BodyType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Value Property

Aspose.Email

BodyType.Value Property

public string Value {get; set;}

Remarks

See Also

BodyType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BodyTypeResponseType Enumeration

public enum BodyTypeResponseType

Remarks

Members

Member Name | Description | Value
Best |  | 0
HTML |  | 1
Text |  | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BodyTypeType Enumeration

public enum BodyTypeType

Remarks

Members

Member Name | Description | Value
HTML |  | 0
Text |  | 1

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalendarEvent Class

For a list of all members of this type, see CalendarEvent Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.CalendarEvent

public class CalendarEvent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CalendarEvent Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalendarEvent Members

CalendarEvent overview

Public Instance Constructors

CalendarEvent Constructor Initializes a new instance of the CalendarEvent class.

Public Instance Properties

BusyType
CalendarEventDetails
EndTime
StartTime

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CalendarEvent Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalendarEvent Constructor

Initializes a new instance of the CalendarEvent class.

public CalendarEvent();

See Also

CalendarEvent Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalendarEvent Properties

The properties of the CalendarEvent class are listed below. For a complete list of CalendarEvent class members, see the CalendarEvent Members topic.

Public Instance Properties

BusyType
CalendarEventDetails
EndTime
StartTime

See Also

CalendarEvent Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BusyType Property

Aspose.Email

CalendarEvent.BusyType Property

public LegacyFreeBusyType BusyType {get; set;}

Remarks

See Also

CalendarEvent Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalendarEventDetails Property

Aspose.Email

CalendarEvent.CalendarEventDetails Property

public CalendarEventDetails CalendarEventDetails {get; set;}

Remarks

See Also

CalendarEvent Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EndTime Property

Aspose.Email

CalendarEvent.EndTime Property

public DateTime EndTime {get; set;}

Remarks

See Also

CalendarEvent Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StartTime Property

Aspose.Email

CalendarEvent.StartTime Property

public DateTime StartTime {get; set;}

Remarks

See Also

CalendarEvent Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalendarEventDetails Class

For a list of all members of this type, see CalendarEventDetails Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.CalendarEventDetails

public class CalendarEventDetails

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CalendarEventDetails Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalendarEventDetails Members

CalendarEventDetails overview

Public Instance Constructors

CalendarEventDetails Constructor Initializes a new instance of the CalendarEventDetails class.

Public Instance Properties

ID
IsException
IsMeeting
IsPrivate
IsRecurring
IsReminderSet
Location
Subject

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CalendarEventDetails Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalendarEventDetails Constructor

Initializes a new instance of the CalendarEventDetails class.

public CalendarEventDetails();

See Also

CalendarEventDetails Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalendarEventDetails Properties

The properties of the CalendarEventDetails class are listed below. For a complete list of CalendarEventDetails class members, see the CalendarEventDetails Members topic.

Public Instance Properties

ID
IsException
IsMeeting
IsPrivate
IsRecurring
IsReminderSet
Location
Subject

See Also

CalendarEventDetails Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ID Property

Aspose.Email

CalendarEventDetails.ID Property

public string ID {get; set;}

Remarks

See Also

CalendarEventDetails Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsException Property

Aspose.Email

CalendarEventDetails.IsException Property

public bool IsException {get; set;}

Remarks

See Also

CalendarEventDetails Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsMeeting Property

Aspose.Email

CalendarEventDetails.IsMeeting Property

public bool IsMeeting {get; set;}

Remarks

See Also

CalendarEventDetails Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsPrivate Property

Aspose.Email

CalendarEventDetails.IsPrivate Property

public bool IsPrivate {get; set;}

Remarks

See Also

CalendarEventDetails Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsRecurring Property

Aspose.Email

CalendarEventDetails.IsRecurring Property

public bool IsRecurring {get; set;}

Remarks

See Also

CalendarEventDetails Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsReminderSet Property

Aspose.Email

CalendarEventDetails.IsReminderSet Property

public bool IsReminderSet {get; set;}

Remarks

See Also

CalendarEventDetails Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Location Property

Aspose.Email

CalendarEventDetails.Location Property

public string Location {get; set;}

Remarks

See Also

CalendarEventDetails Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Subject Property

Aspose.Email

CalendarEventDetails.Subject Property

public string Subject {get; set;}

Remarks

See Also

CalendarEventDetails Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalendarFolderType Class

For a list of all members of this type, see CalendarFolderType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseFolderType
Aspose.Email.Exchange.Schema.Exchange_2013.CalendarFolderType

public class CalendarFolderType : BaseFolderType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CalendarFolderType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalendarFolderType Members

CalendarFolderType overview

Public Instance Constructors

CalendarFolderType Constructor Initializes a new instance of the CalendarFolderType class.

Public Instance Properties

ArchiveTag (inherited from BaseFolderType)
ChildFolderCount (inherited from BaseFolderType)
ChildFolderCountSpecified (inherited from BaseFolderType)
DisplayName (inherited from BaseFolderType)
DistinguishedFolderId (inherited from BaseFolderType)
DistinguishedFolderIdSpecified (inherited from BaseFolderType)
EffectiveRights (inherited from BaseFolderType)
ExtendedProperty (inherited from BaseFolderType)
FolderClass (inherited from BaseFolderType)
FolderId (inherited from BaseFolderType)
ManagedFolderInformation (inherited from BaseFolderType)
ParentFolderId (inherited from BaseFolderType)
PermissionSet
PolicyTag (inherited from BaseFolderType)
SharingEffectiveRights
SharingEffectiveRightsSpecified
TotalCount (inherited from BaseFolderType)
TotalCountSpecified (inherited from BaseFolderType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CalendarFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalendarFolderType Constructor

Initializes a new instance of the CalendarFolderType class.

public CalendarFolderType();

See Also

CalendarFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalendarFolderType Properties

The properties of the CalendarFolderType class are listed below. For a complete list of CalendarFolderType class members, see the CalendarFolderType Members topic.

Public Instance Properties

ArchiveTag (inherited from BaseFolderType)
ChildFolderCount (inherited from BaseFolderType)
ChildFolderCountSpecified (inherited from BaseFolderType)
DisplayName (inherited from BaseFolderType)
DistinguishedFolderId (inherited from BaseFolderType)
DistinguishedFolderIdSpecified (inherited from BaseFolderType)
EffectiveRights (inherited from BaseFolderType)
ExtendedProperty (inherited from BaseFolderType)
FolderClass (inherited from BaseFolderType)
FolderId (inherited from BaseFolderType)
ManagedFolderInformation (inherited from BaseFolderType)
ParentFolderId (inherited from BaseFolderType)
PermissionSet
PolicyTag (inherited from BaseFolderType)
SharingEffectiveRights
SharingEffectiveRightsSpecified
TotalCount (inherited from BaseFolderType)
TotalCountSpecified (inherited from BaseFolderType)

See Also

CalendarFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PermissionSet Property

Aspose.Email

CalendarFolderType.PermissionSet Property

public CalendarPermissionSetType PermissionSet {get; set;}

Remarks

See Also

CalendarFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SharingEffectiveRights Property

Aspose.Email

CalendarFolderType.SharingEffectiveRights Property

public CalendarPermissionReadAccessType SharingEffectiveRights {get; set;}

Remarks

See Also

CalendarFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SharingEffectiveRightsSpecified Property

Aspose.Email

CalendarFolderType.SharingEffectiveRightsSpecified Property

public bool SharingEffectiveRightsSpecified {get; set;}

Remarks

See Also

CalendarFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalendarItemCreateOrDeleteOperationType Enumeration

public enum CalendarItemCreateOrDeleteOperationType

Remarks

Members

Member Name | Description | Value
SendToNone |  | 0
SendOnlyToAll |  | 1
SendToAllAndSaveCopy |  | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalendarItemType Class

For a list of all members of this type, see CalendarItemType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ItemType
Aspose.Email.Exchange.Schema.Exchange_2013.CalendarItemType

public class CalendarItemType : ItemType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CalendarItemType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalendarItemType Members

CalendarItemType overview

Public Instance Constructors

CalendarItemType Constructor Initializes a new instance of the CalendarItemType class.

Public Instance Properties

AdjacentMeetingCount
AdjacentMeetingCountSpecified
AdjacentMeetings
AllowNewTimeProposal
AllowNewTimeProposalSpecified
AppointmentReplyTime
AppointmentReplyTimeSpecified
AppointmentSequenceNumber
AppointmentSequenceNumberSpecified
AppointmentState
AppointmentStateSpecified
ArchiveTag (inherited from ItemType)
Attachments (inherited from ItemType)
BlockStatus (inherited from ItemType)
BlockStatusSpecified (inherited from ItemType)
Body (inherited from ItemType)
CalendarItemType1
CalendarItemType1Specified
Categories (inherited from ItemType)
ConferenceType
ConferenceTypeSpecified
ConflictingMeetingCount
ConflictingMeetingCountSpecified
ConflictingMeetings
ConversationId (inherited from ItemType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DateTimeStamp
DateTimeStampSpecified
DeletedOccurrences
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
Duration
EffectiveRights (inherited from ItemType)
End
EndSpecified
EndTimeZone
EndTimeZoneId
EndWallClock
EndWallClockSpecified
EnhancedLocation
EntityExtractionResult (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
FirstOccurrence
Flag (inherited from ItemType)
GroupingAction (inherited from ItemType)
GroupingActionSpecified (inherited from ItemType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBlockedImages (inherited from ItemType)
HasBlockedImagesSpecified (inherited from ItemType)
IconIndex (inherited from ItemType)
IconIndexSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InstanceKey (inherited from ItemType)
IntendedFreeBusyStatus
IntendedFreeBusyStatusSpecified
InternetMessageHeaders (inherited from ItemType)
IsAllDayEvent
IsAllDayEventSpecified
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsCancelled
IsCancelledSpecified
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsMeeting
IsMeetingSpecified
IsOnlineMeeting
IsOnlineMeetingSpecified
IsOrganizer
IsOrganizerSpecified
IsRecurring
IsRecurringSpecified
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested
IsResponseRequestedSpecified
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
JoinOnlineMeetingUrl
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
LastOccurrence
LegacyFreeBusyStatus
LegacyFreeBusyStatusSpecified
Location
MeetingRequestWasSent
MeetingRequestWasSentSpecified
MeetingTimeZone
MeetingWorkspaceUrl
MimeContent (inherited from ItemType)
ModifiedOccurrences
MyResponseType
MyResponseTypeSpecified
NetShowUrl
NextPredictedAction (inherited from ItemType)
NextPredictedActionSpecified (inherited from ItemType)
NormalizedBody (inherited from ItemType)
OnlineMeetingSettings
OptionalAttendees
Organizer
OriginalStart
OriginalStartSpecified
ParentFolderId (inherited from ItemType)
PolicyTag (inherited from ItemType)
Preview (inherited from ItemType)
Recurrence
RecurrenceId
RecurrenceIdSpecified
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReminderNextTime (inherited from ItemType)
ReminderNextTimeSpecified (inherited from ItemType)
RequiredAttendees
Resources
ResponseObjects (inherited from ItemType)
RetentionDate (inherited from ItemType)
RetentionDateSpecified (inherited from ItemType)
RightsManagementLicenseData (inherited from ItemType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
Start
StartSpecified
StartTimeZone
StartTimeZoneId
StartWallClock
StartWallClockSpecified
StoreEntryId (inherited from ItemType)
Subject (inherited from ItemType)
TextBody (inherited from ItemType)
TimeZone
UID
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)
When

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalendarItemType Constructor

Initializes a new instance of the CalendarItemType class.

public CalendarItemType();

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalendarItemType Properties

The properties of the CalendarItemType class are listed below. For a complete list of CalendarItemType class members, see the CalendarItemType Members topic.

Public Instance Properties

AdjacentMeetingCount
AdjacentMeetingCountSpecified
AdjacentMeetings
AllowNewTimeProposal
AllowNewTimeProposalSpecified
AppointmentReplyTime
AppointmentReplyTimeSpecified
AppointmentSequenceNumber
AppointmentSequenceNumberSpecified
AppointmentState
AppointmentStateSpecified
ArchiveTag (inherited from ItemType)
Attachments (inherited from ItemType)
BlockStatus (inherited from ItemType)
BlockStatusSpecified (inherited from ItemType)
Body (inherited from ItemType)
CalendarItemType1
CalendarItemType1Specified
Categories (inherited from ItemType)
ConferenceType
ConferenceTypeSpecified
ConflictingMeetingCount
ConflictingMeetingCountSpecified
ConflictingMeetings
ConversationId (inherited from ItemType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DateTimeStamp
DateTimeStampSpecified
DeletedOccurrences
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
Duration
EffectiveRights (inherited from ItemType)
End
EndSpecified
EndTimeZone
EndTimeZoneId
EndWallClock
EndWallClockSpecified
EnhancedLocation
EntityExtractionResult (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
FirstOccurrence
Flag (inherited from ItemType)
GroupingAction (inherited from ItemType)
GroupingActionSpecified (inherited from ItemType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBlockedImages (inherited from ItemType)
HasBlockedImagesSpecified (inherited from ItemType)
IconIndex (inherited from ItemType)
IconIndexSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InstanceKey (inherited from ItemType)
IntendedFreeBusyStatus
IntendedFreeBusyStatusSpecified
InternetMessageHeaders (inherited from ItemType)
IsAllDayEvent
IsAllDayEventSpecified
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsCancelled
IsCancelledSpecified
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsMeeting
IsMeetingSpecified
IsOnlineMeeting
IsOnlineMeetingSpecified
IsOrganizer
IsOrganizerSpecified
IsRecurring
IsRecurringSpecified
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested
IsResponseRequestedSpecified
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
JoinOnlineMeetingUrl
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
LastOccurrence
LegacyFreeBusyStatus
LegacyFreeBusyStatusSpecified
Location
MeetingRequestWasSent
MeetingRequestWasSentSpecified
MeetingTimeZone
MeetingWorkspaceUrl
MimeContent (inherited from ItemType)
ModifiedOccurrences
MyResponseType
MyResponseTypeSpecified
NetShowUrl
NextPredictedAction (inherited from ItemType)
NextPredictedActionSpecified (inherited from ItemType)
NormalizedBody (inherited from ItemType)
OnlineMeetingSettings
OptionalAttendees
Organizer
OriginalStart
OriginalStartSpecified
ParentFolderId (inherited from ItemType)
PolicyTag (inherited from ItemType)
Preview (inherited from ItemType)
Recurrence
RecurrenceId
RecurrenceIdSpecified
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReminderNextTime (inherited from ItemType)
ReminderNextTimeSpecified (inherited from ItemType)
RequiredAttendees
Resources
ResponseObjects (inherited from ItemType)
RetentionDate (inherited from ItemType)
RetentionDateSpecified (inherited from ItemType)
RightsManagementLicenseData (inherited from ItemType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
Start
StartSpecified
StartTimeZone
StartTimeZoneId
StartWallClock
StartWallClockSpecified
StoreEntryId (inherited from ItemType)
Subject (inherited from ItemType)
TextBody (inherited from ItemType)
TimeZone
UID
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)
When

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AdjacentMeetingCount Property

Aspose.Email

CalendarItemType.AdjacentMeetingCount Property

public int AdjacentMeetingCount {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AdjacentMeetingCountSpecified Property

Aspose.Email

CalendarItemType.AdjacentMeetingCountSpecified Property

public bool AdjacentMeetingCountSpecified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AdjacentMeetings Property

Aspose.Email

CalendarItemType.AdjacentMeetings Property

public NonEmptyArrayOfAllItemsType AdjacentMeetings {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AllowNewTimeProposal Property

Aspose.Email

CalendarItemType.AllowNewTimeProposal Property

public bool AllowNewTimeProposal {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AllowNewTimeProposalSpecified Property

Aspose.Email

CalendarItemType.AllowNewTimeProposalSpecified Property

public bool AllowNewTimeProposalSpecified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AppointmentReplyTime Property

Aspose.Email

CalendarItemType.AppointmentReplyTime Property

public DateTime AppointmentReplyTime {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AppointmentReplyTimeSpecified Property

Aspose.Email

CalendarItemType.AppointmentReplyTimeSpecified Property

public bool AppointmentReplyTimeSpecified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AppointmentSequenceNumber Property

Aspose.Email

CalendarItemType.AppointmentSequenceNumber Property

public int AppointmentSequenceNumber {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AppointmentSequenceNumberSpecified Property

Aspose.Email

CalendarItemType.AppointmentSequenceNumberSpecified Property

public bool AppointmentSequenceNumberSpecified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AppointmentState Property

Aspose.Email

CalendarItemType.AppointmentState Property

public int AppointmentState {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AppointmentStateSpecified Property

Aspose.Email

CalendarItemType.AppointmentStateSpecified Property

public bool AppointmentStateSpecified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalendarItemType1 Property

Aspose.Email

CalendarItemType.CalendarItemType1 Property

public CalendarItemTypeType CalendarItemType1 {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalendarItemType1Specified Property

Aspose.Email

CalendarItemType.CalendarItemType1Specified Property

public bool CalendarItemType1Specified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConferenceType Property

Aspose.Email

CalendarItemType.ConferenceType Property

public int ConferenceType {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConferenceTypeSpecified Property

Aspose.Email

CalendarItemType.ConferenceTypeSpecified Property

public bool ConferenceTypeSpecified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConflictingMeetingCount Property

Aspose.Email

CalendarItemType.ConflictingMeetingCount Property

public int ConflictingMeetingCount {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConflictingMeetingCountSpecified Property

Aspose.Email

CalendarItemType.ConflictingMeetingCountSpecified Property

public bool ConflictingMeetingCountSpecified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConflictingMeetings Property

Aspose.Email

CalendarItemType.ConflictingMeetings Property

public NonEmptyArrayOfAllItemsType ConflictingMeetings {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DateTimeStamp Property

Aspose.Email

CalendarItemType.DateTimeStamp Property

public DateTime DateTimeStamp {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DateTimeStampSpecified Property

Aspose.Email

CalendarItemType.DateTimeStampSpecified Property

public bool DateTimeStampSpecified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeletedOccurrences Property

Aspose.Email

CalendarItemType.DeletedOccurrences Property

public DeletedOccurrenceInfoType[] DeletedOccurrences {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Duration Property

Aspose.Email

CalendarItemType.Duration Property

public string Duration {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


End Property

Aspose.Email

CalendarItemType.End Property

public DateTime End {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EndSpecified Property

Aspose.Email

CalendarItemType.EndSpecified Property

public bool EndSpecified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EndTimeZone Property

Aspose.Email

CalendarItemType.EndTimeZone Property

public TimeZoneDefinitionType EndTimeZone {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EndTimeZoneId Property

Aspose.Email

CalendarItemType.EndTimeZoneId Property

public string EndTimeZoneId {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EndWallClock Property

Aspose.Email

CalendarItemType.EndWallClock Property

public DateTime EndWallClock {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EndWallClockSpecified Property

Aspose.Email

CalendarItemType.EndWallClockSpecified Property

public bool EndWallClockSpecified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EnhancedLocation Property

Aspose.Email

CalendarItemType.EnhancedLocation Property

public EnhancedLocationType EnhancedLocation {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FirstOccurrence Property

Aspose.Email

CalendarItemType.FirstOccurrence Property

public OccurrenceInfoType FirstOccurrence {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IntendedFreeBusyStatus Property

Aspose.Email

CalendarItemType.IntendedFreeBusyStatus Property

public LegacyFreeBusyType IntendedFreeBusyStatus {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IntendedFreeBusyStatusSpecified Property

Aspose.Email

CalendarItemType.IntendedFreeBusyStatusSpecified Property

public bool IntendedFreeBusyStatusSpecified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsAllDayEvent Property

Aspose.Email

CalendarItemType.IsAllDayEvent Property

public bool IsAllDayEvent {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsAllDayEventSpecified Property

Aspose.Email

CalendarItemType.IsAllDayEventSpecified Property

public bool IsAllDayEventSpecified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsCancelled Property

Aspose.Email

CalendarItemType.IsCancelled Property

public bool IsCancelled {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsCancelledSpecified Property

Aspose.Email

CalendarItemType.IsCancelledSpecified Property

public bool IsCancelledSpecified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsMeeting Property

Aspose.Email

CalendarItemType.IsMeeting Property

public bool IsMeeting {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsMeetingSpecified Property

Aspose.Email

CalendarItemType.IsMeetingSpecified Property

public bool IsMeetingSpecified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsOnlineMeeting Property

Aspose.Email

CalendarItemType.IsOnlineMeeting Property

public bool IsOnlineMeeting {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsOnlineMeetingSpecified Property

Aspose.Email

CalendarItemType.IsOnlineMeetingSpecified Property

public bool IsOnlineMeetingSpecified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsOrganizer Property

Aspose.Email

CalendarItemType.IsOrganizer Property

public bool IsOrganizer {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsOrganizerSpecified Property

Aspose.Email

CalendarItemType.IsOrganizerSpecified Property

public bool IsOrganizerSpecified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsRecurring Property

Aspose.Email

CalendarItemType.IsRecurring Property

public bool IsRecurring {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsRecurringSpecified Property

Aspose.Email

CalendarItemType.IsRecurringSpecified Property

public bool IsRecurringSpecified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsResponseRequested Property

Aspose.Email

CalendarItemType.IsResponseRequested Property

public bool IsResponseRequested {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsResponseRequestedSpecified Property

Aspose.Email

CalendarItemType.IsResponseRequestedSpecified Property

public bool IsResponseRequestedSpecified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


JoinOnlineMeetingUrl Property

Aspose.Email

CalendarItemType.JoinOnlineMeetingUrl Property

public string JoinOnlineMeetingUrl {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


LastOccurrence Property

Aspose.Email

CalendarItemType.LastOccurrence Property

public OccurrenceInfoType LastOccurrence {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


LegacyFreeBusyStatus Property

Aspose.Email

CalendarItemType.LegacyFreeBusyStatus Property

public LegacyFreeBusyType LegacyFreeBusyStatus {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


LegacyFreeBusyStatusSpecified Property

Aspose.Email

CalendarItemType.LegacyFreeBusyStatusSpecified Property

public bool LegacyFreeBusyStatusSpecified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Location Property

Aspose.Email

CalendarItemType.Location Property

public string Location {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MeetingRequestWasSent Property

Aspose.Email

CalendarItemType.MeetingRequestWasSent Property

public bool MeetingRequestWasSent {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MeetingRequestWasSentSpecified Property

Aspose.Email

CalendarItemType.MeetingRequestWasSentSpecified Property

public bool MeetingRequestWasSentSpecified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MeetingTimeZone Property

Aspose.Email

CalendarItemType.MeetingTimeZone Property

public TimeZoneType MeetingTimeZone {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MeetingWorkspaceUrl Property

Aspose.Email

CalendarItemType.MeetingWorkspaceUrl Property

public string MeetingWorkspaceUrl {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ModifiedOccurrences Property

Aspose.Email

CalendarItemType.ModifiedOccurrences Property

public OccurrenceInfoType[] ModifiedOccurrences {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MyResponseType Property

Aspose.Email

CalendarItemType.MyResponseType Property

public ResponseTypeType MyResponseType {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MyResponseTypeSpecified Property

Aspose.Email

CalendarItemType.MyResponseTypeSpecified Property

public bool MyResponseTypeSpecified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NetShowUrl Property

Aspose.Email

CalendarItemType.NetShowUrl Property

public string NetShowUrl {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OnlineMeetingSettings Property

Aspose.Email

CalendarItemType.OnlineMeetingSettings Property

public OnlineMeetingSettingsType OnlineMeetingSettings {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OptionalAttendees Property

Aspose.Email

CalendarItemType.OptionalAttendees Property

public AttendeeType[] OptionalAttendees {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Organizer Property

Aspose.Email

CalendarItemType.Organizer Property

public SingleRecipientType Organizer {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OriginalStart Property

Aspose.Email

CalendarItemType.OriginalStart Property

public DateTime OriginalStart {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OriginalStartSpecified Property

Aspose.Email

CalendarItemType.OriginalStartSpecified Property

public bool OriginalStartSpecified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Recurrence Property

Aspose.Email

CalendarItemType.Recurrence Property

public RecurrenceType Recurrence {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecurrenceId Property

Aspose.Email

CalendarItemType.RecurrenceId Property

public DateTime RecurrenceId {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecurrenceIdSpecified Property

Aspose.Email

CalendarItemType.RecurrenceIdSpecified Property

public bool RecurrenceIdSpecified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RequiredAttendees Property

Aspose.Email

CalendarItemType.RequiredAttendees Property

public AttendeeType[] RequiredAttendees {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Resources Property

Aspose.Email

CalendarItemType.Resources Property

public AttendeeType[] Resources {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Start Property

Aspose.Email

CalendarItemType.Start Property

public DateTime Start {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StartSpecified Property

Aspose.Email

CalendarItemType.StartSpecified Property

public bool StartSpecified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StartTimeZone Property

Aspose.Email

CalendarItemType.StartTimeZone Property

public TimeZoneDefinitionType StartTimeZone {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StartTimeZoneId Property

Aspose.Email

CalendarItemType.StartTimeZoneId Property

public string StartTimeZoneId {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StartWallClock Property

Aspose.Email

CalendarItemType.StartWallClock Property

public DateTime StartWallClock {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StartWallClockSpecified Property

Aspose.Email

CalendarItemType.StartWallClockSpecified Property

public bool StartWallClockSpecified {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TimeZone Property

Aspose.Email

CalendarItemType.TimeZone Property

public string TimeZone {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UID Property

Aspose.Email

CalendarItemType.UID Property

public string UID {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


When Property

Aspose.Email

CalendarItemType.When Property

public string When {get; set;}

Remarks

See Also

CalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalendarItemTypeType Enumeration

public enum CalendarItemTypeType

Remarks

Members

Member Name | Description | Value
Single |  | 0
Occurrence |  | 1
Exception |  | 2
RecurringMaster |  | 3

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalendarItemUpdateOperationType Enumeration

public enum CalendarItemUpdateOperationType

Remarks

Members

Member Name | Description | Value
SendToNone |  | 0
SendOnlyToAll |  | 1
SendOnlyToChanged |  | 2
SendToAllAndSaveCopy |  | 3
SendToChangedAndSaveCopy |  | 4

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalendarPermissionLevelType Enumeration

public enum CalendarPermissionLevelType

Remarks

Members

Member Name | Description | Value
None |  | 0
Owner |  | 1
PublishingEditor |  | 2
Editor |  | 3
PublishingAuthor |  | 4
Author |  | 5
NoneditingAuthor |  | 6
Reviewer |  | 7
Contributor |  | 8
FreeBusyTimeOnly |  | 9
FreeBusyTimeAndSubjectAndLocation |  | 10
Custom |  | 11

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalendarPermissionReadAccessType Enumeration

public enum CalendarPermissionReadAccessType

Remarks

Members

Member Name | Description | Value
None |  | 0
TimeOnly |  | 1
TimeAndSubjectAndLocation |  | 2
FullDetails |  | 3

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalendarPermissionSetType Class

For a list of all members of this type, see CalendarPermissionSetType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.CalendarPermissionSetType

public class CalendarPermissionSetType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CalendarPermissionSetType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalendarPermissionSetType Members

CalendarPermissionSetType overview

Public Instance Constructors

CalendarPermissionSetType Constructor Initializes a new instance of the CalendarPermissionSetType class.

Public Instance Properties

CalendarPermissions
UnknownEntries

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CalendarPermissionSetType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalendarPermissionSetType Constructor

Initializes a new instance of the CalendarPermissionSetType class.

public CalendarPermissionSetType();

See Also

CalendarPermissionSetType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalendarPermissionSetType Properties

The properties of the CalendarPermissionSetType class are listed below. For a complete list of CalendarPermissionSetType class members, see the CalendarPermissionSetType Members topic.

Public Instance Properties

CalendarPermissions
UnknownEntries

See Also

CalendarPermissionSetType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalendarPermissions Property

Aspose.Email

CalendarPermissionSetType.CalendarPermissions Property

public CalendarPermissionType[] CalendarPermissions {get; set;}

Remarks

See Also

CalendarPermissionSetType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UnknownEntries Property

Aspose.Email

CalendarPermissionSetType.UnknownEntries Property

public string[] UnknownEntries {get; set;}

Remarks

See Also

CalendarPermissionSetType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalendarPermissionType Class

For a list of all members of this type, see CalendarPermissionType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BasePermissionType
Aspose.Email.Exchange.Schema.Exchange_2013.CalendarPermissionType

public class CalendarPermissionType : BasePermissionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CalendarPermissionType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalendarPermissionType Members

CalendarPermissionType overview

Public Instance Constructors

CalendarPermissionType Constructor Initializes a new instance of the CalendarPermissionType class.

Public Instance Properties

CalendarPermissionLevel
CanCreateItems (inherited from BasePermissionType)
CanCreateItemsSpecified (inherited from BasePermissionType)
CanCreateSubFolders (inherited from BasePermissionType)
CanCreateSubFoldersSpecified (inherited from BasePermissionType)
DeleteItems (inherited from BasePermissionType)
DeleteItemsSpecified (inherited from BasePermissionType)
EditItems (inherited from BasePermissionType)
EditItemsSpecified (inherited from BasePermissionType)
IsFolderContact (inherited from BasePermissionType)
IsFolderContactSpecified (inherited from BasePermissionType)
IsFolderOwner (inherited from BasePermissionType)
IsFolderOwnerSpecified (inherited from BasePermissionType)
IsFolderVisible (inherited from BasePermissionType)
IsFolderVisibleSpecified (inherited from BasePermissionType)
ReadItems
ReadItemsSpecified
UserId (inherited from BasePermissionType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CalendarPermissionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalendarPermissionType Constructor

Initializes a new instance of the CalendarPermissionType class.

public CalendarPermissionType();

See Also

CalendarPermissionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalendarPermissionType Properties

The properties of the CalendarPermissionType class are listed below. For a complete list of CalendarPermissionType class members, see the CalendarPermissionType Members topic.

Public Instance Properties

CalendarPermissionLevel
CanCreateItems (inherited from BasePermissionType)
CanCreateItemsSpecified (inherited from BasePermissionType)
CanCreateSubFolders (inherited from BasePermissionType)
CanCreateSubFoldersSpecified (inherited from BasePermissionType)
DeleteItems (inherited from BasePermissionType)
DeleteItemsSpecified (inherited from BasePermissionType)
EditItems (inherited from BasePermissionType)
EditItemsSpecified (inherited from BasePermissionType)
IsFolderContact (inherited from BasePermissionType)
IsFolderContactSpecified (inherited from BasePermissionType)
IsFolderOwner (inherited from BasePermissionType)
IsFolderOwnerSpecified (inherited from BasePermissionType)
IsFolderVisible (inherited from BasePermissionType)
IsFolderVisibleSpecified (inherited from BasePermissionType)
ReadItems
ReadItemsSpecified
UserId (inherited from BasePermissionType)

See Also

CalendarPermissionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalendarPermissionLevel Property

Aspose.Email

CalendarPermissionType.CalendarPermissionLevel Property

public CalendarPermissionLevelType CalendarPermissionLevel {get; set;}

Remarks

See Also

CalendarPermissionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReadItems Property

Aspose.Email

CalendarPermissionType.ReadItems Property

public CalendarPermissionReadAccessType ReadItems {get; set;}

Remarks

See Also

CalendarPermissionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReadItemsSpecified Property

Aspose.Email

CalendarPermissionType.ReadItemsSpecified Property

public bool ReadItemsSpecified {get; set;}

Remarks

See Also

CalendarPermissionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalendarViewType Class

For a list of all members of this type, see CalendarViewType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BasePagingType
Aspose.Email.Exchange.Schema.Exchange_2013.CalendarViewType

public class CalendarViewType : BasePagingType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CalendarViewType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalendarViewType Members

CalendarViewType overview

Public Instance Constructors

CalendarViewType Constructor Initializes a new instance of the CalendarViewType class.

Public Instance Properties

EndDate
MaxEntriesReturned (inherited from BasePagingType)
MaxEntriesReturnedSpecified (inherited from BasePagingType)
StartDate

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CalendarViewType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalendarViewType Constructor

Initializes a new instance of the CalendarViewType class.

public CalendarViewType();

See Also

CalendarViewType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalendarViewType Properties

The properties of the CalendarViewType class are listed below. For a complete list of CalendarViewType class members, see the CalendarViewType Members topic.

Public Instance Properties

EndDate
MaxEntriesReturned (inherited from BasePagingType)
MaxEntriesReturnedSpecified (inherited from BasePagingType)
StartDate

See Also

CalendarViewType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EndDate Property

Aspose.Email

CalendarViewType.EndDate Property

public DateTime EndDate {get; set;}

Remarks

See Also

CalendarViewType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StartDate Property

Aspose.Email

CalendarViewType.StartDate Property

public DateTime StartDate {get; set;}

Remarks

See Also

CalendarViewType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CancelCalendarItemType Class

For a list of all members of this type, see CancelCalendarItemType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ItemType
Aspose.Email.Exchange.Schema.Exchange_2013.MessageType
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseObjectCoreType
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseObjectType
Aspose.Email.Exchange.Schema.Exchange_2013.SmartResponseBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.SmartResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.CancelCalendarItemType

public class CancelCalendarItemType : SmartResponseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CancelCalendarItemType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CancelCalendarItemType Members

CancelCalendarItemType overview

Public Instance Constructors

CancelCalendarItemType Constructor Initializes a new instance of the CancelCalendarItemType class.

Public Instance Properties

ArchiveTag (inherited from ItemType)
Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
BlockStatus (inherited from ItemType)
BlockStatusSpecified (inherited from ItemType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
EntityExtractionResult (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
Flag (inherited from ItemType)
From (inherited from MessageType)
GroupingAction (inherited from ItemType)
GroupingActionSpecified (inherited from ItemType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBlockedImages (inherited from ItemType)
HasBlockedImagesSpecified (inherited from ItemType)
IconIndex (inherited from ItemType)
IconIndexSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InstanceKey (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
NewBodyContent (inherited from SmartResponseType)
NextPredictedAction (inherited from ItemType)
NextPredictedActionSpecified (inherited from ItemType)
NormalizedBody (inherited from ItemType)
ObjectName (inherited from ResponseObjectType)
ParentFolderId (inherited from ItemType)
PolicyTag (inherited from ItemType)
Preview (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
ReferenceItemId (inherited from ResponseObjectCoreType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReminderNextTime (inherited from ItemType)
ReminderNextTimeSpecified (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
RetentionDate (inherited from ItemType)
RetentionDateSpecified (inherited from ItemType)
RightsManagementLicenseData (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
StoreEntryId (inherited from ItemType)
Subject (inherited from ItemType)
TextBody (inherited from ItemType)
ToRecipients (inherited from MessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CancelCalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CancelCalendarItemType Constructor

Initializes a new instance of the CancelCalendarItemType class.

public CancelCalendarItemType();

See Also

CancelCalendarItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CDRDataType Class

For a list of all members of this type, see CDRDataType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.CDRDataType

public class CDRDataType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CDRDataType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CDRDataType Members

CDRDataType overview

Public Instance Constructors

CDRDataType Constructor Initializes a new instance of the CDRDataType class.

Public Instance Properties

AudioQualityMetrics
AutoAttendantName
CallDuration
CalledPhoneNumber
CalleeLegacyExchangeDN
CalleeMailboxAlias
CallerLegacyExchangeDN
CallerMailboxAlias
CallerPhoneNumber
CallIdentity
CallStartTime
CallType
CreationTime
DialedString
DialPlanGuid
DialPlanName
DropCallReason
GatewayGuid
IPGatewayAddress
IPGatewayName
OfferResult
ParentCallIdentity
ReasonForCall
TransferredNumber
UMServerName

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CDRDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CDRDataType Constructor

Initializes a new instance of the CDRDataType class.

public CDRDataType();

See Also

CDRDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CDRDataType Properties

The properties of the CDRDataType class are listed below. For a complete list of CDRDataType class members, see the CDRDataType Members topic.

Public Instance Properties

AudioQualityMetrics
AutoAttendantName
CallDuration
CalledPhoneNumber
CalleeLegacyExchangeDN
CalleeMailboxAlias
CallerLegacyExchangeDN
CallerMailboxAlias
CallerPhoneNumber
CallIdentity
CallStartTime
CallType
CreationTime
DialedString
DialPlanGuid
DialPlanName
DropCallReason
GatewayGuid
IPGatewayAddress
IPGatewayName
OfferResult
ParentCallIdentity
ReasonForCall
TransferredNumber
UMServerName

See Also

CDRDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AudioQualityMetrics Property

Aspose.Email

CDRDataType.AudioQualityMetrics Property

public AudioQualityType AudioQualityMetrics {get; set;}

Remarks

See Also

CDRDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AutoAttendantName Property

Aspose.Email

CDRDataType.AutoAttendantName Property

public string AutoAttendantName {get; set;}

Remarks

See Also

CDRDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CallDuration Property

Aspose.Email

CDRDataType.CallDuration Property

public int CallDuration {get; set;}

Remarks

See Also

CDRDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalledPhoneNumber Property

Aspose.Email

CDRDataType.CalledPhoneNumber Property

public string CalledPhoneNumber {get; set;}

Remarks

See Also

CDRDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalleeLegacyExchangeDN Property

Aspose.Email

CDRDataType.CalleeLegacyExchangeDN Property

public string CalleeLegacyExchangeDN {get; set;}

Remarks

See Also

CDRDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalleeMailboxAlias Property

Aspose.Email

CDRDataType.CalleeMailboxAlias Property

public string CalleeMailboxAlias {get; set;}

Remarks

See Also

CDRDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CallerLegacyExchangeDN Property

Aspose.Email

CDRDataType.CallerLegacyExchangeDN Property

public string CallerLegacyExchangeDN {get; set;}

Remarks

See Also

CDRDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CallerMailboxAlias Property

Aspose.Email

CDRDataType.CallerMailboxAlias Property

public string CallerMailboxAlias {get; set;}

Remarks

See Also

CDRDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CallerPhoneNumber Property

Aspose.Email

CDRDataType.CallerPhoneNumber Property

public string CallerPhoneNumber {get; set;}

Remarks

See Also

CDRDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CallIdentity Property

Aspose.Email

CDRDataType.CallIdentity Property

public string CallIdentity {get; set;}

Remarks

See Also

CDRDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CallStartTime Property

Aspose.Email

CDRDataType.CallStartTime Property

public DateTime CallStartTime {get; set;}

Remarks

See Also

CDRDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CallType Property

Aspose.Email

CDRDataType.CallType Property

public string CallType {get; set;}

Remarks

See Also

CDRDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreationTime Property

Aspose.Email

CDRDataType.CreationTime Property

public DateTime CreationTime {get; set;}

Remarks

See Also

CDRDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DialedString Property

Aspose.Email

CDRDataType.DialedString Property

public string DialedString {get; set;}

Remarks

See Also

CDRDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DialPlanGuid Property

Aspose.Email

CDRDataType.DialPlanGuid Property

public string DialPlanGuid {get; set;}

Remarks

See Also

CDRDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DialPlanName Property

Aspose.Email

CDRDataType.DialPlanName Property

public string DialPlanName {get; set;}

Remarks

See Also

CDRDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DropCallReason Property

Aspose.Email

CDRDataType.DropCallReason Property

public string DropCallReason {get; set;}

Remarks

See Also

CDRDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GatewayGuid Property

Aspose.Email

CDRDataType.GatewayGuid Property

public string GatewayGuid {get; set;}

Remarks

See Also

CDRDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IPGatewayAddress Property

Aspose.Email

CDRDataType.IPGatewayAddress Property

public string IPGatewayAddress {get; set;}

Remarks

See Also

CDRDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IPGatewayName Property

Aspose.Email

CDRDataType.IPGatewayName Property

public string IPGatewayName {get; set;}

Remarks

See Also

CDRDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OfferResult Property

Aspose.Email

CDRDataType.OfferResult Property

public string OfferResult {get; set;}

Remarks

See Also

CDRDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ParentCallIdentity Property

Aspose.Email

CDRDataType.ParentCallIdentity Property

public string ParentCallIdentity {get; set;}

Remarks

See Also

CDRDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReasonForCall Property

Aspose.Email

CDRDataType.ReasonForCall Property

public string ReasonForCall {get; set;}

Remarks

See Also

CDRDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TransferredNumber Property

Aspose.Email

CDRDataType.TransferredNumber Property

public string TransferredNumber {get; set;}

Remarks

See Also

CDRDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UMServerName Property

Aspose.Email

CDRDataType.UMServerName Property

public string UMServerName {get; set;}

Remarks

See Also

CDRDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ChangeDescriptionType Class

For a list of all members of this type, see ChangeDescriptionType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ChangeDescriptionType
Aspose.Email.Exchange.Schema.Exchange_2013.FolderChangeDescriptionType
Aspose.Email.Exchange.Schema.Exchange_2013.ItemChangeDescriptionType

public abstract class ChangeDescriptionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ChangeDescriptionType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ChangeDescriptionType Members

ChangeDescriptionType overview

Public Instance Properties

Item

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

ChangeDescriptionType Constructor Initializes a new instance of the ChangeDescriptionType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ChangeDescriptionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ChangeDescriptionType Constructor

Initializes a new instance of the ChangeDescriptionType class.

protected ChangeDescriptionType();

See Also

ChangeDescriptionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ChangeDescriptionType Properties

The properties of the ChangeDescriptionType class are listed below. For a complete list of ChangeDescriptionType class members, see the ChangeDescriptionType Members topic.

Public Instance Properties

Item

See Also

ChangeDescriptionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Item Property

Aspose.Email

ChangeDescriptionType.Item Property

public BasePathToElementType Item {get; set;}

Remarks

See Also

ChangeDescriptionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ChangeHighlightsType Class

For a list of all members of this type, see ChangeHighlightsType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ChangeHighlightsType

public class ChangeHighlightsType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ChangeHighlightsType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ChangeHighlightsType Members

ChangeHighlightsType overview

Public Instance Constructors

ChangeHighlightsType Constructor Initializes a new instance of the ChangeHighlightsType class.

Public Instance Properties

End
EndSpecified
HasEndTimeChanged
HasEndTimeChangedSpecified
HasLocationChanged
HasLocationChangedSpecified
HasStartTimeChanged
HasStartTimeChangedSpecified
Location
Start
StartSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ChangeHighlightsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ChangeHighlightsType Constructor

Initializes a new instance of the ChangeHighlightsType class.

public ChangeHighlightsType();

See Also

ChangeHighlightsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ChangeHighlightsType Properties

The properties of the ChangeHighlightsType class are listed below. For a complete list of ChangeHighlightsType class members, see the ChangeHighlightsType Members topic.

Public Instance Properties

End
EndSpecified
HasEndTimeChanged
HasEndTimeChangedSpecified
HasLocationChanged
HasLocationChangedSpecified
HasStartTimeChanged
HasStartTimeChangedSpecified
Location
Start
StartSpecified

See Also

ChangeHighlightsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


End Property

Aspose.Email

ChangeHighlightsType.End Property

public DateTime End {get; set;}

Remarks

See Also

ChangeHighlightsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EndSpecified Property

Aspose.Email

ChangeHighlightsType.EndSpecified Property

public bool EndSpecified {get; set;}

Remarks

See Also

ChangeHighlightsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


HasEndTimeChanged Property

Aspose.Email

ChangeHighlightsType.HasEndTimeChanged Property

public bool HasEndTimeChanged {get; set;}

Remarks

See Also

ChangeHighlightsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


HasEndTimeChangedSpecified Property

Aspose.Email

ChangeHighlightsType.HasEndTimeChangedSpecified Property

public bool HasEndTimeChangedSpecified {get; set;}

Remarks

See Also

ChangeHighlightsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


HasLocationChanged Property

Aspose.Email

ChangeHighlightsType.HasLocationChanged Property

public bool HasLocationChanged {get; set;}

Remarks

See Also

ChangeHighlightsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


HasLocationChangedSpecified Property

Aspose.Email

ChangeHighlightsType.HasLocationChangedSpecified Property

public bool HasLocationChangedSpecified {get; set;}

Remarks

See Also

ChangeHighlightsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


HasStartTimeChanged Property

Aspose.Email

ChangeHighlightsType.HasStartTimeChanged Property

public bool HasStartTimeChanged {get; set;}

Remarks

See Also

ChangeHighlightsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


HasStartTimeChangedSpecified Property

Aspose.Email

ChangeHighlightsType.HasStartTimeChangedSpecified Property

public bool HasStartTimeChangedSpecified {get; set;}

Remarks

See Also

ChangeHighlightsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Location Property

Aspose.Email

ChangeHighlightsType.Location Property

public string Location {get; set;}

Remarks

See Also

ChangeHighlightsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Start Property

Aspose.Email

ChangeHighlightsType.Start Property

public DateTime Start {get; set;}

Remarks

See Also

ChangeHighlightsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StartSpecified Property

Aspose.Email

ChangeHighlightsType.StartSpecified Property

public bool StartSpecified {get; set;}

Remarks

See Also

ChangeHighlightsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ClientAccessTokenRequestType Class

For a list of all members of this type, see ClientAccessTokenRequestType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ClientAccessTokenRequestType

public class ClientAccessTokenRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ClientAccessTokenRequestType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ClientAccessTokenRequestType Members

ClientAccessTokenRequestType overview

Public Instance Constructors

ClientAccessTokenRequestType Constructor Initializes a new instance of the ClientAccessTokenRequestType class.

Public Instance Properties

Id
TokenType

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ClientAccessTokenRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ClientAccessTokenRequestType Constructor

Initializes a new instance of the ClientAccessTokenRequestType class.

public ClientAccessTokenRequestType();

See Also

ClientAccessTokenRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ClientAccessTokenRequestType Properties

The properties of the ClientAccessTokenRequestType class are listed below. For a complete list of ClientAccessTokenRequestType class members, see the ClientAccessTokenRequestType Members topic.

Public Instance Properties

Id
TokenType

See Also

ClientAccessTokenRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Id Property

Aspose.Email

ClientAccessTokenRequestType.Id Property

public string Id {get; set;}

Remarks

See Also

ClientAccessTokenRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TokenType Property

Aspose.Email

ClientAccessTokenRequestType.TokenType Property

public ClientAccessTokenTypeType TokenType {get; set;}

Remarks

See Also

ClientAccessTokenRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ClientAccessTokenType Class

For a list of all members of this type, see ClientAccessTokenType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ClientAccessTokenType

public class ClientAccessTokenType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ClientAccessTokenType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ClientAccessTokenType Members

ClientAccessTokenType overview

Public Instance Constructors

ClientAccessTokenType Constructor Initializes a new instance of the ClientAccessTokenType class.

Public Instance Properties

Id
TokenType
TokenValue
TTL

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ClientAccessTokenType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ClientAccessTokenType Constructor

Initializes a new instance of the ClientAccessTokenType class.

public ClientAccessTokenType();

See Also

ClientAccessTokenType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ClientAccessTokenType Properties

The properties of the ClientAccessTokenType class are listed below. For a complete list of ClientAccessTokenType class members, see the ClientAccessTokenType Members topic.

Public Instance Properties

Id
TokenType
TokenValue
TTL

See Also

ClientAccessTokenType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Id Property

Aspose.Email

ClientAccessTokenType.Id Property

public string Id {get; set;}

Remarks

See Also

ClientAccessTokenType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TokenType Property

Aspose.Email

ClientAccessTokenType.TokenType Property

public ClientAccessTokenTypeType TokenType {get; set;}

Remarks

See Also

ClientAccessTokenType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TokenValue Property

Aspose.Email

ClientAccessTokenType.TokenValue Property

public string TokenValue {get; set;}

Remarks

See Also

ClientAccessTokenType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TTL Property

Aspose.Email

ClientAccessTokenType.TTL Property

public string TTL {get; set;}

Remarks

See Also

ClientAccessTokenType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ClientAccessTokenTypeType Enumeration

public enum ClientAccessTokenTypeType

Remarks

Members

Member Name | Description | Value
CallerIdentity |  | 0
ExtensionCallback |  | 1

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ClientExtensionProvidedToType Enumeration

public enum ClientExtensionProvidedToType

Remarks

Members

Member Name | Description | Value
Everyone |  | 0
SpecificUsers |  | 1

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ClientExtensionResponseType Class

For a list of all members of this type, see ClientExtensionResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.ClientExtensionResponseType

public class ClientExtensionResponseType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ClientExtensionResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ClientExtensionResponseType Members

ClientExtensionResponseType overview

Public Instance Constructors

ClientExtensionResponseType Constructor Initializes a new instance of the ClientExtensionResponseType class.

Public Instance Properties

ClientExtensions
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
RawMasterTableXml
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ClientExtensionResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ClientExtensionResponseType Constructor

Initializes a new instance of the ClientExtensionResponseType class.

public ClientExtensionResponseType();

See Also

ClientExtensionResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ClientExtensionResponseType Properties

The properties of the ClientExtensionResponseType class are listed below. For a complete list of ClientExtensionResponseType class members, see the ClientExtensionResponseType Members topic.

Public Instance Properties

ClientExtensions
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
RawMasterTableXml
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

ClientExtensionResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ClientExtensions Property

Aspose.Email

ClientExtensionResponseType.ClientExtensions Property

public ClientExtensionType[] ClientExtensions {get; set;}

Remarks

See Also

ClientExtensionResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RawMasterTableXml Property

Aspose.Email

ClientExtensionResponseType.RawMasterTableXml Property

public string RawMasterTableXml {get; set;}

Remarks

See Also

ClientExtensionResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ClientExtensionScopeType Enumeration

public enum ClientExtensionScopeType

Remarks

Members

Member Name | Description | Value
None |  | 0
User |  | 1
Organization |  | 2
Default |  | 3

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ClientExtensionType Class

For a list of all members of this type, see ClientExtensionType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ClientExtensionType

public class ClientExtensionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ClientExtensionType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ClientExtensionType Members

ClientExtensionType overview

Public Instance Constructors

ClientExtensionType Constructor Initializes a new instance of the ClientExtensionType class.

Public Instance Properties

IsAvailable
IsAvailableSpecified
IsEnabledByDefault
IsEnabledByDefaultSpecified
IsMandatory
IsMandatorySpecified
Manifest
MarketplaceAssetId
MarketplaceContentMarket
ProvidedTo
ProvidedToSpecified
Scope
ScopeSpecified
SpecificUsers
Type
TypeSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ClientExtensionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ClientExtensionType Constructor

Initializes a new instance of the ClientExtensionType class.

public ClientExtensionType();

See Also

ClientExtensionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ClientExtensionType Properties

The properties of the ClientExtensionType class are listed below. For a complete list of ClientExtensionType class members, see the ClientExtensionType Members topic.

Public Instance Properties

IsAvailable
IsAvailableSpecified
IsEnabledByDefault
IsEnabledByDefaultSpecified
IsMandatory
IsMandatorySpecified
Manifest
MarketplaceAssetId
MarketplaceContentMarket
ProvidedTo
ProvidedToSpecified
Scope
ScopeSpecified
SpecificUsers
Type
TypeSpecified

See Also

ClientExtensionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsAvailable Property

Aspose.Email

ClientExtensionType.IsAvailable Property

public bool IsAvailable {get; set;}

Remarks

See Also

ClientExtensionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsAvailableSpecified Property

Aspose.Email

ClientExtensionType.IsAvailableSpecified Property

public bool IsAvailableSpecified {get; set;}

Remarks

See Also

ClientExtensionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsEnabledByDefault Property

Aspose.Email

ClientExtensionType.IsEnabledByDefault Property

public bool IsEnabledByDefault {get; set;}

Remarks

See Also

ClientExtensionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsEnabledByDefaultSpecified Property

Aspose.Email

ClientExtensionType.IsEnabledByDefaultSpecified Property

public bool IsEnabledByDefaultSpecified {get; set;}

Remarks

See Also

ClientExtensionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsMandatory Property

Aspose.Email

ClientExtensionType.IsMandatory Property

public bool IsMandatory {get; set;}

Remarks

See Also

ClientExtensionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsMandatorySpecified Property

Aspose.Email

ClientExtensionType.IsMandatorySpecified Property

public bool IsMandatorySpecified {get; set;}

Remarks

See Also

ClientExtensionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Manifest Property

Aspose.Email

ClientExtensionType.Manifest Property

public byte[] Manifest {get; set;}

Remarks

See Also

ClientExtensionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MarketplaceAssetId Property

Aspose.Email

ClientExtensionType.MarketplaceAssetId Property

public string MarketplaceAssetId {get; set;}

Remarks

See Also

ClientExtensionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MarketplaceContentMarket Property

Aspose.Email

ClientExtensionType.MarketplaceContentMarket Property

public string MarketplaceContentMarket {get; set;}

Remarks

See Also

ClientExtensionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ProvidedTo Property

Aspose.Email

ClientExtensionType.ProvidedTo Property

public ClientExtensionProvidedToType ProvidedTo {get; set;}

Remarks

See Also

ClientExtensionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ProvidedToSpecified Property

Aspose.Email

ClientExtensionType.ProvidedToSpecified Property

public bool ProvidedToSpecified {get; set;}

Remarks

See Also

ClientExtensionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Scope Property

Aspose.Email

ClientExtensionType.Scope Property

public ClientExtensionScopeType Scope {get; set;}

Remarks

See Also

ClientExtensionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ScopeSpecified Property

Aspose.Email

ClientExtensionType.ScopeSpecified Property

public bool ScopeSpecified {get; set;}

Remarks

See Also

ClientExtensionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SpecificUsers Property

Aspose.Email

ClientExtensionType.SpecificUsers Property

public string[] SpecificUsers {get; set;}

Remarks

See Also

ClientExtensionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Type Property

Aspose.Email

ClientExtensionType.Type Property

public ClientExtensionTypeType Type {get; set;}

Remarks

See Also

ClientExtensionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TypeSpecified Property

Aspose.Email

ClientExtensionType.TypeSpecified Property

public bool TypeSpecified {get; set;}

Remarks

See Also

ClientExtensionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ClientExtensionTypeType Enumeration

public enum ClientExtensionTypeType

Remarks

Members

Member Name | Description | Value
Default |  | 0
Private |  | 1
MarketPlace |  | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ClientIntentMeetingInquiryActionType Enumeration

public enum ClientIntentMeetingInquiryActionType

Remarks

Members

Member Name | Description | Value
SendCancellation |  | 0
ReviveMeeting |  | 1
SendUpdateForMaster |  | 2
MeetingAlreadyExists |  | 3
ExistingOccurrence |  | 4
HasDelegates |  | 5
DeletedVersionNotFound |  | 6
PairedCancellationFound |  | 7
FailedToRevive |  | 8

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ClientIntentType Class

For a list of all members of this type, see ClientIntentType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ClientIntentType

public class ClientIntentType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ClientIntentType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ClientIntentType Members

ClientIntentType overview

Public Instance Constructors

ClientIntentType Constructor Initializes a new instance of the ClientIntentType class.

Public Instance Properties

Intent
ItemId
ItemVersion
PredictedAction
PredictedActionSpecified
WouldRepair

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ClientIntentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ClientIntentType Constructor

Initializes a new instance of the ClientIntentType class.

public ClientIntentType();

See Also

ClientIntentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ClientIntentType Properties

The properties of the ClientIntentType class are listed below. For a complete list of ClientIntentType class members, see the ClientIntentType Members topic.

Public Instance Properties

Intent
ItemId
ItemVersion
PredictedAction
PredictedActionSpecified
WouldRepair

See Also

ClientIntentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Intent Property

Aspose.Email

ClientIntentType.Intent Property

public int Intent {get; set;}

Remarks

See Also

ClientIntentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemId Property

Aspose.Email

ClientIntentType.ItemId Property

public ItemIdType ItemId {get; set;}

Remarks

See Also

ClientIntentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemVersion Property

Aspose.Email

ClientIntentType.ItemVersion Property

public int ItemVersion {get; set;}

Remarks

See Also

ClientIntentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PredictedAction Property

Aspose.Email

ClientIntentType.PredictedAction Property

public ClientIntentMeetingInquiryActionType PredictedAction {get; set;}

Remarks

See Also

ClientIntentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PredictedActionSpecified Property

Aspose.Email

ClientIntentType.PredictedActionSpecified Property

public bool PredictedActionSpecified {get; set;}

Remarks

See Also

ClientIntentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


WouldRepair Property

Aspose.Email

ClientIntentType.WouldRepair Property

public bool WouldRepair {get; set;}

Remarks

See Also

ClientIntentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CompleteFindInGALSpeechRecognitionResponseMessageType Class

For a list of all members of this type, see CompleteFindInGALSpeechRecognitionResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.CompleteFindInGALSpeechRecognitionResponseMessageType

public class CompleteFindInGALSpeechRecognitionResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CompleteFindInGALSpeechRecognitionResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CompleteFindInGALSpeechRecognitionResponseMessageType Members

CompleteFindInGALSpeechRecognitionResponseMessageType overview

Public Instance Constructors

CompleteFindInGALSpeechRecognitionResponseMessageType Constructor Initializes a new instance of the CompleteFindInGALSpeechRecognitionResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
RecognitionResult
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CompleteFindInGALSpeechRecognitionResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CompleteFindInGALSpeechRecognitionResponseMessageType Constructor

Initializes a new instance of the CompleteFindInGALSpeechRecognitionResponseMessageType class.

public CompleteFindInGALSpeechRecognitionResponseMessageType();

See Also

CompleteFindInGALSpeechRecognitionResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CompleteFindInGALSpeechRecognitionResponseMessageType Properties

The properties of the CompleteFindInGALSpeechRecognitionResponseMessageType class are listed below. For a complete list of CompleteFindInGALSpeechRecognitionResponseMessageType class members, see the CompleteFindInGALSpeechRecognitionResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
RecognitionResult
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

CompleteFindInGALSpeechRecognitionResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecognitionResult Property

Aspose.Email

CompleteFindInGALSpeechRecognitionResponseMessageType.RecognitionResult Property

public RecognitionResultType RecognitionResult {get; set;}

Remarks

See Also

CompleteFindInGALSpeechRecognitionResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CompleteFindInGALSpeechRecognitionType Class

For a list of all members of this type, see CompleteFindInGALSpeechRecognitionType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.CompleteFindInGALSpeechRecognitionType

public class CompleteFindInGALSpeechRecognitionType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CompleteFindInGALSpeechRecognitionType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CompleteFindInGALSpeechRecognitionType Members

CompleteFindInGALSpeechRecognitionType overview

Public Instance Constructors

CompleteFindInGALSpeechRecognitionType Constructor Initializes a new instance of the CompleteFindInGALSpeechRecognitionType class.

Public Instance Properties

AudioData
RecognitionId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CompleteFindInGALSpeechRecognitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CompleteFindInGALSpeechRecognitionType Constructor

Initializes a new instance of the CompleteFindInGALSpeechRecognitionType class.

public CompleteFindInGALSpeechRecognitionType();

See Also

CompleteFindInGALSpeechRecognitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CompleteFindInGALSpeechRecognitionType Properties

The properties of the CompleteFindInGALSpeechRecognitionType class are listed below. For a complete list of CompleteFindInGALSpeechRecognitionType class members, see the CompleteFindInGALSpeechRecognitionType Members topic.

Public Instance Properties

AudioData
RecognitionId

See Also

CompleteFindInGALSpeechRecognitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AudioData Property

Aspose.Email

CompleteFindInGALSpeechRecognitionType.AudioData Property

public byte[] AudioData {get; set;}

Remarks

See Also

CompleteFindInGALSpeechRecognitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecognitionId Property

Aspose.Email

CompleteFindInGALSpeechRecognitionType.RecognitionId Property

public RecognitionIdType RecognitionId {get; set;}

Remarks

See Also

CompleteFindInGALSpeechRecognitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CompleteNameType Class

For a list of all members of this type, see CompleteNameType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.CompleteNameType

public class CompleteNameType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CompleteNameType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CompleteNameType Members

CompleteNameType overview

Public Instance Constructors

CompleteNameType Constructor Initializes a new instance of the CompleteNameType class.

Public Instance Properties

FirstName
FullName
Initials
LastName
MiddleName
Nickname
Suffix
Title
YomiFirstName
YomiLastName

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CompleteNameType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CompleteNameType Constructor

Initializes a new instance of the CompleteNameType class.

public CompleteNameType();

See Also

CompleteNameType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CompleteNameType Properties

The properties of the CompleteNameType class are listed below. For a complete list of CompleteNameType class members, see the CompleteNameType Members topic.

Public Instance Properties

FirstName
FullName
Initials
LastName
MiddleName
Nickname
Suffix
Title
YomiFirstName
YomiLastName

See Also

CompleteNameType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FirstName Property

Aspose.Email

CompleteNameType.FirstName Property

public string FirstName {get; set;}

Remarks

See Also

CompleteNameType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FullName Property

Aspose.Email

CompleteNameType.FullName Property

public string FullName {get; set;}

Remarks

See Also

CompleteNameType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Initials Property

Aspose.Email

CompleteNameType.Initials Property

public string Initials {get; set;}

Remarks

See Also

CompleteNameType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


LastName Property

Aspose.Email

CompleteNameType.LastName Property

public string LastName {get; set;}

Remarks

See Also

CompleteNameType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MiddleName Property

Aspose.Email

CompleteNameType.MiddleName Property

public string MiddleName {get; set;}

Remarks

See Also

CompleteNameType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Nickname Property

Aspose.Email

CompleteNameType.Nickname Property

public string Nickname {get; set;}

Remarks

See Also

CompleteNameType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Suffix Property

Aspose.Email

CompleteNameType.Suffix Property

public string Suffix {get; set;}

Remarks

See Also

CompleteNameType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Title Property

Aspose.Email

CompleteNameType.Title Property

public string Title {get; set;}

Remarks

See Also

CompleteNameType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


YomiFirstName Property

Aspose.Email

CompleteNameType.YomiFirstName Property

public string YomiFirstName {get; set;}

Remarks

See Also

CompleteNameType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


YomiLastName Property

Aspose.Email

CompleteNameType.YomiLastName Property

public string YomiLastName {get; set;}

Remarks

See Also

CompleteNameType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConfigurationRequestDetailsType Class

For a list of all members of this type, see ConfigurationRequestDetailsType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ConfigurationRequestDetailsType

public class ConfigurationRequestDetailsType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ConfigurationRequestDetailsType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConfigurationRequestDetailsType Members

ConfigurationRequestDetailsType overview

Public Instance Constructors

ConfigurationRequestDetailsType Constructor Initializes a new instance of the ConfigurationRequestDetailsType class.

Public Instance Properties

Item

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConfigurationRequestDetailsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConfigurationRequestDetailsType Constructor

Initializes a new instance of the ConfigurationRequestDetailsType class.

public ConfigurationRequestDetailsType();

See Also

ConfigurationRequestDetailsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConfigurationRequestDetailsType Properties

The properties of the ConfigurationRequestDetailsType class are listed below. For a complete list of ConfigurationRequestDetailsType class members, see the ConfigurationRequestDetailsType Members topic.

Public Instance Properties

Item

See Also

ConfigurationRequestDetailsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Item Property

Aspose.Email

ConfigurationRequestDetailsType.Item Property

public XmlElement Item {get; set;}

Remarks

See Also

ConfigurationRequestDetailsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConflictResolutionType Enumeration

public enum ConflictResolutionType

Remarks

Members

Member Name | Description | Value
NeverOverwrite |  | 0
AutoResolve |  | 1
AlwaysOverwrite |  | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConflictResultsType Class

For a list of all members of this type, see ConflictResultsType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ConflictResultsType

public class ConflictResultsType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ConflictResultsType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConflictResultsType Members

ConflictResultsType overview

Public Instance Constructors

ConflictResultsType Constructor Initializes a new instance of the ConflictResultsType class.

Public Instance Properties

Count

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConflictResultsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConflictResultsType Constructor

Initializes a new instance of the ConflictResultsType class.

public ConflictResultsType();

See Also

ConflictResultsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConflictResultsType Properties

The properties of the ConflictResultsType class are listed below. For a complete list of ConflictResultsType class members, see the ConflictResultsType Members topic.

Public Instance Properties

Count

See Also

ConflictResultsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Count Property

Aspose.Email

ConflictResultsType.Count Property

public int Count {get; set;}

Remarks

See Also

ConflictResultsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConnectingSIDType Class

For a list of all members of this type, see ConnectingSIDType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ConnectingSIDType

public class ConnectingSIDType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ConnectingSIDType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConnectingSIDType Members

ConnectingSIDType overview

Public Instance Constructors

ConnectingSIDType Constructor Initializes a new instance of the ConnectingSIDType class.

Public Instance Properties

Item
ItemElementName

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConnectingSIDType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConnectingSIDType Constructor

Initializes a new instance of the ConnectingSIDType class.

public ConnectingSIDType();

See Also

ConnectingSIDType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConnectingSIDType Properties

The properties of the ConnectingSIDType class are listed below. For a complete list of ConnectingSIDType class members, see the ConnectingSIDType Members topic.

Public Instance Properties

Item
ItemElementName

See Also

ConnectingSIDType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Item Property

Aspose.Email

ConnectingSIDType.Item Property

public string Item {get; set;}

Remarks

See Also

ConnectingSIDType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemElementName Property

Aspose.Email

ConnectingSIDType.ItemElementName Property

public ItemChoiceType ItemElementName {get; set;}

Remarks

See Also

ConnectingSIDType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConnectionFailureCauseType Enumeration

public enum ConnectionFailureCauseType

Remarks

Members

Member Name | Description | Value
None |  | 0
UserBusy |  | 1
NoAnswer |  | 2
Unavailable |  | 3
Other |  | 4

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConnectionStatusType Enumeration

public enum ConnectionStatusType

Remarks

Members

Member Name | Description | Value
OK |  | 0
Closed |  | 1

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConstantValueType Class

For a list of all members of this type, see ConstantValueType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ConstantValueType

public class ConstantValueType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ConstantValueType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConstantValueType Members

ConstantValueType overview

Public Instance Constructors

ConstantValueType Constructor Initializes a new instance of the ConstantValueType class.

Public Instance Properties

Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConstantValueType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConstantValueType Constructor

Initializes a new instance of the ConstantValueType class.

public ConstantValueType();

See Also

ConstantValueType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConstantValueType Properties

The properties of the ConstantValueType class are listed below. For a complete list of ConstantValueType class members, see the ConstantValueType Members topic.

Public Instance Properties

Value

See Also

ConstantValueType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Value Property

Aspose.Email

ConstantValueType.Value Property

public string Value {get; set;}

Remarks

See Also

ConstantValueType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContactItemType Class

For a list of all members of this type, see ContactItemType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ItemType
Aspose.Email.Exchange.Schema.Exchange_2013.ContactItemType

public class ContactItemType : ItemType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ContactItemType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContactItemType Members

ContactItemType overview

Public Instance Constructors

ContactItemType Constructor Initializes a new instance of the ContactItemType class.

Public Instance Properties

Alias
ArchiveTag (inherited from ItemType)
AssistantName
Attachments (inherited from ItemType)
Birthday
BirthdaySpecified
BlockStatus (inherited from ItemType)
BlockStatusSpecified (inherited from ItemType)
Body (inherited from ItemType)
BusinessHomePage
Categories (inherited from ItemType)
Children
Companies
CompanyName
CompleteName
ContactSource
ContactSourceSpecified
ConversationId (inherited from ItemType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
Department
DirectoryId
DirectReports
DisplayCc (inherited from ItemType)
DisplayName
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
EmailAddresses
EntityExtractionResult (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
FileAs
FileAsMapping
FileAsMappingSpecified
Flag (inherited from ItemType)
Generation
GivenName
GroupingAction (inherited from ItemType)
GroupingActionSpecified (inherited from ItemType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBlockedImages (inherited from ItemType)
HasBlockedImagesSpecified (inherited from ItemType)
HasPicture
HasPictureSpecified
IconIndex (inherited from ItemType)
IconIndexSpecified (inherited from ItemType)
ImAddresses
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
Initials
InReplyTo (inherited from ItemType)
InstanceKey (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
JobTitle
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
Manager
ManagerMailbox
MiddleName
Mileage
MimeContent (inherited from ItemType)
MSExchangeCertificate
NextPredictedAction (inherited from ItemType)
NextPredictedActionSpecified (inherited from ItemType)
Nickname
NormalizedBody (inherited from ItemType)
Notes
OfficeLocation
ParentFolderId (inherited from ItemType)
PhoneNumbers
PhoneticFirstName
PhoneticFullName
PhoneticLastName
Photo
PhysicalAddresses
PolicyTag (inherited from ItemType)
PostalAddressIndex
PostalAddressIndexSpecified
Preview (inherited from ItemType)
Profession
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReminderNextTime (inherited from ItemType)
ReminderNextTimeSpecified (inherited from ItemType)
ResponseObjects (inherited from ItemType)
RetentionDate (inherited from ItemType)
RetentionDateSpecified (inherited from ItemType)
RightsManagementLicenseData (inherited from ItemType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
SpouseName
StoreEntryId (inherited from ItemType)
Subject (inherited from ItemType)
Surname
TextBody (inherited from ItemType)
UniqueBody (inherited from ItemType)
UserSMIMECertificate
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)
WeddingAnniversary
WeddingAnniversarySpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContactItemType Constructor

Initializes a new instance of the ContactItemType class.

public ContactItemType();

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContactItemType Properties

The properties of the ContactItemType class are listed below. For a complete list of ContactItemType class members, see the ContactItemType Members topic.

Public Instance Properties

Alias
ArchiveTag (inherited from ItemType)
AssistantName
Attachments (inherited from ItemType)
Birthday
BirthdaySpecified
BlockStatus (inherited from ItemType)
BlockStatusSpecified (inherited from ItemType)
Body (inherited from ItemType)
BusinessHomePage
Categories (inherited from ItemType)
Children
Companies
CompanyName
CompleteName
ContactSource
ContactSourceSpecified
ConversationId (inherited from ItemType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
Department
DirectoryId
DirectReports
DisplayCc (inherited from ItemType)
DisplayName
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
EmailAddresses
EntityExtractionResult (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
FileAs
FileAsMapping
FileAsMappingSpecified
Flag (inherited from ItemType)
Generation
GivenName
GroupingAction (inherited from ItemType)
GroupingActionSpecified (inherited from ItemType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBlockedImages (inherited from ItemType)
HasBlockedImagesSpecified (inherited from ItemType)
HasPicture
HasPictureSpecified
IconIndex (inherited from ItemType)
IconIndexSpecified (inherited from ItemType)
ImAddresses
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
Initials
InReplyTo (inherited from ItemType)
InstanceKey (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
JobTitle
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
Manager
ManagerMailbox
MiddleName
Mileage
MimeContent (inherited from ItemType)
MSExchangeCertificate
NextPredictedAction (inherited from ItemType)
NextPredictedActionSpecified (inherited from ItemType)
Nickname
NormalizedBody (inherited from ItemType)
Notes
OfficeLocation
ParentFolderId (inherited from ItemType)
PhoneNumbers
PhoneticFirstName
PhoneticFullName
PhoneticLastName
Photo
PhysicalAddresses
PolicyTag (inherited from ItemType)
PostalAddressIndex
PostalAddressIndexSpecified
Preview (inherited from ItemType)
Profession
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReminderNextTime (inherited from ItemType)
ReminderNextTimeSpecified (inherited from ItemType)
ResponseObjects (inherited from ItemType)
RetentionDate (inherited from ItemType)
RetentionDateSpecified (inherited from ItemType)
RightsManagementLicenseData (inherited from ItemType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
SpouseName
StoreEntryId (inherited from ItemType)
Subject (inherited from ItemType)
Surname
TextBody (inherited from ItemType)
UniqueBody (inherited from ItemType)
UserSMIMECertificate
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)
WeddingAnniversary
WeddingAnniversarySpecified

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Alias Property

Aspose.Email

ContactItemType.Alias Property

public string Alias {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AssistantName Property

Aspose.Email

ContactItemType.AssistantName Property

public string AssistantName {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Birthday Property

Aspose.Email

ContactItemType.Birthday Property

public DateTime Birthday {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BirthdaySpecified Property

Aspose.Email

ContactItemType.BirthdaySpecified Property

public bool BirthdaySpecified {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BusinessHomePage Property

Aspose.Email

ContactItemType.BusinessHomePage Property

public string BusinessHomePage {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Children Property

Aspose.Email

ContactItemType.Children Property

public string[] Children {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Companies Property

Aspose.Email

ContactItemType.Companies Property

public string[] Companies {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CompanyName Property

Aspose.Email

ContactItemType.CompanyName Property

public string CompanyName {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CompleteName Property

Aspose.Email

ContactItemType.CompleteName Property

public CompleteNameType CompleteName {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContactSource Property

Aspose.Email

ContactItemType.ContactSource Property

public ContactSourceType ContactSource {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContactSourceSpecified Property

Aspose.Email

ContactItemType.ContactSourceSpecified Property

public bool ContactSourceSpecified {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Department Property

Aspose.Email

ContactItemType.Department Property

public string Department {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DirectoryId Property

Aspose.Email

ContactItemType.DirectoryId Property

public string DirectoryId {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DirectReports Property

Aspose.Email

ContactItemType.DirectReports Property

public EmailAddressType[] DirectReports {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisplayName Property

Aspose.Email

ContactItemType.DisplayName Property

public string DisplayName {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EmailAddresses Property

Aspose.Email

ContactItemType.EmailAddresses Property

public EmailAddressDictionaryEntryType[] EmailAddresses {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FileAs Property

Aspose.Email

ContactItemType.FileAs Property

public string FileAs {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FileAsMapping Property

Aspose.Email

ContactItemType.FileAsMapping Property

public FileAsMappingType FileAsMapping {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FileAsMappingSpecified Property

Aspose.Email

ContactItemType.FileAsMappingSpecified Property

public bool FileAsMappingSpecified {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Generation Property

Aspose.Email

ContactItemType.Generation Property

public string Generation {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GivenName Property

Aspose.Email

ContactItemType.GivenName Property

public string GivenName {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


HasPicture Property

Aspose.Email

ContactItemType.HasPicture Property

public bool HasPicture {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


HasPictureSpecified Property

Aspose.Email

ContactItemType.HasPictureSpecified Property

public bool HasPictureSpecified {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ImAddresses Property

Aspose.Email

ContactItemType.ImAddresses Property

public ImAddressDictionaryEntryType[] ImAddresses {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Initials Property

Aspose.Email

ContactItemType.Initials Property

public string Initials {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


JobTitle Property

Aspose.Email

ContactItemType.JobTitle Property

public string JobTitle {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Manager Property

Aspose.Email

ContactItemType.Manager Property

public string Manager {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ManagerMailbox Property

Aspose.Email

ContactItemType.ManagerMailbox Property

public SingleRecipientType ManagerMailbox {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MiddleName Property

Aspose.Email

ContactItemType.MiddleName Property

public string MiddleName {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Mileage Property

Aspose.Email

ContactItemType.Mileage Property

public string Mileage {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MSExchangeCertificate Property

Aspose.Email

ContactItemType.MSExchangeCertificate Property

public byte[][] MSExchangeCertificate {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Nickname Property

Aspose.Email

ContactItemType.Nickname Property

public string Nickname {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Notes Property

Aspose.Email

ContactItemType.Notes Property

public string Notes {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OfficeLocation Property

Aspose.Email

ContactItemType.OfficeLocation Property

public string OfficeLocation {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PhoneNumbers Property

Aspose.Email

ContactItemType.PhoneNumbers Property

public PhoneNumberDictionaryEntryType[] PhoneNumbers {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PhoneticFirstName Property

Aspose.Email

ContactItemType.PhoneticFirstName Property

public string PhoneticFirstName {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PhoneticFullName Property

Aspose.Email

ContactItemType.PhoneticFullName Property

public string PhoneticFullName {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PhoneticLastName Property

Aspose.Email

ContactItemType.PhoneticLastName Property

public string PhoneticLastName {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Photo Property

Aspose.Email

ContactItemType.Photo Property

public byte[] Photo {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PhysicalAddresses Property

Aspose.Email

ContactItemType.PhysicalAddresses Property

public PhysicalAddressDictionaryEntryType[] PhysicalAddresses {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PostalAddressIndex Property

Aspose.Email

ContactItemType.PostalAddressIndex Property

public PhysicalAddressIndexType PostalAddressIndex {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PostalAddressIndexSpecified Property

Aspose.Email

ContactItemType.PostalAddressIndexSpecified Property

public bool PostalAddressIndexSpecified {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Profession Property

Aspose.Email

ContactItemType.Profession Property

public string Profession {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SpouseName Property

Aspose.Email

ContactItemType.SpouseName Property

public string SpouseName {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Surname Property

Aspose.Email

ContactItemType.Surname Property

public string Surname {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserSMIMECertificate Property

Aspose.Email

ContactItemType.UserSMIMECertificate Property

public byte[][] UserSMIMECertificate {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


WeddingAnniversary Property

Aspose.Email

ContactItemType.WeddingAnniversary Property

public DateTime WeddingAnniversary {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


WeddingAnniversarySpecified Property

Aspose.Email

ContactItemType.WeddingAnniversarySpecified Property

public bool WeddingAnniversarySpecified {get; set;}

Remarks

See Also

ContactItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContactsFolderType Class

For a list of all members of this type, see ContactsFolderType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseFolderType
Aspose.Email.Exchange.Schema.Exchange_2013.ContactsFolderType

public class ContactsFolderType : BaseFolderType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ContactsFolderType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContactsFolderType Members

ContactsFolderType overview

Public Instance Constructors

ContactsFolderType Constructor Initializes a new instance of the ContactsFolderType class.

Public Instance Properties

ArchiveTag (inherited from BaseFolderType)
ChildFolderCount (inherited from BaseFolderType)
ChildFolderCountSpecified (inherited from BaseFolderType)
DisplayName (inherited from BaseFolderType)
DistinguishedFolderId (inherited from BaseFolderType)
DistinguishedFolderIdSpecified (inherited from BaseFolderType)
EffectiveRights (inherited from BaseFolderType)
ExtendedProperty (inherited from BaseFolderType)
FolderClass (inherited from BaseFolderType)
FolderId (inherited from BaseFolderType)
ManagedFolderInformation (inherited from BaseFolderType)
ParentFolderId (inherited from BaseFolderType)
PermissionSet
PolicyTag (inherited from BaseFolderType)
SharingEffectiveRights
SharingEffectiveRightsSpecified
TotalCount (inherited from BaseFolderType)
TotalCountSpecified (inherited from BaseFolderType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ContactsFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContactsFolderType Constructor

Initializes a new instance of the ContactsFolderType class.

public ContactsFolderType();

See Also

ContactsFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContactsFolderType Properties

The properties of the ContactsFolderType class are listed below. For a complete list of ContactsFolderType class members, see the ContactsFolderType Members topic.

Public Instance Properties

ArchiveTag (inherited from BaseFolderType)
ChildFolderCount (inherited from BaseFolderType)
ChildFolderCountSpecified (inherited from BaseFolderType)
DisplayName (inherited from BaseFolderType)
DistinguishedFolderId (inherited from BaseFolderType)
DistinguishedFolderIdSpecified (inherited from BaseFolderType)
EffectiveRights (inherited from BaseFolderType)
ExtendedProperty (inherited from BaseFolderType)
FolderClass (inherited from BaseFolderType)
FolderId (inherited from BaseFolderType)
ManagedFolderInformation (inherited from BaseFolderType)
ParentFolderId (inherited from BaseFolderType)
PermissionSet
PolicyTag (inherited from BaseFolderType)
SharingEffectiveRights
SharingEffectiveRightsSpecified
TotalCount (inherited from BaseFolderType)
TotalCountSpecified (inherited from BaseFolderType)

See Also

ContactsFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PermissionSet Property

Aspose.Email

ContactsFolderType.PermissionSet Property

public PermissionSetType PermissionSet {get; set;}

Remarks

See Also

ContactsFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SharingEffectiveRights Property

Aspose.Email

ContactsFolderType.SharingEffectiveRights Property

public PermissionReadAccessType SharingEffectiveRights {get; set;}

Remarks

See Also

ContactsFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SharingEffectiveRightsSpecified Property

Aspose.Email

ContactsFolderType.SharingEffectiveRightsSpecified Property

public bool SharingEffectiveRightsSpecified {get; set;}

Remarks

See Also

ContactsFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContactSourceType Enumeration

public enum ContactSourceType

Remarks

Members

Member Name | Description | Value
ActiveDirectory |  | 0
Store |  | 1

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContactsViewType Class

For a list of all members of this type, see ContactsViewType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BasePagingType
Aspose.Email.Exchange.Schema.Exchange_2013.ContactsViewType

public class ContactsViewType : BasePagingType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ContactsViewType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContactsViewType Members

ContactsViewType overview

Public Instance Constructors

ContactsViewType Constructor Initializes a new instance of the ContactsViewType class.

Public Instance Properties

FinalName
InitialName
MaxEntriesReturned (inherited from BasePagingType)
MaxEntriesReturnedSpecified (inherited from BasePagingType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ContactsViewType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContactsViewType Constructor

Initializes a new instance of the ContactsViewType class.

public ContactsViewType();

See Also

ContactsViewType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContactsViewType Properties

The properties of the ContactsViewType class are listed below. For a complete list of ContactsViewType class members, see the ContactsViewType Members topic.

Public Instance Properties

FinalName
InitialName
MaxEntriesReturned (inherited from BasePagingType)
MaxEntriesReturnedSpecified (inherited from BasePagingType)

See Also

ContactsViewType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FinalName Property

Aspose.Email

ContactsViewType.FinalName Property

public string FinalName {get; set;}

Remarks

See Also

ContactsViewType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InitialName Property

Aspose.Email

ContactsViewType.InitialName Property

public string InitialName {get; set;}

Remarks

See Also

ContactsViewType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContactType Class

For a list of all members of this type, see ContactType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.EntityType
Aspose.Email.Exchange.Schema.Exchange_2013.ContactType

public class ContactType : EntityType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ContactType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContactType Members

ContactType overview

Public Instance Constructors

ContactType Constructor Initializes a new instance of the ContactType class.

Public Instance Properties

Addresses
BusinessName
ContactString
EmailAddresses
PersonName
PhoneNumbers
Position (inherited from EntityType)
Urls

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ContactType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContactType Constructor

Initializes a new instance of the ContactType class.

public ContactType();

See Also

ContactType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContactType Properties

The properties of the ContactType class are listed below. For a complete list of ContactType class members, see the ContactType Members topic.

Public Instance Properties

Addresses
BusinessName
ContactString
EmailAddresses
PersonName
PhoneNumbers
Position (inherited from EntityType)
Urls

See Also

ContactType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Addresses Property

Aspose.Email

ContactType.Addresses Property

public string[] Addresses {get; set;}

Remarks

See Also

ContactType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BusinessName Property

Aspose.Email

ContactType.BusinessName Property

public string BusinessName {get; set;}

Remarks

See Also

ContactType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContactString Property

Aspose.Email

ContactType.ContactString Property

public string ContactString {get; set;}

Remarks

See Also

ContactType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EmailAddresses Property

Aspose.Email

ContactType.EmailAddresses Property

public string[] EmailAddresses {get; set;}

Remarks

See Also

ContactType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PersonName Property

Aspose.Email

ContactType.PersonName Property

public string PersonName {get; set;}

Remarks

See Also

ContactType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PhoneNumbers Property

Aspose.Email

ContactType.PhoneNumbers Property

public PhoneType[] PhoneNumbers {get; set;}

Remarks

See Also

ContactType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Urls Property

Aspose.Email

ContactType.Urls Property

public string[] Urls {get; set;}

Remarks

See Also

ContactType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContainmentComparisonType Enumeration

public enum ContainmentComparisonType

Remarks

Members

Member Name | Description | Value
Exact |  | 0
IgnoreCase |  | 1
IgnoreNonSpacingCharacters |  | 2
Loose |  | 3
IgnoreCaseAndNonSpacingCharacters |  | 4
LooseAndIgnoreCase |  | 5
LooseAndIgnoreNonSpace |  | 6
LooseAndIgnoreCaseAndIgnoreNonSpace |  | 7

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContainmentModeType Enumeration

public enum ContainmentModeType

Remarks

Members

Member Name | Description | Value
FullString |  | 0
Prefixed |  | 1
Substring |  | 2
PrefixOnWords |  | 3
ExactPhrase |  | 4

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContainsExpressionType Class

For a list of all members of this type, see ContainsExpressionType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.SearchExpressionType
Aspose.Email.Exchange.Schema.Exchange_2013.ContainsExpressionType

public class ContainsExpressionType : SearchExpressionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ContainsExpressionType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContainsExpressionType Members

ContainsExpressionType overview

Public Instance Constructors

ContainsExpressionType Constructor Initializes a new instance of the ContainsExpressionType class.

Public Instance Properties

Constant
ContainmentComparison
ContainmentComparisonSpecified
ContainmentMode
ContainmentModeSpecified
Item

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ContainsExpressionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContainsExpressionType Constructor

Initializes a new instance of the ContainsExpressionType class.

public ContainsExpressionType();

See Also

ContainsExpressionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContainsExpressionType Properties

The properties of the ContainsExpressionType class are listed below. For a complete list of ContainsExpressionType class members, see the ContainsExpressionType Members topic.

Public Instance Properties

Constant
ContainmentComparison
ContainmentComparisonSpecified
ContainmentMode
ContainmentModeSpecified
Item

See Also

ContainsExpressionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Constant Property

Aspose.Email

ContainsExpressionType.Constant Property

public ConstantValueType Constant {get; set;}

Remarks

See Also

ContainsExpressionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContainmentComparison Property

Aspose.Email

ContainsExpressionType.ContainmentComparison Property

public ContainmentComparisonType ContainmentComparison {get; set;}

Remarks

See Also

ContainsExpressionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContainmentComparisonSpecified Property

Aspose.Email

ContainsExpressionType.ContainmentComparisonSpecified Property

public bool ContainmentComparisonSpecified {get; set;}

Remarks

See Also

ContainsExpressionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContainmentMode Property

Aspose.Email

ContainsExpressionType.ContainmentMode Property

public ContainmentModeType ContainmentMode {get; set;}

Remarks

See Also

ContainsExpressionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContainmentModeSpecified Property

Aspose.Email

ContainsExpressionType.ContainmentModeSpecified Property

public bool ContainmentModeSpecified {get; set;}

Remarks

See Also

ContainsExpressionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Item Property

Aspose.Email

ContainsExpressionType.Item Property

public BasePathToElementType Item {get; set;}

Remarks

See Also

ContainsExpressionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConversationActionType Class

For a list of all members of this type, see ConversationActionType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ConversationActionType

public class ConversationActionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ConversationActionType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConversationActionType Members

ConversationActionType overview

Public Instance Constructors

ConversationActionType Constructor Initializes a new instance of the ConversationActionType class.

Public Instance Properties

Action
Categories
ContextFolderId
ConversationId
ConversationLastSyncTime
ConversationLastSyncTimeSpecified
DeleteType
DeleteTypeSpecified
DestinationFolderId
EnableAlwaysDelete
EnableAlwaysDeleteSpecified
Flag
IsRead
IsReadSpecified
ProcessRightAway
ProcessRightAwaySpecified
RetentionPolicyTagId
RetentionPolicyType
RetentionPolicyTypeSpecified
SuppressReadReceipts
SuppressReadReceiptsSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConversationActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConversationActionType Constructor

Initializes a new instance of the ConversationActionType class.

public ConversationActionType();

See Also

ConversationActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConversationActionType Properties

The properties of the ConversationActionType class are listed below. For a complete list of ConversationActionType class members, see the ConversationActionType Members topic.

Public Instance Properties

Action
Categories
ContextFolderId
ConversationId
ConversationLastSyncTime
ConversationLastSyncTimeSpecified
DeleteType
DeleteTypeSpecified
DestinationFolderId
EnableAlwaysDelete
EnableAlwaysDeleteSpecified
Flag
IsRead
IsReadSpecified
ProcessRightAway
ProcessRightAwaySpecified
RetentionPolicyTagId
RetentionPolicyType
RetentionPolicyTypeSpecified
SuppressReadReceipts
SuppressReadReceiptsSpecified

See Also

ConversationActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Action Property

Aspose.Email

ConversationActionType.Action Property

public ConversationActionTypeType Action {get; set;}

Remarks

See Also

ConversationActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Categories Property

Aspose.Email

ConversationActionType.Categories Property

public string[] Categories {get; set;}

Remarks

See Also

ConversationActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContextFolderId Property

Aspose.Email

ConversationActionType.ContextFolderId Property

public TargetFolderIdType ContextFolderId {get; set;}

Remarks

See Also

ConversationActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConversationId Property

Aspose.Email

ConversationActionType.ConversationId Property

public ItemIdType ConversationId {get; set;}

Remarks

See Also

ConversationActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConversationLastSyncTime Property

Aspose.Email

ConversationActionType.ConversationLastSyncTime Property

public DateTime ConversationLastSyncTime {get; set;}

Remarks

See Also

ConversationActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConversationLastSyncTimeSpecified Property

Aspose.Email

ConversationActionType.ConversationLastSyncTimeSpecified Property

public bool ConversationLastSyncTimeSpecified {get; set;}

Remarks

See Also

ConversationActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteType Property

Aspose.Email

ConversationActionType.DeleteType Property

public DisposalType DeleteType {get; set;}

Remarks

See Also

ConversationActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteTypeSpecified Property

Aspose.Email

ConversationActionType.DeleteTypeSpecified Property

public bool DeleteTypeSpecified {get; set;}

Remarks

See Also

ConversationActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DestinationFolderId Property

Aspose.Email

ConversationActionType.DestinationFolderId Property

public TargetFolderIdType DestinationFolderId {get; set;}

Remarks

See Also

ConversationActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EnableAlwaysDelete Property

Aspose.Email

ConversationActionType.EnableAlwaysDelete Property

public bool EnableAlwaysDelete {get; set;}

Remarks

See Also

ConversationActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EnableAlwaysDeleteSpecified Property

Aspose.Email

ConversationActionType.EnableAlwaysDeleteSpecified Property

public bool EnableAlwaysDeleteSpecified {get; set;}

Remarks

See Also

ConversationActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Flag Property

Aspose.Email

ConversationActionType.Flag Property

public FlagType Flag {get; set;}

Remarks

See Also

ConversationActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsRead Property

Aspose.Email

ConversationActionType.IsRead Property

public bool IsRead {get; set;}

Remarks

See Also

ConversationActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsReadSpecified Property

Aspose.Email

ConversationActionType.IsReadSpecified Property

public bool IsReadSpecified {get; set;}

Remarks

See Also

ConversationActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ProcessRightAway Property

Aspose.Email

ConversationActionType.ProcessRightAway Property

public bool ProcessRightAway {get; set;}

Remarks

See Also

ConversationActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ProcessRightAwaySpecified Property

Aspose.Email

ConversationActionType.ProcessRightAwaySpecified Property

public bool ProcessRightAwaySpecified {get; set;}

Remarks

See Also

ConversationActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RetentionPolicyTagId Property

Aspose.Email

ConversationActionType.RetentionPolicyTagId Property

public string RetentionPolicyTagId {get; set;}

Remarks

See Also

ConversationActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RetentionPolicyType Property

Aspose.Email

ConversationActionType.RetentionPolicyType Property

public RetentionType RetentionPolicyType {get; set;}

Remarks

See Also

ConversationActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RetentionPolicyTypeSpecified Property

Aspose.Email

ConversationActionType.RetentionPolicyTypeSpecified Property

public bool RetentionPolicyTypeSpecified {get; set;}

Remarks

See Also

ConversationActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SuppressReadReceipts Property

Aspose.Email

ConversationActionType.SuppressReadReceipts Property

public bool SuppressReadReceipts {get; set;}

Remarks

See Also

ConversationActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SuppressReadReceiptsSpecified Property

Aspose.Email

ConversationActionType.SuppressReadReceiptsSpecified Property

public bool SuppressReadReceiptsSpecified {get; set;}

Remarks

See Also

ConversationActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConversationActionTypeType Enumeration

public enum ConversationActionTypeType

Remarks

Members

Member Name | Description | Value
AlwaysCategorize |  | 0
AlwaysDelete |  | 1
AlwaysMove |  | 2
Delete |  | 3
Move |  | 4
Copy |  | 5
SetReadState |  | 6
SetRetentionPolicy |  | 7
Flag |  | 8

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConversationNodeSortOrder Enumeration

public enum ConversationNodeSortOrder

Remarks

Members

Member Name | Description | Value
TreeOrderAscending |  | 0
TreeOrderDescending |  | 1
DateOrderAscending |  | 2
DateOrderDescending |  | 3

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConversationNodeType Class

For a list of all members of this type, see ConversationNodeType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ConversationNodeType

public class ConversationNodeType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ConversationNodeType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConversationNodeType Members

ConversationNodeType overview

Public Instance Constructors

ConversationNodeType Constructor Initializes a new instance of the ConversationNodeType class.

Public Instance Properties

InternetMessageId
Items
ParentInternetMessageId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConversationNodeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConversationNodeType Constructor

Initializes a new instance of the ConversationNodeType class.

public ConversationNodeType();

See Also

ConversationNodeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConversationNodeType Properties

The properties of the ConversationNodeType class are listed below. For a complete list of ConversationNodeType class members, see the ConversationNodeType Members topic.

Public Instance Properties

InternetMessageId
Items
ParentInternetMessageId

See Also

ConversationNodeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InternetMessageId Property

Aspose.Email

ConversationNodeType.InternetMessageId Property

public string InternetMessageId {get; set;}

Remarks

See Also

ConversationNodeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Items Property

Aspose.Email

ConversationNodeType.Items Property

public NonEmptyArrayOfAllItemsType Items {get; set;}

Remarks

See Also

ConversationNodeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ParentInternetMessageId Property

Aspose.Email

ConversationNodeType.ParentInternetMessageId Property

public string ParentInternetMessageId {get; set;}

Remarks

See Also

ConversationNodeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConversationQueryTraversalType Enumeration

public enum ConversationQueryTraversalType

Remarks

Members

Member Name | Description | Value
Shallow |  | 0
Deep |  | 1

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConversationRequestType Class

For a list of all members of this type, see ConversationRequestType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ConversationRequestType

public class ConversationRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ConversationRequestType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConversationRequestType Members

ConversationRequestType overview

Public Instance Constructors

ConversationRequestType Constructor Initializes a new instance of the ConversationRequestType class.

Public Instance Properties

ConversationId
SyncState

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConversationRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConversationRequestType Constructor

Initializes a new instance of the ConversationRequestType class.

public ConversationRequestType();

See Also

ConversationRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConversationRequestType Properties

The properties of the ConversationRequestType class are listed below. For a complete list of ConversationRequestType class members, see the ConversationRequestType Members topic.

Public Instance Properties

ConversationId
SyncState

See Also

ConversationRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConversationId Property

Aspose.Email

ConversationRequestType.ConversationId Property

public ItemIdType ConversationId {get; set;}

Remarks

See Also

ConversationRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncState Property

Aspose.Email

ConversationRequestType.SyncState Property

public byte[] SyncState {get; set;}

Remarks

See Also

ConversationRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConversationResponseShapeType Class

For a list of all members of this type, see ConversationResponseShapeType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ConversationResponseShapeType

public class ConversationResponseShapeType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ConversationResponseShapeType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConversationResponseShapeType Members

ConversationResponseShapeType overview

Public Instance Constructors

ConversationResponseShapeType Constructor Initializes a new instance of the ConversationResponseShapeType class.

Public Instance Properties

AdditionalProperties
BaseShape

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConversationResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConversationResponseShapeType Constructor

Initializes a new instance of the ConversationResponseShapeType class.

public ConversationResponseShapeType();

See Also

ConversationResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConversationResponseShapeType Properties

The properties of the ConversationResponseShapeType class are listed below. For a complete list of ConversationResponseShapeType class members, see the ConversationResponseShapeType Members topic.

Public Instance Properties

AdditionalProperties
BaseShape

See Also

ConversationResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AdditionalProperties Property

Aspose.Email

ConversationResponseShapeType.AdditionalProperties Property

public BasePathToElementType[] AdditionalProperties {get; set;}

Remarks

See Also

ConversationResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseShape Property

Aspose.Email

ConversationResponseShapeType.BaseShape Property

public DefaultShapeNamesType BaseShape {get; set;}

Remarks

See Also

ConversationResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConversationResponseType Class

For a list of all members of this type, see ConversationResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ConversationResponseType

public class ConversationResponseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ConversationResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConversationResponseType Members

ConversationResponseType overview

Public Instance Constructors

ConversationResponseType Constructor Initializes a new instance of the ConversationResponseType class.

Public Instance Properties

ConversationId
ConversationNodes
SyncState

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConversationResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConversationResponseType Constructor

Initializes a new instance of the ConversationResponseType class.

public ConversationResponseType();

See Also

ConversationResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConversationResponseType Properties

The properties of the ConversationResponseType class are listed below. For a complete list of ConversationResponseType class members, see the ConversationResponseType Members topic.

Public Instance Properties

ConversationId
ConversationNodes
SyncState

See Also

ConversationResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConversationId Property

Aspose.Email

ConversationResponseType.ConversationId Property

public ItemIdType ConversationId {get; set;}

Remarks

See Also

ConversationResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConversationNodes Property

Aspose.Email

ConversationResponseType.ConversationNodes Property

public ConversationNodeType[] ConversationNodes {get; set;}

Remarks

See Also

ConversationResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncState Property

Aspose.Email

ConversationResponseType.SyncState Property

public byte[] SyncState {get; set;}

Remarks

See Also

ConversationResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConversationType Class

For a list of all members of this type, see ConversationType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ConversationType

public class ConversationType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ConversationType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConversationType Members

ConversationType overview

Public Instance Constructors

ConversationType Constructor Initializes a new instance of the ConversationType class.

Public Instance Properties

Categories
ConversationId
ConversationTopic
DraftItemIds
FlagStatus
FlagStatusSpecified
GlobalCategories
GlobalFlagStatus
GlobalFlagStatusSpecified
GlobalHasAttachments
GlobalHasAttachmentsSpecified
GlobalIconIndex
GlobalIconIndexSpecified
GlobalImportance
GlobalImportanceSpecified
GlobalItemClasses
GlobalItemIds
GlobalLastDeliveryTime
GlobalLastDeliveryTimeSpecified
GlobalMessageCount
GlobalMessageCountSpecified
GlobalSize
GlobalSizeSpecified
GlobalUniqueRecipients
GlobalUniqueSenders
GlobalUniqueUnreadSenders
GlobalUnreadCount
GlobalUnreadCountSpecified
GroupingAction
GroupingActionSpecified
HasAttachments
HasAttachmentsSpecified
IconIndex
IconIndexSpecified
Importance
ImportanceSpecified
InstanceKey
ItemClasses
ItemIds
LastDeliveryTime
LastDeliveryTimeSpecified
LastModifiedTime
LastModifiedTimeSpecified
MailboxScope
MailboxScopeSpecified
MessageCount
MessageCountSpecified
NextPredictedAction
NextPredictedActionSpecified
Preview
Size
SizeSpecified
UniqueRecipients
UniqueSenders
UniqueUnreadSenders
UnreadCount
UnreadCountSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConversationType Constructor

Initializes a new instance of the ConversationType class.

public ConversationType();

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConversationType Properties

The properties of the ConversationType class are listed below. For a complete list of ConversationType class members, see the ConversationType Members topic.

Public Instance Properties

Categories
ConversationId
ConversationTopic
DraftItemIds
FlagStatus
FlagStatusSpecified
GlobalCategories
GlobalFlagStatus
GlobalFlagStatusSpecified
GlobalHasAttachments
GlobalHasAttachmentsSpecified
GlobalIconIndex
GlobalIconIndexSpecified
GlobalImportance
GlobalImportanceSpecified
GlobalItemClasses
GlobalItemIds
GlobalLastDeliveryTime
GlobalLastDeliveryTimeSpecified
GlobalMessageCount
GlobalMessageCountSpecified
GlobalSize
GlobalSizeSpecified
GlobalUniqueRecipients
GlobalUniqueSenders
GlobalUniqueUnreadSenders
GlobalUnreadCount
GlobalUnreadCountSpecified
GroupingAction
GroupingActionSpecified
HasAttachments
HasAttachmentsSpecified
IconIndex
IconIndexSpecified
Importance
ImportanceSpecified
InstanceKey
ItemClasses
ItemIds
LastDeliveryTime
LastDeliveryTimeSpecified
LastModifiedTime
LastModifiedTimeSpecified
MailboxScope
MailboxScopeSpecified
MessageCount
MessageCountSpecified
NextPredictedAction
NextPredictedActionSpecified
Preview
Size
SizeSpecified
UniqueRecipients
UniqueSenders
UniqueUnreadSenders
UnreadCount
UnreadCountSpecified

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Categories Property

Aspose.Email

ConversationType.Categories Property

public string[] Categories {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConversationId Property

Aspose.Email

ConversationType.ConversationId Property

public ItemIdType ConversationId {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConversationTopic Property

Aspose.Email

ConversationType.ConversationTopic Property

public string ConversationTopic {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DraftItemIds Property

Aspose.Email

ConversationType.DraftItemIds Property

public BaseItemIdType[] DraftItemIds {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FlagStatus Property

Aspose.Email

ConversationType.FlagStatus Property

public FlagStatusType FlagStatus {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FlagStatusSpecified Property

Aspose.Email

ConversationType.FlagStatusSpecified Property

public bool FlagStatusSpecified {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GlobalCategories Property

Aspose.Email

ConversationType.GlobalCategories Property

public string[] GlobalCategories {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GlobalFlagStatus Property

Aspose.Email

ConversationType.GlobalFlagStatus Property

public FlagStatusType GlobalFlagStatus {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GlobalFlagStatusSpecified Property

Aspose.Email

ConversationType.GlobalFlagStatusSpecified Property

public bool GlobalFlagStatusSpecified {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GlobalHasAttachments Property

Aspose.Email

ConversationType.GlobalHasAttachments Property

public bool GlobalHasAttachments {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GlobalHasAttachmentsSpecified Property

Aspose.Email

ConversationType.GlobalHasAttachmentsSpecified Property

public bool GlobalHasAttachmentsSpecified {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GlobalIconIndex Property

Aspose.Email

ConversationType.GlobalIconIndex Property

public IconIndexType GlobalIconIndex {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GlobalIconIndexSpecified Property

Aspose.Email

ConversationType.GlobalIconIndexSpecified Property

public bool GlobalIconIndexSpecified {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GlobalImportance Property

Aspose.Email

ConversationType.GlobalImportance Property

public ImportanceChoicesType GlobalImportance {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GlobalImportanceSpecified Property

Aspose.Email

ConversationType.GlobalImportanceSpecified Property

public bool GlobalImportanceSpecified {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GlobalItemClasses Property

Aspose.Email

ConversationType.GlobalItemClasses Property

public string[] GlobalItemClasses {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GlobalItemIds Property

Aspose.Email

ConversationType.GlobalItemIds Property

public BaseItemIdType[] GlobalItemIds {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GlobalLastDeliveryTime Property

Aspose.Email

ConversationType.GlobalLastDeliveryTime Property

public DateTime GlobalLastDeliveryTime {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GlobalLastDeliveryTimeSpecified Property

Aspose.Email

ConversationType.GlobalLastDeliveryTimeSpecified Property

public bool GlobalLastDeliveryTimeSpecified {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GlobalMessageCount Property

Aspose.Email

ConversationType.GlobalMessageCount Property

public int GlobalMessageCount {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GlobalMessageCountSpecified Property

Aspose.Email

ConversationType.GlobalMessageCountSpecified Property

public bool GlobalMessageCountSpecified {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GlobalSize Property

Aspose.Email

ConversationType.GlobalSize Property

public int GlobalSize {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GlobalSizeSpecified Property

Aspose.Email

ConversationType.GlobalSizeSpecified Property

public bool GlobalSizeSpecified {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GlobalUniqueRecipients Property

Aspose.Email

ConversationType.GlobalUniqueRecipients Property

public string[] GlobalUniqueRecipients {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GlobalUniqueSenders Property

Aspose.Email

ConversationType.GlobalUniqueSenders Property

public string[] GlobalUniqueSenders {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GlobalUniqueUnreadSenders Property

Aspose.Email

ConversationType.GlobalUniqueUnreadSenders Property

public string[] GlobalUniqueUnreadSenders {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GlobalUnreadCount Property

Aspose.Email

ConversationType.GlobalUnreadCount Property

public int GlobalUnreadCount {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GlobalUnreadCountSpecified Property

Aspose.Email

ConversationType.GlobalUnreadCountSpecified Property

public bool GlobalUnreadCountSpecified {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GroupingAction Property

Aspose.Email

ConversationType.GroupingAction Property

public PredictedMessageActionType GroupingAction {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GroupingActionSpecified Property

Aspose.Email

ConversationType.GroupingActionSpecified Property

public bool GroupingActionSpecified {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


HasAttachments Property

Aspose.Email

ConversationType.HasAttachments Property

public bool HasAttachments {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


HasAttachmentsSpecified Property

Aspose.Email

ConversationType.HasAttachmentsSpecified Property

public bool HasAttachmentsSpecified {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IconIndex Property

Aspose.Email

ConversationType.IconIndex Property

public IconIndexType IconIndex {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IconIndexSpecified Property

Aspose.Email

ConversationType.IconIndexSpecified Property

public bool IconIndexSpecified {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Importance Property

Aspose.Email

ConversationType.Importance Property

public ImportanceChoicesType Importance {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ImportanceSpecified Property

Aspose.Email

ConversationType.ImportanceSpecified Property

public bool ImportanceSpecified {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InstanceKey Property

Aspose.Email

ConversationType.InstanceKey Property

public byte[] InstanceKey {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemClasses Property

Aspose.Email

ConversationType.ItemClasses Property

public string[] ItemClasses {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemIds Property

Aspose.Email

ConversationType.ItemIds Property

public BaseItemIdType[] ItemIds {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


LastDeliveryTime Property

Aspose.Email

ConversationType.LastDeliveryTime Property

public DateTime LastDeliveryTime {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


LastDeliveryTimeSpecified Property

Aspose.Email

ConversationType.LastDeliveryTimeSpecified Property

public bool LastDeliveryTimeSpecified {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


LastModifiedTime Property

Aspose.Email

ConversationType.LastModifiedTime Property

public DateTime LastModifiedTime {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


LastModifiedTimeSpecified Property

Aspose.Email

ConversationType.LastModifiedTimeSpecified Property

public bool LastModifiedTimeSpecified {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxScope Property

Aspose.Email

ConversationType.MailboxScope Property

public MailboxSearchLocationType MailboxScope {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxScopeSpecified Property

Aspose.Email

ConversationType.MailboxScopeSpecified Property

public bool MailboxScopeSpecified {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MessageCount Property

Aspose.Email

ConversationType.MessageCount Property

public int MessageCount {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MessageCountSpecified Property

Aspose.Email

ConversationType.MessageCountSpecified Property

public bool MessageCountSpecified {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NextPredictedAction Property

Aspose.Email

ConversationType.NextPredictedAction Property

public PredictedMessageActionType NextPredictedAction {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NextPredictedActionSpecified Property

Aspose.Email

ConversationType.NextPredictedActionSpecified Property

public bool NextPredictedActionSpecified {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Preview Property

Aspose.Email

ConversationType.Preview Property

public string Preview {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Size Property

Aspose.Email

ConversationType.Size Property

public int Size {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SizeSpecified Property

Aspose.Email

ConversationType.SizeSpecified Property

public bool SizeSpecified {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UniqueRecipients Property

Aspose.Email

ConversationType.UniqueRecipients Property

public string[] UniqueRecipients {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UniqueSenders Property

Aspose.Email

ConversationType.UniqueSenders Property

public string[] UniqueSenders {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UniqueUnreadSenders Property

Aspose.Email

ConversationType.UniqueUnreadSenders Property

public string[] UniqueUnreadSenders {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UnreadCount Property

Aspose.Email

ConversationType.UnreadCount Property

public int UnreadCount {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UnreadCountSpecified Property

Aspose.Email

ConversationType.UnreadCountSpecified Property

public bool UnreadCountSpecified {get; set;}

Remarks

See Also

ConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConvertIdCompletedEventArgs Class

For a list of all members of this type, see ConvertIdCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.ConvertIdCompletedEventArgs

public class ConvertIdCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ConvertIdCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConvertIdCompletedEventArgs Members

ConvertIdCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

ConvertIdCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConvertIdCompletedEventArgs Properties

The properties of the ConvertIdCompletedEventArgs class are listed below. For a complete list of ConvertIdCompletedEventArgs class members, see the ConvertIdCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

ConvertIdCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

ConvertIdCompletedEventArgs.Result Property

public ConvertIdResponseType Result {get;}

Remarks

See Also

ConvertIdCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConvertIdCompletedEventHandler Delegate

public delegate void ConvertIdCompletedEventHandler(
object sender,
ConvertIdCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConvertIdResponseMessageType Class

For a list of all members of this type, see ConvertIdResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.ConvertIdResponseMessageType

public class ConvertIdResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ConvertIdResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConvertIdResponseMessageType Members

ConvertIdResponseMessageType overview

Public Instance Constructors

ConvertIdResponseMessageType Constructor Initializes a new instance of the ConvertIdResponseMessageType class.

Public Instance Properties

AlternateId
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConvertIdResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConvertIdResponseMessageType Constructor

Initializes a new instance of the ConvertIdResponseMessageType class.

public ConvertIdResponseMessageType();

See Also

ConvertIdResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConvertIdResponseMessageType Properties

The properties of the ConvertIdResponseMessageType class are listed below. For a complete list of ConvertIdResponseMessageType class members, see the ConvertIdResponseMessageType Members topic.

Public Instance Properties

AlternateId
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

ConvertIdResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AlternateId Property

Aspose.Email

ConvertIdResponseMessageType.AlternateId Property

public AlternateIdBaseType AlternateId {get; set;}

Remarks

See Also

ConvertIdResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConvertIdResponseType Class

For a list of all members of this type, see ConvertIdResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.ConvertIdResponseType

public class ConvertIdResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ConvertIdResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConvertIdResponseType Members

ConvertIdResponseType overview

Public Instance Constructors

ConvertIdResponseType Constructor Initializes a new instance of the ConvertIdResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConvertIdResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConvertIdResponseType Constructor

Initializes a new instance of the ConvertIdResponseType class.

public ConvertIdResponseType();

See Also

ConvertIdResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConvertIdType Class

For a list of all members of this type, see ConvertIdType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.ConvertIdType

public class ConvertIdType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ConvertIdType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConvertIdType Members

ConvertIdType overview

Public Instance Constructors

ConvertIdType Constructor Initializes a new instance of the ConvertIdType class.

Public Instance Properties

DestinationFormat
SourceIds

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConvertIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConvertIdType Constructor

Initializes a new instance of the ConvertIdType class.

public ConvertIdType();

See Also

ConvertIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConvertIdType Properties

The properties of the ConvertIdType class are listed below. For a complete list of ConvertIdType class members, see the ConvertIdType Members topic.

Public Instance Properties

DestinationFormat
SourceIds

See Also

ConvertIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DestinationFormat Property

Aspose.Email

ConvertIdType.DestinationFormat Property

public IdFormatType DestinationFormat {get; set;}

Remarks

See Also

ConvertIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SourceIds Property

Aspose.Email

ConvertIdType.SourceIds Property

public AlternateIdBaseType[] SourceIds {get; set;}

Remarks

See Also

ConvertIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CopyFolderCompletedEventArgs Class

For a list of all members of this type, see CopyFolderCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.CopyFolderCompletedEventArgs

public class CopyFolderCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CopyFolderCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CopyFolderCompletedEventArgs Members

CopyFolderCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

CopyFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CopyFolderCompletedEventArgs Properties

The properties of the CopyFolderCompletedEventArgs class are listed below. For a complete list of CopyFolderCompletedEventArgs class members, see the CopyFolderCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

CopyFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

CopyFolderCompletedEventArgs.Result Property

public CopyFolderResponseType Result {get;}

Remarks

See Also

CopyFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CopyFolderCompletedEventHandler Delegate

public delegate void CopyFolderCompletedEventHandler(
object sender,
CopyFolderCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CopyFolderResponseType Class

For a list of all members of this type, see CopyFolderResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.CopyFolderResponseType

public class CopyFolderResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CopyFolderResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CopyFolderResponseType Members

CopyFolderResponseType overview

Public Instance Constructors

CopyFolderResponseType Constructor Initializes a new instance of the CopyFolderResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CopyFolderResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CopyFolderResponseType Constructor

Initializes a new instance of the CopyFolderResponseType class.

public CopyFolderResponseType();

See Also

CopyFolderResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CopyFolderType Class

For a list of all members of this type, see CopyFolderType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.BaseMoveCopyFolderType
Aspose.Email.Exchange.Schema.Exchange_2013.CopyFolderType

public class CopyFolderType : BaseMoveCopyFolderType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CopyFolderType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CopyFolderType Members

CopyFolderType overview

Public Instance Constructors

CopyFolderType Constructor Initializes a new instance of the CopyFolderType class.

Public Instance Properties

FolderIds (inherited from BaseMoveCopyFolderType)
ToFolderId (inherited from BaseMoveCopyFolderType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CopyFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CopyFolderType Constructor

Initializes a new instance of the CopyFolderType class.

public CopyFolderType();

See Also

CopyFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CopyItemCompletedEventArgs Class

For a list of all members of this type, see CopyItemCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.CopyItemCompletedEventArgs

public class CopyItemCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CopyItemCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CopyItemCompletedEventArgs Members

CopyItemCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

CopyItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CopyItemCompletedEventArgs Properties

The properties of the CopyItemCompletedEventArgs class are listed below. For a complete list of CopyItemCompletedEventArgs class members, see the CopyItemCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

CopyItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

CopyItemCompletedEventArgs.Result Property

public CopyItemResponseType Result {get;}

Remarks

See Also

CopyItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CopyItemCompletedEventHandler Delegate

public delegate void CopyItemCompletedEventHandler(
object sender,
CopyItemCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CopyItemResponseType Class

For a list of all members of this type, see CopyItemResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.CopyItemResponseType

public class CopyItemResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CopyItemResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CopyItemResponseType Members

CopyItemResponseType overview

Public Instance Constructors

CopyItemResponseType Constructor Initializes a new instance of the CopyItemResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CopyItemResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CopyItemResponseType Constructor

Initializes a new instance of the CopyItemResponseType class.

public CopyItemResponseType();

See Also

CopyItemResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CopyItemType Class

For a list of all members of this type, see CopyItemType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.BaseMoveCopyItemType
Aspose.Email.Exchange.Schema.Exchange_2013.CopyItemType

public class CopyItemType : BaseMoveCopyItemType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CopyItemType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CopyItemType Members

CopyItemType overview

Public Instance Constructors

CopyItemType Constructor Initializes a new instance of the CopyItemType class.

Public Instance Properties

ItemIds (inherited from BaseMoveCopyItemType)
ReturnNewItemIds (inherited from BaseMoveCopyItemType)
ReturnNewItemIdsSpecified (inherited from BaseMoveCopyItemType)
ToFolderId (inherited from BaseMoveCopyItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CopyItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CopyItemType Constructor

Initializes a new instance of the CopyItemType class.

public CopyItemType();

See Also

CopyItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateActionType Enumeration

public enum CreateActionType

Remarks

Members

Member Name | Description | Value
CreateNew |  | 0
Update |  | 1
UpdateOrCreate |  | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateAttachmentCompletedEventArgs Class

For a list of all members of this type, see CreateAttachmentCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.CreateAttachmentCompletedEventArgs

public class CreateAttachmentCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CreateAttachmentCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateAttachmentCompletedEventArgs Members

CreateAttachmentCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

CreateAttachmentCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateAttachmentCompletedEventArgs Properties

The properties of the CreateAttachmentCompletedEventArgs class are listed below. For a complete list of CreateAttachmentCompletedEventArgs class members, see the CreateAttachmentCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

CreateAttachmentCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

CreateAttachmentCompletedEventArgs.Result Property

public CreateAttachmentResponseType Result {get;}

Remarks

See Also

CreateAttachmentCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateAttachmentCompletedEventHandler Delegate

public delegate void CreateAttachmentCompletedEventHandler(
object sender,
CreateAttachmentCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateAttachmentResponseType Class

For a list of all members of this type, see CreateAttachmentResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.CreateAttachmentResponseType

public class CreateAttachmentResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CreateAttachmentResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateAttachmentResponseType Members

CreateAttachmentResponseType overview

Public Instance Constructors

CreateAttachmentResponseType Constructor Initializes a new instance of the CreateAttachmentResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CreateAttachmentResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateAttachmentResponseType Constructor

Initializes a new instance of the CreateAttachmentResponseType class.

public CreateAttachmentResponseType();

See Also

CreateAttachmentResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateAttachmentType Class

For a list of all members of this type, see CreateAttachmentType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.CreateAttachmentType

public class CreateAttachmentType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CreateAttachmentType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateAttachmentType Members

CreateAttachmentType overview

Public Instance Constructors

CreateAttachmentType Constructor Initializes a new instance of the CreateAttachmentType class.

Public Instance Properties

Attachments
ParentItemId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CreateAttachmentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateAttachmentType Constructor

Initializes a new instance of the CreateAttachmentType class.

public CreateAttachmentType();

See Also

CreateAttachmentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateAttachmentType Properties

The properties of the CreateAttachmentType class are listed below. For a complete list of CreateAttachmentType class members, see the CreateAttachmentType Members topic.

Public Instance Properties

Attachments
ParentItemId

See Also

CreateAttachmentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Attachments Property

Aspose.Email

CreateAttachmentType.Attachments Property

public AttachmentType[] Attachments {get; set;}

Remarks

See Also

CreateAttachmentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ParentItemId Property

Aspose.Email

CreateAttachmentType.ParentItemId Property

public ItemIdType ParentItemId {get; set;}

Remarks

See Also

CreateAttachmentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateFolderCompletedEventArgs Class

For a list of all members of this type, see CreateFolderCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.CreateFolderCompletedEventArgs

public class CreateFolderCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CreateFolderCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateFolderCompletedEventArgs Members

CreateFolderCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

CreateFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateFolderCompletedEventArgs Properties

The properties of the CreateFolderCompletedEventArgs class are listed below. For a complete list of CreateFolderCompletedEventArgs class members, see the CreateFolderCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

CreateFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

CreateFolderCompletedEventArgs.Result Property

public CreateFolderResponseType Result {get;}

Remarks

See Also

CreateFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateFolderCompletedEventHandler Delegate

public delegate void CreateFolderCompletedEventHandler(
object sender,
CreateFolderCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateFolderPathCompletedEventArgs Class

For a list of all members of this type, see CreateFolderPathCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.CreateFolderPathCompletedEventArgs

public class CreateFolderPathCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CreateFolderPathCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateFolderPathCompletedEventArgs Members

CreateFolderPathCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

CreateFolderPathCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateFolderPathCompletedEventArgs Properties

The properties of the CreateFolderPathCompletedEventArgs class are listed below. For a complete list of CreateFolderPathCompletedEventArgs class members, see the CreateFolderPathCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

CreateFolderPathCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

CreateFolderPathCompletedEventArgs.Result Property

public CreateFolderPathResponseType Result {get;}

Remarks

See Also

CreateFolderPathCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateFolderPathCompletedEventHandler Delegate

public delegate void CreateFolderPathCompletedEventHandler(
object sender,
CreateFolderPathCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateFolderPathResponseType Class

For a list of all members of this type, see CreateFolderPathResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.CreateFolderPathResponseType

public class CreateFolderPathResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CreateFolderPathResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateFolderPathResponseType Members

CreateFolderPathResponseType overview

Public Instance Constructors

CreateFolderPathResponseType Constructor Initializes a new instance of the CreateFolderPathResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CreateFolderPathResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateFolderPathResponseType Constructor

Initializes a new instance of the CreateFolderPathResponseType class.

public CreateFolderPathResponseType();

See Also

CreateFolderPathResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateFolderPathType Class

For a list of all members of this type, see CreateFolderPathType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.CreateFolderPathType

public class CreateFolderPathType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CreateFolderPathType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateFolderPathType Members

CreateFolderPathType overview

Public Instance Constructors

CreateFolderPathType Constructor Initializes a new instance of the CreateFolderPathType class.

Public Instance Properties

ParentFolderId
RelativeFolderPath

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CreateFolderPathType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateFolderPathType Constructor

Initializes a new instance of the CreateFolderPathType class.

public CreateFolderPathType();

See Also

CreateFolderPathType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateFolderPathType Properties

The properties of the CreateFolderPathType class are listed below. For a complete list of CreateFolderPathType class members, see the CreateFolderPathType Members topic.

Public Instance Properties

ParentFolderId
RelativeFolderPath

See Also

CreateFolderPathType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ParentFolderId Property

Aspose.Email

CreateFolderPathType.ParentFolderId Property

public TargetFolderIdType ParentFolderId {get; set;}

Remarks

See Also

CreateFolderPathType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RelativeFolderPath Property

Aspose.Email

CreateFolderPathType.RelativeFolderPath Property

public BaseFolderType[] RelativeFolderPath {get; set;}

Remarks

See Also

CreateFolderPathType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateFolderResponseType Class

For a list of all members of this type, see CreateFolderResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.CreateFolderResponseType

public class CreateFolderResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CreateFolderResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateFolderResponseType Members

CreateFolderResponseType overview

Public Instance Constructors

CreateFolderResponseType Constructor Initializes a new instance of the CreateFolderResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CreateFolderResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateFolderResponseType Constructor

Initializes a new instance of the CreateFolderResponseType class.

public CreateFolderResponseType();

See Also

CreateFolderResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateFolderType Class

For a list of all members of this type, see CreateFolderType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.CreateFolderType

public class CreateFolderType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CreateFolderType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateFolderType Members

CreateFolderType overview

Public Instance Constructors

CreateFolderType Constructor Initializes a new instance of the CreateFolderType class.

Public Instance Properties

Folders
ParentFolderId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CreateFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateFolderType Constructor

Initializes a new instance of the CreateFolderType class.

public CreateFolderType();

See Also

CreateFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateFolderType Properties

The properties of the CreateFolderType class are listed below. For a complete list of CreateFolderType class members, see the CreateFolderType Members topic.

Public Instance Properties

Folders
ParentFolderId

See Also

CreateFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Folders Property

Aspose.Email

CreateFolderType.Folders Property

public BaseFolderType[] Folders {get; set;}

Remarks

See Also

CreateFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ParentFolderId Property

Aspose.Email

CreateFolderType.ParentFolderId Property

public TargetFolderIdType ParentFolderId {get; set;}

Remarks

See Also

CreateFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateItemCompletedEventArgs Class

For a list of all members of this type, see CreateItemCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.CreateItemCompletedEventArgs

public class CreateItemCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CreateItemCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateItemCompletedEventArgs Members

CreateItemCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

CreateItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateItemCompletedEventArgs Properties

The properties of the CreateItemCompletedEventArgs class are listed below. For a complete list of CreateItemCompletedEventArgs class members, see the CreateItemCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

CreateItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

CreateItemCompletedEventArgs.Result Property

public CreateItemResponseType Result {get;}

Remarks

See Also

CreateItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateItemCompletedEventHandler Delegate

public delegate void CreateItemCompletedEventHandler(
object sender,
CreateItemCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateItemResponseType Class

For a list of all members of this type, see CreateItemResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.CreateItemResponseType

public class CreateItemResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CreateItemResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateItemResponseType Members

CreateItemResponseType overview

Public Instance Constructors

CreateItemResponseType Constructor Initializes a new instance of the CreateItemResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CreateItemResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateItemResponseType Constructor

Initializes a new instance of the CreateItemResponseType class.

public CreateItemResponseType();

See Also

CreateItemResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateItemType Class

For a list of all members of this type, see CreateItemType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.CreateItemType

public class CreateItemType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CreateItemType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateItemType Members

CreateItemType overview

Public Instance Constructors

CreateItemType Constructor Initializes a new instance of the CreateItemType class.

Public Instance Properties

Items
MessageDisposition
MessageDispositionSpecified
SavedItemFolderId
SendMeetingInvitations
SendMeetingInvitationsSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CreateItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateItemType Constructor

Initializes a new instance of the CreateItemType class.

public CreateItemType();

See Also

CreateItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateItemType Properties

The properties of the CreateItemType class are listed below. For a complete list of CreateItemType class members, see the CreateItemType Members topic.

Public Instance Properties

Items
MessageDisposition
MessageDispositionSpecified
SavedItemFolderId
SendMeetingInvitations
SendMeetingInvitationsSpecified

See Also

CreateItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Items Property

Aspose.Email

CreateItemType.Items Property

public NonEmptyArrayOfAllItemsType Items {get; set;}

Remarks

See Also

CreateItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MessageDisposition Property

Aspose.Email

CreateItemType.MessageDisposition Property

public MessageDispositionType MessageDisposition {get; set;}

Remarks

See Also

CreateItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MessageDispositionSpecified Property

Aspose.Email

CreateItemType.MessageDispositionSpecified Property

public bool MessageDispositionSpecified {get; set;}

Remarks

See Also

CreateItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SavedItemFolderId Property

Aspose.Email

CreateItemType.SavedItemFolderId Property

public TargetFolderIdType SavedItemFolderId {get; set;}

Remarks

See Also

CreateItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SendMeetingInvitations Property

Aspose.Email

CreateItemType.SendMeetingInvitations Property

public CalendarItemCreateOrDeleteOperationType SendMeetingInvitations {get; set;}

Remarks

See Also

CreateItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SendMeetingInvitationsSpecified Property

Aspose.Email

CreateItemType.SendMeetingInvitationsSpecified Property

public bool SendMeetingInvitationsSpecified {get; set;}

Remarks

See Also

CreateItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateManagedFolderCompletedEventArgs Class

For a list of all members of this type, see CreateManagedFolderCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.CreateManagedFolderCompletedEventArgs

public class CreateManagedFolderCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CreateManagedFolderCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateManagedFolderCompletedEventArgs Members

CreateManagedFolderCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

CreateManagedFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateManagedFolderCompletedEventArgs Properties

The properties of the CreateManagedFolderCompletedEventArgs class are listed below. For a complete list of CreateManagedFolderCompletedEventArgs class members, see the CreateManagedFolderCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

CreateManagedFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

CreateManagedFolderCompletedEventArgs.Result Property

public CreateManagedFolderResponseType Result {get;}

Remarks

See Also

CreateManagedFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateManagedFolderCompletedEventHandler Delegate

public delegate void CreateManagedFolderCompletedEventHandler(
object sender,
CreateManagedFolderCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateManagedFolderRequestType Class

For a list of all members of this type, see CreateManagedFolderRequestType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.CreateManagedFolderRequestType

public class CreateManagedFolderRequestType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CreateManagedFolderRequestType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateManagedFolderRequestType Members

CreateManagedFolderRequestType overview

Public Instance Constructors

CreateManagedFolderRequestType Constructor Initializes a new instance of the CreateManagedFolderRequestType class.

Public Instance Properties

FolderNames
Mailbox

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CreateManagedFolderRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateManagedFolderRequestType Constructor

Initializes a new instance of the CreateManagedFolderRequestType class.

public CreateManagedFolderRequestType();

See Also

CreateManagedFolderRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateManagedFolderRequestType Properties

The properties of the CreateManagedFolderRequestType class are listed below. For a complete list of CreateManagedFolderRequestType class members, see the CreateManagedFolderRequestType Members topic.

Public Instance Properties

FolderNames
Mailbox

See Also

CreateManagedFolderRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FolderNames Property

Aspose.Email

CreateManagedFolderRequestType.FolderNames Property

public string[] FolderNames {get; set;}

Remarks

See Also

CreateManagedFolderRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Mailbox Property

Aspose.Email

CreateManagedFolderRequestType.Mailbox Property

public EmailAddressType Mailbox {get; set;}

Remarks

See Also

CreateManagedFolderRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateManagedFolderResponseType Class

For a list of all members of this type, see CreateManagedFolderResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.CreateManagedFolderResponseType

public class CreateManagedFolderResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CreateManagedFolderResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateManagedFolderResponseType Members

CreateManagedFolderResponseType overview

Public Instance Constructors

CreateManagedFolderResponseType Constructor Initializes a new instance of the CreateManagedFolderResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CreateManagedFolderResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateManagedFolderResponseType Constructor

Initializes a new instance of the CreateManagedFolderResponseType class.

public CreateManagedFolderResponseType();

See Also

CreateManagedFolderResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateRuleOperationType Class

For a list of all members of this type, see CreateRuleOperationType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.RuleOperationType
Aspose.Email.Exchange.Schema.Exchange_2013.CreateRuleOperationType

public class CreateRuleOperationType : RuleOperationType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CreateRuleOperationType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateRuleOperationType Members

CreateRuleOperationType overview

Public Instance Constructors

CreateRuleOperationType Constructor Initializes a new instance of the CreateRuleOperationType class.

Public Instance Properties

Rule

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CreateRuleOperationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateRuleOperationType Constructor

Initializes a new instance of the CreateRuleOperationType class.

public CreateRuleOperationType();

See Also

CreateRuleOperationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateRuleOperationType Properties

The properties of the CreateRuleOperationType class are listed below. For a complete list of CreateRuleOperationType class members, see the CreateRuleOperationType Members topic.

Public Instance Properties

Rule

See Also

CreateRuleOperationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Rule Property

Aspose.Email

CreateRuleOperationType.Rule Property

public RuleType Rule {get; set;}

Remarks

See Also

CreateRuleOperationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateUMCallDataRecordResponseMessageType Class

For a list of all members of this type, see CreateUMCallDataRecordResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.CreateUMCallDataRecordResponseMessageType

public class CreateUMCallDataRecordResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CreateUMCallDataRecordResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateUMCallDataRecordResponseMessageType Members

CreateUMCallDataRecordResponseMessageType overview

Public Instance Constructors

CreateUMCallDataRecordResponseMessageType Constructor Initializes a new instance of the CreateUMCallDataRecordResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CreateUMCallDataRecordResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateUMCallDataRecordResponseMessageType Constructor

Initializes a new instance of the CreateUMCallDataRecordResponseMessageType class.

public CreateUMCallDataRecordResponseMessageType();

See Also

CreateUMCallDataRecordResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateUMCallDataRecordType Class

For a list of all members of this type, see CreateUMCallDataRecordType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.CreateUMCallDataRecordType

public class CreateUMCallDataRecordType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CreateUMCallDataRecordType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateUMCallDataRecordType Members

CreateUMCallDataRecordType overview

Public Instance Constructors

CreateUMCallDataRecordType Constructor Initializes a new instance of the CreateUMCallDataRecordType class.

Public Instance Properties

CDRData

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CreateUMCallDataRecordType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateUMCallDataRecordType Constructor

Initializes a new instance of the CreateUMCallDataRecordType class.

public CreateUMCallDataRecordType();

See Also

CreateUMCallDataRecordType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateUMCallDataRecordType Properties

The properties of the CreateUMCallDataRecordType class are listed below. For a complete list of CreateUMCallDataRecordType class members, see the CreateUMCallDataRecordType Members topic.

Public Instance Properties

CDRData

See Also

CreateUMCallDataRecordType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CDRData Property

Aspose.Email

CreateUMCallDataRecordType.CDRData Property

public CDRDataType CDRData {get; set;}

Remarks

See Also

CreateUMCallDataRecordType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateUMPromptResponseMessageType Class

For a list of all members of this type, see CreateUMPromptResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.CreateUMPromptResponseMessageType

public class CreateUMPromptResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CreateUMPromptResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateUMPromptResponseMessageType Members

CreateUMPromptResponseMessageType overview

Public Instance Constructors

CreateUMPromptResponseMessageType Constructor Initializes a new instance of the CreateUMPromptResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CreateUMPromptResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateUMPromptResponseMessageType Constructor

Initializes a new instance of the CreateUMPromptResponseMessageType class.

public CreateUMPromptResponseMessageType();

See Also

CreateUMPromptResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateUMPromptType Class

For a list of all members of this type, see CreateUMPromptType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.CreateUMPromptType

public class CreateUMPromptType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CreateUMPromptType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateUMPromptType Members

CreateUMPromptType overview

Public Instance Constructors

CreateUMPromptType Constructor Initializes a new instance of the CreateUMPromptType class.

Public Instance Properties

AudioData
ConfigurationObject
PromptName

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CreateUMPromptType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateUMPromptType Constructor

Initializes a new instance of the CreateUMPromptType class.

public CreateUMPromptType();

See Also

CreateUMPromptType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateUMPromptType Properties

The properties of the CreateUMPromptType class are listed below. For a complete list of CreateUMPromptType class members, see the CreateUMPromptType Members topic.

Public Instance Properties

AudioData
ConfigurationObject
PromptName

See Also

CreateUMPromptType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AudioData Property

Aspose.Email

CreateUMPromptType.AudioData Property

public byte[] AudioData {get; set;}

Remarks

See Also

CreateUMPromptType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConfigurationObject Property

Aspose.Email

CreateUMPromptType.ConfigurationObject Property

public string ConfigurationObject {get; set;}

Remarks

See Also

CreateUMPromptType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PromptName Property

Aspose.Email

CreateUMPromptType.PromptName Property

public string PromptName {get; set;}

Remarks

See Also

CreateUMPromptType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateUserConfigurationCompletedEventArgs Class

For a list of all members of this type, see CreateUserConfigurationCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.CreateUserConfigurationCompletedEventArgs

public class CreateUserConfigurationCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CreateUserConfigurationCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateUserConfigurationCompletedEventArgs Members

CreateUserConfigurationCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

CreateUserConfigurationCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateUserConfigurationCompletedEventArgs Properties

The properties of the CreateUserConfigurationCompletedEventArgs class are listed below. For a complete list of CreateUserConfigurationCompletedEventArgs class members, see the CreateUserConfigurationCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

CreateUserConfigurationCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

CreateUserConfigurationCompletedEventArgs.Result Property

public CreateUserConfigurationResponseType Result {get;}

Remarks

See Also

CreateUserConfigurationCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateUserConfigurationCompletedEventHandler Delegate

public delegate void CreateUserConfigurationCompletedEventHandler(
object sender,
CreateUserConfigurationCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateUserConfigurationResponseType Class

For a list of all members of this type, see CreateUserConfigurationResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.CreateUserConfigurationResponseType

public class CreateUserConfigurationResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CreateUserConfigurationResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateUserConfigurationResponseType Members

CreateUserConfigurationResponseType overview

Public Instance Constructors

CreateUserConfigurationResponseType Constructor Initializes a new instance of the CreateUserConfigurationResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CreateUserConfigurationResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateUserConfigurationResponseType Constructor

Initializes a new instance of the CreateUserConfigurationResponseType class.

public CreateUserConfigurationResponseType();

See Also

CreateUserConfigurationResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateUserConfigurationType Class

For a list of all members of this type, see CreateUserConfigurationType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.CreateUserConfigurationType

public class CreateUserConfigurationType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CreateUserConfigurationType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateUserConfigurationType Members

CreateUserConfigurationType overview

Public Instance Constructors

CreateUserConfigurationType Constructor Initializes a new instance of the CreateUserConfigurationType class.

Public Instance Properties

UserConfiguration

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CreateUserConfigurationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateUserConfigurationType Constructor

Initializes a new instance of the CreateUserConfigurationType class.

public CreateUserConfigurationType();

See Also

CreateUserConfigurationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateUserConfigurationType Properties

The properties of the CreateUserConfigurationType class are listed below. For a complete list of CreateUserConfigurationType class members, see the CreateUserConfigurationType Members topic.

Public Instance Properties

UserConfiguration

See Also

CreateUserConfigurationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserConfiguration Property

Aspose.Email

CreateUserConfigurationType.UserConfiguration Property

public UserConfigurationType UserConfiguration {get; set;}

Remarks

See Also

CreateUserConfigurationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DailyRecurrencePatternType Class

For a list of all members of this type, see DailyRecurrencePatternType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.RecurrencePatternBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.IntervalRecurrencePatternBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.DailyRecurrencePatternType

public class DailyRecurrencePatternType : IntervalRecurrencePatternBaseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DailyRecurrencePatternType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DailyRecurrencePatternType Members

DailyRecurrencePatternType overview

Public Instance Constructors

DailyRecurrencePatternType Constructor Initializes a new instance of the DailyRecurrencePatternType class.

Public Instance Properties

Interval (inherited from IntervalRecurrencePatternBaseType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DailyRecurrencePatternType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DailyRecurrencePatternType Constructor

Initializes a new instance of the DailyRecurrencePatternType class.

public DailyRecurrencePatternType();

See Also

DailyRecurrencePatternType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DailyRegeneratingPatternType Class

For a list of all members of this type, see DailyRegeneratingPatternType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.RecurrencePatternBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.IntervalRecurrencePatternBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.RegeneratingPatternBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.DailyRegeneratingPatternType

public class DailyRegeneratingPatternType : RegeneratingPatternBaseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DailyRegeneratingPatternType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DailyRegeneratingPatternType Members

DailyRegeneratingPatternType overview

Public Instance Constructors

DailyRegeneratingPatternType Constructor Initializes a new instance of the DailyRegeneratingPatternType class.

Public Instance Properties

Interval (inherited from IntervalRecurrencePatternBaseType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DailyRegeneratingPatternType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DailyRegeneratingPatternType Constructor

Initializes a new instance of the DailyRegeneratingPatternType class.

public DailyRegeneratingPatternType();

See Also

DailyRegeneratingPatternType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DateTimePrecisionType Class

For a list of all members of this type, see DateTimePrecisionType Members.

System.Object
System.Web.Services.Protocols.SoapHeader
Aspose.Email.Exchange.Schema.Exchange_2013.DateTimePrecisionType

public class DateTimePrecisionType : SoapHeader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DateTimePrecisionType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DateTimePrecisionType Members

DateTimePrecisionType overview

Public Instance Constructors

DateTimePrecisionType Constructor Initializes a new instance of the DateTimePrecisionType class.

Public Instance Properties

Actor (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.
DidUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether an XML Web service method properly processed a SOAP header.
EncodedMustUnderstand (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.1.
EncodedMustUnderstand12 (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.2.
EncodedRelay (inherited from SoapHeader) | Gets or sets the relay attribute of the SOAP 1.2 header.
MustUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether the SoapHeader must be understood.
Relay (inherited from SoapHeader) | Gets or sets a value that indicates whether the SOAP header is to be relayed to the next SOAP node if the current node does not understand the header.
Role (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.
Text |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DateTimePrecisionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DateTimePrecisionType Constructor

Initializes a new instance of the DateTimePrecisionType class.

public DateTimePrecisionType();

See Also

DateTimePrecisionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DateTimePrecisionType Properties

The properties of the DateTimePrecisionType class are listed below. For a complete list of DateTimePrecisionType class members, see the DateTimePrecisionType Members topic.

Public Instance Properties

Actor (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.
DidUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether an XML Web service method properly processed a SOAP header.
EncodedMustUnderstand (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.1.
EncodedMustUnderstand12 (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.2.
EncodedRelay (inherited from SoapHeader) | Gets or sets the relay attribute of the SOAP 1.2 header.
MustUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether the SoapHeader must be understood.
Relay (inherited from SoapHeader) | Gets or sets a value that indicates whether the SOAP header is to be relayed to the next SOAP node if the current node does not understand the header.
Role (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.
Text |

See Also

DateTimePrecisionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Text Property

Aspose.Email

DateTimePrecisionType.Text Property

public string[] Text {get; set;}

Remarks

See Also

DateTimePrecisionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DayOfWeekIndexType Enumeration

public enum DayOfWeekIndexType

Remarks

Members

Member Name | Description | Value
First |  | 0
Second |  | 1
Third |  | 2
Fourth |  | 3
Last |  | 4

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DayOfWeekType Enumeration

public enum DayOfWeekType

Remarks

Members

Member Name | Description | Value
Sunday |  | 0
Monday |  | 1
Tuesday |  | 2
Wednesday |  | 3
Thursday |  | 4
Friday |  | 5
Saturday |  | 6
Day |  | 7
Weekday |  | 8
WeekendDay |  | 9

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeclineItemType Class

For a list of all members of this type, see DeclineItemType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ItemType
Aspose.Email.Exchange.Schema.Exchange_2013.MessageType
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseObjectCoreType
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseObjectType
Aspose.Email.Exchange.Schema.Exchange_2013.WellKnownResponseObjectType
Aspose.Email.Exchange.Schema.Exchange_2013.DeclineItemType

public class DeclineItemType : WellKnownResponseObjectType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DeclineItemType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeclineItemType Members

DeclineItemType overview

Public Instance Constructors

DeclineItemType Constructor Initializes a new instance of the DeclineItemType class.

Public Instance Properties

ArchiveTag (inherited from ItemType)
Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
BlockStatus (inherited from ItemType)
BlockStatusSpecified (inherited from ItemType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
EntityExtractionResult (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
Flag (inherited from ItemType)
From (inherited from MessageType)
GroupingAction (inherited from ItemType)
GroupingActionSpecified (inherited from ItemType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBlockedImages (inherited from ItemType)
HasBlockedImagesSpecified (inherited from ItemType)
IconIndex (inherited from ItemType)
IconIndexSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InstanceKey (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
NextPredictedAction (inherited from ItemType)
NextPredictedActionSpecified (inherited from ItemType)
NormalizedBody (inherited from ItemType)
ObjectName (inherited from ResponseObjectType)
ParentFolderId (inherited from ItemType)
PolicyTag (inherited from ItemType)
Preview (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
ReferenceItemId (inherited from ResponseObjectCoreType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReminderNextTime (inherited from ItemType)
ReminderNextTimeSpecified (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
RetentionDate (inherited from ItemType)
RetentionDateSpecified (inherited from ItemType)
RightsManagementLicenseData (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
StoreEntryId (inherited from ItemType)
Subject (inherited from ItemType)
TextBody (inherited from ItemType)
ToRecipients (inherited from MessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DeclineItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeclineItemType Constructor

Initializes a new instance of the DeclineItemType class.

public DeclineItemType();

See Also

DeclineItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DefaultShapeNamesType Enumeration

public enum DefaultShapeNamesType

Remarks

Members

Member Name | Description | Value
IdOnly |  | 0
Default |  | 1
AllProperties |  | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DelegateFolderPermissionLevelType Enumeration

public enum DelegateFolderPermissionLevelType

Remarks

Members

Member Name | Description | Value
None |  | 0
Editor |  | 1
Reviewer |  | 2
Author |  | 3
Custom |  | 4

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DelegatePermissionsType Class

For a list of all members of this type, see DelegatePermissionsType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.DelegatePermissionsType

public class DelegatePermissionsType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DelegatePermissionsType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DelegatePermissionsType Members

DelegatePermissionsType overview

Public Instance Constructors

DelegatePermissionsType Constructor Initializes a new instance of the DelegatePermissionsType class.

Public Instance Properties

CalendarFolderPermissionLevel
CalendarFolderPermissionLevelSpecified
ContactsFolderPermissionLevel
ContactsFolderPermissionLevelSpecified
InboxFolderPermissionLevel
InboxFolderPermissionLevelSpecified
JournalFolderPermissionLevel
JournalFolderPermissionLevelSpecified
NotesFolderPermissionLevel
NotesFolderPermissionLevelSpecified
TasksFolderPermissionLevel
TasksFolderPermissionLevelSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DelegatePermissionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DelegatePermissionsType Constructor

Initializes a new instance of the DelegatePermissionsType class.

public DelegatePermissionsType();

See Also

DelegatePermissionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DelegatePermissionsType Properties

The properties of the DelegatePermissionsType class are listed below. For a complete list of DelegatePermissionsType class members, see the DelegatePermissionsType Members topic.

Public Instance Properties

CalendarFolderPermissionLevel
CalendarFolderPermissionLevelSpecified
ContactsFolderPermissionLevel
ContactsFolderPermissionLevelSpecified
InboxFolderPermissionLevel
InboxFolderPermissionLevelSpecified
JournalFolderPermissionLevel
JournalFolderPermissionLevelSpecified
NotesFolderPermissionLevel
NotesFolderPermissionLevelSpecified
TasksFolderPermissionLevel
TasksFolderPermissionLevelSpecified

See Also

DelegatePermissionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalendarFolderPermissionLevel Property

Aspose.Email

DelegatePermissionsType.CalendarFolderPermissionLevel Property

public DelegateFolderPermissionLevelType CalendarFolderPermissionLevel {get; set;}

Remarks

See Also

DelegatePermissionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalendarFolderPermissionLevelSpecified Property

Aspose.Email

DelegatePermissionsType.CalendarFolderPermissionLevelSpecified Property

public bool CalendarFolderPermissionLevelSpecified {get; set;}

Remarks

See Also

DelegatePermissionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContactsFolderPermissionLevel Property

Aspose.Email

DelegatePermissionsType.ContactsFolderPermissionLevel Property

public DelegateFolderPermissionLevelType ContactsFolderPermissionLevel {get; set;}

Remarks

See Also

DelegatePermissionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContactsFolderPermissionLevelSpecified Property

Aspose.Email

DelegatePermissionsType.ContactsFolderPermissionLevelSpecified Property

public bool ContactsFolderPermissionLevelSpecified {get; set;}

Remarks

See Also

DelegatePermissionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InboxFolderPermissionLevel Property

Aspose.Email

DelegatePermissionsType.InboxFolderPermissionLevel Property

public DelegateFolderPermissionLevelType InboxFolderPermissionLevel {get; set;}

Remarks

See Also

DelegatePermissionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InboxFolderPermissionLevelSpecified Property

Aspose.Email

DelegatePermissionsType.InboxFolderPermissionLevelSpecified Property

public bool InboxFolderPermissionLevelSpecified {get; set;}

Remarks

See Also

DelegatePermissionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


JournalFolderPermissionLevel Property

Aspose.Email

DelegatePermissionsType.JournalFolderPermissionLevel Property

public DelegateFolderPermissionLevelType JournalFolderPermissionLevel {get; set;}

Remarks

See Also

DelegatePermissionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


JournalFolderPermissionLevelSpecified Property

Aspose.Email

DelegatePermissionsType.JournalFolderPermissionLevelSpecified Property

public bool JournalFolderPermissionLevelSpecified {get; set;}

Remarks

See Also

DelegatePermissionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NotesFolderPermissionLevel Property

Aspose.Email

DelegatePermissionsType.NotesFolderPermissionLevel Property

public DelegateFolderPermissionLevelType NotesFolderPermissionLevel {get; set;}

Remarks

See Also

DelegatePermissionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NotesFolderPermissionLevelSpecified Property

Aspose.Email

DelegatePermissionsType.NotesFolderPermissionLevelSpecified Property

public bool NotesFolderPermissionLevelSpecified {get; set;}

Remarks

See Also

DelegatePermissionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TasksFolderPermissionLevel Property

Aspose.Email

DelegatePermissionsType.TasksFolderPermissionLevel Property

public DelegateFolderPermissionLevelType TasksFolderPermissionLevel {get; set;}

Remarks

See Also

DelegatePermissionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TasksFolderPermissionLevelSpecified Property

Aspose.Email

DelegatePermissionsType.TasksFolderPermissionLevelSpecified Property

public bool TasksFolderPermissionLevelSpecified {get; set;}

Remarks

See Also

DelegatePermissionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DelegateUserResponseMessageType Class

For a list of all members of this type, see DelegateUserResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.DelegateUserResponseMessageType

public class DelegateUserResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DelegateUserResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DelegateUserResponseMessageType Members

DelegateUserResponseMessageType overview

Public Instance Constructors

DelegateUserResponseMessageType Constructor Initializes a new instance of the DelegateUserResponseMessageType class.

Public Instance Properties

DelegateUser
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DelegateUserResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DelegateUserResponseMessageType Constructor

Initializes a new instance of the DelegateUserResponseMessageType class.

public DelegateUserResponseMessageType();

See Also

DelegateUserResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DelegateUserResponseMessageType Properties

The properties of the DelegateUserResponseMessageType class are listed below. For a complete list of DelegateUserResponseMessageType class members, see the DelegateUserResponseMessageType Members topic.

Public Instance Properties

DelegateUser
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

DelegateUserResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DelegateUser Property

Aspose.Email

DelegateUserResponseMessageType.DelegateUser Property

public DelegateUserType DelegateUser {get; set;}

Remarks

See Also

DelegateUserResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DelegateUserType Class

For a list of all members of this type, see DelegateUserType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.DelegateUserType

public class DelegateUserType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DelegateUserType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DelegateUserType Members

DelegateUserType overview

Public Instance Constructors

DelegateUserType Constructor Initializes a new instance of the DelegateUserType class.

Public Instance Properties

DelegatePermissions
ReceiveCopiesOfMeetingMessages
ReceiveCopiesOfMeetingMessagesSpecified
UserId
ViewPrivateItems
ViewPrivateItemsSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DelegateUserType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DelegateUserType Constructor

Initializes a new instance of the DelegateUserType class.

public DelegateUserType();

See Also

DelegateUserType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DelegateUserType Properties

The properties of the DelegateUserType class are listed below. For a complete list of DelegateUserType class members, see the DelegateUserType Members topic.

Public Instance Properties

DelegatePermissions
ReceiveCopiesOfMeetingMessages
ReceiveCopiesOfMeetingMessagesSpecified
UserId
ViewPrivateItems
ViewPrivateItemsSpecified

See Also

DelegateUserType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DelegatePermissions Property

Aspose.Email

DelegateUserType.DelegatePermissions Property

public DelegatePermissionsType DelegatePermissions {get; set;}

Remarks

See Also

DelegateUserType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReceiveCopiesOfMeetingMessages Property

Aspose.Email

DelegateUserType.ReceiveCopiesOfMeetingMessages Property

public bool ReceiveCopiesOfMeetingMessages {get; set;}

Remarks

See Also

DelegateUserType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReceiveCopiesOfMeetingMessagesSpecified Property

Aspose.Email

DelegateUserType.ReceiveCopiesOfMeetingMessagesSpecified Property

public bool ReceiveCopiesOfMeetingMessagesSpecified {get; set;}

Remarks

See Also

DelegateUserType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserId Property

Aspose.Email

DelegateUserType.UserId Property

public UserIdType UserId {get; set;}

Remarks

See Also

DelegateUserType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ViewPrivateItems Property

Aspose.Email

DelegateUserType.ViewPrivateItems Property

public bool ViewPrivateItems {get; set;}

Remarks

See Also

DelegateUserType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ViewPrivateItemsSpecified Property

Aspose.Email

DelegateUserType.ViewPrivateItemsSpecified Property

public bool ViewPrivateItemsSpecified {get; set;}

Remarks

See Also

DelegateUserType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteAttachmentCompletedEventArgs Class

For a list of all members of this type, see DeleteAttachmentCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.DeleteAttachmentCompletedEventArgs

public class DeleteAttachmentCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DeleteAttachmentCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteAttachmentCompletedEventArgs Members

DeleteAttachmentCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

DeleteAttachmentCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteAttachmentCompletedEventArgs Properties

The properties of the DeleteAttachmentCompletedEventArgs class are listed below. For a complete list of DeleteAttachmentCompletedEventArgs class members, see the DeleteAttachmentCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

DeleteAttachmentCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

DeleteAttachmentCompletedEventArgs.Result Property

public DeleteAttachmentResponseType Result {get;}

Remarks

See Also

DeleteAttachmentCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteAttachmentCompletedEventHandler Delegate

public delegate void DeleteAttachmentCompletedEventHandler(
object sender,
DeleteAttachmentCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteAttachmentResponseMessageType Class

For a list of all members of this type, see DeleteAttachmentResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.DeleteAttachmentResponseMessageType

public class DeleteAttachmentResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DeleteAttachmentResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteAttachmentResponseMessageType Members

DeleteAttachmentResponseMessageType overview

Public Instance Constructors

DeleteAttachmentResponseMessageType Constructor Initializes a new instance of the DeleteAttachmentResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
RootItemId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DeleteAttachmentResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteAttachmentResponseMessageType Constructor

Initializes a new instance of the DeleteAttachmentResponseMessageType class.

public DeleteAttachmentResponseMessageType();

See Also

DeleteAttachmentResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteAttachmentResponseMessageType Properties

The properties of the DeleteAttachmentResponseMessageType class are listed below. For a complete list of DeleteAttachmentResponseMessageType class members, see the DeleteAttachmentResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
RootItemId

See Also

DeleteAttachmentResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RootItemId Property

Aspose.Email

DeleteAttachmentResponseMessageType.RootItemId Property

public RootItemIdType RootItemId {get; set;}

Remarks

See Also

DeleteAttachmentResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteAttachmentResponseType Class

For a list of all members of this type, see DeleteAttachmentResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.DeleteAttachmentResponseType

public class DeleteAttachmentResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DeleteAttachmentResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteAttachmentResponseType Members

DeleteAttachmentResponseType overview

Public Instance Constructors

DeleteAttachmentResponseType Constructor Initializes a new instance of the DeleteAttachmentResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DeleteAttachmentResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteAttachmentResponseType Constructor

Initializes a new instance of the DeleteAttachmentResponseType class.

public DeleteAttachmentResponseType();

See Also

DeleteAttachmentResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteAttachmentType Class

For a list of all members of this type, see DeleteAttachmentType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.DeleteAttachmentType

public class DeleteAttachmentType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DeleteAttachmentType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteAttachmentType Members

DeleteAttachmentType overview

Public Instance Constructors

DeleteAttachmentType Constructor Initializes a new instance of the DeleteAttachmentType class.

Public Instance Properties

AttachmentIds

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DeleteAttachmentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteAttachmentType Constructor

Initializes a new instance of the DeleteAttachmentType class.

public DeleteAttachmentType();

See Also

DeleteAttachmentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteAttachmentType Properties

The properties of the DeleteAttachmentType class are listed below. For a complete list of DeleteAttachmentType class members, see the DeleteAttachmentType Members topic.

Public Instance Properties

AttachmentIds

See Also

DeleteAttachmentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AttachmentIds Property

Aspose.Email

DeleteAttachmentType.AttachmentIds Property

public RequestAttachmentIdType[] AttachmentIds {get; set;}

Remarks

See Also

DeleteAttachmentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeletedOccurrenceInfoType Class

For a list of all members of this type, see DeletedOccurrenceInfoType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.DeletedOccurrenceInfoType

public class DeletedOccurrenceInfoType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DeletedOccurrenceInfoType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeletedOccurrenceInfoType Members

DeletedOccurrenceInfoType overview

Public Instance Constructors

DeletedOccurrenceInfoType Constructor Initializes a new instance of the DeletedOccurrenceInfoType class.

Public Instance Properties

Start

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DeletedOccurrenceInfoType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeletedOccurrenceInfoType Constructor

Initializes a new instance of the DeletedOccurrenceInfoType class.

public DeletedOccurrenceInfoType();

See Also

DeletedOccurrenceInfoType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeletedOccurrenceInfoType Properties

The properties of the DeletedOccurrenceInfoType class are listed below. For a complete list of DeletedOccurrenceInfoType class members, see the DeletedOccurrenceInfoType Members topic.

Public Instance Properties

Start

See Also

DeletedOccurrenceInfoType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Start Property

Aspose.Email

DeletedOccurrenceInfoType.Start Property

public DateTime Start {get; set;}

Remarks

See Also

DeletedOccurrenceInfoType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeletedOccurrenceStateDefinitionType Class

For a list of all members of this type, see DeletedOccurrenceStateDefinitionType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseCalendarItemStateDefinitionType
Aspose.Email.Exchange.Schema.Exchange_2013.DeletedOccurrenceStateDefinitionType

public class DeletedOccurrenceStateDefinitionType : BaseCalendarItemStateDefinitionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DeletedOccurrenceStateDefinitionType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeletedOccurrenceStateDefinitionType Members

DeletedOccurrenceStateDefinitionType overview

Public Instance Constructors

DeletedOccurrenceStateDefinitionType Constructor Initializes a new instance of the DeletedOccurrenceStateDefinitionType class.

Public Instance Properties

IsOccurrencePresent
IsOccurrencePresentSpecified
OccurrenceDate

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DeletedOccurrenceStateDefinitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeletedOccurrenceStateDefinitionType Constructor

Initializes a new instance of the DeletedOccurrenceStateDefinitionType class.

public DeletedOccurrenceStateDefinitionType();

See Also

DeletedOccurrenceStateDefinitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeletedOccurrenceStateDefinitionType Properties

The properties of the DeletedOccurrenceStateDefinitionType class are listed below. For a complete list of DeletedOccurrenceStateDefinitionType class members, see the DeletedOccurrenceStateDefinitionType Members topic.

Public Instance Properties

IsOccurrencePresent
IsOccurrencePresentSpecified
OccurrenceDate

See Also

DeletedOccurrenceStateDefinitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsOccurrencePresent Property

Aspose.Email

DeletedOccurrenceStateDefinitionType.IsOccurrencePresent Property

public bool IsOccurrencePresent {get; set;}

Remarks

See Also

DeletedOccurrenceStateDefinitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsOccurrencePresentSpecified Property

Aspose.Email

DeletedOccurrenceStateDefinitionType.IsOccurrencePresentSpecified Property

public bool IsOccurrencePresentSpecified {get; set;}

Remarks

See Also

DeletedOccurrenceStateDefinitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OccurrenceDate Property

Aspose.Email

DeletedOccurrenceStateDefinitionType.OccurrenceDate Property

public DateTime OccurrenceDate {get; set;}

Remarks

See Also

DeletedOccurrenceStateDefinitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteFolderCompletedEventArgs Class

For a list of all members of this type, see DeleteFolderCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.DeleteFolderCompletedEventArgs

public class DeleteFolderCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DeleteFolderCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteFolderCompletedEventArgs Members

DeleteFolderCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

DeleteFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteFolderCompletedEventArgs Properties

The properties of the DeleteFolderCompletedEventArgs class are listed below. For a complete list of DeleteFolderCompletedEventArgs class members, see the DeleteFolderCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

DeleteFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

DeleteFolderCompletedEventArgs.Result Property

public DeleteFolderResponseType Result {get;}

Remarks

See Also

DeleteFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteFolderCompletedEventHandler Delegate

public delegate void DeleteFolderCompletedEventHandler(
object sender,
DeleteFolderCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteFolderFieldType Class

For a list of all members of this type, see DeleteFolderFieldType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ChangeDescriptionType
Aspose.Email.Exchange.Schema.Exchange_2013.FolderChangeDescriptionType
Aspose.Email.Exchange.Schema.Exchange_2013.DeleteFolderFieldType

public class DeleteFolderFieldType : FolderChangeDescriptionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DeleteFolderFieldType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteFolderFieldType Members

DeleteFolderFieldType overview

Public Instance Constructors

DeleteFolderFieldType Constructor Initializes a new instance of the DeleteFolderFieldType class.

Public Instance Properties

Item (inherited from ChangeDescriptionType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DeleteFolderFieldType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteFolderFieldType Constructor

Initializes a new instance of the DeleteFolderFieldType class.

public DeleteFolderFieldType();

See Also

DeleteFolderFieldType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteFolderResponseType Class

For a list of all members of this type, see DeleteFolderResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.DeleteFolderResponseType

public class DeleteFolderResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DeleteFolderResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteFolderResponseType Members

DeleteFolderResponseType overview

Public Instance Constructors

DeleteFolderResponseType Constructor Initializes a new instance of the DeleteFolderResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DeleteFolderResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteFolderResponseType Constructor

Initializes a new instance of the DeleteFolderResponseType class.

public DeleteFolderResponseType();

See Also

DeleteFolderResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteFolderType Class

For a list of all members of this type, see DeleteFolderType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.DeleteFolderType

public class DeleteFolderType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DeleteFolderType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteFolderType Members

DeleteFolderType overview

Public Instance Constructors

DeleteFolderType Constructor Initializes a new instance of the DeleteFolderType class.

Public Instance Properties

DeleteType
FolderIds

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DeleteFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteFolderType Constructor

Initializes a new instance of the DeleteFolderType class.

public DeleteFolderType();

See Also

DeleteFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteFolderType Properties

The properties of the DeleteFolderType class are listed below. For a complete list of DeleteFolderType class members, see the DeleteFolderType Members topic.

Public Instance Properties

DeleteType
FolderIds

See Also

DeleteFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteType Property

Aspose.Email

DeleteFolderType.DeleteType Property

public DisposalType DeleteType {get; set;}

Remarks

See Also

DeleteFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FolderIds Property

Aspose.Email

DeleteFolderType.FolderIds Property

public BaseFolderIdType[] FolderIds {get; set;}

Remarks

See Also

DeleteFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteFromFolderStateDefinitionType Class

For a list of all members of this type, see DeleteFromFolderStateDefinitionType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseCalendarItemStateDefinitionType
Aspose.Email.Exchange.Schema.Exchange_2013.DeleteFromFolderStateDefinitionType

public class DeleteFromFolderStateDefinitionType : BaseCalendarItemStateDefinitionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DeleteFromFolderStateDefinitionType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteFromFolderStateDefinitionType Members

DeleteFromFolderStateDefinitionType overview

Public Instance Constructors

DeleteFromFolderStateDefinitionType Constructor Initializes a new instance of the DeleteFromFolderStateDefinitionType class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DeleteFromFolderStateDefinitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteFromFolderStateDefinitionType Constructor

Initializes a new instance of the DeleteFromFolderStateDefinitionType class.

public DeleteFromFolderStateDefinitionType();

See Also

DeleteFromFolderStateDefinitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteItemCompletedEventArgs Class

For a list of all members of this type, see DeleteItemCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.DeleteItemCompletedEventArgs

public class DeleteItemCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DeleteItemCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteItemCompletedEventArgs Members

DeleteItemCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

DeleteItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteItemCompletedEventArgs Properties

The properties of the DeleteItemCompletedEventArgs class are listed below. For a complete list of DeleteItemCompletedEventArgs class members, see the DeleteItemCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

DeleteItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

DeleteItemCompletedEventArgs.Result Property

public DeleteItemResponseType Result {get;}

Remarks

See Also

DeleteItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteItemCompletedEventHandler Delegate

public delegate void DeleteItemCompletedEventHandler(
object sender,
DeleteItemCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteItemFieldType Class

For a list of all members of this type, see DeleteItemFieldType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ChangeDescriptionType
Aspose.Email.Exchange.Schema.Exchange_2013.ItemChangeDescriptionType
Aspose.Email.Exchange.Schema.Exchange_2013.DeleteItemFieldType

public class DeleteItemFieldType : ItemChangeDescriptionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DeleteItemFieldType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteItemFieldType Members

DeleteItemFieldType overview

Public Instance Constructors

DeleteItemFieldType Constructor Initializes a new instance of the DeleteItemFieldType class.

Public Instance Properties

Item (inherited from ChangeDescriptionType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DeleteItemFieldType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteItemFieldType Constructor

Initializes a new instance of the DeleteItemFieldType class.

public DeleteItemFieldType();

See Also

DeleteItemFieldType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteItemResponseType Class

For a list of all members of this type, see DeleteItemResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.DeleteItemResponseType

public class DeleteItemResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DeleteItemResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteItemResponseType Members

DeleteItemResponseType overview

Public Instance Constructors

DeleteItemResponseType Constructor Initializes a new instance of the DeleteItemResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DeleteItemResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteItemResponseType Constructor

Initializes a new instance of the DeleteItemResponseType class.

public DeleteItemResponseType();

See Also

DeleteItemResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteItemType Class

For a list of all members of this type, see DeleteItemType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.DeleteItemType

public class DeleteItemType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DeleteItemType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteItemType Members

DeleteItemType overview

Public Instance Constructors

DeleteItemType Constructor Initializes a new instance of the DeleteItemType class.

Public Instance Properties

AffectedTaskOccurrences
AffectedTaskOccurrencesSpecified
DeleteType
ItemIds
SendMeetingCancellations
SendMeetingCancellationsSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DeleteItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteItemType Constructor

Initializes a new instance of the DeleteItemType class.

public DeleteItemType();

See Also

DeleteItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteItemType Properties

The properties of the DeleteItemType class are listed below. For a complete list of DeleteItemType class members, see the DeleteItemType Members topic.

Public Instance Properties

AffectedTaskOccurrences
AffectedTaskOccurrencesSpecified
DeleteType
ItemIds
SendMeetingCancellations
SendMeetingCancellationsSpecified

See Also

DeleteItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AffectedTaskOccurrences Property

Aspose.Email

DeleteItemType.AffectedTaskOccurrences Property

public AffectedTaskOccurrencesType AffectedTaskOccurrences {get; set;}

Remarks

See Also

DeleteItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AffectedTaskOccurrencesSpecified Property

Aspose.Email

DeleteItemType.AffectedTaskOccurrencesSpecified Property

public bool AffectedTaskOccurrencesSpecified {get; set;}

Remarks

See Also

DeleteItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteType Property

Aspose.Email

DeleteItemType.DeleteType Property

public DisposalType DeleteType {get; set;}

Remarks

See Also

DeleteItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemIds Property

Aspose.Email

DeleteItemType.ItemIds Property

public BaseItemIdType[] ItemIds {get; set;}

Remarks

See Also

DeleteItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SendMeetingCancellations Property

Aspose.Email

DeleteItemType.SendMeetingCancellations Property

public CalendarItemCreateOrDeleteOperationType SendMeetingCancellations {get; set;}

Remarks

See Also

DeleteItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SendMeetingCancellationsSpecified Property

Aspose.Email

DeleteItemType.SendMeetingCancellationsSpecified Property

public bool SendMeetingCancellationsSpecified {get; set;}

Remarks

See Also

DeleteItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteRuleOperationType Class

For a list of all members of this type, see DeleteRuleOperationType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.RuleOperationType
Aspose.Email.Exchange.Schema.Exchange_2013.DeleteRuleOperationType

public class DeleteRuleOperationType : RuleOperationType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DeleteRuleOperationType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteRuleOperationType Members

DeleteRuleOperationType overview

Public Instance Constructors

DeleteRuleOperationType Constructor Initializes a new instance of the DeleteRuleOperationType class.

Public Instance Properties

RuleId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DeleteRuleOperationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteRuleOperationType Constructor

Initializes a new instance of the DeleteRuleOperationType class.

public DeleteRuleOperationType();

See Also

DeleteRuleOperationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteRuleOperationType Properties

The properties of the DeleteRuleOperationType class are listed below. For a complete list of DeleteRuleOperationType class members, see the DeleteRuleOperationType Members topic.

Public Instance Properties

RuleId

See Also

DeleteRuleOperationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RuleId Property

Aspose.Email

DeleteRuleOperationType.RuleId Property

public string RuleId {get; set;}

Remarks

See Also

DeleteRuleOperationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteUMPromptsResponseMessageType Class

For a list of all members of this type, see DeleteUMPromptsResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.DeleteUMPromptsResponseMessageType

public class DeleteUMPromptsResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DeleteUMPromptsResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteUMPromptsResponseMessageType Members

DeleteUMPromptsResponseMessageType overview

Public Instance Constructors

DeleteUMPromptsResponseMessageType Constructor Initializes a new instance of the DeleteUMPromptsResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DeleteUMPromptsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteUMPromptsResponseMessageType Constructor

Initializes a new instance of the DeleteUMPromptsResponseMessageType class.

public DeleteUMPromptsResponseMessageType();

See Also

DeleteUMPromptsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteUMPromptsType Class

For a list of all members of this type, see DeleteUMPromptsType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.DeleteUMPromptsType

public class DeleteUMPromptsType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DeleteUMPromptsType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteUMPromptsType Members

DeleteUMPromptsType overview

Public Instance Constructors

DeleteUMPromptsType Constructor Initializes a new instance of the DeleteUMPromptsType class.

Public Instance Properties

ConfigurationObject
PromptNames

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DeleteUMPromptsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteUMPromptsType Constructor

Initializes a new instance of the DeleteUMPromptsType class.

public DeleteUMPromptsType();

See Also

DeleteUMPromptsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteUMPromptsType Properties

The properties of the DeleteUMPromptsType class are listed below. For a complete list of DeleteUMPromptsType class members, see the DeleteUMPromptsType Members topic.

Public Instance Properties

ConfigurationObject
PromptNames

See Also

DeleteUMPromptsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConfigurationObject Property

Aspose.Email

DeleteUMPromptsType.ConfigurationObject Property

public string ConfigurationObject {get; set;}

Remarks

See Also

DeleteUMPromptsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PromptNames Property

Aspose.Email

DeleteUMPromptsType.PromptNames Property

public string[] PromptNames {get; set;}

Remarks

See Also

DeleteUMPromptsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteUserConfigurationCompletedEventArgs Class

For a list of all members of this type, see DeleteUserConfigurationCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.DeleteUserConfigurationCompletedEventArgs

public class DeleteUserConfigurationCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DeleteUserConfigurationCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteUserConfigurationCompletedEventArgs Members

DeleteUserConfigurationCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

DeleteUserConfigurationCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteUserConfigurationCompletedEventArgs Properties

The properties of the DeleteUserConfigurationCompletedEventArgs class are listed below. For a complete list of DeleteUserConfigurationCompletedEventArgs class members, see the DeleteUserConfigurationCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

DeleteUserConfigurationCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

DeleteUserConfigurationCompletedEventArgs.Result Property

public DeleteUserConfigurationResponseType Result {get;}

Remarks

See Also

DeleteUserConfigurationCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteUserConfigurationCompletedEventHandler Delegate

public delegate void DeleteUserConfigurationCompletedEventHandler(
object sender,
DeleteUserConfigurationCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteUserConfigurationResponseType Class

For a list of all members of this type, see DeleteUserConfigurationResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.DeleteUserConfigurationResponseType

public class DeleteUserConfigurationResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DeleteUserConfigurationResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteUserConfigurationResponseType Members

DeleteUserConfigurationResponseType overview

Public Instance Constructors

DeleteUserConfigurationResponseType Constructor Initializes a new instance of the DeleteUserConfigurationResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DeleteUserConfigurationResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteUserConfigurationResponseType Constructor

Initializes a new instance of the DeleteUserConfigurationResponseType class.

public DeleteUserConfigurationResponseType();

See Also

DeleteUserConfigurationResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteUserConfigurationType Class

For a list of all members of this type, see DeleteUserConfigurationType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.DeleteUserConfigurationType

public class DeleteUserConfigurationType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DeleteUserConfigurationType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteUserConfigurationType Members

DeleteUserConfigurationType overview

Public Instance Constructors

DeleteUserConfigurationType Constructor Initializes a new instance of the DeleteUserConfigurationType class.

Public Instance Properties

UserConfigurationName

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DeleteUserConfigurationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteUserConfigurationType Constructor

Initializes a new instance of the DeleteUserConfigurationType class.

public DeleteUserConfigurationType();

See Also

DeleteUserConfigurationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteUserConfigurationType Properties

The properties of the DeleteUserConfigurationType class are listed below. For a complete list of DeleteUserConfigurationType class members, see the DeleteUserConfigurationType Members topic.

Public Instance Properties

UserConfigurationName

See Also

DeleteUserConfigurationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserConfigurationName Property

Aspose.Email

DeleteUserConfigurationType.UserConfigurationName Property

public UserConfigurationNameType UserConfigurationName {get; set;}

Remarks

See Also

DeleteUserConfigurationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeliverMeetingRequestsType Enumeration

public enum DeliverMeetingRequestsType

Remarks

Members

Member Name | Description | Value
DelegatesOnly |  | 0
DelegatesAndMe |  | 1
DelegatesAndSendInformationToMe |  | 2
NoForward |  | 3

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DictionaryURIType Enumeration

public enum DictionaryURIType

Remarks

Members

Member Name | Description | Value
itemInternetMessageHeader |  | 0
contactsImAddress |  | 1
contactsPhysicalAddressStreet |  | 2
contactsPhysicalAddressCity |  | 3
contactsPhysicalAddressState |  | 4
contactsPhysicalAddressCountryOrRegion |  | 5
contactsPhysicalAddressPostalCode |  | 6
contactsPhoneNumber |  | 7
contactsEmailAddress |  | 8
distributionlistMembersMember |  | 9

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DirectoryEntryType Class

For a list of all members of this type, see DirectoryEntryType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.DirectoryEntryType
Aspose.Email.Exchange.Schema.Exchange_2013.RoomType

public class DirectoryEntryType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DirectoryEntryType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DirectoryEntryType Members

DirectoryEntryType overview

Public Instance Constructors

DirectoryEntryType Constructor Initializes a new instance of the DirectoryEntryType class.

Public Instance Properties

Id

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DirectoryEntryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DirectoryEntryType Constructor

Initializes a new instance of the DirectoryEntryType class.

public DirectoryEntryType();

See Also

DirectoryEntryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DirectoryEntryType Properties

The properties of the DirectoryEntryType class are listed below. For a complete list of DirectoryEntryType class members, see the DirectoryEntryType Members topic.

Public Instance Properties

Id

See Also

DirectoryEntryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Id Property

Aspose.Email

DirectoryEntryType.Id Property

public EmailAddressType Id {get; set;}

Remarks

See Also

DirectoryEntryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisableAppCompletedEventArgs Class

For a list of all members of this type, see DisableAppCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.DisableAppCompletedEventArgs

public class DisableAppCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DisableAppCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisableAppCompletedEventArgs Members

DisableAppCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

DisableAppCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisableAppCompletedEventArgs Properties

The properties of the DisableAppCompletedEventArgs class are listed below. For a complete list of DisableAppCompletedEventArgs class members, see the DisableAppCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

DisableAppCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

DisableAppCompletedEventArgs.Result Property

public DisableAppResponseType Result {get;}

Remarks

See Also

DisableAppCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisableAppCompletedEventHandler Delegate

public delegate void DisableAppCompletedEventHandler(
object sender,
DisableAppCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisableAppResponseType Class

For a list of all members of this type, see DisableAppResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.DisableAppResponseType

public class DisableAppResponseType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DisableAppResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisableAppResponseType Members

DisableAppResponseType overview

Public Instance Constructors

DisableAppResponseType Constructor Initializes a new instance of the DisableAppResponseType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DisableAppResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisableAppResponseType Constructor

Initializes a new instance of the DisableAppResponseType class.

public DisableAppResponseType();

See Also

DisableAppResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisableAppType Class

For a list of all members of this type, see DisableAppType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.DisableAppType

public class DisableAppType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DisableAppType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisableAppType Members

DisableAppType overview

Public Instance Constructors

DisableAppType Constructor Initializes a new instance of the DisableAppType class.

Public Instance Properties

DisableReason
ID

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DisableAppType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisableAppType Constructor

Initializes a new instance of the DisableAppType class.

public DisableAppType();

See Also

DisableAppType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisableAppType Properties

The properties of the DisableAppType class are listed below. For a complete list of DisableAppType class members, see the DisableAppType Members topic.

Public Instance Properties

DisableReason
ID

See Also

DisableAppType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisableReason Property

Aspose.Email

DisableAppType.DisableReason Property

public DisableReasonType DisableReason {get; set;}

Remarks

See Also

DisableAppType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ID Property

Aspose.Email

DisableAppType.ID Property

public string ID {get; set;}

Remarks

See Also

DisableAppType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisableReasonType Enumeration

public enum DisableReasonType

Remarks

Members

Member Name | Description | Value
NoReason |  | 0
OutlookClientPerformance |  | 1
OWAClientPerformance |  | 2
MobileClientPerformance |  | 3

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisconnectPhoneCallCompletedEventArgs Class

For a list of all members of this type, see DisconnectPhoneCallCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.DisconnectPhoneCallCompletedEventArgs

public class DisconnectPhoneCallCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DisconnectPhoneCallCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisconnectPhoneCallCompletedEventArgs Members

DisconnectPhoneCallCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

DisconnectPhoneCallCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisconnectPhoneCallCompletedEventArgs Properties

The properties of the DisconnectPhoneCallCompletedEventArgs class are listed below. For a complete list of DisconnectPhoneCallCompletedEventArgs class members, see the DisconnectPhoneCallCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

DisconnectPhoneCallCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

DisconnectPhoneCallCompletedEventArgs.Result Property

public DisconnectPhoneCallResponseMessageType Result {get;}

Remarks

See Also

DisconnectPhoneCallCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisconnectPhoneCallCompletedEventHandler Delegate

public delegate void DisconnectPhoneCallCompletedEventHandler(
object sender,
DisconnectPhoneCallCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisconnectPhoneCallResponseMessageType Class

For a list of all members of this type, see DisconnectPhoneCallResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.DisconnectPhoneCallResponseMessageType

public class DisconnectPhoneCallResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DisconnectPhoneCallResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisconnectPhoneCallResponseMessageType Members

DisconnectPhoneCallResponseMessageType overview

Public Instance Constructors

DisconnectPhoneCallResponseMessageType Constructor Initializes a new instance of the DisconnectPhoneCallResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DisconnectPhoneCallResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisconnectPhoneCallResponseMessageType Constructor

Initializes a new instance of the DisconnectPhoneCallResponseMessageType class.

public DisconnectPhoneCallResponseMessageType();

See Also

DisconnectPhoneCallResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisconnectPhoneCallType Class

For a list of all members of this type, see DisconnectPhoneCallType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.DisconnectPhoneCallType

public class DisconnectPhoneCallType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DisconnectPhoneCallType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisconnectPhoneCallType Members

DisconnectPhoneCallType overview

Public Instance Constructors

DisconnectPhoneCallType Constructor Initializes a new instance of the DisconnectPhoneCallType class.

Public Instance Properties

PhoneCallId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DisconnectPhoneCallType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisconnectPhoneCallType Constructor

Initializes a new instance of the DisconnectPhoneCallType class.

public DisconnectPhoneCallType();

See Also

DisconnectPhoneCallType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisconnectPhoneCallType Properties

The properties of the DisconnectPhoneCallType class are listed below. For a complete list of DisconnectPhoneCallType class members, see the DisconnectPhoneCallType Members topic.

Public Instance Properties

PhoneCallId

See Also

DisconnectPhoneCallType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PhoneCallId Property

Aspose.Email

DisconnectPhoneCallType.PhoneCallId Property

public PhoneCallIdType PhoneCallId {get; set;}

Remarks

See Also

DisconnectPhoneCallType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DiscoverySearchConfigurationType Class

For a list of all members of this type, see DiscoverySearchConfigurationType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.DiscoverySearchConfigurationType

public class DiscoverySearchConfigurationType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DiscoverySearchConfigurationType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DiscoverySearchConfigurationType Members

DiscoverySearchConfigurationType overview

Public Instance Constructors

DiscoverySearchConfigurationType Constructor Initializes a new instance of the DiscoverySearchConfigurationType class.

Public Instance Properties

InPlaceHoldIdentity
ManagedByOrganization
SearchableMailboxes
SearchId
SearchQuery

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DiscoverySearchConfigurationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DiscoverySearchConfigurationType Constructor

Initializes a new instance of the DiscoverySearchConfigurationType class.

public DiscoverySearchConfigurationType();

See Also

DiscoverySearchConfigurationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DiscoverySearchConfigurationType Properties

The properties of the DiscoverySearchConfigurationType class are listed below. For a complete list of DiscoverySearchConfigurationType class members, see the DiscoverySearchConfigurationType Members topic.

Public Instance Properties

InPlaceHoldIdentity
ManagedByOrganization
SearchableMailboxes
SearchId
SearchQuery

See Also

DiscoverySearchConfigurationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InPlaceHoldIdentity Property

Aspose.Email

DiscoverySearchConfigurationType.InPlaceHoldIdentity Property

public string InPlaceHoldIdentity {get; set;}

Remarks

See Also

DiscoverySearchConfigurationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ManagedByOrganization Property

Aspose.Email

DiscoverySearchConfigurationType.ManagedByOrganization Property

public string ManagedByOrganization {get; set;}

Remarks

See Also

DiscoverySearchConfigurationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchableMailboxes Property

Aspose.Email

DiscoverySearchConfigurationType.SearchableMailboxes Property

public SearchableMailboxType[] SearchableMailboxes {get; set;}

Remarks

See Also

DiscoverySearchConfigurationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchId Property

Aspose.Email

DiscoverySearchConfigurationType.SearchId Property

public string SearchId {get; set;}

Remarks

See Also

DiscoverySearchConfigurationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchQuery Property

Aspose.Email

DiscoverySearchConfigurationType.SearchQuery Property

public string SearchQuery {get; set;}

Remarks

See Also

DiscoverySearchConfigurationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisposalType Enumeration

public enum DisposalType

Remarks

Members

Member Name | Description | Value
HardDelete |  | 0
SoftDelete |  | 1
MoveToDeletedItems |  | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DistinguishedFolderIdNameType Enumeration

public enum DistinguishedFolderIdNameType

Remarks

Members

Member Name | Description | Value
calendar |  | 0
contacts |  | 1
deleteditems |  | 2
drafts |  | 3
inbox |  | 4
journal |  | 5
notes |  | 6
outbox |  | 7
sentitems |  | 8
tasks |  | 9
msgfolderroot |  | 10
publicfoldersroot |  | 11
root |  | 12
junkemail |  | 13
searchfolders |  | 14
voicemail |  | 15
recoverableitemsroot |  | 16
recoverableitemsdeletions |  | 17
recoverableitemsversions |  | 18
recoverableitemspurges |  | 19
archiveroot |  | 20
archivemsgfolderroot |  | 21
archivedeleteditems |  | 22
archiverecoverableitemsroot |  | 23
archiverecoverableitemsdeletions |  | 24
archiverecoverableitemsversions |  | 25
archiverecoverableitemspurges |  | 26
syncissues |  | 27
conflicts |  | 28
localfailures |  | 29
serverfailures |  | 30
recipientcache |  | 31
quickcontacts |  | 32
conversationhistory |  | 33
adminauditlogs |  | 34
todosearch |  | 35
mycontacts |  | 36
directory |  | 37
imcontactlist |  | 38
peopleconnect |  | 39

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DistinguishedFolderIdType Class

For a list of all members of this type, see DistinguishedFolderIdType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseFolderIdType
Aspose.Email.Exchange.Schema.Exchange_2013.DistinguishedFolderIdType

public class DistinguishedFolderIdType : BaseFolderIdType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DistinguishedFolderIdType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DistinguishedFolderIdType Members

DistinguishedFolderIdType overview

Public Instance Constructors

DistinguishedFolderIdType Constructor Initializes a new instance of the DistinguishedFolderIdType class.

Public Instance Properties

ChangeKey
Id
Mailbox

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DistinguishedFolderIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DistinguishedFolderIdType Constructor

Initializes a new instance of the DistinguishedFolderIdType class.

public DistinguishedFolderIdType();

See Also

DistinguishedFolderIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DistinguishedFolderIdType Properties

The properties of the DistinguishedFolderIdType class are listed below. For a complete list of DistinguishedFolderIdType class members, see the DistinguishedFolderIdType Members topic.

Public Instance Properties

ChangeKey
Id
Mailbox

See Also

DistinguishedFolderIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ChangeKey Property

Aspose.Email

DistinguishedFolderIdType.ChangeKey Property

public string ChangeKey {get; set;}

Remarks

See Also

DistinguishedFolderIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Id Property

Aspose.Email

DistinguishedFolderIdType.Id Property

public DistinguishedFolderIdNameType Id {get; set;}

Remarks

See Also

DistinguishedFolderIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Mailbox Property

Aspose.Email

DistinguishedFolderIdType.Mailbox Property

public EmailAddressType Mailbox {get; set;}

Remarks

See Also

DistinguishedFolderIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DistinguishedGroupByType Class

For a list of all members of this type, see DistinguishedGroupByType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseGroupByType
Aspose.Email.Exchange.Schema.Exchange_2013.DistinguishedGroupByType

public class DistinguishedGroupByType : BaseGroupByType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DistinguishedGroupByType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DistinguishedGroupByType Members

DistinguishedGroupByType overview

Public Instance Constructors

DistinguishedGroupByType Constructor Initializes a new instance of the DistinguishedGroupByType class.

Public Instance Properties

Order (inherited from BaseGroupByType)
StandardGroupBy

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DistinguishedGroupByType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DistinguishedGroupByType Constructor

Initializes a new instance of the DistinguishedGroupByType class.

public DistinguishedGroupByType();

See Also

DistinguishedGroupByType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DistinguishedGroupByType Properties

The properties of the DistinguishedGroupByType class are listed below. For a complete list of DistinguishedGroupByType class members, see the DistinguishedGroupByType Members topic.

Public Instance Properties

Order (inherited from BaseGroupByType)
StandardGroupBy

See Also

DistinguishedGroupByType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StandardGroupBy Property

Aspose.Email

DistinguishedGroupByType.StandardGroupBy Property

public StandardGroupByType StandardGroupBy {get; set;}

Remarks

See Also

DistinguishedGroupByType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DistinguishedPropertySetType Enumeration

public enum DistinguishedPropertySetType

Remarks

Members

Member Name | Description | Value
Meeting |  | 0
Appointment |  | 1
Common |  | 2
PublicStrings |  | 3
Address |  | 4
InternetHeaders |  | 5
CalendarAssistant |  | 6
UnifiedMessaging |  | 7
Task |  | 8
Sharing |  | 9

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DistinguishedUserType Enumeration

public enum DistinguishedUserType

Remarks

Members

Member Name | Description | Value
Default |  | 0
Anonymous |  | 1

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DistributionListType Class

For a list of all members of this type, see DistributionListType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ItemType
Aspose.Email.Exchange.Schema.Exchange_2013.DistributionListType

public class DistributionListType : ItemType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DistributionListType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DistributionListType Members

DistributionListType overview

Public Instance Constructors

DistributionListType Constructor Initializes a new instance of the DistributionListType class.

Public Instance Properties

ArchiveTag (inherited from ItemType)
Attachments (inherited from ItemType)
BlockStatus (inherited from ItemType)
BlockStatusSpecified (inherited from ItemType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
ContactSource
ContactSourceSpecified
ConversationId (inherited from ItemType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayName
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
EntityExtractionResult (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
FileAs
Flag (inherited from ItemType)
GroupingAction (inherited from ItemType)
GroupingActionSpecified (inherited from ItemType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBlockedImages (inherited from ItemType)
HasBlockedImagesSpecified (inherited from ItemType)
IconIndex (inherited from ItemType)
IconIndexSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InstanceKey (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
Members
MimeContent (inherited from ItemType)
NextPredictedAction (inherited from ItemType)
NextPredictedActionSpecified (inherited from ItemType)
NormalizedBody (inherited from ItemType)
ParentFolderId (inherited from ItemType)
PolicyTag (inherited from ItemType)
Preview (inherited from ItemType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReminderNextTime (inherited from ItemType)
ReminderNextTimeSpecified (inherited from ItemType)
ResponseObjects (inherited from ItemType)
RetentionDate (inherited from ItemType)
RetentionDateSpecified (inherited from ItemType)
RightsManagementLicenseData (inherited from ItemType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
StoreEntryId (inherited from ItemType)
Subject (inherited from ItemType)
TextBody (inherited from ItemType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DistributionListType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DistributionListType Constructor

Initializes a new instance of the DistributionListType class.

public DistributionListType();

See Also

DistributionListType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DistributionListType Properties

The properties of the DistributionListType class are listed below. For a complete list of DistributionListType class members, see the DistributionListType Members topic.

Public Instance Properties

ArchiveTag (inherited from ItemType)
Attachments (inherited from ItemType)
BlockStatus (inherited from ItemType)
BlockStatusSpecified (inherited from ItemType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
ContactSource
ContactSourceSpecified
ConversationId (inherited from ItemType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayName
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
EntityExtractionResult (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
FileAs
Flag (inherited from ItemType)
GroupingAction (inherited from ItemType)
GroupingActionSpecified (inherited from ItemType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBlockedImages (inherited from ItemType)
HasBlockedImagesSpecified (inherited from ItemType)
IconIndex (inherited from ItemType)
IconIndexSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InstanceKey (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
Members
MimeContent (inherited from ItemType)
NextPredictedAction (inherited from ItemType)
NextPredictedActionSpecified (inherited from ItemType)
NormalizedBody (inherited from ItemType)
ParentFolderId (inherited from ItemType)
PolicyTag (inherited from ItemType)
Preview (inherited from ItemType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReminderNextTime (inherited from ItemType)
ReminderNextTimeSpecified (inherited from ItemType)
ResponseObjects (inherited from ItemType)
RetentionDate (inherited from ItemType)
RetentionDateSpecified (inherited from ItemType)
RightsManagementLicenseData (inherited from ItemType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
StoreEntryId (inherited from ItemType)
Subject (inherited from ItemType)
TextBody (inherited from ItemType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

See Also

DistributionListType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContactSource Property

Aspose.Email

DistributionListType.ContactSource Property

public ContactSourceType ContactSource {get; set;}

Remarks

See Also

DistributionListType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContactSourceSpecified Property

Aspose.Email

DistributionListType.ContactSourceSpecified Property

public bool ContactSourceSpecified {get; set;}

Remarks

See Also

DistributionListType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisplayName Property

Aspose.Email

DistributionListType.DisplayName Property

public string DisplayName {get; set;}

Remarks

See Also

DistributionListType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FileAs Property

Aspose.Email

DistributionListType.FileAs Property

public string FileAs {get; set;}

Remarks

See Also

DistributionListType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Members Property

Aspose.Email

DistributionListType.Members Property

public MemberType[] Members {get; set;}

Remarks

See Also

DistributionListType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Duration Class

For a list of all members of this type, see Duration Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.Duration

public class Duration

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Duration Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Duration Members

Duration overview

Public Instance Constructors

Duration Constructor Initializes a new instance of the Duration class.

Public Instance Properties

EndTime
StartTime

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Duration Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Duration Constructor

Initializes a new instance of the Duration class.

public Duration();

See Also

Duration Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Duration Properties

The properties of the Duration class are listed below. For a complete list of Duration class members, see the Duration Members topic.

Public Instance Properties

EndTime
StartTime

See Also

Duration Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EndTime Property

Aspose.Email

Duration.EndTime Property

public DateTime EndTime {get; set;}

Remarks

See Also

Duration Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StartTime Property

Aspose.Email

Duration.StartTime Property

public DateTime StartTime {get; set;}

Remarks

See Also

Duration Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EffectiveRightsType Class

For a list of all members of this type, see EffectiveRightsType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.EffectiveRightsType

public class EffectiveRightsType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

EffectiveRightsType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EffectiveRightsType Members

EffectiveRightsType overview

Public Instance Constructors

EffectiveRightsType Constructor Initializes a new instance of the EffectiveRightsType class.

Public Instance Properties

CreateAssociated
CreateContents
CreateHierarchy
Delete
Modify
Read
ViewPrivateItems
ViewPrivateItemsSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EffectiveRightsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EffectiveRightsType Constructor

Initializes a new instance of the EffectiveRightsType class.

public EffectiveRightsType();

See Also

EffectiveRightsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EffectiveRightsType Properties

The properties of the EffectiveRightsType class are listed below. For a complete list of EffectiveRightsType class members, see the EffectiveRightsType Members topic.

Public Instance Properties

CreateAssociated
CreateContents
CreateHierarchy
Delete
Modify
Read
ViewPrivateItems
ViewPrivateItemsSpecified

See Also

EffectiveRightsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateAssociated Property

Aspose.Email

EffectiveRightsType.CreateAssociated Property

public bool CreateAssociated {get; set;}

Remarks

See Also

EffectiveRightsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateContents Property

Aspose.Email

EffectiveRightsType.CreateContents Property

public bool CreateContents {get; set;}

Remarks

See Also

EffectiveRightsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateHierarchy Property

Aspose.Email

EffectiveRightsType.CreateHierarchy Property

public bool CreateHierarchy {get; set;}

Remarks

See Also

EffectiveRightsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Delete Property

Aspose.Email

EffectiveRightsType.Delete Property

public bool Delete {get; set;}

Remarks

See Also

EffectiveRightsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Modify Property

Aspose.Email

EffectiveRightsType.Modify Property

public bool Modify {get; set;}

Remarks

See Also

EffectiveRightsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Read Property

Aspose.Email

EffectiveRightsType.Read Property

public bool Read {get; set;}

Remarks

See Also

EffectiveRightsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ViewPrivateItems Property

Aspose.Email

EffectiveRightsType.ViewPrivateItems Property

public bool ViewPrivateItems {get; set;}

Remarks

See Also

EffectiveRightsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ViewPrivateItemsSpecified Property

Aspose.Email

EffectiveRightsType.ViewPrivateItemsSpecified Property

public bool ViewPrivateItemsSpecified {get; set;}

Remarks

See Also

EffectiveRightsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ElcFolderType Enumeration

public enum ElcFolderType

Remarks

Members

Member Name | Description | Value
Calendar |  | 0
Contacts |  | 1
DeletedItems |  | 2
Drafts |  | 3
Inbox |  | 4
JunkEmail |  | 5
Journal |  | 6
Notes |  | 7
Outbox |  | 8
SentItems |  | 9
Tasks |  | 10
All |  | 11
ManagedCustomFolder |  | 12
RssSubscriptions |  | 13
SyncIssues |  | 14
ConversationHistory |  | 15
Personal |  | 16
RecoverableItems |  | 17
NonIpmRoot |  | 18

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EmailAddress Class

For a list of all members of this type, see EmailAddress Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.EmailAddress

public class EmailAddress

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

EmailAddress Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EmailAddress Members

EmailAddress overview

Public Instance Constructors

EmailAddress Constructor Initializes a new instance of the EmailAddress class.

Public Instance Properties

Address
Name
RoutingType

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EmailAddress Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EmailAddress Constructor

Initializes a new instance of the EmailAddress class.

public EmailAddress();

See Also

EmailAddress Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EmailAddress Properties

The properties of the EmailAddress class are listed below. For a complete list of EmailAddress class members, see the EmailAddress Members topic.

Public Instance Properties

Address
Name
RoutingType

See Also

EmailAddress Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Address Property

Aspose.Email

EmailAddress.Address Property

public string Address {get; set;}

Remarks

See Also

EmailAddress Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Name Property

Aspose.Email

EmailAddress.Name Property

public string Name {get; set;}

Remarks

See Also

EmailAddress Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RoutingType Property

Aspose.Email

EmailAddress.RoutingType Property

public string RoutingType {get; set;}

Remarks

See Also

EmailAddress Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EmailAddressAttributedValueType Class

For a list of all members of this type, see EmailAddressAttributedValueType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.EmailAddressAttributedValueType

public class EmailAddressAttributedValueType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

EmailAddressAttributedValueType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EmailAddressAttributedValueType Members

EmailAddressAttributedValueType overview

Public Instance Constructors

EmailAddressAttributedValueType Constructor Initializes a new instance of the EmailAddressAttributedValueType class.

Public Instance Properties

Attributions
Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EmailAddressAttributedValueType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EmailAddressAttributedValueType Constructor

Initializes a new instance of the EmailAddressAttributedValueType class.

public EmailAddressAttributedValueType();

See Also

EmailAddressAttributedValueType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EmailAddressAttributedValueType Properties

The properties of the EmailAddressAttributedValueType class are listed below. For a complete list of EmailAddressAttributedValueType class members, see the EmailAddressAttributedValueType Members topic.

Public Instance Properties

Attributions
Value

See Also

EmailAddressAttributedValueType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Attributions Property

Aspose.Email

EmailAddressAttributedValueType.Attributions Property

public string[] Attributions {get; set;}

Remarks

See Also

EmailAddressAttributedValueType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Value Property

Aspose.Email

EmailAddressAttributedValueType.Value Property

public EmailAddressType Value {get; set;}

Remarks

See Also

EmailAddressAttributedValueType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EmailAddressDictionaryEntryType Class

For a list of all members of this type, see EmailAddressDictionaryEntryType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.EmailAddressDictionaryEntryType

public class EmailAddressDictionaryEntryType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

EmailAddressDictionaryEntryType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EmailAddressDictionaryEntryType Members

EmailAddressDictionaryEntryType overview

Public Instance Constructors

EmailAddressDictionaryEntryType Constructor Initializes a new instance of the EmailAddressDictionaryEntryType class.

Public Instance Properties

Key
MailboxType
MailboxTypeSpecified
Name
RoutingType
Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EmailAddressDictionaryEntryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EmailAddressDictionaryEntryType Constructor

Initializes a new instance of the EmailAddressDictionaryEntryType class.

public EmailAddressDictionaryEntryType();

See Also

EmailAddressDictionaryEntryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EmailAddressDictionaryEntryType Properties

The properties of the EmailAddressDictionaryEntryType class are listed below. For a complete list of EmailAddressDictionaryEntryType class members, see the EmailAddressDictionaryEntryType Members topic.

Public Instance Properties

Key
MailboxType
MailboxTypeSpecified
Name
RoutingType
Value

See Also

EmailAddressDictionaryEntryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Key Property

Aspose.Email

EmailAddressDictionaryEntryType.Key Property

public EmailAddressKeyType Key {get; set;}

Remarks

See Also

EmailAddressDictionaryEntryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxType Property

Aspose.Email

EmailAddressDictionaryEntryType.MailboxType Property

public MailboxTypeType MailboxType {get; set;}

Remarks

See Also

EmailAddressDictionaryEntryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxTypeSpecified Property

Aspose.Email

EmailAddressDictionaryEntryType.MailboxTypeSpecified Property

public bool MailboxTypeSpecified {get; set;}

Remarks

See Also

EmailAddressDictionaryEntryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Name Property

Aspose.Email

EmailAddressDictionaryEntryType.Name Property

public string Name {get; set;}

Remarks

See Also

EmailAddressDictionaryEntryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RoutingType Property

Aspose.Email

EmailAddressDictionaryEntryType.RoutingType Property

public string RoutingType {get; set;}

Remarks

See Also

EmailAddressDictionaryEntryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Value Property

Aspose.Email

EmailAddressDictionaryEntryType.Value Property

public string Value {get; set;}

Remarks

See Also

EmailAddressDictionaryEntryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EmailAddressEntityType Class

For a list of all members of this type, see EmailAddressEntityType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.EntityType
Aspose.Email.Exchange.Schema.Exchange_2013.EmailAddressEntityType

public class EmailAddressEntityType : EntityType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

EmailAddressEntityType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EmailAddressEntityType Members

EmailAddressEntityType overview

Public Instance Constructors

EmailAddressEntityType Constructor Initializes a new instance of the EmailAddressEntityType class.

Public Instance Properties

EmailAddress
Position (inherited from EntityType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EmailAddressEntityType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EmailAddressEntityType Constructor

Initializes a new instance of the EmailAddressEntityType class.

public EmailAddressEntityType();

See Also

EmailAddressEntityType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EmailAddressEntityType Properties

The properties of the EmailAddressEntityType class are listed below. For a complete list of EmailAddressEntityType class members, see the EmailAddressEntityType Members topic.

Public Instance Properties

EmailAddress
Position (inherited from EntityType)

See Also

EmailAddressEntityType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EmailAddress Property

Aspose.Email

EmailAddressEntityType.EmailAddress Property

public string EmailAddress {get; set;}

Remarks

See Also

EmailAddressEntityType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EmailAddressKeyType Enumeration

public enum EmailAddressKeyType

Remarks

Members

Member Name | Description | Value
EmailAddress1 |  | 0
EmailAddress2 |  | 1
EmailAddress3 |  | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EmailAddressType Class

For a list of all members of this type, see EmailAddressType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseEmailAddressType
Aspose.Email.Exchange.Schema.Exchange_2013.EmailAddressType

public class EmailAddressType : BaseEmailAddressType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

EmailAddressType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EmailAddressType Members

EmailAddressType overview

Public Instance Constructors

EmailAddressType Constructor Initializes a new instance of the EmailAddressType class.

Public Instance Properties

EmailAddress
ItemId
MailboxType
MailboxTypeSpecified
Name
OriginalDisplayName
RoutingType

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EmailAddressType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EmailAddressType Constructor

Initializes a new instance of the EmailAddressType class.

public EmailAddressType();

See Also

EmailAddressType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EmailAddressType Properties

The properties of the EmailAddressType class are listed below. For a complete list of EmailAddressType class members, see the EmailAddressType Members topic.

Public Instance Properties

EmailAddress
ItemId
MailboxType
MailboxTypeSpecified
Name
OriginalDisplayName
RoutingType

See Also

EmailAddressType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EmailAddress Property

Aspose.Email

EmailAddressType.EmailAddress Property

public string EmailAddress {get; set;}

Remarks

See Also

EmailAddressType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemId Property

Aspose.Email

EmailAddressType.ItemId Property

public ItemIdType ItemId {get; set;}

Remarks

See Also

EmailAddressType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxType Property

Aspose.Email

EmailAddressType.MailboxType Property

public MailboxTypeType MailboxType {get; set;}

Remarks

See Also

EmailAddressType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxTypeSpecified Property

Aspose.Email

EmailAddressType.MailboxTypeSpecified Property

public bool MailboxTypeSpecified {get; set;}

Remarks

See Also

EmailAddressType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Name Property

Aspose.Email

EmailAddressType.Name Property

public string Name {get; set;}

Remarks

See Also

EmailAddressType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OriginalDisplayName Property

Aspose.Email

EmailAddressType.OriginalDisplayName Property

public string OriginalDisplayName {get; set;}

Remarks

See Also

EmailAddressType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RoutingType Property

Aspose.Email

EmailAddressType.RoutingType Property

public string RoutingType {get; set;}

Remarks

See Also

EmailAddressType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EmailPositionType Enumeration

public enum EmailPositionType

Remarks

Members

Member Name | Description | Value
LatestReply |  | 0
Other |  | 1
Subject |  | 2
Signature |  | 3

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EmailUserType Class

For a list of all members of this type, see EmailUserType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.EmailUserType

public class EmailUserType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

EmailUserType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EmailUserType Members

EmailUserType overview

Public Instance Constructors

EmailUserType Constructor Initializes a new instance of the EmailUserType class.

Public Instance Properties

Name
UserId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EmailUserType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EmailUserType Constructor

Initializes a new instance of the EmailUserType class.

public EmailUserType();

See Also

EmailUserType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EmailUserType Properties

The properties of the EmailUserType class are listed below. For a complete list of EmailUserType class members, see the EmailUserType Members topic.

Public Instance Properties

Name
UserId

See Also

EmailUserType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Name Property

Aspose.Email

EmailUserType.Name Property

public string Name {get; set;}

Remarks

See Also

EmailUserType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserId Property

Aspose.Email

EmailUserType.UserId Property

public string UserId {get; set;}

Remarks

See Also

EmailUserType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EmptyFolderCompletedEventArgs Class

For a list of all members of this type, see EmptyFolderCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.EmptyFolderCompletedEventArgs

public class EmptyFolderCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

EmptyFolderCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EmptyFolderCompletedEventArgs Members

EmptyFolderCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

EmptyFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EmptyFolderCompletedEventArgs Properties

The properties of the EmptyFolderCompletedEventArgs class are listed below. For a complete list of EmptyFolderCompletedEventArgs class members, see the EmptyFolderCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

EmptyFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

EmptyFolderCompletedEventArgs.Result Property

public EmptyFolderResponseType Result {get;}

Remarks

See Also

EmptyFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EmptyFolderCompletedEventHandler Delegate

public delegate void EmptyFolderCompletedEventHandler(
object sender,
EmptyFolderCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EmptyFolderResponseType Class

For a list of all members of this type, see EmptyFolderResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.EmptyFolderResponseType

public class EmptyFolderResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

EmptyFolderResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EmptyFolderResponseType Members

EmptyFolderResponseType overview

Public Instance Constructors

EmptyFolderResponseType Constructor Initializes a new instance of the EmptyFolderResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EmptyFolderResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EmptyFolderResponseType Constructor

Initializes a new instance of the EmptyFolderResponseType class.

public EmptyFolderResponseType();

See Also

EmptyFolderResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EmptyFolderType Class

For a list of all members of this type, see EmptyFolderType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.EmptyFolderType

public class EmptyFolderType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

EmptyFolderType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EmptyFolderType Members

EmptyFolderType overview

Public Instance Constructors

EmptyFolderType Constructor Initializes a new instance of the EmptyFolderType class.

Public Instance Properties

DeleteSubFolders
DeleteType
FolderIds

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EmptyFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EmptyFolderType Constructor

Initializes a new instance of the EmptyFolderType class.

public EmptyFolderType();

See Also

EmptyFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EmptyFolderType Properties

The properties of the EmptyFolderType class are listed below. For a complete list of EmptyFolderType class members, see the EmptyFolderType Members topic.

Public Instance Properties

DeleteSubFolders
DeleteType
FolderIds

See Also

EmptyFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteSubFolders Property

Aspose.Email

EmptyFolderType.DeleteSubFolders Property

public bool DeleteSubFolders {get; set;}

Remarks

See Also

EmptyFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteType Property

Aspose.Email

EmptyFolderType.DeleteType Property

public DisposalType DeleteType {get; set;}

Remarks

See Also

EmptyFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FolderIds Property

Aspose.Email

EmptyFolderType.FolderIds Property

public BaseFolderIdType[] FolderIds {get; set;}

Remarks

See Also

EmptyFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EncryptedSharedFolderDataType Class

For a list of all members of this type, see EncryptedSharedFolderDataType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.EncryptedSharedFolderDataType

public class EncryptedSharedFolderDataType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

EncryptedSharedFolderDataType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EncryptedSharedFolderDataType Members

EncryptedSharedFolderDataType overview

Public Instance Constructors

EncryptedSharedFolderDataType Constructor Initializes a new instance of the EncryptedSharedFolderDataType class.

Public Instance Properties

Data
Token

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EncryptedSharedFolderDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EncryptedSharedFolderDataType Constructor

Initializes a new instance of the EncryptedSharedFolderDataType class.

public EncryptedSharedFolderDataType();

See Also

EncryptedSharedFolderDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EncryptedSharedFolderDataType Properties

The properties of the EncryptedSharedFolderDataType class are listed below. For a complete list of EncryptedSharedFolderDataType class members, see the EncryptedSharedFolderDataType Members topic.

Public Instance Properties

Data
Token

See Also

EncryptedSharedFolderDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Data Property

Aspose.Email

EncryptedSharedFolderDataType.Data Property

public XmlElement Data {get; set;}

Remarks

See Also

EncryptedSharedFolderDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Token Property

Aspose.Email

EncryptedSharedFolderDataType.Token Property

public XmlElement Token {get; set;}

Remarks

See Also

EncryptedSharedFolderDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EndDateRecurrenceRangeType Class

For a list of all members of this type, see EndDateRecurrenceRangeType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.RecurrenceRangeBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.EndDateRecurrenceRangeType

public class EndDateRecurrenceRangeType : RecurrenceRangeBaseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

EndDateRecurrenceRangeType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EndDateRecurrenceRangeType Members

EndDateRecurrenceRangeType overview

Public Instance Constructors

EndDateRecurrenceRangeType Constructor Initializes a new instance of the EndDateRecurrenceRangeType class.

Public Instance Properties

EndDate
StartDate (inherited from RecurrenceRangeBaseType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EndDateRecurrenceRangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EndDateRecurrenceRangeType Constructor

Initializes a new instance of the EndDateRecurrenceRangeType class.

public EndDateRecurrenceRangeType();

See Also

EndDateRecurrenceRangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EndDateRecurrenceRangeType Properties

The properties of the EndDateRecurrenceRangeType class are listed below. For a complete list of EndDateRecurrenceRangeType class members, see the EndDateRecurrenceRangeType Members topic.

Public Instance Properties

EndDate
StartDate (inherited from RecurrenceRangeBaseType)

See Also

EndDateRecurrenceRangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EndDate Property

Aspose.Email

EndDateRecurrenceRangeType.EndDate Property

public DateTime EndDate {get; set;}

Remarks

See Also

EndDateRecurrenceRangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EnhancedLocationType Class

For a list of all members of this type, see EnhancedLocationType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.EnhancedLocationType

public class EnhancedLocationType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

EnhancedLocationType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EnhancedLocationType Members

EnhancedLocationType overview

Public Instance Constructors

EnhancedLocationType Constructor Initializes a new instance of the EnhancedLocationType class.

Public Instance Properties

Annotation
DisplayName
PostalAddress

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EnhancedLocationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EnhancedLocationType Constructor

Initializes a new instance of the EnhancedLocationType class.

public EnhancedLocationType();

See Also

EnhancedLocationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EnhancedLocationType Properties

The properties of the EnhancedLocationType class are listed below. For a complete list of EnhancedLocationType class members, see the EnhancedLocationType Members topic.

Public Instance Properties

Annotation
DisplayName
PostalAddress

See Also

EnhancedLocationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Annotation Property

Aspose.Email

EnhancedLocationType.Annotation Property

public string Annotation {get; set;}

Remarks

See Also

EnhancedLocationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisplayName Property

Aspose.Email

EnhancedLocationType.DisplayName Property

public string DisplayName {get; set;}

Remarks

See Also

EnhancedLocationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PostalAddress Property

Aspose.Email

EnhancedLocationType.PostalAddress Property

public PersonaPostalAddressType PostalAddress {get; set;}

Remarks

See Also

EnhancedLocationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EntityExtractionResultType Class

For a list of all members of this type, see EntityExtractionResultType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.EntityExtractionResultType

public class EntityExtractionResultType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

EntityExtractionResultType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EntityExtractionResultType Members

EntityExtractionResultType overview

Public Instance Constructors

EntityExtractionResultType Constructor Initializes a new instance of the EntityExtractionResultType class.

Public Instance Properties

Addresses
Contacts
EmailAddresses
MeetingSuggestions
PhoneNumbers
TaskSuggestions
Urls

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EntityExtractionResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EntityExtractionResultType Constructor

Initializes a new instance of the EntityExtractionResultType class.

public EntityExtractionResultType();

See Also

EntityExtractionResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EntityExtractionResultType Properties

The properties of the EntityExtractionResultType class are listed below. For a complete list of EntityExtractionResultType class members, see the EntityExtractionResultType Members topic.

Public Instance Properties

Addresses
Contacts
EmailAddresses
MeetingSuggestions
PhoneNumbers
TaskSuggestions
Urls

See Also

EntityExtractionResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Addresses Property

Aspose.Email

EntityExtractionResultType.Addresses Property

public AddressEntityType[] Addresses {get; set;}

Remarks

See Also

EntityExtractionResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Contacts Property

Aspose.Email

EntityExtractionResultType.Contacts Property

public ContactType[] Contacts {get; set;}

Remarks

See Also

EntityExtractionResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EmailAddresses Property

Aspose.Email

EntityExtractionResultType.EmailAddresses Property

public EmailAddressEntityType[] EmailAddresses {get; set;}

Remarks

See Also

EntityExtractionResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MeetingSuggestions Property

Aspose.Email

EntityExtractionResultType.MeetingSuggestions Property

public MeetingSuggestionType[] MeetingSuggestions {get; set;}

Remarks

See Also

EntityExtractionResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PhoneNumbers Property

Aspose.Email

EntityExtractionResultType.PhoneNumbers Property

public PhoneEntityType[] PhoneNumbers {get; set;}

Remarks

See Also

EntityExtractionResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TaskSuggestions Property

Aspose.Email

EntityExtractionResultType.TaskSuggestions Property

public TaskSuggestionType[] TaskSuggestions {get; set;}

Remarks

See Also

EntityExtractionResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Urls Property

Aspose.Email

EntityExtractionResultType.Urls Property

public UrlEntityType[] Urls {get; set;}

Remarks

See Also

EntityExtractionResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EntityType Class

For a list of all members of this type, see EntityType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.EntityType
Derived types

public class EntityType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

EntityType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EntityType Members

EntityType overview

Public Instance Constructors

EntityType Constructor Initializes a new instance of the EntityType class.

Public Instance Properties

Position

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EntityType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EntityType Constructor

Initializes a new instance of the EntityType class.

public EntityType();

See Also

EntityType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EntityType Properties

The properties of the EntityType class are listed below. For a complete list of EntityType class members, see the EntityType Members topic.

Public Instance Properties

Position

See Also

EntityType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Position Property

Aspose.Email

EntityType.Position Property

public EmailPositionType[] Position {get; set;}

Remarks

See Also

EntityType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExceptionPropertyURIType Enumeration

public enum ExceptionPropertyURIType

Remarks

Members

Member Name | Description | Value
attachmentName |  | 0
attachmentContentType |  | 1
attachmentContent |  | 2
recurrenceMonth |  | 3
recurrenceDayOfWeekIndex |  | 4
recurrenceDaysOfWeek |  | 5
recurrenceDayOfMonth |  | 6
recurrenceInterval |  | 7
recurrenceNumberOfOccurrences |  | 8
timezoneOffset |  | 9

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeImpersonationType Class

For a list of all members of this type, see ExchangeImpersonationType Members.

System.Object
System.Web.Services.Protocols.SoapHeader
Aspose.Email.Exchange.Schema.Exchange_2013.ExchangeImpersonationType

public class ExchangeImpersonationType : SoapHeader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExchangeImpersonationType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeImpersonationType Members

ExchangeImpersonationType overview

Public Instance Constructors

ExchangeImpersonationType Constructor Initializes a new instance of the ExchangeImpersonationType class.

Public Instance Properties

Actor (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.
AnyAttr |
ConnectingSID |
DidUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether an XML Web service method properly processed a SOAP header.
EncodedMustUnderstand (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.1.
EncodedMustUnderstand12 (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.2.
EncodedRelay (inherited from SoapHeader) | Gets or sets the relay attribute of the SOAP 1.2 header.
MustUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether the SoapHeader must be understood.
Relay (inherited from SoapHeader) | Gets or sets a value that indicates whether the SOAP header is to be relayed to the next SOAP node if the current node does not understand the header.
Role (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExchangeImpersonationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeImpersonationType Constructor

Initializes a new instance of the ExchangeImpersonationType class.

public ExchangeImpersonationType();

See Also

ExchangeImpersonationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeImpersonationType Properties

The properties of the ExchangeImpersonationType class are listed below. For a complete list of ExchangeImpersonationType class members, see the ExchangeImpersonationType Members topic.

Public Instance Properties

Actor (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.
AnyAttr |
ConnectingSID |
DidUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether an XML Web service method properly processed a SOAP header.
EncodedMustUnderstand (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.1.
EncodedMustUnderstand12 (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.2.
EncodedRelay (inherited from SoapHeader) | Gets or sets the relay attribute of the SOAP 1.2 header.
MustUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether the SoapHeader must be understood.
Relay (inherited from SoapHeader) | Gets or sets a value that indicates whether the SOAP header is to be relayed to the next SOAP node if the current node does not understand the header.
Role (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.

See Also

ExchangeImpersonationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AnyAttr Property

Aspose.Email

ExchangeImpersonationType.AnyAttr Property

public XmlAttribute[] AnyAttr {get; set;}

Remarks

See Also

ExchangeImpersonationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConnectingSID Property

Aspose.Email

ExchangeImpersonationType.ConnectingSID Property

public ConnectingSIDType ConnectingSID {get; set;}

Remarks

See Also

ExchangeImpersonationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding Class

For a list of all members of this type, see ExchangeServiceBinding Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Web.Services.Protocols.WebClientProtocol
System.Web.Services.Protocols.HttpWebClientProtocol
System.Web.Services.Protocols.SoapHttpClientProtocol
Aspose.Email.Exchange.Schema.Exchange_2013.ExchangeServiceBinding

public class ExchangeServiceBinding : SoapHttpClientProtocol

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExchangeServiceBinding Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding Members

ExchangeServiceBinding overview

Public Instance Constructors

ExchangeServiceBinding Constructor Initializes a new instance of the ExchangeServiceBinding class.

Public Instance Properties

AllowAutoRedirect (inherited from HttpWebClientProtocol) | Gets or sets whether the client automatically follows server redirects.
ClientCertificates (inherited from HttpWebClientProtocol) | Gets the collection of client certificates.
ConnectionGroupName (inherited from WebClientProtocol) | Gets or sets the name of the connection group for the request.
Container (inherited from Component) | Gets the IContainer that contains the Component.
CookieContainer (inherited from HttpWebClientProtocol) | Gets or sets the collection of cookies.
Credentials (inherited from WebClientProtocol) | Gets or sets security credentials for XML Web service client authentication.
DateTimePrecision |
EnableDecompression (inherited from HttpWebClientProtocol) | Gets or sets a Boolean that indicates whether decompression is enabled for this HttpWebClientProtocol. The default is true.
ExchangeImpersonation |
MailboxCulture |
ManagementRole |
PreAuthenticate (inherited from WebClientProtocol) | Gets or sets whether pre-authentication is enabled.
Proxy (inherited from HttpWebClientProtocol) | Gets or sets proxy information for making an XML Web service request through a firewall.
RequestEncoding (inherited from WebClientProtocol) | The Encoding used to make the client request to the XML Web service.
RequestServerVersionValue |
ServerVersionInfoValue |
Site (inherited from Component) | Gets or sets the ISite of the Component.
SoapVersion (inherited from SoapHttpClientProtocol) | Gets or sets the version of the SOAP protocol used to make the SOAP request to the XML Web service.
Timeout (inherited from WebClientProtocol) | Indicates the time an XML Web service client waits for a synchronous XML Web service request to complete (in milliseconds).
TimeZoneContext |
UnsafeAuthenticatedConnectionSharing (inherited from HttpWebClientProtocol) | Gets or sets a value that indicates whether connection sharing is enabled when the client uses NTLM authentication to connect to the Web server that hosts the XML Web service.
Url |
UseDefaultCredentials |
UserAgent (inherited from HttpWebClientProtocol) | Gets or sets the value for the user agent header that is sent with each request.

Public Instance Methods

Abort (inherited from WebClientProtocol) | Cancels a request to an XML Web service method.
AddDelegate |
AddDelegateAsync | Overloaded.
AddDistributionGroupToImList |
AddDistributionGroupToImListAsync | Overloaded.
AddImContactToGroup |
AddImContactToGroupAsync | Overloaded.
AddImGroup |
AddImGroupAsync | Overloaded.
AddNewImContactToGroup |
AddNewImContactToGroupAsync | Overloaded.
AddNewTelUriContactToGroup |
AddNewTelUriContactToGroupAsync | Overloaded.
ApplyConversationAction |
ApplyConversationActionAsync | Overloaded.
ArchiveItem |
ArchiveItemAsync | Overloaded.
CancelAsync |
ConvertId |
ConvertIdAsync | Overloaded.
CopyFolder |
CopyFolderAsync | Overloaded.
CopyItem |
CopyItemAsync | Overloaded.
CreateAttachment |
CreateAttachmentAsync | Overloaded.
CreateFolder |
CreateFolderAsync | Overloaded.
CreateFolderPath |
CreateFolderPathAsync | Overloaded.
CreateItem |
CreateItemAsync | Overloaded.
CreateManagedFolder |
CreateManagedFolderAsync | Overloaded.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
CreateUserConfiguration |
CreateUserConfigurationAsync | Overloaded.
DeleteAttachment |
DeleteAttachmentAsync | Overloaded.
DeleteFolder |
DeleteFolderAsync | Overloaded.
DeleteItem |
DeleteItemAsync | Overloaded.
DeleteUserConfiguration |
DeleteUserConfigurationAsync | Overloaded.
DisableApp |
DisableAppAsync | Overloaded.
DisconnectPhoneCall |
DisconnectPhoneCallAsync | Overloaded.
Discover (inherited from SoapHttpClientProtocol) | Dynamically binds to an XML Web service described in the discovery document at Url.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
EmptyFolder |
EmptyFolderAsync | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExpandDL |
ExpandDLAsync | Overloaded.
ExportItems |
ExportItemsAsync | Overloaded.
FindConversation |
FindConversationAsync | Overloaded.
FindFolder |
FindFolderAsync | Overloaded.
FindItem |
FindItemAsync | Overloaded.
FindMessageTrackingReport |
FindMessageTrackingReportAsync | Overloaded.
FindPeople |
FindPeopleAsync | Overloaded.
GetAppManifests |
GetAppManifestsAsync | Overloaded.
GetAppMarketplaceUrl |
GetAppMarketplaceUrlAsync | Overloaded.
GetAttachment |
GetAttachmentAsync | Overloaded.
GetClientAccessToken |
GetClientAccessTokenAsync | Overloaded.
GetConversationItems |
GetConversationItemsAsync | Overloaded.
GetDelegate |
GetDelegateAsync | Overloaded.
GetDiscoverySearchConfiguration |
GetDiscoverySearchConfigurationAsync | Overloaded.
GetEvents |
GetEventsAsync | Overloaded.
GetFolder |
GetFolderAsync | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetHoldOnMailboxes |
GetHoldOnMailboxesAsync | Overloaded.
GetImItemList |
GetImItemListAsync | Overloaded.
GetImItems |
GetImItemsAsync | Overloaded.
GetInboxRules |
GetInboxRulesAsync | Overloaded.
GetItem |
GetItemAsync | Overloaded.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetMailTips |
GetMailTipsAsync | Overloaded.
GetMessageTrackingReport |
GetMessageTrackingReportAsync | Overloaded.
GetNonIndexableItemDetails |
GetNonIndexableItemDetailsAsync | Overloaded.
GetNonIndexableItemStatistics |
GetNonIndexableItemStatisticsAsync | Overloaded.
GetPasswordExpirationDate |
GetPasswordExpirationDateAsync | Overloaded.
GetPersona |
GetPersonaAsync | Overloaded.
GetPhoneCallInformation |
GetPhoneCallInformationAsync | Overloaded.
GetRoomLists |
GetRoomListsAsync | Overloaded.
GetRooms |
GetRoomsAsync | Overloaded.
GetSearchableMailboxes |
GetSearchableMailboxesAsync | Overloaded.
GetServerTimeZones |
GetServerTimeZonesAsync | Overloaded.
GetServiceConfiguration |
GetServiceConfigurationAsync | Overloaded.
GetSharingFolder |
GetSharingFolderAsync | Overloaded.
GetSharingMetadata |
GetSharingMetadataAsync | Overloaded.
GetStreamingEvents |
GetStreamingEventsAsync | Overloaded.
GetType (inherited from Object) | Gets the Type of the current instance.
GetUserAvailability |
GetUserAvailabilityAsync | Overloaded.
GetUserConfiguration |
GetUserConfigurationAsync | Overloaded.
GetUserOofSettings |
GetUserOofSettingsAsync | Overloaded.
GetUserPhoto |
GetUserPhotoAsync | Overloaded.
GetUserRetentionPolicyTags |
GetUserRetentionPolicyTagsAsync | Overloaded.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
InstallApp |
InstallAppAsync | Overloaded.
MarkAllItemsAsRead |
MarkAllItemsAsReadAsync | Overloaded.
MarkAsJunk |
MarkAsJunkAsync | Overloaded.
MoveFolder |
MoveFolderAsync | Overloaded.
MoveItem |
MoveItemAsync | Overloaded.
PlayOnPhone |
PlayOnPhoneAsync | Overloaded.
RefreshSharingFolder |
RefreshSharingFolderAsync | Overloaded.
RemoveContactFromImList |
RemoveContactFromImListAsync | Overloaded.
RemoveDelegate |
RemoveDelegateAsync | Overloaded.
RemoveDistributionGroupFromImList |
RemoveDistributionGroupFromImListAsync | Overloaded.
RemoveImContactFromGroup |
RemoveImContactFromGroupAsync | Overloaded.
RemoveImGroup |
RemoveImGroupAsync | Overloaded.
ResolveNames |
ResolveNamesAsync | Overloaded.
SearchMailboxes |
SearchMailboxesAsync | Overloaded.
SendItem |
SendItemAsync | Overloaded.
SetHoldOnMailboxes |
SetHoldOnMailboxesAsync | Overloaded.
SetImGroup |
SetImGroupAsync | Overloaded.
SetImListMigrationCompleted |
SetImListMigrationCompletedAsync | Overloaded.
SetTeamMailbox |
SetTeamMailboxAsync | Overloaded.
SetUserOofSettings |
SetUserOofSettingsAsync | Overloaded.
Subscribe |
SubscribeAsync | Overloaded.
SyncFolderHierarchy |
SyncFolderHierarchyAsync | Overloaded.
SyncFolderItems |
SyncFolderItemsAsync | Overloaded.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
UninstallApp |
UninstallAppAsync | Overloaded.
UnpinTeamMailbox |
UnpinTeamMailboxAsync | Overloaded.
Unsubscribe |
UnsubscribeAsync | Overloaded.
UpdateDelegate |
UpdateDelegateAsync | Overloaded.
UpdateFolder |
UpdateFolderAsync | Overloaded.
UpdateInboxRules |
UpdateInboxRulesAsync | Overloaded.
UpdateItem |
UpdateItemAsync | Overloaded.
UpdateItemInRecoverableItems |
UpdateItemInRecoverableItemsAsync | Overloaded.
UpdateUserConfiguration |
UpdateUserConfigurationAsync | Overloaded.
UploadItems |
UploadItemsAsync | Overloaded.

Public Instance Events

AddDelegateCompleted |
AddDistributionGroupToImListCompleted |
AddImContactToGroupCompleted |
AddImGroupCompleted |
AddNewImContactToGroupCompleted |
AddNewTelUriContactToGroupCompleted |
ApplyConversationActionCompleted |
ArchiveItemCompleted |
ConvertIdCompleted |
CopyFolderCompleted |
CopyItemCompleted |
CreateAttachmentCompleted |
CreateFolderCompleted |
CreateFolderPathCompleted |
CreateItemCompleted |
CreateManagedFolderCompleted |
CreateUserConfigurationCompleted |
DeleteAttachmentCompleted |
DeleteFolderCompleted |
DeleteItemCompleted |
DeleteUserConfigurationCompleted |
DisableAppCompleted |
DisconnectPhoneCallCompleted |
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
EmptyFolderCompleted |
ExpandDLCompleted |
ExportItemsCompleted |
FindConversationCompleted |
FindFolderCompleted |
FindItemCompleted |
FindMessageTrackingReportCompleted |
FindPeopleCompleted |
GetAppManifestsCompleted |
GetAppMarketplaceUrlCompleted |
GetAttachmentCompleted |
GetClientAccessTokenCompleted |
GetConversationItemsCompleted |
GetDelegateCompleted |
GetDiscoverySearchConfigurationCompleted |
GetEventsCompleted |
GetFolderCompleted |
GetHoldOnMailboxesCompleted |
GetImItemListCompleted |
GetImItemsCompleted |
GetInboxRulesCompleted |
GetItemCompleted |
GetMailTipsCompleted |
GetMessageTrackingReportCompleted |
GetNonIndexableItemDetailsCompleted |
GetNonIndexableItemStatisticsCompleted |
GetPasswordExpirationDateCompleted |
GetPersonaCompleted |
GetPhoneCallInformationCompleted |
GetRoomListsCompleted |
GetRoomsCompleted |
GetSearchableMailboxesCompleted |
GetServerTimeZonesCompleted |
GetServiceConfigurationCompleted |
GetSharingFolderCompleted |
GetSharingMetadataCompleted |
GetStreamingEventsCompleted |
GetUserAvailabilityCompleted |
GetUserConfigurationCompleted |
GetUserOofSettingsCompleted |
GetUserPhotoCompleted |
GetUserRetentionPolicyTagsCompleted |
InstallAppCompleted |
MarkAllItemsAsReadCompleted |
MarkAsJunkCompleted |
MoveFolderCompleted |
MoveItemCompleted |
PlayOnPhoneCompleted |
RefreshSharingFolderCompleted |
RemoveContactFromImListCompleted |
RemoveDelegateCompleted |
RemoveDistributionGroupFromImListCompleted |
RemoveImContactFromGroupCompleted |
RemoveImGroupCompleted |
ResolveNamesCompleted |
SearchMailboxesCompleted |
SendItemCompleted |
SetHoldOnMailboxesCompleted |
SetImGroupCompleted |
SetImListMigrationCompletedCompleted |
SetTeamMailboxCompleted |
SetUserOofSettingsCompleted |
SubscribeCompleted |
SyncFolderHierarchyCompleted |
SyncFolderItemsCompleted |
UninstallAppCompleted |
UnpinTeamMailboxCompleted |
UnsubscribeCompleted |
UpdateDelegateCompleted |
UpdateFolderCompleted |
UpdateInboxRulesCompleted |
UpdateItemCompleted |
UpdateItemInRecoverableItemsCompleted |
UpdateUserConfigurationCompleted |
UploadItemsCompleted |

Protected Instance Properties

CanRaiseEvents (inherited from Component) | Gets a value indicating whether the component can raise an event.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.

Protected Instance Methods

BeginInvoke (inherited from SoapHttpClientProtocol) | Starts an asynchronous invocation of an XML Web service method using SOAP.
Dispose (inherited from Component) | Overloaded. Releases the unmanaged resources used by the Component and optionally releases the managed resources.
EndInvoke (inherited from SoapHttpClientProtocol) | Ends an asynchronous invocation of an XML Web service method using SOAP.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetReaderForMessage |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetWebRequest (inherited from SoapHttpClientProtocol) | Creates a WebRequest for the specified uri.
GetWebResponse (inherited from HttpWebClientProtocol) | Overloaded. Returns a response from a synchronous request to an XML Web service method.
GetWriterForMessage (inherited from SoapHttpClientProtocol) | Returns a XmlWriter initialized with the Stream property of the SoapClientMessage parameter.
Invoke (inherited from SoapHttpClientProtocol) | Invokes an XML Web service method synchronously using SOAP.
InvokeAsync (inherited from SoapHttpClientProtocol) | Overloaded. Invokes the specified method asynchronously.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding Constructor

Initializes a new instance of the ExchangeServiceBinding class.

public ExchangeServiceBinding();

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding Properties

The properties of the ExchangeServiceBinding class are listed below. For a complete list of ExchangeServiceBinding class members, see the ExchangeServiceBinding Members topic.

Public Instance Properties

AllowAutoRedirect (inherited from HttpWebClientProtocol) | Gets or sets whether the client automatically follows server redirects.
ClientCertificates (inherited from HttpWebClientProtocol) | Gets the collection of client certificates.
ConnectionGroupName (inherited from WebClientProtocol) | Gets or sets the name of the connection group for the request.
Container (inherited from Component) | Gets the IContainer that contains the Component.
CookieContainer (inherited from HttpWebClientProtocol) | Gets or sets the collection of cookies.
Credentials (inherited from WebClientProtocol) | Gets or sets security credentials for XML Web service client authentication.
DateTimePrecision |
EnableDecompression (inherited from HttpWebClientProtocol) | Gets or sets a Boolean that indicates whether decompression is enabled for this HttpWebClientProtocol. The default is true.
ExchangeImpersonation |
MailboxCulture |
ManagementRole |
PreAuthenticate (inherited from WebClientProtocol) | Gets or sets whether pre-authentication is enabled.
Proxy (inherited from HttpWebClientProtocol) | Gets or sets proxy information for making an XML Web service request through a firewall.
RequestEncoding (inherited from WebClientProtocol) | The Encoding used to make the client request to the XML Web service.
RequestServerVersionValue |
ServerVersionInfoValue |
Site (inherited from Component) | Gets or sets the ISite of the Component.
SoapVersion (inherited from SoapHttpClientProtocol) | Gets or sets the version of the SOAP protocol used to make the SOAP request to the XML Web service.
Timeout (inherited from WebClientProtocol) | Indicates the time an XML Web service client waits for a synchronous XML Web service request to complete (in milliseconds).
TimeZoneContext |
UnsafeAuthenticatedConnectionSharing (inherited from HttpWebClientProtocol) | Gets or sets a value that indicates whether connection sharing is enabled when the client uses NTLM authentication to connect to the Web server that hosts the XML Web service.
Url |
UseDefaultCredentials |
UserAgent (inherited from HttpWebClientProtocol) | Gets or sets the value for the user agent header that is sent with each request.

Protected Instance Properties

CanRaiseEvents (inherited from Component) | Gets a value indicating whether the component can raise an event.
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DateTimePrecision Property

Aspose.Email

ExchangeServiceBinding.DateTimePrecision Property

public DateTimePrecisionType DateTimePrecision {get; set;}

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeImpersonation Property

Aspose.Email

ExchangeServiceBinding.ExchangeImpersonation Property

public ExchangeImpersonationType ExchangeImpersonation {get; set;}

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxCulture Property

Aspose.Email

ExchangeServiceBinding.MailboxCulture Property

public MailboxCultureType MailboxCulture {get; set;}

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ManagementRole Property

Aspose.Email

ExchangeServiceBinding.ManagementRole Property

public ManagementRoleType ManagementRole {get; set;}

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RequestServerVersionValue Property

Aspose.Email

ExchangeServiceBinding.RequestServerVersionValue Property

public RequestServerVersion RequestServerVersionValue {get; set;}

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ServerVersionInfoValue Property

Aspose.Email

ExchangeServiceBinding.ServerVersionInfoValue Property

public ServerVersionInfo ServerVersionInfoValue {get; set;}

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TimeZoneContext Property

Aspose.Email

ExchangeServiceBinding.TimeZoneContext Property

public TimeZoneContextType TimeZoneContext {get; set;}

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Url Property

Aspose.Email

ExchangeServiceBinding.Url Property

new public string Url {get; set;}

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UseDefaultCredentials Property

Aspose.Email

ExchangeServiceBinding.UseDefaultCredentials Property

new public bool UseDefaultCredentials {get; set;}

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding Methods

The methods of the ExchangeServiceBinding class are listed below. For a complete list of ExchangeServiceBinding class members, see the ExchangeServiceBinding Members topic.

Public Instance Methods

Abort (inherited from WebClientProtocol) | Cancels a request to an XML Web service method.
AddDelegate |
AddDelegateAsync | Overloaded.
AddDistributionGroupToImList |
AddDistributionGroupToImListAsync | Overloaded.
AddImContactToGroup |
AddImContactToGroupAsync | Overloaded.
AddImGroup |
AddImGroupAsync | Overloaded.
AddNewImContactToGroup |
AddNewImContactToGroupAsync | Overloaded.
AddNewTelUriContactToGroup |
AddNewTelUriContactToGroupAsync | Overloaded.
ApplyConversationAction |
ApplyConversationActionAsync | Overloaded.
ArchiveItem |
ArchiveItemAsync | Overloaded.
CancelAsync |
ConvertId |
ConvertIdAsync | Overloaded.
CopyFolder |
CopyFolderAsync | Overloaded.
CopyItem |
CopyItemAsync | Overloaded.
CreateAttachment |
CreateAttachmentAsync | Overloaded.
CreateFolder |
CreateFolderAsync | Overloaded.
CreateFolderPath |
CreateFolderPathAsync | Overloaded.
CreateItem |
CreateItemAsync | Overloaded.
CreateManagedFolder |
CreateManagedFolderAsync | Overloaded.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
CreateUserConfiguration |
CreateUserConfigurationAsync | Overloaded.
DeleteAttachment |
DeleteAttachmentAsync | Overloaded.
DeleteFolder |
DeleteFolderAsync | Overloaded.
DeleteItem |
DeleteItemAsync | Overloaded.
DeleteUserConfiguration |
DeleteUserConfigurationAsync | Overloaded.
DisableApp |
DisableAppAsync | Overloaded.
DisconnectPhoneCall |
DisconnectPhoneCallAsync | Overloaded.
Discover (inherited from SoapHttpClientProtocol) | Dynamically binds to an XML Web service described in the discovery document at Url.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
EmptyFolder |
EmptyFolderAsync | Overloaded.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExpandDL |
ExpandDLAsync | Overloaded.
ExportItems |
ExportItemsAsync | Overloaded.
FindConversation |
FindConversationAsync | Overloaded.
FindFolder |
FindFolderAsync | Overloaded.
FindItem |
FindItemAsync | Overloaded.
FindMessageTrackingReport |
FindMessageTrackingReportAsync | Overloaded.
FindPeople |
FindPeopleAsync | Overloaded.
GetAppManifests |
GetAppManifestsAsync | Overloaded.
GetAppMarketplaceUrl |
GetAppMarketplaceUrlAsync | Overloaded.
GetAttachment |
GetAttachmentAsync | Overloaded.
GetClientAccessToken |
GetClientAccessTokenAsync | Overloaded.
GetConversationItems |
GetConversationItemsAsync | Overloaded.
GetDelegate |
GetDelegateAsync | Overloaded.
GetDiscoverySearchConfiguration |
GetDiscoverySearchConfigurationAsync | Overloaded.
GetEvents |
GetEventsAsync | Overloaded.
GetFolder |
GetFolderAsync | Overloaded.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetHoldOnMailboxes |
GetHoldOnMailboxesAsync | Overloaded.
GetImItemList |
GetImItemListAsync | Overloaded.
GetImItems |
GetImItemsAsync | Overloaded.
GetInboxRules |
GetInboxRulesAsync | Overloaded.
GetItem |
GetItemAsync | Overloaded.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetMailTips |
GetMailTipsAsync | Overloaded.
GetMessageTrackingReport |
GetMessageTrackingReportAsync | Overloaded.
GetNonIndexableItemDetails |
GetNonIndexableItemDetailsAsync | Overloaded.
GetNonIndexableItemStatistics |
GetNonIndexableItemStatisticsAsync | Overloaded.
GetPasswordExpirationDate |
GetPasswordExpirationDateAsync | Overloaded.
GetPersona |
GetPersonaAsync | Overloaded.
GetPhoneCallInformation |
GetPhoneCallInformationAsync | Overloaded.
GetRoomLists |
GetRoomListsAsync | Overloaded.
GetRooms |
GetRoomsAsync | Overloaded.
GetSearchableMailboxes |
GetSearchableMailboxesAsync | Overloaded.
GetServerTimeZones |
GetServerTimeZonesAsync | Overloaded.
GetServiceConfiguration |
GetServiceConfigurationAsync | Overloaded.
GetSharingFolder |
GetSharingFolderAsync | Overloaded.
GetSharingMetadata |
GetSharingMetadataAsync | Overloaded.
GetStreamingEvents |
GetStreamingEventsAsync | Overloaded.
GetType (inherited from Object) | Gets the Type of the current instance.
GetUserAvailability |
GetUserAvailabilityAsync | Overloaded.
GetUserConfiguration |
GetUserConfigurationAsync | Overloaded.
GetUserOofSettings |
GetUserOofSettingsAsync | Overloaded.
GetUserPhoto |
GetUserPhotoAsync | Overloaded.
GetUserRetentionPolicyTags |
GetUserRetentionPolicyTagsAsync | Overloaded.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
InstallApp |
InstallAppAsync | Overloaded.
MarkAllItemsAsRead |
MarkAllItemsAsReadAsync | Overloaded.
MarkAsJunk |
MarkAsJunkAsync | Overloaded.
MoveFolder |
MoveFolderAsync | Overloaded.
MoveItem |
MoveItemAsync | Overloaded.
PlayOnPhone |
PlayOnPhoneAsync | Overloaded.
RefreshSharingFolder |
RefreshSharingFolderAsync | Overloaded.
RemoveContactFromImList |
RemoveContactFromImListAsync | Overloaded.
RemoveDelegate |
RemoveDelegateAsync | Overloaded.
RemoveDistributionGroupFromImList |
RemoveDistributionGroupFromImListAsync | Overloaded.
RemoveImContactFromGroup |
RemoveImContactFromGroupAsync | Overloaded.
RemoveImGroup |
RemoveImGroupAsync | Overloaded.
ResolveNames |
ResolveNamesAsync | Overloaded.
SearchMailboxes |
SearchMailboxesAsync | Overloaded.
SendItem |
SendItemAsync | Overloaded.
SetHoldOnMailboxes |
SetHoldOnMailboxesAsync | Overloaded.
SetImGroup |
SetImGroupAsync | Overloaded.
SetImListMigrationCompleted |
SetImListMigrationCompletedAsync | Overloaded.
SetTeamMailbox |
SetTeamMailboxAsync | Overloaded.
SetUserOofSettings |
SetUserOofSettingsAsync | Overloaded.
Subscribe |
SubscribeAsync | Overloaded.
SyncFolderHierarchy |
SyncFolderHierarchyAsync | Overloaded.
SyncFolderItems |
SyncFolderItemsAsync | Overloaded.
ToString (inherited from Component) | Returns a String containing the name of the Component, if any. This method should not be overridden.
UninstallApp |
UninstallAppAsync | Overloaded.
UnpinTeamMailbox |
UnpinTeamMailboxAsync | Overloaded.
Unsubscribe |
UnsubscribeAsync | Overloaded.
UpdateDelegate |
UpdateDelegateAsync | Overloaded.
UpdateFolder |
UpdateFolderAsync | Overloaded.
UpdateInboxRules |
UpdateInboxRulesAsync | Overloaded.
UpdateItem |
UpdateItemAsync | Overloaded.
UpdateItemInRecoverableItems |
UpdateItemInRecoverableItemsAsync | Overloaded.
UpdateUserConfiguration |
UpdateUserConfigurationAsync | Overloaded.
UploadItems |
UploadItemsAsync | Overloaded.

Protected Instance Methods

BeginInvoke (inherited from SoapHttpClientProtocol) | Starts an asynchronous invocation of an XML Web service method using SOAP.
Dispose (inherited from Component) | Overloaded. Releases the unmanaged resources used by the Component and optionally releases the managed resources.
EndInvoke (inherited from SoapHttpClientProtocol) | Ends an asynchronous invocation of an XML Web service method using SOAP.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetReaderForMessage |
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetWebRequest (inherited from SoapHttpClientProtocol) | Creates a WebRequest for the specified uri.
GetWebResponse (inherited from HttpWebClientProtocol) | Overloaded. Returns a response from a synchronous request to an XML Web service method.
GetWriterForMessage (inherited from SoapHttpClientProtocol) | Returns a XmlWriter initialized with the Stream property of the SoapClientMessage parameter.
Invoke (inherited from SoapHttpClientProtocol) | Invokes an XML Web service method synchronously using SOAP.
InvokeAsync (inherited from SoapHttpClientProtocol) | Overloaded. Invokes the specified method asynchronously.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.AddDelegate Method

public AddDelegateResponseMessageType AddDelegate(
AddDelegateType AddDelegate1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddDelegateAsync Method

Aspose.Email

ExchangeServiceBinding.AddDelegateAsync Method

Overload List

public void AddDelegateAsync(AddDelegateType);

public void AddDelegateAsync(AddDelegateType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.AddDelegateAsync Method (AddDelegateType)

public void AddDelegateAsync(
AddDelegateType AddDelegate1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.AddDelegateAsync Overload List


ExchangeServiceBinding.AddDelegateAsync Method (AddDelegateType, Object)

public void AddDelegateAsync(
AddDelegateType AddDelegate1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.AddDelegateAsync Overload List


ExchangeServiceBinding.AddDistributionGroupToImList Method

public AddDistributionGroupToImListResponseMessageType AddDistributionGroupToImList(
AddDistributionGroupToImListType AddDistributionGroupToImList1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddDistributionGroupToImListAsync Method

Aspose.Email

ExchangeServiceBinding.AddDistributionGroupToImListAsync Method

Overload List

public void AddDistributionGroupToImListAsync(AddDistributionGroupToImListType);

public void AddDistributionGroupToImListAsync(AddDistributionGroupToImListType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.AddDistributionGroupToImListAsync Method (AddDistributionGroupToImListType)

public void AddDistributionGroupToImListAsync(
AddDistributionGroupToImListType AddDistributionGroupToImList1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.AddDistributionGroupToImListAsync Overload List


ExchangeServiceBinding.AddDistributionGroupToImListAsync Method (AddDistributionGroupToImListType, Object)

public void AddDistributionGroupToImListAsync(
AddDistributionGroupToImListType AddDistributionGroupToImList1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.AddDistributionGroupToImListAsync Overload List


ExchangeServiceBinding.AddImContactToGroup Method

public AddImContactToGroupResponseMessageType AddImContactToGroup(
AddImContactToGroupType AddImContactToGroup1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddImContactToGroupAsync Method

Aspose.Email

ExchangeServiceBinding.AddImContactToGroupAsync Method

Overload List

public void AddImContactToGroupAsync(AddImContactToGroupType);

public void AddImContactToGroupAsync(AddImContactToGroupType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.AddImContactToGroupAsync Method (AddImContactToGroupType)

public void AddImContactToGroupAsync(
AddImContactToGroupType AddImContactToGroup1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.AddImContactToGroupAsync Overload List


ExchangeServiceBinding.AddImContactToGroupAsync Method (AddImContactToGroupType, Object)

public void AddImContactToGroupAsync(
AddImContactToGroupType AddImContactToGroup1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.AddImContactToGroupAsync Overload List


ExchangeServiceBinding.AddImGroup Method

public AddImGroupResponseMessageType AddImGroup(
AddImGroupType AddImGroup1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddImGroupAsync Method

Aspose.Email

ExchangeServiceBinding.AddImGroupAsync Method

Overload List

public void AddImGroupAsync(AddImGroupType);

public void AddImGroupAsync(AddImGroupType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.AddImGroupAsync Method (AddImGroupType)

public void AddImGroupAsync(
AddImGroupType AddImGroup1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.AddImGroupAsync Overload List


ExchangeServiceBinding.AddImGroupAsync Method (AddImGroupType, Object)

public void AddImGroupAsync(
AddImGroupType AddImGroup1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.AddImGroupAsync Overload List


ExchangeServiceBinding.AddNewImContactToGroup Method

public AddNewImContactToGroupResponseMessageType AddNewImContactToGroup(
AddNewImContactToGroupType AddNewImContactToGroup1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddNewImContactToGroupAsync Method

Aspose.Email

ExchangeServiceBinding.AddNewImContactToGroupAsync Method

Overload List

public void AddNewImContactToGroupAsync(AddNewImContactToGroupType);

public void AddNewImContactToGroupAsync(AddNewImContactToGroupType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.AddNewImContactToGroupAsync Method (AddNewImContactToGroupType)

public void AddNewImContactToGroupAsync(
AddNewImContactToGroupType AddNewImContactToGroup1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.AddNewImContactToGroupAsync Overload List


ExchangeServiceBinding.AddNewImContactToGroupAsync Method (AddNewImContactToGroupType, Object)

public void AddNewImContactToGroupAsync(
AddNewImContactToGroupType AddNewImContactToGroup1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.AddNewImContactToGroupAsync Overload List


ExchangeServiceBinding.AddNewTelUriContactToGroup Method

public AddNewTelUriContactToGroupResponseMessageType AddNewTelUriContactToGroup(
AddNewTelUriContactToGroupType AddNewTelUriContactToGroup1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddNewTelUriContactToGroupAsync Method

Aspose.Email

ExchangeServiceBinding.AddNewTelUriContactToGroupAsync Method

Overload List

public void AddNewTelUriContactToGroupAsync(AddNewTelUriContactToGroupType);

public void AddNewTelUriContactToGroupAsync(AddNewTelUriContactToGroupType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.AddNewTelUriContactToGroupAsync Method (AddNewTelUriContactToGroupType)

public void AddNewTelUriContactToGroupAsync(
AddNewTelUriContactToGroupType AddNewTelUriContactToGroup1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.AddNewTelUriContactToGroupAsync Overload List


ExchangeServiceBinding.AddNewTelUriContactToGroupAsync Method (AddNewTelUriContactToGroupType, Object)

public void AddNewTelUriContactToGroupAsync(
AddNewTelUriContactToGroupType AddNewTelUriContactToGroup1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.AddNewTelUriContactToGroupAsync Overload List


ExchangeServiceBinding.ApplyConversationAction Method

public ApplyConversationActionResponseType ApplyConversationAction(
ApplyConversationActionType ApplyConversationAction1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ApplyConversationActionAsync Method

Aspose.Email

ExchangeServiceBinding.ApplyConversationActionAsync Method

Overload List

public void ApplyConversationActionAsync(ApplyConversationActionType);

public void ApplyConversationActionAsync(ApplyConversationActionType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.ApplyConversationActionAsync Method (ApplyConversationActionType)

public void ApplyConversationActionAsync(
ApplyConversationActionType ApplyConversationAction1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.ApplyConversationActionAsync Overload List


ExchangeServiceBinding.ApplyConversationActionAsync Method (ApplyConversationActionType, Object)

public void ApplyConversationActionAsync(
ApplyConversationActionType ApplyConversationAction1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.ApplyConversationActionAsync Overload List


ExchangeServiceBinding.ArchiveItem Method

public ArchiveItemResponseType ArchiveItem(
ArchiveItemType ArchiveItem1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ArchiveItemAsync Method

Aspose.Email

ExchangeServiceBinding.ArchiveItemAsync Method

Overload List

public void ArchiveItemAsync(ArchiveItemType);

public void ArchiveItemAsync(ArchiveItemType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.ArchiveItemAsync Method (ArchiveItemType)

public void ArchiveItemAsync(
ArchiveItemType ArchiveItem1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.ArchiveItemAsync Overload List


ExchangeServiceBinding.ArchiveItemAsync Method (ArchiveItemType, Object)

public void ArchiveItemAsync(
ArchiveItemType ArchiveItem1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.ArchiveItemAsync Overload List


ExchangeServiceBinding.CancelAsync Method

new public void CancelAsync(
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.ConvertId Method

public ConvertIdResponseType ConvertId(
ConvertIdType ConvertId1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConvertIdAsync Method

Aspose.Email

ExchangeServiceBinding.ConvertIdAsync Method

Overload List

public void ConvertIdAsync(ConvertIdType);

public void ConvertIdAsync(ConvertIdType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.ConvertIdAsync Method (ConvertIdType)

public void ConvertIdAsync(
ConvertIdType ConvertId1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.ConvertIdAsync Overload List


ExchangeServiceBinding.ConvertIdAsync Method (ConvertIdType, Object)

public void ConvertIdAsync(
ConvertIdType ConvertId1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.ConvertIdAsync Overload List


ExchangeServiceBinding.CopyFolder Method

public CopyFolderResponseType CopyFolder(
CopyFolderType CopyFolder1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CopyFolderAsync Method

Aspose.Email

ExchangeServiceBinding.CopyFolderAsync Method

Overload List

public void CopyFolderAsync(CopyFolderType);

public void CopyFolderAsync(CopyFolderType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.CopyFolderAsync Method (CopyFolderType)

public void CopyFolderAsync(
CopyFolderType CopyFolder1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.CopyFolderAsync Overload List


ExchangeServiceBinding.CopyFolderAsync Method (CopyFolderType, Object)

public void CopyFolderAsync(
CopyFolderType CopyFolder1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.CopyFolderAsync Overload List


ExchangeServiceBinding.CopyItem Method

public CopyItemResponseType CopyItem(
CopyItemType CopyItem1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CopyItemAsync Method

Aspose.Email

ExchangeServiceBinding.CopyItemAsync Method

Overload List

public void CopyItemAsync(CopyItemType);

public void CopyItemAsync(CopyItemType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.CopyItemAsync Method (CopyItemType)

public void CopyItemAsync(
CopyItemType CopyItem1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.CopyItemAsync Overload List


ExchangeServiceBinding.CopyItemAsync Method (CopyItemType, Object)

public void CopyItemAsync(
CopyItemType CopyItem1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.CopyItemAsync Overload List


ExchangeServiceBinding.CreateAttachment Method

public CreateAttachmentResponseType CreateAttachment(
CreateAttachmentType CreateAttachment1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateAttachmentAsync Method

Aspose.Email

ExchangeServiceBinding.CreateAttachmentAsync Method

Overload List

public void CreateAttachmentAsync(CreateAttachmentType);

public void CreateAttachmentAsync(CreateAttachmentType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.CreateAttachmentAsync Method (CreateAttachmentType)

public void CreateAttachmentAsync(
CreateAttachmentType CreateAttachment1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.CreateAttachmentAsync Overload List


ExchangeServiceBinding.CreateAttachmentAsync Method (CreateAttachmentType, Object)

public void CreateAttachmentAsync(
CreateAttachmentType CreateAttachment1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.CreateAttachmentAsync Overload List


ExchangeServiceBinding.CreateFolder Method

public CreateFolderResponseType CreateFolder(
CreateFolderType CreateFolder1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateFolderAsync Method

Aspose.Email

ExchangeServiceBinding.CreateFolderAsync Method

Overload List

public void CreateFolderAsync(CreateFolderType);

public void CreateFolderAsync(CreateFolderType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.CreateFolderAsync Method (CreateFolderType)

public void CreateFolderAsync(
CreateFolderType CreateFolder1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.CreateFolderAsync Overload List


ExchangeServiceBinding.CreateFolderAsync Method (CreateFolderType, Object)

public void CreateFolderAsync(
CreateFolderType CreateFolder1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.CreateFolderAsync Overload List


ExchangeServiceBinding.CreateFolderPath Method

public CreateFolderPathResponseType CreateFolderPath(
CreateFolderPathType CreateFolderPath1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateFolderPathAsync Method

Aspose.Email

ExchangeServiceBinding.CreateFolderPathAsync Method

Overload List

public void CreateFolderPathAsync(CreateFolderPathType);

public void CreateFolderPathAsync(CreateFolderPathType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.CreateFolderPathAsync Method (CreateFolderPathType)

public void CreateFolderPathAsync(
CreateFolderPathType CreateFolderPath1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.CreateFolderPathAsync Overload List


ExchangeServiceBinding.CreateFolderPathAsync Method (CreateFolderPathType, Object)

public void CreateFolderPathAsync(
CreateFolderPathType CreateFolderPath1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.CreateFolderPathAsync Overload List


ExchangeServiceBinding.CreateItem Method

public CreateItemResponseType CreateItem(
CreateItemType CreateItem1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateItemAsync Method

Aspose.Email

ExchangeServiceBinding.CreateItemAsync Method

Overload List

public void CreateItemAsync(CreateItemType);

public void CreateItemAsync(CreateItemType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.CreateItemAsync Method (CreateItemType)

public void CreateItemAsync(
CreateItemType CreateItem1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.CreateItemAsync Overload List


ExchangeServiceBinding.CreateItemAsync Method (CreateItemType, Object)

public void CreateItemAsync(
CreateItemType CreateItem1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.CreateItemAsync Overload List


ExchangeServiceBinding.CreateManagedFolder Method

public CreateManagedFolderResponseType CreateManagedFolder(
CreateManagedFolderRequestType CreateManagedFolder1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateManagedFolderAsync Method

Aspose.Email

ExchangeServiceBinding.CreateManagedFolderAsync Method

Overload List

public void CreateManagedFolderAsync(CreateManagedFolderRequestType);

public void CreateManagedFolderAsync(CreateManagedFolderRequestType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.CreateManagedFolderAsync Method (CreateManagedFolderRequestType)

public void CreateManagedFolderAsync(
CreateManagedFolderRequestType CreateManagedFolder1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.CreateManagedFolderAsync Overload List


ExchangeServiceBinding.CreateManagedFolderAsync Method (CreateManagedFolderRequestType, Object)

public void CreateManagedFolderAsync(
CreateManagedFolderRequestType CreateManagedFolder1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.CreateManagedFolderAsync Overload List


ExchangeServiceBinding.CreateUserConfiguration Method

public CreateUserConfigurationResponseType CreateUserConfiguration(
CreateUserConfigurationType CreateUserConfiguration1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateUserConfigurationAsync Method

Aspose.Email

ExchangeServiceBinding.CreateUserConfigurationAsync Method

Overload List

public void CreateUserConfigurationAsync(CreateUserConfigurationType);

public void CreateUserConfigurationAsync(CreateUserConfigurationType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.CreateUserConfigurationAsync Method (CreateUserConfigurationType)

public void CreateUserConfigurationAsync(
CreateUserConfigurationType CreateUserConfiguration1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.CreateUserConfigurationAsync Overload List


ExchangeServiceBinding.CreateUserConfigurationAsync Method (CreateUserConfigurationType, Object)

public void CreateUserConfigurationAsync(
CreateUserConfigurationType CreateUserConfiguration1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.CreateUserConfigurationAsync Overload List


ExchangeServiceBinding.DeleteAttachment Method

public DeleteAttachmentResponseType DeleteAttachment(
DeleteAttachmentType DeleteAttachment1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteAttachmentAsync Method

Aspose.Email

ExchangeServiceBinding.DeleteAttachmentAsync Method

Overload List

public void DeleteAttachmentAsync(DeleteAttachmentType);

public void DeleteAttachmentAsync(DeleteAttachmentType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.DeleteAttachmentAsync Method (DeleteAttachmentType)

public void DeleteAttachmentAsync(
DeleteAttachmentType DeleteAttachment1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.DeleteAttachmentAsync Overload List


ExchangeServiceBinding.DeleteAttachmentAsync Method (DeleteAttachmentType, Object)

public void DeleteAttachmentAsync(
DeleteAttachmentType DeleteAttachment1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.DeleteAttachmentAsync Overload List


ExchangeServiceBinding.DeleteFolder Method

public DeleteFolderResponseType DeleteFolder(
DeleteFolderType DeleteFolder1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteFolderAsync Method

Aspose.Email

ExchangeServiceBinding.DeleteFolderAsync Method

Overload List

public void DeleteFolderAsync(DeleteFolderType);

public void DeleteFolderAsync(DeleteFolderType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.DeleteFolderAsync Method (DeleteFolderType)

public void DeleteFolderAsync(
DeleteFolderType DeleteFolder1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.DeleteFolderAsync Overload List


ExchangeServiceBinding.DeleteFolderAsync Method (DeleteFolderType, Object)

public void DeleteFolderAsync(
DeleteFolderType DeleteFolder1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.DeleteFolderAsync Overload List


ExchangeServiceBinding.DeleteItem Method

public DeleteItemResponseType DeleteItem(
DeleteItemType DeleteItem1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteItemAsync Method

Aspose.Email

ExchangeServiceBinding.DeleteItemAsync Method

Overload List

public void DeleteItemAsync(DeleteItemType);

public void DeleteItemAsync(DeleteItemType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.DeleteItemAsync Method (DeleteItemType)

public void DeleteItemAsync(
DeleteItemType DeleteItem1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.DeleteItemAsync Overload List


ExchangeServiceBinding.DeleteItemAsync Method (DeleteItemType, Object)

public void DeleteItemAsync(
DeleteItemType DeleteItem1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.DeleteItemAsync Overload List


ExchangeServiceBinding.DeleteUserConfiguration Method

public DeleteUserConfigurationResponseType DeleteUserConfiguration(
DeleteUserConfigurationType DeleteUserConfiguration1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteUserConfigurationAsync Method

Aspose.Email

ExchangeServiceBinding.DeleteUserConfigurationAsync Method

Overload List

public void DeleteUserConfigurationAsync(DeleteUserConfigurationType);

public void DeleteUserConfigurationAsync(DeleteUserConfigurationType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.DeleteUserConfigurationAsync Method (DeleteUserConfigurationType)

public void DeleteUserConfigurationAsync(
DeleteUserConfigurationType DeleteUserConfiguration1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.DeleteUserConfigurationAsync Overload List


ExchangeServiceBinding.DeleteUserConfigurationAsync Method (DeleteUserConfigurationType, Object)

public void DeleteUserConfigurationAsync(
DeleteUserConfigurationType DeleteUserConfiguration1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.DeleteUserConfigurationAsync Overload List


ExchangeServiceBinding.DisableApp Method

public DisableAppResponseType DisableApp(
DisableAppType DisableApp1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisableAppAsync Method

Aspose.Email

ExchangeServiceBinding.DisableAppAsync Method

Overload List

public void DisableAppAsync(DisableAppType);

public void DisableAppAsync(DisableAppType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.DisableAppAsync Method (DisableAppType)

public void DisableAppAsync(
DisableAppType DisableApp1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.DisableAppAsync Overload List


ExchangeServiceBinding.DisableAppAsync Method (DisableAppType, Object)

public void DisableAppAsync(
DisableAppType DisableApp1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.DisableAppAsync Overload List


ExchangeServiceBinding.DisconnectPhoneCall Method

public DisconnectPhoneCallResponseMessageType DisconnectPhoneCall(
DisconnectPhoneCallType DisconnectPhoneCall1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisconnectPhoneCallAsync Method

Aspose.Email

ExchangeServiceBinding.DisconnectPhoneCallAsync Method

Overload List

public void DisconnectPhoneCallAsync(DisconnectPhoneCallType);

public void DisconnectPhoneCallAsync(DisconnectPhoneCallType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.DisconnectPhoneCallAsync Method (DisconnectPhoneCallType)

public void DisconnectPhoneCallAsync(
DisconnectPhoneCallType DisconnectPhoneCall1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.DisconnectPhoneCallAsync Overload List


ExchangeServiceBinding.DisconnectPhoneCallAsync Method (DisconnectPhoneCallType, Object)

public void DisconnectPhoneCallAsync(
DisconnectPhoneCallType DisconnectPhoneCall1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.DisconnectPhoneCallAsync Overload List


ExchangeServiceBinding.EmptyFolder Method

public EmptyFolderResponseType EmptyFolder(
EmptyFolderType EmptyFolder1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EmptyFolderAsync Method

Aspose.Email

ExchangeServiceBinding.EmptyFolderAsync Method

Overload List

public void EmptyFolderAsync(EmptyFolderType);

public void EmptyFolderAsync(EmptyFolderType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.EmptyFolderAsync Method (EmptyFolderType)

public void EmptyFolderAsync(
EmptyFolderType EmptyFolder1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.EmptyFolderAsync Overload List


ExchangeServiceBinding.EmptyFolderAsync Method (EmptyFolderType, Object)

public void EmptyFolderAsync(
EmptyFolderType EmptyFolder1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.EmptyFolderAsync Overload List


ExchangeServiceBinding.ExpandDL Method

public ExpandDLResponseType ExpandDL(
ExpandDLType ExpandDL1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExpandDLAsync Method

Aspose.Email

ExchangeServiceBinding.ExpandDLAsync Method

Overload List

public void ExpandDLAsync(ExpandDLType);

public void ExpandDLAsync(ExpandDLType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.ExpandDLAsync Method (ExpandDLType)

public void ExpandDLAsync(
ExpandDLType ExpandDL1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.ExpandDLAsync Overload List


ExchangeServiceBinding.ExpandDLAsync Method (ExpandDLType, Object)

public void ExpandDLAsync(
ExpandDLType ExpandDL1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.ExpandDLAsync Overload List


ExchangeServiceBinding.ExportItems Method

public ExportItemsResponseType ExportItems(
ExportItemsType ExportItems1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExportItemsAsync Method

Aspose.Email

ExchangeServiceBinding.ExportItemsAsync Method

Overload List

public void ExportItemsAsync(ExportItemsType);

public void ExportItemsAsync(ExportItemsType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.ExportItemsAsync Method (ExportItemsType)

public void ExportItemsAsync(
ExportItemsType ExportItems1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.ExportItemsAsync Overload List


ExchangeServiceBinding.ExportItemsAsync Method (ExportItemsType, Object)

public void ExportItemsAsync(
ExportItemsType ExportItems1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.ExportItemsAsync Overload List


ExchangeServiceBinding.FindConversation Method

public FindConversationResponseMessageType FindConversation(
FindConversationType FindConversation1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindConversationAsync Method

Aspose.Email

ExchangeServiceBinding.FindConversationAsync Method

Overload List

public void FindConversationAsync(FindConversationType);

public void FindConversationAsync(FindConversationType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.FindConversationAsync Method (FindConversationType)

public void FindConversationAsync(
FindConversationType FindConversation1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.FindConversationAsync Overload List


ExchangeServiceBinding.FindConversationAsync Method (FindConversationType, Object)

public void FindConversationAsync(
FindConversationType FindConversation1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.FindConversationAsync Overload List


ExchangeServiceBinding.FindFolder Method

public FindFolderResponseType FindFolder(
FindFolderType FindFolder1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindFolderAsync Method

Aspose.Email

ExchangeServiceBinding.FindFolderAsync Method

Overload List

public void FindFolderAsync(FindFolderType);

public void FindFolderAsync(FindFolderType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.FindFolderAsync Method (FindFolderType)

public void FindFolderAsync(
FindFolderType FindFolder1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.FindFolderAsync Overload List


ExchangeServiceBinding.FindFolderAsync Method (FindFolderType, Object)

public void FindFolderAsync(
FindFolderType FindFolder1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.FindFolderAsync Overload List


ExchangeServiceBinding.FindItem Method

public FindItemResponseType FindItem(
FindItemType FindItem1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindItemAsync Method

Aspose.Email

ExchangeServiceBinding.FindItemAsync Method

Overload List

public void FindItemAsync(FindItemType);

public void FindItemAsync(FindItemType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.FindItemAsync Method (FindItemType)

public void FindItemAsync(
FindItemType FindItem1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.FindItemAsync Overload List


ExchangeServiceBinding.FindItemAsync Method (FindItemType, Object)

public void FindItemAsync(
FindItemType FindItem1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.FindItemAsync Overload List


ExchangeServiceBinding.FindMessageTrackingReport Method

public FindMessageTrackingReportResponseMessageType FindMessageTrackingReport(
FindMessageTrackingReportRequestType FindMessageTrackingReport1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindMessageTrackingReportAsync Method

Aspose.Email

ExchangeServiceBinding.FindMessageTrackingReportAsync Method

Overload List

public void FindMessageTrackingReportAsync(FindMessageTrackingReportRequestType);

public void FindMessageTrackingReportAsync(FindMessageTrackingReportRequestType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.FindMessageTrackingReportAsync Method (FindMessageTrackingReportRequestType)

public void FindMessageTrackingReportAsync(
FindMessageTrackingReportRequestType FindMessageTrackingReport1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.FindMessageTrackingReportAsync Overload List


ExchangeServiceBinding.FindMessageTrackingReportAsync Method (FindMessageTrackingReportRequestType, Object)

public void FindMessageTrackingReportAsync(
FindMessageTrackingReportRequestType FindMessageTrackingReport1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.FindMessageTrackingReportAsync Overload List


ExchangeServiceBinding.FindPeople Method

public FindPeopleResponseMessageType FindPeople(
FindPeopleType FindPeople1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindPeopleAsync Method

Aspose.Email

ExchangeServiceBinding.FindPeopleAsync Method

Overload List

public void FindPeopleAsync(FindPeopleType);

public void FindPeopleAsync(FindPeopleType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.FindPeopleAsync Method (FindPeopleType)

public void FindPeopleAsync(
FindPeopleType FindPeople1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.FindPeopleAsync Overload List


ExchangeServiceBinding.FindPeopleAsync Method (FindPeopleType, Object)

public void FindPeopleAsync(
FindPeopleType FindPeople1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.FindPeopleAsync Overload List


ExchangeServiceBinding.GetAppManifests Method

public GetAppManifestsResponseType GetAppManifests(
GetAppManifestsType GetAppManifests1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetAppManifestsAsync Method

Aspose.Email

ExchangeServiceBinding.GetAppManifestsAsync Method

Overload List

public void GetAppManifestsAsync(GetAppManifestsType);

public void GetAppManifestsAsync(GetAppManifestsType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetAppManifestsAsync Method (GetAppManifestsType)

public void GetAppManifestsAsync(
GetAppManifestsType GetAppManifests1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetAppManifestsAsync Overload List


ExchangeServiceBinding.GetAppManifestsAsync Method (GetAppManifestsType, Object)

public void GetAppManifestsAsync(
GetAppManifestsType GetAppManifests1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetAppManifestsAsync Overload List


ExchangeServiceBinding.GetAppMarketplaceUrl Method

public GetAppMarketplaceUrlResponseMessageType GetAppMarketplaceUrl(
GetAppMarketplaceUrlType GetAppMarketplaceUrl1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetAppMarketplaceUrlAsync Method

Aspose.Email

ExchangeServiceBinding.GetAppMarketplaceUrlAsync Method

Overload List

public void GetAppMarketplaceUrlAsync(GetAppMarketplaceUrlType);

public void GetAppMarketplaceUrlAsync(GetAppMarketplaceUrlType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetAppMarketplaceUrlAsync Method (GetAppMarketplaceUrlType)

public void GetAppMarketplaceUrlAsync(
GetAppMarketplaceUrlType GetAppMarketplaceUrl1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetAppMarketplaceUrlAsync Overload List


ExchangeServiceBinding.GetAppMarketplaceUrlAsync Method (GetAppMarketplaceUrlType, Object)

public void GetAppMarketplaceUrlAsync(
GetAppMarketplaceUrlType GetAppMarketplaceUrl1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetAppMarketplaceUrlAsync Overload List


ExchangeServiceBinding.GetAttachment Method

public GetAttachmentResponseType GetAttachment(
GetAttachmentType GetAttachment1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetAttachmentAsync Method

Aspose.Email

ExchangeServiceBinding.GetAttachmentAsync Method

Overload List

public void GetAttachmentAsync(GetAttachmentType);

public void GetAttachmentAsync(GetAttachmentType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetAttachmentAsync Method (GetAttachmentType)

public void GetAttachmentAsync(
GetAttachmentType GetAttachment1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetAttachmentAsync Overload List


ExchangeServiceBinding.GetAttachmentAsync Method (GetAttachmentType, Object)

public void GetAttachmentAsync(
GetAttachmentType GetAttachment1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetAttachmentAsync Overload List


ExchangeServiceBinding.GetClientAccessToken Method

public GetClientAccessTokenResponseType GetClientAccessToken(
GetClientAccessTokenType GetClientAccessToken1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetClientAccessTokenAsync Method

Aspose.Email

ExchangeServiceBinding.GetClientAccessTokenAsync Method

Overload List

public void GetClientAccessTokenAsync(GetClientAccessTokenType);

public void GetClientAccessTokenAsync(GetClientAccessTokenType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetClientAccessTokenAsync Method (GetClientAccessTokenType)

public void GetClientAccessTokenAsync(
GetClientAccessTokenType GetClientAccessToken1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetClientAccessTokenAsync Overload List


ExchangeServiceBinding.GetClientAccessTokenAsync Method (GetClientAccessTokenType, Object)

public void GetClientAccessTokenAsync(
GetClientAccessTokenType GetClientAccessToken1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetClientAccessTokenAsync Overload List


ExchangeServiceBinding.GetConversationItems Method

public GetConversationItemsResponseType GetConversationItems(
GetConversationItemsType GetConversationItems1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetConversationItemsAsync Method

Aspose.Email

ExchangeServiceBinding.GetConversationItemsAsync Method

Overload List

public void GetConversationItemsAsync(GetConversationItemsType);

public void GetConversationItemsAsync(GetConversationItemsType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetConversationItemsAsync Method (GetConversationItemsType)

public void GetConversationItemsAsync(
GetConversationItemsType GetConversationItems1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetConversationItemsAsync Overload List


ExchangeServiceBinding.GetConversationItemsAsync Method (GetConversationItemsType, Object)

public void GetConversationItemsAsync(
GetConversationItemsType GetConversationItems1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetConversationItemsAsync Overload List


ExchangeServiceBinding.GetDelegate Method

public GetDelegateResponseMessageType GetDelegate(
GetDelegateType GetDelegate1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetDelegateAsync Method

Aspose.Email

ExchangeServiceBinding.GetDelegateAsync Method

Overload List

public void GetDelegateAsync(GetDelegateType);

public void GetDelegateAsync(GetDelegateType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetDelegateAsync Method (GetDelegateType)

public void GetDelegateAsync(
GetDelegateType GetDelegate1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetDelegateAsync Overload List


ExchangeServiceBinding.GetDelegateAsync Method (GetDelegateType, Object)

public void GetDelegateAsync(
GetDelegateType GetDelegate1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetDelegateAsync Overload List


ExchangeServiceBinding.GetDiscoverySearchConfiguration Method

public GetDiscoverySearchConfigurationResponseMessageType GetDiscoverySearchConfiguration(
GetDiscoverySearchConfigurationType GetDiscoverySearchConfiguration1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetDiscoverySearchConfigurationAsync Method

Aspose.Email

ExchangeServiceBinding.GetDiscoverySearchConfigurationAsync Method

Overload List

public void GetDiscoverySearchConfigurationAsync(GetDiscoverySearchConfigurationType);

public void GetDiscoverySearchConfigurationAsync(GetDiscoverySearchConfigurationType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetDiscoverySearchConfigurationAsync Method (GetDiscoverySearchConfigurationType)

public void GetDiscoverySearchConfigurationAsync(
GetDiscoverySearchConfigurationType GetDiscoverySearchConfiguration1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetDiscoverySearchConfigurationAsync Overload List


ExchangeServiceBinding.GetDiscoverySearchConfigurationAsync Method (GetDiscoverySearchConfigurationType, Object)

public void GetDiscoverySearchConfigurationAsync(
GetDiscoverySearchConfigurationType GetDiscoverySearchConfiguration1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetDiscoverySearchConfigurationAsync Overload List


ExchangeServiceBinding.GetEvents Method

public GetEventsResponseType GetEvents(
GetEventsType GetEvents1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetEventsAsync Method

Aspose.Email

ExchangeServiceBinding.GetEventsAsync Method

Overload List

public void GetEventsAsync(GetEventsType);

public void GetEventsAsync(GetEventsType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetEventsAsync Method (GetEventsType)

public void GetEventsAsync(
GetEventsType GetEvents1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetEventsAsync Overload List


ExchangeServiceBinding.GetEventsAsync Method (GetEventsType, Object)

public void GetEventsAsync(
GetEventsType GetEvents1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetEventsAsync Overload List


ExchangeServiceBinding.GetFolder Method

public GetFolderResponseType GetFolder(
GetFolderType GetFolder1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetFolderAsync Method

Aspose.Email

ExchangeServiceBinding.GetFolderAsync Method

Overload List

public void GetFolderAsync(GetFolderType);

public void GetFolderAsync(GetFolderType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetFolderAsync Method (GetFolderType)

public void GetFolderAsync(
GetFolderType GetFolder1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetFolderAsync Overload List


ExchangeServiceBinding.GetFolderAsync Method (GetFolderType, Object)

public void GetFolderAsync(
GetFolderType GetFolder1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetFolderAsync Overload List


ExchangeServiceBinding.GetHoldOnMailboxes Method

public GetHoldOnMailboxesResponseMessageType GetHoldOnMailboxes(
GetHoldOnMailboxesType GetHoldOnMailboxes1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetHoldOnMailboxesAsync Method

Aspose.Email

ExchangeServiceBinding.GetHoldOnMailboxesAsync Method

Overload List

public void GetHoldOnMailboxesAsync(GetHoldOnMailboxesType);

public void GetHoldOnMailboxesAsync(GetHoldOnMailboxesType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetHoldOnMailboxesAsync Method (GetHoldOnMailboxesType)

public void GetHoldOnMailboxesAsync(
GetHoldOnMailboxesType GetHoldOnMailboxes1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetHoldOnMailboxesAsync Overload List


ExchangeServiceBinding.GetHoldOnMailboxesAsync Method (GetHoldOnMailboxesType, Object)

public void GetHoldOnMailboxesAsync(
GetHoldOnMailboxesType GetHoldOnMailboxes1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetHoldOnMailboxesAsync Overload List


ExchangeServiceBinding.GetImItemList Method

public GetImItemListResponseMessageType GetImItemList(
GetImItemListType GetImItemList1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetImItemListAsync Method

Aspose.Email

ExchangeServiceBinding.GetImItemListAsync Method

Overload List

public void GetImItemListAsync(GetImItemListType);

public void GetImItemListAsync(GetImItemListType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetImItemListAsync Method (GetImItemListType)

public void GetImItemListAsync(
GetImItemListType GetImItemList1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetImItemListAsync Overload List


ExchangeServiceBinding.GetImItemListAsync Method (GetImItemListType, Object)

public void GetImItemListAsync(
GetImItemListType GetImItemList1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetImItemListAsync Overload List


ExchangeServiceBinding.GetImItems Method

public GetImItemsResponseMessageType GetImItems(
GetImItemsType GetImItems1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetImItemsAsync Method

Aspose.Email

ExchangeServiceBinding.GetImItemsAsync Method

Overload List

public void GetImItemsAsync(GetImItemsType);

public void GetImItemsAsync(GetImItemsType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetImItemsAsync Method (GetImItemsType)

public void GetImItemsAsync(
GetImItemsType GetImItems1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetImItemsAsync Overload List


ExchangeServiceBinding.GetImItemsAsync Method (GetImItemsType, Object)

public void GetImItemsAsync(
GetImItemsType GetImItems1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetImItemsAsync Overload List


ExchangeServiceBinding.GetInboxRules Method

public GetInboxRulesResponseType GetInboxRules(
GetInboxRulesRequestType GetInboxRules1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetInboxRulesAsync Method

Aspose.Email

ExchangeServiceBinding.GetInboxRulesAsync Method

Overload List

public void GetInboxRulesAsync(GetInboxRulesRequestType);

public void GetInboxRulesAsync(GetInboxRulesRequestType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetInboxRulesAsync Method (GetInboxRulesRequestType)

public void GetInboxRulesAsync(
GetInboxRulesRequestType GetInboxRules1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetInboxRulesAsync Overload List


ExchangeServiceBinding.GetInboxRulesAsync Method (GetInboxRulesRequestType, Object)

public void GetInboxRulesAsync(
GetInboxRulesRequestType GetInboxRules1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetInboxRulesAsync Overload List


ExchangeServiceBinding.GetItem Method

public GetItemResponseType GetItem(
GetItemType GetItem1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetItemAsync Method

Aspose.Email

ExchangeServiceBinding.GetItemAsync Method

Overload List

public void GetItemAsync(GetItemType);

public void GetItemAsync(GetItemType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetItemAsync Method (GetItemType)

public void GetItemAsync(
GetItemType GetItem1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetItemAsync Overload List


ExchangeServiceBinding.GetItemAsync Method (GetItemType, Object)

public void GetItemAsync(
GetItemType GetItem1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetItemAsync Overload List


ExchangeServiceBinding.GetMailTips Method

public GetMailTipsResponseMessageType GetMailTips(
GetMailTipsType GetMailTips1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetMailTipsAsync Method

Aspose.Email

ExchangeServiceBinding.GetMailTipsAsync Method

Overload List

public void GetMailTipsAsync(GetMailTipsType);

public void GetMailTipsAsync(GetMailTipsType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetMailTipsAsync Method (GetMailTipsType)

public void GetMailTipsAsync(
GetMailTipsType GetMailTips1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetMailTipsAsync Overload List


ExchangeServiceBinding.GetMailTipsAsync Method (GetMailTipsType, Object)

public void GetMailTipsAsync(
GetMailTipsType GetMailTips1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetMailTipsAsync Overload List


ExchangeServiceBinding.GetMessageTrackingReport Method

public GetMessageTrackingReportResponseMessageType GetMessageTrackingReport(
GetMessageTrackingReportRequestType GetMessageTrackingReport1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetMessageTrackingReportAsync Method

Aspose.Email

ExchangeServiceBinding.GetMessageTrackingReportAsync Method

Overload List

public void GetMessageTrackingReportAsync(GetMessageTrackingReportRequestType);

public void GetMessageTrackingReportAsync(GetMessageTrackingReportRequestType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetMessageTrackingReportAsync Method (GetMessageTrackingReportRequestType)

public void GetMessageTrackingReportAsync(
GetMessageTrackingReportRequestType GetMessageTrackingReport1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetMessageTrackingReportAsync Overload List


ExchangeServiceBinding.GetMessageTrackingReportAsync Method (GetMessageTrackingReportRequestType, Object)

public void GetMessageTrackingReportAsync(
GetMessageTrackingReportRequestType GetMessageTrackingReport1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetMessageTrackingReportAsync Overload List


ExchangeServiceBinding.GetNonIndexableItemDetails Method

public GetNonIndexableItemDetailsResponseMessageType GetNonIndexableItemDetails(
GetNonIndexableItemDetailsType GetNonIndexableItemDetails1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetNonIndexableItemDetailsAsync Method

Aspose.Email

ExchangeServiceBinding.GetNonIndexableItemDetailsAsync Method

Overload List

public void GetNonIndexableItemDetailsAsync(GetNonIndexableItemDetailsType);

public void GetNonIndexableItemDetailsAsync(GetNonIndexableItemDetailsType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetNonIndexableItemDetailsAsync Method (GetNonIndexableItemDetailsType)

public void GetNonIndexableItemDetailsAsync(
GetNonIndexableItemDetailsType GetNonIndexableItemDetails1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetNonIndexableItemDetailsAsync Overload List


ExchangeServiceBinding.GetNonIndexableItemDetailsAsync Method (GetNonIndexableItemDetailsType, Object)

public void GetNonIndexableItemDetailsAsync(
GetNonIndexableItemDetailsType GetNonIndexableItemDetails1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetNonIndexableItemDetailsAsync Overload List


ExchangeServiceBinding.GetNonIndexableItemStatistics Method

public GetNonIndexableItemStatisticsResponseMessageType GetNonIndexableItemStatistics(
GetNonIndexableItemStatisticsType GetNonIndexableItemStatistics1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetNonIndexableItemStatisticsAsync Method

Aspose.Email

ExchangeServiceBinding.GetNonIndexableItemStatisticsAsync Method

Overload List

public void GetNonIndexableItemStatisticsAsync(GetNonIndexableItemStatisticsType);

public void GetNonIndexableItemStatisticsAsync(GetNonIndexableItemStatisticsType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetNonIndexableItemStatisticsAsync Method (GetNonIndexableItemStatisticsType)

public void GetNonIndexableItemStatisticsAsync(
GetNonIndexableItemStatisticsType GetNonIndexableItemStatistics1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetNonIndexableItemStatisticsAsync Overload List


ExchangeServiceBinding.GetNonIndexableItemStatisticsAsync Method (GetNonIndexableItemStatisticsType, Object)

public void GetNonIndexableItemStatisticsAsync(
GetNonIndexableItemStatisticsType GetNonIndexableItemStatistics1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetNonIndexableItemStatisticsAsync Overload List


ExchangeServiceBinding.GetPasswordExpirationDate Method

public GetPasswordExpirationDateResponseMessageType GetPasswordExpirationDate(
GetPasswordExpirationDateType GetPasswordExpirationDate1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetPasswordExpirationDateAsync Method

Aspose.Email

ExchangeServiceBinding.GetPasswordExpirationDateAsync Method

Overload List

public void GetPasswordExpirationDateAsync(GetPasswordExpirationDateType);

public void GetPasswordExpirationDateAsync(GetPasswordExpirationDateType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetPasswordExpirationDateAsync Method (GetPasswordExpirationDateType)

public void GetPasswordExpirationDateAsync(
GetPasswordExpirationDateType GetPasswordExpirationDate1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetPasswordExpirationDateAsync Overload List


ExchangeServiceBinding.GetPasswordExpirationDateAsync Method (GetPasswordExpirationDateType, Object)

public void GetPasswordExpirationDateAsync(
GetPasswordExpirationDateType GetPasswordExpirationDate1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetPasswordExpirationDateAsync Overload List


ExchangeServiceBinding.GetPersona Method

public GetPersonaResponseMessageType GetPersona(
GetPersonaType GetPersona1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetPersonaAsync Method

Aspose.Email

ExchangeServiceBinding.GetPersonaAsync Method

Overload List

public void GetPersonaAsync(GetPersonaType);

public void GetPersonaAsync(GetPersonaType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetPersonaAsync Method (GetPersonaType)

public void GetPersonaAsync(
GetPersonaType GetPersona1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetPersonaAsync Overload List


ExchangeServiceBinding.GetPersonaAsync Method (GetPersonaType, Object)

public void GetPersonaAsync(
GetPersonaType GetPersona1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetPersonaAsync Overload List


ExchangeServiceBinding.GetPhoneCallInformation Method

public GetPhoneCallInformationResponseMessageType GetPhoneCallInformation(
GetPhoneCallInformationType GetPhoneCallInformation1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetPhoneCallInformationAsync Method

Aspose.Email

ExchangeServiceBinding.GetPhoneCallInformationAsync Method

Overload List

public void GetPhoneCallInformationAsync(GetPhoneCallInformationType);

public void GetPhoneCallInformationAsync(GetPhoneCallInformationType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetPhoneCallInformationAsync Method (GetPhoneCallInformationType)

public void GetPhoneCallInformationAsync(
GetPhoneCallInformationType GetPhoneCallInformation1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetPhoneCallInformationAsync Overload List


ExchangeServiceBinding.GetPhoneCallInformationAsync Method (GetPhoneCallInformationType, Object)

public void GetPhoneCallInformationAsync(
GetPhoneCallInformationType GetPhoneCallInformation1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetPhoneCallInformationAsync Overload List


ExchangeServiceBinding.GetReaderForMessage Method

protected override XmlReader GetReaderForMessage(
SoapClientMessage message,
int bufferSize
);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetRoomLists Method

public GetRoomListsResponseMessageType GetRoomLists(
GetRoomListsType GetRoomLists1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetRoomListsAsync Method

Aspose.Email

ExchangeServiceBinding.GetRoomListsAsync Method

Overload List

public void GetRoomListsAsync(GetRoomListsType);

public void GetRoomListsAsync(GetRoomListsType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetRoomListsAsync Method (GetRoomListsType)

public void GetRoomListsAsync(
GetRoomListsType GetRoomLists1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetRoomListsAsync Overload List


ExchangeServiceBinding.GetRoomListsAsync Method (GetRoomListsType, Object)

public void GetRoomListsAsync(
GetRoomListsType GetRoomLists1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetRoomListsAsync Overload List


ExchangeServiceBinding.GetRooms Method

public GetRoomsResponseMessageType GetRooms(
GetRoomsType GetRooms1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetRoomsAsync Method

Aspose.Email

ExchangeServiceBinding.GetRoomsAsync Method

Overload List

public void GetRoomsAsync(GetRoomsType);

public void GetRoomsAsync(GetRoomsType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetRoomsAsync Method (GetRoomsType)

public void GetRoomsAsync(
GetRoomsType GetRooms1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetRoomsAsync Overload List


ExchangeServiceBinding.GetRoomsAsync Method (GetRoomsType, Object)

public void GetRoomsAsync(
GetRoomsType GetRooms1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetRoomsAsync Overload List


ExchangeServiceBinding.GetSearchableMailboxes Method

public GetSearchableMailboxesResponseMessageType GetSearchableMailboxes(
GetSearchableMailboxesType GetSearchableMailboxes1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetSearchableMailboxesAsync Method

Aspose.Email

ExchangeServiceBinding.GetSearchableMailboxesAsync Method

Overload List

public void GetSearchableMailboxesAsync(GetSearchableMailboxesType);

public void GetSearchableMailboxesAsync(GetSearchableMailboxesType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetSearchableMailboxesAsync Method (GetSearchableMailboxesType)

public void GetSearchableMailboxesAsync(
GetSearchableMailboxesType GetSearchableMailboxes1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetSearchableMailboxesAsync Overload List


ExchangeServiceBinding.GetSearchableMailboxesAsync Method (GetSearchableMailboxesType, Object)

public void GetSearchableMailboxesAsync(
GetSearchableMailboxesType GetSearchableMailboxes1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetSearchableMailboxesAsync Overload List


ExchangeServiceBinding.GetServerTimeZones Method

public GetServerTimeZonesResponseType GetServerTimeZones(
GetServerTimeZonesType GetServerTimeZones1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetServerTimeZonesAsync Method

Aspose.Email

ExchangeServiceBinding.GetServerTimeZonesAsync Method

Overload List

public void GetServerTimeZonesAsync(GetServerTimeZonesType);

public void GetServerTimeZonesAsync(GetServerTimeZonesType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetServerTimeZonesAsync Method (GetServerTimeZonesType)

public void GetServerTimeZonesAsync(
GetServerTimeZonesType GetServerTimeZones1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetServerTimeZonesAsync Overload List


ExchangeServiceBinding.GetServerTimeZonesAsync Method (GetServerTimeZonesType, Object)

public void GetServerTimeZonesAsync(
GetServerTimeZonesType GetServerTimeZones1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetServerTimeZonesAsync Overload List


ExchangeServiceBinding.GetServiceConfiguration Method

public GetServiceConfigurationResponseMessageType GetServiceConfiguration(
GetServiceConfigurationType GetServiceConfiguration1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetServiceConfigurationAsync Method

Aspose.Email

ExchangeServiceBinding.GetServiceConfigurationAsync Method

Overload List

public void GetServiceConfigurationAsync(GetServiceConfigurationType);

public void GetServiceConfigurationAsync(GetServiceConfigurationType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetServiceConfigurationAsync Method (GetServiceConfigurationType)

public void GetServiceConfigurationAsync(
GetServiceConfigurationType GetServiceConfiguration1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetServiceConfigurationAsync Overload List


ExchangeServiceBinding.GetServiceConfigurationAsync Method (GetServiceConfigurationType, Object)

public void GetServiceConfigurationAsync(
GetServiceConfigurationType GetServiceConfiguration1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetServiceConfigurationAsync Overload List


ExchangeServiceBinding.GetSharingFolder Method

public GetSharingFolderResponseMessageType GetSharingFolder(
GetSharingFolderType GetSharingFolder1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetSharingFolderAsync Method

Aspose.Email

ExchangeServiceBinding.GetSharingFolderAsync Method

Overload List

public void GetSharingFolderAsync(GetSharingFolderType);

public void GetSharingFolderAsync(GetSharingFolderType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetSharingFolderAsync Method (GetSharingFolderType)

public void GetSharingFolderAsync(
GetSharingFolderType GetSharingFolder1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetSharingFolderAsync Overload List


ExchangeServiceBinding.GetSharingFolderAsync Method (GetSharingFolderType, Object)

public void GetSharingFolderAsync(
GetSharingFolderType GetSharingFolder1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetSharingFolderAsync Overload List


ExchangeServiceBinding.GetSharingMetadata Method

public GetSharingMetadataResponseMessageType GetSharingMetadata(
GetSharingMetadataType GetSharingMetadata1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetSharingMetadataAsync Method

Aspose.Email

ExchangeServiceBinding.GetSharingMetadataAsync Method

Overload List

public void GetSharingMetadataAsync(GetSharingMetadataType);

public void GetSharingMetadataAsync(GetSharingMetadataType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetSharingMetadataAsync Method (GetSharingMetadataType)

public void GetSharingMetadataAsync(
GetSharingMetadataType GetSharingMetadata1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetSharingMetadataAsync Overload List


ExchangeServiceBinding.GetSharingMetadataAsync Method (GetSharingMetadataType, Object)

public void GetSharingMetadataAsync(
GetSharingMetadataType GetSharingMetadata1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetSharingMetadataAsync Overload List


ExchangeServiceBinding.GetStreamingEvents Method

public GetStreamingEventsResponseType GetStreamingEvents(
GetStreamingEventsType GetStreamingEvents1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetStreamingEventsAsync Method

Aspose.Email

ExchangeServiceBinding.GetStreamingEventsAsync Method

Overload List

public void GetStreamingEventsAsync(GetStreamingEventsType);

public void GetStreamingEventsAsync(GetStreamingEventsType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetStreamingEventsAsync Method (GetStreamingEventsType)

public void GetStreamingEventsAsync(
GetStreamingEventsType GetStreamingEvents1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetStreamingEventsAsync Overload List


ExchangeServiceBinding.GetStreamingEventsAsync Method (GetStreamingEventsType, Object)

public void GetStreamingEventsAsync(
GetStreamingEventsType GetStreamingEvents1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetStreamingEventsAsync Overload List


ExchangeServiceBinding.GetUserAvailability Method

public GetUserAvailabilityResponseType GetUserAvailability(
GetUserAvailabilityRequestType GetUserAvailabilityRequest
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserAvailabilityAsync Method

Aspose.Email

ExchangeServiceBinding.GetUserAvailabilityAsync Method

Overload List

public void GetUserAvailabilityAsync(GetUserAvailabilityRequestType);

public void GetUserAvailabilityAsync(GetUserAvailabilityRequestType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetUserAvailabilityAsync Method (GetUserAvailabilityRequestType)

public void GetUserAvailabilityAsync(
GetUserAvailabilityRequestType GetUserAvailabilityRequest
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetUserAvailabilityAsync Overload List


ExchangeServiceBinding.GetUserAvailabilityAsync Method (GetUserAvailabilityRequestType, Object)

public void GetUserAvailabilityAsync(
GetUserAvailabilityRequestType GetUserAvailabilityRequest,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetUserAvailabilityAsync Overload List


ExchangeServiceBinding.GetUserConfiguration Method

public GetUserConfigurationResponseType GetUserConfiguration(
GetUserConfigurationType GetUserConfiguration1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserConfigurationAsync Method

Aspose.Email

ExchangeServiceBinding.GetUserConfigurationAsync Method

Overload List

public void GetUserConfigurationAsync(GetUserConfigurationType);

public void GetUserConfigurationAsync(GetUserConfigurationType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetUserConfigurationAsync Method (GetUserConfigurationType)

public void GetUserConfigurationAsync(
GetUserConfigurationType GetUserConfiguration1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetUserConfigurationAsync Overload List


ExchangeServiceBinding.GetUserConfigurationAsync Method (GetUserConfigurationType, Object)

public void GetUserConfigurationAsync(
GetUserConfigurationType GetUserConfiguration1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetUserConfigurationAsync Overload List


ExchangeServiceBinding.GetUserOofSettings Method

public GetUserOofSettingsResponse GetUserOofSettings(
GetUserOofSettingsRequest GetUserOofSettingsRequest
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserOofSettingsAsync Method

Aspose.Email

ExchangeServiceBinding.GetUserOofSettingsAsync Method

Overload List

public void GetUserOofSettingsAsync(GetUserOofSettingsRequest);

public void GetUserOofSettingsAsync(GetUserOofSettingsRequest,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetUserOofSettingsAsync Method (GetUserOofSettingsRequest)

public void GetUserOofSettingsAsync(
GetUserOofSettingsRequest GetUserOofSettingsRequest
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetUserOofSettingsAsync Overload List


ExchangeServiceBinding.GetUserOofSettingsAsync Method (GetUserOofSettingsRequest, Object)

public void GetUserOofSettingsAsync(
GetUserOofSettingsRequest GetUserOofSettingsRequest,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetUserOofSettingsAsync Overload List


ExchangeServiceBinding.GetUserPhoto Method

public GetUserPhotoResponseMessageType GetUserPhoto(
GetUserPhotoType GetUserPhoto1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserPhotoAsync Method

Aspose.Email

ExchangeServiceBinding.GetUserPhotoAsync Method

Overload List

public void GetUserPhotoAsync(GetUserPhotoType);

public void GetUserPhotoAsync(GetUserPhotoType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetUserPhotoAsync Method (GetUserPhotoType)

public void GetUserPhotoAsync(
GetUserPhotoType GetUserPhoto1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetUserPhotoAsync Overload List


ExchangeServiceBinding.GetUserPhotoAsync Method (GetUserPhotoType, Object)

public void GetUserPhotoAsync(
GetUserPhotoType GetUserPhoto1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetUserPhotoAsync Overload List


ExchangeServiceBinding.GetUserRetentionPolicyTags Method

public GetUserRetentionPolicyTagsResponseMessageType GetUserRetentionPolicyTags(
GetUserRetentionPolicyTagsType GetUserRetentionPolicyTags1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserRetentionPolicyTagsAsync Method

Aspose.Email

ExchangeServiceBinding.GetUserRetentionPolicyTagsAsync Method

Overload List

public void GetUserRetentionPolicyTagsAsync(GetUserRetentionPolicyTagsType);

public void GetUserRetentionPolicyTagsAsync(GetUserRetentionPolicyTagsType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetUserRetentionPolicyTagsAsync Method (GetUserRetentionPolicyTagsType)

public void GetUserRetentionPolicyTagsAsync(
GetUserRetentionPolicyTagsType GetUserRetentionPolicyTags1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetUserRetentionPolicyTagsAsync Overload List


ExchangeServiceBinding.GetUserRetentionPolicyTagsAsync Method (GetUserRetentionPolicyTagsType, Object)

public void GetUserRetentionPolicyTagsAsync(
GetUserRetentionPolicyTagsType GetUserRetentionPolicyTags1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.GetUserRetentionPolicyTagsAsync Overload List


ExchangeServiceBinding.InstallApp Method

public InstallAppResponseType InstallApp(
InstallAppType InstallApp1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InstallAppAsync Method

Aspose.Email

ExchangeServiceBinding.InstallAppAsync Method

Overload List

public void InstallAppAsync(InstallAppType);

public void InstallAppAsync(InstallAppType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.InstallAppAsync Method (InstallAppType)

public void InstallAppAsync(
InstallAppType InstallApp1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.InstallAppAsync Overload List


ExchangeServiceBinding.InstallAppAsync Method (InstallAppType, Object)

public void InstallAppAsync(
InstallAppType InstallApp1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.InstallAppAsync Overload List


ExchangeServiceBinding.MarkAllItemsAsRead Method

public MarkAllItemsAsReadResponseType MarkAllItemsAsRead(
MarkAllItemsAsReadType MarkAllItemsAsRead1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MarkAllItemsAsReadAsync Method

Aspose.Email

ExchangeServiceBinding.MarkAllItemsAsReadAsync Method

Overload List

public void MarkAllItemsAsReadAsync(MarkAllItemsAsReadType);

public void MarkAllItemsAsReadAsync(MarkAllItemsAsReadType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.MarkAllItemsAsReadAsync Method (MarkAllItemsAsReadType)

public void MarkAllItemsAsReadAsync(
MarkAllItemsAsReadType MarkAllItemsAsRead1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.MarkAllItemsAsReadAsync Overload List


ExchangeServiceBinding.MarkAllItemsAsReadAsync Method (MarkAllItemsAsReadType, Object)

public void MarkAllItemsAsReadAsync(
MarkAllItemsAsReadType MarkAllItemsAsRead1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.MarkAllItemsAsReadAsync Overload List


ExchangeServiceBinding.MarkAsJunk Method

public MarkAsJunkResponseType MarkAsJunk(
MarkAsJunkType MarkAsJunk1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MarkAsJunkAsync Method

Aspose.Email

ExchangeServiceBinding.MarkAsJunkAsync Method

Overload List

public void MarkAsJunkAsync(MarkAsJunkType);

public void MarkAsJunkAsync(MarkAsJunkType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.MarkAsJunkAsync Method (MarkAsJunkType)

public void MarkAsJunkAsync(
MarkAsJunkType MarkAsJunk1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.MarkAsJunkAsync Overload List


ExchangeServiceBinding.MarkAsJunkAsync Method (MarkAsJunkType, Object)

public void MarkAsJunkAsync(
MarkAsJunkType MarkAsJunk1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.MarkAsJunkAsync Overload List


ExchangeServiceBinding.MoveFolder Method

public MoveFolderResponseType MoveFolder(
MoveFolderType MoveFolder1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MoveFolderAsync Method

Aspose.Email

ExchangeServiceBinding.MoveFolderAsync Method

Overload List

public void MoveFolderAsync(MoveFolderType);

public void MoveFolderAsync(MoveFolderType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.MoveFolderAsync Method (MoveFolderType)

public void MoveFolderAsync(
MoveFolderType MoveFolder1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.MoveFolderAsync Overload List


ExchangeServiceBinding.MoveFolderAsync Method (MoveFolderType, Object)

public void MoveFolderAsync(
MoveFolderType MoveFolder1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.MoveFolderAsync Overload List


ExchangeServiceBinding.MoveItem Method

public MoveItemResponseType MoveItem(
MoveItemType MoveItem1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MoveItemAsync Method

Aspose.Email

ExchangeServiceBinding.MoveItemAsync Method

Overload List

public void MoveItemAsync(MoveItemType);

public void MoveItemAsync(MoveItemType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.MoveItemAsync Method (MoveItemType)

public void MoveItemAsync(
MoveItemType MoveItem1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.MoveItemAsync Overload List


ExchangeServiceBinding.MoveItemAsync Method (MoveItemType, Object)

public void MoveItemAsync(
MoveItemType MoveItem1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.MoveItemAsync Overload List


ExchangeServiceBinding.PlayOnPhone Method

public PlayOnPhoneResponseMessageType PlayOnPhone(
PlayOnPhoneType PlayOnPhone1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PlayOnPhoneAsync Method

Aspose.Email

ExchangeServiceBinding.PlayOnPhoneAsync Method

Overload List

public void PlayOnPhoneAsync(PlayOnPhoneType);

public void PlayOnPhoneAsync(PlayOnPhoneType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.PlayOnPhoneAsync Method (PlayOnPhoneType)

public void PlayOnPhoneAsync(
PlayOnPhoneType PlayOnPhone1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.PlayOnPhoneAsync Overload List


ExchangeServiceBinding.PlayOnPhoneAsync Method (PlayOnPhoneType, Object)

public void PlayOnPhoneAsync(
PlayOnPhoneType PlayOnPhone1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.PlayOnPhoneAsync Overload List


ExchangeServiceBinding.RefreshSharingFolder Method

public RefreshSharingFolderResponseMessageType RefreshSharingFolder(
RefreshSharingFolderType RefreshSharingFolder1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RefreshSharingFolderAsync Method

Aspose.Email

ExchangeServiceBinding.RefreshSharingFolderAsync Method

Overload List

public void RefreshSharingFolderAsync(RefreshSharingFolderType);

public void RefreshSharingFolderAsync(RefreshSharingFolderType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.RefreshSharingFolderAsync Method (RefreshSharingFolderType)

public void RefreshSharingFolderAsync(
RefreshSharingFolderType RefreshSharingFolder1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.RefreshSharingFolderAsync Overload List


ExchangeServiceBinding.RefreshSharingFolderAsync Method (RefreshSharingFolderType, Object)

public void RefreshSharingFolderAsync(
RefreshSharingFolderType RefreshSharingFolder1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.RefreshSharingFolderAsync Overload List


ExchangeServiceBinding.RemoveContactFromImList Method

public RemoveContactFromImListResponseMessageType RemoveContactFromImList(
RemoveContactFromImListType RemoveContactFromImList1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveContactFromImListAsync Method

Aspose.Email

ExchangeServiceBinding.RemoveContactFromImListAsync Method

Overload List

public void RemoveContactFromImListAsync(RemoveContactFromImListType);

public void RemoveContactFromImListAsync(RemoveContactFromImListType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.RemoveContactFromImListAsync Method (RemoveContactFromImListType)

public void RemoveContactFromImListAsync(
RemoveContactFromImListType RemoveContactFromImList1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.RemoveContactFromImListAsync Overload List


ExchangeServiceBinding.RemoveContactFromImListAsync Method (RemoveContactFromImListType, Object)

public void RemoveContactFromImListAsync(
RemoveContactFromImListType RemoveContactFromImList1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.RemoveContactFromImListAsync Overload List


ExchangeServiceBinding.RemoveDelegate Method

public RemoveDelegateResponseMessageType RemoveDelegate(
RemoveDelegateType RemoveDelegate1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveDelegateAsync Method

Aspose.Email

ExchangeServiceBinding.RemoveDelegateAsync Method

Overload List

public void RemoveDelegateAsync(RemoveDelegateType);

public void RemoveDelegateAsync(RemoveDelegateType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.RemoveDelegateAsync Method (RemoveDelegateType)

public void RemoveDelegateAsync(
RemoveDelegateType RemoveDelegate1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.RemoveDelegateAsync Overload List


ExchangeServiceBinding.RemoveDelegateAsync Method (RemoveDelegateType, Object)

public void RemoveDelegateAsync(
RemoveDelegateType RemoveDelegate1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.RemoveDelegateAsync Overload List


ExchangeServiceBinding.RemoveDistributionGroupFromImList Method

public RemoveDistributionGroupFromImListResponseMessageType RemoveDistributionGroupFromImList(
RemoveDistributionGroupFromImListType RemoveDistributionGroupFromImList1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveDistributionGroupFromImListAsync Method

Aspose.Email

ExchangeServiceBinding.RemoveDistributionGroupFromImListAsync Method

Overload List

public void RemoveDistributionGroupFromImListAsync(RemoveDistributionGroupFromImListType);

public void RemoveDistributionGroupFromImListAsync(RemoveDistributionGroupFromImListType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.RemoveDistributionGroupFromImListAsync Method (RemoveDistributionGroupFromImListType)

public void RemoveDistributionGroupFromImListAsync(
RemoveDistributionGroupFromImListType RemoveDistributionGroupFromImList1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.RemoveDistributionGroupFromImListAsync Overload List


ExchangeServiceBinding.RemoveDistributionGroupFromImListAsync Method (RemoveDistributionGroupFromImListType, Object)

public void RemoveDistributionGroupFromImListAsync(
RemoveDistributionGroupFromImListType RemoveDistributionGroupFromImList1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.RemoveDistributionGroupFromImListAsync Overload List


ExchangeServiceBinding.RemoveImContactFromGroup Method

public RemoveImContactFromGroupResponseMessageType RemoveImContactFromGroup(
RemoveImContactFromGroupType RemoveImContactFromGroup1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveImContactFromGroupAsync Method

Aspose.Email

ExchangeServiceBinding.RemoveImContactFromGroupAsync Method

Overload List

public void RemoveImContactFromGroupAsync(RemoveImContactFromGroupType);

public void RemoveImContactFromGroupAsync(RemoveImContactFromGroupType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.RemoveImContactFromGroupAsync Method (RemoveImContactFromGroupType)

public void RemoveImContactFromGroupAsync(
RemoveImContactFromGroupType RemoveImContactFromGroup1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.RemoveImContactFromGroupAsync Overload List


ExchangeServiceBinding.RemoveImContactFromGroupAsync Method (RemoveImContactFromGroupType, Object)

public void RemoveImContactFromGroupAsync(
RemoveImContactFromGroupType RemoveImContactFromGroup1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.RemoveImContactFromGroupAsync Overload List


ExchangeServiceBinding.RemoveImGroup Method

public RemoveImGroupResponseMessageType RemoveImGroup(
RemoveImGroupType RemoveImGroup1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveImGroupAsync Method

Aspose.Email

ExchangeServiceBinding.RemoveImGroupAsync Method

Overload List

public void RemoveImGroupAsync(RemoveImGroupType);

public void RemoveImGroupAsync(RemoveImGroupType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.RemoveImGroupAsync Method (RemoveImGroupType)

public void RemoveImGroupAsync(
RemoveImGroupType RemoveImGroup1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.RemoveImGroupAsync Overload List


ExchangeServiceBinding.RemoveImGroupAsync Method (RemoveImGroupType, Object)

public void RemoveImGroupAsync(
RemoveImGroupType RemoveImGroup1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.RemoveImGroupAsync Overload List


ExchangeServiceBinding.ResolveNames Method

public ResolveNamesResponseType ResolveNames(
ResolveNamesType ResolveNames1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResolveNamesAsync Method

Aspose.Email

ExchangeServiceBinding.ResolveNamesAsync Method

Overload List

public void ResolveNamesAsync(ResolveNamesType);

public void ResolveNamesAsync(ResolveNamesType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.ResolveNamesAsync Method (ResolveNamesType)

public void ResolveNamesAsync(
ResolveNamesType ResolveNames1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.ResolveNamesAsync Overload List


ExchangeServiceBinding.ResolveNamesAsync Method (ResolveNamesType, Object)

public void ResolveNamesAsync(
ResolveNamesType ResolveNames1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.ResolveNamesAsync Overload List


ExchangeServiceBinding.SearchMailboxes Method

public SearchMailboxesResponseType SearchMailboxes(
SearchMailboxesType SearchMailboxes1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchMailboxesAsync Method

Aspose.Email

ExchangeServiceBinding.SearchMailboxesAsync Method

Overload List

public void SearchMailboxesAsync(SearchMailboxesType);

public void SearchMailboxesAsync(SearchMailboxesType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.SearchMailboxesAsync Method (SearchMailboxesType)

public void SearchMailboxesAsync(
SearchMailboxesType SearchMailboxes1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.SearchMailboxesAsync Overload List


ExchangeServiceBinding.SearchMailboxesAsync Method (SearchMailboxesType, Object)

public void SearchMailboxesAsync(
SearchMailboxesType SearchMailboxes1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.SearchMailboxesAsync Overload List


ExchangeServiceBinding.SendItem Method

public SendItemResponseType SendItem(
SendItemType SendItem1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SendItemAsync Method

Aspose.Email

ExchangeServiceBinding.SendItemAsync Method

Overload List

public void SendItemAsync(SendItemType);

public void SendItemAsync(SendItemType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.SendItemAsync Method (SendItemType)

public void SendItemAsync(
SendItemType SendItem1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.SendItemAsync Overload List


ExchangeServiceBinding.SendItemAsync Method (SendItemType, Object)

public void SendItemAsync(
SendItemType SendItem1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.SendItemAsync Overload List


ExchangeServiceBinding.SetHoldOnMailboxes Method

public SetHoldOnMailboxesResponseMessageType SetHoldOnMailboxes(
SetHoldOnMailboxesType SetHoldOnMailboxes1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetHoldOnMailboxesAsync Method

Aspose.Email

ExchangeServiceBinding.SetHoldOnMailboxesAsync Method

Overload List

public void SetHoldOnMailboxesAsync(SetHoldOnMailboxesType);

public void SetHoldOnMailboxesAsync(SetHoldOnMailboxesType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.SetHoldOnMailboxesAsync Method (SetHoldOnMailboxesType)

public void SetHoldOnMailboxesAsync(
SetHoldOnMailboxesType SetHoldOnMailboxes1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.SetHoldOnMailboxesAsync Overload List


ExchangeServiceBinding.SetHoldOnMailboxesAsync Method (SetHoldOnMailboxesType, Object)

public void SetHoldOnMailboxesAsync(
SetHoldOnMailboxesType SetHoldOnMailboxes1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.SetHoldOnMailboxesAsync Overload List


ExchangeServiceBinding.SetImGroup Method

public SetImGroupResponseMessageType SetImGroup(
SetImGroupType SetImGroup1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetImGroupAsync Method

Aspose.Email

ExchangeServiceBinding.SetImGroupAsync Method

Overload List

public void SetImGroupAsync(SetImGroupType);

public void SetImGroupAsync(SetImGroupType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.SetImGroupAsync Method (SetImGroupType)

public void SetImGroupAsync(
SetImGroupType SetImGroup1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.SetImGroupAsync Overload List


ExchangeServiceBinding.SetImGroupAsync Method (SetImGroupType, Object)

public void SetImGroupAsync(
SetImGroupType SetImGroup1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.SetImGroupAsync Overload List


ExchangeServiceBinding.SetImListMigrationCompleted Method

public SetImListMigrationCompletedResponseMessageType SetImListMigrationCompleted(
SetImListMigrationCompletedType SetImListMigrationCompleted1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetImListMigrationCompletedAsync Method

Aspose.Email

ExchangeServiceBinding.SetImListMigrationCompletedAsync Method

Overload List

public void SetImListMigrationCompletedAsync(SetImListMigrationCompletedType);

public void SetImListMigrationCompletedAsync(SetImListMigrationCompletedType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.SetImListMigrationCompletedAsync Method (SetImListMigrationCompletedType)

public void SetImListMigrationCompletedAsync(
SetImListMigrationCompletedType SetImListMigrationCompleted1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.SetImListMigrationCompletedAsync Overload List


ExchangeServiceBinding.SetImListMigrationCompletedAsync Method (SetImListMigrationCompletedType, Object)

public void SetImListMigrationCompletedAsync(
SetImListMigrationCompletedType SetImListMigrationCompleted1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.SetImListMigrationCompletedAsync Overload List


ExchangeServiceBinding.SetTeamMailbox Method

public SetTeamMailboxResponseMessageType SetTeamMailbox(
SetTeamMailboxRequestType SetTeamMailbox1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetTeamMailboxAsync Method

Aspose.Email

ExchangeServiceBinding.SetTeamMailboxAsync Method

Overload List

public void SetTeamMailboxAsync(SetTeamMailboxRequestType);

public void SetTeamMailboxAsync(SetTeamMailboxRequestType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.SetTeamMailboxAsync Method (SetTeamMailboxRequestType)

public void SetTeamMailboxAsync(
SetTeamMailboxRequestType SetTeamMailbox1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.SetTeamMailboxAsync Overload List


ExchangeServiceBinding.SetTeamMailboxAsync Method (SetTeamMailboxRequestType, Object)

public void SetTeamMailboxAsync(
SetTeamMailboxRequestType SetTeamMailbox1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.SetTeamMailboxAsync Overload List


ExchangeServiceBinding.SetUserOofSettings Method

public SetUserOofSettingsResponse SetUserOofSettings(
SetUserOofSettingsRequest SetUserOofSettingsRequest
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetUserOofSettingsAsync Method

Aspose.Email

ExchangeServiceBinding.SetUserOofSettingsAsync Method

Overload List

public void SetUserOofSettingsAsync(SetUserOofSettingsRequest);

public void SetUserOofSettingsAsync(SetUserOofSettingsRequest,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.SetUserOofSettingsAsync Method (SetUserOofSettingsRequest)

public void SetUserOofSettingsAsync(
SetUserOofSettingsRequest SetUserOofSettingsRequest
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.SetUserOofSettingsAsync Overload List


ExchangeServiceBinding.SetUserOofSettingsAsync Method (SetUserOofSettingsRequest, Object)

public void SetUserOofSettingsAsync(
SetUserOofSettingsRequest SetUserOofSettingsRequest,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.SetUserOofSettingsAsync Overload List


ExchangeServiceBinding.Subscribe Method

public SubscribeResponseType Subscribe(
SubscribeType Subscribe1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SubscribeAsync Method

Aspose.Email

ExchangeServiceBinding.SubscribeAsync Method

Overload List

public void SubscribeAsync(SubscribeType);

public void SubscribeAsync(SubscribeType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.SubscribeAsync Method (SubscribeType)

public void SubscribeAsync(
SubscribeType Subscribe1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.SubscribeAsync Overload List


ExchangeServiceBinding.SubscribeAsync Method (SubscribeType, Object)

public void SubscribeAsync(
SubscribeType Subscribe1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.SubscribeAsync Overload List


ExchangeServiceBinding.SyncFolderHierarchy Method

public SyncFolderHierarchyResponseType SyncFolderHierarchy(
SyncFolderHierarchyType SyncFolderHierarchy1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderHierarchyAsync Method

Aspose.Email

ExchangeServiceBinding.SyncFolderHierarchyAsync Method

Overload List

public void SyncFolderHierarchyAsync(SyncFolderHierarchyType);

public void SyncFolderHierarchyAsync(SyncFolderHierarchyType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.SyncFolderHierarchyAsync Method (SyncFolderHierarchyType)

public void SyncFolderHierarchyAsync(
SyncFolderHierarchyType SyncFolderHierarchy1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.SyncFolderHierarchyAsync Overload List


ExchangeServiceBinding.SyncFolderHierarchyAsync Method (SyncFolderHierarchyType, Object)

public void SyncFolderHierarchyAsync(
SyncFolderHierarchyType SyncFolderHierarchy1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.SyncFolderHierarchyAsync Overload List


ExchangeServiceBinding.SyncFolderItems Method

public SyncFolderItemsResponseType SyncFolderItems(
SyncFolderItemsType SyncFolderItems1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderItemsAsync Method

Aspose.Email

ExchangeServiceBinding.SyncFolderItemsAsync Method

Overload List

public void SyncFolderItemsAsync(SyncFolderItemsType);

public void SyncFolderItemsAsync(SyncFolderItemsType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.SyncFolderItemsAsync Method (SyncFolderItemsType)

public void SyncFolderItemsAsync(
SyncFolderItemsType SyncFolderItems1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.SyncFolderItemsAsync Overload List


ExchangeServiceBinding.SyncFolderItemsAsync Method (SyncFolderItemsType, Object)

public void SyncFolderItemsAsync(
SyncFolderItemsType SyncFolderItems1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.SyncFolderItemsAsync Overload List


ExchangeServiceBinding.UninstallApp Method

public UninstallAppResponseType UninstallApp(
UninstallAppType UninstallApp1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UninstallAppAsync Method

Aspose.Email

ExchangeServiceBinding.UninstallAppAsync Method

Overload List

public void UninstallAppAsync(UninstallAppType);

public void UninstallAppAsync(UninstallAppType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.UninstallAppAsync Method (UninstallAppType)

public void UninstallAppAsync(
UninstallAppType UninstallApp1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.UninstallAppAsync Overload List


ExchangeServiceBinding.UninstallAppAsync Method (UninstallAppType, Object)

public void UninstallAppAsync(
UninstallAppType UninstallApp1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.UninstallAppAsync Overload List


ExchangeServiceBinding.UnpinTeamMailbox Method

public UnpinTeamMailboxResponseMessageType UnpinTeamMailbox(
UnpinTeamMailboxRequestType UnpinTeamMailbox1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UnpinTeamMailboxAsync Method

Aspose.Email

ExchangeServiceBinding.UnpinTeamMailboxAsync Method

Overload List

public void UnpinTeamMailboxAsync(UnpinTeamMailboxRequestType);

public void UnpinTeamMailboxAsync(UnpinTeamMailboxRequestType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.UnpinTeamMailboxAsync Method (UnpinTeamMailboxRequestType)

public void UnpinTeamMailboxAsync(
UnpinTeamMailboxRequestType UnpinTeamMailbox1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.UnpinTeamMailboxAsync Overload List


ExchangeServiceBinding.UnpinTeamMailboxAsync Method (UnpinTeamMailboxRequestType, Object)

public void UnpinTeamMailboxAsync(
UnpinTeamMailboxRequestType UnpinTeamMailbox1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.UnpinTeamMailboxAsync Overload List


ExchangeServiceBinding.Unsubscribe Method

public UnsubscribeResponseType Unsubscribe(
UnsubscribeType Unsubscribe1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UnsubscribeAsync Method

Aspose.Email

ExchangeServiceBinding.UnsubscribeAsync Method

Overload List

public void UnsubscribeAsync(UnsubscribeType);

public void UnsubscribeAsync(UnsubscribeType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.UnsubscribeAsync Method (UnsubscribeType)

public void UnsubscribeAsync(
UnsubscribeType Unsubscribe1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.UnsubscribeAsync Overload List


ExchangeServiceBinding.UnsubscribeAsync Method (UnsubscribeType, Object)

public void UnsubscribeAsync(
UnsubscribeType Unsubscribe1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.UnsubscribeAsync Overload List


ExchangeServiceBinding.UpdateDelegate Method

public UpdateDelegateResponseMessageType UpdateDelegate(
UpdateDelegateType UpdateDelegate1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateDelegateAsync Method

Aspose.Email

ExchangeServiceBinding.UpdateDelegateAsync Method

Overload List

public void UpdateDelegateAsync(UpdateDelegateType);

public void UpdateDelegateAsync(UpdateDelegateType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.UpdateDelegateAsync Method (UpdateDelegateType)

public void UpdateDelegateAsync(
UpdateDelegateType UpdateDelegate1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.UpdateDelegateAsync Overload List


ExchangeServiceBinding.UpdateDelegateAsync Method (UpdateDelegateType, Object)

public void UpdateDelegateAsync(
UpdateDelegateType UpdateDelegate1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.UpdateDelegateAsync Overload List


ExchangeServiceBinding.UpdateFolder Method

public UpdateFolderResponseType UpdateFolder(
UpdateFolderType UpdateFolder1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateFolderAsync Method

Aspose.Email

ExchangeServiceBinding.UpdateFolderAsync Method

Overload List

public void UpdateFolderAsync(UpdateFolderType);

public void UpdateFolderAsync(UpdateFolderType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.UpdateFolderAsync Method (UpdateFolderType)

public void UpdateFolderAsync(
UpdateFolderType UpdateFolder1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.UpdateFolderAsync Overload List


ExchangeServiceBinding.UpdateFolderAsync Method (UpdateFolderType, Object)

public void UpdateFolderAsync(
UpdateFolderType UpdateFolder1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.UpdateFolderAsync Overload List


ExchangeServiceBinding.UpdateInboxRules Method

public UpdateInboxRulesResponseType UpdateInboxRules(
UpdateInboxRulesRequestType UpdateInboxRules1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateInboxRulesAsync Method

Aspose.Email

ExchangeServiceBinding.UpdateInboxRulesAsync Method

Overload List

public void UpdateInboxRulesAsync(UpdateInboxRulesRequestType);

public void UpdateInboxRulesAsync(UpdateInboxRulesRequestType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.UpdateInboxRulesAsync Method (UpdateInboxRulesRequestType)

public void UpdateInboxRulesAsync(
UpdateInboxRulesRequestType UpdateInboxRules1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.UpdateInboxRulesAsync Overload List


ExchangeServiceBinding.UpdateInboxRulesAsync Method (UpdateInboxRulesRequestType, Object)

public void UpdateInboxRulesAsync(
UpdateInboxRulesRequestType UpdateInboxRules1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.UpdateInboxRulesAsync Overload List


ExchangeServiceBinding.UpdateItem Method

public UpdateItemResponseType UpdateItem(
UpdateItemType UpdateItem1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateItemAsync Method

Aspose.Email

ExchangeServiceBinding.UpdateItemAsync Method

Overload List

public void UpdateItemAsync(UpdateItemType);

public void UpdateItemAsync(UpdateItemType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.UpdateItemAsync Method (UpdateItemType)

public void UpdateItemAsync(
UpdateItemType UpdateItem1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.UpdateItemAsync Overload List


ExchangeServiceBinding.UpdateItemAsync Method (UpdateItemType, Object)

public void UpdateItemAsync(
UpdateItemType UpdateItem1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.UpdateItemAsync Overload List


ExchangeServiceBinding.UpdateItemInRecoverableItems Method

public UpdateItemInRecoverableItemsResponseType UpdateItemInRecoverableItems(
UpdateItemInRecoverableItemsType UpdateItemInRecoverableItems1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateItemInRecoverableItemsAsync Method

Aspose.Email

ExchangeServiceBinding.UpdateItemInRecoverableItemsAsync Method

Overload List

public void UpdateItemInRecoverableItemsAsync(UpdateItemInRecoverableItemsType);

public void UpdateItemInRecoverableItemsAsync(UpdateItemInRecoverableItemsType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.UpdateItemInRecoverableItemsAsync Method (UpdateItemInRecoverableItemsType)

public void UpdateItemInRecoverableItemsAsync(
UpdateItemInRecoverableItemsType UpdateItemInRecoverableItems1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.UpdateItemInRecoverableItemsAsync Overload List


ExchangeServiceBinding.UpdateItemInRecoverableItemsAsync Method (UpdateItemInRecoverableItemsType, Object)

public void UpdateItemInRecoverableItemsAsync(
UpdateItemInRecoverableItemsType UpdateItemInRecoverableItems1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.UpdateItemInRecoverableItemsAsync Overload List


ExchangeServiceBinding.UpdateUserConfiguration Method

public UpdateUserConfigurationResponseType UpdateUserConfiguration(
UpdateUserConfigurationType UpdateUserConfiguration1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateUserConfigurationAsync Method

Aspose.Email

ExchangeServiceBinding.UpdateUserConfigurationAsync Method

Overload List

public void UpdateUserConfigurationAsync(UpdateUserConfigurationType);

public void UpdateUserConfigurationAsync(UpdateUserConfigurationType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.UpdateUserConfigurationAsync Method (UpdateUserConfigurationType)

public void UpdateUserConfigurationAsync(
UpdateUserConfigurationType UpdateUserConfiguration1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.UpdateUserConfigurationAsync Overload List


ExchangeServiceBinding.UpdateUserConfigurationAsync Method (UpdateUserConfigurationType, Object)

public void UpdateUserConfigurationAsync(
UpdateUserConfigurationType UpdateUserConfiguration1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.UpdateUserConfigurationAsync Overload List


ExchangeServiceBinding.UploadItems Method

public UploadItemsResponseType UploadItems(
UploadItemsType UploadItems1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UploadItemsAsync Method

Aspose.Email

ExchangeServiceBinding.UploadItemsAsync Method

Overload List

public void UploadItemsAsync(UploadItemsType);

public void UploadItemsAsync(UploadItemsType,object);

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.UploadItemsAsync Method (UploadItemsType)

public void UploadItemsAsync(
UploadItemsType UploadItems1
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.UploadItemsAsync Overload List


ExchangeServiceBinding.UploadItemsAsync Method (UploadItemsType, Object)

public void UploadItemsAsync(
UploadItemsType UploadItems1,
object userState
);

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace | ExchangeServiceBinding.UploadItemsAsync Overload List


ExchangeServiceBinding Events

The events of the ExchangeServiceBinding class are listed below. For a complete list of ExchangeServiceBinding class members, see the ExchangeServiceBinding Members topic.

Public Instance Events

AddDelegateCompleted |
AddDistributionGroupToImListCompleted |
AddImContactToGroupCompleted |
AddImGroupCompleted |
AddNewImContactToGroupCompleted |
AddNewTelUriContactToGroupCompleted |
ApplyConversationActionCompleted |
ArchiveItemCompleted |
ConvertIdCompleted |
CopyFolderCompleted |
CopyItemCompleted |
CreateAttachmentCompleted |
CreateFolderCompleted |
CreateFolderPathCompleted |
CreateItemCompleted |
CreateManagedFolderCompleted |
CreateUserConfigurationCompleted |
DeleteAttachmentCompleted |
DeleteFolderCompleted |
DeleteItemCompleted |
DeleteUserConfigurationCompleted |
DisableAppCompleted |
DisconnectPhoneCallCompleted |
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
EmptyFolderCompleted |
ExpandDLCompleted |
ExportItemsCompleted |
FindConversationCompleted |
FindFolderCompleted |
FindItemCompleted |
FindMessageTrackingReportCompleted |
FindPeopleCompleted |
GetAppManifestsCompleted |
GetAppMarketplaceUrlCompleted |
GetAttachmentCompleted |
GetClientAccessTokenCompleted |
GetConversationItemsCompleted |
GetDelegateCompleted |
GetDiscoverySearchConfigurationCompleted |
GetEventsCompleted |
GetFolderCompleted |
GetHoldOnMailboxesCompleted |
GetImItemListCompleted |
GetImItemsCompleted |
GetInboxRulesCompleted |
GetItemCompleted |
GetMailTipsCompleted |
GetMessageTrackingReportCompleted |
GetNonIndexableItemDetailsCompleted |
GetNonIndexableItemStatisticsCompleted |
GetPasswordExpirationDateCompleted |
GetPersonaCompleted |
GetPhoneCallInformationCompleted |
GetRoomListsCompleted |
GetRoomsCompleted |
GetSearchableMailboxesCompleted |
GetServerTimeZonesCompleted |
GetServiceConfigurationCompleted |
GetSharingFolderCompleted |
GetSharingMetadataCompleted |
GetStreamingEventsCompleted |
GetUserAvailabilityCompleted |
GetUserConfigurationCompleted |
GetUserOofSettingsCompleted |
GetUserPhotoCompleted |
GetUserRetentionPolicyTagsCompleted |
InstallAppCompleted |
MarkAllItemsAsReadCompleted |
MarkAsJunkCompleted |
MoveFolderCompleted |
MoveItemCompleted |
PlayOnPhoneCompleted |
RefreshSharingFolderCompleted |
RemoveContactFromImListCompleted |
RemoveDelegateCompleted |
RemoveDistributionGroupFromImListCompleted |
RemoveImContactFromGroupCompleted |
RemoveImGroupCompleted |
ResolveNamesCompleted |
SearchMailboxesCompleted |
SendItemCompleted |
SetHoldOnMailboxesCompleted |
SetImGroupCompleted |
SetImListMigrationCompletedCompleted |
SetTeamMailboxCompleted |
SetUserOofSettingsCompleted |
SubscribeCompleted |
SyncFolderHierarchyCompleted |
SyncFolderItemsCompleted |
UninstallAppCompleted |
UnpinTeamMailboxCompleted |
UnsubscribeCompleted |
UpdateDelegateCompleted |
UpdateFolderCompleted |
UpdateInboxRulesCompleted |
UpdateItemCompleted |
UpdateItemInRecoverableItemsCompleted |
UpdateUserConfigurationCompleted |
UploadItemsCompleted |

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.AddDelegateCompleted Event

public event AddDelegateCompletedEventHandler AddDelegateCompleted;

Event Data

The event handler receives an argument of type AddDelegateCompletedEventArgs containing data related to this event. The following AddDelegateCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.AddDistributionGroupToImListCompleted Event

public event AddDistributionGroupToImListCompletedEventHandler AddDistributionGroupToImListCompleted;

Event Data

The event handler receives an argument of type AddDistributionGroupToImListCompletedEventArgs containing data related to this event. The following AddDistributionGroupToImListCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.AddImContactToGroupCompleted Event

public event AddImContactToGroupCompletedEventHandler AddImContactToGroupCompleted;

Event Data

The event handler receives an argument of type AddImContactToGroupCompletedEventArgs containing data related to this event. The following AddImContactToGroupCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.AddImGroupCompleted Event

public event AddImGroupCompletedEventHandler AddImGroupCompleted;

Event Data

The event handler receives an argument of type AddImGroupCompletedEventArgs containing data related to this event. The following AddImGroupCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.AddNewImContactToGroupCompleted Event

public event AddNewImContactToGroupCompletedEventHandler AddNewImContactToGroupCompleted;

Event Data

The event handler receives an argument of type AddNewImContactToGroupCompletedEventArgs containing data related to this event. The following AddNewImContactToGroupCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.AddNewTelUriContactToGroupCompleted Event

public event AddNewTelUriContactToGroupCompletedEventHandler AddNewTelUriContactToGroupCompleted;

Event Data

The event handler receives an argument of type AddNewTelUriContactToGroupCompletedEventArgs containing data related to this event. The following AddNewTelUriContactToGroupCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.ApplyConversationActionCompleted Event

public event ApplyConversationActionCompletedEventHandler ApplyConversationActionCompleted;

Event Data

The event handler receives an argument of type ApplyConversationActionCompletedEventArgs containing data related to this event. The following ApplyConversationActionCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.ArchiveItemCompleted Event

public event ArchiveItemCompletedEventHandler ArchiveItemCompleted;

Event Data

The event handler receives an argument of type ArchiveItemCompletedEventArgs containing data related to this event. The following ArchiveItemCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.ConvertIdCompleted Event

public event ConvertIdCompletedEventHandler ConvertIdCompleted;

Event Data

The event handler receives an argument of type ConvertIdCompletedEventArgs containing data related to this event. The following ConvertIdCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.CopyFolderCompleted Event

public event CopyFolderCompletedEventHandler CopyFolderCompleted;

Event Data

The event handler receives an argument of type CopyFolderCompletedEventArgs containing data related to this event. The following CopyFolderCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.CopyItemCompleted Event

public event CopyItemCompletedEventHandler CopyItemCompleted;

Event Data

The event handler receives an argument of type CopyItemCompletedEventArgs containing data related to this event. The following CopyItemCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.CreateAttachmentCompleted Event

public event CreateAttachmentCompletedEventHandler CreateAttachmentCompleted;

Event Data

The event handler receives an argument of type CreateAttachmentCompletedEventArgs containing data related to this event. The following CreateAttachmentCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.CreateFolderCompleted Event

public event CreateFolderCompletedEventHandler CreateFolderCompleted;

Event Data

The event handler receives an argument of type CreateFolderCompletedEventArgs containing data related to this event. The following CreateFolderCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.CreateFolderPathCompleted Event

public event CreateFolderPathCompletedEventHandler CreateFolderPathCompleted;

Event Data

The event handler receives an argument of type CreateFolderPathCompletedEventArgs containing data related to this event. The following CreateFolderPathCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.CreateItemCompleted Event

public event CreateItemCompletedEventHandler CreateItemCompleted;

Event Data

The event handler receives an argument of type CreateItemCompletedEventArgs containing data related to this event. The following CreateItemCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.CreateManagedFolderCompleted Event

public event CreateManagedFolderCompletedEventHandler CreateManagedFolderCompleted;

Event Data

The event handler receives an argument of type CreateManagedFolderCompletedEventArgs containing data related to this event. The following CreateManagedFolderCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.CreateUserConfigurationCompleted Event

public event CreateUserConfigurationCompletedEventHandler CreateUserConfigurationCompleted;

Event Data

The event handler receives an argument of type CreateUserConfigurationCompletedEventArgs containing data related to this event. The following CreateUserConfigurationCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.DeleteAttachmentCompleted Event

public event DeleteAttachmentCompletedEventHandler DeleteAttachmentCompleted;

Event Data

The event handler receives an argument of type DeleteAttachmentCompletedEventArgs containing data related to this event. The following DeleteAttachmentCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.DeleteFolderCompleted Event

public event DeleteFolderCompletedEventHandler DeleteFolderCompleted;

Event Data

The event handler receives an argument of type DeleteFolderCompletedEventArgs containing data related to this event. The following DeleteFolderCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.DeleteItemCompleted Event

public event DeleteItemCompletedEventHandler DeleteItemCompleted;

Event Data

The event handler receives an argument of type DeleteItemCompletedEventArgs containing data related to this event. The following DeleteItemCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.DeleteUserConfigurationCompleted Event

public event DeleteUserConfigurationCompletedEventHandler DeleteUserConfigurationCompleted;

Event Data

The event handler receives an argument of type DeleteUserConfigurationCompletedEventArgs containing data related to this event. The following DeleteUserConfigurationCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.DisableAppCompleted Event

public event DisableAppCompletedEventHandler DisableAppCompleted;

Event Data

The event handler receives an argument of type DisableAppCompletedEventArgs containing data related to this event. The following DisableAppCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.DisconnectPhoneCallCompleted Event

public event DisconnectPhoneCallCompletedEventHandler DisconnectPhoneCallCompleted;

Event Data

The event handler receives an argument of type DisconnectPhoneCallCompletedEventArgs containing data related to this event. The following DisconnectPhoneCallCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.EmptyFolderCompleted Event

public event EmptyFolderCompletedEventHandler EmptyFolderCompleted;

Event Data

The event handler receives an argument of type EmptyFolderCompletedEventArgs containing data related to this event. The following EmptyFolderCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.ExpandDLCompleted Event

public event ExpandDLCompletedEventHandler ExpandDLCompleted;

Event Data

The event handler receives an argument of type ExpandDLCompletedEventArgs containing data related to this event. The following ExpandDLCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.ExportItemsCompleted Event

public event ExportItemsCompletedEventHandler ExportItemsCompleted;

Event Data

The event handler receives an argument of type ExportItemsCompletedEventArgs containing data related to this event. The following ExportItemsCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.FindConversationCompleted Event

public event FindConversationCompletedEventHandler FindConversationCompleted;

Event Data

The event handler receives an argument of type FindConversationCompletedEventArgs containing data related to this event. The following FindConversationCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.FindFolderCompleted Event

public event FindFolderCompletedEventHandler FindFolderCompleted;

Event Data

The event handler receives an argument of type FindFolderCompletedEventArgs containing data related to this event. The following FindFolderCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.FindItemCompleted Event

public event FindItemCompletedEventHandler FindItemCompleted;

Event Data

The event handler receives an argument of type FindItemCompletedEventArgs containing data related to this event. The following FindItemCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.FindMessageTrackingReportCompleted Event

public event FindMessageTrackingReportCompletedEventHandler FindMessageTrackingReportCompleted;

Event Data

The event handler receives an argument of type FindMessageTrackingReportCompletedEventArgs containing data related to this event. The following FindMessageTrackingReportCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.FindPeopleCompleted Event

public event FindPeopleCompletedEventHandler FindPeopleCompleted;

Event Data

The event handler receives an argument of type FindPeopleCompletedEventArgs containing data related to this event. The following FindPeopleCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetAppManifestsCompleted Event

public event GetAppManifestsCompletedEventHandler GetAppManifestsCompleted;

Event Data

The event handler receives an argument of type GetAppManifestsCompletedEventArgs containing data related to this event. The following GetAppManifestsCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetAppMarketplaceUrlCompleted Event

public event GetAppMarketplaceUrlCompletedEventHandler GetAppMarketplaceUrlCompleted;

Event Data

The event handler receives an argument of type GetAppMarketplaceUrlCompletedEventArgs containing data related to this event. The following GetAppMarketplaceUrlCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetAttachmentCompleted Event

public event GetAttachmentCompletedEventHandler GetAttachmentCompleted;

Event Data

The event handler receives an argument of type GetAttachmentCompletedEventArgs containing data related to this event. The following GetAttachmentCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetClientAccessTokenCompleted Event

public event GetClientAccessTokenCompletedEventHandler GetClientAccessTokenCompleted;

Event Data

The event handler receives an argument of type GetClientAccessTokenCompletedEventArgs containing data related to this event. The following GetClientAccessTokenCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetConversationItemsCompleted Event

public event GetConversationItemsCompletedEventHandler GetConversationItemsCompleted;

Event Data

The event handler receives an argument of type GetConversationItemsCompletedEventArgs containing data related to this event. The following GetConversationItemsCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetDelegateCompleted Event

public event GetDelegateCompletedEventHandler GetDelegateCompleted;

Event Data

The event handler receives an argument of type GetDelegateCompletedEventArgs containing data related to this event. The following GetDelegateCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetDiscoverySearchConfigurationCompleted Event

public event GetDiscoverySearchConfigurationCompletedEventHandler GetDiscoverySearchConfigurationCompleted;

Event Data

The event handler receives an argument of type GetDiscoverySearchConfigurationCompletedEventArgs containing data related to this event. The following GetDiscoverySearchConfigurationCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetEventsCompleted Event

public event GetEventsCompletedEventHandler GetEventsCompleted;

Event Data

The event handler receives an argument of type GetEventsCompletedEventArgs containing data related to this event. The following GetEventsCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetFolderCompleted Event

public event GetFolderCompletedEventHandler GetFolderCompleted;

Event Data

The event handler receives an argument of type GetFolderCompletedEventArgs containing data related to this event. The following GetFolderCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetHoldOnMailboxesCompleted Event

public event GetHoldOnMailboxesCompletedEventHandler GetHoldOnMailboxesCompleted;

Event Data

The event handler receives an argument of type GetHoldOnMailboxesCompletedEventArgs containing data related to this event. The following GetHoldOnMailboxesCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetImItemListCompleted Event

public event GetImItemListCompletedEventHandler GetImItemListCompleted;

Event Data

The event handler receives an argument of type GetImItemListCompletedEventArgs containing data related to this event. The following GetImItemListCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetImItemsCompleted Event

public event GetImItemsCompletedEventHandler GetImItemsCompleted;

Event Data

The event handler receives an argument of type GetImItemsCompletedEventArgs containing data related to this event. The following GetImItemsCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetInboxRulesCompleted Event

public event GetInboxRulesCompletedEventHandler GetInboxRulesCompleted;

Event Data

The event handler receives an argument of type GetInboxRulesCompletedEventArgs containing data related to this event. The following GetInboxRulesCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetItemCompleted Event

public event GetItemCompletedEventHandler GetItemCompleted;

Event Data

The event handler receives an argument of type GetItemCompletedEventArgs containing data related to this event. The following GetItemCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetMailTipsCompleted Event

public event GetMailTipsCompletedEventHandler GetMailTipsCompleted;

Event Data

The event handler receives an argument of type GetMailTipsCompletedEventArgs containing data related to this event. The following GetMailTipsCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetMessageTrackingReportCompleted Event

public event GetMessageTrackingReportCompletedEventHandler GetMessageTrackingReportCompleted;

Event Data

The event handler receives an argument of type GetMessageTrackingReportCompletedEventArgs containing data related to this event. The following GetMessageTrackingReportCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetNonIndexableItemDetailsCompleted Event

public event GetNonIndexableItemDetailsCompletedEventHandler GetNonIndexableItemDetailsCompleted;

Event Data

The event handler receives an argument of type GetNonIndexableItemDetailsCompletedEventArgs containing data related to this event. The following GetNonIndexableItemDetailsCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetNonIndexableItemStatisticsCompleted Event

public event GetNonIndexableItemStatisticsCompletedEventHandler GetNonIndexableItemStatisticsCompleted;

Event Data

The event handler receives an argument of type GetNonIndexableItemStatisticsCompletedEventArgs containing data related to this event. The following GetNonIndexableItemStatisticsCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetPasswordExpirationDateCompleted Event

public event GetPasswordExpirationDateCompletedEventHandler GetPasswordExpirationDateCompleted;

Event Data

The event handler receives an argument of type GetPasswordExpirationDateCompletedEventArgs containing data related to this event. The following GetPasswordExpirationDateCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetPersonaCompleted Event

public event GetPersonaCompletedEventHandler GetPersonaCompleted;

Event Data

The event handler receives an argument of type GetPersonaCompletedEventArgs containing data related to this event. The following GetPersonaCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetPhoneCallInformationCompleted Event

public event GetPhoneCallInformationCompletedEventHandler GetPhoneCallInformationCompleted;

Event Data

The event handler receives an argument of type GetPhoneCallInformationCompletedEventArgs containing data related to this event. The following GetPhoneCallInformationCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetRoomListsCompleted Event

public event GetRoomListsCompletedEventHandler GetRoomListsCompleted;

Event Data

The event handler receives an argument of type GetRoomListsCompletedEventArgs containing data related to this event. The following GetRoomListsCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetRoomsCompleted Event

public event GetRoomsCompletedEventHandler GetRoomsCompleted;

Event Data

The event handler receives an argument of type GetRoomsCompletedEventArgs containing data related to this event. The following GetRoomsCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetSearchableMailboxesCompleted Event

public event GetSearchableMailboxesCompletedEventHandler GetSearchableMailboxesCompleted;

Event Data

The event handler receives an argument of type GetSearchableMailboxesCompletedEventArgs containing data related to this event. The following GetSearchableMailboxesCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetServerTimeZonesCompleted Event

public event GetServerTimeZonesCompletedEventHandler GetServerTimeZonesCompleted;

Event Data

The event handler receives an argument of type GetServerTimeZonesCompletedEventArgs containing data related to this event. The following GetServerTimeZonesCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetServiceConfigurationCompleted Event

public event GetServiceConfigurationCompletedEventHandler GetServiceConfigurationCompleted;

Event Data

The event handler receives an argument of type GetServiceConfigurationCompletedEventArgs containing data related to this event. The following GetServiceConfigurationCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetSharingFolderCompleted Event

public event GetSharingFolderCompletedEventHandler GetSharingFolderCompleted;

Event Data

The event handler receives an argument of type GetSharingFolderCompletedEventArgs containing data related to this event. The following GetSharingFolderCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetSharingMetadataCompleted Event

public event GetSharingMetadataCompletedEventHandler GetSharingMetadataCompleted;

Event Data

The event handler receives an argument of type GetSharingMetadataCompletedEventArgs containing data related to this event. The following GetSharingMetadataCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetStreamingEventsCompleted Event

public event GetStreamingEventsCompletedEventHandler GetStreamingEventsCompleted;

Event Data

The event handler receives an argument of type GetStreamingEventsCompletedEventArgs containing data related to this event. The following GetStreamingEventsCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetUserAvailabilityCompleted Event

public event GetUserAvailabilityCompletedEventHandler GetUserAvailabilityCompleted;

Event Data

The event handler receives an argument of type GetUserAvailabilityCompletedEventArgs containing data related to this event. The following GetUserAvailabilityCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetUserConfigurationCompleted Event

public event GetUserConfigurationCompletedEventHandler GetUserConfigurationCompleted;

Event Data

The event handler receives an argument of type GetUserConfigurationCompletedEventArgs containing data related to this event. The following GetUserConfigurationCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetUserOofSettingsCompleted Event

public event GetUserOofSettingsCompletedEventHandler GetUserOofSettingsCompleted;

Event Data

The event handler receives an argument of type GetUserOofSettingsCompletedEventArgs containing data related to this event. The following GetUserOofSettingsCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetUserPhotoCompleted Event

public event GetUserPhotoCompletedEventHandler GetUserPhotoCompleted;

Event Data

The event handler receives an argument of type GetUserPhotoCompletedEventArgs containing data related to this event. The following GetUserPhotoCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.GetUserRetentionPolicyTagsCompleted Event

public event GetUserRetentionPolicyTagsCompletedEventHandler GetUserRetentionPolicyTagsCompleted;

Event Data

The event handler receives an argument of type GetUserRetentionPolicyTagsCompletedEventArgs containing data related to this event. The following GetUserRetentionPolicyTagsCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.InstallAppCompleted Event

public event InstallAppCompletedEventHandler InstallAppCompleted;

Event Data

The event handler receives an argument of type InstallAppCompletedEventArgs containing data related to this event. The following InstallAppCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.MarkAllItemsAsReadCompleted Event

public event MarkAllItemsAsReadCompletedEventHandler MarkAllItemsAsReadCompleted;

Event Data

The event handler receives an argument of type MarkAllItemsAsReadCompletedEventArgs containing data related to this event. The following MarkAllItemsAsReadCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.MarkAsJunkCompleted Event

public event MarkAsJunkCompletedEventHandler MarkAsJunkCompleted;

Event Data

The event handler receives an argument of type MarkAsJunkCompletedEventArgs containing data related to this event. The following MarkAsJunkCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.MoveFolderCompleted Event

public event MoveFolderCompletedEventHandler MoveFolderCompleted;

Event Data

The event handler receives an argument of type MoveFolderCompletedEventArgs containing data related to this event. The following MoveFolderCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.MoveItemCompleted Event

public event MoveItemCompletedEventHandler MoveItemCompleted;

Event Data

The event handler receives an argument of type MoveItemCompletedEventArgs containing data related to this event. The following MoveItemCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.PlayOnPhoneCompleted Event

public event PlayOnPhoneCompletedEventHandler PlayOnPhoneCompleted;

Event Data

The event handler receives an argument of type PlayOnPhoneCompletedEventArgs containing data related to this event. The following PlayOnPhoneCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.RefreshSharingFolderCompleted Event

public event RefreshSharingFolderCompletedEventHandler RefreshSharingFolderCompleted;

Event Data

The event handler receives an argument of type RefreshSharingFolderCompletedEventArgs containing data related to this event. The following RefreshSharingFolderCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.RemoveContactFromImListCompleted Event

public event RemoveContactFromImListCompletedEventHandler RemoveContactFromImListCompleted;

Event Data

The event handler receives an argument of type RemoveContactFromImListCompletedEventArgs containing data related to this event. The following RemoveContactFromImListCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.RemoveDelegateCompleted Event

public event RemoveDelegateCompletedEventHandler RemoveDelegateCompleted;

Event Data

The event handler receives an argument of type RemoveDelegateCompletedEventArgs containing data related to this event. The following RemoveDelegateCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.RemoveDistributionGroupFromImListCompleted Event

public event RemoveDistributionGroupFromImListCompletedEventHandler RemoveDistributionGroupFromImListCompleted;

Event Data

The event handler receives an argument of type RemoveDistributionGroupFromImListCompletedEventArgs containing data related to this event. The following RemoveDistributionGroupFromImListCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.RemoveImContactFromGroupCompleted Event

public event RemoveImContactFromGroupCompletedEventHandler RemoveImContactFromGroupCompleted;

Event Data

The event handler receives an argument of type RemoveImContactFromGroupCompletedEventArgs containing data related to this event. The following RemoveImContactFromGroupCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.RemoveImGroupCompleted Event

public event RemoveImGroupCompletedEventHandler RemoveImGroupCompleted;

Event Data

The event handler receives an argument of type RemoveImGroupCompletedEventArgs containing data related to this event. The following RemoveImGroupCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.ResolveNamesCompleted Event

public event ResolveNamesCompletedEventHandler ResolveNamesCompleted;

Event Data

The event handler receives an argument of type ResolveNamesCompletedEventArgs containing data related to this event. The following ResolveNamesCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.SearchMailboxesCompleted Event

public event SearchMailboxesCompletedEventHandler SearchMailboxesCompleted;

Event Data

The event handler receives an argument of type SearchMailboxesCompletedEventArgs containing data related to this event. The following SearchMailboxesCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.SendItemCompleted Event

public event SendItemCompletedEventHandler SendItemCompleted;

Event Data

The event handler receives an argument of type SendItemCompletedEventArgs containing data related to this event. The following SendItemCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.SetHoldOnMailboxesCompleted Event

public event SetHoldOnMailboxesCompletedEventHandler SetHoldOnMailboxesCompleted;

Event Data

The event handler receives an argument of type SetHoldOnMailboxesCompletedEventArgs containing data related to this event. The following SetHoldOnMailboxesCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.SetImGroupCompleted Event

public event SetImGroupCompletedEventHandler SetImGroupCompleted;

Event Data

The event handler receives an argument of type SetImGroupCompletedEventArgs containing data related to this event. The following SetImGroupCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.SetImListMigrationCompletedCompleted Event

public event SetImListMigrationCompletedCompletedEventHandler SetImListMigrationCompletedCompleted;

Event Data

The event handler receives an argument of type SetImListMigrationCompletedCompletedEventArgs containing data related to this event. The following SetImListMigrationCompletedCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.SetTeamMailboxCompleted Event

public event SetTeamMailboxCompletedEventHandler SetTeamMailboxCompleted;

Event Data

The event handler receives an argument of type SetTeamMailboxCompletedEventArgs containing data related to this event. The following SetTeamMailboxCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.SetUserOofSettingsCompleted Event

public event SetUserOofSettingsCompletedEventHandler SetUserOofSettingsCompleted;

Event Data

The event handler receives an argument of type SetUserOofSettingsCompletedEventArgs containing data related to this event. The following SetUserOofSettingsCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.SubscribeCompleted Event

public event SubscribeCompletedEventHandler SubscribeCompleted;

Event Data

The event handler receives an argument of type SubscribeCompletedEventArgs containing data related to this event. The following SubscribeCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.SyncFolderHierarchyCompleted Event

public event SyncFolderHierarchyCompletedEventHandler SyncFolderHierarchyCompleted;

Event Data

The event handler receives an argument of type SyncFolderHierarchyCompletedEventArgs containing data related to this event. The following SyncFolderHierarchyCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.SyncFolderItemsCompleted Event

public event SyncFolderItemsCompletedEventHandler SyncFolderItemsCompleted;

Event Data

The event handler receives an argument of type SyncFolderItemsCompletedEventArgs containing data related to this event. The following SyncFolderItemsCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.UninstallAppCompleted Event

public event UninstallAppCompletedEventHandler UninstallAppCompleted;

Event Data

The event handler receives an argument of type UninstallAppCompletedEventArgs containing data related to this event. The following UninstallAppCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.UnpinTeamMailboxCompleted Event

public event UnpinTeamMailboxCompletedEventHandler UnpinTeamMailboxCompleted;

Event Data

The event handler receives an argument of type UnpinTeamMailboxCompletedEventArgs containing data related to this event. The following UnpinTeamMailboxCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.UnsubscribeCompleted Event

public event UnsubscribeCompletedEventHandler UnsubscribeCompleted;

Event Data

The event handler receives an argument of type UnsubscribeCompletedEventArgs containing data related to this event. The following UnsubscribeCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.UpdateDelegateCompleted Event

public event UpdateDelegateCompletedEventHandler UpdateDelegateCompleted;

Event Data

The event handler receives an argument of type UpdateDelegateCompletedEventArgs containing data related to this event. The following UpdateDelegateCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.UpdateFolderCompleted Event

public event UpdateFolderCompletedEventHandler UpdateFolderCompleted;

Event Data

The event handler receives an argument of type UpdateFolderCompletedEventArgs containing data related to this event. The following UpdateFolderCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.UpdateInboxRulesCompleted Event

public event UpdateInboxRulesCompletedEventHandler UpdateInboxRulesCompleted;

Event Data

The event handler receives an argument of type UpdateInboxRulesCompletedEventArgs containing data related to this event. The following UpdateInboxRulesCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.UpdateItemCompleted Event

public event UpdateItemCompletedEventHandler UpdateItemCompleted;

Event Data

The event handler receives an argument of type UpdateItemCompletedEventArgs containing data related to this event. The following UpdateItemCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.UpdateItemInRecoverableItemsCompleted Event

public event UpdateItemInRecoverableItemsCompletedEventHandler UpdateItemInRecoverableItemsCompleted;

Event Data

The event handler receives an argument of type UpdateItemInRecoverableItemsCompletedEventArgs containing data related to this event. The following UpdateItemInRecoverableItemsCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.UpdateUserConfigurationCompleted Event

public event UpdateUserConfigurationCompletedEventHandler UpdateUserConfigurationCompleted;

Event Data

The event handler receives an argument of type UpdateUserConfigurationCompletedEventArgs containing data related to this event. The following UpdateUserConfigurationCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeServiceBinding.UploadItemsCompleted Event

public event UploadItemsCompletedEventHandler UploadItemsCompleted;

Event Data

The event handler receives an argument of type UploadItemsCompletedEventArgs containing data related to this event. The following UploadItemsCompletedEventArgs properties provide information specific to this event.

Property | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled.
Error | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState | Gets the unique identifier for the asynchronous task.

Remarks

See Also

ExchangeServiceBinding Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeVersionType Enumeration

public enum ExchangeVersionType

Remarks

Members

Member Name | Description | Value
Exchange2007 |  | 0
Exchange2007_SP1 |  | 1
Exchange2010 |  | 2
Exchange2010_SP1 |  | 3
Exchange2010_SP2 |  | 4
Exchange2013 |  | 5

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExcludesType Class

For a list of all members of this type, see ExcludesType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.SearchExpressionType
Aspose.Email.Exchange.Schema.Exchange_2013.ExcludesType

public class ExcludesType : SearchExpressionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExcludesType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExcludesType Members

ExcludesType overview

Public Instance Constructors

ExcludesType Constructor Initializes a new instance of the ExcludesType class.

Public Instance Properties

Bitmask
Item

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExcludesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExcludesType Constructor

Initializes a new instance of the ExcludesType class.

public ExcludesType();

See Also

ExcludesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExcludesType Properties

The properties of the ExcludesType class are listed below. For a complete list of ExcludesType class members, see the ExcludesType Members topic.

Public Instance Properties

Bitmask
Item

See Also

ExcludesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Bitmask Property

Aspose.Email

ExcludesType.Bitmask Property

public ExcludesValueType Bitmask {get; set;}

Remarks

See Also

ExcludesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Item Property

Aspose.Email

ExcludesType.Item Property

public BasePathToElementType Item {get; set;}

Remarks

See Also

ExcludesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExcludesValueType Class

For a list of all members of this type, see ExcludesValueType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ExcludesValueType

public class ExcludesValueType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExcludesValueType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExcludesValueType Members

ExcludesValueType overview

Public Instance Constructors

ExcludesValueType Constructor Initializes a new instance of the ExcludesValueType class.

Public Instance Properties

Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExcludesValueType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExcludesValueType Constructor

Initializes a new instance of the ExcludesValueType class.

public ExcludesValueType();

See Also

ExcludesValueType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExcludesValueType Properties

The properties of the ExcludesValueType class are listed below. For a complete list of ExcludesValueType class members, see the ExcludesValueType Members topic.

Public Instance Properties

Value

See Also

ExcludesValueType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Value Property

Aspose.Email

ExcludesValueType.Value Property

public string Value {get; set;}

Remarks

See Also

ExcludesValueType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExistsType Class

For a list of all members of this type, see ExistsType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.SearchExpressionType
Aspose.Email.Exchange.Schema.Exchange_2013.ExistsType

public class ExistsType : SearchExpressionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExistsType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExistsType Members

ExistsType overview

Public Instance Constructors

ExistsType Constructor Initializes a new instance of the ExistsType class.

Public Instance Properties

Item

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExistsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExistsType Constructor

Initializes a new instance of the ExistsType class.

public ExistsType();

See Also

ExistsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExistsType Properties

The properties of the ExistsType class are listed below. For a complete list of ExistsType class members, see the ExistsType Members topic.

Public Instance Properties

Item

See Also

ExistsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Item Property

Aspose.Email

ExistsType.Item Property

public BasePathToElementType Item {get; set;}

Remarks

See Also

ExistsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExpandDLCompletedEventArgs Class

For a list of all members of this type, see ExpandDLCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.ExpandDLCompletedEventArgs

public class ExpandDLCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExpandDLCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExpandDLCompletedEventArgs Members

ExpandDLCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

ExpandDLCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExpandDLCompletedEventArgs Properties

The properties of the ExpandDLCompletedEventArgs class are listed below. For a complete list of ExpandDLCompletedEventArgs class members, see the ExpandDLCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

ExpandDLCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

ExpandDLCompletedEventArgs.Result Property

public ExpandDLResponseType Result {get;}

Remarks

See Also

ExpandDLCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExpandDLCompletedEventHandler Delegate

public delegate void ExpandDLCompletedEventHandler(
object sender,
ExpandDLCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExpandDLResponseMessageType Class

For a list of all members of this type, see ExpandDLResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.ExpandDLResponseMessageType

public class ExpandDLResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExpandDLResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExpandDLResponseMessageType Members

ExpandDLResponseMessageType overview

Public Instance Constructors

ExpandDLResponseMessageType Constructor Initializes a new instance of the ExpandDLResponseMessageType class.

Public Instance Properties

AbsoluteDenominator
AbsoluteDenominatorSpecified
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
DLExpansion
IncludesLastItemInRange
IncludesLastItemInRangeSpecified
IndexedPagingOffset
IndexedPagingOffsetSpecified
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
NumeratorOffset
NumeratorOffsetSpecified
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
TotalItemsInView
TotalItemsInViewSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExpandDLResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExpandDLResponseMessageType Constructor

Initializes a new instance of the ExpandDLResponseMessageType class.

public ExpandDLResponseMessageType();

See Also

ExpandDLResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExpandDLResponseMessageType Properties

The properties of the ExpandDLResponseMessageType class are listed below. For a complete list of ExpandDLResponseMessageType class members, see the ExpandDLResponseMessageType Members topic.

Public Instance Properties

AbsoluteDenominator
AbsoluteDenominatorSpecified
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
DLExpansion
IncludesLastItemInRange
IncludesLastItemInRangeSpecified
IndexedPagingOffset
IndexedPagingOffsetSpecified
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
NumeratorOffset
NumeratorOffsetSpecified
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
TotalItemsInView
TotalItemsInViewSpecified

See Also

ExpandDLResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AbsoluteDenominator Property

Aspose.Email

ExpandDLResponseMessageType.AbsoluteDenominator Property

public int AbsoluteDenominator {get; set;}

Remarks

See Also

ExpandDLResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AbsoluteDenominatorSpecified Property

Aspose.Email

ExpandDLResponseMessageType.AbsoluteDenominatorSpecified Property

public bool AbsoluteDenominatorSpecified {get; set;}

Remarks

See Also

ExpandDLResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DLExpansion Property

Aspose.Email

ExpandDLResponseMessageType.DLExpansion Property

public ArrayOfDLExpansionType DLExpansion {get; set;}

Remarks

See Also

ExpandDLResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IncludesLastItemInRange Property

Aspose.Email

ExpandDLResponseMessageType.IncludesLastItemInRange Property

public bool IncludesLastItemInRange {get; set;}

Remarks

See Also

ExpandDLResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IncludesLastItemInRangeSpecified Property

Aspose.Email

ExpandDLResponseMessageType.IncludesLastItemInRangeSpecified Property

public bool IncludesLastItemInRangeSpecified {get; set;}

Remarks

See Also

ExpandDLResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IndexedPagingOffset Property

Aspose.Email

ExpandDLResponseMessageType.IndexedPagingOffset Property

public int IndexedPagingOffset {get; set;}

Remarks

See Also

ExpandDLResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IndexedPagingOffsetSpecified Property

Aspose.Email

ExpandDLResponseMessageType.IndexedPagingOffsetSpecified Property

public bool IndexedPagingOffsetSpecified {get; set;}

Remarks

See Also

ExpandDLResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NumeratorOffset Property

Aspose.Email

ExpandDLResponseMessageType.NumeratorOffset Property

public int NumeratorOffset {get; set;}

Remarks

See Also

ExpandDLResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NumeratorOffsetSpecified Property

Aspose.Email

ExpandDLResponseMessageType.NumeratorOffsetSpecified Property

public bool NumeratorOffsetSpecified {get; set;}

Remarks

See Also

ExpandDLResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TotalItemsInView Property

Aspose.Email

ExpandDLResponseMessageType.TotalItemsInView Property

public int TotalItemsInView {get; set;}

Remarks

See Also

ExpandDLResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TotalItemsInViewSpecified Property

Aspose.Email

ExpandDLResponseMessageType.TotalItemsInViewSpecified Property

public bool TotalItemsInViewSpecified {get; set;}

Remarks

See Also

ExpandDLResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExpandDLResponseType Class

For a list of all members of this type, see ExpandDLResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.ExpandDLResponseType

public class ExpandDLResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExpandDLResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExpandDLResponseType Members

ExpandDLResponseType overview

Public Instance Constructors

ExpandDLResponseType Constructor Initializes a new instance of the ExpandDLResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExpandDLResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExpandDLResponseType Constructor

Initializes a new instance of the ExpandDLResponseType class.

public ExpandDLResponseType();

See Also

ExpandDLResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExpandDLType Class

For a list of all members of this type, see ExpandDLType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.ExpandDLType

public class ExpandDLType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExpandDLType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExpandDLType Members

ExpandDLType overview

Public Instance Constructors

ExpandDLType Constructor Initializes a new instance of the ExpandDLType class.

Public Instance Properties

Mailbox

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExpandDLType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExpandDLType Constructor

Initializes a new instance of the ExpandDLType class.

public ExpandDLType();

See Also

ExpandDLType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExpandDLType Properties

The properties of the ExpandDLType class are listed below. For a complete list of ExpandDLType class members, see the ExpandDLType Members topic.

Public Instance Properties

Mailbox

See Also

ExpandDLType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Mailbox Property

Aspose.Email

ExpandDLType.Mailbox Property

public EmailAddressType Mailbox {get; set;}

Remarks

See Also

ExpandDLType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExportItemsCompletedEventArgs Class

For a list of all members of this type, see ExportItemsCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.ExportItemsCompletedEventArgs

public class ExportItemsCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExportItemsCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExportItemsCompletedEventArgs Members

ExportItemsCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

ExportItemsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExportItemsCompletedEventArgs Properties

The properties of the ExportItemsCompletedEventArgs class are listed below. For a complete list of ExportItemsCompletedEventArgs class members, see the ExportItemsCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

ExportItemsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

ExportItemsCompletedEventArgs.Result Property

public ExportItemsResponseType Result {get;}

Remarks

See Also

ExportItemsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExportItemsCompletedEventHandler Delegate

public delegate void ExportItemsCompletedEventHandler(
object sender,
ExportItemsCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExportItemsResponseMessageType Class

For a list of all members of this type, see ExportItemsResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.ExportItemsResponseMessageType

public class ExportItemsResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExportItemsResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExportItemsResponseMessageType Members

ExportItemsResponseMessageType overview

Public Instance Constructors

ExportItemsResponseMessageType Constructor Initializes a new instance of the ExportItemsResponseMessageType class.

Public Instance Properties

Data
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
ItemId
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExportItemsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExportItemsResponseMessageType Constructor

Initializes a new instance of the ExportItemsResponseMessageType class.

public ExportItemsResponseMessageType();

See Also

ExportItemsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExportItemsResponseMessageType Properties

The properties of the ExportItemsResponseMessageType class are listed below. For a complete list of ExportItemsResponseMessageType class members, see the ExportItemsResponseMessageType Members topic.

Public Instance Properties

Data
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
ItemId
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

ExportItemsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Data Property

Aspose.Email

ExportItemsResponseMessageType.Data Property

public byte[] Data {get; set;}

Remarks

See Also

ExportItemsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemId Property

Aspose.Email

ExportItemsResponseMessageType.ItemId Property

public ItemIdType ItemId {get; set;}

Remarks

See Also

ExportItemsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExportItemsResponseType Class

For a list of all members of this type, see ExportItemsResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.ExportItemsResponseType

public class ExportItemsResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExportItemsResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExportItemsResponseType Members

ExportItemsResponseType overview

Public Instance Constructors

ExportItemsResponseType Constructor Initializes a new instance of the ExportItemsResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExportItemsResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExportItemsResponseType Constructor

Initializes a new instance of the ExportItemsResponseType class.

public ExportItemsResponseType();

See Also

ExportItemsResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExportItemsType Class

For a list of all members of this type, see ExportItemsType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.ExportItemsType

public class ExportItemsType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExportItemsType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExportItemsType Members

ExportItemsType overview

Public Instance Constructors

ExportItemsType Constructor Initializes a new instance of the ExportItemsType class.

Public Instance Properties

ItemIds

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExportItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExportItemsType Constructor

Initializes a new instance of the ExportItemsType class.

public ExportItemsType();

See Also

ExportItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExportItemsType Properties

The properties of the ExportItemsType class are listed below. For a complete list of ExportItemsType class members, see the ExportItemsType Members topic.

Public Instance Properties

ItemIds

See Also

ExportItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemIds Property

Aspose.Email

ExportItemsType.ItemIds Property

public ItemIdType[] ItemIds {get; set;}

Remarks

See Also

ExportItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExtendedPropertyAttributedValueType Class

For a list of all members of this type, see ExtendedPropertyAttributedValueType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ExtendedPropertyAttributedValueType

public class ExtendedPropertyAttributedValueType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExtendedPropertyAttributedValueType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExtendedPropertyAttributedValueType Members

ExtendedPropertyAttributedValueType overview

Public Instance Constructors

ExtendedPropertyAttributedValueType Constructor Initializes a new instance of the ExtendedPropertyAttributedValueType class.

Public Instance Properties

Attributions
Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExtendedPropertyAttributedValueType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExtendedPropertyAttributedValueType Constructor

Initializes a new instance of the ExtendedPropertyAttributedValueType class.

public ExtendedPropertyAttributedValueType();

See Also

ExtendedPropertyAttributedValueType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExtendedPropertyAttributedValueType Properties

The properties of the ExtendedPropertyAttributedValueType class are listed below. For a complete list of ExtendedPropertyAttributedValueType class members, see the ExtendedPropertyAttributedValueType Members topic.

Public Instance Properties

Attributions
Value

See Also

ExtendedPropertyAttributedValueType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Attributions Property

Aspose.Email

ExtendedPropertyAttributedValueType.Attributions Property

public string[] Attributions {get; set;}

Remarks

See Also

ExtendedPropertyAttributedValueType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Value Property

Aspose.Email

ExtendedPropertyAttributedValueType.Value Property

public ExtendedPropertyType Value {get; set;}

Remarks

See Also

ExtendedPropertyAttributedValueType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExtendedPropertyType Class

For a list of all members of this type, see ExtendedPropertyType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ExtendedPropertyType

public class ExtendedPropertyType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExtendedPropertyType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExtendedPropertyType Members

ExtendedPropertyType overview

Public Instance Constructors

ExtendedPropertyType Constructor Initializes a new instance of the ExtendedPropertyType class.

Public Instance Properties

ExtendedFieldURI
Item

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExtendedPropertyType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExtendedPropertyType Constructor

Initializes a new instance of the ExtendedPropertyType class.

public ExtendedPropertyType();

See Also

ExtendedPropertyType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExtendedPropertyType Properties

The properties of the ExtendedPropertyType class are listed below. For a complete list of ExtendedPropertyType class members, see the ExtendedPropertyType Members topic.

Public Instance Properties

ExtendedFieldURI
Item

See Also

ExtendedPropertyType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExtendedFieldURI Property

Aspose.Email

ExtendedPropertyType.ExtendedFieldURI Property

public PathToExtendedFieldType ExtendedFieldURI {get; set;}

Remarks

See Also

ExtendedPropertyType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Item Property

Aspose.Email

ExtendedPropertyType.Item Property

public object Item {get; set;}

Remarks

See Also

ExtendedPropertyType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExternalAudience Enumeration

public enum ExternalAudience

Remarks

Members

Member Name | Description | Value
None |  | 0
Known |  | 1
All |  | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FailedSearchMailboxType Class

For a list of all members of this type, see FailedSearchMailboxType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.FailedSearchMailboxType

public class FailedSearchMailboxType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FailedSearchMailboxType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FailedSearchMailboxType Members

FailedSearchMailboxType overview

Public Instance Constructors

FailedSearchMailboxType Constructor Initializes a new instance of the FailedSearchMailboxType class.

Public Instance Properties

ErrorCode
ErrorMessage
IsArchive
Mailbox

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FailedSearchMailboxType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FailedSearchMailboxType Constructor

Initializes a new instance of the FailedSearchMailboxType class.

public FailedSearchMailboxType();

See Also

FailedSearchMailboxType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FailedSearchMailboxType Properties

The properties of the FailedSearchMailboxType class are listed below. For a complete list of FailedSearchMailboxType class members, see the FailedSearchMailboxType Members topic.

Public Instance Properties

ErrorCode
ErrorMessage
IsArchive
Mailbox

See Also

FailedSearchMailboxType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ErrorCode Property

Aspose.Email

FailedSearchMailboxType.ErrorCode Property

public int ErrorCode {get; set;}

Remarks

See Also

FailedSearchMailboxType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ErrorMessage Property

Aspose.Email

FailedSearchMailboxType.ErrorMessage Property

public string ErrorMessage {get; set;}

Remarks

See Also

FailedSearchMailboxType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsArchive Property

Aspose.Email

FailedSearchMailboxType.IsArchive Property

public bool IsArchive {get; set;}

Remarks

See Also

FailedSearchMailboxType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Mailbox Property

Aspose.Email

FailedSearchMailboxType.Mailbox Property

public string Mailbox {get; set;}

Remarks

See Also

FailedSearchMailboxType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FieldOrderType Class

For a list of all members of this type, see FieldOrderType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.FieldOrderType

public class FieldOrderType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FieldOrderType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FieldOrderType Members

FieldOrderType overview

Public Instance Constructors

FieldOrderType Constructor Initializes a new instance of the FieldOrderType class.

Public Instance Properties

Item
Order

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FieldOrderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FieldOrderType Constructor

Initializes a new instance of the FieldOrderType class.

public FieldOrderType();

See Also

FieldOrderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FieldOrderType Properties

The properties of the FieldOrderType class are listed below. For a complete list of FieldOrderType class members, see the FieldOrderType Members topic.

Public Instance Properties

Item
Order

See Also

FieldOrderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Item Property

Aspose.Email

FieldOrderType.Item Property

public BasePathToElementType Item {get; set;}

Remarks

See Also

FieldOrderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Order Property

Aspose.Email

FieldOrderType.Order Property

public SortDirectionType Order {get; set;}

Remarks

See Also

FieldOrderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FieldURIOrConstantType Class

For a list of all members of this type, see FieldURIOrConstantType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.FieldURIOrConstantType

public class FieldURIOrConstantType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FieldURIOrConstantType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FieldURIOrConstantType Members

FieldURIOrConstantType overview

Public Instance Constructors

FieldURIOrConstantType Constructor Initializes a new instance of the FieldURIOrConstantType class.

Public Instance Properties

Item

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FieldURIOrConstantType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FieldURIOrConstantType Constructor

Initializes a new instance of the FieldURIOrConstantType class.

public FieldURIOrConstantType();

See Also

FieldURIOrConstantType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FieldURIOrConstantType Properties

The properties of the FieldURIOrConstantType class are listed below. For a complete list of FieldURIOrConstantType class members, see the FieldURIOrConstantType Members topic.

Public Instance Properties

Item

See Also

FieldURIOrConstantType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Item Property

Aspose.Email

FieldURIOrConstantType.Item Property

public object Item {get; set;}

Remarks

See Also

FieldURIOrConstantType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FileAsMappingType Enumeration

public enum FileAsMappingType

Remarks

Members

Member Name | Description | Value
None |  | 0
LastCommaFirst |  | 1
FirstSpaceLast |  | 2
Company |  | 3
LastCommaFirstCompany |  | 4
CompanyLastFirst |  | 5
LastFirst |  | 6
LastFirstCompany |  | 7
CompanyLastCommaFirst |  | 8
LastFirstSuffix |  | 9
LastSpaceFirstCompany |  | 10
CompanyLastSpaceFirst |  | 11
LastSpaceFirst |  | 12
DisplayName |  | 13
FirstName |  | 14
LastFirstMiddleSuffix |  | 15
LastName |  | 16
Empty |  | 17

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FileAttachmentType Class

For a list of all members of this type, see FileAttachmentType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.AttachmentType
Aspose.Email.Exchange.Schema.Exchange_2013.FileAttachmentType

public class FileAttachmentType : AttachmentType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FileAttachmentType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FileAttachmentType Members

FileAttachmentType overview

Public Instance Constructors

FileAttachmentType Constructor Initializes a new instance of the FileAttachmentType class.

Public Instance Properties

AttachmentId (inherited from AttachmentType)
Content
ContentId (inherited from AttachmentType)
ContentLocation (inherited from AttachmentType)
ContentType (inherited from AttachmentType)
IsContactPhoto
IsContactPhotoSpecified
IsInline (inherited from AttachmentType)
IsInlineSpecified (inherited from AttachmentType)
LastModifiedTime (inherited from AttachmentType)
LastModifiedTimeSpecified (inherited from AttachmentType)
Name (inherited from AttachmentType)
Size (inherited from AttachmentType)
SizeSpecified (inherited from AttachmentType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FileAttachmentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FileAttachmentType Constructor

Initializes a new instance of the FileAttachmentType class.

public FileAttachmentType();

See Also

FileAttachmentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FileAttachmentType Properties

The properties of the FileAttachmentType class are listed below. For a complete list of FileAttachmentType class members, see the FileAttachmentType Members topic.

Public Instance Properties

AttachmentId (inherited from AttachmentType)
Content
ContentId (inherited from AttachmentType)
ContentLocation (inherited from AttachmentType)
ContentType (inherited from AttachmentType)
IsContactPhoto
IsContactPhotoSpecified
IsInline (inherited from AttachmentType)
IsInlineSpecified (inherited from AttachmentType)
LastModifiedTime (inherited from AttachmentType)
LastModifiedTimeSpecified (inherited from AttachmentType)
Name (inherited from AttachmentType)
Size (inherited from AttachmentType)
SizeSpecified (inherited from AttachmentType)

See Also

FileAttachmentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Content Property

Aspose.Email

FileAttachmentType.Content Property

public byte[] Content {get; set;}

Remarks

See Also

FileAttachmentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsContactPhoto Property

Aspose.Email

FileAttachmentType.IsContactPhoto Property

public bool IsContactPhoto {get; set;}

Remarks

See Also

FileAttachmentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsContactPhotoSpecified Property

Aspose.Email

FileAttachmentType.IsContactPhotoSpecified Property

public bool IsContactPhotoSpecified {get; set;}

Remarks

See Also

FileAttachmentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindConversationCompletedEventArgs Class

For a list of all members of this type, see FindConversationCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.FindConversationCompletedEventArgs

public class FindConversationCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FindConversationCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindConversationCompletedEventArgs Members

FindConversationCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

FindConversationCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindConversationCompletedEventArgs Properties

The properties of the FindConversationCompletedEventArgs class are listed below. For a complete list of FindConversationCompletedEventArgs class members, see the FindConversationCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

FindConversationCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

FindConversationCompletedEventArgs.Result Property

public FindConversationResponseMessageType Result {get;}

Remarks

See Also

FindConversationCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindConversationCompletedEventHandler Delegate

public delegate void FindConversationCompletedEventHandler(
object sender,
FindConversationCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindConversationResponseMessageType Class

For a list of all members of this type, see FindConversationResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.FindConversationResponseMessageType

public class FindConversationResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FindConversationResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindConversationResponseMessageType Members

FindConversationResponseMessageType overview

Public Instance Constructors

FindConversationResponseMessageType Constructor Initializes a new instance of the FindConversationResponseMessageType class.

Public Instance Properties

Conversations
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
HighlightTerms
IndexedOffset
IndexedOffsetSpecified
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
TotalConversationsInView
TotalConversationsInViewSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FindConversationResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindConversationResponseMessageType Constructor

Initializes a new instance of the FindConversationResponseMessageType class.

public FindConversationResponseMessageType();

See Also

FindConversationResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindConversationResponseMessageType Properties

The properties of the FindConversationResponseMessageType class are listed below. For a complete list of FindConversationResponseMessageType class members, see the FindConversationResponseMessageType Members topic.

Public Instance Properties

Conversations
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
HighlightTerms
IndexedOffset
IndexedOffsetSpecified
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
TotalConversationsInView
TotalConversationsInViewSpecified

See Also

FindConversationResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Conversations Property

Aspose.Email

FindConversationResponseMessageType.Conversations Property

public ConversationType[] Conversations {get; set;}

Remarks

See Also

FindConversationResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


HighlightTerms Property

Aspose.Email

FindConversationResponseMessageType.HighlightTerms Property

public HighlightTermType[] HighlightTerms {get; set;}

Remarks

See Also

FindConversationResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IndexedOffset Property

Aspose.Email

FindConversationResponseMessageType.IndexedOffset Property

public int IndexedOffset {get; set;}

Remarks

See Also

FindConversationResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IndexedOffsetSpecified Property

Aspose.Email

FindConversationResponseMessageType.IndexedOffsetSpecified Property

public bool IndexedOffsetSpecified {get; set;}

Remarks

See Also

FindConversationResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TotalConversationsInView Property

Aspose.Email

FindConversationResponseMessageType.TotalConversationsInView Property

public int TotalConversationsInView {get; set;}

Remarks

See Also

FindConversationResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TotalConversationsInViewSpecified Property

Aspose.Email

FindConversationResponseMessageType.TotalConversationsInViewSpecified Property

public bool TotalConversationsInViewSpecified {get; set;}

Remarks

See Also

FindConversationResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindConversationType Class

For a list of all members of this type, see FindConversationType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.FindConversationType

public class FindConversationType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FindConversationType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindConversationType Members

FindConversationType overview

Public Instance Constructors

FindConversationType Constructor Initializes a new instance of the FindConversationType class.

Public Instance Properties

ConversationShape
Item
MailboxScope
MailboxScopeSpecified
ParentFolderId
QueryString
SortOrder
Traversal
TraversalSpecified
ViewFilter
ViewFilterSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FindConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindConversationType Constructor

Initializes a new instance of the FindConversationType class.

public FindConversationType();

See Also

FindConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindConversationType Properties

The properties of the FindConversationType class are listed below. For a complete list of FindConversationType class members, see the FindConversationType Members topic.

Public Instance Properties

ConversationShape
Item
MailboxScope
MailboxScopeSpecified
ParentFolderId
QueryString
SortOrder
Traversal
TraversalSpecified
ViewFilter
ViewFilterSpecified

See Also

FindConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConversationShape Property

Aspose.Email

FindConversationType.ConversationShape Property

public ConversationResponseShapeType ConversationShape {get; set;}

Remarks

See Also

FindConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Item Property

Aspose.Email

FindConversationType.Item Property

public BasePagingType Item {get; set;}

Remarks

See Also

FindConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxScope Property

Aspose.Email

FindConversationType.MailboxScope Property

public MailboxSearchLocationType MailboxScope {get; set;}

Remarks

See Also

FindConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxScopeSpecified Property

Aspose.Email

FindConversationType.MailboxScopeSpecified Property

public bool MailboxScopeSpecified {get; set;}

Remarks

See Also

FindConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ParentFolderId Property

Aspose.Email

FindConversationType.ParentFolderId Property

public TargetFolderIdType ParentFolderId {get; set;}

Remarks

See Also

FindConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


QueryString Property

Aspose.Email

FindConversationType.QueryString Property

public QueryStringType QueryString {get; set;}

Remarks

See Also

FindConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SortOrder Property

Aspose.Email

FindConversationType.SortOrder Property

public FieldOrderType[] SortOrder {get; set;}

Remarks

See Also

FindConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Traversal Property

Aspose.Email

FindConversationType.Traversal Property

public ConversationQueryTraversalType Traversal {get; set;}

Remarks

See Also

FindConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TraversalSpecified Property

Aspose.Email

FindConversationType.TraversalSpecified Property

public bool TraversalSpecified {get; set;}

Remarks

See Also

FindConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ViewFilter Property

Aspose.Email

FindConversationType.ViewFilter Property

public ViewFilterType ViewFilter {get; set;}

Remarks

See Also

FindConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ViewFilterSpecified Property

Aspose.Email

FindConversationType.ViewFilterSpecified Property

public bool ViewFilterSpecified {get; set;}

Remarks

See Also

FindConversationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindFolderCompletedEventArgs Class

For a list of all members of this type, see FindFolderCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.FindFolderCompletedEventArgs

public class FindFolderCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FindFolderCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindFolderCompletedEventArgs Members

FindFolderCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

FindFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindFolderCompletedEventArgs Properties

The properties of the FindFolderCompletedEventArgs class are listed below. For a complete list of FindFolderCompletedEventArgs class members, see the FindFolderCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

FindFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

FindFolderCompletedEventArgs.Result Property

public FindFolderResponseType Result {get;}

Remarks

See Also

FindFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindFolderCompletedEventHandler Delegate

public delegate void FindFolderCompletedEventHandler(
object sender,
FindFolderCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindFolderParentType Class

For a list of all members of this type, see FindFolderParentType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.FindFolderParentType

public class FindFolderParentType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FindFolderParentType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindFolderParentType Members

FindFolderParentType overview

Public Instance Constructors

FindFolderParentType Constructor Initializes a new instance of the FindFolderParentType class.

Public Instance Properties

AbsoluteDenominator
AbsoluteDenominatorSpecified
Folders
IncludesLastItemInRange
IncludesLastItemInRangeSpecified
IndexedPagingOffset
IndexedPagingOffsetSpecified
NumeratorOffset
NumeratorOffsetSpecified
TotalItemsInView
TotalItemsInViewSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FindFolderParentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindFolderParentType Constructor

Initializes a new instance of the FindFolderParentType class.

public FindFolderParentType();

See Also

FindFolderParentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindFolderParentType Properties

The properties of the FindFolderParentType class are listed below. For a complete list of FindFolderParentType class members, see the FindFolderParentType Members topic.

Public Instance Properties

AbsoluteDenominator
AbsoluteDenominatorSpecified
Folders
IncludesLastItemInRange
IncludesLastItemInRangeSpecified
IndexedPagingOffset
IndexedPagingOffsetSpecified
NumeratorOffset
NumeratorOffsetSpecified
TotalItemsInView
TotalItemsInViewSpecified

See Also

FindFolderParentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AbsoluteDenominator Property

Aspose.Email

FindFolderParentType.AbsoluteDenominator Property

public int AbsoluteDenominator {get; set;}

Remarks

See Also

FindFolderParentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AbsoluteDenominatorSpecified Property

Aspose.Email

FindFolderParentType.AbsoluteDenominatorSpecified Property

public bool AbsoluteDenominatorSpecified {get; set;}

Remarks

See Also

FindFolderParentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Folders Property

Aspose.Email

FindFolderParentType.Folders Property

public BaseFolderType[] Folders {get; set;}

Remarks

See Also

FindFolderParentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IncludesLastItemInRange Property

Aspose.Email

FindFolderParentType.IncludesLastItemInRange Property

public bool IncludesLastItemInRange {get; set;}

Remarks

See Also

FindFolderParentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IncludesLastItemInRangeSpecified Property

Aspose.Email

FindFolderParentType.IncludesLastItemInRangeSpecified Property

public bool IncludesLastItemInRangeSpecified {get; set;}

Remarks

See Also

FindFolderParentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IndexedPagingOffset Property

Aspose.Email

FindFolderParentType.IndexedPagingOffset Property

public int IndexedPagingOffset {get; set;}

Remarks

See Also

FindFolderParentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IndexedPagingOffsetSpecified Property

Aspose.Email

FindFolderParentType.IndexedPagingOffsetSpecified Property

public bool IndexedPagingOffsetSpecified {get; set;}

Remarks

See Also

FindFolderParentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NumeratorOffset Property

Aspose.Email

FindFolderParentType.NumeratorOffset Property

public int NumeratorOffset {get; set;}

Remarks

See Also

FindFolderParentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NumeratorOffsetSpecified Property

Aspose.Email

FindFolderParentType.NumeratorOffsetSpecified Property

public bool NumeratorOffsetSpecified {get; set;}

Remarks

See Also

FindFolderParentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TotalItemsInView Property

Aspose.Email

FindFolderParentType.TotalItemsInView Property

public int TotalItemsInView {get; set;}

Remarks

See Also

FindFolderParentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TotalItemsInViewSpecified Property

Aspose.Email

FindFolderParentType.TotalItemsInViewSpecified Property

public bool TotalItemsInViewSpecified {get; set;}

Remarks

See Also

FindFolderParentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindFolderResponseMessageType Class

For a list of all members of this type, see FindFolderResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.FindFolderResponseMessageType

public class FindFolderResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FindFolderResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindFolderResponseMessageType Members

FindFolderResponseMessageType overview

Public Instance Constructors

FindFolderResponseMessageType Constructor Initializes a new instance of the FindFolderResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
RootFolder

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FindFolderResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindFolderResponseMessageType Constructor

Initializes a new instance of the FindFolderResponseMessageType class.

public FindFolderResponseMessageType();

See Also

FindFolderResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindFolderResponseMessageType Properties

The properties of the FindFolderResponseMessageType class are listed below. For a complete list of FindFolderResponseMessageType class members, see the FindFolderResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
RootFolder

See Also

FindFolderResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RootFolder Property

Aspose.Email

FindFolderResponseMessageType.RootFolder Property

public FindFolderParentType RootFolder {get; set;}

Remarks

See Also

FindFolderResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindFolderResponseType Class

For a list of all members of this type, see FindFolderResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.FindFolderResponseType

public class FindFolderResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FindFolderResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindFolderResponseType Members

FindFolderResponseType overview

Public Instance Constructors

FindFolderResponseType Constructor Initializes a new instance of the FindFolderResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FindFolderResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindFolderResponseType Constructor

Initializes a new instance of the FindFolderResponseType class.

public FindFolderResponseType();

See Also

FindFolderResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindFolderType Class

For a list of all members of this type, see FindFolderType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.FindFolderType

public class FindFolderType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FindFolderType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindFolderType Members

FindFolderType overview

Public Instance Constructors

FindFolderType Constructor Initializes a new instance of the FindFolderType class.

Public Instance Properties

FolderShape
Item
ParentFolderIds
Restriction
Traversal

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FindFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindFolderType Constructor

Initializes a new instance of the FindFolderType class.

public FindFolderType();

See Also

FindFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindFolderType Properties

The properties of the FindFolderType class are listed below. For a complete list of FindFolderType class members, see the FindFolderType Members topic.

Public Instance Properties

FolderShape
Item
ParentFolderIds
Restriction
Traversal

See Also

FindFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FolderShape Property

Aspose.Email

FindFolderType.FolderShape Property

public FolderResponseShapeType FolderShape {get; set;}

Remarks

See Also

FindFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Item Property

Aspose.Email

FindFolderType.Item Property

public BasePagingType Item {get; set;}

Remarks

See Also

FindFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ParentFolderIds Property

Aspose.Email

FindFolderType.ParentFolderIds Property

public BaseFolderIdType[] ParentFolderIds {get; set;}

Remarks

See Also

FindFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Restriction Property

Aspose.Email

FindFolderType.Restriction Property

public RestrictionType Restriction {get; set;}

Remarks

See Also

FindFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Traversal Property

Aspose.Email

FindFolderType.Traversal Property

public FolderQueryTraversalType Traversal {get; set;}

Remarks

See Also

FindFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindItemCompletedEventArgs Class

For a list of all members of this type, see FindItemCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.FindItemCompletedEventArgs

public class FindItemCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FindItemCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindItemCompletedEventArgs Members

FindItemCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

FindItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindItemCompletedEventArgs Properties

The properties of the FindItemCompletedEventArgs class are listed below. For a complete list of FindItemCompletedEventArgs class members, see the FindItemCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

FindItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

FindItemCompletedEventArgs.Result Property

public FindItemResponseType Result {get;}

Remarks

See Also

FindItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindItemCompletedEventHandler Delegate

public delegate void FindItemCompletedEventHandler(
object sender,
FindItemCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindItemParentType Class

For a list of all members of this type, see FindItemParentType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.FindItemParentType

public class FindItemParentType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FindItemParentType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindItemParentType Members

FindItemParentType overview

Public Instance Constructors

FindItemParentType Constructor Initializes a new instance of the FindItemParentType class.

Public Instance Properties

AbsoluteDenominator
AbsoluteDenominatorSpecified
IncludesLastItemInRange
IncludesLastItemInRangeSpecified
IndexedPagingOffset
IndexedPagingOffsetSpecified
Item
NumeratorOffset
NumeratorOffsetSpecified
TotalItemsInView
TotalItemsInViewSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FindItemParentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindItemParentType Constructor

Initializes a new instance of the FindItemParentType class.

public FindItemParentType();

See Also

FindItemParentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindItemParentType Properties

The properties of the FindItemParentType class are listed below. For a complete list of FindItemParentType class members, see the FindItemParentType Members topic.

Public Instance Properties

AbsoluteDenominator
AbsoluteDenominatorSpecified
IncludesLastItemInRange
IncludesLastItemInRangeSpecified
IndexedPagingOffset
IndexedPagingOffsetSpecified
Item
NumeratorOffset
NumeratorOffsetSpecified
TotalItemsInView
TotalItemsInViewSpecified

See Also

FindItemParentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AbsoluteDenominator Property

Aspose.Email

FindItemParentType.AbsoluteDenominator Property

public int AbsoluteDenominator {get; set;}

Remarks

See Also

FindItemParentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AbsoluteDenominatorSpecified Property

Aspose.Email

FindItemParentType.AbsoluteDenominatorSpecified Property

public bool AbsoluteDenominatorSpecified {get; set;}

Remarks

See Also

FindItemParentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IncludesLastItemInRange Property

Aspose.Email

FindItemParentType.IncludesLastItemInRange Property

public bool IncludesLastItemInRange {get; set;}

Remarks

See Also

FindItemParentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IncludesLastItemInRangeSpecified Property

Aspose.Email

FindItemParentType.IncludesLastItemInRangeSpecified Property

public bool IncludesLastItemInRangeSpecified {get; set;}

Remarks

See Also

FindItemParentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IndexedPagingOffset Property

Aspose.Email

FindItemParentType.IndexedPagingOffset Property

public int IndexedPagingOffset {get; set;}

Remarks

See Also

FindItemParentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IndexedPagingOffsetSpecified Property

Aspose.Email

FindItemParentType.IndexedPagingOffsetSpecified Property

public bool IndexedPagingOffsetSpecified {get; set;}

Remarks

See Also

FindItemParentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Item Property

Aspose.Email

FindItemParentType.Item Property

public object Item {get; set;}

Remarks

See Also

FindItemParentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NumeratorOffset Property

Aspose.Email

FindItemParentType.NumeratorOffset Property

public int NumeratorOffset {get; set;}

Remarks

See Also

FindItemParentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NumeratorOffsetSpecified Property

Aspose.Email

FindItemParentType.NumeratorOffsetSpecified Property

public bool NumeratorOffsetSpecified {get; set;}

Remarks

See Also

FindItemParentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TotalItemsInView Property

Aspose.Email

FindItemParentType.TotalItemsInView Property

public int TotalItemsInView {get; set;}

Remarks

See Also

FindItemParentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TotalItemsInViewSpecified Property

Aspose.Email

FindItemParentType.TotalItemsInViewSpecified Property

public bool TotalItemsInViewSpecified {get; set;}

Remarks

See Also

FindItemParentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindItemResponseMessageType Class

For a list of all members of this type, see FindItemResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.FindItemResponseMessageType

public class FindItemResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FindItemResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindItemResponseMessageType Members

FindItemResponseMessageType overview

Public Instance Constructors

FindItemResponseMessageType Constructor Initializes a new instance of the FindItemResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
HighlightTerms
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
RootFolder

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FindItemResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindItemResponseMessageType Constructor

Initializes a new instance of the FindItemResponseMessageType class.

public FindItemResponseMessageType();

See Also

FindItemResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindItemResponseMessageType Properties

The properties of the FindItemResponseMessageType class are listed below. For a complete list of FindItemResponseMessageType class members, see the FindItemResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
HighlightTerms
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
RootFolder

See Also

FindItemResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


HighlightTerms Property

Aspose.Email

FindItemResponseMessageType.HighlightTerms Property

public HighlightTermType[] HighlightTerms {get; set;}

Remarks

See Also

FindItemResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RootFolder Property

Aspose.Email

FindItemResponseMessageType.RootFolder Property

public FindItemParentType RootFolder {get; set;}

Remarks

See Also

FindItemResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindItemResponseType Class

For a list of all members of this type, see FindItemResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.FindItemResponseType

public class FindItemResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FindItemResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindItemResponseType Members

FindItemResponseType overview

Public Instance Constructors

FindItemResponseType Constructor Initializes a new instance of the FindItemResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FindItemResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindItemResponseType Constructor

Initializes a new instance of the FindItemResponseType class.

public FindItemResponseType();

See Also

FindItemResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindItemType Class

For a list of all members of this type, see FindItemType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.FindItemType

public class FindItemType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FindItemType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindItemType Members

FindItemType overview

Public Instance Constructors

FindItemType Constructor Initializes a new instance of the FindItemType class.

Public Instance Properties

Item
Item1
ItemShape
ParentFolderIds
QueryString
Restriction
SortOrder
Traversal

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FindItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindItemType Constructor

Initializes a new instance of the FindItemType class.

public FindItemType();

See Also

FindItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindItemType Properties

The properties of the FindItemType class are listed below. For a complete list of FindItemType class members, see the FindItemType Members topic.

Public Instance Properties

Item
Item1
ItemShape
ParentFolderIds
QueryString
Restriction
SortOrder
Traversal

See Also

FindItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Item Property

Aspose.Email

FindItemType.Item Property

public BasePagingType Item {get; set;}

Remarks

See Also

FindItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Item1 Property

Aspose.Email

FindItemType.Item1 Property

public BaseGroupByType Item1 {get; set;}

Remarks

See Also

FindItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemShape Property

Aspose.Email

FindItemType.ItemShape Property

public ItemResponseShapeType ItemShape {get; set;}

Remarks

See Also

FindItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ParentFolderIds Property

Aspose.Email

FindItemType.ParentFolderIds Property

public BaseFolderIdType[] ParentFolderIds {get; set;}

Remarks

See Also

FindItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


QueryString Property

Aspose.Email

FindItemType.QueryString Property

public QueryStringType QueryString {get; set;}

Remarks

See Also

FindItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Restriction Property

Aspose.Email

FindItemType.Restriction Property

public RestrictionType Restriction {get; set;}

Remarks

See Also

FindItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SortOrder Property

Aspose.Email

FindItemType.SortOrder Property

public FieldOrderType[] SortOrder {get; set;}

Remarks

See Also

FindItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Traversal Property

Aspose.Email

FindItemType.Traversal Property

public ItemQueryTraversalType Traversal {get; set;}

Remarks

See Also

FindItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindMailboxStatisticsByKeywordsResponseMessageType Class

For a list of all members of this type, see FindMailboxStatisticsByKeywordsResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.FindMailboxStatisticsByKeywordsResponseMessageType

public class FindMailboxStatisticsByKeywordsResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FindMailboxStatisticsByKeywordsResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindMailboxStatisticsByKeywordsResponseMessageType Members

FindMailboxStatisticsByKeywordsResponseMessageType overview

Public Instance Constructors

FindMailboxStatisticsByKeywordsResponseMessageType Constructor Initializes a new instance of the FindMailboxStatisticsByKeywordsResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MailboxStatisticsSearchResult
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FindMailboxStatisticsByKeywordsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindMailboxStatisticsByKeywordsResponseMessageType Constructor

Initializes a new instance of the FindMailboxStatisticsByKeywordsResponseMessageType class.

public FindMailboxStatisticsByKeywordsResponseMessageType();

See Also

FindMailboxStatisticsByKeywordsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindMailboxStatisticsByKeywordsResponseMessageType Properties

The properties of the FindMailboxStatisticsByKeywordsResponseMessageType class are listed below. For a complete list of FindMailboxStatisticsByKeywordsResponseMessageType class members, see the FindMailboxStatisticsByKeywordsResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MailboxStatisticsSearchResult
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

FindMailboxStatisticsByKeywordsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxStatisticsSearchResult Property

Aspose.Email

FindMailboxStatisticsByKeywordsResponseMessageType.MailboxStatisticsSearchResult Property

public MailboxStatisticsSearchResultType MailboxStatisticsSearchResult {get; set;}

Remarks

See Also

FindMailboxStatisticsByKeywordsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindMailboxStatisticsByKeywordsResponseType Class

For a list of all members of this type, see FindMailboxStatisticsByKeywordsResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.FindMailboxStatisticsByKeywordsResponseType

public class FindMailboxStatisticsByKeywordsResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FindMailboxStatisticsByKeywordsResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindMailboxStatisticsByKeywordsResponseType Members

FindMailboxStatisticsByKeywordsResponseType overview

Public Instance Constructors

FindMailboxStatisticsByKeywordsResponseType Constructor Initializes a new instance of the FindMailboxStatisticsByKeywordsResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FindMailboxStatisticsByKeywordsResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindMailboxStatisticsByKeywordsResponseType Constructor

Initializes a new instance of the FindMailboxStatisticsByKeywordsResponseType class.

public FindMailboxStatisticsByKeywordsResponseType();

See Also

FindMailboxStatisticsByKeywordsResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindMailboxStatisticsByKeywordsType Class

For a list of all members of this type, see FindMailboxStatisticsByKeywordsType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.FindMailboxStatisticsByKeywordsType

public class FindMailboxStatisticsByKeywordsType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FindMailboxStatisticsByKeywordsType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindMailboxStatisticsByKeywordsType Members

FindMailboxStatisticsByKeywordsType overview

Public Instance Constructors

FindMailboxStatisticsByKeywordsType Constructor Initializes a new instance of the FindMailboxStatisticsByKeywordsType class.

Public Instance Properties

FromDate
FromDateSpecified
IncludePersonalArchive
IncludePersonalArchiveSpecified
IncludeUnsearchableItems
IncludeUnsearchableItemsSpecified
Keywords
Language
Mailboxes
MessageTypes
Recipients
SearchDumpster
SearchDumpsterSpecified
Senders
ToDate
ToDateSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FindMailboxStatisticsByKeywordsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindMailboxStatisticsByKeywordsType Constructor

Initializes a new instance of the FindMailboxStatisticsByKeywordsType class.

public FindMailboxStatisticsByKeywordsType();

See Also

FindMailboxStatisticsByKeywordsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindMailboxStatisticsByKeywordsType Properties

The properties of the FindMailboxStatisticsByKeywordsType class are listed below. For a complete list of FindMailboxStatisticsByKeywordsType class members, see the FindMailboxStatisticsByKeywordsType Members topic.

Public Instance Properties

FromDate
FromDateSpecified
IncludePersonalArchive
IncludePersonalArchiveSpecified
IncludeUnsearchableItems
IncludeUnsearchableItemsSpecified
Keywords
Language
Mailboxes
MessageTypes
Recipients
SearchDumpster
SearchDumpsterSpecified
Senders
ToDate
ToDateSpecified

See Also

FindMailboxStatisticsByKeywordsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FromDate Property

Aspose.Email

FindMailboxStatisticsByKeywordsType.FromDate Property

public DateTime FromDate {get; set;}

Remarks

See Also

FindMailboxStatisticsByKeywordsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FromDateSpecified Property

Aspose.Email

FindMailboxStatisticsByKeywordsType.FromDateSpecified Property

public bool FromDateSpecified {get; set;}

Remarks

See Also

FindMailboxStatisticsByKeywordsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IncludePersonalArchive Property

Aspose.Email

FindMailboxStatisticsByKeywordsType.IncludePersonalArchive Property

public bool IncludePersonalArchive {get; set;}

Remarks

See Also

FindMailboxStatisticsByKeywordsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IncludePersonalArchiveSpecified Property

Aspose.Email

FindMailboxStatisticsByKeywordsType.IncludePersonalArchiveSpecified Property

public bool IncludePersonalArchiveSpecified {get; set;}

Remarks

See Also

FindMailboxStatisticsByKeywordsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IncludeUnsearchableItems Property

Aspose.Email

FindMailboxStatisticsByKeywordsType.IncludeUnsearchableItems Property

public bool IncludeUnsearchableItems {get; set;}

Remarks

See Also

FindMailboxStatisticsByKeywordsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IncludeUnsearchableItemsSpecified Property

Aspose.Email

FindMailboxStatisticsByKeywordsType.IncludeUnsearchableItemsSpecified Property

public bool IncludeUnsearchableItemsSpecified {get; set;}

Remarks

See Also

FindMailboxStatisticsByKeywordsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Keywords Property

Aspose.Email

FindMailboxStatisticsByKeywordsType.Keywords Property

public string[] Keywords {get; set;}

Remarks

See Also

FindMailboxStatisticsByKeywordsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Language Property

Aspose.Email

FindMailboxStatisticsByKeywordsType.Language Property

public string Language {get; set;}

Remarks

See Also

FindMailboxStatisticsByKeywordsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Mailboxes Property

Aspose.Email

FindMailboxStatisticsByKeywordsType.Mailboxes Property

public UserMailboxType[] Mailboxes {get; set;}

Remarks

See Also

FindMailboxStatisticsByKeywordsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MessageTypes Property

Aspose.Email

FindMailboxStatisticsByKeywordsType.MessageTypes Property

public SearchItemKindType[] MessageTypes {get; set;}

Remarks

See Also

FindMailboxStatisticsByKeywordsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Recipients Property

Aspose.Email

FindMailboxStatisticsByKeywordsType.Recipients Property

public string[] Recipients {get; set;}

Remarks

See Also

FindMailboxStatisticsByKeywordsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchDumpster Property

Aspose.Email

FindMailboxStatisticsByKeywordsType.SearchDumpster Property

public bool SearchDumpster {get; set;}

Remarks

See Also

FindMailboxStatisticsByKeywordsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchDumpsterSpecified Property

Aspose.Email

FindMailboxStatisticsByKeywordsType.SearchDumpsterSpecified Property

public bool SearchDumpsterSpecified {get; set;}

Remarks

See Also

FindMailboxStatisticsByKeywordsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Senders Property

Aspose.Email

FindMailboxStatisticsByKeywordsType.Senders Property

public string[] Senders {get; set;}

Remarks

See Also

FindMailboxStatisticsByKeywordsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ToDate Property

Aspose.Email

FindMailboxStatisticsByKeywordsType.ToDate Property

public DateTime ToDate {get; set;}

Remarks

See Also

FindMailboxStatisticsByKeywordsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ToDateSpecified Property

Aspose.Email

FindMailboxStatisticsByKeywordsType.ToDateSpecified Property

public bool ToDateSpecified {get; set;}

Remarks

See Also

FindMailboxStatisticsByKeywordsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindMessageTrackingReportCompletedEventArgs Class

For a list of all members of this type, see FindMessageTrackingReportCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.FindMessageTrackingReportCompletedEventArgs

public class FindMessageTrackingReportCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FindMessageTrackingReportCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindMessageTrackingReportCompletedEventArgs Members

FindMessageTrackingReportCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

FindMessageTrackingReportCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindMessageTrackingReportCompletedEventArgs Properties

The properties of the FindMessageTrackingReportCompletedEventArgs class are listed below. For a complete list of FindMessageTrackingReportCompletedEventArgs class members, see the FindMessageTrackingReportCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

FindMessageTrackingReportCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

FindMessageTrackingReportCompletedEventArgs.Result Property

public FindMessageTrackingReportResponseMessageType Result {get;}

Remarks

See Also

FindMessageTrackingReportCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindMessageTrackingReportCompletedEventHandler Delegate

public delegate void FindMessageTrackingReportCompletedEventHandler(
object sender,
FindMessageTrackingReportCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindMessageTrackingReportRequestType Class

For a list of all members of this type, see FindMessageTrackingReportRequestType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.FindMessageTrackingReportRequestType

public class FindMessageTrackingReportRequestType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FindMessageTrackingReportRequestType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindMessageTrackingReportRequestType Members

FindMessageTrackingReportRequestType overview

Public Instance Constructors

FindMessageTrackingReportRequestType Constructor Initializes a new instance of the FindMessageTrackingReportRequestType class.

Public Instance Properties

DiagnosticsLevel
Domain
EndDateTime
EndDateTimeSpecified
FederatedDeliveryMailbox
MessageId
Properties
PurportedSender
Recipient
Scope
Sender
ServerHint
StartDateTime
StartDateTimeSpecified
Subject

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FindMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindMessageTrackingReportRequestType Constructor

Initializes a new instance of the FindMessageTrackingReportRequestType class.

public FindMessageTrackingReportRequestType();

See Also

FindMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindMessageTrackingReportRequestType Properties

The properties of the FindMessageTrackingReportRequestType class are listed below. For a complete list of FindMessageTrackingReportRequestType class members, see the FindMessageTrackingReportRequestType Members topic.

Public Instance Properties

DiagnosticsLevel
Domain
EndDateTime
EndDateTimeSpecified
FederatedDeliveryMailbox
MessageId
Properties
PurportedSender
Recipient
Scope
Sender
ServerHint
StartDateTime
StartDateTimeSpecified
Subject

See Also

FindMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DiagnosticsLevel Property

Aspose.Email

FindMessageTrackingReportRequestType.DiagnosticsLevel Property

public string DiagnosticsLevel {get; set;}

Remarks

See Also

FindMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Domain Property

Aspose.Email

FindMessageTrackingReportRequestType.Domain Property

public string Domain {get; set;}

Remarks

See Also

FindMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EndDateTime Property

Aspose.Email

FindMessageTrackingReportRequestType.EndDateTime Property

public DateTime EndDateTime {get; set;}

Remarks

See Also

FindMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EndDateTimeSpecified Property

Aspose.Email

FindMessageTrackingReportRequestType.EndDateTimeSpecified Property

public bool EndDateTimeSpecified {get; set;}

Remarks

See Also

FindMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FederatedDeliveryMailbox Property

Aspose.Email

FindMessageTrackingReportRequestType.FederatedDeliveryMailbox Property

public EmailAddressType FederatedDeliveryMailbox {get; set;}

Remarks

See Also

FindMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MessageId Property

Aspose.Email

FindMessageTrackingReportRequestType.MessageId Property

public string MessageId {get; set;}

Remarks

See Also

FindMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Properties Property

Aspose.Email

FindMessageTrackingReportRequestType.Properties Property

public TrackingPropertyType[] Properties {get; set;}

Remarks

See Also

FindMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PurportedSender Property

Aspose.Email

FindMessageTrackingReportRequestType.PurportedSender Property

public EmailAddressType PurportedSender {get; set;}

Remarks

See Also

FindMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Recipient Property

Aspose.Email

FindMessageTrackingReportRequestType.Recipient Property

public EmailAddressType Recipient {get; set;}

Remarks

See Also

FindMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Scope Property

Aspose.Email

FindMessageTrackingReportRequestType.Scope Property

public string Scope {get; set;}

Remarks

See Also

FindMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Sender Property

Aspose.Email

FindMessageTrackingReportRequestType.Sender Property

public EmailAddressType Sender {get; set;}

Remarks

See Also

FindMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ServerHint Property

Aspose.Email

FindMessageTrackingReportRequestType.ServerHint Property

public string ServerHint {get; set;}

Remarks

See Also

FindMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StartDateTime Property

Aspose.Email

FindMessageTrackingReportRequestType.StartDateTime Property

public DateTime StartDateTime {get; set;}

Remarks

See Also

FindMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StartDateTimeSpecified Property

Aspose.Email

FindMessageTrackingReportRequestType.StartDateTimeSpecified Property

public bool StartDateTimeSpecified {get; set;}

Remarks

See Also

FindMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Subject Property

Aspose.Email

FindMessageTrackingReportRequestType.Subject Property

public string Subject {get; set;}

Remarks

See Also

FindMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindMessageTrackingReportResponseMessageType Class

For a list of all members of this type, see FindMessageTrackingReportResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.FindMessageTrackingReportResponseMessageType

public class FindMessageTrackingReportResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FindMessageTrackingReportResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindMessageTrackingReportResponseMessageType Members

FindMessageTrackingReportResponseMessageType overview

Public Instance Constructors

FindMessageTrackingReportResponseMessageType Constructor Initializes a new instance of the FindMessageTrackingReportResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
Diagnostics
Errors
ExecutedSearchScope
MessageText (inherited from ResponseMessageType)
MessageTrackingSearchResults
MessageXml (inherited from ResponseMessageType)
Properties
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FindMessageTrackingReportResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindMessageTrackingReportResponseMessageType Constructor

Initializes a new instance of the FindMessageTrackingReportResponseMessageType class.

public FindMessageTrackingReportResponseMessageType();

See Also

FindMessageTrackingReportResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindMessageTrackingReportResponseMessageType Properties

The properties of the FindMessageTrackingReportResponseMessageType class are listed below. For a complete list of FindMessageTrackingReportResponseMessageType class members, see the FindMessageTrackingReportResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
Diagnostics
Errors
ExecutedSearchScope
MessageText (inherited from ResponseMessageType)
MessageTrackingSearchResults
MessageXml (inherited from ResponseMessageType)
Properties
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

FindMessageTrackingReportResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Diagnostics Property

Aspose.Email

FindMessageTrackingReportResponseMessageType.Diagnostics Property

public string[] Diagnostics {get; set;}

Remarks

See Also

FindMessageTrackingReportResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Errors Property

Aspose.Email

FindMessageTrackingReportResponseMessageType.Errors Property

public ArrayOfTrackingPropertiesType[] Errors {get; set;}

Remarks

See Also

FindMessageTrackingReportResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExecutedSearchScope Property

Aspose.Email

FindMessageTrackingReportResponseMessageType.ExecutedSearchScope Property

public string ExecutedSearchScope {get; set;}

Remarks

See Also

FindMessageTrackingReportResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MessageTrackingSearchResults Property

Aspose.Email

FindMessageTrackingReportResponseMessageType.MessageTrackingSearchResults Property

public FindMessageTrackingSearchResultType[] MessageTrackingSearchResults {get; set;}

Remarks

See Also

FindMessageTrackingReportResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Properties Property

Aspose.Email

FindMessageTrackingReportResponseMessageType.Properties Property

public TrackingPropertyType[] Properties {get; set;}

Remarks

See Also

FindMessageTrackingReportResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindMessageTrackingSearchResultType Class

For a list of all members of this type, see FindMessageTrackingSearchResultType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.FindMessageTrackingSearchResultType

public class FindMessageTrackingSearchResultType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FindMessageTrackingSearchResultType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindMessageTrackingSearchResultType Members

FindMessageTrackingSearchResultType overview

Public Instance Constructors

FindMessageTrackingSearchResultType Constructor Initializes a new instance of the FindMessageTrackingSearchResultType class.

Public Instance Properties

FirstHopServer
MessageTrackingReportId
PreviousHopServer
Properties
PurportedSender
Recipients
Sender
Subject
SubmittedTime

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FindMessageTrackingSearchResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindMessageTrackingSearchResultType Constructor

Initializes a new instance of the FindMessageTrackingSearchResultType class.

public FindMessageTrackingSearchResultType();

See Also

FindMessageTrackingSearchResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindMessageTrackingSearchResultType Properties

The properties of the FindMessageTrackingSearchResultType class are listed below. For a complete list of FindMessageTrackingSearchResultType class members, see the FindMessageTrackingSearchResultType Members topic.

Public Instance Properties

FirstHopServer
MessageTrackingReportId
PreviousHopServer
Properties
PurportedSender
Recipients
Sender
Subject
SubmittedTime

See Also

FindMessageTrackingSearchResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FirstHopServer Property

Aspose.Email

FindMessageTrackingSearchResultType.FirstHopServer Property

public string FirstHopServer {get; set;}

Remarks

See Also

FindMessageTrackingSearchResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MessageTrackingReportId Property

Aspose.Email

FindMessageTrackingSearchResultType.MessageTrackingReportId Property

public string MessageTrackingReportId {get; set;}

Remarks

See Also

FindMessageTrackingSearchResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PreviousHopServer Property

Aspose.Email

FindMessageTrackingSearchResultType.PreviousHopServer Property

public string PreviousHopServer {get; set;}

Remarks

See Also

FindMessageTrackingSearchResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Properties Property

Aspose.Email

FindMessageTrackingSearchResultType.Properties Property

public TrackingPropertyType[] Properties {get; set;}

Remarks

See Also

FindMessageTrackingSearchResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PurportedSender Property

Aspose.Email

FindMessageTrackingSearchResultType.PurportedSender Property

public EmailAddressType PurportedSender {get; set;}

Remarks

See Also

FindMessageTrackingSearchResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Recipients Property

Aspose.Email

FindMessageTrackingSearchResultType.Recipients Property

public EmailAddressType[] Recipients {get; set;}

Remarks

See Also

FindMessageTrackingSearchResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Sender Property

Aspose.Email

FindMessageTrackingSearchResultType.Sender Property

public EmailAddressType Sender {get; set;}

Remarks

See Also

FindMessageTrackingSearchResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Subject Property

Aspose.Email

FindMessageTrackingSearchResultType.Subject Property

public string Subject {get; set;}

Remarks

See Also

FindMessageTrackingSearchResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SubmittedTime Property

Aspose.Email

FindMessageTrackingSearchResultType.SubmittedTime Property

public DateTime SubmittedTime {get; set;}

Remarks

See Also

FindMessageTrackingSearchResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindPeopleCompletedEventArgs Class

For a list of all members of this type, see FindPeopleCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.FindPeopleCompletedEventArgs

public class FindPeopleCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FindPeopleCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindPeopleCompletedEventArgs Members

FindPeopleCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

FindPeopleCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindPeopleCompletedEventArgs Properties

The properties of the FindPeopleCompletedEventArgs class are listed below. For a complete list of FindPeopleCompletedEventArgs class members, see the FindPeopleCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

FindPeopleCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

FindPeopleCompletedEventArgs.Result Property

public FindPeopleResponseMessageType Result {get;}

Remarks

See Also

FindPeopleCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindPeopleCompletedEventHandler Delegate

public delegate void FindPeopleCompletedEventHandler(
object sender,
FindPeopleCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindPeopleResponseMessageType Class

For a list of all members of this type, see FindPeopleResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.FindPeopleResponseMessageType

public class FindPeopleResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FindPeopleResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindPeopleResponseMessageType Members

FindPeopleResponseMessageType overview

Public Instance Constructors

FindPeopleResponseMessageType Constructor Initializes a new instance of the FindPeopleResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
People
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
TotalNumberOfPeopleInView
TotalNumberOfPeopleInViewSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FindPeopleResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindPeopleResponseMessageType Constructor

Initializes a new instance of the FindPeopleResponseMessageType class.

public FindPeopleResponseMessageType();

See Also

FindPeopleResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindPeopleResponseMessageType Properties

The properties of the FindPeopleResponseMessageType class are listed below. For a complete list of FindPeopleResponseMessageType class members, see the FindPeopleResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
People
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
TotalNumberOfPeopleInView
TotalNumberOfPeopleInViewSpecified

See Also

FindPeopleResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


People Property

Aspose.Email

FindPeopleResponseMessageType.People Property

public PersonaType[] People {get; set;}

Remarks

See Also

FindPeopleResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TotalNumberOfPeopleInView Property

Aspose.Email

FindPeopleResponseMessageType.TotalNumberOfPeopleInView Property

public int TotalNumberOfPeopleInView {get; set;}

Remarks

See Also

FindPeopleResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TotalNumberOfPeopleInViewSpecified Property

Aspose.Email

FindPeopleResponseMessageType.TotalNumberOfPeopleInViewSpecified Property

public bool TotalNumberOfPeopleInViewSpecified {get; set;}

Remarks

See Also

FindPeopleResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindPeopleType Class

For a list of all members of this type, see FindPeopleType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.FindPeopleType

public class FindPeopleType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FindPeopleType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindPeopleType Members

FindPeopleType overview

Public Instance Constructors

FindPeopleType Constructor Initializes a new instance of the FindPeopleType class.

Public Instance Properties

AggregationRestriction
IndexedPageItemView
ParentFolderId
PersonaShape
QueryString
Restriction
SortOrder

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FindPeopleType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindPeopleType Constructor

Initializes a new instance of the FindPeopleType class.

public FindPeopleType();

See Also

FindPeopleType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FindPeopleType Properties

The properties of the FindPeopleType class are listed below. For a complete list of FindPeopleType class members, see the FindPeopleType Members topic.

Public Instance Properties

AggregationRestriction
IndexedPageItemView
ParentFolderId
PersonaShape
QueryString
Restriction
SortOrder

See Also

FindPeopleType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AggregationRestriction Property

Aspose.Email

FindPeopleType.AggregationRestriction Property

public RestrictionType AggregationRestriction {get; set;}

Remarks

See Also

FindPeopleType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IndexedPageItemView Property

Aspose.Email

FindPeopleType.IndexedPageItemView Property

public IndexedPageViewType IndexedPageItemView {get; set;}

Remarks

See Also

FindPeopleType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ParentFolderId Property

Aspose.Email

FindPeopleType.ParentFolderId Property

public TargetFolderIdType ParentFolderId {get; set;}

Remarks

See Also

FindPeopleType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PersonaShape Property

Aspose.Email

FindPeopleType.PersonaShape Property

public PersonaResponseShapeType PersonaShape {get; set;}

Remarks

See Also

FindPeopleType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


QueryString Property

Aspose.Email

FindPeopleType.QueryString Property

public string QueryString {get; set;}

Remarks

See Also

FindPeopleType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Restriction Property

Aspose.Email

FindPeopleType.Restriction Property

public RestrictionType Restriction {get; set;}

Remarks

See Also

FindPeopleType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SortOrder Property

Aspose.Email

FindPeopleType.SortOrder Property

public FieldOrderType[] SortOrder {get; set;}

Remarks

See Also

FindPeopleType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FlaggedForActionType Enumeration

public enum FlaggedForActionType

Remarks

Members

Member Name | Description | Value
Any |  | 0
Call |  | 1
DoNotForward |  | 2
FollowUp |  | 3
FYI |  | 4
Forward |  | 5
NoResponseNecessary |  | 6
Read |  | 7
Reply |  | 8
ReplyToAll |  | 9
Review |  | 10

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FlagStatusType Enumeration

public enum FlagStatusType

Remarks

Members

Member Name | Description | Value
NotFlagged |  | 0
Flagged |  | 1
Complete |  | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FlagType Class

For a list of all members of this type, see FlagType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.FlagType

public class FlagType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FlagType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FlagType Members

FlagType overview

Public Instance Constructors

FlagType Constructor Initializes a new instance of the FlagType class.

Public Instance Properties

CompleteDate
CompleteDateSpecified
DueDate
DueDateSpecified
FlagStatus
StartDate
StartDateSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FlagType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FlagType Constructor

Initializes a new instance of the FlagType class.

public FlagType();

See Also

FlagType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FlagType Properties

The properties of the FlagType class are listed below. For a complete list of FlagType class members, see the FlagType Members topic.

Public Instance Properties

CompleteDate
CompleteDateSpecified
DueDate
DueDateSpecified
FlagStatus
StartDate
StartDateSpecified

See Also

FlagType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CompleteDate Property

Aspose.Email

FlagType.CompleteDate Property

public DateTime CompleteDate {get; set;}

Remarks

See Also

FlagType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CompleteDateSpecified Property

Aspose.Email

FlagType.CompleteDateSpecified Property

public bool CompleteDateSpecified {get; set;}

Remarks

See Also

FlagType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DueDate Property

Aspose.Email

FlagType.DueDate Property

public DateTime DueDate {get; set;}

Remarks

See Also

FlagType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DueDateSpecified Property

Aspose.Email

FlagType.DueDateSpecified Property

public bool DueDateSpecified {get; set;}

Remarks

See Also

FlagType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FlagStatus Property

Aspose.Email

FlagType.FlagStatus Property

public FlagStatusType FlagStatus {get; set;}

Remarks

See Also

FlagType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StartDate Property

Aspose.Email

FlagType.StartDate Property

public DateTime StartDate {get; set;}

Remarks

See Also

FlagType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StartDateSpecified Property

Aspose.Email

FlagType.StartDateSpecified Property

public bool StartDateSpecified {get; set;}

Remarks

See Also

FlagType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FolderChangeDescriptionType Class

For a list of all members of this type, see FolderChangeDescriptionType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ChangeDescriptionType
Aspose.Email.Exchange.Schema.Exchange_2013.FolderChangeDescriptionType
Aspose.Email.Exchange.Schema.Exchange_2013.AppendToFolderFieldType
Aspose.Email.Exchange.Schema.Exchange_2013.DeleteFolderFieldType
Aspose.Email.Exchange.Schema.Exchange_2013.SetFolderFieldType

public class FolderChangeDescriptionType : ChangeDescriptionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FolderChangeDescriptionType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FolderChangeDescriptionType Members

FolderChangeDescriptionType overview

Public Instance Constructors

FolderChangeDescriptionType Constructor Initializes a new instance of the FolderChangeDescriptionType class.

Public Instance Properties

Item (inherited from ChangeDescriptionType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FolderChangeDescriptionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FolderChangeDescriptionType Constructor

Initializes a new instance of the FolderChangeDescriptionType class.

public FolderChangeDescriptionType();

See Also

FolderChangeDescriptionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FolderChangeType Class

For a list of all members of this type, see FolderChangeType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.FolderChangeType

public class FolderChangeType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FolderChangeType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FolderChangeType Members

FolderChangeType overview

Public Instance Constructors

FolderChangeType Constructor Initializes a new instance of the FolderChangeType class.

Public Instance Properties

Item
Updates

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FolderChangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FolderChangeType Constructor

Initializes a new instance of the FolderChangeType class.

public FolderChangeType();

See Also

FolderChangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FolderChangeType Properties

The properties of the FolderChangeType class are listed below. For a complete list of FolderChangeType class members, see the FolderChangeType Members topic.

Public Instance Properties

Item
Updates

See Also

FolderChangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Item Property

Aspose.Email

FolderChangeType.Item Property

public BaseFolderIdType Item {get; set;}

Remarks

See Also

FolderChangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Updates Property

Aspose.Email

FolderChangeType.Updates Property

public FolderChangeDescriptionType[] Updates {get; set;}

Remarks

See Also

FolderChangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FolderIdType Class

For a list of all members of this type, see FolderIdType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseFolderIdType
Aspose.Email.Exchange.Schema.Exchange_2013.FolderIdType

public class FolderIdType : BaseFolderIdType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FolderIdType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FolderIdType Members

FolderIdType overview

Public Instance Constructors

FolderIdType Constructor Initializes a new instance of the FolderIdType class.

Public Instance Properties

ChangeKey
Id

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FolderIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FolderIdType Constructor

Initializes a new instance of the FolderIdType class.

public FolderIdType();

See Also

FolderIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FolderIdType Properties

The properties of the FolderIdType class are listed below. For a complete list of FolderIdType class members, see the FolderIdType Members topic.

Public Instance Properties

ChangeKey
Id

See Also

FolderIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ChangeKey Property

Aspose.Email

FolderIdType.ChangeKey Property

public string ChangeKey {get; set;}

Remarks

See Also

FolderIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Id Property

Aspose.Email

FolderIdType.Id Property

public string Id {get; set;}

Remarks

See Also

FolderIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FolderInfoResponseMessageType Class

For a list of all members of this type, see FolderInfoResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.FolderInfoResponseMessageType

public class FolderInfoResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FolderInfoResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FolderInfoResponseMessageType Members

FolderInfoResponseMessageType overview

Public Instance Constructors

FolderInfoResponseMessageType Constructor Initializes a new instance of the FolderInfoResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
Folders
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FolderInfoResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FolderInfoResponseMessageType Constructor

Initializes a new instance of the FolderInfoResponseMessageType class.

public FolderInfoResponseMessageType();

See Also

FolderInfoResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FolderInfoResponseMessageType Properties

The properties of the FolderInfoResponseMessageType class are listed below. For a complete list of FolderInfoResponseMessageType class members, see the FolderInfoResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
Folders
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

FolderInfoResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Folders Property

Aspose.Email

FolderInfoResponseMessageType.Folders Property

public BaseFolderType[] Folders {get; set;}

Remarks

See Also

FolderInfoResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FolderQueryTraversalType Enumeration

public enum FolderQueryTraversalType

Remarks

Members

Member Name | Description | Value
Shallow |  | 0
Deep |  | 1
SoftDeleted |  | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FolderResponseShapeType Class

For a list of all members of this type, see FolderResponseShapeType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.FolderResponseShapeType

public class FolderResponseShapeType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FolderResponseShapeType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FolderResponseShapeType Members

FolderResponseShapeType overview

Public Instance Constructors

FolderResponseShapeType Constructor Initializes a new instance of the FolderResponseShapeType class.

Public Instance Properties

AdditionalProperties
BaseShape

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FolderResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FolderResponseShapeType Constructor

Initializes a new instance of the FolderResponseShapeType class.

public FolderResponseShapeType();

See Also

FolderResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FolderResponseShapeType Properties

The properties of the FolderResponseShapeType class are listed below. For a complete list of FolderResponseShapeType class members, see the FolderResponseShapeType Members topic.

Public Instance Properties

AdditionalProperties
BaseShape

See Also

FolderResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AdditionalProperties Property

Aspose.Email

FolderResponseShapeType.AdditionalProperties Property

public BasePathToElementType[] AdditionalProperties {get; set;}

Remarks

See Also

FolderResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseShape Property

Aspose.Email

FolderResponseShapeType.BaseShape Property

public DefaultShapeNamesType BaseShape {get; set;}

Remarks

See Also

FolderResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FolderType Class

For a list of all members of this type, see FolderType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseFolderType
Aspose.Email.Exchange.Schema.Exchange_2013.FolderType
Aspose.Email.Exchange.Schema.Exchange_2013.SearchFolderType
Aspose.Email.Exchange.Schema.Exchange_2013.TasksFolderType

public class FolderType : BaseFolderType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FolderType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FolderType Members

FolderType overview

Public Instance Constructors

FolderType Constructor Initializes a new instance of the FolderType class.

Public Instance Properties

ArchiveTag (inherited from BaseFolderType)
ChildFolderCount (inherited from BaseFolderType)
ChildFolderCountSpecified (inherited from BaseFolderType)
DisplayName (inherited from BaseFolderType)
DistinguishedFolderId (inherited from BaseFolderType)
DistinguishedFolderIdSpecified (inherited from BaseFolderType)
EffectiveRights (inherited from BaseFolderType)
ExtendedProperty (inherited from BaseFolderType)
FolderClass (inherited from BaseFolderType)
FolderId (inherited from BaseFolderType)
ManagedFolderInformation (inherited from BaseFolderType)
ParentFolderId (inherited from BaseFolderType)
PermissionSet
PolicyTag (inherited from BaseFolderType)
TotalCount (inherited from BaseFolderType)
TotalCountSpecified (inherited from BaseFolderType)
UnreadCount
UnreadCountSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FolderType Constructor

Initializes a new instance of the FolderType class.

public FolderType();

See Also

FolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FolderType Properties

The properties of the FolderType class are listed below. For a complete list of FolderType class members, see the FolderType Members topic.

Public Instance Properties

ArchiveTag (inherited from BaseFolderType)
ChildFolderCount (inherited from BaseFolderType)
ChildFolderCountSpecified (inherited from BaseFolderType)
DisplayName (inherited from BaseFolderType)
DistinguishedFolderId (inherited from BaseFolderType)
DistinguishedFolderIdSpecified (inherited from BaseFolderType)
EffectiveRights (inherited from BaseFolderType)
ExtendedProperty (inherited from BaseFolderType)
FolderClass (inherited from BaseFolderType)
FolderId (inherited from BaseFolderType)
ManagedFolderInformation (inherited from BaseFolderType)
ParentFolderId (inherited from BaseFolderType)
PermissionSet
PolicyTag (inherited from BaseFolderType)
TotalCount (inherited from BaseFolderType)
TotalCountSpecified (inherited from BaseFolderType)
UnreadCount
UnreadCountSpecified

See Also

FolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PermissionSet Property

Aspose.Email

FolderType.PermissionSet Property

public PermissionSetType PermissionSet {get; set;}

Remarks

See Also

FolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UnreadCount Property

Aspose.Email

FolderType.UnreadCount Property

public int UnreadCount {get; set;}

Remarks

See Also

FolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UnreadCountSpecified Property

Aspose.Email

FolderType.UnreadCountSpecified Property

public bool UnreadCountSpecified {get; set;}

Remarks

See Also

FolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ForwardItemType Class

For a list of all members of this type, see ForwardItemType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ItemType
Aspose.Email.Exchange.Schema.Exchange_2013.MessageType
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseObjectCoreType
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseObjectType
Aspose.Email.Exchange.Schema.Exchange_2013.SmartResponseBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.SmartResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.ForwardItemType

public class ForwardItemType : SmartResponseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ForwardItemType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ForwardItemType Members

ForwardItemType overview

Public Instance Constructors

ForwardItemType Constructor Initializes a new instance of the ForwardItemType class.

Public Instance Properties

ArchiveTag (inherited from ItemType)
Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
BlockStatus (inherited from ItemType)
BlockStatusSpecified (inherited from ItemType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
EntityExtractionResult (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
Flag (inherited from ItemType)
From (inherited from MessageType)
GroupingAction (inherited from ItemType)
GroupingActionSpecified (inherited from ItemType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBlockedImages (inherited from ItemType)
HasBlockedImagesSpecified (inherited from ItemType)
IconIndex (inherited from ItemType)
IconIndexSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InstanceKey (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
NewBodyContent (inherited from SmartResponseType)
NextPredictedAction (inherited from ItemType)
NextPredictedActionSpecified (inherited from ItemType)
NormalizedBody (inherited from ItemType)
ObjectName (inherited from ResponseObjectType)
ParentFolderId (inherited from ItemType)
PolicyTag (inherited from ItemType)
Preview (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
ReferenceItemId (inherited from ResponseObjectCoreType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReminderNextTime (inherited from ItemType)
ReminderNextTimeSpecified (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
RetentionDate (inherited from ItemType)
RetentionDateSpecified (inherited from ItemType)
RightsManagementLicenseData (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
StoreEntryId (inherited from ItemType)
Subject (inherited from ItemType)
TextBody (inherited from ItemType)
ToRecipients (inherited from MessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ForwardItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ForwardItemType Constructor

Initializes a new instance of the ForwardItemType class.

public ForwardItemType();

See Also

ForwardItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FractionalPageViewType Class

For a list of all members of this type, see FractionalPageViewType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BasePagingType
Aspose.Email.Exchange.Schema.Exchange_2013.FractionalPageViewType

public class FractionalPageViewType : BasePagingType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FractionalPageViewType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FractionalPageViewType Members

FractionalPageViewType overview

Public Instance Constructors

FractionalPageViewType Constructor Initializes a new instance of the FractionalPageViewType class.

Public Instance Properties

Denominator
MaxEntriesReturned (inherited from BasePagingType)
MaxEntriesReturnedSpecified (inherited from BasePagingType)
Numerator

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FractionalPageViewType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FractionalPageViewType Constructor

Initializes a new instance of the FractionalPageViewType class.

public FractionalPageViewType();

See Also

FractionalPageViewType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FractionalPageViewType Properties

The properties of the FractionalPageViewType class are listed below. For a complete list of FractionalPageViewType class members, see the FractionalPageViewType Members topic.

Public Instance Properties

Denominator
MaxEntriesReturned (inherited from BasePagingType)
MaxEntriesReturnedSpecified (inherited from BasePagingType)
Numerator

See Also

FractionalPageViewType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Denominator Property

Aspose.Email

FractionalPageViewType.Denominator Property

public int Denominator {get; set;}

Remarks

See Also

FractionalPageViewType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Numerator Property

Aspose.Email

FractionalPageViewType.Numerator Property

public int Numerator {get; set;}

Remarks

See Also

FractionalPageViewType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FreeBusyResponseType Class

For a list of all members of this type, see FreeBusyResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.FreeBusyResponseType

public class FreeBusyResponseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FreeBusyResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FreeBusyResponseType Members

FreeBusyResponseType overview

Public Instance Constructors

FreeBusyResponseType Constructor Initializes a new instance of the FreeBusyResponseType class.

Public Instance Properties

FreeBusyView
ResponseMessage

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FreeBusyResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FreeBusyResponseType Constructor

Initializes a new instance of the FreeBusyResponseType class.

public FreeBusyResponseType();

See Also

FreeBusyResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FreeBusyResponseType Properties

The properties of the FreeBusyResponseType class are listed below. For a complete list of FreeBusyResponseType class members, see the FreeBusyResponseType Members topic.

Public Instance Properties

FreeBusyView
ResponseMessage

See Also

FreeBusyResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FreeBusyView Property

Aspose.Email

FreeBusyResponseType.FreeBusyView Property

public FreeBusyView FreeBusyView {get; set;}

Remarks

See Also

FreeBusyResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResponseMessage Property

Aspose.Email

FreeBusyResponseType.ResponseMessage Property

public ResponseMessageType ResponseMessage {get; set;}

Remarks

See Also

FreeBusyResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FreeBusyView Class

For a list of all members of this type, see FreeBusyView Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.FreeBusyView

public class FreeBusyView

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FreeBusyView Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FreeBusyView Members

FreeBusyView overview

Public Instance Constructors

FreeBusyView Constructor Initializes a new instance of the FreeBusyView class.

Public Instance Properties

CalendarEventArray
FreeBusyViewType
MergedFreeBusy
WorkingHours

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FreeBusyView Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FreeBusyView Constructor

Initializes a new instance of the FreeBusyView class.

public FreeBusyView();

See Also

FreeBusyView Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FreeBusyView Properties

The properties of the FreeBusyView class are listed below. For a complete list of FreeBusyView class members, see the FreeBusyView Members topic.

Public Instance Properties

CalendarEventArray
FreeBusyViewType
MergedFreeBusy
WorkingHours

See Also

FreeBusyView Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalendarEventArray Property

Aspose.Email

FreeBusyView.CalendarEventArray Property

public CalendarEvent[] CalendarEventArray {get; set;}

Remarks

See Also

FreeBusyView Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FreeBusyViewType Property

Aspose.Email

FreeBusyView.FreeBusyViewType Property

public FreeBusyViewType FreeBusyViewType {get; set;}

Remarks

See Also

FreeBusyView Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MergedFreeBusy Property

Aspose.Email

FreeBusyView.MergedFreeBusy Property

public string MergedFreeBusy {get; set;}

Remarks

See Also

FreeBusyView Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


WorkingHours Property

Aspose.Email

FreeBusyView.WorkingHours Property

public WorkingHours WorkingHours {get; set;}

Remarks

See Also

FreeBusyView Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FreeBusyViewOptionsType Class

For a list of all members of this type, see FreeBusyViewOptionsType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.FreeBusyViewOptionsType

public class FreeBusyViewOptionsType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FreeBusyViewOptionsType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FreeBusyViewOptionsType Members

FreeBusyViewOptionsType overview

Public Instance Constructors

FreeBusyViewOptionsType Constructor Initializes a new instance of the FreeBusyViewOptionsType class.

Public Instance Properties

MergedFreeBusyIntervalInMinutes
MergedFreeBusyIntervalInMinutesSpecified
RequestedView
RequestedViewSpecified
TimeWindow

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FreeBusyViewOptionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FreeBusyViewOptionsType Constructor

Initializes a new instance of the FreeBusyViewOptionsType class.

public FreeBusyViewOptionsType();

See Also

FreeBusyViewOptionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FreeBusyViewOptionsType Properties

The properties of the FreeBusyViewOptionsType class are listed below. For a complete list of FreeBusyViewOptionsType class members, see the FreeBusyViewOptionsType Members topic.

Public Instance Properties

MergedFreeBusyIntervalInMinutes
MergedFreeBusyIntervalInMinutesSpecified
RequestedView
RequestedViewSpecified
TimeWindow

See Also

FreeBusyViewOptionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MergedFreeBusyIntervalInMinutes Property

Aspose.Email

FreeBusyViewOptionsType.MergedFreeBusyIntervalInMinutes Property

public int MergedFreeBusyIntervalInMinutes {get; set;}

Remarks

See Also

FreeBusyViewOptionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MergedFreeBusyIntervalInMinutesSpecified Property

Aspose.Email

FreeBusyViewOptionsType.MergedFreeBusyIntervalInMinutesSpecified Property

public bool MergedFreeBusyIntervalInMinutesSpecified {get; set;}

Remarks

See Also

FreeBusyViewOptionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RequestedView Property

Aspose.Email

FreeBusyViewOptionsType.RequestedView Property

public FreeBusyViewType RequestedView {get; set;}

Remarks

See Also

FreeBusyViewOptionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RequestedViewSpecified Property

Aspose.Email

FreeBusyViewOptionsType.RequestedViewSpecified Property

public bool RequestedViewSpecified {get; set;}

Remarks

See Also

FreeBusyViewOptionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TimeWindow Property

Aspose.Email

FreeBusyViewOptionsType.TimeWindow Property

public Duration TimeWindow {get; set;}

Remarks

See Also

FreeBusyViewOptionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FreeBusyViewType Enumeration

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum FreeBusyViewType

Remarks

Members

Member Name | Description | Value
None |  | 1
MergedOnly |  | 2
FreeBusy |  | 4
FreeBusyMerged |  | 8
Detailed |  | 16
DetailedMerged |  | 32

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetAppManifestsCompletedEventArgs Class

For a list of all members of this type, see GetAppManifestsCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetAppManifestsCompletedEventArgs

public class GetAppManifestsCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetAppManifestsCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetAppManifestsCompletedEventArgs Members

GetAppManifestsCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetAppManifestsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetAppManifestsCompletedEventArgs Properties

The properties of the GetAppManifestsCompletedEventArgs class are listed below. For a complete list of GetAppManifestsCompletedEventArgs class members, see the GetAppManifestsCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetAppManifestsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

GetAppManifestsCompletedEventArgs.Result Property

public GetAppManifestsResponseType Result {get;}

Remarks

See Also

GetAppManifestsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetAppManifestsCompletedEventHandler Delegate

public delegate void GetAppManifestsCompletedEventHandler(
object sender,
GetAppManifestsCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetAppManifestsResponseType Class

For a list of all members of this type, see GetAppManifestsResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetAppManifestsResponseType

public class GetAppManifestsResponseType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetAppManifestsResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetAppManifestsResponseType Members

GetAppManifestsResponseType overview

Public Instance Constructors

GetAppManifestsResponseType Constructor Initializes a new instance of the GetAppManifestsResponseType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
Manifests
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetAppManifestsResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetAppManifestsResponseType Constructor

Initializes a new instance of the GetAppManifestsResponseType class.

public GetAppManifestsResponseType();

See Also

GetAppManifestsResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetAppManifestsResponseType Properties

The properties of the GetAppManifestsResponseType class are listed below. For a complete list of GetAppManifestsResponseType class members, see the GetAppManifestsResponseType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
Manifests
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

GetAppManifestsResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Manifests Property

Aspose.Email

GetAppManifestsResponseType.Manifests Property

public byte[][] Manifests {get; set;}

Remarks

See Also

GetAppManifestsResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetAppManifestsType Class

For a list of all members of this type, see GetAppManifestsType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.GetAppManifestsType

public class GetAppManifestsType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetAppManifestsType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetAppManifestsType Members

GetAppManifestsType overview

Public Instance Constructors

GetAppManifestsType Constructor Initializes a new instance of the GetAppManifestsType class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetAppManifestsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetAppManifestsType Constructor

Initializes a new instance of the GetAppManifestsType class.

public GetAppManifestsType();

See Also

GetAppManifestsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetAppMarketplaceUrlCompletedEventArgs Class

For a list of all members of this type, see GetAppMarketplaceUrlCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetAppMarketplaceUrlCompletedEventArgs

public class GetAppMarketplaceUrlCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetAppMarketplaceUrlCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetAppMarketplaceUrlCompletedEventArgs Members

GetAppMarketplaceUrlCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetAppMarketplaceUrlCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetAppMarketplaceUrlCompletedEventArgs Properties

The properties of the GetAppMarketplaceUrlCompletedEventArgs class are listed below. For a complete list of GetAppMarketplaceUrlCompletedEventArgs class members, see the GetAppMarketplaceUrlCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetAppMarketplaceUrlCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

GetAppMarketplaceUrlCompletedEventArgs.Result Property

public GetAppMarketplaceUrlResponseMessageType Result {get;}

Remarks

See Also

GetAppMarketplaceUrlCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetAppMarketplaceUrlCompletedEventHandler Delegate

public delegate void GetAppMarketplaceUrlCompletedEventHandler(
object sender,
GetAppMarketplaceUrlCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetAppMarketplaceUrlResponseMessageType Class

For a list of all members of this type, see GetAppMarketplaceUrlResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetAppMarketplaceUrlResponseMessageType

public class GetAppMarketplaceUrlResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetAppMarketplaceUrlResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetAppMarketplaceUrlResponseMessageType Members

GetAppMarketplaceUrlResponseMessageType overview

Public Instance Constructors

GetAppMarketplaceUrlResponseMessageType Constructor Initializes a new instance of the GetAppMarketplaceUrlResponseMessageType class.

Public Instance Properties

AppMarketplaceUrl
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetAppMarketplaceUrlResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetAppMarketplaceUrlResponseMessageType Constructor

Initializes a new instance of the GetAppMarketplaceUrlResponseMessageType class.

public GetAppMarketplaceUrlResponseMessageType();

See Also

GetAppMarketplaceUrlResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetAppMarketplaceUrlResponseMessageType Properties

The properties of the GetAppMarketplaceUrlResponseMessageType class are listed below. For a complete list of GetAppMarketplaceUrlResponseMessageType class members, see the GetAppMarketplaceUrlResponseMessageType Members topic.

Public Instance Properties

AppMarketplaceUrl
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

GetAppMarketplaceUrlResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AppMarketplaceUrl Property

Aspose.Email

GetAppMarketplaceUrlResponseMessageType.AppMarketplaceUrl Property

public string AppMarketplaceUrl {get; set;}

Remarks

See Also

GetAppMarketplaceUrlResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetAppMarketplaceUrlType Class

For a list of all members of this type, see GetAppMarketplaceUrlType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.GetAppMarketplaceUrlType

public class GetAppMarketplaceUrlType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetAppMarketplaceUrlType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetAppMarketplaceUrlType Members

GetAppMarketplaceUrlType overview

Public Instance Constructors

GetAppMarketplaceUrlType Constructor Initializes a new instance of the GetAppMarketplaceUrlType class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetAppMarketplaceUrlType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetAppMarketplaceUrlType Constructor

Initializes a new instance of the GetAppMarketplaceUrlType class.

public GetAppMarketplaceUrlType();

See Also

GetAppMarketplaceUrlType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetAttachmentCompletedEventArgs Class

For a list of all members of this type, see GetAttachmentCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetAttachmentCompletedEventArgs

public class GetAttachmentCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetAttachmentCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetAttachmentCompletedEventArgs Members

GetAttachmentCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetAttachmentCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetAttachmentCompletedEventArgs Properties

The properties of the GetAttachmentCompletedEventArgs class are listed below. For a complete list of GetAttachmentCompletedEventArgs class members, see the GetAttachmentCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetAttachmentCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

GetAttachmentCompletedEventArgs.Result Property

public GetAttachmentResponseType Result {get;}

Remarks

See Also

GetAttachmentCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetAttachmentCompletedEventHandler Delegate

public delegate void GetAttachmentCompletedEventHandler(
object sender,
GetAttachmentCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetAttachmentResponseType Class

For a list of all members of this type, see GetAttachmentResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetAttachmentResponseType

public class GetAttachmentResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetAttachmentResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetAttachmentResponseType Members

GetAttachmentResponseType overview

Public Instance Constructors

GetAttachmentResponseType Constructor Initializes a new instance of the GetAttachmentResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetAttachmentResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetAttachmentResponseType Constructor

Initializes a new instance of the GetAttachmentResponseType class.

public GetAttachmentResponseType();

See Also

GetAttachmentResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetAttachmentType Class

For a list of all members of this type, see GetAttachmentType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.GetAttachmentType

public class GetAttachmentType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetAttachmentType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetAttachmentType Members

GetAttachmentType overview

Public Instance Constructors

GetAttachmentType Constructor Initializes a new instance of the GetAttachmentType class.

Public Instance Properties

AttachmentIds
AttachmentShape

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetAttachmentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetAttachmentType Constructor

Initializes a new instance of the GetAttachmentType class.

public GetAttachmentType();

See Also

GetAttachmentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetAttachmentType Properties

The properties of the GetAttachmentType class are listed below. For a complete list of GetAttachmentType class members, see the GetAttachmentType Members topic.

Public Instance Properties

AttachmentIds
AttachmentShape

See Also

GetAttachmentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AttachmentIds Property

Aspose.Email

GetAttachmentType.AttachmentIds Property

public RequestAttachmentIdType[] AttachmentIds {get; set;}

Remarks

See Also

GetAttachmentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AttachmentShape Property

Aspose.Email

GetAttachmentType.AttachmentShape Property

public AttachmentResponseShapeType AttachmentShape {get; set;}

Remarks

See Also

GetAttachmentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetClientAccessTokenCompletedEventArgs Class

For a list of all members of this type, see GetClientAccessTokenCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetClientAccessTokenCompletedEventArgs

public class GetClientAccessTokenCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetClientAccessTokenCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetClientAccessTokenCompletedEventArgs Members

GetClientAccessTokenCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetClientAccessTokenCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetClientAccessTokenCompletedEventArgs Properties

The properties of the GetClientAccessTokenCompletedEventArgs class are listed below. For a complete list of GetClientAccessTokenCompletedEventArgs class members, see the GetClientAccessTokenCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetClientAccessTokenCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

GetClientAccessTokenCompletedEventArgs.Result Property

public GetClientAccessTokenResponseType Result {get;}

Remarks

See Also

GetClientAccessTokenCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetClientAccessTokenCompletedEventHandler Delegate

public delegate void GetClientAccessTokenCompletedEventHandler(
object sender,
GetClientAccessTokenCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetClientAccessTokenResponseMessageType Class

For a list of all members of this type, see GetClientAccessTokenResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetClientAccessTokenResponseMessageType

public class GetClientAccessTokenResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetClientAccessTokenResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetClientAccessTokenResponseMessageType Members

GetClientAccessTokenResponseMessageType overview

Public Instance Constructors

GetClientAccessTokenResponseMessageType Constructor Initializes a new instance of the GetClientAccessTokenResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
Token

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetClientAccessTokenResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetClientAccessTokenResponseMessageType Constructor

Initializes a new instance of the GetClientAccessTokenResponseMessageType class.

public GetClientAccessTokenResponseMessageType();

See Also

GetClientAccessTokenResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetClientAccessTokenResponseMessageType Properties

The properties of the GetClientAccessTokenResponseMessageType class are listed below. For a complete list of GetClientAccessTokenResponseMessageType class members, see the GetClientAccessTokenResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
Token

See Also

GetClientAccessTokenResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Token Property

Aspose.Email

GetClientAccessTokenResponseMessageType.Token Property

public ClientAccessTokenType Token {get; set;}

Remarks

See Also

GetClientAccessTokenResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetClientAccessTokenResponseType Class

For a list of all members of this type, see GetClientAccessTokenResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetClientAccessTokenResponseType

public class GetClientAccessTokenResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetClientAccessTokenResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetClientAccessTokenResponseType Members

GetClientAccessTokenResponseType overview

Public Instance Constructors

GetClientAccessTokenResponseType Constructor Initializes a new instance of the GetClientAccessTokenResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetClientAccessTokenResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetClientAccessTokenResponseType Constructor

Initializes a new instance of the GetClientAccessTokenResponseType class.

public GetClientAccessTokenResponseType();

See Also

GetClientAccessTokenResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetClientAccessTokenType Class

For a list of all members of this type, see GetClientAccessTokenType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.GetClientAccessTokenType

public class GetClientAccessTokenType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetClientAccessTokenType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetClientAccessTokenType Members

GetClientAccessTokenType overview

Public Instance Constructors

GetClientAccessTokenType Constructor Initializes a new instance of the GetClientAccessTokenType class.

Public Instance Properties

TokenRequests

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetClientAccessTokenType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetClientAccessTokenType Constructor

Initializes a new instance of the GetClientAccessTokenType class.

public GetClientAccessTokenType();

See Also

GetClientAccessTokenType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetClientAccessTokenType Properties

The properties of the GetClientAccessTokenType class are listed below. For a complete list of GetClientAccessTokenType class members, see the GetClientAccessTokenType Members topic.

Public Instance Properties

TokenRequests

See Also

GetClientAccessTokenType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TokenRequests Property

Aspose.Email

GetClientAccessTokenType.TokenRequests Property

public ClientAccessTokenRequestType[] TokenRequests {get; set;}

Remarks

See Also

GetClientAccessTokenType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetClientExtensionType Class

For a list of all members of this type, see GetClientExtensionType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.GetClientExtensionType

public class GetClientExtensionType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetClientExtensionType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetClientExtensionType Members

GetClientExtensionType overview

Public Instance Constructors

GetClientExtensionType Constructor Initializes a new instance of the GetClientExtensionType class.

Public Instance Properties

IsDebug
IsDebugSpecified
RequestedExtensionIds
UserParameters

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetClientExtensionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetClientExtensionType Constructor

Initializes a new instance of the GetClientExtensionType class.

public GetClientExtensionType();

See Also

GetClientExtensionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetClientExtensionType Properties

The properties of the GetClientExtensionType class are listed below. For a complete list of GetClientExtensionType class members, see the GetClientExtensionType Members topic.

Public Instance Properties

IsDebug
IsDebugSpecified
RequestedExtensionIds
UserParameters

See Also

GetClientExtensionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsDebug Property

Aspose.Email

GetClientExtensionType.IsDebug Property

public bool IsDebug {get; set;}

Remarks

See Also

GetClientExtensionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsDebugSpecified Property

Aspose.Email

GetClientExtensionType.IsDebugSpecified Property

public bool IsDebugSpecified {get; set;}

Remarks

See Also

GetClientExtensionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RequestedExtensionIds Property

Aspose.Email

GetClientExtensionType.RequestedExtensionIds Property

public string[] RequestedExtensionIds {get; set;}

Remarks

See Also

GetClientExtensionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserParameters Property

Aspose.Email

GetClientExtensionType.UserParameters Property

public GetClientExtensionUserParametersType UserParameters {get; set;}

Remarks

See Also

GetClientExtensionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetClientExtensionUserParametersType Class

For a list of all members of this type, see GetClientExtensionUserParametersType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.GetClientExtensionUserParametersType

public class GetClientExtensionUserParametersType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetClientExtensionUserParametersType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetClientExtensionUserParametersType Members

GetClientExtensionUserParametersType overview

Public Instance Constructors

GetClientExtensionUserParametersType Constructor Initializes a new instance of the GetClientExtensionUserParametersType class.

Public Instance Properties

EnabledOnly
EnabledOnlySpecified
UserDisabledExtensions
UserEnabledExtensions
UserId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetClientExtensionUserParametersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetClientExtensionUserParametersType Constructor

Initializes a new instance of the GetClientExtensionUserParametersType class.

public GetClientExtensionUserParametersType();

See Also

GetClientExtensionUserParametersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetClientExtensionUserParametersType Properties

The properties of the GetClientExtensionUserParametersType class are listed below. For a complete list of GetClientExtensionUserParametersType class members, see the GetClientExtensionUserParametersType Members topic.

Public Instance Properties

EnabledOnly
EnabledOnlySpecified
UserDisabledExtensions
UserEnabledExtensions
UserId

See Also

GetClientExtensionUserParametersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EnabledOnly Property

Aspose.Email

GetClientExtensionUserParametersType.EnabledOnly Property

public bool EnabledOnly {get; set;}

Remarks

See Also

GetClientExtensionUserParametersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EnabledOnlySpecified Property

Aspose.Email

GetClientExtensionUserParametersType.EnabledOnlySpecified Property

public bool EnabledOnlySpecified {get; set;}

Remarks

See Also

GetClientExtensionUserParametersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserDisabledExtensions Property

Aspose.Email

GetClientExtensionUserParametersType.UserDisabledExtensions Property

public string[] UserDisabledExtensions {get; set;}

Remarks

See Also

GetClientExtensionUserParametersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserEnabledExtensions Property

Aspose.Email

GetClientExtensionUserParametersType.UserEnabledExtensions Property

public string[] UserEnabledExtensions {get; set;}

Remarks

See Also

GetClientExtensionUserParametersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserId Property

Aspose.Email

GetClientExtensionUserParametersType.UserId Property

public string UserId {get; set;}

Remarks

See Also

GetClientExtensionUserParametersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetClientIntentResponseMessageType Class

For a list of all members of this type, see GetClientIntentResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetClientIntentResponseMessageType

public class GetClientIntentResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetClientIntentResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetClientIntentResponseMessageType Members

GetClientIntentResponseMessageType overview

Public Instance Constructors

GetClientIntentResponseMessageType Constructor Initializes a new instance of the GetClientIntentResponseMessageType class.

Public Instance Properties

ClientIntent
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetClientIntentResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetClientIntentResponseMessageType Constructor

Initializes a new instance of the GetClientIntentResponseMessageType class.

public GetClientIntentResponseMessageType();

See Also

GetClientIntentResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetClientIntentResponseMessageType Properties

The properties of the GetClientIntentResponseMessageType class are listed below. For a complete list of GetClientIntentResponseMessageType class members, see the GetClientIntentResponseMessageType Members topic.

Public Instance Properties

ClientIntent
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

GetClientIntentResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ClientIntent Property

Aspose.Email

GetClientIntentResponseMessageType.ClientIntent Property

public ClientIntentType ClientIntent {get; set;}

Remarks

See Also

GetClientIntentResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetClientIntentType Class

For a list of all members of this type, see GetClientIntentType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.GetClientIntentType

public class GetClientIntentType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetClientIntentType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetClientIntentType Members

GetClientIntentType overview

Public Instance Constructors

GetClientIntentType Constructor Initializes a new instance of the GetClientIntentType class.

Public Instance Properties

GlobalObjectId
StateDefinition

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetClientIntentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetClientIntentType Constructor

Initializes a new instance of the GetClientIntentType class.

public GetClientIntentType();

See Also

GetClientIntentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetClientIntentType Properties

The properties of the GetClientIntentType class are listed below. For a complete list of GetClientIntentType class members, see the GetClientIntentType Members topic.

Public Instance Properties

GlobalObjectId
StateDefinition

See Also

GetClientIntentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GlobalObjectId Property

Aspose.Email

GetClientIntentType.GlobalObjectId Property

public string GlobalObjectId {get; set;}

Remarks

See Also

GetClientIntentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StateDefinition Property

Aspose.Email

GetClientIntentType.StateDefinition Property

public NonEmptyStateDefinitionType StateDefinition {get; set;}

Remarks

See Also

GetClientIntentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetConversationItemsCompletedEventArgs Class

For a list of all members of this type, see GetConversationItemsCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetConversationItemsCompletedEventArgs

public class GetConversationItemsCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetConversationItemsCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetConversationItemsCompletedEventArgs Members

GetConversationItemsCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetConversationItemsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetConversationItemsCompletedEventArgs Properties

The properties of the GetConversationItemsCompletedEventArgs class are listed below. For a complete list of GetConversationItemsCompletedEventArgs class members, see the GetConversationItemsCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetConversationItemsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

GetConversationItemsCompletedEventArgs.Result Property

public GetConversationItemsResponseType Result {get;}

Remarks

See Also

GetConversationItemsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetConversationItemsCompletedEventHandler Delegate

public delegate void GetConversationItemsCompletedEventHandler(
object sender,
GetConversationItemsCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetConversationItemsResponseMessageType Class

For a list of all members of this type, see GetConversationItemsResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetConversationItemsResponseMessageType

public class GetConversationItemsResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetConversationItemsResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetConversationItemsResponseMessageType Members

GetConversationItemsResponseMessageType overview

Public Instance Constructors

GetConversationItemsResponseMessageType Constructor Initializes a new instance of the GetConversationItemsResponseMessageType class.

Public Instance Properties

Conversation
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetConversationItemsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetConversationItemsResponseMessageType Constructor

Initializes a new instance of the GetConversationItemsResponseMessageType class.

public GetConversationItemsResponseMessageType();

See Also

GetConversationItemsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetConversationItemsResponseMessageType Properties

The properties of the GetConversationItemsResponseMessageType class are listed below. For a complete list of GetConversationItemsResponseMessageType class members, see the GetConversationItemsResponseMessageType Members topic.

Public Instance Properties

Conversation
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

GetConversationItemsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Conversation Property

Aspose.Email

GetConversationItemsResponseMessageType.Conversation Property

public ConversationResponseType Conversation {get; set;}

Remarks

See Also

GetConversationItemsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetConversationItemsResponseType Class

For a list of all members of this type, see GetConversationItemsResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetConversationItemsResponseType

public class GetConversationItemsResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetConversationItemsResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetConversationItemsResponseType Members

GetConversationItemsResponseType overview

Public Instance Constructors

GetConversationItemsResponseType Constructor Initializes a new instance of the GetConversationItemsResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetConversationItemsResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetConversationItemsResponseType Constructor

Initializes a new instance of the GetConversationItemsResponseType class.

public GetConversationItemsResponseType();

See Also

GetConversationItemsResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetConversationItemsType Class

For a list of all members of this type, see GetConversationItemsType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.GetConversationItemsType

public class GetConversationItemsType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetConversationItemsType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetConversationItemsType Members

GetConversationItemsType overview

Public Instance Constructors

GetConversationItemsType Constructor Initializes a new instance of the GetConversationItemsType class.

Public Instance Properties

Conversations
FoldersToIgnore
ItemShape
MailboxScope
MailboxScopeSpecified
MaxItemsToReturn
MaxItemsToReturnSpecified
SortOrder
SortOrderSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetConversationItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetConversationItemsType Constructor

Initializes a new instance of the GetConversationItemsType class.

public GetConversationItemsType();

See Also

GetConversationItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetConversationItemsType Properties

The properties of the GetConversationItemsType class are listed below. For a complete list of GetConversationItemsType class members, see the GetConversationItemsType Members topic.

Public Instance Properties

Conversations
FoldersToIgnore
ItemShape
MailboxScope
MailboxScopeSpecified
MaxItemsToReturn
MaxItemsToReturnSpecified
SortOrder
SortOrderSpecified

See Also

GetConversationItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Conversations Property

Aspose.Email

GetConversationItemsType.Conversations Property

public ConversationRequestType[] Conversations {get; set;}

Remarks

See Also

GetConversationItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FoldersToIgnore Property

Aspose.Email

GetConversationItemsType.FoldersToIgnore Property

public BaseFolderIdType[] FoldersToIgnore {get; set;}

Remarks

See Also

GetConversationItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemShape Property

Aspose.Email

GetConversationItemsType.ItemShape Property

public ItemResponseShapeType ItemShape {get; set;}

Remarks

See Also

GetConversationItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxScope Property

Aspose.Email

GetConversationItemsType.MailboxScope Property

public MailboxSearchLocationType MailboxScope {get; set;}

Remarks

See Also

GetConversationItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxScopeSpecified Property

Aspose.Email

GetConversationItemsType.MailboxScopeSpecified Property

public bool MailboxScopeSpecified {get; set;}

Remarks

See Also

GetConversationItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MaxItemsToReturn Property

Aspose.Email

GetConversationItemsType.MaxItemsToReturn Property

public int MaxItemsToReturn {get; set;}

Remarks

See Also

GetConversationItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MaxItemsToReturnSpecified Property

Aspose.Email

GetConversationItemsType.MaxItemsToReturnSpecified Property

public bool MaxItemsToReturnSpecified {get; set;}

Remarks

See Also

GetConversationItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SortOrder Property

Aspose.Email

GetConversationItemsType.SortOrder Property

public ConversationNodeSortOrder SortOrder {get; set;}

Remarks

See Also

GetConversationItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SortOrderSpecified Property

Aspose.Email

GetConversationItemsType.SortOrderSpecified Property

public bool SortOrderSpecified {get; set;}

Remarks

See Also

GetConversationItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetDelegateCompletedEventArgs Class

For a list of all members of this type, see GetDelegateCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetDelegateCompletedEventArgs

public class GetDelegateCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetDelegateCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetDelegateCompletedEventArgs Members

GetDelegateCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetDelegateCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetDelegateCompletedEventArgs Properties

The properties of the GetDelegateCompletedEventArgs class are listed below. For a complete list of GetDelegateCompletedEventArgs class members, see the GetDelegateCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetDelegateCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

GetDelegateCompletedEventArgs.Result Property

public GetDelegateResponseMessageType Result {get;}

Remarks

See Also

GetDelegateCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetDelegateCompletedEventHandler Delegate

public delegate void GetDelegateCompletedEventHandler(
object sender,
GetDelegateCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetDelegateResponseMessageType Class

For a list of all members of this type, see GetDelegateResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.BaseDelegateResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetDelegateResponseMessageType

public class GetDelegateResponseMessageType : BaseDelegateResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetDelegateResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetDelegateResponseMessageType Members

GetDelegateResponseMessageType overview

Public Instance Constructors

GetDelegateResponseMessageType Constructor Initializes a new instance of the GetDelegateResponseMessageType class.

Public Instance Properties

DeliverMeetingRequests
DeliverMeetingRequestsSpecified
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
ResponseMessages (inherited from BaseDelegateResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetDelegateResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetDelegateResponseMessageType Constructor

Initializes a new instance of the GetDelegateResponseMessageType class.

public GetDelegateResponseMessageType();

See Also

GetDelegateResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetDelegateResponseMessageType Properties

The properties of the GetDelegateResponseMessageType class are listed below. For a complete list of GetDelegateResponseMessageType class members, see the GetDelegateResponseMessageType Members topic.

Public Instance Properties

DeliverMeetingRequests
DeliverMeetingRequestsSpecified
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
ResponseMessages (inherited from BaseDelegateResponseMessageType)

See Also

GetDelegateResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeliverMeetingRequests Property

Aspose.Email

GetDelegateResponseMessageType.DeliverMeetingRequests Property

public DeliverMeetingRequestsType DeliverMeetingRequests {get; set;}

Remarks

See Also

GetDelegateResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeliverMeetingRequestsSpecified Property

Aspose.Email

GetDelegateResponseMessageType.DeliverMeetingRequestsSpecified Property

public bool DeliverMeetingRequestsSpecified {get; set;}

Remarks

See Also

GetDelegateResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetDelegateType Class

For a list of all members of this type, see GetDelegateType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.BaseDelegateType
Aspose.Email.Exchange.Schema.Exchange_2013.GetDelegateType

public class GetDelegateType : BaseDelegateType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetDelegateType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetDelegateType Members

GetDelegateType overview

Public Instance Constructors

GetDelegateType Constructor Initializes a new instance of the GetDelegateType class.

Public Instance Properties

IncludePermissions
Mailbox (inherited from BaseDelegateType)
UserIds

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetDelegateType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetDelegateType Constructor

Initializes a new instance of the GetDelegateType class.

public GetDelegateType();

See Also

GetDelegateType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetDelegateType Properties

The properties of the GetDelegateType class are listed below. For a complete list of GetDelegateType class members, see the GetDelegateType Members topic.

Public Instance Properties

IncludePermissions
Mailbox (inherited from BaseDelegateType)
UserIds

See Also

GetDelegateType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IncludePermissions Property

Aspose.Email

GetDelegateType.IncludePermissions Property

public bool IncludePermissions {get; set;}

Remarks

See Also

GetDelegateType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserIds Property

Aspose.Email

GetDelegateType.UserIds Property

public UserIdType[] UserIds {get; set;}

Remarks

See Also

GetDelegateType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetDiscoverySearchConfigurationCompletedEventArgs Class

For a list of all members of this type, see GetDiscoverySearchConfigurationCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetDiscoverySearchConfigurationCompletedEventArgs

public class GetDiscoverySearchConfigurationCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetDiscoverySearchConfigurationCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetDiscoverySearchConfigurationCompletedEventArgs Members

GetDiscoverySearchConfigurationCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetDiscoverySearchConfigurationCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetDiscoverySearchConfigurationCompletedEventArgs Properties

The properties of the GetDiscoverySearchConfigurationCompletedEventArgs class are listed below. For a complete list of GetDiscoverySearchConfigurationCompletedEventArgs class members, see the GetDiscoverySearchConfigurationCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetDiscoverySearchConfigurationCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

GetDiscoverySearchConfigurationCompletedEventArgs.Result Property

public GetDiscoverySearchConfigurationResponseMessageType Result {get;}

Remarks

See Also

GetDiscoverySearchConfigurationCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetDiscoverySearchConfigurationCompletedEventHandler Delegate

public delegate void GetDiscoverySearchConfigurationCompletedEventHandler(
object sender,
GetDiscoverySearchConfigurationCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetDiscoverySearchConfigurationResponseMessageType Class

For a list of all members of this type, see GetDiscoverySearchConfigurationResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetDiscoverySearchConfigurationResponseMessageType

public class GetDiscoverySearchConfigurationResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetDiscoverySearchConfigurationResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetDiscoverySearchConfigurationResponseMessageType Members

GetDiscoverySearchConfigurationResponseMessageType overview

Public Instance Constructors

GetDiscoverySearchConfigurationResponseMessageType Constructor Initializes a new instance of the GetDiscoverySearchConfigurationResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
DiscoverySearchConfigurations
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetDiscoverySearchConfigurationResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetDiscoverySearchConfigurationResponseMessageType Constructor

Initializes a new instance of the GetDiscoverySearchConfigurationResponseMessageType class.

public GetDiscoverySearchConfigurationResponseMessageType();

See Also

GetDiscoverySearchConfigurationResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetDiscoverySearchConfigurationResponseMessageType Properties

The properties of the GetDiscoverySearchConfigurationResponseMessageType class are listed below. For a complete list of GetDiscoverySearchConfigurationResponseMessageType class members, see the GetDiscoverySearchConfigurationResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
DiscoverySearchConfigurations
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

GetDiscoverySearchConfigurationResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DiscoverySearchConfigurations Property

Aspose.Email

GetDiscoverySearchConfigurationResponseMessageType.DiscoverySearchConfigurations Property

public DiscoverySearchConfigurationType[] DiscoverySearchConfigurations {get; set;}

Remarks

See Also

GetDiscoverySearchConfigurationResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetDiscoverySearchConfigurationType Class

For a list of all members of this type, see GetDiscoverySearchConfigurationType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.GetDiscoverySearchConfigurationType

public class GetDiscoverySearchConfigurationType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetDiscoverySearchConfigurationType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetDiscoverySearchConfigurationType Members

GetDiscoverySearchConfigurationType overview

Public Instance Constructors

GetDiscoverySearchConfigurationType Constructor Initializes a new instance of the GetDiscoverySearchConfigurationType class.

Public Instance Properties

ExpandGroupMembership
ExpandGroupMembershipSpecified
InPlaceHoldConfigurationOnly
InPlaceHoldConfigurationOnlySpecified
SearchId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetDiscoverySearchConfigurationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetDiscoverySearchConfigurationType Constructor

Initializes a new instance of the GetDiscoverySearchConfigurationType class.

public GetDiscoverySearchConfigurationType();

See Also

GetDiscoverySearchConfigurationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetDiscoverySearchConfigurationType Properties

The properties of the GetDiscoverySearchConfigurationType class are listed below. For a complete list of GetDiscoverySearchConfigurationType class members, see the GetDiscoverySearchConfigurationType Members topic.

Public Instance Properties

ExpandGroupMembership
ExpandGroupMembershipSpecified
InPlaceHoldConfigurationOnly
InPlaceHoldConfigurationOnlySpecified
SearchId

See Also

GetDiscoverySearchConfigurationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExpandGroupMembership Property

Aspose.Email

GetDiscoverySearchConfigurationType.ExpandGroupMembership Property

public bool ExpandGroupMembership {get; set;}

Remarks

See Also

GetDiscoverySearchConfigurationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExpandGroupMembershipSpecified Property

Aspose.Email

GetDiscoverySearchConfigurationType.ExpandGroupMembershipSpecified Property

public bool ExpandGroupMembershipSpecified {get; set;}

Remarks

See Also

GetDiscoverySearchConfigurationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InPlaceHoldConfigurationOnly Property

Aspose.Email

GetDiscoverySearchConfigurationType.InPlaceHoldConfigurationOnly Property

public bool InPlaceHoldConfigurationOnly {get; set;}

Remarks

See Also

GetDiscoverySearchConfigurationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InPlaceHoldConfigurationOnlySpecified Property

Aspose.Email

GetDiscoverySearchConfigurationType.InPlaceHoldConfigurationOnlySpecified Property

public bool InPlaceHoldConfigurationOnlySpecified {get; set;}

Remarks

See Also

GetDiscoverySearchConfigurationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchId Property

Aspose.Email

GetDiscoverySearchConfigurationType.SearchId Property

public string SearchId {get; set;}

Remarks

See Also

GetDiscoverySearchConfigurationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetEventsCompletedEventArgs Class

For a list of all members of this type, see GetEventsCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetEventsCompletedEventArgs

public class GetEventsCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetEventsCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetEventsCompletedEventArgs Members

GetEventsCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetEventsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetEventsCompletedEventArgs Properties

The properties of the GetEventsCompletedEventArgs class are listed below. For a complete list of GetEventsCompletedEventArgs class members, see the GetEventsCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetEventsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

GetEventsCompletedEventArgs.Result Property

public GetEventsResponseType Result {get;}

Remarks

See Also

GetEventsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetEventsCompletedEventHandler Delegate

public delegate void GetEventsCompletedEventHandler(
object sender,
GetEventsCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetEventsResponseMessageType Class

For a list of all members of this type, see GetEventsResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetEventsResponseMessageType

public class GetEventsResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetEventsResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetEventsResponseMessageType Members

GetEventsResponseMessageType overview

Public Instance Constructors

GetEventsResponseMessageType Constructor Initializes a new instance of the GetEventsResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
Notification
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetEventsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetEventsResponseMessageType Constructor

Initializes a new instance of the GetEventsResponseMessageType class.

public GetEventsResponseMessageType();

See Also

GetEventsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetEventsResponseMessageType Properties

The properties of the GetEventsResponseMessageType class are listed below. For a complete list of GetEventsResponseMessageType class members, see the GetEventsResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
Notification
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

GetEventsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Notification Property

Aspose.Email

GetEventsResponseMessageType.Notification Property

public NotificationType Notification {get; set;}

Remarks

See Also

GetEventsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetEventsResponseType Class

For a list of all members of this type, see GetEventsResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetEventsResponseType

public class GetEventsResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetEventsResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetEventsResponseType Members

GetEventsResponseType overview

Public Instance Constructors

GetEventsResponseType Constructor Initializes a new instance of the GetEventsResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetEventsResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetEventsResponseType Constructor

Initializes a new instance of the GetEventsResponseType class.

public GetEventsResponseType();

See Also

GetEventsResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetEventsType Class

For a list of all members of this type, see GetEventsType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.GetEventsType

public class GetEventsType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetEventsType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetEventsType Members

GetEventsType overview

Public Instance Constructors

GetEventsType Constructor Initializes a new instance of the GetEventsType class.

Public Instance Properties

SubscriptionId
Watermark

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetEventsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetEventsType Constructor

Initializes a new instance of the GetEventsType class.

public GetEventsType();

See Also

GetEventsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetEventsType Properties

The properties of the GetEventsType class are listed below. For a complete list of GetEventsType class members, see the GetEventsType Members topic.

Public Instance Properties

SubscriptionId
Watermark

See Also

GetEventsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SubscriptionId Property

Aspose.Email

GetEventsType.SubscriptionId Property

public string SubscriptionId {get; set;}

Remarks

See Also

GetEventsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Watermark Property

Aspose.Email

GetEventsType.Watermark Property

public string Watermark {get; set;}

Remarks

See Also

GetEventsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetFolderCompletedEventArgs Class

For a list of all members of this type, see GetFolderCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetFolderCompletedEventArgs

public class GetFolderCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetFolderCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetFolderCompletedEventArgs Members

GetFolderCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetFolderCompletedEventArgs Properties

The properties of the GetFolderCompletedEventArgs class are listed below. For a complete list of GetFolderCompletedEventArgs class members, see the GetFolderCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

GetFolderCompletedEventArgs.Result Property

public GetFolderResponseType Result {get;}

Remarks

See Also

GetFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetFolderCompletedEventHandler Delegate

public delegate void GetFolderCompletedEventHandler(
object sender,
GetFolderCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetFolderResponseType Class

For a list of all members of this type, see GetFolderResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetFolderResponseType

public class GetFolderResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetFolderResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetFolderResponseType Members

GetFolderResponseType overview

Public Instance Constructors

GetFolderResponseType Constructor Initializes a new instance of the GetFolderResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetFolderResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetFolderResponseType Constructor

Initializes a new instance of the GetFolderResponseType class.

public GetFolderResponseType();

See Also

GetFolderResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetFolderType Class

For a list of all members of this type, see GetFolderType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.GetFolderType

public class GetFolderType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetFolderType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetFolderType Members

GetFolderType overview

Public Instance Constructors

GetFolderType Constructor Initializes a new instance of the GetFolderType class.

Public Instance Properties

FolderIds
FolderShape

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetFolderType Constructor

Initializes a new instance of the GetFolderType class.

public GetFolderType();

See Also

GetFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetFolderType Properties

The properties of the GetFolderType class are listed below. For a complete list of GetFolderType class members, see the GetFolderType Members topic.

Public Instance Properties

FolderIds
FolderShape

See Also

GetFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FolderIds Property

Aspose.Email

GetFolderType.FolderIds Property

public BaseFolderIdType[] FolderIds {get; set;}

Remarks

See Also

GetFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FolderShape Property

Aspose.Email

GetFolderType.FolderShape Property

public FolderResponseShapeType FolderShape {get; set;}

Remarks

See Also

GetFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetHoldOnMailboxesCompletedEventArgs Class

For a list of all members of this type, see GetHoldOnMailboxesCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetHoldOnMailboxesCompletedEventArgs

public class GetHoldOnMailboxesCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetHoldOnMailboxesCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetHoldOnMailboxesCompletedEventArgs Members

GetHoldOnMailboxesCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetHoldOnMailboxesCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetHoldOnMailboxesCompletedEventArgs Properties

The properties of the GetHoldOnMailboxesCompletedEventArgs class are listed below. For a complete list of GetHoldOnMailboxesCompletedEventArgs class members, see the GetHoldOnMailboxesCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetHoldOnMailboxesCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

GetHoldOnMailboxesCompletedEventArgs.Result Property

public GetHoldOnMailboxesResponseMessageType Result {get;}

Remarks

See Also

GetHoldOnMailboxesCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetHoldOnMailboxesCompletedEventHandler Delegate

public delegate void GetHoldOnMailboxesCompletedEventHandler(
object sender,
GetHoldOnMailboxesCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetHoldOnMailboxesResponseMessageType Class

For a list of all members of this type, see GetHoldOnMailboxesResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetHoldOnMailboxesResponseMessageType

public class GetHoldOnMailboxesResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetHoldOnMailboxesResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetHoldOnMailboxesResponseMessageType Members

GetHoldOnMailboxesResponseMessageType overview

Public Instance Constructors

GetHoldOnMailboxesResponseMessageType Constructor Initializes a new instance of the GetHoldOnMailboxesResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MailboxHoldResult
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetHoldOnMailboxesResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetHoldOnMailboxesResponseMessageType Constructor

Initializes a new instance of the GetHoldOnMailboxesResponseMessageType class.

public GetHoldOnMailboxesResponseMessageType();

See Also

GetHoldOnMailboxesResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetHoldOnMailboxesResponseMessageType Properties

The properties of the GetHoldOnMailboxesResponseMessageType class are listed below. For a complete list of GetHoldOnMailboxesResponseMessageType class members, see the GetHoldOnMailboxesResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MailboxHoldResult
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

GetHoldOnMailboxesResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxHoldResult Property

Aspose.Email

GetHoldOnMailboxesResponseMessageType.MailboxHoldResult Property

public MailboxHoldResultType MailboxHoldResult {get; set;}

Remarks

See Also

GetHoldOnMailboxesResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetHoldOnMailboxesType Class

For a list of all members of this type, see GetHoldOnMailboxesType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.GetHoldOnMailboxesType

public class GetHoldOnMailboxesType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetHoldOnMailboxesType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetHoldOnMailboxesType Members

GetHoldOnMailboxesType overview

Public Instance Constructors

GetHoldOnMailboxesType Constructor Initializes a new instance of the GetHoldOnMailboxesType class.

Public Instance Properties

HoldId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetHoldOnMailboxesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetHoldOnMailboxesType Constructor

Initializes a new instance of the GetHoldOnMailboxesType class.

public GetHoldOnMailboxesType();

See Also

GetHoldOnMailboxesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetHoldOnMailboxesType Properties

The properties of the GetHoldOnMailboxesType class are listed below. For a complete list of GetHoldOnMailboxesType class members, see the GetHoldOnMailboxesType Members topic.

Public Instance Properties

HoldId

See Also

GetHoldOnMailboxesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


HoldId Property

Aspose.Email

GetHoldOnMailboxesType.HoldId Property

public string HoldId {get; set;}

Remarks

See Also

GetHoldOnMailboxesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetImItemListCompletedEventArgs Class

For a list of all members of this type, see GetImItemListCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetImItemListCompletedEventArgs

public class GetImItemListCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetImItemListCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetImItemListCompletedEventArgs Members

GetImItemListCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetImItemListCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetImItemListCompletedEventArgs Properties

The properties of the GetImItemListCompletedEventArgs class are listed below. For a complete list of GetImItemListCompletedEventArgs class members, see the GetImItemListCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetImItemListCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

GetImItemListCompletedEventArgs.Result Property

public GetImItemListResponseMessageType Result {get;}

Remarks

See Also

GetImItemListCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetImItemListCompletedEventHandler Delegate

public delegate void GetImItemListCompletedEventHandler(
object sender,
GetImItemListCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetImItemListResponseMessageType Class

For a list of all members of this type, see GetImItemListResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetImItemListResponseMessageType

public class GetImItemListResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetImItemListResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetImItemListResponseMessageType Members

GetImItemListResponseMessageType overview

Public Instance Constructors

GetImItemListResponseMessageType Constructor Initializes a new instance of the GetImItemListResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
ImItemList
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetImItemListResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetImItemListResponseMessageType Constructor

Initializes a new instance of the GetImItemListResponseMessageType class.

public GetImItemListResponseMessageType();

See Also

GetImItemListResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetImItemListResponseMessageType Properties

The properties of the GetImItemListResponseMessageType class are listed below. For a complete list of GetImItemListResponseMessageType class members, see the GetImItemListResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
ImItemList
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

GetImItemListResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ImItemList Property

Aspose.Email

GetImItemListResponseMessageType.ImItemList Property

public ImItemListType ImItemList {get; set;}

Remarks

See Also

GetImItemListResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetImItemListType Class

For a list of all members of this type, see GetImItemListType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.GetImItemListType

public class GetImItemListType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetImItemListType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetImItemListType Members

GetImItemListType overview

Public Instance Constructors

GetImItemListType Constructor Initializes a new instance of the GetImItemListType class.

Public Instance Properties

ExtendedProperties

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetImItemListType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetImItemListType Constructor

Initializes a new instance of the GetImItemListType class.

public GetImItemListType();

See Also

GetImItemListType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetImItemListType Properties

The properties of the GetImItemListType class are listed below. For a complete list of GetImItemListType class members, see the GetImItemListType Members topic.

Public Instance Properties

ExtendedProperties

See Also

GetImItemListType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExtendedProperties Property

Aspose.Email

GetImItemListType.ExtendedProperties Property

public PathToExtendedFieldType[] ExtendedProperties {get; set;}

Remarks

See Also

GetImItemListType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetImItemsCompletedEventArgs Class

For a list of all members of this type, see GetImItemsCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetImItemsCompletedEventArgs

public class GetImItemsCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetImItemsCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetImItemsCompletedEventArgs Members

GetImItemsCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetImItemsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetImItemsCompletedEventArgs Properties

The properties of the GetImItemsCompletedEventArgs class are listed below. For a complete list of GetImItemsCompletedEventArgs class members, see the GetImItemsCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetImItemsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

GetImItemsCompletedEventArgs.Result Property

public GetImItemsResponseMessageType Result {get;}

Remarks

See Also

GetImItemsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetImItemsCompletedEventHandler Delegate

public delegate void GetImItemsCompletedEventHandler(
object sender,
GetImItemsCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetImItemsResponseMessageType Class

For a list of all members of this type, see GetImItemsResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetImItemsResponseMessageType

public class GetImItemsResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetImItemsResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetImItemsResponseMessageType Members

GetImItemsResponseMessageType overview

Public Instance Constructors

GetImItemsResponseMessageType Constructor Initializes a new instance of the GetImItemsResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
ImItemList
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetImItemsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetImItemsResponseMessageType Constructor

Initializes a new instance of the GetImItemsResponseMessageType class.

public GetImItemsResponseMessageType();

See Also

GetImItemsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetImItemsResponseMessageType Properties

The properties of the GetImItemsResponseMessageType class are listed below. For a complete list of GetImItemsResponseMessageType class members, see the GetImItemsResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
ImItemList
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

GetImItemsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ImItemList Property

Aspose.Email

GetImItemsResponseMessageType.ImItemList Property

public ImItemListType ImItemList {get; set;}

Remarks

See Also

GetImItemsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetImItemsType Class

For a list of all members of this type, see GetImItemsType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.GetImItemsType

public class GetImItemsType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetImItemsType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetImItemsType Members

GetImItemsType overview

Public Instance Constructors

GetImItemsType Constructor Initializes a new instance of the GetImItemsType class.

Public Instance Properties

ContactIds
ExtendedProperties
GroupIds

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetImItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetImItemsType Constructor

Initializes a new instance of the GetImItemsType class.

public GetImItemsType();

See Also

GetImItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetImItemsType Properties

The properties of the GetImItemsType class are listed below. For a complete list of GetImItemsType class members, see the GetImItemsType Members topic.

Public Instance Properties

ContactIds
ExtendedProperties
GroupIds

See Also

GetImItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContactIds Property

Aspose.Email

GetImItemsType.ContactIds Property

public BaseItemIdType[] ContactIds {get; set;}

Remarks

See Also

GetImItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExtendedProperties Property

Aspose.Email

GetImItemsType.ExtendedProperties Property

public PathToExtendedFieldType[] ExtendedProperties {get; set;}

Remarks

See Also

GetImItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GroupIds Property

Aspose.Email

GetImItemsType.GroupIds Property

public BaseItemIdType[] GroupIds {get; set;}

Remarks

See Also

GetImItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetInboxRulesCompletedEventArgs Class

For a list of all members of this type, see GetInboxRulesCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetInboxRulesCompletedEventArgs

public class GetInboxRulesCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetInboxRulesCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetInboxRulesCompletedEventArgs Members

GetInboxRulesCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetInboxRulesCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetInboxRulesCompletedEventArgs Properties

The properties of the GetInboxRulesCompletedEventArgs class are listed below. For a complete list of GetInboxRulesCompletedEventArgs class members, see the GetInboxRulesCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetInboxRulesCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

GetInboxRulesCompletedEventArgs.Result Property

public GetInboxRulesResponseType Result {get;}

Remarks

See Also

GetInboxRulesCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetInboxRulesCompletedEventHandler Delegate

public delegate void GetInboxRulesCompletedEventHandler(
object sender,
GetInboxRulesCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetInboxRulesRequestType Class

For a list of all members of this type, see GetInboxRulesRequestType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.GetInboxRulesRequestType

public class GetInboxRulesRequestType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetInboxRulesRequestType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetInboxRulesRequestType Members

GetInboxRulesRequestType overview

Public Instance Constructors

GetInboxRulesRequestType Constructor Initializes a new instance of the GetInboxRulesRequestType class.

Public Instance Properties

MailboxSmtpAddress

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetInboxRulesRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetInboxRulesRequestType Constructor

Initializes a new instance of the GetInboxRulesRequestType class.

public GetInboxRulesRequestType();

See Also

GetInboxRulesRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetInboxRulesRequestType Properties

The properties of the GetInboxRulesRequestType class are listed below. For a complete list of GetInboxRulesRequestType class members, see the GetInboxRulesRequestType Members topic.

Public Instance Properties

MailboxSmtpAddress

See Also

GetInboxRulesRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxSmtpAddress Property

Aspose.Email

GetInboxRulesRequestType.MailboxSmtpAddress Property

public string MailboxSmtpAddress {get; set;}

Remarks

See Also

GetInboxRulesRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetInboxRulesResponseType Class

For a list of all members of this type, see GetInboxRulesResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetInboxRulesResponseType

public class GetInboxRulesResponseType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetInboxRulesResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetInboxRulesResponseType Members

GetInboxRulesResponseType overview

Public Instance Constructors

GetInboxRulesResponseType Constructor Initializes a new instance of the GetInboxRulesResponseType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
InboxRules
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
OutlookRuleBlobExists
OutlookRuleBlobExistsSpecified
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetInboxRulesResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetInboxRulesResponseType Constructor

Initializes a new instance of the GetInboxRulesResponseType class.

public GetInboxRulesResponseType();

See Also

GetInboxRulesResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetInboxRulesResponseType Properties

The properties of the GetInboxRulesResponseType class are listed below. For a complete list of GetInboxRulesResponseType class members, see the GetInboxRulesResponseType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
InboxRules
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
OutlookRuleBlobExists
OutlookRuleBlobExistsSpecified
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

GetInboxRulesResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InboxRules Property

Aspose.Email

GetInboxRulesResponseType.InboxRules Property

public RuleType[] InboxRules {get; set;}

Remarks

See Also

GetInboxRulesResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OutlookRuleBlobExists Property

Aspose.Email

GetInboxRulesResponseType.OutlookRuleBlobExists Property

public bool OutlookRuleBlobExists {get; set;}

Remarks

See Also

GetInboxRulesResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OutlookRuleBlobExistsSpecified Property

Aspose.Email

GetInboxRulesResponseType.OutlookRuleBlobExistsSpecified Property

public bool OutlookRuleBlobExistsSpecified {get; set;}

Remarks

See Also

GetInboxRulesResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetItemCompletedEventArgs Class

For a list of all members of this type, see GetItemCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetItemCompletedEventArgs

public class GetItemCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetItemCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetItemCompletedEventArgs Members

GetItemCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetItemCompletedEventArgs Properties

The properties of the GetItemCompletedEventArgs class are listed below. For a complete list of GetItemCompletedEventArgs class members, see the GetItemCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

GetItemCompletedEventArgs.Result Property

public GetItemResponseType Result {get;}

Remarks

See Also

GetItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetItemCompletedEventHandler Delegate

public delegate void GetItemCompletedEventHandler(
object sender,
GetItemCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetItemResponseType Class

For a list of all members of this type, see GetItemResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetItemResponseType

public class GetItemResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetItemResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetItemResponseType Members

GetItemResponseType overview

Public Instance Constructors

GetItemResponseType Constructor Initializes a new instance of the GetItemResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetItemResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetItemResponseType Constructor

Initializes a new instance of the GetItemResponseType class.

public GetItemResponseType();

See Also

GetItemResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetItemType Class

For a list of all members of this type, see GetItemType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.GetItemType

public class GetItemType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetItemType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetItemType Members

GetItemType overview

Public Instance Constructors

GetItemType Constructor Initializes a new instance of the GetItemType class.

Public Instance Properties

ItemIds
ItemShape

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetItemType Constructor

Initializes a new instance of the GetItemType class.

public GetItemType();

See Also

GetItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetItemType Properties

The properties of the GetItemType class are listed below. For a complete list of GetItemType class members, see the GetItemType Members topic.

Public Instance Properties

ItemIds
ItemShape

See Also

GetItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemIds Property

Aspose.Email

GetItemType.ItemIds Property

public BaseItemIdType[] ItemIds {get; set;}

Remarks

See Also

GetItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemShape Property

Aspose.Email

GetItemType.ItemShape Property

public ItemResponseShapeType ItemShape {get; set;}

Remarks

See Also

GetItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetMailTipsCompletedEventArgs Class

For a list of all members of this type, see GetMailTipsCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetMailTipsCompletedEventArgs

public class GetMailTipsCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetMailTipsCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetMailTipsCompletedEventArgs Members

GetMailTipsCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetMailTipsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetMailTipsCompletedEventArgs Properties

The properties of the GetMailTipsCompletedEventArgs class are listed below. For a complete list of GetMailTipsCompletedEventArgs class members, see the GetMailTipsCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetMailTipsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

GetMailTipsCompletedEventArgs.Result Property

public GetMailTipsResponseMessageType Result {get;}

Remarks

See Also

GetMailTipsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetMailTipsCompletedEventHandler Delegate

public delegate void GetMailTipsCompletedEventHandler(
object sender,
GetMailTipsCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetMailTipsResponseMessageType Class

For a list of all members of this type, see GetMailTipsResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetMailTipsResponseMessageType

public class GetMailTipsResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetMailTipsResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetMailTipsResponseMessageType Members

GetMailTipsResponseMessageType overview

Public Instance Constructors

GetMailTipsResponseMessageType Constructor Initializes a new instance of the GetMailTipsResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
ResponseMessages

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetMailTipsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetMailTipsResponseMessageType Constructor

Initializes a new instance of the GetMailTipsResponseMessageType class.

public GetMailTipsResponseMessageType();

See Also

GetMailTipsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetMailTipsResponseMessageType Properties

The properties of the GetMailTipsResponseMessageType class are listed below. For a complete list of GetMailTipsResponseMessageType class members, see the GetMailTipsResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
ResponseMessages

See Also

GetMailTipsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResponseMessages Property

Aspose.Email

GetMailTipsResponseMessageType.ResponseMessages Property

public MailTipsResponseMessageType[] ResponseMessages {get; set;}

Remarks

See Also

GetMailTipsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetMailTipsType Class

For a list of all members of this type, see GetMailTipsType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.GetMailTipsType

public class GetMailTipsType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetMailTipsType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetMailTipsType Members

GetMailTipsType overview

Public Instance Constructors

GetMailTipsType Constructor Initializes a new instance of the GetMailTipsType class.

Public Instance Properties

MailTipsRequested
Recipients
SendingAs

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetMailTipsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetMailTipsType Constructor

Initializes a new instance of the GetMailTipsType class.

public GetMailTipsType();

See Also

GetMailTipsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetMailTipsType Properties

The properties of the GetMailTipsType class are listed below. For a complete list of GetMailTipsType class members, see the GetMailTipsType Members topic.

Public Instance Properties

MailTipsRequested
Recipients
SendingAs

See Also

GetMailTipsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailTipsRequested Property

Aspose.Email

GetMailTipsType.MailTipsRequested Property

public MailTipTypes MailTipsRequested {get; set;}

Remarks

See Also

GetMailTipsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Recipients Property

Aspose.Email

GetMailTipsType.Recipients Property

public EmailAddressType[] Recipients {get; set;}

Remarks

See Also

GetMailTipsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SendingAs Property

Aspose.Email

GetMailTipsType.SendingAs Property

public EmailAddressType SendingAs {get; set;}

Remarks

See Also

GetMailTipsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetMessageTrackingReportCompletedEventArgs Class

For a list of all members of this type, see GetMessageTrackingReportCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetMessageTrackingReportCompletedEventArgs

public class GetMessageTrackingReportCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetMessageTrackingReportCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetMessageTrackingReportCompletedEventArgs Members

GetMessageTrackingReportCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetMessageTrackingReportCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetMessageTrackingReportCompletedEventArgs Properties

The properties of the GetMessageTrackingReportCompletedEventArgs class are listed below. For a complete list of GetMessageTrackingReportCompletedEventArgs class members, see the GetMessageTrackingReportCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetMessageTrackingReportCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

GetMessageTrackingReportCompletedEventArgs.Result Property

public GetMessageTrackingReportResponseMessageType Result {get;}

Remarks

See Also

GetMessageTrackingReportCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetMessageTrackingReportCompletedEventHandler Delegate

public delegate void GetMessageTrackingReportCompletedEventHandler(
object sender,
GetMessageTrackingReportCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetMessageTrackingReportRequestType Class

For a list of all members of this type, see GetMessageTrackingReportRequestType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.GetMessageTrackingReportRequestType

public class GetMessageTrackingReportRequestType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetMessageTrackingReportRequestType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetMessageTrackingReportRequestType Members

GetMessageTrackingReportRequestType overview

Public Instance Constructors

GetMessageTrackingReportRequestType Constructor Initializes a new instance of the GetMessageTrackingReportRequestType class.

Public Instance Properties

DiagnosticsLevel
MessageTrackingReportId
Properties
RecipientFilter
ReportTemplate
ReturnQueueEvents
ReturnQueueEventsSpecified
Scope

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetMessageTrackingReportRequestType Constructor

Initializes a new instance of the GetMessageTrackingReportRequestType class.

public GetMessageTrackingReportRequestType();

See Also

GetMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetMessageTrackingReportRequestType Properties

The properties of the GetMessageTrackingReportRequestType class are listed below. For a complete list of GetMessageTrackingReportRequestType class members, see the GetMessageTrackingReportRequestType Members topic.

Public Instance Properties

DiagnosticsLevel
MessageTrackingReportId
Properties
RecipientFilter
ReportTemplate
ReturnQueueEvents
ReturnQueueEventsSpecified
Scope

See Also

GetMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DiagnosticsLevel Property

Aspose.Email

GetMessageTrackingReportRequestType.DiagnosticsLevel Property

public string DiagnosticsLevel {get; set;}

Remarks

See Also

GetMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MessageTrackingReportId Property

Aspose.Email

GetMessageTrackingReportRequestType.MessageTrackingReportId Property

public string MessageTrackingReportId {get; set;}

Remarks

See Also

GetMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Properties Property

Aspose.Email

GetMessageTrackingReportRequestType.Properties Property

public TrackingPropertyType[] Properties {get; set;}

Remarks

See Also

GetMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecipientFilter Property

Aspose.Email

GetMessageTrackingReportRequestType.RecipientFilter Property

public EmailAddressType RecipientFilter {get; set;}

Remarks

See Also

GetMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReportTemplate Property

Aspose.Email

GetMessageTrackingReportRequestType.ReportTemplate Property

public MessageTrackingReportTemplateType ReportTemplate {get; set;}

Remarks

See Also

GetMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReturnQueueEvents Property

Aspose.Email

GetMessageTrackingReportRequestType.ReturnQueueEvents Property

public bool ReturnQueueEvents {get; set;}

Remarks

See Also

GetMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReturnQueueEventsSpecified Property

Aspose.Email

GetMessageTrackingReportRequestType.ReturnQueueEventsSpecified Property

public bool ReturnQueueEventsSpecified {get; set;}

Remarks

See Also

GetMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Scope Property

Aspose.Email

GetMessageTrackingReportRequestType.Scope Property

public string Scope {get; set;}

Remarks

See Also

GetMessageTrackingReportRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetMessageTrackingReportResponseMessageType Class

For a list of all members of this type, see GetMessageTrackingReportResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetMessageTrackingReportResponseMessageType

public class GetMessageTrackingReportResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetMessageTrackingReportResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetMessageTrackingReportResponseMessageType Members

GetMessageTrackingReportResponseMessageType overview

Public Instance Constructors

GetMessageTrackingReportResponseMessageType Constructor Initializes a new instance of the GetMessageTrackingReportResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
Diagnostics
Errors
MessageText (inherited from ResponseMessageType)
MessageTrackingReport
MessageXml (inherited from ResponseMessageType)
Properties
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetMessageTrackingReportResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetMessageTrackingReportResponseMessageType Constructor

Initializes a new instance of the GetMessageTrackingReportResponseMessageType class.

public GetMessageTrackingReportResponseMessageType();

See Also

GetMessageTrackingReportResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetMessageTrackingReportResponseMessageType Properties

The properties of the GetMessageTrackingReportResponseMessageType class are listed below. For a complete list of GetMessageTrackingReportResponseMessageType class members, see the GetMessageTrackingReportResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
Diagnostics
Errors
MessageText (inherited from ResponseMessageType)
MessageTrackingReport
MessageXml (inherited from ResponseMessageType)
Properties
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

GetMessageTrackingReportResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Diagnostics Property

Aspose.Email

GetMessageTrackingReportResponseMessageType.Diagnostics Property

public string[] Diagnostics {get; set;}

Remarks

See Also

GetMessageTrackingReportResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Errors Property

Aspose.Email

GetMessageTrackingReportResponseMessageType.Errors Property

public ArrayOfTrackingPropertiesType[] Errors {get; set;}

Remarks

See Also

GetMessageTrackingReportResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MessageTrackingReport Property

Aspose.Email

GetMessageTrackingReportResponseMessageType.MessageTrackingReport Property

public MessageTrackingReportType MessageTrackingReport {get; set;}

Remarks

See Also

GetMessageTrackingReportResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Properties Property

Aspose.Email

GetMessageTrackingReportResponseMessageType.Properties Property

public TrackingPropertyType[] Properties {get; set;}

Remarks

See Also

GetMessageTrackingReportResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetNonIndexableItemDetailsCompletedEventArgs Class

For a list of all members of this type, see GetNonIndexableItemDetailsCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetNonIndexableItemDetailsCompletedEventArgs

public class GetNonIndexableItemDetailsCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetNonIndexableItemDetailsCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetNonIndexableItemDetailsCompletedEventArgs Members

GetNonIndexableItemDetailsCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetNonIndexableItemDetailsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetNonIndexableItemDetailsCompletedEventArgs Properties

The properties of the GetNonIndexableItemDetailsCompletedEventArgs class are listed below. For a complete list of GetNonIndexableItemDetailsCompletedEventArgs class members, see the GetNonIndexableItemDetailsCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetNonIndexableItemDetailsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

GetNonIndexableItemDetailsCompletedEventArgs.Result Property

public GetNonIndexableItemDetailsResponseMessageType Result {get;}

Remarks

See Also

GetNonIndexableItemDetailsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetNonIndexableItemDetailsCompletedEventHandler Delegate

public delegate void GetNonIndexableItemDetailsCompletedEventHandler(
object sender,
GetNonIndexableItemDetailsCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetNonIndexableItemDetailsResponseMessageType Class

For a list of all members of this type, see GetNonIndexableItemDetailsResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetNonIndexableItemDetailsResponseMessageType

public class GetNonIndexableItemDetailsResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetNonIndexableItemDetailsResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetNonIndexableItemDetailsResponseMessageType Members

GetNonIndexableItemDetailsResponseMessageType overview

Public Instance Constructors

GetNonIndexableItemDetailsResponseMessageType Constructor Initializes a new instance of the GetNonIndexableItemDetailsResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
NonIndexableItemDetailsResult
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetNonIndexableItemDetailsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetNonIndexableItemDetailsResponseMessageType Constructor

Initializes a new instance of the GetNonIndexableItemDetailsResponseMessageType class.

public GetNonIndexableItemDetailsResponseMessageType();

See Also

GetNonIndexableItemDetailsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetNonIndexableItemDetailsResponseMessageType Properties

The properties of the GetNonIndexableItemDetailsResponseMessageType class are listed below. For a complete list of GetNonIndexableItemDetailsResponseMessageType class members, see the GetNonIndexableItemDetailsResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
NonIndexableItemDetailsResult
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

GetNonIndexableItemDetailsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NonIndexableItemDetailsResult Property

Aspose.Email

GetNonIndexableItemDetailsResponseMessageType.NonIndexableItemDetailsResult Property

public NonIndexableItemDetailResultType NonIndexableItemDetailsResult {get; set;}

Remarks

See Also

GetNonIndexableItemDetailsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetNonIndexableItemDetailsType Class

For a list of all members of this type, see GetNonIndexableItemDetailsType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.GetNonIndexableItemDetailsType

public class GetNonIndexableItemDetailsType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetNonIndexableItemDetailsType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetNonIndexableItemDetailsType Members

GetNonIndexableItemDetailsType overview

Public Instance Constructors

GetNonIndexableItemDetailsType Constructor Initializes a new instance of the GetNonIndexableItemDetailsType class.

Public Instance Properties

Mailboxes
PageDirection
PageDirectionSpecified
PageItemReference
PageSize
PageSizeSpecified
SearchArchiveOnly
SearchArchiveOnlySpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetNonIndexableItemDetailsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetNonIndexableItemDetailsType Constructor

Initializes a new instance of the GetNonIndexableItemDetailsType class.

public GetNonIndexableItemDetailsType();

See Also

GetNonIndexableItemDetailsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetNonIndexableItemDetailsType Properties

The properties of the GetNonIndexableItemDetailsType class are listed below. For a complete list of GetNonIndexableItemDetailsType class members, see the GetNonIndexableItemDetailsType Members topic.

Public Instance Properties

Mailboxes
PageDirection
PageDirectionSpecified
PageItemReference
PageSize
PageSizeSpecified
SearchArchiveOnly
SearchArchiveOnlySpecified

See Also

GetNonIndexableItemDetailsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Mailboxes Property

Aspose.Email

GetNonIndexableItemDetailsType.Mailboxes Property

public string[] Mailboxes {get; set;}

Remarks

See Also

GetNonIndexableItemDetailsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PageDirection Property

Aspose.Email

GetNonIndexableItemDetailsType.PageDirection Property

public SearchPageDirectionType PageDirection {get; set;}

Remarks

See Also

GetNonIndexableItemDetailsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PageDirectionSpecified Property

Aspose.Email

GetNonIndexableItemDetailsType.PageDirectionSpecified Property

public bool PageDirectionSpecified {get; set;}

Remarks

See Also

GetNonIndexableItemDetailsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PageItemReference Property

Aspose.Email

GetNonIndexableItemDetailsType.PageItemReference Property

public string PageItemReference {get; set;}

Remarks

See Also

GetNonIndexableItemDetailsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PageSize Property

Aspose.Email

GetNonIndexableItemDetailsType.PageSize Property

public int PageSize {get; set;}

Remarks

See Also

GetNonIndexableItemDetailsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PageSizeSpecified Property

Aspose.Email

GetNonIndexableItemDetailsType.PageSizeSpecified Property

public bool PageSizeSpecified {get; set;}

Remarks

See Also

GetNonIndexableItemDetailsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchArchiveOnly Property

Aspose.Email

GetNonIndexableItemDetailsType.SearchArchiveOnly Property

public bool SearchArchiveOnly {get; set;}

Remarks

See Also

GetNonIndexableItemDetailsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchArchiveOnlySpecified Property

Aspose.Email

GetNonIndexableItemDetailsType.SearchArchiveOnlySpecified Property

public bool SearchArchiveOnlySpecified {get; set;}

Remarks

See Also

GetNonIndexableItemDetailsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetNonIndexableItemStatisticsCompletedEventArgs Class

For a list of all members of this type, see GetNonIndexableItemStatisticsCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetNonIndexableItemStatisticsCompletedEventArgs

public class GetNonIndexableItemStatisticsCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetNonIndexableItemStatisticsCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetNonIndexableItemStatisticsCompletedEventArgs Members

GetNonIndexableItemStatisticsCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetNonIndexableItemStatisticsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetNonIndexableItemStatisticsCompletedEventArgs Properties

The properties of the GetNonIndexableItemStatisticsCompletedEventArgs class are listed below. For a complete list of GetNonIndexableItemStatisticsCompletedEventArgs class members, see the GetNonIndexableItemStatisticsCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetNonIndexableItemStatisticsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

GetNonIndexableItemStatisticsCompletedEventArgs.Result Property

public GetNonIndexableItemStatisticsResponseMessageType Result {get;}

Remarks

See Also

GetNonIndexableItemStatisticsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetNonIndexableItemStatisticsCompletedEventHandler Delegate

public delegate void GetNonIndexableItemStatisticsCompletedEventHandler(
object sender,
GetNonIndexableItemStatisticsCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetNonIndexableItemStatisticsResponseMessageType Class

For a list of all members of this type, see GetNonIndexableItemStatisticsResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetNonIndexableItemStatisticsResponseMessageType

public class GetNonIndexableItemStatisticsResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetNonIndexableItemStatisticsResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetNonIndexableItemStatisticsResponseMessageType Members

GetNonIndexableItemStatisticsResponseMessageType overview

Public Instance Constructors

GetNonIndexableItemStatisticsResponseMessageType Constructor Initializes a new instance of the GetNonIndexableItemStatisticsResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
NonIndexableItemStatistics
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetNonIndexableItemStatisticsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetNonIndexableItemStatisticsResponseMessageType Constructor

Initializes a new instance of the GetNonIndexableItemStatisticsResponseMessageType class.

public GetNonIndexableItemStatisticsResponseMessageType();

See Also

GetNonIndexableItemStatisticsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetNonIndexableItemStatisticsResponseMessageType Properties

The properties of the GetNonIndexableItemStatisticsResponseMessageType class are listed below. For a complete list of GetNonIndexableItemStatisticsResponseMessageType class members, see the GetNonIndexableItemStatisticsResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
NonIndexableItemStatistics
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

GetNonIndexableItemStatisticsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NonIndexableItemStatistics Property

Aspose.Email

GetNonIndexableItemStatisticsResponseMessageType.NonIndexableItemStatistics Property

public NonIndexableItemStatisticType[] NonIndexableItemStatistics {get; set;}

Remarks

See Also

GetNonIndexableItemStatisticsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetNonIndexableItemStatisticsType Class

For a list of all members of this type, see GetNonIndexableItemStatisticsType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.GetNonIndexableItemStatisticsType

public class GetNonIndexableItemStatisticsType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetNonIndexableItemStatisticsType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetNonIndexableItemStatisticsType Members

GetNonIndexableItemStatisticsType overview

Public Instance Constructors

GetNonIndexableItemStatisticsType Constructor Initializes a new instance of the GetNonIndexableItemStatisticsType class.

Public Instance Properties

Mailboxes
SearchArchiveOnly
SearchArchiveOnlySpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetNonIndexableItemStatisticsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetNonIndexableItemStatisticsType Constructor

Initializes a new instance of the GetNonIndexableItemStatisticsType class.

public GetNonIndexableItemStatisticsType();

See Also

GetNonIndexableItemStatisticsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetNonIndexableItemStatisticsType Properties

The properties of the GetNonIndexableItemStatisticsType class are listed below. For a complete list of GetNonIndexableItemStatisticsType class members, see the GetNonIndexableItemStatisticsType Members topic.

Public Instance Properties

Mailboxes
SearchArchiveOnly
SearchArchiveOnlySpecified

See Also

GetNonIndexableItemStatisticsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Mailboxes Property

Aspose.Email

GetNonIndexableItemStatisticsType.Mailboxes Property

public string[] Mailboxes {get; set;}

Remarks

See Also

GetNonIndexableItemStatisticsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchArchiveOnly Property

Aspose.Email

GetNonIndexableItemStatisticsType.SearchArchiveOnly Property

public bool SearchArchiveOnly {get; set;}

Remarks

See Also

GetNonIndexableItemStatisticsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchArchiveOnlySpecified Property

Aspose.Email

GetNonIndexableItemStatisticsType.SearchArchiveOnlySpecified Property

public bool SearchArchiveOnlySpecified {get; set;}

Remarks

See Also

GetNonIndexableItemStatisticsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetPasswordExpirationDateCompletedEventArgs Class

For a list of all members of this type, see GetPasswordExpirationDateCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetPasswordExpirationDateCompletedEventArgs

public class GetPasswordExpirationDateCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetPasswordExpirationDateCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetPasswordExpirationDateCompletedEventArgs Members

GetPasswordExpirationDateCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetPasswordExpirationDateCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetPasswordExpirationDateCompletedEventArgs Properties

The properties of the GetPasswordExpirationDateCompletedEventArgs class are listed below. For a complete list of GetPasswordExpirationDateCompletedEventArgs class members, see the GetPasswordExpirationDateCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetPasswordExpirationDateCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

GetPasswordExpirationDateCompletedEventArgs.Result Property

public GetPasswordExpirationDateResponseMessageType Result {get;}

Remarks

See Also

GetPasswordExpirationDateCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetPasswordExpirationDateCompletedEventHandler Delegate

public delegate void GetPasswordExpirationDateCompletedEventHandler(
object sender,
GetPasswordExpirationDateCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetPasswordExpirationDateResponseMessageType Class

For a list of all members of this type, see GetPasswordExpirationDateResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetPasswordExpirationDateResponseMessageType

public class GetPasswordExpirationDateResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetPasswordExpirationDateResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetPasswordExpirationDateResponseMessageType Members

GetPasswordExpirationDateResponseMessageType overview

Public Instance Constructors

GetPasswordExpirationDateResponseMessageType Constructor Initializes a new instance of the GetPasswordExpirationDateResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
PasswordExpirationDate
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetPasswordExpirationDateResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetPasswordExpirationDateResponseMessageType Constructor

Initializes a new instance of the GetPasswordExpirationDateResponseMessageType class.

public GetPasswordExpirationDateResponseMessageType();

See Also

GetPasswordExpirationDateResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetPasswordExpirationDateResponseMessageType Properties

The properties of the GetPasswordExpirationDateResponseMessageType class are listed below. For a complete list of GetPasswordExpirationDateResponseMessageType class members, see the GetPasswordExpirationDateResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
PasswordExpirationDate
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

GetPasswordExpirationDateResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PasswordExpirationDate Property

Aspose.Email

GetPasswordExpirationDateResponseMessageType.PasswordExpirationDate Property

public DateTime PasswordExpirationDate {get; set;}

Remarks

See Also

GetPasswordExpirationDateResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetPasswordExpirationDateType Class

For a list of all members of this type, see GetPasswordExpirationDateType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.GetPasswordExpirationDateType

public class GetPasswordExpirationDateType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetPasswordExpirationDateType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetPasswordExpirationDateType Members

GetPasswordExpirationDateType overview

Public Instance Constructors

GetPasswordExpirationDateType Constructor Initializes a new instance of the GetPasswordExpirationDateType class.

Public Instance Properties

MailboxSmtpAddress

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetPasswordExpirationDateType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetPasswordExpirationDateType Constructor

Initializes a new instance of the GetPasswordExpirationDateType class.

public GetPasswordExpirationDateType();

See Also

GetPasswordExpirationDateType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetPasswordExpirationDateType Properties

The properties of the GetPasswordExpirationDateType class are listed below. For a complete list of GetPasswordExpirationDateType class members, see the GetPasswordExpirationDateType Members topic.

Public Instance Properties

MailboxSmtpAddress

See Also

GetPasswordExpirationDateType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxSmtpAddress Property

Aspose.Email

GetPasswordExpirationDateType.MailboxSmtpAddress Property

public string MailboxSmtpAddress {get; set;}

Remarks

See Also

GetPasswordExpirationDateType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetPersonaCompletedEventArgs Class

For a list of all members of this type, see GetPersonaCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetPersonaCompletedEventArgs

public class GetPersonaCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetPersonaCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetPersonaCompletedEventArgs Members

GetPersonaCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetPersonaCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetPersonaCompletedEventArgs Properties

The properties of the GetPersonaCompletedEventArgs class are listed below. For a complete list of GetPersonaCompletedEventArgs class members, see the GetPersonaCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetPersonaCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

GetPersonaCompletedEventArgs.Result Property

public GetPersonaResponseMessageType Result {get;}

Remarks

See Also

GetPersonaCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetPersonaCompletedEventHandler Delegate

public delegate void GetPersonaCompletedEventHandler(
object sender,
GetPersonaCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetPersonaResponseMessageType Class

For a list of all members of this type, see GetPersonaResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetPersonaResponseMessageType

public class GetPersonaResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetPersonaResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetPersonaResponseMessageType Members

GetPersonaResponseMessageType overview

Public Instance Constructors

GetPersonaResponseMessageType Constructor Initializes a new instance of the GetPersonaResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
Persona
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetPersonaResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetPersonaResponseMessageType Constructor

Initializes a new instance of the GetPersonaResponseMessageType class.

public GetPersonaResponseMessageType();

See Also

GetPersonaResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetPersonaResponseMessageType Properties

The properties of the GetPersonaResponseMessageType class are listed below. For a complete list of GetPersonaResponseMessageType class members, see the GetPersonaResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
Persona
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

GetPersonaResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Persona Property

Aspose.Email

GetPersonaResponseMessageType.Persona Property

public PersonaType Persona {get; set;}

Remarks

See Also

GetPersonaResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetPersonaType Class

For a list of all members of this type, see GetPersonaType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.GetPersonaType

public class GetPersonaType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetPersonaType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetPersonaType Members

GetPersonaType overview

Public Instance Constructors

GetPersonaType Constructor Initializes a new instance of the GetPersonaType class.

Public Instance Properties

PersonaId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetPersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetPersonaType Constructor

Initializes a new instance of the GetPersonaType class.

public GetPersonaType();

See Also

GetPersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetPersonaType Properties

The properties of the GetPersonaType class are listed below. For a complete list of GetPersonaType class members, see the GetPersonaType Members topic.

Public Instance Properties

PersonaId

See Also

GetPersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PersonaId Property

Aspose.Email

GetPersonaType.PersonaId Property

public ItemIdType PersonaId {get; set;}

Remarks

See Also

GetPersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetPhoneCallInformationCompletedEventArgs Class

For a list of all members of this type, see GetPhoneCallInformationCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetPhoneCallInformationCompletedEventArgs

public class GetPhoneCallInformationCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetPhoneCallInformationCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetPhoneCallInformationCompletedEventArgs Members

GetPhoneCallInformationCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetPhoneCallInformationCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetPhoneCallInformationCompletedEventArgs Properties

The properties of the GetPhoneCallInformationCompletedEventArgs class are listed below. For a complete list of GetPhoneCallInformationCompletedEventArgs class members, see the GetPhoneCallInformationCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetPhoneCallInformationCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

GetPhoneCallInformationCompletedEventArgs.Result Property

public GetPhoneCallInformationResponseMessageType Result {get;}

Remarks

See Also

GetPhoneCallInformationCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetPhoneCallInformationCompletedEventHandler Delegate

public delegate void GetPhoneCallInformationCompletedEventHandler(
object sender,
GetPhoneCallInformationCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetPhoneCallInformationResponseMessageType Class

For a list of all members of this type, see GetPhoneCallInformationResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetPhoneCallInformationResponseMessageType

public class GetPhoneCallInformationResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetPhoneCallInformationResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetPhoneCallInformationResponseMessageType Members

GetPhoneCallInformationResponseMessageType overview

Public Instance Constructors

GetPhoneCallInformationResponseMessageType Constructor Initializes a new instance of the GetPhoneCallInformationResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
PhoneCallInformation
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetPhoneCallInformationResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetPhoneCallInformationResponseMessageType Constructor

Initializes a new instance of the GetPhoneCallInformationResponseMessageType class.

public GetPhoneCallInformationResponseMessageType();

See Also

GetPhoneCallInformationResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetPhoneCallInformationResponseMessageType Properties

The properties of the GetPhoneCallInformationResponseMessageType class are listed below. For a complete list of GetPhoneCallInformationResponseMessageType class members, see the GetPhoneCallInformationResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
PhoneCallInformation
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

GetPhoneCallInformationResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PhoneCallInformation Property

Aspose.Email

GetPhoneCallInformationResponseMessageType.PhoneCallInformation Property

public PhoneCallInformationType PhoneCallInformation {get; set;}

Remarks

See Also

GetPhoneCallInformationResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetPhoneCallInformationType Class

For a list of all members of this type, see GetPhoneCallInformationType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.GetPhoneCallInformationType

public class GetPhoneCallInformationType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetPhoneCallInformationType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetPhoneCallInformationType Members

GetPhoneCallInformationType overview

Public Instance Constructors

GetPhoneCallInformationType Constructor Initializes a new instance of the GetPhoneCallInformationType class.

Public Instance Properties

PhoneCallId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetPhoneCallInformationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetPhoneCallInformationType Constructor

Initializes a new instance of the GetPhoneCallInformationType class.

public GetPhoneCallInformationType();

See Also

GetPhoneCallInformationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetPhoneCallInformationType Properties

The properties of the GetPhoneCallInformationType class are listed below. For a complete list of GetPhoneCallInformationType class members, see the GetPhoneCallInformationType Members topic.

Public Instance Properties

PhoneCallId

See Also

GetPhoneCallInformationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PhoneCallId Property

Aspose.Email

GetPhoneCallInformationType.PhoneCallId Property

public PhoneCallIdType PhoneCallId {get; set;}

Remarks

See Also

GetPhoneCallInformationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetRemindersResponseMessageType Class

For a list of all members of this type, see GetRemindersResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetRemindersResponseMessageType

public class GetRemindersResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetRemindersResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetRemindersResponseMessageType Members

GetRemindersResponseMessageType overview

Public Instance Constructors

GetRemindersResponseMessageType Constructor Initializes a new instance of the GetRemindersResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
Reminders
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetRemindersResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetRemindersResponseMessageType Constructor

Initializes a new instance of the GetRemindersResponseMessageType class.

public GetRemindersResponseMessageType();

See Also

GetRemindersResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetRemindersResponseMessageType Properties

The properties of the GetRemindersResponseMessageType class are listed below. For a complete list of GetRemindersResponseMessageType class members, see the GetRemindersResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
Reminders
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

GetRemindersResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Reminders Property

Aspose.Email

GetRemindersResponseMessageType.Reminders Property

public ReminderType[] Reminders {get; set;}

Remarks

See Also

GetRemindersResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetRemindersType Class

For a list of all members of this type, see GetRemindersType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.GetRemindersType

public class GetRemindersType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetRemindersType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetRemindersType Members

GetRemindersType overview

Public Instance Constructors

GetRemindersType Constructor Initializes a new instance of the GetRemindersType class.

Public Instance Properties

BeginTime
BeginTimeSpecified
EndTime
EndTimeSpecified
MaxItems
MaxItemsSpecified
ReminderType
ReminderTypeSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetRemindersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetRemindersType Constructor

Initializes a new instance of the GetRemindersType class.

public GetRemindersType();

See Also

GetRemindersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetRemindersType Properties

The properties of the GetRemindersType class are listed below. For a complete list of GetRemindersType class members, see the GetRemindersType Members topic.

Public Instance Properties

BeginTime
BeginTimeSpecified
EndTime
EndTimeSpecified
MaxItems
MaxItemsSpecified
ReminderType
ReminderTypeSpecified

See Also

GetRemindersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BeginTime Property

Aspose.Email

GetRemindersType.BeginTime Property

public DateTime BeginTime {get; set;}

Remarks

See Also

GetRemindersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BeginTimeSpecified Property

Aspose.Email

GetRemindersType.BeginTimeSpecified Property

public bool BeginTimeSpecified {get; set;}

Remarks

See Also

GetRemindersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EndTime Property

Aspose.Email

GetRemindersType.EndTime Property

public DateTime EndTime {get; set;}

Remarks

See Also

GetRemindersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EndTimeSpecified Property

Aspose.Email

GetRemindersType.EndTimeSpecified Property

public bool EndTimeSpecified {get; set;}

Remarks

See Also

GetRemindersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MaxItems Property

Aspose.Email

GetRemindersType.MaxItems Property

public int MaxItems {get; set;}

Remarks

See Also

GetRemindersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MaxItemsSpecified Property

Aspose.Email

GetRemindersType.MaxItemsSpecified Property

public bool MaxItemsSpecified {get; set;}

Remarks

See Also

GetRemindersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReminderType Property

Aspose.Email

GetRemindersType.ReminderType Property

public GetRemindersTypeReminderType ReminderType {get; set;}

Remarks

See Also

GetRemindersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReminderTypeSpecified Property

Aspose.Email

GetRemindersType.ReminderTypeSpecified Property

public bool ReminderTypeSpecified {get; set;}

Remarks

See Also

GetRemindersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetRemindersTypeReminderType Enumeration

public enum GetRemindersTypeReminderType

Remarks

Members

Member Name | Description | Value
All |  | 0
Current |  | 1
Old |  | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetRoomListsCompletedEventArgs Class

For a list of all members of this type, see GetRoomListsCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetRoomListsCompletedEventArgs

public class GetRoomListsCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetRoomListsCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetRoomListsCompletedEventArgs Members

GetRoomListsCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetRoomListsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetRoomListsCompletedEventArgs Properties

The properties of the GetRoomListsCompletedEventArgs class are listed below. For a complete list of GetRoomListsCompletedEventArgs class members, see the GetRoomListsCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetRoomListsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

GetRoomListsCompletedEventArgs.Result Property

public GetRoomListsResponseMessageType Result {get;}

Remarks

See Also

GetRoomListsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetRoomListsCompletedEventHandler Delegate

public delegate void GetRoomListsCompletedEventHandler(
object sender,
GetRoomListsCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetRoomListsResponseMessageType Class

For a list of all members of this type, see GetRoomListsResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetRoomListsResponseMessageType

public class GetRoomListsResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetRoomListsResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetRoomListsResponseMessageType Members

GetRoomListsResponseMessageType overview

Public Instance Constructors

GetRoomListsResponseMessageType Constructor Initializes a new instance of the GetRoomListsResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
RoomLists

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetRoomListsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetRoomListsResponseMessageType Constructor

Initializes a new instance of the GetRoomListsResponseMessageType class.

public GetRoomListsResponseMessageType();

See Also

GetRoomListsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetRoomListsResponseMessageType Properties

The properties of the GetRoomListsResponseMessageType class are listed below. For a complete list of GetRoomListsResponseMessageType class members, see the GetRoomListsResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
RoomLists

See Also

GetRoomListsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RoomLists Property

Aspose.Email

GetRoomListsResponseMessageType.RoomLists Property

public EmailAddressType[] RoomLists {get; set;}

Remarks

See Also

GetRoomListsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetRoomListsType Class

For a list of all members of this type, see GetRoomListsType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.GetRoomListsType

public class GetRoomListsType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetRoomListsType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetRoomListsType Members

GetRoomListsType overview

Public Instance Constructors

GetRoomListsType Constructor Initializes a new instance of the GetRoomListsType class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetRoomListsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetRoomListsType Constructor

Initializes a new instance of the GetRoomListsType class.

public GetRoomListsType();

See Also

GetRoomListsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetRoomsCompletedEventArgs Class

For a list of all members of this type, see GetRoomsCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetRoomsCompletedEventArgs

public class GetRoomsCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetRoomsCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetRoomsCompletedEventArgs Members

GetRoomsCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetRoomsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetRoomsCompletedEventArgs Properties

The properties of the GetRoomsCompletedEventArgs class are listed below. For a complete list of GetRoomsCompletedEventArgs class members, see the GetRoomsCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetRoomsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

GetRoomsCompletedEventArgs.Result Property

public GetRoomsResponseMessageType Result {get;}

Remarks

See Also

GetRoomsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetRoomsCompletedEventHandler Delegate

public delegate void GetRoomsCompletedEventHandler(
object sender,
GetRoomsCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetRoomsResponseMessageType Class

For a list of all members of this type, see GetRoomsResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetRoomsResponseMessageType

public class GetRoomsResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetRoomsResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetRoomsResponseMessageType Members

GetRoomsResponseMessageType overview

Public Instance Constructors

GetRoomsResponseMessageType Constructor Initializes a new instance of the GetRoomsResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
Rooms

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetRoomsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetRoomsResponseMessageType Constructor

Initializes a new instance of the GetRoomsResponseMessageType class.

public GetRoomsResponseMessageType();

See Also

GetRoomsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetRoomsResponseMessageType Properties

The properties of the GetRoomsResponseMessageType class are listed below. For a complete list of GetRoomsResponseMessageType class members, see the GetRoomsResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
Rooms

See Also

GetRoomsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Rooms Property

Aspose.Email

GetRoomsResponseMessageType.Rooms Property

public RoomType[] Rooms {get; set;}

Remarks

See Also

GetRoomsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetRoomsType Class

For a list of all members of this type, see GetRoomsType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.GetRoomsType

public class GetRoomsType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetRoomsType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetRoomsType Members

GetRoomsType overview

Public Instance Constructors

GetRoomsType Constructor Initializes a new instance of the GetRoomsType class.

Public Instance Properties

RoomList

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetRoomsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetRoomsType Constructor

Initializes a new instance of the GetRoomsType class.

public GetRoomsType();

See Also

GetRoomsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetRoomsType Properties

The properties of the GetRoomsType class are listed below. For a complete list of GetRoomsType class members, see the GetRoomsType Members topic.

Public Instance Properties

RoomList

See Also

GetRoomsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RoomList Property

Aspose.Email

GetRoomsType.RoomList Property

public EmailAddressType RoomList {get; set;}

Remarks

See Also

GetRoomsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetSearchableMailboxesCompletedEventArgs Class

For a list of all members of this type, see GetSearchableMailboxesCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetSearchableMailboxesCompletedEventArgs

public class GetSearchableMailboxesCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetSearchableMailboxesCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetSearchableMailboxesCompletedEventArgs Members

GetSearchableMailboxesCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetSearchableMailboxesCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetSearchableMailboxesCompletedEventArgs Properties

The properties of the GetSearchableMailboxesCompletedEventArgs class are listed below. For a complete list of GetSearchableMailboxesCompletedEventArgs class members, see the GetSearchableMailboxesCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetSearchableMailboxesCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

GetSearchableMailboxesCompletedEventArgs.Result Property

public GetSearchableMailboxesResponseMessageType Result {get;}

Remarks

See Also

GetSearchableMailboxesCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetSearchableMailboxesCompletedEventHandler Delegate

public delegate void GetSearchableMailboxesCompletedEventHandler(
object sender,
GetSearchableMailboxesCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetSearchableMailboxesResponseMessageType Class

For a list of all members of this type, see GetSearchableMailboxesResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetSearchableMailboxesResponseMessageType

public class GetSearchableMailboxesResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetSearchableMailboxesResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetSearchableMailboxesResponseMessageType Members

GetSearchableMailboxesResponseMessageType overview

Public Instance Constructors

GetSearchableMailboxesResponseMessageType Constructor Initializes a new instance of the GetSearchableMailboxesResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
FailedMailboxes
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
SearchableMailboxes

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetSearchableMailboxesResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetSearchableMailboxesResponseMessageType Constructor

Initializes a new instance of the GetSearchableMailboxesResponseMessageType class.

public GetSearchableMailboxesResponseMessageType();

See Also

GetSearchableMailboxesResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetSearchableMailboxesResponseMessageType Properties

The properties of the GetSearchableMailboxesResponseMessageType class are listed below. For a complete list of GetSearchableMailboxesResponseMessageType class members, see the GetSearchableMailboxesResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
FailedMailboxes
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
SearchableMailboxes

See Also

GetSearchableMailboxesResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FailedMailboxes Property

Aspose.Email

GetSearchableMailboxesResponseMessageType.FailedMailboxes Property

public FailedSearchMailboxType[] FailedMailboxes {get; set;}

Remarks

See Also

GetSearchableMailboxesResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchableMailboxes Property

Aspose.Email

GetSearchableMailboxesResponseMessageType.SearchableMailboxes Property

public SearchableMailboxType[] SearchableMailboxes {get; set;}

Remarks

See Also

GetSearchableMailboxesResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetSearchableMailboxesType Class

For a list of all members of this type, see GetSearchableMailboxesType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.GetSearchableMailboxesType

public class GetSearchableMailboxesType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetSearchableMailboxesType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetSearchableMailboxesType Members

GetSearchableMailboxesType overview

Public Instance Constructors

GetSearchableMailboxesType Constructor Initializes a new instance of the GetSearchableMailboxesType class.

Public Instance Properties

ExpandGroupMembership
ExpandGroupMembershipSpecified
SearchFilter

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetSearchableMailboxesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetSearchableMailboxesType Constructor

Initializes a new instance of the GetSearchableMailboxesType class.

public GetSearchableMailboxesType();

See Also

GetSearchableMailboxesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetSearchableMailboxesType Properties

The properties of the GetSearchableMailboxesType class are listed below. For a complete list of GetSearchableMailboxesType class members, see the GetSearchableMailboxesType Members topic.

Public Instance Properties

ExpandGroupMembership
ExpandGroupMembershipSpecified
SearchFilter

See Also

GetSearchableMailboxesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExpandGroupMembership Property

Aspose.Email

GetSearchableMailboxesType.ExpandGroupMembership Property

public bool ExpandGroupMembership {get; set;}

Remarks

See Also

GetSearchableMailboxesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExpandGroupMembershipSpecified Property

Aspose.Email

GetSearchableMailboxesType.ExpandGroupMembershipSpecified Property

public bool ExpandGroupMembershipSpecified {get; set;}

Remarks

See Also

GetSearchableMailboxesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchFilter Property

Aspose.Email

GetSearchableMailboxesType.SearchFilter Property

public string SearchFilter {get; set;}

Remarks

See Also

GetSearchableMailboxesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetServerTimeZonesCompletedEventArgs Class

For a list of all members of this type, see GetServerTimeZonesCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetServerTimeZonesCompletedEventArgs

public class GetServerTimeZonesCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetServerTimeZonesCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetServerTimeZonesCompletedEventArgs Members

GetServerTimeZonesCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetServerTimeZonesCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetServerTimeZonesCompletedEventArgs Properties

The properties of the GetServerTimeZonesCompletedEventArgs class are listed below. For a complete list of GetServerTimeZonesCompletedEventArgs class members, see the GetServerTimeZonesCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetServerTimeZonesCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

GetServerTimeZonesCompletedEventArgs.Result Property

public GetServerTimeZonesResponseType Result {get;}

Remarks

See Also

GetServerTimeZonesCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetServerTimeZonesCompletedEventHandler Delegate

public delegate void GetServerTimeZonesCompletedEventHandler(
object sender,
GetServerTimeZonesCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetServerTimeZonesResponseMessageType Class

For a list of all members of this type, see GetServerTimeZonesResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetServerTimeZonesResponseMessageType

public class GetServerTimeZonesResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetServerTimeZonesResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetServerTimeZonesResponseMessageType Members

GetServerTimeZonesResponseMessageType overview

Public Instance Constructors

GetServerTimeZonesResponseMessageType Constructor Initializes a new instance of the GetServerTimeZonesResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
TimeZoneDefinitions

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetServerTimeZonesResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetServerTimeZonesResponseMessageType Constructor

Initializes a new instance of the GetServerTimeZonesResponseMessageType class.

public GetServerTimeZonesResponseMessageType();

See Also

GetServerTimeZonesResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetServerTimeZonesResponseMessageType Properties

The properties of the GetServerTimeZonesResponseMessageType class are listed below. For a complete list of GetServerTimeZonesResponseMessageType class members, see the GetServerTimeZonesResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
TimeZoneDefinitions

See Also

GetServerTimeZonesResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TimeZoneDefinitions Property

Aspose.Email

GetServerTimeZonesResponseMessageType.TimeZoneDefinitions Property

public ArrayOfTimeZoneDefinitionType TimeZoneDefinitions {get; set;}

Remarks

See Also

GetServerTimeZonesResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetServerTimeZonesResponseType Class

For a list of all members of this type, see GetServerTimeZonesResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetServerTimeZonesResponseType

public class GetServerTimeZonesResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetServerTimeZonesResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetServerTimeZonesResponseType Members

GetServerTimeZonesResponseType overview

Public Instance Constructors

GetServerTimeZonesResponseType Constructor Initializes a new instance of the GetServerTimeZonesResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetServerTimeZonesResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetServerTimeZonesResponseType Constructor

Initializes a new instance of the GetServerTimeZonesResponseType class.

public GetServerTimeZonesResponseType();

See Also

GetServerTimeZonesResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetServerTimeZonesType Class

For a list of all members of this type, see GetServerTimeZonesType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.GetServerTimeZonesType

public class GetServerTimeZonesType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetServerTimeZonesType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetServerTimeZonesType Members

GetServerTimeZonesType overview

Public Instance Constructors

GetServerTimeZonesType Constructor Initializes a new instance of the GetServerTimeZonesType class.

Public Instance Properties

Ids
ReturnFullTimeZoneData
ReturnFullTimeZoneDataSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetServerTimeZonesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetServerTimeZonesType Constructor

Initializes a new instance of the GetServerTimeZonesType class.

public GetServerTimeZonesType();

See Also

GetServerTimeZonesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetServerTimeZonesType Properties

The properties of the GetServerTimeZonesType class are listed below. For a complete list of GetServerTimeZonesType class members, see the GetServerTimeZonesType Members topic.

Public Instance Properties

Ids
ReturnFullTimeZoneData
ReturnFullTimeZoneDataSpecified

See Also

GetServerTimeZonesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Ids Property

Aspose.Email

GetServerTimeZonesType.Ids Property

public string[] Ids {get; set;}

Remarks

See Also

GetServerTimeZonesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReturnFullTimeZoneData Property

Aspose.Email

GetServerTimeZonesType.ReturnFullTimeZoneData Property

public bool ReturnFullTimeZoneData {get; set;}

Remarks

See Also

GetServerTimeZonesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReturnFullTimeZoneDataSpecified Property

Aspose.Email

GetServerTimeZonesType.ReturnFullTimeZoneDataSpecified Property

public bool ReturnFullTimeZoneDataSpecified {get; set;}

Remarks

See Also

GetServerTimeZonesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetServiceConfigurationCompletedEventArgs Class

For a list of all members of this type, see GetServiceConfigurationCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetServiceConfigurationCompletedEventArgs

public class GetServiceConfigurationCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetServiceConfigurationCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetServiceConfigurationCompletedEventArgs Members

GetServiceConfigurationCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetServiceConfigurationCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetServiceConfigurationCompletedEventArgs Properties

The properties of the GetServiceConfigurationCompletedEventArgs class are listed below. For a complete list of GetServiceConfigurationCompletedEventArgs class members, see the GetServiceConfigurationCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetServiceConfigurationCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

GetServiceConfigurationCompletedEventArgs.Result Property

public GetServiceConfigurationResponseMessageType Result {get;}

Remarks

See Also

GetServiceConfigurationCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetServiceConfigurationCompletedEventHandler Delegate

public delegate void GetServiceConfigurationCompletedEventHandler(
object sender,
GetServiceConfigurationCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetServiceConfigurationResponseMessageType Class

For a list of all members of this type, see GetServiceConfigurationResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetServiceConfigurationResponseMessageType

public class GetServiceConfigurationResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetServiceConfigurationResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetServiceConfigurationResponseMessageType Members

GetServiceConfigurationResponseMessageType overview

Public Instance Constructors

GetServiceConfigurationResponseMessageType Constructor Initializes a new instance of the GetServiceConfigurationResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
ResponseMessages

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetServiceConfigurationResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetServiceConfigurationResponseMessageType Constructor

Initializes a new instance of the GetServiceConfigurationResponseMessageType class.

public GetServiceConfigurationResponseMessageType();

See Also

GetServiceConfigurationResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetServiceConfigurationResponseMessageType Properties

The properties of the GetServiceConfigurationResponseMessageType class are listed below. For a complete list of GetServiceConfigurationResponseMessageType class members, see the GetServiceConfigurationResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
ResponseMessages

See Also

GetServiceConfigurationResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResponseMessages Property

Aspose.Email

GetServiceConfigurationResponseMessageType.ResponseMessages Property

public ServiceConfigurationResponseMessageType[] ResponseMessages {get; set;}

Remarks

See Also

GetServiceConfigurationResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetServiceConfigurationType Class

For a list of all members of this type, see GetServiceConfigurationType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.GetServiceConfigurationType

public class GetServiceConfigurationType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetServiceConfigurationType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetServiceConfigurationType Members

GetServiceConfigurationType overview

Public Instance Constructors

GetServiceConfigurationType Constructor Initializes a new instance of the GetServiceConfigurationType class.

Public Instance Properties

ActingAs
ConfigurationRequestDetails
RequestedConfiguration

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetServiceConfigurationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetServiceConfigurationType Constructor

Initializes a new instance of the GetServiceConfigurationType class.

public GetServiceConfigurationType();

See Also

GetServiceConfigurationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetServiceConfigurationType Properties

The properties of the GetServiceConfigurationType class are listed below. For a complete list of GetServiceConfigurationType class members, see the GetServiceConfigurationType Members topic.

Public Instance Properties

ActingAs
ConfigurationRequestDetails
RequestedConfiguration

See Also

GetServiceConfigurationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ActingAs Property

Aspose.Email

GetServiceConfigurationType.ActingAs Property

public EmailAddressType ActingAs {get; set;}

Remarks

See Also

GetServiceConfigurationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConfigurationRequestDetails Property

Aspose.Email

GetServiceConfigurationType.ConfigurationRequestDetails Property

public ConfigurationRequestDetailsType ConfigurationRequestDetails {get; set;}

Remarks

See Also

GetServiceConfigurationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RequestedConfiguration Property

Aspose.Email

GetServiceConfigurationType.RequestedConfiguration Property

public ServiceConfigurationType[] RequestedConfiguration {get; set;}

Remarks

See Also

GetServiceConfigurationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetSharingFolderCompletedEventArgs Class

For a list of all members of this type, see GetSharingFolderCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetSharingFolderCompletedEventArgs

public class GetSharingFolderCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetSharingFolderCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetSharingFolderCompletedEventArgs Members

GetSharingFolderCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetSharingFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetSharingFolderCompletedEventArgs Properties

The properties of the GetSharingFolderCompletedEventArgs class are listed below. For a complete list of GetSharingFolderCompletedEventArgs class members, see the GetSharingFolderCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetSharingFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

GetSharingFolderCompletedEventArgs.Result Property

public GetSharingFolderResponseMessageType Result {get;}

Remarks

See Also

GetSharingFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetSharingFolderCompletedEventHandler Delegate

public delegate void GetSharingFolderCompletedEventHandler(
object sender,
GetSharingFolderCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetSharingFolderResponseMessageType Class

For a list of all members of this type, see GetSharingFolderResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetSharingFolderResponseMessageType

public class GetSharingFolderResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetSharingFolderResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetSharingFolderResponseMessageType Members

GetSharingFolderResponseMessageType overview

Public Instance Constructors

GetSharingFolderResponseMessageType Constructor Initializes a new instance of the GetSharingFolderResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
SharingFolderId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetSharingFolderResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetSharingFolderResponseMessageType Constructor

Initializes a new instance of the GetSharingFolderResponseMessageType class.

public GetSharingFolderResponseMessageType();

See Also

GetSharingFolderResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetSharingFolderResponseMessageType Properties

The properties of the GetSharingFolderResponseMessageType class are listed below. For a complete list of GetSharingFolderResponseMessageType class members, see the GetSharingFolderResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
SharingFolderId

See Also

GetSharingFolderResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SharingFolderId Property

Aspose.Email

GetSharingFolderResponseMessageType.SharingFolderId Property

public FolderIdType SharingFolderId {get; set;}

Remarks

See Also

GetSharingFolderResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetSharingFolderType Class

For a list of all members of this type, see GetSharingFolderType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.GetSharingFolderType

public class GetSharingFolderType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetSharingFolderType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetSharingFolderType Members

GetSharingFolderType overview

Public Instance Constructors

GetSharingFolderType Constructor Initializes a new instance of the GetSharingFolderType class.

Public Instance Properties

DataType
DataTypeSpecified
SharedFolderId
SmtpAddress

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetSharingFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetSharingFolderType Constructor

Initializes a new instance of the GetSharingFolderType class.

public GetSharingFolderType();

See Also

GetSharingFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetSharingFolderType Properties

The properties of the GetSharingFolderType class are listed below. For a complete list of GetSharingFolderType class members, see the GetSharingFolderType Members topic.

Public Instance Properties

DataType
DataTypeSpecified
SharedFolderId
SmtpAddress

See Also

GetSharingFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DataType Property

Aspose.Email

GetSharingFolderType.DataType Property

public SharingDataType DataType {get; set;}

Remarks

See Also

GetSharingFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DataTypeSpecified Property

Aspose.Email

GetSharingFolderType.DataTypeSpecified Property

public bool DataTypeSpecified {get; set;}

Remarks

See Also

GetSharingFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SharedFolderId Property

Aspose.Email

GetSharingFolderType.SharedFolderId Property

public string SharedFolderId {get; set;}

Remarks

See Also

GetSharingFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SmtpAddress Property

Aspose.Email

GetSharingFolderType.SmtpAddress Property

public string SmtpAddress {get; set;}

Remarks

See Also

GetSharingFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetSharingMetadataCompletedEventArgs Class

For a list of all members of this type, see GetSharingMetadataCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetSharingMetadataCompletedEventArgs

public class GetSharingMetadataCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetSharingMetadataCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetSharingMetadataCompletedEventArgs Members

GetSharingMetadataCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetSharingMetadataCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetSharingMetadataCompletedEventArgs Properties

The properties of the GetSharingMetadataCompletedEventArgs class are listed below. For a complete list of GetSharingMetadataCompletedEventArgs class members, see the GetSharingMetadataCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetSharingMetadataCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

GetSharingMetadataCompletedEventArgs.Result Property

public GetSharingMetadataResponseMessageType Result {get;}

Remarks

See Also

GetSharingMetadataCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetSharingMetadataCompletedEventHandler Delegate

public delegate void GetSharingMetadataCompletedEventHandler(
object sender,
GetSharingMetadataCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetSharingMetadataResponseMessageType Class

For a list of all members of this type, see GetSharingMetadataResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetSharingMetadataResponseMessageType

public class GetSharingMetadataResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetSharingMetadataResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetSharingMetadataResponseMessageType Members

GetSharingMetadataResponseMessageType overview

Public Instance Constructors

GetSharingMetadataResponseMessageType Constructor Initializes a new instance of the GetSharingMetadataResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
EncryptedSharedFolderDataCollection
InvalidRecipients
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetSharingMetadataResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetSharingMetadataResponseMessageType Constructor

Initializes a new instance of the GetSharingMetadataResponseMessageType class.

public GetSharingMetadataResponseMessageType();

See Also

GetSharingMetadataResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetSharingMetadataResponseMessageType Properties

The properties of the GetSharingMetadataResponseMessageType class are listed below. For a complete list of GetSharingMetadataResponseMessageType class members, see the GetSharingMetadataResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
EncryptedSharedFolderDataCollection
InvalidRecipients
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

GetSharingMetadataResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EncryptedSharedFolderDataCollection Property

Aspose.Email

GetSharingMetadataResponseMessageType.EncryptedSharedFolderDataCollection Property

public EncryptedSharedFolderDataType[] EncryptedSharedFolderDataCollection {get; set;}

Remarks

See Also

GetSharingMetadataResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InvalidRecipients Property

Aspose.Email

GetSharingMetadataResponseMessageType.InvalidRecipients Property

public InvalidRecipientType[] InvalidRecipients {get; set;}

Remarks

See Also

GetSharingMetadataResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetSharingMetadataType Class

For a list of all members of this type, see GetSharingMetadataType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.GetSharingMetadataType

public class GetSharingMetadataType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetSharingMetadataType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetSharingMetadataType Members

GetSharingMetadataType overview

Public Instance Constructors

GetSharingMetadataType Constructor Initializes a new instance of the GetSharingMetadataType class.

Public Instance Properties

IdOfFolderToShare
Recipients
SenderSmtpAddress

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetSharingMetadataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetSharingMetadataType Constructor

Initializes a new instance of the GetSharingMetadataType class.

public GetSharingMetadataType();

See Also

GetSharingMetadataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetSharingMetadataType Properties

The properties of the GetSharingMetadataType class are listed below. For a complete list of GetSharingMetadataType class members, see the GetSharingMetadataType Members topic.

Public Instance Properties

IdOfFolderToShare
Recipients
SenderSmtpAddress

See Also

GetSharingMetadataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IdOfFolderToShare Property

Aspose.Email

GetSharingMetadataType.IdOfFolderToShare Property

public FolderIdType IdOfFolderToShare {get; set;}

Remarks

See Also

GetSharingMetadataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Recipients Property

Aspose.Email

GetSharingMetadataType.Recipients Property

public string[] Recipients {get; set;}

Remarks

See Also

GetSharingMetadataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SenderSmtpAddress Property

Aspose.Email

GetSharingMetadataType.SenderSmtpAddress Property

public string SenderSmtpAddress {get; set;}

Remarks

See Also

GetSharingMetadataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetStreamingEventsCompletedEventArgs Class

For a list of all members of this type, see GetStreamingEventsCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetStreamingEventsCompletedEventArgs

public class GetStreamingEventsCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetStreamingEventsCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetStreamingEventsCompletedEventArgs Members

GetStreamingEventsCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetStreamingEventsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetStreamingEventsCompletedEventArgs Properties

The properties of the GetStreamingEventsCompletedEventArgs class are listed below. For a complete list of GetStreamingEventsCompletedEventArgs class members, see the GetStreamingEventsCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetStreamingEventsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

GetStreamingEventsCompletedEventArgs.Result Property

public GetStreamingEventsResponseType Result {get;}

Remarks

See Also

GetStreamingEventsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetStreamingEventsCompletedEventHandler Delegate

public delegate void GetStreamingEventsCompletedEventHandler(
object sender,
GetStreamingEventsCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetStreamingEventsResponseMessageType Class

For a list of all members of this type, see GetStreamingEventsResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetStreamingEventsResponseMessageType

public class GetStreamingEventsResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetStreamingEventsResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetStreamingEventsResponseMessageType Members

GetStreamingEventsResponseMessageType overview

Public Instance Constructors

GetStreamingEventsResponseMessageType Constructor Initializes a new instance of the GetStreamingEventsResponseMessageType class.

Public Instance Properties

ConnectionStatus
ConnectionStatusSpecified
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
ErrorSubscriptionIds
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
Notifications
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetStreamingEventsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetStreamingEventsResponseMessageType Constructor

Initializes a new instance of the GetStreamingEventsResponseMessageType class.

public GetStreamingEventsResponseMessageType();

See Also

GetStreamingEventsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetStreamingEventsResponseMessageType Properties

The properties of the GetStreamingEventsResponseMessageType class are listed below. For a complete list of GetStreamingEventsResponseMessageType class members, see the GetStreamingEventsResponseMessageType Members topic.

Public Instance Properties

ConnectionStatus
ConnectionStatusSpecified
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
ErrorSubscriptionIds
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
Notifications
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

GetStreamingEventsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConnectionStatus Property

Aspose.Email

GetStreamingEventsResponseMessageType.ConnectionStatus Property

public ConnectionStatusType ConnectionStatus {get; set;}

Remarks

See Also

GetStreamingEventsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConnectionStatusSpecified Property

Aspose.Email

GetStreamingEventsResponseMessageType.ConnectionStatusSpecified Property

public bool ConnectionStatusSpecified {get; set;}

Remarks

See Also

GetStreamingEventsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ErrorSubscriptionIds Property

Aspose.Email

GetStreamingEventsResponseMessageType.ErrorSubscriptionIds Property

public string[] ErrorSubscriptionIds {get; set;}

Remarks

See Also

GetStreamingEventsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Notifications Property

Aspose.Email

GetStreamingEventsResponseMessageType.Notifications Property

public NotificationType[] Notifications {get; set;}

Remarks

See Also

GetStreamingEventsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetStreamingEventsResponseType Class

For a list of all members of this type, see GetStreamingEventsResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetStreamingEventsResponseType

public class GetStreamingEventsResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetStreamingEventsResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetStreamingEventsResponseType Members

GetStreamingEventsResponseType overview

Public Instance Constructors

GetStreamingEventsResponseType Constructor Initializes a new instance of the GetStreamingEventsResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetStreamingEventsResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetStreamingEventsResponseType Constructor

Initializes a new instance of the GetStreamingEventsResponseType class.

public GetStreamingEventsResponseType();

See Also

GetStreamingEventsResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetStreamingEventsType Class

For a list of all members of this type, see GetStreamingEventsType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.GetStreamingEventsType

public class GetStreamingEventsType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetStreamingEventsType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetStreamingEventsType Members

GetStreamingEventsType overview

Public Instance Constructors

GetStreamingEventsType Constructor Initializes a new instance of the GetStreamingEventsType class.

Public Instance Properties

ConnectionTimeout
SubscriptionIds

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetStreamingEventsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetStreamingEventsType Constructor

Initializes a new instance of the GetStreamingEventsType class.

public GetStreamingEventsType();

See Also

GetStreamingEventsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetStreamingEventsType Properties

The properties of the GetStreamingEventsType class are listed below. For a complete list of GetStreamingEventsType class members, see the GetStreamingEventsType Members topic.

Public Instance Properties

ConnectionTimeout
SubscriptionIds

See Also

GetStreamingEventsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConnectionTimeout Property

Aspose.Email

GetStreamingEventsType.ConnectionTimeout Property

public int ConnectionTimeout {get; set;}

Remarks

See Also

GetStreamingEventsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SubscriptionIds Property

Aspose.Email

GetStreamingEventsType.SubscriptionIds Property

public string[] SubscriptionIds {get; set;}

Remarks

See Also

GetStreamingEventsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUMCallDataRecordsResponseMessageType Class

For a list of all members of this type, see GetUMCallDataRecordsResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetUMCallDataRecordsResponseMessageType

public class GetUMCallDataRecordsResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetUMCallDataRecordsResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUMCallDataRecordsResponseMessageType Members

GetUMCallDataRecordsResponseMessageType overview

Public Instance Constructors

GetUMCallDataRecordsResponseMessageType Constructor Initializes a new instance of the GetUMCallDataRecordsResponseMessageType class.

Public Instance Properties

CallDataRecords
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetUMCallDataRecordsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUMCallDataRecordsResponseMessageType Constructor

Initializes a new instance of the GetUMCallDataRecordsResponseMessageType class.

public GetUMCallDataRecordsResponseMessageType();

See Also

GetUMCallDataRecordsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUMCallDataRecordsResponseMessageType Properties

The properties of the GetUMCallDataRecordsResponseMessageType class are listed below. For a complete list of GetUMCallDataRecordsResponseMessageType class members, see the GetUMCallDataRecordsResponseMessageType Members topic.

Public Instance Properties

CallDataRecords
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

GetUMCallDataRecordsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CallDataRecords Property

Aspose.Email

GetUMCallDataRecordsResponseMessageType.CallDataRecords Property

public CDRDataType[] CallDataRecords {get; set;}

Remarks

See Also

GetUMCallDataRecordsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUMCallDataRecordsType Class

For a list of all members of this type, see GetUMCallDataRecordsType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.GetUMCallDataRecordsType

public class GetUMCallDataRecordsType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetUMCallDataRecordsType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUMCallDataRecordsType Members

GetUMCallDataRecordsType overview

Public Instance Constructors

GetUMCallDataRecordsType Constructor Initializes a new instance of the GetUMCallDataRecordsType class.

Public Instance Properties

EndDateTime
EndDateTimeSpecified
FilterBy
NumberOfRecords
NumberOfRecordsSpecified
Offset
OffsetSpecified
StartDateTime
StartDateTimeSpecified
UserLegacyExchangeDN

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetUMCallDataRecordsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUMCallDataRecordsType Constructor

Initializes a new instance of the GetUMCallDataRecordsType class.

public GetUMCallDataRecordsType();

See Also

GetUMCallDataRecordsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUMCallDataRecordsType Properties

The properties of the GetUMCallDataRecordsType class are listed below. For a complete list of GetUMCallDataRecordsType class members, see the GetUMCallDataRecordsType Members topic.

Public Instance Properties

EndDateTime
EndDateTimeSpecified
FilterBy
NumberOfRecords
NumberOfRecordsSpecified
Offset
OffsetSpecified
StartDateTime
StartDateTimeSpecified
UserLegacyExchangeDN

See Also

GetUMCallDataRecordsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EndDateTime Property

Aspose.Email

GetUMCallDataRecordsType.EndDateTime Property

public DateTime EndDateTime {get; set;}

Remarks

See Also

GetUMCallDataRecordsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EndDateTimeSpecified Property

Aspose.Email

GetUMCallDataRecordsType.EndDateTimeSpecified Property

public bool EndDateTimeSpecified {get; set;}

Remarks

See Also

GetUMCallDataRecordsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FilterBy Property

Aspose.Email

GetUMCallDataRecordsType.FilterBy Property

public UMCDRFilterByType FilterBy {get; set;}

Remarks

See Also

GetUMCallDataRecordsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NumberOfRecords Property

Aspose.Email

GetUMCallDataRecordsType.NumberOfRecords Property

public int NumberOfRecords {get; set;}

Remarks

See Also

GetUMCallDataRecordsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NumberOfRecordsSpecified Property

Aspose.Email

GetUMCallDataRecordsType.NumberOfRecordsSpecified Property

public bool NumberOfRecordsSpecified {get; set;}

Remarks

See Also

GetUMCallDataRecordsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Offset Property

Aspose.Email

GetUMCallDataRecordsType.Offset Property

public int Offset {get; set;}

Remarks

See Also

GetUMCallDataRecordsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OffsetSpecified Property

Aspose.Email

GetUMCallDataRecordsType.OffsetSpecified Property

public bool OffsetSpecified {get; set;}

Remarks

See Also

GetUMCallDataRecordsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StartDateTime Property

Aspose.Email

GetUMCallDataRecordsType.StartDateTime Property

public DateTime StartDateTime {get; set;}

Remarks

See Also

GetUMCallDataRecordsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StartDateTimeSpecified Property

Aspose.Email

GetUMCallDataRecordsType.StartDateTimeSpecified Property

public bool StartDateTimeSpecified {get; set;}

Remarks

See Also

GetUMCallDataRecordsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserLegacyExchangeDN Property

Aspose.Email

GetUMCallDataRecordsType.UserLegacyExchangeDN Property

public string UserLegacyExchangeDN {get; set;}

Remarks

See Also

GetUMCallDataRecordsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUMCallSummaryResponseMessageType Class

For a list of all members of this type, see GetUMCallSummaryResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetUMCallSummaryResponseMessageType

public class GetUMCallSummaryResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetUMCallSummaryResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUMCallSummaryResponseMessageType Members

GetUMCallSummaryResponseMessageType overview

Public Instance Constructors

GetUMCallSummaryResponseMessageType Constructor Initializes a new instance of the GetUMCallSummaryResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
UMReportRawCountersCollection

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetUMCallSummaryResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUMCallSummaryResponseMessageType Constructor

Initializes a new instance of the GetUMCallSummaryResponseMessageType class.

public GetUMCallSummaryResponseMessageType();

See Also

GetUMCallSummaryResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUMCallSummaryResponseMessageType Properties

The properties of the GetUMCallSummaryResponseMessageType class are listed below. For a complete list of GetUMCallSummaryResponseMessageType class members, see the GetUMCallSummaryResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
UMReportRawCountersCollection

See Also

GetUMCallSummaryResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UMReportRawCountersCollection Property

Aspose.Email

GetUMCallSummaryResponseMessageType.UMReportRawCountersCollection Property

public UMReportRawCountersType[] UMReportRawCountersCollection {get; set;}

Remarks

See Also

GetUMCallSummaryResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUMCallSummaryType Class

For a list of all members of this type, see GetUMCallSummaryType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.GetUMCallSummaryType

public class GetUMCallSummaryType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetUMCallSummaryType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUMCallSummaryType Members

GetUMCallSummaryType overview

Public Instance Constructors

GetUMCallSummaryType Constructor Initializes a new instance of the GetUMCallSummaryType class.

Public Instance Properties

DailPlanGuid
GatewayGuid
GroupRecordsBy

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetUMCallSummaryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUMCallSummaryType Constructor

Initializes a new instance of the GetUMCallSummaryType class.

public GetUMCallSummaryType();

See Also

GetUMCallSummaryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUMCallSummaryType Properties

The properties of the GetUMCallSummaryType class are listed below. For a complete list of GetUMCallSummaryType class members, see the GetUMCallSummaryType Members topic.

Public Instance Properties

DailPlanGuid
GatewayGuid
GroupRecordsBy

See Also

GetUMCallSummaryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DailPlanGuid Property

Aspose.Email

GetUMCallSummaryType.DailPlanGuid Property

public string DailPlanGuid {get; set;}

Remarks

See Also

GetUMCallSummaryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GatewayGuid Property

Aspose.Email

GetUMCallSummaryType.GatewayGuid Property

public string GatewayGuid {get; set;}

Remarks

See Also

GetUMCallSummaryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GroupRecordsBy Property

Aspose.Email

GetUMCallSummaryType.GroupRecordsBy Property

public UMCDRGroupByType GroupRecordsBy {get; set;}

Remarks

See Also

GetUMCallSummaryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUMPinResponseMessageType Class

For a list of all members of this type, see GetUMPinResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetUMPinResponseMessageType

public class GetUMPinResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetUMPinResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUMPinResponseMessageType Members

GetUMPinResponseMessageType overview

Public Instance Constructors

GetUMPinResponseMessageType Constructor Initializes a new instance of the GetUMPinResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
PinInfo
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetUMPinResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUMPinResponseMessageType Constructor

Initializes a new instance of the GetUMPinResponseMessageType class.

public GetUMPinResponseMessageType();

See Also

GetUMPinResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUMPinResponseMessageType Properties

The properties of the GetUMPinResponseMessageType class are listed below. For a complete list of GetUMPinResponseMessageType class members, see the GetUMPinResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
PinInfo
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

GetUMPinResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PinInfo Property

Aspose.Email

GetUMPinResponseMessageType.PinInfo Property

public PinInfoType PinInfo {get; set;}

Remarks

See Also

GetUMPinResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUMPinType Class

For a list of all members of this type, see GetUMPinType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.GetUMPinType

public class GetUMPinType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetUMPinType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUMPinType Members

GetUMPinType overview

Public Instance Constructors

GetUMPinType Constructor Initializes a new instance of the GetUMPinType class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetUMPinType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUMPinType Constructor

Initializes a new instance of the GetUMPinType class.

public GetUMPinType();

See Also

GetUMPinType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUMPromptNamesResponseMessageType Class

For a list of all members of this type, see GetUMPromptNamesResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetUMPromptNamesResponseMessageType

public class GetUMPromptNamesResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetUMPromptNamesResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUMPromptNamesResponseMessageType Members

GetUMPromptNamesResponseMessageType overview

Public Instance Constructors

GetUMPromptNamesResponseMessageType Constructor Initializes a new instance of the GetUMPromptNamesResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
PromptNames
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetUMPromptNamesResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUMPromptNamesResponseMessageType Constructor

Initializes a new instance of the GetUMPromptNamesResponseMessageType class.

public GetUMPromptNamesResponseMessageType();

See Also

GetUMPromptNamesResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUMPromptNamesResponseMessageType Properties

The properties of the GetUMPromptNamesResponseMessageType class are listed below. For a complete list of GetUMPromptNamesResponseMessageType class members, see the GetUMPromptNamesResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
PromptNames
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

GetUMPromptNamesResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PromptNames Property

Aspose.Email

GetUMPromptNamesResponseMessageType.PromptNames Property

public string[] PromptNames {get; set;}

Remarks

See Also

GetUMPromptNamesResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUMPromptNamesType Class

For a list of all members of this type, see GetUMPromptNamesType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.GetUMPromptNamesType

public class GetUMPromptNamesType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetUMPromptNamesType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUMPromptNamesType Members

GetUMPromptNamesType overview

Public Instance Constructors

GetUMPromptNamesType Constructor Initializes a new instance of the GetUMPromptNamesType class.

Public Instance Properties

ConfigurationObject
HoursElapsedSinceLastModified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetUMPromptNamesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUMPromptNamesType Constructor

Initializes a new instance of the GetUMPromptNamesType class.

public GetUMPromptNamesType();

See Also

GetUMPromptNamesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUMPromptNamesType Properties

The properties of the GetUMPromptNamesType class are listed below. For a complete list of GetUMPromptNamesType class members, see the GetUMPromptNamesType Members topic.

Public Instance Properties

ConfigurationObject
HoursElapsedSinceLastModified

See Also

GetUMPromptNamesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConfigurationObject Property

Aspose.Email

GetUMPromptNamesType.ConfigurationObject Property

public string ConfigurationObject {get; set;}

Remarks

See Also

GetUMPromptNamesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


HoursElapsedSinceLastModified Property

Aspose.Email

GetUMPromptNamesType.HoursElapsedSinceLastModified Property

public int HoursElapsedSinceLastModified {get; set;}

Remarks

See Also

GetUMPromptNamesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUMPromptResponseMessageType Class

For a list of all members of this type, see GetUMPromptResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetUMPromptResponseMessageType

public class GetUMPromptResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetUMPromptResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUMPromptResponseMessageType Members

GetUMPromptResponseMessageType overview

Public Instance Constructors

GetUMPromptResponseMessageType Constructor Initializes a new instance of the GetUMPromptResponseMessageType class.

Public Instance Properties

AudioData
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetUMPromptResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUMPromptResponseMessageType Constructor

Initializes a new instance of the GetUMPromptResponseMessageType class.

public GetUMPromptResponseMessageType();

See Also

GetUMPromptResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUMPromptResponseMessageType Properties

The properties of the GetUMPromptResponseMessageType class are listed below. For a complete list of GetUMPromptResponseMessageType class members, see the GetUMPromptResponseMessageType Members topic.

Public Instance Properties

AudioData
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

GetUMPromptResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AudioData Property

Aspose.Email

GetUMPromptResponseMessageType.AudioData Property

public byte[] AudioData {get; set;}

Remarks

See Also

GetUMPromptResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUMPromptType Class

For a list of all members of this type, see GetUMPromptType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.GetUMPromptType

public class GetUMPromptType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetUMPromptType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUMPromptType Members

GetUMPromptType overview

Public Instance Constructors

GetUMPromptType Constructor Initializes a new instance of the GetUMPromptType class.

Public Instance Properties

ConfigurationObject
PromptName

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetUMPromptType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUMPromptType Constructor

Initializes a new instance of the GetUMPromptType class.

public GetUMPromptType();

See Also

GetUMPromptType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUMPromptType Properties

The properties of the GetUMPromptType class are listed below. For a complete list of GetUMPromptType class members, see the GetUMPromptType Members topic.

Public Instance Properties

ConfigurationObject
PromptName

See Also

GetUMPromptType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConfigurationObject Property

Aspose.Email

GetUMPromptType.ConfigurationObject Property

public string ConfigurationObject {get; set;}

Remarks

See Also

GetUMPromptType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PromptName Property

Aspose.Email

GetUMPromptType.PromptName Property

public string PromptName {get; set;}

Remarks

See Also

GetUMPromptType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUMSubscriberCallAnsweringDataResponseMessageType Class

For a list of all members of this type, see GetUMSubscriberCallAnsweringDataResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetUMSubscriberCallAnsweringDataResponseMessageType

public class GetUMSubscriberCallAnsweringDataResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetUMSubscriberCallAnsweringDataResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUMSubscriberCallAnsweringDataResponseMessageType Members

GetUMSubscriberCallAnsweringDataResponseMessageType overview

Public Instance Constructors

GetUMSubscriberCallAnsweringDataResponseMessageType Constructor Initializes a new instance of the GetUMSubscriberCallAnsweringDataResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
Greeting
GreetingName
IsMailboxQuotaExceeded
IsOOF
IsTranscriptionEnabledInMailboxConfig
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
TaskTimedOut

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetUMSubscriberCallAnsweringDataResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUMSubscriberCallAnsweringDataResponseMessageType Constructor

Initializes a new instance of the GetUMSubscriberCallAnsweringDataResponseMessageType class.

public GetUMSubscriberCallAnsweringDataResponseMessageType();

See Also

GetUMSubscriberCallAnsweringDataResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUMSubscriberCallAnsweringDataResponseMessageType Properties

The properties of the GetUMSubscriberCallAnsweringDataResponseMessageType class are listed below. For a complete list of GetUMSubscriberCallAnsweringDataResponseMessageType class members, see the GetUMSubscriberCallAnsweringDataResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
Greeting
GreetingName
IsMailboxQuotaExceeded
IsOOF
IsTranscriptionEnabledInMailboxConfig
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
TaskTimedOut

See Also

GetUMSubscriberCallAnsweringDataResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Greeting Property

Aspose.Email

GetUMSubscriberCallAnsweringDataResponseMessageType.Greeting Property

public byte[] Greeting {get; set;}

Remarks

See Also

GetUMSubscriberCallAnsweringDataResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GreetingName Property

Aspose.Email

GetUMSubscriberCallAnsweringDataResponseMessageType.GreetingName Property

public string GreetingName {get; set;}

Remarks

See Also

GetUMSubscriberCallAnsweringDataResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsMailboxQuotaExceeded Property

Aspose.Email

GetUMSubscriberCallAnsweringDataResponseMessageType.IsMailboxQuotaExceeded Property

public bool IsMailboxQuotaExceeded {get; set;}

Remarks

See Also

GetUMSubscriberCallAnsweringDataResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsOOF Property

Aspose.Email

GetUMSubscriberCallAnsweringDataResponseMessageType.IsOOF Property

public bool IsOOF {get; set;}

Remarks

See Also

GetUMSubscriberCallAnsweringDataResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsTranscriptionEnabledInMailboxConfig Property

Aspose.Email

GetUMSubscriberCallAnsweringDataResponseMessageType.IsTranscriptionEnabledInMailboxConfig Property

public UMMailboxTranscriptionEnabledSetting IsTranscriptionEnabledInMailboxConfig {get; set;}

Remarks

See Also

GetUMSubscriberCallAnsweringDataResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TaskTimedOut Property

Aspose.Email

GetUMSubscriberCallAnsweringDataResponseMessageType.TaskTimedOut Property

public bool TaskTimedOut {get; set;}

Remarks

See Also

GetUMSubscriberCallAnsweringDataResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUMSubscriberCallAnsweringDataType Class

For a list of all members of this type, see GetUMSubscriberCallAnsweringDataType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.GetUMSubscriberCallAnsweringDataType

public class GetUMSubscriberCallAnsweringDataType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetUMSubscriberCallAnsweringDataType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUMSubscriberCallAnsweringDataType Members

GetUMSubscriberCallAnsweringDataType overview

Public Instance Constructors

GetUMSubscriberCallAnsweringDataType Constructor Initializes a new instance of the GetUMSubscriberCallAnsweringDataType class.

Public Instance Properties

Timeout

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetUMSubscriberCallAnsweringDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUMSubscriberCallAnsweringDataType Constructor

Initializes a new instance of the GetUMSubscriberCallAnsweringDataType class.

public GetUMSubscriberCallAnsweringDataType();

See Also

GetUMSubscriberCallAnsweringDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUMSubscriberCallAnsweringDataType Properties

The properties of the GetUMSubscriberCallAnsweringDataType class are listed below. For a complete list of GetUMSubscriberCallAnsweringDataType class members, see the GetUMSubscriberCallAnsweringDataType Members topic.

Public Instance Properties

Timeout

See Also

GetUMSubscriberCallAnsweringDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Timeout Property

Aspose.Email

GetUMSubscriberCallAnsweringDataType.Timeout Property

public string Timeout {get; set;}

Remarks

See Also

GetUMSubscriberCallAnsweringDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserAvailabilityCompletedEventArgs Class

For a list of all members of this type, see GetUserAvailabilityCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetUserAvailabilityCompletedEventArgs

public class GetUserAvailabilityCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetUserAvailabilityCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserAvailabilityCompletedEventArgs Members

GetUserAvailabilityCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetUserAvailabilityCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserAvailabilityCompletedEventArgs Properties

The properties of the GetUserAvailabilityCompletedEventArgs class are listed below. For a complete list of GetUserAvailabilityCompletedEventArgs class members, see the GetUserAvailabilityCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetUserAvailabilityCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

GetUserAvailabilityCompletedEventArgs.Result Property

public GetUserAvailabilityResponseType Result {get;}

Remarks

See Also

GetUserAvailabilityCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserAvailabilityCompletedEventHandler Delegate

public delegate void GetUserAvailabilityCompletedEventHandler(
object sender,
GetUserAvailabilityCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserAvailabilityRequestType Class

For a list of all members of this type, see GetUserAvailabilityRequestType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.GetUserAvailabilityRequestType

public class GetUserAvailabilityRequestType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetUserAvailabilityRequestType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserAvailabilityRequestType Members

GetUserAvailabilityRequestType overview

Public Instance Constructors

GetUserAvailabilityRequestType Constructor Initializes a new instance of the GetUserAvailabilityRequestType class.

Public Instance Properties

FreeBusyViewOptions
MailboxDataArray
SuggestionsViewOptions
TimeZone

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetUserAvailabilityRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserAvailabilityRequestType Constructor

Initializes a new instance of the GetUserAvailabilityRequestType class.

public GetUserAvailabilityRequestType();

See Also

GetUserAvailabilityRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserAvailabilityRequestType Properties

The properties of the GetUserAvailabilityRequestType class are listed below. For a complete list of GetUserAvailabilityRequestType class members, see the GetUserAvailabilityRequestType Members topic.

Public Instance Properties

FreeBusyViewOptions
MailboxDataArray
SuggestionsViewOptions
TimeZone

See Also

GetUserAvailabilityRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FreeBusyViewOptions Property

Aspose.Email

GetUserAvailabilityRequestType.FreeBusyViewOptions Property

public FreeBusyViewOptionsType FreeBusyViewOptions {get; set;}

Remarks

See Also

GetUserAvailabilityRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxDataArray Property

Aspose.Email

GetUserAvailabilityRequestType.MailboxDataArray Property

public MailboxData[] MailboxDataArray {get; set;}

Remarks

See Also

GetUserAvailabilityRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SuggestionsViewOptions Property

Aspose.Email

GetUserAvailabilityRequestType.SuggestionsViewOptions Property

public SuggestionsViewOptionsType SuggestionsViewOptions {get; set;}

Remarks

See Also

GetUserAvailabilityRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TimeZone Property

Aspose.Email

GetUserAvailabilityRequestType.TimeZone Property

public SerializableTimeZone TimeZone {get; set;}

Remarks

See Also

GetUserAvailabilityRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserAvailabilityResponseType Class

For a list of all members of this type, see GetUserAvailabilityResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.GetUserAvailabilityResponseType

public class GetUserAvailabilityResponseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetUserAvailabilityResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserAvailabilityResponseType Members

GetUserAvailabilityResponseType overview

Public Instance Constructors

GetUserAvailabilityResponseType Constructor Initializes a new instance of the GetUserAvailabilityResponseType class.

Public Instance Properties

FreeBusyResponseArray
SuggestionsResponse

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetUserAvailabilityResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserAvailabilityResponseType Constructor

Initializes a new instance of the GetUserAvailabilityResponseType class.

public GetUserAvailabilityResponseType();

See Also

GetUserAvailabilityResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserAvailabilityResponseType Properties

The properties of the GetUserAvailabilityResponseType class are listed below. For a complete list of GetUserAvailabilityResponseType class members, see the GetUserAvailabilityResponseType Members topic.

Public Instance Properties

FreeBusyResponseArray
SuggestionsResponse

See Also

GetUserAvailabilityResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FreeBusyResponseArray Property

Aspose.Email

GetUserAvailabilityResponseType.FreeBusyResponseArray Property

public FreeBusyResponseType[] FreeBusyResponseArray {get; set;}

Remarks

See Also

GetUserAvailabilityResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SuggestionsResponse Property

Aspose.Email

GetUserAvailabilityResponseType.SuggestionsResponse Property

public SuggestionsResponseType SuggestionsResponse {get; set;}

Remarks

See Also

GetUserAvailabilityResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserConfigurationCompletedEventArgs Class

For a list of all members of this type, see GetUserConfigurationCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetUserConfigurationCompletedEventArgs

public class GetUserConfigurationCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetUserConfigurationCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserConfigurationCompletedEventArgs Members

GetUserConfigurationCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetUserConfigurationCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserConfigurationCompletedEventArgs Properties

The properties of the GetUserConfigurationCompletedEventArgs class are listed below. For a complete list of GetUserConfigurationCompletedEventArgs class members, see the GetUserConfigurationCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetUserConfigurationCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

GetUserConfigurationCompletedEventArgs.Result Property

public GetUserConfigurationResponseType Result {get;}

Remarks

See Also

GetUserConfigurationCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserConfigurationCompletedEventHandler Delegate

public delegate void GetUserConfigurationCompletedEventHandler(
object sender,
GetUserConfigurationCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserConfigurationResponseMessageType Class

For a list of all members of this type, see GetUserConfigurationResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetUserConfigurationResponseMessageType

public class GetUserConfigurationResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetUserConfigurationResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserConfigurationResponseMessageType Members

GetUserConfigurationResponseMessageType overview

Public Instance Constructors

GetUserConfigurationResponseMessageType Constructor Initializes a new instance of the GetUserConfigurationResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
UserConfiguration

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetUserConfigurationResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserConfigurationResponseMessageType Constructor

Initializes a new instance of the GetUserConfigurationResponseMessageType class.

public GetUserConfigurationResponseMessageType();

See Also

GetUserConfigurationResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserConfigurationResponseMessageType Properties

The properties of the GetUserConfigurationResponseMessageType class are listed below. For a complete list of GetUserConfigurationResponseMessageType class members, see the GetUserConfigurationResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
UserConfiguration

See Also

GetUserConfigurationResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserConfiguration Property

Aspose.Email

GetUserConfigurationResponseMessageType.UserConfiguration Property

public UserConfigurationType UserConfiguration {get; set;}

Remarks

See Also

GetUserConfigurationResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserConfigurationResponseType Class

For a list of all members of this type, see GetUserConfigurationResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetUserConfigurationResponseType

public class GetUserConfigurationResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetUserConfigurationResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserConfigurationResponseType Members

GetUserConfigurationResponseType overview

Public Instance Constructors

GetUserConfigurationResponseType Constructor Initializes a new instance of the GetUserConfigurationResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetUserConfigurationResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserConfigurationResponseType Constructor

Initializes a new instance of the GetUserConfigurationResponseType class.

public GetUserConfigurationResponseType();

See Also

GetUserConfigurationResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserConfigurationType Class

For a list of all members of this type, see GetUserConfigurationType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.GetUserConfigurationType

public class GetUserConfigurationType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetUserConfigurationType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserConfigurationType Members

GetUserConfigurationType overview

Public Instance Constructors

GetUserConfigurationType Constructor Initializes a new instance of the GetUserConfigurationType class.

Public Instance Properties

UserConfigurationName
UserConfigurationProperties

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetUserConfigurationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserConfigurationType Constructor

Initializes a new instance of the GetUserConfigurationType class.

public GetUserConfigurationType();

See Also

GetUserConfigurationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserConfigurationType Properties

The properties of the GetUserConfigurationType class are listed below. For a complete list of GetUserConfigurationType class members, see the GetUserConfigurationType Members topic.

Public Instance Properties

UserConfigurationName
UserConfigurationProperties

See Also

GetUserConfigurationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserConfigurationName Property

Aspose.Email

GetUserConfigurationType.UserConfigurationName Property

public UserConfigurationNameType UserConfigurationName {get; set;}

Remarks

See Also

GetUserConfigurationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserConfigurationProperties Property

Aspose.Email

GetUserConfigurationType.UserConfigurationProperties Property

public UserConfigurationPropertyType UserConfigurationProperties {get; set;}

Remarks

See Also

GetUserConfigurationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserOofSettingsCompletedEventArgs Class

For a list of all members of this type, see GetUserOofSettingsCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetUserOofSettingsCompletedEventArgs

public class GetUserOofSettingsCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetUserOofSettingsCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserOofSettingsCompletedEventArgs Members

GetUserOofSettingsCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetUserOofSettingsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserOofSettingsCompletedEventArgs Properties

The properties of the GetUserOofSettingsCompletedEventArgs class are listed below. For a complete list of GetUserOofSettingsCompletedEventArgs class members, see the GetUserOofSettingsCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetUserOofSettingsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

GetUserOofSettingsCompletedEventArgs.Result Property

public GetUserOofSettingsResponse Result {get;}

Remarks

See Also

GetUserOofSettingsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserOofSettingsCompletedEventHandler Delegate

public delegate void GetUserOofSettingsCompletedEventHandler(
object sender,
GetUserOofSettingsCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserOofSettingsRequest Class

For a list of all members of this type, see GetUserOofSettingsRequest Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.GetUserOofSettingsRequest

public class GetUserOofSettingsRequest : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetUserOofSettingsRequest Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserOofSettingsRequest Members

GetUserOofSettingsRequest overview

Public Instance Constructors

GetUserOofSettingsRequest Constructor Initializes a new instance of the GetUserOofSettingsRequest class.

Public Instance Properties

Mailbox

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetUserOofSettingsRequest Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserOofSettingsRequest Constructor

Initializes a new instance of the GetUserOofSettingsRequest class.

public GetUserOofSettingsRequest();

See Also

GetUserOofSettingsRequest Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserOofSettingsRequest Properties

The properties of the GetUserOofSettingsRequest class are listed below. For a complete list of GetUserOofSettingsRequest class members, see the GetUserOofSettingsRequest Members topic.

Public Instance Properties

Mailbox

See Also

GetUserOofSettingsRequest Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Mailbox Property

Aspose.Email

GetUserOofSettingsRequest.Mailbox Property

public EmailAddress Mailbox {get; set;}

Remarks

See Also

GetUserOofSettingsRequest Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserOofSettingsResponse Class

For a list of all members of this type, see GetUserOofSettingsResponse Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.GetUserOofSettingsResponse

public class GetUserOofSettingsResponse

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetUserOofSettingsResponse Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserOofSettingsResponse Members

GetUserOofSettingsResponse overview

Public Instance Constructors

GetUserOofSettingsResponse Constructor Initializes a new instance of the GetUserOofSettingsResponse class.

Public Instance Properties

AllowExternalOof
AllowExternalOofSpecified
OofSettings
ResponseMessage

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetUserOofSettingsResponse Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserOofSettingsResponse Constructor

Initializes a new instance of the GetUserOofSettingsResponse class.

public GetUserOofSettingsResponse();

See Also

GetUserOofSettingsResponse Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserOofSettingsResponse Properties

The properties of the GetUserOofSettingsResponse class are listed below. For a complete list of GetUserOofSettingsResponse class members, see the GetUserOofSettingsResponse Members topic.

Public Instance Properties

AllowExternalOof
AllowExternalOofSpecified
OofSettings
ResponseMessage

See Also

GetUserOofSettingsResponse Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AllowExternalOof Property

Aspose.Email

GetUserOofSettingsResponse.AllowExternalOof Property

public ExternalAudience AllowExternalOof {get; set;}

Remarks

See Also

GetUserOofSettingsResponse Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AllowExternalOofSpecified Property

Aspose.Email

GetUserOofSettingsResponse.AllowExternalOofSpecified Property

public bool AllowExternalOofSpecified {get; set;}

Remarks

See Also

GetUserOofSettingsResponse Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OofSettings Property

Aspose.Email

GetUserOofSettingsResponse.OofSettings Property

public UserOofSettings OofSettings {get; set;}

Remarks

See Also

GetUserOofSettingsResponse Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResponseMessage Property

Aspose.Email

GetUserOofSettingsResponse.ResponseMessage Property

public ResponseMessageType ResponseMessage {get; set;}

Remarks

See Also

GetUserOofSettingsResponse Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserPhotoCompletedEventArgs Class

For a list of all members of this type, see GetUserPhotoCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetUserPhotoCompletedEventArgs

public class GetUserPhotoCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetUserPhotoCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserPhotoCompletedEventArgs Members

GetUserPhotoCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetUserPhotoCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserPhotoCompletedEventArgs Properties

The properties of the GetUserPhotoCompletedEventArgs class are listed below. For a complete list of GetUserPhotoCompletedEventArgs class members, see the GetUserPhotoCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetUserPhotoCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

GetUserPhotoCompletedEventArgs.Result Property

public GetUserPhotoResponseMessageType Result {get;}

Remarks

See Also

GetUserPhotoCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserPhotoCompletedEventHandler Delegate

public delegate void GetUserPhotoCompletedEventHandler(
object sender,
GetUserPhotoCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserPhotoResponseMessageType Class

For a list of all members of this type, see GetUserPhotoResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetUserPhotoResponseMessageType

public class GetUserPhotoResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetUserPhotoResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserPhotoResponseMessageType Members

GetUserPhotoResponseMessageType overview

Public Instance Constructors

GetUserPhotoResponseMessageType Constructor Initializes a new instance of the GetUserPhotoResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
HasChanged
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
PictureData
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetUserPhotoResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserPhotoResponseMessageType Constructor

Initializes a new instance of the GetUserPhotoResponseMessageType class.

public GetUserPhotoResponseMessageType();

See Also

GetUserPhotoResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserPhotoResponseMessageType Properties

The properties of the GetUserPhotoResponseMessageType class are listed below. For a complete list of GetUserPhotoResponseMessageType class members, see the GetUserPhotoResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
HasChanged
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
PictureData
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

GetUserPhotoResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


HasChanged Property

Aspose.Email

GetUserPhotoResponseMessageType.HasChanged Property

public bool HasChanged {get; set;}

Remarks

See Also

GetUserPhotoResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PictureData Property

Aspose.Email

GetUserPhotoResponseMessageType.PictureData Property

public byte[] PictureData {get; set;}

Remarks

See Also

GetUserPhotoResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserPhotoResponseType Class

For a list of all members of this type, see GetUserPhotoResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetUserPhotoResponseType

public class GetUserPhotoResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetUserPhotoResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserPhotoResponseType Members

GetUserPhotoResponseType overview

Public Instance Constructors

GetUserPhotoResponseType Constructor Initializes a new instance of the GetUserPhotoResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetUserPhotoResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserPhotoResponseType Constructor

Initializes a new instance of the GetUserPhotoResponseType class.

public GetUserPhotoResponseType();

See Also

GetUserPhotoResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserPhotoType Class

For a list of all members of this type, see GetUserPhotoType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.GetUserPhotoType

public class GetUserPhotoType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetUserPhotoType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserPhotoType Members

GetUserPhotoType overview

Public Instance Constructors

GetUserPhotoType Constructor Initializes a new instance of the GetUserPhotoType class.

Public Instance Properties

Email
SizeRequested

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetUserPhotoType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserPhotoType Constructor

Initializes a new instance of the GetUserPhotoType class.

public GetUserPhotoType();

See Also

GetUserPhotoType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserPhotoType Properties

The properties of the GetUserPhotoType class are listed below. For a complete list of GetUserPhotoType class members, see the GetUserPhotoType Members topic.

Public Instance Properties

Email
SizeRequested

See Also

GetUserPhotoType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Email Property

Aspose.Email

GetUserPhotoType.Email Property

public string Email {get; set;}

Remarks

See Also

GetUserPhotoType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SizeRequested Property

Aspose.Email

GetUserPhotoType.SizeRequested Property

public UserPhotoSizeType SizeRequested {get; set;}

Remarks

See Also

GetUserPhotoType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserRetentionPolicyTagsCompletedEventArgs Class

For a list of all members of this type, see GetUserRetentionPolicyTagsCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetUserRetentionPolicyTagsCompletedEventArgs

public class GetUserRetentionPolicyTagsCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetUserRetentionPolicyTagsCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserRetentionPolicyTagsCompletedEventArgs Members

GetUserRetentionPolicyTagsCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

GetUserRetentionPolicyTagsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserRetentionPolicyTagsCompletedEventArgs Properties

The properties of the GetUserRetentionPolicyTagsCompletedEventArgs class are listed below. For a complete list of GetUserRetentionPolicyTagsCompletedEventArgs class members, see the GetUserRetentionPolicyTagsCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

GetUserRetentionPolicyTagsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

GetUserRetentionPolicyTagsCompletedEventArgs.Result Property

public GetUserRetentionPolicyTagsResponseMessageType Result {get;}

Remarks

See Also

GetUserRetentionPolicyTagsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserRetentionPolicyTagsCompletedEventHandler Delegate

public delegate void GetUserRetentionPolicyTagsCompletedEventHandler(
object sender,
GetUserRetentionPolicyTagsCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserRetentionPolicyTagsResponseMessageType Class

For a list of all members of this type, see GetUserRetentionPolicyTagsResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetUserRetentionPolicyTagsResponseMessageType

public class GetUserRetentionPolicyTagsResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetUserRetentionPolicyTagsResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserRetentionPolicyTagsResponseMessageType Members

GetUserRetentionPolicyTagsResponseMessageType overview

Public Instance Constructors

GetUserRetentionPolicyTagsResponseMessageType Constructor Initializes a new instance of the GetUserRetentionPolicyTagsResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
RetentionPolicyTags

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetUserRetentionPolicyTagsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserRetentionPolicyTagsResponseMessageType Constructor

Initializes a new instance of the GetUserRetentionPolicyTagsResponseMessageType class.

public GetUserRetentionPolicyTagsResponseMessageType();

See Also

GetUserRetentionPolicyTagsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserRetentionPolicyTagsResponseMessageType Properties

The properties of the GetUserRetentionPolicyTagsResponseMessageType class are listed below. For a complete list of GetUserRetentionPolicyTagsResponseMessageType class members, see the GetUserRetentionPolicyTagsResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
RetentionPolicyTags

See Also

GetUserRetentionPolicyTagsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RetentionPolicyTags Property

Aspose.Email

GetUserRetentionPolicyTagsResponseMessageType.RetentionPolicyTags Property

public RetentionPolicyTagType[] RetentionPolicyTags {get; set;}

Remarks

See Also

GetUserRetentionPolicyTagsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserRetentionPolicyTagsType Class

For a list of all members of this type, see GetUserRetentionPolicyTagsType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.GetUserRetentionPolicyTagsType

public class GetUserRetentionPolicyTagsType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GetUserRetentionPolicyTagsType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserRetentionPolicyTagsType Members

GetUserRetentionPolicyTagsType overview

Public Instance Constructors

GetUserRetentionPolicyTagsType Constructor Initializes a new instance of the GetUserRetentionPolicyTagsType class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GetUserRetentionPolicyTagsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GetUserRetentionPolicyTagsType Constructor

Initializes a new instance of the GetUserRetentionPolicyTagsType class.

public GetUserRetentionPolicyTagsType();

See Also

GetUserRetentionPolicyTagsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GroupAttendeeConflictData Class

For a list of all members of this type, see GroupAttendeeConflictData Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.AttendeeConflictData
Aspose.Email.Exchange.Schema.Exchange_2013.GroupAttendeeConflictData

public class GroupAttendeeConflictData : AttendeeConflictData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GroupAttendeeConflictData Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GroupAttendeeConflictData Members

GroupAttendeeConflictData overview

Public Instance Constructors

GroupAttendeeConflictData Constructor Initializes a new instance of the GroupAttendeeConflictData class.

Public Instance Properties

NumberOfMembers
NumberOfMembersAvailable
NumberOfMembersWithConflict
NumberOfMembersWithNoData

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GroupAttendeeConflictData Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GroupAttendeeConflictData Constructor

Initializes a new instance of the GroupAttendeeConflictData class.

public GroupAttendeeConflictData();

See Also

GroupAttendeeConflictData Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GroupAttendeeConflictData Properties

The properties of the GroupAttendeeConflictData class are listed below. For a complete list of GroupAttendeeConflictData class members, see the GroupAttendeeConflictData Members topic.

Public Instance Properties

NumberOfMembers
NumberOfMembersAvailable
NumberOfMembersWithConflict
NumberOfMembersWithNoData

See Also

GroupAttendeeConflictData Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NumberOfMembers Property

Aspose.Email

GroupAttendeeConflictData.NumberOfMembers Property

public int NumberOfMembers {get; set;}

Remarks

See Also

GroupAttendeeConflictData Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NumberOfMembersAvailable Property

Aspose.Email

GroupAttendeeConflictData.NumberOfMembersAvailable Property

public int NumberOfMembersAvailable {get; set;}

Remarks

See Also

GroupAttendeeConflictData Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NumberOfMembersWithConflict Property

Aspose.Email

GroupAttendeeConflictData.NumberOfMembersWithConflict Property

public int NumberOfMembersWithConflict {get; set;}

Remarks

See Also

GroupAttendeeConflictData Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NumberOfMembersWithNoData Property

Aspose.Email

GroupAttendeeConflictData.NumberOfMembersWithNoData Property

public int NumberOfMembersWithNoData {get; set;}

Remarks

See Also

GroupAttendeeConflictData Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GroupByType Class

For a list of all members of this type, see GroupByType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseGroupByType
Aspose.Email.Exchange.Schema.Exchange_2013.GroupByType

public class GroupByType : BaseGroupByType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GroupByType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GroupByType Members

GroupByType overview

Public Instance Constructors

GroupByType Constructor Initializes a new instance of the GroupByType class.

Public Instance Properties

AggregateOn
Item
Order (inherited from BaseGroupByType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GroupByType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GroupByType Constructor

Initializes a new instance of the GroupByType class.

public GroupByType();

See Also

GroupByType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GroupByType Properties

The properties of the GroupByType class are listed below. For a complete list of GroupByType class members, see the GroupByType Members topic.

Public Instance Properties

AggregateOn
Item
Order (inherited from BaseGroupByType)

See Also

GroupByType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AggregateOn Property

Aspose.Email

GroupByType.AggregateOn Property

public AggregateOnType AggregateOn {get; set;}

Remarks

See Also

GroupByType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Item Property

Aspose.Email

GroupByType.Item Property

public BasePathToElementType Item {get; set;}

Remarks

See Also

GroupByType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GroupedItemsType Class

For a list of all members of this type, see GroupedItemsType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.GroupedItemsType

public class GroupedItemsType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GroupedItemsType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GroupedItemsType Members

GroupedItemsType overview

Public Instance Constructors

GroupedItemsType Constructor Initializes a new instance of the GroupedItemsType class.

Public Instance Properties

GroupIndex
Items

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GroupedItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GroupedItemsType Constructor

Initializes a new instance of the GroupedItemsType class.

public GroupedItemsType();

See Also

GroupedItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GroupedItemsType Properties

The properties of the GroupedItemsType class are listed below. For a complete list of GroupedItemsType class members, see the GroupedItemsType Members topic.

Public Instance Properties

GroupIndex
Items

See Also

GroupedItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GroupIndex Property

Aspose.Email

GroupedItemsType.GroupIndex Property

public string GroupIndex {get; set;}

Remarks

See Also

GroupedItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Items Property

Aspose.Email

GroupedItemsType.Items Property

public ArrayOfRealItemsType Items {get; set;}

Remarks

See Also

GroupedItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


HighlightTermType Class

For a list of all members of this type, see HighlightTermType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.HighlightTermType

public class HighlightTermType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

HighlightTermType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


HighlightTermType Members

HighlightTermType overview

Public Instance Constructors

HighlightTermType Constructor Initializes a new instance of the HighlightTermType class.

Public Instance Properties

Scope
Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

HighlightTermType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


HighlightTermType Constructor

Initializes a new instance of the HighlightTermType class.

public HighlightTermType();

See Also

HighlightTermType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


HighlightTermType Properties

The properties of the HighlightTermType class are listed below. For a complete list of HighlightTermType class members, see the HighlightTermType Members topic.

Public Instance Properties

Scope
Value

See Also

HighlightTermType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Scope Property

Aspose.Email

HighlightTermType.Scope Property

public string Scope {get; set;}

Remarks

See Also

HighlightTermType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Value Property

Aspose.Email

HighlightTermType.Value Property

public string Value {get; set;}

Remarks

See Also

HighlightTermType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


HoldActionType Enumeration

public enum HoldActionType

Remarks

Members

Member Name | Description | Value
Create |  | 0
Update |  | 1
Remove |  | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


HoldStatusType Enumeration

public enum HoldStatusType

Remarks

Members

Member Name | Description | Value
NotOnHold |  | 0
Pending |  | 1
OnHold |  | 2
PartialHold |  | 3
Failed |  | 4

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IconIndexType Enumeration

public enum IconIndexType

Remarks

Members

Member Name | Description | Value
Default |  | 0
PostItem |  | 1
MailRead |  | 2
MailUnread |  | 3
MailReplied |  | 4
MailForwarded |  | 5
MailEncrypted |  | 6
MailSmimeSigned |  | 7
MailEncryptedReplied |  | 8
MailSmimeSignedReplied |  | 9
MailEncryptedForwarded |  | 10
MailSmimeSignedForwarded |  | 11
MailEncryptedRead |  | 12
MailSmimeSignedRead |  | 13
MailIrm |  | 14
MailIrmForwarded |  | 15
MailIrmReplied |  | 16
SmsSubmitted |  | 17
SmsRoutedToDeliveryPoint |  | 18
SmsRoutedToExternalMessagingSystem |  | 19
SmsDelivered |  | 20
OutlookDefaultForContacts |  | 21
AppointmentItem |  | 22
AppointmentRecur |  | 23
AppointmentMeet |  | 24
AppointmentMeetRecur |  | 25
AppointmentMeetNY |  | 26
AppointmentMeetYes |  | 27
AppointmentMeetNo |  | 28
AppointmentMeetMaybe |  | 29
AppointmentMeetCancel |  | 30
AppointmentMeetInfo |  | 31
TaskItem |  | 32
TaskRecur |  | 33
TaskOwned |  | 34
TaskDelegated |  | 35

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IdFormatType Enumeration

public enum IdFormatType

Remarks

Members

Member Name | Description | Value
EwsLegacyId |  | 0
EwsId |  | 1
EntryId |  | 2
HexEntryId |  | 3
StoreId |  | 4
OwaId |  | 5

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ImAddressDictionaryEntryType Class

For a list of all members of this type, see ImAddressDictionaryEntryType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ImAddressDictionaryEntryType

public class ImAddressDictionaryEntryType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ImAddressDictionaryEntryType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ImAddressDictionaryEntryType Members

ImAddressDictionaryEntryType overview

Public Instance Constructors

ImAddressDictionaryEntryType Constructor Initializes a new instance of the ImAddressDictionaryEntryType class.

Public Instance Properties

Key
Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ImAddressDictionaryEntryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ImAddressDictionaryEntryType Constructor

Initializes a new instance of the ImAddressDictionaryEntryType class.

public ImAddressDictionaryEntryType();

See Also

ImAddressDictionaryEntryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ImAddressDictionaryEntryType Properties

The properties of the ImAddressDictionaryEntryType class are listed below. For a complete list of ImAddressDictionaryEntryType class members, see the ImAddressDictionaryEntryType Members topic.

Public Instance Properties

Key
Value

See Also

ImAddressDictionaryEntryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Key Property

Aspose.Email

ImAddressDictionaryEntryType.Key Property

public ImAddressKeyType Key {get; set;}

Remarks

See Also

ImAddressDictionaryEntryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Value Property

Aspose.Email

ImAddressDictionaryEntryType.Value Property

public string Value {get; set;}

Remarks

See Also

ImAddressDictionaryEntryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ImAddressKeyType Enumeration

public enum ImAddressKeyType

Remarks

Members

Member Name | Description | Value
ImAddress1 |  | 0
ImAddress2 |  | 1
ImAddress3 |  | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ImGroupType Class

For a list of all members of this type, see ImGroupType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ImGroupType

public class ImGroupType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ImGroupType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ImGroupType Members

ImGroupType overview

Public Instance Constructors

ImGroupType Constructor Initializes a new instance of the ImGroupType class.

Public Instance Properties

DisplayName
ExchangeStoreId
ExtendedProperties
GroupType
MemberCorrelationKey
SmtpAddress

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ImGroupType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ImGroupType Constructor

Initializes a new instance of the ImGroupType class.

public ImGroupType();

See Also

ImGroupType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ImGroupType Properties

The properties of the ImGroupType class are listed below. For a complete list of ImGroupType class members, see the ImGroupType Members topic.

Public Instance Properties

DisplayName
ExchangeStoreId
ExtendedProperties
GroupType
MemberCorrelationKey
SmtpAddress

See Also

ImGroupType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisplayName Property

Aspose.Email

ImGroupType.DisplayName Property

public string DisplayName {get; set;}

Remarks

See Also

ImGroupType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExchangeStoreId Property

Aspose.Email

ImGroupType.ExchangeStoreId Property

public ItemIdType ExchangeStoreId {get; set;}

Remarks

See Also

ImGroupType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExtendedProperties Property

Aspose.Email

ImGroupType.ExtendedProperties Property

public NonEmptyArrayOfExtendedPropertyType ExtendedProperties {get; set;}

Remarks

See Also

ImGroupType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GroupType Property

Aspose.Email

ImGroupType.GroupType Property

public string GroupType {get; set;}

Remarks

See Also

ImGroupType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MemberCorrelationKey Property

Aspose.Email

ImGroupType.MemberCorrelationKey Property

public ItemIdType[] MemberCorrelationKey {get; set;}

Remarks

See Also

ImGroupType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SmtpAddress Property

Aspose.Email

ImGroupType.SmtpAddress Property

public string SmtpAddress {get; set;}

Remarks

See Also

ImGroupType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ImItemListType Class

For a list of all members of this type, see ImItemListType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ImItemListType

public class ImItemListType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ImItemListType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ImItemListType Members

ImItemListType overview

Public Instance Constructors

ImItemListType Constructor Initializes a new instance of the ImItemListType class.

Public Instance Properties

Groups
Personas

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ImItemListType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ImItemListType Constructor

Initializes a new instance of the ImItemListType class.

public ImItemListType();

See Also

ImItemListType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ImItemListType Properties

The properties of the ImItemListType class are listed below. For a complete list of ImItemListType class members, see the ImItemListType Members topic.

Public Instance Properties

Groups
Personas

See Also

ImItemListType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Groups Property

Aspose.Email

ImItemListType.Groups Property

public ImGroupType[] Groups {get; set;}

Remarks

See Also

ImItemListType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Personas Property

Aspose.Email

ImItemListType.Personas Property

public PersonaType[] Personas {get; set;}

Remarks

See Also

ImItemListType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ImportanceChoicesType Enumeration

public enum ImportanceChoicesType

Remarks

Members

Member Name | Description | Value
Low |  | 0
Normal |  | 1
High |  | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IndexBasePointType Enumeration

public enum IndexBasePointType

Remarks

Members

Member Name | Description | Value
Beginning |  | 0
End |  | 1

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IndexedPageViewType Class

For a list of all members of this type, see IndexedPageViewType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BasePagingType
Aspose.Email.Exchange.Schema.Exchange_2013.IndexedPageViewType

public class IndexedPageViewType : BasePagingType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

IndexedPageViewType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IndexedPageViewType Members

IndexedPageViewType overview

Public Instance Constructors

IndexedPageViewType Constructor Initializes a new instance of the IndexedPageViewType class.

Public Instance Properties

BasePoint
MaxEntriesReturned (inherited from BasePagingType)
MaxEntriesReturnedSpecified (inherited from BasePagingType)
Offset

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IndexedPageViewType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IndexedPageViewType Constructor

Initializes a new instance of the IndexedPageViewType class.

public IndexedPageViewType();

See Also

IndexedPageViewType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IndexedPageViewType Properties

The properties of the IndexedPageViewType class are listed below. For a complete list of IndexedPageViewType class members, see the IndexedPageViewType Members topic.

Public Instance Properties

BasePoint
MaxEntriesReturned (inherited from BasePagingType)
MaxEntriesReturnedSpecified (inherited from BasePagingType)
Offset

See Also

IndexedPageViewType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BasePoint Property

Aspose.Email

IndexedPageViewType.BasePoint Property

public IndexBasePointType BasePoint {get; set;}

Remarks

See Also

IndexedPageViewType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Offset Property

Aspose.Email

IndexedPageViewType.Offset Property

public int Offset {get; set;}

Remarks

See Also

IndexedPageViewType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IndividualAttendeeConflictData Class

For a list of all members of this type, see IndividualAttendeeConflictData Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.AttendeeConflictData
Aspose.Email.Exchange.Schema.Exchange_2013.IndividualAttendeeConflictData

public class IndividualAttendeeConflictData : AttendeeConflictData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

IndividualAttendeeConflictData Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IndividualAttendeeConflictData Members

IndividualAttendeeConflictData overview

Public Instance Constructors

IndividualAttendeeConflictData Constructor Initializes a new instance of the IndividualAttendeeConflictData class.

Public Instance Properties

BusyType

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IndividualAttendeeConflictData Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IndividualAttendeeConflictData Constructor

Initializes a new instance of the IndividualAttendeeConflictData class.

public IndividualAttendeeConflictData();

See Also

IndividualAttendeeConflictData Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IndividualAttendeeConflictData Properties

The properties of the IndividualAttendeeConflictData class are listed below. For a complete list of IndividualAttendeeConflictData class members, see the IndividualAttendeeConflictData Members topic.

Public Instance Properties

BusyType

See Also

IndividualAttendeeConflictData Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BusyType Property

Aspose.Email

IndividualAttendeeConflictData.BusyType Property

public LegacyFreeBusyType BusyType {get; set;}

Remarks

See Also

IndividualAttendeeConflictData Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InitUMMailboxResponseMessageType Class

For a list of all members of this type, see InitUMMailboxResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.InitUMMailboxResponseMessageType

public class InitUMMailboxResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

InitUMMailboxResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InitUMMailboxResponseMessageType Members

InitUMMailboxResponseMessageType overview

Public Instance Constructors

InitUMMailboxResponseMessageType Constructor Initializes a new instance of the InitUMMailboxResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InitUMMailboxResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InitUMMailboxResponseMessageType Constructor

Initializes a new instance of the InitUMMailboxResponseMessageType class.

public InitUMMailboxResponseMessageType();

See Also

InitUMMailboxResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InitUMMailboxType Class

For a list of all members of this type, see InitUMMailboxType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.InitUMMailboxType

public class InitUMMailboxType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

InitUMMailboxType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InitUMMailboxType Members

InitUMMailboxType overview

Public Instance Constructors

InitUMMailboxType Constructor Initializes a new instance of the InitUMMailboxType class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InitUMMailboxType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InitUMMailboxType Constructor

Initializes a new instance of the InitUMMailboxType class.

public InitUMMailboxType();

See Also

InitUMMailboxType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InstallAppCompletedEventArgs Class

For a list of all members of this type, see InstallAppCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.InstallAppCompletedEventArgs

public class InstallAppCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

InstallAppCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InstallAppCompletedEventArgs Members

InstallAppCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

InstallAppCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InstallAppCompletedEventArgs Properties

The properties of the InstallAppCompletedEventArgs class are listed below. For a complete list of InstallAppCompletedEventArgs class members, see the InstallAppCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

InstallAppCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

InstallAppCompletedEventArgs.Result Property

public InstallAppResponseType Result {get;}

Remarks

See Also

InstallAppCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InstallAppCompletedEventHandler Delegate

public delegate void InstallAppCompletedEventHandler(
object sender,
InstallAppCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InstallAppResponseType Class

For a list of all members of this type, see InstallAppResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.InstallAppResponseType

public class InstallAppResponseType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

InstallAppResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InstallAppResponseType Members

InstallAppResponseType overview

Public Instance Constructors

InstallAppResponseType Constructor Initializes a new instance of the InstallAppResponseType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InstallAppResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InstallAppResponseType Constructor

Initializes a new instance of the InstallAppResponseType class.

public InstallAppResponseType();

See Also

InstallAppResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InstallAppType Class

For a list of all members of this type, see InstallAppType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.InstallAppType

public class InstallAppType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

InstallAppType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InstallAppType Members

InstallAppType overview

Public Instance Constructors

InstallAppType Constructor Initializes a new instance of the InstallAppType class.

Public Instance Properties

Manifest

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InstallAppType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InstallAppType Constructor

Initializes a new instance of the InstallAppType class.

public InstallAppType();

See Also

InstallAppType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InstallAppType Properties

The properties of the InstallAppType class are listed below. For a complete list of InstallAppType class members, see the InstallAppType Members topic.

Public Instance Properties

Manifest

See Also

InstallAppType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Manifest Property

Aspose.Email

InstallAppType.Manifest Property

public byte[] Manifest {get; set;}

Remarks

See Also

InstallAppType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InternetHeaderType Class

For a list of all members of this type, see InternetHeaderType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.InternetHeaderType

public class InternetHeaderType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

InternetHeaderType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InternetHeaderType Members

InternetHeaderType overview

Public Instance Constructors

InternetHeaderType Constructor Initializes a new instance of the InternetHeaderType class.

Public Instance Properties

HeaderName
Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InternetHeaderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InternetHeaderType Constructor

Initializes a new instance of the InternetHeaderType class.

public InternetHeaderType();

See Also

InternetHeaderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InternetHeaderType Properties

The properties of the InternetHeaderType class are listed below. For a complete list of InternetHeaderType class members, see the InternetHeaderType Members topic.

Public Instance Properties

HeaderName
Value

See Also

InternetHeaderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


HeaderName Property

Aspose.Email

InternetHeaderType.HeaderName Property

public string HeaderName {get; set;}

Remarks

See Also

InternetHeaderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Value Property

Aspose.Email

InternetHeaderType.Value Property

public string Value {get; set;}

Remarks

See Also

InternetHeaderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IntervalRecurrencePatternBaseType Class

For a list of all members of this type, see IntervalRecurrencePatternBaseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.RecurrencePatternBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.IntervalRecurrencePatternBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.AbsoluteMonthlyRecurrencePatternType
Aspose.Email.Exchange.Schema.Exchange_2013.DailyRecurrencePatternType
Aspose.Email.Exchange.Schema.Exchange_2013.RegeneratingPatternBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.RelativeMonthlyRecurrencePatternType
Aspose.Email.Exchange.Schema.Exchange_2013.WeeklyRecurrencePatternType

public abstract class IntervalRecurrencePatternBaseType : RecurrencePatternBaseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

IntervalRecurrencePatternBaseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IntervalRecurrencePatternBaseType Members

IntervalRecurrencePatternBaseType overview

Public Instance Properties

Interval

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

IntervalRecurrencePatternBaseType Constructor Initializes a new instance of the IntervalRecurrencePatternBaseType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IntervalRecurrencePatternBaseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IntervalRecurrencePatternBaseType Constructor

Initializes a new instance of the IntervalRecurrencePatternBaseType class.

protected IntervalRecurrencePatternBaseType();

See Also

IntervalRecurrencePatternBaseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IntervalRecurrencePatternBaseType Properties

The properties of the IntervalRecurrencePatternBaseType class are listed below. For a complete list of IntervalRecurrencePatternBaseType class members, see the IntervalRecurrencePatternBaseType Members topic.

Public Instance Properties

Interval

See Also

IntervalRecurrencePatternBaseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Interval Property

Aspose.Email

IntervalRecurrencePatternBaseType.Interval Property

public int Interval {get; set;}

Remarks

See Also

IntervalRecurrencePatternBaseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InvalidRecipientResponseCodeType Enumeration

public enum InvalidRecipientResponseCodeType

Remarks

Members

Member Name | Description | Value
OtherError |  | 0
RecipientOrganizationNotFederated |  | 1
CannotObtainTokenFromSTS |  | 2
SystemPolicyBlocksSharingWithThisRecipient |  | 3
RecipientOrganizationFederatedWithUnknownTokenIssuer |  | 4

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InvalidRecipientType Class

For a list of all members of this type, see InvalidRecipientType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.InvalidRecipientType

public class InvalidRecipientType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

InvalidRecipientType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InvalidRecipientType Members

InvalidRecipientType overview

Public Instance Constructors

InvalidRecipientType Constructor Initializes a new instance of the InvalidRecipientType class.

Public Instance Properties

MessageText
ResponseCode
SmtpAddress

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

InvalidRecipientType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InvalidRecipientType Constructor

Initializes a new instance of the InvalidRecipientType class.

public InvalidRecipientType();

See Also

InvalidRecipientType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InvalidRecipientType Properties

The properties of the InvalidRecipientType class are listed below. For a complete list of InvalidRecipientType class members, see the InvalidRecipientType Members topic.

Public Instance Properties

MessageText
ResponseCode
SmtpAddress

See Also

InvalidRecipientType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MessageText Property

Aspose.Email

InvalidRecipientType.MessageText Property

public string MessageText {get; set;}

Remarks

See Also

InvalidRecipientType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResponseCode Property

Aspose.Email

InvalidRecipientType.ResponseCode Property

public InvalidRecipientResponseCodeType ResponseCode {get; set;}

Remarks

See Also

InvalidRecipientType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SmtpAddress Property

Aspose.Email

InvalidRecipientType.SmtpAddress Property

public string SmtpAddress {get; set;}

Remarks

See Also

InvalidRecipientType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsEqualToType Class

For a list of all members of this type, see IsEqualToType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.SearchExpressionType
Aspose.Email.Exchange.Schema.Exchange_2013.TwoOperandExpressionType
Aspose.Email.Exchange.Schema.Exchange_2013.IsEqualToType

public class IsEqualToType : TwoOperandExpressionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

IsEqualToType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsEqualToType Members

IsEqualToType overview

Public Instance Constructors

IsEqualToType Constructor Initializes a new instance of the IsEqualToType class.

Public Instance Properties

FieldURIOrConstant (inherited from TwoOperandExpressionType)
Item (inherited from TwoOperandExpressionType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IsEqualToType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsEqualToType Constructor

Initializes a new instance of the IsEqualToType class.

public IsEqualToType();

See Also

IsEqualToType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsGreaterThanOrEqualToType Class

For a list of all members of this type, see IsGreaterThanOrEqualToType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.SearchExpressionType
Aspose.Email.Exchange.Schema.Exchange_2013.TwoOperandExpressionType
Aspose.Email.Exchange.Schema.Exchange_2013.IsGreaterThanOrEqualToType

public class IsGreaterThanOrEqualToType : TwoOperandExpressionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

IsGreaterThanOrEqualToType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsGreaterThanOrEqualToType Members

IsGreaterThanOrEqualToType overview

Public Instance Constructors

IsGreaterThanOrEqualToType Constructor Initializes a new instance of the IsGreaterThanOrEqualToType class.

Public Instance Properties

FieldURIOrConstant (inherited from TwoOperandExpressionType)
Item (inherited from TwoOperandExpressionType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IsGreaterThanOrEqualToType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsGreaterThanOrEqualToType Constructor

Initializes a new instance of the IsGreaterThanOrEqualToType class.

public IsGreaterThanOrEqualToType();

See Also

IsGreaterThanOrEqualToType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsGreaterThanType Class

For a list of all members of this type, see IsGreaterThanType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.SearchExpressionType
Aspose.Email.Exchange.Schema.Exchange_2013.TwoOperandExpressionType
Aspose.Email.Exchange.Schema.Exchange_2013.IsGreaterThanType

public class IsGreaterThanType : TwoOperandExpressionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

IsGreaterThanType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsGreaterThanType Members

IsGreaterThanType overview

Public Instance Constructors

IsGreaterThanType Constructor Initializes a new instance of the IsGreaterThanType class.

Public Instance Properties

FieldURIOrConstant (inherited from TwoOperandExpressionType)
Item (inherited from TwoOperandExpressionType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IsGreaterThanType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsGreaterThanType Constructor

Initializes a new instance of the IsGreaterThanType class.

public IsGreaterThanType();

See Also

IsGreaterThanType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsLessThanOrEqualToType Class

For a list of all members of this type, see IsLessThanOrEqualToType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.SearchExpressionType
Aspose.Email.Exchange.Schema.Exchange_2013.TwoOperandExpressionType
Aspose.Email.Exchange.Schema.Exchange_2013.IsLessThanOrEqualToType

public class IsLessThanOrEqualToType : TwoOperandExpressionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

IsLessThanOrEqualToType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsLessThanOrEqualToType Members

IsLessThanOrEqualToType overview

Public Instance Constructors

IsLessThanOrEqualToType Constructor Initializes a new instance of the IsLessThanOrEqualToType class.

Public Instance Properties

FieldURIOrConstant (inherited from TwoOperandExpressionType)
Item (inherited from TwoOperandExpressionType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IsLessThanOrEqualToType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsLessThanOrEqualToType Constructor

Initializes a new instance of the IsLessThanOrEqualToType class.

public IsLessThanOrEqualToType();

See Also

IsLessThanOrEqualToType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsLessThanType Class

For a list of all members of this type, see IsLessThanType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.SearchExpressionType
Aspose.Email.Exchange.Schema.Exchange_2013.TwoOperandExpressionType
Aspose.Email.Exchange.Schema.Exchange_2013.IsLessThanType

public class IsLessThanType : TwoOperandExpressionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

IsLessThanType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsLessThanType Members

IsLessThanType overview

Public Instance Constructors

IsLessThanType Constructor Initializes a new instance of the IsLessThanType class.

Public Instance Properties

FieldURIOrConstant (inherited from TwoOperandExpressionType)
Item (inherited from TwoOperandExpressionType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IsLessThanType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsLessThanType Constructor

Initializes a new instance of the IsLessThanType class.

public IsLessThanType();

See Also

IsLessThanType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsNotEqualToType Class

For a list of all members of this type, see IsNotEqualToType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.SearchExpressionType
Aspose.Email.Exchange.Schema.Exchange_2013.TwoOperandExpressionType
Aspose.Email.Exchange.Schema.Exchange_2013.IsNotEqualToType

public class IsNotEqualToType : TwoOperandExpressionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

IsNotEqualToType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsNotEqualToType Members

IsNotEqualToType overview

Public Instance Constructors

IsNotEqualToType Constructor Initializes a new instance of the IsNotEqualToType class.

Public Instance Properties

FieldURIOrConstant (inherited from TwoOperandExpressionType)
Item (inherited from TwoOperandExpressionType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

IsNotEqualToType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsNotEqualToType Constructor

Initializes a new instance of the IsNotEqualToType class.

public IsNotEqualToType();

See Also

IsNotEqualToType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemAttachmentType Class

For a list of all members of this type, see ItemAttachmentType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.AttachmentType
Aspose.Email.Exchange.Schema.Exchange_2013.ItemAttachmentType

public class ItemAttachmentType : AttachmentType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ItemAttachmentType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemAttachmentType Members

ItemAttachmentType overview

Public Instance Constructors

ItemAttachmentType Constructor Initializes a new instance of the ItemAttachmentType class.

Public Instance Properties

AttachmentId (inherited from AttachmentType)
ContentId (inherited from AttachmentType)
ContentLocation (inherited from AttachmentType)
ContentType (inherited from AttachmentType)
IsInline (inherited from AttachmentType)
IsInlineSpecified (inherited from AttachmentType)
Item
LastModifiedTime (inherited from AttachmentType)
LastModifiedTimeSpecified (inherited from AttachmentType)
Name (inherited from AttachmentType)
Size (inherited from AttachmentType)
SizeSpecified (inherited from AttachmentType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ItemAttachmentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemAttachmentType Constructor

Initializes a new instance of the ItemAttachmentType class.

public ItemAttachmentType();

See Also

ItemAttachmentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemAttachmentType Properties

The properties of the ItemAttachmentType class are listed below. For a complete list of ItemAttachmentType class members, see the ItemAttachmentType Members topic.

Public Instance Properties

AttachmentId (inherited from AttachmentType)
ContentId (inherited from AttachmentType)
ContentLocation (inherited from AttachmentType)
ContentType (inherited from AttachmentType)
IsInline (inherited from AttachmentType)
IsInlineSpecified (inherited from AttachmentType)
Item
LastModifiedTime (inherited from AttachmentType)
LastModifiedTimeSpecified (inherited from AttachmentType)
Name (inherited from AttachmentType)
Size (inherited from AttachmentType)
SizeSpecified (inherited from AttachmentType)

See Also

ItemAttachmentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Item Property

Aspose.Email

ItemAttachmentType.Item Property

public ItemType Item {get; set;}

Remarks

See Also

ItemAttachmentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemChangeDescriptionType Class

For a list of all members of this type, see ItemChangeDescriptionType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ChangeDescriptionType
Aspose.Email.Exchange.Schema.Exchange_2013.ItemChangeDescriptionType
Aspose.Email.Exchange.Schema.Exchange_2013.AppendToItemFieldType
Aspose.Email.Exchange.Schema.Exchange_2013.DeleteItemFieldType
Aspose.Email.Exchange.Schema.Exchange_2013.SetItemFieldType

public class ItemChangeDescriptionType : ChangeDescriptionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ItemChangeDescriptionType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemChangeDescriptionType Members

ItemChangeDescriptionType overview

Public Instance Constructors

ItemChangeDescriptionType Constructor Initializes a new instance of the ItemChangeDescriptionType class.

Public Instance Properties

Item (inherited from ChangeDescriptionType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ItemChangeDescriptionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemChangeDescriptionType Constructor

Initializes a new instance of the ItemChangeDescriptionType class.

public ItemChangeDescriptionType();

See Also

ItemChangeDescriptionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemChangeType Class

For a list of all members of this type, see ItemChangeType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ItemChangeType

public class ItemChangeType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ItemChangeType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemChangeType Members

ItemChangeType overview

Public Instance Constructors

ItemChangeType Constructor Initializes a new instance of the ItemChangeType class.

Public Instance Properties

Item
Updates

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ItemChangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemChangeType Constructor

Initializes a new instance of the ItemChangeType class.

public ItemChangeType();

See Also

ItemChangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemChangeType Properties

The properties of the ItemChangeType class are listed below. For a complete list of ItemChangeType class members, see the ItemChangeType Members topic.

Public Instance Properties

Item
Updates

See Also

ItemChangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Item Property

Aspose.Email

ItemChangeType.Item Property

public BaseItemIdType Item {get; set;}

Remarks

See Also

ItemChangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Updates Property

Aspose.Email

ItemChangeType.Updates Property

public ItemChangeDescriptionType[] Updates {get; set;}

Remarks

See Also

ItemChangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemChoiceType Enumeration

public enum ItemChoiceType

Remarks

Members

Member Name | Description | Value
PrimarySmtpAddress |  | 0
PrincipalName |  | 1
SID |  | 2
SmtpAddress |  | 3

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemChoiceType1 Enumeration

public enum ItemChoiceType1

Remarks

Members

Member Name | Description | Value
AllInternal |  | 0
And |  | 1
RecipientIs |  | 2
SenderDepartments |  | 3
True |  | 4

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemIdType Class

For a list of all members of this type, see ItemIdType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseItemIdType
Aspose.Email.Exchange.Schema.Exchange_2013.ItemIdType
Aspose.Email.Exchange.Schema.Exchange_2013.RecurringMasterItemIdRangesType

public class ItemIdType : BaseItemIdType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ItemIdType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemIdType Members

ItemIdType overview

Public Instance Constructors

ItemIdType Constructor Initializes a new instance of the ItemIdType class.

Public Instance Properties

ChangeKey
Id

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ItemIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemIdType Constructor

Initializes a new instance of the ItemIdType class.

public ItemIdType();

See Also

ItemIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemIdType Properties

The properties of the ItemIdType class are listed below. For a complete list of ItemIdType class members, see the ItemIdType Members topic.

Public Instance Properties

ChangeKey
Id

See Also

ItemIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ChangeKey Property

Aspose.Email

ItemIdType.ChangeKey Property

public string ChangeKey {get; set;}

Remarks

See Also

ItemIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Id Property

Aspose.Email

ItemIdType.Id Property

public string Id {get; set;}

Remarks

See Also

ItemIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemIndexErrorType Enumeration

public enum ItemIndexErrorType

Remarks

Members

Member Name | Description | Value
None |  | 0
GenericError |  | 1
Timeout |  | 2
StaleEvent |  | 3
MailboxOffline |  | 4
AttachmentLimitReached |  | 5
MarsWriterTruncation |  | 6
DocumentParserFailure |  | 7

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemInfoResponseMessageType Class

For a list of all members of this type, see ItemInfoResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.ItemInfoResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateItemInRecoverableItemsResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateItemResponseMessageType

public class ItemInfoResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ItemInfoResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemInfoResponseMessageType Members

ItemInfoResponseMessageType overview

Public Instance Constructors

ItemInfoResponseMessageType Constructor Initializes a new instance of the ItemInfoResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
Items
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ItemInfoResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemInfoResponseMessageType Constructor

Initializes a new instance of the ItemInfoResponseMessageType class.

public ItemInfoResponseMessageType();

See Also

ItemInfoResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemInfoResponseMessageType Properties

The properties of the ItemInfoResponseMessageType class are listed below. For a complete list of ItemInfoResponseMessageType class members, see the ItemInfoResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
Items
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

ItemInfoResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Items Property

Aspose.Email

ItemInfoResponseMessageType.Items Property

public ArrayOfRealItemsType Items {get; set;}

Remarks

See Also

ItemInfoResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemQueryTraversalType Enumeration

public enum ItemQueryTraversalType

Remarks

Members

Member Name | Description | Value
Shallow |  | 0
SoftDeleted |  | 1
Associated |  | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemResponseShapeType Class

For a list of all members of this type, see ItemResponseShapeType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ItemResponseShapeType

public class ItemResponseShapeType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ItemResponseShapeType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemResponseShapeType Members

ItemResponseShapeType overview

Public Instance Constructors

ItemResponseShapeType Constructor Initializes a new instance of the ItemResponseShapeType class.

Public Instance Properties

AddBlankTargetToLinks
AddBlankTargetToLinksSpecified
AdditionalProperties
BaseShape
BlockExternalImages
BlockExternalImagesSpecified
BodyType
BodyTypeSpecified
ConvertHtmlCodePageToUTF8
ConvertHtmlCodePageToUTF8Specified
FilterHtmlContent
FilterHtmlContentSpecified
IncludeMimeContent
IncludeMimeContentSpecified
InlineImageUrlTemplate
MaximumBodySize
MaximumBodySizeSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ItemResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemResponseShapeType Constructor

Initializes a new instance of the ItemResponseShapeType class.

public ItemResponseShapeType();

See Also

ItemResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemResponseShapeType Properties

The properties of the ItemResponseShapeType class are listed below. For a complete list of ItemResponseShapeType class members, see the ItemResponseShapeType Members topic.

Public Instance Properties

AddBlankTargetToLinks
AddBlankTargetToLinksSpecified
AdditionalProperties
BaseShape
BlockExternalImages
BlockExternalImagesSpecified
BodyType
BodyTypeSpecified
ConvertHtmlCodePageToUTF8
ConvertHtmlCodePageToUTF8Specified
FilterHtmlContent
FilterHtmlContentSpecified
IncludeMimeContent
IncludeMimeContentSpecified
InlineImageUrlTemplate
MaximumBodySize
MaximumBodySizeSpecified

See Also

ItemResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddBlankTargetToLinks Property

Aspose.Email

ItemResponseShapeType.AddBlankTargetToLinks Property

public bool AddBlankTargetToLinks {get; set;}

Remarks

See Also

ItemResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AddBlankTargetToLinksSpecified Property

Aspose.Email

ItemResponseShapeType.AddBlankTargetToLinksSpecified Property

public bool AddBlankTargetToLinksSpecified {get; set;}

Remarks

See Also

ItemResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AdditionalProperties Property

Aspose.Email

ItemResponseShapeType.AdditionalProperties Property

public BasePathToElementType[] AdditionalProperties {get; set;}

Remarks

See Also

ItemResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseShape Property

Aspose.Email

ItemResponseShapeType.BaseShape Property

public DefaultShapeNamesType BaseShape {get; set;}

Remarks

See Also

ItemResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BlockExternalImages Property

Aspose.Email

ItemResponseShapeType.BlockExternalImages Property

public bool BlockExternalImages {get; set;}

Remarks

See Also

ItemResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BlockExternalImagesSpecified Property

Aspose.Email

ItemResponseShapeType.BlockExternalImagesSpecified Property

public bool BlockExternalImagesSpecified {get; set;}

Remarks

See Also

ItemResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BodyType Property

Aspose.Email

ItemResponseShapeType.BodyType Property

public BodyTypeResponseType BodyType {get; set;}

Remarks

See Also

ItemResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BodyTypeSpecified Property

Aspose.Email

ItemResponseShapeType.BodyTypeSpecified Property

public bool BodyTypeSpecified {get; set;}

Remarks

See Also

ItemResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConvertHtmlCodePageToUTF8 Property

Aspose.Email

ItemResponseShapeType.ConvertHtmlCodePageToUTF8 Property

public bool ConvertHtmlCodePageToUTF8 {get; set;}

Remarks

See Also

ItemResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConvertHtmlCodePageToUTF8Specified Property

Aspose.Email

ItemResponseShapeType.ConvertHtmlCodePageToUTF8Specified Property

public bool ConvertHtmlCodePageToUTF8Specified {get; set;}

Remarks

See Also

ItemResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FilterHtmlContent Property

Aspose.Email

ItemResponseShapeType.FilterHtmlContent Property

public bool FilterHtmlContent {get; set;}

Remarks

See Also

ItemResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FilterHtmlContentSpecified Property

Aspose.Email

ItemResponseShapeType.FilterHtmlContentSpecified Property

public bool FilterHtmlContentSpecified {get; set;}

Remarks

See Also

ItemResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IncludeMimeContent Property

Aspose.Email

ItemResponseShapeType.IncludeMimeContent Property

public bool IncludeMimeContent {get; set;}

Remarks

See Also

ItemResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IncludeMimeContentSpecified Property

Aspose.Email

ItemResponseShapeType.IncludeMimeContentSpecified Property

public bool IncludeMimeContentSpecified {get; set;}

Remarks

See Also

ItemResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InlineImageUrlTemplate Property

Aspose.Email

ItemResponseShapeType.InlineImageUrlTemplate Property

public string InlineImageUrlTemplate {get; set;}

Remarks

See Also

ItemResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MaximumBodySize Property

Aspose.Email

ItemResponseShapeType.MaximumBodySize Property

public int MaximumBodySize {get; set;}

Remarks

See Also

ItemResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MaximumBodySizeSpecified Property

Aspose.Email

ItemResponseShapeType.MaximumBodySizeSpecified Property

public bool MaximumBodySizeSpecified {get; set;}

Remarks

See Also

ItemResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemsChoiceType Enumeration

public enum ItemsChoiceType

Remarks

Members

Member Name | Description | Value
CopiedEvent |  | 0
CreatedEvent |  | 1
DeletedEvent |  | 2
FreeBusyChangedEvent |  | 3
ModifiedEvent |  | 4
MovedEvent |  | 5
NewMailEvent |  | 6
StatusEvent |  | 7

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemsChoiceType1 Enumeration

public enum ItemsChoiceType1

Remarks

Members

Member Name | Description | Value
Create |  | 0
Delete |  | 1
Update |  | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemsChoiceType2 Enumeration

public enum ItemsChoiceType2

Remarks

Members

Member Name | Description | Value
Create |  | 0
Delete |  | 1
ReadFlagChange |  | 2
Update |  | 3

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemsChoiceType3 Enumeration

public enum ItemsChoiceType3

Remarks

Members

Member Name | Description | Value
AllInternal |  | 0
And |  | 1
RecipientIs |  | 2
SenderDepartments |  | 3
True |  | 4

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemsChoiceType4 Enumeration

public enum ItemsChoiceType4

Remarks

Members

Member Name | Description | Value
ApplyConversationActionResponseMessage |  | 0
ArchiveItemResponseMessage |  | 1
ConvertIdResponseMessage |  | 2
CopyFolderResponseMessage |  | 3
CopyItemResponseMessage |  | 4
CreateAttachmentResponseMessage |  | 5
CreateFolderPathResponseMessage |  | 6
CreateFolderResponseMessage |  | 7
CreateItemResponseMessage |  | 8
CreateManagedFolderResponseMessage |  | 9
CreateUserConfigurationResponseMessage |  | 10
DeleteAttachmentResponseMessage |  | 11
DeleteFolderResponseMessage |  | 12
DeleteItemResponseMessage |  | 13
DeleteUserConfigurationResponseMessage |  | 14
EmptyFolderResponseMessage |  | 15
ExpandDLResponseMessage |  | 16
ExportItemsResponseMessage |  | 17
FindFolderResponseMessage |  | 18
FindItemResponseMessage |  | 19
FindMailboxStatisticsByKeywordsResponseMessage |  | 20
FindPeopleResponseMessage |  | 21
GetAppManifestsResponseMessage |  | 22
GetAttachmentResponseMessage |  | 23
GetClientAccessTokenResponseMessage |  | 24
GetClientExtensionResponseMessage |  | 25
GetConversationItemsResponseMessage |  | 26
GetDiscoverySearchConfigurationResponseMessage |  | 27
GetEventsResponseMessage |  | 28
GetFolderResponseMessage |  | 29
GetHoldOnMailboxesResponseMessage |  | 30
GetItemResponseMessage |  | 31
GetNonIndexableItemDetailsResponseMessage |  | 32
GetNonIndexableItemStatisticsResponseMessage |  | 33
GetPasswordExpirationDateResponse |  | 34
GetPersonaResponseMessage |  | 35
GetRemindersResponse |  | 36
GetRoomListsResponse |  | 37
GetRoomsResponse |  | 38
GetSearchableMailboxesResponseMessage |  | 39
GetServerTimeZonesResponseMessage |  | 40
GetSharingFolderResponseMessage |  | 41
GetSharingMetadataResponseMessage |  | 42
GetStreamingEventsResponseMessage |  | 43
GetUserConfigurationResponseMessage |  | 44
GetUserPhotoResponseMessage |  | 45
GetUserRetentionPolicyTagsResponseMessage |  | 46
MarkAllItemsAsReadResponseMessage |  | 47
MarkAsJunkResponseMessage |  | 48
MoveFolderResponseMessage |  | 49
MoveItemResponseMessage |  | 50
PerformReminderActionResponse |  | 51
RefreshSharingFolderResponseMessage |  | 52
ResolveNamesResponseMessage |  | 53
SearchMailboxesResponseMessage |  | 54
SendItemResponseMessage |  | 55
SendNotificationResponseMessage |  | 56
SetClientExtensionResponseMessage |  | 57
SetHoldOnMailboxesResponseMessage |  | 58
SubscribeResponseMessage |  | 59
SyncFolderHierarchyResponseMessage |  | 60
SyncFolderItemsResponseMessage |  | 61
UnsubscribeResponseMessage |  | 62
UpdateFolderResponseMessage |  | 63
UpdateItemInRecoverableItemsResponseMessage |  | 64
UpdateItemResponseMessage |  | 65
UpdateUserConfigurationResponseMessage |  | 66
UploadItemsResponseMessage |  | 67

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemType Class

For a list of all members of this type, see ItemType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ItemType
Derived types

public class ItemType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ItemType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemType Members

ItemType overview

Public Instance Constructors

ItemType Constructor Initializes a new instance of the ItemType class.

Public Instance Properties

ArchiveTag
Attachments
BlockStatus
BlockStatusSpecified
Body
Categories
ConversationId
Culture
DateTimeCreated
DateTimeCreatedSpecified
DateTimeReceived
DateTimeReceivedSpecified
DateTimeSent
DateTimeSentSpecified
DisplayCc
DisplayTo
EffectiveRights
EntityExtractionResult
ExtendedProperty
Flag
GroupingAction
GroupingActionSpecified
HasAttachments
HasAttachmentsSpecified
HasBlockedImages
HasBlockedImagesSpecified
IconIndex
IconIndexSpecified
Importance
ImportanceSpecified
InReplyTo
InstanceKey
InternetMessageHeaders
IsAssociated
IsAssociatedSpecified
IsDraft
IsDraftSpecified
IsFromMe
IsFromMeSpecified
IsResend
IsResendSpecified
IsSubmitted
IsSubmittedSpecified
IsUnmodified
IsUnmodifiedSpecified
ItemClass
ItemId
LastModifiedName
LastModifiedTime
LastModifiedTimeSpecified
MimeContent
NextPredictedAction
NextPredictedActionSpecified
NormalizedBody
ParentFolderId
PolicyTag
Preview
ReminderDueBy
ReminderDueBySpecified
ReminderIsSet
ReminderIsSetSpecified
ReminderMinutesBeforeStart
ReminderNextTime
ReminderNextTimeSpecified
ResponseObjects
RetentionDate
RetentionDateSpecified
RightsManagementLicenseData
Sensitivity
SensitivitySpecified
Size
SizeSpecified
StoreEntryId
Subject
TextBody
UniqueBody
WebClientEditFormQueryString
WebClientReadFormQueryString

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemType Constructor

Initializes a new instance of the ItemType class.

public ItemType();

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemType Properties

The properties of the ItemType class are listed below. For a complete list of ItemType class members, see the ItemType Members topic.

Public Instance Properties

ArchiveTag
Attachments
BlockStatus
BlockStatusSpecified
Body
Categories
ConversationId
Culture
DateTimeCreated
DateTimeCreatedSpecified
DateTimeReceived
DateTimeReceivedSpecified
DateTimeSent
DateTimeSentSpecified
DisplayCc
DisplayTo
EffectiveRights
EntityExtractionResult
ExtendedProperty
Flag
GroupingAction
GroupingActionSpecified
HasAttachments
HasAttachmentsSpecified
HasBlockedImages
HasBlockedImagesSpecified
IconIndex
IconIndexSpecified
Importance
ImportanceSpecified
InReplyTo
InstanceKey
InternetMessageHeaders
IsAssociated
IsAssociatedSpecified
IsDraft
IsDraftSpecified
IsFromMe
IsFromMeSpecified
IsResend
IsResendSpecified
IsSubmitted
IsSubmittedSpecified
IsUnmodified
IsUnmodifiedSpecified
ItemClass
ItemId
LastModifiedName
LastModifiedTime
LastModifiedTimeSpecified
MimeContent
NextPredictedAction
NextPredictedActionSpecified
NormalizedBody
ParentFolderId
PolicyTag
Preview
ReminderDueBy
ReminderDueBySpecified
ReminderIsSet
ReminderIsSetSpecified
ReminderMinutesBeforeStart
ReminderNextTime
ReminderNextTimeSpecified
ResponseObjects
RetentionDate
RetentionDateSpecified
RightsManagementLicenseData
Sensitivity
SensitivitySpecified
Size
SizeSpecified
StoreEntryId
Subject
TextBody
UniqueBody
WebClientEditFormQueryString
WebClientReadFormQueryString

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ArchiveTag Property

Aspose.Email

ItemType.ArchiveTag Property

public RetentionTagType ArchiveTag {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Attachments Property

Aspose.Email

ItemType.Attachments Property

public AttachmentType[] Attachments {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BlockStatus Property

Aspose.Email

ItemType.BlockStatus Property

public bool BlockStatus {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BlockStatusSpecified Property

Aspose.Email

ItemType.BlockStatusSpecified Property

public bool BlockStatusSpecified {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Body Property

Aspose.Email

ItemType.Body Property

public BodyType Body {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Categories Property

Aspose.Email

ItemType.Categories Property

public string[] Categories {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConversationId Property

Aspose.Email

ItemType.ConversationId Property

public ItemIdType ConversationId {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Culture Property

Aspose.Email

ItemType.Culture Property

public string Culture {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DateTimeCreated Property

Aspose.Email

ItemType.DateTimeCreated Property

public DateTime DateTimeCreated {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DateTimeCreatedSpecified Property

Aspose.Email

ItemType.DateTimeCreatedSpecified Property

public bool DateTimeCreatedSpecified {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DateTimeReceived Property

Aspose.Email

ItemType.DateTimeReceived Property

public DateTime DateTimeReceived {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DateTimeReceivedSpecified Property

Aspose.Email

ItemType.DateTimeReceivedSpecified Property

public bool DateTimeReceivedSpecified {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DateTimeSent Property

Aspose.Email

ItemType.DateTimeSent Property

public DateTime DateTimeSent {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DateTimeSentSpecified Property

Aspose.Email

ItemType.DateTimeSentSpecified Property

public bool DateTimeSentSpecified {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisplayCc Property

Aspose.Email

ItemType.DisplayCc Property

public string DisplayCc {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisplayTo Property

Aspose.Email

ItemType.DisplayTo Property

public string DisplayTo {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EffectiveRights Property

Aspose.Email

ItemType.EffectiveRights Property

public EffectiveRightsType EffectiveRights {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EntityExtractionResult Property

Aspose.Email

ItemType.EntityExtractionResult Property

public EntityExtractionResultType EntityExtractionResult {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExtendedProperty Property

Aspose.Email

ItemType.ExtendedProperty Property

public ExtendedPropertyType[] ExtendedProperty {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Flag Property

Aspose.Email

ItemType.Flag Property

public FlagType Flag {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GroupingAction Property

Aspose.Email

ItemType.GroupingAction Property

public PredictedMessageActionType GroupingAction {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GroupingActionSpecified Property

Aspose.Email

ItemType.GroupingActionSpecified Property

public bool GroupingActionSpecified {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


HasAttachments Property

Aspose.Email

ItemType.HasAttachments Property

public bool HasAttachments {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


HasAttachmentsSpecified Property

Aspose.Email

ItemType.HasAttachmentsSpecified Property

public bool HasAttachmentsSpecified {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


HasBlockedImages Property

Aspose.Email

ItemType.HasBlockedImages Property

public bool HasBlockedImages {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


HasBlockedImagesSpecified Property

Aspose.Email

ItemType.HasBlockedImagesSpecified Property

public bool HasBlockedImagesSpecified {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IconIndex Property

Aspose.Email

ItemType.IconIndex Property

public IconIndexType IconIndex {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IconIndexSpecified Property

Aspose.Email

ItemType.IconIndexSpecified Property

public bool IconIndexSpecified {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Importance Property

Aspose.Email

ItemType.Importance Property

public ImportanceChoicesType Importance {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ImportanceSpecified Property

Aspose.Email

ItemType.ImportanceSpecified Property

public bool ImportanceSpecified {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InReplyTo Property

Aspose.Email

ItemType.InReplyTo Property

public string InReplyTo {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InstanceKey Property

Aspose.Email

ItemType.InstanceKey Property

public byte[] InstanceKey {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InternetMessageHeaders Property

Aspose.Email

ItemType.InternetMessageHeaders Property

public InternetHeaderType[] InternetMessageHeaders {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsAssociated Property

Aspose.Email

ItemType.IsAssociated Property

public bool IsAssociated {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsAssociatedSpecified Property

Aspose.Email

ItemType.IsAssociatedSpecified Property

public bool IsAssociatedSpecified {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsDraft Property

Aspose.Email

ItemType.IsDraft Property

public bool IsDraft {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsDraftSpecified Property

Aspose.Email

ItemType.IsDraftSpecified Property

public bool IsDraftSpecified {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsFromMe Property

Aspose.Email

ItemType.IsFromMe Property

public bool IsFromMe {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsFromMeSpecified Property

Aspose.Email

ItemType.IsFromMeSpecified Property

public bool IsFromMeSpecified {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsResend Property

Aspose.Email

ItemType.IsResend Property

public bool IsResend {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsResendSpecified Property

Aspose.Email

ItemType.IsResendSpecified Property

public bool IsResendSpecified {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsSubmitted Property

Aspose.Email

ItemType.IsSubmitted Property

public bool IsSubmitted {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsSubmittedSpecified Property

Aspose.Email

ItemType.IsSubmittedSpecified Property

public bool IsSubmittedSpecified {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsUnmodified Property

Aspose.Email

ItemType.IsUnmodified Property

public bool IsUnmodified {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsUnmodifiedSpecified Property

Aspose.Email

ItemType.IsUnmodifiedSpecified Property

public bool IsUnmodifiedSpecified {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemClass Property

Aspose.Email

ItemType.ItemClass Property

public string ItemClass {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemId Property

Aspose.Email

ItemType.ItemId Property

public ItemIdType ItemId {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


LastModifiedName Property

Aspose.Email

ItemType.LastModifiedName Property

public string LastModifiedName {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


LastModifiedTime Property

Aspose.Email

ItemType.LastModifiedTime Property

public DateTime LastModifiedTime {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


LastModifiedTimeSpecified Property

Aspose.Email

ItemType.LastModifiedTimeSpecified Property

public bool LastModifiedTimeSpecified {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MimeContent Property

Aspose.Email

ItemType.MimeContent Property

public MimeContentType MimeContent {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NextPredictedAction Property

Aspose.Email

ItemType.NextPredictedAction Property

public PredictedMessageActionType NextPredictedAction {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NextPredictedActionSpecified Property

Aspose.Email

ItemType.NextPredictedActionSpecified Property

public bool NextPredictedActionSpecified {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NormalizedBody Property

Aspose.Email

ItemType.NormalizedBody Property

public BodyType NormalizedBody {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ParentFolderId Property

Aspose.Email

ItemType.ParentFolderId Property

public FolderIdType ParentFolderId {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PolicyTag Property

Aspose.Email

ItemType.PolicyTag Property

public RetentionTagType PolicyTag {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Preview Property

Aspose.Email

ItemType.Preview Property

public string Preview {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReminderDueBy Property

Aspose.Email

ItemType.ReminderDueBy Property

public DateTime ReminderDueBy {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReminderDueBySpecified Property

Aspose.Email

ItemType.ReminderDueBySpecified Property

public bool ReminderDueBySpecified {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReminderIsSet Property

Aspose.Email

ItemType.ReminderIsSet Property

public bool ReminderIsSet {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReminderIsSetSpecified Property

Aspose.Email

ItemType.ReminderIsSetSpecified Property

public bool ReminderIsSetSpecified {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReminderMinutesBeforeStart Property

Aspose.Email

ItemType.ReminderMinutesBeforeStart Property

public string ReminderMinutesBeforeStart {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReminderNextTime Property

Aspose.Email

ItemType.ReminderNextTime Property

public DateTime ReminderNextTime {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReminderNextTimeSpecified Property

Aspose.Email

ItemType.ReminderNextTimeSpecified Property

public bool ReminderNextTimeSpecified {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResponseObjects Property

Aspose.Email

ItemType.ResponseObjects Property

public ResponseObjectType[] ResponseObjects {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RetentionDate Property

Aspose.Email

ItemType.RetentionDate Property

public DateTime RetentionDate {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RetentionDateSpecified Property

Aspose.Email

ItemType.RetentionDateSpecified Property

public bool RetentionDateSpecified {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RightsManagementLicenseData Property

Aspose.Email

ItemType.RightsManagementLicenseData Property

public RightsManagementLicenseDataType RightsManagementLicenseData {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Sensitivity Property

Aspose.Email

ItemType.Sensitivity Property

public SensitivityChoicesType Sensitivity {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SensitivitySpecified Property

Aspose.Email

ItemType.SensitivitySpecified Property

public bool SensitivitySpecified {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Size Property

Aspose.Email

ItemType.Size Property

public int Size {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SizeSpecified Property

Aspose.Email

ItemType.SizeSpecified Property

public bool SizeSpecified {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StoreEntryId Property

Aspose.Email

ItemType.StoreEntryId Property

public byte[] StoreEntryId {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Subject Property

Aspose.Email

ItemType.Subject Property

public string Subject {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TextBody Property

Aspose.Email

ItemType.TextBody Property

public BodyType TextBody {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UniqueBody Property

Aspose.Email

ItemType.UniqueBody Property

public BodyType UniqueBody {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


WebClientEditFormQueryString Property

Aspose.Email

ItemType.WebClientEditFormQueryString Property

public string WebClientEditFormQueryString {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


WebClientReadFormQueryString Property

Aspose.Email

ItemType.WebClientReadFormQueryString Property

public string WebClientReadFormQueryString {get; set;}

Remarks

See Also

ItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


KeywordStatisticsSearchResultType Class

For a list of all members of this type, see KeywordStatisticsSearchResultType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.KeywordStatisticsSearchResultType

public class KeywordStatisticsSearchResultType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

KeywordStatisticsSearchResultType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


KeywordStatisticsSearchResultType Members

KeywordStatisticsSearchResultType overview

Public Instance Constructors

KeywordStatisticsSearchResultType Constructor Initializes a new instance of the KeywordStatisticsSearchResultType class.

Public Instance Properties

ItemHits
Keyword
Size

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

KeywordStatisticsSearchResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


KeywordStatisticsSearchResultType Constructor

Initializes a new instance of the KeywordStatisticsSearchResultType class.

public KeywordStatisticsSearchResultType();

See Also

KeywordStatisticsSearchResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


KeywordStatisticsSearchResultType Properties

The properties of the KeywordStatisticsSearchResultType class are listed below. For a complete list of KeywordStatisticsSearchResultType class members, see the KeywordStatisticsSearchResultType Members topic.

Public Instance Properties

ItemHits
Keyword
Size

See Also

KeywordStatisticsSearchResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemHits Property

Aspose.Email

KeywordStatisticsSearchResultType.ItemHits Property

public int ItemHits {get; set;}

Remarks

See Also

KeywordStatisticsSearchResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Keyword Property

Aspose.Email

KeywordStatisticsSearchResultType.Keyword Property

public string Keyword {get; set;}

Remarks

See Also

KeywordStatisticsSearchResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Size Property

Aspose.Email

KeywordStatisticsSearchResultType.Size Property

public long Size {get; set;}

Remarks

See Also

KeywordStatisticsSearchResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


LegacyFreeBusyType Enumeration

public enum LegacyFreeBusyType

Remarks

Members

Member Name | Description | Value
Free |  | 0
Tentative |  | 1
Busy |  | 2
OOF |  | 3
WorkingElsewhere |  | 4
NoData |  | 5

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


LobbyBypassType Enumeration

public enum LobbyBypassType

Remarks

Members

Member Name | Description | Value
Disabled |  | 0
EnabledForGatewayParticipants |  | 1

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


LocationBasedStateDefinitionType Class

For a list of all members of this type, see LocationBasedStateDefinitionType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseCalendarItemStateDefinitionType
Aspose.Email.Exchange.Schema.Exchange_2013.LocationBasedStateDefinitionType

public class LocationBasedStateDefinitionType : BaseCalendarItemStateDefinitionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

LocationBasedStateDefinitionType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


LocationBasedStateDefinitionType Members

LocationBasedStateDefinitionType overview

Public Instance Constructors

LocationBasedStateDefinitionType Constructor Initializes a new instance of the LocationBasedStateDefinitionType class.

Public Instance Properties

AttendeeLocation
OrganizerLocation

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LocationBasedStateDefinitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


LocationBasedStateDefinitionType Constructor

Initializes a new instance of the LocationBasedStateDefinitionType class.

public LocationBasedStateDefinitionType();

See Also

LocationBasedStateDefinitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


LocationBasedStateDefinitionType Properties

The properties of the LocationBasedStateDefinitionType class are listed below. For a complete list of LocationBasedStateDefinitionType class members, see the LocationBasedStateDefinitionType Members topic.

Public Instance Properties

AttendeeLocation
OrganizerLocation

See Also

LocationBasedStateDefinitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AttendeeLocation Property

Aspose.Email

LocationBasedStateDefinitionType.AttendeeLocation Property

public string AttendeeLocation {get; set;}

Remarks

See Also

LocationBasedStateDefinitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OrganizerLocation Property

Aspose.Email

LocationBasedStateDefinitionType.OrganizerLocation Property

public string OrganizerLocation {get; set;}

Remarks

See Also

LocationBasedStateDefinitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


LocationSourceType Enumeration

public enum LocationSourceType

Remarks

Members

Member Name | Description | Value
None |  | 0
LocationServices |  | 1
PhonebookServices |  | 2
Device |  | 3
Contact |  | 4
Resource |  | 5

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxCultureType Class

For a list of all members of this type, see MailboxCultureType Members.

System.Object
System.Web.Services.Protocols.SoapHeader
Aspose.Email.Exchange.Schema.Exchange_2013.MailboxCultureType

public class MailboxCultureType : SoapHeader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MailboxCultureType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxCultureType Members

MailboxCultureType overview

Public Instance Constructors

MailboxCultureType Constructor Initializes a new instance of the MailboxCultureType class.

Public Instance Properties

Actor (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.
AnyAttr |
DidUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether an XML Web service method properly processed a SOAP header.
EncodedMustUnderstand (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.1.
EncodedMustUnderstand12 (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.2.
EncodedRelay (inherited from SoapHeader) | Gets or sets the relay attribute of the SOAP 1.2 header.
MustUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether the SoapHeader must be understood.
Relay (inherited from SoapHeader) | Gets or sets a value that indicates whether the SOAP header is to be relayed to the next SOAP node if the current node does not understand the header.
Role (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.
Value |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MailboxCultureType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxCultureType Constructor

Initializes a new instance of the MailboxCultureType class.

public MailboxCultureType();

See Also

MailboxCultureType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxCultureType Properties

The properties of the MailboxCultureType class are listed below. For a complete list of MailboxCultureType class members, see the MailboxCultureType Members topic.

Public Instance Properties

Actor (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.
AnyAttr |
DidUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether an XML Web service method properly processed a SOAP header.
EncodedMustUnderstand (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.1.
EncodedMustUnderstand12 (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.2.
EncodedRelay (inherited from SoapHeader) | Gets or sets the relay attribute of the SOAP 1.2 header.
MustUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether the SoapHeader must be understood.
Relay (inherited from SoapHeader) | Gets or sets a value that indicates whether the SOAP header is to be relayed to the next SOAP node if the current node does not understand the header.
Role (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.
Value |

See Also

MailboxCultureType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AnyAttr Property

Aspose.Email

MailboxCultureType.AnyAttr Property

public XmlAttribute[] AnyAttr {get; set;}

Remarks

See Also

MailboxCultureType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Value Property

Aspose.Email

MailboxCultureType.Value Property

public string Value {get; set;}

Remarks

See Also

MailboxCultureType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxData Class

For a list of all members of this type, see MailboxData Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.MailboxData

public class MailboxData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MailboxData Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxData Members

MailboxData overview

Public Instance Constructors

MailboxData Constructor Initializes a new instance of the MailboxData class.

Public Instance Properties

AttendeeType
Email
ExcludeConflicts
ExcludeConflictsSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MailboxData Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxData Constructor

Initializes a new instance of the MailboxData class.

public MailboxData();

See Also

MailboxData Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxData Properties

The properties of the MailboxData class are listed below. For a complete list of MailboxData class members, see the MailboxData Members topic.

Public Instance Properties

AttendeeType
Email
ExcludeConflicts
ExcludeConflictsSpecified

See Also

MailboxData Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AttendeeType Property

Aspose.Email

MailboxData.AttendeeType Property

public MeetingAttendeeType AttendeeType {get; set;}

Remarks

See Also

MailboxData Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Email Property

Aspose.Email

MailboxData.Email Property

public EmailAddress Email {get; set;}

Remarks

See Also

MailboxData Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExcludeConflicts Property

Aspose.Email

MailboxData.ExcludeConflicts Property

public bool ExcludeConflicts {get; set;}

Remarks

See Also

MailboxData Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExcludeConflictsSpecified Property

Aspose.Email

MailboxData.ExcludeConflictsSpecified Property

public bool ExcludeConflictsSpecified {get; set;}

Remarks

See Also

MailboxData Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxHoldResultType Class

For a list of all members of this type, see MailboxHoldResultType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.MailboxHoldResultType

public class MailboxHoldResultType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MailboxHoldResultType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxHoldResultType Members

MailboxHoldResultType overview

Public Instance Constructors

MailboxHoldResultType Constructor Initializes a new instance of the MailboxHoldResultType class.

Public Instance Properties

HoldId
MailboxHoldStatuses
Query

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MailboxHoldResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxHoldResultType Constructor

Initializes a new instance of the MailboxHoldResultType class.

public MailboxHoldResultType();

See Also

MailboxHoldResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxHoldResultType Properties

The properties of the MailboxHoldResultType class are listed below. For a complete list of MailboxHoldResultType class members, see the MailboxHoldResultType Members topic.

Public Instance Properties

HoldId
MailboxHoldStatuses
Query

See Also

MailboxHoldResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


HoldId Property

Aspose.Email

MailboxHoldResultType.HoldId Property

public string HoldId {get; set;}

Remarks

See Also

MailboxHoldResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxHoldStatuses Property

Aspose.Email

MailboxHoldResultType.MailboxHoldStatuses Property

public MailboxHoldStatusType[] MailboxHoldStatuses {get; set;}

Remarks

See Also

MailboxHoldResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Query Property

Aspose.Email

MailboxHoldResultType.Query Property

public string Query {get; set;}

Remarks

See Also

MailboxHoldResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxHoldStatusType Class

For a list of all members of this type, see MailboxHoldStatusType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.MailboxHoldStatusType

public class MailboxHoldStatusType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MailboxHoldStatusType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxHoldStatusType Members

MailboxHoldStatusType overview

Public Instance Constructors

MailboxHoldStatusType Constructor Initializes a new instance of the MailboxHoldStatusType class.

Public Instance Properties

AdditionalInfo
Mailbox
Status

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MailboxHoldStatusType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxHoldStatusType Constructor

Initializes a new instance of the MailboxHoldStatusType class.

public MailboxHoldStatusType();

See Also

MailboxHoldStatusType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxHoldStatusType Properties

The properties of the MailboxHoldStatusType class are listed below. For a complete list of MailboxHoldStatusType class members, see the MailboxHoldStatusType Members topic.

Public Instance Properties

AdditionalInfo
Mailbox
Status

See Also

MailboxHoldStatusType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AdditionalInfo Property

Aspose.Email

MailboxHoldStatusType.AdditionalInfo Property

public string AdditionalInfo {get; set;}

Remarks

See Also

MailboxHoldStatusType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Mailbox Property

Aspose.Email

MailboxHoldStatusType.Mailbox Property

public string Mailbox {get; set;}

Remarks

See Also

MailboxHoldStatusType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Status Property

Aspose.Email

MailboxHoldStatusType.Status Property

public HoldStatusType Status {get; set;}

Remarks

See Also

MailboxHoldStatusType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxQueryType Class

For a list of all members of this type, see MailboxQueryType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.MailboxQueryType

public class MailboxQueryType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MailboxQueryType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxQueryType Members

MailboxQueryType overview

Public Instance Constructors

MailboxQueryType Constructor Initializes a new instance of the MailboxQueryType class.

Public Instance Properties

MailboxSearchScopes
Query

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MailboxQueryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxQueryType Constructor

Initializes a new instance of the MailboxQueryType class.

public MailboxQueryType();

See Also

MailboxQueryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxQueryType Properties

The properties of the MailboxQueryType class are listed below. For a complete list of MailboxQueryType class members, see the MailboxQueryType Members topic.

Public Instance Properties

MailboxSearchScopes
Query

See Also

MailboxQueryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxSearchScopes Property

Aspose.Email

MailboxQueryType.MailboxSearchScopes Property

public MailboxSearchScopeType[] MailboxSearchScopes {get; set;}

Remarks

See Also

MailboxQueryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Query Property

Aspose.Email

MailboxQueryType.Query Property

public string Query {get; set;}

Remarks

See Also

MailboxQueryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxSearchLocationType Enumeration

public enum MailboxSearchLocationType

Remarks

Members

Member Name | Description | Value
PrimaryOnly |  | 0
ArchiveOnly |  | 1
All |  | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxSearchScopeType Class

For a list of all members of this type, see MailboxSearchScopeType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.MailboxSearchScopeType

public class MailboxSearchScopeType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MailboxSearchScopeType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxSearchScopeType Members

MailboxSearchScopeType overview

Public Instance Constructors

MailboxSearchScopeType Constructor Initializes a new instance of the MailboxSearchScopeType class.

Public Instance Properties

Mailbox
SearchScope

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MailboxSearchScopeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxSearchScopeType Constructor

Initializes a new instance of the MailboxSearchScopeType class.

public MailboxSearchScopeType();

See Also

MailboxSearchScopeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxSearchScopeType Properties

The properties of the MailboxSearchScopeType class are listed below. For a complete list of MailboxSearchScopeType class members, see the MailboxSearchScopeType Members topic.

Public Instance Properties

Mailbox
SearchScope

See Also

MailboxSearchScopeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Mailbox Property

Aspose.Email

MailboxSearchScopeType.Mailbox Property

public string Mailbox {get; set;}

Remarks

See Also

MailboxSearchScopeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchScope Property

Aspose.Email

MailboxSearchScopeType.SearchScope Property

public MailboxSearchLocationType SearchScope {get; set;}

Remarks

See Also

MailboxSearchScopeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxStatisticsItemType Class

For a list of all members of this type, see MailboxStatisticsItemType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.MailboxStatisticsItemType

public class MailboxStatisticsItemType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MailboxStatisticsItemType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxStatisticsItemType Members

MailboxStatisticsItemType overview

Public Instance Constructors

MailboxStatisticsItemType Constructor Initializes a new instance of the MailboxStatisticsItemType class.

Public Instance Properties

DisplayName
ItemCount
MailboxId
Size

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MailboxStatisticsItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxStatisticsItemType Constructor

Initializes a new instance of the MailboxStatisticsItemType class.

public MailboxStatisticsItemType();

See Also

MailboxStatisticsItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxStatisticsItemType Properties

The properties of the MailboxStatisticsItemType class are listed below. For a complete list of MailboxStatisticsItemType class members, see the MailboxStatisticsItemType Members topic.

Public Instance Properties

DisplayName
ItemCount
MailboxId
Size

See Also

MailboxStatisticsItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisplayName Property

Aspose.Email

MailboxStatisticsItemType.DisplayName Property

public string DisplayName {get; set;}

Remarks

See Also

MailboxStatisticsItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemCount Property

Aspose.Email

MailboxStatisticsItemType.ItemCount Property

public long ItemCount {get; set;}

Remarks

See Also

MailboxStatisticsItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxId Property

Aspose.Email

MailboxStatisticsItemType.MailboxId Property

public string MailboxId {get; set;}

Remarks

See Also

MailboxStatisticsItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Size Property

Aspose.Email

MailboxStatisticsItemType.Size Property

public long Size {get; set;}

Remarks

See Also

MailboxStatisticsItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxStatisticsSearchResultType Class

For a list of all members of this type, see MailboxStatisticsSearchResultType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.MailboxStatisticsSearchResultType

public class MailboxStatisticsSearchResultType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MailboxStatisticsSearchResultType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxStatisticsSearchResultType Members

MailboxStatisticsSearchResultType overview

Public Instance Constructors

MailboxStatisticsSearchResultType Constructor Initializes a new instance of the MailboxStatisticsSearchResultType class.

Public Instance Properties

KeywordStatisticsSearchResult
UserMailbox

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MailboxStatisticsSearchResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxStatisticsSearchResultType Constructor

Initializes a new instance of the MailboxStatisticsSearchResultType class.

public MailboxStatisticsSearchResultType();

See Also

MailboxStatisticsSearchResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxStatisticsSearchResultType Properties

The properties of the MailboxStatisticsSearchResultType class are listed below. For a complete list of MailboxStatisticsSearchResultType class members, see the MailboxStatisticsSearchResultType Members topic.

Public Instance Properties

KeywordStatisticsSearchResult
UserMailbox

See Also

MailboxStatisticsSearchResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


KeywordStatisticsSearchResult Property

Aspose.Email

MailboxStatisticsSearchResultType.KeywordStatisticsSearchResult Property

public KeywordStatisticsSearchResultType KeywordStatisticsSearchResult {get; set;}

Remarks

See Also

MailboxStatisticsSearchResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserMailbox Property

Aspose.Email

MailboxStatisticsSearchResultType.UserMailbox Property

public UserMailboxType UserMailbox {get; set;}

Remarks

See Also

MailboxStatisticsSearchResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxTypeType Enumeration

public enum MailboxTypeType

Remarks

Members

Member Name | Description | Value
Unknown |  | 0
OneOff |  | 1
Mailbox |  | 2
PublicDL |  | 3
PrivateDL |  | 4
Contact |  | 5
PublicFolder |  | 6

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailTips Class

For a list of all members of this type, see MailTips Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.MailTips

public class MailTips

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MailTips Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailTips Members

MailTips overview

Public Instance Constructors

MailTips Constructor Initializes a new instance of the MailTips class.

Public Instance Properties

CustomMailTip
DeliveryRestricted
DeliveryRestrictedSpecified
ExternalMemberCount
ExternalMemberCountSpecified
InvalidRecipient
InvalidRecipientSpecified
IsModerated
IsModeratedSpecified
MailboxFull
MailboxFullSpecified
MaxMessageSize
MaxMessageSizeSpecified
OutOfOffice
PendingMailTips
RecipientAddress
Scope
ScopeSpecified
TotalMemberCount
TotalMemberCountSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MailTips Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailTips Constructor

Initializes a new instance of the MailTips class.

public MailTips();

See Also

MailTips Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailTips Properties

The properties of the MailTips class are listed below. For a complete list of MailTips class members, see the MailTips Members topic.

Public Instance Properties

CustomMailTip
DeliveryRestricted
DeliveryRestrictedSpecified
ExternalMemberCount
ExternalMemberCountSpecified
InvalidRecipient
InvalidRecipientSpecified
IsModerated
IsModeratedSpecified
MailboxFull
MailboxFullSpecified
MaxMessageSize
MaxMessageSizeSpecified
OutOfOffice
PendingMailTips
RecipientAddress
Scope
ScopeSpecified
TotalMemberCount
TotalMemberCountSpecified

See Also

MailTips Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CustomMailTip Property

Aspose.Email

MailTips.CustomMailTip Property

public string CustomMailTip {get; set;}

Remarks

See Also

MailTips Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeliveryRestricted Property

Aspose.Email

MailTips.DeliveryRestricted Property

public bool DeliveryRestricted {get; set;}

Remarks

See Also

MailTips Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeliveryRestrictedSpecified Property

Aspose.Email

MailTips.DeliveryRestrictedSpecified Property

public bool DeliveryRestrictedSpecified {get; set;}

Remarks

See Also

MailTips Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExternalMemberCount Property

Aspose.Email

MailTips.ExternalMemberCount Property

public int ExternalMemberCount {get; set;}

Remarks

See Also

MailTips Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExternalMemberCountSpecified Property

Aspose.Email

MailTips.ExternalMemberCountSpecified Property

public bool ExternalMemberCountSpecified {get; set;}

Remarks

See Also

MailTips Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InvalidRecipient Property

Aspose.Email

MailTips.InvalidRecipient Property

public bool InvalidRecipient {get; set;}

Remarks

See Also

MailTips Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InvalidRecipientSpecified Property

Aspose.Email

MailTips.InvalidRecipientSpecified Property

public bool InvalidRecipientSpecified {get; set;}

Remarks

See Also

MailTips Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsModerated Property

Aspose.Email

MailTips.IsModerated Property

public bool IsModerated {get; set;}

Remarks

See Also

MailTips Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsModeratedSpecified Property

Aspose.Email

MailTips.IsModeratedSpecified Property

public bool IsModeratedSpecified {get; set;}

Remarks

See Also

MailTips Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxFull Property

Aspose.Email

MailTips.MailboxFull Property

public bool MailboxFull {get; set;}

Remarks

See Also

MailTips Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxFullSpecified Property

Aspose.Email

MailTips.MailboxFullSpecified Property

public bool MailboxFullSpecified {get; set;}

Remarks

See Also

MailTips Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MaxMessageSize Property

Aspose.Email

MailTips.MaxMessageSize Property

public int MaxMessageSize {get; set;}

Remarks

See Also

MailTips Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MaxMessageSizeSpecified Property

Aspose.Email

MailTips.MaxMessageSizeSpecified Property

public bool MaxMessageSizeSpecified {get; set;}

Remarks

See Also

MailTips Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OutOfOffice Property

Aspose.Email

MailTips.OutOfOffice Property

public OutOfOfficeMailTip OutOfOffice {get; set;}

Remarks

See Also

MailTips Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PendingMailTips Property

Aspose.Email

MailTips.PendingMailTips Property

public MailTipTypes PendingMailTips {get; set;}

Remarks

See Also

MailTips Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecipientAddress Property

Aspose.Email

MailTips.RecipientAddress Property

public EmailAddressType RecipientAddress {get; set;}

Remarks

See Also

MailTips Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Scope Property

Aspose.Email

MailTips.Scope Property

public int Scope {get; set;}

Remarks

See Also

MailTips Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ScopeSpecified Property

Aspose.Email

MailTips.ScopeSpecified Property

public bool ScopeSpecified {get; set;}

Remarks

See Also

MailTips Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TotalMemberCount Property

Aspose.Email

MailTips.TotalMemberCount Property

public int TotalMemberCount {get; set;}

Remarks

See Also

MailTips Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TotalMemberCountSpecified Property

Aspose.Email

MailTips.TotalMemberCountSpecified Property

public bool TotalMemberCountSpecified {get; set;}

Remarks

See Also

MailTips Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailTipsResponseMessageType Class

For a list of all members of this type, see MailTipsResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.MailTipsResponseMessageType

public class MailTipsResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MailTipsResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailTipsResponseMessageType Members

MailTipsResponseMessageType overview

Public Instance Constructors

MailTipsResponseMessageType Constructor Initializes a new instance of the MailTipsResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MailTips
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MailTipsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailTipsResponseMessageType Constructor

Initializes a new instance of the MailTipsResponseMessageType class.

public MailTipsResponseMessageType();

See Also

MailTipsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailTipsResponseMessageType Properties

The properties of the MailTipsResponseMessageType class are listed below. For a complete list of MailTipsResponseMessageType class members, see the MailTipsResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MailTips
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

MailTipsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailTips Property

Aspose.Email

MailTipsResponseMessageType.MailTips Property

public MailTips MailTips {get; set;}

Remarks

See Also

MailTipsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailTipsServiceConfiguration Class

For a list of all members of this type, see MailTipsServiceConfiguration Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ServiceConfiguration
Aspose.Email.Exchange.Schema.Exchange_2013.MailTipsServiceConfiguration

public class MailTipsServiceConfiguration : ServiceConfiguration

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MailTipsServiceConfiguration Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailTipsServiceConfiguration Members

MailTipsServiceConfiguration overview

Public Instance Constructors

MailTipsServiceConfiguration Constructor Initializes a new instance of the MailTipsServiceConfiguration class.

Public Instance Properties

InternalDomains
LargeAudienceCap
LargeAudienceThreshold
MailTipsEnabled
MaxMessageSize
MaxRecipientsPerGetMailTipsRequest
PolicyTipsEnabled
ShowExternalRecipientCount

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MailTipsServiceConfiguration Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailTipsServiceConfiguration Constructor

Initializes a new instance of the MailTipsServiceConfiguration class.

public MailTipsServiceConfiguration();

See Also

MailTipsServiceConfiguration Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailTipsServiceConfiguration Properties

The properties of the MailTipsServiceConfiguration class are listed below. For a complete list of MailTipsServiceConfiguration class members, see the MailTipsServiceConfiguration Members topic.

Public Instance Properties

InternalDomains
LargeAudienceCap
LargeAudienceThreshold
MailTipsEnabled
MaxMessageSize
MaxRecipientsPerGetMailTipsRequest
PolicyTipsEnabled
ShowExternalRecipientCount

See Also

MailTipsServiceConfiguration Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InternalDomains Property

Aspose.Email

MailTipsServiceConfiguration.InternalDomains Property

public SmtpDomain[] InternalDomains {get; set;}

Remarks

See Also

MailTipsServiceConfiguration Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


LargeAudienceCap Property

Aspose.Email

MailTipsServiceConfiguration.LargeAudienceCap Property

public int LargeAudienceCap {get; set;}

Remarks

See Also

MailTipsServiceConfiguration Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


LargeAudienceThreshold Property

Aspose.Email

MailTipsServiceConfiguration.LargeAudienceThreshold Property

public int LargeAudienceThreshold {get; set;}

Remarks

See Also

MailTipsServiceConfiguration Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailTipsEnabled Property

Aspose.Email

MailTipsServiceConfiguration.MailTipsEnabled Property

public bool MailTipsEnabled {get; set;}

Remarks

See Also

MailTipsServiceConfiguration Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MaxMessageSize Property

Aspose.Email

MailTipsServiceConfiguration.MaxMessageSize Property

public int MaxMessageSize {get; set;}

Remarks

See Also

MailTipsServiceConfiguration Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MaxRecipientsPerGetMailTipsRequest Property

Aspose.Email

MailTipsServiceConfiguration.MaxRecipientsPerGetMailTipsRequest Property

public int MaxRecipientsPerGetMailTipsRequest {get; set;}

Remarks

See Also

MailTipsServiceConfiguration Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PolicyTipsEnabled Property

Aspose.Email

MailTipsServiceConfiguration.PolicyTipsEnabled Property

public bool PolicyTipsEnabled {get; set;}

Remarks

See Also

MailTipsServiceConfiguration Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ShowExternalRecipientCount Property

Aspose.Email

MailTipsServiceConfiguration.ShowExternalRecipientCount Property

public bool ShowExternalRecipientCount {get; set;}

Remarks

See Also

MailTipsServiceConfiguration Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailTipTypes Enumeration

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum MailTipTypes

Remarks

Members

Member Name | Description | Value
All |  | 1
OutOfOfficeMessage |  | 2
MailboxFullStatus |  | 4
CustomMailTip |  | 8
ExternalMemberCount |  | 16
TotalMemberCount |  | 32
MaxMessageSize |  | 64
DeliveryRestriction |  | 128
ModerationStatus |  | 256
InvalidRecipient |  | 512
Scope |  | 1024

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ManagedFolderInformationType Class

For a list of all members of this type, see ManagedFolderInformationType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ManagedFolderInformationType

public class ManagedFolderInformationType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ManagedFolderInformationType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ManagedFolderInformationType Members

ManagedFolderInformationType overview

Public Instance Constructors

ManagedFolderInformationType Constructor Initializes a new instance of the ManagedFolderInformationType class.

Public Instance Properties

CanDelete
CanDeleteSpecified
CanRenameOrMove
CanRenameOrMoveSpecified
Comment
FolderSize
FolderSizeSpecified
HasQuota
HasQuotaSpecified
HomePage
IsManagedFoldersRoot
IsManagedFoldersRootSpecified
ManagedFolderId
MustDisplayComment
MustDisplayCommentSpecified
StorageQuota
StorageQuotaSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ManagedFolderInformationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ManagedFolderInformationType Constructor

Initializes a new instance of the ManagedFolderInformationType class.

public ManagedFolderInformationType();

See Also

ManagedFolderInformationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ManagedFolderInformationType Properties

The properties of the ManagedFolderInformationType class are listed below. For a complete list of ManagedFolderInformationType class members, see the ManagedFolderInformationType Members topic.

Public Instance Properties

CanDelete
CanDeleteSpecified
CanRenameOrMove
CanRenameOrMoveSpecified
Comment
FolderSize
FolderSizeSpecified
HasQuota
HasQuotaSpecified
HomePage
IsManagedFoldersRoot
IsManagedFoldersRootSpecified
ManagedFolderId
MustDisplayComment
MustDisplayCommentSpecified
StorageQuota
StorageQuotaSpecified

See Also

ManagedFolderInformationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CanDelete Property

Aspose.Email

ManagedFolderInformationType.CanDelete Property

public bool CanDelete {get; set;}

Remarks

See Also

ManagedFolderInformationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CanDeleteSpecified Property

Aspose.Email

ManagedFolderInformationType.CanDeleteSpecified Property

public bool CanDeleteSpecified {get; set;}

Remarks

See Also

ManagedFolderInformationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CanRenameOrMove Property

Aspose.Email

ManagedFolderInformationType.CanRenameOrMove Property

public bool CanRenameOrMove {get; set;}

Remarks

See Also

ManagedFolderInformationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CanRenameOrMoveSpecified Property

Aspose.Email

ManagedFolderInformationType.CanRenameOrMoveSpecified Property

public bool CanRenameOrMoveSpecified {get; set;}

Remarks

See Also

ManagedFolderInformationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Comment Property

Aspose.Email

ManagedFolderInformationType.Comment Property

public string Comment {get; set;}

Remarks

See Also

ManagedFolderInformationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FolderSize Property

Aspose.Email

ManagedFolderInformationType.FolderSize Property

public int FolderSize {get; set;}

Remarks

See Also

ManagedFolderInformationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FolderSizeSpecified Property

Aspose.Email

ManagedFolderInformationType.FolderSizeSpecified Property

public bool FolderSizeSpecified {get; set;}

Remarks

See Also

ManagedFolderInformationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


HasQuota Property

Aspose.Email

ManagedFolderInformationType.HasQuota Property

public bool HasQuota {get; set;}

Remarks

See Also

ManagedFolderInformationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


HasQuotaSpecified Property

Aspose.Email

ManagedFolderInformationType.HasQuotaSpecified Property

public bool HasQuotaSpecified {get; set;}

Remarks

See Also

ManagedFolderInformationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


HomePage Property

Aspose.Email

ManagedFolderInformationType.HomePage Property

public string HomePage {get; set;}

Remarks

See Also

ManagedFolderInformationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsManagedFoldersRoot Property

Aspose.Email

ManagedFolderInformationType.IsManagedFoldersRoot Property

public bool IsManagedFoldersRoot {get; set;}

Remarks

See Also

ManagedFolderInformationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsManagedFoldersRootSpecified Property

Aspose.Email

ManagedFolderInformationType.IsManagedFoldersRootSpecified Property

public bool IsManagedFoldersRootSpecified {get; set;}

Remarks

See Also

ManagedFolderInformationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ManagedFolderId Property

Aspose.Email

ManagedFolderInformationType.ManagedFolderId Property

public string ManagedFolderId {get; set;}

Remarks

See Also

ManagedFolderInformationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MustDisplayComment Property

Aspose.Email

ManagedFolderInformationType.MustDisplayComment Property

public bool MustDisplayComment {get; set;}

Remarks

See Also

ManagedFolderInformationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MustDisplayCommentSpecified Property

Aspose.Email

ManagedFolderInformationType.MustDisplayCommentSpecified Property

public bool MustDisplayCommentSpecified {get; set;}

Remarks

See Also

ManagedFolderInformationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StorageQuota Property

Aspose.Email

ManagedFolderInformationType.StorageQuota Property

public int StorageQuota {get; set;}

Remarks

See Also

ManagedFolderInformationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StorageQuotaSpecified Property

Aspose.Email

ManagedFolderInformationType.StorageQuotaSpecified Property

public bool StorageQuotaSpecified {get; set;}

Remarks

See Also

ManagedFolderInformationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ManagementRoleType Class

For a list of all members of this type, see ManagementRoleType Members.

System.Object
System.Web.Services.Protocols.SoapHeader
Aspose.Email.Exchange.Schema.Exchange_2013.ManagementRoleType

public class ManagementRoleType : SoapHeader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ManagementRoleType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ManagementRoleType Members

ManagementRoleType overview

Public Instance Constructors

ManagementRoleType Constructor Initializes a new instance of the ManagementRoleType class.

Public Instance Properties

Actor (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.
ApplicationRoles |
DidUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether an XML Web service method properly processed a SOAP header.
EncodedMustUnderstand (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.1.
EncodedMustUnderstand12 (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.2.
EncodedRelay (inherited from SoapHeader) | Gets or sets the relay attribute of the SOAP 1.2 header.
MustUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether the SoapHeader must be understood.
Relay (inherited from SoapHeader) | Gets or sets a value that indicates whether the SOAP header is to be relayed to the next SOAP node if the current node does not understand the header.
Role (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.
UserRoles |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ManagementRoleType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ManagementRoleType Constructor

Initializes a new instance of the ManagementRoleType class.

public ManagementRoleType();

See Also

ManagementRoleType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ManagementRoleType Properties

The properties of the ManagementRoleType class are listed below. For a complete list of ManagementRoleType class members, see the ManagementRoleType Members topic.

Public Instance Properties

Actor (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.
ApplicationRoles |
DidUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether an XML Web service method properly processed a SOAP header.
EncodedMustUnderstand (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.1.
EncodedMustUnderstand12 (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.2.
EncodedRelay (inherited from SoapHeader) | Gets or sets the relay attribute of the SOAP 1.2 header.
MustUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether the SoapHeader must be understood.
Relay (inherited from SoapHeader) | Gets or sets a value that indicates whether the SOAP header is to be relayed to the next SOAP node if the current node does not understand the header.
Role (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.
UserRoles |

See Also

ManagementRoleType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ApplicationRoles Property

Aspose.Email

ManagementRoleType.ApplicationRoles Property

public string[] ApplicationRoles {get; set;}

Remarks

See Also

ManagementRoleType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserRoles Property

Aspose.Email

ManagementRoleType.UserRoles Property

public string[] UserRoles {get; set;}

Remarks

See Also

ManagementRoleType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MapiPropertyTypeType Enumeration

public enum MapiPropertyTypeType

Remarks

Members

Member Name | Description | Value
ApplicationTime |  | 0
ApplicationTimeArray |  | 1
Binary |  | 2
BinaryArray |  | 3
Boolean |  | 4
CLSID |  | 5
CLSIDArray |  | 6
Currency |  | 7
CurrencyArray |  | 8
Double |  | 9
DoubleArray |  | 10
Error |  | 11
Float |  | 12
FloatArray |  | 13
Integer |  | 14
IntegerArray |  | 15
Long |  | 16
LongArray |  | 17
Null |  | 18
Object |  | 19
ObjectArray |  | 20
Short |  | 21
ShortArray |  | 22
SystemTime |  | 23
SystemTimeArray |  | 24
String |  | 25
StringArray |  | 26

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MarkAllItemsAsReadCompletedEventArgs Class

For a list of all members of this type, see MarkAllItemsAsReadCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.MarkAllItemsAsReadCompletedEventArgs

public class MarkAllItemsAsReadCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MarkAllItemsAsReadCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MarkAllItemsAsReadCompletedEventArgs Members

MarkAllItemsAsReadCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

MarkAllItemsAsReadCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MarkAllItemsAsReadCompletedEventArgs Properties

The properties of the MarkAllItemsAsReadCompletedEventArgs class are listed below. For a complete list of MarkAllItemsAsReadCompletedEventArgs class members, see the MarkAllItemsAsReadCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

MarkAllItemsAsReadCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

MarkAllItemsAsReadCompletedEventArgs.Result Property

public MarkAllItemsAsReadResponseType Result {get;}

Remarks

See Also

MarkAllItemsAsReadCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MarkAllItemsAsReadCompletedEventHandler Delegate

public delegate void MarkAllItemsAsReadCompletedEventHandler(
object sender,
MarkAllItemsAsReadCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MarkAllItemsAsReadResponseType Class

For a list of all members of this type, see MarkAllItemsAsReadResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.MarkAllItemsAsReadResponseType

public class MarkAllItemsAsReadResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MarkAllItemsAsReadResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MarkAllItemsAsReadResponseType Members

MarkAllItemsAsReadResponseType overview

Public Instance Constructors

MarkAllItemsAsReadResponseType Constructor Initializes a new instance of the MarkAllItemsAsReadResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MarkAllItemsAsReadResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MarkAllItemsAsReadResponseType Constructor

Initializes a new instance of the MarkAllItemsAsReadResponseType class.

public MarkAllItemsAsReadResponseType();

See Also

MarkAllItemsAsReadResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MarkAllItemsAsReadType Class

For a list of all members of this type, see MarkAllItemsAsReadType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.MarkAllItemsAsReadType

public class MarkAllItemsAsReadType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MarkAllItemsAsReadType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MarkAllItemsAsReadType Members

MarkAllItemsAsReadType overview

Public Instance Constructors

MarkAllItemsAsReadType Constructor Initializes a new instance of the MarkAllItemsAsReadType class.

Public Instance Properties

FolderIds
ReadFlag
SuppressReadReceipts

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MarkAllItemsAsReadType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MarkAllItemsAsReadType Constructor

Initializes a new instance of the MarkAllItemsAsReadType class.

public MarkAllItemsAsReadType();

See Also

MarkAllItemsAsReadType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MarkAllItemsAsReadType Properties

The properties of the MarkAllItemsAsReadType class are listed below. For a complete list of MarkAllItemsAsReadType class members, see the MarkAllItemsAsReadType Members topic.

Public Instance Properties

FolderIds
ReadFlag
SuppressReadReceipts

See Also

MarkAllItemsAsReadType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FolderIds Property

Aspose.Email

MarkAllItemsAsReadType.FolderIds Property

public BaseFolderIdType[] FolderIds {get; set;}

Remarks

See Also

MarkAllItemsAsReadType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReadFlag Property

Aspose.Email

MarkAllItemsAsReadType.ReadFlag Property

public bool ReadFlag {get; set;}

Remarks

See Also

MarkAllItemsAsReadType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SuppressReadReceipts Property

Aspose.Email

MarkAllItemsAsReadType.SuppressReadReceipts Property

public bool SuppressReadReceipts {get; set;}

Remarks

See Also

MarkAllItemsAsReadType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MarkAsJunkCompletedEventArgs Class

For a list of all members of this type, see MarkAsJunkCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.MarkAsJunkCompletedEventArgs

public class MarkAsJunkCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MarkAsJunkCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MarkAsJunkCompletedEventArgs Members

MarkAsJunkCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

MarkAsJunkCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MarkAsJunkCompletedEventArgs Properties

The properties of the MarkAsJunkCompletedEventArgs class are listed below. For a complete list of MarkAsJunkCompletedEventArgs class members, see the MarkAsJunkCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

MarkAsJunkCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

MarkAsJunkCompletedEventArgs.Result Property

public MarkAsJunkResponseType Result {get;}

Remarks

See Also

MarkAsJunkCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MarkAsJunkCompletedEventHandler Delegate

public delegate void MarkAsJunkCompletedEventHandler(
object sender,
MarkAsJunkCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MarkAsJunkResponseMessageType Class

For a list of all members of this type, see MarkAsJunkResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.MarkAsJunkResponseMessageType

public class MarkAsJunkResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MarkAsJunkResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MarkAsJunkResponseMessageType Members

MarkAsJunkResponseMessageType overview

Public Instance Constructors

MarkAsJunkResponseMessageType Constructor Initializes a new instance of the MarkAsJunkResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
MovedItemId
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MarkAsJunkResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MarkAsJunkResponseMessageType Constructor

Initializes a new instance of the MarkAsJunkResponseMessageType class.

public MarkAsJunkResponseMessageType();

See Also

MarkAsJunkResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MarkAsJunkResponseMessageType Properties

The properties of the MarkAsJunkResponseMessageType class are listed below. For a complete list of MarkAsJunkResponseMessageType class members, see the MarkAsJunkResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
MovedItemId
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

MarkAsJunkResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MovedItemId Property

Aspose.Email

MarkAsJunkResponseMessageType.MovedItemId Property

public ItemIdType MovedItemId {get; set;}

Remarks

See Also

MarkAsJunkResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MarkAsJunkResponseType Class

For a list of all members of this type, see MarkAsJunkResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.MarkAsJunkResponseType

public class MarkAsJunkResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MarkAsJunkResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MarkAsJunkResponseType Members

MarkAsJunkResponseType overview

Public Instance Constructors

MarkAsJunkResponseType Constructor Initializes a new instance of the MarkAsJunkResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MarkAsJunkResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MarkAsJunkResponseType Constructor

Initializes a new instance of the MarkAsJunkResponseType class.

public MarkAsJunkResponseType();

See Also

MarkAsJunkResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MarkAsJunkType Class

For a list of all members of this type, see MarkAsJunkType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.MarkAsJunkType

public class MarkAsJunkType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MarkAsJunkType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MarkAsJunkType Members

MarkAsJunkType overview

Public Instance Constructors

MarkAsJunkType Constructor Initializes a new instance of the MarkAsJunkType class.

Public Instance Properties

IsJunk
ItemIds
MoveItem

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MarkAsJunkType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MarkAsJunkType Constructor

Initializes a new instance of the MarkAsJunkType class.

public MarkAsJunkType();

See Also

MarkAsJunkType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MarkAsJunkType Properties

The properties of the MarkAsJunkType class are listed below. For a complete list of MarkAsJunkType class members, see the MarkAsJunkType Members topic.

Public Instance Properties

IsJunk
ItemIds
MoveItem

See Also

MarkAsJunkType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsJunk Property

Aspose.Email

MarkAsJunkType.IsJunk Property

public bool IsJunk {get; set;}

Remarks

See Also

MarkAsJunkType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemIds Property

Aspose.Email

MarkAsJunkType.ItemIds Property

public BaseItemIdType[] ItemIds {get; set;}

Remarks

See Also

MarkAsJunkType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MoveItem Property

Aspose.Email

MarkAsJunkType.MoveItem Property

public bool MoveItem {get; set;}

Remarks

See Also

MarkAsJunkType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MeetingAttendeeType Enumeration

public enum MeetingAttendeeType

Remarks

Members

Member Name | Description | Value
Organizer |  | 0
Required |  | 1
Optional |  | 2
Room |  | 3
Resource |  | 4

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MeetingCancellationMessageType Class

For a list of all members of this type, see MeetingCancellationMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ItemType
Aspose.Email.Exchange.Schema.Exchange_2013.MessageType
Aspose.Email.Exchange.Schema.Exchange_2013.MeetingMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.MeetingCancellationMessageType

public class MeetingCancellationMessageType : MeetingMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MeetingCancellationMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MeetingCancellationMessageType Members

MeetingCancellationMessageType overview

Public Instance Constructors

MeetingCancellationMessageType Constructor Initializes a new instance of the MeetingCancellationMessageType class.

Public Instance Properties

ArchiveTag (inherited from ItemType)
AssociatedCalendarItemId (inherited from MeetingMessageType)
Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
BlockStatus (inherited from ItemType)
BlockStatusSpecified (inherited from ItemType)
Body (inherited from ItemType)
CalendarItemType
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DateTimeStamp (inherited from MeetingMessageType)
DateTimeStampSpecified (inherited from MeetingMessageType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
End
EndSpecified
EnhancedLocation
EntityExtractionResult (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
Flag (inherited from ItemType)
From (inherited from MessageType)
GroupingAction (inherited from ItemType)
GroupingActionSpecified (inherited from ItemType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBeenProcessed (inherited from MeetingMessageType)
HasBeenProcessedSpecified (inherited from MeetingMessageType)
HasBlockedImages (inherited from ItemType)
HasBlockedImagesSpecified (inherited from ItemType)
IconIndex (inherited from ItemType)
IconIndexSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InstanceKey (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDelegated (inherited from MeetingMessageType)
IsDelegatedSpecified (inherited from MeetingMessageType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsOrganizer (inherited from MeetingMessageType)
IsOrganizerSpecified (inherited from MeetingMessageType)
IsOutOfDate (inherited from MeetingMessageType)
IsOutOfDateSpecified (inherited from MeetingMessageType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
Location
MimeContent (inherited from ItemType)
NextPredictedAction (inherited from ItemType)
NextPredictedActionSpecified (inherited from ItemType)
NormalizedBody (inherited from ItemType)
ParentFolderId (inherited from ItemType)
PolicyTag (inherited from ItemType)
Preview (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
Recurrence
RecurrenceId (inherited from MeetingMessageType)
RecurrenceIdSpecified (inherited from MeetingMessageType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReminderNextTime (inherited from ItemType)
ReminderNextTimeSpecified (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
ResponseType (inherited from MeetingMessageType)
ResponseTypeSpecified (inherited from MeetingMessageType)
RetentionDate (inherited from ItemType)
RetentionDateSpecified (inherited from ItemType)
RightsManagementLicenseData (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
Start
StartSpecified
StoreEntryId (inherited from ItemType)
Subject (inherited from ItemType)
TextBody (inherited from ItemType)
ToRecipients (inherited from MessageType)
UID (inherited from MeetingMessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MeetingCancellationMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MeetingCancellationMessageType Constructor

Initializes a new instance of the MeetingCancellationMessageType class.

public MeetingCancellationMessageType();

See Also

MeetingCancellationMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MeetingCancellationMessageType Properties

The properties of the MeetingCancellationMessageType class are listed below. For a complete list of MeetingCancellationMessageType class members, see the MeetingCancellationMessageType Members topic.

Public Instance Properties

ArchiveTag (inherited from ItemType)
AssociatedCalendarItemId (inherited from MeetingMessageType)
Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
BlockStatus (inherited from ItemType)
BlockStatusSpecified (inherited from ItemType)
Body (inherited from ItemType)
CalendarItemType
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DateTimeStamp (inherited from MeetingMessageType)
DateTimeStampSpecified (inherited from MeetingMessageType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
End
EndSpecified
EnhancedLocation
EntityExtractionResult (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
Flag (inherited from ItemType)
From (inherited from MessageType)
GroupingAction (inherited from ItemType)
GroupingActionSpecified (inherited from ItemType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBeenProcessed (inherited from MeetingMessageType)
HasBeenProcessedSpecified (inherited from MeetingMessageType)
HasBlockedImages (inherited from ItemType)
HasBlockedImagesSpecified (inherited from ItemType)
IconIndex (inherited from ItemType)
IconIndexSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InstanceKey (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDelegated (inherited from MeetingMessageType)
IsDelegatedSpecified (inherited from MeetingMessageType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsOrganizer (inherited from MeetingMessageType)
IsOrganizerSpecified (inherited from MeetingMessageType)
IsOutOfDate (inherited from MeetingMessageType)
IsOutOfDateSpecified (inherited from MeetingMessageType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
Location
MimeContent (inherited from ItemType)
NextPredictedAction (inherited from ItemType)
NextPredictedActionSpecified (inherited from ItemType)
NormalizedBody (inherited from ItemType)
ParentFolderId (inherited from ItemType)
PolicyTag (inherited from ItemType)
Preview (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
Recurrence
RecurrenceId (inherited from MeetingMessageType)
RecurrenceIdSpecified (inherited from MeetingMessageType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReminderNextTime (inherited from ItemType)
ReminderNextTimeSpecified (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
ResponseType (inherited from MeetingMessageType)
ResponseTypeSpecified (inherited from MeetingMessageType)
RetentionDate (inherited from ItemType)
RetentionDateSpecified (inherited from ItemType)
RightsManagementLicenseData (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
Start
StartSpecified
StoreEntryId (inherited from ItemType)
Subject (inherited from ItemType)
TextBody (inherited from ItemType)
ToRecipients (inherited from MessageType)
UID (inherited from MeetingMessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

See Also

MeetingCancellationMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalendarItemType Property

Aspose.Email

MeetingCancellationMessageType.CalendarItemType Property

public string CalendarItemType {get; set;}

Remarks

See Also

MeetingCancellationMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


End Property

Aspose.Email

MeetingCancellationMessageType.End Property

public DateTime End {get; set;}

Remarks

See Also

MeetingCancellationMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EndSpecified Property

Aspose.Email

MeetingCancellationMessageType.EndSpecified Property

public bool EndSpecified {get; set;}

Remarks

See Also

MeetingCancellationMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EnhancedLocation Property

Aspose.Email

MeetingCancellationMessageType.EnhancedLocation Property

public EnhancedLocationType EnhancedLocation {get; set;}

Remarks

See Also

MeetingCancellationMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Location Property

Aspose.Email

MeetingCancellationMessageType.Location Property

public string Location {get; set;}

Remarks

See Also

MeetingCancellationMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Recurrence Property

Aspose.Email

MeetingCancellationMessageType.Recurrence Property

public RecurrenceType Recurrence {get; set;}

Remarks

See Also

MeetingCancellationMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Start Property

Aspose.Email

MeetingCancellationMessageType.Start Property

public DateTime Start {get; set;}

Remarks

See Also

MeetingCancellationMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StartSpecified Property

Aspose.Email

MeetingCancellationMessageType.StartSpecified Property

public bool StartSpecified {get; set;}

Remarks

See Also

MeetingCancellationMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MeetingMessageType Class

For a list of all members of this type, see MeetingMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ItemType
Aspose.Email.Exchange.Schema.Exchange_2013.MessageType
Aspose.Email.Exchange.Schema.Exchange_2013.MeetingMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.MeetingCancellationMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.MeetingRequestMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.MeetingResponseMessageType

public class MeetingMessageType : MessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MeetingMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MeetingMessageType Members

MeetingMessageType overview

Public Instance Constructors

MeetingMessageType Constructor Initializes a new instance of the MeetingMessageType class.

Public Instance Properties

ArchiveTag (inherited from ItemType)
AssociatedCalendarItemId
Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
BlockStatus (inherited from ItemType)
BlockStatusSpecified (inherited from ItemType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DateTimeStamp
DateTimeStampSpecified
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
EntityExtractionResult (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
Flag (inherited from ItemType)
From (inherited from MessageType)
GroupingAction (inherited from ItemType)
GroupingActionSpecified (inherited from ItemType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBeenProcessed
HasBeenProcessedSpecified
HasBlockedImages (inherited from ItemType)
HasBlockedImagesSpecified (inherited from ItemType)
IconIndex (inherited from ItemType)
IconIndexSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InstanceKey (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDelegated
IsDelegatedSpecified
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsOrganizer
IsOrganizerSpecified
IsOutOfDate
IsOutOfDateSpecified
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
NextPredictedAction (inherited from ItemType)
NextPredictedActionSpecified (inherited from ItemType)
NormalizedBody (inherited from ItemType)
ParentFolderId (inherited from ItemType)
PolicyTag (inherited from ItemType)
Preview (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
RecurrenceId
RecurrenceIdSpecified
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReminderNextTime (inherited from ItemType)
ReminderNextTimeSpecified (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
ResponseType
ResponseTypeSpecified
RetentionDate (inherited from ItemType)
RetentionDateSpecified (inherited from ItemType)
RightsManagementLicenseData (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
StoreEntryId (inherited from ItemType)
Subject (inherited from ItemType)
TextBody (inherited from ItemType)
ToRecipients (inherited from MessageType)
UID
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MeetingMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MeetingMessageType Constructor

Initializes a new instance of the MeetingMessageType class.

public MeetingMessageType();

See Also

MeetingMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MeetingMessageType Properties

The properties of the MeetingMessageType class are listed below. For a complete list of MeetingMessageType class members, see the MeetingMessageType Members topic.

Public Instance Properties

ArchiveTag (inherited from ItemType)
AssociatedCalendarItemId
Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
BlockStatus (inherited from ItemType)
BlockStatusSpecified (inherited from ItemType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DateTimeStamp
DateTimeStampSpecified
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
EntityExtractionResult (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
Flag (inherited from ItemType)
From (inherited from MessageType)
GroupingAction (inherited from ItemType)
GroupingActionSpecified (inherited from ItemType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBeenProcessed
HasBeenProcessedSpecified
HasBlockedImages (inherited from ItemType)
HasBlockedImagesSpecified (inherited from ItemType)
IconIndex (inherited from ItemType)
IconIndexSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InstanceKey (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDelegated
IsDelegatedSpecified
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsOrganizer
IsOrganizerSpecified
IsOutOfDate
IsOutOfDateSpecified
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
NextPredictedAction (inherited from ItemType)
NextPredictedActionSpecified (inherited from ItemType)
NormalizedBody (inherited from ItemType)
ParentFolderId (inherited from ItemType)
PolicyTag (inherited from ItemType)
Preview (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
RecurrenceId
RecurrenceIdSpecified
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReminderNextTime (inherited from ItemType)
ReminderNextTimeSpecified (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
ResponseType
ResponseTypeSpecified
RetentionDate (inherited from ItemType)
RetentionDateSpecified (inherited from ItemType)
RightsManagementLicenseData (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
StoreEntryId (inherited from ItemType)
Subject (inherited from ItemType)
TextBody (inherited from ItemType)
ToRecipients (inherited from MessageType)
UID
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

See Also

MeetingMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AssociatedCalendarItemId Property

Aspose.Email

MeetingMessageType.AssociatedCalendarItemId Property

public ItemIdType AssociatedCalendarItemId {get; set;}

Remarks

See Also

MeetingMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DateTimeStamp Property

Aspose.Email

MeetingMessageType.DateTimeStamp Property

public DateTime DateTimeStamp {get; set;}

Remarks

See Also

MeetingMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DateTimeStampSpecified Property

Aspose.Email

MeetingMessageType.DateTimeStampSpecified Property

public bool DateTimeStampSpecified {get; set;}

Remarks

See Also

MeetingMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


HasBeenProcessed Property

Aspose.Email

MeetingMessageType.HasBeenProcessed Property

public bool HasBeenProcessed {get; set;}

Remarks

See Also

MeetingMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


HasBeenProcessedSpecified Property

Aspose.Email

MeetingMessageType.HasBeenProcessedSpecified Property

public bool HasBeenProcessedSpecified {get; set;}

Remarks

See Also

MeetingMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsDelegated Property

Aspose.Email

MeetingMessageType.IsDelegated Property

public bool IsDelegated {get; set;}

Remarks

See Also

MeetingMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsDelegatedSpecified Property

Aspose.Email

MeetingMessageType.IsDelegatedSpecified Property

public bool IsDelegatedSpecified {get; set;}

Remarks

See Also

MeetingMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsOrganizer Property

Aspose.Email

MeetingMessageType.IsOrganizer Property

public bool IsOrganizer {get; set;}

Remarks

See Also

MeetingMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsOrganizerSpecified Property

Aspose.Email

MeetingMessageType.IsOrganizerSpecified Property

public bool IsOrganizerSpecified {get; set;}

Remarks

See Also

MeetingMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsOutOfDate Property

Aspose.Email

MeetingMessageType.IsOutOfDate Property

public bool IsOutOfDate {get; set;}

Remarks

See Also

MeetingMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsOutOfDateSpecified Property

Aspose.Email

MeetingMessageType.IsOutOfDateSpecified Property

public bool IsOutOfDateSpecified {get; set;}

Remarks

See Also

MeetingMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecurrenceId Property

Aspose.Email

MeetingMessageType.RecurrenceId Property

public DateTime RecurrenceId {get; set;}

Remarks

See Also

MeetingMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecurrenceIdSpecified Property

Aspose.Email

MeetingMessageType.RecurrenceIdSpecified Property

public bool RecurrenceIdSpecified {get; set;}

Remarks

See Also

MeetingMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResponseType Property

Aspose.Email

MeetingMessageType.ResponseType Property

public ResponseTypeType ResponseType {get; set;}

Remarks

See Also

MeetingMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResponseTypeSpecified Property

Aspose.Email

MeetingMessageType.ResponseTypeSpecified Property

public bool ResponseTypeSpecified {get; set;}

Remarks

See Also

MeetingMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UID Property

Aspose.Email

MeetingMessageType.UID Property

public string UID {get; set;}

Remarks

See Also

MeetingMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MeetingRequestMessageType Class

For a list of all members of this type, see MeetingRequestMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ItemType
Aspose.Email.Exchange.Schema.Exchange_2013.MessageType
Aspose.Email.Exchange.Schema.Exchange_2013.MeetingMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.MeetingRequestMessageType

public class MeetingRequestMessageType : MeetingMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MeetingRequestMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MeetingRequestMessageType Members

MeetingRequestMessageType overview

Public Instance Constructors

MeetingRequestMessageType Constructor Initializes a new instance of the MeetingRequestMessageType class.

Public Instance Properties

AdjacentMeetingCount
AdjacentMeetingCountSpecified
AdjacentMeetings
AllowNewTimeProposal
AllowNewTimeProposalSpecified
AppointmentReplyTime
AppointmentReplyTimeSpecified
AppointmentSequenceNumber
AppointmentSequenceNumberSpecified
AppointmentState
AppointmentStateSpecified
ArchiveTag (inherited from ItemType)
AssociatedCalendarItemId (inherited from MeetingMessageType)
Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
BlockStatus (inherited from ItemType)
BlockStatusSpecified (inherited from ItemType)
Body (inherited from ItemType)
CalendarItemType
CalendarItemTypeSpecified
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ChangeHighlights
ConferenceType
ConferenceTypeSpecified
ConflictingMeetingCount
ConflictingMeetingCountSpecified
ConflictingMeetings
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DateTimeStamp (inherited from MeetingMessageType)
DateTimeStampSpecified (inherited from MeetingMessageType)
DeletedOccurrences
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
Duration
EffectiveRights (inherited from ItemType)
End
EndSpecified
EndTimeZone
EndTimeZoneId
EndWallClock
EndWallClockSpecified
EnhancedLocation
EntityExtractionResult (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
FirstOccurrence
Flag (inherited from ItemType)
From (inherited from MessageType)
GroupingAction (inherited from ItemType)
GroupingActionSpecified (inherited from ItemType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBeenProcessed (inherited from MeetingMessageType)
HasBeenProcessedSpecified (inherited from MeetingMessageType)
HasBlockedImages (inherited from ItemType)
HasBlockedImagesSpecified (inherited from ItemType)
IconIndex (inherited from ItemType)
IconIndexSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InstanceKey (inherited from ItemType)
IntendedFreeBusyStatus
IntendedFreeBusyStatusSpecified
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAllDayEvent
IsAllDayEventSpecified
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsCancelled
IsCancelledSpecified
IsDelegated (inherited from MeetingMessageType)
IsDelegatedSpecified (inherited from MeetingMessageType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsMeeting
IsMeetingSpecified
IsOnlineMeeting
IsOnlineMeetingSpecified
IsOrganizer (inherited from MeetingMessageType)
IsOrganizerSpecified (inherited from MeetingMessageType)
IsOutOfDate (inherited from MeetingMessageType)
IsOutOfDateSpecified (inherited from MeetingMessageType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsRecurring
IsRecurringSpecified
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
LastOccurrence
LegacyFreeBusyStatus
LegacyFreeBusyStatusSpecified
Location
MeetingRequestType
MeetingRequestTypeSpecified
MeetingRequestWasSent
MeetingRequestWasSentSpecified
MeetingTimeZone
MeetingWorkspaceUrl
MimeContent (inherited from ItemType)
ModifiedOccurrences
MyResponseType
MyResponseTypeSpecified
NetShowUrl
NextPredictedAction (inherited from ItemType)
NextPredictedActionSpecified (inherited from ItemType)
NormalizedBody (inherited from ItemType)
OptionalAttendees
Organizer
OriginalStart
OriginalStartSpecified
ParentFolderId (inherited from ItemType)
PolicyTag (inherited from ItemType)
Preview (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
Recurrence
RecurrenceId (inherited from MeetingMessageType)
RecurrenceIdSpecified (inherited from MeetingMessageType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReminderNextTime (inherited from ItemType)
ReminderNextTimeSpecified (inherited from ItemType)
ReplyTo (inherited from MessageType)
RequiredAttendees
Resources
ResponseObjects (inherited from ItemType)
ResponseType (inherited from MeetingMessageType)
ResponseTypeSpecified (inherited from MeetingMessageType)
RetentionDate (inherited from ItemType)
RetentionDateSpecified (inherited from ItemType)
RightsManagementLicenseData (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
Start
StartSpecified
StartTimeZone
StartTimeZoneId
StartWallClock
StartWallClockSpecified
StoreEntryId (inherited from ItemType)
Subject (inherited from ItemType)
TextBody (inherited from ItemType)
TimeZone
ToRecipients (inherited from MessageType)
UID (inherited from MeetingMessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)
When

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MeetingRequestMessageType Constructor

Initializes a new instance of the MeetingRequestMessageType class.

public MeetingRequestMessageType();

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MeetingRequestMessageType Properties

The properties of the MeetingRequestMessageType class are listed below. For a complete list of MeetingRequestMessageType class members, see the MeetingRequestMessageType Members topic.

Public Instance Properties

AdjacentMeetingCount
AdjacentMeetingCountSpecified
AdjacentMeetings
AllowNewTimeProposal
AllowNewTimeProposalSpecified
AppointmentReplyTime
AppointmentReplyTimeSpecified
AppointmentSequenceNumber
AppointmentSequenceNumberSpecified
AppointmentState
AppointmentStateSpecified
ArchiveTag (inherited from ItemType)
AssociatedCalendarItemId (inherited from MeetingMessageType)
Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
BlockStatus (inherited from ItemType)
BlockStatusSpecified (inherited from ItemType)
Body (inherited from ItemType)
CalendarItemType
CalendarItemTypeSpecified
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ChangeHighlights
ConferenceType
ConferenceTypeSpecified
ConflictingMeetingCount
ConflictingMeetingCountSpecified
ConflictingMeetings
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DateTimeStamp (inherited from MeetingMessageType)
DateTimeStampSpecified (inherited from MeetingMessageType)
DeletedOccurrences
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
Duration
EffectiveRights (inherited from ItemType)
End
EndSpecified
EndTimeZone
EndTimeZoneId
EndWallClock
EndWallClockSpecified
EnhancedLocation
EntityExtractionResult (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
FirstOccurrence
Flag (inherited from ItemType)
From (inherited from MessageType)
GroupingAction (inherited from ItemType)
GroupingActionSpecified (inherited from ItemType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBeenProcessed (inherited from MeetingMessageType)
HasBeenProcessedSpecified (inherited from MeetingMessageType)
HasBlockedImages (inherited from ItemType)
HasBlockedImagesSpecified (inherited from ItemType)
IconIndex (inherited from ItemType)
IconIndexSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InstanceKey (inherited from ItemType)
IntendedFreeBusyStatus
IntendedFreeBusyStatusSpecified
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAllDayEvent
IsAllDayEventSpecified
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsCancelled
IsCancelledSpecified
IsDelegated (inherited from MeetingMessageType)
IsDelegatedSpecified (inherited from MeetingMessageType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsMeeting
IsMeetingSpecified
IsOnlineMeeting
IsOnlineMeetingSpecified
IsOrganizer (inherited from MeetingMessageType)
IsOrganizerSpecified (inherited from MeetingMessageType)
IsOutOfDate (inherited from MeetingMessageType)
IsOutOfDateSpecified (inherited from MeetingMessageType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsRecurring
IsRecurringSpecified
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
LastOccurrence
LegacyFreeBusyStatus
LegacyFreeBusyStatusSpecified
Location
MeetingRequestType
MeetingRequestTypeSpecified
MeetingRequestWasSent
MeetingRequestWasSentSpecified
MeetingTimeZone
MeetingWorkspaceUrl
MimeContent (inherited from ItemType)
ModifiedOccurrences
MyResponseType
MyResponseTypeSpecified
NetShowUrl
NextPredictedAction (inherited from ItemType)
NextPredictedActionSpecified (inherited from ItemType)
NormalizedBody (inherited from ItemType)
OptionalAttendees
Organizer
OriginalStart
OriginalStartSpecified
ParentFolderId (inherited from ItemType)
PolicyTag (inherited from ItemType)
Preview (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
Recurrence
RecurrenceId (inherited from MeetingMessageType)
RecurrenceIdSpecified (inherited from MeetingMessageType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReminderNextTime (inherited from ItemType)
ReminderNextTimeSpecified (inherited from ItemType)
ReplyTo (inherited from MessageType)
RequiredAttendees
Resources
ResponseObjects (inherited from ItemType)
ResponseType (inherited from MeetingMessageType)
ResponseTypeSpecified (inherited from MeetingMessageType)
RetentionDate (inherited from ItemType)
RetentionDateSpecified (inherited from ItemType)
RightsManagementLicenseData (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
Start
StartSpecified
StartTimeZone
StartTimeZoneId
StartWallClock
StartWallClockSpecified
StoreEntryId (inherited from ItemType)
Subject (inherited from ItemType)
TextBody (inherited from ItemType)
TimeZone
ToRecipients (inherited from MessageType)
UID (inherited from MeetingMessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)
When

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AdjacentMeetingCount Property

Aspose.Email

MeetingRequestMessageType.AdjacentMeetingCount Property

public int AdjacentMeetingCount {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AdjacentMeetingCountSpecified Property

Aspose.Email

MeetingRequestMessageType.AdjacentMeetingCountSpecified Property

public bool AdjacentMeetingCountSpecified {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AdjacentMeetings Property

Aspose.Email

MeetingRequestMessageType.AdjacentMeetings Property

public NonEmptyArrayOfAllItemsType AdjacentMeetings {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AllowNewTimeProposal Property

Aspose.Email

MeetingRequestMessageType.AllowNewTimeProposal Property

public bool AllowNewTimeProposal {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AllowNewTimeProposalSpecified Property

Aspose.Email

MeetingRequestMessageType.AllowNewTimeProposalSpecified Property

public bool AllowNewTimeProposalSpecified {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AppointmentReplyTime Property

Aspose.Email

MeetingRequestMessageType.AppointmentReplyTime Property

public DateTime AppointmentReplyTime {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AppointmentReplyTimeSpecified Property

Aspose.Email

MeetingRequestMessageType.AppointmentReplyTimeSpecified Property

public bool AppointmentReplyTimeSpecified {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AppointmentSequenceNumber Property

Aspose.Email

MeetingRequestMessageType.AppointmentSequenceNumber Property

public int AppointmentSequenceNumber {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AppointmentSequenceNumberSpecified Property

Aspose.Email

MeetingRequestMessageType.AppointmentSequenceNumberSpecified Property

public bool AppointmentSequenceNumberSpecified {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AppointmentState Property

Aspose.Email

MeetingRequestMessageType.AppointmentState Property

public int AppointmentState {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AppointmentStateSpecified Property

Aspose.Email

MeetingRequestMessageType.AppointmentStateSpecified Property

public bool AppointmentStateSpecified {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalendarItemType Property

Aspose.Email

MeetingRequestMessageType.CalendarItemType Property

public CalendarItemTypeType CalendarItemType {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalendarItemTypeSpecified Property

Aspose.Email

MeetingRequestMessageType.CalendarItemTypeSpecified Property

public bool CalendarItemTypeSpecified {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ChangeHighlights Property

Aspose.Email

MeetingRequestMessageType.ChangeHighlights Property

public ChangeHighlightsType ChangeHighlights {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConferenceType Property

Aspose.Email

MeetingRequestMessageType.ConferenceType Property

public int ConferenceType {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConferenceTypeSpecified Property

Aspose.Email

MeetingRequestMessageType.ConferenceTypeSpecified Property

public bool ConferenceTypeSpecified {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConflictingMeetingCount Property

Aspose.Email

MeetingRequestMessageType.ConflictingMeetingCount Property

public int ConflictingMeetingCount {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConflictingMeetingCountSpecified Property

Aspose.Email

MeetingRequestMessageType.ConflictingMeetingCountSpecified Property

public bool ConflictingMeetingCountSpecified {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConflictingMeetings Property

Aspose.Email

MeetingRequestMessageType.ConflictingMeetings Property

public NonEmptyArrayOfAllItemsType ConflictingMeetings {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeletedOccurrences Property

Aspose.Email

MeetingRequestMessageType.DeletedOccurrences Property

public DeletedOccurrenceInfoType[] DeletedOccurrences {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Duration Property

Aspose.Email

MeetingRequestMessageType.Duration Property

public string Duration {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


End Property

Aspose.Email

MeetingRequestMessageType.End Property

public DateTime End {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EndSpecified Property

Aspose.Email

MeetingRequestMessageType.EndSpecified Property

public bool EndSpecified {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EndTimeZone Property

Aspose.Email

MeetingRequestMessageType.EndTimeZone Property

public TimeZoneDefinitionType EndTimeZone {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EndTimeZoneId Property

Aspose.Email

MeetingRequestMessageType.EndTimeZoneId Property

public string EndTimeZoneId {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EndWallClock Property

Aspose.Email

MeetingRequestMessageType.EndWallClock Property

public DateTime EndWallClock {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EndWallClockSpecified Property

Aspose.Email

MeetingRequestMessageType.EndWallClockSpecified Property

public bool EndWallClockSpecified {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EnhancedLocation Property

Aspose.Email

MeetingRequestMessageType.EnhancedLocation Property

public EnhancedLocationType EnhancedLocation {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FirstOccurrence Property

Aspose.Email

MeetingRequestMessageType.FirstOccurrence Property

public OccurrenceInfoType FirstOccurrence {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IntendedFreeBusyStatus Property

Aspose.Email

MeetingRequestMessageType.IntendedFreeBusyStatus Property

public LegacyFreeBusyType IntendedFreeBusyStatus {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IntendedFreeBusyStatusSpecified Property

Aspose.Email

MeetingRequestMessageType.IntendedFreeBusyStatusSpecified Property

public bool IntendedFreeBusyStatusSpecified {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsAllDayEvent Property

Aspose.Email

MeetingRequestMessageType.IsAllDayEvent Property

public bool IsAllDayEvent {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsAllDayEventSpecified Property

Aspose.Email

MeetingRequestMessageType.IsAllDayEventSpecified Property

public bool IsAllDayEventSpecified {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsCancelled Property

Aspose.Email

MeetingRequestMessageType.IsCancelled Property

public bool IsCancelled {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsCancelledSpecified Property

Aspose.Email

MeetingRequestMessageType.IsCancelledSpecified Property

public bool IsCancelledSpecified {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsMeeting Property

Aspose.Email

MeetingRequestMessageType.IsMeeting Property

public bool IsMeeting {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsMeetingSpecified Property

Aspose.Email

MeetingRequestMessageType.IsMeetingSpecified Property

public bool IsMeetingSpecified {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsOnlineMeeting Property

Aspose.Email

MeetingRequestMessageType.IsOnlineMeeting Property

public bool IsOnlineMeeting {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsOnlineMeetingSpecified Property

Aspose.Email

MeetingRequestMessageType.IsOnlineMeetingSpecified Property

public bool IsOnlineMeetingSpecified {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsRecurring Property

Aspose.Email

MeetingRequestMessageType.IsRecurring Property

public bool IsRecurring {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsRecurringSpecified Property

Aspose.Email

MeetingRequestMessageType.IsRecurringSpecified Property

public bool IsRecurringSpecified {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


LastOccurrence Property

Aspose.Email

MeetingRequestMessageType.LastOccurrence Property

public OccurrenceInfoType LastOccurrence {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


LegacyFreeBusyStatus Property

Aspose.Email

MeetingRequestMessageType.LegacyFreeBusyStatus Property

public LegacyFreeBusyType LegacyFreeBusyStatus {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


LegacyFreeBusyStatusSpecified Property

Aspose.Email

MeetingRequestMessageType.LegacyFreeBusyStatusSpecified Property

public bool LegacyFreeBusyStatusSpecified {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Location Property

Aspose.Email

MeetingRequestMessageType.Location Property

public string Location {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MeetingRequestType Property

Aspose.Email

MeetingRequestMessageType.MeetingRequestType Property

public MeetingRequestTypeType MeetingRequestType {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MeetingRequestTypeSpecified Property

Aspose.Email

MeetingRequestMessageType.MeetingRequestTypeSpecified Property

public bool MeetingRequestTypeSpecified {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MeetingRequestWasSent Property

Aspose.Email

MeetingRequestMessageType.MeetingRequestWasSent Property

public bool MeetingRequestWasSent {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MeetingRequestWasSentSpecified Property

Aspose.Email

MeetingRequestMessageType.MeetingRequestWasSentSpecified Property

public bool MeetingRequestWasSentSpecified {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MeetingTimeZone Property

Aspose.Email

MeetingRequestMessageType.MeetingTimeZone Property

public TimeZoneType MeetingTimeZone {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MeetingWorkspaceUrl Property

Aspose.Email

MeetingRequestMessageType.MeetingWorkspaceUrl Property

public string MeetingWorkspaceUrl {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ModifiedOccurrences Property

Aspose.Email

MeetingRequestMessageType.ModifiedOccurrences Property

public OccurrenceInfoType[] ModifiedOccurrences {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MyResponseType Property

Aspose.Email

MeetingRequestMessageType.MyResponseType Property

public ResponseTypeType MyResponseType {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MyResponseTypeSpecified Property

Aspose.Email

MeetingRequestMessageType.MyResponseTypeSpecified Property

public bool MyResponseTypeSpecified {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NetShowUrl Property

Aspose.Email

MeetingRequestMessageType.NetShowUrl Property

public string NetShowUrl {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OptionalAttendees Property

Aspose.Email

MeetingRequestMessageType.OptionalAttendees Property

public AttendeeType[] OptionalAttendees {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Organizer Property

Aspose.Email

MeetingRequestMessageType.Organizer Property

public SingleRecipientType Organizer {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OriginalStart Property

Aspose.Email

MeetingRequestMessageType.OriginalStart Property

public DateTime OriginalStart {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OriginalStartSpecified Property

Aspose.Email

MeetingRequestMessageType.OriginalStartSpecified Property

public bool OriginalStartSpecified {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Recurrence Property

Aspose.Email

MeetingRequestMessageType.Recurrence Property

public RecurrenceType Recurrence {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RequiredAttendees Property

Aspose.Email

MeetingRequestMessageType.RequiredAttendees Property

public AttendeeType[] RequiredAttendees {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Resources Property

Aspose.Email

MeetingRequestMessageType.Resources Property

public AttendeeType[] Resources {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Start Property

Aspose.Email

MeetingRequestMessageType.Start Property

public DateTime Start {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StartSpecified Property

Aspose.Email

MeetingRequestMessageType.StartSpecified Property

public bool StartSpecified {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StartTimeZone Property

Aspose.Email

MeetingRequestMessageType.StartTimeZone Property

public TimeZoneDefinitionType StartTimeZone {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StartTimeZoneId Property

Aspose.Email

MeetingRequestMessageType.StartTimeZoneId Property

public string StartTimeZoneId {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StartWallClock Property

Aspose.Email

MeetingRequestMessageType.StartWallClock Property

public DateTime StartWallClock {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StartWallClockSpecified Property

Aspose.Email

MeetingRequestMessageType.StartWallClockSpecified Property

public bool StartWallClockSpecified {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TimeZone Property

Aspose.Email

MeetingRequestMessageType.TimeZone Property

public string TimeZone {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


When Property

Aspose.Email

MeetingRequestMessageType.When Property

public string When {get; set;}

Remarks

See Also

MeetingRequestMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MeetingRequestTypeType Enumeration

public enum MeetingRequestTypeType

Remarks

Members

Member Name | Description | Value
None |  | 0
FullUpdate |  | 1
InformationalUpdate |  | 2
NewMeetingRequest |  | 3
Outdated |  | 4
SilentUpdate |  | 5
PrincipalWantsCopy |  | 6

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MeetingResponseMessageType Class

For a list of all members of this type, see MeetingResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ItemType
Aspose.Email.Exchange.Schema.Exchange_2013.MessageType
Aspose.Email.Exchange.Schema.Exchange_2013.MeetingMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.MeetingResponseMessageType

public class MeetingResponseMessageType : MeetingMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MeetingResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MeetingResponseMessageType Members

MeetingResponseMessageType overview

Public Instance Constructors

MeetingResponseMessageType Constructor Initializes a new instance of the MeetingResponseMessageType class.

Public Instance Properties

ArchiveTag (inherited from ItemType)
AssociatedCalendarItemId (inherited from MeetingMessageType)
Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
BlockStatus (inherited from ItemType)
BlockStatusSpecified (inherited from ItemType)
Body (inherited from ItemType)
CalendarItemType
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DateTimeStamp (inherited from MeetingMessageType)
DateTimeStampSpecified (inherited from MeetingMessageType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
End
EndSpecified
EnhancedLocation
EntityExtractionResult (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
Flag (inherited from ItemType)
From (inherited from MessageType)
GroupingAction (inherited from ItemType)
GroupingActionSpecified (inherited from ItemType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBeenProcessed (inherited from MeetingMessageType)
HasBeenProcessedSpecified (inherited from MeetingMessageType)
HasBlockedImages (inherited from ItemType)
HasBlockedImagesSpecified (inherited from ItemType)
IconIndex (inherited from ItemType)
IconIndexSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InstanceKey (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDelegated (inherited from MeetingMessageType)
IsDelegatedSpecified (inherited from MeetingMessageType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsOrganizer (inherited from MeetingMessageType)
IsOrganizerSpecified (inherited from MeetingMessageType)
IsOutOfDate (inherited from MeetingMessageType)
IsOutOfDateSpecified (inherited from MeetingMessageType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
Location
MimeContent (inherited from ItemType)
NextPredictedAction (inherited from ItemType)
NextPredictedActionSpecified (inherited from ItemType)
NormalizedBody (inherited from ItemType)
ParentFolderId (inherited from ItemType)
PolicyTag (inherited from ItemType)
Preview (inherited from ItemType)
ProposedEnd
ProposedEndSpecified
ProposedStart
ProposedStartSpecified
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
Recurrence
RecurrenceId (inherited from MeetingMessageType)
RecurrenceIdSpecified (inherited from MeetingMessageType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReminderNextTime (inherited from ItemType)
ReminderNextTimeSpecified (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
ResponseType (inherited from MeetingMessageType)
ResponseTypeSpecified (inherited from MeetingMessageType)
RetentionDate (inherited from ItemType)
RetentionDateSpecified (inherited from ItemType)
RightsManagementLicenseData (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
Start
StartSpecified
StoreEntryId (inherited from ItemType)
Subject (inherited from ItemType)
TextBody (inherited from ItemType)
ToRecipients (inherited from MessageType)
UID (inherited from MeetingMessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MeetingResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MeetingResponseMessageType Constructor

Initializes a new instance of the MeetingResponseMessageType class.

public MeetingResponseMessageType();

See Also

MeetingResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MeetingResponseMessageType Properties

The properties of the MeetingResponseMessageType class are listed below. For a complete list of MeetingResponseMessageType class members, see the MeetingResponseMessageType Members topic.

Public Instance Properties

ArchiveTag (inherited from ItemType)
AssociatedCalendarItemId (inherited from MeetingMessageType)
Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
BlockStatus (inherited from ItemType)
BlockStatusSpecified (inherited from ItemType)
Body (inherited from ItemType)
CalendarItemType
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DateTimeStamp (inherited from MeetingMessageType)
DateTimeStampSpecified (inherited from MeetingMessageType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
End
EndSpecified
EnhancedLocation
EntityExtractionResult (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
Flag (inherited from ItemType)
From (inherited from MessageType)
GroupingAction (inherited from ItemType)
GroupingActionSpecified (inherited from ItemType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBeenProcessed (inherited from MeetingMessageType)
HasBeenProcessedSpecified (inherited from MeetingMessageType)
HasBlockedImages (inherited from ItemType)
HasBlockedImagesSpecified (inherited from ItemType)
IconIndex (inherited from ItemType)
IconIndexSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InstanceKey (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDelegated (inherited from MeetingMessageType)
IsDelegatedSpecified (inherited from MeetingMessageType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsOrganizer (inherited from MeetingMessageType)
IsOrganizerSpecified (inherited from MeetingMessageType)
IsOutOfDate (inherited from MeetingMessageType)
IsOutOfDateSpecified (inherited from MeetingMessageType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
Location
MimeContent (inherited from ItemType)
NextPredictedAction (inherited from ItemType)
NextPredictedActionSpecified (inherited from ItemType)
NormalizedBody (inherited from ItemType)
ParentFolderId (inherited from ItemType)
PolicyTag (inherited from ItemType)
Preview (inherited from ItemType)
ProposedEnd
ProposedEndSpecified
ProposedStart
ProposedStartSpecified
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
Recurrence
RecurrenceId (inherited from MeetingMessageType)
RecurrenceIdSpecified (inherited from MeetingMessageType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReminderNextTime (inherited from ItemType)
ReminderNextTimeSpecified (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
ResponseType (inherited from MeetingMessageType)
ResponseTypeSpecified (inherited from MeetingMessageType)
RetentionDate (inherited from ItemType)
RetentionDateSpecified (inherited from ItemType)
RightsManagementLicenseData (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
Start
StartSpecified
StoreEntryId (inherited from ItemType)
Subject (inherited from ItemType)
TextBody (inherited from ItemType)
ToRecipients (inherited from MessageType)
UID (inherited from MeetingMessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

See Also

MeetingResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CalendarItemType Property

Aspose.Email

MeetingResponseMessageType.CalendarItemType Property

public string CalendarItemType {get; set;}

Remarks

See Also

MeetingResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


End Property

Aspose.Email

MeetingResponseMessageType.End Property

public DateTime End {get; set;}

Remarks

See Also

MeetingResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EndSpecified Property

Aspose.Email

MeetingResponseMessageType.EndSpecified Property

public bool EndSpecified {get; set;}

Remarks

See Also

MeetingResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EnhancedLocation Property

Aspose.Email

MeetingResponseMessageType.EnhancedLocation Property

public EnhancedLocationType EnhancedLocation {get; set;}

Remarks

See Also

MeetingResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Location Property

Aspose.Email

MeetingResponseMessageType.Location Property

public string Location {get; set;}

Remarks

See Also

MeetingResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ProposedEnd Property

Aspose.Email

MeetingResponseMessageType.ProposedEnd Property

public DateTime ProposedEnd {get; set;}

Remarks

See Also

MeetingResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ProposedEndSpecified Property

Aspose.Email

MeetingResponseMessageType.ProposedEndSpecified Property

public bool ProposedEndSpecified {get; set;}

Remarks

See Also

MeetingResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ProposedStart Property

Aspose.Email

MeetingResponseMessageType.ProposedStart Property

public DateTime ProposedStart {get; set;}

Remarks

See Also

MeetingResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ProposedStartSpecified Property

Aspose.Email

MeetingResponseMessageType.ProposedStartSpecified Property

public bool ProposedStartSpecified {get; set;}

Remarks

See Also

MeetingResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Recurrence Property

Aspose.Email

MeetingResponseMessageType.Recurrence Property

public RecurrenceType Recurrence {get; set;}

Remarks

See Also

MeetingResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Start Property

Aspose.Email

MeetingResponseMessageType.Start Property

public DateTime Start {get; set;}

Remarks

See Also

MeetingResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StartSpecified Property

Aspose.Email

MeetingResponseMessageType.StartSpecified Property

public bool StartSpecified {get; set;}

Remarks

See Also

MeetingResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MeetingSuggestionType Class

For a list of all members of this type, see MeetingSuggestionType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.EntityType
Aspose.Email.Exchange.Schema.Exchange_2013.MeetingSuggestionType

public class MeetingSuggestionType : EntityType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MeetingSuggestionType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MeetingSuggestionType Members

MeetingSuggestionType overview

Public Instance Constructors

MeetingSuggestionType Constructor Initializes a new instance of the MeetingSuggestionType class.

Public Instance Properties

Attendees
EndTime
EndTimeSpecified
Location
MeetingString
Position (inherited from EntityType)
StartTime
StartTimeSpecified
Subject

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MeetingSuggestionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MeetingSuggestionType Constructor

Initializes a new instance of the MeetingSuggestionType class.

public MeetingSuggestionType();

See Also

MeetingSuggestionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MeetingSuggestionType Properties

The properties of the MeetingSuggestionType class are listed below. For a complete list of MeetingSuggestionType class members, see the MeetingSuggestionType Members topic.

Public Instance Properties

Attendees
EndTime
EndTimeSpecified
Location
MeetingString
Position (inherited from EntityType)
StartTime
StartTimeSpecified
Subject

See Also

MeetingSuggestionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Attendees Property

Aspose.Email

MeetingSuggestionType.Attendees Property

public EmailUserType[] Attendees {get; set;}

Remarks

See Also

MeetingSuggestionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EndTime Property

Aspose.Email

MeetingSuggestionType.EndTime Property

public DateTime EndTime {get; set;}

Remarks

See Also

MeetingSuggestionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EndTimeSpecified Property

Aspose.Email

MeetingSuggestionType.EndTimeSpecified Property

public bool EndTimeSpecified {get; set;}

Remarks

See Also

MeetingSuggestionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Location Property

Aspose.Email

MeetingSuggestionType.Location Property

public string Location {get; set;}

Remarks

See Also

MeetingSuggestionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MeetingString Property

Aspose.Email

MeetingSuggestionType.MeetingString Property

public string MeetingString {get; set;}

Remarks

See Also

MeetingSuggestionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StartTime Property

Aspose.Email

MeetingSuggestionType.StartTime Property

public DateTime StartTime {get; set;}

Remarks

See Also

MeetingSuggestionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StartTimeSpecified Property

Aspose.Email

MeetingSuggestionType.StartTimeSpecified Property

public bool StartTimeSpecified {get; set;}

Remarks

See Also

MeetingSuggestionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Subject Property

Aspose.Email

MeetingSuggestionType.Subject Property

public string Subject {get; set;}

Remarks

See Also

MeetingSuggestionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MemberStatusType Enumeration

public enum MemberStatusType

Remarks

Members

Member Name | Description | Value
Unrecognized |  | 0
Normal |  | 1
Demoted |  | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MemberType Class

For a list of all members of this type, see MemberType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.MemberType

public class MemberType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MemberType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MemberType Members

MemberType overview

Public Instance Constructors

MemberType Constructor Initializes a new instance of the MemberType class.

Public Instance Properties

Key
Mailbox
Status
StatusSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MemberType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MemberType Constructor

Initializes a new instance of the MemberType class.

public MemberType();

See Also

MemberType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MemberType Properties

The properties of the MemberType class are listed below. For a complete list of MemberType class members, see the MemberType Members topic.

Public Instance Properties

Key
Mailbox
Status
StatusSpecified

See Also

MemberType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Key Property

Aspose.Email

MemberType.Key Property

public string Key {get; set;}

Remarks

See Also

MemberType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Mailbox Property

Aspose.Email

MemberType.Mailbox Property

public EmailAddressType Mailbox {get; set;}

Remarks

See Also

MemberType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Status Property

Aspose.Email

MemberType.Status Property

public MemberStatusType Status {get; set;}

Remarks

See Also

MemberType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StatusSpecified Property

Aspose.Email

MemberType.StatusSpecified Property

public bool StatusSpecified {get; set;}

Remarks

See Also

MemberType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MessageDispositionType Enumeration

public enum MessageDispositionType

Remarks

Members

Member Name | Description | Value
SaveOnly |  | 0
SendOnly |  | 1
SendAndSaveCopy |  | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MessageTrackingReportTemplateType Enumeration

public enum MessageTrackingReportTemplateType

Remarks

Members

Member Name | Description | Value
Summary |  | 0
RecipientPath |  | 1

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MessageTrackingReportType Class

For a list of all members of this type, see MessageTrackingReportType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.MessageTrackingReportType

public class MessageTrackingReportType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MessageTrackingReportType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MessageTrackingReportType Members

MessageTrackingReportType overview

Public Instance Constructors

MessageTrackingReportType Constructor Initializes a new instance of the MessageTrackingReportType class.

Public Instance Properties

OriginalRecipients
Properties
PurportedSender
RecipientTrackingEvents
Sender
Subject
SubmitTime
SubmitTimeSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MessageTrackingReportType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MessageTrackingReportType Constructor

Initializes a new instance of the MessageTrackingReportType class.

public MessageTrackingReportType();

See Also

MessageTrackingReportType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MessageTrackingReportType Properties

The properties of the MessageTrackingReportType class are listed below. For a complete list of MessageTrackingReportType class members, see the MessageTrackingReportType Members topic.

Public Instance Properties

OriginalRecipients
Properties
PurportedSender
RecipientTrackingEvents
Sender
Subject
SubmitTime
SubmitTimeSpecified

See Also

MessageTrackingReportType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OriginalRecipients Property

Aspose.Email

MessageTrackingReportType.OriginalRecipients Property

public EmailAddressType[] OriginalRecipients {get; set;}

Remarks

See Also

MessageTrackingReportType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Properties Property

Aspose.Email

MessageTrackingReportType.Properties Property

public TrackingPropertyType[] Properties {get; set;}

Remarks

See Also

MessageTrackingReportType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PurportedSender Property

Aspose.Email

MessageTrackingReportType.PurportedSender Property

public EmailAddressType PurportedSender {get; set;}

Remarks

See Also

MessageTrackingReportType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecipientTrackingEvents Property

Aspose.Email

MessageTrackingReportType.RecipientTrackingEvents Property

public RecipientTrackingEventType[] RecipientTrackingEvents {get; set;}

Remarks

See Also

MessageTrackingReportType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Sender Property

Aspose.Email

MessageTrackingReportType.Sender Property

public EmailAddressType Sender {get; set;}

Remarks

See Also

MessageTrackingReportType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Subject Property

Aspose.Email

MessageTrackingReportType.Subject Property

public string Subject {get; set;}

Remarks

See Also

MessageTrackingReportType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SubmitTime Property

Aspose.Email

MessageTrackingReportType.SubmitTime Property

public DateTime SubmitTime {get; set;}

Remarks

See Also

MessageTrackingReportType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SubmitTimeSpecified Property

Aspose.Email

MessageTrackingReportType.SubmitTimeSpecified Property

public bool SubmitTimeSpecified {get; set;}

Remarks

See Also

MessageTrackingReportType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MessageType Class

For a list of all members of this type, see MessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ItemType
Aspose.Email.Exchange.Schema.Exchange_2013.MessageType
Aspose.Email.Exchange.Schema.Exchange_2013.MeetingMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseObjectCoreType

public class MessageType : ItemType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MessageType Members

MessageType overview

Public Instance Constructors

MessageType Constructor Initializes a new instance of the MessageType class.

Public Instance Properties

ArchiveTag (inherited from ItemType)
Attachments (inherited from ItemType)
BccRecipients
BlockStatus (inherited from ItemType)
BlockStatusSpecified (inherited from ItemType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients
ConversationId (inherited from ItemType)
ConversationIndex
ConversationTopic
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
EntityExtractionResult (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
Flag (inherited from ItemType)
From
GroupingAction (inherited from ItemType)
GroupingActionSpecified (inherited from ItemType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBlockedImages (inherited from ItemType)
HasBlockedImagesSpecified (inherited from ItemType)
IconIndex (inherited from ItemType)
IconIndexSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InstanceKey (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested
IsDeliveryReceiptRequestedSpecified
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead
IsReadReceiptRequested
IsReadReceiptRequestedSpecified
IsReadSpecified
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested
IsResponseRequestedSpecified
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
NextPredictedAction (inherited from ItemType)
NextPredictedActionSpecified (inherited from ItemType)
NormalizedBody (inherited from ItemType)
ParentFolderId (inherited from ItemType)
PolicyTag (inherited from ItemType)
Preview (inherited from ItemType)
ReceivedBy
ReceivedRepresenting
References
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReminderNextTime (inherited from ItemType)
ReminderNextTimeSpecified (inherited from ItemType)
ReplyTo
ResponseObjects (inherited from ItemType)
RetentionDate (inherited from ItemType)
RetentionDateSpecified (inherited from ItemType)
RightsManagementLicenseData (inherited from ItemType)
Sender
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
StoreEntryId (inherited from ItemType)
Subject (inherited from ItemType)
TextBody (inherited from ItemType)
ToRecipients
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MessageType Constructor

Initializes a new instance of the MessageType class.

public MessageType();

See Also

MessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MessageType Properties

The properties of the MessageType class are listed below. For a complete list of MessageType class members, see the MessageType Members topic.

Public Instance Properties

ArchiveTag (inherited from ItemType)
Attachments (inherited from ItemType)
BccRecipients
BlockStatus (inherited from ItemType)
BlockStatusSpecified (inherited from ItemType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients
ConversationId (inherited from ItemType)
ConversationIndex
ConversationTopic
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
EntityExtractionResult (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
Flag (inherited from ItemType)
From
GroupingAction (inherited from ItemType)
GroupingActionSpecified (inherited from ItemType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBlockedImages (inherited from ItemType)
HasBlockedImagesSpecified (inherited from ItemType)
IconIndex (inherited from ItemType)
IconIndexSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InstanceKey (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested
IsDeliveryReceiptRequestedSpecified
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead
IsReadReceiptRequested
IsReadReceiptRequestedSpecified
IsReadSpecified
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested
IsResponseRequestedSpecified
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
NextPredictedAction (inherited from ItemType)
NextPredictedActionSpecified (inherited from ItemType)
NormalizedBody (inherited from ItemType)
ParentFolderId (inherited from ItemType)
PolicyTag (inherited from ItemType)
Preview (inherited from ItemType)
ReceivedBy
ReceivedRepresenting
References
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReminderNextTime (inherited from ItemType)
ReminderNextTimeSpecified (inherited from ItemType)
ReplyTo
ResponseObjects (inherited from ItemType)
RetentionDate (inherited from ItemType)
RetentionDateSpecified (inherited from ItemType)
RightsManagementLicenseData (inherited from ItemType)
Sender
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
StoreEntryId (inherited from ItemType)
Subject (inherited from ItemType)
TextBody (inherited from ItemType)
ToRecipients
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

See Also

MessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BccRecipients Property

Aspose.Email

MessageType.BccRecipients Property

public EmailAddressType[] BccRecipients {get; set;}

Remarks

See Also

MessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CcRecipients Property

Aspose.Email

MessageType.CcRecipients Property

public EmailAddressType[] CcRecipients {get; set;}

Remarks

See Also

MessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConversationIndex Property

Aspose.Email

MessageType.ConversationIndex Property

public byte[] ConversationIndex {get; set;}

Remarks

See Also

MessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConversationTopic Property

Aspose.Email

MessageType.ConversationTopic Property

public string ConversationTopic {get; set;}

Remarks

See Also

MessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


From Property

Aspose.Email

MessageType.From Property

public SingleRecipientType From {get; set;}

Remarks

See Also

MessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InternetMessageId Property

Aspose.Email

MessageType.InternetMessageId Property

public string InternetMessageId {get; set;}

Remarks

See Also

MessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsDeliveryReceiptRequested Property

Aspose.Email

MessageType.IsDeliveryReceiptRequested Property

public bool IsDeliveryReceiptRequested {get; set;}

Remarks

See Also

MessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsDeliveryReceiptRequestedSpecified Property

Aspose.Email

MessageType.IsDeliveryReceiptRequestedSpecified Property

public bool IsDeliveryReceiptRequestedSpecified {get; set;}

Remarks

See Also

MessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsRead Property

Aspose.Email

MessageType.IsRead Property

public bool IsRead {get; set;}

Remarks

See Also

MessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsReadReceiptRequested Property

Aspose.Email

MessageType.IsReadReceiptRequested Property

public bool IsReadReceiptRequested {get; set;}

Remarks

See Also

MessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsReadReceiptRequestedSpecified Property

Aspose.Email

MessageType.IsReadReceiptRequestedSpecified Property

public bool IsReadReceiptRequestedSpecified {get; set;}

Remarks

See Also

MessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsReadSpecified Property

Aspose.Email

MessageType.IsReadSpecified Property

public bool IsReadSpecified {get; set;}

Remarks

See Also

MessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsResponseRequested Property

Aspose.Email

MessageType.IsResponseRequested Property

public bool IsResponseRequested {get; set;}

Remarks

See Also

MessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsResponseRequestedSpecified Property

Aspose.Email

MessageType.IsResponseRequestedSpecified Property

public bool IsResponseRequestedSpecified {get; set;}

Remarks

See Also

MessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReceivedBy Property

Aspose.Email

MessageType.ReceivedBy Property

public SingleRecipientType ReceivedBy {get; set;}

Remarks

See Also

MessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReceivedRepresenting Property

Aspose.Email

MessageType.ReceivedRepresenting Property

public SingleRecipientType ReceivedRepresenting {get; set;}

Remarks

See Also

MessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


References Property

Aspose.Email

MessageType.References Property

public string References {get; set;}

Remarks

See Also

MessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReplyTo Property

Aspose.Email

MessageType.ReplyTo Property

public EmailAddressType[] ReplyTo {get; set;}

Remarks

See Also

MessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Sender Property

Aspose.Email

MessageType.Sender Property

public SingleRecipientType Sender {get; set;}

Remarks

See Also

MessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ToRecipients Property

Aspose.Email

MessageType.ToRecipients Property

public EmailAddressType[] ToRecipients {get; set;}

Remarks

See Also

MessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MimeContentType Class

For a list of all members of this type, see MimeContentType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.MimeContentType

public class MimeContentType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MimeContentType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MimeContentType Members

MimeContentType overview

Public Instance Constructors

MimeContentType Constructor Initializes a new instance of the MimeContentType class.

Public Instance Properties

CharacterSet
Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MimeContentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MimeContentType Constructor

Initializes a new instance of the MimeContentType class.

public MimeContentType();

See Also

MimeContentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MimeContentType Properties

The properties of the MimeContentType class are listed below. For a complete list of MimeContentType class members, see the MimeContentType Members topic.

Public Instance Properties

CharacterSet
Value

See Also

MimeContentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CharacterSet Property

Aspose.Email

MimeContentType.CharacterSet Property

public string CharacterSet {get; set;}

Remarks

See Also

MimeContentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Value Property

Aspose.Email

MimeContentType.Value Property

public string Value {get; set;}

Remarks

See Also

MimeContentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ModifiedEventType Class

For a list of all members of this type, see ModifiedEventType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseNotificationEventType
Aspose.Email.Exchange.Schema.Exchange_2013.BaseObjectChangedEventType
Aspose.Email.Exchange.Schema.Exchange_2013.ModifiedEventType

public class ModifiedEventType : BaseObjectChangedEventType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ModifiedEventType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ModifiedEventType Members

ModifiedEventType overview

Public Instance Constructors

ModifiedEventType Constructor Initializes a new instance of the ModifiedEventType class.

Public Instance Properties

Item (inherited from BaseObjectChangedEventType)
ParentFolderId (inherited from BaseObjectChangedEventType)
TimeStamp (inherited from BaseObjectChangedEventType)
UnreadCount
UnreadCountSpecified
Watermark (inherited from BaseNotificationEventType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ModifiedEventType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ModifiedEventType Constructor

Initializes a new instance of the ModifiedEventType class.

public ModifiedEventType();

See Also

ModifiedEventType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ModifiedEventType Properties

The properties of the ModifiedEventType class are listed below. For a complete list of ModifiedEventType class members, see the ModifiedEventType Members topic.

Public Instance Properties

Item (inherited from BaseObjectChangedEventType)
ParentFolderId (inherited from BaseObjectChangedEventType)
TimeStamp (inherited from BaseObjectChangedEventType)
UnreadCount
UnreadCountSpecified
Watermark (inherited from BaseNotificationEventType)

See Also

ModifiedEventType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UnreadCount Property

Aspose.Email

ModifiedEventType.UnreadCount Property

public int UnreadCount {get; set;}

Remarks

See Also

ModifiedEventType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UnreadCountSpecified Property

Aspose.Email

ModifiedEventType.UnreadCountSpecified Property

public bool UnreadCountSpecified {get; set;}

Remarks

See Also

ModifiedEventType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MonthlyRegeneratingPatternType Class

For a list of all members of this type, see MonthlyRegeneratingPatternType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.RecurrencePatternBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.IntervalRecurrencePatternBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.RegeneratingPatternBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.MonthlyRegeneratingPatternType

public class MonthlyRegeneratingPatternType : RegeneratingPatternBaseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MonthlyRegeneratingPatternType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MonthlyRegeneratingPatternType Members

MonthlyRegeneratingPatternType overview

Public Instance Constructors

MonthlyRegeneratingPatternType Constructor Initializes a new instance of the MonthlyRegeneratingPatternType class.

Public Instance Properties

Interval (inherited from IntervalRecurrencePatternBaseType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MonthlyRegeneratingPatternType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MonthlyRegeneratingPatternType Constructor

Initializes a new instance of the MonthlyRegeneratingPatternType class.

public MonthlyRegeneratingPatternType();

See Also

MonthlyRegeneratingPatternType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MonthNamesType Enumeration

public enum MonthNamesType

Remarks

Members

Member Name | Description | Value
January |  | 0
February |  | 1
March |  | 2
April |  | 3
May |  | 4
June |  | 5
July |  | 6
August |  | 7
September |  | 8
October |  | 9
November |  | 10
December |  | 11

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MovedCopiedEventType Class

For a list of all members of this type, see MovedCopiedEventType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseNotificationEventType
Aspose.Email.Exchange.Schema.Exchange_2013.BaseObjectChangedEventType
Aspose.Email.Exchange.Schema.Exchange_2013.MovedCopiedEventType

public class MovedCopiedEventType : BaseObjectChangedEventType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MovedCopiedEventType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MovedCopiedEventType Members

MovedCopiedEventType overview

Public Instance Constructors

MovedCopiedEventType Constructor Initializes a new instance of the MovedCopiedEventType class.

Public Instance Properties

Item (inherited from BaseObjectChangedEventType)
Item1
OldParentFolderId
ParentFolderId (inherited from BaseObjectChangedEventType)
TimeStamp (inherited from BaseObjectChangedEventType)
Watermark (inherited from BaseNotificationEventType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MovedCopiedEventType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MovedCopiedEventType Constructor

Initializes a new instance of the MovedCopiedEventType class.

public MovedCopiedEventType();

See Also

MovedCopiedEventType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MovedCopiedEventType Properties

The properties of the MovedCopiedEventType class are listed below. For a complete list of MovedCopiedEventType class members, see the MovedCopiedEventType Members topic.

Public Instance Properties

Item (inherited from BaseObjectChangedEventType)
Item1
OldParentFolderId
ParentFolderId (inherited from BaseObjectChangedEventType)
TimeStamp (inherited from BaseObjectChangedEventType)
Watermark (inherited from BaseNotificationEventType)

See Also

MovedCopiedEventType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Item1 Property

Aspose.Email

MovedCopiedEventType.Item1 Property

public object Item1 {get; set;}

Remarks

See Also

MovedCopiedEventType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OldParentFolderId Property

Aspose.Email

MovedCopiedEventType.OldParentFolderId Property

public FolderIdType OldParentFolderId {get; set;}

Remarks

See Also

MovedCopiedEventType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MoveFolderCompletedEventArgs Class

For a list of all members of this type, see MoveFolderCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.MoveFolderCompletedEventArgs

public class MoveFolderCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MoveFolderCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MoveFolderCompletedEventArgs Members

MoveFolderCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

MoveFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MoveFolderCompletedEventArgs Properties

The properties of the MoveFolderCompletedEventArgs class are listed below. For a complete list of MoveFolderCompletedEventArgs class members, see the MoveFolderCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

MoveFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

MoveFolderCompletedEventArgs.Result Property

public MoveFolderResponseType Result {get;}

Remarks

See Also

MoveFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MoveFolderCompletedEventHandler Delegate

public delegate void MoveFolderCompletedEventHandler(
object sender,
MoveFolderCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MoveFolderResponseType Class

For a list of all members of this type, see MoveFolderResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.MoveFolderResponseType

public class MoveFolderResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MoveFolderResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MoveFolderResponseType Members

MoveFolderResponseType overview

Public Instance Constructors

MoveFolderResponseType Constructor Initializes a new instance of the MoveFolderResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MoveFolderResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MoveFolderResponseType Constructor

Initializes a new instance of the MoveFolderResponseType class.

public MoveFolderResponseType();

See Also

MoveFolderResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MoveFolderType Class

For a list of all members of this type, see MoveFolderType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.BaseMoveCopyFolderType
Aspose.Email.Exchange.Schema.Exchange_2013.MoveFolderType

public class MoveFolderType : BaseMoveCopyFolderType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MoveFolderType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MoveFolderType Members

MoveFolderType overview

Public Instance Constructors

MoveFolderType Constructor Initializes a new instance of the MoveFolderType class.

Public Instance Properties

FolderIds (inherited from BaseMoveCopyFolderType)
ToFolderId (inherited from BaseMoveCopyFolderType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MoveFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MoveFolderType Constructor

Initializes a new instance of the MoveFolderType class.

public MoveFolderType();

See Also

MoveFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MoveItemCompletedEventArgs Class

For a list of all members of this type, see MoveItemCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.MoveItemCompletedEventArgs

public class MoveItemCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MoveItemCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MoveItemCompletedEventArgs Members

MoveItemCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

MoveItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MoveItemCompletedEventArgs Properties

The properties of the MoveItemCompletedEventArgs class are listed below. For a complete list of MoveItemCompletedEventArgs class members, see the MoveItemCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

MoveItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

MoveItemCompletedEventArgs.Result Property

public MoveItemResponseType Result {get;}

Remarks

See Also

MoveItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MoveItemCompletedEventHandler Delegate

public delegate void MoveItemCompletedEventHandler(
object sender,
MoveItemCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MoveItemResponseType Class

For a list of all members of this type, see MoveItemResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.MoveItemResponseType

public class MoveItemResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MoveItemResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MoveItemResponseType Members

MoveItemResponseType overview

Public Instance Constructors

MoveItemResponseType Constructor Initializes a new instance of the MoveItemResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MoveItemResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MoveItemResponseType Constructor

Initializes a new instance of the MoveItemResponseType class.

public MoveItemResponseType();

See Also

MoveItemResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MoveItemType Class

For a list of all members of this type, see MoveItemType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.BaseMoveCopyItemType
Aspose.Email.Exchange.Schema.Exchange_2013.MoveItemType

public class MoveItemType : BaseMoveCopyItemType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MoveItemType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MoveItemType Members

MoveItemType overview

Public Instance Constructors

MoveItemType Constructor Initializes a new instance of the MoveItemType class.

Public Instance Properties

ItemIds (inherited from BaseMoveCopyItemType)
ReturnNewItemIds (inherited from BaseMoveCopyItemType)
ReturnNewItemIdsSpecified (inherited from BaseMoveCopyItemType)
ToFolderId (inherited from BaseMoveCopyItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MoveItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MoveItemType Constructor

Initializes a new instance of the MoveItemType class.

public MoveItemType();

See Also

MoveItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MultipleOperandBooleanExpressionType Class

For a list of all members of this type, see MultipleOperandBooleanExpressionType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.SearchExpressionType
Aspose.Email.Exchange.Schema.Exchange_2013.MultipleOperandBooleanExpressionType
Aspose.Email.Exchange.Schema.Exchange_2013.AndType
Aspose.Email.Exchange.Schema.Exchange_2013.OrType

public abstract class MultipleOperandBooleanExpressionType : SearchExpressionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MultipleOperandBooleanExpressionType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MultipleOperandBooleanExpressionType Members

MultipleOperandBooleanExpressionType overview

Public Instance Properties

Items

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

MultipleOperandBooleanExpressionType Constructor Initializes a new instance of the MultipleOperandBooleanExpressionType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MultipleOperandBooleanExpressionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MultipleOperandBooleanExpressionType Constructor

Initializes a new instance of the MultipleOperandBooleanExpressionType class.

protected MultipleOperandBooleanExpressionType();

See Also

MultipleOperandBooleanExpressionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MultipleOperandBooleanExpressionType Properties

The properties of the MultipleOperandBooleanExpressionType class are listed below. For a complete list of MultipleOperandBooleanExpressionType class members, see the MultipleOperandBooleanExpressionType Members topic.

Public Instance Properties

Items

See Also

MultipleOperandBooleanExpressionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Items Property

Aspose.Email

MultipleOperandBooleanExpressionType.Items Property

public SearchExpressionType[] Items {get; set;}

Remarks

See Also

MultipleOperandBooleanExpressionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NoEndRecurrenceRangeType Class

For a list of all members of this type, see NoEndRecurrenceRangeType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.RecurrenceRangeBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.NoEndRecurrenceRangeType

public class NoEndRecurrenceRangeType : RecurrenceRangeBaseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

NoEndRecurrenceRangeType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NoEndRecurrenceRangeType Members

NoEndRecurrenceRangeType overview

Public Instance Constructors

NoEndRecurrenceRangeType Constructor Initializes a new instance of the NoEndRecurrenceRangeType class.

Public Instance Properties

StartDate (inherited from RecurrenceRangeBaseType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NoEndRecurrenceRangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NoEndRecurrenceRangeType Constructor

Initializes a new instance of the NoEndRecurrenceRangeType class.

public NoEndRecurrenceRangeType();

See Also

NoEndRecurrenceRangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NonEmptyArrayOfAllItemsType Class

For a list of all members of this type, see NonEmptyArrayOfAllItemsType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.NonEmptyArrayOfAllItemsType

public class NonEmptyArrayOfAllItemsType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

NonEmptyArrayOfAllItemsType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NonEmptyArrayOfAllItemsType Members

NonEmptyArrayOfAllItemsType overview

Public Instance Constructors

NonEmptyArrayOfAllItemsType Constructor Initializes a new instance of the NonEmptyArrayOfAllItemsType class.

Public Instance Properties

Items

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NonEmptyArrayOfAllItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NonEmptyArrayOfAllItemsType Constructor

Initializes a new instance of the NonEmptyArrayOfAllItemsType class.

public NonEmptyArrayOfAllItemsType();

See Also

NonEmptyArrayOfAllItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NonEmptyArrayOfAllItemsType Properties

The properties of the NonEmptyArrayOfAllItemsType class are listed below. For a complete list of NonEmptyArrayOfAllItemsType class members, see the NonEmptyArrayOfAllItemsType Members topic.

Public Instance Properties

Items

See Also

NonEmptyArrayOfAllItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Items Property

Aspose.Email

NonEmptyArrayOfAllItemsType.Items Property

public ItemType[] Items {get; set;}

Remarks

See Also

NonEmptyArrayOfAllItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NonEmptyArrayOfExtendedPropertyType Class

For a list of all members of this type, see NonEmptyArrayOfExtendedPropertyType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.NonEmptyArrayOfExtendedPropertyType

public class NonEmptyArrayOfExtendedPropertyType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

NonEmptyArrayOfExtendedPropertyType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NonEmptyArrayOfExtendedPropertyType Members

NonEmptyArrayOfExtendedPropertyType overview

Public Instance Constructors

NonEmptyArrayOfExtendedPropertyType Constructor Initializes a new instance of the NonEmptyArrayOfExtendedPropertyType class.

Public Instance Properties

Items

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NonEmptyArrayOfExtendedPropertyType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NonEmptyArrayOfExtendedPropertyType Constructor

Initializes a new instance of the NonEmptyArrayOfExtendedPropertyType class.

public NonEmptyArrayOfExtendedPropertyType();

See Also

NonEmptyArrayOfExtendedPropertyType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NonEmptyArrayOfExtendedPropertyType Properties

The properties of the NonEmptyArrayOfExtendedPropertyType class are listed below. For a complete list of NonEmptyArrayOfExtendedPropertyType class members, see the NonEmptyArrayOfExtendedPropertyType Members topic.

Public Instance Properties

Items

See Also

NonEmptyArrayOfExtendedPropertyType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Items Property

Aspose.Email

NonEmptyArrayOfExtendedPropertyType.Items Property

public ExtendedPropertyType[] Items {get; set;}

Remarks

See Also

NonEmptyArrayOfExtendedPropertyType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NonEmptyArrayOfPropertyValuesType Class

For a list of all members of this type, see NonEmptyArrayOfPropertyValuesType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.NonEmptyArrayOfPropertyValuesType

public class NonEmptyArrayOfPropertyValuesType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

NonEmptyArrayOfPropertyValuesType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NonEmptyArrayOfPropertyValuesType Members

NonEmptyArrayOfPropertyValuesType overview

Public Instance Constructors

NonEmptyArrayOfPropertyValuesType Constructor Initializes a new instance of the NonEmptyArrayOfPropertyValuesType class.

Public Instance Properties

Items

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NonEmptyArrayOfPropertyValuesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NonEmptyArrayOfPropertyValuesType Constructor

Initializes a new instance of the NonEmptyArrayOfPropertyValuesType class.

public NonEmptyArrayOfPropertyValuesType();

See Also

NonEmptyArrayOfPropertyValuesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NonEmptyArrayOfPropertyValuesType Properties

The properties of the NonEmptyArrayOfPropertyValuesType class are listed below. For a complete list of NonEmptyArrayOfPropertyValuesType class members, see the NonEmptyArrayOfPropertyValuesType Members topic.

Public Instance Properties

Items

See Also

NonEmptyArrayOfPropertyValuesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Items Property

Aspose.Email

NonEmptyArrayOfPropertyValuesType.Items Property

public string[] Items {get; set;}

Remarks

See Also

NonEmptyArrayOfPropertyValuesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NonEmptyStateDefinitionType Class

For a list of all members of this type, see NonEmptyStateDefinitionType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.NonEmptyStateDefinitionType

public class NonEmptyStateDefinitionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

NonEmptyStateDefinitionType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NonEmptyStateDefinitionType Members

NonEmptyStateDefinitionType overview

Public Instance Constructors

NonEmptyStateDefinitionType Constructor Initializes a new instance of the NonEmptyStateDefinitionType class.

Public Instance Properties

Item

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NonEmptyStateDefinitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NonEmptyStateDefinitionType Constructor

Initializes a new instance of the NonEmptyStateDefinitionType class.

public NonEmptyStateDefinitionType();

See Also

NonEmptyStateDefinitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NonEmptyStateDefinitionType Properties

The properties of the NonEmptyStateDefinitionType class are listed below. For a complete list of NonEmptyStateDefinitionType class members, see the NonEmptyStateDefinitionType Members topic.

Public Instance Properties

Item

See Also

NonEmptyStateDefinitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Item Property

Aspose.Email

NonEmptyStateDefinitionType.Item Property

public BaseCalendarItemStateDefinitionType Item {get; set;}

Remarks

See Also

NonEmptyStateDefinitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NonIndexableItemDetailResultType Class

For a list of all members of this type, see NonIndexableItemDetailResultType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.NonIndexableItemDetailResultType

public class NonIndexableItemDetailResultType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

NonIndexableItemDetailResultType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NonIndexableItemDetailResultType Members

NonIndexableItemDetailResultType overview

Public Instance Constructors

NonIndexableItemDetailResultType Constructor Initializes a new instance of the NonIndexableItemDetailResultType class.

Public Instance Properties

FailedMailboxes
Items

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NonIndexableItemDetailResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NonIndexableItemDetailResultType Constructor

Initializes a new instance of the NonIndexableItemDetailResultType class.

public NonIndexableItemDetailResultType();

See Also

NonIndexableItemDetailResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NonIndexableItemDetailResultType Properties

The properties of the NonIndexableItemDetailResultType class are listed below. For a complete list of NonIndexableItemDetailResultType class members, see the NonIndexableItemDetailResultType Members topic.

Public Instance Properties

FailedMailboxes
Items

See Also

NonIndexableItemDetailResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FailedMailboxes Property

Aspose.Email

NonIndexableItemDetailResultType.FailedMailboxes Property

public FailedSearchMailboxType[] FailedMailboxes {get; set;}

Remarks

See Also

NonIndexableItemDetailResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Items Property

Aspose.Email

NonIndexableItemDetailResultType.Items Property

public NonIndexableItemDetailType[] Items {get; set;}

Remarks

See Also

NonIndexableItemDetailResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NonIndexableItemDetailType Class

For a list of all members of this type, see NonIndexableItemDetailType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.NonIndexableItemDetailType

public class NonIndexableItemDetailType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

NonIndexableItemDetailType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NonIndexableItemDetailType Members

NonIndexableItemDetailType overview

Public Instance Constructors

NonIndexableItemDetailType Constructor Initializes a new instance of the NonIndexableItemDetailType class.

Public Instance Properties

AdditionalInfo
AttemptCount
ErrorCode
ErrorDescription
IsPartiallyIndexed
IsPermanentFailure
ItemId
LastAttemptTime
LastAttemptTimeSpecified
SortValue

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NonIndexableItemDetailType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NonIndexableItemDetailType Constructor

Initializes a new instance of the NonIndexableItemDetailType class.

public NonIndexableItemDetailType();

See Also

NonIndexableItemDetailType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NonIndexableItemDetailType Properties

The properties of the NonIndexableItemDetailType class are listed below. For a complete list of NonIndexableItemDetailType class members, see the NonIndexableItemDetailType Members topic.

Public Instance Properties

AdditionalInfo
AttemptCount
ErrorCode
ErrorDescription
IsPartiallyIndexed
IsPermanentFailure
ItemId
LastAttemptTime
LastAttemptTimeSpecified
SortValue

See Also

NonIndexableItemDetailType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AdditionalInfo Property

Aspose.Email

NonIndexableItemDetailType.AdditionalInfo Property

public string AdditionalInfo {get; set;}

Remarks

See Also

NonIndexableItemDetailType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AttemptCount Property

Aspose.Email

NonIndexableItemDetailType.AttemptCount Property

public int AttemptCount {get; set;}

Remarks

See Also

NonIndexableItemDetailType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ErrorCode Property

Aspose.Email

NonIndexableItemDetailType.ErrorCode Property

public ItemIndexErrorType ErrorCode {get; set;}

Remarks

See Also

NonIndexableItemDetailType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ErrorDescription Property

Aspose.Email

NonIndexableItemDetailType.ErrorDescription Property

public string ErrorDescription {get; set;}

Remarks

See Also

NonIndexableItemDetailType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsPartiallyIndexed Property

Aspose.Email

NonIndexableItemDetailType.IsPartiallyIndexed Property

public bool IsPartiallyIndexed {get; set;}

Remarks

See Also

NonIndexableItemDetailType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsPermanentFailure Property

Aspose.Email

NonIndexableItemDetailType.IsPermanentFailure Property

public bool IsPermanentFailure {get; set;}

Remarks

See Also

NonIndexableItemDetailType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemId Property

Aspose.Email

NonIndexableItemDetailType.ItemId Property

public ItemIdType ItemId {get; set;}

Remarks

See Also

NonIndexableItemDetailType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


LastAttemptTime Property

Aspose.Email

NonIndexableItemDetailType.LastAttemptTime Property

public DateTime LastAttemptTime {get; set;}

Remarks

See Also

NonIndexableItemDetailType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


LastAttemptTimeSpecified Property

Aspose.Email

NonIndexableItemDetailType.LastAttemptTimeSpecified Property

public bool LastAttemptTimeSpecified {get; set;}

Remarks

See Also

NonIndexableItemDetailType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SortValue Property

Aspose.Email

NonIndexableItemDetailType.SortValue Property

public string SortValue {get; set;}

Remarks

See Also

NonIndexableItemDetailType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NonIndexableItemStatisticType Class

For a list of all members of this type, see NonIndexableItemStatisticType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.NonIndexableItemStatisticType

public class NonIndexableItemStatisticType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

NonIndexableItemStatisticType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NonIndexableItemStatisticType Members

NonIndexableItemStatisticType overview

Public Instance Constructors

NonIndexableItemStatisticType Constructor Initializes a new instance of the NonIndexableItemStatisticType class.

Public Instance Properties

ErrorMessage
ItemCount
Mailbox

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NonIndexableItemStatisticType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NonIndexableItemStatisticType Constructor

Initializes a new instance of the NonIndexableItemStatisticType class.

public NonIndexableItemStatisticType();

See Also

NonIndexableItemStatisticType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NonIndexableItemStatisticType Properties

The properties of the NonIndexableItemStatisticType class are listed below. For a complete list of NonIndexableItemStatisticType class members, see the NonIndexableItemStatisticType Members topic.

Public Instance Properties

ErrorMessage
ItemCount
Mailbox

See Also

NonIndexableItemStatisticType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ErrorMessage Property

Aspose.Email

NonIndexableItemStatisticType.ErrorMessage Property

public string ErrorMessage {get; set;}

Remarks

See Also

NonIndexableItemStatisticType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemCount Property

Aspose.Email

NonIndexableItemStatisticType.ItemCount Property

public long ItemCount {get; set;}

Remarks

See Also

NonIndexableItemStatisticType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Mailbox Property

Aspose.Email

NonIndexableItemStatisticType.Mailbox Property

public string Mailbox {get; set;}

Remarks

See Also

NonIndexableItemStatisticType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NotificationEventTypeType Enumeration

public enum NotificationEventTypeType

Remarks

Members

Member Name | Description | Value
CopiedEvent |  | 0
CreatedEvent |  | 1
DeletedEvent |  | 2
ModifiedEvent |  | 3
MovedEvent |  | 4
NewMailEvent |  | 5
FreeBusyChangedEvent |  | 6

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NotificationType Class

For a list of all members of this type, see NotificationType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.NotificationType

public class NotificationType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

NotificationType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NotificationType Members

NotificationType overview

Public Instance Constructors

NotificationType Constructor Initializes a new instance of the NotificationType class.

Public Instance Properties

Items
ItemsElementName
MoreEvents
MoreEventsSpecified
PreviousWatermark
SubscriptionId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NotificationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NotificationType Constructor

Initializes a new instance of the NotificationType class.

public NotificationType();

See Also

NotificationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NotificationType Properties

The properties of the NotificationType class are listed below. For a complete list of NotificationType class members, see the NotificationType Members topic.

Public Instance Properties

Items
ItemsElementName
MoreEvents
MoreEventsSpecified
PreviousWatermark
SubscriptionId

See Also

NotificationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Items Property

Aspose.Email

NotificationType.Items Property

public BaseNotificationEventType[] Items {get; set;}

Remarks

See Also

NotificationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemsElementName Property

Aspose.Email

NotificationType.ItemsElementName Property

public ItemsChoiceType[] ItemsElementName {get; set;}

Remarks

See Also

NotificationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MoreEvents Property

Aspose.Email

NotificationType.MoreEvents Property

public bool MoreEvents {get; set;}

Remarks

See Also

NotificationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MoreEventsSpecified Property

Aspose.Email

NotificationType.MoreEventsSpecified Property

public bool MoreEventsSpecified {get; set;}

Remarks

See Also

NotificationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PreviousWatermark Property

Aspose.Email

NotificationType.PreviousWatermark Property

public string PreviousWatermark {get; set;}

Remarks

See Also

NotificationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SubscriptionId Property

Aspose.Email

NotificationType.SubscriptionId Property

public string SubscriptionId {get; set;}

Remarks

See Also

NotificationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NotType Class

For a list of all members of this type, see NotType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.SearchExpressionType
Aspose.Email.Exchange.Schema.Exchange_2013.NotType

public class NotType : SearchExpressionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

NotType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NotType Members

NotType overview

Public Instance Constructors

NotType Constructor Initializes a new instance of the NotType class.

Public Instance Properties

Item

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NotType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NotType Constructor

Initializes a new instance of the NotType class.

public NotType();

See Also

NotType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NotType Properties

The properties of the NotType class are listed below. For a complete list of NotType class members, see the NotType Members topic.

Public Instance Properties

Item

See Also

NotType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Item Property

Aspose.Email

NotType.Item Property

public SearchExpressionType Item {get; set;}

Remarks

See Also

NotType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NumberedRecurrenceRangeType Class

For a list of all members of this type, see NumberedRecurrenceRangeType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.RecurrenceRangeBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.NumberedRecurrenceRangeType

public class NumberedRecurrenceRangeType : RecurrenceRangeBaseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

NumberedRecurrenceRangeType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NumberedRecurrenceRangeType Members

NumberedRecurrenceRangeType overview

Public Instance Constructors

NumberedRecurrenceRangeType Constructor Initializes a new instance of the NumberedRecurrenceRangeType class.

Public Instance Properties

NumberOfOccurrences
StartDate (inherited from RecurrenceRangeBaseType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NumberedRecurrenceRangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NumberedRecurrenceRangeType Constructor

Initializes a new instance of the NumberedRecurrenceRangeType class.

public NumberedRecurrenceRangeType();

See Also

NumberedRecurrenceRangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NumberedRecurrenceRangeType Properties

The properties of the NumberedRecurrenceRangeType class are listed below. For a complete list of NumberedRecurrenceRangeType class members, see the NumberedRecurrenceRangeType Members topic.

Public Instance Properties

NumberOfOccurrences
StartDate (inherited from RecurrenceRangeBaseType)

See Also

NumberedRecurrenceRangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NumberOfOccurrences Property

Aspose.Email

NumberedRecurrenceRangeType.NumberOfOccurrences Property

public int NumberOfOccurrences {get; set;}

Remarks

See Also

NumberedRecurrenceRangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OccurrenceInfoType Class

For a list of all members of this type, see OccurrenceInfoType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.OccurrenceInfoType

public class OccurrenceInfoType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

OccurrenceInfoType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OccurrenceInfoType Members

OccurrenceInfoType overview

Public Instance Constructors

OccurrenceInfoType Constructor Initializes a new instance of the OccurrenceInfoType class.

Public Instance Properties

End
ItemId
OriginalStart
Start

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OccurrenceInfoType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OccurrenceInfoType Constructor

Initializes a new instance of the OccurrenceInfoType class.

public OccurrenceInfoType();

See Also

OccurrenceInfoType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OccurrenceInfoType Properties

The properties of the OccurrenceInfoType class are listed below. For a complete list of OccurrenceInfoType class members, see the OccurrenceInfoType Members topic.

Public Instance Properties

End
ItemId
OriginalStart
Start

See Also

OccurrenceInfoType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


End Property

Aspose.Email

OccurrenceInfoType.End Property

public DateTime End {get; set;}

Remarks

See Also

OccurrenceInfoType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemId Property

Aspose.Email

OccurrenceInfoType.ItemId Property

public ItemIdType ItemId {get; set;}

Remarks

See Also

OccurrenceInfoType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OriginalStart Property

Aspose.Email

OccurrenceInfoType.OriginalStart Property

public DateTime OriginalStart {get; set;}

Remarks

See Also

OccurrenceInfoType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Start Property

Aspose.Email

OccurrenceInfoType.Start Property

public DateTime Start {get; set;}

Remarks

See Also

OccurrenceInfoType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OccurrenceItemIdType Class

For a list of all members of this type, see OccurrenceItemIdType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseItemIdType
Aspose.Email.Exchange.Schema.Exchange_2013.OccurrenceItemIdType

public class OccurrenceItemIdType : BaseItemIdType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

OccurrenceItemIdType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OccurrenceItemIdType Members

OccurrenceItemIdType overview

Public Instance Constructors

OccurrenceItemIdType Constructor Initializes a new instance of the OccurrenceItemIdType class.

Public Instance Properties

ChangeKey
InstanceIndex
RecurringMasterId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OccurrenceItemIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OccurrenceItemIdType Constructor

Initializes a new instance of the OccurrenceItemIdType class.

public OccurrenceItemIdType();

See Also

OccurrenceItemIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OccurrenceItemIdType Properties

The properties of the OccurrenceItemIdType class are listed below. For a complete list of OccurrenceItemIdType class members, see the OccurrenceItemIdType Members topic.

Public Instance Properties

ChangeKey
InstanceIndex
RecurringMasterId

See Also

OccurrenceItemIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ChangeKey Property

Aspose.Email

OccurrenceItemIdType.ChangeKey Property

public string ChangeKey {get; set;}

Remarks

See Also

OccurrenceItemIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InstanceIndex Property

Aspose.Email

OccurrenceItemIdType.InstanceIndex Property

public int InstanceIndex {get; set;}

Remarks

See Also

OccurrenceItemIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecurringMasterId Property

Aspose.Email

OccurrenceItemIdType.RecurringMasterId Property

public string RecurringMasterId {get; set;}

Remarks

See Also

OccurrenceItemIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OccurrencesRangeType Class

For a list of all members of this type, see OccurrencesRangeType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.OccurrencesRangeType

public class OccurrencesRangeType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

OccurrencesRangeType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OccurrencesRangeType Members

OccurrencesRangeType overview

Public Instance Constructors

OccurrencesRangeType Constructor Initializes a new instance of the OccurrencesRangeType class.

Public Instance Properties

CompareOriginalStartTime
CompareOriginalStartTimeSpecified
Count
CountSpecified
End
EndSpecified
Start
StartSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OccurrencesRangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OccurrencesRangeType Constructor

Initializes a new instance of the OccurrencesRangeType class.

public OccurrencesRangeType();

See Also

OccurrencesRangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OccurrencesRangeType Properties

The properties of the OccurrencesRangeType class are listed below. For a complete list of OccurrencesRangeType class members, see the OccurrencesRangeType Members topic.

Public Instance Properties

CompareOriginalStartTime
CompareOriginalStartTimeSpecified
Count
CountSpecified
End
EndSpecified
Start
StartSpecified

See Also

OccurrencesRangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CompareOriginalStartTime Property

Aspose.Email

OccurrencesRangeType.CompareOriginalStartTime Property

public bool CompareOriginalStartTime {get; set;}

Remarks

See Also

OccurrencesRangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CompareOriginalStartTimeSpecified Property

Aspose.Email

OccurrencesRangeType.CompareOriginalStartTimeSpecified Property

public bool CompareOriginalStartTimeSpecified {get; set;}

Remarks

See Also

OccurrencesRangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Count Property

Aspose.Email

OccurrencesRangeType.Count Property

public int Count {get; set;}

Remarks

See Also

OccurrencesRangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CountSpecified Property

Aspose.Email

OccurrencesRangeType.CountSpecified Property

public bool CountSpecified {get; set;}

Remarks

See Also

OccurrencesRangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


End Property

Aspose.Email

OccurrencesRangeType.End Property

public DateTime End {get; set;}

Remarks

See Also

OccurrencesRangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EndSpecified Property

Aspose.Email

OccurrencesRangeType.EndSpecified Property

public bool EndSpecified {get; set;}

Remarks

See Also

OccurrencesRangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Start Property

Aspose.Email

OccurrencesRangeType.Start Property

public DateTime Start {get; set;}

Remarks

See Also

OccurrencesRangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StartSpecified Property

Aspose.Email

OccurrencesRangeType.StartSpecified Property

public bool StartSpecified {get; set;}

Remarks

See Also

OccurrencesRangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OnlineMeetingAccessLevelType Enumeration

public enum OnlineMeetingAccessLevelType

Remarks

Members

Member Name | Description | Value
Locked |  | 0
Invited |  | 1
Internal |  | 2
Everyone |  | 3

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OnlineMeetingSettingsType Class

For a list of all members of this type, see OnlineMeetingSettingsType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.OnlineMeetingSettingsType

public class OnlineMeetingSettingsType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

OnlineMeetingSettingsType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OnlineMeetingSettingsType Members

OnlineMeetingSettingsType overview

Public Instance Constructors

OnlineMeetingSettingsType Constructor Initializes a new instance of the OnlineMeetingSettingsType class.

Public Instance Properties

AccessLevel
LobbyBypass
Presenters

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OnlineMeetingSettingsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OnlineMeetingSettingsType Constructor

Initializes a new instance of the OnlineMeetingSettingsType class.

public OnlineMeetingSettingsType();

See Also

OnlineMeetingSettingsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OnlineMeetingSettingsType Properties

The properties of the OnlineMeetingSettingsType class are listed below. For a complete list of OnlineMeetingSettingsType class members, see the OnlineMeetingSettingsType Members topic.

Public Instance Properties

AccessLevel
LobbyBypass
Presenters

See Also

OnlineMeetingSettingsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AccessLevel Property

Aspose.Email

OnlineMeetingSettingsType.AccessLevel Property

public OnlineMeetingAccessLevelType AccessLevel {get; set;}

Remarks

See Also

OnlineMeetingSettingsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


LobbyBypass Property

Aspose.Email

OnlineMeetingSettingsType.LobbyBypass Property

public LobbyBypassType LobbyBypass {get; set;}

Remarks

See Also

OnlineMeetingSettingsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Presenters Property

Aspose.Email

OnlineMeetingSettingsType.Presenters Property

public PresentersType Presenters {get; set;}

Remarks

See Also

OnlineMeetingSettingsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OofState Enumeration

public enum OofState

Remarks

Members

Member Name | Description | Value
Disabled |  | 0
Enabled |  | 1
Scheduled |  | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OrType Class

For a list of all members of this type, see OrType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.SearchExpressionType
Aspose.Email.Exchange.Schema.Exchange_2013.MultipleOperandBooleanExpressionType
Aspose.Email.Exchange.Schema.Exchange_2013.OrType

public class OrType : MultipleOperandBooleanExpressionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

OrType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OrType Members

OrType overview

Public Instance Constructors

OrType Constructor Initializes a new instance of the OrType class.

Public Instance Properties

Items (inherited from MultipleOperandBooleanExpressionType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OrType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OrType Constructor

Initializes a new instance of the OrType class.

public OrType();

See Also

OrType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OutOfOfficeMailTip Class

For a list of all members of this type, see OutOfOfficeMailTip Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.OutOfOfficeMailTip

public class OutOfOfficeMailTip

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

OutOfOfficeMailTip Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OutOfOfficeMailTip Members

OutOfOfficeMailTip overview

Public Instance Constructors

OutOfOfficeMailTip Constructor Initializes a new instance of the OutOfOfficeMailTip class.

Public Instance Properties

Duration
ReplyBody

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OutOfOfficeMailTip Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OutOfOfficeMailTip Constructor

Initializes a new instance of the OutOfOfficeMailTip class.

public OutOfOfficeMailTip();

See Also

OutOfOfficeMailTip Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OutOfOfficeMailTip Properties

The properties of the OutOfOfficeMailTip class are listed below. For a complete list of OutOfOfficeMailTip class members, see the OutOfOfficeMailTip Members topic.

Public Instance Properties

Duration
ReplyBody

See Also

OutOfOfficeMailTip Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Duration Property

Aspose.Email

OutOfOfficeMailTip.Duration Property

public Duration Duration {get; set;}

Remarks

See Also

OutOfOfficeMailTip Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReplyBody Property

Aspose.Email

OutOfOfficeMailTip.ReplyBody Property

public ReplyBody ReplyBody {get; set;}

Remarks

See Also

OutOfOfficeMailTip Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PathToExceptionFieldType Class

For a list of all members of this type, see PathToExceptionFieldType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BasePathToElementType
Aspose.Email.Exchange.Schema.Exchange_2013.PathToExceptionFieldType

public class PathToExceptionFieldType : BasePathToElementType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PathToExceptionFieldType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PathToExceptionFieldType Members

PathToExceptionFieldType overview

Public Instance Constructors

PathToExceptionFieldType Constructor Initializes a new instance of the PathToExceptionFieldType class.

Public Instance Properties

FieldURI

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PathToExceptionFieldType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PathToExceptionFieldType Constructor

Initializes a new instance of the PathToExceptionFieldType class.

public PathToExceptionFieldType();

See Also

PathToExceptionFieldType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PathToExceptionFieldType Properties

The properties of the PathToExceptionFieldType class are listed below. For a complete list of PathToExceptionFieldType class members, see the PathToExceptionFieldType Members topic.

Public Instance Properties

FieldURI

See Also

PathToExceptionFieldType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FieldURI Property

Aspose.Email

PathToExceptionFieldType.FieldURI Property

public ExceptionPropertyURIType FieldURI {get; set;}

Remarks

See Also

PathToExceptionFieldType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PathToExtendedFieldType Class

For a list of all members of this type, see PathToExtendedFieldType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BasePathToElementType
Aspose.Email.Exchange.Schema.Exchange_2013.PathToExtendedFieldType

public class PathToExtendedFieldType : BasePathToElementType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PathToExtendedFieldType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PathToExtendedFieldType Members

PathToExtendedFieldType overview

Public Instance Constructors

PathToExtendedFieldType Constructor Initializes a new instance of the PathToExtendedFieldType class.

Public Instance Properties

DistinguishedPropertySetId
DistinguishedPropertySetIdSpecified
PropertyId
PropertyIdSpecified
PropertyName
PropertySetId
PropertyTag
PropertyType

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PathToExtendedFieldType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PathToExtendedFieldType Constructor

Initializes a new instance of the PathToExtendedFieldType class.

public PathToExtendedFieldType();

See Also

PathToExtendedFieldType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PathToExtendedFieldType Properties

The properties of the PathToExtendedFieldType class are listed below. For a complete list of PathToExtendedFieldType class members, see the PathToExtendedFieldType Members topic.

Public Instance Properties

DistinguishedPropertySetId
DistinguishedPropertySetIdSpecified
PropertyId
PropertyIdSpecified
PropertyName
PropertySetId
PropertyTag
PropertyType

See Also

PathToExtendedFieldType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DistinguishedPropertySetId Property

Aspose.Email

PathToExtendedFieldType.DistinguishedPropertySetId Property

public DistinguishedPropertySetType DistinguishedPropertySetId {get; set;}

Remarks

See Also

PathToExtendedFieldType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DistinguishedPropertySetIdSpecified Property

Aspose.Email

PathToExtendedFieldType.DistinguishedPropertySetIdSpecified Property

public bool DistinguishedPropertySetIdSpecified {get; set;}

Remarks

See Also

PathToExtendedFieldType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PropertyId Property

Aspose.Email

PathToExtendedFieldType.PropertyId Property

public int PropertyId {get; set;}

Remarks

See Also

PathToExtendedFieldType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PropertyIdSpecified Property

Aspose.Email

PathToExtendedFieldType.PropertyIdSpecified Property

public bool PropertyIdSpecified {get; set;}

Remarks

See Also

PathToExtendedFieldType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PropertyName Property

Aspose.Email

PathToExtendedFieldType.PropertyName Property

public string PropertyName {get; set;}

Remarks

See Also

PathToExtendedFieldType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PropertySetId Property

Aspose.Email

PathToExtendedFieldType.PropertySetId Property

public string PropertySetId {get; set;}

Remarks

See Also

PathToExtendedFieldType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PropertyTag Property

Aspose.Email

PathToExtendedFieldType.PropertyTag Property

public string PropertyTag {get; set;}

Remarks

See Also

PathToExtendedFieldType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PropertyType Property

Aspose.Email

PathToExtendedFieldType.PropertyType Property

public MapiPropertyTypeType PropertyType {get; set;}

Remarks

See Also

PathToExtendedFieldType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PathToIndexedFieldType Class

For a list of all members of this type, see PathToIndexedFieldType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BasePathToElementType
Aspose.Email.Exchange.Schema.Exchange_2013.PathToIndexedFieldType

public class PathToIndexedFieldType : BasePathToElementType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PathToIndexedFieldType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PathToIndexedFieldType Members

PathToIndexedFieldType overview

Public Instance Constructors

PathToIndexedFieldType Constructor Initializes a new instance of the PathToIndexedFieldType class.

Public Instance Properties

FieldIndex
FieldURI

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PathToIndexedFieldType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PathToIndexedFieldType Constructor

Initializes a new instance of the PathToIndexedFieldType class.

public PathToIndexedFieldType();

See Also

PathToIndexedFieldType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PathToIndexedFieldType Properties

The properties of the PathToIndexedFieldType class are listed below. For a complete list of PathToIndexedFieldType class members, see the PathToIndexedFieldType Members topic.

Public Instance Properties

FieldIndex
FieldURI

See Also

PathToIndexedFieldType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FieldIndex Property

Aspose.Email

PathToIndexedFieldType.FieldIndex Property

public string FieldIndex {get; set;}

Remarks

See Also

PathToIndexedFieldType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FieldURI Property

Aspose.Email

PathToIndexedFieldType.FieldURI Property

public DictionaryURIType FieldURI {get; set;}

Remarks

See Also

PathToIndexedFieldType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PathToUnindexedFieldType Class

For a list of all members of this type, see PathToUnindexedFieldType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BasePathToElementType
Aspose.Email.Exchange.Schema.Exchange_2013.PathToUnindexedFieldType

public class PathToUnindexedFieldType : BasePathToElementType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PathToUnindexedFieldType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PathToUnindexedFieldType Members

PathToUnindexedFieldType overview

Public Instance Constructors

PathToUnindexedFieldType Constructor Initializes a new instance of the PathToUnindexedFieldType class.

Public Instance Properties

FieldURI

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PathToUnindexedFieldType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PathToUnindexedFieldType Constructor

Initializes a new instance of the PathToUnindexedFieldType class.

public PathToUnindexedFieldType();

See Also

PathToUnindexedFieldType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PathToUnindexedFieldType Properties

The properties of the PathToUnindexedFieldType class are listed below. For a complete list of PathToUnindexedFieldType class members, see the PathToUnindexedFieldType Members topic.

Public Instance Properties

FieldURI

See Also

PathToUnindexedFieldType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FieldURI Property

Aspose.Email

PathToUnindexedFieldType.FieldURI Property

public UnindexedFieldURIType FieldURI {get; set;}

Remarks

See Also

PathToUnindexedFieldType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PerformReminderActionResponseMessageType Class

For a list of all members of this type, see PerformReminderActionResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.PerformReminderActionResponseMessageType

public class PerformReminderActionResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PerformReminderActionResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PerformReminderActionResponseMessageType Members

PerformReminderActionResponseMessageType overview

Public Instance Constructors

PerformReminderActionResponseMessageType Constructor Initializes a new instance of the PerformReminderActionResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
UpdatedItemIds

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PerformReminderActionResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PerformReminderActionResponseMessageType Constructor

Initializes a new instance of the PerformReminderActionResponseMessageType class.

public PerformReminderActionResponseMessageType();

See Also

PerformReminderActionResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PerformReminderActionResponseMessageType Properties

The properties of the PerformReminderActionResponseMessageType class are listed below. For a complete list of PerformReminderActionResponseMessageType class members, see the PerformReminderActionResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
UpdatedItemIds

See Also

PerformReminderActionResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdatedItemIds Property

Aspose.Email

PerformReminderActionResponseMessageType.UpdatedItemIds Property

public ItemIdType[] UpdatedItemIds {get; set;}

Remarks

See Also

PerformReminderActionResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PerformReminderActionType Class

For a list of all members of this type, see PerformReminderActionType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.PerformReminderActionType

public class PerformReminderActionType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PerformReminderActionType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PerformReminderActionType Members

PerformReminderActionType overview

Public Instance Constructors

PerformReminderActionType Constructor Initializes a new instance of the PerformReminderActionType class.

Public Instance Properties

ReminderItemActions

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PerformReminderActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PerformReminderActionType Constructor

Initializes a new instance of the PerformReminderActionType class.

public PerformReminderActionType();

See Also

PerformReminderActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PerformReminderActionType Properties

The properties of the PerformReminderActionType class are listed below. For a complete list of PerformReminderActionType class members, see the PerformReminderActionType Members topic.

Public Instance Properties

ReminderItemActions

See Also

PerformReminderActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReminderItemActions Property

Aspose.Email

PerformReminderActionType.ReminderItemActions Property

public ReminderItemActionType[] ReminderItemActions {get; set;}

Remarks

See Also

PerformReminderActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PeriodType Class

For a list of all members of this type, see PeriodType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.PeriodType

public class PeriodType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PeriodType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PeriodType Members

PeriodType overview

Public Instance Constructors

PeriodType Constructor Initializes a new instance of the PeriodType class.

Public Instance Properties

Bias
Id
Name

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PeriodType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PeriodType Constructor

Initializes a new instance of the PeriodType class.

public PeriodType();

See Also

PeriodType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PeriodType Properties

The properties of the PeriodType class are listed below. For a complete list of PeriodType class members, see the PeriodType Members topic.

Public Instance Properties

Bias
Id
Name

See Also

PeriodType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Bias Property

Aspose.Email

PeriodType.Bias Property

public string Bias {get; set;}

Remarks

See Also

PeriodType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Id Property

Aspose.Email

PeriodType.Id Property

public string Id {get; set;}

Remarks

See Also

PeriodType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Name Property

Aspose.Email

PeriodType.Name Property

public string Name {get; set;}

Remarks

See Also

PeriodType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PermissionActionType Enumeration

public enum PermissionActionType

Remarks

Members

Member Name | Description | Value
None |  | 0
Owned |  | 1
All |  | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PermissionLevelType Enumeration

public enum PermissionLevelType

Remarks

Members

Member Name | Description | Value
None |  | 0
Owner |  | 1
PublishingEditor |  | 2
Editor |  | 3
PublishingAuthor |  | 4
Author |  | 5
NoneditingAuthor |  | 6
Reviewer |  | 7
Contributor |  | 8
Custom |  | 9

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PermissionReadAccessType Enumeration

public enum PermissionReadAccessType

Remarks

Members

Member Name | Description | Value
None |  | 0
FullDetails |  | 1

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PermissionSetType Class

For a list of all members of this type, see PermissionSetType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.PermissionSetType

public class PermissionSetType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PermissionSetType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PermissionSetType Members

PermissionSetType overview

Public Instance Constructors

PermissionSetType Constructor Initializes a new instance of the PermissionSetType class.

Public Instance Properties

Permissions
UnknownEntries

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PermissionSetType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PermissionSetType Constructor

Initializes a new instance of the PermissionSetType class.

public PermissionSetType();

See Also

PermissionSetType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PermissionSetType Properties

The properties of the PermissionSetType class are listed below. For a complete list of PermissionSetType class members, see the PermissionSetType Members topic.

Public Instance Properties

Permissions
UnknownEntries

See Also

PermissionSetType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Permissions Property

Aspose.Email

PermissionSetType.Permissions Property

public PermissionType[] Permissions {get; set;}

Remarks

See Also

PermissionSetType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UnknownEntries Property

Aspose.Email

PermissionSetType.UnknownEntries Property

public string[] UnknownEntries {get; set;}

Remarks

See Also

PermissionSetType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PermissionType Class

For a list of all members of this type, see PermissionType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BasePermissionType
Aspose.Email.Exchange.Schema.Exchange_2013.PermissionType

public class PermissionType : BasePermissionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PermissionType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PermissionType Members

PermissionType overview

Public Instance Constructors

PermissionType Constructor Initializes a new instance of the PermissionType class.

Public Instance Properties

CanCreateItems (inherited from BasePermissionType)
CanCreateItemsSpecified (inherited from BasePermissionType)
CanCreateSubFolders (inherited from BasePermissionType)
CanCreateSubFoldersSpecified (inherited from BasePermissionType)
DeleteItems (inherited from BasePermissionType)
DeleteItemsSpecified (inherited from BasePermissionType)
EditItems (inherited from BasePermissionType)
EditItemsSpecified (inherited from BasePermissionType)
IsFolderContact (inherited from BasePermissionType)
IsFolderContactSpecified (inherited from BasePermissionType)
IsFolderOwner (inherited from BasePermissionType)
IsFolderOwnerSpecified (inherited from BasePermissionType)
IsFolderVisible (inherited from BasePermissionType)
IsFolderVisibleSpecified (inherited from BasePermissionType)
PermissionLevel
ReadItems
ReadItemsSpecified
UserId (inherited from BasePermissionType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PermissionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PermissionType Constructor

Initializes a new instance of the PermissionType class.

public PermissionType();

See Also

PermissionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PermissionType Properties

The properties of the PermissionType class are listed below. For a complete list of PermissionType class members, see the PermissionType Members topic.

Public Instance Properties

CanCreateItems (inherited from BasePermissionType)
CanCreateItemsSpecified (inherited from BasePermissionType)
CanCreateSubFolders (inherited from BasePermissionType)
CanCreateSubFoldersSpecified (inherited from BasePermissionType)
DeleteItems (inherited from BasePermissionType)
DeleteItemsSpecified (inherited from BasePermissionType)
EditItems (inherited from BasePermissionType)
EditItemsSpecified (inherited from BasePermissionType)
IsFolderContact (inherited from BasePermissionType)
IsFolderContactSpecified (inherited from BasePermissionType)
IsFolderOwner (inherited from BasePermissionType)
IsFolderOwnerSpecified (inherited from BasePermissionType)
IsFolderVisible (inherited from BasePermissionType)
IsFolderVisibleSpecified (inherited from BasePermissionType)
PermissionLevel
ReadItems
ReadItemsSpecified
UserId (inherited from BasePermissionType)

See Also

PermissionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PermissionLevel Property

Aspose.Email

PermissionType.PermissionLevel Property

public PermissionLevelType PermissionLevel {get; set;}

Remarks

See Also

PermissionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReadItems Property

Aspose.Email

PermissionType.ReadItems Property

public PermissionReadAccessType ReadItems {get; set;}

Remarks

See Also

PermissionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReadItemsSpecified Property

Aspose.Email

PermissionType.ReadItemsSpecified Property

public bool ReadItemsSpecified {get; set;}

Remarks

See Also

PermissionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PersonaAttributionType Class

For a list of all members of this type, see PersonaAttributionType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.PersonaAttributionType

public class PersonaAttributionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PersonaAttributionType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PersonaAttributionType Members

PersonaAttributionType overview

Public Instance Constructors

PersonaAttributionType Constructor Initializes a new instance of the PersonaAttributionType class.

Public Instance Properties

DisplayName
FolderId
Id
IsHidden
IsHiddenSpecified
IsQuickContact
IsQuickContactSpecified
IsWritable
IsWritableSpecified
SourceId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PersonaAttributionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PersonaAttributionType Constructor

Initializes a new instance of the PersonaAttributionType class.

public PersonaAttributionType();

See Also

PersonaAttributionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PersonaAttributionType Properties

The properties of the PersonaAttributionType class are listed below. For a complete list of PersonaAttributionType class members, see the PersonaAttributionType Members topic.

Public Instance Properties

DisplayName
FolderId
Id
IsHidden
IsHiddenSpecified
IsQuickContact
IsQuickContactSpecified
IsWritable
IsWritableSpecified
SourceId

See Also

PersonaAttributionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisplayName Property

Aspose.Email

PersonaAttributionType.DisplayName Property

public string DisplayName {get; set;}

Remarks

See Also

PersonaAttributionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FolderId Property

Aspose.Email

PersonaAttributionType.FolderId Property

public FolderIdType FolderId {get; set;}

Remarks

See Also

PersonaAttributionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Id Property

Aspose.Email

PersonaAttributionType.Id Property

public string Id {get; set;}

Remarks

See Also

PersonaAttributionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsHidden Property

Aspose.Email

PersonaAttributionType.IsHidden Property

public bool IsHidden {get; set;}

Remarks

See Also

PersonaAttributionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsHiddenSpecified Property

Aspose.Email

PersonaAttributionType.IsHiddenSpecified Property

public bool IsHiddenSpecified {get; set;}

Remarks

See Also

PersonaAttributionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsQuickContact Property

Aspose.Email

PersonaAttributionType.IsQuickContact Property

public bool IsQuickContact {get; set;}

Remarks

See Also

PersonaAttributionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsQuickContactSpecified Property

Aspose.Email

PersonaAttributionType.IsQuickContactSpecified Property

public bool IsQuickContactSpecified {get; set;}

Remarks

See Also

PersonaAttributionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsWritable Property

Aspose.Email

PersonaAttributionType.IsWritable Property

public bool IsWritable {get; set;}

Remarks

See Also

PersonaAttributionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsWritableSpecified Property

Aspose.Email

PersonaAttributionType.IsWritableSpecified Property

public bool IsWritableSpecified {get; set;}

Remarks

See Also

PersonaAttributionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SourceId Property

Aspose.Email

PersonaAttributionType.SourceId Property

public ItemIdType SourceId {get; set;}

Remarks

See Also

PersonaAttributionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PersonaPhoneNumberType Class

For a list of all members of this type, see PersonaPhoneNumberType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.PersonaPhoneNumberType

public class PersonaPhoneNumberType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PersonaPhoneNumberType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PersonaPhoneNumberType Members

PersonaPhoneNumberType overview

Public Instance Constructors

PersonaPhoneNumberType Constructor Initializes a new instance of the PersonaPhoneNumberType class.

Public Instance Properties

Number
Type

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PersonaPhoneNumberType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PersonaPhoneNumberType Constructor

Initializes a new instance of the PersonaPhoneNumberType class.

public PersonaPhoneNumberType();

See Also

PersonaPhoneNumberType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PersonaPhoneNumberType Properties

The properties of the PersonaPhoneNumberType class are listed below. For a complete list of PersonaPhoneNumberType class members, see the PersonaPhoneNumberType Members topic.

Public Instance Properties

Number
Type

See Also

PersonaPhoneNumberType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Number Property

Aspose.Email

PersonaPhoneNumberType.Number Property

public string Number {get; set;}

Remarks

See Also

PersonaPhoneNumberType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Type Property

Aspose.Email

PersonaPhoneNumberType.Type Property

public string Type {get; set;}

Remarks

See Also

PersonaPhoneNumberType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PersonaPostalAddressType Class

For a list of all members of this type, see PersonaPostalAddressType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.PersonaPostalAddressType

public class PersonaPostalAddressType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PersonaPostalAddressType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PersonaPostalAddressType Members

PersonaPostalAddressType overview

Public Instance Constructors

PersonaPostalAddressType Constructor Initializes a new instance of the PersonaPostalAddressType class.

Public Instance Properties

Accuracy
AccuracySpecified
Altitude
AltitudeAccuracy
AltitudeAccuracySpecified
AltitudeSpecified
City
Country
FormattedAddress
Latitude
LatitudeSpecified
LocationSource
LocationSourceSpecified
LocationUri
Longitude
LongitudeSpecified
PostalCode
PostOfficeBox
State
Street
Type

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PersonaPostalAddressType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PersonaPostalAddressType Constructor

Initializes a new instance of the PersonaPostalAddressType class.

public PersonaPostalAddressType();

See Also

PersonaPostalAddressType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PersonaPostalAddressType Properties

The properties of the PersonaPostalAddressType class are listed below. For a complete list of PersonaPostalAddressType class members, see the PersonaPostalAddressType Members topic.

Public Instance Properties

Accuracy
AccuracySpecified
Altitude
AltitudeAccuracy
AltitudeAccuracySpecified
AltitudeSpecified
City
Country
FormattedAddress
Latitude
LatitudeSpecified
LocationSource
LocationSourceSpecified
LocationUri
Longitude
LongitudeSpecified
PostalCode
PostOfficeBox
State
Street
Type

See Also

PersonaPostalAddressType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Accuracy Property

Aspose.Email

PersonaPostalAddressType.Accuracy Property

public double Accuracy {get; set;}

Remarks

See Also

PersonaPostalAddressType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AccuracySpecified Property

Aspose.Email

PersonaPostalAddressType.AccuracySpecified Property

public bool AccuracySpecified {get; set;}

Remarks

See Also

PersonaPostalAddressType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Altitude Property

Aspose.Email

PersonaPostalAddressType.Altitude Property

public double Altitude {get; set;}

Remarks

See Also

PersonaPostalAddressType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AltitudeAccuracy Property

Aspose.Email

PersonaPostalAddressType.AltitudeAccuracy Property

public double AltitudeAccuracy {get; set;}

Remarks

See Also

PersonaPostalAddressType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AltitudeAccuracySpecified Property

Aspose.Email

PersonaPostalAddressType.AltitudeAccuracySpecified Property

public bool AltitudeAccuracySpecified {get; set;}

Remarks

See Also

PersonaPostalAddressType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AltitudeSpecified Property

Aspose.Email

PersonaPostalAddressType.AltitudeSpecified Property

public bool AltitudeSpecified {get; set;}

Remarks

See Also

PersonaPostalAddressType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


City Property

Aspose.Email

PersonaPostalAddressType.City Property

public string City {get; set;}

Remarks

See Also

PersonaPostalAddressType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Country Property

Aspose.Email

PersonaPostalAddressType.Country Property

public string Country {get; set;}

Remarks

See Also

PersonaPostalAddressType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FormattedAddress Property

Aspose.Email

PersonaPostalAddressType.FormattedAddress Property

public string FormattedAddress {get; set;}

Remarks

See Also

PersonaPostalAddressType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Latitude Property

Aspose.Email

PersonaPostalAddressType.Latitude Property

public double Latitude {get; set;}

Remarks

See Also

PersonaPostalAddressType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


LatitudeSpecified Property

Aspose.Email

PersonaPostalAddressType.LatitudeSpecified Property

public bool LatitudeSpecified {get; set;}

Remarks

See Also

PersonaPostalAddressType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


LocationSource Property

Aspose.Email

PersonaPostalAddressType.LocationSource Property

public LocationSourceType LocationSource {get; set;}

Remarks

See Also

PersonaPostalAddressType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


LocationSourceSpecified Property

Aspose.Email

PersonaPostalAddressType.LocationSourceSpecified Property

public bool LocationSourceSpecified {get; set;}

Remarks

See Also

PersonaPostalAddressType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


LocationUri Property

Aspose.Email

PersonaPostalAddressType.LocationUri Property

public string LocationUri {get; set;}

Remarks

See Also

PersonaPostalAddressType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Longitude Property

Aspose.Email

PersonaPostalAddressType.Longitude Property

public double Longitude {get; set;}

Remarks

See Also

PersonaPostalAddressType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


LongitudeSpecified Property

Aspose.Email

PersonaPostalAddressType.LongitudeSpecified Property

public bool LongitudeSpecified {get; set;}

Remarks

See Also

PersonaPostalAddressType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PostalCode Property

Aspose.Email

PersonaPostalAddressType.PostalCode Property

public string PostalCode {get; set;}

Remarks

See Also

PersonaPostalAddressType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PostOfficeBox Property

Aspose.Email

PersonaPostalAddressType.PostOfficeBox Property

public string PostOfficeBox {get; set;}

Remarks

See Also

PersonaPostalAddressType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


State Property

Aspose.Email

PersonaPostalAddressType.State Property

public string State {get; set;}

Remarks

See Also

PersonaPostalAddressType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Street Property

Aspose.Email

PersonaPostalAddressType.Street Property

public string Street {get; set;}

Remarks

See Also

PersonaPostalAddressType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Type Property

Aspose.Email

PersonaPostalAddressType.Type Property

public string Type {get; set;}

Remarks

See Also

PersonaPostalAddressType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PersonaResponseShapeType Class

For a list of all members of this type, see PersonaResponseShapeType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.PersonaResponseShapeType

public class PersonaResponseShapeType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PersonaResponseShapeType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PersonaResponseShapeType Members

PersonaResponseShapeType overview

Public Instance Constructors

PersonaResponseShapeType Constructor Initializes a new instance of the PersonaResponseShapeType class.

Public Instance Properties

AdditionalProperties
BaseShape

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PersonaResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PersonaResponseShapeType Constructor

Initializes a new instance of the PersonaResponseShapeType class.

public PersonaResponseShapeType();

See Also

PersonaResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PersonaResponseShapeType Properties

The properties of the PersonaResponseShapeType class are listed below. For a complete list of PersonaResponseShapeType class members, see the PersonaResponseShapeType Members topic.

Public Instance Properties

AdditionalProperties
BaseShape

See Also

PersonaResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AdditionalProperties Property

Aspose.Email

PersonaResponseShapeType.AdditionalProperties Property

public BasePathToElementType[] AdditionalProperties {get; set;}

Remarks

See Also

PersonaResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseShape Property

Aspose.Email

PersonaResponseShapeType.BaseShape Property

public DefaultShapeNamesType BaseShape {get; set;}

Remarks

See Also

PersonaResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PersonaType Class

For a list of all members of this type, see PersonaType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.PersonaType

public class PersonaType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PersonaType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PersonaType Members

PersonaType overview

Public Instance Constructors

PersonaType Constructor Initializes a new instance of the PersonaType class.

Public Instance Properties

AssistantNames
AssistantPhoneNumbers
Attributions
Birthdays
Bodies
BusinessAddresses
BusinessHomePages
BusinessPhoneNumbers
BusinessPhoneNumbers2
CallbackPhones
CarPhones
Children
CompanyName
CompanyNames
CompanyNameSortKey
CreationTime
CreationTimeSpecified
Department
Departments
DisplayName
DisplayNameFirstLast
DisplayNameFirstLastHeader
DisplayNameFirstLastSortKey
DisplayNameLastFirst
DisplayNameLastFirstHeader
DisplayNameLastFirstSortKey
DisplayNamePrefix
DisplayNamePrefixes
DisplayNames
EmailAddress
EmailAddresses
Emails1
Emails2
Emails3
ExtendedProperties
FileAs
FileAses
FileAsId
FileAsIds
FolderIds
Generation
Generations
GivenName
GivenNames
Hobbies
HomeAddresses
HomeCity
HomeCitySortKey
HomeFaxes
HomePhones
HomePhones2
ImAddress
ImAddresses
ImAddresses2
ImAddresses3
Initials
Location
Locations
Managers
MiddleName
MiddleNames
MobilePhones
MobilePhones2
Nickname
Nicknames
OfficeLocations
OrganizationMainPhones
OtherAddresses
OtherFaxes
OtherPhones2
OtherTelephones
Pagers
PersonaId
PersonalHomePages
PersonaObjectStatus
PersonaType1
PhoneNumber
Professions
RadioPhones
RelevanceScore
RelevanceScoreSpecified
Schools
SpouseNames
Surname
Surnames
TelexNumbers
Title
Titles
TTYTDDPhoneNumbers
WeddingAnniversaries
WorkCity
WorkCitySortKey
WorkFaxes
YomiCompanyName
YomiCompanyNames
YomiFirstName
YomiFirstNames
YomiLastName
YomiLastNames

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PersonaType Constructor

Initializes a new instance of the PersonaType class.

public PersonaType();

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PersonaType Properties

The properties of the PersonaType class are listed below. For a complete list of PersonaType class members, see the PersonaType Members topic.

Public Instance Properties

AssistantNames
AssistantPhoneNumbers
Attributions
Birthdays
Bodies
BusinessAddresses
BusinessHomePages
BusinessPhoneNumbers
BusinessPhoneNumbers2
CallbackPhones
CarPhones
Children
CompanyName
CompanyNames
CompanyNameSortKey
CreationTime
CreationTimeSpecified
Department
Departments
DisplayName
DisplayNameFirstLast
DisplayNameFirstLastHeader
DisplayNameFirstLastSortKey
DisplayNameLastFirst
DisplayNameLastFirstHeader
DisplayNameLastFirstSortKey
DisplayNamePrefix
DisplayNamePrefixes
DisplayNames
EmailAddress
EmailAddresses
Emails1
Emails2
Emails3
ExtendedProperties
FileAs
FileAses
FileAsId
FileAsIds
FolderIds
Generation
Generations
GivenName
GivenNames
Hobbies
HomeAddresses
HomeCity
HomeCitySortKey
HomeFaxes
HomePhones
HomePhones2
ImAddress
ImAddresses
ImAddresses2
ImAddresses3
Initials
Location
Locations
Managers
MiddleName
MiddleNames
MobilePhones
MobilePhones2
Nickname
Nicknames
OfficeLocations
OrganizationMainPhones
OtherAddresses
OtherFaxes
OtherPhones2
OtherTelephones
Pagers
PersonaId
PersonalHomePages
PersonaObjectStatus
PersonaType1
PhoneNumber
Professions
RadioPhones
RelevanceScore
RelevanceScoreSpecified
Schools
SpouseNames
Surname
Surnames
TelexNumbers
Title
Titles
TTYTDDPhoneNumbers
WeddingAnniversaries
WorkCity
WorkCitySortKey
WorkFaxes
YomiCompanyName
YomiCompanyNames
YomiFirstName
YomiFirstNames
YomiLastName
YomiLastNames

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AssistantNames Property

Aspose.Email

PersonaType.AssistantNames Property

public StringAttributedValueType[] AssistantNames {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AssistantPhoneNumbers Property

Aspose.Email

PersonaType.AssistantPhoneNumbers Property

public PhoneNumberAttributedValueType[] AssistantPhoneNumbers {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Attributions Property

Aspose.Email

PersonaType.Attributions Property

public PersonaAttributionType[] Attributions {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Birthdays Property

Aspose.Email

PersonaType.Birthdays Property

public StringAttributedValueType[] Birthdays {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Bodies Property

Aspose.Email

PersonaType.Bodies Property

public BodyContentAttributedValueType[] Bodies {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BusinessAddresses Property

Aspose.Email

PersonaType.BusinessAddresses Property

public PostalAddressAttributedValueType[] BusinessAddresses {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BusinessHomePages Property

Aspose.Email

PersonaType.BusinessHomePages Property

public StringAttributedValueType[] BusinessHomePages {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BusinessPhoneNumbers Property

Aspose.Email

PersonaType.BusinessPhoneNumbers Property

public PhoneNumberAttributedValueType[] BusinessPhoneNumbers {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BusinessPhoneNumbers2 Property

Aspose.Email

PersonaType.BusinessPhoneNumbers2 Property

public PhoneNumberAttributedValueType[] BusinessPhoneNumbers2 {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CallbackPhones Property

Aspose.Email

PersonaType.CallbackPhones Property

public PhoneNumberAttributedValueType[] CallbackPhones {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CarPhones Property

Aspose.Email

PersonaType.CarPhones Property

public PhoneNumberAttributedValueType[] CarPhones {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Children Property

Aspose.Email

PersonaType.Children Property

public StringArrayAttributedValueType[] Children {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CompanyName Property

Aspose.Email

PersonaType.CompanyName Property

public string CompanyName {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CompanyNames Property

Aspose.Email

PersonaType.CompanyNames Property

public StringAttributedValueType[] CompanyNames {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CompanyNameSortKey Property

Aspose.Email

PersonaType.CompanyNameSortKey Property

public string CompanyNameSortKey {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreationTime Property

Aspose.Email

PersonaType.CreationTime Property

public DateTime CreationTime {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreationTimeSpecified Property

Aspose.Email

PersonaType.CreationTimeSpecified Property

public bool CreationTimeSpecified {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Department Property

Aspose.Email

PersonaType.Department Property

public string Department {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Departments Property

Aspose.Email

PersonaType.Departments Property

public StringAttributedValueType[] Departments {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisplayName Property

Aspose.Email

PersonaType.DisplayName Property

public string DisplayName {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisplayNameFirstLast Property

Aspose.Email

PersonaType.DisplayNameFirstLast Property

public string DisplayNameFirstLast {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisplayNameFirstLastHeader Property

Aspose.Email

PersonaType.DisplayNameFirstLastHeader Property

public string DisplayNameFirstLastHeader {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisplayNameFirstLastSortKey Property

Aspose.Email

PersonaType.DisplayNameFirstLastSortKey Property

public string DisplayNameFirstLastSortKey {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisplayNameLastFirst Property

Aspose.Email

PersonaType.DisplayNameLastFirst Property

public string DisplayNameLastFirst {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisplayNameLastFirstHeader Property

Aspose.Email

PersonaType.DisplayNameLastFirstHeader Property

public string DisplayNameLastFirstHeader {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisplayNameLastFirstSortKey Property

Aspose.Email

PersonaType.DisplayNameLastFirstSortKey Property

public string DisplayNameLastFirstSortKey {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisplayNamePrefix Property

Aspose.Email

PersonaType.DisplayNamePrefix Property

public string DisplayNamePrefix {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisplayNamePrefixes Property

Aspose.Email

PersonaType.DisplayNamePrefixes Property

public StringAttributedValueType[] DisplayNamePrefixes {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisplayNames Property

Aspose.Email

PersonaType.DisplayNames Property

public StringAttributedValueType[] DisplayNames {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EmailAddress Property

Aspose.Email

PersonaType.EmailAddress Property

public EmailAddressType EmailAddress {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EmailAddresses Property

Aspose.Email

PersonaType.EmailAddresses Property

public EmailAddressType[] EmailAddresses {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Emails1 Property

Aspose.Email

PersonaType.Emails1 Property

public EmailAddressAttributedValueType[] Emails1 {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Emails2 Property

Aspose.Email

PersonaType.Emails2 Property

public EmailAddressAttributedValueType[] Emails2 {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Emails3 Property

Aspose.Email

PersonaType.Emails3 Property

public EmailAddressAttributedValueType[] Emails3 {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExtendedProperties Property

Aspose.Email

PersonaType.ExtendedProperties Property

public ExtendedPropertyAttributedValueType[] ExtendedProperties {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FileAs Property

Aspose.Email

PersonaType.FileAs Property

public string FileAs {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FileAses Property

Aspose.Email

PersonaType.FileAses Property

public StringAttributedValueType[] FileAses {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FileAsId Property

Aspose.Email

PersonaType.FileAsId Property

public string FileAsId {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FileAsIds Property

Aspose.Email

PersonaType.FileAsIds Property

public StringAttributedValueType[] FileAsIds {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FolderIds Property

Aspose.Email

PersonaType.FolderIds Property

public FolderIdType[] FolderIds {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Generation Property

Aspose.Email

PersonaType.Generation Property

public string Generation {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Generations Property

Aspose.Email

PersonaType.Generations Property

public StringAttributedValueType[] Generations {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GivenName Property

Aspose.Email

PersonaType.GivenName Property

public string GivenName {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GivenNames Property

Aspose.Email

PersonaType.GivenNames Property

public StringAttributedValueType[] GivenNames {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Hobbies Property

Aspose.Email

PersonaType.Hobbies Property

public StringAttributedValueType[] Hobbies {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


HomeAddresses Property

Aspose.Email

PersonaType.HomeAddresses Property

public PostalAddressAttributedValueType[] HomeAddresses {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


HomeCity Property

Aspose.Email

PersonaType.HomeCity Property

public string HomeCity {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


HomeCitySortKey Property

Aspose.Email

PersonaType.HomeCitySortKey Property

public string HomeCitySortKey {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


HomeFaxes Property

Aspose.Email

PersonaType.HomeFaxes Property

public PhoneNumberAttributedValueType[] HomeFaxes {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


HomePhones Property

Aspose.Email

PersonaType.HomePhones Property

public PhoneNumberAttributedValueType[] HomePhones {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


HomePhones2 Property

Aspose.Email

PersonaType.HomePhones2 Property

public PhoneNumberAttributedValueType[] HomePhones2 {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ImAddress Property

Aspose.Email

PersonaType.ImAddress Property

public string ImAddress {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ImAddresses Property

Aspose.Email

PersonaType.ImAddresses Property

public StringAttributedValueType[] ImAddresses {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ImAddresses2 Property

Aspose.Email

PersonaType.ImAddresses2 Property

public StringAttributedValueType[] ImAddresses2 {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ImAddresses3 Property

Aspose.Email

PersonaType.ImAddresses3 Property

public StringAttributedValueType[] ImAddresses3 {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Initials Property

Aspose.Email

PersonaType.Initials Property

public StringAttributedValueType[] Initials {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Location Property

Aspose.Email

PersonaType.Location Property

public string Location {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Locations Property

Aspose.Email

PersonaType.Locations Property

public StringAttributedValueType[] Locations {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Managers Property

Aspose.Email

PersonaType.Managers Property

public StringAttributedValueType[] Managers {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MiddleName Property

Aspose.Email

PersonaType.MiddleName Property

public string MiddleName {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MiddleNames Property

Aspose.Email

PersonaType.MiddleNames Property

public StringAttributedValueType[] MiddleNames {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MobilePhones Property

Aspose.Email

PersonaType.MobilePhones Property

public PhoneNumberAttributedValueType[] MobilePhones {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MobilePhones2 Property

Aspose.Email

PersonaType.MobilePhones2 Property

public PhoneNumberAttributedValueType[] MobilePhones2 {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Nickname Property

Aspose.Email

PersonaType.Nickname Property

public string Nickname {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Nicknames Property

Aspose.Email

PersonaType.Nicknames Property

public StringAttributedValueType[] Nicknames {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OfficeLocations Property

Aspose.Email

PersonaType.OfficeLocations Property

public StringAttributedValueType[] OfficeLocations {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OrganizationMainPhones Property

Aspose.Email

PersonaType.OrganizationMainPhones Property

public PhoneNumberAttributedValueType[] OrganizationMainPhones {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OtherAddresses Property

Aspose.Email

PersonaType.OtherAddresses Property

public PostalAddressAttributedValueType[] OtherAddresses {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OtherFaxes Property

Aspose.Email

PersonaType.OtherFaxes Property

public PhoneNumberAttributedValueType[] OtherFaxes {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OtherPhones2 Property

Aspose.Email

PersonaType.OtherPhones2 Property

public PhoneNumberAttributedValueType[] OtherPhones2 {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OtherTelephones Property

Aspose.Email

PersonaType.OtherTelephones Property

public PhoneNumberAttributedValueType[] OtherTelephones {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Pagers Property

Aspose.Email

PersonaType.Pagers Property

public PhoneNumberAttributedValueType[] Pagers {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PersonaId Property

Aspose.Email

PersonaType.PersonaId Property

public ItemIdType PersonaId {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PersonalHomePages Property

Aspose.Email

PersonaType.PersonalHomePages Property

public StringAttributedValueType[] PersonalHomePages {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PersonaObjectStatus Property

Aspose.Email

PersonaType.PersonaObjectStatus Property

public string PersonaObjectStatus {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PersonaType1 Property

Aspose.Email

PersonaType.PersonaType1 Property

public string PersonaType1 {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PhoneNumber Property

Aspose.Email

PersonaType.PhoneNumber Property

public PersonaPhoneNumberType PhoneNumber {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Professions Property

Aspose.Email

PersonaType.Professions Property

public StringAttributedValueType[] Professions {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RadioPhones Property

Aspose.Email

PersonaType.RadioPhones Property

public PhoneNumberAttributedValueType[] RadioPhones {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RelevanceScore Property

Aspose.Email

PersonaType.RelevanceScore Property

public int RelevanceScore {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RelevanceScoreSpecified Property

Aspose.Email

PersonaType.RelevanceScoreSpecified Property

public bool RelevanceScoreSpecified {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Schools Property

Aspose.Email

PersonaType.Schools Property

public StringAttributedValueType[] Schools {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SpouseNames Property

Aspose.Email

PersonaType.SpouseNames Property

public StringAttributedValueType[] SpouseNames {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Surname Property

Aspose.Email

PersonaType.Surname Property

public string Surname {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Surnames Property

Aspose.Email

PersonaType.Surnames Property

public StringAttributedValueType[] Surnames {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TelexNumbers Property

Aspose.Email

PersonaType.TelexNumbers Property

public PhoneNumberAttributedValueType[] TelexNumbers {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Title Property

Aspose.Email

PersonaType.Title Property

public string Title {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Titles Property

Aspose.Email

PersonaType.Titles Property

public StringAttributedValueType[] Titles {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TTYTDDPhoneNumbers Property

Aspose.Email

PersonaType.TTYTDDPhoneNumbers Property

public PhoneNumberAttributedValueType[] TTYTDDPhoneNumbers {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


WeddingAnniversaries Property

Aspose.Email

PersonaType.WeddingAnniversaries Property

public StringAttributedValueType[] WeddingAnniversaries {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


WorkCity Property

Aspose.Email

PersonaType.WorkCity Property

public string WorkCity {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


WorkCitySortKey Property

Aspose.Email

PersonaType.WorkCitySortKey Property

public string WorkCitySortKey {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


WorkFaxes Property

Aspose.Email

PersonaType.WorkFaxes Property

public PhoneNumberAttributedValueType[] WorkFaxes {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


YomiCompanyName Property

Aspose.Email

PersonaType.YomiCompanyName Property

public string YomiCompanyName {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


YomiCompanyNames Property

Aspose.Email

PersonaType.YomiCompanyNames Property

public StringAttributedValueType[] YomiCompanyNames {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


YomiFirstName Property

Aspose.Email

PersonaType.YomiFirstName Property

public string YomiFirstName {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


YomiFirstNames Property

Aspose.Email

PersonaType.YomiFirstNames Property

public StringAttributedValueType[] YomiFirstNames {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


YomiLastName Property

Aspose.Email

PersonaType.YomiLastName Property

public string YomiLastName {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


YomiLastNames Property

Aspose.Email

PersonaType.YomiLastNames Property

public StringAttributedValueType[] YomiLastNames {get; set;}

Remarks

See Also

PersonaType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PhoneCallIdType Class

For a list of all members of this type, see PhoneCallIdType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.PhoneCallIdType

public class PhoneCallIdType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PhoneCallIdType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PhoneCallIdType Members

PhoneCallIdType overview

Public Instance Constructors

PhoneCallIdType Constructor Initializes a new instance of the PhoneCallIdType class.

Public Instance Properties

Id

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PhoneCallIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PhoneCallIdType Constructor

Initializes a new instance of the PhoneCallIdType class.

public PhoneCallIdType();

See Also

PhoneCallIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PhoneCallIdType Properties

The properties of the PhoneCallIdType class are listed below. For a complete list of PhoneCallIdType class members, see the PhoneCallIdType Members topic.

Public Instance Properties

Id

See Also

PhoneCallIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Id Property

Aspose.Email

PhoneCallIdType.Id Property

public string Id {get; set;}

Remarks

See Also

PhoneCallIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PhoneCallInformationType Class

For a list of all members of this type, see PhoneCallInformationType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.PhoneCallInformationType

public class PhoneCallInformationType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PhoneCallInformationType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PhoneCallInformationType Members

PhoneCallInformationType overview

Public Instance Constructors

PhoneCallInformationType Constructor Initializes a new instance of the PhoneCallInformationType class.

Public Instance Properties

ConnectionFailureCause
PhoneCallState
SIPResponseCode
SIPResponseCodeSpecified
SIPResponseText

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PhoneCallInformationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PhoneCallInformationType Constructor

Initializes a new instance of the PhoneCallInformationType class.

public PhoneCallInformationType();

See Also

PhoneCallInformationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PhoneCallInformationType Properties

The properties of the PhoneCallInformationType class are listed below. For a complete list of PhoneCallInformationType class members, see the PhoneCallInformationType Members topic.

Public Instance Properties

ConnectionFailureCause
PhoneCallState
SIPResponseCode
SIPResponseCodeSpecified
SIPResponseText

See Also

PhoneCallInformationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConnectionFailureCause Property

Aspose.Email

PhoneCallInformationType.ConnectionFailureCause Property

public ConnectionFailureCauseType ConnectionFailureCause {get; set;}

Remarks

See Also

PhoneCallInformationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PhoneCallState Property

Aspose.Email

PhoneCallInformationType.PhoneCallState Property

public PhoneCallStateType PhoneCallState {get; set;}

Remarks

See Also

PhoneCallInformationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SIPResponseCode Property

Aspose.Email

PhoneCallInformationType.SIPResponseCode Property

public int SIPResponseCode {get; set;}

Remarks

See Also

PhoneCallInformationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SIPResponseCodeSpecified Property

Aspose.Email

PhoneCallInformationType.SIPResponseCodeSpecified Property

public bool SIPResponseCodeSpecified {get; set;}

Remarks

See Also

PhoneCallInformationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SIPResponseText Property

Aspose.Email

PhoneCallInformationType.SIPResponseText Property

public string SIPResponseText {get; set;}

Remarks

See Also

PhoneCallInformationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PhoneCallStateType Enumeration

public enum PhoneCallStateType

Remarks

Members

Member Name | Description | Value
Idle |  | 0
Connecting |  | 1
Alerted |  | 2
Connected |  | 3
Disconnected |  | 4
Incoming |  | 5
Transferring |  | 6
Forwarding |  | 7

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PhoneEntityType Class

For a list of all members of this type, see PhoneEntityType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.EntityType
Aspose.Email.Exchange.Schema.Exchange_2013.PhoneEntityType

public class PhoneEntityType : EntityType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PhoneEntityType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PhoneEntityType Members

PhoneEntityType overview

Public Instance Constructors

PhoneEntityType Constructor Initializes a new instance of the PhoneEntityType class.

Public Instance Properties

OriginalPhoneString
PhoneString
Position (inherited from EntityType)
Type

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PhoneEntityType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PhoneEntityType Constructor

Initializes a new instance of the PhoneEntityType class.

public PhoneEntityType();

See Also

PhoneEntityType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PhoneEntityType Properties

The properties of the PhoneEntityType class are listed below. For a complete list of PhoneEntityType class members, see the PhoneEntityType Members topic.

Public Instance Properties

OriginalPhoneString
PhoneString
Position (inherited from EntityType)
Type

See Also

PhoneEntityType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OriginalPhoneString Property

Aspose.Email

PhoneEntityType.OriginalPhoneString Property

public string OriginalPhoneString {get; set;}

Remarks

See Also

PhoneEntityType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PhoneString Property

Aspose.Email

PhoneEntityType.PhoneString Property

public string PhoneString {get; set;}

Remarks

See Also

PhoneEntityType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Type Property

Aspose.Email

PhoneEntityType.Type Property

public string Type {get; set;}

Remarks

See Also

PhoneEntityType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PhoneNumberAttributedValueType Class

For a list of all members of this type, see PhoneNumberAttributedValueType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.PhoneNumberAttributedValueType

public class PhoneNumberAttributedValueType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PhoneNumberAttributedValueType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PhoneNumberAttributedValueType Members

PhoneNumberAttributedValueType overview

Public Instance Constructors

PhoneNumberAttributedValueType Constructor Initializes a new instance of the PhoneNumberAttributedValueType class.

Public Instance Properties

Attributions
Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PhoneNumberAttributedValueType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PhoneNumberAttributedValueType Constructor

Initializes a new instance of the PhoneNumberAttributedValueType class.

public PhoneNumberAttributedValueType();

See Also

PhoneNumberAttributedValueType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PhoneNumberAttributedValueType Properties

The properties of the PhoneNumberAttributedValueType class are listed below. For a complete list of PhoneNumberAttributedValueType class members, see the PhoneNumberAttributedValueType Members topic.

Public Instance Properties

Attributions
Value

See Also

PhoneNumberAttributedValueType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Attributions Property

Aspose.Email

PhoneNumberAttributedValueType.Attributions Property

public string[] Attributions {get; set;}

Remarks

See Also

PhoneNumberAttributedValueType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Value Property

Aspose.Email

PhoneNumberAttributedValueType.Value Property

public PersonaPhoneNumberType Value {get; set;}

Remarks

See Also

PhoneNumberAttributedValueType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PhoneNumberDictionaryEntryType Class

For a list of all members of this type, see PhoneNumberDictionaryEntryType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.PhoneNumberDictionaryEntryType

public class PhoneNumberDictionaryEntryType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PhoneNumberDictionaryEntryType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PhoneNumberDictionaryEntryType Members

PhoneNumberDictionaryEntryType overview

Public Instance Constructors

PhoneNumberDictionaryEntryType Constructor Initializes a new instance of the PhoneNumberDictionaryEntryType class.

Public Instance Properties

Key
Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PhoneNumberDictionaryEntryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PhoneNumberDictionaryEntryType Constructor

Initializes a new instance of the PhoneNumberDictionaryEntryType class.

public PhoneNumberDictionaryEntryType();

See Also

PhoneNumberDictionaryEntryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PhoneNumberDictionaryEntryType Properties

The properties of the PhoneNumberDictionaryEntryType class are listed below. For a complete list of PhoneNumberDictionaryEntryType class members, see the PhoneNumberDictionaryEntryType Members topic.

Public Instance Properties

Key
Value

See Also

PhoneNumberDictionaryEntryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Key Property

Aspose.Email

PhoneNumberDictionaryEntryType.Key Property

public PhoneNumberKeyType Key {get; set;}

Remarks

See Also

PhoneNumberDictionaryEntryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Value Property

Aspose.Email

PhoneNumberDictionaryEntryType.Value Property

public string Value {get; set;}

Remarks

See Also

PhoneNumberDictionaryEntryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PhoneNumberKeyType Enumeration

public enum PhoneNumberKeyType

Remarks

Members

Member Name | Description | Value
AssistantPhone |  | 0
BusinessFax |  | 1
BusinessPhone |  | 2
BusinessPhone2 |  | 3
Callback |  | 4
CarPhone |  | 5
CompanyMainPhone |  | 6
HomeFax |  | 7
HomePhone |  | 8
HomePhone2 |  | 9
Isdn |  | 10
MobilePhone |  | 11
OtherFax |  | 12
OtherTelephone |  | 13
Pager |  | 14
PrimaryPhone |  | 15
RadioPhone |  | 16
Telex |  | 17
TtyTddPhone |  | 18

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PhoneType Class

For a list of all members of this type, see PhoneType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.PhoneType

public class PhoneType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PhoneType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PhoneType Members

PhoneType overview

Public Instance Constructors

PhoneType Constructor Initializes a new instance of the PhoneType class.

Public Instance Properties

OriginalPhoneString
PhoneString
Type

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PhoneType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PhoneType Constructor

Initializes a new instance of the PhoneType class.

public PhoneType();

See Also

PhoneType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PhoneType Properties

The properties of the PhoneType class are listed below. For a complete list of PhoneType class members, see the PhoneType Members topic.

Public Instance Properties

OriginalPhoneString
PhoneString
Type

See Also

PhoneType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OriginalPhoneString Property

Aspose.Email

PhoneType.OriginalPhoneString Property

public string OriginalPhoneString {get; set;}

Remarks

See Also

PhoneType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PhoneString Property

Aspose.Email

PhoneType.PhoneString Property

public string PhoneString {get; set;}

Remarks

See Also

PhoneType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Type Property

Aspose.Email

PhoneType.Type Property

public string Type {get; set;}

Remarks

See Also

PhoneType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PhysicalAddressDictionaryEntryType Class

For a list of all members of this type, see PhysicalAddressDictionaryEntryType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.PhysicalAddressDictionaryEntryType

public class PhysicalAddressDictionaryEntryType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PhysicalAddressDictionaryEntryType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PhysicalAddressDictionaryEntryType Members

PhysicalAddressDictionaryEntryType overview

Public Instance Constructors

PhysicalAddressDictionaryEntryType Constructor Initializes a new instance of the PhysicalAddressDictionaryEntryType class.

Public Instance Properties

City
CountryOrRegion
Key
PostalCode
State
Street

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PhysicalAddressDictionaryEntryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PhysicalAddressDictionaryEntryType Constructor

Initializes a new instance of the PhysicalAddressDictionaryEntryType class.

public PhysicalAddressDictionaryEntryType();

See Also

PhysicalAddressDictionaryEntryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PhysicalAddressDictionaryEntryType Properties

The properties of the PhysicalAddressDictionaryEntryType class are listed below. For a complete list of PhysicalAddressDictionaryEntryType class members, see the PhysicalAddressDictionaryEntryType Members topic.

Public Instance Properties

City
CountryOrRegion
Key
PostalCode
State
Street

See Also

PhysicalAddressDictionaryEntryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


City Property

Aspose.Email

PhysicalAddressDictionaryEntryType.City Property

public string City {get; set;}

Remarks

See Also

PhysicalAddressDictionaryEntryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CountryOrRegion Property

Aspose.Email

PhysicalAddressDictionaryEntryType.CountryOrRegion Property

public string CountryOrRegion {get; set;}

Remarks

See Also

PhysicalAddressDictionaryEntryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Key Property

Aspose.Email

PhysicalAddressDictionaryEntryType.Key Property

public PhysicalAddressKeyType Key {get; set;}

Remarks

See Also

PhysicalAddressDictionaryEntryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PostalCode Property

Aspose.Email

PhysicalAddressDictionaryEntryType.PostalCode Property

public string PostalCode {get; set;}

Remarks

See Also

PhysicalAddressDictionaryEntryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


State Property

Aspose.Email

PhysicalAddressDictionaryEntryType.State Property

public string State {get; set;}

Remarks

See Also

PhysicalAddressDictionaryEntryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Street Property

Aspose.Email

PhysicalAddressDictionaryEntryType.Street Property

public string Street {get; set;}

Remarks

See Also

PhysicalAddressDictionaryEntryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PhysicalAddressIndexType Enumeration

public enum PhysicalAddressIndexType

Remarks

Members

Member Name | Description | Value
None |  | 0
Business |  | 1
Home |  | 2
Other |  | 3

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PhysicalAddressKeyType Enumeration

public enum PhysicalAddressKeyType

Remarks

Members

Member Name | Description | Value
Business |  | 0
Home |  | 1
Other |  | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PinInfoType Class

For a list of all members of this type, see PinInfoType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.PinInfoType

public class PinInfoType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PinInfoType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PinInfoType Members

PinInfoType overview

Public Instance Constructors

PinInfoType Constructor Initializes a new instance of the PinInfoType class.

Public Instance Properties

FirstTimeUser
IsValid
LockedOut
PIN
PinExpired

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PinInfoType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PinInfoType Constructor

Initializes a new instance of the PinInfoType class.

public PinInfoType();

See Also

PinInfoType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PinInfoType Properties

The properties of the PinInfoType class are listed below. For a complete list of PinInfoType class members, see the PinInfoType Members topic.

Public Instance Properties

FirstTimeUser
IsValid
LockedOut
PIN
PinExpired

See Also

PinInfoType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FirstTimeUser Property

Aspose.Email

PinInfoType.FirstTimeUser Property

public bool FirstTimeUser {get; set;}

Remarks

See Also

PinInfoType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsValid Property

Aspose.Email

PinInfoType.IsValid Property

public bool IsValid {get; set;}

Remarks

See Also

PinInfoType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


LockedOut Property

Aspose.Email

PinInfoType.LockedOut Property

public bool LockedOut {get; set;}

Remarks

See Also

PinInfoType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PIN Property

Aspose.Email

PinInfoType.PIN Property

public string PIN {get; set;}

Remarks

See Also

PinInfoType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PinExpired Property

Aspose.Email

PinInfoType.PinExpired Property

public bool PinExpired {get; set;}

Remarks

See Also

PinInfoType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PlayOnPhoneCompletedEventArgs Class

For a list of all members of this type, see PlayOnPhoneCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.PlayOnPhoneCompletedEventArgs

public class PlayOnPhoneCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PlayOnPhoneCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PlayOnPhoneCompletedEventArgs Members

PlayOnPhoneCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

PlayOnPhoneCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PlayOnPhoneCompletedEventArgs Properties

The properties of the PlayOnPhoneCompletedEventArgs class are listed below. For a complete list of PlayOnPhoneCompletedEventArgs class members, see the PlayOnPhoneCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

PlayOnPhoneCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

PlayOnPhoneCompletedEventArgs.Result Property

public PlayOnPhoneResponseMessageType Result {get;}

Remarks

See Also

PlayOnPhoneCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PlayOnPhoneCompletedEventHandler Delegate

public delegate void PlayOnPhoneCompletedEventHandler(
object sender,
PlayOnPhoneCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PlayOnPhoneResponseMessageType Class

For a list of all members of this type, see PlayOnPhoneResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.PlayOnPhoneResponseMessageType

public class PlayOnPhoneResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PlayOnPhoneResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PlayOnPhoneResponseMessageType Members

PlayOnPhoneResponseMessageType overview

Public Instance Constructors

PlayOnPhoneResponseMessageType Constructor Initializes a new instance of the PlayOnPhoneResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
PhoneCallId
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PlayOnPhoneResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PlayOnPhoneResponseMessageType Constructor

Initializes a new instance of the PlayOnPhoneResponseMessageType class.

public PlayOnPhoneResponseMessageType();

See Also

PlayOnPhoneResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PlayOnPhoneResponseMessageType Properties

The properties of the PlayOnPhoneResponseMessageType class are listed below. For a complete list of PlayOnPhoneResponseMessageType class members, see the PlayOnPhoneResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
PhoneCallId
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

PlayOnPhoneResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PhoneCallId Property

Aspose.Email

PlayOnPhoneResponseMessageType.PhoneCallId Property

public PhoneCallIdType PhoneCallId {get; set;}

Remarks

See Also

PlayOnPhoneResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PlayOnPhoneType Class

For a list of all members of this type, see PlayOnPhoneType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.PlayOnPhoneType

public class PlayOnPhoneType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PlayOnPhoneType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PlayOnPhoneType Members

PlayOnPhoneType overview

Public Instance Constructors

PlayOnPhoneType Constructor Initializes a new instance of the PlayOnPhoneType class.

Public Instance Properties

DialString
ItemId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PlayOnPhoneType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PlayOnPhoneType Constructor

Initializes a new instance of the PlayOnPhoneType class.

public PlayOnPhoneType();

See Also

PlayOnPhoneType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PlayOnPhoneType Properties

The properties of the PlayOnPhoneType class are listed below. For a complete list of PlayOnPhoneType class members, see the PlayOnPhoneType Members topic.

Public Instance Properties

DialString
ItemId

See Also

PlayOnPhoneType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DialString Property

Aspose.Email

PlayOnPhoneType.DialString Property

public string DialString {get; set;}

Remarks

See Also

PlayOnPhoneType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemId Property

Aspose.Email

PlayOnPhoneType.ItemId Property

public ItemIdType ItemId {get; set;}

Remarks

See Also

PlayOnPhoneType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PolicyNudgeRulesServiceConfiguration Class

For a list of all members of this type, see PolicyNudgeRulesServiceConfiguration Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.PolicyNudgeRulesServiceConfiguration

public class PolicyNudgeRulesServiceConfiguration

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PolicyNudgeRulesServiceConfiguration Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PolicyNudgeRulesServiceConfiguration Members

PolicyNudgeRulesServiceConfiguration overview

Public Instance Constructors

PolicyNudgeRulesServiceConfiguration Constructor Initializes a new instance of the PolicyNudgeRulesServiceConfiguration class.

Public Instance Properties

Any

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PolicyNudgeRulesServiceConfiguration Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PolicyNudgeRulesServiceConfiguration Constructor

Initializes a new instance of the PolicyNudgeRulesServiceConfiguration class.

public PolicyNudgeRulesServiceConfiguration();

See Also

PolicyNudgeRulesServiceConfiguration Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PolicyNudgeRulesServiceConfiguration Properties

The properties of the PolicyNudgeRulesServiceConfiguration class are listed below. For a complete list of PolicyNudgeRulesServiceConfiguration class members, see the PolicyNudgeRulesServiceConfiguration Members topic.

Public Instance Properties

Any

See Also

PolicyNudgeRulesServiceConfiguration Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Any Property

Aspose.Email

PolicyNudgeRulesServiceConfiguration.Any Property

public XmlElement[] Any {get; set;}

Remarks

See Also

PolicyNudgeRulesServiceConfiguration Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PostalAddressAttributedValueType Class

For a list of all members of this type, see PostalAddressAttributedValueType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.PostalAddressAttributedValueType

public class PostalAddressAttributedValueType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PostalAddressAttributedValueType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PostalAddressAttributedValueType Members

PostalAddressAttributedValueType overview

Public Instance Constructors

PostalAddressAttributedValueType Constructor Initializes a new instance of the PostalAddressAttributedValueType class.

Public Instance Properties

Attributions
Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PostalAddressAttributedValueType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PostalAddressAttributedValueType Constructor

Initializes a new instance of the PostalAddressAttributedValueType class.

public PostalAddressAttributedValueType();

See Also

PostalAddressAttributedValueType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PostalAddressAttributedValueType Properties

The properties of the PostalAddressAttributedValueType class are listed below. For a complete list of PostalAddressAttributedValueType class members, see the PostalAddressAttributedValueType Members topic.

Public Instance Properties

Attributions
Value

See Also

PostalAddressAttributedValueType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Attributions Property

Aspose.Email

PostalAddressAttributedValueType.Attributions Property

public string[] Attributions {get; set;}

Remarks

See Also

PostalAddressAttributedValueType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Value Property

Aspose.Email

PostalAddressAttributedValueType.Value Property

public PersonaPostalAddressType Value {get; set;}

Remarks

See Also

PostalAddressAttributedValueType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PostItemType Class

For a list of all members of this type, see PostItemType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ItemType
Aspose.Email.Exchange.Schema.Exchange_2013.PostItemType

public class PostItemType : ItemType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PostItemType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PostItemType Members

PostItemType overview

Public Instance Constructors

PostItemType Constructor Initializes a new instance of the PostItemType class.

Public Instance Properties

ArchiveTag (inherited from ItemType)
Attachments (inherited from ItemType)
BlockStatus (inherited from ItemType)
BlockStatusSpecified (inherited from ItemType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
ConversationId (inherited from ItemType)
ConversationIndex
ConversationTopic
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
EntityExtractionResult (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
Flag (inherited from ItemType)
From
GroupingAction (inherited from ItemType)
GroupingActionSpecified (inherited from ItemType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBlockedImages (inherited from ItemType)
HasBlockedImagesSpecified (inherited from ItemType)
IconIndex (inherited from ItemType)
IconIndexSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InstanceKey (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead
IsReadSpecified
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
NextPredictedAction (inherited from ItemType)
NextPredictedActionSpecified (inherited from ItemType)
NormalizedBody (inherited from ItemType)
ParentFolderId (inherited from ItemType)
PolicyTag (inherited from ItemType)
PostedTime
PostedTimeSpecified
Preview (inherited from ItemType)
References
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReminderNextTime (inherited from ItemType)
ReminderNextTimeSpecified (inherited from ItemType)
ResponseObjects (inherited from ItemType)
RetentionDate (inherited from ItemType)
RetentionDateSpecified (inherited from ItemType)
RightsManagementLicenseData (inherited from ItemType)
Sender
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
StoreEntryId (inherited from ItemType)
Subject (inherited from ItemType)
TextBody (inherited from ItemType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PostItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PostItemType Constructor

Initializes a new instance of the PostItemType class.

public PostItemType();

See Also

PostItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PostItemType Properties

The properties of the PostItemType class are listed below. For a complete list of PostItemType class members, see the PostItemType Members topic.

Public Instance Properties

ArchiveTag (inherited from ItemType)
Attachments (inherited from ItemType)
BlockStatus (inherited from ItemType)
BlockStatusSpecified (inherited from ItemType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
ConversationId (inherited from ItemType)
ConversationIndex
ConversationTopic
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
EntityExtractionResult (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
Flag (inherited from ItemType)
From
GroupingAction (inherited from ItemType)
GroupingActionSpecified (inherited from ItemType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBlockedImages (inherited from ItemType)
HasBlockedImagesSpecified (inherited from ItemType)
IconIndex (inherited from ItemType)
IconIndexSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InstanceKey (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead
IsReadSpecified
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
NextPredictedAction (inherited from ItemType)
NextPredictedActionSpecified (inherited from ItemType)
NormalizedBody (inherited from ItemType)
ParentFolderId (inherited from ItemType)
PolicyTag (inherited from ItemType)
PostedTime
PostedTimeSpecified
Preview (inherited from ItemType)
References
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReminderNextTime (inherited from ItemType)
ReminderNextTimeSpecified (inherited from ItemType)
ResponseObjects (inherited from ItemType)
RetentionDate (inherited from ItemType)
RetentionDateSpecified (inherited from ItemType)
RightsManagementLicenseData (inherited from ItemType)
Sender
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
StoreEntryId (inherited from ItemType)
Subject (inherited from ItemType)
TextBody (inherited from ItemType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

See Also

PostItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConversationIndex Property

Aspose.Email

PostItemType.ConversationIndex Property

public byte[] ConversationIndex {get; set;}

Remarks

See Also

PostItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConversationTopic Property

Aspose.Email

PostItemType.ConversationTopic Property

public string ConversationTopic {get; set;}

Remarks

See Also

PostItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


From Property

Aspose.Email

PostItemType.From Property

public SingleRecipientType From {get; set;}

Remarks

See Also

PostItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InternetMessageId Property

Aspose.Email

PostItemType.InternetMessageId Property

public string InternetMessageId {get; set;}

Remarks

See Also

PostItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsRead Property

Aspose.Email

PostItemType.IsRead Property

public bool IsRead {get; set;}

Remarks

See Also

PostItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsReadSpecified Property

Aspose.Email

PostItemType.IsReadSpecified Property

public bool IsReadSpecified {get; set;}

Remarks

See Also

PostItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PostedTime Property

Aspose.Email

PostItemType.PostedTime Property

public DateTime PostedTime {get; set;}

Remarks

See Also

PostItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PostedTimeSpecified Property

Aspose.Email

PostItemType.PostedTimeSpecified Property

public bool PostedTimeSpecified {get; set;}

Remarks

See Also

PostItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


References Property

Aspose.Email

PostItemType.References Property

public string References {get; set;}

Remarks

See Also

PostItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Sender Property

Aspose.Email

PostItemType.Sender Property

public SingleRecipientType Sender {get; set;}

Remarks

See Also

PostItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PostReplyItemBaseType Class

For a list of all members of this type, see PostReplyItemBaseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ItemType
Aspose.Email.Exchange.Schema.Exchange_2013.MessageType
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseObjectCoreType
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseObjectType
Aspose.Email.Exchange.Schema.Exchange_2013.PostReplyItemBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.PostReplyItemType

public class PostReplyItemBaseType : ResponseObjectType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PostReplyItemBaseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PostReplyItemBaseType Members

PostReplyItemBaseType overview

Public Instance Constructors

PostReplyItemBaseType Constructor Initializes a new instance of the PostReplyItemBaseType class.

Public Instance Properties

ArchiveTag (inherited from ItemType)
Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
BlockStatus (inherited from ItemType)
BlockStatusSpecified (inherited from ItemType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
EntityExtractionResult (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
Flag (inherited from ItemType)
From (inherited from MessageType)
GroupingAction (inherited from ItemType)
GroupingActionSpecified (inherited from ItemType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBlockedImages (inherited from ItemType)
HasBlockedImagesSpecified (inherited from ItemType)
IconIndex (inherited from ItemType)
IconIndexSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InstanceKey (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
NextPredictedAction (inherited from ItemType)
NextPredictedActionSpecified (inherited from ItemType)
NormalizedBody (inherited from ItemType)
ObjectName (inherited from ResponseObjectType)
ParentFolderId (inherited from ItemType)
PolicyTag (inherited from ItemType)
Preview (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
ReferenceItemId (inherited from ResponseObjectCoreType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReminderNextTime (inherited from ItemType)
ReminderNextTimeSpecified (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
RetentionDate (inherited from ItemType)
RetentionDateSpecified (inherited from ItemType)
RightsManagementLicenseData (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
StoreEntryId (inherited from ItemType)
Subject (inherited from ItemType)
TextBody (inherited from ItemType)
ToRecipients (inherited from MessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PostReplyItemBaseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PostReplyItemBaseType Constructor

Initializes a new instance of the PostReplyItemBaseType class.

public PostReplyItemBaseType();

See Also

PostReplyItemBaseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PostReplyItemType Class

For a list of all members of this type, see PostReplyItemType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ItemType
Aspose.Email.Exchange.Schema.Exchange_2013.MessageType
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseObjectCoreType
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseObjectType
Aspose.Email.Exchange.Schema.Exchange_2013.PostReplyItemBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.PostReplyItemType

public class PostReplyItemType : PostReplyItemBaseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PostReplyItemType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PostReplyItemType Members

PostReplyItemType overview

Public Instance Constructors

PostReplyItemType Constructor Initializes a new instance of the PostReplyItemType class.

Public Instance Properties

ArchiveTag (inherited from ItemType)
Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
BlockStatus (inherited from ItemType)
BlockStatusSpecified (inherited from ItemType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
EntityExtractionResult (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
Flag (inherited from ItemType)
From (inherited from MessageType)
GroupingAction (inherited from ItemType)
GroupingActionSpecified (inherited from ItemType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBlockedImages (inherited from ItemType)
HasBlockedImagesSpecified (inherited from ItemType)
IconIndex (inherited from ItemType)
IconIndexSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InstanceKey (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
NewBodyContent
NextPredictedAction (inherited from ItemType)
NextPredictedActionSpecified (inherited from ItemType)
NormalizedBody (inherited from ItemType)
ObjectName (inherited from ResponseObjectType)
ParentFolderId (inherited from ItemType)
PolicyTag (inherited from ItemType)
Preview (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
ReferenceItemId (inherited from ResponseObjectCoreType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReminderNextTime (inherited from ItemType)
ReminderNextTimeSpecified (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
RetentionDate (inherited from ItemType)
RetentionDateSpecified (inherited from ItemType)
RightsManagementLicenseData (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
StoreEntryId (inherited from ItemType)
Subject (inherited from ItemType)
TextBody (inherited from ItemType)
ToRecipients (inherited from MessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PostReplyItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PostReplyItemType Constructor

Initializes a new instance of the PostReplyItemType class.

public PostReplyItemType();

See Also

PostReplyItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PostReplyItemType Properties

The properties of the PostReplyItemType class are listed below. For a complete list of PostReplyItemType class members, see the PostReplyItemType Members topic.

Public Instance Properties

ArchiveTag (inherited from ItemType)
Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
BlockStatus (inherited from ItemType)
BlockStatusSpecified (inherited from ItemType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
EntityExtractionResult (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
Flag (inherited from ItemType)
From (inherited from MessageType)
GroupingAction (inherited from ItemType)
GroupingActionSpecified (inherited from ItemType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBlockedImages (inherited from ItemType)
HasBlockedImagesSpecified (inherited from ItemType)
IconIndex (inherited from ItemType)
IconIndexSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InstanceKey (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
NewBodyContent
NextPredictedAction (inherited from ItemType)
NextPredictedActionSpecified (inherited from ItemType)
NormalizedBody (inherited from ItemType)
ObjectName (inherited from ResponseObjectType)
ParentFolderId (inherited from ItemType)
PolicyTag (inherited from ItemType)
Preview (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
ReferenceItemId (inherited from ResponseObjectCoreType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReminderNextTime (inherited from ItemType)
ReminderNextTimeSpecified (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
RetentionDate (inherited from ItemType)
RetentionDateSpecified (inherited from ItemType)
RightsManagementLicenseData (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
StoreEntryId (inherited from ItemType)
Subject (inherited from ItemType)
TextBody (inherited from ItemType)
ToRecipients (inherited from MessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

See Also

PostReplyItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NewBodyContent Property

Aspose.Email

PostReplyItemType.NewBodyContent Property

public BodyType NewBodyContent {get; set;}

Remarks

See Also

PostReplyItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PredictedMessageActionType Enumeration

public enum PredictedMessageActionType

Remarks

Members

Member Name | Description | Value
None |  | 0
Respond |  | 1
FollowUp |  | 2
MoveToFolder |  | 3
Delete |  | 4
Read |  | 5
Ignore |  | 6

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PresentersType Enumeration

public enum PresentersType

Remarks

Members

Member Name | Description | Value
Disabled |  | 0
Internal |  | 1
Everyone |  | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PreviewItemBaseShapeType Enumeration

public enum PreviewItemBaseShapeType

Remarks

Members

Member Name | Description | Value
Default |  | 0
Compact |  | 1

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PreviewItemMailboxType Class

For a list of all members of this type, see PreviewItemMailboxType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.PreviewItemMailboxType

public class PreviewItemMailboxType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PreviewItemMailboxType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PreviewItemMailboxType Members

PreviewItemMailboxType overview

Public Instance Constructors

PreviewItemMailboxType Constructor Initializes a new instance of the PreviewItemMailboxType class.

Public Instance Properties

MailboxId
PrimarySmtpAddress

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PreviewItemMailboxType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PreviewItemMailboxType Constructor

Initializes a new instance of the PreviewItemMailboxType class.

public PreviewItemMailboxType();

See Also

PreviewItemMailboxType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PreviewItemMailboxType Properties

The properties of the PreviewItemMailboxType class are listed below. For a complete list of PreviewItemMailboxType class members, see the PreviewItemMailboxType Members topic.

Public Instance Properties

MailboxId
PrimarySmtpAddress

See Also

PreviewItemMailboxType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxId Property

Aspose.Email

PreviewItemMailboxType.MailboxId Property

public string MailboxId {get; set;}

Remarks

See Also

PreviewItemMailboxType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PrimarySmtpAddress Property

Aspose.Email

PreviewItemMailboxType.PrimarySmtpAddress Property

public string PrimarySmtpAddress {get; set;}

Remarks

See Also

PreviewItemMailboxType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PreviewItemResponseShapeType Class

For a list of all members of this type, see PreviewItemResponseShapeType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.PreviewItemResponseShapeType

public class PreviewItemResponseShapeType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PreviewItemResponseShapeType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PreviewItemResponseShapeType Members

PreviewItemResponseShapeType overview

Public Instance Constructors

PreviewItemResponseShapeType Constructor Initializes a new instance of the PreviewItemResponseShapeType class.

Public Instance Properties

AdditionalProperties
BaseShape

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PreviewItemResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PreviewItemResponseShapeType Constructor

Initializes a new instance of the PreviewItemResponseShapeType class.

public PreviewItemResponseShapeType();

See Also

PreviewItemResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PreviewItemResponseShapeType Properties

The properties of the PreviewItemResponseShapeType class are listed below. For a complete list of PreviewItemResponseShapeType class members, see the PreviewItemResponseShapeType Members topic.

Public Instance Properties

AdditionalProperties
BaseShape

See Also

PreviewItemResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AdditionalProperties Property

Aspose.Email

PreviewItemResponseShapeType.AdditionalProperties Property

public PathToExtendedFieldType[] AdditionalProperties {get; set;}

Remarks

See Also

PreviewItemResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseShape Property

Aspose.Email

PreviewItemResponseShapeType.BaseShape Property

public PreviewItemBaseShapeType BaseShape {get; set;}

Remarks

See Also

PreviewItemResponseShapeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ProtectionRuleActionKindType Enumeration

public enum ProtectionRuleActionKindType

Remarks

Members

Member Name | Description | Value
RightsProtectMessage |  | 0

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ProtectionRuleActionType Class

For a list of all members of this type, see ProtectionRuleActionType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ProtectionRuleActionType

public class ProtectionRuleActionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ProtectionRuleActionType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ProtectionRuleActionType Members

ProtectionRuleActionType overview

Public Instance Constructors

ProtectionRuleActionType Constructor Initializes a new instance of the ProtectionRuleActionType class.

Public Instance Properties

Argument
Name

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProtectionRuleActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ProtectionRuleActionType Constructor

Initializes a new instance of the ProtectionRuleActionType class.

public ProtectionRuleActionType();

See Also

ProtectionRuleActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ProtectionRuleActionType Properties

The properties of the ProtectionRuleActionType class are listed below. For a complete list of ProtectionRuleActionType class members, see the ProtectionRuleActionType Members topic.

Public Instance Properties

Argument
Name

See Also

ProtectionRuleActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Argument Property

Aspose.Email

ProtectionRuleActionType.Argument Property

public ProtectionRuleArgumentType[] Argument {get; set;}

Remarks

See Also

ProtectionRuleActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Name Property

Aspose.Email

ProtectionRuleActionType.Name Property

public ProtectionRuleActionKindType Name {get; set;}

Remarks

See Also

ProtectionRuleActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ProtectionRuleAndType Class

For a list of all members of this type, see ProtectionRuleAndType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ProtectionRuleAndType

public class ProtectionRuleAndType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ProtectionRuleAndType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ProtectionRuleAndType Members

ProtectionRuleAndType overview

Public Instance Constructors

ProtectionRuleAndType Constructor Initializes a new instance of the ProtectionRuleAndType class.

Public Instance Properties

Items
ItemsElementName

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProtectionRuleAndType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ProtectionRuleAndType Constructor

Initializes a new instance of the ProtectionRuleAndType class.

public ProtectionRuleAndType();

See Also

ProtectionRuleAndType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ProtectionRuleAndType Properties

The properties of the ProtectionRuleAndType class are listed below. For a complete list of ProtectionRuleAndType class members, see the ProtectionRuleAndType Members topic.

Public Instance Properties

Items
ItemsElementName

See Also

ProtectionRuleAndType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Items Property

Aspose.Email

ProtectionRuleAndType.Items Property

public object[] Items {get; set;}

Remarks

See Also

ProtectionRuleAndType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemsElementName Property

Aspose.Email

ProtectionRuleAndType.ItemsElementName Property

public ItemsChoiceType3[] ItemsElementName {get; set;}

Remarks

See Also

ProtectionRuleAndType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ProtectionRuleArgumentType Class

For a list of all members of this type, see ProtectionRuleArgumentType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ProtectionRuleArgumentType

public class ProtectionRuleArgumentType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ProtectionRuleArgumentType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ProtectionRuleArgumentType Members

ProtectionRuleArgumentType overview

Public Instance Constructors

ProtectionRuleArgumentType Constructor Initializes a new instance of the ProtectionRuleArgumentType class.

Public Instance Properties

Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProtectionRuleArgumentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ProtectionRuleArgumentType Constructor

Initializes a new instance of the ProtectionRuleArgumentType class.

public ProtectionRuleArgumentType();

See Also

ProtectionRuleArgumentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ProtectionRuleArgumentType Properties

The properties of the ProtectionRuleArgumentType class are listed below. For a complete list of ProtectionRuleArgumentType class members, see the ProtectionRuleArgumentType Members topic.

Public Instance Properties

Value

See Also

ProtectionRuleArgumentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Value Property

Aspose.Email

ProtectionRuleArgumentType.Value Property

public string Value {get; set;}

Remarks

See Also

ProtectionRuleArgumentType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ProtectionRuleConditionType Class

For a list of all members of this type, see ProtectionRuleConditionType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ProtectionRuleConditionType

public class ProtectionRuleConditionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ProtectionRuleConditionType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ProtectionRuleConditionType Members

ProtectionRuleConditionType overview

Public Instance Constructors

ProtectionRuleConditionType Constructor Initializes a new instance of the ProtectionRuleConditionType class.

Public Instance Properties

Item
ItemElementName

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProtectionRuleConditionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ProtectionRuleConditionType Constructor

Initializes a new instance of the ProtectionRuleConditionType class.

public ProtectionRuleConditionType();

See Also

ProtectionRuleConditionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ProtectionRuleConditionType Properties

The properties of the ProtectionRuleConditionType class are listed below. For a complete list of ProtectionRuleConditionType class members, see the ProtectionRuleConditionType Members topic.

Public Instance Properties

Item
ItemElementName

See Also

ProtectionRuleConditionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Item Property

Aspose.Email

ProtectionRuleConditionType.Item Property

public object Item {get; set;}

Remarks

See Also

ProtectionRuleConditionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemElementName Property

Aspose.Email

ProtectionRuleConditionType.ItemElementName Property

public ItemChoiceType1 ItemElementName {get; set;}

Remarks

See Also

ProtectionRuleConditionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ProtectionRuleRecipientIsType Class

For a list of all members of this type, see ProtectionRuleRecipientIsType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ProtectionRuleRecipientIsType

public class ProtectionRuleRecipientIsType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ProtectionRuleRecipientIsType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ProtectionRuleRecipientIsType Members

ProtectionRuleRecipientIsType overview

Public Instance Constructors

ProtectionRuleRecipientIsType Constructor Initializes a new instance of the ProtectionRuleRecipientIsType class.

Public Instance Properties

Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProtectionRuleRecipientIsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ProtectionRuleRecipientIsType Constructor

Initializes a new instance of the ProtectionRuleRecipientIsType class.

public ProtectionRuleRecipientIsType();

See Also

ProtectionRuleRecipientIsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ProtectionRuleRecipientIsType Properties

The properties of the ProtectionRuleRecipientIsType class are listed below. For a complete list of ProtectionRuleRecipientIsType class members, see the ProtectionRuleRecipientIsType Members topic.

Public Instance Properties

Value

See Also

ProtectionRuleRecipientIsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Value Property

Aspose.Email

ProtectionRuleRecipientIsType.Value Property

public string[] Value {get; set;}

Remarks

See Also

ProtectionRuleRecipientIsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ProtectionRuleSenderDepartmentsType Class

For a list of all members of this type, see ProtectionRuleSenderDepartmentsType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ProtectionRuleSenderDepartmentsType

public class ProtectionRuleSenderDepartmentsType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ProtectionRuleSenderDepartmentsType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ProtectionRuleSenderDepartmentsType Members

ProtectionRuleSenderDepartmentsType overview

Public Instance Constructors

ProtectionRuleSenderDepartmentsType Constructor Initializes a new instance of the ProtectionRuleSenderDepartmentsType class.

Public Instance Properties

Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProtectionRuleSenderDepartmentsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ProtectionRuleSenderDepartmentsType Constructor

Initializes a new instance of the ProtectionRuleSenderDepartmentsType class.

public ProtectionRuleSenderDepartmentsType();

See Also

ProtectionRuleSenderDepartmentsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ProtectionRuleSenderDepartmentsType Properties

The properties of the ProtectionRuleSenderDepartmentsType class are listed below. For a complete list of ProtectionRuleSenderDepartmentsType class members, see the ProtectionRuleSenderDepartmentsType Members topic.

Public Instance Properties

Value

See Also

ProtectionRuleSenderDepartmentsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Value Property

Aspose.Email

ProtectionRuleSenderDepartmentsType.Value Property

public string[] Value {get; set;}

Remarks

See Also

ProtectionRuleSenderDepartmentsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ProtectionRulesServiceConfiguration Class

For a list of all members of this type, see ProtectionRulesServiceConfiguration Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ServiceConfiguration
Aspose.Email.Exchange.Schema.Exchange_2013.ProtectionRulesServiceConfiguration

public class ProtectionRulesServiceConfiguration : ServiceConfiguration

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ProtectionRulesServiceConfiguration Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ProtectionRulesServiceConfiguration Members

ProtectionRulesServiceConfiguration overview

Public Instance Constructors

ProtectionRulesServiceConfiguration Constructor Initializes a new instance of the ProtectionRulesServiceConfiguration class.

Public Instance Properties

InternalDomains
RefreshInterval
Rules

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProtectionRulesServiceConfiguration Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ProtectionRulesServiceConfiguration Constructor

Initializes a new instance of the ProtectionRulesServiceConfiguration class.

public ProtectionRulesServiceConfiguration();

See Also

ProtectionRulesServiceConfiguration Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ProtectionRulesServiceConfiguration Properties

The properties of the ProtectionRulesServiceConfiguration class are listed below. For a complete list of ProtectionRulesServiceConfiguration class members, see the ProtectionRulesServiceConfiguration Members topic.

Public Instance Properties

InternalDomains
RefreshInterval
Rules

See Also

ProtectionRulesServiceConfiguration Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InternalDomains Property

Aspose.Email

ProtectionRulesServiceConfiguration.InternalDomains Property

public SmtpDomain[] InternalDomains {get; set;}

Remarks

See Also

ProtectionRulesServiceConfiguration Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RefreshInterval Property

Aspose.Email

ProtectionRulesServiceConfiguration.RefreshInterval Property

public int RefreshInterval {get; set;}

Remarks

See Also

ProtectionRulesServiceConfiguration Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Rules Property

Aspose.Email

ProtectionRulesServiceConfiguration.Rules Property

public ProtectionRuleType[] Rules {get; set;}

Remarks

See Also

ProtectionRulesServiceConfiguration Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ProtectionRuleType Class

For a list of all members of this type, see ProtectionRuleType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ProtectionRuleType

public class ProtectionRuleType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ProtectionRuleType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ProtectionRuleType Members

ProtectionRuleType overview

Public Instance Constructors

ProtectionRuleType Constructor Initializes a new instance of the ProtectionRuleType class.

Public Instance Properties

Action
Condition
Name
Priority
UserOverridable

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProtectionRuleType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ProtectionRuleType Constructor

Initializes a new instance of the ProtectionRuleType class.

public ProtectionRuleType();

See Also

ProtectionRuleType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ProtectionRuleType Properties

The properties of the ProtectionRuleType class are listed below. For a complete list of ProtectionRuleType class members, see the ProtectionRuleType Members topic.

Public Instance Properties

Action
Condition
Name
Priority
UserOverridable

See Also

ProtectionRuleType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Action Property

Aspose.Email

ProtectionRuleType.Action Property

public ProtectionRuleActionType Action {get; set;}

Remarks

See Also

ProtectionRuleType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Condition Property

Aspose.Email

ProtectionRuleType.Condition Property

public ProtectionRuleConditionType Condition {get; set;}

Remarks

See Also

ProtectionRuleType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Name Property

Aspose.Email

ProtectionRuleType.Name Property

public string Name {get; set;}

Remarks

See Also

ProtectionRuleType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Priority Property

Aspose.Email

ProtectionRuleType.Priority Property

public int Priority {get; set;}

Remarks

See Also

ProtectionRuleType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserOverridable Property

Aspose.Email

ProtectionRuleType.UserOverridable Property

public bool UserOverridable {get; set;}

Remarks

See Also

ProtectionRuleType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PullSubscriptionRequestType Class

For a list of all members of this type, see PullSubscriptionRequestType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseSubscriptionRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.PullSubscriptionRequestType

public class PullSubscriptionRequestType : BaseSubscriptionRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PullSubscriptionRequestType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PullSubscriptionRequestType Members

PullSubscriptionRequestType overview

Public Instance Constructors

PullSubscriptionRequestType Constructor Initializes a new instance of the PullSubscriptionRequestType class.

Public Instance Properties

EventTypes (inherited from BaseSubscriptionRequestType)
FolderIds (inherited from BaseSubscriptionRequestType)
SubscribeToAllFolders (inherited from BaseSubscriptionRequestType)
SubscribeToAllFoldersSpecified (inherited from BaseSubscriptionRequestType)
Timeout
Watermark (inherited from BaseSubscriptionRequestType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PullSubscriptionRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PullSubscriptionRequestType Constructor

Initializes a new instance of the PullSubscriptionRequestType class.

public PullSubscriptionRequestType();

See Also

PullSubscriptionRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PullSubscriptionRequestType Properties

The properties of the PullSubscriptionRequestType class are listed below. For a complete list of PullSubscriptionRequestType class members, see the PullSubscriptionRequestType Members topic.

Public Instance Properties

EventTypes (inherited from BaseSubscriptionRequestType)
FolderIds (inherited from BaseSubscriptionRequestType)
SubscribeToAllFolders (inherited from BaseSubscriptionRequestType)
SubscribeToAllFoldersSpecified (inherited from BaseSubscriptionRequestType)
Timeout
Watermark (inherited from BaseSubscriptionRequestType)

See Also

PullSubscriptionRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Timeout Property

Aspose.Email

PullSubscriptionRequestType.Timeout Property

public int Timeout {get; set;}

Remarks

See Also

PullSubscriptionRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PushSubscriptionRequestType Class

For a list of all members of this type, see PushSubscriptionRequestType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseSubscriptionRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.PushSubscriptionRequestType

public class PushSubscriptionRequestType : BaseSubscriptionRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PushSubscriptionRequestType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PushSubscriptionRequestType Members

PushSubscriptionRequestType overview

Public Instance Constructors

PushSubscriptionRequestType Constructor Initializes a new instance of the PushSubscriptionRequestType class.

Public Instance Properties

CallerData
EventTypes (inherited from BaseSubscriptionRequestType)
FolderIds (inherited from BaseSubscriptionRequestType)
StatusFrequency
SubscribeToAllFolders (inherited from BaseSubscriptionRequestType)
SubscribeToAllFoldersSpecified (inherited from BaseSubscriptionRequestType)
URL
Watermark (inherited from BaseSubscriptionRequestType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PushSubscriptionRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PushSubscriptionRequestType Constructor

Initializes a new instance of the PushSubscriptionRequestType class.

public PushSubscriptionRequestType();

See Also

PushSubscriptionRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PushSubscriptionRequestType Properties

The properties of the PushSubscriptionRequestType class are listed below. For a complete list of PushSubscriptionRequestType class members, see the PushSubscriptionRequestType Members topic.

Public Instance Properties

CallerData
EventTypes (inherited from BaseSubscriptionRequestType)
FolderIds (inherited from BaseSubscriptionRequestType)
StatusFrequency
SubscribeToAllFolders (inherited from BaseSubscriptionRequestType)
SubscribeToAllFoldersSpecified (inherited from BaseSubscriptionRequestType)
URL
Watermark (inherited from BaseSubscriptionRequestType)

See Also

PushSubscriptionRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CallerData Property

Aspose.Email

PushSubscriptionRequestType.CallerData Property

public string CallerData {get; set;}

Remarks

See Also

PushSubscriptionRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StatusFrequency Property

Aspose.Email

PushSubscriptionRequestType.StatusFrequency Property

public int StatusFrequency {get; set;}

Remarks

See Also

PushSubscriptionRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


URL Property

Aspose.Email

PushSubscriptionRequestType.URL Property

public string URL {get; set;}

Remarks

See Also

PushSubscriptionRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


QueryStringType Class

For a list of all members of this type, see QueryStringType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.QueryStringType

public class QueryStringType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

QueryStringType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


QueryStringType Members

QueryStringType overview

Public Instance Constructors

QueryStringType Constructor Initializes a new instance of the QueryStringType class.

Public Instance Properties

ResetCache
ResetCacheSpecified
ReturnDeletedItems
ReturnDeletedItemsSpecified
ReturnHighlightTerms
ReturnHighlightTermsSpecified
Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

QueryStringType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


QueryStringType Constructor

Initializes a new instance of the QueryStringType class.

public QueryStringType();

See Also

QueryStringType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


QueryStringType Properties

The properties of the QueryStringType class are listed below. For a complete list of QueryStringType class members, see the QueryStringType Members topic.

Public Instance Properties

ResetCache
ResetCacheSpecified
ReturnDeletedItems
ReturnDeletedItemsSpecified
ReturnHighlightTerms
ReturnHighlightTermsSpecified
Value

See Also

QueryStringType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResetCache Property

Aspose.Email

QueryStringType.ResetCache Property

public bool ResetCache {get; set;}

Remarks

See Also

QueryStringType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResetCacheSpecified Property

Aspose.Email

QueryStringType.ResetCacheSpecified Property

public bool ResetCacheSpecified {get; set;}

Remarks

See Also

QueryStringType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReturnDeletedItems Property

Aspose.Email

QueryStringType.ReturnDeletedItems Property

public bool ReturnDeletedItems {get; set;}

Remarks

See Also

QueryStringType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReturnDeletedItemsSpecified Property

Aspose.Email

QueryStringType.ReturnDeletedItemsSpecified Property

public bool ReturnDeletedItemsSpecified {get; set;}

Remarks

See Also

QueryStringType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReturnHighlightTerms Property

Aspose.Email

QueryStringType.ReturnHighlightTerms Property

public bool ReturnHighlightTerms {get; set;}

Remarks

See Also

QueryStringType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReturnHighlightTermsSpecified Property

Aspose.Email

QueryStringType.ReturnHighlightTermsSpecified Property

public bool ReturnHighlightTermsSpecified {get; set;}

Remarks

See Also

QueryStringType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Value Property

Aspose.Email

QueryStringType.Value Property

public string Value {get; set;}

Remarks

See Also

QueryStringType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecipientTrackingEventType Class

For a list of all members of this type, see RecipientTrackingEventType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.RecipientTrackingEventType

public class RecipientTrackingEventType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RecipientTrackingEventType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecipientTrackingEventType Members

RecipientTrackingEventType overview

Public Instance Constructors

RecipientTrackingEventType Constructor Initializes a new instance of the RecipientTrackingEventType class.

Public Instance Properties

BccRecipient
BccRecipientSpecified
Date
DeliveryStatus
EventData
EventDescription
HiddenRecipient
HiddenRecipientSpecified
InternalId
Properties
Recipient
RootAddress
Server
UniquePathId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RecipientTrackingEventType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecipientTrackingEventType Constructor

Initializes a new instance of the RecipientTrackingEventType class.

public RecipientTrackingEventType();

See Also

RecipientTrackingEventType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecipientTrackingEventType Properties

The properties of the RecipientTrackingEventType class are listed below. For a complete list of RecipientTrackingEventType class members, see the RecipientTrackingEventType Members topic.

Public Instance Properties

BccRecipient
BccRecipientSpecified
Date
DeliveryStatus
EventData
EventDescription
HiddenRecipient
HiddenRecipientSpecified
InternalId
Properties
Recipient
RootAddress
Server
UniquePathId

See Also

RecipientTrackingEventType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BccRecipient Property

Aspose.Email

RecipientTrackingEventType.BccRecipient Property

public bool BccRecipient {get; set;}

Remarks

See Also

RecipientTrackingEventType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BccRecipientSpecified Property

Aspose.Email

RecipientTrackingEventType.BccRecipientSpecified Property

public bool BccRecipientSpecified {get; set;}

Remarks

See Also

RecipientTrackingEventType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Date Property

Aspose.Email

RecipientTrackingEventType.Date Property

public DateTime Date {get; set;}

Remarks

See Also

RecipientTrackingEventType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeliveryStatus Property

Aspose.Email

RecipientTrackingEventType.DeliveryStatus Property

public string DeliveryStatus {get; set;}

Remarks

See Also

RecipientTrackingEventType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EventData Property

Aspose.Email

RecipientTrackingEventType.EventData Property

public string[] EventData {get; set;}

Remarks

See Also

RecipientTrackingEventType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EventDescription Property

Aspose.Email

RecipientTrackingEventType.EventDescription Property

public string EventDescription {get; set;}

Remarks

See Also

RecipientTrackingEventType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


HiddenRecipient Property

Aspose.Email

RecipientTrackingEventType.HiddenRecipient Property

public bool HiddenRecipient {get; set;}

Remarks

See Also

RecipientTrackingEventType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


HiddenRecipientSpecified Property

Aspose.Email

RecipientTrackingEventType.HiddenRecipientSpecified Property

public bool HiddenRecipientSpecified {get; set;}

Remarks

See Also

RecipientTrackingEventType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InternalId Property

Aspose.Email

RecipientTrackingEventType.InternalId Property

public string InternalId {get; set;}

Remarks

See Also

RecipientTrackingEventType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Properties Property

Aspose.Email

RecipientTrackingEventType.Properties Property

public TrackingPropertyType[] Properties {get; set;}

Remarks

See Also

RecipientTrackingEventType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Recipient Property

Aspose.Email

RecipientTrackingEventType.Recipient Property

public EmailAddressType Recipient {get; set;}

Remarks

See Also

RecipientTrackingEventType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RootAddress Property

Aspose.Email

RecipientTrackingEventType.RootAddress Property

public string RootAddress {get; set;}

Remarks

See Also

RecipientTrackingEventType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Server Property

Aspose.Email

RecipientTrackingEventType.Server Property

public string Server {get; set;}

Remarks

See Also

RecipientTrackingEventType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UniquePathId Property

Aspose.Email

RecipientTrackingEventType.UniquePathId Property

public string UniquePathId {get; set;}

Remarks

See Also

RecipientTrackingEventType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecognitionIdType Class

For a list of all members of this type, see RecognitionIdType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.RecognitionIdType

public class RecognitionIdType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RecognitionIdType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecognitionIdType Members

RecognitionIdType overview

Public Instance Constructors

RecognitionIdType Constructor Initializes a new instance of the RecognitionIdType class.

Public Instance Properties

RequestId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RecognitionIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecognitionIdType Constructor

Initializes a new instance of the RecognitionIdType class.

public RecognitionIdType();

See Also

RecognitionIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecognitionIdType Properties

The properties of the RecognitionIdType class are listed below. For a complete list of RecognitionIdType class members, see the RecognitionIdType Members topic.

Public Instance Properties

RequestId

See Also

RecognitionIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RequestId Property

Aspose.Email

RecognitionIdType.RequestId Property

public string RequestId {get; set;}

Remarks

See Also

RecognitionIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecognitionResultType Class

For a list of all members of this type, see RecognitionResultType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.RecognitionResultType

public class RecognitionResultType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RecognitionResultType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecognitionResultType Members

RecognitionResultType overview

Public Instance Constructors

RecognitionResultType Constructor Initializes a new instance of the RecognitionResultType class.

Public Instance Properties

Result

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RecognitionResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecognitionResultType Constructor

Initializes a new instance of the RecognitionResultType class.

public RecognitionResultType();

See Also

RecognitionResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecognitionResultType Properties

The properties of the RecognitionResultType class are listed below. For a complete list of RecognitionResultType class members, see the RecognitionResultType Members topic.

Public Instance Properties

Result

See Also

RecognitionResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

RecognitionResultType.Result Property

public string Result {get; set;}

Remarks

See Also

RecognitionResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecurrencePatternBaseType Class

For a list of all members of this type, see RecurrencePatternBaseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.RecurrencePatternBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.AbsoluteYearlyRecurrencePatternType
Aspose.Email.Exchange.Schema.Exchange_2013.IntervalRecurrencePatternBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.RelativeYearlyRecurrencePatternType

public abstract class RecurrencePatternBaseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RecurrencePatternBaseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecurrencePatternBaseType Members

RecurrencePatternBaseType overview

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

RecurrencePatternBaseType Constructor Initializes a new instance of the RecurrencePatternBaseType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RecurrencePatternBaseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecurrencePatternBaseType Constructor

Initializes a new instance of the RecurrencePatternBaseType class.

protected RecurrencePatternBaseType();

See Also

RecurrencePatternBaseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecurrenceRangeBaseType Class

For a list of all members of this type, see RecurrenceRangeBaseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.RecurrenceRangeBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.EndDateRecurrenceRangeType
Aspose.Email.Exchange.Schema.Exchange_2013.NoEndRecurrenceRangeType
Aspose.Email.Exchange.Schema.Exchange_2013.NumberedRecurrenceRangeType

public abstract class RecurrenceRangeBaseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RecurrenceRangeBaseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecurrenceRangeBaseType Members

RecurrenceRangeBaseType overview

Public Instance Properties

StartDate

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

RecurrenceRangeBaseType Constructor Initializes a new instance of the RecurrenceRangeBaseType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RecurrenceRangeBaseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecurrenceRangeBaseType Constructor

Initializes a new instance of the RecurrenceRangeBaseType class.

protected RecurrenceRangeBaseType();

See Also

RecurrenceRangeBaseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecurrenceRangeBaseType Properties

The properties of the RecurrenceRangeBaseType class are listed below. For a complete list of RecurrenceRangeBaseType class members, see the RecurrenceRangeBaseType Members topic.

Public Instance Properties

StartDate

See Also

RecurrenceRangeBaseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StartDate Property

Aspose.Email

RecurrenceRangeBaseType.StartDate Property

public DateTime StartDate {get; set;}

Remarks

See Also

RecurrenceRangeBaseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecurrenceType Class

For a list of all members of this type, see RecurrenceType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.RecurrenceType

public class RecurrenceType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RecurrenceType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecurrenceType Members

RecurrenceType overview

Public Instance Constructors

RecurrenceType Constructor Initializes a new instance of the RecurrenceType class.

Public Instance Properties

Item
Item1

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RecurrenceType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecurrenceType Constructor

Initializes a new instance of the RecurrenceType class.

public RecurrenceType();

See Also

RecurrenceType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecurrenceType Properties

The properties of the RecurrenceType class are listed below. For a complete list of RecurrenceType class members, see the RecurrenceType Members topic.

Public Instance Properties

Item
Item1

See Also

RecurrenceType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Item Property

Aspose.Email

RecurrenceType.Item Property

public RecurrencePatternBaseType Item {get; set;}

Remarks

See Also

RecurrenceType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Item1 Property

Aspose.Email

RecurrenceType.Item1 Property

public RecurrenceRangeBaseType Item1 {get; set;}

Remarks

See Also

RecurrenceType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecurringDateTransitionType Class

For a list of all members of this type, see RecurringDateTransitionType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.TransitionType
Aspose.Email.Exchange.Schema.Exchange_2013.RecurringTimeTransitionType
Aspose.Email.Exchange.Schema.Exchange_2013.RecurringDateTransitionType

public class RecurringDateTransitionType : RecurringTimeTransitionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RecurringDateTransitionType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecurringDateTransitionType Members

RecurringDateTransitionType overview

Public Instance Constructors

RecurringDateTransitionType Constructor Initializes a new instance of the RecurringDateTransitionType class.

Public Instance Properties

Day
Month (inherited from RecurringTimeTransitionType)
TimeOffset (inherited from RecurringTimeTransitionType)
To (inherited from TransitionType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RecurringDateTransitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecurringDateTransitionType Constructor

Initializes a new instance of the RecurringDateTransitionType class.

public RecurringDateTransitionType();

See Also

RecurringDateTransitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecurringDateTransitionType Properties

The properties of the RecurringDateTransitionType class are listed below. For a complete list of RecurringDateTransitionType class members, see the RecurringDateTransitionType Members topic.

Public Instance Properties

Day
Month (inherited from RecurringTimeTransitionType)
TimeOffset (inherited from RecurringTimeTransitionType)
To (inherited from TransitionType)

See Also

RecurringDateTransitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Day Property

Aspose.Email

RecurringDateTransitionType.Day Property

public int Day {get; set;}

Remarks

See Also

RecurringDateTransitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecurringDayTransitionType Class

For a list of all members of this type, see RecurringDayTransitionType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.TransitionType
Aspose.Email.Exchange.Schema.Exchange_2013.RecurringTimeTransitionType
Aspose.Email.Exchange.Schema.Exchange_2013.RecurringDayTransitionType

public class RecurringDayTransitionType : RecurringTimeTransitionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RecurringDayTransitionType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecurringDayTransitionType Members

RecurringDayTransitionType overview

Public Instance Constructors

RecurringDayTransitionType Constructor Initializes a new instance of the RecurringDayTransitionType class.

Public Instance Properties

DayOfWeek
Month (inherited from RecurringTimeTransitionType)
Occurrence
TimeOffset (inherited from RecurringTimeTransitionType)
To (inherited from TransitionType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RecurringDayTransitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecurringDayTransitionType Constructor

Initializes a new instance of the RecurringDayTransitionType class.

public RecurringDayTransitionType();

See Also

RecurringDayTransitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecurringDayTransitionType Properties

The properties of the RecurringDayTransitionType class are listed below. For a complete list of RecurringDayTransitionType class members, see the RecurringDayTransitionType Members topic.

Public Instance Properties

DayOfWeek
Month (inherited from RecurringTimeTransitionType)
Occurrence
TimeOffset (inherited from RecurringTimeTransitionType)
To (inherited from TransitionType)

See Also

RecurringDayTransitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DayOfWeek Property

Aspose.Email

RecurringDayTransitionType.DayOfWeek Property

public string DayOfWeek {get; set;}

Remarks

See Also

RecurringDayTransitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Occurrence Property

Aspose.Email

RecurringDayTransitionType.Occurrence Property

public int Occurrence {get; set;}

Remarks

See Also

RecurringDayTransitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecurringMasterItemIdRangesType Class

For a list of all members of this type, see RecurringMasterItemIdRangesType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseItemIdType
Aspose.Email.Exchange.Schema.Exchange_2013.ItemIdType
Aspose.Email.Exchange.Schema.Exchange_2013.RecurringMasterItemIdRangesType

public class RecurringMasterItemIdRangesType : ItemIdType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RecurringMasterItemIdRangesType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecurringMasterItemIdRangesType Members

RecurringMasterItemIdRangesType overview

Public Instance Constructors

RecurringMasterItemIdRangesType Constructor Initializes a new instance of the RecurringMasterItemIdRangesType class.

Public Instance Properties

ChangeKey (inherited from ItemIdType)
Id (inherited from ItemIdType)
Ranges

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RecurringMasterItemIdRangesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecurringMasterItemIdRangesType Constructor

Initializes a new instance of the RecurringMasterItemIdRangesType class.

public RecurringMasterItemIdRangesType();

See Also

RecurringMasterItemIdRangesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecurringMasterItemIdRangesType Properties

The properties of the RecurringMasterItemIdRangesType class are listed below. For a complete list of RecurringMasterItemIdRangesType class members, see the RecurringMasterItemIdRangesType Members topic.

Public Instance Properties

ChangeKey (inherited from ItemIdType)
Id (inherited from ItemIdType)
Ranges

See Also

RecurringMasterItemIdRangesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Ranges Property

Aspose.Email

RecurringMasterItemIdRangesType.Ranges Property

public OccurrencesRangeType[] Ranges {get; set;}

Remarks

See Also

RecurringMasterItemIdRangesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecurringMasterItemIdType Class

For a list of all members of this type, see RecurringMasterItemIdType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseItemIdType
Aspose.Email.Exchange.Schema.Exchange_2013.RecurringMasterItemIdType

public class RecurringMasterItemIdType : BaseItemIdType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RecurringMasterItemIdType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecurringMasterItemIdType Members

RecurringMasterItemIdType overview

Public Instance Constructors

RecurringMasterItemIdType Constructor Initializes a new instance of the RecurringMasterItemIdType class.

Public Instance Properties

ChangeKey
OccurrenceId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RecurringMasterItemIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecurringMasterItemIdType Constructor

Initializes a new instance of the RecurringMasterItemIdType class.

public RecurringMasterItemIdType();

See Also

RecurringMasterItemIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecurringMasterItemIdType Properties

The properties of the RecurringMasterItemIdType class are listed below. For a complete list of RecurringMasterItemIdType class members, see the RecurringMasterItemIdType Members topic.

Public Instance Properties

ChangeKey
OccurrenceId

See Also

RecurringMasterItemIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ChangeKey Property

Aspose.Email

RecurringMasterItemIdType.ChangeKey Property

public string ChangeKey {get; set;}

Remarks

See Also

RecurringMasterItemIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OccurrenceId Property

Aspose.Email

RecurringMasterItemIdType.OccurrenceId Property

public string OccurrenceId {get; set;}

Remarks

See Also

RecurringMasterItemIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecurringTimeTransitionType Class

For a list of all members of this type, see RecurringTimeTransitionType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.TransitionType
Aspose.Email.Exchange.Schema.Exchange_2013.RecurringTimeTransitionType
Aspose.Email.Exchange.Schema.Exchange_2013.RecurringDateTransitionType
Aspose.Email.Exchange.Schema.Exchange_2013.RecurringDayTransitionType

public abstract class RecurringTimeTransitionType : TransitionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RecurringTimeTransitionType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecurringTimeTransitionType Members

RecurringTimeTransitionType overview

Public Instance Properties

Month
TimeOffset
To (inherited from TransitionType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

RecurringTimeTransitionType Constructor Initializes a new instance of the RecurringTimeTransitionType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RecurringTimeTransitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecurringTimeTransitionType Constructor

Initializes a new instance of the RecurringTimeTransitionType class.

protected RecurringTimeTransitionType();

See Also

RecurringTimeTransitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecurringTimeTransitionType Properties

The properties of the RecurringTimeTransitionType class are listed below. For a complete list of RecurringTimeTransitionType class members, see the RecurringTimeTransitionType Members topic.

Public Instance Properties

Month
TimeOffset
To (inherited from TransitionType)

See Also

RecurringTimeTransitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Month Property

Aspose.Email

RecurringTimeTransitionType.Month Property

public int Month {get; set;}

Remarks

See Also

RecurringTimeTransitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TimeOffset Property

Aspose.Email

RecurringTimeTransitionType.TimeOffset Property

public string TimeOffset {get; set;}

Remarks

See Also

RecurringTimeTransitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReferenceItemResponseType Class

For a list of all members of this type, see ReferenceItemResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ItemType
Aspose.Email.Exchange.Schema.Exchange_2013.MessageType
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseObjectCoreType
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseObjectType
Aspose.Email.Exchange.Schema.Exchange_2013.ReferenceItemResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.AcceptSharingInvitationType
Aspose.Email.Exchange.Schema.Exchange_2013.SuppressReadReceiptType

public class ReferenceItemResponseType : ResponseObjectType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ReferenceItemResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReferenceItemResponseType Members

ReferenceItemResponseType overview

Public Instance Constructors

ReferenceItemResponseType Constructor Initializes a new instance of the ReferenceItemResponseType class.

Public Instance Properties

ArchiveTag (inherited from ItemType)
Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
BlockStatus (inherited from ItemType)
BlockStatusSpecified (inherited from ItemType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
EntityExtractionResult (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
Flag (inherited from ItemType)
From (inherited from MessageType)
GroupingAction (inherited from ItemType)
GroupingActionSpecified (inherited from ItemType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBlockedImages (inherited from ItemType)
HasBlockedImagesSpecified (inherited from ItemType)
IconIndex (inherited from ItemType)
IconIndexSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InstanceKey (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
NextPredictedAction (inherited from ItemType)
NextPredictedActionSpecified (inherited from ItemType)
NormalizedBody (inherited from ItemType)
ObjectName (inherited from ResponseObjectType)
ParentFolderId (inherited from ItemType)
PolicyTag (inherited from ItemType)
Preview (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
ReferenceItemId (inherited from ResponseObjectCoreType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReminderNextTime (inherited from ItemType)
ReminderNextTimeSpecified (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
RetentionDate (inherited from ItemType)
RetentionDateSpecified (inherited from ItemType)
RightsManagementLicenseData (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
StoreEntryId (inherited from ItemType)
Subject (inherited from ItemType)
TextBody (inherited from ItemType)
ToRecipients (inherited from MessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ReferenceItemResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReferenceItemResponseType Constructor

Initializes a new instance of the ReferenceItemResponseType class.

public ReferenceItemResponseType();

See Also

ReferenceItemResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RefreshSharingFolderCompletedEventArgs Class

For a list of all members of this type, see RefreshSharingFolderCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.RefreshSharingFolderCompletedEventArgs

public class RefreshSharingFolderCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RefreshSharingFolderCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RefreshSharingFolderCompletedEventArgs Members

RefreshSharingFolderCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

RefreshSharingFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RefreshSharingFolderCompletedEventArgs Properties

The properties of the RefreshSharingFolderCompletedEventArgs class are listed below. For a complete list of RefreshSharingFolderCompletedEventArgs class members, see the RefreshSharingFolderCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

RefreshSharingFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

RefreshSharingFolderCompletedEventArgs.Result Property

public RefreshSharingFolderResponseMessageType Result {get;}

Remarks

See Also

RefreshSharingFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RefreshSharingFolderCompletedEventHandler Delegate

public delegate void RefreshSharingFolderCompletedEventHandler(
object sender,
RefreshSharingFolderCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RefreshSharingFolderResponseMessageType Class

For a list of all members of this type, see RefreshSharingFolderResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.RefreshSharingFolderResponseMessageType

public class RefreshSharingFolderResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RefreshSharingFolderResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RefreshSharingFolderResponseMessageType Members

RefreshSharingFolderResponseMessageType overview

Public Instance Constructors

RefreshSharingFolderResponseMessageType Constructor Initializes a new instance of the RefreshSharingFolderResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RefreshSharingFolderResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RefreshSharingFolderResponseMessageType Constructor

Initializes a new instance of the RefreshSharingFolderResponseMessageType class.

public RefreshSharingFolderResponseMessageType();

See Also

RefreshSharingFolderResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RefreshSharingFolderType Class

For a list of all members of this type, see RefreshSharingFolderType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.RefreshSharingFolderType

public class RefreshSharingFolderType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RefreshSharingFolderType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RefreshSharingFolderType Members

RefreshSharingFolderType overview

Public Instance Constructors

RefreshSharingFolderType Constructor Initializes a new instance of the RefreshSharingFolderType class.

Public Instance Properties

SharingFolderId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RefreshSharingFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RefreshSharingFolderType Constructor

Initializes a new instance of the RefreshSharingFolderType class.

public RefreshSharingFolderType();

See Also

RefreshSharingFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RefreshSharingFolderType Properties

The properties of the RefreshSharingFolderType class are listed below. For a complete list of RefreshSharingFolderType class members, see the RefreshSharingFolderType Members topic.

Public Instance Properties

SharingFolderId

See Also

RefreshSharingFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SharingFolderId Property

Aspose.Email

RefreshSharingFolderType.SharingFolderId Property

public FolderIdType SharingFolderId {get; set;}

Remarks

See Also

RefreshSharingFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RegeneratingPatternBaseType Class

For a list of all members of this type, see RegeneratingPatternBaseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.RecurrencePatternBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.IntervalRecurrencePatternBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.RegeneratingPatternBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.DailyRegeneratingPatternType
Aspose.Email.Exchange.Schema.Exchange_2013.MonthlyRegeneratingPatternType
Aspose.Email.Exchange.Schema.Exchange_2013.WeeklyRegeneratingPatternType
Aspose.Email.Exchange.Schema.Exchange_2013.YearlyRegeneratingPatternType

public abstract class RegeneratingPatternBaseType : IntervalRecurrencePatternBaseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RegeneratingPatternBaseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RegeneratingPatternBaseType Members

RegeneratingPatternBaseType overview

Public Instance Properties

Interval (inherited from IntervalRecurrencePatternBaseType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

RegeneratingPatternBaseType Constructor Initializes a new instance of the RegeneratingPatternBaseType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RegeneratingPatternBaseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RegeneratingPatternBaseType Constructor

Initializes a new instance of the RegeneratingPatternBaseType class.

protected RegeneratingPatternBaseType();

See Also

RegeneratingPatternBaseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RelativeMonthlyRecurrencePatternType Class

For a list of all members of this type, see RelativeMonthlyRecurrencePatternType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.RecurrencePatternBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.IntervalRecurrencePatternBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.RelativeMonthlyRecurrencePatternType

public class RelativeMonthlyRecurrencePatternType : IntervalRecurrencePatternBaseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RelativeMonthlyRecurrencePatternType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RelativeMonthlyRecurrencePatternType Members

RelativeMonthlyRecurrencePatternType overview

Public Instance Constructors

RelativeMonthlyRecurrencePatternType Constructor Initializes a new instance of the RelativeMonthlyRecurrencePatternType class.

Public Instance Properties

DayOfWeekIndex
DaysOfWeek
Interval (inherited from IntervalRecurrencePatternBaseType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RelativeMonthlyRecurrencePatternType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RelativeMonthlyRecurrencePatternType Constructor

Initializes a new instance of the RelativeMonthlyRecurrencePatternType class.

public RelativeMonthlyRecurrencePatternType();

See Also

RelativeMonthlyRecurrencePatternType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RelativeMonthlyRecurrencePatternType Properties

The properties of the RelativeMonthlyRecurrencePatternType class are listed below. For a complete list of RelativeMonthlyRecurrencePatternType class members, see the RelativeMonthlyRecurrencePatternType Members topic.

Public Instance Properties

DayOfWeekIndex
DaysOfWeek
Interval (inherited from IntervalRecurrencePatternBaseType)

See Also

RelativeMonthlyRecurrencePatternType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DayOfWeekIndex Property

Aspose.Email

RelativeMonthlyRecurrencePatternType.DayOfWeekIndex Property

public DayOfWeekIndexType DayOfWeekIndex {get; set;}

Remarks

See Also

RelativeMonthlyRecurrencePatternType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DaysOfWeek Property

Aspose.Email

RelativeMonthlyRecurrencePatternType.DaysOfWeek Property

public DayOfWeekType DaysOfWeek {get; set;}

Remarks

See Also

RelativeMonthlyRecurrencePatternType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RelativeYearlyRecurrencePatternType Class

For a list of all members of this type, see RelativeYearlyRecurrencePatternType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.RecurrencePatternBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.RelativeYearlyRecurrencePatternType

public class RelativeYearlyRecurrencePatternType : RecurrencePatternBaseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RelativeYearlyRecurrencePatternType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RelativeYearlyRecurrencePatternType Members

RelativeYearlyRecurrencePatternType overview

Public Instance Constructors

RelativeYearlyRecurrencePatternType Constructor Initializes a new instance of the RelativeYearlyRecurrencePatternType class.

Public Instance Properties

DayOfWeekIndex
DaysOfWeek
Month

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RelativeYearlyRecurrencePatternType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RelativeYearlyRecurrencePatternType Constructor

Initializes a new instance of the RelativeYearlyRecurrencePatternType class.

public RelativeYearlyRecurrencePatternType();

See Also

RelativeYearlyRecurrencePatternType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RelativeYearlyRecurrencePatternType Properties

The properties of the RelativeYearlyRecurrencePatternType class are listed below. For a complete list of RelativeYearlyRecurrencePatternType class members, see the RelativeYearlyRecurrencePatternType Members topic.

Public Instance Properties

DayOfWeekIndex
DaysOfWeek
Month

See Also

RelativeYearlyRecurrencePatternType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DayOfWeekIndex Property

Aspose.Email

RelativeYearlyRecurrencePatternType.DayOfWeekIndex Property

public DayOfWeekIndexType DayOfWeekIndex {get; set;}

Remarks

See Also

RelativeYearlyRecurrencePatternType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DaysOfWeek Property

Aspose.Email

RelativeYearlyRecurrencePatternType.DaysOfWeek Property

public string DaysOfWeek {get; set;}

Remarks

See Also

RelativeYearlyRecurrencePatternType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Month Property

Aspose.Email

RelativeYearlyRecurrencePatternType.Month Property

public MonthNamesType Month {get; set;}

Remarks

See Also

RelativeYearlyRecurrencePatternType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReminderActionType Enumeration

public enum ReminderActionType

Remarks

Members

Member Name | Description | Value
Dismiss |  | 0
Snooze |  | 1

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReminderGroupType Enumeration

public enum ReminderGroupType

Remarks

Members

Member Name | Description | Value
Calendar |  | 0
Task |  | 1

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReminderItemActionType Class

For a list of all members of this type, see ReminderItemActionType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ReminderItemActionType

public class ReminderItemActionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ReminderItemActionType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReminderItemActionType Members

ReminderItemActionType overview

Public Instance Constructors

ReminderItemActionType Constructor Initializes a new instance of the ReminderItemActionType class.

Public Instance Properties

ActionType
ItemId
NewReminderTime

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ReminderItemActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReminderItemActionType Constructor

Initializes a new instance of the ReminderItemActionType class.

public ReminderItemActionType();

See Also

ReminderItemActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReminderItemActionType Properties

The properties of the ReminderItemActionType class are listed below. For a complete list of ReminderItemActionType class members, see the ReminderItemActionType Members topic.

Public Instance Properties

ActionType
ItemId
NewReminderTime

See Also

ReminderItemActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ActionType Property

Aspose.Email

ReminderItemActionType.ActionType Property

public ReminderActionType ActionType {get; set;}

Remarks

See Also

ReminderItemActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemId Property

Aspose.Email

ReminderItemActionType.ItemId Property

public ItemIdType ItemId {get; set;}

Remarks

See Also

ReminderItemActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NewReminderTime Property

Aspose.Email

ReminderItemActionType.NewReminderTime Property

public string NewReminderTime {get; set;}

Remarks

See Also

ReminderItemActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReminderType Class

For a list of all members of this type, see ReminderType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ReminderType

public class ReminderType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ReminderType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReminderType Members

ReminderType overview

Public Instance Constructors

ReminderType Constructor Initializes a new instance of the ReminderType class.

Public Instance Properties

EndDate
ItemId
Location
RecurringMasterItemId
ReminderGroup
ReminderGroupSpecified
ReminderTime
StartDate
Subject

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ReminderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReminderType Constructor

Initializes a new instance of the ReminderType class.

public ReminderType();

See Also

ReminderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReminderType Properties

The properties of the ReminderType class are listed below. For a complete list of ReminderType class members, see the ReminderType Members topic.

Public Instance Properties

EndDate
ItemId
Location
RecurringMasterItemId
ReminderGroup
ReminderGroupSpecified
ReminderTime
StartDate
Subject

See Also

ReminderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EndDate Property

Aspose.Email

ReminderType.EndDate Property

public DateTime EndDate {get; set;}

Remarks

See Also

ReminderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemId Property

Aspose.Email

ReminderType.ItemId Property

public ItemIdType ItemId {get; set;}

Remarks

See Also

ReminderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Location Property

Aspose.Email

ReminderType.Location Property

public string Location {get; set;}

Remarks

See Also

ReminderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecurringMasterItemId Property

Aspose.Email

ReminderType.RecurringMasterItemId Property

public ItemIdType RecurringMasterItemId {get; set;}

Remarks

See Also

ReminderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReminderGroup Property

Aspose.Email

ReminderType.ReminderGroup Property

public ReminderGroupType ReminderGroup {get; set;}

Remarks

See Also

ReminderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReminderGroupSpecified Property

Aspose.Email

ReminderType.ReminderGroupSpecified Property

public bool ReminderGroupSpecified {get; set;}

Remarks

See Also

ReminderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReminderTime Property

Aspose.Email

ReminderType.ReminderTime Property

public DateTime ReminderTime {get; set;}

Remarks

See Also

ReminderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StartDate Property

Aspose.Email

ReminderType.StartDate Property

public DateTime StartDate {get; set;}

Remarks

See Also

ReminderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Subject Property

Aspose.Email

ReminderType.Subject Property

public string Subject {get; set;}

Remarks

See Also

ReminderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveContactFromImListCompletedEventArgs Class

For a list of all members of this type, see RemoveContactFromImListCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.RemoveContactFromImListCompletedEventArgs

public class RemoveContactFromImListCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RemoveContactFromImListCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveContactFromImListCompletedEventArgs Members

RemoveContactFromImListCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

RemoveContactFromImListCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveContactFromImListCompletedEventArgs Properties

The properties of the RemoveContactFromImListCompletedEventArgs class are listed below. For a complete list of RemoveContactFromImListCompletedEventArgs class members, see the RemoveContactFromImListCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

RemoveContactFromImListCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

RemoveContactFromImListCompletedEventArgs.Result Property

public RemoveContactFromImListResponseMessageType Result {get;}

Remarks

See Also

RemoveContactFromImListCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveContactFromImListCompletedEventHandler Delegate

public delegate void RemoveContactFromImListCompletedEventHandler(
object sender,
RemoveContactFromImListCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveContactFromImListResponseMessageType Class

For a list of all members of this type, see RemoveContactFromImListResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.RemoveContactFromImListResponseMessageType

public class RemoveContactFromImListResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RemoveContactFromImListResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveContactFromImListResponseMessageType Members

RemoveContactFromImListResponseMessageType overview

Public Instance Constructors

RemoveContactFromImListResponseMessageType Constructor Initializes a new instance of the RemoveContactFromImListResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RemoveContactFromImListResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveContactFromImListResponseMessageType Constructor

Initializes a new instance of the RemoveContactFromImListResponseMessageType class.

public RemoveContactFromImListResponseMessageType();

See Also

RemoveContactFromImListResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveContactFromImListType Class

For a list of all members of this type, see RemoveContactFromImListType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.RemoveContactFromImListType

public class RemoveContactFromImListType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RemoveContactFromImListType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveContactFromImListType Members

RemoveContactFromImListType overview

Public Instance Constructors

RemoveContactFromImListType Constructor Initializes a new instance of the RemoveContactFromImListType class.

Public Instance Properties

ContactId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RemoveContactFromImListType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveContactFromImListType Constructor

Initializes a new instance of the RemoveContactFromImListType class.

public RemoveContactFromImListType();

See Also

RemoveContactFromImListType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveContactFromImListType Properties

The properties of the RemoveContactFromImListType class are listed below. For a complete list of RemoveContactFromImListType class members, see the RemoveContactFromImListType Members topic.

Public Instance Properties

ContactId

See Also

RemoveContactFromImListType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContactId Property

Aspose.Email

RemoveContactFromImListType.ContactId Property

public ItemIdType ContactId {get; set;}

Remarks

See Also

RemoveContactFromImListType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveDelegateCompletedEventArgs Class

For a list of all members of this type, see RemoveDelegateCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.RemoveDelegateCompletedEventArgs

public class RemoveDelegateCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RemoveDelegateCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveDelegateCompletedEventArgs Members

RemoveDelegateCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

RemoveDelegateCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveDelegateCompletedEventArgs Properties

The properties of the RemoveDelegateCompletedEventArgs class are listed below. For a complete list of RemoveDelegateCompletedEventArgs class members, see the RemoveDelegateCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

RemoveDelegateCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

RemoveDelegateCompletedEventArgs.Result Property

public RemoveDelegateResponseMessageType Result {get;}

Remarks

See Also

RemoveDelegateCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveDelegateCompletedEventHandler Delegate

public delegate void RemoveDelegateCompletedEventHandler(
object sender,
RemoveDelegateCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveDelegateResponseMessageType Class

For a list of all members of this type, see RemoveDelegateResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.BaseDelegateResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.RemoveDelegateResponseMessageType

public class RemoveDelegateResponseMessageType : BaseDelegateResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RemoveDelegateResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveDelegateResponseMessageType Members

RemoveDelegateResponseMessageType overview

Public Instance Constructors

RemoveDelegateResponseMessageType Constructor Initializes a new instance of the RemoveDelegateResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
ResponseMessages (inherited from BaseDelegateResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RemoveDelegateResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveDelegateResponseMessageType Constructor

Initializes a new instance of the RemoveDelegateResponseMessageType class.

public RemoveDelegateResponseMessageType();

See Also

RemoveDelegateResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveDelegateType Class

For a list of all members of this type, see RemoveDelegateType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.BaseDelegateType
Aspose.Email.Exchange.Schema.Exchange_2013.RemoveDelegateType

public class RemoveDelegateType : BaseDelegateType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RemoveDelegateType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveDelegateType Members

RemoveDelegateType overview

Public Instance Constructors

RemoveDelegateType Constructor Initializes a new instance of the RemoveDelegateType class.

Public Instance Properties

Mailbox (inherited from BaseDelegateType)
UserIds

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RemoveDelegateType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveDelegateType Constructor

Initializes a new instance of the RemoveDelegateType class.

public RemoveDelegateType();

See Also

RemoveDelegateType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveDelegateType Properties

The properties of the RemoveDelegateType class are listed below. For a complete list of RemoveDelegateType class members, see the RemoveDelegateType Members topic.

Public Instance Properties

Mailbox (inherited from BaseDelegateType)
UserIds

See Also

RemoveDelegateType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserIds Property

Aspose.Email

RemoveDelegateType.UserIds Property

public UserIdType[] UserIds {get; set;}

Remarks

See Also

RemoveDelegateType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveDistributionGroupFromImListCompletedEventArgs Class

For a list of all members of this type, see RemoveDistributionGroupFromImListCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.RemoveDistributionGroupFromImListCompletedEventArgs

public class RemoveDistributionGroupFromImListCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RemoveDistributionGroupFromImListCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveDistributionGroupFromImListCompletedEventArgs Members

RemoveDistributionGroupFromImListCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

RemoveDistributionGroupFromImListCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveDistributionGroupFromImListCompletedEventArgs Properties

The properties of the RemoveDistributionGroupFromImListCompletedEventArgs class are listed below. For a complete list of RemoveDistributionGroupFromImListCompletedEventArgs class members, see the RemoveDistributionGroupFromImListCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

RemoveDistributionGroupFromImListCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

RemoveDistributionGroupFromImListCompletedEventArgs.Result Property

public RemoveDistributionGroupFromImListResponseMessageType Result {get;}

Remarks

See Also

RemoveDistributionGroupFromImListCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveDistributionGroupFromImListCompletedEventHandler Delegate

public delegate void RemoveDistributionGroupFromImListCompletedEventHandler(
object sender,
RemoveDistributionGroupFromImListCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveDistributionGroupFromImListResponseMessageType Class

For a list of all members of this type, see RemoveDistributionGroupFromImListResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.RemoveDistributionGroupFromImListResponseMessageType

public class RemoveDistributionGroupFromImListResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RemoveDistributionGroupFromImListResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveDistributionGroupFromImListResponseMessageType Members

RemoveDistributionGroupFromImListResponseMessageType overview

Public Instance Constructors

RemoveDistributionGroupFromImListResponseMessageType Constructor Initializes a new instance of the RemoveDistributionGroupFromImListResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RemoveDistributionGroupFromImListResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveDistributionGroupFromImListResponseMessageType Constructor

Initializes a new instance of the RemoveDistributionGroupFromImListResponseMessageType class.

public RemoveDistributionGroupFromImListResponseMessageType();

See Also

RemoveDistributionGroupFromImListResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveDistributionGroupFromImListType Class

For a list of all members of this type, see RemoveDistributionGroupFromImListType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.RemoveDistributionGroupFromImListType

public class RemoveDistributionGroupFromImListType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RemoveDistributionGroupFromImListType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveDistributionGroupFromImListType Members

RemoveDistributionGroupFromImListType overview

Public Instance Constructors

RemoveDistributionGroupFromImListType Constructor Initializes a new instance of the RemoveDistributionGroupFromImListType class.

Public Instance Properties

GroupId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RemoveDistributionGroupFromImListType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveDistributionGroupFromImListType Constructor

Initializes a new instance of the RemoveDistributionGroupFromImListType class.

public RemoveDistributionGroupFromImListType();

See Also

RemoveDistributionGroupFromImListType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveDistributionGroupFromImListType Properties

The properties of the RemoveDistributionGroupFromImListType class are listed below. For a complete list of RemoveDistributionGroupFromImListType class members, see the RemoveDistributionGroupFromImListType Members topic.

Public Instance Properties

GroupId

See Also

RemoveDistributionGroupFromImListType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GroupId Property

Aspose.Email

RemoveDistributionGroupFromImListType.GroupId Property

public ItemIdType GroupId {get; set;}

Remarks

See Also

RemoveDistributionGroupFromImListType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveImContactFromGroupCompletedEventArgs Class

For a list of all members of this type, see RemoveImContactFromGroupCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.RemoveImContactFromGroupCompletedEventArgs

public class RemoveImContactFromGroupCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RemoveImContactFromGroupCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveImContactFromGroupCompletedEventArgs Members

RemoveImContactFromGroupCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

RemoveImContactFromGroupCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveImContactFromGroupCompletedEventArgs Properties

The properties of the RemoveImContactFromGroupCompletedEventArgs class are listed below. For a complete list of RemoveImContactFromGroupCompletedEventArgs class members, see the RemoveImContactFromGroupCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

RemoveImContactFromGroupCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

RemoveImContactFromGroupCompletedEventArgs.Result Property

public RemoveImContactFromGroupResponseMessageType Result {get;}

Remarks

See Also

RemoveImContactFromGroupCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveImContactFromGroupCompletedEventHandler Delegate

public delegate void RemoveImContactFromGroupCompletedEventHandler(
object sender,
RemoveImContactFromGroupCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveImContactFromGroupResponseMessageType Class

For a list of all members of this type, see RemoveImContactFromGroupResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.RemoveImContactFromGroupResponseMessageType

public class RemoveImContactFromGroupResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RemoveImContactFromGroupResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveImContactFromGroupResponseMessageType Members

RemoveImContactFromGroupResponseMessageType overview

Public Instance Constructors

RemoveImContactFromGroupResponseMessageType Constructor Initializes a new instance of the RemoveImContactFromGroupResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RemoveImContactFromGroupResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveImContactFromGroupResponseMessageType Constructor

Initializes a new instance of the RemoveImContactFromGroupResponseMessageType class.

public RemoveImContactFromGroupResponseMessageType();

See Also

RemoveImContactFromGroupResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveImContactFromGroupType Class

For a list of all members of this type, see RemoveImContactFromGroupType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.RemoveImContactFromGroupType

public class RemoveImContactFromGroupType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RemoveImContactFromGroupType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveImContactFromGroupType Members

RemoveImContactFromGroupType overview

Public Instance Constructors

RemoveImContactFromGroupType Constructor Initializes a new instance of the RemoveImContactFromGroupType class.

Public Instance Properties

ContactId
GroupId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RemoveImContactFromGroupType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveImContactFromGroupType Constructor

Initializes a new instance of the RemoveImContactFromGroupType class.

public RemoveImContactFromGroupType();

See Also

RemoveImContactFromGroupType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveImContactFromGroupType Properties

The properties of the RemoveImContactFromGroupType class are listed below. For a complete list of RemoveImContactFromGroupType class members, see the RemoveImContactFromGroupType Members topic.

Public Instance Properties

ContactId
GroupId

See Also

RemoveImContactFromGroupType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContactId Property

Aspose.Email

RemoveImContactFromGroupType.ContactId Property

public ItemIdType ContactId {get; set;}

Remarks

See Also

RemoveImContactFromGroupType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GroupId Property

Aspose.Email

RemoveImContactFromGroupType.GroupId Property

public ItemIdType GroupId {get; set;}

Remarks

See Also

RemoveImContactFromGroupType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveImGroupCompletedEventArgs Class

For a list of all members of this type, see RemoveImGroupCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.RemoveImGroupCompletedEventArgs

public class RemoveImGroupCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RemoveImGroupCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveImGroupCompletedEventArgs Members

RemoveImGroupCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

RemoveImGroupCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveImGroupCompletedEventArgs Properties

The properties of the RemoveImGroupCompletedEventArgs class are listed below. For a complete list of RemoveImGroupCompletedEventArgs class members, see the RemoveImGroupCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

RemoveImGroupCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

RemoveImGroupCompletedEventArgs.Result Property

public RemoveImGroupResponseMessageType Result {get;}

Remarks

See Also

RemoveImGroupCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveImGroupCompletedEventHandler Delegate

public delegate void RemoveImGroupCompletedEventHandler(
object sender,
RemoveImGroupCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveImGroupResponseMessageType Class

For a list of all members of this type, see RemoveImGroupResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.RemoveImGroupResponseMessageType

public class RemoveImGroupResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RemoveImGroupResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveImGroupResponseMessageType Members

RemoveImGroupResponseMessageType overview

Public Instance Constructors

RemoveImGroupResponseMessageType Constructor Initializes a new instance of the RemoveImGroupResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RemoveImGroupResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveImGroupResponseMessageType Constructor

Initializes a new instance of the RemoveImGroupResponseMessageType class.

public RemoveImGroupResponseMessageType();

See Also

RemoveImGroupResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveImGroupType Class

For a list of all members of this type, see RemoveImGroupType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.RemoveImGroupType

public class RemoveImGroupType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RemoveImGroupType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveImGroupType Members

RemoveImGroupType overview

Public Instance Constructors

RemoveImGroupType Constructor Initializes a new instance of the RemoveImGroupType class.

Public Instance Properties

GroupId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RemoveImGroupType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveImGroupType Constructor

Initializes a new instance of the RemoveImGroupType class.

public RemoveImGroupType();

See Also

RemoveImGroupType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveImGroupType Properties

The properties of the RemoveImGroupType class are listed below. For a complete list of RemoveImGroupType class members, see the RemoveImGroupType Members topic.

Public Instance Properties

GroupId

See Also

RemoveImGroupType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GroupId Property

Aspose.Email

RemoveImGroupType.GroupId Property

public ItemIdType GroupId {get; set;}

Remarks

See Also

RemoveImGroupType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveItemType Class

For a list of all members of this type, see RemoveItemType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ItemType
Aspose.Email.Exchange.Schema.Exchange_2013.MessageType
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseObjectCoreType
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseObjectType
Aspose.Email.Exchange.Schema.Exchange_2013.RemoveItemType

public class RemoveItemType : ResponseObjectType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RemoveItemType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveItemType Members

RemoveItemType overview

Public Instance Constructors

RemoveItemType Constructor Initializes a new instance of the RemoveItemType class.

Public Instance Properties

ArchiveTag (inherited from ItemType)
Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
BlockStatus (inherited from ItemType)
BlockStatusSpecified (inherited from ItemType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
EntityExtractionResult (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
Flag (inherited from ItemType)
From (inherited from MessageType)
GroupingAction (inherited from ItemType)
GroupingActionSpecified (inherited from ItemType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBlockedImages (inherited from ItemType)
HasBlockedImagesSpecified (inherited from ItemType)
IconIndex (inherited from ItemType)
IconIndexSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InstanceKey (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
NextPredictedAction (inherited from ItemType)
NextPredictedActionSpecified (inherited from ItemType)
NormalizedBody (inherited from ItemType)
ObjectName (inherited from ResponseObjectType)
ParentFolderId (inherited from ItemType)
PolicyTag (inherited from ItemType)
Preview (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
ReferenceItemId (inherited from ResponseObjectCoreType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReminderNextTime (inherited from ItemType)
ReminderNextTimeSpecified (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
RetentionDate (inherited from ItemType)
RetentionDateSpecified (inherited from ItemType)
RightsManagementLicenseData (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
StoreEntryId (inherited from ItemType)
Subject (inherited from ItemType)
TextBody (inherited from ItemType)
ToRecipients (inherited from MessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RemoveItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveItemType Constructor

Initializes a new instance of the RemoveItemType class.

public RemoveItemType();

See Also

RemoveItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReplyAllToItemType Class

For a list of all members of this type, see ReplyAllToItemType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ItemType
Aspose.Email.Exchange.Schema.Exchange_2013.MessageType
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseObjectCoreType
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseObjectType
Aspose.Email.Exchange.Schema.Exchange_2013.SmartResponseBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.SmartResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.ReplyAllToItemType

public class ReplyAllToItemType : SmartResponseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ReplyAllToItemType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReplyAllToItemType Members

ReplyAllToItemType overview

Public Instance Constructors

ReplyAllToItemType Constructor Initializes a new instance of the ReplyAllToItemType class.

Public Instance Properties

ArchiveTag (inherited from ItemType)
Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
BlockStatus (inherited from ItemType)
BlockStatusSpecified (inherited from ItemType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
EntityExtractionResult (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
Flag (inherited from ItemType)
From (inherited from MessageType)
GroupingAction (inherited from ItemType)
GroupingActionSpecified (inherited from ItemType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBlockedImages (inherited from ItemType)
HasBlockedImagesSpecified (inherited from ItemType)
IconIndex (inherited from ItemType)
IconIndexSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InstanceKey (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
NewBodyContent (inherited from SmartResponseType)
NextPredictedAction (inherited from ItemType)
NextPredictedActionSpecified (inherited from ItemType)
NormalizedBody (inherited from ItemType)
ObjectName (inherited from ResponseObjectType)
ParentFolderId (inherited from ItemType)
PolicyTag (inherited from ItemType)
Preview (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
ReferenceItemId (inherited from ResponseObjectCoreType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReminderNextTime (inherited from ItemType)
ReminderNextTimeSpecified (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
RetentionDate (inherited from ItemType)
RetentionDateSpecified (inherited from ItemType)
RightsManagementLicenseData (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
StoreEntryId (inherited from ItemType)
Subject (inherited from ItemType)
TextBody (inherited from ItemType)
ToRecipients (inherited from MessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ReplyAllToItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReplyAllToItemType Constructor

Initializes a new instance of the ReplyAllToItemType class.

public ReplyAllToItemType();

See Also

ReplyAllToItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReplyBody Class

For a list of all members of this type, see ReplyBody Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ReplyBody

public class ReplyBody

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ReplyBody Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReplyBody Members

ReplyBody overview

Public Instance Constructors

ReplyBody Constructor Initializes a new instance of the ReplyBody class.

Public Instance Properties

lang
Message

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ReplyBody Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReplyBody Constructor

Initializes a new instance of the ReplyBody class.

public ReplyBody();

See Also

ReplyBody Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReplyBody Properties

The properties of the ReplyBody class are listed below. For a complete list of ReplyBody class members, see the ReplyBody Members topic.

Public Instance Properties

lang
Message

See Also

ReplyBody Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


lang Property

Aspose.Email

ReplyBody.lang Property

public string lang {get; set;}

Remarks

See Also

ReplyBody Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Message Property

Aspose.Email

ReplyBody.Message Property

public string Message {get; set;}

Remarks

See Also

ReplyBody Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReplyToItemType Class

For a list of all members of this type, see ReplyToItemType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ItemType
Aspose.Email.Exchange.Schema.Exchange_2013.MessageType
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseObjectCoreType
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseObjectType
Aspose.Email.Exchange.Schema.Exchange_2013.SmartResponseBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.SmartResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.ReplyToItemType

public class ReplyToItemType : SmartResponseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ReplyToItemType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReplyToItemType Members

ReplyToItemType overview

Public Instance Constructors

ReplyToItemType Constructor Initializes a new instance of the ReplyToItemType class.

Public Instance Properties

ArchiveTag (inherited from ItemType)
Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
BlockStatus (inherited from ItemType)
BlockStatusSpecified (inherited from ItemType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
EntityExtractionResult (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
Flag (inherited from ItemType)
From (inherited from MessageType)
GroupingAction (inherited from ItemType)
GroupingActionSpecified (inherited from ItemType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBlockedImages (inherited from ItemType)
HasBlockedImagesSpecified (inherited from ItemType)
IconIndex (inherited from ItemType)
IconIndexSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InstanceKey (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
NewBodyContent (inherited from SmartResponseType)
NextPredictedAction (inherited from ItemType)
NextPredictedActionSpecified (inherited from ItemType)
NormalizedBody (inherited from ItemType)
ObjectName (inherited from ResponseObjectType)
ParentFolderId (inherited from ItemType)
PolicyTag (inherited from ItemType)
Preview (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
ReferenceItemId (inherited from ResponseObjectCoreType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReminderNextTime (inherited from ItemType)
ReminderNextTimeSpecified (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
RetentionDate (inherited from ItemType)
RetentionDateSpecified (inherited from ItemType)
RightsManagementLicenseData (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
StoreEntryId (inherited from ItemType)
Subject (inherited from ItemType)
TextBody (inherited from ItemType)
ToRecipients (inherited from MessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ReplyToItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReplyToItemType Constructor

Initializes a new instance of the ReplyToItemType class.

public ReplyToItemType();

See Also

ReplyToItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RequestAttachmentIdType Class

For a list of all members of this type, see RequestAttachmentIdType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseItemIdType
Aspose.Email.Exchange.Schema.Exchange_2013.RequestAttachmentIdType
Aspose.Email.Exchange.Schema.Exchange_2013.AttachmentIdType

public class RequestAttachmentIdType : BaseItemIdType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RequestAttachmentIdType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RequestAttachmentIdType Members

RequestAttachmentIdType overview

Public Instance Constructors

RequestAttachmentIdType Constructor Initializes a new instance of the RequestAttachmentIdType class.

Public Instance Properties

Id

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RequestAttachmentIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RequestAttachmentIdType Constructor

Initializes a new instance of the RequestAttachmentIdType class.

public RequestAttachmentIdType();

See Also

RequestAttachmentIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RequestAttachmentIdType Properties

The properties of the RequestAttachmentIdType class are listed below. For a complete list of RequestAttachmentIdType class members, see the RequestAttachmentIdType Members topic.

Public Instance Properties

Id

See Also

RequestAttachmentIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Id Property

Aspose.Email

RequestAttachmentIdType.Id Property

public string Id {get; set;}

Remarks

See Also

RequestAttachmentIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RequestServerVersion Class

For a list of all members of this type, see RequestServerVersion Members.

System.Object
System.Web.Services.Protocols.SoapHeader
Aspose.Email.Exchange.Schema.Exchange_2013.RequestServerVersion

public class RequestServerVersion : SoapHeader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RequestServerVersion Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RequestServerVersion Members

RequestServerVersion overview

Public Instance Constructors

RequestServerVersion Constructor Initializes a new instance of the RequestServerVersion class.

Public Instance Properties

Actor (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.
AnyAttr |
DidUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether an XML Web service method properly processed a SOAP header.
EncodedMustUnderstand (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.1.
EncodedMustUnderstand12 (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.2.
EncodedRelay (inherited from SoapHeader) | Gets or sets the relay attribute of the SOAP 1.2 header.
MustUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether the SoapHeader must be understood.
Relay (inherited from SoapHeader) | Gets or sets a value that indicates whether the SOAP header is to be relayed to the next SOAP node if the current node does not understand the header.
Role (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.
Version |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RequestServerVersion Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RequestServerVersion Constructor

Initializes a new instance of the RequestServerVersion class.

public RequestServerVersion();

See Also

RequestServerVersion Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RequestServerVersion Properties

The properties of the RequestServerVersion class are listed below. For a complete list of RequestServerVersion class members, see the RequestServerVersion Members topic.

Public Instance Properties

Actor (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.
AnyAttr |
DidUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether an XML Web service method properly processed a SOAP header.
EncodedMustUnderstand (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.1.
EncodedMustUnderstand12 (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.2.
EncodedRelay (inherited from SoapHeader) | Gets or sets the relay attribute of the SOAP 1.2 header.
MustUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether the SoapHeader must be understood.
Relay (inherited from SoapHeader) | Gets or sets a value that indicates whether the SOAP header is to be relayed to the next SOAP node if the current node does not understand the header.
Role (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.
Version |

See Also

RequestServerVersion Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AnyAttr Property

Aspose.Email

RequestServerVersion.AnyAttr Property

public XmlAttribute[] AnyAttr {get; set;}

Remarks

See Also

RequestServerVersion Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Version Property

Aspose.Email

RequestServerVersion.Version Property

public ExchangeVersionType Version {get; set;}

Remarks

See Also

RequestServerVersion Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResetUMMailboxResponseMessageType Class

For a list of all members of this type, see ResetUMMailboxResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.ResetUMMailboxResponseMessageType

public class ResetUMMailboxResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ResetUMMailboxResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResetUMMailboxResponseMessageType Members

ResetUMMailboxResponseMessageType overview

Public Instance Constructors

ResetUMMailboxResponseMessageType Constructor Initializes a new instance of the ResetUMMailboxResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ResetUMMailboxResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResetUMMailboxResponseMessageType Constructor

Initializes a new instance of the ResetUMMailboxResponseMessageType class.

public ResetUMMailboxResponseMessageType();

See Also

ResetUMMailboxResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResetUMMailboxType Class

For a list of all members of this type, see ResetUMMailboxType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.ResetUMMailboxType

public class ResetUMMailboxType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ResetUMMailboxType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResetUMMailboxType Members

ResetUMMailboxType overview

Public Instance Constructors

ResetUMMailboxType Constructor Initializes a new instance of the ResetUMMailboxType class.

Public Instance Properties

KeepProperties

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ResetUMMailboxType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResetUMMailboxType Constructor

Initializes a new instance of the ResetUMMailboxType class.

public ResetUMMailboxType();

See Also

ResetUMMailboxType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResetUMMailboxType Properties

The properties of the ResetUMMailboxType class are listed below. For a complete list of ResetUMMailboxType class members, see the ResetUMMailboxType Members topic.

Public Instance Properties

KeepProperties

See Also

ResetUMMailboxType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


KeepProperties Property

Aspose.Email

ResetUMMailboxType.KeepProperties Property

public bool KeepProperties {get; set;}

Remarks

See Also

ResetUMMailboxType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResolutionType Class

For a list of all members of this type, see ResolutionType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResolutionType

public class ResolutionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ResolutionType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResolutionType Members

ResolutionType overview

Public Instance Constructors

ResolutionType Constructor Initializes a new instance of the ResolutionType class.

Public Instance Properties

Contact
Mailbox

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ResolutionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResolutionType Constructor

Initializes a new instance of the ResolutionType class.

public ResolutionType();

See Also

ResolutionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResolutionType Properties

The properties of the ResolutionType class are listed below. For a complete list of ResolutionType class members, see the ResolutionType Members topic.

Public Instance Properties

Contact
Mailbox

See Also

ResolutionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Contact Property

Aspose.Email

ResolutionType.Contact Property

public ContactItemType Contact {get; set;}

Remarks

See Also

ResolutionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Mailbox Property

Aspose.Email

ResolutionType.Mailbox Property

public EmailAddressType Mailbox {get; set;}

Remarks

See Also

ResolutionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResolveNamesCompletedEventArgs Class

For a list of all members of this type, see ResolveNamesCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.ResolveNamesCompletedEventArgs

public class ResolveNamesCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ResolveNamesCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResolveNamesCompletedEventArgs Members

ResolveNamesCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

ResolveNamesCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResolveNamesCompletedEventArgs Properties

The properties of the ResolveNamesCompletedEventArgs class are listed below. For a complete list of ResolveNamesCompletedEventArgs class members, see the ResolveNamesCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

ResolveNamesCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

ResolveNamesCompletedEventArgs.Result Property

public ResolveNamesResponseType Result {get;}

Remarks

See Also

ResolveNamesCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResolveNamesCompletedEventHandler Delegate

public delegate void ResolveNamesCompletedEventHandler(
object sender,
ResolveNamesCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResolveNamesResponseMessageType Class

For a list of all members of this type, see ResolveNamesResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.ResolveNamesResponseMessageType

public class ResolveNamesResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ResolveNamesResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResolveNamesResponseMessageType Members

ResolveNamesResponseMessageType overview

Public Instance Constructors

ResolveNamesResponseMessageType Constructor Initializes a new instance of the ResolveNamesResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResolutionSet
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ResolveNamesResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResolveNamesResponseMessageType Constructor

Initializes a new instance of the ResolveNamesResponseMessageType class.

public ResolveNamesResponseMessageType();

See Also

ResolveNamesResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResolveNamesResponseMessageType Properties

The properties of the ResolveNamesResponseMessageType class are listed below. For a complete list of ResolveNamesResponseMessageType class members, see the ResolveNamesResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResolutionSet
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

ResolveNamesResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResolutionSet Property

Aspose.Email

ResolveNamesResponseMessageType.ResolutionSet Property

public ArrayOfResolutionType ResolutionSet {get; set;}

Remarks

See Also

ResolveNamesResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResolveNamesResponseType Class

For a list of all members of this type, see ResolveNamesResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.ResolveNamesResponseType

public class ResolveNamesResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ResolveNamesResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResolveNamesResponseType Members

ResolveNamesResponseType overview

Public Instance Constructors

ResolveNamesResponseType Constructor Initializes a new instance of the ResolveNamesResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ResolveNamesResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResolveNamesResponseType Constructor

Initializes a new instance of the ResolveNamesResponseType class.

public ResolveNamesResponseType();

See Also

ResolveNamesResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResolveNamesSearchScopeType Enumeration

public enum ResolveNamesSearchScopeType

Remarks

Members

Member Name | Description | Value
ActiveDirectory |  | 0
ActiveDirectoryContacts |  | 1
Contacts |  | 2
ContactsActiveDirectory |  | 3

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResolveNamesType Class

For a list of all members of this type, see ResolveNamesType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.ResolveNamesType

public class ResolveNamesType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ResolveNamesType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResolveNamesType Members

ResolveNamesType overview

Public Instance Constructors

ResolveNamesType Constructor Initializes a new instance of the ResolveNamesType class.

Public Instance Properties

ContactDataShape
ContactDataShapeSpecified
ParentFolderIds
ReturnFullContactData
SearchScope
UnresolvedEntry

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ResolveNamesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResolveNamesType Constructor

Initializes a new instance of the ResolveNamesType class.

public ResolveNamesType();

See Also

ResolveNamesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResolveNamesType Properties

The properties of the ResolveNamesType class are listed below. For a complete list of ResolveNamesType class members, see the ResolveNamesType Members topic.

Public Instance Properties

ContactDataShape
ContactDataShapeSpecified
ParentFolderIds
ReturnFullContactData
SearchScope
UnresolvedEntry

See Also

ResolveNamesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContactDataShape Property

Aspose.Email

ResolveNamesType.ContactDataShape Property

public DefaultShapeNamesType ContactDataShape {get; set;}

Remarks

See Also

ResolveNamesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContactDataShapeSpecified Property

Aspose.Email

ResolveNamesType.ContactDataShapeSpecified Property

public bool ContactDataShapeSpecified {get; set;}

Remarks

See Also

ResolveNamesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ParentFolderIds Property

Aspose.Email

ResolveNamesType.ParentFolderIds Property

public BaseFolderIdType[] ParentFolderIds {get; set;}

Remarks

See Also

ResolveNamesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReturnFullContactData Property

Aspose.Email

ResolveNamesType.ReturnFullContactData Property

public bool ReturnFullContactData {get; set;}

Remarks

See Also

ResolveNamesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchScope Property

Aspose.Email

ResolveNamesType.SearchScope Property

public ResolveNamesSearchScopeType SearchScope {get; set;}

Remarks

See Also

ResolveNamesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UnresolvedEntry Property

Aspose.Email

ResolveNamesType.UnresolvedEntry Property

public string UnresolvedEntry {get; set;}

Remarks

See Also

ResolveNamesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResponseClassType Enumeration

public enum ResponseClassType

Remarks

Members

Member Name | Description | Value
Success |  | 0
Warning |  | 1
Error |  | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResponseCodeType Enumeration

public enum ResponseCodeType

Remarks

Members

Member Name | Description | Value
NoError |  | 0
ErrorAccessDenied |  | 1
ErrorAccessModeSpecified |  | 2
ErrorAccountDisabled |  | 3
ErrorAddDelegatesFailed |  | 4
ErrorAddressSpaceNotFound |  | 5
ErrorADOperation |  | 6
ErrorADSessionFilter |  | 7
ErrorADUnavailable |  | 8
ErrorAutoDiscoverFailed |  | 9
ErrorAffectedTaskOccurrencesRequired |  | 10
ErrorAttachmentNestLevelLimitExceeded |  | 11
ErrorAttachmentSizeLimitExceeded |  | 12
ErrorArchiveFolderPathCreation |  | 13
ErrorArchiveMailboxNotEnabled |  | 14
ErrorArchiveMailboxServiceDiscoveryFailed |  | 15
ErrorAvailabilityConfigNotFound |  | 16
ErrorBatchProcessingStopped |  | 17
ErrorCalendarCannotMoveOrCopyOccurrence |  | 18
ErrorCalendarCannotUpdateDeletedItem |  | 19
ErrorCalendarCannotUseIdForOccurrenceId |  | 20
ErrorCalendarCannotUseIdForRecurringMasterId |  | 21
ErrorCalendarDurationIsTooLong |  | 22
ErrorCalendarEndDateIsEarlierThanStartDate |  | 23
ErrorCalendarFolderIsInvalidForCalendarView |  | 24
ErrorCalendarInvalidAttributeValue |  | 25
ErrorCalendarInvalidDayForTimeChangePattern |  | 26
ErrorCalendarInvalidDayForWeeklyRecurrence |  | 27
ErrorCalendarInvalidPropertyState |  | 28
ErrorCalendarInvalidPropertyValue |  | 29
ErrorCalendarInvalidRecurrence |  | 30
ErrorCalendarInvalidTimeZone |  | 31
ErrorCalendarIsCancelledForAccept |  | 32
ErrorCalendarIsCancelledForDecline |  | 33
ErrorCalendarIsCancelledForRemove |  | 34
ErrorCalendarIsCancelledForTentative |  | 35
ErrorCalendarIsDelegatedForAccept |  | 36
ErrorCalendarIsDelegatedForDecline |  | 37
ErrorCalendarIsDelegatedForRemove |  | 38
ErrorCalendarIsDelegatedForTentative |  | 39
ErrorCalendarIsNotOrganizer |  | 40
ErrorCalendarIsOrganizerForAccept |  | 41
ErrorCalendarIsOrganizerForDecline |  | 42
ErrorCalendarIsOrganizerForRemove |  | 43
ErrorCalendarIsOrganizerForTentative |  | 44
ErrorCalendarOccurrenceIndexIsOutOfRecurrenceRange |  | 45
ErrorCalendarOccurrenceIsDeletedFromRecurrence |  | 46
ErrorCalendarOutOfRange |  | 47
ErrorCalendarMeetingRequestIsOutOfDate |  | 48
ErrorCalendarViewRangeTooBig |  | 49
ErrorCallerIsInvalidADAccount |  | 50
ErrorCannotArchiveCalendarContactTaskFolderException |  | 51
ErrorCannotArchiveItemsInPublicFolders |  | 52
ErrorCannotArchiveItemsInArchiveMailbo |  | 53
ErrorCannotCreateCalendarItemInNonCalendarFolder |  | 54
ErrorCannotCreateContactInNonContactFolder |  | 55
ErrorCannotCreatePostItemInNonMailFolder |  | 56
ErrorCannotCreateTaskInNonTaskFolder |  | 57
ErrorCannotDeleteObject |  | 58
ErrorCannotDisableMandatoryExtension |  | 59
ErrorCannotGetSourceFolderPath |  | 60
ErrorCannotGetExternalEcpUrl |  | 61
ErrorCannotOpenFileAttachment |  | 62
ErrorCannotDeleteTaskOccurrence |  | 63
ErrorCannotEmptyFolder |  | 64
ErrorCannotSetCalendarPermissionOnNonCalendarFolder |  | 65
ErrorCannotSetNonCalendarPermissionOnCalendarFolder |  | 66
ErrorCannotSetPermissionUnknownEntries |  | 67
ErrorCannotSpecifySearchFolderAsSourceFolder |  | 68
ErrorCannotUseFolderIdForItemId |  | 69
ErrorCannotUseItemIdForFolderId |  | 70
ErrorChangeKeyRequired |  | 71
ErrorChangeKeyRequiredForWriteOperations |  | 72
ErrorClientDisconnected |  | 73
ErrorClientIntentInvalidStateDefinition |  | 74
ErrorClientIntentNotFound |  | 75
ErrorConnectionFailed |  | 76
ErrorContainsFilterWrongType |  | 77
ErrorContentConversionFailed |  | 78
ErrorContentIndexingNotEnabled |  | 79
ErrorCorruptData |  | 80
ErrorCreateItemAccessDenied |  | 81
ErrorCreateManagedFolderPartialCompletion |  | 82
ErrorCreateSubfolderAccessDenied |  | 83
ErrorCrossMailboxMoveCopy |  | 84
ErrorCrossSiteRequest |  | 85
ErrorDataSizeLimitExceeded |  | 86
ErrorDataSourceOperation |  | 87
ErrorDelegateAlreadyExists |  | 88
ErrorDelegateCannotAddOwner |  | 89
ErrorDelegateMissingConfiguration |  | 90
ErrorDelegateNoUser |  | 91
ErrorDelegateValidationFailed |  | 92
ErrorDeleteDistinguishedFolder |  | 93
ErrorDeleteItemsFailed |  | 94
ErrorDeleteUnifiedMessagingPromptFailed |  | 95
ErrorDistinguishedUserNotSupported |  | 96
ErrorDistributionListMemberNotExist |  | 97
ErrorDuplicateInputFolderNames |  | 98
ErrorDuplicateUserIdsSpecified |  | 99
ErrorEmailAddressMismatch |  | 100
ErrorEventNotFound |  | 101
ErrorExceededConnectionCount |  | 102
ErrorExceededSubscriptionCount |  | 103
ErrorExceededFindCountLimit |  | 104
ErrorExpiredSubscription |  | 105
ErrorExtensionNotFound |  | 106
ErrorFolderCorrupt |  | 107
ErrorFolderNotFound |  | 108
ErrorFolderPropertRequestFailed |  | 109
ErrorFolderSave |  | 110
ErrorFolderSaveFailed |  | 111
ErrorFolderSavePropertyError |  | 112
ErrorFolderExists |  | 113
ErrorFreeBusyGenerationFailed |  | 114
ErrorGetServerSecurityDescriptorFailed |  | 115
ErrorImContactLimitReached |  | 116
ErrorImGroupDisplayNameAlreadyExists |  | 117
ErrorImGroupLimitReached |  | 118
ErrorImpersonateUserDenied |  | 119
ErrorImpersonationDenied |  | 120
ErrorImpersonationFailed |  | 121
ErrorIncorrectSchemaVersion |  | 122
ErrorIncorrectUpdatePropertyCount |  | 123
ErrorIndividualMailboxLimitReached |  | 124
ErrorInsufficientResources |  | 125
ErrorInternalServerError |  | 126
ErrorInternalServerTransientError |  | 127
ErrorInvalidAccessLevel |  | 128
ErrorInvalidArgument |  | 129
ErrorInvalidAttachmentId |  | 130
ErrorInvalidAttachmentSubfilter |  | 131
ErrorInvalidAttachmentSubfilterTextFilter |  | 132
ErrorInvalidAuthorizationContext |  | 133
ErrorInvalidChangeKey |  | 134
ErrorInvalidClientSecurityContext |  | 135
ErrorInvalidCompleteDate |  | 136
ErrorInvalidContactEmailAddress |  | 137
ErrorInvalidContactEmailIndex |  | 138
ErrorInvalidCrossForestCredentials |  | 139
ErrorInvalidDelegatePermission |  | 140
ErrorInvalidDelegateUserId |  | 141
ErrorInvalidExcludesRestriction |  | 142
ErrorInvalidExpressionTypeForSubFilter |  | 143
ErrorInvalidExtendedProperty |  | 144
ErrorInvalidExtendedPropertyValue |  | 145
ErrorInvalidFolderId |  | 146
ErrorInvalidFolderTypeForOperation |  | 147
ErrorInvalidFractionalPagingParameters |  | 148
ErrorInvalidFreeBusyViewType |  | 149
ErrorInvalidId |  | 150
ErrorInvalidIdEmpty |  | 151
ErrorInvalidIdMalformed |  | 152
ErrorInvalidIdMalformedEwsLegacyIdFormat |  | 153
ErrorInvalidIdMonikerTooLong |  | 154
ErrorInvalidIdNotAnItemAttachmentId |  | 155
ErrorInvalidIdReturnedByResolveNames |  | 156
ErrorInvalidIdStoreObjectIdTooLong |  | 157
ErrorInvalidIdTooManyAttachmentLevels |  | 158
ErrorInvalidIdXml |  | 159
ErrorInvalidImContactId |  | 160
ErrorInvalidImDistributionGroupSmtpAddress |  | 161
ErrorInvalidImGroupId |  | 162
ErrorInvalidIndexedPagingParameters |  | 163
ErrorInvalidInternetHeaderChildNodes |  | 164
ErrorInvalidItemForOperationArchiveItem |  | 165
ErrorInvalidItemForOperationCreateItemAttachment |  | 166
ErrorInvalidItemForOperationCreateItem |  | 167
ErrorInvalidItemForOperationAcceptItem |  | 168
ErrorInvalidItemForOperationDeclineItem |  | 169
ErrorInvalidItemForOperationCancelItem |  | 170
ErrorInvalidItemForOperationExpandDL |  | 171
ErrorInvalidItemForOperationRemoveItem |  | 172
ErrorInvalidItemForOperationSendItem |  | 173
ErrorInvalidItemForOperationTentative |  | 174
ErrorInvalidLogonType |  | 175
ErrorInvalidMailbox |  | 176
ErrorInvalidManagedFolderProperty |  | 177
ErrorInvalidManagedFolderQuota |  | 178
ErrorInvalidManagedFolderSize |  | 179
ErrorInvalidMergedFreeBusyInterval |  | 180
ErrorInvalidNameForNameResolution |  | 181
ErrorInvalidOperation |  | 182
ErrorInvalidNetworkServiceContext |  | 183
ErrorInvalidOofParameter |  | 184
ErrorInvalidPagingMaxRows |  | 185
ErrorInvalidParentFolder |  | 186
ErrorInvalidPercentCompleteValue |  | 187
ErrorInvalidPermissionSettings |  | 188
ErrorInvalidPhoneCallId |  | 189
ErrorInvalidPhoneNumber |  | 190
ErrorInvalidUserInfo |  | 191
ErrorInvalidPropertyAppend |  | 192
ErrorInvalidPropertyDelete |  | 193
ErrorInvalidPropertyForExists |  | 194
ErrorInvalidPropertyForOperation |  | 195
ErrorInvalidPropertyRequest |  | 196
ErrorInvalidPropertySet |  | 197
ErrorInvalidPropertyUpdateSentMessage |  | 198
ErrorInvalidProxySecurityContext |  | 199
ErrorInvalidPullSubscriptionId |  | 200
ErrorInvalidPushSubscriptionUrl |  | 201
ErrorInvalidRecipients |  | 202
ErrorInvalidRecipientSubfilter |  | 203
ErrorInvalidRecipientSubfilterComparison |  | 204
ErrorInvalidRecipientSubfilterOrder |  | 205
ErrorInvalidRecipientSubfilterTextFilter |  | 206
ErrorInvalidReferenceItem |  | 207
ErrorInvalidRequest |  | 208
ErrorInvalidRestriction |  | 209
ErrorInvalidRetentionTagTypeMismatch |  | 210
ErrorInvalidRetentionTagInvisible |  | 211
ErrorInvalidRetentionTagInheritance |  | 212
ErrorInvalidRetentionTagIdGuid |  | 213
ErrorInvalidRoutingType |  | 214
ErrorInvalidScheduledOofDuration |  | 215
ErrorInvalidSchemaVersionForMailboxVersion |  | 216
ErrorInvalidSecurityDescriptor |  | 217
ErrorInvalidSendItemSaveSettings |  | 218
ErrorInvalidSerializedAccessToken |  | 219
ErrorInvalidServerVersion |  | 220
ErrorInvalidSid |  | 221
ErrorInvalidSIPUri |  | 222
ErrorInvalidSmtpAddress |  | 223
ErrorInvalidSubfilterType |  | 224
ErrorInvalidSubfilterTypeNotAttendeeType |  | 225
ErrorInvalidSubfilterTypeNotRecipientType |  | 226
ErrorInvalidSubscription |  | 227
ErrorInvalidSubscriptionRequest |  | 228
ErrorInvalidSyncStateData |  | 229
ErrorInvalidTimeInterval |  | 230
ErrorInvalidUserOofSettings |  | 231
ErrorInvalidUserPrincipalName |  | 232
ErrorInvalidUserSid |  | 233
ErrorInvalidUserSidMissingUPN |  | 234
ErrorInvalidValueForProperty |  | 235
ErrorInvalidWatermark |  | 236
ErrorIPGatewayNotFound |  | 237
ErrorIrresolvableConflict |  | 238
ErrorItemCorrupt |  | 239
ErrorItemNotFound |  | 240
ErrorItemPropertyRequestFailed |  | 241
ErrorItemSave |  | 242
ErrorItemSavePropertyError |  | 243
ErrorLegacyMailboxFreeBusyViewTypeNotMerged |  | 244
ErrorLocalServerObjectNotFound |  | 245
ErrorLogonAsNetworkServiceFailed |  | 246
ErrorMailboxConfiguration |  | 247
ErrorMailboxDataArrayEmpty |  | 248
ErrorMailboxDataArrayTooBig |  | 249
ErrorMailboxHoldNotFound |  | 250
ErrorMailboxLogonFailed |  | 251
ErrorMailboxMoveInProgress |  | 252
ErrorMailboxStoreUnavailable |  | 253
ErrorMailRecipientNotFound |  | 254
ErrorMailTipsDisabled |  | 255
ErrorManagedFolderAlreadyExists |  | 256
ErrorManagedFolderNotFound |  | 257
ErrorManagedFoldersRootFailure |  | 258
ErrorMeetingSuggestionGenerationFailed |  | 259
ErrorMessageDispositionRequired |  | 260
ErrorMessageSizeExceeded |  | 261
ErrorMimeContentConversionFailed |  | 262
ErrorMimeContentInvalid |  | 263
ErrorMimeContentInvalidBase64String |  | 264
ErrorMissingArgument |  | 265
ErrorMissingEmailAddress |  | 266
ErrorMissingEmailAddressForManagedFolder |  | 267
ErrorMissingInformationEmailAddress |  | 268
ErrorMissingInformationReferenceItemId |  | 269
ErrorMissingItemForCreateItemAttachment |  | 270
ErrorMissingManagedFolderId |  | 271
ErrorMissingRecipients |  | 272
ErrorMissingUserIdInformation |  | 273
ErrorMoreThanOneAccessModeSpecified |  | 274
ErrorMoveCopyFailed |  | 275
ErrorMoveDistinguishedFolder |  | 276
ErrorMultiLegacyMailboxAccess |  | 277
ErrorNameResolutionMultipleResults |  | 278
ErrorNameResolutionNoMailbox |  | 279
ErrorNameResolutionNoResults |  | 280
ErrorNoApplicableProxyCASServersAvailable |  | 281
ErrorNoCalendar |  | 282
ErrorNoDestinationCASDueToKerberosRequirements |  | 283
ErrorNoDestinationCASDueToSSLRequirements |  | 284
ErrorNoDestinationCASDueToVersionMismatch |  | 285
ErrorNoFolderClassOverride |  | 286
ErrorNoFreeBusyAccess |  | 287
ErrorNonExistentMailbox |  | 288
ErrorNonPrimarySmtpAddress |  | 289
ErrorNoPropertyTagForCustomProperties |  | 290
ErrorNoPublicFolderReplicaAvailable |  | 291
ErrorNoPublicFolderServerAvailable |  | 292
ErrorNoRespondingCASInDestinationSite |  | 293
ErrorNotDelegate |  | 294
ErrorNotEnoughMemory |  | 295
ErrorObjectTypeChanged |  | 296
ErrorOccurrenceCrossingBoundary |  | 297
ErrorOccurrenceTimeSpanTooBig |  | 298
ErrorOperationNotAllowedWithPublicFolderRoot |  | 299
ErrorParentFolderIdRequired |  | 300
ErrorParentFolderNotFound |  | 301
ErrorPasswordChangeRequired |  | 302
ErrorPasswordExpired |  | 303
ErrorPhoneNumberNotDialable |  | 304
ErrorPropertyUpdate |  | 305
ErrorPromptPublishingOperationFailed |  | 306
ErrorPropertyValidationFailure |  | 307
ErrorProxiedSubscriptionCallFailure |  | 308
ErrorProxyCallFailed |  | 309
ErrorProxyGroupSidLimitExceeded |  | 310
ErrorProxyRequestNotAllowed |  | 311
ErrorProxyRequestProcessingFailed |  | 312
ErrorProxyServiceDiscoveryFailed |  | 313
ErrorProxyTokenExpired |  | 314
ErrorPublicFolderMailboxDiscoveryFailed |  | 315
ErrorPublicFolderOperationFailed |  | 316
ErrorPublicFolderRequestProcessingFailed |  | 317
ErrorPublicFolderServerNotFound |  | 318
ErrorPublicFolderSyncException |  | 319
ErrorQueryFilterTooLong |  | 320
ErrorQuotaExceeded |  | 321
ErrorReadEventsFailed |  | 322
ErrorReadReceiptNotPending |  | 323
ErrorRecurrenceEndDateTooBig |  | 324
ErrorRecurrenceHasNoOccurrence |  | 325
ErrorRemoveDelegatesFailed |  | 326
ErrorRequestAborted |  | 327
ErrorRequestStreamTooBig |  | 328
ErrorRequiredPropertyMissing |  | 329
ErrorResolveNamesInvalidFolderType |  | 330
ErrorResolveNamesOnlyOneContactsFolderAllowed |  | 331
ErrorResponseSchemaValidation |  | 332
ErrorRestrictionTooLong |  | 333
ErrorRestrictionTooComplex |  | 334
ErrorResultSetTooBig |  | 335
ErrorInvalidExchangeImpersonationHeaderData |  | 336
ErrorSavedItemFolderNotFound |  | 337
ErrorSchemaValidation |  | 338
ErrorSearchFolderNotInitialized |  | 339
ErrorSendAsDenied |  | 340
ErrorSendMeetingCancellationsRequired |  | 341
ErrorSendMeetingInvitationsOrCancellationsRequired |  | 342
ErrorSendMeetingInvitationsRequired |  | 343
ErrorSentMeetingRequestUpdate |  | 344
ErrorSentTaskRequestUpdate |  | 345
ErrorServerBusy |  | 346
ErrorServiceDiscoveryFailed |  | 347
ErrorStaleObject |  | 348
ErrorSubmissionQuotaExceeded |  | 349
ErrorSubscriptionAccessDenied |  | 350
ErrorSubscriptionDelegateAccessNotSupported |  | 351
ErrorSubscriptionNotFound |  | 352
ErrorSubscriptionUnsubscribed |  | 353
ErrorSyncFolderNotFound |  | 354
ErrorTeamMailboxNotFound |  | 355
ErrorTeamMailboxNotLinkedToSharePoint |  | 356
ErrorTeamMailboxUrlValidationFailed |  | 357
ErrorTeamMailboxNotAuthorizedOwner |  | 358
ErrorTeamMailboxActiveToPendingDelete |  | 359
ErrorTeamMailboxFailedSendingNotifications |  | 360
ErrorTeamMailboxErrorUnknown |  | 361
ErrorTimeIntervalTooBig |  | 362
ErrorTimeoutExpired |  | 363
ErrorTimeZone |  | 364
ErrorToFolderNotFound |  | 365
ErrorTokenSerializationDenied |  | 366
ErrorUpdatePropertyMismatch |  | 367
ErrorUnifiedMessagingDialPlanNotFound |  | 368
ErrorUnifiedMessagingReportDataNotFound |  | 369
ErrorUnifiedMessagingPromptNotFound |  | 370
ErrorUnifiedMessagingRequestFailed |  | 371
ErrorUnifiedMessagingServerNotFound |  | 372
ErrorUnableToGetUserOofSettings |  | 373
ErrorUnableToRemoveImContactFromGroup |  | 374
ErrorUnsupportedSubFilter |  | 375
ErrorUnsupportedCulture |  | 376
ErrorUnsupportedMapiPropertyType |  | 377
ErrorUnsupportedMimeConversion |  | 378
ErrorUnsupportedPathForQuery |  | 379
ErrorUnsupportedPathForSortGroup |  | 380
ErrorUnsupportedPropertyDefinition |  | 381
ErrorUnsupportedQueryFilter |  | 382
ErrorUnsupportedRecurrence |  | 383
ErrorUnsupportedTypeForConversion |  | 384
ErrorUpdateDelegatesFailed |  | 385
ErrorUserNotUnifiedMessagingEnabled |  | 386
ErrorVoiceMailNotImplemented |  | 387
ErrorValueOutOfRange |  | 388
ErrorVirusDetected |  | 389
ErrorVirusMessageDeleted |  | 390
ErrorWebRequestInInvalidState |  | 391
ErrorWin32InteropError |  | 392
ErrorWorkingHoursSaveFailed |  | 393
ErrorWorkingHoursXmlMalformed |  | 394
ErrorWrongServerVersion |  | 395
ErrorWrongServerVersionDelegate |  | 396
ErrorMissingInformationSharingFolderId |  | 397
ErrorDuplicateSOAPHeader |  | 398
ErrorSharingSynchronizationFailed |  | 399
ErrorSharingNoExternalEwsAvailable |  | 400
ErrorFreeBusyDLLimitReached |  | 401
ErrorInvalidGetSharingFolderRequest |  | 402
ErrorNotAllowedExternalSharingByPolicy |  | 403
ErrorUserNotAllowedByPolicy |  | 404
ErrorPermissionNotAllowedByPolicy |  | 405
ErrorOrganizationNotFederated |  | 406
ErrorMailboxFailover |  | 407
ErrorInvalidExternalSharingInitiator |  | 408
ErrorMessageTrackingPermanentError |  | 409
ErrorMessageTrackingTransientError |  | 410
ErrorMessageTrackingNoSuchDomain |  | 411
ErrorUserWithoutFederatedProxyAddress |  | 412
ErrorInvalidOrganizationRelationshipForFreeBusy |  | 413
ErrorInvalidFederatedOrganizationId |  | 414
ErrorInvalidExternalSharingSubscriber |  | 415
ErrorInvalidSharingData |  | 416
ErrorInvalidSharingMessage |  | 417
ErrorNotSupportedSharingMessage |  | 418
ErrorApplyConversationActionFailed |  | 419
ErrorInboxRulesValidationError |  | 420
ErrorOutlookRuleBlobExists |  | 421
ErrorRulesOverQuota |  | 422
ErrorNewEventStreamConnectionOpened |  | 423
ErrorMissedNotificationEvents |  | 424
ErrorDuplicateLegacyDistinguishedName |  | 425
ErrorInvalidClientAccessTokenRequest |  | 426
ErrorNoSpeechDetected |  | 427
ErrorUMServerUnavailable |  | 428
ErrorRecipientNotFound |  | 429
ErrorRecognizerNotInstalled |  | 430
ErrorSpeechGrammarError |  | 431
ErrorInvalidManagementRoleHeader |  | 432
ErrorLocationServicesDisabled |  | 433
ErrorLocationServicesRequestTimedOut |  | 434
ErrorLocationServicesRequestFailed |  | 435
ErrorLocationServicesInvalidRequest |  | 436
ErrorMailboxScopeNotAllowedWithoutQueryString |  | 437
ErrorArchiveMailboxSearchFailed |  | 438
ErrorArchiveMailboxServiceDiscoveryFailed1 |  | 439
ErrorInvalidPhotoSize |  | 440
ErrorSearchQueryHasTooManyKeywords |  | 441
ErrorSearchTooManyMailboxes |  | 442
ErrorInvalidRetentionTagNone |  | 443
ErrorDiscoverySearchesDisabled |  | 444

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResponseMessageType Class

For a list of all members of this type, see ResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Derived types

public class ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResponseMessageType Members

ResponseMessageType overview

Public Instance Constructors

ResponseMessageType Constructor Initializes a new instance of the ResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey
DescriptiveLinkKeySpecified
MessageText
MessageXml
ResponseClass
ResponseCode
ResponseCodeSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResponseMessageType Constructor

Initializes a new instance of the ResponseMessageType class.

public ResponseMessageType();

See Also

ResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResponseMessageType Properties

The properties of the ResponseMessageType class are listed below. For a complete list of ResponseMessageType class members, see the ResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey
DescriptiveLinkKeySpecified
MessageText
MessageXml
ResponseClass
ResponseCode
ResponseCodeSpecified

See Also

ResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DescriptiveLinkKey Property

Aspose.Email

ResponseMessageType.DescriptiveLinkKey Property

public int DescriptiveLinkKey {get; set;}

Remarks

See Also

ResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DescriptiveLinkKeySpecified Property

Aspose.Email

ResponseMessageType.DescriptiveLinkKeySpecified Property

public bool DescriptiveLinkKeySpecified {get; set;}

Remarks

See Also

ResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MessageText Property

Aspose.Email

ResponseMessageType.MessageText Property

public string MessageText {get; set;}

Remarks

See Also

ResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MessageXml Property

Aspose.Email

ResponseMessageType.MessageXml Property

public ResponseMessageTypeMessageXml MessageXml {get; set;}

Remarks

See Also

ResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResponseClass Property

Aspose.Email

ResponseMessageType.ResponseClass Property

public ResponseClassType ResponseClass {get; set;}

Remarks

See Also

ResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResponseCode Property

Aspose.Email

ResponseMessageType.ResponseCode Property

public ResponseCodeType ResponseCode {get; set;}

Remarks

See Also

ResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResponseCodeSpecified Property

Aspose.Email

ResponseMessageType.ResponseCodeSpecified Property

public bool ResponseCodeSpecified {get; set;}

Remarks

See Also

ResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResponseMessageTypeMessageXml Class

For a list of all members of this type, see ResponseMessageTypeMessageXml Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageTypeMessageXml

public class ResponseMessageTypeMessageXml

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ResponseMessageTypeMessageXml Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResponseMessageTypeMessageXml Members

ResponseMessageTypeMessageXml overview

Public Instance Constructors

ResponseMessageTypeMessageXml Constructor Initializes a new instance of the ResponseMessageTypeMessageXml class.

Public Instance Properties

Any

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ResponseMessageTypeMessageXml Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResponseMessageTypeMessageXml Constructor

Initializes a new instance of the ResponseMessageTypeMessageXml class.

public ResponseMessageTypeMessageXml();

See Also

ResponseMessageTypeMessageXml Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResponseMessageTypeMessageXml Properties

The properties of the ResponseMessageTypeMessageXml class are listed below. For a complete list of ResponseMessageTypeMessageXml class members, see the ResponseMessageTypeMessageXml Members topic.

Public Instance Properties

Any

See Also

ResponseMessageTypeMessageXml Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Any Property

Aspose.Email

ResponseMessageTypeMessageXml.Any Property

public XmlElement[] Any {get; set;}

Remarks

See Also

ResponseMessageTypeMessageXml Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResponseObjectCoreType Class

For a list of all members of this type, see ResponseObjectCoreType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ItemType
Aspose.Email.Exchange.Schema.Exchange_2013.MessageType
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseObjectCoreType
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseObjectType

public abstract class ResponseObjectCoreType : MessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ResponseObjectCoreType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResponseObjectCoreType Members

ResponseObjectCoreType overview

Public Instance Properties

ArchiveTag (inherited from ItemType)
Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
BlockStatus (inherited from ItemType)
BlockStatusSpecified (inherited from ItemType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
EntityExtractionResult (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
Flag (inherited from ItemType)
From (inherited from MessageType)
GroupingAction (inherited from ItemType)
GroupingActionSpecified (inherited from ItemType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBlockedImages (inherited from ItemType)
HasBlockedImagesSpecified (inherited from ItemType)
IconIndex (inherited from ItemType)
IconIndexSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InstanceKey (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
NextPredictedAction (inherited from ItemType)
NextPredictedActionSpecified (inherited from ItemType)
NormalizedBody (inherited from ItemType)
ParentFolderId (inherited from ItemType)
PolicyTag (inherited from ItemType)
Preview (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
ReferenceItemId
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReminderNextTime (inherited from ItemType)
ReminderNextTimeSpecified (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
RetentionDate (inherited from ItemType)
RetentionDateSpecified (inherited from ItemType)
RightsManagementLicenseData (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
StoreEntryId (inherited from ItemType)
Subject (inherited from ItemType)
TextBody (inherited from ItemType)
ToRecipients (inherited from MessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

ResponseObjectCoreType Constructor Initializes a new instance of the ResponseObjectCoreType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ResponseObjectCoreType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResponseObjectCoreType Constructor

Initializes a new instance of the ResponseObjectCoreType class.

protected ResponseObjectCoreType();

See Also

ResponseObjectCoreType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResponseObjectCoreType Properties

The properties of the ResponseObjectCoreType class are listed below. For a complete list of ResponseObjectCoreType class members, see the ResponseObjectCoreType Members topic.

Public Instance Properties

ArchiveTag (inherited from ItemType)
Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
BlockStatus (inherited from ItemType)
BlockStatusSpecified (inherited from ItemType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
EntityExtractionResult (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
Flag (inherited from ItemType)
From (inherited from MessageType)
GroupingAction (inherited from ItemType)
GroupingActionSpecified (inherited from ItemType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBlockedImages (inherited from ItemType)
HasBlockedImagesSpecified (inherited from ItemType)
IconIndex (inherited from ItemType)
IconIndexSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InstanceKey (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
NextPredictedAction (inherited from ItemType)
NextPredictedActionSpecified (inherited from ItemType)
NormalizedBody (inherited from ItemType)
ParentFolderId (inherited from ItemType)
PolicyTag (inherited from ItemType)
Preview (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
ReferenceItemId
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReminderNextTime (inherited from ItemType)
ReminderNextTimeSpecified (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
RetentionDate (inherited from ItemType)
RetentionDateSpecified (inherited from ItemType)
RightsManagementLicenseData (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
StoreEntryId (inherited from ItemType)
Subject (inherited from ItemType)
TextBody (inherited from ItemType)
ToRecipients (inherited from MessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

See Also

ResponseObjectCoreType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReferenceItemId Property

Aspose.Email

ResponseObjectCoreType.ReferenceItemId Property

public ItemIdType ReferenceItemId {get; set;}

Remarks

See Also

ResponseObjectCoreType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResponseObjectType Class

For a list of all members of this type, see ResponseObjectType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ItemType
Aspose.Email.Exchange.Schema.Exchange_2013.MessageType
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseObjectCoreType
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseObjectType
Aspose.Email.Exchange.Schema.Exchange_2013.PostReplyItemBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.ReferenceItemResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.RemoveItemType
Aspose.Email.Exchange.Schema.Exchange_2013.SmartResponseBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.WellKnownResponseObjectType

public abstract class ResponseObjectType : ResponseObjectCoreType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ResponseObjectType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResponseObjectType Members

ResponseObjectType overview

Public Instance Properties

ArchiveTag (inherited from ItemType)
Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
BlockStatus (inherited from ItemType)
BlockStatusSpecified (inherited from ItemType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
EntityExtractionResult (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
Flag (inherited from ItemType)
From (inherited from MessageType)
GroupingAction (inherited from ItemType)
GroupingActionSpecified (inherited from ItemType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBlockedImages (inherited from ItemType)
HasBlockedImagesSpecified (inherited from ItemType)
IconIndex (inherited from ItemType)
IconIndexSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InstanceKey (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
NextPredictedAction (inherited from ItemType)
NextPredictedActionSpecified (inherited from ItemType)
NormalizedBody (inherited from ItemType)
ObjectName
ParentFolderId (inherited from ItemType)
PolicyTag (inherited from ItemType)
Preview (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
ReferenceItemId (inherited from ResponseObjectCoreType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReminderNextTime (inherited from ItemType)
ReminderNextTimeSpecified (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
RetentionDate (inherited from ItemType)
RetentionDateSpecified (inherited from ItemType)
RightsManagementLicenseData (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
StoreEntryId (inherited from ItemType)
Subject (inherited from ItemType)
TextBody (inherited from ItemType)
ToRecipients (inherited from MessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

ResponseObjectType Constructor Initializes a new instance of the ResponseObjectType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ResponseObjectType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResponseObjectType Constructor

Initializes a new instance of the ResponseObjectType class.

protected ResponseObjectType();

See Also

ResponseObjectType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResponseObjectType Properties

The properties of the ResponseObjectType class are listed below. For a complete list of ResponseObjectType class members, see the ResponseObjectType Members topic.

Public Instance Properties

ArchiveTag (inherited from ItemType)
Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
BlockStatus (inherited from ItemType)
BlockStatusSpecified (inherited from ItemType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
EntityExtractionResult (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
Flag (inherited from ItemType)
From (inherited from MessageType)
GroupingAction (inherited from ItemType)
GroupingActionSpecified (inherited from ItemType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBlockedImages (inherited from ItemType)
HasBlockedImagesSpecified (inherited from ItemType)
IconIndex (inherited from ItemType)
IconIndexSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InstanceKey (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
NextPredictedAction (inherited from ItemType)
NextPredictedActionSpecified (inherited from ItemType)
NormalizedBody (inherited from ItemType)
ObjectName
ParentFolderId (inherited from ItemType)
PolicyTag (inherited from ItemType)
Preview (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
ReferenceItemId (inherited from ResponseObjectCoreType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReminderNextTime (inherited from ItemType)
ReminderNextTimeSpecified (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
RetentionDate (inherited from ItemType)
RetentionDateSpecified (inherited from ItemType)
RightsManagementLicenseData (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
StoreEntryId (inherited from ItemType)
Subject (inherited from ItemType)
TextBody (inherited from ItemType)
ToRecipients (inherited from MessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

See Also

ResponseObjectType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ObjectName Property

Aspose.Email

ResponseObjectType.ObjectName Property

public string ObjectName {get; set;}

Remarks

See Also

ResponseObjectType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResponseTypeType Enumeration

public enum ResponseTypeType

Remarks

Members

Member Name | Description | Value
Unknown |  | 0
Organizer |  | 1
Tentative |  | 2
Accept |  | 3
Decline |  | 4
NoResponseReceived |  | 5

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RestrictionType Class

For a list of all members of this type, see RestrictionType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.RestrictionType

public class RestrictionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RestrictionType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RestrictionType Members

RestrictionType overview

Public Instance Constructors

RestrictionType Constructor Initializes a new instance of the RestrictionType class.

Public Instance Properties

Item

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RestrictionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RestrictionType Constructor

Initializes a new instance of the RestrictionType class.

public RestrictionType();

See Also

RestrictionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RestrictionType Properties

The properties of the RestrictionType class are listed below. For a complete list of RestrictionType class members, see the RestrictionType Members topic.

Public Instance Properties

Item

See Also

RestrictionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Item Property

Aspose.Email

RestrictionType.Item Property

public SearchExpressionType Item {get; set;}

Remarks

See Also

RestrictionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RetentionActionType Enumeration

public enum RetentionActionType

Remarks

Members

Member Name | Description | Value
None |  | 0
MoveToDeletedItems |  | 1
MoveToFolder |  | 2
DeleteAndAllowRecovery |  | 3
PermanentlyDelete |  | 4
MarkAsPastRetentionLimit |  | 5
MoveToArchive |  | 6

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RetentionPolicyTagType Class

For a list of all members of this type, see RetentionPolicyTagType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.RetentionPolicyTagType

public class RetentionPolicyTagType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RetentionPolicyTagType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RetentionPolicyTagType Members

RetentionPolicyTagType overview

Public Instance Constructors

RetentionPolicyTagType Constructor Initializes a new instance of the RetentionPolicyTagType class.

Public Instance Properties

Description
DisplayName
IsArchive
IsVisible
OptedInto
RetentionAction
RetentionId
RetentionPeriod
Type

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RetentionPolicyTagType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RetentionPolicyTagType Constructor

Initializes a new instance of the RetentionPolicyTagType class.

public RetentionPolicyTagType();

See Also

RetentionPolicyTagType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RetentionPolicyTagType Properties

The properties of the RetentionPolicyTagType class are listed below. For a complete list of RetentionPolicyTagType class members, see the RetentionPolicyTagType Members topic.

Public Instance Properties

Description
DisplayName
IsArchive
IsVisible
OptedInto
RetentionAction
RetentionId
RetentionPeriod
Type

See Also

RetentionPolicyTagType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Description Property

Aspose.Email

RetentionPolicyTagType.Description Property

public string Description {get; set;}

Remarks

See Also

RetentionPolicyTagType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisplayName Property

Aspose.Email

RetentionPolicyTagType.DisplayName Property

public string DisplayName {get; set;}

Remarks

See Also

RetentionPolicyTagType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsArchive Property

Aspose.Email

RetentionPolicyTagType.IsArchive Property

public bool IsArchive {get; set;}

Remarks

See Also

RetentionPolicyTagType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsVisible Property

Aspose.Email

RetentionPolicyTagType.IsVisible Property

public bool IsVisible {get; set;}

Remarks

See Also

RetentionPolicyTagType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OptedInto Property

Aspose.Email

RetentionPolicyTagType.OptedInto Property

public bool OptedInto {get; set;}

Remarks

See Also

RetentionPolicyTagType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RetentionAction Property

Aspose.Email

RetentionPolicyTagType.RetentionAction Property

public RetentionActionType RetentionAction {get; set;}

Remarks

See Also

RetentionPolicyTagType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RetentionId Property

Aspose.Email

RetentionPolicyTagType.RetentionId Property

public string RetentionId {get; set;}

Remarks

See Also

RetentionPolicyTagType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RetentionPeriod Property

Aspose.Email

RetentionPolicyTagType.RetentionPeriod Property

public int RetentionPeriod {get; set;}

Remarks

See Also

RetentionPolicyTagType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Type Property

Aspose.Email

RetentionPolicyTagType.Type Property

public ElcFolderType Type {get; set;}

Remarks

See Also

RetentionPolicyTagType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RetentionTagType Class

For a list of all members of this type, see RetentionTagType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.RetentionTagType

public class RetentionTagType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RetentionTagType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RetentionTagType Members

RetentionTagType overview

Public Instance Constructors

RetentionTagType Constructor Initializes a new instance of the RetentionTagType class.

Public Instance Properties

IsExplicit
Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RetentionTagType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RetentionTagType Constructor

Initializes a new instance of the RetentionTagType class.

public RetentionTagType();

See Also

RetentionTagType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RetentionTagType Properties

The properties of the RetentionTagType class are listed below. For a complete list of RetentionTagType class members, see the RetentionTagType Members topic.

Public Instance Properties

IsExplicit
Value

See Also

RetentionTagType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsExplicit Property

Aspose.Email

RetentionTagType.IsExplicit Property

public bool IsExplicit {get; set;}

Remarks

See Also

RetentionTagType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Value Property

Aspose.Email

RetentionTagType.Value Property

public string Value {get; set;}

Remarks

See Also

RetentionTagType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RetentionType Enumeration

public enum RetentionType

Remarks

Members

Member Name | Description | Value
Delete |  | 0
Archive |  | 1

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RightsManagementLicenseDataType Class

For a list of all members of this type, see RightsManagementLicenseDataType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.RightsManagementLicenseDataType

public class RightsManagementLicenseDataType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RightsManagementLicenseDataType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RightsManagementLicenseDataType Members

RightsManagementLicenseDataType overview

Public Instance Constructors

RightsManagementLicenseDataType Constructor Initializes a new instance of the RightsManagementLicenseDataType class.

Public Instance Properties

ContentExpiryDate
ContentOwner
EditAllowed
EditAllowedSpecified
ExportAllowed
ExportAllowedSpecified
ExtractAllowed
ExtractAllowedSpecified
ForwardAllowed
ForwardAllowedSpecified
IsOwner
IsOwnerSpecified
ModifyRecipientsAllowed
ModifyRecipientsAllowedSpecified
PrintAllowed
PrintAllowedSpecified
ProgrammaticAccessAllowed
ProgrammaticAccessAllowedSpecified
ReplyAllAllowed
ReplyAllAllowedSpecified
ReplyAllowed
ReplyAllowedSpecified
RightsManagedMessageDecryptionStatus
RightsManagedMessageDecryptionStatusSpecified
RmsTemplateId
TemplateDescription
TemplateName

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RightsManagementLicenseDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RightsManagementLicenseDataType Constructor

Initializes a new instance of the RightsManagementLicenseDataType class.

public RightsManagementLicenseDataType();

See Also

RightsManagementLicenseDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RightsManagementLicenseDataType Properties

The properties of the RightsManagementLicenseDataType class are listed below. For a complete list of RightsManagementLicenseDataType class members, see the RightsManagementLicenseDataType Members topic.

Public Instance Properties

ContentExpiryDate
ContentOwner
EditAllowed
EditAllowedSpecified
ExportAllowed
ExportAllowedSpecified
ExtractAllowed
ExtractAllowedSpecified
ForwardAllowed
ForwardAllowedSpecified
IsOwner
IsOwnerSpecified
ModifyRecipientsAllowed
ModifyRecipientsAllowedSpecified
PrintAllowed
PrintAllowedSpecified
ProgrammaticAccessAllowed
ProgrammaticAccessAllowedSpecified
ReplyAllAllowed
ReplyAllAllowedSpecified
ReplyAllowed
ReplyAllowedSpecified
RightsManagedMessageDecryptionStatus
RightsManagedMessageDecryptionStatusSpecified
RmsTemplateId
TemplateDescription
TemplateName

See Also

RightsManagementLicenseDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContentExpiryDate Property

Aspose.Email

RightsManagementLicenseDataType.ContentExpiryDate Property

public string ContentExpiryDate {get; set;}

Remarks

See Also

RightsManagementLicenseDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContentOwner Property

Aspose.Email

RightsManagementLicenseDataType.ContentOwner Property

public string ContentOwner {get; set;}

Remarks

See Also

RightsManagementLicenseDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EditAllowed Property

Aspose.Email

RightsManagementLicenseDataType.EditAllowed Property

public bool EditAllowed {get; set;}

Remarks

See Also

RightsManagementLicenseDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EditAllowedSpecified Property

Aspose.Email

RightsManagementLicenseDataType.EditAllowedSpecified Property

public bool EditAllowedSpecified {get; set;}

Remarks

See Also

RightsManagementLicenseDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExportAllowed Property

Aspose.Email

RightsManagementLicenseDataType.ExportAllowed Property

public bool ExportAllowed {get; set;}

Remarks

See Also

RightsManagementLicenseDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExportAllowedSpecified Property

Aspose.Email

RightsManagementLicenseDataType.ExportAllowedSpecified Property

public bool ExportAllowedSpecified {get; set;}

Remarks

See Also

RightsManagementLicenseDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExtractAllowed Property

Aspose.Email

RightsManagementLicenseDataType.ExtractAllowed Property

public bool ExtractAllowed {get; set;}

Remarks

See Also

RightsManagementLicenseDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExtractAllowedSpecified Property

Aspose.Email

RightsManagementLicenseDataType.ExtractAllowedSpecified Property

public bool ExtractAllowedSpecified {get; set;}

Remarks

See Also

RightsManagementLicenseDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ForwardAllowed Property

Aspose.Email

RightsManagementLicenseDataType.ForwardAllowed Property

public bool ForwardAllowed {get; set;}

Remarks

See Also

RightsManagementLicenseDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ForwardAllowedSpecified Property

Aspose.Email

RightsManagementLicenseDataType.ForwardAllowedSpecified Property

public bool ForwardAllowedSpecified {get; set;}

Remarks

See Also

RightsManagementLicenseDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsOwner Property

Aspose.Email

RightsManagementLicenseDataType.IsOwner Property

public bool IsOwner {get; set;}

Remarks

See Also

RightsManagementLicenseDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsOwnerSpecified Property

Aspose.Email

RightsManagementLicenseDataType.IsOwnerSpecified Property

public bool IsOwnerSpecified {get; set;}

Remarks

See Also

RightsManagementLicenseDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ModifyRecipientsAllowed Property

Aspose.Email

RightsManagementLicenseDataType.ModifyRecipientsAllowed Property

public bool ModifyRecipientsAllowed {get; set;}

Remarks

See Also

RightsManagementLicenseDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ModifyRecipientsAllowedSpecified Property

Aspose.Email

RightsManagementLicenseDataType.ModifyRecipientsAllowedSpecified Property

public bool ModifyRecipientsAllowedSpecified {get; set;}

Remarks

See Also

RightsManagementLicenseDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PrintAllowed Property

Aspose.Email

RightsManagementLicenseDataType.PrintAllowed Property

public bool PrintAllowed {get; set;}

Remarks

See Also

RightsManagementLicenseDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PrintAllowedSpecified Property

Aspose.Email

RightsManagementLicenseDataType.PrintAllowedSpecified Property

public bool PrintAllowedSpecified {get; set;}

Remarks

See Also

RightsManagementLicenseDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ProgrammaticAccessAllowed Property

Aspose.Email

RightsManagementLicenseDataType.ProgrammaticAccessAllowed Property

public bool ProgrammaticAccessAllowed {get; set;}

Remarks

See Also

RightsManagementLicenseDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ProgrammaticAccessAllowedSpecified Property

Aspose.Email

RightsManagementLicenseDataType.ProgrammaticAccessAllowedSpecified Property

public bool ProgrammaticAccessAllowedSpecified {get; set;}

Remarks

See Also

RightsManagementLicenseDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReplyAllAllowed Property

Aspose.Email

RightsManagementLicenseDataType.ReplyAllAllowed Property

public bool ReplyAllAllowed {get; set;}

Remarks

See Also

RightsManagementLicenseDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReplyAllAllowedSpecified Property

Aspose.Email

RightsManagementLicenseDataType.ReplyAllAllowedSpecified Property

public bool ReplyAllAllowedSpecified {get; set;}

Remarks

See Also

RightsManagementLicenseDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReplyAllowed Property

Aspose.Email

RightsManagementLicenseDataType.ReplyAllowed Property

public bool ReplyAllowed {get; set;}

Remarks

See Also

RightsManagementLicenseDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReplyAllowedSpecified Property

Aspose.Email

RightsManagementLicenseDataType.ReplyAllowedSpecified Property

public bool ReplyAllowedSpecified {get; set;}

Remarks

See Also

RightsManagementLicenseDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RightsManagedMessageDecryptionStatus Property

Aspose.Email

RightsManagementLicenseDataType.RightsManagedMessageDecryptionStatus Property

public int RightsManagedMessageDecryptionStatus {get; set;}

Remarks

See Also

RightsManagementLicenseDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RightsManagedMessageDecryptionStatusSpecified Property

Aspose.Email

RightsManagementLicenseDataType.RightsManagedMessageDecryptionStatusSpecified Property

public bool RightsManagedMessageDecryptionStatusSpecified {get; set;}

Remarks

See Also

RightsManagementLicenseDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RmsTemplateId Property

Aspose.Email

RightsManagementLicenseDataType.RmsTemplateId Property

public string RmsTemplateId {get; set;}

Remarks

See Also

RightsManagementLicenseDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TemplateDescription Property

Aspose.Email

RightsManagementLicenseDataType.TemplateDescription Property

public string TemplateDescription {get; set;}

Remarks

See Also

RightsManagementLicenseDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TemplateName Property

Aspose.Email

RightsManagementLicenseDataType.TemplateName Property

public string TemplateName {get; set;}

Remarks

See Also

RightsManagementLicenseDataType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RoomType Class

For a list of all members of this type, see RoomType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.DirectoryEntryType
Aspose.Email.Exchange.Schema.Exchange_2013.RoomType

public class RoomType : DirectoryEntryType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RoomType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RoomType Members

RoomType overview

Public Instance Constructors

RoomType Constructor Initializes a new instance of the RoomType class.

Public Instance Properties

Id (inherited from DirectoryEntryType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RoomType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RoomType Constructor

Initializes a new instance of the RoomType class.

public RoomType();

See Also

RoomType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RootItemIdType Class

For a list of all members of this type, see RootItemIdType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseItemIdType
Aspose.Email.Exchange.Schema.Exchange_2013.RootItemIdType

public class RootItemIdType : BaseItemIdType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RootItemIdType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RootItemIdType Members

RootItemIdType overview

Public Instance Constructors

RootItemIdType Constructor Initializes a new instance of the RootItemIdType class.

Public Instance Properties

RootItemChangeKey
RootItemId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RootItemIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RootItemIdType Constructor

Initializes a new instance of the RootItemIdType class.

public RootItemIdType();

See Also

RootItemIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RootItemIdType Properties

The properties of the RootItemIdType class are listed below. For a complete list of RootItemIdType class members, see the RootItemIdType Members topic.

Public Instance Properties

RootItemChangeKey
RootItemId

See Also

RootItemIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RootItemChangeKey Property

Aspose.Email

RootItemIdType.RootItemChangeKey Property

public string RootItemChangeKey {get; set;}

Remarks

See Also

RootItemIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RootItemId Property

Aspose.Email

RootItemIdType.RootItemId Property

public string RootItemId {get; set;}

Remarks

See Also

RootItemIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RuleActionsType Class

For a list of all members of this type, see RuleActionsType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.RuleActionsType

public class RuleActionsType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RuleActionsType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RuleActionsType Members

RuleActionsType overview

Public Instance Constructors

RuleActionsType Constructor Initializes a new instance of the RuleActionsType class.

Public Instance Properties

AssignCategories
CopyToFolder
Delete
DeleteSpecified
ForwardAsAttachmentToRecipients
ForwardToRecipients
MarkAsRead
MarkAsReadSpecified
MarkImportance
MarkImportanceSpecified
MoveToFolder
PermanentDelete
PermanentDeleteSpecified
RedirectToRecipients
SendSMSAlertToRecipients
ServerReplyWithMessage
StopProcessingRules
StopProcessingRulesSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RuleActionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RuleActionsType Constructor

Initializes a new instance of the RuleActionsType class.

public RuleActionsType();

See Also

RuleActionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RuleActionsType Properties

The properties of the RuleActionsType class are listed below. For a complete list of RuleActionsType class members, see the RuleActionsType Members topic.

Public Instance Properties

AssignCategories
CopyToFolder
Delete
DeleteSpecified
ForwardAsAttachmentToRecipients
ForwardToRecipients
MarkAsRead
MarkAsReadSpecified
MarkImportance
MarkImportanceSpecified
MoveToFolder
PermanentDelete
PermanentDeleteSpecified
RedirectToRecipients
SendSMSAlertToRecipients
ServerReplyWithMessage
StopProcessingRules
StopProcessingRulesSpecified

See Also

RuleActionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AssignCategories Property

Aspose.Email

RuleActionsType.AssignCategories Property

public string[] AssignCategories {get; set;}

Remarks

See Also

RuleActionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CopyToFolder Property

Aspose.Email

RuleActionsType.CopyToFolder Property

public TargetFolderIdType CopyToFolder {get; set;}

Remarks

See Also

RuleActionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Delete Property

Aspose.Email

RuleActionsType.Delete Property

public bool Delete {get; set;}

Remarks

See Also

RuleActionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeleteSpecified Property

Aspose.Email

RuleActionsType.DeleteSpecified Property

public bool DeleteSpecified {get; set;}

Remarks

See Also

RuleActionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ForwardAsAttachmentToRecipients Property

Aspose.Email

RuleActionsType.ForwardAsAttachmentToRecipients Property

public EmailAddressType[] ForwardAsAttachmentToRecipients {get; set;}

Remarks

See Also

RuleActionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ForwardToRecipients Property

Aspose.Email

RuleActionsType.ForwardToRecipients Property

public EmailAddressType[] ForwardToRecipients {get; set;}

Remarks

See Also

RuleActionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MarkAsRead Property

Aspose.Email

RuleActionsType.MarkAsRead Property

public bool MarkAsRead {get; set;}

Remarks

See Also

RuleActionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MarkAsReadSpecified Property

Aspose.Email

RuleActionsType.MarkAsReadSpecified Property

public bool MarkAsReadSpecified {get; set;}

Remarks

See Also

RuleActionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MarkImportance Property

Aspose.Email

RuleActionsType.MarkImportance Property

public ImportanceChoicesType MarkImportance {get; set;}

Remarks

See Also

RuleActionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MarkImportanceSpecified Property

Aspose.Email

RuleActionsType.MarkImportanceSpecified Property

public bool MarkImportanceSpecified {get; set;}

Remarks

See Also

RuleActionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MoveToFolder Property

Aspose.Email

RuleActionsType.MoveToFolder Property

public TargetFolderIdType MoveToFolder {get; set;}

Remarks

See Also

RuleActionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PermanentDelete Property

Aspose.Email

RuleActionsType.PermanentDelete Property

public bool PermanentDelete {get; set;}

Remarks

See Also

RuleActionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PermanentDeleteSpecified Property

Aspose.Email

RuleActionsType.PermanentDeleteSpecified Property

public bool PermanentDeleteSpecified {get; set;}

Remarks

See Also

RuleActionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RedirectToRecipients Property

Aspose.Email

RuleActionsType.RedirectToRecipients Property

public EmailAddressType[] RedirectToRecipients {get; set;}

Remarks

See Also

RuleActionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SendSMSAlertToRecipients Property

Aspose.Email

RuleActionsType.SendSMSAlertToRecipients Property

public EmailAddressType[] SendSMSAlertToRecipients {get; set;}

Remarks

See Also

RuleActionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ServerReplyWithMessage Property

Aspose.Email

RuleActionsType.ServerReplyWithMessage Property

public ItemIdType ServerReplyWithMessage {get; set;}

Remarks

See Also

RuleActionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StopProcessingRules Property

Aspose.Email

RuleActionsType.StopProcessingRules Property

public bool StopProcessingRules {get; set;}

Remarks

See Also

RuleActionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StopProcessingRulesSpecified Property

Aspose.Email

RuleActionsType.StopProcessingRulesSpecified Property

public bool StopProcessingRulesSpecified {get; set;}

Remarks

See Also

RuleActionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RuleFieldURIType Enumeration

public enum RuleFieldURIType

Remarks

Members

Member Name | Description | Value
RuleId |  | 0
DisplayName |  | 1
Priority |  | 2
IsNotSupported |  | 3
Actions |  | 4
ConditionCategories |  | 5
ConditionContainsBodyStrings |  | 6
ConditionContainsHeaderStrings |  | 7
ConditionContainsRecipientStrings |  | 8
ConditionContainsSenderStrings |  | 9
ConditionContainsSubjectOrBodyStrings |  | 10
ConditionContainsSubjectStrings |  | 11
ConditionFlaggedForAction |  | 12
ConditionFromAddresses |  | 13
ConditionFromConnectedAccounts |  | 14
ConditionHasAttachments |  | 15
ConditionImportance |  | 16
ConditionIsApprovalRequest |  | 17
ConditionIsAutomaticForward |  | 18
ConditionIsAutomaticReply |  | 19
ConditionIsEncrypted |  | 20
ConditionIsMeetingRequest |  | 21
ConditionIsMeetingResponse |  | 22
ConditionIsNDR |  | 23
ConditionIsPermissionControlled |  | 24
ConditionIsReadReceipt |  | 25
ConditionIsSigned |  | 26
ConditionIsVoicemail |  | 27
ConditionItemClasses |  | 28
ConditionMessageClassifications |  | 29
ConditionNotSentToMe |  | 30
ConditionSentCcMe |  | 31
ConditionSentOnlyToMe |  | 32
ConditionSentToAddresses |  | 33
ConditionSentToMe |  | 34
ConditionSentToOrCcMe |  | 35
ConditionSensitivity |  | 36
ConditionWithinDateRange |  | 37
ConditionWithinSizeRange |  | 38
ExceptionCategories |  | 39
ExceptionContainsBodyStrings |  | 40
ExceptionContainsHeaderStrings |  | 41
ExceptionContainsRecipientStrings |  | 42
ExceptionContainsSenderStrings |  | 43
ExceptionContainsSubjectOrBodyStrings |  | 44
ExceptionContainsSubjectStrings |  | 45
ExceptionFlaggedForAction |  | 46
ExceptionFromAddresses |  | 47
ExceptionFromConnectedAccounts |  | 48
ExceptionHasAttachments |  | 49
ExceptionImportance |  | 50
ExceptionIsApprovalRequest |  | 51
ExceptionIsAutomaticForward |  | 52
ExceptionIsAutomaticReply |  | 53
ExceptionIsEncrypted |  | 54
ExceptionIsMeetingRequest |  | 55
ExceptionIsMeetingResponse |  | 56
ExceptionIsNDR |  | 57
ExceptionIsPermissionControlled |  | 58
ExceptionIsReadReceipt |  | 59
ExceptionIsSigned |  | 60
ExceptionIsVoicemail |  | 61
ExceptionItemClasses |  | 62
ExceptionMessageClassifications |  | 63
ExceptionNotSentToMe |  | 64
ExceptionSentCcMe |  | 65
ExceptionSentOnlyToMe |  | 66
ExceptionSentToAddresses |  | 67
ExceptionSentToMe |  | 68
ExceptionSentToOrCcMe |  | 69
ExceptionSensitivity |  | 70
ExceptionWithinDateRange |  | 71
ExceptionWithinSizeRange |  | 72
ActionAssignCategories |  | 73
ActionCopyToFolder |  | 74
ActionDelete |  | 75
ActionForwardAsAttachmentToRecipients |  | 76
ActionForwardToRecipients |  | 77
ActionMarkImportance |  | 78
ActionMarkAsRead |  | 79
ActionMoveToFolder |  | 80
ActionPermanentDelete |  | 81
ActionRedirectToRecipients |  | 82
ActionSendSMSAlertToRecipients |  | 83
ActionServerReplyWithMessage |  | 84
ActionStopProcessingRules |  | 85
IsEnabled |  | 86
IsInError |  | 87
Conditions |  | 88
Exceptions |  | 89

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RuleOperationErrorType Class

For a list of all members of this type, see RuleOperationErrorType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.RuleOperationErrorType

public class RuleOperationErrorType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RuleOperationErrorType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RuleOperationErrorType Members

RuleOperationErrorType overview

Public Instance Constructors

RuleOperationErrorType Constructor Initializes a new instance of the RuleOperationErrorType class.

Public Instance Properties

OperationIndex
ValidationErrors

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RuleOperationErrorType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RuleOperationErrorType Constructor

Initializes a new instance of the RuleOperationErrorType class.

public RuleOperationErrorType();

See Also

RuleOperationErrorType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RuleOperationErrorType Properties

The properties of the RuleOperationErrorType class are listed below. For a complete list of RuleOperationErrorType class members, see the RuleOperationErrorType Members topic.

Public Instance Properties

OperationIndex
ValidationErrors

See Also

RuleOperationErrorType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OperationIndex Property

Aspose.Email

RuleOperationErrorType.OperationIndex Property

public int OperationIndex {get; set;}

Remarks

See Also

RuleOperationErrorType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ValidationErrors Property

Aspose.Email

RuleOperationErrorType.ValidationErrors Property

public RuleValidationErrorType[] ValidationErrors {get; set;}

Remarks

See Also

RuleOperationErrorType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RuleOperationType Class

For a list of all members of this type, see RuleOperationType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.RuleOperationType
Aspose.Email.Exchange.Schema.Exchange_2013.CreateRuleOperationType
Aspose.Email.Exchange.Schema.Exchange_2013.DeleteRuleOperationType
Aspose.Email.Exchange.Schema.Exchange_2013.SetRuleOperationType

public abstract class RuleOperationType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RuleOperationType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RuleOperationType Members

RuleOperationType overview

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

RuleOperationType Constructor Initializes a new instance of the RuleOperationType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RuleOperationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RuleOperationType Constructor

Initializes a new instance of the RuleOperationType class.

protected RuleOperationType();

See Also

RuleOperationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RulePredicateDateRangeType Class

For a list of all members of this type, see RulePredicateDateRangeType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.RulePredicateDateRangeType

public class RulePredicateDateRangeType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RulePredicateDateRangeType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RulePredicateDateRangeType Members

RulePredicateDateRangeType overview

Public Instance Constructors

RulePredicateDateRangeType Constructor Initializes a new instance of the RulePredicateDateRangeType class.

Public Instance Properties

EndDateTime
EndDateTimeSpecified
StartDateTime
StartDateTimeSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RulePredicateDateRangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RulePredicateDateRangeType Constructor

Initializes a new instance of the RulePredicateDateRangeType class.

public RulePredicateDateRangeType();

See Also

RulePredicateDateRangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RulePredicateDateRangeType Properties

The properties of the RulePredicateDateRangeType class are listed below. For a complete list of RulePredicateDateRangeType class members, see the RulePredicateDateRangeType Members topic.

Public Instance Properties

EndDateTime
EndDateTimeSpecified
StartDateTime
StartDateTimeSpecified

See Also

RulePredicateDateRangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EndDateTime Property

Aspose.Email

RulePredicateDateRangeType.EndDateTime Property

public DateTime EndDateTime {get; set;}

Remarks

See Also

RulePredicateDateRangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EndDateTimeSpecified Property

Aspose.Email

RulePredicateDateRangeType.EndDateTimeSpecified Property

public bool EndDateTimeSpecified {get; set;}

Remarks

See Also

RulePredicateDateRangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StartDateTime Property

Aspose.Email

RulePredicateDateRangeType.StartDateTime Property

public DateTime StartDateTime {get; set;}

Remarks

See Also

RulePredicateDateRangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StartDateTimeSpecified Property

Aspose.Email

RulePredicateDateRangeType.StartDateTimeSpecified Property

public bool StartDateTimeSpecified {get; set;}

Remarks

See Also

RulePredicateDateRangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RulePredicateSizeRangeType Class

For a list of all members of this type, see RulePredicateSizeRangeType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.RulePredicateSizeRangeType

public class RulePredicateSizeRangeType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RulePredicateSizeRangeType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RulePredicateSizeRangeType Members

RulePredicateSizeRangeType overview

Public Instance Constructors

RulePredicateSizeRangeType Constructor Initializes a new instance of the RulePredicateSizeRangeType class.

Public Instance Properties

MaximumSize
MaximumSizeSpecified
MinimumSize
MinimumSizeSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RulePredicateSizeRangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RulePredicateSizeRangeType Constructor

Initializes a new instance of the RulePredicateSizeRangeType class.

public RulePredicateSizeRangeType();

See Also

RulePredicateSizeRangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RulePredicateSizeRangeType Properties

The properties of the RulePredicateSizeRangeType class are listed below. For a complete list of RulePredicateSizeRangeType class members, see the RulePredicateSizeRangeType Members topic.

Public Instance Properties

MaximumSize
MaximumSizeSpecified
MinimumSize
MinimumSizeSpecified

See Also

RulePredicateSizeRangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MaximumSize Property

Aspose.Email

RulePredicateSizeRangeType.MaximumSize Property

public int MaximumSize {get; set;}

Remarks

See Also

RulePredicateSizeRangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MaximumSizeSpecified Property

Aspose.Email

RulePredicateSizeRangeType.MaximumSizeSpecified Property

public bool MaximumSizeSpecified {get; set;}

Remarks

See Also

RulePredicateSizeRangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MinimumSize Property

Aspose.Email

RulePredicateSizeRangeType.MinimumSize Property

public int MinimumSize {get; set;}

Remarks

See Also

RulePredicateSizeRangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MinimumSizeSpecified Property

Aspose.Email

RulePredicateSizeRangeType.MinimumSizeSpecified Property

public bool MinimumSizeSpecified {get; set;}

Remarks

See Also

RulePredicateSizeRangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RulePredicatesType Class

For a list of all members of this type, see RulePredicatesType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.RulePredicatesType

public class RulePredicatesType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RulePredicatesType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RulePredicatesType Members

RulePredicatesType overview

Public Instance Constructors

RulePredicatesType Constructor Initializes a new instance of the RulePredicatesType class.

Public Instance Properties

Categories
ContainsBodyStrings
ContainsHeaderStrings
ContainsRecipientStrings
ContainsSenderStrings
ContainsSubjectOrBodyStrings
ContainsSubjectStrings
FlaggedForAction
FlaggedForActionSpecified
FromAddresses
FromConnectedAccounts
HasAttachments
HasAttachmentsSpecified
Importance
ImportanceSpecified
IsApprovalRequest
IsApprovalRequestSpecified
IsAutomaticForward
IsAutomaticForwardSpecified
IsAutomaticReply
IsAutomaticReplySpecified
IsEncrypted
IsEncryptedSpecified
IsMeetingRequest
IsMeetingRequestSpecified
IsMeetingResponse
IsMeetingResponseSpecified
IsNDR
IsNDRSpecified
IsPermissionControlled
IsPermissionControlledSpecified
IsReadReceipt
IsReadReceiptSpecified
IsSigned
IsSignedSpecified
IsVoicemail
IsVoicemailSpecified
ItemClasses
MessageClassifications
NotSentToMe
NotSentToMeSpecified
Sensitivity
SensitivitySpecified
SentCcMe
SentCcMeSpecified
SentOnlyToMe
SentOnlyToMeSpecified
SentToAddresses
SentToMe
SentToMeSpecified
SentToOrCcMe
SentToOrCcMeSpecified
WithinDateRange
WithinSizeRange

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RulePredicatesType Constructor

Initializes a new instance of the RulePredicatesType class.

public RulePredicatesType();

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RulePredicatesType Properties

The properties of the RulePredicatesType class are listed below. For a complete list of RulePredicatesType class members, see the RulePredicatesType Members topic.

Public Instance Properties

Categories
ContainsBodyStrings
ContainsHeaderStrings
ContainsRecipientStrings
ContainsSenderStrings
ContainsSubjectOrBodyStrings
ContainsSubjectStrings
FlaggedForAction
FlaggedForActionSpecified
FromAddresses
FromConnectedAccounts
HasAttachments
HasAttachmentsSpecified
Importance
ImportanceSpecified
IsApprovalRequest
IsApprovalRequestSpecified
IsAutomaticForward
IsAutomaticForwardSpecified
IsAutomaticReply
IsAutomaticReplySpecified
IsEncrypted
IsEncryptedSpecified
IsMeetingRequest
IsMeetingRequestSpecified
IsMeetingResponse
IsMeetingResponseSpecified
IsNDR
IsNDRSpecified
IsPermissionControlled
IsPermissionControlledSpecified
IsReadReceipt
IsReadReceiptSpecified
IsSigned
IsSignedSpecified
IsVoicemail
IsVoicemailSpecified
ItemClasses
MessageClassifications
NotSentToMe
NotSentToMeSpecified
Sensitivity
SensitivitySpecified
SentCcMe
SentCcMeSpecified
SentOnlyToMe
SentOnlyToMeSpecified
SentToAddresses
SentToMe
SentToMeSpecified
SentToOrCcMe
SentToOrCcMeSpecified
WithinDateRange
WithinSizeRange

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Categories Property

Aspose.Email

RulePredicatesType.Categories Property

public string[] Categories {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContainsBodyStrings Property

Aspose.Email

RulePredicatesType.ContainsBodyStrings Property

public string[] ContainsBodyStrings {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContainsHeaderStrings Property

Aspose.Email

RulePredicatesType.ContainsHeaderStrings Property

public string[] ContainsHeaderStrings {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContainsRecipientStrings Property

Aspose.Email

RulePredicatesType.ContainsRecipientStrings Property

public string[] ContainsRecipientStrings {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContainsSenderStrings Property

Aspose.Email

RulePredicatesType.ContainsSenderStrings Property

public string[] ContainsSenderStrings {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContainsSubjectOrBodyStrings Property

Aspose.Email

RulePredicatesType.ContainsSubjectOrBodyStrings Property

public string[] ContainsSubjectOrBodyStrings {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ContainsSubjectStrings Property

Aspose.Email

RulePredicatesType.ContainsSubjectStrings Property

public string[] ContainsSubjectStrings {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FlaggedForAction Property

Aspose.Email

RulePredicatesType.FlaggedForAction Property

public FlaggedForActionType FlaggedForAction {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FlaggedForActionSpecified Property

Aspose.Email

RulePredicatesType.FlaggedForActionSpecified Property

public bool FlaggedForActionSpecified {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FromAddresses Property

Aspose.Email

RulePredicatesType.FromAddresses Property

public EmailAddressType[] FromAddresses {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FromConnectedAccounts Property

Aspose.Email

RulePredicatesType.FromConnectedAccounts Property

public string[] FromConnectedAccounts {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


HasAttachments Property

Aspose.Email

RulePredicatesType.HasAttachments Property

public bool HasAttachments {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


HasAttachmentsSpecified Property

Aspose.Email

RulePredicatesType.HasAttachmentsSpecified Property

public bool HasAttachmentsSpecified {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Importance Property

Aspose.Email

RulePredicatesType.Importance Property

public ImportanceChoicesType Importance {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ImportanceSpecified Property

Aspose.Email

RulePredicatesType.ImportanceSpecified Property

public bool ImportanceSpecified {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsApprovalRequest Property

Aspose.Email

RulePredicatesType.IsApprovalRequest Property

public bool IsApprovalRequest {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsApprovalRequestSpecified Property

Aspose.Email

RulePredicatesType.IsApprovalRequestSpecified Property

public bool IsApprovalRequestSpecified {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsAutomaticForward Property

Aspose.Email

RulePredicatesType.IsAutomaticForward Property

public bool IsAutomaticForward {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsAutomaticForwardSpecified Property

Aspose.Email

RulePredicatesType.IsAutomaticForwardSpecified Property

public bool IsAutomaticForwardSpecified {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsAutomaticReply Property

Aspose.Email

RulePredicatesType.IsAutomaticReply Property

public bool IsAutomaticReply {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsAutomaticReplySpecified Property

Aspose.Email

RulePredicatesType.IsAutomaticReplySpecified Property

public bool IsAutomaticReplySpecified {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsEncrypted Property

Aspose.Email

RulePredicatesType.IsEncrypted Property

public bool IsEncrypted {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsEncryptedSpecified Property

Aspose.Email

RulePredicatesType.IsEncryptedSpecified Property

public bool IsEncryptedSpecified {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsMeetingRequest Property

Aspose.Email

RulePredicatesType.IsMeetingRequest Property

public bool IsMeetingRequest {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsMeetingRequestSpecified Property

Aspose.Email

RulePredicatesType.IsMeetingRequestSpecified Property

public bool IsMeetingRequestSpecified {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsMeetingResponse Property

Aspose.Email

RulePredicatesType.IsMeetingResponse Property

public bool IsMeetingResponse {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsMeetingResponseSpecified Property

Aspose.Email

RulePredicatesType.IsMeetingResponseSpecified Property

public bool IsMeetingResponseSpecified {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsNDR Property

Aspose.Email

RulePredicatesType.IsNDR Property

public bool IsNDR {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsNDRSpecified Property

Aspose.Email

RulePredicatesType.IsNDRSpecified Property

public bool IsNDRSpecified {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsPermissionControlled Property

Aspose.Email

RulePredicatesType.IsPermissionControlled Property

public bool IsPermissionControlled {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsPermissionControlledSpecified Property

Aspose.Email

RulePredicatesType.IsPermissionControlledSpecified Property

public bool IsPermissionControlledSpecified {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsReadReceipt Property

Aspose.Email

RulePredicatesType.IsReadReceipt Property

public bool IsReadReceipt {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsReadReceiptSpecified Property

Aspose.Email

RulePredicatesType.IsReadReceiptSpecified Property

public bool IsReadReceiptSpecified {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsSigned Property

Aspose.Email

RulePredicatesType.IsSigned Property

public bool IsSigned {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsSignedSpecified Property

Aspose.Email

RulePredicatesType.IsSignedSpecified Property

public bool IsSignedSpecified {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsVoicemail Property

Aspose.Email

RulePredicatesType.IsVoicemail Property

public bool IsVoicemail {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsVoicemailSpecified Property

Aspose.Email

RulePredicatesType.IsVoicemailSpecified Property

public bool IsVoicemailSpecified {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemClasses Property

Aspose.Email

RulePredicatesType.ItemClasses Property

public string[] ItemClasses {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MessageClassifications Property

Aspose.Email

RulePredicatesType.MessageClassifications Property

public string[] MessageClassifications {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NotSentToMe Property

Aspose.Email

RulePredicatesType.NotSentToMe Property

public bool NotSentToMe {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NotSentToMeSpecified Property

Aspose.Email

RulePredicatesType.NotSentToMeSpecified Property

public bool NotSentToMeSpecified {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Sensitivity Property

Aspose.Email

RulePredicatesType.Sensitivity Property

public SensitivityChoicesType Sensitivity {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SensitivitySpecified Property

Aspose.Email

RulePredicatesType.SensitivitySpecified Property

public bool SensitivitySpecified {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SentCcMe Property

Aspose.Email

RulePredicatesType.SentCcMe Property

public bool SentCcMe {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SentCcMeSpecified Property

Aspose.Email

RulePredicatesType.SentCcMeSpecified Property

public bool SentCcMeSpecified {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SentOnlyToMe Property

Aspose.Email

RulePredicatesType.SentOnlyToMe Property

public bool SentOnlyToMe {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SentOnlyToMeSpecified Property

Aspose.Email

RulePredicatesType.SentOnlyToMeSpecified Property

public bool SentOnlyToMeSpecified {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SentToAddresses Property

Aspose.Email

RulePredicatesType.SentToAddresses Property

public EmailAddressType[] SentToAddresses {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SentToMe Property

Aspose.Email

RulePredicatesType.SentToMe Property

public bool SentToMe {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SentToMeSpecified Property

Aspose.Email

RulePredicatesType.SentToMeSpecified Property

public bool SentToMeSpecified {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SentToOrCcMe Property

Aspose.Email

RulePredicatesType.SentToOrCcMe Property

public bool SentToOrCcMe {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SentToOrCcMeSpecified Property

Aspose.Email

RulePredicatesType.SentToOrCcMeSpecified Property

public bool SentToOrCcMeSpecified {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


WithinDateRange Property

Aspose.Email

RulePredicatesType.WithinDateRange Property

public RulePredicateDateRangeType WithinDateRange {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


WithinSizeRange Property

Aspose.Email

RulePredicatesType.WithinSizeRange Property

public RulePredicateSizeRangeType WithinSizeRange {get; set;}

Remarks

See Also

RulePredicatesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RuleType Class

For a list of all members of this type, see RuleType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.RuleType

public class RuleType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RuleType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RuleType Members

RuleType overview

Public Instance Constructors

RuleType Constructor Initializes a new instance of the RuleType class.

Public Instance Properties

Actions
Conditions
DisplayName
Exceptions
IsEnabled
IsInError
IsInErrorSpecified
IsNotSupported
IsNotSupportedSpecified
Priority
RuleId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RuleType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RuleType Constructor

Initializes a new instance of the RuleType class.

public RuleType();

See Also

RuleType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RuleType Properties

The properties of the RuleType class are listed below. For a complete list of RuleType class members, see the RuleType Members topic.

Public Instance Properties

Actions
Conditions
DisplayName
Exceptions
IsEnabled
IsInError
IsInErrorSpecified
IsNotSupported
IsNotSupportedSpecified
Priority
RuleId

See Also

RuleType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Actions Property

Aspose.Email

RuleType.Actions Property

public RuleActionsType Actions {get; set;}

Remarks

See Also

RuleType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Conditions Property

Aspose.Email

RuleType.Conditions Property

public RulePredicatesType Conditions {get; set;}

Remarks

See Also

RuleType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisplayName Property

Aspose.Email

RuleType.DisplayName Property

public string DisplayName {get; set;}

Remarks

See Also

RuleType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Exceptions Property

Aspose.Email

RuleType.Exceptions Property

public RulePredicatesType Exceptions {get; set;}

Remarks

See Also

RuleType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsEnabled Property

Aspose.Email

RuleType.IsEnabled Property

public bool IsEnabled {get; set;}

Remarks

See Also

RuleType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsInError Property

Aspose.Email

RuleType.IsInError Property

public bool IsInError {get; set;}

Remarks

See Also

RuleType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsInErrorSpecified Property

Aspose.Email

RuleType.IsInErrorSpecified Property

public bool IsInErrorSpecified {get; set;}

Remarks

See Also

RuleType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsNotSupported Property

Aspose.Email

RuleType.IsNotSupported Property

public bool IsNotSupported {get; set;}

Remarks

See Also

RuleType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsNotSupportedSpecified Property

Aspose.Email

RuleType.IsNotSupportedSpecified Property

public bool IsNotSupportedSpecified {get; set;}

Remarks

See Also

RuleType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Priority Property

Aspose.Email

RuleType.Priority Property

public int Priority {get; set;}

Remarks

See Also

RuleType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RuleId Property

Aspose.Email

RuleType.RuleId Property

public string RuleId {get; set;}

Remarks

See Also

RuleType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RuleValidationErrorCodeType Enumeration

public enum RuleValidationErrorCodeType

Remarks

Members

Member Name | Description | Value
ADOperationFailure |  | 0
ConnectedAccountNotFound |  | 1
CreateWithRuleId |  | 2
EmptyValueFound |  | 3
DuplicatedPriority |  | 4
DuplicatedOperationOnTheSameRule |  | 5
FolderDoesNotExist |  | 6
InvalidAddress |  | 7
InvalidDateRange |  | 8
InvalidFolderId |  | 9
InvalidSizeRange |  | 10
InvalidValue |  | 11
MessageClassificationNotFound |  | 12
MissingAction |  | 13
MissingParameter |  | 14
MissingRangeValue |  | 15
NotSettable |  | 16
RecipientDoesNotExist |  | 17
RuleNotFound |  | 18
SizeLessThanZero |  | 19
StringValueTooBig |  | 20
UnsupportedAddress |  | 21
UnexpectedError |  | 22
UnsupportedRule |  | 23

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RuleValidationErrorType Class

For a list of all members of this type, see RuleValidationErrorType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.RuleValidationErrorType

public class RuleValidationErrorType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RuleValidationErrorType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RuleValidationErrorType Members

RuleValidationErrorType overview

Public Instance Constructors

RuleValidationErrorType Constructor Initializes a new instance of the RuleValidationErrorType class.

Public Instance Properties

ErrorCode
ErrorMessage
FieldURI
FieldValue

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RuleValidationErrorType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RuleValidationErrorType Constructor

Initializes a new instance of the RuleValidationErrorType class.

public RuleValidationErrorType();

See Also

RuleValidationErrorType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RuleValidationErrorType Properties

The properties of the RuleValidationErrorType class are listed below. For a complete list of RuleValidationErrorType class members, see the RuleValidationErrorType Members topic.

Public Instance Properties

ErrorCode
ErrorMessage
FieldURI
FieldValue

See Also

RuleValidationErrorType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ErrorCode Property

Aspose.Email

RuleValidationErrorType.ErrorCode Property

public RuleValidationErrorCodeType ErrorCode {get; set;}

Remarks

See Also

RuleValidationErrorType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ErrorMessage Property

Aspose.Email

RuleValidationErrorType.ErrorMessage Property

public string ErrorMessage {get; set;}

Remarks

See Also

RuleValidationErrorType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FieldURI Property

Aspose.Email

RuleValidationErrorType.FieldURI Property

public RuleFieldURIType FieldURI {get; set;}

Remarks

See Also

RuleValidationErrorType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FieldValue Property

Aspose.Email

RuleValidationErrorType.FieldValue Property

public string FieldValue {get; set;}

Remarks

See Also

RuleValidationErrorType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SaveUMPinResponseMessageType Class

For a list of all members of this type, see SaveUMPinResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.SaveUMPinResponseMessageType

public class SaveUMPinResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SaveUMPinResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SaveUMPinResponseMessageType Members

SaveUMPinResponseMessageType overview

Public Instance Constructors

SaveUMPinResponseMessageType Constructor Initializes a new instance of the SaveUMPinResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SaveUMPinResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SaveUMPinResponseMessageType Constructor

Initializes a new instance of the SaveUMPinResponseMessageType class.

public SaveUMPinResponseMessageType();

See Also

SaveUMPinResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SaveUMPinType Class

For a list of all members of this type, see SaveUMPinType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.SaveUMPinType

public class SaveUMPinType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SaveUMPinType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SaveUMPinType Members

SaveUMPinType overview

Public Instance Constructors

SaveUMPinType Constructor Initializes a new instance of the SaveUMPinType class.

Public Instance Properties

PinInfo
UserUMMailboxPolicyGuid

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SaveUMPinType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SaveUMPinType Constructor

Initializes a new instance of the SaveUMPinType class.

public SaveUMPinType();

See Also

SaveUMPinType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SaveUMPinType Properties

The properties of the SaveUMPinType class are listed below. For a complete list of SaveUMPinType class members, see the SaveUMPinType Members topic.

Public Instance Properties

PinInfo
UserUMMailboxPolicyGuid

See Also

SaveUMPinType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PinInfo Property

Aspose.Email

SaveUMPinType.PinInfo Property

public PinInfoType PinInfo {get; set;}

Remarks

See Also

SaveUMPinType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserUMMailboxPolicyGuid Property

Aspose.Email

SaveUMPinType.UserUMMailboxPolicyGuid Property

public string UserUMMailboxPolicyGuid {get; set;}

Remarks

See Also

SaveUMPinType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchableMailboxType Class

For a list of all members of this type, see SearchableMailboxType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.SearchableMailboxType

public class SearchableMailboxType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SearchableMailboxType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchableMailboxType Members

SearchableMailboxType overview

Public Instance Constructors

SearchableMailboxType Constructor Initializes a new instance of the SearchableMailboxType class.

Public Instance Properties

DisplayName
ExternalEmailAddress
Guid
IsExternalMailbox
IsMembershipGroup
PrimarySmtpAddress
ReferenceId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SearchableMailboxType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchableMailboxType Constructor

Initializes a new instance of the SearchableMailboxType class.

public SearchableMailboxType();

See Also

SearchableMailboxType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchableMailboxType Properties

The properties of the SearchableMailboxType class are listed below. For a complete list of SearchableMailboxType class members, see the SearchableMailboxType Members topic.

Public Instance Properties

DisplayName
ExternalEmailAddress
Guid
IsExternalMailbox
IsMembershipGroup
PrimarySmtpAddress
ReferenceId

See Also

SearchableMailboxType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisplayName Property

Aspose.Email

SearchableMailboxType.DisplayName Property

public string DisplayName {get; set;}

Remarks

See Also

SearchableMailboxType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExternalEmailAddress Property

Aspose.Email

SearchableMailboxType.ExternalEmailAddress Property

public string ExternalEmailAddress {get; set;}

Remarks

See Also

SearchableMailboxType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Guid Property

Aspose.Email

SearchableMailboxType.Guid Property

public string Guid {get; set;}

Remarks

See Also

SearchableMailboxType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsExternalMailbox Property

Aspose.Email

SearchableMailboxType.IsExternalMailbox Property

public bool IsExternalMailbox {get; set;}

Remarks

See Also

SearchableMailboxType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsMembershipGroup Property

Aspose.Email

SearchableMailboxType.IsMembershipGroup Property

public bool IsMembershipGroup {get; set;}

Remarks

See Also

SearchableMailboxType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PrimarySmtpAddress Property

Aspose.Email

SearchableMailboxType.PrimarySmtpAddress Property

public string PrimarySmtpAddress {get; set;}

Remarks

See Also

SearchableMailboxType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReferenceId Property

Aspose.Email

SearchableMailboxType.ReferenceId Property

public string ReferenceId {get; set;}

Remarks

See Also

SearchableMailboxType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchExpressionType Class

For a list of all members of this type, see SearchExpressionType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.SearchExpressionType
Derived types

public abstract class SearchExpressionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SearchExpressionType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchExpressionType Members

SearchExpressionType overview

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

SearchExpressionType Constructor Initializes a new instance of the SearchExpressionType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SearchExpressionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchExpressionType Constructor

Initializes a new instance of the SearchExpressionType class.

protected SearchExpressionType();

See Also

SearchExpressionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchFolderTraversalType Enumeration

public enum SearchFolderTraversalType

Remarks

Members

Member Name | Description | Value
Shallow |  | 0
Deep |  | 1

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchFolderType Class

For a list of all members of this type, see SearchFolderType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseFolderType
Aspose.Email.Exchange.Schema.Exchange_2013.FolderType
Aspose.Email.Exchange.Schema.Exchange_2013.SearchFolderType

public class SearchFolderType : FolderType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SearchFolderType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchFolderType Members

SearchFolderType overview

Public Instance Constructors

SearchFolderType Constructor Initializes a new instance of the SearchFolderType class.

Public Instance Properties

ArchiveTag (inherited from BaseFolderType)
ChildFolderCount (inherited from BaseFolderType)
ChildFolderCountSpecified (inherited from BaseFolderType)
DisplayName (inherited from BaseFolderType)
DistinguishedFolderId (inherited from BaseFolderType)
DistinguishedFolderIdSpecified (inherited from BaseFolderType)
EffectiveRights (inherited from BaseFolderType)
ExtendedProperty (inherited from BaseFolderType)
FolderClass (inherited from BaseFolderType)
FolderId (inherited from BaseFolderType)
ManagedFolderInformation (inherited from BaseFolderType)
ParentFolderId (inherited from BaseFolderType)
PermissionSet (inherited from FolderType)
PolicyTag (inherited from BaseFolderType)
SearchParameters
TotalCount (inherited from BaseFolderType)
TotalCountSpecified (inherited from BaseFolderType)
UnreadCount (inherited from FolderType)
UnreadCountSpecified (inherited from FolderType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SearchFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchFolderType Constructor

Initializes a new instance of the SearchFolderType class.

public SearchFolderType();

See Also

SearchFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchFolderType Properties

The properties of the SearchFolderType class are listed below. For a complete list of SearchFolderType class members, see the SearchFolderType Members topic.

Public Instance Properties

ArchiveTag (inherited from BaseFolderType)
ChildFolderCount (inherited from BaseFolderType)
ChildFolderCountSpecified (inherited from BaseFolderType)
DisplayName (inherited from BaseFolderType)
DistinguishedFolderId (inherited from BaseFolderType)
DistinguishedFolderIdSpecified (inherited from BaseFolderType)
EffectiveRights (inherited from BaseFolderType)
ExtendedProperty (inherited from BaseFolderType)
FolderClass (inherited from BaseFolderType)
FolderId (inherited from BaseFolderType)
ManagedFolderInformation (inherited from BaseFolderType)
ParentFolderId (inherited from BaseFolderType)
PermissionSet (inherited from FolderType)
PolicyTag (inherited from BaseFolderType)
SearchParameters
TotalCount (inherited from BaseFolderType)
TotalCountSpecified (inherited from BaseFolderType)
UnreadCount (inherited from FolderType)
UnreadCountSpecified (inherited from FolderType)

See Also

SearchFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchParameters Property

Aspose.Email

SearchFolderType.SearchParameters Property

public SearchParametersType SearchParameters {get; set;}

Remarks

See Also

SearchFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchItemKindType Enumeration

public enum SearchItemKindType

Remarks

Members

Member Name | Description | Value
Email |  | 0
Meetings |  | 1
Tasks |  | 2
Notes |  | 3
Docs |  | 4
Journals |  | 5
Contacts |  | 6
Im |  | 7
Voicemail |  | 8
Faxes |  | 9
Posts |  | 10
Rssfeeds |  | 11

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchMailboxesCompletedEventArgs Class

For a list of all members of this type, see SearchMailboxesCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.SearchMailboxesCompletedEventArgs

public class SearchMailboxesCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SearchMailboxesCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchMailboxesCompletedEventArgs Members

SearchMailboxesCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

SearchMailboxesCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchMailboxesCompletedEventArgs Properties

The properties of the SearchMailboxesCompletedEventArgs class are listed below. For a complete list of SearchMailboxesCompletedEventArgs class members, see the SearchMailboxesCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

SearchMailboxesCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

SearchMailboxesCompletedEventArgs.Result Property

public SearchMailboxesResponseType Result {get;}

Remarks

See Also

SearchMailboxesCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchMailboxesCompletedEventHandler Delegate

public delegate void SearchMailboxesCompletedEventHandler(
object sender,
SearchMailboxesCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchMailboxesResponseMessageType Class

For a list of all members of this type, see SearchMailboxesResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.SearchMailboxesResponseMessageType

public class SearchMailboxesResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SearchMailboxesResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchMailboxesResponseMessageType Members

SearchMailboxesResponseMessageType overview

Public Instance Constructors

SearchMailboxesResponseMessageType Constructor Initializes a new instance of the SearchMailboxesResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
SearchMailboxesResult

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SearchMailboxesResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchMailboxesResponseMessageType Constructor

Initializes a new instance of the SearchMailboxesResponseMessageType class.

public SearchMailboxesResponseMessageType();

See Also

SearchMailboxesResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchMailboxesResponseMessageType Properties

The properties of the SearchMailboxesResponseMessageType class are listed below. For a complete list of SearchMailboxesResponseMessageType class members, see the SearchMailboxesResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
SearchMailboxesResult

See Also

SearchMailboxesResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchMailboxesResult Property

Aspose.Email

SearchMailboxesResponseMessageType.SearchMailboxesResult Property

public SearchMailboxesResultType SearchMailboxesResult {get; set;}

Remarks

See Also

SearchMailboxesResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchMailboxesResponseType Class

For a list of all members of this type, see SearchMailboxesResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.SearchMailboxesResponseType

public class SearchMailboxesResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SearchMailboxesResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchMailboxesResponseType Members

SearchMailboxesResponseType overview

Public Instance Constructors

SearchMailboxesResponseType Constructor Initializes a new instance of the SearchMailboxesResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SearchMailboxesResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchMailboxesResponseType Constructor

Initializes a new instance of the SearchMailboxesResponseType class.

public SearchMailboxesResponseType();

See Also

SearchMailboxesResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchMailboxesResultType Class

For a list of all members of this type, see SearchMailboxesResultType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.SearchMailboxesResultType

public class SearchMailboxesResultType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SearchMailboxesResultType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchMailboxesResultType Members

SearchMailboxesResultType overview

Public Instance Constructors

SearchMailboxesResultType Constructor Initializes a new instance of the SearchMailboxesResultType class.

Public Instance Properties

FailedMailboxes
ItemCount
Items
KeywordStats
MailboxStats
PageItemCount
PageItemSize
Refiners
ResultType
SearchQueries
Size

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SearchMailboxesResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchMailboxesResultType Constructor

Initializes a new instance of the SearchMailboxesResultType class.

public SearchMailboxesResultType();

See Also

SearchMailboxesResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchMailboxesResultType Properties

The properties of the SearchMailboxesResultType class are listed below. For a complete list of SearchMailboxesResultType class members, see the SearchMailboxesResultType Members topic.

Public Instance Properties

FailedMailboxes
ItemCount
Items
KeywordStats
MailboxStats
PageItemCount
PageItemSize
Refiners
ResultType
SearchQueries
Size

See Also

SearchMailboxesResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FailedMailboxes Property

Aspose.Email

SearchMailboxesResultType.FailedMailboxes Property

public FailedSearchMailboxType[] FailedMailboxes {get; set;}

Remarks

See Also

SearchMailboxesResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemCount Property

Aspose.Email

SearchMailboxesResultType.ItemCount Property

public long ItemCount {get; set;}

Remarks

See Also

SearchMailboxesResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Items Property

Aspose.Email

SearchMailboxesResultType.Items Property

public SearchPreviewItemType[] Items {get; set;}

Remarks

See Also

SearchMailboxesResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


KeywordStats Property

Aspose.Email

SearchMailboxesResultType.KeywordStats Property

public KeywordStatisticsSearchResultType[] KeywordStats {get; set;}

Remarks

See Also

SearchMailboxesResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxStats Property

Aspose.Email

SearchMailboxesResultType.MailboxStats Property

public MailboxStatisticsItemType[] MailboxStats {get; set;}

Remarks

See Also

SearchMailboxesResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PageItemCount Property

Aspose.Email

SearchMailboxesResultType.PageItemCount Property

public int PageItemCount {get; set;}

Remarks

See Also

SearchMailboxesResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PageItemSize Property

Aspose.Email

SearchMailboxesResultType.PageItemSize Property

public long PageItemSize {get; set;}

Remarks

See Also

SearchMailboxesResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Refiners Property

Aspose.Email

SearchMailboxesResultType.Refiners Property

public SearchRefinerItemType[] Refiners {get; set;}

Remarks

See Also

SearchMailboxesResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResultType Property

Aspose.Email

SearchMailboxesResultType.ResultType Property

public SearchResultType ResultType {get; set;}

Remarks

See Also

SearchMailboxesResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchQueries Property

Aspose.Email

SearchMailboxesResultType.SearchQueries Property

public MailboxQueryType[] SearchQueries {get; set;}

Remarks

See Also

SearchMailboxesResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Size Property

Aspose.Email

SearchMailboxesResultType.Size Property

public long Size {get; set;}

Remarks

See Also

SearchMailboxesResultType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchMailboxesType Class

For a list of all members of this type, see SearchMailboxesType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.SearchMailboxesType

public class SearchMailboxesType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SearchMailboxesType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchMailboxesType Members

SearchMailboxesType overview

Public Instance Constructors

SearchMailboxesType Constructor Initializes a new instance of the SearchMailboxesType class.

Public Instance Properties

Deduplication
DeduplicationSpecified
Language
PageDirection
PageDirectionSpecified
PageItemReference
PageSize
PageSizeSpecified
PreviewItemResponseShape
ResultType
SearchQueries
SortBy

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SearchMailboxesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchMailboxesType Constructor

Initializes a new instance of the SearchMailboxesType class.

public SearchMailboxesType();

See Also

SearchMailboxesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchMailboxesType Properties

The properties of the SearchMailboxesType class are listed below. For a complete list of SearchMailboxesType class members, see the SearchMailboxesType Members topic.

Public Instance Properties

Deduplication
DeduplicationSpecified
Language
PageDirection
PageDirectionSpecified
PageItemReference
PageSize
PageSizeSpecified
PreviewItemResponseShape
ResultType
SearchQueries
SortBy

See Also

SearchMailboxesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Deduplication Property

Aspose.Email

SearchMailboxesType.Deduplication Property

public bool Deduplication {get; set;}

Remarks

See Also

SearchMailboxesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeduplicationSpecified Property

Aspose.Email

SearchMailboxesType.DeduplicationSpecified Property

public bool DeduplicationSpecified {get; set;}

Remarks

See Also

SearchMailboxesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Language Property

Aspose.Email

SearchMailboxesType.Language Property

public string Language {get; set;}

Remarks

See Also

SearchMailboxesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PageDirection Property

Aspose.Email

SearchMailboxesType.PageDirection Property

public SearchPageDirectionType PageDirection {get; set;}

Remarks

See Also

SearchMailboxesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PageDirectionSpecified Property

Aspose.Email

SearchMailboxesType.PageDirectionSpecified Property

public bool PageDirectionSpecified {get; set;}

Remarks

See Also

SearchMailboxesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PageItemReference Property

Aspose.Email

SearchMailboxesType.PageItemReference Property

public string PageItemReference {get; set;}

Remarks

See Also

SearchMailboxesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PageSize Property

Aspose.Email

SearchMailboxesType.PageSize Property

public int PageSize {get; set;}

Remarks

See Also

SearchMailboxesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PageSizeSpecified Property

Aspose.Email

SearchMailboxesType.PageSizeSpecified Property

public bool PageSizeSpecified {get; set;}

Remarks

See Also

SearchMailboxesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PreviewItemResponseShape Property

Aspose.Email

SearchMailboxesType.PreviewItemResponseShape Property

public PreviewItemResponseShapeType PreviewItemResponseShape {get; set;}

Remarks

See Also

SearchMailboxesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResultType Property

Aspose.Email

SearchMailboxesType.ResultType Property

public SearchResultType ResultType {get; set;}

Remarks

See Also

SearchMailboxesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchQueries Property

Aspose.Email

SearchMailboxesType.SearchQueries Property

public MailboxQueryType[] SearchQueries {get; set;}

Remarks

See Also

SearchMailboxesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SortBy Property

Aspose.Email

SearchMailboxesType.SortBy Property

public FieldOrderType SortBy {get; set;}

Remarks

See Also

SearchMailboxesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchPageDirectionType Enumeration

public enum SearchPageDirectionType

Remarks

Members

Member Name | Description | Value
Previous |  | 0
Next |  | 1

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchParametersType Class

For a list of all members of this type, see SearchParametersType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.SearchParametersType

public class SearchParametersType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SearchParametersType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchParametersType Members

SearchParametersType overview

Public Instance Constructors

SearchParametersType Constructor Initializes a new instance of the SearchParametersType class.

Public Instance Properties

BaseFolderIds
Restriction
Traversal
TraversalSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SearchParametersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchParametersType Constructor

Initializes a new instance of the SearchParametersType class.

public SearchParametersType();

See Also

SearchParametersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchParametersType Properties

The properties of the SearchParametersType class are listed below. For a complete list of SearchParametersType class members, see the SearchParametersType Members topic.

Public Instance Properties

BaseFolderIds
Restriction
Traversal
TraversalSpecified

See Also

SearchParametersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseFolderIds Property

Aspose.Email

SearchParametersType.BaseFolderIds Property

public BaseFolderIdType[] BaseFolderIds {get; set;}

Remarks

See Also

SearchParametersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Restriction Property

Aspose.Email

SearchParametersType.Restriction Property

public RestrictionType Restriction {get; set;}

Remarks

See Also

SearchParametersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Traversal Property

Aspose.Email

SearchParametersType.Traversal Property

public SearchFolderTraversalType Traversal {get; set;}

Remarks

See Also

SearchParametersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TraversalSpecified Property

Aspose.Email

SearchParametersType.TraversalSpecified Property

public bool TraversalSpecified {get; set;}

Remarks

See Also

SearchParametersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchPreviewItemType Class

For a list of all members of this type, see SearchPreviewItemType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.SearchPreviewItemType

public class SearchPreviewItemType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SearchPreviewItemType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchPreviewItemType Members

SearchPreviewItemType overview

Public Instance Constructors

SearchPreviewItemType Constructor Initializes a new instance of the SearchPreviewItemType class.

Public Instance Properties

BccRecipients
CcRecipients
CreatedTime
CreatedTimeSpecified
ExtendedProperties
HasAttachment
HasAttachmentSpecified
Id
Importance
ImportanceSpecified
ItemClass
Mailbox
OwaLink
ParentId
Preview
Read
ReadSpecified
ReceivedTime
ReceivedTimeSpecified
Sender
SentTime
SentTimeSpecified
Size
SizeSpecified
SortValue
Subject
ToRecipients
UniqueHash

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SearchPreviewItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchPreviewItemType Constructor

Initializes a new instance of the SearchPreviewItemType class.

public SearchPreviewItemType();

See Also

SearchPreviewItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchPreviewItemType Properties

The properties of the SearchPreviewItemType class are listed below. For a complete list of SearchPreviewItemType class members, see the SearchPreviewItemType Members topic.

Public Instance Properties

BccRecipients
CcRecipients
CreatedTime
CreatedTimeSpecified
ExtendedProperties
HasAttachment
HasAttachmentSpecified
Id
Importance
ImportanceSpecified
ItemClass
Mailbox
OwaLink
ParentId
Preview
Read
ReadSpecified
ReceivedTime
ReceivedTimeSpecified
Sender
SentTime
SentTimeSpecified
Size
SizeSpecified
SortValue
Subject
ToRecipients
UniqueHash

See Also

SearchPreviewItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BccRecipients Property

Aspose.Email

SearchPreviewItemType.BccRecipients Property

public string[] BccRecipients {get; set;}

Remarks

See Also

SearchPreviewItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CcRecipients Property

Aspose.Email

SearchPreviewItemType.CcRecipients Property

public string[] CcRecipients {get; set;}

Remarks

See Also

SearchPreviewItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreatedTime Property

Aspose.Email

SearchPreviewItemType.CreatedTime Property

public DateTime CreatedTime {get; set;}

Remarks

See Also

SearchPreviewItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreatedTimeSpecified Property

Aspose.Email

SearchPreviewItemType.CreatedTimeSpecified Property

public bool CreatedTimeSpecified {get; set;}

Remarks

See Also

SearchPreviewItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExtendedProperties Property

Aspose.Email

SearchPreviewItemType.ExtendedProperties Property

public NonEmptyArrayOfExtendedPropertyType ExtendedProperties {get; set;}

Remarks

See Also

SearchPreviewItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


HasAttachment Property

Aspose.Email

SearchPreviewItemType.HasAttachment Property

public bool HasAttachment {get; set;}

Remarks

See Also

SearchPreviewItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


HasAttachmentSpecified Property

Aspose.Email

SearchPreviewItemType.HasAttachmentSpecified Property

public bool HasAttachmentSpecified {get; set;}

Remarks

See Also

SearchPreviewItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Id Property

Aspose.Email

SearchPreviewItemType.Id Property

public ItemIdType Id {get; set;}

Remarks

See Also

SearchPreviewItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Importance Property

Aspose.Email

SearchPreviewItemType.Importance Property

public ImportanceChoicesType Importance {get; set;}

Remarks

See Also

SearchPreviewItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ImportanceSpecified Property

Aspose.Email

SearchPreviewItemType.ImportanceSpecified Property

public bool ImportanceSpecified {get; set;}

Remarks

See Also

SearchPreviewItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemClass Property

Aspose.Email

SearchPreviewItemType.ItemClass Property

public string ItemClass {get; set;}

Remarks

See Also

SearchPreviewItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Mailbox Property

Aspose.Email

SearchPreviewItemType.Mailbox Property

public PreviewItemMailboxType Mailbox {get; set;}

Remarks

See Also

SearchPreviewItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OwaLink Property

Aspose.Email

SearchPreviewItemType.OwaLink Property

public string OwaLink {get; set;}

Remarks

See Also

SearchPreviewItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ParentId Property

Aspose.Email

SearchPreviewItemType.ParentId Property

public ItemIdType ParentId {get; set;}

Remarks

See Also

SearchPreviewItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Preview Property

Aspose.Email

SearchPreviewItemType.Preview Property

public string Preview {get; set;}

Remarks

See Also

SearchPreviewItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Read Property

Aspose.Email

SearchPreviewItemType.Read Property

public bool Read {get; set;}

Remarks

See Also

SearchPreviewItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReadSpecified Property

Aspose.Email

SearchPreviewItemType.ReadSpecified Property

public bool ReadSpecified {get; set;}

Remarks

See Also

SearchPreviewItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReceivedTime Property

Aspose.Email

SearchPreviewItemType.ReceivedTime Property

public DateTime ReceivedTime {get; set;}

Remarks

See Also

SearchPreviewItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ReceivedTimeSpecified Property

Aspose.Email

SearchPreviewItemType.ReceivedTimeSpecified Property

public bool ReceivedTimeSpecified {get; set;}

Remarks

See Also

SearchPreviewItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Sender Property

Aspose.Email

SearchPreviewItemType.Sender Property

public string Sender {get; set;}

Remarks

See Also

SearchPreviewItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SentTime Property

Aspose.Email

SearchPreviewItemType.SentTime Property

public DateTime SentTime {get; set;}

Remarks

See Also

SearchPreviewItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SentTimeSpecified Property

Aspose.Email

SearchPreviewItemType.SentTimeSpecified Property

public bool SentTimeSpecified {get; set;}

Remarks

See Also

SearchPreviewItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Size Property

Aspose.Email

SearchPreviewItemType.Size Property

public long Size {get; set;}

Remarks

See Also

SearchPreviewItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SizeSpecified Property

Aspose.Email

SearchPreviewItemType.SizeSpecified Property

public bool SizeSpecified {get; set;}

Remarks

See Also

SearchPreviewItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SortValue Property

Aspose.Email

SearchPreviewItemType.SortValue Property

public string SortValue {get; set;}

Remarks

See Also

SearchPreviewItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Subject Property

Aspose.Email

SearchPreviewItemType.Subject Property

public string Subject {get; set;}

Remarks

See Also

SearchPreviewItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ToRecipients Property

Aspose.Email

SearchPreviewItemType.ToRecipients Property

public string[] ToRecipients {get; set;}

Remarks

See Also

SearchPreviewItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UniqueHash Property

Aspose.Email

SearchPreviewItemType.UniqueHash Property

public string UniqueHash {get; set;}

Remarks

See Also

SearchPreviewItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchRefinerItemType Class

For a list of all members of this type, see SearchRefinerItemType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.SearchRefinerItemType

public class SearchRefinerItemType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SearchRefinerItemType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchRefinerItemType Members

SearchRefinerItemType overview

Public Instance Constructors

SearchRefinerItemType Constructor Initializes a new instance of the SearchRefinerItemType class.

Public Instance Properties

Count
Name
Token
Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SearchRefinerItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchRefinerItemType Constructor

Initializes a new instance of the SearchRefinerItemType class.

public SearchRefinerItemType();

See Also

SearchRefinerItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchRefinerItemType Properties

The properties of the SearchRefinerItemType class are listed below. For a complete list of SearchRefinerItemType class members, see the SearchRefinerItemType Members topic.

Public Instance Properties

Count
Name
Token
Value

See Also

SearchRefinerItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Count Property

Aspose.Email

SearchRefinerItemType.Count Property

public long Count {get; set;}

Remarks

See Also

SearchRefinerItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Name Property

Aspose.Email

SearchRefinerItemType.Name Property

public string Name {get; set;}

Remarks

See Also

SearchRefinerItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Token Property

Aspose.Email

SearchRefinerItemType.Token Property

public string Token {get; set;}

Remarks

See Also

SearchRefinerItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Value Property

Aspose.Email

SearchRefinerItemType.Value Property

public string Value {get; set;}

Remarks

See Also

SearchRefinerItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchResultType Enumeration

public enum SearchResultType

Remarks

Members

Member Name | Description | Value
StatisticsOnly |  | 0
PreviewOnly |  | 1

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SeekToConditionPageViewType Class

For a list of all members of this type, see SeekToConditionPageViewType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BasePagingType
Aspose.Email.Exchange.Schema.Exchange_2013.SeekToConditionPageViewType

public class SeekToConditionPageViewType : BasePagingType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SeekToConditionPageViewType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SeekToConditionPageViewType Members

SeekToConditionPageViewType overview

Public Instance Constructors

SeekToConditionPageViewType Constructor Initializes a new instance of the SeekToConditionPageViewType class.

Public Instance Properties

BasePoint
Condition
MaxEntriesReturned (inherited from BasePagingType)
MaxEntriesReturnedSpecified (inherited from BasePagingType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SeekToConditionPageViewType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SeekToConditionPageViewType Constructor

Initializes a new instance of the SeekToConditionPageViewType class.

public SeekToConditionPageViewType();

See Also

SeekToConditionPageViewType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SeekToConditionPageViewType Properties

The properties of the SeekToConditionPageViewType class are listed below. For a complete list of SeekToConditionPageViewType class members, see the SeekToConditionPageViewType Members topic.

Public Instance Properties

BasePoint
Condition
MaxEntriesReturned (inherited from BasePagingType)
MaxEntriesReturnedSpecified (inherited from BasePagingType)

See Also

SeekToConditionPageViewType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BasePoint Property

Aspose.Email

SeekToConditionPageViewType.BasePoint Property

public IndexBasePointType BasePoint {get; set;}

Remarks

See Also

SeekToConditionPageViewType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Condition Property

Aspose.Email

SeekToConditionPageViewType.Condition Property

public RestrictionType Condition {get; set;}

Remarks

See Also

SeekToConditionPageViewType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SendItemCompletedEventArgs Class

For a list of all members of this type, see SendItemCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.SendItemCompletedEventArgs

public class SendItemCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SendItemCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SendItemCompletedEventArgs Members

SendItemCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

SendItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SendItemCompletedEventArgs Properties

The properties of the SendItemCompletedEventArgs class are listed below. For a complete list of SendItemCompletedEventArgs class members, see the SendItemCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

SendItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

SendItemCompletedEventArgs.Result Property

public SendItemResponseType Result {get;}

Remarks

See Also

SendItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SendItemCompletedEventHandler Delegate

public delegate void SendItemCompletedEventHandler(
object sender,
SendItemCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SendItemResponseType Class

For a list of all members of this type, see SendItemResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.SendItemResponseType

public class SendItemResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SendItemResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SendItemResponseType Members

SendItemResponseType overview

Public Instance Constructors

SendItemResponseType Constructor Initializes a new instance of the SendItemResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SendItemResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SendItemResponseType Constructor

Initializes a new instance of the SendItemResponseType class.

public SendItemResponseType();

See Also

SendItemResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SendItemType Class

For a list of all members of this type, see SendItemType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.SendItemType

public class SendItemType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SendItemType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SendItemType Members

SendItemType overview

Public Instance Constructors

SendItemType Constructor Initializes a new instance of the SendItemType class.

Public Instance Properties

ItemIds
SavedItemFolderId
SaveItemToFolder

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SendItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SendItemType Constructor

Initializes a new instance of the SendItemType class.

public SendItemType();

See Also

SendItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SendItemType Properties

The properties of the SendItemType class are listed below. For a complete list of SendItemType class members, see the SendItemType Members topic.

Public Instance Properties

ItemIds
SavedItemFolderId
SaveItemToFolder

See Also

SendItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemIds Property

Aspose.Email

SendItemType.ItemIds Property

public BaseItemIdType[] ItemIds {get; set;}

Remarks

See Also

SendItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SavedItemFolderId Property

Aspose.Email

SendItemType.SavedItemFolderId Property

public TargetFolderIdType SavedItemFolderId {get; set;}

Remarks

See Also

SendItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SaveItemToFolder Property

Aspose.Email

SendItemType.SaveItemToFolder Property

public bool SaveItemToFolder {get; set;}

Remarks

See Also

SendItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SendNotificationResponseMessageType Class

For a list of all members of this type, see SendNotificationResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.SendNotificationResponseMessageType

public class SendNotificationResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SendNotificationResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SendNotificationResponseMessageType Members

SendNotificationResponseMessageType overview

Public Instance Constructors

SendNotificationResponseMessageType Constructor Initializes a new instance of the SendNotificationResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
Notification
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SendNotificationResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SendNotificationResponseMessageType Constructor

Initializes a new instance of the SendNotificationResponseMessageType class.

public SendNotificationResponseMessageType();

See Also

SendNotificationResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SendNotificationResponseMessageType Properties

The properties of the SendNotificationResponseMessageType class are listed below. For a complete list of SendNotificationResponseMessageType class members, see the SendNotificationResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
Notification
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

SendNotificationResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Notification Property

Aspose.Email

SendNotificationResponseMessageType.Notification Property

public NotificationType Notification {get; set;}

Remarks

See Also

SendNotificationResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SendNotificationResponseType Class

For a list of all members of this type, see SendNotificationResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.SendNotificationResponseType

public class SendNotificationResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SendNotificationResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SendNotificationResponseType Members

SendNotificationResponseType overview

Public Instance Constructors

SendNotificationResponseType Constructor Initializes a new instance of the SendNotificationResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SendNotificationResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SendNotificationResponseType Constructor

Initializes a new instance of the SendNotificationResponseType class.

public SendNotificationResponseType();

See Also

SendNotificationResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SensitivityChoicesType Enumeration

public enum SensitivityChoicesType

Remarks

Members

Member Name | Description | Value
Normal |  | 0
Personal |  | 1
Private |  | 2
Confidential |  | 3

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SerializableTimeZone Class

For a list of all members of this type, see SerializableTimeZone Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.SerializableTimeZone

public class SerializableTimeZone

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SerializableTimeZone Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SerializableTimeZone Members

SerializableTimeZone overview

Public Instance Constructors

SerializableTimeZone Constructor Initializes a new instance of the SerializableTimeZone class.

Public Instance Properties

Bias
DaylightTime
StandardTime

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SerializableTimeZone Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SerializableTimeZone Constructor

Initializes a new instance of the SerializableTimeZone class.

public SerializableTimeZone();

See Also

SerializableTimeZone Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SerializableTimeZone Properties

The properties of the SerializableTimeZone class are listed below. For a complete list of SerializableTimeZone class members, see the SerializableTimeZone Members topic.

Public Instance Properties

Bias
DaylightTime
StandardTime

See Also

SerializableTimeZone Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Bias Property

Aspose.Email

SerializableTimeZone.Bias Property

public int Bias {get; set;}

Remarks

See Also

SerializableTimeZone Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DaylightTime Property

Aspose.Email

SerializableTimeZone.DaylightTime Property

public SerializableTimeZoneTime DaylightTime {get; set;}

Remarks

See Also

SerializableTimeZone Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StandardTime Property

Aspose.Email

SerializableTimeZone.StandardTime Property

public SerializableTimeZoneTime StandardTime {get; set;}

Remarks

See Also

SerializableTimeZone Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SerializableTimeZoneTime Class

For a list of all members of this type, see SerializableTimeZoneTime Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.SerializableTimeZoneTime

public class SerializableTimeZoneTime

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SerializableTimeZoneTime Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SerializableTimeZoneTime Members

SerializableTimeZoneTime overview

Public Instance Constructors

SerializableTimeZoneTime Constructor Initializes a new instance of the SerializableTimeZoneTime class.

Public Instance Properties

Bias
DayOfWeek
DayOrder
Month
Time
Year

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SerializableTimeZoneTime Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SerializableTimeZoneTime Constructor

Initializes a new instance of the SerializableTimeZoneTime class.

public SerializableTimeZoneTime();

See Also

SerializableTimeZoneTime Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SerializableTimeZoneTime Properties

The properties of the SerializableTimeZoneTime class are listed below. For a complete list of SerializableTimeZoneTime class members, see the SerializableTimeZoneTime Members topic.

Public Instance Properties

Bias
DayOfWeek
DayOrder
Month
Time
Year

See Also

SerializableTimeZoneTime Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Bias Property

Aspose.Email

SerializableTimeZoneTime.Bias Property

public int Bias {get; set;}

Remarks

See Also

SerializableTimeZoneTime Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DayOfWeek Property

Aspose.Email

SerializableTimeZoneTime.DayOfWeek Property

public string DayOfWeek {get; set;}

Remarks

See Also

SerializableTimeZoneTime Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DayOrder Property

Aspose.Email

SerializableTimeZoneTime.DayOrder Property

public short DayOrder {get; set;}

Remarks

See Also

SerializableTimeZoneTime Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Month Property

Aspose.Email

SerializableTimeZoneTime.Month Property

public short Month {get; set;}

Remarks

See Also

SerializableTimeZoneTime Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Time Property

Aspose.Email

SerializableTimeZoneTime.Time Property

public string Time {get; set;}

Remarks

See Also

SerializableTimeZoneTime Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Year Property

Aspose.Email

SerializableTimeZoneTime.Year Property

public string Year {get; set;}

Remarks

See Also

SerializableTimeZoneTime Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ServerVersionInfo Class

For a list of all members of this type, see ServerVersionInfo Members.

System.Object
System.Web.Services.Protocols.SoapHeader
Aspose.Email.Exchange.Schema.Exchange_2013.ServerVersionInfo

public class ServerVersionInfo : SoapHeader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ServerVersionInfo Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ServerVersionInfo Members

ServerVersionInfo overview

Public Instance Constructors

ServerVersionInfo Constructor Initializes a new instance of the ServerVersionInfo class.

Public Instance Properties

Actor (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.
DidUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether an XML Web service method properly processed a SOAP header.
EncodedMustUnderstand (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.1.
EncodedMustUnderstand12 (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.2.
EncodedRelay (inherited from SoapHeader) | Gets or sets the relay attribute of the SOAP 1.2 header.
MajorBuildNumber |
MajorBuildNumberSpecified |
MajorVersion |
MajorVersionSpecified |
MinorBuildNumber |
MinorBuildNumberSpecified |
MinorVersion |
MinorVersionSpecified |
MustUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether the SoapHeader must be understood.
Relay (inherited from SoapHeader) | Gets or sets a value that indicates whether the SOAP header is to be relayed to the next SOAP node if the current node does not understand the header.
Role (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.
Version |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ServerVersionInfo Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ServerVersionInfo Constructor

Initializes a new instance of the ServerVersionInfo class.

public ServerVersionInfo();

See Also

ServerVersionInfo Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ServerVersionInfo Properties

The properties of the ServerVersionInfo class are listed below. For a complete list of ServerVersionInfo class members, see the ServerVersionInfo Members topic.

Public Instance Properties

Actor (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.
DidUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether an XML Web service method properly processed a SOAP header.
EncodedMustUnderstand (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.1.
EncodedMustUnderstand12 (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.2.
EncodedRelay (inherited from SoapHeader) | Gets or sets the relay attribute of the SOAP 1.2 header.
MajorBuildNumber |
MajorBuildNumberSpecified |
MajorVersion |
MajorVersionSpecified |
MinorBuildNumber |
MinorBuildNumberSpecified |
MinorVersion |
MinorVersionSpecified |
MustUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether the SoapHeader must be understood.
Relay (inherited from SoapHeader) | Gets or sets a value that indicates whether the SOAP header is to be relayed to the next SOAP node if the current node does not understand the header.
Role (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.
Version |

See Also

ServerVersionInfo Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MajorBuildNumber Property

Aspose.Email

ServerVersionInfo.MajorBuildNumber Property

public int MajorBuildNumber {get; set;}

Remarks

See Also

ServerVersionInfo Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MajorBuildNumberSpecified Property

Aspose.Email

ServerVersionInfo.MajorBuildNumberSpecified Property

public bool MajorBuildNumberSpecified {get; set;}

Remarks

See Also

ServerVersionInfo Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MajorVersion Property

Aspose.Email

ServerVersionInfo.MajorVersion Property

public int MajorVersion {get; set;}

Remarks

See Also

ServerVersionInfo Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MajorVersionSpecified Property

Aspose.Email

ServerVersionInfo.MajorVersionSpecified Property

public bool MajorVersionSpecified {get; set;}

Remarks

See Also

ServerVersionInfo Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MinorBuildNumber Property

Aspose.Email

ServerVersionInfo.MinorBuildNumber Property

public int MinorBuildNumber {get; set;}

Remarks

See Also

ServerVersionInfo Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MinorBuildNumberSpecified Property

Aspose.Email

ServerVersionInfo.MinorBuildNumberSpecified Property

public bool MinorBuildNumberSpecified {get; set;}

Remarks

See Also

ServerVersionInfo Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MinorVersion Property

Aspose.Email

ServerVersionInfo.MinorVersion Property

public int MinorVersion {get; set;}

Remarks

See Also

ServerVersionInfo Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MinorVersionSpecified Property

Aspose.Email

ServerVersionInfo.MinorVersionSpecified Property

public bool MinorVersionSpecified {get; set;}

Remarks

See Also

ServerVersionInfo Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Version Property

Aspose.Email

ServerVersionInfo.Version Property

public string Version {get; set;}

Remarks

See Also

ServerVersionInfo Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ServiceConfiguration Class

For a list of all members of this type, see ServiceConfiguration Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ServiceConfiguration
Aspose.Email.Exchange.Schema.Exchange_2013.MailTipsServiceConfiguration
Aspose.Email.Exchange.Schema.Exchange_2013.ProtectionRulesServiceConfiguration
Aspose.Email.Exchange.Schema.Exchange_2013.UnifiedMessageServiceConfiguration

public class ServiceConfiguration

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ServiceConfiguration Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ServiceConfiguration Members

ServiceConfiguration overview

Public Instance Constructors

ServiceConfiguration Constructor Initializes a new instance of the ServiceConfiguration class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ServiceConfiguration Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ServiceConfiguration Constructor

Initializes a new instance of the ServiceConfiguration class.

public ServiceConfiguration();

See Also

ServiceConfiguration Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ServiceConfigurationResponseMessageType Class

For a list of all members of this type, see ServiceConfigurationResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.ServiceConfigurationResponseMessageType

public class ServiceConfigurationResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ServiceConfigurationResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ServiceConfigurationResponseMessageType Members

ServiceConfigurationResponseMessageType overview

Public Instance Constructors

ServiceConfigurationResponseMessageType Constructor Initializes a new instance of the ServiceConfigurationResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MailTipsConfiguration
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
PolicyNudgeRulesConfiguration
ProtectionRulesConfiguration
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
UnifiedMessagingConfiguration

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ServiceConfigurationResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ServiceConfigurationResponseMessageType Constructor

Initializes a new instance of the ServiceConfigurationResponseMessageType class.

public ServiceConfigurationResponseMessageType();

See Also

ServiceConfigurationResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ServiceConfigurationResponseMessageType Properties

The properties of the ServiceConfigurationResponseMessageType class are listed below. For a complete list of ServiceConfigurationResponseMessageType class members, see the ServiceConfigurationResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MailTipsConfiguration
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
PolicyNudgeRulesConfiguration
ProtectionRulesConfiguration
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
UnifiedMessagingConfiguration

See Also

ServiceConfigurationResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailTipsConfiguration Property

Aspose.Email

ServiceConfigurationResponseMessageType.MailTipsConfiguration Property

public MailTipsServiceConfiguration MailTipsConfiguration {get; set;}

Remarks

See Also

ServiceConfigurationResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PolicyNudgeRulesConfiguration Property

Aspose.Email

ServiceConfigurationResponseMessageType.PolicyNudgeRulesConfiguration Property

public PolicyNudgeRulesServiceConfiguration PolicyNudgeRulesConfiguration {get; set;}

Remarks

See Also

ServiceConfigurationResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ProtectionRulesConfiguration Property

Aspose.Email

ServiceConfigurationResponseMessageType.ProtectionRulesConfiguration Property

public ProtectionRulesServiceConfiguration ProtectionRulesConfiguration {get; set;}

Remarks

See Also

ServiceConfigurationResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UnifiedMessagingConfiguration Property

Aspose.Email

ServiceConfigurationResponseMessageType.UnifiedMessagingConfiguration Property

public UnifiedMessageServiceConfiguration UnifiedMessagingConfiguration {get; set;}

Remarks

See Also

ServiceConfigurationResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ServiceConfigurationType Enumeration

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum ServiceConfigurationType

Remarks

Members

Member Name | Description | Value
MailTips |  | 1
UnifiedMessagingConfiguration |  | 2
ProtectionRules |  | 4
PolicyNudges |  | 8

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetClientExtensionActionIdType Enumeration

public enum SetClientExtensionActionIdType

Remarks

Members

Member Name | Description | Value
Install |  | 0
Uninstall |  | 1
Configure |  | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetClientExtensionActionType Class

For a list of all members of this type, see SetClientExtensionActionType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.SetClientExtensionActionType

public class SetClientExtensionActionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SetClientExtensionActionType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetClientExtensionActionType Members

SetClientExtensionActionType overview

Public Instance Constructors

SetClientExtensionActionType Constructor Initializes a new instance of the SetClientExtensionActionType class.

Public Instance Properties

ActionId
ClientExtension
ExtensionId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SetClientExtensionActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetClientExtensionActionType Constructor

Initializes a new instance of the SetClientExtensionActionType class.

public SetClientExtensionActionType();

See Also

SetClientExtensionActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetClientExtensionActionType Properties

The properties of the SetClientExtensionActionType class are listed below. For a complete list of SetClientExtensionActionType class members, see the SetClientExtensionActionType Members topic.

Public Instance Properties

ActionId
ClientExtension
ExtensionId

See Also

SetClientExtensionActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ActionId Property

Aspose.Email

SetClientExtensionActionType.ActionId Property

public SetClientExtensionActionIdType ActionId {get; set;}

Remarks

See Also

SetClientExtensionActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ClientExtension Property

Aspose.Email

SetClientExtensionActionType.ClientExtension Property

public ClientExtensionType ClientExtension {get; set;}

Remarks

See Also

SetClientExtensionActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExtensionId Property

Aspose.Email

SetClientExtensionActionType.ExtensionId Property

public string ExtensionId {get; set;}

Remarks

See Also

SetClientExtensionActionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetClientExtensionResponseType Class

For a list of all members of this type, see SetClientExtensionResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.SetClientExtensionResponseType

public class SetClientExtensionResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SetClientExtensionResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetClientExtensionResponseType Members

SetClientExtensionResponseType overview

Public Instance Constructors

SetClientExtensionResponseType Constructor Initializes a new instance of the SetClientExtensionResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SetClientExtensionResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetClientExtensionResponseType Constructor

Initializes a new instance of the SetClientExtensionResponseType class.

public SetClientExtensionResponseType();

See Also

SetClientExtensionResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetClientExtensionType Class

For a list of all members of this type, see SetClientExtensionType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.SetClientExtensionType

public class SetClientExtensionType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SetClientExtensionType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetClientExtensionType Members

SetClientExtensionType overview

Public Instance Constructors

SetClientExtensionType Constructor Initializes a new instance of the SetClientExtensionType class.

Public Instance Properties

Actions

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SetClientExtensionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetClientExtensionType Constructor

Initializes a new instance of the SetClientExtensionType class.

public SetClientExtensionType();

See Also

SetClientExtensionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetClientExtensionType Properties

The properties of the SetClientExtensionType class are listed below. For a complete list of SetClientExtensionType class members, see the SetClientExtensionType Members topic.

Public Instance Properties

Actions

See Also

SetClientExtensionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Actions Property

Aspose.Email

SetClientExtensionType.Actions Property

public SetClientExtensionActionType[] Actions {get; set;}

Remarks

See Also

SetClientExtensionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetFolderFieldType Class

For a list of all members of this type, see SetFolderFieldType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ChangeDescriptionType
Aspose.Email.Exchange.Schema.Exchange_2013.FolderChangeDescriptionType
Aspose.Email.Exchange.Schema.Exchange_2013.SetFolderFieldType

public class SetFolderFieldType : FolderChangeDescriptionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SetFolderFieldType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetFolderFieldType Members

SetFolderFieldType overview

Public Instance Constructors

SetFolderFieldType Constructor Initializes a new instance of the SetFolderFieldType class.

Public Instance Properties

Item (inherited from ChangeDescriptionType)
Item1

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SetFolderFieldType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetFolderFieldType Constructor

Initializes a new instance of the SetFolderFieldType class.

public SetFolderFieldType();

See Also

SetFolderFieldType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetFolderFieldType Properties

The properties of the SetFolderFieldType class are listed below. For a complete list of SetFolderFieldType class members, see the SetFolderFieldType Members topic.

Public Instance Properties

Item (inherited from ChangeDescriptionType)
Item1

See Also

SetFolderFieldType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Item1 Property

Aspose.Email

SetFolderFieldType.Item1 Property

public BaseFolderType Item1 {get; set;}

Remarks

See Also

SetFolderFieldType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetHoldOnMailboxesCompletedEventArgs Class

For a list of all members of this type, see SetHoldOnMailboxesCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.SetHoldOnMailboxesCompletedEventArgs

public class SetHoldOnMailboxesCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SetHoldOnMailboxesCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetHoldOnMailboxesCompletedEventArgs Members

SetHoldOnMailboxesCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

SetHoldOnMailboxesCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetHoldOnMailboxesCompletedEventArgs Properties

The properties of the SetHoldOnMailboxesCompletedEventArgs class are listed below. For a complete list of SetHoldOnMailboxesCompletedEventArgs class members, see the SetHoldOnMailboxesCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

SetHoldOnMailboxesCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

SetHoldOnMailboxesCompletedEventArgs.Result Property

public SetHoldOnMailboxesResponseMessageType Result {get;}

Remarks

See Also

SetHoldOnMailboxesCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetHoldOnMailboxesCompletedEventHandler Delegate

public delegate void SetHoldOnMailboxesCompletedEventHandler(
object sender,
SetHoldOnMailboxesCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetHoldOnMailboxesResponseMessageType Class

For a list of all members of this type, see SetHoldOnMailboxesResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.SetHoldOnMailboxesResponseMessageType

public class SetHoldOnMailboxesResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SetHoldOnMailboxesResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetHoldOnMailboxesResponseMessageType Members

SetHoldOnMailboxesResponseMessageType overview

Public Instance Constructors

SetHoldOnMailboxesResponseMessageType Constructor Initializes a new instance of the SetHoldOnMailboxesResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MailboxHoldResult
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SetHoldOnMailboxesResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetHoldOnMailboxesResponseMessageType Constructor

Initializes a new instance of the SetHoldOnMailboxesResponseMessageType class.

public SetHoldOnMailboxesResponseMessageType();

See Also

SetHoldOnMailboxesResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetHoldOnMailboxesResponseMessageType Properties

The properties of the SetHoldOnMailboxesResponseMessageType class are listed below. For a complete list of SetHoldOnMailboxesResponseMessageType class members, see the SetHoldOnMailboxesResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MailboxHoldResult
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

SetHoldOnMailboxesResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxHoldResult Property

Aspose.Email

SetHoldOnMailboxesResponseMessageType.MailboxHoldResult Property

public MailboxHoldResultType MailboxHoldResult {get; set;}

Remarks

See Also

SetHoldOnMailboxesResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetHoldOnMailboxesType Class

For a list of all members of this type, see SetHoldOnMailboxesType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.SetHoldOnMailboxesType

public class SetHoldOnMailboxesType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SetHoldOnMailboxesType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetHoldOnMailboxesType Members

SetHoldOnMailboxesType overview

Public Instance Constructors

SetHoldOnMailboxesType Constructor Initializes a new instance of the SetHoldOnMailboxesType class.

Public Instance Properties

ActionType
Deduplication
DeduplicationSpecified
HoldId
IncludeNonIndexableItems
IncludeNonIndexableItemsSpecified
InPlaceHoldIdentity
Language
Mailboxes
Query

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SetHoldOnMailboxesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetHoldOnMailboxesType Constructor

Initializes a new instance of the SetHoldOnMailboxesType class.

public SetHoldOnMailboxesType();

See Also

SetHoldOnMailboxesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetHoldOnMailboxesType Properties

The properties of the SetHoldOnMailboxesType class are listed below. For a complete list of SetHoldOnMailboxesType class members, see the SetHoldOnMailboxesType Members topic.

Public Instance Properties

ActionType
Deduplication
DeduplicationSpecified
HoldId
IncludeNonIndexableItems
IncludeNonIndexableItemsSpecified
InPlaceHoldIdentity
Language
Mailboxes
Query

See Also

SetHoldOnMailboxesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ActionType Property

Aspose.Email

SetHoldOnMailboxesType.ActionType Property

public HoldActionType ActionType {get; set;}

Remarks

See Also

SetHoldOnMailboxesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Deduplication Property

Aspose.Email

SetHoldOnMailboxesType.Deduplication Property

public bool Deduplication {get; set;}

Remarks

See Also

SetHoldOnMailboxesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeduplicationSpecified Property

Aspose.Email

SetHoldOnMailboxesType.DeduplicationSpecified Property

public bool DeduplicationSpecified {get; set;}

Remarks

See Also

SetHoldOnMailboxesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


HoldId Property

Aspose.Email

SetHoldOnMailboxesType.HoldId Property

public string HoldId {get; set;}

Remarks

See Also

SetHoldOnMailboxesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IncludeNonIndexableItems Property

Aspose.Email

SetHoldOnMailboxesType.IncludeNonIndexableItems Property

public bool IncludeNonIndexableItems {get; set;}

Remarks

See Also

SetHoldOnMailboxesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IncludeNonIndexableItemsSpecified Property

Aspose.Email

SetHoldOnMailboxesType.IncludeNonIndexableItemsSpecified Property

public bool IncludeNonIndexableItemsSpecified {get; set;}

Remarks

See Also

SetHoldOnMailboxesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InPlaceHoldIdentity Property

Aspose.Email

SetHoldOnMailboxesType.InPlaceHoldIdentity Property

public string InPlaceHoldIdentity {get; set;}

Remarks

See Also

SetHoldOnMailboxesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Language Property

Aspose.Email

SetHoldOnMailboxesType.Language Property

public string Language {get; set;}

Remarks

See Also

SetHoldOnMailboxesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Mailboxes Property

Aspose.Email

SetHoldOnMailboxesType.Mailboxes Property

public string[] Mailboxes {get; set;}

Remarks

See Also

SetHoldOnMailboxesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Query Property

Aspose.Email

SetHoldOnMailboxesType.Query Property

public string Query {get; set;}

Remarks

See Also

SetHoldOnMailboxesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetImGroupCompletedEventArgs Class

For a list of all members of this type, see SetImGroupCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.SetImGroupCompletedEventArgs

public class SetImGroupCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SetImGroupCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetImGroupCompletedEventArgs Members

SetImGroupCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

SetImGroupCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetImGroupCompletedEventArgs Properties

The properties of the SetImGroupCompletedEventArgs class are listed below. For a complete list of SetImGroupCompletedEventArgs class members, see the SetImGroupCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

SetImGroupCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

SetImGroupCompletedEventArgs.Result Property

public SetImGroupResponseMessageType Result {get;}

Remarks

See Also

SetImGroupCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetImGroupCompletedEventHandler Delegate

public delegate void SetImGroupCompletedEventHandler(
object sender,
SetImGroupCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetImGroupResponseMessageType Class

For a list of all members of this type, see SetImGroupResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.SetImGroupResponseMessageType

public class SetImGroupResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SetImGroupResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetImGroupResponseMessageType Members

SetImGroupResponseMessageType overview

Public Instance Constructors

SetImGroupResponseMessageType Constructor Initializes a new instance of the SetImGroupResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SetImGroupResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetImGroupResponseMessageType Constructor

Initializes a new instance of the SetImGroupResponseMessageType class.

public SetImGroupResponseMessageType();

See Also

SetImGroupResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetImGroupType Class

For a list of all members of this type, see SetImGroupType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.SetImGroupType

public class SetImGroupType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SetImGroupType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetImGroupType Members

SetImGroupType overview

Public Instance Constructors

SetImGroupType Constructor Initializes a new instance of the SetImGroupType class.

Public Instance Properties

GroupId
NewDisplayName

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SetImGroupType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetImGroupType Constructor

Initializes a new instance of the SetImGroupType class.

public SetImGroupType();

See Also

SetImGroupType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetImGroupType Properties

The properties of the SetImGroupType class are listed below. For a complete list of SetImGroupType class members, see the SetImGroupType Members topic.

Public Instance Properties

GroupId
NewDisplayName

See Also

SetImGroupType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GroupId Property

Aspose.Email

SetImGroupType.GroupId Property

public ItemIdType GroupId {get; set;}

Remarks

See Also

SetImGroupType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NewDisplayName Property

Aspose.Email

SetImGroupType.NewDisplayName Property

public string NewDisplayName {get; set;}

Remarks

See Also

SetImGroupType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetImListMigrationCompletedCompletedEventArgs Class

For a list of all members of this type, see SetImListMigrationCompletedCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.SetImListMigrationCompletedCompletedEventArgs

public class SetImListMigrationCompletedCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SetImListMigrationCompletedCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetImListMigrationCompletedCompletedEventArgs Members

SetImListMigrationCompletedCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

SetImListMigrationCompletedCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetImListMigrationCompletedCompletedEventArgs Properties

The properties of the SetImListMigrationCompletedCompletedEventArgs class are listed below. For a complete list of SetImListMigrationCompletedCompletedEventArgs class members, see the SetImListMigrationCompletedCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

SetImListMigrationCompletedCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

SetImListMigrationCompletedCompletedEventArgs.Result Property

public SetImListMigrationCompletedResponseMessageType Result {get;}

Remarks

See Also

SetImListMigrationCompletedCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetImListMigrationCompletedCompletedEventHandler Delegate

public delegate void SetImListMigrationCompletedCompletedEventHandler(
object sender,
SetImListMigrationCompletedCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetImListMigrationCompletedResponseMessageType Class

For a list of all members of this type, see SetImListMigrationCompletedResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.SetImListMigrationCompletedResponseMessageType

public class SetImListMigrationCompletedResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SetImListMigrationCompletedResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetImListMigrationCompletedResponseMessageType Members

SetImListMigrationCompletedResponseMessageType overview

Public Instance Constructors

SetImListMigrationCompletedResponseMessageType Constructor Initializes a new instance of the SetImListMigrationCompletedResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SetImListMigrationCompletedResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetImListMigrationCompletedResponseMessageType Constructor

Initializes a new instance of the SetImListMigrationCompletedResponseMessageType class.

public SetImListMigrationCompletedResponseMessageType();

See Also

SetImListMigrationCompletedResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetImListMigrationCompletedType Class

For a list of all members of this type, see SetImListMigrationCompletedType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.SetImListMigrationCompletedType

public class SetImListMigrationCompletedType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SetImListMigrationCompletedType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetImListMigrationCompletedType Members

SetImListMigrationCompletedType overview

Public Instance Constructors

SetImListMigrationCompletedType Constructor Initializes a new instance of the SetImListMigrationCompletedType class.

Public Instance Properties

ImListMigrationCompleted

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SetImListMigrationCompletedType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetImListMigrationCompletedType Constructor

Initializes a new instance of the SetImListMigrationCompletedType class.

public SetImListMigrationCompletedType();

See Also

SetImListMigrationCompletedType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetImListMigrationCompletedType Properties

The properties of the SetImListMigrationCompletedType class are listed below. For a complete list of SetImListMigrationCompletedType class members, see the SetImListMigrationCompletedType Members topic.

Public Instance Properties

ImListMigrationCompleted

See Also

SetImListMigrationCompletedType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ImListMigrationCompleted Property

Aspose.Email

SetImListMigrationCompletedType.ImListMigrationCompleted Property

public bool ImListMigrationCompleted {get; set;}

Remarks

See Also

SetImListMigrationCompletedType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetItemFieldType Class

For a list of all members of this type, see SetItemFieldType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ChangeDescriptionType
Aspose.Email.Exchange.Schema.Exchange_2013.ItemChangeDescriptionType
Aspose.Email.Exchange.Schema.Exchange_2013.SetItemFieldType

public class SetItemFieldType : ItemChangeDescriptionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SetItemFieldType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetItemFieldType Members

SetItemFieldType overview

Public Instance Constructors

SetItemFieldType Constructor Initializes a new instance of the SetItemFieldType class.

Public Instance Properties

Item (inherited from ChangeDescriptionType)
Item1

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SetItemFieldType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetItemFieldType Constructor

Initializes a new instance of the SetItemFieldType class.

public SetItemFieldType();

See Also

SetItemFieldType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetItemFieldType Properties

The properties of the SetItemFieldType class are listed below. For a complete list of SetItemFieldType class members, see the SetItemFieldType Members topic.

Public Instance Properties

Item (inherited from ChangeDescriptionType)
Item1

See Also

SetItemFieldType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Item1 Property

Aspose.Email

SetItemFieldType.Item1 Property

public ItemType Item1 {get; set;}

Remarks

See Also

SetItemFieldType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetRuleOperationType Class

For a list of all members of this type, see SetRuleOperationType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.RuleOperationType
Aspose.Email.Exchange.Schema.Exchange_2013.SetRuleOperationType

public class SetRuleOperationType : RuleOperationType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SetRuleOperationType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetRuleOperationType Members

SetRuleOperationType overview

Public Instance Constructors

SetRuleOperationType Constructor Initializes a new instance of the SetRuleOperationType class.

Public Instance Properties

Rule

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SetRuleOperationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetRuleOperationType Constructor

Initializes a new instance of the SetRuleOperationType class.

public SetRuleOperationType();

See Also

SetRuleOperationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetRuleOperationType Properties

The properties of the SetRuleOperationType class are listed below. For a complete list of SetRuleOperationType class members, see the SetRuleOperationType Members topic.

Public Instance Properties

Rule

See Also

SetRuleOperationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Rule Property

Aspose.Email

SetRuleOperationType.Rule Property

public RuleType Rule {get; set;}

Remarks

See Also

SetRuleOperationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetTeamMailboxCompletedEventArgs Class

For a list of all members of this type, see SetTeamMailboxCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.SetTeamMailboxCompletedEventArgs

public class SetTeamMailboxCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SetTeamMailboxCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetTeamMailboxCompletedEventArgs Members

SetTeamMailboxCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

SetTeamMailboxCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetTeamMailboxCompletedEventArgs Properties

The properties of the SetTeamMailboxCompletedEventArgs class are listed below. For a complete list of SetTeamMailboxCompletedEventArgs class members, see the SetTeamMailboxCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

SetTeamMailboxCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

SetTeamMailboxCompletedEventArgs.Result Property

public SetTeamMailboxResponseMessageType Result {get;}

Remarks

See Also

SetTeamMailboxCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetTeamMailboxCompletedEventHandler Delegate

public delegate void SetTeamMailboxCompletedEventHandler(
object sender,
SetTeamMailboxCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetTeamMailboxRequestType Class

For a list of all members of this type, see SetTeamMailboxRequestType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.SetTeamMailboxRequestType

public class SetTeamMailboxRequestType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SetTeamMailboxRequestType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetTeamMailboxRequestType Members

SetTeamMailboxRequestType overview

Public Instance Constructors

SetTeamMailboxRequestType Constructor Initializes a new instance of the SetTeamMailboxRequestType class.

Public Instance Properties

EmailAddress
SharePointSiteUrl
State

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SetTeamMailboxRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetTeamMailboxRequestType Constructor

Initializes a new instance of the SetTeamMailboxRequestType class.

public SetTeamMailboxRequestType();

See Also

SetTeamMailboxRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetTeamMailboxRequestType Properties

The properties of the SetTeamMailboxRequestType class are listed below. For a complete list of SetTeamMailboxRequestType class members, see the SetTeamMailboxRequestType Members topic.

Public Instance Properties

EmailAddress
SharePointSiteUrl
State

See Also

SetTeamMailboxRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EmailAddress Property

Aspose.Email

SetTeamMailboxRequestType.EmailAddress Property

public EmailAddressType EmailAddress {get; set;}

Remarks

See Also

SetTeamMailboxRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SharePointSiteUrl Property

Aspose.Email

SetTeamMailboxRequestType.SharePointSiteUrl Property

public string SharePointSiteUrl {get; set;}

Remarks

See Also

SetTeamMailboxRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


State Property

Aspose.Email

SetTeamMailboxRequestType.State Property

public TeamMailboxLifecycleStateType State {get; set;}

Remarks

See Also

SetTeamMailboxRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetTeamMailboxResponseMessageType Class

For a list of all members of this type, see SetTeamMailboxResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.SetTeamMailboxResponseMessageType

public class SetTeamMailboxResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SetTeamMailboxResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetTeamMailboxResponseMessageType Members

SetTeamMailboxResponseMessageType overview

Public Instance Constructors

SetTeamMailboxResponseMessageType Constructor Initializes a new instance of the SetTeamMailboxResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SetTeamMailboxResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetTeamMailboxResponseMessageType Constructor

Initializes a new instance of the SetTeamMailboxResponseMessageType class.

public SetTeamMailboxResponseMessageType();

See Also

SetTeamMailboxResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetUserOofSettingsCompletedEventArgs Class

For a list of all members of this type, see SetUserOofSettingsCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.SetUserOofSettingsCompletedEventArgs

public class SetUserOofSettingsCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SetUserOofSettingsCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetUserOofSettingsCompletedEventArgs Members

SetUserOofSettingsCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

SetUserOofSettingsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetUserOofSettingsCompletedEventArgs Properties

The properties of the SetUserOofSettingsCompletedEventArgs class are listed below. For a complete list of SetUserOofSettingsCompletedEventArgs class members, see the SetUserOofSettingsCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

SetUserOofSettingsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

SetUserOofSettingsCompletedEventArgs.Result Property

public SetUserOofSettingsResponse Result {get;}

Remarks

See Also

SetUserOofSettingsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetUserOofSettingsCompletedEventHandler Delegate

public delegate void SetUserOofSettingsCompletedEventHandler(
object sender,
SetUserOofSettingsCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetUserOofSettingsRequest Class

For a list of all members of this type, see SetUserOofSettingsRequest Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.SetUserOofSettingsRequest

public class SetUserOofSettingsRequest : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SetUserOofSettingsRequest Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetUserOofSettingsRequest Members

SetUserOofSettingsRequest overview

Public Instance Constructors

SetUserOofSettingsRequest Constructor Initializes a new instance of the SetUserOofSettingsRequest class.

Public Instance Properties

Mailbox
UserOofSettings

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SetUserOofSettingsRequest Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetUserOofSettingsRequest Constructor

Initializes a new instance of the SetUserOofSettingsRequest class.

public SetUserOofSettingsRequest();

See Also

SetUserOofSettingsRequest Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetUserOofSettingsRequest Properties

The properties of the SetUserOofSettingsRequest class are listed below. For a complete list of SetUserOofSettingsRequest class members, see the SetUserOofSettingsRequest Members topic.

Public Instance Properties

Mailbox
UserOofSettings

See Also

SetUserOofSettingsRequest Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Mailbox Property

Aspose.Email

SetUserOofSettingsRequest.Mailbox Property

public EmailAddress Mailbox {get; set;}

Remarks

See Also

SetUserOofSettingsRequest Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserOofSettings Property

Aspose.Email

SetUserOofSettingsRequest.UserOofSettings Property

public UserOofSettings UserOofSettings {get; set;}

Remarks

See Also

SetUserOofSettingsRequest Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetUserOofSettingsResponse Class

For a list of all members of this type, see SetUserOofSettingsResponse Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.SetUserOofSettingsResponse

public class SetUserOofSettingsResponse

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SetUserOofSettingsResponse Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetUserOofSettingsResponse Members

SetUserOofSettingsResponse overview

Public Instance Constructors

SetUserOofSettingsResponse Constructor Initializes a new instance of the SetUserOofSettingsResponse class.

Public Instance Properties

ResponseMessage

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SetUserOofSettingsResponse Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetUserOofSettingsResponse Constructor

Initializes a new instance of the SetUserOofSettingsResponse class.

public SetUserOofSettingsResponse();

See Also

SetUserOofSettingsResponse Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SetUserOofSettingsResponse Properties

The properties of the SetUserOofSettingsResponse class are listed below. For a complete list of SetUserOofSettingsResponse class members, see the SetUserOofSettingsResponse Members topic.

Public Instance Properties

ResponseMessage

See Also

SetUserOofSettingsResponse Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResponseMessage Property

Aspose.Email

SetUserOofSettingsResponse.ResponseMessage Property

public ResponseMessageType ResponseMessage {get; set;}

Remarks

See Also

SetUserOofSettingsResponse Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SharingDataType Enumeration

public enum SharingDataType

Remarks

Members

Member Name | Description | Value
Calendar |  | 0
Contacts |  | 1

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SingleRecipientType Class

For a list of all members of this type, see SingleRecipientType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.SingleRecipientType

public class SingleRecipientType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SingleRecipientType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SingleRecipientType Members

SingleRecipientType overview

Public Instance Constructors

SingleRecipientType Constructor Initializes a new instance of the SingleRecipientType class.

Public Instance Properties

Item

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SingleRecipientType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SingleRecipientType Constructor

Initializes a new instance of the SingleRecipientType class.

public SingleRecipientType();

See Also

SingleRecipientType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SingleRecipientType Properties

The properties of the SingleRecipientType class are listed below. For a complete list of SingleRecipientType class members, see the SingleRecipientType Members topic.

Public Instance Properties

Item

See Also

SingleRecipientType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Item Property

Aspose.Email

SingleRecipientType.Item Property

public EmailAddressType Item {get; set;}

Remarks

See Also

SingleRecipientType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SmartResponseBaseType Class

For a list of all members of this type, see SmartResponseBaseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ItemType
Aspose.Email.Exchange.Schema.Exchange_2013.MessageType
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseObjectCoreType
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseObjectType
Aspose.Email.Exchange.Schema.Exchange_2013.SmartResponseBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.SmartResponseType

public class SmartResponseBaseType : ResponseObjectType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SmartResponseBaseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SmartResponseBaseType Members

SmartResponseBaseType overview

Public Instance Constructors

SmartResponseBaseType Constructor Initializes a new instance of the SmartResponseBaseType class.

Public Instance Properties

ArchiveTag (inherited from ItemType)
Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
BlockStatus (inherited from ItemType)
BlockStatusSpecified (inherited from ItemType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
EntityExtractionResult (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
Flag (inherited from ItemType)
From (inherited from MessageType)
GroupingAction (inherited from ItemType)
GroupingActionSpecified (inherited from ItemType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBlockedImages (inherited from ItemType)
HasBlockedImagesSpecified (inherited from ItemType)
IconIndex (inherited from ItemType)
IconIndexSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InstanceKey (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
NextPredictedAction (inherited from ItemType)
NextPredictedActionSpecified (inherited from ItemType)
NormalizedBody (inherited from ItemType)
ObjectName (inherited from ResponseObjectType)
ParentFolderId (inherited from ItemType)
PolicyTag (inherited from ItemType)
Preview (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
ReferenceItemId (inherited from ResponseObjectCoreType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReminderNextTime (inherited from ItemType)
ReminderNextTimeSpecified (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
RetentionDate (inherited from ItemType)
RetentionDateSpecified (inherited from ItemType)
RightsManagementLicenseData (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
StoreEntryId (inherited from ItemType)
Subject (inherited from ItemType)
TextBody (inherited from ItemType)
ToRecipients (inherited from MessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SmartResponseBaseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SmartResponseBaseType Constructor

Initializes a new instance of the SmartResponseBaseType class.

public SmartResponseBaseType();

See Also

SmartResponseBaseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SmartResponseType Class

For a list of all members of this type, see SmartResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ItemType
Aspose.Email.Exchange.Schema.Exchange_2013.MessageType
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseObjectCoreType
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseObjectType
Aspose.Email.Exchange.Schema.Exchange_2013.SmartResponseBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.SmartResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.CancelCalendarItemType
Aspose.Email.Exchange.Schema.Exchange_2013.ForwardItemType
Aspose.Email.Exchange.Schema.Exchange_2013.ReplyAllToItemType
Aspose.Email.Exchange.Schema.Exchange_2013.ReplyToItemType

public class SmartResponseType : SmartResponseBaseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SmartResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SmartResponseType Members

SmartResponseType overview

Public Instance Constructors

SmartResponseType Constructor Initializes a new instance of the SmartResponseType class.

Public Instance Properties

ArchiveTag (inherited from ItemType)
Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
BlockStatus (inherited from ItemType)
BlockStatusSpecified (inherited from ItemType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
EntityExtractionResult (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
Flag (inherited from ItemType)
From (inherited from MessageType)
GroupingAction (inherited from ItemType)
GroupingActionSpecified (inherited from ItemType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBlockedImages (inherited from ItemType)
HasBlockedImagesSpecified (inherited from ItemType)
IconIndex (inherited from ItemType)
IconIndexSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InstanceKey (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
NewBodyContent
NextPredictedAction (inherited from ItemType)
NextPredictedActionSpecified (inherited from ItemType)
NormalizedBody (inherited from ItemType)
ObjectName (inherited from ResponseObjectType)
ParentFolderId (inherited from ItemType)
PolicyTag (inherited from ItemType)
Preview (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
ReferenceItemId (inherited from ResponseObjectCoreType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReminderNextTime (inherited from ItemType)
ReminderNextTimeSpecified (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
RetentionDate (inherited from ItemType)
RetentionDateSpecified (inherited from ItemType)
RightsManagementLicenseData (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
StoreEntryId (inherited from ItemType)
Subject (inherited from ItemType)
TextBody (inherited from ItemType)
ToRecipients (inherited from MessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SmartResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SmartResponseType Constructor

Initializes a new instance of the SmartResponseType class.

public SmartResponseType();

See Also

SmartResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SmartResponseType Properties

The properties of the SmartResponseType class are listed below. For a complete list of SmartResponseType class members, see the SmartResponseType Members topic.

Public Instance Properties

ArchiveTag (inherited from ItemType)
Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
BlockStatus (inherited from ItemType)
BlockStatusSpecified (inherited from ItemType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
EntityExtractionResult (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
Flag (inherited from ItemType)
From (inherited from MessageType)
GroupingAction (inherited from ItemType)
GroupingActionSpecified (inherited from ItemType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBlockedImages (inherited from ItemType)
HasBlockedImagesSpecified (inherited from ItemType)
IconIndex (inherited from ItemType)
IconIndexSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InstanceKey (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
NewBodyContent
NextPredictedAction (inherited from ItemType)
NextPredictedActionSpecified (inherited from ItemType)
NormalizedBody (inherited from ItemType)
ObjectName (inherited from ResponseObjectType)
ParentFolderId (inherited from ItemType)
PolicyTag (inherited from ItemType)
Preview (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
ReferenceItemId (inherited from ResponseObjectCoreType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReminderNextTime (inherited from ItemType)
ReminderNextTimeSpecified (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
RetentionDate (inherited from ItemType)
RetentionDateSpecified (inherited from ItemType)
RightsManagementLicenseData (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
StoreEntryId (inherited from ItemType)
Subject (inherited from ItemType)
TextBody (inherited from ItemType)
ToRecipients (inherited from MessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

See Also

SmartResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NewBodyContent Property

Aspose.Email

SmartResponseType.NewBodyContent Property

public BodyType NewBodyContent {get; set;}

Remarks

See Also

SmartResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SmtpDomain Class

For a list of all members of this type, see SmtpDomain Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.SmtpDomain

public class SmtpDomain

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SmtpDomain Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SmtpDomain Members

SmtpDomain overview

Public Instance Constructors

SmtpDomain Constructor Initializes a new instance of the SmtpDomain class.

Public Instance Properties

IncludeSubdomains
IncludeSubdomainsSpecified
Name

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SmtpDomain Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SmtpDomain Constructor

Initializes a new instance of the SmtpDomain class.

public SmtpDomain();

See Also

SmtpDomain Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SmtpDomain Properties

The properties of the SmtpDomain class are listed below. For a complete list of SmtpDomain class members, see the SmtpDomain Members topic.

Public Instance Properties

IncludeSubdomains
IncludeSubdomainsSpecified
Name

See Also

SmtpDomain Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IncludeSubdomains Property

Aspose.Email

SmtpDomain.IncludeSubdomains Property

public bool IncludeSubdomains {get; set;}

Remarks

See Also

SmtpDomain Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IncludeSubdomainsSpecified Property

Aspose.Email

SmtpDomain.IncludeSubdomainsSpecified Property

public bool IncludeSubdomainsSpecified {get; set;}

Remarks

See Also

SmtpDomain Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Name Property

Aspose.Email

SmtpDomain.Name Property

public string Name {get; set;}

Remarks

See Also

SmtpDomain Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SortDirectionType Enumeration

public enum SortDirectionType

Remarks

Members

Member Name | Description | Value
Ascending |  | 0
Descending |  | 1

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StandardGroupByType Enumeration

public enum StandardGroupByType

Remarks

Members

Member Name | Description | Value
ConversationTopic |  | 0

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StartFindInGALSpeechRecognitionResponseMessageType Class

For a list of all members of this type, see StartFindInGALSpeechRecognitionResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.StartFindInGALSpeechRecognitionResponseMessageType

public class StartFindInGALSpeechRecognitionResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

StartFindInGALSpeechRecognitionResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StartFindInGALSpeechRecognitionResponseMessageType Members

StartFindInGALSpeechRecognitionResponseMessageType overview

Public Instance Constructors

StartFindInGALSpeechRecognitionResponseMessageType Constructor Initializes a new instance of the StartFindInGALSpeechRecognitionResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
RecognitionId
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StartFindInGALSpeechRecognitionResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StartFindInGALSpeechRecognitionResponseMessageType Constructor

Initializes a new instance of the StartFindInGALSpeechRecognitionResponseMessageType class.

public StartFindInGALSpeechRecognitionResponseMessageType();

See Also

StartFindInGALSpeechRecognitionResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StartFindInGALSpeechRecognitionResponseMessageType Properties

The properties of the StartFindInGALSpeechRecognitionResponseMessageType class are listed below. For a complete list of StartFindInGALSpeechRecognitionResponseMessageType class members, see the StartFindInGALSpeechRecognitionResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
RecognitionId
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

StartFindInGALSpeechRecognitionResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RecognitionId Property

Aspose.Email

StartFindInGALSpeechRecognitionResponseMessageType.RecognitionId Property

public RecognitionIdType RecognitionId {get; set;}

Remarks

See Also

StartFindInGALSpeechRecognitionResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StartFindInGALSpeechRecognitionType Class

For a list of all members of this type, see StartFindInGALSpeechRecognitionType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.StartFindInGALSpeechRecognitionType

public class StartFindInGALSpeechRecognitionType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

StartFindInGALSpeechRecognitionType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StartFindInGALSpeechRecognitionType Members

StartFindInGALSpeechRecognitionType overview

Public Instance Constructors

StartFindInGALSpeechRecognitionType Constructor Initializes a new instance of the StartFindInGALSpeechRecognitionType class.

Public Instance Properties

Culture
TenantGuid
TimeZone
UserObjectGuid

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StartFindInGALSpeechRecognitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StartFindInGALSpeechRecognitionType Constructor

Initializes a new instance of the StartFindInGALSpeechRecognitionType class.

public StartFindInGALSpeechRecognitionType();

See Also

StartFindInGALSpeechRecognitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StartFindInGALSpeechRecognitionType Properties

The properties of the StartFindInGALSpeechRecognitionType class are listed below. For a complete list of StartFindInGALSpeechRecognitionType class members, see the StartFindInGALSpeechRecognitionType Members topic.

Public Instance Properties

Culture
TenantGuid
TimeZone
UserObjectGuid

See Also

StartFindInGALSpeechRecognitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Culture Property

Aspose.Email

StartFindInGALSpeechRecognitionType.Culture Property

public string Culture {get; set;}

Remarks

See Also

StartFindInGALSpeechRecognitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TenantGuid Property

Aspose.Email

StartFindInGALSpeechRecognitionType.TenantGuid Property

public string TenantGuid {get; set;}

Remarks

See Also

StartFindInGALSpeechRecognitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TimeZone Property

Aspose.Email

StartFindInGALSpeechRecognitionType.TimeZone Property

public string TimeZone {get; set;}

Remarks

See Also

StartFindInGALSpeechRecognitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserObjectGuid Property

Aspose.Email

StartFindInGALSpeechRecognitionType.UserObjectGuid Property

public string UserObjectGuid {get; set;}

Remarks

See Also

StartFindInGALSpeechRecognitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StreamingSubscriptionRequestType Class

For a list of all members of this type, see StreamingSubscriptionRequestType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.StreamingSubscriptionRequestType

public class StreamingSubscriptionRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

StreamingSubscriptionRequestType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StreamingSubscriptionRequestType Members

StreamingSubscriptionRequestType overview

Public Instance Constructors

StreamingSubscriptionRequestType Constructor Initializes a new instance of the StreamingSubscriptionRequestType class.

Public Instance Properties

EventTypes
FolderIds
SubscribeToAllFolders
SubscribeToAllFoldersSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StreamingSubscriptionRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StreamingSubscriptionRequestType Constructor

Initializes a new instance of the StreamingSubscriptionRequestType class.

public StreamingSubscriptionRequestType();

See Also

StreamingSubscriptionRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StreamingSubscriptionRequestType Properties

The properties of the StreamingSubscriptionRequestType class are listed below. For a complete list of StreamingSubscriptionRequestType class members, see the StreamingSubscriptionRequestType Members topic.

Public Instance Properties

EventTypes
FolderIds
SubscribeToAllFolders
SubscribeToAllFoldersSpecified

See Also

StreamingSubscriptionRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EventTypes Property

Aspose.Email

StreamingSubscriptionRequestType.EventTypes Property

public NotificationEventTypeType[] EventTypes {get; set;}

Remarks

See Also

StreamingSubscriptionRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FolderIds Property

Aspose.Email

StreamingSubscriptionRequestType.FolderIds Property

public BaseFolderIdType[] FolderIds {get; set;}

Remarks

See Also

StreamingSubscriptionRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SubscribeToAllFolders Property

Aspose.Email

StreamingSubscriptionRequestType.SubscribeToAllFolders Property

public bool SubscribeToAllFolders {get; set;}

Remarks

See Also

StreamingSubscriptionRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SubscribeToAllFoldersSpecified Property

Aspose.Email

StreamingSubscriptionRequestType.SubscribeToAllFoldersSpecified Property

public bool SubscribeToAllFoldersSpecified {get; set;}

Remarks

See Also

StreamingSubscriptionRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StringArrayAttributedValueType Class

For a list of all members of this type, see StringArrayAttributedValueType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.StringArrayAttributedValueType

public class StringArrayAttributedValueType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

StringArrayAttributedValueType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StringArrayAttributedValueType Members

StringArrayAttributedValueType overview

Public Instance Constructors

StringArrayAttributedValueType Constructor Initializes a new instance of the StringArrayAttributedValueType class.

Public Instance Properties

Attributions
Values

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StringArrayAttributedValueType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StringArrayAttributedValueType Constructor

Initializes a new instance of the StringArrayAttributedValueType class.

public StringArrayAttributedValueType();

See Also

StringArrayAttributedValueType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StringArrayAttributedValueType Properties

The properties of the StringArrayAttributedValueType class are listed below. For a complete list of StringArrayAttributedValueType class members, see the StringArrayAttributedValueType Members topic.

Public Instance Properties

Attributions
Values

See Also

StringArrayAttributedValueType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Attributions Property

Aspose.Email

StringArrayAttributedValueType.Attributions Property

public string[] Attributions {get; set;}

Remarks

See Also

StringArrayAttributedValueType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Values Property

Aspose.Email

StringArrayAttributedValueType.Values Property

public string[] Values {get; set;}

Remarks

See Also

StringArrayAttributedValueType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StringAttributedValueType Class

For a list of all members of this type, see StringAttributedValueType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.StringAttributedValueType

public class StringAttributedValueType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

StringAttributedValueType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StringAttributedValueType Members

StringAttributedValueType overview

Public Instance Constructors

StringAttributedValueType Constructor Initializes a new instance of the StringAttributedValueType class.

Public Instance Properties

Attributions
Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StringAttributedValueType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StringAttributedValueType Constructor

Initializes a new instance of the StringAttributedValueType class.

public StringAttributedValueType();

See Also

StringAttributedValueType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StringAttributedValueType Properties

The properties of the StringAttributedValueType class are listed below. For a complete list of StringAttributedValueType class members, see the StringAttributedValueType Members topic.

Public Instance Properties

Attributions
Value

See Also

StringAttributedValueType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Attributions Property

Aspose.Email

StringAttributedValueType.Attributions Property

public string[] Attributions {get; set;}

Remarks

See Also

StringAttributedValueType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Value Property

Aspose.Email

StringAttributedValueType.Value Property

public string Value {get; set;}

Remarks

See Also

StringAttributedValueType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SubscribeCompletedEventArgs Class

For a list of all members of this type, see SubscribeCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.SubscribeCompletedEventArgs

public class SubscribeCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SubscribeCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SubscribeCompletedEventArgs Members

SubscribeCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

SubscribeCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SubscribeCompletedEventArgs Properties

The properties of the SubscribeCompletedEventArgs class are listed below. For a complete list of SubscribeCompletedEventArgs class members, see the SubscribeCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

SubscribeCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

SubscribeCompletedEventArgs.Result Property

public SubscribeResponseType Result {get;}

Remarks

See Also

SubscribeCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SubscribeCompletedEventHandler Delegate

public delegate void SubscribeCompletedEventHandler(
object sender,
SubscribeCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SubscribeResponseMessageType Class

For a list of all members of this type, see SubscribeResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.SubscribeResponseMessageType

public class SubscribeResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SubscribeResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SubscribeResponseMessageType Members

SubscribeResponseMessageType overview

Public Instance Constructors

SubscribeResponseMessageType Constructor Initializes a new instance of the SubscribeResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
SubscriptionId
Watermark

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SubscribeResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SubscribeResponseMessageType Constructor

Initializes a new instance of the SubscribeResponseMessageType class.

public SubscribeResponseMessageType();

See Also

SubscribeResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SubscribeResponseMessageType Properties

The properties of the SubscribeResponseMessageType class are listed below. For a complete list of SubscribeResponseMessageType class members, see the SubscribeResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
SubscriptionId
Watermark

See Also

SubscribeResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SubscriptionId Property

Aspose.Email

SubscribeResponseMessageType.SubscriptionId Property

public string SubscriptionId {get; set;}

Remarks

See Also

SubscribeResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Watermark Property

Aspose.Email

SubscribeResponseMessageType.Watermark Property

public string Watermark {get; set;}

Remarks

See Also

SubscribeResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SubscribeResponseType Class

For a list of all members of this type, see SubscribeResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.SubscribeResponseType

public class SubscribeResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SubscribeResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SubscribeResponseType Members

SubscribeResponseType overview

Public Instance Constructors

SubscribeResponseType Constructor Initializes a new instance of the SubscribeResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SubscribeResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SubscribeResponseType Constructor

Initializes a new instance of the SubscribeResponseType class.

public SubscribeResponseType();

See Also

SubscribeResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SubscribeType Class

For a list of all members of this type, see SubscribeType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.SubscribeType

public class SubscribeType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SubscribeType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SubscribeType Members

SubscribeType overview

Public Instance Constructors

SubscribeType Constructor Initializes a new instance of the SubscribeType class.

Public Instance Properties

Item

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SubscribeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SubscribeType Constructor

Initializes a new instance of the SubscribeType class.

public SubscribeType();

See Also

SubscribeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SubscribeType Properties

The properties of the SubscribeType class are listed below. For a complete list of SubscribeType class members, see the SubscribeType Members topic.

Public Instance Properties

Item

See Also

SubscribeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Item Property

Aspose.Email

SubscribeType.Item Property

public object Item {get; set;}

Remarks

See Also

SubscribeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Suggestion Class

For a list of all members of this type, see Suggestion Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.Suggestion

public class Suggestion

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Suggestion Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Suggestion Members

Suggestion overview

Public Instance Constructors

Suggestion Constructor Initializes a new instance of the Suggestion class.

Public Instance Properties

AttendeeConflictDataArray
IsWorkTime
MeetingTime
SuggestionQuality

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Suggestion Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Suggestion Constructor

Initializes a new instance of the Suggestion class.

public Suggestion();

See Also

Suggestion Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Suggestion Properties

The properties of the Suggestion class are listed below. For a complete list of Suggestion class members, see the Suggestion Members topic.

Public Instance Properties

AttendeeConflictDataArray
IsWorkTime
MeetingTime
SuggestionQuality

See Also

Suggestion Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AttendeeConflictDataArray Property

Aspose.Email

Suggestion.AttendeeConflictDataArray Property

public AttendeeConflictData[] AttendeeConflictDataArray {get; set;}

Remarks

See Also

Suggestion Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsWorkTime Property

Aspose.Email

Suggestion.IsWorkTime Property

public bool IsWorkTime {get; set;}

Remarks

See Also

Suggestion Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MeetingTime Property

Aspose.Email

Suggestion.MeetingTime Property

public DateTime MeetingTime {get; set;}

Remarks

See Also

Suggestion Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SuggestionQuality Property

Aspose.Email

Suggestion.SuggestionQuality Property

public SuggestionQuality SuggestionQuality {get; set;}

Remarks

See Also

Suggestion Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SuggestionDayResult Class

For a list of all members of this type, see SuggestionDayResult Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.SuggestionDayResult

public class SuggestionDayResult

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SuggestionDayResult Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SuggestionDayResult Members

SuggestionDayResult overview

Public Instance Constructors

SuggestionDayResult Constructor Initializes a new instance of the SuggestionDayResult class.

Public Instance Properties

Date
DayQuality
SuggestionArray

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SuggestionDayResult Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SuggestionDayResult Constructor

Initializes a new instance of the SuggestionDayResult class.

public SuggestionDayResult();

See Also

SuggestionDayResult Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SuggestionDayResult Properties

The properties of the SuggestionDayResult class are listed below. For a complete list of SuggestionDayResult class members, see the SuggestionDayResult Members topic.

Public Instance Properties

Date
DayQuality
SuggestionArray

See Also

SuggestionDayResult Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Date Property

Aspose.Email

SuggestionDayResult.Date Property

public DateTime Date {get; set;}

Remarks

See Also

SuggestionDayResult Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DayQuality Property

Aspose.Email

SuggestionDayResult.DayQuality Property

public SuggestionQuality DayQuality {get; set;}

Remarks

See Also

SuggestionDayResult Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SuggestionArray Property

Aspose.Email

SuggestionDayResult.SuggestionArray Property

public Suggestion[] SuggestionArray {get; set;}

Remarks

See Also

SuggestionDayResult Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SuggestionQuality Enumeration

public enum SuggestionQuality

Remarks

Members

Member Name | Description | Value
Excellent |  | 0
Good |  | 1
Fair |  | 2
Poor |  | 3

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SuggestionsResponseType Class

For a list of all members of this type, see SuggestionsResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.SuggestionsResponseType

public class SuggestionsResponseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SuggestionsResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SuggestionsResponseType Members

SuggestionsResponseType overview

Public Instance Constructors

SuggestionsResponseType Constructor Initializes a new instance of the SuggestionsResponseType class.

Public Instance Properties

ResponseMessage
SuggestionDayResultArray

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SuggestionsResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SuggestionsResponseType Constructor

Initializes a new instance of the SuggestionsResponseType class.

public SuggestionsResponseType();

See Also

SuggestionsResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SuggestionsResponseType Properties

The properties of the SuggestionsResponseType class are listed below. For a complete list of SuggestionsResponseType class members, see the SuggestionsResponseType Members topic.

Public Instance Properties

ResponseMessage
SuggestionDayResultArray

See Also

SuggestionsResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResponseMessage Property

Aspose.Email

SuggestionsResponseType.ResponseMessage Property

public ResponseMessageType ResponseMessage {get; set;}

Remarks

See Also

SuggestionsResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SuggestionDayResultArray Property

Aspose.Email

SuggestionsResponseType.SuggestionDayResultArray Property

public SuggestionDayResult[] SuggestionDayResultArray {get; set;}

Remarks

See Also

SuggestionsResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SuggestionsViewOptionsType Class

For a list of all members of this type, see SuggestionsViewOptionsType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.SuggestionsViewOptionsType

public class SuggestionsViewOptionsType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SuggestionsViewOptionsType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SuggestionsViewOptionsType Members

SuggestionsViewOptionsType overview

Public Instance Constructors

SuggestionsViewOptionsType Constructor Initializes a new instance of the SuggestionsViewOptionsType class.

Public Instance Properties

CurrentMeetingTime
CurrentMeetingTimeSpecified
DetailedSuggestionsWindow
GlobalObjectId
GoodThreshold
GoodThresholdSpecified
MaximumNonWorkHourResultsByDay
MaximumNonWorkHourResultsByDaySpecified
MaximumResultsByDay
MaximumResultsByDaySpecified
MeetingDurationInMinutes
MeetingDurationInMinutesSpecified
MinimumSuggestionQuality
MinimumSuggestionQualitySpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SuggestionsViewOptionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SuggestionsViewOptionsType Constructor

Initializes a new instance of the SuggestionsViewOptionsType class.

public SuggestionsViewOptionsType();

See Also

SuggestionsViewOptionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SuggestionsViewOptionsType Properties

The properties of the SuggestionsViewOptionsType class are listed below. For a complete list of SuggestionsViewOptionsType class members, see the SuggestionsViewOptionsType Members topic.

Public Instance Properties

CurrentMeetingTime
CurrentMeetingTimeSpecified
DetailedSuggestionsWindow
GlobalObjectId
GoodThreshold
GoodThresholdSpecified
MaximumNonWorkHourResultsByDay
MaximumNonWorkHourResultsByDaySpecified
MaximumResultsByDay
MaximumResultsByDaySpecified
MeetingDurationInMinutes
MeetingDurationInMinutesSpecified
MinimumSuggestionQuality
MinimumSuggestionQualitySpecified

See Also

SuggestionsViewOptionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CurrentMeetingTime Property

Aspose.Email

SuggestionsViewOptionsType.CurrentMeetingTime Property

public DateTime CurrentMeetingTime {get; set;}

Remarks

See Also

SuggestionsViewOptionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CurrentMeetingTimeSpecified Property

Aspose.Email

SuggestionsViewOptionsType.CurrentMeetingTimeSpecified Property

public bool CurrentMeetingTimeSpecified {get; set;}

Remarks

See Also

SuggestionsViewOptionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DetailedSuggestionsWindow Property

Aspose.Email

SuggestionsViewOptionsType.DetailedSuggestionsWindow Property

public Duration DetailedSuggestionsWindow {get; set;}

Remarks

See Also

SuggestionsViewOptionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GlobalObjectId Property

Aspose.Email

SuggestionsViewOptionsType.GlobalObjectId Property

public string GlobalObjectId {get; set;}

Remarks

See Also

SuggestionsViewOptionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GoodThreshold Property

Aspose.Email

SuggestionsViewOptionsType.GoodThreshold Property

public int GoodThreshold {get; set;}

Remarks

See Also

SuggestionsViewOptionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


GoodThresholdSpecified Property

Aspose.Email

SuggestionsViewOptionsType.GoodThresholdSpecified Property

public bool GoodThresholdSpecified {get; set;}

Remarks

See Also

SuggestionsViewOptionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MaximumNonWorkHourResultsByDay Property

Aspose.Email

SuggestionsViewOptionsType.MaximumNonWorkHourResultsByDay Property

public int MaximumNonWorkHourResultsByDay {get; set;}

Remarks

See Also

SuggestionsViewOptionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MaximumNonWorkHourResultsByDaySpecified Property

Aspose.Email

SuggestionsViewOptionsType.MaximumNonWorkHourResultsByDaySpecified Property

public bool MaximumNonWorkHourResultsByDaySpecified {get; set;}

Remarks

See Also

SuggestionsViewOptionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MaximumResultsByDay Property

Aspose.Email

SuggestionsViewOptionsType.MaximumResultsByDay Property

public int MaximumResultsByDay {get; set;}

Remarks

See Also

SuggestionsViewOptionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MaximumResultsByDaySpecified Property

Aspose.Email

SuggestionsViewOptionsType.MaximumResultsByDaySpecified Property

public bool MaximumResultsByDaySpecified {get; set;}

Remarks

See Also

SuggestionsViewOptionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MeetingDurationInMinutes Property

Aspose.Email

SuggestionsViewOptionsType.MeetingDurationInMinutes Property

public int MeetingDurationInMinutes {get; set;}

Remarks

See Also

SuggestionsViewOptionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MeetingDurationInMinutesSpecified Property

Aspose.Email

SuggestionsViewOptionsType.MeetingDurationInMinutesSpecified Property

public bool MeetingDurationInMinutesSpecified {get; set;}

Remarks

See Also

SuggestionsViewOptionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MinimumSuggestionQuality Property

Aspose.Email

SuggestionsViewOptionsType.MinimumSuggestionQuality Property

public SuggestionQuality MinimumSuggestionQuality {get; set;}

Remarks

See Also

SuggestionsViewOptionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MinimumSuggestionQualitySpecified Property

Aspose.Email

SuggestionsViewOptionsType.MinimumSuggestionQualitySpecified Property

public bool MinimumSuggestionQualitySpecified {get; set;}

Remarks

See Also

SuggestionsViewOptionsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SuppressReadReceiptType Class

For a list of all members of this type, see SuppressReadReceiptType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ItemType
Aspose.Email.Exchange.Schema.Exchange_2013.MessageType
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseObjectCoreType
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseObjectType
Aspose.Email.Exchange.Schema.Exchange_2013.ReferenceItemResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.SuppressReadReceiptType

public class SuppressReadReceiptType : ReferenceItemResponseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SuppressReadReceiptType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SuppressReadReceiptType Members

SuppressReadReceiptType overview

Public Instance Constructors

SuppressReadReceiptType Constructor Initializes a new instance of the SuppressReadReceiptType class.

Public Instance Properties

ArchiveTag (inherited from ItemType)
Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
BlockStatus (inherited from ItemType)
BlockStatusSpecified (inherited from ItemType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
EntityExtractionResult (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
Flag (inherited from ItemType)
From (inherited from MessageType)
GroupingAction (inherited from ItemType)
GroupingActionSpecified (inherited from ItemType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBlockedImages (inherited from ItemType)
HasBlockedImagesSpecified (inherited from ItemType)
IconIndex (inherited from ItemType)
IconIndexSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InstanceKey (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
NextPredictedAction (inherited from ItemType)
NextPredictedActionSpecified (inherited from ItemType)
NormalizedBody (inherited from ItemType)
ObjectName (inherited from ResponseObjectType)
ParentFolderId (inherited from ItemType)
PolicyTag (inherited from ItemType)
Preview (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
ReferenceItemId (inherited from ResponseObjectCoreType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReminderNextTime (inherited from ItemType)
ReminderNextTimeSpecified (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
RetentionDate (inherited from ItemType)
RetentionDateSpecified (inherited from ItemType)
RightsManagementLicenseData (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
StoreEntryId (inherited from ItemType)
Subject (inherited from ItemType)
TextBody (inherited from ItemType)
ToRecipients (inherited from MessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SuppressReadReceiptType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SuppressReadReceiptType Constructor

Initializes a new instance of the SuppressReadReceiptType class.

public SuppressReadReceiptType();

See Also

SuppressReadReceiptType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderHierarchyChangesType Class

For a list of all members of this type, see SyncFolderHierarchyChangesType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.SyncFolderHierarchyChangesType

public class SyncFolderHierarchyChangesType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SyncFolderHierarchyChangesType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderHierarchyChangesType Members

SyncFolderHierarchyChangesType overview

Public Instance Constructors

SyncFolderHierarchyChangesType Constructor Initializes a new instance of the SyncFolderHierarchyChangesType class.

Public Instance Properties

Items
ItemsElementName

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyncFolderHierarchyChangesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderHierarchyChangesType Constructor

Initializes a new instance of the SyncFolderHierarchyChangesType class.

public SyncFolderHierarchyChangesType();

See Also

SyncFolderHierarchyChangesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderHierarchyChangesType Properties

The properties of the SyncFolderHierarchyChangesType class are listed below. For a complete list of SyncFolderHierarchyChangesType class members, see the SyncFolderHierarchyChangesType Members topic.

Public Instance Properties

Items
ItemsElementName

See Also

SyncFolderHierarchyChangesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Items Property

Aspose.Email

SyncFolderHierarchyChangesType.Items Property

public object[] Items {get; set;}

Remarks

See Also

SyncFolderHierarchyChangesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemsElementName Property

Aspose.Email

SyncFolderHierarchyChangesType.ItemsElementName Property

public ItemsChoiceType1[] ItemsElementName {get; set;}

Remarks

See Also

SyncFolderHierarchyChangesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderHierarchyCompletedEventArgs Class

For a list of all members of this type, see SyncFolderHierarchyCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.SyncFolderHierarchyCompletedEventArgs

public class SyncFolderHierarchyCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SyncFolderHierarchyCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderHierarchyCompletedEventArgs Members

SyncFolderHierarchyCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

SyncFolderHierarchyCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderHierarchyCompletedEventArgs Properties

The properties of the SyncFolderHierarchyCompletedEventArgs class are listed below. For a complete list of SyncFolderHierarchyCompletedEventArgs class members, see the SyncFolderHierarchyCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

SyncFolderHierarchyCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

SyncFolderHierarchyCompletedEventArgs.Result Property

public SyncFolderHierarchyResponseType Result {get;}

Remarks

See Also

SyncFolderHierarchyCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderHierarchyCompletedEventHandler Delegate

public delegate void SyncFolderHierarchyCompletedEventHandler(
object sender,
SyncFolderHierarchyCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderHierarchyCreateOrUpdateType Class

For a list of all members of this type, see SyncFolderHierarchyCreateOrUpdateType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.SyncFolderHierarchyCreateOrUpdateType

public class SyncFolderHierarchyCreateOrUpdateType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SyncFolderHierarchyCreateOrUpdateType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderHierarchyCreateOrUpdateType Members

SyncFolderHierarchyCreateOrUpdateType overview

Public Instance Constructors

SyncFolderHierarchyCreateOrUpdateType Constructor Initializes a new instance of the SyncFolderHierarchyCreateOrUpdateType class.

Public Instance Properties

Item

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyncFolderHierarchyCreateOrUpdateType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderHierarchyCreateOrUpdateType Constructor

Initializes a new instance of the SyncFolderHierarchyCreateOrUpdateType class.

public SyncFolderHierarchyCreateOrUpdateType();

See Also

SyncFolderHierarchyCreateOrUpdateType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderHierarchyCreateOrUpdateType Properties

The properties of the SyncFolderHierarchyCreateOrUpdateType class are listed below. For a complete list of SyncFolderHierarchyCreateOrUpdateType class members, see the SyncFolderHierarchyCreateOrUpdateType Members topic.

Public Instance Properties

Item

See Also

SyncFolderHierarchyCreateOrUpdateType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Item Property

Aspose.Email

SyncFolderHierarchyCreateOrUpdateType.Item Property

public BaseFolderType Item {get; set;}

Remarks

See Also

SyncFolderHierarchyCreateOrUpdateType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderHierarchyDeleteType Class

For a list of all members of this type, see SyncFolderHierarchyDeleteType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.SyncFolderHierarchyDeleteType

public class SyncFolderHierarchyDeleteType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SyncFolderHierarchyDeleteType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderHierarchyDeleteType Members

SyncFolderHierarchyDeleteType overview

Public Instance Constructors

SyncFolderHierarchyDeleteType Constructor Initializes a new instance of the SyncFolderHierarchyDeleteType class.

Public Instance Properties

FolderId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyncFolderHierarchyDeleteType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderHierarchyDeleteType Constructor

Initializes a new instance of the SyncFolderHierarchyDeleteType class.

public SyncFolderHierarchyDeleteType();

See Also

SyncFolderHierarchyDeleteType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderHierarchyDeleteType Properties

The properties of the SyncFolderHierarchyDeleteType class are listed below. For a complete list of SyncFolderHierarchyDeleteType class members, see the SyncFolderHierarchyDeleteType Members topic.

Public Instance Properties

FolderId

See Also

SyncFolderHierarchyDeleteType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FolderId Property

Aspose.Email

SyncFolderHierarchyDeleteType.FolderId Property

public FolderIdType FolderId {get; set;}

Remarks

See Also

SyncFolderHierarchyDeleteType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderHierarchyResponseMessageType Class

For a list of all members of this type, see SyncFolderHierarchyResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.SyncFolderHierarchyResponseMessageType

public class SyncFolderHierarchyResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SyncFolderHierarchyResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderHierarchyResponseMessageType Members

SyncFolderHierarchyResponseMessageType overview

Public Instance Constructors

SyncFolderHierarchyResponseMessageType Constructor Initializes a new instance of the SyncFolderHierarchyResponseMessageType class.

Public Instance Properties

Changes
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
IncludesLastFolderInRange
IncludesLastFolderInRangeSpecified
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
SyncState

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyncFolderHierarchyResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderHierarchyResponseMessageType Constructor

Initializes a new instance of the SyncFolderHierarchyResponseMessageType class.

public SyncFolderHierarchyResponseMessageType();

See Also

SyncFolderHierarchyResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderHierarchyResponseMessageType Properties

The properties of the SyncFolderHierarchyResponseMessageType class are listed below. For a complete list of SyncFolderHierarchyResponseMessageType class members, see the SyncFolderHierarchyResponseMessageType Members topic.

Public Instance Properties

Changes
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
IncludesLastFolderInRange
IncludesLastFolderInRangeSpecified
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
SyncState

See Also

SyncFolderHierarchyResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Changes Property

Aspose.Email

SyncFolderHierarchyResponseMessageType.Changes Property

public SyncFolderHierarchyChangesType Changes {get; set;}

Remarks

See Also

SyncFolderHierarchyResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IncludesLastFolderInRange Property

Aspose.Email

SyncFolderHierarchyResponseMessageType.IncludesLastFolderInRange Property

public bool IncludesLastFolderInRange {get; set;}

Remarks

See Also

SyncFolderHierarchyResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IncludesLastFolderInRangeSpecified Property

Aspose.Email

SyncFolderHierarchyResponseMessageType.IncludesLastFolderInRangeSpecified Property

public bool IncludesLastFolderInRangeSpecified {get; set;}

Remarks

See Also

SyncFolderHierarchyResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncState Property

Aspose.Email

SyncFolderHierarchyResponseMessageType.SyncState Property

public string SyncState {get; set;}

Remarks

See Also

SyncFolderHierarchyResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderHierarchyResponseType Class

For a list of all members of this type, see SyncFolderHierarchyResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.SyncFolderHierarchyResponseType

public class SyncFolderHierarchyResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SyncFolderHierarchyResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderHierarchyResponseType Members

SyncFolderHierarchyResponseType overview

Public Instance Constructors

SyncFolderHierarchyResponseType Constructor Initializes a new instance of the SyncFolderHierarchyResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyncFolderHierarchyResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderHierarchyResponseType Constructor

Initializes a new instance of the SyncFolderHierarchyResponseType class.

public SyncFolderHierarchyResponseType();

See Also

SyncFolderHierarchyResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderHierarchyType Class

For a list of all members of this type, see SyncFolderHierarchyType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.SyncFolderHierarchyType

public class SyncFolderHierarchyType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SyncFolderHierarchyType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderHierarchyType Members

SyncFolderHierarchyType overview

Public Instance Constructors

SyncFolderHierarchyType Constructor Initializes a new instance of the SyncFolderHierarchyType class.

Public Instance Properties

FolderShape
SyncFolderId
SyncState

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyncFolderHierarchyType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderHierarchyType Constructor

Initializes a new instance of the SyncFolderHierarchyType class.

public SyncFolderHierarchyType();

See Also

SyncFolderHierarchyType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderHierarchyType Properties

The properties of the SyncFolderHierarchyType class are listed below. For a complete list of SyncFolderHierarchyType class members, see the SyncFolderHierarchyType Members topic.

Public Instance Properties

FolderShape
SyncFolderId
SyncState

See Also

SyncFolderHierarchyType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FolderShape Property

Aspose.Email

SyncFolderHierarchyType.FolderShape Property

public FolderResponseShapeType FolderShape {get; set;}

Remarks

See Also

SyncFolderHierarchyType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderId Property

Aspose.Email

SyncFolderHierarchyType.SyncFolderId Property

public TargetFolderIdType SyncFolderId {get; set;}

Remarks

See Also

SyncFolderHierarchyType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncState Property

Aspose.Email

SyncFolderHierarchyType.SyncState Property

public string SyncState {get; set;}

Remarks

See Also

SyncFolderHierarchyType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderItemsChangesType Class

For a list of all members of this type, see SyncFolderItemsChangesType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.SyncFolderItemsChangesType

public class SyncFolderItemsChangesType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SyncFolderItemsChangesType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderItemsChangesType Members

SyncFolderItemsChangesType overview

Public Instance Constructors

SyncFolderItemsChangesType Constructor Initializes a new instance of the SyncFolderItemsChangesType class.

Public Instance Properties

Items
ItemsElementName

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyncFolderItemsChangesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderItemsChangesType Constructor

Initializes a new instance of the SyncFolderItemsChangesType class.

public SyncFolderItemsChangesType();

See Also

SyncFolderItemsChangesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderItemsChangesType Properties

The properties of the SyncFolderItemsChangesType class are listed below. For a complete list of SyncFolderItemsChangesType class members, see the SyncFolderItemsChangesType Members topic.

Public Instance Properties

Items
ItemsElementName

See Also

SyncFolderItemsChangesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Items Property

Aspose.Email

SyncFolderItemsChangesType.Items Property

public object[] Items {get; set;}

Remarks

See Also

SyncFolderItemsChangesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemsElementName Property

Aspose.Email

SyncFolderItemsChangesType.ItemsElementName Property

public ItemsChoiceType2[] ItemsElementName {get; set;}

Remarks

See Also

SyncFolderItemsChangesType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderItemsCompletedEventArgs Class

For a list of all members of this type, see SyncFolderItemsCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.SyncFolderItemsCompletedEventArgs

public class SyncFolderItemsCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SyncFolderItemsCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderItemsCompletedEventArgs Members

SyncFolderItemsCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

SyncFolderItemsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderItemsCompletedEventArgs Properties

The properties of the SyncFolderItemsCompletedEventArgs class are listed below. For a complete list of SyncFolderItemsCompletedEventArgs class members, see the SyncFolderItemsCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

SyncFolderItemsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

SyncFolderItemsCompletedEventArgs.Result Property

public SyncFolderItemsResponseType Result {get;}

Remarks

See Also

SyncFolderItemsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderItemsCompletedEventHandler Delegate

public delegate void SyncFolderItemsCompletedEventHandler(
object sender,
SyncFolderItemsCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderItemsCreateOrUpdateType Class

For a list of all members of this type, see SyncFolderItemsCreateOrUpdateType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.SyncFolderItemsCreateOrUpdateType

public class SyncFolderItemsCreateOrUpdateType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SyncFolderItemsCreateOrUpdateType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderItemsCreateOrUpdateType Members

SyncFolderItemsCreateOrUpdateType overview

Public Instance Constructors

SyncFolderItemsCreateOrUpdateType Constructor Initializes a new instance of the SyncFolderItemsCreateOrUpdateType class.

Public Instance Properties

Item

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyncFolderItemsCreateOrUpdateType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderItemsCreateOrUpdateType Constructor

Initializes a new instance of the SyncFolderItemsCreateOrUpdateType class.

public SyncFolderItemsCreateOrUpdateType();

See Also

SyncFolderItemsCreateOrUpdateType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderItemsCreateOrUpdateType Properties

The properties of the SyncFolderItemsCreateOrUpdateType class are listed below. For a complete list of SyncFolderItemsCreateOrUpdateType class members, see the SyncFolderItemsCreateOrUpdateType Members topic.

Public Instance Properties

Item

See Also

SyncFolderItemsCreateOrUpdateType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Item Property

Aspose.Email

SyncFolderItemsCreateOrUpdateType.Item Property

public ItemType Item {get; set;}

Remarks

See Also

SyncFolderItemsCreateOrUpdateType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderItemsDeleteType Class

For a list of all members of this type, see SyncFolderItemsDeleteType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.SyncFolderItemsDeleteType

public class SyncFolderItemsDeleteType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SyncFolderItemsDeleteType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderItemsDeleteType Members

SyncFolderItemsDeleteType overview

Public Instance Constructors

SyncFolderItemsDeleteType Constructor Initializes a new instance of the SyncFolderItemsDeleteType class.

Public Instance Properties

ItemId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyncFolderItemsDeleteType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderItemsDeleteType Constructor

Initializes a new instance of the SyncFolderItemsDeleteType class.

public SyncFolderItemsDeleteType();

See Also

SyncFolderItemsDeleteType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderItemsDeleteType Properties

The properties of the SyncFolderItemsDeleteType class are listed below. For a complete list of SyncFolderItemsDeleteType class members, see the SyncFolderItemsDeleteType Members topic.

Public Instance Properties

ItemId

See Also

SyncFolderItemsDeleteType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemId Property

Aspose.Email

SyncFolderItemsDeleteType.ItemId Property

public ItemIdType ItemId {get; set;}

Remarks

See Also

SyncFolderItemsDeleteType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderItemsReadFlagType Class

For a list of all members of this type, see SyncFolderItemsReadFlagType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.SyncFolderItemsReadFlagType

public class SyncFolderItemsReadFlagType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SyncFolderItemsReadFlagType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderItemsReadFlagType Members

SyncFolderItemsReadFlagType overview

Public Instance Constructors

SyncFolderItemsReadFlagType Constructor Initializes a new instance of the SyncFolderItemsReadFlagType class.

Public Instance Properties

IsRead
ItemId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyncFolderItemsReadFlagType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderItemsReadFlagType Constructor

Initializes a new instance of the SyncFolderItemsReadFlagType class.

public SyncFolderItemsReadFlagType();

See Also

SyncFolderItemsReadFlagType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderItemsReadFlagType Properties

The properties of the SyncFolderItemsReadFlagType class are listed below. For a complete list of SyncFolderItemsReadFlagType class members, see the SyncFolderItemsReadFlagType Members topic.

Public Instance Properties

IsRead
ItemId

See Also

SyncFolderItemsReadFlagType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsRead Property

Aspose.Email

SyncFolderItemsReadFlagType.IsRead Property

public bool IsRead {get; set;}

Remarks

See Also

SyncFolderItemsReadFlagType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemId Property

Aspose.Email

SyncFolderItemsReadFlagType.ItemId Property

public ItemIdType ItemId {get; set;}

Remarks

See Also

SyncFolderItemsReadFlagType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderItemsResponseMessageType Class

For a list of all members of this type, see SyncFolderItemsResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.SyncFolderItemsResponseMessageType

public class SyncFolderItemsResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SyncFolderItemsResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderItemsResponseMessageType Members

SyncFolderItemsResponseMessageType overview

Public Instance Constructors

SyncFolderItemsResponseMessageType Constructor Initializes a new instance of the SyncFolderItemsResponseMessageType class.

Public Instance Properties

Changes
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
IncludesLastItemInRange
IncludesLastItemInRangeSpecified
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
SyncState

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyncFolderItemsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderItemsResponseMessageType Constructor

Initializes a new instance of the SyncFolderItemsResponseMessageType class.

public SyncFolderItemsResponseMessageType();

See Also

SyncFolderItemsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderItemsResponseMessageType Properties

The properties of the SyncFolderItemsResponseMessageType class are listed below. For a complete list of SyncFolderItemsResponseMessageType class members, see the SyncFolderItemsResponseMessageType Members topic.

Public Instance Properties

Changes
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
IncludesLastItemInRange
IncludesLastItemInRangeSpecified
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
SyncState

See Also

SyncFolderItemsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Changes Property

Aspose.Email

SyncFolderItemsResponseMessageType.Changes Property

public SyncFolderItemsChangesType Changes {get; set;}

Remarks

See Also

SyncFolderItemsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IncludesLastItemInRange Property

Aspose.Email

SyncFolderItemsResponseMessageType.IncludesLastItemInRange Property

public bool IncludesLastItemInRange {get; set;}

Remarks

See Also

SyncFolderItemsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IncludesLastItemInRangeSpecified Property

Aspose.Email

SyncFolderItemsResponseMessageType.IncludesLastItemInRangeSpecified Property

public bool IncludesLastItemInRangeSpecified {get; set;}

Remarks

See Also

SyncFolderItemsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncState Property

Aspose.Email

SyncFolderItemsResponseMessageType.SyncState Property

public string SyncState {get; set;}

Remarks

See Also

SyncFolderItemsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderItemsResponseType Class

For a list of all members of this type, see SyncFolderItemsResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.SyncFolderItemsResponseType

public class SyncFolderItemsResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SyncFolderItemsResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderItemsResponseType Members

SyncFolderItemsResponseType overview

Public Instance Constructors

SyncFolderItemsResponseType Constructor Initializes a new instance of the SyncFolderItemsResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyncFolderItemsResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderItemsResponseType Constructor

Initializes a new instance of the SyncFolderItemsResponseType class.

public SyncFolderItemsResponseType();

See Also

SyncFolderItemsResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderItemsScopeType Enumeration

public enum SyncFolderItemsScopeType

Remarks

Members

Member Name | Description | Value
NormalItems |  | 0
NormalAndAssociatedItems |  | 1

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderItemsType Class

For a list of all members of this type, see SyncFolderItemsType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.SyncFolderItemsType

public class SyncFolderItemsType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SyncFolderItemsType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderItemsType Members

SyncFolderItemsType overview

Public Instance Constructors

SyncFolderItemsType Constructor Initializes a new instance of the SyncFolderItemsType class.

Public Instance Properties

Ignore
ItemShape
MaxChangesReturned
SyncFolderId
SyncScope
SyncScopeSpecified
SyncState

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyncFolderItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderItemsType Constructor

Initializes a new instance of the SyncFolderItemsType class.

public SyncFolderItemsType();

See Also

SyncFolderItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderItemsType Properties

The properties of the SyncFolderItemsType class are listed below. For a complete list of SyncFolderItemsType class members, see the SyncFolderItemsType Members topic.

Public Instance Properties

Ignore
ItemShape
MaxChangesReturned
SyncFolderId
SyncScope
SyncScopeSpecified
SyncState

See Also

SyncFolderItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Ignore Property

Aspose.Email

SyncFolderItemsType.Ignore Property

public ItemIdType[] Ignore {get; set;}

Remarks

See Also

SyncFolderItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemShape Property

Aspose.Email

SyncFolderItemsType.ItemShape Property

public ItemResponseShapeType ItemShape {get; set;}

Remarks

See Also

SyncFolderItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MaxChangesReturned Property

Aspose.Email

SyncFolderItemsType.MaxChangesReturned Property

public int MaxChangesReturned {get; set;}

Remarks

See Also

SyncFolderItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncFolderId Property

Aspose.Email

SyncFolderItemsType.SyncFolderId Property

public TargetFolderIdType SyncFolderId {get; set;}

Remarks

See Also

SyncFolderItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncScope Property

Aspose.Email

SyncFolderItemsType.SyncScope Property

public SyncFolderItemsScopeType SyncScope {get; set;}

Remarks

See Also

SyncFolderItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncScopeSpecified Property

Aspose.Email

SyncFolderItemsType.SyncScopeSpecified Property

public bool SyncScopeSpecified {get; set;}

Remarks

See Also

SyncFolderItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SyncState Property

Aspose.Email

SyncFolderItemsType.SyncState Property

public string SyncState {get; set;}

Remarks

See Also

SyncFolderItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TargetFolderIdType Class

For a list of all members of this type, see TargetFolderIdType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.TargetFolderIdType
Aspose.Email.Exchange.Schema.Exchange_2013.UserConfigurationNameType

public class TargetFolderIdType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

TargetFolderIdType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TargetFolderIdType Members

TargetFolderIdType overview

Public Instance Constructors

TargetFolderIdType Constructor Initializes a new instance of the TargetFolderIdType class.

Public Instance Properties

Item

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TargetFolderIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TargetFolderIdType Constructor

Initializes a new instance of the TargetFolderIdType class.

public TargetFolderIdType();

See Also

TargetFolderIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TargetFolderIdType Properties

The properties of the TargetFolderIdType class are listed below. For a complete list of TargetFolderIdType class members, see the TargetFolderIdType Members topic.

Public Instance Properties

Item

See Also

TargetFolderIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Item Property

Aspose.Email

TargetFolderIdType.Item Property

public BaseFolderIdType Item {get; set;}

Remarks

See Also

TargetFolderIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TaskDelegateStateType Enumeration

public enum TaskDelegateStateType

Remarks

Members

Member Name | Description | Value
NoMatch |  | 0
OwnNew |  | 1
Owned |  | 2
Accepted |  | 3
Declined |  | 4
Max |  | 5

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TaskRecurrenceType Class

For a list of all members of this type, see TaskRecurrenceType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.TaskRecurrenceType

public class TaskRecurrenceType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

TaskRecurrenceType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TaskRecurrenceType Members

TaskRecurrenceType overview

Public Instance Constructors

TaskRecurrenceType Constructor Initializes a new instance of the TaskRecurrenceType class.

Public Instance Properties

Item
Item1

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TaskRecurrenceType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TaskRecurrenceType Constructor

Initializes a new instance of the TaskRecurrenceType class.

public TaskRecurrenceType();

See Also

TaskRecurrenceType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TaskRecurrenceType Properties

The properties of the TaskRecurrenceType class are listed below. For a complete list of TaskRecurrenceType class members, see the TaskRecurrenceType Members topic.

Public Instance Properties

Item
Item1

See Also

TaskRecurrenceType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Item Property

Aspose.Email

TaskRecurrenceType.Item Property

public RecurrencePatternBaseType Item {get; set;}

Remarks

See Also

TaskRecurrenceType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Item1 Property

Aspose.Email

TaskRecurrenceType.Item1 Property

public RecurrenceRangeBaseType Item1 {get; set;}

Remarks

See Also

TaskRecurrenceType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TasksFolderType Class

For a list of all members of this type, see TasksFolderType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseFolderType
Aspose.Email.Exchange.Schema.Exchange_2013.FolderType
Aspose.Email.Exchange.Schema.Exchange_2013.TasksFolderType

public class TasksFolderType : FolderType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

TasksFolderType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TasksFolderType Members

TasksFolderType overview

Public Instance Constructors

TasksFolderType Constructor Initializes a new instance of the TasksFolderType class.

Public Instance Properties

ArchiveTag (inherited from BaseFolderType)
ChildFolderCount (inherited from BaseFolderType)
ChildFolderCountSpecified (inherited from BaseFolderType)
DisplayName (inherited from BaseFolderType)
DistinguishedFolderId (inherited from BaseFolderType)
DistinguishedFolderIdSpecified (inherited from BaseFolderType)
EffectiveRights (inherited from BaseFolderType)
ExtendedProperty (inherited from BaseFolderType)
FolderClass (inherited from BaseFolderType)
FolderId (inherited from BaseFolderType)
ManagedFolderInformation (inherited from BaseFolderType)
ParentFolderId (inherited from BaseFolderType)
PermissionSet (inherited from FolderType)
PolicyTag (inherited from BaseFolderType)
TotalCount (inherited from BaseFolderType)
TotalCountSpecified (inherited from BaseFolderType)
UnreadCount (inherited from FolderType)
UnreadCountSpecified (inherited from FolderType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TasksFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TasksFolderType Constructor

Initializes a new instance of the TasksFolderType class.

public TasksFolderType();

See Also

TasksFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TaskStatusType Enumeration

public enum TaskStatusType

Remarks

Members

Member Name | Description | Value
NotStarted |  | 0
InProgress |  | 1
Completed |  | 2
WaitingOnOthers |  | 3
Deferred |  | 4

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TaskSuggestionType Class

For a list of all members of this type, see TaskSuggestionType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.EntityType
Aspose.Email.Exchange.Schema.Exchange_2013.TaskSuggestionType

public class TaskSuggestionType : EntityType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

TaskSuggestionType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TaskSuggestionType Members

TaskSuggestionType overview

Public Instance Constructors

TaskSuggestionType Constructor Initializes a new instance of the TaskSuggestionType class.

Public Instance Properties

Assignees
Position (inherited from EntityType)
TaskString

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TaskSuggestionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TaskSuggestionType Constructor

Initializes a new instance of the TaskSuggestionType class.

public TaskSuggestionType();

See Also

TaskSuggestionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TaskSuggestionType Properties

The properties of the TaskSuggestionType class are listed below. For a complete list of TaskSuggestionType class members, see the TaskSuggestionType Members topic.

Public Instance Properties

Assignees
Position (inherited from EntityType)
TaskString

See Also

TaskSuggestionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Assignees Property

Aspose.Email

TaskSuggestionType.Assignees Property

public EmailUserType[] Assignees {get; set;}

Remarks

See Also

TaskSuggestionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TaskString Property

Aspose.Email

TaskSuggestionType.TaskString Property

public string TaskString {get; set;}

Remarks

See Also

TaskSuggestionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TaskType Class

For a list of all members of this type, see TaskType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ItemType
Aspose.Email.Exchange.Schema.Exchange_2013.TaskType

public class TaskType : ItemType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

TaskType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TaskType Members

TaskType overview

Public Instance Constructors

TaskType Constructor Initializes a new instance of the TaskType class.

Public Instance Properties

ActualWork
ActualWorkSpecified
ArchiveTag (inherited from ItemType)
AssignedTime
AssignedTimeSpecified
Attachments (inherited from ItemType)
BillingInformation
BlockStatus (inherited from ItemType)
BlockStatusSpecified (inherited from ItemType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
ChangeCount
ChangeCountSpecified
Companies
CompleteDate
CompleteDateSpecified
Contacts
ConversationId (inherited from ItemType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DelegationState
DelegationStateSpecified
Delegator
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
DueDate
DueDateSpecified
EffectiveRights (inherited from ItemType)
EntityExtractionResult (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
Flag (inherited from ItemType)
GroupingAction (inherited from ItemType)
GroupingActionSpecified (inherited from ItemType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBlockedImages (inherited from ItemType)
HasBlockedImagesSpecified (inherited from ItemType)
IconIndex (inherited from ItemType)
IconIndexSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InstanceKey (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
IsAssignmentEditable
IsAssignmentEditableSpecified
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsComplete
IsCompleteSpecified
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRecurring
IsRecurringSpecified
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsTeamTask
IsTeamTaskSpecified
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
Mileage
MimeContent (inherited from ItemType)
NextPredictedAction (inherited from ItemType)
NextPredictedActionSpecified (inherited from ItemType)
NormalizedBody (inherited from ItemType)
Owner
ParentFolderId (inherited from ItemType)
PercentComplete
PercentCompleteSpecified
PolicyTag (inherited from ItemType)
Preview (inherited from ItemType)
Recurrence
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReminderNextTime (inherited from ItemType)
ReminderNextTimeSpecified (inherited from ItemType)
ResponseObjects (inherited from ItemType)
RetentionDate (inherited from ItemType)
RetentionDateSpecified (inherited from ItemType)
RightsManagementLicenseData (inherited from ItemType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
StartDate
StartDateSpecified
Status
StatusDescription
StatusSpecified
StoreEntryId (inherited from ItemType)
Subject (inherited from ItemType)
TextBody (inherited from ItemType)
TotalWork
TotalWorkSpecified
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TaskType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TaskType Constructor

Initializes a new instance of the TaskType class.

public TaskType();

See Also

TaskType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TaskType Properties

The properties of the TaskType class are listed below. For a complete list of TaskType class members, see the TaskType Members topic.

Public Instance Properties

ActualWork
ActualWorkSpecified
ArchiveTag (inherited from ItemType)
AssignedTime
AssignedTimeSpecified
Attachments (inherited from ItemType)
BillingInformation
BlockStatus (inherited from ItemType)
BlockStatusSpecified (inherited from ItemType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
ChangeCount
ChangeCountSpecified
Companies
CompleteDate
CompleteDateSpecified
Contacts
ConversationId (inherited from ItemType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DelegationState
DelegationStateSpecified
Delegator
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
DueDate
DueDateSpecified
EffectiveRights (inherited from ItemType)
EntityExtractionResult (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
Flag (inherited from ItemType)
GroupingAction (inherited from ItemType)
GroupingActionSpecified (inherited from ItemType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBlockedImages (inherited from ItemType)
HasBlockedImagesSpecified (inherited from ItemType)
IconIndex (inherited from ItemType)
IconIndexSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InstanceKey (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
IsAssignmentEditable
IsAssignmentEditableSpecified
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsComplete
IsCompleteSpecified
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRecurring
IsRecurringSpecified
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsTeamTask
IsTeamTaskSpecified
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
Mileage
MimeContent (inherited from ItemType)
NextPredictedAction (inherited from ItemType)
NextPredictedActionSpecified (inherited from ItemType)
NormalizedBody (inherited from ItemType)
Owner
ParentFolderId (inherited from ItemType)
PercentComplete
PercentCompleteSpecified
PolicyTag (inherited from ItemType)
Preview (inherited from ItemType)
Recurrence
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReminderNextTime (inherited from ItemType)
ReminderNextTimeSpecified (inherited from ItemType)
ResponseObjects (inherited from ItemType)
RetentionDate (inherited from ItemType)
RetentionDateSpecified (inherited from ItemType)
RightsManagementLicenseData (inherited from ItemType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
StartDate
StartDateSpecified
Status
StatusDescription
StatusSpecified
StoreEntryId (inherited from ItemType)
Subject (inherited from ItemType)
TextBody (inherited from ItemType)
TotalWork
TotalWorkSpecified
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

See Also

TaskType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ActualWork Property

Aspose.Email

TaskType.ActualWork Property

public int ActualWork {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ActualWorkSpecified Property

Aspose.Email

TaskType.ActualWorkSpecified Property

public bool ActualWorkSpecified {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AssignedTime Property

Aspose.Email

TaskType.AssignedTime Property

public DateTime AssignedTime {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AssignedTimeSpecified Property

Aspose.Email

TaskType.AssignedTimeSpecified Property

public bool AssignedTimeSpecified {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BillingInformation Property

Aspose.Email

TaskType.BillingInformation Property

public string BillingInformation {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ChangeCount Property

Aspose.Email

TaskType.ChangeCount Property

public int ChangeCount {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ChangeCountSpecified Property

Aspose.Email

TaskType.ChangeCountSpecified Property

public bool ChangeCountSpecified {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Companies Property

Aspose.Email

TaskType.Companies Property

public string[] Companies {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CompleteDate Property

Aspose.Email

TaskType.CompleteDate Property

public DateTime CompleteDate {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CompleteDateSpecified Property

Aspose.Email

TaskType.CompleteDateSpecified Property

public bool CompleteDateSpecified {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Contacts Property

Aspose.Email

TaskType.Contacts Property

public string[] Contacts {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DelegationState Property

Aspose.Email

TaskType.DelegationState Property

public TaskDelegateStateType DelegationState {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DelegationStateSpecified Property

Aspose.Email

TaskType.DelegationStateSpecified Property

public bool DelegationStateSpecified {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Delegator Property

Aspose.Email

TaskType.Delegator Property

public string Delegator {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DueDate Property

Aspose.Email

TaskType.DueDate Property

public DateTime DueDate {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DueDateSpecified Property

Aspose.Email

TaskType.DueDateSpecified Property

public bool DueDateSpecified {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsAssignmentEditable Property

Aspose.Email

TaskType.IsAssignmentEditable Property

public int IsAssignmentEditable {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsAssignmentEditableSpecified Property

Aspose.Email

TaskType.IsAssignmentEditableSpecified Property

public bool IsAssignmentEditableSpecified {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsComplete Property

Aspose.Email

TaskType.IsComplete Property

public bool IsComplete {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsCompleteSpecified Property

Aspose.Email

TaskType.IsCompleteSpecified Property

public bool IsCompleteSpecified {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsRecurring Property

Aspose.Email

TaskType.IsRecurring Property

public bool IsRecurring {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsRecurringSpecified Property

Aspose.Email

TaskType.IsRecurringSpecified Property

public bool IsRecurringSpecified {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsTeamTask Property

Aspose.Email

TaskType.IsTeamTask Property

public bool IsTeamTask {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsTeamTaskSpecified Property

Aspose.Email

TaskType.IsTeamTaskSpecified Property

public bool IsTeamTaskSpecified {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Mileage Property

Aspose.Email

TaskType.Mileage Property

public string Mileage {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Owner Property

Aspose.Email

TaskType.Owner Property

public string Owner {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PercentComplete Property

Aspose.Email

TaskType.PercentComplete Property

public double PercentComplete {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PercentCompleteSpecified Property

Aspose.Email

TaskType.PercentCompleteSpecified Property

public bool PercentCompleteSpecified {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Recurrence Property

Aspose.Email

TaskType.Recurrence Property

public TaskRecurrenceType Recurrence {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StartDate Property

Aspose.Email

TaskType.StartDate Property

public DateTime StartDate {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StartDateSpecified Property

Aspose.Email

TaskType.StartDateSpecified Property

public bool StartDateSpecified {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Status Property

Aspose.Email

TaskType.Status Property

public TaskStatusType Status {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StatusDescription Property

Aspose.Email

TaskType.StatusDescription Property

public string StatusDescription {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StatusSpecified Property

Aspose.Email

TaskType.StatusSpecified Property

public bool StatusSpecified {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TotalWork Property

Aspose.Email

TaskType.TotalWork Property

public int TotalWork {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TotalWorkSpecified Property

Aspose.Email

TaskType.TotalWorkSpecified Property

public bool TotalWorkSpecified {get; set;}

Remarks

See Also

TaskType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TeamMailboxLifecycleStateType Enumeration

public enum TeamMailboxLifecycleStateType

Remarks

Members

Member Name | Description | Value
Active |  | 0
Closed |  | 1
Unlinked |  | 2
PendingDelete |  | 3

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TentativelyAcceptItemType Class

For a list of all members of this type, see TentativelyAcceptItemType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ItemType
Aspose.Email.Exchange.Schema.Exchange_2013.MessageType
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseObjectCoreType
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseObjectType
Aspose.Email.Exchange.Schema.Exchange_2013.WellKnownResponseObjectType
Aspose.Email.Exchange.Schema.Exchange_2013.TentativelyAcceptItemType

public class TentativelyAcceptItemType : WellKnownResponseObjectType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

TentativelyAcceptItemType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TentativelyAcceptItemType Members

TentativelyAcceptItemType overview

Public Instance Constructors

TentativelyAcceptItemType Constructor Initializes a new instance of the TentativelyAcceptItemType class.

Public Instance Properties

ArchiveTag (inherited from ItemType)
Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
BlockStatus (inherited from ItemType)
BlockStatusSpecified (inherited from ItemType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
EntityExtractionResult (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
Flag (inherited from ItemType)
From (inherited from MessageType)
GroupingAction (inherited from ItemType)
GroupingActionSpecified (inherited from ItemType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBlockedImages (inherited from ItemType)
HasBlockedImagesSpecified (inherited from ItemType)
IconIndex (inherited from ItemType)
IconIndexSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InstanceKey (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
NextPredictedAction (inherited from ItemType)
NextPredictedActionSpecified (inherited from ItemType)
NormalizedBody (inherited from ItemType)
ObjectName (inherited from ResponseObjectType)
ParentFolderId (inherited from ItemType)
PolicyTag (inherited from ItemType)
Preview (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
ReferenceItemId (inherited from ResponseObjectCoreType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReminderNextTime (inherited from ItemType)
ReminderNextTimeSpecified (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
RetentionDate (inherited from ItemType)
RetentionDateSpecified (inherited from ItemType)
RightsManagementLicenseData (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
StoreEntryId (inherited from ItemType)
Subject (inherited from ItemType)
TextBody (inherited from ItemType)
ToRecipients (inherited from MessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TentativelyAcceptItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TentativelyAcceptItemType Constructor

Initializes a new instance of the TentativelyAcceptItemType class.

public TentativelyAcceptItemType();

See Also

TentativelyAcceptItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TimeChangeType Class

For a list of all members of this type, see TimeChangeType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.TimeChangeType

public class TimeChangeType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

TimeChangeType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TimeChangeType Members

TimeChangeType overview

Public Instance Constructors

TimeChangeType Constructor Initializes a new instance of the TimeChangeType class.

Public Instance Properties

Item
Offset
Time
TimeZoneName

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TimeChangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TimeChangeType Constructor

Initializes a new instance of the TimeChangeType class.

public TimeChangeType();

See Also

TimeChangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TimeChangeType Properties

The properties of the TimeChangeType class are listed below. For a complete list of TimeChangeType class members, see the TimeChangeType Members topic.

Public Instance Properties

Item
Offset
Time
TimeZoneName

See Also

TimeChangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Item Property

Aspose.Email

TimeChangeType.Item Property

public object Item {get; set;}

Remarks

See Also

TimeChangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Offset Property

Aspose.Email

TimeChangeType.Offset Property

public string Offset {get; set;}

Remarks

See Also

TimeChangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Time Property

Aspose.Email

TimeChangeType.Time Property

public DateTime Time {get; set;}

Remarks

See Also

TimeChangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TimeZoneName Property

Aspose.Email

TimeChangeType.TimeZoneName Property

public string TimeZoneName {get; set;}

Remarks

See Also

TimeChangeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TimeZoneContextType Class

For a list of all members of this type, see TimeZoneContextType Members.

System.Object
System.Web.Services.Protocols.SoapHeader
Aspose.Email.Exchange.Schema.Exchange_2013.TimeZoneContextType

public class TimeZoneContextType : SoapHeader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

TimeZoneContextType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TimeZoneContextType Members

TimeZoneContextType overview

Public Instance Constructors

TimeZoneContextType Constructor Initializes a new instance of the TimeZoneContextType class.

Public Instance Properties

Actor (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.
AnyAttr |
DidUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether an XML Web service method properly processed a SOAP header.
EncodedMustUnderstand (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.1.
EncodedMustUnderstand12 (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.2.
EncodedRelay (inherited from SoapHeader) | Gets or sets the relay attribute of the SOAP 1.2 header.
MustUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether the SoapHeader must be understood.
Relay (inherited from SoapHeader) | Gets or sets a value that indicates whether the SOAP header is to be relayed to the next SOAP node if the current node does not understand the header.
Role (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.
TimeZoneDefinition |

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TimeZoneContextType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TimeZoneContextType Constructor

Initializes a new instance of the TimeZoneContextType class.

public TimeZoneContextType();

See Also

TimeZoneContextType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TimeZoneContextType Properties

The properties of the TimeZoneContextType class are listed below. For a complete list of TimeZoneContextType class members, see the TimeZoneContextType Members topic.

Public Instance Properties

Actor (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.
AnyAttr |
DidUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether an XML Web service method properly processed a SOAP header.
EncodedMustUnderstand (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.1.
EncodedMustUnderstand12 (inherited from SoapHeader) | Gets or sets the value of the mustUnderstand XML attribute for the SOAP header when communicating with SOAP protocol version 1.2.
EncodedRelay (inherited from SoapHeader) | Gets or sets the relay attribute of the SOAP 1.2 header.
MustUnderstand (inherited from SoapHeader) | Gets or sets a value indicating whether the SoapHeader must be understood.
Relay (inherited from SoapHeader) | Gets or sets a value that indicates whether the SOAP header is to be relayed to the next SOAP node if the current node does not understand the header.
Role (inherited from SoapHeader) | Gets or sets the recipient of the SOAP header.
TimeZoneDefinition |

See Also

TimeZoneContextType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AnyAttr Property

Aspose.Email

TimeZoneContextType.AnyAttr Property

public XmlAttribute[] AnyAttr {get; set;}

Remarks

See Also

TimeZoneContextType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TimeZoneDefinition Property

Aspose.Email

TimeZoneContextType.TimeZoneDefinition Property

public TimeZoneDefinitionType TimeZoneDefinition {get; set;}

Remarks

See Also

TimeZoneContextType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TimeZoneDefinitionType Class

For a list of all members of this type, see TimeZoneDefinitionType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.TimeZoneDefinitionType

public class TimeZoneDefinitionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

TimeZoneDefinitionType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TimeZoneDefinitionType Members

TimeZoneDefinitionType overview

Public Instance Constructors

TimeZoneDefinitionType Constructor Initializes a new instance of the TimeZoneDefinitionType class.

Public Instance Properties

Id
Name
Periods
Transitions
TransitionsGroups

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TimeZoneDefinitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TimeZoneDefinitionType Constructor

Initializes a new instance of the TimeZoneDefinitionType class.

public TimeZoneDefinitionType();

See Also

TimeZoneDefinitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TimeZoneDefinitionType Properties

The properties of the TimeZoneDefinitionType class are listed below. For a complete list of TimeZoneDefinitionType class members, see the TimeZoneDefinitionType Members topic.

Public Instance Properties

Id
Name
Periods
Transitions
TransitionsGroups

See Also

TimeZoneDefinitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Id Property

Aspose.Email

TimeZoneDefinitionType.Id Property

public string Id {get; set;}

Remarks

See Also

TimeZoneDefinitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Name Property

Aspose.Email

TimeZoneDefinitionType.Name Property

public string Name {get; set;}

Remarks

See Also

TimeZoneDefinitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Periods Property

Aspose.Email

TimeZoneDefinitionType.Periods Property

public PeriodType[] Periods {get; set;}

Remarks

See Also

TimeZoneDefinitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Transitions Property

Aspose.Email

TimeZoneDefinitionType.Transitions Property

public ArrayOfTransitionsType Transitions {get; set;}

Remarks

See Also

TimeZoneDefinitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TransitionsGroups Property

Aspose.Email

TimeZoneDefinitionType.TransitionsGroups Property

public ArrayOfTransitionsType[] TransitionsGroups {get; set;}

Remarks

See Also

TimeZoneDefinitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TimeZoneType Class

For a list of all members of this type, see TimeZoneType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.TimeZoneType

public class TimeZoneType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

TimeZoneType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TimeZoneType Members

TimeZoneType overview

Public Instance Constructors

TimeZoneType Constructor Initializes a new instance of the TimeZoneType class.

Public Instance Properties

BaseOffset
Daylight
Standard
TimeZoneName

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TimeZoneType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TimeZoneType Constructor

Initializes a new instance of the TimeZoneType class.

public TimeZoneType();

See Also

TimeZoneType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TimeZoneType Properties

The properties of the TimeZoneType class are listed below. For a complete list of TimeZoneType class members, see the TimeZoneType Members topic.

Public Instance Properties

BaseOffset
Daylight
Standard
TimeZoneName

See Also

TimeZoneType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseOffset Property

Aspose.Email

TimeZoneType.BaseOffset Property

public string BaseOffset {get; set;}

Remarks

See Also

TimeZoneType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Daylight Property

Aspose.Email

TimeZoneType.Daylight Property

public TimeChangeType Daylight {get; set;}

Remarks

See Also

TimeZoneType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Standard Property

Aspose.Email

TimeZoneType.Standard Property

public TimeChangeType Standard {get; set;}

Remarks

See Also

TimeZoneType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TimeZoneName Property

Aspose.Email

TimeZoneType.TimeZoneName Property

public string TimeZoneName {get; set;}

Remarks

See Also

TimeZoneType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TooBigGroupAttendeeConflictData Class

For a list of all members of this type, see TooBigGroupAttendeeConflictData Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.AttendeeConflictData
Aspose.Email.Exchange.Schema.Exchange_2013.TooBigGroupAttendeeConflictData

public class TooBigGroupAttendeeConflictData : AttendeeConflictData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

TooBigGroupAttendeeConflictData Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TooBigGroupAttendeeConflictData Members

TooBigGroupAttendeeConflictData overview

Public Instance Constructors

TooBigGroupAttendeeConflictData Constructor Initializes a new instance of the TooBigGroupAttendeeConflictData class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TooBigGroupAttendeeConflictData Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TooBigGroupAttendeeConflictData Constructor

Initializes a new instance of the TooBigGroupAttendeeConflictData class.

public TooBigGroupAttendeeConflictData();

See Also

TooBigGroupAttendeeConflictData Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TrackingPropertyType Class

For a list of all members of this type, see TrackingPropertyType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.TrackingPropertyType

public class TrackingPropertyType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

TrackingPropertyType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TrackingPropertyType Members

TrackingPropertyType overview

Public Instance Constructors

TrackingPropertyType Constructor Initializes a new instance of the TrackingPropertyType class.

Public Instance Properties

Name
Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TrackingPropertyType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TrackingPropertyType Constructor

Initializes a new instance of the TrackingPropertyType class.

public TrackingPropertyType();

See Also

TrackingPropertyType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TrackingPropertyType Properties

The properties of the TrackingPropertyType class are listed below. For a complete list of TrackingPropertyType class members, see the TrackingPropertyType Members topic.

Public Instance Properties

Name
Value

See Also

TrackingPropertyType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Name Property

Aspose.Email

TrackingPropertyType.Name Property

public string Name {get; set;}

Remarks

See Also

TrackingPropertyType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Value Property

Aspose.Email

TrackingPropertyType.Value Property

public string Value {get; set;}

Remarks

See Also

TrackingPropertyType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TransitionTargetKindType Enumeration

public enum TransitionTargetKindType

Remarks

Members

Member Name | Description | Value
Period |  | 0
Group |  | 1

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TransitionTargetType Class

For a list of all members of this type, see TransitionTargetType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.TransitionTargetType

public class TransitionTargetType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

TransitionTargetType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TransitionTargetType Members

TransitionTargetType overview

Public Instance Constructors

TransitionTargetType Constructor Initializes a new instance of the TransitionTargetType class.

Public Instance Properties

Kind
Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TransitionTargetType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TransitionTargetType Constructor

Initializes a new instance of the TransitionTargetType class.

public TransitionTargetType();

See Also

TransitionTargetType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TransitionTargetType Properties

The properties of the TransitionTargetType class are listed below. For a complete list of TransitionTargetType class members, see the TransitionTargetType Members topic.

Public Instance Properties

Kind
Value

See Also

TransitionTargetType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Kind Property

Aspose.Email

TransitionTargetType.Kind Property

public TransitionTargetKindType Kind {get; set;}

Remarks

See Also

TransitionTargetType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Value Property

Aspose.Email

TransitionTargetType.Value Property

public string Value {get; set;}

Remarks

See Also

TransitionTargetType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TransitionType Class

For a list of all members of this type, see TransitionType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.TransitionType
Aspose.Email.Exchange.Schema.Exchange_2013.AbsoluteDateTransitionType
Aspose.Email.Exchange.Schema.Exchange_2013.RecurringTimeTransitionType

public class TransitionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

TransitionType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TransitionType Members

TransitionType overview

Public Instance Constructors

TransitionType Constructor Initializes a new instance of the TransitionType class.

Public Instance Properties

To

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TransitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TransitionType Constructor

Initializes a new instance of the TransitionType class.

public TransitionType();

See Also

TransitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TransitionType Properties

The properties of the TransitionType class are listed below. For a complete list of TransitionType class members, see the TransitionType Members topic.

Public Instance Properties

To

See Also

TransitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


To Property

Aspose.Email

TransitionType.To Property

public TransitionTargetType To {get; set;}

Remarks

See Also

TransitionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TwoOperandExpressionType Class

For a list of all members of this type, see TwoOperandExpressionType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.SearchExpressionType
Aspose.Email.Exchange.Schema.Exchange_2013.TwoOperandExpressionType
Derived types

public abstract class TwoOperandExpressionType : SearchExpressionType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

TwoOperandExpressionType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TwoOperandExpressionType Members

TwoOperandExpressionType overview

Public Instance Properties

FieldURIOrConstant
Item

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

TwoOperandExpressionType Constructor Initializes a new instance of the TwoOperandExpressionType class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

TwoOperandExpressionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TwoOperandExpressionType Constructor

Initializes a new instance of the TwoOperandExpressionType class.

protected TwoOperandExpressionType();

See Also

TwoOperandExpressionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TwoOperandExpressionType Properties

The properties of the TwoOperandExpressionType class are listed below. For a complete list of TwoOperandExpressionType class members, see the TwoOperandExpressionType Members topic.

Public Instance Properties

FieldURIOrConstant
Item

See Also

TwoOperandExpressionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FieldURIOrConstant Property

Aspose.Email

TwoOperandExpressionType.FieldURIOrConstant Property

public FieldURIOrConstantType FieldURIOrConstant {get; set;}

Remarks

See Also

TwoOperandExpressionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Item Property

Aspose.Email

TwoOperandExpressionType.Item Property

public BasePathToElementType Item {get; set;}

Remarks

See Also

TwoOperandExpressionType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UMCDRFilterByType Enumeration

public enum UMCDRFilterByType

Remarks

Members

Member Name | Description | Value
FilterByUser |  | 0
FilterByDate |  | 1

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UMCDRGroupByType Enumeration

public enum UMCDRGroupByType

Remarks

Members

Member Name | Description | Value
Day |  | 0
Month |  | 1
Total |  | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UMMailboxTranscriptionEnabledSetting Enumeration

public enum UMMailboxTranscriptionEnabledSetting

Remarks

Members

Member Name | Description | Value
Disabled |  | 0
Enabled |  | 1
Unknown |  | 2

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UMReportAudioMetricsAverageCountersType Class

For a list of all members of this type, see UMReportAudioMetricsAverageCountersType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.UMReportAudioMetricsAverageCountersType

public class UMReportAudioMetricsAverageCountersType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UMReportAudioMetricsAverageCountersType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UMReportAudioMetricsAverageCountersType Members

UMReportAudioMetricsAverageCountersType overview

Public Instance Constructors

UMReportAudioMetricsAverageCountersType Constructor Initializes a new instance of the UMReportAudioMetricsAverageCountersType class.

Public Instance Properties

BurstLossDuration
Jitter
NMOS
NMOSDegradation
PercentPacketLoss
RoundTrip
TotalAudioQualityCallsSampled

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UMReportAudioMetricsAverageCountersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UMReportAudioMetricsAverageCountersType Constructor

Initializes a new instance of the UMReportAudioMetricsAverageCountersType class.

public UMReportAudioMetricsAverageCountersType();

See Also

UMReportAudioMetricsAverageCountersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UMReportAudioMetricsAverageCountersType Properties

The properties of the UMReportAudioMetricsAverageCountersType class are listed below. For a complete list of UMReportAudioMetricsAverageCountersType class members, see the UMReportAudioMetricsAverageCountersType Members topic.

Public Instance Properties

BurstLossDuration
Jitter
NMOS
NMOSDegradation
PercentPacketLoss
RoundTrip
TotalAudioQualityCallsSampled

See Also

UMReportAudioMetricsAverageCountersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BurstLossDuration Property

Aspose.Email

UMReportAudioMetricsAverageCountersType.BurstLossDuration Property

public AudioMetricsAverageType BurstLossDuration {get; set;}

Remarks

See Also

UMReportAudioMetricsAverageCountersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Jitter Property

Aspose.Email

UMReportAudioMetricsAverageCountersType.Jitter Property

public AudioMetricsAverageType Jitter {get; set;}

Remarks

See Also

UMReportAudioMetricsAverageCountersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NMOS Property

Aspose.Email

UMReportAudioMetricsAverageCountersType.NMOS Property

public AudioMetricsAverageType NMOS {get; set;}

Remarks

See Also

UMReportAudioMetricsAverageCountersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


NMOSDegradation Property

Aspose.Email

UMReportAudioMetricsAverageCountersType.NMOSDegradation Property

public AudioMetricsAverageType NMOSDegradation {get; set;}

Remarks

See Also

UMReportAudioMetricsAverageCountersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PercentPacketLoss Property

Aspose.Email

UMReportAudioMetricsAverageCountersType.PercentPacketLoss Property

public AudioMetricsAverageType PercentPacketLoss {get; set;}

Remarks

See Also

UMReportAudioMetricsAverageCountersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RoundTrip Property

Aspose.Email

UMReportAudioMetricsAverageCountersType.RoundTrip Property

public AudioMetricsAverageType RoundTrip {get; set;}

Remarks

See Also

UMReportAudioMetricsAverageCountersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TotalAudioQualityCallsSampled Property

Aspose.Email

UMReportAudioMetricsAverageCountersType.TotalAudioQualityCallsSampled Property

public long TotalAudioQualityCallsSampled {get; set;}

Remarks

See Also

UMReportAudioMetricsAverageCountersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UMReportRawCountersType Class

For a list of all members of this type, see UMReportRawCountersType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.UMReportRawCountersType

public class UMReportRawCountersType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UMReportRawCountersType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UMReportRawCountersType Members

UMReportRawCountersType overview

Public Instance Constructors

UMReportRawCountersType Constructor Initializes a new instance of the UMReportRawCountersType class.

Public Instance Properties

AudioMetricsAverages
AutoAttendantCalls
Date
FailedCalls
FaxCalls
MissedCalls
OtherCalls
OutboundCalls
SubscriberAccessCalls
TotalCalls
VoiceMailCalls

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UMReportRawCountersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UMReportRawCountersType Constructor

Initializes a new instance of the UMReportRawCountersType class.

public UMReportRawCountersType();

See Also

UMReportRawCountersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UMReportRawCountersType Properties

The properties of the UMReportRawCountersType class are listed below. For a complete list of UMReportRawCountersType class members, see the UMReportRawCountersType Members topic.

Public Instance Properties

AudioMetricsAverages
AutoAttendantCalls
Date
FailedCalls
FaxCalls
MissedCalls
OtherCalls
OutboundCalls
SubscriberAccessCalls
TotalCalls
VoiceMailCalls

See Also

UMReportRawCountersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AudioMetricsAverages Property

Aspose.Email

UMReportRawCountersType.AudioMetricsAverages Property

public UMReportAudioMetricsAverageCountersType AudioMetricsAverages {get; set;}

Remarks

See Also

UMReportRawCountersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


AutoAttendantCalls Property

Aspose.Email

UMReportRawCountersType.AutoAttendantCalls Property

public long AutoAttendantCalls {get; set;}

Remarks

See Also

UMReportRawCountersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Date Property

Aspose.Email

UMReportRawCountersType.Date Property

public DateTime Date {get; set;}

Remarks

See Also

UMReportRawCountersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FailedCalls Property

Aspose.Email

UMReportRawCountersType.FailedCalls Property

public long FailedCalls {get; set;}

Remarks

See Also

UMReportRawCountersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FaxCalls Property

Aspose.Email

UMReportRawCountersType.FaxCalls Property

public long FaxCalls {get; set;}

Remarks

See Also

UMReportRawCountersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MissedCalls Property

Aspose.Email

UMReportRawCountersType.MissedCalls Property

public long MissedCalls {get; set;}

Remarks

See Also

UMReportRawCountersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OtherCalls Property

Aspose.Email

UMReportRawCountersType.OtherCalls Property

public long OtherCalls {get; set;}

Remarks

See Also

UMReportRawCountersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OutboundCalls Property

Aspose.Email

UMReportRawCountersType.OutboundCalls Property

public long OutboundCalls {get; set;}

Remarks

See Also

UMReportRawCountersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SubscriberAccessCalls Property

Aspose.Email

UMReportRawCountersType.SubscriberAccessCalls Property

public long SubscriberAccessCalls {get; set;}

Remarks

See Also

UMReportRawCountersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TotalCalls Property

Aspose.Email

UMReportRawCountersType.TotalCalls Property

public long TotalCalls {get; set;}

Remarks

See Also

UMReportRawCountersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


VoiceMailCalls Property

Aspose.Email

UMReportRawCountersType.VoiceMailCalls Property

public long VoiceMailCalls {get; set;}

Remarks

See Also

UMReportRawCountersType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UnifiedMessageServiceConfiguration Class

For a list of all members of this type, see UnifiedMessageServiceConfiguration Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ServiceConfiguration
Aspose.Email.Exchange.Schema.Exchange_2013.UnifiedMessageServiceConfiguration

public class UnifiedMessageServiceConfiguration : ServiceConfiguration

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UnifiedMessageServiceConfiguration Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UnifiedMessageServiceConfiguration Members

UnifiedMessageServiceConfiguration overview

Public Instance Constructors

UnifiedMessageServiceConfiguration Constructor Initializes a new instance of the UnifiedMessageServiceConfiguration class.

Public Instance Properties

PlayOnPhoneDialString
PlayOnPhoneEnabled
UmEnabled

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UnifiedMessageServiceConfiguration Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UnifiedMessageServiceConfiguration Constructor

Initializes a new instance of the UnifiedMessageServiceConfiguration class.

public UnifiedMessageServiceConfiguration();

See Also

UnifiedMessageServiceConfiguration Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UnifiedMessageServiceConfiguration Properties

The properties of the UnifiedMessageServiceConfiguration class are listed below. For a complete list of UnifiedMessageServiceConfiguration class members, see the UnifiedMessageServiceConfiguration Members topic.

Public Instance Properties

PlayOnPhoneDialString
PlayOnPhoneEnabled
UmEnabled

See Also

UnifiedMessageServiceConfiguration Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PlayOnPhoneDialString Property

Aspose.Email

UnifiedMessageServiceConfiguration.PlayOnPhoneDialString Property

public string PlayOnPhoneDialString {get; set;}

Remarks

See Also

UnifiedMessageServiceConfiguration Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PlayOnPhoneEnabled Property

Aspose.Email

UnifiedMessageServiceConfiguration.PlayOnPhoneEnabled Property

public bool PlayOnPhoneEnabled {get; set;}

Remarks

See Also

UnifiedMessageServiceConfiguration Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UmEnabled Property

Aspose.Email

UnifiedMessageServiceConfiguration.UmEnabled Property

public bool UmEnabled {get; set;}

Remarks

See Also

UnifiedMessageServiceConfiguration Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UnindexedFieldURIType Enumeration

public enum UnindexedFieldURIType

Remarks

Members

Member Name | Description | Value
folderFolderId |  | 0
folderParentFolderId |  | 1
folderDisplayName |  | 2
folderUnreadCount |  | 3
folderTotalCount |  | 4
folderChildFolderCount |  | 5
folderFolderClass |  | 6
folderSearchParameters |  | 7
folderManagedFolderInformation |  | 8
folderPermissionSet |  | 9
folderEffectiveRights |  | 10
folderSharingEffectiveRights |  | 11
folderDistinguishedFolderId |  | 12
folderPolicyTag |  | 13
folderArchiveTag |  | 14
itemItemId |  | 15
itemParentFolderId |  | 16
itemItemClass |  | 17
itemMimeContent |  | 18
itemAttachments |  | 19
itemSubject |  | 20
itemDateTimeReceived |  | 21
itemSize |  | 22
itemCategories |  | 23
itemHasAttachments |  | 24
itemImportance |  | 25
itemInReplyTo |  | 26
itemInternetMessageHeaders |  | 27
itemIsAssociated |  | 28
itemIsDraft |  | 29
itemIsFromMe |  | 30
itemIsResend |  | 31
itemIsSubmitted |  | 32
itemIsUnmodified |  | 33
itemDateTimeSent |  | 34
itemDateTimeCreated |  | 35
itemBody |  | 36
itemResponseObjects |  | 37
itemSensitivity |  | 38
itemReminderDueBy |  | 39
itemReminderIsSet |  | 40
itemReminderNextTime |  | 41
itemReminderMinutesBeforeStart |  | 42
itemDisplayTo |  | 43
itemDisplayCc |  | 44
itemCulture |  | 45
itemEffectiveRights |  | 46
itemLastModifiedName |  | 47
itemLastModifiedTime |  | 48
itemConversationId |  | 49
itemUniqueBody |  | 50
itemFlag |  | 51
itemStoreEntryId |  | 52
itemInstanceKey |  | 53
itemNormalizedBody |  | 54
itemEntityExtractionResult |  | 55
itemPolicyTag |  | 56
itemArchiveTag |  | 57
itemRetentionDate |  | 58
itemPreview |  | 59
itemNextPredictedAction |  | 60
itemGroupingAction |  | 61
itemRightsManagementLicenseData |  | 62
itemBlockStatus |  | 63
itemHasBlockedImages |  | 64
itemWebClientReadFormQueryString |  | 65
itemWebClientEditFormQueryString |  | 66
itemTextBody |  | 67
itemIconIndex |  | 68
messageConversationIndex |  | 69
messageConversationTopic |  | 70
messageInternetMessageId |  | 71
messageIsRead |  | 72
messageIsResponseRequested |  | 73
messageIsReadReceiptRequested |  | 74
messageIsDeliveryReceiptRequested |  | 75
messageReceivedBy |  | 76
messageReceivedRepresenting |  | 77
messageReferences |  | 78
messageReplyTo |  | 79
messageFrom |  | 80
messageSender |  | 81
messageToRecipients |  | 82
messageCcRecipients |  | 83
messageBccRecipients |  | 84
meetingAssociatedCalendarItemId |  | 85
meetingIsDelegated |  | 86
meetingIsOutOfDate |  | 87
meetingHasBeenProcessed |  | 88
meetingResponseType |  | 89
meetingProposedStart |  | 90
meetingProposedEnd |  | 91
meetingRequestMeetingRequestType |  | 92
meetingRequestIntendedFreeBusyStatus |  | 93
meetingRequestChangeHighlights |  | 94
calendarStart |  | 95
calendarEnd |  | 96
calendarOriginalStart |  | 97
calendarStartWallClock |  | 98
calendarEndWallClock |  | 99
calendarStartTimeZoneId |  | 100
calendarEndTimeZoneId |  | 101
calendarIsAllDayEvent |  | 102
calendarLegacyFreeBusyStatus |  | 103
calendarLocation |  | 104
calendarEnhancedLocation |  | 105
calendarWhen |  | 106
calendarIsMeeting |  | 107
calendarIsCancelled |  | 108
calendarIsRecurring |  | 109
calendarMeetingRequestWasSent |  | 110
calendarIsResponseRequested |  | 111
calendarCalendarItemType |  | 112
calendarMyResponseType |  | 113
calendarOrganizer |  | 114
calendarRequiredAttendees |  | 115
calendarOptionalAttendees |  | 116
calendarResources |  | 117
calendarConflictingMeetingCount |  | 118
calendarAdjacentMeetingCount |  | 119
calendarConflictingMeetings |  | 120
calendarAdjacentMeetings |  | 121
calendarDuration |  | 122
calendarTimeZone |  | 123
calendarAppointmentReplyTime |  | 124
calendarAppointmentSequenceNumber |  | 125
calendarAppointmentState |  | 126
calendarRecurrence |  | 127
calendarFirstOccurrence |  | 128
calendarLastOccurrence |  | 129
calendarModifiedOccurrences |  | 130
calendarDeletedOccurrences |  | 131
calendarMeetingTimeZone |  | 132
calendarConferenceType |  | 133
calendarAllowNewTimeProposal |  | 134
calendarIsOnlineMeeting |  | 135
calendarMeetingWorkspaceUrl |  | 136
calendarNetShowUrl |  | 137
calendarUID |  | 138
calendarRecurrenceId |  | 139
calendarDateTimeStamp |  | 140
calendarStartTimeZone |  | 141
calendarEndTimeZone |  | 142
calendarJoinOnlineMeetingUrl |  | 143
calendarOnlineMeetingSettings |  | 144
calendarIsOrganizer |  | 145
taskActualWork |  | 146
taskAssignedTime |  | 147
taskBillingInformation |  | 148
taskChangeCount |  | 149
taskCompanies |  | 150
taskCompleteDate |  | 151
taskContacts |  | 152
taskDelegationState |  | 153
taskDelegator |  | 154
taskDueDate |  | 155
taskIsAssignmentEditable |  | 156
taskIsComplete |  | 157
taskIsRecurring |  | 158
taskIsTeamTask |  | 159
taskMileage |  | 160
taskOwner |  | 161
taskPercentComplete |  | 162
taskRecurrence |  | 163
taskStartDate |  | 164
taskStatus |  | 165
taskStatusDescription |  | 166
taskTotalWork |  | 167
contactsAlias |  | 168
contactsAssistantName |  | 169
contactsBirthday |  | 170
contactsBusinessHomePage |  | 171
contactsChildren |  | 172
contactsCompanies |  | 173
contactsCompanyName |  | 174
contactsCompleteName |  | 175
contactsContactSource |  | 176
contactsCulture |  | 177
contactsDepartment |  | 178
contactsDisplayName |  | 179
contactsDirectoryId |  | 180
contactsDirectReports |  | 181
contactsEmailAddresses |  | 182
contactsFileAs |  | 183
contactsFileAsMapping |  | 184
contactsGeneration |  | 185
contactsGivenName |  | 186
contactsImAddresses |  | 187
contactsInitials |  | 188
contactsJobTitle |  | 189
contactsManager |  | 190
contactsManagerMailbox |  | 191
contactsMiddleName |  | 192
contactsMileage |  | 193
contactsMSExchangeCertificate |  | 194
contactsNickname |  | 195
contactsNotes |  | 196
contactsOfficeLocation |  | 197
contactsPhoneNumbers |  | 198
contactsPhoneticFullName |  | 199
contactsPhoneticFirstName |  | 200
contactsPhoneticLastName |  | 201
contactsPhoto |  | 202
contactsPhysicalAddresses |  | 203
contactsPostalAddressIndex |  | 204
contactsProfession |  | 205
contactsSpouseName |  | 206
contactsSurname |  | 207
contactsWeddingAnniversary |  | 208
contactsUserSMIMECertificate |  | 209
contactsHasPicture |  | 210
distributionlistMembers |  | 211
postitemPostedTime |  | 212
conversationConversationId |  | 213
conversationConversationTopic |  | 214
conversationUniqueRecipients |  | 215
conversationGlobalUniqueRecipients |  | 216
conversationUniqueUnreadSenders |  | 217
conversationGlobalUniqueUnreadSenders |  | 218
conversationUniqueSenders |  | 219
conversationGlobalUniqueSenders |  | 220
conversationLastDeliveryTime |  | 221
conversationGlobalLastDeliveryTime |  | 222
conversationCategories |  | 223
conversationGlobalCategories |  | 224
conversationFlagStatus |  | 225
conversationGlobalFlagStatus |  | 226
conversationHasAttachments |  | 227
conversationGlobalHasAttachments |  | 228
conversationMessageCount |  | 229
conversationGlobalMessageCount |  | 230
conversationUnreadCount |  | 231
conversationGlobalUnreadCount |  | 232
conversationSize |  | 233
conversationGlobalSize |  | 234
conversationItemClasses |  | 235
conversationGlobalItemClasses |  | 236
conversationImportance |  | 237
conversationGlobalImportance |  | 238
conversationItemIds |  | 239
conversationGlobalItemIds |  | 240
conversationLastModifiedTime |  | 241
conversationInstanceKey |  | 242
conversationPreview |  | 243
conversationNextPredictedAction |  | 244
conversationGroupingAction |  | 245
conversationIconIndex |  | 246
conversationGlobalIconIndex |  | 247
conversationDraftItemIds |  | 248
personaPersonaId |  | 249
personaPersonaType |  | 250
personaGivenName |  | 251
personaCompanyName |  | 252
personaSurname |  | 253
personaDisplayName |  | 254
personaEmailAddress |  | 255
personaFileAs |  | 256
personaHomeCity |  | 257
personaCreationTime |  | 258
personaRelevanceScore |  | 259
personaWorkCity |  | 260
personaPersonaObjectStatus |  | 261
personaFileAsId |  | 262
personaDisplayNamePrefix |  | 263
personaYomiCompanyName |  | 264
personaYomiFirstName |  | 265
personaYomiLastName |  | 266
personaTitle |  | 267
personaEmailAddress1 |  | 268
personaEmailAddresses |  | 269
personaPhoneNumber |  | 270
personaImAddress |  | 271
personaImAddresses |  | 272
personaImAddresses2 |  | 273
personaImAddresses3 |  | 274
personaFolderIds |  | 275
personaAttributions |  | 276
personaDisplayNames |  | 277
personaInitials |  | 278
personaFileAses |  | 279
personaFileAsIds |  | 280
personaDisplayNamePrefixes |  | 281
personaGivenNames |  | 282
personaMiddleNames |  | 283
personaSurnames |  | 284
personaGenerations |  | 285
personaNicknames |  | 286
personaYomiCompanyNames |  | 287
personaYomiFirstNames |  | 288
personaYomiLastNames |  | 289
personaBusinessPhoneNumbers |  | 290
personaBusinessPhoneNumbers2 |  | 291
personaHomePhones |  | 292
personaHomePhones2 |  | 293
personaMobilePhones |  | 294
personaMobilePhones2 |  | 295
personaAssistantPhoneNumbers |  | 296
personaCallbackPhones |  | 297
personaCarPhones |  | 298
personaHomeFaxes |  | 299
personaOrganizationMainPhones |  | 300
personaOtherFaxes |  | 301
personaOtherTelephones |  | 302
personaOtherPhones2 |  | 303
personaPagers |  | 304
personaRadioPhones |  | 305
personaTelexNumbers |  | 306
personaWorkFaxes |  | 307
personaEmails1 |  | 308
personaEmails2 |  | 309
personaEmails3 |  | 310
personaBusinessHomePages |  | 311
personaSchool |  | 312
personaPersonalHomePages |  | 313
personaOfficeLocations |  | 314
personaBusinessAddresses |  | 315
personaHomeAddresses |  | 316
personaOtherAddresses |  | 317
personaTitles |  | 318
personaDepartments |  | 319
personaCompanyNames |  | 320
personaManagers |  | 321
personaAssistantNames |  | 322
personaProfessions |  | 323
personaSpouseNames |  | 324
personaHobbies |  | 325
personaWeddingAnniversaries |  | 326
personaBirthdays |  | 327
personaChildren |  | 328
personaLocations |  | 329
personaExtendedProperties |  | 330
personaPostalAddress |  | 331
personaBodies |  | 332

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UninstallAppCompletedEventArgs Class

For a list of all members of this type, see UninstallAppCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.UninstallAppCompletedEventArgs

public class UninstallAppCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UninstallAppCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UninstallAppCompletedEventArgs Members

UninstallAppCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

UninstallAppCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UninstallAppCompletedEventArgs Properties

The properties of the UninstallAppCompletedEventArgs class are listed below. For a complete list of UninstallAppCompletedEventArgs class members, see the UninstallAppCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

UninstallAppCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

UninstallAppCompletedEventArgs.Result Property

public UninstallAppResponseType Result {get;}

Remarks

See Also

UninstallAppCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UninstallAppCompletedEventHandler Delegate

public delegate void UninstallAppCompletedEventHandler(
object sender,
UninstallAppCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UninstallAppResponseType Class

For a list of all members of this type, see UninstallAppResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.UninstallAppResponseType

public class UninstallAppResponseType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UninstallAppResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UninstallAppResponseType Members

UninstallAppResponseType overview

Public Instance Constructors

UninstallAppResponseType Constructor Initializes a new instance of the UninstallAppResponseType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UninstallAppResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UninstallAppResponseType Constructor

Initializes a new instance of the UninstallAppResponseType class.

public UninstallAppResponseType();

See Also

UninstallAppResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UninstallAppType Class

For a list of all members of this type, see UninstallAppType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.UninstallAppType

public class UninstallAppType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UninstallAppType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UninstallAppType Members

UninstallAppType overview

Public Instance Constructors

UninstallAppType Constructor Initializes a new instance of the UninstallAppType class.

Public Instance Properties

ID

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UninstallAppType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UninstallAppType Constructor

Initializes a new instance of the UninstallAppType class.

public UninstallAppType();

See Also

UninstallAppType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UninstallAppType Properties

The properties of the UninstallAppType class are listed below. For a complete list of UninstallAppType class members, see the UninstallAppType Members topic.

Public Instance Properties

ID

See Also

UninstallAppType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ID Property

Aspose.Email

UninstallAppType.ID Property

public string ID {get; set;}

Remarks

See Also

UninstallAppType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UnknownAttendeeConflictData Class

For a list of all members of this type, see UnknownAttendeeConflictData Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.AttendeeConflictData
Aspose.Email.Exchange.Schema.Exchange_2013.UnknownAttendeeConflictData

public class UnknownAttendeeConflictData : AttendeeConflictData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UnknownAttendeeConflictData Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UnknownAttendeeConflictData Members

UnknownAttendeeConflictData overview

Public Instance Constructors

UnknownAttendeeConflictData Constructor Initializes a new instance of the UnknownAttendeeConflictData class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UnknownAttendeeConflictData Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UnknownAttendeeConflictData Constructor

Initializes a new instance of the UnknownAttendeeConflictData class.

public UnknownAttendeeConflictData();

See Also

UnknownAttendeeConflictData Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UnpinTeamMailboxCompletedEventArgs Class

For a list of all members of this type, see UnpinTeamMailboxCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.UnpinTeamMailboxCompletedEventArgs

public class UnpinTeamMailboxCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UnpinTeamMailboxCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UnpinTeamMailboxCompletedEventArgs Members

UnpinTeamMailboxCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

UnpinTeamMailboxCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UnpinTeamMailboxCompletedEventArgs Properties

The properties of the UnpinTeamMailboxCompletedEventArgs class are listed below. For a complete list of UnpinTeamMailboxCompletedEventArgs class members, see the UnpinTeamMailboxCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

UnpinTeamMailboxCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

UnpinTeamMailboxCompletedEventArgs.Result Property

public UnpinTeamMailboxResponseMessageType Result {get;}

Remarks

See Also

UnpinTeamMailboxCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UnpinTeamMailboxCompletedEventHandler Delegate

public delegate void UnpinTeamMailboxCompletedEventHandler(
object sender,
UnpinTeamMailboxCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UnpinTeamMailboxRequestType Class

For a list of all members of this type, see UnpinTeamMailboxRequestType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.UnpinTeamMailboxRequestType

public class UnpinTeamMailboxRequestType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UnpinTeamMailboxRequestType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UnpinTeamMailboxRequestType Members

UnpinTeamMailboxRequestType overview

Public Instance Constructors

UnpinTeamMailboxRequestType Constructor Initializes a new instance of the UnpinTeamMailboxRequestType class.

Public Instance Properties

EmailAddress

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UnpinTeamMailboxRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UnpinTeamMailboxRequestType Constructor

Initializes a new instance of the UnpinTeamMailboxRequestType class.

public UnpinTeamMailboxRequestType();

See Also

UnpinTeamMailboxRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UnpinTeamMailboxRequestType Properties

The properties of the UnpinTeamMailboxRequestType class are listed below. For a complete list of UnpinTeamMailboxRequestType class members, see the UnpinTeamMailboxRequestType Members topic.

Public Instance Properties

EmailAddress

See Also

UnpinTeamMailboxRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EmailAddress Property

Aspose.Email

UnpinTeamMailboxRequestType.EmailAddress Property

public EmailAddressType EmailAddress {get; set;}

Remarks

See Also

UnpinTeamMailboxRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UnpinTeamMailboxResponseMessageType Class

For a list of all members of this type, see UnpinTeamMailboxResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.UnpinTeamMailboxResponseMessageType

public class UnpinTeamMailboxResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UnpinTeamMailboxResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UnpinTeamMailboxResponseMessageType Members

UnpinTeamMailboxResponseMessageType overview

Public Instance Constructors

UnpinTeamMailboxResponseMessageType Constructor Initializes a new instance of the UnpinTeamMailboxResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UnpinTeamMailboxResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UnpinTeamMailboxResponseMessageType Constructor

Initializes a new instance of the UnpinTeamMailboxResponseMessageType class.

public UnpinTeamMailboxResponseMessageType();

See Also

UnpinTeamMailboxResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UnsubscribeCompletedEventArgs Class

For a list of all members of this type, see UnsubscribeCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.UnsubscribeCompletedEventArgs

public class UnsubscribeCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UnsubscribeCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UnsubscribeCompletedEventArgs Members

UnsubscribeCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

UnsubscribeCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UnsubscribeCompletedEventArgs Properties

The properties of the UnsubscribeCompletedEventArgs class are listed below. For a complete list of UnsubscribeCompletedEventArgs class members, see the UnsubscribeCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

UnsubscribeCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

UnsubscribeCompletedEventArgs.Result Property

public UnsubscribeResponseType Result {get;}

Remarks

See Also

UnsubscribeCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UnsubscribeCompletedEventHandler Delegate

public delegate void UnsubscribeCompletedEventHandler(
object sender,
UnsubscribeCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UnsubscribeResponseType Class

For a list of all members of this type, see UnsubscribeResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.UnsubscribeResponseType

public class UnsubscribeResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UnsubscribeResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UnsubscribeResponseType Members

UnsubscribeResponseType overview

Public Instance Constructors

UnsubscribeResponseType Constructor Initializes a new instance of the UnsubscribeResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UnsubscribeResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UnsubscribeResponseType Constructor

Initializes a new instance of the UnsubscribeResponseType class.

public UnsubscribeResponseType();

See Also

UnsubscribeResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UnsubscribeType Class

For a list of all members of this type, see UnsubscribeType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.UnsubscribeType

public class UnsubscribeType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UnsubscribeType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UnsubscribeType Members

UnsubscribeType overview

Public Instance Constructors

UnsubscribeType Constructor Initializes a new instance of the UnsubscribeType class.

Public Instance Properties

SubscriptionId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UnsubscribeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UnsubscribeType Constructor

Initializes a new instance of the UnsubscribeType class.

public UnsubscribeType();

See Also

UnsubscribeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UnsubscribeType Properties

The properties of the UnsubscribeType class are listed below. For a complete list of UnsubscribeType class members, see the UnsubscribeType Members topic.

Public Instance Properties

SubscriptionId

See Also

UnsubscribeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SubscriptionId Property

Aspose.Email

UnsubscribeType.SubscriptionId Property

public string SubscriptionId {get; set;}

Remarks

See Also

UnsubscribeType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateDelegateCompletedEventArgs Class

For a list of all members of this type, see UpdateDelegateCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateDelegateCompletedEventArgs

public class UpdateDelegateCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UpdateDelegateCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateDelegateCompletedEventArgs Members

UpdateDelegateCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

UpdateDelegateCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateDelegateCompletedEventArgs Properties

The properties of the UpdateDelegateCompletedEventArgs class are listed below. For a complete list of UpdateDelegateCompletedEventArgs class members, see the UpdateDelegateCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

UpdateDelegateCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

UpdateDelegateCompletedEventArgs.Result Property

public UpdateDelegateResponseMessageType Result {get;}

Remarks

See Also

UpdateDelegateCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateDelegateCompletedEventHandler Delegate

public delegate void UpdateDelegateCompletedEventHandler(
object sender,
UpdateDelegateCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateDelegateResponseMessageType Class

For a list of all members of this type, see UpdateDelegateResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.BaseDelegateResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateDelegateResponseMessageType

public class UpdateDelegateResponseMessageType : BaseDelegateResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UpdateDelegateResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateDelegateResponseMessageType Members

UpdateDelegateResponseMessageType overview

Public Instance Constructors

UpdateDelegateResponseMessageType Constructor Initializes a new instance of the UpdateDelegateResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
ResponseMessages (inherited from BaseDelegateResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UpdateDelegateResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateDelegateResponseMessageType Constructor

Initializes a new instance of the UpdateDelegateResponseMessageType class.

public UpdateDelegateResponseMessageType();

See Also

UpdateDelegateResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateDelegateType Class

For a list of all members of this type, see UpdateDelegateType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.BaseDelegateType
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateDelegateType

public class UpdateDelegateType : BaseDelegateType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UpdateDelegateType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateDelegateType Members

UpdateDelegateType overview

Public Instance Constructors

UpdateDelegateType Constructor Initializes a new instance of the UpdateDelegateType class.

Public Instance Properties

DelegateUsers
DeliverMeetingRequests
DeliverMeetingRequestsSpecified
Mailbox (inherited from BaseDelegateType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UpdateDelegateType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateDelegateType Constructor

Initializes a new instance of the UpdateDelegateType class.

public UpdateDelegateType();

See Also

UpdateDelegateType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateDelegateType Properties

The properties of the UpdateDelegateType class are listed below. For a complete list of UpdateDelegateType class members, see the UpdateDelegateType Members topic.

Public Instance Properties

DelegateUsers
DeliverMeetingRequests
DeliverMeetingRequestsSpecified
Mailbox (inherited from BaseDelegateType)

See Also

UpdateDelegateType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DelegateUsers Property

Aspose.Email

UpdateDelegateType.DelegateUsers Property

public DelegateUserType[] DelegateUsers {get; set;}

Remarks

See Also

UpdateDelegateType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeliverMeetingRequests Property

Aspose.Email

UpdateDelegateType.DeliverMeetingRequests Property

public DeliverMeetingRequestsType DeliverMeetingRequests {get; set;}

Remarks

See Also

UpdateDelegateType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DeliverMeetingRequestsSpecified Property

Aspose.Email

UpdateDelegateType.DeliverMeetingRequestsSpecified Property

public bool DeliverMeetingRequestsSpecified {get; set;}

Remarks

See Also

UpdateDelegateType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateFolderCompletedEventArgs Class

For a list of all members of this type, see UpdateFolderCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateFolderCompletedEventArgs

public class UpdateFolderCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UpdateFolderCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateFolderCompletedEventArgs Members

UpdateFolderCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

UpdateFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateFolderCompletedEventArgs Properties

The properties of the UpdateFolderCompletedEventArgs class are listed below. For a complete list of UpdateFolderCompletedEventArgs class members, see the UpdateFolderCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

UpdateFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

UpdateFolderCompletedEventArgs.Result Property

public UpdateFolderResponseType Result {get;}

Remarks

See Also

UpdateFolderCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateFolderCompletedEventHandler Delegate

public delegate void UpdateFolderCompletedEventHandler(
object sender,
UpdateFolderCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateFolderResponseType Class

For a list of all members of this type, see UpdateFolderResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateFolderResponseType

public class UpdateFolderResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UpdateFolderResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateFolderResponseType Members

UpdateFolderResponseType overview

Public Instance Constructors

UpdateFolderResponseType Constructor Initializes a new instance of the UpdateFolderResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UpdateFolderResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateFolderResponseType Constructor

Initializes a new instance of the UpdateFolderResponseType class.

public UpdateFolderResponseType();

See Also

UpdateFolderResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateFolderType Class

For a list of all members of this type, see UpdateFolderType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateFolderType

public class UpdateFolderType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UpdateFolderType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateFolderType Members

UpdateFolderType overview

Public Instance Constructors

UpdateFolderType Constructor Initializes a new instance of the UpdateFolderType class.

Public Instance Properties

FolderChanges

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UpdateFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateFolderType Constructor

Initializes a new instance of the UpdateFolderType class.

public UpdateFolderType();

See Also

UpdateFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateFolderType Properties

The properties of the UpdateFolderType class are listed below. For a complete list of UpdateFolderType class members, see the UpdateFolderType Members topic.

Public Instance Properties

FolderChanges

See Also

UpdateFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FolderChanges Property

Aspose.Email

UpdateFolderType.FolderChanges Property

public FolderChangeType[] FolderChanges {get; set;}

Remarks

See Also

UpdateFolderType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateInboxRulesCompletedEventArgs Class

For a list of all members of this type, see UpdateInboxRulesCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateInboxRulesCompletedEventArgs

public class UpdateInboxRulesCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UpdateInboxRulesCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateInboxRulesCompletedEventArgs Members

UpdateInboxRulesCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

UpdateInboxRulesCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateInboxRulesCompletedEventArgs Properties

The properties of the UpdateInboxRulesCompletedEventArgs class are listed below. For a complete list of UpdateInboxRulesCompletedEventArgs class members, see the UpdateInboxRulesCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

UpdateInboxRulesCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

UpdateInboxRulesCompletedEventArgs.Result Property

public UpdateInboxRulesResponseType Result {get;}

Remarks

See Also

UpdateInboxRulesCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateInboxRulesCompletedEventHandler Delegate

public delegate void UpdateInboxRulesCompletedEventHandler(
object sender,
UpdateInboxRulesCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateInboxRulesRequestType Class

For a list of all members of this type, see UpdateInboxRulesRequestType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateInboxRulesRequestType

public class UpdateInboxRulesRequestType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UpdateInboxRulesRequestType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateInboxRulesRequestType Members

UpdateInboxRulesRequestType overview

Public Instance Constructors

UpdateInboxRulesRequestType Constructor Initializes a new instance of the UpdateInboxRulesRequestType class.

Public Instance Properties

MailboxSmtpAddress
Operations
RemoveOutlookRuleBlob
RemoveOutlookRuleBlobSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UpdateInboxRulesRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateInboxRulesRequestType Constructor

Initializes a new instance of the UpdateInboxRulesRequestType class.

public UpdateInboxRulesRequestType();

See Also

UpdateInboxRulesRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateInboxRulesRequestType Properties

The properties of the UpdateInboxRulesRequestType class are listed below. For a complete list of UpdateInboxRulesRequestType class members, see the UpdateInboxRulesRequestType Members topic.

Public Instance Properties

MailboxSmtpAddress
Operations
RemoveOutlookRuleBlob
RemoveOutlookRuleBlobSpecified

See Also

UpdateInboxRulesRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MailboxSmtpAddress Property

Aspose.Email

UpdateInboxRulesRequestType.MailboxSmtpAddress Property

public string MailboxSmtpAddress {get; set;}

Remarks

See Also

UpdateInboxRulesRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Operations Property

Aspose.Email

UpdateInboxRulesRequestType.Operations Property

public RuleOperationType[] Operations {get; set;}

Remarks

See Also

UpdateInboxRulesRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveOutlookRuleBlob Property

Aspose.Email

UpdateInboxRulesRequestType.RemoveOutlookRuleBlob Property

public bool RemoveOutlookRuleBlob {get; set;}

Remarks

See Also

UpdateInboxRulesRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RemoveOutlookRuleBlobSpecified Property

Aspose.Email

UpdateInboxRulesRequestType.RemoveOutlookRuleBlobSpecified Property

public bool RemoveOutlookRuleBlobSpecified {get; set;}

Remarks

See Also

UpdateInboxRulesRequestType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateInboxRulesResponseType Class

For a list of all members of this type, see UpdateInboxRulesResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateInboxRulesResponseType

public class UpdateInboxRulesResponseType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UpdateInboxRulesResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateInboxRulesResponseType Members

UpdateInboxRulesResponseType overview

Public Instance Constructors

UpdateInboxRulesResponseType Constructor Initializes a new instance of the UpdateInboxRulesResponseType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
RuleOperationErrors

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UpdateInboxRulesResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateInboxRulesResponseType Constructor

Initializes a new instance of the UpdateInboxRulesResponseType class.

public UpdateInboxRulesResponseType();

See Also

UpdateInboxRulesResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateInboxRulesResponseType Properties

The properties of the UpdateInboxRulesResponseType class are listed below. For a complete list of UpdateInboxRulesResponseType class members, see the UpdateInboxRulesResponseType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)
RuleOperationErrors

See Also

UpdateInboxRulesResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


RuleOperationErrors Property

Aspose.Email

UpdateInboxRulesResponseType.RuleOperationErrors Property

public RuleOperationErrorType[] RuleOperationErrors {get; set;}

Remarks

See Also

UpdateInboxRulesResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateItemCompletedEventArgs Class

For a list of all members of this type, see UpdateItemCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateItemCompletedEventArgs

public class UpdateItemCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UpdateItemCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateItemCompletedEventArgs Members

UpdateItemCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

UpdateItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateItemCompletedEventArgs Properties

The properties of the UpdateItemCompletedEventArgs class are listed below. For a complete list of UpdateItemCompletedEventArgs class members, see the UpdateItemCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

UpdateItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

UpdateItemCompletedEventArgs.Result Property

public UpdateItemResponseType Result {get;}

Remarks

See Also

UpdateItemCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateItemCompletedEventHandler Delegate

public delegate void UpdateItemCompletedEventHandler(
object sender,
UpdateItemCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateItemInRecoverableItemsCompletedEventArgs Class

For a list of all members of this type, see UpdateItemInRecoverableItemsCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateItemInRecoverableItemsCompletedEventArgs

public class UpdateItemInRecoverableItemsCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UpdateItemInRecoverableItemsCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateItemInRecoverableItemsCompletedEventArgs Members

UpdateItemInRecoverableItemsCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

UpdateItemInRecoverableItemsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateItemInRecoverableItemsCompletedEventArgs Properties

The properties of the UpdateItemInRecoverableItemsCompletedEventArgs class are listed below. For a complete list of UpdateItemInRecoverableItemsCompletedEventArgs class members, see the UpdateItemInRecoverableItemsCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

UpdateItemInRecoverableItemsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

UpdateItemInRecoverableItemsCompletedEventArgs.Result Property

public UpdateItemInRecoverableItemsResponseType Result {get;}

Remarks

See Also

UpdateItemInRecoverableItemsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateItemInRecoverableItemsCompletedEventHandler Delegate

public delegate void UpdateItemInRecoverableItemsCompletedEventHandler(
object sender,
UpdateItemInRecoverableItemsCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateItemInRecoverableItemsResponseMessageType Class

For a list of all members of this type, see UpdateItemInRecoverableItemsResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.ItemInfoResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateItemInRecoverableItemsResponseMessageType

public class UpdateItemInRecoverableItemsResponseMessageType : ItemInfoResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UpdateItemInRecoverableItemsResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateItemInRecoverableItemsResponseMessageType Members

UpdateItemInRecoverableItemsResponseMessageType overview

Public Instance Constructors

UpdateItemInRecoverableItemsResponseMessageType Constructor Initializes a new instance of the UpdateItemInRecoverableItemsResponseMessageType class.

Public Instance Properties

Attachments
ConflictResults
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
Items (inherited from ItemInfoResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UpdateItemInRecoverableItemsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateItemInRecoverableItemsResponseMessageType Constructor

Initializes a new instance of the UpdateItemInRecoverableItemsResponseMessageType class.

public UpdateItemInRecoverableItemsResponseMessageType();

See Also

UpdateItemInRecoverableItemsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateItemInRecoverableItemsResponseMessageType Properties

The properties of the UpdateItemInRecoverableItemsResponseMessageType class are listed below. For a complete list of UpdateItemInRecoverableItemsResponseMessageType class members, see the UpdateItemInRecoverableItemsResponseMessageType Members topic.

Public Instance Properties

Attachments
ConflictResults
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
Items (inherited from ItemInfoResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

UpdateItemInRecoverableItemsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Attachments Property

Aspose.Email

UpdateItemInRecoverableItemsResponseMessageType.Attachments Property

public AttachmentType[] Attachments {get; set;}

Remarks

See Also

UpdateItemInRecoverableItemsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConflictResults Property

Aspose.Email

UpdateItemInRecoverableItemsResponseMessageType.ConflictResults Property

public ConflictResultsType ConflictResults {get; set;}

Remarks

See Also

UpdateItemInRecoverableItemsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateItemInRecoverableItemsResponseType Class

For a list of all members of this type, see UpdateItemInRecoverableItemsResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateItemInRecoverableItemsResponseType

public class UpdateItemInRecoverableItemsResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UpdateItemInRecoverableItemsResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateItemInRecoverableItemsResponseType Members

UpdateItemInRecoverableItemsResponseType overview

Public Instance Constructors

UpdateItemInRecoverableItemsResponseType Constructor Initializes a new instance of the UpdateItemInRecoverableItemsResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UpdateItemInRecoverableItemsResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateItemInRecoverableItemsResponseType Constructor

Initializes a new instance of the UpdateItemInRecoverableItemsResponseType class.

public UpdateItemInRecoverableItemsResponseType();

See Also

UpdateItemInRecoverableItemsResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateItemInRecoverableItemsType Class

For a list of all members of this type, see UpdateItemInRecoverableItemsType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateItemInRecoverableItemsType

public class UpdateItemInRecoverableItemsType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UpdateItemInRecoverableItemsType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateItemInRecoverableItemsType Members

UpdateItemInRecoverableItemsType overview

Public Instance Constructors

UpdateItemInRecoverableItemsType Constructor Initializes a new instance of the UpdateItemInRecoverableItemsType class.

Public Instance Properties

Attachments
ItemId
MakeItemImmutable
MakeItemImmutableSpecified
Updates

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UpdateItemInRecoverableItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateItemInRecoverableItemsType Constructor

Initializes a new instance of the UpdateItemInRecoverableItemsType class.

public UpdateItemInRecoverableItemsType();

See Also

UpdateItemInRecoverableItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateItemInRecoverableItemsType Properties

The properties of the UpdateItemInRecoverableItemsType class are listed below. For a complete list of UpdateItemInRecoverableItemsType class members, see the UpdateItemInRecoverableItemsType Members topic.

Public Instance Properties

Attachments
ItemId
MakeItemImmutable
MakeItemImmutableSpecified
Updates

See Also

UpdateItemInRecoverableItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Attachments Property

Aspose.Email

UpdateItemInRecoverableItemsType.Attachments Property

public AttachmentType[] Attachments {get; set;}

Remarks

See Also

UpdateItemInRecoverableItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemId Property

Aspose.Email

UpdateItemInRecoverableItemsType.ItemId Property

public ItemIdType ItemId {get; set;}

Remarks

See Also

UpdateItemInRecoverableItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MakeItemImmutable Property

Aspose.Email

UpdateItemInRecoverableItemsType.MakeItemImmutable Property

public bool MakeItemImmutable {get; set;}

Remarks

See Also

UpdateItemInRecoverableItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MakeItemImmutableSpecified Property

Aspose.Email

UpdateItemInRecoverableItemsType.MakeItemImmutableSpecified Property

public bool MakeItemImmutableSpecified {get; set;}

Remarks

See Also

UpdateItemInRecoverableItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Updates Property

Aspose.Email

UpdateItemInRecoverableItemsType.Updates Property

public ItemChangeDescriptionType[] Updates {get; set;}

Remarks

See Also

UpdateItemInRecoverableItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateItemResponseMessageType Class

For a list of all members of this type, see UpdateItemResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.ItemInfoResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateItemResponseMessageType

public class UpdateItemResponseMessageType : ItemInfoResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UpdateItemResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateItemResponseMessageType Members

UpdateItemResponseMessageType overview

Public Instance Constructors

UpdateItemResponseMessageType Constructor Initializes a new instance of the UpdateItemResponseMessageType class.

Public Instance Properties

ConflictResults
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
Items (inherited from ItemInfoResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UpdateItemResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateItemResponseMessageType Constructor

Initializes a new instance of the UpdateItemResponseMessageType class.

public UpdateItemResponseMessageType();

See Also

UpdateItemResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateItemResponseMessageType Properties

The properties of the UpdateItemResponseMessageType class are listed below. For a complete list of UpdateItemResponseMessageType class members, see the UpdateItemResponseMessageType Members topic.

Public Instance Properties

ConflictResults
DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
Items (inherited from ItemInfoResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

UpdateItemResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConflictResults Property

Aspose.Email

UpdateItemResponseMessageType.ConflictResults Property

public ConflictResultsType ConflictResults {get; set;}

Remarks

See Also

UpdateItemResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateItemResponseType Class

For a list of all members of this type, see UpdateItemResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateItemResponseType

public class UpdateItemResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UpdateItemResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateItemResponseType Members

UpdateItemResponseType overview

Public Instance Constructors

UpdateItemResponseType Constructor Initializes a new instance of the UpdateItemResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UpdateItemResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateItemResponseType Constructor

Initializes a new instance of the UpdateItemResponseType class.

public UpdateItemResponseType();

See Also

UpdateItemResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateItemType Class

For a list of all members of this type, see UpdateItemType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateItemType

public class UpdateItemType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UpdateItemType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateItemType Members

UpdateItemType overview

Public Instance Constructors

UpdateItemType Constructor Initializes a new instance of the UpdateItemType class.

Public Instance Properties

ConflictResolution
ItemChanges
MessageDisposition
MessageDispositionSpecified
SavedItemFolderId
SendMeetingInvitationsOrCancellations
SendMeetingInvitationsOrCancellationsSpecified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UpdateItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateItemType Constructor

Initializes a new instance of the UpdateItemType class.

public UpdateItemType();

See Also

UpdateItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateItemType Properties

The properties of the UpdateItemType class are listed below. For a complete list of UpdateItemType class members, see the UpdateItemType Members topic.

Public Instance Properties

ConflictResolution
ItemChanges
MessageDisposition
MessageDispositionSpecified
SavedItemFolderId
SendMeetingInvitationsOrCancellations
SendMeetingInvitationsOrCancellationsSpecified

See Also

UpdateItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ConflictResolution Property

Aspose.Email

UpdateItemType.ConflictResolution Property

public ConflictResolutionType ConflictResolution {get; set;}

Remarks

See Also

UpdateItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemChanges Property

Aspose.Email

UpdateItemType.ItemChanges Property

public ItemChangeType[] ItemChanges {get; set;}

Remarks

See Also

UpdateItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MessageDisposition Property

Aspose.Email

UpdateItemType.MessageDisposition Property

public MessageDispositionType MessageDisposition {get; set;}

Remarks

See Also

UpdateItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


MessageDispositionSpecified Property

Aspose.Email

UpdateItemType.MessageDispositionSpecified Property

public bool MessageDispositionSpecified {get; set;}

Remarks

See Also

UpdateItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SavedItemFolderId Property

Aspose.Email

UpdateItemType.SavedItemFolderId Property

public TargetFolderIdType SavedItemFolderId {get; set;}

Remarks

See Also

UpdateItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SendMeetingInvitationsOrCancellations Property

Aspose.Email

UpdateItemType.SendMeetingInvitationsOrCancellations Property

public CalendarItemUpdateOperationType SendMeetingInvitationsOrCancellations {get; set;}

Remarks

See Also

UpdateItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SendMeetingInvitationsOrCancellationsSpecified Property

Aspose.Email

UpdateItemType.SendMeetingInvitationsOrCancellationsSpecified Property

public bool SendMeetingInvitationsOrCancellationsSpecified {get; set;}

Remarks

See Also

UpdateItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateUserConfigurationCompletedEventArgs Class

For a list of all members of this type, see UpdateUserConfigurationCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateUserConfigurationCompletedEventArgs

public class UpdateUserConfigurationCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UpdateUserConfigurationCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateUserConfigurationCompletedEventArgs Members

UpdateUserConfigurationCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

UpdateUserConfigurationCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateUserConfigurationCompletedEventArgs Properties

The properties of the UpdateUserConfigurationCompletedEventArgs class are listed below. For a complete list of UpdateUserConfigurationCompletedEventArgs class members, see the UpdateUserConfigurationCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

UpdateUserConfigurationCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

UpdateUserConfigurationCompletedEventArgs.Result Property

public UpdateUserConfigurationResponseType Result {get;}

Remarks

See Also

UpdateUserConfigurationCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateUserConfigurationCompletedEventHandler Delegate

public delegate void UpdateUserConfigurationCompletedEventHandler(
object sender,
UpdateUserConfigurationCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateUserConfigurationResponseType Class

For a list of all members of this type, see UpdateUserConfigurationResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateUserConfigurationResponseType

public class UpdateUserConfigurationResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UpdateUserConfigurationResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateUserConfigurationResponseType Members

UpdateUserConfigurationResponseType overview

Public Instance Constructors

UpdateUserConfigurationResponseType Constructor Initializes a new instance of the UpdateUserConfigurationResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UpdateUserConfigurationResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateUserConfigurationResponseType Constructor

Initializes a new instance of the UpdateUserConfigurationResponseType class.

public UpdateUserConfigurationResponseType();

See Also

UpdateUserConfigurationResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateUserConfigurationType Class

For a list of all members of this type, see UpdateUserConfigurationType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateUserConfigurationType

public class UpdateUserConfigurationType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UpdateUserConfigurationType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateUserConfigurationType Members

UpdateUserConfigurationType overview

Public Instance Constructors

UpdateUserConfigurationType Constructor Initializes a new instance of the UpdateUserConfigurationType class.

Public Instance Properties

UserConfiguration

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UpdateUserConfigurationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateUserConfigurationType Constructor

Initializes a new instance of the UpdateUserConfigurationType class.

public UpdateUserConfigurationType();

See Also

UpdateUserConfigurationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UpdateUserConfigurationType Properties

The properties of the UpdateUserConfigurationType class are listed below. For a complete list of UpdateUserConfigurationType class members, see the UpdateUserConfigurationType Members topic.

Public Instance Properties

UserConfiguration

See Also

UpdateUserConfigurationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserConfiguration Property

Aspose.Email

UpdateUserConfigurationType.UserConfiguration Property

public UserConfigurationType UserConfiguration {get; set;}

Remarks

See Also

UpdateUserConfigurationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UploadItemsCompletedEventArgs Class

For a list of all members of this type, see UploadItemsCompletedEventArgs Members.

System.Object
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.UploadItemsCompletedEventArgs

public class UploadItemsCompletedEventArgs : AsyncCompletedEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UploadItemsCompletedEventArgs Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UploadItemsCompletedEventArgs Members

UploadItemsCompletedEventArgs overview

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RaiseExceptionIfNecessary (inherited from AsyncCompletedEventArgs) | Raises a user-supplied exception if an asynchronous operation failed.

See Also

UploadItemsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UploadItemsCompletedEventArgs Properties

The properties of the UploadItemsCompletedEventArgs class are listed below. For a complete list of UploadItemsCompletedEventArgs class members, see the UploadItemsCompletedEventArgs Members topic.

Public Instance Properties

Cancelled (inherited from AsyncCompletedEventArgs) | Gets a value indicating whether an asynchronous operation has been canceled.
Error (inherited from AsyncCompletedEventArgs) | Gets a value indicating which error occurred during an asynchronous operation.
Result |
UserState (inherited from AsyncCompletedEventArgs) | Gets the unique identifier for the asynchronous task.

See Also

UploadItemsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Result Property

Aspose.Email

UploadItemsCompletedEventArgs.Result Property

public UploadItemsResponseType Result {get;}

Remarks

See Also

UploadItemsCompletedEventArgs Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UploadItemsCompletedEventHandler Delegate

public delegate void UploadItemsCompletedEventHandler(
object sender,
UploadItemsCompletedEventArgs e
);

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UploadItemsResponseMessageType Class

For a list of all members of this type, see UploadItemsResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.UploadItemsResponseMessageType

public class UploadItemsResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UploadItemsResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UploadItemsResponseMessageType Members

UploadItemsResponseMessageType overview

Public Instance Constructors

UploadItemsResponseMessageType Constructor Initializes a new instance of the UploadItemsResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
ItemId
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UploadItemsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UploadItemsResponseMessageType Constructor

Initializes a new instance of the UploadItemsResponseMessageType class.

public UploadItemsResponseMessageType();

See Also

UploadItemsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UploadItemsResponseMessageType Properties

The properties of the UploadItemsResponseMessageType class are listed below. For a complete list of UploadItemsResponseMessageType class members, see the UploadItemsResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
ItemId
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

UploadItemsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemId Property

Aspose.Email

UploadItemsResponseMessageType.ItemId Property

public ItemIdType ItemId {get; set;}

Remarks

See Also

UploadItemsResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UploadItemsResponseType Class

For a list of all members of this type, see UploadItemsResponseType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.UploadItemsResponseType

public class UploadItemsResponseType : BaseResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UploadItemsResponseType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UploadItemsResponseType Members

UploadItemsResponseType overview

Public Instance Constructors

UploadItemsResponseType Constructor Initializes a new instance of the UploadItemsResponseType class.

Public Instance Properties

ResponseMessages (inherited from BaseResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UploadItemsResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UploadItemsResponseType Constructor

Initializes a new instance of the UploadItemsResponseType class.

public UploadItemsResponseType();

See Also

UploadItemsResponseType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UploadItemsType Class

For a list of all members of this type, see UploadItemsType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.UploadItemsType

public class UploadItemsType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UploadItemsType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UploadItemsType Members

UploadItemsType overview

Public Instance Constructors

UploadItemsType Constructor Initializes a new instance of the UploadItemsType class.

Public Instance Properties

Items

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UploadItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UploadItemsType Constructor

Initializes a new instance of the UploadItemsType class.

public UploadItemsType();

See Also

UploadItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UploadItemsType Properties

The properties of the UploadItemsType class are listed below. For a complete list of UploadItemsType class members, see the UploadItemsType Members topic.

Public Instance Properties

Items

See Also

UploadItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Items Property

Aspose.Email

UploadItemsType.Items Property

public UploadItemType[] Items {get; set;}

Remarks

See Also

UploadItemsType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UploadItemType Class

For a list of all members of this type, see UploadItemType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.UploadItemType

public class UploadItemType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UploadItemType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UploadItemType Members

UploadItemType overview

Public Instance Constructors

UploadItemType Constructor Initializes a new instance of the UploadItemType class.

Public Instance Properties

CreateAction
Data
IsAssociated
IsAssociatedSpecified
ItemId
ParentFolderId

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UploadItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UploadItemType Constructor

Initializes a new instance of the UploadItemType class.

public UploadItemType();

See Also

UploadItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UploadItemType Properties

The properties of the UploadItemType class are listed below. For a complete list of UploadItemType class members, see the UploadItemType Members topic.

Public Instance Properties

CreateAction
Data
IsAssociated
IsAssociatedSpecified
ItemId
ParentFolderId

See Also

UploadItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


CreateAction Property

Aspose.Email

UploadItemType.CreateAction Property

public CreateActionType CreateAction {get; set;}

Remarks

See Also

UploadItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Data Property

Aspose.Email

UploadItemType.Data Property

public byte[] Data {get; set;}

Remarks

See Also

UploadItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsAssociated Property

Aspose.Email

UploadItemType.IsAssociated Property

public bool IsAssociated {get; set;}

Remarks

See Also

UploadItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsAssociatedSpecified Property

Aspose.Email

UploadItemType.IsAssociatedSpecified Property

public bool IsAssociatedSpecified {get; set;}

Remarks

See Also

UploadItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemId Property

Aspose.Email

UploadItemType.ItemId Property

public ItemIdType ItemId {get; set;}

Remarks

See Also

UploadItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ParentFolderId Property

Aspose.Email

UploadItemType.ParentFolderId Property

public FolderIdType ParentFolderId {get; set;}

Remarks

See Also

UploadItemType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UrlEntityType Class

For a list of all members of this type, see UrlEntityType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.EntityType
Aspose.Email.Exchange.Schema.Exchange_2013.UrlEntityType

public class UrlEntityType : EntityType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UrlEntityType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UrlEntityType Members

UrlEntityType overview

Public Instance Constructors

UrlEntityType Constructor Initializes a new instance of the UrlEntityType class.

Public Instance Properties

Position (inherited from EntityType)
Url

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UrlEntityType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UrlEntityType Constructor

Initializes a new instance of the UrlEntityType class.

public UrlEntityType();

See Also

UrlEntityType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UrlEntityType Properties

The properties of the UrlEntityType class are listed below. For a complete list of UrlEntityType class members, see the UrlEntityType Members topic.

Public Instance Properties

Position (inherited from EntityType)
Url

See Also

UrlEntityType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Url Property

Aspose.Email

UrlEntityType.Url Property

public string Url {get; set;}

Remarks

See Also

UrlEntityType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserConfigurationDictionaryEntryType Class

For a list of all members of this type, see UserConfigurationDictionaryEntryType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.UserConfigurationDictionaryEntryType

public class UserConfigurationDictionaryEntryType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UserConfigurationDictionaryEntryType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserConfigurationDictionaryEntryType Members

UserConfigurationDictionaryEntryType overview

Public Instance Constructors

UserConfigurationDictionaryEntryType Constructor Initializes a new instance of the UserConfigurationDictionaryEntryType class.

Public Instance Properties

DictionaryKey
DictionaryValue

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UserConfigurationDictionaryEntryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserConfigurationDictionaryEntryType Constructor

Initializes a new instance of the UserConfigurationDictionaryEntryType class.

public UserConfigurationDictionaryEntryType();

See Also

UserConfigurationDictionaryEntryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserConfigurationDictionaryEntryType Properties

The properties of the UserConfigurationDictionaryEntryType class are listed below. For a complete list of UserConfigurationDictionaryEntryType class members, see the UserConfigurationDictionaryEntryType Members topic.

Public Instance Properties

DictionaryKey
DictionaryValue

See Also

UserConfigurationDictionaryEntryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DictionaryKey Property

Aspose.Email

UserConfigurationDictionaryEntryType.DictionaryKey Property

public UserConfigurationDictionaryObjectType DictionaryKey {get; set;}

Remarks

See Also

UserConfigurationDictionaryEntryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DictionaryValue Property

Aspose.Email

UserConfigurationDictionaryEntryType.DictionaryValue Property

public UserConfigurationDictionaryObjectType DictionaryValue {get; set;}

Remarks

See Also

UserConfigurationDictionaryEntryType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserConfigurationDictionaryObjectType Class

For a list of all members of this type, see UserConfigurationDictionaryObjectType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.UserConfigurationDictionaryObjectType

public class UserConfigurationDictionaryObjectType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UserConfigurationDictionaryObjectType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserConfigurationDictionaryObjectType Members

UserConfigurationDictionaryObjectType overview

Public Instance Constructors

UserConfigurationDictionaryObjectType Constructor Initializes a new instance of the UserConfigurationDictionaryObjectType class.

Public Instance Properties

Type
Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UserConfigurationDictionaryObjectType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserConfigurationDictionaryObjectType Constructor

Initializes a new instance of the UserConfigurationDictionaryObjectType class.

public UserConfigurationDictionaryObjectType();

See Also

UserConfigurationDictionaryObjectType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserConfigurationDictionaryObjectType Properties

The properties of the UserConfigurationDictionaryObjectType class are listed below. For a complete list of UserConfigurationDictionaryObjectType class members, see the UserConfigurationDictionaryObjectType Members topic.

Public Instance Properties

Type
Value

See Also

UserConfigurationDictionaryObjectType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Type Property

Aspose.Email

UserConfigurationDictionaryObjectType.Type Property

public UserConfigurationDictionaryObjectTypesType Type {get; set;}

Remarks

See Also

UserConfigurationDictionaryObjectType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Value Property

Aspose.Email

UserConfigurationDictionaryObjectType.Value Property

public string[] Value {get; set;}

Remarks

See Also

UserConfigurationDictionaryObjectType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserConfigurationDictionaryObjectTypesType Enumeration

public enum UserConfigurationDictionaryObjectTypesType

Remarks

Members

Member Name | Description | Value
DateTime |  | 0
Boolean |  | 1
Byte |  | 2
String |  | 3
Integer32 |  | 4
UnsignedInteger32 |  | 5
Integer64 |  | 6
UnsignedInteger64 |  | 7
StringArray |  | 8
ByteArray |  | 9

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserConfigurationNameType Class

For a list of all members of this type, see UserConfigurationNameType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.TargetFolderIdType
Aspose.Email.Exchange.Schema.Exchange_2013.UserConfigurationNameType

public class UserConfigurationNameType : TargetFolderIdType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UserConfigurationNameType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserConfigurationNameType Members

UserConfigurationNameType overview

Public Instance Constructors

UserConfigurationNameType Constructor Initializes a new instance of the UserConfigurationNameType class.

Public Instance Properties

Item (inherited from TargetFolderIdType)
Name

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UserConfigurationNameType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserConfigurationNameType Constructor

Initializes a new instance of the UserConfigurationNameType class.

public UserConfigurationNameType();

See Also

UserConfigurationNameType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserConfigurationNameType Properties

The properties of the UserConfigurationNameType class are listed below. For a complete list of UserConfigurationNameType class members, see the UserConfigurationNameType Members topic.

Public Instance Properties

Item (inherited from TargetFolderIdType)
Name

See Also

UserConfigurationNameType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Name Property

Aspose.Email

UserConfigurationNameType.Name Property

public string Name {get; set;}

Remarks

See Also

UserConfigurationNameType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserConfigurationPropertyType Enumeration

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum UserConfigurationPropertyType

Remarks

Members

Member Name | Description | Value
Id |  | 1
Dictionary |  | 2
XmlData |  | 4
BinaryData |  | 8
All |  | 16

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserConfigurationType Class

For a list of all members of this type, see UserConfigurationType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.UserConfigurationType

public class UserConfigurationType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UserConfigurationType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserConfigurationType Members

UserConfigurationType overview

Public Instance Constructors

UserConfigurationType Constructor Initializes a new instance of the UserConfigurationType class.

Public Instance Properties

BinaryData
Dictionary
ItemId
UserConfigurationName
XmlData

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UserConfigurationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserConfigurationType Constructor

Initializes a new instance of the UserConfigurationType class.

public UserConfigurationType();

See Also

UserConfigurationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserConfigurationType Properties

The properties of the UserConfigurationType class are listed below. For a complete list of UserConfigurationType class members, see the UserConfigurationType Members topic.

Public Instance Properties

BinaryData
Dictionary
ItemId
UserConfigurationName
XmlData

See Also

UserConfigurationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BinaryData Property

Aspose.Email

UserConfigurationType.BinaryData Property

public byte[] BinaryData {get; set;}

Remarks

See Also

UserConfigurationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Dictionary Property

Aspose.Email

UserConfigurationType.Dictionary Property

public UserConfigurationDictionaryEntryType[] Dictionary {get; set;}

Remarks

See Also

UserConfigurationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemId Property

Aspose.Email

UserConfigurationType.ItemId Property

public ItemIdType ItemId {get; set;}

Remarks

See Also

UserConfigurationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserConfigurationName Property

Aspose.Email

UserConfigurationType.UserConfigurationName Property

public UserConfigurationNameType UserConfigurationName {get; set;}

Remarks

See Also

UserConfigurationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


XmlData Property

Aspose.Email

UserConfigurationType.XmlData Property

public byte[] XmlData {get; set;}

Remarks

See Also

UserConfigurationType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserIdType Class

For a list of all members of this type, see UserIdType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.UserIdType

public class UserIdType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UserIdType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserIdType Members

UserIdType overview

Public Instance Constructors

UserIdType Constructor Initializes a new instance of the UserIdType class.

Public Instance Properties

DisplayName
DistinguishedUser
DistinguishedUserSpecified
ExternalUserIdentity
PrimarySmtpAddress
SID

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UserIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserIdType Constructor

Initializes a new instance of the UserIdType class.

public UserIdType();

See Also

UserIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserIdType Properties

The properties of the UserIdType class are listed below. For a complete list of UserIdType class members, see the UserIdType Members topic.

Public Instance Properties

DisplayName
DistinguishedUser
DistinguishedUserSpecified
ExternalUserIdentity
PrimarySmtpAddress
SID

See Also

UserIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DisplayName Property

Aspose.Email

UserIdType.DisplayName Property

public string DisplayName {get; set;}

Remarks

See Also

UserIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DistinguishedUser Property

Aspose.Email

UserIdType.DistinguishedUser Property

public DistinguishedUserType DistinguishedUser {get; set;}

Remarks

See Also

UserIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DistinguishedUserSpecified Property

Aspose.Email

UserIdType.DistinguishedUserSpecified Property

public bool DistinguishedUserSpecified {get; set;}

Remarks

See Also

UserIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExternalUserIdentity Property

Aspose.Email

UserIdType.ExternalUserIdentity Property

public string ExternalUserIdentity {get; set;}

Remarks

See Also

UserIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PrimarySmtpAddress Property

Aspose.Email

UserIdType.PrimarySmtpAddress Property

public string PrimarySmtpAddress {get; set;}

Remarks

See Also

UserIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SID Property

Aspose.Email

UserIdType.SID Property

public string SID {get; set;}

Remarks

See Also

UserIdType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserMailboxType Class

For a list of all members of this type, see UserMailboxType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.UserMailboxType

public class UserMailboxType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UserMailboxType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserMailboxType Members

UserMailboxType overview

Public Instance Constructors

UserMailboxType Constructor Initializes a new instance of the UserMailboxType class.

Public Instance Properties

Id
IsArchive

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UserMailboxType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserMailboxType Constructor

Initializes a new instance of the UserMailboxType class.

public UserMailboxType();

See Also

UserMailboxType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserMailboxType Properties

The properties of the UserMailboxType class are listed below. For a complete list of UserMailboxType class members, see the UserMailboxType Members topic.

Public Instance Properties

Id
IsArchive

See Also

UserMailboxType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Id Property

Aspose.Email

UserMailboxType.Id Property

public string Id {get; set;}

Remarks

See Also

UserMailboxType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


IsArchive Property

Aspose.Email

UserMailboxType.IsArchive Property

public bool IsArchive {get; set;}

Remarks

See Also

UserMailboxType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserOofSettings Class

For a list of all members of this type, see UserOofSettings Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.UserOofSettings

public class UserOofSettings

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UserOofSettings Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserOofSettings Members

UserOofSettings overview

Public Instance Constructors

UserOofSettings Constructor Initializes a new instance of the UserOofSettings class.

Public Instance Properties

Duration
ExternalAudience
ExternalReply
InternalReply
OofState

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UserOofSettings Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserOofSettings Constructor

Initializes a new instance of the UserOofSettings class.

public UserOofSettings();

See Also

UserOofSettings Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserOofSettings Properties

The properties of the UserOofSettings class are listed below. For a complete list of UserOofSettings class members, see the UserOofSettings Members topic.

Public Instance Properties

Duration
ExternalAudience
ExternalReply
InternalReply
OofState

See Also

UserOofSettings Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Duration Property

Aspose.Email

UserOofSettings.Duration Property

public Duration Duration {get; set;}

Remarks

See Also

UserOofSettings Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExternalAudience Property

Aspose.Email

UserOofSettings.ExternalAudience Property

public ExternalAudience ExternalAudience {get; set;}

Remarks

See Also

UserOofSettings Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ExternalReply Property

Aspose.Email

UserOofSettings.ExternalReply Property

public ReplyBody ExternalReply {get; set;}

Remarks

See Also

UserOofSettings Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


InternalReply Property

Aspose.Email

UserOofSettings.InternalReply Property

public ReplyBody InternalReply {get; set;}

Remarks

See Also

UserOofSettings Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


OofState Property

Aspose.Email

UserOofSettings.OofState Property

public OofState OofState {get; set;}

Remarks

See Also

UserOofSettings Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserPhotoSizeType Enumeration

public enum UserPhotoSizeType

Remarks

Members

Member Name | Description | Value
HR48x48 |  | 0
HR64x64 |  | 1
HR96x96 |  | 2
HR120x120 |  | 3
HR240x240 |  | 4
HR360x360 |  | 5
HR432x432 |  | 6
HR504x504 |  | 7
HR648x648 |  | 8

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ValidateUMPinResponseMessageType Class

For a list of all members of this type, see ValidateUMPinResponseMessageType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.ValidateUMPinResponseMessageType

public class ValidateUMPinResponseMessageType : ResponseMessageType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ValidateUMPinResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ValidateUMPinResponseMessageType Members

ValidateUMPinResponseMessageType overview

Public Instance Constructors

ValidateUMPinResponseMessageType Constructor Initializes a new instance of the ValidateUMPinResponseMessageType class.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
PinInfo
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ValidateUMPinResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ValidateUMPinResponseMessageType Constructor

Initializes a new instance of the ValidateUMPinResponseMessageType class.

public ValidateUMPinResponseMessageType();

See Also

ValidateUMPinResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ValidateUMPinResponseMessageType Properties

The properties of the ValidateUMPinResponseMessageType class are listed below. For a complete list of ValidateUMPinResponseMessageType class members, see the ValidateUMPinResponseMessageType Members topic.

Public Instance Properties

DescriptiveLinkKey (inherited from ResponseMessageType)
DescriptiveLinkKeySpecified (inherited from ResponseMessageType)
MessageText (inherited from ResponseMessageType)
MessageXml (inherited from ResponseMessageType)
PinInfo
ResponseClass (inherited from ResponseMessageType)
ResponseCode (inherited from ResponseMessageType)
ResponseCodeSpecified (inherited from ResponseMessageType)

See Also

ValidateUMPinResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PinInfo Property

Aspose.Email

ValidateUMPinResponseMessageType.PinInfo Property

public PinInfoType PinInfo {get; set;}

Remarks

See Also

ValidateUMPinResponseMessageType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ValidateUMPinType Class

For a list of all members of this type, see ValidateUMPinType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.ValidateUMPinType

public class ValidateUMPinType : BaseRequestType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ValidateUMPinType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ValidateUMPinType Members

ValidateUMPinType overview

Public Instance Constructors

ValidateUMPinType Constructor Initializes a new instance of the ValidateUMPinType class.

Public Instance Properties

PinInfo
UserUMMailboxPolicyGuid

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ValidateUMPinType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ValidateUMPinType Constructor

Initializes a new instance of the ValidateUMPinType class.

public ValidateUMPinType();

See Also

ValidateUMPinType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ValidateUMPinType Properties

The properties of the ValidateUMPinType class are listed below. For a complete list of ValidateUMPinType class members, see the ValidateUMPinType Members topic.

Public Instance Properties

PinInfo
UserUMMailboxPolicyGuid

See Also

ValidateUMPinType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


PinInfo Property

Aspose.Email

ValidateUMPinType.PinInfo Property

public PinInfoType PinInfo {get; set;}

Remarks

See Also

ValidateUMPinType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


UserUMMailboxPolicyGuid Property

Aspose.Email

ValidateUMPinType.UserUMMailboxPolicyGuid Property

public string UserUMMailboxPolicyGuid {get; set;}

Remarks

See Also

ValidateUMPinType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ViewFilterType Enumeration

public enum ViewFilterType

Remarks

Members

Member Name | Description | Value
All |  | 0
Flagged |  | 1
HasAttachment |  | 2
ToOrCcMe |  | 3
Unread |  | 4
TaskActive |  | 5
TaskOverdue |  | 6
TaskCompleted |  | 7
Suggestions |  | 8
SuggestionsRespond |  | 9
SuggestionsDelete |  | 10

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


WeeklyRecurrencePatternType Class

For a list of all members of this type, see WeeklyRecurrencePatternType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.RecurrencePatternBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.IntervalRecurrencePatternBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.WeeklyRecurrencePatternType

public class WeeklyRecurrencePatternType : IntervalRecurrencePatternBaseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

WeeklyRecurrencePatternType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


WeeklyRecurrencePatternType Members

WeeklyRecurrencePatternType overview

Public Instance Constructors

WeeklyRecurrencePatternType Constructor Initializes a new instance of the WeeklyRecurrencePatternType class.

Public Instance Properties

DaysOfWeek
FirstDayOfWeek
Interval (inherited from IntervalRecurrencePatternBaseType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WeeklyRecurrencePatternType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


WeeklyRecurrencePatternType Constructor

Initializes a new instance of the WeeklyRecurrencePatternType class.

public WeeklyRecurrencePatternType();

See Also

WeeklyRecurrencePatternType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


WeeklyRecurrencePatternType Properties

The properties of the WeeklyRecurrencePatternType class are listed below. For a complete list of WeeklyRecurrencePatternType class members, see the WeeklyRecurrencePatternType Members topic.

Public Instance Properties

DaysOfWeek
FirstDayOfWeek
Interval (inherited from IntervalRecurrencePatternBaseType)

See Also

WeeklyRecurrencePatternType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DaysOfWeek Property

Aspose.Email

WeeklyRecurrencePatternType.DaysOfWeek Property

public string DaysOfWeek {get; set;}

Remarks

See Also

WeeklyRecurrencePatternType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


FirstDayOfWeek Property

Aspose.Email

WeeklyRecurrencePatternType.FirstDayOfWeek Property

public string FirstDayOfWeek {get; set;}

Remarks

See Also

WeeklyRecurrencePatternType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


WeeklyRegeneratingPatternType Class

For a list of all members of this type, see WeeklyRegeneratingPatternType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.RecurrencePatternBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.IntervalRecurrencePatternBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.RegeneratingPatternBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.WeeklyRegeneratingPatternType

public class WeeklyRegeneratingPatternType : RegeneratingPatternBaseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

WeeklyRegeneratingPatternType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


WeeklyRegeneratingPatternType Members

WeeklyRegeneratingPatternType overview

Public Instance Constructors

WeeklyRegeneratingPatternType Constructor Initializes a new instance of the WeeklyRegeneratingPatternType class.

Public Instance Properties

Interval (inherited from IntervalRecurrencePatternBaseType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WeeklyRegeneratingPatternType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


WeeklyRegeneratingPatternType Constructor

Initializes a new instance of the WeeklyRegeneratingPatternType class.

public WeeklyRegeneratingPatternType();

See Also

WeeklyRegeneratingPatternType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


WellKnownResponseObjectType Class

For a list of all members of this type, see WellKnownResponseObjectType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.ItemType
Aspose.Email.Exchange.Schema.Exchange_2013.MessageType
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseObjectCoreType
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseObjectType
Aspose.Email.Exchange.Schema.Exchange_2013.WellKnownResponseObjectType
Aspose.Email.Exchange.Schema.Exchange_2013.AcceptItemType
Aspose.Email.Exchange.Schema.Exchange_2013.DeclineItemType
Aspose.Email.Exchange.Schema.Exchange_2013.TentativelyAcceptItemType

public class WellKnownResponseObjectType : ResponseObjectType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

WellKnownResponseObjectType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


WellKnownResponseObjectType Members

WellKnownResponseObjectType overview

Public Instance Constructors

WellKnownResponseObjectType Constructor Initializes a new instance of the WellKnownResponseObjectType class.

Public Instance Properties

ArchiveTag (inherited from ItemType)
Attachments (inherited from ItemType)
BccRecipients (inherited from MessageType)
BlockStatus (inherited from ItemType)
BlockStatusSpecified (inherited from ItemType)
Body (inherited from ItemType)
Categories (inherited from ItemType)
CcRecipients (inherited from MessageType)
ConversationId (inherited from ItemType)
ConversationIndex (inherited from MessageType)
ConversationTopic (inherited from MessageType)
Culture (inherited from ItemType)
DateTimeCreated (inherited from ItemType)
DateTimeCreatedSpecified (inherited from ItemType)
DateTimeReceived (inherited from ItemType)
DateTimeReceivedSpecified (inherited from ItemType)
DateTimeSent (inherited from ItemType)
DateTimeSentSpecified (inherited from ItemType)
DisplayCc (inherited from ItemType)
DisplayTo (inherited from ItemType)
EffectiveRights (inherited from ItemType)
EntityExtractionResult (inherited from ItemType)
ExtendedProperty (inherited from ItemType)
Flag (inherited from ItemType)
From (inherited from MessageType)
GroupingAction (inherited from ItemType)
GroupingActionSpecified (inherited from ItemType)
HasAttachments (inherited from ItemType)
HasAttachmentsSpecified (inherited from ItemType)
HasBlockedImages (inherited from ItemType)
HasBlockedImagesSpecified (inherited from ItemType)
IconIndex (inherited from ItemType)
IconIndexSpecified (inherited from ItemType)
Importance (inherited from ItemType)
ImportanceSpecified (inherited from ItemType)
InReplyTo (inherited from ItemType)
InstanceKey (inherited from ItemType)
InternetMessageHeaders (inherited from ItemType)
InternetMessageId (inherited from MessageType)
IsAssociated (inherited from ItemType)
IsAssociatedSpecified (inherited from ItemType)
IsDeliveryReceiptRequested (inherited from MessageType)
IsDeliveryReceiptRequestedSpecified (inherited from MessageType)
IsDraft (inherited from ItemType)
IsDraftSpecified (inherited from ItemType)
IsFromMe (inherited from ItemType)
IsFromMeSpecified (inherited from ItemType)
IsRead (inherited from MessageType)
IsReadReceiptRequested (inherited from MessageType)
IsReadReceiptRequestedSpecified (inherited from MessageType)
IsReadSpecified (inherited from MessageType)
IsResend (inherited from ItemType)
IsResendSpecified (inherited from ItemType)
IsResponseRequested (inherited from MessageType)
IsResponseRequestedSpecified (inherited from MessageType)
IsSubmitted (inherited from ItemType)
IsSubmittedSpecified (inherited from ItemType)
IsUnmodified (inherited from ItemType)
IsUnmodifiedSpecified (inherited from ItemType)
ItemClass (inherited from ItemType)
ItemId (inherited from ItemType)
LastModifiedName (inherited from ItemType)
LastModifiedTime (inherited from ItemType)
LastModifiedTimeSpecified (inherited from ItemType)
MimeContent (inherited from ItemType)
NextPredictedAction (inherited from ItemType)
NextPredictedActionSpecified (inherited from ItemType)
NormalizedBody (inherited from ItemType)
ObjectName (inherited from ResponseObjectType)
ParentFolderId (inherited from ItemType)
PolicyTag (inherited from ItemType)
Preview (inherited from ItemType)
ReceivedBy (inherited from MessageType)
ReceivedRepresenting (inherited from MessageType)
ReferenceItemId (inherited from ResponseObjectCoreType)
References (inherited from MessageType)
ReminderDueBy (inherited from ItemType)
ReminderDueBySpecified (inherited from ItemType)
ReminderIsSet (inherited from ItemType)
ReminderIsSetSpecified (inherited from ItemType)
ReminderMinutesBeforeStart (inherited from ItemType)
ReminderNextTime (inherited from ItemType)
ReminderNextTimeSpecified (inherited from ItemType)
ReplyTo (inherited from MessageType)
ResponseObjects (inherited from ItemType)
RetentionDate (inherited from ItemType)
RetentionDateSpecified (inherited from ItemType)
RightsManagementLicenseData (inherited from ItemType)
Sender (inherited from MessageType)
Sensitivity (inherited from ItemType)
SensitivitySpecified (inherited from ItemType)
Size (inherited from ItemType)
SizeSpecified (inherited from ItemType)
StoreEntryId (inherited from ItemType)
Subject (inherited from ItemType)
TextBody (inherited from ItemType)
ToRecipients (inherited from MessageType)
UniqueBody (inherited from ItemType)
WebClientEditFormQueryString (inherited from ItemType)
WebClientReadFormQueryString (inherited from ItemType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WellKnownResponseObjectType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


WellKnownResponseObjectType Constructor

Initializes a new instance of the WellKnownResponseObjectType class.

public WellKnownResponseObjectType();

See Also

WellKnownResponseObjectType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


WorkingHours Class

For a list of all members of this type, see WorkingHours Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.WorkingHours

public class WorkingHours

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

WorkingHours Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


WorkingHours Members

WorkingHours overview

Public Instance Constructors

WorkingHours Constructor Initializes a new instance of the WorkingHours class.

Public Instance Properties

TimeZone
WorkingPeriodArray

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WorkingHours Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


WorkingHours Constructor

Initializes a new instance of the WorkingHours class.

public WorkingHours();

See Also

WorkingHours Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


WorkingHours Properties

The properties of the WorkingHours class are listed below. For a complete list of WorkingHours class members, see the WorkingHours Members topic.

Public Instance Properties

TimeZone
WorkingPeriodArray

See Also

WorkingHours Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TimeZone Property

Aspose.Email

WorkingHours.TimeZone Property

public SerializableTimeZone TimeZone {get; set;}

Remarks

See Also

WorkingHours Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


WorkingPeriodArray Property

Aspose.Email

WorkingHours.WorkingPeriodArray Property

public WorkingPeriod[] WorkingPeriodArray {get; set;}

Remarks

See Also

WorkingHours Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


WorkingPeriod Class

For a list of all members of this type, see WorkingPeriod Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.WorkingPeriod

public class WorkingPeriod

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

WorkingPeriod Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


WorkingPeriod Members

WorkingPeriod overview

Public Instance Constructors

WorkingPeriod Constructor Initializes a new instance of the WorkingPeriod class.

Public Instance Properties

DayOfWeek
EndTimeInMinutes
StartTimeInMinutes

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WorkingPeriod Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


WorkingPeriod Constructor

Initializes a new instance of the WorkingPeriod class.

public WorkingPeriod();

See Also

WorkingPeriod Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


WorkingPeriod Properties

The properties of the WorkingPeriod class are listed below. For a complete list of WorkingPeriod class members, see the WorkingPeriod Members topic.

Public Instance Properties

DayOfWeek
EndTimeInMinutes
StartTimeInMinutes

See Also

WorkingPeriod Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


DayOfWeek Property

Aspose.Email

WorkingPeriod.DayOfWeek Property

public string DayOfWeek {get; set;}

Remarks

See Also

WorkingPeriod Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EndTimeInMinutes Property

Aspose.Email

WorkingPeriod.EndTimeInMinutes Property

public int EndTimeInMinutes {get; set;}

Remarks

See Also

WorkingPeriod Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


StartTimeInMinutes Property

Aspose.Email

WorkingPeriod.StartTimeInMinutes Property

public int StartTimeInMinutes {get; set;}

Remarks

See Also

WorkingPeriod Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


YearlyRegeneratingPatternType Class

For a list of all members of this type, see YearlyRegeneratingPatternType Members.

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.RecurrencePatternBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.IntervalRecurrencePatternBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.RegeneratingPatternBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.YearlyRegeneratingPatternType

public class YearlyRegeneratingPatternType : RegeneratingPatternBaseType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.Email.Exchange.Schema.Exchange_2013

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

YearlyRegeneratingPatternType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


YearlyRegeneratingPatternType Members

YearlyRegeneratingPatternType overview

Public Instance Constructors

YearlyRegeneratingPatternType Constructor Initializes a new instance of the YearlyRegeneratingPatternType class.

Public Instance Properties

Interval (inherited from IntervalRecurrencePatternBaseType)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

YearlyRegeneratingPatternType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


YearlyRegeneratingPatternType Constructor

Initializes a new instance of the YearlyRegeneratingPatternType class.

public YearlyRegeneratingPatternType();

See Also

YearlyRegeneratingPatternType Class | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Aspose.Email.Formats

Aspose.Email

Aspose.Email.Formats Namespace

Namespace hierarchy

Classes

Class | Description
MailStorageConverter | Mail storage converter provides services for storage conversion operations.


MailStorageConverter Class

Mail storage converter provides services for storage conversion operations.

For a list of all members of this type, see MailStorageConverter Members.

System.Object
Aspose.Email.Formats.MailStorageConverter

public abstract sealed class MailStorageConverter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Formats

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MailStorageConverter Members | Aspose.Email.Formats Namespace


MailStorageConverter Members

MailStorageConverter overview

Public Static Methods

MboxToPst Overloaded. Converts an mboxrd message store to PST.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MailStorageConverter Class | Aspose.Email.Formats Namespace


MailStorageConverter Methods

The methods of the MailStorageConverter class are listed below. For a complete list of MailStorageConverter class members, see the MailStorageConverter Members topic.

Public Static Methods

MboxToPst Overloaded. Converts an mboxrd message store to PST.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MailStorageConverter Class | Aspose.Email.Formats Namespace


MboxToPst Method

Aspose.Email

MailStorageConverter.MboxToPst Method

Converts an mboxrd message store to PST.

Overload List

Converts an mboxrd message store to PST.

public static PersonalStorage MboxToPst(Stream,string);

Converts an mboxrd message store to PST.

public static PersonalStorage MboxToPst(string,string);

See Also

MailStorageConverter Class | Aspose.Email.Formats Namespace


MailStorageConverter.MboxToPst Method (Stream, String)

Converts an mboxrd message store to PST.

public static PersonalStorage MboxToPst(
Stream mboxrdDataStream,
string pstFileName
);

Parameters

mboxrdDataStream
The mboxrd data stream.
pstFileName
Name of the PST file.

Return Value

Personal storage object that represents the converted storage.

Exceptions

Exception Type | Condition
ArgumentNullException | If mboxrdDataStream is null.
ArgumentNullException | If pstFileName is null or empty.

See Also

MailStorageConverter Class | Aspose.Email.Formats Namespace | MailStorageConverter.MboxToPst Overload List


MailStorageConverter.MboxToPst Method (String, String)

Converts an mboxrd message store to PST.

public static PersonalStorage MboxToPst(
string mboxFileName,
string pstFileName
);

Parameters

mboxFileName
Name of the mbox file.
pstFileName
Name of the PST file.

Return Value

Personal storage object that represents the converted storage.

Remarks

In addition the same set of exceptions can be thrown as for FileStream creation using the open/read, create/write mode.

Exceptions

Exception Type | Condition
ArgumentNullException | If mboxFileName is null.

See Also

MailStorageConverter Class | Aspose.Email.Formats Namespace | MailStorageConverter.MboxToPst Overload List


Aspose.Email.Formats.Mbox

Aspose.Email

Aspose.Email.Formats.Mbox Namespace

Namespace hierarchy

Classes

Class | Description
MboxrdStorageReader | Represents mboxrd format storage reader, this format is being used by Thunderbird, Eudora OSE and other mail clients.
MboxrdStorageWriter | Represents mboxrd format storage writer, this format is being used by Thunderbird and other mail clients.
MboxStorageReader | A base class for any mbox-based mail storage reader.
MboxStorageWriter | A base class for any mbox-based mail storage writer.


MboxrdStorageReader Class

Represents mboxrd format storage reader, this format is being used by Thunderbird, Eudora OSE and other mail clients.

For a list of all members of this type, see MboxrdStorageReader Members.

System.Object
Aspose.Email.Formats.Mbox.MboxStorageReader
Aspose.Email.Formats.Mbox.MboxrdStorageReader

public sealed class MboxrdStorageReader : MboxStorageReader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Formats.Mbox

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MboxrdStorageReader Members | Aspose.Email.Formats.Mbox Namespace


MboxrdStorageReader Members

MboxrdStorageReader overview

Public Instance Constructors

MboxrdStorageReader Overloaded. Initializes a new instance of the MboxrdStorageReader class.

Public Instance Properties

BaseStream (inherited from MboxStorageReader) Gets the base stream.

Public Instance Methods

Dispose (inherited from MboxStorageReader) | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ReadNextMessage | Reads the next message from underlying storage stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MboxrdStorageReader Class | Aspose.Email.Formats.Mbox Namespace


MboxrdStorageReader Constructor

Initializes a new instance of the MboxrdStorageReader class.

Overload List

Initializes a new instance of the MboxrdStorageReader class.

public MboxrdStorageReader(Stream,bool);

Initializes a new instance of the MboxrdStorageReader class.

public MboxrdStorageReader(string,bool);

See Also

MboxrdStorageReader Class | Aspose.Email.Formats.Mbox Namespace


MboxrdStorageReader Constructor (Stream, Boolean)

Initializes a new instance of the MboxrdStorageReader class.

public MboxrdStorageReader(
Stream stream,
bool leaveOpen
);

Parameters

stream
The stream.
leaveOpen
if set to true leaves the underlying stream open after disposing.

Exceptions

Exception Type | Condition
ArgumentNullException | If given stream is null.

See Also

MboxrdStorageReader Class | Aspose.Email.Formats.Mbox Namespace | MboxrdStorageReader Constructor Overload List


MboxrdStorageReader Constructor (String, Boolean)

Initializes a new instance of the MboxrdStorageReader class.

public MboxrdStorageReader(
string fileName,
bool leaveOpen
);

Parameters

fileName
Name of the file.
leaveOpen
if set to true leaves the underlying stream open after disposing.

Exceptions

Exception Type | Condition
ArgumentNullException | If filename is null or empty.

See Also

MboxrdStorageReader Class | Aspose.Email.Formats.Mbox Namespace | MboxrdStorageReader Constructor Overload List


MboxrdStorageReader Methods

The methods of the MboxrdStorageReader class are listed below. For a complete list of MboxrdStorageReader class members, see the MboxrdStorageReader Members topic.

Public Instance Methods

Dispose (inherited from MboxStorageReader) | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ReadNextMessage | Reads the next message from underlying storage stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MboxrdStorageReader Class | Aspose.Email.Formats.Mbox Namespace


MboxrdStorageReader.ReadNextMessage Method

Reads the next message from underlying storage stream.

public override MailMessage ReadNextMessage();

Return Value

A MailMessage object if it can be read or null if no more messages are available.

See Also

MboxrdStorageReader Class | Aspose.Email.Formats.Mbox Namespace


MboxrdStorageWriter Class

Represents mboxrd format storage writer, this format is being used by Thunderbird and other mail clients.

For a list of all members of this type, see MboxrdStorageWriter Members.

System.Object
Aspose.Email.Formats.Mbox.MboxStorageWriter
Aspose.Email.Formats.Mbox.MboxrdStorageWriter

public sealed class MboxrdStorageWriter : MboxStorageWriter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Formats.Mbox

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MboxrdStorageWriter Members | Aspose.Email.Formats.Mbox Namespace


MboxrdStorageWriter Members

MboxrdStorageWriter overview

Public Instance Constructors

MboxrdStorageWriter Overloaded. Initializes a new instance of the MboxrdStorageWriter class.

Public Instance Properties

BaseStream (inherited from MboxStorageWriter) Gets the base stream.

Public Instance Methods

Dispose (inherited from MboxStorageWriter) | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteMessage | Writes the message to underlying storage stream.

See Also

MboxrdStorageWriter Class | Aspose.Email.Formats.Mbox Namespace


MboxrdStorageWriter Constructor

Initializes a new instance of the MboxrdStorageWriter class.

Overload List

Initializes a new instance of the MboxrdStorageWriter class.

public MboxrdStorageWriter(Stream,bool);

Initializes a new instance of the MboxrdStorageWriter class.

public MboxrdStorageWriter(string,bool);

See Also

MboxrdStorageWriter Class | Aspose.Email.Formats.Mbox Namespace


MboxrdStorageWriter Constructor (Stream, Boolean)

Initializes a new instance of the MboxrdStorageWriter class.

public MboxrdStorageWriter(
Stream stream,
bool leaveOpen
);

Parameters

stream
The stream.
leaveOpen
if set to true leaves the underlying stream open after disposing.

Exceptions

Exception Type | Condition
ArgumentNullException | If given stream is null.

See Also

MboxrdStorageWriter Class | Aspose.Email.Formats.Mbox Namespace | MboxrdStorageWriter Constructor Overload List


MboxrdStorageWriter Constructor (String, Boolean)

Initializes a new instance of the MboxrdStorageWriter class.

public MboxrdStorageWriter(
string fileName,
bool leaveOpen
);

Parameters

fileName
Name of the file.
leaveOpen
if set to true leaves the underlying stream open after disposing.

Exceptions

Exception Type | Condition
ArgumentNullException | If filename is null or empty.

See Also

MboxrdStorageWriter Class | Aspose.Email.Formats.Mbox Namespace | MboxrdStorageWriter Constructor Overload List


MboxrdStorageWriter Methods

The methods of the MboxrdStorageWriter class are listed below. For a complete list of MboxrdStorageWriter class members, see the MboxrdStorageWriter Members topic.

Public Instance Methods

Dispose (inherited from MboxStorageWriter) | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteMessage | Writes the message to underlying storage stream.

See Also

MboxrdStorageWriter Class | Aspose.Email.Formats.Mbox Namespace


MboxrdStorageWriter.WriteMessage Method

Writes the message to underlying storage stream.

public override void WriteMessage(
MailMessage message
);

Parameters

message
The message to write to.

See Also

MboxrdStorageWriter Class | Aspose.Email.Formats.Mbox Namespace


MboxStorageReader Class

A base class for any mbox-based mail storage reader.

For a list of all members of this type, see MboxStorageReader Members.

System.Object
Aspose.Email.Formats.Mbox.MboxStorageReader
Aspose.Email.Formats.Mbox.MboxrdStorageReader

public abstract class MboxStorageReader : IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Formats.Mbox

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MboxStorageReader Members | Aspose.Email.Formats.Mbox Namespace


MboxStorageReader Members

MboxStorageReader overview

Public Instance Properties

BaseStream Gets the base stream.

Public Instance Methods

Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ReadNextMessage | Reads the next message from underlying storage stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

MboxStorageReader Overloaded. Initializes a new instance of the MboxStorageReader class.

Protected Instance Methods

Dispose | Overloaded. Releases unmanaged and - optionally - managed resources
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MboxStorageReader Class | Aspose.Email.Formats.Mbox Namespace


MboxStorageReader Constructor

Overload List

protected MboxStorageReader(Stream,bool);

protected MboxStorageReader(string,bool);

See Also

MboxStorageReader Class | Aspose.Email.Formats.Mbox Namespace


MboxStorageReader Constructor (Stream, Boolean)

protected MboxStorageReader(
Stream stream,
bool leaveOpen
);

See Also

MboxStorageReader Class | Aspose.Email.Formats.Mbox Namespace | MboxStorageReader Constructor Overload List


MboxStorageReader Constructor (String, Boolean)

protected MboxStorageReader(
string fileName,
bool leaveOpen
);

See Also

MboxStorageReader Class | Aspose.Email.Formats.Mbox Namespace | MboxStorageReader Constructor Overload List


MboxStorageReader Properties

The properties of the MboxStorageReader class are listed below. For a complete list of MboxStorageReader class members, see the MboxStorageReader Members topic.

Public Instance Properties

BaseStream Gets the base stream.

See Also

MboxStorageReader Class | Aspose.Email.Formats.Mbox Namespace


BaseStream Property

Aspose.Email

MboxStorageReader.BaseStream Property

Gets the base stream.

public Stream BaseStream {get;}

Property Value

The base stream.

See Also

MboxStorageReader Class | Aspose.Email.Formats.Mbox Namespace


MboxStorageReader Methods

The methods of the MboxStorageReader class are listed below. For a complete list of MboxStorageReader class members, see the MboxStorageReader Members topic.

Public Instance Methods

Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ReadNextMessage | Reads the next message from underlying storage stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Dispose | Overloaded. Releases unmanaged and - optionally - managed resources
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MboxStorageReader Class | Aspose.Email.Formats.Mbox Namespace


Dispose Method

Aspose.Email

MboxStorageReader.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Overload List

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

public void Dispose();

Releases unmanaged and - optionally - managed resources

protected virtual void Dispose(bool);

See Also

MboxStorageReader Class | Aspose.Email.Formats.Mbox Namespace


MboxStorageReader.Dispose Method ()

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

public void Dispose();

Implements

IDisposable.Dispose

See Also

MboxStorageReader Class | Aspose.Email.Formats.Mbox Namespace | MboxStorageReader.Dispose Overload List


MboxStorageReader.Dispose Method (Boolean)

Releases unmanaged and - optionally - managed resources

protected virtual void Dispose(
bool disposing
);

Parameters

disposing
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

MboxStorageReader Class | Aspose.Email.Formats.Mbox Namespace | MboxStorageReader.Dispose Overload List


MboxStorageReader.ReadNextMessage Method

Reads the next message from underlying storage stream.

public abstract MailMessage ReadNextMessage();

Return Value

A MailMessage object if it can be read or null if no more messages are available.

See Also

MboxStorageReader Class | Aspose.Email.Formats.Mbox Namespace


MboxStorageWriter Class

A base class for any mbox-based mail storage writer.

For a list of all members of this type, see MboxStorageWriter Members.

System.Object
Aspose.Email.Formats.Mbox.MboxStorageWriter
Aspose.Email.Formats.Mbox.MboxrdStorageWriter

public abstract class MboxStorageWriter : IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Formats.Mbox

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MboxStorageWriter Members | Aspose.Email.Formats.Mbox Namespace


MboxStorageWriter Members

MboxStorageWriter overview

Public Instance Properties

BaseStream Gets the base stream.

Public Instance Methods

Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteMessage | Writes the message to underlying storage stream.

Protected Instance Constructors

MboxStorageWriter Overloaded. Initializes a new instance of the MboxStorageWriter class.

Protected Instance Methods

Dispose | Overloaded. Releases unmanaged and - optionally - managed resources
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MboxStorageWriter Class | Aspose.Email.Formats.Mbox Namespace


MboxStorageWriter Constructor

Overload List

protected MboxStorageWriter(Stream,bool);

protected MboxStorageWriter(string,bool);

See Also

MboxStorageWriter Class | Aspose.Email.Formats.Mbox Namespace


MboxStorageWriter Constructor (Stream, Boolean)

protected MboxStorageWriter(
Stream stream,
bool leaveOpen
);

See Also

MboxStorageWriter Class | Aspose.Email.Formats.Mbox Namespace | MboxStorageWriter Constructor Overload List


MboxStorageWriter Constructor (String, Boolean)

protected MboxStorageWriter(
string fileName,
bool leaveOpen
);

See Also

MboxStorageWriter Class | Aspose.Email.Formats.Mbox Namespace | MboxStorageWriter Constructor Overload List


MboxStorageWriter Properties

The properties of the MboxStorageWriter class are listed below. For a complete list of MboxStorageWriter class members, see the MboxStorageWriter Members topic.

Public Instance Properties

BaseStream Gets the base stream.

See Also

MboxStorageWriter Class | Aspose.Email.Formats.Mbox Namespace


BaseStream Property

Aspose.Email

MboxStorageWriter.BaseStream Property

Gets the base stream.

public Stream BaseStream {get;}

Property Value

The base stream.

See Also

MboxStorageWriter Class | Aspose.Email.Formats.Mbox Namespace


MboxStorageWriter Methods

The methods of the MboxStorageWriter class are listed below. For a complete list of MboxStorageWriter class members, see the MboxStorageWriter Members topic.

Public Instance Methods

Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteMessage | Writes the message to underlying storage stream.

Protected Instance Methods

Dispose | Overloaded. Releases unmanaged and - optionally - managed resources
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MboxStorageWriter Class | Aspose.Email.Formats.Mbox Namespace


Dispose Method

Aspose.Email

MboxStorageWriter.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Overload List

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

public void Dispose();

Releases unmanaged and - optionally - managed resources

protected virtual void Dispose(bool);

See Also

MboxStorageWriter Class | Aspose.Email.Formats.Mbox Namespace


MboxStorageWriter.Dispose Method ()

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

public void Dispose();

Implements

IDisposable.Dispose

See Also

MboxStorageWriter Class | Aspose.Email.Formats.Mbox Namespace | MboxStorageWriter.Dispose Overload List


MboxStorageWriter.Dispose Method (Boolean)

Releases unmanaged and - optionally - managed resources

protected virtual void Dispose(
bool disposing
);

Parameters

disposing
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

MboxStorageWriter Class | Aspose.Email.Formats.Mbox Namespace | MboxStorageWriter.Dispose Overload List


MboxStorageWriter.WriteMessage Method

Writes the message to underlying storage stream.

public abstract void WriteMessage(
MailMessage message
);

Parameters

message
The message to write to.

See Also

MboxStorageWriter Class | Aspose.Email.Formats.Mbox Namespace


Aspose.Email.Formats.Outlook

Aspose.Email

Aspose.Email.Formats.Outlook Namespace

Namespace hierarchy

Classes

Class | Description
InlineAttachmentExtractor | Provides ability to extract files from MSO packages. Can be used to process "oledata.mso" and similar files typically attached to messages created using Outlook.


InlineAttachmentExtractor Class

Provides ability to extract files from MSO packages. Can be used to process "oledata.mso" and similar files typically attached to messages created using Outlook.

For a list of all members of this type, see InlineAttachmentExtractor Members.

System.Object
Aspose.Email.Formats.Outlook.InlineAttachmentExtractor

public abstract sealed class InlineAttachmentExtractor

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Formats.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

InlineAttachmentExtractor Members | Aspose.Email.Formats.Outlook Namespace


InlineAttachmentExtractor Members

InlineAttachmentExtractor overview

Public Static Methods

EnumerateMsoPackage Enumerates the MSO package and returns a dictionary containing files data. The key is file identifier and value contains actual data.Files are usually referenced in message body using the identifiers provided.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

InlineAttachmentExtractor Class | Aspose.Email.Formats.Outlook Namespace


InlineAttachmentExtractor Methods

The methods of the InlineAttachmentExtractor class are listed below. For a complete list of InlineAttachmentExtractor class members, see the InlineAttachmentExtractor Members topic.

Public Static Methods

EnumerateMsoPackage Enumerates the MSO package and returns a dictionary containing files data. The key is file identifier and value contains actual data.Files are usually referenced in message body using the identifiers provided.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

InlineAttachmentExtractor Class | Aspose.Email.Formats.Outlook Namespace


InlineAttachmentExtractor.EnumerateMsoPackage Method

Enumerates the MSO package and returns a dictionary containing files data. The key is file identifier and value contains actual data.Files are usually referenced in message body using the identifiers provided.

public static IDictionary<string, byte[]> EnumerateMsoPackage(
Stream stream
);

Parameters

stream
The stream to parse.

Return Value

Dictionary with files data.

Remarks

While in evaluation mode only one file is extracted from given MSO stream.

Exceptions

Exception Type | Condition
ArgumentNullException | If stream is null.
InvalidDataException | If given stream has data in incorrect format.

See Also

InlineAttachmentExtractor Class | Aspose.Email.Formats.Outlook Namespace


Aspose.Email.Formats.Outlook.Msg

Aspose.Email

Aspose.Email.Formats.Outlook.Msg Namespace

Namespace hierarchy

Classes

Class | Description
CustomAttachmentStorage | Represents custom attachment storage.
MapiGuidConstants | Contains several guid constants defined by MSG format specification.
MessageObject | Represents an Outlook message object. Evaluation limits: only 1 attachment and 1 recipient are read when message is being loaded, watermark will be added when the message is being saved.
MessageObjectAttachmentEntity | Represents an attachment entity.
MessageObjectAttachmentsCollection | Represents a collection for MessageObjectAttachmentEntity objects.
MessageObjectPropertiesCollection | Represents a keyed collection for MessageObjectProperty objects.
MessageObjectProperty | Represents a property on a MessageObject.
MessageObjectRecipientEntity | Represens a recipient entry in message object.
MessageObjectRecipientsCollection | Represents a collection for MessageObjectRecipientEntity objects.

Interfaces

Interface | Description
IMessageObjectPropertyContainer | Defines an interface for container which contains MessageObjectProperty entries.

Enumerations

Enumeration | Description
MapiPropertyFlags | Represents flags which can be set on a MAPI property.
MapiType | Contains possible MAPI property types which can be stored with message object.
MessageObjectLoadFormat | Represents available formats MessageObject could be loaded from.
MessageObjectSaveFormat | Represents available formats MessageObject could be saved to.
NamedPropertyKind | Identifies MessageObjectProperty kind.


CustomAttachmentStorage Class

Represents custom attachment storage.

For a list of all members of this type, see CustomAttachmentStorage Members.

System.Object
Aspose.Email.Formats.Outlook.Msg.CustomAttachmentStorage

public sealed class CustomAttachmentStorage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Formats.Outlook.Msg

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CustomAttachmentStorage Members | Aspose.Email.Formats.Outlook.Msg Namespace


CustomAttachmentStorage Members

CustomAttachmentStorage overview

Public Instance Constructors

CustomAttachmentStorage Constructor Initializes a new instance of the CustomAttachmentStorage class.

Public Instance Properties

DataSet Gets the data set representing custom attachment storage, names of the data streams are keys for this dictionary.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

CustomAttachmentStorage Class | Aspose.Email.Formats.Outlook.Msg Namespace


CustomAttachmentStorage Constructor

Initializes a new instance of the CustomAttachmentStorage class.

public CustomAttachmentStorage();

See Also

CustomAttachmentStorage Class | Aspose.Email.Formats.Outlook.Msg Namespace


CustomAttachmentStorage Properties

The properties of the CustomAttachmentStorage class are listed below. For a complete list of CustomAttachmentStorage class members, see the CustomAttachmentStorage Members topic.

Public Instance Properties

DataSet Gets the data set representing custom attachment storage, names of the data streams are keys for this dictionary.

See Also

CustomAttachmentStorage Class | Aspose.Email.Formats.Outlook.Msg Namespace


DataSet Property

Aspose.Email

CustomAttachmentStorage.DataSet Property

Gets the data set representing custom attachment storage, names of the data streams are keys for this dictionary.

public Byte[]} DataSet {get;}

Property Value

The data set.

See Also

CustomAttachmentStorage Class | Aspose.Email.Formats.Outlook.Msg Namespace


IMessageObjectPropertyContainer Interface

Defines an interface for container which contains MessageObjectProperty entries.

For a list of all members of this type, see IMessageObjectPropertyContainer Members.

public interface IMessageObjectPropertyContainer

Types that implement IMessageObjectPropertyContainer

Type | Description
MessageObject | Represents an Outlook message object. Evaluation limits: only 1 attachment and 1 recipient are read when message is being loaded, watermark will be added when the message is being saved.
MessageObjectAttachmentEntity | Represents an attachment entity.
MessageObjectRecipientEntity | Represens a recipient entry in message object.

Requirements

Namespace: Aspose.Email.Formats.Outlook.Msg

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

IMessageObjectPropertyContainer Members | Aspose.Email.Formats.Outlook.Msg Namespace


IMessageObjectPropertyContainer Members

IMessageObjectPropertyContainer overview

Public Instance Properties

Properties Gets the properties of the container.

See Also

IMessageObjectPropertyContainer Interface | Aspose.Email.Formats.Outlook.Msg Namespace


IMessageObjectPropertyContainer Properties

The properties of the IMessageObjectPropertyContainer interface are listed below. For a complete list of IMessageObjectPropertyContainer interface members, see the IMessageObjectPropertyContainer Members topic.

Public Instance Properties

Properties Gets the properties of the container.

See Also

IMessageObjectPropertyContainer Interface | Aspose.Email.Formats.Outlook.Msg Namespace


Properties Property

Aspose.Email

IMessageObjectPropertyContainer.Properties Property

Gets the properties of the container.

MessageObjectPropertiesCollection Properties {get;}

Property Value

The properties.

See Also

IMessageObjectPropertyContainer Interface | Aspose.Email.Formats.Outlook.Msg Namespace


MapiGuidConstants Class

Contains several guid constants defined by MSG format specification.

For a list of all members of this type, see MapiGuidConstants Members.

System.Object
Aspose.Email.Formats.Outlook.Msg.MapiGuidConstants

public abstract sealed class MapiGuidConstants

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Formats.Outlook.Msg

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiGuidConstants Members | Aspose.Email.Formats.Outlook.Msg Namespace


MapiGuidConstants Members

MapiGuidConstants overview

Public Static Fields

PS_MAPI | Identifies PS_MAPI property set.
PS_PUBLIC_STRINGS | Identifies PS_PUBLIC_STRINGS property set.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MapiGuidConstants Class | Aspose.Email.Formats.Outlook.Msg Namespace


MapiGuidConstants Fields

The fields of the MapiGuidConstants class are listed below. For a complete list of MapiGuidConstants class members, see the MapiGuidConstants Members topic.

Public Static Fields

PS_MAPI | Identifies PS_MAPI property set.
PS_PUBLIC_STRINGS | Identifies PS_PUBLIC_STRINGS property set.

See Also

MapiGuidConstants Class | Aspose.Email.Formats.Outlook.Msg Namespace


MapiGuidConstants.PS_MAPI Field

Identifies PS_MAPI property set.

public static readonly Guid PS_MAPI;

See Also

MapiGuidConstants Class | Aspose.Email.Formats.Outlook.Msg Namespace


MapiGuidConstants.PS_PUBLIC_STRINGS Field

Identifies PS_PUBLIC_STRINGS property set.

public static readonly Guid PS_PUBLIC_STRINGS;

See Also

MapiGuidConstants Class | Aspose.Email.Formats.Outlook.Msg Namespace


MapiPropertyFlags Enumeration

Represents flags which can be set on a MAPI property.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum MapiPropertyFlags

Members

Member Name | Description | Value
PROPATTR_MANDATORY | If this flag is set for a property, that property MUST NOT be deleted from the .msg file (irrespective of which storage it is contained in) and implementations MUST return an error if any attempt is made to do so. This flag is set in circumstances where the implementation depends on that property always being present in the .msg file once it is written there. | 1
PROPATTR_READABLE | If this flag is not set on a property, that property MUST not be read from the .msg file and implementations MUST return an error if any attempt is made to read it. This flag is set on all properties unless there is an implementation-specific reason to prevent a property from being read from the .msg file. | 2
PROPATTR_WRITABLE | If this flag is not set on a property, that property MUST not be modified or deleted and implementations MUST return an error if any attempt is made to do so. This flag is set in circumstances where the implementation depends on the properties being writable. | 4

Requirements

Namespace: Aspose.Email.Formats.Outlook.Msg

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Formats.Outlook.Msg Namespace


MapiType Enumeration

Contains possible MAPI property types which can be stored with message object.

public enum MapiType

Members

Member Name | Description | Value
None | No values are set. | 0
PT_SHORT | 2 bytes, a 16-bit integer | 2
PT_LONG | 4 bytes, a 32-bit integer | 3
PT_FLOAT | 4 bytes, a 32-bit floating point number | 4
PT_DOUBLE | 8 bytes, a 64-bit floating point number | 5
PT_CURRENCY | 8 bytes, a 64-bit signed, scaled integer representation of a decimal currency value, with 4 places to the right of the decimal point | 6
PT_APPTIME | 8 bytes, a 64-bit floating point number in which the whole number part represents the number of days since December 30, 1899, and the fractional part represents the fraction of a day since midnight | 7
PT_ERROR | 4 bytes, a 32-bit integer encoding error information | 10
PT_BOOLEAN | 1 byte, restricted to 1 or 0 | 11
PT_OBJECT | The property value is a COM object | 13
PT_LONGLONG | 8 bytes, a 64-bit integer | 20
PT_UNICODE | Variable size, a string of Unicode characters in UTF-16LE encoding with terminating null character(0x0000) | 31
PT_STRING8 | Variable size, a string of multi-byte characters in externally specified encoding with terminating null character (single 0 byte). | 30
PT_SYSTIME | 8 bytes, a 64-bit integer representing the number of 100-nanosecond intervals since January 1, 1601 | 64
PT_CLSID | 16 bytes, a GUID with Data1, Data2, and Data3 fields in little-endian format | 72
PT_BINARY | Variable size, a byte array | 258
PT_MV_SHORT | Variable size, a set of PT_SHORT values. | 4098
PT_MV_LONG | Variable size, a set of PT_LONG values. | 4099
PT_MV_FLOAT | Variable size, a set of PT_FLOAT values. | 4100
PT_MV_DOUBLE | Variable size, a set of PT_DOUBLE values. | 4101
PT_MV_CURRENCY | Variable size, a set of PT_CURRENCY values. | 4102
PT_MV_APPTIME | Variable size, a set of PT_APPTIME values. | 4103
PT_MV_LONGLONG | Variable size, a set of PT_LONGLONG values. | 4116
PT_MV_UNICODE | Variable size, a set of PT_UNICODE values. | 4127
PT_MV_STRING8 | Variable size, a set of PT_STRING8 values. | 4126
PT_MV_SYSTIME | Variable size, a set of PT_SYSTIME values. | 4160
PT_MV_CLSID | Variable size, a set of PT_CLSID values. | 4168
PT_MV_BINARY | Variable size, a set of PT_BINARY values. | 4354

Requirements

Namespace: Aspose.Email.Formats.Outlook.Msg

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Formats.Outlook.Msg Namespace


MessageObject Class

Represents an Outlook message object. Evaluation limits: only 1 attachment and 1 recipient are read when message is being loaded, watermark will be added when the message is being saved.

For a list of all members of this type, see MessageObject Members.

System.Object
Aspose.Email.Formats.Outlook.Msg.MessageObject

public sealed class MessageObject : IMessageObjectPropertyContainer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Formats.Outlook.Msg

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MessageObject Members | Aspose.Email.Formats.Outlook.Msg Namespace


MessageObject Members

MessageObject overview

Public Instance Constructors

MessageObject Overloaded. Initializes a new instance of the MessageObject class.

Public Instance Properties

Attachments | Gets the attachments of the MessageObject.
Codepage | Gets the codepage used to encode/decode string properties in case PT_STRING8 type for them is used.
Properties | Gets the properties of the MessageObject.
Recipients | Gets the recipients of the MessageObject.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetIdForNamedProperty | Gets the id to be used for named property, named properties are special properties and should have their ids in range [0x8000,0xfffe] aligned starting from 0x8000 sequentally. Use this method to find the available id cause it could be hard to calculate it yourself.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Overloaded. Saves the current message object to the specified file.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MessageObject Class | Aspose.Email.Formats.Outlook.Msg Namespace


MessageObject Constructor

Initializes a new instance of the MessageObject class.

Overload List

Initializes a new instance of the MessageObject class.

public MessageObject(Stream,MessageObjectLoadFormat);

Initializes a new instance of the MessageObject class.

public MessageObject(string,MessageObjectLoadFormat);

See Also

MessageObject Class | Aspose.Email.Formats.Outlook.Msg Namespace


MessageObject Constructor (Stream, MessageObjectLoadFormat)

Initializes a new instance of the MessageObject class.

public MessageObject(
Stream stream,
MessageObjectLoadFormat loadFormat
);

Parameters

stream
The stream to initialize this object from.
loadFormat
The source format message object is stored with.

Exceptions

Exception Type | Condition
ArgumentNullException | If given stream is null.
ArgumentOutOfRangeException | If specified loadFormat is not supported.

See Also

MessageObject Class | Aspose.Email.Formats.Outlook.Msg Namespace | MessageObject Constructor Overload List


MessageObject Constructor (String, MessageObjectLoadFormat)

Initializes a new instance of the MessageObject class.

public MessageObject(
string fileName,
MessageObjectLoadFormat loadFormat
);

Parameters

fileName
Name of the file to read from.
loadFormat
The source format message object is stored with.

Remarks

In addition same set of exceptions could be thrown as for the Open call.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | If specified loadFormat is not supported.

See Also

MessageObject Class | Aspose.Email.Formats.Outlook.Msg Namespace | MessageObject Constructor Overload List


MessageObject Properties

The properties of the MessageObject class are listed below. For a complete list of MessageObject class members, see the MessageObject Members topic.

Public Instance Properties

Attachments | Gets the attachments of the MessageObject.
Codepage | Gets the codepage used to encode/decode string properties in case PT_STRING8 type for them is used.
Properties | Gets the properties of the MessageObject.
Recipients | Gets the recipients of the MessageObject.

See Also

MessageObject Class | Aspose.Email.Formats.Outlook.Msg Namespace


Attachments Property

Aspose.Email

MessageObject.Attachments Property

Gets the attachments of the MessageObject.

public MessageObjectAttachmentsCollection Attachments {get;}

Property Value

The attachments.

See Also

MessageObject Class | Aspose.Email.Formats.Outlook.Msg Namespace


Codepage Property

Aspose.Email

MessageObject.Codepage Property

Gets the codepage used to encode/decode string properties in case PT_STRING8 type for them is used.

public int Codepage {get;}

Property Value

The codepage.

See Also

MessageObject Class | Aspose.Email.Formats.Outlook.Msg Namespace


Properties Property

Aspose.Email

MessageObject.Properties Property

Gets the properties of the MessageObject.

public MessageObjectPropertiesCollection Properties {get;}

Property Value

The properties.

Implements

IMessageObjectPropertyContainer.Properties

See Also

MessageObject Class | Aspose.Email.Formats.Outlook.Msg Namespace


Recipients Property

Aspose.Email

MessageObject.Recipients Property

Gets the recipients of the MessageObject.

public MessageObjectRecipientsCollection Recipients {get;}

Property Value

The recipients.

See Also

MessageObject Class | Aspose.Email.Formats.Outlook.Msg Namespace


MessageObject Methods

The methods of the MessageObject class are listed below. For a complete list of MessageObject class members, see the MessageObject Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetIdForNamedProperty | Gets the id to be used for named property, named properties are special properties and should have their ids in range [0x8000,0xfffe] aligned starting from 0x8000 sequentally. Use this method to find the available id cause it could be hard to calculate it yourself.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Overloaded. Saves the current message object to the specified file.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MessageObject Class | Aspose.Email.Formats.Outlook.Msg Namespace


MessageObject.GetIdForNamedProperty Method

Gets the id to be used for named property, named properties are special properties and should have their ids in range [0x8000,0xfffe] aligned starting from 0x8000 sequentally. Use this method to find the available id cause it could be hard to calculate it yourself.

public int GetIdForNamedProperty();

Return Value

Available id for the named property.

See Also

MessageObject Class | Aspose.Email.Formats.Outlook.Msg Namespace


Save Method

Aspose.Email

MessageObject.Save Method

Saves the current message object to the specified stream.

Overload List

Saves the current message object to the specified stream.

public void Save(Stream,MessageObjectSaveFormat);

Saves the current message object to the specified file.

public void Save(string,MessageObjectSaveFormat);

See Also

MessageObject Class | Aspose.Email.Formats.Outlook.Msg Namespace


MessageObject.Save Method (Stream, MessageObjectSaveFormat)

Saves the current message object to the specified stream.

public void Save(
Stream stream,
MessageObjectSaveFormat format
);

Parameters

stream
The stream to write to.
format
The format of the output data.

Exceptions

Exception Type | Condition
ArgumentNullException | If stream is null.
ArgumentOutOfRangeException | If format value is not valid.

See Also

MessageObject Class | Aspose.Email.Formats.Outlook.Msg Namespace | MessageObject.Save Overload List


MessageObject.Save Method (String, MessageObjectSaveFormat)

Saves the current message object to the specified file.

public void Save(
string fileName,
MessageObjectSaveFormat format
);

Parameters

fileName
Name of the file.
format
The format of the output data.

Remarks

In addition same set of exceptions could be thrown as for the OpenWrite call.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | If format value is not valid.

See Also

MessageObject Class | Aspose.Email.Formats.Outlook.Msg Namespace | MessageObject.Save Overload List


MessageObjectAttachmentEntity Class

Represents an attachment entity.

For a list of all members of this type, see MessageObjectAttachmentEntity Members.

System.Object
Aspose.Email.Formats.Outlook.Msg.MessageObjectAttachmentEntity

public sealed class MessageObjectAttachmentEntity : IMessageObjectPropertyContainer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Formats.Outlook.Msg

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MessageObjectAttachmentEntity Members | Aspose.Email.Formats.Outlook.Msg Namespace


MessageObjectAttachmentEntity Members

MessageObjectAttachmentEntity overview

Public Instance Constructors

MessageObjectAttachmentEntity Constructor Initializes a new instance of the MessageObjectAttachmentEntity class.

Public Instance Properties

CustomAttachmentStorageData | Gets or sets the custom attachment storage data.Can be null.
EmbeddedMessage | Gets or sets the Embedded Message Object storage if present.Can be null.
Properties | Gets the attachment properties.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MessageObjectAttachmentEntity Class | Aspose.Email.Formats.Outlook.Msg Namespace


MessageObjectAttachmentEntity Constructor

Initializes a new instance of the MessageObjectAttachmentEntity class.

public MessageObjectAttachmentEntity();

See Also

MessageObjectAttachmentEntity Class | Aspose.Email.Formats.Outlook.Msg Namespace


MessageObjectAttachmentEntity Properties

The properties of the MessageObjectAttachmentEntity class are listed below. For a complete list of MessageObjectAttachmentEntity class members, see the MessageObjectAttachmentEntity Members topic.

Public Instance Properties

CustomAttachmentStorageData | Gets or sets the custom attachment storage data.Can be null.
EmbeddedMessage | Gets or sets the Embedded Message Object storage if present.Can be null.
Properties | Gets the attachment properties.

See Also

MessageObjectAttachmentEntity Class | Aspose.Email.Formats.Outlook.Msg Namespace


CustomAttachmentStorageData Property

Aspose.Email

MessageObjectAttachmentEntity.CustomAttachmentStorageData Property

Gets or sets the custom attachment storage data.Can be null.

public CustomAttachmentStorage CustomAttachmentStorageData {get; set;}

Property Value

The custom attachment storage data.

Remarks

Mutually exclusive with EmbeddedMessage or both can be null.

See Also

MessageObjectAttachmentEntity Class | Aspose.Email.Formats.Outlook.Msg Namespace


EmbeddedMessage Property

Aspose.Email

MessageObjectAttachmentEntity.EmbeddedMessage Property

Gets or sets the Embedded Message Object storage if present.Can be null.

public MessageObject EmbeddedMessage {get; set;}

Property Value

The embedded message.

Remarks

Mutually exclusive with CustomAttachmentStorageData or both can be null.

See Also

MessageObjectAttachmentEntity Class | Aspose.Email.Formats.Outlook.Msg Namespace


Properties Property

Aspose.Email

MessageObjectAttachmentEntity.Properties Property

Gets the attachment properties.

public MessageObjectPropertiesCollection Properties {get;}

Property Value

The properties collection.

Implements

IMessageObjectPropertyContainer.Properties

See Also

MessageObjectAttachmentEntity Class | Aspose.Email.Formats.Outlook.Msg Namespace


MessageObjectAttachmentsCollection Class

Represents a collection for MessageObjectAttachmentEntity objects.

For a list of all members of this type, see MessageObjectAttachmentsCollection Members.

System.Object
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Formats.Outlook.Msg.MessageObjectAttachmentEntity, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]]
Aspose.Email.Formats.Outlook.Msg.MessageObjectAttachmentsCollection

public sealed class MessageObjectAttachmentsCollection : Collection`1

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Formats.Outlook.Msg

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MessageObjectAttachmentsCollection Members | Aspose.Email.Formats.Outlook.Msg Namespace


MessageObjectAttachmentsCollection Members

MessageObjectAttachmentsCollection overview

Public Instance Constructors

MessageObjectAttachmentsCollection Constructor Initializes a new instance of the MessageObjectAttachmentsCollection class.

Public Instance Properties

Count (inherited from 0, Culture=neutral, PublicKeyToken=null]])
Item (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MessageObjectAttachmentsCollection Class | Aspose.Email.Formats.Outlook.Msg Namespace


MessageObjectAttachmentsCollection Constructor

Initializes a new instance of the MessageObjectAttachmentsCollection class.

public MessageObjectAttachmentsCollection();

See Also

MessageObjectAttachmentsCollection Class | Aspose.Email.Formats.Outlook.Msg Namespace


MessageObjectLoadFormat Enumeration

Represents available formats MessageObject could be loaded from.

public enum MessageObjectLoadFormat

Members

Member Name | Description | Value
Msg | MSG format. | 0

Requirements

Namespace: Aspose.Email.Formats.Outlook.Msg

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Formats.Outlook.Msg Namespace


MessageObjectPropertiesCollection Class

Represents a keyed collection for MessageObjectProperty objects.

For a list of all members of this type, see MessageObjectPropertiesCollection Members.

System.Object
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Formats.Outlook.Msg.MessageObjectProperty, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]]
System.Collections.ObjectModel.KeyedCollection`2[[System.Int64, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089],[Aspose.Email.Formats.Outlook.Msg.MessageObjectProperty, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]]
Aspose.Email.Formats.Outlook.Msg.MessageObjectPropertiesCollection

public sealed class MessageObjectPropertiesCollection : KeyedCollection`2

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Formats.Outlook.Msg

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MessageObjectPropertiesCollection Members | Aspose.Email.Formats.Outlook.Msg Namespace


MessageObjectPropertiesCollection Members

MessageObjectPropertiesCollection overview

Public Instance Constructors

MessageObjectPropertiesCollection Constructor Initializes a new instance of the MessageObjectPropertiesCollection class.

Public Instance Properties

Comparer (inherited from 0, Culture=neutral, PublicKeyToken=null]])
Count (inherited from 0, Culture=neutral, PublicKeyToken=null]])
Item (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) | Overloaded.
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) | Overloaded.
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) | Overloaded.
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) | Overloaded.
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.
TryGetValue | Tries to get value, by specified key.

See Also

MessageObjectPropertiesCollection Class | Aspose.Email.Formats.Outlook.Msg Namespace


MessageObjectPropertiesCollection Constructor

Initializes a new instance of the MessageObjectPropertiesCollection class.

public MessageObjectPropertiesCollection();

See Also

MessageObjectPropertiesCollection Class | Aspose.Email.Formats.Outlook.Msg Namespace


MessageObjectPropertiesCollection Methods

The methods of the MessageObjectPropertiesCollection class are listed below. For a complete list of MessageObjectPropertiesCollection class members, see the MessageObjectPropertiesCollection Members topic.

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) | Overloaded.
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) | Overloaded.
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) | Overloaded.
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) | Overloaded.
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.
TryGetValue | Tries to get value, by specified key.

See Also

MessageObjectPropertiesCollection Class | Aspose.Email.Formats.Outlook.Msg Namespace


MessageObjectPropertiesCollection.TryGetValue Method

Tries to get value, by specified key.

public MessageObjectProperty TryGetValue(
long propertyTag
);

Parameters

propertyTag
The property tag.

Return Value

MessageObjectProperty object if operation succeeds, otherwise null.

See Also

MessageObjectPropertiesCollection Class | Aspose.Email.Formats.Outlook.Msg Namespace


MessageObjectProperty Class

Represents a property on a MessageObject.

For a list of all members of this type, see MessageObjectProperty Members.

System.Object
Aspose.Email.Formats.Outlook.Msg.MessageObjectProperty

public sealed class MessageObjectProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Formats.Outlook.Msg

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MessageObjectProperty Members | Aspose.Email.Formats.Outlook.Msg Namespace


MessageObjectProperty Members

MessageObjectProperty overview

Public Instance Constructors

MessageObjectProperty Overloaded. Initializes a new instance of the MessageObjectProperty class.

Public Instance Properties

Atomic | Gets a value indicating whether this MessageObjectProperty is atomic.
Flags | Gets the flags set on a property.
Guid | Gets or sets the GUID for the named property.
Id | Gets the id of the property.
Name | Gets or sets the name of the property if it's named.
Named | Gets a value indicating whether this MessageObjectProperty is a named property.
NameId | Gets or sets the name id of the property if it's named.
PropertyKind | Gets or sets the kind of the property if it's named.
PropertyTag | Gets the property tag, a combined value which contains Id and PropertyType
PropertyType | Gets the type of the property.
Value | Gets or sets the value of the property.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToDateTime | Converts the value of the property to DateTime.
ToGuid | Converts the value of the property to Guid.
ToInt | Converts the value of the property to integer.
ToList | Converts the value of the property to a list of values.
ToString (inherited from Object) | Returns a String that represents the current Object.
ToStringRepresentation | Converts the value of the property to string.

See Also

MessageObjectProperty Class | Aspose.Email.Formats.Outlook.Msg Namespace


MessageObjectProperty Constructor

Initializes a new instance of the MapiPropertyAtomic class.

Overload List

Initializes a new instance of the MapiPropertyAtomic class.

public MessageObjectProperty(int,MapiType,MapiPropertyFlags,object);

Initializes a new instance of the MapiPropertyAtomic class.

public MessageObjectProperty(long,MapiPropertyFlags,object);

See Also

MessageObjectProperty Class | Aspose.Email.Formats.Outlook.Msg Namespace


MessageObjectProperty Constructor (Int64, MapiPropertyFlags, Object)

Initializes a new instance of the MapiPropertyAtomic class.

public MessageObjectProperty(
long propertyTag,
MapiPropertyFlags flags,
object value
);

Parameters

propertyTag
The property tag.
flags
The flags to be set on.
value
The value of the property.

Exceptions

Exception Type | Condition
ArgumentNullException | If value is null.
InvalidEnumArgumentException | If propertyTag contains invalid type definition."

See Also

MessageObjectProperty Class | Aspose.Email.Formats.Outlook.Msg Namespace | MessageObjectProperty Constructor Overload List


MessageObjectProperty Constructor (Int32, MapiType, MapiPropertyFlags, Object)

Initializes a new instance of the MapiPropertyAtomic class.

public MessageObjectProperty(
int id,
MapiType type,
MapiPropertyFlags flags,
object value
);

Parameters

id
The id.
type
The type of the property.
flags
The flags to be set on.
value
The value of the property.

Exceptions

Exception Type | Condition
ArgumentNullException | If value is null.
InvalidEnumArgumentException | If type is invalid."

See Also

MessageObjectProperty Class | Aspose.Email.Formats.Outlook.Msg Namespace | MessageObjectProperty Constructor Overload List


MessageObjectProperty Properties

The properties of the MessageObjectProperty class are listed below. For a complete list of MessageObjectProperty class members, see the MessageObjectProperty Members topic.

Public Instance Properties

Atomic | Gets a value indicating whether this MessageObjectProperty is atomic.
Flags | Gets the flags set on a property.
Guid | Gets or sets the GUID for the named property.
Id | Gets the id of the property.
Name | Gets or sets the name of the property if it's named.
Named | Gets a value indicating whether this MessageObjectProperty is a named property.
NameId | Gets or sets the name id of the property if it's named.
PropertyKind | Gets or sets the kind of the property if it's named.
PropertyTag | Gets the property tag, a combined value which contains Id and PropertyType
PropertyType | Gets the type of the property.
Value | Gets or sets the value of the property.

See Also

MessageObjectProperty Class | Aspose.Email.Formats.Outlook.Msg Namespace


Atomic Property

Aspose.Email

MessageObjectProperty.Atomic Property

Gets a value indicating whether this MessageObjectProperty is atomic.

public bool Atomic {get;}

Property Value

true if atomic; otherwise, false.

See Also

MessageObjectProperty Class | Aspose.Email.Formats.Outlook.Msg Namespace


Flags Property

Aspose.Email

MessageObjectProperty.Flags Property

Gets the flags set on a property.

public MapiPropertyFlags Flags {get;}

Property Value

The flags.

See Also

MessageObjectProperty Class | Aspose.Email.Formats.Outlook.Msg Namespace


Guid Property

Aspose.Email

MessageObjectProperty.Guid Property

Gets or sets the GUID for the named property.

public Guid Guid {get; set;}

Property Value

The GUID.

See Also

MessageObjectProperty Class | Aspose.Email.Formats.Outlook.Msg Namespace


Id Property

Aspose.Email

MessageObjectProperty.Id Property

Gets the id of the property.

public int Id {get;}

Property Value

The id if the property.

See Also

MessageObjectProperty Class | Aspose.Email.Formats.Outlook.Msg Namespace


Name Property

Aspose.Email

MessageObjectProperty.Name Property

Gets or sets the name of the property if it's named.

public string Name {get; set;}

Property Value

The name.

See Also

MessageObjectProperty Class | Aspose.Email.Formats.Outlook.Msg Namespace


Named Property

Aspose.Email

MessageObjectProperty.Named Property

Gets a value indicating whether this MessageObjectProperty is a named property.

public bool Named {get;}

Property Value

true if named; otherwise, false.

Remarks

A named property is determined by its ID, the range for such ids is [0x8000,0xfffe].

See Also

MessageObjectProperty Class | Aspose.Email.Formats.Outlook.Msg Namespace


NameId Property

Aspose.Email

MessageObjectProperty.NameId Property

Gets or sets the name id of the property if it's named.

public uint NameId {get; set;}

Property Value

The name id.

See Also

MessageObjectProperty Class | Aspose.Email.Formats.Outlook.Msg Namespace


PropertyKind Property

Aspose.Email

MessageObjectProperty.PropertyKind Property

Gets or sets the kind of the property if it's named.

public NamedPropertyKind PropertyKind {get; set;}

Property Value

The kind of the property.

See Also

MessageObjectProperty Class | Aspose.Email.Formats.Outlook.Msg Namespace


PropertyTag Property

Aspose.Email

MessageObjectProperty.PropertyTag Property

Gets the property tag, a combined value which contains Id and PropertyType

public long PropertyTag {get;}

Property Value

The property tag.

See Also

MessageObjectProperty Class | Aspose.Email.Formats.Outlook.Msg Namespace


PropertyType Property

Aspose.Email

MessageObjectProperty.PropertyType Property

Gets the type of the property.

public MapiType PropertyType {get;}

Property Value

The type of the property.

See Also

MessageObjectProperty Class | Aspose.Email.Formats.Outlook.Msg Namespace


Value Property

Aspose.Email

MessageObjectProperty.Value Property

Gets or sets the value of the property.

public object Value {get; set;}

Property Value

The value.

Exceptions

Exception Type | Condition
ArgumentNullException | If passed value is null.

See Also

MessageObjectProperty Class | Aspose.Email.Formats.Outlook.Msg Namespace


MessageObjectProperty Methods

The methods of the MessageObjectProperty class are listed below. For a complete list of MessageObjectProperty class members, see the MessageObjectProperty Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToDateTime | Converts the value of the property to DateTime.
ToGuid | Converts the value of the property to Guid.
ToInt | Converts the value of the property to integer.
ToList | Converts the value of the property to a list of values.
ToString (inherited from Object) | Returns a String that represents the current Object.
ToStringRepresentation | Converts the value of the property to string.

See Also

MessageObjectProperty Class | Aspose.Email.Formats.Outlook.Msg Namespace


MessageObjectProperty.ToDateTime Method

Converts the value of the property to DateTime.

public DateTime ToDateTime();

Return Value

DateTime value, if type can't be converted to DateTime returns MinValue.

Remarks

This method doesn't provide automatic conversion of the data types, e.g. if Value property is of type default value will be returned.

See Also

MessageObjectProperty Class | Aspose.Email.Formats.Outlook.Msg Namespace


MessageObjectProperty.ToGuid Method

Converts the value of the property to Guid.

public Guid ToGuid();

Return Value

Guid object, if type can't be converted to Guid returns empty guid.

Remarks

This method doesn't provide automatic conversion of the data types, e.g. if Value property is of type default value will be returned.

See Also

MessageObjectProperty Class | Aspose.Email.Formats.Outlook.Msg Namespace


MessageObjectProperty.ToInt Method

Converts the value of the property to integer.

public int ToInt();

Return Value

Integer value, if type can't be converted to integer returns 0.

See Also

MessageObjectProperty Class | Aspose.Email.Formats.Outlook.Msg Namespace


MessageObjectProperty.ToList Method

Converts the value of the property to a list of values.

public IList ToList();

Return Value

IList implementation, if type can't be converted to IList returns empty list implementation.

Remarks

This method doesn't provide automatic conversion of the data types, e.g. if Value property is of type default value will be returned.

See Also

MessageObjectProperty Class | Aspose.Email.Formats.Outlook.Msg Namespace


MessageObjectProperty.ToStringRepresentation Method

Converts the value of the property to string.

public string ToStringRepresentation();

Return Value

String value, if type can't be converted to string returns empty string.

Remarks

This method doesn't provide automatic conversion of the data types, e.g. if Value property is of type default value will be returned.

See Also

MessageObjectProperty Class | Aspose.Email.Formats.Outlook.Msg Namespace


MessageObjectRecipientEntity Class

Represens a recipient entry in message object.

For a list of all members of this type, see MessageObjectRecipientEntity Members.

System.Object
Aspose.Email.Formats.Outlook.Msg.MessageObjectRecipientEntity

public class MessageObjectRecipientEntity : IMessageObjectPropertyContainer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Formats.Outlook.Msg

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MessageObjectRecipientEntity Members | Aspose.Email.Formats.Outlook.Msg Namespace


MessageObjectRecipientEntity Members

MessageObjectRecipientEntity overview

Public Instance Constructors

MessageObjectRecipientEntity Constructor Initializes a new instance of the MessageObjectRecipientEntity class.

Public Instance Properties

Properties Gets the properties set on the recipient.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MessageObjectRecipientEntity Class | Aspose.Email.Formats.Outlook.Msg Namespace


MessageObjectRecipientEntity Constructor

Initializes a new instance of the MessageObjectRecipientEntity class.

public MessageObjectRecipientEntity();

See Also

MessageObjectRecipientEntity Class | Aspose.Email.Formats.Outlook.Msg Namespace


MessageObjectRecipientEntity Properties

The properties of the MessageObjectRecipientEntity class are listed below. For a complete list of MessageObjectRecipientEntity class members, see the MessageObjectRecipientEntity Members topic.

Public Instance Properties

Properties Gets the properties set on the recipient.

See Also

MessageObjectRecipientEntity Class | Aspose.Email.Formats.Outlook.Msg Namespace


Properties Property

Aspose.Email

MessageObjectRecipientEntity.Properties Property

Gets the properties set on the recipient.

public MessageObjectPropertiesCollection Properties {get;}

Property Value

The properties.

Implements

IMessageObjectPropertyContainer.Properties

See Also

MessageObjectRecipientEntity Class | Aspose.Email.Formats.Outlook.Msg Namespace


MessageObjectRecipientsCollection Class

Represents a collection for MessageObjectRecipientEntity objects.

For a list of all members of this type, see MessageObjectRecipientsCollection Members.

System.Object
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Formats.Outlook.Msg.MessageObjectRecipientEntity, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]]
Aspose.Email.Formats.Outlook.Msg.MessageObjectRecipientsCollection

public sealed class MessageObjectRecipientsCollection : Collection`1

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Formats.Outlook.Msg

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MessageObjectRecipientsCollection Members | Aspose.Email.Formats.Outlook.Msg Namespace


MessageObjectRecipientsCollection Members

MessageObjectRecipientsCollection overview

Public Instance Constructors

MessageObjectRecipientsCollection Constructor Initializes a new instance of the MessageObjectRecipientsCollection class.

Public Instance Properties

Count (inherited from 0, Culture=neutral, PublicKeyToken=null]])
Item (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MessageObjectRecipientsCollection Class | Aspose.Email.Formats.Outlook.Msg Namespace


MessageObjectRecipientsCollection Constructor

Initializes a new instance of the MessageObjectRecipientsCollection class.

public MessageObjectRecipientsCollection();

See Also

MessageObjectRecipientsCollection Class | Aspose.Email.Formats.Outlook.Msg Namespace


MessageObjectSaveFormat Enumeration

Represents available formats MessageObject could be saved to.

public enum MessageObjectSaveFormat

Members

Member Name | Description | Value
Msg | MSG format. | 0

Requirements

Namespace: Aspose.Email.Formats.Outlook.Msg

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Formats.Outlook.Msg Namespace


NamedPropertyKind Enumeration

Identifies MessageObjectProperty kind.

public enum NamedPropertyKind

Members

Member Name | Description | Value
Numerical | Property has name id. | 0
String | Property has string name. | 1

Requirements

Namespace: Aspose.Email.Formats.Outlook.Msg

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Formats.Outlook.Msg Namespace


Aspose.Email.Formats.VCard

Aspose.Email

Aspose.Email.Formats.VCard Namespace

Namespace hierarchy

Classes

Class | Description
VCardAgent | Represents a vCard Agent property
VCardContact | Represents a vCard contact
VCardDeliveryAddress | Represents a vCard delivery address
VCardDeliveryAddressCollection | Represents a collection of VCardDeliveryAddresses
VCardEmail | Represents vCard email
VCardEmailCollection | Represents a collection of VCardEmails
VCardExplanatoryInfo | Represents vCard explanatory properties
VCardFullName | Represents vCard contact full name (N property)
VCardGeo | Represents a global positioning of vCard contact
VCardIdentificationInfo | Represents vCard identification information
VCardOrganization | Represents vCard organization properties
VCardPhoto | Represents vCard photo property
VCardSaveOptions | Represents vCard save options
VCardSecurity | Represents a vCard security properties
VCardSound | Represents a vCard sound property
VCardTelephoneNumber | Represents a vCard telephone number
VCardTelephoneNumberCollection | Represents a collection of VCardTelephoneNumbers
VCardUrl | Represents a vCard URL property
VCardUrlCollection | Represents a collection of VCardUrls

Enumerations

Enumeration | Description
VCardDeliveryAddressType | Enumerates a vCard delivery address types
VCardEmailType | Enumerates vCard email types
VCardPhotoType | Enumerates vCard photo type
VCardSoundType | Enumerates a cVard sound types
VCardTelephoneType | Enumerates a vCard telephone types
VCardUrlType | Enumerates url type
VCardValueLocation | Enumerates the vCard property parameter ValueLocation.
VCardVersion | Enumerates vCard version


VCardAgent Class

Represents a vCard Agent property

For a list of all members of this type, see VCardAgent Members.

System.Object
Aspose.Email.Formats.VCard.VCardAgent

public sealed class VCardAgent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Formats.VCard

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

VCardAgent Members | Aspose.Email.Formats.VCard Namespace


VCardAgent Members

VCardAgent overview

Public Instance Constructors

VCardAgent Constructor Initializes a new instance of the VCardAgent class

Public Instance Properties

AgentCard | Gets or sets an agent's card (null if ValueLocation is not INLINE)
Uri | Gets or sets a uri of agent card (null if ValueLocation is INLINE)
ValueLocation | Gets or sets a value location

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

VCardAgent Class | Aspose.Email.Formats.VCard Namespace


VCardAgent Constructor

Initializes a new instance of the VCardAgent class

public VCardAgent();

See Also

VCardAgent Class | Aspose.Email.Formats.VCard Namespace


VCardAgent Properties

The properties of the VCardAgent class are listed below. For a complete list of VCardAgent class members, see the VCardAgent Members topic.

Public Instance Properties

AgentCard | Gets or sets an agent's card (null if ValueLocation is not INLINE)
Uri | Gets or sets a uri of agent card (null if ValueLocation is INLINE)
ValueLocation | Gets or sets a value location

See Also

VCardAgent Class | Aspose.Email.Formats.VCard Namespace


AgentCard Property

Aspose.Email

VCardAgent.AgentCard Property

Gets or sets an agent's card (null if ValueLocation is not INLINE)

public VCardContact AgentCard {get; set;}

See Also

VCardAgent Class | Aspose.Email.Formats.VCard Namespace


Uri Property

Aspose.Email

VCardAgent.Uri Property

Gets or sets a uri of agent card (null if ValueLocation is INLINE)

public string Uri {get; set;}

See Also

VCardAgent Class | Aspose.Email.Formats.VCard Namespace


ValueLocation Property

Aspose.Email

VCardAgent.ValueLocation Property

Gets or sets a value location

public VCardValueLocation ValueLocation {get; set;}

See Also

VCardAgent Class | Aspose.Email.Formats.VCard Namespace


VCardContact Class

Represents a vCard contact

For a list of all members of this type, see VCardContact Members.

System.Object
Aspose.Email.Formats.VCard.VCardContact

public sealed class VCardContact

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Formats.VCard

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

VCardContact Members | Aspose.Email.Formats.VCard Namespace


VCardContact Members

VCardContact overview

Public Static Methods

Load Overloaded. Reads VCardContact from the specified vCard file The supported vCard versions are 2.1 and 3.0

Public Instance Constructors

VCardContact Constructor Initializes a new instance of the VCardContact class

Public Instance Properties

DeliveryAddresses | Gets or sets a delivery addresses
Emails | Gets or sets a contact's email addresses
ExplanatoryInfo | Gets or sets a vCard explanatory information
ExtendedProperties | Gets or sets an extended properties
Geo | Gets or sets a global positioning
IdentificationInfo | Gets or sets an identification properties
Mailer | Gets or sets a mailer
Organization | Gets or sets an organization information
Security | Gets or sets a security properites
TelephoneNumbers | Gets or sets a contact's telephone numbers
TimeZone | Gets or sets a timeZone

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Overloaded. Saves this MapiContact to the vCard file with a default options. The supported vCard version is 2.1
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

VCardContact Class | Aspose.Email.Formats.VCard Namespace


VCardContact Constructor

Initializes a new instance of the VCardContact class

public VCardContact();

See Also

VCardContact Class | Aspose.Email.Formats.VCard Namespace


VCardContact Properties

The properties of the VCardContact class are listed below. For a complete list of VCardContact class members, see the VCardContact Members topic.

Public Instance Properties

DeliveryAddresses | Gets or sets a delivery addresses
Emails | Gets or sets a contact's email addresses
ExplanatoryInfo | Gets or sets a vCard explanatory information
ExtendedProperties | Gets or sets an extended properties
Geo | Gets or sets a global positioning
IdentificationInfo | Gets or sets an identification properties
Mailer | Gets or sets a mailer
Organization | Gets or sets an organization information
Security | Gets or sets a security properites
TelephoneNumbers | Gets or sets a contact's telephone numbers
TimeZone | Gets or sets a timeZone

See Also

VCardContact Class | Aspose.Email.Formats.VCard Namespace


DeliveryAddresses Property

Aspose.Email

VCardContact.DeliveryAddresses Property

Gets or sets a delivery addresses

public VCardDeliveryAddressCollection DeliveryAddresses {get; set;}

See Also

VCardContact Class | Aspose.Email.Formats.VCard Namespace


Emails Property

Aspose.Email

VCardContact.Emails Property

Gets or sets a contact's email addresses

public VCardEmailCollection Emails {get; set;}

See Also

VCardContact Class | Aspose.Email.Formats.VCard Namespace


ExplanatoryInfo Property

Aspose.Email

VCardContact.ExplanatoryInfo Property

Gets or sets a vCard explanatory information

public VCardExplanatoryInfo ExplanatoryInfo {get; set;}

See Also

VCardContact Class | Aspose.Email.Formats.VCard Namespace


ExtendedProperties Property

Aspose.Email

VCardContact.ExtendedProperties Property

Gets or sets an extended properties

public StringCollection ExtendedProperties {get; set;}

See Also

VCardContact Class | Aspose.Email.Formats.VCard Namespace


Geo Property

Aspose.Email

VCardContact.Geo Property

Gets or sets a global positioning

public VCardGeo Geo {get; set;}

See Also

VCardContact Class | Aspose.Email.Formats.VCard Namespace


IdentificationInfo Property

Aspose.Email

VCardContact.IdentificationInfo Property

Gets or sets an identification properties

public VCardIdentificationInfo IdentificationInfo {get; set;}

See Also

VCardContact Class | Aspose.Email.Formats.VCard Namespace


Mailer Property

Aspose.Email

VCardContact.Mailer Property

Gets or sets a mailer

public string Mailer {get; set;}

See Also

VCardContact Class | Aspose.Email.Formats.VCard Namespace


Organization Property

Aspose.Email

VCardContact.Organization Property

Gets or sets an organization information

public VCardOrganization Organization {get; set;}

See Also

VCardContact Class | Aspose.Email.Formats.VCard Namespace


Security Property

Aspose.Email

VCardContact.Security Property

Gets or sets a security properites

public VCardSecurity Security {get; set;}

See Also

VCardContact Class | Aspose.Email.Formats.VCard Namespace


TelephoneNumbers Property

Aspose.Email

VCardContact.TelephoneNumbers Property

Gets or sets a contact's telephone numbers

public VCardTelephoneNumberCollection TelephoneNumbers {get; set;}

See Also

VCardContact Class | Aspose.Email.Formats.VCard Namespace


TimeZone Property

Aspose.Email

VCardContact.TimeZone Property

Gets or sets a timeZone

public string TimeZone {get; set;}

See Also

VCardContact Class | Aspose.Email.Formats.VCard Namespace


VCardContact Methods

The methods of the VCardContact class are listed below. For a complete list of VCardContact class members, see the VCardContact Members topic.

Public Static Methods

Load Overloaded. Reads VCardContact from the specified vCard file The supported vCard versions are 2.1 and 3.0

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Overloaded. Saves this MapiContact to the vCard file with a default options. The supported vCard version is 2.1
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

VCardContact Class | Aspose.Email.Formats.VCard Namespace


Load Method

Aspose.Email

VCardContact.Load Method

Reads VCardContact from the specified stream containing vCard. The supported vCard versions are 2.1 and 3.0

Overload List

Reads VCardContact from the specified stream containing vCard. The supported vCard versions are 2.1 and 3.0

public static VCardContact Load(Stream);

Reads VCardContact from the specified stream containing vCard. The supported vCard versions are 2.1 and 3.0

public static VCardContact Load(Stream,Encoding);

Reads VCardContact from the specified vCard file The supported vCard versions are 2.1 and 3.0

public static VCardContact Load(string);

Reads VCardContact from the specified vCard file The supported vCard versions are 2.1 and 3.0

public static VCardContact Load(string,Encoding);

See Also

VCardContact Class | Aspose.Email.Formats.VCard Namespace


VCardContact.Load Method (Stream)

Reads VCardContact from the specified stream containing vCard. The supported vCard versions are 2.1 and 3.0

public static VCardContact Load(
Stream stream
);

Parameters

stream
A stream to read from

Return Value

A read VCardContact

Exceptions

Exception Type | Condition
ArgumentNullException | stream is null
NotSupportedException | stream does not support reading

See Also

VCardContact Class | Aspose.Email.Formats.VCard Namespace | VCardContact.Load Overload List


VCardContact.Load Method (Stream, Encoding)

Reads VCardContact from the specified stream containing vCard. The supported vCard versions are 2.1 and 3.0

public static VCardContact Load(
Stream stream,
Encoding encoding
);

Parameters

stream
A stream to read from
encoding
Stream data encoding

Return Value

A read VCardContact

Exceptions

Exception Type | Condition
ArgumentNullException | stream is null
NotSupportedException | stream does not support reading

See Also

VCardContact Class | Aspose.Email.Formats.VCard Namespace | VCardContact.Load Overload List


VCardContact.Load Method (String)

Reads VCardContact from the specified vCard file The supported vCard versions are 2.1 and 3.0

public static VCardContact Load(
string filePath
);

Parameters

filePath
A file name to read from

Return Value

A read VCardContact

Exceptions

Exception Type | Condition
ArgumentException | filePath is null or empty

See Also

VCardContact Class | Aspose.Email.Formats.VCard Namespace | VCardContact.Load Overload List


VCardContact.Load Method (String, Encoding)

Reads VCardContact from the specified vCard file The supported vCard versions are 2.1 and 3.0

public static VCardContact Load(
string filePath,
Encoding encoding
);

Parameters

filePath
A file name to read from
encoding
File encoding

Return Value

A read VCardContact

Exceptions

Exception Type | Condition
ArgumentException | filePath is null or empty

See Also

VCardContact Class | Aspose.Email.Formats.VCard Namespace | VCardContact.Load Overload List


Save Method

Aspose.Email

VCardContact.Save Method

Saves this MapiContact into the given stream with vCard format. The supported vCard version is 2.1

Overload List

Saves this MapiContact into the given stream with vCard format. The supported vCard version is 2.1

public void Save(Stream);

Saves this MapiContact to the given stream with a format using the default options. The supported save format is vCard

public void Save(Stream,ContactSaveFormat);

Saves this MapiContact to the given stream using specified save options. The supported save options is VCardSaveOptions

public void Save(Stream,ContactSaveOptions);

Saves this MapiContact to the vCard file with a default options. The supported vCard version is 2.1

public void Save(string);

Saves this MapiContact to the specified file with a format using the default options. The supported save format is vCard.

public void Save(string,ContactSaveFormat);

Saves this MapiContact into file using specified save options. The supported save options is VCardSaveOptions

public void Save(string,ContactSaveOptions);

See Also

VCardContact Class | Aspose.Email.Formats.VCard Namespace


VCardContact.Save Method (Stream)

Saves this MapiContact into the given stream with vCard format. The supported vCard version is 2.1

public void Save(
Stream stream
);

Parameters

stream
A stream to save to

Exceptions

Exception Type | Condition
ArgumentNullException | stream is null
NotSupportedException | stream does not support writing

See Also

VCardContact Class | Aspose.Email.Formats.VCard Namespace | VCardContact.Save Overload List


VCardContact.Save Method (Stream, ContactSaveFormat)

Saves this MapiContact to the given stream with a format using the default options. The supported save format is vCard

public void Save(
Stream stream,
ContactSaveFormat saveFormat
);

Parameters

stream
A stream to save to
saveFormat
A save format

Exceptions

Exception Type | Condition
ArgumentNullException | stream is null
NotSupportedException | stream does not support writing
NotSupportedException | The specified format is not supported

See Also

VCardContact Class | Aspose.Email.Formats.VCard Namespace | VCardContact.Save Overload List


VCardContact.Save Method (Stream, ContactSaveOptions)

Saves this MapiContact to the given stream using specified save options. The supported save options is VCardSaveOptions

public void Save(
Stream stream,
ContactSaveOptions saveOptions
);

Parameters

stream
A stream to save to
saveOptions
A save options

Exceptions

Exception Type | Condition
ArgumentNullException | stream or saveOptions is null
NotSupportedException | stream does not support writing
ArgumentException | incorrect saveOptions
NotSupportedException | some save option is not supported

See Also

VCardContact Class | Aspose.Email.Formats.VCard Namespace | VCardContact.Save Overload List


VCardContact.Save Method (String)

Saves this MapiContact to the vCard file with a default options. The supported vCard version is 2.1

public void Save(
string filePath
);

Parameters

filePath
A vCard file name

Exceptions

Exception Type | Condition
ArgumentException | filePath is null or empty

See Also

VCardContact Class | Aspose.Email.Formats.VCard Namespace | VCardContact.Save Overload List


VCardContact.Save Method (String, ContactSaveFormat)

Saves this MapiContact to the specified file with a format using the default options. The supported save format is vCard.

public void Save(
string filePath,
ContactSaveFormat saveFormat
);

Parameters

filePath
A vCard file name
saveFormat
A save format

Exceptions

Exception Type | Condition
ArgumentException | filePath is null or empty
NotSupportedException | the specified format is not supported

See Also

VCardContact Class | Aspose.Email.Formats.VCard Namespace | VCardContact.Save Overload List


VCardContact.Save Method (String, ContactSaveOptions)

Saves this MapiContact into file using specified save options. The supported save options is VCardSaveOptions

public void Save(
string filePath,
ContactSaveOptions saveOptions
);

Parameters

filePath
A vCard file name
saveOptions
A save options

Exceptions

Exception Type | Condition
ArgumentException | filePath is null or empty
ArgumentNullException | saveOptions is null
NotSupportedException | some save option is not supported

See Also

VCardContact Class | Aspose.Email.Formats.VCard Namespace | VCardContact.Save Overload List


VCardDeliveryAddress Class

Represents a vCard delivery address

For a list of all members of this type, see VCardDeliveryAddress Members.

System.Object
Aspose.Email.Formats.VCard.VCardDeliveryAddress

public sealed class VCardDeliveryAddress

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Formats.VCard

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

VCardDeliveryAddress Members | Aspose.Email.Formats.VCard Namespace


VCardDeliveryAddress Members

VCardDeliveryAddress overview

Public Instance Constructors

VCardDeliveryAddress Constructor Initializes a new instance of the VCardDeliveryAddress class

Public Instance Properties

AddressType | Gets or sets an address type
CountryName | Gets or sets a country
ExtendedAddress | Gets or sets an extended address
Locality | Gets or sets a locality
PoBox | Gets or sets a PO box
PostalCode | Gets or sets a postal code
Region | Gets or sets a region
Street | Gets or sets a street

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

VCardDeliveryAddress Class | Aspose.Email.Formats.VCard Namespace


VCardDeliveryAddress Constructor

Initializes a new instance of the VCardDeliveryAddress class

public VCardDeliveryAddress();

See Also

VCardDeliveryAddress Class | Aspose.Email.Formats.VCard Namespace


VCardDeliveryAddress Properties

The properties of the VCardDeliveryAddress class are listed below. For a complete list of VCardDeliveryAddress class members, see the VCardDeliveryAddress Members topic.

Public Instance Properties

AddressType | Gets or sets an address type
CountryName | Gets or sets a country
ExtendedAddress | Gets or sets an extended address
Locality | Gets or sets a locality
PoBox | Gets or sets a PO box
PostalCode | Gets or sets a postal code
Region | Gets or sets a region
Street | Gets or sets a street

See Also

VCardDeliveryAddress Class | Aspose.Email.Formats.VCard Namespace


AddressType Property

Aspose.Email

VCardDeliveryAddress.AddressType Property

Gets or sets an address type

public VCardDeliveryAddressType AddressType {get; set;}

See Also

VCardDeliveryAddress Class | Aspose.Email.Formats.VCard Namespace


CountryName Property

Aspose.Email

VCardDeliveryAddress.CountryName Property

Gets or sets a country

public string CountryName {get; set;}

See Also

VCardDeliveryAddress Class | Aspose.Email.Formats.VCard Namespace


ExtendedAddress Property

Aspose.Email

VCardDeliveryAddress.ExtendedAddress Property

Gets or sets an extended address

public string ExtendedAddress {get; set;}

See Also

VCardDeliveryAddress Class | Aspose.Email.Formats.VCard Namespace


Locality Property

Aspose.Email

VCardDeliveryAddress.Locality Property

Gets or sets a locality

public string Locality {get; set;}

See Also

VCardDeliveryAddress Class | Aspose.Email.Formats.VCard Namespace


PoBox Property

Aspose.Email

VCardDeliveryAddress.PoBox Property

Gets or sets a PO box

public string PoBox {get; set;}

See Also

VCardDeliveryAddress Class | Aspose.Email.Formats.VCard Namespace


PostalCode Property

Aspose.Email

VCardDeliveryAddress.PostalCode Property

Gets or sets a postal code

public string PostalCode {get; set;}

See Also

VCardDeliveryAddress Class | Aspose.Email.Formats.VCard Namespace


Region Property

Aspose.Email

VCardDeliveryAddress.Region Property

Gets or sets a region

public string Region {get; set;}

See Also

VCardDeliveryAddress Class | Aspose.Email.Formats.VCard Namespace


Street Property

Aspose.Email

VCardDeliveryAddress.Street Property

Gets or sets a street

public string Street {get; set;}

See Also

VCardDeliveryAddress Class | Aspose.Email.Formats.VCard Namespace


VCardDeliveryAddressCollection Class

Represents a collection of VCardDeliveryAddresses

For a list of all members of this type, see VCardDeliveryAddressCollection Members.

System.Object
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Formats.VCard.VCardDeliveryAddress, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]]
Aspose.Email.Formats.VCard.VCardDeliveryAddressCollection

public sealed class VCardDeliveryAddressCollection : Collection`1

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Formats.VCard

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

VCardDeliveryAddressCollection Members | Aspose.Email.Formats.VCard Namespace


VCardDeliveryAddressCollection Members

VCardDeliveryAddressCollection overview

Public Instance Constructors

VCardDeliveryAddressCollection Constructor Initializes a new instance of the VCardDeliveryAddressCollection class.

Public Instance Properties

Count (inherited from 0, Culture=neutral, PublicKeyToken=null]])
Item (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

VCardDeliveryAddressCollection Class | Aspose.Email.Formats.VCard Namespace


VCardDeliveryAddressCollection Constructor

Initializes a new instance of the VCardDeliveryAddressCollection class.

public VCardDeliveryAddressCollection();

See Also

VCardDeliveryAddressCollection Class | Aspose.Email.Formats.VCard Namespace


VCardDeliveryAddressType Enumeration

Enumerates a vCard delivery address types

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum VCardDeliveryAddressType

Members

Member Name | Description | Value
None | No values are set. | 0
POSTAL | A postal delivery address | 1
PREF | A preferred delivery address | 2
DOM | A domestic address | 4
PARCEL | A parcel delivery address | 8
HOME | A home delivery address | 16
WORK | A work delivery address | 32
INTL | An international address | 64

Requirements

Namespace: Aspose.Email.Formats.VCard

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Formats.VCard Namespace


VCardEmail Class

Represents vCard email

For a list of all members of this type, see VCardEmail Members.

System.Object
Aspose.Email.Formats.VCard.VCardEmail

public sealed class VCardEmail

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Formats.VCard

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

VCardEmail Members | Aspose.Email.Formats.VCard Namespace


VCardEmail Members

VCardEmail overview

Public Instance Constructors

VCardEmail Constructor Initializes a new instance of the VCardEmail class

Public Instance Properties

EmailAddress | Gets or sets an email address
EmailType | Gets or sets an email address type

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

VCardEmail Class | Aspose.Email.Formats.VCard Namespace


VCardEmail Constructor

Initializes a new instance of the VCardEmail class

public VCardEmail();

See Also

VCardEmail Class | Aspose.Email.Formats.VCard Namespace


VCardEmail Properties

The properties of the VCardEmail class are listed below. For a complete list of VCardEmail class members, see the VCardEmail Members topic.

Public Instance Properties

EmailAddress | Gets or sets an email address
EmailType | Gets or sets an email address type

See Also

VCardEmail Class | Aspose.Email.Formats.VCard Namespace


EmailAddress Property

Aspose.Email

VCardEmail.EmailAddress Property

Gets or sets an email address

public string EmailAddress {get; set;}

See Also

VCardEmail Class | Aspose.Email.Formats.VCard Namespace


EmailType Property

Aspose.Email

VCardEmail.EmailType Property

Gets or sets an email address type

public VCardEmailType EmailType {get; set;}

Exceptions

Exception Type | Condition
ArgumentException | value is not defined in the VCardEmailType

See Also

VCardEmail Class | Aspose.Email.Formats.VCard Namespace


VCardEmailCollection Class

Represents a collection of VCardEmails

For a list of all members of this type, see VCardEmailCollection Members.

System.Object
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Formats.VCard.VCardEmail, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]]
Aspose.Email.Formats.VCard.VCardEmailCollection

public sealed class VCardEmailCollection : Collection`1

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Formats.VCard

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

VCardEmailCollection Members | Aspose.Email.Formats.VCard Namespace


VCardEmailCollection Members

VCardEmailCollection overview

Public Instance Constructors

VCardEmailCollection Constructor Initializes a new instance of the VCardEmailCollection class.

Public Instance Properties

Count (inherited from 0, Culture=neutral, PublicKeyToken=null]])
Item (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

VCardEmailCollection Class | Aspose.Email.Formats.VCard Namespace


VCardEmailCollection Constructor

Initializes a new instance of the VCardEmailCollection class.

public VCardEmailCollection();

See Also

VCardEmailCollection Class | Aspose.Email.Formats.VCard Namespace


VCardEmailType Enumeration

Enumerates vCard email types

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum VCardEmailType

Members

Member Name | Description | Value
None | No values are set. | 0
INTERNET | An internet | 1
PREF | An prefered address | 2
AOL | An america On-Line | 4
ATTMAIL | An AT&T Mail | 8
CIS | A CompuServe Information Service | 16
EWORLD | An eWorld type | 32
IBMMAIL | An IBM Mail | 64
MCIMAIL | A MCI Mail | 128
POWERSHARE | A PowerShare | 256
PRODIGY | A prodigy information service | 512
TLX | A telex number | 1024
X400 | A X.400 service | 2048
IM | An instant messaging address | 4096
APPLELINK | An AppleLink | 8192

Requirements

Namespace: Aspose.Email.Formats.VCard

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Formats.VCard Namespace


VCardExplanatoryInfo Class

Represents vCard explanatory properties

For a list of all members of this type, see VCardExplanatoryInfo Members.

System.Object
Aspose.Email.Formats.VCard.VCardExplanatoryInfo

public sealed class VCardExplanatoryInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Formats.VCard

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

VCardExplanatoryInfo Members | Aspose.Email.Formats.VCard Namespace


VCardExplanatoryInfo Members

VCardExplanatoryInfo overview

Public Instance Constructors

VCardExplanatoryInfo Constructor Initializes a new instance of the VCardExplanatoryInfo class

Public Instance Properties

Categories | Gets or sets a categories information
Note | Gets or sets a comments
ProdId | Gets an id of product that created a vCard
Revision | Gets or sets a revision time
SortString | Gets or sets a sort string
Sound | Gets or sets a sound
Uid | Gets or sets a unique identifier
Urls | Gets or sets a urls
Version | Gets a vCard version

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

VCardExplanatoryInfo Class | Aspose.Email.Formats.VCard Namespace


VCardExplanatoryInfo Constructor

Initializes a new instance of the VCardExplanatoryInfo class

public VCardExplanatoryInfo();

See Also

VCardExplanatoryInfo Class | Aspose.Email.Formats.VCard Namespace


VCardExplanatoryInfo Properties

The properties of the VCardExplanatoryInfo class are listed below. For a complete list of VCardExplanatoryInfo class members, see the VCardExplanatoryInfo Members topic.

Public Instance Properties

Categories | Gets or sets a categories information
Note | Gets or sets a comments
ProdId | Gets an id of product that created a vCard
Revision | Gets or sets a revision time
SortString | Gets or sets a sort string
Sound | Gets or sets a sound
Uid | Gets or sets a unique identifier
Urls | Gets or sets a urls
Version | Gets a vCard version

See Also

VCardExplanatoryInfo Class | Aspose.Email.Formats.VCard Namespace


Categories Property

Aspose.Email

VCardExplanatoryInfo.Categories Property

Gets or sets a categories information

public StringCollection Categories {get; set;}

See Also

VCardExplanatoryInfo Class | Aspose.Email.Formats.VCard Namespace


Note Property

Aspose.Email

VCardExplanatoryInfo.Note Property

Gets or sets a comments

public string Note {get; set;}

See Also

VCardExplanatoryInfo Class | Aspose.Email.Formats.VCard Namespace


ProdId Property

Aspose.Email

VCardExplanatoryInfo.ProdId Property

Gets an id of product that created a vCard

public string ProdId {get;}

See Also

VCardExplanatoryInfo Class | Aspose.Email.Formats.VCard Namespace


Revision Property

Aspose.Email

VCardExplanatoryInfo.Revision Property

Gets or sets a revision time

public DateTime Revision {get; set;}

See Also

VCardExplanatoryInfo Class | Aspose.Email.Formats.VCard Namespace


SortString Property

Aspose.Email

VCardExplanatoryInfo.SortString Property

Gets or sets a sort string

public string SortString {get; set;}

See Also

VCardExplanatoryInfo Class | Aspose.Email.Formats.VCard Namespace


Sound Property

Aspose.Email

VCardExplanatoryInfo.Sound Property

Gets or sets a sound

public VCardSound Sound {get; set;}

See Also

VCardExplanatoryInfo Class | Aspose.Email.Formats.VCard Namespace


Uid Property

Aspose.Email

VCardExplanatoryInfo.Uid Property

Gets or sets a unique identifier

public string Uid {get; set;}

See Also

VCardExplanatoryInfo Class | Aspose.Email.Formats.VCard Namespace


Urls Property

Aspose.Email

VCardExplanatoryInfo.Urls Property

Gets or sets a urls

public VCardUrlCollection Urls {get; set;}

See Also

VCardExplanatoryInfo Class | Aspose.Email.Formats.VCard Namespace


Version Property

Aspose.Email

VCardExplanatoryInfo.Version Property

Gets a vCard version

public string Version {get;}

See Also

VCardExplanatoryInfo Class | Aspose.Email.Formats.VCard Namespace


VCardFullName Class

Represents vCard contact full name (N property)

For a list of all members of this type, see VCardFullName Members.

System.Object
Aspose.Email.Formats.VCard.VCardFullName

public sealed class VCardFullName

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Formats.VCard

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

VCardFullName Members | Aspose.Email.Formats.VCard Namespace


VCardFullName Members

VCardFullName overview

Public Instance Constructors

VCardFullName Constructor Initializes a new instance of the VCardFullName class

Public Instance Properties

FamilyName | Gets or sets a family name
GivenName | Gets or sets a given name
HonorificPostfixes | Gets or sets a honorific postfixes
HonorificPrefixes | Gets or sets a honorific prefixes
MiddleName | Gets or sets a middle name

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

VCardFullName Class | Aspose.Email.Formats.VCard Namespace


VCardFullName Constructor

Initializes a new instance of the VCardFullName class

public VCardFullName();

See Also

VCardFullName Class | Aspose.Email.Formats.VCard Namespace


VCardFullName Properties

The properties of the VCardFullName class are listed below. For a complete list of VCardFullName class members, see the VCardFullName Members topic.

Public Instance Properties

FamilyName | Gets or sets a family name
GivenName | Gets or sets a given name
HonorificPostfixes | Gets or sets a honorific postfixes
HonorificPrefixes | Gets or sets a honorific prefixes
MiddleName | Gets or sets a middle name

See Also

VCardFullName Class | Aspose.Email.Formats.VCard Namespace


FamilyName Property

Aspose.Email

VCardFullName.FamilyName Property

Gets or sets a family name

public string FamilyName {get; set;}

See Also

VCardFullName Class | Aspose.Email.Formats.VCard Namespace


GivenName Property

Aspose.Email

VCardFullName.GivenName Property

Gets or sets a given name

public string GivenName {get; set;}

See Also

VCardFullName Class | Aspose.Email.Formats.VCard Namespace


HonorificPostfixes Property

Aspose.Email

VCardFullName.HonorificPostfixes Property

Gets or sets a honorific postfixes

public string HonorificPostfixes {get; set;}

See Also

VCardFullName Class | Aspose.Email.Formats.VCard Namespace


HonorificPrefixes Property

Aspose.Email

VCardFullName.HonorificPrefixes Property

Gets or sets a honorific prefixes

public string HonorificPrefixes {get; set;}

See Also

VCardFullName Class | Aspose.Email.Formats.VCard Namespace


MiddleName Property

Aspose.Email

VCardFullName.MiddleName Property

Gets or sets a middle name

public string MiddleName {get; set;}

See Also

VCardFullName Class | Aspose.Email.Formats.VCard Namespace


VCardGeo Class

Represents a global positioning of vCard contact

For a list of all members of this type, see VCardGeo Members.

System.Object
Aspose.Email.Formats.VCard.VCardGeo

public sealed class VCardGeo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Formats.VCard

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

VCardGeo Members | Aspose.Email.Formats.VCard Namespace


VCardGeo Members

VCardGeo overview

Public Instance Constructors

VCardGeo Constructor Initializes a new instance of the VCardGeo class

Public Instance Properties

Latitude | Gets or sets a latitude
Longitude | Gets or sets a longitude

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

VCardGeo Class | Aspose.Email.Formats.VCard Namespace


VCardGeo Constructor

Initializes a new instance of the VCardGeo class

public VCardGeo();

See Also

VCardGeo Class | Aspose.Email.Formats.VCard Namespace


VCardGeo Properties

The properties of the VCardGeo class are listed below. For a complete list of VCardGeo class members, see the VCardGeo Members topic.

Public Instance Properties

Latitude | Gets or sets a latitude
Longitude | Gets or sets a longitude

See Also

VCardGeo Class | Aspose.Email.Formats.VCard Namespace


Latitude Property

Aspose.Email

VCardGeo.Latitude Property

Gets or sets a latitude

public float Latitude {get; set;}

See Also

VCardGeo Class | Aspose.Email.Formats.VCard Namespace


Longitude Property

Aspose.Email

VCardGeo.Longitude Property

Gets or sets a longitude

public float Longitude {get; set;}

See Also

VCardGeo Class | Aspose.Email.Formats.VCard Namespace


VCardIdentificationInfo Class

Represents vCard identification information

For a list of all members of this type, see VCardIdentificationInfo Members.

System.Object
Aspose.Email.Formats.VCard.VCardIdentificationInfo

public sealed class VCardIdentificationInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Formats.VCard

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

VCardIdentificationInfo Members | Aspose.Email.Formats.VCard Namespace


VCardIdentificationInfo Members

VCardIdentificationInfo overview

Public Instance Constructors

VCardIdentificationInfo Constructor Initializes a new instance of the VCardIdentificationInfo class

Public Instance Properties

Birthday | Gets or sets a contact's bithday
DisplayName | Gets or sets a contact's display(formatted) name
FullName | Gets or sets a contact's full name
Nickname | Gets or sets a contact's nickname
Photo | Gets or sets a contact's photo

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

VCardIdentificationInfo Class | Aspose.Email.Formats.VCard Namespace


VCardIdentificationInfo Constructor

Initializes a new instance of the VCardIdentificationInfo class

public VCardIdentificationInfo();

See Also

VCardIdentificationInfo Class | Aspose.Email.Formats.VCard Namespace


VCardIdentificationInfo Properties

The properties of the VCardIdentificationInfo class are listed below. For a complete list of VCardIdentificationInfo class members, see the VCardIdentificationInfo Members topic.

Public Instance Properties

Birthday | Gets or sets a contact's bithday
DisplayName | Gets or sets a contact's display(formatted) name
FullName | Gets or sets a contact's full name
Nickname | Gets or sets a contact's nickname
Photo | Gets or sets a contact's photo

See Also

VCardIdentificationInfo Class | Aspose.Email.Formats.VCard Namespace


Birthday Property

Aspose.Email

VCardIdentificationInfo.Birthday Property

Gets or sets a contact's bithday

public DateTime Birthday {get; set;}

See Also

VCardIdentificationInfo Class | Aspose.Email.Formats.VCard Namespace


DisplayName Property

Aspose.Email

VCardIdentificationInfo.DisplayName Property

Gets or sets a contact's display(formatted) name

public string DisplayName {get; set;}

See Also

VCardIdentificationInfo Class | Aspose.Email.Formats.VCard Namespace


FullName Property

Aspose.Email

VCardIdentificationInfo.FullName Property

Gets or sets a contact's full name

public VCardFullName FullName {get; set;}

See Also

VCardIdentificationInfo Class | Aspose.Email.Formats.VCard Namespace


Nickname Property

Aspose.Email

VCardIdentificationInfo.Nickname Property

Gets or sets a contact's nickname

public string Nickname {get; set;}

See Also

VCardIdentificationInfo Class | Aspose.Email.Formats.VCard Namespace


Photo Property

Aspose.Email

VCardIdentificationInfo.Photo Property

Gets or sets a contact's photo

public VCardPhoto Photo {get; set;}

See Also

VCardIdentificationInfo Class | Aspose.Email.Formats.VCard Namespace


VCardOrganization Class

Represents vCard organization properties

For a list of all members of this type, see VCardOrganization Members.

System.Object
Aspose.Email.Formats.VCard.VCardOrganization

public sealed class VCardOrganization

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Formats.VCard

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

VCardOrganization Members | Aspose.Email.Formats.VCard Namespace


VCardOrganization Members

VCardOrganization overview

Public Instance Constructors

VCardOrganization Constructor Initializes a new instance of the VCardOrganization class

Public Instance Properties

Agent | Gets or sets an agent
Departments | Gets or sets a departments
Logo | Gets or sets a logo
Organization | Gets or sets a organization
Role | Gets or sets a role
Title | Gets or sets a job title

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

VCardOrganization Class | Aspose.Email.Formats.VCard Namespace


VCardOrganization Constructor

Initializes a new instance of the VCardOrganization class

public VCardOrganization();

See Also

VCardOrganization Class | Aspose.Email.Formats.VCard Namespace


VCardOrganization Properties

The properties of the VCardOrganization class are listed below. For a complete list of VCardOrganization class members, see the VCardOrganization Members topic.

Public Instance Properties

Agent | Gets or sets an agent
Departments | Gets or sets a departments
Logo | Gets or sets a logo
Organization | Gets or sets a organization
Role | Gets or sets a role
Title | Gets or sets a job title

See Also

VCardOrganization Class | Aspose.Email.Formats.VCard Namespace


Agent Property

Aspose.Email

VCardOrganization.Agent Property

Gets or sets an agent

public VCardAgent Agent {get; set;}

See Also

VCardOrganization Class | Aspose.Email.Formats.VCard Namespace


Departments Property

Aspose.Email

VCardOrganization.Departments Property

Gets or sets a departments

public StringCollection Departments {get; set;}

See Also

VCardOrganization Class | Aspose.Email.Formats.VCard Namespace


Logo Property

Aspose.Email

VCardOrganization.Logo Property

Gets or sets a logo

public VCardPhoto Logo {get; set;}

See Also

VCardOrganization Class | Aspose.Email.Formats.VCard Namespace


Organization Property

Aspose.Email

VCardOrganization.Organization Property

Gets or sets a organization

public string Organization {get; set;}

See Also

VCardOrganization Class | Aspose.Email.Formats.VCard Namespace


Role Property

Aspose.Email

VCardOrganization.Role Property

Gets or sets a role

public string Role {get; set;}

See Also

VCardOrganization Class | Aspose.Email.Formats.VCard Namespace


Title Property

Aspose.Email

VCardOrganization.Title Property

Gets or sets a job title

public string Title {get; set;}

See Also

VCardOrganization Class | Aspose.Email.Formats.VCard Namespace


VCardPhoto Class

Represents vCard photo property

For a list of all members of this type, see VCardPhoto Members.

System.Object
Aspose.Email.Formats.VCard.VCardPhoto

public sealed class VCardPhoto

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Formats.VCard

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

VCardPhoto Members | Aspose.Email.Formats.VCard Namespace


VCardPhoto Members

VCardPhoto overview

Public Instance Constructors

VCardPhoto Constructor Initializes a new instance of the VCardPhoto class

Public Instance Properties

Data | Gets or sets an image data (null if valueLocation is not inline)
PhotoType | Gets or sets a photo type
Uri | Gets or sets a uri of photo (null if valueLocation is inline)
ValueLocation | Gets or sets a value location

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

VCardPhoto Class | Aspose.Email.Formats.VCard Namespace


VCardPhoto Constructor

Initializes a new instance of the VCardPhoto class

public VCardPhoto();

See Also

VCardPhoto Class | Aspose.Email.Formats.VCard Namespace


VCardPhoto Properties

The properties of the VCardPhoto class are listed below. For a complete list of VCardPhoto class members, see the VCardPhoto Members topic.

Public Instance Properties

Data | Gets or sets an image data (null if valueLocation is not inline)
PhotoType | Gets or sets a photo type
Uri | Gets or sets a uri of photo (null if valueLocation is inline)
ValueLocation | Gets or sets a value location

See Also

VCardPhoto Class | Aspose.Email.Formats.VCard Namespace


Data Property

Aspose.Email

VCardPhoto.Data Property

Gets or sets an image data (null if valueLocation is not inline)

public byte[] Data {get; set;}

See Also

VCardPhoto Class | Aspose.Email.Formats.VCard Namespace


PhotoType Property

Aspose.Email

VCardPhoto.PhotoType Property

Gets or sets a photo type

public VCardPhotoType PhotoType {get; set;}

See Also

VCardPhoto Class | Aspose.Email.Formats.VCard Namespace


Uri Property

Aspose.Email

VCardPhoto.Uri Property

Gets or sets a uri of photo (null if valueLocation is inline)

public string Uri {get; set;}

See Also

VCardPhoto Class | Aspose.Email.Formats.VCard Namespace


ValueLocation Property

Aspose.Email

VCardPhoto.ValueLocation Property

Gets or sets a value location

public VCardValueLocation ValueLocation {get; set;}

See Also

VCardPhoto Class | Aspose.Email.Formats.VCard Namespace


VCardPhotoType Enumeration

Enumerates vCard photo type

public enum VCardPhotoType

Members

Member Name | Description | Value
GIF | Graphics interchange format | 0
CGM | ISO computer graphics metafile | 1
WMF | MS windows metafile | 2
BMP | MS windows bitmap | 3
MET | IBM pm metafile | 4
PMB | IBM pm bitmap | 5
DIB | MS windows dib | 6
PICT | Apple picture format | 7
TIFF | Tagged image file format | 8
PS | Adobe postscript format | 9
PDF | Adobe page description format | 10
JPEG | Jpeg format | 11
MPEG | Mpeg format | 12
MPEG2 | MPEG v.2 format | 13
AVI | Intel avi format | 14
QTIME | Apple quickTime format | 15

Requirements

Namespace: Aspose.Email.Formats.VCard

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Formats.VCard Namespace


VCardSaveOptions Class

Represents vCard save options

For a list of all members of this type, see VCardSaveOptions Members.

System.Object
Aspose.Email.Outlook.ContactSaveOptions
Aspose.Email.Formats.VCard.VCardSaveOptions

public sealed class VCardSaveOptions : ContactSaveOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Formats.VCard

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

VCardSaveOptions Members | Aspose.Email.Formats.VCard Namespace


VCardSaveOptions Members

VCardSaveOptions overview

Public Static Properties

Default Gets default VCardSaveOptions

Public Instance Constructors

VCardSaveOptions Overloaded. Initializes a new instance of the VCardSaveOptions class.

Public Instance Properties

SaveFormat (inherited from ContactSaveOptions) | Gets a save format
UseExtensions | Gets or sets a value indicating whether the extended types can be used
Version | Gets or sets a vCard version

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

VCardSaveOptions Class | Aspose.Email.Formats.VCard Namespace


VCardSaveOptions Constructor

Initializes a new instance of the VCardSaveOptions class

Overload List

Initializes a new instance of the VCardSaveOptions class

public VCardSaveOptions();

Initializes a new instance of the VCardSaveOptions class

public VCardSaveOptions(VCardVersion);

Initializes a new instance of the VCardSaveOptions class

public VCardSaveOptions(VCardVersion,bool);

See Also

VCardSaveOptions Class | Aspose.Email.Formats.VCard Namespace


VCardSaveOptions Constructor ()

Initializes a new instance of the VCardSaveOptions class

public VCardSaveOptions();

See Also

VCardSaveOptions Class | Aspose.Email.Formats.VCard Namespace | VCardSaveOptions Constructor Overload List


VCardSaveOptions Constructor (VCardVersion, Boolean)

Initializes a new instance of the VCardSaveOptions class

public VCardSaveOptions(
VCardVersion version,
bool useExtensions
);

Parameters

version
a vCard version
useExtensions
indicates whether extended types can be used.

Exceptions

Exception Type | Condition
ArgumentException | A version is not defined in VCardVersion

See Also

VCardSaveOptions Class | Aspose.Email.Formats.VCard Namespace | VCardSaveOptions Constructor Overload List


VCardSaveOptions Constructor (VCardVersion)

Initializes a new instance of the VCardSaveOptions class

public VCardSaveOptions(
VCardVersion version
);

Parameters

version
a vCard version

Exceptions

Exception Type | Condition
ArgumentException | A version is not defined in VCardVersion

See Also

VCardSaveOptions Class | Aspose.Email.Formats.VCard Namespace | VCardSaveOptions Constructor Overload List


VCardSaveOptions Properties

The properties of the VCardSaveOptions class are listed below. For a complete list of VCardSaveOptions class members, see the VCardSaveOptions Members topic.

Public Static Properties

Default Gets default VCardSaveOptions

Public Instance Properties

SaveFormat (inherited from ContactSaveOptions) | Gets a save format
UseExtensions | Gets or sets a value indicating whether the extended types can be used
Version | Gets or sets a vCard version

See Also

VCardSaveOptions Class | Aspose.Email.Formats.VCard Namespace


Default Property

Aspose.Email

VCardSaveOptions.Default Property

Gets default VCardSaveOptions

public static VCardSaveOptions Default {get;}

See Also

VCardSaveOptions Class | Aspose.Email.Formats.VCard Namespace


UseExtensions Property

Aspose.Email

VCardSaveOptions.UseExtensions Property

Gets or sets a value indicating whether the extended types can be used

public bool UseExtensions {get; set;}

See Also

VCardSaveOptions Class | Aspose.Email.Formats.VCard Namespace


Version Property

Aspose.Email

VCardSaveOptions.Version Property

Gets or sets a vCard version

public VCardVersion Version {get; set;}

Exceptions

Exception Type | Condition
ArgumentException | A value is not defined in VCardVersion

See Also

VCardSaveOptions Class | Aspose.Email.Formats.VCard Namespace


VCardSecurity Class

Represents a vCard security properties

For a list of all members of this type, see VCardSecurity Members.

System.Object
Aspose.Email.Formats.VCard.VCardSecurity

public sealed class VCardSecurity

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Formats.VCard

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

VCardSecurity Members | Aspose.Email.Formats.VCard Namespace


VCardSecurity Members

VCardSecurity overview

Public Instance Constructors

VCardSecurity Constructor Initializes a new instance of the VCardSecurity class

Public Instance Properties

AccessClass | Gets or sets an access class
Key | Gets or sets a public key(or authentication certificate)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

VCardSecurity Class | Aspose.Email.Formats.VCard Namespace


VCardSecurity Constructor

Initializes a new instance of the VCardSecurity class

public VCardSecurity();

See Also

VCardSecurity Class | Aspose.Email.Formats.VCard Namespace


VCardSecurity Properties

The properties of the VCardSecurity class are listed below. For a complete list of VCardSecurity class members, see the VCardSecurity Members topic.

Public Instance Properties

AccessClass | Gets or sets an access class
Key | Gets or sets a public key(or authentication certificate)

See Also

VCardSecurity Class | Aspose.Email.Formats.VCard Namespace


AccessClass Property

Aspose.Email

VCardSecurity.AccessClass Property

Gets or sets an access class

public string AccessClass {get; set;}

See Also

VCardSecurity Class | Aspose.Email.Formats.VCard Namespace


Key Property

Aspose.Email

VCardSecurity.Key Property

Gets or sets a public key(or authentication certificate)

public string Key {get; set;}

See Also

VCardSecurity Class | Aspose.Email.Formats.VCard Namespace


VCardSound Class

Represents a vCard sound property

For a list of all members of this type, see VCardSound Members.

System.Object
Aspose.Email.Formats.VCard.VCardSound

public sealed class VCardSound

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Formats.VCard

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

VCardSound Members | Aspose.Email.Formats.VCard Namespace


VCardSound Members

VCardSound overview

Public Instance Constructors

VCardSound Constructor Initializes a new instance of the VCardSound class

Public Instance Properties

Data | Gets or sets a sound data (null if valueLocation is not inline)
SoundType | Gets or sets a sound type
Uri | Gets or sets a uri of sound (null if valueLocation is inline)
ValueLocation | Gets or sets a value location

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

VCardSound Class | Aspose.Email.Formats.VCard Namespace


VCardSound Constructor

Initializes a new instance of the VCardSound class

public VCardSound();

See Also

VCardSound Class | Aspose.Email.Formats.VCard Namespace


VCardSound Properties

The properties of the VCardSound class are listed below. For a complete list of VCardSound class members, see the VCardSound Members topic.

Public Instance Properties

Data | Gets or sets a sound data (null if valueLocation is not inline)
SoundType | Gets or sets a sound type
Uri | Gets or sets a uri of sound (null if valueLocation is inline)
ValueLocation | Gets or sets a value location

See Also

VCardSound Class | Aspose.Email.Formats.VCard Namespace


Data Property

Aspose.Email

VCardSound.Data Property

Gets or sets a sound data (null if valueLocation is not inline)

public byte[] Data {get; set;}

See Also

VCardSound Class | Aspose.Email.Formats.VCard Namespace


SoundType Property

Aspose.Email

VCardSound.SoundType Property

Gets or sets a sound type

public VCardSoundType SoundType {get; set;}

See Also

VCardSound Class | Aspose.Email.Formats.VCard Namespace


Uri Property

Aspose.Email

VCardSound.Uri Property

Gets or sets a uri of sound (null if valueLocation is inline)

public string Uri {get; set;}

See Also

VCardSound Class | Aspose.Email.Formats.VCard Namespace


ValueLocation Property

Aspose.Email

VCardSound.ValueLocation Property

Gets or sets a value location

public VCardValueLocation ValueLocation {get; set;}

See Also

VCardSound Class | Aspose.Email.Formats.VCard Namespace


VCardSoundType Enumeration

Enumerates a cVard sound types

public enum VCardSoundType

Members

Member Name | Description | Value
BASIC | A basic format | 0
WAVE | A wave format | 1
PCM | A MIME basic audio type | 2
AIFF | A AIFF format | 3
MPEG | A mpeg audio | 4
MP4 | A mp4 audio | 5
OGG | An ogg audio | 6
WMA | A windows media audio | 7

Requirements

Namespace: Aspose.Email.Formats.VCard

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Formats.VCard Namespace


VCardTelephoneNumber Class

Represents a vCard telephone number

For a list of all members of this type, see VCardTelephoneNumber Members.

System.Object
Aspose.Email.Formats.VCard.VCardTelephoneNumber

public sealed class VCardTelephoneNumber

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Formats.VCard

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

VCardTelephoneNumber Members | Aspose.Email.Formats.VCard Namespace


VCardTelephoneNumber Members

VCardTelephoneNumber overview

Public Instance Constructors

VCardTelephoneNumber Constructor Initializes a new instance of the VCardTelephoneNumber class

Public Instance Properties

TelephoneNumber | Gets or sets a telephone number
TelephoneType | Gets or sets a telephone numer type

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

VCardTelephoneNumber Class | Aspose.Email.Formats.VCard Namespace


VCardTelephoneNumber Constructor

Initializes a new instance of the VCardTelephoneNumber class

public VCardTelephoneNumber();

See Also

VCardTelephoneNumber Class | Aspose.Email.Formats.VCard Namespace


VCardTelephoneNumber Properties

The properties of the VCardTelephoneNumber class are listed below. For a complete list of VCardTelephoneNumber class members, see the VCardTelephoneNumber Members topic.

Public Instance Properties

TelephoneNumber | Gets or sets a telephone number
TelephoneType | Gets or sets a telephone numer type

See Also

VCardTelephoneNumber Class | Aspose.Email.Formats.VCard Namespace


TelephoneNumber Property

Aspose.Email

VCardTelephoneNumber.TelephoneNumber Property

Gets or sets a telephone number

public string TelephoneNumber {get; set;}

See Also

VCardTelephoneNumber Class | Aspose.Email.Formats.VCard Namespace


TelephoneType Property

Aspose.Email

VCardTelephoneNumber.TelephoneType Property

Gets or sets a telephone numer type

public VCardTelephoneType TelephoneType {get; set;}

Exceptions

Exception Type | Condition
ArgumentException | value is not defined in the VCardTelephoneType

See Also

VCardTelephoneNumber Class | Aspose.Email.Formats.VCard Namespace


VCardTelephoneNumberCollection Class

Represents a collection of VCardTelephoneNumbers

For a list of all members of this type, see VCardTelephoneNumberCollection Members.

System.Object
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Formats.VCard.VCardTelephoneNumber, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]]
Aspose.Email.Formats.VCard.VCardTelephoneNumberCollection

public sealed class VCardTelephoneNumberCollection : Collection`1

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Formats.VCard

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

VCardTelephoneNumberCollection Members | Aspose.Email.Formats.VCard Namespace


VCardTelephoneNumberCollection Members

VCardTelephoneNumberCollection overview

Public Instance Constructors

VCardTelephoneNumberCollection Constructor Initializes a new instance of the VCardTelephoneNumberCollection class.

Public Instance Properties

Count (inherited from 0, Culture=neutral, PublicKeyToken=null]])
Item (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

VCardTelephoneNumberCollection Class | Aspose.Email.Formats.VCard Namespace


VCardTelephoneNumberCollection Constructor

Initializes a new instance of the VCardTelephoneNumberCollection class.

public VCardTelephoneNumberCollection();

See Also

VCardTelephoneNumberCollection Class | Aspose.Email.Formats.VCard Namespace


VCardTelephoneType Enumeration

Enumerates a vCard telephone types

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum VCardTelephoneType

Members

Member Name | Description | Value
None | No values are set. | 0
VOICE | A voice number | 1
PREF | A preferred number | 2
WORK | A work number | 4
HOME | A home number | 8
FAX | A facsimile number | 16
CELL | A cellular number | 32
PAGER | A pager number | 64
BBS | A bulletin board service number | 128
MODEM | A modem number | 256
CAR | A car-phone number | 512
ISDN | An ISDN number | 1024
VIDEO | A video-phone number | 2048
PCS | A personal communication services telephone number | 4096
MSG | A messaging service on the number | 8192

Requirements

Namespace: Aspose.Email.Formats.VCard

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Formats.VCard Namespace


VCardUrl Class

Represents a vCard URL property

For a list of all members of this type, see VCardUrl Members.

System.Object
Aspose.Email.Formats.VCard.VCardUrl

public sealed class VCardUrl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Formats.VCard

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

VCardUrl Members | Aspose.Email.Formats.VCard Namespace


VCardUrl Members

VCardUrl overview

Public Instance Constructors

VCardUrl Constructor Initializes a new instance of the VCardUrl class

Public Instance Properties

Url | Gets or sets a url
UrlType | Gets or sets a url type

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

VCardUrl Class | Aspose.Email.Formats.VCard Namespace


VCardUrl Constructor

Initializes a new instance of the VCardUrl class

public VCardUrl();

See Also

VCardUrl Class | Aspose.Email.Formats.VCard Namespace


VCardUrl Properties

The properties of the VCardUrl class are listed below. For a complete list of VCardUrl class members, see the VCardUrl Members topic.

Public Instance Properties

Url | Gets or sets a url
UrlType | Gets or sets a url type

See Also

VCardUrl Class | Aspose.Email.Formats.VCard Namespace


Url Property

Aspose.Email

VCardUrl.Url Property

Gets or sets a url

public string Url {get; set;}

See Also

VCardUrl Class | Aspose.Email.Formats.VCard Namespace


UrlType Property

Aspose.Email

VCardUrl.UrlType Property

Gets or sets a url type

public VCardUrlType UrlType {get; set;}

See Also

VCardUrl Class | Aspose.Email.Formats.VCard Namespace


VCardUrlCollection Class

Represents a collection of VCardUrls

For a list of all members of this type, see VCardUrlCollection Members.

System.Object
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Formats.VCard.VCardUrl, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]]
Aspose.Email.Formats.VCard.VCardUrlCollection

public sealed class VCardUrlCollection : Collection`1

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Formats.VCard

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

VCardUrlCollection Members | Aspose.Email.Formats.VCard Namespace


VCardUrlCollection Members

VCardUrlCollection overview

Public Instance Constructors

VCardUrlCollection Constructor Initializes a new instance of the VCardUrlCollection class.

Public Instance Properties

Count (inherited from 0, Culture=neutral, PublicKeyToken=null]])
Item (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

VCardUrlCollection Class | Aspose.Email.Formats.VCard Namespace


VCardUrlCollection Constructor

Initializes a new instance of the VCardUrlCollection class.

public VCardUrlCollection();

See Also

VCardUrlCollection Class | Aspose.Email.Formats.VCard Namespace


VCardUrlType Enumeration

Enumerates url type

public enum VCardUrlType

Members

Member Name | Description | Value
None | No type is specified, | 0
HOME | Home type of url. | 1
WORK | Work type of url. | 2

Requirements

Namespace: Aspose.Email.Formats.VCard

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Formats.VCard Namespace


VCardValueLocation Enumeration

Enumerates the vCard property parameter ValueLocation.

public enum VCardValueLocation

Members

Member Name | Description | Value
INLINE | Inline value location (default). | 0
URL | Url value location. | 1
CID | Content id value location. | 2
URI | Uri value location. | 3

Requirements

Namespace: Aspose.Email.Formats.VCard

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Formats.VCard Namespace


VCardVersion Enumeration

Enumerates vCard version

public enum VCardVersion

Members

Member Name | Description | Value
V21 | vCard version 2.1 (default) | 0

Requirements

Namespace: Aspose.Email.Formats.VCard

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Formats.VCard Namespace


Aspose.Email.Google

Aspose.Email

Aspose.Email.Google Namespace

Namespace hierarchy

Classes

Class | Description
AccessControlRule | Access control rule.
AclScope | The scope of the access rule.
BaseDataObject | Base class for google data objects.
Calendar | A set of metadata, such as a description, for a single calendar.
Colors | Set of colors for calendar object
ColorsInfo | Contains colors definition for calendars and events
ErrorDetails | Error informnation
ExtendedCalendar | A set of extended metadata, such as a colors, for a single calendar.
FreebusyCalendarInfo | Defines list of free/busy information for specified calendar.
FreebusyGroupInfo | Specifies list of calendars that are members of the groups.
FreebusyQuery | Request free/busy information for a set of calendars.
FreebusyResponse | Freebusy response
Gadget | A gadget that extends this event.
GmailClient | Base class for Gmail client
Range | Time range during which calendar should be regarded as busy.
Reminders | Information about the event's reminders for the authenticated user.

Interfaces

Interface | Description
IBaseGmailClient | Interface for base class of Gmail client
IGmailClient | Represents the interface for Gmail client

Enumerations

Enumeration | Description
AccessRole | The effective access role that the authenticated user has on the calendar.
AclScopeType | The type of the ACL scope.
NotificationMethod | The method used by this notification.
NotificationType | The type of notification.
ReminderMethods | The method used by this reminder.


AccessControlRule Class

Access control rule.

For a list of all members of this type, see AccessControlRule Members.

System.Object
Aspose.Email.Google.BaseDataObject
Aspose.Email.Google.AccessControlRule

public class AccessControlRule : BaseDataObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Google

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AccessControlRule Members | Aspose.Email.Google Namespace


AccessControlRule Members

AccessControlRule overview

Public Static Fields

KIND Type of the resource ("calendar#calendar").

Public Instance Constructors

AccessControlRule Overloaded. Initializes a new instance of the AccessControlRule class.

Public Instance Properties

ETag (inherited from BaseDataObject) | An ETag or entity tag is one of several mechanisms that HTTP provides for web cache validation, and which allows a client to make conditional requests. This allows caches to be more efficient, and saves bandwidth, as a web server does not need to send a full response if the content has not changed. ETags can also be used for optimistic concurrency control, as a way to help prevent simultaneous updates of a resource from overwriting each other.
Id (inherited from BaseDataObject) | Identifier of the resource.
Kind (inherited from BaseDataObject) | Type of the resource
Role | The role assigned to the scope.
Scope | The scope of the rule.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a string which represents the object instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AccessControlRule Class | Aspose.Email.Google Namespace


AccessControlRule Constructor

Initializes a new instance of the AccessControlRule class.

Overload List

Initializes a new instance of the AccessControlRule class.

public AccessControlRule();

Initializes a new instance of the AccessControlRule class.

public AccessControlRule(AclScope,AccessRole);

Initializes a new instance of the AccessControlRule class.

public AccessControlRule(string,AclScope,AccessRole);

Initializes a new instance of the AccessControlRule class.

public AccessControlRule(string,string,AclScope,AccessRole);

See Also

AccessControlRule Class | Aspose.Email.Google Namespace


AccessControlRule Constructor ()

Initializes a new instance of the AccessControlRule class.

public AccessControlRule();

See Also

AccessControlRule Class | Aspose.Email.Google Namespace | AccessControlRule Constructor Overload List


AccessControlRule Constructor (AclScope, AccessRole)

Initializes a new instance of the AccessControlRule class.

public AccessControlRule(
AclScope scope,
AccessRole role
);

Parameters

scope
The scope of the rule.
role
The role assigned to the scope.

See Also

AccessControlRule Class | Aspose.Email.Google Namespace | AccessControlRule Constructor Overload List


AccessControlRule Constructor (String, AclScope, AccessRole)

Initializes a new instance of the AccessControlRule class.

public AccessControlRule(
string id,
AclScope scope,
AccessRole role
);

Parameters

id
Identifier of the resource.
scope
The scope of the rule.
role
The role assigned to the scope.

See Also

AccessControlRule Class | Aspose.Email.Google Namespace | AccessControlRule Constructor Overload List


AccessControlRule Constructor (String, String, AclScope, AccessRole)

Initializes a new instance of the AccessControlRule class.

public AccessControlRule(
string id,
string eTag,
AclScope scope,
AccessRole role
);

Parameters

id
Identifier of the resource.
eTag
An entity tag
scope
The scope of the rule.
role
The role assigned to the scope.

See Also

AccessControlRule Class | Aspose.Email.Google Namespace | AccessControlRule Constructor Overload List


AccessControlRule Fields

The fields of the AccessControlRule class are listed below. For a complete list of AccessControlRule class members, see the AccessControlRule Members topic.

Public Static Fields

KIND Type of the resource ("calendar#calendar").

See Also

AccessControlRule Class | Aspose.Email.Google Namespace


AccessControlRule.KIND Field

Type of the resource ("calendar#calendar").

public const string KIND = "calendar#aclRule";

See Also

AccessControlRule Class | Aspose.Email.Google Namespace


AccessControlRule Properties

The properties of the AccessControlRule class are listed below. For a complete list of AccessControlRule class members, see the AccessControlRule Members topic.

Public Instance Properties

ETag (inherited from BaseDataObject) | An ETag or entity tag is one of several mechanisms that HTTP provides for web cache validation, and which allows a client to make conditional requests. This allows caches to be more efficient, and saves bandwidth, as a web server does not need to send a full response if the content has not changed. ETags can also be used for optimistic concurrency control, as a way to help prevent simultaneous updates of a resource from overwriting each other.
Id (inherited from BaseDataObject) | Identifier of the resource.
Kind (inherited from BaseDataObject) | Type of the resource
Role | The role assigned to the scope.
Scope | The scope of the rule.

See Also

AccessControlRule Class | Aspose.Email.Google Namespace


Role Property

Aspose.Email

AccessControlRule.Role Property

The role assigned to the scope.

public AccessRole Role {get; set;}

See Also

AccessControlRule Class | Aspose.Email.Google Namespace


Scope Property

Aspose.Email

AccessControlRule.Scope Property

The scope of the rule.

public AclScope Scope {get; set;}

See Also

AccessControlRule Class | Aspose.Email.Google Namespace


AccessControlRule Methods

The methods of the AccessControlRule class are listed below. For a complete list of AccessControlRule class members, see the AccessControlRule Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a string which represents the object instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AccessControlRule Class | Aspose.Email.Google Namespace


AccessControlRule.ToString Method

Returns a string which represents the object instance.

public override string ToString();

Return Value

Returns a string which represents the object instance.

See Also

AccessControlRule Class | Aspose.Email.Google Namespace


AccessRole Enumeration

The effective access role that the authenticated user has on the calendar.

public enum AccessRole

Members

Member Name | Description | Value
none | Not defined | 0
freeBusyReader | Provides read access to free/busy information. | 1
reader | Provides read access to the calendar. Private events will appear to users with reader access, but event details will be hidden. | 2
writer | Provides read and write access to the calendar. Private events will appear to users with writer access, and event details will be visible. | 3
owner | Provides ownership of the calendar. This role has all of the permissions of the writer role with the additional ability to see and manipulate ACLs. | 4

Requirements

Namespace: Aspose.Email.Google

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Google Namespace


AclScope Class

The scope of the access rule.

For a list of all members of this type, see AclScope Members.

System.Object
Aspose.Email.Google.AclScope

public class AclScope

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Google

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AclScope Members | Aspose.Email.Google Namespace


AclScope Members

AclScope overview

Public Instance Constructors

AclScope Overloaded. Initializes a new instance of the AclScope class.

Public Instance Properties

Type | The type of the ACL scope.
Value | The email address of a user or group, or the name of a domain, depending on the scope type. Omitted for type "default".

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AclScope Class | Aspose.Email.Google Namespace


AclScope Constructor

Initializes a new instance of the AclScope class.

Overload List

Initializes a new instance of the AclScope class.

public AclScope();

Initializes a new instance of the AclScope class.

public AclScope(AclScopeType,string);

See Also

AclScope Class | Aspose.Email.Google Namespace


AclScope Constructor ()

Initializes a new instance of the AclScope class.

public AclScope();

See Also

AclScope Class | Aspose.Email.Google Namespace | AclScope Constructor Overload List


AclScope Constructor (AclScopeType, String)

Initializes a new instance of the AclScope class.

public AclScope(
AclScopeType type,
string value
);

Parameters

type
The type of the ACL scope.
value
The email address of a user or group, or the name of a domain, depending on the scope type.

See Also

AclScope Class | Aspose.Email.Google Namespace | AclScope Constructor Overload List


AclScope Properties

The properties of the AclScope class are listed below. For a complete list of AclScope class members, see the AclScope Members topic.

Public Instance Properties

Type | The type of the ACL scope.
Value | The email address of a user or group, or the name of a domain, depending on the scope type. Omitted for type "default".

See Also

AclScope Class | Aspose.Email.Google Namespace


Type Property

Aspose.Email

AclScope.Type Property

The type of the ACL scope.

public AclScopeType Type {get; set;}

See Also

AclScope Class | Aspose.Email.Google Namespace


Value Property

Aspose.Email

AclScope.Value Property

The email address of a user or group, or the name of a domain, depending on the scope type. Omitted for type "default".

public string Value {get; set;}

See Also

AclScope Class | Aspose.Email.Google Namespace


AclScopeType Enumeration

The type of the ACL scope.

public enum AclScopeType

Members

Member Name | Description | Value
Default | The public scope. This is the default value. | 0
user | Limits the scope to a single user. | 1
group | Limits the scope to a group. | 2
domain | Limits the scope to a domain. | 3

Requirements

Namespace: Aspose.Email.Google

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Google Namespace


BaseDataObject Class

Base class for google data objects.

For a list of all members of this type, see BaseDataObject Members.

System.Object
Aspose.Email.Google.BaseDataObject
Aspose.Email.Google.AccessControlRule
Aspose.Email.Google.Calendar

public abstract class BaseDataObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Google

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

BaseDataObject Members | Aspose.Email.Google Namespace


BaseDataObject Members

BaseDataObject overview

Public Instance Constructors

BaseDataObject Overloaded. Initializes a new instance of the BaseDataObject class.

Public Instance Properties

ETag | An ETag or entity tag is one of several mechanisms that HTTP provides for web cache validation, and which allows a client to make conditional requests. This allows caches to be more efficient, and saves bandwidth, as a web server does not need to send a full response if the content has not changed. ETags can also be used for optimistic concurrency control, as a way to help prevent simultaneous updates of a resource from overwriting each other.
Id | Identifier of the resource.
Kind | Type of the resource

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BaseDataObject Class | Aspose.Email.Google Namespace


BaseDataObject Constructor

Initializes a new instance of the class.

Overload List

Initializes a new instance of the class.

public BaseDataObject(string);

Initializes a new instance of the class.

public BaseDataObject(string,string);

Initializes a new instance of the class.

public BaseDataObject(string,string,string);

See Also

BaseDataObject Class | Aspose.Email.Google Namespace


BaseDataObject Constructor (String)

Initializes a new instance of the class.

public BaseDataObject(
string kind
);

Parameters

kind
Type of the resource

See Also

BaseDataObject Class | Aspose.Email.Google Namespace | BaseDataObject Constructor Overload List


BaseDataObject Constructor (String, String)

Initializes a new instance of the class.

public BaseDataObject(
string kind,
string id
);

Parameters

kind
Type of the resource
id
Identifier of the resource.

See Also

BaseDataObject Class | Aspose.Email.Google Namespace | BaseDataObject Constructor Overload List


BaseDataObject Constructor (String, String, String)

Initializes a new instance of the class.

public BaseDataObject(
string kind,
string id,
string eTag
);

Parameters

kind
Type of the resource
id
Identifier of the resource.
eTag
An entity tag

See Also

BaseDataObject Class | Aspose.Email.Google Namespace | BaseDataObject Constructor Overload List


BaseDataObject Properties

The properties of the BaseDataObject class are listed below. For a complete list of BaseDataObject class members, see the BaseDataObject Members topic.

Public Instance Properties

ETag | An ETag or entity tag is one of several mechanisms that HTTP provides for web cache validation, and which allows a client to make conditional requests. This allows caches to be more efficient, and saves bandwidth, as a web server does not need to send a full response if the content has not changed. ETags can also be used for optimistic concurrency control, as a way to help prevent simultaneous updates of a resource from overwriting each other.
Id | Identifier of the resource.
Kind | Type of the resource

See Also

BaseDataObject Class | Aspose.Email.Google Namespace


ETag Property

Aspose.Email

BaseDataObject.ETag Property

An ETag or entity tag is one of several mechanisms that HTTP provides for web cache validation, and which allows a client to make conditional requests. This allows caches to be more efficient, and saves bandwidth, as a web server does not need to send a full response if the content has not changed. ETags can also be used for optimistic concurrency control, as a way to help prevent simultaneous updates of a resource from overwriting each other.

public virtual string ETag {get; set;}

See Also

BaseDataObject Class | Aspose.Email.Google Namespace


Id Property

Aspose.Email

BaseDataObject.Id Property

Identifier of the resource.

public virtual string Id {get; set;}

See Also

BaseDataObject Class | Aspose.Email.Google Namespace


Kind Property

Aspose.Email

BaseDataObject.Kind Property

Type of the resource

public virtual string Kind {get;}

See Also

BaseDataObject Class | Aspose.Email.Google Namespace


Calendar Class

A set of metadata, such as a description, for a single calendar.

For a list of all members of this type, see Calendar Members.

System.Object
Aspose.Email.Google.BaseDataObject
Aspose.Email.Google.Calendar
Aspose.Email.Google.ExtendedCalendar

public class Calendar : BaseDataObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Google

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Calendar Members | Aspose.Email.Google Namespace


Calendar Members

Calendar overview

Public Static Fields

KIND Type of the resource "calendar#calendar".

Public Instance Constructors

Calendar Overloaded. Initializes a new instance of the Calendar class.

Public Instance Properties

Description | Description of the calendar.
ETag (inherited from BaseDataObject) | An ETag or entity tag is one of several mechanisms that HTTP provides for web cache validation, and which allows a client to make conditional requests. This allows caches to be more efficient, and saves bandwidth, as a web server does not need to send a full response if the content has not changed. ETags can also be used for optimistic concurrency control, as a way to help prevent simultaneous updates of a resource from overwriting each other.
Id (inherited from BaseDataObject) | Identifier of the resource.
Kind (inherited from BaseDataObject) | Type of the resource
Location | Geographic location of the calendar as free-form text.
Summary | Title of the calendar.
TimeZone | The time zone of the calendar.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a string which represents the object instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Calendar Class | Aspose.Email.Google Namespace


Calendar Constructor

Initializes a new instance of the Calendar class.

Overload List

Initializes a new instance of the Calendar class.

public Calendar();

Initializes a new instance of the Calendar class.

public Calendar(string);

Initializes a new instance of the Calendar class.

public Calendar(string,string);

Initializes a new instance of the Calendar class.

public Calendar(string,string,string,string);

Initializes a new instance of the Calendar class.

public Calendar(string,string,string,string,string);

Initializes a new instance of the Calendar class.

public Calendar(string,string,string,string,string,string);

See Also

Calendar Class | Aspose.Email.Google Namespace


Calendar Constructor ()

Initializes a new instance of the Calendar class.

public Calendar();

See Also

Calendar Class | Aspose.Email.Google Namespace | Calendar Constructor Overload List


Calendar Constructor (String)

Initializes a new instance of the Calendar class.

public Calendar(
string summary
);

Parameters

summary
Title of the calendar.

See Also

Calendar Class | Aspose.Email.Google Namespace | Calendar Constructor Overload List


Calendar Constructor (String, String)

Initializes a new instance of the Calendar class.

public Calendar(
string id,
string summary
);

Parameters

id
Identifier of the resource.
summary
Title of the calendar.

See Also

Calendar Class | Aspose.Email.Google Namespace | Calendar Constructor Overload List


Calendar Constructor (String, String, String, String)

Initializes a new instance of the Calendar class.

public Calendar(
string summary,
string description,
string location,
string timeZone
);

Parameters

summary
Title of the calendar.
description
Description of the calendar.
location
Geographic location of the calendar as free-form text.
timeZone
The time zone of the calendar.

See Also

Calendar Class | Aspose.Email.Google Namespace | Calendar Constructor Overload List


Calendar Constructor (String, String, String, String, String)

Initializes a new instance of the Calendar class.

public Calendar(
string id,
string summary,
string description,
string location,
string timeZone
);

Parameters

id
Identifier of the resource.
summary
Title of the calendar.
description
Description of the calendar.
location
Geographic location of the calendar as free-form text.
timeZone
The time zone of the calendar.

See Also

Calendar Class | Aspose.Email.Google Namespace | Calendar Constructor Overload List


Calendar Constructor (String, String, String, String, String, String)

Initializes a new instance of the Calendar class.

public Calendar(
string id,
string eTag,
string summary,
string description,
string location,
string timeZone
);

Parameters

id
Identifier of the resource.
eTag
An entity tag
summary
Title of the calendar.
description
Description of the calendar.
location
Geographic location of the calendar as free-form text.
timeZone
The time zone of the calendar.

See Also

Calendar Class | Aspose.Email.Google Namespace | Calendar Constructor Overload List


Calendar Fields

The fields of the Calendar class are listed below. For a complete list of Calendar class members, see the Calendar Members topic.

Public Static Fields

KIND Type of the resource "calendar#calendar".

See Also

Calendar Class | Aspose.Email.Google Namespace


Calendar.KIND Field

Type of the resource "calendar#calendar".

public const string KIND = "calendar#calendar";

See Also

Calendar Class | Aspose.Email.Google Namespace


Calendar Properties

The properties of the Calendar class are listed below. For a complete list of Calendar class members, see the Calendar Members topic.

Public Instance Properties

Description | Description of the calendar.
ETag (inherited from BaseDataObject) | An ETag or entity tag is one of several mechanisms that HTTP provides for web cache validation, and which allows a client to make conditional requests. This allows caches to be more efficient, and saves bandwidth, as a web server does not need to send a full response if the content has not changed. ETags can also be used for optimistic concurrency control, as a way to help prevent simultaneous updates of a resource from overwriting each other.
Id (inherited from BaseDataObject) | Identifier of the resource.
Kind (inherited from BaseDataObject) | Type of the resource
Location | Geographic location of the calendar as free-form text.
Summary | Title of the calendar.
TimeZone | The time zone of the calendar.

See Also

Calendar Class | Aspose.Email.Google Namespace


Description Property

Aspose.Email

Calendar.Description Property

Description of the calendar.

public virtual string Description {get; set;}

See Also

Calendar Class | Aspose.Email.Google Namespace


Location Property

Aspose.Email

Calendar.Location Property

Geographic location of the calendar as free-form text.

public virtual string Location {get; set;}

See Also

Calendar Class | Aspose.Email.Google Namespace


Summary Property

Aspose.Email

Calendar.Summary Property

Title of the calendar.

public virtual string Summary {get; set;}

See Also

Calendar Class | Aspose.Email.Google Namespace


TimeZone Property

Aspose.Email

Calendar.TimeZone Property

The time zone of the calendar.

public virtual string TimeZone {get; set;}

See Also

Calendar Class | Aspose.Email.Google Namespace


Calendar Methods

The methods of the Calendar class are listed below. For a complete list of Calendar class members, see the Calendar Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a string which represents the object instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Calendar Class | Aspose.Email.Google Namespace


Calendar.ToString Method

Returns a string which represents the object instance.

public override string ToString();

Return Value

Returns a string which represents the object instance.

See Also

Calendar Class | Aspose.Email.Google Namespace


Colors Class

Set of colors for calendar object

For a list of all members of this type, see Colors Members.

System.Object
Aspose.Email.Google.Colors

public class Colors

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Google

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Colors Members | Aspose.Email.Google Namespace


Colors Members

Colors overview

Public Instance Constructors

Colors Overloaded. Initializes a new instance of the Colors class.

Public Instance Properties

Background | The background color associated with this color definition.
Foreground | The foreground color that can be used to write on top of a background with 'background' color.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String which represents the object instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Colors Class | Aspose.Email.Google Namespace


Colors Constructor

Initializes a new instance of the Colors class.

Overload List

Initializes a new instance of the Colors class.

public Colors();

Initializes a new instance of the Colors class.

public Colors(string,string);

See Also

Colors Class | Aspose.Email.Google Namespace


Colors Constructor ()

Initializes a new instance of the Colors class.

public Colors();

See Also

Colors Class | Aspose.Email.Google Namespace | Colors Constructor Overload List


Colors Constructor (String, String)

Initializes a new instance of the Colors class.

public Colors(
string background,
string foreground
);

Parameters

background
The background color associated with this color definition.
foreground
The foreground color that can be used to write on top of a background with 'background' color.

See Also

Colors Class | Aspose.Email.Google Namespace | Colors Constructor Overload List


Colors Properties

The properties of the Colors class are listed below. For a complete list of Colors class members, see the Colors Members topic.

Public Instance Properties

Background | The background color associated with this color definition.
Foreground | The foreground color that can be used to write on top of a background with 'background' color.

See Also

Colors Class | Aspose.Email.Google Namespace


Background Property

Aspose.Email

Colors.Background Property

The background color associated with this color definition.

public string Background {get; set;}

See Also

Colors Class | Aspose.Email.Google Namespace


Foreground Property

Aspose.Email

Colors.Foreground Property

The foreground color that can be used to write on top of a background with 'background' color.

public string Foreground {get; set;}

See Also

Colors Class | Aspose.Email.Google Namespace


Colors Methods

The methods of the Colors class are listed below. For a complete list of Colors class members, see the Colors Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String which represents the object instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Colors Class | Aspose.Email.Google Namespace


Colors.ToString Method

Returns a String which represents the object instance.

public override string ToString();

Return Value

Returns a String which represents the object instance.

See Also

Colors Class | Aspose.Email.Google Namespace


ColorsInfo Class

Contains colors definition for calendars and events

For a list of all members of this type, see ColorsInfo Members.

System.Object
Aspose.Email.Google.ColorsInfo

public class ColorsInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Google

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ColorsInfo Members | Aspose.Email.Google Namespace


ColorsInfo Members

ColorsInfo overview

Public Static Fields

KIND Type of the resource "calendar#colors".

Public Instance Constructors

ColorsInfo Overloaded. Initializes a new instance of the ColorsInfo class.

Public Instance Properties

Calendar | Palette of calendar colors, mapping from the color ID to its definition. An 'calendarListEntry' resource refers to one of these color IDs in its 'color' field.
Event | Palette of event colors, mapping from the color ID to its definition. An 'event' resource may refer to one of these color IDs in its 'color' field.
Updated | Last modification time of the color palette.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ColorsInfo Class | Aspose.Email.Google Namespace


ColorsInfo Constructor

Initializes a new instance of the ColorsInfo class.

Overload List

Initializes a new instance of the ColorsInfo class.

public ColorsInfo();

public ColorsInfo(DateTime,Colors},Colors});

See Also

ColorsInfo Class | Aspose.Email.Google Namespace


ColorsInfo Constructor ()

Initializes a new instance of the ColorsInfo class.

public ColorsInfo();

See Also

ColorsInfo Class | Aspose.Email.Google Namespace | ColorsInfo Constructor Overload List


ColorsInfo Constructor (DateTime, Colors}, Colors})

public ColorsInfo(
DateTime updated,
Dictionary<string, Colors> calendar,
Dictionary<string, Colors> evnt
);

See Also

ColorsInfo Class | Aspose.Email.Google Namespace | ColorsInfo Constructor Overload List


ColorsInfo Fields

The fields of the ColorsInfo class are listed below. For a complete list of ColorsInfo class members, see the ColorsInfo Members topic.

Public Static Fields

KIND Type of the resource "calendar#colors".

See Also

ColorsInfo Class | Aspose.Email.Google Namespace


ColorsInfo.KIND Field

Type of the resource "calendar#colors".

public const string KIND = "calendar#colors";

See Also

ColorsInfo Class | Aspose.Email.Google Namespace


ColorsInfo Properties

The properties of the ColorsInfo class are listed below. For a complete list of ColorsInfo class members, see the ColorsInfo Members topic.

Public Instance Properties

Calendar | Palette of calendar colors, mapping from the color ID to its definition. An 'calendarListEntry' resource refers to one of these color IDs in its 'color' field.
Event | Palette of event colors, mapping from the color ID to its definition. An 'event' resource may refer to one of these color IDs in its 'color' field.
Updated | Last modification time of the color palette.

See Also

ColorsInfo Class | Aspose.Email.Google Namespace


Calendar Property

Aspose.Email

ColorsInfo.Calendar Property

Palette of calendar colors, mapping from the color ID to its definition. An 'calendarListEntry' resource refers to one of these color IDs in its 'color' field.

public Colors} Calendar {get;}

See Also

ColorsInfo Class | Aspose.Email.Google Namespace


Event Property

Aspose.Email

ColorsInfo.Event Property

Palette of event colors, mapping from the color ID to its definition. An 'event' resource may refer to one of these color IDs in its 'color' field.

public Colors} Event {get;}

See Also

ColorsInfo Class | Aspose.Email.Google Namespace


Updated Property

Aspose.Email

ColorsInfo.Updated Property

Last modification time of the color palette.

public DateTime Updated {get; set;}

See Also

ColorsInfo Class | Aspose.Email.Google Namespace


ErrorDetails Class

Error informnation

For a list of all members of this type, see ErrorDetails Members.

System.Object
Aspose.Email.Google.ErrorDetails

public class ErrorDetails

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Google

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ErrorDetails Members | Aspose.Email.Google Namespace


ErrorDetails Members

ErrorDetails overview

Public Instance Constructors

ErrorDetails Overloaded. Initializes a new instance of the ErrorDetails class.

Public Instance Properties

Domain | Domain, or broad category, of the error.
Reason | Specific reason for the error.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String which represents the object instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ErrorDetails Class | Aspose.Email.Google Namespace


ErrorDetails Constructor

Initializes a new instance of the ErrorDetails class.

Overload List

Initializes a new instance of the ErrorDetails class.

public ErrorDetails();

Initializes a new instance of the ErrorDetails class.

public ErrorDetails(string,string);

See Also

ErrorDetails Class | Aspose.Email.Google Namespace


ErrorDetails Constructor ()

Initializes a new instance of the ErrorDetails class.

public ErrorDetails();

See Also

ErrorDetails Class | Aspose.Email.Google Namespace | ErrorDetails Constructor Overload List


ErrorDetails Constructor (String, String)

Initializes a new instance of the ErrorDetails class.

public ErrorDetails(
string domain,
string reason
);

Parameters

domain
Domain, or broad category, of the error.
reason
Specific reason for the error.

See Also

ErrorDetails Class | Aspose.Email.Google Namespace | ErrorDetails Constructor Overload List


ErrorDetails Properties

The properties of the ErrorDetails class are listed below. For a complete list of ErrorDetails class members, see the ErrorDetails Members topic.

Public Instance Properties

Domain | Domain, or broad category, of the error.
Reason | Specific reason for the error.

See Also

ErrorDetails Class | Aspose.Email.Google Namespace


Domain Property

Aspose.Email

ErrorDetails.Domain Property

Domain, or broad category, of the error.

public string Domain {get; set;}

See Also

ErrorDetails Class | Aspose.Email.Google Namespace


Reason Property

Aspose.Email

ErrorDetails.Reason Property

Specific reason for the error.

public string Reason {get; set;}

See Also

ErrorDetails Class | Aspose.Email.Google Namespace


ErrorDetails Methods

The methods of the ErrorDetails class are listed below. For a complete list of ErrorDetails class members, see the ErrorDetails Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String which represents the object instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ErrorDetails Class | Aspose.Email.Google Namespace


ErrorDetails.ToString Method

Returns a String which represents the object instance.

public override string ToString();

Return Value

Returns a String which represents the object instance.

See Also

ErrorDetails Class | Aspose.Email.Google Namespace


ExtendedCalendar Class

A set of extended metadata, such as a colors, for a single calendar.

For a list of all members of this type, see ExtendedCalendar Members.

System.Object
Aspose.Email.Google.BaseDataObject
Aspose.Email.Google.Calendar
Aspose.Email.Google.ExtendedCalendar

public class ExtendedCalendar : Calendar

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Google

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ExtendedCalendar Members | Aspose.Email.Google Namespace


ExtendedCalendar Members

ExtendedCalendar overview

Public Static Fields

KIND | Type of the resource "calendar#calendarListEntry".
LIST_KIND | Type of the resources list "calendar#calendarList".

Public Instance Constructors

ExtendedCalendar Overloaded. Initializes a new instance of the ExtendedCalendar class.

Public Instance Properties

AccessRole | The effective access role that the authenticated user has on the calendar. Read-only. Possible values are:
BackgroundColor | The main color of the calendar in the format '#0088aa'. This property supersedes the index-based colorId property.
ColorId | The color of the calendar. This is an ID referring to an entry in the "calendar" section of the colors definition (see the "colors" endpoint).
DefaultReminders | The default reminders that the authenticated user has for this calendar.
Description (inherited from Calendar) | Description of the calendar.
ETag (inherited from BaseDataObject) | An ETag or entity tag is one of several mechanisms that HTTP provides for web cache validation, and which allows a client to make conditional requests. This allows caches to be more efficient, and saves bandwidth, as a web server does not need to send a full response if the content has not changed. ETags can also be used for optimistic concurrency control, as a way to help prevent simultaneous updates of a resource from overwriting each other.
ForegroundColor | The foreground color of the calendar in the format '#ffffff'. This property supersedes the index-based colorId property.
Hidden | Whether the calendar has been hidden from the list. The default is False.
Id (inherited from BaseDataObject) | Identifier of the resource.
Kind (inherited from BaseDataObject) | Type of the resource
Location (inherited from Calendar) | Geographic location of the calendar as free-form text.
NotificationSettings | The notifications that the authenticated user is receiving for this calendar.
Primary | Whether the calendar is the primary calendar of the authenticated user. Read-only. The default is False.
Selected | Whether the calendar content shows up in the calendar UI. The default is False.
Summary (inherited from Calendar) | Title of the calendar.
SummaryOverride | The summary that the authenticated user has set for this calendar.
TimeZone (inherited from Calendar) | The time zone of the calendar.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a string which represents the object instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExtendedCalendar Class | Aspose.Email.Google Namespace


ExtendedCalendar Constructor

Initializes a new instance of the ExtendedCalendar class.

Overload List

Initializes a new instance of the ExtendedCalendar class.

public ExtendedCalendar();

Initializes a new instance of the ExtendedCalendar class.

public ExtendedCalendar(string);

Initializes a new instance of the ExtendedCalendar class.

public ExtendedCalendar(string,string);

Initializes a new instance of the ExtendedCalendar class.

public ExtendedCalendar(string,string,string,string);

Initializes a new instance of the ExtendedCalendar class.

public ExtendedCalendar(string,string,string,string,string);

public ExtendedCalendar(string,string,string,string,string,string,string,string,string,bool,bool,AccessRole,0, Culture=neutral, PublicKeyToken=b77a5c561934e089]][],bool);

public ExtendedCalendar(string,string,string,string,string,string,string,string,string,string,bool,bool,AccessRole,0, Culture=neutral, PublicKeyToken=b77a5c561934e089]][],bool);

See Also

ExtendedCalendar Class | Aspose.Email.Google Namespace


ExtendedCalendar Constructor ()

Initializes a new instance of the ExtendedCalendar class.

public ExtendedCalendar();

See Also

ExtendedCalendar Class | Aspose.Email.Google Namespace | ExtendedCalendar Constructor Overload List


ExtendedCalendar Constructor (String)

Initializes a new instance of the ExtendedCalendar class.

public ExtendedCalendar(
string summary
);

Parameters

summary
Title of the calendar.

See Also

ExtendedCalendar Class | Aspose.Email.Google Namespace | ExtendedCalendar Constructor Overload List


ExtendedCalendar Constructor (String, String)

Initializes a new instance of the ExtendedCalendar class.

public ExtendedCalendar(
string id,
string summary
);

Parameters

id
Identifier of the resource.
summary
Title of the calendar.

See Also

ExtendedCalendar Class | Aspose.Email.Google Namespace | ExtendedCalendar Constructor Overload List


ExtendedCalendar Constructor (String, String, String, String)

Initializes a new instance of the ExtendedCalendar class.

public ExtendedCalendar(
string summary,
string description,
string location,
string timeZone
);

Parameters

summary
Title of the calendar.
description
Description of the calendar.
location
Geographic location of the calendar as free-form text.
timeZone
The time zone of the calendar.

See Also

ExtendedCalendar Class | Aspose.Email.Google Namespace | ExtendedCalendar Constructor Overload List


ExtendedCalendar Constructor (String, String, String, String, String)

Initializes a new instance of the ExtendedCalendar class.

public ExtendedCalendar(
string id,
string summary,
string description,
string location,
string timeZone
);

Parameters

id
Identifier of the resource.
summary
Title of the calendar.
description
Description of the calendar.
location
Geographic location of the calendar as free-form text.
timeZone
The time zone of the calendar.

See Also

ExtendedCalendar Class | Aspose.Email.Google Namespace | ExtendedCalendar Constructor Overload List


ExtendedCalendar Constructor (String, String, String, String, String, String, String, String, String, Boolean, Boolean, AccessRole, 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]][], Boolean)

public ExtendedCalendar(
string id,
string summary,
string description,
string location,
string timeZone,
string summaryOverride,
string colorId,
string backgroundColor,
string foregroundColor,
bool hidden,
bool selected,
AccessRole accessRole,
0, Culture=neutral, PublicKeyToken=b77a5c561934e089]][] defaultReminders,
bool primary
);

See Also

ExtendedCalendar Class | Aspose.Email.Google Namespace | ExtendedCalendar Constructor Overload List


ExtendedCalendar Constructor (String, String, String, String, String, String, String, String, String, String, Boolean, Boolean, AccessRole, 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]][], Boolean)

public ExtendedCalendar(
string id,
string eTag,
string summary,
string description,
string location,
string timeZone,
string summaryOverride,
string colorId,
string backgroundColor,
string foregroundColor,
bool hidden,
bool selected,
AccessRole accessRole,
0, Culture=neutral, PublicKeyToken=b77a5c561934e089]][] defaultReminders,
bool primary
);

See Also

ExtendedCalendar Class | Aspose.Email.Google Namespace | ExtendedCalendar Constructor Overload List


ExtendedCalendar Fields

The fields of the ExtendedCalendar class are listed below. For a complete list of ExtendedCalendar class members, see the ExtendedCalendar Members topic.

Public Static Fields

KIND | Type of the resource "calendar#calendarListEntry".
LIST_KIND | Type of the resources list "calendar#calendarList".

See Also

ExtendedCalendar Class | Aspose.Email.Google Namespace


ExtendedCalendar.KIND Field

Type of the resource "calendar#calendarListEntry".

new public const string KIND = "calendar#calendarListEntry";

See Also

ExtendedCalendar Class | Aspose.Email.Google Namespace


ExtendedCalendar.LIST_KIND Field

Type of the resources list "calendar#calendarList".

public const string LIST_KIND = "calendar#calendarList";

See Also

ExtendedCalendar Class | Aspose.Email.Google Namespace


ExtendedCalendar Properties

The properties of the ExtendedCalendar class are listed below. For a complete list of ExtendedCalendar class members, see the ExtendedCalendar Members topic.

Public Instance Properties

AccessRole | The effective access role that the authenticated user has on the calendar. Read-only. Possible values are:
BackgroundColor | The main color of the calendar in the format '#0088aa'. This property supersedes the index-based colorId property.
ColorId | The color of the calendar. This is an ID referring to an entry in the "calendar" section of the colors definition (see the "colors" endpoint).
DefaultReminders | The default reminders that the authenticated user has for this calendar.
Description (inherited from Calendar) | Description of the calendar.
ETag (inherited from BaseDataObject) | An ETag or entity tag is one of several mechanisms that HTTP provides for web cache validation, and which allows a client to make conditional requests. This allows caches to be more efficient, and saves bandwidth, as a web server does not need to send a full response if the content has not changed. ETags can also be used for optimistic concurrency control, as a way to help prevent simultaneous updates of a resource from overwriting each other.
ForegroundColor | The foreground color of the calendar in the format '#ffffff'. This property supersedes the index-based colorId property.
Hidden | Whether the calendar has been hidden from the list. The default is False.
Id (inherited from BaseDataObject) | Identifier of the resource.
Kind (inherited from BaseDataObject) | Type of the resource
Location (inherited from Calendar) | Geographic location of the calendar as free-form text.
NotificationSettings | The notifications that the authenticated user is receiving for this calendar.
Primary | Whether the calendar is the primary calendar of the authenticated user. Read-only. The default is False.
Selected | Whether the calendar content shows up in the calendar UI. The default is False.
Summary (inherited from Calendar) | Title of the calendar.
SummaryOverride | The summary that the authenticated user has set for this calendar.
TimeZone (inherited from Calendar) | The time zone of the calendar.

See Also

ExtendedCalendar Class | Aspose.Email.Google Namespace


AccessRole Property

Aspose.Email

ExtendedCalendar.AccessRole Property

The effective access role that the authenticated user has on the calendar. Read-only. Possible values are:

public virtual AccessRole AccessRole {get; set;}

See Also

ExtendedCalendar Class | Aspose.Email.Google Namespace


BackgroundColor Property

Aspose.Email

ExtendedCalendar.BackgroundColor Property

The main color of the calendar in the format '#0088aa'. This property supersedes the index-based colorId property.

public virtual string BackgroundColor {get; set;}

See Also

ExtendedCalendar Class | Aspose.Email.Google Namespace


ColorId Property

Aspose.Email

ExtendedCalendar.ColorId Property

The color of the calendar. This is an ID referring to an entry in the "calendar" section of the colors definition (see the "colors" endpoint).

public virtual string ColorId {get; set;}

See Also

ExtendedCalendar Class | Aspose.Email.Google Namespace


DefaultReminders Property

Aspose.Email

ExtendedCalendar.DefaultReminders Property

The default reminders that the authenticated user has for this calendar.

public virtual 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]][] DefaultReminders {get; set;}

See Also

ExtendedCalendar Class | Aspose.Email.Google Namespace


ForegroundColor Property

Aspose.Email

ExtendedCalendar.ForegroundColor Property

The foreground color of the calendar in the format '#ffffff'. This property supersedes the index-based colorId property.

public virtual string ForegroundColor {get; set;}

See Also

ExtendedCalendar Class | Aspose.Email.Google Namespace


Hidden Property

Aspose.Email

ExtendedCalendar.Hidden Property

Whether the calendar has been hidden from the list. The default is False.

public virtual bool Hidden {get; set;}

See Also

ExtendedCalendar Class | Aspose.Email.Google Namespace


NotificationSettings Property

Aspose.Email

ExtendedCalendar.NotificationSettings Property

The notifications that the authenticated user is receiving for this calendar.

public virtual 0, Culture=neutral, PublicKeyToken=null]][] NotificationSettings {get; set;}

See Also

ExtendedCalendar Class | Aspose.Email.Google Namespace


Primary Property

Aspose.Email

ExtendedCalendar.Primary Property

Whether the calendar is the primary calendar of the authenticated user. Read-only. The default is False.

public virtual bool Primary {get; set;}

See Also

ExtendedCalendar Class | Aspose.Email.Google Namespace


Selected Property

Aspose.Email

ExtendedCalendar.Selected Property

Whether the calendar content shows up in the calendar UI. The default is False.

public virtual bool Selected {get; set;}

See Also

ExtendedCalendar Class | Aspose.Email.Google Namespace


SummaryOverride Property

Aspose.Email

ExtendedCalendar.SummaryOverride Property

The summary that the authenticated user has set for this calendar.

public virtual string SummaryOverride {get; set;}

See Also

ExtendedCalendar Class | Aspose.Email.Google Namespace


ExtendedCalendar Methods

The methods of the ExtendedCalendar class are listed below. For a complete list of ExtendedCalendar class members, see the ExtendedCalendar Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a string which represents the object instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ExtendedCalendar Class | Aspose.Email.Google Namespace


ExtendedCalendar.ToString Method

Returns a string which represents the object instance.

public override string ToString();

Return Value

Returns a string which represents the object instance.

See Also

ExtendedCalendar Class | Aspose.Email.Google Namespace


FreebusyCalendarInfo Class

Defines list of free/busy information for specified calendar.

For a list of all members of this type, see FreebusyCalendarInfo Members.

System.Object
Aspose.Email.Google.FreebusyCalendarInfo

public class FreebusyCalendarInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Google

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FreebusyCalendarInfo Members | Aspose.Email.Google Namespace


FreebusyCalendarInfo Members

FreebusyCalendarInfo overview

Public Instance Constructors

FreebusyCalendarInfo Overloaded. Initializes a new instance of the FreebusyCalendarInfo class.

Public Instance Properties

Busy | List of time ranges during which this calendar should be regarded as busy.
CalendarId | Calendar Id
Errors | Optional error(s) (if computation for the calendar failed).

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FreebusyCalendarInfo Class | Aspose.Email.Google Namespace


FreebusyCalendarInfo Constructor

Initializes a new instance of the FreebusyCalendarInfo class.

Overload List

Initializes a new instance of the FreebusyCalendarInfo class.

public FreebusyCalendarInfo();

Initializes a new instance of the FreebusyCalendarInfo class.

public FreebusyCalendarInfo(string,ErrorDetails});

Initializes a new instance of the FreebusyCalendarInfo class.

public FreebusyCalendarInfo(string,ErrorDetails},Range});

Initializes a new instance of the FreebusyCalendarInfo class.

public FreebusyCalendarInfo(string,Range});

See Also

FreebusyCalendarInfo Class | Aspose.Email.Google Namespace


FreebusyCalendarInfo Constructor ()

Initializes a new instance of the FreebusyCalendarInfo class.

public FreebusyCalendarInfo();

See Also

FreebusyCalendarInfo Class | Aspose.Email.Google Namespace | FreebusyCalendarInfo Constructor Overload List


FreebusyCalendarInfo Constructor (String, ErrorDetails})

Initializes a new instance of the FreebusyCalendarInfo class.

public FreebusyCalendarInfo(
string calendarId,
IEnumerable<ErrorDetails> errors
);

Parameters

calendarId
Calendar Id
errors
Optional error(s) (if computation for the calendar failed).

See Also

FreebusyCalendarInfo Class | Aspose.Email.Google Namespace | FreebusyCalendarInfo Constructor Overload List


FreebusyCalendarInfo Constructor (String, Range})

Initializes a new instance of the FreebusyCalendarInfo class.

public FreebusyCalendarInfo(
string calendarId,
IEnumerable<Range> busy
);

Parameters

calendarId
Calendar Id
busy
List of time ranges during which this calendar should be regarded as busy.

See Also

FreebusyCalendarInfo Class | Aspose.Email.Google Namespace | FreebusyCalendarInfo Constructor Overload List


FreebusyCalendarInfo Constructor (String, ErrorDetails}, Range})

Initializes a new instance of the FreebusyCalendarInfo class.

public FreebusyCalendarInfo(
string calendarId,
IEnumerable<ErrorDetails> errors,
IEnumerable<Range> busy
);

Parameters

calendarId
Calendar Id
errors
Optional error(s) (if computation for the calendar failed).
busy
List of time ranges during which this calendar should be regarded as busy.

See Also

FreebusyCalendarInfo Class | Aspose.Email.Google Namespace | FreebusyCalendarInfo Constructor Overload List


FreebusyCalendarInfo Properties

The properties of the FreebusyCalendarInfo class are listed below. For a complete list of FreebusyCalendarInfo class members, see the FreebusyCalendarInfo Members topic.

Public Instance Properties

Busy | List of time ranges during which this calendar should be regarded as busy.
CalendarId | Calendar Id
Errors | Optional error(s) (if computation for the calendar failed).

See Also

FreebusyCalendarInfo Class | Aspose.Email.Google Namespace


Busy Property

Aspose.Email

FreebusyCalendarInfo.Busy Property

List of time ranges during which this calendar should be regarded as busy.

public Range} Busy {get;}

See Also

FreebusyCalendarInfo Class | Aspose.Email.Google Namespace


CalendarId Property

Aspose.Email

FreebusyCalendarInfo.CalendarId Property

Calendar Id

public string CalendarId {get; set;}

See Also

FreebusyCalendarInfo Class | Aspose.Email.Google Namespace


Errors Property

Aspose.Email

FreebusyCalendarInfo.Errors Property

Optional error(s) (if computation for the calendar failed).

public ErrorDetails} Errors {get;}

See Also

FreebusyCalendarInfo Class | Aspose.Email.Google Namespace


FreebusyGroupInfo Class

Specifies list of calendars that are members of the groups.

For a list of all members of this type, see FreebusyGroupInfo Members.

System.Object
Aspose.Email.Google.FreebusyGroupInfo

public class FreebusyGroupInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Google

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FreebusyGroupInfo Members | Aspose.Email.Google Namespace


FreebusyGroupInfo Members

FreebusyGroupInfo overview

Public Instance Constructors

FreebusyGroupInfo Overloaded. Initializes a new instance of the FreebusyGroupInfo class.

Public Instance Properties

Calendars | List of calendars' identifiers within a group.
Errors | Optional error(s) (if computation for the group failed).
GroupId | Group id

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FreebusyGroupInfo Class | Aspose.Email.Google Namespace


FreebusyGroupInfo Constructor

Initializes a new instance of the FreebusyGroupInfo class.

Overload List

Initializes a new instance of the FreebusyGroupInfo class.

public FreebusyGroupInfo();

Initializes a new instance of the FreebusyGroupInfo class.

public FreebusyGroupInfo(string,ErrorDetails});

Initializes a new instance of the FreebusyGroupInfo class.

public FreebusyGroupInfo(string,ErrorDetails},String});

Initializes a new instance of the FreebusyGroupInfo class.

public FreebusyGroupInfo(string,String});

See Also

FreebusyGroupInfo Class | Aspose.Email.Google Namespace


FreebusyGroupInfo Constructor ()

Initializes a new instance of the FreebusyGroupInfo class.

public FreebusyGroupInfo();

See Also

FreebusyGroupInfo Class | Aspose.Email.Google Namespace | FreebusyGroupInfo Constructor Overload List


FreebusyGroupInfo Constructor (String, ErrorDetails})

Initializes a new instance of the FreebusyGroupInfo class.

public FreebusyGroupInfo(
string groupId,
IEnumerable<ErrorDetails> errors
);

Parameters

groupId
Group id
errors
Optional error(s) (if computation for the group failed).

See Also

FreebusyGroupInfo Class | Aspose.Email.Google Namespace | FreebusyGroupInfo Constructor Overload List


FreebusyGroupInfo Constructor (String, String})

Initializes a new instance of the FreebusyGroupInfo class.

public FreebusyGroupInfo(
string groupId,
IEnumerable<string> calendars
);

Parameters

groupId
Group id
calendars
List of calendars' identifiers within a group.

See Also

FreebusyGroupInfo Class | Aspose.Email.Google Namespace | FreebusyGroupInfo Constructor Overload List


FreebusyGroupInfo Constructor (String, ErrorDetails}, String})

Initializes a new instance of the FreebusyGroupInfo class.

public FreebusyGroupInfo(
string groupId,
IEnumerable<ErrorDetails> errors,
IEnumerable<string> calendars
);

Parameters

groupId
Group id
errors
Optional error(s) (if computation for the group failed).
calendars
List of calendars' identifiers within a group.

See Also

FreebusyGroupInfo Class | Aspose.Email.Google Namespace | FreebusyGroupInfo Constructor Overload List


FreebusyGroupInfo Properties

The properties of the FreebusyGroupInfo class are listed below. For a complete list of FreebusyGroupInfo class members, see the FreebusyGroupInfo Members topic.

Public Instance Properties

Calendars | List of calendars' identifiers within a group.
Errors | Optional error(s) (if computation for the group failed).
GroupId | Group id

See Also

FreebusyGroupInfo Class | Aspose.Email.Google Namespace


Calendars Property

Aspose.Email

FreebusyGroupInfo.Calendars Property

List of calendars' identifiers within a group.

public String} Calendars {get;}

See Also

FreebusyGroupInfo Class | Aspose.Email.Google Namespace


Errors Property

Aspose.Email

FreebusyGroupInfo.Errors Property

Optional error(s) (if computation for the group failed).

public ErrorDetails} Errors {get;}

See Also

FreebusyGroupInfo Class | Aspose.Email.Google Namespace


GroupId Property

Aspose.Email

FreebusyGroupInfo.GroupId Property

Group id

public string GroupId {get; set;}

See Also

FreebusyGroupInfo Class | Aspose.Email.Google Namespace


FreebusyQuery Class

Request free/busy information for a set of calendars.

For a list of all members of this type, see FreebusyQuery Members.

System.Object
Aspose.Email.Google.FreebusyQuery

public class FreebusyQuery

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Google

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FreebusyQuery Members | Aspose.Email.Google Namespace


FreebusyQuery Members

FreebusyQuery overview

Public Instance Constructors

FreebusyQuery Overloaded. Initializes a new instance of the FreebusyQuery class.

Public Instance Properties

CalendarExpansionMax | Maximal number of calendars for which FreeBusy information is to be provided. Optional.
GroupExpansionMax | Maximal number of calendar identifiers to be provided for a single group. Optional. An error will be returned for a group with more members than this value.
Items | List of calendars and/or groups to query. Contains identifiers of a calendar or a group.
TimeMax | The end of the interval for the query.
TimeMin | The start of the interval for the query.
TimeZone | Time zone used in the response. Optional. The default is UTC.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FreebusyQuery Class | Aspose.Email.Google Namespace


FreebusyQuery Constructor

Initializes a new instance of the FreebusyQuery class.

Overload List

Initializes a new instance of the FreebusyQuery class.

public FreebusyQuery();

Initializes a new instance of the FreebusyQuery class.

public FreebusyQuery(DateTime,DateTime,String});

Initializes a new instance of the FreebusyQuery class.

public FreebusyQuery(DateTime,DateTime,string,String});

Initializes a new instance of the FreebusyQuery class.

public FreebusyQuery(DateTime,DateTime,string,Int32},Int32},String});

Initializes a new instance of the FreebusyQuery class.

public FreebusyQuery(DateTime,DateTime,string,Int32},Int32},params string[]);

Initializes a new instance of the FreebusyQuery class.

public FreebusyQuery(DateTime,DateTime,string,params string[]);

Initializes a new instance of the FreebusyQuery class.

public FreebusyQuery(DateTime,DateTime,params string[]);

See Also

FreebusyQuery Class | Aspose.Email.Google Namespace


FreebusyQuery Constructor ()

Initializes a new instance of the FreebusyQuery class.

public FreebusyQuery();

See Also

FreebusyQuery Class | Aspose.Email.Google Namespace | FreebusyQuery Constructor Overload List


FreebusyQuery Constructor (DateTime, DateTime, String})

Initializes a new instance of the FreebusyQuery class.

public FreebusyQuery(
DateTime timeMin,
DateTime timeMax,
IEnumerable<string> items
);

Parameters

timeMin
The end of the interval for the query.
timeMax
The end of the interval for the query.
items
List of calendars and/or groups to query. Contains identifiers of a calendar or a group.

See Also

FreebusyQuery Class | Aspose.Email.Google Namespace | FreebusyQuery Constructor Overload List


FreebusyQuery Constructor (DateTime, DateTime, String, String})

Initializes a new instance of the FreebusyQuery class.

public FreebusyQuery(
DateTime timeMin,
DateTime timeMax,
string timeZone,
IEnumerable<string> items
);

Parameters

timeMin
The end of the interval for the query.
timeMax
The end of the interval for the query.
timeZone
Time zone used in the response. Optional. The default is UTC.
items
List of calendars and/or groups to query. Contains identifiers of a calendar or a group.

See Also

FreebusyQuery Class | Aspose.Email.Google Namespace | FreebusyQuery Constructor Overload List


FreebusyQuery Constructor (DateTime, DateTime, String, Int32}, Int32}, String})

Initializes a new instance of the FreebusyQuery class.

public FreebusyQuery(
DateTime timeMin,
DateTime timeMax,
string timeZone,
Nullable<int> groupExpansionMax,
Nullable<int> calendarExpansionMax,
IEnumerable<string> items
);

Parameters

timeMin
The end of the interval for the query.
timeMax
The end of the interval for the query.
timeZone
Time zone used in the response. Optional. The default is UTC.
groupExpansionMax
Maximal number of calendar identifiers to be provided for a single group. Optional. An error will be returned for a group with more members than this value.
calendarExpansionMax
Maximal number of calendars for which FreeBusy information is to be provided. Optional.
items
List of calendars and/or groups to query. Contains identifiers of a calendar or a group.

See Also

FreebusyQuery Class | Aspose.Email.Google Namespace | FreebusyQuery Constructor Overload List


FreebusyQuery Constructor (DateTime, DateTime, String[])

Initializes a new instance of the FreebusyQuery class.

public FreebusyQuery(
DateTime timeMin,
DateTime timeMax,
params string[] items
);

Parameters

timeMin
The end of the interval for the query.
timeMax
The end of the interval for the query.
items
List of calendars and/or groups to query. Contains identifiers of a calendar or a group.

See Also

FreebusyQuery Class | Aspose.Email.Google Namespace | FreebusyQuery Constructor Overload List


FreebusyQuery Constructor (DateTime, DateTime, String, String[])

Initializes a new instance of the FreebusyQuery class.

public FreebusyQuery(
DateTime timeMin,
DateTime timeMax,
string timeZone,
params string[] items
);

Parameters

timeMin
The end of the interval for the query.
timeMax
The end of the interval for the query.
timeZone
Time zone used in the response. Optional. The default is UTC.
items
List of calendars and/or groups to query. Contains identifiers of a calendar or a group.

See Also

FreebusyQuery Class | Aspose.Email.Google Namespace | FreebusyQuery Constructor Overload List


FreebusyQuery Constructor (DateTime, DateTime, String, Int32}, Int32}, String[])

Initializes a new instance of the FreebusyQuery class.

public FreebusyQuery(
DateTime timeMin,
DateTime timeMax,
string timeZone,
Nullable<int> groupExpansionMax,
Nullable<int> calendarExpansionMax,
params string[] items
);

Parameters

timeMin
The end of the interval for the query.
timeMax
The end of the interval for the query.
timeZone
Time zone used in the response. Optional. The default is UTC.
groupExpansionMax
Maximal number of calendar identifiers to be provided for a single group. Optional. An error will be returned for a group with more members than this value.
calendarExpansionMax
Maximal number of calendars for which FreeBusy information is to be provided. Optional.
items
List of calendars and/or groups to query. Contains identifiers of a calendar or a group.

See Also

FreebusyQuery Class | Aspose.Email.Google Namespace | FreebusyQuery Constructor Overload List


FreebusyQuery Properties

The properties of the FreebusyQuery class are listed below. For a complete list of FreebusyQuery class members, see the FreebusyQuery Members topic.

Public Instance Properties

CalendarExpansionMax | Maximal number of calendars for which FreeBusy information is to be provided. Optional.
GroupExpansionMax | Maximal number of calendar identifiers to be provided for a single group. Optional. An error will be returned for a group with more members than this value.
Items | List of calendars and/or groups to query. Contains identifiers of a calendar or a group.
TimeMax | The end of the interval for the query.
TimeMin | The start of the interval for the query.
TimeZone | Time zone used in the response. Optional. The default is UTC.

See Also

FreebusyQuery Class | Aspose.Email.Google Namespace


CalendarExpansionMax Property

Aspose.Email

FreebusyQuery.CalendarExpansionMax Property

Maximal number of calendars for which FreeBusy information is to be provided. Optional.

public Int32} CalendarExpansionMax {get; set;}

See Also

FreebusyQuery Class | Aspose.Email.Google Namespace


GroupExpansionMax Property

Aspose.Email

FreebusyQuery.GroupExpansionMax Property

Maximal number of calendar identifiers to be provided for a single group. Optional. An error will be returned for a group with more members than this value.

public Int32} GroupExpansionMax {get; set;}

See Also

FreebusyQuery Class | Aspose.Email.Google Namespace


Items Property

Aspose.Email

FreebusyQuery.Items Property

List of calendars and/or groups to query. Contains identifiers of a calendar or a group.

public String} Items {get;}

See Also

FreebusyQuery Class | Aspose.Email.Google Namespace


TimeMax Property

Aspose.Email

FreebusyQuery.TimeMax Property

The end of the interval for the query.

public DateTime TimeMax {get; set;}

See Also

FreebusyQuery Class | Aspose.Email.Google Namespace


TimeMin Property

Aspose.Email

FreebusyQuery.TimeMin Property

The start of the interval for the query.

public DateTime TimeMin {get; set;}

See Also

FreebusyQuery Class | Aspose.Email.Google Namespace


TimeZone Property

Aspose.Email

FreebusyQuery.TimeZone Property

Time zone used in the response. Optional. The default is UTC.

public string TimeZone {get; set;}

See Also

FreebusyQuery Class | Aspose.Email.Google Namespace


FreebusyResponse Class

Freebusy response

For a list of all members of this type, see FreebusyResponse Members.

System.Object
Aspose.Email.Google.FreebusyResponse

public class FreebusyResponse

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Google

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FreebusyResponse Members | Aspose.Email.Google Namespace


FreebusyResponse Members

FreebusyResponse overview

Public Static Fields

KIND Type of the resource "calendar#freeBusy".

Public Instance Constructors

FreebusyResponse Overloaded. Initializes a new instance of the FreebusyResponse class.

Public Instance Properties

Calendars | List of free/busy information for calendars.
Groups | Expansion of groups.
TimeMax | The end of the interval for the query.
TimeMin | The start of the interval for the query.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FreebusyResponse Class | Aspose.Email.Google Namespace


FreebusyResponse Constructor

Initializes a new instance of the FreebusyResponse class.

Overload List

Initializes a new instance of the FreebusyResponse class.

public FreebusyResponse();

Initializes a new instance of the FreebusyResponse class.

public FreebusyResponse(DateTime,DateTime);

public FreebusyResponse(DateTime,DateTime,FreebusyGroupInfo},FreebusyCalendarInfo});

See Also

FreebusyResponse Class | Aspose.Email.Google Namespace


FreebusyResponse Constructor ()

Initializes a new instance of the FreebusyResponse class.

public FreebusyResponse();

See Also

FreebusyResponse Class | Aspose.Email.Google Namespace | FreebusyResponse Constructor Overload List


FreebusyResponse Constructor (DateTime, DateTime)

Initializes a new instance of the FreebusyResponse class.

public FreebusyResponse(
DateTime timeMin,
DateTime timeMax
);

Parameters

timeMin
The start of the interval for the query.
timeMax
The end of the interval for the query.

See Also

FreebusyResponse Class | Aspose.Email.Google Namespace | FreebusyResponse Constructor Overload List


FreebusyResponse Constructor (DateTime, DateTime, FreebusyGroupInfo}, FreebusyCalendarInfo})

public FreebusyResponse(
DateTime timeMin,
DateTime timeMax,
Dictionary<string, FreebusyGroupInfo> groups,
Dictionary<string, FreebusyCalendarInfo> calendars
);

See Also

FreebusyResponse Class | Aspose.Email.Google Namespace | FreebusyResponse Constructor Overload List


FreebusyResponse Fields

The fields of the FreebusyResponse class are listed below. For a complete list of FreebusyResponse class members, see the FreebusyResponse Members topic.

Public Static Fields

KIND Type of the resource "calendar#freeBusy".

See Also

FreebusyResponse Class | Aspose.Email.Google Namespace


FreebusyResponse.KIND Field

Type of the resource "calendar#freeBusy".

public const string KIND = "calendar#freeBusy";

See Also

FreebusyResponse Class | Aspose.Email.Google Namespace


FreebusyResponse Properties

The properties of the FreebusyResponse class are listed below. For a complete list of FreebusyResponse class members, see the FreebusyResponse Members topic.

Public Instance Properties

Calendars | List of free/busy information for calendars.
Groups | Expansion of groups.
TimeMax | The end of the interval for the query.
TimeMin | The start of the interval for the query.

See Also

FreebusyResponse Class | Aspose.Email.Google Namespace


Calendars Property

Aspose.Email

FreebusyResponse.Calendars Property

List of free/busy information for calendars.

public FreebusyCalendarInfo} Calendars {get;}

See Also

FreebusyResponse Class | Aspose.Email.Google Namespace


Groups Property

Aspose.Email

FreebusyResponse.Groups Property

Expansion of groups.

public FreebusyGroupInfo} Groups {get;}

See Also

FreebusyResponse Class | Aspose.Email.Google Namespace


TimeMax Property

Aspose.Email

FreebusyResponse.TimeMax Property

The end of the interval for the query.

public DateTime TimeMax {get; set;}

See Also

FreebusyResponse Class | Aspose.Email.Google Namespace


TimeMin Property

Aspose.Email

FreebusyResponse.TimeMin Property

The start of the interval for the query.

public DateTime TimeMin {get; set;}

See Also

FreebusyResponse Class | Aspose.Email.Google Namespace


Gadget Class

A gadget that extends this event.

For a list of all members of this type, see Gadget Members.

System.Object
Aspose.Email.Google.Gadget

public class Gadget

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Google

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Gadget Members | Aspose.Email.Google Namespace


Gadget Members

Gadget overview

Public Instance Constructors

Gadget Constructor Initializes a new instance of the Gadget class.

Public Instance Properties

Display | The gadget's display mode. Optional. Possible values are: "icon" - The gadget displays next to the event's title in the calendar view. "chip" - The gadget displays when the event is clicked.
Height | The gadget's height in pixels.
IconLink | The gadget's icon URL.
Link | The gadget's URL.
Preferences | The gadget's preferences
Title | The gadget's title.
Type | The gadget's type.
Width | The gadget's width in pixels.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Gadget Class | Aspose.Email.Google Namespace


Gadget Constructor

Initializes a new instance of the Gadget class.

public Gadget();

See Also

Gadget Class | Aspose.Email.Google Namespace


Gadget Properties

The properties of the Gadget class are listed below. For a complete list of Gadget class members, see the Gadget Members topic.

Public Instance Properties

Display | The gadget's display mode. Optional. Possible values are: "icon" - The gadget displays next to the event's title in the calendar view. "chip" - The gadget displays when the event is clicked.
Height | The gadget's height in pixels.
IconLink | The gadget's icon URL.
Link | The gadget's URL.
Preferences | The gadget's preferences
Title | The gadget's title.
Type | The gadget's type.
Width | The gadget's width in pixels.

See Also

Gadget Class | Aspose.Email.Google Namespace


Display Property

Aspose.Email

Gadget.Display Property

The gadget's display mode. Optional. Possible values are: "icon" - The gadget displays next to the event's title in the calendar view. "chip" - The gadget displays when the event is clicked.

public string Display {get; set;}

See Also

Gadget Class | Aspose.Email.Google Namespace


Height Property

Aspose.Email

Gadget.Height Property

The gadget's height in pixels.

public int Height {get; set;}

See Also

Gadget Class | Aspose.Email.Google Namespace


IconLink Property

Aspose.Email

Gadget.IconLink Property

The gadget's icon URL.

public string IconLink {get; set;}

See Also

Gadget Class | Aspose.Email.Google Namespace


Link Property

Aspose.Email

Gadget.Link Property

The gadget's URL.

public string Link {get; set;}

See Also

Gadget Class | Aspose.Email.Google Namespace


Preferences Property

Aspose.Email

Gadget.Preferences Property

The gadget's preferences

public String} Preferences {get;}

See Also

Gadget Class | Aspose.Email.Google Namespace


Title Property

Aspose.Email

Gadget.Title Property

The gadget's title.

public string Title {get; set;}

See Also

Gadget Class | Aspose.Email.Google Namespace


Type Property

Aspose.Email

Gadget.Type Property

The gadget's type.

public string Type {get; set;}

See Also

Gadget Class | Aspose.Email.Google Namespace


Width Property

Aspose.Email

Gadget.Width Property

The gadget's width in pixels.

public int Width {get; set;}

See Also

Gadget Class | Aspose.Email.Google Namespace


GmailClient Class

Base class for Gmail client

For a list of all members of this type, see GmailClient Members.

System.Object
Aspose.Email.Google.GmailClient

public abstract class GmailClient : IBaseGmailClient, IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Google

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GmailClient Members | Aspose.Email.Google Namespace


GmailClient Members

GmailClient overview

Public Static Properties

DefaultTimeout Gets or sets the default timeout value for ActiveSync client instances The default value is 100,000 milliseconds (100 seconds).

Public Static Methods

GetInstance Overloaded. Gets instance of Gmail client

Public Instance Properties

AccessToken | Gets or sets OAuth 2.0 access token In case if refresh token is set, access token is generated automatically.
Proxy | Gets or sets the proxy.
Timeout | Gets or sets the number of milliseconds to wait before the operation times out. The default value is 100,000 milliseconds (100 seconds).

Public Instance Methods

Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RefreshToken | Refresh access token
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GmailClient Class | Aspose.Email.Google Namespace


GmailClient Properties

The properties of the GmailClient class are listed below. For a complete list of GmailClient class members, see the GmailClient Members topic.

Public Static Properties

DefaultTimeout Gets or sets the default timeout value for ActiveSync client instances The default value is 100,000 milliseconds (100 seconds).

Public Instance Properties

AccessToken | Gets or sets OAuth 2.0 access token In case if refresh token is set, access token is generated automatically.
Proxy | Gets or sets the proxy.
Timeout | Gets or sets the number of milliseconds to wait before the operation times out. The default value is 100,000 milliseconds (100 seconds).

See Also

GmailClient Class | Aspose.Email.Google Namespace


AccessToken Property

Aspose.Email

GmailClient.AccessToken Property

Gets or sets OAuth 2.0 access token In case if refresh token is set, access token is generated automatically.

public string AccessToken {get; set;}

Implements

IBaseGmailClient.AccessToken

See Also

GmailClient Class | Aspose.Email.Google Namespace


DefaultTimeout Property

Aspose.Email

GmailClient.DefaultTimeout Property

Gets or sets the default timeout value for ActiveSync client instances The default value is 100,000 milliseconds (100 seconds).

public static int DefaultTimeout {get; set;}

See Also

GmailClient Class | Aspose.Email.Google Namespace


Proxy Property

Aspose.Email

GmailClient.Proxy Property

Gets or sets the proxy.

public WebProxy Proxy {get; set;}

Implements

IBaseGmailClient.Proxy

See Also

GmailClient Class | Aspose.Email.Google Namespace


Timeout Property

Aspose.Email

GmailClient.Timeout Property

Gets or sets the number of milliseconds to wait before the operation times out. The default value is 100,000 milliseconds (100 seconds).

public virtual int Timeout {get; set;}

Implements

IBaseGmailClient.Timeout

See Also

GmailClient Class | Aspose.Email.Google Namespace


GmailClient Methods

The methods of the GmailClient class are listed below. For a complete list of GmailClient class members, see the GmailClient Members topic.

Public Static Methods

GetInstance Overloaded. Gets instance of Gmail client

Public Instance Methods

Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RefreshToken | Refresh access token
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GmailClient Class | Aspose.Email.Google Namespace


GmailClient.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

public virtual void Dispose();

Implements

IDisposable.Dispose

See Also

GmailClient Class | Aspose.Email.Google Namespace


GetInstance Method

Aspose.Email

GmailClient.GetInstance Method

Gets instance of Gmail client

Overload List

Gets instance of Gmail client

public static IGmailClient GetInstance(string);

Gets instance of Gmail client

public static IGmailClient GetInstance(string,WebProxy);

Gets instance of Gmail client

public static IGmailClient GetInstance(string,string,string);

Gets instance of Gmail client

public static IGmailClient GetInstance(string,string,string,WebProxy);

See Also

GmailClient Class | Aspose.Email.Google Namespace


GmailClient.GetInstance Method (String)

Gets instance of Gmail client

public static IGmailClient GetInstance(
string accessToken
);

Parameters

accessToken
OAuth 2.0 access token

Return Value

Returns instance of Gmail client

See Also

GmailClient Class | Aspose.Email.Google Namespace | GmailClient.GetInstance Overload List


GmailClient.GetInstance Method (String, WebProxy)

Gets instance of Gmail client

public static IGmailClient GetInstance(
string accessToken,
WebProxy proxy
);

Parameters

accessToken
OAuth 2.0 access token
proxy
WebProxy for Gmail client

Return Value

Returns instance of Gmail client

See Also

GmailClient Class | Aspose.Email.Google Namespace | GmailClient.GetInstance Overload List


GmailClient.GetInstance Method (String, String, String)

Gets instance of Gmail client

public static IGmailClient GetInstance(
string clientId,
string clientSecret,
string refreshToken
);

Parameters

clientId
The client ID obtained from the Google Cloud Console during application registration.
clientSecret
The client secret obtained during application registration.
refreshToken
OAuth 2.0 refresh token

Return Value

Returns instance of Gmail client

See Also

GmailClient Class | Aspose.Email.Google Namespace | GmailClient.GetInstance Overload List


GmailClient.GetInstance Method (String, String, String, WebProxy)

Gets instance of Gmail client

public static IGmailClient GetInstance(
string clientId,
string clientSecret,
string refreshToken,
WebProxy proxy
);

Parameters

clientId
The client ID obtained from the Google Cloud Console during application registration.
clientSecret
The client secret obtained during application registration.
refreshToken
OAuth 2.0 refresh token
proxy
WebProxy for Gmail client

Return Value

Returns instance of Gmail client

See Also

GmailClient Class | Aspose.Email.Google Namespace | GmailClient.GetInstance Overload List


GmailClient.RefreshToken Method

Refresh access token

public virtual void RefreshToken();

Implements

IBaseGmailClient.RefreshToken

See Also

GmailClient Class | Aspose.Email.Google Namespace


IBaseGmailClient Interface

Interface for base class of Gmail client

For a list of all members of this type, see IBaseGmailClient Members.

Aspose.Email.Google.IBaseGmailClient
Aspose.Email.Google.IGmailClient

public interface IBaseGmailClient : IDisposable

Types that implement IBaseGmailClient

Type | Description
GmailClient | Base class for Gmail client

Requirements

Namespace: Aspose.Email.Google

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

IBaseGmailClient Members | Aspose.Email.Google Namespace


IBaseGmailClient Members

IBaseGmailClient overview

Public Instance Properties

AccessToken | Gets or sets OAuth 2.0 bearer token
Proxy | Gets or sets the proxy.
Timeout | Gets or sets the number of milliseconds to wait before the operation times out. The default value is 100,000 milliseconds (100 seconds).

Public Instance Methods

RefreshToken Refresh access token

See Also

IBaseGmailClient Interface | Aspose.Email.Google Namespace


IBaseGmailClient Properties

The properties of the IBaseGmailClient interface are listed below. For a complete list of IBaseGmailClient interface members, see the IBaseGmailClient Members topic.

Public Instance Properties

AccessToken | Gets or sets OAuth 2.0 bearer token
Proxy | Gets or sets the proxy.
Timeout | Gets or sets the number of milliseconds to wait before the operation times out. The default value is 100,000 milliseconds (100 seconds).

See Also

IBaseGmailClient Interface | Aspose.Email.Google Namespace


AccessToken Property

Aspose.Email

IBaseGmailClient.AccessToken Property

Gets or sets OAuth 2.0 bearer token

string AccessToken {get; set;}

See Also

IBaseGmailClient Interface | Aspose.Email.Google Namespace


Proxy Property

Aspose.Email

IBaseGmailClient.Proxy Property

Gets or sets the proxy.

WebProxy Proxy {get; set;}

See Also

IBaseGmailClient Interface | Aspose.Email.Google Namespace


Timeout Property

Aspose.Email

IBaseGmailClient.Timeout Property

Gets or sets the number of milliseconds to wait before the operation times out. The default value is 100,000 milliseconds (100 seconds).

int Timeout {get; set;}

See Also

IBaseGmailClient Interface | Aspose.Email.Google Namespace


IBaseGmailClient Methods

The methods of the IBaseGmailClient interface are listed below. For a complete list of IBaseGmailClient interface members, see the IBaseGmailClient Members topic.

Public Instance Methods

RefreshToken Refresh access token

See Also

IBaseGmailClient Interface | Aspose.Email.Google Namespace


IBaseGmailClient.RefreshToken Method

Refresh access token

void RefreshToken();

See Also

IBaseGmailClient Interface | Aspose.Email.Google Namespace


IGmailClient Interface

Represents the interface for Gmail client

For a list of all members of this type, see IGmailClient Members.

public interface IGmailClient : IBaseGmailClient, IDisposable

Requirements

Namespace: Aspose.Email.Google

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

IGmailClient Members | Aspose.Email.Google Namespace


IGmailClient Members

IGmailClient overview

Public Instance Methods

ClearCalendar | Clears a calendar.
CreateAccessRule | Creates access rule
CreateAppointment | Creates an appointment.
CreateCalendar | Overloaded. Creates a calendar.
DeleteAccessRule | Deletes access rule
DeleteAppointment | Deletes an appointment.
DeleteCalendar | Deletes a calendar.
FetchAccessRule | Fetches access rule
FetchAllContacts | Fetches all contacts.
FetchAllGroups | Fetches all contact groups.
FetchAppointment | Fetches appointment by identifier.
FetchCalendar | Fetches calendar by identifier.
FetchContact | Fetches the contact
FetchContactGroup | Overloaded. Retrieves a single group entry for a group that a given contact belongs to
FetchContactsFromGroup | Overloaded. Fetches contacts belonging to the group specified.
GetColors | Gets color information
GetFreebusyInfo | Gets free/busy information
GetSetting | Gets settings by the name
GetSettings | Gets settings dictionary
ImportAppointment | Imports appointment to calendar
ListAccessRules | Gets list of access rules
ListAppointmentInstances | Gets list of an appointment instances for calendar.
ListAppointments | Gets list of an appointments for calendar.
ListCalendars | Overloaded. Gets array of calendars.
MoveAppointment | Overloaded. Moves an appointment to another calendar.
UpdateAccessRule | Updates access rule
UpdateAppointment | Updates an appointment.
UpdateCalendar | Overloaded. Updates a calendar

See Also

IGmailClient Interface | Aspose.Email.Google Namespace


IGmailClient Methods

The methods of the IGmailClient interface are listed below. For a complete list of IGmailClient interface members, see the IGmailClient Members topic.

Public Instance Methods

ClearCalendar | Clears a calendar.
CreateAccessRule | Creates access rule
CreateAppointment | Creates an appointment.
CreateCalendar | Overloaded. Creates a calendar.
DeleteAccessRule | Deletes access rule
DeleteAppointment | Deletes an appointment.
DeleteCalendar | Deletes a calendar.
FetchAccessRule | Fetches access rule
FetchAllContacts | Fetches all contacts.
FetchAllGroups | Fetches all contact groups.
FetchAppointment | Fetches appointment by identifier.
FetchCalendar | Fetches calendar by identifier.
FetchContact | Fetches the contact
FetchContactGroup | Overloaded. Retrieves a single group entry for a group that a given contact belongs to
FetchContactsFromGroup | Overloaded. Fetches contacts belonging to the group specified.
GetColors | Gets color information
GetFreebusyInfo | Gets free/busy information
GetSetting | Gets settings by the name
GetSettings | Gets settings dictionary
ImportAppointment | Imports appointment to calendar
ListAccessRules | Gets list of access rules
ListAppointmentInstances | Gets list of an appointment instances for calendar.
ListAppointments | Gets list of an appointments for calendar.
ListCalendars | Overloaded. Gets array of calendars.
MoveAppointment | Overloaded. Moves an appointment to another calendar.
UpdateAccessRule | Updates access rule
UpdateAppointment | Updates an appointment.
UpdateCalendar | Overloaded. Updates a calendar

See Also

IGmailClient Interface | Aspose.Email.Google Namespace


IGmailClient.ClearCalendar Method

Clears a calendar.

void ClearCalendar(
string calendarId
);

Parameters

calendarId
Calendar identifier.

See Also

IGmailClient Interface | Aspose.Email.Google Namespace


IGmailClient.CreateAccessRule Method

Creates access rule

AccessControlRule CreateAccessRule(
string calendarId,
AccessControlRule role
);

Parameters

calendarId
Calendar identifier.
role
Access control rule

Return Value

Returns created access rule

See Also

IGmailClient Interface | Aspose.Email.Google Namespace


IGmailClient.CreateAppointment Method

Creates an appointment.

Appointment CreateAppointment(
string calendarId,
Appointment appointment
);

Parameters

calendarId
Calendar identifier.
appointment
An instance of appointment object to create.

Return Value

Returns the created appointment.

See Also

IGmailClient Interface | Aspose.Email.Google Namespace


CreateCalendar Method

Aspose.Email

IGmailClient.CreateCalendar Method

Creates a calendar.

Overload List

Creates a calendar.

string CreateCalendar(Calendar);

Creates a calendar.

string CreateCalendar(Calendar,bool);

See Also

IGmailClient Interface | Aspose.Email.Google Namespace


IGmailClient.CreateCalendar Method (Calendar)

Creates a calendar.

string CreateCalendar(
Calendar calendar
);

Parameters

calendar
An instance of calendar object to create.

Return Value

Returns calendar identifier

See Also

IGmailClient Interface | Aspose.Email.Google Namespace | IGmailClient.CreateCalendar Overload List


IGmailClient.CreateCalendar Method (Calendar, Boolean)

Creates a calendar.

string CreateCalendar(
Calendar calendar,
bool useColorRgbFormat
);

Parameters

calendar
An instance of calendar object to create.
useColorRgbFormat
Indicates whether color rgb format is used.

Return Value

Returns calendar identifier

See Also

IGmailClient Interface | Aspose.Email.Google Namespace | IGmailClient.CreateCalendar Overload List


IGmailClient.DeleteAccessRule Method

Deletes access rule

void DeleteAccessRule(
string calendarId,
string roleId
);

Parameters

calendarId
Calendar identifier.
roleId
Role identifier.

See Also

IGmailClient Interface | Aspose.Email.Google Namespace


IGmailClient.DeleteAppointment Method

Deletes an appointment.

void DeleteAppointment(
string calendarId,
string appointmentId
);

Parameters

calendarId
Calendar identifier.
appointmentId
Appointment identifier.

See Also

IGmailClient Interface | Aspose.Email.Google Namespace


IGmailClient.DeleteCalendar Method

Deletes a calendar.

void DeleteCalendar(
string calendarId
);

Parameters

calendarId
Calendar identifier.

See Also

IGmailClient Interface | Aspose.Email.Google Namespace


IGmailClient.FetchAccessRule Method

Fetches access rule

AccessControlRule FetchAccessRule(
string calendarId,
string roleId
);

Parameters

calendarId
Calendar identifier.
roleId
Role identifier.

Return Value

Returns fetched access rule

See Also

IGmailClient Interface | Aspose.Email.Google Namespace


IGmailClient.FetchAllContacts Method

Fetches all contacts.

FeedEntryCollection FetchAllContacts();

Return Value

Contacts array

Exceptions

Exception Type | Condition
WebException | when operation fails

See Also

IGmailClient Interface | Aspose.Email.Google Namespace


IGmailClient.FetchAllGroups Method

Fetches all contact groups.

FeedEntryCollection FetchAllGroups();

Return Value

Contact groups collection

Exceptions

Exception Type | Condition
WebException | when operation fails

See Also

IGmailClient Interface | Aspose.Email.Google Namespace


IGmailClient.FetchAppointment Method

Fetches appointment by identifier.

Appointment FetchAppointment(
string calendarId,
string appointmentId
);

Parameters

calendarId
Calendar identifier.
appointmentId
Appointment identifier.

Return Value

Returns fetched appointment.

See Also

IGmailClient Interface | Aspose.Email.Google Namespace


IGmailClient.FetchCalendar Method

Fetches calendar by identifier.

ExtendedCalendar FetchCalendar(
string calendarId
);

Parameters

calendarId
Calendar identifier.

Return Value

Returns fetched calendar.

See Also

IGmailClient Interface | Aspose.Email.Google Namespace


IGmailClient.FetchContact Method

Fetches the contact

GmailContact FetchContact(
string contactId
);

Parameters

contactId
String, that represents contact's Id

Return Value

GmailContact object, that represents a contact of gmail

Exceptions

Exception Type | Condition
ArgumentNullException | contactId is null or empty.
WebException | when operation fails

See Also

IGmailClient Interface | Aspose.Email.Google Namespace


FetchContactGroup Method

Aspose.Email

IGmailClient.FetchContactGroup Method

Retrieves a single group entry for a group that a given contact belongs to

Overload List

Retrieves a single group entry for a group that a given contact belongs to

GmailContactGroup FetchContactGroup(IFeedEntry);

Retrieves a single group entry for a group that a given contact belongs to

GmailContactGroup FetchContactGroup(string);

See Also

IGmailClient Interface | Aspose.Email.Google Namespace


IGmailClient.FetchContactGroup Method (IFeedEntry)

Retrieves a single group entry for a group that a given contact belongs to

GmailContactGroup FetchContactGroup(
IFeedEntry entry
);

Parameters

entry
GmailContactGroup object that contains group id for a contact

Return Value

GmailContactGroup object that represents group for a contact

Exceptions

Exception Type | Condition
ArgumentException | entry contains empty group id.
WebException | when operation fails

See Also

IGmailClient Interface | Aspose.Email.Google Namespace | IGmailClient.FetchContactGroup Overload List


IGmailClient.FetchContactGroup Method (String)

Retrieves a single group entry for a group that a given contact belongs to

GmailContactGroup FetchContactGroup(
string groupId
);

Parameters

groupId

Return Value

GmailContactGroup object that represents group for a contact

Exceptions

Exception Type | Condition
ArgumentNullException | contact is null.
WebException | when operation fails

See Also

IGmailClient Interface | Aspose.Email.Google Namespace | IGmailClient.FetchContactGroup Overload List


FetchContactsFromGroup Method

Aspose.Email

IGmailClient.FetchContactsFromGroup Method

Fetches contacts belonging to the group specified.

Overload List

Fetches contacts belonging to the group specified.

FeedEntryCollection FetchContactsFromGroup(IFeedEntry);

Fetches contacts belonging to the group specified.

FeedEntryCollection FetchContactsFromGroup(string);

See Also

IGmailClient Interface | Aspose.Email.Google Namespace


IGmailClient.FetchContactsFromGroup Method (IFeedEntry)

Fetches contacts belonging to the group specified.

FeedEntryCollection FetchContactsFromGroup(
IFeedEntry entry
);

Parameters

entry
GmailContactGroup object that contains group id for a contact

Return Value

Contacts collection

Exceptions

Exception Type | Condition
ArgumentException | entry contains empty group id.
WebException | when operation fails

See Also

IGmailClient Interface | Aspose.Email.Google Namespace | IGmailClient.FetchContactsFromGroup Overload List


IGmailClient.FetchContactsFromGroup Method (String)

Fetches contacts belonging to the group specified.

FeedEntryCollection FetchContactsFromGroup(
string groupId
);

Parameters

groupId
string that represents group id for a contact

Return Value

Contacts array

Exceptions

Exception Type | Condition
ArgumentNullException | groupId is null or empty.
WebException | when operation fails

See Also

IGmailClient Interface | Aspose.Email.Google Namespace | IGmailClient.FetchContactsFromGroup Overload List


IGmailClient.GetColors Method

Gets color information

ColorsInfo GetColors();

Return Value

Returns color information

See Also

IGmailClient Interface | Aspose.Email.Google Namespace


IGmailClient.GetFreebusyInfo Method

Gets free/busy information

FreebusyResponse GetFreebusyInfo(
FreebusyQuery query
);

Parameters

query
Query to get free/busy information

Return Value

Returns free/busy information.

See Also

IGmailClient Interface | Aspose.Email.Google Namespace


IGmailClient.GetSetting Method

Gets settings by the name

string GetSetting(
string setting
);

Parameters

setting
Setting name

Return Value

Returns settings value

See Also

IGmailClient Interface | Aspose.Email.Google Namespace


IGmailClient.GetSettings Method

Gets settings dictionary

Dictionary<string, string> GetSettings();

Return Value

Returns settings dictionary

See Also

IGmailClient Interface | Aspose.Email.Google Namespace


IGmailClient.ImportAppointment Method

Imports appointment to calendar

Appointment ImportAppointment(
string calendarId,
Appointment appointment
);

Parameters

calendarId
Calendar identifier.
appointment
An instance of appointment object to import.

Return Value

Returns the imported appointment.

See Also

IGmailClient Interface | Aspose.Email.Google Namespace


IGmailClient.ListAccessRules Method

Gets list of access rules

AccessControlRule[] ListAccessRules(
string calendarId
);

Parameters

calendarId
Calendar identifier.

Return Value

Returns list of access rules

See Also

IGmailClient Interface | Aspose.Email.Google Namespace


IGmailClient.ListAppointmentInstances Method

Gets list of an appointment instances for calendar.

Appointment[] ListAppointmentInstances(
string calendarId,
string appointmentId
);

Parameters

calendarId
Calendar identifier.
appointmentId
Appointment identifier.

Return Value

Returns list of an appointment instances for calendar.

See Also

IGmailClient Interface | Aspose.Email.Google Namespace


IGmailClient.ListAppointments Method

Gets list of an appointments for calendar.

Appointment[] ListAppointments(
string calendarId
);

Parameters

calendarId
Calendar identifier.

Return Value

Returns list of an appointments for calendar.

See Also

IGmailClient Interface | Aspose.Email.Google Namespace


ListCalendars Method

Aspose.Email

IGmailClient.ListCalendars Method

Gets array of calendars.

Overload List

Gets array of calendars.

ExtendedCalendar[] ListCalendars();

Gets array of calendars.

ExtendedCalendar[] ListCalendars(AccessRole,bool);

See Also

IGmailClient Interface | Aspose.Email.Google Namespace


IGmailClient.ListCalendars Method ()

Gets array of calendars.

ExtendedCalendar[] ListCalendars();

Return Value

Returns array of calendars.

See Also

IGmailClient Interface | Aspose.Email.Google Namespace | IGmailClient.ListCalendars Overload List


IGmailClient.ListCalendars Method (AccessRole, Boolean)

Gets array of calendars.

ExtendedCalendar[] ListCalendars(
AccessRole minAccessRole,
bool showHidden
);

Parameters

minAccessRole
The effective access role that the authenticated user has on the calendar.
showHidden
Show hidden calendars

Return Value

Returns array of calendars.

See Also

IGmailClient Interface | Aspose.Email.Google Namespace | IGmailClient.ListCalendars Overload List


MoveAppointment Method

Aspose.Email

IGmailClient.MoveAppointment Method

Moves an appointment to another calendar.

Overload List

Moves an appointment to another calendar.

Appointment MoveAppointment(string,string,string);

Moves an appointment to another calendar.

Appointment MoveAppointment(string,string,string,bool);

See Also

IGmailClient Interface | Aspose.Email.Google Namespace


IGmailClient.MoveAppointment Method (String, String, String)

Moves an appointment to another calendar.

Appointment MoveAppointment(
string sourceCalendarId,
string destinationCalendarId,
string appointmentId
);

Parameters

sourceCalendarId
Identifier of source calendar.
destinationCalendarId
Identifier of destination calendar.
appointmentId
Appointment identifier.

Return Value

Returns moved appointment.

See Also

IGmailClient Interface | Aspose.Email.Google Namespace | IGmailClient.MoveAppointment Overload List


IGmailClient.MoveAppointment Method (String, String, String, Boolean)

Moves an appointment to another calendar.

Appointment MoveAppointment(
string sourceCalendarId,
string destinationCalendarId,
string appointmentId,
bool sendNotifications
);

Parameters

sourceCalendarId
Identifier of source calendar.
destinationCalendarId
Identifier of destination calendar.
appointmentId
Appointment identifier.
sendNotifications
Specifies whether notification should be sent.

Return Value

Returns moved appointment.

See Also

IGmailClient Interface | Aspose.Email.Google Namespace | IGmailClient.MoveAppointment Overload List


IGmailClient.UpdateAccessRule Method

Updates access rule

AccessControlRule UpdateAccessRule(
string calendarId,
AccessControlRule role
);

Parameters

calendarId
Calendar identifier.
role
Access control rule

Return Value

Returns updated access rule

See Also

IGmailClient Interface | Aspose.Email.Google Namespace


IGmailClient.UpdateAppointment Method

Updates an appointment.

Appointment UpdateAppointment(
string calendarId,
Appointment appointment
);

Parameters

calendarId
Calendar identifier.
appointment
An instance of appointment object to update.

Return Value

Returns updated appointment.

See Also

IGmailClient Interface | Aspose.Email.Google Namespace


UpdateCalendar Method

Aspose.Email

IGmailClient.UpdateCalendar Method

Updates a calendar

Overload List

Updates a calendar

void UpdateCalendar(Calendar);

Updates a calendar

void UpdateCalendar(Calendar,bool);

See Also

IGmailClient Interface | Aspose.Email.Google Namespace


IGmailClient.UpdateCalendar Method (Calendar)

Updates a calendar

void UpdateCalendar(
Calendar calendar
);

Parameters

calendar
An instance of calendar object to update.

See Also

IGmailClient Interface | Aspose.Email.Google Namespace | IGmailClient.UpdateCalendar Overload List


IGmailClient.UpdateCalendar Method (Calendar, Boolean)

Updates a calendar

void UpdateCalendar(
Calendar calendar,
bool useColorRgbFormat
);

Parameters

calendar
An instance of calendar object to update.
useColorRgbFormat
Indicates whether color rgb format is used.

See Also

IGmailClient Interface | Aspose.Email.Google Namespace | IGmailClient.UpdateCalendar Overload List


NotificationMethod Enumeration

The method used by this notification.

public enum NotificationMethod

Members

Member Name | Description | Value
Email | Reminders are sent via email. | 0
Sms | Reminders are sent via SMS. | 1

Requirements

Namespace: Aspose.Email.Google

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Google Namespace


NotificationType Enumeration

The type of notification.

public enum NotificationType

Members

Member Name | Description | Value
EventCreation | Notification sent when a new event is put on the calendar. | 0
EventChange | Notification sent when an event is changed. | 1
EventCancellation | Notification sent when an event is cancelled. | 2
EventResponse | Notification sent when an event is changed. | 3
Agenda | An agenda with the events of the day (sent out in the morning). | 4

Requirements

Namespace: Aspose.Email.Google

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Google Namespace


Range Class

Time range during which calendar should be regarded as busy.

For a list of all members of this type, see Range Members.

System.Object
Aspose.Email.Google.Range

public class Range

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Google

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Range Members | Aspose.Email.Google Namespace


Range Members

Range overview

Public Instance Constructors

Range Overloaded. Initializes a new instance of the Range class.

Public Instance Properties

End | The end of the time period.
Start | The start of the time period.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String which represents the object instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Range Class | Aspose.Email.Google Namespace


Range Constructor

Initializes a new instance of the Range class.

Overload List

Initializes a new instance of the Range class.

public Range();

Initializes a new instance of the Range class.

public Range(DateTime,DateTime);

See Also

Range Class | Aspose.Email.Google Namespace


Range Constructor ()

Initializes a new instance of the Range class.

public Range();

See Also

Range Class | Aspose.Email.Google Namespace | Range Constructor Overload List


Range Constructor (DateTime, DateTime)

Initializes a new instance of the Range class.

public Range(
DateTime start,
DateTime end
);

Parameters

start
The start of the time period.
end
The end of the time period.

See Also

Range Class | Aspose.Email.Google Namespace | Range Constructor Overload List


Range Properties

The properties of the Range class are listed below. For a complete list of Range class members, see the Range Members topic.

Public Instance Properties

End | The end of the time period.
Start | The start of the time period.

See Also

Range Class | Aspose.Email.Google Namespace


End Property

Aspose.Email

Range.End Property

The end of the time period.

public DateTime End {get; set;}

See Also

Range Class | Aspose.Email.Google Namespace


Start Property

Aspose.Email

Range.Start Property

The start of the time period.

public DateTime Start {get; set;}

See Also

Range Class | Aspose.Email.Google Namespace


Range Methods

The methods of the Range class are listed below. For a complete list of Range class members, see the Range Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String which represents the object instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Range Class | Aspose.Email.Google Namespace


Range.ToString Method

Returns a String which represents the object instance.

public override string ToString();

Return Value

Returns a String which represents the object instance.

See Also

Range Class | Aspose.Email.Google Namespace


ReminderMethods Enumeration

The method used by this reminder.

public enum ReminderMethods

Members

Member Name | Description | Value
email | Reminders are sent via email. | 0
sms | Reminders are sent via SMS. | 1
popup | Reminders are sent via a UI popup. | 2

Requirements

Namespace: Aspose.Email.Google

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Google Namespace


Reminders Class

Information about the event's reminders for the authenticated user.

For a list of all members of this type, see Reminders Members.

System.Object
Aspose.Email.Google.Reminders

public class Reminders

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Google

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Reminders Members | Aspose.Email.Google Namespace


Reminders Members

Reminders overview

Public Instance Constructors

Reminders Constructor Initializes a new instance of the Reminders class.

Public Instance Properties

Overrides | If the event doesn't use the default reminders, this lists the reminders specific to the event, or, if not set, indicates that no reminders are set for this event.
UseDefault | Whether the default reminders of the calendar apply to the event.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Reminders Class | Aspose.Email.Google Namespace


Reminders Constructor

Initializes a new instance of the Reminders class.

public Reminders();

See Also

Reminders Class | Aspose.Email.Google Namespace


Reminders Properties

The properties of the Reminders class are listed below. For a complete list of Reminders class members, see the Reminders Members topic.

Public Instance Properties

Overrides | If the event doesn't use the default reminders, this lists the reminders specific to the event, or, if not set, indicates that no reminders are set for this event.
UseDefault | Whether the default reminders of the calendar apply to the event.

See Also

Reminders Class | Aspose.Email.Google Namespace


Overrides Property

Aspose.Email

Reminders.Overrides Property

If the event doesn't use the default reminders, this lists the reminders specific to the event, or, if not set, indicates that no reminders are set for this event.

public 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]][] Overrides {get; set;}

See Also

Reminders Class | Aspose.Email.Google Namespace


UseDefault Property

Aspose.Email

Reminders.UseDefault Property

Whether the default reminders of the calendar apply to the event.

public bool UseDefault {get; set;}

See Also

Reminders Class | Aspose.Email.Google Namespace


Aspose.Email.Imap

Aspose.Email

Aspose.Email.Imap Namespace

Namespace hierarchy

Classes

Class | Description
FetchTimeoutException | Represents the exception that is thrown when a message can not be read within the specified time.
ImapAuthentication | Represents the authentication methods for ImapClient to log into the IMAP servers.
ImapClient | Allows applications to access and manipulate messages by using the Internet Message Access Protocol (IMAP).
ImapException | Represents the exception that is thrown when the ImapClient is not able to complete an operation.
ImapFolderInfo | Represents an IMAP folder.
ImapFolderInfoCollection | Provides a container for a collection of ImapFolderInfo objects.
ImapMessageFlags | Represents the flags associated with the message.
ImapMessageInfo | Represents a Imap message object.
ImapMessageInfoCollection | Provides a container for a collection of ImapMessageInfo objects
ImapQueryBuilder | Represents the builder of search expression that used by IMAP protocol.
ImapResponse | Represents an imap response retrieved from server.
RangeSeqSet |
ReadLinesTimeoutException | Represents the exception that is thrown when a response from server can not be read within the specified time.
SequenceSetBaseValue |
SequenceSetField |
SimpleSeqSet |

Enumerations

Enumeration | Description
ImapCommandResult | Enumerates the imap command results.
ImapSslSecurityMode | Represents the SSL security mode for ImapClient
ImapStatusCode | Represents the status responses.


FetchTimeoutException Class

Represents the exception that is thrown when a message can not be read within the specified time.

For a list of all members of this type, see FetchTimeoutException Members.

System.Object
System.Exception
Aspose.Email.Imap.FetchTimeoutException

public class FetchTimeoutException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Imap

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FetchTimeoutException Members | Aspose.Email.Imap Namespace


FetchTimeoutException Members

FetchTimeoutException overview

Public Instance Constructors

FetchTimeoutException Overloaded. Initializes a new instance of the FetchTimeoutException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

FetchTimeoutException Overloaded. Initializes a new instance of the FetchTimeoutException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FetchTimeoutException Class | Aspose.Email.Imap Namespace


FetchTimeoutException Constructor

Initializes a new instance of the FetchTimeoutException class.

Overload List

Initializes a new instance of the FetchTimeoutException class.

public FetchTimeoutException();

Initializes a new instance of the FetchTimeoutException class with a serialized data.

protected FetchTimeoutException(SerializationInfo,StreamingContext);

Initializes a new instance of the FetchTimeoutException class with a specified error message.

public FetchTimeoutException(string);

Initializes a new instance of the FetchTimeoutException class with a specified error message.

public FetchTimeoutException(string,Exception);

See Also

FetchTimeoutException Class | Aspose.Email.Imap Namespace


FetchTimeoutException Constructor ()

Initializes a new instance of the FetchTimeoutException class.

public FetchTimeoutException();

See Also

FetchTimeoutException Class | Aspose.Email.Imap Namespace | FetchTimeoutException Constructor Overload List


FetchTimeoutException Constructor (String)

Initializes a new instance of the FetchTimeoutException class with a specified error message.

public FetchTimeoutException(
string message
);

Parameters

message
A message that describes the error.

See Also

FetchTimeoutException Class | Aspose.Email.Imap Namespace | FetchTimeoutException Constructor Overload List


FetchTimeoutException Constructor (String, Exception)

Initializes a new instance of the FetchTimeoutException class with a specified error message.

public FetchTimeoutException(
string message,
Exception inner
);

Parameters

message
A message that describes the error.
inner
The exception causing the current exception.

See Also

FetchTimeoutException Class | Aspose.Email.Imap Namespace | FetchTimeoutException Constructor Overload List


FetchTimeoutException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the FetchTimeoutException class with a serialized data.

protected FetchTimeoutException(
SerializationInfo info,
StreamingContext context
);

Parameters

info
The SerializationInfo that hold data about exception being thrown.
context
The StreamingContext that contains information about the source or destination.

See Also

FetchTimeoutException Class | Aspose.Email.Imap Namespace | FetchTimeoutException Constructor Overload List


ImapAuthentication Class

Represents the authentication methods for ImapClient to log into the IMAP servers.

For a list of all members of this type, see ImapAuthentication Members.

System.Object
Aspose.Email.Imap.ImapAuthentication

public sealed class ImapAuthentication

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Imap

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ImapAuthentication Members | Aspose.Email.Imap Namespace


ImapAuthentication Members

ImapAuthentication overview

Public Static Properties

CramMD5Authentication | Gets RFC 2195 CRAM-MD5 authentication object.
DigestMD5Authentication | Gets RFC 2831 DIGEST-MD5 authentication object.
PlainTextAuthentication | Gets a RFC 2595 TLS plaintext authentication object.
PlainTextLogin | Gets a login authentication object.

Public Instance Methods

Equals | Overrided.
GetHashCode | Overrided.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Overrided.

See Also

ImapAuthentication Class | Aspose.Email.Imap Namespace


ImapAuthentication Properties

The properties of the ImapAuthentication class are listed below. For a complete list of ImapAuthentication class members, see the ImapAuthentication Members topic.

Public Static Properties

CramMD5Authentication | Gets RFC 2195 CRAM-MD5 authentication object.
DigestMD5Authentication | Gets RFC 2831 DIGEST-MD5 authentication object.
PlainTextAuthentication | Gets a RFC 2595 TLS plaintext authentication object.
PlainTextLogin | Gets a login authentication object.

See Also

ImapAuthentication Class | Aspose.Email.Imap Namespace


CramMD5Authentication Property

Aspose.Email

ImapAuthentication.CramMD5Authentication Property

Gets RFC 2195 CRAM-MD5 authentication object.

public static ImapAuthentication CramMD5Authentication {get;}

See Also

ImapAuthentication Class | Aspose.Email.Imap Namespace


DigestMD5Authentication Property

Aspose.Email

ImapAuthentication.DigestMD5Authentication Property

Gets RFC 2831 DIGEST-MD5 authentication object.

public static ImapAuthentication DigestMD5Authentication {get;}

See Also

ImapAuthentication Class | Aspose.Email.Imap Namespace


PlainTextAuthentication Property

Aspose.Email

ImapAuthentication.PlainTextAuthentication Property

Gets a RFC 2595 TLS plaintext authentication object.

public static ImapAuthentication PlainTextAuthentication {get;}

See Also

ImapAuthentication Class | Aspose.Email.Imap Namespace


PlainTextLogin Property

Aspose.Email

ImapAuthentication.PlainTextLogin Property

Gets a login authentication object.

public static ImapAuthentication PlainTextLogin {get;}

See Also

ImapAuthentication Class | Aspose.Email.Imap Namespace


ImapAuthentication Methods

The methods of the ImapAuthentication class are listed below. For a complete list of ImapAuthentication class members, see the ImapAuthentication Members topic.

Public Instance Methods

Equals | Overrided.
GetHashCode | Overrided.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Overrided.

See Also

ImapAuthentication Class | Aspose.Email.Imap Namespace


ImapAuthentication.Equals Method

Overrided.

public override bool Equals(
object o
);

Parameters

o
Object to be compared.

Return Value

True if the specified object equals to this imap authentication object

See Also

ImapAuthentication Class | Aspose.Email.Imap Namespace


ImapAuthentication.GetHashCode Method

Overrided.

public override int GetHashCode();

Return Value

The hash code of this object.

See Also

ImapAuthentication Class | Aspose.Email.Imap Namespace


ImapAuthentication.ToString Method

Overrided.

public override string ToString();

Return Value

The string of this object.

See Also

ImapAuthentication Class | Aspose.Email.Imap Namespace


ImapClient Class

Allows applications to access and manipulate messages by using the Internet Message Access Protocol (IMAP).

For a list of all members of this type, see ImapClient Members.

System.Object
Aspose.Email.CredentialsByHostClient
Aspose.Email.Imap.ImapClient

public sealed class ImapClient : CredentialsByHostClient

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Imap

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ImapClient Members | Aspose.Email.Imap Namespace


ImapClient Members

ImapClient overview

Public Static Properties

DefaultFolder Default folder for ImapClients

Public Instance Constructors

ImapClient Overloaded. Initializes a new instance of the ImapClient class.

Public Instance Properties

AccessToken (inherited from CredentialsByHostClient) | Gets or sets the access token.
ConnectionCheckupPeriod (inherited from CredentialsByHostClient) | Period of connection checking up in milliseconds. Default value is 5 min.
ConnectionState | Gets the current state of the connection.
CurrentFolder | Gets the current folder
EnableSsl (inherited from CredentialsByHostClient) | Set to true if we need SSL
Host (inherited from CredentialsByHostClient) | Gets or sets the host name.
Password (inherited from CredentialsByHostClient) | Gets or sets the password.
Port (inherited from CredentialsByHostClient) | Gets or sets the port.
SecurityMode | Gets or sets the security mode
SocksProxy (inherited from CredentialsByHostClient) | Gets or sets SOCKS proxy for the client
Timeout (inherited from CredentialsByHostClient) | Gets or sets the timeout
TokenProvider (inherited from CredentialsByHostClient) | Gets or sets TokenProvider allowing to retrieve access token.
UseAuthentication (inherited from CredentialsByHostClient) | Indicates whether authentication is used.
UseDefaultCredentials (inherited from CredentialsByHostClient) | Gets or sets a Boolean value that controls whether the DefaultCredentials are sent with requests.
Username (inherited from CredentialsByHostClient) | Gets or sets the username.

Public Instance Methods

AddMessageFlags | Overloaded. Adds the flags to the message
AppendMessage | Overloaded. Uploads the mail message to the current folder If current folder hasn't been specified default folder is used.
Backup | Overloaded. Backups the content of the specified folders
BeginConnect | Obsolete. Begins an asynchronous connection.
BeginCopyMessage | Overloaded. Begins an asynchronous copying.
BeginCreateFolder | Overloaded. Begins an asynchronous folder creation.
BeginDeleteFolder | Overloaded. Begins an asynchronous folder deletion.
BeginDeleteMessage | Overloaded. Begins an asynchronous message deletion.
BeginDisconnect | Obsolete. Begins an asynchronous disconnection.
BeginExpungeMessages | Obsolete. Begins an asynchronous message expungement.
BeginFetchMessage | Overloaded. Begins an asynchronous message fetching.
BeginListFolder | Overloaded. Begins an asynchronous folder listing.
BeginListMessages | Overloaded. Begins getting the list of messages asynchronously in the current folder
BeginLogin | Obsolete. Begins Login operation asynchronously
BeginRenameFolder | Overloaded. Begins RenameFolder operation asynchronously
BeginRequestCheckpoint | Obsolete. Begins RequestCheckpoint operation asynchronously
BeginSaveMessage | Overloaded. Begins SaveMessage operation asynchronously
BeginSelectFolder | Obsolete. Begins SelectFolder operation asynchronously
BeginSubscribeFolder | Obsolete. Begins SubscribeFolder operation asynchronously
BeginUndeleteMessage | Obsolete. Begins UndeleteMessage operation asynchronously
BeginUnselectFolder | Obsolete. Begins UnselectFolder operation asynchronously
BeginUnsubscribeFolder | Obsolete. Begins UnsubscribeFolder operation asynchronously
ChangeMessageFlags | Overloaded. Changes the flags of the message
Connect | Overloaded. Connects to IMAP server
CopyMessage | Overloaded. Copies the message
CreateFolder | Creates a folder with the specified name
DeleteFolder | Deletes a specified folder. This method represents IMAP DELETE command
DeleteMessage | Overloaded. Marks a message with the specified sequence number as deleted
Disconnect | Disconnects from the IMAP server
Dispose (inherited from CredentialsByHostClient) | Releases unmanaged and - optionally - managed resources
EndConnect | Obsolete. Waits for the pending asynchronous connection to complete.
EndCopyMessage | Waits for the pending asynchronous copying to complete.
EndCreateFolder | Waits for the pending asynchronous folder creation to complete.
EndDeleteFolder | Waits for the pending asynchronous folder deletion to complete.
EndDeleteMessage | Waits for the pending asynchronous message deletion to complete.
EndDisconnect | Obsolete. Waits for the pending asynchronous disconnection to complete.
EndExpungeMessages | Obsolete. Waits for the pending asynchronous message expungement to complete.
EndFetchMessage | Waits for the pending asynchronous message fetching to complete.
EndListFolder | Waits for the pending asynchronous folder listing to complete.
EndListMessages | Waits for the asynchronous ListMessages operation to complete.
EndLogin | Obsolete. Waits for the asynchronous operation to complete.
EndRenameFolder | Waits for the asynchronous operation to complete.
EndRequestCheckpoint | Obsolete. Waits for the asynchronous operation to complete.
EndSaveMessage | Waits for the asynchronous operation to complete.
EndSelectFolder | Obsolete. Waits for the asynchronous operation to complete.
EndSubscribeFolder | Obsolete. Waits for the asynchronous operation to complete.
EndUndeleteMessage | Obsolete. Waits for the asynchronous operation to complete.
EndUnselectFolder | Obsolete. Waits for the asynchronous operation to complete.
EndUnsubscribeFolder | Obsolete. Waits for the asynchronous operation to complete.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExistFolder | Overloaded. Check whether this folder exists
ExpungeMessages | Permanently removes all messages marked as deleted (with a Deleted flag) from the current folder
FetchAttachment | Fetches the specified attachment
FetchMessage | Overloaded. Fetches the message
GetCapabilities (inherited from CredentialsByHostClient) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ListFolder | Returns information about the specified folder without selecting it
ListFolders | Overloaded. Gets the list of subfolders in the specified folder
ListMessage | Overloaded. Gets the message info
ListMessages | Overloaded. Gets the list of messages in the current folder
Login | Overloaded. Authenticates the user to the IMAP server using the specified authentication method
RemoveMessageFlags | Overloaded. Removes the flags of the message
RenameFolder | Renames a specified folder to a new name
RequestCheckpoint | Requests a checkpoint of the currently selected mailbox.
Restore | Overloaded. Restores imap folders from the specified personal storage file.
SaveMessage | Overloaded. Downloads the message with the specified sequence number and writes its data into a supplied stream
SelectFolder | Overloaded. Selects the specified folder
SendCustomCommand | Overloaded. Sends the specified custom command to the server.
SubscribeFolder | Sent the SUBSCRIBE command that adds the specified mailbox name to the server's set of "active" mailboxes.
ToString (inherited from Object) | Returns a String that represents the current Object.
UndeleteMessage | Overloaded. Marks a message with the specified sequence number as not deleted
UnselectFolder | Unselects the currently selected folder
UnsubscribeFolder | Sent the UNSUBSCRIBE command that removes the specified mailbox name from the server's set of "active" mailboxes

Public Instance Events

OnConnect (inherited from CredentialsByHostClient) The OnConnect event occurs when the clent establishes connection.

Protected Internal Instance Fields

_accessToken (inherited from CredentialsByHostClient)
_inCall (inherited from CredentialsByHostClient)
_password (inherited from CredentialsByHostClient)
_tokenProvider (inherited from CredentialsByHostClient)
_username (inherited from CredentialsByHostClient)

Protected Internal Instance Properties

InCall (inherited from CredentialsByHostClient)

Protected Internal Instance Methods

CheckCredentials (inherited from CredentialsByHostClient)
Initialize

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient Constructor

Initializes a new instance of the ImapClient class

Overload List

Initializes a new instance of the ImapClient class

public ImapClient();

Initializes a new instance of the ImapClient class

public ImapClient(string);

Initializes a new instance of the ImapClient class

public ImapClient(string,int);

Initializes a new instance of the ImapClient class

public ImapClient(string,int,string,ITokenProvider);

Initializes a new instance of the ImapClient class

public ImapClient(string,int,string,string);

Initializes a new instance of the ImapClient class

public ImapClient(string,int,string,string,bool);

Initializes a new instance of the ImapClient class

public ImapClient(string,int,string,string,RemoteCertificateValidationCallback);

Initializes a new instance of the ImapClient class

public ImapClient(string,string,ITokenProvider);

Initializes a new instance of the ImapClient class

public ImapClient(string,string,string);

Initializes a new instance of the ImapClient class

public ImapClient(string,string,string,bool);

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient Constructor ()

Initializes a new instance of the ImapClient class

public ImapClient();

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient Constructor Overload List


ImapClient Constructor (String)

Initializes a new instance of the ImapClient class

public ImapClient(
string host
);

Parameters

host
The host name

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient Constructor Overload List


ImapClient Constructor (String, Int32)

Initializes a new instance of the ImapClient class

public ImapClient(
string host,
int port
);

Parameters

host
The host name
port
The port number

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient Constructor Overload List


ImapClient Constructor (String, String, String)

Initializes a new instance of the ImapClient class

public ImapClient(
string host,
string username,
string password
);

Parameters

host
The host name
username
The user name
password
The password

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient Constructor Overload List


ImapClient Constructor (String, Int32, String, String)

Initializes a new instance of the ImapClient class

public ImapClient(
string host,
int port,
string username,
string password
);

Parameters

host
The host name
port
The port number
username
The user name
password
The password

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient Constructor Overload List


ImapClient Constructor (String, Int32, String, String, RemoteCertificateValidationCallback)

Initializes a new instance of the ImapClient class

public ImapClient(
string host,
int port,
string username,
string password,
RemoteCertificateValidationCallback userCertificateValidationCallback
);

Parameters

host
The host name
port
The portnumber
username
The user name
password
The password
userCertificateValidationCallback
System.Net.Security.RemoteCertificateValidationCallback

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient Constructor Overload List


ImapClient Constructor (String, String, String, Boolean)

Initializes a new instance of the ImapClient class

public ImapClient(
string host,
string username,
string authInfo,
bool useOAuth
);

Parameters

host
The host name
username
The user name
authInfo
The user password or XOAUTH2 access token
useOAuth
Defines whether SASL XOAUTH2 mechanism is used to login to the server

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient Constructor Overload List


ImapClient Constructor (String, Int32, String, String, Boolean)

Initializes a new instance of the ImapClient class

public ImapClient(
string host,
int port,
string username,
string authInfo,
bool useOAuth
);

Parameters

host
The host name
port
The port number
username
The user name
authInfo
The user password or XOAUTH2 access token
useOAuth
Defines whether SASL XOAUTH2 mechanism is used to login to the server

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient Constructor Overload List


ImapClient Constructor (String, String, ITokenProvider)

Initializes a new instance of the ImapClient class

public ImapClient(
string host,
string username,
ITokenProvider tokenProvider
);

Parameters

host
The host name
username
The user name
tokenProvider
TokenProvider allowing to retrieve access token.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient Constructor Overload List


ImapClient Constructor (String, Int32, String, ITokenProvider)

Initializes a new instance of the ImapClient class

public ImapClient(
string host,
int port,
string username,
ITokenProvider tokenProvider
);

Parameters

host
The host name
port
The port number
username
The user name
tokenProvider
TokenProvider allowing to retrieve access token.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient Constructor Overload List


ImapClient Properties

The properties of the ImapClient class are listed below. For a complete list of ImapClient class members, see the ImapClient Members topic.

Public Static Properties

DefaultFolder Default folder for ImapClients

Public Instance Properties

AccessToken (inherited from CredentialsByHostClient) | Gets or sets the access token.
ConnectionCheckupPeriod (inherited from CredentialsByHostClient) | Period of connection checking up in milliseconds. Default value is 5 min.
ConnectionState | Gets the current state of the connection.
CurrentFolder | Gets the current folder
EnableSsl (inherited from CredentialsByHostClient) | Set to true if we need SSL
Host (inherited from CredentialsByHostClient) | Gets or sets the host name.
Password (inherited from CredentialsByHostClient) | Gets or sets the password.
Port (inherited from CredentialsByHostClient) | Gets or sets the port.
SecurityMode | Gets or sets the security mode
SocksProxy (inherited from CredentialsByHostClient) | Gets or sets SOCKS proxy for the client
Timeout (inherited from CredentialsByHostClient) | Gets or sets the timeout
TokenProvider (inherited from CredentialsByHostClient) | Gets or sets TokenProvider allowing to retrieve access token.
UseAuthentication (inherited from CredentialsByHostClient) | Indicates whether authentication is used.
UseDefaultCredentials (inherited from CredentialsByHostClient) | Gets or sets a Boolean value that controls whether the DefaultCredentials are sent with requests.
Username (inherited from CredentialsByHostClient) | Gets or sets the username.

Protected Internal Instance Properties

InCall (inherited from CredentialsByHostClient)

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ConnectionState Property

Aspose.Email

ImapClient.ConnectionState Property

Gets the current state of the connection.

public ConnectionState ConnectionState {get;}

See Also

ImapClient Class | Aspose.Email.Imap Namespace


CurrentFolder Property

Aspose.Email

ImapClient.CurrentFolder Property

Gets the current folder

public ImapFolderInfo CurrentFolder {get; set;}

Property Value

ImapFolderInfo that represents current folder

See Also

ImapClient Class | Aspose.Email.Imap Namespace


DefaultFolder Property

Aspose.Email

ImapClient.DefaultFolder Property

Default folder for ImapClients

public static string DefaultFolder {get; set;}

See Also

ImapClient Class | Aspose.Email.Imap Namespace


SecurityMode Property

Aspose.Email

ImapClient.SecurityMode Property

Gets or sets the security mode

public ImapSslSecurityMode SecurityMode {get; set;}

Property Value

ImapSslSecurityMode

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient Methods

The methods of the ImapClient class are listed below. For a complete list of ImapClient class members, see the ImapClient Members topic.

Public Instance Methods

AddMessageFlags | Overloaded. Adds the flags to the message
AppendMessage | Overloaded. Uploads the mail message to the current folder If current folder hasn't been specified default folder is used.
Backup | Overloaded. Backups the content of the specified folders
BeginConnect | Obsolete. Begins an asynchronous connection.
BeginCopyMessage | Overloaded. Begins an asynchronous copying.
BeginCreateFolder | Overloaded. Begins an asynchronous folder creation.
BeginDeleteFolder | Overloaded. Begins an asynchronous folder deletion.
BeginDeleteMessage | Overloaded. Begins an asynchronous message deletion.
BeginDisconnect | Obsolete. Begins an asynchronous disconnection.
BeginExpungeMessages | Obsolete. Begins an asynchronous message expungement.
BeginFetchMessage | Overloaded. Begins an asynchronous message fetching.
BeginListFolder | Overloaded. Begins an asynchronous folder listing.
BeginListMessages | Overloaded. Begins getting the list of messages asynchronously in the current folder
BeginLogin | Obsolete. Begins Login operation asynchronously
BeginRenameFolder | Overloaded. Begins RenameFolder operation asynchronously
BeginRequestCheckpoint | Obsolete. Begins RequestCheckpoint operation asynchronously
BeginSaveMessage | Overloaded. Begins SaveMessage operation asynchronously
BeginSelectFolder | Obsolete. Begins SelectFolder operation asynchronously
BeginSubscribeFolder | Obsolete. Begins SubscribeFolder operation asynchronously
BeginUndeleteMessage | Obsolete. Begins UndeleteMessage operation asynchronously
BeginUnselectFolder | Obsolete. Begins UnselectFolder operation asynchronously
BeginUnsubscribeFolder | Obsolete. Begins UnsubscribeFolder operation asynchronously
ChangeMessageFlags | Overloaded. Changes the flags of the message
Connect | Overloaded. Connects to IMAP server
CopyMessage | Overloaded. Copies the message
CreateFolder | Creates a folder with the specified name
DeleteFolder | Deletes a specified folder. This method represents IMAP DELETE command
DeleteMessage | Overloaded. Marks a message with the specified sequence number as deleted
Disconnect | Disconnects from the IMAP server
Dispose (inherited from CredentialsByHostClient) | Releases unmanaged and - optionally - managed resources
EndConnect | Obsolete. Waits for the pending asynchronous connection to complete.
EndCopyMessage | Waits for the pending asynchronous copying to complete.
EndCreateFolder | Waits for the pending asynchronous folder creation to complete.
EndDeleteFolder | Waits for the pending asynchronous folder deletion to complete.
EndDeleteMessage | Waits for the pending asynchronous message deletion to complete.
EndDisconnect | Obsolete. Waits for the pending asynchronous disconnection to complete.
EndExpungeMessages | Obsolete. Waits for the pending asynchronous message expungement to complete.
EndFetchMessage | Waits for the pending asynchronous message fetching to complete.
EndListFolder | Waits for the pending asynchronous folder listing to complete.
EndListMessages | Waits for the asynchronous ListMessages operation to complete.
EndLogin | Obsolete. Waits for the asynchronous operation to complete.
EndRenameFolder | Waits for the asynchronous operation to complete.
EndRequestCheckpoint | Obsolete. Waits for the asynchronous operation to complete.
EndSaveMessage | Waits for the asynchronous operation to complete.
EndSelectFolder | Obsolete. Waits for the asynchronous operation to complete.
EndSubscribeFolder | Obsolete. Waits for the asynchronous operation to complete.
EndUndeleteMessage | Obsolete. Waits for the asynchronous operation to complete.
EndUnselectFolder | Obsolete. Waits for the asynchronous operation to complete.
EndUnsubscribeFolder | Obsolete. Waits for the asynchronous operation to complete.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExistFolder | Overloaded. Check whether this folder exists
ExpungeMessages | Permanently removes all messages marked as deleted (with a Deleted flag) from the current folder
FetchAttachment | Fetches the specified attachment
FetchMessage | Overloaded. Fetches the message
GetCapabilities (inherited from CredentialsByHostClient) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ListFolder | Returns information about the specified folder without selecting it
ListFolders | Overloaded. Gets the list of subfolders in the specified folder
ListMessage | Overloaded. Gets the message info
ListMessages | Overloaded. Gets the list of messages in the current folder
Login | Overloaded. Authenticates the user to the IMAP server using the specified authentication method
RemoveMessageFlags | Overloaded. Removes the flags of the message
RenameFolder | Renames a specified folder to a new name
RequestCheckpoint | Requests a checkpoint of the currently selected mailbox.
Restore | Overloaded. Restores imap folders from the specified personal storage file.
SaveMessage | Overloaded. Downloads the message with the specified sequence number and writes its data into a supplied stream
SelectFolder | Overloaded. Selects the specified folder
SendCustomCommand | Overloaded. Sends the specified custom command to the server.
SubscribeFolder | Sent the SUBSCRIBE command that adds the specified mailbox name to the server's set of "active" mailboxes.
ToString (inherited from Object) | Returns a String that represents the current Object.
UndeleteMessage | Overloaded. Marks a message with the specified sequence number as not deleted
UnselectFolder | Unselects the currently selected folder
UnsubscribeFolder | Sent the UNSUBSCRIBE command that removes the specified mailbox name from the server's set of "active" mailboxes

Protected Internal Instance Methods

CheckCredentials (inherited from CredentialsByHostClient)
Initialize

See Also

ImapClient Class | Aspose.Email.Imap Namespace


AddMessageFlags Method

Aspose.Email

ImapClient.AddMessageFlags Method

Adds the flags to the message

Overload List

Adds the flags to the message

public void AddMessageFlags(int,ImapMessageFlags);

Adds the flags to the message

public void AddMessageFlags(string,ImapMessageFlags);

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.AddMessageFlags Method (Int32, ImapMessageFlags)

Adds the flags to the message

public void AddMessageFlags(
int sequenceNumber,
ImapMessageFlags flags
);

Parameters

sequenceNumber
The sequence number of the message
flags
The flags to be added

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.AddMessageFlags Overload List


ImapClient.AddMessageFlags Method (String, ImapMessageFlags)

Adds the flags to the message

public void AddMessageFlags(
string uniqueId,
ImapMessageFlags flags
);

Parameters

uniqueId
The uid of the message
flags
The flags to be added

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.AddMessageFlags Overload List


AppendMessage Method

Aspose.Email

ImapClient.AppendMessage Method

Uploads the mail message to the current folder If current folder hasn't been specified default folder is used.

Overload List

Uploads the mail message to the current folder If current folder hasn't been specified default folder is used.

public string AppendMessage(MailMessage);

Uploads the mail message to the specified folder

public string AppendMessage(string,MailMessage);

Uploads the mail message to the specified folder

public string AppendMessage(string,string);

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.AppendMessage Method (MailMessage)

Uploads the mail message to the current folder If current folder hasn't been specified default folder is used.

public string AppendMessage(
MailMessage message
);

Parameters

message
Mail message to be upload

Return Value

An unique id of appended message

Exceptions

Exception Type | Condition
ArgumentNullException | message is null

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.AppendMessage Overload List


ImapClient.AppendMessage Method (String, MailMessage)

Uploads the mail message to the specified folder

public string AppendMessage(
string folderName,
MailMessage message
);

Parameters

folderName
Folder that will receive the mail message
message
Mail message to be upload

Return Value

An unique id of appended message

Exceptions

Exception Type | Condition
ArgumentException | folderName is null or empty
ArgumentNullException | message is null

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.AppendMessage Overload List


ImapClient.AppendMessage Method (String, String)

Uploads the mail message to the specified folder

public string AppendMessage(
string folderName,
string fileName
);

Parameters

folderName
Folder that will receive the mail message
fileName
File name (*.eml) of the mail message that will be uploaded

Return Value

An unique id of appended message

Exceptions

Exception Type | Condition
ArgumentException | folderName is null or empty
ArgumentException | fileName is null or empty

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.AppendMessage Overload List


Backup Method

Aspose.Email

ImapClient.Backup Method

Backups the content of the specified folders

Overload List

Backups the content of the specified folders

public void Backup(ImapFolderInfoCollection,Stream,BackupOptions);

Backups the content of the specified folders

public void Backup(ImapFolderInfoCollection,string,BackupOptions);

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.Backup Method (ImapFolderInfoCollection, Stream, BackupOptions)

Backups the content of the specified folders

public void Backup(
ImapFolderInfoCollection folders,
Stream stream,
BackupOptions options
);

Parameters

folders
A folders to backup
stream
A stream to write into
options
A backup options

Exceptions

Exception Type | Condition
NotSupportedException | The given stream does not support writting
ArgumentNullException | folders or stream is null

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.Backup Overload List


ImapClient.Backup Method (ImapFolderInfoCollection, String, BackupOptions)

Backups the content of the specified folders

public void Backup(
ImapFolderInfoCollection folders,
string fileName,
BackupOptions options
);

Parameters

folders
A folders to backup
fileName
A path to the presonal storage file
options
A backup options

Exceptions

Exception Type | Condition
ArgumentException | A fileName is null or empty
ArgumentNullException | folders is null

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.Backup Overload List


ImapClient.BeginConnect Method

NOTE: This method is now obsolete.

This method is obsolete, please don't use it anymore.

Begins an asynchronous connection.

public IAsyncResult BeginConnect(
AsyncCallback callback,
object state
);

Parameters

callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace


BeginCopyMessage Method

Aspose.Email

ImapClient.BeginCopyMessage Method

Begins an asynchronous copying.

Overload List

Begins an asynchronous copying.

public IAsyncResult BeginCopyMessage(int,string);

Begins an asynchronous copying.

public IAsyncResult BeginCopyMessage(int,string,AsyncCallback,object);

Begins an asynchronous copying.

public IAsyncResult BeginCopyMessage(string,int,string);

Begins an asynchronous copying.

public IAsyncResult BeginCopyMessage(string,int,string,AsyncCallback,object);

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.BeginCopyMessage Method (Int32, String)

Begins an asynchronous copying.

public IAsyncResult BeginCopyMessage(
int sequenceNumber,
string folderName
);

Parameters

sequenceNumber
The message sequence number.
folderName
Name of the folder.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginCopyMessage Overload List


ImapClient.BeginCopyMessage Method (Int32, String, AsyncCallback, Object)

Begins an asynchronous copying.

public IAsyncResult BeginCopyMessage(
int sequenceNumber,
string folderName,
AsyncCallback callback,
object state
);

Parameters

sequenceNumber
The message sequence number.
folderName
Name of the folder.
callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginCopyMessage Overload List


ImapClient.BeginCopyMessage Method (String, Int32, String)

Begins an asynchronous copying.

public IAsyncResult BeginCopyMessage(
string parentFolder,
int sequenceNumber,
string folderName
);

Parameters

parentFolder
Message location
sequenceNumber
The message sequence number.
folderName
Name of the folder.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginCopyMessage Overload List


ImapClient.BeginCopyMessage Method (String, Int32, String, AsyncCallback, Object)

Begins an asynchronous copying.

public IAsyncResult BeginCopyMessage(
string parentFolder,
int sequenceNumber,
string folderName,
AsyncCallback callback,
object state
);

Parameters

parentFolder
Message location
sequenceNumber
The message sequence number.
folderName
Name of the folder.
callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginCopyMessage Overload List


BeginCreateFolder Method

Aspose.Email

ImapClient.BeginCreateFolder Method

Begins an asynchronous folder creation.

Overload List

Begins an asynchronous folder creation.

public IAsyncResult BeginCreateFolder(string);

Begins an asynchronous folder creation.

public IAsyncResult BeginCreateFolder(string,AsyncCallback,object);

Begins an asynchronous folder creation.

public IAsyncResult BeginCreateFolder(string,string);

Begins an asynchronous folder creation.

public IAsyncResult BeginCreateFolder(string,string,AsyncCallback,object);

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.BeginCreateFolder Method (String)

Begins an asynchronous folder creation.

public IAsyncResult BeginCreateFolder(
string folderName
);

Parameters

folderName
Name of the folder.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginCreateFolder Overload List


ImapClient.BeginCreateFolder Method (String, AsyncCallback, Object)

Begins an asynchronous folder creation.

public IAsyncResult BeginCreateFolder(
string folderName,
AsyncCallback callback,
object state
);

Parameters

folderName
Name of the folder.
callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginCreateFolder Overload List


ImapClient.BeginCreateFolder Method (String, String)

Begins an asynchronous folder creation.

public IAsyncResult BeginCreateFolder(
string parentFolder,
string folderName
);

Parameters

parentFolder
folderName
Name of the folder.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginCreateFolder Overload List


ImapClient.BeginCreateFolder Method (String, String, AsyncCallback, Object)

Begins an asynchronous folder creation.

public IAsyncResult BeginCreateFolder(
string parentFolder,
string folderName,
AsyncCallback callback,
object state
);

Parameters

parentFolder
Name of the parent folder.
folderName
Name of the folder.
callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginCreateFolder Overload List


BeginDeleteFolder Method

Aspose.Email

ImapClient.BeginDeleteFolder Method

Begins an asynchronous folder deletion.

Overload List

Begins an asynchronous folder deletion.

public IAsyncResult BeginDeleteFolder(string);

Begins an asynchronous folder deletion.

public IAsyncResult BeginDeleteFolder(string,AsyncCallback,object);

Begins an asynchronous folder deletion.

public IAsyncResult BeginDeleteFolder(string,string);

Begins an asynchronous folder deletion.

public IAsyncResult BeginDeleteFolder(string,string,AsyncCallback,object);

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.BeginDeleteFolder Method (String)

Begins an asynchronous folder deletion.

public IAsyncResult BeginDeleteFolder(
string folderName
);

Parameters

folderName
Name of the folder.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginDeleteFolder Overload List


ImapClient.BeginDeleteFolder Method (String, AsyncCallback, Object)

Begins an asynchronous folder deletion.

public IAsyncResult BeginDeleteFolder(
string folderName,
AsyncCallback callback,
object state
);

Parameters

folderName
Name of the folder.
callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginDeleteFolder Overload List


ImapClient.BeginDeleteFolder Method (String, String)

Begins an asynchronous folder deletion.

public IAsyncResult BeginDeleteFolder(
string parentFolder,
string folderName
);

Parameters

parentFolder
Name of the parent folder.
folderName
Name of the folder.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginDeleteFolder Overload List


ImapClient.BeginDeleteFolder Method (String, String, AsyncCallback, Object)

Begins an asynchronous folder deletion.

public IAsyncResult BeginDeleteFolder(
string parentFolder,
string folderName,
AsyncCallback callback,
object state
);

Parameters

parentFolder
Name of the parent folder.
folderName
Name of the folder.
callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginDeleteFolder Overload List


BeginDeleteMessage Method

Aspose.Email

ImapClient.BeginDeleteMessage Method

Begins an asynchronous message deletion.

Overload List

Begins an asynchronous message deletion.

public IAsyncResult BeginDeleteMessage(int);

Begins an asynchronous message deletion.

public IAsyncResult BeginDeleteMessage(int,AsyncCallback,object);

Begins an asynchronous message deletion.

public IAsyncResult BeginDeleteMessage(string);

Begins an asynchronous message deletion.

public IAsyncResult BeginDeleteMessage(string,AsyncCallback,object);

Begins an asynchronous message deletion.

public IAsyncResult BeginDeleteMessage(string,int);

Begins an asynchronous message deletion.

public IAsyncResult BeginDeleteMessage(string,int,AsyncCallback,object);

Begins an asynchronous message deletion.

public IAsyncResult BeginDeleteMessage(string,string);

Begins an asynchronous message deletion.

public IAsyncResult BeginDeleteMessage(string,string,AsyncCallback,object);

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.BeginDeleteMessage Method (Int32)

Begins an asynchronous message deletion.

public IAsyncResult BeginDeleteMessage(
int sequenceNumber
);

Parameters

sequenceNumber
The sequence number of message.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginDeleteMessage Overload List


ImapClient.BeginDeleteMessage Method (Int32, AsyncCallback, Object)

Begins an asynchronous message deletion.

public IAsyncResult BeginDeleteMessage(
int sequenceNumber,
AsyncCallback callback,
object state
);

Parameters

sequenceNumber
The sequence number of message.
callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginDeleteMessage Overload List


ImapClient.BeginDeleteMessage Method (String)

Begins an asynchronous message deletion.

public IAsyncResult BeginDeleteMessage(
string uniqueId
);

Parameters

uniqueId
The uid of the message

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginDeleteMessage Overload List


ImapClient.BeginDeleteMessage Method (String, AsyncCallback, Object)

Begins an asynchronous message deletion.

public IAsyncResult BeginDeleteMessage(
string uniqueId,
AsyncCallback callback,
object state
);

Parameters

uniqueId
The uid of the message
callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginDeleteMessage Overload List


ImapClient.BeginDeleteMessage Method (String, Int32)

Begins an asynchronous message deletion.

public IAsyncResult BeginDeleteMessage(
string parentFolder,
int sequenceNumber
);

Parameters

parentFolder
Message location
sequenceNumber
The sequence number of message.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginDeleteMessage Overload List


ImapClient.BeginDeleteMessage Method (String, Int32, AsyncCallback, Object)

Begins an asynchronous message deletion.

public IAsyncResult BeginDeleteMessage(
string parentFolder,
int sequenceNumber,
AsyncCallback callback,
object state
);

Parameters

parentFolder
Message location
sequenceNumber
The sequence number of message.
callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginDeleteMessage Overload List


ImapClient.BeginDeleteMessage Method (String, String)

Begins an asynchronous message deletion.

public IAsyncResult BeginDeleteMessage(
string parentFolder,
string uniqueId
);

Parameters

parentFolder
Message location
uniqueId
The uid of the message

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginDeleteMessage Overload List


ImapClient.BeginDeleteMessage Method (String, String, AsyncCallback, Object)

Begins an asynchronous message deletion.

public IAsyncResult BeginDeleteMessage(
string parentFolder,
string uniqueId,
AsyncCallback callback,
object state
);

Parameters

parentFolder
Message location
uniqueId
The uid of the message
callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginDeleteMessage Overload List


ImapClient.BeginDisconnect Method

NOTE: This method is now obsolete.

This method is obsolete, please don't use it anymore.

Begins an asynchronous disconnection.

public IAsyncResult BeginDisconnect(
AsyncCallback callback,
object state
);

Parameters

callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.BeginExpungeMessages Method

NOTE: This method is now obsolete.

This method is obsolete, please don't use it anymore.

Begins an asynchronous message expungement.

public IAsyncResult BeginExpungeMessages(
AsyncCallback callback,
object state
);

Parameters

callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace


BeginFetchMessage Method

Aspose.Email

ImapClient.BeginFetchMessage Method

Begins an asynchronous message fetching.

Overload List

Begins an asynchronous message fetching.

public IAsyncResult BeginFetchMessage(int);

Begins an asynchronous message fetching.

public IAsyncResult BeginFetchMessage(int,AsyncCallback,object);

Begins an asynchronous message fetching.

public IAsyncResult BeginFetchMessage(string);

Begins an asynchronous message fetching.

public IAsyncResult BeginFetchMessage(string,AsyncCallback,object);

Begins an asynchronous message fetching.

public IAsyncResult BeginFetchMessage(string,int);

Begins an asynchronous message fetching.

public IAsyncResult BeginFetchMessage(string,int,AsyncCallback,object);

Begins an asynchronous message fetching.

public IAsyncResult BeginFetchMessage(string,string);

Begins an asynchronous message fetching.

public IAsyncResult BeginFetchMessage(string,string,AsyncCallback,object);

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.BeginFetchMessage Method (Int32)

Begins an asynchronous message fetching.

public IAsyncResult BeginFetchMessage(
int sequenceNumber
);

Parameters

sequenceNumber
The sequence number of message.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginFetchMessage Overload List


ImapClient.BeginFetchMessage Method (Int32, AsyncCallback, Object)

Begins an asynchronous message fetching.

public IAsyncResult BeginFetchMessage(
int sequenceNumber,
AsyncCallback callback,
object state
);

Parameters

sequenceNumber
The sequence number of message.
callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginFetchMessage Overload List


ImapClient.BeginFetchMessage Method (String)

Begins an asynchronous message fetching.

public IAsyncResult BeginFetchMessage(
string uniqueId
);

Parameters

uniqueId
The uid of the message

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginFetchMessage Overload List


ImapClient.BeginFetchMessage Method (String, AsyncCallback, Object)

Begins an asynchronous message fetching.

public IAsyncResult BeginFetchMessage(
string uniqueId,
AsyncCallback callback,
object state
);

Parameters

uniqueId
The uid of the message
callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginFetchMessage Overload List


ImapClient.BeginFetchMessage Method (String, Int32)

Begins an asynchronous message fetching.

public IAsyncResult BeginFetchMessage(
string folder,
int sequenceNumber
);

Parameters

folder
Message location
sequenceNumber
The sequence number of message.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginFetchMessage Overload List


ImapClient.BeginFetchMessage Method (String, Int32, AsyncCallback, Object)

Begins an asynchronous message fetching.

public IAsyncResult BeginFetchMessage(
string folder,
int sequenceNumber,
AsyncCallback callback,
object state
);

Parameters

folder
Message location
sequenceNumber
The sequence number of message.
callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginFetchMessage Overload List


ImapClient.BeginFetchMessage Method (String, String)

Begins an asynchronous message fetching.

public IAsyncResult BeginFetchMessage(
string folder,
string uniqueId
);

Parameters

folder
Message location
uniqueId
The uid of the message

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginFetchMessage Overload List


ImapClient.BeginFetchMessage Method (String, String, AsyncCallback, Object)

Begins an asynchronous message fetching.

public IAsyncResult BeginFetchMessage(
string folder,
string uniqueId,
AsyncCallback callback,
object state
);

Parameters

folder
Message location
uniqueId
The uid of the message
callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginFetchMessage Overload List


BeginListFolder Method

Aspose.Email

ImapClient.BeginListFolder Method

Begins an asynchronous folder listing.

Overload List

Begins an asynchronous folder listing.

public IAsyncResult BeginListFolder(string);

Begins an asynchronous folder listing.

public IAsyncResult BeginListFolder(string,AsyncCallback,object);

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.BeginListFolder Method (String)

Begins an asynchronous folder listing.

public IAsyncResult BeginListFolder(
string folderName
);

Parameters

folderName
Name of the folder.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginListFolder Overload List


ImapClient.BeginListFolder Method (String, AsyncCallback, Object)

Begins an asynchronous folder listing.

public IAsyncResult BeginListFolder(
string folderName,
AsyncCallback callback,
object state
);

Parameters

folderName
Name of the folder.
callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginListFolder Overload List


BeginListMessages Method

Aspose.Email

ImapClient.BeginListMessages Method

Begins getting the list of messages asynchronously in the current folder

Overload List

Begins getting the list of messages asynchronously in the current folder

public IAsyncResult BeginListMessages();

Begins getting the list of messages asynchronously in the current folder

public IAsyncResult BeginListMessages(MailQuery);

Begins getting the list of messages asynchronously in the current folder

public IAsyncResult BeginListMessages(MailQuery,AsyncCallback,object);

Begins getting the list of messages asynchronously in the current folder

public IAsyncResult BeginListMessages(MailQuery,int);

Begins getting the list of messages asynchronously in the current folder

public IAsyncResult BeginListMessages(MailQuery,int,AsyncCallback,object);

Begins getting the list of messages asynchronously in the current folder

public IAsyncResult BeginListMessages(AsyncCallback,object);

Begins getting the list of messages asynchronously in the current folder

public IAsyncResult BeginListMessages(string);

Begins getting the list of messages asynchronously in the current folder

public IAsyncResult BeginListMessages(string,MailQuery);

Begins getting the list of messages asynchronously in the current folder

public IAsyncResult BeginListMessages(string,MailQuery,AsyncCallback,object);

Begins getting the list of messages asynchronously in the current folder

public IAsyncResult BeginListMessages(string,MailQuery,int);

Begins getting the list of messages asynchronously in the current folder

public IAsyncResult BeginListMessages(string,MailQuery,int,AsyncCallback,object);

Begins getting the list of messages asynchronously in the current folder

public IAsyncResult BeginListMessages(string,AsyncCallback,object);

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.BeginListMessages Method ()

Begins getting the list of messages asynchronously in the current folder

public IAsyncResult BeginListMessages();

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginListMessages Overload List


ImapClient.BeginListMessages Method (MailQuery)

Begins getting the list of messages asynchronously in the current folder

public IAsyncResult BeginListMessages(
MailQuery query
);

Parameters

query
MailQuery that represents search query.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginListMessages Overload List


ImapClient.BeginListMessages Method (MailQuery, AsyncCallback, Object)

Begins getting the list of messages asynchronously in the current folder

public IAsyncResult BeginListMessages(
MailQuery query,
AsyncCallback callback,
object state
);

Parameters

query
MailQuery that represents search query.
callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginListMessages Overload List


ImapClient.BeginListMessages Method (MailQuery, Int32)

Begins getting the list of messages asynchronously in the current folder

public IAsyncResult BeginListMessages(
MailQuery query,
int maxNumberOfMessages
);

Parameters

query
MailQuery that represents search query.
maxNumberOfMessages
Maximum number of messages.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginListMessages Overload List


ImapClient.BeginListMessages Method (MailQuery, Int32, AsyncCallback, Object)

Begins getting the list of messages asynchronously in the current folder

public IAsyncResult BeginListMessages(
MailQuery query,
int maxNumberOfMessages,
AsyncCallback callback,
object state
);

Parameters

query
MailQuery that represents search query.
maxNumberOfMessages
Maximum number of messages.
callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginListMessages Overload List


ImapClient.BeginListMessages Method (AsyncCallback, Object)

Begins getting the list of messages asynchronously in the current folder

public IAsyncResult BeginListMessages(
AsyncCallback callback,
object state
);

Parameters

callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginListMessages Overload List


ImapClient.BeginListMessages Method (String)

Begins getting the list of messages asynchronously in the current folder

public IAsyncResult BeginListMessages(
string parentFolder
);

Parameters

parentFolder
Messages location

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginListMessages Overload List


ImapClient.BeginListMessages Method (String, MailQuery)

Begins getting the list of messages asynchronously in the current folder

public IAsyncResult BeginListMessages(
string parentFolder,
MailQuery query
);

Parameters

parentFolder
Messages location
query
MailQuery that represents search query.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginListMessages Overload List


ImapClient.BeginListMessages Method (String, MailQuery, AsyncCallback, Object)

Begins getting the list of messages asynchronously in the current folder

public IAsyncResult BeginListMessages(
string parentFolder,
MailQuery query,
AsyncCallback callback,
object state
);

Parameters

parentFolder
Messages location
query
MailQuery that represents search query.
callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginListMessages Overload List


ImapClient.BeginListMessages Method (String, MailQuery, Int32)

Begins getting the list of messages asynchronously in the current folder

public IAsyncResult BeginListMessages(
string parentFolder,
MailQuery query,
int maxNumberOfMessages
);

Parameters

parentFolder
Messages location
query
MailQuery that represents search query.
maxNumberOfMessages
Maximum number of messages.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginListMessages Overload List


ImapClient.BeginListMessages Method (String, MailQuery, Int32, AsyncCallback, Object)

Begins getting the list of messages asynchronously in the current folder

public IAsyncResult BeginListMessages(
string parentFolder,
MailQuery query,
int maxNumberOfMessages,
AsyncCallback callback,
object state
);

Parameters

parentFolder
Messages location
query
MailQuery that represents search query.
maxNumberOfMessages
Maximum number of messages.
callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginListMessages Overload List


ImapClient.BeginListMessages Method (String, AsyncCallback, Object)

Begins getting the list of messages asynchronously in the current folder

public IAsyncResult BeginListMessages(
string parentFolder,
AsyncCallback callback,
object state
);

Parameters

parentFolder
Messages location
callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginListMessages Overload List


ImapClient.BeginLogin Method

NOTE: This method is now obsolete.

This method is obsolete, please don't use it anymore.

Begins Login operation asynchronously

public IAsyncResult BeginLogin(
AsyncCallback callback,
object state
);

Parameters

callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace


BeginRenameFolder Method

Aspose.Email

ImapClient.BeginRenameFolder Method

Begins RenameFolder operation asynchronously

Overload List

Begins RenameFolder operation asynchronously

public IAsyncResult BeginRenameFolder(string,string);

Begins RenameFolder operation asynchronously

public IAsyncResult BeginRenameFolder(string,string,AsyncCallback,object);

Begins RenameFolder operation asynchronously

public IAsyncResult BeginRenameFolder(string,string,string);

Begins RenameFolder operation asynchronously

public IAsyncResult BeginRenameFolder(string,string,string,AsyncCallback,object);

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.BeginRenameFolder Method (String, String)

Begins RenameFolder operation asynchronously

public IAsyncResult BeginRenameFolder(
string folderName,
string newName
);

Parameters

folderName
Folder to be renamed
newName
New folder name

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginRenameFolder Overload List


ImapClient.BeginRenameFolder Method (String, String, AsyncCallback, Object)

Begins RenameFolder operation asynchronously

public IAsyncResult BeginRenameFolder(
string folderName,
string newName,
AsyncCallback callback,
object state
);

Parameters

folderName
Folder to be renamed
newName
New folder name
callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginRenameFolder Overload List


ImapClient.BeginRenameFolder Method (String, String, String)

Begins RenameFolder operation asynchronously

public IAsyncResult BeginRenameFolder(
string parentFolder,
string folderName,
string newName
);

Parameters

parentFolder
Parent folder
folderName
Folder to be renamed
newName
New folder name

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginRenameFolder Overload List


ImapClient.BeginRenameFolder Method (String, String, String, AsyncCallback, Object)

Begins RenameFolder operation asynchronously

public IAsyncResult BeginRenameFolder(
string parentFolder,
string folderName,
string newName,
AsyncCallback callback,
object state
);

Parameters

parentFolder
Parent folder
folderName
Folder to be renamed
newName
New folder name
callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginRenameFolder Overload List


ImapClient.BeginRequestCheckpoint Method

NOTE: This method is now obsolete.

This method is obsolete, please don't use it anymore.

Begins RequestCheckpoint operation asynchronously

public IAsyncResult BeginRequestCheckpoint(
AsyncCallback callback,
object state
);

Parameters

callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace


BeginSaveMessage Method

Aspose.Email

ImapClient.BeginSaveMessage Method

Begins SaveMessage operation asynchronously

Overload List

Begins SaveMessage operation asynchronously

public IAsyncResult BeginSaveMessage(int,Stream);

Begins SaveMessage operation asynchronously

public IAsyncResult BeginSaveMessage(int,Stream,AsyncCallback,object);

Begins SaveMessage operation asynchronously

public IAsyncResult BeginSaveMessage(string,int,Stream);

Begins SaveMessage operation asynchronously

public IAsyncResult BeginSaveMessage(string,int,Stream,AsyncCallback,object);

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.BeginSaveMessage Method (Int32, Stream)

Begins SaveMessage operation asynchronously

public IAsyncResult BeginSaveMessage(
int sequenceNumber,
Stream output
);

Parameters

sequenceNumber
The sequence number of the message
output
Stream that will receive the message

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginSaveMessage Overload List


ImapClient.BeginSaveMessage Method (Int32, Stream, AsyncCallback, Object)

Begins SaveMessage operation asynchronously

public IAsyncResult BeginSaveMessage(
int sequenceNumber,
Stream output,
AsyncCallback callback,
object state
);

Parameters

sequenceNumber
The sequence number of the message
output
Stream that will receive the message
callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginSaveMessage Overload List


ImapClient.BeginSaveMessage Method (String, Int32, Stream)

Begins SaveMessage operation asynchronously

public IAsyncResult BeginSaveMessage(
string parentFolder,
int sequenceNumber,
Stream output
);

Parameters

parentFolder
Message location
sequenceNumber
The sequence number of the message
output
Stream that will receive the message

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginSaveMessage Overload List


ImapClient.BeginSaveMessage Method (String, Int32, Stream, AsyncCallback, Object)

Begins SaveMessage operation asynchronously

public IAsyncResult BeginSaveMessage(
string parentFolder,
int sequenceNumber,
Stream output,
AsyncCallback callback,
object state
);

Parameters

parentFolder
Message location
sequenceNumber
The sequence number of the message
output
Stream that will receive the message
callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.BeginSaveMessage Overload List


ImapClient.BeginSelectFolder Method

NOTE: This method is now obsolete.

This method is obsolete, please don't use it anymore.

Begins SelectFolder operation asynchronously

public IAsyncResult BeginSelectFolder(
string folderName,
bool readOnly,
AsyncCallback callback,
object state
);

Parameters

folderName
Folder to be selected
readOnly
Specifies whether the folder is to be selected as read-only
callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.BeginSubscribeFolder Method

NOTE: This method is now obsolete.

This method is obsolete, please don't use it anymore.

Begins SubscribeFolder operation asynchronously

public IAsyncResult BeginSubscribeFolder(
string folderName,
AsyncCallback callback,
object state
);

Parameters

folderName
Name of the folder
callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.BeginUndeleteMessage Method

NOTE: This method is now obsolete.

This method is obsolete, please don't use it anymore.

Begins UndeleteMessage operation asynchronously

public IAsyncResult BeginUndeleteMessage(
int sequenceNumber,
AsyncCallback callback,
object state
);

Parameters

sequenceNumber
The sequence number of the message
callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.BeginUnselectFolder Method

NOTE: This method is now obsolete.

This method is obsolete, please don't use it anymore.

Begins UnselectFolder operation asynchronously

public IAsyncResult BeginUnselectFolder(
AsyncCallback callback,
object state
);

Parameters

callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.BeginUnsubscribeFolder Method

NOTE: This method is now obsolete.

This method is obsolete, please don't use it anymore.

Begins UnsubscribeFolder operation asynchronously

public IAsyncResult BeginUnsubscribeFolder(
string folderName,
AsyncCallback callback,
object state
);

Parameters

folderName
Name of the folder
callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ChangeMessageFlags Method

Aspose.Email

ImapClient.ChangeMessageFlags Method

Changes the flags of the message

Overload List

Changes the flags of the message

public void ChangeMessageFlags(int,ImapMessageFlags);

Changes the flags of the message

public void ChangeMessageFlags(string,ImapMessageFlags);

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.ChangeMessageFlags Method (Int32, ImapMessageFlags)

Changes the flags of the message

public void ChangeMessageFlags(
int sequenceNumber,
ImapMessageFlags flags
);

Parameters

sequenceNumber
The sequence number of the message
flags
The flags to be removed

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.ChangeMessageFlags Overload List


ImapClient.ChangeMessageFlags Method (String, ImapMessageFlags)

Changes the flags of the message

public void ChangeMessageFlags(
string uniqueId,
ImapMessageFlags flags
);

Parameters

uniqueId
The uid of the message
flags
The flags to be changed

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.ChangeMessageFlags Overload List


Connect Method

Aspose.Email

ImapClient.Connect Method

NOTE: This method is now obsolete.

Connect and Login methods are obsolete, please don't use them anymore.

Connects to IMAP server

Overload List

Obsolete. Connects to IMAP server

public void Connect();

Obsolete. Connects to IMAP server

public void Connect(bool);

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.Connect Method ()

NOTE: This method is now obsolete.

Connect and Login methods are obsolete, please don't use them anymore.

Connects to IMAP server

public void Connect();

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.Connect Overload List


ImapClient.Connect Method (Boolean)

NOTE: This method is now obsolete.

Connect and Login methods are obsolete, please don't use them anymore.

Connects to IMAP server

public void Connect(
bool autologin
);

Parameters

autologin
Sets whether or not the user wants to automatically login

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.Connect Overload List


CopyMessage Method

Aspose.Email

ImapClient.CopyMessage Method

Copies the message

Overload List

Copies the message

public void CopyMessage(int,string);

Copies the message

public void CopyMessage(string,string);

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.CopyMessage Method (Int32, String)

Copies the message

public void CopyMessage(
int sequenceNumber,
string folderName
);

Parameters

sequenceNumber
The sequence number of the message
folderName
Folder name where a message is to be copied

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.CopyMessage Overload List


ImapClient.CopyMessage Method (String, String)

Copies the message

public void CopyMessage(
string uniqueId,
string folderName
);

Parameters

uniqueId
The uid of the message
folderName
Folder name where a message is to be copied

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.CopyMessage Overload List


ImapClient.CreateFolder Method

Creates a folder with the specified name

public void CreateFolder(
string folderName
);

Parameters

folderName
Folder to be created

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.DeleteFolder Method

Deletes a specified folder. This method represents IMAP DELETE command

public void DeleteFolder(
string folderName
);

Parameters

folderName
Folder to be deleted

See Also

ImapClient Class | Aspose.Email.Imap Namespace


DeleteMessage Method

Aspose.Email

ImapClient.DeleteMessage Method

Marks a message with the specified sequence number as deleted

Overload List

Marks a message with the specified sequence number as deleted

public void DeleteMessage(int);

Marks a message with the specified sequence number as deleted

public void DeleteMessage(string);

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.DeleteMessage Method (Int32)

Marks a message with the specified sequence number as deleted

public void DeleteMessage(
int sequenceNumber
);

Parameters

sequenceNumber
Sequence number of a message

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.DeleteMessage Overload List


ImapClient.DeleteMessage Method (String)

Marks a message with the specified sequence number as deleted

public void DeleteMessage(
string uniqueId
);

Parameters

uniqueId
The uid of the message

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.DeleteMessage Overload List


ImapClient.Disconnect Method

Disconnects from the IMAP server

public void Disconnect();

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.EndConnect Method

NOTE: This method is now obsolete.

This method is obsolete, please don't use it anymore.

Waits for the pending asynchronous connection to complete.

public void EndConnect(
IAsyncResult asyncResult
);

Parameters

asyncResult
The reference to the pending asynchronous request to wait for.

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.EndCopyMessage Method

Waits for the pending asynchronous copying to complete.

public void EndCopyMessage(
IAsyncResult asyncResult
);

Parameters

asyncResult
The reference to the pending asynchronous request to wait for.

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.EndCreateFolder Method

Waits for the pending asynchronous folder creation to complete.

public void EndCreateFolder(
IAsyncResult asyncResult
);

Parameters

asyncResult
The reference to the pending asynchronous request to wait for.

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.EndDeleteFolder Method

Waits for the pending asynchronous folder deletion to complete.

public void EndDeleteFolder(
IAsyncResult asyncResult
);

Parameters

asyncResult
The reference to the pending asynchronous request to wait for.

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.EndDeleteMessage Method

Waits for the pending asynchronous message deletion to complete.

public void EndDeleteMessage(
IAsyncResult asyncResult
);

Parameters

asyncResult
The reference to the pending asynchronous request to wait for.

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.EndDisconnect Method

NOTE: This method is now obsolete.

This method is obsolete, please don't use it anymore.

Waits for the pending asynchronous disconnection to complete.

public void EndDisconnect(
IAsyncResult asyncResult
);

Parameters

asyncResult
The reference to the pending asynchronous request to wait for.

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.EndExpungeMessages Method

NOTE: This method is now obsolete.

This method is obsolete, please don't use it anymore.

Waits for the pending asynchronous message expungement to complete.

public void EndExpungeMessages(
IAsyncResult asyncResult
);

Parameters

asyncResult
The reference to the pending asynchronous request to wait for.

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.EndFetchMessage Method

Waits for the pending asynchronous message fetching to complete.

public MailMessage EndFetchMessage(
IAsyncResult asyncResult
);

Parameters

asyncResult
The reference to the pending asynchronous request to wait for.

Return Value

The MailMessage that represents message.

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.EndListFolder Method

Waits for the pending asynchronous folder listing to complete.

public ImapFolderInfo EndListFolder(
IAsyncResult asyncResult
);

Parameters

asyncResult
The reference to the pending asynchronous request to wait for.

Return Value

An ImapFolderInfo.

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.EndListMessages Method

Waits for the asynchronous ListMessages operation to complete.

public ImapMessageInfoCollection EndListMessages(
IAsyncResult asyncResult
);

Parameters

asyncResult
The reference to the pending asynchronous request to wait for.

Return Value

Returns container for a collection of ImapMessageInfo objects

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.EndLogin Method

NOTE: This method is now obsolete.

This method is obsolete, please don't use it anymore.

Waits for the asynchronous operation to complete.

public void EndLogin(
IAsyncResult asyncResult
);

Parameters

asyncResult
The reference to the pending asynchronous request to wait for.

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.EndRenameFolder Method

Waits for the asynchronous operation to complete.

public void EndRenameFolder(
IAsyncResult asyncResult
);

Parameters

asyncResult
The reference to the pending asynchronous request to wait for.

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.EndRequestCheckpoint Method

NOTE: This method is now obsolete.

This method is obsolete, please don't use it anymore.

Waits for the asynchronous operation to complete.

public void EndRequestCheckpoint(
IAsyncResult asyncResult
);

Parameters

asyncResult
The reference to the pending asynchronous request to wait for.

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.EndSaveMessage Method

Waits for the asynchronous operation to complete.

public void EndSaveMessage(
IAsyncResult asyncResult
);

Parameters

asyncResult
The reference to the pending asynchronous request to wait for.

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.EndSelectFolder Method

NOTE: This method is now obsolete.

This method is obsolete, please don't use it anymore.

Waits for the asynchronous operation to complete.

public void EndSelectFolder(
IAsyncResult asyncResult
);

Parameters

asyncResult
The reference to the pending asynchronous request to wait for.

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.EndSubscribeFolder Method

NOTE: This method is now obsolete.

This method is obsolete, please don't use it anymore.

Waits for the asynchronous operation to complete.

public void EndSubscribeFolder(
IAsyncResult asyncResult
);

Parameters

asyncResult
The reference to the pending asynchronous request to wait for.

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.EndUndeleteMessage Method

NOTE: This method is now obsolete.

This method is obsolete, please don't use it anymore.

Waits for the asynchronous operation to complete.

public void EndUndeleteMessage(
IAsyncResult asyncResult
);

Parameters

asyncResult
The reference to the pending asynchronous request to wait for.

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.EndUnselectFolder Method

NOTE: This method is now obsolete.

This method is obsolete, please don't use it anymore.

Waits for the asynchronous operation to complete.

public void EndUnselectFolder(
IAsyncResult asyncResult
);

Parameters

asyncResult
The reference to the pending asynchronous request to wait for.

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.EndUnsubscribeFolder Method

NOTE: This method is now obsolete.

This method is obsolete, please don't use it anymore.

Waits for the asynchronous operation to complete.

public void EndUnsubscribeFolder(
IAsyncResult asyncResult
);

Parameters

asyncResult
The reference to the pending asynchronous request to wait for.

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ExistFolder Method

Aspose.Email

ImapClient.ExistFolder Method

Check whether this folder exists

Overload List

Check whether this folder exists

public bool ExistFolder(string);

public bool ExistFolder(string,out ImapFolderInfo);

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.ExistFolder Method (String)

Check whether this folder exists

public bool ExistFolder(
string folderName
);

Parameters

folderName
Name of the folder

Return Value

Returns true if the folder is existing, otherwise returns false

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.ExistFolder Overload List


ImapClient.ExistFolder Method (String, ImapFolderInfo)

public bool ExistFolder(
string folderName,
out ImapFolderInfo folderInfo
);

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.ExistFolder Overload List


ImapClient.ExpungeMessages Method

Permanently removes all messages marked as deleted (with a Deleted flag) from the current folder

public void ExpungeMessages();

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.FetchAttachment Method

Fetches the specified attachment

public Attachment FetchAttachment(
int messageSequenceNumber,
string attachmentName
);

Parameters

messageSequenceNumber
The sequence number of message
attachmentName
A name of attachment

Return Value

Attachment that represents attachment

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | messageSequenceNumber is negative
ArgumentException | attachmentName is null or empty

See Also

ImapClient Class | Aspose.Email.Imap Namespace


FetchMessage Method

Aspose.Email

ImapClient.FetchMessage Method

Fetches the message

Overload List

Fetches the message

public MailMessage FetchMessage(int);

Fetches the message

public MailMessage FetchMessage(int,bool);

Fetches the message

public MailMessage FetchMessage(string);

Fetches the specified message.

public MailMessage FetchMessage(string,int);

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.FetchMessage Method (Int32)

Fetches the message

public MailMessage FetchMessage(
int sequenceNumber
);

Parameters

sequenceNumber
The sequence number of message

Return Value

MailMessage that represents e-mail message

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.FetchMessage Overload List


ImapClient.FetchMessage Method (Int32, Boolean)

Fetches the message

public MailMessage FetchMessage(
int sequenceNumber,
bool ignoreAttachment
);

Parameters

sequenceNumber
The sequence number of message
ignoreAttachment
A value that defines whether the attachments should not be loaded. If it is set to true, then only message headers, message body and attachment information are fetched. Attachment content is not loaded

Return Value

MailMessage that represents e-mail message

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.FetchMessage Overload List


ImapClient.FetchMessage Method (String)

Fetches the message

public MailMessage FetchMessage(
string uniqueId
);

Parameters

uniqueId
The unique id of message

Return Value

MailMessage that represents e-mail message

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.FetchMessage Overload List


ImapClient.FetchMessage Method (String, Int32)

Fetches the specified message.

public MailMessage FetchMessage(
string uniqueId,
int fetchTimeout
);

Parameters

uniqueId
The unique id of the message to fetch.
fetchTimeout
The fetching timout (ms).

Return Value

MailMessage that represents e-mail message.

Exceptions

Exception Type | Condition
ArgumentException | uniqueId is null or empty.
ArgumentOutOfRangeException | fetchTimeout is negative or zero.
ImapException | The message could not be fetched for the specified time.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.FetchMessage Overload List


ImapClient.Initialize Method

protected internal override void Initialize();

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.ListFolder Method

Returns information about the specified folder without selecting it

public ImapFolderInfo ListFolder(
string folderName
);

Parameters

folderName
Folder to retrieve information about

Return Value

The specified folder information

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ListFolders Method

Aspose.Email

ImapClient.ListFolders Method

Gets the list of folders in the mailbox

Overload List

Gets the list of folders in the mailbox

public ImapFolderInfoCollection ListFolders();

Gets the list of subfolders in the specified folder

public ImapFolderInfoCollection ListFolders(string);

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.ListFolders Method ()

Gets the list of folders in the mailbox

public ImapFolderInfoCollection ListFolders();

Return Value

Collection of ImapFolderInfo objects

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.ListFolders Overload List


ImapClient.ListFolders Method (String)

Gets the list of subfolders in the specified folder

public ImapFolderInfoCollection ListFolders(
string folderName
);

Parameters

folderName
Name of the folder

Return Value

Collection of ImapFolderInfo objects

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.ListFolders Overload List


ListMessage Method

Aspose.Email

ImapClient.ListMessage Method

Gets the message info

Overload List

Gets the message info

public ImapMessageInfo ListMessage(int);

Gets the message info

public ImapMessageInfo ListMessage(string);

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.ListMessage Method (Int32)

Gets the message info

public ImapMessageInfo ListMessage(
int sequenceNumber
);

Parameters

sequenceNumber
The sequence number of message

Return Value

ImapMessageInfo

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.ListMessage Overload List


ImapClient.ListMessage Method (String)

Gets the message info

public ImapMessageInfo ListMessage(
string uniqueId
);

Parameters

uniqueId
The uid of message

Return Value

ImapMessageInfo

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.ListMessage Overload List


ListMessages Method

Aspose.Email

ImapClient.ListMessages Method

Gets the list of messages in the current folder

Overload List

Gets the list of messages in the current folder

public ImapMessageInfoCollection ListMessages();

Gets the list of messages in the current folder.

public ImapMessageInfoCollection ListMessages(MailQuery);

Gets the list of messages in the current folder.

public ImapMessageInfoCollection ListMessages(MailQuery,int);

Gets the list of messages in the current folder

public ImapMessageInfoCollection ListMessages(bool);

Gets the list of messages in the current folder.

public ImapMessageInfoCollection ListMessages(int);

Gets the list of messages in the specified folder

public ImapMessageInfoCollection ListMessages(string);

Gets the list of messages in the specified folder

public ImapMessageInfoCollection ListMessages(string,bool);

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.ListMessages Method ()

Gets the list of messages in the current folder

public ImapMessageInfoCollection ListMessages();

Return Value

Collection of ImapMessageInfo objects

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.ListMessages Overload List


ImapClient.ListMessages Method (MailQuery)

Gets the list of messages in the current folder.

public ImapMessageInfoCollection ListMessages(
MailQuery query
);

Parameters

query
MailQuery that represents search query.

Return Value

Collection of ImapMessageInfo objects.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.ListMessages Overload List


ImapClient.ListMessages Method (MailQuery, Int32)

Gets the list of messages in the current folder.

public ImapMessageInfoCollection ListMessages(
MailQuery query,
int maxNumberOfMessages
);

Parameters

query
MailQuery that represents search query.
maxNumberOfMessages
Maximum number of messages.

Return Value

Collection of ImapMessageInfo objects.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.ListMessages Overload List


ImapClient.ListMessages Method (Boolean)

Gets the list of messages in the current folder

public ImapMessageInfoCollection ListMessages(
bool retrieveRecursively
);

Parameters

retrieveRecursively
Indicates, if messages have to be retrieved recursively.

Return Value

Collection of ImapMessageInfo objects

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.ListMessages Overload List


ImapClient.ListMessages Method (Int32)

Gets the list of messages in the current folder.

public ImapMessageInfoCollection ListMessages(
int maxNumberOfMessages
);

Parameters

maxNumberOfMessages
Maximum number of messages.

Return Value

Collection of ImapMessageInfo representing the messages information.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | maxNumberOfMessages is negative.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.ListMessages Overload List


ImapClient.ListMessages Method (String)

Gets the list of messages in the specified folder

public ImapMessageInfoCollection ListMessages(
string folderName
);

Parameters

folderName
Folder to retrieve messages.

Return Value

Collection of ImapMessageInfo objects

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.ListMessages Overload List


ImapClient.ListMessages Method (String, Boolean)

Gets the list of messages in the specified folder

public ImapMessageInfoCollection ListMessages(
string folderName,
bool retrieveRecursively
);

Parameters

folderName
Folder to retrieve messages.
retrieveRecursively
Indicates, if messages have to be retrieved recursively.

Return Value

Collection of ImapMessageInfo objects

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.ListMessages Overload List


Login Method

Aspose.Email

ImapClient.Login Method

NOTE: This method is now obsolete.

Connect and Login methods are obsolete, please don't use them anymore.

Authenticates the user to the IMAP server

Overload List

Obsolete. Authenticates the user to the IMAP server

public void Login();

Obsolete. Authenticates the user to the IMAP server using the specified authentication method

public void Login(ImapAuthentication);

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.Login Method ()

NOTE: This method is now obsolete.

Connect and Login methods are obsolete, please don't use them anymore.

Authenticates the user to the IMAP server

public void Login();

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.Login Overload List


ImapClient.Login Method (ImapAuthentication)

NOTE: This method is now obsolete.

Connect and Login methods are obsolete, please don't use them anymore.

Authenticates the user to the IMAP server using the specified authentication method

public void Login(
ImapAuthentication authentication
);

Parameters

authentication
Represents the authentication methods for ImapClient to log into the IMAP servers.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.Login Overload List


RemoveMessageFlags Method

Aspose.Email

ImapClient.RemoveMessageFlags Method

Removes the flags of the message

Overload List

Removes the flags of the message

public void RemoveMessageFlags(int,ImapMessageFlags);

Removes the flags of the message

public void RemoveMessageFlags(string,ImapMessageFlags);

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.RemoveMessageFlags Method (Int32, ImapMessageFlags)

Removes the flags of the message

public void RemoveMessageFlags(
int sequenceNumber,
ImapMessageFlags flags
);

Parameters

sequenceNumber
The sequence number of the message
flags
The flags to be removed

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.RemoveMessageFlags Overload List


ImapClient.RemoveMessageFlags Method (String, ImapMessageFlags)

Removes the flags of the message

public void RemoveMessageFlags(
string uniqueId,
ImapMessageFlags flags
);

Parameters

uniqueId
The uid of the message
flags
The flags to be removed

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.RemoveMessageFlags Overload List


ImapClient.RenameFolder Method

Renames a specified folder to a new name

public void RenameFolder(
string folderName,
string newName
);

Parameters

folderName
Folder to be renamed
newName
New folder name

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.RequestCheckpoint Method

Requests a checkpoint of the currently selected mailbox.

public void RequestCheckpoint();

See Also

ImapClient Class | Aspose.Email.Imap Namespace


Restore Method

Aspose.Email

ImapClient.Restore Method

Restores the specified imap folders from the given personal storage.

Overload List

Restores the specified imap folders from the given personal storage.

public void Restore(PersonalStorage,ImapFolderInfoCollection,RestoreOptions);

Restores imap folders from the given personal storage.

public void Restore(PersonalStorage,RestoreOptions);

Restores the specified imap folders from the given personal storage.

public void Restore(Stream,ImapFolderInfoCollection,RestoreOptions);

Restores imap folders from the given personal storage.

public void Restore(Stream,RestoreOptions);

Restores the specified imap folders from the specified personal storage file.

public void Restore(string,ImapFolderInfoCollection,RestoreOptions);

Restores imap folders from the specified personal storage file.

public void Restore(string,RestoreOptions);

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.Restore Method (PersonalStorage, ImapFolderInfoCollection, RestoreOptions)

Restores the specified imap folders from the given personal storage.

public void Restore(
PersonalStorage pst,
ImapFolderInfoCollection folders,
RestoreOptions options
);

Parameters

pst
A personal storage containing the backuped imap folders.
folders
A folders to be restored.
options
Restore options.

Exceptions

Exception Type | Condition
ArgumentNullException | pst or folders is null.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.Restore Overload List


ImapClient.Restore Method (PersonalStorage, RestoreOptions)

Restores imap folders from the given personal storage.

public void Restore(
PersonalStorage pst,
RestoreOptions options
);

Parameters

pst
A personal storage containing the backuped imap folders.
options
Restore options.

Exceptions

Exception Type | Condition
ArgumentNullException | pst is null.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.Restore Overload List


ImapClient.Restore Method (Stream, ImapFolderInfoCollection, RestoreOptions)

Restores the specified imap folders from the given personal storage.

public void Restore(
Stream stream,
ImapFolderInfoCollection folders,
RestoreOptions options
);

Parameters

stream
A stream containing personal storage.
folders
A folders to be restored.
options
Restore options.

Exceptions

Exception Type | Condition
NotSupportedException | The stream does not support reading.
ArgumentNullException | stream or folders is null.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.Restore Overload List


ImapClient.Restore Method (Stream, RestoreOptions)

Restores imap folders from the given personal storage.

public void Restore(
Stream stream,
RestoreOptions options
);

Parameters

stream
A stream containing personal storage.
options
Restore options.

Exceptions

Exception Type | Condition
NotSupportedException | The stream does not support reading.
ArgumentNullException | stream is null.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.Restore Overload List


ImapClient.Restore Method (String, ImapFolderInfoCollection, RestoreOptions)

Restores the specified imap folders from the specified personal storage file.

public void Restore(
string fileName,
ImapFolderInfoCollection folders,
RestoreOptions options
);

Parameters

fileName
A path to personal storage file.
folders
A folders to be restored.
options
Restore options.

Exceptions

Exception Type | Condition
ArgumentException | fileName is not specified.
ArgumentNullException | folders is null.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.Restore Overload List


ImapClient.Restore Method (String, RestoreOptions)

Restores imap folders from the specified personal storage file.

public void Restore(
string fileName,
RestoreOptions options
);

Parameters

fileName
A path to personal storage file.
options
Restore options.

Exceptions

Exception Type | Condition
ArgumentException | fileName is not specified.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.Restore Overload List


SaveMessage Method

Aspose.Email

ImapClient.SaveMessage Method

Downloads the message with the specified sequence number and writes its data into a supplied stream

Overload List

Downloads the message with the specified sequence number and writes its data into a supplied stream

public void SaveMessage(int,Stream);

Downloads the message with the specified sequence number and writes its data into a local file

public void SaveMessage(int,string);

Downloads the message with the specified sequence number and writes its data into a supplied stream

public void SaveMessage(string,Stream);

Downloads the message with the specified sequence number and writes its data into a local file

public void SaveMessage(string,string);

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.SaveMessage Method (Int32, Stream)

Downloads the message with the specified sequence number and writes its data into a supplied stream

public void SaveMessage(
int sequenceNumber,
Stream output
);

Parameters

sequenceNumber
The sequence number of the message
output
Stream that will receive the message

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.SaveMessage Overload List


ImapClient.SaveMessage Method (Int32, String)

Downloads the message with the specified sequence number and writes its data into a local file

public void SaveMessage(
int sequenceNumber,
string fileName
);

Parameters

sequenceNumber
The sequence number of the message
fileName
The path of the local file. This cannot be a directory

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.SaveMessage Overload List


ImapClient.SaveMessage Method (String, Stream)

Downloads the message with the specified sequence number and writes its data into a supplied stream

public void SaveMessage(
string uniqueId,
Stream output
);

Parameters

uniqueId
The unique Id of the message
output
Stream that will receive the message

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.SaveMessage Overload List


ImapClient.SaveMessage Method (String, String)

Downloads the message with the specified sequence number and writes its data into a local file

public void SaveMessage(
string uniqueId,
string fileName
);

Parameters

uniqueId
The unique Id of the message
fileName
The path of the local file. This cannot be a directory

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.SaveMessage Overload List


SelectFolder Method

Aspose.Email

ImapClient.SelectFolder Method

Selects the specified folder

Overload List

Selects the specified folder

public void SelectFolder(string);

Selects the specified folder

public void SelectFolder(string,bool);

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.SelectFolder Method (String)

Selects the specified folder

public void SelectFolder(
string folderName
);

Parameters

folderName
Folder to be selected

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.SelectFolder Overload List


ImapClient.SelectFolder Method (String, Boolean)

Selects the specified folder

public void SelectFolder(
string folderName,
bool readOnly
);

Parameters

folderName
Folder to be selected
readOnly
Specifies whether the folder is to be selected as read-only

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.SelectFolder Overload List


SendCustomCommand Method

Aspose.Email

ImapClient.SendCustomCommand Method

Sends the specified custom command to the server.

Overload List

Sends the specified custom command to the server.

public ImapResponse SendCustomCommand(string);

Sends the specified custom command to the server.

public ImapResponse SendCustomCommand(string,string);

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.SendCustomCommand Method (String)

Sends the specified custom command to the server.

public ImapResponse SendCustomCommand(
string command
);

Parameters

command
A string containing the custom command to be send.

Return Value

A ImapResponse representing the response received from server.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.SendCustomCommand Overload List


ImapClient.SendCustomCommand Method (String, String)

Sends the specified custom command to the server.

public ImapResponse SendCustomCommand(
string nextCommandPart,
string commandId
);

Parameters

nextCommandPart
A string containing the next custom command part to be send.
commandId
A command identifier. (It's contained in the ImapResponse returned by the SendCustomCommand(string command).)

Return Value

A ImapResponse representing the response received from server.

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.SendCustomCommand Overload List


ImapClient.SubscribeFolder Method

Sent the SUBSCRIBE command that adds the specified mailbox name to the server's set of "active" mailboxes.

public void SubscribeFolder(
string folderName
);

Parameters

folderName
Name of the folder

See Also

ImapClient Class | Aspose.Email.Imap Namespace


UndeleteMessage Method

Aspose.Email

ImapClient.UndeleteMessage Method

Marks a message with the specified sequence number as not deleted

Overload List

Marks a message with the specified sequence number as not deleted

public void UndeleteMessage(int);

Marks a message with the specified sequence number as not deleted.

public void UndeleteMessage(string);

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.UndeleteMessage Method (Int32)

Marks a message with the specified sequence number as not deleted

public void UndeleteMessage(
int sequenceNumber
);

Parameters

sequenceNumber
The sequence number of the message

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.UndeleteMessage Overload List


ImapClient.UndeleteMessage Method (String)

Marks a message with the specified sequence number as not deleted.

public void UndeleteMessage(
string uniqueId
);

Parameters

uniqueId
The unique Id of the message

See Also

ImapClient Class | Aspose.Email.Imap Namespace | ImapClient.UndeleteMessage Overload List


ImapClient.UnselectFolder Method

Unselects the currently selected folder

public void UnselectFolder();

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapClient.UnsubscribeFolder Method

Sent the UNSUBSCRIBE command that removes the specified mailbox name from the server's set of "active" mailboxes

public void UnsubscribeFolder(
string folderName
);

Parameters

folderName
Name of the folder

See Also

ImapClient Class | Aspose.Email.Imap Namespace


ImapCommandResult Enumeration

Enumerates the imap command results.

public enum ImapCommandResult

Members

Member Name | Description | Value
Undetermined | Indicates that the result of command is undetermined. | 0
Success | Indicates that the command is successfully completed. | 1
Failure | Indicates that the command failed. | 2
Error | Indicates the protocol error or command syntax error. | 3
ContinuationRequest | Indicates that the next part of command is expected. | 4

Requirements

Namespace: Aspose.Email.Imap

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Imap Namespace


ImapException Class

Represents the exception that is thrown when the ImapClient is not able to complete an operation.

For a list of all members of this type, see ImapException Members.

System.Object
System.Exception
Aspose.Email.Imap.ImapException

public class ImapException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Imap

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ImapException Members | Aspose.Email.Imap Namespace


ImapException Members

ImapException overview

Public Instance Constructors

ImapException Overloaded. Initializes a new instance of the ImapException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | Gets the object data.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

ImapException Overloaded. Initializes a new instance of the ImapException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ImapException Class | Aspose.Email.Imap Namespace


ImapException Constructor

Initializes a new instance of the ImapException class.

Overload List

Initializes a new instance of the ImapException class.

public ImapException();

Initializes a new instance of the ImapException class.

protected ImapException(SerializationInfo,StreamingContext);

Initializes a new instance of the ImapException class.

public ImapException(string);

Initializes a new instance of the ImapException class.

public ImapException(string,Exception);

See Also

ImapException Class | Aspose.Email.Imap Namespace


ImapException Constructor ()

Initializes a new instance of the ImapException class.

public ImapException();

See Also

ImapException Class | Aspose.Email.Imap Namespace | ImapException Constructor Overload List


ImapException Constructor (String)

Initializes a new instance of the ImapException class.

public ImapException(
string message
);

Parameters

message
A String that describes the error that occurred.

See Also

ImapException Class | Aspose.Email.Imap Namespace | ImapException Constructor Overload List


ImapException Constructor (String, Exception)

Initializes a new instance of the ImapException class.

public ImapException(
string message,
Exception innerException
);

Parameters

message
A String that describes the error that occurred.
innerException
The exception that is the cause of the current exception.

See Also

ImapException Class | Aspose.Email.Imap Namespace | ImapException Constructor Overload List


ImapException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the ImapException class.

protected ImapException(
SerializationInfo serializationInfo,
StreamingContext streamingContext
);

Parameters

serializationInfo
The serialization info.
streamingContext
The streaming context.

See Also

ImapException Class | Aspose.Email.Imap Namespace | ImapException Constructor Overload List


ImapException Methods

The methods of the ImapException class are listed below. For a complete list of ImapException class members, see the ImapException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | Gets the object data.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ImapException Class | Aspose.Email.Imap Namespace


ImapException.GetObjectData Method

Gets the object data.

public override void GetObjectData(
SerializationInfo serializationInfo,
StreamingContext streamingContext
);

Parameters

serializationInfo
The serialization info.
streamingContext
The streaming context.

See Also

ImapException Class | Aspose.Email.Imap Namespace


ImapFolderInfo Class

Represents an IMAP folder.

For a list of all members of this type, see ImapFolderInfo Members.

System.Object
Aspose.Email.Imap.ImapFolderInfo

public sealed class ImapFolderInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Imap

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ImapFolderInfo Members | Aspose.Email.Imap Namespace


ImapFolderInfo Members

ImapFolderInfo overview

Public Static Fields

InBox Gets inbox name.

Public Instance Properties

Marked | Gets a value indicating whether it is marked this folder.
Name | Gets the name of the folder.
NewMessageCount | Gets the number of the new messages.
ReadOnly | Gets a value indicating whether the folder is read-only.
RecentMessageCount | Gets the number of messages that arrived recently.
Selectable | Gets a value indicating whether it is possible to select this folder.
TotalMessageCount | Gets the number of messages in the folder.
UIDNext | Gets the validity ID of the mailbox.
ValidityId | Gets the validity ID of the mailbox.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ImapFolderInfo Class | Aspose.Email.Imap Namespace


ImapFolderInfo Fields

The fields of the ImapFolderInfo class are listed below. For a complete list of ImapFolderInfo class members, see the ImapFolderInfo Members topic.

Public Static Fields

InBox Gets inbox name.

See Also

ImapFolderInfo Class | Aspose.Email.Imap Namespace


ImapFolderInfo.InBox Field

Gets inbox name.

public const string InBox = "inbox";

See Also

ImapFolderInfo Class | Aspose.Email.Imap Namespace


ImapFolderInfo Properties

The properties of the ImapFolderInfo class are listed below. For a complete list of ImapFolderInfo class members, see the ImapFolderInfo Members topic.

Public Instance Properties

Marked | Gets a value indicating whether it is marked this folder.
Name | Gets the name of the folder.
NewMessageCount | Gets the number of the new messages.
ReadOnly | Gets a value indicating whether the folder is read-only.
RecentMessageCount | Gets the number of messages that arrived recently.
Selectable | Gets a value indicating whether it is possible to select this folder.
TotalMessageCount | Gets the number of messages in the folder.
UIDNext | Gets the validity ID of the mailbox.
ValidityId | Gets the validity ID of the mailbox.

See Also

ImapFolderInfo Class | Aspose.Email.Imap Namespace


Marked Property

Aspose.Email

ImapFolderInfo.Marked Property

Gets a value indicating whether it is marked this folder.

public bool Marked {get;}

See Also

ImapFolderInfo Class | Aspose.Email.Imap Namespace


Name Property

Aspose.Email

ImapFolderInfo.Name Property

Gets the name of the folder.

public string Name {get;}

See Also

ImapFolderInfo Class | Aspose.Email.Imap Namespace


NewMessageCount Property

Aspose.Email

ImapFolderInfo.NewMessageCount Property

Gets the number of the new messages.

public int NewMessageCount {get;}

See Also

ImapFolderInfo Class | Aspose.Email.Imap Namespace


ReadOnly Property

Aspose.Email

ImapFolderInfo.ReadOnly Property

Gets a value indicating whether the folder is read-only.

public bool ReadOnly {get;}

See Also

ImapFolderInfo Class | Aspose.Email.Imap Namespace


RecentMessageCount Property

Aspose.Email

ImapFolderInfo.RecentMessageCount Property

Gets the number of messages that arrived recently.

public int RecentMessageCount {get;}

See Also

ImapFolderInfo Class | Aspose.Email.Imap Namespace


Selectable Property

Aspose.Email

ImapFolderInfo.Selectable Property

Gets a value indicating whether it is possible to select this folder.

public bool Selectable {get;}

See Also

ImapFolderInfo Class | Aspose.Email.Imap Namespace


TotalMessageCount Property

Aspose.Email

ImapFolderInfo.TotalMessageCount Property

Gets the number of messages in the folder.

public int TotalMessageCount {get;}

See Also

ImapFolderInfo Class | Aspose.Email.Imap Namespace


UIDNext Property

Aspose.Email

ImapFolderInfo.UIDNext Property

Gets the validity ID of the mailbox.

public long UIDNext {get;}

See Also

ImapFolderInfo Class | Aspose.Email.Imap Namespace


ValidityId Property

Aspose.Email

ImapFolderInfo.ValidityId Property

Gets the validity ID of the mailbox.

public long ValidityId {get;}

See Also

ImapFolderInfo Class | Aspose.Email.Imap Namespace


ImapFolderInfoCollection Class

Provides a container for a collection of ImapFolderInfo objects.

For a list of all members of this type, see ImapFolderInfoCollection Members.

System.Object
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Imap.ImapFolderInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]]
Aspose.Email.Imap.ImapFolderInfoCollection

public sealed class ImapFolderInfoCollection : Collection`1

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Imap

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ImapFolderInfoCollection Members | Aspose.Email.Imap Namespace


ImapFolderInfoCollection Members

ImapFolderInfoCollection overview

Public Instance Constructors

ImapFolderInfoCollection Constructor Initializes a new instance of the ImapFolderInfoCollection class.

Public Instance Properties

Count (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Item (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds the ImapFolderInfo to the ImapFolderInfoCollection.
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt | Remove a folder info at specified index.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ImapFolderInfoCollection Class | Aspose.Email.Imap Namespace


ImapFolderInfoCollection Constructor

Initializes a new instance of the ImapFolderInfoCollection class.

public ImapFolderInfoCollection();

See Also

ImapFolderInfoCollection Class | Aspose.Email.Imap Namespace


ImapFolderInfoCollection Properties

The properties of the ImapFolderInfoCollection class are listed below. For a complete list of ImapFolderInfoCollection class members, see the ImapFolderInfoCollection Members topic.

Public Instance Properties

Count (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Item (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

ImapFolderInfoCollection Class | Aspose.Email.Imap Namespace


SyncRoot Property

Aspose.Email

ImapFolderInfoCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

public object SyncRoot {get;}

See Also

ImapFolderInfoCollection Class | Aspose.Email.Imap Namespace


ImapFolderInfoCollection Methods

The methods of the ImapFolderInfoCollection class are listed below. For a complete list of ImapFolderInfoCollection class members, see the ImapFolderInfoCollection Members topic.

Public Instance Methods

Add | Adds the ImapFolderInfo to the ImapFolderInfoCollection.
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt | Remove a folder info at specified index.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ImapFolderInfoCollection Class | Aspose.Email.Imap Namespace


ImapFolderInfoCollection.Add Method

Adds the ImapFolderInfo to the ImapFolderInfoCollection.

new public void Add(
ImapFolderInfo item
);

Parameters

item
The ImapFolderInfo object.

Implements

ICollection`1.Add

See Also

ImapFolderInfoCollection Class | Aspose.Email.Imap Namespace


ImapFolderInfoCollection.RemoveAt Method

Remove a folder info at specified index.

new public void RemoveAt(
int index
);

Parameters

index
The zero-based index of the ImapFolderInfo to remove.

Implements

IList.RemoveAt

See Also

ImapFolderInfoCollection Class | Aspose.Email.Imap Namespace


ImapMessageFlags Class

Represents the flags associated with the message.

For a list of all members of this type, see ImapMessageFlags Members.

System.Object
Aspose.Email.Imap.ImapMessageFlags

public class ImapMessageFlags

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Imap

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ImapMessageFlags Members | Aspose.Email.Imap Namespace


ImapMessageFlags Members

ImapMessageFlags overview

Public Static Properties

Answered | Message has been answered.
Deleted | Message is "deleted" for removal by later EXPUNGE.
Draft | Message has been marked as a draft.
Empty | Flags are not set
Flagged | Message is "flagged" for urgent/special attention.
IsRead | Message has been read.
Readed | Obsolete. Message has been read.
Recent | Message is "recently" arrived in this mailbox.

Public Static Methods

BitwiseAnd | Implements the operator &.
BitwiseOr | Overloaded. Implements the operator |.

Public Static Operators and Type Conversions

Bitwise And Operator | Implements the operator &.
Bitwise Or Operator | Overloaded. Implements the operator |.
Equality Operator | Implements the operator ==.
Inequality Operator | Implements the operator !=.
Implicit Int64 to ImapMessageFlags Conversion | Performs an implicit conversion from Int64 to ImapMessageFlags.

Public Instance Methods

Equals | Determines whether the specified Object is equal to this instance.
GetHashCode | Returns a hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFlag | Returns true if "who" contains the "flag"
IsEmpty | Determines whether this instance is empty.
ToString | Returns a String that represents this instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ImapMessageFlags Class | Aspose.Email.Imap Namespace


ImapMessageFlags Properties

The properties of the ImapMessageFlags class are listed below. For a complete list of ImapMessageFlags class members, see the ImapMessageFlags Members topic.

Public Static Properties

Answered | Message has been answered.
Deleted | Message is "deleted" for removal by later EXPUNGE.
Draft | Message has been marked as a draft.
Empty | Flags are not set
Flagged | Message is "flagged" for urgent/special attention.
IsRead | Message has been read.
Readed | Obsolete. Message has been read.
Recent | Message is "recently" arrived in this mailbox.

See Also

ImapMessageFlags Class | Aspose.Email.Imap Namespace


Answered Property

Aspose.Email

ImapMessageFlags.Answered Property

Message has been answered.

public static ImapMessageFlags Answered {get;}

See Also

ImapMessageFlags Class | Aspose.Email.Imap Namespace


Deleted Property

Aspose.Email

ImapMessageFlags.Deleted Property

Message is "deleted" for removal by later EXPUNGE.

public static ImapMessageFlags Deleted {get;}

See Also

ImapMessageFlags Class | Aspose.Email.Imap Namespace


Draft Property

Aspose.Email

ImapMessageFlags.Draft Property

Message has been marked as a draft.

public static ImapMessageFlags Draft {get;}

See Also

ImapMessageFlags Class | Aspose.Email.Imap Namespace


Empty Property

Aspose.Email

ImapMessageFlags.Empty Property

Flags are not set

public static ImapMessageFlags Empty {get;}

See Also

ImapMessageFlags Class | Aspose.Email.Imap Namespace


Flagged Property

Aspose.Email

ImapMessageFlags.Flagged Property

Message is "flagged" for urgent/special attention.

public static ImapMessageFlags Flagged {get;}

See Also

ImapMessageFlags Class | Aspose.Email.Imap Namespace


IsRead Property

Aspose.Email

ImapMessageFlags.IsRead Property

Message has been read.

public static ImapMessageFlags IsRead {get;}

See Also

ImapMessageFlags Class | Aspose.Email.Imap Namespace


Readed Property

Aspose.Email

ImapMessageFlags.Readed Property

NOTE: This property is now obsolete.

Use IsRead property instead.

Message has been read.

public static ImapMessageFlags Readed {get;}

See Also

ImapMessageFlags Class | Aspose.Email.Imap Namespace


Recent Property

Aspose.Email

ImapMessageFlags.Recent Property

Message is "recently" arrived in this mailbox.

public static ImapMessageFlags Recent {get;}

See Also

ImapMessageFlags Class | Aspose.Email.Imap Namespace


ImapMessageFlags Methods

The methods of the ImapMessageFlags class are listed below. For a complete list of ImapMessageFlags class members, see the ImapMessageFlags Members topic.

Public Static Methods

BitwiseAnd | Implements the operator &.
BitwiseOr | Overloaded. Implements the operator |.

Public Instance Methods

Equals | Determines whether the specified Object is equal to this instance.
GetHashCode | Returns a hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFlag | Returns true if "who" contains the "flag"
IsEmpty | Determines whether this instance is empty.
ToString | Returns a String that represents this instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ImapMessageFlags Class | Aspose.Email.Imap Namespace


ImapMessageFlags.BitwiseAnd Method

Implements the operator &.

public static ImapMessageFlags BitwiseAnd(
ImapMessageFlags a,
ImapMessageFlags b
);

Parameters

a
First set of imap message flags.
b
Second set of imap message flags.

Return Value

The result of the operator.

See Also

ImapMessageFlags Class | Aspose.Email.Imap Namespace


BitwiseOr Method

Aspose.Email

ImapMessageFlags.BitwiseOr Method

Implements the operator |.

Overload List

Implements the operator |.

public static ImapMessageFlags BitwiseOr(ImapMessageFlags,ImapMessageFlags);

Implements the operator |.

public static ImapMessageFlags BitwiseOr(ImapMessageFlags,long);

Implements the operator |.

public static ImapMessageFlags BitwiseOr(long,ImapMessageFlags);

See Also

ImapMessageFlags Class | Aspose.Email.Imap Namespace


ImapMessageFlags.BitwiseOr Method (ImapMessageFlags, ImapMessageFlags)

Implements the operator |.

public static ImapMessageFlags BitwiseOr(
ImapMessageFlags a,
ImapMessageFlags b
);

Parameters

a
First set of imap message flags.
b
Second set of imap message flags.

Return Value

The result of the operator.

See Also

ImapMessageFlags Class | Aspose.Email.Imap Namespace | ImapMessageFlags.BitwiseOr Overload List


ImapMessageFlags.BitwiseOr Method (ImapMessageFlags, Int64)

Implements the operator |.

public static ImapMessageFlags BitwiseOr(
ImapMessageFlags a,
long b
);

Parameters

a
First set of imap message flags.
b
Second set of imap message flags.

Return Value

The result of the operator.

See Also

ImapMessageFlags Class | Aspose.Email.Imap Namespace | ImapMessageFlags.BitwiseOr Overload List


ImapMessageFlags.BitwiseOr Method (Int64, ImapMessageFlags)

Implements the operator |.

public static ImapMessageFlags BitwiseOr(
long a,
ImapMessageFlags b
);

Parameters

a
First set of imap message flags.
b
Second set of imap message flags.

Return Value

The result of the operator.

See Also

ImapMessageFlags Class | Aspose.Email.Imap Namespace | ImapMessageFlags.BitwiseOr Overload List


ImapMessageFlags.Equals Method

Determines whether the specified Object is equal to this instance.

public override bool Equals(
object obj
);

Parameters

obj
The Object to compare with this instance.

Return Value

true if the specified Object is equal to this instance; otherwise, false.

Exceptions

Exception Type | Condition
NullReferenceException | The obj parameter is null.

See Also

ImapMessageFlags Class | Aspose.Email.Imap Namespace


ImapMessageFlags.GetHashCode Method

Returns a hash code for this instance.

public override int GetHashCode();

Return Value

A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.

See Also

ImapMessageFlags Class | Aspose.Email.Imap Namespace


ImapMessageFlags.HasFlag Method

Returns true if "who" contains the "flag"

public bool HasFlag(
ImapMessageFlags what
);

Parameters

what
Imap message flags

Return Value

See Also

ImapMessageFlags Class | Aspose.Email.Imap Namespace


ImapMessageFlags.IsEmpty Method

Determines whether this instance is empty.

public bool IsEmpty();

Return Value

true if this instance is empty; otherwise, false.

See Also

ImapMessageFlags Class | Aspose.Email.Imap Namespace


ImapMessageFlags.ToString Method

Returns a String that represents this instance.

public override string ToString();

Return Value

A String that represents this instance.

See Also

ImapMessageFlags Class | Aspose.Email.Imap Namespace


ImapMessageFlags Operators and Type Conversions

The operators and type conversions of the ImapMessageFlags class are listed below. For a complete list of ImapMessageFlags class members, see the ImapMessageFlags Members topic.

Public Static Operators and Type Conversions

Bitwise And Operator | Implements the operator &.
Bitwise Or Operator | Overloaded. Implements the operator |.
Equality Operator | Implements the operator ==.
Inequality Operator | Implements the operator !=.
Implicit Int64 to ImapMessageFlags Conversion | Performs an implicit conversion from Int64 to ImapMessageFlags.

See Also

ImapMessageFlags Class | ImapMessageFlags Members | Aspose.Email.Imap Namespace


ImapMessageFlags Bitwise And Operator

Implements the operator &.

public static ImapMessageFlags operator &(
ImapMessageFlags a,
ImapMessageFlags b
);

Parameters

a
First set of imap message flags.
b
Second set of imap message flags.

Return Value

The result of the operator.

See Also

ImapMessageFlags Class | Aspose.Email.Imap Namespace


ImapMessageFlags Bitwise Or Operator

Implements the operator |.

Overload List

Implements the operator |.

public static ImapMessageFlags Bitwise Or Operator(ImapMessageFlags,ImapMessageFlags);

Implements the operator |.

public static ImapMessageFlags Bitwise Or Operator(ImapMessageFlags,long);

Implements the operator |.

public static ImapMessageFlags Bitwise Or Operator(long,ImapMessageFlags);

See Also

ImapMessageFlags Class | Aspose.Email.Imap Namespace


ImapMessageFlags Bitwise Or Operator

Implements the operator |.

public static ImapMessageFlags operator |(
ImapMessageFlags a,
ImapMessageFlags b
);

Parameters

a
First set of imap message flags.
b
Second set of imap message flags.

Return Value

The result of the operator.

See Also

ImapMessageFlags Class | Aspose.Email.Imap Namespace | ImapMessageFlagsBitwise Or Operator Overload List


ImapMessageFlags Bitwise Or Operator

Implements the operator |.

public static ImapMessageFlags operator |(
ImapMessageFlags a,
long b
);

Parameters

a
First set of imap message flags.
b
Second set of imap message flags.

Return Value

The result of the operator.

See Also

ImapMessageFlags Class | Aspose.Email.Imap Namespace | ImapMessageFlagsBitwise Or Operator Overload List


ImapMessageFlags Bitwise Or Operator

Implements the operator |.

public static ImapMessageFlags operator |(
long a,
ImapMessageFlags b
);

Parameters

a
First set of imap message flags.
b
Second set of imap message flags.

Return Value

The result of the operator.

See Also

ImapMessageFlags Class | Aspose.Email.Imap Namespace | ImapMessageFlagsBitwise Or Operator Overload List


ImapMessageFlags Equality Operator

Implements the operator ==.

public static bool operator ==(
ImapMessageFlags a,
ImapMessageFlags b
);

Parameters

a
First set of imap message flags.
b
Second set of imap message flags.

Return Value

The result of the operator.

See Also

ImapMessageFlags Class | Aspose.Email.Imap Namespace


ImapMessageFlags Inequality Operator

Implements the operator !=.

public static bool operator !=(
ImapMessageFlags a,
ImapMessageFlags b
);

Parameters

a
First set of imap message flags.
b
Second set of imap message flags.

Return Value

The result of the operator.

See Also

ImapMessageFlags Class | Aspose.Email.Imap Namespace


ImapMessageFlags Implicit Int64 to ImapMessageFlags Conversion

Performs an implicit conversion from Int64 to ImapMessageFlags.

public static implicit operator ImapMessageFlags(
long type
);

Parameters

type
Value of a type.

Return Value

The result of the conversion.

See Also

ImapMessageFlags Class | Aspose.Email.Imap Namespace


ImapMessageInfo Class

Represents a Imap message object.

For a list of all members of this type, see ImapMessageInfo Members.

System.Object
Aspose.Email.Imap.ImapMessageInfo

public sealed class ImapMessageInfo : IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Imap

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ImapMessageInfo Members | Aspose.Email.Imap Namespace


ImapMessageInfo Members

ImapMessageInfo overview

Public Instance Properties

Answered | Gets a value indicating whether Flags property contains the Answered flag.
BCC | Gets the list of blind carbon copy. BCC is a copy of an email message sent to a recipient whose email address does not appear in the message.
CC | Gets the list of addresses of others who are to receive the message.
Date | Gets the origination date of this message.
Deleted | Gets a value indicating whether Flags property contains the Deleted flag.
Draft | Gets a value indicating whether Flags property contains the Draft flag.
Flagged | Gets a value indicating whether Flags property contains the Flagged flag.
Flags | Gets the message flags.
From | Gets the list of authors of this message.
InternalDate | Gets the internal date of this message.
IsRead | Gets a value indicating whether Flags property contains the Read flag.
Length | Gets the length of the message.
MessageId | Gets the message ID.
ParentFolder | Gets parent folder for message
Readed | Obsolete. Gets a value indicating whether Flags property contains the Read flag.
Recent | Gets a value indicating whether Flags property contains the Recent flag.
ReplyTo | Gets the list of addresses that should receive replies to this message.
Sender | Gets the sender of this message.
SequenceNumber | Gets the message sequence number.
Subject | Gets the subject of the message.
To | Gets the list of addresses of primary recipients of the message.
UniqueId | Gets the message unique ID.

Public Instance Methods

Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ImapMessageInfo Class | Aspose.Email.Imap Namespace


ImapMessageInfo Properties

The properties of the ImapMessageInfo class are listed below. For a complete list of ImapMessageInfo class members, see the ImapMessageInfo Members topic.

Public Instance Properties

Answered | Gets a value indicating whether Flags property contains the Answered flag.
BCC | Gets the list of blind carbon copy. BCC is a copy of an email message sent to a recipient whose email address does not appear in the message.
CC | Gets the list of addresses of others who are to receive the message.
Date | Gets the origination date of this message.
Deleted | Gets a value indicating whether Flags property contains the Deleted flag.
Draft | Gets a value indicating whether Flags property contains the Draft flag.
Flagged | Gets a value indicating whether Flags property contains the Flagged flag.
Flags | Gets the message flags.
From | Gets the list of authors of this message.
InternalDate | Gets the internal date of this message.
IsRead | Gets a value indicating whether Flags property contains the Read flag.
Length | Gets the length of the message.
MessageId | Gets the message ID.
ParentFolder | Gets parent folder for message
Readed | Obsolete. Gets a value indicating whether Flags property contains the Read flag.
Recent | Gets a value indicating whether Flags property contains the Recent flag.
ReplyTo | Gets the list of addresses that should receive replies to this message.
Sender | Gets the sender of this message.
SequenceNumber | Gets the message sequence number.
Subject | Gets the subject of the message.
To | Gets the list of addresses of primary recipients of the message.
UniqueId | Gets the message unique ID.

See Also

ImapMessageInfo Class | Aspose.Email.Imap Namespace


Answered Property

Aspose.Email

ImapMessageInfo.Answered Property

Gets a value indicating whether Flags property contains the Answered flag.

public bool Answered {get;}

Property Value

The answered flag.

See Also

ImapMessageInfo Class | Aspose.Email.Imap Namespace


BCC Property

Aspose.Email

ImapMessageInfo.BCC Property

Gets the list of blind carbon copy. BCC is a copy of an email message sent to a recipient whose email address does not appear in the message.

public MailAddressCollection BCC {get;}

Property Value

The the list of addresses.

See Also

ImapMessageInfo Class | Aspose.Email.Imap Namespace


CC Property

Aspose.Email

ImapMessageInfo.CC Property

Gets the list of addresses of others who are to receive the message.

public MailAddressCollection CC {get;}

Property Value

The the list of addresses.

See Also

ImapMessageInfo Class | Aspose.Email.Imap Namespace


Date Property

Aspose.Email

ImapMessageInfo.Date Property

Gets the origination date of this message.

public DateTime Date {get;}

Property Value

The message date.

See Also

ImapMessageInfo Class | Aspose.Email.Imap Namespace


Deleted Property

Aspose.Email

ImapMessageInfo.Deleted Property

Gets a value indicating whether Flags property contains the Deleted flag.

public bool Deleted {get;}

Property Value

The deleted flag.

See Also

ImapMessageInfo Class | Aspose.Email.Imap Namespace


Draft Property

Aspose.Email

ImapMessageInfo.Draft Property

Gets a value indicating whether Flags property contains the Draft flag.

public bool Draft {get;}

Property Value

The draft flag.

See Also

ImapMessageInfo Class | Aspose.Email.Imap Namespace


Flagged Property

Aspose.Email

ImapMessageInfo.Flagged Property

Gets a value indicating whether Flags property contains the Flagged flag.

public bool Flagged {get;}

Property Value

The flagged flag.

See Also

ImapMessageInfo Class | Aspose.Email.Imap Namespace


Flags Property

Aspose.Email

ImapMessageInfo.Flags Property

Gets the message flags.

public ImapMessageFlags Flags {get;}

Property Value

The message flags.

See Also

ImapMessageInfo Class | Aspose.Email.Imap Namespace


From Property

Aspose.Email

ImapMessageInfo.From Property

Gets the list of authors of this message.

public MailAddress From {get;}

Property Value

The list of authors of this message.

See Also

ImapMessageInfo Class | Aspose.Email.Imap Namespace


InternalDate Property

Aspose.Email

ImapMessageInfo.InternalDate Property

Gets the internal date of this message.

public DateTime InternalDate {get; set;}

Property Value

Returns the internal date.

See Also

ImapMessageInfo Class | Aspose.Email.Imap Namespace


IsRead Property

Aspose.Email

ImapMessageInfo.IsRead Property

Gets a value indicating whether Flags property contains the Read flag.

public bool IsRead {get;}

Property Value

The read flag.

See Also

ImapMessageInfo Class | Aspose.Email.Imap Namespace


Length Property

Aspose.Email

ImapMessageInfo.Length Property

Gets the length of the message.

public long Length {get;}

Property Value

The length of message.

See Also

ImapMessageInfo Class | Aspose.Email.Imap Namespace


MessageId Property

Aspose.Email

ImapMessageInfo.MessageId Property

Gets the message ID.

public string MessageId {get;}

Property Value

The message id string.

See Also

ImapMessageInfo Class | Aspose.Email.Imap Namespace


ParentFolder Property

Aspose.Email

ImapMessageInfo.ParentFolder Property

Gets parent folder for message

public string ParentFolder {get; set;}

See Also

ImapMessageInfo Class | Aspose.Email.Imap Namespace


Readed Property

Aspose.Email

ImapMessageInfo.Readed Property

NOTE: This property is now obsolete.

Use IsRead property instead.

Gets a value indicating whether Flags property contains the Read flag.

public bool Readed {get;}

Property Value

The read flag.

See Also

ImapMessageInfo Class | Aspose.Email.Imap Namespace


Recent Property

Aspose.Email

ImapMessageInfo.Recent Property

Gets a value indicating whether Flags property contains the Recent flag.

public bool Recent {get;}

Property Value

The recent flag.

See Also

ImapMessageInfo Class | Aspose.Email.Imap Namespace


ReplyTo Property

Aspose.Email

ImapMessageInfo.ReplyTo Property

Gets the list of addresses that should receive replies to this message.

public MailAddress ReplyTo {get;}

Property Value

The list of addresses.

See Also

ImapMessageInfo Class | Aspose.Email.Imap Namespace


Sender Property

Aspose.Email

ImapMessageInfo.Sender Property

Gets the sender of this message.

public MailAddress Sender {get;}

Property Value

The sender of this message.

See Also

ImapMessageInfo Class | Aspose.Email.Imap Namespace


SequenceNumber Property

Aspose.Email

ImapMessageInfo.SequenceNumber Property

Gets the message sequence number.

public int SequenceNumber {get;}

Property Value

The sequence number.

See Also

ImapMessageInfo Class | Aspose.Email.Imap Namespace


Subject Property

Aspose.Email

ImapMessageInfo.Subject Property

Gets the subject of the message.

public string Subject {get;}

Property Value

The subject.

See Also

ImapMessageInfo Class | Aspose.Email.Imap Namespace


To Property

Aspose.Email

ImapMessageInfo.To Property

Gets the list of addresses of primary recipients of the message.

public MailAddressCollection To {get;}

Property Value

The list of addresses.

See Also

ImapMessageInfo Class | Aspose.Email.Imap Namespace


UniqueId Property

Aspose.Email

ImapMessageInfo.UniqueId Property

Gets the message unique ID.

public string UniqueId {get;}

Property Value

The unique id string.

See Also

ImapMessageInfo Class | Aspose.Email.Imap Namespace


ImapMessageInfo Methods

The methods of the ImapMessageInfo class are listed below. For a complete list of ImapMessageInfo class members, see the ImapMessageInfo Members topic.

Public Instance Methods

Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ImapMessageInfo Class | Aspose.Email.Imap Namespace


ImapMessageInfo.Dispose Method

Performs tasks associated with freeing, releasing, or resetting unmanaged resources.

public void Dispose();

Implements

IDisposable.Dispose

See Also

ImapMessageInfo Class | Aspose.Email.Imap Namespace


ImapMessageInfoCollection Class

Provides a container for a collection of ImapMessageInfo objects

For a list of all members of this type, see ImapMessageInfoCollection Members.

System.Object
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Imap.ImapMessageInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]]
Aspose.Email.Imap.ImapMessageInfoCollection

public sealed class ImapMessageInfoCollection : Collection`1

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Imap

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ImapMessageInfoCollection Members | Aspose.Email.Imap Namespace


ImapMessageInfoCollection Members

ImapMessageInfoCollection overview

Public Instance Constructors

ImapMessageInfoCollection Constructor Initializes a new instance of the ImapMessageCollection class.

Public Instance Properties

Count (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Item (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
SyncRoot | Gets an object that can be used to synchronize access to the collection.

Public Instance Methods

Add | Adds the ImapMessageInfo to the ImapMessageCollection.
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert | Insert the specified ImapMessagInfo object at the specified index.
Remove | Remove specifed ImapMessageInfo object from this collection.
RemoveAt | Remove a ImapMessageInfo in specified index from this collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ImapMessageInfoCollection Class | Aspose.Email.Imap Namespace


ImapMessageInfoCollection Constructor

Initializes a new instance of the ImapMessageCollection class.

public ImapMessageInfoCollection();

See Also

ImapMessageInfoCollection Class | Aspose.Email.Imap Namespace


ImapMessageInfoCollection Properties

The properties of the ImapMessageInfoCollection class are listed below. For a complete list of ImapMessageInfoCollection class members, see the ImapMessageInfoCollection Members topic.

Public Instance Properties

Count (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Item (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
SyncRoot | Gets an object that can be used to synchronize access to the collection.

See Also

ImapMessageInfoCollection Class | Aspose.Email.Imap Namespace


SyncRoot Property

Aspose.Email

ImapMessageInfoCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

public object SyncRoot {get;}

See Also

ImapMessageInfoCollection Class | Aspose.Email.Imap Namespace


ImapMessageInfoCollection Methods

The methods of the ImapMessageInfoCollection class are listed below. For a complete list of ImapMessageInfoCollection class members, see the ImapMessageInfoCollection Members topic.

Public Instance Methods

Add | Adds the ImapMessageInfo to the ImapMessageCollection.
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert | Insert the specified ImapMessagInfo object at the specified index.
Remove | Remove specifed ImapMessageInfo object from this collection.
RemoveAt | Remove a ImapMessageInfo in specified index from this collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ImapMessageInfoCollection Class | Aspose.Email.Imap Namespace


ImapMessageInfoCollection.Add Method

Adds the ImapMessageInfo to the ImapMessageCollection.

new public void Add(
ImapMessageInfo item
);

Parameters

item
The ImapMessageInfo to be added.

Implements

ICollection`1.Add

See Also

ImapMessageInfoCollection Class | Aspose.Email.Imap Namespace


ImapMessageInfoCollection.Insert Method

Insert the specified ImapMessagInfo object at the specified index.

new public void Insert(
int index,
ImapMessageInfo item
);

Parameters

index
The index that the specified object will be inserted into.
item
The ImapMessagInfo object to be inserted.

Implements

IList`1.Insert

See Also

ImapMessageInfoCollection Class | Aspose.Email.Imap Namespace


ImapMessageInfoCollection.Remove Method

Remove specifed ImapMessageInfo object from this collection.

new public bool Remove(
ImapMessageInfo item
);

Parameters

item
The ImapMessageInfo object to be remove.

Return Value

False if this collection doesn't contains specified object.True if removed successfully.

Implements

ICollection`1.Remove

See Also

ImapMessageInfoCollection Class | Aspose.Email.Imap Namespace


ImapMessageInfoCollection.RemoveAt Method

Remove a ImapMessageInfo in specified index from this collection.

new public void RemoveAt(
int index
);

Parameters

index
The index of the message to be remove.

Implements

IList.RemoveAt

See Also

ImapMessageInfoCollection Class | Aspose.Email.Imap Namespace


ImapQueryBuilder Class

Represents the builder of search expression that used by IMAP protocol.

For a list of all members of this type, see ImapQueryBuilder Members.

System.Object
Aspose.Email.MailQueryBuilder
Aspose.Email.Imap.ImapQueryBuilder

public sealed class ImapQueryBuilder : MailQueryBuilder

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Imap

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ImapQueryBuilder Members | Aspose.Email.Imap Namespace


ImapQueryBuilder Members

ImapQueryBuilder overview

Public Instance Constructors

ImapQueryBuilder Constructor Initializes a new instance of the ImapQueryBuilder class.

Public Instance Properties

Bcc (inherited from MailQueryBuilder) | Gets the field that allows to find messages that contain the specified string in the envelope structure's BCC field.
Body (inherited from MailQueryBuilder) | Gets the field that allows to find messages that contain the specified string in the body of the message.
Cc (inherited from MailQueryBuilder) | Gets the field that allows to find messages that contain the specified string in the envelope structure's CC field.
From (inherited from MailQueryBuilder) | Gets the field that allows to find messages that contain the specified string in the envelope structure's FROM field.
InternalDate (inherited from MailQueryBuilder) | Gets the field that allows to find messages by internal date.
MessageId (inherited from MailQueryBuilder) | Gets the field that allows to find messages that contain the specified string in the envelope structure's MessageId field.
MessageSize | Gets messages with an specified size.
SentDate (inherited from MailQueryBuilder) | Gets the field that allows to find messages by sent date.
Subject (inherited from MailQueryBuilder) | Gets the field that allows to find messages that contain the specified string in the envelope structure's SUBJECT field.
Text (inherited from MailQueryBuilder) | Gets the field that allows to find the messages that contain the specified string in the header or body of the message.
To (inherited from MailQueryBuilder) | Gets the field that allows to find messages that contain the specified string in the envelope structure's TO field.
UniqueId | Unique identifier

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetQuery (inherited from MailQueryBuilder) | Gets the query.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFlags | Search messages with the specified flags.
HasHeader | Search messages that have a header with the specified field-name and that contains the specified string in the text of the header (what comes after the colon). If the string to search is zero-length, this matches all messages that have a header line with the specified field-name regardless of the contents.
HasNoFlags | Search messages with the unspecified flags.
Or (inherited from MailQueryBuilder) | Search messages that match either search key. Provides disjunction between two expressions (OR).
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ImapQueryBuilder Class | Aspose.Email.Imap Namespace


ImapQueryBuilder Constructor

Initializes a new instance of the ImapQueryBuilder class.

public ImapQueryBuilder();

See Also

ImapQueryBuilder Class | Aspose.Email.Imap Namespace


ImapQueryBuilder Properties

The properties of the ImapQueryBuilder class are listed below. For a complete list of ImapQueryBuilder class members, see the ImapQueryBuilder Members topic.

Public Instance Properties

Bcc (inherited from MailQueryBuilder) | Gets the field that allows to find messages that contain the specified string in the envelope structure's BCC field.
Body (inherited from MailQueryBuilder) | Gets the field that allows to find messages that contain the specified string in the body of the message.
Cc (inherited from MailQueryBuilder) | Gets the field that allows to find messages that contain the specified string in the envelope structure's CC field.
From (inherited from MailQueryBuilder) | Gets the field that allows to find messages that contain the specified string in the envelope structure's FROM field.
InternalDate (inherited from MailQueryBuilder) | Gets the field that allows to find messages by internal date.
MessageId (inherited from MailQueryBuilder) | Gets the field that allows to find messages that contain the specified string in the envelope structure's MessageId field.
MessageSize | Gets messages with an specified size.
SentDate (inherited from MailQueryBuilder) | Gets the field that allows to find messages by sent date.
Subject (inherited from MailQueryBuilder) | Gets the field that allows to find messages that contain the specified string in the envelope structure's SUBJECT field.
Text (inherited from MailQueryBuilder) | Gets the field that allows to find the messages that contain the specified string in the header or body of the message.
To (inherited from MailQueryBuilder) | Gets the field that allows to find messages that contain the specified string in the envelope structure's TO field.
UniqueId | Unique identifier

See Also

ImapQueryBuilder Class | Aspose.Email.Imap Namespace


MessageSize Property

Aspose.Email

ImapQueryBuilder.MessageSize Property

Gets messages with an specified size.

public IntComparisonField MessageSize {get;}

Property Value

The IntComparisonField that represents a message size.

See Also

ImapQueryBuilder Class | Aspose.Email.Imap Namespace


UniqueId Property

Aspose.Email

ImapQueryBuilder.UniqueId Property

Unique identifier

public SequenceSetField UniqueId {get;}

See Also

ImapQueryBuilder Class | Aspose.Email.Imap Namespace


ImapQueryBuilder Methods

The methods of the ImapQueryBuilder class are listed below. For a complete list of ImapQueryBuilder class members, see the ImapQueryBuilder Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetQuery (inherited from MailQueryBuilder) | Gets the query.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFlags | Search messages with the specified flags.
HasHeader | Search messages that have a header with the specified field-name and that contains the specified string in the text of the header (what comes after the colon). If the string to search is zero-length, this matches all messages that have a header line with the specified field-name regardless of the contents.
HasNoFlags | Search messages with the unspecified flags.
Or (inherited from MailQueryBuilder) | Search messages that match either search key. Provides disjunction between two expressions (OR).
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ImapQueryBuilder Class | Aspose.Email.Imap Namespace


ImapQueryBuilder.HasFlags Method

Search messages with the specified flags.

public MailQuery HasFlags(
ImapMessageFlags flags
);

Parameters

flags
The flags.

Return Value

MailQuery that represents search query (one searching criteria).

See Also

ImapQueryBuilder Class | Aspose.Email.Imap Namespace


ImapQueryBuilder.HasHeader Method

Search messages that have a header with the specified field-name and that contains the specified string in the text of the header (what comes after the colon). If the string to search is zero-length, this matches all messages that have a header line with the specified field-name regardless of the contents.

public MailQuery HasHeader(
string fieldName,
string fieldValue
);

Parameters

fieldName
Name of the field.
fieldValue
The field value.

Return Value

MailQuery that represents search query (one searching criteria).

See Also

ImapQueryBuilder Class | Aspose.Email.Imap Namespace


ImapQueryBuilder.HasNoFlags Method

Search messages with the unspecified flags.

public MailQuery HasNoFlags(
ImapMessageFlags flags
);

Parameters

flags
The flags.

Return Value

MailQuery that represents search query (one searching criteria).

See Also

ImapQueryBuilder Class | Aspose.Email.Imap Namespace


ImapResponse Class

Represents an imap response retrieved from server.

For a list of all members of this type, see ImapResponse Members.

System.Object
Aspose.Email.Imap.ImapResponse

public sealed class ImapResponse

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Imap

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ImapResponse Members | Aspose.Email.Imap Namespace


ImapResponse Members

ImapResponse overview

Public Instance Properties

CommandId | Gets a command identifier.
Message | Gets a response message.
ResponseLines | Gets a response lines.
Result | Gets a result of command.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ImapResponse Class | Aspose.Email.Imap Namespace


ImapResponse Properties

The properties of the ImapResponse class are listed below. For a complete list of ImapResponse class members, see the ImapResponse Members topic.

Public Instance Properties

CommandId | Gets a command identifier.
Message | Gets a response message.
ResponseLines | Gets a response lines.
Result | Gets a result of command.

See Also

ImapResponse Class | Aspose.Email.Imap Namespace


CommandId Property

Aspose.Email

ImapResponse.CommandId Property

Gets a command identifier.

public string CommandId {get;}

See Also

ImapResponse Class | Aspose.Email.Imap Namespace


Message Property

Aspose.Email

ImapResponse.Message Property

Gets a response message.

public string Message {get;}

See Also

ImapResponse Class | Aspose.Email.Imap Namespace


ResponseLines Property

Aspose.Email

ImapResponse.ResponseLines Property

Gets a response lines.

public StringCollection ResponseLines {get;}

See Also

ImapResponse Class | Aspose.Email.Imap Namespace


Result Property

Aspose.Email

ImapResponse.Result Property

Gets a result of command.

public ImapCommandResult Result {get;}

See Also

ImapResponse Class | Aspose.Email.Imap Namespace


ImapSslSecurityMode Enumeration

Represents the SSL security mode for ImapClient

public enum ImapSslSecurityMode

Members

Member Name | Description | Value
Explicit | Explicit mode. | 1
Implicit | Implicit mode. | 0

Requirements

Namespace: Aspose.Email.Imap

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Imap Namespace


ImapStatusCode Enumeration

Represents the status responses.

public enum ImapStatusCode

Members

Member Name | Description | Value
Bad | The BAD response indicates an error message from the server. When tagged, it reports a protocol-level error in the client's command; the tag indicates the command that caused the error. The untagged form indicates a protocol-level error for which the associated command can not be determined; it can also indicate an internal server failure. The human-readable text describes the condition. | 0
Ok | The OK response indicates an information message from the server. When tagged, it indicates successful completion of the associated command. The human-readable text MAY be presented to the user as an information message. The untagged form indicates an information-only message; the nature of the information MAY be indicated by a response code. | 1
No | The NO response indicates an operational error message from the server. When tagged, it indicates unsuccessful completion of the associated command. The untagged form indicates a warning; the command can still complete successfully. The human-readable text describes the condition. | 2
Preauth | The PREAUTH response is always untagged, and is one of three possible greetings at connection startup. It indicates that the connection has already been authenticated by external means and thus no LOGIN command is needed. | 3
Bye | The BYE response is always untagged, and indicates that the server is about to close the connection. The human-readable text MAY be displayed to the user in a status report by the client. The difference between a BYE that occurs as part of a normal LOGOUT sequence (the first case) and a BYE that occurs because of a failure (the other three cases) is that the connection closes immediately in the failure case. | 4
Alert | The human-readable text contains a special alert that MUST be presented to the user in a fashion that calls the user's attention to the message. | 5
BadCharset | Optionally followed by a parenthesized list of charsets. A SEARCH failed because the given charset is not supported by this implementation. | 6
Capability | Followed by a list of capabilities. | 7
Parse | The human-readable text represents an error in parsing the [RFC-2822] header or [MIME-IMB] headers of a message in the mailbox. | 8
PermanentFlags | Followed by a parenthesized list of flags, indicates which of the known flags the client can change permanently. | 9
ReadOnly | The mailbox is selected read-only. | 10
ReadWrite | The mailbox is selected read-write. | 11
TryCreate | An APPEND or COPY attempt is failing because the target mailbox does not exist. | 12
UIDNext | Indicates the next unique identifier value. | 13
UIDValidity | Indicates the unique identifier validity value. | 14
Unseen | Indicates the number of the first message without the \Seen flag set. | 15
Unsolicited | Untagged status responses. | 16

Requirements

Namespace: Aspose.Email.Imap

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Imap Namespace


RangeSeqSet Class

For a list of all members of this type, see RangeSeqSet Members.

System.Object
Aspose.Email.Imap.SequenceSetBaseValue
Aspose.Email.Imap.RangeSeqSet

public class RangeSeqSet : SequenceSetBaseValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Imap

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RangeSeqSet Members | Aspose.Email.Imap Namespace


RangeSeqSet Members

RangeSeqSet overview

Public Static Type Conversions

Implicit RangeSeqSet to String Conversion

Public Instance Constructors

RangeSeqSet Overloaded. Initializes a new instance of the RangeSeqSet class.

Public Instance Properties

EndRange
StartRange

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a string that represents the current object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RangeSeqSet Class | Aspose.Email.Imap Namespace


RangeSeqSet Constructor

Initializes a new instance of the RangeSeqSet class.

Overload List

Initializes a new instance of the RangeSeqSet class.

public RangeSeqSet();

public RangeSeqSet(SimpleSeqSet);

public RangeSeqSet(SimpleSeqSet,SimpleSeqSet);

public RangeSeqSet(string);

public RangeSeqSet(string,string);

See Also

RangeSeqSet Class | Aspose.Email.Imap Namespace


RangeSeqSet Constructor ()

Initializes a new instance of the RangeSeqSet class.

public RangeSeqSet();

See Also

RangeSeqSet Class | Aspose.Email.Imap Namespace | RangeSeqSet Constructor Overload List


RangeSeqSet Constructor (SimpleSeqSet)

public RangeSeqSet(
SimpleSeqSet startRange
);

See Also

RangeSeqSet Class | Aspose.Email.Imap Namespace | RangeSeqSet Constructor Overload List


RangeSeqSet Constructor (SimpleSeqSet, SimpleSeqSet)

public RangeSeqSet(
SimpleSeqSet startRange,
SimpleSeqSet endRange
);

See Also

RangeSeqSet Class | Aspose.Email.Imap Namespace | RangeSeqSet Constructor Overload List


RangeSeqSet Constructor (String)

public RangeSeqSet(
string startRange
);

See Also

RangeSeqSet Class | Aspose.Email.Imap Namespace | RangeSeqSet Constructor Overload List


RangeSeqSet Constructor (String, String)

public RangeSeqSet(
string startRange,
string endRange
);

See Also

RangeSeqSet Class | Aspose.Email.Imap Namespace | RangeSeqSet Constructor Overload List


RangeSeqSet Properties

The properties of the RangeSeqSet class are listed below. For a complete list of RangeSeqSet class members, see the RangeSeqSet Members topic.

Public Instance Properties

EndRange
StartRange

See Also

RangeSeqSet Class | Aspose.Email.Imap Namespace


EndRange Property

Aspose.Email

RangeSeqSet.EndRange Property

public SimpleSeqSet EndRange {get; set;}

See Also

RangeSeqSet Class | Aspose.Email.Imap Namespace


StartRange Property

Aspose.Email

RangeSeqSet.StartRange Property

public SimpleSeqSet StartRange {get; set;}

See Also

RangeSeqSet Class | Aspose.Email.Imap Namespace


RangeSeqSet Methods

The methods of the RangeSeqSet class are listed below. For a complete list of RangeSeqSet class members, see the RangeSeqSet Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a string that represents the current object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RangeSeqSet Class | Aspose.Email.Imap Namespace


RangeSeqSet.ToString Method

Returns a string that represents the current object.

public override string ToString();

Return Value

A string that represents the current object.

See Also

RangeSeqSet Class | Aspose.Email.Imap Namespace


RangeSeqSet Type Conversions

The type conversions of the RangeSeqSet class are listed below. For a complete list of RangeSeqSet class members, see the RangeSeqSet Members topic.

Public Static Type Conversions

Implicit RangeSeqSet to String Conversion

See Also

RangeSeqSet Class | RangeSeqSet Members | Aspose.Email.Imap Namespace


RangeSeqSet Implicit RangeSeqSet to String Conversion

public static implicit operator string(
RangeSeqSet range
);

See Also

RangeSeqSet Class | Aspose.Email.Imap Namespace


ReadLinesTimeoutException Class

Represents the exception that is thrown when a response from server can not be read within the specified time.

For a list of all members of this type, see ReadLinesTimeoutException Members.

System.Object
System.Exception
Aspose.Email.Imap.ReadLinesTimeoutException

public class ReadLinesTimeoutException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Imap

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ReadLinesTimeoutException Members | Aspose.Email.Imap Namespace


ReadLinesTimeoutException Members

ReadLinesTimeoutException overview

Public Instance Constructors

ReadLinesTimeoutException Overloaded. Initializes a new instance of the ReadLinesTimeoutException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

ReadLinesTimeoutException Overloaded. Initializes a new instance of the ReadLinesTimeoutException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ReadLinesTimeoutException Class | Aspose.Email.Imap Namespace


ReadLinesTimeoutException Constructor

Initializes a new instance of the ReadLinesTimeoutException class.

Overload List

Initializes a new instance of the ReadLinesTimeoutException class.

public ReadLinesTimeoutException();

Initializes a new instance of the ReadLinesTimeoutException class with a serialized data.

protected ReadLinesTimeoutException(SerializationInfo,StreamingContext);

Initializes a new instance of the ReadLinesTimeoutException class with a specified error message.

public ReadLinesTimeoutException(string);

Initializes a new instance of the ReadLinesTimeoutException class with a specified error message.

public ReadLinesTimeoutException(string,Exception);

See Also

ReadLinesTimeoutException Class | Aspose.Email.Imap Namespace


ReadLinesTimeoutException Constructor ()

Initializes a new instance of the ReadLinesTimeoutException class.

public ReadLinesTimeoutException();

See Also

ReadLinesTimeoutException Class | Aspose.Email.Imap Namespace | ReadLinesTimeoutException Constructor Overload List


ReadLinesTimeoutException Constructor (String)

Initializes a new instance of the ReadLinesTimeoutException class with a specified error message.

public ReadLinesTimeoutException(
string message
);

Parameters

message
A message that describes the error.

See Also

ReadLinesTimeoutException Class | Aspose.Email.Imap Namespace | ReadLinesTimeoutException Constructor Overload List


ReadLinesTimeoutException Constructor (String, Exception)

Initializes a new instance of the ReadLinesTimeoutException class with a specified error message.

public ReadLinesTimeoutException(
string message,
Exception inner
);

Parameters

message
A message that describes the error.
inner
The exception causing the current exception.

See Also

ReadLinesTimeoutException Class | Aspose.Email.Imap Namespace | ReadLinesTimeoutException Constructor Overload List


ReadLinesTimeoutException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the ReadLinesTimeoutException class with a serialized data.

protected ReadLinesTimeoutException(
SerializationInfo info,
StreamingContext context
);

Parameters

info
The SerializationInfo that hold data about exception being thrown.
context
The StreamingContext that contains information about the source or destination.

See Also

ReadLinesTimeoutException Class | Aspose.Email.Imap Namespace | ReadLinesTimeoutException Constructor Overload List


SequenceSetBaseValue Class

For a list of all members of this type, see SequenceSetBaseValue Members.

System.Object
Aspose.Email.Imap.SequenceSetBaseValue
Aspose.Email.Imap.RangeSeqSet
Aspose.Email.Imap.SimpleSeqSet

public abstract class SequenceSetBaseValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Imap

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SequenceSetBaseValue Members | Aspose.Email.Imap Namespace


SequenceSetBaseValue Members

SequenceSetBaseValue overview

Public Static Type Conversions

Implicit SequenceSetBaseValue to String Conversion

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

SequenceSetBaseValue Constructor Initializes a new instance of the SequenceSetBaseValue class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SequenceSetBaseValue Class | Aspose.Email.Imap Namespace


SequenceSetBaseValue Constructor

Initializes a new instance of the SequenceSetBaseValue class.

protected SequenceSetBaseValue();

See Also

SequenceSetBaseValue Class | Aspose.Email.Imap Namespace


SequenceSetBaseValue Type Conversions

The type conversions of the SequenceSetBaseValue class are listed below. For a complete list of SequenceSetBaseValue class members, see the SequenceSetBaseValue Members topic.

Public Static Type Conversions

Implicit SequenceSetBaseValue to String Conversion

See Also

SequenceSetBaseValue Class | SequenceSetBaseValue Members | Aspose.Email.Imap Namespace


SequenceSetBaseValue Implicit SequenceSetBaseValue to String Conversion

public static implicit operator string(
SequenceSetBaseValue value
);

See Also

SequenceSetBaseValue Class | Aspose.Email.Imap Namespace


SequenceSetField Class

For a list of all members of this type, see SequenceSetField Members.

System.Object
Aspose.Email.QueryField
Aspose.Email.Imap.SequenceSetField

public class SequenceSetField : QueryField

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Imap

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SequenceSetField Members | Aspose.Email.Imap Namespace


SequenceSetField Members

SequenceSetField overview

Public Static Type Conversions

Implicit SequenceSetField to MailQuery Conversion Creates the search key.

Public Instance Properties

Values

Public Instance Methods

Add |
CreateQuery | Creates the search key.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String which represents the object instance.

Protected Instance Fields

FieldName (inherited from QueryField)
owner (inherited from QueryField)

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SequenceSetField Class | Aspose.Email.Imap Namespace


SequenceSetField Properties

The properties of the SequenceSetField class are listed below. For a complete list of SequenceSetField class members, see the SequenceSetField Members topic.

Public Instance Properties

Values

See Also

SequenceSetField Class | Aspose.Email.Imap Namespace


Values Property

Aspose.Email

SequenceSetField.Values Property

public SequenceSetBaseValue[] Values {get;}

See Also

SequenceSetField Class | Aspose.Email.Imap Namespace


SequenceSetField Methods

The methods of the SequenceSetField class are listed below. For a complete list of SequenceSetField class members, see the SequenceSetField Members topic.

Public Instance Methods

Add |
CreateQuery | Creates the search key.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String which represents the object instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SequenceSetField Class | Aspose.Email.Imap Namespace


SequenceSetField.Add Method

public void Add(
SequenceSetBaseValue value
);

See Also

SequenceSetField Class | Aspose.Email.Imap Namespace


SequenceSetField.CreateQuery Method

Creates the search key.

public MailQuery CreateQuery();

Return Value

MailQuery that represents search query.

See Also

SequenceSetField Class | Aspose.Email.Imap Namespace


SequenceSetField.ToString Method

Returns a String which represents the object instance.

public override string ToString();

Return Value

Returns a string which represents the object instance.

See Also

SequenceSetField Class | Aspose.Email.Imap Namespace


SequenceSetField Type Conversions

The type conversions of the SequenceSetField class are listed below. For a complete list of SequenceSetField class members, see the SequenceSetField Members topic.

Public Static Type Conversions

Implicit SequenceSetField to MailQuery Conversion Creates the search key.

See Also

SequenceSetField Class | SequenceSetField Members | Aspose.Email.Imap Namespace


SequenceSetField Implicit SequenceSetField to MailQuery Conversion

Creates the search key.

public static implicit operator MailQuery(
SequenceSetField seqSetField
);

Parameters

seqSetField
SequenceSet object instance

Return Value

MailQuery that represents search query.

See Also

SequenceSetField Class | Aspose.Email.Imap Namespace


SimpleSeqSet Class

For a list of all members of this type, see SimpleSeqSet Members.

System.Object
Aspose.Email.Imap.SequenceSetBaseValue
Aspose.Email.Imap.SimpleSeqSet

public class SimpleSeqSet : SequenceSetBaseValue

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Imap

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SimpleSeqSet Members | Aspose.Email.Imap Namespace


SimpleSeqSet Members

SimpleSeqSet overview

Public Static Type Conversions

Implicit SimpleSeqSet to String Conversion
Implicit String to SimpleSeqSet Conversion

Public Instance Constructors

SimpleSeqSet Overloaded. Initializes a new instance of the SimpleSeqSet class.

Public Instance Properties

Value

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a string that represents the current object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SimpleSeqSet Class | Aspose.Email.Imap Namespace


SimpleSeqSet Constructor

Initializes a new instance of the SimpleSeqSet class.

Overload List

Initializes a new instance of the SimpleSeqSet class.

public SimpleSeqSet();

public SimpleSeqSet(string);

See Also

SimpleSeqSet Class | Aspose.Email.Imap Namespace


SimpleSeqSet Constructor ()

Initializes a new instance of the SimpleSeqSet class.

public SimpleSeqSet();

See Also

SimpleSeqSet Class | Aspose.Email.Imap Namespace | SimpleSeqSet Constructor Overload List


SimpleSeqSet Constructor (String)

public SimpleSeqSet(
string value
);

See Also

SimpleSeqSet Class | Aspose.Email.Imap Namespace | SimpleSeqSet Constructor Overload List


SimpleSeqSet Properties

The properties of the SimpleSeqSet class are listed below. For a complete list of SimpleSeqSet class members, see the SimpleSeqSet Members topic.

Public Instance Properties

Value

See Also

SimpleSeqSet Class | Aspose.Email.Imap Namespace


Value Property

Aspose.Email

SimpleSeqSet.Value Property

public string Value {get; set;}

See Also

SimpleSeqSet Class | Aspose.Email.Imap Namespace


SimpleSeqSet Methods

The methods of the SimpleSeqSet class are listed below. For a complete list of SimpleSeqSet class members, see the SimpleSeqSet Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a string that represents the current object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SimpleSeqSet Class | Aspose.Email.Imap Namespace


SimpleSeqSet.ToString Method

Returns a string that represents the current object.

public override string ToString();

Return Value

A string that represents the current object.

See Also

SimpleSeqSet Class | Aspose.Email.Imap Namespace


SimpleSeqSet Type Conversions

The type conversions of the SimpleSeqSet class are listed below. For a complete list of SimpleSeqSet class members, see the SimpleSeqSet Members topic.

Public Static Type Conversions

Implicit SimpleSeqSet to String Conversion
Implicit String to SimpleSeqSet Conversion

See Also

SimpleSeqSet Class | SimpleSeqSet Members | Aspose.Email.Imap Namespace


SimpleSeqSet Implicit SimpleSeqSet to String Conversion

public static implicit operator string(
SimpleSeqSet simple
);

See Also

SimpleSeqSet Class | Aspose.Email.Imap Namespace


SimpleSeqSet Implicit String to SimpleSeqSet Conversion

public static implicit operator SimpleSeqSet(
string simple
);

See Also

SimpleSeqSet Class | Aspose.Email.Imap Namespace


Aspose.Email.Logging

Aspose.Email

Aspose.Email.Logging Namespace

Namespace hierarchy

Classes

Class | Description
Appender | Represents the base class for Appender.
AppenderCollection | Represents the collecton for Appender objects.
ConsoleAppender | Represents an appender for console output.
DebugAppender | Represents an appender is only enabled when debugging.
FileAppender | Reprensents a file appender.
Formatter | Represents the interface for formatting log entry messsages.
LogEntry | Represents a log message. Contains the common properties that are required for all log messages.
Logger | Provides the logging functionality.
LoggerManager | Static manager that controls the creation of loggers.
LoggingException | The exception that is thrown when error is found in logging.
LogLevel | Defines available log levels.
NullAppender | Represents a do-nothing appender.
SimpleFormatter | Represents the default implementation of IFormatter interface.
StandardFormatter | Represents the class for formatting log entry messsages.

Interfaces

Interface | Description
IAppender | Implement this interface for your own strategies for printing log entries.
IFormatter | Represents the interface for formatting log entry messsages.


Appender Class

Represents the base class for Appender.

For a list of all members of this type, see Appender Members.

System.Object
Aspose.Email.Logging.Appender
Aspose.Email.Logging.ConsoleAppender
Aspose.Email.Logging.DebugAppender
Aspose.Email.Logging.FileAppender
Aspose.Email.Logging.NullAppender

public abstract class Appender : IAppender, IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Logging

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Appender Members | Aspose.Email.Logging Namespace


Appender Members

Appender overview

Public Instance Properties

Formatter Gets or sets the formatter.

Public Instance Methods

Append | Appends the specified log entry to the appender.
AppendHeader | Starts log file with specific header.
Close | Closes the appender.
Dispose | Overloaded. Releases the unmanaged resources used by the Appender.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize | Initializes the appender instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

Appender Overloaded. Initializes a new instance of the Appender class.

Protected Instance Properties

Closed
Initialized

Protected Instance Methods

Dispose | Overloaded. Releases the unmanaged resources used by the Appender, and optionally disposes of the managed resources.
Finalize |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Appender Class | Aspose.Email.Logging Namespace


Appender Constructor

Initializes a new instance of the Appender class.

Overload List

Initializes a new instance of the Appender class.

protected Appender();

protected Appender(IFormatter);

See Also

Appender Class | Aspose.Email.Logging Namespace


Appender Constructor ()

Initializes a new instance of the Appender class.

protected Appender();

See Also

Appender Class | Aspose.Email.Logging Namespace | Appender Constructor Overload List


Appender Constructor (IFormatter)

protected Appender(
IFormatter formatter
);

See Also

Appender Class | Aspose.Email.Logging Namespace | Appender Constructor Overload List


Appender Properties

The properties of the Appender class are listed below. For a complete list of Appender class members, see the Appender Members topic.

Public Instance Properties

Formatter Gets or sets the formatter.

Protected Instance Properties

Closed
Initialized

See Also

Appender Class | Aspose.Email.Logging Namespace


Closed Property

Aspose.Email

Appender.Closed Property

protected bool Closed {get;}

See Also

Appender Class | Aspose.Email.Logging Namespace


Formatter Property

Aspose.Email

Appender.Formatter Property

Gets or sets the formatter.

public IFormatter Formatter {get; set;}

Implements

IAppender.Formatter

See Also

Appender Class | Aspose.Email.Logging Namespace


Initialized Property

Aspose.Email

Appender.Initialized Property

protected bool Initialized {get;}

See Also

Appender Class | Aspose.Email.Logging Namespace


Appender Methods

The methods of the Appender class are listed below. For a complete list of Appender class members, see the Appender Members topic.

Public Instance Methods

Append | Appends the specified log entry to the appender.
AppendHeader | Starts log file with specific header.
Close | Closes the appender.
Dispose | Overloaded. Releases the unmanaged resources used by the Appender.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize | Initializes the appender instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Dispose | Overloaded. Releases the unmanaged resources used by the Appender, and optionally disposes of the managed resources.
Finalize |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Appender Class | Aspose.Email.Logging Namespace


Appender.Append Method

Appends the specified log entry to the appender.

public abstract void Append(
LogEntry entry
);

Parameters

entry
The log entry.

Implements

IAppender.Append

See Also

Appender Class | Aspose.Email.Logging Namespace


Appender.AppendHeader Method

Starts log file with specific header.

public virtual void AppendHeader();

Implements

IAppender.AppendHeader

See Also

Appender Class | Aspose.Email.Logging Namespace


Appender.Close Method

Closes the appender.

public virtual void Close();

See Also

Appender Class | Aspose.Email.Logging Namespace


Dispose Method

Aspose.Email

Appender.Dispose Method

Releases the unmanaged resources used by the Appender.

Overload List

Releases the unmanaged resources used by the Appender.

public void Dispose();

Releases the unmanaged resources used by the Appender, and optionally disposes of the managed resources.

protected virtual void Dispose(bool);

See Also

Appender Class | Aspose.Email.Logging Namespace


Appender.Dispose Method ()

Releases the unmanaged resources used by the Appender.

public void Dispose();

Implements

IDisposable.Dispose

See Also

Appender Class | Aspose.Email.Logging Namespace | Appender.Dispose Overload List


Appender.Dispose Method (Boolean)

Releases the unmanaged resources used by the Appender, and optionally disposes of the managed resources.

protected virtual void Dispose(
bool disposing
);

Parameters

disposing
true to release both managed and unmanaged resources; false to releases only unmanaged resources.

See Also

Appender Class | Aspose.Email.Logging Namespace | Appender.Dispose Overload List


Appender.Finalize Method

protected override void Finalize();

See Also

Appender Class | Aspose.Email.Logging Namespace


Appender.Initialize Method

Initializes the appender instance.

public virtual void Initialize();

See Also

Appender Class | Aspose.Email.Logging Namespace


AppenderCollection Class

Represents the collecton for Appender objects.

For a list of all members of this type, see AppenderCollection Members.

System.Object
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Logging.IAppender, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]]
Aspose.Email.Logging.AppenderCollection

public class AppenderCollection : Collection`1

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Logging

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AppenderCollection Members | Aspose.Email.Logging Namespace


AppenderCollection Members

AppenderCollection overview

Public Instance Constructors

AppenderCollection Constructor Initializes a new instance of the AppenderCollection class.

Public Instance Properties

Count (inherited from 0, Culture=neutral, PublicKeyToken=null]])
Item (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Public Instance Methods

Add | Adds an IAppender object to the end of collection.
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Items (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Protected Instance Methods

ClearItems (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
InsertItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RemoveItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
SetItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |

See Also

AppenderCollection Class | Aspose.Email.Logging Namespace


AppenderCollection Constructor

Initializes a new instance of the AppenderCollection class.

public AppenderCollection();

See Also

AppenderCollection Class | Aspose.Email.Logging Namespace


AppenderCollection Methods

The methods of the AppenderCollection class are listed below. For a complete list of AppenderCollection class members, see the AppenderCollection Members topic.

Public Instance Methods

Add | Adds an IAppender object to the end of collection.
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

ClearItems (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
InsertItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RemoveItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
SetItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |

See Also

AppenderCollection Class | Aspose.Email.Logging Namespace


AppenderCollection.Add Method

Adds an IAppender object to the end of collection.

new public int Add(
IAppender value
);

Parameters

value
The IAppender to be added to the end of the collection. The value can be null.

Return Value

The index at which the value has been added.

See Also

AppenderCollection Class | Aspose.Email.Logging Namespace


ConsoleAppender Class

Represents an appender for console output.

For a list of all members of this type, see ConsoleAppender Members.

System.Object
Aspose.Email.Logging.Appender
Aspose.Email.Logging.ConsoleAppender

public class ConsoleAppender : Appender

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Logging

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ConsoleAppender Members | Aspose.Email.Logging Namespace


ConsoleAppender Members

ConsoleAppender overview

Public Instance Constructors

ConsoleAppender Constructor Initializes a new instance of the ConsoleAppender class.

Public Instance Properties

Formatter (inherited from Appender) Gets or sets the formatter.

Public Instance Methods

Append | Appends the specified log entry to the appender.
AppendHeader (inherited from Appender) | Starts log file with specific header.
Close (inherited from Appender) | Closes the appender.
Dispose (inherited from Appender) | Overloaded. Releases the unmanaged resources used by the Appender.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Appender) | Initializes the appender instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Closed (inherited from Appender)
Initialized (inherited from Appender)

Protected Instance Methods

Dispose (inherited from Appender) | Overloaded. Releases the unmanaged resources used by the Appender.
Finalize (inherited from Appender) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConsoleAppender Class | Aspose.Email.Logging Namespace


ConsoleAppender Constructor

Initializes a new instance of the ConsoleAppender class.

public ConsoleAppender();

See Also

ConsoleAppender Class | Aspose.Email.Logging Namespace


ConsoleAppender Methods

The methods of the ConsoleAppender class are listed below. For a complete list of ConsoleAppender class members, see the ConsoleAppender Members topic.

Public Instance Methods

Append | Appends the specified log entry to the appender.
AppendHeader (inherited from Appender) | Starts log file with specific header.
Close (inherited from Appender) | Closes the appender.
Dispose (inherited from Appender) | Overloaded. Releases the unmanaged resources used by the Appender.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Appender) | Initializes the appender instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Dispose (inherited from Appender) | Overloaded. Releases the unmanaged resources used by the Appender.
Finalize (inherited from Appender) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ConsoleAppender Class | Aspose.Email.Logging Namespace


ConsoleAppender.Append Method

Appends the specified log entry to the appender.

public override void Append(
LogEntry entry
);

Parameters

entry
The log entry.

Implements

IAppender.Append

See Also

ConsoleAppender Class | Aspose.Email.Logging Namespace


DebugAppender Class

Represents an appender is only enabled when debugging.

For a list of all members of this type, see DebugAppender Members.

System.Object
Aspose.Email.Logging.Appender
Aspose.Email.Logging.DebugAppender

public class DebugAppender : Appender

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Logging

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DebugAppender Members | Aspose.Email.Logging Namespace


DebugAppender Members

DebugAppender overview

Public Instance Constructors

DebugAppender Constructor Initializes a new instance of the DebugAppender class.

Public Instance Properties

Formatter (inherited from Appender) Gets or sets the formatter.

Public Instance Methods

Append | Appends the specified log entry to the appender.
AppendHeader (inherited from Appender) | Starts log file with specific header.
Close (inherited from Appender) | Closes the appender.
Dispose (inherited from Appender) | Overloaded. Releases the unmanaged resources used by the Appender.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Appender) | Initializes the appender instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Closed (inherited from Appender)
Initialized (inherited from Appender)

Protected Instance Methods

Dispose (inherited from Appender) | Overloaded. Releases the unmanaged resources used by the Appender.
Finalize (inherited from Appender) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DebugAppender Class | Aspose.Email.Logging Namespace


DebugAppender Constructor

Initializes a new instance of the DebugAppender class.

public DebugAppender();

See Also

DebugAppender Class | Aspose.Email.Logging Namespace


DebugAppender Methods

The methods of the DebugAppender class are listed below. For a complete list of DebugAppender class members, see the DebugAppender Members topic.

Public Instance Methods

Append | Appends the specified log entry to the appender.
AppendHeader (inherited from Appender) | Starts log file with specific header.
Close (inherited from Appender) | Closes the appender.
Dispose (inherited from Appender) | Overloaded. Releases the unmanaged resources used by the Appender.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Appender) | Initializes the appender instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Dispose (inherited from Appender) | Overloaded. Releases the unmanaged resources used by the Appender.
Finalize (inherited from Appender) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DebugAppender Class | Aspose.Email.Logging Namespace


DebugAppender.Append Method

Appends the specified log entry to the appender.

public override void Append(
LogEntry entry
);

Parameters

entry
The log entry.

Implements

IAppender.Append

See Also

DebugAppender Class | Aspose.Email.Logging Namespace


FileAppender Class

Reprensents a file appender.

For a list of all members of this type, see FileAppender Members.

System.Object
Aspose.Email.Logging.Appender
Aspose.Email.Logging.FileAppender

public sealed class FileAppender : Appender

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Logging

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FileAppender Members | Aspose.Email.Logging Namespace


FileAppender Members

FileAppender overview

Public Instance Constructors

FileAppender Overloaded. Initializes a new instance of the FileAppender class.

Public Instance Properties

Encoding | Gets or sets the encoding.
FileName | Gets or sets file name.
Formatter (inherited from Appender) | Gets or sets the formatter.
UseDate | Gets or sets value which indicates whether date is used for logging.

Public Instance Methods

Append | Overloaded. Appends the log entry information to the appender.
AppendHeader | Starts log file with specific header.
Close | Closes the appender.
Dispose (inherited from Appender) | Releases the unmanaged resources used by the Appender.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Appender) | Initializes the appender instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FileAppender Class | Aspose.Email.Logging Namespace


FileAppender Constructor

Initializes a new instance of the FileAppender class.

Overload List

Initializes a new instance of the FileAppender class.

public FileAppender();

Initializes a new instance of the FileAppender class.

public FileAppender(string);

Initializes a new instance of the FileAppender class.

public FileAppender(string,IFormatter);

Initializes a new instance of the FileAppender class.

public FileAppender(string,bool);

Initializes a new instance of the FileAppender class.

public FileAppender(string,bool,IFormatter);

See Also

FileAppender Class | Aspose.Email.Logging Namespace


FileAppender Constructor ()

Initializes a new instance of the FileAppender class.

public FileAppender();

See Also

FileAppender Class | Aspose.Email.Logging Namespace | FileAppender Constructor Overload List


FileAppender Constructor (String)

Initializes a new instance of the FileAppender class.

public FileAppender(
string fileName
);

Parameters

fileName
The file name.

See Also

FileAppender Class | Aspose.Email.Logging Namespace | FileAppender Constructor Overload List


FileAppender Constructor (String, Boolean)

Initializes a new instance of the FileAppender class.

public FileAppender(
string fileName,
bool useDate
);

Parameters

fileName
The file name.
useDate
Indicates if date is used in file name

See Also

FileAppender Class | Aspose.Email.Logging Namespace | FileAppender Constructor Overload List


FileAppender Constructor (String, IFormatter)

Initializes a new instance of the FileAppender class.

public FileAppender(
string fileName,
IFormatter formatter
);

Parameters

fileName
The file name.
formatter
Log formatter

See Also

FileAppender Class | Aspose.Email.Logging Namespace | FileAppender Constructor Overload List


FileAppender Constructor (String, Boolean, IFormatter)

Initializes a new instance of the FileAppender class.

public FileAppender(
string fileName,
bool useDate,
IFormatter formatter
);

Parameters

fileName
The file name.
useDate
Indicates if date is used in file name
formatter
Log formatter

See Also

FileAppender Class | Aspose.Email.Logging Namespace | FileAppender Constructor Overload List


FileAppender Properties

The properties of the FileAppender class are listed below. For a complete list of FileAppender class members, see the FileAppender Members topic.

Public Instance Properties

Encoding | Gets or sets the encoding.
FileName | Gets or sets file name.
Formatter (inherited from Appender) | Gets or sets the formatter.
UseDate | Gets or sets value which indicates whether date is used for logging.

See Also

FileAppender Class | Aspose.Email.Logging Namespace


Encoding Property

Aspose.Email

FileAppender.Encoding Property

Gets or sets the encoding.

public string Encoding {get; set;}

See Also

FileAppender Class | Aspose.Email.Logging Namespace


FileName Property

Aspose.Email

FileAppender.FileName Property

Gets or sets file name.

public string FileName {get; set;}

See Also

FileAppender Class | Aspose.Email.Logging Namespace


UseDate Property

Aspose.Email

FileAppender.UseDate Property

Gets or sets value which indicates whether date is used for logging.

public bool UseDate {get; set;}

See Also

FileAppender Class | Aspose.Email.Logging Namespace


FileAppender Methods

The methods of the FileAppender class are listed below. For a complete list of FileAppender class members, see the FileAppender Members topic.

Public Instance Methods

Append | Overloaded. Appends the log entry information to the appender.
AppendHeader | Starts log file with specific header.
Close | Closes the appender.
Dispose (inherited from Appender) | Releases the unmanaged resources used by the Appender.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Appender) | Initializes the appender instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FileAppender Class | Aspose.Email.Logging Namespace


Append Method

Aspose.Email

FileAppender.Append Method

Appends the log entry information to the appender.

Overload List

Appends the log entry information to the appender.

public override void Append(LogEntry);

Appends a set of log entries to the appender.

public void Append(LogEntry[]);

See Also

FileAppender Class | Aspose.Email.Logging Namespace


FileAppender.Append Method (LogEntry)

Appends the log entry information to the appender.

public override void Append(
LogEntry logEntry
);

Parameters

logEntry
The log entry.

Implements

IAppender.Append

See Also

FileAppender Class | Aspose.Email.Logging Namespace | FileAppender.Append Overload List


FileAppender.Append Method (LogEntry[])

Appends a set of log entries to the appender.

public void Append(
LogEntry[] logEntries
);

Parameters

logEntries
A set of log entries to log.

See Also

FileAppender Class | Aspose.Email.Logging Namespace | FileAppender.Append Overload List


FileAppender.AppendHeader Method

Starts log file with specific header.

public override void AppendHeader();

Implements

IAppender.AppendHeader

See Also

FileAppender Class | Aspose.Email.Logging Namespace


FileAppender.Close Method

Closes the appender.

public override void Close();

See Also

FileAppender Class | Aspose.Email.Logging Namespace


Formatter Class

Represents the interface for formatting log entry messsages.

For a list of all members of this type, see Formatter Members.

System.Object
Aspose.Email.Logging.Formatter
Aspose.Email.Logging.SimpleFormatter
Aspose.Email.Logging.StandardFormatter

public abstract class Formatter : IFormatter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Logging

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Formatter Members | Aspose.Email.Logging Namespace


Formatter Members

Formatter overview

Public Static Properties

DefaultFormatter Gets or sets default formatter

Public Instance Properties

Footer | Gets or sets the footer.
Header | Gets or sets the header.
LogHeader | Gets or sets the log header

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Format | Overloaded. Formats a log entry and return a string to be outputted.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

Formatter Overloaded. Initializes a new instance of the Formatter class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Formatter Class | Aspose.Email.Logging Namespace


Formatter Constructor

Initializes a new instance of the Formatter class.

Overload List

Initializes a new instance of the Formatter class.

protected Formatter();

protected Formatter(string);

protected Formatter(StringBuilder);

See Also

Formatter Class | Aspose.Email.Logging Namespace


Formatter Constructor ()

Initializes a new instance of the Formatter class.

protected Formatter();

See Also

Formatter Class | Aspose.Email.Logging Namespace | Formatter Constructor Overload List


Formatter Constructor (StringBuilder)

protected Formatter(
StringBuilder logHeaderText
);

See Also

Formatter Class | Aspose.Email.Logging Namespace | Formatter Constructor Overload List


Formatter Constructor (String)

protected Formatter(
string logHeaderText
);

See Also

Formatter Class | Aspose.Email.Logging Namespace | Formatter Constructor Overload List


Formatter Properties

The properties of the Formatter class are listed below. For a complete list of Formatter class members, see the Formatter Members topic.

Public Static Properties

DefaultFormatter Gets or sets default formatter

Public Instance Properties

Footer | Gets or sets the footer.
Header | Gets or sets the header.
LogHeader | Gets or sets the log header

See Also

Formatter Class | Aspose.Email.Logging Namespace


DefaultFormatter Property

Aspose.Email

Formatter.DefaultFormatter Property

Gets or sets default formatter

public static IFormatter DefaultFormatter {get; set;}

See Also

Formatter Class | Aspose.Email.Logging Namespace


Footer Property

Aspose.Email

Formatter.Footer Property

Gets or sets the footer.

public virtual string Footer {get; set;}

Implements

IFormatter.Footer

See Also

Formatter Class | Aspose.Email.Logging Namespace


Header Property

Aspose.Email

Formatter.Header Property

Gets or sets the header.

public virtual string Header {get; set;}

Implements

IFormatter.Header

See Also

Formatter Class | Aspose.Email.Logging Namespace


LogHeader Property

Aspose.Email

Formatter.LogHeader Property

Gets or sets the log header

public virtual string LogHeader {get; set;}

Implements

IFormatter.LogHeader

See Also

Formatter Class | Aspose.Email.Logging Namespace


Formatter Methods

The methods of the Formatter class are listed below. For a complete list of Formatter class members, see the Formatter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Format | Overloaded. Formats a log entry and return a string to be outputted.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Formatter Class | Aspose.Email.Logging Namespace


Format Method

Aspose.Email

Formatter.Format Method

Formats a log entry and return a string to be outputted.

Overload List

Formats a log entry and return a string to be outputted.

public virtual string Format(LogEntry);

Formats a datetime and return a string to be outputted.

public virtual string Format(DateTime);

See Also

Formatter Class | Aspose.Email.Logging Namespace


Formatter.Format Method (LogEntry)

Formats a log entry and return a string to be outputted.

public virtual string Format(
LogEntry entry
);

Parameters

entry
Log entry to format.

Return Value

String representing the log entry.

Implements

IFormatter.Format

See Also

Formatter Class | Aspose.Email.Logging Namespace | Formatter.Format Overload List


Formatter.Format Method (DateTime)

Formats a datetime and return a string to be outputted.

public virtual string Format(
DateTime date
);

Parameters

date
The datetime value for formatting to string

Implements

IFormatter.Format

See Also

Formatter Class | Aspose.Email.Logging Namespace | Formatter.Format Overload List


IAppender Interface

Implement this interface for your own strategies for printing log entries.

For a list of all members of this type, see IAppender Members.

public interface IAppender

Types that implement IAppender

Type | Description
Appender | Represents the base class for Appender.
ConsoleAppender | Represents an appender for console output.
DebugAppender | Represents an appender is only enabled when debugging.
FileAppender | Reprensents a file appender.
NullAppender | Represents a do-nothing appender.

Requirements

Namespace: Aspose.Email.Logging

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

IAppender Members | Aspose.Email.Logging Namespace


IAppender Members

IAppender overview

Public Instance Properties

Formatter Gets or sets the IFormatter.

Public Instance Methods

Append | Log the specified log entry in Appender specific way.
AppendHeader | Starts log file with specific header.

See Also

IAppender Interface | Aspose.Email.Logging Namespace


IAppender Properties

The properties of the IAppender interface are listed below. For a complete list of IAppender interface members, see the IAppender Members topic.

Public Instance Properties

Formatter Gets or sets the IFormatter.

See Also

IAppender Interface | Aspose.Email.Logging Namespace


Formatter Property

Aspose.Email

IAppender.Formatter Property

Gets or sets the IFormatter.

IFormatter Formatter {get; set;}

See Also

IAppender Interface | Aspose.Email.Logging Namespace


IAppender Methods

The methods of the IAppender interface are listed below. For a complete list of IAppender interface members, see the IAppender Members topic.

Public Instance Methods

Append | Log the specified log entry in Appender specific way.
AppendHeader | Starts log file with specific header.

See Also

IAppender Interface | Aspose.Email.Logging Namespace


IAppender.Append Method

Log the specified log entry in Appender specific way.

void Append(
LogEntry entry
);

Parameters

entry
Contains a log message.

See Also

IAppender Interface | Aspose.Email.Logging Namespace


IAppender.AppendHeader Method

Starts log file with specific header.

void AppendHeader();

See Also

IAppender Interface | Aspose.Email.Logging Namespace


IFormatter Interface

Represents the interface for formatting log entry messsages.

For a list of all members of this type, see IFormatter Members.

public interface IFormatter

Types that implement IFormatter

Type | Description
Formatter | Represents the interface for formatting log entry messsages.
SimpleFormatter | Represents the default implementation of IFormatter interface.
StandardFormatter | Represents the class for formatting log entry messsages.

Requirements

Namespace: Aspose.Email.Logging

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

IFormatter Members | Aspose.Email.Logging Namespace


IFormatter Members

IFormatter overview

Public Instance Properties

Footer | Gest the footer string.
Header | Gets the header string.
LogHeader | Represents start log header

Public Instance Methods

Format Overloaded. Formats a log entry and return a string to be outputted.

See Also

IFormatter Interface | Aspose.Email.Logging Namespace


IFormatter Properties

The properties of the IFormatter interface are listed below. For a complete list of IFormatter interface members, see the IFormatter Members topic.

Public Instance Properties

Footer | Gest the footer string.
Header | Gets the header string.
LogHeader | Represents start log header

See Also

IFormatter Interface | Aspose.Email.Logging Namespace


Footer Property

Aspose.Email

IFormatter.Footer Property

Gest the footer string.

string Footer {get;}

See Also

IFormatter Interface | Aspose.Email.Logging Namespace


Header Property

Aspose.Email

IFormatter.Header Property

Gets the header string.

string Header {get;}

See Also

IFormatter Interface | Aspose.Email.Logging Namespace


LogHeader Property

Aspose.Email

IFormatter.LogHeader Property

Represents start log header

string LogHeader {get;}

See Also

IFormatter Interface | Aspose.Email.Logging Namespace


IFormatter Methods

The methods of the IFormatter interface are listed below. For a complete list of IFormatter interface members, see the IFormatter Members topic.

Public Instance Methods

Format Overloaded. Formats a log entry and return a string to be outputted.

See Also

IFormatter Interface | Aspose.Email.Logging Namespace


Format Method

Aspose.Email

IFormatter.Format Method

Formats a log entry and return a string to be outputted.

Overload List

Formats a log entry and return a string to be outputted.

string Format(LogEntry);

Formats a datetime and return a string to be outputted.

string Format(DateTime);

See Also

IFormatter Interface | Aspose.Email.Logging Namespace


IFormatter.Format Method (LogEntry)

Formats a log entry and return a string to be outputted.

string Format(
LogEntry entry
);

Parameters

entry
The Log entry to format.

Return Value

String representing the log entry.

See Also

IFormatter Interface | Aspose.Email.Logging Namespace | IFormatter.Format Overload List


IFormatter.Format Method (DateTime)

Formats a datetime and return a string to be outputted.

string Format(
DateTime datatime
);

Parameters

datatime
The datetime value for formatting to string

See Also

IFormatter Interface | Aspose.Email.Logging Namespace | IFormatter.Format Overload List


LogEntry Class

Represents a log message. Contains the common properties that are required for all log messages.

For a list of all members of this type, see LogEntry Members.

System.Object
Aspose.Email.Logging.LogEntry

public class LogEntry : ICloneable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Logging

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

LogEntry Members | Aspose.Email.Logging Namespace


LogEntry Members

LogEntry overview

Public Instance Constructors

LogEntry Overloaded. Initializes a new instance of the LogEntry class.

Public Instance Properties

AppDomainName | The AppDomain in which we are running
Category | Category name used to route the log entry to a one or more sinks.
ContextualProperties | Dictionary of key/value pairs to record.
ErrorMessages | Gets the error message with the LogEntry
EventId | Event number or identifier.
InnerException | Gets or sets the inner exception object.
MachineName | Name of the computer.
Message | Message body to log. Value from ToString() method from message object.
SequenceId | The unique identifier of log event which is automatically generated and monotonously increasing.
Severity | Log entry severity as a Severity enumeration. (Unspecified, Information, Warning or Error).
ThreadName | The name of the .NET thread.
TimeStamp | Date and time of the log entry message.
Title | Additional description of the log entry message.

Public Instance Methods

AddErrorMessage | Add an error or warning message to the start of the messages string builder. Used by the distributor to record problems.
Clone | Creates a new LogEntry that is a copy of the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LogEntry Class | Aspose.Email.Logging Namespace


LogEntry Constructor

Initialize a new instance of a LogEntry class.

Overload List

Initialize a new instance of a LogEntry class.

public LogEntry();

Initialize a new instance of a LogEntry class.

public LogEntry(string);

Initialize a new instance of a LogEntry class.

public LogEntry(string,LogLevel);

Create a new instance of LogEntry with a full set of constructor parameters

public LogEntry(string,LogLevel,string,int,string,IDictionary);

Initialize a new instance of a LogEntry class.

public LogEntry(string,Exception);

Initialize a new instance of a LogEntry class.

public LogEntry(string,Exception,LogLevel);

Create a new instance of LogEntry with a full set of constructor parameters

public LogEntry(string,Exception,LogLevel,string,int,string,IDictionary);

See Also

LogEntry Class | Aspose.Email.Logging Namespace


LogEntry Constructor ()

Initialize a new instance of a LogEntry class.

public LogEntry();

See Also

LogEntry Class | Aspose.Email.Logging Namespace | LogEntry Constructor Overload List


LogEntry Constructor (String)

Initialize a new instance of a LogEntry class.

public LogEntry(
string message
);

Parameters

message
The message.

See Also

LogEntry Class | Aspose.Email.Logging Namespace | LogEntry Constructor Overload List


LogEntry Constructor (String, Exception)

Initialize a new instance of a LogEntry class.

public LogEntry(
string message,
Exception innerException
);

Parameters

message
Message body to log. Value from ToString() method from message object.
innerException
The inner exception to log.

See Also

LogEntry Class | Aspose.Email.Logging Namespace | LogEntry Constructor Overload List


LogEntry Constructor (String, LogLevel)

Initialize a new instance of a LogEntry class.

public LogEntry(
string message,
LogLevel severity
);

Parameters

message
Message body to log. Value from ToString() method from message object.
severity
Log entry severity as a Severity enumeration. (Unspecified, Information, Warning or Error).

See Also

LogEntry Class | Aspose.Email.Logging Namespace | LogEntry Constructor Overload List


LogEntry Constructor (String, Exception, LogLevel)

Initialize a new instance of a LogEntry class.

public LogEntry(
string message,
Exception innerException,
LogLevel severity
);

Parameters

message
Message body to log. Value from ToString() method from message object.
innerException
The inner exception to log.
severity
Log entry severity as a Severity enumeration. (Unspecified, Information, Warning or Error).

See Also

LogEntry Class | Aspose.Email.Logging Namespace | LogEntry Constructor Overload List


LogEntry Constructor (String, LogLevel, String, Int32, String, IDictionary)

Create a new instance of LogEntry with a full set of constructor parameters

public LogEntry(
string message,
LogLevel severity,
string category,
int eventId,
string title,
IDictionary properties
);

Parameters

message
Message body to log. Value from ToString() method from message object.
severity
Log entry severity as a Severity enumeration. (Unspecified, Information, Warning or Error).
category
Category name used to route the log entry to a one or more sinks.
eventId
Event number or identifier.
title
Additional description of the log entry message.
properties
Dictionary of key/value pairs to record.

See Also

LogEntry Class | Aspose.Email.Logging Namespace | LogEntry Constructor Overload List


LogEntry Constructor (String, Exception, LogLevel, String, Int32, String, IDictionary)

Create a new instance of LogEntry with a full set of constructor parameters

public LogEntry(
string message,
Exception innerException,
LogLevel severity,
string category,
int eventId,
string title,
IDictionary properties
);

Parameters

message
Message body to log. Value from ToString() method from message object.
innerException
The inner exception to log.
severity
Log entry severity as a Severity enumeration. (Unspecified, Information, Warning or Error).
category
Category name used to route the log entry to a one or more sinks.
eventId
Event number or identifier.
title
Additional description of the log entry message.
properties
Dictionary of key/value pairs to record.

See Also

LogEntry Class | Aspose.Email.Logging Namespace | LogEntry Constructor Overload List


LogEntry Properties

The properties of the LogEntry class are listed below. For a complete list of LogEntry class members, see the LogEntry Members topic.

Public Instance Properties

AppDomainName | The AppDomain in which we are running
Category | Category name used to route the log entry to a one or more sinks.
ContextualProperties | Dictionary of key/value pairs to record.
ErrorMessages | Gets the error message with the LogEntry
EventId | Event number or identifier.
InnerException | Gets or sets the inner exception object.
MachineName | Name of the computer.
Message | Message body to log. Value from ToString() method from message object.
SequenceId | The unique identifier of log event which is automatically generated and monotonously increasing.
Severity | Log entry severity as a Severity enumeration. (Unspecified, Information, Warning or Error).
ThreadName | The name of the .NET thread.
TimeStamp | Date and time of the log entry message.
Title | Additional description of the log entry message.

See Also

LogEntry Class | Aspose.Email.Logging Namespace


AppDomainName Property

Aspose.Email

LogEntry.AppDomainName Property

The AppDomain in which we are running

public string AppDomainName {get; set;}

See Also

LogEntry Class | Aspose.Email.Logging Namespace


Category Property

Aspose.Email

LogEntry.Category Property

Category name used to route the log entry to a one or more sinks.

public string Category {get; set;}

See Also

LogEntry Class | Aspose.Email.Logging Namespace


ContextualProperties Property

Aspose.Email

LogEntry.ContextualProperties Property

Dictionary of key/value pairs to record.

public IDictionary ContextualProperties {get; set;}

See Also

LogEntry Class | Aspose.Email.Logging Namespace


ErrorMessages Property

Aspose.Email

LogEntry.ErrorMessages Property

Gets the error message with the LogEntry

public string ErrorMessages {get;}

See Also

LogEntry Class | Aspose.Email.Logging Namespace


EventId Property

Aspose.Email

LogEntry.EventId Property

Event number or identifier.

public int EventId {get; set;}

See Also

LogEntry Class | Aspose.Email.Logging Namespace


InnerException Property

Aspose.Email

LogEntry.InnerException Property

Gets or sets the inner exception object.

public Exception InnerException {get; set;}

See Also

LogEntry Class | Aspose.Email.Logging Namespace


MachineName Property

Aspose.Email

LogEntry.MachineName Property

Name of the computer.

public string MachineName {get; set;}

See Also

LogEntry Class | Aspose.Email.Logging Namespace


Message Property

Aspose.Email

LogEntry.Message Property

Message body to log. Value from ToString() method from message object.

public string Message {get; set;}

See Also

LogEntry Class | Aspose.Email.Logging Namespace


SequenceId Property

Aspose.Email

LogEntry.SequenceId Property

The unique identifier of log event which is automatically generated and monotonously increasing.

public int SequenceId {get;}

See Also

LogEntry Class | Aspose.Email.Logging Namespace


Severity Property

Aspose.Email

LogEntry.Severity Property

Log entry severity as a Severity enumeration. (Unspecified, Information, Warning or Error).

public LogLevel Severity {get; set;}

See Also

LogEntry Class | Aspose.Email.Logging Namespace


ThreadName Property

Aspose.Email

LogEntry.ThreadName Property

The name of the .NET thread.

public string ThreadName {get; set;}

See Also

LogEntry Class | Aspose.Email.Logging Namespace


TimeStamp Property

Aspose.Email

LogEntry.TimeStamp Property

Date and time of the log entry message.

public DateTime TimeStamp {get; set;}

See Also

LogEntry Class | Aspose.Email.Logging Namespace


Title Property

Aspose.Email

LogEntry.Title Property

Additional description of the log entry message.

public string Title {get; set;}

See Also

LogEntry Class | Aspose.Email.Logging Namespace


LogEntry Methods

The methods of the LogEntry class are listed below. For a complete list of LogEntry class members, see the LogEntry Members topic.

Public Instance Methods

AddErrorMessage | Add an error or warning message to the start of the messages string builder. Used by the distributor to record problems.
Clone | Creates a new LogEntry that is a copy of the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LogEntry Class | Aspose.Email.Logging Namespace


LogEntry.AddErrorMessage Method

Add an error or warning message to the start of the messages string builder. Used by the distributor to record problems.

public virtual void AddErrorMessage(
string message
);

Parameters

message
Message to be added to this instance

See Also

LogEntry Class | Aspose.Email.Logging Namespace


LogEntry.Clone Method

Creates a new LogEntry that is a copy of the current instance.

public object Clone();

Return Value

A new LogEntry that is a copy of the current instance.

Implements

ICloneable.Clone

See Also

LogEntry Class | Aspose.Email.Logging Namespace


Logger Class

Provides the logging functionality.

For a list of all members of this type, see Logger Members.

System.Object
Aspose.Email.Logging.Logger

public sealed class Logger

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Logging

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Logger Members | Aspose.Email.Logging Namespace


Logger Members

Logger overview

Public Static Properties

Debug Gets the debug logger.

Public Instance Properties

Appenders | Gets or sets the appender list.
Name | Gets or sets name.
Severity | Gets or sets severity.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEnabled | Determines if logging is enabled for the specified level.
Log | Overloaded. Logs the specified message and exception if the log level is enabled.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write | Overloaded. Writes the specified message and exception to appenders.
WriteIf | Overloaded. Writes the specified message to appenders if condition is true.

See Also

Logger Class | Aspose.Email.Logging Namespace


Logger Properties

The properties of the Logger class are listed below. For a complete list of Logger class members, see the Logger Members topic.

Public Static Properties

Debug Gets the debug logger.

Public Instance Properties

Appenders | Gets or sets the appender list.
Name | Gets or sets name.
Severity | Gets or sets severity.

See Also

Logger Class | Aspose.Email.Logging Namespace


Appenders Property

Aspose.Email

Logger.Appenders Property

Gets or sets the appender list.

public AppenderCollection Appenders {get; set;}

See Also

Logger Class | Aspose.Email.Logging Namespace


Debug Property

Aspose.Email

Logger.Debug Property

Gets the debug logger.

public static Logger Debug {get;}

See Also

Logger Class | Aspose.Email.Logging Namespace


Name Property

Aspose.Email

Logger.Name Property

Gets or sets name.

public string Name {get;}

See Also

Logger Class | Aspose.Email.Logging Namespace


Severity Property

Aspose.Email

Logger.Severity Property

Gets or sets severity.

public LogLevel Severity {get; set;}

See Also

Logger Class | Aspose.Email.Logging Namespace


Logger Methods

The methods of the Logger class are listed below. For a complete list of Logger class members, see the Logger Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEnabled | Determines if logging is enabled for the specified level.
Log | Overloaded. Logs the specified message and exception if the log level is enabled.
ToString (inherited from Object) | Returns a String that represents the current Object.
Write | Overloaded. Writes the specified message and exception to appenders.
WriteIf | Overloaded. Writes the specified message to appenders if condition is true.

See Also

Logger Class | Aspose.Email.Logging Namespace


Logger.IsEnabled Method

Determines if logging is enabled for the specified level.

public bool IsEnabled(
LogLevel level
);

Parameters

level
level to be checked

Return Value

true if logging is enabled for the specified level, otherwise it returns false.

See Also

Logger Class | Aspose.Email.Logging Namespace


Log Method

Aspose.Email

Logger.Log Method

Logs the specified message if the log level is enabled.

Overload List

Logs the specified message if the log level is enabled.

public void Log(string,LogLevel);

Logs the specified message and exception if the log level is enabled.

public void Log(string,Exception,LogLevel);

See Also

Logger Class | Aspose.Email.Logging Namespace


Logger.Log Method (String, LogLevel)

Logs the specified message if the log level is enabled.

public void Log(
string message,
LogLevel level
);

Parameters

message
The message to log.
level
The log level.

See Also

Logger Class | Aspose.Email.Logging Namespace | Logger.Log Overload List


Logger.Log Method (String, Exception, LogLevel)

Logs the specified message and exception if the log level is enabled.

public void Log(
string message,
Exception exception,
LogLevel level
);

Parameters

message
The message to log.
exception
The exception to log.
level
The log level.

See Also

Logger Class | Aspose.Email.Logging Namespace | Logger.Log Overload List


Write Method

Aspose.Email

Logger.Write Method

Writes the specified message to appenders.

Overload List

Writes the specified message to appenders.

public void Write(object);

Writes the specified message to appenders.

public void Write(string);

Writes the specified message and exception to appenders.

public void Write(string,Exception);

See Also

Logger Class | Aspose.Email.Logging Namespace


Logger.Write Method (Object)

Writes the specified message to appenders.

public void Write(
object message
);

Parameters

message
The message to write.

See Also

Logger Class | Aspose.Email.Logging Namespace | Logger.Write Overload List


Logger.Write Method (String)

Writes the specified message to appenders.

public void Write(
string message
);

Parameters

message
The message to write.

See Also

Logger Class | Aspose.Email.Logging Namespace | Logger.Write Overload List


Logger.Write Method (String, Exception)

Writes the specified message and exception to appenders.

public void Write(
string message,
Exception exception
);

Parameters

message
The message to write.
exception
The exception to write.

See Also

Logger Class | Aspose.Email.Logging Namespace | Logger.Write Overload List


WriteIf Method

Aspose.Email

Logger.WriteIf Method

Writes the specified message to appenders if condition is true.

Overload List

Writes the specified message to appenders if condition is true.

public void WriteIf(bool,object);

Writes the specified message to appenders if condition is true.

public void WriteIf(bool,string);

Writes the specified message and exception to appenders if condition is true.

public void WriteIf(bool,string,Exception);

See Also

Logger Class | Aspose.Email.Logging Namespace


Logger.WriteIf Method (Boolean, Object)

Writes the specified message to appenders if condition is true.

public void WriteIf(
bool condition,
object message
);

Parameters

condition
The condition to test.
message
The message to write.

See Also

Logger Class | Aspose.Email.Logging Namespace | Logger.WriteIf Overload List


Logger.WriteIf Method (Boolean, String)

Writes the specified message to appenders if condition is true.

public void WriteIf(
bool condition,
string message
);

Parameters

condition
The condition to test.
message
The message to write.

See Also

Logger Class | Aspose.Email.Logging Namespace | Logger.WriteIf Overload List


Logger.WriteIf Method (Boolean, String, Exception)

Writes the specified message and exception to appenders if condition is true.

public void WriteIf(
bool condition,
string message,
Exception exception
);

Parameters

condition
The condition to test.
message
The message to write.
exception
The exception to write.

See Also

Logger Class | Aspose.Email.Logging Namespace | Logger.WriteIf Overload List


LoggerManager Class

Static manager that controls the creation of loggers.

For a list of all members of this type, see LoggerManager Members.

System.Object
Aspose.Email.Logging.LoggerManager

public abstract sealed class LoggerManager

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Logging

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

LoggerManager Members | Aspose.Email.Logging Namespace


LoggerManager Members

LoggerManager overview

Public Static Methods

AddLogger | Adds a logger to the LoggerManager with specified name.
CreateLogger | Overloaded. Creates a logger with specified name and appender.
GetLogger | Gets a logger by the specified name.
RemoveLogger | Removes a logger with the specified name.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

LoggerManager Class | Aspose.Email.Logging Namespace


LoggerManager Methods

The methods of the LoggerManager class are listed below. For a complete list of LoggerManager class members, see the LoggerManager Members topic.

Public Static Methods

AddLogger | Adds a logger to the LoggerManager with specified name.
CreateLogger | Overloaded. Creates a logger with specified name and appender.
GetLogger | Gets a logger by the specified name.
RemoveLogger | Removes a logger with the specified name.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

LoggerManager Class | Aspose.Email.Logging Namespace


LoggerManager.AddLogger Method

Adds a logger to the LoggerManager with specified name.

public static void AddLogger(
string name,
Logger logger
);

Parameters

name
The logger name.
logger
The logger.

See Also

LoggerManager Class | Aspose.Email.Logging Namespace


CreateLogger Method

Aspose.Email

LoggerManager.CreateLogger Method

Creates a logger with specified name and appender.

Overload List

Creates a logger with specified name and appender.

public static Logger CreateLogger(string,Appender);

Creates a logger with specified name and appender.

public static Logger CreateLogger(string,LogLevel,Appender);

See Also

LoggerManager Class | Aspose.Email.Logging Namespace


LoggerManager.CreateLogger Method (String, Appender)

Creates a logger with specified name and appender.

public static Logger CreateLogger(
string name,
Appender appender
);

Parameters

name
The logger name.
appender
The appender.

Return Value

The created logger.

See Also

LoggerManager Class | Aspose.Email.Logging Namespace | LoggerManager.CreateLogger Overload List


LoggerManager.CreateLogger Method (String, LogLevel, Appender)

Creates a logger with specified name and appender.

public static Logger CreateLogger(
string name,
LogLevel severity,
Appender appender
);

Parameters

name
The logger name.
severity
The severity.
appender
The appender.

Return Value

The created logger.

See Also

LoggerManager Class | Aspose.Email.Logging Namespace | LoggerManager.CreateLogger Overload List


LoggerManager.GetLogger Method

Gets a logger by the specified name.

public static Logger GetLogger(
string name
);

Parameters

name
The logger name.

Return Value

The logger.

See Also

LoggerManager Class | Aspose.Email.Logging Namespace


LoggerManager.RemoveLogger Method

Removes a logger with the specified name.

public static void RemoveLogger(
string name
);

Parameters

name
The logger name.

See Also

LoggerManager Class | Aspose.Email.Logging Namespace


LoggingException Class

The exception that is thrown when error is found in logging.

For a list of all members of this type, see LoggingException Members.

System.Object
System.Exception
Aspose.Email.Logging.LoggingException

public class LoggingException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Logging

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

LoggingException Members | Aspose.Email.Logging Namespace


LoggingException Members

LoggingException overview

Public Instance Constructors

LoggingException Overloaded. Initializes a new instance of the LoggingException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

LoggingException Overloaded. Initializes a new instance of the LoggingException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LoggingException Class | Aspose.Email.Logging Namespace


LoggingException Constructor

Initializes a new instance of the LoggingException class.

Overload List

Initializes a new instance of the LoggingException class.

public LoggingException();

Initializes a new instance of the LoggingException class with serialized data.

protected LoggingException(SerializationInfo,StreamingContext);

Initializes a new instance of the LoggingException class.

public LoggingException(string);

Initializes a new instance of the LoggingException class.

public LoggingException(string,Exception);

See Also

LoggingException Class | Aspose.Email.Logging Namespace


LoggingException Constructor ()

Initializes a new instance of the LoggingException class.

public LoggingException();

See Also

LoggingException Class | Aspose.Email.Logging Namespace | LoggingException Constructor Overload List


LoggingException Constructor (String)

Initializes a new instance of the LoggingException class.

public LoggingException(
string message
);

Parameters

message
The error message.

See Also

LoggingException Class | Aspose.Email.Logging Namespace | LoggingException Constructor Overload List


LoggingException Constructor (String, Exception)

Initializes a new instance of the LoggingException class.

public LoggingException(
string message,
Exception innerException
);

Parameters

message
The error message.
innerException
The inner exception.

See Also

LoggingException Class | Aspose.Email.Logging Namespace | LoggingException Constructor Overload List


LoggingException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the LoggingException class with serialized data.

protected LoggingException(
SerializationInfo info,
StreamingContext context
);

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception Type | Condition
ArgumentNullException | The info parameter is null.
SerializationException | The class name is null or HResult is zero (0).

See Also

LoggingException Class | Aspose.Email.Logging Namespace | LoggingException Constructor Overload List


LogLevel Class

Defines available log levels.

For a list of all members of this type, see LogLevel Members.

System.Object
Aspose.Email.Logging.LogLevel

public class LogLevel : IComparable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Logging

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

LogLevel Members | Aspose.Email.Logging Namespace


LogLevel Members

LogLevel overview

Public Static Fields

Debug | The Debug level.
Error | The Error level.
Fatal | The Fatal level.
Information | The Info level.
Trace | The Trace level.
Warning | The Warn level.

Public Static Operators

Greater Than Operator | Compares two LogLevel objects and returns a value indicating whether the first one is greater than the second one.
Greater Than Or Equal Operator | Compares two LogLevel objects and returns a value indicating whether the first one is greater than or equal to the second one.
Less Than Operator | Compares two LogLevel objects and returns a value indicating whether the first one is less than the second one.
Less Than Or Equal Operator | Compares two LogLevel objects and returns a value indicating whether the first one is less than or equal to the second one.

Public Instance Methods

CompareTo | Compares the level to the other LogLevel object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a string representation of the log level.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LogLevel Class | Aspose.Email.Logging Namespace


LogLevel Fields

The fields of the LogLevel class are listed below. For a complete list of LogLevel class members, see the LogLevel Members topic.

Public Static Fields

Debug | The Debug level.
Error | The Error level.
Fatal | The Fatal level.
Information | The Info level.
Trace | The Trace level.
Warning | The Warn level.

See Also

LogLevel Class | Aspose.Email.Logging Namespace


LogLevel.Debug Field

The Debug level.

public static LogLevel Debug;

See Also

LogLevel Class | Aspose.Email.Logging Namespace


LogLevel.Error Field

The Error level.

public static LogLevel Error;

See Also

LogLevel Class | Aspose.Email.Logging Namespace


LogLevel.Fatal Field

The Fatal level.

public static LogLevel Fatal;

See Also

LogLevel Class | Aspose.Email.Logging Namespace


LogLevel.Information Field

The Info level.

public static LogLevel Information;

See Also

LogLevel Class | Aspose.Email.Logging Namespace


LogLevel.Trace Field

The Trace level.

public static LogLevel Trace;

See Also

LogLevel Class | Aspose.Email.Logging Namespace


LogLevel.Warning Field

The Warn level.

public static LogLevel Warning;

See Also

LogLevel Class | Aspose.Email.Logging Namespace


LogLevel Methods

The methods of the LogLevel class are listed below. For a complete list of LogLevel class members, see the LogLevel Members topic.

Public Instance Methods

CompareTo | Compares the level to the other LogLevel object.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a string representation of the log level.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LogLevel Class | Aspose.Email.Logging Namespace


LogLevel.CompareTo Method

Compares the level to the other LogLevel object.

public int CompareTo(
object obj
);

Parameters

obj
the object object

Return Value

a value less than zero when this logger's Ordinal is less than the other logger's ordinal, 0 when they are equal and greater than zero when this ordinal is greater than the other ordinal.

Implements

IComparable.CompareTo

See Also

LogLevel Class | Aspose.Email.Logging Namespace


LogLevel.ToString Method

Returns a string representation of the log level.

public override string ToString();

Return Value

Log level name.

See Also

LogLevel Class | Aspose.Email.Logging Namespace


LogLevel Operators

The operators of the LogLevel class are listed below. For a complete list of LogLevel class members, see the LogLevel Members topic.

Public Static Operators

Greater Than Operator | Compares two LogLevel objects and returns a value indicating whether the first one is greater than the second one.
Greater Than Or Equal Operator | Compares two LogLevel objects and returns a value indicating whether the first one is greater than or equal to the second one.
Less Than Operator | Compares two LogLevel objects and returns a value indicating whether the first one is less than the second one.
Less Than Or Equal Operator | Compares two LogLevel objects and returns a value indicating whether the first one is less than or equal to the second one.

See Also

LogLevel Class | LogLevel Members | Aspose.Email.Logging Namespace


LogLevel Greater Than Operator

Compares two LogLevel objects and returns a value indicating whether the first one is greater than the second one.

public static bool operator >(
LogLevel l1,
LogLevel l2
);

Parameters

l1
The first level.
l2
The second level.

Return Value

The value of l1.Ordinal > l2.Ordinal

See Also

LogLevel Class | Aspose.Email.Logging Namespace


LogLevel Greater Than Or Equal Operator

Compares two LogLevel objects and returns a value indicating whether the first one is greater than or equal to the second one.

public static bool operator >=(
LogLevel l1,
LogLevel l2
);

Parameters

l1
The first level.
l2
The second level.

Return Value

The value of l1.Ordinal >= l2.Ordinal

See Also

LogLevel Class | Aspose.Email.Logging Namespace


LogLevel Less Than Operator

Compares two LogLevel objects and returns a value indicating whether the first one is less than the second one.

public static bool operator <(
LogLevel l1,
LogLevel l2
);

Parameters

l1
The first level.
l2
The second level.

Return Value

The value of l1.Ordinal < l2.Ordinal

See Also

LogLevel Class | Aspose.Email.Logging Namespace


LogLevel Less Than Or Equal Operator

Compares two LogLevel objects and returns a value indicating whether the first one is less than or equal to the second one.

public static bool operator <=(
LogLevel l1,
LogLevel l2
);

Parameters

l1
The first level.
l2
The second level.

Return Value

The value of l1.Ordinal <= l2.Ordinal

See Also

LogLevel Class | Aspose.Email.Logging Namespace


NullAppender Class

Represents a do-nothing appender.

For a list of all members of this type, see NullAppender Members.

System.Object
Aspose.Email.Logging.Appender
Aspose.Email.Logging.NullAppender

public sealed class NullAppender : Appender

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Logging

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

NullAppender Members | Aspose.Email.Logging Namespace


NullAppender Members

NullAppender overview

Public Instance Constructors

NullAppender Constructor Creates a new instace of NullAppender.

Public Instance Properties

Formatter (inherited from Appender) Gets or sets the formatter.

Public Instance Methods

Append | Appends a log entry to NullAppender.
AppendHeader (inherited from Appender) | Starts log file with specific header.
Close (inherited from Appender) | Closes the appender.
Dispose (inherited from Appender) | Releases the unmanaged resources used by the Appender.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Appender) | Initializes the appender instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

NullAppender Class | Aspose.Email.Logging Namespace


NullAppender Constructor

Creates a new instace of NullAppender.

public NullAppender();

See Also

NullAppender Class | Aspose.Email.Logging Namespace


NullAppender Methods

The methods of the NullAppender class are listed below. For a complete list of NullAppender class members, see the NullAppender Members topic.

Public Instance Methods

Append | Appends a log entry to NullAppender.
AppendHeader (inherited from Appender) | Starts log file with specific header.
Close (inherited from Appender) | Closes the appender.
Dispose (inherited from Appender) | Releases the unmanaged resources used by the Appender.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize (inherited from Appender) | Initializes the appender instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

NullAppender Class | Aspose.Email.Logging Namespace


NullAppender.Append Method

Appends a log entry to NullAppender.

public override void Append(
LogEntry entry
);

Parameters

entry
The entry need to log.

Implements

IAppender.Append

See Also

NullAppender Class | Aspose.Email.Logging Namespace


SimpleFormatter Class

Represents the default implementation of IFormatter interface.

For a list of all members of this type, see SimpleFormatter Members.

System.Object
Aspose.Email.Logging.Formatter
Aspose.Email.Logging.SimpleFormatter

public sealed class SimpleFormatter : Formatter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Logging

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SimpleFormatter Members | Aspose.Email.Logging Namespace


SimpleFormatter Members

SimpleFormatter overview

Public Instance Constructors

SimpleFormatter Overloaded. Initializes a new instance of the SimpleFormatter class.

Public Instance Properties

Footer (inherited from Formatter) | Gets or sets the footer.
Header (inherited from Formatter) | Gets or sets the header.
LogHeader (inherited from Formatter) | Gets or sets the log header

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Format | Overloaded. Formats a log entry and return a string to be outputted.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

SimpleFormatter Class | Aspose.Email.Logging Namespace


SimpleFormatter Constructor

Creates a new SimpleFormatter instance.

Overload List

Creates a new SimpleFormatter instance.

public SimpleFormatter();

Creates a new SimpleFormatter instance.

public SimpleFormatter(string,string);

See Also

SimpleFormatter Class | Aspose.Email.Logging Namespace


SimpleFormatter Constructor ()

Creates a new SimpleFormatter instance.

public SimpleFormatter();

See Also

SimpleFormatter Class | Aspose.Email.Logging Namespace | SimpleFormatter Constructor Overload List


SimpleFormatter Constructor (String, String)

Creates a new SimpleFormatter instance.

public SimpleFormatter(
string header,
string footer
);

Parameters

header
The header.
footer
The footer.

See Also

SimpleFormatter Class | Aspose.Email.Logging Namespace | SimpleFormatter Constructor Overload List


SimpleFormatter Methods

The methods of the SimpleFormatter class are listed below. For a complete list of SimpleFormatter class members, see the SimpleFormatter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Format | Overloaded. Formats a log entry and return a string to be outputted.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

SimpleFormatter Class | Aspose.Email.Logging Namespace


Format Method

Aspose.Email

SimpleFormatter.Format Method

Formats a log entry and return a string to be outputted.

Overload List

Formats a log entry and return a string to be outputted.

public override string Format(LogEntry);

Formats a datetime and return a string to be outputted.

public override string Format(DateTime);

See Also

SimpleFormatter Class | Aspose.Email.Logging Namespace


SimpleFormatter.Format Method (LogEntry)

Formats a log entry and return a string to be outputted.

public override string Format(
LogEntry entry
);

Parameters

entry
Log entry to format.

Return Value

String representing the log entry.

Implements

IFormatter.Format

See Also

SimpleFormatter Class | Aspose.Email.Logging Namespace | SimpleFormatter.Format Overload List


SimpleFormatter.Format Method (DateTime)

Formats a datetime and return a string to be outputted.

public override string Format(
DateTime date
);

Parameters

date
The datetime value for formatting to string

Implements

IFormatter.Format

See Also

SimpleFormatter Class | Aspose.Email.Logging Namespace | SimpleFormatter.Format Overload List


StandardFormatter Class

Represents the class for formatting log entry messsages.

For a list of all members of this type, see StandardFormatter Members.

System.Object
Aspose.Email.Logging.Formatter
Aspose.Email.Logging.StandardFormatter

public class StandardFormatter : Formatter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Logging

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

StandardFormatter Members | Aspose.Email.Logging Namespace


StandardFormatter Members

StandardFormatter overview

Public Instance Constructors

StandardFormatter Overloaded. Initializes a new instance of the StandardFormatter class.

Public Instance Properties

Footer | Gest the footer string.
Header | Gets the log header.
LogHeader (inherited from Formatter) | Gets or sets the log header

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Format | Overloaded. Formats a log entry and return a string to be outputted.
Format (inherited from Formatter) | Overloaded. Formats a log entry and return a string to be outputted.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StandardFormatter Class | Aspose.Email.Logging Namespace


StandardFormatter Constructor

Initializes a new instance of the StandardFormatter class.

Overload List

Initializes a new instance of the StandardFormatter class.

public StandardFormatter();

Initializes a new instance of the StandardFormatter class.

public StandardFormatter(string);

Initializes a new instance of the StandardFormatter class.

public StandardFormatter(StringBuilder);

See Also

StandardFormatter Class | Aspose.Email.Logging Namespace


StandardFormatter Constructor ()

Initializes a new instance of the StandardFormatter class.

public StandardFormatter();

See Also

StandardFormatter Class | Aspose.Email.Logging Namespace | StandardFormatter Constructor Overload List


StandardFormatter Constructor (StringBuilder)

Initializes a new instance of the StandardFormatter class.

public StandardFormatter(
StringBuilder headerText
);

Parameters

headerText
The header text.

See Also

StandardFormatter Class | Aspose.Email.Logging Namespace | StandardFormatter Constructor Overload List


StandardFormatter Constructor (String)

Initializes a new instance of the StandardFormatter class.

public StandardFormatter(
string headerText
);

Parameters

headerText
The header text.

See Also

StandardFormatter Class | Aspose.Email.Logging Namespace | StandardFormatter Constructor Overload List


StandardFormatter Properties

The properties of the StandardFormatter class are listed below. For a complete list of StandardFormatter class members, see the StandardFormatter Members topic.

Public Instance Properties

Footer | Gest the footer string.
Header | Gets the log header.
LogHeader (inherited from Formatter) | Gets or sets the log header

See Also

StandardFormatter Class | Aspose.Email.Logging Namespace


Footer Property

Aspose.Email

StandardFormatter.Footer Property

Gest the footer string.

public override string Footer {get;}

Implements

IFormatter.Footer

See Also

StandardFormatter Class | Aspose.Email.Logging Namespace


Header Property

Aspose.Email

StandardFormatter.Header Property

Gets the log header.

new public virtual string Header {get;}

Property Value

Implements

IFormatter.Header

See Also

StandardFormatter Class | Aspose.Email.Logging Namespace


StandardFormatter Methods

The methods of the StandardFormatter class are listed below. For a complete list of StandardFormatter class members, see the StandardFormatter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Format | Overloaded. Formats a log entry and return a string to be outputted.
Format (inherited from Formatter) | Overloaded. Formats a log entry and return a string to be outputted.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

StandardFormatter Class | Aspose.Email.Logging Namespace


Format Method

Aspose.Email

StandardFormatter.Format Method

Formats a log entry and return a string to be outputted.

Overload List

Formats a log entry and return a string to be outputted.

public override string Format(LogEntry);

Inherited from Formatter.

public virtual string Format(DateTime);

See Also

StandardFormatter Class | Aspose.Email.Logging Namespace


StandardFormatter.Format Method (LogEntry)

Formats a log entry and return a string to be outputted.

public override string Format(
LogEntry entry
);

Parameters

entry
The Log entry to format.

Return Value

String representing the log entry.

Implements

IFormatter.Format

See Also

StandardFormatter Class | Aspose.Email.Logging Namespace | StandardFormatter.Format Overload List


Aspose.Email.Mail

Aspose.Email

Aspose.Email.Mail Namespace

Namespace hierarchy

Classes

Class | Description
AlternateView | Represents the format to view a message.
AlternateViewCollection | Represents a collection of AlternateView objects.
Appointment | Represents a calendar to an e-mail.
AppointmentFormattingOptions | Represents the appointment formatting options.
AppointmentReminder | Provides a grouping of component properties that define an alarm.
AppointmentReminderCollection | Contains collection of AppointmentReminder AppointmentReminderobjects.
AppointmentSaveOptions | Represents base appointment save options
Attachment | Represents an e-mail attachment.
AttachmentBase | Base class for mail attachment.
AttachmentCollection | Represents a collection of e-mail message attachments.
EmlValidationError | Represents the eml validation error information.
EmlValidationErrorCollection | Represents the collection of EmlValidationError
HeaderType | Represents the Internet standards and RFCs define header fields which may occur on Internet Mail Messages .
IcsSaveOptions | Represents iCalendar save options
LinkedResource | Represents an embedded resource in a message.
LinkedResourceCollection | Represents a collection of LinkedResource objects
MailAddress | Represents the address of a message.
MailAddressCollection | Represents a collection of MailAddress objects.
MailboxConverter | Provides mailbox conversion routines.
MailException | Represents the exception that is thrown when the mail message processing.
MailMessage | Represents an e-mail message. It allows to access message properties, ex. subject, body, sender and recipients addreses, etc. Also it can be sent and delivered by means of supported mail protocols.
MailMessageCollection | Represents a collection of MailMessage objects.
MailMessageLoadOptions | This class allows the user to specify additional options when loading a message.
MailMessageSaveType | Represents the mail message format.It can be in eml,msg or mhtml format.
MesageLoadOptions | Obsolete. This class allows the user to specify additional options when loading a message.
MessageFormat | Represents the mail message format.It can be in eml,msg or mhtml format.
MhtMessageFormatter | Provides a default formatter for Mht conversion.
ReminderAttachment | Provides the capability to associate a document object with an alarm.
ReminderAttachmentCollection | Contains collection of ReminderAttachment ReminderAttachmentobjects.
ReminderAttendee | Defines an "Attendee" within a alarm.
ReminderAttendeeCollection | Contains collection of ReminderAttendee ReminderAttendeeobjects.
ReminderDuration | Used to identify properties that contain a duration of time.
ReminderTrigger | Specifies when an alarm will trigger.
SmtpAuthentication | Represents the SMTP authentication supported by the SMTP server.
SmtpClient | Allows applications to send messages by using the Simple Mail Transfer Protocol (SMTP).
SmtpClientBulkSendAgent | Represents a multi-threading agent for E-mail delivery using SmtpClient.
SmtpClientBulkSendEventArgs | Provides data for the MessageSending and MessageSent events.
SmtpException | Represents the exception that is thrown when the SmtpClient is not able to complete an operation.
SmtpFailedBulkSendException | Represents the exception thrown in bulk sending email message.
SmtpFailedRecipientException | Represents the exception which arises when the specified recipient is wrong
SmtpFailedRecipientsException | Summary description for SmtpFailedRecipientsException.
Task | Represents the exchange task information.
TemplateEngine | This class uses specified template to construct E-Mail messages.

Interfaces

Interface | Description
IAttachment | Represents a common attachment interface
IMailAddress | Represents a common mail address interface
IMailTransferAgent | Provides the base interface for mail transfer agents.
IMessage | Represents a common message interface
IMessageFormatter | Provides a mechanism for retrieving an object to Message formatting.

Delegates

Delegate | Description
MessageAcceptanceCallback | Callback function which is being called during the conversion process.
SendCompletedEventHandler | Delegate is used for asynchronous mail sending
TemplateRoutine | Represents the routine used in the template file.

Enumerations

Enumeration | Description
AppointmentAction | Enumerates appointments methods
AppointmentFlags | Enumerates appointment flags.
AppointmentMethodType | Defines the iCalendar object method type associated with the calendar object.
AppointmentSaveFormat | Enumerates AppointmentSaveFormat
AppointmentStatus | Defines the overall status or confirmation for the appointment.
AppointmentTransparency | Specifies whether or not this appointment is intended to be visible in availability searches.
DeliveryNotificationOptions | Specifies delivery notifications.
EmlValidationErrorType | Enumerates the types of the eml validation errors.
FileCompatibilityMode | Defines inner conversions, that are necessarily to be done when loading or saving a message. By default CR is not replaces by CRLF, Tnef-attachment is not saved.
MailMessageSaveOptions | Enumerates the MailMessage save options
MailPriority | Represents the mail priopity
MailSensitivity | Specifies the sensitivity of a MailMessage.
MhtFormatOptions | Enumerates the Mht format options
MSBusyStatus | Specifies the BUSY status of an appointment.
MSIntendedStatus | Specifies the INTENDED status of an appointment.
ReminderAction | Defines the action to be invoked when an alarm is triggered.
ReminderRelated | Specify the relationship of the alarm trigger with respect to the start or end of the event.
SmtpDeliveryMethod | Smtp delivery method
SmtpSslSecurityMode | Ssl security mode for smtp client
SmtpStatusCode | Smtp status codes
TIPMethod | Defines the iTIP (iCalendar Transport-Independent Interoperability Protocol) methods associated with an object.


AlternateView Class

Represents the format to view a message.

For a list of all members of this type, see AlternateView Members.

System.Object
Aspose.Email.Mail.AttachmentBase
Aspose.Email.Mail.AlternateView

public class AlternateView : AttachmentBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AlternateView Members | Aspose.Email.Mail Namespace


AlternateView Members

AlternateView overview

Public Static Methods

CreateAlternateViewFromString Overloaded. Creates a AlternateView of using the content specified in a string.

Public Instance Constructors

AlternateView Overloaded. Initializes a new instance of the AlternateView class.

Public Instance Properties

BaseUri | Gets or sets the base URI.
ContentId (inherited from AttachmentBase) | Gets or sets the content id.
ContentStream (inherited from AttachmentBase) | Gets or sets the content stream.
ContentType (inherited from AttachmentBase) | Gets or sets the type of the content.
LinkedResources | Gets the set of embedded resources referred to by this alternate view.
TransferEncoding (inherited from AttachmentBase) | Gets or sets the transfer encoding.

Public Instance Methods

Dispose (inherited from AttachmentBase) | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save (inherited from AttachmentBase) | Overloaded. Saves the specified stream.
SaveRawContent (inherited from AttachmentBase) | Obsolete. Saves the content of the raw.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Dispose | Overloaded. Releases unmanaged and - optionally - managed resources.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetContentFromString (inherited from AttachmentBase) |

See Also

AlternateView Class | Aspose.Email.Mail Namespace


AlternateView Constructor

Initializes a new instance of the AlternateView class.

Overload List

Initializes a new instance of the AlternateView class.

public AlternateView(Stream);

Initializes a new instance of the AlternateView class.

public AlternateView(Stream,ContentType);

Initializes a new instance of the AlternateView class.

public AlternateView(Stream,string);

Initializes a new instance of the AlternateView class.

public AlternateView(string);

Initializes a new instance of the AlternateView class.

public AlternateView(string,ContentType);

Initializes a new instance of the AlternateView class.

public AlternateView(string,string);

See Also

AlternateView Class | Aspose.Email.Mail Namespace


AlternateView Constructor (String)

Initializes a new instance of the AlternateView class.

public AlternateView(
string fileName
);

Parameters

fileName
Name of the file.

See Also

AlternateView Class | Aspose.Email.Mail Namespace | AlternateView Constructor Overload List


AlternateView Constructor (String, String)

Initializes a new instance of the AlternateView class.

public AlternateView(
string fileName,
string mediaType
);

Parameters

fileName
Name of the file.
mediaType
Internet media type.

See Also

AlternateView Class | Aspose.Email.Mail Namespace | AlternateView Constructor Overload List


AlternateView Constructor (String, ContentType)

Initializes a new instance of the AlternateView class.

public AlternateView(
string fileName,
ContentType contentType
);

Parameters

fileName
Name of the file.
contentType
Content type.

See Also

AlternateView Class | Aspose.Email.Mail Namespace | AlternateView Constructor Overload List


AlternateView Constructor (Stream)

Initializes a new instance of the AlternateView class.

public AlternateView(
Stream contentStream
);

Parameters

contentStream
The content stream.

See Also

AlternateView Class | Aspose.Email.Mail Namespace | AlternateView Constructor Overload List


AlternateView Constructor (Stream, String)

Initializes a new instance of the AlternateView class.

public AlternateView(
Stream contentStream,
string mediaType
);

Parameters

contentStream
The content stream.
mediaType
Internet media type.

See Also

AlternateView Class | Aspose.Email.Mail Namespace | AlternateView Constructor Overload List


AlternateView Constructor (Stream, ContentType)

Initializes a new instance of the AlternateView class.

public AlternateView(
Stream contentStream,
ContentType contentType
);

Parameters

contentStream
The content stream.
contentType
Content type.

See Also

AlternateView Class | Aspose.Email.Mail Namespace | AlternateView Constructor Overload List


AlternateView Properties

The properties of the AlternateView class are listed below. For a complete list of AlternateView class members, see the AlternateView Members topic.

Public Instance Properties

BaseUri | Gets or sets the base URI.
ContentId (inherited from AttachmentBase) | Gets or sets the content id.
ContentStream (inherited from AttachmentBase) | Gets or sets the content stream.
ContentType (inherited from AttachmentBase) | Gets or sets the type of the content.
LinkedResources | Gets the set of embedded resources referred to by this alternate view.
TransferEncoding (inherited from AttachmentBase) | Gets or sets the transfer encoding.

See Also

AlternateView Class | Aspose.Email.Mail Namespace


BaseUri Property

Aspose.Email

AlternateView.BaseUri Property

Gets or sets the base URI.

public Uri BaseUri {get; set;}

Property Value

The base URI.

See Also

AlternateView Class | Aspose.Email.Mail Namespace


LinkedResources Property

Aspose.Email

AlternateView.LinkedResources Property

Gets the set of embedded resources referred to by this alternate view.

public LinkedResourceCollection LinkedResources {get;}

Property Value

The linked resources.

See Also

AlternateView Class | Aspose.Email.Mail Namespace


AlternateView Methods

The methods of the AlternateView class are listed below. For a complete list of AlternateView class members, see the AlternateView Members topic.

Public Static Methods

CreateAlternateViewFromString Overloaded. Creates a AlternateView of using the content specified in a string.

Public Instance Methods

Dispose (inherited from AttachmentBase) | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save (inherited from AttachmentBase) | Overloaded. Saves the specified stream.
SaveRawContent (inherited from AttachmentBase) | Obsolete. Saves the content of the raw.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Dispose | Overloaded. Releases unmanaged and - optionally - managed resources.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetContentFromString (inherited from AttachmentBase) |

See Also

AlternateView Class | Aspose.Email.Mail Namespace


CreateAlternateViewFromString Method

Aspose.Email

AlternateView.CreateAlternateViewFromString Method

Creates a AlternateView of using the content specified in a string.

Overload List

Creates a AlternateView of using the content specified in a string.

public static AlternateView CreateAlternateViewFromString(string);

Creates a AlternateView of using the content specified in a string.

public static AlternateView CreateAlternateViewFromString(string,ContentType);

Creates a AlternateView of using the content specified in a string.

public static AlternateView CreateAlternateViewFromString(string,ContentType,TransferEncoding);

Creates a AlternateView of using the content specified in a string.

public static AlternateView CreateAlternateViewFromString(string,Encoding,string);

See Also

AlternateView Class | Aspose.Email.Mail Namespace


AlternateView.CreateAlternateViewFromString Method (String)

Creates a AlternateView of using the content specified in a string.

public static AlternateView CreateAlternateViewFromString(
string content
);

Parameters

content
The string that contains the content.

Return Value

An AlternateView object that represents an alternate view.

See Also

AlternateView Class | Aspose.Email.Mail Namespace | AlternateView.CreateAlternateViewFromString Overload List


AlternateView.CreateAlternateViewFromString Method (String, ContentType)

Creates a AlternateView of using the content specified in a string.

public static AlternateView CreateAlternateViewFromString(
string content,
ContentType contentType
);

Parameters

content
The string that contains the content.
contentType
Content type.

Return Value

An AlternateView object that represents an alternate view.

See Also

AlternateView Class | Aspose.Email.Mail Namespace | AlternateView.CreateAlternateViewFromString Overload List


AlternateView.CreateAlternateViewFromString Method (String, ContentType, TransferEncoding)

Creates a AlternateView of using the content specified in a string.

public static AlternateView CreateAlternateViewFromString(
string content,
ContentType contentType,
TransferEncoding transferencoding
);

Parameters

content
The string that contains the content.
contentType
Content type.
transferencoding
The transfer encoding.

Return Value

An AlternateView object that represents an alternate view.

See Also

AlternateView Class | Aspose.Email.Mail Namespace | AlternateView.CreateAlternateViewFromString Overload List


AlternateView.CreateAlternateViewFromString Method (String, Encoding, String)

Creates a AlternateView of using the content specified in a string.

public static AlternateView CreateAlternateViewFromString(
string content,
Encoding contentEncoding,
string mediaType
);

Parameters

content
The string that contains the content.
contentEncoding
The content encoding.
mediaType
Internet media type.

Return Value

An AlternateView object that represents an alternate view.

See Also

AlternateView Class | Aspose.Email.Mail Namespace | AlternateView.CreateAlternateViewFromString Overload List


Dispose Method

Aspose.Email

AlternateView.Dispose Method

Releases unmanaged and - optionally - managed resources.

Overload List

Inherited from AttachmentBase.

public void Dispose();

Releases unmanaged and - optionally - managed resources.

protected override void Dispose(bool);

See Also

AlternateView Class | Aspose.Email.Mail Namespace


AlternateView.Dispose Method (Boolean)

Releases unmanaged and - optionally - managed resources.

protected override void Dispose(
bool disposing
);

Parameters

disposing
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

AlternateView Class | Aspose.Email.Mail Namespace | AlternateView.Dispose Overload List


AlternateViewCollection Class

Represents a collection of AlternateView objects.

For a list of all members of this type, see AlternateViewCollection Members.

System.Object
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Mail.AlternateView, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]]
Aspose.Email.Mail.AlternateViewCollection

public sealed class AlternateViewCollection : Collection`1, IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AlternateViewCollection Members | Aspose.Email.Mail Namespace


AlternateViewCollection Members

AlternateViewCollection overview

Public Instance Properties

Count (inherited from 0, Culture=neutral, PublicKeyToken=null]])
Item (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

AlternateViewCollection Class | Aspose.Email.Mail Namespace


AlternateViewCollection Methods

The methods of the AlternateViewCollection class are listed below. For a complete list of AlternateViewCollection class members, see the AlternateViewCollection Members topic.

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

AlternateViewCollection Class | Aspose.Email.Mail Namespace


AlternateViewCollection.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

public void Dispose();

Implements

IDisposable.Dispose

See Also

AlternateViewCollection Class | Aspose.Email.Mail Namespace


Appointment Class

Represents a calendar to an e-mail.

For a list of all members of this type, see Appointment Members.

System.Object
Aspose.Email.Mail.Appointment

public class Appointment

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

This example demonstrates how to add a calendar to an E-Mail message.

[C#]

[Visual Basic]

Requirements
Namespace:  Aspose.Email.Mail
Assembly: Aspose.Email (in Aspose.Email.dll)

See Also
Appointment Members | Aspose.Email.Mail Namespace


Appointment Members

Appointment overview

Public Static Methods

Load Overloaded. Loads Appointment from the file. Supported file formats: iCalendar

Public Instance Constructors

Appointment Overloaded. Initializes a new instance of the Appointment class.

Public Instance Properties

Attachments | Gets the collection of attachments of appointment.
Attendees | Gets or sets the attendees.
Description | Gets or sets the description.
EndDate | Gets or sets the end date.
EndTimeZone | End time zone
Flags | Gets or sets appointment flags.
Location | Gets or sets the location.
Method | Gets or sets the iCalendar object method type associated with the calendar object.
MicrosoftBusyStatus | Specifies the BUSY status of an appointment.
MicrosoftIntendedStatus | Specifies the INTENDED status of an appointment.
OptionalAttendees | Gets the optional attendees.
Organizer | Gets or sets the organizer.
RecurrencePattern | Gets or sets the recurrence pattern.
Reminders | Contains collection of AppointmentReminder AppointmentReminder objects.
SequenceId | Gets the sequence id.
StartDate | Gets or sets the start date.
StartTimeZone | Start time zone
Status | Gets or sets the overall status or confirmation for the object.
Summary | Gets or sets the summary.
Transparency | Specifies whether or not this appointment is intended to be visible in availability searches.
UniqueId | Gets or sets the unique id.

Public Instance Methods

CancelAppointment | Overloaded. Cancels the appointment.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAppointmentHtml | Gets the calendar HTML.
GetAppointmentText | Overloaded. Gets the calendar text.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RequestApointment | Overloaded. Requests the apointment.
ResetTimeZone | Set local time zone
Save | Overloaded. Saves appointment to the file with iCalendar format using te default save options
SetTimeZone | Set time zone
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateAppointment | Overloaded. Updates the appointment.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Appointment Class | Aspose.Email.Mail Namespace


Appointment Constructor

Initialize a new instance of the Appointment class.

Overload List

Initialize a new instance of the Appointment class.

public Appointment(string,DateTime,DateTime,MailAddress,MailAddressCollection);

Initialize a new instance of the Appointment class.

public Appointment(string,string,string,DateTime,DateTime,MailAddress,MailAddressCollection);

Initialize a new instance of the Appointment class.

public Appointment(string,string,string,DateTime,DateTime,MailAddress,MailAddressCollection,RecurrencePattern);

Initialize a new instance of the Appointment class.

public Appointment(string,string,string,DateTime,DateTime,MailAddress,MailAddressCollection,string);

Initialize a new instance of the Appointment class.

public Appointment(string,string,string,DateTime,DateTime,MailAddress,MailAddressCollection,string,RecurrencePattern);

See Also

Appointment Class | Aspose.Email.Mail Namespace


Appointment Constructor (String, DateTime, DateTime, MailAddress, MailAddressCollection)

Initialize a new instance of the Appointment class.

public Appointment(
string location,
DateTime startDate,
DateTime endDate,
MailAddress organizer,
MailAddressCollection attendees
);

Parameters

location
The location of the calendar event.
startDate
The start time of the calendar event.
endDate
The end time of the calendar event.
organizer
The organizer of the calendar event.
attendees
The attendees of th calendar event.

See Also

Appointment Class | Aspose.Email.Mail Namespace | Appointment Constructor Overload List


Appointment Constructor (String, String, String, DateTime, DateTime, MailAddress, MailAddressCollection)

Initialize a new instance of the Appointment class.

public Appointment(
string location,
string summary,
string description,
DateTime startDate,
DateTime endDate,
MailAddress organizer,
MailAddressCollection attendees
);

Parameters

location
The location of the calendar event.
summary
The summary of the calendar event.
description
The description of the calendar event.
startDate
The start time of the calendar event.
endDate
The end time of the calendar event.
organizer
The organizer of the calendar event.
attendees
The attendees of th calendar event.

See Also

Appointment Class | Aspose.Email.Mail Namespace | Appointment Constructor Overload List


Appointment Constructor (String, String, String, DateTime, DateTime, MailAddress, MailAddressCollection, String)

Initialize a new instance of the Appointment class.

public Appointment(
string location,
string summary,
string description,
DateTime startDate,
DateTime endDate,
MailAddress organizer,
MailAddressCollection attendees,
string uid
);

Parameters

location
The location of the calendar event.
summary
The summary of the calendar event.
description
The description of the calendar event.
startDate
The start time of the calendar event.
endDate
The end time of the calendar event.
organizer
The organizer of the calendar event.
attendees
The attendees of th calendar event.
uid
The unique identifier of th calendar event.

See Also

Appointment Class | Aspose.Email.Mail Namespace | Appointment Constructor Overload List


Appointment Constructor (String, String, String, DateTime, DateTime, MailAddress, MailAddressCollection, RecurrencePattern)

Initialize a new instance of the Appointment class.

public Appointment(
string location,
string summary,
string description,
DateTime startDate,
DateTime endDate,
MailAddress organizer,
MailAddressCollection attendees,
RecurrencePattern recurrencePattern
);

Parameters

location
The location of the calendar event.
summary
The summary of the calendar event.
description
The description of the calendar event.
startDate
The start time of the calendar event.
endDate
The end time of the calendar event.
organizer
The organizer of the calendar event.
attendees
The attendees of th calendar event.
recurrencePattern
The recurrence pattern.

See Also

Appointment Class | Aspose.Email.Mail Namespace | Appointment Constructor Overload List


Appointment Constructor (String, String, String, DateTime, DateTime, MailAddress, MailAddressCollection, String, RecurrencePattern)

Initialize a new instance of the Appointment class.

public Appointment(
string location,
string summary,
string description,
DateTime startDate,
DateTime endDate,
MailAddress organizer,
MailAddressCollection attendees,
string uid,
RecurrencePattern recurrencePattern
);

Parameters

location
The location of the calendar event.
summary
The summary of the calendar event.
description
The description of the calendar event.
startDate
The start time of the calendar event.
endDate
The end time of the calendar event.
organizer
The organizer of the calendar event.
attendees
The attendees of th calendar event.
uid
The unique identifier of th calendar event.
recurrencePattern
The recurrence pattern.

See Also

Appointment Class | Aspose.Email.Mail Namespace | Appointment Constructor Overload List


Appointment Properties

The properties of the Appointment class are listed below. For a complete list of Appointment class members, see the Appointment Members topic.

Public Instance Properties

Attachments | Gets the collection of attachments of appointment.
Attendees | Gets or sets the attendees.
Description | Gets or sets the description.
EndDate | Gets or sets the end date.
EndTimeZone | End time zone
Flags | Gets or sets appointment flags.
Location | Gets or sets the location.
Method | Gets or sets the iCalendar object method type associated with the calendar object.
MicrosoftBusyStatus | Specifies the BUSY status of an appointment.
MicrosoftIntendedStatus | Specifies the INTENDED status of an appointment.
OptionalAttendees | Gets the optional attendees.
Organizer | Gets or sets the organizer.
RecurrencePattern | Gets or sets the recurrence pattern.
Reminders | Contains collection of AppointmentReminder AppointmentReminder objects.
SequenceId | Gets the sequence id.
StartDate | Gets or sets the start date.
StartTimeZone | Start time zone
Status | Gets or sets the overall status or confirmation for the object.
Summary | Gets or sets the summary.
Transparency | Specifies whether or not this appointment is intended to be visible in availability searches.
UniqueId | Gets or sets the unique id.

See Also

Appointment Class | Aspose.Email.Mail Namespace


Attachments Property

Aspose.Email

Appointment.Attachments Property

Gets the collection of attachments of appointment.

public AttachmentCollection Attachments {get;}

See Also

Appointment Class | Aspose.Email.Mail Namespace


Attendees Property

Aspose.Email

Appointment.Attendees Property

Gets or sets the attendees.

public MailAddressCollection Attendees {get; set;}

See Also

Appointment Class | Aspose.Email.Mail Namespace


Description Property

Aspose.Email

Appointment.Description Property

Gets or sets the description.

public string Description {get; set;}

See Also

Appointment Class | Aspose.Email.Mail Namespace


EndDate Property

Aspose.Email

Appointment.EndDate Property

Gets or sets the end date.

public DateTime EndDate {get; set;}

See Also

Appointment Class | Aspose.Email.Mail Namespace


EndTimeZone Property

Aspose.Email

Appointment.EndTimeZone Property

End time zone

public string EndTimeZone {get; set;}

See Also

Appointment Class | Aspose.Email.Mail Namespace


Flags Property

Aspose.Email

Appointment.Flags Property

Gets or sets appointment flags.

public AppointmentFlags Flags {get; set;}

See Also

Appointment Class | Aspose.Email.Mail Namespace


Location Property

Aspose.Email

Appointment.Location Property

Gets or sets the location.

public string Location {get; set;}

See Also

Appointment Class | Aspose.Email.Mail Namespace


Method Property

Aspose.Email

Appointment.Method Property

Gets or sets the iCalendar object method type associated with the calendar object.

public AppointmentMethodType Method {get; set;}

See Also

Appointment Class | Aspose.Email.Mail Namespace


MicrosoftBusyStatus Property

Aspose.Email

Appointment.MicrosoftBusyStatus Property

Specifies the BUSY status of an appointment.

public MSBusyStatus MicrosoftBusyStatus {get; set;}

See Also

Appointment Class | Aspose.Email.Mail Namespace


MicrosoftIntendedStatus Property

Aspose.Email

Appointment.MicrosoftIntendedStatus Property

Specifies the INTENDED status of an appointment.

public MSIntendedStatus MicrosoftIntendedStatus {get; set;}

See Also

Appointment Class | Aspose.Email.Mail Namespace


OptionalAttendees Property

Aspose.Email

Appointment.OptionalAttendees Property

Gets the optional attendees.

public MailAddressCollection OptionalAttendees {get;}

Property Value

The address collection of optional attendees.

See Also

Appointment Class | Aspose.Email.Mail Namespace


Organizer Property

Aspose.Email

Appointment.Organizer Property

Gets or sets the organizer.

public MailAddress Organizer {get; set;}

See Also

Appointment Class | Aspose.Email.Mail Namespace


RecurrencePattern Property

Aspose.Email

Appointment.RecurrencePattern Property

Gets or sets the recurrence pattern.

public RecurrencePattern RecurrencePattern {get; set;}

Property Value

The recurrence pattern.

See Also

Appointment Class | Aspose.Email.Mail Namespace


Reminders Property

Aspose.Email

Appointment.Reminders Property

Contains collection of AppointmentReminder AppointmentReminder objects.

public AppointmentReminderCollection Reminders {get;}

See Also

Appointment Class | Aspose.Email.Mail Namespace


SequenceId Property

Aspose.Email

Appointment.SequenceId Property

Gets the sequence id.

public string SequenceId {get; set;}

Property Value

The sequence id.

See Also

Appointment Class | Aspose.Email.Mail Namespace


StartDate Property

Aspose.Email

Appointment.StartDate Property

Gets or sets the start date.

public DateTime StartDate {get; set;}

See Also

Appointment Class | Aspose.Email.Mail Namespace


StartTimeZone Property

Aspose.Email

Appointment.StartTimeZone Property

Start time zone

public string StartTimeZone {get; set;}

See Also

Appointment Class | Aspose.Email.Mail Namespace


Status Property

Aspose.Email

Appointment.Status Property

Gets or sets the overall status or confirmation for the object.

public AppointmentStatus Status {get; set;}

See Also

Appointment Class | Aspose.Email.Mail Namespace


Summary Property

Aspose.Email

Appointment.Summary Property

Gets or sets the summary.

public string Summary {get; set;}

See Also

Appointment Class | Aspose.Email.Mail Namespace


Transparency Property

Aspose.Email

Appointment.Transparency Property

Specifies whether or not this appointment is intended to be visible in availability searches.

public AppointmentTransparency Transparency {get; set;}

See Also

Appointment Class | Aspose.Email.Mail Namespace


UniqueId Property

Aspose.Email

Appointment.UniqueId Property

Gets or sets the unique id.

public string UniqueId {get; set;}

Property Value

The unique id.

See Also

Appointment Class | Aspose.Email.Mail Namespace


Appointment Methods

The methods of the Appointment class are listed below. For a complete list of Appointment class members, see the Appointment Members topic.

Public Static Methods

Load Overloaded. Loads Appointment from the file. Supported file formats: iCalendar

Public Instance Methods

CancelAppointment | Overloaded. Cancels the appointment.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAppointmentHtml | Gets the calendar HTML.
GetAppointmentText | Overloaded. Gets the calendar text.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RequestApointment | Overloaded. Requests the apointment.
ResetTimeZone | Set local time zone
Save | Overloaded. Saves appointment to the file with iCalendar format using te default save options
SetTimeZone | Set time zone
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateAppointment | Overloaded. Updates the appointment.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Appointment Class | Aspose.Email.Mail Namespace


CancelAppointment Method

Aspose.Email

Appointment.CancelAppointment Method

Cancels the appointment.

Overload List

Cancels the appointment.

public AlternateView CancelAppointment();

Cancels the appointment.

public AlternateView CancelAppointment(int);

See Also

Appointment Class | Aspose.Email.Mail Namespace


Appointment.CancelAppointment Method ()

Cancels the appointment.

public AlternateView CancelAppointment();

Return Value

AlternateViewAlternateView that represents the format to view an email message.

See Also

Appointment Class | Aspose.Email.Mail Namespace | Appointment.CancelAppointment Overload List


Appointment.CancelAppointment Method (Int32)

Cancels the appointment.

public AlternateView CancelAppointment(
int sequenceId
);

Parameters

sequenceId
The sequence id.

Return Value

AlternateViewAlternateView that represents the format to view an email message.

See Also

Appointment Class | Aspose.Email.Mail Namespace | Appointment.CancelAppointment Overload List


Appointment.GetAppointmentHtml Method

Gets the calendar HTML.

public string GetAppointmentHtml();

Return Value

String value of calendar as HTML.

See Also

Appointment Class | Aspose.Email.Mail Namespace


GetAppointmentText Method

Aspose.Email

Appointment.GetAppointmentText Method

Gets the calendar text.

Overload List

Gets the calendar text.

public string GetAppointmentText();

Gets the calendar text.

public string GetAppointmentText(AppointmentFormattingOptions);

See Also

Appointment Class | Aspose.Email.Mail Namespace


Appointment.GetAppointmentText Method ()

Gets the calendar text.

public string GetAppointmentText();

Return Value

String value of calendar as plain text.

See Also

Appointment Class | Aspose.Email.Mail Namespace | Appointment.GetAppointmentText Overload List


Appointment.GetAppointmentText Method (AppointmentFormattingOptions)

Gets the calendar text.

public string GetAppointmentText(
AppointmentFormattingOptions formattingOptions
);

Parameters

formattingOptions
AppointmentFormattingOptions that represents appointment formatting options.

Return Value

The text representation of appointment.

Exceptions

Exception Type | Condition
ArgumentNullException | throws when formattingOptions is null.

See Also

Appointment Class | Aspose.Email.Mail Namespace | Appointment.GetAppointmentText Overload List


Load Method

Aspose.Email

Appointment.Load Method

Loads Appointment from the stream

Overload List

Loads Appointment from the stream

public static Appointment Load(Stream);

Loads Appointment from the stream

public static Appointment Load(Stream,bool);

Loads Appointment from the file. Supported file formats: iCalendar

public static Appointment Load(string);

See Also

Appointment Class | Aspose.Email.Mail Namespace


Appointment.Load Method (Stream)

Loads Appointment from the stream

public static Appointment Load(
Stream stream
);

Parameters

stream
A stream to load from

Return Value

A read Appointment

Exceptions

Exception Type | Condition
ArgumentNullException | stream is null
NotSupportedException | stream does not support reading

See Also

Appointment Class | Aspose.Email.Mail Namespace | Appointment.Load Overload List


Appointment.Load Method (Stream, Boolean)

Loads Appointment from the stream

public static Appointment Load(
Stream stream,
bool applyLocalTZ
);

Parameters

stream
A stream to load from
applyLocalTZ
Convert time to local timezone

Return Value

A read Appointment

Exceptions

Exception Type | Condition
ArgumentNullException | stream is null
NotSupportedException | stream does not support reading

See Also

Appointment Class | Aspose.Email.Mail Namespace | Appointment.Load Overload List


Appointment.Load Method (String)

Loads Appointment from the file. Supported file formats: iCalendar

public static Appointment Load(
string filePath
);

Parameters

filePath
A file path

Return Value

A read Appointment

Exceptions

Exception Type | Condition
ArgumentException | filePath is null or empty

See Also

Appointment Class | Aspose.Email.Mail Namespace | Appointment.Load Overload List


RequestApointment Method

Aspose.Email

Appointment.RequestApointment Method

Requests the apointment.

Overload List

Requests the apointment.

public AlternateView RequestApointment();

Requests the apointment.

public AlternateView RequestApointment(int);

See Also

Appointment Class | Aspose.Email.Mail Namespace


Appointment.RequestApointment Method ()

Requests the apointment.

public AlternateView RequestApointment();

Return Value

AlternateViewAlternateView that represents the format to view an email message.

See Also

Appointment Class | Aspose.Email.Mail Namespace | Appointment.RequestApointment Overload List


Appointment.RequestApointment Method (Int32)

Requests the apointment.

public AlternateView RequestApointment(
int sequenceId
);

Parameters

sequenceId
The sequence id.

Return Value

AlternateViewAlternateView that represents the format to view an email message.

See Also

Appointment Class | Aspose.Email.Mail Namespace | Appointment.RequestApointment Overload List


Appointment.ResetTimeZone Method

Set local time zone

public void ResetTimeZone();

See Also

Appointment Class | Aspose.Email.Mail Namespace


Save Method

Aspose.Email

Appointment.Save Method

Saves appointment to the file with iCalendar format using te default save options

Overload List

Saves appointment to the file with iCalendar format using te default save options

public void Save(Stream);

Saves appointment to the stream with specified format using te default save options

public void Save(Stream,AppointmentSaveFormat);

Saves appointment to the stream with specified save options

public void Save(Stream,AppointmentSaveOptions);

Saves appointment to the file with iCalendar format using te default save options

public void Save(string);

Saves appointment to the file with specified format using te default save options

public void Save(string,AppointmentSaveFormat);

Saves appointment to the file with specified save options

public void Save(string,AppointmentSaveOptions);

See Also

Appointment Class | Aspose.Email.Mail Namespace


Appointment.Save Method (Stream)

Saves appointment to the file with iCalendar format using te default save options

public void Save(
Stream stream
);

Parameters

stream
A stream to save to

Exceptions

Exception Type | Condition
ArgumentNullException | stream is null
NotSupportedException | stream does not support writing

See Also

Appointment Class | Aspose.Email.Mail Namespace | Appointment.Save Overload List


Appointment.Save Method (Stream, AppointmentSaveFormat)

Saves appointment to the stream with specified format using te default save options

public void Save(
Stream stream,
AppointmentSaveFormat saveFormat
);

Parameters

stream
A stream to save to
saveFormat
A save format

Exceptions

Exception Type | Condition
ArgumentNullException | stream is null
NotSupportedException | The specified save options are not supported
NotSupportedException | stream does not support writing

See Also

Appointment Class | Aspose.Email.Mail Namespace | Appointment.Save Overload List


Appointment.Save Method (Stream, AppointmentSaveOptions)

Saves appointment to the stream with specified save options

public void Save(
Stream stream,
AppointmentSaveOptions saveOptions
);

Parameters

stream
A stream to save to
saveOptions
A save options

Exceptions

Exception Type | Condition
ArgumentNullException | saveOptions or stream is null
NotSupportedException | the specified save options are not supported
NotSupportedException | stream does not support writing

See Also

Appointment Class | Aspose.Email.Mail Namespace | Appointment.Save Overload List


Appointment.Save Method (String)

Saves appointment to the file with iCalendar format using te default save options

public void Save(
string filePath
);

Parameters

filePath
A file path

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | filePath is null or empty

See Also

Appointment Class | Aspose.Email.Mail Namespace | Appointment.Save Overload List


Appointment.Save Method (String, AppointmentSaveFormat)

Saves appointment to the file with specified format using te default save options

public void Save(
string filePath,
AppointmentSaveFormat saveFormat
);

Parameters

filePath
A file path
saveFormat
A save format

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | filePath is null or empty
NotSupportedException | The specified save options are not supported

See Also

Appointment Class | Aspose.Email.Mail Namespace | Appointment.Save Overload List


Appointment.Save Method (String, AppointmentSaveOptions)

Saves appointment to the file with specified save options

public void Save(
string filePath,
AppointmentSaveOptions saveOptions
);

Parameters

filePath
A file path
saveOptions
A save options

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | filePath is null or empty
ArgumentNullException | saveOptions is null
NotSupportedException | The specified save options are not supported

See Also

Appointment Class | Aspose.Email.Mail Namespace | Appointment.Save Overload List


Appointment.SetTimeZone Method

Set time zone

public void SetTimeZone(
string tzName
);

Parameters

tzName
The time zone name, for sample "America/New_York"

See Also

Appointment Class | Aspose.Email.Mail Namespace


UpdateAppointment Method

Aspose.Email

Appointment.UpdateAppointment Method

Updates the appointment.

Overload List

Updates the appointment.

public AlternateView UpdateAppointment();

Updates the appointment.

public AlternateView UpdateAppointment(int);

See Also

Appointment Class | Aspose.Email.Mail Namespace


Appointment.UpdateAppointment Method ()

Updates the appointment.

public AlternateView UpdateAppointment();

Return Value

AlternateViewAlternateView that represents the format to view an email message.

See Also

Appointment Class | Aspose.Email.Mail Namespace | Appointment.UpdateAppointment Overload List


Appointment.UpdateAppointment Method (Int32)

Updates the appointment.

public AlternateView UpdateAppointment(
int sequenceId
);

Parameters

sequenceId
The sequence id.

Return Value

AlternateViewAlternateView that represents the format to view an email message.

See Also

Appointment Class | Aspose.Email.Mail Namespace | Appointment.UpdateAppointment Overload List


AppointmentAction Enumeration

Enumerates appointments methods

public enum AppointmentAction

Members

Member Name | Description | Value
Create | Create method | 0
Update | Update method | 1
Cancel | Cancel method | 2

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Mail Namespace


AppointmentFlags Enumeration

Enumerates appointment flags.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum AppointmentFlags

Members

Member Name | Description | Value
None | Indicates that no specific flags are set. | 0
AllDayEvent | Indicates that appointment is an all day event. | 1

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Mail Namespace


AppointmentFormattingOptions Class

Represents the appointment formatting options.

For a list of all members of this type, see AppointmentFormattingOptions Members.

System.Object
Aspose.Email.Mail.AppointmentFormattingOptions

public class AppointmentFormattingOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AppointmentFormattingOptions Members | Aspose.Email.Mail Namespace


AppointmentFormattingOptions Members

AppointmentFormattingOptions overview

Public Static Methods

CreateAsHtml Specifies formatting in the html.

Public Instance Constructors

AppointmentFormattingOptions Constructor Initializes a new instance of the AppointmentFormattingOptions class. By default, template will be created in the plain text format.

Public Instance Properties

CssStyles | Gets or sets the additional css styles for the formatter.
DescriptionFormat | Gets or sets the description format.
EndDateFormat | Gets or sets the end date format.
IsTextFormat | Gets a value indicating whether template has a text format.
LocationFormat | Gets or sets the where format.
OrganizerFormat | Gets or sets the organizer format.
StartDateFormat | Gets or sets the start date format.
TimezoneFormat | Gets or sets the timezone format.
TitleFormat | Gets or sets the title format.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AppointmentFormattingOptions Class | Aspose.Email.Mail Namespace


AppointmentFormattingOptions Constructor

Initializes a new instance of the AppointmentFormattingOptions class. By default, template will be created in the plain text format.

public AppointmentFormattingOptions();

See Also

AppointmentFormattingOptions Class | Aspose.Email.Mail Namespace


AppointmentFormattingOptions Properties

The properties of the AppointmentFormattingOptions class are listed below. For a complete list of AppointmentFormattingOptions class members, see the AppointmentFormattingOptions Members topic.

Public Instance Properties

CssStyles | Gets or sets the additional css styles for the formatter.
DescriptionFormat | Gets or sets the description format.
EndDateFormat | Gets or sets the end date format.
IsTextFormat | Gets a value indicating whether template has a text format.
LocationFormat | Gets or sets the where format.
OrganizerFormat | Gets or sets the organizer format.
StartDateFormat | Gets or sets the start date format.
TimezoneFormat | Gets or sets the timezone format.
TitleFormat | Gets or sets the title format.

See Also

AppointmentFormattingOptions Class | Aspose.Email.Mail Namespace


CssStyles Property

Aspose.Email

AppointmentFormattingOptions.CssStyles Property

Gets or sets the additional css styles for the formatter.

public string CssStyles {get; set;}

Property Value

The styles to be injected into resulting html body.

See Also

AppointmentFormattingOptions Class | Aspose.Email.Mail Namespace


DescriptionFormat Property

Aspose.Email

AppointmentFormattingOptions.DescriptionFormat Property

Gets or sets the description format.

public string DescriptionFormat {get; set;}

Property Value

The description format.

See Also

AppointmentFormattingOptions Class | Aspose.Email.Mail Namespace


EndDateFormat Property

Aspose.Email

AppointmentFormattingOptions.EndDateFormat Property

Gets or sets the end date format.

public string EndDateFormat {get; set;}

Property Value

The end date format.

See Also

AppointmentFormattingOptions Class | Aspose.Email.Mail Namespace


IsTextFormat Property

Aspose.Email

AppointmentFormattingOptions.IsTextFormat Property

Gets a value indicating whether template has a text format.

public bool IsTextFormat {get;}

Property Value

true if template has a text format; otherwise, false.

See Also

AppointmentFormattingOptions Class | Aspose.Email.Mail Namespace


LocationFormat Property

Aspose.Email

AppointmentFormattingOptions.LocationFormat Property

Gets or sets the where format.

public string LocationFormat {get; set;}

Property Value

The where format.

See Also

AppointmentFormattingOptions Class | Aspose.Email.Mail Namespace


OrganizerFormat Property

Aspose.Email

AppointmentFormattingOptions.OrganizerFormat Property

Gets or sets the organizer format.

public string OrganizerFormat {get; set;}

Property Value

The organizer format.

See Also

AppointmentFormattingOptions Class | Aspose.Email.Mail Namespace


StartDateFormat Property

Aspose.Email

AppointmentFormattingOptions.StartDateFormat Property

Gets or sets the start date format.

public string StartDateFormat {get; set;}

Property Value

The start date format.

See Also

AppointmentFormattingOptions Class | Aspose.Email.Mail Namespace


TimezoneFormat Property

Aspose.Email

AppointmentFormattingOptions.TimezoneFormat Property

Gets or sets the timezone format.

public string TimezoneFormat {get; set;}

Property Value

The timezone format.

See Also

AppointmentFormattingOptions Class | Aspose.Email.Mail Namespace


TitleFormat Property

Aspose.Email

AppointmentFormattingOptions.TitleFormat Property

Gets or sets the title format.

public string TitleFormat {get; set;}

Property Value

The title format.

See Also

AppointmentFormattingOptions Class | Aspose.Email.Mail Namespace


AppointmentFormattingOptions Methods

The methods of the AppointmentFormattingOptions class are listed below. For a complete list of AppointmentFormattingOptions class members, see the AppointmentFormattingOptions Members topic.

Public Static Methods

CreateAsHtml Specifies formatting in the html.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AppointmentFormattingOptions Class | Aspose.Email.Mail Namespace


AppointmentFormattingOptions.CreateAsHtml Method

Specifies formatting in the html.

public static AppointmentFormattingOptions CreateAsHtml();

Return Value

AppointmentFormattingOptions that represents appointment formatting options.

See Also

AppointmentFormattingOptions Class | Aspose.Email.Mail Namespace


AppointmentMethodType Enumeration

Defines the iCalendar object method type associated with the calendar object.

public enum AppointmentMethodType

Members

Member Name | Description | Value
None | Method is not defined. | 0
Publish | Post notification of an event. Used primarily as a method of advertising the existence of an event. | 1
Request | Make a request for an event. This is an explicit invitation to one or more "Attendees". | 2
Reply | Reply to an event request. | 3
Add | Add one or more instances to an existing event. | 4
Cancel | Cancel one or more instances of an existing event. | 5
Refresh | A request is sent to an "Organizer" by an "Attendee" asking for the latest version of an event to be resent to the requester. | 6
Counter | Counter a REQUEST with an alternative proposal, Sent by an "Attendee" to the "Organizer". | 7
DeclineCounter | Decline a counter proposal. Sent to an "Attendee" by the "Organizer". | 8

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Mail Namespace


AppointmentReminder Class

Provides a grouping of component properties that define an alarm.

For a list of all members of this type, see AppointmentReminder Members.

System.Object
Aspose.Email.Mail.AppointmentReminder

public class AppointmentReminder

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AppointmentReminder Members | Aspose.Email.Mail Namespace


AppointmentReminder Members

AppointmentReminder overview

Public Static Properties

Default15MinReminder Gets the default 15 min reminder.

Public Instance Constructors

AppointmentReminder Constructor Initialize a new instance of AppointmentReminder class.

Public Instance Properties

Action | Defines the action to be invoked when an alarm is triggered.
Attachments | Contains collection of ReminderAttachment ReminderAttachmentobjects.
Attendees | Contains collection of ReminderAttendee ReminderAttendeeobjects.
Description | Provides a more complete description of the alarm.
Duration | Specifies the delay period, after which the alarm will repeat.
Repeat | Defines the number of time the alarm should be repeated, after the initial trigger.
Summary | Defines a short summary or subject for the alarm.
Trigger | Specifies when an alarm will trigger.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AppointmentReminder Class | Aspose.Email.Mail Namespace


AppointmentReminder Constructor

Initialize a new instance of AppointmentReminder class.

public AppointmentReminder();

See Also

AppointmentReminder Class | Aspose.Email.Mail Namespace


AppointmentReminder Properties

The properties of the AppointmentReminder class are listed below. For a complete list of AppointmentReminder class members, see the AppointmentReminder Members topic.

Public Static Properties

Default15MinReminder Gets the default 15 min reminder.

Public Instance Properties

Action | Defines the action to be invoked when an alarm is triggered.
Attachments | Contains collection of ReminderAttachment ReminderAttachmentobjects.
Attendees | Contains collection of ReminderAttendee ReminderAttendeeobjects.
Description | Provides a more complete description of the alarm.
Duration | Specifies the delay period, after which the alarm will repeat.
Repeat | Defines the number of time the alarm should be repeated, after the initial trigger.
Summary | Defines a short summary or subject for the alarm.
Trigger | Specifies when an alarm will trigger.

See Also

AppointmentReminder Class | Aspose.Email.Mail Namespace


Action Property

Aspose.Email

AppointmentReminder.Action Property

Defines the action to be invoked when an alarm is triggered.

public ReminderAction Action {get; set;}

See Also

AppointmentReminder Class | Aspose.Email.Mail Namespace


Attachments Property

Aspose.Email

AppointmentReminder.Attachments Property

Contains collection of ReminderAttachment ReminderAttachmentobjects.

public ReminderAttachmentCollection Attachments {get;}

See Also

AppointmentReminder Class | Aspose.Email.Mail Namespace


Attendees Property

Aspose.Email

AppointmentReminder.Attendees Property

Contains collection of ReminderAttendee ReminderAttendeeobjects.

public ReminderAttendeeCollection Attendees {get;}

See Also

AppointmentReminder Class | Aspose.Email.Mail Namespace


Default15MinReminder Property

Aspose.Email

AppointmentReminder.Default15MinReminder Property

Gets the default 15 min reminder.

public static AppointmentReminder Default15MinReminder {get;}

See Also

AppointmentReminder Class | Aspose.Email.Mail Namespace


Description Property

Aspose.Email

AppointmentReminder.Description Property

Provides a more complete description of the alarm.

public string Description {get; set;}

See Also

AppointmentReminder Class | Aspose.Email.Mail Namespace


Duration Property

Aspose.Email

AppointmentReminder.Duration Property

Specifies the delay period, after which the alarm will repeat.

public ReminderDuration Duration {get; set;}

See Also

AppointmentReminder Class | Aspose.Email.Mail Namespace


Repeat Property

Aspose.Email

AppointmentReminder.Repeat Property

Defines the number of time the alarm should be repeated, after the initial trigger.

public int Repeat {get; set;}

See Also

AppointmentReminder Class | Aspose.Email.Mail Namespace


Summary Property

Aspose.Email

AppointmentReminder.Summary Property

Defines a short summary or subject for the alarm.

public string Summary {get; set;}

See Also

AppointmentReminder Class | Aspose.Email.Mail Namespace


Trigger Property

Aspose.Email

AppointmentReminder.Trigger Property

Specifies when an alarm will trigger.

public ReminderTrigger Trigger {get; set;}

See Also

AppointmentReminder Class | Aspose.Email.Mail Namespace


AppointmentReminderCollection Class

Contains collection of AppointmentReminder AppointmentReminderobjects.

For a list of all members of this type, see AppointmentReminderCollection Members.

System.Object
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Mail.AppointmentReminder, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]]
Aspose.Email.Mail.AppointmentReminderCollection

public class AppointmentReminderCollection : Collection`1

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AppointmentReminderCollection Members | Aspose.Email.Mail Namespace


AppointmentReminderCollection Members

AppointmentReminderCollection overview

Public Instance Constructors

AppointmentReminderCollection Constructor Initializes a new instance of the AppointmentReminderCollection class.

Public Instance Properties

Count (inherited from 0, Culture=neutral, PublicKeyToken=null]])
Item (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Items (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Protected Instance Methods

ClearItems (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
InsertItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RemoveItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
SetItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |

See Also

AppointmentReminderCollection Class | Aspose.Email.Mail Namespace


AppointmentReminderCollection Constructor

Initializes a new instance of the AppointmentReminderCollection class.

public AppointmentReminderCollection();

See Also

AppointmentReminderCollection Class | Aspose.Email.Mail Namespace


AppointmentSaveFormat Enumeration

Enumerates AppointmentSaveFormat

public enum AppointmentSaveFormat

Members

Member Name | Description | Value
Ics | ICalendar format | 0
Msg | MSG format. | 1

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Mail Namespace


AppointmentSaveOptions Class

Represents base appointment save options

For a list of all members of this type, see AppointmentSaveOptions Members.

System.Object
Aspose.Email.Mail.AppointmentSaveOptions
Aspose.Email.Mail.IcsSaveOptions

public abstract class AppointmentSaveOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AppointmentSaveOptions Members | Aspose.Email.Mail Namespace


AppointmentSaveOptions Members

AppointmentSaveOptions overview

Public Instance Properties

SaveFormat Gets a save format

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

AppointmentSaveOptions Constructor

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AppointmentSaveOptions Class | Aspose.Email.Mail Namespace


AppointmentSaveOptions Constructor

protected AppointmentSaveOptions(
AppointmentSaveFormat saveFormat
);

See Also

AppointmentSaveOptions Class | Aspose.Email.Mail Namespace


AppointmentSaveOptions Properties

The properties of the AppointmentSaveOptions class are listed below. For a complete list of AppointmentSaveOptions class members, see the AppointmentSaveOptions Members topic.

Public Instance Properties

SaveFormat Gets a save format

See Also

AppointmentSaveOptions Class | Aspose.Email.Mail Namespace


SaveFormat Property

Aspose.Email

AppointmentSaveOptions.SaveFormat Property

Gets a save format

public AppointmentSaveFormat SaveFormat {get;}

See Also

AppointmentSaveOptions Class | Aspose.Email.Mail Namespace


AppointmentStatus Enumeration

Defines the overall status or confirmation for the appointment.

public enum AppointmentStatus

Members

Member Name | Description | Value
NotDefined | Value is not defined | -1
Cancelled | Indicates journal is removed. or Indicates to-do was cancelled. or Indicates event was cancelled. | 0
Tentative | Indicates event is tentative. | 1
Confirmed | Indicates event is definite. | 2

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Mail Namespace


AppointmentTransparency Enumeration

Specifies whether or not this appointment is intended to be visible in availability searches.

public enum AppointmentTransparency

Members

Member Name | Description | Value
NotDefined | Value is not defined | -1
Transparent | Appointment is transparent | 0
Opaque | Appointment is opaque | 2

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Mail Namespace


Attachment Class

Represents an e-mail attachment.

For a list of all members of this type, see Attachment Members.

System.Object
Aspose.Email.Mail.AttachmentBase
Aspose.Email.Mail.Attachment

public class Attachment : AttachmentBase, IPreferredTextEncodingProvider, IAttachment

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Attachment Members | Aspose.Email.Mail Namespace


Attachment Members

Attachment overview

Public Static Methods

CreateAttachmentFromString Overloaded. Creates the attachment from string.

Public Instance Constructors

Attachment Overloaded. Initializes a new instance of the Attachment class.

Public Instance Properties

ContentDisposition | Gets Content-Disposition header
ContentId (inherited from AttachmentBase) | Gets or sets the content id.
ContentStream (inherited from AttachmentBase) | Gets or sets the content stream.
ContentType (inherited from AttachmentBase) | Gets or sets the type of the content.
Name | Gets or sets an attachment name
NameEncoding | Gets or sets an encoding of attachment name
PreferredTextEncoding | Gets or sets a preferred text encoding
TransferEncoding (inherited from AttachmentBase) | Gets or sets the transfer encoding.

Public Instance Methods

Dispose (inherited from AttachmentBase) | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save (inherited from AttachmentBase) | Overloaded. Saves the specified stream.
SaveRawContent (inherited from AttachmentBase) | Obsolete. Saves the content of the raw.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Dispose (inherited from AttachmentBase) | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetContentFromString (inherited from AttachmentBase) |

See Also

Attachment Class | Aspose.Email.Mail Namespace


Attachment Constructor

Initializes a new instance of the Attachment class.

Overload List

Initializes a new instance of the Attachment class.

public Attachment(Stream,ContentType);

Initializes a new instance of the Attachment class.

public Attachment(Stream,string);

Initializes a new instance of the Attachment class.

public Attachment(Stream,string,string);

Initializes a new instance of the Attachment class.

public Attachment(string);

Initializes a new instance of the Attachment class.

public Attachment(string,ContentType);

Initializes a new instance of the Attachment class.

public Attachment(string,string);

See Also

Attachment Class | Aspose.Email.Mail Namespace


Attachment Constructor (String)

Initializes a new instance of the Attachment class.

public Attachment(
string fileName
);

Parameters

fileName
Name of the file.

See Also

Attachment Class | Aspose.Email.Mail Namespace | Attachment Constructor Overload List


Attachment Constructor (String, String)

Initializes a new instance of the Attachment class.

public Attachment(
string fileName,
string mediaType
);

Parameters

fileName
Name of the file.
mediaType
Type media type name.

See Also

Attachment Class | Aspose.Email.Mail Namespace | Attachment Constructor Overload List


Attachment Constructor (String, ContentType)

Initializes a new instance of the Attachment class.

public Attachment(
string fileName,
ContentType contentType
);

Parameters

fileName
Name of the file.
contentType
The ContentType.

See Also

Attachment Class | Aspose.Email.Mail Namespace | Attachment Constructor Overload List


Attachment Constructor (Stream, String)

Initializes a new instance of the Attachment class.

public Attachment(
Stream contentStream,
string name
);

Parameters

contentStream
The content stream of attachment.
name
The attachment name.

See Also

Attachment Class | Aspose.Email.Mail Namespace | Attachment Constructor Overload List


Attachment Constructor (Stream, String, String)

Initializes a new instance of the Attachment class.

public Attachment(
Stream contentStream,
string name,
string mediaType
);

Parameters

contentStream
The content stream of attachment.
name
The attachment name.
mediaType
The media type name.

See Also

Attachment Class | Aspose.Email.Mail Namespace | Attachment Constructor Overload List


Attachment Constructor (Stream, ContentType)

Initializes a new instance of the Attachment class.

public Attachment(
Stream contentStream,
ContentType contentType
);

Parameters

contentStream
The content stream of attachment.
contentType
The ContentType.

See Also

Attachment Class | Aspose.Email.Mail Namespace | Attachment Constructor Overload List


Attachment Properties

The properties of the Attachment class are listed below. For a complete list of Attachment class members, see the Attachment Members topic.

Public Instance Properties

ContentDisposition | Gets Content-Disposition header
ContentId (inherited from AttachmentBase) | Gets or sets the content id.
ContentStream (inherited from AttachmentBase) | Gets or sets the content stream.
ContentType (inherited from AttachmentBase) | Gets or sets the type of the content.
Name | Gets or sets an attachment name
NameEncoding | Gets or sets an encoding of attachment name
PreferredTextEncoding | Gets or sets a preferred text encoding
TransferEncoding (inherited from AttachmentBase) | Gets or sets the transfer encoding.

See Also

Attachment Class | Aspose.Email.Mail Namespace


ContentDisposition Property

Aspose.Email

Attachment.ContentDisposition Property

Gets Content-Disposition header

public ContentDisposition ContentDisposition {get;}

See Also

Attachment Class | Aspose.Email.Mail Namespace


Name Property

Aspose.Email

Attachment.Name Property

Gets or sets an attachment name

public string Name {get; set;}

Implements

IAttachment.Name

See Also

Attachment Class | Aspose.Email.Mail Namespace


NameEncoding Property

Aspose.Email

Attachment.NameEncoding Property

Gets or sets an encoding of attachment name

public Encoding NameEncoding {get; set;}

See Also

Attachment Class | Aspose.Email.Mail Namespace


PreferredTextEncoding Property

Aspose.Email

Attachment.PreferredTextEncoding Property

Gets or sets a preferred text encoding

public Encoding PreferredTextEncoding {get; set;}

Implements

IPreferredTextEncodingProvider.PreferredTextEncoding

See Also

Attachment Class | Aspose.Email.Mail Namespace


Attachment Methods

The methods of the Attachment class are listed below. For a complete list of Attachment class members, see the Attachment Members topic.

Public Static Methods

CreateAttachmentFromString Overloaded. Creates the attachment from string.

Public Instance Methods

Dispose (inherited from AttachmentBase) | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save (inherited from AttachmentBase) | Overloaded. Saves the specified stream.
SaveRawContent (inherited from AttachmentBase) | Obsolete. Saves the content of the raw.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Dispose (inherited from AttachmentBase) | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetContentFromString (inherited from AttachmentBase) |

See Also

Attachment Class | Aspose.Email.Mail Namespace


CreateAttachmentFromString Method

Aspose.Email

Attachment.CreateAttachmentFromString Method

Creates the attachment from string.

Overload List

Creates the attachment from string.

public static Attachment CreateAttachmentFromString(string,ContentType);

Creates the attachment from string.

public static Attachment CreateAttachmentFromString(string,string);

Creates the attachment from string.

public static Attachment CreateAttachmentFromString(string,string,Encoding,string);

See Also

Attachment Class | Aspose.Email.Mail Namespace


Attachment.CreateAttachmentFromString Method (String, ContentType)

Creates the attachment from string.

public static Attachment CreateAttachmentFromString(
string content,
ContentType contentType
);

Parameters

content
A string that represents the content of attachment.
contentType
The ContentType.

Return Value

Returns created attachment

See Also

Attachment Class | Aspose.Email.Mail Namespace | Attachment.CreateAttachmentFromString Overload List


Attachment.CreateAttachmentFromString Method (String, String)

Creates the attachment from string.

public static Attachment CreateAttachmentFromString(
string content,
string name
);

Parameters

content
A string that represents the content of attachment.
name
The attachment name.

Return Value

Returns created attachment

See Also

Attachment Class | Aspose.Email.Mail Namespace | Attachment.CreateAttachmentFromString Overload List


Attachment.CreateAttachmentFromString Method (String, String, Encoding, String)

Creates the attachment from string.

public static Attachment CreateAttachmentFromString(
string content,
string name,
Encoding contentEncoding,
string mediaType
);

Parameters

content
A string that represents the content of attachment.
name
The attachment name.
contentEncoding
The content encoding.
mediaType
The media type name

Return Value

Returns created attachment

See Also

Attachment Class | Aspose.Email.Mail Namespace | Attachment.CreateAttachmentFromString Overload List


AttachmentBase Class

Base class for mail attachment.

For a list of all members of this type, see AttachmentBase Members.

System.Object
Aspose.Email.Mail.AttachmentBase
Aspose.Email.Mail.AlternateView
Aspose.Email.Mail.Attachment
Aspose.Email.Mail.LinkedResource

public abstract class AttachmentBase : IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AttachmentBase Members | Aspose.Email.Mail Namespace


AttachmentBase Members

AttachmentBase overview

Protected Static Methods

GetEncodingFromContent

Public Instance Properties

ContentId | Gets or sets the content id.
ContentStream | Gets or sets the content stream.
ContentType | Gets or sets the type of the content.
TransferEncoding | Gets or sets the transfer encoding.

Public Instance Methods

Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Overloaded. Saves the specified stream.
SaveRawContent | Obsolete. Saves the content of the raw.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

AttachmentBase Overloaded. Initializes a new instance of the AttachmentBase class.

Protected Instance Methods

Dispose | Overloaded. Releases unmanaged and - optionally - managed resources.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetContentFromString |

See Also

AttachmentBase Class | Aspose.Email.Mail Namespace


AttachmentBase Constructor

Overload List

protected AttachmentBase(Stream);

protected AttachmentBase(Stream,ContentType);

protected AttachmentBase(Stream,string);

protected AttachmentBase(string);

protected AttachmentBase(string,ContentType);

protected AttachmentBase(string,string);

See Also

AttachmentBase Class | Aspose.Email.Mail Namespace


AttachmentBase Constructor (String)

protected AttachmentBase(
string fileName
);

See Also

AttachmentBase Class | Aspose.Email.Mail Namespace | AttachmentBase Constructor Overload List


AttachmentBase Constructor (String, String)

protected AttachmentBase(
string fileName,
string mediaType
);

See Also

AttachmentBase Class | Aspose.Email.Mail Namespace | AttachmentBase Constructor Overload List


AttachmentBase Constructor (String, ContentType)

protected AttachmentBase(
string fileName,
ContentType contentType
);

See Also

AttachmentBase Class | Aspose.Email.Mail Namespace | AttachmentBase Constructor Overload List


AttachmentBase Constructor (Stream)

protected AttachmentBase(
Stream contentStream
);

See Also

AttachmentBase Class | Aspose.Email.Mail Namespace | AttachmentBase Constructor Overload List


AttachmentBase Constructor (Stream, String)

protected AttachmentBase(
Stream contentStream,
string mediaType
);

See Also

AttachmentBase Class | Aspose.Email.Mail Namespace | AttachmentBase Constructor Overload List


AttachmentBase Constructor (Stream, ContentType)

protected AttachmentBase(
Stream contentStream,
ContentType contentType
);

See Also

AttachmentBase Class | Aspose.Email.Mail Namespace | AttachmentBase Constructor Overload List


AttachmentBase Properties

The properties of the AttachmentBase class are listed below. For a complete list of AttachmentBase class members, see the AttachmentBase Members topic.

Public Instance Properties

ContentId | Gets or sets the content id.
ContentStream | Gets or sets the content stream.
ContentType | Gets or sets the type of the content.
TransferEncoding | Gets or sets the transfer encoding.

See Also

AttachmentBase Class | Aspose.Email.Mail Namespace


ContentId Property

Aspose.Email

AttachmentBase.ContentId Property

Gets or sets the content id.

public string ContentId {get; set;}

Property Value

The content id.

See Also

AttachmentBase Class | Aspose.Email.Mail Namespace


ContentStream Property

Aspose.Email

AttachmentBase.ContentStream Property

Gets or sets the content stream.

public Stream ContentStream {get; set;}

Property Value

The content stream.

See Also

AttachmentBase Class | Aspose.Email.Mail Namespace


ContentType Property

Aspose.Email

AttachmentBase.ContentType Property

Gets or sets the type of the content.

public ContentType ContentType {get; set;}

Property Value

The type of the content.

See Also

AttachmentBase Class | Aspose.Email.Mail Namespace


TransferEncoding Property

Aspose.Email

AttachmentBase.TransferEncoding Property

Gets or sets the transfer encoding.

public TransferEncoding TransferEncoding {get; set;}

Property Value

The transfer encoding.

See Also

AttachmentBase Class | Aspose.Email.Mail Namespace


AttachmentBase Methods

The methods of the AttachmentBase class are listed below. For a complete list of AttachmentBase class members, see the AttachmentBase Members topic.

Protected Static Methods

GetEncodingFromContent

Public Instance Methods

Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Overloaded. Saves the specified stream.
SaveRawContent | Obsolete. Saves the content of the raw.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Dispose | Overloaded. Releases unmanaged and - optionally - managed resources.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetContentFromString |

See Also

AttachmentBase Class | Aspose.Email.Mail Namespace


Dispose Method

Aspose.Email

AttachmentBase.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Overload List

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

public void Dispose();

Releases unmanaged and - optionally - managed resources.

protected virtual void Dispose(bool);

See Also

AttachmentBase Class | Aspose.Email.Mail Namespace


AttachmentBase.Dispose Method ()

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

public void Dispose();

Implements

IDisposable.Dispose

See Also

AttachmentBase Class | Aspose.Email.Mail Namespace | AttachmentBase.Dispose Overload List


AttachmentBase.Dispose Method (Boolean)

Releases unmanaged and - optionally - managed resources.

protected virtual void Dispose(
bool disposing
);

Parameters

disposing
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

AttachmentBase Class | Aspose.Email.Mail Namespace | AttachmentBase.Dispose Overload List


AttachmentBase.GetEncodingFromContent Method

protected static Encoding GetEncodingFromContent(
string contentString,
ContentType contentType
);

See Also

AttachmentBase Class | Aspose.Email.Mail Namespace


Save Method

Aspose.Email

AttachmentBase.Save Method

Saves the specified stream.

Overload List

Saves the specified stream.

public virtual void Save(Stream);

Saves the specified file name.

public virtual void Save(string);

See Also

AttachmentBase Class | Aspose.Email.Mail Namespace


AttachmentBase.Save Method (Stream)

Saves the specified stream.

public virtual void Save(
Stream stream
);

Parameters

stream
The stream.

See Also

AttachmentBase Class | Aspose.Email.Mail Namespace | AttachmentBase.Save Overload List


AttachmentBase.Save Method (String)

Saves the specified file name.

public virtual void Save(
string fileName
);

Parameters

fileName
Name of the file.

See Also

AttachmentBase Class | Aspose.Email.Mail Namespace | AttachmentBase.Save Overload List


AttachmentBase.SaveRawContent Method

NOTE: This method is now obsolete.

Use Save() method instead, the result of this call will be identical to Save()

Saves the content of the raw.

public virtual void SaveRawContent(
Stream stream
);

Parameters

stream
The stream.

See Also

AttachmentBase Class | Aspose.Email.Mail Namespace


AttachmentBase.SetContentFromString Method

protected void SetContentFromString(
string contentString,
Encoding encoding,
ContentType contentType,
TransferEncoding te
);

See Also

AttachmentBase Class | Aspose.Email.Mail Namespace


AttachmentCollection Class

Represents a collection of e-mail message attachments.

For a list of all members of this type, see AttachmentCollection Members.

System.Object
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Mail.Attachment, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]]
Aspose.Email.Mail.AttachmentCollection

public sealed class AttachmentCollection : Collection`1, IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AttachmentCollection Members | Aspose.Email.Mail Namespace


AttachmentCollection Members

AttachmentCollection overview

Public Instance Properties

Count (inherited from 0, Culture=neutral, PublicKeyToken=null]])
Item (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

AttachmentCollection Class | Aspose.Email.Mail Namespace


AttachmentCollection Methods

The methods of the AttachmentCollection class are listed below. For a complete list of AttachmentCollection class members, see the AttachmentCollection Members topic.

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

AttachmentCollection Class | Aspose.Email.Mail Namespace


AttachmentCollection.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

public void Dispose();

Implements

IDisposable.Dispose

See Also

AttachmentCollection Class | Aspose.Email.Mail Namespace


DeliveryNotificationOptions Enumeration

Specifies delivery notifications.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum DeliveryNotificationOptions

Members

Member Name | Description | Value
None | No notification information will be sent. The mail server will utilize its configured behavior to determine whether it should generate a delivery notification. | 0
OnSuccess | Notify if the delivery is successful. | 1
OnFailure | Notify if the delivery is unsuccessful. | 2
Delay | Notify if the delivery is delayed. | 4
Never | A notification should not be generated under any circumstances. | 134217728

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Mail Namespace


EmlValidationError Class

Represents the eml validation error information.

For a list of all members of this type, see EmlValidationError Members.

System.Object
Aspose.Email.Mail.EmlValidationError

public sealed class EmlValidationError

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

EmlValidationError Members | Aspose.Email.Mail Namespace


EmlValidationError Members

EmlValidationError overview

Public Instance Properties

ErrorMessage | Gets an error message.
ErrorType | Gets a type of error.
LineNumber | Gets a number of line where error was found.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

EmlValidationError Class | Aspose.Email.Mail Namespace


EmlValidationError Properties

The properties of the EmlValidationError class are listed below. For a complete list of EmlValidationError class members, see the EmlValidationError Members topic.

Public Instance Properties

ErrorMessage | Gets an error message.
ErrorType | Gets a type of error.
LineNumber | Gets a number of line where error was found.

See Also

EmlValidationError Class | Aspose.Email.Mail Namespace


ErrorMessage Property

Aspose.Email

EmlValidationError.ErrorMessage Property

Gets an error message.

public string ErrorMessage {get;}

See Also

EmlValidationError Class | Aspose.Email.Mail Namespace


ErrorType Property

Aspose.Email

EmlValidationError.ErrorType Property

Gets a type of error.

public EmlValidationErrorType ErrorType {get;}

See Also

EmlValidationError Class | Aspose.Email.Mail Namespace


LineNumber Property

Aspose.Email

EmlValidationError.LineNumber Property

Gets a number of line where error was found.

public int LineNumber {get;}

See Also

EmlValidationError Class | Aspose.Email.Mail Namespace


EmlValidationErrorCollection Class

Represents the collection of EmlValidationError

For a list of all members of this type, see EmlValidationErrorCollection Members.

System.Object
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Mail.EmlValidationError, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]]
Aspose.Email.Mail.EmlValidationErrorCollection

public sealed class EmlValidationErrorCollection : Collection`1

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

EmlValidationErrorCollection Members | Aspose.Email.Mail Namespace


EmlValidationErrorCollection Members

EmlValidationErrorCollection overview

Public Instance Constructors

EmlValidationErrorCollection Constructor Initializes a new instance of the EmlValidationErrorCollection class.

Public Instance Properties

Count (inherited from 0, Culture=neutral, PublicKeyToken=null]])
Item (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

EmlValidationErrorCollection Class | Aspose.Email.Mail Namespace


EmlValidationErrorCollection Constructor

Initializes a new instance of the EmlValidationErrorCollection class.

public EmlValidationErrorCollection();

See Also

EmlValidationErrorCollection Class | Aspose.Email.Mail Namespace


EmlValidationErrorType Enumeration

Enumerates the types of the eml validation errors.

public enum EmlValidationErrorType

Members

Member Name | Description | Value
MessageStructureError | Indicates that the message structure is incorrect. | 0
EmailAddressError | Indicates that email address is invalid. | 1
TransferEncodingError | Indicates that message contains unexpected unencoded non-ASCII data. | 2

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Mail Namespace


FileCompatibilityMode Enumeration

Defines inner conversions, that are necessarily to be done when loading or saving a message. By default CR is not replaces by CRLF, Tnef-attachment is not saved.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum FileCompatibilityMode

Members

Member Name | Description | Value
None | No values are set. | 0
AllowCROnly | Shows the necessity of the forced replace of line separators by CRLF. | 1
PreserveTnefAttachments | Controls TNEF attachment load/save behaviour | 2
SkipValidityChecking | Sets whether to skip checking on rfc conformity while loading message. | 4

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Mail Namespace


HeaderType Class

Represents the Internet standards and RFCs define header fields which may occur on Internet Mail Messages .

For a list of all members of this type, see HeaderType Members.

System.Object
Aspose.Email.Mail.HeaderType

public sealed class HeaderType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

HeaderType Members | Aspose.Email.Mail Namespace


HeaderType Members

HeaderType overview

Public Static Properties

ApparentlyTo | Inserted by sending e-mail when there is no "To:" recipient in the original message. This causes the recipients derived from the envelope to be listed in the message heading. This behavior is not quite proper, MTAs should not modify headers (except inserting Received lines), and it can in some cases cause Bcc recipients to be wrongly divulged to non-Bcc recipients. Example: Apparently-To: someone@somedomain.com Non-standard header that is discouraged in use, mentioned in RFC1211.
ApprovedBy | Name of the moderator of the mailing list to which this message is sent; necessary on a posting sent to a moderated mailing list to allow its distribution to the list members. Example: Approved-By: someone@somedomain.com Non-standard for use in e-mail. Defined in RFC1036.
Bcc | A copy of the e-mail message that is sent to one or more recipients without the knowledge of the primary recipients. Primary recipients are listed in the To: and Cc: lines. This is useful if you want to copy a message to many people without each of them seeing who the other recipients are. If you see this header on incoming mail, something is wrong because it does not appear in the headers.
CC | This header can be considered an extension of the "To:" field as it is used to specifiy additional recipients. In this case, the copy of an e-mail message sent to a recipient has the recipient's address appearing in the message. This is useful if you want to copy a message to many people with each of them seeing who the other recipients are; contrast with Bcc above. This header does appear in incoming e-mail. Exmple: Cc: gboyd@netcom.com
Comments | This is a free-form header field defined in RFC2822. The header is used to place explanatory text into the header portion of an e-mail message. The field may contain arbitrary text. Exmple: Comments: Authenticated sender is someone@somedonmain.com.
ContentTransferEncoding | The third of the MIME-related headers. Indicates the coding method used in a MIME message body. It has no direct relevance to the delivery of e-mail, but it affects how MIME compliant mail programs interpret the content of the message. Defined in RFC2045. Content-Transfer-Encoding: 8bit Content-transfer-encoding: 7BIT Content-Transfer-Encoding: 7bit Content-Transfer-Encoding: base64 Content-Transfer-Encoding: quoted-printable
ContentType | The "Content-Type" defines the format of content (character set etc.) Note that the values for this header are defined in different ways in RFC1049 and in MIME (RFC2045). Look for the MIME-version: header to understand if Content-Type is to be interpreted according to RFC1049 or according to MIME (RFC2045). The MIME definition should be used in generating mail. Historically, Content-Type field was proposed in RFC1049. In it, Content-Type did not distinguish type and subtype like RFC2045 does. Example: Content-Type: text/plain; charset="us-ascii" Content-type: text/plain; charset=US-ASCII Content-Type: text/plain; charset="iso-8859-1" Content-Type: text/plain; charset=koi8-r Content-Type: text/plain; charset=unknown-8bit
Date | This header specifies a date (and time), normally the date the message was composed and sent. In X.400 mail systems, the time a message was submitted. Some Internet mail systems also use the date when the message was submitted. If this header is omitted by the sender's computer, it might conceivably be added by a mail server or even by some other machine along the route. What you may not know is that the information in the "Date:" line is supplied by the time on the sender's computer, which may or may not be set correctly. Also, the "Date:" header does not normally indicate when the message was sent, but only when it was composed. The date is in the form 3 character day-of-week (Sun - Sat), day number (1-31) dd, 3-character month name, 4-digit year yyyy, followed by time (24-hour) hh:mm:ss and zone zzz format. Time Zone (zzz) is either the 3-character time zone or the local differential in hours and minutes offset from UTC (Universal Time Coordinated - old Greenwich Mean Time). "-" indicates west and "+" indicates east of UTC. No standard Time Zone definitions seem to exist. Many UNIX versions understand a great range of abbreviations, but the most exhaustive list I found was the GNU tar manual Timezone item and documentation for the Perl date manipulation module TIMEZONES. Example: Date: Tue, 9 Jan 2001 23:40:00 -0800 Date: Sun, 1 Apr 2001 22:52:04 EDT Date: Mon, 2 Apr 2001 16:02:19 +0200 Date: Fri, 30 Mar 2001 10:47:15 -0800
DispositionNotificationTo | When the DispositionNotificationTo field is set, a request for a MDN (Message Delivery Notification) is made. The recipient's email software (Outlook, Eudora, etc.) may silently ignore the request, or it may prompt the user for permission to send the MDN. There is no guarantee of the "return-receipt". The DispositionNotificationTo field is the de facto standard for requesting return-receipts (i.e. MDN, or message delivery notifications).
FollowupTo | Used in Usenet News to indicate that future discussions (=follow-up) on an article should go to a different set of newsgroups than the replied-to article. The most common usage is when an article is posted to several newsgroups, and further discussions is to take place in only one of them. Defined in RFC 1036: 2.2.3, not standardized for use in e-mail.
From | This field contains the identity of the person(s) who wished this message to be sent. The message-creation process should default this field to be a single, authenticated machine address, indicating the AGENT (person, system or process) composing the message. If this is not done, the "Sender:" field MUST be present. If the "From:" field IS defaulted this way, the "Sender:" field is optional and is redundant with the "From:" field. Example: From: "Mr. Some One" someone@somedomain.com
Importance | Gets the importance.
InReplyTo | Reference to message which this message is a reply to.
MessageID | Unique ID of this message. Defined In RFC 822: 4.6.1 ,RFC 1036: 2.1.5.
MIMEVersion | An indicator that this message is formatted according to the MIME standard, and an indication of which version of MIME is utilized. Defined in RFC 2045
Newsgroups | In Usenet News: group(s) to which this article was posted. Some systems provide this header field also in e-mail although it is not standardized there. Unfortunately, the header field can appear in e-mail with three different and contradictory meanings: (a) Indicating the newsgroup recipient of an article/message sent to both e-mail and Usenet News recipients. (b) In a message adressed to some mail to news gateways, indicates the newsgroup(s) that the message is to be posted to. (c) In a personally addressed reply to an article in a news-group, indicating the newsgroup in which this discussion originated. Defined in RFC 1036: 2.1.3, not standardized and controversial for use in e-mail.
Received | Trace of MTAs which a message has passed. Defined in RFC 822
References | Reference to other related messages.
ReplyTo | This header field is meant to indicate where the sender wants replies to go. Unfortunately, this is ambiguous, since there are different kinds of replies, which the sender may wish to go to different addresses. In particular, there are personal replies intended for only one person, and group replies, intended for the whole group of people who read the replied-to message (often a mailing list, anewsgroup name cannot appear here because of different syntax, see "FollowupTo" .).
ReturnPath | Used to convey the information from the MAIL FROM envelope attribute in final delivery, when the message leaves the SMTP environment in which "MAIL FROM" is used. ///
ReturnReceiptTo | A sender can request a return-receipt by including this header field. The return-receipt is sent to the Return-Path address of the email and not to the address specified in the Return-Receipt-To header field. This header is non-standard and mostly not supported. Use Disposition-Notification-To instead. Even if supported, there is no guarantee of a receipt being sent.
Sender | The person or agent submitting the message to the network, if other than shown by the From: header field. Should be authenticated, according to RFC 822, but what kind of authentication is not clear.
Sensitivity | Gets the sensitivity.
Subject | Title, heading, subject. Often used as thread indicator for messages replying to or commenting on other messages.
To | Primary recipients. Example: To: someone@somedomain.com
XConfirmReadingTo | This header requests an automated confirmation notice when the message is received or read. It is typically ignored; presumably some software acts on it.
XMailer | Information about the client software of the originator. Example: X-Mailer: Aspose.Email

Public Static Type Conversions

Implicit HeaderType to String Conversion Performs an implicit conversion from HeaderType to String.

Public Instance Methods

Equals | Returns a boolean indicating if the passed in object obj is Equal to this.
GetHashCode | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents the current Object.

See Also

HeaderType Class | Aspose.Email.Mail Namespace


HeaderType Properties

The properties of the HeaderType class are listed below. For a complete list of HeaderType class members, see the HeaderType Members topic.

Public Static Properties

ApparentlyTo | Inserted by sending e-mail when there is no "To:" recipient in the original message. This causes the recipients derived from the envelope to be listed in the message heading. This behavior is not quite proper, MTAs should not modify headers (except inserting Received lines), and it can in some cases cause Bcc recipients to be wrongly divulged to non-Bcc recipients. Example: Apparently-To: someone@somedomain.com Non-standard header that is discouraged in use, mentioned in RFC1211.
ApprovedBy | Name of the moderator of the mailing list to which this message is sent; necessary on a posting sent to a moderated mailing list to allow its distribution to the list members. Example: Approved-By: someone@somedomain.com Non-standard for use in e-mail. Defined in RFC1036.
Bcc | A copy of the e-mail message that is sent to one or more recipients without the knowledge of the primary recipients. Primary recipients are listed in the To: and Cc: lines. This is useful if you want to copy a message to many people without each of them seeing who the other recipients are. If you see this header on incoming mail, something is wrong because it does not appear in the headers.
CC | This header can be considered an extension of the "To:" field as it is used to specifiy additional recipients. In this case, the copy of an e-mail message sent to a recipient has the recipient's address appearing in the message. This is useful if you want to copy a message to many people with each of them seeing who the other recipients are; contrast with Bcc above. This header does appear in incoming e-mail. Exmple: Cc: gboyd@netcom.com
Comments | This is a free-form header field defined in RFC2822. The header is used to place explanatory text into the header portion of an e-mail message. The field may contain arbitrary text. Exmple: Comments: Authenticated sender is someone@somedonmain.com.
ContentTransferEncoding | The third of the MIME-related headers. Indicates the coding method used in a MIME message body. It has no direct relevance to the delivery of e-mail, but it affects how MIME compliant mail programs interpret the content of the message. Defined in RFC2045. Content-Transfer-Encoding: 8bit Content-transfer-encoding: 7BIT Content-Transfer-Encoding: 7bit Content-Transfer-Encoding: base64 Content-Transfer-Encoding: quoted-printable
ContentType | The "Content-Type" defines the format of content (character set etc.) Note that the values for this header are defined in different ways in RFC1049 and in MIME (RFC2045). Look for the MIME-version: header to understand if Content-Type is to be interpreted according to RFC1049 or according to MIME (RFC2045). The MIME definition should be used in generating mail. Historically, Content-Type field was proposed in RFC1049. In it, Content-Type did not distinguish type and subtype like RFC2045 does. Example: Content-Type: text/plain; charset="us-ascii" Content-type: text/plain; charset=US-ASCII Content-Type: text/plain; charset="iso-8859-1" Content-Type: text/plain; charset=koi8-r Content-Type: text/plain; charset=unknown-8bit
Date | This header specifies a date (and time), normally the date the message was composed and sent. In X.400 mail systems, the time a message was submitted. Some Internet mail systems also use the date when the message was submitted. If this header is omitted by the sender's computer, it might conceivably be added by a mail server or even by some other machine along the route. What you may not know is that the information in the "Date:" line is supplied by the time on the sender's computer, which may or may not be set correctly. Also, the "Date:" header does not normally indicate when the message was sent, but only when it was composed. The date is in the form 3 character day-of-week (Sun - Sat), day number (1-31) dd, 3-character month name, 4-digit year yyyy, followed by time (24-hour) hh:mm:ss and zone zzz format. Time Zone (zzz) is either the 3-character time zone or the local differential in hours and minutes offset from UTC (Universal Time Coordinated - old Greenwich Mean Time). "-" indicates west and "+" indicates east of UTC. No standard Time Zone definitions seem to exist. Many UNIX versions understand a great range of abbreviations, but the most exhaustive list I found was the GNU tar manual Timezone item and documentation for the Perl date manipulation module TIMEZONES. Example: Date: Tue, 9 Jan 2001 23:40:00 -0800 Date: Sun, 1 Apr 2001 22:52:04 EDT Date: Mon, 2 Apr 2001 16:02:19 +0200 Date: Fri, 30 Mar 2001 10:47:15 -0800
DispositionNotificationTo | When the DispositionNotificationTo field is set, a request for a MDN (Message Delivery Notification) is made. The recipient's email software (Outlook, Eudora, etc.) may silently ignore the request, or it may prompt the user for permission to send the MDN. There is no guarantee of the "return-receipt". The DispositionNotificationTo field is the de facto standard for requesting return-receipts (i.e. MDN, or message delivery notifications).
FollowupTo | Used in Usenet News to indicate that future discussions (=follow-up) on an article should go to a different set of newsgroups than the replied-to article. The most common usage is when an article is posted to several newsgroups, and further discussions is to take place in only one of them. Defined in RFC 1036: 2.2.3, not standardized for use in e-mail.
From | This field contains the identity of the person(s) who wished this message to be sent. The message-creation process should default this field to be a single, authenticated machine address, indicating the AGENT (person, system or process) composing the message. If this is not done, the "Sender:" field MUST be present. If the "From:" field IS defaulted this way, the "Sender:" field is optional and is redundant with the "From:" field. Example: From: "Mr. Some One" someone@somedomain.com
Importance | Gets the importance.
InReplyTo | Reference to message which this message is a reply to.
MessageID | Unique ID of this message. Defined In RFC 822: 4.6.1 ,RFC 1036: 2.1.5.
MIMEVersion | An indicator that this message is formatted according to the MIME standard, and an indication of which version of MIME is utilized. Defined in RFC 2045
Newsgroups | In Usenet News: group(s) to which this article was posted. Some systems provide this header field also in e-mail although it is not standardized there. Unfortunately, the header field can appear in e-mail with three different and contradictory meanings: (a) Indicating the newsgroup recipient of an article/message sent to both e-mail and Usenet News recipients. (b) In a message adressed to some mail to news gateways, indicates the newsgroup(s) that the message is to be posted to. (c) In a personally addressed reply to an article in a news-group, indicating the newsgroup in which this discussion originated. Defined in RFC 1036: 2.1.3, not standardized and controversial for use in e-mail.
Received | Trace of MTAs which a message has passed. Defined in RFC 822
References | Reference to other related messages.
ReplyTo | This header field is meant to indicate where the sender wants replies to go. Unfortunately, this is ambiguous, since there are different kinds of replies, which the sender may wish to go to different addresses. In particular, there are personal replies intended for only one person, and group replies, intended for the whole group of people who read the replied-to message (often a mailing list, anewsgroup name cannot appear here because of different syntax, see "FollowupTo" .).
ReturnPath | Used to convey the information from the MAIL FROM envelope attribute in final delivery, when the message leaves the SMTP environment in which "MAIL FROM" is used. ///
ReturnReceiptTo | A sender can request a return-receipt by including this header field. The return-receipt is sent to the Return-Path address of the email and not to the address specified in the Return-Receipt-To header field. This header is non-standard and mostly not supported. Use Disposition-Notification-To instead. Even if supported, there is no guarantee of a receipt being sent.
Sender | The person or agent submitting the message to the network, if other than shown by the From: header field. Should be authenticated, according to RFC 822, but what kind of authentication is not clear.
Sensitivity | Gets the sensitivity.
Subject | Title, heading, subject. Often used as thread indicator for messages replying to or commenting on other messages.
To | Primary recipients. Example: To: someone@somedomain.com
XConfirmReadingTo | This header requests an automated confirmation notice when the message is received or read. It is typically ignored; presumably some software acts on it.
XMailer | Information about the client software of the originator. Example: X-Mailer: Aspose.Email

See Also

HeaderType Class | Aspose.Email.Mail Namespace


ApparentlyTo Property

Aspose.Email

HeaderType.ApparentlyTo Property

Inserted by sending e-mail when there is no "To:" recipient in the original message. This causes the recipients derived from the envelope to be listed in the message heading. This behavior is not quite proper, MTAs should not modify headers (except inserting Received lines), and it can in some cases cause Bcc recipients to be wrongly divulged to non-Bcc recipients. Example: Apparently-To: someone@somedomain.com Non-standard header that is discouraged in use, mentioned in RFC1211.

public static HeaderType ApparentlyTo {get;}

See Also

HeaderType Class | Aspose.Email.Mail Namespace


ApprovedBy Property

Aspose.Email

HeaderType.ApprovedBy Property

Name of the moderator of the mailing list to which this message is sent; necessary on a posting sent to a moderated mailing list to allow its distribution to the list members. Example: Approved-By: someone@somedomain.com Non-standard for use in e-mail. Defined in RFC1036.

public static HeaderType ApprovedBy {get;}

See Also

HeaderType Class | Aspose.Email.Mail Namespace


Bcc Property

Aspose.Email

HeaderType.Bcc Property

A copy of the e-mail message that is sent to one or more recipients without the knowledge of the primary recipients. Primary recipients are listed in the To: and Cc: lines. This is useful if you want to copy a message to many people without each of them seeing who the other recipients are. If you see this header on incoming mail, something is wrong because it does not appear in the headers.

public static HeaderType Bcc {get;}

See Also

HeaderType Class | Aspose.Email.Mail Namespace


CC Property

Aspose.Email

HeaderType.CC Property

This header can be considered an extension of the "To:" field as it is used to specifiy additional recipients. In this case, the copy of an e-mail message sent to a recipient has the recipient's address appearing in the message. This is useful if you want to copy a message to many people with each of them seeing who the other recipients are; contrast with Bcc above. This header does appear in incoming e-mail. Exmple: Cc: gboyd@netcom.com

public static HeaderType CC {get;}

See Also

HeaderType Class | Aspose.Email.Mail Namespace


Comments Property

Aspose.Email

HeaderType.Comments Property

This is a free-form header field defined in RFC2822. The header is used to place explanatory text into the header portion of an e-mail message. The field may contain arbitrary text. Exmple: Comments: Authenticated sender is someone@somedonmain.com.

public static HeaderType Comments {get;}

See Also

HeaderType Class | Aspose.Email.Mail Namespace


ContentTransferEncoding Property

Aspose.Email

HeaderType.ContentTransferEncoding Property

The third of the MIME-related headers. Indicates the coding method used in a MIME message body. It has no direct relevance to the delivery of e-mail, but it affects how MIME compliant mail programs interpret the content of the message. Defined in RFC2045. Content-Transfer-Encoding: 8bit Content-transfer-encoding: 7BIT Content-Transfer-Encoding: 7bit Content-Transfer-Encoding: base64 Content-Transfer-Encoding: quoted-printable

public static HeaderType ContentTransferEncoding {get;}

See Also

HeaderType Class | Aspose.Email.Mail Namespace


ContentType Property

Aspose.Email

HeaderType.ContentType Property

The "Content-Type" defines the format of content (character set etc.) Note that the values for this header are defined in different ways in RFC1049 and in MIME (RFC2045). Look for the MIME-version: header to understand if Content-Type is to be interpreted according to RFC1049 or according to MIME (RFC2045). The MIME definition should be used in generating mail. Historically, Content-Type field was proposed in RFC1049. In it, Content-Type did not distinguish type and subtype like RFC2045 does. Example: Content-Type: text/plain; charset="us-ascii" Content-type: text/plain; charset=US-ASCII Content-Type: text/plain; charset="iso-8859-1" Content-Type: text/plain; charset=koi8-r Content-Type: text/plain; charset=unknown-8bit

public static HeaderType ContentType {get;}

See Also

HeaderType Class | Aspose.Email.Mail Namespace


Date Property

Aspose.Email

HeaderType.Date Property

This header specifies a date (and time), normally the date the message was composed and sent. In X.400 mail systems, the time a message was submitted. Some Internet mail systems also use the date when the message was submitted. If this header is omitted by the sender's computer, it might conceivably be added by a mail server or even by some other machine along the route. What you may not know is that the information in the "Date:" line is supplied by the time on the sender's computer, which may or may not be set correctly. Also, the "Date:" header does not normally indicate when the message was sent, but only when it was composed. The date is in the form 3 character day-of-week (Sun - Sat), day number (1-31) dd, 3-character month name, 4-digit year yyyy, followed by time (24-hour) hh:mm:ss and zone zzz format. Time Zone (zzz) is either the 3-character time zone or the local differential in hours and minutes offset from UTC (Universal Time Coordinated - old Greenwich Mean Time). "-" indicates west and "+" indicates east of UTC. No standard Time Zone definitions seem to exist. Many UNIX versions understand a great range of abbreviations, but the most exhaustive list I found was the GNU tar manual Timezone item and documentation for the Perl date manipulation module TIMEZONES. Example: Date: Tue, 9 Jan 2001 23:40:00 -0800 Date: Sun, 1 Apr 2001 22:52:04 EDT Date: Mon, 2 Apr 2001 16:02:19 +0200 Date: Fri, 30 Mar 2001 10:47:15 -0800

public static HeaderType Date {get;}

See Also

HeaderType Class | Aspose.Email.Mail Namespace


DispositionNotificationTo Property

Aspose.Email

HeaderType.DispositionNotificationTo Property

When the DispositionNotificationTo field is set, a request for a MDN (Message Delivery Notification) is made. The recipient's email software (Outlook, Eudora, etc.) may silently ignore the request, or it may prompt the user for permission to send the MDN. There is no guarantee of the "return-receipt". The DispositionNotificationTo field is the de facto standard for requesting return-receipts (i.e. MDN, or message delivery notifications).

public static HeaderType DispositionNotificationTo {get;}

See Also

HeaderType Class | Aspose.Email.Mail Namespace


FollowupTo Property

Aspose.Email

HeaderType.FollowupTo Property

Used in Usenet News to indicate that future discussions (=follow-up) on an article should go to a different set of newsgroups than the replied-to article. The most common usage is when an article is posted to several newsgroups, and further discussions is to take place in only one of them. Defined in RFC 1036: 2.2.3, not standardized for use in e-mail.

public static HeaderType FollowupTo {get;}

See Also

HeaderType Class | Aspose.Email.Mail Namespace


From Property

Aspose.Email

HeaderType.From Property

This field contains the identity of the person(s) who wished this message to be sent. The message-creation process should default this field to be a single, authenticated machine address, indicating the AGENT (person, system or process) composing the message. If this is not done, the "Sender:" field MUST be present. If the "From:" field IS defaulted this way, the "Sender:" field is optional and is redundant with the "From:" field. Example: From: "Mr. Some One" someone@somedomain.com

public static HeaderType From {get;}

See Also

HeaderType Class | Aspose.Email.Mail Namespace


Importance Property

Aspose.Email

HeaderType.Importance Property

Gets the importance.

public static HeaderType Importance {get;}

Property Value

The importance.

See Also

HeaderType Class | Aspose.Email.Mail Namespace


InReplyTo Property

Aspose.Email

HeaderType.InReplyTo Property

Reference to message which this message is a reply to.

public static HeaderType InReplyTo {get;}

See Also

HeaderType Class | Aspose.Email.Mail Namespace


MessageID Property

Aspose.Email

HeaderType.MessageID Property

Unique ID of this message. Defined In RFC 822: 4.6.1 ,RFC 1036: 2.1.5.

public static HeaderType MessageID {get;}

See Also

HeaderType Class | Aspose.Email.Mail Namespace


MIMEVersion Property

Aspose.Email

HeaderType.MIMEVersion Property

An indicator that this message is formatted according to the MIME standard, and an indication of which version of MIME is utilized. Defined in RFC 2045

public static HeaderType MIMEVersion {get;}

See Also

HeaderType Class | Aspose.Email.Mail Namespace


Newsgroups Property

Aspose.Email

HeaderType.Newsgroups Property

In Usenet News: group(s) to which this article was posted. Some systems provide this header field also in e-mail although it is not standardized there. Unfortunately, the header field can appear in e-mail with three different and contradictory meanings: (a) Indicating the newsgroup recipient of an article/message sent to both e-mail and Usenet News recipients. (b) In a message adressed to some mail to news gateways, indicates the newsgroup(s) that the message is to be posted to. (c) In a personally addressed reply to an article in a news-group, indicating the newsgroup in which this discussion originated. Defined in RFC 1036: 2.1.3, not standardized and controversial for use in e-mail.

public static HeaderType Newsgroups {get;}

See Also

HeaderType Class | Aspose.Email.Mail Namespace


Received Property

Aspose.Email

HeaderType.Received Property

Trace of MTAs which a message has passed. Defined in RFC 822

public static HeaderType Received {get;}

See Also

HeaderType Class | Aspose.Email.Mail Namespace


References Property

Aspose.Email

HeaderType.References Property

Reference to other related messages.

public static HeaderType References {get;}

See Also

HeaderType Class | Aspose.Email.Mail Namespace


ReplyTo Property

Aspose.Email

HeaderType.ReplyTo Property

This header field is meant to indicate where the sender wants replies to go. Unfortunately, this is ambiguous, since there are different kinds of replies, which the sender may wish to go to different addresses. In particular, there are personal replies intended for only one person, and group replies, intended for the whole group of people who read the replied-to message (often a mailing list, anewsgroup name cannot appear here because of different syntax, see "FollowupTo" .).

public static HeaderType ReplyTo {get;}

See Also

HeaderType Class | Aspose.Email.Mail Namespace


ReturnPath Property

Aspose.Email

HeaderType.ReturnPath Property

Used to convey the information from the MAIL FROM envelope attribute in final delivery, when the message leaves the SMTP environment in which "MAIL FROM" is used. ///

public static HeaderType ReturnPath {get;}

See Also

HeaderType Class | Aspose.Email.Mail Namespace


ReturnReceiptTo Property

Aspose.Email

HeaderType.ReturnReceiptTo Property

A sender can request a return-receipt by including this header field. The return-receipt is sent to the Return-Path address of the email and not to the address specified in the Return-Receipt-To header field. This header is non-standard and mostly not supported. Use Disposition-Notification-To instead. Even if supported, there is no guarantee of a receipt being sent.

public static HeaderType ReturnReceiptTo {get;}

See Also

HeaderType Class | Aspose.Email.Mail Namespace


Sender Property

Aspose.Email

HeaderType.Sender Property

The person or agent submitting the message to the network, if other than shown by the From: header field. Should be authenticated, according to RFC 822, but what kind of authentication is not clear.

public static HeaderType Sender {get;}

See Also

HeaderType Class | Aspose.Email.Mail Namespace


Sensitivity Property

Aspose.Email

HeaderType.Sensitivity Property

Gets the sensitivity.

public static HeaderType Sensitivity {get;}

Property Value

The sensitivity.

See Also

HeaderType Class | Aspose.Email.Mail Namespace


Subject Property

Aspose.Email

HeaderType.Subject Property

Title, heading, subject. Often used as thread indicator for messages replying to or commenting on other messages.

public static HeaderType Subject {get;}

See Also

HeaderType Class | Aspose.Email.Mail Namespace


To Property

Aspose.Email

HeaderType.To Property

Primary recipients. Example: To: someone@somedomain.com

public static HeaderType To {get;}

See Also

HeaderType Class | Aspose.Email.Mail Namespace


XConfirmReadingTo Property

Aspose.Email

HeaderType.XConfirmReadingTo Property

This header requests an automated confirmation notice when the message is received or read. It is typically ignored; presumably some software acts on it.

public static HeaderType XConfirmReadingTo {get;}

See Also

HeaderType Class | Aspose.Email.Mail Namespace


XMailer Property

Aspose.Email

HeaderType.XMailer Property

Information about the client software of the originator. Example: X-Mailer: Aspose.Email

public static HeaderType XMailer {get;}

See Also

HeaderType Class | Aspose.Email.Mail Namespace


HeaderType Methods

The methods of the HeaderType class are listed below. For a complete list of HeaderType class members, see the HeaderType Members topic.

Public Instance Methods

Equals | Returns a boolean indicating if the passed in object obj is Equal to this.
GetHashCode | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents the current Object.

See Also

HeaderType Class | Aspose.Email.Mail Namespace


HeaderType.Equals Method

Returns a boolean indicating if the passed in object obj is Equal to this.

public override bool Equals(
object o
);

Parameters

o
The HeaderType object to compare.

Return Value

Returns true if objects are equal, otherwise returns false

See Also

HeaderType Class | Aspose.Email.Mail Namespace


HeaderType.GetHashCode Method

Serves as a hash function for a particular type.

public override int GetHashCode();

Return Value

A hash code for the current Object.

See Also

HeaderType Class | Aspose.Email.Mail Namespace


HeaderType.ToString Method

Returns a String that represents the current Object.

public override string ToString();

Return Value

A String that represents the current Object.

See Also

HeaderType Class | Aspose.Email.Mail Namespace


HeaderType Type Conversions

The type conversions of the HeaderType class are listed below. For a complete list of HeaderType class members, see the HeaderType Members topic.

Public Static Type Conversions

Implicit HeaderType to String Conversion Performs an implicit conversion from HeaderType to String.

See Also

HeaderType Class | HeaderType Members | Aspose.Email.Mail Namespace


HeaderType Implicit HeaderType to String Conversion

Performs an implicit conversion from HeaderType to String.

public static implicit operator string(
HeaderType type
);

Parameters

type
The 'HeaderType' object to convert.

Return Value

The result of the conversion.

See Also

HeaderType Class | Aspose.Email.Mail Namespace


IAttachment Interface

Represents a common attachment interface

For a list of all members of this type, see IAttachment Members.

public interface IAttachment

Types that implement IAttachment

Type | Description
Attachment | Represents an e-mail attachment.

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

IAttachment Members | Aspose.Email.Mail Namespace


IAttachment Members

IAttachment overview

Public Instance Properties

Name Gets or sets an attachment name

Public Instance Methods

Save Overloaded. Saves attachment to file

See Also

IAttachment Interface | Aspose.Email.Mail Namespace


IAttachment Properties

The properties of the IAttachment interface are listed below. For a complete list of IAttachment interface members, see the IAttachment Members topic.

Public Instance Properties

Name Gets or sets an attachment name

See Also

IAttachment Interface | Aspose.Email.Mail Namespace


Name Property

Aspose.Email

IAttachment.Name Property

Gets or sets an attachment name

string Name {get; set;}

See Also

IAttachment Interface | Aspose.Email.Mail Namespace


IAttachment Methods

The methods of the IAttachment interface are listed below. For a complete list of IAttachment interface members, see the IAttachment Members topic.

Public Instance Methods

Save Overloaded. Saves attachment to file

See Also

IAttachment Interface | Aspose.Email.Mail Namespace


Save Method

Aspose.Email

IAttachment.Save Method

Saves an attachment to stream

Overload List

Saves an attachment to stream

void Save(Stream);

Saves attachment to file

void Save(string);

See Also

IAttachment Interface | Aspose.Email.Mail Namespace


IAttachment.Save Method (Stream)

Saves an attachment to stream

void Save(
Stream stream
);

Parameters

stream
A stream to save to

See Also

IAttachment Interface | Aspose.Email.Mail Namespace | IAttachment.Save Overload List


IAttachment.Save Method (String)

Saves attachment to file

void Save(
string fileName
);

Parameters

fileName
A file name

See Also

IAttachment Interface | Aspose.Email.Mail Namespace | IAttachment.Save Overload List


IcsSaveOptions Class

Represents iCalendar save options

For a list of all members of this type, see IcsSaveOptions Members.

System.Object
Aspose.Email.Mail.AppointmentSaveOptions
Aspose.Email.Mail.IcsSaveOptions

public sealed class IcsSaveOptions : AppointmentSaveOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

IcsSaveOptions Members | Aspose.Email.Mail Namespace


IcsSaveOptions Members

IcsSaveOptions overview

Public Static Properties

Default Gets the default ics save options

Public Instance Constructors

IcsSaveOptions Overloaded. Initializes a new instance of the IcsSaveOptions class.

Public Instance Properties

Method | Gets or sets appointment method
SaveFormat (inherited from AppointmentSaveOptions) | Gets a save format

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

IcsSaveOptions Class | Aspose.Email.Mail Namespace


IcsSaveOptions Constructor

Initializes a new instance of the IcsSaveOptions class

Overload List

Initializes a new instance of the IcsSaveOptions class

public IcsSaveOptions();

Initializes a new instance of the IcsSaveOptions class

public IcsSaveOptions(AppointmentAction);

See Also

IcsSaveOptions Class | Aspose.Email.Mail Namespace


IcsSaveOptions Constructor ()

Initializes a new instance of the IcsSaveOptions class

public IcsSaveOptions();

See Also

IcsSaveOptions Class | Aspose.Email.Mail Namespace | IcsSaveOptions Constructor Overload List


IcsSaveOptions Constructor (AppointmentAction)

Initializes a new instance of the IcsSaveOptions class

public IcsSaveOptions(
AppointmentAction method
);

Parameters

method
An appointment method

See Also

IcsSaveOptions Class | Aspose.Email.Mail Namespace | IcsSaveOptions Constructor Overload List


IcsSaveOptions Properties

The properties of the IcsSaveOptions class are listed below. For a complete list of IcsSaveOptions class members, see the IcsSaveOptions Members topic.

Public Static Properties

Default Gets the default ics save options

Public Instance Properties

Method | Gets or sets appointment method
SaveFormat (inherited from AppointmentSaveOptions) | Gets a save format

See Also

IcsSaveOptions Class | Aspose.Email.Mail Namespace


Default Property

Aspose.Email

IcsSaveOptions.Default Property

Gets the default ics save options

public static IcsSaveOptions Default {get;}

See Also

IcsSaveOptions Class | Aspose.Email.Mail Namespace


Method Property

Aspose.Email

IcsSaveOptions.Method Property

Gets or sets appointment method

public AppointmentAction Method {get; set;}

Exceptions

Exception Type | Condition
ArgumentException | value is not defined in AppointmentAction

See Also

IcsSaveOptions Class | Aspose.Email.Mail Namespace


IMailAddress Interface

Represents a common mail address interface

For a list of all members of this type, see IMailAddress Members.

public interface IMailAddress

Types that implement IMailAddress

Type | Description
MailAddress | Represents the address of a message.

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

IMailAddress Members | Aspose.Email.Mail Namespace


IMailAddress Members

IMailAddress overview

Public Instance Properties

Address | Gets or sets a mail address
DisplayName | Gets or sets a display name

See Also

IMailAddress Interface | Aspose.Email.Mail Namespace


IMailAddress Properties

The properties of the IMailAddress interface are listed below. For a complete list of IMailAddress interface members, see the IMailAddress Members topic.

Public Instance Properties

Address | Gets or sets a mail address
DisplayName | Gets or sets a display name

See Also

IMailAddress Interface | Aspose.Email.Mail Namespace


Address Property

Aspose.Email

IMailAddress.Address Property

Gets or sets a mail address

string Address {get; set;}

See Also

IMailAddress Interface | Aspose.Email.Mail Namespace


DisplayName Property

Aspose.Email

IMailAddress.DisplayName Property

Gets or sets a display name

string DisplayName {get; set;}

See Also

IMailAddress Interface | Aspose.Email.Mail Namespace


IMailTransferAgent Interface

Provides the base interface for mail transfer agents.

For a list of all members of this type, see IMailTransferAgent Members.

public interface IMailTransferAgent : IDisposable

Types that implement IMailTransferAgent

Type | Description
SmtpClient | Allows applications to send messages by using the Simple Mail Transfer Protocol (SMTP).

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

IMailTransferAgent Members | Aspose.Email.Mail Namespace


IMailTransferAgent Members

IMailTransferAgent overview

Public Instance Methods

Clone | Creates a copy of the current instance.
Send | Sends an Email message.

See Also

IMailTransferAgent Interface | Aspose.Email.Mail Namespace


IMailTransferAgent Methods

The methods of the IMailTransferAgent interface are listed below. For a complete list of IMailTransferAgent interface members, see the IMailTransferAgent Members topic.

Public Instance Methods

Clone | Creates a copy of the current instance.
Send | Sends an Email message.

See Also

IMailTransferAgent Interface | Aspose.Email.Mail Namespace


IMailTransferAgent.Clone Method

Creates a copy of the current instance.

IMailTransferAgent Clone();

Return Value

A copy of current instance.

See Also

IMailTransferAgent Interface | Aspose.Email.Mail Namespace


IMailTransferAgent.Send Method

Sends an Email message.

void Send(
MailMessage message
);

Parameters

message
The Email message.

See Also

IMailTransferAgent Interface | Aspose.Email.Mail Namespace


IMessage Interface

Represents a common message interface

For a list of all members of this type, see IMessage Members.

public interface IMessage

Types that implement IMessage

Type | Description
MailMessage | Represents an e-mail message. It allows to access message properties, ex. subject, body, sender and recipients addreses, etc. Also it can be sent and delivered by means of supported mail protocols.

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

IMessage Members | Aspose.Email.Mail Namespace


IMessage Members

IMessage overview

Public Instance Properties

Attachments | Gets message attachments
Bcc | Gets BCC recipients
Body | Gets or sets a message body
BodyType | Gets the type of the body.
Cc | Gets CC recipients
Date | Gets the date and time when message was delivered
From | Gets or sets a from address
HtmlBody | Gets or sets a html formatted message body
Subject | Gets or sets a message subject
To | Gets recipients

Public Instance Methods

Save Overloaded. Saves message to the specified file

See Also

IMessage Interface | Aspose.Email.Mail Namespace


IMessage Properties

The properties of the IMessage interface are listed below. For a complete list of IMessage interface members, see the IMessage Members topic.

Public Instance Properties

Attachments | Gets message attachments
Bcc | Gets BCC recipients
Body | Gets or sets a message body
BodyType | Gets the type of the body.
Cc | Gets CC recipients
Date | Gets the date and time when message was delivered
From | Gets or sets a from address
HtmlBody | Gets or sets a html formatted message body
Subject | Gets or sets a message subject
To | Gets recipients

See Also

IMessage Interface | Aspose.Email.Mail Namespace


Attachments Property

Aspose.Email

IMessage.Attachments Property

Gets message attachments

ICollection Attachments {get;}

See Also

IMessage Interface | Aspose.Email.Mail Namespace


Bcc Property

Aspose.Email

IMessage.Bcc Property

Gets BCC recipients

ICollection Bcc {get;}

See Also

IMessage Interface | Aspose.Email.Mail Namespace


Body Property

Aspose.Email

IMessage.Body Property

Gets or sets a message body

string Body {get; set;}

See Also

IMessage Interface | Aspose.Email.Mail Namespace


BodyType Property

Aspose.Email

IMessage.BodyType Property

Gets the type of the body.

BodyContentType BodyType {get;}

See Also

IMessage Interface | Aspose.Email.Mail Namespace


Cc Property

Aspose.Email

IMessage.Cc Property

Gets CC recipients

ICollection Cc {get;}

See Also

IMessage Interface | Aspose.Email.Mail Namespace


Date Property

Aspose.Email

IMessage.Date Property

Gets the date and time when message was delivered

DateTime Date {get;}

See Also

IMessage Interface | Aspose.Email.Mail Namespace


From Property

Aspose.Email

IMessage.From Property

Gets or sets a from address

IMailAddress From {get; set;}

See Also

IMessage Interface | Aspose.Email.Mail Namespace


HtmlBody Property

Aspose.Email

IMessage.HtmlBody Property

Gets or sets a html formatted message body

string HtmlBody {get; set;}

See Also

IMessage Interface | Aspose.Email.Mail Namespace


Subject Property

Aspose.Email

IMessage.Subject Property

Gets or sets a message subject

string Subject {get; set;}

See Also

IMessage Interface | Aspose.Email.Mail Namespace


To Property

Aspose.Email

IMessage.To Property

Gets recipients

ICollection To {get;}

See Also

IMessage Interface | Aspose.Email.Mail Namespace


IMessage Methods

The methods of the IMessage interface are listed below. For a complete list of IMessage interface members, see the IMessage Members topic.

Public Instance Methods

Save Overloaded. Saves message to the specified file

See Also

IMessage Interface | Aspose.Email.Mail Namespace


Save Method

Aspose.Email

IMessage.Save Method

Saves message to the specified stream

Overload List

Saves message to the specified stream

void Save(Stream);

Saves message to the specified stream into one of the supported formats

void Save(Stream,MailMessageSaveType);

Saves message to the specified file

void Save(string);

Saves message to the specified file into one of the supported formats

void Save(string,MailMessageSaveType);

See Also

IMessage Interface | Aspose.Email.Mail Namespace


IMessage.Save Method (Stream)

Saves message to the specified stream

void Save(
Stream stream
);

Parameters

stream
A stream to save to

See Also

IMessage Interface | Aspose.Email.Mail Namespace | IMessage.Save Overload List


IMessage.Save Method (Stream, MailMessageSaveType)

Saves message to the specified stream into one of the supported formats

void Save(
Stream stream,
MailMessageSaveType saveFormat
);

Parameters

stream
A stream to save to
saveFormat
A format into which save message

See Also

IMessage Interface | Aspose.Email.Mail Namespace | IMessage.Save Overload List


IMessage.Save Method (String)

Saves message to the specified file

void Save(
string fileName
);

Parameters

fileName
A file name

See Also

IMessage Interface | Aspose.Email.Mail Namespace | IMessage.Save Overload List


IMessage.Save Method (String, MailMessageSaveType)

Saves message to the specified file into one of the supported formats

void Save(
string fileName,
MailMessageSaveType saveFormat
);

Parameters

fileName
A file name
saveFormat
A format into which save message

See Also

IMessage Interface | Aspose.Email.Mail Namespace | IMessage.Save Overload List


IMessageFormatter Interface

Provides a mechanism for retrieving an object to Message formatting.

For a list of all members of this type, see IMessageFormatter Members.

public interface IMessageFormatter

Types that implement IMessageFormatter

Type | Description
MhtMessageFormatter | Provides a default formatter for Mht conversion.

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

IMessageFormatter Members | Aspose.Email.Mail Namespace


IMessageFormatter Members

IMessageFormatter overview

Public Instance Properties

FormatTemplates Gets the format templates.

Public Instance Methods

Format Formats the specified message.

See Also

IMessageFormatter Interface | Aspose.Email.Mail Namespace


IMessageFormatter Properties

The properties of the IMessageFormatter interface are listed below. For a complete list of IMessageFormatter interface members, see the IMessageFormatter Members topic.

Public Instance Properties

FormatTemplates Gets the format templates.

See Also

IMessageFormatter Interface | Aspose.Email.Mail Namespace


FormatTemplates Property

Aspose.Email

IMessageFormatter.FormatTemplates Property

Gets the format templates.

StringDictionary FormatTemplates {get;}

Property Value

The format templates.

See Also

IMessageFormatter Interface | Aspose.Email.Mail Namespace


IMessageFormatter Methods

The methods of the IMessageFormatter interface are listed below. For a complete list of IMessageFormatter interface members, see the IMessageFormatter Members topic.

Public Instance Methods

Format Formats the specified message.

See Also

IMessageFormatter Interface | Aspose.Email.Mail Namespace


IMessageFormatter.Format Method

Formats the specified message.

void Format(
MailMessage message
);

Parameters

message
The message.

See Also

IMessageFormatter Interface | Aspose.Email.Mail Namespace


LinkedResource Class

Represents an embedded resource in a message.

For a list of all members of this type, see LinkedResource Members.

System.Object
Aspose.Email.Mail.AttachmentBase
Aspose.Email.Mail.LinkedResource

public class LinkedResource : AttachmentBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

LinkedResource Members | Aspose.Email.Mail Namespace


LinkedResource Members

LinkedResource overview

Public Static Methods

CreateLinkedResourceFromString Overloaded. Creates the linked resource from string.

Public Instance Constructors

LinkedResource Overloaded. Initializes a new instance of the LinkedResource class.

Public Instance Properties

ContentId (inherited from AttachmentBase) | Gets or sets the content id.
ContentLink | Gets or sets a URI that the resource must match.
ContentStream (inherited from AttachmentBase) | Gets or sets the content stream.
ContentType (inherited from AttachmentBase) | Gets or sets the type of the content.
TransferEncoding (inherited from AttachmentBase) | Gets or sets the transfer encoding.

Public Instance Methods

Dispose (inherited from AttachmentBase) | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save (inherited from AttachmentBase) | Overloaded. Saves the specified stream.
SaveRawContent (inherited from AttachmentBase) | Obsolete. Saves the content of the raw.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Dispose (inherited from AttachmentBase) | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetContentFromString (inherited from AttachmentBase) |

See Also

LinkedResource Class | Aspose.Email.Mail Namespace


LinkedResource Constructor

Initializes a new instance of the LinkedResource class.

Overload List

Initializes a new instance of the LinkedResource class.

public LinkedResource(Stream);

Initializes a new instance of the LinkedResource class.

public LinkedResource(Stream,ContentType);

Initializes a new instance of the LinkedResource class.

public LinkedResource(Stream,string);

Initializes a new instance of the LinkedResource class.

public LinkedResource(string);

Initializes a new instance of the LinkedResource class.

public LinkedResource(string,ContentType);

Initializes a new instance of the LinkedResource class.

public LinkedResource(string,string);

See Also

LinkedResource Class | Aspose.Email.Mail Namespace


LinkedResource Constructor (String)

Initializes a new instance of the LinkedResource class.

public LinkedResource(
string fileName
);

Parameters

fileName
The file name that holds the content for this resource.

See Also

LinkedResource Class | Aspose.Email.Mail Namespace | LinkedResource Constructor Overload List


LinkedResource Constructor (String, String)

Initializes a new instance of the LinkedResource class.

public LinkedResource(
string fileName,
string mediaType
);

Parameters

fileName
The file name that holds the content for this resource.
mediaType
Internet media type.

See Also

LinkedResource Class | Aspose.Email.Mail Namespace | LinkedResource Constructor Overload List


LinkedResource Constructor (String, ContentType)

Initializes a new instance of the LinkedResource class.

public LinkedResource(
string fileName,
ContentType contentType
);

Parameters

fileName
The file name that holds the content for this resource.
contentType
The type of content.

See Also

LinkedResource Class | Aspose.Email.Mail Namespace | LinkedResource Constructor Overload List


LinkedResource Constructor (Stream)

Initializes a new instance of the LinkedResource class.

public LinkedResource(
Stream contentStream
);

Parameters

contentStream
A stream that contains the content for this resource.

See Also

LinkedResource Class | Aspose.Email.Mail Namespace | LinkedResource Constructor Overload List


LinkedResource Constructor (Stream, String)

Initializes a new instance of the LinkedResource class.

public LinkedResource(
Stream contentStream,
string mediaType
);

Parameters

contentStream
A stream that contains the content for this resource.
mediaType
Internet media type.

See Also

LinkedResource Class | Aspose.Email.Mail Namespace | LinkedResource Constructor Overload List


LinkedResource Constructor (Stream, ContentType)

Initializes a new instance of the LinkedResource class.

public LinkedResource(
Stream contentStream,
ContentType contentType
);

Parameters

contentStream
A stream that contains the content for this resource.
contentType
The type of content.

See Also

LinkedResource Class | Aspose.Email.Mail Namespace | LinkedResource Constructor Overload List


LinkedResource Properties

The properties of the LinkedResource class are listed below. For a complete list of LinkedResource class members, see the LinkedResource Members topic.

Public Instance Properties

ContentId (inherited from AttachmentBase) | Gets or sets the content id.
ContentLink | Gets or sets a URI that the resource must match.
ContentStream (inherited from AttachmentBase) | Gets or sets the content stream.
ContentType (inherited from AttachmentBase) | Gets or sets the type of the content.
TransferEncoding (inherited from AttachmentBase) | Gets or sets the transfer encoding.

See Also

LinkedResource Class | Aspose.Email.Mail Namespace


ContentLink Property

Aspose.Email

LinkedResource.ContentLink Property

Gets or sets a URI that the resource must match.

public Uri ContentLink {get; set;}

See Also

LinkedResource Class | Aspose.Email.Mail Namespace


LinkedResource Methods

The methods of the LinkedResource class are listed below. For a complete list of LinkedResource class members, see the LinkedResource Members topic.

Public Static Methods

CreateLinkedResourceFromString Overloaded. Creates the linked resource from string.

Public Instance Methods

Dispose (inherited from AttachmentBase) | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save (inherited from AttachmentBase) | Overloaded. Saves the specified stream.
SaveRawContent (inherited from AttachmentBase) | Obsolete. Saves the content of the raw.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Dispose (inherited from AttachmentBase) | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
SetContentFromString (inherited from AttachmentBase) |

See Also

LinkedResource Class | Aspose.Email.Mail Namespace


CreateLinkedResourceFromString Method

Aspose.Email

LinkedResource.CreateLinkedResourceFromString Method

Creates the linked resource from string.

Overload List

Creates the linked resource from string.

public static LinkedResource CreateLinkedResourceFromString(string);

Creates the linked resource from string.

public static LinkedResource CreateLinkedResourceFromString(string,ContentType);

Creates the linked resource from string.

public static LinkedResource CreateLinkedResourceFromString(string,Encoding,string);

See Also

LinkedResource Class | Aspose.Email.Mail Namespace


LinkedResource.CreateLinkedResourceFromString Method (String)

Creates the linked resource from string.

public static LinkedResource CreateLinkedResourceFromString(
string content
);

Parameters

content
A string that contains the resource to be included in the email attachment.

Return Value

A LinkedResource object that contains the embedded resource.

See Also

LinkedResource Class | Aspose.Email.Mail Namespace | LinkedResource.CreateLinkedResourceFromString Overload List


LinkedResource.CreateLinkedResourceFromString Method (String, ContentType)

Creates the linked resource from string.

public static LinkedResource CreateLinkedResourceFromString(
string content,
ContentType contentType
);

Parameters

content
A string that contains the resource to be included in the email attachment.
contentType
The type of the content.

Return Value

A LinkedResource object that contains the embedded resource.

See Also

LinkedResource Class | Aspose.Email.Mail Namespace | LinkedResource.CreateLinkedResourceFromString Overload List


LinkedResource.CreateLinkedResourceFromString Method (String, Encoding, String)

Creates the linked resource from string.

public static LinkedResource CreateLinkedResourceFromString(
string content,
Encoding contentEncoding,
string mediaType
);

Parameters

content
A string that contains the resource to be included in the email attachment.
contentEncoding
The content encoding.
mediaType
The MIME media type of the content.

Return Value

A LinkedResource object that contains the embedded resource.

See Also

LinkedResource Class | Aspose.Email.Mail Namespace | LinkedResource.CreateLinkedResourceFromString Overload List


LinkedResourceCollection Class

Represents a collection of LinkedResource objects

For a list of all members of this type, see LinkedResourceCollection Members.

System.Object
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Mail.LinkedResource, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]]
Aspose.Email.Mail.LinkedResourceCollection

public sealed class LinkedResourceCollection : Collection`1, IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

LinkedResourceCollection Members | Aspose.Email.Mail Namespace


LinkedResourceCollection Members

LinkedResourceCollection overview

Public Instance Properties

Count (inherited from 0, Culture=neutral, PublicKeyToken=null]])
Item (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

LinkedResourceCollection Class | Aspose.Email.Mail Namespace


LinkedResourceCollection Methods

The methods of the LinkedResourceCollection class are listed below. For a complete list of LinkedResourceCollection class members, see the LinkedResourceCollection Members topic.

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

LinkedResourceCollection Class | Aspose.Email.Mail Namespace


LinkedResourceCollection.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

public void Dispose();

Implements

IDisposable.Dispose

See Also

LinkedResourceCollection Class | Aspose.Email.Mail Namespace


MailAddress Class

Represents the address of a message.

For a list of all members of this type, see MailAddress Members.

System.Object
Aspose.Email.Mail.MailAddress

public class MailAddress : IMailAddress

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MailAddress Members | Aspose.Email.Mail Namespace


MailAddress Members

MailAddress overview

Public Static Type Conversions

Implicit MailAddressCollection to MailAddress Conversion | Performs an implicit conversion from MailAddressCollection to MailAddress.
Implicit String to MailAddress Conversion | Performs an implicit conversion from String to MailAddress.

Public Instance Constructors

MailAddress Overloaded. Initializes a new instance of the MailAddress class.

Public Instance Properties

Address | Gets or sets the e-mail address.
Count | Contains count of mail addresses.
DisplayName | Gets or sets a display name.
Host | Gets the host portion of the address.
Item | Gets the element at the specified index.
User | Gets the username.

Public Instance Methods

Add | Obsolete. Adds the specified address.
Equals | Determines whether the specified Object is equal to this instance.
GetHashCode | Returns a hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents this instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MailAddress Class | Aspose.Email.Mail Namespace


MailAddress Constructor

Initializes a new instance of the MailAddress class.

Overload List

Initializes a new instance of the MailAddress class.

public MailAddress(string);

Initializes a new instance of the MailAddress class.

public MailAddress(string,bool);

Initializes a new instance of the MailAddress class.

public MailAddress(string,string);

Initializes a new instance of the MailAddress class.

public MailAddress(string,string,bool);

Initializes a new instance of the MailAddress class.

public MailAddress(string,string,Encoding);

Initializes a new instance of the MailAddress class.

public MailAddress(string,string,Encoding,bool);

See Also

MailAddress Class | Aspose.Email.Mail Namespace


MailAddress Constructor (String, Boolean)

Initializes a new instance of the MailAddress class.

public MailAddress(
string address,
bool ignoreSmtpCheck
);

Parameters

address
The mail address.
ignoreSmtpCheck
if set to true then SMTP check will be omitted.

See Also

MailAddress Class | Aspose.Email.Mail Namespace | MailAddress Constructor Overload List


MailAddress Constructor (String, String, Boolean)

Initializes a new instance of the MailAddress class.

public MailAddress(
string address,
string displayName,
bool ignoreSmtpCheck
);

Parameters

address
The mail address.
displayName
The display name.
ignoreSmtpCheck
if set to true then SMTP check will be omitted.

See Also

MailAddress Class | Aspose.Email.Mail Namespace | MailAddress Constructor Overload List


MailAddress Constructor (String, String, Encoding)

Initializes a new instance of the MailAddress class.

public MailAddress(
string address,
string displayName,
Encoding displayNameEncoding
);

Parameters

address
The mail address.
displayName
The display name.
displayNameEncoding
The display name encoding.

See Also

MailAddress Class | Aspose.Email.Mail Namespace | MailAddress Constructor Overload List


MailAddress Constructor (String, String, Encoding, Boolean)

Initializes a new instance of the MailAddress class.

public MailAddress(
string address,
string displayName,
Encoding displayNameEncoding,
bool ignoreSmtpCheck
);

Parameters

address
The mail address.
displayName
The display name.
displayNameEncoding
The display name encoding.
ignoreSmtpCheck
if set to true then SMTP check will be omitted.

See Also

MailAddress Class | Aspose.Email.Mail Namespace | MailAddress Constructor Overload List


MailAddress Constructor (String)

Initializes a new instance of the MailAddress class.

public MailAddress(
string address
);

Parameters

address
The mail address.

See Also

MailAddress Class | Aspose.Email.Mail Namespace | MailAddress Constructor Overload List


MailAddress Constructor (String, String)

Initializes a new instance of the MailAddress class.

public MailAddress(
string address,
string displayName
);

Parameters

address
The mail address.
displayName
The display name.

See Also

MailAddress Class | Aspose.Email.Mail Namespace | MailAddress Constructor Overload List


MailAddress Properties

The properties of the MailAddress class are listed below. For a complete list of MailAddress class members, see the MailAddress Members topic.

Public Instance Properties

Address | Gets or sets the e-mail address.
Count | Contains count of mail addresses.
DisplayName | Gets or sets a display name.
Host | Gets the host portion of the address.
Item | Gets the element at the specified index.
User | Gets the username.

See Also

MailAddress Class | Aspose.Email.Mail Namespace


Address Property

Aspose.Email

MailAddress.Address Property

Gets or sets the e-mail address.

public string Address {get; set;}

Property Value

A String that contains the e-mail address.

Implements

IMailAddress.Address

See Also

MailAddress Class | Aspose.Email.Mail Namespace


Count Property

Aspose.Email

MailAddress.Count Property

Contains count of mail addresses.

public int Count {get;}

See Also

MailAddress Class | Aspose.Email.Mail Namespace


DisplayName Property

Aspose.Email

MailAddress.DisplayName Property

Gets or sets a display name.

public string DisplayName {get; set;}

Property Value

A String that contains the display name.

Implements

IMailAddress.DisplayName

See Also

MailAddress Class | Aspose.Email.Mail Namespace


Host Property

Aspose.Email

MailAddress.Host Property

Gets the host portion of the address.

public string Host {get;}

Property Value

A String that contains the name of the host.

See Also

MailAddress Class | Aspose.Email.Mail Namespace


Item Property

Aspose.Email

MailAddress.Item Property

Gets the element at the specified index.

public MailAddress this[
int i
] {get;}

Parameters

i
The zero-based index of the element to get or set.

See Also

MailAddress Class | Aspose.Email.Mail Namespace


User Property

Aspose.Email

MailAddress.User Property

Gets the username.

public string User {get;}

Property Value

A String that contains the user name.

See Also

MailAddress Class | Aspose.Email.Mail Namespace


MailAddress Methods

The methods of the MailAddress class are listed below. For a complete list of MailAddress class members, see the MailAddress Members topic.

Public Instance Methods

Add | Obsolete. Adds the specified address.
Equals | Determines whether the specified Object is equal to this instance.
GetHashCode | Returns a hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents this instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MailAddress Class | Aspose.Email.Mail Namespace


MailAddress.Add Method

NOTE: This method is now obsolete.

Adds the specified address.

public void Add(
MailAddress address
);

Parameters

address
The address.

See Also

MailAddress Class | Aspose.Email.Mail Namespace


MailAddress.Equals Method

Determines whether the specified Object is equal to this instance.

public override bool Equals(
object value
);

Parameters

value
The Object to compare with this instance.

Return Value

true if the specified Object is equal to this instance; otherwise, false.

See Also

MailAddress Class | Aspose.Email.Mail Namespace


MailAddress.GetHashCode Method

Returns a hash code for this instance.

public override int GetHashCode();

Return Value

A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.

See Also

MailAddress Class | Aspose.Email.Mail Namespace


MailAddress.ToString Method

Returns a String that represents this instance.

public override string ToString();

Return Value

A String that represents this instance.

See Also

MailAddress Class | Aspose.Email.Mail Namespace


MailAddress Type Conversions

The type conversions of the MailAddress class are listed below. For a complete list of MailAddress class members, see the MailAddress Members topic.

Public Static Type Conversions

Implicit MailAddressCollection to MailAddress Conversion | Performs an implicit conversion from MailAddressCollection to MailAddress.
Implicit String to MailAddress Conversion | Performs an implicit conversion from String to MailAddress.

See Also

MailAddress Class | MailAddress Members | Aspose.Email.Mail Namespace


MailAddress Implicit MailAddressCollection to MailAddress Conversion

Performs an implicit conversion from MailAddressCollection to MailAddress.

public static implicit operator MailAddress(
MailAddressCollection addresses
);

Parameters

addresses
The address collection.

Return Value

The result of the conversion.

See Also

MailAddress Class | Aspose.Email.Mail Namespace


MailAddress Implicit String to MailAddress Conversion

Performs an implicit conversion from String to MailAddress.

public static implicit operator MailAddress(
string address
);

Parameters

address
The address.

Return Value

The result of the conversion.

See Also

MailAddress Class | Aspose.Email.Mail Namespace


MailAddressCollection Class

Represents a collection of MailAddress objects.

For a list of all members of this type, see MailAddressCollection Members.

System.Object
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Mail.MailAddress, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]]
Aspose.Email.Mail.MailAddressCollection

public class MailAddressCollection : Collection`1

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MailAddressCollection Members | Aspose.Email.Mail Namespace


MailAddressCollection Members

MailAddressCollection overview

Public Static Type Conversions

Implicit MailAddress to MailAddressCollection Conversion | Performs an implicit conversion from MailAddress to MailAddressCollection.
Implicit String to MailAddressCollection Conversion | Performs an implicit conversion from String to MailAddressCollection.

Public Instance Constructors

MailAddressCollection Constructor Initializes a new instance of the MailAddressCollection class.

Public Instance Properties

Count (inherited from 0, Culture=neutral, PublicKeyToken=null]])
Item (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Public Instance Methods

Add | Overloaded. Add a list of e-mail addresses to the collection.
AddRange | Overloaded. Adds addresses to collection
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Copy | Copies this instance.
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString | Returns a String that represents this instance.

Protected Instance Properties

Items (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Protected Instance Methods

ClearItems (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
InsertItem |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RemoveItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
SetItem |

See Also

MailAddressCollection Class | Aspose.Email.Mail Namespace


MailAddressCollection Constructor

Initializes a new instance of the MailAddressCollection class.

public MailAddressCollection();

See Also

MailAddressCollection Class | Aspose.Email.Mail Namespace


MailAddressCollection Methods

The methods of the MailAddressCollection class are listed below. For a complete list of MailAddressCollection class members, see the MailAddressCollection Members topic.

Public Instance Methods

Add | Overloaded. Add a list of e-mail addresses to the collection.
AddRange | Overloaded. Adds addresses to collection
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Copy | Copies this instance.
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString | Returns a String that represents this instance.

Protected Instance Methods

ClearItems (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
InsertItem |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RemoveItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
SetItem |

See Also

MailAddressCollection Class | Aspose.Email.Mail Namespace


Add Method

Aspose.Email

MailAddressCollection.Add Method

Add a MailAddress to the collection.

Overload List

Add a MailAddress to the collection.

new public void Add(MailAddress);

Add a list of e-mail addresses to the collection.

public void Add(string);

See Also

MailAddressCollection Class | Aspose.Email.Mail Namespace


MailAddressCollection.Add Method (MailAddress)

Add a MailAddress to the collection.

new public void Add(
MailAddress address
);

Parameters

address
The MailAddress

Implements

ICollection`1.Add

See Also

MailAddressCollection Class | Aspose.Email.Mail Namespace | MailAddressCollection.Add Overload List


MailAddressCollection.Add Method (String)

Add a list of e-mail addresses to the collection.

public void Add(
string addresses
);

Parameters

addresses
An address list. Addresses must be separated with a comma character.

See Also

MailAddressCollection Class | Aspose.Email.Mail Namespace | MailAddressCollection.Add Overload List


AddRange Method

Aspose.Email

MailAddressCollection.AddRange Method

Adds addresses to collection

Overload List

Adds addresses to collection

public void AddRange(MailAddressCollection);

Adds addresses to collection

public void AddRange(MailAddress});

See Also

MailAddressCollection Class | Aspose.Email.Mail Namespace


MailAddressCollection.AddRange Method (MailAddressCollection)

Adds addresses to collection

public void AddRange(
MailAddressCollection addresses
);

Parameters

addresses
Collection of mail addresses

See Also

MailAddressCollection Class | Aspose.Email.Mail Namespace | MailAddressCollection.AddRange Overload List


MailAddressCollection.AddRange Method (MailAddress})

Adds addresses to collection

public void AddRange(
IEnumerable<MailAddress> addresses
);

Parameters

addresses
Enumeration of mail addresses

See Also

MailAddressCollection Class | Aspose.Email.Mail Namespace | MailAddressCollection.AddRange Overload List


MailAddressCollection.Copy Method

Copies this instance.

public MailAddressCollection Copy();

Return Value

See Also

MailAddressCollection Class | Aspose.Email.Mail Namespace


MailAddressCollection.InsertItem Method

protected override void InsertItem(
int index,
MailAddress item
);

See Also

MailAddressCollection Class | Aspose.Email.Mail Namespace


MailAddressCollection.SetItem Method

protected override void SetItem(
int index,
MailAddress item
);

See Also

MailAddressCollection Class | Aspose.Email.Mail Namespace


MailAddressCollection.ToString Method

Returns a String that represents this instance.

public override string ToString();

Return Value

A String that represents this instance.

See Also

MailAddressCollection Class | Aspose.Email.Mail Namespace


MailAddressCollection Type Conversions

The type conversions of the MailAddressCollection class are listed below. For a complete list of MailAddressCollection class members, see the MailAddressCollection Members topic.

Public Static Type Conversions

Implicit MailAddress to MailAddressCollection Conversion | Performs an implicit conversion from MailAddress to MailAddressCollection.
Implicit String to MailAddressCollection Conversion | Performs an implicit conversion from String to MailAddressCollection.

See Also

MailAddressCollection Class | MailAddressCollection Members | Aspose.Email.Mail Namespace


MailAddressCollection Implicit MailAddress to MailAddressCollection Conversion

Performs an implicit conversion from MailAddress to MailAddressCollection.

public static implicit operator MailAddressCollection(
MailAddress address
);

Parameters

address
The address.

Return Value

The result of the conversion.

See Also

MailAddressCollection Class | Aspose.Email.Mail Namespace


MailAddressCollection Implicit String to MailAddressCollection Conversion

Performs an implicit conversion from String to MailAddressCollection.

public static implicit operator MailAddressCollection(
string addresses
);

Parameters

addresses
The address list.

Return Value

The result of the conversion.

See Also

MailAddressCollection Class | Aspose.Email.Mail Namespace


MailboxConverter Class

Provides mailbox conversion routines.

For a list of all members of this type, see MailboxConverter Members.

System.Object
Aspose.Email.Mail.MailboxConverter

public abstract sealed class MailboxConverter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MailboxConverter Members | Aspose.Email.Mail Namespace


MailboxConverter Members

MailboxConverter overview

Public Static Methods

ConvertPersonalStorageToMbox Overloaded. Converts the PersonalStorage to mbox format using given path.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MailboxConverter Class | Aspose.Email.Mail Namespace


MailboxConverter Methods

The methods of the MailboxConverter class are listed below. For a complete list of MailboxConverter class members, see the MailboxConverter Members topic.

Public Static Methods

ConvertPersonalStorageToMbox Overloaded. Converts the PersonalStorage to mbox format using given path.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MailboxConverter Class | Aspose.Email.Mail Namespace


ConvertPersonalStorageToMbox Method

Aspose.Email

MailboxConverter.ConvertPersonalStorageToMbox Method

Converts the PersonalStorage to mbox format using given MboxStorageWriter.

Overload List

Converts the PersonalStorage to mbox format using given MboxStorageWriter.

public static void ConvertPersonalStorageToMbox(PersonalStorage,MboxStorageWriter,MessageAcceptanceCallback);

Converts the PersonalStorage to mbox format using given path.

public static void ConvertPersonalStorageToMbox(PersonalStorage,string,MessageAcceptanceCallback);

See Also

MailboxConverter Class | Aspose.Email.Mail Namespace


MailboxConverter.ConvertPersonalStorageToMbox Method (PersonalStorage, MboxStorageWriter, MessageAcceptanceCallback)

Converts the PersonalStorage to mbox format using given MboxStorageWriter.

public static void ConvertPersonalStorageToMbox(
PersonalStorage personalStorage,
MboxStorageWriter mboxStorageWriter,
MessageAcceptanceCallback acceptanceCallback
);

Parameters

personalStorage
The personal storage.
mboxStorageWriter
The mbox storage writer.
acceptanceCallback
The acceptance callback, can be null.

Remarks

Resulting mbox storage will contain only one plain inbox folder with all messages, if you have to preserve the original structure of the storage, use XXX_method instead.

Exceptions

Exception Type | Condition
ArgumentNullException | If personalStorage is null.
ArgumentNullException | If mboxStorageWriter is null.

See Also

MailboxConverter Class | Aspose.Email.Mail Namespace | MailboxConverter.ConvertPersonalStorageToMbox Overload List


MailboxConverter.ConvertPersonalStorageToMbox Method (PersonalStorage, String, MessageAcceptanceCallback)

Converts the PersonalStorage to mbox format using given path.

public static void ConvertPersonalStorageToMbox(
PersonalStorage personalStorage,
string storagePath,
MessageAcceptanceCallback acceptanceCallback
);

Parameters

personalStorage
The personal storage.
storagePath
The path to save personalStorage structure to.
acceptanceCallback
The acceptance callback, can be null.

Remarks

Resulting folder will contain an exact copy of the personalStorage e.g. directory tree will be recreated on disk.

Exceptions

Exception Type | Condition
ArgumentNullException | If personalStorage is null.
ArgumentNullException | If storagePath is null.

See Also

MailboxConverter Class | Aspose.Email.Mail Namespace | MailboxConverter.ConvertPersonalStorageToMbox Overload List


MailException Class

Represents the exception that is thrown when the mail message processing.

For a list of all members of this type, see MailException Members.

System.Object
System.Exception
Aspose.Email.Mail.MailException

public class MailException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MailException Members | Aspose.Email.Mail Namespace


MailException Members

MailException overview

Public Instance Constructors

MailException Overloaded. Initializes a new instance of the MailException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

MailException Overloaded. Initializes a new instance of the MailException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MailException Class | Aspose.Email.Mail Namespace


MailException Constructor

Initializes a new instance of the MailException class.

Overload List

Initializes a new instance of the MailException class.

public MailException();

Initializes a new instance of the MailException class.

protected MailException(SerializationInfo,StreamingContext);

Initializes a new instance of the MailException class.

public MailException(string);

Initializes a new instance of the MailException class.

public MailException(string,Exception);

See Also

MailException Class | Aspose.Email.Mail Namespace


MailException Constructor ()

Initializes a new instance of the MailException class.

public MailException();

See Also

MailException Class | Aspose.Email.Mail Namespace | MailException Constructor Overload List


MailException Constructor (String)

Initializes a new instance of the MailException class.

public MailException(
string message
);

Parameters

message
The message.

See Also

MailException Class | Aspose.Email.Mail Namespace | MailException Constructor Overload List


MailException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the MailException class.

protected MailException(
SerializationInfo info,
StreamingContext context
);

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception Type | Condition
ArgumentNullException | The info parameter is null.
SerializationException | The class name is null or HResult is zero (0).

See Also

MailException Class | Aspose.Email.Mail Namespace | MailException Constructor Overload List


MailException Constructor (String, Exception)

Initializes a new instance of the MailException class.

public MailException(
string message,
Exception inner
);

Parameters

message
The message.
inner
The inner.

See Also

MailException Class | Aspose.Email.Mail Namespace | MailException Constructor Overload List


MailMessage Class

Represents an e-mail message. It allows to access message properties, ex. subject, body, sender and recipients addreses, etc. Also it can be sent and delivered by means of supported mail protocols.

For a list of all members of this type, see MailMessage Members.

System.Object
Aspose.Email.Mail.MailMessage

public class MailMessage : IDisposable, IPreferredTextEncodingProvider, IMessage, ISerializable, 0, Culture=neutral, PublicKeyToken=null]], IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MailMessage Members | Aspose.Email.Mail Namespace


MailMessage Members

MailMessage overview

Public Static Methods

CheckSignature | Overloaded. Checks the signature of the specified eml file.
Load | Overloaded. Load message from file
LoadFromTnef | Overloaded. Loads message from Transport Neutral Encapsulation Format (TNEF) data structure
ValidateMessage | Overloaded. Validate eml message for corresponding to mime specification.

Public Instance Constructors

MailMessage Overloaded. Initializes a new instance of the MailMessage class.

Public Instance Properties

AlternateViews | Gets the collection of alternate views of message
Attachments | Gets the collection of attachments of message
Bcc | Gets or sets the address collection that contains the BCC recipients of message
Body | Gets or sets the message body
BodyEncoding | Gets or sets encoding of body
BodyType | Gets the type of the body.
CC | Gets or sets the address collection that contains the CC recipients
Date | Gets or sets the date of message
DeliveryNotificationOptions | Gets or sets the delivery notifications
From | Gets or sets the from address
Headers | Gets headers collection of message
HtmlBody | Gets or sets html body
IsBodyHtml | Gets or sets a value indicating whether the message body is in Html
IsReadOnly | Gets a value indicating whether the message is read only
IsSigned | Gets a value indicating whether the message is signed
LinkedResources | Gets the collection of linked resources of message
MessageId | Gets or sets the message id
PreferredTextEncoding | Gets or sets preferred encoding for all text properties
PreserveOriginalBoundaries | Defines whether need keep original boundaries in mail message when saving or not.
PreserveOriginalDates | Gets or sets a value indicating whether it is necessary to generate new saving and modification dates when saving a message
Priority | Gets or sets the priority of message
ReplyTo | Obsolete. Gets or sets the ReplyTo address
ReplyToList | Gets or sets the list of addresses to reply to for the mail message
ReversePath | Gets or sets ReversePath address
Sender | Gets or sets sender address
Sensitivity | Gets or sets the sensitivity of message
Subject | Gets or sets the subject line
SubjectEncoding | Gets or sets the encoding of subject
TextBody | Gets or sets plain text body
TimeZoneOffset | Gets or sets the Coordinated Universal Time (UTC) offset for the message dates. This property defines the time zone difference, between the local time and UTC.
To | Gets or sets the address collection that contains the recipients of message
WriteHeaderToMht | Obsolete. Gets or sets a value indicating whether header information should be written if message is being saved in mht format. Default value is true.
WriteOutlineAttachmentsToMht | Obsolete. Gets or sets a value indicating whether outline attachments should be written if message is being saved in mht format. Default value is true.
XMailer | Gets or sets the X-Mailer the software that created the e-mail message

Public Instance Methods

AddAlternateView | Add an alternate view to message
AddAttachment | Add an attachment to message
AttachSignature | Overloaded. Creates a signed message. Creates a read-only copy of the specified MailMessage and adds a digital signature to it.
CheckSignature | Overloaded. Check signature
Clone | Clones this instance
Decrypt | Overloaded. Decrypts this message
Dispose | Overloaded. Releases all resources used by the MailMessage
Encrypt | Overloaded. Encrypts this message
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that iterates through a collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
GetType (inherited from Object) | Gets the Type of the current instance.
Import | Imports message from stream
RecomposeTnefContent | Composes the TNEF content. Note, that tnef attachment is composed if a message initially contained TNEF and was loaded without FileCompatibilityMode.PreserveTnefAttachments flag, That is this method doesn't create tnef message out of the regular one.
RemoveSignature | Remove signature
Save | Overloaded. Save message as a file
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

MailMessage Overloaded. Initializes a new instance of the MailMessage class.

Protected Instance Methods

Dispose | Overloaded. Releases unmanaged and - optionally - managed resources
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MailMessage Class | Aspose.Email.Mail Namespace


MailMessage Constructor

Initializes a new instance of the MailMessage class

Overload List

Initializes a new instance of the MailMessage class

public MailMessage();

Initializes a new instance of the MailMessage class

public MailMessage(MailAddress,MailAddress);

Initializes a new instance of the MailMessage class.

protected MailMessage(SerializationInfo,StreamingContext);

Initializes a new instance of the MailMessage class

public MailMessage(string,string);

Initializes a new instance of the MailMessage class

public MailMessage(string,string,string,string);

See Also

MailMessage Class | Aspose.Email.Mail Namespace


MailMessage Constructor (String, String)

Initializes a new instance of the MailMessage class

public MailMessage(
string from,
string to
);

Parameters

from
Sender address
to
Recipient address

See Also

MailMessage Class | Aspose.Email.Mail Namespace | MailMessage Constructor Overload List


MailMessage Constructor ()

Initializes a new instance of the MailMessage class

public MailMessage();

See Also

MailMessage Class | Aspose.Email.Mail Namespace | MailMessage Constructor Overload List


MailMessage Constructor (String, String, String, String)

Initializes a new instance of the MailMessage class

public MailMessage(
string from,
string to,
string subject,
string body
);

Parameters

from
Sender address
to
Recipient address
subject
Message subject
body
Message body

See Also

MailMessage Class | Aspose.Email.Mail Namespace | MailMessage Constructor Overload List


MailMessage Constructor (MailAddress, MailAddress)

Initializes a new instance of the MailMessage class

public MailMessage(
MailAddress from,
MailAddress to
);

Parameters

from
Sender address
to
Recipient address

See Also

MailMessage Class | Aspose.Email.Mail Namespace | MailMessage Constructor Overload List


MailMessage Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the MailMessage class.

protected MailMessage(
SerializationInfo info,
StreamingContext context
);

Parameters

info
The SerializationInfo.
context
The StreamingContext.

See Also

MailMessage Class | Aspose.Email.Mail Namespace | MailMessage Constructor Overload List


MailMessage Properties

The properties of the MailMessage class are listed below. For a complete list of MailMessage class members, see the MailMessage Members topic.

Public Instance Properties

AlternateViews | Gets the collection of alternate views of message
Attachments | Gets the collection of attachments of message
Bcc | Gets or sets the address collection that contains the BCC recipients of message
Body | Gets or sets the message body
BodyEncoding | Gets or sets encoding of body
BodyType | Gets the type of the body.
CC | Gets or sets the address collection that contains the CC recipients
Date | Gets or sets the date of message
DeliveryNotificationOptions | Gets or sets the delivery notifications
From | Gets or sets the from address
Headers | Gets headers collection of message
HtmlBody | Gets or sets html body
IsBodyHtml | Gets or sets a value indicating whether the message body is in Html
IsReadOnly | Gets a value indicating whether the message is read only
IsSigned | Gets a value indicating whether the message is signed
LinkedResources | Gets the collection of linked resources of message
MessageId | Gets or sets the message id
PreferredTextEncoding | Gets or sets preferred encoding for all text properties
PreserveOriginalBoundaries | Defines whether need keep original boundaries in mail message when saving or not.
PreserveOriginalDates | Gets or sets a value indicating whether it is necessary to generate new saving and modification dates when saving a message
Priority | Gets or sets the priority of message
ReplyTo | Obsolete. Gets or sets the ReplyTo address
ReplyToList | Gets or sets the list of addresses to reply to for the mail message
ReversePath | Gets or sets ReversePath address
Sender | Gets or sets sender address
Sensitivity | Gets or sets the sensitivity of message
Subject | Gets or sets the subject line
SubjectEncoding | Gets or sets the encoding of subject
TextBody | Gets or sets plain text body
TimeZoneOffset | Gets or sets the Coordinated Universal Time (UTC) offset for the message dates. This property defines the time zone difference, between the local time and UTC.
To | Gets or sets the address collection that contains the recipients of message
WriteHeaderToMht | Obsolete. Gets or sets a value indicating whether header information should be written if message is being saved in mht format. Default value is true.
WriteOutlineAttachmentsToMht | Obsolete. Gets or sets a value indicating whether outline attachments should be written if message is being saved in mht format. Default value is true.
XMailer | Gets or sets the X-Mailer the software that created the e-mail message

See Also

MailMessage Class | Aspose.Email.Mail Namespace


AlternateViews Property

Aspose.Email

MailMessage.AlternateViews Property

Gets the collection of alternate views of message

public virtual AlternateViewCollection AlternateViews {get;}

See Also

MailMessage Class | Aspose.Email.Mail Namespace


Attachments Property

Aspose.Email

MailMessage.Attachments Property

Gets the collection of attachments of message

public virtual AttachmentCollection Attachments {get;}

See Also

MailMessage Class | Aspose.Email.Mail Namespace


Bcc Property

Aspose.Email

MailMessage.Bcc Property

Gets or sets the address collection that contains the BCC recipients of message

public virtual MailAddressCollection Bcc {get; set;}

See Also

MailMessage Class | Aspose.Email.Mail Namespace


Body Property

Aspose.Email

MailMessage.Body Property

Gets or sets the message body

public virtual string Body {get; set;}

Implements

IMessage.Body

See Also

MailMessage Class | Aspose.Email.Mail Namespace


BodyEncoding Property

Aspose.Email

MailMessage.BodyEncoding Property

Gets or sets encoding of body

public virtual Encoding BodyEncoding {get; set;}

See Also

MailMessage Class | Aspose.Email.Mail Namespace


BodyType Property

Aspose.Email

MailMessage.BodyType Property

Gets the type of the body.

public BodyContentType BodyType {get;}

Implements

IMessage.BodyType

See Also

MailMessage Class | Aspose.Email.Mail Namespace


CC Property

Aspose.Email

MailMessage.CC Property

Gets or sets the address collection that contains the CC recipients

public virtual MailAddressCollection CC {get; set;}

See Also

MailMessage Class | Aspose.Email.Mail Namespace


Date Property

Aspose.Email

MailMessage.Date Property

Gets or sets the date of message

public virtual DateTime Date {get; set;}

Implements

IMessage.Date

See Also

MailMessage Class | Aspose.Email.Mail Namespace


DeliveryNotificationOptions Property

Aspose.Email

MailMessage.DeliveryNotificationOptions Property

Gets or sets the delivery notifications

public virtual DeliveryNotificationOptions DeliveryNotificationOptions {get; set;}

See Also

MailMessage Class | Aspose.Email.Mail Namespace


From Property

Aspose.Email

MailMessage.From Property

Gets or sets the from address

public virtual MailAddress From {get; set;}

See Also

MailMessage Class | Aspose.Email.Mail Namespace


Headers Property

Aspose.Email

MailMessage.Headers Property

Gets headers collection of message

public virtual HeaderCollection Headers {get;}

See Also

MailMessage Class | Aspose.Email.Mail Namespace


HtmlBody Property

Aspose.Email

MailMessage.HtmlBody Property

Gets or sets html body

public virtual string HtmlBody {get; set;}

Implements

IMessage.HtmlBody

See Also

MailMessage Class | Aspose.Email.Mail Namespace


IsBodyHtml Property

Aspose.Email

MailMessage.IsBodyHtml Property

Gets or sets a value indicating whether the message body is in Html

public virtual bool IsBodyHtml {get; set;}

See Also

MailMessage Class | Aspose.Email.Mail Namespace


IsReadOnly Property

Aspose.Email

MailMessage.IsReadOnly Property

Gets a value indicating whether the message is read only

public virtual bool IsReadOnly {get;}

See Also

MailMessage Class | Aspose.Email.Mail Namespace


IsSigned Property

Aspose.Email

MailMessage.IsSigned Property

Gets a value indicating whether the message is signed

public virtual bool IsSigned {get;}

See Also

MailMessage Class | Aspose.Email.Mail Namespace


LinkedResources Property

Aspose.Email

MailMessage.LinkedResources Property

Gets the collection of linked resources of message

public virtual LinkedResourceCollection LinkedResources {get;}

See Also

MailMessage Class | Aspose.Email.Mail Namespace


MessageId Property

Aspose.Email

MailMessage.MessageId Property

Gets or sets the message id

public virtual string MessageId {get; set;}

See Also

MailMessage Class | Aspose.Email.Mail Namespace


PreferredTextEncoding Property

Aspose.Email

MailMessage.PreferredTextEncoding Property

Gets or sets preferred encoding for all text properties

public Encoding PreferredTextEncoding {get; set;}

Implements

IPreferredTextEncodingProvider.PreferredTextEncoding

See Also

MailMessage Class | Aspose.Email.Mail Namespace


PreserveOriginalBoundaries Property

Aspose.Email

MailMessage.PreserveOriginalBoundaries Property

Defines whether need keep original boundaries in mail message when saving or not.

public bool PreserveOriginalBoundaries {get; set;}

See Also

MailMessage Class | Aspose.Email.Mail Namespace


PreserveOriginalDates Property

Aspose.Email

MailMessage.PreserveOriginalDates Property

Gets or sets a value indicating whether it is necessary to generate new saving and modification dates when saving a message

public virtual bool PreserveOriginalDates {get; set;}

See Also

MailMessage Class | Aspose.Email.Mail Namespace


Priority Property

Aspose.Email

MailMessage.Priority Property

Gets or sets the priority of message

public virtual MailPriority Priority {get; set;}

See Also

MailMessage Class | Aspose.Email.Mail Namespace


ReplyTo Property

Aspose.Email

MailMessage.ReplyTo Property

NOTE: This property is now obsolete.

Please use ReplyToList instead

Gets or sets the ReplyTo address

public virtual MailAddress ReplyTo {get; set;}

See Also

MailMessage Class | Aspose.Email.Mail Namespace


ReplyToList Property

Aspose.Email

MailMessage.ReplyToList Property

Gets or sets the list of addresses to reply to for the mail message

public virtual MailAddressCollection ReplyToList {get; set;}

See Also

MailMessage Class | Aspose.Email.Mail Namespace


ReversePath Property

Aspose.Email

MailMessage.ReversePath Property

Gets or sets ReversePath address

public virtual MailAddress ReversePath {get; set;}

See Also

MailMessage Class | Aspose.Email.Mail Namespace


Sender Property

Aspose.Email

MailMessage.Sender Property

Gets or sets sender address

public virtual MailAddress Sender {get; set;}

See Also

MailMessage Class | Aspose.Email.Mail Namespace


Sensitivity Property

Aspose.Email

MailMessage.Sensitivity Property

Gets or sets the sensitivity of message

public virtual MailSensitivity Sensitivity {get; set;}

See Also

MailMessage Class | Aspose.Email.Mail Namespace


Subject Property

Aspose.Email

MailMessage.Subject Property

Gets or sets the subject line

public virtual string Subject {get; set;}

Implements

IMessage.Subject

See Also

MailMessage Class | Aspose.Email.Mail Namespace


SubjectEncoding Property

Aspose.Email

MailMessage.SubjectEncoding Property

Gets or sets the encoding of subject

public virtual Encoding SubjectEncoding {get; set;}

See Also

MailMessage Class | Aspose.Email.Mail Namespace


TextBody Property

Aspose.Email

MailMessage.TextBody Property

Gets or sets plain text body

public virtual string TextBody {get; set;}

See Also

MailMessage Class | Aspose.Email.Mail Namespace


TimeZoneOffset Property

Aspose.Email

MailMessage.TimeZoneOffset Property

Gets or sets the Coordinated Universal Time (UTC) offset for the message dates. This property defines the time zone difference, between the local time and UTC.

public TimeSpan TimeZoneOffset {get; set;}

See Also

MailMessage Class | Aspose.Email.Mail Namespace


To Property

Aspose.Email

MailMessage.To Property

Gets or sets the address collection that contains the recipients of message

public virtual MailAddressCollection To {get; set;}

See Also

MailMessage Class | Aspose.Email.Mail Namespace


WriteHeaderToMht Property

Aspose.Email

MailMessage.WriteHeaderToMht Property

NOTE: This property is now obsolete.

Please use MailMessageSaveOptions.WriteHeaderToMht in Save method instead

Gets or sets a value indicating whether header information should be written if message is being saved in mht format. Default value is true.

public bool WriteHeaderToMht {get; set;}

Property Value

true if header information should be written; otherwise, false.

See Also

MailMessage Class | Aspose.Email.Mail Namespace


WriteOutlineAttachmentsToMht Property

Aspose.Email

MailMessage.WriteOutlineAttachmentsToMht Property

NOTE: This property is now obsolete.

Please use MailMessageSaveOptions.WriteOutlineAttachmentsToMht in Save method instead

Gets or sets a value indicating whether outline attachments should be written if message is being saved in mht format. Default value is true.

public bool WriteOutlineAttachmentsToMht {get; set;}

Property Value

true if outline attachments should be written; otherwise, false.

See Also

MailMessage Class | Aspose.Email.Mail Namespace


XMailer Property

Aspose.Email

MailMessage.XMailer Property

Gets or sets the X-Mailer the software that created the e-mail message

public virtual string XMailer {get; set;}

See Also

MailMessage Class | Aspose.Email.Mail Namespace


MailMessage Methods

The methods of the MailMessage class are listed below. For a complete list of MailMessage class members, see the MailMessage Members topic.

Public Static Methods

CheckSignature | Overloaded. Checks the signature of the specified eml file.
Load | Overloaded. Load message from file
LoadFromTnef | Overloaded. Loads message from Transport Neutral Encapsulation Format (TNEF) data structure
ValidateMessage | Overloaded. Validate eml message for corresponding to mime specification.

Public Instance Methods

AddAlternateView | Add an alternate view to message
AddAttachment | Add an attachment to message
AttachSignature | Overloaded. Creates a signed message. Creates a read-only copy of the specified MailMessage and adds a digital signature to it.
CheckSignature | Overloaded. Check signature
Clone | Clones this instance
Decrypt | Overloaded. Decrypts this message
Dispose | Overloaded. Releases all resources used by the MailMessage
Encrypt | Overloaded. Encrypts this message
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an enumerator that iterates through a collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
GetType (inherited from Object) | Gets the Type of the current instance.
Import | Imports message from stream
RecomposeTnefContent | Composes the TNEF content. Note, that tnef attachment is composed if a message initially contained TNEF and was loaded without FileCompatibilityMode.PreserveTnefAttachments flag, That is this method doesn't create tnef message out of the regular one.
RemoveSignature | Remove signature
Save | Overloaded. Save message as a file
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Dispose | Overloaded. Releases unmanaged and - optionally - managed resources
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MailMessage Class | Aspose.Email.Mail Namespace


MailMessage.AddAlternateView Method

Add an alternate view to message

public virtual void AddAlternateView(
AlternateView view
);

Parameters

view
Alternate view for adding

See Also

MailMessage Class | Aspose.Email.Mail Namespace


MailMessage.AddAttachment Method

Add an attachment to message

public virtual void AddAttachment(
Attachment attachment
);

Parameters

attachment
Attachment for adding

See Also

MailMessage Class | Aspose.Email.Mail Namespace


AttachSignature Method

Aspose.Email

MailMessage.AttachSignature Method

Creates a signed message. Creates a read-only copy of the specified MailMessage and adds a digital signature to it.

Overload List

Creates a signed message. Creates a read-only copy of the specified MailMessage and adds a digital signature to it.

public virtual MailMessage AttachSignature(CmsSigner);

Creates a signed message. Creates a read-only copy of the specified MailMessage and adds a digital signature to it.

public virtual MailMessage AttachSignature(X509Certificate2);

See Also

MailMessage Class | Aspose.Email.Mail Namespace


MailMessage.AttachSignature Method (CmsSigner)

Creates a signed message. Creates a read-only copy of the specified MailMessage and adds a digital signature to it.

public virtual MailMessage AttachSignature(
CmsSigner signer
);

Parameters

signer
System.Security.Cryptography.Pkcs.CmsSigner.

Return Value

The signed MailMessage.

See Also

MailMessage Class | Aspose.Email.Mail Namespace | MailMessage.AttachSignature Overload List


MailMessage.AttachSignature Method (X509Certificate2)

Creates a signed message. Creates a read-only copy of the specified MailMessage and adds a digital signature to it.

public virtual MailMessage AttachSignature(
X509Certificate2 certificate
);

Parameters

certificate
X.509 certificate.

Return Value

The signed MailMessage.

See Also

MailMessage Class | Aspose.Email.Mail Namespace | MailMessage.AttachSignature Overload List


CheckSignature Method

Aspose.Email

MailMessage.CheckSignature Method

Check signature

Overload List

Check signature

public virtual void CheckSignature();

Checks the signature of the specified eml message.

public static bool CheckSignature(Stream);

Checks the signature of the specified eml file.

public static bool CheckSignature(string);

See Also

MailMessage Class | Aspose.Email.Mail Namespace


MailMessage.CheckSignature Method ()

Check signature

public virtual void CheckSignature();

See Also

MailMessage Class | Aspose.Email.Mail Namespace | MailMessage.CheckSignature Overload List


MailMessage.CheckSignature Method (Stream)

Checks the signature of the specified eml message.

public static bool CheckSignature(
Stream stream
);

Parameters

stream
A stream containing the message in eml format.

Return Value

True if signature is valid; otherwise, false.

Exceptions

Exception Type | Condition
ArgumentNullException | stream is null.
NotSupportedException | Signature type is not supported.
InvalidOperationException | Mail message is not signed or signature type is not specified.

See Also

MailMessage Class | Aspose.Email.Mail Namespace | MailMessage.CheckSignature Overload List


MailMessage.CheckSignature Method (String)

Checks the signature of the specified eml file.

public static bool CheckSignature(
string fileName
);

Parameters

fileName
A file name (eml).

Return Value

True if signature is valid; otherwise, false.

Exceptions

Exception Type | Condition
ArgumentException | fileName is null or empty.
FileNotFoundException | The specified fileName doesn't exist.
NotSupportedException | Signature type is not supported.
InvalidOperationException | Mail message is not signed or signature type is not specified.

See Also

MailMessage Class | Aspose.Email.Mail Namespace | MailMessage.CheckSignature Overload List


MailMessage.Clone Method

Clones this instance

public virtual MailMessage Clone();

Return Value

MailMessage that is a copy of the current instance

See Also

MailMessage Class | Aspose.Email.Mail Namespace


Decrypt Method

Aspose.Email

MailMessage.Decrypt Method

Decrypts this message

Overload List

Decrypts this message

public virtual MailMessage Decrypt();

Decrypts this message

public virtual MailMessage Decrypt(X509Certificate2);

See Also

MailMessage Class | Aspose.Email.Mail Namespace


MailMessage.Decrypt Method ()

Decrypts this message

public virtual MailMessage Decrypt();

Return Value

E-mail message

See Also

MailMessage Class | Aspose.Email.Mail Namespace | MailMessage.Decrypt Overload List


MailMessage.Decrypt Method (X509Certificate2)

Decrypts this message

public virtual MailMessage Decrypt(
X509Certificate2 certificate
);

Parameters

certificate
System.Security.Cryptography.X509Certificates.X509Certificate2

Return Value

E-mail message

See Also

MailMessage Class | Aspose.Email.Mail Namespace | MailMessage.Decrypt Overload List


Dispose Method

Aspose.Email

MailMessage.Dispose Method

Releases all resources used by the MailMessage

Overload List

Releases all resources used by the MailMessage

public void Dispose();

Releases unmanaged and - optionally - managed resources

protected virtual void Dispose(bool);

See Also

MailMessage Class | Aspose.Email.Mail Namespace


MailMessage.Dispose Method ()

Releases all resources used by the MailMessage

public void Dispose();

Implements

IDisposable.Dispose

See Also

MailMessage Class | Aspose.Email.Mail Namespace | MailMessage.Dispose Overload List


MailMessage.Dispose Method (Boolean)

Releases unmanaged and - optionally - managed resources

protected virtual void Dispose(
bool disposing
);

Parameters

disposing
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

MailMessage Class | Aspose.Email.Mail Namespace | MailMessage.Dispose Overload List


Encrypt Method

Aspose.Email

MailMessage.Encrypt Method

Encrypts this message

Overload List

Encrypts this message

public virtual MailMessage Encrypt(X509Certificate2);

Encrypts this message

public virtual MailMessage Encrypt(X509Certificate2[]);

See Also

MailMessage Class | Aspose.Email.Mail Namespace


MailMessage.Encrypt Method (X509Certificate2)

Encrypts this message

public virtual MailMessage Encrypt(
X509Certificate2 certificate
);

Parameters

certificate
X509 certificate to encrypt message

Return Value

Encrypted email message

See Also

MailMessage Class | Aspose.Email.Mail Namespace | MailMessage.Encrypt Overload List


MailMessage.Encrypt Method (X509Certificate2[])

Encrypts this message

public virtual MailMessage Encrypt(
X509Certificate2[] certificates
);

Parameters

certificates
Array with X509 certificates to encrypt message

Return Value

Encrypted email message

See Also

MailMessage Class | Aspose.Email.Mail Namespace | MailMessage.Encrypt Overload List


MailMessage.GetEnumerator Method

Returns an enumerator that iterates through a collection.

public IEnumerator GetEnumerator();

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable.GetEnumerator

See Also

MailMessage Class | Aspose.Email.Mail Namespace


MailMessage.GetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

public virtual void GetObjectData(
SerializationInfo info,
StreamingContext context
);

Parameters

info
The SerializationInfo to populate with data.
context
The destination (see StreamingContext) for this serialization.

Implements

ISerializable.GetObjectData

Exceptions

Exception Type | Condition
SecurityException | The caller does not have the required permission.

See Also

MailMessage Class | Aspose.Email.Mail Namespace


MailMessage.Import Method

Imports message from stream

public virtual void Import(
Stream stream
);

Parameters

stream
System.IO.Stream

See Also

MailMessage Class | Aspose.Email.Mail Namespace


Load Method

Aspose.Email

MailMessage.Load Method

Load message from stream

Overload List

Load message from stream

public static MailMessage Load(Stream);

Obsolete. Load message from stream

public static MailMessage Load(Stream,FileCompatibilityMode);

Load message from stream with additional options.

public static MailMessage Load(Stream,MailMessageLoadOptions);

Obsolete. Load message from stream

public static MailMessage Load(Stream,MessageFormat);

Load message from file

public static MailMessage Load(string);

Obsolete. Load message from file

public static MailMessage Load(string,FileCompatibilityMode);

Load message from file with additional options.

public static MailMessage Load(string,MailMessageLoadOptions);

Obsolete. Load message from stream

public static MailMessage Load(string,MessageFormat);

See Also

MailMessage Class | Aspose.Email.Mail Namespace


MailMessage.Load Method (Stream)

Load message from stream

public static MailMessage Load(
Stream stream
);

Parameters

stream
Stream that represents message in eml or msg format

Return Value

E-mail message

See Also

MailMessage Class | Aspose.Email.Mail Namespace | MailMessage.Load Overload List


MailMessage.Load Method (Stream, FileCompatibilityMode)

NOTE: This method is now obsolete.

Use Load(Stream stream, MailMessageLoadOptions options) instead this.

Load message from stream

public static MailMessage Load(
Stream stream,
FileCompatibilityMode mode
);

Parameters

stream
Stream that represents message in .eml format
mode
FileCompatibilityMode that defines inner conversions that are necessarily to be done

Return Value

E-mail message

Remarks

If a flag FileCompatibilityMode.PreserveTnefAttachments is set, it means that TNEF attachment shouldn't be decoded if present. If a flag FileCompatibilityMode.AllowCROnly is set, it means that line separators will be replaced by CRLF.

Exceptions

Exception Type | Condition
ArgumentNullException | stream is null.
InvalidOperationException | streamis used .msg format

See Also

MailMessage Class | Aspose.Email.Mail Namespace | MailMessage.Load Overload List


MailMessage.Load Method (Stream, MailMessageLoadOptions)

Load message from stream with additional options.

public static MailMessage Load(
Stream stream,
MailMessageLoadOptions options
);

Parameters

stream
Source streamStream.
options
Additional options MailMessageLoadOptions.

Return Value

Mail messageMailMessage.

Exceptions

Exception Type | Condition
ArgumentNullException | If stream is null.

See Also

MailMessage Class | Aspose.Email.Mail Namespace | MailMessage.Load Overload List


MailMessage.Load Method (Stream, MessageFormat)

NOTE: This method is now obsolete.

Use Load(Stream stream, MailMessageLoadOptions options) instead this.

Load message from stream

public static MailMessage Load(
Stream stream,
MessageFormat format
);

Parameters

stream
Stream that represents message in one of the supported formats
format
Message format represented in stream

Return Value

E-mail message

Exceptions

Exception Type | Condition
ArgumentNullException | If stream is null.
FormatNotSupportedException | If format is not supported.

See Also

MailMessage Class | Aspose.Email.Mail Namespace | MailMessage.Load Overload List


MailMessage.Load Method (String)

Load message from file

public static MailMessage Load(
string fileName
);

Parameters

fileName
Message file name. The message file must be in eml or msg format.

Return Value

E-mail message

See Also

MailMessage Class | Aspose.Email.Mail Namespace | MailMessage.Load Overload List


MailMessage.Load Method (String, FileCompatibilityMode)

NOTE: This method is now obsolete.

Use Load(string fileName, MailMessageLoadOptions options) instead this

Load message from file

public static MailMessage Load(
string fileName,
FileCompatibilityMode mode
);

Parameters

fileName
Message file name (.eml)
mode
FileCompatibilityMode that defines inner conversions that are necessarily to be done

Return Value

E-mail message

Remarks

If a flag FileCompatibilityMode.PreserveTnefAttachments is set, it means that TNEF attachment shouldn't be decoded if present. If a flag FileCompatibilityMode.AllowCROnly is set, it means that line separators will be replaced by CRLF.

See Also

MailMessage Class | Aspose.Email.Mail Namespace | MailMessage.Load Overload List


MailMessage.Load Method (String, MailMessageLoadOptions)

Load message from file with additional options.

public static MailMessage Load(
string fileName,
MailMessageLoadOptions options
);

Parameters

fileName
Source file pathString.
options
Additional options MailMessageLoadOptions.

Return Value

Mail messageMailMessage.

Exceptions

Exception Type | Condition
ArgumentNullException | If fileName is null.

See Also

MailMessage Class | Aspose.Email.Mail Namespace | MailMessage.Load Overload List


MailMessage.Load Method (String, MessageFormat)

NOTE: This method is now obsolete.

Use Load(string fileName, MailMessageLoadOptions options) instead this

Load message from stream

public static MailMessage Load(
string fileName,
MessageFormat format
);

Parameters

fileName
Message file name. File must be in one of the suported formats
format
Message file format

Return Value

E-mail message

Exceptions

Exception Type | Condition
ArgumentNullException | If fileName is null.
FormatNotSupportedException | If format is not supported.

See Also

MailMessage Class | Aspose.Email.Mail Namespace | MailMessage.Load Overload List


LoadFromTnef Method

Aspose.Email

MailMessage.LoadFromTnef Method

Loads message from Transport Neutral Encapsulation Format (TNEF) data structure

Overload List

Loads message from Transport Neutral Encapsulation Format (TNEF) data structure

public static MailMessage LoadFromTnef(Stream);

Loads message from Transport Neutral Encapsulation Format (TNEF) data structure

public static MailMessage LoadFromTnef(string);

See Also

MailMessage Class | Aspose.Email.Mail Namespace


MailMessage.LoadFromTnef Method (Stream)

Loads message from Transport Neutral Encapsulation Format (TNEF) data structure

public static MailMessage LoadFromTnef(
Stream stream
);

Parameters

stream
A stream representing message data in TNEF format

Return Value

A read MailMessage

Exceptions

Exception Type | Condition
ArgumentNullException | stream is null
NotSupportedException | stream does not support reading

See Also

MailMessage Class | Aspose.Email.Mail Namespace | MailMessage.LoadFromTnef Overload List


MailMessage.LoadFromTnef Method (String)

Loads message from Transport Neutral Encapsulation Format (TNEF) data structure

public static MailMessage LoadFromTnef(
string fileName
);

Parameters

fileName
Name of file containing message data in TNEF format

Return Value

A read MailMessage

Exceptions

Exception Type | Condition
ArgumentException | fileName is null or empty

See Also

MailMessage Class | Aspose.Email.Mail Namespace | MailMessage.LoadFromTnef Overload List


MailMessage.RecomposeTnefContent Method

Composes the TNEF content. Note, that tnef attachment is composed if a message initially contained TNEF and was loaded without FileCompatibilityMode.PreserveTnefAttachments flag, That is this method doesn't create tnef message out of the regular one.

public void RecomposeTnefContent();

See Also

MailMessage Class | Aspose.Email.Mail Namespace


MailMessage.RemoveSignature Method

Remove signature

public virtual MailMessage RemoveSignature();

Return Value

E-mail message

See Also

MailMessage Class | Aspose.Email.Mail Namespace


Save Method

Aspose.Email

MailMessage.Save Method

Save message as a stream

Overload List

Save message as a stream

public virtual void Save(Stream);

Save message as a stream

public virtual void Save(Stream,FileCompatibilityMode);

Message saving into a stream in one of the supported formats

public virtual void Save(Stream,MailMessageSaveType);

Message saving into a stream in one of the supported formats

public virtual void Save(Stream,MailMessageSaveType,MailMessageSaveOptions);

Message saving as a stream in one of the supported formats

public virtual void Save(Stream,MessageFormat);

Message saving as a stream in one of the supported formats

public virtual void Save(Stream,MessageFormat,MailMessageSaveOptions);

Save message as a file

public virtual void Save(string);

Save message as a file

public virtual void Save(string,FileCompatibilityMode);

Message saving into a file into one of the supported formats

public virtual void Save(string,MailMessageSaveType);

Message saving into a file into one of the supported formats

public virtual void Save(string,MailMessageSaveType,MailMessageSaveOptions);

Message saving into a file into one of the supported formats

public virtual void Save(string,MessageFormat);

Message saving into a file into one of the supported formats

public virtual void Save(string,MessageFormat,MailMessageSaveOptions);

See Also

MailMessage Class | Aspose.Email.Mail Namespace


MailMessage.Save Method (Stream)

Save message as a stream

public virtual void Save(
Stream stream
);

Parameters

stream
Stream into which message is saved

Implements

IMessage.Save

See Also

MailMessage Class | Aspose.Email.Mail Namespace | MailMessage.Save Overload List


MailMessage.Save Method (Stream, FileCompatibilityMode)

Save message as a stream

public virtual void Save(
Stream stream,
FileCompatibilityMode mode
);

Parameters

stream
The stream into which message is saved
mode
FileCompatibilityMode that defines inner conversions that are necessarily to be done

Remarks

A message is saved in eml format. If a flag FileCompatibilityMode.PreserveTnefAttachments is set, it means that TNEF attachment should be preserved. Note, that now tnef attachment is saved when being loaded a message contains tnef, that is the FileCompatibilityMode.PreserveTnefAttachments flag doesn't allow to create tnef message out of an regular one.

See Also

MailMessage Class | Aspose.Email.Mail Namespace | MailMessage.Save Overload List


MailMessage.Save Method (Stream, MailMessageSaveType)

Message saving into a stream in one of the supported formats

public virtual void Save(
Stream stream,
MailMessageSaveType savetype
);

Parameters

stream
Stream into which message is saved
savetype
Format into which message is saved

Implements

IMessage.Save

See Also

MailMessage Class | Aspose.Email.Mail Namespace | MailMessage.Save Overload List


MailMessage.Save Method (Stream, MailMessageSaveType, MailMessageSaveOptions)

Message saving into a stream in one of the supported formats

public virtual void Save(
Stream stream,
MailMessageSaveType savetype,
MailMessageSaveOptions saveOptions
);

Parameters

stream
Stream into which message is saved
savetype
Format into which message is saved
saveOptions
Save options

See Also

MailMessage Class | Aspose.Email.Mail Namespace | MailMessage.Save Overload List


MailMessage.Save Method (Stream, MessageFormat)

Message saving as a stream in one of the supported formats

public virtual void Save(
Stream stream,
MessageFormat format
);

Parameters

stream
Stream into which message is saved
format
Format into which message is saved

See Also

MailMessage Class | Aspose.Email.Mail Namespace | MailMessage.Save Overload List


MailMessage.Save Method (Stream, MessageFormat, MailMessageSaveOptions)

Message saving as a stream in one of the supported formats

public virtual void Save(
Stream stream,
MessageFormat format,
MailMessageSaveOptions saveOptions
);

Parameters

stream
Stream into which message is saved
format
Format into which message is saved
saveOptions
Save options

See Also

MailMessage Class | Aspose.Email.Mail Namespace | MailMessage.Save Overload List


MailMessage.Save Method (String)

Save message as a file

public virtual void Save(
string fileName
);

Parameters

fileName
Name of a file to save message.

Implements

IMessage.Save

See Also

MailMessage Class | Aspose.Email.Mail Namespace | MailMessage.Save Overload List


MailMessage.Save Method (String, FileCompatibilityMode)

Save message as a file

public virtual void Save(
string fileName,
FileCompatibilityMode mode
);

Parameters

fileName
Name of the file
mode
FileCompatibilityMode that defines inner conversions that are necessarily to be done

Remarks

A message is saved in eml format. If a flag FileCompatibilityMode.PreserveTnefAttachments is set, it means that TNEF attachment should be preserved. Note, that now tnef attachment is saved when being loaded a message contains tnef, that is the FileCompatibilityMode.PreserveTnefAttachments flag doesn't allow to create tnef message out of an regular one.

See Also

MailMessage Class | Aspose.Email.Mail Namespace | MailMessage.Save Overload List


MailMessage.Save Method (String, MailMessageSaveType)

Message saving into a file into one of the supported formats

public virtual void Save(
string fileName,
MailMessageSaveType savetype
);

Parameters

fileName
Full file name
savetype
Format into which message is saved

Implements

IMessage.Save

See Also

MailMessage Class | Aspose.Email.Mail Namespace | MailMessage.Save Overload List


MailMessage.Save Method (String, MailMessageSaveType, MailMessageSaveOptions)

Message saving into a file into one of the supported formats

public virtual void Save(
string fileName,
MailMessageSaveType savetype,
MailMessageSaveOptions saveOptions
);

Parameters

fileName
Full file name
savetype
Format into which message is saved
saveOptions
Save options

See Also

MailMessage Class | Aspose.Email.Mail Namespace | MailMessage.Save Overload List


MailMessage.Save Method (String, MessageFormat)

Message saving into a file into one of the supported formats

public virtual void Save(
string fileName,
MessageFormat format
);

Parameters

fileName
Full file name
format
Format into which message is saved

See Also

MailMessage Class | Aspose.Email.Mail Namespace | MailMessage.Save Overload List


MailMessage.Save Method (String, MessageFormat, MailMessageSaveOptions)

Message saving into a file into one of the supported formats

public virtual void Save(
string fileName,
MessageFormat format,
MailMessageSaveOptions saveOptions
);

Parameters

fileName
Full file name
format
Format into which message is saved
saveOptions
Save options

See Also

MailMessage Class | Aspose.Email.Mail Namespace | MailMessage.Save Overload List


ValidateMessage Method

Aspose.Email

MailMessage.ValidateMessage Method

Validate eml message for corresponding to mime specification.

Overload List

Validate eml message for corresponding to mime specification.

public static EmlValidationErrorCollection ValidateMessage(Stream);

Validate eml message for corresponding to mime specification.

public static EmlValidationErrorCollection ValidateMessage(string);

See Also

MailMessage Class | Aspose.Email.Mail Namespace


MailMessage.ValidateMessage Method (Stream)

Validate eml message for corresponding to mime specification.

public static EmlValidationErrorCollection ValidateMessage(
Stream stream
);

Parameters

stream
A stream containing the message in eml format.

Return Value

A EmlValidationErrorCollection containing the found validation error messages.

Exceptions

Exception Type | Condition
ArgumentNullException | stream is null.

See Also

MailMessage Class | Aspose.Email.Mail Namespace | MailMessage.ValidateMessage Overload List


MailMessage.ValidateMessage Method (String)

Validate eml message for corresponding to mime specification.

public static EmlValidationErrorCollection ValidateMessage(
string fileName
);

Parameters

fileName
A file name (eml).

Return Value

A EmlValidationErrorCollection containing the found validation error messages.

Exceptions

Exception Type | Condition
ArgumentException | fileName is null or empty.
FileNotFoundException | The specified fileName doesn't exist.

See Also

MailMessage Class | Aspose.Email.Mail Namespace | MailMessage.ValidateMessage Overload List


MailMessageCollection Class

Represents a collection of MailMessage objects.

For a list of all members of this type, see MailMessageCollection Members.

System.Object
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Mail.MailMessage, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]]
Aspose.Email.Mail.MailMessageCollection

public class MailMessageCollection : Collection`1

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Provides a simple collection object that can represent a set of MailMessage objects. The MailMessageCollection class provides a simple collection object that can be used to store a set of MailMessage objects.

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MailMessageCollection Members | Aspose.Email.Mail Namespace


MailMessageCollection Members

MailMessageCollection overview

Public Instance Constructors

MailMessageCollection Constructor Initialize a new instance of the class MailMessageCollection.

Public Instance Properties

Count (inherited from 0, Culture=neutral, PublicKeyToken=null]])
Item (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Items (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Protected Instance Methods

ClearItems (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
InsertItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RemoveItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
SetItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |

See Also

MailMessageCollection Class | Aspose.Email.Mail Namespace


MailMessageCollection Constructor

Initialize a new instance of the class MailMessageCollection.

public MailMessageCollection();

See Also

MailMessageCollection Class | Aspose.Email.Mail Namespace


MailMessageLoadOptions Class

This class allows the user to specify additional options when loading a message.

For a list of all members of this type, see MailMessageLoadOptions Members.

System.Object
Aspose.Email.Mail.MailMessageLoadOptions

public class MailMessageLoadOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MailMessageLoadOptions Members | Aspose.Email.Mail Namespace


MailMessageLoadOptions Members

MailMessageLoadOptions overview

Public Static Properties

DefaultEml | Gets options with default values for Eml format of message.
DefaultMsg | Gets options with default values for Msg format of message.

Public Instance Constructors

MailMessageLoadOptions Constructor Initializes a new instance of the MailMessageLoadOptions class.

Public Instance Properties

FileCompatibilityMode | Defines inner conversions,that are necessarily to be done when loading a message. The default value is FileCompatibilityMode.None.
MessageFormat | Represents the mail message format.It can be in eml,msg or mhtml format. The default value is Eml.
PrefferedTextEncoding | Gets or sets preferred encoding for message. The default value is null.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MailMessageLoadOptions Class | Aspose.Email.Mail Namespace


MailMessageLoadOptions Constructor

Initializes a new instance of the MailMessageLoadOptions class.

public MailMessageLoadOptions();

See Also

MailMessageLoadOptions Class | Aspose.Email.Mail Namespace


MailMessageLoadOptions Properties

The properties of the MailMessageLoadOptions class are listed below. For a complete list of MailMessageLoadOptions class members, see the MailMessageLoadOptions Members topic.

Public Static Properties

DefaultEml | Gets options with default values for Eml format of message.
DefaultMsg | Gets options with default values for Msg format of message.

Public Instance Properties

FileCompatibilityMode | Defines inner conversions,that are necessarily to be done when loading a message. The default value is FileCompatibilityMode.None.
MessageFormat | Represents the mail message format.It can be in eml,msg or mhtml format. The default value is Eml.
PrefferedTextEncoding | Gets or sets preferred encoding for message. The default value is null.

See Also

MailMessageLoadOptions Class | Aspose.Email.Mail Namespace


DefaultEml Property

Aspose.Email

MailMessageLoadOptions.DefaultEml Property

Gets options with default values for Eml format of message.

public static MailMessageLoadOptions DefaultEml {get;}

See Also

MailMessageLoadOptions Class | Aspose.Email.Mail Namespace


DefaultMsg Property

Aspose.Email

MailMessageLoadOptions.DefaultMsg Property

Gets options with default values for Msg format of message.

public static MailMessageLoadOptions DefaultMsg {get;}

See Also

MailMessageLoadOptions Class | Aspose.Email.Mail Namespace


FileCompatibilityMode Property

Aspose.Email

MailMessageLoadOptions.FileCompatibilityMode Property

Defines inner conversions,that are necessarily to be done when loading a message. The default value is FileCompatibilityMode.None.

public FileCompatibilityMode FileCompatibilityMode {get; set;}

See Also

MailMessageLoadOptions Class | Aspose.Email.Mail Namespace


MessageFormat Property

Aspose.Email

MailMessageLoadOptions.MessageFormat Property

Represents the mail message format.It can be in eml,msg or mhtml format. The default value is Eml.

public MessageFormat MessageFormat {get; set;}

See Also

MailMessageLoadOptions Class | Aspose.Email.Mail Namespace


PrefferedTextEncoding Property

Aspose.Email

MailMessageLoadOptions.PrefferedTextEncoding Property

Gets or sets preferred encoding for message. The default value is null.

public Encoding PrefferedTextEncoding {get; set;}

See Also

MailMessageLoadOptions Class | Aspose.Email.Mail Namespace


MailMessageSaveOptions Enumeration

Enumerates the MailMessage save options

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum MailMessageSaveOptions

Members

Member Name | Description | Value
None | No specific settings are specified | 0
WriteHeaderToMht | Indicates that header information should be written if message is being saved in mht format | 1
WriteOutlineAttachmentsToMht | Indicates that outline attachments should be written if message is being saved in mht format. | 2
WriteCompleteEmailAddressToMht | Indicates that complete e-mail address should be written if message is being saved in mht format. | 4
NoEncodeCharactersToMht | Indicates that no transfer encoding of characters should be used if message is being saved in mht format. | 8
HideExtraPrintHeader | Indicates that PageHeader will be unvisible. | 16

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Mail Namespace


MailMessageSaveType Class

Represents the mail message format.It can be in eml,msg or mhtml format.

For a list of all members of this type, see MailMessageSaveType Members.

System.Object
Aspose.Email.Mail.MailMessageSaveType

public sealed class MailMessageSaveType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MailMessageSaveType Members | Aspose.Email.Mail Namespace


MailMessageSaveType Members

MailMessageSaveType overview

Public Static Properties

EmlFormat | Gets the eml.
EmlxFormat | Gets the emlx.
MHtmlFormat | Gets the MHT.
MHtmlFromat | Obsolete. Gets the MHT.
OutlookMessageFormat | Gets the MSG.
OutlookMessageFormatUnicode | Gets the MSG.

Public Instance Methods

Equals | Equalses the specified o.
GetHashCode | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents the current Object.

See Also

MailMessageSaveType Class | Aspose.Email.Mail Namespace


MailMessageSaveType Properties

The properties of the MailMessageSaveType class are listed below. For a complete list of MailMessageSaveType class members, see the MailMessageSaveType Members topic.

Public Static Properties

EmlFormat | Gets the eml.
EmlxFormat | Gets the emlx.
MHtmlFormat | Gets the MHT.
MHtmlFromat | Obsolete. Gets the MHT.
OutlookMessageFormat | Gets the MSG.
OutlookMessageFormatUnicode | Gets the MSG.

See Also

MailMessageSaveType Class | Aspose.Email.Mail Namespace


EmlFormat Property

Aspose.Email

MailMessageSaveType.EmlFormat Property

Gets the eml.

public static MailMessageSaveType EmlFormat {get;}

Property Value

The eml.

See Also

MailMessageSaveType Class | Aspose.Email.Mail Namespace


EmlxFormat Property

Aspose.Email

MailMessageSaveType.EmlxFormat Property

Gets the emlx.

public static MailMessageSaveType EmlxFormat {get;}

Property Value

The emlx.

See Also

MailMessageSaveType Class | Aspose.Email.Mail Namespace


MHtmlFormat Property

Aspose.Email

MailMessageSaveType.MHtmlFormat Property

Gets the MHT.

public static MailMessageSaveType MHtmlFormat {get;}

Property Value

The MHT.

See Also

MailMessageSaveType Class | Aspose.Email.Mail Namespace


MHtmlFromat Property

Aspose.Email

MailMessageSaveType.MHtmlFromat Property

NOTE: This property is now obsolete.

Please use MHtmlFormat instead

Gets the MHT.

public static MailMessageSaveType MHtmlFromat {get;}

Property Value

The MHT.

See Also

MailMessageSaveType Class | Aspose.Email.Mail Namespace


OutlookMessageFormat Property

Aspose.Email

MailMessageSaveType.OutlookMessageFormat Property

Gets the MSG.

public static MailMessageSaveType OutlookMessageFormat {get;}

Property Value

The MSG.

See Also

MailMessageSaveType Class | Aspose.Email.Mail Namespace


OutlookMessageFormatUnicode Property

Aspose.Email

MailMessageSaveType.OutlookMessageFormatUnicode Property

Gets the MSG.

public static MailMessageSaveType OutlookMessageFormatUnicode {get;}

Property Value

The MSG.

See Also

MailMessageSaveType Class | Aspose.Email.Mail Namespace


MailMessageSaveType Methods

The methods of the MailMessageSaveType class are listed below. For a complete list of MailMessageSaveType class members, see the MailMessageSaveType Members topic.

Public Instance Methods

Equals | Equalses the specified o.
GetHashCode | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents the current Object.

See Also

MailMessageSaveType Class | Aspose.Email.Mail Namespace


MailMessageSaveType.Equals Method

Equalses the specified o.

public override bool Equals(
object o
);

Parameters

o
An object to compare

Return Value

Returns true if objects are an equal, otherwise returns false.

See Also

MailMessageSaveType Class | Aspose.Email.Mail Namespace


MailMessageSaveType.GetHashCode Method

Serves as a hash function for a particular type.

public override int GetHashCode();

Return Value

A hash code for the current Object.

See Also

MailMessageSaveType Class | Aspose.Email.Mail Namespace


MailMessageSaveType.ToString Method

Returns a String that represents the current Object.

public override string ToString();

Return Value

A String that represents the current Object.

See Also

MailMessageSaveType Class | Aspose.Email.Mail Namespace


MailPriority Enumeration

Represents the mail priopity

public enum MailPriority

Members

Member Name | Description | Value
Normal | Normal priority | 0
Low | Low priority | 1
High | High priority | 2

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Mail Namespace


MailSensitivity Enumeration

Specifies the sensitivity of a MailMessage.

public enum MailSensitivity

Members

Member Name | Description | Value
None | No Sensitivity set. | 0
Normal | The normal sensitivity. | 1
Personal | Sets the sensitivity to Personal. | 2
Private | Sets the sensitivity to Private. | 3
CompanyConfidential | Sets the sensitivity to CompanyConfidential. | 4

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Mail Namespace


MesageLoadOptions Class

NOTE: This class is now obsolete.

Use Aspose.Email.Mail.MailMessageLoadOptions instead this

This class allows the user to specify additional options when loading a message.

For a list of all members of this type, see MesageLoadOptions Members.

System.Object
Aspose.Email.Mail.MesageLoadOptions

public class MesageLoadOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MesageLoadOptions Members | Aspose.Email.Mail Namespace


MesageLoadOptions Members

MesageLoadOptions overview

Public Static Properties

DefaultEml | Obsolete. Gets options with default values for Eml format of message.
DefaultMsg | Obsolete. Gets options with default values for Msg format of message.

Public Instance Constructors

MesageLoadOptions Constructor Initializes a new instance of the MesageLoadOptions class.

Public Instance Properties

FileCompatibilityMode | Obsolete. Defines inner conversions,that are necessarily to be done when loading a message. The default value is FileCompatibilityMode.None.
MessageFormat | Obsolete. Represents the mail message format.It can be in eml,msg or mhtml format. The default value is Eml.
PrefferedTextEncoding | Obsolete. Gets or sets preferred encoding for message. The default value is null.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MesageLoadOptions Class | Aspose.Email.Mail Namespace


MesageLoadOptions Constructor

NOTE: This constructor is now obsolete.

Use Aspose.Email.Mail.MailMessageLoadOptions instead this

Initializes a new instance of the MesageLoadOptions class.

public MesageLoadOptions();

See Also

MesageLoadOptions Class | Aspose.Email.Mail Namespace


MesageLoadOptions Properties

The properties of the MesageLoadOptions class are listed below. For a complete list of MesageLoadOptions class members, see the MesageLoadOptions Members topic.

Public Static Properties

DefaultEml | Obsolete. Gets options with default values for Eml format of message.
DefaultMsg | Obsolete. Gets options with default values for Msg format of message.

Public Instance Properties

FileCompatibilityMode | Obsolete. Defines inner conversions,that are necessarily to be done when loading a message. The default value is FileCompatibilityMode.None.
MessageFormat | Obsolete. Represents the mail message format.It can be in eml,msg or mhtml format. The default value is Eml.
PrefferedTextEncoding | Obsolete. Gets or sets preferred encoding for message. The default value is null.

See Also

MesageLoadOptions Class | Aspose.Email.Mail Namespace


DefaultEml Property

Aspose.Email

MesageLoadOptions.DefaultEml Property

NOTE: This property is now obsolete.

Use Aspose.Email.Mail.MailMessageLoadOptions.DefaultEml instead this

Gets options with default values for Eml format of message.

public static MesageLoadOptions DefaultEml {get;}

See Also

MesageLoadOptions Class | Aspose.Email.Mail Namespace


DefaultMsg Property

Aspose.Email

MesageLoadOptions.DefaultMsg Property

NOTE: This property is now obsolete.

Use Aspose.Email.Mail.MailMessageLoadOptions.DefaultMsg instead this

Gets options with default values for Msg format of message.

public static MesageLoadOptions DefaultMsg {get;}

See Also

MesageLoadOptions Class | Aspose.Email.Mail Namespace


FileCompatibilityMode Property

Aspose.Email

MesageLoadOptions.FileCompatibilityMode Property

NOTE: This property is now obsolete.

Use Aspose.Email.Mail.MailMessageLoadOptions.FileCompatibilityMode instead this

Defines inner conversions,that are necessarily to be done when loading a message. The default value is FileCompatibilityMode.None.

public FileCompatibilityMode FileCompatibilityMode {get; set;}

See Also

MesageLoadOptions Class | Aspose.Email.Mail Namespace


MessageFormat Property

Aspose.Email

MesageLoadOptions.MessageFormat Property

NOTE: This property is now obsolete.

Use Aspose.Email.Mail.MailMessageLoadOptions.MessageFormat instead this

Represents the mail message format.It can be in eml,msg or mhtml format. The default value is Eml.

public MessageFormat MessageFormat {get; set;}

See Also

MesageLoadOptions Class | Aspose.Email.Mail Namespace


PrefferedTextEncoding Property

Aspose.Email

MesageLoadOptions.PrefferedTextEncoding Property

NOTE: This property is now obsolete.

Use Aspose.Email.Mail.MailMessageLoadOptions.PrefferedTextEncoding instead this

Gets or sets preferred encoding for message. The default value is null.

public Encoding PrefferedTextEncoding {get; set;}

See Also

MesageLoadOptions Class | Aspose.Email.Mail Namespace


MessageAcceptanceCallback Delegate

Callback function which is being called during the conversion process.

public delegate bool MessageAcceptanceCallback(
MapiMessage mapiMessage
);

Parameters

mapiMessage
MapiMessage to check.

Return Value

If it returns true it indicates that message can be accepted for conversion, otherwise it will be skipped.

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Mail Namespace


MessageFormat Class

Represents the mail message format.It can be in eml,msg or mhtml format.

For a list of all members of this type, see MessageFormat Members.

System.Object
Aspose.Email.Mail.MessageFormat

public sealed class MessageFormat

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MessageFormat Members | Aspose.Email.Mail Namespace


MessageFormat Members

MessageFormat overview

Public Static Properties

Eml | Indicates message in Eml format.
Emlx | Indicates message in Emlx format, used by Apple Mail.
Mht | Indicates message in Mht format.
Msg | Indicates message in Msg format, used by Microsoft Outlook.

Public Instance Methods

Equals | Equalses the specified o.
GetHashCode | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents the current Object.

See Also

MessageFormat Class | Aspose.Email.Mail Namespace


MessageFormat Properties

The properties of the MessageFormat class are listed below. For a complete list of MessageFormat class members, see the MessageFormat Members topic.

Public Static Properties

Eml | Indicates message in Eml format.
Emlx | Indicates message in Emlx format, used by Apple Mail.
Mht | Indicates message in Mht format.
Msg | Indicates message in Msg format, used by Microsoft Outlook.

See Also

MessageFormat Class | Aspose.Email.Mail Namespace


Eml Property

Aspose.Email

MessageFormat.Eml Property

Indicates message in Eml format.

public static MessageFormat Eml {get;}

See Also

MessageFormat Class | Aspose.Email.Mail Namespace


Emlx Property

Aspose.Email

MessageFormat.Emlx Property

Indicates message in Emlx format, used by Apple Mail.

public static MessageFormat Emlx {get;}

See Also

MessageFormat Class | Aspose.Email.Mail Namespace


Mht Property

Aspose.Email

MessageFormat.Mht Property

Indicates message in Mht format.

public static MessageFormat Mht {get;}

See Also

MessageFormat Class | Aspose.Email.Mail Namespace


Msg Property

Aspose.Email

MessageFormat.Msg Property

Indicates message in Msg format, used by Microsoft Outlook.

public static MessageFormat Msg {get;}

See Also

MessageFormat Class | Aspose.Email.Mail Namespace


MessageFormat Methods

The methods of the MessageFormat class are listed below. For a complete list of MessageFormat class members, see the MessageFormat Members topic.

Public Instance Methods

Equals | Equalses the specified o.
GetHashCode | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents the current Object.

See Also

MessageFormat Class | Aspose.Email.Mail Namespace


MessageFormat.Equals Method

Equalses the specified o.

public override bool Equals(
object o
);

Parameters

o
An object to compare

Return Value

Returns true if objects are an equal, otherwise returns false.

See Also

MessageFormat Class | Aspose.Email.Mail Namespace


MessageFormat.GetHashCode Method

Serves as a hash function for a particular type.

public override int GetHashCode();

Return Value

A hash code for the current Object.

See Also

MessageFormat Class | Aspose.Email.Mail Namespace


MessageFormat.ToString Method

Returns a String that represents the current Object.

public override string ToString();

Return Value

A String that represents the current Object.

See Also

MessageFormat Class | Aspose.Email.Mail Namespace


MhtFormatOptions Enumeration

Enumerates the Mht format options

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum MhtFormatOptions

Members

Member Name | Description | Value
None | No specific settings are specified | 0
WriteCompleteEmailAddressToMht | Indicates that complete e-mail address should be written if message is being saved in mht format. | 1
HideExtraPrintHeader | Indicates that PageHeader will be invisible. | 2

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Mail Namespace


MhtMessageFormatter Class

Provides a default formatter for Mht conversion.

For a list of all members of this type, see MhtMessageFormatter Members.

System.Object
Aspose.Email.Mail.MhtMessageFormatter

public class MhtMessageFormatter : IMessageFormatter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MhtMessageFormatter Members | Aspose.Email.Mail Namespace


MhtMessageFormatter Members

MhtMessageFormatter overview

Public Static Properties

DefaultMhtFormatOptions MhtFormatOptions that will be used for formatting by default.

Public Instance Constructors

MhtMessageFormatter Constructor Creates an instance of MhtMessageFormatter.

Public Instance Properties

AttachmentFormat | Gets or sets the attachment format.
BccFormat | Gets or sets the bcc format.
CcFormat | Gets or sets the cc format.
CssStyles | Gets or sets the additional css styles for the formatter.
DateTimeFormat | Gets or sets the date time format.
FormatTemplates | Gets the format templates.
FormFormat | Obsolete. Gets or sets the from format.
FromFormat | Gets or sets format of the "From" field.
ImportanceFormat | Gets or sets the importance format.
PageHeaderFormat | Gets or sets the page header format.
SaveAttachments | Gets or sets a value indicating whether to save attachments.
SentFormat | Gets or sets the sent format.
SubjectFormat | Gets or sets the subject format.
ToFormat | Gets or sets to format.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Format | Overloaded. Adds information header into message body.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MhtMessageFormatter Class | Aspose.Email.Mail Namespace


MhtMessageFormatter Constructor

Creates an instance of MhtMessageFormatter.

public MhtMessageFormatter();

See Also

MhtMessageFormatter Class | Aspose.Email.Mail Namespace


MhtMessageFormatter Properties

The properties of the MhtMessageFormatter class are listed below. For a complete list of MhtMessageFormatter class members, see the MhtMessageFormatter Members topic.

Public Static Properties

DefaultMhtFormatOptions MhtFormatOptions that will be used for formatting by default.

Public Instance Properties

AttachmentFormat | Gets or sets the attachment format.
BccFormat | Gets or sets the bcc format.
CcFormat | Gets or sets the cc format.
CssStyles | Gets or sets the additional css styles for the formatter.
DateTimeFormat | Gets or sets the date time format.
FormatTemplates | Gets the format templates.
FormFormat | Obsolete. Gets or sets the from format.
FromFormat | Gets or sets format of the "From" field.
ImportanceFormat | Gets or sets the importance format.
PageHeaderFormat | Gets or sets the page header format.
SaveAttachments | Gets or sets a value indicating whether to save attachments.
SentFormat | Gets or sets the sent format.
SubjectFormat | Gets or sets the subject format.
ToFormat | Gets or sets to format.

See Also

MhtMessageFormatter Class | Aspose.Email.Mail Namespace


AttachmentFormat Property

Aspose.Email

MhtMessageFormatter.AttachmentFormat Property

Gets or sets the attachment format.

public string AttachmentFormat {get; set;}

Property Value

The attachment format.

See Also

MhtMessageFormatter Class | Aspose.Email.Mail Namespace


BccFormat Property

Aspose.Email

MhtMessageFormatter.BccFormat Property

Gets or sets the bcc format.

public string BccFormat {get; set;}

Property Value

The bcc format.

See Also

MhtMessageFormatter Class | Aspose.Email.Mail Namespace


CcFormat Property

Aspose.Email

MhtMessageFormatter.CcFormat Property

Gets or sets the cc format.

public string CcFormat {get; set;}

Property Value

The cc format.

See Also

MhtMessageFormatter Class | Aspose.Email.Mail Namespace


CssStyles Property

Aspose.Email

MhtMessageFormatter.CssStyles Property

Gets or sets the additional css styles for the formatter.

public string CssStyles {get; set;}

Property Value

The styles to be injected into resulting html body.

See Also

MhtMessageFormatter Class | Aspose.Email.Mail Namespace


DateTimeFormat Property

Aspose.Email

MhtMessageFormatter.DateTimeFormat Property

Gets or sets the date time format.

public string DateTimeFormat {get; set;}

Property Value

The date time format.

See Also

MhtMessageFormatter Class | Aspose.Email.Mail Namespace


DefaultMhtFormatOptions Property

Aspose.Email

MhtMessageFormatter.DefaultMhtFormatOptions Property

MhtFormatOptions that will be used for formatting by default.

public static MhtFormatOptions DefaultMhtFormatOptions {get;}

See Also

MhtMessageFormatter Class | Aspose.Email.Mail Namespace


FormatTemplates Property

Aspose.Email

MhtMessageFormatter.FormatTemplates Property

Gets the format templates.

public StringDictionary FormatTemplates {get;}

Property Value

The format templates.

Implements

IMessageFormatter.FormatTemplates

See Also

MhtMessageFormatter Class | Aspose.Email.Mail Namespace


FormFormat Property

Aspose.Email

MhtMessageFormatter.FormFormat Property

NOTE: This property is now obsolete.

Please use FromFormat instead

Gets or sets the from format.

public string FormFormat {get; set;}

Property Value

The from format.

See Also

MhtMessageFormatter Class | Aspose.Email.Mail Namespace


FromFormat Property

Aspose.Email

MhtMessageFormatter.FromFormat Property

Gets or sets format of the "From" field.

public string FromFormat {get; set;}

Property Value

Format of the "From" field.

See Also

MhtMessageFormatter Class | Aspose.Email.Mail Namespace


ImportanceFormat Property

Aspose.Email

MhtMessageFormatter.ImportanceFormat Property

Gets or sets the importance format.

public string ImportanceFormat {get; set;}

Property Value

The importance format.

See Also

MhtMessageFormatter Class | Aspose.Email.Mail Namespace


PageHeaderFormat Property

Aspose.Email

MhtMessageFormatter.PageHeaderFormat Property

Gets or sets the page header format.

public string PageHeaderFormat {get; set;}

Property Value

The page header format.

See Also

MhtMessageFormatter Class | Aspose.Email.Mail Namespace


SaveAttachments Property

Aspose.Email

MhtMessageFormatter.SaveAttachments Property

Gets or sets a value indicating whether to save attachments.

public bool SaveAttachments {get; set;}

Property Value

true if attachments should be saved; otherwise, false.

See Also

MhtMessageFormatter Class | Aspose.Email.Mail Namespace


SentFormat Property

Aspose.Email

MhtMessageFormatter.SentFormat Property

Gets or sets the sent format.

public string SentFormat {get; set;}

Property Value

The sent format.

See Also

MhtMessageFormatter Class | Aspose.Email.Mail Namespace


SubjectFormat Property

Aspose.Email

MhtMessageFormatter.SubjectFormat Property

Gets or sets the subject format.

public string SubjectFormat {get; set;}

Property Value

The subject format.

See Also

MhtMessageFormatter Class | Aspose.Email.Mail Namespace


ToFormat Property

Aspose.Email

MhtMessageFormatter.ToFormat Property

Gets or sets to format.

public string ToFormat {get; set;}

Property Value

To format.

See Also

MhtMessageFormatter Class | Aspose.Email.Mail Namespace


MhtMessageFormatter Methods

The methods of the MhtMessageFormatter class are listed below. For a complete list of MhtMessageFormatter class members, see the MhtMessageFormatter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Format | Overloaded. Adds information header into message body.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MhtMessageFormatter Class | Aspose.Email.Mail Namespace


Format Method

Aspose.Email

MhtMessageFormatter.Format Method

Adds information header into message body.

Overload List

Adds information header into message body.

public void Format(MailMessage);

Adds information header into message body.

public void Format(MailMessage,MhtFormatOptions);

Obsolete. Adds information header into message body.

public void Format(MailMessage,bool);

See Also

MhtMessageFormatter Class | Aspose.Email.Mail Namespace


MhtMessageFormatter.Format Method (MailMessage)

Adds information header into message body.

public void Format(
MailMessage message
);

Parameters

message
The MailMessage to be formatted.

Implements

IMessageFormatter.Format

See Also

MhtMessageFormatter Class | Aspose.Email.Mail Namespace | MhtMessageFormatter.Format Overload List


MhtMessageFormatter.Format Method (MailMessage, MhtFormatOptions)

Adds information header into message body.

public void Format(
MailMessage message,
MhtFormatOptions formatOptions
);

Parameters

message
The MailMessage to be formatted.
formatOptions
Options for formattingMhtFormatOptions.

See Also

MhtMessageFormatter Class | Aspose.Email.Mail Namespace | MhtMessageFormatter.Format Overload List


MhtMessageFormatter.Format Method (MailMessage, Boolean)

NOTE: This method is now obsolete.

Use Format(MailMessage message, MhtFormatOptions formatOptions) instead this.

Adds information header into message body.

public void Format(
MailMessage message,
bool writeCompleteEmailAddress
);

Parameters

message
The MailMessage to be formatted.
writeCompleteEmailAddress
if set to true [write complete email address].

See Also

MhtMessageFormatter Class | Aspose.Email.Mail Namespace | MhtMessageFormatter.Format Overload List


MSBusyStatus Enumeration

Specifies the BUSY status of an appointment.

public enum MSBusyStatus

Members

Member Name | Description | Value
NotDefined | Value is not defined | -1
Free | Free | 0
Tentative | Tentative | 1
Busy | Busy | 2
Oof | Out of office | 3

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Mail Namespace


MSIntendedStatus Enumeration

Specifies the INTENDED status of an appointment.

public enum MSIntendedStatus

Members

Member Name | Description | Value
NotDefined | Property is not set | -1
Free | Free | 0
Tentative | Tentative | 1
Busy | Busy | 2
Oof | Out of office | 3

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Mail Namespace


ReminderAction Enumeration

Defines the action to be invoked when an alarm is triggered.

public enum ReminderAction

Members

Member Name | Description | Value
Audio | Audio action. | 0
Display | Display action. | 1
Email | Email action. | 2
Procedure | Procedure action. | 3

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Mail Namespace


ReminderAttachment Class

Provides the capability to associate a document object with an alarm.

For a list of all members of this type, see ReminderAttachment Members.

System.Object
Aspose.Email.Mail.ReminderAttachment

public class ReminderAttachment

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ReminderAttachment Members | Aspose.Email.Mail Namespace


ReminderAttachment Members

ReminderAttachment overview

Public Instance Constructors

ReminderAttachment Overloaded. Initializes a new instance of the ReminderAttachment class.

Public Instance Properties

BinaryData | Contain a character encoding of inline binary data.
Uri | URI type of reference to the data.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ReminderAttachment Class | Aspose.Email.Mail Namespace


ReminderAttachment Constructor

Initialize a new instance of ReminderAttachment class.

Overload List

Initialize a new instance of ReminderAttachment class.

public ReminderAttachment(byte[]);

Initialize a new instance of ReminderAttachment class.

public ReminderAttachment(Uri);

See Also

ReminderAttachment Class | Aspose.Email.Mail Namespace


ReminderAttachment Constructor (Byte[])

Initialize a new instance of ReminderAttachment class.

public ReminderAttachment(
byte[] binaryData
);

Parameters

binaryData
Binary data.

See Also

ReminderAttachment Class | Aspose.Email.Mail Namespace | ReminderAttachment Constructor Overload List


ReminderAttachment Constructor (Uri)

Initialize a new instance of ReminderAttachment class.

public ReminderAttachment(
Uri uri
);

Parameters

uri
Uri.

See Also

ReminderAttachment Class | Aspose.Email.Mail Namespace | ReminderAttachment Constructor Overload List


ReminderAttachment Properties

The properties of the ReminderAttachment class are listed below. For a complete list of ReminderAttachment class members, see the ReminderAttachment Members topic.

Public Instance Properties

BinaryData | Contain a character encoding of inline binary data.
Uri | URI type of reference to the data.

See Also

ReminderAttachment Class | Aspose.Email.Mail Namespace


BinaryData Property

Aspose.Email

ReminderAttachment.BinaryData Property

Contain a character encoding of inline binary data.

public byte[] BinaryData {get; set;}

See Also

ReminderAttachment Class | Aspose.Email.Mail Namespace


Uri Property

Aspose.Email

ReminderAttachment.Uri Property

URI type of reference to the data.

public Uri Uri {get; set;}

See Also

ReminderAttachment Class | Aspose.Email.Mail Namespace


ReminderAttachmentCollection Class

Contains collection of ReminderAttachment ReminderAttachmentobjects.

For a list of all members of this type, see ReminderAttachmentCollection Members.

System.Object
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Mail.ReminderAttachment, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]]
Aspose.Email.Mail.ReminderAttachmentCollection

public class ReminderAttachmentCollection : Collection`1

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ReminderAttachmentCollection Members | Aspose.Email.Mail Namespace


ReminderAttachmentCollection Members

ReminderAttachmentCollection overview

Public Instance Constructors

ReminderAttachmentCollection Constructor Initializes a new instance of the ReminderAttachmentCollection class.

Public Instance Properties

Count (inherited from 0, Culture=neutral, PublicKeyToken=null]])
Item (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Items (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Protected Instance Methods

ClearItems (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
InsertItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RemoveItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
SetItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |

See Also

ReminderAttachmentCollection Class | Aspose.Email.Mail Namespace


ReminderAttachmentCollection Constructor

Initializes a new instance of the ReminderAttachmentCollection class.

public ReminderAttachmentCollection();

See Also

ReminderAttachmentCollection Class | Aspose.Email.Mail Namespace


ReminderAttendee Class

Defines an "Attendee" within a alarm.

For a list of all members of this type, see ReminderAttendee Members.

System.Object
Aspose.Email.Mail.ReminderAttendee

public class ReminderAttendee

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ReminderAttendee Members | Aspose.Email.Mail Namespace


ReminderAttendee Members

ReminderAttendee overview

Public Instance Constructors

ReminderAttendee Constructor Initialize a new instance of ReminderAttendee class.

Public Instance Properties

Address Contains the email address.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ReminderAttendee Class | Aspose.Email.Mail Namespace


ReminderAttendee Constructor

Initialize a new instance of ReminderAttendee class.

public ReminderAttendee(
string address
);

Parameters

address
Email address.

See Also

ReminderAttendee Class | Aspose.Email.Mail Namespace


ReminderAttendee Properties

The properties of the ReminderAttendee class are listed below. For a complete list of ReminderAttendee class members, see the ReminderAttendee Members topic.

Public Instance Properties

Address Contains the email address.

See Also

ReminderAttendee Class | Aspose.Email.Mail Namespace


Address Property

Aspose.Email

ReminderAttendee.Address Property

Contains the email address.

public string Address {get; set;}

See Also

ReminderAttendee Class | Aspose.Email.Mail Namespace


ReminderAttendeeCollection Class

Contains collection of ReminderAttendee ReminderAttendeeobjects.

For a list of all members of this type, see ReminderAttendeeCollection Members.

System.Object
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Mail.ReminderAttendee, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]]
Aspose.Email.Mail.ReminderAttendeeCollection

public class ReminderAttendeeCollection : Collection`1

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ReminderAttendeeCollection Members | Aspose.Email.Mail Namespace


ReminderAttendeeCollection Members

ReminderAttendeeCollection overview

Public Instance Constructors

ReminderAttendeeCollection Constructor Initializes a new instance of the ReminderAttendeeCollection class.

Public Instance Properties

Count (inherited from 0, Culture=neutral, PublicKeyToken=null]])
Item (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Items (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Protected Instance Methods

ClearItems (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
InsertItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RemoveItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
SetItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |

See Also

ReminderAttendeeCollection Class | Aspose.Email.Mail Namespace


ReminderAttendeeCollection Constructor

Initializes a new instance of the ReminderAttendeeCollection class.

public ReminderAttendeeCollection();

See Also

ReminderAttendeeCollection Class | Aspose.Email.Mail Namespace


ReminderDuration Class

Used to identify properties that contain a duration of time.

For a list of all members of this type, see ReminderDuration Members.

System.Object
Aspose.Email.Mail.ReminderDuration

public class ReminderDuration

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ReminderDuration Members | Aspose.Email.Mail Namespace


ReminderDuration Members

ReminderDuration overview

Public Instance Constructors

ReminderDuration Constructor Initialize a new instance of ReminderDuration class.

Public Instance Properties

Duration Duration of time.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ReminderDuration Class | Aspose.Email.Mail Namespace


ReminderDuration Constructor

Initialize a new instance of ReminderDuration class.

public ReminderDuration(
TimeSpan duration
);

Parameters

duration
Duration of time.

See Also

ReminderDuration Class | Aspose.Email.Mail Namespace


ReminderDuration Properties

The properties of the ReminderDuration class are listed below. For a complete list of ReminderDuration class members, see the ReminderDuration Members topic.

Public Instance Properties

Duration Duration of time.

See Also

ReminderDuration Class | Aspose.Email.Mail Namespace


Duration Property

Aspose.Email

ReminderDuration.Duration Property

Duration of time.

public TimeSpan Duration {get;}

See Also

ReminderDuration Class | Aspose.Email.Mail Namespace


ReminderRelated Enumeration

Specify the relationship of the alarm trigger with respect to the start or end of the event.

public enum ReminderRelated

Members

Member Name | Description | Value
Start | Sets the alarm to trigger off the start of the associated event. | 0
End | Sets the alarm to trigger off the end of the associated event. | 1

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Mail Namespace


ReminderTrigger Class

Specifies when an alarm will trigger.

For a list of all members of this type, see ReminderTrigger Members.

System.Object
Aspose.Email.Mail.ReminderTrigger

public class ReminderTrigger

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ReminderTrigger Members | Aspose.Email.Mail Namespace


ReminderTrigger Members

ReminderTrigger overview

Public Instance Constructors

ReminderTrigger Overloaded. Initializes a new instance of the ReminderTrigger class.

Public Instance Properties

DateTime | A trigger set to an absolute date/time.
Duration | Specifies a relative time for the trigger of the alarm.
Related | Specify the relationship of the alarm trigger with respect to the start or end of the event.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ReminderTrigger Class | Aspose.Email.Mail Namespace


ReminderTrigger Constructor

Initialize a new instance of ReminderTrigger class.

Overload List

Initialize a new instance of ReminderTrigger class.

public ReminderTrigger(ReminderDuration,ReminderRelated);

Initialize a new instance of ReminderTrigger class.

public ReminderTrigger(DateTime);

See Also

ReminderTrigger Class | Aspose.Email.Mail Namespace


ReminderTrigger Constructor (DateTime)

Initialize a new instance of ReminderTrigger class.

public ReminderTrigger(
DateTime dateTime
);

Parameters

dateTime
Absolute DateTime value.

See Also

ReminderTrigger Class | Aspose.Email.Mail Namespace | ReminderTrigger Constructor Overload List


ReminderTrigger Constructor (ReminderDuration, ReminderRelated)

Initialize a new instance of ReminderTrigger class.

public ReminderTrigger(
ReminderDuration duration,
ReminderRelated related
);

Parameters

duration
To specify a relative time for the trigger of the alarm.
related
To specify the relationship of the alarm trigger with respect to the start or end of the event.

See Also

ReminderTrigger Class | Aspose.Email.Mail Namespace | ReminderTrigger Constructor Overload List


ReminderTrigger Properties

The properties of the ReminderTrigger class are listed below. For a complete list of ReminderTrigger class members, see the ReminderTrigger Members topic.

Public Instance Properties

DateTime | A trigger set to an absolute date/time.
Duration | Specifies a relative time for the trigger of the alarm.
Related | Specify the relationship of the alarm trigger with respect to the start or end of the event.

See Also

ReminderTrigger Class | Aspose.Email.Mail Namespace


DateTime Property

Aspose.Email

ReminderTrigger.DateTime Property

A trigger set to an absolute date/time.

public DateTime DateTime {get; set;}

See Also

ReminderTrigger Class | Aspose.Email.Mail Namespace


Duration Property

Aspose.Email

ReminderTrigger.Duration Property

Specifies a relative time for the trigger of the alarm.

public ReminderDuration Duration {get; set;}

See Also

ReminderTrigger Class | Aspose.Email.Mail Namespace


Related Property

Aspose.Email

ReminderTrigger.Related Property

Specify the relationship of the alarm trigger with respect to the start or end of the event.

public ReminderRelated Related {get; set;}

See Also

ReminderTrigger Class | Aspose.Email.Mail Namespace


SendCompletedEventHandler Delegate

Delegate is used for asynchronous mail sending

public delegate void SendCompletedEventHandler(
object sender,
AsyncCompletedEventArgs e
);

Parameters

sender
Sender of a notification .
e
Event arguments

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Mail Namespace


SmtpAuthentication Class

Represents the SMTP authentication supported by the SMTP server.

For a list of all members of this type, see SmtpAuthentication Members.

System.Object
Aspose.Email.Mail.SmtpAuthentication

public sealed class SmtpAuthentication

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SmtpAuthentication Members | Aspose.Email.Mail Namespace


SmtpAuthentication Members

SmtpAuthentication overview

Public Static Properties

Auto | Automatic selection of authorization protocol
CramMD5 | CRAM-MD5 authorization protocol
DigestMD5 | DIGEST-MD5 authorization protocol
Login | LOGIN authorization (Uses Base64 encoding.)
None | Without authorization
Ntlm | NTLM authorization protocol
Plain | PLAIN authorization (Uses Base64 encoding.)
XOAuth2 | OAuth 2.0 authorization protocol

Public Instance Methods

Equals | Checks equality of this object and operand.
GetHashCode | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a string that represents the current object.

See Also

SmtpAuthentication Class | Aspose.Email.Mail Namespace


SmtpAuthentication Properties

The properties of the SmtpAuthentication class are listed below. For a complete list of SmtpAuthentication class members, see the SmtpAuthentication Members topic.

Public Static Properties

Auto | Automatic selection of authorization protocol
CramMD5 | CRAM-MD5 authorization protocol
DigestMD5 | DIGEST-MD5 authorization protocol
Login | LOGIN authorization (Uses Base64 encoding.)
None | Without authorization
Ntlm | NTLM authorization protocol
Plain | PLAIN authorization (Uses Base64 encoding.)
XOAuth2 | OAuth 2.0 authorization protocol

See Also

SmtpAuthentication Class | Aspose.Email.Mail Namespace


Auto Property

Aspose.Email

SmtpAuthentication.Auto Property

Automatic selection of authorization protocol

public static SmtpAuthentication Auto {get;}

See Also

SmtpAuthentication Class | Aspose.Email.Mail Namespace


CramMD5 Property

Aspose.Email

SmtpAuthentication.CramMD5 Property

CRAM-MD5 authorization protocol

public static SmtpAuthentication CramMD5 {get;}

See Also

SmtpAuthentication Class | Aspose.Email.Mail Namespace


DigestMD5 Property

Aspose.Email

SmtpAuthentication.DigestMD5 Property

DIGEST-MD5 authorization protocol

public static SmtpAuthentication DigestMD5 {get;}

See Also

SmtpAuthentication Class | Aspose.Email.Mail Namespace


Login Property

Aspose.Email

SmtpAuthentication.Login Property

LOGIN authorization (Uses Base64 encoding.)

public static SmtpAuthentication Login {get;}

See Also

SmtpAuthentication Class | Aspose.Email.Mail Namespace


None Property

Aspose.Email

SmtpAuthentication.None Property

Without authorization

public static SmtpAuthentication None {get;}

See Also

SmtpAuthentication Class | Aspose.Email.Mail Namespace


Ntlm Property

Aspose.Email

SmtpAuthentication.Ntlm Property

NTLM authorization protocol

public static SmtpAuthentication Ntlm {get;}

See Also

SmtpAuthentication Class | Aspose.Email.Mail Namespace


Plain Property

Aspose.Email

SmtpAuthentication.Plain Property

PLAIN authorization (Uses Base64 encoding.)

public static SmtpAuthentication Plain {get;}

See Also

SmtpAuthentication Class | Aspose.Email.Mail Namespace


XOAuth2 Property

Aspose.Email

SmtpAuthentication.XOAuth2 Property

OAuth 2.0 authorization protocol

public static SmtpAuthentication XOAuth2 {get;}

See Also

SmtpAuthentication Class | Aspose.Email.Mail Namespace


SmtpAuthentication Methods

The methods of the SmtpAuthentication class are listed below. For a complete list of SmtpAuthentication class members, see the SmtpAuthentication Members topic.

Public Instance Methods

Equals | Checks equality of this object and operand.
GetHashCode | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a string that represents the current object.

See Also

SmtpAuthentication Class | Aspose.Email.Mail Namespace


SmtpAuthentication.Equals Method

Checks equality of this object and operand.

public override bool Equals(
object o
);

Parameters

o
Object to compare

Return Value

Returns a boolean indicating if the passed in object obj is Equal to this.

See Also

SmtpAuthentication Class | Aspose.Email.Mail Namespace


SmtpAuthentication.GetHashCode Method

Returns the hash code for this instance.

public override int GetHashCode();

Return Value

The hash code for this instance.

See Also

SmtpAuthentication Class | Aspose.Email.Mail Namespace


SmtpAuthentication.ToString Method

Returns a string that represents the current object.

public override string ToString();

Return Value

A string that represents the current object.

See Also

SmtpAuthentication Class | Aspose.Email.Mail Namespace


SmtpClient Class

Allows applications to send messages by using the Simple Mail Transfer Protocol (SMTP).

For a list of all members of this type, see SmtpClient Members.

System.Object
Aspose.Email.CredentialsByHostClient
Aspose.Email.Mail.SmtpClient

public sealed class SmtpClient : CredentialsByHostClient, IMailTransferAgent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SmtpClient Members | Aspose.Email.Mail Namespace


SmtpClient Members

SmtpClient overview

Public Instance Constructors

SmtpClient Overloaded. Initializes a new instance of the SmtpClient class.

Public Instance Properties

AccessToken (inherited from CredentialsByHostClient) | Gets or sets the access token.
AuthenticationMethod | Gets or sets the authentication method.
ConnectionCheckupPeriod (inherited from CredentialsByHostClient) | Period of connection checking up in milliseconds. Default value is 5 min.
DeliveryMethod | Gets or sets the delivery method.
EnableSsl (inherited from CredentialsByHostClient) | Set to true if we need SSL
Encoding | Gets or sets the encoding.
HelloMessage | Gets or sets a HELO/EHLO string.
Host (inherited from CredentialsByHostClient) | Gets or sets the host name.
Password (inherited from CredentialsByHostClient) | Gets or sets the password.
PickupDirectoryLocation | Gets or sets the directory where applications save mail messages to be processed by the local SMTP server.
Port (inherited from CredentialsByHostClient) | Gets or sets the port.
SecurityMode | Gets or sets the security mode.
SocksProxy (inherited from CredentialsByHostClient) | Gets or sets SOCKS proxy for the client
Timeout (inherited from CredentialsByHostClient) | Gets or sets the timeout
TokenProvider (inherited from CredentialsByHostClient) | Gets or sets TokenProvider allowing to retrieve access token.
UseAuthentication (inherited from CredentialsByHostClient) | Indicates whether authentication is used.
UseDefaultCredentials | Gets or sets a Boolean value that controls whether the DefaultCredentials are sent with requests.
Username (inherited from CredentialsByHostClient) | Gets or sets the username.

Public Instance Methods

BeginSendMessage | Overloaded. Begins sending email asynchronously.
BulkSend | Overloaded. Sends the specified message collection.
Clone |
Dispose (inherited from CredentialsByHostClient) | Releases unmanaged and - optionally - managed resources
EndSendMessage | Waits for the asynchronous operation to complete.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCapabilities (inherited from CredentialsByHostClient) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Send | Overloaded. Creates and sends the specified message.
SendAsync | Overloaded. Sends mail asynchronously
SendAsyncCancel | Cancels sending mail asynchronously
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

OnConnect (inherited from CredentialsByHostClient) | The OnConnect event occurs when the clent establishes connection.
SendCompleted | Rises when mail sending is completed Only for asynchronous operations

Protected Internal Instance Fields

_accessToken (inherited from CredentialsByHostClient)
_inCall (inherited from CredentialsByHostClient)
_password (inherited from CredentialsByHostClient)
_tokenProvider (inherited from CredentialsByHostClient)
_username (inherited from CredentialsByHostClient)

Protected Internal Instance Properties

InCall (inherited from CredentialsByHostClient)

Protected Internal Instance Methods

CheckCredentials (inherited from CredentialsByHostClient)
Initialize

See Also

SmtpClient Class | Aspose.Email.Mail Namespace


SmtpClient Constructor

Initializes a new instance of the SmtpClient class.

Overload List

Initializes a new instance of the SmtpClient class.

public SmtpClient();

Initializes a new instance of the SmtpClient class by using configuration file settings.

public SmtpClient(Configuration);

Initializes a new instance of the SmtpClient class.

public SmtpClient(string);

Initializes a new instance of the SmtpClient class.

public SmtpClient(string,int);

Initializes a new instance of the SmtpClient class.

public SmtpClient(string,int,string,ITokenProvider);

Initializes a new instance of the SmtpClient class.

public SmtpClient(string,int,string,string);

Initializes a new instance of the SmtpClient class.

public SmtpClient(string,int,string,string,bool);

Initializes a new instance of the SmtpClient class.

public SmtpClient(string,string,ITokenProvider);

Initializes a new instance of the SmtpClient class.

public SmtpClient(string,string,string);

Initializes a new instance of the SmtpClient class.

public SmtpClient(string,string,string,bool);

See Also

SmtpClient Class | Aspose.Email.Mail Namespace


SmtpClient Constructor ()

Initializes a new instance of the SmtpClient class.

public SmtpClient();

See Also

SmtpClient Class | Aspose.Email.Mail Namespace | SmtpClient Constructor Overload List


SmtpClient Constructor (Configuration)

Initializes a new instance of the SmtpClient class by using configuration file settings.

public SmtpClient(
Configuration configuration
);

Parameters

configuration
The configuration.

Remarks

Initializes the Host, Port, Username, Password properties for the new SmtpClient.

See Also

SmtpClient Class | Aspose.Email.Mail Namespace | SmtpClient Constructor Overload List


SmtpClient Constructor (String)

Initializes a new instance of the SmtpClient class.

public SmtpClient(
string host
);

Parameters

host
The name of the host used for SMTP.

See Also

SmtpClient Class | Aspose.Email.Mail Namespace | SmtpClient Constructor Overload List


SmtpClient Constructor (String, Int32)

Initializes a new instance of the SmtpClient class.

public SmtpClient(
string host,
int port
);

Parameters

host
The name of the host used for SMTP.
port
The port used for SMTP.

See Also

SmtpClient Class | Aspose.Email.Mail Namespace | SmtpClient Constructor Overload List


SmtpClient Constructor (String, String, String)

Initializes a new instance of the SmtpClient class.

public SmtpClient(
string host,
string username,
string password
);

Parameters

host
The name of the host used for SMTP.
username
The username.
password
The password.

See Also

SmtpClient Class | Aspose.Email.Mail Namespace | SmtpClient Constructor Overload List


SmtpClient Constructor (String, Int32, String, String)

Initializes a new instance of the SmtpClient class.

public SmtpClient(
string host,
int port,
string username,
string password
);

Parameters

host
The name of the host used for SMTP.
port
The port used for SMTP.
username
The username.
password
The password.

See Also

SmtpClient Class | Aspose.Email.Mail Namespace | SmtpClient Constructor Overload List


SmtpClient Constructor (String, String, String, Boolean)

Initializes a new instance of the SmtpClient class.

public SmtpClient(
string host,
string username,
string authInfo,
bool useOAuth
);

Parameters

host
The name of the host used for SMTP.
username
The username.
authInfo
The user password or XOAUTH2 access token
useOAuth
Defines whether SASL XOAUTH2 mechanism is used to login to the server

See Also

SmtpClient Class | Aspose.Email.Mail Namespace | SmtpClient Constructor Overload List


SmtpClient Constructor (String, Int32, String, String, Boolean)

Initializes a new instance of the SmtpClient class.

public SmtpClient(
string host,
int port,
string username,
string authInfo,
bool useOAuth
);

Parameters

host
The name of the host used for SMTP.
port
The port used for SMTP.
username
The username.
authInfo
The user password or XOAUTH2 access token
useOAuth
Defines whether SASL XOAUTH2 mechanism is used to login to the server

See Also

SmtpClient Class | Aspose.Email.Mail Namespace | SmtpClient Constructor Overload List


SmtpClient Constructor (String, String, ITokenProvider)

Initializes a new instance of the SmtpClient class.

public SmtpClient(
string host,
string username,
ITokenProvider tokenProvider
);

Parameters

host
The name of the host used for SMTP.
username
The username.
tokenProvider
TokenProvider allowing to retrieve access token.

See Also

SmtpClient Class | Aspose.Email.Mail Namespace | SmtpClient Constructor Overload List


SmtpClient Constructor (String, Int32, String, ITokenProvider)

Initializes a new instance of the SmtpClient class.

public SmtpClient(
string host,
int port,
string username,
ITokenProvider tokenProvider
);

Parameters

host
The name of the host used for SMTP.
port
The port used for SMTP.
username
The username.
tokenProvider
TokenProvider allowing to retrieve access token.

See Also

SmtpClient Class | Aspose.Email.Mail Namespace | SmtpClient Constructor Overload List


SmtpClient Properties

The properties of the SmtpClient class are listed below. For a complete list of SmtpClient class members, see the SmtpClient Members topic.

Public Instance Properties

AccessToken (inherited from CredentialsByHostClient) | Gets or sets the access token.
AuthenticationMethod | Gets or sets the authentication method.
ConnectionCheckupPeriod (inherited from CredentialsByHostClient) | Period of connection checking up in milliseconds. Default value is 5 min.
DeliveryMethod | Gets or sets the delivery method.
EnableSsl (inherited from CredentialsByHostClient) | Set to true if we need SSL
Encoding | Gets or sets the encoding.
HelloMessage | Gets or sets a HELO/EHLO string.
Host (inherited from CredentialsByHostClient) | Gets or sets the host name.
Password (inherited from CredentialsByHostClient) | Gets or sets the password.
PickupDirectoryLocation | Gets or sets the directory where applications save mail messages to be processed by the local SMTP server.
Port (inherited from CredentialsByHostClient) | Gets or sets the port.
SecurityMode | Gets or sets the security mode.
SocksProxy (inherited from CredentialsByHostClient) | Gets or sets SOCKS proxy for the client
Timeout (inherited from CredentialsByHostClient) | Gets or sets the timeout
TokenProvider (inherited from CredentialsByHostClient) | Gets or sets TokenProvider allowing to retrieve access token.
UseAuthentication (inherited from CredentialsByHostClient) | Indicates whether authentication is used.
UseDefaultCredentials | Gets or sets a Boolean value that controls whether the DefaultCredentials are sent with requests.
Username (inherited from CredentialsByHostClient) | Gets or sets the username.

Protected Internal Instance Properties

InCall (inherited from CredentialsByHostClient)

See Also

SmtpClient Class | Aspose.Email.Mail Namespace


AuthenticationMethod Property

Aspose.Email

SmtpClient.AuthenticationMethod Property

Gets or sets the authentication method.

public SmtpAuthentication AuthenticationMethod {get; set;}

Property Value

A SmtpAuthentication that represents the authentication method.

See Also

SmtpClient Class | Aspose.Email.Mail Namespace


DeliveryMethod Property

Aspose.Email

SmtpClient.DeliveryMethod Property

Gets or sets the delivery method.

public SmtpDeliveryMethod DeliveryMethod {get; set;}

Property Value

An SmtpDeliveryMethod that indicates how messages are delivered.

See Also

SmtpClient Class | Aspose.Email.Mail Namespace


Encoding Property

Aspose.Email

SmtpClient.Encoding Property

Gets or sets the encoding.

public Encoding Encoding {get; set;}

Property Value

The encoding.

See Also

SmtpClient Class | Aspose.Email.Mail Namespace


HelloMessage Property

Aspose.Email

SmtpClient.HelloMessage Property

Gets or sets a HELO/EHLO string.

public string HelloMessage {get; set;}

See Also

SmtpClient Class | Aspose.Email.Mail Namespace


PickupDirectoryLocation Property

Aspose.Email

SmtpClient.PickupDirectoryLocation Property

Gets or sets the directory where applications save mail messages to be processed by the local SMTP server.

public string PickupDirectoryLocation {get; set;}

Property Value

A String that represents the pickup directory

See Also

SmtpClient Class | Aspose.Email.Mail Namespace


SecurityMode Property

Aspose.Email

SmtpClient.SecurityMode Property

Gets or sets the security mode.

public SmtpSslSecurityMode SecurityMode {get; set;}

Property Value

A SmtpSslSecurityMode that represents the security mode.

See Also

SmtpClient Class | Aspose.Email.Mail Namespace


UseDefaultCredentials Property

Aspose.Email

SmtpClient.UseDefaultCredentials Property

Gets or sets a Boolean value that controls whether the DefaultCredentials are sent with requests.

public override bool UseDefaultCredentials {get; set;}

See Also

SmtpClient Class | Aspose.Email.Mail Namespace


SmtpClient Methods

The methods of the SmtpClient class are listed below. For a complete list of SmtpClient class members, see the SmtpClient Members topic.

Public Instance Methods

BeginSendMessage | Overloaded. Begins sending email asynchronously.
BulkSend | Overloaded. Sends the specified message collection.
Clone |
Dispose (inherited from CredentialsByHostClient) | Releases unmanaged and - optionally - managed resources
EndSendMessage | Waits for the asynchronous operation to complete.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetCapabilities (inherited from CredentialsByHostClient) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Send | Overloaded. Creates and sends the specified message.
SendAsync | Overloaded. Sends mail asynchronously
SendAsyncCancel | Cancels sending mail asynchronously
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Internal Instance Methods

CheckCredentials (inherited from CredentialsByHostClient)
Initialize

See Also

SmtpClient Class | Aspose.Email.Mail Namespace


BeginSendMessage Method

Aspose.Email

SmtpClient.BeginSendMessage Method

Begins sending email asynchronously.

Overload List

Begins sending email asynchronously.

public IAsyncResult BeginSendMessage(MailMessage);

Begins sending email asynchronously.

public IAsyncResult BeginSendMessage(MailMessage,AsyncCallback,object);

See Also

SmtpClient Class | Aspose.Email.Mail Namespace


SmtpClient.BeginSendMessage Method (MailMessage)

Begins sending email asynchronously.

public IAsyncResult BeginSendMessage(
MailMessage message
);

Parameters

message
Represents an e-mail message

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

SmtpClient Class | Aspose.Email.Mail Namespace | SmtpClient.BeginSendMessage Overload List


SmtpClient.BeginSendMessage Method (MailMessage, AsyncCallback, Object)

Begins sending email asynchronously.

public IAsyncResult BeginSendMessage(
MailMessage message,
AsyncCallback callback,
object state
);

Parameters

message
Represents an e-mail message
callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

SmtpClient Class | Aspose.Email.Mail Namespace | SmtpClient.BeginSendMessage Overload List


BulkSend Method

Aspose.Email

SmtpClient.BulkSend Method

Sends the specified message collection.

Overload List

Sends the specified message collection.

public void BulkSend(MailMessageCollection);

Sends the specified messages.

public void BulkSend(IEnumerator);

See Also

SmtpClient Class | Aspose.Email.Mail Namespace


SmtpClient.BulkSend Method (MailMessageCollection)

Sends the specified message collection.

public void BulkSend(
MailMessageCollection messages
);

Parameters

messages
The collection of messages.

See Also

SmtpClient Class | Aspose.Email.Mail Namespace | SmtpClient.BulkSend Overload List


SmtpClient.BulkSend Method (IEnumerator)

Sends the specified messages.

public void BulkSend(
IEnumerator messages
);

Parameters

messages
The IEnumerator that supports a message iteration.

See Also

SmtpClient Class | Aspose.Email.Mail Namespace | SmtpClient.BulkSend Overload List


SmtpClient.Clone Method

public IMailTransferAgent Clone();

Implements

IMailTransferAgent.Clone

See Also

SmtpClient Class | Aspose.Email.Mail Namespace


SmtpClient.EndSendMessage Method

Waits for the asynchronous operation to complete.

public void EndSendMessage(
IAsyncResult asyncResult
);

Parameters

asyncResult
The reference to the pending asynchronous request to wait for.

See Also

SmtpClient Class | Aspose.Email.Mail Namespace


SmtpClient.Initialize Method

protected internal override void Initialize();

See Also

SmtpClient Class | Aspose.Email.Mail Namespace


Send Method

Aspose.Email

SmtpClient.Send Method

Sends the specified message.

Overload List

Sends the specified message.

public void Send(MailMessage);

Creates and sends the specified message.

public void Send(string,string,string,string);

See Also

SmtpClient Class | Aspose.Email.Mail Namespace


SmtpClient.Send Method (MailMessage)

Sends the specified message.

public void Send(
MailMessage message
);

Parameters

message
The MailMessage that represents an email-message.

Implements

IMailTransferAgent.Send

See Also

SmtpClient Class | Aspose.Email.Mail Namespace | SmtpClient.Send Overload List


SmtpClient.Send Method (String, String, String, String)

Creates and sends the specified message.

public void Send(
string from,
string recipients,
string subject,
string body
);

Parameters

from
A String that contains the address of message sender.
recipients
A String that contains the address of recipients.
subject
A subject of message.
body
A body of message.

See Also

SmtpClient Class | Aspose.Email.Mail Namespace | SmtpClient.Send Overload List


SendAsync Method

Aspose.Email

SmtpClient.SendAsync Method

Sends mail asynchronously

Overload List

Sends mail asynchronously

public void SendAsync(MailMessage,object);

Sends mail asynchronously

public void SendAsync(string,string,string,string,object);

See Also

SmtpClient Class | Aspose.Email.Mail Namespace


SmtpClient.SendAsync Method (MailMessage, Object)

Sends mail asynchronously

public void SendAsync(
MailMessage message,
object userToken
);

Parameters

message
Represents an e-mail message
userToken
User token

See Also

SmtpClient Class | Aspose.Email.Mail Namespace | SmtpClient.SendAsync Overload List


SmtpClient.SendAsync Method (String, String, String, String, Object)

Sends mail asynchronously

public void SendAsync(
string from,
string recipients,
string subject,
string body,
object userToken
);

Parameters

from
A String that contains the address of message sender.
recipients
A String that contains the address of recipients.
subject
A subject of message.
body
A body of message.
userToken
User token

See Also

SmtpClient Class | Aspose.Email.Mail Namespace | SmtpClient.SendAsync Overload List


SmtpClient.SendAsyncCancel Method

Cancels sending mail asynchronously

public void SendAsyncCancel();

See Also

SmtpClient Class | Aspose.Email.Mail Namespace


SmtpClient Events

The events of the SmtpClient class are listed below. For a complete list of SmtpClient class members, see the SmtpClient Members topic.

Public Instance Events

OnConnect (inherited from CredentialsByHostClient) | The OnConnect event occurs when the clent establishes connection.
SendCompleted | Rises when mail sending is completed Only for asynchronous operations

See Also

SmtpClient Class | Aspose.Email.Mail Namespace


SmtpClient.SendCompleted Event

Rises when mail sending is completed Only for asynchronous operations

public event SendCompletedEventHandler SendCompleted;

See Also

SmtpClient Class | Aspose.Email.Mail Namespace


SmtpClientBulkSendAgent Class

Represents a multi-threading agent for E-mail delivery using SmtpClient.

For a list of all members of this type, see SmtpClientBulkSendAgent Members.

System.Object
Aspose.Email.Mail.SmtpClientBulkSendAgent

public class SmtpClientBulkSendAgent : IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SmtpClientBulkSendAgent Members | Aspose.Email.Mail Namespace


SmtpClientBulkSendAgent Members

SmtpClientBulkSendAgent overview

Public Instance Constructors

SmtpClientBulkSendAgent Overloaded. Initializes a new instance of the SmtpClientBulkSendAgent class.

Public Instance Properties

ActiveThreads | Gets the number of active threads.
Client | Gets or sets the smtpclient.
DeliveryInterval | Gets the interval of mail message delivery.
FailedDeliveryMessages | Gets the failed delivery Email messages.
InnerExceptions | Gets the exception list.
MessagePool | Gets the message pool.
TotalFailed | Gets the number of total failed Email messages.
TotalProcessed | Gets the number of total processed Email messages.
TotalQueued | Gets the number of total queued Email messages.
TotalSent | Gets the number of total sent Email messages.
TotolSent | Obsolete. Gets the number of total sent Email messages.

Public Instance Methods

AddMessage | Add messages to Message Pool.
AddMessages | Add messages to Message Pool.
ClearMessages | Clear the Email messages in the Message Pool.
Dispose | Overloaded. Releases the unmanaged resources used by the SmtpClientBulkSendAgent.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Start | Start the Bulk send.
Stop | Stop the bulk sending.
ToString (inherited from Object) | Returns a String that represents the current Object.
WaitForIdle | Wait for the thread pool to be idle

Public Instance Events

BulkSendCompleted | Occurs when bulk send operation is completed.
LastMessageSending | Occurs if the the last message in MessagePool send is begining.
MessageSending | Occurs if the message is started to send.
MessageSent | Occurs if the message has been sent.

Protected Instance Methods

Dispose | Overloaded. Releases the unmanaged resources used by the SmtpClientBulkSendAgent, and optionally disposes of the managed resources.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

DoSendMailMessage

See Also

SmtpClientBulkSendAgent Class | Aspose.Email.Mail Namespace


SmtpClientBulkSendAgent Constructor

Initialize an instance of SmtpclientBulkSendAgent class with specified SmtpClient.

Overload List

Initialize an instance of SmtpclientBulkSendAgent class with specified SmtpClient.

public SmtpClientBulkSendAgent(SmtpClient);

Initialize an instance of SmtpclientBulkSendAgent class with specified SmtpClient.

public SmtpClientBulkSendAgent(SmtpClient,int);

See Also

SmtpClientBulkSendAgent Class | Aspose.Email.Mail Namespace


SmtpClientBulkSendAgent Constructor (SmtpClient)

Initialize an instance of SmtpclientBulkSendAgent class with specified SmtpClient.

public SmtpClientBulkSendAgent(
SmtpClient client
);

Parameters

client
The SmtpClient settings used to send E-mail messages.

See Also

SmtpClientBulkSendAgent Class | Aspose.Email.Mail Namespace | SmtpClientBulkSendAgent Constructor Overload List


SmtpClientBulkSendAgent Constructor (SmtpClient, Int32)

Initialize an instance of SmtpclientBulkSendAgent class with specified SmtpClient.

public SmtpClientBulkSendAgent(
SmtpClient client,
int concurrent
);

Parameters

client
The SmtpClient settings used to send E-mail messages.
concurrent
The concurrent threads number.

See Also

SmtpClientBulkSendAgent Class | Aspose.Email.Mail Namespace | SmtpClientBulkSendAgent Constructor Overload List


SmtpClientBulkSendAgent Properties

The properties of the SmtpClientBulkSendAgent class are listed below. For a complete list of SmtpClientBulkSendAgent class members, see the SmtpClientBulkSendAgent Members topic.

Public Instance Properties

ActiveThreads | Gets the number of active threads.
Client | Gets or sets the smtpclient.
DeliveryInterval | Gets the interval of mail message delivery.
FailedDeliveryMessages | Gets the failed delivery Email messages.
InnerExceptions | Gets the exception list.
MessagePool | Gets the message pool.
TotalFailed | Gets the number of total failed Email messages.
TotalProcessed | Gets the number of total processed Email messages.
TotalQueued | Gets the number of total queued Email messages.
TotalSent | Gets the number of total sent Email messages.
TotolSent | Obsolete. Gets the number of total sent Email messages.

See Also

SmtpClientBulkSendAgent Class | Aspose.Email.Mail Namespace


ActiveThreads Property

Aspose.Email

SmtpClientBulkSendAgent.ActiveThreads Property

Gets the number of active threads.

public int ActiveThreads {get;}

See Also

SmtpClientBulkSendAgent Class | Aspose.Email.Mail Namespace


Client Property

Aspose.Email

SmtpClientBulkSendAgent.Client Property

Gets or sets the smtpclient.

public SmtpClient Client {get;}

See Also

SmtpClientBulkSendAgent Class | Aspose.Email.Mail Namespace


DeliveryInterval Property

Aspose.Email

SmtpClientBulkSendAgent.DeliveryInterval Property

Gets the interval of mail message delivery.

public int DeliveryInterval {get; set;}

See Also

SmtpClientBulkSendAgent Class | Aspose.Email.Mail Namespace


FailedDeliveryMessages Property

Aspose.Email

SmtpClientBulkSendAgent.FailedDeliveryMessages Property

Gets the failed delivery Email messages.

public MailMessageCollection FailedDeliveryMessages {get;}

See Also

SmtpClientBulkSendAgent Class | Aspose.Email.Mail Namespace


InnerExceptions Property

Aspose.Email

SmtpClientBulkSendAgent.InnerExceptions Property

Gets the exception list.

public ArrayList InnerExceptions {get;}

See Also

SmtpClientBulkSendAgent Class | Aspose.Email.Mail Namespace


MessagePool Property

Aspose.Email

SmtpClientBulkSendAgent.MessagePool Property

Gets the message pool.

public MailMessageCollection MessagePool {get;}

See Also

SmtpClientBulkSendAgent Class | Aspose.Email.Mail Namespace


TotalFailed Property

Aspose.Email

SmtpClientBulkSendAgent.TotalFailed Property

Gets the number of total failed Email messages.

public int TotalFailed {get;}

See Also

SmtpClientBulkSendAgent Class | Aspose.Email.Mail Namespace


TotalProcessed Property

Aspose.Email

SmtpClientBulkSendAgent.TotalProcessed Property

Gets the number of total processed Email messages.

public int TotalProcessed {get;}

See Also

SmtpClientBulkSendAgent Class | Aspose.Email.Mail Namespace


TotalQueued Property

Aspose.Email

SmtpClientBulkSendAgent.TotalQueued Property

Gets the number of total queued Email messages.

public int TotalQueued {get;}

See Also

SmtpClientBulkSendAgent Class | Aspose.Email.Mail Namespace


TotalSent Property

Aspose.Email

SmtpClientBulkSendAgent.TotalSent Property

Gets the number of total sent Email messages.

public int TotalSent {get;}

See Also

SmtpClientBulkSendAgent Class | Aspose.Email.Mail Namespace


TotolSent Property

Aspose.Email

SmtpClientBulkSendAgent.TotolSent Property

NOTE: This property is now obsolete.

Please use TotalSent instead

Gets the number of total sent Email messages.

public int TotolSent {get;}

See Also

SmtpClientBulkSendAgent Class | Aspose.Email.Mail Namespace


SmtpClientBulkSendAgent Methods

The methods of the SmtpClientBulkSendAgent class are listed below. For a complete list of SmtpClientBulkSendAgent class members, see the SmtpClientBulkSendAgent Members topic.

Public Instance Methods

AddMessage | Add messages to Message Pool.
AddMessages | Add messages to Message Pool.
ClearMessages | Clear the Email messages in the Message Pool.
Dispose | Overloaded. Releases the unmanaged resources used by the SmtpClientBulkSendAgent.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Start | Start the Bulk send.
Stop | Stop the bulk sending.
ToString (inherited from Object) | Returns a String that represents the current Object.
WaitForIdle | Wait for the thread pool to be idle

Protected Instance Methods

Dispose | Overloaded. Releases the unmanaged resources used by the SmtpClientBulkSendAgent, and optionally disposes of the managed resources.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Methods

DoSendMailMessage

See Also

SmtpClientBulkSendAgent Class | Aspose.Email.Mail Namespace


SmtpClientBulkSendAgent.AddMessage Method

Add messages to Message Pool.

public void AddMessage(
MailMessage message
);

Parameters

message
Mail message.

See Also

SmtpClientBulkSendAgent Class | Aspose.Email.Mail Namespace


SmtpClientBulkSendAgent.AddMessages Method

Add messages to Message Pool.

public void AddMessages(
MailMessageCollection messages
);

Parameters

messages
Mail messages collection

See Also

SmtpClientBulkSendAgent Class | Aspose.Email.Mail Namespace


SmtpClientBulkSendAgent.ClearMessages Method

Clear the Email messages in the Message Pool.

public void ClearMessages();

See Also

SmtpClientBulkSendAgent Class | Aspose.Email.Mail Namespace


Dispose Method

Aspose.Email

SmtpClientBulkSendAgent.Dispose Method

Releases the unmanaged resources used by the SmtpClientBulkSendAgent.

Overload List

Releases the unmanaged resources used by the SmtpClientBulkSendAgent.

public void Dispose();

Releases the unmanaged resources used by the SmtpClientBulkSendAgent, and optionally disposes of the managed resources.

protected virtual void Dispose(bool);

See Also

SmtpClientBulkSendAgent Class | Aspose.Email.Mail Namespace


SmtpClientBulkSendAgent.Dispose Method ()

Releases the unmanaged resources used by the SmtpClientBulkSendAgent.

public void Dispose();

Implements

IDisposable.Dispose

See Also

SmtpClientBulkSendAgent Class | Aspose.Email.Mail Namespace | SmtpClientBulkSendAgent.Dispose Overload List


SmtpClientBulkSendAgent.Dispose Method (Boolean)

Releases the unmanaged resources used by the SmtpClientBulkSendAgent, and optionally disposes of the managed resources.

protected virtual void Dispose(
bool disposing
);

Parameters

disposing
true to release both managed and unmanaged resources; false to releases only unmanaged resources.

See Also

SmtpClientBulkSendAgent Class | Aspose.Email.Mail Namespace | SmtpClientBulkSendAgent.Dispose Overload List


SmtpClientBulkSendAgent.DoSendMailMessage Method

protected internal virtual void DoSendMailMessage(
object state
);

See Also

SmtpClientBulkSendAgent Class | Aspose.Email.Mail Namespace


SmtpClientBulkSendAgent.Start Method

Start the Bulk send.

public void Start();

See Also

SmtpClientBulkSendAgent Class | Aspose.Email.Mail Namespace


SmtpClientBulkSendAgent.Stop Method

Stop the bulk sending.

public void Stop();

See Also

SmtpClientBulkSendAgent Class | Aspose.Email.Mail Namespace


SmtpClientBulkSendAgent.WaitForIdle Method

Wait for the thread pool to be idle

public void WaitForIdle();

See Also

SmtpClientBulkSendAgent Class | Aspose.Email.Mail Namespace


SmtpClientBulkSendAgent Events

The events of the SmtpClientBulkSendAgent class are listed below. For a complete list of SmtpClientBulkSendAgent class members, see the SmtpClientBulkSendAgent Members topic.

Public Instance Events

BulkSendCompleted | Occurs when bulk send operation is completed.
LastMessageSending | Occurs if the the last message in MessagePool send is begining.
MessageSending | Occurs if the message is started to send.
MessageSent | Occurs if the message has been sent.

See Also

SmtpClientBulkSendAgent Class | Aspose.Email.Mail Namespace


SmtpClientBulkSendAgent.BulkSendCompleted Event

Occurs when bulk send operation is completed.

public event EventHandler BulkSendCompleted;

See Also

SmtpClientBulkSendAgent Class | Aspose.Email.Mail Namespace


SmtpClientBulkSendAgent.LastMessageSending Event

Occurs if the the last message in MessagePool send is begining.

public event EventHandler LastMessageSending;

See Also

SmtpClientBulkSendAgent Class | Aspose.Email.Mail Namespace


SmtpClientBulkSendAgent.MessageSending Event

Occurs if the message is started to send.

public event EventHandler MessageSending;

See Also

SmtpClientBulkSendAgent Class | Aspose.Email.Mail Namespace


SmtpClientBulkSendAgent.MessageSent Event

Occurs if the message has been sent.

public event EventHandler MessageSent;

See Also

SmtpClientBulkSendAgent Class | Aspose.Email.Mail Namespace


SmtpClientBulkSendEventArgs Class

Provides data for the MessageSending and MessageSent events.

For a list of all members of this type, see SmtpClientBulkSendEventArgs Members.

System.Object
System.EventArgs
Aspose.Email.Mail.SmtpClientBulkSendEventArgs

public class SmtpClientBulkSendEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SmtpClientBulkSendEventArgs Members | Aspose.Email.Mail Namespace


SmtpClientBulkSendEventArgs Members

SmtpClientBulkSendEventArgs overview

Public Instance Constructors

SmtpClientBulkSendEventArgs Constructor Initializes a new instance of the SmtpBulkSendEventArgs class.

Public Instance Properties

Message Gets the sending message.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SmtpClientBulkSendEventArgs Class | Aspose.Email.Mail Namespace


SmtpClientBulkSendEventArgs Constructor

Initializes a new instance of the SmtpBulkSendEventArgs class.

public SmtpClientBulkSendEventArgs(
MailMessage message
);

Parameters

message
The message.

See Also

SmtpClientBulkSendEventArgs Class | Aspose.Email.Mail Namespace


SmtpClientBulkSendEventArgs Properties

The properties of the SmtpClientBulkSendEventArgs class are listed below. For a complete list of SmtpClientBulkSendEventArgs class members, see the SmtpClientBulkSendEventArgs Members topic.

Public Instance Properties

Message Gets the sending message.

See Also

SmtpClientBulkSendEventArgs Class | Aspose.Email.Mail Namespace


Message Property

Aspose.Email

SmtpClientBulkSendEventArgs.Message Property

Gets the sending message.

public MailMessage Message {get;}

Property Value

The MailMessage.

See Also

SmtpClientBulkSendEventArgs Class | Aspose.Email.Mail Namespace


SmtpDeliveryMethod Enumeration

Smtp delivery method

public enum SmtpDeliveryMethod

Members

Member Name | Description | Value
Network | Transporting messages through the network | 0
SpecifiedPickupDirectory | Transporting messages through the specified directory | 1
PickupDirectoryFromIis | Transporting messages through the specified IIS directory | 2

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Mail Namespace


SmtpException Class

Represents the exception that is thrown when the SmtpClient is not able to complete an operation.

For a list of all members of this type, see SmtpException Members.

System.Object
System.Exception
Aspose.Email.Mail.SmtpException
Aspose.Email.Mail.SmtpFailedBulkSendException
Aspose.Email.Mail.SmtpFailedRecipientException

public class SmtpException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SmtpException Members | Aspose.Email.Mail Namespace


SmtpException Members

SmtpException overview

Public Instance Constructors

SmtpException Overloaded. Initializes a new instance of the SmtpException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
StatusCode | Smtp status code
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

SmtpException Overloaded. Initializes a new instance of the SmtpException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SmtpException Class | Aspose.Email.Mail Namespace


SmtpException Constructor

Initializes a new instance of the SmtpException class

Overload List

Initializes a new instance of the SmtpException class

public SmtpException();

Initializes a new instance of the SmtpException class

public SmtpException(SmtpStatusCode);

Initializes a new instance of the SmtpException class

public SmtpException(SmtpStatusCode,string);

Initializes a new instance of the SmtpException class

protected SmtpException(SerializationInfo,StreamingContext);

Initializes a new instance of the SmtpException class

public SmtpException(string);

Initializes a new instance of the SmtpException class

public SmtpException(string,Exception);

See Also

SmtpException Class | Aspose.Email.Mail Namespace


SmtpException Constructor (SmtpStatusCode)

Initializes a new instance of the SmtpException class

public SmtpException(
SmtpStatusCode statusCode
);

Parameters

statusCode
Smtp status code

See Also

SmtpException Class | Aspose.Email.Mail Namespace | SmtpException Constructor Overload List


SmtpException Constructor (SmtpStatusCode, String)

Initializes a new instance of the SmtpException class

public SmtpException(
SmtpStatusCode statusCode,
string message
);

Parameters

statusCode
Smtp status code
message
Error message

See Also

SmtpException Class | Aspose.Email.Mail Namespace | SmtpException Constructor Overload List


SmtpException Constructor ()

Initializes a new instance of the SmtpException class

public SmtpException();

See Also

SmtpException Class | Aspose.Email.Mail Namespace | SmtpException Constructor Overload List


SmtpException Constructor (String)

Initializes a new instance of the SmtpException class

public SmtpException(
string message
);

Parameters

message
Error message

See Also

SmtpException Class | Aspose.Email.Mail Namespace | SmtpException Constructor Overload List


SmtpException Constructor (String, Exception)

Initializes a new instance of the SmtpException class

public SmtpException(
string message,
Exception innerException
);

Parameters

message
Error message
innerException
The exception that is the cause of the current exception, or a null reference (Nothing in Visual Basic) if no inner exception is specified.

See Also

SmtpException Class | Aspose.Email.Mail Namespace | SmtpException Constructor Overload List


SmtpException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the SmtpException class

protected SmtpException(
SerializationInfo serializationInfo,
StreamingContext streamingContext
);

Parameters

serializationInfo
Serialization info
streamingContext
Streaming context

See Also

SmtpException Class | Aspose.Email.Mail Namespace | SmtpException Constructor Overload List


SmtpException Properties

The properties of the SmtpException class are listed below. For a complete list of SmtpException class members, see the SmtpException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
StatusCode | Smtp status code
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

SmtpException Class | Aspose.Email.Mail Namespace


StatusCode Property

Aspose.Email

SmtpException.StatusCode Property

Smtp status code

public SmtpStatusCode StatusCode {get; set;}

See Also

SmtpException Class | Aspose.Email.Mail Namespace


SmtpException Methods

The methods of the SmtpException class are listed below. For a complete list of SmtpException class members, see the SmtpException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SmtpException Class | Aspose.Email.Mail Namespace


SmtpException.GetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

public override void GetObjectData(
SerializationInfo serializationInfo,
StreamingContext streamingContext
);

Parameters

serializationInfo
The SerializationInfo to populate with data.
streamingContext
The destination (see StreamingContext) for this serialization.

Exceptions

Exception Type | Condition
SecurityException | The caller does not have the required permission.

See Also

SmtpException Class | Aspose.Email.Mail Namespace


SmtpFailedBulkSendException Class

Represents the exception thrown in bulk sending email message.

For a list of all members of this type, see SmtpFailedBulkSendException Members.

System.Object
System.Exception
Aspose.Email.Mail.SmtpException
Aspose.Email.Mail.SmtpFailedBulkSendException

public class SmtpFailedBulkSendException : SmtpException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SmtpFailedBulkSendException Members | Aspose.Email.Mail Namespace


SmtpFailedBulkSendException Members

SmtpFailedBulkSendException overview

Public Instance Constructors

SmtpFailedBulkSendException Overloaded. Initializes a new instance of the SmtpFailedBulkSendException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
FailedSentMessages | Gets the email message that fail to send.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
InnerExceptions | Gets a list of inner exceptions.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
StatusCode (inherited from SmtpException) | Smtp status code
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

SmtpFailedBulkSendException Overloaded. Initializes a new instance of the SmtpFailedBulkSendException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SmtpFailedBulkSendException Class | Aspose.Email.Mail Namespace


SmtpFailedBulkSendException Constructor

Initializes a new instance of the SmtpFailedBulkSendException class.

Overload List

Initializes a new instance of the SmtpFailedBulkSendException class.

public SmtpFailedBulkSendException();

Initializes a new instance of the SmtpFailedBulkSendException class.

protected SmtpFailedBulkSendException(SerializationInfo,StreamingContext);

Initializes a new instance of the SmtpFailedBulkSendException class.

public SmtpFailedBulkSendException(string);

Initializes a new instance of the SmtpFailedBulkSendException class.

public SmtpFailedBulkSendException(string,MailMessageCollection,ArrayList);

Initializes a new instance of the SmtpFailedBulkSendException class with a specified error message and a reference to the inner exception that is the cause of this exception.

public SmtpFailedBulkSendException(string,Exception);

See Also

SmtpFailedBulkSendException Class | Aspose.Email.Mail Namespace


SmtpFailedBulkSendException Constructor ()

Initializes a new instance of the SmtpFailedBulkSendException class.

public SmtpFailedBulkSendException();

See Also

SmtpFailedBulkSendException Class | Aspose.Email.Mail Namespace | SmtpFailedBulkSendException Constructor Overload List


SmtpFailedBulkSendException Constructor (String)

Initializes a new instance of the SmtpFailedBulkSendException class.

public SmtpFailedBulkSendException(
string message
);

Parameters

message
The error message.

See Also

SmtpFailedBulkSendException Class | Aspose.Email.Mail Namespace | SmtpFailedBulkSendException Constructor Overload List


SmtpFailedBulkSendException Constructor (String, MailMessageCollection, ArrayList)

Initializes a new instance of the SmtpFailedBulkSendException class.

public SmtpFailedBulkSendException(
string message,
MailMessageCollection failedMessages,
ArrayList innerExceptions
);

Parameters

message
The error message.
failedMessages
The email message fail to send.
innerExceptions

See Also

SmtpFailedBulkSendException Class | Aspose.Email.Mail Namespace | SmtpFailedBulkSendException Constructor Overload List


SmtpFailedBulkSendException Constructor (String, Exception)

Initializes a new instance of the SmtpFailedBulkSendException class with a specified error message and a reference to the inner exception that is the cause of this exception.

public SmtpFailedBulkSendException(
string message,
Exception innerException
);

Parameters

message
The error message that explains the reason for the exception.
innerException
The exception that is the cause of the current exception, or a null reference (Nothing in Visual Basic) if no inner exception is specified.

See Also

SmtpFailedBulkSendException Class | Aspose.Email.Mail Namespace | SmtpFailedBulkSendException Constructor Overload List


SmtpFailedBulkSendException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the SmtpFailedBulkSendException class.

protected SmtpFailedBulkSendException(
SerializationInfo info,
StreamingContext context
);

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception Type | Condition
ArgumentNullException | The info parameter is null.
SerializationException | The class name is null or HResult is zero (0).

See Also

SmtpFailedBulkSendException Class | Aspose.Email.Mail Namespace | SmtpFailedBulkSendException Constructor Overload List


SmtpFailedBulkSendException Properties

The properties of the SmtpFailedBulkSendException class are listed below. For a complete list of SmtpFailedBulkSendException class members, see the SmtpFailedBulkSendException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
FailedSentMessages | Gets the email message that fail to send.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
InnerExceptions | Gets a list of inner exceptions.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
StatusCode (inherited from SmtpException) | Smtp status code
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

SmtpFailedBulkSendException Class | Aspose.Email.Mail Namespace


FailedSentMessages Property

Aspose.Email

SmtpFailedBulkSendException.FailedSentMessages Property

Gets the email message that fail to send.

public MailMessageCollection FailedSentMessages {get;}

See Also

SmtpFailedBulkSendException Class | Aspose.Email.Mail Namespace


InnerExceptions Property

Aspose.Email

SmtpFailedBulkSendException.InnerExceptions Property

Gets a list of inner exceptions.

public ArrayList InnerExceptions {get;}

See Also

SmtpFailedBulkSendException Class | Aspose.Email.Mail Namespace


SmtpFailedBulkSendException Methods

The methods of the SmtpFailedBulkSendException class are listed below. For a complete list of SmtpFailedBulkSendException class members, see the SmtpFailedBulkSendException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SmtpFailedBulkSendException Class | Aspose.Email.Mail Namespace


SmtpFailedBulkSendException.GetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

public override void GetObjectData(
SerializationInfo info,
StreamingContext context
);

Parameters

info
The SerializationInfo to populate with data.
context
The destination (see StreamingContext) for this serialization.

Exceptions

Exception Type | Condition
SecurityException | The caller does not have the required permission.

See Also

SmtpFailedBulkSendException Class | Aspose.Email.Mail Namespace


SmtpFailedRecipientException Class

Represents the exception which arises when the specified recipient is wrong

For a list of all members of this type, see SmtpFailedRecipientException Members.

System.Object
System.Exception
Aspose.Email.Mail.SmtpException
Aspose.Email.Mail.SmtpFailedRecipientException
Aspose.Email.Mail.SmtpFailedRecipientsException

public class SmtpFailedRecipientException : SmtpException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SmtpFailedRecipientException Members | Aspose.Email.Mail Namespace


SmtpFailedRecipientException Members

SmtpFailedRecipientException overview

Public Instance Constructors

SmtpFailedRecipientException Overloaded. Initializes a new instance of the SmtpFailedRecipientException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
FailedRecipient | Failed recipient
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
StatusCode (inherited from SmtpException) | Smtp status code
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

SmtpFailedRecipientException Overloaded. Initializes a new instance of the SmtpFailedRecipientException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SmtpFailedRecipientException Class | Aspose.Email.Mail Namespace


SmtpFailedRecipientException Constructor

Initializes a new instance of the SmtpFailedRecipientException class

Overload List

Initializes a new instance of the SmtpFailedRecipientException class

public SmtpFailedRecipientException();

Initializes a new instance of the SmtpFailedRecipientException class

public SmtpFailedRecipientException(SmtpStatusCode,string);

Initializes a new instance of the SmtpFailedRecipientException class

public SmtpFailedRecipientException(SmtpStatusCode,string,string);

Initializes a new instance of the SmtpFailedRecipientException class

protected SmtpFailedRecipientException(SerializationInfo,StreamingContext);

Initializes a new instance of the SmtpFailedRecipientException class

public SmtpFailedRecipientException(string);

Initializes a new instance of the SmtpFailedRecipientException class

public SmtpFailedRecipientException(string,Exception);

Initializes a new instance of the SmtpFailedRecipientException class

public SmtpFailedRecipientException(string,string,Exception);

See Also

SmtpFailedRecipientException Class | Aspose.Email.Mail Namespace


SmtpFailedRecipientException Constructor ()

Initializes a new instance of the SmtpFailedRecipientException class

public SmtpFailedRecipientException();

See Also

SmtpFailedRecipientException Class | Aspose.Email.Mail Namespace | SmtpFailedRecipientException Constructor Overload List


SmtpFailedRecipientException Constructor (String)

Initializes a new instance of the SmtpFailedRecipientException class

public SmtpFailedRecipientException(
string message
);

Parameters

message
Error message

See Also

SmtpFailedRecipientException Class | Aspose.Email.Mail Namespace | SmtpFailedRecipientException Constructor Overload List


SmtpFailedRecipientException Constructor (String, Exception)

Initializes a new instance of the SmtpFailedRecipientException class

public SmtpFailedRecipientException(
string message,
Exception innerException
);

Parameters

message
Error message
innerException
The exception that is the cause of the current exception, or a null reference (Nothing in Visual Basic) if no inner exception is specified.

See Also

SmtpFailedRecipientException Class | Aspose.Email.Mail Namespace | SmtpFailedRecipientException Constructor Overload List


SmtpFailedRecipientException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the SmtpFailedRecipientException class

protected SmtpFailedRecipientException(
SerializationInfo info,
StreamingContext context
);

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

See Also

SmtpFailedRecipientException Class | Aspose.Email.Mail Namespace | SmtpFailedRecipientException Constructor Overload List


SmtpFailedRecipientException Constructor (SmtpStatusCode, String)

Initializes a new instance of the SmtpFailedRecipientException class

public SmtpFailedRecipientException(
SmtpStatusCode statusCode,
string failedRecipient
);

Parameters

statusCode
Status code
failedRecipient
Failed recipient

See Also

SmtpFailedRecipientException Class | Aspose.Email.Mail Namespace | SmtpFailedRecipientException Constructor Overload List


SmtpFailedRecipientException Constructor (SmtpStatusCode, String, String)

Initializes a new instance of the SmtpFailedRecipientException class

public SmtpFailedRecipientException(
SmtpStatusCode statusCode,
string failedRecipient,
string serverResponse
);

Parameters

statusCode
Status code
failedRecipient
Failed recipient
serverResponse
Server response

See Also

SmtpFailedRecipientException Class | Aspose.Email.Mail Namespace | SmtpFailedRecipientException Constructor Overload List


SmtpFailedRecipientException Constructor (String, String, Exception)

Initializes a new instance of the SmtpFailedRecipientException class

public SmtpFailedRecipientException(
string message,
string failedRecipient,
Exception innerException
);

Parameters

message
Error message
failedRecipient
Failed recipient
innerException
The exception that is the cause of the current exception, or a null reference (Nothing in Visual Basic) if no inner exception is specified.

See Also

SmtpFailedRecipientException Class | Aspose.Email.Mail Namespace | SmtpFailedRecipientException Constructor Overload List


SmtpFailedRecipientException Properties

The properties of the SmtpFailedRecipientException class are listed below. For a complete list of SmtpFailedRecipientException class members, see the SmtpFailedRecipientException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
FailedRecipient | Failed recipient
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
StatusCode (inherited from SmtpException) | Smtp status code
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

SmtpFailedRecipientException Class | Aspose.Email.Mail Namespace


FailedRecipient Property

Aspose.Email

SmtpFailedRecipientException.FailedRecipient Property

Failed recipient

public string FailedRecipient {get;}

See Also

SmtpFailedRecipientException Class | Aspose.Email.Mail Namespace


SmtpFailedRecipientException Methods

The methods of the SmtpFailedRecipientException class are listed below. For a complete list of SmtpFailedRecipientException class members, see the SmtpFailedRecipientException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SmtpFailedRecipientException Class | Aspose.Email.Mail Namespace


SmtpFailedRecipientException.GetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

public override void GetObjectData(
SerializationInfo serializationInfo,
StreamingContext streamingContext
);

Parameters

serializationInfo
The SerializationInfo to populate with data.
streamingContext
The destination (see StreamingContext) for this serialization.

Exceptions

Exception Type | Condition
SecurityException | The caller does not have the required permission.

See Also

SmtpFailedRecipientException Class | Aspose.Email.Mail Namespace


SmtpFailedRecipientsException Class

Summary description for SmtpFailedRecipientsException.

For a list of all members of this type, see SmtpFailedRecipientsException Members.

System.Object
System.Exception
Aspose.Email.Mail.SmtpException
Aspose.Email.Mail.SmtpFailedRecipientException
Aspose.Email.Mail.SmtpFailedRecipientsException

public class SmtpFailedRecipientsException : SmtpFailedRecipientException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SmtpFailedRecipientsException Members | Aspose.Email.Mail Namespace


SmtpFailedRecipientsException Members

SmtpFailedRecipientsException overview

Public Instance Constructors

SmtpFailedRecipientsException Overloaded. Initializes a new instance of the SmtpFailedRecipientsException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
FailedRecipient (inherited from SmtpFailedRecipientException) | Failed recipient
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
InnerExceptions | Array of inner exceptions
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
StatusCode (inherited from SmtpException) | Smtp status code
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

SmtpFailedRecipientsException Overloaded. Initializes a new instance of the SmtpFailedRecipientsException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SmtpFailedRecipientsException Class | Aspose.Email.Mail Namespace


SmtpFailedRecipientsException Constructor

Initializes a new instance of the SmtpFailedRecipientsException class

Overload List

Initializes a new instance of the SmtpFailedRecipientsException class

public SmtpFailedRecipientsException();

Initializes a new instance of the SmtpFailedRecipientException class

protected SmtpFailedRecipientsException(SerializationInfo,StreamingContext);

Initializes a new instance of the SmtpFailedRecipientsException class

public SmtpFailedRecipientsException(string);

Initializes a new instance of the SmtpFailedRecipientsException class

public SmtpFailedRecipientsException(string,SmtpFailedRecipientException[]);

Initializes a new instance of the SmtpFailedRecipientsException class

public SmtpFailedRecipientsException(string,Exception);

See Also

SmtpFailedRecipientsException Class | Aspose.Email.Mail Namespace


SmtpFailedRecipientsException Constructor ()

Initializes a new instance of the SmtpFailedRecipientsException class

public SmtpFailedRecipientsException();

See Also

SmtpFailedRecipientsException Class | Aspose.Email.Mail Namespace | SmtpFailedRecipientsException Constructor Overload List


SmtpFailedRecipientsException Constructor (String)

Initializes a new instance of the SmtpFailedRecipientsException class

public SmtpFailedRecipientsException(
string message
);

Parameters

message
Error message

See Also

SmtpFailedRecipientsException Class | Aspose.Email.Mail Namespace | SmtpFailedRecipientsException Constructor Overload List


SmtpFailedRecipientsException Constructor (String, Exception)

Initializes a new instance of the SmtpFailedRecipientsException class

public SmtpFailedRecipientsException(
string message,
Exception innerException
);

Parameters

message
Error message
innerException
The exception that is the cause of the current exception, or a null reference (Nothing in Visual Basic) if no inner exception is specified.

See Also

SmtpFailedRecipientsException Class | Aspose.Email.Mail Namespace | SmtpFailedRecipientsException Constructor Overload List


SmtpFailedRecipientsException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the SmtpFailedRecipientException class

protected SmtpFailedRecipientsException(
SerializationInfo info,
StreamingContext context
);

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

See Also

SmtpFailedRecipientsException Class | Aspose.Email.Mail Namespace | SmtpFailedRecipientsException Constructor Overload List


SmtpFailedRecipientsException Constructor (String, SmtpFailedRecipientException[])

Initializes a new instance of the SmtpFailedRecipientsException class

public SmtpFailedRecipientsException(
string message,
SmtpFailedRecipientException[] innerExceptions
);

Parameters

message
Error message
innerExceptions
The list of exceptions that is the cause of the current exception.

See Also

SmtpFailedRecipientsException Class | Aspose.Email.Mail Namespace | SmtpFailedRecipientsException Constructor Overload List


SmtpFailedRecipientsException Properties

The properties of the SmtpFailedRecipientsException class are listed below. For a complete list of SmtpFailedRecipientsException class members, see the SmtpFailedRecipientsException Members topic.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
FailedRecipient (inherited from SmtpFailedRecipientException) | Failed recipient
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
InnerExceptions | Array of inner exceptions
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
StatusCode (inherited from SmtpException) | Smtp status code
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

See Also

SmtpFailedRecipientsException Class | Aspose.Email.Mail Namespace


InnerExceptions Property

Aspose.Email

SmtpFailedRecipientsException.InnerExceptions Property

Array of inner exceptions

public SmtpFailedRecipientException[] InnerExceptions {get;}

See Also

SmtpFailedRecipientsException Class | Aspose.Email.Mail Namespace


SmtpFailedRecipientsException Methods

The methods of the SmtpFailedRecipientsException class are listed below. For a complete list of SmtpFailedRecipientsException class members, see the SmtpFailedRecipientsException Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SmtpFailedRecipientsException Class | Aspose.Email.Mail Namespace


SmtpFailedRecipientsException.GetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

public override void GetObjectData(
SerializationInfo serializationInfo,
StreamingContext streamingContext
);

Parameters

serializationInfo
The SerializationInfo to populate with data.
streamingContext
The destination (see StreamingContext) for this serialization.

Exceptions

Exception Type | Condition
SecurityException | The caller does not have the required permission.

See Also

SmtpFailedRecipientsException Class | Aspose.Email.Mail Namespace


SmtpSslSecurityMode Enumeration

Ssl security mode for smtp client

public enum SmtpSslSecurityMode

Members

Member Name | Description | Value
Explicit | Explicit mode. | 1
Implicit | Implicit mode. | 0

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Mail Namespace


SmtpStatusCode Enumeration

Smtp status codes

public enum SmtpStatusCode

Members

Member Name | Description | Value
None | Not defined | 0
GeneralFailure | General failure | -1
SystemStatus | System status, or system help reply. A SMTP status 211 is a message that gives details about the Mail Server status. In the case of a System Help reply, it is a message to the user requesting help information. | 211
HelpMessage | A help message for a human reader will follow. SMTP 214 is usually provided as a response to the “HELP” command. A user will usually receive this as a displays of information about the mail server and it will most likely be in the form of a link to the FAQ page of THAT particular SMTP software that is running on the mail server. Due to the nature of this error and how the email server responds, it is normally called a reply, as in SMTP Reply 214. | 214
ServiceReady | SMTP Service ready. | 220
ServiceClosingTransmissionChannel | Service closing transmission channel | 221
Ok | Requested action taken and completed. | 250
UserNotLocalWillForward | The recipient is not local to the server, but the server will accept and forward the message. | 251
CannotVerifyUserWillAttemptDelivery | The recipient cannot be VRFYed, but the server accepts the message and attempts delivery. | 252
StartMailInput | Start message input and end with. This indicates that the server is ready to accept the message itself | 354
ServiceNotAvailable | The service is not available and the connection will be closed. | 421
MailboxBusy | The requested command failed because the user’s mailbox was unavailable (such as being full). Try again later. | 450
LocalErrorInProcessing | The command has been aborted due to a server error. (on their side) | 451
InsufficientStorage | The command has been aborted because the server has insufficient system storage. | 452
ClientNotPermitted | Client does not have permission. TLS not available due to temporary reason. Encryption required for requested authentication mechanism. | 454
CommandUnrecognized | The server could not recognize the command due to a syntax error. | 500
SyntaxError | A syntax error was encountered in command arguments. | 501
CommandNotImplemented | This command is not implemented. | 502
BadCommandSequence | The server has encountered a bad sequence of commands. | 503
CommandParameterNotImplemented | Command parameter not implemented | 504
MustIssueStartTlsFirst | Normally, an authentication problem. But sometimes it's about the recipient's server blacklisting yours, or an invalid email address. | 530
MailboxUnavailable | It usually defines a non-existent email address on the remote side. | 550
UserNotLocalTryAlternatePath | "User not local or invalid address – Relay denied". Meaning, if both your address and the recipient's are not locally hosted by the server, a relay can be interrupted. | 551
ExceededStorageAllocation | "Requested mail actions aborted – Exceeded storage allocation": simply put, the recipient's mailbox has exceeded its limits. | 552
MailboxNameNotAllowed | "Requested action not taken – Mailbox name invalid". That is, there's an incorrect email address into the recipients line. | 553
TransactionFailed | This means that the transaction has failed. It's a permanent error and the server will not try to send the message again. | 554

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Mail Namespace


Task Class

Represents the exchange task information.

For a list of all members of this type, see Task Members.

System.Object
Aspose.Email.Mail.Task
Aspose.Email.Exchange.ExchangeTask

public class Task : IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Task Members | Aspose.Email.Mail Namespace


Task Members

Task overview

Public Instance Constructors

Task Constructor Initializes a new instance of the Task class.

Public Instance Properties

Attachments | Gets or sets a collection of file attached to the task.
Attendees | Gets or sets the attendees.
Body | Gets or sets a task body.
DueDate | Gets or sets a date when the task is due.
Method | Gets or sets iTIP methods associated with an task.
Organizer | Gets or sets the organizer.
PercentComplete | Gets or sets a pecent of task completion.
Priority | Gets or sets a task priority.
RelatedTo | Gets or sets a related UID
SequenceId | Gets or sets the sequence id.
StartDate | Gets or sets a start date of task.
Subject | Gets or sets a task subject.
UniqueId | Gets or sets unique identifier

Public Instance Methods

Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Request | Requests the object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

_attachments
_attendees
_body
_dueDate
_method
_organizer
_percentComplete
_priority
_relatedTo
_sequeneId
_startDate
_subject
_uid

See Also

Task Class | Aspose.Email.Mail Namespace


Task Constructor

Initializes a new instance of the Task class.

public Task();

See Also

Task Class | Aspose.Email.Mail Namespace


Task Fields

The fields of the Task class are listed below. For a complete list of Task class members, see the Task Members topic.

Protected Internal Instance Fields

_attachments
_attendees
_body
_dueDate
_method
_organizer
_percentComplete
_priority
_relatedTo
_sequeneId
_startDate
_subject
_uid

See Also

Task Class | Aspose.Email.Mail Namespace


Task._attachments Field

protected internal AttachmentCollection _attachments;

See Also

Task Class | Aspose.Email.Mail Namespace


Task._attendees Field

protected internal MailAddressCollection _attendees;

See Also

Task Class | Aspose.Email.Mail Namespace


Task._body Field

protected internal string _body;

See Also

Task Class | Aspose.Email.Mail Namespace


Task._dueDate Field

protected internal DateTime _dueDate;

See Also

Task Class | Aspose.Email.Mail Namespace


Task._method Field

protected internal TIPMethod _method;

See Also

Task Class | Aspose.Email.Mail Namespace


Task._organizer Field

protected internal MailAddress _organizer;

See Also

Task Class | Aspose.Email.Mail Namespace


Task._percentComplete Field

protected internal float _percentComplete;

See Also

Task Class | Aspose.Email.Mail Namespace


Task._priority Field

protected internal MailPriority _priority;

See Also

Task Class | Aspose.Email.Mail Namespace


Task._relatedTo Field

protected internal string _relatedTo;

See Also

Task Class | Aspose.Email.Mail Namespace


Task._sequeneId Field

protected internal int _sequeneId;

See Also

Task Class | Aspose.Email.Mail Namespace


Task._startDate Field

protected internal DateTime _startDate;

See Also

Task Class | Aspose.Email.Mail Namespace


Task._subject Field

protected internal string _subject;

See Also

Task Class | Aspose.Email.Mail Namespace


Task._uid Field

protected internal string _uid;

See Also

Task Class | Aspose.Email.Mail Namespace


Task Properties

The properties of the Task class are listed below. For a complete list of Task class members, see the Task Members topic.

Public Instance Properties

Attachments | Gets or sets a collection of file attached to the task.
Attendees | Gets or sets the attendees.
Body | Gets or sets a task body.
DueDate | Gets or sets a date when the task is due.
Method | Gets or sets iTIP methods associated with an task.
Organizer | Gets or sets the organizer.
PercentComplete | Gets or sets a pecent of task completion.
Priority | Gets or sets a task priority.
RelatedTo | Gets or sets a related UID
SequenceId | Gets or sets the sequence id.
StartDate | Gets or sets a start date of task.
Subject | Gets or sets a task subject.
UniqueId | Gets or sets unique identifier

See Also

Task Class | Aspose.Email.Mail Namespace


Attachments Property

Aspose.Email

Task.Attachments Property

Gets or sets a collection of file attached to the task.

public AttachmentCollection Attachments {get; set;}

See Also

Task Class | Aspose.Email.Mail Namespace


Attendees Property

Aspose.Email

Task.Attendees Property

Gets or sets the attendees.

public MailAddressCollection Attendees {get; set;}

See Also

Task Class | Aspose.Email.Mail Namespace


Body Property

Aspose.Email

Task.Body Property

Gets or sets a task body.

public string Body {get; set;}

See Also

Task Class | Aspose.Email.Mail Namespace


DueDate Property

Aspose.Email

Task.DueDate Property

Gets or sets a date when the task is due.

public DateTime DueDate {get; set;}

See Also

Task Class | Aspose.Email.Mail Namespace


Method Property

Aspose.Email

Task.Method Property

Gets or sets iTIP methods associated with an task.

public TIPMethod Method {get; set;}

See Also

Task Class | Aspose.Email.Mail Namespace


Organizer Property

Aspose.Email

Task.Organizer Property

Gets or sets the organizer.

public MailAddress Organizer {get; set;}

See Also

Task Class | Aspose.Email.Mail Namespace


PercentComplete Property

Aspose.Email

Task.PercentComplete Property

Gets or sets a pecent of task completion.

public float PercentComplete {get; set;}

See Also

Task Class | Aspose.Email.Mail Namespace


Priority Property

Aspose.Email

Task.Priority Property

Gets or sets a task priority.

public MailPriority Priority {get; set;}

See Also

Task Class | Aspose.Email.Mail Namespace


RelatedTo Property

Aspose.Email

Task.RelatedTo Property

Gets or sets a related UID

public string RelatedTo {get; set;}

See Also

Task Class | Aspose.Email.Mail Namespace


SequenceId Property

Aspose.Email

Task.SequenceId Property

Gets or sets the sequence id.

public int SequenceId {get; set;}

Property Value

The sequence id.

See Also

Task Class | Aspose.Email.Mail Namespace


StartDate Property

Aspose.Email

Task.StartDate Property

Gets or sets a start date of task.

public DateTime StartDate {get; set;}

See Also

Task Class | Aspose.Email.Mail Namespace


Subject Property

Aspose.Email

Task.Subject Property

Gets or sets a task subject.

public string Subject {get; set;}

See Also

Task Class | Aspose.Email.Mail Namespace


UniqueId Property

Aspose.Email

Task.UniqueId Property

Gets or sets unique identifier

public string UniqueId {get; set;}

See Also

Task Class | Aspose.Email.Mail Namespace


Task Methods

The methods of the Task class are listed below. For a complete list of Task class members, see the Task Members topic.

Public Instance Methods

Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Request | Requests the object.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Task Class | Aspose.Email.Mail Namespace


Task.Dispose Method

Performs tasks associated with freeing, releasing, or resetting unmanaged resources.

public virtual void Dispose();

Implements

IDisposable.Dispose

See Also

Task Class | Aspose.Email.Mail Namespace


Task.Request Method

Requests the object.

public AlternateView Request();

Return Value

AlternateViewAlternateView that represents the format to view an email message.

See Also

Task Class | Aspose.Email.Mail Namespace


TemplateEngine Class

This class uses specified template to construct E-Mail messages.

For a list of all members of this type, see TemplateEngine Members.

System.Object
Aspose.Email.Mail.TemplateEngine

public sealed class TemplateEngine

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

The example demonstrates how to use TemplateEngine to contruct E-Mail messages.

[C#]

[Visual Basic]

Requirements
Namespace:  Aspose.Email.Mail
Assembly: Aspose.Email (in Aspose.Email.dll)

See Also
TemplateEngine Members | Aspose.Email.Mail Namespace


TemplateEngine Members

TemplateEngine overview

Public Instance Constructors

TemplateEngine Overloaded. Initializes a new instance of the TemplateEngine class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Instantiate | Overloaded. Instantiates the template with a DataTable as datasource.
IsRoutineRegistered | Determines if a name of template routine is registered in the template engine.
Merge | Merge a source MailMessage with the template
RegisterRoutine | Registers the template routine to the temaplate engine.
Reset | Resets this instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
UnregisterRoutine | Unregister the template routine from the template engine by name.

See Also

TemplateEngine Class | Aspose.Email.Mail Namespace


TemplateEngine Constructor

Initializes a new instance of the TemplateEngine class.

Overload List

Initializes a new instance of the TemplateEngine class.

public TemplateEngine(MailMessage);

Initializes a new instance of the TemplateEngine class.

public TemplateEngine(string);

See Also

TemplateEngine Class | Aspose.Email.Mail Namespace


TemplateEngine Constructor (String)

Initializes a new instance of the TemplateEngine class.

public TemplateEngine(
string fileName
);

Parameters

fileName
Name of the file.

See Also

TemplateEngine Class | Aspose.Email.Mail Namespace | TemplateEngine Constructor Overload List


TemplateEngine Constructor (MailMessage)

Initializes a new instance of the TemplateEngine class.

public TemplateEngine(
MailMessage templateMessage
);

Parameters

templateMessage
The template message.

See Also

TemplateEngine Class | Aspose.Email.Mail Namespace | TemplateEngine Constructor Overload List


TemplateEngine Methods

The methods of the TemplateEngine class are listed below. For a complete list of TemplateEngine class members, see the TemplateEngine Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Instantiate | Overloaded. Instantiates the template with a DataTable as datasource.
IsRoutineRegistered | Determines if a name of template routine is registered in the template engine.
Merge | Merge a source MailMessage with the template
RegisterRoutine | Registers the template routine to the temaplate engine.
Reset | Resets this instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
UnregisterRoutine | Unregister the template routine from the template engine by name.

See Also

TemplateEngine Class | Aspose.Email.Mail Namespace


Instantiate Method

Aspose.Email

TemplateEngine.Instantiate Method

Instantiates the template with a DataRowCollection as datasource.

Overload List

Instantiates the template with a DataRowCollection as datasource.

public MailMessageCollection Instantiate(DataRowCollection);

Instantiates the template with a DataRowCollection as datasource.

public MailMessageCollection Instantiate(DataRowCollection,DataColumnMappingCollection);

Instantiates the template with a DataTable as datasource.

public MailMessageCollection Instantiate(DataTable);

Instantiates the template with a DataTable as datasource.

public MailMessageCollection Instantiate(DataTable,DataColumnMappingCollection);

Instantiates the template with a IDataReader as datasource.

public MailMessageCollection Instantiate(IDataReader);

See Also

TemplateEngine Class | Aspose.Email.Mail Namespace


TemplateEngine.Instantiate Method (DataRowCollection)

Instantiates the template with a DataRowCollection as datasource.

public MailMessageCollection Instantiate(
DataRowCollection rows
);

Parameters

rows
The DataRowCollection, which contains the source data to instantiate the template.

Return Value

A MailMessageCollection that generated by the template and the datasource.

See Also

TemplateEngine Class | Aspose.Email.Mail Namespace | TemplateEngine.Instantiate Overload List


TemplateEngine.Instantiate Method (DataRowCollection, DataColumnMappingCollection)

Instantiates the template with a DataRowCollection as datasource.

public MailMessageCollection Instantiate(
DataRowCollection rows,
DataColumnMappingCollection mappings
);

Parameters

rows
The DataRowCollection, which contains the source data to instantiate the template.
mappings
The DataColumnMappingCollection, which represents the mapping between the source column in data source and target field in template

Return Value

A MailMessageCollection that generated by the template and the datasource.

See Also

TemplateEngine Class | Aspose.Email.Mail Namespace | TemplateEngine.Instantiate Overload List


TemplateEngine.Instantiate Method (DataTable)

Instantiates the template with a DataTable as datasource.

public MailMessageCollection Instantiate(
DataTable table
);

Parameters

table
The DataTable, which contains the source data to instantiate the template.

Return Value

A MailMessageCollection that generated by the template and the datasource.

See Also

TemplateEngine Class | Aspose.Email.Mail Namespace | TemplateEngine.Instantiate Overload List


TemplateEngine.Instantiate Method (DataTable, DataColumnMappingCollection)

Instantiates the template with a DataTable as datasource.

public MailMessageCollection Instantiate(
DataTable table,
DataColumnMappingCollection mappings
);

Parameters

table
The DataTable, which contains the source data to instantiate the template.
mappings
The DataColumnMappingCollection, which represents the mapping between the source column in DataTable and target field in template

Return Value

A MailMessageCollection that generated by the template and the datasource.

See Also

TemplateEngine Class | Aspose.Email.Mail Namespace | TemplateEngine.Instantiate Overload List


TemplateEngine.Instantiate Method (IDataReader)

Instantiates the template with a IDataReader as datasource.

public MailMessageCollection Instantiate(
IDataReader reader
);

Parameters

reader
The IDataReader, which will provide the source data to instantiate the template.

Return Value

A MailMessageCollection that generated by the template and the datasource.

See Also

TemplateEngine Class | Aspose.Email.Mail Namespace | TemplateEngine.Instantiate Overload List


TemplateEngine.IsRoutineRegistered Method

Determines if a name of template routine is registered in the template engine.

public bool IsRoutineRegistered(
string name
);

Parameters

name
The name that is used to register the template routine.

Return Value

Returns True if the name is registered in the template engine, otherwise returns False.

See Also

TemplateEngine Class | Aspose.Email.Mail Namespace


TemplateEngine.Merge Method

Merge a source MailMessage with the template

public MailMessage Merge(
MailMessage source
);

Parameters

source
The source MailMessage

Return Value

The MailMessage merged with template

Example

The following exmaple demonstrates how to create e-mail message.

[C#]

[Visual Basic]
See Also
TemplateEngine Class | Aspose.Email.Mail Namespace


TemplateEngine.RegisterRoutine Method

Registers the template routine to the temaplate engine.

public void RegisterRoutine(
string name,
TemplateRoutine routine
);

Parameters

name
The name of the funciton.
routine
Delegate processing the data

Example

[C#]

[Visual Basic]

See Also
TemplateEngine Class | Aspose.Email.Mail Namespace


TemplateEngine.Reset Method

Resets this instance.

public void Reset();

See Also

TemplateEngine Class | Aspose.Email.Mail Namespace


TemplateEngine.UnregisterRoutine Method

Unregister the template routine from the template engine by name.

public void UnregisterRoutine(
string name
);

Parameters

name
The name that is used to unregister the template routine.

See Also

TemplateEngine Class | Aspose.Email.Mail Namespace


TemplateRoutine Delegate

Represents the routine used in the template file.

public delegate object TemplateRoutine(
object[] args
);

Parameters

args
Arguments, which have to be processed by user-defined function.

Return Value

Operation result

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Mail Namespace


TIPMethod Enumeration

Defines the iTIP (iCalendar Transport-Independent Interoperability Protocol) methods associated with an object.

public enum TIPMethod

Members

Member Name | Description | Value
None | Method is not defined. | 0
Publish | Post notification of an object. Used primarily as a method of advertising the existence of an object. | 1
Request | Assign an object. This is an explicit assignment to one or more Calendar Users. The REQUEST method is also used to update or change an existing object. Clients that cannot handle REQUEST MAY degrade the method to treat it as a PUBLISH. | 2
Reply | Reply to an object request. | 3
Add | Add one or more instances to an existing object. | 4
Cancel | Cancel one or more instances of an existing object. | 5
Refresh | A request sent to an object Organizer asking for the latest version of an object. | 6
Counter | Counter a REQUEST with an alternative proposal. | 7
DeclineCounter | Decline a counter proposal by an Attendee. | 8

Requirements

Namespace: Aspose.Email.Mail

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Mail Namespace


Aspose.Email.Mail.Calendaring

Aspose.Email

Aspose.Email.Mail.Calendaring Namespace

Namespace hierarchy

Classes

Class | Description
DailyRecurrencePattern | Represents a recurrence pattern of daily recurrence type.
MonthlyRecurrencePattern | Represents a recurrence pattern of monthly recurrence type.
RecurrencePattern | Represents a recurrence pattern.
WeeklyRecurrencePattern | Represents a recurrence pattern of weekly recurrence type.
YearlyRecurrencePattern | Represents a recurrence pattern of yearly recurrence type.

Enumerations

Enumeration | Description
CalendarDay | Represents the day of the week.
CalendarMonth | Represents a calendar month.
DayPosition | Day positions, typically found in a month.


CalendarDay Enumeration

Represents the day of the week.

public enum CalendarDay

Members

Member Name | Description | Value
None | No values are set. | 0
Monday | Monday. | 1
Tuesday | Tuesday. | 2
Wednesday | Wednesday. | 3
Thursday | Thursday. | 4
Friday | Friday. | 5
Saturday | Saturday. | 6
Sunday | Sunday. | 7
Day | Represents all days of the week: SU,MO,TU,WE,TH,FR,SA. | 8
WeekDay | Represents weekdays of the week: MO,TU,WE,TH,FR. | 9
WeekendDay | Represents weekend days of the week: SU,SA. | 10

Requirements

Namespace: Aspose.Email.Mail.Calendaring

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Mail.Calendaring Namespace


CalendarMonth Enumeration

Represents a calendar month.

public enum CalendarMonth

Members

Member Name | Description | Value
None | No values are set. | 0
January | January. | 1
February | February. | 2
March | March. | 3
April | April. | 4
May | May. | 5
June | June. | 6
July | July. | 7
August | August. | 8
September | September. | 9
October | October. | 10
Novemeber | Novemeber. | 11
December | December. | 12

Requirements

Namespace: Aspose.Email.Mail.Calendaring

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Mail.Calendaring Namespace


DailyRecurrencePattern Class

Represents a recurrence pattern of daily recurrence type.

For a list of all members of this type, see DailyRecurrencePattern Members.

System.Object
Aspose.Email.Mail.Calendaring.RecurrencePattern
Aspose.Email.Mail.Calendaring.DailyRecurrencePattern

public class DailyRecurrencePattern : RecurrencePattern

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mail.Calendaring

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DailyRecurrencePattern Members | Aspose.Email.Mail.Calendaring Namespace


DailyRecurrencePattern Members

DailyRecurrencePattern overview

Public Instance Constructors

DailyRecurrencePattern Overloaded. Initializes a new instance of the DailyRecurrencePattern class.

Public Instance Properties

EndDate (inherited from RecurrencePattern) | Gets or sets the end date.
Interval (inherited from RecurrencePattern) | Gets or sets the number of recurrence units.
Occurs (inherited from RecurrencePattern) | Gets or sets the number of occurrences of the recurrence pattern.
WeekStart (inherited from RecurrencePattern) | Gets or sets the week start.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DailyRecurrencePattern Class | Aspose.Email.Mail.Calendaring Namespace


DailyRecurrencePattern Constructor

Initializes a new instance of the DailyRecurrencePattern class.

Overload List

Initializes a new instance of the DailyRecurrencePattern class.

public DailyRecurrencePattern(DateTime);

Initializes a new instance of the DailyRecurrencePattern class.

public DailyRecurrencePattern(DateTime,int);

Initializes a new instance of the DailyRecurrencePattern class.

public DailyRecurrencePattern(int);

Initializes a new instance of the DailyRecurrencePattern class.

public DailyRecurrencePattern(int,int);

See Also

DailyRecurrencePattern Class | Aspose.Email.Mail.Calendaring Namespace


DailyRecurrencePattern Constructor (DateTime)

Initializes a new instance of the DailyRecurrencePattern class.

public DailyRecurrencePattern(
DateTime endDate
);

Parameters

endDate
The end date.

See Also

DailyRecurrencePattern Class | Aspose.Email.Mail.Calendaring Namespace | DailyRecurrencePattern Constructor Overload List


DailyRecurrencePattern Constructor (Int32)

Initializes a new instance of the DailyRecurrencePattern class.

public DailyRecurrencePattern(
int occurs
);

Parameters

occurs
The Int32 value that represents number of occurrences.

See Also

DailyRecurrencePattern Class | Aspose.Email.Mail.Calendaring Namespace | DailyRecurrencePattern Constructor Overload List


DailyRecurrencePattern Constructor (DateTime, Int32)

Initializes a new instance of the DailyRecurrencePattern class.

public DailyRecurrencePattern(
DateTime endDate,
int interval
);

Parameters

endDate
The end date.
interval
The number of recurrence units.

See Also

DailyRecurrencePattern Class | Aspose.Email.Mail.Calendaring Namespace | DailyRecurrencePattern Constructor Overload List


DailyRecurrencePattern Constructor (Int32, Int32)

Initializes a new instance of the DailyRecurrencePattern class.

public DailyRecurrencePattern(
int occurs,
int interval
);

Parameters

occurs
The Int32 value that represents number of occurrences.
interval
The number of recurrence units.

See Also

DailyRecurrencePattern Class | Aspose.Email.Mail.Calendaring Namespace | DailyRecurrencePattern Constructor Overload List


DayPosition Enumeration

Day positions, typically found in a month.

public enum DayPosition

Members

Member Name | Description | Value
None | No values are set. | 0
First | First occurrence found in a given interval. | 1
Second | Second occurrence found in a given interval. | 2
Third | Third occurrence found in a given interval. | 3
Fourth | Fourth occurrence found in a given interval. | 4
Last | Last occurrence found in a given interval. | 5

Requirements

Namespace: Aspose.Email.Mail.Calendaring

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Mail.Calendaring Namespace


MonthlyRecurrencePattern Class

Represents a recurrence pattern of monthly recurrence type.

For a list of all members of this type, see MonthlyRecurrencePattern Members.

System.Object
Aspose.Email.Mail.Calendaring.RecurrencePattern
Aspose.Email.Mail.Calendaring.MonthlyRecurrencePattern

public class MonthlyRecurrencePattern : RecurrencePattern

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mail.Calendaring

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MonthlyRecurrencePattern Members | Aspose.Email.Mail.Calendaring Namespace


MonthlyRecurrencePattern Members

MonthlyRecurrencePattern overview

Public Instance Constructors

MonthlyRecurrencePattern Overloaded. Initializes a new instance of the MonthlyRecurrencePattern class.

Public Instance Properties

EndDate (inherited from RecurrencePattern) | Gets or sets the end date.
Interval (inherited from RecurrencePattern) | Gets or sets the number of recurrence units.
Occurs (inherited from RecurrencePattern) | Gets or sets the number of occurrences of the recurrence pattern.
StartDay | Gets or sets the start day.
StartOffset | Gets or sets the start offset.
StartPosition | Gets or sets the start position.
WeekStart (inherited from RecurrencePattern) | Gets or sets the week start.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MonthlyRecurrencePattern Class | Aspose.Email.Mail.Calendaring Namespace


MonthlyRecurrencePattern Constructor

Initializes a new instance of the MonthlyRecurrencePattern class.

Overload List

Initializes a new instance of the MonthlyRecurrencePattern class.

public MonthlyRecurrencePattern();

Initializes a new instance of the MonthlyRecurrencePattern class.

public MonthlyRecurrencePattern(DayPosition,CalendarDay,int);

Initializes a new instance of the MonthlyRecurrencePattern class.

public MonthlyRecurrencePattern(int,int);

See Also

MonthlyRecurrencePattern Class | Aspose.Email.Mail.Calendaring Namespace


MonthlyRecurrencePattern Constructor ()

Initializes a new instance of the MonthlyRecurrencePattern class.

public MonthlyRecurrencePattern();

See Also

MonthlyRecurrencePattern Class | Aspose.Email.Mail.Calendaring Namespace | MonthlyRecurrencePattern Constructor Overload List


MonthlyRecurrencePattern Constructor (Int32, Int32)

Initializes a new instance of the MonthlyRecurrencePattern class.

public MonthlyRecurrencePattern(
int startOffset,
int interval
);

Parameters

startOffset
The start offset.
interval
The number of recurrence units.

See Also

MonthlyRecurrencePattern Class | Aspose.Email.Mail.Calendaring Namespace | MonthlyRecurrencePattern Constructor Overload List


MonthlyRecurrencePattern Constructor (DayPosition, CalendarDay, Int32)

Initializes a new instance of the MonthlyRecurrencePattern class.

public MonthlyRecurrencePattern(
DayPosition startPosition,
CalendarDay startDay,
int interval
);

Parameters

startPosition
The start position.
startDay
The start day.
interval
The number of recurrence units.

See Also

MonthlyRecurrencePattern Class | Aspose.Email.Mail.Calendaring Namespace | MonthlyRecurrencePattern Constructor Overload List


MonthlyRecurrencePattern Properties

The properties of the MonthlyRecurrencePattern class are listed below. For a complete list of MonthlyRecurrencePattern class members, see the MonthlyRecurrencePattern Members topic.

Public Instance Properties

EndDate (inherited from RecurrencePattern) | Gets or sets the end date.
Interval (inherited from RecurrencePattern) | Gets or sets the number of recurrence units.
Occurs (inherited from RecurrencePattern) | Gets or sets the number of occurrences of the recurrence pattern.
StartDay | Gets or sets the start day.
StartOffset | Gets or sets the start offset.
StartPosition | Gets or sets the start position.
WeekStart (inherited from RecurrencePattern) | Gets or sets the week start.

See Also

MonthlyRecurrencePattern Class | Aspose.Email.Mail.Calendaring Namespace


StartDay Property

Aspose.Email

MonthlyRecurrencePattern.StartDay Property

Gets or sets the start day.

public CalendarDay StartDay {get; set;}

Property Value

The start day.

See Also

MonthlyRecurrencePattern Class | Aspose.Email.Mail.Calendaring Namespace


StartOffset Property

Aspose.Email

MonthlyRecurrencePattern.StartOffset Property

Gets or sets the start offset.

public int StartOffset {get; set;}

Property Value

The start offset.

See Also

MonthlyRecurrencePattern Class | Aspose.Email.Mail.Calendaring Namespace


StartPosition Property

Aspose.Email

MonthlyRecurrencePattern.StartPosition Property

Gets or sets the start position.

public DayPosition StartPosition {get; set;}

Property Value

The start position.

See Also

MonthlyRecurrencePattern Class | Aspose.Email.Mail.Calendaring Namespace


RecurrencePattern Class

Represents a recurrence pattern.

For a list of all members of this type, see RecurrencePattern Members.

System.Object
Aspose.Email.Mail.Calendaring.RecurrencePattern
Aspose.Email.Exchange.TaskRegeneratingPattern
Aspose.Email.Mail.Calendaring.DailyRecurrencePattern
Aspose.Email.Mail.Calendaring.MonthlyRecurrencePattern
Aspose.Email.Mail.Calendaring.WeeklyRecurrencePattern
Aspose.Email.Mail.Calendaring.YearlyRecurrencePattern

public abstract class RecurrencePattern

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mail.Calendaring

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RecurrencePattern Members | Aspose.Email.Mail.Calendaring Namespace


RecurrencePattern Members

RecurrencePattern overview

Public Instance Properties

EndDate | Gets or sets the end date.
Interval | Gets or sets the number of recurrence units.
Occurs | Gets or sets the number of occurrences of the recurrence pattern.
WeekStart | Gets or sets the week start.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

RecurrencePattern Overloaded. Initializes a new instance of the RecurrencePattern class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RecurrencePattern Class | Aspose.Email.Mail.Calendaring Namespace


RecurrencePattern Constructor

Initializes a new instance of the RecurrencePattern class.

Overload List

Initializes a new instance of the RecurrencePattern class.

protected RecurrencePattern();

protected RecurrencePattern(DateTime);

protected RecurrencePattern(DateTime,int);

protected RecurrencePattern(int);

protected RecurrencePattern(int,int);

See Also

RecurrencePattern Class | Aspose.Email.Mail.Calendaring Namespace


RecurrencePattern Constructor ()

Initializes a new instance of the RecurrencePattern class.

protected RecurrencePattern();

See Also

RecurrencePattern Class | Aspose.Email.Mail.Calendaring Namespace | RecurrencePattern Constructor Overload List


RecurrencePattern Constructor (DateTime)

protected RecurrencePattern(
DateTime endDate
);

See Also

RecurrencePattern Class | Aspose.Email.Mail.Calendaring Namespace | RecurrencePattern Constructor Overload List


RecurrencePattern Constructor (Int32)

protected RecurrencePattern(
int occurs
);

See Also

RecurrencePattern Class | Aspose.Email.Mail.Calendaring Namespace | RecurrencePattern Constructor Overload List


RecurrencePattern Constructor (DateTime, Int32)

protected RecurrencePattern(
DateTime endDate,
int interval
);

See Also

RecurrencePattern Class | Aspose.Email.Mail.Calendaring Namespace | RecurrencePattern Constructor Overload List


RecurrencePattern Constructor (Int32, Int32)

protected RecurrencePattern(
int occurs,
int interval
);

See Also

RecurrencePattern Class | Aspose.Email.Mail.Calendaring Namespace | RecurrencePattern Constructor Overload List


RecurrencePattern Properties

The properties of the RecurrencePattern class are listed below. For a complete list of RecurrencePattern class members, see the RecurrencePattern Members topic.

Public Instance Properties

EndDate | Gets or sets the end date.
Interval | Gets or sets the number of recurrence units.
Occurs | Gets or sets the number of occurrences of the recurrence pattern.
WeekStart | Gets or sets the week start.

See Also

RecurrencePattern Class | Aspose.Email.Mail.Calendaring Namespace


EndDate Property

Aspose.Email

RecurrencePattern.EndDate Property

Gets or sets the end date.

public DateTime EndDate {get; set;}

Property Value

The end date.

See Also

RecurrencePattern Class | Aspose.Email.Mail.Calendaring Namespace


Interval Property

Aspose.Email

RecurrencePattern.Interval Property

Gets or sets the number of recurrence units.

public int Interval {get; set;}

Property Value

The number of recurrence units.

See Also

RecurrencePattern Class | Aspose.Email.Mail.Calendaring Namespace


Occurs Property

Aspose.Email

RecurrencePattern.Occurs Property

Gets or sets the number of occurrences of the recurrence pattern.

public int Occurs {get; set;}

Property Value

The number of occurrences.

See Also

RecurrencePattern Class | Aspose.Email.Mail.Calendaring Namespace


WeekStart Property

Aspose.Email

RecurrencePattern.WeekStart Property

Gets or sets the week start.

public CalendarDay WeekStart {get; set;}

Property Value

The week start.

See Also

RecurrencePattern Class | Aspose.Email.Mail.Calendaring Namespace


WeeklyRecurrencePattern Class

Represents a recurrence pattern of weekly recurrence type.

For a list of all members of this type, see WeeklyRecurrencePattern Members.

System.Object
Aspose.Email.Mail.Calendaring.RecurrencePattern
Aspose.Email.Mail.Calendaring.WeeklyRecurrencePattern

public class WeeklyRecurrencePattern : RecurrencePattern

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mail.Calendaring

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

WeeklyRecurrencePattern Members | Aspose.Email.Mail.Calendaring Namespace


WeeklyRecurrencePattern Members

WeeklyRecurrencePattern overview

Public Instance Constructors

WeeklyRecurrencePattern Overloaded. Initializes a new instance of the WeeklyRecurrencePattern class.

Public Instance Properties

EndDate (inherited from RecurrencePattern) | Gets or sets the end date.
Interval (inherited from RecurrencePattern) | Gets or sets the number of recurrence units.
Occurs (inherited from RecurrencePattern) | Gets or sets the number of occurrences of the recurrence pattern.
StartDays | Gets or sets the start days.
WeekStart (inherited from RecurrencePattern) | Gets or sets the week start.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

WeeklyRecurrencePattern Class | Aspose.Email.Mail.Calendaring Namespace


WeeklyRecurrencePattern Constructor

Initializes a new instance of the WeeklyRecurrencePattern class.

Overload List

Initializes a new instance of the WeeklyRecurrencePattern class.

public WeeklyRecurrencePattern(DateTime);

Initializes a new instance of the WeeklyRecurrencePattern class.

public WeeklyRecurrencePattern(DateTime,int);

Initializes a new instance of the WeeklyRecurrencePattern class.

public WeeklyRecurrencePattern(int);

Initializes a new instance of the WeeklyRecurrencePattern class.

public WeeklyRecurrencePattern(int,int);

See Also

WeeklyRecurrencePattern Class | Aspose.Email.Mail.Calendaring Namespace


WeeklyRecurrencePattern Constructor (DateTime)

Initializes a new instance of the WeeklyRecurrencePattern class.

public WeeklyRecurrencePattern(
DateTime endDate
);

Parameters

endDate
The end date.

See Also

WeeklyRecurrencePattern Class | Aspose.Email.Mail.Calendaring Namespace | WeeklyRecurrencePattern Constructor Overload List


WeeklyRecurrencePattern Constructor (Int32)

Initializes a new instance of the WeeklyRecurrencePattern class.

public WeeklyRecurrencePattern(
int occurs
);

Parameters

occurs
The number of occurrences.

See Also

WeeklyRecurrencePattern Class | Aspose.Email.Mail.Calendaring Namespace | WeeklyRecurrencePattern Constructor Overload List


WeeklyRecurrencePattern Constructor (DateTime, Int32)

Initializes a new instance of the WeeklyRecurrencePattern class.

public WeeklyRecurrencePattern(
DateTime endDate,
int interval
);

Parameters

endDate
The end date.
interval
The number of recurrence units.

See Also

WeeklyRecurrencePattern Class | Aspose.Email.Mail.Calendaring Namespace | WeeklyRecurrencePattern Constructor Overload List


WeeklyRecurrencePattern Constructor (Int32, Int32)

Initializes a new instance of the WeeklyRecurrencePattern class.

public WeeklyRecurrencePattern(
int occurs,
int interval
);

Parameters

occurs
The number of occurrences.
interval
The number of recurrence units.

See Also

WeeklyRecurrencePattern Class | Aspose.Email.Mail.Calendaring Namespace | WeeklyRecurrencePattern Constructor Overload List


WeeklyRecurrencePattern Properties

The properties of the WeeklyRecurrencePattern class are listed below. For a complete list of WeeklyRecurrencePattern class members, see the WeeklyRecurrencePattern Members topic.

Public Instance Properties

EndDate (inherited from RecurrencePattern) | Gets or sets the end date.
Interval (inherited from RecurrencePattern) | Gets or sets the number of recurrence units.
Occurs (inherited from RecurrencePattern) | Gets or sets the number of occurrences of the recurrence pattern.
StartDays | Gets or sets the start days.
WeekStart (inherited from RecurrencePattern) | Gets or sets the week start.

See Also

WeeklyRecurrencePattern Class | Aspose.Email.Mail.Calendaring Namespace


StartDays Property

Aspose.Email

WeeklyRecurrencePattern.StartDays Property

Gets or sets the start days.

public CalendarDay[] StartDays {get; set;}

Property Value

The start days.

See Also

WeeklyRecurrencePattern Class | Aspose.Email.Mail.Calendaring Namespace


YearlyRecurrencePattern Class

Represents a recurrence pattern of yearly recurrence type.

For a list of all members of this type, see YearlyRecurrencePattern Members.

System.Object
Aspose.Email.Mail.Calendaring.RecurrencePattern
Aspose.Email.Mail.Calendaring.YearlyRecurrencePattern

public class YearlyRecurrencePattern : RecurrencePattern

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mail.Calendaring

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

YearlyRecurrencePattern Members | Aspose.Email.Mail.Calendaring Namespace


YearlyRecurrencePattern Members

YearlyRecurrencePattern overview

Public Instance Constructors

YearlyRecurrencePattern Overloaded. Initializes a new instance of the YearlyRecurrencePattern class.

Public Instance Properties

EndDate (inherited from RecurrencePattern) | Gets or sets the end date.
Interval (inherited from RecurrencePattern) | Gets or sets the number of recurrence units.
Occurs (inherited from RecurrencePattern) | Gets or sets the number of occurrences of the recurrence pattern.
StartDay | Gets or sets the start day.
StartMonth | Gets or sets the start month.
StartOffset | Gets or sets the start offset.
StartPosition | Gets or sets the start position.
WeekStart (inherited from RecurrencePattern) | Gets or sets the week start.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

YearlyRecurrencePattern Class | Aspose.Email.Mail.Calendaring Namespace


YearlyRecurrencePattern Constructor

Initializes a new instance of the YearlyRecurrencePattern class.

Overload List

Initializes a new instance of the YearlyRecurrencePattern class.

public YearlyRecurrencePattern();

Initializes a new instance of the YearlyRecurrencePattern class.

public YearlyRecurrencePattern(CalendarDay,CalendarMonth,DayPosition);

Initializes a new instance of the YearlyRecurrencePattern class.

public YearlyRecurrencePattern(int,CalendarMonth);

See Also

YearlyRecurrencePattern Class | Aspose.Email.Mail.Calendaring Namespace


YearlyRecurrencePattern Constructor ()

Initializes a new instance of the YearlyRecurrencePattern class.

public YearlyRecurrencePattern();

See Also

YearlyRecurrencePattern Class | Aspose.Email.Mail.Calendaring Namespace | YearlyRecurrencePattern Constructor Overload List


YearlyRecurrencePattern Constructor (Int32, CalendarMonth)

Initializes a new instance of the YearlyRecurrencePattern class.

public YearlyRecurrencePattern(
int startOffset,
CalendarMonth startMonth
);

Parameters

startOffset
The start offset.
startMonth
The start month.

See Also

YearlyRecurrencePattern Class | Aspose.Email.Mail.Calendaring Namespace | YearlyRecurrencePattern Constructor Overload List


YearlyRecurrencePattern Constructor (CalendarDay, CalendarMonth, DayPosition)

Initializes a new instance of the YearlyRecurrencePattern class.

public YearlyRecurrencePattern(
CalendarDay startDay,
CalendarMonth startMonth,
DayPosition startPosition
);

Parameters

startDay
The start day.
startMonth
The start month.
startPosition
The start position.

See Also

YearlyRecurrencePattern Class | Aspose.Email.Mail.Calendaring Namespace | YearlyRecurrencePattern Constructor Overload List


YearlyRecurrencePattern Properties

The properties of the YearlyRecurrencePattern class are listed below. For a complete list of YearlyRecurrencePattern class members, see the YearlyRecurrencePattern Members topic.

Public Instance Properties

EndDate (inherited from RecurrencePattern) | Gets or sets the end date.
Interval (inherited from RecurrencePattern) | Gets or sets the number of recurrence units.
Occurs (inherited from RecurrencePattern) | Gets or sets the number of occurrences of the recurrence pattern.
StartDay | Gets or sets the start day.
StartMonth | Gets or sets the start month.
StartOffset | Gets or sets the start offset.
StartPosition | Gets or sets the start position.
WeekStart (inherited from RecurrencePattern) | Gets or sets the week start.

See Also

YearlyRecurrencePattern Class | Aspose.Email.Mail.Calendaring Namespace


StartDay Property

Aspose.Email

YearlyRecurrencePattern.StartDay Property

Gets or sets the start day.

public CalendarDay StartDay {get; set;}

Property Value

The start day.

See Also

YearlyRecurrencePattern Class | Aspose.Email.Mail.Calendaring Namespace


StartMonth Property

Aspose.Email

YearlyRecurrencePattern.StartMonth Property

Gets or sets the start month.

public CalendarMonth StartMonth {get; set;}

Property Value

The start month.

See Also

YearlyRecurrencePattern Class | Aspose.Email.Mail.Calendaring Namespace


StartOffset Property

Aspose.Email

YearlyRecurrencePattern.StartOffset Property

Gets or sets the start offset.

public int StartOffset {get; set;}

Property Value

The start offset.

See Also

YearlyRecurrencePattern Class | Aspose.Email.Mail.Calendaring Namespace


StartPosition Property

Aspose.Email

YearlyRecurrencePattern.StartPosition Property

Gets or sets the start position.

public DayPosition StartPosition {get; set;}

Property Value

The start position.

See Also

YearlyRecurrencePattern Class | Aspose.Email.Mail.Calendaring Namespace


Aspose.Email.Mime

Aspose.Email

Aspose.Email.Mime Namespace

Namespace hierarchy

Classes

Class | Description
ContentDisposition | Represents a Content-Disposition header.
ContentType | Represents a Content-Type header.
DispositionTypeNames | Represents the disposition type names.
HeaderCollection | Defines the collection of header fields
HeaderCollection.KeysCollection |
MediaTypeNames | Specifies the media type names for an e-mail message.
MediaTypeNames.Application |
MediaTypeNames.Image |
MediaTypeNames.Text |
MimeException | Provides information about MIME errors
MimeHeader | Represents the mime header defined in RFC 2822.

Interfaces

Interface | Description
IPreferredTextEncodingProvider |

Enumerations

Enumeration | Description
TransferEncoding | Specifies the Content-Transfer-Encoding header information.


ContentDisposition Class

Represents a Content-Disposition header.

For a list of all members of this type, see ContentDisposition Members.

System.Object
Aspose.Email.Mime.ContentDisposition

public class ContentDisposition

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mime

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ContentDisposition Members | Aspose.Email.Mime Namespace


ContentDisposition Members

ContentDisposition overview

Public Instance Constructors

ContentDisposition Overloaded. Initializes a new instance of the ContentDisposition class.

Public Instance Properties

CreationDate | Gets or sets the creation date.
DispositionType | Gets or sets the type of the disposition.
FileName | Gets or sets the file name for an attachment.
Inline | Gets or sets a value that determines the disposition type.
ModificationDate | Gets or sets the modification date.
Parameters | Gets the parameters.
ReadDate | Gets or sets the read date.
Size | Gets or sets the size of a file attachment.

Public Instance Methods

Equals | Determines whether the specified Object is equal to this instance.
GetHashCode | Returns a hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents this instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ContentDisposition Class | Aspose.Email.Mime Namespace


ContentDisposition Constructor

Initializes a new instance of the ContentDisposition class.

Overload List

Initializes a new instance of the ContentDisposition class.

public ContentDisposition();

Initializes a new instance of the ContentDisposition class.

public ContentDisposition(string);

See Also

ContentDisposition Class | Aspose.Email.Mime Namespace


ContentDisposition Constructor ()

Initializes a new instance of the ContentDisposition class.

public ContentDisposition();

See Also

ContentDisposition Class | Aspose.Email.Mime Namespace | ContentDisposition Constructor Overload List


ContentDisposition Constructor (String)

Initializes a new instance of the ContentDisposition class.

public ContentDisposition(
string disposition
);

Parameters

disposition
A value that contains the disposition.

See Also

ContentDisposition Class | Aspose.Email.Mime Namespace | ContentDisposition Constructor Overload List


ContentDisposition Properties

The properties of the ContentDisposition class are listed below. For a complete list of ContentDisposition class members, see the ContentDisposition Members topic.

Public Instance Properties

CreationDate | Gets or sets the creation date.
DispositionType | Gets or sets the type of the disposition.
FileName | Gets or sets the file name for an attachment.
Inline | Gets or sets a value that determines the disposition type.
ModificationDate | Gets or sets the modification date.
Parameters | Gets the parameters.
ReadDate | Gets or sets the read date.
Size | Gets or sets the size of a file attachment.

See Also

ContentDisposition Class | Aspose.Email.Mime Namespace


CreationDate Property

Aspose.Email

ContentDisposition.CreationDate Property

Gets or sets the creation date.

public DateTime CreationDate {get; set;}

Property Value

A DateTime value that indicates the file creation date; otherwise, MinValue if no date was specified.

See Also

ContentDisposition Class | Aspose.Email.Mime Namespace


DispositionType Property

Aspose.Email

ContentDisposition.DispositionType Property

Gets or sets the type of the disposition.

public string DispositionType {get; set;}

Property Value

The String that contains the disposition type.

See Also

ContentDisposition Class | Aspose.Email.Mime Namespace


FileName Property

Aspose.Email

ContentDisposition.FileName Property

Gets or sets the file name for an attachment.

public string FileName {get; set;}

Property Value

The name of the file.

See Also

ContentDisposition Class | Aspose.Email.Mime Namespace


Inline Property

Aspose.Email

ContentDisposition.Inline Property

Gets or sets a value that determines the disposition type.

public bool Inline {get; set;}

Property Value

true if content in the attachment is presented inline; otherwise, false.

See Also

ContentDisposition Class | Aspose.Email.Mime Namespace


ModificationDate Property

Aspose.Email

ContentDisposition.ModificationDate Property

Gets or sets the modification date.

public DateTime ModificationDate {get; set;}

Property Value

A DateTime value that indicates the file modification date; otherwise, MinValue if no date was specified.

See Also

ContentDisposition Class | Aspose.Email.Mime Namespace


Parameters Property

Aspose.Email

ContentDisposition.Parameters Property

Gets the parameters.

public StringDictionary Parameters {get;}

Property Value

A StringDictionary that contains parameter name/value pairs.

See Also

ContentDisposition Class | Aspose.Email.Mime Namespace


ReadDate Property

Aspose.Email

ContentDisposition.ReadDate Property

Gets or sets the read date.

public DateTime ReadDate {get; set;}

Property Value

A DateTime value that indicates the file read date; otherwise, MinValue if no date was specified.

See Also

ContentDisposition Class | Aspose.Email.Mime Namespace


Size Property

Aspose.Email

ContentDisposition.Size Property

Gets or sets the size of a file attachment.

public long Size {get; set;}

Property Value

A Int32 that specifies the number of bytes in the file attachment.

See Also

ContentDisposition Class | Aspose.Email.Mime Namespace


ContentDisposition Methods

The methods of the ContentDisposition class are listed below. For a complete list of ContentDisposition class members, see the ContentDisposition Members topic.

Public Instance Methods

Equals | Determines whether the specified Object is equal to this instance.
GetHashCode | Returns a hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents this instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ContentDisposition Class | Aspose.Email.Mime Namespace


ContentDisposition.Equals Method

Determines whether the specified Object is equal to this instance.

public override bool Equals(
object rparam
);

Parameters

rparam
The Object to compare with this instance.

Return Value

true if the specified Object is equal to this instance; otherwise, false.

See Also

ContentDisposition Class | Aspose.Email.Mime Namespace


ContentDisposition.GetHashCode Method

Returns a hash code for this instance.

public override int GetHashCode();

Return Value

A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.

See Also

ContentDisposition Class | Aspose.Email.Mime Namespace


ContentDisposition.ToString Method

Returns a String that represents this instance.

public override string ToString();

Return Value

A String that represents this instance.

See Also

ContentDisposition Class | Aspose.Email.Mime Namespace


ContentType Class

Represents a Content-Type header.

For a list of all members of this type, see ContentType Members.

System.Object
Aspose.Email.Mime.ContentType

public class ContentType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mime

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ContentType Members | Aspose.Email.Mime Namespace


ContentType Members

ContentType overview

Public Instance Constructors

ContentType Overloaded. Initializes a new instance of the ContentType class.

Public Instance Properties

Boundary | Gets or sets the value of the boundary parameter included in the Content-Type header.
CharSet | Gets or sets the value of the charset parameter.
MediaType | Gets or sets the internet media type.
Name | Gets or sets the value of the name parameter.
Parameters | Gets the dictionary that contains the parameters.

Public Instance Methods

Equals | Determines whether the specified Object is equal to this instance.
GetHashCode | Returns a hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents this instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ContentType Class | Aspose.Email.Mime Namespace


ContentType Constructor

Initializes a new instance of the ContentType class.

Overload List

Initializes a new instance of the ContentType class.

public ContentType();

Initializes a new instance of the ContentType class.

public ContentType(string);

See Also

ContentType Class | Aspose.Email.Mime Namespace


ContentType Constructor ()

Initializes a new instance of the ContentType class.

public ContentType();

See Also

ContentType Class | Aspose.Email.Mime Namespace | ContentType Constructor Overload List


ContentType Constructor (String)

Initializes a new instance of the ContentType class.

public ContentType(
string contentType
);

Parameters

contentType
Type of the content.

See Also

ContentType Class | Aspose.Email.Mime Namespace | ContentType Constructor Overload List


ContentType Properties

The properties of the ContentType class are listed below. For a complete list of ContentType class members, see the ContentType Members topic.

Public Instance Properties

Boundary | Gets or sets the value of the boundary parameter included in the Content-Type header.
CharSet | Gets or sets the value of the charset parameter.
MediaType | Gets or sets the internet media type.
Name | Gets or sets the value of the name parameter.
Parameters | Gets the dictionary that contains the parameters.

See Also

ContentType Class | Aspose.Email.Mime Namespace


Boundary Property

Aspose.Email

ContentType.Boundary Property

Gets or sets the value of the boundary parameter included in the Content-Type header.

public string Boundary {get; set;}

Property Value

A string that contains the value of boundary parameter.

See Also

ContentType Class | Aspose.Email.Mime Namespace


CharSet Property

Aspose.Email

ContentType.CharSet Property

Gets or sets the value of the charset parameter.

public string CharSet {get; set;}

Property Value

A string that contains the value of charset parameter.

See Also

ContentType Class | Aspose.Email.Mime Namespace


MediaType Property

Aspose.Email

ContentType.MediaType Property

Gets or sets the internet media type.

public string MediaType {get; set;}

Property Value

A String that contains the media type.

See Also

ContentType Class | Aspose.Email.Mime Namespace


Name Property

Aspose.Email

ContentType.Name Property

Gets or sets the value of the name parameter.

public string Name {get; set;}

Property Value

A String that contains the name.

See Also

ContentType Class | Aspose.Email.Mime Namespace


Parameters Property

Aspose.Email

ContentType.Parameters Property

Gets the dictionary that contains the parameters.

public StringDictionary Parameters {get;}

Property Value

A StringDictionary that contains name and value pairs.

See Also

ContentType Class | Aspose.Email.Mime Namespace


ContentType Methods

The methods of the ContentType class are listed below. For a complete list of ContentType class members, see the ContentType Members topic.

Public Instance Methods

Equals | Determines whether the specified Object is equal to this instance.
GetHashCode | Returns a hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents this instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ContentType Class | Aspose.Email.Mime Namespace


ContentType.Equals Method

Determines whether the specified Object is equal to this instance.

public override bool Equals(
object rparam
);

Parameters

rparam
The Object to compare with this instance.

Return Value

true if the specified Object is equal to this instance; otherwise, false.

See Also

ContentType Class | Aspose.Email.Mime Namespace


ContentType.GetHashCode Method

Returns a hash code for this instance.

public override int GetHashCode();

Return Value

A hash code for this instance, suitable for use in hashing algorithms and data structures like a hash table.

See Also

ContentType Class | Aspose.Email.Mime Namespace


ContentType.ToString Method

Returns a String that represents this instance.

public override string ToString();

Return Value

A String that represents this instance.

See Also

ContentType Class | Aspose.Email.Mime Namespace


DispositionTypeNames Class

Represents the disposition type names.

For a list of all members of this type, see DispositionTypeNames Members.

System.Object
Aspose.Email.Mime.DispositionTypeNames

public sealed class DispositionTypeNames

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mime

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DispositionTypeNames Members | Aspose.Email.Mime Namespace


DispositionTypeNames Members

DispositionTypeNames overview

Public Static Fields

Attachment | Name for attachment disposition type.
Inline | Name for inline disposition type.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DispositionTypeNames Class | Aspose.Email.Mime Namespace


DispositionTypeNames Fields

The fields of the DispositionTypeNames class are listed below. For a complete list of DispositionTypeNames class members, see the DispositionTypeNames Members topic.

Public Static Fields

Attachment | Name for attachment disposition type.
Inline | Name for inline disposition type.

See Also

DispositionTypeNames Class | Aspose.Email.Mime Namespace


DispositionTypeNames.Attachment Field

Name for attachment disposition type.

public const string Attachment = "attachment";

See Also

DispositionTypeNames Class | Aspose.Email.Mime Namespace


DispositionTypeNames.Inline Field

Name for inline disposition type.

public const string Inline = "inline";

See Also

DispositionTypeNames Class | Aspose.Email.Mime Namespace


HeaderCollection Class

Defines the collection of header fields

For a list of all members of this type, see HeaderCollection Members.

System.Object
Aspose.Email.Mime.HeaderCollection

public class HeaderCollection : ICollection, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mime

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

HeaderCollection Members | Aspose.Email.Mime Namespace


HeaderCollection Members

HeaderCollection overview

Public Instance Constructors

HeaderCollection Overloaded. Initializes a new instance of the HeaderCollection class.

Public Instance Properties

AllKeys | Gets an array of strings containing all header keys in collections
Count | Gets a count of headers
Item | Overloaded. Gets a value from collection by the name.
Keys | Gets a HeaderCollection.KeysCollection containing all header keys in collections

Public Instance Methods

Add | Overloaded. Adds a header to collection.
Add_ | Adds the header.
Clear | Clears all headers.
CopyTo | Copies all the elements of the current collection to the specified Array starting at the specified destination index.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Get | Overloaded. Gets the value at the specified index.
GetEnumerator | Returns an enumerator that iterates through a collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetKey | Gets the key at the specified index of the collection.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValues | Gets the header values.
HasKeys | Gets a value indicating whether the collection contains keys.
Remove | Removes the header from collection by a given header name.
Set | Sets the header.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

IsSynchronized
SyncRoot

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

HeaderCollection Class | Aspose.Email.Mime Namespace


HeaderCollection Constructor

Initializes a new instance of the HeaderCollection class.

Overload List

Initializes a new instance of the HeaderCollection class.

public HeaderCollection();

Initializes a new instance of the HeaderCollection class.

public HeaderCollection(HeaderCollection);

See Also

HeaderCollection Class | Aspose.Email.Mime Namespace


HeaderCollection Constructor (HeaderCollection)

Initializes a new instance of the HeaderCollection class.

public HeaderCollection(
HeaderCollection col
);

Parameters

col
The collection.

See Also

HeaderCollection Class | Aspose.Email.Mime Namespace | HeaderCollection Constructor Overload List


HeaderCollection Constructor ()

Initializes a new instance of the HeaderCollection class.

public HeaderCollection();

See Also

HeaderCollection Class | Aspose.Email.Mime Namespace | HeaderCollection Constructor Overload List


HeaderCollection Properties

The properties of the HeaderCollection class are listed below. For a complete list of HeaderCollection class members, see the HeaderCollection Members topic.

Public Instance Properties

AllKeys | Gets an array of strings containing all header keys in collections
Count | Gets a count of headers
Item | Overloaded. Gets a value from collection by the name.
Keys | Gets a HeaderCollection.KeysCollection containing all header keys in collections

Protected Instance Properties

IsSynchronized
SyncRoot

See Also

HeaderCollection Class | Aspose.Email.Mime Namespace


AllKeys Property

Aspose.Email

HeaderCollection.AllKeys Property

Gets an array of strings containing all header keys in collections

public virtual string[] AllKeys {get;}

See Also

HeaderCollection Class | Aspose.Email.Mime Namespace


Count Property

Aspose.Email

HeaderCollection.Count Property

Gets a count of headers

public virtual int Count {get;}

Implements

ICollection.Count

See Also

HeaderCollection Class | Aspose.Email.Mime Namespace


IsSynchronized Property

Aspose.Email

HeaderCollection.IsSynchronized Property

protected bool IsSynchronized {get;}

See Also

HeaderCollection Class | Aspose.Email.Mime Namespace


Item Property

Aspose.Email

HeaderCollection.Item Property

Gets a value from collection by the index.

Overload List

Gets a value from collection by the index.

public string this[int] {get;}

Gets a value from collection by the name.

public string this[string] {get; set;}

See Also

HeaderCollection Class | Aspose.Email.Mime Namespace


Item Property (Int32)

Aspose.Email

HeaderCollection.Item Property (Int32)

Gets a value from collection by the index.

public string this[
int index
] {get;}

Parameters

index
The index in collection for an item.

See Also

HeaderCollection Class | Aspose.Email.Mime Namespace | HeaderCollection.Item Overload List


Item Property (String)

Aspose.Email

HeaderCollection.Item Property (String)

Gets a value from collection by the name.

public string this[
string name
] {get; set;}

Parameters

name
The name (key) in collection for an item.

See Also

HeaderCollection Class | Aspose.Email.Mime Namespace | HeaderCollection.Item Overload List


Keys Property

Aspose.Email

HeaderCollection.Keys Property

Gets a HeaderCollection.KeysCollection containing all header keys in collections

public virtual KeysCollection Keys {get;}

See Also

HeaderCollection Class | Aspose.Email.Mime Namespace


SyncRoot Property

Aspose.Email

HeaderCollection.SyncRoot Property

protected object SyncRoot {get;}

See Also

HeaderCollection Class | Aspose.Email.Mime Namespace


HeaderCollection Methods

The methods of the HeaderCollection class are listed below. For a complete list of HeaderCollection class members, see the HeaderCollection Members topic.

Public Instance Methods

Add | Overloaded. Adds a header to collection.
Add_ | Adds the header.
Clear | Clears all headers.
CopyTo | Copies all the elements of the current collection to the specified Array starting at the specified destination index.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Get | Overloaded. Gets the value at the specified index.
GetEnumerator | Returns an enumerator that iterates through a collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetKey | Gets the key at the specified index of the collection.
GetType (inherited from Object) | Gets the Type of the current instance.
GetValues | Gets the header values.
HasKeys | Gets a value indicating whether the collection contains keys.
Remove | Removes the header from collection by a given header name.
Set | Sets the header.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

HeaderCollection Class | Aspose.Email.Mime Namespace


Add Method

Aspose.Email

HeaderCollection.Add Method

Adds a header to collection.

Overload List

Adds a header to collection.

public void Add(HeaderCollection);

Obsolete. Adds the header.

public void Add(MimeHeader);

Adds the header.

public void Add(string,string);

See Also

HeaderCollection Class | Aspose.Email.Mime Namespace


HeaderCollection.Add Method (HeaderCollection)

Adds a header to collection.

public void Add(
HeaderCollection c
);

Parameters

c
HeaderCollection for adding.

See Also

HeaderCollection Class | Aspose.Email.Mime Namespace | HeaderCollection.Add Overload List


HeaderCollection.Add Method (MimeHeader)

NOTE: This method is now obsolete.

Adds the header.

public void Add(
MimeHeader header
);

Parameters

header
The MimeHeader.

See Also

HeaderCollection Class | Aspose.Email.Mime Namespace | HeaderCollection.Add Overload List


HeaderCollection.Add Method (String, String)

Adds the header.

public void Add(
string name,
string value
);

Parameters

name
The header name.
value
The header value.

See Also

HeaderCollection Class | Aspose.Email.Mime Namespace | HeaderCollection.Add Overload List


HeaderCollection.Add_ Method

Adds the header.

public virtual void Add_(
string name,
string value
);

Parameters

name
The header name.
value
The header value.

See Also

HeaderCollection Class | Aspose.Email.Mime Namespace


HeaderCollection.Clear Method

Clears all headers.

public virtual void Clear();

See Also

HeaderCollection Class | Aspose.Email.Mime Namespace


HeaderCollection.CopyTo Method

Copies all the elements of the current collection to the specified Array starting at the specified destination index.

public void CopyTo(
Array dest,
int index
);

Parameters

dest
The destination of the elements copied from the current collection.
index
An integer that represents the index in array at which copying begins.

See Also

HeaderCollection Class | Aspose.Email.Mime Namespace


Get Method

Aspose.Email

HeaderCollection.Get Method

Gets the value at the specified index.

Overload List

Gets the value at the specified index.

public virtual string Get(int);

Gets the header value by a given header name.

public string Get(string);

See Also

HeaderCollection Class | Aspose.Email.Mime Namespace


HeaderCollection.Get Method (Int32)

Gets the value at the specified index.

public virtual string Get(
int index
);

Parameters

index
An integer that represents the position of the element to get.

Return Value

The value at the specified position in current collection.

See Also

HeaderCollection Class | Aspose.Email.Mime Namespace | HeaderCollection.Get Overload List


HeaderCollection.Get Method (String)

Gets the header value by a given header name.

public string Get(
string name
);

Parameters

name
The haeader name.

Return Value

The header value.

See Also

HeaderCollection Class | Aspose.Email.Mime Namespace | HeaderCollection.Get Overload List


HeaderCollection.GetEnumerator Method

Returns an enumerator that iterates through a collection.

public virtual IEnumerator GetEnumerator();

Return Value

An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerable.GetEnumerator

See Also

HeaderCollection Class | Aspose.Email.Mime Namespace


HeaderCollection.GetKey Method

Gets the key at the specified index of the collection.

public virtual string GetKey(
int index
);

Parameters

index
The index of the key.

Return Value

The key at the specified index.

See Also

HeaderCollection Class | Aspose.Email.Mime Namespace


HeaderCollection.GetValues Method

Gets the header values.

public string[] GetValues(
string name
);

Parameters

name
The header name.

Return Value

The collection of header values.

See Also

HeaderCollection Class | Aspose.Email.Mime Namespace


HeaderCollection.HasKeys Method

Gets a value indicating whether the collection contains keys.

public bool HasKeys();

Return Value

Returns true if collection has an items, otherwise returns false.

See Also

HeaderCollection Class | Aspose.Email.Mime Namespace


HeaderCollection.Remove Method

Removes the header from collection by a given header name.

public void Remove(
string name
);

Parameters

name
The header name.

See Also

HeaderCollection Class | Aspose.Email.Mime Namespace


HeaderCollection.Set Method

Sets the header.

public void Set(
string name,
string value
);

Parameters

name
The header name.
value
The header value.

See Also

HeaderCollection Class | Aspose.Email.Mime Namespace


HeaderCollection.KeysCollection Class

For a list of all members of this type, see HeaderCollection.KeysCollection Members.

System.Object
Aspose.Email.Mime.HeaderCollection.KeysCollection

public class HeaderCollection.KeysCollection : ICollection, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mime

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

HeaderCollection.KeysCollection Members | Aspose.Email.Mime Namespace


HeaderCollection.KeysCollection Members

HeaderCollection.KeysCollection overview

Public Instance Properties

Count
Item

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Get |
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

IsSynchronized
SyncRoot

Protected Instance Methods

CopyTo |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

HeaderCollection.KeysCollection Class | Aspose.Email.Mime Namespace


HeaderCollection.KeysCollection Properties

The properties of the HeaderCollection.KeysCollection class are listed below. For a complete list of HeaderCollection.KeysCollection class members, see the HeaderCollection.KeysCollection Members topic.

Public Instance Properties

Count
Item

Protected Instance Properties

IsSynchronized
SyncRoot

See Also

HeaderCollection.KeysCollection Class | Aspose.Email.Mime Namespace


Count Property

Aspose.Email

HeaderCollection.KeysCollection.Count Property

public int Count {get;}

Implements

ICollection.Count

See Also

HeaderCollection.KeysCollection Class | Aspose.Email.Mime Namespace


IsSynchronized Property

Aspose.Email

HeaderCollection.KeysCollection.IsSynchronized Property

protected bool IsSynchronized {get;}

See Also

HeaderCollection.KeysCollection Class | Aspose.Email.Mime Namespace


Item Property

Aspose.Email

HeaderCollection.KeysCollection.Item Property

public string this[
int index
] {get;}

See Also

HeaderCollection.KeysCollection Class | Aspose.Email.Mime Namespace


SyncRoot Property

Aspose.Email

HeaderCollection.KeysCollection.SyncRoot Property

protected object SyncRoot {get;}

See Also

HeaderCollection.KeysCollection Class | Aspose.Email.Mime Namespace


HeaderCollection.KeysCollection Methods

The methods of the HeaderCollection.KeysCollection class are listed below. For a complete list of HeaderCollection.KeysCollection class members, see the HeaderCollection.KeysCollection Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
Get |
GetEnumerator |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

CopyTo |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

HeaderCollection.KeysCollection Class | Aspose.Email.Mime Namespace


HeaderCollection.KeysCollection.CopyTo Method

protected void CopyTo(
Array array,
int index
);

See Also

HeaderCollection.KeysCollection Class | Aspose.Email.Mime Namespace


HeaderCollection.KeysCollection.Get Method

public virtual string Get(
int index
);

See Also

HeaderCollection.KeysCollection Class | Aspose.Email.Mime Namespace


HeaderCollection.KeysCollection.GetEnumerator Method

public IEnumerator GetEnumerator();

Implements

IEnumerable.GetEnumerator

See Also

HeaderCollection.KeysCollection Class | Aspose.Email.Mime Namespace


IPreferredTextEncodingProvider Interface

For a list of all members of this type, see IPreferredTextEncodingProvider Members.

public interface IPreferredTextEncodingProvider

Types that implement IPreferredTextEncodingProvider

Type | Description
Attachment | Represents an e-mail attachment.
MailMessage | Represents an e-mail message. It allows to access message properties, ex. subject, body, sender and recipients addreses, etc. Also it can be sent and delivered by means of supported mail protocols.

Requirements

Namespace: Aspose.Email.Mime

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

IPreferredTextEncodingProvider Members | Aspose.Email.Mime Namespace


IPreferredTextEncodingProvider Members

IPreferredTextEncodingProvider overview

Public Instance Properties

PreferredTextEncoding

See Also

IPreferredTextEncodingProvider Interface | Aspose.Email.Mime Namespace


IPreferredTextEncodingProvider Properties

The properties of the IPreferredTextEncodingProvider interface are listed below. For a complete list of IPreferredTextEncodingProvider interface members, see the IPreferredTextEncodingProvider Members topic.

Public Instance Properties

PreferredTextEncoding

See Also

IPreferredTextEncodingProvider Interface | Aspose.Email.Mime Namespace


PreferredTextEncoding Property

Aspose.Email

IPreferredTextEncodingProvider.PreferredTextEncoding Property

Encoding PreferredTextEncoding {get; set;}

See Also

IPreferredTextEncodingProvider Interface | Aspose.Email.Mime Namespace


MediaTypeNames Class

Specifies the media type names for an e-mail message.

For a list of all members of this type, see MediaTypeNames Members.

System.Object
Aspose.Email.Mime.MediaTypeNames

public sealed class MediaTypeNames

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mime

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MediaTypeNames Members | Aspose.Email.Mime Namespace


MediaTypeNames Members

MediaTypeNames overview

Public Static Methods

ParseName Converts file name extension to media type name

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MediaTypeNames Class | Aspose.Email.Mime Namespace


MediaTypeNames Methods

The methods of the MediaTypeNames class are listed below. For a complete list of MediaTypeNames class members, see the MediaTypeNames Members topic.

Public Static Methods

ParseName Converts file name extension to media type name

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MediaTypeNames Class | Aspose.Email.Mime Namespace


MediaTypeNames.ParseName Method

Converts file name extension to media type name

public static string ParseName(
string name
);

Parameters

name
File name extension

Return Value

Returns media type name

See Also

MediaTypeNames Class | Aspose.Email.Mime Namespace


MediaTypeNames.Application Class

For a list of all members of this type, see MediaTypeNames.Application Members.

System.Object
Aspose.Email.Mime.MediaTypeNames.Application

public sealed class MediaTypeNames.Application

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mime

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MediaTypeNames.Application Members | Aspose.Email.Mime Namespace


MediaTypeNames.Application Members

MediaTypeNames.Application overview

Public Static Fields

Octet
Pdf
Rtf
Soap
Zip

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MediaTypeNames.Application Class | Aspose.Email.Mime Namespace


MediaTypeNames.Application Fields

The fields of the MediaTypeNames.Application class are listed below. For a complete list of MediaTypeNames.Application class members, see the MediaTypeNames.Application Members topic.

Public Static Fields

Octet
Pdf
Rtf
Soap
Zip

See Also

MediaTypeNames.Application Class | Aspose.Email.Mime Namespace


MediaTypeNames.Application.Octet Field

public const string Octet = "application/octet-stream";

See Also

MediaTypeNames.Application Class | Aspose.Email.Mime Namespace


MediaTypeNames.Application.Pdf Field

public const string Pdf = "application/pdf";

See Also

MediaTypeNames.Application Class | Aspose.Email.Mime Namespace


MediaTypeNames.Application.Rtf Field

public const string Rtf = "application/rtf";

See Also

MediaTypeNames.Application Class | Aspose.Email.Mime Namespace


MediaTypeNames.Application.Soap Field

public const string Soap = "application/soap+xml";

See Also

MediaTypeNames.Application Class | Aspose.Email.Mime Namespace


MediaTypeNames.Application.Zip Field

public const string Zip = "application/zip";

See Also

MediaTypeNames.Application Class | Aspose.Email.Mime Namespace


MediaTypeNames.Image Class

For a list of all members of this type, see MediaTypeNames.Image Members.

System.Object
Aspose.Email.Mime.MediaTypeNames.Image

public sealed class MediaTypeNames.Image

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mime

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MediaTypeNames.Image Members | Aspose.Email.Mime Namespace


MediaTypeNames.Image Members

MediaTypeNames.Image overview

Public Static Fields

Bmp
Gif
Jpeg
Png
Tiff
Wmf

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MediaTypeNames.Image Class | Aspose.Email.Mime Namespace


MediaTypeNames.Image Fields

The fields of the MediaTypeNames.Image class are listed below. For a complete list of MediaTypeNames.Image class members, see the MediaTypeNames.Image Members topic.

Public Static Fields

Bmp
Gif
Jpeg
Png
Tiff
Wmf

See Also

MediaTypeNames.Image Class | Aspose.Email.Mime Namespace


MediaTypeNames.Image.Bmp Field

public const string Bmp = "image/bmp";

See Also

MediaTypeNames.Image Class | Aspose.Email.Mime Namespace


MediaTypeNames.Image.Gif Field

public const string Gif = "image/gif";

See Also

MediaTypeNames.Image Class | Aspose.Email.Mime Namespace


MediaTypeNames.Image.Jpeg Field

public const string Jpeg = "image/jpeg";

See Also

MediaTypeNames.Image Class | Aspose.Email.Mime Namespace


MediaTypeNames.Image.Png Field

public const string Png = "image/png";

See Also

MediaTypeNames.Image Class | Aspose.Email.Mime Namespace


MediaTypeNames.Image.Tiff Field

public const string Tiff = "image/tiff";

See Also

MediaTypeNames.Image Class | Aspose.Email.Mime Namespace


MediaTypeNames.Image.Wmf Field

public const string Wmf = "image/x-wmf";

See Also

MediaTypeNames.Image Class | Aspose.Email.Mime Namespace


MediaTypeNames.Text Class

For a list of all members of this type, see MediaTypeNames.Text Members.

System.Object
Aspose.Email.Mime.MediaTypeNames.Text

public sealed class MediaTypeNames.Text

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mime

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MediaTypeNames.Text Members | Aspose.Email.Mime Namespace


MediaTypeNames.Text Members

MediaTypeNames.Text overview

Public Static Fields

Html
Plain
RichText
Xml

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MediaTypeNames.Text Class | Aspose.Email.Mime Namespace


MediaTypeNames.Text Fields

The fields of the MediaTypeNames.Text class are listed below. For a complete list of MediaTypeNames.Text class members, see the MediaTypeNames.Text Members topic.

Public Static Fields

Html
Plain
RichText
Xml

See Also

MediaTypeNames.Text Class | Aspose.Email.Mime Namespace


MediaTypeNames.Text.Html Field

public const string Html = "text/html";

See Also

MediaTypeNames.Text Class | Aspose.Email.Mime Namespace


MediaTypeNames.Text.Plain Field

public const string Plain = "text/plain";

See Also

MediaTypeNames.Text Class | Aspose.Email.Mime Namespace


MediaTypeNames.Text.RichText Field

public const string RichText = "text/richtext";

See Also

MediaTypeNames.Text Class | Aspose.Email.Mime Namespace


MediaTypeNames.Text.Xml Field

public const string Xml = "text/xml";

See Also

MediaTypeNames.Text Class | Aspose.Email.Mime Namespace


MimeException Class

Provides information about MIME errors

For a list of all members of this type, see MimeException Members.

System.Object
System.Exception
Aspose.Email.Mime.MimeException

public class MimeException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mime

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MimeException Members | Aspose.Email.Mime Namespace


MimeException Members

MimeException overview

Public Instance Constructors

MimeException Overloaded. Initializes a new instance of the MimeException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

MimeException Overloaded. Initializes a new instance of the MimeException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MimeException Class | Aspose.Email.Mime Namespace


MimeException Constructor

Initializes a new instance of the MimeException class.

Overload List

Initializes a new instance of the MimeException class.

public MimeException();

Initializes a new instance of the MimeException class.

protected MimeException(SerializationInfo,StreamingContext);

Initializes a new instance of the MimeException class.

public MimeException(string);

Initializes a new instance of the MimeException class.

public MimeException(string,Exception);

See Also

MimeException Class | Aspose.Email.Mime Namespace


MimeException Constructor ()

Initializes a new instance of the MimeException class.

public MimeException();

See Also

MimeException Class | Aspose.Email.Mime Namespace | MimeException Constructor Overload List


MimeException Constructor (String)

Initializes a new instance of the MimeException class.

public MimeException(
string message
);

Parameters

message
The error message.

See Also

MimeException Class | Aspose.Email.Mime Namespace | MimeException Constructor Overload List


MimeException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the MimeException class.

protected MimeException(
SerializationInfo info,
StreamingContext context
);

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

See Also

MimeException Class | Aspose.Email.Mime Namespace | MimeException Constructor Overload List


MimeException Constructor (String, Exception)

Initializes a new instance of the MimeException class.

public MimeException(
string message,
Exception innerException
);

Parameters

message
The error message.
innerException
The inner exception.

See Also

MimeException Class | Aspose.Email.Mime Namespace | MimeException Constructor Overload List


MimeHeader Class

Represents the mime header defined in RFC 2822.

For a list of all members of this type, see MimeHeader Members.

System.Object
Aspose.Email.Mime.MimeHeader

public class MimeHeader

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Mime

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MimeHeader Members | Aspose.Email.Mime Namespace


MimeHeader Members

MimeHeader overview

Public Instance Constructors

MimeHeader Constructor Initializes a new instance of the MimeHeader class.

Public Instance Properties

Name | Gets the name.
RawContent | Gets the content of the raw.

Public Instance Methods

Clone | Clones this instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MimeHeader Class | Aspose.Email.Mime Namespace


MimeHeader Constructor

Initializes a new instance of the MimeHeader class.

public MimeHeader(
string name,
string value
);

Parameters

name
The MimeHeader name.
value
The MimeHeader value.

See Also

MimeHeader Class | Aspose.Email.Mime Namespace


MimeHeader Properties

The properties of the MimeHeader class are listed below. For a complete list of MimeHeader class members, see the MimeHeader Members topic.

Public Instance Properties

Name | Gets the name.
RawContent | Gets the content of the raw.

See Also

MimeHeader Class | Aspose.Email.Mime Namespace


Name Property

Aspose.Email

MimeHeader.Name Property

Gets the name.

public string Name {get;}

Property Value

The name.

See Also

MimeHeader Class | Aspose.Email.Mime Namespace


RawContent Property

Aspose.Email

MimeHeader.RawContent Property

Gets the content of the raw.

public string RawContent {get;}

Property Value

The content of the raw.

See Also

MimeHeader Class | Aspose.Email.Mime Namespace


MimeHeader Methods

The methods of the MimeHeader class are listed below. For a complete list of MimeHeader class members, see the MimeHeader Members topic.

Public Instance Methods

Clone | Clones this instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MimeHeader Class | Aspose.Email.Mime Namespace


MimeHeader.Clone Method

Clones this instance.

public MimeHeader Clone();

Return Value

Returns new instance of the cloned MimeHeader class.

See Also

MimeHeader Class | Aspose.Email.Mime Namespace


MimeHeader.ToString Method

Returns a String that represents the current Object.

public override string ToString();

Return Value

A String that represents the current Object.

See Also

MimeHeader Class | Aspose.Email.Mime Namespace


TransferEncoding Enumeration

Specifies the Content-Transfer-Encoding header information.

public enum TransferEncoding

Members

Member Name | Description | Value
Unknown | The transfer encoding is unknown. | -1
SevenBit | The data is in 7-bit US-ASCII characters. | 2
EightBit | The data is in 8-bit characters. | 3
Binary | The binary encoding. | 4
QuotedPrintable | Quoted-printable, is an encoding using printable ASCII characters. | 0
Base64 | Base64 encoding that encodes stream-based data. | 1
UUEncode | UUEncoding that encodes binary data for transmission over the uucp mail system. | 5
BinHex | The binary-to-hexadecimal encoding. | 6

Requirements

Namespace: Aspose.Email.Mime

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Mime Namespace


Aspose.Email.OAuth

Aspose.Email

Aspose.Email.OAuth Namespace

Namespace hierarchy

Classes

Class | Description
GoogleTokenProvider | Class GoogleTokenProvider allows to retrieve access token for Google services.
OAuthToken | Contains OAuth token data such like token value, token type, expiration date.

Interfaces

Interface | Description
ITokenProvider | Defines interface allowing to retrieve access token.

Enumerations

Enumeration | Description
TokenType | Defines OAuth token types


GoogleTokenProvider Class

Class GoogleTokenProvider allows to retrieve access token for Google services.

For a list of all members of this type, see GoogleTokenProvider Members.

System.Object
Aspose.Email.OAuth.GoogleTokenProvider

public class GoogleTokenProvider : ITokenProvider, IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.OAuth

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GoogleTokenProvider Members | Aspose.Email.OAuth Namespace


GoogleTokenProvider Members

GoogleTokenProvider overview

Public Static Methods

GetInstance Gets an instance of the GoogleTokenProvider for defined parameters.

Public Instance Properties

ClientId | The client ID obtained from the Google Cloud Console during application registration.
ClientSecret | The client secret obtained during application registration.
RefreshToken | OAuth 2.0 refresh token

Public Instance Methods

Dispose | Performs releasing resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAccessToken | Overloaded. Gets oAuth access token. If token exists and its expiration date is not expired returns current token, otherwise requests new token from a server.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GoogleTokenProvider Class | Aspose.Email.OAuth Namespace


GoogleTokenProvider Properties

The properties of the GoogleTokenProvider class are listed below. For a complete list of GoogleTokenProvider class members, see the GoogleTokenProvider Members topic.

Public Instance Properties

ClientId | The client ID obtained from the Google Cloud Console during application registration.
ClientSecret | The client secret obtained during application registration.
RefreshToken | OAuth 2.0 refresh token

See Also

GoogleTokenProvider Class | Aspose.Email.OAuth Namespace


ClientId Property

Aspose.Email

GoogleTokenProvider.ClientId Property

The client ID obtained from the Google Cloud Console during application registration.

public string ClientId {get;}

See Also

GoogleTokenProvider Class | Aspose.Email.OAuth Namespace


ClientSecret Property

Aspose.Email

GoogleTokenProvider.ClientSecret Property

The client secret obtained during application registration.

public string ClientSecret {get;}

See Also

GoogleTokenProvider Class | Aspose.Email.OAuth Namespace


RefreshToken Property

Aspose.Email

GoogleTokenProvider.RefreshToken Property

OAuth 2.0 refresh token

public string RefreshToken {get;}

See Also

GoogleTokenProvider Class | Aspose.Email.OAuth Namespace


GoogleTokenProvider Methods

The methods of the GoogleTokenProvider class are listed below. For a complete list of GoogleTokenProvider class members, see the GoogleTokenProvider Members topic.

Public Static Methods

GetInstance Gets an instance of the GoogleTokenProvider for defined parameters.

Public Instance Methods

Dispose | Performs releasing resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetAccessToken | Overloaded. Gets oAuth access token. If token exists and its expiration date is not expired returns current token, otherwise requests new token from a server.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GoogleTokenProvider Class | Aspose.Email.OAuth Namespace


GoogleTokenProvider.Dispose Method

Performs releasing resources.

public virtual void Dispose();

Implements

IDisposable.Dispose

See Also

GoogleTokenProvider Class | Aspose.Email.OAuth Namespace


GetAccessToken Method

Aspose.Email

GoogleTokenProvider.GetAccessToken Method

Gets oAuth access token. If token exists and its expiration date is not expired returns current token, otherwise requests new token from a server.

Overload List

Gets oAuth access token. If token exists and its expiration date is not expired returns current token, otherwise requests new token from a server.

public OAuthToken GetAccessToken();

Gets oAuth access token.

public OAuthToken GetAccessToken(bool);

See Also

GoogleTokenProvider Class | Aspose.Email.OAuth Namespace


GoogleTokenProvider.GetAccessToken Method ()

Gets oAuth access token. If token exists and its expiration date is not expired returns current token, otherwise requests new token from a server.

public OAuthToken GetAccessToken();

Return Value

Returns oAuth access token

Implements

ITokenProvider.GetAccessToken

See Also

GoogleTokenProvider Class | Aspose.Email.OAuth Namespace | GoogleTokenProvider.GetAccessToken Overload List


GoogleTokenProvider.GetAccessToken Method (Boolean)

Gets oAuth access token.

public OAuthToken GetAccessToken(
bool ignoreExistingToken
);

Parameters

ignoreExistingToken
If ignoreExistingToken is true, requests new token from a server. Otherwise behaviour is depended on whether token exists or not. If token exists and its expiration date is not expired returns current token, otherwise requests new token from a server.

Return Value

Returns oAuth access token

Implements

ITokenProvider.GetAccessToken

See Also

GoogleTokenProvider Class | Aspose.Email.OAuth Namespace | GoogleTokenProvider.GetAccessToken Overload List


GoogleTokenProvider.GetInstance Method

Gets an instance of the GoogleTokenProvider for defined parameters.

public static GoogleTokenProvider GetInstance(
string clientId,
string clientSecret,
string refreshToken
);

Parameters

clientId
The client ID obtained from the Google Cloud Console during application registration.
clientSecret
The client secret obtained during application registration.
refreshToken
OAuth 2.0 refresh token

Return Value

Returns an instance of the GoogleTokenProvider for defined parameters.

See Also

GoogleTokenProvider Class | Aspose.Email.OAuth Namespace


ITokenProvider Interface

Defines interface allowing to retrieve access token.

For a list of all members of this type, see ITokenProvider Members.

public interface ITokenProvider : IDisposable

Types that implement ITokenProvider

Type | Description
GoogleTokenProvider | Class GoogleTokenProvider allows to retrieve access token for Google services.

Requirements

Namespace: Aspose.Email.OAuth

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ITokenProvider Members | Aspose.Email.OAuth Namespace


ITokenProvider Members

ITokenProvider overview

Public Instance Methods

GetAccessToken Overloaded. Gets oAuth access token. If token exists and its expiration date is not expired returns current token, otherwise requests new token from a server.

See Also

ITokenProvider Interface | Aspose.Email.OAuth Namespace


ITokenProvider Methods

The methods of the ITokenProvider interface are listed below. For a complete list of ITokenProvider interface members, see the ITokenProvider Members topic.

Public Instance Methods

GetAccessToken Overloaded. Gets oAuth access token. If token exists and its expiration date is not expired returns current token, otherwise requests new token from a server.

See Also

ITokenProvider Interface | Aspose.Email.OAuth Namespace


GetAccessToken Method

Aspose.Email

ITokenProvider.GetAccessToken Method

Gets oAuth access token. If token exists and its expiration date is not expired returns current token, otherwise requests new token from a server.

Overload List

Gets oAuth access token. If token exists and its expiration date is not expired returns current token, otherwise requests new token from a server.

OAuthToken GetAccessToken();

Gets oAuth access token.

OAuthToken GetAccessToken(bool);

See Also

ITokenProvider Interface | Aspose.Email.OAuth Namespace


ITokenProvider.GetAccessToken Method ()

Gets oAuth access token. If token exists and its expiration date is not expired returns current token, otherwise requests new token from a server.

OAuthToken GetAccessToken();

Return Value

Returns oAuth access token

See Also

ITokenProvider Interface | Aspose.Email.OAuth Namespace | ITokenProvider.GetAccessToken Overload List


ITokenProvider.GetAccessToken Method (Boolean)

Gets oAuth access token.

OAuthToken GetAccessToken(
bool ignoreExistingToken
);

Parameters

ignoreExistingToken
If ignoreExistingToken is true, requests new token from a server. Otherwise behaviour is depended on whether token exists or not. If token exists and its expiration date is not expired returns current token, otherwise requests new token from a server.

Return Value

Returns oAuth access token

See Also

ITokenProvider Interface | Aspose.Email.OAuth Namespace | ITokenProvider.GetAccessToken Overload List


OAuthToken Class

Contains OAuth token data such like token value, token type, expiration date.

For a list of all members of this type, see OAuthToken Members.

System.Object
Aspose.Email.OAuth.OAuthToken

public class OAuthToken

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.OAuth

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

OAuthToken Members | Aspose.Email.OAuth Namespace


OAuthToken Members

OAuthToken overview

Public Instance Constructors

OAuthToken Overloaded. Initializes a new instance of the OAuthToken class.

Public Instance Properties

ExpirationDate | Gets expiration date of the token.
Expired | Indicates whether token is expired
Token | Gets token value
TokenType | Gets OAuth token type

Public Instance Methods

Equals | Determines whether the specified object is equal to the current object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a string that represents the current object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OAuthToken Class | Aspose.Email.OAuth Namespace


OAuthToken Constructor

Initializes a new instance of the OAuthToken class

Overload List

Initializes a new instance of the OAuthToken class

public OAuthToken(string);

Initializes a new instance of the OAuthToken class

public OAuthToken(string,TokenType,DateTime);

Initializes a new instance of the OAuthToken class

public OAuthToken(string,DateTime);

See Also

OAuthToken Class | Aspose.Email.OAuth Namespace


OAuthToken Constructor (String)

Initializes a new instance of the OAuthToken class

public OAuthToken(
string token
);

Parameters

token
Refresh token value

See Also

OAuthToken Class | Aspose.Email.OAuth Namespace | OAuthToken Constructor Overload List


OAuthToken Constructor (String, DateTime)

Initializes a new instance of the OAuthToken class

public OAuthToken(
string token,
DateTime expirationDate
);

Parameters

token
Access token value
expirationDate
Expiration date of the token.

See Also

OAuthToken Class | Aspose.Email.OAuth Namespace | OAuthToken Constructor Overload List


OAuthToken Constructor (String, TokenType, DateTime)

Initializes a new instance of the OAuthToken class

public OAuthToken(
string token,
TokenType tokenType,
DateTime expirationDate
);

Parameters

token
Token value
tokenType
OAuth token type
expirationDate
Expiration date of the token.

See Also

OAuthToken Class | Aspose.Email.OAuth Namespace | OAuthToken Constructor Overload List


OAuthToken Properties

The properties of the OAuthToken class are listed below. For a complete list of OAuthToken class members, see the OAuthToken Members topic.

Public Instance Properties

ExpirationDate | Gets expiration date of the token.
Expired | Indicates whether token is expired
Token | Gets token value
TokenType | Gets OAuth token type

See Also

OAuthToken Class | Aspose.Email.OAuth Namespace


ExpirationDate Property

Aspose.Email

OAuthToken.ExpirationDate Property

Gets expiration date of the token.

public DateTime ExpirationDate {get;}

See Also

OAuthToken Class | Aspose.Email.OAuth Namespace


Expired Property

Aspose.Email

OAuthToken.Expired Property

Indicates whether token is expired

public bool Expired {get;}

See Also

OAuthToken Class | Aspose.Email.OAuth Namespace


Token Property

Aspose.Email

OAuthToken.Token Property

Gets token value

public string Token {get;}

See Also

OAuthToken Class | Aspose.Email.OAuth Namespace


TokenType Property

Aspose.Email

OAuthToken.TokenType Property

Gets OAuth token type

public TokenType TokenType {get;}

See Also

OAuthToken Class | Aspose.Email.OAuth Namespace


OAuthToken Methods

The methods of the OAuthToken class are listed below. For a complete list of OAuthToken class members, see the OAuthToken Members topic.

Public Instance Methods

Equals | Determines whether the specified object is equal to the current object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a string that represents the current object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OAuthToken Class | Aspose.Email.OAuth Namespace


OAuthToken.Equals Method

Determines whether the specified object is equal to the current object.

public override bool Equals(
object obj
);

Parameters

obj
The object to compare with the current object.

Return Value

true if the specified object is equal to the current object; otherwise, false.

See Also

OAuthToken Class | Aspose.Email.OAuth Namespace


OAuthToken.ToString Method

Returns a string that represents the current object.

public override string ToString();

Return Value

A string that represents the current object.

See Also

OAuthToken Class | Aspose.Email.OAuth Namespace


TokenType Enumeration

Defines OAuth token types

public enum TokenType

Members

Member Name | Description | Value
AccessToken | Access token grants access to an API. | 0
RefreshToken | Refresh token allows to obtain new access tokens. | 1

Requirements

Namespace: Aspose.Email.OAuth

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.OAuth Namespace


Aspose.Email.Outlook

Aspose.Email

Aspose.Email.Outlook Namespace

Namespace hierarchy

Classes

Class | Description
ActivityMailMessageInterpretor | Represents a MailMessage interpretor for the activity message type of Outlook MapiMessage.
AppointmentMailMessageInterpretor | Represents an appointment mail message.
ContactMailMessageInterpretor | Represents a Contact message type interpretor.
ContactSaveOptions | Represents the base contact save options
FileAccessViolationException | This exception wile be thrown when the file open and locked by another caller.
FollowUpManager | Provides the ability to set and handle follow-up Outlook flags and categories. Supports the features to add and remove a flag in MapiMessage, and mark it as completed as well.
FollowUpOptions | Represents options for using follow-up flags and reminders in a message.
MailMessageInterpretor | The base class for MailMessage interpretor.
MailMessageInterpretorFactory | Represents the object factory for MailMessageInterpretor class.
MapiAttachment | Represents the attachment in the E-mail message.
MapiAttachmentCollection | Represents a collection of MapiAttachment objects.
MapiAttachmentPropertyStream | Represents the property stream of attachment object.
MapiCalendar | Represents the mapi calendar object
MapiCalendarAttendees | Represents the mapi calendar attendees
MapiCalendarDailyRecurrencePattern | Represents the daily recurrence pattern of the mapi calendar
MapiCalendarEventRecurrence | Represents the recurrence properties of calendar object
MapiCalendarMonthlyNthRecurrencePattern | Represents the daily recurrence pattern of the mapi calendar
MapiCalendarMonthlyRecurrencePattern | Represents the monthly recurrence pattern of the mapi calendar
MapiCalendarRecurrencePattern | Represents the mapi recurrence pattern
MapiCalendarTimeZone | Represents the mapi calendar time zone information
MapiCalendarTimeZoneInfo | Represents the mapi calendar time zone rule
MapiCalendarTimeZoneInfoCollection | Represents a collection of MapiCalendarTimeZoneInfo
MapiCalendarTimeZoneRule | Represents time zone rule that indicate when to begin using the Standard/Daylight time.
MapiCalendarWeeklyRecurrencePattern | Represents the weekly recurrence pattern of the mapi calendar
MapiContact | Represents outlook contact information
MapiContactCollection | Represents the collection of MapiContact
MapiContactElectronicAddress | Refers to the group of properties that define the e-mail address or fax address for a contact.
MapiContactElectronicAddressPropertySet | Specify properties for up to three different e-mail addresses (Email1, Email2, and Email3) and three different fax addresses (Primary Fax, Business Fax, and Home Fax)
MapiContactEventPropertySet | Specify events associated with a contact
MapiContactNamePropertySet | The properties are used to specify the name of the person represented by the contact
MapiContactPersonalInfoPropertySet | Specify other additional contact information
MapiContactPhoto | Contains data and type of contact's photo.
MapiContactPhysicalAddress | Refers to the group of properties that define physical address for a contact.
MapiContactPhysicalAddressPropertySet | Specify three physical addresses: Home Address, Work Address, and Other Address. One of the addresses can be marked as the Mailing Address
MapiContactProfessionalPropertySet | Properties are used to store professional details for the person represented by the contact
MapiContactTelephonePropertySet | Specify optional telephone numbers for the contact
MapiDistributionList | Represents the Personal Distribution List object.
MapiDistributionListMember | Represents the members of the personal distribution list.
MapiDistributionListMemberCollection | Represents a collection of MapiDistributionListMember objects.
MapiElectronicAddress | Refers to the group of properties that define the e-mail address or fax address.
MapiJournal | Represents the Outlook Journal object.
MapiMessage | Represents an Outlook Message format document that can be parsed.
MapiMessageParseException | This exception is thrown when errors occur in parsing MapiMessage.
MapiMessagePropertyStream | Represents the property stream.
MapiMessageReader | Represents a reader that can read a Microsoft Outlook Message format document.
MapiNamedProperty | Represents the data type of Named Property.
MapiNamedPropertyMappingStorage | Represents the named property mapping
MapiNote | Represents outlook Note object ("sticky note")
MapiObjectProperty | Reprensents a Custom object included in Outlook Message documents.
MapiProperty | Represents the mapi property.
MapiPropertyCollection | Represents the collection of MapiProperty items.
MapiPropertyContainer | Represents the base class for MapiAttachment, MapiRecipient, MapiMessage.
MapiPropertyStream | Represents the property stream.
MapiPropertyTag | Represents the MAPI property tags definition.
MapiRecipient | Represents the recipient information in the Microsoft Outlook Message.
MapiRecipientCollection | Represents a collection of MapiRecipient objects.
MapiRecipientPropertyStream | Represents the property stream of recipient object.
MapiTask | Represents the Outlook Task object.
MapiTaskUsers | Represents information about task users.
NDRReportMailMessageInterpretor | Represents a Non-Delivery Report MailMesssage interpretor.
NormalMessageMailMessageInterpretor | Represents the default mail message interpretor.
OleDocumentFormat | Represents the format for OLE document.

Interfaces

Interface | Description
IMapiMessageItem | Base interface for all message items in Outlook

Enumerations

Enumeration | Description
BodyContentType | The content type of message body.
ContactSaveFormat | Enumerates contact save formats
MapiCalendarBusyStatus | Enumerates the mapi calendar possible busy status
MapiCalendarClientIntent | Enumerates the actions the user can taken on the Meeting object
MapiCalendarDayOfWeek | Enumerates the days of week of the mapi calendar recurrence pattern
MapiCalendarRecurrenceCalendarType | Enumerated the calendar type of the mapi recurrence
MapiCalendarRecurrenceEndType | Enumerates the ending type for the recurrence.
MapiCalendarRecurrenceFrequency | Enumerates mapi calendar recurrence frequency
MapiCalendarRecurrencePatternType | Enumerates the mapi calendar recurrence pattern types
MapiCalendarTimeZoneFlags | Enumerates the individual bit flags that specify information about TimeZoneRule
MapiContactGender | Gender of the contact
MapiContactPhotoImageFormat | Enumerates MapiContact photo image format.
MapiDistributionListContactAddressType | Represents the address type of a personal distribution list member.
MapiDistributionListEntryIdType | Specifies the type of EntryID.
MapiJournalDocumentStatus | Indicates the status of document.
MapiJournalFlags | Contains metadata about the Journal object. Must be either zero or the following values.
MapiMessageFlags | MapiMessageFlags.
MapiObjectType | Represents the mapi object type.
MapiPropertyType | Represents the data type of MapiProperty data.
MapiRecipientType | Represent the PR_RECIPIENT_TYPE property which contains the recipient type for a message recipient.
MapiTaskAcceptanceState | Indicates the acceptance state of the task.
MapiTaskFlags | Contains indication flags of the Task object.
MapiTaskHistory | Indicates the type of change that was last made to the Task object.
MapiTaskMode | Represents the assignment statuses of the task object.
MapiTaskOwnership | Indicates the role of the current user relative to the Task object.
MapiTaskState | Indicates the assignment state of the Task object.
MapiTaskStatus | Represents the statuses of the user's progress on the task.
NoteColor | Specifies the suggested background color of the Note object
NoteSaveFormat | Enumerates NoteSaveFormat
OutlookMessageFormat | Represents outlook message format.
TaskSaveFormat | Enumerates TaskSaveFormat


ActivityMailMessageInterpretor Class

Represents a MailMessage interpretor for the activity message type of Outlook MapiMessage.

For a list of all members of this type, see ActivityMailMessageInterpretor Members.

System.Object
Aspose.Email.Outlook.MailMessageInterpretor
Aspose.Email.Outlook.ActivityMailMessageInterpretor

public class ActivityMailMessageInterpretor : MailMessageInterpretor

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ActivityMailMessageInterpretor Members | Aspose.Email.Outlook Namespace


ActivityMailMessageInterpretor Members

ActivityMailMessageInterpretor overview

Public Instance Constructors

ActivityMailMessageInterpretor Constructor Initializes a new instance of the ActivityMailMessageInterpretor class.

Public Instance Properties

FormatTemplates Gets the format template collection.

Public Instance Methods

Clone | Creates a copy of the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Interpret (inherited from MailMessageInterpretor) | Imports the MapiMessage information into a MailMessage object.
Save | Saves the specified MapiMessage to a Stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
LoadAttachment (inherited from MailMessageInterpretor) |
LoadEachAttachment (inherited from MailMessageInterpretor) |
LoadMessageBody (inherited from MailMessageInterpretor) |
LoadMessageBodyHtml |
LoadMessageBodyText (inherited from MailMessageInterpretor) |
LoadMessageHeader |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ActivityMailMessageInterpretor Class | Aspose.Email.Outlook Namespace


ActivityMailMessageInterpretor Constructor

Initializes a new instance of the ActivityMailMessageInterpretor class.

public ActivityMailMessageInterpretor();

See Also

ActivityMailMessageInterpretor Class | Aspose.Email.Outlook Namespace


ActivityMailMessageInterpretor Properties

The properties of the ActivityMailMessageInterpretor class are listed below. For a complete list of ActivityMailMessageInterpretor class members, see the ActivityMailMessageInterpretor Members topic.

Public Instance Properties

FormatTemplates Gets the format template collection.

See Also

ActivityMailMessageInterpretor Class | Aspose.Email.Outlook Namespace


FormatTemplates Property

Aspose.Email

ActivityMailMessageInterpretor.FormatTemplates Property

Gets the format template collection.

public StringDictionary FormatTemplates {get;}

See Also

ActivityMailMessageInterpretor Class | Aspose.Email.Outlook Namespace


ActivityMailMessageInterpretor Methods

The methods of the ActivityMailMessageInterpretor class are listed below. For a complete list of ActivityMailMessageInterpretor class members, see the ActivityMailMessageInterpretor Members topic.

Public Instance Methods

Clone | Creates a copy of the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Interpret (inherited from MailMessageInterpretor) | Imports the MapiMessage information into a MailMessage object.
Save | Saves the specified MapiMessage to a Stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
LoadAttachment (inherited from MailMessageInterpretor) |
LoadEachAttachment (inherited from MailMessageInterpretor) |
LoadMessageBody (inherited from MailMessageInterpretor) |
LoadMessageBodyHtml |
LoadMessageBodyText (inherited from MailMessageInterpretor) |
LoadMessageHeader |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ActivityMailMessageInterpretor Class | Aspose.Email.Outlook Namespace


ActivityMailMessageInterpretor.Clone Method

Creates a copy of the current instance.

public override MailMessageInterpretor Clone();

Return Value

A copy of MailMessageInterpretor.

See Also

ActivityMailMessageInterpretor Class | Aspose.Email.Outlook Namespace


ActivityMailMessageInterpretor.LoadMessageBodyHtml Method

protected override void LoadMessageBodyHtml(
MailMessage mailMessage,
MapiMessage mapiMessage
);

See Also

ActivityMailMessageInterpretor Class | Aspose.Email.Outlook Namespace


ActivityMailMessageInterpretor.LoadMessageHeader Method

protected override void LoadMessageHeader(
MailMessage mailmessage,
MapiMessage mapiMessage
);

See Also

ActivityMailMessageInterpretor Class | Aspose.Email.Outlook Namespace


ActivityMailMessageInterpretor.Save Method

Saves the specified MapiMessage to a Stream.

public override void Save(
MapiMessage mapiMessage,
Stream stream,
MessageFormat messageFormat
);

Parameters

mapiMessage
The source MapiMessage instance.
stream
The target stream
messageFormat
The message format.

See Also

ActivityMailMessageInterpretor Class | Aspose.Email.Outlook Namespace


AppointmentMailMessageInterpretor Class

Represents an appointment mail message.

For a list of all members of this type, see AppointmentMailMessageInterpretor Members.

System.Object
Aspose.Email.Outlook.MailMessageInterpretor
Aspose.Email.Outlook.AppointmentMailMessageInterpretor

public class AppointmentMailMessageInterpretor : MailMessageInterpretor

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AppointmentMailMessageInterpretor Members | Aspose.Email.Outlook Namespace


AppointmentMailMessageInterpretor Members

AppointmentMailMessageInterpretor overview

Public Instance Constructors

AppointmentMailMessageInterpretor Constructor Initializes a new instance of the AppointmentMailMessageInterpretor class.

Public Instance Properties

FormatTemplates Gets the format templates.

Public Instance Methods

Clone | Creates a copy of current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Interpret |
Save | Saves the specified MapiMessage to a Stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
LoadAttachment (inherited from MailMessageInterpretor) |
LoadEachAttachment (inherited from MailMessageInterpretor) |
LoadMessageBody (inherited from MailMessageInterpretor) |
LoadMessageBodyHtml |
LoadMessageBodyText (inherited from MailMessageInterpretor) |
LoadMessageHeader |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AppointmentMailMessageInterpretor Class | Aspose.Email.Outlook Namespace


AppointmentMailMessageInterpretor Constructor

Initializes a new instance of the AppointmentMailMessageInterpretor class.

public AppointmentMailMessageInterpretor();

See Also

AppointmentMailMessageInterpretor Class | Aspose.Email.Outlook Namespace


AppointmentMailMessageInterpretor Properties

The properties of the AppointmentMailMessageInterpretor class are listed below. For a complete list of AppointmentMailMessageInterpretor class members, see the AppointmentMailMessageInterpretor Members topic.

Public Instance Properties

FormatTemplates Gets the format templates.

See Also

AppointmentMailMessageInterpretor Class | Aspose.Email.Outlook Namespace


FormatTemplates Property

Aspose.Email

AppointmentMailMessageInterpretor.FormatTemplates Property

Gets the format templates.

public StringDictionary FormatTemplates {get;}

See Also

AppointmentMailMessageInterpretor Class | Aspose.Email.Outlook Namespace


AppointmentMailMessageInterpretor Methods

The methods of the AppointmentMailMessageInterpretor class are listed below. For a complete list of AppointmentMailMessageInterpretor class members, see the AppointmentMailMessageInterpretor Members topic.

Public Instance Methods

Clone | Creates a copy of current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Interpret |
Save | Saves the specified MapiMessage to a Stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
LoadAttachment (inherited from MailMessageInterpretor) |
LoadEachAttachment (inherited from MailMessageInterpretor) |
LoadMessageBody (inherited from MailMessageInterpretor) |
LoadMessageBodyHtml |
LoadMessageBodyText (inherited from MailMessageInterpretor) |
LoadMessageHeader |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AppointmentMailMessageInterpretor Class | Aspose.Email.Outlook Namespace


AppointmentMailMessageInterpretor.Clone Method

Creates a copy of current instance.

public override MailMessageInterpretor Clone();

Return Value

A copy of MailMessageInterpretor.

See Also

AppointmentMailMessageInterpretor Class | Aspose.Email.Outlook Namespace


AppointmentMailMessageInterpretor.Interpret Method

public override MailMessage Interpret(
MapiMessage mapiMessage
);

See Also

AppointmentMailMessageInterpretor Class | Aspose.Email.Outlook Namespace


AppointmentMailMessageInterpretor.LoadMessageBodyHtml Method

protected override void LoadMessageBodyHtml(
MailMessage mailMessage,
MapiMessage mapiMessage
);

See Also

AppointmentMailMessageInterpretor Class | Aspose.Email.Outlook Namespace


AppointmentMailMessageInterpretor.LoadMessageHeader Method

protected override void LoadMessageHeader(
MailMessage mailMessage,
MapiMessage mapiMessage
);

See Also

AppointmentMailMessageInterpretor Class | Aspose.Email.Outlook Namespace


AppointmentMailMessageInterpretor.Save Method

Saves the specified MapiMessage to a Stream.

public override void Save(
MapiMessage mapiMessage,
Stream stream,
MessageFormat messageFormat
);

Parameters

mapiMessage
The source MapiMessage instance.
stream
The target stream
messageFormat
The message format.

See Also

AppointmentMailMessageInterpretor Class | Aspose.Email.Outlook Namespace


BodyContentType Enumeration

The content type of message body.

public enum BodyContentType

Members

Member Name | Description | Value
PlainText | The plain text. | 0
Html | The html type. | 1
Rtf | The rtf type. | 2

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Outlook Namespace


ContactMailMessageInterpretor Class

Represents a Contact message type interpretor.

For a list of all members of this type, see ContactMailMessageInterpretor Members.

System.Object
Aspose.Email.Outlook.MailMessageInterpretor
Aspose.Email.Outlook.ContactMailMessageInterpretor

public class ContactMailMessageInterpretor : MailMessageInterpretor

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ContactMailMessageInterpretor Members | Aspose.Email.Outlook Namespace


ContactMailMessageInterpretor Members

ContactMailMessageInterpretor overview

Public Instance Constructors

ContactMailMessageInterpretor Constructor Initializes a new instance of the ContactMailMessageInterpretor class.

Public Instance Properties

FormatTemplates Gets the format templates.

Public Instance Methods

Clone | Creates a copy of the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Interpret (inherited from MailMessageInterpretor) | Imports the MapiMessage information into a MailMessage object.
Save | Saves the specified MapiMessage to a Stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
LoadAttachment (inherited from MailMessageInterpretor) |
LoadEachAttachment (inherited from MailMessageInterpretor) |
LoadMessageBody (inherited from MailMessageInterpretor) |
LoadMessageBodyHtml |
LoadMessageBodyText (inherited from MailMessageInterpretor) |
LoadMessageHeader (inherited from MailMessageInterpretor) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ContactMailMessageInterpretor Class | Aspose.Email.Outlook Namespace


ContactMailMessageInterpretor Constructor

Initializes a new instance of the ContactMailMessageInterpretor class.

public ContactMailMessageInterpretor();

See Also

ContactMailMessageInterpretor Class | Aspose.Email.Outlook Namespace


ContactMailMessageInterpretor Properties

The properties of the ContactMailMessageInterpretor class are listed below. For a complete list of ContactMailMessageInterpretor class members, see the ContactMailMessageInterpretor Members topic.

Public Instance Properties

FormatTemplates Gets the format templates.

See Also

ContactMailMessageInterpretor Class | Aspose.Email.Outlook Namespace


FormatTemplates Property

Aspose.Email

ContactMailMessageInterpretor.FormatTemplates Property

Gets the format templates.

public StringDictionary FormatTemplates {get;}

See Also

ContactMailMessageInterpretor Class | Aspose.Email.Outlook Namespace


ContactMailMessageInterpretor Methods

The methods of the ContactMailMessageInterpretor class are listed below. For a complete list of ContactMailMessageInterpretor class members, see the ContactMailMessageInterpretor Members topic.

Public Instance Methods

Clone | Creates a copy of the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Interpret (inherited from MailMessageInterpretor) | Imports the MapiMessage information into a MailMessage object.
Save | Saves the specified MapiMessage to a Stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
LoadAttachment (inherited from MailMessageInterpretor) |
LoadEachAttachment (inherited from MailMessageInterpretor) |
LoadMessageBody (inherited from MailMessageInterpretor) |
LoadMessageBodyHtml |
LoadMessageBodyText (inherited from MailMessageInterpretor) |
LoadMessageHeader (inherited from MailMessageInterpretor) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ContactMailMessageInterpretor Class | Aspose.Email.Outlook Namespace


ContactMailMessageInterpretor.Clone Method

Creates a copy of the current instance.

public override MailMessageInterpretor Clone();

Return Value

A ContactMailMessageInterpretor copy.

See Also

ContactMailMessageInterpretor Class | Aspose.Email.Outlook Namespace


ContactMailMessageInterpretor.LoadMessageBodyHtml Method

protected override void LoadMessageBodyHtml(
MailMessage mailMessage,
MapiMessage mapiMessage
);

See Also

ContactMailMessageInterpretor Class | Aspose.Email.Outlook Namespace


ContactMailMessageInterpretor.Save Method

Saves the specified MapiMessage to a Stream.

public override void Save(
MapiMessage mapiMessage,
Stream stream,
MessageFormat messageFormat
);

Parameters

mapiMessage
The source MapiMessage instance.
stream
The target stream
messageFormat
The message format.

See Also

ContactMailMessageInterpretor Class | Aspose.Email.Outlook Namespace


ContactSaveFormat Enumeration

Enumerates contact save formats

public enum ContactSaveFormat

Members

Member Name | Description | Value
VCard | vCard format (default). | 0
WebDav | WebDav format. | 1
Msg | MSG format. | 2

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Outlook Namespace


ContactSaveOptions Class

Represents the base contact save options

For a list of all members of this type, see ContactSaveOptions Members.

System.Object
Aspose.Email.Outlook.ContactSaveOptions
Aspose.Email.Formats.VCard.VCardSaveOptions
Aspose.Email.Protocols.Exchange.ExchangeDav.WebDavContactSaveOptions

public abstract class ContactSaveOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ContactSaveOptions Members | Aspose.Email.Outlook Namespace


ContactSaveOptions Members

ContactSaveOptions overview

Public Instance Properties

SaveFormat Gets a save format

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

ContactSaveOptions Constructor

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ContactSaveOptions Class | Aspose.Email.Outlook Namespace


ContactSaveOptions Constructor

protected ContactSaveOptions(
ContactSaveFormat format
);

See Also

ContactSaveOptions Class | Aspose.Email.Outlook Namespace


ContactSaveOptions Properties

The properties of the ContactSaveOptions class are listed below. For a complete list of ContactSaveOptions class members, see the ContactSaveOptions Members topic.

Public Instance Properties

SaveFormat Gets a save format

See Also

ContactSaveOptions Class | Aspose.Email.Outlook Namespace


SaveFormat Property

Aspose.Email

ContactSaveOptions.SaveFormat Property

Gets a save format

public ContactSaveFormat SaveFormat {get;}

See Also

ContactSaveOptions Class | Aspose.Email.Outlook Namespace


FileAccessViolationException Class

This exception wile be thrown when the file open and locked by another caller.

For a list of all members of this type, see FileAccessViolationException Members.

System.Object
System.Exception
System.SystemException
System.IO.IOException
Aspose.Email.Outlook.FileAccessViolationException

public class FileAccessViolationException : IOException

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FileAccessViolationException Members | Aspose.Email.Outlook Namespace


FileAccessViolationException Members

FileAccessViolationException overview

Public Instance Constructors

FileAccessViolationException Overloaded. Initializes a new instance of the FileAccessViolationException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

FileAccessViolationException Overloaded. Initializes a new instance of the FileAccessViolationException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FileAccessViolationException Class | Aspose.Email.Outlook Namespace


FileAccessViolationException Constructor

Initializes a new instance of the class with default error message.

Overload List

Initializes a new instance of the class with default error message.

public FileAccessViolationException();

Initializes a new instance of the FileAccessViolationException class with serialized data.

protected FileAccessViolationException(SerializationInfo,StreamingContext);

Initializes a new instance of the class with a specified error message.

public FileAccessViolationException(string);

Initializes a new instance of the Exception class with a specified error message and a reference to the inner exception that is the cause of this exception.

public FileAccessViolationException(string,Exception);

See Also

FileAccessViolationException Class | Aspose.Email.Outlook Namespace


FileAccessViolationException Constructor ()

Initializes a new instance of the class with default error message.

public FileAccessViolationException();

See Also

FileAccessViolationException Class | Aspose.Email.Outlook Namespace | FileAccessViolationException Constructor Overload List


FileAccessViolationException Constructor (String)

Initializes a new instance of the class with a specified error message.

public FileAccessViolationException(
string message
);

Parameters

message
Error message.

See Also

FileAccessViolationException Class | Aspose.Email.Outlook Namespace | FileAccessViolationException Constructor Overload List


FileAccessViolationException Constructor (String, Exception)

Initializes a new instance of the Exception class with a specified error message and a reference to the inner exception that is the cause of this exception.

public FileAccessViolationException(
string message,
Exception innerException
);

Parameters

message
The error message that explains the reason for the exception.
innerException
The exception that is the cause of the current exception. If the innerException parameter is not a NULL reference (Nothing in Visual Basic), the current exception is raised in a catch block that handles the inner exception.

See Also

FileAccessViolationException Class | Aspose.Email.Outlook Namespace | FileAccessViolationException Constructor Overload List


FileAccessViolationException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the FileAccessViolationException class with serialized data.

protected FileAccessViolationException(
SerializationInfo info,
StreamingContext context
);

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception Type | Condition
ArgumentNullException | The info parameter is null.
SerializationException | The class name is null or HResult is zero (0).

See Also

FileAccessViolationException Class | Aspose.Email.Outlook Namespace | FileAccessViolationException Constructor Overload List


FollowUpManager Class

Provides the ability to set and handle follow-up Outlook flags and categories. Supports the features to add and remove a flag in MapiMessage, and mark it as completed as well.

For a list of all members of this type, see FollowUpManager Members.

System.Object
Aspose.Email.Outlook.FollowUpManager

public abstract sealed class FollowUpManager

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FollowUpManager Members | Aspose.Email.Outlook Namespace


FollowUpManager Members

FollowUpManager overview

Public Static Methods

AddCategory | Adds the category for a message.
AddVotingButton | Adds the voting button.
ClearCategories | Clears the categories.
ClearFlag | Clears the follow-up flag and reminder.
ClearVotingButtons | Deletes the voting buttons.
GetCategories | Get the available message categories.
GetFlag | Obsolete. Gets the follow-up flag of a message.
GetOptions | Gets the follow-up options of a message.
GetVotingButtons | Get the available message voting buttons.
MarkAsCompleted | Marks the flagged message as completed.
RemoveCategory | Removes the category.
RemoveVotingButton | Removes the voting button.
SetFlag | Overloaded. Sets the follow-up flag for a message.
SetFlagForRecipients | Overloaded. Sets the flag for a draft message to remind recipients to follow-up.
SetOptions | Sets the additional follow-up options for a message.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FollowUpManager Class | Aspose.Email.Outlook Namespace


FollowUpManager Methods

The methods of the FollowUpManager class are listed below. For a complete list of FollowUpManager class members, see the FollowUpManager Members topic.

Public Static Methods

AddCategory | Adds the category for a message.
AddVotingButton | Adds the voting button.
ClearCategories | Clears the categories.
ClearFlag | Clears the follow-up flag and reminder.
ClearVotingButtons | Deletes the voting buttons.
GetCategories | Get the available message categories.
GetFlag | Obsolete. Gets the follow-up flag of a message.
GetOptions | Gets the follow-up options of a message.
GetVotingButtons | Get the available message voting buttons.
MarkAsCompleted | Marks the flagged message as completed.
RemoveCategory | Removes the category.
RemoveVotingButton | Removes the voting button.
SetFlag | Overloaded. Sets the follow-up flag for a message.
SetFlagForRecipients | Overloaded. Sets the flag for a draft message to remind recipients to follow-up.
SetOptions | Sets the additional follow-up options for a message.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FollowUpManager Class | Aspose.Email.Outlook Namespace


FollowUpManager.AddCategory Method

Adds the category for a message.

public static void AddCategory(
MapiMessage message,
string categoryName
);

Parameters

message
The MapiMessage in which a category will be added.
categoryName
Category name.

Exceptions

Exception Type | Condition
ArgumentNullException | If message is null.
ArgumentException | If categoryName is null or empty.

See Also

FollowUpManager Class | Aspose.Email.Outlook Namespace


FollowUpManager.AddVotingButton Method

Adds the voting button.

public static void AddVotingButton(
MapiMessage message,
string displayName
);

Parameters

message
The MapiMessage in which the voting button is added.
displayName
The display name of button.

Exceptions

Exception Type | Condition
ArgumentNullException | If message is null.
ArgumentException | If displayName is null or empty.

See Also

FollowUpManager Class | Aspose.Email.Outlook Namespace


FollowUpManager.ClearCategories Method

Clears the categories.

public static void ClearCategories(
MapiMessage message
);

Parameters

message
The MapiMessage in which the categories will be cleared.

Exceptions

Exception Type | Condition
ArgumentNullException | If message is null.

See Also

FollowUpManager Class | Aspose.Email.Outlook Namespace


FollowUpManager.ClearFlag Method

Clears the follow-up flag and reminder.

public static void ClearFlag(
MapiMessage message
);

Parameters

message
The MapiMessage in which a flag is set.

Exceptions

Exception Type | Condition
ArgumentNullException | If message is null.

See Also

FollowUpManager Class | Aspose.Email.Outlook Namespace


FollowUpManager.ClearVotingButtons Method

Deletes the voting buttons.

public static void ClearVotingButtons(
MapiMessage message
);

Parameters

message
The MapiMessage in which the categories will be cleared.

Exceptions

Exception Type | Condition
ArgumentNullException | If message is null.

See Also

FollowUpManager Class | Aspose.Email.Outlook Namespace


FollowUpManager.GetCategories Method

Get the available message categories.

public static IList GetCategories(
MapiMessage message
);

Parameters

message
The MapiMessage in which the categories are added.

Return Value

The list of added categories.

Exceptions

Exception Type | Condition
ArgumentNullException | If message is null.

See Also

FollowUpManager Class | Aspose.Email.Outlook Namespace


FollowUpManager.GetFlag Method

NOTE: This method is now obsolete.

Please use GetOptions(MapiMessage message) method instead this

Gets the follow-up flag of a message.

public static FollowUpOptions GetFlag(
MapiMessage message
);

Parameters

message
The MapiMessage in which a flag is set.

Return Value

The FollowUpOptions that represents options for using follow-up flags and reminders.

Exceptions

Exception Type | Condition
ArgumentNullException | If message is null.

See Also

FollowUpManager Class | Aspose.Email.Outlook Namespace


FollowUpManager.GetOptions Method

Gets the follow-up options of a message.

public static FollowUpOptions GetOptions(
MapiMessage message
);

Parameters

message
The MapiMessage in which options is set.

Return Value

The FollowUpOptions that represents options for using follow-up flags, reminders, category and voting buttons.

Exceptions

Exception Type | Condition
ArgumentNullException | If message is null.

See Also

FollowUpManager Class | Aspose.Email.Outlook Namespace


FollowUpManager.GetVotingButtons Method

Get the available message voting buttons.

public static IList GetVotingButtons(
MapiMessage message
);

Parameters

message
The MapiMessage in which the buttons are added.

Return Value

The list of added voting buttons.

Exceptions

Exception Type | Condition
ArgumentNullException | If message is null.

See Also

FollowUpManager Class | Aspose.Email.Outlook Namespace


FollowUpManager.MarkAsCompleted Method

Marks the flagged message as completed.

public static void MarkAsCompleted(
MapiMessage message
);

Parameters

message
The MapiMessage in which a flag is set.

Exceptions

Exception Type | Condition
ArgumentNullException | If message is null.

See Also

FollowUpManager Class | Aspose.Email.Outlook Namespace


FollowUpManager.RemoveCategory Method

Removes the category.

public static void RemoveCategory(
MapiMessage message,
string categoryName
);

Parameters

message
The message.
categoryName
Name of the category.

Exceptions

Exception Type | Condition
ArgumentNullException | If message is null.
ArgumentException | If categoryName is null or empty.

See Also

FollowUpManager Class | Aspose.Email.Outlook Namespace


FollowUpManager.RemoveVotingButton Method

Removes the voting button.

public static void RemoveVotingButton(
MapiMessage message,
string displayName
);

Parameters

message
The MapiMessage in which the voting button is removed.
displayName
The display name of button.

Exceptions

Exception Type | Condition
ArgumentNullException | If message is null.
ArgumentException | If displayName is null or empty.

See Also

FollowUpManager Class | Aspose.Email.Outlook Namespace


SetFlag Method

Aspose.Email

FollowUpManager.SetFlag Method

NOTE: This method is now obsolete.

Please use SetOptions(MapiMessage message, FollowUpOptions options) method instead this)

Sets the follow-up flag for a message.

Overload List

Obsolete. Sets the follow-up flag for a message.

public static void SetFlag(MapiMessage,FollowUpOptions);

Sets the follow-up flag for a message.

public static void SetFlag(MapiMessage,string);

Sets the follow-up flag for a message.

public static void SetFlag(MapiMessage,string,DateTime,DateTime);

See Also

FollowUpManager Class | Aspose.Email.Outlook Namespace


FollowUpManager.SetFlag Method (MapiMessage, FollowUpOptions)

NOTE: This method is now obsolete.

Please use SetOptions(MapiMessage message, FollowUpOptions options) method instead this)

Sets the follow-up flag for a message.

public static void SetFlag(
MapiMessage message,
FollowUpOptions options
);

Parameters

message
The MapiMessage in which a flag will be set.
options
The FollowUpOptions that represents options for using follow-up flags and reminders.

Exceptions

Exception Type | Condition
ArgumentNullException | If message is null.
ArgumentNullException | If options is null.

See Also

FollowUpManager Class | Aspose.Email.Outlook Namespace | FollowUpManager.SetFlag Overload List


FollowUpManager.SetFlag Method (MapiMessage, String)

Sets the follow-up flag for a message.

public static void SetFlag(
MapiMessage message,
string flagRequest
);

Parameters

message
The MapiMessage in which a flag will be set.
flagRequest
A string indicating the requested action for an e-mail message.

Exceptions

Exception Type | Condition
ArgumentException | If flagRequest is null or empty.
ArgumentNullException | If message is null.

See Also

FollowUpManager Class | Aspose.Email.Outlook Namespace | FollowUpManager.SetFlag Overload List


FollowUpManager.SetFlag Method (MapiMessage, String, DateTime, DateTime)

Sets the follow-up flag for a message.

public static void SetFlag(
MapiMessage message,
string flagRequest,
DateTime startDate,
DateTime dueDate
);

Parameters

message
The MapiMessage in which a flag will be set.
flagRequest
A string indicating the requested action for an e-mail message.
startDate
The start date.
dueDate
The due date.

Exceptions

Exception Type | Condition
ArgumentException | If flagRequest is null or empty.
ArgumentNullException | If message is null.

See Also

FollowUpManager Class | Aspose.Email.Outlook Namespace | FollowUpManager.SetFlag Overload List


SetFlagForRecipients Method

Aspose.Email

FollowUpManager.SetFlagForRecipients Method

Sets the flag for a draft message to remind recipients to follow-up.

Overload List

Sets the flag for a draft message to remind recipients to follow-up.

public static void SetFlagForRecipients(MapiMessage,string);

Sets the flag for a draft message to remind recipients to follow-up.

public static void SetFlagForRecipients(MapiMessage,string,DateTime);

See Also

FollowUpManager Class | Aspose.Email.Outlook Namespace


FollowUpManager.SetFlagForRecipients Method (MapiMessage, String)

Sets the flag for a draft message to remind recipients to follow-up.

public static void SetFlagForRecipients(
MapiMessage message,
string flagRequest
);

Parameters

message
The MapiMessage in which a flag will be set.
flagRequest
A string indicating the requested action action for recipients of an e-mail message.

Exceptions

Exception Type | Condition
ArgumentNullException | If message is null.
ArgumentException | If flagRequest is null or empty.
InvalidOperationException | If message is not set on a draft mode.

See Also

FollowUpManager Class | Aspose.Email.Outlook Namespace | FollowUpManager.SetFlagForRecipients Overload List


FollowUpManager.SetFlagForRecipients Method (MapiMessage, String, DateTime)

Sets the flag for a draft message to remind recipients to follow-up.

public static void SetFlagForRecipients(
MapiMessage message,
string flagRequest,
DateTime reminderTime
);

Parameters

message
The MapiMessage in which a flag will be set.
flagRequest
A string indicating the requested action action for recipients of an e-mail message.
reminderTime
A date indicating the date and time at which the reminder should occur.

Exceptions

Exception Type | Condition
ArgumentNullException | If message is null.
ArgumentException | If flagRequest is null or empty.
InvalidOperationException | If message is not set on a draft mode.

See Also

FollowUpManager Class | Aspose.Email.Outlook Namespace | FollowUpManager.SetFlagForRecipients Overload List


FollowUpManager.SetOptions Method

Sets the additional follow-up options for a message.

public static void SetOptions(
MapiMessage message,
FollowUpOptions options
);

Parameters

message
The MapiMessage in which a flag will be set.
options
The FollowUpOptions that represents options for using follow-up flags and reminders.

Exceptions

Exception Type | Condition
ArgumentNullException | If message is null.
ArgumentNullException | If options is null.

See Also

FollowUpManager Class | Aspose.Email.Outlook Namespace


FollowUpOptions Class

Represents options for using follow-up flags and reminders in a message.

For a list of all members of this type, see FollowUpOptions Members.

System.Object
Aspose.Email.Outlook.FollowUpOptions

public sealed class FollowUpOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FollowUpOptions Members | Aspose.Email.Outlook Namespace


FollowUpOptions Members

FollowUpOptions overview

Public Instance Constructors

FollowUpOptions Overloaded. Initializes a new instance of the FollowUpOptions class.

Public Instance Properties

Categories | Gets or sets string that represents list of the categories, separated by semicolons (;).
CodePage | Gets or sets the code page.
DueDate | Gets or sets a date indicating the due date for the flagged message.
FlagRequest | Gets or sets a string indicating the requested action for an e-mail message.
IsCompleted | Gets a value indicating whether the Message object was flagged as completed.
RecipientsFlagRequest | Gets or sets a string indicating the requested action for recipients of an e-mail message.
RecipientsReminderTime | Gets or sets a date for recipients indicating the date and time at which the reminder should occur.
ReminderTime | Gets or sets a date indicating the date and time at which the reminder should occur.
StartDate | Gets or sets a date specifying the starting date and time for the flagged message.
VotingButtons | Gets or sets string that represents list of the voting buttons names, separated by semicolons (;).

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FollowUpOptions Class | Aspose.Email.Outlook Namespace


FollowUpOptions Constructor

Initializes a new instance of the FollowUpOptions class.

Overload List

Initializes a new instance of the FollowUpOptions class.

public FollowUpOptions();

Initializes a new instance of the FollowUpOptions class.

public FollowUpOptions(string);

Initializes a new instance of the FollowUpOptions class.

public FollowUpOptions(string,DateTime,DateTime);

Initializes a new instance of the FollowUpOptions class.

public FollowUpOptions(string,DateTime,DateTime,DateTime);

See Also

FollowUpOptions Class | Aspose.Email.Outlook Namespace


FollowUpOptions Constructor ()

Initializes a new instance of the FollowUpOptions class.

public FollowUpOptions();

See Also

FollowUpOptions Class | Aspose.Email.Outlook Namespace | FollowUpOptions Constructor Overload List


FollowUpOptions Constructor (String)

Initializes a new instance of the FollowUpOptions class.

public FollowUpOptions(
string flagRequest
);

Parameters

flagRequest
The flag request.

Exceptions

Exception Type | Condition
ArgumentException | If flagRequest is null or empty.

See Also

FollowUpOptions Class | Aspose.Email.Outlook Namespace | FollowUpOptions Constructor Overload List


FollowUpOptions Constructor (String, DateTime, DateTime)

Initializes a new instance of the FollowUpOptions class.

public FollowUpOptions(
string flagRequest,
DateTime startDate,
DateTime dueDate
);

Parameters

flagRequest
The flag request.
startDate
The start Date.
dueDate
The due Date.

Exceptions

Exception Type | Condition
ArgumentException | If flagRequest is null or empty.

See Also

FollowUpOptions Class | Aspose.Email.Outlook Namespace | FollowUpOptions Constructor Overload List


FollowUpOptions Constructor (String, DateTime, DateTime, DateTime)

Initializes a new instance of the FollowUpOptions class.

public FollowUpOptions(
string flagRequest,
DateTime startDate,
DateTime dueDate,
DateTime reminderTime
);

Parameters

flagRequest
The flag request.
startDate
The start date.
dueDate
The due date.
reminderTime
The reminder time.

Exceptions

Exception Type | Condition
ArgumentException | If flagRequest is null or empty.

See Also

FollowUpOptions Class | Aspose.Email.Outlook Namespace | FollowUpOptions Constructor Overload List


FollowUpOptions Properties

The properties of the FollowUpOptions class are listed below. For a complete list of FollowUpOptions class members, see the FollowUpOptions Members topic.

Public Instance Properties

Categories | Gets or sets string that represents list of the categories, separated by semicolons (;).
CodePage | Gets or sets the code page.
DueDate | Gets or sets a date indicating the due date for the flagged message.
FlagRequest | Gets or sets a string indicating the requested action for an e-mail message.
IsCompleted | Gets a value indicating whether the Message object was flagged as completed.
RecipientsFlagRequest | Gets or sets a string indicating the requested action for recipients of an e-mail message.
RecipientsReminderTime | Gets or sets a date for recipients indicating the date and time at which the reminder should occur.
ReminderTime | Gets or sets a date indicating the date and time at which the reminder should occur.
StartDate | Gets or sets a date specifying the starting date and time for the flagged message.
VotingButtons | Gets or sets string that represents list of the voting buttons names, separated by semicolons (;).

See Also

FollowUpOptions Class | Aspose.Email.Outlook Namespace


Categories Property

Aspose.Email

FollowUpOptions.Categories Property

Gets or sets string that represents list of the categories, separated by semicolons (;).

public string Categories {get; set;}

See Also

FollowUpOptions Class | Aspose.Email.Outlook Namespace


CodePage Property

Aspose.Email

FollowUpOptions.CodePage Property

Gets or sets the code page.

public int CodePage {get; set;}

See Also

FollowUpOptions Class | Aspose.Email.Outlook Namespace


DueDate Property

Aspose.Email

FollowUpOptions.DueDate Property

Gets or sets a date indicating the due date for the flagged message.

public DateTime DueDate {get; set;}

See Also

FollowUpOptions Class | Aspose.Email.Outlook Namespace


FlagRequest Property

Aspose.Email

FollowUpOptions.FlagRequest Property

Gets or sets a string indicating the requested action for an e-mail message.

public string FlagRequest {get; set;}

See Also

FollowUpOptions Class | Aspose.Email.Outlook Namespace


IsCompleted Property

Aspose.Email

FollowUpOptions.IsCompleted Property

Gets a value indicating whether the Message object was flagged as completed.

public bool IsCompleted {get;}

See Also

FollowUpOptions Class | Aspose.Email.Outlook Namespace


RecipientsFlagRequest Property

Aspose.Email

FollowUpOptions.RecipientsFlagRequest Property

Gets or sets a string indicating the requested action for recipients of an e-mail message.

public string RecipientsFlagRequest {get; set;}

See Also

FollowUpOptions Class | Aspose.Email.Outlook Namespace


RecipientsReminderTime Property

Aspose.Email

FollowUpOptions.RecipientsReminderTime Property

Gets or sets a date for recipients indicating the date and time at which the reminder should occur.

public DateTime RecipientsReminderTime {get; set;}

See Also

FollowUpOptions Class | Aspose.Email.Outlook Namespace


ReminderTime Property

Aspose.Email

FollowUpOptions.ReminderTime Property

Gets or sets a date indicating the date and time at which the reminder should occur.

public DateTime ReminderTime {get; set;}

See Also

FollowUpOptions Class | Aspose.Email.Outlook Namespace


StartDate Property

Aspose.Email

FollowUpOptions.StartDate Property

Gets or sets a date specifying the starting date and time for the flagged message.

public DateTime StartDate {get; set;}

See Also

FollowUpOptions Class | Aspose.Email.Outlook Namespace


VotingButtons Property

Aspose.Email

FollowUpOptions.VotingButtons Property

Gets or sets string that represents list of the voting buttons names, separated by semicolons (;).

public string VotingButtons {get; set;}

See Also

FollowUpOptions Class | Aspose.Email.Outlook Namespace


IMapiMessageItem Interface

Base interface for all message items in Outlook

For a list of all members of this type, see IMapiMessageItem Members.

public interface IMapiMessageItem

Types that implement IMapiMessageItem

Type | Description
MapiCalendar | Represents the mapi calendar object
MapiContact | Represents outlook contact information
MapiDistributionList | Represents the Personal Distribution List object.
MapiJournal | Represents the Outlook Journal object.
MapiMessage | Represents an Outlook Message format document that can be parsed.
MapiNote | Represents outlook Note object ("sticky note")
MapiTask | Represents the Outlook Task object.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

IMapiMessageItem Members | Aspose.Email.Outlook Namespace


IMapiMessageItem Members

IMapiMessageItem overview

Public Instance Properties

Body | Gets message body
MessageClass | Gets message class
Subject | Gets message subject

See Also

IMapiMessageItem Interface | Aspose.Email.Outlook Namespace


IMapiMessageItem Properties

The properties of the IMapiMessageItem interface are listed below. For a complete list of IMapiMessageItem interface members, see the IMapiMessageItem Members topic.

Public Instance Properties

Body | Gets message body
MessageClass | Gets message class
Subject | Gets message subject

See Also

IMapiMessageItem Interface | Aspose.Email.Outlook Namespace


Body Property

Aspose.Email

IMapiMessageItem.Body Property

Gets message body

string Body {get;}

See Also

IMapiMessageItem Interface | Aspose.Email.Outlook Namespace


MessageClass Property

Aspose.Email

IMapiMessageItem.MessageClass Property

Gets message class

string MessageClass {get;}

See Also

IMapiMessageItem Interface | Aspose.Email.Outlook Namespace


Subject Property

Aspose.Email

IMapiMessageItem.Subject Property

Gets message subject

string Subject {get;}

See Also

IMapiMessageItem Interface | Aspose.Email.Outlook Namespace


MailMessageInterpretor Class

The base class for MailMessage interpretor.

For a list of all members of this type, see MailMessageInterpretor Members.

System.Object
Aspose.Email.Outlook.MailMessageInterpretor
Aspose.Email.Outlook.ActivityMailMessageInterpretor
Aspose.Email.Outlook.AppointmentMailMessageInterpretor
Aspose.Email.Outlook.ContactMailMessageInterpretor
Aspose.Email.Outlook.NDRReportMailMessageInterpretor
Aspose.Email.Outlook.NormalMessageMailMessageInterpretor

public abstract class MailMessageInterpretor

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MailMessageInterpretor Members | Aspose.Email.Outlook Namespace


MailMessageInterpretor Members

MailMessageInterpretor overview

Public Instance Methods

Clone | Creates a copy of the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Interpret | Imports the MapiMessage information into a MailMessage object.
Save | Saves the specified MapiMessage to a Stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

MailMessageInterpretor Constructor Initializes a new instance of the MailMessageInterpretor class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
LoadAttachment |
LoadEachAttachment |
LoadMessageBody |
LoadMessageBodyHtml |
LoadMessageBodyText |
LoadMessageHeader |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MailMessageInterpretor Class | Aspose.Email.Outlook Namespace


MailMessageInterpretor Constructor

Initializes a new instance of the MailMessageInterpretor class.

protected MailMessageInterpretor();

See Also

MailMessageInterpretor Class | Aspose.Email.Outlook Namespace


MailMessageInterpretor Methods

The methods of the MailMessageInterpretor class are listed below. For a complete list of MailMessageInterpretor class members, see the MailMessageInterpretor Members topic.

Public Instance Methods

Clone | Creates a copy of the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Interpret | Imports the MapiMessage information into a MailMessage object.
Save | Saves the specified MapiMessage to a Stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
LoadAttachment |
LoadEachAttachment |
LoadMessageBody |
LoadMessageBodyHtml |
LoadMessageBodyText |
LoadMessageHeader |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MailMessageInterpretor Class | Aspose.Email.Outlook Namespace


MailMessageInterpretor.Clone Method

Creates a copy of the current instance.

public abstract MailMessageInterpretor Clone();

Return Value

A copy of MailMessageInterpretor.

See Also

MailMessageInterpretor Class | Aspose.Email.Outlook Namespace


MailMessageInterpretor.Interpret Method

Imports the MapiMessage information into a MailMessage object.

public virtual MailMessage Interpret(
MapiMessage mapiMessage
);

Parameters

mapiMessage
The source MapiMessage.

Return Value

The MailMessage.

See Also

MailMessageInterpretor Class | Aspose.Email.Outlook Namespace


MailMessageInterpretor.LoadAttachment Method

protected virtual void LoadAttachment(
MailMessage mailmessage,
MapiMessage mapiMessage
);

See Also

MailMessageInterpretor Class | Aspose.Email.Outlook Namespace


MailMessageInterpretor.LoadEachAttachment Method

protected virtual void LoadEachAttachment(
MailMessage mailmessage,
MapiMessage mapiMessage,
int index
);

See Also

MailMessageInterpretor Class | Aspose.Email.Outlook Namespace


MailMessageInterpretor.LoadMessageBody Method

protected virtual void LoadMessageBody(
MailMessage mailmessage,
MapiMessage mapiMessage
);

See Also

MailMessageInterpretor Class | Aspose.Email.Outlook Namespace


MailMessageInterpretor.LoadMessageBodyHtml Method

protected virtual void LoadMessageBodyHtml(
MailMessage mailmessage,
MapiMessage mapiMessage
);

See Also

MailMessageInterpretor Class | Aspose.Email.Outlook Namespace


MailMessageInterpretor.LoadMessageBodyText Method

protected virtual void LoadMessageBodyText(
MailMessage mailmessage,
MapiMessage mapiMessage
);

See Also

MailMessageInterpretor Class | Aspose.Email.Outlook Namespace


MailMessageInterpretor.LoadMessageHeader Method

protected virtual void LoadMessageHeader(
MailMessage mailmessage,
MapiMessage mapiMessage
);

See Also

MailMessageInterpretor Class | Aspose.Email.Outlook Namespace


MailMessageInterpretor.Save Method

Saves the specified MapiMessage to a Stream.

public virtual void Save(
MapiMessage mapiMessage,
Stream stream,
MessageFormat messageFormat
);

Parameters

mapiMessage
The source MapiMessage instance.
stream
The target stream.
messageFormat
The message format.

See Also

MailMessageInterpretor Class | Aspose.Email.Outlook Namespace


MailMessageInterpretorFactory Class

Represents the object factory for MailMessageInterpretor class.

For a list of all members of this type, see MailMessageInterpretorFactory Members.

System.Object
Aspose.Email.Outlook.MailMessageInterpretorFactory

public sealed class MailMessageInterpretorFactory

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MailMessageInterpretorFactory Members | Aspose.Email.Outlook Namespace


MailMessageInterpretorFactory Members

MailMessageInterpretorFactory overview

Public Static Properties

Instance Gets an instance of the MailMessageInterpretorFactory class.

Public Instance Properties

DefaultInterpretor Gets or sets the defalut interpretor.

Public Instance Methods

AddInterpretor | Adds an interpretor instance with specified message class.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetIntepretor | Gets an interpretor intance from the factory with specified message class.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MailMessageInterpretorFactory Class | Aspose.Email.Outlook Namespace


MailMessageInterpretorFactory Properties

The properties of the MailMessageInterpretorFactory class are listed below. For a complete list of MailMessageInterpretorFactory class members, see the MailMessageInterpretorFactory Members topic.

Public Static Properties

Instance Gets an instance of the MailMessageInterpretorFactory class.

Public Instance Properties

DefaultInterpretor Gets or sets the defalut interpretor.

See Also

MailMessageInterpretorFactory Class | Aspose.Email.Outlook Namespace


DefaultInterpretor Property

Aspose.Email

MailMessageInterpretorFactory.DefaultInterpretor Property

Gets or sets the defalut interpretor.

public MailMessageInterpretor DefaultInterpretor {get; set;}

See Also

MailMessageInterpretorFactory Class | Aspose.Email.Outlook Namespace


Instance Property

Aspose.Email

MailMessageInterpretorFactory.Instance Property

Gets an instance of the MailMessageInterpretorFactory class.

public static MailMessageInterpretorFactory Instance {get;}

See Also

MailMessageInterpretorFactory Class | Aspose.Email.Outlook Namespace


MailMessageInterpretorFactory Methods

The methods of the MailMessageInterpretorFactory class are listed below. For a complete list of MailMessageInterpretorFactory class members, see the MailMessageInterpretorFactory Members topic.

Public Instance Methods

AddInterpretor | Adds an interpretor instance with specified message class.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetIntepretor | Gets an interpretor intance from the factory with specified message class.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MailMessageInterpretorFactory Class | Aspose.Email.Outlook Namespace


MailMessageInterpretorFactory.AddInterpretor Method

Adds an interpretor instance with specified message class.

public void AddInterpretor(
MailMessageInterpretor interpretor,
string messageClass
);

Parameters

interpretor
The interpretor to add.
messageClass
The mapping message class.

See Also

MailMessageInterpretorFactory Class | Aspose.Email.Outlook Namespace


MailMessageInterpretorFactory.GetIntepretor Method

Gets an interpretor intance from the factory with specified message class.

public MailMessageInterpretor GetIntepretor(
string messageClass
);

Parameters

messageClass
The mapping message class.

Return Value

An interpretor.

See Also

MailMessageInterpretorFactory Class | Aspose.Email.Outlook Namespace


MapiAttachment Class

Represents the attachment in the E-mail message.

For a list of all members of this type, see MapiAttachment Members.

System.Object
Aspose.Email.Outlook.MapiPropertyContainer
Aspose.Email.Outlook.MapiAttachment

public class MapiAttachment : MapiPropertyContainer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiAttachment Members | Aspose.Email.Outlook Namespace


MapiAttachment Members

MapiAttachment overview

Public Instance Properties

BinaryData | Gets or sets binary attachment data.
CodePage (inherited from MapiPropertyContainer) | Gets the code page.
Content | Gets the content.
DisplayName | Gets the display name of the ole object in an attachment.
Extension | Gets a filename extension that indicates the document type of an attachment.
FileName | Gets an attachment's base filename and extension, excluding path.
ItemId | The attachment id, uses with exchange server
LongFileName | Gets an attachment's long filename and extension, excluding path.
MimeTag | Gets formatting information about a Multipurpose Internet Mail Extensions (MIME) attachment.
ObjectData | Gets an attachment object typically accessed through the OLE IStorage interface.
Properties (inherited from MapiPropertyContainer) | Gets the collection of properties.
PropertyStream | Gets the property stream.
SubStorages | Gets the sub storages.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPropertyBoolean (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Boolean type.
GetPropertyBytes (inherited from MapiPropertyContainer) | Gets the string value of the property specified by tag.
GetPropertyDateTime (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as DateTime type.
GetPropertyInt32 (inherited from MapiPropertyContainer) | Gets the int32 value of the property specified by tag.
GetPropertyLong (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Long (int64) type.
GetPropertyShort (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Short type.
GetPropertyString (inherited from MapiPropertyContainer) | Overloaded. Gets the string value of the property specified by tag.
GetType (inherited from Object) | Gets the Type of the current instance.
IsStoreUnicodeOk (inherited from MapiPropertyContainer) | Determines if string properties are Unicode encoded or not.
Save | Overloaded. Save attachment content.
SetProperty | Sets the property.
ToString (inherited from Object) | Returns a String that represents the current Object.
TryGetPropertyData (inherited from MapiPropertyContainer) | Try to get the property data with specified tag key.
TryGetPropertyDateTime (inherited from MapiPropertyContainer) |
TryGetPropertyInt32 (inherited from MapiPropertyContainer) |
TryGetPropertyLong (inherited from MapiPropertyContainer) |
TryGetPropertyString (inherited from MapiPropertyContainer) | Overloaded. Try to get a property data as string with specified tag and code page.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MapiAttachment Class | Aspose.Email.Outlook Namespace


MapiAttachment Properties

The properties of the MapiAttachment class are listed below. For a complete list of MapiAttachment class members, see the MapiAttachment Members topic.

Public Instance Properties

BinaryData | Gets or sets binary attachment data.
CodePage (inherited from MapiPropertyContainer) | Gets the code page.
Content | Gets the content.
DisplayName | Gets the display name of the ole object in an attachment.
Extension | Gets a filename extension that indicates the document type of an attachment.
FileName | Gets an attachment's base filename and extension, excluding path.
ItemId | The attachment id, uses with exchange server
LongFileName | Gets an attachment's long filename and extension, excluding path.
MimeTag | Gets formatting information about a Multipurpose Internet Mail Extensions (MIME) attachment.
ObjectData | Gets an attachment object typically accessed through the OLE IStorage interface.
Properties (inherited from MapiPropertyContainer) | Gets the collection of properties.
PropertyStream | Gets the property stream.
SubStorages | Gets the sub storages.

See Also

MapiAttachment Class | Aspose.Email.Outlook Namespace


BinaryData Property

Aspose.Email

MapiAttachment.BinaryData Property

Gets or sets binary attachment data.

public byte[] BinaryData {get; set;}

Property Value

The binary data.

See Also

MapiAttachment Class | Aspose.Email.Outlook Namespace


Content Property

Aspose.Email

MapiAttachment.Content Property

Gets the content.

public object Content {get;}

Property Value

The content.

See Also

MapiAttachment Class | Aspose.Email.Outlook Namespace


DisplayName Property

Aspose.Email

MapiAttachment.DisplayName Property

Gets the display name of the ole object in an attachment.

public string DisplayName {get;}

Property Value

The display name.

See Also

MapiAttachment Class | Aspose.Email.Outlook Namespace


Extension Property

Aspose.Email

MapiAttachment.Extension Property

Gets a filename extension that indicates the document type of an attachment.

public string Extension {get;}

Property Value

The extension.

See Also

MapiAttachment Class | Aspose.Email.Outlook Namespace


FileName Property

Aspose.Email

MapiAttachment.FileName Property

Gets an attachment's base filename and extension, excluding path.

public string FileName {get;}

Property Value

The file name.

See Also

MapiAttachment Class | Aspose.Email.Outlook Namespace


ItemId Property

Aspose.Email

MapiAttachment.ItemId Property

The attachment id, uses with exchange server

public string ItemId {get; set;}

See Also

MapiAttachment Class | Aspose.Email.Outlook Namespace


LongFileName Property

Aspose.Email

MapiAttachment.LongFileName Property

Gets an attachment's long filename and extension, excluding path.

public string LongFileName {get;}

Property Value

The long file name.

See Also

MapiAttachment Class | Aspose.Email.Outlook Namespace


MimeTag Property

Aspose.Email

MapiAttachment.MimeTag Property

Gets formatting information about a Multipurpose Internet Mail Extensions (MIME) attachment.

public string MimeTag {get;}

Property Value

The mime tag.

See Also

MapiAttachment Class | Aspose.Email.Outlook Namespace


ObjectData Property

Aspose.Email

MapiAttachment.ObjectData Property

Gets an attachment object typically accessed through the OLE IStorage interface.

public MapiObjectProperty ObjectData {get;}

Property Value

The object data.

See Also

MapiAttachment Class | Aspose.Email.Outlook Namespace


PropertyStream Property

Aspose.Email

MapiAttachment.PropertyStream Property

Gets the property stream.

public MapiPropertyStream PropertyStream {get;}

Property Value

The property stream.

See Also

MapiAttachment Class | Aspose.Email.Outlook Namespace


SubStorages Property

Aspose.Email

MapiAttachment.SubStorages Property

Gets the sub storages.

public MapiPropertyCollection SubStorages {get;}

Property Value

The sub storages.

See Also

MapiAttachment Class | Aspose.Email.Outlook Namespace


MapiAttachment Methods

The methods of the MapiAttachment class are listed below. For a complete list of MapiAttachment class members, see the MapiAttachment Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPropertyBoolean (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Boolean type.
GetPropertyBytes (inherited from MapiPropertyContainer) | Gets the string value of the property specified by tag.
GetPropertyDateTime (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as DateTime type.
GetPropertyInt32 (inherited from MapiPropertyContainer) | Gets the int32 value of the property specified by tag.
GetPropertyLong (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Long (int64) type.
GetPropertyShort (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Short type.
GetPropertyString (inherited from MapiPropertyContainer) | Overloaded. Gets the string value of the property specified by tag.
GetType (inherited from Object) | Gets the Type of the current instance.
IsStoreUnicodeOk (inherited from MapiPropertyContainer) | Determines if string properties are Unicode encoded or not.
Save | Overloaded. Save attachment content.
SetProperty | Sets the property.
ToString (inherited from Object) | Returns a String that represents the current Object.
TryGetPropertyData (inherited from MapiPropertyContainer) | Try to get the property data with specified tag key.
TryGetPropertyDateTime (inherited from MapiPropertyContainer) |
TryGetPropertyInt32 (inherited from MapiPropertyContainer) |
TryGetPropertyLong (inherited from MapiPropertyContainer) |
TryGetPropertyString (inherited from MapiPropertyContainer) | Overloaded. Try to get a property data as string with specified tag and code page.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MapiAttachment Class | Aspose.Email.Outlook Namespace


Save Method

Aspose.Email

MapiAttachment.Save Method

Save attachment content.

Overload List

Save attachment content.

public void Save(Stream);

Save attachment content.

public void Save(string);

See Also

MapiAttachment Class | Aspose.Email.Outlook Namespace


MapiAttachment.Save Method (Stream)

Save attachment content.

public void Save(
Stream stream
);

Parameters

stream
The stream to save.

See Also

MapiAttachment Class | Aspose.Email.Outlook Namespace | MapiAttachment.Save Overload List


MapiAttachment.Save Method (String)

Save attachment content.

public void Save(
string filename
);

Parameters

filename
The file name to save.

See Also

MapiAttachment Class | Aspose.Email.Outlook Namespace | MapiAttachment.Save Overload List


MapiAttachment.SetProperty Method

Sets the property.

public override void SetProperty(
MapiProperty property
);

Parameters

property
The property.

Exceptions

Exception Type | Condition
ArgumentNullException | If property is null.
ArgumentException | If property data is null.
InvalidOperationException | If data type is not supported.

See Also

MapiAttachment Class | Aspose.Email.Outlook Namespace


MapiAttachmentCollection Class

Represents a collection of MapiAttachment objects.

For a list of all members of this type, see MapiAttachmentCollection Members.

System.Object
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Outlook.MapiAttachment, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]]
Aspose.Email.Outlook.MapiAttachmentCollection

public class MapiAttachmentCollection : Collection`1

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiAttachmentCollection Members | Aspose.Email.Outlook Namespace


MapiAttachmentCollection Members

MapiAttachmentCollection overview

Public Instance Constructors

MapiAttachmentCollection Overloaded. Initializes a new instance of the MapiAttachmentCollection class.

Public Instance Properties

Count (inherited from 0, Culture=neutral, PublicKeyToken=null]])
Item (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Public Instance Methods

Add | Overloaded. Adds the new attachment.
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert | Inserts an element into the Collection`1 at the specified index.
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Items (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Protected Instance Methods

ClearItems (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
InsertItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RemoveItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
SetItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |

See Also

MapiAttachmentCollection Class | Aspose.Email.Outlook Namespace


MapiAttachmentCollection Constructor

Initializes a new instance of the MapiAttachmentCollection class.

Overload List

Initializes a new instance of the MapiAttachmentCollection class.

public MapiAttachmentCollection();

Initializes a new instance of the MapiAttachmentCollection class.

public MapiAttachmentCollection(MapiMessage);

See Also

MapiAttachmentCollection Class | Aspose.Email.Outlook Namespace


MapiAttachmentCollection Constructor ()

Initializes a new instance of the MapiAttachmentCollection class.

public MapiAttachmentCollection();

See Also

MapiAttachmentCollection Class | Aspose.Email.Outlook Namespace | MapiAttachmentCollection Constructor Overload List


MapiAttachmentCollection Constructor (MapiMessage)

Initializes a new instance of the MapiAttachmentCollection class.

public MapiAttachmentCollection(
MapiMessage owner
);

Parameters

owner
The owner message.

See Also

MapiAttachmentCollection Class | Aspose.Email.Outlook Namespace | MapiAttachmentCollection Constructor Overload List


MapiAttachmentCollection Methods

The methods of the MapiAttachmentCollection class are listed below. For a complete list of MapiAttachmentCollection class members, see the MapiAttachmentCollection Members topic.

Public Instance Methods

Add | Overloaded. Adds the new attachment.
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert | Inserts an element into the Collection`1 at the specified index.
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

ClearItems (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
InsertItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RemoveItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
SetItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |

See Also

MapiAttachmentCollection Class | Aspose.Email.Outlook Namespace


Add Method

Aspose.Email

MapiAttachmentCollection.Add Method

Adds an object to the end of the Collection`1.

Overload List

Adds an object to the end of the Collection`1.

new public void Add(MapiAttachment);

Adds the new attachment.

public void Add(string,byte[]);

See Also

MapiAttachmentCollection Class | Aspose.Email.Outlook Namespace


MapiAttachmentCollection.Add Method (MapiAttachment)

Adds an object to the end of the Collection`1.

new public void Add(
MapiAttachment item
);

Parameters

item
The object to be added to the end of the Collection`1. The value can be null for reference types.

Implements

ICollection`1.Add

See Also

MapiAttachmentCollection Class | Aspose.Email.Outlook Namespace | MapiAttachmentCollection.Add Overload List


MapiAttachmentCollection.Add Method (String, Byte[])

Adds the new attachment.

public void Add(
string name,
byte[] data
);

Parameters

name
The name of attachment.
data
The attachment data.

Exceptions

Exception Type | Condition
ArgumentNullException | throws if attachment name is null or empty.
ArgumentNullException | throws if attachment data is null.

See Also

MapiAttachmentCollection Class | Aspose.Email.Outlook Namespace | MapiAttachmentCollection.Add Overload List


MapiAttachmentCollection.Insert Method

Inserts an element into the Collection`1 at the specified index.

new public void Insert(
int index,
MapiAttachment item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The object to insert. The value can be null for reference types.

Implements

IList`1.Insert

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is greater than Count.

See Also

MapiAttachmentCollection Class | Aspose.Email.Outlook Namespace


MapiAttachmentPropertyStream Class

Represents the property stream of attachment object.

For a list of all members of this type, see MapiAttachmentPropertyStream Members.

System.Object
Aspose.Email.Outlook.MapiPropertyContainer
Aspose.Email.Outlook.MapiPropertyStream
Aspose.Email.Outlook.MapiAttachmentPropertyStream

public class MapiAttachmentPropertyStream : MapiPropertyStream

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiAttachmentPropertyStream Members | Aspose.Email.Outlook Namespace


MapiAttachmentPropertyStream Members

MapiAttachmentPropertyStream overview

Public Instance Constructors

MapiAttachmentPropertyStream Constructor Initializes a new instance of the MapiAttachmentPropertyStream class.

Public Instance Properties

CodePage (inherited from MapiPropertyContainer) | Gets the code page.
Content (inherited from MapiPropertyStream) | Gets the content.
Name (inherited from MapiPropertyStream) | Gets the name.
Properties (inherited from MapiPropertyContainer) | Gets the collection of properties.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPropertyBoolean (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Boolean type.
GetPropertyBytes (inherited from MapiPropertyContainer) | Gets the string value of the property specified by tag.
GetPropertyDateTime (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as DateTime type.
GetPropertyInt32 (inherited from MapiPropertyContainer) | Gets the int32 value of the property specified by tag.
GetPropertyLong (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Long (int64) type.
GetPropertyShort (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Short type.
GetPropertyString (inherited from MapiPropertyContainer) | Overloaded. Gets the string value of the property specified by tag.
GetType (inherited from Object) | Gets the Type of the current instance.
IsStoreUnicodeOk (inherited from MapiPropertyContainer) | Determines if string properties are Unicode encoded or not.
SetProperty |
ToString (inherited from Object) | Returns a String that represents the current Object.
TryGetPropertyData (inherited from MapiPropertyContainer) | Try to get the property data with specified tag key.
TryGetPropertyDateTime (inherited from MapiPropertyContainer) |
TryGetPropertyInt32 (inherited from MapiPropertyContainer) |
TryGetPropertyLong (inherited from MapiPropertyContainer) |
TryGetPropertyString (inherited from MapiPropertyContainer) | Overloaded. Try to get a property data as string with specified tag and code page.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetContent |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MapiAttachmentPropertyStream Class | Aspose.Email.Outlook Namespace


MapiAttachmentPropertyStream Constructor

Initializes a new instance of the MapiAttachmentPropertyStream class.

public MapiAttachmentPropertyStream();

See Also

MapiAttachmentPropertyStream Class | Aspose.Email.Outlook Namespace


MapiAttachmentPropertyStream Methods

The methods of the MapiAttachmentPropertyStream class are listed below. For a complete list of MapiAttachmentPropertyStream class members, see the MapiAttachmentPropertyStream Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPropertyBoolean (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Boolean type.
GetPropertyBytes (inherited from MapiPropertyContainer) | Gets the string value of the property specified by tag.
GetPropertyDateTime (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as DateTime type.
GetPropertyInt32 (inherited from MapiPropertyContainer) | Gets the int32 value of the property specified by tag.
GetPropertyLong (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Long (int64) type.
GetPropertyShort (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Short type.
GetPropertyString (inherited from MapiPropertyContainer) | Overloaded. Gets the string value of the property specified by tag.
GetType (inherited from Object) | Gets the Type of the current instance.
IsStoreUnicodeOk (inherited from MapiPropertyContainer) | Determines if string properties are Unicode encoded or not.
SetProperty |
ToString (inherited from Object) | Returns a String that represents the current Object.
TryGetPropertyData (inherited from MapiPropertyContainer) | Try to get the property data with specified tag key.
TryGetPropertyDateTime (inherited from MapiPropertyContainer) |
TryGetPropertyInt32 (inherited from MapiPropertyContainer) |
TryGetPropertyLong (inherited from MapiPropertyContainer) |
TryGetPropertyString (inherited from MapiPropertyContainer) | Overloaded. Try to get a property data as string with specified tag and code page.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetContent |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MapiAttachmentPropertyStream Class | Aspose.Email.Outlook Namespace


MapiAttachmentPropertyStream.GetContent Method

protected override MemoryStream GetContent();

See Also

MapiAttachmentPropertyStream Class | Aspose.Email.Outlook Namespace


MapiAttachmentPropertyStream.SetProperty Method

public override void SetProperty(
MapiProperty property
);

See Also

MapiAttachmentPropertyStream Class | Aspose.Email.Outlook Namespace


MapiCalendar Class

Represents the mapi calendar object

For a list of all members of this type, see MapiCalendar Members.

System.Object
Aspose.Email.Outlook.MapiCalendar

public sealed class MapiCalendar : IMapiMessageItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiCalendar Members | Aspose.Email.Outlook Namespace


MapiCalendar Members

MapiCalendar overview

Public Instance Constructors

MapiCalendar Overloaded. Initializes a new instance of the MapiCalendar class.

Public Instance Properties

AppointmentCounterProposal | Gets or sets a value indicating whether a Meeting Response object is a counter proposal.
Attachments | Gets the attachment collection.
Attendees | Gets or sets the attendees
Body | Gets message body
BusyStatus | Gets or sets the busy status
ClientIntent | Gets or sets the actions the user has taken on this Meeting object.
EndDate | Gets or sets the end date and time of the event. If the date is not set, default value for DateTime is returned.
EndDateTimeZone | Gets or sets time zone information that indicates the time zone of the EndDate property
IsAllDay | Gets or sets a value indicating whether the event is an all-day event
KeyWords | Gets or sets the categories of the calendar object
Location | Gets or sets the location of the event
MessageClass | Gets message class
Recurrence | Gets or sets the recurrence properties
RemainderDelta | Obsolete. Gets or sets the interval, in minutes, between the time at which the reminder first becomes overdue and the start time of the Calendar object
RemainderSet | Obsolete. Gets or sets a value indicating whether a reminder is set on the object
ReminderDelta | Gets or sets the interval, in minutes, between the time at which the reminder first becomes overdue and the start time of the Calendar object
ReminderFileParameter | Specifies the full path of the sound that a client SHOULD play when the reminder becomes overdue.
ReminderSet | Gets or sets a value indicating whether a reminder is set on the object
Sequence | Gets or sets the sequence number
StartDate | Gets or sets the start date and time of the event. If the date is not set, default value for DateTime is returned.
StartDateTimeZone | Gets or sets time zone information that indicates the time zone of the StartDate property
Subject | Gets message subject
Uid | Gets the unique identifier

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Overloaded. Saves calendar object to the file with iCalendar format using te default save options
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MapiCalendar Class | Aspose.Email.Outlook Namespace


MapiCalendar Constructor

Initializes a new instance of the MapiCalendar class

Overload List

Initializes a new instance of the MapiCalendar class

public MapiCalendar();

Initializes a new instance of the MapiCalendar class.

public MapiCalendar(string,string,string,DateTime,DateTime);

Initializes a new instance of the MapiCalendar class.

public MapiCalendar(string,string,string,DateTime,DateTime,string,MapiRecipientCollection);

See Also

MapiCalendar Class | Aspose.Email.Outlook Namespace


MapiCalendar Constructor ()

Initializes a new instance of the MapiCalendar class

public MapiCalendar();

See Also

MapiCalendar Class | Aspose.Email.Outlook Namespace | MapiCalendar Constructor Overload List


MapiCalendar Constructor (String, String, String, DateTime, DateTime)

Initializes a new instance of the MapiCalendar class.

public MapiCalendar(
string location,
string summary,
string description,
DateTime startDate,
DateTime endDate
);

Parameters

location
The appointment location.
summary
The appointment summary.
description
The appointment description.
startDate
The start date.
endDate
The end date.

See Also

MapiCalendar Class | Aspose.Email.Outlook Namespace | MapiCalendar Constructor Overload List


MapiCalendar Constructor (String, String, String, DateTime, DateTime, String, MapiRecipientCollection)

Initializes a new instance of the MapiCalendar class.

public MapiCalendar(
string location,
string summary,
string description,
DateTime startDate,
DateTime endDate,
string organizer,
MapiRecipientCollection attendees
);

Parameters

location
The meeting location.
summary
The meeting summary.
description
The meeting description.
startDate
The start date.
endDate
The end date.
organizer
The meeting organizer address.
attendees
The meeting attendees.

See Also

MapiCalendar Class | Aspose.Email.Outlook Namespace | MapiCalendar Constructor Overload List


MapiCalendar Properties

The properties of the MapiCalendar class are listed below. For a complete list of MapiCalendar class members, see the MapiCalendar Members topic.

Public Instance Properties

AppointmentCounterProposal | Gets or sets a value indicating whether a Meeting Response object is a counter proposal.
Attachments | Gets the attachment collection.
Attendees | Gets or sets the attendees
Body | Gets message body
BusyStatus | Gets or sets the busy status
ClientIntent | Gets or sets the actions the user has taken on this Meeting object.
EndDate | Gets or sets the end date and time of the event. If the date is not set, default value for DateTime is returned.
EndDateTimeZone | Gets or sets time zone information that indicates the time zone of the EndDate property
IsAllDay | Gets or sets a value indicating whether the event is an all-day event
KeyWords | Gets or sets the categories of the calendar object
Location | Gets or sets the location of the event
MessageClass | Gets message class
Recurrence | Gets or sets the recurrence properties
RemainderDelta | Obsolete. Gets or sets the interval, in minutes, between the time at which the reminder first becomes overdue and the start time of the Calendar object
RemainderSet | Obsolete. Gets or sets a value indicating whether a reminder is set on the object
ReminderDelta | Gets or sets the interval, in minutes, between the time at which the reminder first becomes overdue and the start time of the Calendar object
ReminderFileParameter | Specifies the full path of the sound that a client SHOULD play when the reminder becomes overdue.
ReminderSet | Gets or sets a value indicating whether a reminder is set on the object
Sequence | Gets or sets the sequence number
StartDate | Gets or sets the start date and time of the event. If the date is not set, default value for DateTime is returned.
StartDateTimeZone | Gets or sets time zone information that indicates the time zone of the StartDate property
Subject | Gets message subject
Uid | Gets the unique identifier

See Also

MapiCalendar Class | Aspose.Email.Outlook Namespace


AppointmentCounterProposal Property

Aspose.Email

MapiCalendar.AppointmentCounterProposal Property

Gets or sets a value indicating whether a Meeting Response object is a counter proposal.

public bool AppointmentCounterProposal {get; set;}

See Also

MapiCalendar Class | Aspose.Email.Outlook Namespace


Attachments Property

Aspose.Email

MapiCalendar.Attachments Property

Gets the attachment collection.

public MapiAttachmentCollection Attachments {get;}

See Also

MapiCalendar Class | Aspose.Email.Outlook Namespace


Attendees Property

Aspose.Email

MapiCalendar.Attendees Property

Gets or sets the attendees

public MapiCalendarAttendees Attendees {get; set;}

See Also

MapiCalendar Class | Aspose.Email.Outlook Namespace


Body Property

Aspose.Email

MapiCalendar.Body Property

Gets message body

public string Body {get;}

Implements

IMapiMessageItem.Body

See Also

MapiCalendar Class | Aspose.Email.Outlook Namespace


BusyStatus Property

Aspose.Email

MapiCalendar.BusyStatus Property

Gets or sets the busy status

public MapiCalendarBusyStatus BusyStatus {get; set;}

See Also

MapiCalendar Class | Aspose.Email.Outlook Namespace


ClientIntent Property

Aspose.Email

MapiCalendar.ClientIntent Property

Gets or sets the actions the user has taken on this Meeting object.

public MapiCalendarClientIntent ClientIntent {get; set;}

See Also

MapiCalendar Class | Aspose.Email.Outlook Namespace


EndDate Property

Aspose.Email

MapiCalendar.EndDate Property

Gets or sets the end date and time of the event. If the date is not set, default value for DateTime is returned.

public DateTime EndDate {get; set;}

See Also

MapiCalendar Class | Aspose.Email.Outlook Namespace


EndDateTimeZone Property

Aspose.Email

MapiCalendar.EndDateTimeZone Property

Gets or sets time zone information that indicates the time zone of the EndDate property

public MapiCalendarTimeZone EndDateTimeZone {get; set;}

See Also

MapiCalendar Class | Aspose.Email.Outlook Namespace


IsAllDay Property

Aspose.Email

MapiCalendar.IsAllDay Property

Gets or sets a value indicating whether the event is an all-day event

public bool IsAllDay {get; set;}

See Also

MapiCalendar Class | Aspose.Email.Outlook Namespace


KeyWords Property

Aspose.Email

MapiCalendar.KeyWords Property

Gets or sets the categories of the calendar object

public string KeyWords {get; set;}

See Also

MapiCalendar Class | Aspose.Email.Outlook Namespace


Location Property

Aspose.Email

MapiCalendar.Location Property

Gets or sets the location of the event

public string Location {get; set;}

See Also

MapiCalendar Class | Aspose.Email.Outlook Namespace


MessageClass Property

Aspose.Email

MapiCalendar.MessageClass Property

Gets message class

public string MessageClass {get;}

Implements

IMapiMessageItem.MessageClass

See Also

MapiCalendar Class | Aspose.Email.Outlook Namespace


Recurrence Property

Aspose.Email

MapiCalendar.Recurrence Property

Gets or sets the recurrence properties

public MapiCalendarEventRecurrence Recurrence {get; set;}

See Also

MapiCalendar Class | Aspose.Email.Outlook Namespace


RemainderDelta Property

Aspose.Email

MapiCalendar.RemainderDelta Property

NOTE: This property is now obsolete.

Please use ReminderDelta instead

Gets or sets the interval, in minutes, between the time at which the reminder first becomes overdue and the start time of the Calendar object

public int RemainderDelta {get; set;}

See Also

MapiCalendar Class | Aspose.Email.Outlook Namespace


RemainderSet Property

Aspose.Email

MapiCalendar.RemainderSet Property

NOTE: This property is now obsolete.

Please use ReminderSet instead

Gets or sets a value indicating whether a reminder is set on the object

public bool RemainderSet {get; set;}

See Also

MapiCalendar Class | Aspose.Email.Outlook Namespace


ReminderDelta Property

Aspose.Email

MapiCalendar.ReminderDelta Property

Gets or sets the interval, in minutes, between the time at which the reminder first becomes overdue and the start time of the Calendar object

public int ReminderDelta {get; set;}

See Also

MapiCalendar Class | Aspose.Email.Outlook Namespace


ReminderFileParameter Property

Aspose.Email

MapiCalendar.ReminderFileParameter Property

Specifies the full path of the sound that a client SHOULD play when the reminder becomes overdue.

public string ReminderFileParameter {get; set;}

See Also

MapiCalendar Class | Aspose.Email.Outlook Namespace


ReminderSet Property

Aspose.Email

MapiCalendar.ReminderSet Property

Gets or sets a value indicating whether a reminder is set on the object

public bool ReminderSet {get; set;}

See Also

MapiCalendar Class | Aspose.Email.Outlook Namespace


Sequence Property

Aspose.Email

MapiCalendar.Sequence Property

Gets or sets the sequence number

public int Sequence {get; set;}

See Also

MapiCalendar Class | Aspose.Email.Outlook Namespace


StartDate Property

Aspose.Email

MapiCalendar.StartDate Property

Gets or sets the start date and time of the event. If the date is not set, default value for DateTime is returned.

public DateTime StartDate {get; set;}

See Also

MapiCalendar Class | Aspose.Email.Outlook Namespace


StartDateTimeZone Property

Aspose.Email

MapiCalendar.StartDateTimeZone Property

Gets or sets time zone information that indicates the time zone of the StartDate property

public MapiCalendarTimeZone StartDateTimeZone {get; set;}

See Also

MapiCalendar Class | Aspose.Email.Outlook Namespace


Subject Property

Aspose.Email

MapiCalendar.Subject Property

Gets message subject

public string Subject {get;}

Implements

IMapiMessageItem.Subject

See Also

MapiCalendar Class | Aspose.Email.Outlook Namespace


Uid Property

Aspose.Email

MapiCalendar.Uid Property

Gets the unique identifier

public string Uid {get;}

See Also

MapiCalendar Class | Aspose.Email.Outlook Namespace


MapiCalendar Methods

The methods of the MapiCalendar class are listed below. For a complete list of MapiCalendar class members, see the MapiCalendar Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Overloaded. Saves calendar object to the file with iCalendar format using te default save options
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MapiCalendar Class | Aspose.Email.Outlook Namespace


Save Method

Aspose.Email

MapiCalendar.Save Method

Saves calendar object to the file with iCalendar format using te default save options

Overload List

Saves calendar object to the file with iCalendar format using te default save options

public void Save(Stream);

Saves calendar object to the stream with specified format using te default save options

public void Save(Stream,AppointmentSaveFormat);

Saves calendar object to the file with iCalendar format using te default save options

public void Save(string);

Saves calendar object to the file with specified format using te default save options

public void Save(string,AppointmentSaveFormat);

See Also

MapiCalendar Class | Aspose.Email.Outlook Namespace


MapiCalendar.Save Method (Stream)

Saves calendar object to the file with iCalendar format using te default save options

public void Save(
Stream stream
);

Parameters

stream
A stream to save to

Exceptions

Exception Type | Condition
ArgumentNullException | stream is null
NotSupportedException | stream does not support writing

See Also

MapiCalendar Class | Aspose.Email.Outlook Namespace | MapiCalendar.Save Overload List


MapiCalendar.Save Method (Stream, AppointmentSaveFormat)

Saves calendar object to the stream with specified format using te default save options

public void Save(
Stream stream,
AppointmentSaveFormat saveFormat
);

Parameters

stream
A stream to save to
saveFormat
A save format

Exceptions

Exception Type | Condition
ArgumentNullException | stream is null
NotSupportedException | The specified saveFormat is not supported
NotSupportedException | stream does not support writing

See Also

MapiCalendar Class | Aspose.Email.Outlook Namespace | MapiCalendar.Save Overload List


MapiCalendar.Save Method (String)

Saves calendar object to the file with iCalendar format using te default save options

public void Save(
string filePath
);

Parameters

filePath
A file path

Exceptions

Exception Type | Condition
ArgumentException | filePath is null or empty

See Also

MapiCalendar Class | Aspose.Email.Outlook Namespace | MapiCalendar.Save Overload List


MapiCalendar.Save Method (String, AppointmentSaveFormat)

Saves calendar object to the file with specified format using te default save options

public void Save(
string filePath,
AppointmentSaveFormat saveFormat
);

Parameters

filePath
A file path
saveFormat
A save format

Exceptions

Exception Type | Condition
ArgumentException | filePath is null or empty
NotSupportedException | The specified saveFormat is not supported

See Also

MapiCalendar Class | Aspose.Email.Outlook Namespace | MapiCalendar.Save Overload List


MapiCalendarAttendees Class

Represents the mapi calendar attendees

For a list of all members of this type, see MapiCalendarAttendees Members.

System.Object
Aspose.Email.Outlook.MapiCalendarAttendees

public sealed class MapiCalendarAttendees

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiCalendarAttendees Members | Aspose.Email.Outlook Namespace


MapiCalendarAttendees Members

MapiCalendarAttendees overview

Public Instance Constructors

MapiCalendarAttendees Constructor Initializes a new instance of the MapiCalendarAttendees class

Public Instance Properties

AppointmentRecipients | Gets or sets a list of attendees.
NotAllowPropose | Gets or sets a value indicating whether attendees are not allowed to propose a new date and/or time for the meeting.
ResponseRequested | Gets or sets a value indicating whether a response is requested to a Message object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MapiCalendarAttendees Class | Aspose.Email.Outlook Namespace


MapiCalendarAttendees Constructor

Initializes a new instance of the MapiCalendarAttendees class

public MapiCalendarAttendees();

See Also

MapiCalendarAttendees Class | Aspose.Email.Outlook Namespace


MapiCalendarAttendees Properties

The properties of the MapiCalendarAttendees class are listed below. For a complete list of MapiCalendarAttendees class members, see the MapiCalendarAttendees Members topic.

Public Instance Properties

AppointmentRecipients | Gets or sets a list of attendees.
NotAllowPropose | Gets or sets a value indicating whether attendees are not allowed to propose a new date and/or time for the meeting.
ResponseRequested | Gets or sets a value indicating whether a response is requested to a Message object.

See Also

MapiCalendarAttendees Class | Aspose.Email.Outlook Namespace


AppointmentRecipients Property

Aspose.Email

MapiCalendarAttendees.AppointmentRecipients Property

Gets or sets a list of attendees.

public MapiRecipientCollection AppointmentRecipients {get; set;}

See Also

MapiCalendarAttendees Class | Aspose.Email.Outlook Namespace


NotAllowPropose Property

Aspose.Email

MapiCalendarAttendees.NotAllowPropose Property

Gets or sets a value indicating whether attendees are not allowed to propose a new date and/or time for the meeting.

public bool NotAllowPropose {get; set;}

See Also

MapiCalendarAttendees Class | Aspose.Email.Outlook Namespace


ResponseRequested Property

Aspose.Email

MapiCalendarAttendees.ResponseRequested Property

Gets or sets a value indicating whether a response is requested to a Message object.

public bool ResponseRequested {get; set;}

See Also

MapiCalendarAttendees Class | Aspose.Email.Outlook Namespace


MapiCalendarBusyStatus Enumeration

Enumerates the mapi calendar possible busy status

public enum MapiCalendarBusyStatus

Members

Member Name | Description | Value
Free | The user is available. | 0
Tentative | The user has a tentative event scheduled. | 1
Busy | The user is busy. | 2
OutOfOffice | The user is Out of Office (OOF). | 3

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Outlook Namespace


MapiCalendarClientIntent Enumeration

Enumerates the actions the user can taken on the Meeting object

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum MapiCalendarClientIntent

Members

Member Name | Description | Value
Manager | The user is the owner of the meeting object. | 1
Delegate | The user is a delegate acting on a meeting object in a delegator's calendar folder. | 2
DeletedWithNoResponse | The user deleted the meeting object with no response sent to the organizer. | 4
DeletedExceptionWithNoResponse | The user deleted an exception to a recurring series with no response sent to the organizer. | 8
RespondedTentative | The user tentatively accepted the meeting request. | 16
RespondedAccept | The user accepted the meeting request. | 32
RespondedDecline | The user declined the meeting request. | 64
ModifiedStartTime | The user modified the start time. | 128
ModifiedEndTime | The user modified the end time. | 256
ModifiedLocation | The user changed the location of the meeting. | 512
RespondedExceptionDecline | The user declined an exception to a recurring series. | 1024
Canceled | The user canceled a meeting request. | 2048
ExceptionCanceled | The user canceled an exception to a recurring series. | 4096

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Outlook Namespace


MapiCalendarDailyRecurrencePattern Class

Represents the daily recurrence pattern of the mapi calendar

For a list of all members of this type, see MapiCalendarDailyRecurrencePattern Members.

System.Object
Aspose.Email.Outlook.MapiCalendarRecurrencePattern
Aspose.Email.Outlook.MapiCalendarDailyRecurrencePattern

public sealed class MapiCalendarDailyRecurrencePattern : MapiCalendarRecurrencePattern

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiCalendarDailyRecurrencePattern Members | Aspose.Email.Outlook Namespace


MapiCalendarDailyRecurrencePattern Members

MapiCalendarDailyRecurrencePattern overview

Public Instance Constructors

MapiCalendarDailyRecurrencePattern Constructor Initializes a new instance of the MapiCalendarDailyRecurrencePattern class

Public Instance Properties

CalendarType (inherited from MapiCalendarRecurrencePattern) | Gets or sets the type of calendar that is used
EndType (inherited from MapiCalendarRecurrencePattern) | Gets or sets the ending type for the recurrence.
Frequency (inherited from MapiCalendarRecurrencePattern) | Gets or sets the frequency of the recurring series.
OccurrenceCount (inherited from MapiCalendarRecurrencePattern) | Gets or sets the number of occurrences in a recurrence.
PatternType (inherited from MapiCalendarRecurrencePattern) | Gets or sets the type of recurrence pattern
Period | Gets or sets interval (in days) at which the meeting pattern repeats
WeekStartDay (inherited from MapiCalendarRecurrencePattern) | Gets or sets the first day of the calendar week.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MapiCalendarDailyRecurrencePattern Class | Aspose.Email.Outlook Namespace


MapiCalendarDailyRecurrencePattern Constructor

Initializes a new instance of the MapiCalendarDailyRecurrencePattern class

public MapiCalendarDailyRecurrencePattern();

See Also

MapiCalendarDailyRecurrencePattern Class | Aspose.Email.Outlook Namespace


MapiCalendarDailyRecurrencePattern Properties

The properties of the MapiCalendarDailyRecurrencePattern class are listed below. For a complete list of MapiCalendarDailyRecurrencePattern class members, see the MapiCalendarDailyRecurrencePattern Members topic.

Public Instance Properties

CalendarType (inherited from MapiCalendarRecurrencePattern) | Gets or sets the type of calendar that is used
EndType (inherited from MapiCalendarRecurrencePattern) | Gets or sets the ending type for the recurrence.
Frequency (inherited from MapiCalendarRecurrencePattern) | Gets or sets the frequency of the recurring series.
OccurrenceCount (inherited from MapiCalendarRecurrencePattern) | Gets or sets the number of occurrences in a recurrence.
PatternType (inherited from MapiCalendarRecurrencePattern) | Gets or sets the type of recurrence pattern
Period | Gets or sets interval (in days) at which the meeting pattern repeats
WeekStartDay (inherited from MapiCalendarRecurrencePattern) | Gets or sets the first day of the calendar week.

See Also

MapiCalendarDailyRecurrencePattern Class | Aspose.Email.Outlook Namespace


Period Property

Aspose.Email

MapiCalendarDailyRecurrencePattern.Period Property

Gets or sets interval (in days) at which the meeting pattern repeats

public override uint Period {get; set;}

See Also

MapiCalendarDailyRecurrencePattern Class | Aspose.Email.Outlook Namespace


MapiCalendarDayOfWeek Enumeration

Enumerates the days of week of the mapi calendar recurrence pattern

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum MapiCalendarDayOfWeek

Members

Member Name | Description | Value
Saturday | The event occurs on Saturday. | 64
Friday | The event occurs on Friday. | 32
Thursday | The event occurs on Thursday. | 16
Wednesday | The event occurs on Wednesday. | 8
Tuesday | The event occurs on Tuesday. | 4
Monday | The event occurs on Monday. | 2
Sunday | The event occurs on Sunday. | 1

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Outlook Namespace


MapiCalendarEventRecurrence Class

Represents the recurrence properties of calendar object

For a list of all members of this type, see MapiCalendarEventRecurrence Members.

System.Object
Aspose.Email.Outlook.MapiCalendarEventRecurrence

public sealed class MapiCalendarEventRecurrence

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiCalendarEventRecurrence Members | Aspose.Email.Outlook Namespace


MapiCalendarEventRecurrence Members

MapiCalendarEventRecurrence overview

Public Instance Constructors

MapiCalendarEventRecurrence Constructor Initializes a new instance of the MapiCalendarEventRecurrence class

Public Instance Properties

AppointmentTimeZoneDefinitionRecur | Gets or sets time zone information that describes how to convert the meeting date and time on a recurring series to and from UTC.
ClipEnd | Gets or sets the date of the last instance
ClipStart | Gets or sets the date of the first instance
IsException | Gets or sets a value indicating whether the object represents an exception
RecurrencePattern | Gets or sets the recurrence pattern
TimeZoneStruct | Gets or sets the time zone information for a recurring meeting.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MapiCalendarEventRecurrence Class | Aspose.Email.Outlook Namespace


MapiCalendarEventRecurrence Constructor

Initializes a new instance of the MapiCalendarEventRecurrence class

public MapiCalendarEventRecurrence();

See Also

MapiCalendarEventRecurrence Class | Aspose.Email.Outlook Namespace


MapiCalendarEventRecurrence Properties

The properties of the MapiCalendarEventRecurrence class are listed below. For a complete list of MapiCalendarEventRecurrence class members, see the MapiCalendarEventRecurrence Members topic.

Public Instance Properties

AppointmentTimeZoneDefinitionRecur | Gets or sets time zone information that describes how to convert the meeting date and time on a recurring series to and from UTC.
ClipEnd | Gets or sets the date of the last instance
ClipStart | Gets or sets the date of the first instance
IsException | Gets or sets a value indicating whether the object represents an exception
RecurrencePattern | Gets or sets the recurrence pattern
TimeZoneStruct | Gets or sets the time zone information for a recurring meeting.

See Also

MapiCalendarEventRecurrence Class | Aspose.Email.Outlook Namespace


AppointmentTimeZoneDefinitionRecur Property

Aspose.Email

MapiCalendarEventRecurrence.AppointmentTimeZoneDefinitionRecur Property

Gets or sets time zone information that describes how to convert the meeting date and time on a recurring series to and from UTC.

public MapiCalendarTimeZone AppointmentTimeZoneDefinitionRecur {get; set;}

See Also

MapiCalendarEventRecurrence Class | Aspose.Email.Outlook Namespace


ClipEnd Property

Aspose.Email

MapiCalendarEventRecurrence.ClipEnd Property

Gets or sets the date of the last instance

public DateTime ClipEnd {get; set;}

See Also

MapiCalendarEventRecurrence Class | Aspose.Email.Outlook Namespace


ClipStart Property

Aspose.Email

MapiCalendarEventRecurrence.ClipStart Property

Gets or sets the date of the first instance

public DateTime ClipStart {get; set;}

See Also

MapiCalendarEventRecurrence Class | Aspose.Email.Outlook Namespace


IsException Property

Aspose.Email

MapiCalendarEventRecurrence.IsException Property

Gets or sets a value indicating whether the object represents an exception

public bool IsException {get; set;}

See Also

MapiCalendarEventRecurrence Class | Aspose.Email.Outlook Namespace


RecurrencePattern Property

Aspose.Email

MapiCalendarEventRecurrence.RecurrencePattern Property

Gets or sets the recurrence pattern

public MapiCalendarRecurrencePattern RecurrencePattern {get; set;}

See Also

MapiCalendarEventRecurrence Class | Aspose.Email.Outlook Namespace


TimeZoneStruct Property

Aspose.Email

MapiCalendarEventRecurrence.TimeZoneStruct Property

Gets or sets the time zone information for a recurring meeting.

public MapiCalendarTimeZone TimeZoneStruct {get; set;}

See Also

MapiCalendarEventRecurrence Class | Aspose.Email.Outlook Namespace


MapiCalendarMonthlyNthRecurrencePattern Class

Represents the daily recurrence pattern of the mapi calendar

For a list of all members of this type, see MapiCalendarMonthlyNthRecurrencePattern Members.

System.Object
Aspose.Email.Outlook.MapiCalendarRecurrencePattern
Aspose.Email.Outlook.MapiCalendarMonthlyNthRecurrencePattern

public sealed class MapiCalendarMonthlyNthRecurrencePattern : MapiCalendarRecurrencePattern

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiCalendarMonthlyNthRecurrencePattern Members | Aspose.Email.Outlook Namespace


MapiCalendarMonthlyNthRecurrencePattern Members

MapiCalendarMonthlyNthRecurrencePattern overview

Public Instance Constructors

MapiCalendarMonthlyNthRecurrencePattern Constructor Initializes a new instance of the MapiCalendarMonthlyNthRecurrencePattern class

Public Instance Properties

CalendarType (inherited from MapiCalendarRecurrencePattern) | Gets or sets the type of calendar that is used
DayOfWeek | Gets or sets the days of week at which the event occurs
DayPosition | Gets or sets the occurrence of the recurrence's days in each month in which the recurrence falls.
EndType (inherited from MapiCalendarRecurrencePattern) | Gets or sets the ending type for the recurrence.
Frequency | Gets or sets the frequency of the recurring series.
OccurrenceCount (inherited from MapiCalendarRecurrencePattern) | Gets or sets the number of occurrences in a recurrence.
PatternType (inherited from MapiCalendarRecurrencePattern) | Gets or sets the type of recurrence pattern
Period | Gets or sets interval (in months) at which the meeting pattern repeats
WeekStartDay (inherited from MapiCalendarRecurrencePattern) | Gets or sets the first day of the calendar week.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MapiCalendarMonthlyNthRecurrencePattern Class | Aspose.Email.Outlook Namespace


MapiCalendarMonthlyNthRecurrencePattern Constructor

Initializes a new instance of the MapiCalendarMonthlyNthRecurrencePattern class

public MapiCalendarMonthlyNthRecurrencePattern();

See Also

MapiCalendarMonthlyNthRecurrencePattern Class | Aspose.Email.Outlook Namespace


MapiCalendarMonthlyNthRecurrencePattern Properties

The properties of the MapiCalendarMonthlyNthRecurrencePattern class are listed below. For a complete list of MapiCalendarMonthlyNthRecurrencePattern class members, see the MapiCalendarMonthlyNthRecurrencePattern Members topic.

Public Instance Properties

CalendarType (inherited from MapiCalendarRecurrencePattern) | Gets or sets the type of calendar that is used
DayOfWeek | Gets or sets the days of week at which the event occurs
DayPosition | Gets or sets the occurrence of the recurrence's days in each month in which the recurrence falls.
EndType (inherited from MapiCalendarRecurrencePattern) | Gets or sets the ending type for the recurrence.
Frequency | Gets or sets the frequency of the recurring series.
OccurrenceCount (inherited from MapiCalendarRecurrencePattern) | Gets or sets the number of occurrences in a recurrence.
PatternType (inherited from MapiCalendarRecurrencePattern) | Gets or sets the type of recurrence pattern
Period | Gets or sets interval (in months) at which the meeting pattern repeats
WeekStartDay (inherited from MapiCalendarRecurrencePattern) | Gets or sets the first day of the calendar week.

See Also

MapiCalendarMonthlyNthRecurrencePattern Class | Aspose.Email.Outlook Namespace


DayOfWeek Property

Aspose.Email

MapiCalendarMonthlyNthRecurrencePattern.DayOfWeek Property

Gets or sets the days of week at which the event occurs

public MapiCalendarDayOfWeek DayOfWeek {get; set;}

See Also

MapiCalendarMonthlyNthRecurrencePattern Class | Aspose.Email.Outlook Namespace


DayPosition Property

Aspose.Email

MapiCalendarMonthlyNthRecurrencePattern.DayPosition Property

Gets or sets the occurrence of the recurrence's days in each month in which the recurrence falls.

public DayPosition DayPosition {get; set;}

See Also

MapiCalendarMonthlyNthRecurrencePattern Class | Aspose.Email.Outlook Namespace


Frequency Property

Aspose.Email

MapiCalendarMonthlyNthRecurrencePattern.Frequency Property

Gets or sets the frequency of the recurring series.

public override MapiCalendarRecurrenceFrequency Frequency {get;}

See Also

MapiCalendarMonthlyNthRecurrencePattern Class | Aspose.Email.Outlook Namespace


Period Property

Aspose.Email

MapiCalendarMonthlyNthRecurrencePattern.Period Property

Gets or sets interval (in months) at which the meeting pattern repeats

public override uint Period {get; set;}

See Also

MapiCalendarMonthlyNthRecurrencePattern Class | Aspose.Email.Outlook Namespace


MapiCalendarMonthlyRecurrencePattern Class

Represents the monthly recurrence pattern of the mapi calendar

For a list of all members of this type, see MapiCalendarMonthlyRecurrencePattern Members.

System.Object
Aspose.Email.Outlook.MapiCalendarRecurrencePattern
Aspose.Email.Outlook.MapiCalendarMonthlyRecurrencePattern

public sealed class MapiCalendarMonthlyRecurrencePattern : MapiCalendarRecurrencePattern

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiCalendarMonthlyRecurrencePattern Members | Aspose.Email.Outlook Namespace


MapiCalendarMonthlyRecurrencePattern Members

MapiCalendarMonthlyRecurrencePattern overview

Public Instance Constructors

MapiCalendarMonthlyRecurrencePattern Constructor Initializes a new instance of the MapiCalendarMonthlyRecurrencePattern class

Public Instance Properties

CalendarType (inherited from MapiCalendarRecurrencePattern) | Gets or sets the type of calendar that is used
Day | Gets or sets day of the month on which the recurrence falls.
EndType (inherited from MapiCalendarRecurrencePattern) | Gets or sets the ending type for the recurrence.
Frequency | Gets or sets the frequency of the recurring series.
OccurrenceCount (inherited from MapiCalendarRecurrencePattern) | Gets or sets the number of occurrences in a recurrence.
PatternType (inherited from MapiCalendarRecurrencePattern) | Gets or sets the type of recurrence pattern
Period | Gets or sets interval (in months) at which the meeting pattern repeats
WeekStartDay (inherited from MapiCalendarRecurrencePattern) | Gets or sets the first day of the calendar week.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MapiCalendarMonthlyRecurrencePattern Class | Aspose.Email.Outlook Namespace


MapiCalendarMonthlyRecurrencePattern Constructor

Initializes a new instance of the MapiCalendarMonthlyRecurrencePattern class

public MapiCalendarMonthlyRecurrencePattern();

See Also

MapiCalendarMonthlyRecurrencePattern Class | Aspose.Email.Outlook Namespace


MapiCalendarMonthlyRecurrencePattern Properties

The properties of the MapiCalendarMonthlyRecurrencePattern class are listed below. For a complete list of MapiCalendarMonthlyRecurrencePattern class members, see the MapiCalendarMonthlyRecurrencePattern Members topic.

Public Instance Properties

CalendarType (inherited from MapiCalendarRecurrencePattern) | Gets or sets the type of calendar that is used
Day | Gets or sets day of the month on which the recurrence falls.
EndType (inherited from MapiCalendarRecurrencePattern) | Gets or sets the ending type for the recurrence.
Frequency | Gets or sets the frequency of the recurring series.
OccurrenceCount (inherited from MapiCalendarRecurrencePattern) | Gets or sets the number of occurrences in a recurrence.
PatternType (inherited from MapiCalendarRecurrencePattern) | Gets or sets the type of recurrence pattern
Period | Gets or sets interval (in months) at which the meeting pattern repeats
WeekStartDay (inherited from MapiCalendarRecurrencePattern) | Gets or sets the first day of the calendar week.

See Also

MapiCalendarMonthlyRecurrencePattern Class | Aspose.Email.Outlook Namespace


Day Property

Aspose.Email

MapiCalendarMonthlyRecurrencePattern.Day Property

Gets or sets day of the month on which the recurrence falls.

public uint Day {get; set;}

See Also

MapiCalendarMonthlyRecurrencePattern Class | Aspose.Email.Outlook Namespace


Frequency Property

Aspose.Email

MapiCalendarMonthlyRecurrencePattern.Frequency Property

Gets or sets the frequency of the recurring series.

public override MapiCalendarRecurrenceFrequency Frequency {get;}

See Also

MapiCalendarMonthlyRecurrencePattern Class | Aspose.Email.Outlook Namespace


Period Property

Aspose.Email

MapiCalendarMonthlyRecurrencePattern.Period Property

Gets or sets interval (in months) at which the meeting pattern repeats

public override uint Period {get; set;}

See Also

MapiCalendarMonthlyRecurrencePattern Class | Aspose.Email.Outlook Namespace


MapiCalendarRecurrenceCalendarType Enumeration

Enumerated the calendar type of the mapi recurrence

public enum MapiCalendarRecurrenceCalendarType

Members

Member Name | Description | Value
Default | The default value for the calendar type is Gregorian. (If the PatternType is HjMonth, HjMonthNth, or HjMonthEnd, and the CalendarType is Default, this recurrence uses the Hijri calendar.) | 0
CAL_GREGORIAN | Gregorian (localized) calendar | 1
CAL_GREGORIAN_US | Gregorian (U.S.) calendar | 2
CAL_JAPAN | Japanese Emperor Era calendar | 3
CAL_TAIWAN | Taiwan calendar | 4
CAL_KOREA | Korean Tangun Era calendar | 5
CAL_HIJRI | Hijri (Arabic Lunar) calendar | 6
CAL_THAI | Thai calendar | 7
CAL_HEBREW | Hebrew lunar calendar | 8
CAL_GREGORIAN_ME_FRENCH | Gregorian Middle East French calendar | 9
CAL_GREGORIAN_ARABIC | Gregorian Arabic calendar | 10
CAL_GREGORIAN_XLIT_ENGLISH | Gregorian transliterated English calendar | 11
CAL_GREGORIAN_XLIT_FRENCH | Gregorian transliterated French calendar | 12
CAL_LUNAR_JAPANESE | Japanese lunar calendar | 14
CAL_CHINESE_LUNAR | Chinese lunar calendar | 15
CAL_SAKA | Saka Era calendar | 16
CAL_LUNAR_ETO_CHN | Lunar ETO Chinese calendar | 17
CAL_LUNAR_ETO_KOR | Lunar ETO Korean calendar | 18
CAL_LUNAR_ROKUYOU | Lunar Rokuyou calendar | 19
CAL_LUNAR_KOREAN | Korean lunar calendar | 20
CAL_UMALQURA | Um Al Qura calendar | 23

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Outlook Namespace


MapiCalendarRecurrenceEndType Enumeration

Enumerates the ending type for the recurrence.

public enum MapiCalendarRecurrenceEndType

Members

Member Name | Description | Value
None | No values are set | 0
EndAfterDate | Ends after date. | 8225
EndAfterNOccurrences | Ends after N occurrences. | 8226
NeverEnd | Never ends. | 8227

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Outlook Namespace


MapiCalendarRecurrenceFrequency Enumeration

Enumerates mapi calendar recurrence frequency

public enum MapiCalendarRecurrenceFrequency

Members

Member Name | Description | Value
None | No values are set. | 0
Daily | Specifies daily frequency | 8202
Weekly | Specifies weekly frequency | 8203
Monthly | Specifies monthly frequency | 8204
Yearly | Specifies yearly frequency | 8205

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Outlook Namespace


MapiCalendarRecurrencePattern Class

Represents the mapi recurrence pattern

For a list of all members of this type, see MapiCalendarRecurrencePattern Members.

System.Object
Aspose.Email.Outlook.MapiCalendarRecurrencePattern
Aspose.Email.Outlook.MapiCalendarDailyRecurrencePattern
Aspose.Email.Outlook.MapiCalendarMonthlyNthRecurrencePattern
Aspose.Email.Outlook.MapiCalendarMonthlyRecurrencePattern
Aspose.Email.Outlook.MapiCalendarWeeklyRecurrencePattern

public abstract class MapiCalendarRecurrencePattern

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiCalendarRecurrencePattern Members | Aspose.Email.Outlook Namespace


MapiCalendarRecurrencePattern Members

MapiCalendarRecurrencePattern overview

Public Instance Properties

CalendarType | Gets or sets the type of calendar that is used
EndType | Gets or sets the ending type for the recurrence.
Frequency | Gets or sets the frequency of the recurring series.
OccurrenceCount | Gets or sets the number of occurrences in a recurrence.
PatternType | Gets or sets the type of recurrence pattern
Period | Gets or sets interval at which the meeting pattern repeats
WeekStartDay | Gets or sets the first day of the calendar week.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

MapiCalendarRecurrencePattern Constructor Initializes a new instance of the MapiCalendarRecurrencePattern class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MapiCalendarRecurrencePattern Class | Aspose.Email.Outlook Namespace


MapiCalendarRecurrencePattern Constructor

Initializes a new instance of the MapiCalendarRecurrencePattern class.

protected MapiCalendarRecurrencePattern();

See Also

MapiCalendarRecurrencePattern Class | Aspose.Email.Outlook Namespace


MapiCalendarRecurrencePattern Properties

The properties of the MapiCalendarRecurrencePattern class are listed below. For a complete list of MapiCalendarRecurrencePattern class members, see the MapiCalendarRecurrencePattern Members topic.

Public Instance Properties

CalendarType | Gets or sets the type of calendar that is used
EndType | Gets or sets the ending type for the recurrence.
Frequency | Gets or sets the frequency of the recurring series.
OccurrenceCount | Gets or sets the number of occurrences in a recurrence.
PatternType | Gets or sets the type of recurrence pattern
Period | Gets or sets interval at which the meeting pattern repeats
WeekStartDay | Gets or sets the first day of the calendar week.

See Also

MapiCalendarRecurrencePattern Class | Aspose.Email.Outlook Namespace


CalendarType Property

Aspose.Email

MapiCalendarRecurrencePattern.CalendarType Property

Gets or sets the type of calendar that is used

public MapiCalendarRecurrenceCalendarType CalendarType {get; set;}

See Also

MapiCalendarRecurrencePattern Class | Aspose.Email.Outlook Namespace


EndType Property

Aspose.Email

MapiCalendarRecurrencePattern.EndType Property

Gets or sets the ending type for the recurrence.

public MapiCalendarRecurrenceEndType EndType {get; set;}

See Also

MapiCalendarRecurrencePattern Class | Aspose.Email.Outlook Namespace


Frequency Property

Aspose.Email

MapiCalendarRecurrencePattern.Frequency Property

Gets or sets the frequency of the recurring series.

public virtual MapiCalendarRecurrenceFrequency Frequency {get; set;}

See Also

MapiCalendarRecurrencePattern Class | Aspose.Email.Outlook Namespace


OccurrenceCount Property

Aspose.Email

MapiCalendarRecurrencePattern.OccurrenceCount Property

Gets or sets the number of occurrences in a recurrence.

public uint OccurrenceCount {get; set;}

See Also

MapiCalendarRecurrencePattern Class | Aspose.Email.Outlook Namespace


PatternType Property

Aspose.Email

MapiCalendarRecurrencePattern.PatternType Property

Gets or sets the type of recurrence pattern

public MapiCalendarRecurrencePatternType PatternType {get; set;}

See Also

MapiCalendarRecurrencePattern Class | Aspose.Email.Outlook Namespace


Period Property

Aspose.Email

MapiCalendarRecurrencePattern.Period Property

Gets or sets interval at which the meeting pattern repeats

public abstract uint Period {get; set;}

See Also

MapiCalendarRecurrencePattern Class | Aspose.Email.Outlook Namespace


WeekStartDay Property

Aspose.Email

MapiCalendarRecurrencePattern.WeekStartDay Property

Gets or sets the first day of the calendar week.

public DayOfWeek WeekStartDay {get; set;}

See Also

MapiCalendarRecurrencePattern Class | Aspose.Email.Outlook Namespace


MapiCalendarRecurrencePatternType Enumeration

Enumerates the mapi calendar recurrence pattern types

public enum MapiCalendarRecurrencePatternType

Members

Member Name | Description | Value
Day | The event has a daily recurrence. | 0
Week | The event has a weekly recurrence. | 1
Month | The event has a monthly recurrence. | 2
MonthEnd | The event has a month-end recurrence. | 4
MonthNth | The event has an every nth month pattern. | 3
HjMonth | The event has a monthly recurrence in the Hijri calendar | 10
HjMonthNth | The event has an every nth month pattern in the Hijri calendar. | 11
HjMonthEnd | The event has a month end recurrence in the Hijri calendar. | 12

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Outlook Namespace


MapiCalendarTimeZone Class

Represents the mapi calendar time zone information

For a list of all members of this type, see MapiCalendarTimeZone Members.

System.Object
Aspose.Email.Outlook.MapiCalendarTimeZone

public sealed class MapiCalendarTimeZone

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiCalendarTimeZone Members | Aspose.Email.Outlook Namespace


MapiCalendarTimeZone Members

MapiCalendarTimeZone overview

Public Instance Constructors

MapiCalendarTimeZone Constructor Initializes a new instance of the MapiCalendarTimeZone class.

Public Instance Properties

KeyName | Gets or sets a human-readable description of the time zone
TimeZoneRules | Gets or sets the time zone rules

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MapiCalendarTimeZone Class | Aspose.Email.Outlook Namespace


MapiCalendarTimeZone Constructor

Initializes a new instance of the MapiCalendarTimeZone class.

public MapiCalendarTimeZone();

See Also

MapiCalendarTimeZone Class | Aspose.Email.Outlook Namespace


MapiCalendarTimeZone Properties

The properties of the MapiCalendarTimeZone class are listed below. For a complete list of MapiCalendarTimeZone class members, see the MapiCalendarTimeZone Members topic.

Public Instance Properties

KeyName | Gets or sets a human-readable description of the time zone
TimeZoneRules | Gets or sets the time zone rules

See Also

MapiCalendarTimeZone Class | Aspose.Email.Outlook Namespace


KeyName Property

Aspose.Email

MapiCalendarTimeZone.KeyName Property

Gets or sets a human-readable description of the time zone

public string KeyName {get; set;}

See Also

MapiCalendarTimeZone Class | Aspose.Email.Outlook Namespace


TimeZoneRules Property

Aspose.Email

MapiCalendarTimeZone.TimeZoneRules Property

Gets or sets the time zone rules

public MapiCalendarTimeZoneInfoCollection TimeZoneRules {get; set;}

See Also

MapiCalendarTimeZone Class | Aspose.Email.Outlook Namespace


MapiCalendarTimeZoneFlags Enumeration

Enumerates the individual bit flags that specify information about TimeZoneRule

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum MapiCalendarTimeZoneFlags

Members

Member Name | Description | Value
TZRULE_FLAG_RECUR_CURRENT_TZREG | Indicates that this rule is associated with a recurring series. | 1
TZRULE_FLAG_EFFECTIVE_TZREG | This flag indicates that this rule is the effective rule. | 2

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Outlook Namespace


MapiCalendarTimeZoneInfo Class

Represents the mapi calendar time zone rule

For a list of all members of this type, see MapiCalendarTimeZoneInfo Members.

System.Object
Aspose.Email.Outlook.MapiCalendarTimeZoneInfo

public sealed class MapiCalendarTimeZoneInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiCalendarTimeZoneInfo Members | Aspose.Email.Outlook Namespace


MapiCalendarTimeZoneInfo Members

MapiCalendarTimeZoneInfo overview

Public Instance Constructors

MapiCalendarTimeZoneInfo Constructor Initializes a new instance of the MapiCalendarTimeZoneInfo class.

Public Instance Properties

Bias | Gets or sets the time zone's offset in minutes from UTC.
DaylightBias | Gets or sets offset in minutes from lBias during daylight saving time.
DaylightDate | Gets or sets the date and local time that indicate when to begin using the DaylightBias.
StandardBias | Gets or sets the offset in minutes from lBias during standard time.
StandardDate | Gets or sets the date and local time that indicate when to begin using the StandardBias.
TimeZoneFlags | Gets or sets individual bit flags that specify information about this TimeZoneRule
Year | Gets or sets the year in which this rule is scheduled to take effect.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MapiCalendarTimeZoneInfo Class | Aspose.Email.Outlook Namespace


MapiCalendarTimeZoneInfo Constructor

Initializes a new instance of the MapiCalendarTimeZoneInfo class.

public MapiCalendarTimeZoneInfo();

See Also

MapiCalendarTimeZoneInfo Class | Aspose.Email.Outlook Namespace


MapiCalendarTimeZoneInfo Properties

The properties of the MapiCalendarTimeZoneInfo class are listed below. For a complete list of MapiCalendarTimeZoneInfo class members, see the MapiCalendarTimeZoneInfo Members topic.

Public Instance Properties

Bias | Gets or sets the time zone's offset in minutes from UTC.
DaylightBias | Gets or sets offset in minutes from lBias during daylight saving time.
DaylightDate | Gets or sets the date and local time that indicate when to begin using the DaylightBias.
StandardBias | Gets or sets the offset in minutes from lBias during standard time.
StandardDate | Gets or sets the date and local time that indicate when to begin using the StandardBias.
TimeZoneFlags | Gets or sets individual bit flags that specify information about this TimeZoneRule
Year | Gets or sets the year in which this rule is scheduled to take effect.

See Also

MapiCalendarTimeZoneInfo Class | Aspose.Email.Outlook Namespace


Bias Property

Aspose.Email

MapiCalendarTimeZoneInfo.Bias Property

Gets or sets the time zone's offset in minutes from UTC.

public int Bias {get; set;}

See Also

MapiCalendarTimeZoneInfo Class | Aspose.Email.Outlook Namespace


DaylightBias Property

Aspose.Email

MapiCalendarTimeZoneInfo.DaylightBias Property

Gets or sets offset in minutes from lBias during daylight saving time.

public int DaylightBias {get; set;}

See Also

MapiCalendarTimeZoneInfo Class | Aspose.Email.Outlook Namespace


DaylightDate Property

Aspose.Email

MapiCalendarTimeZoneInfo.DaylightDate Property

Gets or sets the date and local time that indicate when to begin using the DaylightBias.

public MapiCalendarTimeZoneRule DaylightDate {get; set;}

See Also

MapiCalendarTimeZoneInfo Class | Aspose.Email.Outlook Namespace


StandardBias Property

Aspose.Email

MapiCalendarTimeZoneInfo.StandardBias Property

Gets or sets the offset in minutes from lBias during standard time.

public int StandardBias {get; set;}

See Also

MapiCalendarTimeZoneInfo Class | Aspose.Email.Outlook Namespace


StandardDate Property

Aspose.Email

MapiCalendarTimeZoneInfo.StandardDate Property

Gets or sets the date and local time that indicate when to begin using the StandardBias.

public MapiCalendarTimeZoneRule StandardDate {get; set;}

See Also

MapiCalendarTimeZoneInfo Class | Aspose.Email.Outlook Namespace


TimeZoneFlags Property

Aspose.Email

MapiCalendarTimeZoneInfo.TimeZoneFlags Property

Gets or sets individual bit flags that specify information about this TimeZoneRule

public MapiCalendarTimeZoneFlags TimeZoneFlags {get; set;}

See Also

MapiCalendarTimeZoneInfo Class | Aspose.Email.Outlook Namespace


Year Property

Aspose.Email

MapiCalendarTimeZoneInfo.Year Property

Gets or sets the year in which this rule is scheduled to take effect.

public ushort Year {get; set;}

See Also

MapiCalendarTimeZoneInfo Class | Aspose.Email.Outlook Namespace


MapiCalendarTimeZoneInfoCollection Class

Represents a collection of MapiCalendarTimeZoneInfo

For a list of all members of this type, see MapiCalendarTimeZoneInfoCollection Members.

System.Object
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Outlook.MapiCalendarTimeZoneInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]]
Aspose.Email.Outlook.MapiCalendarTimeZoneInfoCollection

public sealed class MapiCalendarTimeZoneInfoCollection : Collection`1

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiCalendarTimeZoneInfoCollection Members | Aspose.Email.Outlook Namespace


MapiCalendarTimeZoneInfoCollection Members

MapiCalendarTimeZoneInfoCollection overview

Public Instance Constructors

MapiCalendarTimeZoneInfoCollection Constructor Initializes a new instance of the MapiCalendarTimeZoneInfoCollection class.

Public Instance Properties

Count (inherited from 0, Culture=neutral, PublicKeyToken=null]])
Item (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MapiCalendarTimeZoneInfoCollection Class | Aspose.Email.Outlook Namespace


MapiCalendarTimeZoneInfoCollection Constructor

Initializes a new instance of the MapiCalendarTimeZoneInfoCollection class.

public MapiCalendarTimeZoneInfoCollection();

See Also

MapiCalendarTimeZoneInfoCollection Class | Aspose.Email.Outlook Namespace


MapiCalendarTimeZoneRule Class

Represents time zone rule that indicate when to begin using the Standard/Daylight time.

For a list of all members of this type, see MapiCalendarTimeZoneRule Members.

System.Object
Aspose.Email.Outlook.MapiCalendarTimeZoneRule

public sealed class MapiCalendarTimeZoneRule

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiCalendarTimeZoneRule Members | Aspose.Email.Outlook Namespace


MapiCalendarTimeZoneRule Members

MapiCalendarTimeZoneRule overview

Public Instance Constructors

MapiCalendarTimeZoneRule Constructor Initializes a new instance of the MapiCalendarTimeZoneRule class.

Public Instance Properties

Date | Gets the date and time that indicate when to begin using the Standard/Daylight time.
DayOfWeek | Gets or sets the day of week
DayPosition | Gets or sets the day position
Hour | Gets or sets the hour
Milliseconds | Gets or sets the milliseconds
Minute | Gets or sets the minutes
Month | Gets or sets the month
Seconds | Gets or sets the seconds
Year | Gets or sets the year

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MapiCalendarTimeZoneRule Class | Aspose.Email.Outlook Namespace


MapiCalendarTimeZoneRule Constructor

Initializes a new instance of the MapiCalendarTimeZoneRule class.

public MapiCalendarTimeZoneRule();

See Also

MapiCalendarTimeZoneRule Class | Aspose.Email.Outlook Namespace


MapiCalendarTimeZoneRule Properties

The properties of the MapiCalendarTimeZoneRule class are listed below. For a complete list of MapiCalendarTimeZoneRule class members, see the MapiCalendarTimeZoneRule Members topic.

Public Instance Properties

Date | Gets the date and time that indicate when to begin using the Standard/Daylight time.
DayOfWeek | Gets or sets the day of week
DayPosition | Gets or sets the day position
Hour | Gets or sets the hour
Milliseconds | Gets or sets the milliseconds
Minute | Gets or sets the minutes
Month | Gets or sets the month
Seconds | Gets or sets the seconds
Year | Gets or sets the year

See Also

MapiCalendarTimeZoneRule Class | Aspose.Email.Outlook Namespace


Date Property

Aspose.Email

MapiCalendarTimeZoneRule.Date Property

Gets the date and time that indicate when to begin using the Standard/Daylight time.

public DateTime Date {get;}

See Also

MapiCalendarTimeZoneRule Class | Aspose.Email.Outlook Namespace


DayOfWeek Property

Aspose.Email

MapiCalendarTimeZoneRule.DayOfWeek Property

Gets or sets the day of week

public DayOfWeek DayOfWeek {get; set;}

See Also

MapiCalendarTimeZoneRule Class | Aspose.Email.Outlook Namespace


DayPosition Property

Aspose.Email

MapiCalendarTimeZoneRule.DayPosition Property

Gets or sets the day position

public DayPosition DayPosition {get; set;}

See Also

MapiCalendarTimeZoneRule Class | Aspose.Email.Outlook Namespace


Hour Property

Aspose.Email

MapiCalendarTimeZoneRule.Hour Property

Gets or sets the hour

public ushort Hour {get; set;}

See Also

MapiCalendarTimeZoneRule Class | Aspose.Email.Outlook Namespace


Milliseconds Property

Aspose.Email

MapiCalendarTimeZoneRule.Milliseconds Property

Gets or sets the milliseconds

public ushort Milliseconds {get; set;}

See Also

MapiCalendarTimeZoneRule Class | Aspose.Email.Outlook Namespace


Minute Property

Aspose.Email

MapiCalendarTimeZoneRule.Minute Property

Gets or sets the minutes

public ushort Minute {get; set;}

See Also

MapiCalendarTimeZoneRule Class | Aspose.Email.Outlook Namespace


Month Property

Aspose.Email

MapiCalendarTimeZoneRule.Month Property

Gets or sets the month

public ushort Month {get; set;}

See Also

MapiCalendarTimeZoneRule Class | Aspose.Email.Outlook Namespace


Seconds Property

Aspose.Email

MapiCalendarTimeZoneRule.Seconds Property

Gets or sets the seconds

public ushort Seconds {get; set;}

See Also

MapiCalendarTimeZoneRule Class | Aspose.Email.Outlook Namespace


Year Property

Aspose.Email

MapiCalendarTimeZoneRule.Year Property

Gets or sets the year

public ushort Year {get; set;}

See Also

MapiCalendarTimeZoneRule Class | Aspose.Email.Outlook Namespace


MapiCalendarWeeklyRecurrencePattern Class

Represents the weekly recurrence pattern of the mapi calendar

For a list of all members of this type, see MapiCalendarWeeklyRecurrencePattern Members.

System.Object
Aspose.Email.Outlook.MapiCalendarRecurrencePattern
Aspose.Email.Outlook.MapiCalendarWeeklyRecurrencePattern

public sealed class MapiCalendarWeeklyRecurrencePattern : MapiCalendarRecurrencePattern

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiCalendarWeeklyRecurrencePattern Members | Aspose.Email.Outlook Namespace


MapiCalendarWeeklyRecurrencePattern Members

MapiCalendarWeeklyRecurrencePattern overview

Public Instance Constructors

MapiCalendarWeeklyRecurrencePattern Constructor Initializes a new instance of the MapiCalendarWeeklyRecurrencePattern class

Public Instance Properties

CalendarType (inherited from MapiCalendarRecurrencePattern) | Gets or sets the type of calendar that is used
DayOfWeek | Gets or sets the days of week at which the event occurs
EndType (inherited from MapiCalendarRecurrencePattern) | Gets or sets the ending type for the recurrence.
Frequency (inherited from MapiCalendarRecurrencePattern) | Gets or sets the frequency of the recurring series.
OccurrenceCount (inherited from MapiCalendarRecurrencePattern) | Gets or sets the number of occurrences in a recurrence.
PatternType (inherited from MapiCalendarRecurrencePattern) | Gets or sets the type of recurrence pattern
Period | Gets or sets interval (in weeks) at which the meeting pattern repeats
WeekStartDay (inherited from MapiCalendarRecurrencePattern) | Gets or sets the first day of the calendar week.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MapiCalendarWeeklyRecurrencePattern Class | Aspose.Email.Outlook Namespace


MapiCalendarWeeklyRecurrencePattern Constructor

Initializes a new instance of the MapiCalendarWeeklyRecurrencePattern class

public MapiCalendarWeeklyRecurrencePattern();

See Also

MapiCalendarWeeklyRecurrencePattern Class | Aspose.Email.Outlook Namespace


MapiCalendarWeeklyRecurrencePattern Properties

The properties of the MapiCalendarWeeklyRecurrencePattern class are listed below. For a complete list of MapiCalendarWeeklyRecurrencePattern class members, see the MapiCalendarWeeklyRecurrencePattern Members topic.

Public Instance Properties

CalendarType (inherited from MapiCalendarRecurrencePattern) | Gets or sets the type of calendar that is used
DayOfWeek | Gets or sets the days of week at which the event occurs
EndType (inherited from MapiCalendarRecurrencePattern) | Gets or sets the ending type for the recurrence.
Frequency (inherited from MapiCalendarRecurrencePattern) | Gets or sets the frequency of the recurring series.
OccurrenceCount (inherited from MapiCalendarRecurrencePattern) | Gets or sets the number of occurrences in a recurrence.
PatternType (inherited from MapiCalendarRecurrencePattern) | Gets or sets the type of recurrence pattern
Period | Gets or sets interval (in weeks) at which the meeting pattern repeats
WeekStartDay (inherited from MapiCalendarRecurrencePattern) | Gets or sets the first day of the calendar week.

See Also

MapiCalendarWeeklyRecurrencePattern Class | Aspose.Email.Outlook Namespace


DayOfWeek Property

Aspose.Email

MapiCalendarWeeklyRecurrencePattern.DayOfWeek Property

Gets or sets the days of week at which the event occurs

public MapiCalendarDayOfWeek DayOfWeek {get; set;}

See Also

MapiCalendarWeeklyRecurrencePattern Class | Aspose.Email.Outlook Namespace


Period Property

Aspose.Email

MapiCalendarWeeklyRecurrencePattern.Period Property

Gets or sets interval (in weeks) at which the meeting pattern repeats

public override uint Period {get; set;}

See Also

MapiCalendarWeeklyRecurrencePattern Class | Aspose.Email.Outlook Namespace


MapiContact Class

Represents outlook contact information

For a list of all members of this type, see MapiContact Members.

System.Object
Aspose.Email.Outlook.MapiContact

public sealed class MapiContact : IMapiMessageItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiContact Members | Aspose.Email.Outlook Namespace


MapiContact Members

MapiContact overview

Public Static Methods

FromVCard Overloaded. Reads MapiContact from the specified vCard file The supported vCard versions are 2.1 and 3.0

Public Static Type Conversions

Implicit MapiContact to ContactItemType Conversion Obsolete. Performs an implicit conversion from MapiContact to ContactItemType.

Public Instance Constructors

MapiContact Overloaded. Initializes a new instance of the MapiContact class.

Public Instance Properties

Attachments | Gets the attachments in the contact.
Body | Gets message body
ElectronicAddresses | Specify properties for up to three different e-mail addresses and three different fax addresses
Events | Specify events associated with a contact
MessageClass | Gets message class
NameInfo | The properties are used to specify the name of the person represented by the contact
PersonalInfo | Specify other additional contact information
Photo | Contains contact photoMapiContactPhoto.
PhysicalAddresses | Specify three physical addresses: Home Address, Work Address, and Other Address. One of the addresses can be marked as the Mailing Address
ProfessionalInfo | Properties are used to store professional details for the person represented by the contact
Subject | Gets message subject
Telephones | Specify telephone numbers for the contact

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetUnderlyingMessage | Get the MapiMessage that represent contact.
Save | Overloaded. Saves this MapiContact to the vCard file with a default options. The supported vCard version is 2.1
ToContactItemType | Obsolete. Converts MapiContact to a ContactItemType object.
ToString (inherited from Object) | Returns a String that represents the current Object.
ToWebDavStream | Saves the MapiContact to a WebDav data stream.

See Also

MapiContact Class | Aspose.Email.Outlook Namespace


MapiContact Constructor

Initializes a new instance of the MapiContact class

Overload List

Initializes a new instance of the MapiContact class

public MapiContact();

Initializes a new instance of the MapiContact class.

public MapiContact(string,string);

Initializes a new instance of the MapiContact class.

public MapiContact(string,string,string);

Initializes a new instance of the MapiContact class.

public MapiContact(string,string,string,string);

See Also

MapiContact Class | Aspose.Email.Outlook Namespace


MapiContact Constructor ()

Initializes a new instance of the MapiContact class

public MapiContact();

See Also

MapiContact Class | Aspose.Email.Outlook Namespace | MapiContact Constructor Overload List


MapiContact Constructor (String, String)

Initializes a new instance of the MapiContact class.

public MapiContact(
string displayName,
string electonicAddress
);

Parameters

displayName
The display name.
electonicAddress
The electonic address.

See Also

MapiContact Class | Aspose.Email.Outlook Namespace | MapiContact Constructor Overload List


MapiContact Constructor (String, String, String)

Initializes a new instance of the MapiContact class.

public MapiContact(
string displayName,
string electonicAddress,
string companyName
);

Parameters

displayName
The display name.
electonicAddress
The electonic address.
companyName
Name of the company.

See Also

MapiContact Class | Aspose.Email.Outlook Namespace | MapiContact Constructor Overload List


MapiContact Constructor (String, String, String, String)

Initializes a new instance of the MapiContact class.

public MapiContact(
string displayName,
string electonicAddress,
string companyName,
string primaryTelephoneNumber
);

Parameters

displayName
The display name.
electonicAddress
The electonic address.
companyName
Name of the company.
primaryTelephoneNumber
The telephone number.

See Also

MapiContact Class | Aspose.Email.Outlook Namespace | MapiContact Constructor Overload List


MapiContact Properties

The properties of the MapiContact class are listed below. For a complete list of MapiContact class members, see the MapiContact Members topic.

Public Instance Properties

Attachments | Gets the attachments in the contact.
Body | Gets message body
ElectronicAddresses | Specify properties for up to three different e-mail addresses and three different fax addresses
Events | Specify events associated with a contact
MessageClass | Gets message class
NameInfo | The properties are used to specify the name of the person represented by the contact
PersonalInfo | Specify other additional contact information
Photo | Contains contact photoMapiContactPhoto.
PhysicalAddresses | Specify three physical addresses: Home Address, Work Address, and Other Address. One of the addresses can be marked as the Mailing Address
ProfessionalInfo | Properties are used to store professional details for the person represented by the contact
Subject | Gets message subject
Telephones | Specify telephone numbers for the contact

See Also

MapiContact Class | Aspose.Email.Outlook Namespace


Attachments Property

Aspose.Email

MapiContact.Attachments Property

Gets the attachments in the contact.

public MapiAttachmentCollection Attachments {get;}

Property Value

The attachment collection.

See Also

MapiContact Class | Aspose.Email.Outlook Namespace


Body Property

Aspose.Email

MapiContact.Body Property

Gets message body

public string Body {get; set;}

Property Value

Implements

IMapiMessageItem.Body

See Also

MapiContact Class | Aspose.Email.Outlook Namespace


ElectronicAddresses Property

Aspose.Email

MapiContact.ElectronicAddresses Property

Specify properties for up to three different e-mail addresses and three different fax addresses

public MapiContactElectronicAddressPropertySet ElectronicAddresses {get; set;}

See Also

MapiContact Class | Aspose.Email.Outlook Namespace


Events Property

Aspose.Email

MapiContact.Events Property

Specify events associated with a contact

public MapiContactEventPropertySet Events {get; set;}

See Also

MapiContact Class | Aspose.Email.Outlook Namespace


MessageClass Property

Aspose.Email

MapiContact.MessageClass Property

Gets message class

public string MessageClass {get;}

Property Value

String that represents message class

Implements

IMapiMessageItem.MessageClass

See Also

MapiContact Class | Aspose.Email.Outlook Namespace


NameInfo Property

Aspose.Email

MapiContact.NameInfo Property

The properties are used to specify the name of the person represented by the contact

public MapiContactNamePropertySet NameInfo {get; set;}

See Also

MapiContact Class | Aspose.Email.Outlook Namespace


PersonalInfo Property

Aspose.Email

MapiContact.PersonalInfo Property

Specify other additional contact information

public MapiContactPersonalInfoPropertySet PersonalInfo {get; set;}

See Also

MapiContact Class | Aspose.Email.Outlook Namespace


Photo Property

Aspose.Email

MapiContact.Photo Property

Contains contact photoMapiContactPhoto.

public MapiContactPhoto Photo {get; set;}

See Also

MapiContact Class | Aspose.Email.Outlook Namespace


PhysicalAddresses Property

Aspose.Email

MapiContact.PhysicalAddresses Property

Specify three physical addresses: Home Address, Work Address, and Other Address. One of the addresses can be marked as the Mailing Address

public MapiContactPhysicalAddressPropertySet PhysicalAddresses {get; set;}

See Also

MapiContact Class | Aspose.Email.Outlook Namespace


ProfessionalInfo Property

Aspose.Email

MapiContact.ProfessionalInfo Property

Properties are used to store professional details for the person represented by the contact

public MapiContactProfessionalPropertySet ProfessionalInfo {get; set;}

See Also

MapiContact Class | Aspose.Email.Outlook Namespace


Subject Property

Aspose.Email

MapiContact.Subject Property

Gets message subject

public string Subject {get; set;}

Property Value

Implements

IMapiMessageItem.Subject

See Also

MapiContact Class | Aspose.Email.Outlook Namespace


Telephones Property

Aspose.Email

MapiContact.Telephones Property

Specify telephone numbers for the contact

public MapiContactTelephonePropertySet Telephones {get; set;}

See Also

MapiContact Class | Aspose.Email.Outlook Namespace


MapiContact Methods

The methods of the MapiContact class are listed below. For a complete list of MapiContact class members, see the MapiContact Members topic.

Public Static Methods

FromVCard Overloaded. Reads MapiContact from the specified vCard file The supported vCard versions are 2.1 and 3.0

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
GetUnderlyingMessage | Get the MapiMessage that represent contact.
Save | Overloaded. Saves this MapiContact to the vCard file with a default options. The supported vCard version is 2.1
ToContactItemType | Obsolete. Converts MapiContact to a ContactItemType object.
ToString (inherited from Object) | Returns a String that represents the current Object.
ToWebDavStream | Saves the MapiContact to a WebDav data stream.

See Also

MapiContact Class | Aspose.Email.Outlook Namespace


FromVCard Method

Aspose.Email

MapiContact.FromVCard Method

Reads MapiContact from the specified stream containing vCard. The supported vCard versions are 2.1 and 3.0

Overload List

Reads MapiContact from the specified stream containing vCard. The supported vCard versions are 2.1 and 3.0

public static MapiContact FromVCard(Stream);

Reads MapiContact from the specified stream containing vCard. The supported vCard versions are 2.1 and 3.0

public static MapiContact FromVCard(Stream,Encoding);

Reads MapiContact from the specified vCard file The supported vCard versions are 2.1 and 3.0

public static MapiContact FromVCard(string);

See Also

MapiContact Class | Aspose.Email.Outlook Namespace


MapiContact.FromVCard Method (Stream)

Reads MapiContact from the specified stream containing vCard. The supported vCard versions are 2.1 and 3.0

public static MapiContact FromVCard(
Stream stream
);

Parameters

stream
A stream to read from

Return Value

A read MapiContact

Exceptions

Exception Type | Condition
ArgumentNullException | stream is null
NotSupportedException | stream does not support reading

See Also

MapiContact Class | Aspose.Email.Outlook Namespace | MapiContact.FromVCard Overload List


MapiContact.FromVCard Method (Stream, Encoding)

Reads MapiContact from the specified stream containing vCard. The supported vCard versions are 2.1 and 3.0

public static MapiContact FromVCard(
Stream stream,
Encoding encoding
);

Parameters

stream
A stream to read from
encoding
Stream data encoding

Return Value

A read MapiContact

Exceptions

Exception Type | Condition
ArgumentNullException | stream is null
NotSupportedException | stream does not support reading

See Also

MapiContact Class | Aspose.Email.Outlook Namespace | MapiContact.FromVCard Overload List


MapiContact.FromVCard Method (String)

Reads MapiContact from the specified vCard file The supported vCard versions are 2.1 and 3.0

public static MapiContact FromVCard(
string filePath
);

Parameters

filePath
A file name to read from

Return Value

A read MapiContact

Exceptions

Exception Type | Condition
ArgumentException | filePath is null or empty

See Also

MapiContact Class | Aspose.Email.Outlook Namespace | MapiContact.FromVCard Overload List


MapiContact.GetUnderlyingMessage Method

Get the MapiMessage that represent contact.

public MapiMessage GetUnderlyingMessage();

Return Value

The MapiMessage object.

See Also

MapiContact Class | Aspose.Email.Outlook Namespace


Save Method

Aspose.Email

MapiContact.Save Method

Saves this MapiContact into the given stream with vCard format. The supported vCard version is 2.1

Overload List

Saves this MapiContact into the given stream with vCard format. The supported vCard version is 2.1

public void Save(Stream);

Saves this MapiContact to the given stream with a format using the default options. The supported save format is vCard

public void Save(Stream,ContactSaveFormat);

Saves this MapiContact to the given stream using specified save options. The supported save options is VCardSaveOptions

public void Save(Stream,ContactSaveOptions);

Saves this MapiContact to the vCard file with a default options. The supported vCard version is 2.1

public void Save(string);

Saves this MapiContact to the specified file with a format using the default options. The supported save format is vCard.

public void Save(string,ContactSaveFormat);

Saves this MapiContact into file using specified save options. The supported save options is VCardSaveOptions

public void Save(string,ContactSaveOptions);

See Also

MapiContact Class | Aspose.Email.Outlook Namespace


MapiContact.Save Method (Stream)

Saves this MapiContact into the given stream with vCard format. The supported vCard version is 2.1

public void Save(
Stream stream
);

Parameters

stream
A stream to save to

Exceptions

Exception Type | Condition
ArgumentNullException | stream is null
NotSupportedException | stream does not support writing

See Also

MapiContact Class | Aspose.Email.Outlook Namespace | MapiContact.Save Overload List


MapiContact.Save Method (Stream, ContactSaveFormat)

Saves this MapiContact to the given stream with a format using the default options. The supported save format is vCard

public void Save(
Stream stream,
ContactSaveFormat saveFormat
);

Parameters

stream
A stream to save to
saveFormat
A save format

Exceptions

Exception Type | Condition
ArgumentNullException | stream is null
NotSupportedException | stream does not support writing
NotSupportedException | The specified format is not supported

See Also

MapiContact Class | Aspose.Email.Outlook Namespace | MapiContact.Save Overload List


MapiContact.Save Method (Stream, ContactSaveOptions)

Saves this MapiContact to the given stream using specified save options. The supported save options is VCardSaveOptions

public void Save(
Stream stream,
ContactSaveOptions saveOptions
);

Parameters

stream
A stream to save to
saveOptions
A save options

Exceptions

Exception Type | Condition
ArgumentNullException | stream or saveOptions is null
NotSupportedException | stream does not support writing
ArgumentException | incorrect saveOptions
NotSupportedException | some save option is not supported

See Also

MapiContact Class | Aspose.Email.Outlook Namespace | MapiContact.Save Overload List


MapiContact.Save Method (String)

Saves this MapiContact to the vCard file with a default options. The supported vCard version is 2.1

public void Save(
string filePath
);

Parameters

filePath
A vCard file name

Exceptions

Exception Type | Condition
ArgumentException | filePath is null or empty

See Also

MapiContact Class | Aspose.Email.Outlook Namespace | MapiContact.Save Overload List


MapiContact.Save Method (String, ContactSaveFormat)

Saves this MapiContact to the specified file with a format using the default options. The supported save format is vCard.

public void Save(
string filePath,
ContactSaveFormat saveFormat
);

Parameters

filePath
A vCard file name
saveFormat
A save format

Exceptions

Exception Type | Condition
ArgumentException | filePath is null or empty
NotSupportedException | the specified format is not supported

See Also

MapiContact Class | Aspose.Email.Outlook Namespace | MapiContact.Save Overload List


MapiContact.Save Method (String, ContactSaveOptions)

Saves this MapiContact into file using specified save options. The supported save options is VCardSaveOptions

public void Save(
string filePath,
ContactSaveOptions saveOptions
);

Parameters

filePath
A vCard file name
saveOptions
A save options

Exceptions

Exception Type | Condition
ArgumentException | filePath is null or empty
ArgumentNullException | saveOptions is null
NotSupportedException | some save option is not supported

See Also

MapiContact Class | Aspose.Email.Outlook Namespace | MapiContact.Save Overload List


MapiContact.ToContactItemType Method

NOTE: This method is now obsolete.

Converts MapiContact to a ContactItemType object.

public ContactItemType ToContactItemType();

Return Value

The ContactItemType object.

See Also

MapiContact Class | Aspose.Email.Outlook Namespace


MapiContact.ToWebDavStream Method

Saves the MapiContact to a WebDav data stream.

public MemoryStream ToWebDavStream();

Return Value

The MemoryStream that represents a WebDav data.

See Also

MapiContact Class | Aspose.Email.Outlook Namespace


MapiContact Type Conversions

The type conversions of the MapiContact class are listed below. For a complete list of MapiContact class members, see the MapiContact Members topic.

Public Static Type Conversions

Implicit MapiContact to ContactItemType Conversion Obsolete. Performs an implicit conversion from MapiContact to ContactItemType.

See Also

MapiContact Class | MapiContact Members | Aspose.Email.Outlook Namespace


MapiContact Implicit MapiContact to ContactItemType Conversion

NOTE: This operator is now obsolete.

Performs an implicit conversion from MapiContact to ContactItemType.

public static implicit operator ContactItemType(
MapiContact сontact
);

Parameters

сontact
The сontact.

Return Value

The result of the conversion.

See Also

MapiContact Class | Aspose.Email.Outlook Namespace


MapiContactCollection Class

Represents the collection of MapiContact

For a list of all members of this type, see MapiContactCollection Members.

System.Object
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Outlook.MapiContact, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]]
Aspose.Email.Outlook.MapiContactCollection

public sealed class MapiContactCollection : Collection`1

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiContactCollection Members | Aspose.Email.Outlook Namespace


MapiContactCollection Members

MapiContactCollection overview

Public Instance Constructors

MapiContactCollection Constructor Initializes a new instance of the MapiContactCollection class.

Public Instance Properties

Count (inherited from 0, Culture=neutral, PublicKeyToken=null]])
Item (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MapiContactCollection Class | Aspose.Email.Outlook Namespace


MapiContactCollection Constructor

Initializes a new instance of the MapiContactCollection class.

public MapiContactCollection();

See Also

MapiContactCollection Class | Aspose.Email.Outlook Namespace


MapiContactElectronicAddress Class

Refers to the group of properties that define the e-mail address or fax address for a contact.

For a list of all members of this type, see MapiContactElectronicAddress Members.

System.Object
Aspose.Email.Outlook.MapiContactElectronicAddress

public sealed class MapiContactElectronicAddress

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiContactElectronicAddress Members | Aspose.Email.Outlook Namespace


MapiContactElectronicAddress Members

MapiContactElectronicAddress overview

Public Static Type Conversions

Implicit String to MapiContactElectronicAddress Conversion Performs an implicit conversion from String to MapiContactElectronicAddress.

Public Instance Constructors

MapiContactElectronicAddress Overloaded. Initializes a new instance of the MapiContactElectronicAddress class.

Public Instance Properties

AddressType | Gets or sets the address type of an electronic address
DisplayName | Gets or sets the user-readable display name for the e-mail address
EmailAddress | Gets or sets the e-mail address of the contact
FaxNumber | Gets or sets the telephone number of the mail user's primary fax machine
IsEmpty | Shows if MapiContactElectronicAddress is empty
OriginalDisplayName | Gets or sets the SMTP e-mail address that corresponds to the e-mail address for the Contact object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MapiContactElectronicAddress Class | Aspose.Email.Outlook Namespace


MapiContactElectronicAddress Constructor

Initializes a new instance of the MapiContactElectronicAddress class.

Overload List

Initializes a new instance of the MapiContactElectronicAddress class.

public MapiContactElectronicAddress();

Initializes a new instance of the MapiContactElectronicAddress class.

public MapiContactElectronicAddress(string);

Initializes a new instance of the MapiContactElectronicAddress class.

public MapiContactElectronicAddress(string,string);

Initializes a new instance of the MapiContactElectronicAddress class.

public MapiContactElectronicAddress(string,string,string);

See Also

MapiContactElectronicAddress Class | Aspose.Email.Outlook Namespace


MapiContactElectronicAddress Constructor ()

Initializes a new instance of the MapiContactElectronicAddress class.

public MapiContactElectronicAddress();

See Also

MapiContactElectronicAddress Class | Aspose.Email.Outlook Namespace | MapiContactElectronicAddress Constructor Overload List


MapiContactElectronicAddress Constructor (String, String, String)

Initializes a new instance of the MapiContactElectronicAddress class.

public MapiContactElectronicAddress(
string displayName,
string addressType,
string emailAddress
);

Parameters

displayName
The display name.
addressType
Type of the address.
emailAddress
The email address.

See Also

MapiContactElectronicAddress Class | Aspose.Email.Outlook Namespace | MapiContactElectronicAddress Constructor Overload List


MapiContactElectronicAddress Constructor (String)

Initializes a new instance of the MapiContactElectronicAddress class.

public MapiContactElectronicAddress(
string emailAddress
);

Parameters

emailAddress
The email address.

See Also

MapiContactElectronicAddress Class | Aspose.Email.Outlook Namespace | MapiContactElectronicAddress Constructor Overload List


MapiContactElectronicAddress Constructor (String, String)

Initializes a new instance of the MapiContactElectronicAddress class.

public MapiContactElectronicAddress(
string faxNumber,
string emailAddress
);

Parameters

faxNumber
The fax number.
emailAddress
The email address.

See Also

MapiContactElectronicAddress Class | Aspose.Email.Outlook Namespace | MapiContactElectronicAddress Constructor Overload List


MapiContactElectronicAddress Properties

The properties of the MapiContactElectronicAddress class are listed below. For a complete list of MapiContactElectronicAddress class members, see the MapiContactElectronicAddress Members topic.

Public Instance Properties

AddressType | Gets or sets the address type of an electronic address
DisplayName | Gets or sets the user-readable display name for the e-mail address
EmailAddress | Gets or sets the e-mail address of the contact
FaxNumber | Gets or sets the telephone number of the mail user's primary fax machine
IsEmpty | Shows if MapiContactElectronicAddress is empty
OriginalDisplayName | Gets or sets the SMTP e-mail address that corresponds to the e-mail address for the Contact object.

See Also

MapiContactElectronicAddress Class | Aspose.Email.Outlook Namespace


AddressType Property

Aspose.Email

MapiContactElectronicAddress.AddressType Property

Gets or sets the address type of an electronic address

public string AddressType {get; set;}

See Also

MapiContactElectronicAddress Class | Aspose.Email.Outlook Namespace


DisplayName Property

Aspose.Email

MapiContactElectronicAddress.DisplayName Property

Gets or sets the user-readable display name for the e-mail address

public string DisplayName {get; set;}

See Also

MapiContactElectronicAddress Class | Aspose.Email.Outlook Namespace


EmailAddress Property

Aspose.Email

MapiContactElectronicAddress.EmailAddress Property

Gets or sets the e-mail address of the contact

public string EmailAddress {get; set;}

See Also

MapiContactElectronicAddress Class | Aspose.Email.Outlook Namespace


FaxNumber Property

Aspose.Email

MapiContactElectronicAddress.FaxNumber Property

Gets or sets the telephone number of the mail user's primary fax machine

public string FaxNumber {get; set;}

See Also

MapiContactElectronicAddress Class | Aspose.Email.Outlook Namespace


IsEmpty Property

Aspose.Email

MapiContactElectronicAddress.IsEmpty Property

Shows if MapiContactElectronicAddress is empty

public bool IsEmpty {get;}

See Also

MapiContactElectronicAddress Class | Aspose.Email.Outlook Namespace


OriginalDisplayName Property

Aspose.Email

MapiContactElectronicAddress.OriginalDisplayName Property

Gets or sets the SMTP e-mail address that corresponds to the e-mail address for the Contact object.

public string OriginalDisplayName {get; set;}

Property Value

The the SMTP e-mail address.

See Also

MapiContactElectronicAddress Class | Aspose.Email.Outlook Namespace


MapiContactElectronicAddress Type Conversions

The type conversions of the MapiContactElectronicAddress class are listed below. For a complete list of MapiContactElectronicAddress class members, see the MapiContactElectronicAddress Members topic.

Public Static Type Conversions

Implicit String to MapiContactElectronicAddress Conversion Performs an implicit conversion from String to MapiContactElectronicAddress.

See Also

MapiContactElectronicAddress Class | MapiContactElectronicAddress Members | Aspose.Email.Outlook Namespace


MapiContactElectronicAddress Implicit String to MapiContactElectronicAddress Conversion

Performs an implicit conversion from String to MapiContactElectronicAddress.

public static implicit operator MapiContactElectronicAddress(
string emailAddress
);

Parameters

emailAddress
The email address.

Return Value

The result of the conversion.

See Also

MapiContactElectronicAddress Class | Aspose.Email.Outlook Namespace


MapiContactElectronicAddressPropertySet Class

Specify properties for up to three different e-mail addresses (Email1, Email2, and Email3) and three different fax addresses (Primary Fax, Business Fax, and Home Fax)

For a list of all members of this type, see MapiContactElectronicAddressPropertySet Members.

System.Object
Aspose.Email.Outlook.MapiContactElectronicAddressPropertySet

public sealed class MapiContactElectronicAddressPropertySet

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiContactElectronicAddressPropertySet Members | Aspose.Email.Outlook Namespace


MapiContactElectronicAddressPropertySet Members

MapiContactElectronicAddressPropertySet overview

Public Instance Constructors

MapiContactElectronicAddressPropertySet Overloaded. Initializes a new instance of the MapiContactElectronicAddressPropertySet class.

Public Instance Properties

BusinessFax | Refers to the group of properties that define the business fax address for a contact.
DefaultEmailAddress | Default value of electronic address Uses when user does not set any electronic address if UseAutocomplete property is set 'true'
Email1 | Refers to the group of properties that define the first e-mail address for a contact.
Email2 | Refers to the group of properties that define the second e-mail address for a contact.
Email3 | Refers to the group of properties that define the third e-mail address for a contact.
HomeFax | Refers to the group of properties that define the home fax address for a contact.
IsEmpty | Shows if MapiContactElectronicAddressPropertySet is empty
PrimaryFax | Refers to the group of properties that define the primary fax address for a contact.
UseAutocomplete | Indicates that one electronic address is completed automatically in case if user does not set any electronic address

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MapiContactElectronicAddressPropertySet Class | Aspose.Email.Outlook Namespace


MapiContactElectronicAddressPropertySet Constructor

Initializes a new instance of the MapiContactElectronicAddressPropertySet class

Overload List

Initializes a new instance of the MapiContactElectronicAddressPropertySet class

public MapiContactElectronicAddressPropertySet();

Initializes a new instance of the MapiContactElectronicAddressPropertySet class

public MapiContactElectronicAddressPropertySet(MapiPropertyCollection);

See Also

MapiContactElectronicAddressPropertySet Class | Aspose.Email.Outlook Namespace


MapiContactElectronicAddressPropertySet Constructor ()

Initializes a new instance of the MapiContactElectronicAddressPropertySet class

public MapiContactElectronicAddressPropertySet();

See Also

MapiContactElectronicAddressPropertySet Class | Aspose.Email.Outlook Namespace | MapiContactElectronicAddressPropertySet Constructor Overload List


MapiContactElectronicAddressPropertySet Constructor (MapiPropertyCollection)

Initializes a new instance of the MapiContactElectronicAddressPropertySet class

public MapiContactElectronicAddressPropertySet(
MapiPropertyCollection properties
);

Parameters

properties
A MapiPropertyCollection containing contact e-mail addresses properties

See Also

MapiContactElectronicAddressPropertySet Class | Aspose.Email.Outlook Namespace | MapiContactElectronicAddressPropertySet Constructor Overload List


MapiContactElectronicAddressPropertySet Properties

The properties of the MapiContactElectronicAddressPropertySet class are listed below. For a complete list of MapiContactElectronicAddressPropertySet class members, see the MapiContactElectronicAddressPropertySet Members topic.

Public Instance Properties

BusinessFax | Refers to the group of properties that define the business fax address for a contact.
DefaultEmailAddress | Default value of electronic address Uses when user does not set any electronic address if UseAutocomplete property is set 'true'
Email1 | Refers to the group of properties that define the first e-mail address for a contact.
Email2 | Refers to the group of properties that define the second e-mail address for a contact.
Email3 | Refers to the group of properties that define the third e-mail address for a contact.
HomeFax | Refers to the group of properties that define the home fax address for a contact.
IsEmpty | Shows if MapiContactElectronicAddressPropertySet is empty
PrimaryFax | Refers to the group of properties that define the primary fax address for a contact.
UseAutocomplete | Indicates that one electronic address is completed automatically in case if user does not set any electronic address

See Also

MapiContactElectronicAddressPropertySet Class | Aspose.Email.Outlook Namespace


BusinessFax Property

Aspose.Email

MapiContactElectronicAddressPropertySet.BusinessFax Property

Refers to the group of properties that define the business fax address for a contact.

public MapiContactElectronicAddress BusinessFax {get; set;}

See Also

MapiContactElectronicAddressPropertySet Class | Aspose.Email.Outlook Namespace


DefaultEmailAddress Property

Aspose.Email

MapiContactElectronicAddressPropertySet.DefaultEmailAddress Property

Default value of electronic address Uses when user does not set any electronic address if UseAutocomplete property is set 'true'

public MapiContactElectronicAddress DefaultEmailAddress {get; set;}

See Also

MapiContactElectronicAddressPropertySet Class | Aspose.Email.Outlook Namespace


Email1 Property

Aspose.Email

MapiContactElectronicAddressPropertySet.Email1 Property

Refers to the group of properties that define the first e-mail address for a contact.

public MapiContactElectronicAddress Email1 {get; set;}

See Also

MapiContactElectronicAddressPropertySet Class | Aspose.Email.Outlook Namespace


Email2 Property

Aspose.Email

MapiContactElectronicAddressPropertySet.Email2 Property

Refers to the group of properties that define the second e-mail address for a contact.

public MapiContactElectronicAddress Email2 {get; set;}

See Also

MapiContactElectronicAddressPropertySet Class | Aspose.Email.Outlook Namespace


Email3 Property

Aspose.Email

MapiContactElectronicAddressPropertySet.Email3 Property

Refers to the group of properties that define the third e-mail address for a contact.

public MapiContactElectronicAddress Email3 {get; set;}

See Also

MapiContactElectronicAddressPropertySet Class | Aspose.Email.Outlook Namespace


HomeFax Property

Aspose.Email

MapiContactElectronicAddressPropertySet.HomeFax Property

Refers to the group of properties that define the home fax address for a contact.

public MapiContactElectronicAddress HomeFax {get; set;}

See Also

MapiContactElectronicAddressPropertySet Class | Aspose.Email.Outlook Namespace


IsEmpty Property

Aspose.Email

MapiContactElectronicAddressPropertySet.IsEmpty Property

Shows if MapiContactElectronicAddressPropertySet is empty

public bool IsEmpty {get;}

See Also

MapiContactElectronicAddressPropertySet Class | Aspose.Email.Outlook Namespace


PrimaryFax Property

Aspose.Email

MapiContactElectronicAddressPropertySet.PrimaryFax Property

Refers to the group of properties that define the primary fax address for a contact.

public MapiContactElectronicAddress PrimaryFax {get; set;}

See Also

MapiContactElectronicAddressPropertySet Class | Aspose.Email.Outlook Namespace


UseAutocomplete Property

Aspose.Email

MapiContactElectronicAddressPropertySet.UseAutocomplete Property

Indicates that one electronic address is completed automatically in case if user does not set any electronic address

public bool UseAutocomplete {get; set;}

See Also

MapiContactElectronicAddressPropertySet Class | Aspose.Email.Outlook Namespace


MapiContactEventPropertySet Class

Specify events associated with a contact

For a list of all members of this type, see MapiContactEventPropertySet Members.

System.Object
Aspose.Email.Outlook.MapiContactEventPropertySet

public sealed class MapiContactEventPropertySet

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiContactEventPropertySet Members | Aspose.Email.Outlook Namespace


MapiContactEventPropertySet Members

MapiContactEventPropertySet overview

Public Instance Constructors

MapiContactEventPropertySet Overloaded. Initializes a new instance of the MapiContactEventPropertySet class.

Public Instance Properties

Birthday | Specifies the birthday of the contact
WeddingAnniversary | Specifies the wedding anniversary of the contact

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MapiContactEventPropertySet Class | Aspose.Email.Outlook Namespace


MapiContactEventPropertySet Constructor

Initializes a new instance of the MapiContactEventPropertySet class

Overload List

Initializes a new instance of the MapiContactEventPropertySet class

public MapiContactEventPropertySet();

Initializes a new instance of the MapiContactEventPropertySet class

public MapiContactEventPropertySet(MapiPropertyCollection);

See Also

MapiContactEventPropertySet Class | Aspose.Email.Outlook Namespace


MapiContactEventPropertySet Constructor ()

Initializes a new instance of the MapiContactEventPropertySet class

public MapiContactEventPropertySet();

See Also

MapiContactEventPropertySet Class | Aspose.Email.Outlook Namespace | MapiContactEventPropertySet Constructor Overload List


MapiContactEventPropertySet Constructor (MapiPropertyCollection)

Initializes a new instance of the MapiContactEventPropertySet class

public MapiContactEventPropertySet(
MapiPropertyCollection properties
);

Parameters

properties
A MapiPropertyCollection containing contact events properties

See Also

MapiContactEventPropertySet Class | Aspose.Email.Outlook Namespace | MapiContactEventPropertySet Constructor Overload List


MapiContactEventPropertySet Properties

The properties of the MapiContactEventPropertySet class are listed below. For a complete list of MapiContactEventPropertySet class members, see the MapiContactEventPropertySet Members topic.

Public Instance Properties

Birthday | Specifies the birthday of the contact
WeddingAnniversary | Specifies the wedding anniversary of the contact

See Also

MapiContactEventPropertySet Class | Aspose.Email.Outlook Namespace


Birthday Property

Aspose.Email

MapiContactEventPropertySet.Birthday Property

Specifies the birthday of the contact

public DateTime Birthday {get; set;}

See Also

MapiContactEventPropertySet Class | Aspose.Email.Outlook Namespace


WeddingAnniversary Property

Aspose.Email

MapiContactEventPropertySet.WeddingAnniversary Property

Specifies the wedding anniversary of the contact

public DateTime WeddingAnniversary {get; set;}

See Also

MapiContactEventPropertySet Class | Aspose.Email.Outlook Namespace


MapiContactGender Enumeration

Gender of the contact

public enum MapiContactGender

Members

Member Name | Description | Value
Unspecified | The gender is not specified. | 0
Female | The value that indicates that the gender is female. | 1
Male | The value that indicates that the gender is male. | 2

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Outlook Namespace


MapiContactNamePropertySet Class

The properties are used to specify the name of the person represented by the contact

For a list of all members of this type, see MapiContactNamePropertySet Members.

System.Object
Aspose.Email.Outlook.MapiContactNamePropertySet

public sealed class MapiContactNamePropertySet

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiContactNamePropertySet Members | Aspose.Email.Outlook Namespace


MapiContactNamePropertySet Members

MapiContactNamePropertySet overview

Public Instance Constructors

MapiContactNamePropertySet Overloaded. Initializes a new instance of the MapiContactNamePropertySet class.

Public Instance Properties

DisplayName | Gets or sets the full name of the contact
DisplayNamePrefix | Gets or sets the title of the contact
FileUnder | Gets or sets the name under which to file this contact when displaying a list of contacts
FileUnderID | Gets or sets a value specifying how to generate and recompute the property when other properties are changed
Generation | Gets or sets the generation suffix of the contact
GivenName | Gets or sets the given name (first name) of the contact
Initials | Gets or sets the initials of the contact
MiddleName | Gets or sets the middle name of the contact
Nickname | Gets or sets the nickname of the contact
Surname | Gets or sets the surname (family name) of the contact

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MapiContactNamePropertySet Class | Aspose.Email.Outlook Namespace


MapiContactNamePropertySet Constructor

Initializes a new instance of MapiContactNamePropertySet class

Overload List

Initializes a new instance of MapiContactNamePropertySet class

public MapiContactNamePropertySet();

Initializes a new instance of MapiContactNamePropertySet class.

public MapiContactNamePropertySet(string,string,string);

See Also

MapiContactNamePropertySet Class | Aspose.Email.Outlook Namespace


MapiContactNamePropertySet Constructor ()

Initializes a new instance of MapiContactNamePropertySet class

public MapiContactNamePropertySet();

See Also

MapiContactNamePropertySet Class | Aspose.Email.Outlook Namespace | MapiContactNamePropertySet Constructor Overload List


MapiContactNamePropertySet Constructor (String, String, String)

Initializes a new instance of MapiContactNamePropertySet class.

public MapiContactNamePropertySet(
string givenName,
string middleName,
string surname
);

Parameters

givenName
The string that represents a given name.
middleName
The string that represents a middle name.
surname
The string that represents a surname.

See Also

MapiContactNamePropertySet Class | Aspose.Email.Outlook Namespace | MapiContactNamePropertySet Constructor Overload List


MapiContactNamePropertySet Properties

The properties of the MapiContactNamePropertySet class are listed below. For a complete list of MapiContactNamePropertySet class members, see the MapiContactNamePropertySet Members topic.

Public Instance Properties

DisplayName | Gets or sets the full name of the contact
DisplayNamePrefix | Gets or sets the title of the contact
FileUnder | Gets or sets the name under which to file this contact when displaying a list of contacts
FileUnderID | Gets or sets a value specifying how to generate and recompute the property when other properties are changed
Generation | Gets or sets the generation suffix of the contact
GivenName | Gets or sets the given name (first name) of the contact
Initials | Gets or sets the initials of the contact
MiddleName | Gets or sets the middle name of the contact
Nickname | Gets or sets the nickname of the contact
Surname | Gets or sets the surname (family name) of the contact

See Also

MapiContactNamePropertySet Class | Aspose.Email.Outlook Namespace


DisplayName Property

Aspose.Email

MapiContactNamePropertySet.DisplayName Property

Gets or sets the full name of the contact

public string DisplayName {get; set;}

See Also

MapiContactNamePropertySet Class | Aspose.Email.Outlook Namespace


DisplayNamePrefix Property

Aspose.Email

MapiContactNamePropertySet.DisplayNamePrefix Property

Gets or sets the title of the contact

public string DisplayNamePrefix {get; set;}

See Also

MapiContactNamePropertySet Class | Aspose.Email.Outlook Namespace


FileUnder Property

Aspose.Email

MapiContactNamePropertySet.FileUnder Property

Gets or sets the name under which to file this contact when displaying a list of contacts

public string FileUnder {get; set;}

See Also

MapiContactNamePropertySet Class | Aspose.Email.Outlook Namespace


FileUnderID Property

Aspose.Email

MapiContactNamePropertySet.FileUnderID Property

Gets or sets a value specifying how to generate and recompute the property when other properties are changed

public uint FileUnderID {get; set;}

See Also

MapiContactNamePropertySet Class | Aspose.Email.Outlook Namespace | FileUnder


Generation Property

Aspose.Email

MapiContactNamePropertySet.Generation Property

Gets or sets the generation suffix of the contact

public string Generation {get; set;}

See Also

MapiContactNamePropertySet Class | Aspose.Email.Outlook Namespace


GivenName Property

Aspose.Email

MapiContactNamePropertySet.GivenName Property

Gets or sets the given name (first name) of the contact

public string GivenName {get; set;}

See Also

MapiContactNamePropertySet Class | Aspose.Email.Outlook Namespace


Initials Property

Aspose.Email

MapiContactNamePropertySet.Initials Property

Gets or sets the initials of the contact

public string Initials {get; set;}

See Also

MapiContactNamePropertySet Class | Aspose.Email.Outlook Namespace


MiddleName Property

Aspose.Email

MapiContactNamePropertySet.MiddleName Property

Gets or sets the middle name of the contact

public string MiddleName {get; set;}

See Also

MapiContactNamePropertySet Class | Aspose.Email.Outlook Namespace


Nickname Property

Aspose.Email

MapiContactNamePropertySet.Nickname Property

Gets or sets the nickname of the contact

public string Nickname {get; set;}

See Also

MapiContactNamePropertySet Class | Aspose.Email.Outlook Namespace


Surname Property

Aspose.Email

MapiContactNamePropertySet.Surname Property

Gets or sets the surname (family name) of the contact

public string Surname {get; set;}

See Also

MapiContactNamePropertySet Class | Aspose.Email.Outlook Namespace


MapiContactPersonalInfoPropertySet Class

Specify other additional contact information

For a list of all members of this type, see MapiContactPersonalInfoPropertySet Members.

System.Object
Aspose.Email.Outlook.MapiContactPersonalInfoPropertySet

public sealed class MapiContactPersonalInfoPropertySet

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiContactPersonalInfoPropertySet Members | Aspose.Email.Outlook Namespace


MapiContactPersonalInfoPropertySet Members

MapiContactPersonalInfoPropertySet overview

Public Instance Constructors

MapiContactPersonalInfoPropertySet Overloaded. Initializes a new instance of the MapiContactPersonalInfoPropertySet class.

Public Instance Properties

Account | Specifies the account name of the contact
BusinessHomePage | Specifies the contact's business web page URL
ComputerNetworkName | Specifies the name of the network to which the contact's computer is connected
CustomerId | Specifies the contact's customer ID number
FreeBusyLocation | Specifies a URL path from which a client can retrieve free/busy information for the contact as an iCal file
FtpSite | Specifies the contact's File Transfer Protocol (FTP) URL
Gender | Specifies the gender of the contact
GovernmentIdNumber | Specifies the contact's government ID number
Hobbies | Specifies the hobbies of the contact
Html | Specifies the contact's business web page URL
InstantMessagingAddress | Specifies the contact's instant messaging address
Language | Specifies the language that the contact uses
Location | Specifies the location of the contact
Notes | Specifies the additional notes
OrganizationalIdNumber | Specifies an organizational ID number for the contact
PersonalHomePage | Specifies the contact's personal web page URL
ReferredByName | Specifies the name of the person who referred this contact to the user
SpouseName | Specifies the name of the contact's spouse/partner

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MapiContactPersonalInfoPropertySet Class | Aspose.Email.Outlook Namespace


MapiContactPersonalInfoPropertySet Constructor

Initializes a new instance of the MapiContactPersonalInfoPropertySet class

Overload List

Initializes a new instance of the MapiContactPersonalInfoPropertySet class

public MapiContactPersonalInfoPropertySet();

Initializes a new instance of the MapiContactPersonalInfoPropertySet class

public MapiContactPersonalInfoPropertySet(MapiPropertyCollection);

See Also

MapiContactPersonalInfoPropertySet Class | Aspose.Email.Outlook Namespace


MapiContactPersonalInfoPropertySet Constructor ()

Initializes a new instance of the MapiContactPersonalInfoPropertySet class

public MapiContactPersonalInfoPropertySet();

See Also

MapiContactPersonalInfoPropertySet Class | Aspose.Email.Outlook Namespace | MapiContactPersonalInfoPropertySet Constructor Overload List


MapiContactPersonalInfoPropertySet Constructor (MapiPropertyCollection)

Initializes a new instance of the MapiContactPersonalInfoPropertySet class

public MapiContactPersonalInfoPropertySet(
MapiPropertyCollection properties
);

Parameters

properties
A MapiPropertyCollection containing contact personal properties

See Also

MapiContactPersonalInfoPropertySet Class | Aspose.Email.Outlook Namespace | MapiContactPersonalInfoPropertySet Constructor Overload List


MapiContactPersonalInfoPropertySet Properties

The properties of the MapiContactPersonalInfoPropertySet class are listed below. For a complete list of MapiContactPersonalInfoPropertySet class members, see the MapiContactPersonalInfoPropertySet Members topic.

Public Instance Properties

Account | Specifies the account name of the contact
BusinessHomePage | Specifies the contact's business web page URL
ComputerNetworkName | Specifies the name of the network to which the contact's computer is connected
CustomerId | Specifies the contact's customer ID number
FreeBusyLocation | Specifies a URL path from which a client can retrieve free/busy information for the contact as an iCal file
FtpSite | Specifies the contact's File Transfer Protocol (FTP) URL
Gender | Specifies the gender of the contact
GovernmentIdNumber | Specifies the contact's government ID number
Hobbies | Specifies the hobbies of the contact
Html | Specifies the contact's business web page URL
InstantMessagingAddress | Specifies the contact's instant messaging address
Language | Specifies the language that the contact uses
Location | Specifies the location of the contact
Notes | Specifies the additional notes
OrganizationalIdNumber | Specifies an organizational ID number for the contact
PersonalHomePage | Specifies the contact's personal web page URL
ReferredByName | Specifies the name of the person who referred this contact to the user
SpouseName | Specifies the name of the contact's spouse/partner

See Also

MapiContactPersonalInfoPropertySet Class | Aspose.Email.Outlook Namespace


Account Property

Aspose.Email

MapiContactPersonalInfoPropertySet.Account Property

Specifies the account name of the contact

public string Account {get; set;}

See Also

MapiContactPersonalInfoPropertySet Class | Aspose.Email.Outlook Namespace


BusinessHomePage Property

Aspose.Email

MapiContactPersonalInfoPropertySet.BusinessHomePage Property

Specifies the contact's business web page URL

public string BusinessHomePage {get; set;}

See Also

MapiContactPersonalInfoPropertySet Class | Aspose.Email.Outlook Namespace


ComputerNetworkName Property

Aspose.Email

MapiContactPersonalInfoPropertySet.ComputerNetworkName Property

Specifies the name of the network to which the contact's computer is connected

public string ComputerNetworkName {get; set;}

See Also

MapiContactPersonalInfoPropertySet Class | Aspose.Email.Outlook Namespace


CustomerId Property

Aspose.Email

MapiContactPersonalInfoPropertySet.CustomerId Property

Specifies the contact's customer ID number

public string CustomerId {get; set;}

See Also

MapiContactPersonalInfoPropertySet Class | Aspose.Email.Outlook Namespace


FreeBusyLocation Property

Aspose.Email

MapiContactPersonalInfoPropertySet.FreeBusyLocation Property

Specifies a URL path from which a client can retrieve free/busy information for the contact as an iCal file

public string FreeBusyLocation {get; set;}

See Also

MapiContactPersonalInfoPropertySet Class | Aspose.Email.Outlook Namespace


FtpSite Property

Aspose.Email

MapiContactPersonalInfoPropertySet.FtpSite Property

Specifies the contact's File Transfer Protocol (FTP) URL

public string FtpSite {get; set;}

See Also

MapiContactPersonalInfoPropertySet Class | Aspose.Email.Outlook Namespace


Gender Property

Aspose.Email

MapiContactPersonalInfoPropertySet.Gender Property

Specifies the gender of the contact

public MapiContactGender Gender {get; set;}

See Also

MapiContactPersonalInfoPropertySet Class | Aspose.Email.Outlook Namespace


GovernmentIdNumber Property

Aspose.Email

MapiContactPersonalInfoPropertySet.GovernmentIdNumber Property

Specifies the contact's government ID number

public string GovernmentIdNumber {get; set;}

See Also

MapiContactPersonalInfoPropertySet Class | Aspose.Email.Outlook Namespace


Hobbies Property

Aspose.Email

MapiContactPersonalInfoPropertySet.Hobbies Property

Specifies the hobbies of the contact

public string Hobbies {get; set;}

See Also

MapiContactPersonalInfoPropertySet Class | Aspose.Email.Outlook Namespace


Html Property

Aspose.Email

MapiContactPersonalInfoPropertySet.Html Property

Specifies the contact's business web page URL

public string Html {get; set;}

See Also

MapiContactPersonalInfoPropertySet Class | Aspose.Email.Outlook Namespace


InstantMessagingAddress Property

Aspose.Email

MapiContactPersonalInfoPropertySet.InstantMessagingAddress Property

Specifies the contact's instant messaging address

public string InstantMessagingAddress {get; set;}

See Also

MapiContactPersonalInfoPropertySet Class | Aspose.Email.Outlook Namespace


Language Property

Aspose.Email

MapiContactPersonalInfoPropertySet.Language Property

Specifies the language that the contact uses

public string Language {get; set;}

See Also

MapiContactPersonalInfoPropertySet Class | Aspose.Email.Outlook Namespace


Location Property

Aspose.Email

MapiContactPersonalInfoPropertySet.Location Property

Specifies the location of the contact

public string Location {get; set;}

See Also

MapiContactPersonalInfoPropertySet Class | Aspose.Email.Outlook Namespace


Notes Property

Aspose.Email

MapiContactPersonalInfoPropertySet.Notes Property

Specifies the additional notes

public string Notes {get; set;}

See Also

MapiContactPersonalInfoPropertySet Class | Aspose.Email.Outlook Namespace


OrganizationalIdNumber Property

Aspose.Email

MapiContactPersonalInfoPropertySet.OrganizationalIdNumber Property

Specifies an organizational ID number for the contact

public string OrganizationalIdNumber {get; set;}

See Also

MapiContactPersonalInfoPropertySet Class | Aspose.Email.Outlook Namespace


PersonalHomePage Property

Aspose.Email

MapiContactPersonalInfoPropertySet.PersonalHomePage Property

Specifies the contact's personal web page URL

public string PersonalHomePage {get; set;}

See Also

MapiContactPersonalInfoPropertySet Class | Aspose.Email.Outlook Namespace


ReferredByName Property

Aspose.Email

MapiContactPersonalInfoPropertySet.ReferredByName Property

Specifies the name of the person who referred this contact to the user

public string ReferredByName {get; set;}

See Also

MapiContactPersonalInfoPropertySet Class | Aspose.Email.Outlook Namespace


SpouseName Property

Aspose.Email

MapiContactPersonalInfoPropertySet.SpouseName Property

Specifies the name of the contact's spouse/partner

public string SpouseName {get; set;}

See Also

MapiContactPersonalInfoPropertySet Class | Aspose.Email.Outlook Namespace


MapiContactPhoto Class

Contains data and type of contact's photo.

For a list of all members of this type, see MapiContactPhoto Members.

System.Object
Aspose.Email.Outlook.MapiContactPhoto

public sealed class MapiContactPhoto

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiContactPhoto Members | Aspose.Email.Outlook Namespace


MapiContactPhoto Members

MapiContactPhoto overview

Public Instance Constructors

MapiContactPhoto Overloaded. Initializes a new instance of the MapiContactPhoto class.

Public Instance Properties

Data | Gets an image data.
PhotoImageFormat | Gets a photo type.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MapiContactPhoto Class | Aspose.Email.Outlook Namespace


MapiContactPhoto Constructor

Initializes a new instance of the MapiContactPhoto class

Overload List

Initializes a new instance of the MapiContactPhoto class

public MapiContactPhoto(byte[],MapiContactPhotoImageFormat);

Initializes a new instance of the MapiContactPhoto class

public MapiContactPhoto(string,MapiContactPhotoImageFormat);

Initializes a new instance of the MapiContactPhoto class

public MapiContactPhoto(string,byte[],MapiContactPhotoImageFormat);

See Also

MapiContactPhoto Class | Aspose.Email.Outlook Namespace


MapiContactPhoto Constructor (String, MapiContactPhotoImageFormat)

Initializes a new instance of the MapiContactPhoto class

public MapiContactPhoto(
string itemId,
MapiContactPhotoImageFormat photoImageFormat
);

Parameters

itemId
Uses to specify the server id of the contact.
photoImageFormat
Image format of photo MapiContactPhotoImageFormat.

See Also

MapiContactPhoto Class | Aspose.Email.Outlook Namespace | MapiContactPhoto Constructor Overload List


MapiContactPhoto Constructor (String, Byte[], MapiContactPhotoImageFormat)

Initializes a new instance of the MapiContactPhoto class

public MapiContactPhoto(
string itemId,
byte[] data,
MapiContactPhotoImageFormat photoImageFormat
);

Parameters

itemId
Uses to specify the server id of the contact.
data
Image data of photo.
photoImageFormat
Image format of photo MapiContactPhotoImageFormat.

See Also

MapiContactPhoto Class | Aspose.Email.Outlook Namespace | MapiContactPhoto Constructor Overload List


MapiContactPhoto Constructor (Byte[], MapiContactPhotoImageFormat)

Initializes a new instance of the MapiContactPhoto class

public MapiContactPhoto(
byte[] data,
MapiContactPhotoImageFormat photoImageFormat
);

Parameters

data
Image data of photo.
photoImageFormat
Image format of photo MapiContactPhotoImageFormat.

See Also

MapiContactPhoto Class | Aspose.Email.Outlook Namespace | MapiContactPhoto Constructor Overload List


MapiContactPhoto Properties

The properties of the MapiContactPhoto class are listed below. For a complete list of MapiContactPhoto class members, see the MapiContactPhoto Members topic.

Public Instance Properties

Data | Gets an image data.
PhotoImageFormat | Gets a photo type.

See Also

MapiContactPhoto Class | Aspose.Email.Outlook Namespace


Data Property

Aspose.Email

MapiContactPhoto.Data Property

Gets an image data.

public byte[] Data {get; set;}

See Also

MapiContactPhoto Class | Aspose.Email.Outlook Namespace


PhotoImageFormat Property

Aspose.Email

MapiContactPhoto.PhotoImageFormat Property

Gets a photo type.

public MapiContactPhotoImageFormat PhotoImageFormat {get;}

See Also

MapiContactPhoto Class | Aspose.Email.Outlook Namespace


MapiContactPhotoImageFormat Enumeration

Enumerates MapiContact photo image format.

public enum MapiContactPhotoImageFormat

Members

Member Name | Description | Value
Undefined | Undefined format. | -1
Jpeg | Jpeg format | 0
Gif | Graphics interchange format. | 1
Wmf | MS windows metafile. | 2
Bmp | MS windows bitmap. | 3
Tiff | Tagged image file format. | 4

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Outlook Namespace


MapiContactPhysicalAddress Class

Refers to the group of properties that define physical address for a contact.

For a list of all members of this type, see MapiContactPhysicalAddress Members.

System.Object
Aspose.Email.Outlook.MapiContactPhysicalAddress

public sealed class MapiContactPhysicalAddress

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiContactPhysicalAddress Members | Aspose.Email.Outlook Namespace


MapiContactPhysicalAddress Members

MapiContactPhysicalAddress overview

Public Instance Constructors

MapiContactPhysicalAddress Constructor Initializes a new instance of the MapiContactPhysicalAddress class.

Public Instance Properties

Address | Specifies the complete address of the contact's address
City | Specifies the city or locality portion of the contact's address
Country | Specifies the country or region portion of the contact's address
CountryCode | Specifies the country code portion of the contact's address
IsMailingAddress | Gets or sets a value indicating whether this address is mailing address
PostalCode | Specifies the postal code (ZIP code) portion of the contact's address
PostOfficeBox | Gets or sets the post office box
StateOrProvince | Specifies the state or province portion of the contact's address
Street | Specifies the street portion of the contact's address

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MapiContactPhysicalAddress Class | Aspose.Email.Outlook Namespace


MapiContactPhysicalAddress Constructor

Initializes a new instance of the MapiContactPhysicalAddress class.

public MapiContactPhysicalAddress();

See Also

MapiContactPhysicalAddress Class | Aspose.Email.Outlook Namespace


MapiContactPhysicalAddress Properties

The properties of the MapiContactPhysicalAddress class are listed below. For a complete list of MapiContactPhysicalAddress class members, see the MapiContactPhysicalAddress Members topic.

Public Instance Properties

Address | Specifies the complete address of the contact's address
City | Specifies the city or locality portion of the contact's address
Country | Specifies the country or region portion of the contact's address
CountryCode | Specifies the country code portion of the contact's address
IsMailingAddress | Gets or sets a value indicating whether this address is mailing address
PostalCode | Specifies the postal code (ZIP code) portion of the contact's address
PostOfficeBox | Gets or sets the post office box
StateOrProvince | Specifies the state or province portion of the contact's address
Street | Specifies the street portion of the contact's address

See Also

MapiContactPhysicalAddress Class | Aspose.Email.Outlook Namespace


Address Property

Aspose.Email

MapiContactPhysicalAddress.Address Property

Specifies the complete address of the contact's address

public string Address {get; set;}

See Also

MapiContactPhysicalAddress Class | Aspose.Email.Outlook Namespace


City Property

Aspose.Email

MapiContactPhysicalAddress.City Property

Specifies the city or locality portion of the contact's address

public string City {get; set;}

See Also

MapiContactPhysicalAddress Class | Aspose.Email.Outlook Namespace


Country Property

Aspose.Email

MapiContactPhysicalAddress.Country Property

Specifies the country or region portion of the contact's address

public string Country {get; set;}

See Also

MapiContactPhysicalAddress Class | Aspose.Email.Outlook Namespace


CountryCode Property

Aspose.Email

MapiContactPhysicalAddress.CountryCode Property

Specifies the country code portion of the contact's address

public string CountryCode {get; set;}

See Also

MapiContactPhysicalAddress Class | Aspose.Email.Outlook Namespace


IsMailingAddress Property

Aspose.Email

MapiContactPhysicalAddress.IsMailingAddress Property

Gets or sets a value indicating whether this address is mailing address

public bool IsMailingAddress {get; set;}

See Also

MapiContactPhysicalAddress Class | Aspose.Email.Outlook Namespace


PostalCode Property

Aspose.Email

MapiContactPhysicalAddress.PostalCode Property

Specifies the postal code (ZIP code) portion of the contact's address

public string PostalCode {get; set;}

See Also

MapiContactPhysicalAddress Class | Aspose.Email.Outlook Namespace


PostOfficeBox Property

Aspose.Email

MapiContactPhysicalAddress.PostOfficeBox Property

Gets or sets the post office box

public string PostOfficeBox {get; set;}

See Also

MapiContactPhysicalAddress Class | Aspose.Email.Outlook Namespace


StateOrProvince Property

Aspose.Email

MapiContactPhysicalAddress.StateOrProvince Property

Specifies the state or province portion of the contact's address

public string StateOrProvince {get; set;}

See Also

MapiContactPhysicalAddress Class | Aspose.Email.Outlook Namespace


Street Property

Aspose.Email

MapiContactPhysicalAddress.Street Property

Specifies the street portion of the contact's address

public string Street {get; set;}

See Also

MapiContactPhysicalAddress Class | Aspose.Email.Outlook Namespace


MapiContactPhysicalAddressPropertySet Class

Specify three physical addresses: Home Address, Work Address, and Other Address. One of the addresses can be marked as the Mailing Address

For a list of all members of this type, see MapiContactPhysicalAddressPropertySet Members.

System.Object
Aspose.Email.Outlook.MapiContactPhysicalAddressPropertySet

public sealed class MapiContactPhysicalAddressPropertySet

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiContactPhysicalAddressPropertySet Members | Aspose.Email.Outlook Namespace


MapiContactPhysicalAddressPropertySet Members

MapiContactPhysicalAddressPropertySet overview

Public Instance Constructors

MapiContactPhysicalAddressPropertySet Overloaded. Initializes a new instance of the MapiContactPhysicalAddressPropertySet class.

Public Instance Properties

HomeAddress | Specifies the address of the contact's home
OtherAddress | Specifies the other contact's address
WorkAddress | Specifies the address of the contact's work

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MapiContactPhysicalAddressPropertySet Class | Aspose.Email.Outlook Namespace


MapiContactPhysicalAddressPropertySet Constructor

Initializes a new instance of the MapiContactPhysicalAddressPropertySet class

Overload List

Initializes a new instance of the MapiContactPhysicalAddressPropertySet class

public MapiContactPhysicalAddressPropertySet();

Initializes a new instance of the MapiContactPhysicalAddressPropertySet class

public MapiContactPhysicalAddressPropertySet(MapiPropertyCollection);

See Also

MapiContactPhysicalAddressPropertySet Class | Aspose.Email.Outlook Namespace


MapiContactPhysicalAddressPropertySet Constructor ()

Initializes a new instance of the MapiContactPhysicalAddressPropertySet class

public MapiContactPhysicalAddressPropertySet();

See Also

MapiContactPhysicalAddressPropertySet Class | Aspose.Email.Outlook Namespace | MapiContactPhysicalAddressPropertySet Constructor Overload List


MapiContactPhysicalAddressPropertySet Constructor (MapiPropertyCollection)

Initializes a new instance of the MapiContactPhysicalAddressPropertySet class

public MapiContactPhysicalAddressPropertySet(
MapiPropertyCollection properties
);

Parameters

properties
A MapiPropertyCollection containing contact physical addresses properties

See Also

MapiContactPhysicalAddressPropertySet Class | Aspose.Email.Outlook Namespace | MapiContactPhysicalAddressPropertySet Constructor Overload List


MapiContactPhysicalAddressPropertySet Properties

The properties of the MapiContactPhysicalAddressPropertySet class are listed below. For a complete list of MapiContactPhysicalAddressPropertySet class members, see the MapiContactPhysicalAddressPropertySet Members topic.

Public Instance Properties

HomeAddress | Specifies the address of the contact's home
OtherAddress | Specifies the other contact's address
WorkAddress | Specifies the address of the contact's work

See Also

MapiContactPhysicalAddressPropertySet Class | Aspose.Email.Outlook Namespace


HomeAddress Property

Aspose.Email

MapiContactPhysicalAddressPropertySet.HomeAddress Property

Specifies the address of the contact's home

public MapiContactPhysicalAddress HomeAddress {get; set;}

See Also

MapiContactPhysicalAddressPropertySet Class | Aspose.Email.Outlook Namespace


OtherAddress Property

Aspose.Email

MapiContactPhysicalAddressPropertySet.OtherAddress Property

Specifies the other contact's address

public MapiContactPhysicalAddress OtherAddress {get; set;}

See Also

MapiContactPhysicalAddressPropertySet Class | Aspose.Email.Outlook Namespace


WorkAddress Property

Aspose.Email

MapiContactPhysicalAddressPropertySet.WorkAddress Property

Specifies the address of the contact's work

public MapiContactPhysicalAddress WorkAddress {get; set;}

See Also

MapiContactPhysicalAddressPropertySet Class | Aspose.Email.Outlook Namespace


MapiContactProfessionalPropertySet Class

Properties are used to store professional details for the person represented by the contact

For a list of all members of this type, see MapiContactProfessionalPropertySet Members.

System.Object
Aspose.Email.Outlook.MapiContactProfessionalPropertySet

public sealed class MapiContactProfessionalPropertySet

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiContactProfessionalPropertySet Members | Aspose.Email.Outlook Namespace


MapiContactProfessionalPropertySet Members

MapiContactProfessionalPropertySet overview

Public Instance Constructors

MapiContactProfessionalPropertySet Overloaded. Initializes a new instance of the MapiContactProfessionalPropertySet class.

Public Instance Properties

Assistant | Gets or sets the name of the contact's assistant
CompanyName | Gets or sets the company that employs the contact
DepartmentName | Gets or sets the name of the department to which the contact belongs
ManagerName | Gets or sets the name of the contact's manager
OfficeLocation | Gets or sets the location of the office that the contact works in
Profession | Gets or sets the profession of the contact
Title | Gets or sets the job title of the contact

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MapiContactProfessionalPropertySet Class | Aspose.Email.Outlook Namespace


MapiContactProfessionalPropertySet Constructor

Initializes a new instance of the MapiContactProfessionalPropertySet class.

Overload List

Initializes a new instance of the MapiContactProfessionalPropertySet class.

public MapiContactProfessionalPropertySet();

Initializes a new instance of the MapiContactProfessionalPropertySet class

public MapiContactProfessionalPropertySet(MapiPropertyCollection);

Initializes a new instance of the MapiContactProfessionalPropertySet class.

public MapiContactProfessionalPropertySet(string,string);

See Also

MapiContactProfessionalPropertySet Class | Aspose.Email.Outlook Namespace


MapiContactProfessionalPropertySet Constructor ()

Initializes a new instance of the MapiContactProfessionalPropertySet class.

public MapiContactProfessionalPropertySet();

See Also

MapiContactProfessionalPropertySet Class | Aspose.Email.Outlook Namespace | MapiContactProfessionalPropertySet Constructor Overload List


MapiContactProfessionalPropertySet Constructor (String, String)

Initializes a new instance of the MapiContactProfessionalPropertySet class.

public MapiContactProfessionalPropertySet(
string companyName,
string title
);

Parameters

companyName
Name of the company.
title
The title.

See Also

MapiContactProfessionalPropertySet Class | Aspose.Email.Outlook Namespace | MapiContactProfessionalPropertySet Constructor Overload List


MapiContactProfessionalPropertySet Constructor (MapiPropertyCollection)

Initializes a new instance of the MapiContactProfessionalPropertySet class

public MapiContactProfessionalPropertySet(
MapiPropertyCollection properties
);

Parameters

properties
A MapiPropertyCollection containing contact professional properties

See Also

MapiContactProfessionalPropertySet Class | Aspose.Email.Outlook Namespace | MapiContactProfessionalPropertySet Constructor Overload List


MapiContactProfessionalPropertySet Properties

The properties of the MapiContactProfessionalPropertySet class are listed below. For a complete list of MapiContactProfessionalPropertySet class members, see the MapiContactProfessionalPropertySet Members topic.

Public Instance Properties

Assistant | Gets or sets the name of the contact's assistant
CompanyName | Gets or sets the company that employs the contact
DepartmentName | Gets or sets the name of the department to which the contact belongs
ManagerName | Gets or sets the name of the contact's manager
OfficeLocation | Gets or sets the location of the office that the contact works in
Profession | Gets or sets the profession of the contact
Title | Gets or sets the job title of the contact

See Also

MapiContactProfessionalPropertySet Class | Aspose.Email.Outlook Namespace


Assistant Property

Aspose.Email

MapiContactProfessionalPropertySet.Assistant Property

Gets or sets the name of the contact's assistant

public string Assistant {get; set;}

See Also

MapiContactProfessionalPropertySet Class | Aspose.Email.Outlook Namespace


CompanyName Property

Aspose.Email

MapiContactProfessionalPropertySet.CompanyName Property

Gets or sets the company that employs the contact

public string CompanyName {get; set;}

See Also

MapiContactProfessionalPropertySet Class | Aspose.Email.Outlook Namespace


DepartmentName Property

Aspose.Email

MapiContactProfessionalPropertySet.DepartmentName Property

Gets or sets the name of the department to which the contact belongs

public string DepartmentName {get; set;}

See Also

MapiContactProfessionalPropertySet Class | Aspose.Email.Outlook Namespace


ManagerName Property

Aspose.Email

MapiContactProfessionalPropertySet.ManagerName Property

Gets or sets the name of the contact's manager

public string ManagerName {get; set;}

See Also

MapiContactProfessionalPropertySet Class | Aspose.Email.Outlook Namespace


OfficeLocation Property

Aspose.Email

MapiContactProfessionalPropertySet.OfficeLocation Property

Gets or sets the location of the office that the contact works in

public string OfficeLocation {get; set;}

See Also

MapiContactProfessionalPropertySet Class | Aspose.Email.Outlook Namespace


Profession Property

Aspose.Email

MapiContactProfessionalPropertySet.Profession Property

Gets or sets the profession of the contact

public string Profession {get; set;}

See Also

MapiContactProfessionalPropertySet Class | Aspose.Email.Outlook Namespace


Title Property

Aspose.Email

MapiContactProfessionalPropertySet.Title Property

Gets or sets the job title of the contact

public string Title {get; set;}

See Also

MapiContactProfessionalPropertySet Class | Aspose.Email.Outlook Namespace


MapiContactTelephonePropertySet Class

Specify optional telephone numbers for the contact

For a list of all members of this type, see MapiContactTelephonePropertySet Members.

System.Object
Aspose.Email.Outlook.MapiContactTelephonePropertySet

public sealed class MapiContactTelephonePropertySet

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiContactTelephonePropertySet Members | Aspose.Email.Outlook Namespace


MapiContactTelephonePropertySet Members

MapiContactTelephonePropertySet overview

Public Instance Constructors

MapiContactTelephonePropertySet Overloaded. Initializes a new instance of the MapiContactTelephonePropertySet class.

Public Instance Properties

AssistantTelephoneNumber | Gets or sets the telephone number of the contact's assistant
Business2TelephoneNumber | Gets or sets the second business telephone number
BusinessTelephoneNumber | Gets or sets the business telephone number
CallbackTelephoneNumber | Gets or sets the callback telephone number
CarTelephoneNumber | Gets or sets the car telephone number
CompanyMainTelephoneNumber | Gets or sets the company phone number
DefaultTelephoneNumber | Default value of electronic address Uses when user does not set any electronic address if UseAutocomplete property is set 'true'
Home2TelephoneNumber | Gets or sets a second home telephone number
HomeTelephoneNumber | Gets or sets the home telephone number
IsdnNumber | Gets or sets the integrated services digital network (ISDN) number
IsEmpty | Shows if MapiContactTelephonePropertySet is empty
MobileTelephoneNumber | Gets or sets the mobile telephone number
OtherTelephoneNumber | Gets or sets an alternate telephone number
PagerTelephoneNumber | Gets or sets a pager telephone number
PrimaryTelephoneNumber | Gets or sets the primary telephone number
RadioTelephoneNumber | Gets or sets the radio telephone number
TelexNumber | Gets or sets the telex number
TtyTddPhoneNumber | Gets or sets the telephone number for the contact's text telephone (TTY) or telecommunication device for the deaf (TDD)
UseAutocomplete | Indicates that one electronic address is completed automatically in case if user does not set any electronic address

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MapiContactTelephonePropertySet Class | Aspose.Email.Outlook Namespace


MapiContactTelephonePropertySet Constructor

Initializes a new instance of the MapiContactTelephonePropertySet class

Overload List

Initializes a new instance of the MapiContactTelephonePropertySet class

public MapiContactTelephonePropertySet();

Initializes a new instance of the MapiContactTelephonePropertySet class

public MapiContactTelephonePropertySet(MapiPropertyCollection);

Initializes a new instance of the MapiContactTelephonePropertySet class.

public MapiContactTelephonePropertySet(string);

See Also

MapiContactTelephonePropertySet Class | Aspose.Email.Outlook Namespace


MapiContactTelephonePropertySet Constructor ()

Initializes a new instance of the MapiContactTelephonePropertySet class

public MapiContactTelephonePropertySet();

See Also

MapiContactTelephonePropertySet Class | Aspose.Email.Outlook Namespace | MapiContactTelephonePropertySet Constructor Overload List


MapiContactTelephonePropertySet Constructor (String)

Initializes a new instance of the MapiContactTelephonePropertySet class.

public MapiContactTelephonePropertySet(
string primaryTelephoneNumber
);

Parameters

primaryTelephoneNumber
The primary telephone number.

See Also

MapiContactTelephonePropertySet Class | Aspose.Email.Outlook Namespace | MapiContactTelephonePropertySet Constructor Overload List


MapiContactTelephonePropertySet Constructor (MapiPropertyCollection)

Initializes a new instance of the MapiContactTelephonePropertySet class

public MapiContactTelephonePropertySet(
MapiPropertyCollection properties
);

Parameters

properties
A MapiPropertyCollection containing contact telephone properties

See Also

MapiContactTelephonePropertySet Class | Aspose.Email.Outlook Namespace | MapiContactTelephonePropertySet Constructor Overload List


MapiContactTelephonePropertySet Properties

The properties of the MapiContactTelephonePropertySet class are listed below. For a complete list of MapiContactTelephonePropertySet class members, see the MapiContactTelephonePropertySet Members topic.

Public Instance Properties

AssistantTelephoneNumber | Gets or sets the telephone number of the contact's assistant
Business2TelephoneNumber | Gets or sets the second business telephone number
BusinessTelephoneNumber | Gets or sets the business telephone number
CallbackTelephoneNumber | Gets or sets the callback telephone number
CarTelephoneNumber | Gets or sets the car telephone number
CompanyMainTelephoneNumber | Gets or sets the company phone number
DefaultTelephoneNumber | Default value of electronic address Uses when user does not set any electronic address if UseAutocomplete property is set 'true'
Home2TelephoneNumber | Gets or sets a second home telephone number
HomeTelephoneNumber | Gets or sets the home telephone number
IsdnNumber | Gets or sets the integrated services digital network (ISDN) number
IsEmpty | Shows if MapiContactTelephonePropertySet is empty
MobileTelephoneNumber | Gets or sets the mobile telephone number
OtherTelephoneNumber | Gets or sets an alternate telephone number
PagerTelephoneNumber | Gets or sets a pager telephone number
PrimaryTelephoneNumber | Gets or sets the primary telephone number
RadioTelephoneNumber | Gets or sets the radio telephone number
TelexNumber | Gets or sets the telex number
TtyTddPhoneNumber | Gets or sets the telephone number for the contact's text telephone (TTY) or telecommunication device for the deaf (TDD)
UseAutocomplete | Indicates that one electronic address is completed automatically in case if user does not set any electronic address

See Also

MapiContactTelephonePropertySet Class | Aspose.Email.Outlook Namespace


AssistantTelephoneNumber Property

Aspose.Email

MapiContactTelephonePropertySet.AssistantTelephoneNumber Property

Gets or sets the telephone number of the contact's assistant

public string AssistantTelephoneNumber {get; set;}

See Also

MapiContactTelephonePropertySet Class | Aspose.Email.Outlook Namespace


Business2TelephoneNumber Property

Aspose.Email

MapiContactTelephonePropertySet.Business2TelephoneNumber Property

Gets or sets the second business telephone number

public string Business2TelephoneNumber {get; set;}

See Also

MapiContactTelephonePropertySet Class | Aspose.Email.Outlook Namespace


BusinessTelephoneNumber Property

Aspose.Email

MapiContactTelephonePropertySet.BusinessTelephoneNumber Property

Gets or sets the business telephone number

public string BusinessTelephoneNumber {get; set;}

See Also

MapiContactTelephonePropertySet Class | Aspose.Email.Outlook Namespace


CallbackTelephoneNumber Property

Aspose.Email

MapiContactTelephonePropertySet.CallbackTelephoneNumber Property

Gets or sets the callback telephone number

public string CallbackTelephoneNumber {get; set;}

See Also

MapiContactTelephonePropertySet Class | Aspose.Email.Outlook Namespace


CarTelephoneNumber Property

Aspose.Email

MapiContactTelephonePropertySet.CarTelephoneNumber Property

Gets or sets the car telephone number

public string CarTelephoneNumber {get; set;}

See Also

MapiContactTelephonePropertySet Class | Aspose.Email.Outlook Namespace


CompanyMainTelephoneNumber Property

Aspose.Email

MapiContactTelephonePropertySet.CompanyMainTelephoneNumber Property

Gets or sets the company phone number

public string CompanyMainTelephoneNumber {get; set;}

See Also

MapiContactTelephonePropertySet Class | Aspose.Email.Outlook Namespace


DefaultTelephoneNumber Property

Aspose.Email

MapiContactTelephonePropertySet.DefaultTelephoneNumber Property

Default value of electronic address Uses when user does not set any electronic address if UseAutocomplete property is set 'true'

public string DefaultTelephoneNumber {get; set;}

See Also

MapiContactTelephonePropertySet Class | Aspose.Email.Outlook Namespace


Home2TelephoneNumber Property

Aspose.Email

MapiContactTelephonePropertySet.Home2TelephoneNumber Property

Gets or sets a second home telephone number

public string Home2TelephoneNumber {get; set;}

See Also

MapiContactTelephonePropertySet Class | Aspose.Email.Outlook Namespace


HomeTelephoneNumber Property

Aspose.Email

MapiContactTelephonePropertySet.HomeTelephoneNumber Property

Gets or sets the home telephone number

public string HomeTelephoneNumber {get; set;}

See Also

MapiContactTelephonePropertySet Class | Aspose.Email.Outlook Namespace


IsdnNumber Property

Aspose.Email

MapiContactTelephonePropertySet.IsdnNumber Property

Gets or sets the integrated services digital network (ISDN) number

public string IsdnNumber {get; set;}

See Also

MapiContactTelephonePropertySet Class | Aspose.Email.Outlook Namespace


IsEmpty Property

Aspose.Email

MapiContactTelephonePropertySet.IsEmpty Property

Shows if MapiContactTelephonePropertySet is empty

public bool IsEmpty {get;}

See Also

MapiContactTelephonePropertySet Class | Aspose.Email.Outlook Namespace


MobileTelephoneNumber Property

Aspose.Email

MapiContactTelephonePropertySet.MobileTelephoneNumber Property

Gets or sets the mobile telephone number

public string MobileTelephoneNumber {get; set;}

See Also

MapiContactTelephonePropertySet Class | Aspose.Email.Outlook Namespace


OtherTelephoneNumber Property

Aspose.Email

MapiContactTelephonePropertySet.OtherTelephoneNumber Property

Gets or sets an alternate telephone number

public string OtherTelephoneNumber {get; set;}

See Also

MapiContactTelephonePropertySet Class | Aspose.Email.Outlook Namespace


PagerTelephoneNumber Property

Aspose.Email

MapiContactTelephonePropertySet.PagerTelephoneNumber Property

Gets or sets a pager telephone number

public string PagerTelephoneNumber {get; set;}

See Also

MapiContactTelephonePropertySet Class | Aspose.Email.Outlook Namespace


PrimaryTelephoneNumber Property

Aspose.Email

MapiContactTelephonePropertySet.PrimaryTelephoneNumber Property

Gets or sets the primary telephone number

public string PrimaryTelephoneNumber {get; set;}

See Also

MapiContactTelephonePropertySet Class | Aspose.Email.Outlook Namespace


RadioTelephoneNumber Property

Aspose.Email

MapiContactTelephonePropertySet.RadioTelephoneNumber Property

Gets or sets the radio telephone number

public string RadioTelephoneNumber {get; set;}

See Also

MapiContactTelephonePropertySet Class | Aspose.Email.Outlook Namespace


TelexNumber Property

Aspose.Email

MapiContactTelephonePropertySet.TelexNumber Property

Gets or sets the telex number

public string TelexNumber {get; set;}

See Also

MapiContactTelephonePropertySet Class | Aspose.Email.Outlook Namespace


TtyTddPhoneNumber Property

Aspose.Email

MapiContactTelephonePropertySet.TtyTddPhoneNumber Property

Gets or sets the telephone number for the contact's text telephone (TTY) or telecommunication device for the deaf (TDD)

public string TtyTddPhoneNumber {get; set;}

See Also

MapiContactTelephonePropertySet Class | Aspose.Email.Outlook Namespace


UseAutocomplete Property

Aspose.Email

MapiContactTelephonePropertySet.UseAutocomplete Property

Indicates that one electronic address is completed automatically in case if user does not set any electronic address

public bool UseAutocomplete {get; set;}

See Also

MapiContactTelephonePropertySet Class | Aspose.Email.Outlook Namespace


MapiDistributionList Class

Represents the Personal Distribution List object.

For a list of all members of this type, see MapiDistributionList Members.

System.Object
Aspose.Email.Outlook.MapiDistributionList

public sealed class MapiDistributionList : IMapiMessageItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiDistributionList Members | Aspose.Email.Outlook Namespace


MapiDistributionList Members

MapiDistributionList overview

Public Instance Constructors

MapiDistributionList Overloaded. Initializes a new instance of the MapiDistributionList class.

Public Instance Properties

Body | Gets message body
DisplayName | Gets or sets the user-visible name of the personal distribution list.
Members | Gets the list of the members of the personal distribution list.
MessageClass | Gets message class
Subject | Gets message subject

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MapiDistributionList Class | Aspose.Email.Outlook Namespace


MapiDistributionList Constructor

Initializes a new instance of the MapiDistributionList class.

Overload List

Initializes a new instance of the MapiDistributionList class.

public MapiDistributionList();

Initializes a new instance of the MapiDistributionList class.

public MapiDistributionList(string,MapiDistributionListMemberCollection);

See Also

MapiDistributionList Class | Aspose.Email.Outlook Namespace


MapiDistributionList Constructor ()

Initializes a new instance of the MapiDistributionList class.

public MapiDistributionList();

See Also

MapiDistributionList Class | Aspose.Email.Outlook Namespace | MapiDistributionList Constructor Overload List


MapiDistributionList Constructor (String, MapiDistributionListMemberCollection)

Initializes a new instance of the MapiDistributionList class.

public MapiDistributionList(
string displayName,
MapiDistributionListMemberCollection members
);

Parameters

displayName
The display namme.
members
The recipiens.

See Also

MapiDistributionList Class | Aspose.Email.Outlook Namespace | MapiDistributionList Constructor Overload List


MapiDistributionList Properties

The properties of the MapiDistributionList class are listed below. For a complete list of MapiDistributionList class members, see the MapiDistributionList Members topic.

Public Instance Properties

Body | Gets message body
DisplayName | Gets or sets the user-visible name of the personal distribution list.
Members | Gets the list of the members of the personal distribution list.
MessageClass | Gets message class
Subject | Gets message subject

See Also

MapiDistributionList Class | Aspose.Email.Outlook Namespace


Body Property

Aspose.Email

MapiDistributionList.Body Property

Gets message body

public string Body {get;}

Property Value

Implements

IMapiMessageItem.Body

See Also

MapiDistributionList Class | Aspose.Email.Outlook Namespace


DisplayName Property

Aspose.Email

MapiDistributionList.DisplayName Property

Gets or sets the user-visible name of the personal distribution list.

public string DisplayName {get; set;}

Property Value

The display name.

See Also

MapiDistributionList Class | Aspose.Email.Outlook Namespace


Members Property

Aspose.Email

MapiDistributionList.Members Property

Gets the list of the members of the personal distribution list.

public MapiDistributionListMemberCollection Members {get;}

Property Value

The collection of MapiDistributionListMember.

See Also

MapiDistributionList Class | Aspose.Email.Outlook Namespace


MessageClass Property

Aspose.Email

MapiDistributionList.MessageClass Property

Gets message class

public string MessageClass {get;}

Property Value

Implements

IMapiMessageItem.MessageClass

See Also

MapiDistributionList Class | Aspose.Email.Outlook Namespace


Subject Property

Aspose.Email

MapiDistributionList.Subject Property

Gets message subject

public string Subject {get;}

Property Value

Implements

IMapiMessageItem.Subject

See Also

MapiDistributionList Class | Aspose.Email.Outlook Namespace


MapiDistributionListContactAddressType Enumeration

Represents the address type of a personal distribution list member.

public enum MapiDistributionListContactAddressType

Members

Member Name | Description | Value
BusinessFax | Business Fax electronic address. | 0
HomeFax | Home Fax electronic address. | 1
PrimaryFax | Primary Fax electronic address. | 2
Email1 | Email1 address. | 4
Email2 | Email2 address. | 5
Email3 | Email3 address. | 6
None | None. | 3

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Outlook Namespace


MapiDistributionListEntryIdType Enumeration

Specifies the type of EntryID.

public enum MapiDistributionListEntryIdType

Members

Member Name | Description | Value
OneOff | Designates a one-off EntryID. The EntryID must be a One-Off EntryID structure. | 0
Contact | EntryID of a Contact object. The EntryID must be a Message EntryID structure. | 3
DistributionList | EntryID of a Personal Distribution List object. The EntryID must be a Message EntryID structure. | 4
GalMailUser | EntryID of a mail user in the GAL. The EntryID must be an Address Book EntryID structure. | 5
GalDistributionList | EntryID of a distribution list in the GAL. The EntryID must be an Address Book EntryID structure. | 6

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Outlook Namespace


MapiDistributionListMember Class

Represents the members of the personal distribution list.

For a list of all members of this type, see MapiDistributionListMember Members.

System.Object
Aspose.Email.Outlook.MapiDistributionListMember

public sealed class MapiDistributionListMember

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiDistributionListMember Members | Aspose.Email.Outlook Namespace


MapiDistributionListMember Members

MapiDistributionListMember overview

Public Instance Constructors

MapiDistributionListMember Constructor Initializes a new instance of the MapiDistributionListMember class.

Public Instance Properties

AddressType | Gets or sets the recipient's e-mail address type.
ContactAddressType | Gets or sets the type of the address, when EntryId property contains a the EntryID of a Contact object.
DisplayName | Gets or sets the recipient's display name.
EmailAddress | Gets or sets the recipient's e-mail address.
EntryId | Gets or sets the EntryID of a member of a personal distribution list.
EntryIdType | Gets or sets the type of EntryID.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MapiDistributionListMember Class | Aspose.Email.Outlook Namespace


MapiDistributionListMember Constructor

Initializes a new instance of the MapiDistributionListMember class.

public MapiDistributionListMember(
string displayName,
string emailAddress
);

Parameters

displayName
The display name.
emailAddress
The email address.

Exceptions

Exception Type | Condition
ArgumentException | If displayName is null or empty.
ArgumentException | If emailAddress is null or empty.

See Also

MapiDistributionListMember Class | Aspose.Email.Outlook Namespace


MapiDistributionListMember Properties

The properties of the MapiDistributionListMember class are listed below. For a complete list of MapiDistributionListMember class members, see the MapiDistributionListMember Members topic.

Public Instance Properties

AddressType | Gets or sets the recipient's e-mail address type.
ContactAddressType | Gets or sets the type of the address, when EntryId property contains a the EntryID of a Contact object.
DisplayName | Gets or sets the recipient's display name.
EmailAddress | Gets or sets the recipient's e-mail address.
EntryId | Gets or sets the EntryID of a member of a personal distribution list.
EntryIdType | Gets or sets the type of EntryID.

See Also

MapiDistributionListMember Class | Aspose.Email.Outlook Namespace


AddressType Property

Aspose.Email

MapiDistributionListMember.AddressType Property

Gets or sets the recipient's e-mail address type.

public string AddressType {get; set;}

Property Value

The type of the address.

See Also

MapiDistributionListMember Class | Aspose.Email.Outlook Namespace


ContactAddressType Property

Aspose.Email

MapiDistributionListMember.ContactAddressType Property

Gets or sets the type of the address, when EntryId property contains a the EntryID of a Contact object.

public MapiDistributionListContactAddressType ContactAddressType {get; set;}

Property Value

The type of the address.

See Also

MapiDistributionListMember Class | Aspose.Email.Outlook Namespace


DisplayName Property

Aspose.Email

MapiDistributionListMember.DisplayName Property

Gets or sets the recipient's display name.

public string DisplayName {get; set;}

Property Value

The display name.

See Also

MapiDistributionListMember Class | Aspose.Email.Outlook Namespace


EmailAddress Property

Aspose.Email

MapiDistributionListMember.EmailAddress Property

Gets or sets the recipient's e-mail address.

public string EmailAddress {get; set;}

Property Value

The email address.

See Also

MapiDistributionListMember Class | Aspose.Email.Outlook Namespace


EntryId Property

Aspose.Email

MapiDistributionListMember.EntryId Property

Gets or sets the EntryID of a member of a personal distribution list.

public byte[] EntryId {get; set;}

Property Value

The entry id.

See Also

MapiDistributionListMember Class | Aspose.Email.Outlook Namespace


EntryIdType Property

Aspose.Email

MapiDistributionListMember.EntryIdType Property

Gets or sets the type of EntryID.

public MapiDistributionListEntryIdType EntryIdType {get; set;}

Property Value

The type of the entry id.

See Also

MapiDistributionListMember Class | Aspose.Email.Outlook Namespace


MapiDistributionListMemberCollection Class

Represents a collection of MapiDistributionListMember objects.

For a list of all members of this type, see MapiDistributionListMemberCollection Members.

System.Object
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Outlook.MapiDistributionListMember, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]]
Aspose.Email.Outlook.MapiDistributionListMemberCollection

public sealed class MapiDistributionListMemberCollection : Collection`1

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiDistributionListMemberCollection Members | Aspose.Email.Outlook Namespace


MapiDistributionListMemberCollection Members

MapiDistributionListMemberCollection overview

Public Instance Constructors

MapiDistributionListMemberCollection Constructor Initializes a new instance of the MapiDistributionListMemberCollection class.

Public Instance Properties

Count (inherited from 0, Culture=neutral, PublicKeyToken=null]])
Item (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MapiDistributionListMemberCollection Class | Aspose.Email.Outlook Namespace


MapiDistributionListMemberCollection Constructor

Initializes a new instance of the MapiDistributionListMemberCollection class.

public MapiDistributionListMemberCollection();

See Also

MapiDistributionListMemberCollection Class | Aspose.Email.Outlook Namespace


MapiElectronicAddress Class

Refers to the group of properties that define the e-mail address or fax address.

For a list of all members of this type, see MapiElectronicAddress Members.

System.Object
Aspose.Email.Outlook.MapiElectronicAddress

public sealed class MapiElectronicAddress

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiElectronicAddress Members | Aspose.Email.Outlook Namespace


MapiElectronicAddress Members

MapiElectronicAddress overview

Public Static Type Conversions

Implicit String to MapiElectronicAddress Conversion Performs an implicit conversion from String to MapiElectronicAddress.

Public Instance Constructors

MapiElectronicAddress Overloaded. Initializes a new instance of the MapiElectronicAddress class.

Public Instance Properties

AddressType | Gets or sets the address type of an electronic address.
DisplayName | Gets or sets the user-readable display name for the e-mail address.
EmailAddress | Gets or sets the e-mail address.
FaxNumber | Gets or sets the telephone number of the mail user's primary fax machine.
IsEmpty | Shows if MapiElectronicAddress is empty
OriginalDisplayName | Gets or sets the SMTP e-mail address that corresponds to the e-mail address .

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MapiElectronicAddress Class | Aspose.Email.Outlook Namespace


MapiElectronicAddress Constructor

Initializes a new instance of the MapiElectronicAddress class.

Overload List

Initializes a new instance of the MapiElectronicAddress class.

public MapiElectronicAddress();

Initializes a new instance of the MapiElectronicAddress class.

public MapiElectronicAddress(string);

Initializes a new instance of the MapiElectronicAddress class.

public MapiElectronicAddress(string,string);

Initializes a new instance of the MapiElectronicAddress class.

public MapiElectronicAddress(string,string,string);

See Also

MapiElectronicAddress Class | Aspose.Email.Outlook Namespace


MapiElectronicAddress Constructor ()

Initializes a new instance of the MapiElectronicAddress class.

public MapiElectronicAddress();

See Also

MapiElectronicAddress Class | Aspose.Email.Outlook Namespace | MapiElectronicAddress Constructor Overload List


MapiElectronicAddress Constructor (String, String, String)

Initializes a new instance of the MapiElectronicAddress class.

public MapiElectronicAddress(
string displayName,
string addressType,
string emailAddress
);

Parameters

displayName
The display name.
addressType
Type of the address.
emailAddress
The email address.

See Also

MapiElectronicAddress Class | Aspose.Email.Outlook Namespace | MapiElectronicAddress Constructor Overload List


MapiElectronicAddress Constructor (String)

Initializes a new instance of the MapiElectronicAddress class.

public MapiElectronicAddress(
string emailAddress
);

Parameters

emailAddress
The email address.

See Also

MapiElectronicAddress Class | Aspose.Email.Outlook Namespace | MapiElectronicAddress Constructor Overload List


MapiElectronicAddress Constructor (String, String)

Initializes a new instance of the MapiElectronicAddress class.

public MapiElectronicAddress(
string faxNumber,
string emailAddress
);

Parameters

faxNumber
The fax number.
emailAddress
The email address.

See Also

MapiElectronicAddress Class | Aspose.Email.Outlook Namespace | MapiElectronicAddress Constructor Overload List


MapiElectronicAddress Properties

The properties of the MapiElectronicAddress class are listed below. For a complete list of MapiElectronicAddress class members, see the MapiElectronicAddress Members topic.

Public Instance Properties

AddressType | Gets or sets the address type of an electronic address.
DisplayName | Gets or sets the user-readable display name for the e-mail address.
EmailAddress | Gets or sets the e-mail address.
FaxNumber | Gets or sets the telephone number of the mail user's primary fax machine.
IsEmpty | Shows if MapiElectronicAddress is empty
OriginalDisplayName | Gets or sets the SMTP e-mail address that corresponds to the e-mail address .

See Also

MapiElectronicAddress Class | Aspose.Email.Outlook Namespace


AddressType Property

Aspose.Email

MapiElectronicAddress.AddressType Property

Gets or sets the address type of an electronic address.

public string AddressType {get; set;}

See Also

MapiElectronicAddress Class | Aspose.Email.Outlook Namespace


DisplayName Property

Aspose.Email

MapiElectronicAddress.DisplayName Property

Gets or sets the user-readable display name for the e-mail address.

public string DisplayName {get; set;}

See Also

MapiElectronicAddress Class | Aspose.Email.Outlook Namespace


EmailAddress Property

Aspose.Email

MapiElectronicAddress.EmailAddress Property

Gets or sets the e-mail address.

public string EmailAddress {get; set;}

See Also

MapiElectronicAddress Class | Aspose.Email.Outlook Namespace


FaxNumber Property

Aspose.Email

MapiElectronicAddress.FaxNumber Property

Gets or sets the telephone number of the mail user's primary fax machine.

public string FaxNumber {get; set;}

See Also

MapiElectronicAddress Class | Aspose.Email.Outlook Namespace


IsEmpty Property

Aspose.Email

MapiElectronicAddress.IsEmpty Property

Shows if MapiElectronicAddress is empty

public bool IsEmpty {get;}

See Also

MapiElectronicAddress Class | Aspose.Email.Outlook Namespace


OriginalDisplayName Property

Aspose.Email

MapiElectronicAddress.OriginalDisplayName Property

Gets or sets the SMTP e-mail address that corresponds to the e-mail address .

public string OriginalDisplayName {get; set;}

Property Value

The SMTP e-mail address.

See Also

MapiElectronicAddress Class | Aspose.Email.Outlook Namespace


MapiElectronicAddress Type Conversions

The type conversions of the MapiElectronicAddress class are listed below. For a complete list of MapiElectronicAddress class members, see the MapiElectronicAddress Members topic.

Public Static Type Conversions

Implicit String to MapiElectronicAddress Conversion Performs an implicit conversion from String to MapiElectronicAddress.

See Also

MapiElectronicAddress Class | MapiElectronicAddress Members | Aspose.Email.Outlook Namespace


MapiElectronicAddress Implicit String to MapiElectronicAddress Conversion

Performs an implicit conversion from String to MapiElectronicAddress.

public static implicit operator MapiElectronicAddress(
string emailAddress
);

Parameters

emailAddress
The email address.

Return Value

The result of the conversion.

See Also

MapiElectronicAddress Class | Aspose.Email.Outlook Namespace


MapiJournal Class

Represents the Outlook Journal object.

For a list of all members of this type, see MapiJournal Members.

System.Object
Aspose.Email.Outlook.MapiJournal

public sealed class MapiJournal : IMapiMessageItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiJournal Members | Aspose.Email.Outlook Namespace


MapiJournal Members

MapiJournal overview

Public Instance Constructors

MapiJournal Overloaded. Initializes a new instance of the MapiJournal class.

Public Instance Properties

Body | Gets message body.
BriefDescription | Gets or sets the brief description of activity that is being recorded.
Description | Gets or sets the description of activity that is being recorded.
DocumentStatus | Gets or sets the status of document.
Duration | Gets the duration of the activity.
EndTime | Gets or sets the time at which the activity ended.
Flags | Gets or sets a flags that contains metadata about the Journal object.
MessageClass | Gets message class.
StartTime | Gets or sets the time at which the activity began.
Subject | Gets message subject.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MapiJournal Class | Aspose.Email.Outlook Namespace


MapiJournal Constructor

Initializes a new instance of the MapiJournal class.

Overload List

Initializes a new instance of the MapiJournal class.

public MapiJournal();

Initializes a new instance of the MapiJournal class.

public MapiJournal(string,string,string,string);

See Also

MapiJournal Class | Aspose.Email.Outlook Namespace


MapiJournal Constructor ()

Initializes a new instance of the MapiJournal class.

public MapiJournal();

See Also

MapiJournal Class | Aspose.Email.Outlook Namespace | MapiJournal Constructor Overload List


MapiJournal Constructor (String, String, String, String)

Initializes a new instance of the MapiJournal class.

public MapiJournal(
string subject,
string body,
string description,
string briefDescription
);

Parameters

subject
The subject.
body
The message body.
description
The description.
briefDescription
The brief description.

See Also

MapiJournal Class | Aspose.Email.Outlook Namespace | MapiJournal Constructor Overload List


MapiJournal Properties

The properties of the MapiJournal class are listed below. For a complete list of MapiJournal class members, see the MapiJournal Members topic.

Public Instance Properties

Body | Gets message body.
BriefDescription | Gets or sets the brief description of activity that is being recorded.
Description | Gets or sets the description of activity that is being recorded.
DocumentStatus | Gets or sets the status of document.
Duration | Gets the duration of the activity.
EndTime | Gets or sets the time at which the activity ended.
Flags | Gets or sets a flags that contains metadata about the Journal object.
MessageClass | Gets message class.
StartTime | Gets or sets the time at which the activity began.
Subject | Gets message subject.

See Also

MapiJournal Class | Aspose.Email.Outlook Namespace


Body Property

Aspose.Email

MapiJournal.Body Property

Gets message body.

public string Body {get; set;}

Property Value

The message body.

Implements

IMapiMessageItem.Body

See Also

MapiJournal Class | Aspose.Email.Outlook Namespace


BriefDescription Property

Aspose.Email

MapiJournal.BriefDescription Property

Gets or sets the brief description of activity that is being recorded.

public string BriefDescription {get; set;}

Property Value

The string that represents activity.

See Also

MapiJournal Class | Aspose.Email.Outlook Namespace


Description Property

Aspose.Email

MapiJournal.Description Property

Gets or sets the description of activity that is being recorded.

public string Description {get; set;}

Property Value

The string that represents activity.

See Also

MapiJournal Class | Aspose.Email.Outlook Namespace


DocumentStatus Property

Aspose.Email

MapiJournal.DocumentStatus Property

Gets or sets the status of document.

public MapiJournalDocumentStatus DocumentStatus {get; set;}

Property Value

The document status.

See Also

MapiJournal Class | Aspose.Email.Outlook Namespace


Duration Property

Aspose.Email

MapiJournal.Duration Property

Gets the duration of the activity.

public TimeSpan Duration {get;}

Property Value

The value that represents duration of the activity.

See Also

MapiJournal Class | Aspose.Email.Outlook Namespace


EndTime Property

Aspose.Email

MapiJournal.EndTime Property

Gets or sets the time at which the activity ended.

public DateTime EndTime {get; set;}

Property Value

The value that represents time at which the activity ended.

Exceptions

Exception Type | Condition
ArgumentException | trows when start time is less than end time.

See Also

MapiJournal Class | Aspose.Email.Outlook Namespace


Flags Property

Aspose.Email

MapiJournal.Flags Property

Gets or sets a flags that contains metadata about the Journal object.

public MapiJournalFlags Flags {get; set;}

Property Value

The journal flags.

See Also

MapiJournal Class | Aspose.Email.Outlook Namespace


MessageClass Property

Aspose.Email

MapiJournal.MessageClass Property

Gets message class.

public string MessageClass {get;}

Property Value

String that represents message class.

Implements

IMapiMessageItem.MessageClass

See Also

MapiJournal Class | Aspose.Email.Outlook Namespace


StartTime Property

Aspose.Email

MapiJournal.StartTime Property

Gets or sets the time at which the activity began.

public DateTime StartTime {get; set;}

Property Value

The value that represents time at which the activity began.

Exceptions

Exception Type | Condition
ArgumentException | trows when start time is less than end time.

See Also

MapiJournal Class | Aspose.Email.Outlook Namespace


Subject Property

Aspose.Email

MapiJournal.Subject Property

Gets message subject.

public string Subject {get; set;}

Property Value

The message subject.

Implements

IMapiMessageItem.Subject

See Also

MapiJournal Class | Aspose.Email.Outlook Namespace


MapiJournalDocumentStatus Enumeration

Indicates the status of document.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum MapiJournalDocumentStatus

Members

Member Name | Description | Value
None | The document has not any status. | 0
Printed | Indicates whether the document was printed during journaling. | 1
Saved | Indicates whether the document was saved during journaling. | 2
Routed | Indicates whether the document was sent to a routing recipient during journaling. | 4
Posted | Indicates whether the document was sent by e-mail or posted to a server folder during journaling. | 8

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Outlook Namespace


MapiJournalFlags Enumeration

Contains metadata about the Journal object. Must be either zero or the following values.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum MapiJournalFlags

Members

Member Name | Description | Value
None | The Journal object has no journal-associated attachment. | 0
HasAttachment | The Journal object has a journal-associated attachment. | 1073741824

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Outlook Namespace


MapiMessage Class

Represents an Outlook Message format document that can be parsed.

For a list of all members of this type, see MapiMessage Members.

System.Object
Aspose.Email.Outlook.MapiPropertyContainer
Aspose.Email.Outlook.MapiMessage

public sealed class MapiMessage : MapiPropertyContainer, IMapiMessageItem, ICloneable, IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Instances of the MapiMessage class are used to represent Microsoft Outlook Message document files that are parsed by MapiMessageReader class. To access the sender, recipient, and contents of an e-mail message, use the associated properties of the MapiMessage class.

Example

The following exmaple demonstrates how to read Outlook Message files.

[C#]

[Visual Basic]

Requirements
Namespace:  Aspose.Email.Outlook
Assembly: Aspose.Email (in Aspose.Email.dll)

See Also
MapiMessage Members | Aspose.Email.Outlook Namespace


MapiMessage Members

MapiMessage overview

Public Static Methods

DestroyAttachments | Destroies the attachments in the specified Outlook Message files. DestroyAttachments will ignore the attachment parsing.
FromFile | Create an instance of MapiMessage from the specified file.
FromMailMessage | Overloaded. Creates an instance of MapiMessage from the MailMessage.
FromProperties | Creates an instance of MapiMessage from a collection of Mapi properties.
FromStream | Create an instance of MapiMessage from the specified stream.
IsMsgFormat | Overloaded. Determines whether the specified file has a MSG format.
LoadFromTnef | Overloaded. Loads message from Transport Neutral Encapsulation Format (TNEF) data structure
RemoveAttachments | Removes all of the attachments from the specified Outlook Message files.

Public Instance Constructors

MapiMessage Overloaded. Initializes a new instance of the MapiMessage class.

Public Instance Properties

Attachments | Gets the attachments in the message.
Body | Gets the message text.
BodyHtml | Gets the BodyRtf of the message converted to HTML, if present, otherwise an empty string.
BodyRtf | Gets or sets the RTF formatted message text.
BodyType | Gets the type of the body.
ClientSubmitTime | Gets or sets the date and time the message sender submitted a message.
CodePage (inherited from MapiPropertyContainer) | Gets the code page.
ConversationTopic | Gets the topic of the first message in a conversation thread.
DeliveryTime | Gets or sets the date and time a message was delivered.
DisplayBcc | Gets a list of the display names of any blind carbon copy (BCC) message recipients, separated by semicolons (;).
DisplayCc | Gets a list of the display names of any carbon copy (CC) message recipients, separated by semicolons (;).
DisplayName | Gets the display name for the message.
DisplayNamePrefix | Gets a prefix of the display name.
DisplayTo | Gets a list of the display names of the primary (To) message recipients, separated by semicolons (;).
Flags | Gets the message flags.
Headers | Gets the transport message headers
InternetMessageId | Gets the message id of the message.
MessageClass | Gets a case-sensitive string that identifies the sender-defined message class, such as IPM.Note. The message class specifies the type, purpose, or content of the message.
NamedProperties | Gets the named properties of message.
NamedPropertyMapping | Gets the named property mapping.
NormalizedSubject | Gets normalized subject of the message.
Properties (inherited from MapiPropertyContainer) | Gets the collection of properties.
PropertyStream | Gets the property stream.
Recipients | Gets the recipients of the message.
ReplyTo | Gets or sets the reply to names.
SenderAddressType | Gets the message sender's e-mail address type.
SenderEmailAddress | Gets or sets the message sender's e-mail address.
SenderName | Gets or sets the message sender's display name.
SentRepresentingAddressType | Gets the address type for the messaging user represented by the sender.
SentRepresentingEmailAddress | Gets or sets the e-mail address for the messaging user represented by the sender.
SentRepresentingName | Gets or sets the display name for the messaging user represented by the sender.
Subject | Gets or sets the subject of the message.
SubjectPrefix | Gets a subject prefix that typically indicates some action on a message, such as "FW: " for forwarding.
SubStorages | Gets the sub storages.
TransportMessageHeaders | Gets the transport-specific message envelope information.

Public Instance Methods

AddCustomProperty | Adds the custom property.
Clone | Creates a new object that is a copy of the current instance.
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPropertyBoolean (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Boolean type.
GetPropertyBytes (inherited from MapiPropertyContainer) | Gets the string value of the property specified by tag.
GetPropertyDateTime (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as DateTime type.
GetPropertyInt32 (inherited from MapiPropertyContainer) | Gets the int32 value of the property specified by tag.
GetPropertyLong (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Long (int64) type.
GetPropertyShort (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Short type.
GetPropertyString (inherited from MapiPropertyContainer) | Overloaded. Gets the string value of the property specified by tag.
GetType (inherited from Object) | Gets the Type of the current instance.
IsStoreUnicodeOk (inherited from MapiPropertyContainer) | Determines if string properties are Unicode encoded or not.
Save | Overloaded. Saves the specified file name.
SaveAsTnef | Overloaded. Save message in TNEF format.
SetBodyContent | Sets the content of the body.
SetMessageFlags | Sets the message flags.
SetProperty | Sets the property.
SetStringPropertyValue | Sets the string property value.
ToMapiMessageItem | Convert MapiMessage to IMapiMessageItem object in dependence with MessageClass.
ToString (inherited from Object) | Returns a String that represents the current Object.
TryGetPropertyData (inherited from MapiPropertyContainer) | Try to get the property data with specified tag key.
TryGetPropertyDateTime (inherited from MapiPropertyContainer) |
TryGetPropertyInt32 (inherited from MapiPropertyContainer) |
TryGetPropertyLong (inherited from MapiPropertyContainer) |
TryGetPropertyString (inherited from MapiPropertyContainer) | Overloaded. Try to get a property data as string with specified tag and code page.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


MapiMessage Constructor

Initializes a new instance of the MapiMessage class.

Overload List

Initializes a new instance of the MapiMessage class.

public MapiMessage();

Initializes a new instance of the MapiMessage class.

public MapiMessage(string,string,string,string);

Initializes a new instance of the MapiMessage class.

public MapiMessage(string,string,string,string,OutlookMessageFormat);

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


MapiMessage Constructor ()

Initializes a new instance of the MapiMessage class.

public MapiMessage();

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace | MapiMessage Constructor Overload List


MapiMessage Constructor (String, String, String, String, OutlookMessageFormat)

Initializes a new instance of the MapiMessage class.

public MapiMessage(
string from,
string to,
string subject,
string body,
OutlookMessageFormat format
);

Parameters

from
The From address.
to
The addresses of recipients. Note, that addresses are separated by semicolon.
subject
The message subject.
body
The message body.
format
Defines whether to use Unicode or ASCII encoding for this message.

Exceptions

Exception Type | Condition
ArgumentNullException | Is being thrown if address of recipient is null or empty.
ArgumentException | Is being thrown if sender or recipient address is not in a recognized format.
InvalidEnumArgumentException | Is being thrown if format parameter is not a valid enumeration member.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace | MapiMessage Constructor Overload List


MapiMessage Constructor (String, String, String, String)

Initializes a new instance of the MapiMessage class.

public MapiMessage(
string from,
string to,
string subject,
string body
);

Parameters

from
The From address.
to
The addresses of recipients. Note, that addresses are separated by semicolon.
subject
The message subject.
body
The message body.

Exceptions

Exception Type | Condition
ArgumentNullException | throws if address of recipient is null or empty.
ArgumentException | throws if sender or recipient address is not in a recognized format.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace | MapiMessage Constructor Overload List


MapiMessage Properties

The properties of the MapiMessage class are listed below. For a complete list of MapiMessage class members, see the MapiMessage Members topic.

Public Instance Properties

Attachments | Gets the attachments in the message.
Body | Gets the message text.
BodyHtml | Gets the BodyRtf of the message converted to HTML, if present, otherwise an empty string.
BodyRtf | Gets or sets the RTF formatted message text.
BodyType | Gets the type of the body.
ClientSubmitTime | Gets or sets the date and time the message sender submitted a message.
CodePage (inherited from MapiPropertyContainer) | Gets the code page.
ConversationTopic | Gets the topic of the first message in a conversation thread.
DeliveryTime | Gets or sets the date and time a message was delivered.
DisplayBcc | Gets a list of the display names of any blind carbon copy (BCC) message recipients, separated by semicolons (;).
DisplayCc | Gets a list of the display names of any carbon copy (CC) message recipients, separated by semicolons (;).
DisplayName | Gets the display name for the message.
DisplayNamePrefix | Gets a prefix of the display name.
DisplayTo | Gets a list of the display names of the primary (To) message recipients, separated by semicolons (;).
Flags | Gets the message flags.
Headers | Gets the transport message headers
InternetMessageId | Gets the message id of the message.
MessageClass | Gets a case-sensitive string that identifies the sender-defined message class, such as IPM.Note. The message class specifies the type, purpose, or content of the message.
NamedProperties | Gets the named properties of message.
NamedPropertyMapping | Gets the named property mapping.
NormalizedSubject | Gets normalized subject of the message.
Properties (inherited from MapiPropertyContainer) | Gets the collection of properties.
PropertyStream | Gets the property stream.
Recipients | Gets the recipients of the message.
ReplyTo | Gets or sets the reply to names.
SenderAddressType | Gets the message sender's e-mail address type.
SenderEmailAddress | Gets or sets the message sender's e-mail address.
SenderName | Gets or sets the message sender's display name.
SentRepresentingAddressType | Gets the address type for the messaging user represented by the sender.
SentRepresentingEmailAddress | Gets or sets the e-mail address for the messaging user represented by the sender.
SentRepresentingName | Gets or sets the display name for the messaging user represented by the sender.
Subject | Gets or sets the subject of the message.
SubjectPrefix | Gets a subject prefix that typically indicates some action on a message, such as "FW: " for forwarding.
SubStorages | Gets the sub storages.
TransportMessageHeaders | Gets the transport-specific message envelope information.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


Attachments Property

Aspose.Email

MapiMessage.Attachments Property

Gets the attachments in the message.

public MapiAttachmentCollection Attachments {get;}

Property Value

The attachment collection.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


Body Property

Aspose.Email

MapiMessage.Body Property

Gets the message text.

public string Body {get;}

Property Value

The string that represents message body.

Implements

IMapiMessageItem.Body

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


BodyHtml Property

Aspose.Email

MapiMessage.BodyHtml Property

Gets the BodyRtf of the message converted to HTML, if present, otherwise an empty string.

public string BodyHtml {get;}

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


BodyRtf Property

Aspose.Email

MapiMessage.BodyRtf Property

Gets or sets the RTF formatted message text.

public string BodyRtf {get; set;}

Property Value

The string that represents message body rtf.

Remarks

When setting a value, the values of PR_RTF_COMPRESSED, PR_RTF_DECOMPRESSES, PR_BODY properties are updated. A string value being set must have RTF format. Thus, if it is necessary to set a value in HTML format, the value must be first to encoded within RTF, according to RTF Extensions Specification. To set the content of the body message in HTML or Plain Text formats quickly, please, use SetBodyContent method. When setting a null value or empty string, the values of BodyRtf and Body properties are set null.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


BodyType Property

Aspose.Email

MapiMessage.BodyType Property

Gets the type of the body.

public BodyContentType BodyType {get;}

Property Value

The type of the body.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


ClientSubmitTime Property

Aspose.Email

MapiMessage.ClientSubmitTime Property

Gets or sets the date and time the message sender submitted a message.

public DateTime ClientSubmitTime {get; set;}

Property Value

The DateTime that represents client submit time.

Remarks

If the property was not available, DateTime.MinValue is returned.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


ConversationTopic Property

Aspose.Email

MapiMessage.ConversationTopic Property

Gets the topic of the first message in a conversation thread.

public string ConversationTopic {get;}

Property Value

The string that represens conversation topic.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


DeliveryTime Property

Aspose.Email

MapiMessage.DeliveryTime Property

Gets or sets the date and time a message was delivered.

public DateTime DeliveryTime {get; set;}

Property Value

The DateTime that represents delivery time.

Remarks

If the property was not available, DateTime.MinValue is returned.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


DisplayBcc Property

Aspose.Email

MapiMessage.DisplayBcc Property

Gets a list of the display names of any blind carbon copy (BCC) message recipients, separated by semicolons (;).

public string DisplayBcc {get;}

Property Value

The string that represents display bcc.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


DisplayCc Property

Aspose.Email

MapiMessage.DisplayCc Property

Gets a list of the display names of any carbon copy (CC) message recipients, separated by semicolons (;).

public string DisplayCc {get;}

Property Value

The string that represents display cc.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


DisplayName Property

Aspose.Email

MapiMessage.DisplayName Property

Gets the display name for the message.

public string DisplayName {get;}

Property Value

The string that represents display name.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


DisplayNamePrefix Property

Aspose.Email

MapiMessage.DisplayNamePrefix Property

Gets a prefix of the display name.

public string DisplayNamePrefix {get;}

Property Value

The string that represents display name prefix.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


DisplayTo Property

Aspose.Email

MapiMessage.DisplayTo Property

Gets a list of the display names of the primary (To) message recipients, separated by semicolons (;).

public string DisplayTo {get;}

Property Value

The string that represents display to.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


Flags Property

Aspose.Email

MapiMessage.Flags Property

Gets the message flags.

public MapiMessageFlags Flags {get;}

Property Value

The message flags.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


Headers Property

Aspose.Email

MapiMessage.Headers Property

Gets the transport message headers

public HeaderCollection Headers {get;}

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


InternetMessageId Property

Aspose.Email

MapiMessage.InternetMessageId Property

Gets the message id of the message.

public string InternetMessageId {get;}

Property Value

The string that represents internet message id.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


MessageClass Property

Aspose.Email

MapiMessage.MessageClass Property

Gets a case-sensitive string that identifies the sender-defined message class, such as IPM.Note. The message class specifies the type, purpose, or content of the message.

public string MessageClass {get;}

Property Value

The string that represents message class.

Implements

IMapiMessageItem.MessageClass

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


NamedProperties Property

Aspose.Email

MapiMessage.NamedProperties Property

Gets the named properties of message.

public MapiPropertyCollection NamedProperties {get;}

Property Value

The collection of named properties.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


NamedPropertyMapping Property

Aspose.Email

MapiMessage.NamedPropertyMapping Property

Gets the named property mapping.

public MapiNamedPropertyMappingStorage NamedPropertyMapping {get;}

Property Value

The named property mapping.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


NormalizedSubject Property

Aspose.Email

MapiMessage.NormalizedSubject Property

Gets normalized subject of the message.

public string NormalizedSubject {get;}

Property Value

The string that represents normalized subject.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


PropertyStream Property

Aspose.Email

MapiMessage.PropertyStream Property

Gets the property stream.

public MapiPropertyStream PropertyStream {get;}

Property Value

The property stream.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


Recipients Property

Aspose.Email

MapiMessage.Recipients Property

Gets the recipients of the message.

public MapiRecipientCollection Recipients {get;}

Property Value

The collection of recipients.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


ReplyTo Property

Aspose.Email

MapiMessage.ReplyTo Property

Gets or sets the reply to names.

public string ReplyTo {get; set;}

Property Value

The reply to names.

Remarks

Gets or sets the list of ReplyTo addresses separated by semicolon.

Exceptions

Exception Type | Condition
ArgumentNullException | throws if reply to address is null.
ArgumentException | throws if reply to address is not in a recognized format.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


SenderAddressType Property

Aspose.Email

MapiMessage.SenderAddressType Property

Gets the message sender's e-mail address type.

public string SenderAddressType {get;}

Property Value

The string that represents sender address type.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


SenderEmailAddress Property

Aspose.Email

MapiMessage.SenderEmailAddress Property

Gets or sets the message sender's e-mail address.

public string SenderEmailAddress {get; set;}

Property Value

The string that represents sender email address.

Remarks

When setting a value, the values of PR_SENDER_SEARCH_KEY and PR_SENDER_ENTRYID properties are updated as well. When setting a null value or empty string, the values of properties are set null.

Exceptions

Exception Type | Condition
ArgumentException | throws if sender address is not in a recognized format.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


SenderName Property

Aspose.Email

MapiMessage.SenderName Property

Gets or sets the message sender's display name.

public string SenderName {get; set;}

Property Value

The the string that represents sender name.

Remarks

When setting a null value or empty string, the values of the property get the value equal to SenderEmailAddress.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


SentRepresentingAddressType Property

Aspose.Email

MapiMessage.SentRepresentingAddressType Property

Gets the address type for the messaging user represented by the sender.

public string SentRepresentingAddressType {get;}

Property Value

The string that represents sent representing address type.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


SentRepresentingEmailAddress Property

Aspose.Email

MapiMessage.SentRepresentingEmailAddress Property

Gets or sets the e-mail address for the messaging user represented by the sender.

public string SentRepresentingEmailAddress {get; set;}

Property Value

The string that represents sent representing email address.

Remarks

When setting a value, the values of PR_SENT_REPRESENTING_SEARCH_KEY and PR_SENT_REPRESENTING_ENTRYID properties are updated as well. When setting a null value or empty string, the values of the property are set null.

Exceptions

Exception Type | Condition
ArgumentException | throws if email address is not in a recognized format.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


SentRepresentingName Property

Aspose.Email

MapiMessage.SentRepresentingName Property

Gets or sets the display name for the messaging user represented by the sender.

public string SentRepresentingName {get; set;}

Property Value

The string that represents sent representing name.

Remarks

When setting a null value or empty string, the values of the property are set in SentRepresentingEmailAddress.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


Subject Property

Aspose.Email

MapiMessage.Subject Property

Gets or sets the subject of the message.

public string Subject {get; set;}

Property Value

The string that represents message subject.

Implements

IMapiMessageItem.Subject

Remarks

When setting a value, the values of SubjectPrefix(PR_SUBJECT_PREFIX) and NormalizedSubject(PR_NORMALIZED_SUBJECT) properties are updated as well. If Subject has no prefix, the value of SubjectPrefix property is set null. When setting a null value or empty string, the values of Subject, SubjectPrefix, NormalizedSubject properties are set null.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


SubjectPrefix Property

Aspose.Email

MapiMessage.SubjectPrefix Property

Gets a subject prefix that typically indicates some action on a message, such as "FW: " for forwarding.

public string SubjectPrefix {get;}

Property Value

The string that represents subject prefix.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


SubStorages Property

Aspose.Email

MapiMessage.SubStorages Property

Gets the sub storages.

public MapiPropertyCollection SubStorages {get;}

Property Value

The sub storages.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


TransportMessageHeaders Property

Aspose.Email

MapiMessage.TransportMessageHeaders Property

Gets the transport-specific message envelope information.

public string TransportMessageHeaders {get;}

Property Value

The string that represents transport message headers.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


MapiMessage Methods

The methods of the MapiMessage class are listed below. For a complete list of MapiMessage class members, see the MapiMessage Members topic.

Public Static Methods

DestroyAttachments | Destroies the attachments in the specified Outlook Message files. DestroyAttachments will ignore the attachment parsing.
FromFile | Create an instance of MapiMessage from the specified file.
FromMailMessage | Overloaded. Creates an instance of MapiMessage from the MailMessage.
FromProperties | Creates an instance of MapiMessage from a collection of Mapi properties.
FromStream | Create an instance of MapiMessage from the specified stream.
IsMsgFormat | Overloaded. Determines whether the specified file has a MSG format.
LoadFromTnef | Overloaded. Loads message from Transport Neutral Encapsulation Format (TNEF) data structure
RemoveAttachments | Removes all of the attachments from the specified Outlook Message files.

Public Instance Methods

AddCustomProperty | Adds the custom property.
Clone | Creates a new object that is a copy of the current instance.
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPropertyBoolean (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Boolean type.
GetPropertyBytes (inherited from MapiPropertyContainer) | Gets the string value of the property specified by tag.
GetPropertyDateTime (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as DateTime type.
GetPropertyInt32 (inherited from MapiPropertyContainer) | Gets the int32 value of the property specified by tag.
GetPropertyLong (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Long (int64) type.
GetPropertyShort (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Short type.
GetPropertyString (inherited from MapiPropertyContainer) | Overloaded. Gets the string value of the property specified by tag.
GetType (inherited from Object) | Gets the Type of the current instance.
IsStoreUnicodeOk (inherited from MapiPropertyContainer) | Determines if string properties are Unicode encoded or not.
Save | Overloaded. Saves the specified file name.
SaveAsTnef | Overloaded. Save message in TNEF format.
SetBodyContent | Sets the content of the body.
SetMessageFlags | Sets the message flags.
SetProperty | Sets the property.
SetStringPropertyValue | Sets the string property value.
ToMapiMessageItem | Convert MapiMessage to IMapiMessageItem object in dependence with MessageClass.
ToString (inherited from Object) | Returns a String that represents the current Object.
TryGetPropertyData (inherited from MapiPropertyContainer) | Try to get the property data with specified tag key.
TryGetPropertyDateTime (inherited from MapiPropertyContainer) |
TryGetPropertyInt32 (inherited from MapiPropertyContainer) |
TryGetPropertyLong (inherited from MapiPropertyContainer) |
TryGetPropertyString (inherited from MapiPropertyContainer) | Overloaded. Try to get a property data as string with specified tag and code page.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


MapiMessage.AddCustomProperty Method

Adds the custom property.

public void AddCustomProperty(
MapiProperty property,
string stringNameId
);

Parameters

property
The propertyMapiProperty.
stringNameId
The name of propertyString.

Exceptions

Exception Type | Condition
ArgumentNullException | If property is null.
ArgumentException | If property data is null.
NotSupportedException | If data type is not supported yet.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


MapiMessage.Clone Method

Creates a new object that is a copy of the current instance.

public object Clone();

Return Value

A new object that is a copy of this instance.

Implements

ICloneable.Clone

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


MapiMessage.DestroyAttachments Method

Destroies the attachments in the specified Outlook Message files. DestroyAttachments will ignore the attachment parsing.

public static void DestroyAttachments(
string path
);

Parameters

path
The name of the Outlook Message file.

Example

The following exmaple demonstrates how to destroy attachments in Outlook Message files.

[C#]

[Visual Basic]

See Also
MapiMessage Class | Aspose.Email.Outlook Namespace


MapiMessage.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

public void Dispose();

Implements

IDisposable.Dispose

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


MapiMessage.FromFile Method

Create an instance of MapiMessage from the specified file.

public static MapiMessage FromFile(
string path
);

Parameters

path
The name of the file to be loaded.

Return Value

Returns a MapiMessage instance which is loaded from the specified file.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


FromMailMessage Method

Aspose.Email

MapiMessage.FromMailMessage Method

Creates an instance of MapiMessage from the MailMessage.

Overload List

Creates an instance of MapiMessage from the MailMessage.

public static MapiMessage FromMailMessage(MailMessage);

Creates an instance of MapiMessage from the MailMessage.

public static MapiMessage FromMailMessage(MailMessage,OutlookMessageFormat);

Creates an instance of MapiMessage from the MailMessage.

public static MapiMessage FromMailMessage(MailMessage,OutlookMessageFormat,bool);

Creates an instance of MapiMessage from the MailMessage.

public static MapiMessage FromMailMessage(string);

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


MapiMessage.FromMailMessage Method (MailMessage)

Creates an instance of MapiMessage from the MailMessage.

public static MapiMessage FromMailMessage(
MailMessage message
);

Parameters

message
The MailMessage.

Return Value

Returns a MapiMessage instance which is loaded from the MailMessage.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace | MapiMessage.FromMailMessage Overload List


MapiMessage.FromMailMessage Method (MailMessage, OutlookMessageFormat)

Creates an instance of MapiMessage from the MailMessage.

public static MapiMessage FromMailMessage(
MailMessage message,
OutlookMessageFormat format
);

Parameters

message
The MailMessage.
format
The message format.

Return Value

MapiMessage that represents Outlook message.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace | MapiMessage.FromMailMessage Overload List


MapiMessage.FromMailMessage Method (MailMessage, OutlookMessageFormat, Boolean)

Creates an instance of MapiMessage from the MailMessage.

public static MapiMessage FromMailMessage(
MailMessage message,
OutlookMessageFormat format,
bool preserveSignature
);

Parameters

message
The MailMessage.
format
The message format.
preserveSignature
Set to true, if signature is to be preserved.

Return Value

MapiMessage that represents Outlook message.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace | MapiMessage.FromMailMessage Overload List


MapiMessage.FromMailMessage Method (String)

Creates an instance of MapiMessage from the MailMessage.

public static MapiMessage FromMailMessage(
string fileName
);

Parameters

fileName
The file name of MailMessage.

Return Value

Returns a MapiMessage instance which is loaded from the MailMessage.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace | MapiMessage.FromMailMessage Overload List


MapiMessage.FromProperties Method

Creates an instance of MapiMessage from a collection of Mapi properties.

public static MapiMessage FromProperties(
MapiPropertyCollection properties
);

Parameters

properties
A collection of MapiProperty.

Return Value

Returns a MapiMessage instance which is loaded from the specified properties.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


MapiMessage.FromStream Method

Create an instance of MapiMessage from the specified stream.

public static MapiMessage FromStream(
Stream stream
);

Parameters

stream
The stream to be loaded.

Return Value

Returns a MapiMessage instance which is loaded from the specified stream.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


IsMsgFormat Method

Aspose.Email

MapiMessage.IsMsgFormat Method

Determines whether the specified stream has a MSG format.

Overload List

Determines whether the specified stream has a MSG format.

public static bool IsMsgFormat(Stream);

Determines whether the specified file has a MSG format.

public static bool IsMsgFormat(string);

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


MapiMessage.IsMsgFormat Method (Stream)

Determines whether the specified stream has a MSG format.

public static bool IsMsgFormat(
Stream stream
);

Parameters

stream
The message stream.

Return Value

true if the stream is represented in MSG format]; otherwise, false.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace | MapiMessage.IsMsgFormat Overload List


MapiMessage.IsMsgFormat Method (String)

Determines whether the specified file has a MSG format.

public static bool IsMsgFormat(
string fileName
);

Parameters

fileName
Name of the file.

Return Value

true if the file is represented in MSG format; otherwise, false.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace | MapiMessage.IsMsgFormat Overload List


LoadFromTnef Method

Aspose.Email

MapiMessage.LoadFromTnef Method

Loads message from Transport Neutral Encapsulation Format (TNEF) data structure

Overload List

Loads message from Transport Neutral Encapsulation Format (TNEF) data structure

public static MapiMessage LoadFromTnef(Stream);

Loads message from Transport Neutral Encapsulation Format (TNEF) data structure

public static MapiMessage LoadFromTnef(string);

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


MapiMessage.LoadFromTnef Method (Stream)

Loads message from Transport Neutral Encapsulation Format (TNEF) data structure

public static MapiMessage LoadFromTnef(
Stream stream
);

Parameters

stream
A stream representing message data in TNEF format

Return Value

A read MapiMessage

Exceptions

Exception Type | Condition
ArgumentNullException | stream is null
NotSupportedException | stream does not support reading

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace | MapiMessage.LoadFromTnef Overload List


MapiMessage.LoadFromTnef Method (String)

Loads message from Transport Neutral Encapsulation Format (TNEF) data structure

public static MapiMessage LoadFromTnef(
string fileName
);

Parameters

fileName
Name of file containing message data in TNEF format

Return Value

A read MapiMessage

Exceptions

Exception Type | Condition
ArgumentException | fileName is null or empty

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace | MapiMessage.LoadFromTnef Overload List


MapiMessage.RemoveAttachments Method

Removes all of the attachments from the specified Outlook Message files.

public static MapiAttachmentCollection RemoveAttachments(
string path
);

Parameters

path
The name of the Outlook Message file.

Return Value

The attachments collection.

Example

The following exmaple demonstrates how to destroy attachments in Outlook Message files.

[C#]

[Visual Basic]

See Also
MapiMessage Class | Aspose.Email.Outlook Namespace


Save Method

Aspose.Email

MapiMessage.Save Method

Saves the specified stream.

Overload List

Saves the specified stream.

public void Save(Stream);

Saves the specified file name.

public void Save(string);

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


MapiMessage.Save Method (Stream)

Saves the specified stream.

public void Save(
Stream stream
);

Parameters

stream
The stream.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace | MapiMessage.Save Overload List


MapiMessage.Save Method (String)

Saves the specified file name.

public void Save(
string fileName
);

Parameters

fileName
Name of the file.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace | MapiMessage.Save Overload List


SaveAsTnef Method

Aspose.Email

MapiMessage.SaveAsTnef Method

Save message in TNEF format.

Overload List

Save message in TNEF format.

public void SaveAsTnef(Stream);

Save message in TNEF format.

public void SaveAsTnef(string);

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


MapiMessage.SaveAsTnef Method (Stream)

Save message in TNEF format.

public void SaveAsTnef(
Stream stream
);

Parameters

stream
The stream where a message will be saved to.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace | MapiMessage.SaveAsTnef Overload List


MapiMessage.SaveAsTnef Method (String)

Save message in TNEF format.

public void SaveAsTnef(
string fileName
);

Parameters

fileName
Name of the file where a message will be saved to.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace | MapiMessage.SaveAsTnef Overload List


MapiMessage.SetBodyContent Method

Sets the content of the body.

public void SetBodyContent(
string content,
BodyContentType contentType
);

Parameters

content
The content.
contentType
Type of the content.

Remarks

It is provided for setting of the content of the body message in RTF, HTML or Plain Text formats. When setting a value, the values of PR_RTF_COMPRESSED, PR_RTF_DECOMPRESSES, PR_BODY properties are updated as well. Note, after the value in HTML format is set, BodyRtf property returns the value which is encoded within RTF.

Exceptions

Exception Type | Condition
ArgumentNullException | throws if the specified content string is null or empty.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


MapiMessage.SetMessageFlags Method

Sets the message flags.

public void SetMessageFlags(
MapiMessageFlags flags
);

Parameters

flags
The message flags.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


MapiMessage.SetProperty Method

Sets the property.

public override void SetProperty(
MapiProperty property
);

Parameters

property
The property.

Exceptions

Exception Type | Condition
ArgumentNullException | If property is null.
ArgumentException | If property data is null.
InvalidOperationException | If data type is not supported.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


MapiMessage.SetStringPropertyValue Method

Sets the string property value.

public void SetStringPropertyValue(
long tag,
string value
);

Parameters

tag
The property tag.
value
The property value.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


MapiMessage.ToMapiMessageItem Method

Convert MapiMessage to IMapiMessageItem object in dependence with MessageClass.

public IMapiMessageItem ToMapiMessageItem();

Return Value

The IMapiMessageItem interface.

Remarks

Note, that the following message classes are supported by now: IPM.Note, IPM.StickyNote, IPM.Contact, IPM.Activity, IPM.Appointment, IPM.Schedule.meeting, IPM.Task. If MapiMessage has another class, different from these ones, then NotSupportedException is thrown. If MessageClass is IPM.Note, then MapiMessage copy is returned.

Exceptions

Exception Type | Condition
NotSupportedException | Thrown when MessageClass doesn't belong to IPM.Note, IPM.StickyNote, IPM.Contact, IPM.Activity, IPM.Appointment, IPM.Schedule.meeting, IPM.Task.

See Also

MapiMessage Class | Aspose.Email.Outlook Namespace


MapiMessageFlags Enumeration

MapiMessageFlags.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum MapiMessageFlags

Members

Member Name | Description | Value
MSGFLAG_READ | The message is marked as having been read. | 1
MSGFLAG_UNMODIFIED | The message has not been modified since it was first saved (if unsent) or it was delivered (if sent). | 2
MSGFLAG_UNSENT | The message is still being composed. | 8
MSGFLAG_FROMME | The user receiving the message was also the user who sent the message. | 32
MSGFLAG_HASATTACH | The message has at least one attachment. | 16
MSGFLAG_ASSOCIATED | MSGFLAG_ASSOCIATED. | 64
MSGFLAG_RESEND | The message includes a request for a resend operation with a non-delivery report. | 128
MSGFLAG_NOTIFYREAD | The user who sent the message has requested notification when a recipient first reads it. | 256
MSGFLAG_NOTIFYUNREAD | The user who sent the message has requested notification when a recipient deletes it before reading or the Message object expires. | 512
MSGFLAG_EVERREAD | The message has been read at least once. This flag is set or cleared by the server whenever the MSGFLAG_READ flag is set or cleared. | 1024

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Outlook Namespace


MapiMessageParseException Class

This exception is thrown when errors occur in parsing MapiMessage.

For a list of all members of this type, see MapiMessageParseException Members.

System.Object
System.Exception
Aspose.Email.Outlook.MapiMessageParseException

public class MapiMessageParseException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiMessageParseException Members | Aspose.Email.Outlook Namespace


MapiMessageParseException Members

MapiMessageParseException overview

Public Instance Constructors

MapiMessageParseException Overloaded. Initializes a new instance of the MapiMessageParseException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

MapiMessageParseException Overloaded. Initializes a new instance of the MapiMessageParseException class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MapiMessageParseException Class | Aspose.Email.Outlook Namespace


MapiMessageParseException Constructor

Initializes a new instance of the MapiMessageParseException class.

Overload List

Initializes a new instance of the MapiMessageParseException class.

public MapiMessageParseException();

Initializes a new instance of the MapiMessageParseException class with serialized data.

protected MapiMessageParseException(SerializationInfo,StreamingContext);

Initializes a new instance of the MapiMessageParseException class.

public MapiMessageParseException(string);

Initializes a new instance of the MapiMessageParseException class.

public MapiMessageParseException(string,Exception);

See Also

MapiMessageParseException Class | Aspose.Email.Outlook Namespace


MapiMessageParseException Constructor ()

Initializes a new instance of the MapiMessageParseException class.

public MapiMessageParseException();

See Also

MapiMessageParseException Class | Aspose.Email.Outlook Namespace | MapiMessageParseException Constructor Overload List


MapiMessageParseException Constructor (String)

Initializes a new instance of the MapiMessageParseException class.

public MapiMessageParseException(
string message
);

Parameters

message
The error message.

See Also

MapiMessageParseException Class | Aspose.Email.Outlook Namespace | MapiMessageParseException Constructor Overload List


MapiMessageParseException Constructor (String, Exception)

Initializes a new instance of the MapiMessageParseException class.

public MapiMessageParseException(
string message,
Exception innerException
);

Parameters

message
The error message.
innerException
The inner exception.

See Also

MapiMessageParseException Class | Aspose.Email.Outlook Namespace | MapiMessageParseException Constructor Overload List


MapiMessageParseException Constructor (SerializationInfo, StreamingContext)

Initializes a new instance of the MapiMessageParseException class with serialized data.

protected MapiMessageParseException(
SerializationInfo info,
StreamingContext context
);

Parameters

info
The SerializationInfo that holds the serialized object data about the exception being thrown.
context
The StreamingContext that contains contextual information about the source or destination.

Exceptions

Exception Type | Condition
ArgumentNullException | The info parameter is null.
SerializationException | The class name is null or HResult is zero (0).

See Also

MapiMessageParseException Class | Aspose.Email.Outlook Namespace | MapiMessageParseException Constructor Overload List


MapiMessagePropertyStream Class

Represents the property stream.

For a list of all members of this type, see MapiMessagePropertyStream Members.

System.Object
Aspose.Email.Outlook.MapiPropertyContainer
Aspose.Email.Outlook.MapiPropertyStream
Aspose.Email.Outlook.MapiMessagePropertyStream

public class MapiMessagePropertyStream : MapiPropertyStream

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiMessagePropertyStream Members | Aspose.Email.Outlook Namespace


MapiMessagePropertyStream Members

MapiMessagePropertyStream overview

Public Instance Constructors

MapiMessagePropertyStream Constructor Initializes a new instance of the MapiMessagePropertyStream class.

Public Instance Properties

CodePage (inherited from MapiPropertyContainer) | Gets the code page.
Content (inherited from MapiPropertyStream) | Gets the content.
Name (inherited from MapiPropertyStream) | Gets the name.
Properties (inherited from MapiPropertyContainer) | Gets the collection of properties.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPropertyBoolean (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Boolean type.
GetPropertyBytes (inherited from MapiPropertyContainer) | Gets the string value of the property specified by tag.
GetPropertyDateTime (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as DateTime type.
GetPropertyInt32 (inherited from MapiPropertyContainer) | Gets the int32 value of the property specified by tag.
GetPropertyLong (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Long (int64) type.
GetPropertyShort (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Short type.
GetPropertyString (inherited from MapiPropertyContainer) | Overloaded. Gets the string value of the property specified by tag.
GetType (inherited from Object) | Gets the Type of the current instance.
IsStoreUnicodeOk (inherited from MapiPropertyContainer) | Determines if string properties are Unicode encoded or not.
SetProperty | Sets the property.
ToString (inherited from Object) | Returns a String that represents the current Object.
TryGetPropertyData (inherited from MapiPropertyContainer) | Try to get the property data with specified tag key.
TryGetPropertyDateTime (inherited from MapiPropertyContainer) |
TryGetPropertyInt32 (inherited from MapiPropertyContainer) |
TryGetPropertyLong (inherited from MapiPropertyContainer) |
TryGetPropertyString (inherited from MapiPropertyContainer) | Overloaded. Try to get a property data as string with specified tag and code page.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetContent |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MapiMessagePropertyStream Class | Aspose.Email.Outlook Namespace


MapiMessagePropertyStream Constructor

Initializes a new instance of the MapiMessagePropertyStream class.

public MapiMessagePropertyStream(
MapiMessage parent
);

Parameters

parent
The parent.

See Also

MapiMessagePropertyStream Class | Aspose.Email.Outlook Namespace


MapiMessagePropertyStream Methods

The methods of the MapiMessagePropertyStream class are listed below. For a complete list of MapiMessagePropertyStream class members, see the MapiMessagePropertyStream Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPropertyBoolean (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Boolean type.
GetPropertyBytes (inherited from MapiPropertyContainer) | Gets the string value of the property specified by tag.
GetPropertyDateTime (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as DateTime type.
GetPropertyInt32 (inherited from MapiPropertyContainer) | Gets the int32 value of the property specified by tag.
GetPropertyLong (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Long (int64) type.
GetPropertyShort (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Short type.
GetPropertyString (inherited from MapiPropertyContainer) | Overloaded. Gets the string value of the property specified by tag.
GetType (inherited from Object) | Gets the Type of the current instance.
IsStoreUnicodeOk (inherited from MapiPropertyContainer) | Determines if string properties are Unicode encoded or not.
SetProperty | Sets the property.
ToString (inherited from Object) | Returns a String that represents the current Object.
TryGetPropertyData (inherited from MapiPropertyContainer) | Try to get the property data with specified tag key.
TryGetPropertyDateTime (inherited from MapiPropertyContainer) |
TryGetPropertyInt32 (inherited from MapiPropertyContainer) |
TryGetPropertyLong (inherited from MapiPropertyContainer) |
TryGetPropertyString (inherited from MapiPropertyContainer) | Overloaded. Try to get a property data as string with specified tag and code page.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetContent |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MapiMessagePropertyStream Class | Aspose.Email.Outlook Namespace


MapiMessagePropertyStream.GetContent Method

protected override MemoryStream GetContent();

See Also

MapiMessagePropertyStream Class | Aspose.Email.Outlook Namespace


MapiMessagePropertyStream.SetProperty Method

Sets the property.

public override void SetProperty(
MapiProperty property
);

Parameters

property
The MapiProperty.

Exceptions

Exception Type | Condition
NotImplementedException |

See Also

MapiMessagePropertyStream Class | Aspose.Email.Outlook Namespace


MapiMessageReader Class

Represents a reader that can read a Microsoft Outlook Message format document.

For a list of all members of this type, see MapiMessageReader Members.

System.Object
Aspose.Email.Outlook.MapiMessageReader

public sealed class MapiMessageReader : IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiMessageReader Members | Aspose.Email.Outlook Namespace


MapiMessageReader Members

MapiMessageReader overview

Public Instance Constructors

MapiMessageReader Overloaded. Initializes a new instance of the MapiMessageReader class.

Public Instance Methods

Dispose | Releases the unmanaged resources used by the MapiMessageReader.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ReadAttachments | Extracts the attachment from the Outlook Message files.
ReadMessage | Parse the current stream and returns the data as a MapiMessage.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MapiMessageReader Class | Aspose.Email.Outlook Namespace


MapiMessageReader Constructor

Initializes a new instance of the MapiMessageReader class for the specified file name.

Overload List

Initializes a new instance of the MapiMessageReader class for the specified stream.

public MapiMessageReader(Stream);

Initializes a new instance of the MapiMessageReader class for the specified file name.

public MapiMessageReader(string);

See Also

MapiMessageReader Class | Aspose.Email.Outlook Namespace


MapiMessageReader Constructor (String)

Initializes a new instance of the MapiMessageReader class for the specified file name.

public MapiMessageReader(
string path
);

Parameters

path
The complete file path to be read.

See Also

MapiMessageReader Class | Aspose.Email.Outlook Namespace | MapiMessageReader Constructor Overload List


MapiMessageReader Constructor (Stream)

Initializes a new instance of the MapiMessageReader class for the specified stream.

public MapiMessageReader(
Stream stream
);

Parameters

stream
The stream to be read.

See Also

MapiMessageReader Class | Aspose.Email.Outlook Namespace | MapiMessageReader Constructor Overload List


MapiMessageReader Methods

The methods of the MapiMessageReader class are listed below. For a complete list of MapiMessageReader class members, see the MapiMessageReader Members topic.

Public Instance Methods

Dispose | Releases the unmanaged resources used by the MapiMessageReader.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ReadAttachments | Extracts the attachment from the Outlook Message files.
ReadMessage | Parse the current stream and returns the data as a MapiMessage.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MapiMessageReader Class | Aspose.Email.Outlook Namespace


MapiMessageReader.Dispose Method

Releases the unmanaged resources used by the MapiMessageReader.

public void Dispose();

Implements

IDisposable.Dispose

See Also

MapiMessageReader Class | Aspose.Email.Outlook Namespace


MapiMessageReader.ReadAttachments Method

Extracts the attachment from the Outlook Message files.

public MapiAttachmentCollection ReadAttachments();

Return Value

The Attachment collection.

See Also

MapiMessageReader Class | Aspose.Email.Outlook Namespace


MapiMessageReader.ReadMessage Method

Parse the current stream and returns the data as a MapiMessage.

public MapiMessage ReadMessage();

Return Value

The MapiMessage from the input stream.

See Also

MapiMessageReader Class | Aspose.Email.Outlook Namespace


MapiNamedProperty Class

Represents the data type of Named Property.

For a list of all members of this type, see MapiNamedProperty Members.

System.Object
Aspose.Email.Outlook.MapiProperty
Aspose.Email.Outlook.MapiNamedProperty

public sealed class MapiNamedProperty : MapiProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiNamedProperty Members | Aspose.Email.Outlook Namespace


MapiNamedProperty Members

MapiNamedProperty overview

Public Instance Constructors

MapiNamedProperty Constructor Initializes a new instance of the MapiNamedProperty class.

Public Instance Properties

Data (inherited from MapiProperty) | Gets the binary data.
DataType (inherited from MapiProperty) | Gets the data type.
Guid | gets named property GUID
Identifier (inherited from MapiProperty) | Gets the indifier.
IsSigned (inherited from MapiProperty) | Indicates whether the binary data is signed.
Kind | gets named property kind
MVEntries (inherited from MapiProperty) | Gets the MV entries list.
Name (inherited from MapiProperty) | Gets the name.
NameId | gets named property ID
Oom | gets OOM value
PropertyTagName (inherited from MapiProperty) | Gets the PropertyName.
Tag (inherited from MapiProperty) | Gets the tag.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBoolean (inherited from MapiProperty) | Gets the first bytes of the binary data as boolean.
GetDateTime (inherited from MapiProperty) | Gets the first bytes of the binary data as datetime.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt32 (inherited from MapiProperty) | Gets the first 4 bytes of the binary data as int32.
GetLong (inherited from MapiProperty) | Gets the first 8 bytes of the binary data as long.
GetShort (inherited from MapiProperty) | Gets the first 2 bytes of the binary data as short.
GetString (inherited from MapiProperty) | Overloaded. Gets the binary data as string using the specified code page.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from MapiProperty) | Returns a String that represents the current Object.

See Also

MapiNamedProperty Class | Aspose.Email.Outlook Namespace


MapiNamedProperty Constructor

Initializes a new instance of the MapiNamedProperty class.

public MapiNamedProperty();

See Also

MapiNamedProperty Class | Aspose.Email.Outlook Namespace


MapiNamedProperty Properties

The properties of the MapiNamedProperty class are listed below. For a complete list of MapiNamedProperty class members, see the MapiNamedProperty Members topic.

Public Instance Properties

Data (inherited from MapiProperty) | Gets the binary data.
DataType (inherited from MapiProperty) | Gets the data type.
Guid | gets named property GUID
Identifier (inherited from MapiProperty) | Gets the indifier.
IsSigned (inherited from MapiProperty) | Indicates whether the binary data is signed.
Kind | gets named property kind
MVEntries (inherited from MapiProperty) | Gets the MV entries list.
Name (inherited from MapiProperty) | Gets the name.
NameId | gets named property ID
Oom | gets OOM value
PropertyTagName (inherited from MapiProperty) | Gets the PropertyName.
Tag (inherited from MapiProperty) | Gets the tag.

See Also

MapiNamedProperty Class | Aspose.Email.Outlook Namespace


Guid Property

Aspose.Email

MapiNamedProperty.Guid Property

gets named property GUID

public Guid Guid {get;}

See Also

MapiNamedProperty Class | Aspose.Email.Outlook Namespace


Kind Property

Aspose.Email

MapiNamedProperty.Kind Property

gets named property kind

public int Kind {get;}

See Also

MapiNamedProperty Class | Aspose.Email.Outlook Namespace


NameId Property

Aspose.Email

MapiNamedProperty.NameId Property

gets named property ID

public string NameId {get;}

See Also

MapiNamedProperty Class | Aspose.Email.Outlook Namespace


Oom Property

Aspose.Email

MapiNamedProperty.Oom Property

gets OOM value

public string Oom {get;}

See Also

MapiNamedProperty Class | Aspose.Email.Outlook Namespace


MapiNamedPropertyMappingStorage Class

Represents the named property mapping

For a list of all members of this type, see MapiNamedPropertyMappingStorage Members.

System.Object
Aspose.Email.Outlook.MapiPropertyContainer
Aspose.Email.Outlook.MapiNamedPropertyMappingStorage

public sealed class MapiNamedPropertyMappingStorage : MapiPropertyContainer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiNamedPropertyMappingStorage Members | Aspose.Email.Outlook Namespace


MapiNamedPropertyMappingStorage Members

MapiNamedPropertyMappingStorage overview

Public Instance Constructors

MapiNamedPropertyMappingStorage Constructor Initializes a new instance of the MapiNamedPropertyMappingStorage class.

Public Instance Properties

CodePage (inherited from MapiPropertyContainer) | Gets the code page.
Content | Gets the content
Name | Gets the name
Properties (inherited from MapiPropertyContainer) | Gets the collection of properties.

Public Instance Methods

AddNamedPropertyMapping | Overloaded. Adds the named property mapping for numeric named property.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNextAvailablePropertyId | Gets the next available property id in entries stream based on property datatype.
GetPropertyBoolean (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Boolean type.
GetPropertyBytes (inherited from MapiPropertyContainer) | Gets the string value of the property specified by tag.
GetPropertyDateTime (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as DateTime type.
GetPropertyInt32 (inherited from MapiPropertyContainer) | Gets the int32 value of the property specified by tag.
GetPropertyLong (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Long (int64) type.
GetPropertyShort (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Short type.
GetPropertyString (inherited from MapiPropertyContainer) | Overloaded. Gets the string value of the property specified by tag.
GetType (inherited from Object) | Gets the Type of the current instance.
IsStoreUnicodeOk (inherited from MapiPropertyContainer) | Determines if string properties are Unicode encoded or not.
SetProperty | Sets the property.
ToString (inherited from Object) | Returns a String that represents the current Object.
TryGetPropertyData (inherited from MapiPropertyContainer) | Try to get the property data with specified tag key.
TryGetPropertyDateTime (inherited from MapiPropertyContainer) |
TryGetPropertyInt32 (inherited from MapiPropertyContainer) |
TryGetPropertyLong (inherited from MapiPropertyContainer) |
TryGetPropertyString (inherited from MapiPropertyContainer) | Overloaded. Try to get a property data as string with specified tag and code page.

See Also

MapiNamedPropertyMappingStorage Class | Aspose.Email.Outlook Namespace


MapiNamedPropertyMappingStorage Constructor

Initializes a new instance of the MapiNamedPropertyMappingStorage class.

public MapiNamedPropertyMappingStorage();

See Also

MapiNamedPropertyMappingStorage Class | Aspose.Email.Outlook Namespace


MapiNamedPropertyMappingStorage Properties

The properties of the MapiNamedPropertyMappingStorage class are listed below. For a complete list of MapiNamedPropertyMappingStorage class members, see the MapiNamedPropertyMappingStorage Members topic.

Public Instance Properties

CodePage (inherited from MapiPropertyContainer) | Gets the code page.
Content | Gets the content
Name | Gets the name
Properties (inherited from MapiPropertyContainer) | Gets the collection of properties.

See Also

MapiNamedPropertyMappingStorage Class | Aspose.Email.Outlook Namespace


Content Property

Aspose.Email

MapiNamedPropertyMappingStorage.Content Property

Gets the content

public object Content {get;}

Property Value

The content

See Also

MapiNamedPropertyMappingStorage Class | Aspose.Email.Outlook Namespace


Name Property

Aspose.Email

MapiNamedPropertyMappingStorage.Name Property

Gets the name

public string Name {get;}

Property Value

The name

See Also

MapiNamedPropertyMappingStorage Class | Aspose.Email.Outlook Namespace


MapiNamedPropertyMappingStorage Methods

The methods of the MapiNamedPropertyMappingStorage class are listed below. For a complete list of MapiNamedPropertyMappingStorage class members, see the MapiNamedPropertyMappingStorage Members topic.

Public Instance Methods

AddNamedPropertyMapping | Overloaded. Adds the named property mapping for numeric named property.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetNextAvailablePropertyId | Gets the next available property id in entries stream based on property datatype.
GetPropertyBoolean (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Boolean type.
GetPropertyBytes (inherited from MapiPropertyContainer) | Gets the string value of the property specified by tag.
GetPropertyDateTime (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as DateTime type.
GetPropertyInt32 (inherited from MapiPropertyContainer) | Gets the int32 value of the property specified by tag.
GetPropertyLong (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Long (int64) type.
GetPropertyShort (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Short type.
GetPropertyString (inherited from MapiPropertyContainer) | Overloaded. Gets the string value of the property specified by tag.
GetType (inherited from Object) | Gets the Type of the current instance.
IsStoreUnicodeOk (inherited from MapiPropertyContainer) | Determines if string properties are Unicode encoded or not.
SetProperty | Sets the property.
ToString (inherited from Object) | Returns a String that represents the current Object.
TryGetPropertyData (inherited from MapiPropertyContainer) | Try to get the property data with specified tag key.
TryGetPropertyDateTime (inherited from MapiPropertyContainer) |
TryGetPropertyInt32 (inherited from MapiPropertyContainer) |
TryGetPropertyLong (inherited from MapiPropertyContainer) |
TryGetPropertyString (inherited from MapiPropertyContainer) | Overloaded. Try to get a property data as string with specified tag and code page.

See Also

MapiNamedPropertyMappingStorage Class | Aspose.Email.Outlook Namespace


AddNamedPropertyMapping Method

Aspose.Email

MapiNamedPropertyMappingStorage.AddNamedPropertyMapping Method

Adds the named property mapping for numeric named property.

Overload List

Adds the named property mapping for numeric named property.

public void AddNamedPropertyMapping(MapiProperty,long,Guid);

Adds the named property mapping for string named property.

public void AddNamedPropertyMapping(MapiProperty,string,Guid);

See Also

MapiNamedPropertyMappingStorage Class | Aspose.Email.Outlook Namespace


MapiNamedPropertyMappingStorage.AddNamedPropertyMapping Method (MapiProperty, Int64, Guid)

Adds the named property mapping for numeric named property.

public void AddNamedPropertyMapping(
MapiProperty property,
long nameId,
Guid guid
);

Parameters

property
The property to add mapping for.
nameId
The name id.
guid
The GUID identifying property set.

Remarks

property should have a valid id for named property, GetNextAvailablePropertyId can be used to generate one. Otherwise an exception will be thrown.

See Also

MapiNamedPropertyMappingStorage Class | Aspose.Email.Outlook Namespace | MapiNamedPropertyMappingStorage.AddNamedPropertyMapping Overload List


MapiNamedPropertyMappingStorage.AddNamedPropertyMapping Method (MapiProperty, String, Guid)

Adds the named property mapping for string named property.

public void AddNamedPropertyMapping(
MapiProperty property,
string nameId,
Guid guid
);

Parameters

property
The property to add mapping for.
nameId
The name id.
guid
The GUID identifying property set.

Remarks

property should have a valid id for named property, GetNextAvailablePropertyId can be used to generate one. Otherwise an exception will be thrown.

See Also

MapiNamedPropertyMappingStorage Class | Aspose.Email.Outlook Namespace | MapiNamedPropertyMappingStorage.AddNamedPropertyMapping Overload List


MapiNamedPropertyMappingStorage.GetNextAvailablePropertyId Method

Gets the next available property id in entries stream based on property datatype.

public long GetNextAvailablePropertyId(
MapiPropertyType dataType
);

Parameters

dataType
Type of the data for the property.

Return Value

An id that can be lately used to add property mapping.

See Also

MapiNamedPropertyMappingStorage Class | Aspose.Email.Outlook Namespace


MapiNamedPropertyMappingStorage.SetProperty Method

Sets the property.

public override void SetProperty(
MapiProperty property
);

Parameters

property
The MapiProperty.

Exceptions

Exception Type | Condition
NotImplementedException |

See Also

MapiNamedPropertyMappingStorage Class | Aspose.Email.Outlook Namespace


MapiNote Class

Represents outlook Note object ("sticky note")

For a list of all members of this type, see MapiNote Members.

System.Object
Aspose.Email.Outlook.MapiNote

public sealed class MapiNote : IMapiMessageItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiNote Members | Aspose.Email.Outlook Namespace


MapiNote Members

MapiNote overview

Public Instance Constructors

MapiNote Overloaded. Initializes a new instance of the MapiNote class.

Public Instance Properties

Body | Gets or sets the text content of the Note object
Color | Gets or sets the suggested background color of the Note object
CreationDate | Gets or sets the creation date of note
Height | Gets or sets height of the visible message window in pixels
MessageClass | Gets message class
Subject | Gets an abbreviated version of the contents of the note
Width | Gets or sets width of the visible message window in pixels
XPosition | Gets or sets the distance, in pixels, from the left edge of the screen that a user interface displays a Note object
YPosition | Gets or sets the distance, in pixels, from the top edge of the screen that a user interface displays a Note object

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Overloaded. Saves this MapiNote to the given stream using specified format.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MapiNote Class | Aspose.Email.Outlook Namespace


MapiNote Constructor

Initializes a new instance of the MapiNote class.

Overload List

Initializes a new instance of the MapiNote class.

public MapiNote();

Initializes a new instance of the MapiNote class.

public MapiNote(string,string);

See Also

MapiNote Class | Aspose.Email.Outlook Namespace


MapiNote Constructor ()

Initializes a new instance of the MapiNote class.

public MapiNote();

See Also

MapiNote Class | Aspose.Email.Outlook Namespace | MapiNote Constructor Overload List


MapiNote Constructor (String, String)

Initializes a new instance of the MapiNote class.

public MapiNote(
string subject,
string body
);

Parameters

subject
The message subject.
body
The message body.

See Also

MapiNote Class | Aspose.Email.Outlook Namespace | MapiNote Constructor Overload List


MapiNote Properties

The properties of the MapiNote class are listed below. For a complete list of MapiNote class members, see the MapiNote Members topic.

Public Instance Properties

Body | Gets or sets the text content of the Note object
Color | Gets or sets the suggested background color of the Note object
CreationDate | Gets or sets the creation date of note
Height | Gets or sets height of the visible message window in pixels
MessageClass | Gets message class
Subject | Gets an abbreviated version of the contents of the note
Width | Gets or sets width of the visible message window in pixels
XPosition | Gets or sets the distance, in pixels, from the left edge of the screen that a user interface displays a Note object
YPosition | Gets or sets the distance, in pixels, from the top edge of the screen that a user interface displays a Note object

See Also

MapiNote Class | Aspose.Email.Outlook Namespace


Body Property

Aspose.Email

MapiNote.Body Property

Gets or sets the text content of the Note object

public string Body {get; set;}

Implements

IMapiMessageItem.Body

See Also

MapiNote Class | Aspose.Email.Outlook Namespace


Color Property

Aspose.Email

MapiNote.Color Property

Gets or sets the suggested background color of the Note object

public NoteColor Color {get; set;}

See Also

MapiNote Class | Aspose.Email.Outlook Namespace


CreationDate Property

Aspose.Email

MapiNote.CreationDate Property

Gets or sets the creation date of note

public DateTime CreationDate {get; set;}

See Also

MapiNote Class | Aspose.Email.Outlook Namespace


Height Property

Aspose.Email

MapiNote.Height Property

Gets or sets height of the visible message window in pixels

public int Height {get; set;}

See Also

MapiNote Class | Aspose.Email.Outlook Namespace


MessageClass Property

Aspose.Email

MapiNote.MessageClass Property

Gets message class

public string MessageClass {get;}

Property Value

String that represents message class

Implements

IMapiMessageItem.MessageClass

See Also

MapiNote Class | Aspose.Email.Outlook Namespace


Subject Property

Aspose.Email

MapiNote.Subject Property

Gets an abbreviated version of the contents of the note

public string Subject {get; set;}

Implements

IMapiMessageItem.Subject

See Also

MapiNote Class | Aspose.Email.Outlook Namespace


Width Property

Aspose.Email

MapiNote.Width Property

Gets or sets width of the visible message window in pixels

public int Width {get; set;}

See Also

MapiNote Class | Aspose.Email.Outlook Namespace


XPosition Property

Aspose.Email

MapiNote.XPosition Property

Gets or sets the distance, in pixels, from the left edge of the screen that a user interface displays a Note object

public int XPosition {get; set;}

See Also

MapiNote Class | Aspose.Email.Outlook Namespace


YPosition Property

Aspose.Email

MapiNote.YPosition Property

Gets or sets the distance, in pixels, from the top edge of the screen that a user interface displays a Note object

public int YPosition {get; set;}

See Also

MapiNote Class | Aspose.Email.Outlook Namespace


MapiNote Methods

The methods of the MapiNote class are listed below. For a complete list of MapiNote class members, see the MapiNote Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Overloaded. Saves this MapiNote to the given stream using specified format.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MapiNote Class | Aspose.Email.Outlook Namespace


Save Method

Aspose.Email

MapiNote.Save Method

Saves this MapiNote to the given stream using specified format.

Overload List

Saves this MapiNote to the given stream using specified format.

public void Save(Stream,NoteSaveFormat);

Saves this MapiNote into file using specified format.

public void Save(string,NoteSaveFormat);

See Also

MapiNote Class | Aspose.Email.Outlook Namespace


MapiNote.Save Method (Stream, NoteSaveFormat)

Saves this MapiNote to the given stream using specified format.

public void Save(
Stream stream,
NoteSaveFormat saveFormat
);

Parameters

stream
A stream to save to.
saveFormat
A save format.

Exceptions

Exception Type | Condition
ArgumentNullException | stream is null.
NotSupportedException | stream does not support writing.
NotSupportedException | The specified format is not supported.

See Also

MapiNote Class | Aspose.Email.Outlook Namespace | MapiNote.Save Overload List


MapiNote.Save Method (String, NoteSaveFormat)

Saves this MapiNote into file using specified format.

public void Save(
string filePath,
NoteSaveFormat saveFormat
);

Parameters

filePath
A file name.
saveFormat
A save format.

Exceptions

Exception Type | Condition
ArgumentException | filePath is null or empty.
NotSupportedException | some save option is not supported

See Also

MapiNote Class | Aspose.Email.Outlook Namespace | MapiNote.Save Overload List


MapiObjectProperty Class

Reprensents a Custom object included in Outlook Message documents.

For a list of all members of this type, see MapiObjectProperty Members.

System.Object
Aspose.Email.Outlook.MapiProperty
Aspose.Email.Outlook.MapiObjectProperty

public class MapiObjectProperty : MapiProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiObjectProperty Members | Aspose.Email.Outlook Namespace


MapiObjectProperty Members

MapiObjectProperty overview

Public Instance Properties

Data (inherited from MapiProperty) | Gets the binary data.
DataType (inherited from MapiProperty) | Gets the data type.
DocumentName | Gets the document name.
Identifier (inherited from MapiProperty) | Gets the indifier.
IsOutlookMessage | Indicates whether the object property is an embedded outlook message.
IsSigned (inherited from MapiProperty) | Indicates whether the binary data is signed.
MVEntries (inherited from MapiProperty) | Gets the MV entries list.
Name (inherited from MapiProperty) | Gets the name.
OleDocumentFormat | Gets the Ole format type.
Properties | Gets a collection of mapi properties.
PropertyTagName (inherited from MapiProperty) | Gets the PropertyName.
Tag (inherited from MapiProperty) | Gets the tag.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBoolean (inherited from MapiProperty) | Gets the first bytes of the binary data as boolean.
GetDateTime (inherited from MapiProperty) | Gets the first bytes of the binary data as datetime.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt32 (inherited from MapiProperty) | Gets the first 4 bytes of the binary data as int32.
GetLong (inherited from MapiProperty) | Gets the first 8 bytes of the binary data as long.
GetShort (inherited from MapiProperty) | Gets the first 2 bytes of the binary data as short.
GetString (inherited from MapiProperty) | Overloaded. Gets the binary data as string using the specified code page.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from MapiProperty) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MapiObjectProperty Class | Aspose.Email.Outlook Namespace


MapiObjectProperty Properties

The properties of the MapiObjectProperty class are listed below. For a complete list of MapiObjectProperty class members, see the MapiObjectProperty Members topic.

Public Instance Properties

Data (inherited from MapiProperty) | Gets the binary data.
DataType (inherited from MapiProperty) | Gets the data type.
DocumentName | Gets the document name.
Identifier (inherited from MapiProperty) | Gets the indifier.
IsOutlookMessage | Indicates whether the object property is an embedded outlook message.
IsSigned (inherited from MapiProperty) | Indicates whether the binary data is signed.
MVEntries (inherited from MapiProperty) | Gets the MV entries list.
Name (inherited from MapiProperty) | Gets the name.
OleDocumentFormat | Gets the Ole format type.
Properties | Gets a collection of mapi properties.
PropertyTagName (inherited from MapiProperty) | Gets the PropertyName.
Tag (inherited from MapiProperty) | Gets the tag.

See Also

MapiObjectProperty Class | Aspose.Email.Outlook Namespace


DocumentName Property

Aspose.Email

MapiObjectProperty.DocumentName Property

Gets the document name.

public string DocumentName {get;}

See Also

MapiObjectProperty Class | Aspose.Email.Outlook Namespace


IsOutlookMessage Property

Aspose.Email

MapiObjectProperty.IsOutlookMessage Property

Indicates whether the object property is an embedded outlook message.

public bool IsOutlookMessage {get;}

See Also

MapiObjectProperty Class | Aspose.Email.Outlook Namespace


OleDocumentFormat Property

Aspose.Email

MapiObjectProperty.OleDocumentFormat Property

Gets the Ole format type.

public OleDocumentFormat OleDocumentFormat {get;}

See Also

MapiObjectProperty Class | Aspose.Email.Outlook Namespace


Properties Property

Aspose.Email

MapiObjectProperty.Properties Property

Gets a collection of mapi properties.

public MapiPropertyCollection Properties {get;}

See Also

MapiObjectProperty Class | Aspose.Email.Outlook Namespace


MapiObjectType Enumeration

Represents the mapi object type.

public enum MapiObjectType

Members

Member Name | Description | Value
MAPI_ABCONT | MAPI_ABCONT | 4
MAPI_ADDRBOOK | MAPI_ADDRBOOK | 2
MAPI_ATTACH | MAPI_ATTACH | 7
MAPI_DISTLIST | MAPI_DISTLIST | 8
MAPI_FOLDER | MAPI_FOLDER | 3
MAPI_FORMINFO | MAPI_FORMINFO | 12
MAPI_MAILUSER | MAPI_MAILUSER | 6
MAPI_MESSAGE | MAPI_MESSAGE | 5
MAPI_PROFSECT | MAPI_PROFSECT | 9
MAPI_SESSION | MAPI_SESSION | 11
MAPI_STATUS | MAPI_STATUS | 10
MAPI_STORE | MAPI_STORE | 1
None | No values are set. | 0
Unknown | Obsolete. Please use 'None' value instead Unknown type. | -1

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Outlook Namespace


MapiProperty Class

Represents the mapi property.

For a list of all members of this type, see MapiProperty Members.

System.Object
Aspose.Email.Outlook.MapiProperty
Aspose.Email.Outlook.MapiNamedProperty
Aspose.Email.Outlook.MapiObjectProperty

public class MapiProperty

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiProperty Members | Aspose.Email.Outlook Namespace


MapiProperty Members

MapiProperty overview

Public Instance Constructors

MapiProperty Overloaded. Initializes a new instance of the MapiProperty class.

Public Instance Properties

Data | Gets the binary data.
DataType | Gets the data type.
Identifier | Gets the indifier.
IsSigned | Indicates whether the binary data is signed.
MVEntries | Gets the MV entries list.
Name | Gets the name.
PropertyTagName | Gets the PropertyName.
Tag | Gets the tag.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBoolean | Gets the first bytes of the binary data as boolean.
GetDateTime | Gets the first bytes of the binary data as datetime.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt32 | Gets the first 4 bytes of the binary data as int32.
GetLong | Gets the first 8 bytes of the binary data as long.
GetShort | Gets the first 2 bytes of the binary data as short.
GetString | Overloaded. Gets the binary data as string using the specified code page.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents the current Object.

Protected Instance Constructors

MapiProperty Overloaded. Initializes a new instance of the MapiProperty class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MapiProperty Class | Aspose.Email.Outlook Namespace


MapiProperty Constructor

Initializes a new instance of the MapiProperty class.

Overload List

Initializes a new instance of the MapiProperty class.

protected MapiProperty();

Initializes a new instance of the MapiProperty class.

public MapiProperty(long,byte[]);

Initializes a new instance of the MapiProperty class. This overload is used to create a multiple valued property, PT_MV_*.

public MapiProperty(long,IList);

Initializes a new instance of the MapiProperty class.

public MapiProperty(long,long,byte[]);

Initializes a new instance of the MapiProperty class.

public MapiProperty(string,long,long,byte[]);

See Also

MapiProperty Class | Aspose.Email.Outlook Namespace


MapiProperty Constructor ()

Initializes a new instance of the MapiProperty class.

protected MapiProperty();

See Also

MapiProperty Class | Aspose.Email.Outlook Namespace | MapiProperty Constructor Overload List


MapiProperty Constructor (String, Int64, Int64, Byte[])

Initializes a new instance of the MapiProperty class.

public MapiProperty(
string name,
long tag,
long signed,
byte[] data
);

Parameters

name
The name.
tag
The tag key of the property.
signed
Indicates the data is signed or not.
data
The binary data of the property.

See Also

MapiProperty Class | Aspose.Email.Outlook Namespace | MapiProperty Constructor Overload List


MapiProperty Constructor (Int64, Int64, Byte[])

Initializes a new instance of the MapiProperty class.

public MapiProperty(
long tag,
long signed,
byte[] data
);

Parameters

tag
The property tag.
signed
The signed.
data
The property data.

See Also

MapiProperty Class | Aspose.Email.Outlook Namespace | MapiProperty Constructor Overload List


MapiProperty Constructor (Int64, Byte[])

Initializes a new instance of the MapiProperty class.

public MapiProperty(
long tag,
byte[] data
);

Parameters

tag
The tag key of the property.
data
The binary data of the property.

See Also

MapiProperty Class | Aspose.Email.Outlook Namespace | MapiProperty Constructor Overload List


MapiProperty Constructor (Int64, IList)

Initializes a new instance of the MapiProperty class. This overload is used to create a multiple valued property, PT_MV_*.

public MapiProperty(
long tag,
IList values
);

Parameters

tag
The property tag.
values
The values.

See Also

MapiProperty Class | Aspose.Email.Outlook Namespace | MapiProperty Constructor Overload List


MapiProperty Properties

The properties of the MapiProperty class are listed below. For a complete list of MapiProperty class members, see the MapiProperty Members topic.

Public Instance Properties

Data | Gets the binary data.
DataType | Gets the data type.
Identifier | Gets the indifier.
IsSigned | Indicates whether the binary data is signed.
MVEntries | Gets the MV entries list.
Name | Gets the name.
PropertyTagName | Gets the PropertyName.
Tag | Gets the tag.

See Also

MapiProperty Class | Aspose.Email.Outlook Namespace


Data Property

Aspose.Email

MapiProperty.Data Property

Gets the binary data.

public virtual byte[] Data {get;}

See Also

MapiProperty Class | Aspose.Email.Outlook Namespace


DataType Property

Aspose.Email

MapiProperty.DataType Property

Gets the data type.

public virtual int DataType {get;}

See Also

MapiProperty Class | Aspose.Email.Outlook Namespace


Identifier Property

Aspose.Email

MapiProperty.Identifier Property

Gets the indifier.

public virtual long Identifier {get;}

See Also

MapiProperty Class | Aspose.Email.Outlook Namespace


IsSigned Property

Aspose.Email

MapiProperty.IsSigned Property

Indicates whether the binary data is signed.

public virtual bool IsSigned {get;}

See Also

MapiProperty Class | Aspose.Email.Outlook Namespace


MVEntries Property

Aspose.Email

MapiProperty.MVEntries Property

Gets the MV entries list.

public IList MVEntries {get;}

See Also

MapiProperty Class | Aspose.Email.Outlook Namespace


Name Property

Aspose.Email

MapiProperty.Name Property

Gets the name.

public virtual string Name {get;}

See Also

MapiProperty Class | Aspose.Email.Outlook Namespace


PropertyTagName Property

Aspose.Email

MapiProperty.PropertyTagName Property

Gets the PropertyName.

public virtual string PropertyTagName {get;}

See Also

MapiProperty Class | Aspose.Email.Outlook Namespace


Tag Property

Aspose.Email

MapiProperty.Tag Property

Gets the tag.

public virtual long Tag {get;}

See Also

MapiProperty Class | Aspose.Email.Outlook Namespace


MapiProperty Methods

The methods of the MapiProperty class are listed below. For a complete list of MapiProperty class members, see the MapiProperty Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBoolean | Gets the first bytes of the binary data as boolean.
GetDateTime | Gets the first bytes of the binary data as datetime.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetInt32 | Gets the first 4 bytes of the binary data as int32.
GetLong | Gets the first 8 bytes of the binary data as long.
GetShort | Gets the first 2 bytes of the binary data as short.
GetString | Overloaded. Gets the binary data as string using the specified code page.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MapiProperty Class | Aspose.Email.Outlook Namespace


MapiProperty.GetBoolean Method

Gets the first bytes of the binary data as boolean.

public virtual bool GetBoolean();

Return Value

The boolean value.

See Also

MapiProperty Class | Aspose.Email.Outlook Namespace


MapiProperty.GetDateTime Method

Gets the first bytes of the binary data as datetime.

public virtual DateTime GetDateTime();

Return Value

The datetime value.

See Also

MapiProperty Class | Aspose.Email.Outlook Namespace


MapiProperty.GetInt32 Method

Gets the first 4 bytes of the binary data as int32.

public virtual int GetInt32();

Return Value

The int32 value.

See Also

MapiProperty Class | Aspose.Email.Outlook Namespace


MapiProperty.GetLong Method

Gets the first 8 bytes of the binary data as long.

public virtual long GetLong();

Return Value

The long value.

See Also

MapiProperty Class | Aspose.Email.Outlook Namespace


MapiProperty.GetShort Method

Gets the first 2 bytes of the binary data as short.

public virtual short GetShort();

Return Value

The short value.

See Also

MapiProperty Class | Aspose.Email.Outlook Namespace


GetString Method

Aspose.Email

MapiProperty.GetString Method

Gets the binary data as string.

Overload List

Gets the binary data as string.

public virtual string GetString();

Gets the binary data as string using the specified code page.

public virtual string GetString(int);

See Also

MapiProperty Class | Aspose.Email.Outlook Namespace


MapiProperty.GetString Method ()

Gets the binary data as string.

public virtual string GetString();

Return Value

A string contains the binary data.

See Also

MapiProperty Class | Aspose.Email.Outlook Namespace | MapiProperty.GetString Overload List


MapiProperty.GetString Method (Int32)

Gets the binary data as string using the specified code page.

public virtual string GetString(
int codepage
);

Parameters

codepage
The code page.

Return Value

A string contains the binary data.

See Also

MapiProperty Class | Aspose.Email.Outlook Namespace | MapiProperty.GetString Overload List


MapiProperty.ToString Method

Returns a String that represents the current Object.

public override string ToString();

Return Value

A String that represents the current Object.

See Also

MapiProperty Class | Aspose.Email.Outlook Namespace


MapiPropertyCollection Class

Represents the collection of MapiProperty items.

For a list of all members of this type, see MapiPropertyCollection Members.

System.Object
Aspose.Email.Outlook.MapiPropertyCollection

public class MapiPropertyCollection : IDictionary, ICollection, IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiPropertyCollection Members | Aspose.Email.Outlook Namespace


MapiPropertyCollection Members

MapiPropertyCollection overview

Public Instance Constructors

MapiPropertyCollection Constructor Creates a new instance of class MapiProperty.

Public Instance Properties

Count | Gets the number of elements contained in the collection.
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | Gets a value indicating whether the collection is read only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
Item | Overloaded. Gets or sets the value associated with the specified key.
Keys | Gets a System.Collections.ICollection containing the keys in the collection.
SyncRoot | Gets an object that can be used to synchronize access to the collection.
Values | Gets an System.Collections.ICollection containing the values in the collection.

Public Instance Methods

Add | Overloaded. Adds a MapiProperty item with specified tag.
Clear | Removes all of the elements from the collection.
Contains | Overloaded. Determines whether the collection contains the specified tag.
CopyTo | Copies the collection elements to a one-dimensional System.Array instance at the specified index.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an System.Collections.IDictionaryEnumerator that iterates through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove | Overloaded. Removes the element with the specified key from the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MapiPropertyCollection Class | Aspose.Email.Outlook Namespace


MapiPropertyCollection Constructor

Creates a new instance of class MapiProperty.

public MapiPropertyCollection();

See Also

MapiPropertyCollection Class | Aspose.Email.Outlook Namespace


MapiPropertyCollection Properties

The properties of the MapiPropertyCollection class are listed below. For a complete list of MapiPropertyCollection class members, see the MapiPropertyCollection Members topic.

Public Instance Properties

Count | Gets the number of elements contained in the collection.
IsFixedSize | Gets a value indicating whether the collection has a fixed size.
IsReadOnly | Gets a value indicating whether the collection is read only.
IsSynchronized | Gets a value indicating whether access to the collection is synchronized (thread safe).
Item | Overloaded. Gets or sets the value associated with the specified key.
Keys | Gets a System.Collections.ICollection containing the keys in the collection.
SyncRoot | Gets an object that can be used to synchronize access to the collection.
Values | Gets an System.Collections.ICollection containing the values in the collection.

See Also

MapiPropertyCollection Class | Aspose.Email.Outlook Namespace


Count Property

Aspose.Email

MapiPropertyCollection.Count Property

Gets the number of elements contained in the collection.

public virtual int Count {get;}

Implements

ICollection.Count

See Also

MapiPropertyCollection Class | Aspose.Email.Outlook Namespace


IsFixedSize Property

Aspose.Email

MapiPropertyCollection.IsFixedSize Property

Gets a value indicating whether the collection has a fixed size.

public virtual bool IsFixedSize {get;}

Implements

IDictionary.IsFixedSize

See Also

MapiPropertyCollection Class | Aspose.Email.Outlook Namespace


IsReadOnly Property

Aspose.Email

MapiPropertyCollection.IsReadOnly Property

Gets a value indicating whether the collection is read only.

public virtual bool IsReadOnly {get;}

Implements

IDictionary.IsReadOnly

See Also

MapiPropertyCollection Class | Aspose.Email.Outlook Namespace


IsSynchronized Property

Aspose.Email

MapiPropertyCollection.IsSynchronized Property

Gets a value indicating whether access to the collection is synchronized (thread safe).

public virtual bool IsSynchronized {get;}

Implements

ICollection.IsSynchronized

See Also

MapiPropertyCollection Class | Aspose.Email.Outlook Namespace


Item Property

Aspose.Email

MapiPropertyCollection.Item Property

Gets or sets the value associated with the specified key.

Overload List

Gets or sets the value associated with the specified key.

public virtual MapiProperty this[long] {get; set;}

Gets or sets the value associated with the specified key.

public virtual object this[object] {get; set;}

See Also

MapiPropertyCollection Class | Aspose.Email.Outlook Namespace


Item Property (Int64)

Aspose.Email

MapiPropertyCollection.Item Property (Int64)

Gets or sets the value associated with the specified key.

public virtual MapiProperty this[
long tag
] {get; set;}

Parameters

tag
The tag key whose value to get or set.

See Also

MapiPropertyCollection Class | Aspose.Email.Outlook Namespace | MapiPropertyCollection.Item Overload List


Item Property (Object)

Aspose.Email

MapiPropertyCollection.Item Property (Object)

Gets or sets the value associated with the specified key.

public virtual object this[
object tag
] {get; set;}

Parameters

tag
The tag key whose value to get or set.

Implements

IDictionary.Item

See Also

MapiPropertyCollection Class | Aspose.Email.Outlook Namespace | MapiPropertyCollection.Item Overload List


Keys Property

Aspose.Email

MapiPropertyCollection.Keys Property

Gets a System.Collections.ICollection containing the keys in the collection.

public virtual ICollection Keys {get;}

Implements

IDictionary.Keys

See Also

MapiPropertyCollection Class | Aspose.Email.Outlook Namespace


SyncRoot Property

Aspose.Email

MapiPropertyCollection.SyncRoot Property

Gets an object that can be used to synchronize access to the collection.

public virtual object SyncRoot {get;}

Implements

ICollection.SyncRoot

See Also

MapiPropertyCollection Class | Aspose.Email.Outlook Namespace


Values Property

Aspose.Email

MapiPropertyCollection.Values Property

Gets an System.Collections.ICollection containing the values in the collection.

public virtual ICollection Values {get;}

Implements

IDictionary.Values

See Also

MapiPropertyCollection Class | Aspose.Email.Outlook Namespace


MapiPropertyCollection Methods

The methods of the MapiPropertyCollection class are listed below. For a complete list of MapiPropertyCollection class members, see the MapiPropertyCollection Members topic.

Public Instance Methods

Add | Overloaded. Adds a MapiProperty item with specified tag.
Clear | Removes all of the elements from the collection.
Contains | Overloaded. Determines whether the collection contains the specified tag.
CopyTo | Copies the collection elements to a one-dimensional System.Array instance at the specified index.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator | Returns an System.Collections.IDictionaryEnumerator that iterates through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Remove | Overloaded. Removes the element with the specified key from the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MapiPropertyCollection Class | Aspose.Email.Outlook Namespace


Add Method

Aspose.Email

MapiPropertyCollection.Add Method

Adds a MapiProperty item with specified tag.

Overload List

Adds a MapiProperty item with specified tag.

public virtual void Add(long,MapiProperty);

Adds an element with the specified key and value to the collection.

public virtual void Add(object,object);

See Also

MapiPropertyCollection Class | Aspose.Email.Outlook Namespace


MapiPropertyCollection.Add Method (Int64, MapiProperty)

Adds a MapiProperty item with specified tag.

public virtual void Add(
long tag,
MapiProperty value
);

Parameters

tag
The property tag.
value
The property value.

See Also

MapiPropertyCollection Class | Aspose.Email.Outlook Namespace | MapiPropertyCollection.Add Overload List


MapiPropertyCollection.Add Method (Object, Object)

Adds an element with the specified key and value to the collection.

public virtual void Add(
object tag,
object value
);

Parameters

tag
The tag key.
value
The value.

Implements

IDictionary.Add

See Also

MapiPropertyCollection Class | Aspose.Email.Outlook Namespace | MapiPropertyCollection.Add Overload List


MapiPropertyCollection.Clear Method

Removes all of the elements from the collection.

public virtual void Clear();

Implements

IDictionary.Clear

See Also

MapiPropertyCollection Class | Aspose.Email.Outlook Namespace


Contains Method

Aspose.Email

MapiPropertyCollection.Contains Method

Determines whether the collection contains the specified tag.

Overload List

Determines whether the collection contains the specified tag.

public virtual bool Contains(long);

Determines whether the collection contains the specified tag.

public virtual bool Contains(object);

See Also

MapiPropertyCollection Class | Aspose.Email.Outlook Namespace


MapiPropertyCollection.Contains Method (Int64)

Determines whether the collection contains the specified tag.

public virtual bool Contains(
long tag
);

Parameters

tag
The property tag.

Return Value

true if the collection contains an element with the specified tag; otherwise, false.

See Also

MapiPropertyCollection Class | Aspose.Email.Outlook Namespace | MapiPropertyCollection.Contains Overload List


MapiPropertyCollection.Contains Method (Object)

Determines whether the collection contains the specified tag.

public virtual bool Contains(
object tag
);

Parameters

tag
The property tag.

Return Value

true if the collection contains an element with the specified tag; otherwise, false.

Implements

IDictionary.Contains

See Also

MapiPropertyCollection Class | Aspose.Email.Outlook Namespace | MapiPropertyCollection.Contains Overload List


MapiPropertyCollection.CopyTo Method

Copies the collection elements to a one-dimensional System.Array instance at the specified index.

public virtual void CopyTo(
Array array,
int index
);

Parameters

array
The one-dimensional System.Array that is the destination of the System.Collections.DictionaryEntry objects copied from the collection. The System.Array must have zero-based indexing.
index
The zero-based index in array at which copying begins.

Implements

ICollection.CopyTo

See Also

MapiPropertyCollection Class | Aspose.Email.Outlook Namespace


MapiPropertyCollection.GetEnumerator Method

Returns an System.Collections.IDictionaryEnumerator that iterates through the collection.

public virtual IDictionaryEnumerator GetEnumerator();

Return Value

An System.Collections.IDictionaryEnumerator for the collection.

Implements

IDictionary.GetEnumerator

See Also

MapiPropertyCollection Class | Aspose.Email.Outlook Namespace


Remove Method

Aspose.Email

MapiPropertyCollection.Remove Method

Removes the element with the specified key from the collection.

Overload List

Removes the element with the specified key from the collection.

public virtual void Remove(long);

Removes the element with the specified key from the collection.

public virtual void Remove(object);

See Also

MapiPropertyCollection Class | Aspose.Email.Outlook Namespace


MapiPropertyCollection.Remove Method (Int64)

Removes the element with the specified key from the collection.

public virtual void Remove(
long tag
);

Parameters

tag
The key tag of the element to remove.

See Also

MapiPropertyCollection Class | Aspose.Email.Outlook Namespace | MapiPropertyCollection.Remove Overload List


MapiPropertyCollection.Remove Method (Object)

Removes the element with the specified key from the collection.

public virtual void Remove(
object tag
);

Parameters

tag
The key tag of the element to remove.

Implements

IDictionary.Remove

See Also

MapiPropertyCollection Class | Aspose.Email.Outlook Namespace | MapiPropertyCollection.Remove Overload List


MapiPropertyContainer Class

Represents the base class for MapiAttachment, MapiRecipient, MapiMessage.

For a list of all members of this type, see MapiPropertyContainer Members.

System.Object
Aspose.Email.Outlook.MapiPropertyContainer
Aspose.Email.Outlook.MapiAttachment
Aspose.Email.Outlook.MapiMessage
Aspose.Email.Outlook.MapiNamedPropertyMappingStorage
Aspose.Email.Outlook.MapiPropertyStream
Aspose.Email.Outlook.MapiRecipient

public abstract class MapiPropertyContainer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiPropertyContainer Members | Aspose.Email.Outlook Namespace


MapiPropertyContainer Members

MapiPropertyContainer overview

Public Instance Properties

CodePage | Gets the code page.
Properties | Gets the collection of properties.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPropertyBoolean | Gets the value of the property specified by tag as Boolean type.
GetPropertyBytes | Gets the string value of the property specified by tag.
GetPropertyDateTime | Gets the value of the property specified by tag as DateTime type.
GetPropertyInt32 | Gets the int32 value of the property specified by tag.
GetPropertyLong | Gets the value of the property specified by tag as Long (int64) type.
GetPropertyShort | Gets the value of the property specified by tag as Short type.
GetPropertyString | Overloaded. Gets the string value of the property specified by tag.
GetType (inherited from Object) | Gets the Type of the current instance.
IsStoreUnicodeOk | Determines if string properties are Unicode encoded or not.
SetProperty | Sets the property.
ToString (inherited from Object) | Returns a String that represents the current Object.
TryGetPropertyData | Try to get the property data with specified tag key.
TryGetPropertyDateTime |
TryGetPropertyInt32 |
TryGetPropertyLong |
TryGetPropertyString | Overloaded. Try to get a property data as string with specified tag and code page.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MapiPropertyContainer Class | Aspose.Email.Outlook Namespace


MapiPropertyContainer Properties

The properties of the MapiPropertyContainer class are listed below. For a complete list of MapiPropertyContainer class members, see the MapiPropertyContainer Members topic.

Public Instance Properties

CodePage | Gets the code page.
Properties | Gets the collection of properties.

See Also

MapiPropertyContainer Class | Aspose.Email.Outlook Namespace


CodePage Property

Aspose.Email

MapiPropertyContainer.CodePage Property

Gets the code page.

public virtual int CodePage {get;}

Property Value

The code page.

See Also

MapiPropertyContainer Class | Aspose.Email.Outlook Namespace


Properties Property

Aspose.Email

MapiPropertyContainer.Properties Property

Gets the collection of properties.

public virtual MapiPropertyCollection Properties {get;}

Property Value

The properties.

See Also

MapiPropertyContainer Class | Aspose.Email.Outlook Namespace


MapiPropertyContainer Methods

The methods of the MapiPropertyContainer class are listed below. For a complete list of MapiPropertyContainer class members, see the MapiPropertyContainer Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPropertyBoolean | Gets the value of the property specified by tag as Boolean type.
GetPropertyBytes | Gets the string value of the property specified by tag.
GetPropertyDateTime | Gets the value of the property specified by tag as DateTime type.
GetPropertyInt32 | Gets the int32 value of the property specified by tag.
GetPropertyLong | Gets the value of the property specified by tag as Long (int64) type.
GetPropertyShort | Gets the value of the property specified by tag as Short type.
GetPropertyString | Overloaded. Gets the string value of the property specified by tag.
GetType (inherited from Object) | Gets the Type of the current instance.
IsStoreUnicodeOk | Determines if string properties are Unicode encoded or not.
SetProperty | Sets the property.
ToString (inherited from Object) | Returns a String that represents the current Object.
TryGetPropertyData | Try to get the property data with specified tag key.
TryGetPropertyDateTime |
TryGetPropertyInt32 |
TryGetPropertyLong |
TryGetPropertyString | Overloaded. Try to get a property data as string with specified tag and code page.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MapiPropertyContainer Class | Aspose.Email.Outlook Namespace


MapiPropertyContainer.GetPropertyBoolean Method

Gets the value of the property specified by tag as Boolean type.

public Nullable<bool> GetPropertyBoolean(
long tag
);

Parameters

tag
The MAPI property tag.

Return Value

The value of the property. If the property does not exist, returns NULL; otherwise, returns the value.

See Also

MapiPropertyContainer Class | Aspose.Email.Outlook Namespace


MapiPropertyContainer.GetPropertyBytes Method

Gets the string value of the property specified by tag.

public byte[] GetPropertyBytes(
long tag
);

Parameters

tag
The MAPI property tag.

Return Value

The value of the property. If the property does not exist, returns NULL; otherwise, returns the value.

See Also

MapiPropertyContainer Class | Aspose.Email.Outlook Namespace


MapiPropertyContainer.GetPropertyDateTime Method

Gets the value of the property specified by tag as DateTime type.

public Nullable<DateTime> GetPropertyDateTime(
long key
);

Parameters

key
The MAPI property tag.

Return Value

The value of the property. If the property does not exist, returns NULL; otherwise, returns the value.

See Also

MapiPropertyContainer Class | Aspose.Email.Outlook Namespace


MapiPropertyContainer.GetPropertyInt32 Method

Gets the int32 value of the property specified by tag.

public Nullable<int> GetPropertyInt32(
long tag
);

Parameters

tag
The MAPI property tag.

Return Value

The value of the property. If the property does not exist, returns NULL; otherwise, returns the value.

See Also

MapiPropertyContainer Class | Aspose.Email.Outlook Namespace


MapiPropertyContainer.GetPropertyLong Method

Gets the value of the property specified by tag as Long (int64) type.

public Nullable<long> GetPropertyLong(
long tag
);

Parameters

tag
The MAPI property tag.

Return Value

The value of the property. If the property does not exist, returns NULL; otherwise, returns the value.

See Also

MapiPropertyContainer Class | Aspose.Email.Outlook Namespace


MapiPropertyContainer.GetPropertyShort Method

Gets the value of the property specified by tag as Short type.

public Nullable<short> GetPropertyShort(
long tag
);

Parameters

tag
The MAPI property tag.

Return Value

The value of the property. If the property does not exist, returns NULL; otherwise, returns the value.

See Also

MapiPropertyContainer Class | Aspose.Email.Outlook Namespace


GetPropertyString Method

Aspose.Email

MapiPropertyContainer.GetPropertyString Method

Gets the string value of the property specified by tag.

Overload List

Gets the string value of the property specified by tag.

public string GetPropertyString(long);

Gets the string value of the property specified by tag.

public string GetPropertyString(long,int);

See Also

MapiPropertyContainer Class | Aspose.Email.Outlook Namespace


MapiPropertyContainer.GetPropertyString Method (Int64)

Gets the string value of the property specified by tag.

public string GetPropertyString(
long tag
);

Parameters

tag
The MAPI property tag.

Return Value

The value of the property. If the property does not exist, returns NULL; otherwise, returns the value.

See Also

MapiPropertyContainer Class | Aspose.Email.Outlook Namespace | MapiPropertyContainer.GetPropertyString Overload List


MapiPropertyContainer.GetPropertyString Method (Int64, Int32)

Gets the string value of the property specified by tag.

public string GetPropertyString(
long tag,
int codepage
);

Parameters

tag
The MAPI property tag.
codepage
The specified codepage used to get string value.

Return Value

The value of the property. If the property does not exist, returns NULL; otherwise, returns the value.

See Also

MapiPropertyContainer Class | Aspose.Email.Outlook Namespace | MapiPropertyContainer.GetPropertyString Overload List


MapiPropertyContainer.IsStoreUnicodeOk Method

Determines if string properties are Unicode encoded or not.

public bool IsStoreUnicodeOk();

Return Value

True, if string properties are Unicode encoded.

See Also

MapiPropertyContainer Class | Aspose.Email.Outlook Namespace


MapiPropertyContainer.SetProperty Method

Sets the property.

public abstract void SetProperty(
MapiProperty property
);

Parameters

property
The property.

Exceptions

Exception Type | Condition
NotImplementedException |

See Also

MapiPropertyContainer Class | Aspose.Email.Outlook Namespace


MapiPropertyContainer.TryGetPropertyData Method

Try to get the property data with specified tag key.

public byte[] TryGetPropertyData(
long tag
);

Parameters

tag
The tag key.

Return Value

The property data.

See Also

MapiPropertyContainer Class | Aspose.Email.Outlook Namespace


MapiPropertyContainer.TryGetPropertyDateTime Method

public bool TryGetPropertyDateTime(
long tag,
ref DateTime value
);

See Also

MapiPropertyContainer Class | Aspose.Email.Outlook Namespace


MapiPropertyContainer.TryGetPropertyInt32 Method

public bool TryGetPropertyInt32(
long tag,
ref int value
);

See Also

MapiPropertyContainer Class | Aspose.Email.Outlook Namespace


MapiPropertyContainer.TryGetPropertyLong Method

public bool TryGetPropertyLong(
long tag,
ref long value
);

See Also

MapiPropertyContainer Class | Aspose.Email.Outlook Namespace


TryGetPropertyString Method

Aspose.Email

MapiPropertyContainer.TryGetPropertyString Method

Try to get a property data as string with specified tag.

Overload List

Try to get a property data as string with specified tag.

public string TryGetPropertyString(long);

Try to get a property data as string with specified tag and code page.

public string TryGetPropertyString(long,int);

public bool TryGetPropertyString(long,ref string);

public bool TryGetPropertyString(long,ref string,int);

See Also

MapiPropertyContainer Class | Aspose.Email.Outlook Namespace


MapiPropertyContainer.TryGetPropertyString Method (Int64)

Try to get a property data as string with specified tag.

public string TryGetPropertyString(
long tag
);

Parameters

tag
The property tag key.

Return Value

String that contains the contents of property data.

See Also

MapiPropertyContainer Class | Aspose.Email.Outlook Namespace | MapiPropertyContainer.TryGetPropertyString Overload List


MapiPropertyContainer.TryGetPropertyString Method (Int64, Int32)

Try to get a property data as string with specified tag and code page.

public string TryGetPropertyString(
long tag,
int codepage
);

Parameters

tag
The property tag key.
codepage
The code page.

Return Value

String that contains the contents of property data.

See Also

MapiPropertyContainer Class | Aspose.Email.Outlook Namespace | MapiPropertyContainer.TryGetPropertyString Overload List


MapiPropertyContainer.TryGetPropertyString Method (Int64, String)

public bool TryGetPropertyString(
long tag,
ref string value
);

See Also

MapiPropertyContainer Class | Aspose.Email.Outlook Namespace | MapiPropertyContainer.TryGetPropertyString Overload List


MapiPropertyContainer.TryGetPropertyString Method (Int64, String, Int32)

public bool TryGetPropertyString(
long tag,
ref string value,
int codepage
);

See Also

MapiPropertyContainer Class | Aspose.Email.Outlook Namespace | MapiPropertyContainer.TryGetPropertyString Overload List


MapiPropertyStream Class

Represents the property stream.

For a list of all members of this type, see MapiPropertyStream Members.

System.Object
Aspose.Email.Outlook.MapiPropertyContainer
Aspose.Email.Outlook.MapiPropertyStream
Aspose.Email.Outlook.MapiAttachmentPropertyStream
Aspose.Email.Outlook.MapiMessagePropertyStream
Aspose.Email.Outlook.MapiRecipientPropertyStream

public abstract class MapiPropertyStream : MapiPropertyContainer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiPropertyStream Members | Aspose.Email.Outlook Namespace


MapiPropertyStream Members

MapiPropertyStream overview

Public Instance Properties

CodePage (inherited from MapiPropertyContainer) | Gets the code page.
Content | Gets the content.
Name | Gets the name.
Properties (inherited from MapiPropertyContainer) | Gets the collection of properties.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPropertyBoolean (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Boolean type.
GetPropertyBytes (inherited from MapiPropertyContainer) | Gets the string value of the property specified by tag.
GetPropertyDateTime (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as DateTime type.
GetPropertyInt32 (inherited from MapiPropertyContainer) | Gets the int32 value of the property specified by tag.
GetPropertyLong (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Long (int64) type.
GetPropertyShort (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Short type.
GetPropertyString (inherited from MapiPropertyContainer) | Overloaded. Gets the string value of the property specified by tag.
GetType (inherited from Object) | Gets the Type of the current instance.
IsStoreUnicodeOk (inherited from MapiPropertyContainer) | Determines if string properties are Unicode encoded or not.
SetProperty (inherited from MapiPropertyContainer) | Sets the property.
ToString (inherited from Object) | Returns a String that represents the current Object.
TryGetPropertyData (inherited from MapiPropertyContainer) | Try to get the property data with specified tag key.
TryGetPropertyDateTime (inherited from MapiPropertyContainer) |
TryGetPropertyInt32 (inherited from MapiPropertyContainer) |
TryGetPropertyLong (inherited from MapiPropertyContainer) |
TryGetPropertyString (inherited from MapiPropertyContainer) | Overloaded. Try to get a property data as string with specified tag and code page.

Protected Instance Constructors

MapiPropertyStream Constructor Initializes a new instance of the MapiPropertyStream class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetContent |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MapiPropertyStream Class | Aspose.Email.Outlook Namespace


MapiPropertyStream Constructor

Initializes a new instance of the MapiPropertyStream class.

protected MapiPropertyStream();

See Also

MapiPropertyStream Class | Aspose.Email.Outlook Namespace


MapiPropertyStream Properties

The properties of the MapiPropertyStream class are listed below. For a complete list of MapiPropertyStream class members, see the MapiPropertyStream Members topic.

Public Instance Properties

CodePage (inherited from MapiPropertyContainer) | Gets the code page.
Content | Gets the content.
Name | Gets the name.
Properties (inherited from MapiPropertyContainer) | Gets the collection of properties.

See Also

MapiPropertyStream Class | Aspose.Email.Outlook Namespace


Content Property

Aspose.Email

MapiPropertyStream.Content Property

Gets the content.

public object Content {get;}

Property Value

The content.

See Also

MapiPropertyStream Class | Aspose.Email.Outlook Namespace


Name Property

Aspose.Email

MapiPropertyStream.Name Property

Gets the name.

public string Name {get;}

Property Value

The name.

See Also

MapiPropertyStream Class | Aspose.Email.Outlook Namespace


MapiPropertyStream Methods

The methods of the MapiPropertyStream class are listed below. For a complete list of MapiPropertyStream class members, see the MapiPropertyStream Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPropertyBoolean (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Boolean type.
GetPropertyBytes (inherited from MapiPropertyContainer) | Gets the string value of the property specified by tag.
GetPropertyDateTime (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as DateTime type.
GetPropertyInt32 (inherited from MapiPropertyContainer) | Gets the int32 value of the property specified by tag.
GetPropertyLong (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Long (int64) type.
GetPropertyShort (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Short type.
GetPropertyString (inherited from MapiPropertyContainer) | Overloaded. Gets the string value of the property specified by tag.
GetType (inherited from Object) | Gets the Type of the current instance.
IsStoreUnicodeOk (inherited from MapiPropertyContainer) | Determines if string properties are Unicode encoded or not.
SetProperty (inherited from MapiPropertyContainer) | Sets the property.
ToString (inherited from Object) | Returns a String that represents the current Object.
TryGetPropertyData (inherited from MapiPropertyContainer) | Try to get the property data with specified tag key.
TryGetPropertyDateTime (inherited from MapiPropertyContainer) |
TryGetPropertyInt32 (inherited from MapiPropertyContainer) |
TryGetPropertyLong (inherited from MapiPropertyContainer) |
TryGetPropertyString (inherited from MapiPropertyContainer) | Overloaded. Try to get a property data as string with specified tag and code page.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetContent |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MapiPropertyStream Class | Aspose.Email.Outlook Namespace


MapiPropertyStream.GetContent Method

protected abstract MemoryStream GetContent();

See Also

MapiPropertyStream Class | Aspose.Email.Outlook Namespace


MapiPropertyTag Class

Represents the MAPI property tags definition.

For a list of all members of this type, see MapiPropertyTag Members.

System.Object
Aspose.Email.Outlook.MapiPropertyTag

public sealed class MapiPropertyTag

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiPropertyTag Members | Aspose.Email.Outlook Namespace


MapiPropertyTag Members

MapiPropertyTag overview

Public Static Fields

PR_7BIT_DISPLAY_NAME | The PR_7BIT_DISPLAY_NAME property contains a 7-bit ASCII version of a messaging user's name.
PR_7BIT_DISPLAY_NAME_A | The ASCII peer for PR_7BIT_DISPLAY_NAME.
PR_7BIT_DISPLAY_NAME_W | The Unicode peer for PR_7BIT_DISPLAY_NAME.
PR_AB_DEFAULT_DIR | The PR_AB_DEFAULT_DIR property contains the entry identifier of the address book container that is to be shown to the user first.
PR_AB_DEFAULT_PAB | The PR_AB_DEFAULT_PAB property contains the entry identifier of the address book container that is to be used as the personal address book.
PR_AB_PROVIDER_ID | The PR_AB_DEFAULT_PAB property contains the entry identifier of the address book container that is to be used as the personal address book.
PR_AB_PROVIDERS | The PR_AB_PROVIDERS property contains a list of identifiers for address book providers in the current profile.
PR_AB_SEARCH_PATH | The PR_AB_PROVIDERS property contains a list of identifiers for address book providers in the current profile.
PR_AB_SEARCH_PATH_UPDATE |
PR_ABSTRACT |
PR_ABSTRACT_A |
PR_ABSTRACT_W |
PR_ACCESS |
PR_ACCESS_LEVEL |
PR_ACCOUNT |
PR_ACCOUNT_A |
PR_ACCOUNT_W |
PR_ACKNOWLEDGEMENT_MODE |
PR_ACL_DATA |
PR_ACL_TABLE |
PR_ACTIVE_USER_ENTRYID |
PR_ADDRBOOK_FOR_LOCAL_SITE_ENTRYID |
PR_ADDRESS_BOOK_DISPLAY_NAME |
PR_ADDRESS_BOOK_DISPLAY_NAME_A |
PR_ADDRESS_BOOK_DISPLAY_NAME_W |
PR_ADDRESS_BOOK_ENTRYID |
PR_ADDRTYPE |
PR_ADDRTYPE_A |
PR_ADDRTYPE_W |
PR_ALTERNATE_RECIPIENT |
PR_ALTERNATE_RECIPIENT_ALLOWED |
PR_ANR |
PR_ANR_A |
PR_ANR_W |
PR_ARRIVAL_TIME |
PR_ASSISTANT |
PR_ASSISTANT_A |
PR_ASSISTANT_TELEPHONE_NUMBER |
PR_ASSISTANT_TELEPHONE_NUMBER_A |
PR_ASSISTANT_TELEPHONE_NUMBER_W |
PR_ASSISTANT_W |
PR_ASSOC_CONTENT_COUNT |
PR_ASSOC_MESSAGE_SIZE |
PR_ASSOC_MESSAGE_SIZE_EXTENDED |
PR_ASSOC_MSG_W_ATTACH_COUNT |
PR_ATTACH_ADDITIONAL_INFO |
PR_ATTACH_CONTENT_ID | Contains the content identification header of a MIME message attachment. This property is used for MHTML support.
PR_ATTACH_CONTENT_ID_A | Contains the content identification header of a MIME message attachment. This property is used for MHTML support. Non-UNICODE compilation.
PR_ATTACH_CONTENT_ID_W | Contains the content identification header of a MIME message attachment. This property is used for MHTML support. UNICODE compilation.
PR_ATTACH_DATA_BIN |
PR_ATTACH_DATA_OBJ |
PR_ATTACH_ENCODING |
PR_ATTACH_EXTENSION |
PR_ATTACH_EXTENSION_A |
PR_ATTACH_EXTENSION_W |
PR_ATTACH_FILENAME |
PR_ATTACH_FILENAME_A |
PR_ATTACH_FILENAME_W |
PR_ATTACH_LONG_FILENAME |
PR_ATTACH_LONG_FILENAME_A |
PR_ATTACH_LONG_FILENAME_W |
PR_ATTACH_LONG_PATHNAME |
PR_ATTACH_LONG_PATHNAME_A |
PR_ATTACH_LONG_PATHNAME_W |
PR_ATTACH_METHOD |
PR_ATTACH_MIME_TAG |
PR_ATTACH_MIME_TAG_A |
PR_ATTACH_MIME_TAG_W |
PR_ATTACH_NUM |
PR_ATTACH_ON_ASSOC_MSG_COUNT |
PR_ATTACH_ON_NORMAL_MSG_COUNT |
PR_ATTACH_PATHNAME |
PR_ATTACH_PATHNAME_A |
PR_ATTACH_PATHNAME_W |
PR_ATTACH_RENDERING |
PR_ATTACH_SIZE |
PR_ATTACH_TAG |
PR_ATTACH_TRANSPORT_NAME |
PR_ATTACH_TRANSPORT_NAME_A |
PR_ATTACH_TRANSPORT_NAME_W |
PR_ATTACHMENT_CONTACTPHOTO |
PR_ATTACHMENT_FLAGS |
PR_ATTACHMENT_X400_PARAMETERS |
PR_AUTHORIZING_USERS |
PR_AUTO_ADD_NEW_SUBS |
PR_AUTO_FORWARD_COMMENT |
PR_AUTO_FORWARD_COMMENT_A |
PR_AUTO_FORWARD_COMMENT_W |
PR_AUTO_FORWARDED |
PR_AUTO_RESPONSE_SUPPRESS |
PR_BEEPER_TELEPHONE_NUMBER |
PR_BEEPER_TELEPHONE_NUMBER_A |
PR_BEEPER_TELEPHONE_NUMBER_W |
PR_BILATERAL_INFO |
PR_BIRTHDAY |
PR_BODY |
PR_BODY_A |
PR_BODY_CRC |
PR_BODY_W |
PR_BUSINESS_ADDRESS_CITY |
PR_BUSINESS_ADDRESS_CITY_A |
PR_BUSINESS_ADDRESS_CITY_W |
PR_BUSINESS_ADDRESS_COUNTRY |
PR_BUSINESS_ADDRESS_COUNTRY_A |
PR_BUSINESS_ADDRESS_COUNTRY_W |
PR_BUSINESS_ADDRESS_POST_OFFICE_BOX |
PR_BUSINESS_ADDRESS_POST_OFFICE_BOX_A |
PR_BUSINESS_ADDRESS_POST_OFFICE_BOX_W |
PR_BUSINESS_ADDRESS_POSTAL_CODE |
PR_BUSINESS_ADDRESS_POSTAL_CODE_A |
PR_BUSINESS_ADDRESS_POSTAL_CODE_W |
PR_BUSINESS_ADDRESS_STATE_OR_PROVINCE |
PR_BUSINESS_ADDRESS_STATE_OR_PROVINCE_A |
PR_BUSINESS_ADDRESS_STATE_OR_PROVINCE_W |
PR_BUSINESS_ADDRESS_STREET |
PR_BUSINESS_ADDRESS_STREET_A |
PR_BUSINESS_ADDRESS_STREET_W |
PR_BUSINESS_FAX_NUMBER |
PR_BUSINESS_FAX_NUMBER_A |
PR_BUSINESS_FAX_NUMBER_W |
PR_BUSINESS_HOME_PAGE |
PR_BUSINESS_HOME_PAGE_A |
PR_BUSINESS_HOME_PAGE_W |
PR_BUSINESS_TELEPHONE_NUMBER |
PR_BUSINESS_TELEPHONE_NUMBER_A |
PR_BUSINESS_TELEPHONE_NUMBER_W |
PR_BUSINESS2_TELEPHONE_NUMBER |
PR_BUSINESS2_TELEPHONE_NUMBER_A |
PR_BUSINESS2_TELEPHONE_NUMBER_W |
PR_CACHED_COLUMN_COUNT |
PR_CALLBACK_TELEPHONE_NUMBER |
PR_CALLBACK_TELEPHONE_NUMBER_A |
PR_CALLBACK_TELEPHONE_NUMBER_W |
PR_CAR_TELEPHONE_NUMBER |
PR_CAR_TELEPHONE_NUMBER_A |
PR_CAR_TELEPHONE_NUMBER_W |
PR_CATEG_COUNT |
PR_CELLULAR_TELEPHONE_NUMBER |
PR_CELLULAR_TELEPHONE_NUMBER_A |
PR_CELLULAR_TELEPHONE_NUMBER_W |
PR_CHANGE_ADVISOR |
PR_CHANGE_KEY |
PR_CHANGE_NOTIFICATION_GUID |
PR_CHILDRENS_NAMES |
PR_CLIENT_ACTIONS |
PR_CLIENT_SUBMIT_TIME |
PR_CODE_PAGE_ID |
PR_COLLECTOR |
PR_COMMENT |
PR_COMMENT_A |
PR_COMMENT_W |
PR_COMMON_VIEWS_ENTRYID |
PR_COMPANY_MAIN_PHONE_NUMBER |
PR_COMPANY_MAIN_PHONE_NUMBER_A |
PR_COMPANY_MAIN_PHONE_NUMBER_W |
PR_COMPANY_NAME |
PR_COMPANY_NAME_A |
PR_COMPANY_NAME_W |
PR_COMPUTER_NETWORK_NAME |
PR_COMPUTER_NETWORK_NAME_A |
PR_COMPUTER_NETWORK_NAME_W |
PR_CONFLICT_ENTRYID |
PR_CONTACT_ADDRTYPES |
PR_CONTACT_COUNT |
PR_CONTACT_DEFAULT_ADDRESS_INDEX |
PR_CONTACT_EMAIL_ADDRESSES |
PR_CONTACT_ENTRYIDS |
PR_CONTACT_VERSION |
PR_CONTAINER_CLASS |
PR_CONTAINER_CLASS_A |
PR_CONTAINER_CLASS_W |
PR_CONTAINER_CONTENTS |
PR_CONTAINER_FLAGS |
PR_CONTAINER_HIERARCHY |
PR_CONTAINER_MODIFY_VERSION |
PR_CONTENT_CONFIDENTIALITY_ALGORITHM_ID |
PR_CONTENT_CORRELATOR |
PR_CONTENT_COUNT |
PR_CONTENT_IDENTIFIER |
PR_CONTENT_IDENTIFIER_A |
PR_CONTENT_IDENTIFIER_W |
PR_CONTENT_INTEGRITY_CHECK |
PR_CONTENT_LENGTH |
PR_CONTENT_RETURN_REQUESTED |
PR_CONTENT_SEARCH_KEY |
PR_CONTENT_UNREAD |
PR_CONTENTS_SORT_ORDER |
PR_CONTENTS_SYNCHRONIZER |
PR_CONTROL_FLAGS |
PR_CONTROL_ID |
PR_CONTROL_STRUCTURE |
PR_CONTROL_TYPE |
PR_CONVERSATION_INDEX |
PR_CONVERSATION_KEY |
PR_CONVERSATION_TOPIC |
PR_CONVERSATION_TOPIC_A |
PR_CONVERSATION_TOPIC_W |
PR_CONVERSION_EITS |
PR_CONVERSION_PROHIBITED |
PR_CONVERSION_WITH_LOSS_PROHIBITED |
PR_CONVERTED_EITS |
PR_CORRELATE |
PR_CORRELATE_MTSID |
PR_COUNTRY |
PR_COUNTRY_A |
PR_COUNTRY_W |
PR_CREATE_TEMPLATES |
PR_CREATION_TIME |
PR_CREATION_VERSION |
PR_CREATOR_ENTRYID |
PR_CREATOR_NAME |
PR_CREATOR_NAME_A |
PR_CREATOR_NAME_W |
PR_CURRENT_VERSION |
PR_CUSTOMER_ID |
PR_CUSTOMER_ID_A |
PR_CUSTOMER_ID_W |
PR_DAM_BACK_PATCHED |
PR_DAM_ORIGINAL_ENTRYID |
PR_DEF_CREATE_DL |
PR_DEF_CREATE_MAILUSER |
PR_DEFAULT_PROFILE |
PR_DEFAULT_STORE |
PR_DEFAULT_VIEW_ENTRYID |
PR_DEFERRED_DELIVERY_TIME |
PR_DEFERRED_SEND_NUMBER |
PR_DEFERRED_SEND_TIME |
PR_DEFERRED_SEND_UNITS |
PR_DELEGATED_BY_RULE |
PR_DELEGATION |
PR_DELETE_AFTER_SUBMIT |
PR_DELETED_ASSOC_MESSAGE_SIZE_EXTENDED |
PR_DELETED_ASSOC_MSG_COUNT |
PR_DELETED_FOLDER_COUNT |
PR_DELETED_MESSAGE_SIZE_EXTENDED |
PR_DELETED_MSG_COUNT |
PR_DELETED_NORMAL_MESSAGE_SIZE_EXTENDED |
PR_DELETED_ON |
PR_DELIVER_TIME |
PR_DELIVERY_POINT |
PR_DELTAX |
PR_DELTAY |
PR_DEPARTMENT_NAME |
PR_DEPARTMENT_NAME_A |
PR_DEPARTMENT_NAME_W |
PR_DEPTH |
PR_DESIGN_IN_PROGRESS |
PR_DETAILS_TABLE |
PR_DISABLE_FULL_FIDELITY |
PR_DISABLE_WINSOCK |
PR_DISC_VAL |
PR_DISCARD_REASON |
PR_DISCLOSE_RECIPIENTS |
PR_DISCLOSURE_OF_RECIPIENTS |
PR_DISCRETE_VALUES |
PR_DISPLAY_BCC |
PR_DISPLAY_BCC_A |
PR_DISPLAY_BCC_W |
PR_DISPLAY_CC |
PR_DISPLAY_CC_A |
PR_DISPLAY_CC_W |
PR_DISPLAY_NAME |
PR_DISPLAY_NAME_A |
PR_DISPLAY_NAME_PREFIX |
PR_DISPLAY_NAME_PREFIX_A |
PR_DISPLAY_NAME_PREFIX_W |
PR_DISPLAY_NAME_W |
PR_DISPLAY_TO |
PR_DISPLAY_TO_A |
PR_DISPLAY_TO_W |
PR_DISPLAY_TYPE |
PR_DL_EXPANSION_HISTORY |
PR_DL_EXPANSION_PROHIBITED |
PR_DL_REPORT_FLAGS |
PR_EFORMS_FOR_LOCALE_ENTRYID |
PR_EFORMS_LOCALE_ID |
PR_EFORMS_REGISTRY_ENTRYID |
PR_EMAIL_ADDRESS |
PR_EMAIL_ADDRESS_A |
PR_EMAIL_ADDRESS_W |
PR_EMS_AB_ACCESS_CATEGORY |
PR_EMS_AB_ACTIVATION_SCHEDULE |
PR_EMS_AB_ACTIVATION_STYLE |
PR_EMS_AB_ADDRESS_ENTRY_DISPLAY_TABLE |
PR_EMS_AB_ADDRESS_ENTRY_DISPLAY_TABLE_MSDOS |
PR_EMS_AB_ADDRESS_SYNTAX |
PR_EMS_AB_ADDRESS_TYPE |
PR_EMS_AB_ADDRESS_TYPE_A |
PR_EMS_AB_ADDRESS_TYPE_W |
PR_EMS_AB_ADMD |
PR_EMS_AB_ADMD_A |
PR_EMS_AB_ADMD_W |
PR_EMS_AB_ADMIN_DESCRIPTION |
PR_EMS_AB_ADMIN_DESCRIPTION_A |
PR_EMS_AB_ADMIN_DESCRIPTION_W |
PR_EMS_AB_ADMIN_DISPLAY_NAME |
PR_EMS_AB_ADMIN_DISPLAY_NAME_A |
PR_EMS_AB_ADMIN_DISPLAY_NAME_W |
PR_EMS_AB_ADMIN_EXTENSION_DLL |
PR_EMS_AB_ADMIN_EXTENSION_DLL_A |
PR_EMS_AB_ADMIN_EXTENSION_DLL_W |
PR_EMS_AB_ALIASED_OBJECT_NAME |
PR_EMS_AB_ALIASED_OBJECT_NAME_A |
PR_EMS_AB_ALIASED_OBJECT_NAME_O |
PR_EMS_AB_ALIASED_OBJECT_NAME_W |
PR_EMS_AB_ALT_RECIPIENT |
PR_EMS_AB_ALT_RECIPIENT_A |
PR_EMS_AB_ALT_RECIPIENT_BL |
PR_EMS_AB_ALT_RECIPIENT_BL_O |
PR_EMS_AB_ALT_RECIPIENT_O |
PR_EMS_AB_ALT_RECIPIENT_W |
PR_EMS_AB_ANCESTOR_ID |
PR_EMS_AB_ANONYMOUS_ACCESS |
PR_EMS_AB_ANONYMOUS_ACCOUNT |
PR_EMS_AB_ANONYMOUS_ACCOUNT_A |
PR_EMS_AB_ANONYMOUS_ACCOUNT_W |
PR_EMS_AB_ASSOC_NT_ACCOUNT |
PR_EMS_AB_ASSOC_PROTOCOL_CFG_NNTP |
PR_EMS_AB_ASSOC_PROTOCOL_CFG_NNTP_A |
PR_EMS_AB_ASSOC_PROTOCOL_CFG_NNTP_O |
PR_EMS_AB_ASSOC_PROTOCOL_CFG_NNTP_W |
PR_EMS_AB_ASSOC_REMOTE_DXA |
PR_EMS_AB_ASSOC_REMOTE_DXA_O |
PR_EMS_AB_ASSOCIATION_LIFETIME |
PR_EMS_AB_ATTRIBUTE_CERTIFICATE |
PR_EMS_AB_AUTH_ORIG_BL |
PR_EMS_AB_AUTH_ORIG_BL_O |
PR_EMS_AB_AUTHENTICATION_TO_USE |
PR_EMS_AB_AUTHENTICATION_TO_USE_A |
PR_EMS_AB_AUTHENTICATION_TO_USE_W |
PR_EMS_AB_AUTHORITY_REVOCATION_LIST |
PR_EMS_AB_AUTHORIZED_DOMAIN |
PR_EMS_AB_AUTHORIZED_DOMAIN_A |
PR_EMS_AB_AUTHORIZED_DOMAIN_W |
PR_EMS_AB_AUTHORIZED_PASSWORD |
PR_EMS_AB_AUTHORIZED_PASSWORD_CONFIRM |
PR_EMS_AB_AUTHORIZED_USER |
PR_EMS_AB_AUTHORIZED_USER_A |
PR_EMS_AB_AUTHORIZED_USER_W |
PR_EMS_AB_AUTOREPLY |
PR_EMS_AB_AUTOREPLY_MESSAGE |
PR_EMS_AB_AUTOREPLY_MESSAGE_A |
PR_EMS_AB_AUTOREPLY_MESSAGE_W |
PR_EMS_AB_AUTOREPLY_SUBJECT |
PR_EMS_AB_AUTOREPLY_SUBJECT_A |
PR_EMS_AB_AUTOREPLY_SUBJECT_W |
PR_EMS_AB_AVAILABLE_AUTHORIZATION_PACKAGES |
PR_EMS_AB_AVAILABLE_DISTRIBUTIONS |
PR_EMS_AB_AVAILABLE_DISTRIBUTIONS_A |
PR_EMS_AB_AVAILABLE_DISTRIBUTIONS_W |
PR_EMS_AB_BRIDGEHEAD_SERVERS |
PR_EMS_AB_BRIDGEHEAD_SERVERS_O |
PR_EMS_AB_BUSINESS_CATEGORY |
PR_EMS_AB_BUSINESS_ROLES |
PR_EMS_AB_CA_CERTIFICATE |
PR_EMS_AB_CAN_CREATE_PF |
PR_EMS_AB_CAN_CREATE_PF_BL |
PR_EMS_AB_CAN_CREATE_PF_BL_O |
PR_EMS_AB_CAN_CREATE_PF_DL |
PR_EMS_AB_CAN_CREATE_PF_DL_BL |
PR_EMS_AB_CAN_CREATE_PF_DL_BL_O |
PR_EMS_AB_CAN_CREATE_PF_DL_O |
PR_EMS_AB_CAN_CREATE_PF_O |
PR_EMS_AB_CAN_NOT_CREATE_PF |
PR_EMS_AB_CAN_NOT_CREATE_PF_BL |
PR_EMS_AB_CAN_NOT_CREATE_PF_BL_O |
PR_EMS_AB_CAN_NOT_CREATE_PF_DL |
PR_EMS_AB_CAN_NOT_CREATE_PF_DL_BL |
PR_EMS_AB_CAN_NOT_CREATE_PF_DL_BL_O |
PR_EMS_AB_CAN_NOT_CREATE_PF_DL_O |
PR_EMS_AB_CAN_NOT_CREATE_PF_O |
PR_EMS_AB_CAN_PRESERVE_DNS |
PR_EMS_AB_CERTIFICATE_CHAIN_V3 |
PR_EMS_AB_CERTIFICATE_REVOCATION_LIST |
PR_EMS_AB_CERTIFICATE_REVOCATION_LIST_V1 |
PR_EMS_AB_CERTIFICATE_REVOCATION_LIST_V3 |
PR_EMS_AB_CHARACTER_SET |
PR_EMS_AB_CHARACTER_SET_A |
PR_EMS_AB_CHARACTER_SET_LIST |
PR_EMS_AB_CHARACTER_SET_W |
PR_EMS_AB_CHILD_RDNS |
PR_EMS_AB_CLIENT_ACCESS_ENABLED |
PR_EMS_AB_CLOCK_ALERT_OFFSET |
PR_EMS_AB_CLOCK_ALERT_REPAIR |
PR_EMS_AB_CLOCK_WARNING_OFFSET |
PR_EMS_AB_CLOCK_WARNING_REPAIR |
PR_EMS_AB_COMPROMISED_KEY_LIST |
PR_EMS_AB_COMPUTER_NAME |
PR_EMS_AB_COMPUTER_NAME_A |
PR_EMS_AB_COMPUTER_NAME_W |
PR_EMS_AB_CONNECTED_DOMAINS |
PR_EMS_AB_CONNECTION_LIST_FILTER |
PR_EMS_AB_CONNECTION_LIST_FILTER_TYPE |
PR_EMS_AB_CONNECTION_TYPE |
PR_EMS_AB_CONTAINER_INFO |
PR_EMS_AB_CONTAINERID |
PR_EMS_AB_CONTENT_TYPE |
PR_EMS_AB_CONTROL_MSG_FOLDER_ID |
PR_EMS_AB_CONTROL_MSG_RULES |
PR_EMS_AB_COST |
PR_EMS_AB_COUNTRY_NAME |
PR_EMS_AB_COUNTRY_NAME_A |
PR_EMS_AB_COUNTRY_NAME_W |
PR_EMS_AB_CROSS_CERTIFICATE_CRL |
PR_EMS_AB_CROSS_CERTIFICATE_PAIR |
PR_EMS_AB_DEFAULT_MESSAGE_FORMAT |
PR_EMS_AB_DELEGATE_USER |
PR_EMS_AB_DELIV_CONT_LENGTH |
PR_EMS_AB_DELIV_EITS |
PR_EMS_AB_DELIV_EXT_CONT_TYPES |
PR_EMS_AB_DELIVER_AND_REDIRECT |
PR_EMS_AB_DELIVERY_MECHANISM |
PR_EMS_AB_DELTA_REVOCATION_LIST |
PR_EMS_AB_DESCRIPTION |
PR_EMS_AB_DESTINATION_INDICATOR |
PR_EMS_AB_DIAGNOSTIC_REG_KEY |
PR_EMS_AB_DIAGNOSTIC_REG_KEY_A |
PR_EMS_AB_DIAGNOSTIC_REG_KEY_W |
PR_EMS_AB_DISABLE_DEFERRED_COMMIT |
PR_EMS_AB_DISABLED_GATEWAY_PROXY |
PR_EMS_AB_DISPLAY_NAME_OVERRIDE |
PR_EMS_AB_DISPLAY_NAME_PRINTABLE |
PR_EMS_AB_DISPLAY_NAME_PRINTABLE_A |
PR_EMS_AB_DISPLAY_NAME_PRINTABLE_W |
PR_EMS_AB_DISPLAY_NAME_SUFFIX |
PR_EMS_AB_DISPLAY_NAME_SUFFIX_A |
PR_EMS_AB_DISPLAY_NAME_SUFFIX_W |
PR_EMS_AB_DL_MEM_REJECT_PERMS_BL |
PR_EMS_AB_DL_MEM_REJECT_PERMS_BL_O |
PR_EMS_AB_DL_MEM_SUBMIT_PERMS_BL |
PR_EMS_AB_DL_MEM_SUBMIT_PERMS_BL_O |
PR_EMS_AB_DL_MEMBER_RULE |
PR_EMS_AB_DMD_NAME |
PR_EMS_AB_DMD_NAME_A |
PR_EMS_AB_DMD_NAME_W |
PR_EMS_AB_DO_OAB_VERSION |
PR_EMS_AB_DOMAIN_DEF_ALT_RECIP |
PR_EMS_AB_DOMAIN_DEF_ALT_RECIP_A |
PR_EMS_AB_DOMAIN_DEF_ALT_RECIP_O |
PR_EMS_AB_DOMAIN_DEF_ALT_RECIP_W |
PR_EMS_AB_DOMAIN_NAME |
PR_EMS_AB_DOMAIN_NAME_A |
PR_EMS_AB_DOMAIN_NAME_W |
PR_EMS_AB_DOS_ENTRYID |
PR_EMS_AB_DSA_SIGNATURE |
PR_EMS_AB_DXA_ADMIN_COPY |
PR_EMS_AB_DXA_ADMIN_FORWARD |
PR_EMS_AB_DXA_ADMIN_UPDATE |
PR_EMS_AB_DXA_APPEND_REQCN |
PR_EMS_AB_DXA_CONF_CONTAINER_LIST |
PR_EMS_AB_DXA_CONF_CONTAINER_LIST_O |
PR_EMS_AB_DXA_CONF_REQ_TIME |
PR_EMS_AB_DXA_CONF_SEQ |
PR_EMS_AB_DXA_CONF_SEQ_A |
PR_EMS_AB_DXA_CONF_SEQ_USN |
PR_EMS_AB_DXA_CONF_SEQ_W |
PR_EMS_AB_DXA_EXCHANGE_OPTIONS |
PR_EMS_AB_DXA_EXPORT_NOW |
PR_EMS_AB_DXA_FLAGS |
PR_EMS_AB_DXA_IMP_SEQ |
PR_EMS_AB_DXA_IMP_SEQ_A |
PR_EMS_AB_DXA_IMP_SEQ_TIME |
PR_EMS_AB_DXA_IMP_SEQ_USN |
PR_EMS_AB_DXA_IMP_SEQ_W |
PR_EMS_AB_DXA_IMPORT_NOW |
PR_EMS_AB_DXA_IN_TEMPLATE_MAP |
PR_EMS_AB_DXA_LOCAL_ADMIN |
PR_EMS_AB_DXA_LOCAL_ADMIN_A |
PR_EMS_AB_DXA_LOCAL_ADMIN_O |
PR_EMS_AB_DXA_LOCAL_ADMIN_W |
PR_EMS_AB_DXA_LOGGING_LEVEL |
PR_EMS_AB_DXA_NATIVE_ADDRESS_TYPE |
PR_EMS_AB_DXA_NATIVE_ADDRESS_TYPE_A |
PR_EMS_AB_DXA_NATIVE_ADDRESS_TYPE_W |
PR_EMS_AB_DXA_OUT_TEMPLATE_MAP |
PR_EMS_AB_DXA_PASSWORD |
PR_EMS_AB_DXA_PASSWORD_A |
PR_EMS_AB_DXA_PASSWORD_W |
PR_EMS_AB_DXA_PREV_EXCHANGE_OPTIONS |
PR_EMS_AB_DXA_PREV_EXPORT_NATIVE_ONLY |
PR_EMS_AB_DXA_PREV_IN_EXCHANGE_SENSITIVITY |
PR_EMS_AB_DXA_PREV_REMOTE_ENTRIES |
PR_EMS_AB_DXA_PREV_REMOTE_ENTRIES_A |
PR_EMS_AB_DXA_PREV_REMOTE_ENTRIES_O |
PR_EMS_AB_DXA_PREV_REMOTE_ENTRIES_W |
PR_EMS_AB_DXA_PREV_REPLICATION_SENSITIVITY |
PR_EMS_AB_DXA_PREV_TEMPLATE_OPTIONS |
PR_EMS_AB_DXA_PREV_TYPES |
PR_EMS_AB_DXA_RECIPIENT_CP |
PR_EMS_AB_DXA_RECIPIENT_CP_A |
PR_EMS_AB_DXA_RECIPIENT_CP_W |
PR_EMS_AB_DXA_REMOTE_CLIENT |
PR_EMS_AB_DXA_REMOTE_CLIENT_A |
PR_EMS_AB_DXA_REMOTE_CLIENT_O |
PR_EMS_AB_DXA_REMOTE_CLIENT_W |
PR_EMS_AB_DXA_REQ_SEQ |
PR_EMS_AB_DXA_REQ_SEQ_A |
PR_EMS_AB_DXA_REQ_SEQ_TIME |
PR_EMS_AB_DXA_REQ_SEQ_USN |
PR_EMS_AB_DXA_REQ_SEQ_W |
PR_EMS_AB_DXA_REQNAME |
PR_EMS_AB_DXA_REQNAME_A |
PR_EMS_AB_DXA_REQNAME_W |
PR_EMS_AB_DXA_SVR_SEQ |
PR_EMS_AB_DXA_SVR_SEQ_A |
PR_EMS_AB_DXA_SVR_SEQ_TIME |
PR_EMS_AB_DXA_SVR_SEQ_USN |
PR_EMS_AB_DXA_SVR_SEQ_W |
PR_EMS_AB_DXA_TASK |
PR_EMS_AB_DXA_TEMPLATE_OPTIONS |
PR_EMS_AB_DXA_TEMPLATE_TIMESTAMP |
PR_EMS_AB_DXA_TYPES |
PR_EMS_AB_DXA_UNCONF_CONTAINER_LIST |
PR_EMS_AB_DXA_UNCONF_CONTAINER_LIST_O |
PR_EMS_AB_EMPLOYEE_NUMBER |
PR_EMS_AB_EMPLOYEE_NUMBER_A |
PR_EMS_AB_EMPLOYEE_NUMBER_W |
PR_EMS_AB_EMPLOYEE_TYPE |
PR_EMS_AB_EMPLOYEE_TYPE_A |
PR_EMS_AB_EMPLOYEE_TYPE_W |
PR_EMS_AB_ENABLE_COMPATIBILITY |
PR_EMS_AB_ENABLED |
PR_EMS_AB_ENABLED_AUTHORIZATION_PACKAGES |
PR_EMS_AB_ENABLED_PROTOCOL_CFG |
PR_EMS_AB_ENABLED_PROTOCOLS |
PR_EMS_AB_ENCAPSULATION_METHOD |
PR_EMS_AB_ENCRYPT |
PR_EMS_AB_ENCRYPT_ALG_LIST_NA |
PR_EMS_AB_ENCRYPT_ALG_LIST_OTHER |
PR_EMS_AB_ENCRYPT_ALG_SELECTED_NA |
PR_EMS_AB_ENCRYPT_ALG_SELECTED_NA_A |
PR_EMS_AB_ENCRYPT_ALG_SELECTED_NA_W |
PR_EMS_AB_ENCRYPT_ALG_SELECTED_OTHER |
PR_EMS_AB_ENCRYPT_ALG_SELECTED_OTHER_A |
PR_EMS_AB_ENCRYPT_ALG_SELECTED_OTHER_W |
PR_EMS_AB_EXPAND_DLS_LOCALLY |
PR_EMS_AB_EXPIRATION_TIME |
PR_EMS_AB_EXPORT_CONTAINERS |
PR_EMS_AB_EXPORT_CONTAINERS_O |
PR_EMS_AB_EXPORT_CUSTOM_RECIPIENTS |
PR_EMS_AB_EXTENDED_CHARS_ALLOWED |
PR_EMS_AB_EXTENSION_ATTRIBUTE_1 |
PR_EMS_AB_EXTENSION_ATTRIBUTE_1_A |
PR_EMS_AB_EXTENSION_ATTRIBUTE_1_W |
PR_EMS_AB_EXTENSION_ATTRIBUTE_10 |
PR_EMS_AB_EXTENSION_ATTRIBUTE_10_A |
PR_EMS_AB_EXTENSION_ATTRIBUTE_10_W |
PR_EMS_AB_EXTENSION_ATTRIBUTE_11 |
PR_EMS_AB_EXTENSION_ATTRIBUTE_11_A |
PR_EMS_AB_EXTENSION_ATTRIBUTE_11_W |
PR_EMS_AB_EXTENSION_ATTRIBUTE_12 |
PR_EMS_AB_EXTENSION_ATTRIBUTE_12_A |
PR_EMS_AB_EXTENSION_ATTRIBUTE_12_W |
PR_EMS_AB_EXTENSION_ATTRIBUTE_13 |
PR_EMS_AB_EXTENSION_ATTRIBUTE_13_A |
PR_EMS_AB_EXTENSION_ATTRIBUTE_13_W |
PR_EMS_AB_EXTENSION_ATTRIBUTE_14 |
PR_EMS_AB_EXTENSION_ATTRIBUTE_14_A |
PR_EMS_AB_EXTENSION_ATTRIBUTE_14_W |
PR_EMS_AB_EXTENSION_ATTRIBUTE_15 |
PR_EMS_AB_EXTENSION_ATTRIBUTE_15_A |
PR_EMS_AB_EXTENSION_ATTRIBUTE_15_W |
PR_EMS_AB_EXTENSION_ATTRIBUTE_2 |
PR_EMS_AB_EXTENSION_ATTRIBUTE_2_A |
PR_EMS_AB_EXTENSION_ATTRIBUTE_2_W |
PR_EMS_AB_EXTENSION_ATTRIBUTE_3 |
PR_EMS_AB_EXTENSION_ATTRIBUTE_3_A |
PR_EMS_AB_EXTENSION_ATTRIBUTE_3_W |
PR_EMS_AB_EXTENSION_ATTRIBUTE_4 |
PR_EMS_AB_EXTENSION_ATTRIBUTE_4_A |
PR_EMS_AB_EXTENSION_ATTRIBUTE_4_W |
PR_EMS_AB_EXTENSION_ATTRIBUTE_5 |
PR_EMS_AB_EXTENSION_ATTRIBUTE_5_A |
PR_EMS_AB_EXTENSION_ATTRIBUTE_5_W |
PR_EMS_AB_EXTENSION_ATTRIBUTE_6 |
PR_EMS_AB_EXTENSION_ATTRIBUTE_6_A |
PR_EMS_AB_EXTENSION_ATTRIBUTE_6_W |
PR_EMS_AB_EXTENSION_ATTRIBUTE_7 |
PR_EMS_AB_EXTENSION_ATTRIBUTE_7_A |
PR_EMS_AB_EXTENSION_ATTRIBUTE_7_W |
PR_EMS_AB_EXTENSION_ATTRIBUTE_8 |
PR_EMS_AB_EXTENSION_ATTRIBUTE_8_A |
PR_EMS_AB_EXTENSION_ATTRIBUTE_8_W |
PR_EMS_AB_EXTENSION_ATTRIBUTE_9 |
PR_EMS_AB_EXTENSION_ATTRIBUTE_9_A |
PR_EMS_AB_EXTENSION_ATTRIBUTE_9_W |
PR_EMS_AB_EXTENSION_DATA |
PR_EMS_AB_EXTENSION_NAME |
PR_EMS_AB_EXTENSION_NAME_INHERITED |
PR_EMS_AB_FACSIMILE_TELEPHONE_NUMBER |
PR_EMS_AB_FILE_VERSION |
PR_EMS_AB_FILTER_LOCAL_ADDRESSES |
PR_EMS_AB_FOLDER_PATHNAME |
PR_EMS_AB_FOLDER_PATHNAME_A |
PR_EMS_AB_FOLDER_PATHNAME_W |
PR_EMS_AB_FOLDERS_CONTAINER |
PR_EMS_AB_FOLDERS_CONTAINER_A |
PR_EMS_AB_FOLDERS_CONTAINER_O |
PR_EMS_AB_FOLDERS_CONTAINER_W |
PR_EMS_AB_FORM_DATA |
PR_EMS_AB_FORWARDING_ADDRESS |
PR_EMS_AB_FORWARDING_ADDRESS_A |
PR_EMS_AB_FORWARDING_ADDRESS_W |
PR_EMS_AB_GARBAGE_COLL_PERIOD |
PR_EMS_AB_GATEWAY_LOCAL_CRED |
PR_EMS_AB_GATEWAY_LOCAL_CRED_A |
PR_EMS_AB_GATEWAY_LOCAL_CRED_W |
PR_EMS_AB_GATEWAY_LOCAL_DESIG |
PR_EMS_AB_GATEWAY_LOCAL_DESIG_A |
PR_EMS_AB_GATEWAY_LOCAL_DESIG_W |
PR_EMS_AB_GATEWAY_PROXY |
PR_EMS_AB_GATEWAY_ROUTING_TREE |
PR_EMS_AB_GENERATION_QUALIFIER |
PR_EMS_AB_GENERATION_QUALIFIER_A |
PR_EMS_AB_GENERATION_QUALIFIER_W |
PR_EMS_AB_GROUP_BY_ATTR_1 |
PR_EMS_AB_GROUP_BY_ATTR_1_A |
PR_EMS_AB_GROUP_BY_ATTR_1_W |
PR_EMS_AB_GROUP_BY_ATTR_2 |
PR_EMS_AB_GROUP_BY_ATTR_2_A |
PR_EMS_AB_GROUP_BY_ATTR_2_W |
PR_EMS_AB_GROUP_BY_ATTR_3 |
PR_EMS_AB_GROUP_BY_ATTR_3_A |
PR_EMS_AB_GROUP_BY_ATTR_3_W |
PR_EMS_AB_GROUP_BY_ATTR_4 |
PR_EMS_AB_GROUP_BY_ATTR_4_A |
PR_EMS_AB_GROUP_BY_ATTR_4_W |
PR_EMS_AB_GROUP_BY_ATTR_VALUE_DN |
PR_EMS_AB_GROUP_BY_ATTR_VALUE_DN_A |
PR_EMS_AB_GROUP_BY_ATTR_VALUE_DN_O |
PR_EMS_AB_GROUP_BY_ATTR_VALUE_DN_W |
PR_EMS_AB_GROUP_BY_ATTR_VALUE_STR |
PR_EMS_AB_GROUP_BY_ATTR_VALUE_STR_A |
PR_EMS_AB_GROUP_BY_ATTR_VALUE_STR_W |
PR_EMS_AB_GWART_LAST_MODIFIED |
PR_EMS_AB_HAS_FULL_REPLICA_NCS |
PR_EMS_AB_HAS_FULL_REPLICA_NCS_O |
PR_EMS_AB_HAS_MASTER_NCS |
PR_EMS_AB_HAS_MASTER_NCS_O |
PR_EMS_AB_HELP_DATA16 |
PR_EMS_AB_HELP_DATA32 |
PR_EMS_AB_HELP_FILE_NAME |
PR_EMS_AB_HELP_FILE_NAME_A |
PR_EMS_AB_HELP_FILE_NAME_W |
PR_EMS_AB_HEURISTICS |
PR_EMS_AB_HIDE_DL_MEMBERSHIP |
PR_EMS_AB_HIDE_FROM_ADDRESS_BOOK |
PR_EMS_AB_HIERARCHY_PATH |
PR_EMS_AB_HIERARCHY_PATH_A |
PR_EMS_AB_HIERARCHY_PATH_W |
PR_EMS_AB_HOME_MDB |
PR_EMS_AB_HOME_MDB_A |
PR_EMS_AB_HOME_MDB_BL |
PR_EMS_AB_HOME_MDB_BL_O |
PR_EMS_AB_HOME_MDB_O |
PR_EMS_AB_HOME_MDB_W |
PR_EMS_AB_HOME_MTA |
PR_EMS_AB_HOME_MTA_A |
PR_EMS_AB_HOME_MTA_O |
PR_EMS_AB_HOME_MTA_W |
PR_EMS_AB_HOME_PUBLIC_SERVER |
PR_EMS_AB_HOME_PUBLIC_SERVER_A |
PR_EMS_AB_HOME_PUBLIC_SERVER_O |
PR_EMS_AB_HOME_PUBLIC_SERVER_W |
PR_EMS_AB_HOUSE_IDENTIFIER |
PR_EMS_AB_HOUSE_IDENTIFIER_A |
PR_EMS_AB_HOUSE_IDENTIFIER_W |
PR_EMS_AB_HTTP_PUB_AB_ATTRIBUTES |
PR_EMS_AB_HTTP_PUB_GAL |
PR_EMS_AB_HTTP_PUB_GAL_LIMIT |
PR_EMS_AB_HTTP_PUB_PF |
PR_EMS_AB_HTTP_SERVERS |
PR_EMS_AB_IMPORT_CONTAINER |
PR_EMS_AB_IMPORT_CONTAINER_A |
PR_EMS_AB_IMPORT_CONTAINER_O |
PR_EMS_AB_IMPORT_CONTAINER_W |
PR_EMS_AB_IMPORT_SENSITIVITY |
PR_EMS_AB_IMPORTED_FROM |
PR_EMS_AB_IMPORTED_FROM_A |
PR_EMS_AB_IMPORTED_FROM_W |
PR_EMS_AB_INBOUND_ACCEPT_ALL |
PR_EMS_AB_INBOUND_DN |
PR_EMS_AB_INBOUND_DN_A |
PR_EMS_AB_INBOUND_DN_O |
PR_EMS_AB_INBOUND_DN_W |
PR_EMS_AB_INBOUND_HOST |
PR_EMS_AB_INBOUND_NEWSFEED |
PR_EMS_AB_INBOUND_NEWSFEED_A |
PR_EMS_AB_INBOUND_NEWSFEED_TYPE |
PR_EMS_AB_INBOUND_NEWSFEED_W |
PR_EMS_AB_INBOUND_SITES |
PR_EMS_AB_INBOUND_SITES_O |
PR_EMS_AB_INCOMING_MSG_SIZE_LIMIT |
PR_EMS_AB_INCOMING_PASSWORD |
PR_EMS_AB_INSADMIN |
PR_EMS_AB_INSADMIN_A |
PR_EMS_AB_INSADMIN_O |
PR_EMS_AB_INSADMIN_W |
PR_EMS_AB_INSTANCE_TYPE |
PR_EMS_AB_INTERNATIONAL_ISDN_NUMBER |
PR_EMS_AB_INVOCATION_ID |
PR_EMS_AB_IS_DELETED |
PR_EMS_AB_IS_MASTER |
PR_EMS_AB_IS_MEMBER_OF_DL |
PR_EMS_AB_IS_MEMBER_OF_DL_T |
PR_EMS_AB_IS_MEMBER_OF_DL_T_A |
PR_EMS_AB_IS_MEMBER_OF_DL_T_W |
PR_EMS_AB_IS_SINGLE_VALUED |
PR_EMS_AB_KCC_STATUS |
PR_EMS_AB_KM_SERVER |
PR_EMS_AB_KM_SERVER_A |
PR_EMS_AB_KM_SERVER_O |
PR_EMS_AB_KM_SERVER_W |
PR_EMS_AB_KNOWLEDGE_INFORMATION |
PR_EMS_AB_LABELEDURI |
PR_EMS_AB_LABELEDURI_A |
PR_EMS_AB_LABELEDURI_W |
PR_EMS_AB_LANGUAGE |
PR_EMS_AB_LANGUAGE_ISO639 |
PR_EMS_AB_LANGUAGE_ISO639_A |
PR_EMS_AB_LANGUAGE_ISO639_W |
PR_EMS_AB_LDAP_DISPLAY_NAME |
PR_EMS_AB_LDAP_SEARCH_CFG |
PR_EMS_AB_LINE_WRAP |
PR_EMS_AB_LINK_ID |
PR_EMS_AB_LIST_PUBLIC_FOLDERS |
PR_EMS_AB_LOCAL_BRIDGE_HEAD |
PR_EMS_AB_LOCAL_BRIDGE_HEAD_A |
PR_EMS_AB_LOCAL_BRIDGE_HEAD_ADDRESS |
PR_EMS_AB_LOCAL_BRIDGE_HEAD_ADDRESS_A |
PR_EMS_AB_LOCAL_BRIDGE_HEAD_ADDRESS_W |
PR_EMS_AB_LOCAL_BRIDGE_HEAD_W |
PR_EMS_AB_LOCAL_INITIAL_TURN |
PR_EMS_AB_LOCAL_SCOPE |
PR_EMS_AB_LOCAL_SCOPE_O |
PR_EMS_AB_LOG_FILENAME |
PR_EMS_AB_LOG_FILENAME_A |
PR_EMS_AB_LOG_FILENAME_W |
PR_EMS_AB_LOG_ROLLOVER_INTERVAL |
PR_EMS_AB_MAIL_DROP |
PR_EMS_AB_MAIL_DROP_A |
PR_EMS_AB_MAIL_DROP_W |
PR_EMS_AB_MAINTAIN_AUTOREPLY_HISTORY |
PR_EMS_AB_MANAGER |
PR_EMS_AB_MANAGER_T |
PR_EMS_AB_MANAGER_T_A |
PR_EMS_AB_MANAGER_T_W |
PR_EMS_AB_MAPI_DISPLAY_TYPE |
PR_EMS_AB_MAPI_ID |
PR_EMS_AB_MAXIMUM_OBJECT_ID |
PR_EMS_AB_MDB_BACKOFF_INTERVAL |
PR_EMS_AB_MDB_MSG_TIME_OUT_PERIOD |
PR_EMS_AB_MDB_OVER_QUOTA_LIMIT |
PR_EMS_AB_MDB_STORAGE_QUOTA |
PR_EMS_AB_MDB_UNREAD_LIMIT |
PR_EMS_AB_MDB_USE_DEFAULTS |
PR_EMS_AB_MEMBER |
PR_EMS_AB_MEMBER_T |
PR_EMS_AB_MEMBER_T_A |
PR_EMS_AB_MEMBER_T_W |
PR_EMS_AB_MESSAGE_TRACKING_ENABLED |
PR_EMS_AB_MIME_TYPES |
PR_EMS_AB_MODERATED |
PR_EMS_AB_MODERATOR |
PR_EMS_AB_MODERATOR_A |
PR_EMS_AB_MODERATOR_W |
PR_EMS_AB_MONITOR_CLOCK |
PR_EMS_AB_MONITOR_SERVERS |
PR_EMS_AB_MONITOR_SERVICES |
PR_EMS_AB_MONITORED_CONFIGURATIONS |
PR_EMS_AB_MONITORED_CONFIGURATIONS_O |
PR_EMS_AB_MONITORED_SERVERS |
PR_EMS_AB_MONITORED_SERVERS_O |
PR_EMS_AB_MONITORED_SERVICES |
PR_EMS_AB_MONITORING_ALERT_DELAY |
PR_EMS_AB_MONITORING_ALERT_UNITS |
PR_EMS_AB_MONITORING_AVAILABILITY_STYLE |
PR_EMS_AB_MONITORING_AVAILABILITY_WINDOW |
PR_EMS_AB_MONITORING_CACHED_VIA_MAIL |
PR_EMS_AB_MONITORING_CACHED_VIA_MAIL_O |
PR_EMS_AB_MONITORING_CACHED_VIA_RPC |
PR_EMS_AB_MONITORING_CACHED_VIA_RPC_O |
PR_EMS_AB_MONITORING_ESCALATION_PROCEDURE |
PR_EMS_AB_MONITORING_HOTSITE_POLL_INTERVAL |
PR_EMS_AB_MONITORING_HOTSITE_POLL_UNITS |
PR_EMS_AB_MONITORING_MAIL_UPDATE_INTERVAL |
PR_EMS_AB_MONITORING_MAIL_UPDATE_UNITS |
PR_EMS_AB_MONITORING_NORMAL_POLL_INTERVAL |
PR_EMS_AB_MONITORING_NORMAL_POLL_UNITS |
PR_EMS_AB_MONITORING_RECIPIENTS |
PR_EMS_AB_MONITORING_RECIPIENTS_NDR |
PR_EMS_AB_MONITORING_RECIPIENTS_NDR_O |
PR_EMS_AB_MONITORING_RECIPIENTS_O |
PR_EMS_AB_MONITORING_RPC_UPDATE_INTERVAL |
PR_EMS_AB_MONITORING_RPC_UPDATE_UNITS |
PR_EMS_AB_MONITORING_WARNING_DELAY |
PR_EMS_AB_MONITORING_WARNING_UNITS |
PR_EMS_AB_MTA_LOCAL_CRED |
PR_EMS_AB_MTA_LOCAL_CRED_A |
PR_EMS_AB_MTA_LOCAL_CRED_W |
PR_EMS_AB_MTA_LOCAL_DESIG |
PR_EMS_AB_MTA_LOCAL_DESIG_A |
PR_EMS_AB_MTA_LOCAL_DESIG_W |
PR_EMS_AB_N_ADDRESS |
PR_EMS_AB_N_ADDRESS_TYPE |
PR_EMS_AB_NETWORK_ADDRESS |
PR_EMS_AB_NEWSFEED_TYPE |
PR_EMS_AB_NEWSGROUP |
PR_EMS_AB_NEWSGROUP_A |
PR_EMS_AB_NEWSGROUP_LIST |
PR_EMS_AB_NEWSGROUP_W |
PR_EMS_AB_NNTP_CHARACTER_SET |
PR_EMS_AB_NNTP_CHARACTER_SET_A |
PR_EMS_AB_NNTP_CHARACTER_SET_W |
PR_EMS_AB_NNTP_CONTENT_FORMAT |
PR_EMS_AB_NNTP_CONTENT_FORMAT_A |
PR_EMS_AB_NNTP_CONTENT_FORMAT_W |
PR_EMS_AB_NNTP_DISTRIBUTIONS |
PR_EMS_AB_NNTP_DISTRIBUTIONS_FLAG |
PR_EMS_AB_NNTP_NEWSFEEDS |
PR_EMS_AB_NNTP_NEWSFEEDS_O |
PR_EMS_AB_NT_MACHINE_NAME |
PR_EMS_AB_NT_MACHINE_NAME_A |
PR_EMS_AB_NT_MACHINE_NAME_W |
PR_EMS_AB_NT_SECURITY_DESCRIPTOR |
PR_EMS_AB_NUM_OF_OPEN_RETRIES |
PR_EMS_AB_NUM_OF_TRANSFER_RETRIES |
PR_EMS_AB_OBJ_DIST_NAME |
PR_EMS_AB_OBJ_DIST_NAME_A |
PR_EMS_AB_OBJ_DIST_NAME_O |
PR_EMS_AB_OBJ_DIST_NAME_W |
PR_EMS_AB_OBJ_VIEW_CONTAINERS |
PR_EMS_AB_OBJ_VIEW_CONTAINERS_O |
PR_EMS_AB_OBJECT_CLASS_CATEGORY |
PR_EMS_AB_OBJECT_OID |
PR_EMS_AB_OBJECT_VERSION |
PR_EMS_AB_OFF_LINE_AB_CONTAINERS |
PR_EMS_AB_OFF_LINE_AB_CONTAINERS_O |
PR_EMS_AB_OFF_LINE_AB_SCHEDULE |
PR_EMS_AB_OFF_LINE_AB_SERVER |
PR_EMS_AB_OFF_LINE_AB_SERVER_A |
PR_EMS_AB_OFF_LINE_AB_SERVER_O |
PR_EMS_AB_OFF_LINE_AB_SERVER_W |
PR_EMS_AB_OFF_LINE_AB_STYLE |
PR_EMS_AB_OID_TYPE |
PR_EMS_AB_OM_OBJECT_CLASS |
PR_EMS_AB_OM_SYNTAX |
PR_EMS_AB_OOF_REPLY_TO_ORIGINATOR |
PR_EMS_AB_OPEN_RETRY_INTERVAL |
PR_EMS_AB_ORGANIZATION_NAME |
PR_EMS_AB_ORGANIZATIONAL_UNIT_NAME |
PR_EMS_AB_ORIGINAL_DISPLAY_TABLE |
PR_EMS_AB_ORIGINAL_DISPLAY_TABLE_MSDOS |
PR_EMS_AB_OTHER_RECIPS |
PR_EMS_AB_OUTBOUND_HOST |
PR_EMS_AB_OUTBOUND_HOST_TYPE |
PR_EMS_AB_OUTBOUND_NEWSFEED |
PR_EMS_AB_OUTBOUND_NEWSFEED_A |
PR_EMS_AB_OUTBOUND_NEWSFEED_W |
PR_EMS_AB_OUTBOUND_SITES |
PR_EMS_AB_OUTBOUND_SITES_O |
PR_EMS_AB_OUTGOING_MSG_SIZE_LIMIT |
PR_EMS_AB_OVERRIDE_NNTP_CONTENT_FORMAT |
PR_EMS_AB_OWA_SERVER |
PR_EMS_AB_OWA_SERVER_A |
PR_EMS_AB_OWA_SERVER_W |
PR_EMS_AB_OWNER |
PR_EMS_AB_OWNER_A |
PR_EMS_AB_OWNER_BL |
PR_EMS_AB_OWNER_BL_O |
PR_EMS_AB_OWNER_O |
PR_EMS_AB_OWNER_W |
PR_EMS_AB_P_SELECTOR |
PR_EMS_AB_P_SELECTOR_INBOUND |
PR_EMS_AB_PARENT_ENTRYID |
PR_EMS_AB_PER_MSG_DIALOG_DISPLAY_TABLE |
PR_EMS_AB_PER_RECIP_DIALOG_DISPLAY_TABLE |
PR_EMS_AB_PERIOD_REP_SYNC_TIMES |
PR_EMS_AB_PERIOD_REPL_STAGGER |
PR_EMS_AB_PERSONAL_TITLE |
PR_EMS_AB_PERSONAL_TITLE_A |
PR_EMS_AB_PERSONAL_TITLE_W |
PR_EMS_AB_PF_CONTACTS |
PR_EMS_AB_PF_CONTACTS_O |
PR_EMS_AB_POP_CHARACTER_SET |
PR_EMS_AB_POP_CHARACTER_SET_A |
PR_EMS_AB_POP_CHARACTER_SET_W |
PR_EMS_AB_POP_CONTENT_FORMAT |
PR_EMS_AB_POP_CONTENT_FORMAT_A |
PR_EMS_AB_POP_CONTENT_FORMAT_W |
PR_EMS_AB_PORT_NUMBER |
PR_EMS_AB_POSTAL_ADDRESS |
PR_EMS_AB_PREFERRED_DELIVERY_METHOD |
PR_EMS_AB_PRESERVE_INTERNET_CONTENT |
PR_EMS_AB_PRMD |
PR_EMS_AB_PRMD_A |
PR_EMS_AB_PRMD_W |
PR_EMS_AB_PROMO_EXPIRATION |
PR_EMS_AB_PROTOCOL_SETTINGS |
PR_EMS_AB_PROXY_ADDRESSES |
PR_EMS_AB_PROXY_GENERATION_ENABLED |
PR_EMS_AB_PROXY_GENERATOR_DLL |
PR_EMS_AB_PROXY_GENERATOR_DLL_A |
PR_EMS_AB_PROXY_GENERATOR_DLL_W |
PR_EMS_AB_PUBLIC_DELEGATES |
PR_EMS_AB_PUBLIC_DELEGATES_BL |
PR_EMS_AB_PUBLIC_DELEGATES_BL_O |
PR_EMS_AB_PUBLIC_DELEGATES_T |
PR_EMS_AB_PUBLIC_DELEGATES_T_A |
PR_EMS_AB_PUBLIC_DELEGATES_T_W |
PR_EMS_AB_QUOTA_NOTIFICATION_SCHEDULE |
PR_EMS_AB_QUOTA_NOTIFICATION_STYLE |
PR_EMS_AB_RANGE_LOWER |
PR_EMS_AB_RANGE_UPPER |
PR_EMS_AB_RAS_ACCOUNT |
PR_EMS_AB_RAS_ACCOUNT_A |
PR_EMS_AB_RAS_ACCOUNT_W |
PR_EMS_AB_RAS_CALLBACK_NUMBER |
PR_EMS_AB_RAS_CALLBACK_NUMBER_A |
PR_EMS_AB_RAS_CALLBACK_NUMBER_W |
PR_EMS_AB_RAS_PASSWORD |
PR_EMS_AB_RAS_PHONE_NUMBER |
PR_EMS_AB_RAS_PHONE_NUMBER_A |
PR_EMS_AB_RAS_PHONE_NUMBER_W |
PR_EMS_AB_RAS_PHONEBOOK_ENTRY_NAME |
PR_EMS_AB_RAS_PHONEBOOK_ENTRY_NAME_A |
PR_EMS_AB_RAS_PHONEBOOK_ENTRY_NAME_W |
PR_EMS_AB_RAS_REMOTE_SRVR_NAME |
PR_EMS_AB_RAS_REMOTE_SRVR_NAME_A |
PR_EMS_AB_RAS_REMOTE_SRVR_NAME_W |
PR_EMS_AB_REFERRAL_LIST |
PR_EMS_AB_REGISTERED_ADDRESS |
PR_EMS_AB_REMOTE_BRIDGE_HEAD |
PR_EMS_AB_REMOTE_BRIDGE_HEAD_A |
PR_EMS_AB_REMOTE_BRIDGE_HEAD_ADDRESS |
PR_EMS_AB_REMOTE_BRIDGE_HEAD_ADDRESS_A |
PR_EMS_AB_REMOTE_BRIDGE_HEAD_ADDRESS_W |
PR_EMS_AB_REMOTE_BRIDGE_HEAD_W |
PR_EMS_AB_REMOTE_OUT_BH_SERVER |
PR_EMS_AB_REMOTE_OUT_BH_SERVER_A |
PR_EMS_AB_REMOTE_OUT_BH_SERVER_O |
PR_EMS_AB_REMOTE_OUT_BH_SERVER_W |
PR_EMS_AB_REMOTE_SITE |
PR_EMS_AB_REMOTE_SITE_A |
PR_EMS_AB_REMOTE_SITE_O |
PR_EMS_AB_REMOTE_SITE_W |
PR_EMS_AB_REPLICATED_OBJECT_VERSION |
PR_EMS_AB_REPLICATION_MAIL_MSG_SIZE |
PR_EMS_AB_REPLICATION_SENSITIVITY |
PR_EMS_AB_REPLICATION_STAGGER |
PR_EMS_AB_REPORT_TO_ORIGINATOR |
PR_EMS_AB_REPORT_TO_OWNER |
PR_EMS_AB_REPORTS |
PR_EMS_AB_REPORTS_T |
PR_EMS_AB_REQ_SEQ |
PR_EMS_AB_REQUIRE_SSL |
PR_EMS_AB_RESPONSIBLE_LOCAL_DXA |
PR_EMS_AB_RESPONSIBLE_LOCAL_DXA_A |
PR_EMS_AB_RESPONSIBLE_LOCAL_DXA_O |
PR_EMS_AB_RESPONSIBLE_LOCAL_DXA_W |
PR_EMS_AB_RETURN_EXACT_MSG_SIZE |
PR_EMS_AB_RID_SERVER |
PR_EMS_AB_RID_SERVER_A |
PR_EMS_AB_RID_SERVER_O |
PR_EMS_AB_RID_SERVER_W |
PR_EMS_AB_ROLE_OCCUPANT |
PR_EMS_AB_ROLE_OCCUPANT_O |
PR_EMS_AB_ROOT_NEWSGROUPS_FOLDER_ID |
PR_EMS_AB_ROUTING_LIST |
PR_EMS_AB_RTS_CHECKPOINT_SIZE |
PR_EMS_AB_RTS_RECOVERY_TIMEOUT |
PR_EMS_AB_RTS_WINDOW_SIZE |
PR_EMS_AB_RUNS_ON |
PR_EMS_AB_RUNS_ON_O |
PR_EMS_AB_S_SELECTOR |
PR_EMS_AB_S_SELECTOR_INBOUND |
PR_EMS_AB_SCHEMA_FLAGS |
PR_EMS_AB_SCHEMA_VERSION |
PR_EMS_AB_SEARCH_FLAGS |
PR_EMS_AB_SEARCH_GUIDE |
PR_EMS_AB_SECURITY_POLICY |
PR_EMS_AB_SECURITY_PROTOCOL |
PR_EMS_AB_SEE_ALSO |
PR_EMS_AB_SEE_ALSO_O |
PR_EMS_AB_SEND_EMAIL_MESSAGE |
PR_EMS_AB_SEND_TNEF |
PR_EMS_AB_SERIAL_NUMBER |
PR_EMS_AB_SERVER |
PR_EMS_AB_SERVER_A |
PR_EMS_AB_SERVER_W |
PR_EMS_AB_SERVICE_ACTION_FIRST |
PR_EMS_AB_SERVICE_ACTION_OTHER |
PR_EMS_AB_SERVICE_ACTION_SECOND |
PR_EMS_AB_SERVICE_RESTART_DELAY |
PR_EMS_AB_SERVICE_RESTART_MESSAGE |
PR_EMS_AB_SERVICE_RESTART_MESSAGE_A |
PR_EMS_AB_SERVICE_RESTART_MESSAGE_W |
PR_EMS_AB_SESSION_DISCONNECT_TIMER |
PR_EMS_AB_SITE_AFFINITY |
PR_EMS_AB_SITE_FOLDER_GUID |
PR_EMS_AB_SITE_FOLDER_SERVER |
PR_EMS_AB_SITE_FOLDER_SERVER_A |
PR_EMS_AB_SITE_FOLDER_SERVER_O |
PR_EMS_AB_SITE_FOLDER_SERVER_W |
PR_EMS_AB_SITE_PROXY_SPACE |
PR_EMS_AB_SMIME_ALG_LIST_NA |
PR_EMS_AB_SMIME_ALG_LIST_OTHER |
PR_EMS_AB_SMIME_ALG_SELECTED_NA |
PR_EMS_AB_SMIME_ALG_SELECTED_NA_A |
PR_EMS_AB_SMIME_ALG_SELECTED_NA_W |
PR_EMS_AB_SMIME_ALG_SELECTED_OTHER |
PR_EMS_AB_SMIME_ALG_SELECTED_OTHER_A |
PR_EMS_AB_SMIME_ALG_SELECTED_OTHER_W |
PR_EMS_AB_SPACE_LAST_COMPUTED |
PR_EMS_AB_STREET_ADDRESS |
PR_EMS_AB_STREET_ADDRESS_A |
PR_EMS_AB_STREET_ADDRESS_W |
PR_EMS_AB_SUB_REFS |
PR_EMS_AB_SUB_REFS_O |
PR_EMS_AB_SUB_SITE |
PR_EMS_AB_SUB_SITE_A |
PR_EMS_AB_SUB_SITE_W |
PR_EMS_AB_SUBMISSION_CONT_LENGTH |
PR_EMS_AB_SUPPORT_SMIME_SIGNATURES |
PR_EMS_AB_SUPPORTED_ALGORITHMS |
PR_EMS_AB_SUPPORTED_APPLICATION_CONTEXT |
PR_EMS_AB_SUPPORTING_STACK |
PR_EMS_AB_SUPPORTING_STACK_BL |
PR_EMS_AB_SUPPORTING_STACK_BL_O |
PR_EMS_AB_SUPPORTING_STACK_O |
PR_EMS_AB_T_SELECTOR |
PR_EMS_AB_T_SELECTOR_INBOUND |
PR_EMS_AB_TAGGED_X509_CERT |
PR_EMS_AB_TARGET_ADDRESS |
PR_EMS_AB_TARGET_ADDRESS_A |
PR_EMS_AB_TARGET_ADDRESS_W |
PR_EMS_AB_TARGET_MTAS |
PR_EMS_AB_TELEPHONE_NUMBER |
PR_EMS_AB_TELEPHONE_PERSONAL_PAGER |
PR_EMS_AB_TELEPHONE_PERSONAL_PAGER_A |
PR_EMS_AB_TELEPHONE_PERSONAL_PAGER_W |
PR_EMS_AB_TELETEX_TERMINAL_IDENTIFIER |
PR_EMS_AB_TEMP_ASSOC_THRESHOLD |
PR_EMS_AB_TOMBSTONE_LIFETIME |
PR_EMS_AB_TRACKING_LOG_PATH_NAME |
PR_EMS_AB_TRACKING_LOG_PATH_NAME_A |
PR_EMS_AB_TRACKING_LOG_PATH_NAME_W |
PR_EMS_AB_TRANS_RETRY_MINS |
PR_EMS_AB_TRANS_TIMEOUT_MINS |
PR_EMS_AB_TRANSFER_RETRY_INTERVAL |
PR_EMS_AB_TRANSFER_TIMEOUT_NON_URGENT |
PR_EMS_AB_TRANSFER_TIMEOUT_NORMAL |
PR_EMS_AB_TRANSFER_TIMEOUT_URGENT |
PR_EMS_AB_TRANSLATION_TABLE_USED |
PR_EMS_AB_TRANSPORT_EXPEDITED_DATA |
PR_EMS_AB_TRUST_LEVEL |
PR_EMS_AB_TURN_REQUEST_THRESHOLD |
PR_EMS_AB_TWO_WAY_ALTERNATE_FACILITY |
PR_EMS_AB_TYPE |
PR_EMS_AB_TYPE_A |
PR_EMS_AB_TYPE_W |
PR_EMS_AB_UNAUTH_ORIG_BL |
PR_EMS_AB_UNAUTH_ORIG_BL_O |
PR_EMS_AB_USE_SERVER_VALUES |
PR_EMS_AB_USE_SITE_VALUES |
PR_EMS_AB_USENET_SITE_NAME |
PR_EMS_AB_USENET_SITE_NAME_A |
PR_EMS_AB_USENET_SITE_NAME_W |
PR_EMS_AB_USER_PASSWORD |
PR_EMS_AB_USN_CHANGED |
PR_EMS_AB_USN_CREATED |
PR_EMS_AB_USN_DSA_LAST_OBJ_REMOVED |
PR_EMS_AB_USN_INTERSITE |
PR_EMS_AB_USN_LAST_OBJ_REM |
PR_EMS_AB_USN_SOURCE |
PR_EMS_AB_VIEW_CONTAINER_1 |
PR_EMS_AB_VIEW_CONTAINER_1_A |
PR_EMS_AB_VIEW_CONTAINER_1_W |
PR_EMS_AB_VIEW_CONTAINER_2 |
PR_EMS_AB_VIEW_CONTAINER_2_A |
PR_EMS_AB_VIEW_CONTAINER_2_W |
PR_EMS_AB_VIEW_CONTAINER_3 |
PR_EMS_AB_VIEW_CONTAINER_3_A |
PR_EMS_AB_VIEW_CONTAINER_3_W |
PR_EMS_AB_VIEW_DEFINITION |
PR_EMS_AB_VIEW_FLAGS |
PR_EMS_AB_VIEW_SITE |
PR_EMS_AB_VIEW_SITE_A |
PR_EMS_AB_VIEW_SITE_W |
PR_EMS_AB_VOICE_MAIL_FLAGS |
PR_EMS_AB_VOICE_MAIL_GREETINGS |
PR_EMS_AB_VOICE_MAIL_PASSWORD |
PR_EMS_AB_VOICE_MAIL_PASSWORD_A |
PR_EMS_AB_VOICE_MAIL_PASSWORD_W |
PR_EMS_AB_VOICE_MAIL_RECORDED_NAME |
PR_EMS_AB_VOICE_MAIL_RECORDING_LENGTH |
PR_EMS_AB_VOICE_MAIL_SPEED |
PR_EMS_AB_VOICE_MAIL_SYSTEM_GUID |
PR_EMS_AB_VOICE_MAIL_USER_ID |
PR_EMS_AB_VOICE_MAIL_USER_ID_A |
PR_EMS_AB_VOICE_MAIL_USER_ID_W |
PR_EMS_AB_VOICE_MAIL_VOLUME |
PR_EMS_AB_WWW_HOME_PAGE |
PR_EMS_AB_WWW_HOME_PAGE_A |
PR_EMS_AB_WWW_HOME_PAGE_W |
PR_EMS_AB_X121_ADDRESS |
PR_EMS_AB_X25_CALL_USER_DATA_INCOMING |
PR_EMS_AB_X25_CALL_USER_DATA_OUTGOING |
PR_EMS_AB_X25_FACILITIES_DATA_INCOMING |
PR_EMS_AB_X25_FACILITIES_DATA_OUTGOING |
PR_EMS_AB_X25_LEASED_LINE_PORT |
PR_EMS_AB_X25_LEASED_OR_SWITCHED |
PR_EMS_AB_X25_REMOTE_MTA_PHONE |
PR_EMS_AB_X25_REMOTE_MTA_PHONE_A |
PR_EMS_AB_X25_REMOTE_MTA_PHONE_W |
PR_EMS_AB_X400_ATTACHMENT_TYPE |
PR_EMS_AB_X400_SELECTOR_SYNTAX |
PR_EMS_AB_X500_ACCESS_CONTROL_LIST |
PR_EMS_AB_X500_NC |
PR_EMS_AB_X500_NC_A |
PR_EMS_AB_X500_NC_W |
PR_EMS_AB_X500_RDN |
PR_EMS_AB_X500_RDN_A |
PR_EMS_AB_X500_RDN_W |
PR_EMS_AB_XMIT_TIMEOUT_NON_URGENT |
PR_EMS_AB_XMIT_TIMEOUT_NORMAL |
PR_EMS_AB_XMIT_TIMEOUT_URGENT |
PR_END_DATE |
PR_ENTRYID |
PR_EVENTS_ROOT_FOLDER_ENTRYID |
PR_EXCESS_STORAGE_USED |
PR_EXPIRY_NUMBER |
PR_EXPIRY_TIME |
PR_EXPIRY_UNITS |
PR_EXPLICIT_CONVERSION |
PR_EXTENDED_ACL_DATA |
PR_FAST_TRANSFER |
PR_FAVORITES_DEFAULT_NAME |
PR_FAVORITES_DEFAULT_NAME_A |
PR_FAVORITES_DEFAULT_NAME_W |
PR_FILTERING_HOOKS |
PR_FINDER_ENTRYID |
PR_FLAG_COMPLETE_TIME | Specifies the date and time in Coordinated Universal Time (UTC) that the message object was flagged as completed.
PR_FLAG_ICON | Specifies the flag icon of the message object.
PR_FLAG_STATUS | Specifies the flag state of the message object.
PR_FOLDER_ASSOCIATED_CONTENTS |
PR_FOLDER_CHILD_COUNT |
PR_FOLDER_DESIGN_FLAGS |
PR_FOLDER_FLAGS |
PR_FOLDER_PATHNAME |
PR_FOLDER_PATHNAME_A |
PR_FOLDER_PATHNAME_W |
PR_FOLDER_TYPE |
PR_FOREIGN_ID |
PR_FOREIGN_REPORT_ID |
PR_FOREIGN_SUBJECT_ID |
PR_FORM_CATEGORY |
PR_FORM_CATEGORY_A |
PR_FORM_CATEGORY_SUB |
PR_FORM_CATEGORY_SUB_A |
PR_FORM_CATEGORY_SUB_W |
PR_FORM_CATEGORY_W |
PR_FORM_CLSID |
PR_FORM_CONTACT_NAME |
PR_FORM_CONTACT_NAME_A |
PR_FORM_CONTACT_NAME_W |
PR_FORM_DESIGNER_GUID |
PR_FORM_DESIGNER_NAME |
PR_FORM_DESIGNER_NAME_A |
PR_FORM_DESIGNER_NAME_W |
PR_FORM_HIDDEN |
PR_FORM_HOST_MAP |
PR_FORM_MESSAGE_BEHAVIOR |
PR_FORM_VERSION |
PR_FORM_VERSION_A |
PR_FORM_VERSION_W |
PR_FREE_BUSY_FOR_LOCAL_SITE_ENTRYID |
PR_FTP_SITE |
PR_FTP_SITE_A |
PR_FTP_SITE_W |
PR_GENDER |
PR_GENERATION |
PR_GENERATION_A |
PR_GENERATION_W |
PR_GIVEN_NAME |
PR_GIVEN_NAME_A |
PR_GIVEN_NAME_W |
PR_GOVERNMENT_ID_NUMBER |
PR_GOVERNMENT_ID_NUMBER_A |
PR_GOVERNMENT_ID_NUMBER_W |
PR_GW_ADMIN_OPERATIONS |
PR_GW_MTSIN_ENTRYID |
PR_GW_MTSOUT_ENTRYID |
PR_HAS_DAMS |
PR_HAS_MODERATOR_RULES |
PR_HAS_NAMED_PROPERTIES |
PR_HAS_RULES |
PR_HASATTACH |
PR_HEADER_FOLDER_ENTRYID |
PR_HIERARCHY_CHANGE_NUM |
PR_HIERARCHY_SERVER |
PR_HIERARCHY_SERVER_A |
PR_HIERARCHY_SERVER_W |
PR_HIERARCHY_SYNCHRONIZER |
PR_HOBBIES |
PR_HOBBIES_A |
PR_HOBBIES_W |
PR_HOME_ADDRESS_CITY |
PR_HOME_ADDRESS_CITY_A |
PR_HOME_ADDRESS_CITY_W |
PR_HOME_ADDRESS_COUNTRY |
PR_HOME_ADDRESS_COUNTRY_A |
PR_HOME_ADDRESS_COUNTRY_W |
PR_HOME_ADDRESS_POST_OFFICE_BOX |
PR_HOME_ADDRESS_POST_OFFICE_BOX_A |
PR_HOME_ADDRESS_POST_OFFICE_BOX_W |
PR_HOME_ADDRESS_POSTAL_CODE |
PR_HOME_ADDRESS_POSTAL_CODE_A |
PR_HOME_ADDRESS_POSTAL_CODE_W |
PR_HOME_ADDRESS_STATE_OR_PROVINCE |
PR_HOME_ADDRESS_STATE_OR_PROVINCE_A |
PR_HOME_ADDRESS_STATE_OR_PROVINCE_W |
PR_HOME_ADDRESS_STREET |
PR_HOME_ADDRESS_STREET_A |
PR_HOME_ADDRESS_STREET_W |
PR_HOME_FAX_NUMBER |
PR_HOME_FAX_NUMBER_A |
PR_HOME_FAX_NUMBER_W |
PR_HOME_TELEPHONE_NUMBER |
PR_HOME_TELEPHONE_NUMBER_A |
PR_HOME_TELEPHONE_NUMBER_W |
PR_HOME2_TELEPHONE_NUMBER |
PR_HOME2_TELEPHONE_NUMBER_A |
PR_HOME2_TELEPHONE_NUMBER_W |
PR_HTML |
PR_ICON |
PR_IDENTITY_DISPLAY |
PR_IDENTITY_DISPLAY_A |
PR_IDENTITY_DISPLAY_W |
PR_IDENTITY_ENTRYID |
PR_IDENTITY_SEARCH_KEY |
PR_IMAP_INTERNAL_DATE |
PR_IMPLICIT_CONVERSION_PROHIBITED |
PR_IMPORTANCE |
PR_IN_CONFLICT |
PR_IN_TRANSIT |
PR_INBOUND_NEWSFEED_DN |
PR_INBOUND_NEWSFEED_DN_A |
PR_INBOUND_NEWSFEED_DN_W |
PR_INCOMPLETE_COPY |
PR_INITIAL_DETAILS_PANE |
PR_INITIALS |
PR_INITIALS_A |
PR_INITIALS_W |
PR_INSTANCE_KEY |
PR_INTERNAL_TRACE_INFO |
PR_INTERNET_APPROVED |
PR_INTERNET_APPROVED_A |
PR_INTERNET_APPROVED_W |
PR_INTERNET_ARTICLE_NUMBER |
PR_INTERNET_CHARSET |
PR_INTERNET_CHARSET_A |
PR_INTERNET_CHARSET_W |
PR_INTERNET_CONTROL |
PR_INTERNET_CONTROL_A |
PR_INTERNET_CONTROL_W |
PR_INTERNET_CPID |
PR_INTERNET_DISTRIBUTION |
PR_INTERNET_DISTRIBUTION_A |
PR_INTERNET_DISTRIBUTION_W |
PR_INTERNET_FOLLOWUP_TO |
PR_INTERNET_FOLLOWUP_TO_A |
PR_INTERNET_FOLLOWUP_TO_W |
PR_INTERNET_LINES |
PR_INTERNET_MESSAGE_ID |
PR_INTERNET_MESSAGE_ID_A |
PR_INTERNET_MESSAGE_ID_W |
PR_INTERNET_NEWSGROUP_NAME |
PR_INTERNET_NEWSGROUP_NAME_A |
PR_INTERNET_NEWSGROUP_NAME_W |
PR_INTERNET_NEWSGROUPS |
PR_INTERNET_NEWSGROUPS_A |
PR_INTERNET_NEWSGROUPS_W |
PR_INTERNET_NNTP_PATH |
PR_INTERNET_NNTP_PATH_A |
PR_INTERNET_NNTP_PATH_W |
PR_INTERNET_ORGANIZATION |
PR_INTERNET_ORGANIZATION_A |
PR_INTERNET_ORGANIZATION_W |
PR_INTERNET_PRECEDENCE |
PR_INTERNET_PRECEDENCE_A |
PR_INTERNET_PRECEDENCE_W |
PR_INTERNET_REFERENCES |
PR_INTERNET_REFERENCES_A |
PR_INTERNET_REFERENCES_W |
PR_IPM_APPOINTMENT_ENTRYID | Contains the EntryID of the Outlook Calendar folder.
PR_IPM_CONTACT_ENTRYID | Contains the EntryID of the Outlook Contacts folder.
PR_IPM_DAF_ENTRYID |
PR_IPM_DRAFTS_ENTRYID | Contains the EntryID of the Outlook Drafts folder.
PR_IPM_FAVORITES_ENTRYID |
PR_IPM_ID |
PR_IPM_JOURNAL_ENTRYID | Contains the EntryID of the Outlook Journal folder.
PR_IPM_NOTE_ENTRYID | Contains the EntryID of the Outlook Notes folder.
PR_IPM_OUTBOX_ENTRYID |
PR_IPM_OUTBOX_SEARCH_KEY |
PR_IPM_PUBLIC_FOLDERS_ENTRYID |
PR_IPM_RETURN_REQUESTED |
PR_IPM_SENTMAIL_ENTRYID |
PR_IPM_SENTMAIL_SEARCH_KEY |
PR_IPM_SUBTREE_ENTRYID |
PR_IPM_SUBTREE_SEARCH_KEY |
PR_IPM_TASK_ENTRYID | Contains the EntryID of the Outlook Tasks folder.
PR_IPM_WASTEBASKET_ENTRYID |
PR_IPM_WASTEBASKET_SEARCH_KEY |
PR_IS_NEWSGROUP |
PR_IS_NEWSGROUP_ANCHOR |
PR_ISDN_NUMBER |
PR_ISDN_NUMBER_A |
PR_ISDN_NUMBER_W |
PR_KEYWORD |
PR_KEYWORD_A |
PR_KEYWORD_W |
PR_LANGUAGE |
PR_LANGUAGE_A |
PR_LANGUAGE_W |
PR_LANGUAGES |
PR_LANGUAGES_A |
PR_LANGUAGES_W |
PR_LAST_ACCESS_TIME |
PR_LAST_FULL_BACKUP |
PR_LAST_LOGOFF_TIME |
PR_LAST_LOGON_TIME |
PR_LAST_MODIFICATION_TIME |
PR_LAST_MODIFIER_ENTRYID |
PR_LAST_MODIFIER_NAME |
PR_LAST_MODIFIER_NAME_A |
PR_LAST_MODIFIER_NAME_W |
PR_LAST_VERB_EXECUTION_TIME | Contains the time when the last verb was executed.
PR_LATEST_DELIVERY_TIME |
PR_LOCALE_ID |
PR_LOCALITY |
PR_LOCALITY_A |
PR_LOCALITY_W |
PR_LOCATION |
PR_LOCATION_A |
PR_LOCATION_W |
PR_LONGTERM_ENTRYID_FROM_TABLE |
PR_LTP_ROW_ID | LTP Row ID.
PR_LTP_ROW_VER | LTP Row Ver.
PR_MAIL_PERMISSION |
PR_MAILBOX_OWNER_ENTRYID |
PR_MAILBOX_OWNER_NAME |
PR_MAILBOX_OWNER_NAME_A |
PR_MAILBOX_OWNER_NAME_W |
PR_MANAGER_NAME |
PR_MANAGER_NAME_A |
PR_MANAGER_NAME_W |
PR_MAPPING_SIGNATURE |
PR_MDB_PROVIDER |
PR_MEMBER_ENTRYID |
PR_MEMBER_ID |
PR_MEMBER_NAME |
PR_MEMBER_NAME_A |
PR_MEMBER_NAME_W |
PR_MEMBER_RIGHTS |
PR_MESSAGE_ATTACHMENTS |
PR_MESSAGE_CC_ME |
PR_MESSAGE_CLASS |
PR_MESSAGE_CLASS_A |
PR_MESSAGE_CLASS_W |
PR_MESSAGE_CODEPAGE |
PR_MESSAGE_DELIVERY_ID |
PR_MESSAGE_DELIVERY_TIME |
PR_MESSAGE_DOWNLOAD_TIME |
PR_MESSAGE_FLAGS |
PR_MESSAGE_LOCALE_ID |
PR_MESSAGE_PROCESSED |
PR_MESSAGE_RECIP_ME |
PR_MESSAGE_RECIPIENTS |
PR_MESSAGE_SECURITY_LABEL |
PR_MESSAGE_SITE_NAME |
PR_MESSAGE_SITE_NAME_A |
PR_MESSAGE_SITE_NAME_W |
PR_MESSAGE_SIZE |
PR_MESSAGE_SIZE_EXTENDED |
PR_MESSAGE_SUBMISSION_ID |
PR_MESSAGE_TO_ME |
PR_MESSAGE_TOKEN |
PR_MHS_COMMON_NAME |
PR_MHS_COMMON_NAME_A |
PR_MHS_COMMON_NAME_W |
PR_MIDDLE_NAME |
PR_MIDDLE_NAME_A |
PR_MIDDLE_NAME_W |
PR_MINI_ICON |
PR_MOBILE_TELEPHONE_NUMBER |
PR_MOBILE_TELEPHONE_NUMBER_A |
PR_MOBILE_TELEPHONE_NUMBER_W |
PR_MODIFY_VERSION |
PR_MOVE_TO_FOLDER_ENTRYID |
PR_MOVE_TO_STORE_ENTRYID |
PR_MSG_BODY_ID |
PR_MSG_STATUS |
PR_MTS_ID |
PR_MTS_REPORT_ID |
PR_MTS_SUBJECT_ID |
PR_NDR_DIAG_CODE |
PR_NDR_REASON_CODE |
PR_NEW_SUBS_GET_AUTO_ADD |
PR_NEWSFEED_INFO |
PR_NEWSGROUP_COMPONENT |
PR_NEWSGROUP_COMPONENT_A |
PR_NEWSGROUP_COMPONENT_W |
PR_NEWSGROUP_NAME |
PR_NEWSGROUP_NAME_A |
PR_NEWSGROUP_NAME_W |
PR_NEWSGROUP_ROOT_FOLDER_ENTRYID |
PR_NICKNAME |
PR_NICKNAME_A |
PR_NICKNAME_W |
PR_NNTP_ARTICLE_FOLDER_ENTRYID |
PR_NNTP_CONTROL_FOLDER_ENTRYID |
PR_NNTP_XREF |
PR_NNTP_XREF_A |
PR_NNTP_XREF_W |
PR_NON_IPM_SUBTREE_ENTRYID |
PR_NON_RECEIPT_NOTIFICATION_REQUESTED |
PR_NON_RECEIPT_REASON |
PR_NORMAL_MESSAGE_SIZE |
PR_NORMAL_MESSAGE_SIZE_EXTENDED |
PR_NORMAL_MSG_W_ATTACH_COUNT |
PR_NORMALIZED_SUBJECT |
PR_NORMALIZED_SUBJECT_A |
PR_NORMALIZED_SUBJECT_W |
PR_NT_USER_NAME |
PR_NT_USER_NAME_A |
PR_NT_USER_NAME_W |
PR_OBJECT_TYPE |
PR_OBSOLETED_IPMS |
PR_OFFICE_LOCATION |
PR_OFFICE_LOCATION_A |
PR_OFFICE_LOCATION_W |
PR_OFFICE_TELEPHONE_NUMBER |
PR_OFFICE_TELEPHONE_NUMBER_A |
PR_OFFICE_TELEPHONE_NUMBER_W |
PR_OFFICE2_TELEPHONE_NUMBER |
PR_OFFICE2_TELEPHONE_NUMBER_A |
PR_OFFICE2_TELEPHONE_NUMBER_W |
PR_OFFLINE_ADDRBOOK_ENTRYID |
PR_OFFLINE_FLAGS |
PR_OFFLINE_MESSAGE_ENTRYID |
PR_OLDEST_DELETED_ON |
PR_OOF_STATE |
PR_ORG_EMAIL_ADDR |
PR_ORG_EMAIL_ADDR_A |
PR_ORG_EMAIL_ADDR_W |
PR_ORGANIZATIONAL_ID_NUMBER |
PR_ORGANIZATIONAL_ID_NUMBER_A |
PR_ORGANIZATIONAL_ID_NUMBER_W |
PR_ORIG_MESSAGE_CLASS |
PR_ORIG_MESSAGE_CLASS_A |
PR_ORIG_MESSAGE_CLASS_W |
PR_ORIGIN_CHECK |
PR_ORIGINAL_AUTHOR_ADDRTYPE |
PR_ORIGINAL_AUTHOR_ADDRTYPE_A |
PR_ORIGINAL_AUTHOR_ADDRTYPE_W |
PR_ORIGINAL_AUTHOR_EMAIL_ADDRESS |
PR_ORIGINAL_AUTHOR_EMAIL_ADDRESS_A |
PR_ORIGINAL_AUTHOR_EMAIL_ADDRESS_W |
PR_ORIGINAL_AUTHOR_ENTRYID |
PR_ORIGINAL_AUTHOR_NAME |
PR_ORIGINAL_AUTHOR_NAME_A |
PR_ORIGINAL_AUTHOR_NAME_W |
PR_ORIGINAL_AUTHOR_SEARCH_KEY |
PR_ORIGINAL_DELIVERY_TIME |
PR_ORIGINAL_DISPLAY_BCC |
PR_ORIGINAL_DISPLAY_BCC_A |
PR_ORIGINAL_DISPLAY_BCC_W |
PR_ORIGINAL_DISPLAY_CC |
PR_ORIGINAL_DISPLAY_CC_A |
PR_ORIGINAL_DISPLAY_CC_W |
PR_ORIGINAL_DISPLAY_NAME |
PR_ORIGINAL_DISPLAY_NAME_A |
PR_ORIGINAL_DISPLAY_NAME_W |
PR_ORIGINAL_DISPLAY_TO |
PR_ORIGINAL_DISPLAY_TO_A |
PR_ORIGINAL_DISPLAY_TO_W |
PR_ORIGINAL_EITS |
PR_ORIGINAL_ENTRYID |
PR_ORIGINAL_SEARCH_KEY |
PR_ORIGINAL_SENDER_ADDRTYPE |
PR_ORIGINAL_SENDER_ADDRTYPE_A |
PR_ORIGINAL_SENDER_ADDRTYPE_W |
PR_ORIGINAL_SENDER_EMAIL_ADDRESS |
PR_ORIGINAL_SENDER_EMAIL_ADDRESS_A |
PR_ORIGINAL_SENDER_EMAIL_ADDRESS_W |
PR_ORIGINAL_SENDER_ENTRYID |
PR_ORIGINAL_SENDER_NAME |
PR_ORIGINAL_SENDER_NAME_A |
PR_ORIGINAL_SENDER_NAME_W |
PR_ORIGINAL_SENDER_SEARCH_KEY |
PR_ORIGINAL_SENSITIVITY |
PR_ORIGINAL_SENT_REPRESENTING_ADDRTYPE |
PR_ORIGINAL_SENT_REPRESENTING_ADDRTYPE_A |
PR_ORIGINAL_SENT_REPRESENTING_ADDRTYPE_W |
PR_ORIGINAL_SENT_REPRESENTING_EMAIL_ADDRESS |
PR_ORIGINAL_SENT_REPRESENTING_EMAIL_ADDRESS_A |
PR_ORIGINAL_SENT_REPRESENTING_EMAIL_ADDRESS_W |
PR_ORIGINAL_SENT_REPRESENTING_ENTRYID |
PR_ORIGINAL_SENT_REPRESENTING_NAME |
PR_ORIGINAL_SENT_REPRESENTING_NAME_A |
PR_ORIGINAL_SENT_REPRESENTING_NAME_W |
PR_ORIGINAL_SENT_REPRESENTING_SEARCH_KEY |
PR_ORIGINAL_SUBJECT |
PR_ORIGINAL_SUBJECT_A |
PR_ORIGINAL_SUBJECT_W |
PR_ORIGINAL_SUBMIT_TIME |
PR_ORIGINALLY_INTENDED_RECIP_ADDRTYPE |
PR_ORIGINALLY_INTENDED_RECIP_ADDRTYPE_A |
PR_ORIGINALLY_INTENDED_RECIP_ADDRTYPE_W |
PR_ORIGINALLY_INTENDED_RECIP_EMAIL_ADDRESS |
PR_ORIGINALLY_INTENDED_RECIP_EMAIL_ADDRESS_A |
PR_ORIGINALLY_INTENDED_RECIP_EMAIL_ADDRESS_W |
PR_ORIGINALLY_INTENDED_RECIP_ENTRYID |
PR_ORIGINALLY_INTENDED_RECIPIENT_NAME |
PR_ORIGINATING_MTA_CERTIFICATE |
PR_ORIGINATOR_ADDR |
PR_ORIGINATOR_ADDR_A |
PR_ORIGINATOR_ADDR_W |
PR_ORIGINATOR_ADDRTYPE |
PR_ORIGINATOR_ADDRTYPE_A |
PR_ORIGINATOR_ADDRTYPE_W |
PR_ORIGINATOR_AND_DL_EXPANSION_HISTORY |
PR_ORIGINATOR_CERTIFICATE |
PR_ORIGINATOR_DELIVERY_REPORT_REQUESTED |
PR_ORIGINATOR_ENTRYID |
PR_ORIGINATOR_NAME |
PR_ORIGINATOR_NAME_A |
PR_ORIGINATOR_NAME_W |
PR_ORIGINATOR_NON_DELIVERY_REPORT_REQUESTED |
PR_ORIGINATOR_REQUESTED_ALTERNATE_RECIPIENT |
PR_ORIGINATOR_RETURN_ADDRESS |
PR_OST_ENCRYPTION |
PR_OTHER_ADDRESS_CITY |
PR_OTHER_ADDRESS_CITY_A |
PR_OTHER_ADDRESS_CITY_W |
PR_OTHER_ADDRESS_COUNTRY |
PR_OTHER_ADDRESS_COUNTRY_A |
PR_OTHER_ADDRESS_COUNTRY_W |
PR_OTHER_ADDRESS_POST_OFFICE_BOX |
PR_OTHER_ADDRESS_POST_OFFICE_BOX_A |
PR_OTHER_ADDRESS_POST_OFFICE_BOX_W |
PR_OTHER_ADDRESS_POSTAL_CODE |
PR_OTHER_ADDRESS_POSTAL_CODE_A |
PR_OTHER_ADDRESS_POSTAL_CODE_W |
PR_OTHER_ADDRESS_STATE_OR_PROVINCE |
PR_OTHER_ADDRESS_STATE_OR_PROVINCE_A |
PR_OTHER_ADDRESS_STATE_OR_PROVINCE_W |
PR_OTHER_ADDRESS_STREET |
PR_OTHER_ADDRESS_STREET_A |
PR_OTHER_ADDRESS_STREET_W |
PR_OTHER_TELEPHONE_NUMBER |
PR_OTHER_TELEPHONE_NUMBER_A |
PR_OTHER_TELEPHONE_NUMBER_W |
PR_OUTBOUND_NEWSFEED_DN |
PR_OUTBOUND_NEWSFEED_DN_A |
PR_OUTBOUND_NEWSFEED_DN_W |
PR_OVERALL_AGE_LIMIT |
PR_OVERALL_MSG_AGE_LIMIT |
PR_OWA_URL |
PR_OWA_URL_A |
PR_OWA_URL_W |
PR_OWN_STORE_ENTRYID |
PR_OWNER_APPT_ID |
PR_OWNER_COUNT |
PR_P1_CONTENT |
PR_P1_CONTENT_TYPE |
PR_PAGER_TELEPHONE_NUMBER |
PR_PAGER_TELEPHONE_NUMBER_A |
PR_PAGER_TELEPHONE_NUMBER_W |
PR_PARENT_DISPLAY |
PR_PARENT_DISPLAY_A |
PR_PARENT_DISPLAY_W |
PR_PARENT_ENTRYID |
PR_PARENT_KEY |
PR_PARENT_SOURCE_KEY |
PR_PERSONAL_HOME_PAGE |
PR_PERSONAL_HOME_PAGE_A |
PR_PERSONAL_HOME_PAGE_W |
PR_PHYSICAL_DELIVERY_BUREAU_FAX_DELIVERY |
PR_PHYSICAL_DELIVERY_MODE |
PR_PHYSICAL_DELIVERY_REPORT_REQUEST |
PR_PHYSICAL_FORWARDING_ADDRESS |
PR_PHYSICAL_FORWARDING_ADDRESS_REQUESTED |
PR_PHYSICAL_FORWARDING_PROHIBITED |
PR_PHYSICAL_RENDITION_ATTRIBUTES |
PR_POST_FOLDER_ENTRIES |
PR_POST_FOLDER_NAMES |
PR_POST_FOLDER_NAMES_A |
PR_POST_FOLDER_NAMES_W |
PR_POST_OFFICE_BOX |
PR_POST_OFFICE_BOX_A |
PR_POST_OFFICE_BOX_W |
PR_POST_REPLY_DENIED |
PR_POST_REPLY_FOLDER_ENTRIES |
PR_POST_REPLY_FOLDER_NAMES |
PR_POST_REPLY_FOLDER_NAMES_A |
PR_POST_REPLY_FOLDER_NAMES_W |
PR_POSTAL_ADDRESS |
PR_POSTAL_ADDRESS_A |
PR_POSTAL_ADDRESS_W |
PR_POSTAL_CODE |
PR_POSTAL_CODE_A |
PR_POSTAL_CODE_W |
PR_PREDECESSOR_CHANGE_LIST |
PR_PREFERRED_BY_NAME |
PR_PREFERRED_BY_NAME_A |
PR_PREFERRED_BY_NAME_W |
PR_PREPROCESS |
PR_PREVENT_MSG_CREATE |
PR_PREVIEW |
PR_PREVIEW_A |
PR_PREVIEW_UNREAD |
PR_PREVIEW_UNREAD_A |
PR_PREVIEW_UNREAD_W |
PR_PREVIEW_W |
PR_PRIMARY_CAPABILITY |
PR_PRIMARY_FAX_NUMBER |
PR_PRIMARY_FAX_NUMBER_A |
PR_PRIMARY_FAX_NUMBER_W |
PR_PRIMARY_TELEPHONE_NUMBER |
PR_PRIMARY_TELEPHONE_NUMBER_A |
PR_PRIMARY_TELEPHONE_NUMBER_W |
PR_PRIORITY |
PR_PROFESSION |
PR_PROFESSION_A |
PR_PROFESSION_W |
PR_PROFILE_AB_FILES_PATH |
PR_PROFILE_AB_FILES_PATH_A |
PR_PROFILE_AB_FILES_PATH_W |
PR_PROFILE_ADDR_INFO |
PR_PROFILE_ALLPUB_COMMENT |
PR_PROFILE_ALLPUB_COMMENT_A |
PR_PROFILE_ALLPUB_COMMENT_W |
PR_PROFILE_ALLPUB_DISPLAY_NAME |
PR_PROFILE_ALLPUB_DISPLAY_NAME_A |
PR_PROFILE_ALLPUB_DISPLAY_NAME_W |
PR_PROFILE_AUTH_PACKAGE |
PR_PROFILE_BINDING_ORDER |
PR_PROFILE_BINDING_ORDER_A |
PR_PROFILE_BINDING_ORDER_W |
PR_PROFILE_CONFIG_FLAGS |
PR_PROFILE_CONNECT_FLAGS |
PR_PROFILE_FAVFLD_COMMENT |
PR_PROFILE_FAVFLD_COMMENT_A |
PR_PROFILE_FAVFLD_COMMENT_W |
PR_PROFILE_FAVFLD_DISPLAY_NAME |
PR_PROFILE_FAVFLD_DISPLAY_NAME_A |
PR_PROFILE_FAVFLD_DISPLAY_NAME_W |
PR_PROFILE_HOME_SERVER |
PR_PROFILE_HOME_SERVER_A |
PR_PROFILE_HOME_SERVER_ADDRS |
PR_PROFILE_HOME_SERVER_DN |
PR_PROFILE_HOME_SERVER_DN_A |
PR_PROFILE_HOME_SERVER_DN_W |
PR_PROFILE_HOME_SERVER_W |
PR_PROFILE_MAILBOX |
PR_PROFILE_MAILBOX_A |
PR_PROFILE_MAILBOX_W |
PR_PROFILE_MAX_RESTRICT |
PR_PROFILE_MOAB |
PR_PROFILE_MOAB_A |
PR_PROFILE_MOAB_GUID |
PR_PROFILE_MOAB_GUID_A |
PR_PROFILE_MOAB_GUID_W |
PR_PROFILE_MOAB_SEQ |
PR_PROFILE_MOAB_W |
PR_PROFILE_NAME |
PR_PROFILE_NAME_A |
PR_PROFILE_NAME_W |
PR_PROFILE_OFFLINE_INFO |
PR_PROFILE_OFFLINE_STORE_PATH |
PR_PROFILE_OFFLINE_STORE_PATH_A |
PR_PROFILE_OFFLINE_STORE_PATH_W |
PR_PROFILE_OPEN_FLAGS |
PR_PROFILE_OPTIONS_DATA |
PR_PROFILE_SECURE_MAILBOX |
PR_PROFILE_SERVER |
PR_PROFILE_SERVER_A |
PR_PROFILE_SERVER_DN |
PR_PROFILE_SERVER_DN_A |
PR_PROFILE_SERVER_DN_W |
PR_PROFILE_SERVER_W |
PR_PROFILE_TRANSPORT_FLAGS |
PR_PROFILE_TYPE |
PR_PROFILE_UI_STATE |
PR_PROFILE_UNRESOLVED_NAME |
PR_PROFILE_UNRESOLVED_NAME_A |
PR_PROFILE_UNRESOLVED_NAME_W |
PR_PROFILE_UNRESOLVED_SERVER |
PR_PROFILE_UNRESOLVED_SERVER_A |
PR_PROFILE_UNRESOLVED_SERVER_W |
PR_PROFILE_USER |
PR_PROFILE_USER_A |
PR_PROFILE_USER_W |
PR_PROFILE_VERSION |
PR_PROMOTE_PROP_ID_LIST |
PR_PROOF_OF_DELIVERY |
PR_PROOF_OF_DELIVERY_REQUESTED |
PR_PROOF_OF_SUBMISSION |
PR_PROOF_OF_SUBMISSION_REQUESTED |
PR_PROVIDER_DISPLAY |
PR_PROVIDER_DISPLAY_A |
PR_PROVIDER_DISPLAY_W |
PR_PROVIDER_DLL_NAME |
PR_PROVIDER_DLL_NAME_A |
PR_PROVIDER_DLL_NAME_W |
PR_PROVIDER_ORDINAL |
PR_PROVIDER_SUBMIT_TIME |
PR_PROVIDER_UID |
PR_PST_ENCRYPTION |
PR_PST_PASSWORD | Contains the CRC-32 hash of the password string of PST. If the property exists and is nonzero, then the PST file is password protected.
PR_PST_PATH |
PR_PST_PATH_A |
PR_PST_PATH_W |
PR_PST_PW_SZ_NEW |
PR_PST_PW_SZ_NEW_A |
PR_PST_PW_SZ_NEW_W |
PR_PST_PW_SZ_OLD |
PR_PST_PW_SZ_OLD_A |
PR_PST_PW_SZ_OLD_W |
PR_PST_REMEMBER_PW |
PR_PUBLIC_FOLDER_ENTRYID |
PR_PUBLISH_IN_ADDRESS_BOOK |
PR_RADIO_TELEPHONE_NUMBER |
PR_RADIO_TELEPHONE_NUMBER_A |
PR_RADIO_TELEPHONE_NUMBER_W |
PR_RCVD_REPRESENTING_ADDRTYPE |
PR_RCVD_REPRESENTING_ADDRTYPE_A |
PR_RCVD_REPRESENTING_ADDRTYPE_W |
PR_RCVD_REPRESENTING_EMAIL_ADDRESS |
PR_RCVD_REPRESENTING_EMAIL_ADDRESS_A |
PR_RCVD_REPRESENTING_EMAIL_ADDRESS_W |
PR_RCVD_REPRESENTING_ENTRYID |
PR_RCVD_REPRESENTING_NAME |
PR_RCVD_REPRESENTING_NAME_A |
PR_RCVD_REPRESENTING_NAME_W |
PR_RCVD_REPRESENTING_SEARCH_KEY |
PR_READ_RECEIPT_ENTRYID |
PR_READ_RECEIPT_REQUESTED |
PR_READ_RECEIPT_SEARCH_KEY |
PR_RECEIPT_TIME |
PR_RECEIVE_FOLDER_SETTINGS |
PR_RECEIVED_BY_ADDRTYPE |
PR_RECEIVED_BY_ADDRTYPE_A |
PR_RECEIVED_BY_ADDRTYPE_W |
PR_RECEIVED_BY_EMAIL_ADDRESS |
PR_RECEIVED_BY_EMAIL_ADDRESS_A |
PR_RECEIVED_BY_EMAIL_ADDRESS_W |
PR_RECEIVED_BY_ENTRYID |
PR_RECEIVED_BY_NAME |
PR_RECEIVED_BY_NAME_A |
PR_RECEIVED_BY_NAME_W |
PR_RECEIVED_BY_SEARCH_KEY |
PR_RECIPIENT_CERTIFICATE |
PR_RECIPIENT_NUMBER |
PR_RECIPIENT_NUMBER_FOR_ADVICE |
PR_RECIPIENT_NUMBER_FOR_ADVICE_A |
PR_RECIPIENT_NUMBER_FOR_ADVICE_W |
PR_RECIPIENT_ON_ASSOC_MSG_COUNT |
PR_RECIPIENT_ON_NORMAL_MSG_COUNT |
PR_RECIPIENT_REASSIGNMENT_PROHIBITED |
PR_RECIPIENT_STATUS |
PR_RECIPIENT_TYPE |
PR_RECORD_KEY |
PR_REDIRECTION_HISTORY |
PR_REFERRED_BY_NAME |
PR_REFERRED_BY_NAME_A |
PR_REFERRED_BY_NAME_W |
PR_REGISTERED_MAIL_TYPE |
PR_RELATED_IPMS |
PR_REMOTE_PROGRESS |
PR_REMOTE_PROGRESS_TEXT |
PR_REMOTE_PROGRESS_TEXT_A |
PR_REMOTE_PROGRESS_TEXT_W |
PR_REMOTE_VALIDATE_OK |
PR_RENDERING_POSITION |
PR_REPLICA_LIST |
PR_REPLICA_SERVER |
PR_REPLICA_SERVER_A |
PR_REPLICA_SERVER_W |
PR_REPLICA_VERSION |
PR_REPLICATION_ALWAYS_INTERVAL |
PR_REPLICATION_MESSAGE_PRIORITY |
PR_REPLICATION_MSG_SIZE |
PR_REPLICATION_SCHEDULE |
PR_REPLICATION_STYLE |
PR_REPLY_RECIPIENT_ENTRIES |
PR_REPLY_RECIPIENT_NAMES |
PR_REPLY_RECIPIENT_NAMES_A |
PR_REPLY_RECIPIENT_NAMES_W |
PR_REPLY_RECIPIENT_SMTP_PROXIES |
PR_REPLY_RECIPIENT_SMTP_PROXIES_A |
PR_REPLY_RECIPIENT_SMTP_PROXIES_W |
PR_REPLY_REQUESTED |
PR_REPLY_TIME |
PR_REPORT_DESTINATION_ENTRYID |
PR_REPORT_DESTINATION_NAME |
PR_REPORT_DESTINATION_NAME_A |
PR_REPORT_DESTINATION_NAME_W |
PR_REPORT_ENTRYID |
PR_REPORT_NAME |
PR_REPORT_NAME_A |
PR_REPORT_NAME_W |
PR_REPORT_SEARCH_KEY |
PR_REPORT_TAG |
PR_REPORT_TEXT |
PR_REPORT_TEXT_A |
PR_REPORT_TEXT_W |
PR_REPORT_TIME |
PR_REPORTING_DL_NAME |
PR_REPORTING_MTA_CERTIFICATE |
PR_REQUESTED_DELIVERY_METHOD |
PR_RESOLVE_METHOD |
PR_RESOURCE_FLAGS |
PR_RESOURCE_METHODS |
PR_RESOURCE_PATH |
PR_RESOURCE_PATH_A |
PR_RESOURCE_PATH_W |
PR_RESOURCE_TYPE |
PR_RESPONSE_REQUESTED |
PR_RESPONSIBILITY |
PR_RESTRICTION_COUNT |
PR_RETENTION_AGE_LIMIT |
PR_RETURNED_IPM |
PR_RIGHTS |
PR_ROW_TYPE |
PR_ROWID |
PR_RTF_COMPRESSED |
PR_RTF_DECOMPRESSED |
PR_RTF_IN_SYNC |
PR_RTF_SYNC_BODY_COUNT |
PR_RTF_SYNC_BODY_CRC |
PR_RTF_SYNC_BODY_TAG |
PR_RTF_SYNC_BODY_TAG_A |
PR_RTF_SYNC_BODY_TAG_W |
PR_RTF_SYNC_PREFIX_COUNT |
PR_RTF_SYNC_TRAILING_COUNT |
PR_RULE_ACTION_NUMBER |
PR_RULE_ACTION_TYPE |
PR_RULE_ACTIONS |
PR_RULE_CONDITION |
PR_RULE_ERROR |
PR_RULE_FOLDER_ENTRYID |
PR_RULE_ID |
PR_RULE_IDS |
PR_RULE_LEVEL |
PR_RULE_NAME |
PR_RULE_NAME_A |
PR_RULE_NAME_W |
PR_RULE_PROVIDER |
PR_RULE_PROVIDER_A |
PR_RULE_PROVIDER_DATA |
PR_RULE_PROVIDER_W |
PR_RULE_SEQUENCE |
PR_RULE_STATE |
PR_RULE_TRIGGER_HISTORY |
PR_RULE_USER_FLAGS |
PR_RULES_DATA |
PR_RULES_TABLE |
PR_SCHEDULE_FOLDER_ENTRYID |
PR_SEARCH |
PR_SEARCH_KEY |
PR_SECURE_IN_SITE |
PR_SECURE_ORIGINATION |
PR_SECURITY |
PR_SELECTABLE |
PR_SEND_INTERNET_ENCODING |
PR_SEND_RICH_INFO |
PR_SENDER_ADDRTYPE |
PR_SENDER_ADDRTYPE_A |
PR_SENDER_ADDRTYPE_W |
PR_SENDER_EMAIL_ADDRESS |
PR_SENDER_EMAIL_ADDRESS_A |
PR_SENDER_EMAIL_ADDRESS_W |
PR_SENDER_ENTRYID |
PR_SENDER_NAME |
PR_SENDER_NAME_A |
PR_SENDER_NAME_W |
PR_SENDER_SEARCH_KEY |
PR_SENSITIVITY |
PR_SENT_REPRESENTING_ADDRTYPE |
PR_SENT_REPRESENTING_ADDRTYPE_A |
PR_SENT_REPRESENTING_ADDRTYPE_W |
PR_SENT_REPRESENTING_EMAIL_ADDRESS |
PR_SENT_REPRESENTING_EMAIL_ADDRESS_A |
PR_SENT_REPRESENTING_EMAIL_ADDRESS_W |
PR_SENT_REPRESENTING_ENTRYID |
PR_SENT_REPRESENTING_NAME |
PR_SENT_REPRESENTING_NAME_A |
PR_SENT_REPRESENTING_NAME_W |
PR_SENT_REPRESENTING_SEARCH_KEY |
PR_SENTMAIL_ENTRYID |
PR_SERVICE_DELETE_FILES |
PR_SERVICE_DLL_NAME |
PR_SERVICE_DLL_NAME_A |
PR_SERVICE_DLL_NAME_W |
PR_SERVICE_ENTRY_NAME |
PR_SERVICE_ENTRY_NAME_A |
PR_SERVICE_ENTRY_NAME_W |
PR_SERVICE_EXTRA_UIDS |
PR_SERVICE_NAME |
PR_SERVICE_NAME_A |
PR_SERVICE_NAME_W |
PR_SERVICE_SUPPORT_FILES |
PR_SERVICE_UID |
PR_SERVICES |
PR_SORT_LOCALE_ID |
PR_SOURCE_KEY |
PR_SPLUS_FREE_BUSY_ENTRYID |
PR_SPOOLER_STATUS |
PR_SPOUSE_NAME |
PR_SPOUSE_NAME_A |
PR_SPOUSE_NAME_W |
PR_START_DATE |
PR_STATE_OR_PROVINCE |
PR_STATE_OR_PROVINCE_A |
PR_STATE_OR_PROVINCE_W |
PR_STATUS |
PR_STATUS_CODE |
PR_STATUS_STRING |
PR_STATUS_STRING_A |
PR_STATUS_STRING_W |
PR_STORAGE_LIMIT_INFORMATION |
PR_STORAGE_QUOTA_LIMIT |
PR_STORE_ENTRYID |
PR_STORE_OFFLINE |
PR_STORE_PROVIDERS |
PR_STORE_RECORD_KEY |
PR_STORE_SLOWLINK |
PR_STORE_STATE |
PR_STORE_SUPPORT_MASK |
PR_STREET_ADDRESS |
PR_STREET_ADDRESS_A |
PR_STREET_ADDRESS_W |
PR_SUBFOLDERS |
PR_SUBJECT |
PR_SUBJECT_A |
PR_SUBJECT_IPM |
PR_SUBJECT_PREFIX |
PR_SUBJECT_PREFIX_A |
PR_SUBJECT_PREFIX_W |
PR_SUBJECT_TRACE_INFO |
PR_SUBJECT_W |
PR_SUBMIT_FLAGS |
PR_SUPERSEDES |
PR_SUPERSEDES_A |
PR_SUPERSEDES_W |
PR_SUPPLEMENTARY_INFO |
PR_SUPPLEMENTARY_INFO_A |
PR_SUPPLEMENTARY_INFO_W |
PR_SURNAME |
PR_SURNAME_A |
PR_SURNAME_W |
PR_SVR_GENERATING_QUOTA_MSG |
PR_SVR_GENERATING_QUOTA_MSG_A |
PR_SVR_GENERATING_QUOTA_MSG_W |
PR_SWAPPED_TODO_DATA | Maintains a second set of property values that do not affect the flagged state of the Message object.
PR_SYNCHRONIZE_FLAGS |
PR_SYS_CONFIG_FOLDER_ENTRYID |
PR_TELEX_NUMBER |
PR_TELEX_NUMBER_A |
PR_TELEX_NUMBER_W |
PR_TEMPLATEID |
PR_TEST_LINE_SPEED |
PR_TITLE |
PR_TITLE_A |
PR_TITLE_W |
PR_TNEF_CORRELATION_KEY |
PR_TODO_ITEM_FLAGS | Represents a To-Do item's flagged condition.
PR_TRACE_INFO |
PR_TRANSFER_ENABLED |
PR_TRANSMITABLE_DISPLAY_NAME |
PR_TRANSMITABLE_DISPLAY_NAME_A |
PR_TRANSMITABLE_DISPLAY_NAME_W |
PR_TRANSPORT_KEY |
PR_TRANSPORT_MESSAGE_HEADERS |
PR_TRANSPORT_MESSAGE_HEADERS_A |
PR_TRANSPORT_MESSAGE_HEADERS_W |
PR_TRANSPORT_PROVIDERS |
PR_TRANSPORT_STATUS |
PR_TTYTDD_PHONE_NUMBER |
PR_TTYTDD_PHONE_NUMBER_A |
PR_TTYTDD_PHONE_NUMBER_W |
PR_TYPE_OF_MTS_USER |
PR_USER_CERTIFICATE |
PR_USER_ENTRYID |
PR_USER_NAME |
PR_USER_NAME_A |
PR_USER_NAME_W |
PR_USER_X509_CERTIFICATE |
PR_VALID_FOLDER_MASK |
PR_VIEWS_ENTRYID |
PR_WEDDING_ANNIVERSARY |
PR_X400_CONTENT_TYPE |
PR_X400_DEFERRED_DELIVERY_CANCEL |
PR_X400_ENVELOPE_TYPE |
PR_XPOS |
PR_YPOS |

Public Static Methods

GetPropertyName Gets the name of the property.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag Fields

The fields of the MapiPropertyTag class are listed below. For a complete list of MapiPropertyTag class members, see the MapiPropertyTag Members topic.

Public Static Fields

PR_7BIT_DISPLAY_NAME | The PR_7BIT_DISPLAY_NAME property contains a 7-bit ASCII version of a messaging user's name.
PR_7BIT_DISPLAY_NAME_A | The ASCII peer for PR_7BIT_DISPLAY_NAME.
PR_7BIT_DISPLAY_NAME_W | The Unicode peer for PR_7BIT_DISPLAY_NAME.
PR_AB_DEFAULT_DIR | The PR_AB_DEFAULT_DIR property contains the entry identifier of the address book container that is to be shown to the user first.
PR_AB_DEFAULT_PAB | The PR_AB_DEFAULT_PAB property contains the entry identifier of the address book container that is to be used as the personal address book.
PR_AB_PROVIDER_ID | The PR_AB_DEFAULT_PAB property contains the entry identifier of the address book container that is to be used as the personal address book.
PR_AB_PROVIDERS | The PR_AB_PROVIDERS property contains a list of identifiers for address book providers in the current profile.
PR_AB_SEARCH_PATH | The PR_AB_PROVIDERS property contains a list of identifiers for address book providers in the current profile.
PR_AB_SEARCH_PATH_UPDATE |
PR_ABSTRACT |
PR_ABSTRACT_A |
PR_ABSTRACT_W |
PR_ACCESS |
PR_ACCESS_LEVEL |
PR_ACCOUNT |
PR_ACCOUNT_A |
PR_ACCOUNT_W |
PR_ACKNOWLEDGEMENT_MODE |
PR_ACL_DATA |
PR_ACL_TABLE |
PR_ACTIVE_USER_ENTRYID |
PR_ADDRBOOK_FOR_LOCAL_SITE_ENTRYID |
PR_ADDRESS_BOOK_DISPLAY_NAME |
PR_ADDRESS_BOOK_DISPLAY_NAME_A |
PR_ADDRESS_BOOK_DISPLAY_NAME_W |
PR_ADDRESS_BOOK_ENTRYID |
PR_ADDRTYPE |
PR_ADDRTYPE_A |
PR_ADDRTYPE_W |
PR_ALTERNATE_RECIPIENT |
PR_ALTERNATE_RECIPIENT_ALLOWED |
PR_ANR |
PR_ANR_A |
PR_ANR_W |
PR_ARRIVAL_TIME |
PR_ASSISTANT |
PR_ASSISTANT_A |
PR_ASSISTANT_TELEPHONE_NUMBER |
PR_ASSISTANT_TELEPHONE_NUMBER_A |
PR_ASSISTANT_TELEPHONE_NUMBER_W |
PR_ASSISTANT_W |
PR_ASSOC_CONTENT_COUNT |
PR_ASSOC_MESSAGE_SIZE |
PR_ASSOC_MESSAGE_SIZE_EXTENDED |
PR_ASSOC_MSG_W_ATTACH_COUNT |
PR_ATTACH_ADDITIONAL_INFO |
PR_ATTACH_CONTENT_ID | Contains the content identification header of a MIME message attachment. This property is used for MHTML support.
PR_ATTACH_CONTENT_ID_A | Contains the content identification header of a MIME message attachment. This property is used for MHTML support. Non-UNICODE compilation.
PR_ATTACH_CONTENT_ID_W | Contains the content identification header of a MIME message attachment. This property is used for MHTML support. UNICODE compilation.
PR_ATTACH_DATA_BIN |
PR_ATTACH_DATA_OBJ |
PR_ATTACH_ENCODING |
PR_ATTACH_EXTENSION |
PR_ATTACH_EXTENSION_A |
PR_ATTACH_EXTENSION_W |
PR_ATTACH_FILENAME |
PR_ATTACH_FILENAME_A |
PR_ATTACH_FILENAME_W |
PR_ATTACH_LONG_FILENAME |
PR_ATTACH_LONG_FILENAME_A |
PR_ATTACH_LONG_FILENAME_W |
PR_ATTACH_LONG_PATHNAME |
PR_ATTACH_LONG_PATHNAME_A |
PR_ATTACH_LONG_PATHNAME_W |
PR_ATTACH_METHOD |
PR_ATTACH_MIME_TAG |
PR_ATTACH_MIME_TAG_A |
PR_ATTACH_MIME_TAG_W |
PR_ATTACH_NUM |
PR_ATTACH_ON_ASSOC_MSG_COUNT |
PR_ATTACH_ON_NORMAL_MSG_COUNT |
PR_ATTACH_PATHNAME |
PR_ATTACH_PATHNAME_A |
PR_ATTACH_PATHNAME_W |
PR_ATTACH_RENDERING |
PR_ATTACH_SIZE |
PR_ATTACH_TAG |
PR_ATTACH_TRANSPORT_NAME |
PR_ATTACH_TRANSPORT_NAME_A |
PR_ATTACH_TRANSPORT_NAME_W |
PR_ATTACHMENT_CONTACTPHOTO |
PR_ATTACHMENT_FLAGS |
PR_ATTACHMENT_X400_PARAMETERS |
PR_AUTHORIZING_USERS |
PR_AUTO_ADD_NEW_SUBS |
PR_AUTO_FORWARD_COMMENT |
PR_AUTO_FORWARD_COMMENT_A |
PR_AUTO_FORWARD_COMMENT_W |
PR_AUTO_FORWARDED |
PR_AUTO_RESPONSE_SUPPRESS |
PR_BEEPER_TELEPHONE_NUMBER |
PR_BEEPER_TELEPHONE_NUMBER_A |
PR_BEEPER_TELEPHONE_NUMBER_W |
PR_BILATERAL_INFO |
PR_BIRTHDAY |
PR_BODY |
PR_BODY_A |
PR_BODY_CRC |
PR_BODY_W |
PR_BUSINESS_ADDRESS_CITY |
PR_BUSINESS_ADDRESS_CITY_A |
PR_BUSINESS_ADDRESS_CITY_W |
PR_BUSINESS_ADDRESS_COUNTRY |
PR_BUSINESS_ADDRESS_COUNTRY_A |
PR_BUSINESS_ADDRESS_COUNTRY_W |
PR_BUSINESS_ADDRESS_POST_OFFICE_BOX |
PR_BUSINESS_ADDRESS_POST_OFFICE_BOX_A |
PR_BUSINESS_ADDRESS_POST_OFFICE_BOX_W |
PR_BUSINESS_ADDRESS_POSTAL_CODE |
PR_BUSINESS_ADDRESS_POSTAL_CODE_A |
PR_BUSINESS_ADDRESS_POSTAL_CODE_W |
PR_BUSINESS_ADDRESS_STATE_OR_PROVINCE |
PR_BUSINESS_ADDRESS_STATE_OR_PROVINCE_A |
PR_BUSINESS_ADDRESS_STATE_OR_PROVINCE_W |
PR_BUSINESS_ADDRESS_STREET |
PR_BUSINESS_ADDRESS_STREET_A |
PR_BUSINESS_ADDRESS_STREET_W |
PR_BUSINESS_FAX_NUMBER |
PR_BUSINESS_FAX_NUMBER_A |
PR_BUSINESS_FAX_NUMBER_W |
PR_BUSINESS_HOME_PAGE |
PR_BUSINESS_HOME_PAGE_A |
PR_BUSINESS_HOME_PAGE_W |
PR_BUSINESS_TELEPHONE_NUMBER |
PR_BUSINESS_TELEPHONE_NUMBER_A |
PR_BUSINESS_TELEPHONE_NUMBER_W |
PR_BUSINESS2_TELEPHONE_NUMBER |
PR_BUSINESS2_TELEPHONE_NUMBER_A |
PR_BUSINESS2_TELEPHONE_NUMBER_W |
PR_CACHED_COLUMN_COUNT |
PR_CALLBACK_TELEPHONE_NUMBER |
PR_CALLBACK_TELEPHONE_NUMBER_A |
PR_CALLBACK_TELEPHONE_NUMBER_W |
PR_CAR_TELEPHONE_NUMBER |
PR_CAR_TELEPHONE_NUMBER_A |
PR_CAR_TELEPHONE_NUMBER_W |
PR_CATEG_COUNT |
PR_CELLULAR_TELEPHONE_NUMBER |
PR_CELLULAR_TELEPHONE_NUMBER_A |
PR_CELLULAR_TELEPHONE_NUMBER_W |
PR_CHANGE_ADVISOR |
PR_CHANGE_KEY |
PR_CHANGE_NOTIFICATION_GUID |
PR_CHILDRENS_NAMES |
PR_CLIENT_ACTIONS |
PR_CLIENT_SUBMIT_TIME |
PR_CODE_PAGE_ID |
PR_COLLECTOR |
PR_COMMENT |
PR_COMMENT_A |
PR_COMMENT_W |
PR_COMMON_VIEWS_ENTRYID |
PR_COMPANY_MAIN_PHONE_NUMBER |
PR_COMPANY_MAIN_PHONE_NUMBER_A |
PR_COMPANY_MAIN_PHONE_NUMBER_W |
PR_COMPANY_NAME |
PR_COMPANY_NAME_A |
PR_COMPANY_NAME_W |
PR_COMPUTER_NETWORK_NAME |
PR_COMPUTER_NETWORK_NAME_A |
PR_COMPUTER_NETWORK_NAME_W |
PR_CONFLICT_ENTRYID |
PR_CONTACT_ADDRTYPES |
PR_CONTACT_COUNT |
PR_CONTACT_DEFAULT_ADDRESS_INDEX |
PR_CONTACT_EMAIL_ADDRESSES |
PR_CONTACT_ENTRYIDS |
PR_CONTACT_VERSION |
PR_CONTAINER_CLASS |
PR_CONTAINER_CLASS_A |
PR_CONTAINER_CLASS_W |
PR_CONTAINER_CONTENTS |
PR_CONTAINER_FLAGS |
PR_CONTAINER_HIERARCHY |
PR_CONTAINER_MODIFY_VERSION |
PR_CONTENT_CONFIDENTIALITY_ALGORITHM_ID |
PR_CONTENT_CORRELATOR |
PR_CONTENT_COUNT |
PR_CONTENT_IDENTIFIER |
PR_CONTENT_IDENTIFIER_A |
PR_CONTENT_IDENTIFIER_W |
PR_CONTENT_INTEGRITY_CHECK |
PR_CONTENT_LENGTH |
PR_CONTENT_RETURN_REQUESTED |
PR_CONTENT_SEARCH_KEY |
PR_CONTENT_UNREAD |
PR_CONTENTS_SORT_ORDER |
PR_CONTENTS_SYNCHRONIZER |
PR_CONTROL_FLAGS |
PR_CONTROL_ID |
PR_CONTROL_STRUCTURE |
PR_CONTROL_TYPE |
PR_CONVERSATION_INDEX |
PR_CONVERSATION_KEY |
PR_CONVERSATION_TOPIC |
PR_CONVERSATION_TOPIC_A |
PR_CONVERSATION_TOPIC_W |
PR_CONVERSION_EITS |
PR_CONVERSION_PROHIBITED |
PR_CONVERSION_WITH_LOSS_PROHIBITED |
PR_CONVERTED_EITS |
PR_CORRELATE |
PR_CORRELATE_MTSID |
PR_COUNTRY |
PR_COUNTRY_A |
PR_COUNTRY_W |
PR_CREATE_TEMPLATES |
PR_CREATION_TIME |
PR_CREATION_VERSION |
PR_CREATOR_ENTRYID |
PR_CREATOR_NAME |
PR_CREATOR_NAME_A |
PR_CREATOR_NAME_W |
PR_CURRENT_VERSION |
PR_CUSTOMER_ID |
PR_CUSTOMER_ID_A |
PR_CUSTOMER_ID_W |
PR_DAM_BACK_PATCHED |
PR_DAM_ORIGINAL_ENTRYID |
PR_DEF_CREATE_DL |
PR_DEF_CREATE_MAILUSER |
PR_DEFAULT_PROFILE |
PR_DEFAULT_STORE |
PR_DEFAULT_VIEW_ENTRYID |
PR_DEFERRED_DELIVERY_TIME |
PR_DEFERRED_SEND_NUMBER |
PR_DEFERRED_SEND_TIME |
PR_DEFERRED_SEND_UNITS |
PR_DELEGATED_BY_RULE |
PR_DELEGATION |
PR_DELETE_AFTER_SUBMIT |
PR_DELETED_ASSOC_MESSAGE_SIZE_EXTENDED |
PR_DELETED_ASSOC_MSG_COUNT |
PR_DELETED_FOLDER_COUNT |
PR_DELETED_MESSAGE_SIZE_EXTENDED |
PR_DELETED_MSG_COUNT |
PR_DELETED_NORMAL_MESSAGE_SIZE_EXTENDED |
PR_DELETED_ON |
PR_DELIVER_TIME |
PR_DELIVERY_POINT |
PR_DELTAX |
PR_DELTAY |
PR_DEPARTMENT_NAME |
PR_DEPARTMENT_NAME_A |
PR_DEPARTMENT_NAME_W |
PR_DEPTH |
PR_DESIGN_IN_PROGRESS |
PR_DETAILS_TABLE |
PR_DISABLE_FULL_FIDELITY |
PR_DISABLE_WINSOCK |
PR_DISC_VAL |
PR_DISCARD_REASON |
PR_DISCLOSE_RECIPIENTS |
PR_DISCLOSURE_OF_RECIPIENTS |
PR_DISCRETE_VALUES |
PR_DISPLAY_BCC |
PR_DISPLAY_BCC_A |
PR_DISPLAY_BCC_W |
PR_DISPLAY_CC |
PR_DISPLAY_CC_A |
PR_DISPLAY_CC_W |
PR_DISPLAY_NAME |
PR_DISPLAY_NAME_A |
PR_DISPLAY_NAME_PREFIX |
PR_DISPLAY_NAME_PREFIX_A |
PR_DISPLAY_NAME_PREFIX_W |
PR_DISPLAY_NAME_W |
PR_DISPLAY_TO |
PR_DISPLAY_TO_A |
PR_DISPLAY_TO_W |
PR_DISPLAY_TYPE |
PR_DL_EXPANSION_HISTORY |
PR_DL_EXPANSION_PROHIBITED |
PR_DL_REPORT_FLAGS |
PR_EFORMS_FOR_LOCALE_ENTRYID |
PR_EFORMS_LOCALE_ID |
PR_EFORMS_REGISTRY_ENTRYID |
PR_EMAIL_ADDRESS |
PR_EMAIL_ADDRESS_A |
PR_EMAIL_ADDRESS_W |
PR_EMS_AB_ACCESS_CATEGORY |
PR_EMS_AB_ACTIVATION_SCHEDULE |
PR_EMS_AB_ACTIVATION_STYLE |
PR_EMS_AB_ADDRESS_ENTRY_DISPLAY_TABLE |
PR_EMS_AB_ADDRESS_ENTRY_DISPLAY_TABLE_MSDOS |
PR_EMS_AB_ADDRESS_SYNTAX |
PR_EMS_AB_ADDRESS_TYPE |
PR_EMS_AB_ADDRESS_TYPE_A |
PR_EMS_AB_ADDRESS_TYPE_W |
PR_EMS_AB_ADMD |
PR_EMS_AB_ADMD_A |
PR_EMS_AB_ADMD_W |
PR_EMS_AB_ADMIN_DESCRIPTION |
PR_EMS_AB_ADMIN_DESCRIPTION_A |
PR_EMS_AB_ADMIN_DESCRIPTION_W |
PR_EMS_AB_ADMIN_DISPLAY_NAME |
PR_EMS_AB_ADMIN_DISPLAY_NAME_A |
PR_EMS_AB_ADMIN_DISPLAY_NAME_W |
PR_EMS_AB_ADMIN_EXTENSION_DLL |
PR_EMS_AB_ADMIN_EXTENSION_DLL_A |
PR_EMS_AB_ADMIN_EXTENSION_DLL_W |
PR_EMS_AB_ALIASED_OBJECT_NAME |
PR_EMS_AB_ALIASED_OBJECT_NAME_A |
PR_EMS_AB_ALIASED_OBJECT_NAME_O |
PR_EMS_AB_ALIASED_OBJECT_NAME_W |
PR_EMS_AB_ALT_RECIPIENT |
PR_EMS_AB_ALT_RECIPIENT_A |
PR_EMS_AB_ALT_RECIPIENT_BL |
PR_EMS_AB_ALT_RECIPIENT_BL_O |
PR_EMS_AB_ALT_RECIPIENT_O |
PR_EMS_AB_ALT_RECIPIENT_W |
PR_EMS_AB_ANCESTOR_ID |
PR_EMS_AB_ANONYMOUS_ACCESS |
PR_EMS_AB_ANONYMOUS_ACCOUNT |
PR_EMS_AB_ANONYMOUS_ACCOUNT_A |
PR_EMS_AB_ANONYMOUS_ACCOUNT_W |
PR_EMS_AB_ASSOC_NT_ACCOUNT |
PR_EMS_AB_ASSOC_PROTOCOL_CFG_NNTP |
PR_EMS_AB_ASSOC_PROTOCOL_CFG_NNTP_A |
PR_EMS_AB_ASSOC_PROTOCOL_CFG_NNTP_O |
PR_EMS_AB_ASSOC_PROTOCOL_CFG_NNTP_W |
PR_EMS_AB_ASSOC_REMOTE_DXA |
PR_EMS_AB_ASSOC_REMOTE_DXA_O |
PR_EMS_AB_ASSOCIATION_LIFETIME |
PR_EMS_AB_ATTRIBUTE_CERTIFICATE |
PR_EMS_AB_AUTH_ORIG_BL |
PR_EMS_AB_AUTH_ORIG_BL_O |
PR_EMS_AB_AUTHENTICATION_TO_USE |
PR_EMS_AB_AUTHENTICATION_TO_USE_A |
PR_EMS_AB_AUTHENTICATION_TO_USE_W |
PR_EMS_AB_AUTHORITY_REVOCATION_LIST |
PR_EMS_AB_AUTHORIZED_DOMAIN |
PR_EMS_AB_AUTHORIZED_DOMAIN_A |
PR_EMS_AB_AUTHORIZED_DOMAIN_W |
PR_EMS_AB_AUTHORIZED_PASSWORD |
PR_EMS_AB_AUTHORIZED_PASSWORD_CONFIRM |
PR_EMS_AB_AUTHORIZED_USER |
PR_EMS_AB_AUTHORIZED_USER_A |
PR_EMS_AB_AUTHORIZED_USER_W |
PR_EMS_AB_AUTOREPLY |
PR_EMS_AB_AUTOREPLY_MESSAGE |
PR_EMS_AB_AUTOREPLY_MESSAGE_A |
PR_EMS_AB_AUTOREPLY_MESSAGE_W |
PR_EMS_AB_AUTOREPLY_SUBJECT |
PR_EMS_AB_AUTOREPLY_SUBJECT_A |
PR_EMS_AB_AUTOREPLY_SUBJECT_W |
PR_EMS_AB_AVAILABLE_AUTHORIZATION_PACKAGES |
PR_EMS_AB_AVAILABLE_DISTRIBUTIONS |
PR_EMS_AB_AVAILABLE_DISTRIBUTIONS_A |
PR_EMS_AB_AVAILABLE_DISTRIBUTIONS_W |
PR_EMS_AB_BRIDGEHEAD_SERVERS |
PR_EMS_AB_BRIDGEHEAD_SERVERS_O |
PR_EMS_AB_BUSINESS_CATEGORY |
PR_EMS_AB_BUSINESS_ROLES |
PR_EMS_AB_CA_CERTIFICATE |
PR_EMS_AB_CAN_CREATE_PF |
PR_EMS_AB_CAN_CREATE_PF_BL |
PR_EMS_AB_CAN_CREATE_PF_BL_O |
PR_EMS_AB_CAN_CREATE_PF_DL |
PR_EMS_AB_CAN_CREATE_PF_DL_BL |
PR_EMS_AB_CAN_CREATE_PF_DL_BL_O |
PR_EMS_AB_CAN_CREATE_PF_DL_O |
PR_EMS_AB_CAN_CREATE_PF_O |
PR_EMS_AB_CAN_NOT_CREATE_PF |
PR_EMS_AB_CAN_NOT_CREATE_PF_BL |
PR_EMS_AB_CAN_NOT_CREATE_PF_BL_O |
PR_EMS_AB_CAN_NOT_CREATE_PF_DL |
PR_EMS_AB_CAN_NOT_CREATE_PF_DL_BL |
PR_EMS_AB_CAN_NOT_CREATE_PF_DL_BL_O |
PR_EMS_AB_CAN_NOT_CREATE_PF_DL_O |
PR_EMS_AB_CAN_NOT_CREATE_PF_O |
PR_EMS_AB_CAN_PRESERVE_DNS |
PR_EMS_AB_CERTIFICATE_CHAIN_V3 |
PR_EMS_AB_CERTIFICATE_REVOCATION_LIST |
PR_EMS_AB_CERTIFICATE_REVOCATION_LIST_V1 |
PR_EMS_AB_CERTIFICATE_REVOCATION_LIST_V3 |
PR_EMS_AB_CHARACTER_SET |
PR_EMS_AB_CHARACTER_SET_A |
PR_EMS_AB_CHARACTER_SET_LIST |
PR_EMS_AB_CHARACTER_SET_W |
PR_EMS_AB_CHILD_RDNS |
PR_EMS_AB_CLIENT_ACCESS_ENABLED |
PR_EMS_AB_CLOCK_ALERT_OFFSET |
PR_EMS_AB_CLOCK_ALERT_REPAIR |
PR_EMS_AB_CLOCK_WARNING_OFFSET |
PR_EMS_AB_CLOCK_WARNING_REPAIR |
PR_EMS_AB_COMPROMISED_KEY_LIST |
PR_EMS_AB_COMPUTER_NAME |
PR_EMS_AB_COMPUTER_NAME_A |
PR_EMS_AB_COMPUTER_NAME_W |
PR_EMS_AB_CONNECTED_DOMAINS |
PR_EMS_AB_CONNECTION_LIST_FILTER |
PR_EMS_AB_CONNECTION_LIST_FILTER_TYPE |
PR_EMS_AB_CONNECTION_TYPE |
PR_EMS_AB_CONTAINER_INFO |
PR_EMS_AB_CONTAINERID |
PR_EMS_AB_CONTENT_TYPE |
PR_EMS_AB_CONTROL_MSG_FOLDER_ID |
PR_EMS_AB_CONTROL_MSG_RULES |
PR_EMS_AB_COST |
PR_EMS_AB_COUNTRY_NAME |
PR_EMS_AB_COUNTRY_NAME_A |
PR_EMS_AB_COUNTRY_NAME_W |
PR_EMS_AB_CROSS_CERTIFICATE_CRL |
PR_EMS_AB_CROSS_CERTIFICATE_PAIR |
PR_EMS_AB_DEFAULT_MESSAGE_FORMAT |
PR_EMS_AB_DELEGATE_USER |
PR_EMS_AB_DELIV_CONT_LENGTH |
PR_EMS_AB_DELIV_EITS |
PR_EMS_AB_DELIV_EXT_CONT_TYPES |
PR_EMS_AB_DELIVER_AND_REDIRECT |
PR_EMS_AB_DELIVERY_MECHANISM |
PR_EMS_AB_DELTA_REVOCATION_LIST |
PR_EMS_AB_DESCRIPTION |
PR_EMS_AB_DESTINATION_INDICATOR |
PR_EMS_AB_DIAGNOSTIC_REG_KEY |
PR_EMS_AB_DIAGNOSTIC_REG_KEY_A |
PR_EMS_AB_DIAGNOSTIC_REG_KEY_W |
PR_EMS_AB_DISABLE_DEFERRED_COMMIT |
PR_EMS_AB_DISABLED_GATEWAY_PROXY |
PR_EMS_AB_DISPLAY_NAME_OVERRIDE |
PR_EMS_AB_DISPLAY_NAME_PRINTABLE |
PR_EMS_AB_DISPLAY_NAME_PRINTABLE_A |
PR_EMS_AB_DISPLAY_NAME_PRINTABLE_W |
PR_EMS_AB_DISPLAY_NAME_SUFFIX |
PR_EMS_AB_DISPLAY_NAME_SUFFIX_A |
PR_EMS_AB_DISPLAY_NAME_SUFFIX_W |
PR_EMS_AB_DL_MEM_REJECT_PERMS_BL |
PR_EMS_AB_DL_MEM_REJECT_PERMS_BL_O |
PR_EMS_AB_DL_MEM_SUBMIT_PERMS_BL |
PR_EMS_AB_DL_MEM_SUBMIT_PERMS_BL_O |
PR_EMS_AB_DL_MEMBER_RULE |
PR_EMS_AB_DMD_NAME |
PR_EMS_AB_DMD_NAME_A |
PR_EMS_AB_DMD_NAME_W |
PR_EMS_AB_DO_OAB_VERSION |
PR_EMS_AB_DOMAIN_DEF_ALT_RECIP |
PR_EMS_AB_DOMAIN_DEF_ALT_RECIP_A |
PR_EMS_AB_DOMAIN_DEF_ALT_RECIP_O |
PR_EMS_AB_DOMAIN_DEF_ALT_RECIP_W |
PR_EMS_AB_DOMAIN_NAME |
PR_EMS_AB_DOMAIN_NAME_A |
PR_EMS_AB_DOMAIN_NAME_W |
PR_EMS_AB_DOS_ENTRYID |
PR_EMS_AB_DSA_SIGNATURE |
PR_EMS_AB_DXA_ADMIN_COPY |
PR_EMS_AB_DXA_ADMIN_FORWARD |
PR_EMS_AB_DXA_ADMIN_UPDATE |
PR_EMS_AB_DXA_APPEND_REQCN |
PR_EMS_AB_DXA_CONF_CONTAINER_LIST |
PR_EMS_AB_DXA_CONF_CONTAINER_LIST_O |
PR_EMS_AB_DXA_CONF_REQ_TIME |
PR_EMS_AB_DXA_CONF_SEQ |
PR_EMS_AB_DXA_CONF_SEQ_A |
PR_EMS_AB_DXA_CONF_SEQ_USN |
PR_EMS_AB_DXA_CONF_SEQ_W |
PR_EMS_AB_DXA_EXCHANGE_OPTIONS |
PR_EMS_AB_DXA_EXPORT_NOW |
PR_EMS_AB_DXA_FLAGS |
PR_EMS_AB_DXA_IMP_SEQ |
PR_EMS_AB_DXA_IMP_SEQ_A |
PR_EMS_AB_DXA_IMP_SEQ_TIME |
PR_EMS_AB_DXA_IMP_SEQ_USN |
PR_EMS_AB_DXA_IMP_SEQ_W |
PR_EMS_AB_DXA_IMPORT_NOW |
PR_EMS_AB_DXA_IN_TEMPLATE_MAP |
PR_EMS_AB_DXA_LOCAL_ADMIN |
PR_EMS_AB_DXA_LOCAL_ADMIN_A |
PR_EMS_AB_DXA_LOCAL_ADMIN_O |
PR_EMS_AB_DXA_LOCAL_ADMIN_W |
PR_EMS_AB_DXA_LOGGING_LEVEL |
PR_EMS_AB_DXA_NATIVE_ADDRESS_TYPE |
PR_EMS_AB_DXA_NATIVE_ADDRESS_TYPE_A |
PR_EMS_AB_DXA_NATIVE_ADDRESS_TYPE_W |
PR_EMS_AB_DXA_OUT_TEMPLATE_MAP |
PR_EMS_AB_DXA_PASSWORD |
PR_EMS_AB_DXA_PASSWORD_A |
PR_EMS_AB_DXA_PASSWORD_W |
PR_EMS_AB_DXA_PREV_EXCHANGE_OPTIONS |
PR_EMS_AB_DXA_PREV_EXPORT_NATIVE_ONLY |
PR_EMS_AB_DXA_PREV_IN_EXCHANGE_SENSITIVITY |
PR_EMS_AB_DXA_PREV_REMOTE_ENTRIES |
PR_EMS_AB_DXA_PREV_REMOTE_ENTRIES_A |
PR_EMS_AB_DXA_PREV_REMOTE_ENTRIES_O |
PR_EMS_AB_DXA_PREV_REMOTE_ENTRIES_W |
PR_EMS_AB_DXA_PREV_REPLICATION_SENSITIVITY |
PR_EMS_AB_DXA_PREV_TEMPLATE_OPTIONS |
PR_EMS_AB_DXA_PREV_TYPES |
PR_EMS_AB_DXA_RECIPIENT_CP |
PR_EMS_AB_DXA_RECIPIENT_CP_A |
PR_EMS_AB_DXA_RECIPIENT_CP_W |
PR_EMS_AB_DXA_REMOTE_CLIENT |
PR_EMS_AB_DXA_REMOTE_CLIENT_A |
PR_EMS_AB_DXA_REMOTE_CLIENT_O |
PR_EMS_AB_DXA_REMOTE_CLIENT_W |
PR_EMS_AB_DXA_REQ_SEQ |
PR_EMS_AB_DXA_REQ_SEQ_A |
PR_EMS_AB_DXA_REQ_SEQ_TIME |
PR_EMS_AB_DXA_REQ_SEQ_USN |
PR_EMS_AB_DXA_REQ_SEQ_W |
PR_EMS_AB_DXA_REQNAME |
PR_EMS_AB_DXA_REQNAME_A |
PR_EMS_AB_DXA_REQNAME_W |
PR_EMS_AB_DXA_SVR_SEQ |
PR_EMS_AB_DXA_SVR_SEQ_A |
PR_EMS_AB_DXA_SVR_SEQ_TIME |
PR_EMS_AB_DXA_SVR_SEQ_USN |
PR_EMS_AB_DXA_SVR_SEQ_W |
PR_EMS_AB_DXA_TASK |
PR_EMS_AB_DXA_TEMPLATE_OPTIONS |
PR_EMS_AB_DXA_TEMPLATE_TIMESTAMP |
PR_EMS_AB_DXA_TYPES |
PR_EMS_AB_DXA_UNCONF_CONTAINER_LIST |
PR_EMS_AB_DXA_UNCONF_CONTAINER_LIST_O |
PR_EMS_AB_EMPLOYEE_NUMBER |
PR_EMS_AB_EMPLOYEE_NUMBER_A |
PR_EMS_AB_EMPLOYEE_NUMBER_W |
PR_EMS_AB_EMPLOYEE_TYPE |
PR_EMS_AB_EMPLOYEE_TYPE_A |
PR_EMS_AB_EMPLOYEE_TYPE_W |
PR_EMS_AB_ENABLE_COMPATIBILITY |
PR_EMS_AB_ENABLED |
PR_EMS_AB_ENABLED_AUTHORIZATION_PACKAGES |
PR_EMS_AB_ENABLED_PROTOCOL_CFG |
PR_EMS_AB_ENABLED_PROTOCOLS |
PR_EMS_AB_ENCAPSULATION_METHOD |
PR_EMS_AB_ENCRYPT |
PR_EMS_AB_ENCRYPT_ALG_LIST_NA |
PR_EMS_AB_ENCRYPT_ALG_LIST_OTHER |
PR_EMS_AB_ENCRYPT_ALG_SELECTED_NA |
PR_EMS_AB_ENCRYPT_ALG_SELECTED_NA_A |
PR_EMS_AB_ENCRYPT_ALG_SELECTED_NA_W |
PR_EMS_AB_ENCRYPT_ALG_SELECTED_OTHER |
PR_EMS_AB_ENCRYPT_ALG_SELECTED_OTHER_A |
PR_EMS_AB_ENCRYPT_ALG_SELECTED_OTHER_W |
PR_EMS_AB_EXPAND_DLS_LOCALLY |
PR_EMS_AB_EXPIRATION_TIME |
PR_EMS_AB_EXPORT_CONTAINERS |
PR_EMS_AB_EXPORT_CONTAINERS_O |
PR_EMS_AB_EXPORT_CUSTOM_RECIPIENTS |
PR_EMS_AB_EXTENDED_CHARS_ALLOWED |
PR_EMS_AB_EXTENSION_ATTRIBUTE_1 |
PR_EMS_AB_EXTENSION_ATTRIBUTE_1_A |
PR_EMS_AB_EXTENSION_ATTRIBUTE_1_W |
PR_EMS_AB_EXTENSION_ATTRIBUTE_10 |
PR_EMS_AB_EXTENSION_ATTRIBUTE_10_A |
PR_EMS_AB_EXTENSION_ATTRIBUTE_10_W |
PR_EMS_AB_EXTENSION_ATTRIBUTE_11 |
PR_EMS_AB_EXTENSION_ATTRIBUTE_11_A |
PR_EMS_AB_EXTENSION_ATTRIBUTE_11_W |
PR_EMS_AB_EXTENSION_ATTRIBUTE_12 |
PR_EMS_AB_EXTENSION_ATTRIBUTE_12_A |
PR_EMS_AB_EXTENSION_ATTRIBUTE_12_W |
PR_EMS_AB_EXTENSION_ATTRIBUTE_13 |
PR_EMS_AB_EXTENSION_ATTRIBUTE_13_A |
PR_EMS_AB_EXTENSION_ATTRIBUTE_13_W |
PR_EMS_AB_EXTENSION_ATTRIBUTE_14 |
PR_EMS_AB_EXTENSION_ATTRIBUTE_14_A |
PR_EMS_AB_EXTENSION_ATTRIBUTE_14_W |
PR_EMS_AB_EXTENSION_ATTRIBUTE_15 |
PR_EMS_AB_EXTENSION_ATTRIBUTE_15_A |
PR_EMS_AB_EXTENSION_ATTRIBUTE_15_W |
PR_EMS_AB_EXTENSION_ATTRIBUTE_2 |
PR_EMS_AB_EXTENSION_ATTRIBUTE_2_A |
PR_EMS_AB_EXTENSION_ATTRIBUTE_2_W |
PR_EMS_AB_EXTENSION_ATTRIBUTE_3 |
PR_EMS_AB_EXTENSION_ATTRIBUTE_3_A |
PR_EMS_AB_EXTENSION_ATTRIBUTE_3_W |
PR_EMS_AB_EXTENSION_ATTRIBUTE_4 |
PR_EMS_AB_EXTENSION_ATTRIBUTE_4_A |
PR_EMS_AB_EXTENSION_ATTRIBUTE_4_W |
PR_EMS_AB_EXTENSION_ATTRIBUTE_5 |
PR_EMS_AB_EXTENSION_ATTRIBUTE_5_A |
PR_EMS_AB_EXTENSION_ATTRIBUTE_5_W |
PR_EMS_AB_EXTENSION_ATTRIBUTE_6 |
PR_EMS_AB_EXTENSION_ATTRIBUTE_6_A |
PR_EMS_AB_EXTENSION_ATTRIBUTE_6_W |
PR_EMS_AB_EXTENSION_ATTRIBUTE_7 |
PR_EMS_AB_EXTENSION_ATTRIBUTE_7_A |
PR_EMS_AB_EXTENSION_ATTRIBUTE_7_W |
PR_EMS_AB_EXTENSION_ATTRIBUTE_8 |
PR_EMS_AB_EXTENSION_ATTRIBUTE_8_A |
PR_EMS_AB_EXTENSION_ATTRIBUTE_8_W |
PR_EMS_AB_EXTENSION_ATTRIBUTE_9 |
PR_EMS_AB_EXTENSION_ATTRIBUTE_9_A |
PR_EMS_AB_EXTENSION_ATTRIBUTE_9_W |
PR_EMS_AB_EXTENSION_DATA |
PR_EMS_AB_EXTENSION_NAME |
PR_EMS_AB_EXTENSION_NAME_INHERITED |
PR_EMS_AB_FACSIMILE_TELEPHONE_NUMBER |
PR_EMS_AB_FILE_VERSION |
PR_EMS_AB_FILTER_LOCAL_ADDRESSES |
PR_EMS_AB_FOLDER_PATHNAME |
PR_EMS_AB_FOLDER_PATHNAME_A |
PR_EMS_AB_FOLDER_PATHNAME_W |
PR_EMS_AB_FOLDERS_CONTAINER |
PR_EMS_AB_FOLDERS_CONTAINER_A |
PR_EMS_AB_FOLDERS_CONTAINER_O |
PR_EMS_AB_FOLDERS_CONTAINER_W |
PR_EMS_AB_FORM_DATA |
PR_EMS_AB_FORWARDING_ADDRESS |
PR_EMS_AB_FORWARDING_ADDRESS_A |
PR_EMS_AB_FORWARDING_ADDRESS_W |
PR_EMS_AB_GARBAGE_COLL_PERIOD |
PR_EMS_AB_GATEWAY_LOCAL_CRED |
PR_EMS_AB_GATEWAY_LOCAL_CRED_A |
PR_EMS_AB_GATEWAY_LOCAL_CRED_W |
PR_EMS_AB_GATEWAY_LOCAL_DESIG |
PR_EMS_AB_GATEWAY_LOCAL_DESIG_A |
PR_EMS_AB_GATEWAY_LOCAL_DESIG_W |
PR_EMS_AB_GATEWAY_PROXY |
PR_EMS_AB_GATEWAY_ROUTING_TREE |
PR_EMS_AB_GENERATION_QUALIFIER |
PR_EMS_AB_GENERATION_QUALIFIER_A |
PR_EMS_AB_GENERATION_QUALIFIER_W |
PR_EMS_AB_GROUP_BY_ATTR_1 |
PR_EMS_AB_GROUP_BY_ATTR_1_A |
PR_EMS_AB_GROUP_BY_ATTR_1_W |
PR_EMS_AB_GROUP_BY_ATTR_2 |
PR_EMS_AB_GROUP_BY_ATTR_2_A |
PR_EMS_AB_GROUP_BY_ATTR_2_W |
PR_EMS_AB_GROUP_BY_ATTR_3 |
PR_EMS_AB_GROUP_BY_ATTR_3_A |
PR_EMS_AB_GROUP_BY_ATTR_3_W |
PR_EMS_AB_GROUP_BY_ATTR_4 |
PR_EMS_AB_GROUP_BY_ATTR_4_A |
PR_EMS_AB_GROUP_BY_ATTR_4_W |
PR_EMS_AB_GROUP_BY_ATTR_VALUE_DN |
PR_EMS_AB_GROUP_BY_ATTR_VALUE_DN_A |
PR_EMS_AB_GROUP_BY_ATTR_VALUE_DN_O |
PR_EMS_AB_GROUP_BY_ATTR_VALUE_DN_W |
PR_EMS_AB_GROUP_BY_ATTR_VALUE_STR |
PR_EMS_AB_GROUP_BY_ATTR_VALUE_STR_A |
PR_EMS_AB_GROUP_BY_ATTR_VALUE_STR_W |
PR_EMS_AB_GWART_LAST_MODIFIED |
PR_EMS_AB_HAS_FULL_REPLICA_NCS |
PR_EMS_AB_HAS_FULL_REPLICA_NCS_O |
PR_EMS_AB_HAS_MASTER_NCS |
PR_EMS_AB_HAS_MASTER_NCS_O |
PR_EMS_AB_HELP_DATA16 |
PR_EMS_AB_HELP_DATA32 |
PR_EMS_AB_HELP_FILE_NAME |
PR_EMS_AB_HELP_FILE_NAME_A |
PR_EMS_AB_HELP_FILE_NAME_W |
PR_EMS_AB_HEURISTICS |
PR_EMS_AB_HIDE_DL_MEMBERSHIP |
PR_EMS_AB_HIDE_FROM_ADDRESS_BOOK |
PR_EMS_AB_HIERARCHY_PATH |
PR_EMS_AB_HIERARCHY_PATH_A |
PR_EMS_AB_HIERARCHY_PATH_W |
PR_EMS_AB_HOME_MDB |
PR_EMS_AB_HOME_MDB_A |
PR_EMS_AB_HOME_MDB_BL |
PR_EMS_AB_HOME_MDB_BL_O |
PR_EMS_AB_HOME_MDB_O |
PR_EMS_AB_HOME_MDB_W |
PR_EMS_AB_HOME_MTA |
PR_EMS_AB_HOME_MTA_A |
PR_EMS_AB_HOME_MTA_O |
PR_EMS_AB_HOME_MTA_W |
PR_EMS_AB_HOME_PUBLIC_SERVER |
PR_EMS_AB_HOME_PUBLIC_SERVER_A |
PR_EMS_AB_HOME_PUBLIC_SERVER_O |
PR_EMS_AB_HOME_PUBLIC_SERVER_W |
PR_EMS_AB_HOUSE_IDENTIFIER |
PR_EMS_AB_HOUSE_IDENTIFIER_A |
PR_EMS_AB_HOUSE_IDENTIFIER_W |
PR_EMS_AB_HTTP_PUB_AB_ATTRIBUTES |
PR_EMS_AB_HTTP_PUB_GAL |
PR_EMS_AB_HTTP_PUB_GAL_LIMIT |
PR_EMS_AB_HTTP_PUB_PF |
PR_EMS_AB_HTTP_SERVERS |
PR_EMS_AB_IMPORT_CONTAINER |
PR_EMS_AB_IMPORT_CONTAINER_A |
PR_EMS_AB_IMPORT_CONTAINER_O |
PR_EMS_AB_IMPORT_CONTAINER_W |
PR_EMS_AB_IMPORT_SENSITIVITY |
PR_EMS_AB_IMPORTED_FROM |
PR_EMS_AB_IMPORTED_FROM_A |
PR_EMS_AB_IMPORTED_FROM_W |
PR_EMS_AB_INBOUND_ACCEPT_ALL |
PR_EMS_AB_INBOUND_DN |
PR_EMS_AB_INBOUND_DN_A |
PR_EMS_AB_INBOUND_DN_O |
PR_EMS_AB_INBOUND_DN_W |
PR_EMS_AB_INBOUND_HOST |
PR_EMS_AB_INBOUND_NEWSFEED |
PR_EMS_AB_INBOUND_NEWSFEED_A |
PR_EMS_AB_INBOUND_NEWSFEED_TYPE |
PR_EMS_AB_INBOUND_NEWSFEED_W |
PR_EMS_AB_INBOUND_SITES |
PR_EMS_AB_INBOUND_SITES_O |
PR_EMS_AB_INCOMING_MSG_SIZE_LIMIT |
PR_EMS_AB_INCOMING_PASSWORD |
PR_EMS_AB_INSADMIN |
PR_EMS_AB_INSADMIN_A |
PR_EMS_AB_INSADMIN_O |
PR_EMS_AB_INSADMIN_W |
PR_EMS_AB_INSTANCE_TYPE |
PR_EMS_AB_INTERNATIONAL_ISDN_NUMBER |
PR_EMS_AB_INVOCATION_ID |
PR_EMS_AB_IS_DELETED |
PR_EMS_AB_IS_MASTER |
PR_EMS_AB_IS_MEMBER_OF_DL |
PR_EMS_AB_IS_MEMBER_OF_DL_T |
PR_EMS_AB_IS_MEMBER_OF_DL_T_A |
PR_EMS_AB_IS_MEMBER_OF_DL_T_W |
PR_EMS_AB_IS_SINGLE_VALUED |
PR_EMS_AB_KCC_STATUS |
PR_EMS_AB_KM_SERVER |
PR_EMS_AB_KM_SERVER_A |
PR_EMS_AB_KM_SERVER_O |
PR_EMS_AB_KM_SERVER_W |
PR_EMS_AB_KNOWLEDGE_INFORMATION |
PR_EMS_AB_LABELEDURI |
PR_EMS_AB_LABELEDURI_A |
PR_EMS_AB_LABELEDURI_W |
PR_EMS_AB_LANGUAGE |
PR_EMS_AB_LANGUAGE_ISO639 |
PR_EMS_AB_LANGUAGE_ISO639_A |
PR_EMS_AB_LANGUAGE_ISO639_W |
PR_EMS_AB_LDAP_DISPLAY_NAME |
PR_EMS_AB_LDAP_SEARCH_CFG |
PR_EMS_AB_LINE_WRAP |
PR_EMS_AB_LINK_ID |
PR_EMS_AB_LIST_PUBLIC_FOLDERS |
PR_EMS_AB_LOCAL_BRIDGE_HEAD |
PR_EMS_AB_LOCAL_BRIDGE_HEAD_A |
PR_EMS_AB_LOCAL_BRIDGE_HEAD_ADDRESS |
PR_EMS_AB_LOCAL_BRIDGE_HEAD_ADDRESS_A |
PR_EMS_AB_LOCAL_BRIDGE_HEAD_ADDRESS_W |
PR_EMS_AB_LOCAL_BRIDGE_HEAD_W |
PR_EMS_AB_LOCAL_INITIAL_TURN |
PR_EMS_AB_LOCAL_SCOPE |
PR_EMS_AB_LOCAL_SCOPE_O |
PR_EMS_AB_LOG_FILENAME |
PR_EMS_AB_LOG_FILENAME_A |
PR_EMS_AB_LOG_FILENAME_W |
PR_EMS_AB_LOG_ROLLOVER_INTERVAL |
PR_EMS_AB_MAIL_DROP |
PR_EMS_AB_MAIL_DROP_A |
PR_EMS_AB_MAIL_DROP_W |
PR_EMS_AB_MAINTAIN_AUTOREPLY_HISTORY |
PR_EMS_AB_MANAGER |
PR_EMS_AB_MANAGER_T |
PR_EMS_AB_MANAGER_T_A |
PR_EMS_AB_MANAGER_T_W |
PR_EMS_AB_MAPI_DISPLAY_TYPE |
PR_EMS_AB_MAPI_ID |
PR_EMS_AB_MAXIMUM_OBJECT_ID |
PR_EMS_AB_MDB_BACKOFF_INTERVAL |
PR_EMS_AB_MDB_MSG_TIME_OUT_PERIOD |
PR_EMS_AB_MDB_OVER_QUOTA_LIMIT |
PR_EMS_AB_MDB_STORAGE_QUOTA |
PR_EMS_AB_MDB_UNREAD_LIMIT |
PR_EMS_AB_MDB_USE_DEFAULTS |
PR_EMS_AB_MEMBER |
PR_EMS_AB_MEMBER_T |
PR_EMS_AB_MEMBER_T_A |
PR_EMS_AB_MEMBER_T_W |
PR_EMS_AB_MESSAGE_TRACKING_ENABLED |
PR_EMS_AB_MIME_TYPES |
PR_EMS_AB_MODERATED |
PR_EMS_AB_MODERATOR |
PR_EMS_AB_MODERATOR_A |
PR_EMS_AB_MODERATOR_W |
PR_EMS_AB_MONITOR_CLOCK |
PR_EMS_AB_MONITOR_SERVERS |
PR_EMS_AB_MONITOR_SERVICES |
PR_EMS_AB_MONITORED_CONFIGURATIONS |
PR_EMS_AB_MONITORED_CONFIGURATIONS_O |
PR_EMS_AB_MONITORED_SERVERS |
PR_EMS_AB_MONITORED_SERVERS_O |
PR_EMS_AB_MONITORED_SERVICES |
PR_EMS_AB_MONITORING_ALERT_DELAY |
PR_EMS_AB_MONITORING_ALERT_UNITS |
PR_EMS_AB_MONITORING_AVAILABILITY_STYLE |
PR_EMS_AB_MONITORING_AVAILABILITY_WINDOW |
PR_EMS_AB_MONITORING_CACHED_VIA_MAIL |
PR_EMS_AB_MONITORING_CACHED_VIA_MAIL_O |
PR_EMS_AB_MONITORING_CACHED_VIA_RPC |
PR_EMS_AB_MONITORING_CACHED_VIA_RPC_O |
PR_EMS_AB_MONITORING_ESCALATION_PROCEDURE |
PR_EMS_AB_MONITORING_HOTSITE_POLL_INTERVAL |
PR_EMS_AB_MONITORING_HOTSITE_POLL_UNITS |
PR_EMS_AB_MONITORING_MAIL_UPDATE_INTERVAL |
PR_EMS_AB_MONITORING_MAIL_UPDATE_UNITS |
PR_EMS_AB_MONITORING_NORMAL_POLL_INTERVAL |
PR_EMS_AB_MONITORING_NORMAL_POLL_UNITS |
PR_EMS_AB_MONITORING_RECIPIENTS |
PR_EMS_AB_MONITORING_RECIPIENTS_NDR |
PR_EMS_AB_MONITORING_RECIPIENTS_NDR_O |
PR_EMS_AB_MONITORING_RECIPIENTS_O |
PR_EMS_AB_MONITORING_RPC_UPDATE_INTERVAL |
PR_EMS_AB_MONITORING_RPC_UPDATE_UNITS |
PR_EMS_AB_MONITORING_WARNING_DELAY |
PR_EMS_AB_MONITORING_WARNING_UNITS |
PR_EMS_AB_MTA_LOCAL_CRED |
PR_EMS_AB_MTA_LOCAL_CRED_A |
PR_EMS_AB_MTA_LOCAL_CRED_W |
PR_EMS_AB_MTA_LOCAL_DESIG |
PR_EMS_AB_MTA_LOCAL_DESIG_A |
PR_EMS_AB_MTA_LOCAL_DESIG_W |
PR_EMS_AB_N_ADDRESS |
PR_EMS_AB_N_ADDRESS_TYPE |
PR_EMS_AB_NETWORK_ADDRESS |
PR_EMS_AB_NEWSFEED_TYPE |
PR_EMS_AB_NEWSGROUP |
PR_EMS_AB_NEWSGROUP_A |
PR_EMS_AB_NEWSGROUP_LIST |
PR_EMS_AB_NEWSGROUP_W |
PR_EMS_AB_NNTP_CHARACTER_SET |
PR_EMS_AB_NNTP_CHARACTER_SET_A |
PR_EMS_AB_NNTP_CHARACTER_SET_W |
PR_EMS_AB_NNTP_CONTENT_FORMAT |
PR_EMS_AB_NNTP_CONTENT_FORMAT_A |
PR_EMS_AB_NNTP_CONTENT_FORMAT_W |
PR_EMS_AB_NNTP_DISTRIBUTIONS |
PR_EMS_AB_NNTP_DISTRIBUTIONS_FLAG |
PR_EMS_AB_NNTP_NEWSFEEDS |
PR_EMS_AB_NNTP_NEWSFEEDS_O |
PR_EMS_AB_NT_MACHINE_NAME |
PR_EMS_AB_NT_MACHINE_NAME_A |
PR_EMS_AB_NT_MACHINE_NAME_W |
PR_EMS_AB_NT_SECURITY_DESCRIPTOR |
PR_EMS_AB_NUM_OF_OPEN_RETRIES |
PR_EMS_AB_NUM_OF_TRANSFER_RETRIES |
PR_EMS_AB_OBJ_DIST_NAME |
PR_EMS_AB_OBJ_DIST_NAME_A |
PR_EMS_AB_OBJ_DIST_NAME_O |
PR_EMS_AB_OBJ_DIST_NAME_W |
PR_EMS_AB_OBJ_VIEW_CONTAINERS |
PR_EMS_AB_OBJ_VIEW_CONTAINERS_O |
PR_EMS_AB_OBJECT_CLASS_CATEGORY |
PR_EMS_AB_OBJECT_OID |
PR_EMS_AB_OBJECT_VERSION |
PR_EMS_AB_OFF_LINE_AB_CONTAINERS |
PR_EMS_AB_OFF_LINE_AB_CONTAINERS_O |
PR_EMS_AB_OFF_LINE_AB_SCHEDULE |
PR_EMS_AB_OFF_LINE_AB_SERVER |
PR_EMS_AB_OFF_LINE_AB_SERVER_A |
PR_EMS_AB_OFF_LINE_AB_SERVER_O |
PR_EMS_AB_OFF_LINE_AB_SERVER_W |
PR_EMS_AB_OFF_LINE_AB_STYLE |
PR_EMS_AB_OID_TYPE |
PR_EMS_AB_OM_OBJECT_CLASS |
PR_EMS_AB_OM_SYNTAX |
PR_EMS_AB_OOF_REPLY_TO_ORIGINATOR |
PR_EMS_AB_OPEN_RETRY_INTERVAL |
PR_EMS_AB_ORGANIZATION_NAME |
PR_EMS_AB_ORGANIZATIONAL_UNIT_NAME |
PR_EMS_AB_ORIGINAL_DISPLAY_TABLE |
PR_EMS_AB_ORIGINAL_DISPLAY_TABLE_MSDOS |
PR_EMS_AB_OTHER_RECIPS |
PR_EMS_AB_OUTBOUND_HOST |
PR_EMS_AB_OUTBOUND_HOST_TYPE |
PR_EMS_AB_OUTBOUND_NEWSFEED |
PR_EMS_AB_OUTBOUND_NEWSFEED_A |
PR_EMS_AB_OUTBOUND_NEWSFEED_W |
PR_EMS_AB_OUTBOUND_SITES |
PR_EMS_AB_OUTBOUND_SITES_O |
PR_EMS_AB_OUTGOING_MSG_SIZE_LIMIT |
PR_EMS_AB_OVERRIDE_NNTP_CONTENT_FORMAT |
PR_EMS_AB_OWA_SERVER |
PR_EMS_AB_OWA_SERVER_A |
PR_EMS_AB_OWA_SERVER_W |
PR_EMS_AB_OWNER |
PR_EMS_AB_OWNER_A |
PR_EMS_AB_OWNER_BL |
PR_EMS_AB_OWNER_BL_O |
PR_EMS_AB_OWNER_O |
PR_EMS_AB_OWNER_W |
PR_EMS_AB_P_SELECTOR |
PR_EMS_AB_P_SELECTOR_INBOUND |
PR_EMS_AB_PARENT_ENTRYID |
PR_EMS_AB_PER_MSG_DIALOG_DISPLAY_TABLE |
PR_EMS_AB_PER_RECIP_DIALOG_DISPLAY_TABLE |
PR_EMS_AB_PERIOD_REP_SYNC_TIMES |
PR_EMS_AB_PERIOD_REPL_STAGGER |
PR_EMS_AB_PERSONAL_TITLE |
PR_EMS_AB_PERSONAL_TITLE_A |
PR_EMS_AB_PERSONAL_TITLE_W |
PR_EMS_AB_PF_CONTACTS |
PR_EMS_AB_PF_CONTACTS_O |
PR_EMS_AB_POP_CHARACTER_SET |
PR_EMS_AB_POP_CHARACTER_SET_A |
PR_EMS_AB_POP_CHARACTER_SET_W |
PR_EMS_AB_POP_CONTENT_FORMAT |
PR_EMS_AB_POP_CONTENT_FORMAT_A |
PR_EMS_AB_POP_CONTENT_FORMAT_W |
PR_EMS_AB_PORT_NUMBER |
PR_EMS_AB_POSTAL_ADDRESS |
PR_EMS_AB_PREFERRED_DELIVERY_METHOD |
PR_EMS_AB_PRESERVE_INTERNET_CONTENT |
PR_EMS_AB_PRMD |
PR_EMS_AB_PRMD_A |
PR_EMS_AB_PRMD_W |
PR_EMS_AB_PROMO_EXPIRATION |
PR_EMS_AB_PROTOCOL_SETTINGS |
PR_EMS_AB_PROXY_ADDRESSES |
PR_EMS_AB_PROXY_GENERATION_ENABLED |
PR_EMS_AB_PROXY_GENERATOR_DLL |
PR_EMS_AB_PROXY_GENERATOR_DLL_A |
PR_EMS_AB_PROXY_GENERATOR_DLL_W |
PR_EMS_AB_PUBLIC_DELEGATES |
PR_EMS_AB_PUBLIC_DELEGATES_BL |
PR_EMS_AB_PUBLIC_DELEGATES_BL_O |
PR_EMS_AB_PUBLIC_DELEGATES_T |
PR_EMS_AB_PUBLIC_DELEGATES_T_A |
PR_EMS_AB_PUBLIC_DELEGATES_T_W |
PR_EMS_AB_QUOTA_NOTIFICATION_SCHEDULE |
PR_EMS_AB_QUOTA_NOTIFICATION_STYLE |
PR_EMS_AB_RANGE_LOWER |
PR_EMS_AB_RANGE_UPPER |
PR_EMS_AB_RAS_ACCOUNT |
PR_EMS_AB_RAS_ACCOUNT_A |
PR_EMS_AB_RAS_ACCOUNT_W |
PR_EMS_AB_RAS_CALLBACK_NUMBER |
PR_EMS_AB_RAS_CALLBACK_NUMBER_A |
PR_EMS_AB_RAS_CALLBACK_NUMBER_W |
PR_EMS_AB_RAS_PASSWORD |
PR_EMS_AB_RAS_PHONE_NUMBER |
PR_EMS_AB_RAS_PHONE_NUMBER_A |
PR_EMS_AB_RAS_PHONE_NUMBER_W |
PR_EMS_AB_RAS_PHONEBOOK_ENTRY_NAME |
PR_EMS_AB_RAS_PHONEBOOK_ENTRY_NAME_A |
PR_EMS_AB_RAS_PHONEBOOK_ENTRY_NAME_W |
PR_EMS_AB_RAS_REMOTE_SRVR_NAME |
PR_EMS_AB_RAS_REMOTE_SRVR_NAME_A |
PR_EMS_AB_RAS_REMOTE_SRVR_NAME_W |
PR_EMS_AB_REFERRAL_LIST |
PR_EMS_AB_REGISTERED_ADDRESS |
PR_EMS_AB_REMOTE_BRIDGE_HEAD |
PR_EMS_AB_REMOTE_BRIDGE_HEAD_A |
PR_EMS_AB_REMOTE_BRIDGE_HEAD_ADDRESS |
PR_EMS_AB_REMOTE_BRIDGE_HEAD_ADDRESS_A |
PR_EMS_AB_REMOTE_BRIDGE_HEAD_ADDRESS_W |
PR_EMS_AB_REMOTE_BRIDGE_HEAD_W |
PR_EMS_AB_REMOTE_OUT_BH_SERVER |
PR_EMS_AB_REMOTE_OUT_BH_SERVER_A |
PR_EMS_AB_REMOTE_OUT_BH_SERVER_O |
PR_EMS_AB_REMOTE_OUT_BH_SERVER_W |
PR_EMS_AB_REMOTE_SITE |
PR_EMS_AB_REMOTE_SITE_A |
PR_EMS_AB_REMOTE_SITE_O |
PR_EMS_AB_REMOTE_SITE_W |
PR_EMS_AB_REPLICATED_OBJECT_VERSION |
PR_EMS_AB_REPLICATION_MAIL_MSG_SIZE |
PR_EMS_AB_REPLICATION_SENSITIVITY |
PR_EMS_AB_REPLICATION_STAGGER |
PR_EMS_AB_REPORT_TO_ORIGINATOR |
PR_EMS_AB_REPORT_TO_OWNER |
PR_EMS_AB_REPORTS |
PR_EMS_AB_REPORTS_T |
PR_EMS_AB_REQ_SEQ |
PR_EMS_AB_REQUIRE_SSL |
PR_EMS_AB_RESPONSIBLE_LOCAL_DXA |
PR_EMS_AB_RESPONSIBLE_LOCAL_DXA_A |
PR_EMS_AB_RESPONSIBLE_LOCAL_DXA_O |
PR_EMS_AB_RESPONSIBLE_LOCAL_DXA_W |
PR_EMS_AB_RETURN_EXACT_MSG_SIZE |
PR_EMS_AB_RID_SERVER |
PR_EMS_AB_RID_SERVER_A |
PR_EMS_AB_RID_SERVER_O |
PR_EMS_AB_RID_SERVER_W |
PR_EMS_AB_ROLE_OCCUPANT |
PR_EMS_AB_ROLE_OCCUPANT_O |
PR_EMS_AB_ROOT_NEWSGROUPS_FOLDER_ID |
PR_EMS_AB_ROUTING_LIST |
PR_EMS_AB_RTS_CHECKPOINT_SIZE |
PR_EMS_AB_RTS_RECOVERY_TIMEOUT |
PR_EMS_AB_RTS_WINDOW_SIZE |
PR_EMS_AB_RUNS_ON |
PR_EMS_AB_RUNS_ON_O |
PR_EMS_AB_S_SELECTOR |
PR_EMS_AB_S_SELECTOR_INBOUND |
PR_EMS_AB_SCHEMA_FLAGS |
PR_EMS_AB_SCHEMA_VERSION |
PR_EMS_AB_SEARCH_FLAGS |
PR_EMS_AB_SEARCH_GUIDE |
PR_EMS_AB_SECURITY_POLICY |
PR_EMS_AB_SECURITY_PROTOCOL |
PR_EMS_AB_SEE_ALSO |
PR_EMS_AB_SEE_ALSO_O |
PR_EMS_AB_SEND_EMAIL_MESSAGE |
PR_EMS_AB_SEND_TNEF |
PR_EMS_AB_SERIAL_NUMBER |
PR_EMS_AB_SERVER |
PR_EMS_AB_SERVER_A |
PR_EMS_AB_SERVER_W |
PR_EMS_AB_SERVICE_ACTION_FIRST |
PR_EMS_AB_SERVICE_ACTION_OTHER |
PR_EMS_AB_SERVICE_ACTION_SECOND |
PR_EMS_AB_SERVICE_RESTART_DELAY |
PR_EMS_AB_SERVICE_RESTART_MESSAGE |
PR_EMS_AB_SERVICE_RESTART_MESSAGE_A |
PR_EMS_AB_SERVICE_RESTART_MESSAGE_W |
PR_EMS_AB_SESSION_DISCONNECT_TIMER |
PR_EMS_AB_SITE_AFFINITY |
PR_EMS_AB_SITE_FOLDER_GUID |
PR_EMS_AB_SITE_FOLDER_SERVER |
PR_EMS_AB_SITE_FOLDER_SERVER_A |
PR_EMS_AB_SITE_FOLDER_SERVER_O |
PR_EMS_AB_SITE_FOLDER_SERVER_W |
PR_EMS_AB_SITE_PROXY_SPACE |
PR_EMS_AB_SMIME_ALG_LIST_NA |
PR_EMS_AB_SMIME_ALG_LIST_OTHER |
PR_EMS_AB_SMIME_ALG_SELECTED_NA |
PR_EMS_AB_SMIME_ALG_SELECTED_NA_A |
PR_EMS_AB_SMIME_ALG_SELECTED_NA_W |
PR_EMS_AB_SMIME_ALG_SELECTED_OTHER |
PR_EMS_AB_SMIME_ALG_SELECTED_OTHER_A |
PR_EMS_AB_SMIME_ALG_SELECTED_OTHER_W |
PR_EMS_AB_SPACE_LAST_COMPUTED |
PR_EMS_AB_STREET_ADDRESS |
PR_EMS_AB_STREET_ADDRESS_A |
PR_EMS_AB_STREET_ADDRESS_W |
PR_EMS_AB_SUB_REFS |
PR_EMS_AB_SUB_REFS_O |
PR_EMS_AB_SUB_SITE |
PR_EMS_AB_SUB_SITE_A |
PR_EMS_AB_SUB_SITE_W |
PR_EMS_AB_SUBMISSION_CONT_LENGTH |
PR_EMS_AB_SUPPORT_SMIME_SIGNATURES |
PR_EMS_AB_SUPPORTED_ALGORITHMS |
PR_EMS_AB_SUPPORTED_APPLICATION_CONTEXT |
PR_EMS_AB_SUPPORTING_STACK |
PR_EMS_AB_SUPPORTING_STACK_BL |
PR_EMS_AB_SUPPORTING_STACK_BL_O |
PR_EMS_AB_SUPPORTING_STACK_O |
PR_EMS_AB_T_SELECTOR |
PR_EMS_AB_T_SELECTOR_INBOUND |
PR_EMS_AB_TAGGED_X509_CERT |
PR_EMS_AB_TARGET_ADDRESS |
PR_EMS_AB_TARGET_ADDRESS_A |
PR_EMS_AB_TARGET_ADDRESS_W |
PR_EMS_AB_TARGET_MTAS |
PR_EMS_AB_TELEPHONE_NUMBER |
PR_EMS_AB_TELEPHONE_PERSONAL_PAGER |
PR_EMS_AB_TELEPHONE_PERSONAL_PAGER_A |
PR_EMS_AB_TELEPHONE_PERSONAL_PAGER_W |
PR_EMS_AB_TELETEX_TERMINAL_IDENTIFIER |
PR_EMS_AB_TEMP_ASSOC_THRESHOLD |
PR_EMS_AB_TOMBSTONE_LIFETIME |
PR_EMS_AB_TRACKING_LOG_PATH_NAME |
PR_EMS_AB_TRACKING_LOG_PATH_NAME_A |
PR_EMS_AB_TRACKING_LOG_PATH_NAME_W |
PR_EMS_AB_TRANS_RETRY_MINS |
PR_EMS_AB_TRANS_TIMEOUT_MINS |
PR_EMS_AB_TRANSFER_RETRY_INTERVAL |
PR_EMS_AB_TRANSFER_TIMEOUT_NON_URGENT |
PR_EMS_AB_TRANSFER_TIMEOUT_NORMAL |
PR_EMS_AB_TRANSFER_TIMEOUT_URGENT |
PR_EMS_AB_TRANSLATION_TABLE_USED |
PR_EMS_AB_TRANSPORT_EXPEDITED_DATA |
PR_EMS_AB_TRUST_LEVEL |
PR_EMS_AB_TURN_REQUEST_THRESHOLD |
PR_EMS_AB_TWO_WAY_ALTERNATE_FACILITY |
PR_EMS_AB_TYPE |
PR_EMS_AB_TYPE_A |
PR_EMS_AB_TYPE_W |
PR_EMS_AB_UNAUTH_ORIG_BL |
PR_EMS_AB_UNAUTH_ORIG_BL_O |
PR_EMS_AB_USE_SERVER_VALUES |
PR_EMS_AB_USE_SITE_VALUES |
PR_EMS_AB_USENET_SITE_NAME |
PR_EMS_AB_USENET_SITE_NAME_A |
PR_EMS_AB_USENET_SITE_NAME_W |
PR_EMS_AB_USER_PASSWORD |
PR_EMS_AB_USN_CHANGED |
PR_EMS_AB_USN_CREATED |
PR_EMS_AB_USN_DSA_LAST_OBJ_REMOVED |
PR_EMS_AB_USN_INTERSITE |
PR_EMS_AB_USN_LAST_OBJ_REM |
PR_EMS_AB_USN_SOURCE |
PR_EMS_AB_VIEW_CONTAINER_1 |
PR_EMS_AB_VIEW_CONTAINER_1_A |
PR_EMS_AB_VIEW_CONTAINER_1_W |
PR_EMS_AB_VIEW_CONTAINER_2 |
PR_EMS_AB_VIEW_CONTAINER_2_A |
PR_EMS_AB_VIEW_CONTAINER_2_W |
PR_EMS_AB_VIEW_CONTAINER_3 |
PR_EMS_AB_VIEW_CONTAINER_3_A |
PR_EMS_AB_VIEW_CONTAINER_3_W |
PR_EMS_AB_VIEW_DEFINITION |
PR_EMS_AB_VIEW_FLAGS |
PR_EMS_AB_VIEW_SITE |
PR_EMS_AB_VIEW_SITE_A |
PR_EMS_AB_VIEW_SITE_W |
PR_EMS_AB_VOICE_MAIL_FLAGS |
PR_EMS_AB_VOICE_MAIL_GREETINGS |
PR_EMS_AB_VOICE_MAIL_PASSWORD |
PR_EMS_AB_VOICE_MAIL_PASSWORD_A |
PR_EMS_AB_VOICE_MAIL_PASSWORD_W |
PR_EMS_AB_VOICE_MAIL_RECORDED_NAME |
PR_EMS_AB_VOICE_MAIL_RECORDING_LENGTH |
PR_EMS_AB_VOICE_MAIL_SPEED |
PR_EMS_AB_VOICE_MAIL_SYSTEM_GUID |
PR_EMS_AB_VOICE_MAIL_USER_ID |
PR_EMS_AB_VOICE_MAIL_USER_ID_A |
PR_EMS_AB_VOICE_MAIL_USER_ID_W |
PR_EMS_AB_VOICE_MAIL_VOLUME |
PR_EMS_AB_WWW_HOME_PAGE |
PR_EMS_AB_WWW_HOME_PAGE_A |
PR_EMS_AB_WWW_HOME_PAGE_W |
PR_EMS_AB_X121_ADDRESS |
PR_EMS_AB_X25_CALL_USER_DATA_INCOMING |
PR_EMS_AB_X25_CALL_USER_DATA_OUTGOING |
PR_EMS_AB_X25_FACILITIES_DATA_INCOMING |
PR_EMS_AB_X25_FACILITIES_DATA_OUTGOING |
PR_EMS_AB_X25_LEASED_LINE_PORT |
PR_EMS_AB_X25_LEASED_OR_SWITCHED |
PR_EMS_AB_X25_REMOTE_MTA_PHONE |
PR_EMS_AB_X25_REMOTE_MTA_PHONE_A |
PR_EMS_AB_X25_REMOTE_MTA_PHONE_W |
PR_EMS_AB_X400_ATTACHMENT_TYPE |
PR_EMS_AB_X400_SELECTOR_SYNTAX |
PR_EMS_AB_X500_ACCESS_CONTROL_LIST |
PR_EMS_AB_X500_NC |
PR_EMS_AB_X500_NC_A |
PR_EMS_AB_X500_NC_W |
PR_EMS_AB_X500_RDN |
PR_EMS_AB_X500_RDN_A |
PR_EMS_AB_X500_RDN_W |
PR_EMS_AB_XMIT_TIMEOUT_NON_URGENT |
PR_EMS_AB_XMIT_TIMEOUT_NORMAL |
PR_EMS_AB_XMIT_TIMEOUT_URGENT |
PR_END_DATE |
PR_ENTRYID |
PR_EVENTS_ROOT_FOLDER_ENTRYID |
PR_EXCESS_STORAGE_USED |
PR_EXPIRY_NUMBER |
PR_EXPIRY_TIME |
PR_EXPIRY_UNITS |
PR_EXPLICIT_CONVERSION |
PR_EXTENDED_ACL_DATA |
PR_FAST_TRANSFER |
PR_FAVORITES_DEFAULT_NAME |
PR_FAVORITES_DEFAULT_NAME_A |
PR_FAVORITES_DEFAULT_NAME_W |
PR_FILTERING_HOOKS |
PR_FINDER_ENTRYID |
PR_FLAG_COMPLETE_TIME | Specifies the date and time in Coordinated Universal Time (UTC) that the message object was flagged as completed.
PR_FLAG_ICON | Specifies the flag icon of the message object.
PR_FLAG_STATUS | Specifies the flag state of the message object.
PR_FOLDER_ASSOCIATED_CONTENTS |
PR_FOLDER_CHILD_COUNT |
PR_FOLDER_DESIGN_FLAGS |
PR_FOLDER_FLAGS |
PR_FOLDER_PATHNAME |
PR_FOLDER_PATHNAME_A |
PR_FOLDER_PATHNAME_W |
PR_FOLDER_TYPE |
PR_FOREIGN_ID |
PR_FOREIGN_REPORT_ID |
PR_FOREIGN_SUBJECT_ID |
PR_FORM_CATEGORY |
PR_FORM_CATEGORY_A |
PR_FORM_CATEGORY_SUB |
PR_FORM_CATEGORY_SUB_A |
PR_FORM_CATEGORY_SUB_W |
PR_FORM_CATEGORY_W |
PR_FORM_CLSID |
PR_FORM_CONTACT_NAME |
PR_FORM_CONTACT_NAME_A |
PR_FORM_CONTACT_NAME_W |
PR_FORM_DESIGNER_GUID |
PR_FORM_DESIGNER_NAME |
PR_FORM_DESIGNER_NAME_A |
PR_FORM_DESIGNER_NAME_W |
PR_FORM_HIDDEN |
PR_FORM_HOST_MAP |
PR_FORM_MESSAGE_BEHAVIOR |
PR_FORM_VERSION |
PR_FORM_VERSION_A |
PR_FORM_VERSION_W |
PR_FREE_BUSY_FOR_LOCAL_SITE_ENTRYID |
PR_FTP_SITE |
PR_FTP_SITE_A |
PR_FTP_SITE_W |
PR_GENDER |
PR_GENERATION |
PR_GENERATION_A |
PR_GENERATION_W |
PR_GIVEN_NAME |
PR_GIVEN_NAME_A |
PR_GIVEN_NAME_W |
PR_GOVERNMENT_ID_NUMBER |
PR_GOVERNMENT_ID_NUMBER_A |
PR_GOVERNMENT_ID_NUMBER_W |
PR_GW_ADMIN_OPERATIONS |
PR_GW_MTSIN_ENTRYID |
PR_GW_MTSOUT_ENTRYID |
PR_HAS_DAMS |
PR_HAS_MODERATOR_RULES |
PR_HAS_NAMED_PROPERTIES |
PR_HAS_RULES |
PR_HASATTACH |
PR_HEADER_FOLDER_ENTRYID |
PR_HIERARCHY_CHANGE_NUM |
PR_HIERARCHY_SERVER |
PR_HIERARCHY_SERVER_A |
PR_HIERARCHY_SERVER_W |
PR_HIERARCHY_SYNCHRONIZER |
PR_HOBBIES |
PR_HOBBIES_A |
PR_HOBBIES_W |
PR_HOME_ADDRESS_CITY |
PR_HOME_ADDRESS_CITY_A |
PR_HOME_ADDRESS_CITY_W |
PR_HOME_ADDRESS_COUNTRY |
PR_HOME_ADDRESS_COUNTRY_A |
PR_HOME_ADDRESS_COUNTRY_W |
PR_HOME_ADDRESS_POST_OFFICE_BOX |
PR_HOME_ADDRESS_POST_OFFICE_BOX_A |
PR_HOME_ADDRESS_POST_OFFICE_BOX_W |
PR_HOME_ADDRESS_POSTAL_CODE |
PR_HOME_ADDRESS_POSTAL_CODE_A |
PR_HOME_ADDRESS_POSTAL_CODE_W |
PR_HOME_ADDRESS_STATE_OR_PROVINCE |
PR_HOME_ADDRESS_STATE_OR_PROVINCE_A |
PR_HOME_ADDRESS_STATE_OR_PROVINCE_W |
PR_HOME_ADDRESS_STREET |
PR_HOME_ADDRESS_STREET_A |
PR_HOME_ADDRESS_STREET_W |
PR_HOME_FAX_NUMBER |
PR_HOME_FAX_NUMBER_A |
PR_HOME_FAX_NUMBER_W |
PR_HOME_TELEPHONE_NUMBER |
PR_HOME_TELEPHONE_NUMBER_A |
PR_HOME_TELEPHONE_NUMBER_W |
PR_HOME2_TELEPHONE_NUMBER |
PR_HOME2_TELEPHONE_NUMBER_A |
PR_HOME2_TELEPHONE_NUMBER_W |
PR_HTML |
PR_ICON |
PR_IDENTITY_DISPLAY |
PR_IDENTITY_DISPLAY_A |
PR_IDENTITY_DISPLAY_W |
PR_IDENTITY_ENTRYID |
PR_IDENTITY_SEARCH_KEY |
PR_IMAP_INTERNAL_DATE |
PR_IMPLICIT_CONVERSION_PROHIBITED |
PR_IMPORTANCE |
PR_IN_CONFLICT |
PR_IN_TRANSIT |
PR_INBOUND_NEWSFEED_DN |
PR_INBOUND_NEWSFEED_DN_A |
PR_INBOUND_NEWSFEED_DN_W |
PR_INCOMPLETE_COPY |
PR_INITIAL_DETAILS_PANE |
PR_INITIALS |
PR_INITIALS_A |
PR_INITIALS_W |
PR_INSTANCE_KEY |
PR_INTERNAL_TRACE_INFO |
PR_INTERNET_APPROVED |
PR_INTERNET_APPROVED_A |
PR_INTERNET_APPROVED_W |
PR_INTERNET_ARTICLE_NUMBER |
PR_INTERNET_CHARSET |
PR_INTERNET_CHARSET_A |
PR_INTERNET_CHARSET_W |
PR_INTERNET_CONTROL |
PR_INTERNET_CONTROL_A |
PR_INTERNET_CONTROL_W |
PR_INTERNET_CPID |
PR_INTERNET_DISTRIBUTION |
PR_INTERNET_DISTRIBUTION_A |
PR_INTERNET_DISTRIBUTION_W |
PR_INTERNET_FOLLOWUP_TO |
PR_INTERNET_FOLLOWUP_TO_A |
PR_INTERNET_FOLLOWUP_TO_W |
PR_INTERNET_LINES |
PR_INTERNET_MESSAGE_ID |
PR_INTERNET_MESSAGE_ID_A |
PR_INTERNET_MESSAGE_ID_W |
PR_INTERNET_NEWSGROUP_NAME |
PR_INTERNET_NEWSGROUP_NAME_A |
PR_INTERNET_NEWSGROUP_NAME_W |
PR_INTERNET_NEWSGROUPS |
PR_INTERNET_NEWSGROUPS_A |
PR_INTERNET_NEWSGROUPS_W |
PR_INTERNET_NNTP_PATH |
PR_INTERNET_NNTP_PATH_A |
PR_INTERNET_NNTP_PATH_W |
PR_INTERNET_ORGANIZATION |
PR_INTERNET_ORGANIZATION_A |
PR_INTERNET_ORGANIZATION_W |
PR_INTERNET_PRECEDENCE |
PR_INTERNET_PRECEDENCE_A |
PR_INTERNET_PRECEDENCE_W |
PR_INTERNET_REFERENCES |
PR_INTERNET_REFERENCES_A |
PR_INTERNET_REFERENCES_W |
PR_IPM_APPOINTMENT_ENTRYID | Contains the EntryID of the Outlook Calendar folder.
PR_IPM_CONTACT_ENTRYID | Contains the EntryID of the Outlook Contacts folder.
PR_IPM_DAF_ENTRYID |
PR_IPM_DRAFTS_ENTRYID | Contains the EntryID of the Outlook Drafts folder.
PR_IPM_FAVORITES_ENTRYID |
PR_IPM_ID |
PR_IPM_JOURNAL_ENTRYID | Contains the EntryID of the Outlook Journal folder.
PR_IPM_NOTE_ENTRYID | Contains the EntryID of the Outlook Notes folder.
PR_IPM_OUTBOX_ENTRYID |
PR_IPM_OUTBOX_SEARCH_KEY |
PR_IPM_PUBLIC_FOLDERS_ENTRYID |
PR_IPM_RETURN_REQUESTED |
PR_IPM_SENTMAIL_ENTRYID |
PR_IPM_SENTMAIL_SEARCH_KEY |
PR_IPM_SUBTREE_ENTRYID |
PR_IPM_SUBTREE_SEARCH_KEY |
PR_IPM_TASK_ENTRYID | Contains the EntryID of the Outlook Tasks folder.
PR_IPM_WASTEBASKET_ENTRYID |
PR_IPM_WASTEBASKET_SEARCH_KEY |
PR_IS_NEWSGROUP |
PR_IS_NEWSGROUP_ANCHOR |
PR_ISDN_NUMBER |
PR_ISDN_NUMBER_A |
PR_ISDN_NUMBER_W |
PR_KEYWORD |
PR_KEYWORD_A |
PR_KEYWORD_W |
PR_LANGUAGE |
PR_LANGUAGE_A |
PR_LANGUAGE_W |
PR_LANGUAGES |
PR_LANGUAGES_A |
PR_LANGUAGES_W |
PR_LAST_ACCESS_TIME |
PR_LAST_FULL_BACKUP |
PR_LAST_LOGOFF_TIME |
PR_LAST_LOGON_TIME |
PR_LAST_MODIFICATION_TIME |
PR_LAST_MODIFIER_ENTRYID |
PR_LAST_MODIFIER_NAME |
PR_LAST_MODIFIER_NAME_A |
PR_LAST_MODIFIER_NAME_W |
PR_LAST_VERB_EXECUTION_TIME | Contains the time when the last verb was executed.
PR_LATEST_DELIVERY_TIME |
PR_LOCALE_ID |
PR_LOCALITY |
PR_LOCALITY_A |
PR_LOCALITY_W |
PR_LOCATION |
PR_LOCATION_A |
PR_LOCATION_W |
PR_LONGTERM_ENTRYID_FROM_TABLE |
PR_LTP_ROW_ID | LTP Row ID.
PR_LTP_ROW_VER | LTP Row Ver.
PR_MAIL_PERMISSION |
PR_MAILBOX_OWNER_ENTRYID |
PR_MAILBOX_OWNER_NAME |
PR_MAILBOX_OWNER_NAME_A |
PR_MAILBOX_OWNER_NAME_W |
PR_MANAGER_NAME |
PR_MANAGER_NAME_A |
PR_MANAGER_NAME_W |
PR_MAPPING_SIGNATURE |
PR_MDB_PROVIDER |
PR_MEMBER_ENTRYID |
PR_MEMBER_ID |
PR_MEMBER_NAME |
PR_MEMBER_NAME_A |
PR_MEMBER_NAME_W |
PR_MEMBER_RIGHTS |
PR_MESSAGE_ATTACHMENTS |
PR_MESSAGE_CC_ME |
PR_MESSAGE_CLASS |
PR_MESSAGE_CLASS_A |
PR_MESSAGE_CLASS_W |
PR_MESSAGE_CODEPAGE |
PR_MESSAGE_DELIVERY_ID |
PR_MESSAGE_DELIVERY_TIME |
PR_MESSAGE_DOWNLOAD_TIME |
PR_MESSAGE_FLAGS |
PR_MESSAGE_LOCALE_ID |
PR_MESSAGE_PROCESSED |
PR_MESSAGE_RECIP_ME |
PR_MESSAGE_RECIPIENTS |
PR_MESSAGE_SECURITY_LABEL |
PR_MESSAGE_SITE_NAME |
PR_MESSAGE_SITE_NAME_A |
PR_MESSAGE_SITE_NAME_W |
PR_MESSAGE_SIZE |
PR_MESSAGE_SIZE_EXTENDED |
PR_MESSAGE_SUBMISSION_ID |
PR_MESSAGE_TO_ME |
PR_MESSAGE_TOKEN |
PR_MHS_COMMON_NAME |
PR_MHS_COMMON_NAME_A |
PR_MHS_COMMON_NAME_W |
PR_MIDDLE_NAME |
PR_MIDDLE_NAME_A |
PR_MIDDLE_NAME_W |
PR_MINI_ICON |
PR_MOBILE_TELEPHONE_NUMBER |
PR_MOBILE_TELEPHONE_NUMBER_A |
PR_MOBILE_TELEPHONE_NUMBER_W |
PR_MODIFY_VERSION |
PR_MOVE_TO_FOLDER_ENTRYID |
PR_MOVE_TO_STORE_ENTRYID |
PR_MSG_BODY_ID |
PR_MSG_STATUS |
PR_MTS_ID |
PR_MTS_REPORT_ID |
PR_MTS_SUBJECT_ID |
PR_NDR_DIAG_CODE |
PR_NDR_REASON_CODE |
PR_NEW_SUBS_GET_AUTO_ADD |
PR_NEWSFEED_INFO |
PR_NEWSGROUP_COMPONENT |
PR_NEWSGROUP_COMPONENT_A |
PR_NEWSGROUP_COMPONENT_W |
PR_NEWSGROUP_NAME |
PR_NEWSGROUP_NAME_A |
PR_NEWSGROUP_NAME_W |
PR_NEWSGROUP_ROOT_FOLDER_ENTRYID |
PR_NICKNAME |
PR_NICKNAME_A |
PR_NICKNAME_W |
PR_NNTP_ARTICLE_FOLDER_ENTRYID |
PR_NNTP_CONTROL_FOLDER_ENTRYID |
PR_NNTP_XREF |
PR_NNTP_XREF_A |
PR_NNTP_XREF_W |
PR_NON_IPM_SUBTREE_ENTRYID |
PR_NON_RECEIPT_NOTIFICATION_REQUESTED |
PR_NON_RECEIPT_REASON |
PR_NORMAL_MESSAGE_SIZE |
PR_NORMAL_MESSAGE_SIZE_EXTENDED |
PR_NORMAL_MSG_W_ATTACH_COUNT |
PR_NORMALIZED_SUBJECT |
PR_NORMALIZED_SUBJECT_A |
PR_NORMALIZED_SUBJECT_W |
PR_NT_USER_NAME |
PR_NT_USER_NAME_A |
PR_NT_USER_NAME_W |
PR_OBJECT_TYPE |
PR_OBSOLETED_IPMS |
PR_OFFICE_LOCATION |
PR_OFFICE_LOCATION_A |
PR_OFFICE_LOCATION_W |
PR_OFFICE_TELEPHONE_NUMBER |
PR_OFFICE_TELEPHONE_NUMBER_A |
PR_OFFICE_TELEPHONE_NUMBER_W |
PR_OFFICE2_TELEPHONE_NUMBER |
PR_OFFICE2_TELEPHONE_NUMBER_A |
PR_OFFICE2_TELEPHONE_NUMBER_W |
PR_OFFLINE_ADDRBOOK_ENTRYID |
PR_OFFLINE_FLAGS |
PR_OFFLINE_MESSAGE_ENTRYID |
PR_OLDEST_DELETED_ON |
PR_OOF_STATE |
PR_ORG_EMAIL_ADDR |
PR_ORG_EMAIL_ADDR_A |
PR_ORG_EMAIL_ADDR_W |
PR_ORGANIZATIONAL_ID_NUMBER |
PR_ORGANIZATIONAL_ID_NUMBER_A |
PR_ORGANIZATIONAL_ID_NUMBER_W |
PR_ORIG_MESSAGE_CLASS |
PR_ORIG_MESSAGE_CLASS_A |
PR_ORIG_MESSAGE_CLASS_W |
PR_ORIGIN_CHECK |
PR_ORIGINAL_AUTHOR_ADDRTYPE |
PR_ORIGINAL_AUTHOR_ADDRTYPE_A |
PR_ORIGINAL_AUTHOR_ADDRTYPE_W |
PR_ORIGINAL_AUTHOR_EMAIL_ADDRESS |
PR_ORIGINAL_AUTHOR_EMAIL_ADDRESS_A |
PR_ORIGINAL_AUTHOR_EMAIL_ADDRESS_W |
PR_ORIGINAL_AUTHOR_ENTRYID |
PR_ORIGINAL_AUTHOR_NAME |
PR_ORIGINAL_AUTHOR_NAME_A |
PR_ORIGINAL_AUTHOR_NAME_W |
PR_ORIGINAL_AUTHOR_SEARCH_KEY |
PR_ORIGINAL_DELIVERY_TIME |
PR_ORIGINAL_DISPLAY_BCC |
PR_ORIGINAL_DISPLAY_BCC_A |
PR_ORIGINAL_DISPLAY_BCC_W |
PR_ORIGINAL_DISPLAY_CC |
PR_ORIGINAL_DISPLAY_CC_A |
PR_ORIGINAL_DISPLAY_CC_W |
PR_ORIGINAL_DISPLAY_NAME |
PR_ORIGINAL_DISPLAY_NAME_A |
PR_ORIGINAL_DISPLAY_NAME_W |
PR_ORIGINAL_DISPLAY_TO |
PR_ORIGINAL_DISPLAY_TO_A |
PR_ORIGINAL_DISPLAY_TO_W |
PR_ORIGINAL_EITS |
PR_ORIGINAL_ENTRYID |
PR_ORIGINAL_SEARCH_KEY |
PR_ORIGINAL_SENDER_ADDRTYPE |
PR_ORIGINAL_SENDER_ADDRTYPE_A |
PR_ORIGINAL_SENDER_ADDRTYPE_W |
PR_ORIGINAL_SENDER_EMAIL_ADDRESS |
PR_ORIGINAL_SENDER_EMAIL_ADDRESS_A |
PR_ORIGINAL_SENDER_EMAIL_ADDRESS_W |
PR_ORIGINAL_SENDER_ENTRYID |
PR_ORIGINAL_SENDER_NAME |
PR_ORIGINAL_SENDER_NAME_A |
PR_ORIGINAL_SENDER_NAME_W |
PR_ORIGINAL_SENDER_SEARCH_KEY |
PR_ORIGINAL_SENSITIVITY |
PR_ORIGINAL_SENT_REPRESENTING_ADDRTYPE |
PR_ORIGINAL_SENT_REPRESENTING_ADDRTYPE_A |
PR_ORIGINAL_SENT_REPRESENTING_ADDRTYPE_W |
PR_ORIGINAL_SENT_REPRESENTING_EMAIL_ADDRESS |
PR_ORIGINAL_SENT_REPRESENTING_EMAIL_ADDRESS_A |
PR_ORIGINAL_SENT_REPRESENTING_EMAIL_ADDRESS_W |
PR_ORIGINAL_SENT_REPRESENTING_ENTRYID |
PR_ORIGINAL_SENT_REPRESENTING_NAME |
PR_ORIGINAL_SENT_REPRESENTING_NAME_A |
PR_ORIGINAL_SENT_REPRESENTING_NAME_W |
PR_ORIGINAL_SENT_REPRESENTING_SEARCH_KEY |
PR_ORIGINAL_SUBJECT |
PR_ORIGINAL_SUBJECT_A |
PR_ORIGINAL_SUBJECT_W |
PR_ORIGINAL_SUBMIT_TIME |
PR_ORIGINALLY_INTENDED_RECIP_ADDRTYPE |
PR_ORIGINALLY_INTENDED_RECIP_ADDRTYPE_A |
PR_ORIGINALLY_INTENDED_RECIP_ADDRTYPE_W |
PR_ORIGINALLY_INTENDED_RECIP_EMAIL_ADDRESS |
PR_ORIGINALLY_INTENDED_RECIP_EMAIL_ADDRESS_A |
PR_ORIGINALLY_INTENDED_RECIP_EMAIL_ADDRESS_W |
PR_ORIGINALLY_INTENDED_RECIP_ENTRYID |
PR_ORIGINALLY_INTENDED_RECIPIENT_NAME |
PR_ORIGINATING_MTA_CERTIFICATE |
PR_ORIGINATOR_ADDR |
PR_ORIGINATOR_ADDR_A |
PR_ORIGINATOR_ADDR_W |
PR_ORIGINATOR_ADDRTYPE |
PR_ORIGINATOR_ADDRTYPE_A |
PR_ORIGINATOR_ADDRTYPE_W |
PR_ORIGINATOR_AND_DL_EXPANSION_HISTORY |
PR_ORIGINATOR_CERTIFICATE |
PR_ORIGINATOR_DELIVERY_REPORT_REQUESTED |
PR_ORIGINATOR_ENTRYID |
PR_ORIGINATOR_NAME |
PR_ORIGINATOR_NAME_A |
PR_ORIGINATOR_NAME_W |
PR_ORIGINATOR_NON_DELIVERY_REPORT_REQUESTED |
PR_ORIGINATOR_REQUESTED_ALTERNATE_RECIPIENT |
PR_ORIGINATOR_RETURN_ADDRESS |
PR_OST_ENCRYPTION |
PR_OTHER_ADDRESS_CITY |
PR_OTHER_ADDRESS_CITY_A |
PR_OTHER_ADDRESS_CITY_W |
PR_OTHER_ADDRESS_COUNTRY |
PR_OTHER_ADDRESS_COUNTRY_A |
PR_OTHER_ADDRESS_COUNTRY_W |
PR_OTHER_ADDRESS_POST_OFFICE_BOX |
PR_OTHER_ADDRESS_POST_OFFICE_BOX_A |
PR_OTHER_ADDRESS_POST_OFFICE_BOX_W |
PR_OTHER_ADDRESS_POSTAL_CODE |
PR_OTHER_ADDRESS_POSTAL_CODE_A |
PR_OTHER_ADDRESS_POSTAL_CODE_W |
PR_OTHER_ADDRESS_STATE_OR_PROVINCE |
PR_OTHER_ADDRESS_STATE_OR_PROVINCE_A |
PR_OTHER_ADDRESS_STATE_OR_PROVINCE_W |
PR_OTHER_ADDRESS_STREET |
PR_OTHER_ADDRESS_STREET_A |
PR_OTHER_ADDRESS_STREET_W |
PR_OTHER_TELEPHONE_NUMBER |
PR_OTHER_TELEPHONE_NUMBER_A |
PR_OTHER_TELEPHONE_NUMBER_W |
PR_OUTBOUND_NEWSFEED_DN |
PR_OUTBOUND_NEWSFEED_DN_A |
PR_OUTBOUND_NEWSFEED_DN_W |
PR_OVERALL_AGE_LIMIT |
PR_OVERALL_MSG_AGE_LIMIT |
PR_OWA_URL |
PR_OWA_URL_A |
PR_OWA_URL_W |
PR_OWN_STORE_ENTRYID |
PR_OWNER_APPT_ID |
PR_OWNER_COUNT |
PR_P1_CONTENT |
PR_P1_CONTENT_TYPE |
PR_PAGER_TELEPHONE_NUMBER |
PR_PAGER_TELEPHONE_NUMBER_A |
PR_PAGER_TELEPHONE_NUMBER_W |
PR_PARENT_DISPLAY |
PR_PARENT_DISPLAY_A |
PR_PARENT_DISPLAY_W |
PR_PARENT_ENTRYID |
PR_PARENT_KEY |
PR_PARENT_SOURCE_KEY |
PR_PERSONAL_HOME_PAGE |
PR_PERSONAL_HOME_PAGE_A |
PR_PERSONAL_HOME_PAGE_W |
PR_PHYSICAL_DELIVERY_BUREAU_FAX_DELIVERY |
PR_PHYSICAL_DELIVERY_MODE |
PR_PHYSICAL_DELIVERY_REPORT_REQUEST |
PR_PHYSICAL_FORWARDING_ADDRESS |
PR_PHYSICAL_FORWARDING_ADDRESS_REQUESTED |
PR_PHYSICAL_FORWARDING_PROHIBITED |
PR_PHYSICAL_RENDITION_ATTRIBUTES |
PR_POST_FOLDER_ENTRIES |
PR_POST_FOLDER_NAMES |
PR_POST_FOLDER_NAMES_A |
PR_POST_FOLDER_NAMES_W |
PR_POST_OFFICE_BOX |
PR_POST_OFFICE_BOX_A |
PR_POST_OFFICE_BOX_W |
PR_POST_REPLY_DENIED |
PR_POST_REPLY_FOLDER_ENTRIES |
PR_POST_REPLY_FOLDER_NAMES |
PR_POST_REPLY_FOLDER_NAMES_A |
PR_POST_REPLY_FOLDER_NAMES_W |
PR_POSTAL_ADDRESS |
PR_POSTAL_ADDRESS_A |
PR_POSTAL_ADDRESS_W |
PR_POSTAL_CODE |
PR_POSTAL_CODE_A |
PR_POSTAL_CODE_W |
PR_PREDECESSOR_CHANGE_LIST |
PR_PREFERRED_BY_NAME |
PR_PREFERRED_BY_NAME_A |
PR_PREFERRED_BY_NAME_W |
PR_PREPROCESS |
PR_PREVENT_MSG_CREATE |
PR_PREVIEW |
PR_PREVIEW_A |
PR_PREVIEW_UNREAD |
PR_PREVIEW_UNREAD_A |
PR_PREVIEW_UNREAD_W |
PR_PREVIEW_W |
PR_PRIMARY_CAPABILITY |
PR_PRIMARY_FAX_NUMBER |
PR_PRIMARY_FAX_NUMBER_A |
PR_PRIMARY_FAX_NUMBER_W |
PR_PRIMARY_TELEPHONE_NUMBER |
PR_PRIMARY_TELEPHONE_NUMBER_A |
PR_PRIMARY_TELEPHONE_NUMBER_W |
PR_PRIORITY |
PR_PROFESSION |
PR_PROFESSION_A |
PR_PROFESSION_W |
PR_PROFILE_AB_FILES_PATH |
PR_PROFILE_AB_FILES_PATH_A |
PR_PROFILE_AB_FILES_PATH_W |
PR_PROFILE_ADDR_INFO |
PR_PROFILE_ALLPUB_COMMENT |
PR_PROFILE_ALLPUB_COMMENT_A |
PR_PROFILE_ALLPUB_COMMENT_W |
PR_PROFILE_ALLPUB_DISPLAY_NAME |
PR_PROFILE_ALLPUB_DISPLAY_NAME_A |
PR_PROFILE_ALLPUB_DISPLAY_NAME_W |
PR_PROFILE_AUTH_PACKAGE |
PR_PROFILE_BINDING_ORDER |
PR_PROFILE_BINDING_ORDER_A |
PR_PROFILE_BINDING_ORDER_W |
PR_PROFILE_CONFIG_FLAGS |
PR_PROFILE_CONNECT_FLAGS |
PR_PROFILE_FAVFLD_COMMENT |
PR_PROFILE_FAVFLD_COMMENT_A |
PR_PROFILE_FAVFLD_COMMENT_W |
PR_PROFILE_FAVFLD_DISPLAY_NAME |
PR_PROFILE_FAVFLD_DISPLAY_NAME_A |
PR_PROFILE_FAVFLD_DISPLAY_NAME_W |
PR_PROFILE_HOME_SERVER |
PR_PROFILE_HOME_SERVER_A |
PR_PROFILE_HOME_SERVER_ADDRS |
PR_PROFILE_HOME_SERVER_DN |
PR_PROFILE_HOME_SERVER_DN_A |
PR_PROFILE_HOME_SERVER_DN_W |
PR_PROFILE_HOME_SERVER_W |
PR_PROFILE_MAILBOX |
PR_PROFILE_MAILBOX_A |
PR_PROFILE_MAILBOX_W |
PR_PROFILE_MAX_RESTRICT |
PR_PROFILE_MOAB |
PR_PROFILE_MOAB_A |
PR_PROFILE_MOAB_GUID |
PR_PROFILE_MOAB_GUID_A |
PR_PROFILE_MOAB_GUID_W |
PR_PROFILE_MOAB_SEQ |
PR_PROFILE_MOAB_W |
PR_PROFILE_NAME |
PR_PROFILE_NAME_A |
PR_PROFILE_NAME_W |
PR_PROFILE_OFFLINE_INFO |
PR_PROFILE_OFFLINE_STORE_PATH |
PR_PROFILE_OFFLINE_STORE_PATH_A |
PR_PROFILE_OFFLINE_STORE_PATH_W |
PR_PROFILE_OPEN_FLAGS |
PR_PROFILE_OPTIONS_DATA |
PR_PROFILE_SECURE_MAILBOX |
PR_PROFILE_SERVER |
PR_PROFILE_SERVER_A |
PR_PROFILE_SERVER_DN |
PR_PROFILE_SERVER_DN_A |
PR_PROFILE_SERVER_DN_W |
PR_PROFILE_SERVER_W |
PR_PROFILE_TRANSPORT_FLAGS |
PR_PROFILE_TYPE |
PR_PROFILE_UI_STATE |
PR_PROFILE_UNRESOLVED_NAME |
PR_PROFILE_UNRESOLVED_NAME_A |
PR_PROFILE_UNRESOLVED_NAME_W |
PR_PROFILE_UNRESOLVED_SERVER |
PR_PROFILE_UNRESOLVED_SERVER_A |
PR_PROFILE_UNRESOLVED_SERVER_W |
PR_PROFILE_USER |
PR_PROFILE_USER_A |
PR_PROFILE_USER_W |
PR_PROFILE_VERSION |
PR_PROMOTE_PROP_ID_LIST |
PR_PROOF_OF_DELIVERY |
PR_PROOF_OF_DELIVERY_REQUESTED |
PR_PROOF_OF_SUBMISSION |
PR_PROOF_OF_SUBMISSION_REQUESTED |
PR_PROVIDER_DISPLAY |
PR_PROVIDER_DISPLAY_A |
PR_PROVIDER_DISPLAY_W |
PR_PROVIDER_DLL_NAME |
PR_PROVIDER_DLL_NAME_A |
PR_PROVIDER_DLL_NAME_W |
PR_PROVIDER_ORDINAL |
PR_PROVIDER_SUBMIT_TIME |
PR_PROVIDER_UID |
PR_PST_ENCRYPTION |
PR_PST_PASSWORD | Contains the CRC-32 hash of the password string of PST. If the property exists and is nonzero, then the PST file is password protected.
PR_PST_PATH |
PR_PST_PATH_A |
PR_PST_PATH_W |
PR_PST_PW_SZ_NEW |
PR_PST_PW_SZ_NEW_A |
PR_PST_PW_SZ_NEW_W |
PR_PST_PW_SZ_OLD |
PR_PST_PW_SZ_OLD_A |
PR_PST_PW_SZ_OLD_W |
PR_PST_REMEMBER_PW |
PR_PUBLIC_FOLDER_ENTRYID |
PR_PUBLISH_IN_ADDRESS_BOOK |
PR_RADIO_TELEPHONE_NUMBER |
PR_RADIO_TELEPHONE_NUMBER_A |
PR_RADIO_TELEPHONE_NUMBER_W |
PR_RCVD_REPRESENTING_ADDRTYPE |
PR_RCVD_REPRESENTING_ADDRTYPE_A |
PR_RCVD_REPRESENTING_ADDRTYPE_W |
PR_RCVD_REPRESENTING_EMAIL_ADDRESS |
PR_RCVD_REPRESENTING_EMAIL_ADDRESS_A |
PR_RCVD_REPRESENTING_EMAIL_ADDRESS_W |
PR_RCVD_REPRESENTING_ENTRYID |
PR_RCVD_REPRESENTING_NAME |
PR_RCVD_REPRESENTING_NAME_A |
PR_RCVD_REPRESENTING_NAME_W |
PR_RCVD_REPRESENTING_SEARCH_KEY |
PR_READ_RECEIPT_ENTRYID |
PR_READ_RECEIPT_REQUESTED |
PR_READ_RECEIPT_SEARCH_KEY |
PR_RECEIPT_TIME |
PR_RECEIVE_FOLDER_SETTINGS |
PR_RECEIVED_BY_ADDRTYPE |
PR_RECEIVED_BY_ADDRTYPE_A |
PR_RECEIVED_BY_ADDRTYPE_W |
PR_RECEIVED_BY_EMAIL_ADDRESS |
PR_RECEIVED_BY_EMAIL_ADDRESS_A |
PR_RECEIVED_BY_EMAIL_ADDRESS_W |
PR_RECEIVED_BY_ENTRYID |
PR_RECEIVED_BY_NAME |
PR_RECEIVED_BY_NAME_A |
PR_RECEIVED_BY_NAME_W |
PR_RECEIVED_BY_SEARCH_KEY |
PR_RECIPIENT_CERTIFICATE |
PR_RECIPIENT_NUMBER |
PR_RECIPIENT_NUMBER_FOR_ADVICE |
PR_RECIPIENT_NUMBER_FOR_ADVICE_A |
PR_RECIPIENT_NUMBER_FOR_ADVICE_W |
PR_RECIPIENT_ON_ASSOC_MSG_COUNT |
PR_RECIPIENT_ON_NORMAL_MSG_COUNT |
PR_RECIPIENT_REASSIGNMENT_PROHIBITED |
PR_RECIPIENT_STATUS |
PR_RECIPIENT_TYPE |
PR_RECORD_KEY |
PR_REDIRECTION_HISTORY |
PR_REFERRED_BY_NAME |
PR_REFERRED_BY_NAME_A |
PR_REFERRED_BY_NAME_W |
PR_REGISTERED_MAIL_TYPE |
PR_RELATED_IPMS |
PR_REMOTE_PROGRESS |
PR_REMOTE_PROGRESS_TEXT |
PR_REMOTE_PROGRESS_TEXT_A |
PR_REMOTE_PROGRESS_TEXT_W |
PR_REMOTE_VALIDATE_OK |
PR_RENDERING_POSITION |
PR_REPLICA_LIST |
PR_REPLICA_SERVER |
PR_REPLICA_SERVER_A |
PR_REPLICA_SERVER_W |
PR_REPLICA_VERSION |
PR_REPLICATION_ALWAYS_INTERVAL |
PR_REPLICATION_MESSAGE_PRIORITY |
PR_REPLICATION_MSG_SIZE |
PR_REPLICATION_SCHEDULE |
PR_REPLICATION_STYLE |
PR_REPLY_RECIPIENT_ENTRIES |
PR_REPLY_RECIPIENT_NAMES |
PR_REPLY_RECIPIENT_NAMES_A |
PR_REPLY_RECIPIENT_NAMES_W |
PR_REPLY_RECIPIENT_SMTP_PROXIES |
PR_REPLY_RECIPIENT_SMTP_PROXIES_A |
PR_REPLY_RECIPIENT_SMTP_PROXIES_W |
PR_REPLY_REQUESTED |
PR_REPLY_TIME |
PR_REPORT_DESTINATION_ENTRYID |
PR_REPORT_DESTINATION_NAME |
PR_REPORT_DESTINATION_NAME_A |
PR_REPORT_DESTINATION_NAME_W |
PR_REPORT_ENTRYID |
PR_REPORT_NAME |
PR_REPORT_NAME_A |
PR_REPORT_NAME_W |
PR_REPORT_SEARCH_KEY |
PR_REPORT_TAG |
PR_REPORT_TEXT |
PR_REPORT_TEXT_A |
PR_REPORT_TEXT_W |
PR_REPORT_TIME |
PR_REPORTING_DL_NAME |
PR_REPORTING_MTA_CERTIFICATE |
PR_REQUESTED_DELIVERY_METHOD |
PR_RESOLVE_METHOD |
PR_RESOURCE_FLAGS |
PR_RESOURCE_METHODS |
PR_RESOURCE_PATH |
PR_RESOURCE_PATH_A |
PR_RESOURCE_PATH_W |
PR_RESOURCE_TYPE |
PR_RESPONSE_REQUESTED |
PR_RESPONSIBILITY |
PR_RESTRICTION_COUNT |
PR_RETENTION_AGE_LIMIT |
PR_RETURNED_IPM |
PR_RIGHTS |
PR_ROW_TYPE |
PR_ROWID |
PR_RTF_COMPRESSED |
PR_RTF_DECOMPRESSED |
PR_RTF_IN_SYNC |
PR_RTF_SYNC_BODY_COUNT |
PR_RTF_SYNC_BODY_CRC |
PR_RTF_SYNC_BODY_TAG |
PR_RTF_SYNC_BODY_TAG_A |
PR_RTF_SYNC_BODY_TAG_W |
PR_RTF_SYNC_PREFIX_COUNT |
PR_RTF_SYNC_TRAILING_COUNT |
PR_RULE_ACTION_NUMBER |
PR_RULE_ACTION_TYPE |
PR_RULE_ACTIONS |
PR_RULE_CONDITION |
PR_RULE_ERROR |
PR_RULE_FOLDER_ENTRYID |
PR_RULE_ID |
PR_RULE_IDS |
PR_RULE_LEVEL |
PR_RULE_NAME |
PR_RULE_NAME_A |
PR_RULE_NAME_W |
PR_RULE_PROVIDER |
PR_RULE_PROVIDER_A |
PR_RULE_PROVIDER_DATA |
PR_RULE_PROVIDER_W |
PR_RULE_SEQUENCE |
PR_RULE_STATE |
PR_RULE_TRIGGER_HISTORY |
PR_RULE_USER_FLAGS |
PR_RULES_DATA |
PR_RULES_TABLE |
PR_SCHEDULE_FOLDER_ENTRYID |
PR_SEARCH |
PR_SEARCH_KEY |
PR_SECURE_IN_SITE |
PR_SECURE_ORIGINATION |
PR_SECURITY |
PR_SELECTABLE |
PR_SEND_INTERNET_ENCODING |
PR_SEND_RICH_INFO |
PR_SENDER_ADDRTYPE |
PR_SENDER_ADDRTYPE_A |
PR_SENDER_ADDRTYPE_W |
PR_SENDER_EMAIL_ADDRESS |
PR_SENDER_EMAIL_ADDRESS_A |
PR_SENDER_EMAIL_ADDRESS_W |
PR_SENDER_ENTRYID |
PR_SENDER_NAME |
PR_SENDER_NAME_A |
PR_SENDER_NAME_W |
PR_SENDER_SEARCH_KEY |
PR_SENSITIVITY |
PR_SENT_REPRESENTING_ADDRTYPE |
PR_SENT_REPRESENTING_ADDRTYPE_A |
PR_SENT_REPRESENTING_ADDRTYPE_W |
PR_SENT_REPRESENTING_EMAIL_ADDRESS |
PR_SENT_REPRESENTING_EMAIL_ADDRESS_A |
PR_SENT_REPRESENTING_EMAIL_ADDRESS_W |
PR_SENT_REPRESENTING_ENTRYID |
PR_SENT_REPRESENTING_NAME |
PR_SENT_REPRESENTING_NAME_A |
PR_SENT_REPRESENTING_NAME_W |
PR_SENT_REPRESENTING_SEARCH_KEY |
PR_SENTMAIL_ENTRYID |
PR_SERVICE_DELETE_FILES |
PR_SERVICE_DLL_NAME |
PR_SERVICE_DLL_NAME_A |
PR_SERVICE_DLL_NAME_W |
PR_SERVICE_ENTRY_NAME |
PR_SERVICE_ENTRY_NAME_A |
PR_SERVICE_ENTRY_NAME_W |
PR_SERVICE_EXTRA_UIDS |
PR_SERVICE_NAME |
PR_SERVICE_NAME_A |
PR_SERVICE_NAME_W |
PR_SERVICE_SUPPORT_FILES |
PR_SERVICE_UID |
PR_SERVICES |
PR_SORT_LOCALE_ID |
PR_SOURCE_KEY |
PR_SPLUS_FREE_BUSY_ENTRYID |
PR_SPOOLER_STATUS |
PR_SPOUSE_NAME |
PR_SPOUSE_NAME_A |
PR_SPOUSE_NAME_W |
PR_START_DATE |
PR_STATE_OR_PROVINCE |
PR_STATE_OR_PROVINCE_A |
PR_STATE_OR_PROVINCE_W |
PR_STATUS |
PR_STATUS_CODE |
PR_STATUS_STRING |
PR_STATUS_STRING_A |
PR_STATUS_STRING_W |
PR_STORAGE_LIMIT_INFORMATION |
PR_STORAGE_QUOTA_LIMIT |
PR_STORE_ENTRYID |
PR_STORE_OFFLINE |
PR_STORE_PROVIDERS |
PR_STORE_RECORD_KEY |
PR_STORE_SLOWLINK |
PR_STORE_STATE |
PR_STORE_SUPPORT_MASK |
PR_STREET_ADDRESS |
PR_STREET_ADDRESS_A |
PR_STREET_ADDRESS_W |
PR_SUBFOLDERS |
PR_SUBJECT |
PR_SUBJECT_A |
PR_SUBJECT_IPM |
PR_SUBJECT_PREFIX |
PR_SUBJECT_PREFIX_A |
PR_SUBJECT_PREFIX_W |
PR_SUBJECT_TRACE_INFO |
PR_SUBJECT_W |
PR_SUBMIT_FLAGS |
PR_SUPERSEDES |
PR_SUPERSEDES_A |
PR_SUPERSEDES_W |
PR_SUPPLEMENTARY_INFO |
PR_SUPPLEMENTARY_INFO_A |
PR_SUPPLEMENTARY_INFO_W |
PR_SURNAME |
PR_SURNAME_A |
PR_SURNAME_W |
PR_SVR_GENERATING_QUOTA_MSG |
PR_SVR_GENERATING_QUOTA_MSG_A |
PR_SVR_GENERATING_QUOTA_MSG_W |
PR_SWAPPED_TODO_DATA | Maintains a second set of property values that do not affect the flagged state of the Message object.
PR_SYNCHRONIZE_FLAGS |
PR_SYS_CONFIG_FOLDER_ENTRYID |
PR_TELEX_NUMBER |
PR_TELEX_NUMBER_A |
PR_TELEX_NUMBER_W |
PR_TEMPLATEID |
PR_TEST_LINE_SPEED |
PR_TITLE |
PR_TITLE_A |
PR_TITLE_W |
PR_TNEF_CORRELATION_KEY |
PR_TODO_ITEM_FLAGS | Represents a To-Do item's flagged condition.
PR_TRACE_INFO |
PR_TRANSFER_ENABLED |
PR_TRANSMITABLE_DISPLAY_NAME |
PR_TRANSMITABLE_DISPLAY_NAME_A |
PR_TRANSMITABLE_DISPLAY_NAME_W |
PR_TRANSPORT_KEY |
PR_TRANSPORT_MESSAGE_HEADERS |
PR_TRANSPORT_MESSAGE_HEADERS_A |
PR_TRANSPORT_MESSAGE_HEADERS_W |
PR_TRANSPORT_PROVIDERS |
PR_TRANSPORT_STATUS |
PR_TTYTDD_PHONE_NUMBER |
PR_TTYTDD_PHONE_NUMBER_A |
PR_TTYTDD_PHONE_NUMBER_W |
PR_TYPE_OF_MTS_USER |
PR_USER_CERTIFICATE |
PR_USER_ENTRYID |
PR_USER_NAME |
PR_USER_NAME_A |
PR_USER_NAME_W |
PR_USER_X509_CERTIFICATE |
PR_VALID_FOLDER_MASK |
PR_VIEWS_ENTRYID |
PR_WEDDING_ANNIVERSARY |
PR_X400_CONTENT_TYPE |
PR_X400_DEFERRED_DELIVERY_CANCEL |
PR_X400_ENVELOPE_TYPE |
PR_XPOS |
PR_YPOS |

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_7BIT_DISPLAY_NAME Field

The PR_7BIT_DISPLAY_NAME property contains a 7-bit ASCII version of a messaging user's name.

public static readonly long PR_7BIT_DISPLAY_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_7BIT_DISPLAY_NAME_A Field

The ASCII peer for PR_7BIT_DISPLAY_NAME.

public static readonly long PR_7BIT_DISPLAY_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_7BIT_DISPLAY_NAME_W Field

The Unicode peer for PR_7BIT_DISPLAY_NAME.

public static readonly long PR_7BIT_DISPLAY_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_AB_DEFAULT_DIR Field

The PR_AB_DEFAULT_DIR property contains the entry identifier of the address book container that is to be shown to the user first.

public static readonly long PR_AB_DEFAULT_DIR;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_AB_DEFAULT_PAB Field

The PR_AB_DEFAULT_PAB property contains the entry identifier of the address book container that is to be used as the personal address book.

public static readonly long PR_AB_DEFAULT_PAB;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_AB_PROVIDER_ID Field

The PR_AB_DEFAULT_PAB property contains the entry identifier of the address book container that is to be used as the personal address book.

public static readonly long PR_AB_PROVIDER_ID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_AB_PROVIDERS Field

The PR_AB_PROVIDERS property contains a list of identifiers for address book providers in the current profile.

public static readonly long PR_AB_PROVIDERS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_AB_SEARCH_PATH Field

The PR_AB_PROVIDERS property contains a list of identifiers for address book providers in the current profile.

public static readonly long PR_AB_SEARCH_PATH;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_AB_SEARCH_PATH_UPDATE Field

public static readonly long PR_AB_SEARCH_PATH_UPDATE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ABSTRACT Field

public static readonly long PR_ABSTRACT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ABSTRACT_A Field

public static readonly long PR_ABSTRACT_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ABSTRACT_W Field

public static readonly long PR_ABSTRACT_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ACCESS Field

public static readonly long PR_ACCESS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ACCESS_LEVEL Field

public static readonly long PR_ACCESS_LEVEL;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ACCOUNT Field

public static readonly long PR_ACCOUNT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ACCOUNT_A Field

public static readonly long PR_ACCOUNT_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ACCOUNT_W Field

public static readonly long PR_ACCOUNT_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ACKNOWLEDGEMENT_MODE Field

public static readonly long PR_ACKNOWLEDGEMENT_MODE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ACL_DATA Field

public static readonly long PR_ACL_DATA;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ACL_TABLE Field

public static readonly long PR_ACL_TABLE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ACTIVE_USER_ENTRYID Field

public static readonly long PR_ACTIVE_USER_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ADDRBOOK_FOR_LOCAL_SITE_ENTRYID Field

public static readonly long PR_ADDRBOOK_FOR_LOCAL_SITE_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ADDRESS_BOOK_DISPLAY_NAME Field

public static readonly long PR_ADDRESS_BOOK_DISPLAY_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ADDRESS_BOOK_DISPLAY_NAME_A Field

public static readonly long PR_ADDRESS_BOOK_DISPLAY_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ADDRESS_BOOK_DISPLAY_NAME_W Field

public static readonly long PR_ADDRESS_BOOK_DISPLAY_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ADDRESS_BOOK_ENTRYID Field

public static readonly long PR_ADDRESS_BOOK_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ADDRTYPE Field

public static readonly long PR_ADDRTYPE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ADDRTYPE_A Field

public static readonly long PR_ADDRTYPE_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ADDRTYPE_W Field

public static readonly long PR_ADDRTYPE_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ALTERNATE_RECIPIENT Field

public static readonly long PR_ALTERNATE_RECIPIENT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ALTERNATE_RECIPIENT_ALLOWED Field

public static readonly long PR_ALTERNATE_RECIPIENT_ALLOWED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ANR Field

public static readonly long PR_ANR;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ANR_A Field

public static readonly long PR_ANR_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ANR_W Field

public static readonly long PR_ANR_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ARRIVAL_TIME Field

public static readonly long PR_ARRIVAL_TIME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ASSISTANT Field

public static readonly long PR_ASSISTANT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ASSISTANT_A Field

public static readonly long PR_ASSISTANT_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ASSISTANT_TELEPHONE_NUMBER Field

public static readonly long PR_ASSISTANT_TELEPHONE_NUMBER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ASSISTANT_TELEPHONE_NUMBER_A Field

public static readonly long PR_ASSISTANT_TELEPHONE_NUMBER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ASSISTANT_TELEPHONE_NUMBER_W Field

public static readonly long PR_ASSISTANT_TELEPHONE_NUMBER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ASSISTANT_W Field

public static readonly long PR_ASSISTANT_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ASSOC_CONTENT_COUNT Field

public static readonly long PR_ASSOC_CONTENT_COUNT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ASSOC_MESSAGE_SIZE Field

public static readonly long PR_ASSOC_MESSAGE_SIZE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ASSOC_MESSAGE_SIZE_EXTENDED Field

public static readonly long PR_ASSOC_MESSAGE_SIZE_EXTENDED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ASSOC_MSG_W_ATTACH_COUNT Field

public static readonly long PR_ASSOC_MSG_W_ATTACH_COUNT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ATTACH_ADDITIONAL_INFO Field

public static readonly long PR_ATTACH_ADDITIONAL_INFO;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ATTACH_CONTENT_ID Field

Contains the content identification header of a MIME message attachment. This property is used for MHTML support.

public static readonly long PR_ATTACH_CONTENT_ID;

Remarks

It can be used to distinguish between inline attachments such as signature images and normal attached files. If Attachment has this property, then it is an embedded image.

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ATTACH_CONTENT_ID_A Field

Contains the content identification header of a MIME message attachment. This property is used for MHTML support. Non-UNICODE compilation.

public static readonly long PR_ATTACH_CONTENT_ID_A;

Remarks

It can be used to distinguish between inline attachments such as signature images and normal attached files. If Attachment has this property, then it is an embedded image.

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ATTACH_CONTENT_ID_W Field

Contains the content identification header of a MIME message attachment. This property is used for MHTML support. UNICODE compilation.

public static readonly long PR_ATTACH_CONTENT_ID_W;

Remarks

It can be used to distinguish between inline attachments such as signature images and normal attached files. If Attachment has this property, then it is an embedded image.

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ATTACH_DATA_BIN Field

public static readonly long PR_ATTACH_DATA_BIN;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ATTACH_DATA_OBJ Field

public static readonly long PR_ATTACH_DATA_OBJ;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ATTACH_ENCODING Field

public static readonly long PR_ATTACH_ENCODING;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ATTACH_EXTENSION Field

public static readonly long PR_ATTACH_EXTENSION;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ATTACH_EXTENSION_A Field

public static readonly long PR_ATTACH_EXTENSION_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ATTACH_EXTENSION_W Field

public static readonly long PR_ATTACH_EXTENSION_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ATTACH_FILENAME Field

public static readonly long PR_ATTACH_FILENAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ATTACH_FILENAME_A Field

public static readonly long PR_ATTACH_FILENAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ATTACH_FILENAME_W Field

public static readonly long PR_ATTACH_FILENAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ATTACH_LONG_FILENAME Field

public static readonly long PR_ATTACH_LONG_FILENAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ATTACH_LONG_FILENAME_A Field

public static readonly long PR_ATTACH_LONG_FILENAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ATTACH_LONG_FILENAME_W Field

public static readonly long PR_ATTACH_LONG_FILENAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ATTACH_LONG_PATHNAME Field

public static readonly long PR_ATTACH_LONG_PATHNAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ATTACH_LONG_PATHNAME_A Field

public static readonly long PR_ATTACH_LONG_PATHNAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ATTACH_LONG_PATHNAME_W Field

public static readonly long PR_ATTACH_LONG_PATHNAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ATTACH_METHOD Field

public static readonly long PR_ATTACH_METHOD;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ATTACH_MIME_TAG Field

public static readonly long PR_ATTACH_MIME_TAG;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ATTACH_MIME_TAG_A Field

public static readonly long PR_ATTACH_MIME_TAG_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ATTACH_MIME_TAG_W Field

public static readonly long PR_ATTACH_MIME_TAG_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ATTACH_NUM Field

public static readonly long PR_ATTACH_NUM;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ATTACH_ON_ASSOC_MSG_COUNT Field

public static readonly long PR_ATTACH_ON_ASSOC_MSG_COUNT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ATTACH_ON_NORMAL_MSG_COUNT Field

public static readonly long PR_ATTACH_ON_NORMAL_MSG_COUNT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ATTACH_PATHNAME Field

public static readonly long PR_ATTACH_PATHNAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ATTACH_PATHNAME_A Field

public static readonly long PR_ATTACH_PATHNAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ATTACH_PATHNAME_W Field

public static readonly long PR_ATTACH_PATHNAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ATTACH_RENDERING Field

public static readonly long PR_ATTACH_RENDERING;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ATTACH_SIZE Field

public static readonly long PR_ATTACH_SIZE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ATTACH_TAG Field

public static readonly long PR_ATTACH_TAG;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ATTACH_TRANSPORT_NAME Field

public static readonly long PR_ATTACH_TRANSPORT_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ATTACH_TRANSPORT_NAME_A Field

public static readonly long PR_ATTACH_TRANSPORT_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ATTACH_TRANSPORT_NAME_W Field

public static readonly long PR_ATTACH_TRANSPORT_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ATTACHMENT_CONTACTPHOTO Field

public static readonly long PR_ATTACHMENT_CONTACTPHOTO;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ATTACHMENT_FLAGS Field

public static readonly long PR_ATTACHMENT_FLAGS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ATTACHMENT_X400_PARAMETERS Field

public static readonly long PR_ATTACHMENT_X400_PARAMETERS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_AUTHORIZING_USERS Field

public static readonly long PR_AUTHORIZING_USERS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_AUTO_ADD_NEW_SUBS Field

public static readonly long PR_AUTO_ADD_NEW_SUBS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_AUTO_FORWARD_COMMENT Field

public static readonly long PR_AUTO_FORWARD_COMMENT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_AUTO_FORWARD_COMMENT_A Field

public static readonly long PR_AUTO_FORWARD_COMMENT_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_AUTO_FORWARD_COMMENT_W Field

public static readonly long PR_AUTO_FORWARD_COMMENT_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_AUTO_FORWARDED Field

public static readonly long PR_AUTO_FORWARDED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_AUTO_RESPONSE_SUPPRESS Field

public static readonly long PR_AUTO_RESPONSE_SUPPRESS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_BEEPER_TELEPHONE_NUMBER Field

public static readonly long PR_BEEPER_TELEPHONE_NUMBER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_BEEPER_TELEPHONE_NUMBER_A Field

public static readonly long PR_BEEPER_TELEPHONE_NUMBER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_BEEPER_TELEPHONE_NUMBER_W Field

public static readonly long PR_BEEPER_TELEPHONE_NUMBER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_BILATERAL_INFO Field

public static readonly long PR_BILATERAL_INFO;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_BIRTHDAY Field

public static readonly long PR_BIRTHDAY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_BODY Field

public static readonly long PR_BODY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_BODY_A Field

public static readonly long PR_BODY_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_BODY_CRC Field

public static readonly long PR_BODY_CRC;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_BODY_W Field

public static readonly long PR_BODY_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_BUSINESS_ADDRESS_CITY Field

public static readonly long PR_BUSINESS_ADDRESS_CITY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_BUSINESS_ADDRESS_CITY_A Field

public static readonly long PR_BUSINESS_ADDRESS_CITY_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_BUSINESS_ADDRESS_CITY_W Field

public static readonly long PR_BUSINESS_ADDRESS_CITY_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_BUSINESS_ADDRESS_COUNTRY Field

public static readonly long PR_BUSINESS_ADDRESS_COUNTRY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_BUSINESS_ADDRESS_COUNTRY_A Field

public static readonly long PR_BUSINESS_ADDRESS_COUNTRY_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_BUSINESS_ADDRESS_COUNTRY_W Field

public static readonly long PR_BUSINESS_ADDRESS_COUNTRY_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_BUSINESS_ADDRESS_POST_OFFICE_BOX Field

public static readonly long PR_BUSINESS_ADDRESS_POST_OFFICE_BOX;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_BUSINESS_ADDRESS_POST_OFFICE_BOX_A Field

public static readonly long PR_BUSINESS_ADDRESS_POST_OFFICE_BOX_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_BUSINESS_ADDRESS_POST_OFFICE_BOX_W Field

public static readonly long PR_BUSINESS_ADDRESS_POST_OFFICE_BOX_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_BUSINESS_ADDRESS_POSTAL_CODE Field

public static readonly long PR_BUSINESS_ADDRESS_POSTAL_CODE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_BUSINESS_ADDRESS_POSTAL_CODE_A Field

public static readonly long PR_BUSINESS_ADDRESS_POSTAL_CODE_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_BUSINESS_ADDRESS_POSTAL_CODE_W Field

public static readonly long PR_BUSINESS_ADDRESS_POSTAL_CODE_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_BUSINESS_ADDRESS_STATE_OR_PROVINCE Field

public static readonly long PR_BUSINESS_ADDRESS_STATE_OR_PROVINCE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_BUSINESS_ADDRESS_STATE_OR_PROVINCE_A Field

public static readonly long PR_BUSINESS_ADDRESS_STATE_OR_PROVINCE_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_BUSINESS_ADDRESS_STATE_OR_PROVINCE_W Field

public static readonly long PR_BUSINESS_ADDRESS_STATE_OR_PROVINCE_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_BUSINESS_ADDRESS_STREET Field

public static readonly long PR_BUSINESS_ADDRESS_STREET;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_BUSINESS_ADDRESS_STREET_A Field

public static readonly long PR_BUSINESS_ADDRESS_STREET_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_BUSINESS_ADDRESS_STREET_W Field

public static readonly long PR_BUSINESS_ADDRESS_STREET_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_BUSINESS_FAX_NUMBER Field

public static readonly long PR_BUSINESS_FAX_NUMBER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_BUSINESS_FAX_NUMBER_A Field

public static readonly long PR_BUSINESS_FAX_NUMBER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_BUSINESS_FAX_NUMBER_W Field

public static readonly long PR_BUSINESS_FAX_NUMBER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_BUSINESS_HOME_PAGE Field

public static readonly long PR_BUSINESS_HOME_PAGE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_BUSINESS_HOME_PAGE_A Field

public static readonly long PR_BUSINESS_HOME_PAGE_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_BUSINESS_HOME_PAGE_W Field

public static readonly long PR_BUSINESS_HOME_PAGE_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_BUSINESS_TELEPHONE_NUMBER Field

public static readonly long PR_BUSINESS_TELEPHONE_NUMBER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_BUSINESS_TELEPHONE_NUMBER_A Field

public static readonly long PR_BUSINESS_TELEPHONE_NUMBER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_BUSINESS_TELEPHONE_NUMBER_W Field

public static readonly long PR_BUSINESS_TELEPHONE_NUMBER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_BUSINESS2_TELEPHONE_NUMBER Field

public static readonly long PR_BUSINESS2_TELEPHONE_NUMBER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_BUSINESS2_TELEPHONE_NUMBER_A Field

public static readonly long PR_BUSINESS2_TELEPHONE_NUMBER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_BUSINESS2_TELEPHONE_NUMBER_W Field

public static readonly long PR_BUSINESS2_TELEPHONE_NUMBER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CACHED_COLUMN_COUNT Field

public static readonly long PR_CACHED_COLUMN_COUNT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CALLBACK_TELEPHONE_NUMBER Field

public static readonly long PR_CALLBACK_TELEPHONE_NUMBER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CALLBACK_TELEPHONE_NUMBER_A Field

public static readonly long PR_CALLBACK_TELEPHONE_NUMBER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CALLBACK_TELEPHONE_NUMBER_W Field

public static readonly long PR_CALLBACK_TELEPHONE_NUMBER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CAR_TELEPHONE_NUMBER Field

public static readonly long PR_CAR_TELEPHONE_NUMBER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CAR_TELEPHONE_NUMBER_A Field

public static readonly long PR_CAR_TELEPHONE_NUMBER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CAR_TELEPHONE_NUMBER_W Field

public static readonly long PR_CAR_TELEPHONE_NUMBER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CATEG_COUNT Field

public static readonly long PR_CATEG_COUNT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CELLULAR_TELEPHONE_NUMBER Field

public static readonly long PR_CELLULAR_TELEPHONE_NUMBER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CELLULAR_TELEPHONE_NUMBER_A Field

public static readonly long PR_CELLULAR_TELEPHONE_NUMBER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CELLULAR_TELEPHONE_NUMBER_W Field

public static readonly long PR_CELLULAR_TELEPHONE_NUMBER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CHANGE_ADVISOR Field

public static readonly long PR_CHANGE_ADVISOR;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CHANGE_KEY Field

public static readonly long PR_CHANGE_KEY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CHANGE_NOTIFICATION_GUID Field

public static readonly long PR_CHANGE_NOTIFICATION_GUID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CHILDRENS_NAMES Field

public static readonly long PR_CHILDRENS_NAMES;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CLIENT_ACTIONS Field

public static readonly long PR_CLIENT_ACTIONS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CLIENT_SUBMIT_TIME Field

public static readonly long PR_CLIENT_SUBMIT_TIME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CODE_PAGE_ID Field

public static readonly long PR_CODE_PAGE_ID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_COLLECTOR Field

public static readonly long PR_COLLECTOR;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_COMMENT Field

public static readonly long PR_COMMENT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_COMMENT_A Field

public static readonly long PR_COMMENT_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_COMMENT_W Field

public static readonly long PR_COMMENT_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_COMMON_VIEWS_ENTRYID Field

public static readonly long PR_COMMON_VIEWS_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_COMPANY_MAIN_PHONE_NUMBER Field

public static readonly long PR_COMPANY_MAIN_PHONE_NUMBER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_COMPANY_MAIN_PHONE_NUMBER_A Field

public static readonly long PR_COMPANY_MAIN_PHONE_NUMBER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_COMPANY_MAIN_PHONE_NUMBER_W Field

public static readonly long PR_COMPANY_MAIN_PHONE_NUMBER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_COMPANY_NAME Field

public static readonly long PR_COMPANY_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_COMPANY_NAME_A Field

public static readonly long PR_COMPANY_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_COMPANY_NAME_W Field

public static readonly long PR_COMPANY_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_COMPUTER_NETWORK_NAME Field

public static readonly long PR_COMPUTER_NETWORK_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_COMPUTER_NETWORK_NAME_A Field

public static readonly long PR_COMPUTER_NETWORK_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_COMPUTER_NETWORK_NAME_W Field

public static readonly long PR_COMPUTER_NETWORK_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CONFLICT_ENTRYID Field

public static readonly long PR_CONFLICT_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CONTACT_ADDRTYPES Field

public static readonly long PR_CONTACT_ADDRTYPES;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CONTACT_COUNT Field

public static readonly long PR_CONTACT_COUNT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CONTACT_DEFAULT_ADDRESS_INDEX Field

public static readonly long PR_CONTACT_DEFAULT_ADDRESS_INDEX;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CONTACT_EMAIL_ADDRESSES Field

public static readonly long PR_CONTACT_EMAIL_ADDRESSES;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CONTACT_ENTRYIDS Field

public static readonly long PR_CONTACT_ENTRYIDS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CONTACT_VERSION Field

public static readonly long PR_CONTACT_VERSION;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CONTAINER_CLASS Field

public static readonly long PR_CONTAINER_CLASS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CONTAINER_CLASS_A Field

public static readonly long PR_CONTAINER_CLASS_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CONTAINER_CLASS_W Field

public static readonly long PR_CONTAINER_CLASS_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CONTAINER_CONTENTS Field

public static readonly long PR_CONTAINER_CONTENTS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CONTAINER_FLAGS Field

public static readonly long PR_CONTAINER_FLAGS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CONTAINER_HIERARCHY Field

public static readonly long PR_CONTAINER_HIERARCHY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CONTAINER_MODIFY_VERSION Field

public static readonly long PR_CONTAINER_MODIFY_VERSION;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CONTENT_CONFIDENTIALITY_ALGORITHM_ID Field

public static readonly long PR_CONTENT_CONFIDENTIALITY_ALGORITHM_ID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CONTENT_CORRELATOR Field

public static readonly long PR_CONTENT_CORRELATOR;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CONTENT_COUNT Field

public static readonly long PR_CONTENT_COUNT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CONTENT_IDENTIFIER Field

public static readonly long PR_CONTENT_IDENTIFIER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CONTENT_IDENTIFIER_A Field

public static readonly long PR_CONTENT_IDENTIFIER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CONTENT_IDENTIFIER_W Field

public static readonly long PR_CONTENT_IDENTIFIER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CONTENT_INTEGRITY_CHECK Field

public static readonly long PR_CONTENT_INTEGRITY_CHECK;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CONTENT_LENGTH Field

public static readonly long PR_CONTENT_LENGTH;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CONTENT_RETURN_REQUESTED Field

public static readonly long PR_CONTENT_RETURN_REQUESTED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CONTENT_SEARCH_KEY Field

public static readonly long PR_CONTENT_SEARCH_KEY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CONTENT_UNREAD Field

public static readonly long PR_CONTENT_UNREAD;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CONTENTS_SORT_ORDER Field

public static readonly long PR_CONTENTS_SORT_ORDER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CONTENTS_SYNCHRONIZER Field

public static readonly long PR_CONTENTS_SYNCHRONIZER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CONTROL_FLAGS Field

public static readonly long PR_CONTROL_FLAGS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CONTROL_ID Field

public static readonly long PR_CONTROL_ID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CONTROL_STRUCTURE Field

public static readonly long PR_CONTROL_STRUCTURE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CONTROL_TYPE Field

public static readonly long PR_CONTROL_TYPE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CONVERSATION_INDEX Field

public static readonly long PR_CONVERSATION_INDEX;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CONVERSATION_KEY Field

public static readonly long PR_CONVERSATION_KEY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CONVERSATION_TOPIC Field

public static readonly long PR_CONVERSATION_TOPIC;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CONVERSATION_TOPIC_A Field

public static readonly long PR_CONVERSATION_TOPIC_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CONVERSATION_TOPIC_W Field

public static readonly long PR_CONVERSATION_TOPIC_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CONVERSION_EITS Field

public static readonly long PR_CONVERSION_EITS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CONVERSION_PROHIBITED Field

public static readonly long PR_CONVERSION_PROHIBITED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CONVERSION_WITH_LOSS_PROHIBITED Field

public static readonly long PR_CONVERSION_WITH_LOSS_PROHIBITED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CONVERTED_EITS Field

public static readonly long PR_CONVERTED_EITS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CORRELATE Field

public static readonly long PR_CORRELATE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CORRELATE_MTSID Field

public static readonly long PR_CORRELATE_MTSID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_COUNTRY Field

public static readonly long PR_COUNTRY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_COUNTRY_A Field

public static readonly long PR_COUNTRY_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_COUNTRY_W Field

public static readonly long PR_COUNTRY_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CREATE_TEMPLATES Field

public static readonly long PR_CREATE_TEMPLATES;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CREATION_TIME Field

public static readonly long PR_CREATION_TIME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CREATION_VERSION Field

public static readonly long PR_CREATION_VERSION;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CREATOR_ENTRYID Field

public static readonly long PR_CREATOR_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CREATOR_NAME Field

public static readonly long PR_CREATOR_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CREATOR_NAME_A Field

public static readonly long PR_CREATOR_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CREATOR_NAME_W Field

public static readonly long PR_CREATOR_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CURRENT_VERSION Field

public static readonly long PR_CURRENT_VERSION;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CUSTOMER_ID Field

public static readonly long PR_CUSTOMER_ID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CUSTOMER_ID_A Field

public static readonly long PR_CUSTOMER_ID_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_CUSTOMER_ID_W Field

public static readonly long PR_CUSTOMER_ID_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DAM_BACK_PATCHED Field

public static readonly long PR_DAM_BACK_PATCHED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DAM_ORIGINAL_ENTRYID Field

public static readonly long PR_DAM_ORIGINAL_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DEF_CREATE_DL Field

public static readonly long PR_DEF_CREATE_DL;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DEF_CREATE_MAILUSER Field

public static readonly long PR_DEF_CREATE_MAILUSER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DEFAULT_PROFILE Field

public static readonly long PR_DEFAULT_PROFILE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DEFAULT_STORE Field

public static readonly long PR_DEFAULT_STORE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DEFAULT_VIEW_ENTRYID Field

public static readonly long PR_DEFAULT_VIEW_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DEFERRED_DELIVERY_TIME Field

public static readonly long PR_DEFERRED_DELIVERY_TIME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DEFERRED_SEND_NUMBER Field

public static readonly long PR_DEFERRED_SEND_NUMBER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DEFERRED_SEND_TIME Field

public static readonly long PR_DEFERRED_SEND_TIME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DEFERRED_SEND_UNITS Field

public static readonly long PR_DEFERRED_SEND_UNITS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DELEGATED_BY_RULE Field

public static readonly long PR_DELEGATED_BY_RULE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DELEGATION Field

public static readonly long PR_DELEGATION;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DELETE_AFTER_SUBMIT Field

public static readonly long PR_DELETE_AFTER_SUBMIT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DELETED_ASSOC_MESSAGE_SIZE_EXTENDED Field

public static readonly long PR_DELETED_ASSOC_MESSAGE_SIZE_EXTENDED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DELETED_ASSOC_MSG_COUNT Field

public static readonly long PR_DELETED_ASSOC_MSG_COUNT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DELETED_FOLDER_COUNT Field

public static readonly long PR_DELETED_FOLDER_COUNT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DELETED_MESSAGE_SIZE_EXTENDED Field

public static readonly long PR_DELETED_MESSAGE_SIZE_EXTENDED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DELETED_MSG_COUNT Field

public static readonly long PR_DELETED_MSG_COUNT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DELETED_NORMAL_MESSAGE_SIZE_EXTENDED Field

public static readonly long PR_DELETED_NORMAL_MESSAGE_SIZE_EXTENDED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DELETED_ON Field

public static readonly long PR_DELETED_ON;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DELIVER_TIME Field

public static readonly long PR_DELIVER_TIME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DELIVERY_POINT Field

public static readonly long PR_DELIVERY_POINT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DELTAX Field

public static readonly long PR_DELTAX;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DELTAY Field

public static readonly long PR_DELTAY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DEPARTMENT_NAME Field

public static readonly long PR_DEPARTMENT_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DEPARTMENT_NAME_A Field

public static readonly long PR_DEPARTMENT_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DEPARTMENT_NAME_W Field

public static readonly long PR_DEPARTMENT_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DEPTH Field

public static readonly long PR_DEPTH;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DESIGN_IN_PROGRESS Field

public static readonly long PR_DESIGN_IN_PROGRESS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DETAILS_TABLE Field

public static readonly long PR_DETAILS_TABLE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DISABLE_FULL_FIDELITY Field

public static readonly long PR_DISABLE_FULL_FIDELITY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DISABLE_WINSOCK Field

public static readonly long PR_DISABLE_WINSOCK;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DISC_VAL Field

public static readonly long PR_DISC_VAL;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DISCARD_REASON Field

public static readonly long PR_DISCARD_REASON;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DISCLOSE_RECIPIENTS Field

public static readonly long PR_DISCLOSE_RECIPIENTS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DISCLOSURE_OF_RECIPIENTS Field

public static readonly long PR_DISCLOSURE_OF_RECIPIENTS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DISCRETE_VALUES Field

public static readonly long PR_DISCRETE_VALUES;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DISPLAY_BCC Field

public static readonly long PR_DISPLAY_BCC;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DISPLAY_BCC_A Field

public static readonly long PR_DISPLAY_BCC_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DISPLAY_BCC_W Field

public static readonly long PR_DISPLAY_BCC_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DISPLAY_CC Field

public static readonly long PR_DISPLAY_CC;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DISPLAY_CC_A Field

public static readonly long PR_DISPLAY_CC_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DISPLAY_CC_W Field

public static readonly long PR_DISPLAY_CC_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DISPLAY_NAME Field

public static readonly long PR_DISPLAY_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DISPLAY_NAME_A Field

public static readonly long PR_DISPLAY_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DISPLAY_NAME_PREFIX Field

public static readonly long PR_DISPLAY_NAME_PREFIX;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DISPLAY_NAME_PREFIX_A Field

public static readonly long PR_DISPLAY_NAME_PREFIX_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DISPLAY_NAME_PREFIX_W Field

public static readonly long PR_DISPLAY_NAME_PREFIX_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DISPLAY_NAME_W Field

public static readonly long PR_DISPLAY_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DISPLAY_TO Field

public static readonly long PR_DISPLAY_TO;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DISPLAY_TO_A Field

public static readonly long PR_DISPLAY_TO_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DISPLAY_TO_W Field

public static readonly long PR_DISPLAY_TO_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DISPLAY_TYPE Field

public static readonly long PR_DISPLAY_TYPE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DL_EXPANSION_HISTORY Field

public static readonly long PR_DL_EXPANSION_HISTORY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DL_EXPANSION_PROHIBITED Field

public static readonly long PR_DL_EXPANSION_PROHIBITED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_DL_REPORT_FLAGS Field

public static readonly long PR_DL_REPORT_FLAGS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EFORMS_FOR_LOCALE_ENTRYID Field

public static readonly long PR_EFORMS_FOR_LOCALE_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EFORMS_LOCALE_ID Field

public static readonly long PR_EFORMS_LOCALE_ID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EFORMS_REGISTRY_ENTRYID Field

public static readonly long PR_EFORMS_REGISTRY_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMAIL_ADDRESS Field

public static readonly long PR_EMAIL_ADDRESS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMAIL_ADDRESS_A Field

public static readonly long PR_EMAIL_ADDRESS_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMAIL_ADDRESS_W Field

public static readonly long PR_EMAIL_ADDRESS_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ACCESS_CATEGORY Field

public static readonly long PR_EMS_AB_ACCESS_CATEGORY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ACTIVATION_SCHEDULE Field

public static readonly long PR_EMS_AB_ACTIVATION_SCHEDULE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ACTIVATION_STYLE Field

public static readonly long PR_EMS_AB_ACTIVATION_STYLE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ADDRESS_ENTRY_DISPLAY_TABLE Field

public static readonly long PR_EMS_AB_ADDRESS_ENTRY_DISPLAY_TABLE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ADDRESS_ENTRY_DISPLAY_TABLE_MSDOS Field

public static readonly long PR_EMS_AB_ADDRESS_ENTRY_DISPLAY_TABLE_MSDOS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ADDRESS_SYNTAX Field

public static readonly long PR_EMS_AB_ADDRESS_SYNTAX;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ADDRESS_TYPE Field

public static readonly long PR_EMS_AB_ADDRESS_TYPE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ADDRESS_TYPE_A Field

public static readonly long PR_EMS_AB_ADDRESS_TYPE_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ADDRESS_TYPE_W Field

public static readonly long PR_EMS_AB_ADDRESS_TYPE_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ADMD Field

public static readonly long PR_EMS_AB_ADMD;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ADMD_A Field

public static readonly long PR_EMS_AB_ADMD_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ADMD_W Field

public static readonly long PR_EMS_AB_ADMD_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ADMIN_DESCRIPTION Field

public static readonly long PR_EMS_AB_ADMIN_DESCRIPTION;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ADMIN_DESCRIPTION_A Field

public static readonly long PR_EMS_AB_ADMIN_DESCRIPTION_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ADMIN_DESCRIPTION_W Field

public static readonly long PR_EMS_AB_ADMIN_DESCRIPTION_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ADMIN_DISPLAY_NAME Field

public static readonly long PR_EMS_AB_ADMIN_DISPLAY_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ADMIN_DISPLAY_NAME_A Field

public static readonly long PR_EMS_AB_ADMIN_DISPLAY_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ADMIN_DISPLAY_NAME_W Field

public static readonly long PR_EMS_AB_ADMIN_DISPLAY_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ADMIN_EXTENSION_DLL Field

public static readonly long PR_EMS_AB_ADMIN_EXTENSION_DLL;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ADMIN_EXTENSION_DLL_A Field

public static readonly long PR_EMS_AB_ADMIN_EXTENSION_DLL_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ADMIN_EXTENSION_DLL_W Field

public static readonly long PR_EMS_AB_ADMIN_EXTENSION_DLL_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ALIASED_OBJECT_NAME Field

public static readonly long PR_EMS_AB_ALIASED_OBJECT_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ALIASED_OBJECT_NAME_A Field

public static readonly long PR_EMS_AB_ALIASED_OBJECT_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ALIASED_OBJECT_NAME_O Field

public static readonly long PR_EMS_AB_ALIASED_OBJECT_NAME_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ALIASED_OBJECT_NAME_W Field

public static readonly long PR_EMS_AB_ALIASED_OBJECT_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ALT_RECIPIENT Field

public static readonly long PR_EMS_AB_ALT_RECIPIENT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ALT_RECIPIENT_A Field

public static readonly long PR_EMS_AB_ALT_RECIPIENT_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ALT_RECIPIENT_BL Field

public static readonly long PR_EMS_AB_ALT_RECIPIENT_BL;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ALT_RECIPIENT_BL_O Field

public static readonly long PR_EMS_AB_ALT_RECIPIENT_BL_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ALT_RECIPIENT_O Field

public static readonly long PR_EMS_AB_ALT_RECIPIENT_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ALT_RECIPIENT_W Field

public static readonly long PR_EMS_AB_ALT_RECIPIENT_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ANCESTOR_ID Field

public static readonly long PR_EMS_AB_ANCESTOR_ID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ANONYMOUS_ACCESS Field

public static readonly long PR_EMS_AB_ANONYMOUS_ACCESS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ANONYMOUS_ACCOUNT Field

public static readonly long PR_EMS_AB_ANONYMOUS_ACCOUNT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ANONYMOUS_ACCOUNT_A Field

public static readonly long PR_EMS_AB_ANONYMOUS_ACCOUNT_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ANONYMOUS_ACCOUNT_W Field

public static readonly long PR_EMS_AB_ANONYMOUS_ACCOUNT_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ASSOC_NT_ACCOUNT Field

public static readonly long PR_EMS_AB_ASSOC_NT_ACCOUNT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ASSOC_PROTOCOL_CFG_NNTP Field

public static readonly long PR_EMS_AB_ASSOC_PROTOCOL_CFG_NNTP;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ASSOC_PROTOCOL_CFG_NNTP_A Field

public static readonly long PR_EMS_AB_ASSOC_PROTOCOL_CFG_NNTP_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ASSOC_PROTOCOL_CFG_NNTP_O Field

public static readonly long PR_EMS_AB_ASSOC_PROTOCOL_CFG_NNTP_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ASSOC_PROTOCOL_CFG_NNTP_W Field

public static readonly long PR_EMS_AB_ASSOC_PROTOCOL_CFG_NNTP_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ASSOC_REMOTE_DXA Field

public static readonly long PR_EMS_AB_ASSOC_REMOTE_DXA;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ASSOC_REMOTE_DXA_O Field

public static readonly long PR_EMS_AB_ASSOC_REMOTE_DXA_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ASSOCIATION_LIFETIME Field

public static readonly long PR_EMS_AB_ASSOCIATION_LIFETIME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ATTRIBUTE_CERTIFICATE Field

public static readonly long PR_EMS_AB_ATTRIBUTE_CERTIFICATE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_AUTH_ORIG_BL Field

public static readonly long PR_EMS_AB_AUTH_ORIG_BL;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_AUTH_ORIG_BL_O Field

public static readonly long PR_EMS_AB_AUTH_ORIG_BL_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_AUTHENTICATION_TO_USE Field

public static readonly long PR_EMS_AB_AUTHENTICATION_TO_USE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_AUTHENTICATION_TO_USE_A Field

public static readonly long PR_EMS_AB_AUTHENTICATION_TO_USE_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_AUTHENTICATION_TO_USE_W Field

public static readonly long PR_EMS_AB_AUTHENTICATION_TO_USE_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_AUTHORITY_REVOCATION_LIST Field

public static readonly long PR_EMS_AB_AUTHORITY_REVOCATION_LIST;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_AUTHORIZED_DOMAIN Field

public static readonly long PR_EMS_AB_AUTHORIZED_DOMAIN;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_AUTHORIZED_DOMAIN_A Field

public static readonly long PR_EMS_AB_AUTHORIZED_DOMAIN_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_AUTHORIZED_DOMAIN_W Field

public static readonly long PR_EMS_AB_AUTHORIZED_DOMAIN_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_AUTHORIZED_PASSWORD Field

public static readonly long PR_EMS_AB_AUTHORIZED_PASSWORD;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_AUTHORIZED_PASSWORD_CONFIRM Field

public static readonly long PR_EMS_AB_AUTHORIZED_PASSWORD_CONFIRM;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_AUTHORIZED_USER Field

public static readonly long PR_EMS_AB_AUTHORIZED_USER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_AUTHORIZED_USER_A Field

public static readonly long PR_EMS_AB_AUTHORIZED_USER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_AUTHORIZED_USER_W Field

public static readonly long PR_EMS_AB_AUTHORIZED_USER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_AUTOREPLY Field

public static readonly long PR_EMS_AB_AUTOREPLY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_AUTOREPLY_MESSAGE Field

public static readonly long PR_EMS_AB_AUTOREPLY_MESSAGE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_AUTOREPLY_MESSAGE_A Field

public static readonly long PR_EMS_AB_AUTOREPLY_MESSAGE_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_AUTOREPLY_MESSAGE_W Field

public static readonly long PR_EMS_AB_AUTOREPLY_MESSAGE_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_AUTOREPLY_SUBJECT Field

public static readonly long PR_EMS_AB_AUTOREPLY_SUBJECT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_AUTOREPLY_SUBJECT_A Field

public static readonly long PR_EMS_AB_AUTOREPLY_SUBJECT_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_AUTOREPLY_SUBJECT_W Field

public static readonly long PR_EMS_AB_AUTOREPLY_SUBJECT_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_AVAILABLE_AUTHORIZATION_PACKAGES Field

public static readonly long PR_EMS_AB_AVAILABLE_AUTHORIZATION_PACKAGES;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_AVAILABLE_DISTRIBUTIONS Field

public static readonly long PR_EMS_AB_AVAILABLE_DISTRIBUTIONS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_AVAILABLE_DISTRIBUTIONS_A Field

public static readonly long PR_EMS_AB_AVAILABLE_DISTRIBUTIONS_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_AVAILABLE_DISTRIBUTIONS_W Field

public static readonly long PR_EMS_AB_AVAILABLE_DISTRIBUTIONS_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_BRIDGEHEAD_SERVERS Field

public static readonly long PR_EMS_AB_BRIDGEHEAD_SERVERS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_BRIDGEHEAD_SERVERS_O Field

public static readonly long PR_EMS_AB_BRIDGEHEAD_SERVERS_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_BUSINESS_CATEGORY Field

public static readonly long PR_EMS_AB_BUSINESS_CATEGORY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_BUSINESS_ROLES Field

public static readonly long PR_EMS_AB_BUSINESS_ROLES;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_CA_CERTIFICATE Field

public static readonly long PR_EMS_AB_CA_CERTIFICATE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_CAN_CREATE_PF Field

public static readonly long PR_EMS_AB_CAN_CREATE_PF;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_CAN_CREATE_PF_BL Field

public static readonly long PR_EMS_AB_CAN_CREATE_PF_BL;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_CAN_CREATE_PF_BL_O Field

public static readonly long PR_EMS_AB_CAN_CREATE_PF_BL_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_CAN_CREATE_PF_DL Field

public static readonly long PR_EMS_AB_CAN_CREATE_PF_DL;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_CAN_CREATE_PF_DL_BL Field

public static readonly long PR_EMS_AB_CAN_CREATE_PF_DL_BL;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_CAN_CREATE_PF_DL_BL_O Field

public static readonly long PR_EMS_AB_CAN_CREATE_PF_DL_BL_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_CAN_CREATE_PF_DL_O Field

public static readonly long PR_EMS_AB_CAN_CREATE_PF_DL_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_CAN_CREATE_PF_O Field

public static readonly long PR_EMS_AB_CAN_CREATE_PF_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_CAN_NOT_CREATE_PF Field

public static readonly long PR_EMS_AB_CAN_NOT_CREATE_PF;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_CAN_NOT_CREATE_PF_BL Field

public static readonly long PR_EMS_AB_CAN_NOT_CREATE_PF_BL;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_CAN_NOT_CREATE_PF_BL_O Field

public static readonly long PR_EMS_AB_CAN_NOT_CREATE_PF_BL_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_CAN_NOT_CREATE_PF_DL Field

public static readonly long PR_EMS_AB_CAN_NOT_CREATE_PF_DL;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_CAN_NOT_CREATE_PF_DL_BL Field

public static readonly long PR_EMS_AB_CAN_NOT_CREATE_PF_DL_BL;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_CAN_NOT_CREATE_PF_DL_BL_O Field

public static readonly long PR_EMS_AB_CAN_NOT_CREATE_PF_DL_BL_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_CAN_NOT_CREATE_PF_DL_O Field

public static readonly long PR_EMS_AB_CAN_NOT_CREATE_PF_DL_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_CAN_NOT_CREATE_PF_O Field

public static readonly long PR_EMS_AB_CAN_NOT_CREATE_PF_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_CAN_PRESERVE_DNS Field

public static readonly long PR_EMS_AB_CAN_PRESERVE_DNS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_CERTIFICATE_CHAIN_V3 Field

public static readonly long PR_EMS_AB_CERTIFICATE_CHAIN_V3;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_CERTIFICATE_REVOCATION_LIST Field

public static readonly long PR_EMS_AB_CERTIFICATE_REVOCATION_LIST;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_CERTIFICATE_REVOCATION_LIST_V1 Field

public static readonly long PR_EMS_AB_CERTIFICATE_REVOCATION_LIST_V1;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_CERTIFICATE_REVOCATION_LIST_V3 Field

public static readonly long PR_EMS_AB_CERTIFICATE_REVOCATION_LIST_V3;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_CHARACTER_SET Field

public static readonly long PR_EMS_AB_CHARACTER_SET;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_CHARACTER_SET_A Field

public static readonly long PR_EMS_AB_CHARACTER_SET_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_CHARACTER_SET_LIST Field

public static readonly long PR_EMS_AB_CHARACTER_SET_LIST;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_CHARACTER_SET_W Field

public static readonly long PR_EMS_AB_CHARACTER_SET_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_CHILD_RDNS Field

public static readonly long PR_EMS_AB_CHILD_RDNS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_CLIENT_ACCESS_ENABLED Field

public static readonly long PR_EMS_AB_CLIENT_ACCESS_ENABLED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_CLOCK_ALERT_OFFSET Field

public static readonly long PR_EMS_AB_CLOCK_ALERT_OFFSET;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_CLOCK_ALERT_REPAIR Field

public static readonly long PR_EMS_AB_CLOCK_ALERT_REPAIR;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_CLOCK_WARNING_OFFSET Field

public static readonly long PR_EMS_AB_CLOCK_WARNING_OFFSET;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_CLOCK_WARNING_REPAIR Field

public static readonly long PR_EMS_AB_CLOCK_WARNING_REPAIR;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_COMPROMISED_KEY_LIST Field

public static readonly long PR_EMS_AB_COMPROMISED_KEY_LIST;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_COMPUTER_NAME Field

public static readonly long PR_EMS_AB_COMPUTER_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_COMPUTER_NAME_A Field

public static readonly long PR_EMS_AB_COMPUTER_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_COMPUTER_NAME_W Field

public static readonly long PR_EMS_AB_COMPUTER_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_CONNECTED_DOMAINS Field

public static readonly long PR_EMS_AB_CONNECTED_DOMAINS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_CONNECTION_LIST_FILTER Field

public static readonly long PR_EMS_AB_CONNECTION_LIST_FILTER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_CONNECTION_LIST_FILTER_TYPE Field

public static readonly long PR_EMS_AB_CONNECTION_LIST_FILTER_TYPE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_CONNECTION_TYPE Field

public static readonly long PR_EMS_AB_CONNECTION_TYPE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_CONTAINER_INFO Field

public static readonly long PR_EMS_AB_CONTAINER_INFO;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_CONTAINERID Field

public static readonly long PR_EMS_AB_CONTAINERID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_CONTENT_TYPE Field

public static readonly long PR_EMS_AB_CONTENT_TYPE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_CONTROL_MSG_FOLDER_ID Field

public static readonly long PR_EMS_AB_CONTROL_MSG_FOLDER_ID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_CONTROL_MSG_RULES Field

public static readonly long PR_EMS_AB_CONTROL_MSG_RULES;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_COST Field

public static readonly long PR_EMS_AB_COST;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_COUNTRY_NAME Field

public static readonly long PR_EMS_AB_COUNTRY_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_COUNTRY_NAME_A Field

public static readonly long PR_EMS_AB_COUNTRY_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_COUNTRY_NAME_W Field

public static readonly long PR_EMS_AB_COUNTRY_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_CROSS_CERTIFICATE_CRL Field

public static readonly long PR_EMS_AB_CROSS_CERTIFICATE_CRL;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_CROSS_CERTIFICATE_PAIR Field

public static readonly long PR_EMS_AB_CROSS_CERTIFICATE_PAIR;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DEFAULT_MESSAGE_FORMAT Field

public static readonly long PR_EMS_AB_DEFAULT_MESSAGE_FORMAT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DELEGATE_USER Field

public static readonly long PR_EMS_AB_DELEGATE_USER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DELIV_CONT_LENGTH Field

public static readonly long PR_EMS_AB_DELIV_CONT_LENGTH;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DELIV_EITS Field

public static readonly long PR_EMS_AB_DELIV_EITS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DELIV_EXT_CONT_TYPES Field

public static readonly long PR_EMS_AB_DELIV_EXT_CONT_TYPES;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DELIVER_AND_REDIRECT Field

public static readonly long PR_EMS_AB_DELIVER_AND_REDIRECT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DELIVERY_MECHANISM Field

public static readonly long PR_EMS_AB_DELIVERY_MECHANISM;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DELTA_REVOCATION_LIST Field

public static readonly long PR_EMS_AB_DELTA_REVOCATION_LIST;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DESCRIPTION Field

public static readonly long PR_EMS_AB_DESCRIPTION;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DESTINATION_INDICATOR Field

public static readonly long PR_EMS_AB_DESTINATION_INDICATOR;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DIAGNOSTIC_REG_KEY Field

public static readonly long PR_EMS_AB_DIAGNOSTIC_REG_KEY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DIAGNOSTIC_REG_KEY_A Field

public static readonly long PR_EMS_AB_DIAGNOSTIC_REG_KEY_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DIAGNOSTIC_REG_KEY_W Field

public static readonly long PR_EMS_AB_DIAGNOSTIC_REG_KEY_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DISABLE_DEFERRED_COMMIT Field

public static readonly long PR_EMS_AB_DISABLE_DEFERRED_COMMIT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DISABLED_GATEWAY_PROXY Field

public static readonly long PR_EMS_AB_DISABLED_GATEWAY_PROXY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DISPLAY_NAME_OVERRIDE Field

public static readonly long PR_EMS_AB_DISPLAY_NAME_OVERRIDE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DISPLAY_NAME_PRINTABLE Field

public static readonly long PR_EMS_AB_DISPLAY_NAME_PRINTABLE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DISPLAY_NAME_PRINTABLE_A Field

public static readonly long PR_EMS_AB_DISPLAY_NAME_PRINTABLE_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DISPLAY_NAME_PRINTABLE_W Field

public static readonly long PR_EMS_AB_DISPLAY_NAME_PRINTABLE_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DISPLAY_NAME_SUFFIX Field

public static readonly long PR_EMS_AB_DISPLAY_NAME_SUFFIX;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DISPLAY_NAME_SUFFIX_A Field

public static readonly long PR_EMS_AB_DISPLAY_NAME_SUFFIX_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DISPLAY_NAME_SUFFIX_W Field

public static readonly long PR_EMS_AB_DISPLAY_NAME_SUFFIX_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DL_MEM_REJECT_PERMS_BL Field

public static readonly long PR_EMS_AB_DL_MEM_REJECT_PERMS_BL;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DL_MEM_REJECT_PERMS_BL_O Field

public static readonly long PR_EMS_AB_DL_MEM_REJECT_PERMS_BL_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DL_MEM_SUBMIT_PERMS_BL Field

public static readonly long PR_EMS_AB_DL_MEM_SUBMIT_PERMS_BL;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DL_MEM_SUBMIT_PERMS_BL_O Field

public static readonly long PR_EMS_AB_DL_MEM_SUBMIT_PERMS_BL_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DL_MEMBER_RULE Field

public static readonly long PR_EMS_AB_DL_MEMBER_RULE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DMD_NAME Field

public static readonly long PR_EMS_AB_DMD_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DMD_NAME_A Field

public static readonly long PR_EMS_AB_DMD_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DMD_NAME_W Field

public static readonly long PR_EMS_AB_DMD_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DO_OAB_VERSION Field

public static readonly long PR_EMS_AB_DO_OAB_VERSION;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DOMAIN_DEF_ALT_RECIP Field

public static readonly long PR_EMS_AB_DOMAIN_DEF_ALT_RECIP;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DOMAIN_DEF_ALT_RECIP_A Field

public static readonly long PR_EMS_AB_DOMAIN_DEF_ALT_RECIP_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DOMAIN_DEF_ALT_RECIP_O Field

public static readonly long PR_EMS_AB_DOMAIN_DEF_ALT_RECIP_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DOMAIN_DEF_ALT_RECIP_W Field

public static readonly long PR_EMS_AB_DOMAIN_DEF_ALT_RECIP_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DOMAIN_NAME Field

public static readonly long PR_EMS_AB_DOMAIN_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DOMAIN_NAME_A Field

public static readonly long PR_EMS_AB_DOMAIN_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DOMAIN_NAME_W Field

public static readonly long PR_EMS_AB_DOMAIN_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DOS_ENTRYID Field

public static readonly long PR_EMS_AB_DOS_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DSA_SIGNATURE Field

public static readonly long PR_EMS_AB_DSA_SIGNATURE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_ADMIN_COPY Field

public static readonly long PR_EMS_AB_DXA_ADMIN_COPY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_ADMIN_FORWARD Field

public static readonly long PR_EMS_AB_DXA_ADMIN_FORWARD;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_ADMIN_UPDATE Field

public static readonly long PR_EMS_AB_DXA_ADMIN_UPDATE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_APPEND_REQCN Field

public static readonly long PR_EMS_AB_DXA_APPEND_REQCN;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_CONF_CONTAINER_LIST Field

public static readonly long PR_EMS_AB_DXA_CONF_CONTAINER_LIST;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_CONF_CONTAINER_LIST_O Field

public static readonly long PR_EMS_AB_DXA_CONF_CONTAINER_LIST_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_CONF_REQ_TIME Field

public static readonly long PR_EMS_AB_DXA_CONF_REQ_TIME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_CONF_SEQ Field

public static readonly long PR_EMS_AB_DXA_CONF_SEQ;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_CONF_SEQ_A Field

public static readonly long PR_EMS_AB_DXA_CONF_SEQ_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_CONF_SEQ_USN Field

public static readonly long PR_EMS_AB_DXA_CONF_SEQ_USN;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_CONF_SEQ_W Field

public static readonly long PR_EMS_AB_DXA_CONF_SEQ_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_EXCHANGE_OPTIONS Field

public static readonly long PR_EMS_AB_DXA_EXCHANGE_OPTIONS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_EXPORT_NOW Field

public static readonly long PR_EMS_AB_DXA_EXPORT_NOW;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_FLAGS Field

public static readonly long PR_EMS_AB_DXA_FLAGS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_IMP_SEQ Field

public static readonly long PR_EMS_AB_DXA_IMP_SEQ;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_IMP_SEQ_A Field

public static readonly long PR_EMS_AB_DXA_IMP_SEQ_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_IMP_SEQ_TIME Field

public static readonly long PR_EMS_AB_DXA_IMP_SEQ_TIME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_IMP_SEQ_USN Field

public static readonly long PR_EMS_AB_DXA_IMP_SEQ_USN;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_IMP_SEQ_W Field

public static readonly long PR_EMS_AB_DXA_IMP_SEQ_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_IMPORT_NOW Field

public static readonly long PR_EMS_AB_DXA_IMPORT_NOW;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_IN_TEMPLATE_MAP Field

public static readonly long PR_EMS_AB_DXA_IN_TEMPLATE_MAP;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_LOCAL_ADMIN Field

public static readonly long PR_EMS_AB_DXA_LOCAL_ADMIN;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_LOCAL_ADMIN_A Field

public static readonly long PR_EMS_AB_DXA_LOCAL_ADMIN_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_LOCAL_ADMIN_O Field

public static readonly long PR_EMS_AB_DXA_LOCAL_ADMIN_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_LOCAL_ADMIN_W Field

public static readonly long PR_EMS_AB_DXA_LOCAL_ADMIN_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_LOGGING_LEVEL Field

public static readonly long PR_EMS_AB_DXA_LOGGING_LEVEL;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_NATIVE_ADDRESS_TYPE Field

public static readonly long PR_EMS_AB_DXA_NATIVE_ADDRESS_TYPE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_NATIVE_ADDRESS_TYPE_A Field

public static readonly long PR_EMS_AB_DXA_NATIVE_ADDRESS_TYPE_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_NATIVE_ADDRESS_TYPE_W Field

public static readonly long PR_EMS_AB_DXA_NATIVE_ADDRESS_TYPE_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_OUT_TEMPLATE_MAP Field

public static readonly long PR_EMS_AB_DXA_OUT_TEMPLATE_MAP;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_PASSWORD Field

public static readonly long PR_EMS_AB_DXA_PASSWORD;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_PASSWORD_A Field

public static readonly long PR_EMS_AB_DXA_PASSWORD_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_PASSWORD_W Field

public static readonly long PR_EMS_AB_DXA_PASSWORD_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_PREV_EXCHANGE_OPTIONS Field

public static readonly long PR_EMS_AB_DXA_PREV_EXCHANGE_OPTIONS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_PREV_EXPORT_NATIVE_ONLY Field

public static readonly long PR_EMS_AB_DXA_PREV_EXPORT_NATIVE_ONLY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_PREV_IN_EXCHANGE_SENSITIVITY Field

public static readonly long PR_EMS_AB_DXA_PREV_IN_EXCHANGE_SENSITIVITY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_PREV_REMOTE_ENTRIES Field

public static readonly long PR_EMS_AB_DXA_PREV_REMOTE_ENTRIES;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_PREV_REMOTE_ENTRIES_A Field

public static readonly long PR_EMS_AB_DXA_PREV_REMOTE_ENTRIES_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_PREV_REMOTE_ENTRIES_O Field

public static readonly long PR_EMS_AB_DXA_PREV_REMOTE_ENTRIES_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_PREV_REMOTE_ENTRIES_W Field

public static readonly long PR_EMS_AB_DXA_PREV_REMOTE_ENTRIES_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_PREV_REPLICATION_SENSITIVITY Field

public static readonly long PR_EMS_AB_DXA_PREV_REPLICATION_SENSITIVITY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_PREV_TEMPLATE_OPTIONS Field

public static readonly long PR_EMS_AB_DXA_PREV_TEMPLATE_OPTIONS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_PREV_TYPES Field

public static readonly long PR_EMS_AB_DXA_PREV_TYPES;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_RECIPIENT_CP Field

public static readonly long PR_EMS_AB_DXA_RECIPIENT_CP;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_RECIPIENT_CP_A Field

public static readonly long PR_EMS_AB_DXA_RECIPIENT_CP_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_RECIPIENT_CP_W Field

public static readonly long PR_EMS_AB_DXA_RECIPIENT_CP_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_REMOTE_CLIENT Field

public static readonly long PR_EMS_AB_DXA_REMOTE_CLIENT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_REMOTE_CLIENT_A Field

public static readonly long PR_EMS_AB_DXA_REMOTE_CLIENT_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_REMOTE_CLIENT_O Field

public static readonly long PR_EMS_AB_DXA_REMOTE_CLIENT_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_REMOTE_CLIENT_W Field

public static readonly long PR_EMS_AB_DXA_REMOTE_CLIENT_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_REQ_SEQ Field

public static readonly long PR_EMS_AB_DXA_REQ_SEQ;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_REQ_SEQ_A Field

public static readonly long PR_EMS_AB_DXA_REQ_SEQ_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_REQ_SEQ_TIME Field

public static readonly long PR_EMS_AB_DXA_REQ_SEQ_TIME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_REQ_SEQ_USN Field

public static readonly long PR_EMS_AB_DXA_REQ_SEQ_USN;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_REQ_SEQ_W Field

public static readonly long PR_EMS_AB_DXA_REQ_SEQ_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_REQNAME Field

public static readonly long PR_EMS_AB_DXA_REQNAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_REQNAME_A Field

public static readonly long PR_EMS_AB_DXA_REQNAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_REQNAME_W Field

public static readonly long PR_EMS_AB_DXA_REQNAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_SVR_SEQ Field

public static readonly long PR_EMS_AB_DXA_SVR_SEQ;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_SVR_SEQ_A Field

public static readonly long PR_EMS_AB_DXA_SVR_SEQ_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_SVR_SEQ_TIME Field

public static readonly long PR_EMS_AB_DXA_SVR_SEQ_TIME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_SVR_SEQ_USN Field

public static readonly long PR_EMS_AB_DXA_SVR_SEQ_USN;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_SVR_SEQ_W Field

public static readonly long PR_EMS_AB_DXA_SVR_SEQ_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_TASK Field

public static readonly long PR_EMS_AB_DXA_TASK;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_TEMPLATE_OPTIONS Field

public static readonly long PR_EMS_AB_DXA_TEMPLATE_OPTIONS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_TEMPLATE_TIMESTAMP Field

public static readonly long PR_EMS_AB_DXA_TEMPLATE_TIMESTAMP;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_TYPES Field

public static readonly long PR_EMS_AB_DXA_TYPES;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_UNCONF_CONTAINER_LIST Field

public static readonly long PR_EMS_AB_DXA_UNCONF_CONTAINER_LIST;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_DXA_UNCONF_CONTAINER_LIST_O Field

public static readonly long PR_EMS_AB_DXA_UNCONF_CONTAINER_LIST_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EMPLOYEE_NUMBER Field

public static readonly long PR_EMS_AB_EMPLOYEE_NUMBER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EMPLOYEE_NUMBER_A Field

public static readonly long PR_EMS_AB_EMPLOYEE_NUMBER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EMPLOYEE_NUMBER_W Field

public static readonly long PR_EMS_AB_EMPLOYEE_NUMBER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EMPLOYEE_TYPE Field

public static readonly long PR_EMS_AB_EMPLOYEE_TYPE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EMPLOYEE_TYPE_A Field

public static readonly long PR_EMS_AB_EMPLOYEE_TYPE_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EMPLOYEE_TYPE_W Field

public static readonly long PR_EMS_AB_EMPLOYEE_TYPE_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ENABLE_COMPATIBILITY Field

public static readonly long PR_EMS_AB_ENABLE_COMPATIBILITY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ENABLED Field

public static readonly long PR_EMS_AB_ENABLED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ENABLED_AUTHORIZATION_PACKAGES Field

public static readonly long PR_EMS_AB_ENABLED_AUTHORIZATION_PACKAGES;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ENABLED_PROTOCOL_CFG Field

public static readonly long PR_EMS_AB_ENABLED_PROTOCOL_CFG;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ENABLED_PROTOCOLS Field

public static readonly long PR_EMS_AB_ENABLED_PROTOCOLS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ENCAPSULATION_METHOD Field

public static readonly long PR_EMS_AB_ENCAPSULATION_METHOD;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ENCRYPT Field

public static readonly long PR_EMS_AB_ENCRYPT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ENCRYPT_ALG_LIST_NA Field

public static readonly long PR_EMS_AB_ENCRYPT_ALG_LIST_NA;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ENCRYPT_ALG_LIST_OTHER Field

public static readonly long PR_EMS_AB_ENCRYPT_ALG_LIST_OTHER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ENCRYPT_ALG_SELECTED_NA Field

public static readonly long PR_EMS_AB_ENCRYPT_ALG_SELECTED_NA;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ENCRYPT_ALG_SELECTED_NA_A Field

public static readonly long PR_EMS_AB_ENCRYPT_ALG_SELECTED_NA_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ENCRYPT_ALG_SELECTED_NA_W Field

public static readonly long PR_EMS_AB_ENCRYPT_ALG_SELECTED_NA_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ENCRYPT_ALG_SELECTED_OTHER Field

public static readonly long PR_EMS_AB_ENCRYPT_ALG_SELECTED_OTHER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ENCRYPT_ALG_SELECTED_OTHER_A Field

public static readonly long PR_EMS_AB_ENCRYPT_ALG_SELECTED_OTHER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ENCRYPT_ALG_SELECTED_OTHER_W Field

public static readonly long PR_EMS_AB_ENCRYPT_ALG_SELECTED_OTHER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXPAND_DLS_LOCALLY Field

public static readonly long PR_EMS_AB_EXPAND_DLS_LOCALLY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXPIRATION_TIME Field

public static readonly long PR_EMS_AB_EXPIRATION_TIME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXPORT_CONTAINERS Field

public static readonly long PR_EMS_AB_EXPORT_CONTAINERS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXPORT_CONTAINERS_O Field

public static readonly long PR_EMS_AB_EXPORT_CONTAINERS_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXPORT_CUSTOM_RECIPIENTS Field

public static readonly long PR_EMS_AB_EXPORT_CUSTOM_RECIPIENTS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENDED_CHARS_ALLOWED Field

public static readonly long PR_EMS_AB_EXTENDED_CHARS_ALLOWED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_ATTRIBUTE_1 Field

public static readonly long PR_EMS_AB_EXTENSION_ATTRIBUTE_1;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_ATTRIBUTE_1_A Field

public static readonly long PR_EMS_AB_EXTENSION_ATTRIBUTE_1_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_ATTRIBUTE_1_W Field

public static readonly long PR_EMS_AB_EXTENSION_ATTRIBUTE_1_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_ATTRIBUTE_10 Field

public static readonly long PR_EMS_AB_EXTENSION_ATTRIBUTE_10;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_ATTRIBUTE_10_A Field

public static readonly long PR_EMS_AB_EXTENSION_ATTRIBUTE_10_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_ATTRIBUTE_10_W Field

public static readonly long PR_EMS_AB_EXTENSION_ATTRIBUTE_10_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_ATTRIBUTE_11 Field

public static readonly long PR_EMS_AB_EXTENSION_ATTRIBUTE_11;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_ATTRIBUTE_11_A Field

public static readonly long PR_EMS_AB_EXTENSION_ATTRIBUTE_11_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_ATTRIBUTE_11_W Field

public static readonly long PR_EMS_AB_EXTENSION_ATTRIBUTE_11_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_ATTRIBUTE_12 Field

public static readonly long PR_EMS_AB_EXTENSION_ATTRIBUTE_12;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_ATTRIBUTE_12_A Field

public static readonly long PR_EMS_AB_EXTENSION_ATTRIBUTE_12_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_ATTRIBUTE_12_W Field

public static readonly long PR_EMS_AB_EXTENSION_ATTRIBUTE_12_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_ATTRIBUTE_13 Field

public static readonly long PR_EMS_AB_EXTENSION_ATTRIBUTE_13;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_ATTRIBUTE_13_A Field

public static readonly long PR_EMS_AB_EXTENSION_ATTRIBUTE_13_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_ATTRIBUTE_13_W Field

public static readonly long PR_EMS_AB_EXTENSION_ATTRIBUTE_13_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_ATTRIBUTE_14 Field

public static readonly long PR_EMS_AB_EXTENSION_ATTRIBUTE_14;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_ATTRIBUTE_14_A Field

public static readonly long PR_EMS_AB_EXTENSION_ATTRIBUTE_14_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_ATTRIBUTE_14_W Field

public static readonly long PR_EMS_AB_EXTENSION_ATTRIBUTE_14_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_ATTRIBUTE_15 Field

public static readonly long PR_EMS_AB_EXTENSION_ATTRIBUTE_15;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_ATTRIBUTE_15_A Field

public static readonly long PR_EMS_AB_EXTENSION_ATTRIBUTE_15_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_ATTRIBUTE_15_W Field

public static readonly long PR_EMS_AB_EXTENSION_ATTRIBUTE_15_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_ATTRIBUTE_2 Field

public static readonly long PR_EMS_AB_EXTENSION_ATTRIBUTE_2;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_ATTRIBUTE_2_A Field

public static readonly long PR_EMS_AB_EXTENSION_ATTRIBUTE_2_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_ATTRIBUTE_2_W Field

public static readonly long PR_EMS_AB_EXTENSION_ATTRIBUTE_2_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_ATTRIBUTE_3 Field

public static readonly long PR_EMS_AB_EXTENSION_ATTRIBUTE_3;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_ATTRIBUTE_3_A Field

public static readonly long PR_EMS_AB_EXTENSION_ATTRIBUTE_3_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_ATTRIBUTE_3_W Field

public static readonly long PR_EMS_AB_EXTENSION_ATTRIBUTE_3_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_ATTRIBUTE_4 Field

public static readonly long PR_EMS_AB_EXTENSION_ATTRIBUTE_4;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_ATTRIBUTE_4_A Field

public static readonly long PR_EMS_AB_EXTENSION_ATTRIBUTE_4_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_ATTRIBUTE_4_W Field

public static readonly long PR_EMS_AB_EXTENSION_ATTRIBUTE_4_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_ATTRIBUTE_5 Field

public static readonly long PR_EMS_AB_EXTENSION_ATTRIBUTE_5;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_ATTRIBUTE_5_A Field

public static readonly long PR_EMS_AB_EXTENSION_ATTRIBUTE_5_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_ATTRIBUTE_5_W Field

public static readonly long PR_EMS_AB_EXTENSION_ATTRIBUTE_5_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_ATTRIBUTE_6 Field

public static readonly long PR_EMS_AB_EXTENSION_ATTRIBUTE_6;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_ATTRIBUTE_6_A Field

public static readonly long PR_EMS_AB_EXTENSION_ATTRIBUTE_6_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_ATTRIBUTE_6_W Field

public static readonly long PR_EMS_AB_EXTENSION_ATTRIBUTE_6_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_ATTRIBUTE_7 Field

public static readonly long PR_EMS_AB_EXTENSION_ATTRIBUTE_7;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_ATTRIBUTE_7_A Field

public static readonly long PR_EMS_AB_EXTENSION_ATTRIBUTE_7_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_ATTRIBUTE_7_W Field

public static readonly long PR_EMS_AB_EXTENSION_ATTRIBUTE_7_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_ATTRIBUTE_8 Field

public static readonly long PR_EMS_AB_EXTENSION_ATTRIBUTE_8;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_ATTRIBUTE_8_A Field

public static readonly long PR_EMS_AB_EXTENSION_ATTRIBUTE_8_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_ATTRIBUTE_8_W Field

public static readonly long PR_EMS_AB_EXTENSION_ATTRIBUTE_8_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_ATTRIBUTE_9 Field

public static readonly long PR_EMS_AB_EXTENSION_ATTRIBUTE_9;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_ATTRIBUTE_9_A Field

public static readonly long PR_EMS_AB_EXTENSION_ATTRIBUTE_9_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_ATTRIBUTE_9_W Field

public static readonly long PR_EMS_AB_EXTENSION_ATTRIBUTE_9_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_DATA Field

public static readonly long PR_EMS_AB_EXTENSION_DATA;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_NAME Field

public static readonly long PR_EMS_AB_EXTENSION_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_EXTENSION_NAME_INHERITED Field

public static readonly long PR_EMS_AB_EXTENSION_NAME_INHERITED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_FACSIMILE_TELEPHONE_NUMBER Field

public static readonly long PR_EMS_AB_FACSIMILE_TELEPHONE_NUMBER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_FILE_VERSION Field

public static readonly long PR_EMS_AB_FILE_VERSION;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_FILTER_LOCAL_ADDRESSES Field

public static readonly long PR_EMS_AB_FILTER_LOCAL_ADDRESSES;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_FOLDER_PATHNAME Field

public static readonly long PR_EMS_AB_FOLDER_PATHNAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_FOLDER_PATHNAME_A Field

public static readonly long PR_EMS_AB_FOLDER_PATHNAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_FOLDER_PATHNAME_W Field

public static readonly long PR_EMS_AB_FOLDER_PATHNAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_FOLDERS_CONTAINER Field

public static readonly long PR_EMS_AB_FOLDERS_CONTAINER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_FOLDERS_CONTAINER_A Field

public static readonly long PR_EMS_AB_FOLDERS_CONTAINER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_FOLDERS_CONTAINER_O Field

public static readonly long PR_EMS_AB_FOLDERS_CONTAINER_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_FOLDERS_CONTAINER_W Field

public static readonly long PR_EMS_AB_FOLDERS_CONTAINER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_FORM_DATA Field

public static readonly long PR_EMS_AB_FORM_DATA;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_FORWARDING_ADDRESS Field

public static readonly long PR_EMS_AB_FORWARDING_ADDRESS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_FORWARDING_ADDRESS_A Field

public static readonly long PR_EMS_AB_FORWARDING_ADDRESS_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_FORWARDING_ADDRESS_W Field

public static readonly long PR_EMS_AB_FORWARDING_ADDRESS_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_GARBAGE_COLL_PERIOD Field

public static readonly long PR_EMS_AB_GARBAGE_COLL_PERIOD;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_GATEWAY_LOCAL_CRED Field

public static readonly long PR_EMS_AB_GATEWAY_LOCAL_CRED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_GATEWAY_LOCAL_CRED_A Field

public static readonly long PR_EMS_AB_GATEWAY_LOCAL_CRED_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_GATEWAY_LOCAL_CRED_W Field

public static readonly long PR_EMS_AB_GATEWAY_LOCAL_CRED_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_GATEWAY_LOCAL_DESIG Field

public static readonly long PR_EMS_AB_GATEWAY_LOCAL_DESIG;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_GATEWAY_LOCAL_DESIG_A Field

public static readonly long PR_EMS_AB_GATEWAY_LOCAL_DESIG_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_GATEWAY_LOCAL_DESIG_W Field

public static readonly long PR_EMS_AB_GATEWAY_LOCAL_DESIG_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_GATEWAY_PROXY Field

public static readonly long PR_EMS_AB_GATEWAY_PROXY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_GATEWAY_ROUTING_TREE Field

public static readonly long PR_EMS_AB_GATEWAY_ROUTING_TREE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_GENERATION_QUALIFIER Field

public static readonly long PR_EMS_AB_GENERATION_QUALIFIER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_GENERATION_QUALIFIER_A Field

public static readonly long PR_EMS_AB_GENERATION_QUALIFIER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_GENERATION_QUALIFIER_W Field

public static readonly long PR_EMS_AB_GENERATION_QUALIFIER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_GROUP_BY_ATTR_1 Field

public static readonly long PR_EMS_AB_GROUP_BY_ATTR_1;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_GROUP_BY_ATTR_1_A Field

public static readonly long PR_EMS_AB_GROUP_BY_ATTR_1_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_GROUP_BY_ATTR_1_W Field

public static readonly long PR_EMS_AB_GROUP_BY_ATTR_1_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_GROUP_BY_ATTR_2 Field

public static readonly long PR_EMS_AB_GROUP_BY_ATTR_2;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_GROUP_BY_ATTR_2_A Field

public static readonly long PR_EMS_AB_GROUP_BY_ATTR_2_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_GROUP_BY_ATTR_2_W Field

public static readonly long PR_EMS_AB_GROUP_BY_ATTR_2_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_GROUP_BY_ATTR_3 Field

public static readonly long PR_EMS_AB_GROUP_BY_ATTR_3;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_GROUP_BY_ATTR_3_A Field

public static readonly long PR_EMS_AB_GROUP_BY_ATTR_3_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_GROUP_BY_ATTR_3_W Field

public static readonly long PR_EMS_AB_GROUP_BY_ATTR_3_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_GROUP_BY_ATTR_4 Field

public static readonly long PR_EMS_AB_GROUP_BY_ATTR_4;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_GROUP_BY_ATTR_4_A Field

public static readonly long PR_EMS_AB_GROUP_BY_ATTR_4_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_GROUP_BY_ATTR_4_W Field

public static readonly long PR_EMS_AB_GROUP_BY_ATTR_4_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_GROUP_BY_ATTR_VALUE_DN Field

public static readonly long PR_EMS_AB_GROUP_BY_ATTR_VALUE_DN;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_GROUP_BY_ATTR_VALUE_DN_A Field

public static readonly long PR_EMS_AB_GROUP_BY_ATTR_VALUE_DN_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_GROUP_BY_ATTR_VALUE_DN_O Field

public static readonly long PR_EMS_AB_GROUP_BY_ATTR_VALUE_DN_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_GROUP_BY_ATTR_VALUE_DN_W Field

public static readonly long PR_EMS_AB_GROUP_BY_ATTR_VALUE_DN_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_GROUP_BY_ATTR_VALUE_STR Field

public static readonly long PR_EMS_AB_GROUP_BY_ATTR_VALUE_STR;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_GROUP_BY_ATTR_VALUE_STR_A Field

public static readonly long PR_EMS_AB_GROUP_BY_ATTR_VALUE_STR_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_GROUP_BY_ATTR_VALUE_STR_W Field

public static readonly long PR_EMS_AB_GROUP_BY_ATTR_VALUE_STR_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_GWART_LAST_MODIFIED Field

public static readonly long PR_EMS_AB_GWART_LAST_MODIFIED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_HAS_FULL_REPLICA_NCS Field

public static readonly long PR_EMS_AB_HAS_FULL_REPLICA_NCS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_HAS_FULL_REPLICA_NCS_O Field

public static readonly long PR_EMS_AB_HAS_FULL_REPLICA_NCS_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_HAS_MASTER_NCS Field

public static readonly long PR_EMS_AB_HAS_MASTER_NCS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_HAS_MASTER_NCS_O Field

public static readonly long PR_EMS_AB_HAS_MASTER_NCS_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_HELP_DATA16 Field

public static readonly long PR_EMS_AB_HELP_DATA16;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_HELP_DATA32 Field

public static readonly long PR_EMS_AB_HELP_DATA32;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_HELP_FILE_NAME Field

public static readonly long PR_EMS_AB_HELP_FILE_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_HELP_FILE_NAME_A Field

public static readonly long PR_EMS_AB_HELP_FILE_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_HELP_FILE_NAME_W Field

public static readonly long PR_EMS_AB_HELP_FILE_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_HEURISTICS Field

public static readonly long PR_EMS_AB_HEURISTICS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_HIDE_DL_MEMBERSHIP Field

public static readonly long PR_EMS_AB_HIDE_DL_MEMBERSHIP;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_HIDE_FROM_ADDRESS_BOOK Field

public static readonly long PR_EMS_AB_HIDE_FROM_ADDRESS_BOOK;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_HIERARCHY_PATH Field

public static readonly long PR_EMS_AB_HIERARCHY_PATH;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_HIERARCHY_PATH_A Field

public static readonly long PR_EMS_AB_HIERARCHY_PATH_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_HIERARCHY_PATH_W Field

public static readonly long PR_EMS_AB_HIERARCHY_PATH_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_HOME_MDB Field

public static readonly long PR_EMS_AB_HOME_MDB;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_HOME_MDB_A Field

public static readonly long PR_EMS_AB_HOME_MDB_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_HOME_MDB_BL Field

public static readonly long PR_EMS_AB_HOME_MDB_BL;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_HOME_MDB_BL_O Field

public static readonly long PR_EMS_AB_HOME_MDB_BL_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_HOME_MDB_O Field

public static readonly long PR_EMS_AB_HOME_MDB_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_HOME_MDB_W Field

public static readonly long PR_EMS_AB_HOME_MDB_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_HOME_MTA Field

public static readonly long PR_EMS_AB_HOME_MTA;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_HOME_MTA_A Field

public static readonly long PR_EMS_AB_HOME_MTA_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_HOME_MTA_O Field

public static readonly long PR_EMS_AB_HOME_MTA_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_HOME_MTA_W Field

public static readonly long PR_EMS_AB_HOME_MTA_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_HOME_PUBLIC_SERVER Field

public static readonly long PR_EMS_AB_HOME_PUBLIC_SERVER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_HOME_PUBLIC_SERVER_A Field

public static readonly long PR_EMS_AB_HOME_PUBLIC_SERVER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_HOME_PUBLIC_SERVER_O Field

public static readonly long PR_EMS_AB_HOME_PUBLIC_SERVER_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_HOME_PUBLIC_SERVER_W Field

public static readonly long PR_EMS_AB_HOME_PUBLIC_SERVER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_HOUSE_IDENTIFIER Field

public static readonly long PR_EMS_AB_HOUSE_IDENTIFIER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_HOUSE_IDENTIFIER_A Field

public static readonly long PR_EMS_AB_HOUSE_IDENTIFIER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_HOUSE_IDENTIFIER_W Field

public static readonly long PR_EMS_AB_HOUSE_IDENTIFIER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_HTTP_PUB_AB_ATTRIBUTES Field

public static readonly long PR_EMS_AB_HTTP_PUB_AB_ATTRIBUTES;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_HTTP_PUB_GAL Field

public static readonly long PR_EMS_AB_HTTP_PUB_GAL;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_HTTP_PUB_GAL_LIMIT Field

public static readonly long PR_EMS_AB_HTTP_PUB_GAL_LIMIT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_HTTP_PUB_PF Field

public static readonly long PR_EMS_AB_HTTP_PUB_PF;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_HTTP_SERVERS Field

public static readonly long PR_EMS_AB_HTTP_SERVERS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_IMPORT_CONTAINER Field

public static readonly long PR_EMS_AB_IMPORT_CONTAINER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_IMPORT_CONTAINER_A Field

public static readonly long PR_EMS_AB_IMPORT_CONTAINER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_IMPORT_CONTAINER_O Field

public static readonly long PR_EMS_AB_IMPORT_CONTAINER_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_IMPORT_CONTAINER_W Field

public static readonly long PR_EMS_AB_IMPORT_CONTAINER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_IMPORT_SENSITIVITY Field

public static readonly long PR_EMS_AB_IMPORT_SENSITIVITY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_IMPORTED_FROM Field

public static readonly long PR_EMS_AB_IMPORTED_FROM;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_IMPORTED_FROM_A Field

public static readonly long PR_EMS_AB_IMPORTED_FROM_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_IMPORTED_FROM_W Field

public static readonly long PR_EMS_AB_IMPORTED_FROM_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_INBOUND_ACCEPT_ALL Field

public static readonly long PR_EMS_AB_INBOUND_ACCEPT_ALL;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_INBOUND_DN Field

public static readonly long PR_EMS_AB_INBOUND_DN;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_INBOUND_DN_A Field

public static readonly long PR_EMS_AB_INBOUND_DN_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_INBOUND_DN_O Field

public static readonly long PR_EMS_AB_INBOUND_DN_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_INBOUND_DN_W Field

public static readonly long PR_EMS_AB_INBOUND_DN_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_INBOUND_HOST Field

public static readonly long PR_EMS_AB_INBOUND_HOST;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_INBOUND_NEWSFEED Field

public static readonly long PR_EMS_AB_INBOUND_NEWSFEED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_INBOUND_NEWSFEED_A Field

public static readonly long PR_EMS_AB_INBOUND_NEWSFEED_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_INBOUND_NEWSFEED_TYPE Field

public static readonly long PR_EMS_AB_INBOUND_NEWSFEED_TYPE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_INBOUND_NEWSFEED_W Field

public static readonly long PR_EMS_AB_INBOUND_NEWSFEED_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_INBOUND_SITES Field

public static readonly long PR_EMS_AB_INBOUND_SITES;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_INBOUND_SITES_O Field

public static readonly long PR_EMS_AB_INBOUND_SITES_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_INCOMING_MSG_SIZE_LIMIT Field

public static readonly long PR_EMS_AB_INCOMING_MSG_SIZE_LIMIT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_INCOMING_PASSWORD Field

public static readonly long PR_EMS_AB_INCOMING_PASSWORD;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_INSADMIN Field

public static readonly long PR_EMS_AB_INSADMIN;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_INSADMIN_A Field

public static readonly long PR_EMS_AB_INSADMIN_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_INSADMIN_O Field

public static readonly long PR_EMS_AB_INSADMIN_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_INSADMIN_W Field

public static readonly long PR_EMS_AB_INSADMIN_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_INSTANCE_TYPE Field

public static readonly long PR_EMS_AB_INSTANCE_TYPE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_INTERNATIONAL_ISDN_NUMBER Field

public static readonly long PR_EMS_AB_INTERNATIONAL_ISDN_NUMBER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_INVOCATION_ID Field

public static readonly long PR_EMS_AB_INVOCATION_ID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_IS_DELETED Field

public static readonly long PR_EMS_AB_IS_DELETED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_IS_MASTER Field

public static readonly long PR_EMS_AB_IS_MASTER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_IS_MEMBER_OF_DL Field

public static readonly long PR_EMS_AB_IS_MEMBER_OF_DL;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_IS_MEMBER_OF_DL_T Field

public static readonly long PR_EMS_AB_IS_MEMBER_OF_DL_T;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_IS_MEMBER_OF_DL_T_A Field

public static readonly long PR_EMS_AB_IS_MEMBER_OF_DL_T_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_IS_MEMBER_OF_DL_T_W Field

public static readonly long PR_EMS_AB_IS_MEMBER_OF_DL_T_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_IS_SINGLE_VALUED Field

public static readonly long PR_EMS_AB_IS_SINGLE_VALUED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_KCC_STATUS Field

public static readonly long PR_EMS_AB_KCC_STATUS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_KM_SERVER Field

public static readonly long PR_EMS_AB_KM_SERVER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_KM_SERVER_A Field

public static readonly long PR_EMS_AB_KM_SERVER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_KM_SERVER_O Field

public static readonly long PR_EMS_AB_KM_SERVER_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_KM_SERVER_W Field

public static readonly long PR_EMS_AB_KM_SERVER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_KNOWLEDGE_INFORMATION Field

public static readonly long PR_EMS_AB_KNOWLEDGE_INFORMATION;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_LABELEDURI Field

public static readonly long PR_EMS_AB_LABELEDURI;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_LABELEDURI_A Field

public static readonly long PR_EMS_AB_LABELEDURI_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_LABELEDURI_W Field

public static readonly long PR_EMS_AB_LABELEDURI_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_LANGUAGE Field

public static readonly long PR_EMS_AB_LANGUAGE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_LANGUAGE_ISO639 Field

public static readonly long PR_EMS_AB_LANGUAGE_ISO639;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_LANGUAGE_ISO639_A Field

public static readonly long PR_EMS_AB_LANGUAGE_ISO639_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_LANGUAGE_ISO639_W Field

public static readonly long PR_EMS_AB_LANGUAGE_ISO639_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_LDAP_DISPLAY_NAME Field

public static readonly long PR_EMS_AB_LDAP_DISPLAY_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_LDAP_SEARCH_CFG Field

public static readonly long PR_EMS_AB_LDAP_SEARCH_CFG;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_LINE_WRAP Field

public static readonly long PR_EMS_AB_LINE_WRAP;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_LINK_ID Field

public static readonly long PR_EMS_AB_LINK_ID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_LIST_PUBLIC_FOLDERS Field

public static readonly long PR_EMS_AB_LIST_PUBLIC_FOLDERS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_LOCAL_BRIDGE_HEAD Field

public static readonly long PR_EMS_AB_LOCAL_BRIDGE_HEAD;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_LOCAL_BRIDGE_HEAD_A Field

public static readonly long PR_EMS_AB_LOCAL_BRIDGE_HEAD_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_LOCAL_BRIDGE_HEAD_ADDRESS Field

public static readonly long PR_EMS_AB_LOCAL_BRIDGE_HEAD_ADDRESS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_LOCAL_BRIDGE_HEAD_ADDRESS_A Field

public static readonly long PR_EMS_AB_LOCAL_BRIDGE_HEAD_ADDRESS_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_LOCAL_BRIDGE_HEAD_ADDRESS_W Field

public static readonly long PR_EMS_AB_LOCAL_BRIDGE_HEAD_ADDRESS_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_LOCAL_BRIDGE_HEAD_W Field

public static readonly long PR_EMS_AB_LOCAL_BRIDGE_HEAD_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_LOCAL_INITIAL_TURN Field

public static readonly long PR_EMS_AB_LOCAL_INITIAL_TURN;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_LOCAL_SCOPE Field

public static readonly long PR_EMS_AB_LOCAL_SCOPE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_LOCAL_SCOPE_O Field

public static readonly long PR_EMS_AB_LOCAL_SCOPE_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_LOG_FILENAME Field

public static readonly long PR_EMS_AB_LOG_FILENAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_LOG_FILENAME_A Field

public static readonly long PR_EMS_AB_LOG_FILENAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_LOG_FILENAME_W Field

public static readonly long PR_EMS_AB_LOG_FILENAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_LOG_ROLLOVER_INTERVAL Field

public static readonly long PR_EMS_AB_LOG_ROLLOVER_INTERVAL;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MAIL_DROP Field

public static readonly long PR_EMS_AB_MAIL_DROP;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MAIL_DROP_A Field

public static readonly long PR_EMS_AB_MAIL_DROP_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MAIL_DROP_W Field

public static readonly long PR_EMS_AB_MAIL_DROP_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MAINTAIN_AUTOREPLY_HISTORY Field

public static readonly long PR_EMS_AB_MAINTAIN_AUTOREPLY_HISTORY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MANAGER Field

public static readonly long PR_EMS_AB_MANAGER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MANAGER_T Field

public static readonly long PR_EMS_AB_MANAGER_T;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MANAGER_T_A Field

public static readonly long PR_EMS_AB_MANAGER_T_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MANAGER_T_W Field

public static readonly long PR_EMS_AB_MANAGER_T_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MAPI_DISPLAY_TYPE Field

public static readonly long PR_EMS_AB_MAPI_DISPLAY_TYPE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MAPI_ID Field

public static readonly long PR_EMS_AB_MAPI_ID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MAXIMUM_OBJECT_ID Field

public static readonly long PR_EMS_AB_MAXIMUM_OBJECT_ID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MDB_BACKOFF_INTERVAL Field

public static readonly long PR_EMS_AB_MDB_BACKOFF_INTERVAL;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MDB_MSG_TIME_OUT_PERIOD Field

public static readonly long PR_EMS_AB_MDB_MSG_TIME_OUT_PERIOD;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MDB_OVER_QUOTA_LIMIT Field

public static readonly long PR_EMS_AB_MDB_OVER_QUOTA_LIMIT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MDB_STORAGE_QUOTA Field

public static readonly long PR_EMS_AB_MDB_STORAGE_QUOTA;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MDB_UNREAD_LIMIT Field

public static readonly long PR_EMS_AB_MDB_UNREAD_LIMIT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MDB_USE_DEFAULTS Field

public static readonly long PR_EMS_AB_MDB_USE_DEFAULTS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MEMBER Field

public static readonly long PR_EMS_AB_MEMBER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MEMBER_T Field

public static readonly long PR_EMS_AB_MEMBER_T;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MEMBER_T_A Field

public static readonly long PR_EMS_AB_MEMBER_T_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MEMBER_T_W Field

public static readonly long PR_EMS_AB_MEMBER_T_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MESSAGE_TRACKING_ENABLED Field

public static readonly long PR_EMS_AB_MESSAGE_TRACKING_ENABLED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MIME_TYPES Field

public static readonly long PR_EMS_AB_MIME_TYPES;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MODERATED Field

public static readonly long PR_EMS_AB_MODERATED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MODERATOR Field

public static readonly long PR_EMS_AB_MODERATOR;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MODERATOR_A Field

public static readonly long PR_EMS_AB_MODERATOR_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MODERATOR_W Field

public static readonly long PR_EMS_AB_MODERATOR_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MONITOR_CLOCK Field

public static readonly long PR_EMS_AB_MONITOR_CLOCK;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MONITOR_SERVERS Field

public static readonly long PR_EMS_AB_MONITOR_SERVERS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MONITOR_SERVICES Field

public static readonly long PR_EMS_AB_MONITOR_SERVICES;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MONITORED_CONFIGURATIONS Field

public static readonly long PR_EMS_AB_MONITORED_CONFIGURATIONS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MONITORED_CONFIGURATIONS_O Field

public static readonly long PR_EMS_AB_MONITORED_CONFIGURATIONS_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MONITORED_SERVERS Field

public static readonly long PR_EMS_AB_MONITORED_SERVERS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MONITORED_SERVERS_O Field

public static readonly long PR_EMS_AB_MONITORED_SERVERS_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MONITORED_SERVICES Field

public static readonly long PR_EMS_AB_MONITORED_SERVICES;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MONITORING_ALERT_DELAY Field

public static readonly long PR_EMS_AB_MONITORING_ALERT_DELAY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MONITORING_ALERT_UNITS Field

public static readonly long PR_EMS_AB_MONITORING_ALERT_UNITS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MONITORING_AVAILABILITY_STYLE Field

public static readonly long PR_EMS_AB_MONITORING_AVAILABILITY_STYLE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MONITORING_AVAILABILITY_WINDOW Field

public static readonly long PR_EMS_AB_MONITORING_AVAILABILITY_WINDOW;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MONITORING_CACHED_VIA_MAIL Field

public static readonly long PR_EMS_AB_MONITORING_CACHED_VIA_MAIL;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MONITORING_CACHED_VIA_MAIL_O Field

public static readonly long PR_EMS_AB_MONITORING_CACHED_VIA_MAIL_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MONITORING_CACHED_VIA_RPC Field

public static readonly long PR_EMS_AB_MONITORING_CACHED_VIA_RPC;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MONITORING_CACHED_VIA_RPC_O Field

public static readonly long PR_EMS_AB_MONITORING_CACHED_VIA_RPC_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MONITORING_ESCALATION_PROCEDURE Field

public static readonly long PR_EMS_AB_MONITORING_ESCALATION_PROCEDURE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MONITORING_HOTSITE_POLL_INTERVAL Field

public static readonly long PR_EMS_AB_MONITORING_HOTSITE_POLL_INTERVAL;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MONITORING_HOTSITE_POLL_UNITS Field

public static readonly long PR_EMS_AB_MONITORING_HOTSITE_POLL_UNITS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MONITORING_MAIL_UPDATE_INTERVAL Field

public static readonly long PR_EMS_AB_MONITORING_MAIL_UPDATE_INTERVAL;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MONITORING_MAIL_UPDATE_UNITS Field

public static readonly long PR_EMS_AB_MONITORING_MAIL_UPDATE_UNITS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MONITORING_NORMAL_POLL_INTERVAL Field

public static readonly long PR_EMS_AB_MONITORING_NORMAL_POLL_INTERVAL;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MONITORING_NORMAL_POLL_UNITS Field

public static readonly long PR_EMS_AB_MONITORING_NORMAL_POLL_UNITS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MONITORING_RECIPIENTS Field

public static readonly long PR_EMS_AB_MONITORING_RECIPIENTS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MONITORING_RECIPIENTS_NDR Field

public static readonly long PR_EMS_AB_MONITORING_RECIPIENTS_NDR;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MONITORING_RECIPIENTS_NDR_O Field

public static readonly long PR_EMS_AB_MONITORING_RECIPIENTS_NDR_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MONITORING_RECIPIENTS_O Field

public static readonly long PR_EMS_AB_MONITORING_RECIPIENTS_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MONITORING_RPC_UPDATE_INTERVAL Field

public static readonly long PR_EMS_AB_MONITORING_RPC_UPDATE_INTERVAL;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MONITORING_RPC_UPDATE_UNITS Field

public static readonly long PR_EMS_AB_MONITORING_RPC_UPDATE_UNITS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MONITORING_WARNING_DELAY Field

public static readonly long PR_EMS_AB_MONITORING_WARNING_DELAY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MONITORING_WARNING_UNITS Field

public static readonly long PR_EMS_AB_MONITORING_WARNING_UNITS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MTA_LOCAL_CRED Field

public static readonly long PR_EMS_AB_MTA_LOCAL_CRED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MTA_LOCAL_CRED_A Field

public static readonly long PR_EMS_AB_MTA_LOCAL_CRED_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MTA_LOCAL_CRED_W Field

public static readonly long PR_EMS_AB_MTA_LOCAL_CRED_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MTA_LOCAL_DESIG Field

public static readonly long PR_EMS_AB_MTA_LOCAL_DESIG;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MTA_LOCAL_DESIG_A Field

public static readonly long PR_EMS_AB_MTA_LOCAL_DESIG_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_MTA_LOCAL_DESIG_W Field

public static readonly long PR_EMS_AB_MTA_LOCAL_DESIG_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_N_ADDRESS Field

public static readonly long PR_EMS_AB_N_ADDRESS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_N_ADDRESS_TYPE Field

public static readonly long PR_EMS_AB_N_ADDRESS_TYPE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_NETWORK_ADDRESS Field

public static readonly long PR_EMS_AB_NETWORK_ADDRESS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_NEWSFEED_TYPE Field

public static readonly long PR_EMS_AB_NEWSFEED_TYPE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_NEWSGROUP Field

public static readonly long PR_EMS_AB_NEWSGROUP;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_NEWSGROUP_A Field

public static readonly long PR_EMS_AB_NEWSGROUP_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_NEWSGROUP_LIST Field

public static readonly long PR_EMS_AB_NEWSGROUP_LIST;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_NEWSGROUP_W Field

public static readonly long PR_EMS_AB_NEWSGROUP_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_NNTP_CHARACTER_SET Field

public static readonly long PR_EMS_AB_NNTP_CHARACTER_SET;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_NNTP_CHARACTER_SET_A Field

public static readonly long PR_EMS_AB_NNTP_CHARACTER_SET_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_NNTP_CHARACTER_SET_W Field

public static readonly long PR_EMS_AB_NNTP_CHARACTER_SET_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_NNTP_CONTENT_FORMAT Field

public static readonly long PR_EMS_AB_NNTP_CONTENT_FORMAT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_NNTP_CONTENT_FORMAT_A Field

public static readonly long PR_EMS_AB_NNTP_CONTENT_FORMAT_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_NNTP_CONTENT_FORMAT_W Field

public static readonly long PR_EMS_AB_NNTP_CONTENT_FORMAT_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_NNTP_DISTRIBUTIONS Field

public static readonly long PR_EMS_AB_NNTP_DISTRIBUTIONS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_NNTP_DISTRIBUTIONS_FLAG Field

public static readonly long PR_EMS_AB_NNTP_DISTRIBUTIONS_FLAG;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_NNTP_NEWSFEEDS Field

public static readonly long PR_EMS_AB_NNTP_NEWSFEEDS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_NNTP_NEWSFEEDS_O Field

public static readonly long PR_EMS_AB_NNTP_NEWSFEEDS_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_NT_MACHINE_NAME Field

public static readonly long PR_EMS_AB_NT_MACHINE_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_NT_MACHINE_NAME_A Field

public static readonly long PR_EMS_AB_NT_MACHINE_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_NT_MACHINE_NAME_W Field

public static readonly long PR_EMS_AB_NT_MACHINE_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_NT_SECURITY_DESCRIPTOR Field

public static readonly long PR_EMS_AB_NT_SECURITY_DESCRIPTOR;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_NUM_OF_OPEN_RETRIES Field

public static readonly long PR_EMS_AB_NUM_OF_OPEN_RETRIES;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_NUM_OF_TRANSFER_RETRIES Field

public static readonly long PR_EMS_AB_NUM_OF_TRANSFER_RETRIES;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_OBJ_DIST_NAME Field

public static readonly long PR_EMS_AB_OBJ_DIST_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_OBJ_DIST_NAME_A Field

public static readonly long PR_EMS_AB_OBJ_DIST_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_OBJ_DIST_NAME_O Field

public static readonly long PR_EMS_AB_OBJ_DIST_NAME_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_OBJ_DIST_NAME_W Field

public static readonly long PR_EMS_AB_OBJ_DIST_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_OBJ_VIEW_CONTAINERS Field

public static readonly long PR_EMS_AB_OBJ_VIEW_CONTAINERS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_OBJ_VIEW_CONTAINERS_O Field

public static readonly long PR_EMS_AB_OBJ_VIEW_CONTAINERS_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_OBJECT_CLASS_CATEGORY Field

public static readonly long PR_EMS_AB_OBJECT_CLASS_CATEGORY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_OBJECT_OID Field

public static readonly long PR_EMS_AB_OBJECT_OID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_OBJECT_VERSION Field

public static readonly long PR_EMS_AB_OBJECT_VERSION;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_OFF_LINE_AB_CONTAINERS Field

public static readonly long PR_EMS_AB_OFF_LINE_AB_CONTAINERS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_OFF_LINE_AB_CONTAINERS_O Field

public static readonly long PR_EMS_AB_OFF_LINE_AB_CONTAINERS_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_OFF_LINE_AB_SCHEDULE Field

public static readonly long PR_EMS_AB_OFF_LINE_AB_SCHEDULE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_OFF_LINE_AB_SERVER Field

public static readonly long PR_EMS_AB_OFF_LINE_AB_SERVER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_OFF_LINE_AB_SERVER_A Field

public static readonly long PR_EMS_AB_OFF_LINE_AB_SERVER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_OFF_LINE_AB_SERVER_O Field

public static readonly long PR_EMS_AB_OFF_LINE_AB_SERVER_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_OFF_LINE_AB_SERVER_W Field

public static readonly long PR_EMS_AB_OFF_LINE_AB_SERVER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_OFF_LINE_AB_STYLE Field

public static readonly long PR_EMS_AB_OFF_LINE_AB_STYLE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_OID_TYPE Field

public static readonly long PR_EMS_AB_OID_TYPE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_OM_OBJECT_CLASS Field

public static readonly long PR_EMS_AB_OM_OBJECT_CLASS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_OM_SYNTAX Field

public static readonly long PR_EMS_AB_OM_SYNTAX;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_OOF_REPLY_TO_ORIGINATOR Field

public static readonly long PR_EMS_AB_OOF_REPLY_TO_ORIGINATOR;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_OPEN_RETRY_INTERVAL Field

public static readonly long PR_EMS_AB_OPEN_RETRY_INTERVAL;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ORGANIZATION_NAME Field

public static readonly long PR_EMS_AB_ORGANIZATION_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ORGANIZATIONAL_UNIT_NAME Field

public static readonly long PR_EMS_AB_ORGANIZATIONAL_UNIT_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ORIGINAL_DISPLAY_TABLE Field

public static readonly long PR_EMS_AB_ORIGINAL_DISPLAY_TABLE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ORIGINAL_DISPLAY_TABLE_MSDOS Field

public static readonly long PR_EMS_AB_ORIGINAL_DISPLAY_TABLE_MSDOS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_OTHER_RECIPS Field

public static readonly long PR_EMS_AB_OTHER_RECIPS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_OUTBOUND_HOST Field

public static readonly long PR_EMS_AB_OUTBOUND_HOST;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_OUTBOUND_HOST_TYPE Field

public static readonly long PR_EMS_AB_OUTBOUND_HOST_TYPE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_OUTBOUND_NEWSFEED Field

public static readonly long PR_EMS_AB_OUTBOUND_NEWSFEED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_OUTBOUND_NEWSFEED_A Field

public static readonly long PR_EMS_AB_OUTBOUND_NEWSFEED_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_OUTBOUND_NEWSFEED_W Field

public static readonly long PR_EMS_AB_OUTBOUND_NEWSFEED_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_OUTBOUND_SITES Field

public static readonly long PR_EMS_AB_OUTBOUND_SITES;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_OUTBOUND_SITES_O Field

public static readonly long PR_EMS_AB_OUTBOUND_SITES_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_OUTGOING_MSG_SIZE_LIMIT Field

public static readonly long PR_EMS_AB_OUTGOING_MSG_SIZE_LIMIT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_OVERRIDE_NNTP_CONTENT_FORMAT Field

public static readonly long PR_EMS_AB_OVERRIDE_NNTP_CONTENT_FORMAT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_OWA_SERVER Field

public static readonly long PR_EMS_AB_OWA_SERVER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_OWA_SERVER_A Field

public static readonly long PR_EMS_AB_OWA_SERVER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_OWA_SERVER_W Field

public static readonly long PR_EMS_AB_OWA_SERVER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_OWNER Field

public static readonly long PR_EMS_AB_OWNER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_OWNER_A Field

public static readonly long PR_EMS_AB_OWNER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_OWNER_BL Field

public static readonly long PR_EMS_AB_OWNER_BL;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_OWNER_BL_O Field

public static readonly long PR_EMS_AB_OWNER_BL_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_OWNER_O Field

public static readonly long PR_EMS_AB_OWNER_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_OWNER_W Field

public static readonly long PR_EMS_AB_OWNER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_P_SELECTOR Field

public static readonly long PR_EMS_AB_P_SELECTOR;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_P_SELECTOR_INBOUND Field

public static readonly long PR_EMS_AB_P_SELECTOR_INBOUND;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_PARENT_ENTRYID Field

public static readonly long PR_EMS_AB_PARENT_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_PER_MSG_DIALOG_DISPLAY_TABLE Field

public static readonly long PR_EMS_AB_PER_MSG_DIALOG_DISPLAY_TABLE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_PER_RECIP_DIALOG_DISPLAY_TABLE Field

public static readonly long PR_EMS_AB_PER_RECIP_DIALOG_DISPLAY_TABLE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_PERIOD_REP_SYNC_TIMES Field

public static readonly long PR_EMS_AB_PERIOD_REP_SYNC_TIMES;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_PERIOD_REPL_STAGGER Field

public static readonly long PR_EMS_AB_PERIOD_REPL_STAGGER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_PERSONAL_TITLE Field

public static readonly long PR_EMS_AB_PERSONAL_TITLE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_PERSONAL_TITLE_A Field

public static readonly long PR_EMS_AB_PERSONAL_TITLE_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_PERSONAL_TITLE_W Field

public static readonly long PR_EMS_AB_PERSONAL_TITLE_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_PF_CONTACTS Field

public static readonly long PR_EMS_AB_PF_CONTACTS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_PF_CONTACTS_O Field

public static readonly long PR_EMS_AB_PF_CONTACTS_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_POP_CHARACTER_SET Field

public static readonly long PR_EMS_AB_POP_CHARACTER_SET;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_POP_CHARACTER_SET_A Field

public static readonly long PR_EMS_AB_POP_CHARACTER_SET_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_POP_CHARACTER_SET_W Field

public static readonly long PR_EMS_AB_POP_CHARACTER_SET_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_POP_CONTENT_FORMAT Field

public static readonly long PR_EMS_AB_POP_CONTENT_FORMAT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_POP_CONTENT_FORMAT_A Field

public static readonly long PR_EMS_AB_POP_CONTENT_FORMAT_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_POP_CONTENT_FORMAT_W Field

public static readonly long PR_EMS_AB_POP_CONTENT_FORMAT_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_PORT_NUMBER Field

public static readonly long PR_EMS_AB_PORT_NUMBER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_POSTAL_ADDRESS Field

public static readonly long PR_EMS_AB_POSTAL_ADDRESS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_PREFERRED_DELIVERY_METHOD Field

public static readonly long PR_EMS_AB_PREFERRED_DELIVERY_METHOD;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_PRESERVE_INTERNET_CONTENT Field

public static readonly long PR_EMS_AB_PRESERVE_INTERNET_CONTENT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_PRMD Field

public static readonly long PR_EMS_AB_PRMD;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_PRMD_A Field

public static readonly long PR_EMS_AB_PRMD_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_PRMD_W Field

public static readonly long PR_EMS_AB_PRMD_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_PROMO_EXPIRATION Field

public static readonly long PR_EMS_AB_PROMO_EXPIRATION;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_PROTOCOL_SETTINGS Field

public static readonly long PR_EMS_AB_PROTOCOL_SETTINGS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_PROXY_ADDRESSES Field

public static readonly long PR_EMS_AB_PROXY_ADDRESSES;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_PROXY_GENERATION_ENABLED Field

public static readonly long PR_EMS_AB_PROXY_GENERATION_ENABLED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_PROXY_GENERATOR_DLL Field

public static readonly long PR_EMS_AB_PROXY_GENERATOR_DLL;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_PROXY_GENERATOR_DLL_A Field

public static readonly long PR_EMS_AB_PROXY_GENERATOR_DLL_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_PROXY_GENERATOR_DLL_W Field

public static readonly long PR_EMS_AB_PROXY_GENERATOR_DLL_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_PUBLIC_DELEGATES Field

public static readonly long PR_EMS_AB_PUBLIC_DELEGATES;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_PUBLIC_DELEGATES_BL Field

public static readonly long PR_EMS_AB_PUBLIC_DELEGATES_BL;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_PUBLIC_DELEGATES_BL_O Field

public static readonly long PR_EMS_AB_PUBLIC_DELEGATES_BL_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_PUBLIC_DELEGATES_T Field

public static readonly long PR_EMS_AB_PUBLIC_DELEGATES_T;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_PUBLIC_DELEGATES_T_A Field

public static readonly long PR_EMS_AB_PUBLIC_DELEGATES_T_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_PUBLIC_DELEGATES_T_W Field

public static readonly long PR_EMS_AB_PUBLIC_DELEGATES_T_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_QUOTA_NOTIFICATION_SCHEDULE Field

public static readonly long PR_EMS_AB_QUOTA_NOTIFICATION_SCHEDULE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_QUOTA_NOTIFICATION_STYLE Field

public static readonly long PR_EMS_AB_QUOTA_NOTIFICATION_STYLE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_RANGE_LOWER Field

public static readonly long PR_EMS_AB_RANGE_LOWER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_RANGE_UPPER Field

public static readonly long PR_EMS_AB_RANGE_UPPER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_RAS_ACCOUNT Field

public static readonly long PR_EMS_AB_RAS_ACCOUNT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_RAS_ACCOUNT_A Field

public static readonly long PR_EMS_AB_RAS_ACCOUNT_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_RAS_ACCOUNT_W Field

public static readonly long PR_EMS_AB_RAS_ACCOUNT_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_RAS_CALLBACK_NUMBER Field

public static readonly long PR_EMS_AB_RAS_CALLBACK_NUMBER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_RAS_CALLBACK_NUMBER_A Field

public static readonly long PR_EMS_AB_RAS_CALLBACK_NUMBER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_RAS_CALLBACK_NUMBER_W Field

public static readonly long PR_EMS_AB_RAS_CALLBACK_NUMBER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_RAS_PASSWORD Field

public static readonly long PR_EMS_AB_RAS_PASSWORD;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_RAS_PHONE_NUMBER Field

public static readonly long PR_EMS_AB_RAS_PHONE_NUMBER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_RAS_PHONE_NUMBER_A Field

public static readonly long PR_EMS_AB_RAS_PHONE_NUMBER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_RAS_PHONE_NUMBER_W Field

public static readonly long PR_EMS_AB_RAS_PHONE_NUMBER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_RAS_PHONEBOOK_ENTRY_NAME Field

public static readonly long PR_EMS_AB_RAS_PHONEBOOK_ENTRY_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_RAS_PHONEBOOK_ENTRY_NAME_A Field

public static readonly long PR_EMS_AB_RAS_PHONEBOOK_ENTRY_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_RAS_PHONEBOOK_ENTRY_NAME_W Field

public static readonly long PR_EMS_AB_RAS_PHONEBOOK_ENTRY_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_RAS_REMOTE_SRVR_NAME Field

public static readonly long PR_EMS_AB_RAS_REMOTE_SRVR_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_RAS_REMOTE_SRVR_NAME_A Field

public static readonly long PR_EMS_AB_RAS_REMOTE_SRVR_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_RAS_REMOTE_SRVR_NAME_W Field

public static readonly long PR_EMS_AB_RAS_REMOTE_SRVR_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_REFERRAL_LIST Field

public static readonly long PR_EMS_AB_REFERRAL_LIST;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_REGISTERED_ADDRESS Field

public static readonly long PR_EMS_AB_REGISTERED_ADDRESS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_REMOTE_BRIDGE_HEAD Field

public static readonly long PR_EMS_AB_REMOTE_BRIDGE_HEAD;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_REMOTE_BRIDGE_HEAD_A Field

public static readonly long PR_EMS_AB_REMOTE_BRIDGE_HEAD_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_REMOTE_BRIDGE_HEAD_ADDRESS Field

public static readonly long PR_EMS_AB_REMOTE_BRIDGE_HEAD_ADDRESS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_REMOTE_BRIDGE_HEAD_ADDRESS_A Field

public static readonly long PR_EMS_AB_REMOTE_BRIDGE_HEAD_ADDRESS_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_REMOTE_BRIDGE_HEAD_ADDRESS_W Field

public static readonly long PR_EMS_AB_REMOTE_BRIDGE_HEAD_ADDRESS_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_REMOTE_BRIDGE_HEAD_W Field

public static readonly long PR_EMS_AB_REMOTE_BRIDGE_HEAD_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_REMOTE_OUT_BH_SERVER Field

public static readonly long PR_EMS_AB_REMOTE_OUT_BH_SERVER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_REMOTE_OUT_BH_SERVER_A Field

public static readonly long PR_EMS_AB_REMOTE_OUT_BH_SERVER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_REMOTE_OUT_BH_SERVER_O Field

public static readonly long PR_EMS_AB_REMOTE_OUT_BH_SERVER_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_REMOTE_OUT_BH_SERVER_W Field

public static readonly long PR_EMS_AB_REMOTE_OUT_BH_SERVER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_REMOTE_SITE Field

public static readonly long PR_EMS_AB_REMOTE_SITE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_REMOTE_SITE_A Field

public static readonly long PR_EMS_AB_REMOTE_SITE_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_REMOTE_SITE_O Field

public static readonly long PR_EMS_AB_REMOTE_SITE_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_REMOTE_SITE_W Field

public static readonly long PR_EMS_AB_REMOTE_SITE_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_REPLICATED_OBJECT_VERSION Field

public static readonly long PR_EMS_AB_REPLICATED_OBJECT_VERSION;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_REPLICATION_MAIL_MSG_SIZE Field

public static readonly long PR_EMS_AB_REPLICATION_MAIL_MSG_SIZE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_REPLICATION_SENSITIVITY Field

public static readonly long PR_EMS_AB_REPLICATION_SENSITIVITY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_REPLICATION_STAGGER Field

public static readonly long PR_EMS_AB_REPLICATION_STAGGER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_REPORT_TO_ORIGINATOR Field

public static readonly long PR_EMS_AB_REPORT_TO_ORIGINATOR;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_REPORT_TO_OWNER Field

public static readonly long PR_EMS_AB_REPORT_TO_OWNER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_REPORTS Field

public static readonly long PR_EMS_AB_REPORTS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_REPORTS_T Field

public static readonly long PR_EMS_AB_REPORTS_T;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_REQ_SEQ Field

public static readonly long PR_EMS_AB_REQ_SEQ;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_REQUIRE_SSL Field

public static readonly long PR_EMS_AB_REQUIRE_SSL;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_RESPONSIBLE_LOCAL_DXA Field

public static readonly long PR_EMS_AB_RESPONSIBLE_LOCAL_DXA;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_RESPONSIBLE_LOCAL_DXA_A Field

public static readonly long PR_EMS_AB_RESPONSIBLE_LOCAL_DXA_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_RESPONSIBLE_LOCAL_DXA_O Field

public static readonly long PR_EMS_AB_RESPONSIBLE_LOCAL_DXA_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_RESPONSIBLE_LOCAL_DXA_W Field

public static readonly long PR_EMS_AB_RESPONSIBLE_LOCAL_DXA_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_RETURN_EXACT_MSG_SIZE Field

public static readonly long PR_EMS_AB_RETURN_EXACT_MSG_SIZE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_RID_SERVER Field

public static readonly long PR_EMS_AB_RID_SERVER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_RID_SERVER_A Field

public static readonly long PR_EMS_AB_RID_SERVER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_RID_SERVER_O Field

public static readonly long PR_EMS_AB_RID_SERVER_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_RID_SERVER_W Field

public static readonly long PR_EMS_AB_RID_SERVER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ROLE_OCCUPANT Field

public static readonly long PR_EMS_AB_ROLE_OCCUPANT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ROLE_OCCUPANT_O Field

public static readonly long PR_EMS_AB_ROLE_OCCUPANT_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ROOT_NEWSGROUPS_FOLDER_ID Field

public static readonly long PR_EMS_AB_ROOT_NEWSGROUPS_FOLDER_ID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_ROUTING_LIST Field

public static readonly long PR_EMS_AB_ROUTING_LIST;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_RTS_CHECKPOINT_SIZE Field

public static readonly long PR_EMS_AB_RTS_CHECKPOINT_SIZE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_RTS_RECOVERY_TIMEOUT Field

public static readonly long PR_EMS_AB_RTS_RECOVERY_TIMEOUT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_RTS_WINDOW_SIZE Field

public static readonly long PR_EMS_AB_RTS_WINDOW_SIZE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_RUNS_ON Field

public static readonly long PR_EMS_AB_RUNS_ON;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_RUNS_ON_O Field

public static readonly long PR_EMS_AB_RUNS_ON_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_S_SELECTOR Field

public static readonly long PR_EMS_AB_S_SELECTOR;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_S_SELECTOR_INBOUND Field

public static readonly long PR_EMS_AB_S_SELECTOR_INBOUND;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SCHEMA_FLAGS Field

public static readonly long PR_EMS_AB_SCHEMA_FLAGS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SCHEMA_VERSION Field

public static readonly long PR_EMS_AB_SCHEMA_VERSION;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SEARCH_FLAGS Field

public static readonly long PR_EMS_AB_SEARCH_FLAGS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SEARCH_GUIDE Field

public static readonly long PR_EMS_AB_SEARCH_GUIDE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SECURITY_POLICY Field

public static readonly long PR_EMS_AB_SECURITY_POLICY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SECURITY_PROTOCOL Field

public static readonly long PR_EMS_AB_SECURITY_PROTOCOL;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SEE_ALSO Field

public static readonly long PR_EMS_AB_SEE_ALSO;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SEE_ALSO_O Field

public static readonly long PR_EMS_AB_SEE_ALSO_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SEND_EMAIL_MESSAGE Field

public static readonly long PR_EMS_AB_SEND_EMAIL_MESSAGE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SEND_TNEF Field

public static readonly long PR_EMS_AB_SEND_TNEF;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SERIAL_NUMBER Field

public static readonly long PR_EMS_AB_SERIAL_NUMBER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SERVER Field

public static readonly long PR_EMS_AB_SERVER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SERVER_A Field

public static readonly long PR_EMS_AB_SERVER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SERVER_W Field

public static readonly long PR_EMS_AB_SERVER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SERVICE_ACTION_FIRST Field

public static readonly long PR_EMS_AB_SERVICE_ACTION_FIRST;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SERVICE_ACTION_OTHER Field

public static readonly long PR_EMS_AB_SERVICE_ACTION_OTHER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SERVICE_ACTION_SECOND Field

public static readonly long PR_EMS_AB_SERVICE_ACTION_SECOND;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SERVICE_RESTART_DELAY Field

public static readonly long PR_EMS_AB_SERVICE_RESTART_DELAY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SERVICE_RESTART_MESSAGE Field

public static readonly long PR_EMS_AB_SERVICE_RESTART_MESSAGE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SERVICE_RESTART_MESSAGE_A Field

public static readonly long PR_EMS_AB_SERVICE_RESTART_MESSAGE_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SERVICE_RESTART_MESSAGE_W Field

public static readonly long PR_EMS_AB_SERVICE_RESTART_MESSAGE_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SESSION_DISCONNECT_TIMER Field

public static readonly long PR_EMS_AB_SESSION_DISCONNECT_TIMER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SITE_AFFINITY Field

public static readonly long PR_EMS_AB_SITE_AFFINITY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SITE_FOLDER_GUID Field

public static readonly long PR_EMS_AB_SITE_FOLDER_GUID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SITE_FOLDER_SERVER Field

public static readonly long PR_EMS_AB_SITE_FOLDER_SERVER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SITE_FOLDER_SERVER_A Field

public static readonly long PR_EMS_AB_SITE_FOLDER_SERVER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SITE_FOLDER_SERVER_O Field

public static readonly long PR_EMS_AB_SITE_FOLDER_SERVER_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SITE_FOLDER_SERVER_W Field

public static readonly long PR_EMS_AB_SITE_FOLDER_SERVER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SITE_PROXY_SPACE Field

public static readonly long PR_EMS_AB_SITE_PROXY_SPACE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SMIME_ALG_LIST_NA Field

public static readonly long PR_EMS_AB_SMIME_ALG_LIST_NA;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SMIME_ALG_LIST_OTHER Field

public static readonly long PR_EMS_AB_SMIME_ALG_LIST_OTHER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SMIME_ALG_SELECTED_NA Field

public static readonly long PR_EMS_AB_SMIME_ALG_SELECTED_NA;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SMIME_ALG_SELECTED_NA_A Field

public static readonly long PR_EMS_AB_SMIME_ALG_SELECTED_NA_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SMIME_ALG_SELECTED_NA_W Field

public static readonly long PR_EMS_AB_SMIME_ALG_SELECTED_NA_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SMIME_ALG_SELECTED_OTHER Field

public static readonly long PR_EMS_AB_SMIME_ALG_SELECTED_OTHER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SMIME_ALG_SELECTED_OTHER_A Field

public static readonly long PR_EMS_AB_SMIME_ALG_SELECTED_OTHER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SMIME_ALG_SELECTED_OTHER_W Field

public static readonly long PR_EMS_AB_SMIME_ALG_SELECTED_OTHER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SPACE_LAST_COMPUTED Field

public static readonly long PR_EMS_AB_SPACE_LAST_COMPUTED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_STREET_ADDRESS Field

public static readonly long PR_EMS_AB_STREET_ADDRESS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_STREET_ADDRESS_A Field

public static readonly long PR_EMS_AB_STREET_ADDRESS_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_STREET_ADDRESS_W Field

public static readonly long PR_EMS_AB_STREET_ADDRESS_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SUB_REFS Field

public static readonly long PR_EMS_AB_SUB_REFS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SUB_REFS_O Field

public static readonly long PR_EMS_AB_SUB_REFS_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SUB_SITE Field

public static readonly long PR_EMS_AB_SUB_SITE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SUB_SITE_A Field

public static readonly long PR_EMS_AB_SUB_SITE_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SUB_SITE_W Field

public static readonly long PR_EMS_AB_SUB_SITE_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SUBMISSION_CONT_LENGTH Field

public static readonly long PR_EMS_AB_SUBMISSION_CONT_LENGTH;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SUPPORT_SMIME_SIGNATURES Field

public static readonly long PR_EMS_AB_SUPPORT_SMIME_SIGNATURES;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SUPPORTED_ALGORITHMS Field

public static readonly long PR_EMS_AB_SUPPORTED_ALGORITHMS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SUPPORTED_APPLICATION_CONTEXT Field

public static readonly long PR_EMS_AB_SUPPORTED_APPLICATION_CONTEXT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SUPPORTING_STACK Field

public static readonly long PR_EMS_AB_SUPPORTING_STACK;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SUPPORTING_STACK_BL Field

public static readonly long PR_EMS_AB_SUPPORTING_STACK_BL;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SUPPORTING_STACK_BL_O Field

public static readonly long PR_EMS_AB_SUPPORTING_STACK_BL_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_SUPPORTING_STACK_O Field

public static readonly long PR_EMS_AB_SUPPORTING_STACK_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_T_SELECTOR Field

public static readonly long PR_EMS_AB_T_SELECTOR;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_T_SELECTOR_INBOUND Field

public static readonly long PR_EMS_AB_T_SELECTOR_INBOUND;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_TAGGED_X509_CERT Field

public static readonly long PR_EMS_AB_TAGGED_X509_CERT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_TARGET_ADDRESS Field

public static readonly long PR_EMS_AB_TARGET_ADDRESS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_TARGET_ADDRESS_A Field

public static readonly long PR_EMS_AB_TARGET_ADDRESS_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_TARGET_ADDRESS_W Field

public static readonly long PR_EMS_AB_TARGET_ADDRESS_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_TARGET_MTAS Field

public static readonly long PR_EMS_AB_TARGET_MTAS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_TELEPHONE_NUMBER Field

public static readonly long PR_EMS_AB_TELEPHONE_NUMBER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_TELEPHONE_PERSONAL_PAGER Field

public static readonly long PR_EMS_AB_TELEPHONE_PERSONAL_PAGER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_TELEPHONE_PERSONAL_PAGER_A Field

public static readonly long PR_EMS_AB_TELEPHONE_PERSONAL_PAGER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_TELEPHONE_PERSONAL_PAGER_W Field

public static readonly long PR_EMS_AB_TELEPHONE_PERSONAL_PAGER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_TELETEX_TERMINAL_IDENTIFIER Field

public static readonly long PR_EMS_AB_TELETEX_TERMINAL_IDENTIFIER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_TEMP_ASSOC_THRESHOLD Field

public static readonly long PR_EMS_AB_TEMP_ASSOC_THRESHOLD;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_TOMBSTONE_LIFETIME Field

public static readonly long PR_EMS_AB_TOMBSTONE_LIFETIME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_TRACKING_LOG_PATH_NAME Field

public static readonly long PR_EMS_AB_TRACKING_LOG_PATH_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_TRACKING_LOG_PATH_NAME_A Field

public static readonly long PR_EMS_AB_TRACKING_LOG_PATH_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_TRACKING_LOG_PATH_NAME_W Field

public static readonly long PR_EMS_AB_TRACKING_LOG_PATH_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_TRANS_RETRY_MINS Field

public static readonly long PR_EMS_AB_TRANS_RETRY_MINS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_TRANS_TIMEOUT_MINS Field

public static readonly long PR_EMS_AB_TRANS_TIMEOUT_MINS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_TRANSFER_RETRY_INTERVAL Field

public static readonly long PR_EMS_AB_TRANSFER_RETRY_INTERVAL;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_TRANSFER_TIMEOUT_NON_URGENT Field

public static readonly long PR_EMS_AB_TRANSFER_TIMEOUT_NON_URGENT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_TRANSFER_TIMEOUT_NORMAL Field

public static readonly long PR_EMS_AB_TRANSFER_TIMEOUT_NORMAL;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_TRANSFER_TIMEOUT_URGENT Field

public static readonly long PR_EMS_AB_TRANSFER_TIMEOUT_URGENT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_TRANSLATION_TABLE_USED Field

public static readonly long PR_EMS_AB_TRANSLATION_TABLE_USED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_TRANSPORT_EXPEDITED_DATA Field

public static readonly long PR_EMS_AB_TRANSPORT_EXPEDITED_DATA;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_TRUST_LEVEL Field

public static readonly long PR_EMS_AB_TRUST_LEVEL;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_TURN_REQUEST_THRESHOLD Field

public static readonly long PR_EMS_AB_TURN_REQUEST_THRESHOLD;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_TWO_WAY_ALTERNATE_FACILITY Field

public static readonly long PR_EMS_AB_TWO_WAY_ALTERNATE_FACILITY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_TYPE Field

public static readonly long PR_EMS_AB_TYPE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_TYPE_A Field

public static readonly long PR_EMS_AB_TYPE_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_TYPE_W Field

public static readonly long PR_EMS_AB_TYPE_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_UNAUTH_ORIG_BL Field

public static readonly long PR_EMS_AB_UNAUTH_ORIG_BL;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_UNAUTH_ORIG_BL_O Field

public static readonly long PR_EMS_AB_UNAUTH_ORIG_BL_O;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_USE_SERVER_VALUES Field

public static readonly long PR_EMS_AB_USE_SERVER_VALUES;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_USE_SITE_VALUES Field

public static readonly long PR_EMS_AB_USE_SITE_VALUES;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_USENET_SITE_NAME Field

public static readonly long PR_EMS_AB_USENET_SITE_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_USENET_SITE_NAME_A Field

public static readonly long PR_EMS_AB_USENET_SITE_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_USENET_SITE_NAME_W Field

public static readonly long PR_EMS_AB_USENET_SITE_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_USER_PASSWORD Field

public static readonly long PR_EMS_AB_USER_PASSWORD;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_USN_CHANGED Field

public static readonly long PR_EMS_AB_USN_CHANGED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_USN_CREATED Field

public static readonly long PR_EMS_AB_USN_CREATED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_USN_DSA_LAST_OBJ_REMOVED Field

public static readonly long PR_EMS_AB_USN_DSA_LAST_OBJ_REMOVED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_USN_INTERSITE Field

public static readonly long PR_EMS_AB_USN_INTERSITE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_USN_LAST_OBJ_REM Field

public static readonly long PR_EMS_AB_USN_LAST_OBJ_REM;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_USN_SOURCE Field

public static readonly long PR_EMS_AB_USN_SOURCE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_VIEW_CONTAINER_1 Field

public static readonly long PR_EMS_AB_VIEW_CONTAINER_1;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_VIEW_CONTAINER_1_A Field

public static readonly long PR_EMS_AB_VIEW_CONTAINER_1_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_VIEW_CONTAINER_1_W Field

public static readonly long PR_EMS_AB_VIEW_CONTAINER_1_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_VIEW_CONTAINER_2 Field

public static readonly long PR_EMS_AB_VIEW_CONTAINER_2;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_VIEW_CONTAINER_2_A Field

public static readonly long PR_EMS_AB_VIEW_CONTAINER_2_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_VIEW_CONTAINER_2_W Field

public static readonly long PR_EMS_AB_VIEW_CONTAINER_2_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_VIEW_CONTAINER_3 Field

public static readonly long PR_EMS_AB_VIEW_CONTAINER_3;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_VIEW_CONTAINER_3_A Field

public static readonly long PR_EMS_AB_VIEW_CONTAINER_3_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_VIEW_CONTAINER_3_W Field

public static readonly long PR_EMS_AB_VIEW_CONTAINER_3_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_VIEW_DEFINITION Field

public static readonly long PR_EMS_AB_VIEW_DEFINITION;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_VIEW_FLAGS Field

public static readonly long PR_EMS_AB_VIEW_FLAGS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_VIEW_SITE Field

public static readonly long PR_EMS_AB_VIEW_SITE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_VIEW_SITE_A Field

public static readonly long PR_EMS_AB_VIEW_SITE_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_VIEW_SITE_W Field

public static readonly long PR_EMS_AB_VIEW_SITE_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_VOICE_MAIL_FLAGS Field

public static readonly long PR_EMS_AB_VOICE_MAIL_FLAGS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_VOICE_MAIL_GREETINGS Field

public static readonly long PR_EMS_AB_VOICE_MAIL_GREETINGS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_VOICE_MAIL_PASSWORD Field

public static readonly long PR_EMS_AB_VOICE_MAIL_PASSWORD;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_VOICE_MAIL_PASSWORD_A Field

public static readonly long PR_EMS_AB_VOICE_MAIL_PASSWORD_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_VOICE_MAIL_PASSWORD_W Field

public static readonly long PR_EMS_AB_VOICE_MAIL_PASSWORD_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_VOICE_MAIL_RECORDED_NAME Field

public static readonly long PR_EMS_AB_VOICE_MAIL_RECORDED_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_VOICE_MAIL_RECORDING_LENGTH Field

public static readonly long PR_EMS_AB_VOICE_MAIL_RECORDING_LENGTH;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_VOICE_MAIL_SPEED Field

public static readonly long PR_EMS_AB_VOICE_MAIL_SPEED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_VOICE_MAIL_SYSTEM_GUID Field

public static readonly long PR_EMS_AB_VOICE_MAIL_SYSTEM_GUID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_VOICE_MAIL_USER_ID Field

public static readonly long PR_EMS_AB_VOICE_MAIL_USER_ID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_VOICE_MAIL_USER_ID_A Field

public static readonly long PR_EMS_AB_VOICE_MAIL_USER_ID_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_VOICE_MAIL_USER_ID_W Field

public static readonly long PR_EMS_AB_VOICE_MAIL_USER_ID_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_VOICE_MAIL_VOLUME Field

public static readonly long PR_EMS_AB_VOICE_MAIL_VOLUME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_WWW_HOME_PAGE Field

public static readonly long PR_EMS_AB_WWW_HOME_PAGE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_WWW_HOME_PAGE_A Field

public static readonly long PR_EMS_AB_WWW_HOME_PAGE_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_WWW_HOME_PAGE_W Field

public static readonly long PR_EMS_AB_WWW_HOME_PAGE_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_X121_ADDRESS Field

public static readonly long PR_EMS_AB_X121_ADDRESS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_X25_CALL_USER_DATA_INCOMING Field

public static readonly long PR_EMS_AB_X25_CALL_USER_DATA_INCOMING;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_X25_CALL_USER_DATA_OUTGOING Field

public static readonly long PR_EMS_AB_X25_CALL_USER_DATA_OUTGOING;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_X25_FACILITIES_DATA_INCOMING Field

public static readonly long PR_EMS_AB_X25_FACILITIES_DATA_INCOMING;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_X25_FACILITIES_DATA_OUTGOING Field

public static readonly long PR_EMS_AB_X25_FACILITIES_DATA_OUTGOING;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_X25_LEASED_LINE_PORT Field

public static readonly long PR_EMS_AB_X25_LEASED_LINE_PORT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_X25_LEASED_OR_SWITCHED Field

public static readonly long PR_EMS_AB_X25_LEASED_OR_SWITCHED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_X25_REMOTE_MTA_PHONE Field

public static readonly long PR_EMS_AB_X25_REMOTE_MTA_PHONE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_X25_REMOTE_MTA_PHONE_A Field

public static readonly long PR_EMS_AB_X25_REMOTE_MTA_PHONE_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_X25_REMOTE_MTA_PHONE_W Field

public static readonly long PR_EMS_AB_X25_REMOTE_MTA_PHONE_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_X400_ATTACHMENT_TYPE Field

public static readonly long PR_EMS_AB_X400_ATTACHMENT_TYPE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_X400_SELECTOR_SYNTAX Field

public static readonly long PR_EMS_AB_X400_SELECTOR_SYNTAX;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_X500_ACCESS_CONTROL_LIST Field

public static readonly long PR_EMS_AB_X500_ACCESS_CONTROL_LIST;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_X500_NC Field

public static readonly long PR_EMS_AB_X500_NC;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_X500_NC_A Field

public static readonly long PR_EMS_AB_X500_NC_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_X500_NC_W Field

public static readonly long PR_EMS_AB_X500_NC_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_X500_RDN Field

public static readonly long PR_EMS_AB_X500_RDN;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_X500_RDN_A Field

public static readonly long PR_EMS_AB_X500_RDN_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_X500_RDN_W Field

public static readonly long PR_EMS_AB_X500_RDN_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_XMIT_TIMEOUT_NON_URGENT Field

public static readonly long PR_EMS_AB_XMIT_TIMEOUT_NON_URGENT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_XMIT_TIMEOUT_NORMAL Field

public static readonly long PR_EMS_AB_XMIT_TIMEOUT_NORMAL;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EMS_AB_XMIT_TIMEOUT_URGENT Field

public static readonly long PR_EMS_AB_XMIT_TIMEOUT_URGENT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_END_DATE Field

public static readonly long PR_END_DATE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ENTRYID Field

public static readonly long PR_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EVENTS_ROOT_FOLDER_ENTRYID Field

public static readonly long PR_EVENTS_ROOT_FOLDER_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EXCESS_STORAGE_USED Field

public static readonly long PR_EXCESS_STORAGE_USED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EXPIRY_NUMBER Field

public static readonly long PR_EXPIRY_NUMBER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EXPIRY_TIME Field

public static readonly long PR_EXPIRY_TIME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EXPIRY_UNITS Field

public static readonly long PR_EXPIRY_UNITS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EXPLICIT_CONVERSION Field

public static readonly long PR_EXPLICIT_CONVERSION;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_EXTENDED_ACL_DATA Field

public static readonly long PR_EXTENDED_ACL_DATA;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_FAST_TRANSFER Field

public static readonly long PR_FAST_TRANSFER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_FAVORITES_DEFAULT_NAME Field

public static readonly long PR_FAVORITES_DEFAULT_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_FAVORITES_DEFAULT_NAME_A Field

public static readonly long PR_FAVORITES_DEFAULT_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_FAVORITES_DEFAULT_NAME_W Field

public static readonly long PR_FAVORITES_DEFAULT_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_FILTERING_HOOKS Field

public static readonly long PR_FILTERING_HOOKS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_FINDER_ENTRYID Field

public static readonly long PR_FINDER_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_FLAG_COMPLETE_TIME Field

Specifies the date and time in Coordinated Universal Time (UTC) that the message object was flagged as completed.

public static readonly long PR_FLAG_COMPLETE_TIME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_FLAG_ICON Field

Specifies the flag icon of the message object.

public static readonly long PR_FLAG_ICON;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_FLAG_STATUS Field

Specifies the flag state of the message object.

public static readonly long PR_FLAG_STATUS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_FOLDER_ASSOCIATED_CONTENTS Field

public static readonly long PR_FOLDER_ASSOCIATED_CONTENTS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_FOLDER_CHILD_COUNT Field

public static readonly long PR_FOLDER_CHILD_COUNT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_FOLDER_DESIGN_FLAGS Field

public static readonly long PR_FOLDER_DESIGN_FLAGS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_FOLDER_FLAGS Field

public static readonly long PR_FOLDER_FLAGS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_FOLDER_PATHNAME Field

public static readonly long PR_FOLDER_PATHNAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_FOLDER_PATHNAME_A Field

public static readonly long PR_FOLDER_PATHNAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_FOLDER_PATHNAME_W Field

public static readonly long PR_FOLDER_PATHNAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_FOLDER_TYPE Field

public static readonly long PR_FOLDER_TYPE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_FOREIGN_ID Field

public static readonly long PR_FOREIGN_ID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_FOREIGN_REPORT_ID Field

public static readonly long PR_FOREIGN_REPORT_ID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_FOREIGN_SUBJECT_ID Field

public static readonly long PR_FOREIGN_SUBJECT_ID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_FORM_CATEGORY Field

public static readonly long PR_FORM_CATEGORY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_FORM_CATEGORY_A Field

public static readonly long PR_FORM_CATEGORY_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_FORM_CATEGORY_SUB Field

public static readonly long PR_FORM_CATEGORY_SUB;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_FORM_CATEGORY_SUB_A Field

public static readonly long PR_FORM_CATEGORY_SUB_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_FORM_CATEGORY_SUB_W Field

public static readonly long PR_FORM_CATEGORY_SUB_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_FORM_CATEGORY_W Field

public static readonly long PR_FORM_CATEGORY_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_FORM_CLSID Field

public static readonly long PR_FORM_CLSID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_FORM_CONTACT_NAME Field

public static readonly long PR_FORM_CONTACT_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_FORM_CONTACT_NAME_A Field

public static readonly long PR_FORM_CONTACT_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_FORM_CONTACT_NAME_W Field

public static readonly long PR_FORM_CONTACT_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_FORM_DESIGNER_GUID Field

public static readonly long PR_FORM_DESIGNER_GUID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_FORM_DESIGNER_NAME Field

public static readonly long PR_FORM_DESIGNER_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_FORM_DESIGNER_NAME_A Field

public static readonly long PR_FORM_DESIGNER_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_FORM_DESIGNER_NAME_W Field

public static readonly long PR_FORM_DESIGNER_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_FORM_HIDDEN Field

public static readonly long PR_FORM_HIDDEN;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_FORM_HOST_MAP Field

public static readonly long PR_FORM_HOST_MAP;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_FORM_MESSAGE_BEHAVIOR Field

public static readonly long PR_FORM_MESSAGE_BEHAVIOR;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_FORM_VERSION Field

public static readonly long PR_FORM_VERSION;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_FORM_VERSION_A Field

public static readonly long PR_FORM_VERSION_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_FORM_VERSION_W Field

public static readonly long PR_FORM_VERSION_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_FREE_BUSY_FOR_LOCAL_SITE_ENTRYID Field

public static readonly long PR_FREE_BUSY_FOR_LOCAL_SITE_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_FTP_SITE Field

public static readonly long PR_FTP_SITE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_FTP_SITE_A Field

public static readonly long PR_FTP_SITE_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_FTP_SITE_W Field

public static readonly long PR_FTP_SITE_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_GENDER Field

public static readonly long PR_GENDER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_GENERATION Field

public static readonly long PR_GENERATION;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_GENERATION_A Field

public static readonly long PR_GENERATION_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_GENERATION_W Field

public static readonly long PR_GENERATION_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_GIVEN_NAME Field

public static readonly long PR_GIVEN_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_GIVEN_NAME_A Field

public static readonly long PR_GIVEN_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_GIVEN_NAME_W Field

public static readonly long PR_GIVEN_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_GOVERNMENT_ID_NUMBER Field

public static readonly long PR_GOVERNMENT_ID_NUMBER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_GOVERNMENT_ID_NUMBER_A Field

public static readonly long PR_GOVERNMENT_ID_NUMBER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_GOVERNMENT_ID_NUMBER_W Field

public static readonly long PR_GOVERNMENT_ID_NUMBER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_GW_ADMIN_OPERATIONS Field

public static readonly long PR_GW_ADMIN_OPERATIONS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_GW_MTSIN_ENTRYID Field

public static readonly long PR_GW_MTSIN_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_GW_MTSOUT_ENTRYID Field

public static readonly long PR_GW_MTSOUT_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_HAS_DAMS Field

public static readonly long PR_HAS_DAMS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_HAS_MODERATOR_RULES Field

public static readonly long PR_HAS_MODERATOR_RULES;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_HAS_NAMED_PROPERTIES Field

public static readonly long PR_HAS_NAMED_PROPERTIES;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_HAS_RULES Field

public static readonly long PR_HAS_RULES;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_HASATTACH Field

public static readonly long PR_HASATTACH;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_HEADER_FOLDER_ENTRYID Field

public static readonly long PR_HEADER_FOLDER_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_HIERARCHY_CHANGE_NUM Field

public static readonly long PR_HIERARCHY_CHANGE_NUM;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_HIERARCHY_SERVER Field

public static readonly long PR_HIERARCHY_SERVER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_HIERARCHY_SERVER_A Field

public static readonly long PR_HIERARCHY_SERVER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_HIERARCHY_SERVER_W Field

public static readonly long PR_HIERARCHY_SERVER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_HIERARCHY_SYNCHRONIZER Field

public static readonly long PR_HIERARCHY_SYNCHRONIZER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_HOBBIES Field

public static readonly long PR_HOBBIES;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_HOBBIES_A Field

public static readonly long PR_HOBBIES_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_HOBBIES_W Field

public static readonly long PR_HOBBIES_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_HOME_ADDRESS_CITY Field

public static readonly long PR_HOME_ADDRESS_CITY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_HOME_ADDRESS_CITY_A Field

public static readonly long PR_HOME_ADDRESS_CITY_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_HOME_ADDRESS_CITY_W Field

public static readonly long PR_HOME_ADDRESS_CITY_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_HOME_ADDRESS_COUNTRY Field

public static readonly long PR_HOME_ADDRESS_COUNTRY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_HOME_ADDRESS_COUNTRY_A Field

public static readonly long PR_HOME_ADDRESS_COUNTRY_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_HOME_ADDRESS_COUNTRY_W Field

public static readonly long PR_HOME_ADDRESS_COUNTRY_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_HOME_ADDRESS_POST_OFFICE_BOX Field

public static readonly long PR_HOME_ADDRESS_POST_OFFICE_BOX;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_HOME_ADDRESS_POST_OFFICE_BOX_A Field

public static readonly long PR_HOME_ADDRESS_POST_OFFICE_BOX_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_HOME_ADDRESS_POST_OFFICE_BOX_W Field

public static readonly long PR_HOME_ADDRESS_POST_OFFICE_BOX_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_HOME_ADDRESS_POSTAL_CODE Field

public static readonly long PR_HOME_ADDRESS_POSTAL_CODE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_HOME_ADDRESS_POSTAL_CODE_A Field

public static readonly long PR_HOME_ADDRESS_POSTAL_CODE_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_HOME_ADDRESS_POSTAL_CODE_W Field

public static readonly long PR_HOME_ADDRESS_POSTAL_CODE_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_HOME_ADDRESS_STATE_OR_PROVINCE Field

public static readonly long PR_HOME_ADDRESS_STATE_OR_PROVINCE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_HOME_ADDRESS_STATE_OR_PROVINCE_A Field

public static readonly long PR_HOME_ADDRESS_STATE_OR_PROVINCE_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_HOME_ADDRESS_STATE_OR_PROVINCE_W Field

public static readonly long PR_HOME_ADDRESS_STATE_OR_PROVINCE_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_HOME_ADDRESS_STREET Field

public static readonly long PR_HOME_ADDRESS_STREET;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_HOME_ADDRESS_STREET_A Field

public static readonly long PR_HOME_ADDRESS_STREET_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_HOME_ADDRESS_STREET_W Field

public static readonly long PR_HOME_ADDRESS_STREET_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_HOME_FAX_NUMBER Field

public static readonly long PR_HOME_FAX_NUMBER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_HOME_FAX_NUMBER_A Field

public static readonly long PR_HOME_FAX_NUMBER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_HOME_FAX_NUMBER_W Field

public static readonly long PR_HOME_FAX_NUMBER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_HOME_TELEPHONE_NUMBER Field

public static readonly long PR_HOME_TELEPHONE_NUMBER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_HOME_TELEPHONE_NUMBER_A Field

public static readonly long PR_HOME_TELEPHONE_NUMBER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_HOME_TELEPHONE_NUMBER_W Field

public static readonly long PR_HOME_TELEPHONE_NUMBER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_HOME2_TELEPHONE_NUMBER Field

public static readonly long PR_HOME2_TELEPHONE_NUMBER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_HOME2_TELEPHONE_NUMBER_A Field

public static readonly long PR_HOME2_TELEPHONE_NUMBER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_HOME2_TELEPHONE_NUMBER_W Field

public static readonly long PR_HOME2_TELEPHONE_NUMBER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_HTML Field

public static readonly long PR_HTML;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ICON Field

public static readonly long PR_ICON;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_IDENTITY_DISPLAY Field

public static readonly long PR_IDENTITY_DISPLAY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_IDENTITY_DISPLAY_A Field

public static readonly long PR_IDENTITY_DISPLAY_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_IDENTITY_DISPLAY_W Field

public static readonly long PR_IDENTITY_DISPLAY_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_IDENTITY_ENTRYID Field

public static readonly long PR_IDENTITY_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_IDENTITY_SEARCH_KEY Field

public static readonly long PR_IDENTITY_SEARCH_KEY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_IMAP_INTERNAL_DATE Field

public static readonly long PR_IMAP_INTERNAL_DATE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_IMPLICIT_CONVERSION_PROHIBITED Field

public static readonly long PR_IMPLICIT_CONVERSION_PROHIBITED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_IMPORTANCE Field

public static readonly long PR_IMPORTANCE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_IN_CONFLICT Field

public static readonly long PR_IN_CONFLICT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_IN_TRANSIT Field

public static readonly long PR_IN_TRANSIT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INBOUND_NEWSFEED_DN Field

public static readonly long PR_INBOUND_NEWSFEED_DN;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INBOUND_NEWSFEED_DN_A Field

public static readonly long PR_INBOUND_NEWSFEED_DN_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INBOUND_NEWSFEED_DN_W Field

public static readonly long PR_INBOUND_NEWSFEED_DN_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INCOMPLETE_COPY Field

public static readonly long PR_INCOMPLETE_COPY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INITIAL_DETAILS_PANE Field

public static readonly long PR_INITIAL_DETAILS_PANE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INITIALS Field

public static readonly long PR_INITIALS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INITIALS_A Field

public static readonly long PR_INITIALS_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INITIALS_W Field

public static readonly long PR_INITIALS_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INSTANCE_KEY Field

public static readonly long PR_INSTANCE_KEY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INTERNAL_TRACE_INFO Field

public static readonly long PR_INTERNAL_TRACE_INFO;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INTERNET_APPROVED Field

public static readonly long PR_INTERNET_APPROVED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INTERNET_APPROVED_A Field

public static readonly long PR_INTERNET_APPROVED_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INTERNET_APPROVED_W Field

public static readonly long PR_INTERNET_APPROVED_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INTERNET_ARTICLE_NUMBER Field

public static readonly long PR_INTERNET_ARTICLE_NUMBER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INTERNET_CHARSET Field

public static readonly long PR_INTERNET_CHARSET;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INTERNET_CHARSET_A Field

public static readonly long PR_INTERNET_CHARSET_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INTERNET_CHARSET_W Field

public static readonly long PR_INTERNET_CHARSET_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INTERNET_CONTROL Field

public static readonly long PR_INTERNET_CONTROL;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INTERNET_CONTROL_A Field

public static readonly long PR_INTERNET_CONTROL_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INTERNET_CONTROL_W Field

public static readonly long PR_INTERNET_CONTROL_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INTERNET_CPID Field

public static readonly long PR_INTERNET_CPID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INTERNET_DISTRIBUTION Field

public static readonly long PR_INTERNET_DISTRIBUTION;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INTERNET_DISTRIBUTION_A Field

public static readonly long PR_INTERNET_DISTRIBUTION_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INTERNET_DISTRIBUTION_W Field

public static readonly long PR_INTERNET_DISTRIBUTION_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INTERNET_FOLLOWUP_TO Field

public static readonly long PR_INTERNET_FOLLOWUP_TO;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INTERNET_FOLLOWUP_TO_A Field

public static readonly long PR_INTERNET_FOLLOWUP_TO_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INTERNET_FOLLOWUP_TO_W Field

public static readonly long PR_INTERNET_FOLLOWUP_TO_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INTERNET_LINES Field

public static readonly long PR_INTERNET_LINES;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INTERNET_MESSAGE_ID Field

public static readonly long PR_INTERNET_MESSAGE_ID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INTERNET_MESSAGE_ID_A Field

public static readonly long PR_INTERNET_MESSAGE_ID_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INTERNET_MESSAGE_ID_W Field

public static readonly long PR_INTERNET_MESSAGE_ID_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INTERNET_NEWSGROUP_NAME Field

public static readonly long PR_INTERNET_NEWSGROUP_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INTERNET_NEWSGROUP_NAME_A Field

public static readonly long PR_INTERNET_NEWSGROUP_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INTERNET_NEWSGROUP_NAME_W Field

public static readonly long PR_INTERNET_NEWSGROUP_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INTERNET_NEWSGROUPS Field

public static readonly long PR_INTERNET_NEWSGROUPS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INTERNET_NEWSGROUPS_A Field

public static readonly long PR_INTERNET_NEWSGROUPS_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INTERNET_NEWSGROUPS_W Field

public static readonly long PR_INTERNET_NEWSGROUPS_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INTERNET_NNTP_PATH Field

public static readonly long PR_INTERNET_NNTP_PATH;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INTERNET_NNTP_PATH_A Field

public static readonly long PR_INTERNET_NNTP_PATH_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INTERNET_NNTP_PATH_W Field

public static readonly long PR_INTERNET_NNTP_PATH_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INTERNET_ORGANIZATION Field

public static readonly long PR_INTERNET_ORGANIZATION;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INTERNET_ORGANIZATION_A Field

public static readonly long PR_INTERNET_ORGANIZATION_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INTERNET_ORGANIZATION_W Field

public static readonly long PR_INTERNET_ORGANIZATION_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INTERNET_PRECEDENCE Field

public static readonly long PR_INTERNET_PRECEDENCE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INTERNET_PRECEDENCE_A Field

public static readonly long PR_INTERNET_PRECEDENCE_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INTERNET_PRECEDENCE_W Field

public static readonly long PR_INTERNET_PRECEDENCE_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INTERNET_REFERENCES Field

public static readonly long PR_INTERNET_REFERENCES;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INTERNET_REFERENCES_A Field

public static readonly long PR_INTERNET_REFERENCES_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_INTERNET_REFERENCES_W Field

public static readonly long PR_INTERNET_REFERENCES_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_IPM_APPOINTMENT_ENTRYID Field

Contains the EntryID of the Outlook Calendar folder.

public static readonly long PR_IPM_APPOINTMENT_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_IPM_CONTACT_ENTRYID Field

Contains the EntryID of the Outlook Contacts folder.

public static readonly long PR_IPM_CONTACT_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_IPM_DAF_ENTRYID Field

public static readonly long PR_IPM_DAF_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_IPM_DRAFTS_ENTRYID Field

Contains the EntryID of the Outlook Drafts folder.

public static readonly long PR_IPM_DRAFTS_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_IPM_FAVORITES_ENTRYID Field

public static readonly long PR_IPM_FAVORITES_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_IPM_ID Field

public static readonly long PR_IPM_ID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_IPM_JOURNAL_ENTRYID Field

Contains the EntryID of the Outlook Journal folder.

public static readonly long PR_IPM_JOURNAL_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_IPM_NOTE_ENTRYID Field

Contains the EntryID of the Outlook Notes folder.

public static readonly long PR_IPM_NOTE_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_IPM_OUTBOX_ENTRYID Field

public static readonly long PR_IPM_OUTBOX_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_IPM_OUTBOX_SEARCH_KEY Field

public static readonly long PR_IPM_OUTBOX_SEARCH_KEY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_IPM_PUBLIC_FOLDERS_ENTRYID Field

public static readonly long PR_IPM_PUBLIC_FOLDERS_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_IPM_RETURN_REQUESTED Field

public static readonly long PR_IPM_RETURN_REQUESTED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_IPM_SENTMAIL_ENTRYID Field

public static readonly long PR_IPM_SENTMAIL_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_IPM_SENTMAIL_SEARCH_KEY Field

public static readonly long PR_IPM_SENTMAIL_SEARCH_KEY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_IPM_SUBTREE_ENTRYID Field

public static readonly long PR_IPM_SUBTREE_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_IPM_SUBTREE_SEARCH_KEY Field

public static readonly long PR_IPM_SUBTREE_SEARCH_KEY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_IPM_TASK_ENTRYID Field

Contains the EntryID of the Outlook Tasks folder.

public static readonly long PR_IPM_TASK_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_IPM_WASTEBASKET_ENTRYID Field

public static readonly long PR_IPM_WASTEBASKET_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_IPM_WASTEBASKET_SEARCH_KEY Field

public static readonly long PR_IPM_WASTEBASKET_SEARCH_KEY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_IS_NEWSGROUP Field

public static readonly long PR_IS_NEWSGROUP;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_IS_NEWSGROUP_ANCHOR Field

public static readonly long PR_IS_NEWSGROUP_ANCHOR;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ISDN_NUMBER Field

public static readonly long PR_ISDN_NUMBER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ISDN_NUMBER_A Field

public static readonly long PR_ISDN_NUMBER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ISDN_NUMBER_W Field

public static readonly long PR_ISDN_NUMBER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_KEYWORD Field

public static readonly long PR_KEYWORD;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_KEYWORD_A Field

public static readonly long PR_KEYWORD_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_KEYWORD_W Field

public static readonly long PR_KEYWORD_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_LANGUAGE Field

public static readonly long PR_LANGUAGE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_LANGUAGE_A Field

public static readonly long PR_LANGUAGE_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_LANGUAGE_W Field

public static readonly long PR_LANGUAGE_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_LANGUAGES Field

public static readonly long PR_LANGUAGES;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_LANGUAGES_A Field

public static readonly long PR_LANGUAGES_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_LANGUAGES_W Field

public static readonly long PR_LANGUAGES_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_LAST_ACCESS_TIME Field

public static readonly long PR_LAST_ACCESS_TIME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_LAST_FULL_BACKUP Field

public static readonly long PR_LAST_FULL_BACKUP;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_LAST_LOGOFF_TIME Field

public static readonly long PR_LAST_LOGOFF_TIME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_LAST_LOGON_TIME Field

public static readonly long PR_LAST_LOGON_TIME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_LAST_MODIFICATION_TIME Field

public static readonly long PR_LAST_MODIFICATION_TIME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_LAST_MODIFIER_ENTRYID Field

public static readonly long PR_LAST_MODIFIER_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_LAST_MODIFIER_NAME Field

public static readonly long PR_LAST_MODIFIER_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_LAST_MODIFIER_NAME_A Field

public static readonly long PR_LAST_MODIFIER_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_LAST_MODIFIER_NAME_W Field

public static readonly long PR_LAST_MODIFIER_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_LAST_VERB_EXECUTION_TIME Field

Contains the time when the last verb was executed.

public static readonly long PR_LAST_VERB_EXECUTION_TIME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_LATEST_DELIVERY_TIME Field

public static readonly long PR_LATEST_DELIVERY_TIME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_LOCALE_ID Field

public static readonly long PR_LOCALE_ID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_LOCALITY Field

public static readonly long PR_LOCALITY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_LOCALITY_A Field

public static readonly long PR_LOCALITY_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_LOCALITY_W Field

public static readonly long PR_LOCALITY_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_LOCATION Field

public static readonly long PR_LOCATION;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_LOCATION_A Field

public static readonly long PR_LOCATION_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_LOCATION_W Field

public static readonly long PR_LOCATION_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_LONGTERM_ENTRYID_FROM_TABLE Field

public static readonly long PR_LONGTERM_ENTRYID_FROM_TABLE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_LTP_ROW_ID Field

LTP Row ID.

public static readonly long PR_LTP_ROW_ID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_LTP_ROW_VER Field

LTP Row Ver.

public static readonly long PR_LTP_ROW_VER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MAIL_PERMISSION Field

public static readonly long PR_MAIL_PERMISSION;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MAILBOX_OWNER_ENTRYID Field

public static readonly long PR_MAILBOX_OWNER_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MAILBOX_OWNER_NAME Field

public static readonly long PR_MAILBOX_OWNER_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MAILBOX_OWNER_NAME_A Field

public static readonly long PR_MAILBOX_OWNER_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MAILBOX_OWNER_NAME_W Field

public static readonly long PR_MAILBOX_OWNER_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MANAGER_NAME Field

public static readonly long PR_MANAGER_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MANAGER_NAME_A Field

public static readonly long PR_MANAGER_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MANAGER_NAME_W Field

public static readonly long PR_MANAGER_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MAPPING_SIGNATURE Field

public static readonly long PR_MAPPING_SIGNATURE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MDB_PROVIDER Field

public static readonly long PR_MDB_PROVIDER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MEMBER_ENTRYID Field

public static readonly long PR_MEMBER_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MEMBER_ID Field

public static readonly long PR_MEMBER_ID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MEMBER_NAME Field

public static readonly long PR_MEMBER_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MEMBER_NAME_A Field

public static readonly long PR_MEMBER_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MEMBER_NAME_W Field

public static readonly long PR_MEMBER_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MEMBER_RIGHTS Field

public static readonly long PR_MEMBER_RIGHTS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MESSAGE_ATTACHMENTS Field

public static readonly long PR_MESSAGE_ATTACHMENTS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MESSAGE_CC_ME Field

public static readonly long PR_MESSAGE_CC_ME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MESSAGE_CLASS Field

public static readonly long PR_MESSAGE_CLASS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MESSAGE_CLASS_A Field

public static readonly long PR_MESSAGE_CLASS_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MESSAGE_CLASS_W Field

public static readonly long PR_MESSAGE_CLASS_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MESSAGE_CODEPAGE Field

public static readonly long PR_MESSAGE_CODEPAGE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MESSAGE_DELIVERY_ID Field

public static readonly long PR_MESSAGE_DELIVERY_ID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MESSAGE_DELIVERY_TIME Field

public static readonly long PR_MESSAGE_DELIVERY_TIME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MESSAGE_DOWNLOAD_TIME Field

public static readonly long PR_MESSAGE_DOWNLOAD_TIME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MESSAGE_FLAGS Field

public static readonly long PR_MESSAGE_FLAGS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MESSAGE_LOCALE_ID Field

public static readonly long PR_MESSAGE_LOCALE_ID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MESSAGE_PROCESSED Field

public static readonly long PR_MESSAGE_PROCESSED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MESSAGE_RECIP_ME Field

public static readonly long PR_MESSAGE_RECIP_ME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MESSAGE_RECIPIENTS Field

public static readonly long PR_MESSAGE_RECIPIENTS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MESSAGE_SECURITY_LABEL Field

public static readonly long PR_MESSAGE_SECURITY_LABEL;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MESSAGE_SITE_NAME Field

public static readonly long PR_MESSAGE_SITE_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MESSAGE_SITE_NAME_A Field

public static readonly long PR_MESSAGE_SITE_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MESSAGE_SITE_NAME_W Field

public static readonly long PR_MESSAGE_SITE_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MESSAGE_SIZE Field

public static readonly long PR_MESSAGE_SIZE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MESSAGE_SIZE_EXTENDED Field

public static readonly long PR_MESSAGE_SIZE_EXTENDED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MESSAGE_SUBMISSION_ID Field

public static readonly long PR_MESSAGE_SUBMISSION_ID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MESSAGE_TO_ME Field

public static readonly long PR_MESSAGE_TO_ME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MESSAGE_TOKEN Field

public static readonly long PR_MESSAGE_TOKEN;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MHS_COMMON_NAME Field

public static readonly long PR_MHS_COMMON_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MHS_COMMON_NAME_A Field

public static readonly long PR_MHS_COMMON_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MHS_COMMON_NAME_W Field

public static readonly long PR_MHS_COMMON_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MIDDLE_NAME Field

public static readonly long PR_MIDDLE_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MIDDLE_NAME_A Field

public static readonly long PR_MIDDLE_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MIDDLE_NAME_W Field

public static readonly long PR_MIDDLE_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MINI_ICON Field

public static readonly long PR_MINI_ICON;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MOBILE_TELEPHONE_NUMBER Field

public static readonly long PR_MOBILE_TELEPHONE_NUMBER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MOBILE_TELEPHONE_NUMBER_A Field

public static readonly long PR_MOBILE_TELEPHONE_NUMBER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MOBILE_TELEPHONE_NUMBER_W Field

public static readonly long PR_MOBILE_TELEPHONE_NUMBER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MODIFY_VERSION Field

public static readonly long PR_MODIFY_VERSION;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MOVE_TO_FOLDER_ENTRYID Field

public static readonly long PR_MOVE_TO_FOLDER_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MOVE_TO_STORE_ENTRYID Field

public static readonly long PR_MOVE_TO_STORE_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MSG_BODY_ID Field

public static readonly long PR_MSG_BODY_ID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MSG_STATUS Field

public static readonly long PR_MSG_STATUS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MTS_ID Field

public static readonly long PR_MTS_ID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MTS_REPORT_ID Field

public static readonly long PR_MTS_REPORT_ID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_MTS_SUBJECT_ID Field

public static readonly long PR_MTS_SUBJECT_ID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_NDR_DIAG_CODE Field

public static readonly long PR_NDR_DIAG_CODE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_NDR_REASON_CODE Field

public static readonly long PR_NDR_REASON_CODE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_NEW_SUBS_GET_AUTO_ADD Field

public static readonly long PR_NEW_SUBS_GET_AUTO_ADD;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_NEWSFEED_INFO Field

public static readonly long PR_NEWSFEED_INFO;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_NEWSGROUP_COMPONENT Field

public static readonly long PR_NEWSGROUP_COMPONENT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_NEWSGROUP_COMPONENT_A Field

public static readonly long PR_NEWSGROUP_COMPONENT_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_NEWSGROUP_COMPONENT_W Field

public static readonly long PR_NEWSGROUP_COMPONENT_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_NEWSGROUP_NAME Field

public static readonly long PR_NEWSGROUP_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_NEWSGROUP_NAME_A Field

public static readonly long PR_NEWSGROUP_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_NEWSGROUP_NAME_W Field

public static readonly long PR_NEWSGROUP_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_NEWSGROUP_ROOT_FOLDER_ENTRYID Field

public static readonly long PR_NEWSGROUP_ROOT_FOLDER_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_NICKNAME Field

public static readonly long PR_NICKNAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_NICKNAME_A Field

public static readonly long PR_NICKNAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_NICKNAME_W Field

public static readonly long PR_NICKNAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_NNTP_ARTICLE_FOLDER_ENTRYID Field

public static readonly long PR_NNTP_ARTICLE_FOLDER_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_NNTP_CONTROL_FOLDER_ENTRYID Field

public static readonly long PR_NNTP_CONTROL_FOLDER_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_NNTP_XREF Field

public static readonly long PR_NNTP_XREF;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_NNTP_XREF_A Field

public static readonly long PR_NNTP_XREF_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_NNTP_XREF_W Field

public static readonly long PR_NNTP_XREF_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_NON_IPM_SUBTREE_ENTRYID Field

public static readonly long PR_NON_IPM_SUBTREE_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_NON_RECEIPT_NOTIFICATION_REQUESTED Field

public static readonly long PR_NON_RECEIPT_NOTIFICATION_REQUESTED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_NON_RECEIPT_REASON Field

public static readonly long PR_NON_RECEIPT_REASON;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_NORMAL_MESSAGE_SIZE Field

public static readonly long PR_NORMAL_MESSAGE_SIZE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_NORMAL_MESSAGE_SIZE_EXTENDED Field

public static readonly long PR_NORMAL_MESSAGE_SIZE_EXTENDED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_NORMAL_MSG_W_ATTACH_COUNT Field

public static readonly long PR_NORMAL_MSG_W_ATTACH_COUNT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_NORMALIZED_SUBJECT Field

public static readonly long PR_NORMALIZED_SUBJECT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_NORMALIZED_SUBJECT_A Field

public static readonly long PR_NORMALIZED_SUBJECT_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_NORMALIZED_SUBJECT_W Field

public static readonly long PR_NORMALIZED_SUBJECT_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_NT_USER_NAME Field

public static readonly long PR_NT_USER_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_NT_USER_NAME_A Field

public static readonly long PR_NT_USER_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_NT_USER_NAME_W Field

public static readonly long PR_NT_USER_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OBJECT_TYPE Field

public static readonly long PR_OBJECT_TYPE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OBSOLETED_IPMS Field

public static readonly long PR_OBSOLETED_IPMS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OFFICE_LOCATION Field

public static readonly long PR_OFFICE_LOCATION;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OFFICE_LOCATION_A Field

public static readonly long PR_OFFICE_LOCATION_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OFFICE_LOCATION_W Field

public static readonly long PR_OFFICE_LOCATION_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OFFICE_TELEPHONE_NUMBER Field

public static readonly long PR_OFFICE_TELEPHONE_NUMBER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OFFICE_TELEPHONE_NUMBER_A Field

public static readonly long PR_OFFICE_TELEPHONE_NUMBER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OFFICE_TELEPHONE_NUMBER_W Field

public static readonly long PR_OFFICE_TELEPHONE_NUMBER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OFFICE2_TELEPHONE_NUMBER Field

public static readonly long PR_OFFICE2_TELEPHONE_NUMBER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OFFICE2_TELEPHONE_NUMBER_A Field

public static readonly long PR_OFFICE2_TELEPHONE_NUMBER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OFFICE2_TELEPHONE_NUMBER_W Field

public static readonly long PR_OFFICE2_TELEPHONE_NUMBER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OFFLINE_ADDRBOOK_ENTRYID Field

public static readonly long PR_OFFLINE_ADDRBOOK_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OFFLINE_FLAGS Field

public static readonly long PR_OFFLINE_FLAGS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OFFLINE_MESSAGE_ENTRYID Field

public static readonly long PR_OFFLINE_MESSAGE_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OLDEST_DELETED_ON Field

public static readonly long PR_OLDEST_DELETED_ON;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OOF_STATE Field

public static readonly long PR_OOF_STATE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORG_EMAIL_ADDR Field

public static readonly long PR_ORG_EMAIL_ADDR;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORG_EMAIL_ADDR_A Field

public static readonly long PR_ORG_EMAIL_ADDR_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORG_EMAIL_ADDR_W Field

public static readonly long PR_ORG_EMAIL_ADDR_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORGANIZATIONAL_ID_NUMBER Field

public static readonly long PR_ORGANIZATIONAL_ID_NUMBER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORGANIZATIONAL_ID_NUMBER_A Field

public static readonly long PR_ORGANIZATIONAL_ID_NUMBER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORGANIZATIONAL_ID_NUMBER_W Field

public static readonly long PR_ORGANIZATIONAL_ID_NUMBER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIG_MESSAGE_CLASS Field

public static readonly long PR_ORIG_MESSAGE_CLASS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIG_MESSAGE_CLASS_A Field

public static readonly long PR_ORIG_MESSAGE_CLASS_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIG_MESSAGE_CLASS_W Field

public static readonly long PR_ORIG_MESSAGE_CLASS_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGIN_CHECK Field

public static readonly long PR_ORIGIN_CHECK;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_AUTHOR_ADDRTYPE Field

public static readonly long PR_ORIGINAL_AUTHOR_ADDRTYPE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_AUTHOR_ADDRTYPE_A Field

public static readonly long PR_ORIGINAL_AUTHOR_ADDRTYPE_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_AUTHOR_ADDRTYPE_W Field

public static readonly long PR_ORIGINAL_AUTHOR_ADDRTYPE_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_AUTHOR_EMAIL_ADDRESS Field

public static readonly long PR_ORIGINAL_AUTHOR_EMAIL_ADDRESS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_AUTHOR_EMAIL_ADDRESS_A Field

public static readonly long PR_ORIGINAL_AUTHOR_EMAIL_ADDRESS_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_AUTHOR_EMAIL_ADDRESS_W Field

public static readonly long PR_ORIGINAL_AUTHOR_EMAIL_ADDRESS_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_AUTHOR_ENTRYID Field

public static readonly long PR_ORIGINAL_AUTHOR_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_AUTHOR_NAME Field

public static readonly long PR_ORIGINAL_AUTHOR_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_AUTHOR_NAME_A Field

public static readonly long PR_ORIGINAL_AUTHOR_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_AUTHOR_NAME_W Field

public static readonly long PR_ORIGINAL_AUTHOR_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_AUTHOR_SEARCH_KEY Field

public static readonly long PR_ORIGINAL_AUTHOR_SEARCH_KEY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_DELIVERY_TIME Field

public static readonly long PR_ORIGINAL_DELIVERY_TIME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_DISPLAY_BCC Field

public static readonly long PR_ORIGINAL_DISPLAY_BCC;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_DISPLAY_BCC_A Field

public static readonly long PR_ORIGINAL_DISPLAY_BCC_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_DISPLAY_BCC_W Field

public static readonly long PR_ORIGINAL_DISPLAY_BCC_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_DISPLAY_CC Field

public static readonly long PR_ORIGINAL_DISPLAY_CC;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_DISPLAY_CC_A Field

public static readonly long PR_ORIGINAL_DISPLAY_CC_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_DISPLAY_CC_W Field

public static readonly long PR_ORIGINAL_DISPLAY_CC_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_DISPLAY_NAME Field

public static readonly long PR_ORIGINAL_DISPLAY_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_DISPLAY_NAME_A Field

public static readonly long PR_ORIGINAL_DISPLAY_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_DISPLAY_NAME_W Field

public static readonly long PR_ORIGINAL_DISPLAY_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_DISPLAY_TO Field

public static readonly long PR_ORIGINAL_DISPLAY_TO;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_DISPLAY_TO_A Field

public static readonly long PR_ORIGINAL_DISPLAY_TO_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_DISPLAY_TO_W Field

public static readonly long PR_ORIGINAL_DISPLAY_TO_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_EITS Field

public static readonly long PR_ORIGINAL_EITS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_ENTRYID Field

public static readonly long PR_ORIGINAL_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_SEARCH_KEY Field

public static readonly long PR_ORIGINAL_SEARCH_KEY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_SENDER_ADDRTYPE Field

public static readonly long PR_ORIGINAL_SENDER_ADDRTYPE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_SENDER_ADDRTYPE_A Field

public static readonly long PR_ORIGINAL_SENDER_ADDRTYPE_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_SENDER_ADDRTYPE_W Field

public static readonly long PR_ORIGINAL_SENDER_ADDRTYPE_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_SENDER_EMAIL_ADDRESS Field

public static readonly long PR_ORIGINAL_SENDER_EMAIL_ADDRESS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_SENDER_EMAIL_ADDRESS_A Field

public static readonly long PR_ORIGINAL_SENDER_EMAIL_ADDRESS_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_SENDER_EMAIL_ADDRESS_W Field

public static readonly long PR_ORIGINAL_SENDER_EMAIL_ADDRESS_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_SENDER_ENTRYID Field

public static readonly long PR_ORIGINAL_SENDER_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_SENDER_NAME Field

public static readonly long PR_ORIGINAL_SENDER_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_SENDER_NAME_A Field

public static readonly long PR_ORIGINAL_SENDER_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_SENDER_NAME_W Field

public static readonly long PR_ORIGINAL_SENDER_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_SENDER_SEARCH_KEY Field

public static readonly long PR_ORIGINAL_SENDER_SEARCH_KEY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_SENSITIVITY Field

public static readonly long PR_ORIGINAL_SENSITIVITY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_SENT_REPRESENTING_ADDRTYPE Field

public static readonly long PR_ORIGINAL_SENT_REPRESENTING_ADDRTYPE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_SENT_REPRESENTING_ADDRTYPE_A Field

public static readonly long PR_ORIGINAL_SENT_REPRESENTING_ADDRTYPE_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_SENT_REPRESENTING_ADDRTYPE_W Field

public static readonly long PR_ORIGINAL_SENT_REPRESENTING_ADDRTYPE_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_SENT_REPRESENTING_EMAIL_ADDRESS Field

public static readonly long PR_ORIGINAL_SENT_REPRESENTING_EMAIL_ADDRESS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_SENT_REPRESENTING_EMAIL_ADDRESS_A Field

public static readonly long PR_ORIGINAL_SENT_REPRESENTING_EMAIL_ADDRESS_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_SENT_REPRESENTING_EMAIL_ADDRESS_W Field

public static readonly long PR_ORIGINAL_SENT_REPRESENTING_EMAIL_ADDRESS_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_SENT_REPRESENTING_ENTRYID Field

public static readonly long PR_ORIGINAL_SENT_REPRESENTING_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_SENT_REPRESENTING_NAME Field

public static readonly long PR_ORIGINAL_SENT_REPRESENTING_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_SENT_REPRESENTING_NAME_A Field

public static readonly long PR_ORIGINAL_SENT_REPRESENTING_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_SENT_REPRESENTING_NAME_W Field

public static readonly long PR_ORIGINAL_SENT_REPRESENTING_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_SENT_REPRESENTING_SEARCH_KEY Field

public static readonly long PR_ORIGINAL_SENT_REPRESENTING_SEARCH_KEY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_SUBJECT Field

public static readonly long PR_ORIGINAL_SUBJECT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_SUBJECT_A Field

public static readonly long PR_ORIGINAL_SUBJECT_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_SUBJECT_W Field

public static readonly long PR_ORIGINAL_SUBJECT_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINAL_SUBMIT_TIME Field

public static readonly long PR_ORIGINAL_SUBMIT_TIME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINALLY_INTENDED_RECIP_ADDRTYPE Field

public static readonly long PR_ORIGINALLY_INTENDED_RECIP_ADDRTYPE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINALLY_INTENDED_RECIP_ADDRTYPE_A Field

public static readonly long PR_ORIGINALLY_INTENDED_RECIP_ADDRTYPE_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINALLY_INTENDED_RECIP_ADDRTYPE_W Field

public static readonly long PR_ORIGINALLY_INTENDED_RECIP_ADDRTYPE_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINALLY_INTENDED_RECIP_EMAIL_ADDRESS Field

public static readonly long PR_ORIGINALLY_INTENDED_RECIP_EMAIL_ADDRESS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINALLY_INTENDED_RECIP_EMAIL_ADDRESS_A Field

public static readonly long PR_ORIGINALLY_INTENDED_RECIP_EMAIL_ADDRESS_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINALLY_INTENDED_RECIP_EMAIL_ADDRESS_W Field

public static readonly long PR_ORIGINALLY_INTENDED_RECIP_EMAIL_ADDRESS_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINALLY_INTENDED_RECIP_ENTRYID Field

public static readonly long PR_ORIGINALLY_INTENDED_RECIP_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINALLY_INTENDED_RECIPIENT_NAME Field

public static readonly long PR_ORIGINALLY_INTENDED_RECIPIENT_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINATING_MTA_CERTIFICATE Field

public static readonly long PR_ORIGINATING_MTA_CERTIFICATE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINATOR_ADDR Field

public static readonly long PR_ORIGINATOR_ADDR;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINATOR_ADDR_A Field

public static readonly long PR_ORIGINATOR_ADDR_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINATOR_ADDR_W Field

public static readonly long PR_ORIGINATOR_ADDR_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINATOR_ADDRTYPE Field

public static readonly long PR_ORIGINATOR_ADDRTYPE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINATOR_ADDRTYPE_A Field

public static readonly long PR_ORIGINATOR_ADDRTYPE_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINATOR_ADDRTYPE_W Field

public static readonly long PR_ORIGINATOR_ADDRTYPE_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINATOR_AND_DL_EXPANSION_HISTORY Field

public static readonly long PR_ORIGINATOR_AND_DL_EXPANSION_HISTORY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINATOR_CERTIFICATE Field

public static readonly long PR_ORIGINATOR_CERTIFICATE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINATOR_DELIVERY_REPORT_REQUESTED Field

public static readonly long PR_ORIGINATOR_DELIVERY_REPORT_REQUESTED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINATOR_ENTRYID Field

public static readonly long PR_ORIGINATOR_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINATOR_NAME Field

public static readonly long PR_ORIGINATOR_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINATOR_NAME_A Field

public static readonly long PR_ORIGINATOR_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINATOR_NAME_W Field

public static readonly long PR_ORIGINATOR_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINATOR_NON_DELIVERY_REPORT_REQUESTED Field

public static readonly long PR_ORIGINATOR_NON_DELIVERY_REPORT_REQUESTED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINATOR_REQUESTED_ALTERNATE_RECIPIENT Field

public static readonly long PR_ORIGINATOR_REQUESTED_ALTERNATE_RECIPIENT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ORIGINATOR_RETURN_ADDRESS Field

public static readonly long PR_ORIGINATOR_RETURN_ADDRESS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OST_ENCRYPTION Field

public static readonly long PR_OST_ENCRYPTION;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OTHER_ADDRESS_CITY Field

public static readonly long PR_OTHER_ADDRESS_CITY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OTHER_ADDRESS_CITY_A Field

public static readonly long PR_OTHER_ADDRESS_CITY_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OTHER_ADDRESS_CITY_W Field

public static readonly long PR_OTHER_ADDRESS_CITY_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OTHER_ADDRESS_COUNTRY Field

public static readonly long PR_OTHER_ADDRESS_COUNTRY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OTHER_ADDRESS_COUNTRY_A Field

public static readonly long PR_OTHER_ADDRESS_COUNTRY_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OTHER_ADDRESS_COUNTRY_W Field

public static readonly long PR_OTHER_ADDRESS_COUNTRY_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OTHER_ADDRESS_POST_OFFICE_BOX Field

public static readonly long PR_OTHER_ADDRESS_POST_OFFICE_BOX;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OTHER_ADDRESS_POST_OFFICE_BOX_A Field

public static readonly long PR_OTHER_ADDRESS_POST_OFFICE_BOX_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OTHER_ADDRESS_POST_OFFICE_BOX_W Field

public static readonly long PR_OTHER_ADDRESS_POST_OFFICE_BOX_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OTHER_ADDRESS_POSTAL_CODE Field

public static readonly long PR_OTHER_ADDRESS_POSTAL_CODE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OTHER_ADDRESS_POSTAL_CODE_A Field

public static readonly long PR_OTHER_ADDRESS_POSTAL_CODE_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OTHER_ADDRESS_POSTAL_CODE_W Field

public static readonly long PR_OTHER_ADDRESS_POSTAL_CODE_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OTHER_ADDRESS_STATE_OR_PROVINCE Field

public static readonly long PR_OTHER_ADDRESS_STATE_OR_PROVINCE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OTHER_ADDRESS_STATE_OR_PROVINCE_A Field

public static readonly long PR_OTHER_ADDRESS_STATE_OR_PROVINCE_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OTHER_ADDRESS_STATE_OR_PROVINCE_W Field

public static readonly long PR_OTHER_ADDRESS_STATE_OR_PROVINCE_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OTHER_ADDRESS_STREET Field

public static readonly long PR_OTHER_ADDRESS_STREET;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OTHER_ADDRESS_STREET_A Field

public static readonly long PR_OTHER_ADDRESS_STREET_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OTHER_ADDRESS_STREET_W Field

public static readonly long PR_OTHER_ADDRESS_STREET_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OTHER_TELEPHONE_NUMBER Field

public static readonly long PR_OTHER_TELEPHONE_NUMBER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OTHER_TELEPHONE_NUMBER_A Field

public static readonly long PR_OTHER_TELEPHONE_NUMBER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OTHER_TELEPHONE_NUMBER_W Field

public static readonly long PR_OTHER_TELEPHONE_NUMBER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OUTBOUND_NEWSFEED_DN Field

public static readonly long PR_OUTBOUND_NEWSFEED_DN;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OUTBOUND_NEWSFEED_DN_A Field

public static readonly long PR_OUTBOUND_NEWSFEED_DN_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OUTBOUND_NEWSFEED_DN_W Field

public static readonly long PR_OUTBOUND_NEWSFEED_DN_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OVERALL_AGE_LIMIT Field

public static readonly long PR_OVERALL_AGE_LIMIT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OVERALL_MSG_AGE_LIMIT Field

public static readonly long PR_OVERALL_MSG_AGE_LIMIT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OWA_URL Field

public static readonly long PR_OWA_URL;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OWA_URL_A Field

public static readonly long PR_OWA_URL_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OWA_URL_W Field

public static readonly long PR_OWA_URL_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OWN_STORE_ENTRYID Field

public static readonly long PR_OWN_STORE_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OWNER_APPT_ID Field

public static readonly long PR_OWNER_APPT_ID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_OWNER_COUNT Field

public static readonly long PR_OWNER_COUNT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_P1_CONTENT Field

public static readonly long PR_P1_CONTENT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_P1_CONTENT_TYPE Field

public static readonly long PR_P1_CONTENT_TYPE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PAGER_TELEPHONE_NUMBER Field

public static readonly long PR_PAGER_TELEPHONE_NUMBER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PAGER_TELEPHONE_NUMBER_A Field

public static readonly long PR_PAGER_TELEPHONE_NUMBER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PAGER_TELEPHONE_NUMBER_W Field

public static readonly long PR_PAGER_TELEPHONE_NUMBER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PARENT_DISPLAY Field

public static readonly long PR_PARENT_DISPLAY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PARENT_DISPLAY_A Field

public static readonly long PR_PARENT_DISPLAY_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PARENT_DISPLAY_W Field

public static readonly long PR_PARENT_DISPLAY_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PARENT_ENTRYID Field

public static readonly long PR_PARENT_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PARENT_KEY Field

public static readonly long PR_PARENT_KEY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PARENT_SOURCE_KEY Field

public static readonly long PR_PARENT_SOURCE_KEY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PERSONAL_HOME_PAGE Field

public static readonly long PR_PERSONAL_HOME_PAGE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PERSONAL_HOME_PAGE_A Field

public static readonly long PR_PERSONAL_HOME_PAGE_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PERSONAL_HOME_PAGE_W Field

public static readonly long PR_PERSONAL_HOME_PAGE_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PHYSICAL_DELIVERY_BUREAU_FAX_DELIVERY Field

public static readonly long PR_PHYSICAL_DELIVERY_BUREAU_FAX_DELIVERY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PHYSICAL_DELIVERY_MODE Field

public static readonly long PR_PHYSICAL_DELIVERY_MODE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PHYSICAL_DELIVERY_REPORT_REQUEST Field

public static readonly long PR_PHYSICAL_DELIVERY_REPORT_REQUEST;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PHYSICAL_FORWARDING_ADDRESS Field

public static readonly long PR_PHYSICAL_FORWARDING_ADDRESS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PHYSICAL_FORWARDING_ADDRESS_REQUESTED Field

public static readonly long PR_PHYSICAL_FORWARDING_ADDRESS_REQUESTED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PHYSICAL_FORWARDING_PROHIBITED Field

public static readonly long PR_PHYSICAL_FORWARDING_PROHIBITED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PHYSICAL_RENDITION_ATTRIBUTES Field

public static readonly long PR_PHYSICAL_RENDITION_ATTRIBUTES;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_POST_FOLDER_ENTRIES Field

public static readonly long PR_POST_FOLDER_ENTRIES;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_POST_FOLDER_NAMES Field

public static readonly long PR_POST_FOLDER_NAMES;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_POST_FOLDER_NAMES_A Field

public static readonly long PR_POST_FOLDER_NAMES_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_POST_FOLDER_NAMES_W Field

public static readonly long PR_POST_FOLDER_NAMES_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_POST_OFFICE_BOX Field

public static readonly long PR_POST_OFFICE_BOX;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_POST_OFFICE_BOX_A Field

public static readonly long PR_POST_OFFICE_BOX_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_POST_OFFICE_BOX_W Field

public static readonly long PR_POST_OFFICE_BOX_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_POST_REPLY_DENIED Field

public static readonly long PR_POST_REPLY_DENIED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_POST_REPLY_FOLDER_ENTRIES Field

public static readonly long PR_POST_REPLY_FOLDER_ENTRIES;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_POST_REPLY_FOLDER_NAMES Field

public static readonly long PR_POST_REPLY_FOLDER_NAMES;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_POST_REPLY_FOLDER_NAMES_A Field

public static readonly long PR_POST_REPLY_FOLDER_NAMES_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_POST_REPLY_FOLDER_NAMES_W Field

public static readonly long PR_POST_REPLY_FOLDER_NAMES_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_POSTAL_ADDRESS Field

public static readonly long PR_POSTAL_ADDRESS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_POSTAL_ADDRESS_A Field

public static readonly long PR_POSTAL_ADDRESS_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_POSTAL_ADDRESS_W Field

public static readonly long PR_POSTAL_ADDRESS_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_POSTAL_CODE Field

public static readonly long PR_POSTAL_CODE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_POSTAL_CODE_A Field

public static readonly long PR_POSTAL_CODE_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_POSTAL_CODE_W Field

public static readonly long PR_POSTAL_CODE_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PREDECESSOR_CHANGE_LIST Field

public static readonly long PR_PREDECESSOR_CHANGE_LIST;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PREFERRED_BY_NAME Field

public static readonly long PR_PREFERRED_BY_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PREFERRED_BY_NAME_A Field

public static readonly long PR_PREFERRED_BY_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PREFERRED_BY_NAME_W Field

public static readonly long PR_PREFERRED_BY_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PREPROCESS Field

public static readonly long PR_PREPROCESS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PREVENT_MSG_CREATE Field

public static readonly long PR_PREVENT_MSG_CREATE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PREVIEW Field

public static readonly long PR_PREVIEW;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PREVIEW_A Field

public static readonly long PR_PREVIEW_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PREVIEW_UNREAD Field

public static readonly long PR_PREVIEW_UNREAD;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PREVIEW_UNREAD_A Field

public static readonly long PR_PREVIEW_UNREAD_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PREVIEW_UNREAD_W Field

public static readonly long PR_PREVIEW_UNREAD_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PREVIEW_W Field

public static readonly long PR_PREVIEW_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PRIMARY_CAPABILITY Field

public static readonly long PR_PRIMARY_CAPABILITY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PRIMARY_FAX_NUMBER Field

public static readonly long PR_PRIMARY_FAX_NUMBER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PRIMARY_FAX_NUMBER_A Field

public static readonly long PR_PRIMARY_FAX_NUMBER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PRIMARY_FAX_NUMBER_W Field

public static readonly long PR_PRIMARY_FAX_NUMBER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PRIMARY_TELEPHONE_NUMBER Field

public static readonly long PR_PRIMARY_TELEPHONE_NUMBER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PRIMARY_TELEPHONE_NUMBER_A Field

public static readonly long PR_PRIMARY_TELEPHONE_NUMBER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PRIMARY_TELEPHONE_NUMBER_W Field

public static readonly long PR_PRIMARY_TELEPHONE_NUMBER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PRIORITY Field

public static readonly long PR_PRIORITY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFESSION Field

public static readonly long PR_PROFESSION;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFESSION_A Field

public static readonly long PR_PROFESSION_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFESSION_W Field

public static readonly long PR_PROFESSION_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_AB_FILES_PATH Field

public static readonly long PR_PROFILE_AB_FILES_PATH;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_AB_FILES_PATH_A Field

public static readonly long PR_PROFILE_AB_FILES_PATH_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_AB_FILES_PATH_W Field

public static readonly long PR_PROFILE_AB_FILES_PATH_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_ADDR_INFO Field

public static readonly long PR_PROFILE_ADDR_INFO;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_ALLPUB_COMMENT Field

public static readonly long PR_PROFILE_ALLPUB_COMMENT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_ALLPUB_COMMENT_A Field

public static readonly long PR_PROFILE_ALLPUB_COMMENT_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_ALLPUB_COMMENT_W Field

public static readonly long PR_PROFILE_ALLPUB_COMMENT_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_ALLPUB_DISPLAY_NAME Field

public static readonly long PR_PROFILE_ALLPUB_DISPLAY_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_ALLPUB_DISPLAY_NAME_A Field

public static readonly long PR_PROFILE_ALLPUB_DISPLAY_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_ALLPUB_DISPLAY_NAME_W Field

public static readonly long PR_PROFILE_ALLPUB_DISPLAY_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_AUTH_PACKAGE Field

public static readonly long PR_PROFILE_AUTH_PACKAGE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_BINDING_ORDER Field

public static readonly long PR_PROFILE_BINDING_ORDER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_BINDING_ORDER_A Field

public static readonly long PR_PROFILE_BINDING_ORDER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_BINDING_ORDER_W Field

public static readonly long PR_PROFILE_BINDING_ORDER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_CONFIG_FLAGS Field

public static readonly long PR_PROFILE_CONFIG_FLAGS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_CONNECT_FLAGS Field

public static readonly long PR_PROFILE_CONNECT_FLAGS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_FAVFLD_COMMENT Field

public static readonly long PR_PROFILE_FAVFLD_COMMENT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_FAVFLD_COMMENT_A Field

public static readonly long PR_PROFILE_FAVFLD_COMMENT_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_FAVFLD_COMMENT_W Field

public static readonly long PR_PROFILE_FAVFLD_COMMENT_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_FAVFLD_DISPLAY_NAME Field

public static readonly long PR_PROFILE_FAVFLD_DISPLAY_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_FAVFLD_DISPLAY_NAME_A Field

public static readonly long PR_PROFILE_FAVFLD_DISPLAY_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_FAVFLD_DISPLAY_NAME_W Field

public static readonly long PR_PROFILE_FAVFLD_DISPLAY_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_HOME_SERVER Field

public static readonly long PR_PROFILE_HOME_SERVER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_HOME_SERVER_A Field

public static readonly long PR_PROFILE_HOME_SERVER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_HOME_SERVER_ADDRS Field

public static readonly long PR_PROFILE_HOME_SERVER_ADDRS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_HOME_SERVER_DN Field

public static readonly long PR_PROFILE_HOME_SERVER_DN;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_HOME_SERVER_DN_A Field

public static readonly long PR_PROFILE_HOME_SERVER_DN_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_HOME_SERVER_DN_W Field

public static readonly long PR_PROFILE_HOME_SERVER_DN_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_HOME_SERVER_W Field

public static readonly long PR_PROFILE_HOME_SERVER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_MAILBOX Field

public static readonly long PR_PROFILE_MAILBOX;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_MAILBOX_A Field

public static readonly long PR_PROFILE_MAILBOX_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_MAILBOX_W Field

public static readonly long PR_PROFILE_MAILBOX_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_MAX_RESTRICT Field

public static readonly long PR_PROFILE_MAX_RESTRICT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_MOAB Field

public static readonly long PR_PROFILE_MOAB;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_MOAB_A Field

public static readonly long PR_PROFILE_MOAB_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_MOAB_GUID Field

public static readonly long PR_PROFILE_MOAB_GUID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_MOAB_GUID_A Field

public static readonly long PR_PROFILE_MOAB_GUID_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_MOAB_GUID_W Field

public static readonly long PR_PROFILE_MOAB_GUID_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_MOAB_SEQ Field

public static readonly long PR_PROFILE_MOAB_SEQ;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_MOAB_W Field

public static readonly long PR_PROFILE_MOAB_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_NAME Field

public static readonly long PR_PROFILE_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_NAME_A Field

public static readonly long PR_PROFILE_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_NAME_W Field

public static readonly long PR_PROFILE_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_OFFLINE_INFO Field

public static readonly long PR_PROFILE_OFFLINE_INFO;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_OFFLINE_STORE_PATH Field

public static readonly long PR_PROFILE_OFFLINE_STORE_PATH;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_OFFLINE_STORE_PATH_A Field

public static readonly long PR_PROFILE_OFFLINE_STORE_PATH_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_OFFLINE_STORE_PATH_W Field

public static readonly long PR_PROFILE_OFFLINE_STORE_PATH_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_OPEN_FLAGS Field

public static readonly long PR_PROFILE_OPEN_FLAGS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_OPTIONS_DATA Field

public static readonly long PR_PROFILE_OPTIONS_DATA;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_SECURE_MAILBOX Field

public static readonly long PR_PROFILE_SECURE_MAILBOX;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_SERVER Field

public static readonly long PR_PROFILE_SERVER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_SERVER_A Field

public static readonly long PR_PROFILE_SERVER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_SERVER_DN Field

public static readonly long PR_PROFILE_SERVER_DN;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_SERVER_DN_A Field

public static readonly long PR_PROFILE_SERVER_DN_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_SERVER_DN_W Field

public static readonly long PR_PROFILE_SERVER_DN_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_SERVER_W Field

public static readonly long PR_PROFILE_SERVER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_TRANSPORT_FLAGS Field

public static readonly long PR_PROFILE_TRANSPORT_FLAGS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_TYPE Field

public static readonly long PR_PROFILE_TYPE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_UI_STATE Field

public static readonly long PR_PROFILE_UI_STATE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_UNRESOLVED_NAME Field

public static readonly long PR_PROFILE_UNRESOLVED_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_UNRESOLVED_NAME_A Field

public static readonly long PR_PROFILE_UNRESOLVED_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_UNRESOLVED_NAME_W Field

public static readonly long PR_PROFILE_UNRESOLVED_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_UNRESOLVED_SERVER Field

public static readonly long PR_PROFILE_UNRESOLVED_SERVER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_UNRESOLVED_SERVER_A Field

public static readonly long PR_PROFILE_UNRESOLVED_SERVER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_UNRESOLVED_SERVER_W Field

public static readonly long PR_PROFILE_UNRESOLVED_SERVER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_USER Field

public static readonly long PR_PROFILE_USER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_USER_A Field

public static readonly long PR_PROFILE_USER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_USER_W Field

public static readonly long PR_PROFILE_USER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROFILE_VERSION Field

public static readonly long PR_PROFILE_VERSION;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROMOTE_PROP_ID_LIST Field

public static readonly long PR_PROMOTE_PROP_ID_LIST;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROOF_OF_DELIVERY Field

public static readonly long PR_PROOF_OF_DELIVERY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROOF_OF_DELIVERY_REQUESTED Field

public static readonly long PR_PROOF_OF_DELIVERY_REQUESTED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROOF_OF_SUBMISSION Field

public static readonly long PR_PROOF_OF_SUBMISSION;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROOF_OF_SUBMISSION_REQUESTED Field

public static readonly long PR_PROOF_OF_SUBMISSION_REQUESTED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROVIDER_DISPLAY Field

public static readonly long PR_PROVIDER_DISPLAY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROVIDER_DISPLAY_A Field

public static readonly long PR_PROVIDER_DISPLAY_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROVIDER_DISPLAY_W Field

public static readonly long PR_PROVIDER_DISPLAY_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROVIDER_DLL_NAME Field

public static readonly long PR_PROVIDER_DLL_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROVIDER_DLL_NAME_A Field

public static readonly long PR_PROVIDER_DLL_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROVIDER_DLL_NAME_W Field

public static readonly long PR_PROVIDER_DLL_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROVIDER_ORDINAL Field

public static readonly long PR_PROVIDER_ORDINAL;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROVIDER_SUBMIT_TIME Field

public static readonly long PR_PROVIDER_SUBMIT_TIME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PROVIDER_UID Field

public static readonly long PR_PROVIDER_UID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PST_ENCRYPTION Field

public static readonly long PR_PST_ENCRYPTION;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PST_PASSWORD Field

Contains the CRC-32 hash of the password string of PST. If the property exists and is nonzero, then the PST file is password protected.

public static readonly long PR_PST_PASSWORD;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PST_PATH Field

public static readonly long PR_PST_PATH;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PST_PATH_A Field

public static readonly long PR_PST_PATH_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PST_PATH_W Field

public static readonly long PR_PST_PATH_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PST_PW_SZ_NEW Field

public static readonly long PR_PST_PW_SZ_NEW;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PST_PW_SZ_NEW_A Field

public static readonly long PR_PST_PW_SZ_NEW_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PST_PW_SZ_NEW_W Field

public static readonly long PR_PST_PW_SZ_NEW_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PST_PW_SZ_OLD Field

public static readonly long PR_PST_PW_SZ_OLD;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PST_PW_SZ_OLD_A Field

public static readonly long PR_PST_PW_SZ_OLD_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PST_PW_SZ_OLD_W Field

public static readonly long PR_PST_PW_SZ_OLD_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PST_REMEMBER_PW Field

public static readonly long PR_PST_REMEMBER_PW;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PUBLIC_FOLDER_ENTRYID Field

public static readonly long PR_PUBLIC_FOLDER_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_PUBLISH_IN_ADDRESS_BOOK Field

public static readonly long PR_PUBLISH_IN_ADDRESS_BOOK;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RADIO_TELEPHONE_NUMBER Field

public static readonly long PR_RADIO_TELEPHONE_NUMBER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RADIO_TELEPHONE_NUMBER_A Field

public static readonly long PR_RADIO_TELEPHONE_NUMBER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RADIO_TELEPHONE_NUMBER_W Field

public static readonly long PR_RADIO_TELEPHONE_NUMBER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RCVD_REPRESENTING_ADDRTYPE Field

public static readonly long PR_RCVD_REPRESENTING_ADDRTYPE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RCVD_REPRESENTING_ADDRTYPE_A Field

public static readonly long PR_RCVD_REPRESENTING_ADDRTYPE_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RCVD_REPRESENTING_ADDRTYPE_W Field

public static readonly long PR_RCVD_REPRESENTING_ADDRTYPE_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RCVD_REPRESENTING_EMAIL_ADDRESS Field

public static readonly long PR_RCVD_REPRESENTING_EMAIL_ADDRESS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RCVD_REPRESENTING_EMAIL_ADDRESS_A Field

public static readonly long PR_RCVD_REPRESENTING_EMAIL_ADDRESS_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RCVD_REPRESENTING_EMAIL_ADDRESS_W Field

public static readonly long PR_RCVD_REPRESENTING_EMAIL_ADDRESS_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RCVD_REPRESENTING_ENTRYID Field

public static readonly long PR_RCVD_REPRESENTING_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RCVD_REPRESENTING_NAME Field

public static readonly long PR_RCVD_REPRESENTING_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RCVD_REPRESENTING_NAME_A Field

public static readonly long PR_RCVD_REPRESENTING_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RCVD_REPRESENTING_NAME_W Field

public static readonly long PR_RCVD_REPRESENTING_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RCVD_REPRESENTING_SEARCH_KEY Field

public static readonly long PR_RCVD_REPRESENTING_SEARCH_KEY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_READ_RECEIPT_ENTRYID Field

public static readonly long PR_READ_RECEIPT_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_READ_RECEIPT_REQUESTED Field

public static readonly long PR_READ_RECEIPT_REQUESTED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_READ_RECEIPT_SEARCH_KEY Field

public static readonly long PR_READ_RECEIPT_SEARCH_KEY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RECEIPT_TIME Field

public static readonly long PR_RECEIPT_TIME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RECEIVE_FOLDER_SETTINGS Field

public static readonly long PR_RECEIVE_FOLDER_SETTINGS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RECEIVED_BY_ADDRTYPE Field

public static readonly long PR_RECEIVED_BY_ADDRTYPE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RECEIVED_BY_ADDRTYPE_A Field

public static readonly long PR_RECEIVED_BY_ADDRTYPE_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RECEIVED_BY_ADDRTYPE_W Field

public static readonly long PR_RECEIVED_BY_ADDRTYPE_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RECEIVED_BY_EMAIL_ADDRESS Field

public static readonly long PR_RECEIVED_BY_EMAIL_ADDRESS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RECEIVED_BY_EMAIL_ADDRESS_A Field

public static readonly long PR_RECEIVED_BY_EMAIL_ADDRESS_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RECEIVED_BY_EMAIL_ADDRESS_W Field

public static readonly long PR_RECEIVED_BY_EMAIL_ADDRESS_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RECEIVED_BY_ENTRYID Field

public static readonly long PR_RECEIVED_BY_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RECEIVED_BY_NAME Field

public static readonly long PR_RECEIVED_BY_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RECEIVED_BY_NAME_A Field

public static readonly long PR_RECEIVED_BY_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RECEIVED_BY_NAME_W Field

public static readonly long PR_RECEIVED_BY_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RECEIVED_BY_SEARCH_KEY Field

public static readonly long PR_RECEIVED_BY_SEARCH_KEY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RECIPIENT_CERTIFICATE Field

public static readonly long PR_RECIPIENT_CERTIFICATE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RECIPIENT_NUMBER Field

public static readonly long PR_RECIPIENT_NUMBER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RECIPIENT_NUMBER_FOR_ADVICE Field

public static readonly long PR_RECIPIENT_NUMBER_FOR_ADVICE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RECIPIENT_NUMBER_FOR_ADVICE_A Field

public static readonly long PR_RECIPIENT_NUMBER_FOR_ADVICE_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RECIPIENT_NUMBER_FOR_ADVICE_W Field

public static readonly long PR_RECIPIENT_NUMBER_FOR_ADVICE_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RECIPIENT_ON_ASSOC_MSG_COUNT Field

public static readonly long PR_RECIPIENT_ON_ASSOC_MSG_COUNT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RECIPIENT_ON_NORMAL_MSG_COUNT Field

public static readonly long PR_RECIPIENT_ON_NORMAL_MSG_COUNT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RECIPIENT_REASSIGNMENT_PROHIBITED Field

public static readonly long PR_RECIPIENT_REASSIGNMENT_PROHIBITED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RECIPIENT_STATUS Field

public static readonly long PR_RECIPIENT_STATUS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RECIPIENT_TYPE Field

public static readonly long PR_RECIPIENT_TYPE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RECORD_KEY Field

public static readonly long PR_RECORD_KEY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_REDIRECTION_HISTORY Field

public static readonly long PR_REDIRECTION_HISTORY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_REFERRED_BY_NAME Field

public static readonly long PR_REFERRED_BY_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_REFERRED_BY_NAME_A Field

public static readonly long PR_REFERRED_BY_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_REFERRED_BY_NAME_W Field

public static readonly long PR_REFERRED_BY_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_REGISTERED_MAIL_TYPE Field

public static readonly long PR_REGISTERED_MAIL_TYPE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RELATED_IPMS Field

public static readonly long PR_RELATED_IPMS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_REMOTE_PROGRESS Field

public static readonly long PR_REMOTE_PROGRESS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_REMOTE_PROGRESS_TEXT Field

public static readonly long PR_REMOTE_PROGRESS_TEXT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_REMOTE_PROGRESS_TEXT_A Field

public static readonly long PR_REMOTE_PROGRESS_TEXT_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_REMOTE_PROGRESS_TEXT_W Field

public static readonly long PR_REMOTE_PROGRESS_TEXT_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_REMOTE_VALIDATE_OK Field

public static readonly long PR_REMOTE_VALIDATE_OK;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RENDERING_POSITION Field

public static readonly long PR_RENDERING_POSITION;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_REPLICA_LIST Field

public static readonly long PR_REPLICA_LIST;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_REPLICA_SERVER Field

public static readonly long PR_REPLICA_SERVER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_REPLICA_SERVER_A Field

public static readonly long PR_REPLICA_SERVER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_REPLICA_SERVER_W Field

public static readonly long PR_REPLICA_SERVER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_REPLICA_VERSION Field

public static readonly long PR_REPLICA_VERSION;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_REPLICATION_ALWAYS_INTERVAL Field

public static readonly long PR_REPLICATION_ALWAYS_INTERVAL;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_REPLICATION_MESSAGE_PRIORITY Field

public static readonly long PR_REPLICATION_MESSAGE_PRIORITY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_REPLICATION_MSG_SIZE Field

public static readonly long PR_REPLICATION_MSG_SIZE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_REPLICATION_SCHEDULE Field

public static readonly long PR_REPLICATION_SCHEDULE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_REPLICATION_STYLE Field

public static readonly long PR_REPLICATION_STYLE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_REPLY_RECIPIENT_ENTRIES Field

public static readonly long PR_REPLY_RECIPIENT_ENTRIES;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_REPLY_RECIPIENT_NAMES Field

public static readonly long PR_REPLY_RECIPIENT_NAMES;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_REPLY_RECIPIENT_NAMES_A Field

public static readonly long PR_REPLY_RECIPIENT_NAMES_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_REPLY_RECIPIENT_NAMES_W Field

public static readonly long PR_REPLY_RECIPIENT_NAMES_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_REPLY_RECIPIENT_SMTP_PROXIES Field

public static readonly long PR_REPLY_RECIPIENT_SMTP_PROXIES;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_REPLY_RECIPIENT_SMTP_PROXIES_A Field

public static readonly long PR_REPLY_RECIPIENT_SMTP_PROXIES_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_REPLY_RECIPIENT_SMTP_PROXIES_W Field

public static readonly long PR_REPLY_RECIPIENT_SMTP_PROXIES_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_REPLY_REQUESTED Field

public static readonly long PR_REPLY_REQUESTED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_REPLY_TIME Field

public static readonly long PR_REPLY_TIME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_REPORT_DESTINATION_ENTRYID Field

public static readonly long PR_REPORT_DESTINATION_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_REPORT_DESTINATION_NAME Field

public static readonly long PR_REPORT_DESTINATION_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_REPORT_DESTINATION_NAME_A Field

public static readonly long PR_REPORT_DESTINATION_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_REPORT_DESTINATION_NAME_W Field

public static readonly long PR_REPORT_DESTINATION_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_REPORT_ENTRYID Field

public static readonly long PR_REPORT_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_REPORT_NAME Field

public static readonly long PR_REPORT_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_REPORT_NAME_A Field

public static readonly long PR_REPORT_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_REPORT_NAME_W Field

public static readonly long PR_REPORT_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_REPORT_SEARCH_KEY Field

public static readonly long PR_REPORT_SEARCH_KEY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_REPORT_TAG Field

public static readonly long PR_REPORT_TAG;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_REPORT_TEXT Field

public static readonly long PR_REPORT_TEXT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_REPORT_TEXT_A Field

public static readonly long PR_REPORT_TEXT_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_REPORT_TEXT_W Field

public static readonly long PR_REPORT_TEXT_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_REPORT_TIME Field

public static readonly long PR_REPORT_TIME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_REPORTING_DL_NAME Field

public static readonly long PR_REPORTING_DL_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_REPORTING_MTA_CERTIFICATE Field

public static readonly long PR_REPORTING_MTA_CERTIFICATE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_REQUESTED_DELIVERY_METHOD Field

public static readonly long PR_REQUESTED_DELIVERY_METHOD;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RESOLVE_METHOD Field

public static readonly long PR_RESOLVE_METHOD;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RESOURCE_FLAGS Field

public static readonly long PR_RESOURCE_FLAGS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RESOURCE_METHODS Field

public static readonly long PR_RESOURCE_METHODS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RESOURCE_PATH Field

public static readonly long PR_RESOURCE_PATH;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RESOURCE_PATH_A Field

public static readonly long PR_RESOURCE_PATH_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RESOURCE_PATH_W Field

public static readonly long PR_RESOURCE_PATH_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RESOURCE_TYPE Field

public static readonly long PR_RESOURCE_TYPE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RESPONSE_REQUESTED Field

public static readonly long PR_RESPONSE_REQUESTED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RESPONSIBILITY Field

public static readonly long PR_RESPONSIBILITY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RESTRICTION_COUNT Field

public static readonly long PR_RESTRICTION_COUNT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RETENTION_AGE_LIMIT Field

public static readonly long PR_RETENTION_AGE_LIMIT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RETURNED_IPM Field

public static readonly long PR_RETURNED_IPM;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RIGHTS Field

public static readonly long PR_RIGHTS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ROW_TYPE Field

public static readonly long PR_ROW_TYPE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_ROWID Field

public static readonly long PR_ROWID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RTF_COMPRESSED Field

public static readonly long PR_RTF_COMPRESSED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RTF_DECOMPRESSED Field

public static readonly long PR_RTF_DECOMPRESSED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RTF_IN_SYNC Field

public static readonly long PR_RTF_IN_SYNC;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RTF_SYNC_BODY_COUNT Field

public static readonly long PR_RTF_SYNC_BODY_COUNT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RTF_SYNC_BODY_CRC Field

public static readonly long PR_RTF_SYNC_BODY_CRC;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RTF_SYNC_BODY_TAG Field

public static readonly long PR_RTF_SYNC_BODY_TAG;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RTF_SYNC_BODY_TAG_A Field

public static readonly long PR_RTF_SYNC_BODY_TAG_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RTF_SYNC_BODY_TAG_W Field

public static readonly long PR_RTF_SYNC_BODY_TAG_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RTF_SYNC_PREFIX_COUNT Field

public static readonly long PR_RTF_SYNC_PREFIX_COUNT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RTF_SYNC_TRAILING_COUNT Field

public static readonly long PR_RTF_SYNC_TRAILING_COUNT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RULE_ACTION_NUMBER Field

public static readonly long PR_RULE_ACTION_NUMBER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RULE_ACTION_TYPE Field

public static readonly long PR_RULE_ACTION_TYPE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RULE_ACTIONS Field

public static readonly long PR_RULE_ACTIONS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RULE_CONDITION Field

public static readonly long PR_RULE_CONDITION;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RULE_ERROR Field

public static readonly long PR_RULE_ERROR;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RULE_FOLDER_ENTRYID Field

public static readonly long PR_RULE_FOLDER_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RULE_ID Field

public static readonly long PR_RULE_ID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RULE_IDS Field

public static readonly long PR_RULE_IDS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RULE_LEVEL Field

public static readonly long PR_RULE_LEVEL;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RULE_NAME Field

public static readonly long PR_RULE_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RULE_NAME_A Field

public static readonly long PR_RULE_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RULE_NAME_W Field

public static readonly long PR_RULE_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RULE_PROVIDER Field

public static readonly long PR_RULE_PROVIDER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RULE_PROVIDER_A Field

public static readonly long PR_RULE_PROVIDER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RULE_PROVIDER_DATA Field

public static readonly long PR_RULE_PROVIDER_DATA;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RULE_PROVIDER_W Field

public static readonly long PR_RULE_PROVIDER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RULE_SEQUENCE Field

public static readonly long PR_RULE_SEQUENCE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RULE_STATE Field

public static readonly long PR_RULE_STATE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RULE_TRIGGER_HISTORY Field

public static readonly long PR_RULE_TRIGGER_HISTORY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RULE_USER_FLAGS Field

public static readonly long PR_RULE_USER_FLAGS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RULES_DATA Field

public static readonly long PR_RULES_DATA;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_RULES_TABLE Field

public static readonly long PR_RULES_TABLE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SCHEDULE_FOLDER_ENTRYID Field

public static readonly long PR_SCHEDULE_FOLDER_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SEARCH Field

public static readonly long PR_SEARCH;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SEARCH_KEY Field

public static readonly long PR_SEARCH_KEY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SECURE_IN_SITE Field

public static readonly long PR_SECURE_IN_SITE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SECURE_ORIGINATION Field

public static readonly long PR_SECURE_ORIGINATION;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SECURITY Field

public static readonly long PR_SECURITY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SELECTABLE Field

public static readonly long PR_SELECTABLE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SEND_INTERNET_ENCODING Field

public static readonly long PR_SEND_INTERNET_ENCODING;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SEND_RICH_INFO Field

public static readonly long PR_SEND_RICH_INFO;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SENDER_ADDRTYPE Field

public static readonly long PR_SENDER_ADDRTYPE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SENDER_ADDRTYPE_A Field

public static readonly long PR_SENDER_ADDRTYPE_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SENDER_ADDRTYPE_W Field

public static readonly long PR_SENDER_ADDRTYPE_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SENDER_EMAIL_ADDRESS Field

public static readonly long PR_SENDER_EMAIL_ADDRESS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SENDER_EMAIL_ADDRESS_A Field

public static readonly long PR_SENDER_EMAIL_ADDRESS_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SENDER_EMAIL_ADDRESS_W Field

public static readonly long PR_SENDER_EMAIL_ADDRESS_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SENDER_ENTRYID Field

public static readonly long PR_SENDER_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SENDER_NAME Field

public static readonly long PR_SENDER_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SENDER_NAME_A Field

public static readonly long PR_SENDER_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SENDER_NAME_W Field

public static readonly long PR_SENDER_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SENDER_SEARCH_KEY Field

public static readonly long PR_SENDER_SEARCH_KEY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SENSITIVITY Field

public static readonly long PR_SENSITIVITY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SENT_REPRESENTING_ADDRTYPE Field

public static readonly long PR_SENT_REPRESENTING_ADDRTYPE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SENT_REPRESENTING_ADDRTYPE_A Field

public static readonly long PR_SENT_REPRESENTING_ADDRTYPE_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SENT_REPRESENTING_ADDRTYPE_W Field

public static readonly long PR_SENT_REPRESENTING_ADDRTYPE_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SENT_REPRESENTING_EMAIL_ADDRESS Field

public static readonly long PR_SENT_REPRESENTING_EMAIL_ADDRESS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SENT_REPRESENTING_EMAIL_ADDRESS_A Field

public static readonly long PR_SENT_REPRESENTING_EMAIL_ADDRESS_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SENT_REPRESENTING_EMAIL_ADDRESS_W Field

public static readonly long PR_SENT_REPRESENTING_EMAIL_ADDRESS_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SENT_REPRESENTING_ENTRYID Field

public static readonly long PR_SENT_REPRESENTING_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SENT_REPRESENTING_NAME Field

public static readonly long PR_SENT_REPRESENTING_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SENT_REPRESENTING_NAME_A Field

public static readonly long PR_SENT_REPRESENTING_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SENT_REPRESENTING_NAME_W Field

public static readonly long PR_SENT_REPRESENTING_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SENT_REPRESENTING_SEARCH_KEY Field

public static readonly long PR_SENT_REPRESENTING_SEARCH_KEY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SENTMAIL_ENTRYID Field

public static readonly long PR_SENTMAIL_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SERVICE_DELETE_FILES Field

public static readonly long PR_SERVICE_DELETE_FILES;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SERVICE_DLL_NAME Field

public static readonly long PR_SERVICE_DLL_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SERVICE_DLL_NAME_A Field

public static readonly long PR_SERVICE_DLL_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SERVICE_DLL_NAME_W Field

public static readonly long PR_SERVICE_DLL_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SERVICE_ENTRY_NAME Field

public static readonly long PR_SERVICE_ENTRY_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SERVICE_ENTRY_NAME_A Field

public static readonly long PR_SERVICE_ENTRY_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SERVICE_ENTRY_NAME_W Field

public static readonly long PR_SERVICE_ENTRY_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SERVICE_EXTRA_UIDS Field

public static readonly long PR_SERVICE_EXTRA_UIDS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SERVICE_NAME Field

public static readonly long PR_SERVICE_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SERVICE_NAME_A Field

public static readonly long PR_SERVICE_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SERVICE_NAME_W Field

public static readonly long PR_SERVICE_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SERVICE_SUPPORT_FILES Field

public static readonly long PR_SERVICE_SUPPORT_FILES;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SERVICE_UID Field

public static readonly long PR_SERVICE_UID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SERVICES Field

public static readonly long PR_SERVICES;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SORT_LOCALE_ID Field

public static readonly long PR_SORT_LOCALE_ID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SOURCE_KEY Field

public static readonly long PR_SOURCE_KEY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SPLUS_FREE_BUSY_ENTRYID Field

public static readonly long PR_SPLUS_FREE_BUSY_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SPOOLER_STATUS Field

public static readonly long PR_SPOOLER_STATUS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SPOUSE_NAME Field

public static readonly long PR_SPOUSE_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SPOUSE_NAME_A Field

public static readonly long PR_SPOUSE_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SPOUSE_NAME_W Field

public static readonly long PR_SPOUSE_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_START_DATE Field

public static readonly long PR_START_DATE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_STATE_OR_PROVINCE Field

public static readonly long PR_STATE_OR_PROVINCE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_STATE_OR_PROVINCE_A Field

public static readonly long PR_STATE_OR_PROVINCE_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_STATE_OR_PROVINCE_W Field

public static readonly long PR_STATE_OR_PROVINCE_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_STATUS Field

public static readonly long PR_STATUS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_STATUS_CODE Field

public static readonly long PR_STATUS_CODE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_STATUS_STRING Field

public static readonly long PR_STATUS_STRING;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_STATUS_STRING_A Field

public static readonly long PR_STATUS_STRING_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_STATUS_STRING_W Field

public static readonly long PR_STATUS_STRING_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_STORAGE_LIMIT_INFORMATION Field

public static readonly long PR_STORAGE_LIMIT_INFORMATION;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_STORAGE_QUOTA_LIMIT Field

public static readonly long PR_STORAGE_QUOTA_LIMIT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_STORE_ENTRYID Field

public static readonly long PR_STORE_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_STORE_OFFLINE Field

public static readonly long PR_STORE_OFFLINE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_STORE_PROVIDERS Field

public static readonly long PR_STORE_PROVIDERS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_STORE_RECORD_KEY Field

public static readonly long PR_STORE_RECORD_KEY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_STORE_SLOWLINK Field

public static readonly long PR_STORE_SLOWLINK;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_STORE_STATE Field

public static readonly long PR_STORE_STATE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_STORE_SUPPORT_MASK Field

public static readonly long PR_STORE_SUPPORT_MASK;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_STREET_ADDRESS Field

public static readonly long PR_STREET_ADDRESS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_STREET_ADDRESS_A Field

public static readonly long PR_STREET_ADDRESS_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_STREET_ADDRESS_W Field

public static readonly long PR_STREET_ADDRESS_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SUBFOLDERS Field

public static readonly long PR_SUBFOLDERS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SUBJECT Field

public static readonly long PR_SUBJECT;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SUBJECT_A Field

public static readonly long PR_SUBJECT_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SUBJECT_IPM Field

public static readonly long PR_SUBJECT_IPM;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SUBJECT_PREFIX Field

public static readonly long PR_SUBJECT_PREFIX;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SUBJECT_PREFIX_A Field

public static readonly long PR_SUBJECT_PREFIX_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SUBJECT_PREFIX_W Field

public static readonly long PR_SUBJECT_PREFIX_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SUBJECT_TRACE_INFO Field

public static readonly long PR_SUBJECT_TRACE_INFO;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SUBJECT_W Field

public static readonly long PR_SUBJECT_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SUBMIT_FLAGS Field

public static readonly long PR_SUBMIT_FLAGS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SUPERSEDES Field

public static readonly long PR_SUPERSEDES;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SUPERSEDES_A Field

public static readonly long PR_SUPERSEDES_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SUPERSEDES_W Field

public static readonly long PR_SUPERSEDES_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SUPPLEMENTARY_INFO Field

public static readonly long PR_SUPPLEMENTARY_INFO;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SUPPLEMENTARY_INFO_A Field

public static readonly long PR_SUPPLEMENTARY_INFO_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SUPPLEMENTARY_INFO_W Field

public static readonly long PR_SUPPLEMENTARY_INFO_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SURNAME Field

public static readonly long PR_SURNAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SURNAME_A Field

public static readonly long PR_SURNAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SURNAME_W Field

public static readonly long PR_SURNAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SVR_GENERATING_QUOTA_MSG Field

public static readonly long PR_SVR_GENERATING_QUOTA_MSG;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SVR_GENERATING_QUOTA_MSG_A Field

public static readonly long PR_SVR_GENERATING_QUOTA_MSG_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SVR_GENERATING_QUOTA_MSG_W Field

public static readonly long PR_SVR_GENERATING_QUOTA_MSG_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SWAPPED_TODO_DATA Field

Maintains a second set of property values that do not affect the flagged state of the Message object.

public static readonly long PR_SWAPPED_TODO_DATA;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SYNCHRONIZE_FLAGS Field

public static readonly long PR_SYNCHRONIZE_FLAGS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_SYS_CONFIG_FOLDER_ENTRYID Field

public static readonly long PR_SYS_CONFIG_FOLDER_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_TELEX_NUMBER Field

public static readonly long PR_TELEX_NUMBER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_TELEX_NUMBER_A Field

public static readonly long PR_TELEX_NUMBER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_TELEX_NUMBER_W Field

public static readonly long PR_TELEX_NUMBER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_TEMPLATEID Field

public static readonly long PR_TEMPLATEID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_TEST_LINE_SPEED Field

public static readonly long PR_TEST_LINE_SPEED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_TITLE Field

public static readonly long PR_TITLE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_TITLE_A Field

public static readonly long PR_TITLE_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_TITLE_W Field

public static readonly long PR_TITLE_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_TNEF_CORRELATION_KEY Field

public static readonly long PR_TNEF_CORRELATION_KEY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_TODO_ITEM_FLAGS Field

Represents a To-Do item's flagged condition.

public static readonly long PR_TODO_ITEM_FLAGS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_TRACE_INFO Field

public static readonly long PR_TRACE_INFO;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_TRANSFER_ENABLED Field

public static readonly long PR_TRANSFER_ENABLED;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_TRANSMITABLE_DISPLAY_NAME Field

public static readonly long PR_TRANSMITABLE_DISPLAY_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_TRANSMITABLE_DISPLAY_NAME_A Field

public static readonly long PR_TRANSMITABLE_DISPLAY_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_TRANSMITABLE_DISPLAY_NAME_W Field

public static readonly long PR_TRANSMITABLE_DISPLAY_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_TRANSPORT_KEY Field

public static readonly long PR_TRANSPORT_KEY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_TRANSPORT_MESSAGE_HEADERS Field

public static readonly long PR_TRANSPORT_MESSAGE_HEADERS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_TRANSPORT_MESSAGE_HEADERS_A Field

public static readonly long PR_TRANSPORT_MESSAGE_HEADERS_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_TRANSPORT_MESSAGE_HEADERS_W Field

public static readonly long PR_TRANSPORT_MESSAGE_HEADERS_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_TRANSPORT_PROVIDERS Field

public static readonly long PR_TRANSPORT_PROVIDERS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_TRANSPORT_STATUS Field

public static readonly long PR_TRANSPORT_STATUS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_TTYTDD_PHONE_NUMBER Field

public static readonly long PR_TTYTDD_PHONE_NUMBER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_TTYTDD_PHONE_NUMBER_A Field

public static readonly long PR_TTYTDD_PHONE_NUMBER_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_TTYTDD_PHONE_NUMBER_W Field

public static readonly long PR_TTYTDD_PHONE_NUMBER_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_TYPE_OF_MTS_USER Field

public static readonly long PR_TYPE_OF_MTS_USER;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_USER_CERTIFICATE Field

public static readonly long PR_USER_CERTIFICATE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_USER_ENTRYID Field

public static readonly long PR_USER_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_USER_NAME Field

public static readonly long PR_USER_NAME;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_USER_NAME_A Field

public static readonly long PR_USER_NAME_A;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_USER_NAME_W Field

public static readonly long PR_USER_NAME_W;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_USER_X509_CERTIFICATE Field

public static readonly long PR_USER_X509_CERTIFICATE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_VALID_FOLDER_MASK Field

public static readonly long PR_VALID_FOLDER_MASK;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_VIEWS_ENTRYID Field

public static readonly long PR_VIEWS_ENTRYID;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_WEDDING_ANNIVERSARY Field

public static readonly long PR_WEDDING_ANNIVERSARY;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_X400_CONTENT_TYPE Field

public static readonly long PR_X400_CONTENT_TYPE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_X400_DEFERRED_DELIVERY_CANCEL Field

public static readonly long PR_X400_DEFERRED_DELIVERY_CANCEL;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_X400_ENVELOPE_TYPE Field

public static readonly long PR_X400_ENVELOPE_TYPE;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_XPOS Field

public static readonly long PR_XPOS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.PR_YPOS Field

public static readonly long PR_YPOS;

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag Methods

The methods of the MapiPropertyTag class are listed below. For a complete list of MapiPropertyTag class members, see the MapiPropertyTag Members topic.

Public Static Methods

GetPropertyName Gets the name of the property.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyTag.GetPropertyName Method

Gets the name of the property.

public static string GetPropertyName(
long tag
);

Parameters

tag
The property tag.

Return Value

A String that represents property name.

See Also

MapiPropertyTag Class | Aspose.Email.Outlook Namespace


MapiPropertyType Enumeration

Represents the data type of MapiProperty data.

public enum MapiPropertyType

Members

Member Name | Description | Value
None | No values are set. | 0
PT_SHORT | Signed 16-bit integer. This property type is the same as PT_SHORT and the OLE type VT_I2. | 2
PT_LONG | Signed or unsigned 32-bit integer. This property type is the same as PT_I4 and the OLE type VT_I4. | 3
PT_ERROR | SCODE value; 32-bit unsigned integer. This property type is the same as the OLE type VT_ERROR. | 10
PT_BOOLEAN | 16-bit Boolean value where zero equals FALSE and non-zero equals TRUE. This property type is the same as the OLE type VT_BOOL. | 11
PT_OBJECT | Pointer to an object that implements the IUnknown interface. This property type is similar to several OLE types such as VT_UNKNOWN. | 13
PT_LONGLONG | Signed or unsigned 64-bit integer. This property type is the same as PT_I8 and the OLE type VT_I8. | 20
PT_STRING8 | Null-terminated 8-bit character string. This property type is the same as the OLE type VT_LPSTR. | 30
PT_UNICODE | PT_UNICODE | 31
PT_SYSTIME | 64-bit integer data and time value in the form of a FILETIME structure. This property type is the same as the OLE type VT_FILETIME. | 64
PT_CLSID | CLSID structure value. This property type is the same as the OLE type VT_CLSID. | 72
PT_SRESTRICTION | PT_SRESTRICTION | 253
PT_ACTIONS | PT_ACTIONS | 254
PT_BINARY | SBinary structure value, a counted byte array. | 258
PT_MV_xxx | PT_MV_xxx | 4096
PT_MV_STRING8 |  | 4126
PT_MV_UNICODE |  | 4127
PT_MV_BINARY |  | 4354
PT_DOUBLE |  | 5
PT_MV_LONG |  | 4099

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Outlook Namespace


MapiRecipient Class

Represents the recipient information in the Microsoft Outlook Message.

For a list of all members of this type, see MapiRecipient Members.

System.Object
Aspose.Email.Outlook.MapiPropertyContainer
Aspose.Email.Outlook.MapiRecipient

public class MapiRecipient : MapiPropertyContainer

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiRecipient Members | Aspose.Email.Outlook Namespace


MapiRecipient Members

MapiRecipient overview

Public Instance Properties

AddressType | Gets the type of the address of the message recipient or sender.
CodePage (inherited from MapiPropertyContainer) | Gets the code page.
Content | Gets the content.
DisplayName | Gets or sets the display name of the message recipient or sender.
EmailAddress | Gets or sets the email address of the message recipient or sender.
OrganizationEmailAddress | Gets the organization email address.
Properties (inherited from MapiPropertyContainer) | Gets the collection of properties.
PropertyStream | Gets the property stream.
RecipientClass | Gets the type of recipent.
RecipientType | Gets the type of the recipient or sender.
SubStorages | Gets the sub storages.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPropertyBoolean (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Boolean type.
GetPropertyBytes (inherited from MapiPropertyContainer) | Gets the string value of the property specified by tag.
GetPropertyDateTime (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as DateTime type.
GetPropertyInt32 (inherited from MapiPropertyContainer) | Gets the int32 value of the property specified by tag.
GetPropertyLong (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Long (int64) type.
GetPropertyShort (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Short type.
GetPropertyString (inherited from MapiPropertyContainer) | Overloaded. Gets the string value of the property specified by tag.
GetType (inherited from Object) | Gets the Type of the current instance.
IsStoreUnicodeOk (inherited from MapiPropertyContainer) | Determines if string properties are Unicode encoded or not.
SetProperty | Sets the property.
ToString (inherited from Object) | Returns a String that represents the current Object.
TryGetPropertyData (inherited from MapiPropertyContainer) | Try to get the property data with specified tag key.
TryGetPropertyDateTime (inherited from MapiPropertyContainer) |
TryGetPropertyInt32 (inherited from MapiPropertyContainer) |
TryGetPropertyLong (inherited from MapiPropertyContainer) |
TryGetPropertyString (inherited from MapiPropertyContainer) | Overloaded. Try to get a property data as string with specified tag and code page.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MapiRecipient Class | Aspose.Email.Outlook Namespace


MapiRecipient Properties

The properties of the MapiRecipient class are listed below. For a complete list of MapiRecipient class members, see the MapiRecipient Members topic.

Public Instance Properties

AddressType | Gets the type of the address of the message recipient or sender.
CodePage (inherited from MapiPropertyContainer) | Gets the code page.
Content | Gets the content.
DisplayName | Gets or sets the display name of the message recipient or sender.
EmailAddress | Gets or sets the email address of the message recipient or sender.
OrganizationEmailAddress | Gets the organization email address.
Properties (inherited from MapiPropertyContainer) | Gets the collection of properties.
PropertyStream | Gets the property stream.
RecipientClass | Gets the type of recipent.
RecipientType | Gets the type of the recipient or sender.
SubStorages | Gets the sub storages.

See Also

MapiRecipient Class | Aspose.Email.Outlook Namespace


AddressType Property

Aspose.Email

MapiRecipient.AddressType Property

Gets the type of the address of the message recipient or sender.

public string AddressType {get;}

Property Value

The address type.

Remarks

This property indicates the type for PR_EMAIL_ADDRESS mapi property.

See Also

MapiRecipient Class | Aspose.Email.Outlook Namespace


Content Property

Aspose.Email

MapiRecipient.Content Property

Gets the content.

public object Content {get;}

Property Value

The content.

See Also

MapiRecipient Class | Aspose.Email.Outlook Namespace


DisplayName Property

Aspose.Email

MapiRecipient.DisplayName Property

Gets or sets the display name of the message recipient or sender.

public string DisplayName {get; set;}

Property Value

The display name.

Remarks

When setting a value, the values of either MapiMessage.DisplayTo or MapiMessage.DisplayBcc or MapiMessage.DisplayCC are also updated depending on the type of recepient.

See Also

MapiRecipient Class | Aspose.Email.Outlook Namespace


EmailAddress Property

Aspose.Email

MapiRecipient.EmailAddress Property

Gets or sets the email address of the message recipient or sender.

public string EmailAddress {get; set;}

Property Value

The email address.

Remarks

Note, this property displays an address in SMTP format. It means that if MapiRecipient.AddressType == "EX" and MapiPropertyTag.PR_EMAIL_ADDRESS contain an address in Exchange-style, the value for mapiRecipient.EmailAddress property filling is picked from PR_SMTP_ADDRESS. When setting a value, the values of PR_SEARCH_KEY and PR_ENTRYID properties are updated as well.

Exceptions

Exception Type | Condition
ArgumentNullException | throws if recipient address is null or empty.
ArgumentException | throws if recipient address is not in a recognized format.

See Also

MapiRecipient Class | Aspose.Email.Outlook Namespace


OrganizationEmailAddress Property

Aspose.Email

MapiRecipient.OrganizationEmailAddress Property

Gets the organization email address.

public string OrganizationEmailAddress {get;}

Property Value

The organization email address.

See Also

MapiRecipient Class | Aspose.Email.Outlook Namespace


PropertyStream Property

Aspose.Email

MapiRecipient.PropertyStream Property

Gets the property stream.

public MapiPropertyStream PropertyStream {get;}

Property Value

The property stream.

See Also

MapiRecipient Class | Aspose.Email.Outlook Namespace


RecipientClass Property

Aspose.Email

MapiRecipient.RecipientClass Property

Gets the type of recipent.

public MapiObjectType RecipientClass {get;}

Property Value

The recipient class.

See Also

MapiRecipient Class | Aspose.Email.Outlook Namespace


RecipientType Property

Aspose.Email

MapiRecipient.RecipientType Property

Gets the type of the recipient or sender.

public MapiRecipientType RecipientType {get;}

Property Value

The recipient type.

See Also

MapiRecipient Class | Aspose.Email.Outlook Namespace


SubStorages Property

Aspose.Email

MapiRecipient.SubStorages Property

Gets the sub storages.

public MapiPropertyCollection SubStorages {get;}

Property Value

The sub storages.

See Also

MapiRecipient Class | Aspose.Email.Outlook Namespace


MapiRecipient Methods

The methods of the MapiRecipient class are listed below. For a complete list of MapiRecipient class members, see the MapiRecipient Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPropertyBoolean (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Boolean type.
GetPropertyBytes (inherited from MapiPropertyContainer) | Gets the string value of the property specified by tag.
GetPropertyDateTime (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as DateTime type.
GetPropertyInt32 (inherited from MapiPropertyContainer) | Gets the int32 value of the property specified by tag.
GetPropertyLong (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Long (int64) type.
GetPropertyShort (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Short type.
GetPropertyString (inherited from MapiPropertyContainer) | Overloaded. Gets the string value of the property specified by tag.
GetType (inherited from Object) | Gets the Type of the current instance.
IsStoreUnicodeOk (inherited from MapiPropertyContainer) | Determines if string properties are Unicode encoded or not.
SetProperty | Sets the property.
ToString (inherited from Object) | Returns a String that represents the current Object.
TryGetPropertyData (inherited from MapiPropertyContainer) | Try to get the property data with specified tag key.
TryGetPropertyDateTime (inherited from MapiPropertyContainer) |
TryGetPropertyInt32 (inherited from MapiPropertyContainer) |
TryGetPropertyLong (inherited from MapiPropertyContainer) |
TryGetPropertyString (inherited from MapiPropertyContainer) | Overloaded. Try to get a property data as string with specified tag and code page.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MapiRecipient Class | Aspose.Email.Outlook Namespace


MapiRecipient.SetProperty Method

Sets the property.

public override void SetProperty(
MapiProperty property
);

Parameters

property
The property.

Exceptions

Exception Type | Condition
ArgumentNullException | If property is null.
ArgumentException | If property data is null.
InvalidOperationException | If data type is not supported.

See Also

MapiRecipient Class | Aspose.Email.Outlook Namespace


MapiRecipientCollection Class

Represents a collection of MapiRecipient objects.

For a list of all members of this type, see MapiRecipientCollection Members.

System.Object
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Outlook.MapiRecipient, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]]
Aspose.Email.Outlook.MapiRecipientCollection

public class MapiRecipientCollection : Collection`1

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiRecipientCollection Members | Aspose.Email.Outlook Namespace


MapiRecipientCollection Members

MapiRecipientCollection overview

Public Instance Constructors

MapiRecipientCollection Constructor Initializes a new instance of the MapiRecipientCollection class.

Public Instance Properties

Count (inherited from 0, Culture=neutral, PublicKeyToken=null]])
Item (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Public Instance Methods

Add | Overloaded. Adds the new recipient.
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert | Inserts an element into the Collection`1 at the specified index.
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Items (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Protected Instance Methods

ClearItems (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
InsertItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RemoveItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
SetItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |

See Also

MapiRecipientCollection Class | Aspose.Email.Outlook Namespace


MapiRecipientCollection Constructor

Initializes a new instance of the MapiRecipientCollection class.

public MapiRecipientCollection();

See Also

MapiRecipientCollection Class | Aspose.Email.Outlook Namespace


MapiRecipientCollection Methods

The methods of the MapiRecipientCollection class are listed below. For a complete list of MapiRecipientCollection class members, see the MapiRecipientCollection Members topic.

Public Instance Methods

Add | Overloaded. Adds the new recipient.
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert | Inserts an element into the Collection`1 at the specified index.
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

ClearItems (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
InsertItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RemoveItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
SetItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |

See Also

MapiRecipientCollection Class | Aspose.Email.Outlook Namespace


Add Method

Aspose.Email

MapiRecipientCollection.Add Method

Adds an object to the end of the Collection`1.

Overload List

Adds an object to the end of the Collection`1.

new public void Add(MapiRecipient);

Adds the new recipient.

public void Add(string,string,MapiRecipientType);

Adds the new recipient.

public void Add(string,string,string,MapiRecipientType);

See Also

MapiRecipientCollection Class | Aspose.Email.Outlook Namespace


MapiRecipientCollection.Add Method (MapiRecipient)

Adds an object to the end of the Collection`1.

new public void Add(
MapiRecipient item
);

Parameters

item
The object to be added to the end of the Collection`1. The value can be null for reference types.

Implements

ICollection`1.Add

See Also

MapiRecipientCollection Class | Aspose.Email.Outlook Namespace | MapiRecipientCollection.Add Overload List


MapiRecipientCollection.Add Method (String, String, MapiRecipientType)

Adds the new recipient.

public void Add(
string address,
string displayName,
MapiRecipientType recipientType
);

Parameters

address
The mail address of recipient.
displayName
The display name of recipient.
recipientType
Type of the recipient.

Remarks

When adding a new recepient, the value of either MapiMessage.DisplayTo or MapiMessage.DisplayBcc or MapiMessage.DisplayCC is also updated depending on the type of recepient.

Exceptions

Exception Type | Condition
ArgumentNullException | throws if recipient address is null or empty.
ArgumentException | throws if recipient address is not in a recognized format.

See Also

MapiRecipientCollection Class | Aspose.Email.Outlook Namespace | MapiRecipientCollection.Add Overload List


MapiRecipientCollection.Add Method (String, String, String, MapiRecipientType)

Adds the new recipient.

public void Add(
string address,
string addressType,
string displayName,
MapiRecipientType recipientType
);

Parameters

address
The mail address of recipient.
addressType
The type of address.
displayName
The display name of recipient.
recipientType
Type of the recipient.

Remarks

When adding a new recepient, the value of either MapiMessage.DisplayTo or MapiMessage.DisplayBcc or MapiMessage.DisplayCC is also updated depending on the type of recepient.

Exceptions

Exception Type | Condition
ArgumentNullException | throws if recipient address is null or empty.
ArgumentException | throws if recipient address is not in a recognized format.

See Also

MapiRecipientCollection Class | Aspose.Email.Outlook Namespace | MapiRecipientCollection.Add Overload List


MapiRecipientCollection.Insert Method

Inserts an element into the Collection`1 at the specified index.

new public void Insert(
int index,
MapiRecipient item
);

Parameters

index
The zero-based index at which item should be inserted.
item
The object to insert. The value can be null for reference types.

Implements

IList`1.Insert

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is greater than Count.

See Also

MapiRecipientCollection Class | Aspose.Email.Outlook Namespace


MapiRecipientPropertyStream Class

Represents the property stream of recipient object.

For a list of all members of this type, see MapiRecipientPropertyStream Members.

System.Object
Aspose.Email.Outlook.MapiPropertyContainer
Aspose.Email.Outlook.MapiPropertyStream
Aspose.Email.Outlook.MapiRecipientPropertyStream

public class MapiRecipientPropertyStream : MapiPropertyStream

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiRecipientPropertyStream Members | Aspose.Email.Outlook Namespace


MapiRecipientPropertyStream Members

MapiRecipientPropertyStream overview

Public Instance Constructors

MapiRecipientPropertyStream Constructor Initializes a new instance of the MapiRecipientPropertyStream class.

Public Instance Properties

CodePage (inherited from MapiPropertyContainer) | Gets the code page.
Content (inherited from MapiPropertyStream) | Gets the content.
Name (inherited from MapiPropertyStream) | Gets the name.
Properties (inherited from MapiPropertyContainer) | Gets the collection of properties.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPropertyBoolean (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Boolean type.
GetPropertyBytes (inherited from MapiPropertyContainer) | Gets the string value of the property specified by tag.
GetPropertyDateTime (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as DateTime type.
GetPropertyInt32 (inherited from MapiPropertyContainer) | Gets the int32 value of the property specified by tag.
GetPropertyLong (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Long (int64) type.
GetPropertyShort (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Short type.
GetPropertyString (inherited from MapiPropertyContainer) | Overloaded. Gets the string value of the property specified by tag.
GetType (inherited from Object) | Gets the Type of the current instance.
IsStoreUnicodeOk (inherited from MapiPropertyContainer) | Determines if string properties are Unicode encoded or not.
SetProperty | Sets the property.
ToString (inherited from Object) | Returns a String that represents the current Object.
TryGetPropertyData (inherited from MapiPropertyContainer) | Try to get the property data with specified tag key.
TryGetPropertyDateTime (inherited from MapiPropertyContainer) |
TryGetPropertyInt32 (inherited from MapiPropertyContainer) |
TryGetPropertyLong (inherited from MapiPropertyContainer) |
TryGetPropertyString (inherited from MapiPropertyContainer) | Overloaded. Try to get a property data as string with specified tag and code page.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetContent |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MapiRecipientPropertyStream Class | Aspose.Email.Outlook Namespace


MapiRecipientPropertyStream Constructor

Initializes a new instance of the MapiRecipientPropertyStream class.

public MapiRecipientPropertyStream();

See Also

MapiRecipientPropertyStream Class | Aspose.Email.Outlook Namespace


MapiRecipientPropertyStream Methods

The methods of the MapiRecipientPropertyStream class are listed below. For a complete list of MapiRecipientPropertyStream class members, see the MapiRecipientPropertyStream Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPropertyBoolean (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Boolean type.
GetPropertyBytes (inherited from MapiPropertyContainer) | Gets the string value of the property specified by tag.
GetPropertyDateTime (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as DateTime type.
GetPropertyInt32 (inherited from MapiPropertyContainer) | Gets the int32 value of the property specified by tag.
GetPropertyLong (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Long (int64) type.
GetPropertyShort (inherited from MapiPropertyContainer) | Gets the value of the property specified by tag as Short type.
GetPropertyString (inherited from MapiPropertyContainer) | Overloaded. Gets the string value of the property specified by tag.
GetType (inherited from Object) | Gets the Type of the current instance.
IsStoreUnicodeOk (inherited from MapiPropertyContainer) | Determines if string properties are Unicode encoded or not.
SetProperty | Sets the property.
ToString (inherited from Object) | Returns a String that represents the current Object.
TryGetPropertyData (inherited from MapiPropertyContainer) | Try to get the property data with specified tag key.
TryGetPropertyDateTime (inherited from MapiPropertyContainer) |
TryGetPropertyInt32 (inherited from MapiPropertyContainer) |
TryGetPropertyLong (inherited from MapiPropertyContainer) |
TryGetPropertyString (inherited from MapiPropertyContainer) | Overloaded. Try to get a property data as string with specified tag and code page.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
GetContent |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MapiRecipientPropertyStream Class | Aspose.Email.Outlook Namespace


MapiRecipientPropertyStream.GetContent Method

protected override MemoryStream GetContent();

See Also

MapiRecipientPropertyStream Class | Aspose.Email.Outlook Namespace


MapiRecipientPropertyStream.SetProperty Method

Sets the property.

public override void SetProperty(
MapiProperty property
);

Parameters

property
The property.

Exceptions

Exception Type | Condition
NotImplementedException |

See Also

MapiRecipientPropertyStream Class | Aspose.Email.Outlook Namespace


MapiRecipientType Enumeration

Represent the PR_RECIPIENT_TYPE property which contains the recipient type for a message recipient.

public enum MapiRecipientType

Members

Member Name | Description | Value
MAPI_BCC | The recipient is a blind carbon copy (BCC) recipient. Primary and carbon copy recipients are unaware of the existence of BCC recipients. | 3
MAPI_CC | The recipient is a carbon copy (CC) recipient, a recipient that receives a message in addition to the primary recipients. | 2
MAPI_ORIG | The recipient sent the message. | 0
MAPI_P1 | The recipient did not successfully receive the message on the previous attempt. This is a resend of an earlier transmission. | 268435456
MAPI_SUBMITTED | The recipient has already received the message and does not need to receive it again. This is a resend of an earlier transmission. This flag is set in conjunction with the MAPI_TO, MAPI_CC, and MAPI_BCC values. | -2147483648
MAPI_TO | The recipient is a primary (To) recipient. Clients are required to handle primary recipients; all other types are optional. | 1
Unknown | Unknow. | -1

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Outlook Namespace


MapiTask Class

Represents the Outlook Task object.

For a list of all members of this type, see MapiTask Members.

System.Object
Aspose.Email.Outlook.MapiTask

public sealed class MapiTask : IMapiMessageItem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiTask Members | Aspose.Email.Outlook Namespace


MapiTask Members

MapiTask overview

Public Static Methods

FromVTodo Overloaded. Creates an instance of MapiTask from the specified .ics file.

Public Instance Constructors

MapiTask Overloaded. Initializes a new instance of the MapiTask class.

Public Instance Properties

AcceptanceState | Gets or sets the acceptance state of the task.
ActualEffort | Gets or sets the number of minutes that the user actually spent working on a task.
Attachments | Gets the attachments collection.
Body | Gets or sets message body.
DateCompleted | Gets or sets the date when the user completed work on the task.
DueDate | Gets or sets the date by which the user expects work on the task to be complete.
EstimatedEffort | Gets or sets the number of minutes that the user expects to work on a task.
Flags | Gets the indication flags of the Task object.
History | Gets or sets the type of change that was last made to the Task object.
LastUpdate | Gets or sets the date and time of the most recent change made to the Task object.
MessageClass | Gets message class.
Mode | Gets or sets the assignment status of the Task object.
PercentComplete | Gets or sets the progress the user has made on a task.
Recurrence | Gets or sets the recurrence properties.
ReminderFileParameter | Specifies the full path of the sound that a client SHOULD play when the reminder becomes overdue.
ReminderSet | Gets or sets a value indicating whether a reminder is set on the object
ReminderTime | Gets or sets the initial signal time for a reminder
StartDate | Gets or sets the date on which the user expects work on the task to begin.
State | Gets or sets the current assignment state of the Task object.
Status | Gets or sets the status of the user's progress on the task.
Subject | Gets or sets message subject.
Users | Gets or sets information about task users.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Overloaded. Saves this MapiTask to the given stream using specified format.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MapiTask Class | Aspose.Email.Outlook Namespace


MapiTask Constructor

Initializes a new instance of the MapiTask class.

Overload List

Initializes a new instance of the MapiTask class.

public MapiTask();

Initializes a new instance of the MapiTask class.

public MapiTask(string,string,DateTime,DateTime);

See Also

MapiTask Class | Aspose.Email.Outlook Namespace


MapiTask Constructor ()

Initializes a new instance of the MapiTask class.

public MapiTask();

See Also

MapiTask Class | Aspose.Email.Outlook Namespace | MapiTask Constructor Overload List


MapiTask Constructor (String, String, DateTime, DateTime)

Initializes a new instance of the MapiTask class.

public MapiTask(
string subject,
string body,
DateTime startDate,
DateTime dueDate
);

Parameters

subject
The subject.
body
The message body.
startDate
The start date.
dueDate
The due date.

See Also

MapiTask Class | Aspose.Email.Outlook Namespace | MapiTask Constructor Overload List


MapiTask Properties

The properties of the MapiTask class are listed below. For a complete list of MapiTask class members, see the MapiTask Members topic.

Public Instance Properties

AcceptanceState | Gets or sets the acceptance state of the task.
ActualEffort | Gets or sets the number of minutes that the user actually spent working on a task.
Attachments | Gets the attachments collection.
Body | Gets or sets message body.
DateCompleted | Gets or sets the date when the user completed work on the task.
DueDate | Gets or sets the date by which the user expects work on the task to be complete.
EstimatedEffort | Gets or sets the number of minutes that the user expects to work on a task.
Flags | Gets the indication flags of the Task object.
History | Gets or sets the type of change that was last made to the Task object.
LastUpdate | Gets or sets the date and time of the most recent change made to the Task object.
MessageClass | Gets message class.
Mode | Gets or sets the assignment status of the Task object.
PercentComplete | Gets or sets the progress the user has made on a task.
Recurrence | Gets or sets the recurrence properties.
ReminderFileParameter | Specifies the full path of the sound that a client SHOULD play when the reminder becomes overdue.
ReminderSet | Gets or sets a value indicating whether a reminder is set on the object
ReminderTime | Gets or sets the initial signal time for a reminder
StartDate | Gets or sets the date on which the user expects work on the task to begin.
State | Gets or sets the current assignment state of the Task object.
Status | Gets or sets the status of the user's progress on the task.
Subject | Gets or sets message subject.
Users | Gets or sets information about task users.

See Also

MapiTask Class | Aspose.Email.Outlook Namespace


AcceptanceState Property

Aspose.Email

MapiTask.AcceptanceState Property

Gets or sets the acceptance state of the task.

public MapiTaskAcceptanceState AcceptanceState {get; set;}

See Also

MapiTask Class | Aspose.Email.Outlook Namespace


ActualEffort Property

Aspose.Email

MapiTask.ActualEffort Property

Gets or sets the number of minutes that the user actually spent working on a task.

public int ActualEffort {get; set;}

See Also

MapiTask Class | Aspose.Email.Outlook Namespace


Attachments Property

Aspose.Email

MapiTask.Attachments Property

Gets the attachments collection.

public MapiAttachmentCollection Attachments {get;}

See Also

MapiTask Class | Aspose.Email.Outlook Namespace


Body Property

Aspose.Email

MapiTask.Body Property

Gets or sets message body.

public string Body {get; set;}

Property Value

The message body.

Implements

IMapiMessageItem.Body

See Also

MapiTask Class | Aspose.Email.Outlook Namespace


DateCompleted Property

Aspose.Email

MapiTask.DateCompleted Property

Gets or sets the date when the user completed work on the task.

public DateTime DateCompleted {get; set;}

Exceptions

Exception Type | Condition
ArgumentException | trows when start date is less than date completed.

See Also

MapiTask Class | Aspose.Email.Outlook Namespace


DueDate Property

Aspose.Email

MapiTask.DueDate Property

Gets or sets the date by which the user expects work on the task to be complete.

public DateTime DueDate {get; set;}

See Also

MapiTask Class | Aspose.Email.Outlook Namespace


EstimatedEffort Property

Aspose.Email

MapiTask.EstimatedEffort Property

Gets or sets the number of minutes that the user expects to work on a task.

public int EstimatedEffort {get; set;}

See Also

MapiTask Class | Aspose.Email.Outlook Namespace


Flags Property

Aspose.Email

MapiTask.Flags Property

Gets the indication flags of the Task object.

public MapiTaskFlags Flags {get;}

See Also

MapiTask Class | Aspose.Email.Outlook Namespace


History Property

Aspose.Email

MapiTask.History Property

Gets or sets the type of change that was last made to the Task object.

public MapiTaskHistory History {get; set;}

See Also

MapiTask Class | Aspose.Email.Outlook Namespace


LastUpdate Property

Aspose.Email

MapiTask.LastUpdate Property

Gets or sets the date and time of the most recent change made to the Task object.

public DateTime LastUpdate {get; set;}

See Also

MapiTask Class | Aspose.Email.Outlook Namespace


MessageClass Property

Aspose.Email

MapiTask.MessageClass Property

Gets message class.

public string MessageClass {get;}

Property Value

String that represents message class.

Implements

IMapiMessageItem.MessageClass

See Also

MapiTask Class | Aspose.Email.Outlook Namespace


Mode Property

Aspose.Email

MapiTask.Mode Property

Gets or sets the assignment status of the Task object.

public MapiTaskMode Mode {get; set;}

See Also

MapiTask Class | Aspose.Email.Outlook Namespace


PercentComplete Property

Aspose.Email

MapiTask.PercentComplete Property

Gets or sets the progress the user has made on a task.

public int PercentComplete {get; set;}

See Also

MapiTask Class | Aspose.Email.Outlook Namespace


Recurrence Property

Aspose.Email

MapiTask.Recurrence Property

Gets or sets the recurrence properties.

public MapiCalendarRecurrencePattern Recurrence {get; set;}

See Also

MapiTask Class | Aspose.Email.Outlook Namespace


ReminderFileParameter Property

Aspose.Email

MapiTask.ReminderFileParameter Property

Specifies the full path of the sound that a client SHOULD play when the reminder becomes overdue.

public string ReminderFileParameter {get; set;}

See Also

MapiTask Class | Aspose.Email.Outlook Namespace


ReminderSet Property

Aspose.Email

MapiTask.ReminderSet Property

Gets or sets a value indicating whether a reminder is set on the object

public bool ReminderSet {get; set;}

See Also

MapiTask Class | Aspose.Email.Outlook Namespace


ReminderTime Property

Aspose.Email

MapiTask.ReminderTime Property

Gets or sets the initial signal time for a reminder

public DateTime ReminderTime {get; set;}

See Also

MapiTask Class | Aspose.Email.Outlook Namespace


StartDate Property

Aspose.Email

MapiTask.StartDate Property

Gets or sets the date on which the user expects work on the task to begin.

public DateTime StartDate {get; set;}

Exceptions

Exception Type | Condition
ArgumentException | trows when start date is greater than date completed.

See Also

MapiTask Class | Aspose.Email.Outlook Namespace


State Property

Aspose.Email

MapiTask.State Property

Gets or sets the current assignment state of the Task object.

public MapiTaskState State {get; set;}

See Also

MapiTask Class | Aspose.Email.Outlook Namespace


Status Property

Aspose.Email

MapiTask.Status Property

Gets or sets the status of the user's progress on the task.

public MapiTaskStatus Status {get; set;}

See Also

MapiTask Class | Aspose.Email.Outlook Namespace


Subject Property

Aspose.Email

MapiTask.Subject Property

Gets or sets message subject.

public string Subject {get; set;}

Property Value

The message subject.

Implements

IMapiMessageItem.Subject

See Also

MapiTask Class | Aspose.Email.Outlook Namespace


Users Property

Aspose.Email

MapiTask.Users Property

Gets or sets information about task users.

public MapiTaskUsers Users {get; set;}

See Also

MapiTask Class | Aspose.Email.Outlook Namespace


MapiTask Methods

The methods of the MapiTask class are listed below. For a complete list of MapiTask class members, see the MapiTask Members topic.

Public Static Methods

FromVTodo Overloaded. Creates an instance of MapiTask from the specified .ics file.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Overloaded. Saves this MapiTask to the given stream using specified format.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MapiTask Class | Aspose.Email.Outlook Namespace


FromVTodo Method

Aspose.Email

MapiTask.FromVTodo Method

Creates an instance of MapiTask from the specified stream.

Overload List

Creates an instance of MapiTask from the specified stream.

public static MapiTask FromVTodo(Stream);

Creates an instance of MapiTask from the specified .ics file.

public static MapiTask FromVTodo(string);

See Also

MapiTask Class | Aspose.Email.Outlook Namespace


MapiTask.FromVTodo Method (Stream)

Creates an instance of MapiTask from the specified stream.

public static MapiTask FromVTodo(
Stream stream
);

Parameters

stream
The stream to be loaded.

Return Value

Returns a MapiTask instance which is loaded from the specified stream.

See Also

MapiTask Class | Aspose.Email.Outlook Namespace | MapiTask.FromVTodo Overload List


MapiTask.FromVTodo Method (String)

Creates an instance of MapiTask from the specified .ics file.

public static MapiTask FromVTodo(
string filePath
);

Parameters

filePath
The path to the file to be loaded.

Return Value

Returns a MapiTask instance which is loaded from the specified file.

See Also

MapiTask Class | Aspose.Email.Outlook Namespace | MapiTask.FromVTodo Overload List


Save Method

Aspose.Email

MapiTask.Save Method

Saves this MapiTask to the given stream using specified format.

Overload List

Saves this MapiTask to the given stream using specified format.

public void Save(Stream,TaskSaveFormat);

Saves this MapiTask into file using specified format.

public void Save(string,TaskSaveFormat);

See Also

MapiTask Class | Aspose.Email.Outlook Namespace


MapiTask.Save Method (Stream, TaskSaveFormat)

Saves this MapiTask to the given stream using specified format.

public void Save(
Stream stream,
TaskSaveFormat saveFormat
);

Parameters

stream
A stream to save to.
saveFormat
A save format.

Exceptions

Exception Type | Condition
ArgumentNullException | stream is null.
NotSupportedException | stream does not support writing.
NotSupportedException | The specified format is not supported.

See Also

MapiTask Class | Aspose.Email.Outlook Namespace | MapiTask.Save Overload List


MapiTask.Save Method (String, TaskSaveFormat)

Saves this MapiTask into file using specified format.

public void Save(
string filePath,
TaskSaveFormat saveFormat
);

Parameters

filePath
A file name.
saveFormat
A save format.

Exceptions

Exception Type | Condition
ArgumentException | filePath is null or empty.
NotSupportedException | some save option is not supported

See Also

MapiTask Class | Aspose.Email.Outlook Namespace | MapiTask.Save Overload List


MapiTaskAcceptanceState Enumeration

Indicates the acceptance state of the task.

public enum MapiTaskAcceptanceState

Members

Member Name | Description | Value
NotAssigned | The Task object is not assigned. | 0
Unknown | The Task object's acceptance status is unknown. | 1
Accepted | The task assignee has accepted the Task object. | 2
Rejected | The task assignee has rejected the Task object. | 3

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Outlook Namespace


MapiTaskFlags Enumeration

Contains indication flags of the Task object.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum MapiTaskFlags

Members

Member Name | Description | Value
Complete | Indicates whether the task has been completed. | 1
Accepted | Indicates whether a task assignee has replied to a task request for this Task object. | 2
Updates | Indicates whether the task assignee has been requested to send a task update when the assigned Task object changes. | 4
Recurring | Indicates whether the task includes a recurrence pattern. | 8
StatusOnComplete | Indicates whether the task assignee has been requested to send an e-mail message update when the task assignee completes the assigned task. | 16
DeadOccurrence | Indicates whether new occurrences remain to be generated. | 32
ResetReminder | Indicates whether future instances of recurring tasks need reminders. | 64

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Outlook Namespace


MapiTaskHistory Enumeration

Indicates the type of change that was last made to the Task object.

public enum MapiTaskHistory

Members

Member Name | Description | Value
DueDateChanged | The PidLidTaskDueDate property changed. | 4
AnotherPropertyChanged | Another property was changed. | 3
Accepted | The task assignee accepted this Task object. | 1
Rejected | The task assignee rejected this Task object. | 2
Assigned | The Task object has been assigned to a task assignee. | 5
NoChanges | No changes were made. | 0

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Outlook Namespace


MapiTaskMode Enumeration

Represents the assignment statuses of the task object.

public enum MapiTaskMode

Members

Member Name | Description | Value
NotAssigned | The Task object is not assigned. | 0
RequestEmbedded | The Task object is embedded in a task request. | 1
Accepted | The Task object has been accepted by the task assignee. | 2
Rejected | The Task object was rejected by the task assignee. | 3
UpdateEmbedded | The Task object is embedded in a task update. | 4
Assigned | The Task object was assigned to the task assigner (self-delegation). | 5

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Outlook Namespace


MapiTaskOwnership Enumeration

Indicates the role of the current user relative to the Task object.

public enum MapiTaskOwnership

Members

Member Name | Description | Value
NotAssigned | The Task object is not assigned. | 0
AssignersCopy | The Task object is the task assigner's copy of the Task object. | 1
AssigneesCopy | The Task object is the task assignee's copy of the Task object. | 2

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Outlook Namespace


MapiTaskState Enumeration

Indicates the assignment state of the Task object.

public enum MapiTaskState

Members

Member Name | Description | Value
NotAssigned | The Task object is not assigned. | 1
AssigneesCopyOfAssignedTask | The Task object is the task assignee's copy of an assigned Task object. | 2
AssignersCopyOfAssignedTask | The Task object is the task assigner's copy of an assigned Task object. | 3
AssignersCopyOfRejectedTask | The Task object is the task assigner's copy of a rejected Task object. | 4
EmbeddedInTaskRejection | This Task object was created to correspond to a Task object that was embedded in a task rejection but could not be found locally. | 0

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Outlook Namespace


MapiTaskStatus Enumeration

Represents the statuses of the user's progress on the task.

public enum MapiTaskStatus

Members

Member Name | Description | Value
NotStarted | The user has not started work on the Task object. | 0
InProgress | The user's work on this Task object is in progress. | 1
Complete | The user's work on this Task object is complete. | 2
Waiting | The user is waiting on somebody else. | 3
Deferred | The user has deferred work on the Task object. | 4

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Outlook Namespace


MapiTaskUsers Class

Represents information about task users.

For a list of all members of this type, see MapiTaskUsers Members.

System.Object
Aspose.Email.Outlook.MapiTaskUsers

public sealed class MapiTaskUsers

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MapiTaskUsers Members | Aspose.Email.Outlook Namespace


MapiTaskUsers Members

MapiTaskUsers overview

Public Instance Constructors

MapiTaskUsers Constructor Initializes a new instance of the MapiTaskUsers class.

Public Instance Properties

Assigner | Specifies the group of properties that defines the display name and e-mail address of user who created task.
Attendees | Gets the attendees.
Delegator | Gets or sets task delegator.
LastAssigner | Gets or sets the name of the user that last assigned the task.
LastDelegate | Gets or sets the name of the mailbox's delegate who most recently assigned the task, or an empty string if there is no delegate.
LastUser | Gets or sets the name of the most recent user to have been the task owner.
Owner | Gets or sets the name of the task owner.
Ownership | Gets or sets the role of the current user relative to the Task object.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MapiTaskUsers Class | Aspose.Email.Outlook Namespace


MapiTaskUsers Constructor

Initializes a new instance of the MapiTaskUsers class.

public MapiTaskUsers();

See Also

MapiTaskUsers Class | Aspose.Email.Outlook Namespace


MapiTaskUsers Properties

The properties of the MapiTaskUsers class are listed below. For a complete list of MapiTaskUsers class members, see the MapiTaskUsers Members topic.

Public Instance Properties

Assigner | Specifies the group of properties that defines the display name and e-mail address of user who created task.
Attendees | Gets the attendees.
Delegator | Gets or sets task delegator.
LastAssigner | Gets or sets the name of the user that last assigned the task.
LastDelegate | Gets or sets the name of the mailbox's delegate who most recently assigned the task, or an empty string if there is no delegate.
LastUser | Gets or sets the name of the most recent user to have been the task owner.
Owner | Gets or sets the name of the task owner.
Ownership | Gets or sets the role of the current user relative to the Task object.

See Also

MapiTaskUsers Class | Aspose.Email.Outlook Namespace


Assigner Property

Aspose.Email

MapiTaskUsers.Assigner Property

Specifies the group of properties that defines the display name and e-mail address of user who created task.

public MapiElectronicAddress Assigner {get; set;}

See Also

MapiTaskUsers Class | Aspose.Email.Outlook Namespace


Attendees Property

Aspose.Email

MapiTaskUsers.Attendees Property

Gets the attendees.

public MapiRecipientCollection Attendees {get;}

See Also

MapiTaskUsers Class | Aspose.Email.Outlook Namespace


Delegator Property

Aspose.Email

MapiTaskUsers.Delegator Property

Gets or sets task delegator.

public string Delegator {get; set;}

See Also

MapiTaskUsers Class | Aspose.Email.Outlook Namespace


LastAssigner Property

Aspose.Email

MapiTaskUsers.LastAssigner Property

Gets or sets the name of the user that last assigned the task.

public string LastAssigner {get; set;}

See Also

MapiTaskUsers Class | Aspose.Email.Outlook Namespace


LastDelegate Property

Aspose.Email

MapiTaskUsers.LastDelegate Property

Gets or sets the name of the mailbox's delegate who most recently assigned the task, or an empty string if there is no delegate.

public string LastDelegate {get; set;}

See Also

MapiTaskUsers Class | Aspose.Email.Outlook Namespace


LastUser Property

Aspose.Email

MapiTaskUsers.LastUser Property

Gets or sets the name of the most recent user to have been the task owner.

public string LastUser {get; set;}

See Also

MapiTaskUsers Class | Aspose.Email.Outlook Namespace


Owner Property

Aspose.Email

MapiTaskUsers.Owner Property

Gets or sets the name of the task owner.

public string Owner {get; set;}

See Also

MapiTaskUsers Class | Aspose.Email.Outlook Namespace


Ownership Property

Aspose.Email

MapiTaskUsers.Ownership Property

Gets or sets the role of the current user relative to the Task object.

public MapiTaskOwnership Ownership {get; set;}

See Also

MapiTaskUsers Class | Aspose.Email.Outlook Namespace


NDRReportMailMessageInterpretor Class

Represents a Non-Delivery Report MailMesssage interpretor.

For a list of all members of this type, see NDRReportMailMessageInterpretor Members.

System.Object
Aspose.Email.Outlook.MailMessageInterpretor
Aspose.Email.Outlook.NDRReportMailMessageInterpretor

public class NDRReportMailMessageInterpretor : MailMessageInterpretor

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

NDRReportMailMessageInterpretor Members | Aspose.Email.Outlook Namespace


NDRReportMailMessageInterpretor Members

NDRReportMailMessageInterpretor overview

Public Instance Constructors

NDRReportMailMessageInterpretor Constructor Initializes a new instance of the NDRReportMailMessageInterpretor class.

Public Instance Methods

Clone | Creates a copy of the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Interpret (inherited from MailMessageInterpretor) | Imports the MapiMessage information into a MailMessage object.
Save (inherited from MailMessageInterpretor) | Saves the specified MapiMessage to a Stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
LoadAttachment (inherited from MailMessageInterpretor) |
LoadEachAttachment (inherited from MailMessageInterpretor) |
LoadMessageBody |
LoadMessageBodyHtml (inherited from MailMessageInterpretor) |
LoadMessageBodyText (inherited from MailMessageInterpretor) |
LoadMessageHeader |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NDRReportMailMessageInterpretor Class | Aspose.Email.Outlook Namespace


NDRReportMailMessageInterpretor Constructor

Initializes a new instance of the NDRReportMailMessageInterpretor class.

public NDRReportMailMessageInterpretor();

See Also

NDRReportMailMessageInterpretor Class | Aspose.Email.Outlook Namespace


NDRReportMailMessageInterpretor Methods

The methods of the NDRReportMailMessageInterpretor class are listed below. For a complete list of NDRReportMailMessageInterpretor class members, see the NDRReportMailMessageInterpretor Members topic.

Public Instance Methods

Clone | Creates a copy of the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Interpret (inherited from MailMessageInterpretor) | Imports the MapiMessage information into a MailMessage object.
Save (inherited from MailMessageInterpretor) | Saves the specified MapiMessage to a Stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
LoadAttachment (inherited from MailMessageInterpretor) |
LoadEachAttachment (inherited from MailMessageInterpretor) |
LoadMessageBody |
LoadMessageBodyHtml (inherited from MailMessageInterpretor) |
LoadMessageBodyText (inherited from MailMessageInterpretor) |
LoadMessageHeader |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NDRReportMailMessageInterpretor Class | Aspose.Email.Outlook Namespace


NDRReportMailMessageInterpretor.Clone Method

Creates a copy of the current instance.

public override MailMessageInterpretor Clone();

Return Value

A copy of NDRReportMailMessageInterpretor.

See Also

NDRReportMailMessageInterpretor Class | Aspose.Email.Outlook Namespace


NDRReportMailMessageInterpretor.LoadMessageBody Method

protected override void LoadMessageBody(
MailMessage mailmessage,
MapiMessage mapiMessage
);

See Also

NDRReportMailMessageInterpretor Class | Aspose.Email.Outlook Namespace


NDRReportMailMessageInterpretor.LoadMessageHeader Method

protected override void LoadMessageHeader(
MailMessage mailmessage,
MapiMessage mapiMessage
);

See Also

NDRReportMailMessageInterpretor Class | Aspose.Email.Outlook Namespace


NormalMessageMailMessageInterpretor Class

Represents the default mail message interpretor.

For a list of all members of this type, see NormalMessageMailMessageInterpretor Members.

System.Object
Aspose.Email.Outlook.MailMessageInterpretor
Aspose.Email.Outlook.NormalMessageMailMessageInterpretor

public class NormalMessageMailMessageInterpretor : MailMessageInterpretor

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

NormalMessageMailMessageInterpretor Members | Aspose.Email.Outlook Namespace


NormalMessageMailMessageInterpretor Members

NormalMessageMailMessageInterpretor overview

Public Instance Constructors

NormalMessageMailMessageInterpretor Constructor Initializes a new instance of the NormalMessageMailMessageInterpretor class.

Public Instance Methods

Clone | Creates a copy of the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Interpret (inherited from MailMessageInterpretor) | Imports the MapiMessage information into a MailMessage object.
Save (inherited from MailMessageInterpretor) | Saves the specified MapiMessage to a Stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
LoadAttachment (inherited from MailMessageInterpretor) |
LoadEachAttachment (inherited from MailMessageInterpretor) |
LoadMessageBody (inherited from MailMessageInterpretor) |
LoadMessageBodyHtml (inherited from MailMessageInterpretor) |
LoadMessageBodyText (inherited from MailMessageInterpretor) |
LoadMessageHeader (inherited from MailMessageInterpretor) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NormalMessageMailMessageInterpretor Class | Aspose.Email.Outlook Namespace


NormalMessageMailMessageInterpretor Constructor

Initializes a new instance of the NormalMessageMailMessageInterpretor class.

public NormalMessageMailMessageInterpretor();

See Also

NormalMessageMailMessageInterpretor Class | Aspose.Email.Outlook Namespace


NormalMessageMailMessageInterpretor Methods

The methods of the NormalMessageMailMessageInterpretor class are listed below. For a complete list of NormalMessageMailMessageInterpretor class members, see the NormalMessageMailMessageInterpretor Members topic.

Public Instance Methods

Clone | Creates a copy of the current instance.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Interpret (inherited from MailMessageInterpretor) | Imports the MapiMessage information into a MailMessage object.
Save (inherited from MailMessageInterpretor) | Saves the specified MapiMessage to a Stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
LoadAttachment (inherited from MailMessageInterpretor) |
LoadEachAttachment (inherited from MailMessageInterpretor) |
LoadMessageBody (inherited from MailMessageInterpretor) |
LoadMessageBodyHtml (inherited from MailMessageInterpretor) |
LoadMessageBodyText (inherited from MailMessageInterpretor) |
LoadMessageHeader (inherited from MailMessageInterpretor) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

NormalMessageMailMessageInterpretor Class | Aspose.Email.Outlook Namespace


NormalMessageMailMessageInterpretor.Clone Method

Creates a copy of the current instance.

public override MailMessageInterpretor Clone();

Return Value

A copy of MailMessageInterpretor.

See Also

NormalMessageMailMessageInterpretor Class | Aspose.Email.Outlook Namespace


NoteColor Enumeration

Specifies the suggested background color of the Note object

public enum NoteColor

Members

Member Name | Description | Value
Blue | Blue color. | 0
Green | Green color. | 1
Pink | Pink color. | 2
Yellow | Yellow color. | 3
White | White color. | 4

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Outlook Namespace


NoteSaveFormat Enumeration

Enumerates NoteSaveFormat

public enum NoteSaveFormat

Members

Member Name | Description | Value
Msg | MSG format. | 0

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Outlook Namespace


OleDocumentFormat Class

Represents the format for OLE document.

For a list of all members of this type, see OleDocumentFormat Members.

System.Object
Aspose.Email.Outlook.OleDocumentFormat

public sealed class OleDocumentFormat

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

OleDocumentFormat Members | Aspose.Email.Outlook Namespace


OleDocumentFormat Members

OleDocumentFormat overview

Public Static Properties

AdobeAcrobatDocument | Adobe PDF format.
MicrosoftOfficeExcelWorksheet | Microsoft office exccel format.
MicrosoftOfficeWordDocument | Microsoft office word format.
MicrosoftOutlookMessage | Microsoft outlook message format.
MicrosoftPowerPointPresentation | Microsoft power point format.
Unknown | Unknown type.

Public Instance Constructors

OleDocumentFormat Constructor Initializes a new instance of the OleDocumentFormat class.

Public Instance Methods

Equals | Returns a value indicating whether this instance is equal to a specified object.
GetHashCode | Returns the hash code of this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Overridden. Returns a string representation of this instance.

See Also

OleDocumentFormat Class | Aspose.Email.Outlook Namespace


OleDocumentFormat Constructor

Initializes a new instance of the OleDocumentFormat class.

public OleDocumentFormat(
Guid guid
);

Parameters

guid
The guid of the ole document.

See Also

OleDocumentFormat Class | Aspose.Email.Outlook Namespace


OleDocumentFormat Properties

The properties of the OleDocumentFormat class are listed below. For a complete list of OleDocumentFormat class members, see the OleDocumentFormat Members topic.

Public Static Properties

AdobeAcrobatDocument | Adobe PDF format.
MicrosoftOfficeExcelWorksheet | Microsoft office exccel format.
MicrosoftOfficeWordDocument | Microsoft office word format.
MicrosoftOutlookMessage | Microsoft outlook message format.
MicrosoftPowerPointPresentation | Microsoft power point format.
Unknown | Unknown type.

See Also

OleDocumentFormat Class | Aspose.Email.Outlook Namespace


AdobeAcrobatDocument Property

Aspose.Email

OleDocumentFormat.AdobeAcrobatDocument Property

Adobe PDF format.

public static OleDocumentFormat AdobeAcrobatDocument {get;}

See Also

OleDocumentFormat Class | Aspose.Email.Outlook Namespace


MicrosoftOfficeExcelWorksheet Property

Aspose.Email

OleDocumentFormat.MicrosoftOfficeExcelWorksheet Property

Microsoft office exccel format.

public static OleDocumentFormat MicrosoftOfficeExcelWorksheet {get;}

See Also

OleDocumentFormat Class | Aspose.Email.Outlook Namespace


MicrosoftOfficeWordDocument Property

Aspose.Email

OleDocumentFormat.MicrosoftOfficeWordDocument Property

Microsoft office word format.

public static OleDocumentFormat MicrosoftOfficeWordDocument {get;}

See Also

OleDocumentFormat Class | Aspose.Email.Outlook Namespace


MicrosoftOutlookMessage Property

Aspose.Email

OleDocumentFormat.MicrosoftOutlookMessage Property

Microsoft outlook message format.

public static OleDocumentFormat MicrosoftOutlookMessage {get;}

See Also

OleDocumentFormat Class | Aspose.Email.Outlook Namespace


MicrosoftPowerPointPresentation Property

Aspose.Email

OleDocumentFormat.MicrosoftPowerPointPresentation Property

Microsoft power point format.

public static OleDocumentFormat MicrosoftPowerPointPresentation {get;}

See Also

OleDocumentFormat Class | Aspose.Email.Outlook Namespace


Unknown Property

Aspose.Email

OleDocumentFormat.Unknown Property

Unknown type.

public static OleDocumentFormat Unknown {get;}

See Also

OleDocumentFormat Class | Aspose.Email.Outlook Namespace


OleDocumentFormat Methods

The methods of the OleDocumentFormat class are listed below. For a complete list of OleDocumentFormat class members, see the OleDocumentFormat Members topic.

Public Instance Methods

Equals | Returns a value indicating whether this instance is equal to a specified object.
GetHashCode | Returns the hash code of this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Overridden. Returns a string representation of this instance.

See Also

OleDocumentFormat Class | Aspose.Email.Outlook Namespace


OleDocumentFormat.Equals Method

Returns a value indicating whether this instance is equal to a specified object.

public override bool Equals(
object o
);

Parameters

o
The object to compare with this instance.

Return Value

true if o is a System.Guid that has the same value as this instance; otherwise, false.

See Also

OleDocumentFormat Class | Aspose.Email.Outlook Namespace


OleDocumentFormat.GetHashCode Method

Returns the hash code of this instance.

public override int GetHashCode();

Return Value

The hash code for this instance.

See Also

OleDocumentFormat Class | Aspose.Email.Outlook Namespace


OleDocumentFormat.ToString Method

Overridden. Returns a string representation of this instance.

public override string ToString();

Return Value

A string contains the mail addresse.

See Also

OleDocumentFormat Class | Aspose.Email.Outlook Namespace


OutlookMessageFormat Enumeration

Represents outlook message format.

public enum OutlookMessageFormat

Members

Member Name | Description | Value
ASCII | ASCII. | 0
Unicode | Unicode. | 1

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Outlook Namespace


TaskSaveFormat Enumeration

Enumerates TaskSaveFormat

public enum TaskSaveFormat

Members

Member Name | Description | Value
Msg | MSG format. | 0

Requirements

Namespace: Aspose.Email.Outlook

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Outlook Namespace


Aspose.Email.Outlook.Pst

Aspose.Email

Aspose.Email.Outlook.Pst Namespace

Namespace hierarchy

Classes

Class | Description
FolderInfo | Represents information about personal folder in PST.
FolderInfoCollection | Represents collection of FolderInfo.
ItemMovedEventArgs | Provides data for the ItemMoved event
MessageAddedEventArgs | Provides data for the MessageAdded event
MessageInfo | Represents information about message in PST.
MessageInfoCollection | Represents the collection of MessageInfo.
PersonalStorage | Represents Personal Storage Table (.pst) file.
PersonalStorageQueryBuilder | Represents the builder of search expression that used by pst.

Delegates

Delegate | Description
ItemMovedEventHandler | Represents the method that will handle an ItemMoved event.
MessageAddedEventHandler | Represents the method that will handle an MessageAdded event.

Enumerations

Enumeration | Description
BackupOptions | Enumerates backup options
FileFormat | Specifies the file format used to store messages, calendar events, and other items.
FileFormatVersion | Represents version of file.
MapiImportance | Contains a values that indicates the message importance.
MapiSensitivity | Contains a values that indicates the message sensitivity.
RestoreOptions | Enumerates restore options
StandardIpmFolder | Represents a standard interpersonal message (IPM) folders.


BackupOptions Enumeration

Enumerates backup options

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum BackupOptions

Members

Member Name | Description | Value
None | Indicates that no specific options are specified | 0
Recursive | Indicates that nested folders should be also backuped | 1

Requirements

Namespace: Aspose.Email.Outlook.Pst

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Outlook.Pst Namespace


FileFormat Enumeration

Specifies the file format used to store messages, calendar events, and other items.

public enum FileFormat

Members

Member Name | Description | Value
Pst | Personal Storage Table (.pst file format). | 0
Ost | Off-line Storage Table (.ost file format). | 1

Requirements

Namespace: Aspose.Email.Outlook.Pst

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Outlook.Pst Namespace


FileFormatVersion Enumeration

Represents version of file.

public enum FileFormatVersion

Members

Member Name | Description | Value
Unicode | Unicode file format. | 0
ANSI | ANSI file format. | 1

Requirements

Namespace: Aspose.Email.Outlook.Pst

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Outlook.Pst Namespace


FolderInfo Class

Represents information about personal folder in PST.

For a list of all members of this type, see FolderInfo Members.

System.Object
Aspose.Email.Outlook.Pst.FolderInfo

public sealed class FolderInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook.Pst

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FolderInfo Members | Aspose.Email.Outlook.Pst Namespace


FolderInfo Members

FolderInfo overview

Public Instance Constructors

FolderInfo Constructor Initializes a new instance of the FolderInfo class.

Public Instance Properties

ContainerClass | Gets container class of the folder object.
ContentCount | Gets the total number of items in the folder.
ContentUnreadCount | Gets the number of unread items in the folder.
DisplayName | Gets the display name of folder.
EntryId | Gets the entry ID.
EntryIdString | Gets string representation of entry ID.
HasSubFolders | Gets a value indicating whether the Folder object has any subfolders.
LastModificationTime | Gets the last modification time.
Properties | Gets the folder properties.

Public Instance Methods

AddFile | Adds a file into pst folder.
AddMapiMessageItem | Adds the IMapiMessageItem object into folder.
AddMessage | Adds a new message into folder.
AddMessages | Provides message adding in a bulk mode.
AddSubFolder | Overloaded. Adds the new subfolder.
ChangeContainerClass | Changes the container class.
ChangeDisplayName | Changes the display name.
DeleteChildItem | Deletes the item (folder or message) by it's entryId.
EnumerateFolders | Exposes the enumerator, which supports an iteration of subfolders in folder.
EnumerateMapiMessages | Exposes the enumerator, which supports an iteration of messages in folder.
EnumerateMessageObjects | Exposes the enumerator, which supports an iteration of messages in folder.
EnumerateMessages | Exposes the enumerator, which supports an iteration of messages in folder.
EnumerateMessagesEntryId | Enumerates the entryID of messages.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetContents | Overloaded. Get collection of messages.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSubFolder | Get subfolder.
GetSubFolders | Overloaded. Gets collection of subfolders.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveContents | Moves the contents to a new folder.
MoveSubfolders | Moves the subfolders to a new parent folder.
RetrieveFullPath | Retrieves the full path of folder within the PST file.
ToString (inherited from Object) | Returns a String that represents the current Object.

Public Instance Events

ItemMoved | Occurs when an item is moved to the another folder.
MessageAdded | Occurs when a message is added to the current folder.

See Also

FolderInfo Class | Aspose.Email.Outlook.Pst Namespace


FolderInfo Constructor

Initializes a new instance of the FolderInfo class.

public FolderInfo();

See Also

FolderInfo Class | Aspose.Email.Outlook.Pst Namespace


FolderInfo Properties

The properties of the FolderInfo class are listed below. For a complete list of FolderInfo class members, see the FolderInfo Members topic.

Public Instance Properties

ContainerClass | Gets container class of the folder object.
ContentCount | Gets the total number of items in the folder.
ContentUnreadCount | Gets the number of unread items in the folder.
DisplayName | Gets the display name of folder.
EntryId | Gets the entry ID.
EntryIdString | Gets string representation of entry ID.
HasSubFolders | Gets a value indicating whether the Folder object has any subfolders.
LastModificationTime | Gets the last modification time.
Properties | Gets the folder properties.

See Also

FolderInfo Class | Aspose.Email.Outlook.Pst Namespace


ContainerClass Property

Aspose.Email

FolderInfo.ContainerClass Property

Gets container class of the folder object.

public string ContainerClass {get;}

Property Value

The container class.

See Also

FolderInfo Class | Aspose.Email.Outlook.Pst Namespace


ContentCount Property

Aspose.Email

FolderInfo.ContentCount Property

Gets the total number of items in the folder.

public int ContentCount {get;}

Property Value

The content count.

See Also

FolderInfo Class | Aspose.Email.Outlook.Pst Namespace


ContentUnreadCount Property

Aspose.Email

FolderInfo.ContentUnreadCount Property

Gets the number of unread items in the folder.

public int ContentUnreadCount {get;}

Property Value

The content unread count.

See Also

FolderInfo Class | Aspose.Email.Outlook.Pst Namespace


DisplayName Property

Aspose.Email

FolderInfo.DisplayName Property

Gets the display name of folder.

public string DisplayName {get;}

Property Value

The display name.

See Also

FolderInfo Class | Aspose.Email.Outlook.Pst Namespace


EntryId Property

Aspose.Email

FolderInfo.EntryId Property

Gets the entry ID.

public byte[] EntryId {get;}

Property Value

The entry id.

See Also

FolderInfo Class | Aspose.Email.Outlook.Pst Namespace


EntryIdString Property

Aspose.Email

FolderInfo.EntryIdString Property

Gets string representation of entry ID.

public string EntryIdString {get;}

Property Value

The entry id string.

See Also

FolderInfo Class | Aspose.Email.Outlook.Pst Namespace


HasSubFolders Property

Aspose.Email

FolderInfo.HasSubFolders Property

Gets a value indicating whether the Folder object has any subfolders.

public bool HasSubFolders {get;}

Property Value

The has sub folders.

See Also

FolderInfo Class | Aspose.Email.Outlook.Pst Namespace


LastModificationTime Property

Aspose.Email

FolderInfo.LastModificationTime Property

Gets the last modification time.

public DateTime LastModificationTime {get;}

Property Value

The last modification time. If the folder doesn't have PR_LAST_MODIFICATION_TIME property, DateTime.MinValue is returned.

See Also

FolderInfo Class | Aspose.Email.Outlook.Pst Namespace


Properties Property

Aspose.Email

FolderInfo.Properties Property

Gets the folder properties.

public MapiPropertyCollection Properties {get;}

See Also

FolderInfo Class | Aspose.Email.Outlook.Pst Namespace


FolderInfo Methods

The methods of the FolderInfo class are listed below. For a complete list of FolderInfo class members, see the FolderInfo Members topic.

Public Instance Methods

AddFile | Adds a file into pst folder.
AddMapiMessageItem | Adds the IMapiMessageItem object into folder.
AddMessage | Adds a new message into folder.
AddMessages | Provides message adding in a bulk mode.
AddSubFolder | Overloaded. Adds the new subfolder.
ChangeContainerClass | Changes the container class.
ChangeDisplayName | Changes the display name.
DeleteChildItem | Deletes the item (folder or message) by it's entryId.
EnumerateFolders | Exposes the enumerator, which supports an iteration of subfolders in folder.
EnumerateMapiMessages | Exposes the enumerator, which supports an iteration of messages in folder.
EnumerateMessageObjects | Exposes the enumerator, which supports an iteration of messages in folder.
EnumerateMessages | Exposes the enumerator, which supports an iteration of messages in folder.
EnumerateMessagesEntryId | Enumerates the entryID of messages.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetContents | Overloaded. Get collection of messages.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetSubFolder | Get subfolder.
GetSubFolders | Overloaded. Gets collection of subfolders.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveContents | Moves the contents to a new folder.
MoveSubfolders | Moves the subfolders to a new parent folder.
RetrieveFullPath | Retrieves the full path of folder within the PST file.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FolderInfo Class | Aspose.Email.Outlook.Pst Namespace


FolderInfo.AddFile Method

Adds a file into pst folder.

public string AddFile(
string fileName,
string messageClass
);

Parameters

fileName
The name of file necessary to add.
messageClass
The message class.

Return Value

The string that represents the EntryId of the added message.

Exceptions

Exception Type | Condition
NotImplementedException | throws, if a PST file version is ANSI.
ArgumentNullException | throws, if a name of file to add is null or empty.
InvalidOperationException | throws, if a PST is open for reading only.

See Also

FolderInfo Class | Aspose.Email.Outlook.Pst Namespace


FolderInfo.AddMapiMessageItem Method

Adds the IMapiMessageItem object into folder.

public string AddMapiMessageItem(
IMapiMessageItem item
);

Parameters

item
The item necessary to add.

Return Value

The string that represents the EntryId of the added item.

Exceptions

Exception Type | Condition
NotImplementedException | throws, if a PST file version is ANSI.
ArgumentNullException | throws, if an item to add is null.
InvalidOperationException | throws, if a PST is open for reading only.
NotSupportedException | Thrown when MessageClass doesn't belong to IPM.Note, IPM.StickyNote, IPM.Contact, IPM.Activity, IPM.Appointment, IPM.Schedule.meeting, IPM.Task.
InvalidOperationException | Thrown when MessageClass doesn't correspond to the folder's ContainerClass.

See Also

FolderInfo Class | Aspose.Email.Outlook.Pst Namespace


FolderInfo.AddMessage Method

Adds a new message into folder.

public string AddMessage(
MapiMessage message
);

Parameters

message
The message necessary to add.

Return Value

The string that represents the EntryId of the added message.

Exceptions

Exception Type | Condition
NotImplementedException | throws, if a PST file version is ANSI.
ArgumentNullException | throws, if a message to add is null.
InvalidOperationException | throws, if a PST is open for reading only.

See Also

FolderInfo Class | Aspose.Email.Outlook.Pst Namespace


FolderInfo.AddMessages Method

Provides message adding in a bulk mode.

public void AddMessages(
IEnumerable<MapiMessage> messages
);

Parameters

messages
An IEnumerator representing the enumerator, which supports iteration over a collection of MapiMessage.

See Also

FolderInfo Class | Aspose.Email.Outlook.Pst Namespace


AddSubFolder Method

Aspose.Email

FolderInfo.AddSubFolder Method

Adds the new subfolder.

Overload List

Adds the new subfolder.

public FolderInfo AddSubFolder(string);

Adds the new subfolder.

public FolderInfo AddSubFolder(string,string);

See Also

FolderInfo Class | Aspose.Email.Outlook.Pst Namespace


FolderInfo.AddSubFolder Method (String)

Adds the new subfolder.

public FolderInfo AddSubFolder(
string name
);

Parameters

name
The name of subfolder.

Return Value

The new subfolder.

Exceptions

Exception Type | Condition
NotImplementedException | throws, if a PST file version is ANSI.
ArgumentNullException | throws, if a subfolder name is null or empty.
InvalidOperationException | throws, if a PST is open for reading only.

See Also

FolderInfo Class | Aspose.Email.Outlook.Pst Namespace | FolderInfo.AddSubFolder Overload List


FolderInfo.AddSubFolder Method (String, String)

Adds the new subfolder.

public FolderInfo AddSubFolder(
string name,
string containerClass
);

Parameters

name
The name of subfolder.
containerClass
Container class of the sub-Folder object.

Return Value

The new subfolder.

Exceptions

Exception Type | Condition
NotImplementedException | throws, if a PST file version is ANSI.
ArgumentNullException | throws, if a subfolder name is null or empty.
InvalidOperationException | throws, if a PST is open for reading only.

See Also

FolderInfo Class | Aspose.Email.Outlook.Pst Namespace | FolderInfo.AddSubFolder Overload List


FolderInfo.ChangeContainerClass Method

Changes the container class.

public void ChangeContainerClass(
string containerClass
);

Parameters

containerClass
Container class of the of the folder object.

Exceptions

Exception Type | Condition
InvalidOperationException | throws, if a PST is open for reading only.
NotImplementedException | throws, if a PST file version is ANSI.

See Also

FolderInfo Class | Aspose.Email.Outlook.Pst Namespace


FolderInfo.ChangeDisplayName Method

Changes the display name.

public void ChangeDisplayName(
string newName
);

Parameters

newName
A new name.

Exceptions

Exception Type | Condition
InvalidOperationException | throws, if a PST is open for reading only.
NotImplementedException | throws, if a PST file version is ANSI.

See Also

FolderInfo Class | Aspose.Email.Outlook.Pst Namespace


FolderInfo.DeleteChildItem Method

Deletes the item (folder or message) by it's entryId.

public void DeleteChildItem(
byte[] entryId
);

Parameters

entryId
The entry id.

Remarks

The item must be contained in a folder.

Exceptions

Exception Type | Condition
ArgumentNullException | throws, if entryId is null.
InvalidOperationException | throws, if the item doesn't belong to the folder or the item can't be deleted or enrtyID has the incorrect value.
InvalidOperationException | throws, if a PST is open for reading only.

See Also

FolderInfo Class | Aspose.Email.Outlook.Pst Namespace


FolderInfo.EnumerateFolders Method

Exposes the enumerator, which supports an iteration of subfolders in folder.

public IEnumerable<FolderInfo> EnumerateFolders();

Return Value

IEnumerable`1, that represents an enumerator that iterates through a subfolders in folder.

See Also

FolderInfo Class | Aspose.Email.Outlook.Pst Namespace


FolderInfo.EnumerateMapiMessages Method

Exposes the enumerator, which supports an iteration of messages in folder.

public IEnumerable<MapiMessage> EnumerateMapiMessages();

Return Value

IEnumerable`1, that represents an enumerator that iterates through a messages in folder.

See Also

FolderInfo Class | Aspose.Email.Outlook.Pst Namespace


FolderInfo.EnumerateMessageObjects Method

Exposes the enumerator, which supports an iteration of messages in folder.

public IEnumerable<MessageObject> EnumerateMessageObjects();

Return Value

IEnumerable`1, that represents an enumerator that iterates through a messages in folder.

See Also

FolderInfo Class | Aspose.Email.Outlook.Pst Namespace


FolderInfo.EnumerateMessages Method

Exposes the enumerator, which supports an iteration of messages in folder.

public IEnumerable<MessageInfo> EnumerateMessages();

Return Value

IEnumerable`1, that represents an enumerator that iterates through a messages in folder.

See Also

FolderInfo Class | Aspose.Email.Outlook.Pst Namespace


FolderInfo.EnumerateMessagesEntryId Method

Enumerates the entryID of messages.

public IEnumerable<string> EnumerateMessagesEntryId();

Return Value

See Also

FolderInfo Class | Aspose.Email.Outlook.Pst Namespace


GetContents Method

Aspose.Email

FolderInfo.GetContents Method

Get collection of messages.

Overload List

Get collection of messages.

public MessageInfoCollection GetContents();

Get collection of messages.

public MessageInfoCollection GetContents(MailQuery);

Get collection of messages.

public MessageInfoCollection GetContents(bool);

Gets the collection of messages.

public MessageInfoCollection GetContents(int,int);

See Also

FolderInfo Class | Aspose.Email.Outlook.Pst Namespace


FolderInfo.GetContents Method ()

Get collection of messages.

public MessageInfoCollection GetContents();

Return Value

Collection of MessageInfo.

See Also

FolderInfo Class | Aspose.Email.Outlook.Pst Namespace | FolderInfo.GetContents Overload List


FolderInfo.GetContents Method (MailQuery)

Get collection of messages.

public MessageInfoCollection GetContents(
MailQuery query
);

Parameters

query
MailQuery that represents search query.

Return Value

Collection of MessageInfo.

See Also

FolderInfo Class | Aspose.Email.Outlook.Pst Namespace | FolderInfo.GetContents Overload List


FolderInfo.GetContents Method (Boolean)

Get collection of messages.

public MessageInfoCollection GetContents(
bool tryToReadCorruptedContents
);

Parameters

tryToReadCorruptedContents
If the value of this parameter is true, the method will try to read the content even if the file is corrupted. This value can be used if the GetContents() method throws an exception about the file corruption. If the value of this parameter is false, the method works in the same way as GetContents() method without parameters.

Return Value

Collection of MessageInfo.

See Also

FolderInfo Class | Aspose.Email.Outlook.Pst Namespace | FolderInfo.GetContents Overload List


FolderInfo.GetContents Method (Int32, Int32)

Gets the collection of messages.

public MessageInfoCollection GetContents(
int startIndex,
int count
);

Parameters

startIndex
The start message index.
count
The number of messages that will be retrieved.

Return Value

Collection of MessageInfo.

Remarks

If "count" param is less than 0 or more than remained message count then remained message count will be returned.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | throws, if startIndex less than 0.
ArgumentOutOfRangeException | throws, if startIndex more or equal to total message count that folder contains.

See Also

FolderInfo Class | Aspose.Email.Outlook.Pst Namespace | FolderInfo.GetContents Overload List


FolderInfo.GetSubFolder Method

Get subfolder.

public FolderInfo GetSubFolder(
string name
);

Parameters

name
Name of subfolder.

Return Value

A FolderInfo object.

See Also

FolderInfo Class | Aspose.Email.Outlook.Pst Namespace


GetSubFolders Method

Aspose.Email

FolderInfo.GetSubFolders Method

Gets collection of subfolders.

Overload List

Gets collection of subfolders.

public FolderInfoCollection GetSubFolders();

Gets collection of subfolders.

public FolderInfoCollection GetSubFolders(MailQuery);

See Also

FolderInfo Class | Aspose.Email.Outlook.Pst Namespace


FolderInfo.GetSubFolders Method ()

Gets collection of subfolders.

public FolderInfoCollection GetSubFolders();

Return Value

The FolderInfo collection.

See Also

FolderInfo Class | Aspose.Email.Outlook.Pst Namespace | FolderInfo.GetSubFolders Overload List


FolderInfo.GetSubFolders Method (MailQuery)

Gets collection of subfolders.

public FolderInfoCollection GetSubFolders(
MailQuery query
);

Parameters

query
MailQuery that represents search query.

Return Value

The FolderInfo collection.

See Also

FolderInfo Class | Aspose.Email.Outlook.Pst Namespace | FolderInfo.GetSubFolders Overload List


FolderInfo.MoveContents Method

Moves the contents to a new folder.

public void MoveContents(
FolderInfo newFolder
);

Parameters

newFolder
The new folder.

See Also

FolderInfo Class | Aspose.Email.Outlook.Pst Namespace


FolderInfo.MoveSubfolders Method

Moves the subfolders to a new parent folder.

public void MoveSubfolders(
FolderInfo newFolder
);

Parameters

newFolder
The new parent folder.

See Also

FolderInfo Class | Aspose.Email.Outlook.Pst Namespace


FolderInfo.RetrieveFullPath Method

Retrieves the full path of folder within the PST file.

public string RetrieveFullPath();

Return Value

The string that represents the full path.

See Also

FolderInfo Class | Aspose.Email.Outlook.Pst Namespace


FolderInfo Events

The events of the FolderInfo class are listed below. For a complete list of FolderInfo class members, see the FolderInfo Members topic.

Public Instance Events

ItemMoved | Occurs when an item is moved to the another folder.
MessageAdded | Occurs when a message is added to the current folder.

See Also

FolderInfo Class | Aspose.Email.Outlook.Pst Namespace


FolderInfo.ItemMoved Event

Occurs when an item is moved to the another folder.

public event ItemMovedEventHandler ItemMoved;

Event Data

The event handler receives an argument of type ItemMovedEventArgs containing data related to this event. The following ItemMovedEventArgs properties provide information specific to this event.

Property | Description
EntryId | Gets the string that represents the EntryId of the moved message.
ItemProperties | Gets the item properties that has been moved.

See Also

FolderInfo Class | Aspose.Email.Outlook.Pst Namespace


FolderInfo.MessageAdded Event

Occurs when a message is added to the current folder.

public event MessageAddedEventHandler MessageAdded;

Event Data

The event handler receives an argument of type MessageAddedEventArgs containing data related to this event. The following MessageAddedEventArgs properties provide information specific to this event.

Property | Description
EntryId | Gets the string that represents the EntryId of the added message.
Message | Gets the message that has been added.

See Also

FolderInfo Class | Aspose.Email.Outlook.Pst Namespace


FolderInfoCollection Class

Represents collection of FolderInfo.

For a list of all members of this type, see FolderInfoCollection Members.

System.Object
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Outlook.Pst.FolderInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]]
Aspose.Email.Outlook.Pst.FolderInfoCollection

public sealed class FolderInfoCollection : Collection`1

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook.Pst

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FolderInfoCollection Members | Aspose.Email.Outlook.Pst Namespace


FolderInfoCollection Members

FolderInfoCollection overview

Public Instance Constructors

FolderInfoCollection Constructor Initializes a new instance of the FolderInfoCollection class.

Public Instance Properties

Count (inherited from 0, Culture=neutral, PublicKeyToken=null]])
Item (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FolderInfoCollection Class | Aspose.Email.Outlook.Pst Namespace


FolderInfoCollection Constructor

Initializes a new instance of the FolderInfoCollection class.

public FolderInfoCollection();

See Also

FolderInfoCollection Class | Aspose.Email.Outlook.Pst Namespace


ItemMovedEventArgs Class

Provides data for the ItemMoved event

For a list of all members of this type, see ItemMovedEventArgs Members.

System.Object
System.EventArgs
Aspose.Email.Outlook.Pst.ItemMovedEventArgs

public class ItemMovedEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook.Pst

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ItemMovedEventArgs Members | Aspose.Email.Outlook.Pst Namespace


ItemMovedEventArgs Members

ItemMovedEventArgs overview

Public Instance Constructors

ItemMovedEventArgs Overloaded. Initializes a new instance of the ItemMovedEventArgs class.

Public Instance Properties

EntryId | Gets the string that represents the EntryId of the moved message.
ItemProperties | Gets the item properties that has been moved.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ItemMovedEventArgs Class | Aspose.Email.Outlook.Pst Namespace


ItemMovedEventArgs Constructor

Initializes a new instance of the ItemMovedEventArgs class.

Overload List

Initializes a new instance of the ItemMovedEventArgs class.

public ItemMovedEventArgs(FolderInfo);

Initializes a new instance of the ItemMovedEventArgs class.

public ItemMovedEventArgs(MessageInfo);

See Also

ItemMovedEventArgs Class | Aspose.Email.Outlook.Pst Namespace


ItemMovedEventArgs Constructor (MessageInfo)

Initializes a new instance of the ItemMovedEventArgs class.

public ItemMovedEventArgs(
MessageInfo message
);

Parameters

message
The message.

See Also

ItemMovedEventArgs Class | Aspose.Email.Outlook.Pst Namespace | ItemMovedEventArgs Constructor Overload List


ItemMovedEventArgs Constructor (FolderInfo)

Initializes a new instance of the ItemMovedEventArgs class.

public ItemMovedEventArgs(
FolderInfo folder
);

Parameters

folder
The folder.

See Also

ItemMovedEventArgs Class | Aspose.Email.Outlook.Pst Namespace | ItemMovedEventArgs Constructor Overload List


ItemMovedEventArgs Properties

The properties of the ItemMovedEventArgs class are listed below. For a complete list of ItemMovedEventArgs class members, see the ItemMovedEventArgs Members topic.

Public Instance Properties

EntryId | Gets the string that represents the EntryId of the moved message.
ItemProperties | Gets the item properties that has been moved.

See Also

ItemMovedEventArgs Class | Aspose.Email.Outlook.Pst Namespace


EntryId Property

Aspose.Email

ItemMovedEventArgs.EntryId Property

Gets the string that represents the EntryId of the moved message.

public string EntryId {get;}

Property Value

The entry id.

See Also

ItemMovedEventArgs Class | Aspose.Email.Outlook.Pst Namespace


ItemProperties Property

Aspose.Email

ItemMovedEventArgs.ItemProperties Property

Gets the item properties that has been moved.

public MapiPropertyCollection ItemProperties {get;}

Property Value

The message.

See Also

ItemMovedEventArgs Class | Aspose.Email.Outlook.Pst Namespace


ItemMovedEventHandler Delegate

Represents the method that will handle an ItemMoved event.

public delegate void ItemMovedEventHandler(
object sender,
ItemMovedEventArgs e
);

Requirements

Namespace: Aspose.Email.Outlook.Pst

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Outlook.Pst Namespace


MapiImportance Enumeration

Contains a values that indicates the message importance.

public enum MapiImportance

Members

Member Name | Description | Value
Low | Low importance. | 0
Normal | Normal importance. | 1
High | High importance. | 2

Requirements

Namespace: Aspose.Email.Outlook.Pst

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Outlook.Pst Namespace


MapiSensitivity Enumeration

Contains a values that indicates the message sensitivity.

public enum MapiSensitivity

Members

Member Name | Description | Value
None | The message has no special sensitivity. | 0
Personal | The message is personal. | 1
Private | The message is private. | 2
CompanyConfidential | The message is designated company confidential. | 3

Requirements

Namespace: Aspose.Email.Outlook.Pst

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Outlook.Pst Namespace


MessageAddedEventArgs Class

Provides data for the MessageAdded event

For a list of all members of this type, see MessageAddedEventArgs Members.

System.Object
System.EventArgs
Aspose.Email.Outlook.Pst.MessageAddedEventArgs

public class MessageAddedEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook.Pst

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MessageAddedEventArgs Members | Aspose.Email.Outlook.Pst Namespace


MessageAddedEventArgs Members

MessageAddedEventArgs overview

Public Instance Constructors

MessageAddedEventArgs Constructor Initializes a new instance of the MessageAddedEventArgs class.

Public Instance Properties

EntryId | Gets the string that represents the EntryId of the added message.
Message | Gets the message that has been added.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MessageAddedEventArgs Class | Aspose.Email.Outlook.Pst Namespace


MessageAddedEventArgs Constructor

Initializes a new instance of the MessageAddedEventArgs class.

public MessageAddedEventArgs(
string entryId,
MapiMessage message
);

Parameters

entryId
The entry id.
message
The message.

See Also

MessageAddedEventArgs Class | Aspose.Email.Outlook.Pst Namespace


MessageAddedEventArgs Properties

The properties of the MessageAddedEventArgs class are listed below. For a complete list of MessageAddedEventArgs class members, see the MessageAddedEventArgs Members topic.

Public Instance Properties

EntryId | Gets the string that represents the EntryId of the added message.
Message | Gets the message that has been added.

See Also

MessageAddedEventArgs Class | Aspose.Email.Outlook.Pst Namespace


EntryId Property

Aspose.Email

MessageAddedEventArgs.EntryId Property

Gets the string that represents the EntryId of the added message.

public string EntryId {get;}

Property Value

The entry id.

See Also

MessageAddedEventArgs Class | Aspose.Email.Outlook.Pst Namespace


Message Property

Aspose.Email

MessageAddedEventArgs.Message Property

Gets the message that has been added.

public MapiMessage Message {get;}

Property Value

The message.

See Also

MessageAddedEventArgs Class | Aspose.Email.Outlook.Pst Namespace


MessageAddedEventHandler Delegate

Represents the method that will handle an MessageAdded event.

public delegate void MessageAddedEventHandler(
object sender,
MessageAddedEventArgs e
);

Requirements

Namespace: Aspose.Email.Outlook.Pst

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Outlook.Pst Namespace


MessageInfo Class

Represents information about message in PST.

For a list of all members of this type, see MessageInfo Members.

System.Object
Aspose.Email.Outlook.Pst.MessageInfo

public sealed class MessageInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook.Pst

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MessageInfo Members | Aspose.Email.Outlook.Pst Namespace


MessageInfo Members

MessageInfo overview

Public Instance Constructors

MessageInfo Constructor Initializes a new instance of the MessageInfo class.

Public Instance Properties

DisplayCC | Gets the CC: line.
DisplayTo | Gets the To: line.
EntryId | Gets the entry ID.
EntryIdString | Gets string representation of entry ID.
Importance | Gets the Importance.
MessageClass | Gets the Message class.
Properties | Gets the MessageInfo properties.
SenderRepresentativeName | Gets the sender representative name.
Sensitivity | Gets the Sensitivity.
Subject | Gets the message subject.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MessageInfo Class | Aspose.Email.Outlook.Pst Namespace


MessageInfo Constructor

Initializes a new instance of the MessageInfo class.

public MessageInfo();

See Also

MessageInfo Class | Aspose.Email.Outlook.Pst Namespace


MessageInfo Properties

The properties of the MessageInfo class are listed below. For a complete list of MessageInfo class members, see the MessageInfo Members topic.

Public Instance Properties

DisplayCC | Gets the CC: line.
DisplayTo | Gets the To: line.
EntryId | Gets the entry ID.
EntryIdString | Gets string representation of entry ID.
Importance | Gets the Importance.
MessageClass | Gets the Message class.
Properties | Gets the MessageInfo properties.
SenderRepresentativeName | Gets the sender representative name.
Sensitivity | Gets the Sensitivity.
Subject | Gets the message subject.

See Also

MessageInfo Class | Aspose.Email.Outlook.Pst Namespace


DisplayCC Property

Aspose.Email

MessageInfo.DisplayCC Property

Gets the CC: line.

public string DisplayCC {get;}

Property Value

The display cc.

See Also

MessageInfo Class | Aspose.Email.Outlook.Pst Namespace


DisplayTo Property

Aspose.Email

MessageInfo.DisplayTo Property

Gets the To: line.

public string DisplayTo {get;}

Property Value

The display to.

See Also

MessageInfo Class | Aspose.Email.Outlook.Pst Namespace


EntryId Property

Aspose.Email

MessageInfo.EntryId Property

Gets the entry ID.

public byte[] EntryId {get;}

Property Value

The entry id.

See Also

MessageInfo Class | Aspose.Email.Outlook.Pst Namespace


EntryIdString Property

Aspose.Email

MessageInfo.EntryIdString Property

Gets string representation of entry ID.

public string EntryIdString {get;}

Property Value

The entry id string.

See Also

MessageInfo Class | Aspose.Email.Outlook.Pst Namespace


Importance Property

Aspose.Email

MessageInfo.Importance Property

Gets the Importance.

public MapiImportance Importance {get;}

Property Value

The importance.

See Also

MessageInfo Class | Aspose.Email.Outlook.Pst Namespace


MessageClass Property

Aspose.Email

MessageInfo.MessageClass Property

Gets the Message class.

public string MessageClass {get;}

Property Value

The message class.

See Also

MessageInfo Class | Aspose.Email.Outlook.Pst Namespace


Properties Property

Aspose.Email

MessageInfo.Properties Property

Gets the MessageInfo properties.

public MapiPropertyCollection Properties {get;}

Property Value

The properties of MessageInfo.

See Also

MessageInfo Class | Aspose.Email.Outlook.Pst Namespace


SenderRepresentativeName Property

Aspose.Email

MessageInfo.SenderRepresentativeName Property

Gets the sender representative name.

public string SenderRepresentativeName {get;}

Property Value

The sender representative name.

See Also

MessageInfo Class | Aspose.Email.Outlook.Pst Namespace


Sensitivity Property

Aspose.Email

MessageInfo.Sensitivity Property

Gets the Sensitivity.

public MapiSensitivity Sensitivity {get;}

Property Value

The sensitivity.

See Also

MessageInfo Class | Aspose.Email.Outlook.Pst Namespace


Subject Property

Aspose.Email

MessageInfo.Subject Property

Gets the message subject.

public string Subject {get;}

Property Value

The subject.

See Also

MessageInfo Class | Aspose.Email.Outlook.Pst Namespace


MessageInfoCollection Class

Represents the collection of MessageInfo.

For a list of all members of this type, see MessageInfoCollection Members.

System.Object
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Outlook.Pst.MessageInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]]
Aspose.Email.Outlook.Pst.MessageInfoCollection

public sealed class MessageInfoCollection : Collection`1

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook.Pst

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MessageInfoCollection Members | Aspose.Email.Outlook.Pst Namespace


MessageInfoCollection Members

MessageInfoCollection overview

Public Instance Constructors

MessageInfoCollection Constructor Initializes a new instance of the MessageInfoCollection class.

Public Instance Properties

Count (inherited from 0, Culture=neutral, PublicKeyToken=null]])
Item (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MessageInfoCollection Class | Aspose.Email.Outlook.Pst Namespace


MessageInfoCollection Constructor

Initializes a new instance of the MessageInfoCollection class.

public MessageInfoCollection();

See Also

MessageInfoCollection Class | Aspose.Email.Outlook.Pst Namespace


PersonalStorage Class

Represents Personal Storage Table (.pst) file.

For a list of all members of this type, see PersonalStorage Members.

System.Object
Aspose.Email.Outlook.Pst.PersonalStorage

public class PersonalStorage : IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook.Pst

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PersonalStorage Members | Aspose.Email.Outlook.Pst Namespace


PersonalStorage Members

PersonalStorage overview

Public Static Methods

Create | Overloaded. Creates the new PST file with the specified file name.
FromFile | Overloaded. Load PST from file.
FromStream | Overloaded. Load PST from stream.

Public Instance Constructors

PersonalStorage Constructor Initializes a new instance of the PersonalStorage class.

Public Instance Properties

CanWrite | Gets a value indicating whether the current pst supports writing.
DisplayName | Gets the display Name of PST.
Format | Gets the file format.
IsUnicode | Gets a value indicating whether the PST file format is Unicode. There are two versions of the PST file format: Unicode and ANSI.
MessageStoreProperties | Gets the MAPI properties of message store object. The message store contains the top-level PST settings and metadata that are required to access and manage the PST contents.
RootFolder | Gets the root folder of PST.

Public Instance Methods

ChangeDisplayName | Changes the pst display name.
ConvertTo | Converts the current object to the specified format.
CreatePredefinedFolder | Creates the standard interpersonal message (IPM) folder.
Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExtractMessage | Overloaded. Get the message from PST.
ExtractProperty | Gets the specified property of item, without extract the item fully.
GetFolderById | Overloaded. Gets the personal folder from PST.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPredefinedFolder | Gets the standard interpersonal message (IPM) folder from PST. Outlook can create a number of default folders, such as Outbox, Deleted Items, Sent Items etc.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveItem | Overloaded. Moves a specified message to a new folder within the current pst.
SaveAs | Saves the current object to a specified file format in a different file.
SaveMessageToStream | Saves the message, with specified entryID, to a stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Dispose | Overloaded. Releases unmanaged and - optionally - managed resources.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PersonalStorage Class | Aspose.Email.Outlook.Pst Namespace


PersonalStorage Constructor

Initializes a new instance of the PersonalStorage class.

public PersonalStorage();

See Also

PersonalStorage Class | Aspose.Email.Outlook.Pst Namespace


PersonalStorage Properties

The properties of the PersonalStorage class are listed below. For a complete list of PersonalStorage class members, see the PersonalStorage Members topic.

Public Instance Properties

CanWrite | Gets a value indicating whether the current pst supports writing.
DisplayName | Gets the display Name of PST.
Format | Gets the file format.
IsUnicode | Gets a value indicating whether the PST file format is Unicode. There are two versions of the PST file format: Unicode and ANSI.
MessageStoreProperties | Gets the MAPI properties of message store object. The message store contains the top-level PST settings and metadata that are required to access and manage the PST contents.
RootFolder | Gets the root folder of PST.

See Also

PersonalStorage Class | Aspose.Email.Outlook.Pst Namespace


CanWrite Property

Aspose.Email

PersonalStorage.CanWrite Property

Gets a value indicating whether the current pst supports writing.

public bool CanWrite {get;}

See Also

PersonalStorage Class | Aspose.Email.Outlook.Pst Namespace


DisplayName Property

Aspose.Email

PersonalStorage.DisplayName Property

Gets the display Name of PST.

public string DisplayName {get;}

Property Value

The string that represents display name.

See Also

PersonalStorage Class | Aspose.Email.Outlook.Pst Namespace


Format Property

Aspose.Email

PersonalStorage.Format Property

Gets the file format.

public FileFormat Format {get;}

Property Value

FileFormat that specifies file format.

Remarks

The .pst and .ost file formats are supported now.

See Also

PersonalStorage Class | Aspose.Email.Outlook.Pst Namespace


IsUnicode Property

Aspose.Email

PersonalStorage.IsUnicode Property

Gets a value indicating whether the PST file format is Unicode. There are two versions of the PST file format: Unicode and ANSI.

public bool IsUnicode {get;}

See Also

PersonalStorage Class | Aspose.Email.Outlook.Pst Namespace


MessageStoreProperties Property

Aspose.Email

PersonalStorage.MessageStoreProperties Property

Gets the MAPI properties of message store object. The message store contains the top-level PST settings and metadata that are required to access and manage the PST contents.

public MapiPropertyCollection MessageStoreProperties {get;}

See Also

PersonalStorage Class | Aspose.Email.Outlook.Pst Namespace


RootFolder Property

Aspose.Email

PersonalStorage.RootFolder Property

Gets the root folder of PST.

public FolderInfo RootFolder {get;}

Property Value

FolderInfo that represents a root folder.

See Also

PersonalStorage Class | Aspose.Email.Outlook.Pst Namespace


PersonalStorage Methods

The methods of the PersonalStorage class are listed below. For a complete list of PersonalStorage class members, see the PersonalStorage Members topic.

Public Static Methods

Create | Overloaded. Creates the new PST file with the specified file name.
FromFile | Overloaded. Load PST from file.
FromStream | Overloaded. Load PST from stream.

Public Instance Methods

ChangeDisplayName | Changes the pst display name.
ConvertTo | Converts the current object to the specified format.
CreatePredefinedFolder | Creates the standard interpersonal message (IPM) folder.
Dispose | Overloaded. Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ExtractMessage | Overloaded. Get the message from PST.
ExtractProperty | Gets the specified property of item, without extract the item fully.
GetFolderById | Overloaded. Gets the personal folder from PST.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetPredefinedFolder | Gets the standard interpersonal message (IPM) folder from PST. Outlook can create a number of default folders, such as Outbox, Deleted Items, Sent Items etc.
GetType (inherited from Object) | Gets the Type of the current instance.
MoveItem | Overloaded. Moves a specified message to a new folder within the current pst.
SaveAs | Saves the current object to a specified file format in a different file.
SaveMessageToStream | Saves the message, with specified entryID, to a stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Dispose | Overloaded. Releases unmanaged and - optionally - managed resources.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PersonalStorage Class | Aspose.Email.Outlook.Pst Namespace


PersonalStorage.ChangeDisplayName Method

Changes the pst display name.

public void ChangeDisplayName(
string newName
);

Parameters

newName
The new display name of message store.

See Also

PersonalStorage Class | Aspose.Email.Outlook.Pst Namespace


PersonalStorage.ConvertTo Method

Converts the current object to the specified format.

public void ConvertTo(
FileFormat format
);

Parameters

format
The FileFormat to convert the current object to.

See Also

PersonalStorage Class | Aspose.Email.Outlook.Pst Namespace


Create Method

Aspose.Email

PersonalStorage.Create Method

Creates the PST in a stream.

Overload List

Creates the PST in a stream.

public static PersonalStorage Create(Stream,FileFormatVersion);

Creates the new PST file with the specified file name.

public static PersonalStorage Create(string,FileFormatVersion);

See Also

PersonalStorage Class | Aspose.Email.Outlook.Pst Namespace


PersonalStorage.Create Method (Stream, FileFormatVersion)

Creates the PST in a stream.

public static PersonalStorage Create(
Stream stream,
FileFormatVersion version
);

Parameters

stream
The stream in which PST is created.
version
The PST file version.

Return Value

A PersonalStorage object that represents the new PST.

Remarks

Note, only Unicode file version creation is supported now.

Exceptions

Exception Type | Condition
NotImplementedException | throws if ANSI file version is created
ArgumentNullException | throws if stream is null

See Also

PersonalStorage Class | Aspose.Email.Outlook.Pst Namespace | PersonalStorage.Create Overload List


PersonalStorage.Create Method (String, FileFormatVersion)

Creates the new PST file with the specified file name.

public static PersonalStorage Create(
string fileName,
FileFormatVersion version
);

Parameters

fileName
The full name of the file.
version
The PST file version.

Return Value

A PersonalStorage object that represents the new PST.

Remarks

Note, only Unicode file version creation is supported now.

Exceptions

Exception Type | Condition
NotImplementedException | throws if ANSI file version is created
ArgumentNullException | throws if file name is null or empty

See Also

PersonalStorage Class | Aspose.Email.Outlook.Pst Namespace | PersonalStorage.Create Overload List


PersonalStorage.CreatePredefinedFolder Method

Creates the standard interpersonal message (IPM) folder.

public FolderInfo CreatePredefinedFolder(
string name,
StandardIpmFolder defaultFolder
);

Parameters

name
The name of folder.
defaultFolder
The value of StandardIpmFolder enumeration.

Return Value

A FolderInfo object that represents a standard IPM folder.

See Also

PersonalStorage Class | Aspose.Email.Outlook.Pst Namespace


Dispose Method

Aspose.Email

PersonalStorage.Dispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Overload List

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

public void Dispose();

Releases unmanaged and - optionally - managed resources.

protected virtual void Dispose(bool);

See Also

PersonalStorage Class | Aspose.Email.Outlook.Pst Namespace


PersonalStorage.Dispose Method ()

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

public void Dispose();

Implements

IDisposable.Dispose

See Also

PersonalStorage Class | Aspose.Email.Outlook.Pst Namespace | PersonalStorage.Dispose Overload List


PersonalStorage.Dispose Method (Boolean)

Releases unmanaged and - optionally - managed resources.

protected virtual void Dispose(
bool disposing
);

Parameters

disposing
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

PersonalStorage Class | Aspose.Email.Outlook.Pst Namespace | PersonalStorage.Dispose Overload List


ExtractMessage Method

Aspose.Email

PersonalStorage.ExtractMessage Method

Get the message from PST.

Overload List

Get the message from PST.

public MapiMessage ExtractMessage(MessageInfo);

Get the message from PST.

public MapiMessage ExtractMessage(byte[]);

Get the message from PST.

public MapiMessage ExtractMessage(string);

See Also

PersonalStorage Class | Aspose.Email.Outlook.Pst Namespace


PersonalStorage.ExtractMessage Method (MessageInfo)

Get the message from PST.

public MapiMessage ExtractMessage(
MessageInfo messageInfo
);

Parameters

messageInfo
A MessageInfo object that represents information about message.

Return Value

A MapiMessage object.

See Also

PersonalStorage Class | Aspose.Email.Outlook.Pst Namespace | PersonalStorage.ExtractMessage Overload List


PersonalStorage.ExtractMessage Method (Byte[])

Get the message from PST.

public MapiMessage ExtractMessage(
byte[] entryId
);

Parameters

entryId
EntryId of message.

Return Value

A MapiMessage object.

See Also

PersonalStorage Class | Aspose.Email.Outlook.Pst Namespace | PersonalStorage.ExtractMessage Overload List


PersonalStorage.ExtractMessage Method (String)

Get the message from PST.

public MapiMessage ExtractMessage(
string entryId
);

Parameters

entryId
String representation of EntryId.

Return Value

A MapiMessage object.

See Also

PersonalStorage Class | Aspose.Email.Outlook.Pst Namespace | PersonalStorage.ExtractMessage Overload List


PersonalStorage.ExtractProperty Method

Gets the specified property of item, without extract the item fully.

public MapiProperty ExtractProperty(
byte[] entryId,
long tag
);

Parameters

entryId
The entry id of item.
tag
The property tag.

Return Value

The MapiProperty.

Remarks

If a property is not found, null is returned.

See Also

PersonalStorage Class | Aspose.Email.Outlook.Pst Namespace


FromFile Method

Aspose.Email

PersonalStorage.FromFile Method

Load PST from file.

Overload List

Load PST from file.

public static PersonalStorage FromFile(string);

Load PST from file.

public static PersonalStorage FromFile(string,bool);

See Also

PersonalStorage Class | Aspose.Email.Outlook.Pst Namespace


PersonalStorage.FromFile Method (String)

Load PST from file.

public static PersonalStorage FromFile(
string fileName
);

Parameters

fileName
Name of .pst file.

Return Value

A PersonalStorage object that represents the current PST.

Remarks

By default, the pst will support writing.

See Also

PersonalStorage Class | Aspose.Email.Outlook.Pst Namespace | PersonalStorage.FromFile Overload List


PersonalStorage.FromFile Method (String, Boolean)

Load PST from file.

public static PersonalStorage FromFile(
string fileName,
bool writable
);

Parameters

fileName
Name of .pst file.
writable
if set to true then the the pst file will support writing, otherwise it will be opened in read-only mode.

Return Value

A PersonalStorage object that represents the current PST.

See Also

PersonalStorage Class | Aspose.Email.Outlook.Pst Namespace | PersonalStorage.FromFile Overload List


FromStream Method

Aspose.Email

PersonalStorage.FromStream Method

Load PST from stream.

Overload List

Load PST from stream.

public static PersonalStorage FromStream(Stream);

Load PST from stream.

public static PersonalStorage FromStream(Stream,bool);

See Also

PersonalStorage Class | Aspose.Email.Outlook.Pst Namespace


PersonalStorage.FromStream Method (Stream)

Load PST from stream.

public static PersonalStorage FromStream(
Stream stream
);

Parameters

stream
The System.IO.Stream.

Return Value

A PersonalStorage object that represents the current PST.

Remarks

By default, the pst will support writing.

See Also

PersonalStorage Class | Aspose.Email.Outlook.Pst Namespace | PersonalStorage.FromStream Overload List


PersonalStorage.FromStream Method (Stream, Boolean)

Load PST from stream.

public static PersonalStorage FromStream(
Stream stream,
bool writable
);

Parameters

stream
The System.IO.Stream.
writable
if set to true then the the pst will support writing, otherwise it will be opened in read-only mode.

Return Value

A PersonalStorage object that represents the current PST.

See Also

PersonalStorage Class | Aspose.Email.Outlook.Pst Namespace | PersonalStorage.FromStream Overload List


GetFolderById Method

Aspose.Email

PersonalStorage.GetFolderById Method

Gets the personal folder from PST.

Overload List

Gets the personal folder from PST.

public FolderInfo GetFolderById(byte[]);

Gets the personal folder from PST.

public FolderInfo GetFolderById(string);

See Also

PersonalStorage Class | Aspose.Email.Outlook.Pst Namespace


PersonalStorage.GetFolderById Method (Byte[])

Gets the personal folder from PST.

public FolderInfo GetFolderById(
byte[] entryId
);

Parameters

entryId
The Entry id.

Return Value

A FolderInfo object.

See Also

PersonalStorage Class | Aspose.Email.Outlook.Pst Namespace | PersonalStorage.GetFolderById Overload List


PersonalStorage.GetFolderById Method (String)

Gets the personal folder from PST.

public FolderInfo GetFolderById(
string entryIdString
);

Parameters

entryIdString
String representation of entry ID.

Return Value

A FolderInfo object.

See Also

PersonalStorage Class | Aspose.Email.Outlook.Pst Namespace | PersonalStorage.GetFolderById Overload List


PersonalStorage.GetPredefinedFolder Method

Gets the standard interpersonal message (IPM) folder from PST. Outlook can create a number of default folders, such as Outbox, Deleted Items, Sent Items etc.

public FolderInfo GetPredefinedFolder(
StandardIpmFolder defaultFolder
);

Parameters

defaultFolder
The value of StandardIpmFolder enumeration.

Return Value

A FolderInfo object that represents a standard IPM folder.

See Also

PersonalStorage Class | Aspose.Email.Outlook.Pst Namespace


MoveItem Method

Aspose.Email

PersonalStorage.MoveItem Method

Moves a specified folder to a new parent folder within the current pst.

Overload List

Moves a specified folder to a new parent folder within the current pst.

public void MoveItem(FolderInfo,FolderInfo);

Moves a specified message to a new folder within the current pst.

public void MoveItem(MessageInfo,FolderInfo);

See Also

PersonalStorage Class | Aspose.Email.Outlook.Pst Namespace


PersonalStorage.MoveItem Method (FolderInfo, FolderInfo)

Moves a specified folder to a new parent folder within the current pst.

public void MoveItem(
FolderInfo folder,
FolderInfo newFolder
);

Parameters

folder
The folder to move.
newFolder
The new parent folder.

See Also

PersonalStorage Class | Aspose.Email.Outlook.Pst Namespace | PersonalStorage.MoveItem Overload List


PersonalStorage.MoveItem Method (MessageInfo, FolderInfo)

Moves a specified message to a new folder within the current pst.

public void MoveItem(
MessageInfo message,
FolderInfo newFolder
);

Parameters

message
The message to move.
newFolder
The new folder for the message.

See Also

PersonalStorage Class | Aspose.Email.Outlook.Pst Namespace | PersonalStorage.MoveItem Overload List


PersonalStorage.SaveAs Method

Saves the current object to a specified file format in a different file.

public void SaveAs(
string fileName,
FileFormat format
);

Parameters

fileName
The name of the file to be saved.
format
The FileFormat is to be used when saving a file.

See Also

PersonalStorage Class | Aspose.Email.Outlook.Pst Namespace


PersonalStorage.SaveMessageToStream Method

Saves the message, with specified entryID, to a stream.

public void SaveMessageToStream(
string entryId,
Stream stream
);

Parameters

entryId
The entry id.
stream
The stream for writing.

See Also

PersonalStorage Class | Aspose.Email.Outlook.Pst Namespace


PersonalStorageQueryBuilder Class

Represents the builder of search expression that used by pst.

For a list of all members of this type, see PersonalStorageQueryBuilder Members.

System.Object
Aspose.Email.MailQueryBuilder
Aspose.Email.Outlook.Pst.PersonalStorageQueryBuilder

public sealed class PersonalStorageQueryBuilder : MailQueryBuilder

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Outlook.Pst

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PersonalStorageQueryBuilder Members | Aspose.Email.Outlook.Pst Namespace


PersonalStorageQueryBuilder Members

PersonalStorageQueryBuilder overview

Public Instance Constructors

PersonalStorageQueryBuilder Constructor Initializes a new instance of the PersonalStorageQueryBuilder class.

Public Instance Properties

Bcc (inherited from MailQueryBuilder) | Gets the field that allows to find messages that contain the specified string in the envelope structure's BCC field.
Body (inherited from MailQueryBuilder) | Gets the field that allows to find messages that contain the specified string in the body of the message.
Cc (inherited from MailQueryBuilder) | Gets the field that allows to find messages that contain the specified string in the envelope structure's CC field.
ContainerClass | Gets folders with an specified message class.
ContentsCount | Search folders with an specified contents count.
FolderName | Search folders with an specified display name.
From (inherited from MailQueryBuilder) | Gets the field that allows to find messages that contain the specified string in the envelope structure's FROM field.
Importance | Search messages with an specified importance.
InternalDate (inherited from MailQueryBuilder) | Gets the field that allows to find messages by internal date.
MessageClass | Gets messages with an specified message class.
MessageId (inherited from MailQueryBuilder) | Gets the field that allows to find messages that contain the specified string in the envelope structure's MessageId field.
MessageSize | Search messages with an specified size.
SentDate (inherited from MailQueryBuilder) | Gets the field that allows to find messages by sent date.
Subject (inherited from MailQueryBuilder) | Gets the field that allows to find messages that contain the specified string in the envelope structure's SUBJECT field.
Text (inherited from MailQueryBuilder) | Gets the field that allows to find the messages that contain the specified string in the header or body of the message.
To (inherited from MailQueryBuilder) | Gets the field that allows to find messages that contain the specified string in the envelope structure's TO field.
UnreadContentsCount | Search folders with an specified unread contents count.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetQuery (inherited from MailQueryBuilder) | Gets the query.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFlags | Search messages with the specified flags.
HasNoFlags | Search messages with the unspecified flags.
HasNoSubfolders | Search folders which does not contains subfolders.
HasSubfolders | Search folders which contains subfolders.
Or (inherited from MailQueryBuilder) | Search messages that match either search key. Provides disjunction between two expressions (OR).
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

PersonalStorageQueryBuilder Class | Aspose.Email.Outlook.Pst Namespace


PersonalStorageQueryBuilder Constructor

Initializes a new instance of the PersonalStorageQueryBuilder class.

public PersonalStorageQueryBuilder();

See Also

PersonalStorageQueryBuilder Class | Aspose.Email.Outlook.Pst Namespace


PersonalStorageQueryBuilder Properties

The properties of the PersonalStorageQueryBuilder class are listed below. For a complete list of PersonalStorageQueryBuilder class members, see the PersonalStorageQueryBuilder Members topic.

Public Instance Properties

Bcc (inherited from MailQueryBuilder) | Gets the field that allows to find messages that contain the specified string in the envelope structure's BCC field.
Body (inherited from MailQueryBuilder) | Gets the field that allows to find messages that contain the specified string in the body of the message.
Cc (inherited from MailQueryBuilder) | Gets the field that allows to find messages that contain the specified string in the envelope structure's CC field.
ContainerClass | Gets folders with an specified message class.
ContentsCount | Search folders with an specified contents count.
FolderName | Search folders with an specified display name.
From (inherited from MailQueryBuilder) | Gets the field that allows to find messages that contain the specified string in the envelope structure's FROM field.
Importance | Search messages with an specified importance.
InternalDate (inherited from MailQueryBuilder) | Gets the field that allows to find messages by internal date.
MessageClass | Gets messages with an specified message class.
MessageId (inherited from MailQueryBuilder) | Gets the field that allows to find messages that contain the specified string in the envelope structure's MessageId field.
MessageSize | Search messages with an specified size.
SentDate (inherited from MailQueryBuilder) | Gets the field that allows to find messages by sent date.
Subject (inherited from MailQueryBuilder) | Gets the field that allows to find messages that contain the specified string in the envelope structure's SUBJECT field.
Text (inherited from MailQueryBuilder) | Gets the field that allows to find the messages that contain the specified string in the header or body of the message.
To (inherited from MailQueryBuilder) | Gets the field that allows to find messages that contain the specified string in the envelope structure's TO field.
UnreadContentsCount | Search folders with an specified unread contents count.

See Also

PersonalStorageQueryBuilder Class | Aspose.Email.Outlook.Pst Namespace


ContainerClass Property

Aspose.Email

PersonalStorageQueryBuilder.ContainerClass Property

Gets folders with an specified message class.

public StringComparisonField ContainerClass {get;}

Property Value

The StringComparisonField that represents a container class.

See Also

PersonalStorageQueryBuilder Class | Aspose.Email.Outlook.Pst Namespace


ContentsCount Property

Aspose.Email

PersonalStorageQueryBuilder.ContentsCount Property

Search folders with an specified contents count.

public IntComparisonField ContentsCount {get;}

See Also

PersonalStorageQueryBuilder Class | Aspose.Email.Outlook.Pst Namespace


FolderName Property

Aspose.Email

PersonalStorageQueryBuilder.FolderName Property

Search folders with an specified display name.

public StringComparisonField FolderName {get;}

See Also

PersonalStorageQueryBuilder Class | Aspose.Email.Outlook.Pst Namespace


Importance Property

Aspose.Email

PersonalStorageQueryBuilder.Importance Property

Search messages with an specified importance.

public IntComparisonField Importance {get;}

See Also

PersonalStorageQueryBuilder Class | Aspose.Email.Outlook.Pst Namespace


MessageClass Property

Aspose.Email

PersonalStorageQueryBuilder.MessageClass Property

Gets messages with an specified message class.

public StringComparisonField MessageClass {get;}

Property Value

The StringComparisonField that represents a message class.

See Also

PersonalStorageQueryBuilder Class | Aspose.Email.Outlook.Pst Namespace


MessageSize Property

Aspose.Email

PersonalStorageQueryBuilder.MessageSize Property

Search messages with an specified size.

public IntComparisonField MessageSize {get;}

See Also

PersonalStorageQueryBuilder Class | Aspose.Email.Outlook.Pst Namespace


UnreadContentsCount Property

Aspose.Email

PersonalStorageQueryBuilder.UnreadContentsCount Property

Search folders with an specified unread contents count.

public IntComparisonField UnreadContentsCount {get;}

See Also

PersonalStorageQueryBuilder Class | Aspose.Email.Outlook.Pst Namespace


PersonalStorageQueryBuilder Methods

The methods of the PersonalStorageQueryBuilder class are listed below. For a complete list of PersonalStorageQueryBuilder class members, see the PersonalStorageQueryBuilder Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetQuery (inherited from MailQueryBuilder) | Gets the query.
GetType (inherited from Object) | Gets the Type of the current instance.
HasFlags | Search messages with the specified flags.
HasNoFlags | Search messages with the unspecified flags.
HasNoSubfolders | Search folders which does not contains subfolders.
HasSubfolders | Search folders which contains subfolders.
Or (inherited from MailQueryBuilder) | Search messages that match either search key. Provides disjunction between two expressions (OR).
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

PersonalStorageQueryBuilder Class | Aspose.Email.Outlook.Pst Namespace


PersonalStorageQueryBuilder.HasFlags Method

Search messages with the specified flags.

public MailQuery HasFlags(
MapiMessageFlags flags
);

Parameters

flags
The flags.

Return Value

MailQuery that represents search query (one searching criteria).

See Also

PersonalStorageQueryBuilder Class | Aspose.Email.Outlook.Pst Namespace


PersonalStorageQueryBuilder.HasNoFlags Method

Search messages with the unspecified flags.

public MailQuery HasNoFlags(
MapiMessageFlags flags
);

Parameters

flags
The flags.

Return Value

MailQuery that represents search query (one searching criteria).

See Also

PersonalStorageQueryBuilder Class | Aspose.Email.Outlook.Pst Namespace


PersonalStorageQueryBuilder.HasNoSubfolders Method

Search folders which does not contains subfolders.

public MailQuery HasNoSubfolders();

Return Value

MailQuery that represents search query (one searching criteria).

See Also

PersonalStorageQueryBuilder Class | Aspose.Email.Outlook.Pst Namespace


PersonalStorageQueryBuilder.HasSubfolders Method

Search folders which contains subfolders.

public MailQuery HasSubfolders();

Return Value

MailQuery that represents search query (one searching criteria).

See Also

PersonalStorageQueryBuilder Class | Aspose.Email.Outlook.Pst Namespace


RestoreOptions Enumeration

Enumerates restore options

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum RestoreOptions

Members

Member Name | Description | Value
None | Indicates that no specific options are specified | 0
Recursive | Indicates that nested folders should be also restored | 1
RemoveNonexistentFolders | Indicates that mail folders, which do not have the equal folders in the personal storage, should be removed | 2
RemoveNonexistentItems | Indicates that mail items, which do not have the equal items in the personal storage, should be removed | 4

Requirements

Namespace: Aspose.Email.Outlook.Pst

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Outlook.Pst Namespace


StandardIpmFolder Enumeration

Represents a standard interpersonal message (IPM) folders.

public enum StandardIpmFolder

Members

Member Name | Description | Value
Inbox | Inbox folder. | 0
DeletedItems | Deleted Items folder. A client application move deleted messages to the Deleted Items folder. | 1
Outbox | Outbox folder. Outbound messages are usually created in the Outbox folder. | 2
SentItems | Sent Items folder. After being sent, messages are usually placed in the Sent Items folder. | 3
Appointments | Outlook Calendar folder. | 4
Contacts | Outlook Contacts folder. | 5
Drafts | Outlook Drafts folder. | 6
Journal | Outlook Journal folder. | 7
Notes | Outlook Notes folder. | 8
Tasks | Outlook Tasks folder. | 9

Requirements

Namespace: Aspose.Email.Outlook.Pst

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Outlook.Pst Namespace


Aspose.Email.Pop3

Aspose.Email

Aspose.Email.Pop3 Namespace

Namespace hierarchy

Classes

Class | Description
Pop3Authentication | Pop3 Authentication method
Pop3Client | Allows applications to access and manipulate messages by using the Post Office Protocol Version 3 (POP3).
Pop3Exception | Represents the exception that is thrown when the Pop3Client is not able to complete an operation.
Pop3MailboxInfo | Represents the status of the mailbox.
Pop3MessageInfo | The Pop3MessageInfo represents the E-Mail message info fetched from the Pop3 server.
Pop3MessageInfoCollection | Represents the information of a mail message from Pop3 server.

Enumerations

Enumeration | Description
Pop3ConnectionState | States of the Pop3 connection
Pop3ListFields | Fields that may be retrieved from the server
Pop3SslSecurityMode | Represents the SSL security mode for ImapClient


Pop3Authentication Class

Pop3 Authentication method

For a list of all members of this type, see Pop3Authentication Members.

System.Object
Aspose.Email.Pop3.Pop3Authentication

public sealed class Pop3Authentication

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Pop3

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Pop3Authentication Members | Aspose.Email.Pop3 Namespace


Pop3Authentication Members

Pop3Authentication overview

Public Static Properties

Auto | Auto detects the authentication methods.
CramMD5Authentication | RFC 2195 CRAM-MD5 authentication
DigestMD5Authentication | RFC 2831 DIGEST-MD5 authentication
PlainTextAuthentication | RFC 2595 TLS plaintext authentication
PlainTextLogin | Login authentication

Public Instance Methods

Equals | Compares object with this.
GetHashCode | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a string that represents the current object.

See Also

Pop3Authentication Class | Aspose.Email.Pop3 Namespace


Pop3Authentication Properties

The properties of the Pop3Authentication class are listed below. For a complete list of Pop3Authentication class members, see the Pop3Authentication Members topic.

Public Static Properties

Auto | Auto detects the authentication methods.
CramMD5Authentication | RFC 2195 CRAM-MD5 authentication
DigestMD5Authentication | RFC 2831 DIGEST-MD5 authentication
PlainTextAuthentication | RFC 2595 TLS plaintext authentication
PlainTextLogin | Login authentication

See Also

Pop3Authentication Class | Aspose.Email.Pop3 Namespace


Auto Property

Aspose.Email

Pop3Authentication.Auto Property

Auto detects the authentication methods.

public static Pop3Authentication Auto {get;}

See Also

Pop3Authentication Class | Aspose.Email.Pop3 Namespace


CramMD5Authentication Property

Aspose.Email

Pop3Authentication.CramMD5Authentication Property

RFC 2195 CRAM-MD5 authentication

public static Pop3Authentication CramMD5Authentication {get;}

See Also

Pop3Authentication Class | Aspose.Email.Pop3 Namespace


DigestMD5Authentication Property

Aspose.Email

Pop3Authentication.DigestMD5Authentication Property

RFC 2831 DIGEST-MD5 authentication

public static Pop3Authentication DigestMD5Authentication {get;}

See Also

Pop3Authentication Class | Aspose.Email.Pop3 Namespace


PlainTextAuthentication Property

Aspose.Email

Pop3Authentication.PlainTextAuthentication Property

RFC 2595 TLS plaintext authentication

public static Pop3Authentication PlainTextAuthentication {get;}

See Also

Pop3Authentication Class | Aspose.Email.Pop3 Namespace


PlainTextLogin Property

Aspose.Email

Pop3Authentication.PlainTextLogin Property

Login authentication

public static Pop3Authentication PlainTextLogin {get;}

See Also

Pop3Authentication Class | Aspose.Email.Pop3 Namespace


Pop3Authentication Methods

The methods of the Pop3Authentication class are listed below. For a complete list of Pop3Authentication class members, see the Pop3Authentication Members topic.

Public Instance Methods

Equals | Compares object with this.
GetHashCode | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a string that represents the current object.

See Also

Pop3Authentication Class | Aspose.Email.Pop3 Namespace


Pop3Authentication.Equals Method

Compares object with this.

public override bool Equals(
object o
);

Parameters

o
Object to compare

Return Value

Returns a boolean indicating if the passed in object obj is Equal to this.

See Also

Pop3Authentication Class | Aspose.Email.Pop3 Namespace


Pop3Authentication.GetHashCode Method

Returns the hash code for this instance.

public override int GetHashCode();

Return Value

The hash code for this instance.

See Also

Pop3Authentication Class | Aspose.Email.Pop3 Namespace


Pop3Authentication.ToString Method

Returns a string that represents the current object.

public override string ToString();

Return Value

A string that represents the current object.

See Also

Pop3Authentication Class | Aspose.Email.Pop3 Namespace


Pop3Client Class

Allows applications to access and manipulate messages by using the Post Office Protocol Version 3 (POP3).

For a list of all members of this type, see Pop3Client Members.

System.Object
Aspose.Email.CredentialsByHostClient
Aspose.Email.Pop3.Pop3Client

public sealed class Pop3Client : CredentialsByHostClient

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Pop3

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Pop3Client Members | Aspose.Email.Pop3 Namespace


Pop3Client Members

Pop3Client overview

Public Instance Constructors

Pop3Client Overloaded. Initializes a new instance of the Pop3Client class.

Public Instance Properties

AccessToken (inherited from CredentialsByHostClient) | Gets or sets the access token.
ConnectionCheckupPeriod (inherited from CredentialsByHostClient) | Period of connection checking up in milliseconds. Default value is 5 min.
ConnectionState | Gets the state of the connection
EnableSsl (inherited from CredentialsByHostClient) | Set to true if we need SSL
Host (inherited from CredentialsByHostClient) | Gets or sets the host name.
Password (inherited from CredentialsByHostClient) | Gets or sets the password.
Port (inherited from CredentialsByHostClient) | Gets or sets the port.
SecurityMode | Gets or sets the security mode
SocksProxy (inherited from CredentialsByHostClient) | Gets or sets SOCKS proxy for the client
Timeout (inherited from CredentialsByHostClient) | Gets or sets the timeout
TokenProvider (inherited from CredentialsByHostClient) | Gets or sets TokenProvider allowing to retrieve access token.
UseAuthentication (inherited from CredentialsByHostClient) | Indicates whether authentication is used.
UseDefaultCredentials (inherited from CredentialsByHostClient) | Gets or sets a Boolean value that controls whether the DefaultCredentials are sent with requests.
Username (inherited from CredentialsByHostClient) | Gets or sets the username.

Public Instance Methods

BeginCancelDeletes | Obsolete. Begins CancelDeletes operation asynchronously
BeginConnect | Overloaded. Begins connect operation asynchronously
BeginDeleteMessage | Overloaded. Begins DeleteMessage operation asynchronously
BeginDisconnect | Obsolete. Begins Disconnect operation asynchronously
BeginFetchMessage | Overloaded. Begins FetchMessage operation asynchronously
BeginGetMailboxSize | Overloaded. Begins GetMailboxSize operation asynchronously
BeginGetMessageCount | Overloaded. Begins GetMessageCount operation asynchronously
BeginListMessage | Overloaded. Begins ListMessage operation asynchronously
BeginListMessages | Overloaded.
BeginLogin | Obsolete. Begins Login operation asynchronously
BeginSaveMessage | Overloaded. Begins SaveMessage operation asynchronously
CancelDeletes | Obsolete. If any messages have been marked as deleted by the POP3 server, they are unmarked.
CheckMessages | Obsolete. Gets the message count
CommitDeletes | Overloaded. Commit the deletions
Connect | Overloaded. Connects to Pop3 server
DeleteAllMessages | Deletes all messages
DeleteMessage | Overloaded. Deletes the message
Disconnect | Disconnects from the POP3 server
Dispose (inherited from CredentialsByHostClient) | Releases unmanaged and - optionally - managed resources
EndCancelDeletes | Obsolete. Ends the cancel deletes.
EndConnect | Obsolete. Waits for the asynchronous operation to complete.
EndDeleteMessage | Waits for the asynchronous operation to complete.
EndDisconnect | Obsolete. Waits for the asynchronous operation to complete.
EndFetchMessage | Waits for the asynchronous operation to complete.
EndGetMailboxSize | Waits for the asynchronous operation to complete.
EndGetMessageCount | Waits for the asynchronous operation to complete.
EndListMessage | Waits for the asynchronous operation to complete.
EndListMessages | Waits for the asynchronous operation to complete.
EndLogin | Obsolete. Waits for the asynchronous operation to complete.
EndSaveMessage | Waits for the asynchronous operation to complete.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FetchMessage | Overloaded. Fetches the message
GetCapabilities (inherited from CredentialsByHostClient) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetMailboxInfo | Gets the mailbox status info
GetMailboxSize | Gets the size of the mailbox
GetMessageCount | Overloaded. Gets the message count
GetMessageHeaders | Gets the message headers
GetMessageSize | Gets the size of the message
GetMessageUniqueId | Gets the message unique id
GetType (inherited from Object) | Gets the Type of the current instance.
KeepAlive | The POP3 server does nothing, it merely replies with a positive response. (Sends NOOP comand)
ListIdentifier | Obsolete. Gets the information (unique-id listing) for that message
ListMessage | Overloaded. Gets the information for that message
ListMessages | Overloaded. Lists the messages. Gets an information for earch message
Login | Overloaded. Authenticates the user to the POP3 server using the USER and PASS command combination
Quit | The POP3 server removes all messages marked as deleted then closes the TCP connection.
Reset | Resets the session to its initial state
SaveMessage | Overloaded. Fetches and save the message as a stream
ToString (inherited from Object) | Returns a String that represents the current Object.
UndeleteMessages | Undeletes the messages. If any messages have been marked as deleted by the POP3 server, they are unmarked.

Public Instance Events

OnConnect (inherited from CredentialsByHostClient) The OnConnect event occurs when the clent establishes connection.

Protected Internal Instance Fields

_accessToken (inherited from CredentialsByHostClient)
_inCall (inherited from CredentialsByHostClient)
_password (inherited from CredentialsByHostClient)
_tokenProvider (inherited from CredentialsByHostClient)
_username (inherited from CredentialsByHostClient)

Protected Internal Instance Properties

InCall (inherited from CredentialsByHostClient)

Protected Internal Instance Methods

CheckCredentials (inherited from CredentialsByHostClient)
Initialize

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


Pop3Client Constructor

Initializes a new instance of the Pop3Client class

Overload List

Initializes a new instance of the Pop3Client class

public Pop3Client();

Initializes a new instance of the Pop3Client class

public Pop3Client(string);

Initializes a new instance of the Pop3Client class

public Pop3Client(string,int);

Initializes a new instance of the Pop3Client class

public Pop3Client(string,int,string,string);

Initializes a new instance of the Pop3Client class

public Pop3Client(string,int,string,string,RemoteCertificateValidationCallback);

Initializes a new instance of the Pop3Client class

public Pop3Client(string,string,string);

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


Pop3Client Constructor ()

Initializes a new instance of the Pop3Client class

public Pop3Client();

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client Constructor Overload List


Pop3Client Constructor (String)

Initializes a new instance of the Pop3Client class

public Pop3Client(
string host
);

Parameters

host
The host name

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client Constructor Overload List


Pop3Client Constructor (String, Int32)

Initializes a new instance of the Pop3Client class

public Pop3Client(
string host,
int port
);

Parameters

host
The host name
port
The port number

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client Constructor Overload List


Pop3Client Constructor (String, String, String)

Initializes a new instance of the Pop3Client class

public Pop3Client(
string host,
string username,
string password
);

Parameters

host
The host name
username
The username
password
The password

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client Constructor Overload List


Pop3Client Constructor (String, Int32, String, String)

Initializes a new instance of the Pop3Client class

public Pop3Client(
string host,
int port,
string username,
string password
);

Parameters

host
The host name
port
The port number
username
The username
password
The password

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client Constructor Overload List


Pop3Client Constructor (String, Int32, String, String, RemoteCertificateValidationCallback)

Initializes a new instance of the Pop3Client class

public Pop3Client(
string host,
int port,
string username,
string password,
RemoteCertificateValidationCallback userCertificateValidationCallback
);

Parameters

host
The host name
port
The port number
username
The username
password
The password
userCertificateValidationCallback
System.Net.Security.RemoteCertificateValidationCallback

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client Constructor Overload List


Pop3Client Properties

The properties of the Pop3Client class are listed below. For a complete list of Pop3Client class members, see the Pop3Client Members topic.

Public Instance Properties

AccessToken (inherited from CredentialsByHostClient) | Gets or sets the access token.
ConnectionCheckupPeriod (inherited from CredentialsByHostClient) | Period of connection checking up in milliseconds. Default value is 5 min.
ConnectionState | Gets the state of the connection
EnableSsl (inherited from CredentialsByHostClient) | Set to true if we need SSL
Host (inherited from CredentialsByHostClient) | Gets or sets the host name.
Password (inherited from CredentialsByHostClient) | Gets or sets the password.
Port (inherited from CredentialsByHostClient) | Gets or sets the port.
SecurityMode | Gets or sets the security mode
SocksProxy (inherited from CredentialsByHostClient) | Gets or sets SOCKS proxy for the client
Timeout (inherited from CredentialsByHostClient) | Gets or sets the timeout
TokenProvider (inherited from CredentialsByHostClient) | Gets or sets TokenProvider allowing to retrieve access token.
UseAuthentication (inherited from CredentialsByHostClient) | Indicates whether authentication is used.
UseDefaultCredentials (inherited from CredentialsByHostClient) | Gets or sets a Boolean value that controls whether the DefaultCredentials are sent with requests.
Username (inherited from CredentialsByHostClient) | Gets or sets the username.

Protected Internal Instance Properties

InCall (inherited from CredentialsByHostClient)

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


ConnectionState Property

Aspose.Email

Pop3Client.ConnectionState Property

Gets the state of the connection

public Pop3ConnectionState ConnectionState {get;}

Property Value

The state of the connection

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


SecurityMode Property

Aspose.Email

Pop3Client.SecurityMode Property

Gets or sets the security mode

public Pop3SslSecurityMode SecurityMode {get; set;}

Property Value

The security mode

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


Pop3Client Methods

The methods of the Pop3Client class are listed below. For a complete list of Pop3Client class members, see the Pop3Client Members topic.

Public Instance Methods

BeginCancelDeletes | Obsolete. Begins CancelDeletes operation asynchronously
BeginConnect | Overloaded. Begins connect operation asynchronously
BeginDeleteMessage | Overloaded. Begins DeleteMessage operation asynchronously
BeginDisconnect | Obsolete. Begins Disconnect operation asynchronously
BeginFetchMessage | Overloaded. Begins FetchMessage operation asynchronously
BeginGetMailboxSize | Overloaded. Begins GetMailboxSize operation asynchronously
BeginGetMessageCount | Overloaded. Begins GetMessageCount operation asynchronously
BeginListMessage | Overloaded. Begins ListMessage operation asynchronously
BeginListMessages | Overloaded.
BeginLogin | Obsolete. Begins Login operation asynchronously
BeginSaveMessage | Overloaded. Begins SaveMessage operation asynchronously
CancelDeletes | Obsolete. If any messages have been marked as deleted by the POP3 server, they are unmarked.
CheckMessages | Obsolete. Gets the message count
CommitDeletes | Overloaded. Commit the deletions
Connect | Overloaded. Connects to Pop3 server
DeleteAllMessages | Deletes all messages
DeleteMessage | Overloaded. Deletes the message
Disconnect | Disconnects from the POP3 server
Dispose (inherited from CredentialsByHostClient) | Releases unmanaged and - optionally - managed resources
EndCancelDeletes | Obsolete. Ends the cancel deletes.
EndConnect | Obsolete. Waits for the asynchronous operation to complete.
EndDeleteMessage | Waits for the asynchronous operation to complete.
EndDisconnect | Obsolete. Waits for the asynchronous operation to complete.
EndFetchMessage | Waits for the asynchronous operation to complete.
EndGetMailboxSize | Waits for the asynchronous operation to complete.
EndGetMessageCount | Waits for the asynchronous operation to complete.
EndListMessage | Waits for the asynchronous operation to complete.
EndListMessages | Waits for the asynchronous operation to complete.
EndLogin | Obsolete. Waits for the asynchronous operation to complete.
EndSaveMessage | Waits for the asynchronous operation to complete.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FetchMessage | Overloaded. Fetches the message
GetCapabilities (inherited from CredentialsByHostClient) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetMailboxInfo | Gets the mailbox status info
GetMailboxSize | Gets the size of the mailbox
GetMessageCount | Overloaded. Gets the message count
GetMessageHeaders | Gets the message headers
GetMessageSize | Gets the size of the message
GetMessageUniqueId | Gets the message unique id
GetType (inherited from Object) | Gets the Type of the current instance.
KeepAlive | The POP3 server does nothing, it merely replies with a positive response. (Sends NOOP comand)
ListIdentifier | Obsolete. Gets the information (unique-id listing) for that message
ListMessage | Overloaded. Gets the information for that message
ListMessages | Overloaded. Lists the messages. Gets an information for earch message
Login | Overloaded. Authenticates the user to the POP3 server using the USER and PASS command combination
Quit | The POP3 server removes all messages marked as deleted then closes the TCP connection.
Reset | Resets the session to its initial state
SaveMessage | Overloaded. Fetches and save the message as a stream
ToString (inherited from Object) | Returns a String that represents the current Object.
UndeleteMessages | Undeletes the messages. If any messages have been marked as deleted by the POP3 server, they are unmarked.

Protected Internal Instance Methods

CheckCredentials (inherited from CredentialsByHostClient)
Initialize

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


Pop3Client.BeginCancelDeletes Method

NOTE: This method is now obsolete.

This method is obsolete, please don't use it anymore.

Begins CancelDeletes operation asynchronously

public IAsyncResult BeginCancelDeletes(
AsyncCallback callback,
object state
);

Parameters

callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


BeginConnect Method

Aspose.Email

Pop3Client.BeginConnect Method

NOTE: This method is now obsolete.

This method is obsolete, please don't use it anymore.

Begins connect operation asynchronously

Overload List

Obsolete. Begins connect operation asynchronously

public IAsyncResult BeginConnect(AsyncCallback,object);

Obsolete. Begins connect operation asynchronously

public IAsyncResult BeginConnect(bool,AsyncCallback,object);

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


Pop3Client.BeginConnect Method (AsyncCallback, Object)

NOTE: This method is now obsolete.

This method is obsolete, please don't use it anymore.

Begins connect operation asynchronously

public IAsyncResult BeginConnect(
AsyncCallback callback,
object state
);

Parameters

callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client.BeginConnect Overload List


Pop3Client.BeginConnect Method (Boolean, AsyncCallback, Object)

NOTE: This method is now obsolete.

This method is obsolete, please don't use it anymore.

Begins connect operation asynchronously

public IAsyncResult BeginConnect(
bool autoLogin,
AsyncCallback callback,
object state
);

Parameters

autoLogin
Sets whether or not the user wants to automatically login
callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client.BeginConnect Overload List


BeginDeleteMessage Method

Aspose.Email

Pop3Client.BeginDeleteMessage Method

NOTE: This method is now obsolete.

Begins DeleteMessage operation asynchronously

Overload List

Obsolete. Begins DeleteMessage operation asynchronously

public IAsyncResult BeginDeleteMessage(int);

Obsolete. Begins DeleteMessage operation asynchronously

public IAsyncResult BeginDeleteMessage(int,AsyncCallback,object);

Begins DeleteMessage operation asynchronously

public IAsyncResult BeginDeleteMessage(string);

Begins DeleteMessage operation asynchronously

public IAsyncResult BeginDeleteMessage(string,AsyncCallback,object);

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


Pop3Client.BeginDeleteMessage Method (Int32)

NOTE: This method is now obsolete.

Begins DeleteMessage operation asynchronously

public IAsyncResult BeginDeleteMessage(
int sequenceNumber
);

Parameters

sequenceNumber
The sequence number of the message

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client.BeginDeleteMessage Overload List


Pop3Client.BeginDeleteMessage Method (Int32, AsyncCallback, Object)

NOTE: This method is now obsolete.

Begins DeleteMessage operation asynchronously

public IAsyncResult BeginDeleteMessage(
int sequenceNumber,
AsyncCallback callback,
object state
);

Parameters

sequenceNumber
The sequence number of the message
callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client.BeginDeleteMessage Overload List


Pop3Client.BeginDeleteMessage Method (String)

Begins DeleteMessage operation asynchronously

public IAsyncResult BeginDeleteMessage(
string uniqueId
);

Parameters

uniqueId
The unique id of the message

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client.BeginDeleteMessage Overload List


Pop3Client.BeginDeleteMessage Method (String, AsyncCallback, Object)

Begins DeleteMessage operation asynchronously

public IAsyncResult BeginDeleteMessage(
string uniqueId,
AsyncCallback callback,
object state
);

Parameters

uniqueId
The unique id of the message
callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client.BeginDeleteMessage Overload List


Pop3Client.BeginDisconnect Method

NOTE: This method is now obsolete.

This method is obsolete, please don't use it anymore.

Begins Disconnect operation asynchronously

public IAsyncResult BeginDisconnect(
AsyncCallback callback,
object state
);

Parameters

callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


BeginFetchMessage Method

Aspose.Email

Pop3Client.BeginFetchMessage Method

Begins FetchMessage operation asynchronously

Overload List

Begins FetchMessage operation asynchronously

public IAsyncResult BeginFetchMessage(int);

Begins FetchMessage operation asynchronously

public IAsyncResult BeginFetchMessage(int,AsyncCallback,object);

Begins FetchMessage operation asynchronously

public IAsyncResult BeginFetchMessage(string);

Begins FetchMessage operation asynchronously

public IAsyncResult BeginFetchMessage(string,AsyncCallback,object);

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


Pop3Client.BeginFetchMessage Method (Int32)

Begins FetchMessage operation asynchronously

public IAsyncResult BeginFetchMessage(
int sequenceNumber
);

Parameters

sequenceNumber
The sequence number of the message

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client.BeginFetchMessage Overload List


Pop3Client.BeginFetchMessage Method (Int32, AsyncCallback, Object)

Begins FetchMessage operation asynchronously

public IAsyncResult BeginFetchMessage(
int sequenceNumber,
AsyncCallback callback,
object state
);

Parameters

sequenceNumber
The sequence number of the message
callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client.BeginFetchMessage Overload List


Pop3Client.BeginFetchMessage Method (String)

Begins FetchMessage operation asynchronously

public IAsyncResult BeginFetchMessage(
string uniqueId
);

Parameters

uniqueId
The unique id of the message

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client.BeginFetchMessage Overload List


Pop3Client.BeginFetchMessage Method (String, AsyncCallback, Object)

Begins FetchMessage operation asynchronously

public IAsyncResult BeginFetchMessage(
string uniqueId,
AsyncCallback callback,
object state
);

Parameters

uniqueId
The unique id of the message
callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client.BeginFetchMessage Overload List


BeginGetMailboxSize Method

Aspose.Email

Pop3Client.BeginGetMailboxSize Method

Begins GetMailboxSize operation asynchronously

Overload List

Begins GetMailboxSize operation asynchronously

public IAsyncResult BeginGetMailboxSize();

Begins GetMailboxSize operation asynchronously

public IAsyncResult BeginGetMailboxSize(AsyncCallback,object);

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


Pop3Client.BeginGetMailboxSize Method ()

Begins GetMailboxSize operation asynchronously

public IAsyncResult BeginGetMailboxSize();

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client.BeginGetMailboxSize Overload List


Pop3Client.BeginGetMailboxSize Method (AsyncCallback, Object)

Begins GetMailboxSize operation asynchronously

public IAsyncResult BeginGetMailboxSize(
AsyncCallback callback,
object state
);

Parameters

callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client.BeginGetMailboxSize Overload List


BeginGetMessageCount Method

Aspose.Email

Pop3Client.BeginGetMessageCount Method

Begins GetMessageCount operation asynchronously

Overload List

Begins GetMessageCount operation asynchronously

public IAsyncResult BeginGetMessageCount();

Begins GetMessageCount operation asynchronously

public IAsyncResult BeginGetMessageCount(AsyncCallback,object);

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


Pop3Client.BeginGetMessageCount Method ()

Begins GetMessageCount operation asynchronously

public IAsyncResult BeginGetMessageCount();

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client.BeginGetMessageCount Overload List


Pop3Client.BeginGetMessageCount Method (AsyncCallback, Object)

Begins GetMessageCount operation asynchronously

public IAsyncResult BeginGetMessageCount(
AsyncCallback callback,
object state
);

Parameters

callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client.BeginGetMessageCount Overload List


BeginListMessage Method

Aspose.Email

Pop3Client.BeginListMessage Method

Begins ListMessage operation asynchronously

Overload List

Begins ListMessage operation asynchronously

public IAsyncResult BeginListMessage(int);

Begins ListMessage operation asynchronously

public IAsyncResult BeginListMessage(int,AsyncCallback,object);

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


Pop3Client.BeginListMessage Method (Int32)

Begins ListMessage operation asynchronously

public IAsyncResult BeginListMessage(
int sequenceNumber
);

Parameters

sequenceNumber
The sequence number of the message

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client.BeginListMessage Overload List


Pop3Client.BeginListMessage Method (Int32, AsyncCallback, Object)

Begins ListMessage operation asynchronously

public IAsyncResult BeginListMessage(
int sequenceNumber,
AsyncCallback callback,
object state
);

Parameters

sequenceNumber
The sequence number of the message
callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client.BeginListMessage Overload List


BeginListMessages Method

Aspose.Email

Pop3Client.BeginListMessages Method

Begins ListMessages operation asynchronously

Overload List

Begins ListMessages operation asynchronously

public IAsyncResult BeginListMessages();

public IAsyncResult BeginListMessages(MailQuery);

public IAsyncResult BeginListMessages(MailQuery,AsyncCallback,object);

Begins ListMessages operation asynchronously

public IAsyncResult BeginListMessages(AsyncCallback,object);

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


Pop3Client.BeginListMessages Method ()

Begins ListMessages operation asynchronously

public IAsyncResult BeginListMessages();

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client.BeginListMessages Overload List


Pop3Client.BeginListMessages Method (MailQuery)

public IAsyncResult BeginListMessages(
MailQuery query
);

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client.BeginListMessages Overload List


Pop3Client.BeginListMessages Method (MailQuery, AsyncCallback, Object)

public IAsyncResult BeginListMessages(
MailQuery query,
AsyncCallback callback,
object state
);

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client.BeginListMessages Overload List


Pop3Client.BeginListMessages Method (AsyncCallback, Object)

Begins ListMessages operation asynchronously

public IAsyncResult BeginListMessages(
AsyncCallback callback,
object state
);

Parameters

callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client.BeginListMessages Overload List


Pop3Client.BeginLogin Method

NOTE: This method is now obsolete.

This method is obsolete, please don't use it anymore.

Begins Login operation asynchronously

public IAsyncResult BeginLogin(
AsyncCallback callback,
object state
);

Parameters

callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


BeginSaveMessage Method

Aspose.Email

Pop3Client.BeginSaveMessage Method

Begins SaveMessage operation asynchronously

Overload List

Begins SaveMessage operation asynchronously

public IAsyncResult BeginSaveMessage(int,Stream);

Begins SaveMessage operation asynchronously

public IAsyncResult BeginSaveMessage(int,Stream,AsyncCallback,object);

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


Pop3Client.BeginSaveMessage Method (Int32, Stream)

Begins SaveMessage operation asynchronously

public IAsyncResult BeginSaveMessage(
int sequenceNumber,
Stream output
);

Parameters

sequenceNumber
The sequence number of the message
output
Stream into which message is saved

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client.BeginSaveMessage Overload List


Pop3Client.BeginSaveMessage Method (Int32, Stream, AsyncCallback, Object)

Begins SaveMessage operation asynchronously

public IAsyncResult BeginSaveMessage(
int sequenceNumber,
Stream output,
AsyncCallback callback,
object state
);

Parameters

sequenceNumber
The sequence number of the message
output
Stream into which message is saved
callback
References a method to be called when a corresponding asynchronous operation completes.
state
The state.

Return Value

IAsyncResult that represents the status of an asynchronous operation.

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client.BeginSaveMessage Overload List


Pop3Client.CancelDeletes Method

NOTE: This method is now obsolete.

Use UndeleteMessages instead.

If any messages have been marked as deleted by the POP3 server, they are unmarked.

public void CancelDeletes();

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


Pop3Client.CheckMessages Method

NOTE: This method is now obsolete.

Use GetMessageCount method instead.

Gets the message count

public int CheckMessages();

Return Value

message count

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


CommitDeletes Method

Aspose.Email

Pop3Client.CommitDeletes Method

Commit the deletions

Overload List

Commit the deletions

public void CommitDeletes();

Commit the deletions

public void CommitDeletes(int);

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


Pop3Client.CommitDeletes Method ()

Commit the deletions

public void CommitDeletes();

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client.CommitDeletes Overload List


Pop3Client.CommitDeletes Method (Int32)

Commit the deletions

public void CommitDeletes(
int sleep
);

Parameters

sleep
Timeout in milliseconds

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client.CommitDeletes Overload List


Connect Method

Aspose.Email

Pop3Client.Connect Method

NOTE: This method is now obsolete.

Connect and Login methods are obsolete, please don't use them anymore.

Connects to Pop3 server

Overload List

Obsolete. Connects to Pop3 server

public void Connect();

Obsolete. Connects to Pop3 server

public void Connect(bool);

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


Pop3Client.Connect Method ()

NOTE: This method is now obsolete.

Connect and Login methods are obsolete, please don't use them anymore.

Connects to Pop3 server

public void Connect();

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client.Connect Overload List


Pop3Client.Connect Method (Boolean)

NOTE: This method is now obsolete.

Connect and Login methods are obsolete, please don't use them anymore.

Connects to Pop3 server

public void Connect(
bool autologin
);

Parameters

autologin
Sets whether or not the user wants to automatically login

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client.Connect Overload List


Pop3Client.DeleteAllMessages Method

Deletes all messages

public void DeleteAllMessages();

Remarks

The POP3 server marks the message as deleted. The POP3 server does not actually delete the message until the POP3 session enters the UPDATE state.

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


DeleteMessage Method

Aspose.Email

Pop3Client.DeleteMessage Method

Deletes the message

Overload List

Deletes the message

public void DeleteMessage(int);

Deletes the message

public void DeleteMessage(string);

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


Pop3Client.DeleteMessage Method (Int32)

Deletes the message

public void DeleteMessage(
int sequenceNumber
);

Parameters

sequenceNumber
The sequence number of the message

Remarks

The POP3 server marks the message as deleted. The POP3 server does not actually delete the message until the POP3 session enters the UPDATE state.

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client.DeleteMessage Overload List


Pop3Client.DeleteMessage Method (String)

Deletes the message

public void DeleteMessage(
string uniqueId
);

Parameters

uniqueId
The unique id of the message

Remarks

The POP3 server marks the message as deleted. The POP3 server does not actually delete the message until the POP3 session enters the UPDATE state.

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client.DeleteMessage Overload List


Pop3Client.Disconnect Method

Disconnects from the POP3 server

public void Disconnect();

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


Pop3Client.EndCancelDeletes Method

NOTE: This method is now obsolete.

This method is obsolete, please don't use it anymore.

Ends the cancel deletes.

public void EndCancelDeletes(
IAsyncResult asyncResult
);

Parameters

asyncResult
The async result.

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


Pop3Client.EndConnect Method

NOTE: This method is now obsolete.

This method is obsolete, please don't use it anymore.

Waits for the asynchronous operation to complete.

public void EndConnect(
IAsyncResult asyncResult
);

Parameters

asyncResult
The reference to the pending asynchronous request to wait for.

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


Pop3Client.EndDeleteMessage Method

Waits for the asynchronous operation to complete.

public void EndDeleteMessage(
IAsyncResult asyncResult
);

Parameters

asyncResult
The reference to the pending asynchronous request to wait for.

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


Pop3Client.EndDisconnect Method

NOTE: This method is now obsolete.

This method is obsolete, please don't use it anymore.

Waits for the asynchronous operation to complete.

public void EndDisconnect(
IAsyncResult asyncResult
);

Parameters

asyncResult
The reference to the pending asynchronous request to wait for.

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


Pop3Client.EndFetchMessage Method

Waits for the asynchronous operation to complete.

public MailMessage EndFetchMessage(
IAsyncResult asyncResult
);

Parameters

asyncResult
The reference to the pending asynchronous request to wait for.

Return Value

MailMessage that represents e-mail message

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


Pop3Client.EndGetMailboxSize Method

Waits for the asynchronous operation to complete.

public long EndGetMailboxSize(
IAsyncResult asyncResult
);

Parameters

asyncResult
The reference to the pending asynchronous request to wait for.

Return Value

size of the mailbox in bytes

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


Pop3Client.EndGetMessageCount Method

Waits for the asynchronous operation to complete.

public int EndGetMessageCount(
IAsyncResult asyncResult
);

Parameters

asyncResult
The reference to the pending asynchronous request to wait for.

Return Value

message count

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


Pop3Client.EndListMessage Method

Waits for the asynchronous operation to complete.

public Pop3MessageInfo EndListMessage(
IAsyncResult asyncResult
);

Parameters

asyncResult
The reference to the pending asynchronous request to wait for.

Return Value

Returns E-Mail message info fetched from the Pop3 server.

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


Pop3Client.EndListMessages Method

Waits for the asynchronous operation to complete.

public Pop3MessageInfoCollection EndListMessages(
IAsyncResult asyncResult
);

Parameters

asyncResult
The reference to the pending asynchronous request to wait for.

Return Value

Returns collection of Pop3MessageInfo

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


Pop3Client.EndLogin Method

NOTE: This method is now obsolete.

This method is obsolete, please don't use it anymore.

Waits for the asynchronous operation to complete.

public void EndLogin(
IAsyncResult asyncResult
);

Parameters

asyncResult
The reference to the pending asynchronous request to wait for.

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


Pop3Client.EndSaveMessage Method

Waits for the asynchronous operation to complete.

public void EndSaveMessage(
IAsyncResult asyncResult
);

Parameters

asyncResult
The reference to the pending asynchronous request to wait for.

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


FetchMessage Method

Aspose.Email

Pop3Client.FetchMessage Method

Fetches the message

Overload List

Fetches the message

public MailMessage FetchMessage(int);

Fetches the message

public MailMessage FetchMessage(string);

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


Pop3Client.FetchMessage Method (Int32)

Fetches the message

public MailMessage FetchMessage(
int sequenceNumber
);

Parameters

sequenceNumber
The sequence number of the message

Return Value

MailMessage that represents e-mail message

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client.FetchMessage Overload List


Pop3Client.FetchMessage Method (String)

Fetches the message

public MailMessage FetchMessage(
string uniqueId
);

Parameters

uniqueId
The unique id of the message

Return Value

MailMessage that represents e-mail message

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client.FetchMessage Overload List


Pop3Client.GetMailboxInfo Method

Gets the mailbox status info

public Pop3MailboxInfo GetMailboxInfo();

Return Value

Pop3MailboxInfo

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


Pop3Client.GetMailboxSize Method

Gets the size of the mailbox

public long GetMailboxSize();

Return Value

size of the mailbox in bytes

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


GetMessageCount Method

Aspose.Email

Pop3Client.GetMessageCount Method

Gets the message count

Overload List

Gets the message count

public int GetMessageCount();

Gets the message count

public int GetMessageCount(bool);

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


Pop3Client.GetMessageCount Method ()

Gets the message count

public int GetMessageCount();

Return Value

message count

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client.GetMessageCount Overload List


Pop3Client.GetMessageCount Method (Boolean)

Gets the message count

public int GetMessageCount(
bool closeTransaction
);

Parameters

closeTransaction
Indicates if current transaction has to be closed, before the list is retrieved.

Return Value

message count

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client.GetMessageCount Overload List


Pop3Client.GetMessageHeaders Method

Gets the message headers

public HeaderCollection GetMessageHeaders(
int sequenceNumber
);

Parameters

sequenceNumber
The sequence number of the message

Return Value

HeaderCollection that represents collection of the headers

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


Pop3Client.GetMessageSize Method

Gets the size of the message

public long GetMessageSize(
int sequenceNumber
);

Parameters

sequenceNumber
The sequence number of the message

Return Value

size of the message in bytes

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


Pop3Client.GetMessageUniqueId Method

Gets the message unique id

public string GetMessageUniqueId(
int sequenceNumber
);

Parameters

sequenceNumber
The sequence number of the message

Return Value

String that represents uid of the message

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


Pop3Client.Initialize Method

protected internal override void Initialize();

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


Pop3Client.KeepAlive Method

The POP3 server does nothing, it merely replies with a positive response. (Sends NOOP comand)

public void KeepAlive();

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


Pop3Client.ListIdentifier Method

NOTE: This method is now obsolete.

Use GetMessageUniqueId instead.

Gets the information (unique-id listing) for that message

public Pop3MessageInfo ListIdentifier(
int sequenceNumber
);

Parameters

sequenceNumber
The message sequence number

Return Value

Pop3MessageInfo

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


ListMessage Method

Aspose.Email

Pop3Client.ListMessage Method

Gets the information for that message

Overload List

Gets the information for that message

public Pop3MessageInfo ListMessage(int);

Gets the information for that message

public Pop3MessageInfo ListMessage(int,Pop3ListFields);

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


Pop3Client.ListMessage Method (Int32)

Gets the information for that message

public Pop3MessageInfo ListMessage(
int sequenceNumber
);

Parameters

sequenceNumber
The sequence number of the message

Return Value

Pop3MessageInfo

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client.ListMessage Overload List


Pop3Client.ListMessage Method (Int32, Pop3ListFields)

Gets the information for that message

public Pop3MessageInfo ListMessage(
int sequenceNumber,
Pop3ListFields fields
);

Parameters

sequenceNumber
The sequence number of the message
fields
The fields that we want get

Return Value

Pop3MessageInfo

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client.ListMessage Overload List


ListMessages Method

Aspose.Email

Pop3Client.ListMessages Method

Lists the messages. Gets an information for earch message

Overload List

Lists the messages. Gets an information for earch message

public Pop3MessageInfoCollection ListMessages();

Lists the messages.

public Pop3MessageInfoCollection ListMessages(MailQuery);

Lists the messages.

public Pop3MessageInfoCollection ListMessages(Pop3ListFields);

Lists the messages. Gets an information for earch message

public Pop3MessageInfoCollection ListMessages(bool);

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


Pop3Client.ListMessages Method ()

Lists the messages. Gets an information for earch message

public Pop3MessageInfoCollection ListMessages();

Return Value

Pop3MessageInfoCollection

Remarks

Note that messages marked as deleted are not listed

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client.ListMessages Overload List


Pop3Client.ListMessages Method (MailQuery)

Lists the messages.

public Pop3MessageInfoCollection ListMessages(
MailQuery query
);

Parameters

query
MailQuery that represents search query.

Return Value

Collection of Pop3MessageInfo objects.

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client.ListMessages Overload List


Pop3Client.ListMessages Method (Pop3ListFields)

Lists the messages.

public Pop3MessageInfoCollection ListMessages(
Pop3ListFields fields
);

Parameters

fields
The fields that we want get

Return Value

Pop3MessageInfoCollection

Remarks

Note that messages marked as deleted are not listed

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client.ListMessages Overload List


Pop3Client.ListMessages Method (Boolean)

Lists the messages. Gets an information for earch message

public Pop3MessageInfoCollection ListMessages(
bool closeTransaction
);

Parameters

closeTransaction
Indicates if current transaction has to be closed, before the list is retrieved.

Return Value

Pop3MessageInfoCollection

Remarks

Note that messages marked as deleted are not listed

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client.ListMessages Overload List


Login Method

Aspose.Email

Pop3Client.Login Method

NOTE: This method is now obsolete.

Connect and Login methods are obsolete, please don't use them anymore.

Authenticates the user to the POP3 server using the USER and PASS command combination

Overload List

Obsolete. Authenticates the user to the POP3 server using the USER and PASS command combination

public void Login();

Obsolete. Authenticates the user to the POP3 server using the USER and PASS command combination

public void Login(Pop3Authentication);

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


Pop3Client.Login Method ()

NOTE: This method is now obsolete.

Connect and Login methods are obsolete, please don't use them anymore.

Authenticates the user to the POP3 server using the USER and PASS command combination

public void Login();

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client.Login Overload List


Pop3Client.Login Method (Pop3Authentication)

NOTE: This method is now obsolete.

Connect and Login methods are obsolete, please don't use them anymore.

Authenticates the user to the POP3 server using the USER and PASS command combination

public void Login(
Pop3Authentication authentication
);

Parameters

authentication
Pop3Authentication

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client.Login Overload List


Pop3Client.Quit Method

The POP3 server removes all messages marked as deleted then closes the TCP connection.

public void Quit();

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


Pop3Client.Reset Method

Resets the session to its initial state

public void Reset();

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


SaveMessage Method

Aspose.Email

Pop3Client.SaveMessage Method

Fetches and save the message as a stream

Overload List

Fetches and save the message as a stream

public void SaveMessage(int,Stream);

Fetches and save the message into a file

public void SaveMessage(int,string);

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


Pop3Client.SaveMessage Method (Int32, Stream)

Fetches and save the message as a stream

public void SaveMessage(
int sequenceNumber,
Stream output
);

Parameters

sequenceNumber
The sequence number of the message
output
Stream into which message is saved

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client.SaveMessage Overload List


Pop3Client.SaveMessage Method (Int32, String)

Fetches and save the message into a file

public void SaveMessage(
int sequenceNumber,
string fileName
);

Parameters

sequenceNumber
The sequence number of the message
fileName
File name for message

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace | Pop3Client.SaveMessage Overload List


Pop3Client.UndeleteMessages Method

Undeletes the messages. If any messages have been marked as deleted by the POP3 server, they are unmarked.

public void UndeleteMessages();

See Also

Pop3Client Class | Aspose.Email.Pop3 Namespace


Pop3ConnectionState Enumeration

States of the Pop3 connection

public enum Pop3ConnectionState

Members

Member Name | Description | Value
Authentication | Authentication state | 0
Transaction | Transaction state | 1
Update | Update state | 2

Requirements

Namespace: Aspose.Email.Pop3

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Pop3 Namespace


Pop3Exception Class

Represents the exception that is thrown when the Pop3Client is not able to complete an operation.

For a list of all members of this type, see Pop3Exception Members.

System.Object
System.Exception
Aspose.Email.Pop3.Pop3Exception

public class Pop3Exception : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Pop3

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Pop3Exception Members | Aspose.Email.Pop3 Namespace


Pop3Exception Members

Pop3Exception overview

Public Instance Constructors

Pop3Exception Overloaded. Initializes a new instance of the Pop3Exception class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | Gets the object data.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Constructors

Pop3Exception Overloaded. Initializes a new instance of the Pop3Exception class.

Protected Instance Properties

HResult (inherited from Exception) Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Pop3Exception Class | Aspose.Email.Pop3 Namespace


Pop3Exception Constructor

Initializes a new instance of the Pop3Exception class.

Overload List

Initializes a new instance of the Pop3Exception class.

public Pop3Exception();

protected Pop3Exception(SerializationInfo,StreamingContext);

Initializes a new instance of the Pop3Exception class.

public Pop3Exception(string);

Initializes a new instance of the Pop3Exception class.

public Pop3Exception(string,Exception);

See Also

Pop3Exception Class | Aspose.Email.Pop3 Namespace


Pop3Exception Constructor ()

Initializes a new instance of the Pop3Exception class.

public Pop3Exception();

See Also

Pop3Exception Class | Aspose.Email.Pop3 Namespace | Pop3Exception Constructor Overload List


Pop3Exception Constructor (String)

Initializes a new instance of the Pop3Exception class.

public Pop3Exception(
string message
);

Parameters

message
The error message.

See Also

Pop3Exception Class | Aspose.Email.Pop3 Namespace | Pop3Exception Constructor Overload List


Pop3Exception Constructor (String, Exception)

Initializes a new instance of the Pop3Exception class.

public Pop3Exception(
string message,
Exception innerException
);

Parameters

message
The error message.
innerException
The inner exception.

See Also

Pop3Exception Class | Aspose.Email.Pop3 Namespace | Pop3Exception Constructor Overload List


Pop3Exception Constructor (SerializationInfo, StreamingContext)

protected Pop3Exception(
SerializationInfo serializationInfo,
StreamingContext streamingContext
);

See Also

Pop3Exception Class | Aspose.Email.Pop3 Namespace | Pop3Exception Constructor Overload List


Pop3Exception Methods

The methods of the Pop3Exception class are listed below. For a complete list of Pop3Exception class members, see the Pop3Exception Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | Gets the object data.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Pop3Exception Class | Aspose.Email.Pop3 Namespace


Pop3Exception.GetObjectData Method

Gets the object data.

public override void GetObjectData(
SerializationInfo serializationInfo,
StreamingContext streamingContext
);

Parameters

serializationInfo
The serialization info.
streamingContext
The streaming context.

See Also

Pop3Exception Class | Aspose.Email.Pop3 Namespace


Pop3ListFields Enumeration

Fields that may be retrieved from the server

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum Pop3ListFields

Members

Member Name | Description | Value
UniqueId | Unique Id | 1
SequenceNumber | Sequence Number | 2
Size | Size | 4
Header | Header | 8

Requirements

Namespace: Aspose.Email.Pop3

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Pop3 Namespace


Pop3MailboxInfo Class

Represents the status of the mailbox.

For a list of all members of this type, see Pop3MailboxInfo Members.

System.Object
Aspose.Email.Pop3.Pop3MailboxInfo

public class Pop3MailboxInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Pop3

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Pop3MailboxInfo Members | Aspose.Email.Pop3 Namespace


Pop3MailboxInfo Members

Pop3MailboxInfo overview

Public Instance Constructors

Pop3MailboxInfo Constructor Initializes a new instance of the Pop3MailboxInfo class.

Public Instance Properties

MessageCount | Gets the count of messages in the mailbox.
OccupiedSize | Gets the occupied size of the mailbox.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents this instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Pop3MailboxInfo Class | Aspose.Email.Pop3 Namespace


Pop3MailboxInfo Constructor

Initializes a new instance of the Pop3MailboxInfo class.

public Pop3MailboxInfo(
int count,
long size
);

Parameters

count
The message count.
size
The occupied size.

See Also

Pop3MailboxInfo Class | Aspose.Email.Pop3 Namespace


Pop3MailboxInfo Properties

The properties of the Pop3MailboxInfo class are listed below. For a complete list of Pop3MailboxInfo class members, see the Pop3MailboxInfo Members topic.

Public Instance Properties

MessageCount | Gets the count of messages in the mailbox.
OccupiedSize | Gets the occupied size of the mailbox.

See Also

Pop3MailboxInfo Class | Aspose.Email.Pop3 Namespace


MessageCount Property

Aspose.Email

Pop3MailboxInfo.MessageCount Property

Gets the count of messages in the mailbox.

public int MessageCount {get;}

Property Value

The message count.

See Also

Pop3MailboxInfo Class | Aspose.Email.Pop3 Namespace


OccupiedSize Property

Aspose.Email

Pop3MailboxInfo.OccupiedSize Property

Gets the occupied size of the mailbox.

public long OccupiedSize {get;}

Property Value

The occupied size.

See Also

Pop3MailboxInfo Class | Aspose.Email.Pop3 Namespace


Pop3MailboxInfo Methods

The methods of the Pop3MailboxInfo class are listed below. For a complete list of Pop3MailboxInfo class members, see the Pop3MailboxInfo Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String that represents this instance.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Pop3MailboxInfo Class | Aspose.Email.Pop3 Namespace


Pop3MailboxInfo.ToString Method

Returns a String that represents this instance.

public override string ToString();

Return Value

A String that represents this instance.

See Also

Pop3MailboxInfo Class | Aspose.Email.Pop3 Namespace


Pop3MessageInfo Class

The Pop3MessageInfo represents the E-Mail message info fetched from the Pop3 server.

For a list of all members of this type, see Pop3MessageInfo Members.

System.Object
Aspose.Email.Pop3.Pop3MessageInfo

public sealed class Pop3MessageInfo : IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Pop3

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Pop3MessageInfo Members | Aspose.Email.Pop3 Namespace


Pop3MessageInfo Members

Pop3MessageInfo overview

Public Instance Properties

CC | Gets CC of the E-Mail message.
Date | Gets Date of the E-Mail message.
From | Gets the From property.
Headers | Gets the Headers of the E-Mail message.
Identifier | Obsolete. Gets the Unique Id of the E-Mail message.
Number | Obsolete. Gets the Sequence Number of the E-Mail message.
ReplyTo | Gets the ReplyTo of the E-Mail message.
Sender | Gets the Sender of the E-Mail message.
SequenceNumber | Gets the Sequence Number of the E-Mail message.
Size | Gets the size of the E-Mail message.
Subject | Gets the Subject of the E-Mail message.
To | Gets the receiptants of the E-Mail message.
UniqueId | Gets the Unique Id of the E-Mail message.

Public Instance Methods

Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a string that represents the current object.

See Also

Pop3MessageInfo Class | Aspose.Email.Pop3 Namespace


Pop3MessageInfo Properties

The properties of the Pop3MessageInfo class are listed below. For a complete list of Pop3MessageInfo class members, see the Pop3MessageInfo Members topic.

Public Instance Properties

CC | Gets CC of the E-Mail message.
Date | Gets Date of the E-Mail message.
From | Gets the From property.
Headers | Gets the Headers of the E-Mail message.
Identifier | Obsolete. Gets the Unique Id of the E-Mail message.
Number | Obsolete. Gets the Sequence Number of the E-Mail message.
ReplyTo | Gets the ReplyTo of the E-Mail message.
Sender | Gets the Sender of the E-Mail message.
SequenceNumber | Gets the Sequence Number of the E-Mail message.
Size | Gets the size of the E-Mail message.
Subject | Gets the Subject of the E-Mail message.
To | Gets the receiptants of the E-Mail message.
UniqueId | Gets the Unique Id of the E-Mail message.

See Also

Pop3MessageInfo Class | Aspose.Email.Pop3 Namespace


CC Property

Aspose.Email

Pop3MessageInfo.CC Property

Gets CC of the E-Mail message.

public MailAddressCollection CC {get;}

Property Value

The cc field of the E-Mail message.

See Also

Pop3MessageInfo Class | Aspose.Email.Pop3 Namespace


Date Property

Aspose.Email

Pop3MessageInfo.Date Property

Gets Date of the E-Mail message.

public DateTime Date {get;}

Property Value

The date of the E-Mail message.

See Also

Pop3MessageInfo Class | Aspose.Email.Pop3 Namespace


From Property

Aspose.Email

Pop3MessageInfo.From Property

Gets the From property.

public MailAddressCollection From {get;}

Property Value

The from field.

See Also

Pop3MessageInfo Class | Aspose.Email.Pop3 Namespace


Headers Property

Aspose.Email

Pop3MessageInfo.Headers Property

Gets the Headers of the E-Mail message.

public HeaderCollection Headers {get;}

Property Value

The headers.

See Also

Pop3MessageInfo Class | Aspose.Email.Pop3 Namespace


Identifier Property

Aspose.Email

Pop3MessageInfo.Identifier Property

NOTE: This property is now obsolete.

Use UniqueId property instead.

Gets the Unique Id of the E-Mail message.

public string Identifier {get;}

Property Value

The identifier.

See Also

Pop3MessageInfo Class | Aspose.Email.Pop3 Namespace


Number Property

Aspose.Email

Pop3MessageInfo.Number Property

NOTE: This property is now obsolete.

Use SequenceNumber property instead.

Gets the Sequence Number of the E-Mail message.

public int Number {get;}

Property Value

The sequence number.

See Also

Pop3MessageInfo Class | Aspose.Email.Pop3 Namespace


ReplyTo Property

Aspose.Email

Pop3MessageInfo.ReplyTo Property

Gets the ReplyTo of the E-Mail message.

public MailAddressCollection ReplyTo {get;}

Property Value

The reply to.

See Also

Pop3MessageInfo Class | Aspose.Email.Pop3 Namespace


Sender Property

Aspose.Email

Pop3MessageInfo.Sender Property

Gets the Sender of the E-Mail message.

public MailAddress Sender {get;}

Property Value

The sender.

See Also

Pop3MessageInfo Class | Aspose.Email.Pop3 Namespace


SequenceNumber Property

Aspose.Email

Pop3MessageInfo.SequenceNumber Property

Gets the Sequence Number of the E-Mail message.

public int SequenceNumber {get;}

Property Value

The sequence number.

See Also

Pop3MessageInfo Class | Aspose.Email.Pop3 Namespace


Size Property

Aspose.Email

Pop3MessageInfo.Size Property

Gets the size of the E-Mail message.

public long Size {get;}

Property Value

The size of the E-Mail message.

See Also

Pop3MessageInfo Class | Aspose.Email.Pop3 Namespace


Subject Property

Aspose.Email

Pop3MessageInfo.Subject Property

Gets the Subject of the E-Mail message.

public string Subject {get;}

Property Value

The subject of the E-Mail message.

See Also

Pop3MessageInfo Class | Aspose.Email.Pop3 Namespace


To Property

Aspose.Email

Pop3MessageInfo.To Property

Gets the receiptants of the E-Mail message.

public MailAddressCollection To {get;}

Property Value

The receiptants of the E-Mail message.

See Also

Pop3MessageInfo Class | Aspose.Email.Pop3 Namespace


UniqueId Property

Aspose.Email

Pop3MessageInfo.UniqueId Property

Gets the Unique Id of the E-Mail message.

public string UniqueId {get;}

Property Value

The unique id.

See Also

Pop3MessageInfo Class | Aspose.Email.Pop3 Namespace


Pop3MessageInfo Methods

The methods of the Pop3MessageInfo class are listed below. For a complete list of Pop3MessageInfo class members, see the Pop3MessageInfo Members topic.

Public Instance Methods

Dispose | Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a string that represents the current object.

See Also

Pop3MessageInfo Class | Aspose.Email.Pop3 Namespace


Pop3MessageInfo.Dispose Method

Performs tasks associated with freeing, releasing, or resetting unmanaged resources.

public void Dispose();

Implements

IDisposable.Dispose

See Also

Pop3MessageInfo Class | Aspose.Email.Pop3 Namespace


Pop3MessageInfo.ToString Method

Returns a string that represents the current object.

public override string ToString();

Return Value

A string that represents the current object.

See Also

Pop3MessageInfo Class | Aspose.Email.Pop3 Namespace


Pop3MessageInfoCollection Class

Represents the information of a mail message from Pop3 server.

For a list of all members of this type, see Pop3MessageInfoCollection Members.

System.Object
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Pop3.Pop3MessageInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]]
Aspose.Email.Pop3.Pop3MessageInfoCollection

public sealed class Pop3MessageInfoCollection : Collection`1

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Pop3

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Pop3MessageInfoCollection Members | Aspose.Email.Pop3 Namespace


Pop3MessageInfoCollection Members

Pop3MessageInfoCollection overview

Public Instance Constructors

Pop3MessageInfoCollection Constructor Initializes a new instance of the Pop3MessageInfoCollection class.

Public Instance Properties

Count (inherited from 0, Culture=neutral, PublicKeyToken=null]])
Item (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

Pop3MessageInfoCollection Class | Aspose.Email.Pop3 Namespace


Pop3MessageInfoCollection Constructor

Initializes a new instance of the Pop3MessageInfoCollection class.

public Pop3MessageInfoCollection();

See Also

Pop3MessageInfoCollection Class | Aspose.Email.Pop3 Namespace


Pop3SslSecurityMode Enumeration

Represents the SSL security mode for ImapClient

public enum Pop3SslSecurityMode

Members

Member Name | Description | Value
Explicit | Explicit mode. | 1
Implicit | Implicit mode. | 0

Requirements

Namespace: Aspose.Email.Pop3

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Pop3 Namespace


Aspose.Email.Printing

Aspose.Email

Aspose.Email.Printing Namespace

Namespace hierarchy

Classes

Class | Description
MailPrinter | Represents a printer for mail messages.

Interfaces

Interface | Description
IPrintSettingsProvider | Represents a source of printer settings which can be used for MailPrinter initialization.

Enumerations

Enumeration | Description
MessageFormattingFlags | Represents possible options that can be set during the message formatting process for various outputs.
PrinterUnit | Represents supported units for PageUnit.
PrintFormat | Descibes possible printing formats for MailPrinter.


IPrintSettingsProvider Interface

Represents a source of printer settings which can be used for MailPrinter initialization.

For a list of all members of this type, see IPrintSettingsProvider Members.

public interface IPrintSettingsProvider

Types that implement IPrintSettingsProvider

Type | Description
MailPrinter | Represents a printer for mail messages.

Requirements

Namespace: Aspose.Email.Printing

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

IPrintSettingsProvider Members | Aspose.Email.Printing Namespace


IPrintSettingsProvider Members

IPrintSettingsProvider overview

Public Instance Properties

CultureName | Gets or sets the culture name in the format languagecode2-country/regioncode2.
DpiX | Gets or sets the horizontal DPI.
DpiY | Gets or sets the vertical DPI.
FormattingFlags | Gets or sets the printer options.
MarginBottom | Gets or sets the bottom margin.
MarginLeft | Gets or sets the left margin.
MarginRight | Gets or sets the right margin.
MarginTop | Gets or sets the top margin.
PageHeight | Gets or sets the height of the page.
PageUnit | Gets or sets the page unit.
PageWidth | Gets or sets the width of the page.

See Also

IPrintSettingsProvider Interface | Aspose.Email.Printing Namespace


IPrintSettingsProvider Properties

The properties of the IPrintSettingsProvider interface are listed below. For a complete list of IPrintSettingsProvider interface members, see the IPrintSettingsProvider Members topic.

Public Instance Properties

CultureName | Gets or sets the culture name in the format languagecode2-country/regioncode2.
DpiX | Gets or sets the horizontal DPI.
DpiY | Gets or sets the vertical DPI.
FormattingFlags | Gets or sets the printer options.
MarginBottom | Gets or sets the bottom margin.
MarginLeft | Gets or sets the left margin.
MarginRight | Gets or sets the right margin.
MarginTop | Gets or sets the top margin.
PageHeight | Gets or sets the height of the page.
PageUnit | Gets or sets the page unit.
PageWidth | Gets or sets the width of the page.

See Also

IPrintSettingsProvider Interface | Aspose.Email.Printing Namespace


CultureName Property

Aspose.Email

IPrintSettingsProvider.CultureName Property

Gets or sets the culture name in the format languagecode2-country/regioncode2.

string CultureName {get; set;}

Property Value

A string that represents the current culture.

Remarks

languagecode2 is a lowercase two-letter code derived from ISO 639-1. country/regioncode2 is derived from ISO 3166 and usually consists of two uppercase letters.

See Also

IPrintSettingsProvider Interface | Aspose.Email.Printing Namespace


DpiX Property

Aspose.Email

IPrintSettingsProvider.DpiX Property

Gets or sets the horizontal DPI.

double DpiX {get; set;}

Property Value

The horizontal DPI.

Remarks

Default value is 96.

Exceptions

Exception Type | Condition
ArgumentException | If value is less or equal to zero.

See Also

IPrintSettingsProvider Interface | Aspose.Email.Printing Namespace


DpiY Property

Aspose.Email

IPrintSettingsProvider.DpiY Property

Gets or sets the vertical DPI.

double DpiY {get; set;}

Property Value

The vertical DPI.

Remarks

Default value is 96.

Exceptions

Exception Type | Condition
ArgumentException | If value is less or equal to zero.

See Also

IPrintSettingsProvider Interface | Aspose.Email.Printing Namespace


FormattingFlags Property

Aspose.Email

IPrintSettingsProvider.FormattingFlags Property

Gets or sets the printer options.

MessageFormattingFlags FormattingFlags {get; set;}

Property Value

The printer options.

See Also

IPrintSettingsProvider Interface | Aspose.Email.Printing Namespace


MarginBottom Property

Aspose.Email

IPrintSettingsProvider.MarginBottom Property

Gets or sets the bottom margin.

double MarginBottom {get; set;}

Property Value

The bottom margin.

Exceptions

Exception Type | Condition
ArgumentException | If value is less than zero.

See Also

IPrintSettingsProvider Interface | Aspose.Email.Printing Namespace


MarginLeft Property

Aspose.Email

IPrintSettingsProvider.MarginLeft Property

Gets or sets the left margin.

double MarginLeft {get; set;}

Property Value

The left margin.

Exceptions

Exception Type | Condition
ArgumentException | If value is less than zero.

See Also

IPrintSettingsProvider Interface | Aspose.Email.Printing Namespace


MarginRight Property

Aspose.Email

IPrintSettingsProvider.MarginRight Property

Gets or sets the right margin.

double MarginRight {get; set;}

Property Value

The right margin.

Exceptions

Exception Type | Condition
ArgumentException | If value is less than zero.

See Also

IPrintSettingsProvider Interface | Aspose.Email.Printing Namespace


MarginTop Property

Aspose.Email

IPrintSettingsProvider.MarginTop Property

Gets or sets the top margin.

double MarginTop {get; set;}

Property Value

The top margin.

Exceptions

Exception Type | Condition
ArgumentException | If value is less than zero.

See Also

IPrintSettingsProvider Interface | Aspose.Email.Printing Namespace


PageHeight Property

Aspose.Email

IPrintSettingsProvider.PageHeight Property

Gets or sets the height of the page.

double PageHeight {get; set;}

Property Value

The height of the page.

Exceptions

Exception Type | Condition
ArgumentException | If value is less or equal to zero.

See Also

IPrintSettingsProvider Interface | Aspose.Email.Printing Namespace


PageUnit Property

Aspose.Email

IPrintSettingsProvider.PageUnit Property

Gets or sets the page unit.

PrinterUnit PageUnit {get; set;}

Property Value

The page unit.

Exceptions

Exception Type | Condition
InvalidEnumArgumentException | If passed value is not a PrinterUnit

See Also

IPrintSettingsProvider Interface | Aspose.Email.Printing Namespace


PageWidth Property

Aspose.Email

IPrintSettingsProvider.PageWidth Property

Gets or sets the width of the page.

double PageWidth {get; set;}

Property Value

The width of the page.

Exceptions

Exception Type | Condition
ArgumentException | If value is less or equal to zero.

See Also

IPrintSettingsProvider Interface | Aspose.Email.Printing Namespace


MailPrinter Class

Represents a printer for mail messages.

For a list of all members of this type, see MailPrinter Members.

System.Object
Aspose.Email.Printing.MailPrinter

public sealed class MailPrinter : IPrintSettingsProvider

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Printing

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MailPrinter Members | Aspose.Email.Printing Namespace


MailPrinter Members

MailPrinter overview

Public Instance Constructors

MailPrinter Overloaded. Initializes a new instance of the MailPrinter class.

Public Instance Properties

CultureName | Gets or sets the culture name in the format languagecode2-country/regioncode2.
DpiX | Gets or sets the horizontal DPI.
DpiY | Gets or sets the vertical DPI.
FormattingFlags | Gets or sets the printer options.
MarginBottom | Gets or sets the bottom margin.
MarginLeft | Gets or sets the left margin.
MarginRight | Gets or sets the right margin.
MarginTop | Gets or sets the top margin.
PageHeight | Gets or sets the height of the page.
PageUnit | Gets or sets the page unit.
PageWidth | Gets or sets the width of the page.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Print | Overloaded. Prints the specified MSG object using the desired format.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MailPrinter Class | Aspose.Email.Printing Namespace


MailPrinter Constructor

Initializes a new instance of the MailPrinter class with A4 paper setting for page size and 0.5in margin for all sides.

Overload List

Initializes a new instance of the MailPrinter class with A4 paper setting for page size and 0.5in margin for all sides.

public MailPrinter();

Initializes a new instance of the MailPrinter class using given settings provider.

public MailPrinter(IPrintSettingsProvider);

See Also

MailPrinter Class | Aspose.Email.Printing Namespace


MailPrinter Constructor ()

Initializes a new instance of the MailPrinter class with A4 paper setting for page size and 0.5in margin for all sides.

public MailPrinter();

See Also

MailPrinter Class | Aspose.Email.Printing Namespace | MailPrinter Constructor Overload List


MailPrinter Constructor (IPrintSettingsProvider)

Initializes a new instance of the MailPrinter class using given settings provider.

public MailPrinter(
IPrintSettingsProvider printSettingsProvider
);

Parameters

printSettingsProvider
The print settings provider object.

See Also

MailPrinter Class | Aspose.Email.Printing Namespace | MailPrinter Constructor Overload List


MailPrinter Properties

The properties of the MailPrinter class are listed below. For a complete list of MailPrinter class members, see the MailPrinter Members topic.

Public Instance Properties

CultureName | Gets or sets the culture name in the format languagecode2-country/regioncode2.
DpiX | Gets or sets the horizontal DPI.
DpiY | Gets or sets the vertical DPI.
FormattingFlags | Gets or sets the printer options.
MarginBottom | Gets or sets the bottom margin.
MarginLeft | Gets or sets the left margin.
MarginRight | Gets or sets the right margin.
MarginTop | Gets or sets the top margin.
PageHeight | Gets or sets the height of the page.
PageUnit | Gets or sets the page unit.
PageWidth | Gets or sets the width of the page.

See Also

MailPrinter Class | Aspose.Email.Printing Namespace


CultureName Property

Aspose.Email

MailPrinter.CultureName Property

Gets or sets the culture name in the format languagecode2-country/regioncode2.

public string CultureName {get; set;}

Property Value

A string that represents the current culture.

Implements

IPrintSettingsProvider.CultureName

Remarks

languagecode2 is a lowercase two-letter code derived from ISO 639-1. country/regioncode2 is derived from ISO 3166 and usually consists of two uppercase letters.

See Also

MailPrinter Class | Aspose.Email.Printing Namespace


DpiX Property

Aspose.Email

MailPrinter.DpiX Property

Gets or sets the horizontal DPI.

public double DpiX {get; set;}

Property Value

The horizontal DPI.

Implements

IPrintSettingsProvider.DpiX

Remarks

Default value is 96.

Exceptions

Exception Type | Condition
ArgumentException | If value is less or equal to zero.

See Also

MailPrinter Class | Aspose.Email.Printing Namespace


DpiY Property

Aspose.Email

MailPrinter.DpiY Property

Gets or sets the vertical DPI.

public double DpiY {get; set;}

Property Value

The vertical DPI.

Implements

IPrintSettingsProvider.DpiY

Remarks

Default value is 96.

Exceptions

Exception Type | Condition
ArgumentException | If value is less or equal to zero.

See Also

MailPrinter Class | Aspose.Email.Printing Namespace


FormattingFlags Property

Aspose.Email

MailPrinter.FormattingFlags Property

Gets or sets the printer options.

public MessageFormattingFlags FormattingFlags {get; set;}

Property Value

The printer options.

Implements

IPrintSettingsProvider.FormattingFlags

See Also

MailPrinter Class | Aspose.Email.Printing Namespace


MarginBottom Property

Aspose.Email

MailPrinter.MarginBottom Property

Gets or sets the bottom margin.

public double MarginBottom {get; set;}

Property Value

The bottom margin.

Implements

IPrintSettingsProvider.MarginBottom

Exceptions

Exception Type | Condition
ArgumentException | If value is less than zero.

See Also

MailPrinter Class | Aspose.Email.Printing Namespace


MarginLeft Property

Aspose.Email

MailPrinter.MarginLeft Property

Gets or sets the left margin.

public double MarginLeft {get; set;}

Property Value

The left margin.

Implements

IPrintSettingsProvider.MarginLeft

Exceptions

Exception Type | Condition
ArgumentException | If value is less than zero.

See Also

MailPrinter Class | Aspose.Email.Printing Namespace


MarginRight Property

Aspose.Email

MailPrinter.MarginRight Property

Gets or sets the right margin.

public double MarginRight {get; set;}

Property Value

The right margin.

Implements

IPrintSettingsProvider.MarginRight

Exceptions

Exception Type | Condition
ArgumentException | If value is less than zero.

See Also

MailPrinter Class | Aspose.Email.Printing Namespace


MarginTop Property

Aspose.Email

MailPrinter.MarginTop Property

Gets or sets the top margin.

public double MarginTop {get; set;}

Property Value

The top margin.

Implements

IPrintSettingsProvider.MarginTop

Exceptions

Exception Type | Condition
ArgumentException | If value is less than zero.

See Also

MailPrinter Class | Aspose.Email.Printing Namespace


PageHeight Property

Aspose.Email

MailPrinter.PageHeight Property

Gets or sets the height of the page.

public double PageHeight {get; set;}

Property Value

The height of the page.

Implements

IPrintSettingsProvider.PageHeight

Exceptions

Exception Type | Condition
ArgumentException | If value is less or equal to zero.

See Also

MailPrinter Class | Aspose.Email.Printing Namespace


PageUnit Property

Aspose.Email

MailPrinter.PageUnit Property

Gets or sets the page unit.

public PrinterUnit PageUnit {get; set;}

Property Value

The page unit.

Implements

IPrintSettingsProvider.PageUnit

Exceptions

Exception Type | Condition
InvalidEnumArgumentException | If passed value is not a PrinterUnit

See Also

MailPrinter Class | Aspose.Email.Printing Namespace


PageWidth Property

Aspose.Email

MailPrinter.PageWidth Property

Gets or sets the width of the page.

public double PageWidth {get; set;}

Property Value

The width of the page.

Implements

IPrintSettingsProvider.PageWidth

Exceptions

Exception Type | Condition
ArgumentException | If value is less or equal to zero.

See Also

MailPrinter Class | Aspose.Email.Printing Namespace


MailPrinter Methods

The methods of the MailPrinter class are listed below. For a complete list of MailPrinter class members, see the MailPrinter Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Print | Overloaded. Prints the specified MSG object using the desired format.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

MailPrinter Class | Aspose.Email.Printing Namespace


Print Method

Aspose.Email

MailPrinter.Print Method

Prints the specified message object using the desired format.

Overload List

Prints the specified message object using the desired format.

public void Print(MailMessage,Stream,PrintFormat);

Prints the specified message object using the desired format.

public void Print(MailMessage,string,PrintFormat);

Prints the specified MSG object using the desired format.

public void Print(MapiMessage,Stream,PrintFormat);

Prints the specified MSG object using the desired format.

public void Print(MapiMessage,string,PrintFormat);

See Also

MailPrinter Class | Aspose.Email.Printing Namespace


MailPrinter.Print Method (MailMessage, Stream, PrintFormat)

Prints the specified message object using the desired format.

public void Print(
MailMessage message,
Stream outputStream,
PrintFormat printingFormat
);

Parameters

message
The MSG file to print.
outputStream
The output stream.
printingFormat
The printing format.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | If printingFormat is not supported.
ArgumentNullException | If one of the arguments is null.
InvalidOperationException | If object can't be processed.

See Also

MailPrinter Class | Aspose.Email.Printing Namespace | MailPrinter.Print Overload List


MailPrinter.Print Method (MailMessage, String, PrintFormat)

Prints the specified message object using the desired format.

public void Print(
MailMessage message,
string outputFile,
PrintFormat printingFormat
);

Parameters

message
The MSG file to print.
outputFile
The output file.
printingFormat
The printing format.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | If printingFormat is not supported.
ArgumentNullException | If one of the arguments is null.
InvalidOperationException | If object can't be processed.

See Also

MailPrinter Class | Aspose.Email.Printing Namespace | MailPrinter.Print Overload List


MailPrinter.Print Method (MapiMessage, Stream, PrintFormat)

Prints the specified MSG object using the desired format.

public void Print(
MapiMessage message,
Stream outputStream,
PrintFormat printingFormat
);

Parameters

message
The MSG file to print.
outputStream
The output stream.
printingFormat
The printing format.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | If printingFormat is not supported.
ArgumentNullException | If one of the arguments is null.
InvalidOperationException | If object can't be processed.

See Also

MailPrinter Class | Aspose.Email.Printing Namespace | MailPrinter.Print Overload List


MailPrinter.Print Method (MapiMessage, String, PrintFormat)

Prints the specified MSG object using the desired format.

public void Print(
MapiMessage message,
string outputFile,
PrintFormat printingFormat
);

Parameters

message
The MSG file to print.
outputFile
The output file.
printingFormat
The printing format.

Exceptions

Exception Type | Condition
ArgumentOutOfRangeException | If printingFormat is not supported.
ArgumentNullException | If one of the arguments is null.
InvalidOperationException | If object can't be processed.

See Also

MailPrinter Class | Aspose.Email.Printing Namespace | MailPrinter.Print Overload List


MessageFormattingFlags Enumeration

Represents possible options that can be set during the message formatting process for various outputs.

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum MessageFormattingFlags

Members

Member Name | Description | Value
None | None of the options are set. | 0
MailInfo | Indicates that mail header including From,To, CC, DateSent & Subject should be included into result. | 1
AutoFitWidth | Specifies whether the page width is fitted automatically by the content. | 2
Attachments | Indicates that mail attachment names should be included into result. | 4

Requirements

Namespace: Aspose.Email.Printing

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Printing Namespace


PrinterUnit Enumeration

Represents supported units for PageUnit.

public enum PrinterUnit

Members

Member Name | Description | Value
Inch | Specifies the inch as the unit of measure. | 0
Pixel | Specifies a device pixel as the unit of measure. | 1
Point | Specifies a printer's point as the unit of measure. | 2
Cm | Specifies the cm as the unit of measure. | 3
Millimeter | Specifies the millimeter as the unit of measure. | 4

Requirements

Namespace: Aspose.Email.Printing

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Printing Namespace


PrintFormat Enumeration

Descibes possible printing formats for MailPrinter.

public enum PrintFormat

Members

Member Name | Description | Value
XPS | XPS output format. | 0
Tiff | Tiff output format. | 1

Requirements

Namespace: Aspose.Email.Printing

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Printing Namespace


Aspose.Email.Protocols.ActiveSync.TransportLayer

Aspose.Email

Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace

Namespace hierarchy

Classes

Class | Description
AccountInformation | Contains user's account information.
ActiveSyncTLClient | Basic class for ActiveSync client implementations
AutodiscoverResult | Result of the Autodiscover operation
Body | Specifies a free-form, variable-length data field associated with a stored item on the server.
BodyPart | Specifies details about the message part of an e-mail in a response. The BodyPart element MUST be included in a command response when the BodyPartPreference is specified in a request.
BodyPreference | Contains preference information related to the type and size of information that is returned from searching, synchronizing, or fetching.
CertificateStatuses | Indicates whether certificate was successfully validated.
DataContainer | Contains data for a particular object, such as a contact, email message, calendar appointment, or task item. The DataContainer can be used to change items, add items, or fetch items on the client device or server.
DeviceInformation | Request that is used for sending the client device's properties to the server.
DevicePasswordRequest | Specifies the request to set recovery password of the client device by the server. To clear an existing recovery password, the client MUST send an empty Password.
EASProvisionDoc | Specifies the collection of security settings for device provisioning.
EmptyFolderContentsRequest | Contains request about deleting the contents of a folder. EmptyFolderContents supports a single child element of the Options element, the DeleteSubFolders, which determines whether subfolders contained in the folder are deleted. If the DeleteSubFolders option is not included in the request, the subfolders of the specified CollectionId are not deleted.
FolderInfo | FolderInfo class contains folder information
FolderSyncResult | Contains changes to the folder hierarchy.
ItemEstimate | Contains an assessment on the requested folder
ItemEstimateOptions | Contains elements that filter the results of the GetItemEstimate operation.
ItemEstimateRequest | Contains ItemEstimate request parameters
ItemOperationsEmptFldrCntntsResponce | Identifies the body of the response as containing the operation that deletes the contents of a folder.
ItemOperationsFetchProperties | Contains the properties that are returned for item(s) in the response.
ItemOperationsFetchRequest | Contains request about retrieving an item from the server.
ItemOperationsFetchResponce | Contains responce about retrieving an items from the server.
ItemOperationsMoveRequest | Contains request about moving a conversation to specific folder.
ItemOperationsMoveResponce | Identifies the body of the response as containing the operation that moves a given conversation.
ItemOperationsRequest | Contains ItemOperations request.
ItemOperationsResponse | Contains ItemOperations response.
ItOpEmpFldCntOptions | Contains the options for the ItemOperations.EmptyFolderContents operation
ItOpFetchOptions | Contains the options for the ItemOperations.Fetch operation.
ItOpMoveOptions | Contains the options for the ItemOperations.Move operation.
MeetingResponseRequest | Specifies the meeting request that is being responded to, the response to that meeting request, and the folder on the server that the meeting request is located in.
MeetingResponseResult | Meeting response result object
MoveItemData | Contains information about moving items
MoveItemResponse | Contains information that describe the moved items.
OOFMessage | Specifies the OOF message for a particular audience. Exchange 2007, Exchange 2010, and Exchange 2013 require that the reply message for unknown external and known external audiences be the same. The property supports the following three audiences for an OOF message: Internal — A user who is in the same organization as the sending user. Known external — A user who is outside the sending user's organization, but is represented in the sending user's contacts. Unknown external — A user who is outside the sending user's organization and is not represented in the sending user's contacts.
OOFReqParametrs | Gets OOF information settings from the server.
OOFRequest | Specifies a class for retrieving and setting Out of Office (OOF) information.
OOFResponse | Specifies a class for retrieving and setting Out of Office (OOF) information.
OOFSettings | OOF information settings.
PictureRequest | Indicates that the client is requesting that photos be returned in the server response. The Picture is not supported when the protocol version is 12.1 or 14.0. Contains the data related to the photos request.
PictureRespose | Contains the data related to the contact photos. The Picture is not supported when the protocol version is 12.1 or 14.0.
PingParameter | Contains the ping command parameters
ProvisionPolicy | Specifies a security policy.
ProvisionPolicyData | Specifies the settings for a policy.
ProvisionRequest | Contains request information for provision command
ProvisionResponse | Contains response information for provision command
QueryType | Specifies the keywords to use for matching the entries in the store that is being searched. The value of the Query is used as a prefix-string matching pattern, and returns entries that match the beginning of the string. For example, searching for "John" would match "John Frum" or "Barry Johnson", but would not match "James Littlejohn". All nonempty text properties in the GAL that are indexed by using ANR are compared with the Query element value. Search comparisons are performed by using case-insensitive matching. For a Windows SharePoint Services document library search, this protocol supports queries of the following form: LinkId == value, where value specifies the URL of the item or folder and LinkId indicates that the value is to be compared to the link ID property. For mailbox search, the query syntax is as follows: - Folders can be specified in the following ways: Specified ID Specified folder and subfolders All email folders, including Draft, Inbox and subfolders, Outbox, and Sent Items - The basic keyword query can be composed of the following: The basic operator: And (section 2.2.3.10) A dateTime filter specified by using the GreaterThan (section 2.2.3.78) and LessThan elements (section 2.2.3.87) FreeText elements (section 2.2.3.73) that contain keywords The basic keyword query is executed against all indexed properties.
Recipient | Represents a single recipient that has been resolved.
ResolveRecipientsAvailabilityRequest | Indicates to the server that free/busy data is being requested by the client and identifies the start time and end time of the free/busy data to retrieve. The Availability is not supported when the protocol version is 12.1.
ResolveRecipientsAvailabilityResponse | Identifies status and free/busy data of the users or distribution lists identified in the request for the time identified by the StartTime and EndTime. When the Availability is included in a ResolveRecipients request, the server retrieves free/busy information for the users identified in the To elements included in the request, and returns the free/busy information in the MergedFreeBusy in the response. When the server parses the request, the server first resolves the recipients identified by the To elements, and then determines the users free/busy information for the specified time span, before returning the free/busy data in the MergedFreeBusy.
ResolveRecipientsCertificates | Contains information about the certificates for a recipient.
ResolveRecipientsOptions | Contains the options for resolving the list of recipients.
ResolveRecipientsRequest | Contains information to resolve recipients.
ResolveRecipientsResponse | Contains information as to whether the recipient was resolved. If the recipient was resolved, the it also contains the type of recipient, the email address that the recipient resolved to, and, optionally, the S/MIME certificate for the recipient.
RightsManagementInformationResponce | Contains rights management information settings retrieved from the server.
RightsManagementLicense | Contains the rights policy template settings for the template applied to the e-mail message being synchronized.
RightsManagementTemplate | Contains the template identifier, name, and description of a rights policy template available on the client.
SearchCondition | Specifies a condition for search requests
SearchOptions | Contains the search options. The UserName and Password can only be sent in the request after receiving a Status value of 14. The server requires these credentials to access the requested resources. The client MUST only send these over a secure or trusted connection, and only in response to a Status value of 14. The supported options vary according to the store that is being searched. The following table lists the valid options for each store. GAL: Range, UserName, Password, Picture Mailbox: Range, DeepTraversal, RebuildResults, BodyPreference, BodyPartPreference, RightsManagementSupport DocumentLibrary: Range, UserName, Password The BodyPartPreference is only valid in Search command requests that include a ConversationId.
SearchQuery | Specifies the keywords to use for matching the entries in the store that is being searched. The value of the Query is used as a prefix-string matching pattern, and returns entries that match the beginning of the string. For example, searching for "John" would match "John Frum" or "Barry Johnson", but would not match "James Littlejohn". All nonempty text properties in the GAL that are indexed by using ANR are compared with the Query element value. Search comparisons are performed by using case-insensitive matching. For a Windows SharePoint Services document library search, this protocol supports queries of the following form: LinkId == value, where value specifies the URL of the item or folder and LinkId indicates that the value is to be compared to the link ID property. For mailbox search, the query syntax is as follows: - Folders can be specified in the following ways: Specified ID Specified folder and subfolders All email folders, including Draft, Inbox and subfolders, Outbox, and Sent Items - The basic keyword query can be composed of the following: The basic operator: And (section 2.2.3.10) A dateTime filter specified by using the GreaterThan (section 2.2.3.78) and LessThan elements (section 2.2.3.87) FreeText elements (section 2.2.3.73) that contain keywords The basic keyword query is executed against all indexed properties.
SearchRequest | Contains search request information
SearchRequestStore | Specify the name, query and options for the search.
SearchResponse | Contains search response information
SearchResponseStore | Contains the Status, Result, Range, and Total elements for the returned mailbox entries.
SearchResult | Container for an individual matching mailbox item. When the store that is being searched is the mailbox: - There is one Result element for each match that is found in the mailbox. If no matches are found, an empty Result element is present in the Store container element of the response XML. - Inside the Result element, the Properties element contains a list of requested properties for the mailbox item. When the store that is being searched is the document library: - The first result that is returned in the Search response is the metadata for the Root folder or item to which the LinkId value is pointing. The client can choose to ignore this entry if it does not require it. - If the documentlibrary:LinkId element value in the request points to a folder, the metadata properties of the folder are returned as the first item, and the contents of the folder are returned as subsequent results. The Range applies to these results with no difference; for example, the index 0 would always be for the root item to which the link is pointing. - If the documentlibrary:LinkId element value in the request points to an item, only one result is returned: the metadata for the item. - Inside the Result element, the Properties element contains a list of requested properties for the mailbox item.
SearchResultProperties | The Search command response Properties is a container for properties that apply to an individual entry that matches the Query element search string. For example, the Properties element contains an element for each nonempty, text-valued GAL property that is attached to the matching GAL entry. Only those properties that are attached to the specific GAL entry are returned; therefore different sets of properties can be returned in the response XML for different matching GAL entries. Each element in the Properties container is scoped to the appropriate namespace that is specified in the top-level Search element.
ServerInfo | Server settings in Autodiscover operation
SettingsRequest | The Settings command supports get and set operations on global properties and Out of Office (OOF) settings for the user. The Settings command also sends device information to the server, implements the device password/personal identification number (PIN) recovery, and retrieves a list of the user's email addresses.
SettingsResponse | Specifies a response with Out of Office (OOF) settings and list of the user's accounts.
SmartRequest | Contains smart request information
SmartRequestSource | Contains information about the source message.
Status | Indicates the result of an operation.
SyncAddClientOperation | Creates a new object in a collection on the client.
SyncAddResponse | Serves to indicate that a new object has to be created in a collection.
SyncAddServerOperation | Creates a new object in a collection on the server.
SyncChangeClientOperation | Contains properties of an existing object on the client device that were modified. The changed object is identified by its ServerId element.
SyncChangeResponse | Serves to Indicate that an object has been modified.
SyncChangeServerOperation | Contains properties of an existing object on the the server that were modified. The changed object is identified by its ServerId element.
SyncCollectionRequest | Class contains commands and options that apply to a particular collection.
SyncCollectionResponse | Class contains commands and options that apply to a Sync response.
SyncCommandsRequest | Contains operations that apply to a collection. Available operations are Add, Delete, Change, Fetch, and SoftDelete.
SyncCommandsResponse | Contains operations that apply to a collection. Available operations are Add, Delete, Change, Fetch, and SoftDelete.
SyncDeleteClientOperation | Deletes an object on the client device or the server. The object is identified by its ServerId.
SyncFetchResponse | Requests the application data of an item that was truncated in a synchronization response from the server.
SyncOperationResponse | Base abstract class for Sync operation responses
SyncOperationsResponse | Contains responses to operations such as Add, Fetch, Change that are processed by the server. The response contains a status code and other information, depending on the operation.
SyncOptions | Specifies options that control certain aspects of how the synchronization is performed.
SyncRequest | Contains Sync request parameters
UserInformationResponse | Contains status of the request and a list of a user’s account information (email addresses).
ValueConverter | Class converts ActiveSync protocol version from string representation to enum and back.

Interfaces

Interface | Description
IActiveSyncTLClient | ActiveSync client interface
IBaseActiveSyncTLClient | Base ActiveSync client interface

Enumerations

Enumeration | Description
ActiveSyncAuthenticationType | Enum specifies type of authentication
AirsyncClass | Identifies the class of the item. The following classes are supported for mailbox searches when the protocol version is 12.1: - Email - Calendar - Contacts - Tasks The SMS and Notes classes are only available if the protocol version is 14.0 or 14.1.
AirsyncFilterType | Specifies an optional time window for the objects
AllowBluetooth | Specifies the use of Bluetooth on the device.
ASProtocolVersions | The ASProtocolVersions indicates the versions of the ActiveSync protocol.
BehaviorReplacement | Specifies how to resolve the conflict that occurs when an object has been changed on both the client and the server. The value specifies which object—the client object or the server object—to keep if there is a conflict.
BodyType | Specifies the format type of the body content of the item.
CertificateRetrieval | Specifies whether S/MIME certificates SHOULD be returned by the server for each resolved recipient.
CommandCodes | The following table provides the numeric codes that correspond to the ActiveSync commands. The numeric code is used in the Command code field of the base64 encoded URI to specify the command.
CommandParameters | Command parameters.
EncryptionSMIMEAlgorithm | Specifies the algorithm used when encrypting S/MIME messages.
FolderClass | Specifies the content class of the folder to be monitored.
FolderTypes | Specifies the type of the folder that was updated (renamed or moved) or added on the server.
MaxAgeFilter | Specifies the maximum number of calendar days that can be synchronized.
MergedFreeBusy | Specifies the free/busy information for the users or distribution list.
MIMESupport | Enables MIME support for email items that are sent from the server to the client.
MIMETruncation | Specifies whether the MIME data of the email item SHOULD be truncated when it is sent from the server to the client.
MinDevicePasswordComplexCharacters | Specifies the required level of complexity of the client password. For example: If the value of MinDevicePasswordComplexCharacters is 2, a password with both upper case and lower case alphabetical characters would be sufficient, as would a password with lower case alphabetical characters and numbers.
OofState | Specifies the availability of the Oof property.
ProvisionPolicyStatuses | The value indicates the success or failure of the client to apply the policy settings retrieved from the server.
ProvisionRemoteWipeStatuses | The value indicates the success or failure of a remote wipe operation on the client.
RecipientType | Indicates the type of recipient.
ServerType | Specifies the server type
SignedSMIMEAlgorithm | Specifies the algorithm used when signing S/MIME messages.
SMIMEEncryptionAlgorithmNegotiation | Controls the negotiation of the encryption algorithm.
StoreType | Contains infarmation that specify the location, for the operations.
UserCreatedFolderTypes | Specifies the type of the folder to be created.
UserResponse | Indicates whether the meeting is being accepted, tentatively accepted, or declined.


AccountInformation Class

Contains user's account information.

For a list of all members of this type, see AccountInformation Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.AccountInformation

public class AccountInformation

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AccountInformation Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


AccountInformation Members

AccountInformation overview

Public Instance Constructors

AccountInformation Constructor Initializes a new instance of the AccountInformation class.

Public Instance Properties

AccountId | Identifies an account. The primary account, as identified by the PrimarySmtpAddress element, does not have an AccountId value. The AccountId is not supported when the protocol version is 12.1 or 14.0.
AccountName | Specifies the friendly name for the given account. The AccountName value is a string value up to 512 characters in length. The AccountName is not supported when the protocol version is 12.1 or 14.0.
PrimarySmtpAddress | Specifies the primary SMTP address for the given account. The value of the PrimarySmtpAddress can also be returned as a value for the SMTPAddress. The PrimarySmtpAddress is not supported when the protocol version is 12.1 or 14.0.
SendDisabled | Specifies whether the client can send messages using the given account. The value of the SendDisabled is TRUE if the client cannot send using the given account; otherwise, FALSE. The SendDisabled is not supported when the protocol version is 12.1 or 14.0.
SMTPAddresses | Specifies one of the user's email addresses.
UserDisplayName | Specifies the display name of the user associated with the given account. The UserDisplayName value can be up to 512 characters in length. The UserDisplayName is not supported when the protocol version is 12.1 or 14.0.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AccountInformation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


AccountInformation Constructor

Initializes a new instance of the AccountInformation class.

public AccountInformation();

See Also

AccountInformation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


AccountInformation Properties

The properties of the AccountInformation class are listed below. For a complete list of AccountInformation class members, see the AccountInformation Members topic.

Public Instance Properties

AccountId | Identifies an account. The primary account, as identified by the PrimarySmtpAddress element, does not have an AccountId value. The AccountId is not supported when the protocol version is 12.1 or 14.0.
AccountName | Specifies the friendly name for the given account. The AccountName value is a string value up to 512 characters in length. The AccountName is not supported when the protocol version is 12.1 or 14.0.
PrimarySmtpAddress | Specifies the primary SMTP address for the given account. The value of the PrimarySmtpAddress can also be returned as a value for the SMTPAddress. The PrimarySmtpAddress is not supported when the protocol version is 12.1 or 14.0.
SendDisabled | Specifies whether the client can send messages using the given account. The value of the SendDisabled is TRUE if the client cannot send using the given account; otherwise, FALSE. The SendDisabled is not supported when the protocol version is 12.1 or 14.0.
SMTPAddresses | Specifies one of the user's email addresses.
UserDisplayName | Specifies the display name of the user associated with the given account. The UserDisplayName value can be up to 512 characters in length. The UserDisplayName is not supported when the protocol version is 12.1 or 14.0.

See Also

AccountInformation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


AccountId Property

Aspose.Email

AccountInformation.AccountId Property

Identifies an account. The primary account, as identified by the PrimarySmtpAddress element, does not have an AccountId value. The AccountId is not supported when the protocol version is 12.1 or 14.0.

public string AccountId {get; set;}

See Also

AccountInformation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


AccountName Property

Aspose.Email

AccountInformation.AccountName Property

Specifies the friendly name for the given account. The AccountName value is a string value up to 512 characters in length. The AccountName is not supported when the protocol version is 12.1 or 14.0.

public string AccountName {get; set;}

See Also

AccountInformation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


PrimarySmtpAddress Property

Aspose.Email

AccountInformation.PrimarySmtpAddress Property

Specifies the primary SMTP address for the given account. The value of the PrimarySmtpAddress can also be returned as a value for the SMTPAddress. The PrimarySmtpAddress is not supported when the protocol version is 12.1 or 14.0.

public string PrimarySmtpAddress {get; set;}

See Also

AccountInformation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SendDisabled Property

Aspose.Email

AccountInformation.SendDisabled Property

Specifies whether the client can send messages using the given account. The value of the SendDisabled is TRUE if the client cannot send using the given account; otherwise, FALSE. The SendDisabled is not supported when the protocol version is 12.1 or 14.0.

public Boolean} SendDisabled {get; set;}

See Also

AccountInformation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SMTPAddresses Property

Aspose.Email

AccountInformation.SMTPAddresses Property

Specifies one of the user's email addresses.

public String} SMTPAddresses {get;}

See Also

AccountInformation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


UserDisplayName Property

Aspose.Email

AccountInformation.UserDisplayName Property

Specifies the display name of the user associated with the given account. The UserDisplayName value can be up to 512 characters in length. The UserDisplayName is not supported when the protocol version is 12.1 or 14.0.

public string UserDisplayName {get; set;}

See Also

AccountInformation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ActiveSyncAuthenticationType Enumeration

Enum specifies type of authentication

public enum ActiveSyncAuthenticationType

Members

Member Name | Description | Value
Basic | HTTP basic authentication | 0

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ActiveSyncTLClient Class

Basic class for ActiveSync client implementations

For a list of all members of this type, see ActiveSyncTLClient Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.ActiveSyncTLClient

public class ActiveSyncTLClient : IBaseActiveSyncTLClient, IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ActiveSyncTLClient Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ActiveSyncTLClient Members

ActiveSyncTLClient overview

Public Static Properties

DefaultTimeout Gets or sets the default timeout value for ActiveSync client instances The default value is 100,000 milliseconds (100 seconds).

Public Static Methods

Autodiscover | Overloaded. The Autodiscover command facilitates the discovery of core account configuration information by using the user's Simple Mail Transfer Protocol (SMTP) address as the primary input.
GetInstance | Overloaded. Gets an instance of the ActiveSync client The version of the ActiveSync protocol is selected automatically according to server response.
GetOptions |

Public Instance Properties

AuthenticationType | Gets or sets the type of authentication is used by the ActiveSync client.
AutodiscoverUri | Gets or sets the autodiscover service uri
Credentials | User's credentials for Exchange server
DeviceID | A GUID that identifies the device. The device ID is specified by the device-id-spec ABNF rule portion of the plain text query value. The value, represented by the device-id ABNF rule, is a string that specifies the device. Each device MUST have a unique device ID string. Each request from the device MUST include the same device ID string.
DeviceType | The device type is specified by the device-type-spec ABNF rule portion of the plain text query value. The value, represented by the device-type ABNF rule, is any string that specifies a device type. "SP" specifies a SmartPhone and "PPC" specifies a PocketPC. Other client devices send unique strings for their specific device type. Each request from a client device MUST include the same device type string.
PolicyKey | An unsigned integer that indicates the state of policy settings on the client device, as specified in [MS-ASPROV] section 2.2.2.41.
Proxy | Gets or sets the proxy.
SupportedServerCommands | Gets the versions of ActiveSync commands which are supported
SupportedServerProtocols | Gets the versions of ActiveSync protocols which are supported
Timeout | Gets or sets the number of milliseconds to wait before the operation times out. The default value is 100,000 milliseconds (100 seconds).
Uri | Gets the URL of ActiveSync service
UserAgent | The User-Agent request-header field contains information about the user agent originating the request. This is for statistical purposes, the tracing of protocol violations, and automated recognition of user agents for the sake of tailoring responses to avoid particular user agent limitations. User agents SHOULD include this field with requests. The field can contain multiple product tokens (section 3.8) and comments identifying the agent and any subproducts which form a significant part of the user agent. By convention, the product tokens are listed in order of their significance for identifying the application. Example: User-Agent: CERN-LineMode/2.15 libwww/2.17b3
Version | Gets the version of the protocol which is used in ActiveSync client.

Public Instance Methods

Autodiscover | Overloaded. The Autodiscover command facilitates the discovery of core account configuration information by using the user's Simple Mail Transfer Protocol (SMTP) address as the primary input.
Dispose | Overloaded. Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Dispose | Overloaded. Releases unmanaged and - optionally - managed resources.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ActiveSyncTLClient Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ActiveSyncTLClient Properties

The properties of the ActiveSyncTLClient class are listed below. For a complete list of ActiveSyncTLClient class members, see the ActiveSyncTLClient Members topic.

Public Static Properties

DefaultTimeout Gets or sets the default timeout value for ActiveSync client instances The default value is 100,000 milliseconds (100 seconds).

Public Instance Properties

AuthenticationType | Gets or sets the type of authentication is used by the ActiveSync client.
AutodiscoverUri | Gets or sets the autodiscover service uri
Credentials | User's credentials for Exchange server
DeviceID | A GUID that identifies the device. The device ID is specified by the device-id-spec ABNF rule portion of the plain text query value. The value, represented by the device-id ABNF rule, is a string that specifies the device. Each device MUST have a unique device ID string. Each request from the device MUST include the same device ID string.
DeviceType | The device type is specified by the device-type-spec ABNF rule portion of the plain text query value. The value, represented by the device-type ABNF rule, is any string that specifies a device type. "SP" specifies a SmartPhone and "PPC" specifies a PocketPC. Other client devices send unique strings for their specific device type. Each request from a client device MUST include the same device type string.
PolicyKey | An unsigned integer that indicates the state of policy settings on the client device, as specified in [MS-ASPROV] section 2.2.2.41.
Proxy | Gets or sets the proxy.
SupportedServerCommands | Gets the versions of ActiveSync commands which are supported
SupportedServerProtocols | Gets the versions of ActiveSync protocols which are supported
Timeout | Gets or sets the number of milliseconds to wait before the operation times out. The default value is 100,000 milliseconds (100 seconds).
Uri | Gets the URL of ActiveSync service
UserAgent | The User-Agent request-header field contains information about the user agent originating the request. This is for statistical purposes, the tracing of protocol violations, and automated recognition of user agents for the sake of tailoring responses to avoid particular user agent limitations. User agents SHOULD include this field with requests. The field can contain multiple product tokens (section 3.8) and comments identifying the agent and any subproducts which form a significant part of the user agent. By convention, the product tokens are listed in order of their significance for identifying the application. Example: User-Agent: CERN-LineMode/2.15 libwww/2.17b3
Version | Gets the version of the protocol which is used in ActiveSync client.

See Also

ActiveSyncTLClient Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


AuthenticationType Property

Aspose.Email

ActiveSyncTLClient.AuthenticationType Property

Gets or sets the type of authentication is used by the ActiveSync client.

public virtual ActiveSyncAuthenticationType AuthenticationType {get; set;}

Implements

IBaseActiveSyncTLClient.AuthenticationType

See Also

ActiveSyncTLClient Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


AutodiscoverUri Property

Aspose.Email

ActiveSyncTLClient.AutodiscoverUri Property

Gets or sets the autodiscover service uri

public virtual string AutodiscoverUri {get; set;}

Implements

IBaseActiveSyncTLClient.AutodiscoverUri

See Also

ActiveSyncTLClient Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Credentials Property

Aspose.Email

ActiveSyncTLClient.Credentials Property

User's credentials for Exchange server

public virtual NetworkCredential Credentials {get;}

Implements

IBaseActiveSyncTLClient.Credentials

See Also

ActiveSyncTLClient Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


DefaultTimeout Property

Aspose.Email

ActiveSyncTLClient.DefaultTimeout Property

Gets or sets the default timeout value for ActiveSync client instances The default value is 100,000 milliseconds (100 seconds).

public static int DefaultTimeout {get; set;}

See Also

ActiveSyncTLClient Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


DeviceID Property

Aspose.Email

ActiveSyncTLClient.DeviceID Property

A GUID that identifies the device. The device ID is specified by the device-id-spec ABNF rule portion of the plain text query value. The value, represented by the device-id ABNF rule, is a string that specifies the device. Each device MUST have a unique device ID string. Each request from the device MUST include the same device ID string.

public virtual string DeviceID {get; set;}

Implements

IBaseActiveSyncTLClient.DeviceID

See Also

ActiveSyncTLClient Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


DeviceType Property

Aspose.Email

ActiveSyncTLClient.DeviceType Property

The device type is specified by the device-type-spec ABNF rule portion of the plain text query value. The value, represented by the device-type ABNF rule, is any string that specifies a device type. "SP" specifies a SmartPhone and "PPC" specifies a PocketPC. Other client devices send unique strings for their specific device type. Each request from a client device MUST include the same device type string.

public virtual string DeviceType {get; set;}

Implements

IBaseActiveSyncTLClient.DeviceType

See Also

ActiveSyncTLClient Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


PolicyKey Property

Aspose.Email

ActiveSyncTLClient.PolicyKey Property

An unsigned integer that indicates the state of policy settings on the client device, as specified in [MS-ASPROV] section 2.2.2.41.

public virtual UInt32} PolicyKey {get; set;}

Implements

IBaseActiveSyncTLClient.PolicyKey

See Also

ActiveSyncTLClient Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Proxy Property

Aspose.Email

ActiveSyncTLClient.Proxy Property

Gets or sets the proxy.

public virtual WebProxy Proxy {get; set;}

Implements

IBaseActiveSyncTLClient.Proxy

See Also

ActiveSyncTLClient Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SupportedServerCommands Property

Aspose.Email

ActiveSyncTLClient.SupportedServerCommands Property

Gets the versions of ActiveSync commands which are supported

public virtual string[] SupportedServerCommands {get;}

Implements

IBaseActiveSyncTLClient.SupportedServerCommands

See Also

ActiveSyncTLClient Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SupportedServerProtocols Property

Aspose.Email

ActiveSyncTLClient.SupportedServerProtocols Property

Gets the versions of ActiveSync protocols which are supported

public virtual string[] SupportedServerProtocols {get;}

Implements

IBaseActiveSyncTLClient.SupportedServerProtocols

See Also

ActiveSyncTLClient Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Timeout Property

Aspose.Email

ActiveSyncTLClient.Timeout Property

Gets or sets the number of milliseconds to wait before the operation times out. The default value is 100,000 milliseconds (100 seconds).

public virtual int Timeout {get; set;}

Implements

IBaseActiveSyncTLClient.Timeout

See Also

ActiveSyncTLClient Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Uri Property

Aspose.Email

ActiveSyncTLClient.Uri Property

Gets the URL of ActiveSync service

public virtual string Uri {get;}

Implements

IBaseActiveSyncTLClient.Uri

See Also

ActiveSyncTLClient Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


UserAgent Property

Aspose.Email

ActiveSyncTLClient.UserAgent Property

The User-Agent request-header field contains information about the user agent originating the request. This is for statistical purposes, the tracing of protocol violations, and automated recognition of user agents for the sake of tailoring responses to avoid particular user agent limitations. User agents SHOULD include this field with requests. The field can contain multiple product tokens (section 3.8) and comments identifying the agent and any subproducts which form a significant part of the user agent. By convention, the product tokens are listed in order of their significance for identifying the application. Example: User-Agent: CERN-LineMode/2.15 libwww/2.17b3

public virtual string UserAgent {get; set;}

Implements

IBaseActiveSyncTLClient.UserAgent

See Also

ActiveSyncTLClient Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Version Property

Aspose.Email

ActiveSyncTLClient.Version Property

Gets the version of the protocol which is used in ActiveSync client.

public virtual ASProtocolVersions Version {get; set;}

Implements

IBaseActiveSyncTLClient.Version

See Also

ActiveSyncTLClient Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ActiveSyncTLClient Methods

The methods of the ActiveSyncTLClient class are listed below. For a complete list of ActiveSyncTLClient class members, see the ActiveSyncTLClient Members topic.

Public Static Methods

Autodiscover | Overloaded. The Autodiscover command facilitates the discovery of core account configuration information by using the user's Simple Mail Transfer Protocol (SMTP) address as the primary input.
GetInstance | Overloaded. Gets an instance of the ActiveSync client The version of the ActiveSync protocol is selected automatically according to server response.
GetOptions |

Public Instance Methods

Autodiscover | Overloaded. The Autodiscover command facilitates the discovery of core account configuration information by using the user's Simple Mail Transfer Protocol (SMTP) address as the primary input.
Dispose | Overloaded. Performs tasks associated with freeing, releasing, or resetting unmanaged resources.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Dispose | Overloaded. Releases unmanaged and - optionally - managed resources.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ActiveSyncTLClient Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Autodiscover Method

Aspose.Email

ActiveSyncTLClient.Autodiscover Method

The Autodiscover command facilitates the discovery of core account configuration information by using the user's Simple Mail Transfer Protocol (SMTP) address as the primary input.

Overload List

The Autodiscover command facilitates the discovery of core account configuration information by using the user's Simple Mail Transfer Protocol (SMTP) address as the primary input.

public virtual AutodiscoverResult Autodiscover(string);

The Autodiscover command facilitates the discovery of core account configuration information by using the user's Simple Mail Transfer Protocol (SMTP) address as the primary input.

public static AutodiscoverResult Autodiscover(string,NetworkCredential,string);

See Also

ActiveSyncTLClient Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ActiveSyncTLClient.Autodiscover Method (String)

The Autodiscover command facilitates the discovery of core account configuration information by using the user's Simple Mail Transfer Protocol (SMTP) address as the primary input.

public virtual AutodiscoverResult Autodiscover(
string emailAddress
);

Parameters

emailAddress
The email address is a required child element of the autodiscover request

Return Value

Autodiscover result

Implements

IBaseActiveSyncTLClient.Autodiscover

See Also

ActiveSyncTLClient Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | ActiveSyncTLClient.Autodiscover Overload List


ActiveSyncTLClient.Autodiscover Method (String, NetworkCredential, String)

The Autodiscover command facilitates the discovery of core account configuration information by using the user's Simple Mail Transfer Protocol (SMTP) address as the primary input.

public static AutodiscoverResult Autodiscover(
string autodiscoverUri,
NetworkCredential credential,
string emailAddress
);

Parameters

autodiscoverUri
The URL of autodiscover service
credential
Credentials for connecting to the server.
emailAddress
The email address is a required child element of the autodiscover request

Return Value

Autodiscover result

See Also

ActiveSyncTLClient Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | ActiveSyncTLClient.Autodiscover Overload List


Dispose Method

Aspose.Email

ActiveSyncTLClient.Dispose Method

Performs tasks associated with freeing, releasing, or resetting unmanaged resources.

Overload List

Performs tasks associated with freeing, releasing, or resetting unmanaged resources.

public void Dispose();

Releases unmanaged and - optionally - managed resources.

protected virtual void Dispose(bool);

See Also

ActiveSyncTLClient Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ActiveSyncTLClient.Dispose Method ()

Performs tasks associated with freeing, releasing, or resetting unmanaged resources.

public void Dispose();

Implements

IDisposable.Dispose

See Also

ActiveSyncTLClient Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | ActiveSyncTLClient.Dispose Overload List


ActiveSyncTLClient.Dispose Method (Boolean)

Releases unmanaged and - optionally - managed resources.

protected virtual void Dispose(
bool disposing
);

Parameters

disposing
true to release both managed and unmanaged resources; false to release only unmanaged resources.

See Also

ActiveSyncTLClient Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | ActiveSyncTLClient.Dispose Overload List


GetInstance Method

Aspose.Email

ActiveSyncTLClient.GetInstance Method

Gets an instance of the ActiveSync client The version of the ActiveSync protocol is selected automatically according to server response.

Overload List

Gets an instance of the ActiveSync client The version of the ActiveSync protocol is selected automatically according to server response.

public static IActiveSyncTLClient GetInstance(string,NetworkCredential);

Gets an instance of the ActiveSync client

public static IActiveSyncTLClient GetInstance(string,NetworkCredential,ASProtocolVersions);

See Also

ActiveSyncTLClient Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ActiveSyncTLClient.GetInstance Method (String, NetworkCredential)

Gets an instance of the ActiveSync client The version of the ActiveSync protocol is selected automatically according to server response.

public static IActiveSyncTLClient GetInstance(
string uri,
NetworkCredential credentials
);

Parameters

uri
server uri
credentials
user credentials

Return Value

Returns an instance of the ActiveSync client

See Also

ActiveSyncTLClient Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | ActiveSyncTLClient.GetInstance Overload List


ActiveSyncTLClient.GetInstance Method (String, NetworkCredential, ASProtocolVersions)

Gets an instance of the ActiveSync client

public static IActiveSyncTLClient GetInstance(
string uri,
NetworkCredential credentials,
ASProtocolVersions version
);

Parameters

uri
server uri
credentials
user credentials
version
ActiveSync protocol version

Return Value

Returns an instance of the ActiveSync client

See Also

ActiveSyncTLClient Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | ActiveSyncTLClient.GetInstance Overload List


ActiveSyncTLClient.GetOptions Method

public static ASProtocolVersions GetOptions(
string uri,
NetworkCredential credentials,
out string[] supportedServerCommands,
out string[] supportedServerProtocols
);

See Also

ActiveSyncTLClient Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


AirsyncClass Enumeration

Identifies the class of the item. The following classes are supported for mailbox searches when the protocol version is 12.1: - Email - Calendar - Contacts - Tasks The SMS and Notes classes are only available if the protocol version is 14.0 or 14.1.

public enum AirsyncClass

Members

Member Name | Description | Value
Tasks | Tasks item class | 0
Email | Email item class | 1
Calendar | Calendar item class | 2
Contacts | Contacts item class | 3
SMS | SMS item class The SMS class is only available if the protocol version is 14.0 or 14.1. | 4
Notes | Notes item class The Notes class is only available if the protocol version is 14.0 or 14.1. | 5

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


AirsyncFilterType Enumeration

Specifies an optional time window for the objects

public enum AirsyncFilterType

Members

Member Name | Description | Value
NoFilter | No filter- synchronize all items | 0
OneDay | Specifies 1 day time window | 1
ThreeDays | Specifies 3 days time window | 2
OneWeek | Specifies 1 week time window | 3
TwoWeeks | Specifies 2 weeks time window | 4
OneMonth | Specifies 1 month time window | 5
ThreeMonths | Specifies 3 months time window | 6
SixMonths | Specifies 6 months time window | 7
IncompleteTasks | Filter by incomplete tasks | 8
Any | Identifies any email, contact, calendar or task collection results in a Status element value of 103. | 9

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


AllowBluetooth Enumeration

Specifies the use of Bluetooth on the device.

public enum AllowBluetooth

Members

Member Name | Description | Value
Disable | Disable Bluetooth. | 0
AllowProfilesConfiguration | Disable Bluetooth, but allow the configuration of hands-free profiles. | 1
AllowBluetooth | Allow Bluetooth. | 2

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ASProtocolVersions Enumeration

The ASProtocolVersions indicates the versions of the ActiveSync protocol.

public enum ASProtocolVersions

Members

Member Name | Description | Value
Unknown | Version is unknown | 0
Version_12_1 | Exchange ActiveSync (EAS) 12.1 version | 121
Version_14 | Exchange ActiveSync (EAS) 14.0 version | 140
Version_14_1 | Exchange ActiveSync (EAS) 14.1 version | 141

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


AutodiscoverResult Class

Result of the Autodiscover operation

For a list of all members of this type, see AutodiscoverResult Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.AutodiscoverResult

public class AutodiscoverResult

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

AutodiscoverResult Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


AutodiscoverResult Members

AutodiscoverResult overview

Public Instance Constructors

AutodiscoverResult Overloaded. Initializes a new instance of the AutodiscoverResult class.

Public Instance Properties

Culture | Specifies the client culture, which is used to localize error messages.
DisplayName | Contains the user's display name in the directory service.
EMailAddress | Contains the SMTP email address of the user and is used to identify the user's mailbox in the network.
Redirect | Specifies the SMTP address of the requested user.
Servers | Contains array of server settings

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a string that represents the current object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AutodiscoverResult Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


AutodiscoverResult Constructor

Initializes a new instance of the AutodiscoverResult class.

Overload List

Initializes a new instance of the AutodiscoverResult class.

public AutodiscoverResult(CultureInfo,string,string,ServerInfo[]);

Initializes a new instance of the AutodiscoverResult class.

public AutodiscoverResult(CultureInfo,string,string,string);

Initializes a new instance of the AutodiscoverResult class.

public AutodiscoverResult(CultureInfo,string,string,string,ServerInfo[]);

See Also

AutodiscoverResult Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


AutodiscoverResult Constructor (CultureInfo, String, String, String)

Initializes a new instance of the AutodiscoverResult class.

public AutodiscoverResult(
CultureInfo culture,
string displayName,
string emailAddress,
string redirect
);

Parameters

culture
Specifies the client culture, which is used to localize error messages.
displayName
Contains the user's display name in the directory service.
emailAddress
Contains the SMTP email address of the user and is used to identify the user's mailbox in the network.
redirect
Specifies the SMTP address of the requested user.

See Also

AutodiscoverResult Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | AutodiscoverResult Constructor Overload List


AutodiscoverResult Constructor (CultureInfo, String, String, ServerInfo[])

Initializes a new instance of the AutodiscoverResult class.

public AutodiscoverResult(
CultureInfo culture,
string displayName,
string emailAddress,
ServerInfo[] servers
);

Parameters

culture
Specifies the client culture, which is used to localize error messages.
displayName
Contains the user's display name in the directory service.
emailAddress
Contains the SMTP email address of the user and is used to identify the user's mailbox in the network.
servers
Contains array of server settings

See Also

AutodiscoverResult Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | AutodiscoverResult Constructor Overload List


AutodiscoverResult Constructor (CultureInfo, String, String, String, ServerInfo[])

Initializes a new instance of the AutodiscoverResult class.

public AutodiscoverResult(
CultureInfo culture,
string displayName,
string emailAddress,
string redirect,
ServerInfo[] servers
);

Parameters

culture
Specifies the client culture, which is used to localize error messages.
displayName
Contains the user's display name in the directory service.
emailAddress
Contains the SMTP email address of the user and is used to identify the user's mailbox in the network.
redirect
Specifies the SMTP address of the requested user.
servers
Contains array of server settings

See Also

AutodiscoverResult Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | AutodiscoverResult Constructor Overload List


AutodiscoverResult Properties

The properties of the AutodiscoverResult class are listed below. For a complete list of AutodiscoverResult class members, see the AutodiscoverResult Members topic.

Public Instance Properties

Culture | Specifies the client culture, which is used to localize error messages.
DisplayName | Contains the user's display name in the directory service.
EMailAddress | Contains the SMTP email address of the user and is used to identify the user's mailbox in the network.
Redirect | Specifies the SMTP address of the requested user.
Servers | Contains array of server settings

See Also

AutodiscoverResult Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Culture Property

Aspose.Email

AutodiscoverResult.Culture Property

Specifies the client culture, which is used to localize error messages.

public CultureInfo Culture {get;}

See Also

AutodiscoverResult Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


DisplayName Property

Aspose.Email

AutodiscoverResult.DisplayName Property

Contains the user's display name in the directory service.

public string DisplayName {get;}

See Also

AutodiscoverResult Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


EMailAddress Property

Aspose.Email

AutodiscoverResult.EMailAddress Property

Contains the SMTP email address of the user and is used to identify the user's mailbox in the network.

public string EMailAddress {get;}

See Also

AutodiscoverResult Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Redirect Property

Aspose.Email

AutodiscoverResult.Redirect Property

Specifies the SMTP address of the requested user.

public string Redirect {get;}

See Also

AutodiscoverResult Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Servers Property

Aspose.Email

AutodiscoverResult.Servers Property

Contains array of server settings

public ServerInfo[] Servers {get;}

See Also

AutodiscoverResult Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


AutodiscoverResult Methods

The methods of the AutodiscoverResult class are listed below. For a complete list of AutodiscoverResult class members, see the AutodiscoverResult Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a string that represents the current object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AutodiscoverResult Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


AutodiscoverResult.ToString Method

Returns a string that represents the current object.

public override string ToString();

Return Value

A string that represents the current object.

See Also

AutodiscoverResult Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


BehaviorReplacement Enumeration

Specifies how to resolve the conflict that occurs when an object has been changed on both the client and the server. The value specifies which object—the client object or the server object—to keep if there is a conflict.

public enum BehaviorReplacement

Members

Member Name | Description | Value
ClientObjectReplaces | Client object replaces server object. | 0
ServerObjectReplaces | Server object replaces client object. | 1

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Body Class

Specifies a free-form, variable-length data field associated with a stored item on the server.

For a list of all members of this type, see Body Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.Body

public class Body

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Body Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Body Members

Body overview

Public Instance Constructors

Body Constructor Initializes a new instance of the Body class.

Public Instance Properties

Data | The content of the Data element is a string in the format that is specified by the Type property. If the value of the Type is RTF, the value of the Data element is encoded using base64 encoding. If the Truncated property set true, the data in the Data element is truncated. The EstimatedDataSize property provides a rough estimation of the actual size of the complete content of the Data string.
EstimatedDataSize | Specifies an informational estimate of the size of the data associated with the parent element. The EstimatedDataSize element SHOULD be presented whenever the Truncated element is set to TRUE
Part | Contains an integer index into the metadata of the multipart response. This property MUST be present in multipart responses. This property MUST NOT be present in requests or non-multipart responses.
Preview | Contains the Unicode plain text message or message part preview returned to the client.
Truncated | Specifies whether the body of the item has been truncated according to the BodyPreference element indicated by the client. If the value is TRUE, then the body of the item has been truncated. If the value is FALSE, or Truncated property is not set, then the body of the item has not been truncated.
Type | Specifies the format type of the body content of the item.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Body Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Body Constructor

Initializes a new instance of the Body class.

public Body();

See Also

Body Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Body Properties

The properties of the Body class are listed below. For a complete list of Body class members, see the Body Members topic.

Public Instance Properties

Data | The content of the Data element is a string in the format that is specified by the Type property. If the value of the Type is RTF, the value of the Data element is encoded using base64 encoding. If the Truncated property set true, the data in the Data element is truncated. The EstimatedDataSize property provides a rough estimation of the actual size of the complete content of the Data string.
EstimatedDataSize | Specifies an informational estimate of the size of the data associated with the parent element. The EstimatedDataSize element SHOULD be presented whenever the Truncated element is set to TRUE
Part | Contains an integer index into the metadata of the multipart response. This property MUST be present in multipart responses. This property MUST NOT be present in requests or non-multipart responses.
Preview | Contains the Unicode plain text message or message part preview returned to the client.
Truncated | Specifies whether the body of the item has been truncated according to the BodyPreference element indicated by the client. If the value is TRUE, then the body of the item has been truncated. If the value is FALSE, or Truncated property is not set, then the body of the item has not been truncated.
Type | Specifies the format type of the body content of the item.

See Also

Body Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Data Property

Aspose.Email

Body.Data Property

The content of the Data element is a string in the format that is specified by the Type property. If the value of the Type is RTF, the value of the Data element is encoded using base64 encoding. If the Truncated property set true, the data in the Data element is truncated. The EstimatedDataSize property provides a rough estimation of the actual size of the complete content of the Data string.

public string Data {get; set;}

See Also

Body Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


EstimatedDataSize Property

Aspose.Email

Body.EstimatedDataSize Property

Specifies an informational estimate of the size of the data associated with the parent element. The EstimatedDataSize element SHOULD be presented whenever the Truncated element is set to TRUE

public Int32} EstimatedDataSize {get; set;}

See Also

Body Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Part Property

Aspose.Email

Body.Part Property

Contains an integer index into the metadata of the multipart response. This property MUST be present in multipart responses. This property MUST NOT be present in requests or non-multipart responses.

public Int32} Part {get; set;}

See Also

Body Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Preview Property

Aspose.Email

Body.Preview Property

Contains the Unicode plain text message or message part preview returned to the client.

public string Preview {get; set;}

See Also

Body Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Truncated Property

Aspose.Email

Body.Truncated Property

Specifies whether the body of the item has been truncated according to the BodyPreference element indicated by the client. If the value is TRUE, then the body of the item has been truncated. If the value is FALSE, or Truncated property is not set, then the body of the item has not been truncated.

public Boolean} Truncated {get; set;}

See Also

Body Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Type Property

Aspose.Email

Body.Type Property

Specifies the format type of the body content of the item.

public BodyType Type {get; set;}

See Also

Body Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


BodyPart Class

Specifies details about the message part of an e-mail in a response. The BodyPart element MUST be included in a command response when the BodyPartPreference is specified in a request.

For a list of all members of this type, see BodyPart Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.BodyPart

public class BodyPart

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

BodyPart Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


BodyPart Members

BodyPart overview

Public Instance Constructors

BodyPart Constructor Initializes a new instance of the BodyPart class.

Public Instance Properties

Data | The content of the Data element is a string in the format that is specified by the Type property. If the value of the Type is RTF, the value of the Data element is encoded using base64 encoding. If the Truncated property set true, the data in the Data element is truncated. The EstimatedDataSize property provides a rough estimation of the actual size of the complete content of the Data string.
EstimatedDataSize | Specifies an informational estimate of the size of the data associated with the parent element. The EstimatedDataSize element SHOULD be presented whenever the Truncated element is set to TRUE
Preview | Contains the Unicode plain text message or message part preview returned to the client.
Status | Contains a code and description that indicates the success or failure of the operation
Truncated | Specifies whether the body of the item has been truncated according to the BodyPreference element indicated by the client. If the value is TRUE, then the body of the item has been truncated. If the value is FALSE, or Truncated property is not set, then the body of the item has not been truncated.
Type | Specifies the format type of the body content of the item.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BodyPart Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


BodyPart Constructor

Initializes a new instance of the BodyPart class.

public BodyPart();

See Also

BodyPart Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


BodyPart Properties

The properties of the BodyPart class are listed below. For a complete list of BodyPart class members, see the BodyPart Members topic.

Public Instance Properties

Data | The content of the Data element is a string in the format that is specified by the Type property. If the value of the Type is RTF, the value of the Data element is encoded using base64 encoding. If the Truncated property set true, the data in the Data element is truncated. The EstimatedDataSize property provides a rough estimation of the actual size of the complete content of the Data string.
EstimatedDataSize | Specifies an informational estimate of the size of the data associated with the parent element. The EstimatedDataSize element SHOULD be presented whenever the Truncated element is set to TRUE
Preview | Contains the Unicode plain text message or message part preview returned to the client.
Status | Contains a code and description that indicates the success or failure of the operation
Truncated | Specifies whether the body of the item has been truncated according to the BodyPreference element indicated by the client. If the value is TRUE, then the body of the item has been truncated. If the value is FALSE, or Truncated property is not set, then the body of the item has not been truncated.
Type | Specifies the format type of the body content of the item.

See Also

BodyPart Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Data Property

Aspose.Email

BodyPart.Data Property

The content of the Data element is a string in the format that is specified by the Type property. If the value of the Type is RTF, the value of the Data element is encoded using base64 encoding. If the Truncated property set true, the data in the Data element is truncated. The EstimatedDataSize property provides a rough estimation of the actual size of the complete content of the Data string.

public string Data {get; set;}

See Also

BodyPart Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


EstimatedDataSize Property

Aspose.Email

BodyPart.EstimatedDataSize Property

Specifies an informational estimate of the size of the data associated with the parent element. The EstimatedDataSize element SHOULD be presented whenever the Truncated element is set to TRUE

public Int32} EstimatedDataSize {get; set;}

See Also

BodyPart Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Preview Property

Aspose.Email

BodyPart.Preview Property

Contains the Unicode plain text message or message part preview returned to the client.

public string Preview {get; set;}

See Also

BodyPart Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Status Property

Aspose.Email

BodyPart.Status Property

Contains a code and description that indicates the success or failure of the operation

public Status Status {get; set;}

See Also

BodyPart Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Truncated Property

Aspose.Email

BodyPart.Truncated Property

Specifies whether the body of the item has been truncated according to the BodyPreference element indicated by the client. If the value is TRUE, then the body of the item has been truncated. If the value is FALSE, or Truncated property is not set, then the body of the item has not been truncated.

public Boolean} Truncated {get; set;}

See Also

BodyPart Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Type Property

Aspose.Email

BodyPart.Type Property

Specifies the format type of the body content of the item.

public BodyType Type {get; set;}

See Also

BodyPart Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


BodyPreference Class

Contains preference information related to the type and size of information that is returned from searching, synchronizing, or fetching.

For a list of all members of this type, see BodyPreference Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.BodyPreference

public class BodyPreference

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

BodyPreference Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


BodyPreference Members

BodyPreference overview

Public Instance Constructors

BodyPreference Constructor Initializes a new instance of the BodyPreference class.

Public Instance Properties

AllOrNone | A client can include multiple BodyPreference elements in a command request with different values for the Type element (section 2.2.2.22.4). By default, the server returns the data truncated to the size requested by TruncationSize for the Type element that matches the native storage format of the item's Body element. But, if the client also includes the AllOrNone element with a value of TRUE along with the TruncationSize element, it is instructing the server not to return a truncated response for that type when the size (in bytes) of the available data exceeds the value of the TruncationSize element. For example, a client can use these two elements to signify that it cannot process partial Rich Text Format (RTF) data (a Type element value of 3). In this case, if the client has specified multiple BodyPreference elements, the server selects the next BodyPreference element that will return the maximum amount of body text to the client. Assume that the client specifies two BodyPreference elements. If the AllOrNone element is not defined, then the truncated or non-truncated content is searched, synchronized, or retrieved as if the value was set to FALSE.
Preview | Specifies the maximum length of the Unicode plain text message or message part preview to be returned to the client. This property MUST have a value set from 0 to 255, inclusive.
TruncationSize | Specifies the size which is used by a server to truncate returned data. The maximum value for TruncationSize is 4,294,967,295. If the TruncationSize element is not defined, the entire content is used for the request.
Type | Specifies the format type of the body content of the item.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BodyPreference Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


BodyPreference Constructor

Initializes a new instance of the BodyPreference class.

public BodyPreference();

See Also

BodyPreference Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


BodyPreference Properties

The properties of the BodyPreference class are listed below. For a complete list of BodyPreference class members, see the BodyPreference Members topic.

Public Instance Properties

AllOrNone | A client can include multiple BodyPreference elements in a command request with different values for the Type element (section 2.2.2.22.4). By default, the server returns the data truncated to the size requested by TruncationSize for the Type element that matches the native storage format of the item's Body element. But, if the client also includes the AllOrNone element with a value of TRUE along with the TruncationSize element, it is instructing the server not to return a truncated response for that type when the size (in bytes) of the available data exceeds the value of the TruncationSize element. For example, a client can use these two elements to signify that it cannot process partial Rich Text Format (RTF) data (a Type element value of 3). In this case, if the client has specified multiple BodyPreference elements, the server selects the next BodyPreference element that will return the maximum amount of body text to the client. Assume that the client specifies two BodyPreference elements. If the AllOrNone element is not defined, then the truncated or non-truncated content is searched, synchronized, or retrieved as if the value was set to FALSE.
Preview | Specifies the maximum length of the Unicode plain text message or message part preview to be returned to the client. This property MUST have a value set from 0 to 255, inclusive.
TruncationSize | Specifies the size which is used by a server to truncate returned data. The maximum value for TruncationSize is 4,294,967,295. If the TruncationSize element is not defined, the entire content is used for the request.
Type | Specifies the format type of the body content of the item.

See Also

BodyPreference Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


AllOrNone Property

Aspose.Email

BodyPreference.AllOrNone Property

A client can include multiple BodyPreference elements in a command request with different values for the Type element (section 2.2.2.22.4). By default, the server returns the data truncated to the size requested by TruncationSize for the Type element that matches the native storage format of the item's Body element. But, if the client also includes the AllOrNone element with a value of TRUE along with the TruncationSize element, it is instructing the server not to return a truncated response for that type when the size (in bytes) of the available data exceeds the value of the TruncationSize element. For example, a client can use these two elements to signify that it cannot process partial Rich Text Format (RTF) data (a Type element value of 3). In this case, if the client has specified multiple BodyPreference elements, the server selects the next BodyPreference element that will return the maximum amount of body text to the client. Assume that the client specifies two BodyPreference elements. If the AllOrNone element is not defined, then the truncated or non-truncated content is searched, synchronized, or retrieved as if the value was set to FALSE.

public Boolean} AllOrNone {get; set;}

See Also

BodyPreference Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Preview Property

Aspose.Email

BodyPreference.Preview Property

Specifies the maximum length of the Unicode plain text message or message part preview to be returned to the client. This property MUST have a value set from 0 to 255, inclusive.

public Int32} Preview {get; set;}

See Also

BodyPreference Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


TruncationSize Property

Aspose.Email

BodyPreference.TruncationSize Property

Specifies the size which is used by a server to truncate returned data. The maximum value for TruncationSize is 4,294,967,295. If the TruncationSize element is not defined, the entire content is used for the request.

public Int32} TruncationSize {get; set;}

See Also

BodyPreference Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Type Property

Aspose.Email

BodyPreference.Type Property

Specifies the format type of the body content of the item.

public BodyType Type {get; set;}

See Also

BodyPreference Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


BodyType Enumeration

Specifies the format type of the body content of the item.

public enum BodyType

Members

Member Name | Description | Value
Text | Body type is plain text | 1
HTML | Body type is HTML | 2
RTF | Body type is RTF | 3
MIME | Body type is MIME | 4

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


CertificateRetrieval Enumeration

Specifies whether S/MIME certificates SHOULD be returned by the server for each resolved recipient.

public enum CertificateRetrieval

Members

Member Name | Description | Value
DoNotRetrieve | Do not retrieve certificates for the recipient (default). | 1
RetrieveFull | Retrieve the full certificate for each resolved recipient. | 2
RetrieveMini | Retrieve the mini certificate for each resolved recipient. | 3

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


CertificateStatuses Class

Indicates whether certificate was successfully validated.

For a list of all members of this type, see CertificateStatuses Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.CertificateStatuses

public class CertificateStatuses

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

CertificateStatuses Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


CertificateStatuses Members

CertificateStatuses overview

Public Instance Constructors

CertificateStatuses Constructor Initializes a new instance of the CertificateStatuses class.

Public Instance Properties

Statuses Indicates the result of a validation.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a string which concatinated statuses

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CertificateStatuses Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


CertificateStatuses Constructor

Initializes a new instance of the CertificateStatuses class.

public CertificateStatuses();

See Also

CertificateStatuses Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


CertificateStatuses Properties

The properties of the CertificateStatuses class are listed below. For a complete list of CertificateStatuses class members, see the CertificateStatuses Members topic.

Public Instance Properties

Statuses Indicates the result of a validation.

See Also

CertificateStatuses Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Statuses Property

Aspose.Email

CertificateStatuses.Statuses Property

Indicates the result of a validation.

public Status} Statuses {get;}

See Also

CertificateStatuses Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


CertificateStatuses Methods

The methods of the CertificateStatuses class are listed below. For a complete list of CertificateStatuses class members, see the CertificateStatuses Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a string which concatinated statuses

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

CertificateStatuses Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


CertificateStatuses.ToString Method

Returns a string which concatinated statuses

public override string ToString();

Return Value

A string that represents the current object.

See Also

CertificateStatuses Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


CommandCodes Enumeration

The following table provides the numeric codes that correspond to the ActiveSync commands. The numeric code is used in the Command code field of the base64 encoded URI to specify the command.

public enum CommandCodes

Members

Member Name | Description | Value
Undefined | Command code is not defined. | -3
Options | The OPTIONS command, is used to discover what protocol versions are supported, and which protocol commands are supported on the server. | -2
Autodiscover | The Autodiscover command facilitates the discovery of core account configuration information by using the user's Simple Mail Transfer Protocol (SMTP) address as the primary input. | -1
Sync | Synchronizes changes in a folder between the client and the server. | 0
SendMail | Sends mail to the server. This command is issued in the HTTP POST command's URI, and does not contain an XML body. The body will instead contain the MIME message. | 1
SmartForward | Forwards a Message object without retrieving the full Message object from the server. | 2
SmartReply | Replies to a Message object without retrieving the full Message object from the server. | 3
GetAttachment | Retrieves an e-mail attachment from the server. | 4
FolderSync | Synchronizes the folder hierarchy but does not synchronize the items in the folders. | 9
FolderCreate | Creates an e-mail, calendar, or contacts folder on the server. | 10
FolderDelete | Deletes a folder from the server. | 11
FolderUpdate | Moves a folder from one location to another on the server and is used to rename folders. | 12
MoveItems | Moves items from one folder to another. | 13
GetItemEstimate | Gets an estimate of the number of items in a folder that is synchronized. | 14
MeetingResponse | Used to accept, tentatively accept, or decline a meeting request in the user's Inbox folder. | 15
Search | Finds and retrieves information about contacts and recipients in the Global Address List. | 16
Settings | Supports getting and setting global properties, such as Out of Office (OOF) and device information. | 17
Ping | Requests that the server monitor specified folders for changes that would require the client to resynchronize. | 18
ItemOperations | Identifies the body of the request or response as containing a set of commands operating on items. | 19
Provision | Gets the security policy settings set by the server administrator, such as the user's minimum password length requirement. | 20
ResolveRecipients | Resolves a list of supplied recipients and optionally fetches their S/MIME certificates so that clients can send encrypted messages. | 21
ValidateCert | Validates a certificate that has been received through an S/MIME mail. | 22

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


CommandParameters Enumeration

Command parameters.

public enum CommandParameters

Members

Member Name | Description | Value
AttachmentName | A string that specifies the name of the attachment file to be retrieved. Used By: GetAttachment | 0
CollectionId | A string that specifies the server ID of the folder that contains the Message object to be forwarded or replied to. Used By: SmartForward, SmartReply | 1
ItemId | A string that specifies the server ID of the Message object to be forwarded or replied to. Used By: SmartForward, SmartReply | 3
LongId | A string that references a result set that was returned in the Search command response. Used By: SmartForward, SmartReply | 4
Occurrence | A string that specifies the ID of a particular occurrence in a recurring meeting. Used By: SmartForward, SmartReply | 6
Options | A single-byte bitmask that specifies command options. See the table below for valid flags for this bitmask. Used By: SmartReply, SmartForward, SendMail, ItemOperations | 7
User | A string that specifies the user ID in a format that can be logged in the Web server log. Used By: Any command | 8

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


DataContainer Class

Contains data for a particular object, such as a contact, email message, calendar appointment, or task item. The DataContainer can be used to change items, add items, or fetch items on the client device or server.

For a list of all members of this type, see DataContainer Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.DataContainer

public class DataContainer : 0, Culture=neutral, PublicKeyToken=null]], IEnumerable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DataContainer Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


DataContainer Members

DataContainer overview

Public Instance Constructors

DataContainer Overloaded. Initializes a new instance of the DataContainer class.

Public Instance Properties

BinaryData | Specifies if data is binary.
ElementName | Name of the element, whose data are contained in the data container.
Item | Overloaded. Gets DataContainer for selected element If quantity of DataContainers more then one, AsposeException rises.
Namespace | NameSpace of the element, whose data are contained in the data container.
Parent | Parent DataContainer
Prefix | Prefix in xml node for the element
SubItems | Copies the sub-elements of the ApplicationData to a new List.
Value | Value of the element

Public Instance Methods

Add | Overloaded. Adds data of element in xml format to the DataContainer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetApplicationDataList | Overloaded. Gets list of DataContainers for selected element
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a string that represents the current object.

Protected Instance Properties

Item Overloaded. Gets DataContainer for selected element

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


DataContainer Constructor

Initializes a new instance of the DataContainer class.

Overload List

Initializes a new instance of the DataContainer class.

public DataContainer(string,Namespace);

Initializes a new instance of the DataContainer class.

public DataContainer(string,Namespace,DataContainer);

Initializes a new instance of the DataContainer class.

public DataContainer(string,Namespace,DataContainer,string);

Initializes a new instance of the DataContainer class.

public DataContainer(string,Namespace,DataContainer,string,bool);

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


DataContainer Constructor (String, Namespace)

Initializes a new instance of the DataContainer class.

public DataContainer(
string elementName,
Namespace nameSpace
);

Parameters

elementName
Name of the element, whose data are contained in the data container.
nameSpace
NameSpace of the element, whose data are contained in the data container.

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | DataContainer Constructor Overload List


DataContainer Constructor (String, Namespace, DataContainer)

Initializes a new instance of the DataContainer class.

public DataContainer(
string elementName,
Namespace nameSpace,
DataContainer parent
);

Parameters

elementName
Name of the element, whose data are contained in the data container.
nameSpace
NameSpace of the element, whose data are contained in the data container.
parent
Parent DataContainer

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | DataContainer Constructor Overload List


DataContainer Constructor (String, Namespace, DataContainer, String)

Initializes a new instance of the DataContainer class.

public DataContainer(
string elementName,
Namespace nameSpace,
DataContainer parent,
string value
);

Parameters

elementName
Name of the element, whose data are contained in the data container.
nameSpace
NameSpace of the element, whose data are contained in the data container.
parent
Parent DataContainer
value
Value of the element

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | DataContainer Constructor Overload List


DataContainer Constructor (String, Namespace, DataContainer, String, Boolean)

Initializes a new instance of the DataContainer class.

public DataContainer(
string elementName,
Namespace nameSpace,
DataContainer parent,
string value,
bool binaryData
);

Parameters

elementName
Name of the element, whose data are contained in the data container.
nameSpace
NameSpace of the element, whose data are contained in the data container.
parent
Parent DataContainer
value
Value of the element
binaryData
Specifies if data is binary.

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | DataContainer Constructor Overload List


DataContainer Properties

The properties of the DataContainer class are listed below. For a complete list of DataContainer class members, see the DataContainer Members topic.

Public Instance Properties

BinaryData | Specifies if data is binary.
ElementName | Name of the element, whose data are contained in the data container.
Item | Overloaded. Gets DataContainer for selected element If quantity of DataContainers more then one, AsposeException rises.
Namespace | NameSpace of the element, whose data are contained in the data container.
Parent | Parent DataContainer
Prefix | Prefix in xml node for the element
SubItems | Copies the sub-elements of the ApplicationData to a new List.
Value | Value of the element

Protected Instance Properties

Item Overloaded. Gets DataContainer for selected element

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


BinaryData Property

Aspose.Email

DataContainer.BinaryData Property

Specifies if data is binary.

public bool BinaryData {get; set;}

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ElementName Property

Aspose.Email

DataContainer.ElementName Property

Name of the element, whose data are contained in the data container.

public string ElementName {get;}

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Item Property

Aspose.Email

DataContainer.Item Property

Gets DataContainer for selected element If quantity of DataContainers more then one, AsposeException rises.

Overload List

Gets DataContainer for selected element If quantity of DataContainers more then one, AsposeException rises.

public DataContainer this[Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.AirSync] {get;}

Gets DataContainer for selected element If quantity of DataContainers more then one, AsposeException rises.

public DataContainer this[Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.AirSyncBase] {get;}

Gets DataContainer for selected element If quantity of DataContainers more then one, AsposeException rises.

public DataContainer this[Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.Calendar] {get;}

Gets DataContainer for selected element If quantity of DataContainers more then one, AsposeException rises.

public DataContainer this[Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.Contacts] {get;}

Gets DataContainer for selected element If quantity of DataContainers more then one, AsposeException rises.

public DataContainer this[Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.Contacts2] {get;}

Gets DataContainer for selected element If quantity of DataContainers more then one, AsposeException rises.

public DataContainer this[Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.DocumentLibrary] {get;}

Gets DataContainer for selected element If quantity of DataContainers more then one, AsposeException rises.

public DataContainer this[Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.Email] {get;}

Gets DataContainer for selected element If quantity of DataContainers more then one, AsposeException rises.

public DataContainer this[Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.Email2] {get;}

Gets DataContainer for selected element If quantity of DataContainers more then one, AsposeException rises.

public DataContainer this[Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.GAL] {get;}

Gets DataContainer for selected element If quantity of DataContainers more then one, AsposeException rises.

public DataContainer this[Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.ItemOperations] {get;}

Gets DataContainer for selected element If quantity of DataContainers more then one, AsposeException rises.

public DataContainer this[Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.Notes] {get;}

Gets DataContainer for selected element If quantity of DataContainers more then one, AsposeException rises.

public DataContainer this[Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.RightsManagement] {get;}

Gets DataContainer for selected element If quantity of DataContainers more then one, AsposeException rises.

public DataContainer this[Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.Search] {get;}

Gets DataContainer for selected element If quantity of DataContainers more then one, AsposeException rises.

public DataContainer this[Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.Settings] {get;}

Gets DataContainer for selected element If quantity of DataContainers more then one, AsposeException rises.

public DataContainer this[Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.Tasks] {get;}

Gets DataContainer for selected element

protected DataContainer this[System.Type, int] {get;}

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Item Property (AirSync)

Aspose.Email

DataContainer.Item Property (AirSync)

Gets DataContainer for selected element If quantity of DataContainers more then one, AsposeException rises.

public DataContainer this[
Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.AirSync elementName
] {get;}

Parameters

elementName
Element name

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | DataContainer.Item Overload List


Item Property (AirSyncBase)

Aspose.Email

DataContainer.Item Property (AirSyncBase)

Gets DataContainer for selected element If quantity of DataContainers more then one, AsposeException rises.

public DataContainer this[
Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.AirSyncBase elementName
] {get;}

Parameters

elementName
Element name

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | DataContainer.Item Overload List


Item Property (Calendar)

Aspose.Email

DataContainer.Item Property (Calendar)

Gets DataContainer for selected element If quantity of DataContainers more then one, AsposeException rises.

public DataContainer this[
Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.Calendar elementName
] {get;}

Parameters

elementName
Element name

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | DataContainer.Item Overload List


Item Property (Contacts)

Aspose.Email

DataContainer.Item Property (Contacts)

Gets DataContainer for selected element If quantity of DataContainers more then one, AsposeException rises.

public DataContainer this[
Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.Contacts elementName
] {get;}

Parameters

elementName
Element name

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | DataContainer.Item Overload List


Item Property (Contacts2)

Aspose.Email

DataContainer.Item Property (Contacts2)

Gets DataContainer for selected element If quantity of DataContainers more then one, AsposeException rises.

public DataContainer this[
Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.Contacts2 elementName
] {get;}

Parameters

elementName
Element name

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | DataContainer.Item Overload List


Item Property (DocumentLibrary)

Aspose.Email

DataContainer.Item Property (DocumentLibrary)

Gets DataContainer for selected element If quantity of DataContainers more then one, AsposeException rises.

public DataContainer this[
Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.DocumentLibrary elementName
] {get;}

Parameters

elementName
Element name

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | DataContainer.Item Overload List


Item Property (Email)

Aspose.Email

DataContainer.Item Property (Email)

Gets DataContainer for selected element If quantity of DataContainers more then one, AsposeException rises.

public DataContainer this[
Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.Email elementName
] {get;}

Parameters

elementName
Element name

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | DataContainer.Item Overload List


Item Property (Email2)

Aspose.Email

DataContainer.Item Property (Email2)

Gets DataContainer for selected element If quantity of DataContainers more then one, AsposeException rises.

public DataContainer this[
Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.Email2 elementName
] {get;}

Parameters

elementName
Element name

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | DataContainer.Item Overload List


Item Property (GAL)

Aspose.Email

DataContainer.Item Property (GAL)

Gets DataContainer for selected element If quantity of DataContainers more then one, AsposeException rises.

public DataContainer this[
Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.GAL elementName
] {get;}

Parameters

elementName
Element name

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | DataContainer.Item Overload List


Item Property (ItemOperations)

Aspose.Email

DataContainer.Item Property (ItemOperations)

Gets DataContainer for selected element If quantity of DataContainers more then one, AsposeException rises.

public DataContainer this[
Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.ItemOperations elementName
] {get;}

Parameters

elementName
Element name

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | DataContainer.Item Overload List


Item Property (Notes)

Aspose.Email

DataContainer.Item Property (Notes)

Gets DataContainer for selected element If quantity of DataContainers more then one, AsposeException rises.

public DataContainer this[
Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.Notes elementName
] {get;}

Parameters

elementName
Element name

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | DataContainer.Item Overload List


Item Property (RightsManagement)

Aspose.Email

DataContainer.Item Property (RightsManagement)

Gets DataContainer for selected element If quantity of DataContainers more then one, AsposeException rises.

public DataContainer this[
Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.RightsManagement elementName
] {get;}

Parameters

elementName
Element name

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | DataContainer.Item Overload List


Item Property (Search)

Aspose.Email

DataContainer.Item Property (Search)

Gets DataContainer for selected element If quantity of DataContainers more then one, AsposeException rises.

public DataContainer this[
Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.Search elementName
] {get;}

Parameters

elementName
Element name

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | DataContainer.Item Overload List


Item Property (Settings)

Aspose.Email

DataContainer.Item Property (Settings)

Gets DataContainer for selected element If quantity of DataContainers more then one, AsposeException rises.

public DataContainer this[
Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.Settings elementName
] {get;}

Parameters

elementName
Element name

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | DataContainer.Item Overload List


Item Property (Tasks)

Aspose.Email

DataContainer.Item Property (Tasks)

Gets DataContainer for selected element If quantity of DataContainers more then one, AsposeException rises.

public DataContainer this[
Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.Tasks elementName
] {get;}

Parameters

elementName
Element name

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | DataContainer.Item Overload List


Item Property (Type, Int32)

Aspose.Email

DataContainer.Item Property (Type, Int32)

Gets DataContainer for selected element

protected DataContainer this[
System.Type elementType,
int iElementName
] {get;}

Parameters

elementType
iElementName
Integer representation for element name

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | DataContainer.Item Overload List


Namespace Property

Aspose.Email

DataContainer.Namespace Property

NameSpace of the element, whose data are contained in the data container.

public Namespace Namespace {get;}

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Parent Property

Aspose.Email

DataContainer.Parent Property

Parent DataContainer

public DataContainer Parent {get;}

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Prefix Property

Aspose.Email

DataContainer.Prefix Property

Prefix in xml node for the element

public string Prefix {get;}

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SubItems Property

Aspose.Email

DataContainer.SubItems Property

Copies the sub-elements of the ApplicationData to a new List.

public DataContainer} SubItems {get;}

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Value Property

Aspose.Email

DataContainer.Value Property

Value of the element

public string Value {get; set;}

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


DataContainer Methods

The methods of the DataContainer class are listed below. For a complete list of DataContainer class members, see the DataContainer Members topic.

Public Instance Methods

Add | Overloaded. Adds data of element in xml format to the DataContainer.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetApplicationDataList | Overloaded. Gets list of DataContainers for selected element
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a string that represents the current object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Add Method

Aspose.Email

DataContainer.Add Method

Adds empty DataContainer for element.

Overload List

Adds empty DataContainer for element.

public DataContainer Add(int,Namespace);

Adds data of element to the DataContainer.

public DataContainer Add(int,string,Namespace);

Adds data of element to the DataContainer.

public DataContainer Add(int,string,bool,Namespace);

Adds data of element in xml format to the DataContainer.

public DataContainer Add(string);

Adds data of element in xml format to the DataContainer.

public DataContainer Add(XmlNode);

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


DataContainer.Add Method (Int32, Namespace)

Adds empty DataContainer for element.

public DataContainer Add(
int element,
Namespace ns
);

Parameters

element
Name of the element
ns
NameSpace of the element

Return Value

Returns empty DataContainer.

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | DataContainer.Add Overload List


DataContainer.Add Method (Int32, String, Namespace)

Adds data of element to the DataContainer.

public DataContainer Add(
int element,
string value,
Namespace ns
);

Parameters

element
Name of the element, whose data are contained in the data container.
value
Value of the element
ns
NameSpace of the element, whose data are contained in the data container.

Return Value

Returns the DataContainer with added data.

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | DataContainer.Add Overload List


DataContainer.Add Method (Int32, String, Boolean, Namespace)

Adds data of element to the DataContainer.

public DataContainer Add(
int element,
string value,
bool binaryData,
Namespace ns
);

Parameters

element
Name of the element, whose data are contained in the data container.
value
Value of the element
binaryData
Specifies if data is binary.
ns
NameSpace of the element, whose data are contained in the data container.

Return Value

Returns the DataContainer with added data.

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | DataContainer.Add Overload List


DataContainer.Add Method (String)

Adds data of element in xml format to the DataContainer.

public DataContainer Add(
string applicationDataXml
);

Parameters

applicationDataXml
Contains data of element in xml format

Return Value

Returns the DataContainer with added data.

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | DataContainer.Add Overload List


DataContainer.Add Method (XmlNode)

Adds data of element in xml format to the DataContainer.

public DataContainer Add(
XmlNode node
);

Parameters

node
Contains data of element in xml format

Return Value

Returns the DataContainer with added data.

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | DataContainer.Add Overload List


GetApplicationDataList Method

Aspose.Email

DataContainer.GetApplicationDataList Method

Gets list of DataContainers for selected element

Overload List

Gets list of DataContainers for selected element

public DataContainer} GetApplicationDataList(AirSync);

Gets list of DataContainers for selected element

public DataContainer} GetApplicationDataList(AirSyncBase);

Gets list of DataContainers for selected element

public DataContainer} GetApplicationDataList(Calendar);

Gets list of DataContainers for selected element

public DataContainer} GetApplicationDataList(Contacts);

Gets list of DataContainers for selected element

public DataContainer} GetApplicationDataList(Contacts2);

Gets list of DataContainers for selected element

public DataContainer} GetApplicationDataList(DocumentLibrary);

Gets list of DataContainers for selected element

public DataContainer} GetApplicationDataList(Email);

Gets list of DataContainers for selected element

public DataContainer} GetApplicationDataList(Email2);

Gets list of DataContainers for selected element

public DataContainer} GetApplicationDataList(GAL);

Gets list of DataContainers for selected element

public DataContainer} GetApplicationDataList(ItemOperations);

Gets list of DataContainers for selected element

public DataContainer} GetApplicationDataList(Notes);

Gets list of DataContainers for selected element

public DataContainer} GetApplicationDataList(RightsManagement);

Gets list of DataContainers for selected element

public DataContainer} GetApplicationDataList(Search);

Gets list of DataContainers for selected element

public DataContainer} GetApplicationDataList(Settings);

Gets list of DataContainers for selected element

public DataContainer} GetApplicationDataList(Tasks);

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


DataContainer.GetApplicationDataList Method (AirSync)

Gets list of DataContainers for selected element

public List<DataContainer> GetApplicationDataList(
AirSync elementName
);

Parameters

elementName
Element name

Return Value

Returns list of DataContainers for selected element

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | DataContainer.GetApplicationDataList Overload List


DataContainer.GetApplicationDataList Method (AirSyncBase)

Gets list of DataContainers for selected element

public List<DataContainer> GetApplicationDataList(
AirSyncBase elementName
);

Parameters

elementName
Element name

Return Value

Returns list of DataContainers for selected element

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | DataContainer.GetApplicationDataList Overload List


DataContainer.GetApplicationDataList Method (Calendar)

Gets list of DataContainers for selected element

public List<DataContainer> GetApplicationDataList(
Calendar elementName
);

Parameters

elementName
Element name

Return Value

Returns list of DataContainers for selected element

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | DataContainer.GetApplicationDataList Overload List


DataContainer.GetApplicationDataList Method (Contacts)

Gets list of DataContainers for selected element

public List<DataContainer> GetApplicationDataList(
Contacts elementName
);

Parameters

elementName
Element name

Return Value

Returns list of DataContainers for selected element

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | DataContainer.GetApplicationDataList Overload List


DataContainer.GetApplicationDataList Method (Contacts2)

Gets list of DataContainers for selected element

public List<DataContainer> GetApplicationDataList(
Contacts2 elementName
);

Parameters

elementName
Element name

Return Value

Returns list of DataContainers for selected element

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | DataContainer.GetApplicationDataList Overload List


DataContainer.GetApplicationDataList Method (DocumentLibrary)

Gets list of DataContainers for selected element

public List<DataContainer> GetApplicationDataList(
DocumentLibrary elementName
);

Parameters

elementName
Element name

Return Value

Returns list of DataContainers for selected element

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | DataContainer.GetApplicationDataList Overload List


DataContainer.GetApplicationDataList Method (Email)

Gets list of DataContainers for selected element

public List<DataContainer> GetApplicationDataList(
Email elementName
);

Parameters

elementName
Element name

Return Value

Returns list of DataContainers for selected element

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | DataContainer.GetApplicationDataList Overload List


DataContainer.GetApplicationDataList Method (Email2)

Gets list of DataContainers for selected element

public List<DataContainer> GetApplicationDataList(
Email2 elementName
);

Parameters

elementName
Element name

Return Value

Returns list of DataContainers for selected element

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | DataContainer.GetApplicationDataList Overload List


DataContainer.GetApplicationDataList Method (GAL)

Gets list of DataContainers for selected element

public List<DataContainer> GetApplicationDataList(
GAL elementName
);

Parameters

elementName
Element name

Return Value

Returns list of DataContainers for selected element

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | DataContainer.GetApplicationDataList Overload List


DataContainer.GetApplicationDataList Method (ItemOperations)

Gets list of DataContainers for selected element

public List<DataContainer> GetApplicationDataList(
ItemOperations elementName
);

Parameters

elementName
Element name

Return Value

Returns list of DataContainers for selected element

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | DataContainer.GetApplicationDataList Overload List


DataContainer.GetApplicationDataList Method (Notes)

Gets list of DataContainers for selected element

public List<DataContainer> GetApplicationDataList(
Notes elementName
);

Parameters

elementName
Element name

Return Value

Returns list of DataContainers for selected element

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | DataContainer.GetApplicationDataList Overload List


DataContainer.GetApplicationDataList Method (RightsManagement)

Gets list of DataContainers for selected element

public List<DataContainer> GetApplicationDataList(
RightsManagement elementName
);

Parameters

elementName
Element name

Return Value

Returns list of DataContainers for selected element

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | DataContainer.GetApplicationDataList Overload List


DataContainer.GetApplicationDataList Method (Search)

Gets list of DataContainers for selected element

public List<DataContainer> GetApplicationDataList(
Search elementName
);

Parameters

elementName
Element name

Return Value

Returns list of DataContainers for selected element

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | DataContainer.GetApplicationDataList Overload List


DataContainer.GetApplicationDataList Method (Settings)

Gets list of DataContainers for selected element

public List<DataContainer> GetApplicationDataList(
Settings elementName
);

Parameters

elementName
Element name

Return Value

Returns list of DataContainers for selected element

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | DataContainer.GetApplicationDataList Overload List


DataContainer.GetApplicationDataList Method (Tasks)

Gets list of DataContainers for selected element

public List<DataContainer> GetApplicationDataList(
Tasks elementName
);

Parameters

elementName
Element name

Return Value

Returns list of DataContainers for selected element

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | DataContainer.GetApplicationDataList Overload List


DataContainer.GetEnumerator Method

Returns an enumerator that iterates through the collection.

public IEnumerator<DataContainer> GetEnumerator();

Return Value

A IEnumerator`1 that can be used to iterate through the collection.

Implements

IEnumerable`1.GetEnumerator

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


DataContainer.ToString Method

Returns a string that represents the current object.

public override string ToString();

Return Value

A string that represents the current object.

See Also

DataContainer Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


DeviceInformation Class

Request that is used for sending the client device's properties to the server.

For a list of all members of this type, see DeviceInformation Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.DeviceInformation

public class DeviceInformation

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DeviceInformation Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


DeviceInformation Members

DeviceInformation overview

Public Instance Constructors

DeviceInformation Constructor Initializes a new instance of the DeviceInformation class.

Public Instance Properties

EnableOutboundSMS | Whether to enable outbound SMS
FriendlyName | Device friendly name
IMEI | International Mobile Equipment Identity (IMEI)
MobileOperator | Mobile operator name
Model | Device model
OS | Device operating system
OSLanguage | Device operating system language
PhoneNumber | Telephone number
UserAgent | User Agent

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DeviceInformation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


DeviceInformation Constructor

Initializes a new instance of the DeviceInformation class.

public DeviceInformation();

See Also

DeviceInformation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


DeviceInformation Properties

The properties of the DeviceInformation class are listed below. For a complete list of DeviceInformation class members, see the DeviceInformation Members topic.

Public Instance Properties

EnableOutboundSMS | Whether to enable outbound SMS
FriendlyName | Device friendly name
IMEI | International Mobile Equipment Identity (IMEI)
MobileOperator | Mobile operator name
Model | Device model
OS | Device operating system
OSLanguage | Device operating system language
PhoneNumber | Telephone number
UserAgent | User Agent

See Also

DeviceInformation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


EnableOutboundSMS Property

Aspose.Email

DeviceInformation.EnableOutboundSMS Property

Whether to enable outbound SMS

public Boolean} EnableOutboundSMS {get; set;}

See Also

DeviceInformation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


FriendlyName Property

Aspose.Email

DeviceInformation.FriendlyName Property

Device friendly name

public string FriendlyName {get; set;}

See Also

DeviceInformation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


IMEI Property

Aspose.Email

DeviceInformation.IMEI Property

International Mobile Equipment Identity (IMEI)

public string IMEI {get; set;}

See Also

DeviceInformation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


MobileOperator Property

Aspose.Email

DeviceInformation.MobileOperator Property

Mobile operator name

public string MobileOperator {get; set;}

See Also

DeviceInformation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Model Property

Aspose.Email

DeviceInformation.Model Property

Device model

public string Model {get; set;}

See Also

DeviceInformation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


OS Property

Aspose.Email

DeviceInformation.OS Property

Device operating system

public string OS {get; set;}

See Also

DeviceInformation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


OSLanguage Property

Aspose.Email

DeviceInformation.OSLanguage Property

Device operating system language

public string OSLanguage {get; set;}

See Also

DeviceInformation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


PhoneNumber Property

Aspose.Email

DeviceInformation.PhoneNumber Property

Telephone number

public string PhoneNumber {get; set;}

See Also

DeviceInformation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


UserAgent Property

Aspose.Email

DeviceInformation.UserAgent Property

User Agent

public string UserAgent {get; set;}

See Also

DeviceInformation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


DevicePasswordRequest Class

Specifies the request to set recovery password of the client device by the server. To clear an existing recovery password, the client MUST send an empty Password.

For a list of all members of this type, see DevicePasswordRequest Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.DevicePasswordRequest

public class DevicePasswordRequest

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DevicePasswordRequest Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


DevicePasswordRequest Members

DevicePasswordRequest overview

Public Instance Constructors

DevicePasswordRequest Constructor Initializes a new instance of the DevicePasswordRequest class.

Public Instance Properties

Password Specifies the recovery password of the client device, which is stored by the server. The value of the DevicePassword has a maximum length of 255 characters.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DevicePasswordRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


DevicePasswordRequest Constructor

Initializes a new instance of the DevicePasswordRequest class.

public DevicePasswordRequest();

See Also

DevicePasswordRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


DevicePasswordRequest Properties

The properties of the DevicePasswordRequest class are listed below. For a complete list of DevicePasswordRequest class members, see the DevicePasswordRequest Members topic.

Public Instance Properties

Password Specifies the recovery password of the client device, which is stored by the server. The value of the DevicePassword has a maximum length of 255 characters.

See Also

DevicePasswordRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Password Property

Aspose.Email

DevicePasswordRequest.Password Property

Specifies the recovery password of the client device, which is stored by the server. The value of the DevicePassword has a maximum length of 255 characters.

public string Password {get; set;}

See Also

DevicePasswordRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


EASProvisionDoc Class

Specifies the collection of security settings for device provisioning.

For a list of all members of this type, see EASProvisionDoc Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.EASProvisionDoc

public class EASProvisionDoc

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

EASProvisionDoc Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


EASProvisionDoc Members

EASProvisionDoc overview

Public Instance Constructors

EASProvisionDoc Constructor Initializes a new instance of the EASProvisionDoc class.

Public Instance Properties

AllowBluetooth | Specifies the use of Bluetooth on the device. This property SHOULD be ignored if the client does not support Bluetooth.
AllowBrowser | Specifies whether the device allows the use of a web browser.
AllowCamera | Specifies whether the device allows the use of the built-in camera. This property SHOULD be ignored if the client does not have a camera and no camera can be attached to the device.
AllowConsumerEmail | Specifies whether the device allows the user to configure a personal email account.
AllowDesktopSync | Specifies whether the device allows synchronization with Desktop ActiveSync. This property SHOULD be ignored if the client does not support connecting to a personal computer.
AllowHTMLEmail | Specifies whether the client uses HTML-formatted email.
AllowInternetSharing | Specifies whether the device allows the use of Internet Sharing. This property SHOULD be ignored if the client does not support sharing its internet connection with other devices.
AllowIrDA | Specifies whether the device allows the use of IrDA (infrared) connections. This property SHOULD be ignored if the client does not have the capability of transmitting or receiving infrared signals.
AllowPOPIMAPEmail | Specifies whether the device allows access to POP or IMAP email.
AllowRemoteDesktop | Specifies whether the device allows the use of Remote Desktop. This property SHOULD be ignored if the client does not support connecting remotely to a personal computer.
AllowSimpleDevicePassword | Specifies whether the client allows simple passwords. A simple password is one consisting only of repeated ("2222") or sequential ("abcd") characters. If AllowSimpleDevicePassword is null, a client SHOULD treat this value as TRUE. If the value of the DevicePasswordEnabled is set to FALSE, the client SHOULD ignore this property.
AllowSMIMEEncryptionAlgorithmNegotiation | Controls the negotiation of the encryption algorithm.
AllowSMIMESoftCerts | Specifies whether the client can use soft certificates to sign outgoing messages.
AllowStorageCard | Specifies whether the device allows use of the storage card. This property SHOULD be ignored if the client does not support storing data on removable storage.
AllowTextMessaging | Specifies whether the device allows the use of SMS or text messaging. This property SHOULD be ignored if the client does not support SMS or text messaging.
AllowUnsignedApplications | Specifies whether the device allows unsigned applications to execute.
AllowUnsignedInstallationPackages | Specifies whether the device allows unsigned cabinet (.cab) files to be installed.
AllowWiFi | Specifies whether the device allows the use of Wi-Fi connections. This property SHOULD be ignored if the client does not have Wi-Fi capability.
AlphanumericDevicePasswordRequired | Specifies whether a client requires an alphanumeric password. If AlphanumericDevicePasswordRequired is null, a client SHOULD treat this value as FALSE. If the value of the DevicePasswordEnabled is FALSE, the client SHOULD ignore this property.
ApprovedApplicationList | Specifies a list of in-memory applications that are approved for execution. Only in-memory applications are affected by this property. This property does not apply to in-ROM applications. If non empty, the client MUST only allow the in-memory applications specified by this property to execute.
AttachmentsEnabled | Specifies whether email attachments are enabled.
DevicePasswordEnabled | Specifies whether a client requires a password.
DevicePasswordExpiration | Specifies the maximum number of days until a password expires. The DevicePasswordExpiration can be null, indicating that no password expiration policy is set. Valid values are listed bellow: = 0 - Passwords do not expire. > 0 - Passwords expire in the specified maximum number of days. If DevicePasswordExpiration is null, a client SHOULD treat this value as 0. If the value of the DevicePasswordEnabled is set to FALSE, the client SHOULD ignore this property.
DevicePasswordHistory | Specifies the minimum number of previously used passwords stored to prevent reuse by the client. Valid values are listed bellow: = 0 - Storage of previously used passwords is not required. > 0 - The minimum number of previously used passwords to be stored. If DevicePasswordHistory is null, then a client SHOULD treat this value as 0. If the value of the DevicePasswordEnabled is set to TRUE, the client disallows the user from using a stored prior password after a password expires. If the value of the DevicePasswordEnabled is set to FALSE, the client SHOULD ignore this property.
MaxAttachmentSize | Specifies the maximum attachment size in bytes as determined by security policy. If the property is null, the client interprets this as meaning no maximum attachment size has been set by the security policy.
MaxCalendarAgeFilter | Specifies the maximum number of calendar days that can be synchronized. Valid values are listed bellow: All days 2 weeks 1 month 3 months 6 months
MaxDevicePasswordFailedAttempts | Specifies the maximum number of failed password logon attempts that are permitted. The client SHOULD perform a local wipe or enter a timed lock out mode if the maximum number of failed password logon attempts is reached. The MaxDevicePasswordFailedAttempts can be null or have a value in the range from 4 through 16. If the property is null, the client interprets this as meaning that no maximum number of failed password logon attempts has been set by the security policy. If the value of the DevicePasswordEnabled is set to FALSE, the client ignores this property.
MaxEmailAgeFilter | Specifies the email age limit for synchronization. Valid values are listed bellow: Sync all 1 day 3 days 1 week 2 weeks 1 month
MaxEmailBodyTruncationSize | Specifies the truncation size for plain text–formatted email. Valid values are listed bellow: -1 No truncation. =0 Truncate only the header. >0 Truncate the email body to the specified size.
MaxEmailHTMLBodyTruncationSize | Specifies the truncation size for HTML-formatted email. Valid values are listed bellow: -1 No truncation. =0 Truncate only the header. >0 Truncate the email body to the specified size.
MaxInactivityTimeDeviceLock | Specifies the maximum number of seconds of inactivity before the device locks itself. If this value is greater than or equal to 9999, the client interprets it as unlimited. If the MaxInactivityTimeDeviceLock is null, the client interprets this as meaning that no time device lock has been set by the security policy.
MinDevicePasswordComplexCharacters | Specifies the required level of complexity of the client password. The value specifies the number of character groups that are required to be present in the password. The character groups are defined as: Lower case alphabetical characters = 1 Lower case and Upper case alphabetical characters = 2 Lower case, Upper case alphabetical characters and Numbers = 3 Lower case and Upper case alphabetical characters, Numbers and Non-alphanumeric characters = 4 For example: If the value of MinDevicePasswordComplexCharacters is 2, a password with both upper case and lower case alphabetical characters would be sufficient, as would a password with lower case alphabetical characters and numbers.
MinDevicePasswordLength | Specifies the minimum client password length. The MinDevicePasswordLength can be empty or have a value no less than 1 and no greater than 16. If the property is null or the value of this property is 1, there is no minimum length for the device password. If the value of the DevicePasswordEnabled is FALSE, the client SHOULD ignore this property .
PasswordRecoveryEnabled | Specifies whether the server supports storage of a recovery password to be sent by the client using the Settings command. A recovery password is a special password created by the client that gives the administrator or user the ability to log on to the device one time, after which the user is required to create a new password. The client then creates a new recovery password. If the PasswordRecoveryEnabled is set to TRUE, the server supports storage of a recovery password sent by the device. If the property is set to FALSE, the device SHOULD NOT send a recovery password, because the server does not support storage of the password. If PasswordRecoveryEnabled is null, a client SHOULD treat this value as FALSE. If the value of the DevicePasswordEnabled is FALSE, the client SHOULD ignore this property. This property SHOULD be ignored if the client does not support recovery passwords.
RequireDeviceEncryption | Specifies whether the client uses encryption.
RequireEncryptedSMIMEMessages | Specifies whether the client sends encrypted email messages.
RequireEncryptionSMIMEAlgorithm | Specifies the algorithm used when encrypting S/MIME messages.
RequireManualSyncWhenRoaming | Specifies whether the device requires manual synchronization when the device is roaming.
RequireSignedSMIMEAlgorithm | Specifies the algorithm used when signing S/MIME messages.
RequireSignedSMIMEMessages | Specifies whether the client sends signed S/MIME messages.
RequireStorageCardEncryption | Specifies whether the device encrypts content that is stored on the device. This property SHOULD be ignored if the client does not support storing data on removable storage.
UnapprovedInROMApplicationList | Specifies a list of in-ROM applications that are not approved for execution. Only applications that are preinstalled in ROM are affected by the entries in this property. This property does not apply to applications that are installed in-memory.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EASProvisionDoc Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


EASProvisionDoc Constructor

Initializes a new instance of the EASProvisionDoc class.

public EASProvisionDoc();

See Also

EASProvisionDoc Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


EASProvisionDoc Properties

The properties of the EASProvisionDoc class are listed below. For a complete list of EASProvisionDoc class members, see the EASProvisionDoc Members topic.

Public Instance Properties

AllowBluetooth | Specifies the use of Bluetooth on the device. This property SHOULD be ignored if the client does not support Bluetooth.
AllowBrowser | Specifies whether the device allows the use of a web browser.
AllowCamera | Specifies whether the device allows the use of the built-in camera. This property SHOULD be ignored if the client does not have a camera and no camera can be attached to the device.
AllowConsumerEmail | Specifies whether the device allows the user to configure a personal email account.
AllowDesktopSync | Specifies whether the device allows synchronization with Desktop ActiveSync. This property SHOULD be ignored if the client does not support connecting to a personal computer.
AllowHTMLEmail | Specifies whether the client uses HTML-formatted email.
AllowInternetSharing | Specifies whether the device allows the use of Internet Sharing. This property SHOULD be ignored if the client does not support sharing its internet connection with other devices.
AllowIrDA | Specifies whether the device allows the use of IrDA (infrared) connections. This property SHOULD be ignored if the client does not have the capability of transmitting or receiving infrared signals.
AllowPOPIMAPEmail | Specifies whether the device allows access to POP or IMAP email.
AllowRemoteDesktop | Specifies whether the device allows the use of Remote Desktop. This property SHOULD be ignored if the client does not support connecting remotely to a personal computer.
AllowSimpleDevicePassword | Specifies whether the client allows simple passwords. A simple password is one consisting only of repeated ("2222") or sequential ("abcd") characters. If AllowSimpleDevicePassword is null, a client SHOULD treat this value as TRUE. If the value of the DevicePasswordEnabled is set to FALSE, the client SHOULD ignore this property.
AllowSMIMEEncryptionAlgorithmNegotiation | Controls the negotiation of the encryption algorithm.
AllowSMIMESoftCerts | Specifies whether the client can use soft certificates to sign outgoing messages.
AllowStorageCard | Specifies whether the device allows use of the storage card. This property SHOULD be ignored if the client does not support storing data on removable storage.
AllowTextMessaging | Specifies whether the device allows the use of SMS or text messaging. This property SHOULD be ignored if the client does not support SMS or text messaging.
AllowUnsignedApplications | Specifies whether the device allows unsigned applications to execute.
AllowUnsignedInstallationPackages | Specifies whether the device allows unsigned cabinet (.cab) files to be installed.
AllowWiFi | Specifies whether the device allows the use of Wi-Fi connections. This property SHOULD be ignored if the client does not have Wi-Fi capability.
AlphanumericDevicePasswordRequired | Specifies whether a client requires an alphanumeric password. If AlphanumericDevicePasswordRequired is null, a client SHOULD treat this value as FALSE. If the value of the DevicePasswordEnabled is FALSE, the client SHOULD ignore this property.
ApprovedApplicationList | Specifies a list of in-memory applications that are approved for execution. Only in-memory applications are affected by this property. This property does not apply to in-ROM applications. If non empty, the client MUST only allow the in-memory applications specified by this property to execute.
AttachmentsEnabled | Specifies whether email attachments are enabled.
DevicePasswordEnabled | Specifies whether a client requires a password.
DevicePasswordExpiration | Specifies the maximum number of days until a password expires. The DevicePasswordExpiration can be null, indicating that no password expiration policy is set. Valid values are listed bellow: = 0 - Passwords do not expire. > 0 - Passwords expire in the specified maximum number of days. If DevicePasswordExpiration is null, a client SHOULD treat this value as 0. If the value of the DevicePasswordEnabled is set to FALSE, the client SHOULD ignore this property.
DevicePasswordHistory | Specifies the minimum number of previously used passwords stored to prevent reuse by the client. Valid values are listed bellow: = 0 - Storage of previously used passwords is not required. > 0 - The minimum number of previously used passwords to be stored. If DevicePasswordHistory is null, then a client SHOULD treat this value as 0. If the value of the DevicePasswordEnabled is set to TRUE, the client disallows the user from using a stored prior password after a password expires. If the value of the DevicePasswordEnabled is set to FALSE, the client SHOULD ignore this property.
MaxAttachmentSize | Specifies the maximum attachment size in bytes as determined by security policy. If the property is null, the client interprets this as meaning no maximum attachment size has been set by the security policy.
MaxCalendarAgeFilter | Specifies the maximum number of calendar days that can be synchronized. Valid values are listed bellow: All days 2 weeks 1 month 3 months 6 months
MaxDevicePasswordFailedAttempts | Specifies the maximum number of failed password logon attempts that are permitted. The client SHOULD perform a local wipe or enter a timed lock out mode if the maximum number of failed password logon attempts is reached. The MaxDevicePasswordFailedAttempts can be null or have a value in the range from 4 through 16. If the property is null, the client interprets this as meaning that no maximum number of failed password logon attempts has been set by the security policy. If the value of the DevicePasswordEnabled is set to FALSE, the client ignores this property.
MaxEmailAgeFilter | Specifies the email age limit for synchronization. Valid values are listed bellow: Sync all 1 day 3 days 1 week 2 weeks 1 month
MaxEmailBodyTruncationSize | Specifies the truncation size for plain text–formatted email. Valid values are listed bellow: -1 No truncation. =0 Truncate only the header. >0 Truncate the email body to the specified size.
MaxEmailHTMLBodyTruncationSize | Specifies the truncation size for HTML-formatted email. Valid values are listed bellow: -1 No truncation. =0 Truncate only the header. >0 Truncate the email body to the specified size.
MaxInactivityTimeDeviceLock | Specifies the maximum number of seconds of inactivity before the device locks itself. If this value is greater than or equal to 9999, the client interprets it as unlimited. If the MaxInactivityTimeDeviceLock is null, the client interprets this as meaning that no time device lock has been set by the security policy.
MinDevicePasswordComplexCharacters | Specifies the required level of complexity of the client password. The value specifies the number of character groups that are required to be present in the password. The character groups are defined as: Lower case alphabetical characters = 1 Lower case and Upper case alphabetical characters = 2 Lower case, Upper case alphabetical characters and Numbers = 3 Lower case and Upper case alphabetical characters, Numbers and Non-alphanumeric characters = 4 For example: If the value of MinDevicePasswordComplexCharacters is 2, a password with both upper case and lower case alphabetical characters would be sufficient, as would a password with lower case alphabetical characters and numbers.
MinDevicePasswordLength | Specifies the minimum client password length. The MinDevicePasswordLength can be empty or have a value no less than 1 and no greater than 16. If the property is null or the value of this property is 1, there is no minimum length for the device password. If the value of the DevicePasswordEnabled is FALSE, the client SHOULD ignore this property .
PasswordRecoveryEnabled | Specifies whether the server supports storage of a recovery password to be sent by the client using the Settings command. A recovery password is a special password created by the client that gives the administrator or user the ability to log on to the device one time, after which the user is required to create a new password. The client then creates a new recovery password. If the PasswordRecoveryEnabled is set to TRUE, the server supports storage of a recovery password sent by the device. If the property is set to FALSE, the device SHOULD NOT send a recovery password, because the server does not support storage of the password. If PasswordRecoveryEnabled is null, a client SHOULD treat this value as FALSE. If the value of the DevicePasswordEnabled is FALSE, the client SHOULD ignore this property. This property SHOULD be ignored if the client does not support recovery passwords.
RequireDeviceEncryption | Specifies whether the client uses encryption.
RequireEncryptedSMIMEMessages | Specifies whether the client sends encrypted email messages.
RequireEncryptionSMIMEAlgorithm | Specifies the algorithm used when encrypting S/MIME messages.
RequireManualSyncWhenRoaming | Specifies whether the device requires manual synchronization when the device is roaming.
RequireSignedSMIMEAlgorithm | Specifies the algorithm used when signing S/MIME messages.
RequireSignedSMIMEMessages | Specifies whether the client sends signed S/MIME messages.
RequireStorageCardEncryption | Specifies whether the device encrypts content that is stored on the device. This property SHOULD be ignored if the client does not support storing data on removable storage.
UnapprovedInROMApplicationList | Specifies a list of in-ROM applications that are not approved for execution. Only applications that are preinstalled in ROM are affected by the entries in this property. This property does not apply to applications that are installed in-memory.

See Also

EASProvisionDoc Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


AllowBluetooth Property

Aspose.Email

EASProvisionDoc.AllowBluetooth Property

Specifies the use of Bluetooth on the device. This property SHOULD be ignored if the client does not support Bluetooth.

public AllowBluetooth} AllowBluetooth {get; set;}

See Also

EASProvisionDoc Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


AllowBrowser Property

Aspose.Email

EASProvisionDoc.AllowBrowser Property

Specifies whether the device allows the use of a web browser.

public Boolean} AllowBrowser {get; set;}

See Also

EASProvisionDoc Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


AllowCamera Property

Aspose.Email

EASProvisionDoc.AllowCamera Property

Specifies whether the device allows the use of the built-in camera. This property SHOULD be ignored if the client does not have a camera and no camera can be attached to the device.

public Boolean} AllowCamera {get; set;}

See Also

EASProvisionDoc Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


AllowConsumerEmail Property

Aspose.Email

EASProvisionDoc.AllowConsumerEmail Property

Specifies whether the device allows the user to configure a personal email account.

public Boolean} AllowConsumerEmail {get; set;}

See Also

EASProvisionDoc Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


AllowDesktopSync Property

Aspose.Email

EASProvisionDoc.AllowDesktopSync Property

Specifies whether the device allows synchronization with Desktop ActiveSync. This property SHOULD be ignored if the client does not support connecting to a personal computer.

public Boolean} AllowDesktopSync {get; set;}

See Also

EASProvisionDoc Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


AllowHTMLEmail Property

Aspose.Email

EASProvisionDoc.AllowHTMLEmail Property

Specifies whether the client uses HTML-formatted email.

public Boolean} AllowHTMLEmail {get; set;}

See Also

EASProvisionDoc Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


AllowInternetSharing Property

Aspose.Email

EASProvisionDoc.AllowInternetSharing Property

Specifies whether the device allows the use of Internet Sharing. This property SHOULD be ignored if the client does not support sharing its internet connection with other devices.

public Boolean} AllowInternetSharing {get; set;}

See Also

EASProvisionDoc Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


AllowIrDA Property

Aspose.Email

EASProvisionDoc.AllowIrDA Property

Specifies whether the device allows the use of IrDA (infrared) connections. This property SHOULD be ignored if the client does not have the capability of transmitting or receiving infrared signals.

public Boolean} AllowIrDA {get; set;}

See Also

EASProvisionDoc Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


AllowPOPIMAPEmail Property

Aspose.Email

EASProvisionDoc.AllowPOPIMAPEmail Property

Specifies whether the device allows access to POP or IMAP email.

public Boolean} AllowPOPIMAPEmail {get; set;}

See Also

EASProvisionDoc Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


AllowRemoteDesktop Property

Aspose.Email

EASProvisionDoc.AllowRemoteDesktop Property

Specifies whether the device allows the use of Remote Desktop. This property SHOULD be ignored if the client does not support connecting remotely to a personal computer.

public Boolean} AllowRemoteDesktop {get; set;}

See Also

EASProvisionDoc Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


AllowSimpleDevicePassword Property

Aspose.Email

EASProvisionDoc.AllowSimpleDevicePassword Property

Specifies whether the client allows simple passwords. A simple password is one consisting only of repeated ("2222") or sequential ("abcd") characters. If AllowSimpleDevicePassword is null, a client SHOULD treat this value as TRUE. If the value of the DevicePasswordEnabled is set to FALSE, the client SHOULD ignore this property.

public Boolean} AllowSimpleDevicePassword {get; set;}

See Also

EASProvisionDoc Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


AllowSMIMEEncryptionAlgorithmNegotiation Property

Aspose.Email

EASProvisionDoc.AllowSMIMEEncryptionAlgorithmNegotiation Property

Controls the negotiation of the encryption algorithm.

public SMIMEEncryptionAlgorithmNegotiation} AllowSMIMEEncryptionAlgorithmNegotiation {get; set;}

See Also

EASProvisionDoc Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


AllowSMIMESoftCerts Property

Aspose.Email

EASProvisionDoc.AllowSMIMESoftCerts Property

Specifies whether the client can use soft certificates to sign outgoing messages.

public Boolean} AllowSMIMESoftCerts {get; set;}

See Also

EASProvisionDoc Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


AllowStorageCard Property

Aspose.Email

EASProvisionDoc.AllowStorageCard Property

Specifies whether the device allows use of the storage card. This property SHOULD be ignored if the client does not support storing data on removable storage.

public Boolean} AllowStorageCard {get; set;}

See Also

EASProvisionDoc Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


AllowTextMessaging Property

Aspose.Email

EASProvisionDoc.AllowTextMessaging Property

Specifies whether the device allows the use of SMS or text messaging. This property SHOULD be ignored if the client does not support SMS or text messaging.

public Boolean} AllowTextMessaging {get; set;}

See Also

EASProvisionDoc Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


AllowUnsignedApplications Property

Aspose.Email

EASProvisionDoc.AllowUnsignedApplications Property

Specifies whether the device allows unsigned applications to execute.

public Boolean} AllowUnsignedApplications {get; set;}

See Also

EASProvisionDoc Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


AllowUnsignedInstallationPackages Property

Aspose.Email

EASProvisionDoc.AllowUnsignedInstallationPackages Property

Specifies whether the device allows unsigned cabinet (.cab) files to be installed.

public Boolean} AllowUnsignedInstallationPackages {get; set;}

See Also

EASProvisionDoc Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


AllowWiFi Property

Aspose.Email

EASProvisionDoc.AllowWiFi Property

Specifies whether the device allows the use of Wi-Fi connections. This property SHOULD be ignored if the client does not have Wi-Fi capability.

public Boolean} AllowWiFi {get; set;}

See Also

EASProvisionDoc Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


AlphanumericDevicePasswordRequired Property

Aspose.Email

EASProvisionDoc.AlphanumericDevicePasswordRequired Property

Specifies whether a client requires an alphanumeric password. If AlphanumericDevicePasswordRequired is null, a client SHOULD treat this value as FALSE. If the value of the DevicePasswordEnabled is FALSE, the client SHOULD ignore this property.

public Boolean} AlphanumericDevicePasswordRequired {get; set;}

See Also

EASProvisionDoc Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ApprovedApplicationList Property

Aspose.Email

EASProvisionDoc.ApprovedApplicationList Property

Specifies a list of in-memory applications that are approved for execution. Only in-memory applications are affected by this property. This property does not apply to in-ROM applications. If non empty, the client MUST only allow the in-memory applications specified by this property to execute.

public String} ApprovedApplicationList {get;}

See Also

EASProvisionDoc Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


AttachmentsEnabled Property

Aspose.Email

EASProvisionDoc.AttachmentsEnabled Property

Specifies whether email attachments are enabled.

public Boolean} AttachmentsEnabled {get; set;}

See Also

EASProvisionDoc Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


DevicePasswordEnabled Property

Aspose.Email

EASProvisionDoc.DevicePasswordEnabled Property

Specifies whether a client requires a password.

public Boolean} DevicePasswordEnabled {get; set;}

See Also

EASProvisionDoc Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


DevicePasswordExpiration Property

Aspose.Email

EASProvisionDoc.DevicePasswordExpiration Property

Specifies the maximum number of days until a password expires. The DevicePasswordExpiration can be null, indicating that no password expiration policy is set. Valid values are listed bellow: = 0 - Passwords do not expire. > 0 - Passwords expire in the specified maximum number of days. If DevicePasswordExpiration is null, a client SHOULD treat this value as 0. If the value of the DevicePasswordEnabled is set to FALSE, the client SHOULD ignore this property.

public Int32} DevicePasswordExpiration {get; set;}

See Also

EASProvisionDoc Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


DevicePasswordHistory Property

Aspose.Email

EASProvisionDoc.DevicePasswordHistory Property

Specifies the minimum number of previously used passwords stored to prevent reuse by the client. Valid values are listed bellow: = 0 - Storage of previously used passwords is not required. > 0 - The minimum number of previously used passwords to be stored. If DevicePasswordHistory is null, then a client SHOULD treat this value as 0. If the value of the DevicePasswordEnabled is set to TRUE, the client disallows the user from using a stored prior password after a password expires. If the value of the DevicePasswordEnabled is set to FALSE, the client SHOULD ignore this property.

public Int32} DevicePasswordHistory {get; set;}

See Also

EASProvisionDoc Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


MaxAttachmentSize Property

Aspose.Email

EASProvisionDoc.MaxAttachmentSize Property

Specifies the maximum attachment size in bytes as determined by security policy. If the property is null, the client interprets this as meaning no maximum attachment size has been set by the security policy.

public Int32} MaxAttachmentSize {get; set;}

See Also

EASProvisionDoc Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


MaxCalendarAgeFilter Property

Aspose.Email

EASProvisionDoc.MaxCalendarAgeFilter Property

Specifies the maximum number of calendar days that can be synchronized. Valid values are listed bellow: All days 2 weeks 1 month 3 months 6 months

public MaxAgeFilter} MaxCalendarAgeFilter {get; set;}

See Also

EASProvisionDoc Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


MaxDevicePasswordFailedAttempts Property

Aspose.Email

EASProvisionDoc.MaxDevicePasswordFailedAttempts Property

Specifies the maximum number of failed password logon attempts that are permitted. The client SHOULD perform a local wipe or enter a timed lock out mode if the maximum number of failed password logon attempts is reached. The MaxDevicePasswordFailedAttempts can be null or have a value in the range from 4 through 16. If the property is null, the client interprets this as meaning that no maximum number of failed password logon attempts has been set by the security policy. If the value of the DevicePasswordEnabled is set to FALSE, the client ignores this property.

public Int32} MaxDevicePasswordFailedAttempts {get; set;}

See Also

EASProvisionDoc Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


MaxEmailAgeFilter Property

Aspose.Email

EASProvisionDoc.MaxEmailAgeFilter Property

Specifies the email age limit for synchronization. Valid values are listed bellow: Sync all 1 day 3 days 1 week 2 weeks 1 month

public MaxAgeFilter} MaxEmailAgeFilter {get; set;}

See Also

EASProvisionDoc Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


MaxEmailBodyTruncationSize Property

Aspose.Email

EASProvisionDoc.MaxEmailBodyTruncationSize Property

Specifies the truncation size for plain text–formatted email. Valid values are listed bellow: -1 No truncation. =0 Truncate only the header. >0 Truncate the email body to the specified size.

public Int32} MaxEmailBodyTruncationSize {get; set;}

See Also

EASProvisionDoc Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


MaxEmailHTMLBodyTruncationSize Property

Aspose.Email

EASProvisionDoc.MaxEmailHTMLBodyTruncationSize Property

Specifies the truncation size for HTML-formatted email. Valid values are listed bellow: -1 No truncation. =0 Truncate only the header. >0 Truncate the email body to the specified size.

public Int32} MaxEmailHTMLBodyTruncationSize {get; set;}

See Also

EASProvisionDoc Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


MaxInactivityTimeDeviceLock Property

Aspose.Email

EASProvisionDoc.MaxInactivityTimeDeviceLock Property

Specifies the maximum number of seconds of inactivity before the device locks itself. If this value is greater than or equal to 9999, the client interprets it as unlimited. If the MaxInactivityTimeDeviceLock is null, the client interprets this as meaning that no time device lock has been set by the security policy.

public Int32} MaxInactivityTimeDeviceLock {get; set;}

See Also

EASProvisionDoc Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


MinDevicePasswordComplexCharacters Property

Aspose.Email

EASProvisionDoc.MinDevicePasswordComplexCharacters Property

Specifies the required level of complexity of the client password. The value specifies the number of character groups that are required to be present in the password. The character groups are defined as: Lower case alphabetical characters = 1 Lower case and Upper case alphabetical characters = 2 Lower case, Upper case alphabetical characters and Numbers = 3 Lower case and Upper case alphabetical characters, Numbers and Non-alphanumeric characters = 4 For example: If the value of MinDevicePasswordComplexCharacters is 2, a password with both upper case and lower case alphabetical characters would be sufficient, as would a password with lower case alphabetical characters and numbers.

public MinDevicePasswordComplexCharacters} MinDevicePasswordComplexCharacters {get; set;}

See Also

EASProvisionDoc Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


MinDevicePasswordLength Property

Aspose.Email

EASProvisionDoc.MinDevicePasswordLength Property

Specifies the minimum client password length. The MinDevicePasswordLength can be empty or have a value no less than 1 and no greater than 16. If the property is null or the value of this property is 1, there is no minimum length for the device password. If the value of the DevicePasswordEnabled is FALSE, the client SHOULD ignore this property .

public Int32} MinDevicePasswordLength {get; set;}

See Also

EASProvisionDoc Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


PasswordRecoveryEnabled Property

Aspose.Email

EASProvisionDoc.PasswordRecoveryEnabled Property

Specifies whether the server supports storage of a recovery password to be sent by the client using the Settings command. A recovery password is a special password created by the client that gives the administrator or user the ability to log on to the device one time, after which the user is required to create a new password. The client then creates a new recovery password. If the PasswordRecoveryEnabled is set to TRUE, the server supports storage of a recovery password sent by the device. If the property is set to FALSE, the device SHOULD NOT send a recovery password, because the server does not support storage of the password. If PasswordRecoveryEnabled is null, a client SHOULD treat this value as FALSE. If the value of the DevicePasswordEnabled is FALSE, the client SHOULD ignore this property. This property SHOULD be ignored if the client does not support recovery passwords.

public Boolean} PasswordRecoveryEnabled {get; set;}

See Also

EASProvisionDoc Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


RequireDeviceEncryption Property

Aspose.Email

EASProvisionDoc.RequireDeviceEncryption Property

Specifies whether the client uses encryption.

public Boolean} RequireDeviceEncryption {get; set;}

See Also

EASProvisionDoc Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


RequireEncryptedSMIMEMessages Property

Aspose.Email

EASProvisionDoc.RequireEncryptedSMIMEMessages Property

Specifies whether the client sends encrypted email messages.

public Boolean} RequireEncryptedSMIMEMessages {get; set;}

See Also

EASProvisionDoc Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


RequireEncryptionSMIMEAlgorithm Property

Aspose.Email

EASProvisionDoc.RequireEncryptionSMIMEAlgorithm Property

Specifies the algorithm used when encrypting S/MIME messages.

public EncryptionSMIMEAlgorithm} RequireEncryptionSMIMEAlgorithm {get; set;}

See Also

EASProvisionDoc Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


RequireManualSyncWhenRoaming Property

Aspose.Email

EASProvisionDoc.RequireManualSyncWhenRoaming Property

Specifies whether the device requires manual synchronization when the device is roaming.

public Boolean} RequireManualSyncWhenRoaming {get; set;}

See Also

EASProvisionDoc Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


RequireSignedSMIMEAlgorithm Property

Aspose.Email

EASProvisionDoc.RequireSignedSMIMEAlgorithm Property

Specifies the algorithm used when signing S/MIME messages.

public SignedSMIMEAlgorithm} RequireSignedSMIMEAlgorithm {get; set;}

See Also

EASProvisionDoc Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


RequireSignedSMIMEMessages Property

Aspose.Email

EASProvisionDoc.RequireSignedSMIMEMessages Property

Specifies whether the client sends signed S/MIME messages.

public Boolean} RequireSignedSMIMEMessages {get; set;}

See Also

EASProvisionDoc Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


RequireStorageCardEncryption Property

Aspose.Email

EASProvisionDoc.RequireStorageCardEncryption Property

Specifies whether the device encrypts content that is stored on the device. This property SHOULD be ignored if the client does not support storing data on removable storage.

public Boolean} RequireStorageCardEncryption {get; set;}

See Also

EASProvisionDoc Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


UnapprovedInROMApplicationList Property

Aspose.Email

EASProvisionDoc.UnapprovedInROMApplicationList Property

Specifies a list of in-ROM applications that are not approved for execution. Only applications that are preinstalled in ROM are affected by the entries in this property. This property does not apply to applications that are installed in-memory.

public String} UnapprovedInROMApplicationList {get;}

See Also

EASProvisionDoc Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


EmptyFolderContentsRequest Class

Contains request about deleting the contents of a folder. EmptyFolderContents supports a single child element of the Options element, the DeleteSubFolders, which determines whether subfolders contained in the folder are deleted. If the DeleteSubFolders option is not included in the request, the subfolders of the specified CollectionId are not deleted.

For a list of all members of this type, see EmptyFolderContentsRequest Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.EmptyFolderContentsRequest

public class EmptyFolderContentsRequest

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

EmptyFolderContentsRequest Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


EmptyFolderContentsRequest Members

EmptyFolderContentsRequest overview

Public Instance Constructors

EmptyFolderContentsRequest Constructor Initializes a new instance of the EmptyFolderContentsRequest class.

Public Instance Properties

CollectionId | Specifies the folder to be emptied.
Options | Contains the options for the ItemOperations.EmptyFolderContents operation

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

EmptyFolderContentsRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


EmptyFolderContentsRequest Constructor

Initializes a new instance of the EmptyFolderContentsRequest class.

public EmptyFolderContentsRequest();

See Also

EmptyFolderContentsRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


EmptyFolderContentsRequest Properties

The properties of the EmptyFolderContentsRequest class are listed below. For a complete list of EmptyFolderContentsRequest class members, see the EmptyFolderContentsRequest Members topic.

Public Instance Properties

CollectionId | Specifies the folder to be emptied.
Options | Contains the options for the ItemOperations.EmptyFolderContents operation

See Also

EmptyFolderContentsRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


CollectionId Property

Aspose.Email

EmptyFolderContentsRequest.CollectionId Property

Specifies the folder to be emptied.

public string CollectionId {get; set;}

See Also

EmptyFolderContentsRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Options Property

Aspose.Email

EmptyFolderContentsRequest.Options Property

Contains the options for the ItemOperations.EmptyFolderContents operation

public ItOpEmpFldCntOptions Options {get; set;}

See Also

EmptyFolderContentsRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


EncryptionSMIMEAlgorithm Enumeration

Specifies the algorithm used when encrypting S/MIME messages.

public enum EncryptionSMIMEAlgorithm

Members

Member Name | Description | Value
TripleDES | Triple DES algorithm | 0
DES | DES algorithm | 1
RC2128bit | RC2 128 bit algorithm | 2
RC264bit | RC2 64 bit algorithm | 3
RC240bit | RC2 40 bit algorithm | 4

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


FolderClass Enumeration

Specifies the content class of the folder to be monitored.

public enum FolderClass

Members

Member Name | Description | Value
Email | Folder contains Email items | 0
Calendar | Folder contains Calendar items | 1
Contacts | Folder contains Contacts items | 2
Tasks | Folder contains Tasks items | 3
Notes | Folder contains Notes items | 4

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


FolderInfo Class

FolderInfo class contains folder information

For a list of all members of this type, see FolderInfo Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.FolderInfo

public class FolderInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FolderInfo Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


FolderInfo Members

FolderInfo overview

Public Instance Constructors

FolderInfo Constructor Initializes a new instance of the FolderInfo class.

Public Instance Properties

DisplayName | Specifies the user-friendly name of the folder.
ParentId | Specifies the server ID of the parent folder of the folder on the server
ServerId | Specifies the server ID of of the folder on the server
Type | Specifies the type of the folder.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a string that represents the current object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FolderInfo Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


FolderInfo Constructor

Initializes a new instance of the FolderInfo class.

public FolderInfo(
string serverId,
string parentId,
string displayName,
FolderTypes type
);

Parameters

serverId
Specifies the server ID of of the folder on the server
parentId
Specifies the server ID of the parent folder of the folder on the server
displayName
Specifies the user-friendly name of the folder.
type
Specifies the type of the folder.

See Also

FolderInfo Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


FolderInfo Properties

The properties of the FolderInfo class are listed below. For a complete list of FolderInfo class members, see the FolderInfo Members topic.

Public Instance Properties

DisplayName | Specifies the user-friendly name of the folder.
ParentId | Specifies the server ID of the parent folder of the folder on the server
ServerId | Specifies the server ID of of the folder on the server
Type | Specifies the type of the folder.

See Also

FolderInfo Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


DisplayName Property

Aspose.Email

FolderInfo.DisplayName Property

Specifies the user-friendly name of the folder.

public string DisplayName {get;}

See Also

FolderInfo Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ParentId Property

Aspose.Email

FolderInfo.ParentId Property

Specifies the server ID of the parent folder of the folder on the server

public string ParentId {get;}

See Also

FolderInfo Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ServerId Property

Aspose.Email

FolderInfo.ServerId Property

Specifies the server ID of of the folder on the server

public string ServerId {get;}

See Also

FolderInfo Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Type Property

Aspose.Email

FolderInfo.Type Property

Specifies the type of the folder.

public FolderTypes Type {get;}

See Also

FolderInfo Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


FolderInfo Methods

The methods of the FolderInfo class are listed below. For a complete list of FolderInfo class members, see the FolderInfo Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a string that represents the current object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FolderInfo Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


FolderInfo.ToString Method

Returns a string that represents the current object.

public override string ToString();

Return Value

A string that represents the current object.

See Also

FolderInfo Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


FolderSyncResult Class

Contains changes to the folder hierarchy.

For a list of all members of this type, see FolderSyncResult Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.FolderSyncResult

public class FolderSyncResult

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FolderSyncResult Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


FolderSyncResult Members

FolderSyncResult overview

Public Instance Constructors

FolderSyncResult Constructor Initializes a new instance of the FolderSyncResult class.

Public Instance Properties

Added | Contains array of added folders.
Deleted | Contains array of deleted folders.
Updated | Contains array of modified folders.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a string that represents the current object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FolderSyncResult Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


FolderSyncResult Constructor

Initializes a new instance of the FolderSyncResult class.

public FolderSyncResult(
FolderInfo[] added,
FolderInfo[] updated,
FolderInfo[] deleted
);

Parameters

added
Contains array of added folders.
updated
Contains array of modified folders.
deleted
Contains array of deleted folders.

See Also

FolderSyncResult Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


FolderSyncResult Properties

The properties of the FolderSyncResult class are listed below. For a complete list of FolderSyncResult class members, see the FolderSyncResult Members topic.

Public Instance Properties

Added | Contains array of added folders.
Deleted | Contains array of deleted folders.
Updated | Contains array of modified folders.

See Also

FolderSyncResult Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Added Property

Aspose.Email

FolderSyncResult.Added Property

Contains array of added folders.

public FolderInfo[] Added {get;}

See Also

FolderSyncResult Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Deleted Property

Aspose.Email

FolderSyncResult.Deleted Property

Contains array of deleted folders.

public FolderInfo[] Deleted {get;}

See Also

FolderSyncResult Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Updated Property

Aspose.Email

FolderSyncResult.Updated Property

Contains array of modified folders.

public FolderInfo[] Updated {get;}

See Also

FolderSyncResult Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


FolderSyncResult Methods

The methods of the FolderSyncResult class are listed below. For a complete list of FolderSyncResult class members, see the FolderSyncResult Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a string that represents the current object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FolderSyncResult Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


FolderSyncResult.ToString Method

Returns a string that represents the current object.

public override string ToString();

Return Value

A string that represents the current object.

See Also

FolderSyncResult Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


FolderTypes Enumeration

Specifies the type of the folder that was updated (renamed or moved) or added on the server.

public enum FolderTypes

Members

Member Name | Description | Value
UserCreatedFolder | User-created folder (generic) | 1
DefaultInboxFolder | Default Inbox folder | 2
DefaultDraftsFolder | Default Drafts folder | 3
DefaultDeletedItemsFolder | Default Deleted Items folder | 4
DefaultSentItemsFolder | Default Sent Items folder | 5
DefaultOutboxFolder | Default Outbox folder | 6
DefaultTasksFolder | Default Tasks folder | 7
DefaultCalendarFolder | Default Calendar folder | 8
DefaultContactsFolder | Default Contacts folder | 9
DefaultNotesFolder | Default Notes folder | 10
DefaultJournalFolder | Default Journal folder | 11
UserCreatedMailFolder | User-created Mail folder | 12
UserCreatedCalendarFolder | User-created Calendar folder | 13
UserCreatedContactsFolder | User-created Contacts folder | 14
UserCreatedTasksFolder | User-created Tasks folder | 15
UserCreatedJournalFolder | User-created journal folder | 16
UserCreatedNoteFolder | User-created Notes folder | 17
UnknownFolderType | Unknown folder type | 18
RecipientInformationCache | Recipient information cache | 19

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


IActiveSyncTLClient Interface

ActiveSync client interface

For a list of all members of this type, see IActiveSyncTLClient Members.

public interface IActiveSyncTLClient : IBaseActiveSyncTLClient, IDisposable

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

IActiveSyncTLClient Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


IActiveSyncTLClient Members

IActiveSyncTLClient overview

Public Instance Properties

AirSyncKeys | Contains a values that is used by the server to mark the synchronization state of a every synchronized collection. Where dictionary key is server Id and dictionary value is SyncKey. For GetItemEstimate and Sync commands.
FoldersSyncKey | Used by the server to track the current state of the client. For operations with folders only
HeartbeatInterval | The HeartbeatInterval element is a child element of the Ping element in Ping command requests and responses. In Ping command requests, it specifies the length of time, in seconds, that the server SHOULD wait before sending a response if no new items are added to the specified set of folders, as specified in section 3.1.5.6. The HeartbeatInterval element is also returned by the server with a status code of 5 and specifies either the minimum or maximum interval that is allowed when the client has requested a heartbeat interval that is outside the acceptable range.

Public Instance Methods

FolderCreate | The FolderCreate creates a new folder as a child folder of the specified parent folder.
FolderDelete | Deletes the collection with the matching identifier.
FolderSync | Overloaded. The FolderSync synchronizes the collection hierarchy but does not synchronize the items in the collections themselves.
FolderUpdate | Overloaded. The FolderUpdate command moves a folder from one location to another on the server. The command is also used to rename a folder.
GetAttachment | The GetAttachment retrieves an email attachment from the server. The GetAttachment is not supported when the protocol version is 14.0 or 14.1. Use the Fetch element of the ItemOperations command instead.
GetItemEstimate | Overloaded. The GetItemEstimate command gets an estimate of the number of items in a collection or folder on the server that have to be synchronized.
ItemOperations | The ItemOperations provides batched online handling of the Fetch, the EmptyFolderContents, and the Move operations.
MeetingResponse | Overloaded. Accepts, tentatively accepts, or declines a meeting request in the user's Inbox folder or Calendar folder.
MoveItem | The MoveItems command moves an item or items from one folder on the server to another.
MoveItems | Overloaded. The MoveItems command moves an item or items from one folder on the server to another.
Ping | Overloaded. The Ping command is used to request that the server monitor specified folders for changes that would require the client to resynchronize.
Provision | The Provision command enables client devices to request from the server the security policy settings that the administrator sets, such as the minimum personal identification number (PIN) password length requirement.
ResetAirSyncKey | Overloaded. Reset SyncKey for GetItemEstimate and Sync operations for defined collection.
ResetFoldersSyncKey | Reset SyncKey for operations with folders
ResolveRecipients | The ResolveRecipients is used to resolve a list of supplied recipients, to retrieve their free/busy information, and optionally, to retrieve their S/MIME certificates so that clients can send encrypted S/MIME email messages. Retrieval of free/busy information using the Availability element in the ResolveRecipients command is not supported when the protocol version is 12.1.
Search | The Search is used to find entries in an address book, mailbox, or document library (UNC or Windows SharePoint Services).
SendMail | Overloaded. The SendMail is used by clients to send MIME-formatted email messages to the server.
Settings | The Settings supports get and set operations on global properties and Out of Office (OOF) settings for the user. The Settings also sends device information to the server, implements the device password/personal identification number (PIN) recovery, and retrieves a list of the user's email addresses.
SmartForward | The SmartForward command is used by clients to forward messages without retrieving the full, original message from the server.
SmartReply | The SmartReply command is used by clients to reply to messages without retrieving the full, original message from the server.
Sync | The Sync synchronizes changes in a collection between the client and the server.
ValidateCert | Overloaded. The ValidateCert command is used by the client to validate a certificate that has been received via an S/MIME mail.

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


IActiveSyncTLClient Properties

The properties of the IActiveSyncTLClient interface are listed below. For a complete list of IActiveSyncTLClient interface members, see the IActiveSyncTLClient Members topic.

Public Instance Properties

AirSyncKeys | Contains a values that is used by the server to mark the synchronization state of a every synchronized collection. Where dictionary key is server Id and dictionary value is SyncKey. For GetItemEstimate and Sync commands.
FoldersSyncKey | Used by the server to track the current state of the client. For operations with folders only
HeartbeatInterval | The HeartbeatInterval element is a child element of the Ping element in Ping command requests and responses. In Ping command requests, it specifies the length of time, in seconds, that the server SHOULD wait before sending a response if no new items are added to the specified set of folders, as specified in section 3.1.5.6. The HeartbeatInterval element is also returned by the server with a status code of 5 and specifies either the minimum or maximum interval that is allowed when the client has requested a heartbeat interval that is outside the acceptable range.

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


AirSyncKeys Property

Aspose.Email

IActiveSyncTLClient.AirSyncKeys Property

Contains a values that is used by the server to mark the synchronization state of a every synchronized collection. Where dictionary key is server Id and dictionary value is SyncKey. For GetItemEstimate and Sync commands.

String} AirSyncKeys {get;}

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


FoldersSyncKey Property

Aspose.Email

IActiveSyncTLClient.FoldersSyncKey Property

Used by the server to track the current state of the client. For operations with folders only

string FoldersSyncKey {get;}

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


HeartbeatInterval Property

Aspose.Email

IActiveSyncTLClient.HeartbeatInterval Property

The HeartbeatInterval element is a child element of the Ping element in Ping command requests and responses. In Ping command requests, it specifies the length of time, in seconds, that the server SHOULD wait before sending a response if no new items are added to the specified set of folders, as specified in section 3.1.5.6. The HeartbeatInterval element is also returned by the server with a status code of 5 and specifies either the minimum or maximum interval that is allowed when the client has requested a heartbeat interval that is outside the acceptable range.

int HeartbeatInterval {get; set;}

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


IActiveSyncTLClient Methods

The methods of the IActiveSyncTLClient interface are listed below. For a complete list of IActiveSyncTLClient interface members, see the IActiveSyncTLClient Members topic.

Public Instance Methods

FolderCreate | The FolderCreate creates a new folder as a child folder of the specified parent folder.
FolderDelete | Deletes the collection with the matching identifier.
FolderSync | Overloaded. The FolderSync synchronizes the collection hierarchy but does not synchronize the items in the collections themselves.
FolderUpdate | Overloaded. The FolderUpdate command moves a folder from one location to another on the server. The command is also used to rename a folder.
GetAttachment | The GetAttachment retrieves an email attachment from the server. The GetAttachment is not supported when the protocol version is 14.0 or 14.1. Use the Fetch element of the ItemOperations command instead.
GetItemEstimate | Overloaded. The GetItemEstimate command gets an estimate of the number of items in a collection or folder on the server that have to be synchronized.
ItemOperations | The ItemOperations provides batched online handling of the Fetch, the EmptyFolderContents, and the Move operations.
MeetingResponse | Overloaded. Accepts, tentatively accepts, or declines a meeting request in the user's Inbox folder or Calendar folder.
MoveItem | The MoveItems command moves an item or items from one folder on the server to another.
MoveItems | Overloaded. The MoveItems command moves an item or items from one folder on the server to another.
Ping | Overloaded. The Ping command is used to request that the server monitor specified folders for changes that would require the client to resynchronize.
Provision | The Provision command enables client devices to request from the server the security policy settings that the administrator sets, such as the minimum personal identification number (PIN) password length requirement.
ResetAirSyncKey | Overloaded. Reset SyncKey for GetItemEstimate and Sync operations for defined collection.
ResetFoldersSyncKey | Reset SyncKey for operations with folders
ResolveRecipients | The ResolveRecipients is used to resolve a list of supplied recipients, to retrieve their free/busy information, and optionally, to retrieve their S/MIME certificates so that clients can send encrypted S/MIME email messages. Retrieval of free/busy information using the Availability element in the ResolveRecipients command is not supported when the protocol version is 12.1.
Search | The Search is used to find entries in an address book, mailbox, or document library (UNC or Windows SharePoint Services).
SendMail | Overloaded. The SendMail is used by clients to send MIME-formatted email messages to the server.
Settings | The Settings supports get and set operations on global properties and Out of Office (OOF) settings for the user. The Settings also sends device information to the server, implements the device password/personal identification number (PIN) recovery, and retrieves a list of the user's email addresses.
SmartForward | The SmartForward command is used by clients to forward messages without retrieving the full, original message from the server.
SmartReply | The SmartReply command is used by clients to reply to messages without retrieving the full, original message from the server.
Sync | The Sync synchronizes changes in a collection between the client and the server.
ValidateCert | Overloaded. The ValidateCert command is used by the client to validate a certificate that has been received via an S/MIME mail.

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


IActiveSyncTLClient.FolderCreate Method

The FolderCreate creates a new folder as a child folder of the specified parent folder.

FolderInfo FolderCreate(
string parentId,
string displayName,
UserCreatedFolderTypes type
);

Parameters

parentId
Specifies the server ID of the parent folder of the folder on the server
displayName
Specifies the name of the folder that is shown to the user.
type
Specifies the type of the folder to be created.

Return Value

Returns folder information of the created folder

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


IActiveSyncTLClient.FolderDelete Method

Deletes the collection with the matching identifier.

void FolderDelete(
string serverId
);

Parameters

serverId
Identifies a folder on a server.

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


FolderSync Method

Aspose.Email

IActiveSyncTLClient.FolderSync Method

The FolderSync synchronizes the collection hierarchy but does not synchronize the items in the collections themselves.

Overload List

The FolderSync synchronizes the collection hierarchy but does not synchronize the items in the collections themselves.

FolderSyncResult FolderSync();

The FolderSync synchronizes the collection hierarchy but does not synchronize the items in the collections themselves.

FolderSyncResult FolderSync(bool);

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


IActiveSyncTLClient.FolderSync Method ()

The FolderSync synchronizes the collection hierarchy but does not synchronize the items in the collections themselves.

FolderSyncResult FolderSync();

Return Value

Returns changes to the folder hierarchy.

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | IActiveSyncTLClient.FolderSync Overload List


IActiveSyncTLClient.FolderSync Method (Boolean)

The FolderSync synchronizes the collection hierarchy but does not synchronize the items in the collections themselves.

FolderSyncResult FolderSync(
bool resetSyncKey
);

Parameters

resetSyncKey
Indicates if SyncKey for operations with folders has to be reseted or not.

Return Value

Returns changes to the folder hierarchy.

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | IActiveSyncTLClient.FolderSync Overload List


FolderUpdate Method

Aspose.Email

IActiveSyncTLClient.FolderUpdate Method

The FolderUpdate command moves a folder from one location to another on the server. The command is also used to rename a folder.

Overload List

The FolderUpdate command moves a folder from one location to another on the server. The command is also used to rename a folder.

void FolderUpdate(FolderInfo);

The FolderUpdate command moves a folder from one location to another on the server. The command is also used to rename a folder.

void FolderUpdate(string,string,string);

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


IActiveSyncTLClient.FolderUpdate Method (FolderInfo)

The FolderUpdate command moves a folder from one location to another on the server. The command is also used to rename a folder.

void FolderUpdate(
FolderInfo folder
);

Parameters

folder
Folder information

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | IActiveSyncTLClient.FolderUpdate Overload List


IActiveSyncTLClient.FolderUpdate Method (String, String, String)

The FolderUpdate command moves a folder from one location to another on the server. The command is also used to rename a folder.

void FolderUpdate(
string serverId,
string parentId,
string displayName
);

Parameters

serverId
Specifies the server ID of the folder on the server
parentId
Specifies the server ID of the parent folder of the folder on the server
displayName
Specifies the user-friendly name of the folder.

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | IActiveSyncTLClient.FolderUpdate Overload List


IActiveSyncTLClient.GetAttachment Method

The GetAttachment retrieves an email attachment from the server. The GetAttachment is not supported when the protocol version is 14.0 or 14.1. Use the Fetch element of the ItemOperations command instead.

byte[] GetAttachment(
string AttachmentName
);

Parameters

AttachmentName
The name of the attachment to be retrieved.

Return Value

Returns attachment data

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


GetItemEstimate Method

Aspose.Email

IActiveSyncTLClient.GetItemEstimate Method

The GetItemEstimate command gets an estimate of the number of items in a collection or folder on the server that have to be synchronized.

Overload List

The GetItemEstimate command gets an estimate of the number of items in a collection or folder on the server that have to be synchronized.

ItemEstimate GetItemEstimate(ItemEstimateRequest);

The GetItemEstimate command gets an estimate of the number of items in a collection or folder on the server that have to be synchronized.

ItemEstimate[] GetItemEstimate(params ItemEstimateRequest[]);

The GetItemEstimate command gets an estimate of the number of items in a collection or folder on the server that have to be synchronized.

ItemEstimate[] GetItemEstimate(ItemEstimateRequest});

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


IActiveSyncTLClient.GetItemEstimate Method (ItemEstimateRequest)

The GetItemEstimate command gets an estimate of the number of items in a collection or folder on the server that have to be synchronized.

ItemEstimate GetItemEstimate(
ItemEstimateRequest request
);

Parameters

request
ItemEstimate request parameters

Return Value

Estimate on the requested folder

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | IActiveSyncTLClient.GetItemEstimate Overload List


IActiveSyncTLClient.GetItemEstimate Method (ItemEstimateRequest[])

The GetItemEstimate command gets an estimate of the number of items in a collection or folder on the server that have to be synchronized.

ItemEstimate[] GetItemEstimate(
params ItemEstimateRequest[] request
);

Parameters

request
Array with ItemEstimate request parameters

Return Value

Contains array with estimates on the requested folders

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | IActiveSyncTLClient.GetItemEstimate Overload List


IActiveSyncTLClient.GetItemEstimate Method (ItemEstimateRequest})

The GetItemEstimate command gets an estimate of the number of items in a collection or folder on the server that have to be synchronized.

ItemEstimate[] GetItemEstimate(
IEnumerable<ItemEstimateRequest> request
);

Parameters

request
Enumeration with ItemEstimate request parameters

Return Value

Contains array with estimates on the requested folders

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | IActiveSyncTLClient.GetItemEstimate Overload List


IActiveSyncTLClient.ItemOperations Method

The ItemOperations provides batched online handling of the Fetch, the EmptyFolderContents, and the Move operations.

ItemOperationsResponse ItemOperations(
ItemOperationsRequest request
);

Parameters

request
ItemOperations request.

Return Value

Returns ItemOperations result

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


MeetingResponse Method

Aspose.Email

IActiveSyncTLClient.MeetingResponse Method

Accepts, tentatively accepts, or declines a meeting request in the user's Inbox folder or Calendar folder.

Overload List

Accepts, tentatively accepts, or declines a meeting request in the user's Inbox folder or Calendar folder.

MeetingResponseResult[] MeetingResponse(params MeetingResponseRequest[]);

Accepts, tentatively accepts, or declines a meeting request in the user's Inbox folder or Calendar folder.

MeetingResponseResult MeetingResponse(UserResponse,string,string);

Accepts, tentatively accepts, or declines a meeting request in the user's Inbox folder or Calendar folder.

MeetingResponseResult MeetingResponse(UserResponse,string,string,string,string);

Accepts, tentatively accepts, or declines a meeting request in the user's Inbox folder or Calendar folder.

MeetingResponseResult[] MeetingResponse(MeetingResponseRequest});

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


IActiveSyncTLClient.MeetingResponse Method (MeetingResponseRequest[])

Accepts, tentatively accepts, or declines a meeting request in the user's Inbox folder or Calendar folder.

MeetingResponseResult[] MeetingResponse(
params MeetingResponseRequest[] request
);

Parameters

request
Array of MeetingResponseRequest objects

Return Value

Returns array of MeetingResponseResult objects.

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | IActiveSyncTLClient.MeetingResponse Overload List


IActiveSyncTLClient.MeetingResponse Method (UserResponse, String, String)

Accepts, tentatively accepts, or declines a meeting request in the user's Inbox folder or Calendar folder.

MeetingResponseResult MeetingResponse(
UserResponse userResponse,
string collectionId,
string requestId
);

Parameters

userResponse
Indicates whether the meeting is being accepted, tentatively accepted, or declined.
collectionId
Specifies the folder that contains the meeting request. Optional if LongId is included. The CollectionId value can be up to 64 characters in length.
requestId
Specifies the server ID of the meeting request message item. Optional if LongId is included. The RequestId value can be up to 64 characters in length.

Return Value

Returns MeetingResponseResult object.

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | IActiveSyncTLClient.MeetingResponse Overload List


IActiveSyncTLClient.MeetingResponse Method (UserResponse, String, String, String, String)

Accepts, tentatively accepts, or declines a meeting request in the user's Inbox folder or Calendar folder.

MeetingResponseResult MeetingResponse(
UserResponse userResponse,
string collectionId,
string requestId,
string longId,
string instanceId
);

Parameters

userResponse
Indicates whether the meeting is being accepted, tentatively accepted, or declined.
collectionId
Specifies the folder that contains the meeting request. Optional if LongId is included. The CollectionId value can be up to 64 characters in length.
requestId
Specifies the server ID of the meeting request message item. Optional if LongId is included. The RequestId value can be up to 64 characters in length.
longId
Specifies the long ID for the source meeting request, which is returned in the Search command response message. If the LongId is present, the CollectionId, InstanceId, and RequestId are not present. The LongId value can be up to 256 characters in length.
instanceId
Specifies the instance of the recurring meeting to be modified. The InstanceId is not supported when the protocol version is 12.1 or 14.0. A Status value of 2 is returned if the InstanceId element is included in requests in which the protocol version is 12.1 or 14.0. The InstanceId contains the start time of the appointment or meeting instance to be modified. If the InstanceId is not included in the MeetingResponse request, then the action is to be taken on every instance of the recurring item. The InstanceId can specify the start time of an exception to a recurring appointment or meeting. The InstanceId can be used with the LongId to identify a calendar item, or it can be used with the CollectionId and RequestId to identify a calendar item. The format of the InstanceId value is a string in dateTime format with the punctuation separators, for example, 2010-04-08T18:16:00.000Z. If the InstanceId value specified is not in the proper format, the server responds with a Status element value of 104. If the InstanceId value specifies a non-recurring meeting, the server responds with a Status element value of 146.

Return Value

Returns MeetingResponseResult object.

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | IActiveSyncTLClient.MeetingResponse Overload List


IActiveSyncTLClient.MeetingResponse Method (MeetingResponseRequest})

Accepts, tentatively accepts, or declines a meeting request in the user's Inbox folder or Calendar folder.

MeetingResponseResult[] MeetingResponse(
IEnumerable<MeetingResponseRequest> request
);

Parameters

request
Enumeration of MeetingResponseRequest objects

Return Value

Returns array of MeetingResponseResult objects.

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | IActiveSyncTLClient.MeetingResponse Overload List


IActiveSyncTLClient.MoveItem Method

The MoveItems command moves an item or items from one folder on the server to another.

MoveItemResponse MoveItem(
string srcMsgId,
string srcFldId,
string dstFldId
);

Parameters

srcMsgId
Specifies the server ID of the item that was moved. The SrcMsgId element value can be up to 64 characters in length.
srcFldId
Specifies the server ID of the source folder (that is, the folder that contains the items to be moved). The SrcFldId element value can be up to 64 characters in length
dstFldId
Specifies the server ID of the destination folder (that is, the folder to which the items are moved). The DstFldId property value can be up to 64 characters in length.

Return Value

Returns information that describe the moved item.

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


MoveItems Method

Aspose.Email

IActiveSyncTLClient.MoveItems Method

The MoveItems command moves an item or items from one folder on the server to another.

Overload List

The MoveItems command moves an item or items from one folder on the server to another.

MoveItemResponse[] MoveItems(params MoveItemData[]);

The MoveItems command moves an item or items from one folder on the server to another.

MoveItemResponse[] MoveItems(MoveItemData});

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


IActiveSyncTLClient.MoveItems Method (MoveItemData[])

The MoveItems command moves an item or items from one folder on the server to another.

MoveItemResponse[] MoveItems(
params MoveItemData[] request
);

Parameters

request
Array of the items that has to be moved

Return Value

Returns array of objects that describe the moved item.

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | IActiveSyncTLClient.MoveItems Overload List


IActiveSyncTLClient.MoveItems Method (MoveItemData})

The MoveItems command moves an item or items from one folder on the server to another.

MoveItemResponse[] MoveItems(
IEnumerable<MoveItemData> request
);

Parameters

request
Enumeration of the items that has to be moved

Return Value

Returns array of objects that describe the moved item.

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | IActiveSyncTLClient.MoveItems Overload List


Ping Method

Aspose.Email

IActiveSyncTLClient.Ping Method

The Ping command is used to request that the server monitor specified folders for changes that would require the client to resynchronize.

Overload List

The Ping command is used to request that the server monitor specified folders for changes that would require the client to resynchronize.

string[] Ping(params PingParameter[]);

The Ping command is used to request that the server monitor specified folders for changes that would require the client to resynchronize.

string[] Ping(PingParameter});

The Ping command is used to request that the server monitor specified folders for changes that would require the client to resynchronize.

string[] Ping(int,params PingParameter[]);

The Ping command is used to request that the server monitor specified folders for changes that would require the client to resynchronize.

string[] Ping(int,PingParameter});

The Ping command is used to request that the server monitor specified folders for changes that would require the client to resynchronize.

string[] Ping(int,string,FolderClass);

The Ping command is used to request that the server monitor specified folders for changes that would require the client to resynchronize.

string[] Ping(string,FolderClass);

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


IActiveSyncTLClient.Ping Method (PingParameter[])

The Ping command is used to request that the server monitor specified folders for changes that would require the client to resynchronize.

string[] Ping(
params PingParameter[] pingParameters
);

Parameters

pingParameters
Ping parameters

Return Value

Array of folders where changes has been discovered

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | IActiveSyncTLClient.Ping Overload List


IActiveSyncTLClient.Ping Method (PingParameter})

The Ping command is used to request that the server monitor specified folders for changes that would require the client to resynchronize.

string[] Ping(
IEnumerable<PingParameter> pingParameters
);

Parameters

pingParameters
Ping parameters

Return Value

Array of folders where changes has been discovered

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | IActiveSyncTLClient.Ping Overload List


IActiveSyncTLClient.Ping Method (Int32, PingParameter[])

The Ping command is used to request that the server monitor specified folders for changes that would require the client to resynchronize.

string[] Ping(
int heartbeatInterval,
params PingParameter[] pingParameters
);

Parameters

heartbeatInterval
The HeartbeatInterval specifies the length of time, in seconds, that the server SHOULD wait before sending a response if no new items are added to the specified set of folders.
pingParameters
Ping parameters

Return Value

Array of folders where changes has been discovered

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | IActiveSyncTLClient.Ping Overload List


IActiveSyncTLClient.Ping Method (Int32, PingParameter})

The Ping command is used to request that the server monitor specified folders for changes that would require the client to resynchronize.

string[] Ping(
int heartbeatInterval,
IEnumerable<PingParameter> pingParameters
);

Parameters

heartbeatInterval
The HeartbeatInterval specifies the length of time, in seconds, that the server SHOULD wait before sending a response if no new items are added to the specified set of folders.
pingParameters
Ping parameters

Return Value

Array of folders where changes has been discovered

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | IActiveSyncTLClient.Ping Overload List


IActiveSyncTLClient.Ping Method (Int32, String, FolderClass)

The Ping command is used to request that the server monitor specified folders for changes that would require the client to resynchronize.

string[] Ping(
int heartbeatInterval,
string serverId,
FolderClass fClass
);

Parameters

heartbeatInterval
The HeartbeatInterval specifies the length of time, in seconds, that the server SHOULD wait before sending a response if no new items are added to the specified set of folders.
serverId
The Id element is a required child element of the Folder element in Ping command requests that specifies the server ID of the folder to be monitored.
fClass
The Class element is a required child element of the Folder element in Ping command requests that specifies the content class of the folder to be monitored.

Return Value

Array of folders where changes has been discovered

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | IActiveSyncTLClient.Ping Overload List


IActiveSyncTLClient.Ping Method (String, FolderClass)

The Ping command is used to request that the server monitor specified folders for changes that would require the client to resynchronize.

string[] Ping(
string serverId,
FolderClass fClass
);

Parameters

serverId
The Id element is a required child element of the Folder element in Ping command requests that specifies the server ID of the folder to be monitored.
fClass
The Class element is a required child element of the Folder element in Ping command requests that specifies the content class of the folder to be monitored.

Return Value

Array of folders where changes has been discovered

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | IActiveSyncTLClient.Ping Overload List


IActiveSyncTLClient.Provision Method

The Provision command enables client devices to request from the server the security policy settings that the administrator sets, such as the minimum personal identification number (PIN) password length requirement.

ProvisionResponse Provision(
ProvisionRequest request
);

Parameters

request
Provision operation parameters

Return Value

Returns Provision operation result

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ResetAirSyncKey Method

Aspose.Email

IActiveSyncTLClient.ResetAirSyncKey Method

Reset SyncKeys for GetItemEstimate and Sync operations for all collections.

Overload List

Reset SyncKeys for GetItemEstimate and Sync operations for all collections.

void ResetAirSyncKey();

Reset SyncKey for GetItemEstimate and Sync operations for defined collection.

void ResetAirSyncKey(string);

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


IActiveSyncTLClient.ResetAirSyncKey Method ()

Reset SyncKeys for GetItemEstimate and Sync operations for all collections.

void ResetAirSyncKey();

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | IActiveSyncTLClient.ResetAirSyncKey Overload List


IActiveSyncTLClient.ResetAirSyncKey Method (String)

Reset SyncKey for GetItemEstimate and Sync operations for defined collection.

void ResetAirSyncKey(
string serverId
);

Parameters

serverId
Server Id of the collection.

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | IActiveSyncTLClient.ResetAirSyncKey Overload List


IActiveSyncTLClient.ResetFoldersSyncKey Method

Reset SyncKey for operations with folders

void ResetFoldersSyncKey();

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


IActiveSyncTLClient.ResolveRecipients Method

The ResolveRecipients is used to resolve a list of supplied recipients, to retrieve their free/busy information, and optionally, to retrieve their S/MIME certificates so that clients can send encrypted S/MIME email messages. Retrieval of free/busy information using the Availability element in the ResolveRecipients command is not supported when the protocol version is 12.1.

ResolveRecipientsResponse ResolveRecipients(
ResolveRecipientsRequest request
);

Parameters

request
ResolveRecipients operation parameters

Return Value

Returns ResolveRecipients operation result

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


IActiveSyncTLClient.Search Method

The Search is used to find entries in an address book, mailbox, or document library (UNC or Windows SharePoint Services).

SearchResponse Search(
SearchRequest request
);

Parameters

request
Search operation parameters

Return Value

Returns Search operation result

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SendMail Method

Aspose.Email

IActiveSyncTLClient.SendMail Method

The SendMail is used by clients to send MIME-formatted email messages to the server.

Overload List

The SendMail is used by clients to send MIME-formatted email messages to the server.

string SendMail(string);

The SendMail is used by clients to send MIME-formatted email messages to the server.

string SendMail(string,bool);

The SendMail is used by clients to send MIME-formatted email messages to the server.

string SendMail(string,bool,string);

The SendMail is used by clients to send MIME-formatted email messages to the server.

string SendMail(string,bool,string,string);

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


IActiveSyncTLClient.SendMail Method (String)

The SendMail is used by clients to send MIME-formatted email messages to the server.

string SendMail(
string mimeContent
);

Parameters

mimeContent
Contains the MIME-encoded message.

Return Value

Returns the client's unique message ID (MID).

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | IActiveSyncTLClient.SendMail Overload List


IActiveSyncTLClient.SendMail Method (String, Boolean)

The SendMail is used by clients to send MIME-formatted email messages to the server.

string SendMail(
string mimeContent,
bool saveInSentItems
);

Parameters

mimeContent
Contains the MIME-encoded message.
saveInSentItems
Specifies whether a copy of the message will be stored in the Sent Items folder.

Return Value

Returns the client's unique message ID (MID).

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | IActiveSyncTLClient.SendMail Overload List


IActiveSyncTLClient.SendMail Method (String, Boolean, String)

The SendMail is used by clients to send MIME-formatted email messages to the server.

string SendMail(
string mimeContent,
bool saveInSentItems,
string accountId
);

Parameters

mimeContent
Contains the MIME-encoded message.
saveInSentItems
Specifies whether a copy of the message will be stored in the Sent Items folder.
accountId
Identifies the account from which an email is sent.

Return Value

Returns the client's unique message ID (MID).

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | IActiveSyncTLClient.SendMail Overload List


IActiveSyncTLClient.SendMail Method (String, Boolean, String, String)

The SendMail is used by clients to send MIME-formatted email messages to the server.

string SendMail(
string mimeContent,
bool saveInSentItems,
string accountId,
string templateId
);

Parameters

mimeContent
Contains the MIME-encoded message.
saveInSentItems
Specifies whether a copy of the message will be stored in the Sent Items folder.
accountId
Identifies the account from which an email is sent.
templateId
Contains a string that identifies the rights policy template.

Return Value

Returns the client's unique message ID (MID).

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | IActiveSyncTLClient.SendMail Overload List


IActiveSyncTLClient.Settings Method

The Settings supports get and set operations on global properties and Out of Office (OOF) settings for the user. The Settings also sends device information to the server, implements the device password/personal identification number (PIN) recovery, and retrieves a list of the user's email addresses.

SettingsResponse Settings(
SettingsRequest request
);

Parameters

request
Settings operation parameters

Return Value

Returns settings operation result

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


IActiveSyncTLClient.SmartForward Method

The SmartForward command is used by clients to forward messages without retrieving the full, original message from the server.

void SmartForward(
SmartRequest request
);

Parameters

request
SmartForward operation parameters

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


IActiveSyncTLClient.SmartReply Method

The SmartReply command is used by clients to reply to messages without retrieving the full, original message from the server.

void SmartReply(
SmartRequest request
);

Parameters

request
SmartReply operation parameters

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


IActiveSyncTLClient.Sync Method

The Sync synchronizes changes in a collection between the client and the server.

List<SyncCollectionResponse> Sync(
SyncRequest request
);

Parameters

request
Sync request parameters

Return Value

Returns list of responses for Sync operations such as Add, Fetch, Change

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ValidateCert Method

Aspose.Email

IActiveSyncTLClient.ValidateCert Method

The ValidateCert is used by the client to validate a certificate that has been received via an S/MIME mail.

Overload List

The ValidateCert is used by the client to validate a certificate that has been received via an S/MIME mail.

CertificateStatuses} ValidateCert(X509Certificate});

The ValidateCert is used by the client to validate a certificate that has been received via an S/MIME mail.

CertificateStatuses} ValidateCert(X509Certificate},bool);

The ValidateCert is used by the client to validate a certificate that has been received via an S/MIME mail.

CertificateStatuses} ValidateCert(X509Certificate},X509Certificate});

The ValidateCert is used by the client to validate a certificate that has been received via an S/MIME mail.

CertificateStatuses} ValidateCert(X509Certificate},X509Certificate},bool);

The ValidateCert command is used by the client to validate a certificate that has been received via an S/MIME mail.

CertificateStatuses} ValidateCert(X509Certificate);

The ValidateCert is used by the client to validate a certificate that has been received via an S/MIME mail.

CertificateStatuses} ValidateCert(X509Certificate,bool);

The ValidateCert is used by the client to validate a certificate that has been received via an S/MIME mail.

CertificateStatuses} ValidateCert(X509Certificate,X509Certificate});

The ValidateCert is used by the client to validate a certificate that has been received via an S/MIME mail.

CertificateStatuses} ValidateCert(X509Certificate,X509Certificate},bool);

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


IActiveSyncTLClient.ValidateCert Method (X509Certificate})

The ValidateCert is used by the client to validate a certificate that has been received via an S/MIME mail.

List<CertificateStatuses> ValidateCert(
IEnumerable<X509Certificate> certificates
);

Parameters

certificates
Enumeration of certificates that have to be validated.

Return Value

List of validation certificate statuses

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | IActiveSyncTLClient.ValidateCert Overload List


IActiveSyncTLClient.ValidateCert Method (X509Certificate}, Boolean)

The ValidateCert is used by the client to validate a certificate that has been received via an S/MIME mail.

List<CertificateStatuses> ValidateCert(
IEnumerable<X509Certificate> certificates,
bool checkCrl
);

Parameters

certificates
Enumeration of certificates that have to be validated.
checkCrl
Specifies whether the server SHOULD ignore an unverifiable revocation status. The revocation status of a certificate cannot be verified when the certificate revocation lists (CRLs) cannot be retrieved. When the CheckCRL value is set to TRUE, the server MUST NOT ignore an unverifiable revocation status. When the CheckCRL value is set to FALSE, the server SHOULD ignore an unverifiable revocation status. The default value is FALSE.

Return Value

List of validation certificate statuses

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | IActiveSyncTLClient.ValidateCert Overload List


IActiveSyncTLClient.ValidateCert Method (X509Certificate}, X509Certificate})

The ValidateCert is used by the client to validate a certificate that has been received via an S/MIME mail.

List<CertificateStatuses> ValidateCert(
IEnumerable<X509Certificate> certificates,
IEnumerable<X509Certificate> certificateChains
);

Parameters

certificates
Enumeration of certificates that have to be validated.
certificateChains
Enumeration of certificates that have to be validated.

Return Value

List of validation certificate statuses

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | IActiveSyncTLClient.ValidateCert Overload List


IActiveSyncTLClient.ValidateCert Method (X509Certificate}, X509Certificate}, Boolean)

The ValidateCert is used by the client to validate a certificate that has been received via an S/MIME mail.

List<CertificateStatuses> ValidateCert(
IEnumerable<X509Certificate> certificates,
IEnumerable<X509Certificate> certificateChains,
bool checkCrl
);

Parameters

certificates
Enumeration of certificates that have to be validated.
certificateChains
Enumeration of certificates that have to be validated.
checkCrl
Specifies whether the server SHOULD ignore an unverifiable revocation status. The revocation status of a certificate cannot be verified when the certificate revocation lists (CRLs) cannot be retrieved. When the CheckCRL value is set to TRUE, the server MUST NOT ignore an unverifiable revocation status. When the CheckCRL value is set to FALSE, the server SHOULD ignore an unverifiable revocation status. The default value is FALSE.

Return Value

List of validation certificate statuses

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | IActiveSyncTLClient.ValidateCert Overload List


IActiveSyncTLClient.ValidateCert Method (X509Certificate)

The ValidateCert command is used by the client to validate a certificate that has been received via an S/MIME mail.

List<CertificateStatuses> ValidateCert(
X509Certificate certificate
);

Parameters

certificate
Certificate that has to be validated.

Return Value

List of validation certificate statuses

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | IActiveSyncTLClient.ValidateCert Overload List


IActiveSyncTLClient.ValidateCert Method (X509Certificate, Boolean)

The ValidateCert is used by the client to validate a certificate that has been received via an S/MIME mail.

List<CertificateStatuses> ValidateCert(
X509Certificate certificate,
bool checkCrl
);

Parameters

certificate
Certificate that has to be validated.
checkCrl
Specifies whether the server SHOULD ignore an unverifiable revocation status. The revocation status of a certificate cannot be verified when the certificate revocation lists (CRLs) cannot be retrieved. When the CheckCRL value is set to TRUE, the server MUST NOT ignore an unverifiable revocation status. When the CheckCRL value is set to FALSE, the server SHOULD ignore an unverifiable revocation status. The default value is FALSE.

Return Value

List of validation certificate statuses

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | IActiveSyncTLClient.ValidateCert Overload List


IActiveSyncTLClient.ValidateCert Method (X509Certificate, X509Certificate})

The ValidateCert is used by the client to validate a certificate that has been received via an S/MIME mail.

List<CertificateStatuses> ValidateCert(
X509Certificate certificate,
IEnumerable<X509Certificate> certificateChains
);

Parameters

certificate
Certificate that has to be validated.
certificateChains
List of certificates to be validated.

Return Value

List of validation certificate statuses

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | IActiveSyncTLClient.ValidateCert Overload List


IActiveSyncTLClient.ValidateCert Method (X509Certificate, X509Certificate}, Boolean)

The ValidateCert is used by the client to validate a certificate that has been received via an S/MIME mail.

List<CertificateStatuses> ValidateCert(
X509Certificate certificate,
IEnumerable<X509Certificate> certificateChains,
bool checkCrl
);

Parameters

certificate
Certificate that has to be validated.
certificateChains
List of certificates that have to be validated.
checkCrl
Specifies whether the server SHOULD ignore an unverifiable revocation status. The revocation status of a certificate cannot be verified when the certificate revocation lists (CRLs) cannot be retrieved. When the CheckCRL value is set to TRUE, the server MUST NOT ignore an unverifiable revocation status. When the CheckCRL value is set to FALSE, the server SHOULD ignore an unverifiable revocation status. The default value is FALSE.

Return Value

List of validation certificate statuses

See Also

IActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | IActiveSyncTLClient.ValidateCert Overload List


IBaseActiveSyncTLClient Interface

Base ActiveSync client interface

For a list of all members of this type, see IBaseActiveSyncTLClient Members.

Aspose.Email.Protocols.ActiveSync.TransportLayer.IBaseActiveSyncTLClient
Aspose.Email.Protocols.ActiveSync.TransportLayer.IActiveSyncTLClient

public interface IBaseActiveSyncTLClient : IDisposable

Types that implement IBaseActiveSyncTLClient

Type | Description
ActiveSyncTLClient | Basic class for ActiveSync client implementations

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

IBaseActiveSyncTLClient Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


IBaseActiveSyncTLClient Members

IBaseActiveSyncTLClient overview

Public Instance Properties

AuthenticationType | Gets or sets the type of authentication is used by the ActiveSync client.
AutodiscoverUri | Gets the autodiscover uri
Credentials | User's credentials for Exchange server
DeviceID | A GUID that identifies the device. The device ID is specified by the device-id-spec ABNF rule portion of the plain text query value. The value, represented by the device-id ABNF rule, is a string that specifies the device. Each device MUST have a unique device ID string. Each request from the device MUST include the same device ID string.
DeviceType | The device type is specified by the device-type-spec ABNF rule portion of the plain text query value. The value, represented by the device-type ABNF rule, is any string that specifies a device type. "SP" specifies a SmartPhone and "PPC" specifies a PocketPC. Other client devices send unique strings for their specific device type. Each request from a client device MUST include the same device type string.
PolicyKey | An unsigned integer that indicates the state of policy settings on the client device, as specified in [MS-ASPROV] section 2.2.2.41.
Proxy | Gets or sets the proxy.
SupportedServerCommands | Gets the versions of ActiveSync commands which are server supported
SupportedServerProtocols | Gets the versions of ActiveSync protocols which are server supported
Timeout | Gets or sets the number of milliseconds to wait before the operation times out. The default value is 100,000 milliseconds (100 seconds).
Uri | Gets the server uri
UserAgent | The User-Agent request-header field contains information about the user agent originating the request. This is for statistical purposes, the tracing of protocol violations, and automated recognition of user agents for the sake of tailoring responses to avoid particular user agent limitations. User agents SHOULD include this field with requests. The field can contain multiple product tokens (section 3.8) and comments identifying the agent and any subproducts which form a significant part of the user agent. By convention, the product tokens are listed in order of their significance for identifying the application. Example: User-Agent: CERN-LineMode/2.15 libwww/2.17b3
Version | Gets the version of the protocol which is used in ActiveSync client.

Public Instance Methods

Autodiscover The Autodiscover command facilitates the discovery of core account configuration information by using the user's Simple Mail Transfer Protocol (SMTP) address as the primary input.

See Also

IBaseActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


IBaseActiveSyncTLClient Properties

The properties of the IBaseActiveSyncTLClient interface are listed below. For a complete list of IBaseActiveSyncTLClient interface members, see the IBaseActiveSyncTLClient Members topic.

Public Instance Properties

AuthenticationType | Gets or sets the type of authentication is used by the ActiveSync client.
AutodiscoverUri | Gets the autodiscover uri
Credentials | User's credentials for Exchange server
DeviceID | A GUID that identifies the device. The device ID is specified by the device-id-spec ABNF rule portion of the plain text query value. The value, represented by the device-id ABNF rule, is a string that specifies the device. Each device MUST have a unique device ID string. Each request from the device MUST include the same device ID string.
DeviceType | The device type is specified by the device-type-spec ABNF rule portion of the plain text query value. The value, represented by the device-type ABNF rule, is any string that specifies a device type. "SP" specifies a SmartPhone and "PPC" specifies a PocketPC. Other client devices send unique strings for their specific device type. Each request from a client device MUST include the same device type string.
PolicyKey | An unsigned integer that indicates the state of policy settings on the client device, as specified in [MS-ASPROV] section 2.2.2.41.
Proxy | Gets or sets the proxy.
SupportedServerCommands | Gets the versions of ActiveSync commands which are server supported
SupportedServerProtocols | Gets the versions of ActiveSync protocols which are server supported
Timeout | Gets or sets the number of milliseconds to wait before the operation times out. The default value is 100,000 milliseconds (100 seconds).
Uri | Gets the server uri
UserAgent | The User-Agent request-header field contains information about the user agent originating the request. This is for statistical purposes, the tracing of protocol violations, and automated recognition of user agents for the sake of tailoring responses to avoid particular user agent limitations. User agents SHOULD include this field with requests. The field can contain multiple product tokens (section 3.8) and comments identifying the agent and any subproducts which form a significant part of the user agent. By convention, the product tokens are listed in order of their significance for identifying the application. Example: User-Agent: CERN-LineMode/2.15 libwww/2.17b3
Version | Gets the version of the protocol which is used in ActiveSync client.

See Also

IBaseActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


AuthenticationType Property

Aspose.Email

IBaseActiveSyncTLClient.AuthenticationType Property

Gets or sets the type of authentication is used by the ActiveSync client.

ActiveSyncAuthenticationType AuthenticationType {get; set;}

See Also

IBaseActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


AutodiscoverUri Property

Aspose.Email

IBaseActiveSyncTLClient.AutodiscoverUri Property

Gets the autodiscover uri

string AutodiscoverUri {get; set;}

See Also

IBaseActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Credentials Property

Aspose.Email

IBaseActiveSyncTLClient.Credentials Property

User's credentials for Exchange server

NetworkCredential Credentials {get;}

See Also

IBaseActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


DeviceID Property

Aspose.Email

IBaseActiveSyncTLClient.DeviceID Property

A GUID that identifies the device. The device ID is specified by the device-id-spec ABNF rule portion of the plain text query value. The value, represented by the device-id ABNF rule, is a string that specifies the device. Each device MUST have a unique device ID string. Each request from the device MUST include the same device ID string.

string DeviceID {get; set;}

See Also

IBaseActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


DeviceType Property

Aspose.Email

IBaseActiveSyncTLClient.DeviceType Property

The device type is specified by the device-type-spec ABNF rule portion of the plain text query value. The value, represented by the device-type ABNF rule, is any string that specifies a device type. "SP" specifies a SmartPhone and "PPC" specifies a PocketPC. Other client devices send unique strings for their specific device type. Each request from a client device MUST include the same device type string.

string DeviceType {get; set;}

See Also

IBaseActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


PolicyKey Property

Aspose.Email

IBaseActiveSyncTLClient.PolicyKey Property

An unsigned integer that indicates the state of policy settings on the client device, as specified in [MS-ASPROV] section 2.2.2.41.

UInt32} PolicyKey {get; set;}

See Also

IBaseActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Proxy Property

Aspose.Email

IBaseActiveSyncTLClient.Proxy Property

Gets or sets the proxy.

WebProxy Proxy {get; set;}

See Also

IBaseActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SupportedServerCommands Property

Aspose.Email

IBaseActiveSyncTLClient.SupportedServerCommands Property

Gets the versions of ActiveSync commands which are server supported

string[] SupportedServerCommands {get;}

See Also

IBaseActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SupportedServerProtocols Property

Aspose.Email

IBaseActiveSyncTLClient.SupportedServerProtocols Property

Gets the versions of ActiveSync protocols which are server supported

string[] SupportedServerProtocols {get;}

See Also

IBaseActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Timeout Property

Aspose.Email

IBaseActiveSyncTLClient.Timeout Property

Gets or sets the number of milliseconds to wait before the operation times out. The default value is 100,000 milliseconds (100 seconds).

int Timeout {get; set;}

See Also

IBaseActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Uri Property

Aspose.Email

IBaseActiveSyncTLClient.Uri Property

Gets the server uri

string Uri {get;}

See Also

IBaseActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


UserAgent Property

Aspose.Email

IBaseActiveSyncTLClient.UserAgent Property

The User-Agent request-header field contains information about the user agent originating the request. This is for statistical purposes, the tracing of protocol violations, and automated recognition of user agents for the sake of tailoring responses to avoid particular user agent limitations. User agents SHOULD include this field with requests. The field can contain multiple product tokens (section 3.8) and comments identifying the agent and any subproducts which form a significant part of the user agent. By convention, the product tokens are listed in order of their significance for identifying the application. Example: User-Agent: CERN-LineMode/2.15 libwww/2.17b3

string UserAgent {get; set;}

See Also

IBaseActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Version Property

Aspose.Email

IBaseActiveSyncTLClient.Version Property

Gets the version of the protocol which is used in ActiveSync client.

ASProtocolVersions Version {get;}

See Also

IBaseActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


IBaseActiveSyncTLClient Methods

The methods of the IBaseActiveSyncTLClient interface are listed below. For a complete list of IBaseActiveSyncTLClient interface members, see the IBaseActiveSyncTLClient Members topic.

Public Instance Methods

Autodiscover The Autodiscover command facilitates the discovery of core account configuration information by using the user's Simple Mail Transfer Protocol (SMTP) address as the primary input.

See Also

IBaseActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


IBaseActiveSyncTLClient.Autodiscover Method

The Autodiscover command facilitates the discovery of core account configuration information by using the user's Simple Mail Transfer Protocol (SMTP) address as the primary input.

AutodiscoverResult Autodiscover(
string emailAddress
);

Parameters

emailAddress
The email address is a required child element of the autodiscover request

Return Value

Result of the Autodiscover operation

See Also

IBaseActiveSyncTLClient Interface | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItemEstimate Class

Contains an assessment on the requested folder

For a list of all members of this type, see ItemEstimate Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.ItemEstimate

public class ItemEstimate

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ItemEstimate Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItemEstimate Members

ItemEstimate overview

Public Instance Constructors

ItemEstimate Overloaded. Initializes a new instance of the ItemEstimate class.

Public Instance Properties

CollectionId | Specifies the server ID of the collection from which the item estimate is being obtained.
Estimate | Specifies the estimated number of items in the collection or folder that have to be synchronized.
Status | Indicates the result of an operation.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a string that represents the current object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ItemEstimate Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItemEstimate Constructor

Initializes a new instance of the ItemEstimate class.

Overload List

Initializes a new instance of the ItemEstimate class.

public ItemEstimate(Status);

Initializes a new instance of the ItemEstimate class.

public ItemEstimate(Status,string,int);

See Also

ItemEstimate Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItemEstimate Constructor (Status)

Initializes a new instance of the ItemEstimate class.

public ItemEstimate(
Status status
);

Parameters

status
Indicates the result of an operation.

See Also

ItemEstimate Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | ItemEstimate Constructor Overload List


ItemEstimate Constructor (Status, String, Int32)

Initializes a new instance of the ItemEstimate class.

public ItemEstimate(
Status status,
string collectionId,
int estimate
);

Parameters

status
Indicates the result of an operation.
collectionId
Specifies the server ID of the collection from which the item estimate is being obtained.
estimate
Specifies the estimated number of items in the collection or folder that have to be synchronized.

See Also

ItemEstimate Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | ItemEstimate Constructor Overload List


ItemEstimate Properties

The properties of the ItemEstimate class are listed below. For a complete list of ItemEstimate class members, see the ItemEstimate Members topic.

Public Instance Properties

CollectionId | Specifies the server ID of the collection from which the item estimate is being obtained.
Estimate | Specifies the estimated number of items in the collection or folder that have to be synchronized.
Status | Indicates the result of an operation.

See Also

ItemEstimate Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


CollectionId Property

Aspose.Email

ItemEstimate.CollectionId Property

Specifies the server ID of the collection from which the item estimate is being obtained.

public string CollectionId {get;}

See Also

ItemEstimate Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Estimate Property

Aspose.Email

ItemEstimate.Estimate Property

Specifies the estimated number of items in the collection or folder that have to be synchronized.

public int Estimate {get;}

See Also

ItemEstimate Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Status Property

Aspose.Email

ItemEstimate.Status Property

Indicates the result of an operation.

public Status Status {get;}

See Also

ItemEstimate Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItemEstimate Methods

The methods of the ItemEstimate class are listed below. For a complete list of ItemEstimate class members, see the ItemEstimate Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a string that represents the current object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ItemEstimate Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItemEstimate.ToString Method

Returns a string that represents the current object.

public override string ToString();

Return Value

A string that represents the current object.

See Also

ItemEstimate Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItemEstimateOptions Class

Contains elements that filter the results of the GetItemEstimate operation.

For a list of all members of this type, see ItemEstimateOptions Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.ItemEstimateOptions

public class ItemEstimateOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ItemEstimateOptions Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItemEstimateOptions Members

ItemEstimateOptions overview

Public Instance Constructors

ItemEstimateOptions Overloaded. Initializes a new instance of the ItemEstimateOptions class.

Public Instance Properties

Class | Identifies the class of the item.
FilterType | Specifies an optional time window for the objects
MaxItems | Specifies the maximum number of items to include in the response.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ItemEstimateOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItemEstimateOptions Constructor

Initializes a new instance of the ItemEstimateOptions class.

Overload List

Initializes a new instance of the ItemEstimateOptions class.

public ItemEstimateOptions();

Initializes a new instance of the ItemEstimateOptions class.

public ItemEstimateOptions(AirsyncClass},AirsyncFilterType},Int32});

See Also

ItemEstimateOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItemEstimateOptions Constructor ()

Initializes a new instance of the ItemEstimateOptions class.

public ItemEstimateOptions();

See Also

ItemEstimateOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | ItemEstimateOptions Constructor Overload List


ItemEstimateOptions Constructor (AirsyncClass}, AirsyncFilterType}, Int32})

Initializes a new instance of the ItemEstimateOptions class.

public ItemEstimateOptions(
Nullable<AirsyncClass> airClass,
Nullable<AirsyncFilterType> filterType,
Nullable<int> maxItems
);

Parameters

airClass
Identifies the class of the item.
filterType
Specifies an optional time window for the objects
maxItems
Specifies the maximum number of items to include in the response.

See Also

ItemEstimateOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | ItemEstimateOptions Constructor Overload List


ItemEstimateOptions Properties

The properties of the ItemEstimateOptions class are listed below. For a complete list of ItemEstimateOptions class members, see the ItemEstimateOptions Members topic.

Public Instance Properties

Class | Identifies the class of the item.
FilterType | Specifies an optional time window for the objects
MaxItems | Specifies the maximum number of items to include in the response.

See Also

ItemEstimateOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Class Property

Aspose.Email

ItemEstimateOptions.Class Property

Identifies the class of the item.

public AirsyncClass} Class {get; set;}

See Also

ItemEstimateOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


FilterType Property

Aspose.Email

ItemEstimateOptions.FilterType Property

Specifies an optional time window for the objects

public AirsyncFilterType} FilterType {get; set;}

See Also

ItemEstimateOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


MaxItems Property

Aspose.Email

ItemEstimateOptions.MaxItems Property

Specifies the maximum number of items to include in the response.

public Int32} MaxItems {get; set;}

See Also

ItemEstimateOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItemEstimateRequest Class

Contains ItemEstimate request parameters

For a list of all members of this type, see ItemEstimateRequest Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.ItemEstimateRequest

public class ItemEstimateRequest

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ItemEstimateRequest Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItemEstimateRequest Members

ItemEstimateRequest overview

Public Instance Constructors

ItemEstimateRequest Overloaded. Initializes a new instance of the ItemEstimateRequest class.

Public Instance Properties

CollectionId | Specifies the server ID of the collection from which the item estimate is being obtained.
ConversationMode | Specifies whether to include items that are included within the conversation modality within the results of the GetItemEstimate command response.
FilterType | Specifies an optional time window for the objects
Options | Contains array of elements that filter the results of the GetItemEstimate operation.
SyncKey | Represents the current state of a collection.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ItemEstimateRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItemEstimateRequest Constructor

Initializes a new instance of the ItemEstimateRequest class.

Overload List

Initializes a new instance of the ItemEstimateRequest class.

public ItemEstimateRequest();

Initializes a new instance of the ItemEstimateRequest class.

public ItemEstimateRequest(string,string,ItemEstimateOptions[],Boolean});

Initializes a new instance of the ItemEstimateRequest class.

public ItemEstimateRequest(string,string,AirsyncFilterType});

See Also

ItemEstimateRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItemEstimateRequest Constructor ()

Initializes a new instance of the ItemEstimateRequest class.

public ItemEstimateRequest();

See Also

ItemEstimateRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | ItemEstimateRequest Constructor Overload List


ItemEstimateRequest Constructor (String, String, ItemEstimateOptions[], Boolean})

Initializes a new instance of the ItemEstimateRequest class.

public ItemEstimateRequest(
string syncKey,
string collectionId,
ItemEstimateOptions[] options,
Nullable<bool> conversationMode
);

Parameters

syncKey
Represents the current state of a collection.
collectionId
Specifies the server ID of the collection from which the item estimate is being obtained.
options
Contains array of elements that filter the results of the GetItemEstimate operation.
conversationMode
Specifies whether to include items that are included within the conversation modality within the results of the GetItemEstimate command response.

See Also

ItemEstimateRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | ItemEstimateRequest Constructor Overload List


ItemEstimateRequest Constructor (String, String, AirsyncFilterType})

Initializes a new instance of the ItemEstimateRequest class.

public ItemEstimateRequest(
string syncKey,
string collectionId,
Nullable<AirsyncFilterType> filterType
);

Parameters

syncKey
Represents the current state of a collection.
collectionId
Specifies the server ID of the collection from which the item estimate is being obtained.
filterType
Specifies an optional time window for the objects

See Also

ItemEstimateRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | ItemEstimateRequest Constructor Overload List


ItemEstimateRequest Properties

The properties of the ItemEstimateRequest class are listed below. For a complete list of ItemEstimateRequest class members, see the ItemEstimateRequest Members topic.

Public Instance Properties

CollectionId | Specifies the server ID of the collection from which the item estimate is being obtained.
ConversationMode | Specifies whether to include items that are included within the conversation modality within the results of the GetItemEstimate command response.
FilterType | Specifies an optional time window for the objects
Options | Contains array of elements that filter the results of the GetItemEstimate operation.
SyncKey | Represents the current state of a collection.

See Also

ItemEstimateRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


CollectionId Property

Aspose.Email

ItemEstimateRequest.CollectionId Property

Specifies the server ID of the collection from which the item estimate is being obtained.

public string CollectionId {get; set;}

See Also

ItemEstimateRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ConversationMode Property

Aspose.Email

ItemEstimateRequest.ConversationMode Property

Specifies whether to include items that are included within the conversation modality within the results of the GetItemEstimate command response.

public Boolean} ConversationMode {get; set;}

See Also

ItemEstimateRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


FilterType Property

Aspose.Email

ItemEstimateRequest.FilterType Property

Specifies an optional time window for the objects

public AirsyncFilterType} FilterType {get; set;}

See Also

ItemEstimateRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Options Property

Aspose.Email

ItemEstimateRequest.Options Property

Contains array of elements that filter the results of the GetItemEstimate operation.

public ItemEstimateOptions[] Options {get; set;}

See Also

ItemEstimateRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncKey Property

Aspose.Email

ItemEstimateRequest.SyncKey Property

Represents the current state of a collection.

public string SyncKey {get; set;}

See Also

ItemEstimateRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItemOperationsEmptFldrCntntsResponce Class

Identifies the body of the response as containing the operation that deletes the contents of a folder.

For a list of all members of this type, see ItemOperationsEmptFldrCntntsResponce Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.ItemOperationsEmptFldrCntntsResponce

public class ItemOperationsEmptFldrCntntsResponce

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ItemOperationsEmptFldrCntntsResponce Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItemOperationsEmptFldrCntntsResponce Members

ItemOperationsEmptFldrCntntsResponce overview

Public Instance Constructors

ItemOperationsEmptFldrCntntsResponce Constructor Initializes a new instance of the ItemOperationsEmptFldrCntntsResponce class.

Public Instance Properties

CollectionId | Specifies the folder that has to be emptied. Contains ServerId of a folder.
Status | Contains a code and description that indicates the success or failure of the ItemOperations operation.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ItemOperationsEmptFldrCntntsResponce Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItemOperationsEmptFldrCntntsResponce Constructor

Initializes a new instance of the ItemOperationsEmptFldrCntntsResponce class.

public ItemOperationsEmptFldrCntntsResponce();

See Also

ItemOperationsEmptFldrCntntsResponce Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItemOperationsEmptFldrCntntsResponce Properties

The properties of the ItemOperationsEmptFldrCntntsResponce class are listed below. For a complete list of ItemOperationsEmptFldrCntntsResponce class members, see the ItemOperationsEmptFldrCntntsResponce Members topic.

Public Instance Properties

CollectionId | Specifies the folder that has to be emptied. Contains ServerId of a folder.
Status | Contains a code and description that indicates the success or failure of the ItemOperations operation.

See Also

ItemOperationsEmptFldrCntntsResponce Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


CollectionId Property

Aspose.Email

ItemOperationsEmptFldrCntntsResponce.CollectionId Property

Specifies the folder that has to be emptied. Contains ServerId of a folder.

public string CollectionId {get; set;}

See Also

ItemOperationsEmptFldrCntntsResponce Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Status Property

Aspose.Email

ItemOperationsEmptFldrCntntsResponce.Status Property

Contains a code and description that indicates the success or failure of the ItemOperations operation.

public Status Status {get; set;}

See Also

ItemOperationsEmptFldrCntntsResponce Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItemOperationsFetchProperties Class

Contains the properties that are returned for item(s) in the response.

For a list of all members of this type, see ItemOperationsFetchProperties Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.ItemOperationsFetchProperties

public class ItemOperationsFetchProperties

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ItemOperationsFetchProperties Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItemOperationsFetchProperties Members

ItemOperationsFetchProperties overview

Public Instance Constructors

ItemOperationsFetchProperties Constructor Initializes a new instance of the ItemOperationsFetchProperties class.

Public Instance Properties

Body | Specifies a free-form, variable-length data field associated with a stored item on the server.
BodyPart | Specifies details about the message part of an e-mail in a response.
Data | Contains the item content for inline content responses. The content of the Data element is a base64 encoding of the binary document, attachment, or body data. The size of the data (in bytes) that is contained within the Data element is indicated by the Range property. The total size of the item (in bytes) is indicated by the Total element.
DataContainer | Contains data elements from the content classes.
Part | Specifies an integer index into the metadata of the multipart response. The Part element is present only in a multipart ItemOperations response. It presents in Properties if the item being fetched is located in a document library.
Range | Specifies the range of bytes that the client can receive in response to the Fetch operation for a document library item. The Range element contains a string value in the format m-n, where m less than n, and m is the minimum value and n is the maximum value. The byte range is zero-indexed; the first byte is indicated by a 0 (zero). If the Range element is omitted in the Fetch request, the whole item is fetched.
RightsManagementLicense | Contains the rights policy template settings for the template applied to the e-mail message being synchronized.
Total | Specifies the total size of an item on the server, in bytes.
Version | Specifies the time at which a document item was last modified. The Version element is present only when the ItemOperations command is used to access a Windows SharePoint Services or UNC resource.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ItemOperationsFetchProperties Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItemOperationsFetchProperties Constructor

Initializes a new instance of the ItemOperationsFetchProperties class.

public ItemOperationsFetchProperties();

See Also

ItemOperationsFetchProperties Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItemOperationsFetchProperties Properties

The properties of the ItemOperationsFetchProperties class are listed below. For a complete list of ItemOperationsFetchProperties class members, see the ItemOperationsFetchProperties Members topic.

Public Instance Properties

Body | Specifies a free-form, variable-length data field associated with a stored item on the server.
BodyPart | Specifies details about the message part of an e-mail in a response.
Data | Contains the item content for inline content responses. The content of the Data element is a base64 encoding of the binary document, attachment, or body data. The size of the data (in bytes) that is contained within the Data element is indicated by the Range property. The total size of the item (in bytes) is indicated by the Total element.
DataContainer | Contains data elements from the content classes.
Part | Specifies an integer index into the metadata of the multipart response. The Part element is present only in a multipart ItemOperations response. It presents in Properties if the item being fetched is located in a document library.
Range | Specifies the range of bytes that the client can receive in response to the Fetch operation for a document library item. The Range element contains a string value in the format m-n, where m less than n, and m is the minimum value and n is the maximum value. The byte range is zero-indexed; the first byte is indicated by a 0 (zero). If the Range element is omitted in the Fetch request, the whole item is fetched.
RightsManagementLicense | Contains the rights policy template settings for the template applied to the e-mail message being synchronized.
Total | Specifies the total size of an item on the server, in bytes.
Version | Specifies the time at which a document item was last modified. The Version element is present only when the ItemOperations command is used to access a Windows SharePoint Services or UNC resource.

See Also

ItemOperationsFetchProperties Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Body Property

Aspose.Email

ItemOperationsFetchProperties.Body Property

Specifies a free-form, variable-length data field associated with a stored item on the server.

public Body} Body {get;}

See Also

ItemOperationsFetchProperties Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


BodyPart Property

Aspose.Email

ItemOperationsFetchProperties.BodyPart Property

Specifies details about the message part of an e-mail in a response.

public BodyPart} BodyPart {get;}

See Also

ItemOperationsFetchProperties Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Data Property

Aspose.Email

ItemOperationsFetchProperties.Data Property

Contains the item content for inline content responses. The content of the Data element is a base64 encoding of the binary document, attachment, or body data. The size of the data (in bytes) that is contained within the Data element is indicated by the Range property. The total size of the item (in bytes) is indicated by the Total element.

public string Data {get; set;}

See Also

ItemOperationsFetchProperties Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


DataContainer Property

Aspose.Email

ItemOperationsFetchProperties.DataContainer Property

Contains data elements from the content classes.

public DataContainer DataContainer {get;}

See Also

ItemOperationsFetchProperties Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Part Property

Aspose.Email

ItemOperationsFetchProperties.Part Property

Specifies an integer index into the metadata of the multipart response. The Part element is present only in a multipart ItemOperations response. It presents in Properties if the item being fetched is located in a document library.

public Int32} Part {get; set;}

See Also

ItemOperationsFetchProperties Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Range Property

Aspose.Email

ItemOperationsFetchProperties.Range Property

Specifies the range of bytes that the client can receive in response to the Fetch operation for a document library item. The Range element contains a string value in the format m-n, where m less than n, and m is the minimum value and n is the maximum value. The byte range is zero-indexed; the first byte is indicated by a 0 (zero). If the Range element is omitted in the Fetch request, the whole item is fetched.

public string Range {get; set;}

See Also

ItemOperationsFetchProperties Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


RightsManagementLicense Property

Aspose.Email

ItemOperationsFetchProperties.RightsManagementLicense Property

Contains the rights policy template settings for the template applied to the e-mail message being synchronized.

public RightsManagementLicense RightsManagementLicense {get; set;}

See Also

ItemOperationsFetchProperties Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Total Property

Aspose.Email

ItemOperationsFetchProperties.Total Property

Specifies the total size of an item on the server, in bytes.

public Int32} Total {get; set;}

See Also

ItemOperationsFetchProperties Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Version Property

Aspose.Email

ItemOperationsFetchProperties.Version Property

Specifies the time at which a document item was last modified. The Version element is present only when the ItemOperations command is used to access a Windows SharePoint Services or UNC resource.

public DateTime} Version {get; set;}

See Also

ItemOperationsFetchProperties Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItemOperationsFetchRequest Class

Contains request about retrieving an item from the server.

For a list of all members of this type, see ItemOperationsFetchRequest Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.ItemOperationsFetchRequest

public class ItemOperationsFetchRequest

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ItemOperationsFetchRequest Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItemOperationsFetchRequest Members

ItemOperationsFetchRequest overview

Public Instance Constructors

ItemOperationsFetchRequest Constructor Initializes a new instance of the ItemOperationsFetchRequest class.

Public Instance Properties

CollectionId | Identifies the folder that was fetched.
FileReference | Specifies a unique identifier that is assigned by the server to each attachment. In an ItemOperations request, only one FileReference identifier can exist per Fetch. Violation of this constraint results in a Status element value of 2 being returned from the server. The client can, however, retrieve multiple attachments by using one Fetch node per attachment.
LinkId | Specifies a Uniform Resource Identifier (URI) that is assigned by the server to certain resources, such as Windows SharePoint Services or UNC documents. LinkId can be used to refer to the location of an item.
LongId | Specifies a unique identifier that was assigned by the server to each result returned by a previous Search response. The LongId value can be up to 256 characters in length.
Options | Contains the options for the ItemOperations.Fetch operation.
RemoveRightsManagementProtection | If present or true, it indicates that the client is removing the IRM protection from the e-mail. IRM protection can only be removed from e-mail messages when the ExportAllowed element is set to TRUE.
ServerId | Specifies a unique identifier that is assigned by the server to each object that have an item operation applied to it.
Store | Specifies the name of the store to which the parent operation applies. The following values are valid for the Store element: - Document Library (Microsoft SharePoint Server and UNC links) - Mailbox (items and attachments)

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ItemOperationsFetchRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItemOperationsFetchRequest Constructor

Initializes a new instance of the ItemOperationsFetchRequest class.

public ItemOperationsFetchRequest();

See Also

ItemOperationsFetchRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItemOperationsFetchRequest Properties

The properties of the ItemOperationsFetchRequest class are listed below. For a complete list of ItemOperationsFetchRequest class members, see the ItemOperationsFetchRequest Members topic.

Public Instance Properties

CollectionId | Identifies the folder that was fetched.
FileReference | Specifies a unique identifier that is assigned by the server to each attachment. In an ItemOperations request, only one FileReference identifier can exist per Fetch. Violation of this constraint results in a Status element value of 2 being returned from the server. The client can, however, retrieve multiple attachments by using one Fetch node per attachment.
LinkId | Specifies a Uniform Resource Identifier (URI) that is assigned by the server to certain resources, such as Windows SharePoint Services or UNC documents. LinkId can be used to refer to the location of an item.
LongId | Specifies a unique identifier that was assigned by the server to each result returned by a previous Search response. The LongId value can be up to 256 characters in length.
Options | Contains the options for the ItemOperations.Fetch operation.
RemoveRightsManagementProtection | If present or true, it indicates that the client is removing the IRM protection from the e-mail. IRM protection can only be removed from e-mail messages when the ExportAllowed element is set to TRUE.
ServerId | Specifies a unique identifier that is assigned by the server to each object that have an item operation applied to it.
Store | Specifies the name of the store to which the parent operation applies. The following values are valid for the Store element: - Document Library (Microsoft SharePoint Server and UNC links) - Mailbox (items and attachments)

See Also

ItemOperationsFetchRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


CollectionId Property

Aspose.Email

ItemOperationsFetchRequest.CollectionId Property

Identifies the folder that was fetched.

public string CollectionId {get; set;}

See Also

ItemOperationsFetchRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


FileReference Property

Aspose.Email

ItemOperationsFetchRequest.FileReference Property

Specifies a unique identifier that is assigned by the server to each attachment. In an ItemOperations request, only one FileReference identifier can exist per Fetch. Violation of this constraint results in a Status element value of 2 being returned from the server. The client can, however, retrieve multiple attachments by using one Fetch node per attachment.

public string FileReference {get; set;}

See Also

ItemOperationsFetchRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


LinkId Property

Aspose.Email

ItemOperationsFetchRequest.LinkId Property

Specifies a Uniform Resource Identifier (URI) that is assigned by the server to certain resources, such as Windows SharePoint Services or UNC documents. LinkId can be used to refer to the location of an item.

public string LinkId {get; set;}

See Also

ItemOperationsFetchRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


LongId Property

Aspose.Email

ItemOperationsFetchRequest.LongId Property

Specifies a unique identifier that was assigned by the server to each result returned by a previous Search response. The LongId value can be up to 256 characters in length.

public string LongId {get; set;}

See Also

ItemOperationsFetchRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Options Property

Aspose.Email

ItemOperationsFetchRequest.Options Property

Contains the options for the ItemOperations.Fetch operation.

public ItOpFetchOptions Options {get; set;}

See Also

ItemOperationsFetchRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


RemoveRightsManagementProtection Property

Aspose.Email

ItemOperationsFetchRequest.RemoveRightsManagementProtection Property

If present or true, it indicates that the client is removing the IRM protection from the e-mail. IRM protection can only be removed from e-mail messages when the ExportAllowed element is set to TRUE.

public Boolean} RemoveRightsManagementProtection {get; set;}

See Also

ItemOperationsFetchRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ServerId Property

Aspose.Email

ItemOperationsFetchRequest.ServerId Property

Specifies a unique identifier that is assigned by the server to each object that have an item operation applied to it.

public string ServerId {get; set;}

See Also

ItemOperationsFetchRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Store Property

Aspose.Email

ItemOperationsFetchRequest.Store Property

Specifies the name of the store to which the parent operation applies. The following values are valid for the Store element: - Document Library (Microsoft SharePoint Server and UNC links) - Mailbox (items and attachments)

public StoreType Store {get; set;}

See Also

ItemOperationsFetchRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItemOperationsFetchResponce Class

Contains responce about retrieving an items from the server.

For a list of all members of this type, see ItemOperationsFetchResponce Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.ItemOperationsFetchResponce

public class ItemOperationsFetchResponce

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ItemOperationsFetchResponce Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItemOperationsFetchResponce Members

ItemOperationsFetchResponce overview

Public Instance Constructors

ItemOperationsFetchResponce Constructor Initializes a new instance of the ItemOperationsFetchResponce class.

Public Instance Properties

Class | Identifies the class of the item. The valid Class element values are: - Email - Contacts - Calendar - Tasks
CollectionId | Specifies the folder that has to be fetched. Contains ServerId of a folder.
LinkId | Specifies a Uniform Resource Identifier (URI) that is assigned by the server to certain resources, such as Windows SharePoint Services or UNC documents. Can be used by the Fetch element to refer to the location of an item.
LongId | Specifies a unique identifier that was assigned by the server to each result returned by a previous Search response. The LongId element value can be up to 256 characters in length.
Properties | Contains the properties that are returned for item(s) in the response.
ServerId | Specifies a unique identifier that is assigned by the server to each object that can be synchronized or have an item operation applied to it.
Status | Contains a code and description that indicates the success or failure of the ItemOperations operation

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ItemOperationsFetchResponce Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItemOperationsFetchResponce Constructor

Initializes a new instance of the ItemOperationsFetchResponce class.

public ItemOperationsFetchResponce();

See Also

ItemOperationsFetchResponce Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItemOperationsFetchResponce Properties

The properties of the ItemOperationsFetchResponce class are listed below. For a complete list of ItemOperationsFetchResponce class members, see the ItemOperationsFetchResponce Members topic.

Public Instance Properties

Class | Identifies the class of the item. The valid Class element values are: - Email - Contacts - Calendar - Tasks
CollectionId | Specifies the folder that has to be fetched. Contains ServerId of a folder.
LinkId | Specifies a Uniform Resource Identifier (URI) that is assigned by the server to certain resources, such as Windows SharePoint Services or UNC documents. Can be used by the Fetch element to refer to the location of an item.
LongId | Specifies a unique identifier that was assigned by the server to each result returned by a previous Search response. The LongId element value can be up to 256 characters in length.
Properties | Contains the properties that are returned for item(s) in the response.
ServerId | Specifies a unique identifier that is assigned by the server to each object that can be synchronized or have an item operation applied to it.
Status | Contains a code and description that indicates the success or failure of the ItemOperations operation

See Also

ItemOperationsFetchResponce Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Class Property

Aspose.Email

ItemOperationsFetchResponce.Class Property

Identifies the class of the item. The valid Class element values are: - Email - Contacts - Calendar - Tasks

public AirsyncClass} Class {get; set;}

See Also

ItemOperationsFetchResponce Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


CollectionId Property

Aspose.Email

ItemOperationsFetchResponce.CollectionId Property

Specifies the folder that has to be fetched. Contains ServerId of a folder.

public string CollectionId {get; set;}

See Also

ItemOperationsFetchResponce Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


LinkId Property

Aspose.Email

ItemOperationsFetchResponce.LinkId Property

Specifies a Uniform Resource Identifier (URI) that is assigned by the server to certain resources, such as Windows SharePoint Services or UNC documents. Can be used by the Fetch element to refer to the location of an item.

public string LinkId {get; set;}

See Also

ItemOperationsFetchResponce Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


LongId Property

Aspose.Email

ItemOperationsFetchResponce.LongId Property

Specifies a unique identifier that was assigned by the server to each result returned by a previous Search response. The LongId element value can be up to 256 characters in length.

public string LongId {get; set;}

See Also

ItemOperationsFetchResponce Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Properties Property

Aspose.Email

ItemOperationsFetchResponce.Properties Property

Contains the properties that are returned for item(s) in the response.

public ItemOperationsFetchProperties Properties {get; set;}

See Also

ItemOperationsFetchResponce Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ServerId Property

Aspose.Email

ItemOperationsFetchResponce.ServerId Property

Specifies a unique identifier that is assigned by the server to each object that can be synchronized or have an item operation applied to it.

public string ServerId {get; set;}

See Also

ItemOperationsFetchResponce Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Status Property

Aspose.Email

ItemOperationsFetchResponce.Status Property

Contains a code and description that indicates the success or failure of the ItemOperations operation

public Status Status {get; set;}

See Also

ItemOperationsFetchResponce Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItemOperationsMoveRequest Class

Contains request about moving a conversation to specific folder.

For a list of all members of this type, see ItemOperationsMoveRequest Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.ItemOperationsMoveRequest

public class ItemOperationsMoveRequest

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ItemOperationsMoveRequest Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItemOperationsMoveRequest Members

ItemOperationsMoveRequest overview

Public Instance Constructors

ItemOperationsMoveRequest Constructor Initializes a new instance of the ItemOperationsMoveRequest class.

Public Instance Properties

ConversationId | Specifies the conversation to be moved.
DstFldId | Specifies the server ID of the destination folder.
Options | Contains the options for the ItemOperations.Move operation.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ItemOperationsMoveRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItemOperationsMoveRequest Constructor

Initializes a new instance of the ItemOperationsMoveRequest class.

public ItemOperationsMoveRequest();

See Also

ItemOperationsMoveRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItemOperationsMoveRequest Properties

The properties of the ItemOperationsMoveRequest class are listed below. For a complete list of ItemOperationsMoveRequest class members, see the ItemOperationsMoveRequest Members topic.

Public Instance Properties

ConversationId | Specifies the conversation to be moved.
DstFldId | Specifies the server ID of the destination folder.
Options | Contains the options for the ItemOperations.Move operation.

See Also

ItemOperationsMoveRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ConversationId Property

Aspose.Email

ItemOperationsMoveRequest.ConversationId Property

Specifies the conversation to be moved.

public string ConversationId {get; set;}

See Also

ItemOperationsMoveRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


DstFldId Property

Aspose.Email

ItemOperationsMoveRequest.DstFldId Property

Specifies the server ID of the destination folder.

public string DstFldId {get; set;}

See Also

ItemOperationsMoveRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Options Property

Aspose.Email

ItemOperationsMoveRequest.Options Property

Contains the options for the ItemOperations.Move operation.

public ItOpMoveOptions Options {get; set;}

See Also

ItemOperationsMoveRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItemOperationsMoveResponce Class

Identifies the body of the response as containing the operation that moves a given conversation.

For a list of all members of this type, see ItemOperationsMoveResponce Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.ItemOperationsMoveResponce

public class ItemOperationsMoveResponce

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ItemOperationsMoveResponce Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItemOperationsMoveResponce Members

ItemOperationsMoveResponce overview

Public Instance Constructors

ItemOperationsMoveResponce Constructor Initializes a new instance of the ItemOperationsMoveResponce class.

Public Instance Properties

ConversationId | Specifies the conversation that has to be moved.
Status | Contains a code and description that indicates the success or failure of the ItemOperations operation

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ItemOperationsMoveResponce Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItemOperationsMoveResponce Constructor

Initializes a new instance of the ItemOperationsMoveResponce class.

public ItemOperationsMoveResponce();

See Also

ItemOperationsMoveResponce Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItemOperationsMoveResponce Properties

The properties of the ItemOperationsMoveResponce class are listed below. For a complete list of ItemOperationsMoveResponce class members, see the ItemOperationsMoveResponce Members topic.

Public Instance Properties

ConversationId | Specifies the conversation that has to be moved.
Status | Contains a code and description that indicates the success or failure of the ItemOperations operation

See Also

ItemOperationsMoveResponce Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ConversationId Property

Aspose.Email

ItemOperationsMoveResponce.ConversationId Property

Specifies the conversation that has to be moved.

public string ConversationId {get; set;}

See Also

ItemOperationsMoveResponce Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Status Property

Aspose.Email

ItemOperationsMoveResponce.Status Property

Contains a code and description that indicates the success or failure of the ItemOperations operation

public Status Status {get; set;}

See Also

ItemOperationsMoveResponce Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItemOperationsRequest Class

Contains ItemOperations request.

For a list of all members of this type, see ItemOperationsRequest Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.ItemOperationsRequest

public class ItemOperationsRequest

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ItemOperationsRequest Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItemOperationsRequest Members

ItemOperationsRequest overview

Public Instance Constructors

ItemOperationsRequest Constructor Initializes a new instance of the ItemOperationsRequest class.

Public Instance Properties

EmptyFolderContents | Contains requests about deleting the contents of a folder. EmptyFolderContents supports a single child element of the Options element, the DeleteSubFolders, which determines whether subfolders contained in the folder are deleted. If the DeleteSubFolders option is not included in the request, the subfolders of the specified CollectionId are not deleted.
Fetch | Contains requests about retrieving an items from the server.
Move | Contains requests about moving a conversations to specific folders.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ItemOperationsRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItemOperationsRequest Constructor

Initializes a new instance of the ItemOperationsRequest class.

public ItemOperationsRequest();

See Also

ItemOperationsRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItemOperationsRequest Properties

The properties of the ItemOperationsRequest class are listed below. For a complete list of ItemOperationsRequest class members, see the ItemOperationsRequest Members topic.

Public Instance Properties

EmptyFolderContents | Contains requests about deleting the contents of a folder. EmptyFolderContents supports a single child element of the Options element, the DeleteSubFolders, which determines whether subfolders contained in the folder are deleted. If the DeleteSubFolders option is not included in the request, the subfolders of the specified CollectionId are not deleted.
Fetch | Contains requests about retrieving an items from the server.
Move | Contains requests about moving a conversations to specific folders.

See Also

ItemOperationsRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


EmptyFolderContents Property

Aspose.Email

ItemOperationsRequest.EmptyFolderContents Property

Contains requests about deleting the contents of a folder. EmptyFolderContents supports a single child element of the Options element, the DeleteSubFolders, which determines whether subfolders contained in the folder are deleted. If the DeleteSubFolders option is not included in the request, the subfolders of the specified CollectionId are not deleted.

public EmptyFolderContentsRequest} EmptyFolderContents {get;}

See Also

ItemOperationsRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Fetch Property

Aspose.Email

ItemOperationsRequest.Fetch Property

Contains requests about retrieving an items from the server.

public ItemOperationsFetchRequest} Fetch {get;}

See Also

ItemOperationsRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Move Property

Aspose.Email

ItemOperationsRequest.Move Property

Contains requests about moving a conversations to specific folders.

public ItemOperationsMoveRequest} Move {get;}

See Also

ItemOperationsRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItemOperationsResponse Class

Contains ItemOperations response.

For a list of all members of this type, see ItemOperationsResponse Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.ItemOperationsResponse

public class ItemOperationsResponse

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ItemOperationsResponse Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItemOperationsResponse Members

ItemOperationsResponse overview

Public Instance Constructors

ItemOperationsResponse Constructor Initializes a new instance of the ItemOperationsResponse class.

Public Instance Properties

EmptyFolderContents | Identifies the body of the response as containing the operation that deletes the contents of a folder.
Fetch | Contains responce about retrieving an items from the server.
Move | Identifies the body of the response as containing the operation that moves a given conversation. The Move element is not supported when the protocol version is 12.1.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ItemOperationsResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItemOperationsResponse Constructor

Initializes a new instance of the ItemOperationsResponse class.

public ItemOperationsResponse();

See Also

ItemOperationsResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItemOperationsResponse Properties

The properties of the ItemOperationsResponse class are listed below. For a complete list of ItemOperationsResponse class members, see the ItemOperationsResponse Members topic.

Public Instance Properties

EmptyFolderContents | Identifies the body of the response as containing the operation that deletes the contents of a folder.
Fetch | Contains responce about retrieving an items from the server.
Move | Identifies the body of the response as containing the operation that moves a given conversation. The Move element is not supported when the protocol version is 12.1.

See Also

ItemOperationsResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


EmptyFolderContents Property

Aspose.Email

ItemOperationsResponse.EmptyFolderContents Property

Identifies the body of the response as containing the operation that deletes the contents of a folder.

public ItemOperationsEmptFldrCntntsResponce} EmptyFolderContents {get;}

See Also

ItemOperationsResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Fetch Property

Aspose.Email

ItemOperationsResponse.Fetch Property

Contains responce about retrieving an items from the server.

public ItemOperationsFetchResponce} Fetch {get;}

See Also

ItemOperationsResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Move Property

Aspose.Email

ItemOperationsResponse.Move Property

Identifies the body of the response as containing the operation that moves a given conversation. The Move element is not supported when the protocol version is 12.1.

public ItemOperationsMoveResponce} Move {get;}

See Also

ItemOperationsResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItOpEmpFldCntOptions Class

Contains the options for the ItemOperations.EmptyFolderContents operation

For a list of all members of this type, see ItOpEmpFldCntOptions Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.ItOpEmpFldCntOptions

public class ItOpEmpFldCntOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ItOpEmpFldCntOptions Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItOpEmpFldCntOptions Members

ItOpEmpFldCntOptions overview

Public Instance Constructors

ItOpEmpFldCntOptions Constructor Initializes a new instance of the ItOpEmpFldCntOptions class.

Public Instance Properties

DeleteSubFolders Indicates whether to delete the subfolders of the specified folder. If the DeleteSubFolders option is not included in the request, the subfolders of the specified CollectionId are not deleted.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ItOpEmpFldCntOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItOpEmpFldCntOptions Constructor

Initializes a new instance of the ItOpEmpFldCntOptions class.

public ItOpEmpFldCntOptions();

See Also

ItOpEmpFldCntOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItOpEmpFldCntOptions Properties

The properties of the ItOpEmpFldCntOptions class are listed below. For a complete list of ItOpEmpFldCntOptions class members, see the ItOpEmpFldCntOptions Members topic.

Public Instance Properties

DeleteSubFolders Indicates whether to delete the subfolders of the specified folder. If the DeleteSubFolders option is not included in the request, the subfolders of the specified CollectionId are not deleted.

See Also

ItOpEmpFldCntOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


DeleteSubFolders Property

Aspose.Email

ItOpEmpFldCntOptions.DeleteSubFolders Property

Indicates whether to delete the subfolders of the specified folder. If the DeleteSubFolders option is not included in the request, the subfolders of the specified CollectionId are not deleted.

public Boolean} DeleteSubFolders {get; set;}

See Also

ItOpEmpFldCntOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItOpFetchOptions Class

Contains the options for the ItemOperations.Fetch operation.

For a list of all members of this type, see ItOpFetchOptions Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.ItOpFetchOptions

public class ItOpFetchOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ItOpFetchOptions Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItOpFetchOptions Members

ItOpFetchOptions overview

Public Instance Constructors

ItOpFetchOptions Constructor Initializes a new instance of the ItOpFetchOptions class.

Public Instance Properties

BodyPartPreference | Contains preference information related to the type and size of information that is returned from searching, synchronizing, or fetching a message part.
BodyPreference | Contains preference information related to the type and size of information that is returned from searching, synchronizing, or fetching.
MIMESupport | Enables MIME support for email items that are sent from the server to the client.
Password | Specifies the password for the given UserName. The server accepts password values up to 256 characters in length.
Range | Specifies the range of bytes that the client can receive in response to the Fetch operation for a document library item. The Range element is an optional field. The Range element contains a string value in the format M-N, where M is less than N, and M is the minimum value and N is the maximum value. The byte range is zero-indexed; the first byte is indicated by a 0 (zero). If the Range is omitted in the Fetch request, the whole item is fetched. If the FileReference is present in the request, then the Range element is the only valid child element of the Options element.
RightsManagementSupport | Specifies how the server returns rights-managed email messages to the client. If the value of this element is TRUE, the server will decompress and decrypt rights-managed email messages before sending them to the client, as specified in section 3.2.4.3. If the value is FALSE (0), the server will not decompress or decrypt rights-managed email messages before sending them to the client. If the RightsManagementSupport element is not defined, a default value of FALSE is assumed.
Schema | Specifies the schema of the item to be fetched. The Schema is supported within options for PIM Fetch (section 2.2.3.63.1) requests. It is not supported when the client is retrieving items from a document library or retrieving an attachment. If the Schema element is not specified, the server allows all properties to be retrieved.
UserName | Specifies the username of the account leveraged to fetch the desired item. The UserName value can be up to 100 characters in length.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ItOpFetchOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItOpFetchOptions Constructor

Initializes a new instance of the ItOpFetchOptions class.

public ItOpFetchOptions();

See Also

ItOpFetchOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItOpFetchOptions Properties

The properties of the ItOpFetchOptions class are listed below. For a complete list of ItOpFetchOptions class members, see the ItOpFetchOptions Members topic.

Public Instance Properties

BodyPartPreference | Contains preference information related to the type and size of information that is returned from searching, synchronizing, or fetching a message part.
BodyPreference | Contains preference information related to the type and size of information that is returned from searching, synchronizing, or fetching.
MIMESupport | Enables MIME support for email items that are sent from the server to the client.
Password | Specifies the password for the given UserName. The server accepts password values up to 256 characters in length.
Range | Specifies the range of bytes that the client can receive in response to the Fetch operation for a document library item. The Range element is an optional field. The Range element contains a string value in the format M-N, where M is less than N, and M is the minimum value and N is the maximum value. The byte range is zero-indexed; the first byte is indicated by a 0 (zero). If the Range is omitted in the Fetch request, the whole item is fetched. If the FileReference is present in the request, then the Range element is the only valid child element of the Options element.
RightsManagementSupport | Specifies how the server returns rights-managed email messages to the client. If the value of this element is TRUE, the server will decompress and decrypt rights-managed email messages before sending them to the client, as specified in section 3.2.4.3. If the value is FALSE (0), the server will not decompress or decrypt rights-managed email messages before sending them to the client. If the RightsManagementSupport element is not defined, a default value of FALSE is assumed.
Schema | Specifies the schema of the item to be fetched. The Schema is supported within options for PIM Fetch (section 2.2.3.63.1) requests. It is not supported when the client is retrieving items from a document library or retrieving an attachment. If the Schema element is not specified, the server allows all properties to be retrieved.
UserName | Specifies the username of the account leveraged to fetch the desired item. The UserName value can be up to 100 characters in length.

See Also

ItOpFetchOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


BodyPartPreference Property

Aspose.Email

ItOpFetchOptions.BodyPartPreference Property

Contains preference information related to the type and size of information that is returned from searching, synchronizing, or fetching a message part.

public BodyPreference} BodyPartPreference {get; set;}

See Also

ItOpFetchOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


BodyPreference Property

Aspose.Email

ItOpFetchOptions.BodyPreference Property

Contains preference information related to the type and size of information that is returned from searching, synchronizing, or fetching.

public BodyPreference} BodyPreference {get; set;}

See Also

ItOpFetchOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


MIMESupport Property

Aspose.Email

ItOpFetchOptions.MIMESupport Property

Enables MIME support for email items that are sent from the server to the client.

public MIMESupport} MIMESupport {get; set;}

See Also

ItOpFetchOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Password Property

Aspose.Email

ItOpFetchOptions.Password Property

Specifies the password for the given UserName. The server accepts password values up to 256 characters in length.

public string Password {get; set;}

See Also

ItOpFetchOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Range Property

Aspose.Email

ItOpFetchOptions.Range Property

Specifies the range of bytes that the client can receive in response to the Fetch operation for a document library item. The Range element is an optional field. The Range element contains a string value in the format M-N, where M is less than N, and M is the minimum value and N is the maximum value. The byte range is zero-indexed; the first byte is indicated by a 0 (zero). If the Range is omitted in the Fetch request, the whole item is fetched. If the FileReference is present in the request, then the Range element is the only valid child element of the Options element.

public string Range {get; set;}

See Also

ItOpFetchOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


RightsManagementSupport Property

Aspose.Email

ItOpFetchOptions.RightsManagementSupport Property

Specifies how the server returns rights-managed email messages to the client. If the value of this element is TRUE, the server will decompress and decrypt rights-managed email messages before sending them to the client, as specified in section 3.2.4.3. If the value is FALSE (0), the server will not decompress or decrypt rights-managed email messages before sending them to the client. If the RightsManagementSupport element is not defined, a default value of FALSE is assumed.

public Boolean} RightsManagementSupport {get; set;}

See Also

ItOpFetchOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Schema Property

Aspose.Email

ItOpFetchOptions.Schema Property

Specifies the schema of the item to be fetched. The Schema is supported within options for PIM Fetch (section 2.2.3.63.1) requests. It is not supported when the client is retrieving items from a document library or retrieving an attachment. If the Schema element is not specified, the server allows all properties to be retrieved.

public String} Schema {get;}

See Also

ItOpFetchOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


UserName Property

Aspose.Email

ItOpFetchOptions.UserName Property

Specifies the username of the account leveraged to fetch the desired item. The UserName value can be up to 100 characters in length.

public string UserName {get; set;}

See Also

ItOpFetchOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItOpMoveOptions Class

Contains the options for the ItemOperations.Move operation.

For a list of all members of this type, see ItOpMoveOptions Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.ItOpMoveOptions

public class ItOpMoveOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ItOpMoveOptions Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItOpMoveOptions Members

ItOpMoveOptions overview

Public Instance Constructors

ItOpMoveOptions Constructor Initializes a new instance of the ItOpMoveOptions class.

Public Instance Properties

MoveAlways Indicates whether to always move the specified conversation, including all future emails in the conversation, to the folder specified by the DstFldId. The MoveAlways MUST be set in an ItemOperations request when performing a move operation on a conversation. A Status element value of 155 is returned if the MoveAlways element is not set in the ItemOperations request for a move operation.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ItOpMoveOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItOpMoveOptions Constructor

Initializes a new instance of the ItOpMoveOptions class.

public ItOpMoveOptions();

See Also

ItOpMoveOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItOpMoveOptions Properties

The properties of the ItOpMoveOptions class are listed below. For a complete list of ItOpMoveOptions class members, see the ItOpMoveOptions Members topic.

Public Instance Properties

MoveAlways Indicates whether to always move the specified conversation, including all future emails in the conversation, to the folder specified by the DstFldId. The MoveAlways MUST be set in an ItemOperations request when performing a move operation on a conversation. A Status element value of 155 is returned if the MoveAlways element is not set in the ItemOperations request for a move operation.

See Also

ItOpMoveOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


MoveAlways Property

Aspose.Email

ItOpMoveOptions.MoveAlways Property

Indicates whether to always move the specified conversation, including all future emails in the conversation, to the folder specified by the DstFldId. The MoveAlways MUST be set in an ItemOperations request when performing a move operation on a conversation. A Status element value of 155 is returned if the MoveAlways element is not set in the ItemOperations request for a move operation.

public Boolean} MoveAlways {get; set;}

See Also

ItOpMoveOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


MaxAgeFilter Enumeration

Specifies the maximum number of calendar days that can be synchronized.

public enum MaxAgeFilter

Members

Member Name | Description | Value
All | Defines all days for synchronization. Filter is disabled. | 0
OneDay | Defines 1 day for synchronization. | 1
ThreeDays | Defines 3 days for synchronization. | 2
OneWeek | Defines 1 week for synchronization. | 3
TwoWeeks | Defines 2 weeks for synchronization. | 4
OneMonth | Defines 1 month for synchronization. | 5
ThreeMonths | Defines 3 months for synchronization. | 6
SixMonths | Defines 6 months for synchronization. | 7

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


MeetingResponseRequest Class

Specifies the meeting request that is being responded to, the response to that meeting request, and the folder on the server that the meeting request is located in.

For a list of all members of this type, see MeetingResponseRequest Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.MeetingResponseRequest

public class MeetingResponseRequest

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MeetingResponseRequest Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


MeetingResponseRequest Members

MeetingResponseRequest overview

Public Instance Constructors

MeetingResponseRequest Overloaded. Initializes a new instance of the MeetingResponseRequest class.

Public Instance Properties

CollectionId | Specifies the folder that contains the meeting request. Optional if LongId is included. The CollectionId value can be up to 64 characters in length.
InstanceId | Specifies the instance of the recurring meeting to be modified. The InstanceId is not supported when the protocol version is 12.1 or 14.0. A Status value of 2 is returned if the InstanceId element is included in requests in which the protocol version is 12.1 or 14.0. The InstanceId contains the start time of the appointment or meeting instance to be modified. If the InstanceId is not included in the MeetingResponse request, then the action is to be taken on every instance of the recurring item. The InstanceId can specify the start time of an exception to a recurring appointment or meeting. The InstanceId can be used with the LongId to identify a calendar item, or it can be used with the CollectionId and RequestId to identify a calendar item. The format of the InstanceId value is a string in dateTime format with the punctuation separators, for example, 2010-04-08T18:16:00.000Z. If the InstanceId value specified is not in the proper format, the server responds with a Status element value of 104. If the InstanceId value specifies a non-recurring meeting, the server responds with a Status element value of 146.
LongId | Specifies the long ID for the source meeting request, which is returned in the Search command response message. If the LongId is present, the CollectionId, InstanceId, and RequestId are not present. The LongId value can be up to 256 characters in length.
RequestId | Specifies the server ID of the meeting request message item. Optional if LongId is included. The RequestId value can be up to 64 characters in length.
UserResponse | Indicates whether the meeting is being accepted, tentatively accepted, or declined.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MeetingResponseRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


MeetingResponseRequest Constructor

Initializes a new instance of the MeetingResponseRequest class.

Overload List

Initializes a new instance of the MeetingResponseRequest class.

public MeetingResponseRequest();

Initializes a new instance of the MeetingResponseRequest class.

public MeetingResponseRequest(UserResponse,string,string,string,string);

See Also

MeetingResponseRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


MeetingResponseRequest Constructor ()

Initializes a new instance of the MeetingResponseRequest class.

public MeetingResponseRequest();

See Also

MeetingResponseRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | MeetingResponseRequest Constructor Overload List


MeetingResponseRequest Constructor (UserResponse, String, String, String, String)

Initializes a new instance of the MeetingResponseRequest class.

public MeetingResponseRequest(
UserResponse userResponse,
string collectionId,
string requestId,
string longId,
string instanceId
);

Parameters

userResponse
Indicates whether the meeting is being accepted, tentatively accepted, or declined.
collectionId
Specifies the folder that contains the meeting request.
requestId
Specifies the server ID of the meeting request message item.
longId
Specifies the long ID for the source meeting request, which is returned in the Search command response message.
instanceId
Specifies the instance of the recurring meeting to be modified.

See Also

MeetingResponseRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | MeetingResponseRequest Constructor Overload List


MeetingResponseRequest Properties

The properties of the MeetingResponseRequest class are listed below. For a complete list of MeetingResponseRequest class members, see the MeetingResponseRequest Members topic.

Public Instance Properties

CollectionId | Specifies the folder that contains the meeting request. Optional if LongId is included. The CollectionId value can be up to 64 characters in length.
InstanceId | Specifies the instance of the recurring meeting to be modified. The InstanceId is not supported when the protocol version is 12.1 or 14.0. A Status value of 2 is returned if the InstanceId element is included in requests in which the protocol version is 12.1 or 14.0. The InstanceId contains the start time of the appointment or meeting instance to be modified. If the InstanceId is not included in the MeetingResponse request, then the action is to be taken on every instance of the recurring item. The InstanceId can specify the start time of an exception to a recurring appointment or meeting. The InstanceId can be used with the LongId to identify a calendar item, or it can be used with the CollectionId and RequestId to identify a calendar item. The format of the InstanceId value is a string in dateTime format with the punctuation separators, for example, 2010-04-08T18:16:00.000Z. If the InstanceId value specified is not in the proper format, the server responds with a Status element value of 104. If the InstanceId value specifies a non-recurring meeting, the server responds with a Status element value of 146.
LongId | Specifies the long ID for the source meeting request, which is returned in the Search command response message. If the LongId is present, the CollectionId, InstanceId, and RequestId are not present. The LongId value can be up to 256 characters in length.
RequestId | Specifies the server ID of the meeting request message item. Optional if LongId is included. The RequestId value can be up to 64 characters in length.
UserResponse | Indicates whether the meeting is being accepted, tentatively accepted, or declined.

See Also

MeetingResponseRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


CollectionId Property

Aspose.Email

MeetingResponseRequest.CollectionId Property

Specifies the folder that contains the meeting request. Optional if LongId is included. The CollectionId value can be up to 64 characters in length.

public string CollectionId {get; set;}

See Also

MeetingResponseRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


InstanceId Property

Aspose.Email

MeetingResponseRequest.InstanceId Property

Specifies the instance of the recurring meeting to be modified. The InstanceId is not supported when the protocol version is 12.1 or 14.0. A Status value of 2 is returned if the InstanceId element is included in requests in which the protocol version is 12.1 or 14.0. The InstanceId contains the start time of the appointment or meeting instance to be modified. If the InstanceId is not included in the MeetingResponse request, then the action is to be taken on every instance of the recurring item. The InstanceId can specify the start time of an exception to a recurring appointment or meeting. The InstanceId can be used with the LongId to identify a calendar item, or it can be used with the CollectionId and RequestId to identify a calendar item. The format of the InstanceId value is a string in dateTime format with the punctuation separators, for example, 2010-04-08T18:16:00.000Z. If the InstanceId value specified is not in the proper format, the server responds with a Status element value of 104. If the InstanceId value specifies a non-recurring meeting, the server responds with a Status element value of 146.

public string InstanceId {get; set;}

See Also

MeetingResponseRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


LongId Property

Aspose.Email

MeetingResponseRequest.LongId Property

Specifies the long ID for the source meeting request, which is returned in the Search command response message. If the LongId is present, the CollectionId, InstanceId, and RequestId are not present. The LongId value can be up to 256 characters in length.

public string LongId {get; set;}

See Also

MeetingResponseRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


RequestId Property

Aspose.Email

MeetingResponseRequest.RequestId Property

Specifies the server ID of the meeting request message item. Optional if LongId is included. The RequestId value can be up to 64 characters in length.

public string RequestId {get; set;}

See Also

MeetingResponseRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


UserResponse Property

Aspose.Email

MeetingResponseRequest.UserResponse Property

Indicates whether the meeting is being accepted, tentatively accepted, or declined.

public UserResponse UserResponse {get; set;}

See Also

MeetingResponseRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


MeetingResponseResult Class

Meeting response result object

For a list of all members of this type, see MeetingResponseResult Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.MeetingResponseResult

public class MeetingResponseResult

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MeetingResponseResult Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


MeetingResponseResult Members

MeetingResponseResult overview

Public Instance Constructors

MeetingResponseResult Constructor Initializes a new instance of the MeetingResponseResult class.

Public Instance Properties

CalendarId | Specifies the server ID of the calendar item. The CalendarId element value can be up to 64 characters in length. The CalendarId element is included in the MeetingResponse command response that is sent to the client if the meeting request was not declined. If the meeting is accepted or tentatively accepted, the server adds a new item to the calendar and returns its server ID in the CalendarId element in the response. If the client created a tentative meeting calendar item, the client updates that item with the new server ID. The client also changes the busy status from tentative to busy. When a meeting is accepted, the server also creates a new calendar item with the same server ID. This means there is a conflict that will be resolved the next time the calendar is synchronized. If the meeting is declined, the response does not contain a CalendarId element.
RequestId | Specifies the server ID of the meeting request message item.
Status | Indicates the success or failure of the operation.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MeetingResponseResult Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


MeetingResponseResult Constructor

Initializes a new instance of the MeetingResponseResult class.

public MeetingResponseResult();

See Also

MeetingResponseResult Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


MeetingResponseResult Properties

The properties of the MeetingResponseResult class are listed below. For a complete list of MeetingResponseResult class members, see the MeetingResponseResult Members topic.

Public Instance Properties

CalendarId | Specifies the server ID of the calendar item. The CalendarId element value can be up to 64 characters in length. The CalendarId element is included in the MeetingResponse command response that is sent to the client if the meeting request was not declined. If the meeting is accepted or tentatively accepted, the server adds a new item to the calendar and returns its server ID in the CalendarId element in the response. If the client created a tentative meeting calendar item, the client updates that item with the new server ID. The client also changes the busy status from tentative to busy. When a meeting is accepted, the server also creates a new calendar item with the same server ID. This means there is a conflict that will be resolved the next time the calendar is synchronized. If the meeting is declined, the response does not contain a CalendarId element.
RequestId | Specifies the server ID of the meeting request message item.
Status | Indicates the success or failure of the operation.

See Also

MeetingResponseResult Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


CalendarId Property

Aspose.Email

MeetingResponseResult.CalendarId Property

Specifies the server ID of the calendar item. The CalendarId element value can be up to 64 characters in length. The CalendarId element is included in the MeetingResponse command response that is sent to the client if the meeting request was not declined. If the meeting is accepted or tentatively accepted, the server adds a new item to the calendar and returns its server ID in the CalendarId element in the response. If the client created a tentative meeting calendar item, the client updates that item with the new server ID. The client also changes the busy status from tentative to busy. When a meeting is accepted, the server also creates a new calendar item with the same server ID. This means there is a conflict that will be resolved the next time the calendar is synchronized. If the meeting is declined, the response does not contain a CalendarId element.

public string CalendarId {get; set;}

See Also

MeetingResponseResult Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


RequestId Property

Aspose.Email

MeetingResponseResult.RequestId Property

Specifies the server ID of the meeting request message item.

public string RequestId {get; set;}

See Also

MeetingResponseResult Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Status Property

Aspose.Email

MeetingResponseResult.Status Property

Indicates the success or failure of the operation.

public Status Status {get; set;}

See Also

MeetingResponseResult Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


MergedFreeBusy Enumeration

Specifies the free/busy information for the users or distribution list.

public enum MergedFreeBusy

Members

Member Name | Description | Value
Free | User is free. | 0
Tentative | Timesheet is indeterminate | 1
Busy | User is busy. | 2
OutOfOffice | User is out of office. | 3
NoData | Information is absent | 4

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


MIMESupport Enumeration

Enables MIME support for email items that are sent from the server to the client.

public enum MIMESupport

Members

Member Name | Description | Value
NeverSend | Never send MIME data. | 0
SendForSecureMIMEonly | Send MIME data for S/MIME messages only. Send regular body for all other messages. | 1
SendForAll | Send MIME data for all messages. This flag could be used by clients to build a more rich and complete Inbox solution. | 2

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


MIMETruncation Enumeration

Specifies whether the MIME data of the email item SHOULD be truncated when it is sent from the server to the client.

public enum MIMETruncation

Members

Member Name | Description | Value
TruncateAllBodyText | Truncate all body text. | 0
TruncateOver4096 | Truncate text over 4,096 characters. | 1
TruncateOver5120 | Truncate text over 5,120 characters. | 2
TruncateOver7168 | Truncate text over 7,168 characters. | 3
TruncateOver10240 | Truncate text over 10,240 characters. | 4
TruncateOver20480 | Truncate text over 20,480 characters. | 5
TruncateOver51200 | Truncate text over 51,200 characters. | 6
TruncateOver102400 | Truncate text over 102,400 characters. | 7
DoNotTruncate | Do not truncate; send complete MIME data. | 8

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


MinDevicePasswordComplexCharacters Enumeration

Specifies the required level of complexity of the client password. For example: If the value of MinDevicePasswordComplexCharacters is 2, a password with both upper case and lower case alphabetical characters would be sufficient, as would a password with lower case alphabetical characters and numbers.

public enum MinDevicePasswordComplexCharacters

Members

Member Name | Description | Value
LowerCase | Lower case alphabetical characters | 1
LowerUpperCase | Lower case and Upper case alphabetical characters | 2
LowerUpperCaseNumbers | Lower case, Upper case alphabetical characters and Numbers | 3
LowerUpperCaseNumbersNonAlphanumeric | Lower case and Upper case alphabetical characters, Numbers and Non-alphanumeric characters | 4

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


MoveItemData Class

Contains information about moving items

For a list of all members of this type, see MoveItemData Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.MoveItemData

public class MoveItemData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MoveItemData Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


MoveItemData Members

MoveItemData overview

Public Instance Constructors

MoveItemData Overloaded. Initializes a new instance of the MoveItemData class.

Public Instance Properties

DstFldId | Specifies the server ID of the destination folder (that is, the folder to which the items are moved). The DstFldId property value can be up to 64 characters in length.
SrcFldId | Specifies the server ID of the source folder (that is, the folder that contains the items to be moved). The SrcFldId element value can be up to 64 characters in length.
SrcMsgId | Specifies the server ID of the item that was moved. The SrcMsgId element value can be up to 64 characters in length.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MoveItemData Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


MoveItemData Constructor

Initializes a new instance of the MoveItemData class.

Overload List

Initializes a new instance of the MoveItemData class.

public MoveItemData();

Initializes a new instance of the MoveItemData class.

public MoveItemData(string,string,string);

See Also

MoveItemData Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


MoveItemData Constructor ()

Initializes a new instance of the MoveItemData class.

public MoveItemData();

See Also

MoveItemData Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | MoveItemData Constructor Overload List


MoveItemData Constructor (String, String, String)

Initializes a new instance of the MoveItemData class.

public MoveItemData(
string srcMsgId,
string srcFldId,
string dstFldId
);

Parameters

srcMsgId
Specifies the server ID of the item that was moved.
srcFldId
Specifies the server ID of the source folder (that is, the folder that contains the items to be moved).
dstFldId
Specifies the server ID of the destination folder (that is, the folder to which the items are moved).

See Also

MoveItemData Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | MoveItemData Constructor Overload List


MoveItemData Properties

The properties of the MoveItemData class are listed below. For a complete list of MoveItemData class members, see the MoveItemData Members topic.

Public Instance Properties

DstFldId | Specifies the server ID of the destination folder (that is, the folder to which the items are moved). The DstFldId property value can be up to 64 characters in length.
SrcFldId | Specifies the server ID of the source folder (that is, the folder that contains the items to be moved). The SrcFldId element value can be up to 64 characters in length.
SrcMsgId | Specifies the server ID of the item that was moved. The SrcMsgId element value can be up to 64 characters in length.

See Also

MoveItemData Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


DstFldId Property

Aspose.Email

MoveItemData.DstFldId Property

Specifies the server ID of the destination folder (that is, the folder to which the items are moved). The DstFldId property value can be up to 64 characters in length.

public string DstFldId {get; set;}

See Also

MoveItemData Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SrcFldId Property

Aspose.Email

MoveItemData.SrcFldId Property

Specifies the server ID of the source folder (that is, the folder that contains the items to be moved). The SrcFldId element value can be up to 64 characters in length.

public string SrcFldId {get; set;}

See Also

MoveItemData Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SrcMsgId Property

Aspose.Email

MoveItemData.SrcMsgId Property

Specifies the server ID of the item that was moved. The SrcMsgId element value can be up to 64 characters in length.

public string SrcMsgId {get; set;}

See Also

MoveItemData Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


MoveItemResponse Class

Contains information that describe the moved items.

For a list of all members of this type, see MoveItemResponse Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.MoveItemResponse

public class MoveItemResponse

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MoveItemResponse Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


MoveItemResponse Members

MoveItemResponse overview

Public Instance Constructors

MoveItemResponse Overloaded. Initializes a new instance of the MoveItemResponse class.

Public Instance Properties

DstMsgId | Specifies the new server ID of the item after the item is moved to the destination folder. The DstMsgId element value can be up to 64 characters in length.
SrcMsgId | Specifies the server ID of the item to be moved. The SrcMsgId element value can be up to 64 characters in length.
Status | Indicates the success or failure the MoveItems command request.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MoveItemResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


MoveItemResponse Constructor

Initializes a new instance of the MoveItemResponse class.

Overload List

Initializes a new instance of the MoveItemResponse class.

public MoveItemResponse();

Initializes a new instance of the MoveItemResponse class.

public MoveItemResponse(Status,string,string);

See Also

MoveItemResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


MoveItemResponse Constructor ()

Initializes a new instance of the MoveItemResponse class.

public MoveItemResponse();

See Also

MoveItemResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | MoveItemResponse Constructor Overload List


MoveItemResponse Constructor (Status, String, String)

Initializes a new instance of the MoveItemResponse class.

public MoveItemResponse(
Status status,
string srcMsgId,
string dstMsgId
);

Parameters

status
Indicates the success or failure the MoveItems command request.
srcMsgId
Specifies the server ID of the item to be moved.
dstMsgId
Specifies the new server ID of the item after the item is moved to the destination folder.

See Also

MoveItemResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | MoveItemResponse Constructor Overload List


MoveItemResponse Properties

The properties of the MoveItemResponse class are listed below. For a complete list of MoveItemResponse class members, see the MoveItemResponse Members topic.

Public Instance Properties

DstMsgId | Specifies the new server ID of the item after the item is moved to the destination folder. The DstMsgId element value can be up to 64 characters in length.
SrcMsgId | Specifies the server ID of the item to be moved. The SrcMsgId element value can be up to 64 characters in length.
Status | Indicates the success or failure the MoveItems command request.

See Also

MoveItemResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


DstMsgId Property

Aspose.Email

MoveItemResponse.DstMsgId Property

Specifies the new server ID of the item after the item is moved to the destination folder. The DstMsgId element value can be up to 64 characters in length.

public string DstMsgId {get; set;}

See Also

MoveItemResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SrcMsgId Property

Aspose.Email

MoveItemResponse.SrcMsgId Property

Specifies the server ID of the item to be moved. The SrcMsgId element value can be up to 64 characters in length.

public string SrcMsgId {get; set;}

See Also

MoveItemResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Status Property

Aspose.Email

MoveItemResponse.Status Property

Indicates the success or failure the MoveItems command request.

public Status Status {get; set;}

See Also

MoveItemResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


OOFMessage Class

Specifies the OOF message for a particular audience. Exchange 2007, Exchange 2010, and Exchange 2013 require that the reply message for unknown external and known external audiences be the same. The property supports the following three audiences for an OOF message: Internal — A user who is in the same organization as the sending user. Known external — A user who is outside the sending user's organization, but is represented in the sending user's contacts. Unknown external — A user who is outside the sending user's organization and is not represented in the sending user's contacts.

For a list of all members of this type, see OOFMessage Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.OOFMessage

public class OOFMessage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

OOFMessage Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


OOFMessage Members

OOFMessage overview

Public Instance Constructors

OOFMessage Constructor Initializes a new instance of the OOFMessage class.

Public Instance Properties

AppliesToExternalKnown | Indicates that the OOF message applies to known external users.
AppliesToExternalUnknown | Indicates that the OOF message applies to unknown external users.
AppliesToInternal | Indicates that the OOF message applies to internal users.
BodyType | Specifies the format of the OOF message. The following are the permitted values for the BodyType element: - Text - HTML
Enabled | Specifies whether an OOF message is sent to this audience while the sending user is OOF.
ReplyMessage | Specifies the message to be shown to a particular audience when the user is OOF.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OOFMessage Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


OOFMessage Constructor

Initializes a new instance of the OOFMessage class.

public OOFMessage();

See Also

OOFMessage Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


OOFMessage Properties

The properties of the OOFMessage class are listed below. For a complete list of OOFMessage class members, see the OOFMessage Members topic.

Public Instance Properties

AppliesToExternalKnown | Indicates that the OOF message applies to known external users.
AppliesToExternalUnknown | Indicates that the OOF message applies to unknown external users.
AppliesToInternal | Indicates that the OOF message applies to internal users.
BodyType | Specifies the format of the OOF message. The following are the permitted values for the BodyType element: - Text - HTML
Enabled | Specifies whether an OOF message is sent to this audience while the sending user is OOF.
ReplyMessage | Specifies the message to be shown to a particular audience when the user is OOF.

See Also

OOFMessage Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


AppliesToExternalKnown Property

Aspose.Email

OOFMessage.AppliesToExternalKnown Property

Indicates that the OOF message applies to known external users.

public Boolean} AppliesToExternalKnown {get; set;}

See Also

OOFMessage Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


AppliesToExternalUnknown Property

Aspose.Email

OOFMessage.AppliesToExternalUnknown Property

Indicates that the OOF message applies to unknown external users.

public Boolean} AppliesToExternalUnknown {get; set;}

See Also

OOFMessage Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


AppliesToInternal Property

Aspose.Email

OOFMessage.AppliesToInternal Property

Indicates that the OOF message applies to internal users.

public Boolean} AppliesToInternal {get; set;}

See Also

OOFMessage Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


BodyType Property

Aspose.Email

OOFMessage.BodyType Property

Specifies the format of the OOF message. The following are the permitted values for the BodyType element: - Text - HTML

public BodyType} BodyType {get; set;}

See Also

OOFMessage Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Enabled Property

Aspose.Email

OOFMessage.Enabled Property

Specifies whether an OOF message is sent to this audience while the sending user is OOF.

public Boolean} Enabled {get; set;}

See Also

OOFMessage Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ReplyMessage Property

Aspose.Email

OOFMessage.ReplyMessage Property

Specifies the message to be shown to a particular audience when the user is OOF.

public string ReplyMessage {get; set;}

See Also

OOFMessage Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


OOFReqParametrs Class

Gets OOF information settings from the server.

For a list of all members of this type, see OOFReqParametrs Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.OOFReqParametrs

public class OOFReqParametrs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

OOFReqParametrs Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


OOFReqParametrs Members

OOFReqParametrs overview

Public Instance Constructors

OOFReqParametrs Constructor Initializes a new instance of the OOFReqParametrs class.

Public Instance Properties

BodyType Specifies the format type of the body content of the item. The following are the permitted values for the BodyType element: - Text - HTML

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OOFReqParametrs Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


OOFReqParametrs Constructor

Initializes a new instance of the OOFReqParametrs class.

public OOFReqParametrs();

See Also

OOFReqParametrs Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


OOFReqParametrs Properties

The properties of the OOFReqParametrs class are listed below. For a complete list of OOFReqParametrs class members, see the OOFReqParametrs Members topic.

Public Instance Properties

BodyType Specifies the format type of the body content of the item. The following are the permitted values for the BodyType element: - Text - HTML

See Also

OOFReqParametrs Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


BodyType Property

Aspose.Email

OOFReqParametrs.BodyType Property

Specifies the format type of the body content of the item. The following are the permitted values for the BodyType element: - Text - HTML

public BodyType BodyType {get; set;}

See Also

OOFReqParametrs Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


OOFRequest Class

Specifies a class for retrieving and setting Out of Office (OOF) information.

For a list of all members of this type, see OOFRequest Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.OOFRequest

public class OOFRequest

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

OOFRequest Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


OOFRequest Members

OOFRequest overview

Public Instance Constructors

OOFRequest Constructor Initializes a new instance of the OOFRequest class.

Public Instance Properties

Get | Gets OOF information settings from the server.
Set | Sets OOF information settings on the server.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OOFRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


OOFRequest Constructor

Initializes a new instance of the OOFRequest class.

public OOFRequest();

See Also

OOFRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


OOFRequest Properties

The properties of the OOFRequest class are listed below. For a complete list of OOFRequest class members, see the OOFRequest Members topic.

Public Instance Properties

Get | Gets OOF information settings from the server.
Set | Sets OOF information settings on the server.

See Also

OOFRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Get Property

Aspose.Email

OOFRequest.Get Property

Gets OOF information settings from the server.

public OOFReqParametrs Get {get; set;}

See Also

OOFRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Set Property

Aspose.Email

OOFRequest.Set Property

Sets OOF information settings on the server.

public OOFSettings Set {get; set;}

See Also

OOFRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


OOFResponse Class

Specifies a class for retrieving and setting Out of Office (OOF) information.

For a list of all members of this type, see OOFResponse Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.OOFResponse

public class OOFResponse

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

OOFResponse Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


OOFResponse Members

OOFResponse overview

Public Instance Constructors

OOFResponse Constructor Initializes a new instance of the OOFResponse class.

Public Instance Properties

Oof | OOF information settings from the server.
Status | Indicates the result of the ActiveSync command request.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OOFResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


OOFResponse Constructor

Initializes a new instance of the OOFResponse class.

public OOFResponse();

See Also

OOFResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


OOFResponse Properties

The properties of the OOFResponse class are listed below. For a complete list of OOFResponse class members, see the OOFResponse Members topic.

Public Instance Properties

Oof | OOF information settings from the server.
Status | Indicates the result of the ActiveSync command request.

See Also

OOFResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Oof Property

Aspose.Email

OOFResponse.Oof Property

OOF information settings from the server.

public OOFSettings Oof {get; set;}

See Also

OOFResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Status Property

Aspose.Email

OOFResponse.Status Property

Indicates the result of the ActiveSync command request.

public Status Status {get; set;}

See Also

OOFResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


OOFSettings Class

OOF information settings.

For a list of all members of this type, see OOFSettings Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.OOFSettings

public class OOFSettings

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

OOFSettings Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


OOFSettings Members

OOFSettings overview

Public Instance Constructors

OOFSettings Constructor Initializes a new instance of the OOFSettings class.

Public Instance Properties

EndTime | End time during which the user is out of office.
OofMessage | Specifies the OOF message for a particular audience. Exchange 2007, Exchange 2010, and Exchange 2013 require that the reply message for unknown external and known external audiences be the same. The property supports the following three audiences for an OOF message: Internal — A user who is in the same organization as the sending user. Known external — A user who is outside the sending user's organization, but is represented in the sending user's contacts. Unknown external — A user who is outside the sending user's organization and is not represented in the sending user's contacts.
OofState | Specifies the availability of the Oof property.
StartTime | Start time during which the user is out of office.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

OOFSettings Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


OOFSettings Constructor

Initializes a new instance of the OOFSettings class.

public OOFSettings();

See Also

OOFSettings Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


OOFSettings Properties

The properties of the OOFSettings class are listed below. For a complete list of OOFSettings class members, see the OOFSettings Members topic.

Public Instance Properties

EndTime | End time during which the user is out of office.
OofMessage | Specifies the OOF message for a particular audience. Exchange 2007, Exchange 2010, and Exchange 2013 require that the reply message for unknown external and known external audiences be the same. The property supports the following three audiences for an OOF message: Internal — A user who is in the same organization as the sending user. Known external — A user who is outside the sending user's organization, but is represented in the sending user's contacts. Unknown external — A user who is outside the sending user's organization and is not represented in the sending user's contacts.
OofState | Specifies the availability of the Oof property.
StartTime | Start time during which the user is out of office.

See Also

OOFSettings Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


EndTime Property

Aspose.Email

OOFSettings.EndTime Property

End time during which the user is out of office.

public DateTime} EndTime {get; set;}

See Also

OOFSettings Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


OofMessage Property

Aspose.Email

OOFSettings.OofMessage Property

Specifies the OOF message for a particular audience. Exchange 2007, Exchange 2010, and Exchange 2013 require that the reply message for unknown external and known external audiences be the same. The property supports the following three audiences for an OOF message: Internal — A user who is in the same organization as the sending user. Known external — A user who is outside the sending user's organization, but is represented in the sending user's contacts. Unknown external — A user who is outside the sending user's organization and is not represented in the sending user's contacts.

public OOFMessage} OofMessage {get;}

See Also

OOFSettings Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


OofState Property

Aspose.Email

OOFSettings.OofState Property

Specifies the availability of the Oof property.

public OofState} OofState {get; set;}

See Also

OOFSettings Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


StartTime Property

Aspose.Email

OOFSettings.StartTime Property

Start time during which the user is out of office.

public DateTime} StartTime {get; set;}

See Also

OOFSettings Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


OofState Enumeration

Specifies the availability of the Oof property.

public enum OofState

Members

Member Name | Description | Value
Disabled | The Oof property is disabled. | 0
Global | The Oof property is global. | 1
TimeBased | The Oof property is time-based. | 2

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


PictureRequest Class

Indicates that the client is requesting that photos be returned in the server response. The Picture is not supported when the protocol version is 12.1 or 14.0. Contains the data related to the photos request.

For a list of all members of this type, see PictureRequest Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.PictureRequest

public class PictureRequest

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PictureRequest Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


PictureRequest Members

PictureRequest overview

Public Instance Constructors

PictureRequest Constructor Initializes a new instance of the PictureRequest class.

Public Instance Properties

MaxPictures | Limits the number of contact photos returned in the server response. The MaxPictures is not supported when the protocol version is 12.1 or 14.0. The server returns the first N results that have contact photos, where N is the value of the MaxPictures. After the MaxPictures limit is reached, the server returns Status value 173 (NoPicture) if the contact has no photo, Status value 174 (PictureTooLarge) if the contact’s photo is too large, or Status value 175 (PictureLimitReached) if the contact has a photo but the MaxPictures limit was reached. Note that the MaxPictures identifies the number of contact photos returned per query. Therefore, if the client includes three recipients to resolve and sets the MaxPictures value to 3 in the ResolveRecipients command request, a maximum of 9 contact photos can be returned.
MaxSize | Specifies the maximum size of an individual contact photo that is returned in the response, in bytes. The MaxSize is not supported when the protocol version is 12.1 or 14.0. The maximum value of the MaxSize is 100 KB or 102400 bytes.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PictureRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


PictureRequest Constructor

Initializes a new instance of the PictureRequest class.

public PictureRequest();

See Also

PictureRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


PictureRequest Properties

The properties of the PictureRequest class are listed below. For a complete list of PictureRequest class members, see the PictureRequest Members topic.

Public Instance Properties

MaxPictures | Limits the number of contact photos returned in the server response. The MaxPictures is not supported when the protocol version is 12.1 or 14.0. The server returns the first N results that have contact photos, where N is the value of the MaxPictures. After the MaxPictures limit is reached, the server returns Status value 173 (NoPicture) if the contact has no photo, Status value 174 (PictureTooLarge) if the contact’s photo is too large, or Status value 175 (PictureLimitReached) if the contact has a photo but the MaxPictures limit was reached. Note that the MaxPictures identifies the number of contact photos returned per query. Therefore, if the client includes three recipients to resolve and sets the MaxPictures value to 3 in the ResolveRecipients command request, a maximum of 9 contact photos can be returned.
MaxSize | Specifies the maximum size of an individual contact photo that is returned in the response, in bytes. The MaxSize is not supported when the protocol version is 12.1 or 14.0. The maximum value of the MaxSize is 100 KB or 102400 bytes.

See Also

PictureRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


MaxPictures Property

Aspose.Email

PictureRequest.MaxPictures Property

Limits the number of contact photos returned in the server response. The MaxPictures is not supported when the protocol version is 12.1 or 14.0. The server returns the first N results that have contact photos, where N is the value of the MaxPictures. After the MaxPictures limit is reached, the server returns Status value 173 (NoPicture) if the contact has no photo, Status value 174 (PictureTooLarge) if the contact’s photo is too large, or Status value 175 (PictureLimitReached) if the contact has a photo but the MaxPictures limit was reached. Note that the MaxPictures identifies the number of contact photos returned per query. Therefore, if the client includes three recipients to resolve and sets the MaxPictures value to 3 in the ResolveRecipients command request, a maximum of 9 contact photos can be returned.

public Int32} MaxPictures {get; set;}

See Also

PictureRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


MaxSize Property

Aspose.Email

PictureRequest.MaxSize Property

Specifies the maximum size of an individual contact photo that is returned in the response, in bytes. The MaxSize is not supported when the protocol version is 12.1 or 14.0. The maximum value of the MaxSize is 100 KB or 102400 bytes.

public Int32} MaxSize {get; set;}

See Also

PictureRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


PictureRespose Class

Contains the data related to the contact photos. The Picture is not supported when the protocol version is 12.1 or 14.0.

For a list of all members of this type, see PictureRespose Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.PictureRespose

public class PictureRespose

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PictureRespose Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


PictureRespose Members

PictureRespose overview

Public Instance Constructors

PictureRespose Constructor Initializes a new instance of the PictureRespose class.

Public Instance Properties

Data | Contains the binary data of the contact photo. The Data is not supported when the protocol version is 12.1 or 14.0.
Status | Indicates the result of the ActiveSync command request.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PictureRespose Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


PictureRespose Constructor

Initializes a new instance of the PictureRespose class.

public PictureRespose();

See Also

PictureRespose Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


PictureRespose Properties

The properties of the PictureRespose class are listed below. For a complete list of PictureRespose class members, see the PictureRespose Members topic.

Public Instance Properties

Data | Contains the binary data of the contact photo. The Data is not supported when the protocol version is 12.1 or 14.0.
Status | Indicates the result of the ActiveSync command request.

See Also

PictureRespose Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Data Property

Aspose.Email

PictureRespose.Data Property

Contains the binary data of the contact photo. The Data is not supported when the protocol version is 12.1 or 14.0.

public byte[] Data {get; set;}

See Also

PictureRespose Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Status Property

Aspose.Email

PictureRespose.Status Property

Indicates the result of the ActiveSync command request.

public Status Status {get; set;}

See Also

PictureRespose Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


PingParameter Class

Contains the ping command parameters

For a list of all members of this type, see PingParameter Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.PingParameter

public class PingParameter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

PingParameter Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


PingParameter Members

PingParameter overview

Public Instance Constructors

PingParameter Constructor Initializes a new instance of the PingParameter class.

Public Instance Properties

Class | The Class element is a required child element of the Folder element in Ping command requests that specifies the content class of the folder to be monitored. The valid Class element values are: Email, Calendar, Contacts, Tasks, Notes
ServerId | The Id element is a required child element of the Folder element in Ping command requests that specifies the server ID of the folder to be monitored. Elements referenced in this section are defined in the Ping namespace, except where otherwise indicated by the presence of a namespace prefix (as defined in section 2.2.1).

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

PingParameter Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


PingParameter Constructor

Initializes a new instance of the PingParameter class.

public PingParameter(
string serverId,
FolderClass fClass
);

Parameters

serverId
The Id element is a required child element of the Folder element in Ping command requests that specifies the server ID of the folder to be monitored.
fClass
The Class element is a required child element of the Folder element in Ping command requests that specifies the content class of the folder to be monitored.

See Also

PingParameter Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


PingParameter Properties

The properties of the PingParameter class are listed below. For a complete list of PingParameter class members, see the PingParameter Members topic.

Public Instance Properties

Class | The Class element is a required child element of the Folder element in Ping command requests that specifies the content class of the folder to be monitored. The valid Class element values are: Email, Calendar, Contacts, Tasks, Notes
ServerId | The Id element is a required child element of the Folder element in Ping command requests that specifies the server ID of the folder to be monitored. Elements referenced in this section are defined in the Ping namespace, except where otherwise indicated by the presence of a namespace prefix (as defined in section 2.2.1).

See Also

PingParameter Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Class Property

Aspose.Email

PingParameter.Class Property

The Class element is a required child element of the Folder element in Ping command requests that specifies the content class of the folder to be monitored. The valid Class element values are: Email, Calendar, Contacts, Tasks, Notes

public FolderClass Class {get;}

See Also

PingParameter Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ServerId Property

Aspose.Email

PingParameter.ServerId Property

The Id element is a required child element of the Folder element in Ping command requests that specifies the server ID of the folder to be monitored. Elements referenced in this section are defined in the Ping namespace, except where otherwise indicated by the presence of a namespace prefix (as defined in section 2.2.1).

public string ServerId {get;}

See Also

PingParameter Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ProvisionPolicy Class

Specifies a security policy.

For a list of all members of this type, see ProvisionPolicy Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.ProvisionPolicy

public class ProvisionPolicy

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ProvisionPolicy Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ProvisionPolicy Members

ProvisionPolicy overview

Public Instance Constructors

ProvisionPolicy Constructor Initializes a new instance of the ProvisionPolicy class.

Public Instance Properties

Data | Specifies the settings for a policy. Used in the Policy responses only. It is not present in responses to acknowledgment requests.
PolicyKey | PolicyKey is used by the server to mark the state of policy settings on the client in the settings download phase of the Provision command. The PolicyKey is an element of type string with a maximum of 64 characters. The value of the PolicyKey SHOULD be a string representation of a 32-bit unsigned integer.
PolicyType | Specifies the format in which the policy settings are to be provided to the client device.
Status | Indicates the result of the operation.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProvisionPolicy Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ProvisionPolicy Constructor

Initializes a new instance of the ProvisionPolicy class.

public ProvisionPolicy();

See Also

ProvisionPolicy Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ProvisionPolicy Properties

The properties of the ProvisionPolicy class are listed below. For a complete list of ProvisionPolicy class members, see the ProvisionPolicy Members topic.

Public Instance Properties

Data | Specifies the settings for a policy. Used in the Policy responses only. It is not present in responses to acknowledgment requests.
PolicyKey | PolicyKey is used by the server to mark the state of policy settings on the client in the settings download phase of the Provision command. The PolicyKey is an element of type string with a maximum of 64 characters. The value of the PolicyKey SHOULD be a string representation of a 32-bit unsigned integer.
PolicyType | Specifies the format in which the policy settings are to be provided to the client device.
Status | Indicates the result of the operation.

See Also

ProvisionPolicy Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Data Property

Aspose.Email

ProvisionPolicy.Data Property

Specifies the settings for a policy. Used in the Policy responses only. It is not present in responses to acknowledgment requests.

public ProvisionPolicyData Data {get; set;}

See Also

ProvisionPolicy Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


PolicyKey Property

Aspose.Email

ProvisionPolicy.PolicyKey Property

PolicyKey is used by the server to mark the state of policy settings on the client in the settings download phase of the Provision command. The PolicyKey is an element of type string with a maximum of 64 characters. The value of the PolicyKey SHOULD be a string representation of a 32-bit unsigned integer.

public string PolicyKey {get; set;}

See Also

ProvisionPolicy Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


PolicyType Property

Aspose.Email

ProvisionPolicy.PolicyType Property

Specifies the format in which the policy settings are to be provided to the client device.

public string PolicyType {get; set;}

See Also

ProvisionPolicy Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Status Property

Aspose.Email

ProvisionPolicy.Status Property

Indicates the result of the operation.

public Status Status {get; set;}

See Also

ProvisionPolicy Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ProvisionPolicyData Class

Specifies the settings for a policy.

For a list of all members of this type, see ProvisionPolicyData Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.ProvisionPolicyData

public class ProvisionPolicyData

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ProvisionPolicyData Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ProvisionPolicyData Members

ProvisionPolicyData overview

Public Instance Constructors

ProvisionPolicyData Constructor Initializes a new instance of the ProvisionPolicyData class.

Public Instance Properties

EASProvisionDoc Specifies the collection of security settings for device provisioning.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProvisionPolicyData Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ProvisionPolicyData Constructor

Initializes a new instance of the ProvisionPolicyData class.

public ProvisionPolicyData();

See Also

ProvisionPolicyData Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ProvisionPolicyData Properties

The properties of the ProvisionPolicyData class are listed below. For a complete list of ProvisionPolicyData class members, see the ProvisionPolicyData Members topic.

Public Instance Properties

EASProvisionDoc Specifies the collection of security settings for device provisioning.

See Also

ProvisionPolicyData Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


EASProvisionDoc Property

Aspose.Email

ProvisionPolicyData.EASProvisionDoc Property

Specifies the collection of security settings for device provisioning.

public EASProvisionDoc EASProvisionDoc {get; set;}

See Also

ProvisionPolicyData Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ProvisionPolicyStatuses Enumeration

The value indicates the success or failure of the client to apply the policy settings retrieved from the server.

public enum ProvisionPolicyStatuses

Members

Member Name | Description | Value
Success | The client operation was successful. | 1
PartialSuccess | Partial success (at least the PIN was enabled). | 2
NotApply | The client did not apply the policy at all. | 3
ProvisionedByThirdParty | The client claims to have been provisioned by a third party. | 4

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ProvisionRemoteWipeStatuses Enumeration

The value indicates the success or failure of a remote wipe operation on the client.

public enum ProvisionRemoteWipeStatuses

Members

Member Name | Description | Value
Successful | The client remote wipe operation was successful. | 1
Failed | The remote wipe operation failed. | 2

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ProvisionRequest Class

Contains request information for provision command

For a list of all members of this type, see ProvisionRequest Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.ProvisionRequest

public class ProvisionRequest

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ProvisionRequest Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ProvisionRequest Members

ProvisionRequest overview

Public Instance Constructors

ProvisionRequest Constructor Initializes a new instance of the ProvisionRequest class.

Public Instance Properties

DeviceInformation | Device information. When the protocol version is 14.1, the client MUST send the DeviceInformation element with its contents when sending an initial Provision command request to the server but not on subsequent requests.
Policies | Specifies a collection of security policies.
RemoteWipeStatus | Specifies a client's confirmation of a server's remote wipe directive. The value indicates the success or failure of a remote wipe operation on the client.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProvisionRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ProvisionRequest Constructor

Initializes a new instance of the ProvisionRequest class.

public ProvisionRequest();

See Also

ProvisionRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ProvisionRequest Properties

The properties of the ProvisionRequest class are listed below. For a complete list of ProvisionRequest class members, see the ProvisionRequest Members topic.

Public Instance Properties

DeviceInformation | Device information. When the protocol version is 14.1, the client MUST send the DeviceInformation element with its contents when sending an initial Provision command request to the server but not on subsequent requests.
Policies | Specifies a collection of security policies.
RemoteWipeStatus | Specifies a client's confirmation of a server's remote wipe directive. The value indicates the success or failure of a remote wipe operation on the client.

See Also

ProvisionRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


DeviceInformation Property

Aspose.Email

ProvisionRequest.DeviceInformation Property

Device information. When the protocol version is 14.1, the client MUST send the DeviceInformation element with its contents when sending an initial Provision command request to the server but not on subsequent requests.

public DeviceInformation DeviceInformation {get; set;}

See Also

ProvisionRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Policies Property

Aspose.Email

ProvisionRequest.Policies Property

Specifies a collection of security policies.

public ProvisionPolicy} Policies {get;}

See Also

ProvisionRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


RemoteWipeStatus Property

Aspose.Email

ProvisionRequest.RemoteWipeStatus Property

Specifies a client's confirmation of a server's remote wipe directive. The value indicates the success or failure of a remote wipe operation on the client.

public Status RemoteWipeStatus {get; set;}

See Also

ProvisionRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ProvisionResponse Class

Contains response information for provision command

For a list of all members of this type, see ProvisionResponse Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.ProvisionResponse

public class ProvisionResponse

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ProvisionResponse Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ProvisionResponse Members

ProvisionResponse overview

Public Instance Constructors

ProvisionResponse Constructor Initializes a new instance of the ProvisionResponse class.

Public Instance Properties

DeviceInformationStatus | Contains DeviceInformation status
Policies | Specifies a collection of security policies.
RemoteWipe | Specifies a remote wipe directive from the server.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ProvisionResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ProvisionResponse Constructor

Initializes a new instance of the ProvisionResponse class.

public ProvisionResponse();

See Also

ProvisionResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ProvisionResponse Properties

The properties of the ProvisionResponse class are listed below. For a complete list of ProvisionResponse class members, see the ProvisionResponse Members topic.

Public Instance Properties

DeviceInformationStatus | Contains DeviceInformation status
Policies | Specifies a collection of security policies.
RemoteWipe | Specifies a remote wipe directive from the server.

See Also

ProvisionResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


DeviceInformationStatus Property

Aspose.Email

ProvisionResponse.DeviceInformationStatus Property

Contains DeviceInformation status

public Status DeviceInformationStatus {get; set;}

See Also

ProvisionResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Policies Property

Aspose.Email

ProvisionResponse.Policies Property

Specifies a collection of security policies.

public ProvisionPolicy} Policies {get;}

See Also

ProvisionResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


RemoteWipe Property

Aspose.Email

ProvisionResponse.RemoteWipe Property

Specifies a remote wipe directive from the server.

public bool RemoteWipe {get; set;}

See Also

ProvisionResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


QueryType Class

Specifies the keywords to use for matching the entries in the store that is being searched. The value of the Query is used as a prefix-string matching pattern, and returns entries that match the beginning of the string. For example, searching for "John" would match "John Frum" or "Barry Johnson", but would not match "James Littlejohn". All nonempty text properties in the GAL that are indexed by using ANR are compared with the Query element value. Search comparisons are performed by using case-insensitive matching. For a Windows SharePoint Services document library search, this protocol supports queries of the following form: LinkId == value, where value specifies the URL of the item or folder and LinkId indicates that the value is to be compared to the link ID property. For mailbox search, the query syntax is as follows: - Folders can be specified in the following ways: Specified ID Specified folder and subfolders All email folders, including Draft, Inbox and subfolders, Outbox, and Sent Items - The basic keyword query can be composed of the following: The basic operator: And (section 2.2.3.10) A dateTime filter specified by using the GreaterThan (section 2.2.3.78) and LessThan elements (section 2.2.3.87) FreeText elements (section 2.2.3.73) that contain keywords The basic keyword query is executed against all indexed properties.

For a list of all members of this type, see QueryType Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.QueryType

public class QueryType

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

QueryType Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


QueryType Members

QueryType overview

Public Instance Constructors

QueryType Constructor Initializes a new instance of the QueryType class.

Public Instance Properties

Class | Identifies the class of the item. The valid airsync:Class element values are: - Tasks - Email - Calendar - Contacts - Notes - SMS The following classes are supported for mailbox searches when the protocol version is 12.1: Email, Calendar, Contacts, Tasks. The SMS and Notes classes are only available if the protocol version is 14.0 or 14.1. The Search request can include one or more Class elements in the request to limit the type of data included in the Search response. If one or more Class elements are not included in the Search request, the server will return all supported classes. If the Class is included as a child of any element other than the And element, the server responds with a Status value of 8 (SearchTooComplex).
CollectionId | Specifies the folder in which to search. If the DeepTraversal is present, it applies to all folders under each CollectionId. If the CollectionId is included as a child of any element other than And, the server responds with a Status value of 8 (SearchTooComplex).
ConversationId | Specifies the conversation for which to search. The value is a GUID. The ConversationId is not supported when the protocol version is 12.1. If the ConversationId is included as a child of any element other than the And element, the server responds with a Status value of 8 (SearchTooComplex).
FreeText | Specifies a string value for which to search. If the FreeText property is set other than the And property, the server responds with a Status value of 8 (SearchTooComplex).
GreaterThan | Specifies a property and a value that are compared for a 'Greater than' conditions during a search.
LessThan | Specifies a property and a value that are compared for a 'Less than' conditions during a search.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

QueryType Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


QueryType Constructor

Initializes a new instance of the QueryType class.

public QueryType();

See Also

QueryType Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


QueryType Properties

The properties of the QueryType class are listed below. For a complete list of QueryType class members, see the QueryType Members topic.

Public Instance Properties

Class | Identifies the class of the item. The valid airsync:Class element values are: - Tasks - Email - Calendar - Contacts - Notes - SMS The following classes are supported for mailbox searches when the protocol version is 12.1: Email, Calendar, Contacts, Tasks. The SMS and Notes classes are only available if the protocol version is 14.0 or 14.1. The Search request can include one or more Class elements in the request to limit the type of data included in the Search response. If one or more Class elements are not included in the Search request, the server will return all supported classes. If the Class is included as a child of any element other than the And element, the server responds with a Status value of 8 (SearchTooComplex).
CollectionId | Specifies the folder in which to search. If the DeepTraversal is present, it applies to all folders under each CollectionId. If the CollectionId is included as a child of any element other than And, the server responds with a Status value of 8 (SearchTooComplex).
ConversationId | Specifies the conversation for which to search. The value is a GUID. The ConversationId is not supported when the protocol version is 12.1. If the ConversationId is included as a child of any element other than the And element, the server responds with a Status value of 8 (SearchTooComplex).
FreeText | Specifies a string value for which to search. If the FreeText property is set other than the And property, the server responds with a Status value of 8 (SearchTooComplex).
GreaterThan | Specifies a property and a value that are compared for a 'Greater than' conditions during a search.
LessThan | Specifies a property and a value that are compared for a 'Less than' conditions during a search.

See Also

QueryType Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Class Property

Aspose.Email

QueryType.Class Property

Identifies the class of the item. The valid airsync:Class element values are: - Tasks - Email - Calendar - Contacts - Notes - SMS The following classes are supported for mailbox searches when the protocol version is 12.1: Email, Calendar, Contacts, Tasks. The SMS and Notes classes are only available if the protocol version is 14.0 or 14.1. The Search request can include one or more Class elements in the request to limit the type of data included in the Search response. If one or more Class elements are not included in the Search request, the server will return all supported classes. If the Class is included as a child of any element other than the And element, the server responds with a Status value of 8 (SearchTooComplex).

public AirsyncClass} Class {get;}

See Also

QueryType Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


CollectionId Property

Aspose.Email

QueryType.CollectionId Property

Specifies the folder in which to search. If the DeepTraversal is present, it applies to all folders under each CollectionId. If the CollectionId is included as a child of any element other than And, the server responds with a Status value of 8 (SearchTooComplex).

public String} CollectionId {get;}

See Also

QueryType Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ConversationId Property

Aspose.Email

QueryType.ConversationId Property

Specifies the conversation for which to search. The value is a GUID. The ConversationId is not supported when the protocol version is 12.1. If the ConversationId is included as a child of any element other than the And element, the server responds with a Status value of 8 (SearchTooComplex).

public string ConversationId {get; set;}

See Also

QueryType Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


FreeText Property

Aspose.Email

QueryType.FreeText Property

Specifies a string value for which to search. If the FreeText property is set other than the And property, the server responds with a Status value of 8 (SearchTooComplex).

public string FreeText {get; set;}

See Also

QueryType Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


GreaterThan Property

Aspose.Email

QueryType.GreaterThan Property

Specifies a property and a value that are compared for a 'Greater than' conditions during a search.

public SearchCondition GreaterThan {get; set;}

See Also

QueryType Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


LessThan Property

Aspose.Email

QueryType.LessThan Property

Specifies a property and a value that are compared for a 'Less than' conditions during a search.

public SearchCondition LessThan {get; set;}

See Also

QueryType Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Recipient Class

Represents a single recipient that has been resolved.

For a list of all members of this type, see Recipient Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.Recipient

public class Recipient

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Recipient Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Recipient Members

Recipient overview

Public Instance Constructors

Recipient Constructor Initializes a new instance of the Recipient class.

Public Instance Properties

Availability | Identifies status and free/busy data of the users or distribution lists identified in the request for the time identified by the StartTime and EndTime. When the Availability is included in a ResolveRecipients request, the server retrieves free/busy information for the users identified in the To elements included in the request, and returns the free/busy information in the MergedFreeBusy in the response.
Certificates | Contains information about the certificates for a recipient.
DisplayName | Contains the display name of the recipient.
EmailAddress | Contains the email address of the recipient, in SMTP format.
Picture | Contains the data related to the contact photos.
Type | Indicates the type of recipient.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Recipient Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Recipient Constructor

Initializes a new instance of the Recipient class.

public Recipient();

See Also

Recipient Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Recipient Properties

The properties of the Recipient class are listed below. For a complete list of Recipient class members, see the Recipient Members topic.

Public Instance Properties

Availability | Identifies status and free/busy data of the users or distribution lists identified in the request for the time identified by the StartTime and EndTime. When the Availability is included in a ResolveRecipients request, the server retrieves free/busy information for the users identified in the To elements included in the request, and returns the free/busy information in the MergedFreeBusy in the response.
Certificates | Contains information about the certificates for a recipient.
DisplayName | Contains the display name of the recipient.
EmailAddress | Contains the email address of the recipient, in SMTP format.
Picture | Contains the data related to the contact photos.
Type | Indicates the type of recipient.

See Also

Recipient Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Availability Property

Aspose.Email

Recipient.Availability Property

Identifies status and free/busy data of the users or distribution lists identified in the request for the time identified by the StartTime and EndTime. When the Availability is included in a ResolveRecipients request, the server retrieves free/busy information for the users identified in the To elements included in the request, and returns the free/busy information in the MergedFreeBusy in the response.

public ResolveRecipientsAvailabilityResponse Availability {get; set;}

See Also

Recipient Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Certificates Property

Aspose.Email

Recipient.Certificates Property

Contains information about the certificates for a recipient.

public ResolveRecipientsCertificates Certificates {get; set;}

See Also

Recipient Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


DisplayName Property

Aspose.Email

Recipient.DisplayName Property

Contains the display name of the recipient.

public string DisplayName {get; set;}

See Also

Recipient Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


EmailAddress Property

Aspose.Email

Recipient.EmailAddress Property

Contains the email address of the recipient, in SMTP format.

public string EmailAddress {get; set;}

See Also

Recipient Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Picture Property

Aspose.Email

Recipient.Picture Property

Contains the data related to the contact photos.

public PictureRespose Picture {get; set;}

See Also

Recipient Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Type Property

Aspose.Email

Recipient.Type Property

Indicates the type of recipient.

public RecipientType Type {get; set;}

See Also

Recipient Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


RecipientType Enumeration

Indicates the type of recipient.

public enum RecipientType

Members

Member Name | Description | Value
GAL | Represents a GAL entry. | 1
Contact | Represents a contact entry. | 2

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ResolveRecipientsAvailabilityRequest Class

Indicates to the server that free/busy data is being requested by the client and identifies the start time and end time of the free/busy data to retrieve. The Availability is not supported when the protocol version is 12.1.

For a list of all members of this type, see ResolveRecipientsAvailabilityRequest Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.ResolveRecipientsAvailabilityRequest

public class ResolveRecipientsAvailabilityRequest

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ResolveRecipientsAvailabilityRequest Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ResolveRecipientsAvailabilityRequest Members

ResolveRecipientsAvailabilityRequest overview

Public Instance Constructors

ResolveRecipientsAvailabilityRequest Constructor Initializes a new instance of the ResolveRecipientsAvailabilityRequest class.

Public Instance Properties

EndTime | Identifies the end of the span of free/busy time requested by the client. The EndTime is not supported when the protocol version is 12.1. If the client sends an invalid EndTime value, then the server returns a Status value of 5 in the ResolveRecipients command response. If no EndTime is included in an Availablity request, the server uses a default end time value of seven days after the StartTime value. If the EndTime value specified in the request is smaller than the StartTime value plus 30 minutes, or the duration spanned by the StartTime value and the EndTime value is greater than a specific number of days, then the server returns a Status value of 5 in the ResolveRecipients command response. Exchange 2010 and Exchange 2013 use 42 days; Exchange 2007 SP1 uses 62 days.
StartTime | Identifies the start of the span of free/busy time requested by the client. The StartTime is not supported when the protocol version is 12.1. If the Availability is included in the request, the request MUST also include the StartTime and EndTime. If the client sends an invalid StartTime value, then the server returns a Status value of 5 in the ResolveRecipients command response.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ResolveRecipientsAvailabilityRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ResolveRecipientsAvailabilityRequest Constructor

Initializes a new instance of the ResolveRecipientsAvailabilityRequest class.

public ResolveRecipientsAvailabilityRequest();

See Also

ResolveRecipientsAvailabilityRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ResolveRecipientsAvailabilityRequest Properties

The properties of the ResolveRecipientsAvailabilityRequest class are listed below. For a complete list of ResolveRecipientsAvailabilityRequest class members, see the ResolveRecipientsAvailabilityRequest Members topic.

Public Instance Properties

EndTime | Identifies the end of the span of free/busy time requested by the client. The EndTime is not supported when the protocol version is 12.1. If the client sends an invalid EndTime value, then the server returns a Status value of 5 in the ResolveRecipients command response. If no EndTime is included in an Availablity request, the server uses a default end time value of seven days after the StartTime value. If the EndTime value specified in the request is smaller than the StartTime value plus 30 minutes, or the duration spanned by the StartTime value and the EndTime value is greater than a specific number of days, then the server returns a Status value of 5 in the ResolveRecipients command response. Exchange 2010 and Exchange 2013 use 42 days; Exchange 2007 SP1 uses 62 days.
StartTime | Identifies the start of the span of free/busy time requested by the client. The StartTime is not supported when the protocol version is 12.1. If the Availability is included in the request, the request MUST also include the StartTime and EndTime. If the client sends an invalid StartTime value, then the server returns a Status value of 5 in the ResolveRecipients command response.

See Also

ResolveRecipientsAvailabilityRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


EndTime Property

Aspose.Email

ResolveRecipientsAvailabilityRequest.EndTime Property

Identifies the end of the span of free/busy time requested by the client. The EndTime is not supported when the protocol version is 12.1. If the client sends an invalid EndTime value, then the server returns a Status value of 5 in the ResolveRecipients command response. If no EndTime is included in an Availablity request, the server uses a default end time value of seven days after the StartTime value. If the EndTime value specified in the request is smaller than the StartTime value plus 30 minutes, or the duration spanned by the StartTime value and the EndTime value is greater than a specific number of days, then the server returns a Status value of 5 in the ResolveRecipients command response. Exchange 2010 and Exchange 2013 use 42 days; Exchange 2007 SP1 uses 62 days.

public DateTime} EndTime {get; set;}

See Also

ResolveRecipientsAvailabilityRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


StartTime Property

Aspose.Email

ResolveRecipientsAvailabilityRequest.StartTime Property

Identifies the start of the span of free/busy time requested by the client. The StartTime is not supported when the protocol version is 12.1. If the Availability is included in the request, the request MUST also include the StartTime and EndTime. If the client sends an invalid StartTime value, then the server returns a Status value of 5 in the ResolveRecipients command response.

public DateTime StartTime {get; set;}

See Also

ResolveRecipientsAvailabilityRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ResolveRecipientsAvailabilityResponse Class

Identifies status and free/busy data of the users or distribution lists identified in the request for the time identified by the StartTime and EndTime. When the Availability is included in a ResolveRecipients request, the server retrieves free/busy information for the users identified in the To elements included in the request, and returns the free/busy information in the MergedFreeBusy in the response. When the server parses the request, the server first resolves the recipients identified by the To elements, and then determines the users free/busy information for the specified time span, before returning the free/busy data in the MergedFreeBusy.

For a list of all members of this type, see ResolveRecipientsAvailabilityResponse Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.ResolveRecipientsAvailabilityResponse

public class ResolveRecipientsAvailabilityResponse

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ResolveRecipientsAvailabilityResponse Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ResolveRecipientsAvailabilityResponse Members

ResolveRecipientsAvailabilityResponse overview

Public Instance Constructors

ResolveRecipientsAvailabilityResponse Constructor Initializes a new instance of the ResolveRecipientsAvailabilityResponse class.

Public Instance Properties

MergedFreeBusy | Specifies the free/busy information for the users or distribution list identified in the request. Each item in the MergedFreeBusy list indicates the free/busy status for the user or distribution list for every 30 minute interval.
Status | Indicates the result of the ActiveSync command request.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ResolveRecipientsAvailabilityResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ResolveRecipientsAvailabilityResponse Constructor

Initializes a new instance of the ResolveRecipientsAvailabilityResponse class.

public ResolveRecipientsAvailabilityResponse();

See Also

ResolveRecipientsAvailabilityResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ResolveRecipientsAvailabilityResponse Properties

The properties of the ResolveRecipientsAvailabilityResponse class are listed below. For a complete list of ResolveRecipientsAvailabilityResponse class members, see the ResolveRecipientsAvailabilityResponse Members topic.

Public Instance Properties

MergedFreeBusy | Specifies the free/busy information for the users or distribution list identified in the request. Each item in the MergedFreeBusy list indicates the free/busy status for the user or distribution list for every 30 minute interval.
Status | Indicates the result of the ActiveSync command request.

See Also

ResolveRecipientsAvailabilityResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


MergedFreeBusy Property

Aspose.Email

ResolveRecipientsAvailabilityResponse.MergedFreeBusy Property

Specifies the free/busy information for the users or distribution list identified in the request. Each item in the MergedFreeBusy list indicates the free/busy status for the user or distribution list for every 30 minute interval.

public MergedFreeBusy} MergedFreeBusy {get;}

See Also

ResolveRecipientsAvailabilityResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Status Property

Aspose.Email

ResolveRecipientsAvailabilityResponse.Status Property

Indicates the result of the ActiveSync command request.

public Status Status {get; set;}

See Also

ResolveRecipientsAvailabilityResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ResolveRecipientsCertificates Class

Contains information about the certificates for a recipient.

For a list of all members of this type, see ResolveRecipientsCertificates Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.ResolveRecipientsCertificates

public class ResolveRecipientsCertificates

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ResolveRecipientsCertificates Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ResolveRecipientsCertificates Members

ResolveRecipientsCertificates overview

Public Instance Constructors

ResolveRecipientsCertificates Constructor Initializes a new instance of the ResolveRecipientsCertificates class.

Public Instance Properties

CertificateCount | Specifies the number of valid certificates that were found for the recipient. If a Status value of 8 is returned with the Certificates, the CertificateCount specifies the number of recipient certificates that were not returned.
Certificates | Contains the list of X509 certificates as binary large object (BLOB). This element is returned by the server only if the client specifies a value of 2 in the CertificateRetrieval in the ResolveRecipients command request.
MiniCertificate | Contains the mini-certificate BLOB. This element is returned only if the client specifies a value of 3 in the CertificateRetrieval in the ResolveRecipients command request and the resolved recipient has a valid S/MIME certificate.
RecipientCount | Specifies the number of members belonging to a distribution list. It can be used to determine whether all recipients belonging to a distribution list have valid certificates by comparing values of the CertificateCount and RecipientCount elements.
Status | Indicates the result of the ActiveSync command request.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ResolveRecipientsCertificates Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ResolveRecipientsCertificates Constructor

Initializes a new instance of the ResolveRecipientsCertificates class.

public ResolveRecipientsCertificates();

See Also

ResolveRecipientsCertificates Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ResolveRecipientsCertificates Properties

The properties of the ResolveRecipientsCertificates class are listed below. For a complete list of ResolveRecipientsCertificates class members, see the ResolveRecipientsCertificates Members topic.

Public Instance Properties

CertificateCount | Specifies the number of valid certificates that were found for the recipient. If a Status value of 8 is returned with the Certificates, the CertificateCount specifies the number of recipient certificates that were not returned.
Certificates | Contains the list of X509 certificates as binary large object (BLOB). This element is returned by the server only if the client specifies a value of 2 in the CertificateRetrieval in the ResolveRecipients command request.
MiniCertificate | Contains the mini-certificate BLOB. This element is returned only if the client specifies a value of 3 in the CertificateRetrieval in the ResolveRecipients command request and the resolved recipient has a valid S/MIME certificate.
RecipientCount | Specifies the number of members belonging to a distribution list. It can be used to determine whether all recipients belonging to a distribution list have valid certificates by comparing values of the CertificateCount and RecipientCount elements.
Status | Indicates the result of the ActiveSync command request.

See Also

ResolveRecipientsCertificates Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


CertificateCount Property

Aspose.Email

ResolveRecipientsCertificates.CertificateCount Property

Specifies the number of valid certificates that were found for the recipient. If a Status value of 8 is returned with the Certificates, the CertificateCount specifies the number of recipient certificates that were not returned.

public Int32} CertificateCount {get; set;}

See Also

ResolveRecipientsCertificates Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Certificates Property

Aspose.Email

ResolveRecipientsCertificates.Certificates Property

Contains the list of X509 certificates as binary large object (BLOB). This element is returned by the server only if the client specifies a value of 2 in the CertificateRetrieval in the ResolveRecipients command request.

public Byte[]} Certificates {get;}

See Also

ResolveRecipientsCertificates Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


MiniCertificate Property

Aspose.Email

ResolveRecipientsCertificates.MiniCertificate Property

Contains the mini-certificate BLOB. This element is returned only if the client specifies a value of 3 in the CertificateRetrieval in the ResolveRecipients command request and the resolved recipient has a valid S/MIME certificate.

public byte[] MiniCertificate {get; set;}

See Also

ResolveRecipientsCertificates Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


RecipientCount Property

Aspose.Email

ResolveRecipientsCertificates.RecipientCount Property

Specifies the number of members belonging to a distribution list. It can be used to determine whether all recipients belonging to a distribution list have valid certificates by comparing values of the CertificateCount and RecipientCount elements.

public int RecipientCount {get; set;}

See Also

ResolveRecipientsCertificates Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Status Property

Aspose.Email

ResolveRecipientsCertificates.Status Property

Indicates the result of the ActiveSync command request.

public Status Status {get; set;}

See Also

ResolveRecipientsCertificates Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ResolveRecipientsOptions Class

Contains the options for resolving the list of recipients.

For a list of all members of this type, see ResolveRecipientsOptions Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.ResolveRecipientsOptions

public class ResolveRecipientsOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ResolveRecipientsOptions Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ResolveRecipientsOptions Members

ResolveRecipientsOptions overview

Public Instance Constructors

ResolveRecipientsOptions Constructor Initializes a new instance of the ResolveRecipientsOptions class.

Public Instance Properties

Availability | Indicates to the server that free/busy data is being requested by the client and identifies the start time and end time of the free/busy data to retrieve. When the Availability is included in a ResolveRecipients request, the server retrieves free/busy information for the users identified in the To elements included in the request, and returns the free/busy information in the MergedFreeBusy in the response. If the Availability element is included in the ResolveRecipients request, the request MUST also include a valid StartTime value and EndTime value. When the server parses the request, the server first resolves the recipients identified by the To elements, and then determines the users free/busy information for the specified time span, before returning the free/busy data in the MergedFreeBusy.
CertificateRetrieval | Specifies whether S/MIME certificates SHOULD be returned by the server for each resolved recipient.
MaxAmbiguousRecipients | Limits the number of suggestions that are returned for each ambiguous recipient node in the response. The value of the MaxAmbiguousRecipients is limited to a range of 0–9999. Each ambiguous recipient node receives only this many suggestions and no more. The recipient count, returned in the RecipientCount, can be used by the client to determine the total number of suggestions available for that recipient.
MaxCertificates | Limits the total number of certificates that are returned by the server. The value of the MaxCertificates is limited to a range of 0–9999. This limit ensures that no individual recipient receives an incomplete set of certificates. If the MaxCertificates limit is reached while enumerating certificates for an address list, that address list will not get back any certificates and a Status value of 8 is returned.
Picture | Indicates that the client is requesting that contact photos be returned in the server response. The Picture is not supported when the protocol version is 12.1 or 14.0. Contains the data related to the contact photos.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ResolveRecipientsOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ResolveRecipientsOptions Constructor

Initializes a new instance of the ResolveRecipientsOptions class.

public ResolveRecipientsOptions();

See Also

ResolveRecipientsOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ResolveRecipientsOptions Properties

The properties of the ResolveRecipientsOptions class are listed below. For a complete list of ResolveRecipientsOptions class members, see the ResolveRecipientsOptions Members topic.

Public Instance Properties

Availability | Indicates to the server that free/busy data is being requested by the client and identifies the start time and end time of the free/busy data to retrieve. When the Availability is included in a ResolveRecipients request, the server retrieves free/busy information for the users identified in the To elements included in the request, and returns the free/busy information in the MergedFreeBusy in the response. If the Availability element is included in the ResolveRecipients request, the request MUST also include a valid StartTime value and EndTime value. When the server parses the request, the server first resolves the recipients identified by the To elements, and then determines the users free/busy information for the specified time span, before returning the free/busy data in the MergedFreeBusy.
CertificateRetrieval | Specifies whether S/MIME certificates SHOULD be returned by the server for each resolved recipient.
MaxAmbiguousRecipients | Limits the number of suggestions that are returned for each ambiguous recipient node in the response. The value of the MaxAmbiguousRecipients is limited to a range of 0–9999. Each ambiguous recipient node receives only this many suggestions and no more. The recipient count, returned in the RecipientCount, can be used by the client to determine the total number of suggestions available for that recipient.
MaxCertificates | Limits the total number of certificates that are returned by the server. The value of the MaxCertificates is limited to a range of 0–9999. This limit ensures that no individual recipient receives an incomplete set of certificates. If the MaxCertificates limit is reached while enumerating certificates for an address list, that address list will not get back any certificates and a Status value of 8 is returned.
Picture | Indicates that the client is requesting that contact photos be returned in the server response. The Picture is not supported when the protocol version is 12.1 or 14.0. Contains the data related to the contact photos.

See Also

ResolveRecipientsOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Availability Property

Aspose.Email

ResolveRecipientsOptions.Availability Property

Indicates to the server that free/busy data is being requested by the client and identifies the start time and end time of the free/busy data to retrieve. When the Availability is included in a ResolveRecipients request, the server retrieves free/busy information for the users identified in the To elements included in the request, and returns the free/busy information in the MergedFreeBusy in the response. If the Availability element is included in the ResolveRecipients request, the request MUST also include a valid StartTime value and EndTime value. When the server parses the request, the server first resolves the recipients identified by the To elements, and then determines the users free/busy information for the specified time span, before returning the free/busy data in the MergedFreeBusy.

public ResolveRecipientsAvailabilityRequest Availability {get; set;}

See Also

ResolveRecipientsOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


CertificateRetrieval Property

Aspose.Email

ResolveRecipientsOptions.CertificateRetrieval Property

Specifies whether S/MIME certificates SHOULD be returned by the server for each resolved recipient.

public CertificateRetrieval} CertificateRetrieval {get; set;}

See Also

ResolveRecipientsOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


MaxAmbiguousRecipients Property

Aspose.Email

ResolveRecipientsOptions.MaxAmbiguousRecipients Property

Limits the number of suggestions that are returned for each ambiguous recipient node in the response. The value of the MaxAmbiguousRecipients is limited to a range of 0–9999. Each ambiguous recipient node receives only this many suggestions and no more. The recipient count, returned in the RecipientCount, can be used by the client to determine the total number of suggestions available for that recipient.

public Int32} MaxAmbiguousRecipients {get; set;}

See Also

ResolveRecipientsOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


MaxCertificates Property

Aspose.Email

ResolveRecipientsOptions.MaxCertificates Property

Limits the total number of certificates that are returned by the server. The value of the MaxCertificates is limited to a range of 0–9999. This limit ensures that no individual recipient receives an incomplete set of certificates. If the MaxCertificates limit is reached while enumerating certificates for an address list, that address list will not get back any certificates and a Status value of 8 is returned.

public Int32} MaxCertificates {get; set;}

See Also

ResolveRecipientsOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Picture Property

Aspose.Email

ResolveRecipientsOptions.Picture Property

Indicates that the client is requesting that contact photos be returned in the server response. The Picture is not supported when the protocol version is 12.1 or 14.0. Contains the data related to the contact photos.

public PictureRequest Picture {get; set;}

See Also

ResolveRecipientsOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ResolveRecipientsRequest Class

Contains information to resolve recipients.

For a list of all members of this type, see ResolveRecipientsRequest Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.ResolveRecipientsRequest

public class ResolveRecipientsRequest

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ResolveRecipientsRequest Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ResolveRecipientsRequest Members

ResolveRecipientsRequest overview

Public Instance Constructors

ResolveRecipientsRequest Constructor Initializes a new instance of the ResolveRecipientsRequest class.

Public Instance Properties

Options | Contains the options for resolving the list of recipients.
To | Specifies one or more recipients to be resolved. Value can be up to 256 characters in length. The result of including more than 1000 To elements in the request is undefined. The server MAY return a protocol status error in response to such a command request. If the ResolveRecipients command request includes the Availability, a maximum of 100 To elements containing SMTP addresses can be included in the request. If more than 100 SMTP addresses are included in the request, Status value 160 is returned in the response. If the ResolveRecipients command request includes the Availability and includes a To element for an ambiguous user, the response does not include a MergedFreeBusy element for that user. Only users or distribution lists specified with valid SMTP addresses or a uniquely identifiable string in the request message To element have MergedFreeBusy elements included in the response. If the ResolveRecipients command request includes the Availability and the To element specifies a distribution group, then the availability data is returned as a single string that merges the data for the individual members of the distribution group. If the distribution group contains more than 20 members, a Status element value of 161 is returned in the response indicating that the merged free busy information of such a large distribution group is not useful.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ResolveRecipientsRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ResolveRecipientsRequest Constructor

Initializes a new instance of the ResolveRecipientsRequest class.

public ResolveRecipientsRequest();

See Also

ResolveRecipientsRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ResolveRecipientsRequest Properties

The properties of the ResolveRecipientsRequest class are listed below. For a complete list of ResolveRecipientsRequest class members, see the ResolveRecipientsRequest Members topic.

Public Instance Properties

Options | Contains the options for resolving the list of recipients.
To | Specifies one or more recipients to be resolved. Value can be up to 256 characters in length. The result of including more than 1000 To elements in the request is undefined. The server MAY return a protocol status error in response to such a command request. If the ResolveRecipients command request includes the Availability, a maximum of 100 To elements containing SMTP addresses can be included in the request. If more than 100 SMTP addresses are included in the request, Status value 160 is returned in the response. If the ResolveRecipients command request includes the Availability and includes a To element for an ambiguous user, the response does not include a MergedFreeBusy element for that user. Only users or distribution lists specified with valid SMTP addresses or a uniquely identifiable string in the request message To element have MergedFreeBusy elements included in the response. If the ResolveRecipients command request includes the Availability and the To element specifies a distribution group, then the availability data is returned as a single string that merges the data for the individual members of the distribution group. If the distribution group contains more than 20 members, a Status element value of 161 is returned in the response indicating that the merged free busy information of such a large distribution group is not useful.

See Also

ResolveRecipientsRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Options Property

Aspose.Email

ResolveRecipientsRequest.Options Property

Contains the options for resolving the list of recipients.

public ResolveRecipientsOptions Options {get; set;}

See Also

ResolveRecipientsRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


To Property

Aspose.Email

ResolveRecipientsRequest.To Property

Specifies one or more recipients to be resolved. Value can be up to 256 characters in length. The result of including more than 1000 To elements in the request is undefined. The server MAY return a protocol status error in response to such a command request. If the ResolveRecipients command request includes the Availability, a maximum of 100 To elements containing SMTP addresses can be included in the request. If more than 100 SMTP addresses are included in the request, Status value 160 is returned in the response. If the ResolveRecipients command request includes the Availability and includes a To element for an ambiguous user, the response does not include a MergedFreeBusy element for that user. Only users or distribution lists specified with valid SMTP addresses or a uniquely identifiable string in the request message To element have MergedFreeBusy elements included in the response. If the ResolveRecipients command request includes the Availability and the To element specifies a distribution group, then the availability data is returned as a single string that merges the data for the individual members of the distribution group. If the distribution group contains more than 20 members, a Status element value of 161 is returned in the response indicating that the merged free busy information of such a large distribution group is not useful.

public String} To {get;}

See Also

ResolveRecipientsRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ResolveRecipientsResponse Class

Contains information as to whether the recipient was resolved. If the recipient was resolved, the it also contains the type of recipient, the email address that the recipient resolved to, and, optionally, the S/MIME certificate for the recipient.

For a list of all members of this type, see ResolveRecipientsResponse Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.ResolveRecipientsResponse

public class ResolveRecipientsResponse

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ResolveRecipientsResponse Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ResolveRecipientsResponse Members

ResolveRecipientsResponse overview

Public Instance Constructors

ResolveRecipientsResponse Constructor Initializes a new instance of the ResolveRecipientsResponse class.

Public Instance Properties

RecipientCount | Specifies the number of recipients that are returned in the ResolveRecipients command response.
Recipients | Represents recipients that have been resolved. More than one Recipient are returned in a Response if the To specified in the request was either resolved to a distribution list or found to be ambiguous. The status code returned in the Response can be used to determine if the recipient was found to be ambiguous. The recipient would be a suggested match if the recipient specified in the request was found to be ambiguous. Certificates are returned if the client requested certificates to be returned in the response.
Status | Indicates the result of the ActiveSync command request.
To | Specifies a recipient to be resolved. Its value can be up to 256 characters in length. If the To element specifies an ambiguous name and the Availability is included in the request, the response will not include free/busy data for that user. The Availability is only included when the To element includes a valid SMTP address or name that resolves to a unique individual on the server. The result of including more than 1000 To elements in the request is undefined. The server MAY return a protocol status error in response to such a command request. If the ResolveRecipients command request includes the Availability, a maximum of 100 To elements containing SMTP addresses can be included in the request. If more than 100 SMTP addresses are included in the request, Status value 160 is returned in the response. If the ResolveRecipients command request includes the Availability and includes a To element for an ambiguous user, the response does not include a MergedFreeBusy element for that user. Only users or distribution lists specified with valid SMTP addresses or a uniquely identifiable string in the request message To element have MergedFreeBusy elements included in the response. If the ResolveRecipients command request includes the Availability and the To element specifies a distribution group, then the availability data is returned as a single string that merges the data for the individual members of the distribution group. If the distribution group contains more than 20 members, a Status element value of 161 is returned in the response indicating that the merged free busy information of such a large distribution group is not useful.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ResolveRecipientsResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ResolveRecipientsResponse Constructor

Initializes a new instance of the ResolveRecipientsResponse class.

public ResolveRecipientsResponse();

See Also

ResolveRecipientsResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ResolveRecipientsResponse Properties

The properties of the ResolveRecipientsResponse class are listed below. For a complete list of ResolveRecipientsResponse class members, see the ResolveRecipientsResponse Members topic.

Public Instance Properties

RecipientCount | Specifies the number of recipients that are returned in the ResolveRecipients command response.
Recipients | Represents recipients that have been resolved. More than one Recipient are returned in a Response if the To specified in the request was either resolved to a distribution list or found to be ambiguous. The status code returned in the Response can be used to determine if the recipient was found to be ambiguous. The recipient would be a suggested match if the recipient specified in the request was found to be ambiguous. Certificates are returned if the client requested certificates to be returned in the response.
Status | Indicates the result of the ActiveSync command request.
To | Specifies a recipient to be resolved. Its value can be up to 256 characters in length. If the To element specifies an ambiguous name and the Availability is included in the request, the response will not include free/busy data for that user. The Availability is only included when the To element includes a valid SMTP address or name that resolves to a unique individual on the server. The result of including more than 1000 To elements in the request is undefined. The server MAY return a protocol status error in response to such a command request. If the ResolveRecipients command request includes the Availability, a maximum of 100 To elements containing SMTP addresses can be included in the request. If more than 100 SMTP addresses are included in the request, Status value 160 is returned in the response. If the ResolveRecipients command request includes the Availability and includes a To element for an ambiguous user, the response does not include a MergedFreeBusy element for that user. Only users or distribution lists specified with valid SMTP addresses or a uniquely identifiable string in the request message To element have MergedFreeBusy elements included in the response. If the ResolveRecipients command request includes the Availability and the To element specifies a distribution group, then the availability data is returned as a single string that merges the data for the individual members of the distribution group. If the distribution group contains more than 20 members, a Status element value of 161 is returned in the response indicating that the merged free busy information of such a large distribution group is not useful.

See Also

ResolveRecipientsResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


RecipientCount Property

Aspose.Email

ResolveRecipientsResponse.RecipientCount Property

Specifies the number of recipients that are returned in the ResolveRecipients command response.

public int RecipientCount {get; set;}

See Also

ResolveRecipientsResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Recipients Property

Aspose.Email

ResolveRecipientsResponse.Recipients Property

Represents recipients that have been resolved. More than one Recipient are returned in a Response if the To specified in the request was either resolved to a distribution list or found to be ambiguous. The status code returned in the Response can be used to determine if the recipient was found to be ambiguous. The recipient would be a suggested match if the recipient specified in the request was found to be ambiguous. Certificates are returned if the client requested certificates to be returned in the response.

public Recipient} Recipients {get;}

See Also

ResolveRecipientsResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Status Property

Aspose.Email

ResolveRecipientsResponse.Status Property

Indicates the result of the ActiveSync command request.

public Status Status {get; set;}

See Also

ResolveRecipientsResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


To Property

Aspose.Email

ResolveRecipientsResponse.To Property

Specifies a recipient to be resolved. Its value can be up to 256 characters in length. If the To element specifies an ambiguous name and the Availability is included in the request, the response will not include free/busy data for that user. The Availability is only included when the To element includes a valid SMTP address or name that resolves to a unique individual on the server. The result of including more than 1000 To elements in the request is undefined. The server MAY return a protocol status error in response to such a command request. If the ResolveRecipients command request includes the Availability, a maximum of 100 To elements containing SMTP addresses can be included in the request. If more than 100 SMTP addresses are included in the request, Status value 160 is returned in the response. If the ResolveRecipients command request includes the Availability and includes a To element for an ambiguous user, the response does not include a MergedFreeBusy element for that user. Only users or distribution lists specified with valid SMTP addresses or a uniquely identifiable string in the request message To element have MergedFreeBusy elements included in the response. If the ResolveRecipients command request includes the Availability and the To element specifies a distribution group, then the availability data is returned as a single string that merges the data for the individual members of the distribution group. If the distribution group contains more than 20 members, a Status element value of 161 is returned in the response indicating that the merged free busy information of such a large distribution group is not useful.

public string To {get; set;}

See Also

ResolveRecipientsResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


RightsManagementInformationResponce Class

Contains rights management information settings retrieved from the server.

For a list of all members of this type, see RightsManagementInformationResponce Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.RightsManagementInformationResponce

public class RightsManagementInformationResponce

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RightsManagementInformationResponce Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


RightsManagementInformationResponce Members

RightsManagementInformationResponce overview

Public Instance Constructors

RightsManagementInformationResponce Constructor Initializes a new instance of the RightsManagementInformationResponce class.

Public Instance Properties

RightsManagementTemplates | The list of RightsManagementTemplates. A maximum of 20 RightsManagementTemplate objects can be returned to the client.
Status | Indicates the result of the ActiveSync command request.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RightsManagementInformationResponce Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


RightsManagementInformationResponce Constructor

Initializes a new instance of the RightsManagementInformationResponce class.

public RightsManagementInformationResponce();

See Also

RightsManagementInformationResponce Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


RightsManagementInformationResponce Properties

The properties of the RightsManagementInformationResponce class are listed below. For a complete list of RightsManagementInformationResponce class members, see the RightsManagementInformationResponce Members topic.

Public Instance Properties

RightsManagementTemplates | The list of RightsManagementTemplates. A maximum of 20 RightsManagementTemplate objects can be returned to the client.
Status | Indicates the result of the ActiveSync command request.

See Also

RightsManagementInformationResponce Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


RightsManagementTemplates Property

Aspose.Email

RightsManagementInformationResponce.RightsManagementTemplates Property

The list of RightsManagementTemplates. A maximum of 20 RightsManagementTemplate objects can be returned to the client.

public RightsManagementTemplate} RightsManagementTemplates {get;}

See Also

RightsManagementInformationResponce Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Status Property

Aspose.Email

RightsManagementInformationResponce.Status Property

Indicates the result of the ActiveSync command request.

public Status Status {get; set;}

See Also

RightsManagementInformationResponce Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


RightsManagementLicense Class

Contains the rights policy template settings for the template applied to the e-mail message being synchronized.

For a list of all members of this type, see RightsManagementLicense Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.RightsManagementLicense

public class RightsManagementLicense

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RightsManagementLicense Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


RightsManagementLicense Members

RightsManagementLicense overview

Public Instance Constructors

RightsManagementLicense Constructor Initializes a new instance of the RightsManagementLicense class.

Public Instance Properties

ContentExpiryDate | Specifies the expiration date for the license. The ContentExpiryDate element is set to "9999-12-30T23:59:59.999Z" if the rights management license has no expiration date set.
ContentOwner | Specifies whether the content of the original email can be modified by the user when the user forwards, replies, or replies all to the email message. The value is TRUE if the e-mail can be modified by the user; otherwise, FALSE. A value of FALSE requires that the client MUST exclude the original rights-managed email message from the SmartForward or SmartReply request. Consequently, inline replies are not allowed if the EditAllowed element is set to FALSE. When EditAllowed is set to FALSE and ReplaceMime is not present in a SmartForward or SmartReply request, the server will add the original rights-managed email message as an attachment to the new message. Conversely, if ReplaceMime is present, the server will not attach the original rights-managed email message as an attachment.
EditAllowed | Specifies whether the content of the original email can be modified by the user when the user forwards, replies, or replies all to the email message. The value is TRUE if the e-mail can be modified by the user; otherwise, FALSE. A value of FALSE requires that the client MUST exclude the original rights-managed email message from the SmartForward or SmartReply request. Consequently, inline replies are not allowed if the EditAllowed element is set to FALSE. When EditAllowed is set to FALSE and ReplaceMime is not present in a SmartForward or SmartReply request, the server will add the original rights-managed email message as an attachment to the new message. Conversely, if composemail:ReplaceMime is present, the server will not attach the original rights-managed email message as an attachment.
ExportAllowed | Specifies whether the IRM protection on the e-mail message can be removed by the user. The value is TRUE if the user can remove the IRM protection when the user forwards, replies, or replies all to the e-mail message; otherwise, FALSE. If a rights-managed email message is forwarded or replied to using the SmartForward or SmartReply command, the following conditions are evaluated: - The original rights policy template has the ExportAllowed element set to TRUE - The TemplateID on the new message is set to the "No Restriction" template (TemplateID value "00000000-0000-0000-0000-000000000000") If both of the conditions are true, the IRM protection is removed from the outgoing message. The original message retains its IRM protection.
ExtractAllowed | Specifies whether the user can copy content out of the e-mail message. The value is TRUE if the content of the e-mail message can be cut, copied, or a screen capture can be taken of the content; otherwise, FALSE.
ForwardAllowed | Specifies whether the user can forward the e-mail message. The value is TRUE if the user can forward the e-mail message; otherwise, FALSE.
ModifyRecipientsAllowed | Specifies whether the user can modify the recipient list when the user forwards, or replies to the e-mail message. The value is TRUE if the user can modify the recipient (1) list; otherwise, FALSE.
Owner | Specifies whether the user is the owner of the e-mail message. The value is TRUE if the user is the owner of the e-mail message; otherwise, FALSE. A value of TRUE indicates that the authenticated user has owner rights on this message. This element is used for information presentation purposes only. The Allowed elements (EditAllowed, ReplyAllowed, etc.) are used to evaluate whether a particular action is permitted or restricted.
PrintAllowed | Specifies whether the e-mail can be printed by the user. This element does not indicate client support for printing an e-mail message; it only specifies whether the e-mail message can be printed if the client supports printing. The value is TRUE if the e-mail can be printed by the user; otherwise, FALSE.
ProgrammaticAccessAllowed | Specifies whether the contents of the e-mail message can be accessed programmatically by third party applications. The value is TRUE if third party applications can access the content of the e-mail message programmatically; otherwise, FALSE. A value of TRUE indicates whether the protected content is accessible by other applications. Protected content consists of the message body and attachments.
ReplyAllAllowed | Specifies whether the user can reply to all of the recipients (1) of the original e-mail message. The value is TRUE if the user can reply to all of the recipients of the e-mail message; otherwise, FALSE.
ReplyAllowed | Specifies whether the user is allowed to reply to the e-mail message. The value is TRUE if the user can reply to the e-mail message; otherwise, FALSE.
TemplateDescription | Contains a description of the rights policy template represented by the parent RightsManagementLicense element. This element is used for informational presentation purposes only. The maximum length of the TemplateDescription element is 10240 characters.
TemplateID | Contains a string that identifies the rights policy template represented by the parent RightsManagementLicense element.
TemplateName | Specifies the name of the rights policy template represented by the parent RightsManagementLicense element. This element is used for informational presentation purposes only. The maximum length of the TemplateName element is 256 characters.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RightsManagementLicense Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


RightsManagementLicense Constructor

Initializes a new instance of the RightsManagementLicense class.

public RightsManagementLicense();

See Also

RightsManagementLicense Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


RightsManagementLicense Properties

The properties of the RightsManagementLicense class are listed below. For a complete list of RightsManagementLicense class members, see the RightsManagementLicense Members topic.

Public Instance Properties

ContentExpiryDate | Specifies the expiration date for the license. The ContentExpiryDate element is set to "9999-12-30T23:59:59.999Z" if the rights management license has no expiration date set.
ContentOwner | Specifies whether the content of the original email can be modified by the user when the user forwards, replies, or replies all to the email message. The value is TRUE if the e-mail can be modified by the user; otherwise, FALSE. A value of FALSE requires that the client MUST exclude the original rights-managed email message from the SmartForward or SmartReply request. Consequently, inline replies are not allowed if the EditAllowed element is set to FALSE. When EditAllowed is set to FALSE and ReplaceMime is not present in a SmartForward or SmartReply request, the server will add the original rights-managed email message as an attachment to the new message. Conversely, if ReplaceMime is present, the server will not attach the original rights-managed email message as an attachment.
EditAllowed | Specifies whether the content of the original email can be modified by the user when the user forwards, replies, or replies all to the email message. The value is TRUE if the e-mail can be modified by the user; otherwise, FALSE. A value of FALSE requires that the client MUST exclude the original rights-managed email message from the SmartForward or SmartReply request. Consequently, inline replies are not allowed if the EditAllowed element is set to FALSE. When EditAllowed is set to FALSE and ReplaceMime is not present in a SmartForward or SmartReply request, the server will add the original rights-managed email message as an attachment to the new message. Conversely, if composemail:ReplaceMime is present, the server will not attach the original rights-managed email message as an attachment.
ExportAllowed | Specifies whether the IRM protection on the e-mail message can be removed by the user. The value is TRUE if the user can remove the IRM protection when the user forwards, replies, or replies all to the e-mail message; otherwise, FALSE. If a rights-managed email message is forwarded or replied to using the SmartForward or SmartReply command, the following conditions are evaluated: - The original rights policy template has the ExportAllowed element set to TRUE - The TemplateID on the new message is set to the "No Restriction" template (TemplateID value "00000000-0000-0000-0000-000000000000") If both of the conditions are true, the IRM protection is removed from the outgoing message. The original message retains its IRM protection.
ExtractAllowed | Specifies whether the user can copy content out of the e-mail message. The value is TRUE if the content of the e-mail message can be cut, copied, or a screen capture can be taken of the content; otherwise, FALSE.
ForwardAllowed | Specifies whether the user can forward the e-mail message. The value is TRUE if the user can forward the e-mail message; otherwise, FALSE.
ModifyRecipientsAllowed | Specifies whether the user can modify the recipient list when the user forwards, or replies to the e-mail message. The value is TRUE if the user can modify the recipient (1) list; otherwise, FALSE.
Owner | Specifies whether the user is the owner of the e-mail message. The value is TRUE if the user is the owner of the e-mail message; otherwise, FALSE. A value of TRUE indicates that the authenticated user has owner rights on this message. This element is used for information presentation purposes only. The Allowed elements (EditAllowed, ReplyAllowed, etc.) are used to evaluate whether a particular action is permitted or restricted.
PrintAllowed | Specifies whether the e-mail can be printed by the user. This element does not indicate client support for printing an e-mail message; it only specifies whether the e-mail message can be printed if the client supports printing. The value is TRUE if the e-mail can be printed by the user; otherwise, FALSE.
ProgrammaticAccessAllowed | Specifies whether the contents of the e-mail message can be accessed programmatically by third party applications. The value is TRUE if third party applications can access the content of the e-mail message programmatically; otherwise, FALSE. A value of TRUE indicates whether the protected content is accessible by other applications. Protected content consists of the message body and attachments.
ReplyAllAllowed | Specifies whether the user can reply to all of the recipients (1) of the original e-mail message. The value is TRUE if the user can reply to all of the recipients of the e-mail message; otherwise, FALSE.
ReplyAllowed | Specifies whether the user is allowed to reply to the e-mail message. The value is TRUE if the user can reply to the e-mail message; otherwise, FALSE.
TemplateDescription | Contains a description of the rights policy template represented by the parent RightsManagementLicense element. This element is used for informational presentation purposes only. The maximum length of the TemplateDescription element is 10240 characters.
TemplateID | Contains a string that identifies the rights policy template represented by the parent RightsManagementLicense element.
TemplateName | Specifies the name of the rights policy template represented by the parent RightsManagementLicense element. This element is used for informational presentation purposes only. The maximum length of the TemplateName element is 256 characters.

See Also

RightsManagementLicense Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ContentExpiryDate Property

Aspose.Email

RightsManagementLicense.ContentExpiryDate Property

Specifies the expiration date for the license. The ContentExpiryDate element is set to "9999-12-30T23:59:59.999Z" if the rights management license has no expiration date set.

public DateTime ContentExpiryDate {get; set;}

See Also

RightsManagementLicense Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ContentOwner Property

Aspose.Email

RightsManagementLicense.ContentOwner Property

Specifies whether the content of the original email can be modified by the user when the user forwards, replies, or replies all to the email message. The value is TRUE if the e-mail can be modified by the user; otherwise, FALSE. A value of FALSE requires that the client MUST exclude the original rights-managed email message from the SmartForward or SmartReply request. Consequently, inline replies are not allowed if the EditAllowed element is set to FALSE. When EditAllowed is set to FALSE and ReplaceMime is not present in a SmartForward or SmartReply request, the server will add the original rights-managed email message as an attachment to the new message. Conversely, if ReplaceMime is present, the server will not attach the original rights-managed email message as an attachment.

public bool ContentOwner {get; set;}

See Also

RightsManagementLicense Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


EditAllowed Property

Aspose.Email

RightsManagementLicense.EditAllowed Property

Specifies whether the content of the original email can be modified by the user when the user forwards, replies, or replies all to the email message. The value is TRUE if the e-mail can be modified by the user; otherwise, FALSE. A value of FALSE requires that the client MUST exclude the original rights-managed email message from the SmartForward or SmartReply request. Consequently, inline replies are not allowed if the EditAllowed element is set to FALSE. When EditAllowed is set to FALSE and ReplaceMime is not present in a SmartForward or SmartReply request, the server will add the original rights-managed email message as an attachment to the new message. Conversely, if composemail:ReplaceMime is present, the server will not attach the original rights-managed email message as an attachment.

public bool EditAllowed {get; set;}

See Also

RightsManagementLicense Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ExportAllowed Property

Aspose.Email

RightsManagementLicense.ExportAllowed Property

Specifies whether the IRM protection on the e-mail message can be removed by the user. The value is TRUE if the user can remove the IRM protection when the user forwards, replies, or replies all to the e-mail message; otherwise, FALSE. If a rights-managed email message is forwarded or replied to using the SmartForward or SmartReply command, the following conditions are evaluated: - The original rights policy template has the ExportAllowed element set to TRUE - The TemplateID on the new message is set to the "No Restriction" template (TemplateID value "00000000-0000-0000-0000-000000000000") If both of the conditions are true, the IRM protection is removed from the outgoing message. The original message retains its IRM protection.

public bool ExportAllowed {get; set;}

See Also

RightsManagementLicense Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ExtractAllowed Property

Aspose.Email

RightsManagementLicense.ExtractAllowed Property

Specifies whether the user can copy content out of the e-mail message. The value is TRUE if the content of the e-mail message can be cut, copied, or a screen capture can be taken of the content; otherwise, FALSE.

public bool ExtractAllowed {get; set;}

See Also

RightsManagementLicense Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ForwardAllowed Property

Aspose.Email

RightsManagementLicense.ForwardAllowed Property

Specifies whether the user can forward the e-mail message. The value is TRUE if the user can forward the e-mail message; otherwise, FALSE.

public bool ForwardAllowed {get; set;}

See Also

RightsManagementLicense Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ModifyRecipientsAllowed Property

Aspose.Email

RightsManagementLicense.ModifyRecipientsAllowed Property

Specifies whether the user can modify the recipient list when the user forwards, or replies to the e-mail message. The value is TRUE if the user can modify the recipient (1) list; otherwise, FALSE.

public bool ModifyRecipientsAllowed {get; set;}

See Also

RightsManagementLicense Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Owner Property

Aspose.Email

RightsManagementLicense.Owner Property

Specifies whether the user is the owner of the e-mail message. The value is TRUE if the user is the owner of the e-mail message; otherwise, FALSE. A value of TRUE indicates that the authenticated user has owner rights on this message. This element is used for information presentation purposes only. The Allowed elements (EditAllowed, ReplyAllowed, etc.) are used to evaluate whether a particular action is permitted or restricted.

public bool Owner {get; set;}

See Also

RightsManagementLicense Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


PrintAllowed Property

Aspose.Email

RightsManagementLicense.PrintAllowed Property

Specifies whether the e-mail can be printed by the user. This element does not indicate client support for printing an e-mail message; it only specifies whether the e-mail message can be printed if the client supports printing. The value is TRUE if the e-mail can be printed by the user; otherwise, FALSE.

public bool PrintAllowed {get; set;}

See Also

RightsManagementLicense Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ProgrammaticAccessAllowed Property

Aspose.Email

RightsManagementLicense.ProgrammaticAccessAllowed Property

Specifies whether the contents of the e-mail message can be accessed programmatically by third party applications. The value is TRUE if third party applications can access the content of the e-mail message programmatically; otherwise, FALSE. A value of TRUE indicates whether the protected content is accessible by other applications. Protected content consists of the message body and attachments.

public bool ProgrammaticAccessAllowed {get; set;}

See Also

RightsManagementLicense Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ReplyAllAllowed Property

Aspose.Email

RightsManagementLicense.ReplyAllAllowed Property

Specifies whether the user can reply to all of the recipients (1) of the original e-mail message. The value is TRUE if the user can reply to all of the recipients of the e-mail message; otherwise, FALSE.

public bool ReplyAllAllowed {get; set;}

See Also

RightsManagementLicense Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ReplyAllowed Property

Aspose.Email

RightsManagementLicense.ReplyAllowed Property

Specifies whether the user is allowed to reply to the e-mail message. The value is TRUE if the user can reply to the e-mail message; otherwise, FALSE.

public bool ReplyAllowed {get; set;}

See Also

RightsManagementLicense Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


TemplateDescription Property

Aspose.Email

RightsManagementLicense.TemplateDescription Property

Contains a description of the rights policy template represented by the parent RightsManagementLicense element. This element is used for informational presentation purposes only. The maximum length of the TemplateDescription element is 10240 characters.

public string TemplateDescription {get; set;}

See Also

RightsManagementLicense Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


TemplateID Property

Aspose.Email

RightsManagementLicense.TemplateID Property

Contains a string that identifies the rights policy template represented by the parent RightsManagementLicense element.

public string TemplateID {get; set;}

See Also

RightsManagementLicense Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


TemplateName Property

Aspose.Email

RightsManagementLicense.TemplateName Property

Specifies the name of the rights policy template represented by the parent RightsManagementLicense element. This element is used for informational presentation purposes only. The maximum length of the TemplateName element is 256 characters.

public string TemplateName {get; set;}

See Also

RightsManagementLicense Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


RightsManagementTemplate Class

Contains the template identifier, name, and description of a rights policy template available on the client.

For a list of all members of this type, see RightsManagementTemplate Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.RightsManagementTemplate

public class RightsManagementTemplate

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RightsManagementTemplate Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


RightsManagementTemplate Members

RightsManagementTemplate overview

Public Instance Constructors

RightsManagementTemplate Overloaded. Initializes a new instance of the RightsManagementTemplate class.

Public Instance Properties

TemplateDescription | Template description
TemplateID | Template identifier
TemplateName | Template name

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RightsManagementTemplate Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


RightsManagementTemplate Constructor

Initializes a new instance of the RightsManagementTemplate class.

Overload List

Initializes a new instance of the RightsManagementTemplate class.

public RightsManagementTemplate();

Initializes a new instance of the RightsManagementTemplate class.

public RightsManagementTemplate(string,string,string);

See Also

RightsManagementTemplate Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


RightsManagementTemplate Constructor ()

Initializes a new instance of the RightsManagementTemplate class.

public RightsManagementTemplate();

See Also

RightsManagementTemplate Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | RightsManagementTemplate Constructor Overload List


RightsManagementTemplate Constructor (String, String, String)

Initializes a new instance of the RightsManagementTemplate class.

public RightsManagementTemplate(
string templateID,
string templateName,
string templateDescription
);

Parameters

templateID
Template identifier
templateName
Template name
templateDescription
Template description

See Also

RightsManagementTemplate Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | RightsManagementTemplate Constructor Overload List


RightsManagementTemplate Properties

The properties of the RightsManagementTemplate class are listed below. For a complete list of RightsManagementTemplate class members, see the RightsManagementTemplate Members topic.

Public Instance Properties

TemplateDescription | Template description
TemplateID | Template identifier
TemplateName | Template name

See Also

RightsManagementTemplate Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


TemplateDescription Property

Aspose.Email

RightsManagementTemplate.TemplateDescription Property

Template description

public string TemplateDescription {get; set;}

See Also

RightsManagementTemplate Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


TemplateID Property

Aspose.Email

RightsManagementTemplate.TemplateID Property

Template identifier

public string TemplateID {get; set;}

See Also

RightsManagementTemplate Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


TemplateName Property

Aspose.Email

RightsManagementTemplate.TemplateName Property

Template name

public string TemplateName {get; set;}

See Also

RightsManagementTemplate Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SearchCondition Class

Specifies a condition for search requests

For a list of all members of this type, see SearchCondition Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.SearchCondition

public class SearchCondition

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SearchCondition Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SearchCondition Members

SearchCondition overview

Public Instance Constructors

SearchCondition Constructor Initializes a new instance of the SearchCondition class.

Public Instance Properties

Value String value of condition

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SearchCondition Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SearchCondition Constructor

Initializes a new instance of the SearchCondition class.

public SearchCondition();

See Also

SearchCondition Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SearchCondition Properties

The properties of the SearchCondition class are listed below. For a complete list of SearchCondition class members, see the SearchCondition Members topic.

Public Instance Properties

Value String value of condition

See Also

SearchCondition Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Value Property

Aspose.Email

SearchCondition.Value Property

String value of condition

public string Value {get; set;}

See Also

SearchCondition Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SearchOptions Class

Contains the search options. The UserName and Password can only be sent in the request after receiving a Status value of 14. The server requires these credentials to access the requested resources. The client MUST only send these over a secure or trusted connection, and only in response to a Status value of 14. The supported options vary according to the store that is being searched. The following table lists the valid options for each store. GAL: Range, UserName, Password, Picture Mailbox: Range, DeepTraversal, RebuildResults, BodyPreference, BodyPartPreference, RightsManagementSupport DocumentLibrary: Range, UserName, Password The BodyPartPreference is only valid in Search command requests that include a ConversationId.

For a list of all members of this type, see SearchOptions Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.SearchOptions

public class SearchOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SearchOptions Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SearchOptions Members

SearchOptions overview

Public Instance Constructors

SearchOptions Constructor Initializes a new instance of the SearchOptions class.

Public Instance Properties

BodyPartPreference | Contains preference information related to the type and size of information that is returned from searching, synchronizing, or fetching a message part.
BodyPreference | Contains preference information related to the type and size of information that is returned from searching, synchronizing, or fetching.
DeepTraversal | Indicates that the client wants the server to search all subfolders for the folders that are specified in the query.
MIMESupport | Enables MIME support for email items that are sent from the server to the client. If the airsync:MIMESupport element is set to 'SendForSecureMIMEonly' (1) or 'SendForAll' (2) in the Search request: - The property of the airsyncbase:BodyPreference, the Type, SHOULD be included in the Search request, containing a value of 'MIME' (4) to inform the server that the device can read the MIME BLOB. - The response from the server MUST include the airsyncbase:Body, which is a child of the Properties. The airsyncbase:Body MUST contain the following properties in an S/MIME Search response: - The airsyncbase:Type with a value of 'MIME' (4) to inform the device that the data is a MIME BLOB. - The airsyncbase:EstimatedDataSize to specify the rough total size of the data. - The airsyncbase:Truncated to indicate whether the MIME BLOB is truncated. - The airsyncbase:Data that contains the full MIME BLOB.
Password | Specifies the password for the given UserName. The value of the Password has a maximum length of 100 characters.
Picture | Contains the data related to the photos request. The Picture is not supported when the protocol version is 12.1 or 14.0.
Range | Specifies the maximum number of matching entries to return. The format of the Range element value is in the form of a zero-based index specifier, formed with a zero, a hyphen, and another numeric value: "m-n." The m indicates the lowest index of a zero-based array that would hold the items. The n indicates the highest index of a zero-based array that would hold the items. For example, a Range element value of 0–9 indicates 10 items, and 0–10 indicates 11 items. A Range element value of 0–0 indicates 1 item. If Range is null, the default Range value for each Store type is used. The following table identifies the default Range values and maximum results returned for each Store type: Mailbox - Default range value: 0-99 - Maximum results returned: 100 DocumentLibrary - Default range value: 0-999 - Maximum results returned: 1000 GAL - Default range value: 0-99 - Maximum results returned: 100 If the Range value specified in the request exceeds the default range value, a Status value of 12 is returned to indicate that the maximum range has been exceeded. In the Search command response, the Total property indicates an estimate of the total number of entries that matched the Query value. Search results are stored in a search folder on the server. This way, when a client comes back with the same query but a new row range, rows are pulled from the result set that is currently stored in the search folder. The entire result set does not have to be rebuilt.
RebuildResults | Forces the server to rebuild the search folder (2) that corresponds to a given query. The search results (that is, the result set) are stored in a search folder on the server. This way, when a client comes back with the same query but a new row range, rows are pulled from the result set that is currently stored in the search folder. The entire result set does not have to be rebuilt. The search folder remains unchanged until the client does one of the following to update the result set: - Sends a Search request, specifying a new query. In this case, the search folder is automatically rebuilt. The RebuildResults node does not have to be included. - Sends a Search request that includes the RebuildResults node. In this case, the server is forced to rebuild the search folder. If a new item is added, the item does not appear in the result set until the result set is updated. If an item is deleted, the server will filter the deleted item out of the result set. The client SHOULD send a new Search request with the given query and include the RebuildResults option every few days to ensure accurate results for that query.
RightsManagementSupport | Specifies how the server returns rights-managed email messages to the client. If the value is TRUE, the server will decompress and decrypt rights-managed email messages before sending them to the client. If the value is FALSE, the server will not decompress or decrypt rights-managed email messages before sending them to the client. If the RightsManagementSupport element is not included in a request message, a default value of FALSE is assumed.
UserName | Specifies the user account used to search the document from the document library. The UserName value can be up to 100 characters in length.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SearchOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SearchOptions Constructor

Initializes a new instance of the SearchOptions class.

public SearchOptions();

See Also

SearchOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SearchOptions Properties

The properties of the SearchOptions class are listed below. For a complete list of SearchOptions class members, see the SearchOptions Members topic.

Public Instance Properties

BodyPartPreference | Contains preference information related to the type and size of information that is returned from searching, synchronizing, or fetching a message part.
BodyPreference | Contains preference information related to the type and size of information that is returned from searching, synchronizing, or fetching.
DeepTraversal | Indicates that the client wants the server to search all subfolders for the folders that are specified in the query.
MIMESupport | Enables MIME support for email items that are sent from the server to the client. If the airsync:MIMESupport element is set to 'SendForSecureMIMEonly' (1) or 'SendForAll' (2) in the Search request: - The property of the airsyncbase:BodyPreference, the Type, SHOULD be included in the Search request, containing a value of 'MIME' (4) to inform the server that the device can read the MIME BLOB. - The response from the server MUST include the airsyncbase:Body, which is a child of the Properties. The airsyncbase:Body MUST contain the following properties in an S/MIME Search response: - The airsyncbase:Type with a value of 'MIME' (4) to inform the device that the data is a MIME BLOB. - The airsyncbase:EstimatedDataSize to specify the rough total size of the data. - The airsyncbase:Truncated to indicate whether the MIME BLOB is truncated. - The airsyncbase:Data that contains the full MIME BLOB.
Password | Specifies the password for the given UserName. The value of the Password has a maximum length of 100 characters.
Picture | Contains the data related to the photos request. The Picture is not supported when the protocol version is 12.1 or 14.0.
Range | Specifies the maximum number of matching entries to return. The format of the Range element value is in the form of a zero-based index specifier, formed with a zero, a hyphen, and another numeric value: "m-n." The m indicates the lowest index of a zero-based array that would hold the items. The n indicates the highest index of a zero-based array that would hold the items. For example, a Range element value of 0–9 indicates 10 items, and 0–10 indicates 11 items. A Range element value of 0–0 indicates 1 item. If Range is null, the default Range value for each Store type is used. The following table identifies the default Range values and maximum results returned for each Store type: Mailbox - Default range value: 0-99 - Maximum results returned: 100 DocumentLibrary - Default range value: 0-999 - Maximum results returned: 1000 GAL - Default range value: 0-99 - Maximum results returned: 100 If the Range value specified in the request exceeds the default range value, a Status value of 12 is returned to indicate that the maximum range has been exceeded. In the Search command response, the Total property indicates an estimate of the total number of entries that matched the Query value. Search results are stored in a search folder on the server. This way, when a client comes back with the same query but a new row range, rows are pulled from the result set that is currently stored in the search folder. The entire result set does not have to be rebuilt.
RebuildResults | Forces the server to rebuild the search folder (2) that corresponds to a given query. The search results (that is, the result set) are stored in a search folder on the server. This way, when a client comes back with the same query but a new row range, rows are pulled from the result set that is currently stored in the search folder. The entire result set does not have to be rebuilt. The search folder remains unchanged until the client does one of the following to update the result set: - Sends a Search request, specifying a new query. In this case, the search folder is automatically rebuilt. The RebuildResults node does not have to be included. - Sends a Search request that includes the RebuildResults node. In this case, the server is forced to rebuild the search folder. If a new item is added, the item does not appear in the result set until the result set is updated. If an item is deleted, the server will filter the deleted item out of the result set. The client SHOULD send a new Search request with the given query and include the RebuildResults option every few days to ensure accurate results for that query.
RightsManagementSupport | Specifies how the server returns rights-managed email messages to the client. If the value is TRUE, the server will decompress and decrypt rights-managed email messages before sending them to the client. If the value is FALSE, the server will not decompress or decrypt rights-managed email messages before sending them to the client. If the RightsManagementSupport element is not included in a request message, a default value of FALSE is assumed.
UserName | Specifies the user account used to search the document from the document library. The UserName value can be up to 100 characters in length.

See Also

SearchOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


BodyPartPreference Property

Aspose.Email

SearchOptions.BodyPartPreference Property

Contains preference information related to the type and size of information that is returned from searching, synchronizing, or fetching a message part.

public BodyPreference} BodyPartPreference {get;}

See Also

SearchOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


BodyPreference Property

Aspose.Email

SearchOptions.BodyPreference Property

Contains preference information related to the type and size of information that is returned from searching, synchronizing, or fetching.

public BodyPreference} BodyPreference {get;}

See Also

SearchOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


DeepTraversal Property

Aspose.Email

SearchOptions.DeepTraversal Property

Indicates that the client wants the server to search all subfolders for the folders that are specified in the query.

public bool DeepTraversal {get; set;}

See Also

SearchOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


MIMESupport Property

Aspose.Email

SearchOptions.MIMESupport Property

Enables MIME support for email items that are sent from the server to the client. If the airsync:MIMESupport element is set to 'SendForSecureMIMEonly' (1) or 'SendForAll' (2) in the Search request: - The property of the airsyncbase:BodyPreference, the Type, SHOULD be included in the Search request, containing a value of 'MIME' (4) to inform the server that the device can read the MIME BLOB. - The response from the server MUST include the airsyncbase:Body, which is a child of the Properties. The airsyncbase:Body MUST contain the following properties in an S/MIME Search response: - The airsyncbase:Type with a value of 'MIME' (4) to inform the device that the data is a MIME BLOB. - The airsyncbase:EstimatedDataSize to specify the rough total size of the data. - The airsyncbase:Truncated to indicate whether the MIME BLOB is truncated. - The airsyncbase:Data that contains the full MIME BLOB.

public MIMESupport} MIMESupport {get; set;}

See Also

SearchOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Password Property

Aspose.Email

SearchOptions.Password Property

Specifies the password for the given UserName. The value of the Password has a maximum length of 100 characters.

public string Password {get; set;}

See Also

SearchOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Picture Property

Aspose.Email

SearchOptions.Picture Property

Contains the data related to the photos request. The Picture is not supported when the protocol version is 12.1 or 14.0.

public PictureRequest Picture {get; set;}

See Also

SearchOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Range Property

Aspose.Email

SearchOptions.Range Property

Specifies the maximum number of matching entries to return. The format of the Range element value is in the form of a zero-based index specifier, formed with a zero, a hyphen, and another numeric value: "m-n." The m indicates the lowest index of a zero-based array that would hold the items. The n indicates the highest index of a zero-based array that would hold the items. For example, a Range element value of 0–9 indicates 10 items, and 0–10 indicates 11 items. A Range element value of 0–0 indicates 1 item. If Range is null, the default Range value for each Store type is used. The following table identifies the default Range values and maximum results returned for each Store type: Mailbox - Default range value: 0-99 - Maximum results returned: 100 DocumentLibrary - Default range value: 0-999 - Maximum results returned: 1000 GAL - Default range value: 0-99 - Maximum results returned: 100 If the Range value specified in the request exceeds the default range value, a Status value of 12 is returned to indicate that the maximum range has been exceeded. In the Search command response, the Total property indicates an estimate of the total number of entries that matched the Query value. Search results are stored in a search folder on the server. This way, when a client comes back with the same query but a new row range, rows are pulled from the result set that is currently stored in the search folder. The entire result set does not have to be rebuilt.

public string Range {get; set;}

See Also

SearchOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


RebuildResults Property

Aspose.Email

SearchOptions.RebuildResults Property

Forces the server to rebuild the search folder (2) that corresponds to a given query. The search results (that is, the result set) are stored in a search folder on the server. This way, when a client comes back with the same query but a new row range, rows are pulled from the result set that is currently stored in the search folder. The entire result set does not have to be rebuilt. The search folder remains unchanged until the client does one of the following to update the result set: - Sends a Search request, specifying a new query. In this case, the search folder is automatically rebuilt. The RebuildResults node does not have to be included. - Sends a Search request that includes the RebuildResults node. In this case, the server is forced to rebuild the search folder. If a new item is added, the item does not appear in the result set until the result set is updated. If an item is deleted, the server will filter the deleted item out of the result set. The client SHOULD send a new Search request with the given query and include the RebuildResults option every few days to ensure accurate results for that query.

public bool RebuildResults {get; set;}

See Also

SearchOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


RightsManagementSupport Property

Aspose.Email

SearchOptions.RightsManagementSupport Property

Specifies how the server returns rights-managed email messages to the client. If the value is TRUE, the server will decompress and decrypt rights-managed email messages before sending them to the client. If the value is FALSE, the server will not decompress or decrypt rights-managed email messages before sending them to the client. If the RightsManagementSupport element is not included in a request message, a default value of FALSE is assumed.

public Boolean} RightsManagementSupport {get; set;}

See Also

SearchOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


UserName Property

Aspose.Email

SearchOptions.UserName Property

Specifies the user account used to search the document from the document library. The UserName value can be up to 100 characters in length.

public string UserName {get; set;}

See Also

SearchOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SearchQuery Class

Specifies the keywords to use for matching the entries in the store that is being searched. The value of the Query is used as a prefix-string matching pattern, and returns entries that match the beginning of the string. For example, searching for "John" would match "John Frum" or "Barry Johnson", but would not match "James Littlejohn". All nonempty text properties in the GAL that are indexed by using ANR are compared with the Query element value. Search comparisons are performed by using case-insensitive matching. For a Windows SharePoint Services document library search, this protocol supports queries of the following form: LinkId == value, where value specifies the URL of the item or folder and LinkId indicates that the value is to be compared to the link ID property. For mailbox search, the query syntax is as follows: - Folders can be specified in the following ways: Specified ID Specified folder and subfolders All email folders, including Draft, Inbox and subfolders, Outbox, and Sent Items - The basic keyword query can be composed of the following: The basic operator: And (section 2.2.3.10) A dateTime filter specified by using the GreaterThan (section 2.2.3.78) and LessThan elements (section 2.2.3.87) FreeText elements (section 2.2.3.73) that contain keywords The basic keyword query is executed against all indexed properties.

For a list of all members of this type, see SearchQuery Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.SearchQuery

public class SearchQuery

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SearchQuery Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SearchQuery Members

SearchQuery overview

Public Instance Constructors

SearchQuery Constructor Initializes a new instance of the SearchQuery class.

Public Instance Properties

And | Specifies the keywords to use for matching the entries in the store that is being searched.
EqualTo | Specifies a property and a value that are compared for a "Equal To" condition during a search.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SearchQuery Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SearchQuery Constructor

Initializes a new instance of the SearchQuery class.

public SearchQuery();

See Also

SearchQuery Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SearchQuery Properties

The properties of the SearchQuery class are listed below. For a complete list of SearchQuery class members, see the SearchQuery Members topic.

Public Instance Properties

And | Specifies the keywords to use for matching the entries in the store that is being searched.
EqualTo | Specifies a property and a value that are compared for a "Equal To" condition during a search.

See Also

SearchQuery Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


And Property

Aspose.Email

SearchQuery.And Property

Specifies the keywords to use for matching the entries in the store that is being searched.

public QueryType And {get; set;}

See Also

SearchQuery Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


EqualTo Property

Aspose.Email

SearchQuery.EqualTo Property

Specifies a property and a value that are compared for a "Equal To" condition during a search.

public SearchCondition EqualTo {get; set;}

See Also

SearchQuery Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SearchRequest Class

Contains search request information

For a list of all members of this type, see SearchRequest Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.SearchRequest

public class SearchRequest

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SearchRequest Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SearchRequest Members

SearchRequest overview

Public Instance Constructors

SearchRequest Constructor Initializes a new instance of the SearchRequest class.

Public Instance Properties

Store Specify the location, name, and options for the search.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SearchRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SearchRequest Constructor

Initializes a new instance of the SearchRequest class.

public SearchRequest();

See Also

SearchRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SearchRequest Properties

The properties of the SearchRequest class are listed below. For a complete list of SearchRequest class members, see the SearchRequest Members topic.

Public Instance Properties

Store Specify the location, name, and options for the search.

See Also

SearchRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Store Property

Aspose.Email

SearchRequest.Store Property

Specify the location, name, and options for the search.

public SearchRequestStore Store {get; set;}

See Also

SearchRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SearchRequestStore Class

Specify the name, query and options for the search.

For a list of all members of this type, see SearchRequestStore Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.SearchRequestStore

public class SearchRequestStore

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SearchRequestStore Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SearchRequestStore Members

SearchRequestStore overview

Public Instance Constructors

SearchRequestStore Constructor Initializes a new instance of the SearchRequestStore class.

Public Instance Properties

Name | Contains infarmation that specify the location, for the operations.
Options | Contains the search options. The UserName and Password can only be sent in the request after receiving a Status value of 14. The server requires these credentials to access the requested resources. The client MUST only send these over a secure or trusted connection, and only in response to a Status value of 14. The supported options vary according to the store that is being searched. The following table lists the valid options for each store. GAL: Range, UserName, Password, Picture Mailbox: Range, DeepTraversal, RebuildResults, BodyPreference, BodyPartPreference, RightsManagementSupport DocumentLibrary: Range, UserName, Password The BodyPartPreference is only valid in Search command requests that include a ConversationId.
Query | Specifies the keywords to use for matching the entries in the store that is being searched. The value of the Query is used as a prefix-string matching pattern, and returns entries that match the beginning of the string. For example, searching for "John" would match "John Frum" or "Barry Johnson", but would not match "James Littlejohn". All nonempty text properties in the GAL that are indexed by using ANR are compared with the Query element value. Search comparisons are performed by using case-insensitive matching. For a Windows SharePoint Services document library search, this protocol supports queries of the following form: LinkId == value, where value specifies the URL of the item or folder and LinkId indicates that the value is to be compared to the link ID property. For mailbox search, the query syntax is as follows: - Folders can be specified in the following ways: Specified ID Specified folder and subfolders All email folders, including Draft, Inbox and subfolders, Outbox, and Sent Items - The basic keyword query can be composed of the following: The basic operator: And (section 2.2.3.10) A dateTime filter specified by using the GreaterThan (section 2.2.3.78) and LessThan elements (section 2.2.3.87) FreeText elements (section 2.2.3.73) that contain keywords The basic keyword query is executed against all indexed properties.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SearchRequestStore Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SearchRequestStore Constructor

Initializes a new instance of the SearchRequestStore class.

public SearchRequestStore();

See Also

SearchRequestStore Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SearchRequestStore Properties

The properties of the SearchRequestStore class are listed below. For a complete list of SearchRequestStore class members, see the SearchRequestStore Members topic.

Public Instance Properties

Name | Contains infarmation that specify the location, for the operations.
Options | Contains the search options. The UserName and Password can only be sent in the request after receiving a Status value of 14. The server requires these credentials to access the requested resources. The client MUST only send these over a secure or trusted connection, and only in response to a Status value of 14. The supported options vary according to the store that is being searched. The following table lists the valid options for each store. GAL: Range, UserName, Password, Picture Mailbox: Range, DeepTraversal, RebuildResults, BodyPreference, BodyPartPreference, RightsManagementSupport DocumentLibrary: Range, UserName, Password The BodyPartPreference is only valid in Search command requests that include a ConversationId.
Query | Specifies the keywords to use for matching the entries in the store that is being searched. The value of the Query is used as a prefix-string matching pattern, and returns entries that match the beginning of the string. For example, searching for "John" would match "John Frum" or "Barry Johnson", but would not match "James Littlejohn". All nonempty text properties in the GAL that are indexed by using ANR are compared with the Query element value. Search comparisons are performed by using case-insensitive matching. For a Windows SharePoint Services document library search, this protocol supports queries of the following form: LinkId == value, where value specifies the URL of the item or folder and LinkId indicates that the value is to be compared to the link ID property. For mailbox search, the query syntax is as follows: - Folders can be specified in the following ways: Specified ID Specified folder and subfolders All email folders, including Draft, Inbox and subfolders, Outbox, and Sent Items - The basic keyword query can be composed of the following: The basic operator: And (section 2.2.3.10) A dateTime filter specified by using the GreaterThan (section 2.2.3.78) and LessThan elements (section 2.2.3.87) FreeText elements (section 2.2.3.73) that contain keywords The basic keyword query is executed against all indexed properties.

See Also

SearchRequestStore Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Name Property

Aspose.Email

SearchRequestStore.Name Property

Contains infarmation that specify the location, for the operations.

public StoreType Name {get; set;}

See Also

SearchRequestStore Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Options Property

Aspose.Email

SearchRequestStore.Options Property

Contains the search options. The UserName and Password can only be sent in the request after receiving a Status value of 14. The server requires these credentials to access the requested resources. The client MUST only send these over a secure or trusted connection, and only in response to a Status value of 14. The supported options vary according to the store that is being searched. The following table lists the valid options for each store. GAL: Range, UserName, Password, Picture Mailbox: Range, DeepTraversal, RebuildResults, BodyPreference, BodyPartPreference, RightsManagementSupport DocumentLibrary: Range, UserName, Password The BodyPartPreference is only valid in Search command requests that include a ConversationId.

public SearchOptions Options {get; set;}

See Also

SearchRequestStore Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Query Property

Aspose.Email

SearchRequestStore.Query Property

Specifies the keywords to use for matching the entries in the store that is being searched. The value of the Query is used as a prefix-string matching pattern, and returns entries that match the beginning of the string. For example, searching for "John" would match "John Frum" or "Barry Johnson", but would not match "James Littlejohn". All nonempty text properties in the GAL that are indexed by using ANR are compared with the Query element value. Search comparisons are performed by using case-insensitive matching. For a Windows SharePoint Services document library search, this protocol supports queries of the following form: LinkId == value, where value specifies the URL of the item or folder and LinkId indicates that the value is to be compared to the link ID property. For mailbox search, the query syntax is as follows: - Folders can be specified in the following ways: Specified ID Specified folder and subfolders All email folders, including Draft, Inbox and subfolders, Outbox, and Sent Items - The basic keyword query can be composed of the following: The basic operator: And (section 2.2.3.10) A dateTime filter specified by using the GreaterThan (section 2.2.3.78) and LessThan elements (section 2.2.3.87) FreeText elements (section 2.2.3.73) that contain keywords The basic keyword query is executed against all indexed properties.

public SearchQuery Query {get; set;}

See Also

SearchRequestStore Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SearchResponse Class

Contains search response information

For a list of all members of this type, see SearchResponse Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.SearchResponse

public class SearchResponse

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SearchResponse Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SearchResponse Members

SearchResponse overview

Public Instance Constructors

SearchResponse Constructor Initializes a new instance of the SearchResponse class.

Public Instance Properties

Store Contains the Status, Result, Range, and Total elements for the returned mailbox entries.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SearchResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SearchResponse Constructor

Initializes a new instance of the SearchResponse class.

public SearchResponse();

See Also

SearchResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SearchResponse Properties

The properties of the SearchResponse class are listed below. For a complete list of SearchResponse class members, see the SearchResponse Members topic.

Public Instance Properties

Store Contains the Status, Result, Range, and Total elements for the returned mailbox entries.

See Also

SearchResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Store Property

Aspose.Email

SearchResponse.Store Property

Contains the Status, Result, Range, and Total elements for the returned mailbox entries.

public SearchResponseStore Store {get; set;}

See Also

SearchResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SearchResponseStore Class

Contains the Status, Result, Range, and Total elements for the returned mailbox entries.

For a list of all members of this type, see SearchResponseStore Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.SearchResponseStore

public class SearchResponseStore

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SearchResponseStore Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SearchResponseStore Members

SearchResponseStore overview

Public Instance Constructors

SearchResponseStore Constructor Initializes a new instance of the SearchResponseStore class.

Public Instance Properties

Range | Specifies the number of matching entries that are being returned. The format of the Range element value is in the form of a zero-based index specifier, formed with a zero, a hyphen, and another numeric value: "m-n." The m indicates the lowest index of a zero-based array that would hold the items. The n indicates the highest index of a zero-based array that would hold the items. For example, a Range element value of 0–9 indicates 10 items, and 0–10 indicates 11 items. A Range element value of 0–0 indicates 1 item. If Range is null, the default Range value for each Store type is used. The following table identifies the default Range values and maximum results returned for each Store type: Mailbox - Default range value: 0-99 - Maximum results returned: 100 DocumentLibrary - Default range value: 0-999 - Maximum results returned: 1000 GAL - Default range value: 0-99 - Maximum results returned: 100 If the Range value specified in the request exceeds the default range value, a Status value of 12 is returned to indicate that the maximum range has been exceeded. In the Search command response, the Total property indicates an estimate of the total number of entries that matched the Query value. Search results are stored in a search folder on the server. This way, when a client comes back with the same query but a new row range, rows are pulled from the result set that is currently stored in the search folder. The entire result set does not have to be rebuilt.
Result | The list of matched items.
Status | Indicates the result of an operation.
Total | Provides an estimate of the total number of mailbox entries that matched the search Query value. The value of the Total does not always equal the number of entries that are returned. To determine the number of entries that are returned by the Search command, use the Range value. The Total indicates the number of entries that are available. In cases where all the results are returned in the response XML, the value of the Total element is one more than the end-index value that is provided in the Range element. For example, if the Search command returns 15 entries, the value of the Range element is 0–14, while the value of the Total is 15. The Total is used by clients to determine whether more matching entries were found in the mailbox than have been returned by the Search command. For example, a client might perform an initial search and specify a requested Range of 0–4 (return 5 entries maximum). If the Total element indicates that there are actually 25 matching items, the client can then enable the user to retrieve the full results.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SearchResponseStore Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SearchResponseStore Constructor

Initializes a new instance of the SearchResponseStore class.

public SearchResponseStore();

See Also

SearchResponseStore Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SearchResponseStore Properties

The properties of the SearchResponseStore class are listed below. For a complete list of SearchResponseStore class members, see the SearchResponseStore Members topic.

Public Instance Properties

Range | Specifies the number of matching entries that are being returned. The format of the Range element value is in the form of a zero-based index specifier, formed with a zero, a hyphen, and another numeric value: "m-n." The m indicates the lowest index of a zero-based array that would hold the items. The n indicates the highest index of a zero-based array that would hold the items. For example, a Range element value of 0–9 indicates 10 items, and 0–10 indicates 11 items. A Range element value of 0–0 indicates 1 item. If Range is null, the default Range value for each Store type is used. The following table identifies the default Range values and maximum results returned for each Store type: Mailbox - Default range value: 0-99 - Maximum results returned: 100 DocumentLibrary - Default range value: 0-999 - Maximum results returned: 1000 GAL - Default range value: 0-99 - Maximum results returned: 100 If the Range value specified in the request exceeds the default range value, a Status value of 12 is returned to indicate that the maximum range has been exceeded. In the Search command response, the Total property indicates an estimate of the total number of entries that matched the Query value. Search results are stored in a search folder on the server. This way, when a client comes back with the same query but a new row range, rows are pulled from the result set that is currently stored in the search folder. The entire result set does not have to be rebuilt.
Result | The list of matched items.
Status | Indicates the result of an operation.
Total | Provides an estimate of the total number of mailbox entries that matched the search Query value. The value of the Total does not always equal the number of entries that are returned. To determine the number of entries that are returned by the Search command, use the Range value. The Total indicates the number of entries that are available. In cases where all the results are returned in the response XML, the value of the Total element is one more than the end-index value that is provided in the Range element. For example, if the Search command returns 15 entries, the value of the Range element is 0–14, while the value of the Total is 15. The Total is used by clients to determine whether more matching entries were found in the mailbox than have been returned by the Search command. For example, a client might perform an initial search and specify a requested Range of 0–4 (return 5 entries maximum). If the Total element indicates that there are actually 25 matching items, the client can then enable the user to retrieve the full results.

See Also

SearchResponseStore Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Range Property

Aspose.Email

SearchResponseStore.Range Property

Specifies the number of matching entries that are being returned. The format of the Range element value is in the form of a zero-based index specifier, formed with a zero, a hyphen, and another numeric value: "m-n." The m indicates the lowest index of a zero-based array that would hold the items. The n indicates the highest index of a zero-based array that would hold the items. For example, a Range element value of 0–9 indicates 10 items, and 0–10 indicates 11 items. A Range element value of 0–0 indicates 1 item. If Range is null, the default Range value for each Store type is used. The following table identifies the default Range values and maximum results returned for each Store type: Mailbox - Default range value: 0-99 - Maximum results returned: 100 DocumentLibrary - Default range value: 0-999 - Maximum results returned: 1000 GAL - Default range value: 0-99 - Maximum results returned: 100 If the Range value specified in the request exceeds the default range value, a Status value of 12 is returned to indicate that the maximum range has been exceeded. In the Search command response, the Total property indicates an estimate of the total number of entries that matched the Query value. Search results are stored in a search folder on the server. This way, when a client comes back with the same query but a new row range, rows are pulled from the result set that is currently stored in the search folder. The entire result set does not have to be rebuilt.

public string Range {get; set;}

See Also

SearchResponseStore Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Result Property

Aspose.Email

SearchResponseStore.Result Property

The list of matched items.

public SearchResult} Result {get;}

See Also

SearchResponseStore Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Status Property

Aspose.Email

SearchResponseStore.Status Property

Indicates the result of an operation.

public Status Status {get; set;}

See Also

SearchResponseStore Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Total Property

Aspose.Email

SearchResponseStore.Total Property

Provides an estimate of the total number of mailbox entries that matched the search Query value. The value of the Total does not always equal the number of entries that are returned. To determine the number of entries that are returned by the Search command, use the Range value. The Total indicates the number of entries that are available. In cases where all the results are returned in the response XML, the value of the Total element is one more than the end-index value that is provided in the Range element. For example, if the Search command returns 15 entries, the value of the Range element is 0–14, while the value of the Total is 15. The Total is used by clients to determine whether more matching entries were found in the mailbox than have been returned by the Search command. For example, a client might perform an initial search and specify a requested Range of 0–4 (return 5 entries maximum). If the Total element indicates that there are actually 25 matching items, the client can then enable the user to retrieve the full results.

public int Total {get; set;}

See Also

SearchResponseStore Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SearchResult Class

Container for an individual matching mailbox item. When the store that is being searched is the mailbox: - There is one Result element for each match that is found in the mailbox. If no matches are found, an empty Result element is present in the Store container element of the response XML. - Inside the Result element, the Properties element contains a list of requested properties for the mailbox item. When the store that is being searched is the document library: - The first result that is returned in the Search response is the metadata for the Root folder or item to which the LinkId value is pointing. The client can choose to ignore this entry if it does not require it. - If the documentlibrary:LinkId element value in the request points to a folder, the metadata properties of the folder are returned as the first item, and the contents of the folder are returned as subsequent results. The Range applies to these results with no difference; for example, the index 0 would always be for the root item to which the link is pointing. - If the documentlibrary:LinkId element value in the request points to an item, only one result is returned: the metadata for the item. - Inside the Result element, the Properties element contains a list of requested properties for the mailbox item.

For a list of all members of this type, see SearchResult Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.SearchResult

public class SearchResult

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SearchResult Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SearchResult Members

SearchResult overview

Public Instance Constructors

SearchResult Constructor Initializes a new instance of the SearchResult class.

Public Instance Properties

Class | Identifies the class of the item.
CollectionId | Specifies the folders in which the item was found.
LongId | Specifies a unique identifier that is assigned by the server to each result set that is returned. The value of the LongId can be used as the long ID specified in the ItemOperations command request, the SmartReply command request, the SmartForward command request, or the MeetingResponse command request to reference the result set. The client MUST store the value of LongId as an opaque string of up to 256 characters.
Properties | The Search command response Properties is a container for properties that apply to an individual entry that matches the Query element search string. For example, the Properties element contains an element for each nonempty, text-valued GAL property that is attached to the matching GAL entry. Only those properties that are attached to the specific GAL entry are returned; therefore different sets of properties can be returned in the response XML for different matching GAL entries. Each element in the Properties container is scoped to the appropriate namespace that is specified in the top-level Search element.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SearchResult Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SearchResult Constructor

Initializes a new instance of the SearchResult class.

public SearchResult();

See Also

SearchResult Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SearchResult Properties

The properties of the SearchResult class are listed below. For a complete list of SearchResult class members, see the SearchResult Members topic.

Public Instance Properties

Class | Identifies the class of the item.
CollectionId | Specifies the folders in which the item was found.
LongId | Specifies a unique identifier that is assigned by the server to each result set that is returned. The value of the LongId can be used as the long ID specified in the ItemOperations command request, the SmartReply command request, the SmartForward command request, or the MeetingResponse command request to reference the result set. The client MUST store the value of LongId as an opaque string of up to 256 characters.
Properties | The Search command response Properties is a container for properties that apply to an individual entry that matches the Query element search string. For example, the Properties element contains an element for each nonempty, text-valued GAL property that is attached to the matching GAL entry. Only those properties that are attached to the specific GAL entry are returned; therefore different sets of properties can be returned in the response XML for different matching GAL entries. Each element in the Properties container is scoped to the appropriate namespace that is specified in the top-level Search element.

See Also

SearchResult Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Class Property

Aspose.Email

SearchResult.Class Property

Identifies the class of the item.

public AirsyncClass Class {get; set;}

See Also

SearchResult Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


CollectionId Property

Aspose.Email

SearchResult.CollectionId Property

Specifies the folders in which the item was found.

public String} CollectionId {get;}

See Also

SearchResult Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


LongId Property

Aspose.Email

SearchResult.LongId Property

Specifies a unique identifier that is assigned by the server to each result set that is returned. The value of the LongId can be used as the long ID specified in the ItemOperations command request, the SmartReply command request, the SmartForward command request, or the MeetingResponse command request to reference the result set. The client MUST store the value of LongId as an opaque string of up to 256 characters.

public string LongId {get; set;}

See Also

SearchResult Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Properties Property

Aspose.Email

SearchResult.Properties Property

The Search command response Properties is a container for properties that apply to an individual entry that matches the Query element search string. For example, the Properties element contains an element for each nonempty, text-valued GAL property that is attached to the matching GAL entry. Only those properties that are attached to the specific GAL entry are returned; therefore different sets of properties can be returned in the response XML for different matching GAL entries. Each element in the Properties container is scoped to the appropriate namespace that is specified in the top-level Search element.

public SearchResultProperties Properties {get; set;}

See Also

SearchResult Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SearchResultProperties Class

The Search command response Properties is a container for properties that apply to an individual entry that matches the Query element search string. For example, the Properties element contains an element for each nonempty, text-valued GAL property that is attached to the matching GAL entry. Only those properties that are attached to the specific GAL entry are returned; therefore different sets of properties can be returned in the response XML for different matching GAL entries. Each element in the Properties container is scoped to the appropriate namespace that is specified in the top-level Search element.

For a list of all members of this type, see SearchResultProperties Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.SearchResultProperties

public class SearchResultProperties

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SearchResultProperties Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SearchResultProperties Members

SearchResultProperties overview

Public Instance Constructors

SearchResultProperties Constructor Initializes a new instance of the SearchResultProperties class.

Public Instance Properties

Body | Specifies a free-form, variable-length data field associated with a stored item on the server.
BodyPart | Specifies details about the message part of an e-mail in a response.
DataContainer | Contains data elements from the content classes.
Picture | Contains the data related to the contact photos.
RightsManagementLicense | Contains the rights policy template settings for the template applied to the e-mail message being synchronized.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SearchResultProperties Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SearchResultProperties Constructor

Initializes a new instance of the SearchResultProperties class.

public SearchResultProperties();

See Also

SearchResultProperties Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SearchResultProperties Properties

The properties of the SearchResultProperties class are listed below. For a complete list of SearchResultProperties class members, see the SearchResultProperties Members topic.

Public Instance Properties

Body | Specifies a free-form, variable-length data field associated with a stored item on the server.
BodyPart | Specifies details about the message part of an e-mail in a response.
DataContainer | Contains data elements from the content classes.
Picture | Contains the data related to the contact photos.
RightsManagementLicense | Contains the rights policy template settings for the template applied to the e-mail message being synchronized.

See Also

SearchResultProperties Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Body Property

Aspose.Email

SearchResultProperties.Body Property

Specifies a free-form, variable-length data field associated with a stored item on the server.

public Body} Body {get;}

See Also

SearchResultProperties Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


BodyPart Property

Aspose.Email

SearchResultProperties.BodyPart Property

Specifies details about the message part of an e-mail in a response.

public BodyPart} BodyPart {get;}

See Also

SearchResultProperties Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


DataContainer Property

Aspose.Email

SearchResultProperties.DataContainer Property

Contains data elements from the content classes.

public DataContainer DataContainer {get;}

See Also

SearchResultProperties Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Picture Property

Aspose.Email

SearchResultProperties.Picture Property

Contains the data related to the contact photos.

public PictureRespose Picture {get; set;}

See Also

SearchResultProperties Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


RightsManagementLicense Property

Aspose.Email

SearchResultProperties.RightsManagementLicense Property

Contains the rights policy template settings for the template applied to the e-mail message being synchronized.

public RightsManagementLicense RightsManagementLicense {get; set;}

See Also

SearchResultProperties Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ServerInfo Class

Server settings in Autodiscover operation

For a list of all members of this type, see ServerInfo Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.ServerInfo

public class ServerInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ServerInfo Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ServerInfo Members

ServerInfo overview

Public Instance Constructors

ServerInfo Constructor Initializes a new instance of the ServerInfo class.

Public Instance Properties

Name | Specifies a URL if the Type element (section 2.2.3.170.1) value is set to "MobileSync". If the Type element value is "MobileSync", then the Name element specifies the URL that conveys the protocol. If the Type element value is "CertEnroll", then the Name element value is NULL.
ServerData | The ServerData specifies the template name for the client certificate. Optional.
Type | Specifies the server type The following are the valid values for the Type element: MobileSync — Indicates that the URL that is returned by the URL element (section 2.2.3.172) can be accessed by clients. CertEnroll — Indicates that the URL that is returned by the URL element can be accessed by clients to obtain a client certificate for Secure Sockets Layer (SSL) negotiation.
Url | Specifies a URL string that conveys the protocol, port, resource location, and other information.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a string that represents the current object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ServerInfo Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ServerInfo Constructor

Initializes a new instance of the ServerInfo class.

public ServerInfo(
ServerType type,
string url,
string name,
string serverData
);

Parameters

type
Specifies the server type
url
Specifies a URL string that conveys the protocol, port, resource location, and other information.
name
Specifies a URL if the Type element (section 2.2.3.170.1) value is set to "MobileSync".
serverData
The ServerData specifies the template name for the client certificate.

See Also

ServerInfo Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ServerInfo Properties

The properties of the ServerInfo class are listed below. For a complete list of ServerInfo class members, see the ServerInfo Members topic.

Public Instance Properties

Name | Specifies a URL if the Type element (section 2.2.3.170.1) value is set to "MobileSync". If the Type element value is "MobileSync", then the Name element specifies the URL that conveys the protocol. If the Type element value is "CertEnroll", then the Name element value is NULL.
ServerData | The ServerData specifies the template name for the client certificate. Optional.
Type | Specifies the server type The following are the valid values for the Type element: MobileSync — Indicates that the URL that is returned by the URL element (section 2.2.3.172) can be accessed by clients. CertEnroll — Indicates that the URL that is returned by the URL element can be accessed by clients to obtain a client certificate for Secure Sockets Layer (SSL) negotiation.
Url | Specifies a URL string that conveys the protocol, port, resource location, and other information.

See Also

ServerInfo Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Name Property

Aspose.Email

ServerInfo.Name Property

Specifies a URL if the Type element (section 2.2.3.170.1) value is set to "MobileSync". If the Type element value is "MobileSync", then the Name element specifies the URL that conveys the protocol. If the Type element value is "CertEnroll", then the Name element value is NULL.

public string Name {get;}

See Also

ServerInfo Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ServerData Property

Aspose.Email

ServerInfo.ServerData Property

The ServerData specifies the template name for the client certificate. Optional.

public string ServerData {get;}

See Also

ServerInfo Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Type Property

Aspose.Email

ServerInfo.Type Property

Specifies the server type The following are the valid values for the Type element: MobileSync — Indicates that the URL that is returned by the URL element (section 2.2.3.172) can be accessed by clients. CertEnroll — Indicates that the URL that is returned by the URL element can be accessed by clients to obtain a client certificate for Secure Sockets Layer (SSL) negotiation.

public ServerType Type {get;}

See Also

ServerInfo Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Url Property

Aspose.Email

ServerInfo.Url Property

Specifies a URL string that conveys the protocol, port, resource location, and other information.

public string Url {get;}

See Also

ServerInfo Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ServerInfo Methods

The methods of the ServerInfo class are listed below. For a complete list of ServerInfo class members, see the ServerInfo Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a string that represents the current object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ServerInfo Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ServerInfo.ToString Method

Returns a string that represents the current object.

public override string ToString();

Return Value

A string that represents the current object.

See Also

ServerInfo Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ServerType Enumeration

Specifies the server type

public enum ServerType

Members

Member Name | Description | Value
None | Not defined | 0
MobileSync | Indicates that the URL that is returned by the URL element (section 2.2.3.172) can be accessed by clients. | 1
CertEnroll | Indicates that the URL that is returned by the URL element can be accessed by clients to obtain a client certificate for Secure Sockets Layer (SSL) negotiation. | 2

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SettingsRequest Class

The Settings command supports get and set operations on global properties and Out of Office (OOF) settings for the user. The Settings command also sends device information to the server, implements the device password/personal identification number (PIN) recovery, and retrieves a list of the user's email addresses.

For a list of all members of this type, see SettingsRequest Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.SettingsRequest

public class SettingsRequest

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SettingsRequest Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SettingsRequest Members

SettingsRequest overview

Public Instance Constructors

SettingsRequest Constructor Initializes a new instance of the SettingsRequest class.

Public Instance Properties

DeviceInformation | Request that is used for sending the client device's properties to the server.
DevicePassword | Specifies the request to set recovery password of the client device by the server. To clear an existing recovery password, the client MUST send an empty Password.
GetRightsManagementInformation | Requests a rights management information from the server.
GetUserInformation | Requests a list of a user's email addresses from the server.
Oof | Specifies a request for retrieving and setting Out of Office (OOF) information.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SettingsRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SettingsRequest Constructor

Initializes a new instance of the SettingsRequest class.

public SettingsRequest();

See Also

SettingsRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SettingsRequest Properties

The properties of the SettingsRequest class are listed below. For a complete list of SettingsRequest class members, see the SettingsRequest Members topic.

Public Instance Properties

DeviceInformation | Request that is used for sending the client device's properties to the server.
DevicePassword | Specifies the request to set recovery password of the client device by the server. To clear an existing recovery password, the client MUST send an empty Password.
GetRightsManagementInformation | Requests a rights management information from the server.
GetUserInformation | Requests a list of a user's email addresses from the server.
Oof | Specifies a request for retrieving and setting Out of Office (OOF) information.

See Also

SettingsRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


DeviceInformation Property

Aspose.Email

SettingsRequest.DeviceInformation Property

Request that is used for sending the client device's properties to the server.

public DeviceInformation DeviceInformation {get; set;}

See Also

SettingsRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


DevicePassword Property

Aspose.Email

SettingsRequest.DevicePassword Property

Specifies the request to set recovery password of the client device by the server. To clear an existing recovery password, the client MUST send an empty Password.

public DevicePasswordRequest DevicePassword {get; set;}

See Also

SettingsRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


GetRightsManagementInformation Property

Aspose.Email

SettingsRequest.GetRightsManagementInformation Property

Requests a rights management information from the server.

public Boolean} GetRightsManagementInformation {get; set;}

See Also

SettingsRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


GetUserInformation Property

Aspose.Email

SettingsRequest.GetUserInformation Property

Requests a list of a user's email addresses from the server.

public Boolean} GetUserInformation {get; set;}

See Also

SettingsRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Oof Property

Aspose.Email

SettingsRequest.Oof Property

Specifies a request for retrieving and setting Out of Office (OOF) information.

public OOFRequest Oof {get; set;}

See Also

SettingsRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SettingsResponse Class

Specifies a response with Out of Office (OOF) settings and list of the user's accounts.

For a list of all members of this type, see SettingsResponse Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.SettingsResponse

public class SettingsResponse

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SettingsResponse Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SettingsResponse Members

SettingsResponse overview

Public Instance Constructors

SettingsResponse Constructor Initializes a new instance of the SettingsResponse class.

Public Instance Properties

DeviceInformationStatus | Indicates the result of the DeviceInformation setup request
DevicePasswordStatus | Indicates the result of the DevicePassword setup request
Oof | Specifies a class for retrieving and setting Out of Office (OOF) information.
RightsManagementInformation | Contains rights management information settings retrieved from the server.
UserInformation | Contains status of the request and a list of a user’s account information (email addresses).

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SettingsResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SettingsResponse Constructor

Initializes a new instance of the SettingsResponse class.

public SettingsResponse();

See Also

SettingsResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SettingsResponse Properties

The properties of the SettingsResponse class are listed below. For a complete list of SettingsResponse class members, see the SettingsResponse Members topic.

Public Instance Properties

DeviceInformationStatus | Indicates the result of the DeviceInformation setup request
DevicePasswordStatus | Indicates the result of the DevicePassword setup request
Oof | Specifies a class for retrieving and setting Out of Office (OOF) information.
RightsManagementInformation | Contains rights management information settings retrieved from the server.
UserInformation | Contains status of the request and a list of a user’s account information (email addresses).

See Also

SettingsResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


DeviceInformationStatus Property

Aspose.Email

SettingsResponse.DeviceInformationStatus Property

Indicates the result of the DeviceInformation setup request

public Status DeviceInformationStatus {get; set;}

See Also

SettingsResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


DevicePasswordStatus Property

Aspose.Email

SettingsResponse.DevicePasswordStatus Property

Indicates the result of the DevicePassword setup request

public Status DevicePasswordStatus {get; set;}

See Also

SettingsResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Oof Property

Aspose.Email

SettingsResponse.Oof Property

Specifies a class for retrieving and setting Out of Office (OOF) information.

public OOFResponse Oof {get; set;}

See Also

SettingsResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


RightsManagementInformation Property

Aspose.Email

SettingsResponse.RightsManagementInformation Property

Contains rights management information settings retrieved from the server.

public RightsManagementInformationResponce RightsManagementInformation {get; set;}

See Also

SettingsResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


UserInformation Property

Aspose.Email

SettingsResponse.UserInformation Property

Contains status of the request and a list of a user’s account information (email addresses).

public UserInformationResponse UserInformation {get; set;}

See Also

SettingsResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SignedSMIMEAlgorithm Enumeration

Specifies the algorithm used when signing S/MIME messages.

public enum SignedSMIMEAlgorithm

Members

Member Name | Description | Value
SHA1 | Uses SHA1 algorithm. | 0
MD5 | Uses MD5 algorithm. | 1

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SmartRequest Class

Contains smart request information

For a list of all members of this type, see SmartRequest Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.SmartRequest

public class SmartRequest

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SmartRequest Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SmartRequest Members

SmartRequest overview

Public Instance Constructors

SmartRequest Constructor Initializes a new instance of the SmartRequest class.

Public Instance Properties

AccountId | Identifies the account from which an email is sent. If the AccountId is null, the server sends the email using the account identified by the settings:PrimarySmtpAddress returned in the Settings command response. If AccountId is included in the request, the value MUST equal one of the settings:AccountId element values included in the Settings command response. The server MUST validate that the AccountId element value provided is valid for sending email. A Status value of 166 is returned if the AccountId element value is not valid. A Status element value of 167 is returned if the account does not support sending email. Note The server sends the email using the account specified by the AccountId, and not the account specified by the From. The AccountId element is not supported when the protocol version is 12.1 or 14.0. Exchange 2007 returns Status value 103 if the AccountId element is included in a SendMail command request, a SmartForward command request, or a SmartReply command request.
ClientId | Specifies the client's unique message ID (MID). The ClientId value can be up to 40 characters in length and MUST be unique for each message, as the server will use the ClientId value to identify duplicate messages. The ClientId value can be a simple counter incremented for each new message.
Mime | Contains the MIME-encoded message. The Mime content is transferred as an opaque BLOB within the WBXML tags, as specified in [WBXML1.2]. If the message contains a meeting request, the Mime element contains the details of meeting in iCalendar format [MS-OXCICAL] or Transport Neutral Encapsulation Format (TNEF) format [MS-OXTNEF]. As specified in [RFC2447] section 3.4, iCalendar meeting requests have a content type of "text/calendar" with the method parameter set to "REQUEST".
ReplaceMime | Specifies whether the client is sending the entire message. When the ReplaceMime is TRUE, the server MUST not include the body or attachments of the original message being forwarded. When the ReplaceMime is FALSE, the client MUST append the body of the original message as attachments to the outgoing message. The client can use this property to indicate whether the message was edited inline, or whether the message had reply/forward text prepended to the source message. If the ReplaceMime is TRUE, the message was edited.
SaveInSentItems | Specifies whether a copy of the message will be stored in the Sent Items folder.
Source | Contains information about the source message.
TemplateID | Contains a string that identifies the rights policy template represented by the parent RightsManagementLicense element.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SmartRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SmartRequest Constructor

Initializes a new instance of the SmartRequest class.

public SmartRequest();

See Also

SmartRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SmartRequest Properties

The properties of the SmartRequest class are listed below. For a complete list of SmartRequest class members, see the SmartRequest Members topic.

Public Instance Properties

AccountId | Identifies the account from which an email is sent. If the AccountId is null, the server sends the email using the account identified by the settings:PrimarySmtpAddress returned in the Settings command response. If AccountId is included in the request, the value MUST equal one of the settings:AccountId element values included in the Settings command response. The server MUST validate that the AccountId element value provided is valid for sending email. A Status value of 166 is returned if the AccountId element value is not valid. A Status element value of 167 is returned if the account does not support sending email. Note The server sends the email using the account specified by the AccountId, and not the account specified by the From. The AccountId element is not supported when the protocol version is 12.1 or 14.0. Exchange 2007 returns Status value 103 if the AccountId element is included in a SendMail command request, a SmartForward command request, or a SmartReply command request.
ClientId | Specifies the client's unique message ID (MID). The ClientId value can be up to 40 characters in length and MUST be unique for each message, as the server will use the ClientId value to identify duplicate messages. The ClientId value can be a simple counter incremented for each new message.
Mime | Contains the MIME-encoded message. The Mime content is transferred as an opaque BLOB within the WBXML tags, as specified in [WBXML1.2]. If the message contains a meeting request, the Mime element contains the details of meeting in iCalendar format [MS-OXCICAL] or Transport Neutral Encapsulation Format (TNEF) format [MS-OXTNEF]. As specified in [RFC2447] section 3.4, iCalendar meeting requests have a content type of "text/calendar" with the method parameter set to "REQUEST".
ReplaceMime | Specifies whether the client is sending the entire message. When the ReplaceMime is TRUE, the server MUST not include the body or attachments of the original message being forwarded. When the ReplaceMime is FALSE, the client MUST append the body of the original message as attachments to the outgoing message. The client can use this property to indicate whether the message was edited inline, or whether the message had reply/forward text prepended to the source message. If the ReplaceMime is TRUE, the message was edited.
SaveInSentItems | Specifies whether a copy of the message will be stored in the Sent Items folder.
Source | Contains information about the source message.
TemplateID | Contains a string that identifies the rights policy template represented by the parent RightsManagementLicense element.

See Also

SmartRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


AccountId Property

Aspose.Email

SmartRequest.AccountId Property

Identifies the account from which an email is sent. If the AccountId is null, the server sends the email using the account identified by the settings:PrimarySmtpAddress returned in the Settings command response. If AccountId is included in the request, the value MUST equal one of the settings:AccountId element values included in the Settings command response. The server MUST validate that the AccountId element value provided is valid for sending email. A Status value of 166 is returned if the AccountId element value is not valid. A Status element value of 167 is returned if the account does not support sending email. Note The server sends the email using the account specified by the AccountId, and not the account specified by the From. The AccountId element is not supported when the protocol version is 12.1 or 14.0. Exchange 2007 returns Status value 103 if the AccountId element is included in a SendMail command request, a SmartForward command request, or a SmartReply command request.

public string AccountId {get; set;}

See Also

SmartRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ClientId Property

Aspose.Email

SmartRequest.ClientId Property

Specifies the client's unique message ID (MID). The ClientId value can be up to 40 characters in length and MUST be unique for each message, as the server will use the ClientId value to identify duplicate messages. The ClientId value can be a simple counter incremented for each new message.

public string ClientId {get; set;}

See Also

SmartRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Mime Property

Aspose.Email

SmartRequest.Mime Property

Contains the MIME-encoded message. The Mime content is transferred as an opaque BLOB within the WBXML tags, as specified in [WBXML1.2]. If the message contains a meeting request, the Mime element contains the details of meeting in iCalendar format [MS-OXCICAL] or Transport Neutral Encapsulation Format (TNEF) format [MS-OXTNEF]. As specified in [RFC2447] section 3.4, iCalendar meeting requests have a content type of "text/calendar" with the method parameter set to "REQUEST".

public string Mime {get; set;}

See Also

SmartRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ReplaceMime Property

Aspose.Email

SmartRequest.ReplaceMime Property

Specifies whether the client is sending the entire message. When the ReplaceMime is TRUE, the server MUST not include the body or attachments of the original message being forwarded. When the ReplaceMime is FALSE, the client MUST append the body of the original message as attachments to the outgoing message. The client can use this property to indicate whether the message was edited inline, or whether the message had reply/forward text prepended to the source message. If the ReplaceMime is TRUE, the message was edited.

public bool ReplaceMime {get; set;}

See Also

SmartRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SaveInSentItems Property

Aspose.Email

SmartRequest.SaveInSentItems Property

Specifies whether a copy of the message will be stored in the Sent Items folder.

public bool SaveInSentItems {get; set;}

See Also

SmartRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Source Property

Aspose.Email

SmartRequest.Source Property

Contains information about the source message.

public SmartRequestSource Source {get; set;}

See Also

SmartRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


TemplateID Property

Aspose.Email

SmartRequest.TemplateID Property

Contains a string that identifies the rights policy template represented by the parent RightsManagementLicense element.

public string TemplateID {get; set;}

See Also

SmartRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SmartRequestSource Class

Contains information about the source message.

For a list of all members of this type, see SmartRequestSource Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.SmartRequestSource

public class SmartRequestSource

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SmartRequestSource Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SmartRequestSource Members

SmartRequestSource overview

Public Instance Constructors

SmartRequestSource Constructor Initializes a new instance of the SmartRequestSource class.

Public Instance Properties

FolderId | Specifies the folder ID for the source message, which is returned in the FolderSync command. If the FolderId is present, the ItemId MUST also be present. The FolderId value can be up to 64 characters in length.
InstanceId | Specifies the instance of a recurrence for the source item. If the InstanceId is present, both the FolderId and ItemId SHOULD be present.
ItemId | Specifies the item ID for the source message, which is returned in the Sync command. If the ItemId is present, the FolderId MUST also be present if the message being forwarded or replied to is stored in a folder other than the Inbox folder. The ItemId element value can be up to 64 characters in length.
LongId | Specifies the long ID for the source message, which is returned in the Search command. If the LongId is present, the FolderId, ItemId, and InstanceId are not present. The LongId value can be up to 256 characters in length.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SmartRequestSource Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SmartRequestSource Constructor

Initializes a new instance of the SmartRequestSource class.

public SmartRequestSource();

See Also

SmartRequestSource Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SmartRequestSource Properties

The properties of the SmartRequestSource class are listed below. For a complete list of SmartRequestSource class members, see the SmartRequestSource Members topic.

Public Instance Properties

FolderId | Specifies the folder ID for the source message, which is returned in the FolderSync command. If the FolderId is present, the ItemId MUST also be present. The FolderId value can be up to 64 characters in length.
InstanceId | Specifies the instance of a recurrence for the source item. If the InstanceId is present, both the FolderId and ItemId SHOULD be present.
ItemId | Specifies the item ID for the source message, which is returned in the Sync command. If the ItemId is present, the FolderId MUST also be present if the message being forwarded or replied to is stored in a folder other than the Inbox folder. The ItemId element value can be up to 64 characters in length.
LongId | Specifies the long ID for the source message, which is returned in the Search command. If the LongId is present, the FolderId, ItemId, and InstanceId are not present. The LongId value can be up to 256 characters in length.

See Also

SmartRequestSource Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


FolderId Property

Aspose.Email

SmartRequestSource.FolderId Property

Specifies the folder ID for the source message, which is returned in the FolderSync command. If the FolderId is present, the ItemId MUST also be present. The FolderId value can be up to 64 characters in length.

public string FolderId {get; set;}

See Also

SmartRequestSource Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


InstanceId Property

Aspose.Email

SmartRequestSource.InstanceId Property

Specifies the instance of a recurrence for the source item. If the InstanceId is present, both the FolderId and ItemId SHOULD be present.

public DateTime} InstanceId {get; set;}

See Also

SmartRequestSource Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ItemId Property

Aspose.Email

SmartRequestSource.ItemId Property

Specifies the item ID for the source message, which is returned in the Sync command. If the ItemId is present, the FolderId MUST also be present if the message being forwarded or replied to is stored in a folder other than the Inbox folder. The ItemId element value can be up to 64 characters in length.

public string ItemId {get; set;}

See Also

SmartRequestSource Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


LongId Property

Aspose.Email

SmartRequestSource.LongId Property

Specifies the long ID for the source message, which is returned in the Search command. If the LongId is present, the FolderId, ItemId, and InstanceId are not present. The LongId value can be up to 256 characters in length.

public string LongId {get; set;}

See Also

SmartRequestSource Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SMIMEEncryptionAlgorithmNegotiation Enumeration

Controls the negotiation of the encryption algorithm.

public enum SMIMEEncryptionAlgorithmNegotiation

Members

Member Name | Description | Value
DoNotNegotiate | Do not negotiate. | 0
NegotiateStrong | Negotiate a strong algorithm. | 1
NegotiateAny | Negotiate any algorithm. | 2

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Status Class

Indicates the result of an operation.

For a list of all members of this type, see Status Members.

System.Object
Aspose.Email.Common.Commands.CommandStatus
Aspose.Email.Protocols.ActiveSync.TransportLayer.Status

public class Status : CommandStatus

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Status Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Status Members

Status overview

Public Static Methods

GetStatus Overloaded. Gets status by code.

Public Static Operators and Type Conversions

Equality Operator | The inequality operator (==) returns true if its operands are equal, false otherwise.
Inequality Operator | The inequality operator (!=) returns false if its operands are equal, true otherwise.
Implicit Status to Int32 Conversion | Converts status to int value

Public Instance Constructors

Status Overloaded. Initializes a new instance of the Status class.

Public Instance Properties

Description (inherited from CommandStatus) | Contains status description
StatusCode (inherited from CommandStatus) | Contains status code

Public Instance Methods

Equals (inherited from CommandStatus) | Determines whether the specified object is equal to the current object.
GetHashCode (inherited from CommandStatus) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from CommandStatus) | Returns a string that represents the current object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

Protected Internal Instance Fields

_description (inherited from CommandStatus)
_statusCode (inherited from CommandStatus)

See Also

Status Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Status Constructor

Initializes a new instance of the Status class.

Overload List

Initializes a new instance of the Status class.

public Status(Status);

Initializes a new instance of the Status class.

public Status(int,string);

Initializes a new instance of the Status class. Status code is initialized with 0 value.

public Status(string);

See Also

Status Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Status Constructor (Status)

Initializes a new instance of the Status class.

public Status(
Status status
);

Parameters

status
Object of status to copy

See Also

Status Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | Status Constructor Overload List


Status Constructor (String)

Initializes a new instance of the Status class. Status code is initialized with 0 value.

public Status(
string description
);

Parameters

description
Contains status description

See Also

Status Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | Status Constructor Overload List


Status Constructor (Int32, String)

Initializes a new instance of the Status class.

public Status(
int statusCode,
string description
);

Parameters

statusCode
Contains status code
description
Contains status description

See Also

Status Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | Status Constructor Overload List


Status Methods

The methods of the Status class are listed below. For a complete list of Status class members, see the Status Members topic.

Public Static Methods

GetStatus Overloaded. Gets status by code.

Public Instance Methods

Equals (inherited from CommandStatus) | Determines whether the specified object is equal to the current object.
GetHashCode (inherited from CommandStatus) | Serves as a hash function for a particular type.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from CommandStatus) | Returns a string that represents the current object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Status Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


GetStatus Method

Aspose.Email

Status.GetStatus Method

Gets status by code.

Overload List

Gets status by code.

public static Status GetStatus(CommandCodes,int);

Gets status by code.

public static Status GetStatus(CommandCodes,int,int);

Gets status by code.

public static Status GetStatus(CommandCodes,string);

Gets status by code.

public static Status GetStatus(CommandCodes,string,int);

Gets status by code.

public static Status GetStatus(int);

See Also

Status Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Status.GetStatus Method (CommandCodes, Int32)

Gets status by code.

public static Status GetStatus(
CommandCodes commandCode,
int statusCode
);

Parameters

commandCode
Specifies ActiveSync command code.
statusCode
Contains status code

Return Value

Returns status specified by code.

See Also

Status Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | Status.GetStatus Overload List


Status.GetStatus Method (CommandCodes, Int32, Int32)

Gets status by code.

public static Status GetStatus(
CommandCodes commandCode,
int statusCode,
int subCategory
);

Parameters

commandCode
Specifies ActiveSync command code.
statusCode
Contains status code
subCategory
Specifies subcategory for status

Return Value

Returns status specified by code.

See Also

Status Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | Status.GetStatus Overload List


Status.GetStatus Method (CommandCodes, String)

Gets status by code.

public static Status GetStatus(
CommandCodes commandCode,
string statusCode
);

Parameters

commandCode
Specifies ActiveSync command code.
statusCode
Contains status code

Return Value

Returns status specified by code.

See Also

Status Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | Status.GetStatus Overload List


Status.GetStatus Method (CommandCodes, String, Int32)

Gets status by code.

public static Status GetStatus(
CommandCodes commandCode,
string statusCode,
int subCategory
);

Parameters

commandCode
Specifies ActiveSync command code.
statusCode
Contains status code
subCategory
Specifies subcategory for status

Return Value

Returns status specified by code.

See Also

Status Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | Status.GetStatus Overload List


Status.GetStatus Method (Int32)

Gets status by code.

public static Status GetStatus(
int statusCode
);

Parameters

statusCode
Contains status code

Return Value

Returns status specified by code.

See Also

Status Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | Status.GetStatus Overload List


Status Operators and Type Conversions

The operators and type conversions of the Status class are listed below. For a complete list of Status class members, see the Status Members topic.

Public Static Operators and Type Conversions

Equality Operator | The inequality operator (==) returns true if its operands are equal, false otherwise.
Inequality Operator | The inequality operator (!=) returns false if its operands are equal, true otherwise.
Implicit Status to Int32 Conversion | Converts status to int value

See Also

Status Class | Status Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Status Equality Operator

The inequality operator (==) returns true if its operands are equal, false otherwise.

public static bool operator ==(
Status status1,
Status status2
);

Parameters

status1
First object to compare
status2
Second object to compare

Return Value

true if the first status is equal to the second status; otherwise, false.

See Also

Status Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Status Inequality Operator

The inequality operator (!=) returns false if its operands are equal, true otherwise.

public static bool operator !=(
Status status1,
Status status2
);

Parameters

status1
First object to compare
status2
Second object to compare

Return Value

true if the first status is not equal to the second status; otherwise, false.

See Also

Status Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Status Implicit Status to Int32 Conversion

Converts status to int value

public static implicit operator int(
Status status
);

Parameters

status
Object to convert.

Return Value

Returns status code value.

See Also

Status Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


StoreType Enumeration

Contains infarmation that specify the location, for the operations.

public enum StoreType

Members

Member Name | Description | Value
Mailbox | The client specifies "Mailbox" when it intends to search the store. | 0
DocumentLibrary | The client specifies "DocumentLibrary" when it intends to search a Windows SharePoint Services or UNC library. | 1
GAL | The client specifies "GAL" when it intends to search the Global Address List. | 2

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncAddClientOperation Class

Creates a new object in a collection on the client.

For a list of all members of this type, see SyncAddClientOperation Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.SyncAddClientOperation

public class SyncAddClientOperation

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SyncAddClientOperation Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncAddClientOperation Members

SyncAddClientOperation overview

Public Instance Constructors

SyncAddClientOperation Constructor Initializes a new instance of the SyncAddClientOperation class.

Public Instance Properties

ApplicationData | ApplicationData contains data for a particular object, such as a contact, email message, calendar appointment, or task item.
ServerId | Represents a unique identifier that is assigned by the server to each object that can be synchronized. Used in server responses only.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyncAddClientOperation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncAddClientOperation Constructor

Initializes a new instance of the SyncAddClientOperation class.

public SyncAddClientOperation();

See Also

SyncAddClientOperation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncAddClientOperation Properties

The properties of the SyncAddClientOperation class are listed below. For a complete list of SyncAddClientOperation class members, see the SyncAddClientOperation Members topic.

Public Instance Properties

ApplicationData | ApplicationData contains data for a particular object, such as a contact, email message, calendar appointment, or task item.
ServerId | Represents a unique identifier that is assigned by the server to each object that can be synchronized. Used in server responses only.

See Also

SyncAddClientOperation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ApplicationData Property

Aspose.Email

SyncAddClientOperation.ApplicationData Property

ApplicationData contains data for a particular object, such as a contact, email message, calendar appointment, or task item.

public DataContainer ApplicationData {get;}

See Also

SyncAddClientOperation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ServerId Property

Aspose.Email

SyncAddClientOperation.ServerId Property

Represents a unique identifier that is assigned by the server to each object that can be synchronized. Used in server responses only.

public string ServerId {get; set;}

See Also

SyncAddClientOperation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncAddResponse Class

Serves to indicate that a new object has to be created in a collection.

For a list of all members of this type, see SyncAddResponse Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.SyncOperationResponse
Aspose.Email.Protocols.ActiveSync.TransportLayer.SyncAddResponse

public class SyncAddResponse : SyncOperationResponse

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SyncAddResponse Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncAddResponse Members

SyncAddResponse overview

Public Instance Constructors

SyncAddResponse Constructor Initializes a new instance of the SyncAddResponse class.

Public Instance Properties

Class | Identifies the class of the item being added to the collection.
ClientId | Contains a unique identifier that is generated by the client to temporarily identify a new object that is being created by using the Add element. The client includes the ClientId element in the Add element request that it sends to the server. The server response contains an Add element that contains the original client ID and a new server ID that was assigned for the object, which replaces the client ID as the permanent object identifier. The ClientId element is a unique identifier that consists of up to 64 digits and letters. The client generates this ID. The value only has to be unique for the device during the duration of the Sync request that adds the object to the server. The client stores the client IDs until the synchronization session is completed successfully, to make recovery easier if the synchronization process fails.
ServerId (inherited from SyncOperationResponse) | Represents a unique identifier that is assigned by the server to each object that can be synchronized.
Status (inherited from SyncOperationResponse) | Indicates the result of the operation. Used in server responses only.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyncAddResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncAddResponse Constructor

Initializes a new instance of the SyncAddResponse class.

public SyncAddResponse();

See Also

SyncAddResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncAddResponse Properties

The properties of the SyncAddResponse class are listed below. For a complete list of SyncAddResponse class members, see the SyncAddResponse Members topic.

Public Instance Properties

Class | Identifies the class of the item being added to the collection.
ClientId | Contains a unique identifier that is generated by the client to temporarily identify a new object that is being created by using the Add element. The client includes the ClientId element in the Add element request that it sends to the server. The server response contains an Add element that contains the original client ID and a new server ID that was assigned for the object, which replaces the client ID as the permanent object identifier. The ClientId element is a unique identifier that consists of up to 64 digits and letters. The client generates this ID. The value only has to be unique for the device during the duration of the Sync request that adds the object to the server. The client stores the client IDs until the synchronization session is completed successfully, to make recovery easier if the synchronization process fails.
ServerId (inherited from SyncOperationResponse) | Represents a unique identifier that is assigned by the server to each object that can be synchronized.
Status (inherited from SyncOperationResponse) | Indicates the result of the operation. Used in server responses only.

See Also

SyncAddResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Class Property

Aspose.Email

SyncAddResponse.Class Property

Identifies the class of the item being added to the collection.

public AirsyncClass} Class {get; set;}

See Also

SyncAddResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ClientId Property

Aspose.Email

SyncAddResponse.ClientId Property

Contains a unique identifier that is generated by the client to temporarily identify a new object that is being created by using the Add element. The client includes the ClientId element in the Add element request that it sends to the server. The server response contains an Add element that contains the original client ID and a new server ID that was assigned for the object, which replaces the client ID as the permanent object identifier. The ClientId element is a unique identifier that consists of up to 64 digits and letters. The client generates this ID. The value only has to be unique for the device during the duration of the Sync request that adds the object to the server. The client stores the client IDs until the synchronization session is completed successfully, to make recovery easier if the synchronization process fails.

public string ClientId {get; set;}

See Also

SyncAddResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncAddServerOperation Class

Creates a new object in a collection on the server.

For a list of all members of this type, see SyncAddServerOperation Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.SyncAddServerOperation

public class SyncAddServerOperation

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SyncAddServerOperation Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncAddServerOperation Members

SyncAddServerOperation overview

Public Instance Constructors

SyncAddServerOperation Constructor Initializes a new instance of the SyncAddServerOperation class.

Public Instance Properties

ApplicationData | ApplicationData contains data for a particular object, such as a contact, email message, calendar appointment, or task item.
Class | Identifies the class of the item being added to the collection.
ClientId | Contains a unique identifier that is generated by the client to temporarily identify a new object that is being created by using the Add element. The client includes the ClientId element in the Add element request that it sends to the server. The server response contains an Add element that contains the original client ID and a new server ID that was assigned for the object, which replaces the client ID as the permanent object identifier. The ClientId element is a unique identifier that consists of up to 64 digits and letters. The client generates this ID. The value only has to be unique for the device during the duration of the Sync request that adds the object to the server. The client stores the client IDs until the synchronization session is completed successfully, to make recovery easier if the synchronization process fails.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyncAddServerOperation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncAddServerOperation Constructor

Initializes a new instance of the SyncAddServerOperation class.

public SyncAddServerOperation();

See Also

SyncAddServerOperation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncAddServerOperation Properties

The properties of the SyncAddServerOperation class are listed below. For a complete list of SyncAddServerOperation class members, see the SyncAddServerOperation Members topic.

Public Instance Properties

ApplicationData | ApplicationData contains data for a particular object, such as a contact, email message, calendar appointment, or task item.
Class | Identifies the class of the item being added to the collection.
ClientId | Contains a unique identifier that is generated by the client to temporarily identify a new object that is being created by using the Add element. The client includes the ClientId element in the Add element request that it sends to the server. The server response contains an Add element that contains the original client ID and a new server ID that was assigned for the object, which replaces the client ID as the permanent object identifier. The ClientId element is a unique identifier that consists of up to 64 digits and letters. The client generates this ID. The value only has to be unique for the device during the duration of the Sync request that adds the object to the server. The client stores the client IDs until the synchronization session is completed successfully, to make recovery easier if the synchronization process fails.

See Also

SyncAddServerOperation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ApplicationData Property

Aspose.Email

SyncAddServerOperation.ApplicationData Property

ApplicationData contains data for a particular object, such as a contact, email message, calendar appointment, or task item.

public DataContainer ApplicationData {get;}

See Also

SyncAddServerOperation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Class Property

Aspose.Email

SyncAddServerOperation.Class Property

Identifies the class of the item being added to the collection.

public AirsyncClass} Class {get; set;}

See Also

SyncAddServerOperation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ClientId Property

Aspose.Email

SyncAddServerOperation.ClientId Property

Contains a unique identifier that is generated by the client to temporarily identify a new object that is being created by using the Add element. The client includes the ClientId element in the Add element request that it sends to the server. The server response contains an Add element that contains the original client ID and a new server ID that was assigned for the object, which replaces the client ID as the permanent object identifier. The ClientId element is a unique identifier that consists of up to 64 digits and letters. The client generates this ID. The value only has to be unique for the device during the duration of the Sync request that adds the object to the server. The client stores the client IDs until the synchronization session is completed successfully, to make recovery easier if the synchronization process fails.

public string ClientId {get; set;}

See Also

SyncAddServerOperation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncChangeClientOperation Class

Contains properties of an existing object on the client device that were modified. The changed object is identified by its ServerId element.

For a list of all members of this type, see SyncChangeClientOperation Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.SyncChangeClientOperation

public class SyncChangeClientOperation

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SyncChangeClientOperation Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncChangeClientOperation Members

SyncChangeClientOperation overview

Public Instance Constructors

SyncChangeClientOperation Overloaded. Initializes a new instance of the SyncChangeClientOperation class.

Public Instance Properties

ApplicationData | ApplicationData contains data for a particular object, such as a contact, email message, calendar appointment, or task item.
Class | Identifies the class of the item being added to the collection. Used in server responses only.
ServerId | Represents a unique identifier that is assigned by the server to each object that can be synchronized.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyncChangeClientOperation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncChangeClientOperation Constructor

Initializes a new instance of the SyncChangeClientOperation class.

Overload List

Initializes a new instance of the SyncChangeClientOperation class.

public SyncChangeClientOperation();

Initializes a new instance of the SyncChangeClientOperation class.

public SyncChangeClientOperation(string,DataContainer,AirsyncClass);

See Also

SyncChangeClientOperation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncChangeClientOperation Constructor ()

Initializes a new instance of the SyncChangeClientOperation class.

public SyncChangeClientOperation();

See Also

SyncChangeClientOperation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | SyncChangeClientOperation Constructor Overload List


SyncChangeClientOperation Constructor (String, DataContainer, AirsyncClass)

Initializes a new instance of the SyncChangeClientOperation class.

public SyncChangeClientOperation(
string serverId,
DataContainer applicationData,
AirsyncClass aClass
);

Parameters

serverId
Represents a unique identifier that is assigned by the server to each object that can be synchronized.
applicationData
ApplicationData contains data for a particular object, such as a contact, email message, calendar appointment, or task item.
aClass
Identifies the class of the item being added to the collection.

See Also

SyncChangeClientOperation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | SyncChangeClientOperation Constructor Overload List


SyncChangeClientOperation Properties

The properties of the SyncChangeClientOperation class are listed below. For a complete list of SyncChangeClientOperation class members, see the SyncChangeClientOperation Members topic.

Public Instance Properties

ApplicationData | ApplicationData contains data for a particular object, such as a contact, email message, calendar appointment, or task item.
Class | Identifies the class of the item being added to the collection. Used in server responses only.
ServerId | Represents a unique identifier that is assigned by the server to each object that can be synchronized.

See Also

SyncChangeClientOperation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ApplicationData Property

Aspose.Email

SyncChangeClientOperation.ApplicationData Property

ApplicationData contains data for a particular object, such as a contact, email message, calendar appointment, or task item.

public DataContainer ApplicationData {get;}

See Also

SyncChangeClientOperation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Class Property

Aspose.Email

SyncChangeClientOperation.Class Property

Identifies the class of the item being added to the collection. Used in server responses only.

public AirsyncClass Class {get; set;}

See Also

SyncChangeClientOperation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ServerId Property

Aspose.Email

SyncChangeClientOperation.ServerId Property

Represents a unique identifier that is assigned by the server to each object that can be synchronized.

public string ServerId {get; set;}

See Also

SyncChangeClientOperation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncChangeResponse Class

Serves to Indicate that an object has been modified.

For a list of all members of this type, see SyncChangeResponse Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.SyncOperationResponse
Aspose.Email.Protocols.ActiveSync.TransportLayer.SyncChangeResponse

public class SyncChangeResponse : SyncOperationResponse

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SyncChangeResponse Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncChangeResponse Members

SyncChangeResponse overview

Public Instance Constructors

SyncChangeResponse Constructor Initializes a new instance of the SyncChangeResponse class.

Public Instance Properties

Class | Identifies the class of the item being added to the collection.
ServerId (inherited from SyncOperationResponse) | Represents a unique identifier that is assigned by the server to each object that can be synchronized.
Status (inherited from SyncOperationResponse) | Indicates the result of the operation. Used in server responses only.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyncChangeResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncChangeResponse Constructor

Initializes a new instance of the SyncChangeResponse class.

public SyncChangeResponse();

See Also

SyncChangeResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncChangeResponse Properties

The properties of the SyncChangeResponse class are listed below. For a complete list of SyncChangeResponse class members, see the SyncChangeResponse Members topic.

Public Instance Properties

Class | Identifies the class of the item being added to the collection.
ServerId (inherited from SyncOperationResponse) | Represents a unique identifier that is assigned by the server to each object that can be synchronized.
Status (inherited from SyncOperationResponse) | Indicates the result of the operation. Used in server responses only.

See Also

SyncChangeResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Class Property

Aspose.Email

SyncChangeResponse.Class Property

Identifies the class of the item being added to the collection.

public AirsyncClass} Class {get; set;}

See Also

SyncChangeResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncChangeServerOperation Class

Contains properties of an existing object on the the server that were modified. The changed object is identified by its ServerId element.

For a list of all members of this type, see SyncChangeServerOperation Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.SyncChangeServerOperation

public class SyncChangeServerOperation

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SyncChangeServerOperation Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncChangeServerOperation Members

SyncChangeServerOperation overview

Public Instance Constructors

SyncChangeServerOperation Overloaded. Initializes a new instance of the SyncChangeServerOperation class.

Public Instance Properties

ApplicationData | ApplicationData contains data for a particular object, such as a contact, email message, calendar appointment, or task item.
ServerId | Represents a unique identifier that is assigned by the server to each object that can be synchronized.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyncChangeServerOperation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncChangeServerOperation Constructor

Initializes a new instance of the SyncChangeServerOperation class.

Overload List

Initializes a new instance of the SyncChangeServerOperation class.

public SyncChangeServerOperation();

Initializes a new instance of the SyncChangeServerOperation class.

public SyncChangeServerOperation(string,DataContainer);

See Also

SyncChangeServerOperation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncChangeServerOperation Constructor ()

Initializes a new instance of the SyncChangeServerOperation class.

public SyncChangeServerOperation();

See Also

SyncChangeServerOperation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | SyncChangeServerOperation Constructor Overload List


SyncChangeServerOperation Constructor (String, DataContainer)

Initializes a new instance of the SyncChangeServerOperation class.

public SyncChangeServerOperation(
string serverId,
DataContainer applicationData
);

Parameters

serverId
Represents a unique identifier that is assigned by the server to each object that can be synchronized.
applicationData
ApplicationData contains data for a particular object, such as a contact, email message, calendar appointment, or task item.

See Also

SyncChangeServerOperation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | SyncChangeServerOperation Constructor Overload List


SyncChangeServerOperation Properties

The properties of the SyncChangeServerOperation class are listed below. For a complete list of SyncChangeServerOperation class members, see the SyncChangeServerOperation Members topic.

Public Instance Properties

ApplicationData | ApplicationData contains data for a particular object, such as a contact, email message, calendar appointment, or task item.
ServerId | Represents a unique identifier that is assigned by the server to each object that can be synchronized.

See Also

SyncChangeServerOperation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ApplicationData Property

Aspose.Email

SyncChangeServerOperation.ApplicationData Property

ApplicationData contains data for a particular object, such as a contact, email message, calendar appointment, or task item.

public DataContainer ApplicationData {get;}

See Also

SyncChangeServerOperation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ServerId Property

Aspose.Email

SyncChangeServerOperation.ServerId Property

Represents a unique identifier that is assigned by the server to each object that can be synchronized.

public string ServerId {get; set;}

See Also

SyncChangeServerOperation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncCollectionRequest Class

Class contains commands and options that apply to a particular collection.

For a list of all members of this type, see SyncCollectionRequest Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.SyncCollectionRequest

public class SyncCollectionRequest

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SyncCollectionRequest Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncCollectionRequest Members

SyncCollectionRequest overview

Public Instance Constructors

SyncCollectionRequest Constructor Initializes a new instance of the SyncCollectionRequest class.

Public Instance Properties

CollectionId | Specifies the server ID of the folder to be synchronized.
Commands | Contains operations that apply to a collection. Available operations are Add, Delete, Change, Fetch, and SoftDelete.
ConversationMode | Specifies whether to include items that are included within the conversation modality within the results of the Sync response. Setting the ConversationMode element value to TRUE results in retrieving all emails that match the conversations received within the date filter specified. However, although the body of the emails outside of that time based filter will not be retrieved, the text previews will be retrieved if the previews were requested.Setting the ConversationMode element value to FALSE in a Sync request results in the synchronization of items that meet the criteria of the FilterType element (section 2.2.3.64) value. Setting the ConversationMode element value to TRUE expands the result set to also include any items with identical email2:ConversationId ([MS-ASEMAIL] section 2.2.2.14) values to those in the FilterType result set. The ConversationMode element value has no impact on items outside the collection specified by the CollectionId element (section 2.2.3.30.5); the result set is always limited to items in the specified collection. The ConversationMode element value only limits or expands the results determined by the FilterType element value.
DeletesAsMoves | Requests that indicates that any deleted items SHOULD be moved to the Deleted Items folder. If the DeletesAsMoves element is set to false, the deletion is permanent. If the client wants to permanently delete items, the request MUST include the DeletesAsMoves element with a value of FALSE. A value of TRUE, which is the default, indicates that any deleted items are moved to the Deleted Items folder.
GetChanges | Requests that the server include in its response any pending changes to the collection that is specified by the ServerId element (section 2.2.3.151.6). If there have been changes since the last synchronization, the server response includes a Commands element (section 2.2.3.32) that contains additions, deletions, and changes. If the client does not want the server changes returned, the request MUST include the GetChanges element with a value of FALSE. A value of TRUE indicates that the client wants the server changes to be returned. A value of TRUE is assumed when the GetChanges element is empty. When the GetChanges element is not present in the request, the behavior depends on the value of the SyncKey element, as specified in section 2.2.3.166.4. If the SyncKey element has a value of 0, then the request is handled as if the GetChanges element were set to FALSE. If the SyncKey element has a non-zero value, then the request is handled as if the GetChanges element were set to TRUE.
Options | Specifies options that control certain aspects of how the synchronization is performed. Number allowed 0...2. Synchronization options enable the client to specify truncation and content settings. These settings are encapsulated within a airsyncbase:BodyPreference child element, as specified in [MS-ASAIRS] section 2.2.2.7. Because synchronization options are specified on a collection, the client can specify a unique airsyncbase:BodyPreference element value for each collection that it is being synchronized. For more details about the airsyncbase:BodyPreference element, see [MS-ASAIRS] section 2.2.2.7. The server preserves the Options block across requests, using a concept referred to as "sticky options". If the Options block is not included in a request, the previous Options block is used. Whenever the client specifies new options by including an Options block in the request, the server MUST replace the original Options block with the new Options block. If two Options elements are included in a single Sync command request, one of the Options elements MUST specify the synchronization options for the SMS class, while the other Options element specifies the options for the default class of the given folder.
Supported | Elements of the Contact class and the Calendar class that are not ghosted can be included as child elements of the Supported element. For details about the use of ghosted properties, see section 2.2.3.154.
SyncKey | SyncKey value is used by the server to mark the synchronization state of a collection. A synchronization key of value 0 (zero) initializes the synchronization state on the server and causes a full synchronization of the collection.
WindowSize | Specifies a maximum number of changed items in a collection or a request that SHOULD be included in the synchronization response. If the WindowSize is not defined, the server behaves as if a WindowSize element with a value of 100 were submitted. The server interprets the value 0 (zero) and values above 512 as 512.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyncCollectionRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncCollectionRequest Constructor

Initializes a new instance of the SyncCollectionRequest class.

public SyncCollectionRequest();

See Also

SyncCollectionRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncCollectionRequest Properties

The properties of the SyncCollectionRequest class are listed below. For a complete list of SyncCollectionRequest class members, see the SyncCollectionRequest Members topic.

Public Instance Properties

CollectionId | Specifies the server ID of the folder to be synchronized.
Commands | Contains operations that apply to a collection. Available operations are Add, Delete, Change, Fetch, and SoftDelete.
ConversationMode | Specifies whether to include items that are included within the conversation modality within the results of the Sync response. Setting the ConversationMode element value to TRUE results in retrieving all emails that match the conversations received within the date filter specified. However, although the body of the emails outside of that time based filter will not be retrieved, the text previews will be retrieved if the previews were requested.Setting the ConversationMode element value to FALSE in a Sync request results in the synchronization of items that meet the criteria of the FilterType element (section 2.2.3.64) value. Setting the ConversationMode element value to TRUE expands the result set to also include any items with identical email2:ConversationId ([MS-ASEMAIL] section 2.2.2.14) values to those in the FilterType result set. The ConversationMode element value has no impact on items outside the collection specified by the CollectionId element (section 2.2.3.30.5); the result set is always limited to items in the specified collection. The ConversationMode element value only limits or expands the results determined by the FilterType element value.
DeletesAsMoves | Requests that indicates that any deleted items SHOULD be moved to the Deleted Items folder. If the DeletesAsMoves element is set to false, the deletion is permanent. If the client wants to permanently delete items, the request MUST include the DeletesAsMoves element with a value of FALSE. A value of TRUE, which is the default, indicates that any deleted items are moved to the Deleted Items folder.
GetChanges | Requests that the server include in its response any pending changes to the collection that is specified by the ServerId element (section 2.2.3.151.6). If there have been changes since the last synchronization, the server response includes a Commands element (section 2.2.3.32) that contains additions, deletions, and changes. If the client does not want the server changes returned, the request MUST include the GetChanges element with a value of FALSE. A value of TRUE indicates that the client wants the server changes to be returned. A value of TRUE is assumed when the GetChanges element is empty. When the GetChanges element is not present in the request, the behavior depends on the value of the SyncKey element, as specified in section 2.2.3.166.4. If the SyncKey element has a value of 0, then the request is handled as if the GetChanges element were set to FALSE. If the SyncKey element has a non-zero value, then the request is handled as if the GetChanges element were set to TRUE.
Options | Specifies options that control certain aspects of how the synchronization is performed. Number allowed 0...2. Synchronization options enable the client to specify truncation and content settings. These settings are encapsulated within a airsyncbase:BodyPreference child element, as specified in [MS-ASAIRS] section 2.2.2.7. Because synchronization options are specified on a collection, the client can specify a unique airsyncbase:BodyPreference element value for each collection that it is being synchronized. For more details about the airsyncbase:BodyPreference element, see [MS-ASAIRS] section 2.2.2.7. The server preserves the Options block across requests, using a concept referred to as "sticky options". If the Options block is not included in a request, the previous Options block is used. Whenever the client specifies new options by including an Options block in the request, the server MUST replace the original Options block with the new Options block. If two Options elements are included in a single Sync command request, one of the Options elements MUST specify the synchronization options for the SMS class, while the other Options element specifies the options for the default class of the given folder.
Supported | Elements of the Contact class and the Calendar class that are not ghosted can be included as child elements of the Supported element. For details about the use of ghosted properties, see section 2.2.3.154.
SyncKey | SyncKey value is used by the server to mark the synchronization state of a collection. A synchronization key of value 0 (zero) initializes the synchronization state on the server and causes a full synchronization of the collection.
WindowSize | Specifies a maximum number of changed items in a collection or a request that SHOULD be included in the synchronization response. If the WindowSize is not defined, the server behaves as if a WindowSize element with a value of 100 were submitted. The server interprets the value 0 (zero) and values above 512 as 512.

See Also

SyncCollectionRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


CollectionId Property

Aspose.Email

SyncCollectionRequest.CollectionId Property

Specifies the server ID of the folder to be synchronized.

public string CollectionId {get; set;}

See Also

SyncCollectionRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Commands Property

Aspose.Email

SyncCollectionRequest.Commands Property

Contains operations that apply to a collection. Available operations are Add, Delete, Change, Fetch, and SoftDelete.

public SyncCommandsRequest Commands {get; set;}

See Also

SyncCollectionRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ConversationMode Property

Aspose.Email

SyncCollectionRequest.ConversationMode Property

Specifies whether to include items that are included within the conversation modality within the results of the Sync response. Setting the ConversationMode element value to TRUE results in retrieving all emails that match the conversations received within the date filter specified. However, although the body of the emails outside of that time based filter will not be retrieved, the text previews will be retrieved if the previews were requested.Setting the ConversationMode element value to FALSE in a Sync request results in the synchronization of items that meet the criteria of the FilterType element (section 2.2.3.64) value. Setting the ConversationMode element value to TRUE expands the result set to also include any items with identical email2:ConversationId ([MS-ASEMAIL] section 2.2.2.14) values to those in the FilterType result set. The ConversationMode element value has no impact on items outside the collection specified by the CollectionId element (section 2.2.3.30.5); the result set is always limited to items in the specified collection. The ConversationMode element value only limits or expands the results determined by the FilterType element value.

public Boolean} ConversationMode {get; set;}

See Also

SyncCollectionRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


DeletesAsMoves Property

Aspose.Email

SyncCollectionRequest.DeletesAsMoves Property

Requests that indicates that any deleted items SHOULD be moved to the Deleted Items folder. If the DeletesAsMoves element is set to false, the deletion is permanent. If the client wants to permanently delete items, the request MUST include the DeletesAsMoves element with a value of FALSE. A value of TRUE, which is the default, indicates that any deleted items are moved to the Deleted Items folder.

public Boolean} DeletesAsMoves {get; set;}

See Also

SyncCollectionRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


GetChanges Property

Aspose.Email

SyncCollectionRequest.GetChanges Property

Requests that the server include in its response any pending changes to the collection that is specified by the ServerId element (section 2.2.3.151.6). If there have been changes since the last synchronization, the server response includes a Commands element (section 2.2.3.32) that contains additions, deletions, and changes. If the client does not want the server changes returned, the request MUST include the GetChanges element with a value of FALSE. A value of TRUE indicates that the client wants the server changes to be returned. A value of TRUE is assumed when the GetChanges element is empty. When the GetChanges element is not present in the request, the behavior depends on the value of the SyncKey element, as specified in section 2.2.3.166.4. If the SyncKey element has a value of 0, then the request is handled as if the GetChanges element were set to FALSE. If the SyncKey element has a non-zero value, then the request is handled as if the GetChanges element were set to TRUE.

public Boolean} GetChanges {get; set;}

See Also

SyncCollectionRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Options Property

Aspose.Email

SyncCollectionRequest.Options Property

Specifies options that control certain aspects of how the synchronization is performed. Number allowed 0...2. Synchronization options enable the client to specify truncation and content settings. These settings are encapsulated within a airsyncbase:BodyPreference child element, as specified in [MS-ASAIRS] section 2.2.2.7. Because synchronization options are specified on a collection, the client can specify a unique airsyncbase:BodyPreference element value for each collection that it is being synchronized. For more details about the airsyncbase:BodyPreference element, see [MS-ASAIRS] section 2.2.2.7. The server preserves the Options block across requests, using a concept referred to as "sticky options". If the Options block is not included in a request, the previous Options block is used. Whenever the client specifies new options by including an Options block in the request, the server MUST replace the original Options block with the new Options block. If two Options elements are included in a single Sync command request, one of the Options elements MUST specify the synchronization options for the SMS class, while the other Options element specifies the options for the default class of the given folder.

public SyncOptions} Options {get;}

See Also

SyncCollectionRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Supported Property

Aspose.Email

SyncCollectionRequest.Supported Property

Elements of the Contact class and the Calendar class that are not ghosted can be included as child elements of the Supported element. For details about the use of ghosted properties, see section 2.2.3.154.

public String} Supported {get;}

See Also

SyncCollectionRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncKey Property

Aspose.Email

SyncCollectionRequest.SyncKey Property

SyncKey value is used by the server to mark the synchronization state of a collection. A synchronization key of value 0 (zero) initializes the synchronization state on the server and causes a full synchronization of the collection.

public string SyncKey {get; set;}

See Also

SyncCollectionRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


WindowSize Property

Aspose.Email

SyncCollectionRequest.WindowSize Property

Specifies a maximum number of changed items in a collection or a request that SHOULD be included in the synchronization response. If the WindowSize is not defined, the server behaves as if a WindowSize element with a value of 100 were submitted. The server interprets the value 0 (zero) and values above 512 as 512.

public Int32} WindowSize {get; set;}

See Also

SyncCollectionRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncCollectionResponse Class

Class contains commands and options that apply to a Sync response.

For a list of all members of this type, see SyncCollectionResponse Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.SyncCollectionResponse

public class SyncCollectionResponse

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SyncCollectionResponse Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncCollectionResponse Members

SyncCollectionResponse overview

Public Instance Constructors

SyncCollectionResponse Constructor Initializes a new instance of the SyncCollectionResponse class.

Public Instance Properties

Class | Identifies the class of the item being added to the collection. Uses when the protocol version is 12.1 only.
CollectionId | Specifies the server ID of the folder to be synchronized.
Commands | Contains operations that apply to a collection. Available operations are Add, Delete, Change, SoftDelete.
MoreAvailable | Indicates there are more changes than the number that are requested in the WindowSize element. In Exchange 2007, the server sends Sync response messages containing the MoreAvailable and between zero (0) and WindowSize schema changes when it encounters elements external to the protocol.
Responses | Contains responses to operations such as Add, Fetch, Change that are processed by the server.
Status | Indicates the status of the command operation
SyncKey | SyncKey value is used by the server to mark the synchronization state of a collection. A synchronization key of value 0 (zero) initializes the synchronization state on the server and causes a full synchronization of the collection.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyncCollectionResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncCollectionResponse Constructor

Initializes a new instance of the SyncCollectionResponse class.

public SyncCollectionResponse();

See Also

SyncCollectionResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncCollectionResponse Properties

The properties of the SyncCollectionResponse class are listed below. For a complete list of SyncCollectionResponse class members, see the SyncCollectionResponse Members topic.

Public Instance Properties

Class | Identifies the class of the item being added to the collection. Uses when the protocol version is 12.1 only.
CollectionId | Specifies the server ID of the folder to be synchronized.
Commands | Contains operations that apply to a collection. Available operations are Add, Delete, Change, SoftDelete.
MoreAvailable | Indicates there are more changes than the number that are requested in the WindowSize element. In Exchange 2007, the server sends Sync response messages containing the MoreAvailable and between zero (0) and WindowSize schema changes when it encounters elements external to the protocol.
Responses | Contains responses to operations such as Add, Fetch, Change that are processed by the server.
Status | Indicates the status of the command operation
SyncKey | SyncKey value is used by the server to mark the synchronization state of a collection. A synchronization key of value 0 (zero) initializes the synchronization state on the server and causes a full synchronization of the collection.

See Also

SyncCollectionResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Class Property

Aspose.Email

SyncCollectionResponse.Class Property

Identifies the class of the item being added to the collection. Uses when the protocol version is 12.1 only.

public AirsyncClass Class {get; set;}

See Also

SyncCollectionResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


CollectionId Property

Aspose.Email

SyncCollectionResponse.CollectionId Property

Specifies the server ID of the folder to be synchronized.

public string CollectionId {get; set;}

See Also

SyncCollectionResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Commands Property

Aspose.Email

SyncCollectionResponse.Commands Property

Contains operations that apply to a collection. Available operations are Add, Delete, Change, SoftDelete.

public SyncCommandsResponse Commands {get; set;}

See Also

SyncCollectionResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


MoreAvailable Property

Aspose.Email

SyncCollectionResponse.MoreAvailable Property

Indicates there are more changes than the number that are requested in the WindowSize element. In Exchange 2007, the server sends Sync response messages containing the MoreAvailable and between zero (0) and WindowSize schema changes when it encounters elements external to the protocol.

public bool MoreAvailable {get; set;}

See Also

SyncCollectionResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Responses Property

Aspose.Email

SyncCollectionResponse.Responses Property

Contains responses to operations such as Add, Fetch, Change that are processed by the server.

public SyncOperationsResponse Responses {get; set;}

See Also

SyncCollectionResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Status Property

Aspose.Email

SyncCollectionResponse.Status Property

Indicates the status of the command operation

public Status Status {get; set;}

See Also

SyncCollectionResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncKey Property

Aspose.Email

SyncCollectionResponse.SyncKey Property

SyncKey value is used by the server to mark the synchronization state of a collection. A synchronization key of value 0 (zero) initializes the synchronization state on the server and causes a full synchronization of the collection.

public string SyncKey {get; set;}

See Also

SyncCollectionResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncCommandsRequest Class

Contains operations that apply to a collection. Available operations are Add, Delete, Change, Fetch, and SoftDelete.

For a list of all members of this type, see SyncCommandsRequest Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.SyncCommandsRequest

public class SyncCommandsRequest

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SyncCommandsRequest Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncCommandsRequest Members

SyncCommandsRequest overview

Public Instance Constructors

SyncCommandsRequest Constructor Initializes a new instance of the SyncCommandsRequest class.

Public Instance Properties

Add | Contains the list of add operations.
Change | Contains the list of update operations.
Delete | Contains the list of delete operations.
Fetch | Contains the list of fetch operations.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyncCommandsRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncCommandsRequest Constructor

Initializes a new instance of the SyncCommandsRequest class.

public SyncCommandsRequest();

See Also

SyncCommandsRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncCommandsRequest Properties

The properties of the SyncCommandsRequest class are listed below. For a complete list of SyncCommandsRequest class members, see the SyncCommandsRequest Members topic.

Public Instance Properties

Add | Contains the list of add operations.
Change | Contains the list of update operations.
Delete | Contains the list of delete operations.
Fetch | Contains the list of fetch operations.

See Also

SyncCommandsRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Add Property

Aspose.Email

SyncCommandsRequest.Add Property

Contains the list of add operations.

public SyncAddServerOperation} Add {get;}

See Also

SyncCommandsRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Change Property

Aspose.Email

SyncCommandsRequest.Change Property

Contains the list of update operations.

public SyncChangeServerOperation} Change {get;}

See Also

SyncCommandsRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Delete Property

Aspose.Email

SyncCommandsRequest.Delete Property

Contains the list of delete operations.

public String} Delete {get;}

See Also

SyncCommandsRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Fetch Property

Aspose.Email

SyncCommandsRequest.Fetch Property

Contains the list of fetch operations.

public String} Fetch {get;}

See Also

SyncCommandsRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncCommandsResponse Class

Contains operations that apply to a collection. Available operations are Add, Delete, Change, Fetch, and SoftDelete.

For a list of all members of this type, see SyncCommandsResponse Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.SyncCommandsResponse

public class SyncCommandsResponse

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SyncCommandsResponse Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncCommandsResponse Members

SyncCommandsResponse overview

Public Instance Constructors

SyncCommandsResponse Constructor Initializes a new instance of the SyncCommandsResponse class.

Public Instance Properties

Add | Contains the list of responses to add operations.
Change | Contains the list of responses to update operations.
Delete | Contains the list of responses to delete operations.
SoftDelete | Contains the list of responses to delete operations.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyncCommandsResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncCommandsResponse Constructor

Initializes a new instance of the SyncCommandsResponse class.

public SyncCommandsResponse();

See Also

SyncCommandsResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncCommandsResponse Properties

The properties of the SyncCommandsResponse class are listed below. For a complete list of SyncCommandsResponse class members, see the SyncCommandsResponse Members topic.

Public Instance Properties

Add | Contains the list of responses to add operations.
Change | Contains the list of responses to update operations.
Delete | Contains the list of responses to delete operations.
SoftDelete | Contains the list of responses to delete operations.

See Also

SyncCommandsResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Add Property

Aspose.Email

SyncCommandsResponse.Add Property

Contains the list of responses to add operations.

public SyncAddClientOperation} Add {get;}

See Also

SyncCommandsResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Change Property

Aspose.Email

SyncCommandsResponse.Change Property

Contains the list of responses to update operations.

public SyncChangeClientOperation} Change {get;}

See Also

SyncCommandsResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Delete Property

Aspose.Email

SyncCommandsResponse.Delete Property

Contains the list of responses to delete operations.

public SyncDeleteClientOperation} Delete {get;}

See Also

SyncCommandsResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SoftDelete Property

Aspose.Email

SyncCommandsResponse.SoftDelete Property

Contains the list of responses to delete operations.

public String} SoftDelete {get;}

See Also

SyncCommandsResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncDeleteClientOperation Class

Deletes an object on the client device or the server. The object is identified by its ServerId.

For a list of all members of this type, see SyncDeleteClientOperation Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.SyncDeleteClientOperation

public class SyncDeleteClientOperation

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SyncDeleteClientOperation Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncDeleteClientOperation Members

SyncDeleteClientOperation overview

Public Static Type Conversions

Implicit String to SyncDeleteClientOperation Conversion Converts server id to SyncDeleteClientOperation object

Public Instance Constructors

SyncDeleteClientOperation Overloaded. Initializes a new instance of the SyncDeleteClientOperation class.

Public Instance Properties

Class | Identifies the class of the item being added to the collection. Used in server responses only.
ServerId | Represents a unique identifier that is assigned by the server to each object that can be synchronized.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyncDeleteClientOperation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncDeleteClientOperation Constructor

Initializes a new instance of the SyncDeleteClientOperation class.

Overload List

Initializes a new instance of the SyncDeleteClientOperation class.

public SyncDeleteClientOperation();

Initializes a new instance of the SyncDeleteClientOperation class.

public SyncDeleteClientOperation(string);

Initializes a new instance of the SyncDeleteClientOperation class.

public SyncDeleteClientOperation(string,AirsyncClass);

See Also

SyncDeleteClientOperation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncDeleteClientOperation Constructor ()

Initializes a new instance of the SyncDeleteClientOperation class.

public SyncDeleteClientOperation();

See Also

SyncDeleteClientOperation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | SyncDeleteClientOperation Constructor Overload List


SyncDeleteClientOperation Constructor (String)

Initializes a new instance of the SyncDeleteClientOperation class.

public SyncDeleteClientOperation(
string serverId
);

Parameters

serverId
Represents a unique identifier that is assigned by the server to each object that can be synchronized.

See Also

SyncDeleteClientOperation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | SyncDeleteClientOperation Constructor Overload List


SyncDeleteClientOperation Constructor (String, AirsyncClass)

Initializes a new instance of the SyncDeleteClientOperation class.

public SyncDeleteClientOperation(
string serverId,
AirsyncClass aClass
);

Parameters

serverId
Represents a unique identifier that is assigned by the server to each object that can be synchronized.
aClass
Identifies the class of the item being added to the collection.

See Also

SyncDeleteClientOperation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | SyncDeleteClientOperation Constructor Overload List


SyncDeleteClientOperation Properties

The properties of the SyncDeleteClientOperation class are listed below. For a complete list of SyncDeleteClientOperation class members, see the SyncDeleteClientOperation Members topic.

Public Instance Properties

Class | Identifies the class of the item being added to the collection. Used in server responses only.
ServerId | Represents a unique identifier that is assigned by the server to each object that can be synchronized.

See Also

SyncDeleteClientOperation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Class Property

Aspose.Email

SyncDeleteClientOperation.Class Property

Identifies the class of the item being added to the collection. Used in server responses only.

public AirsyncClass} Class {get; set;}

See Also

SyncDeleteClientOperation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ServerId Property

Aspose.Email

SyncDeleteClientOperation.ServerId Property

Represents a unique identifier that is assigned by the server to each object that can be synchronized.

public string ServerId {get; set;}

See Also

SyncDeleteClientOperation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncDeleteClientOperation Type Conversions

The type conversions of the SyncDeleteClientOperation class are listed below. For a complete list of SyncDeleteClientOperation class members, see the SyncDeleteClientOperation Members topic.

Public Static Type Conversions

Implicit String to SyncDeleteClientOperation Conversion Converts server id to SyncDeleteClientOperation object

See Also

SyncDeleteClientOperation Class | SyncDeleteClientOperation Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncDeleteClientOperation Implicit String to SyncDeleteClientOperation Conversion

Converts server id to SyncDeleteClientOperation object

public static implicit operator SyncDeleteClientOperation(
string serverId
);

Parameters

serverId
Represents a unique identifier that is assigned by the server to each object that can be synchronized.

Return Value

Returns instance of the SyncDeleteClientOperation class

See Also

SyncDeleteClientOperation Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncFetchResponse Class

Requests the application data of an item that was truncated in a synchronization response from the server.

For a list of all members of this type, see SyncFetchResponse Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.SyncOperationResponse
Aspose.Email.Protocols.ActiveSync.TransportLayer.SyncFetchResponse

public class SyncFetchResponse : SyncOperationResponse

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SyncFetchResponse Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncFetchResponse Members

SyncFetchResponse overview

Public Instance Constructors

SyncFetchResponse Constructor Initializes a new instance of the SyncFetchResponse class.

Public Instance Properties

ApplicationData | ApplicationData contains data for a particular object, such as a contact, email message, calendar appointment, or task item.
ServerId (inherited from SyncOperationResponse) | Represents a unique identifier that is assigned by the server to each object that can be synchronized.
Status (inherited from SyncOperationResponse) | Indicates the result of the operation. Used in server responses only.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyncFetchResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncFetchResponse Constructor

Initializes a new instance of the SyncFetchResponse class.

public SyncFetchResponse();

See Also

SyncFetchResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncFetchResponse Properties

The properties of the SyncFetchResponse class are listed below. For a complete list of SyncFetchResponse class members, see the SyncFetchResponse Members topic.

Public Instance Properties

ApplicationData | ApplicationData contains data for a particular object, such as a contact, email message, calendar appointment, or task item.
ServerId (inherited from SyncOperationResponse) | Represents a unique identifier that is assigned by the server to each object that can be synchronized.
Status (inherited from SyncOperationResponse) | Indicates the result of the operation. Used in server responses only.

See Also

SyncFetchResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ApplicationData Property

Aspose.Email

SyncFetchResponse.ApplicationData Property

ApplicationData contains data for a particular object, such as a contact, email message, calendar appointment, or task item.

public DataContainer ApplicationData {get;}

See Also

SyncFetchResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncOperationResponse Class

Base abstract class for Sync operation responses

For a list of all members of this type, see SyncOperationResponse Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.SyncOperationResponse
Aspose.Email.Protocols.ActiveSync.TransportLayer.SyncAddResponse
Aspose.Email.Protocols.ActiveSync.TransportLayer.SyncChangeResponse
Aspose.Email.Protocols.ActiveSync.TransportLayer.SyncFetchResponse

public abstract class SyncOperationResponse

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SyncOperationResponse Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncOperationResponse Members

SyncOperationResponse overview

Public Instance Properties

ServerId | Represents a unique identifier that is assigned by the server to each object that can be synchronized.
Status | Indicates the result of the operation. Used in server responses only.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

SyncOperationResponse Constructor Initializes a new instance of the SyncOperationResponse class.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyncOperationResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncOperationResponse Constructor

Initializes a new instance of the SyncOperationResponse class.

protected SyncOperationResponse();

See Also

SyncOperationResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncOperationResponse Properties

The properties of the SyncOperationResponse class are listed below. For a complete list of SyncOperationResponse class members, see the SyncOperationResponse Members topic.

Public Instance Properties

ServerId | Represents a unique identifier that is assigned by the server to each object that can be synchronized.
Status | Indicates the result of the operation. Used in server responses only.

See Also

SyncOperationResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ServerId Property

Aspose.Email

SyncOperationResponse.ServerId Property

Represents a unique identifier that is assigned by the server to each object that can be synchronized.

public string ServerId {get; set;}

See Also

SyncOperationResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Status Property

Aspose.Email

SyncOperationResponse.Status Property

Indicates the result of the operation. Used in server responses only.

public Status Status {get; set;}

See Also

SyncOperationResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncOperationsResponse Class

Contains responses to operations such as Add, Fetch, Change that are processed by the server. The response contains a status code and other information, depending on the operation.

For a list of all members of this type, see SyncOperationsResponse Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.SyncOperationsResponse

public class SyncOperationsResponse

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SyncOperationsResponse Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncOperationsResponse Members

SyncOperationsResponse overview

Public Instance Constructors

SyncOperationsResponse Constructor Initializes a new instance of the SyncOperationsResponse class.

Public Instance Properties

Add | List of objects that indicates that a new object has to be created in a collection.
Change | List of objects that indicates that a object has to be modified in a collection.
Fetch | List of fetched objects

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyncOperationsResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncOperationsResponse Constructor

Initializes a new instance of the SyncOperationsResponse class.

public SyncOperationsResponse();

See Also

SyncOperationsResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncOperationsResponse Properties

The properties of the SyncOperationsResponse class are listed below. For a complete list of SyncOperationsResponse class members, see the SyncOperationsResponse Members topic.

Public Instance Properties

Add | List of objects that indicates that a new object has to be created in a collection.
Change | List of objects that indicates that a object has to be modified in a collection.
Fetch | List of fetched objects

See Also

SyncOperationsResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Add Property

Aspose.Email

SyncOperationsResponse.Add Property

List of objects that indicates that a new object has to be created in a collection.

public SyncAddResponse} Add {get;}

See Also

SyncOperationsResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Change Property

Aspose.Email

SyncOperationsResponse.Change Property

List of objects that indicates that a object has to be modified in a collection.

public SyncChangeResponse} Change {get;}

See Also

SyncOperationsResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Fetch Property

Aspose.Email

SyncOperationsResponse.Fetch Property

List of fetched objects

public SyncFetchResponse} Fetch {get;}

See Also

SyncOperationsResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncOptions Class

Specifies options that control certain aspects of how the synchronization is performed.

For a list of all members of this type, see SyncOptions Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.SyncOptions

public class SyncOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SyncOptions Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncOptions Members

SyncOptions overview

Public Instance Constructors

SyncOptions Constructor Initializes a new instance of the SyncOptions class.

Public Instance Properties

BodyPartPreference | Contains preference information related to the type and size of information that is returned from searching, synchronizing, or fetching a message part.
BodyPreference | Contains preference information related to the type and size of information that is returned from searching, synchronizing, or fetching.
Class | Specifies the class of the item being added to the collection.
Conflict | Specifies how to resolve the conflict that occurs when an object has been changed on both the client and the server. The value specifies which object—the client object or the server object—to keep if there is a conflict. If value is not defined, the server object will replace the client object when a conflict occurs.
FilterType | Specifies an optional time window for the objects that are sent from the server to the client.
MaxItems | Specifies the maximum number of recipients (that is, the top N most frequently used recipients) to keep synchronized from within the recipient information cache. This element MUST only be included in a request when the value of the CollectionId element (section 2.2.3.30.5) maps to the recipient information cache. The value of the MaxItems element does not specify the maximum estimate of additions and deletions to make to the recipient information cache, it only specifies the number of recipients to keep synchronized. A complete replacement of each recipient would be double the number of MaxItems or items in the store, as each recipient update requires a deletion and an addition.
MIMESupport | Enables MIME support for email items that are sent from the server to the client.
MIMETruncation | Specifies whether the MIME data of the email item SHOULD be truncated when it is sent from the server to the client.
RightsManagementSupport | Specifies how the server returns rights-managed email messages to the client. If the value of this element is TRUE, the server will decompress and decrypt rights-managed email messages before sending them to the client, as specified in section 3.2.4.3. If the value is FALSE (0), the server will not decompress or decrypt rights-managed email messages before sending them to the client. If the RightsManagementSupport element is not defined, a default value of FALSE is assumed.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyncOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncOptions Constructor

Initializes a new instance of the SyncOptions class.

public SyncOptions();

See Also

SyncOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncOptions Properties

The properties of the SyncOptions class are listed below. For a complete list of SyncOptions class members, see the SyncOptions Members topic.

Public Instance Properties

BodyPartPreference | Contains preference information related to the type and size of information that is returned from searching, synchronizing, or fetching a message part.
BodyPreference | Contains preference information related to the type and size of information that is returned from searching, synchronizing, or fetching.
Class | Specifies the class of the item being added to the collection.
Conflict | Specifies how to resolve the conflict that occurs when an object has been changed on both the client and the server. The value specifies which object—the client object or the server object—to keep if there is a conflict. If value is not defined, the server object will replace the client object when a conflict occurs.
FilterType | Specifies an optional time window for the objects that are sent from the server to the client.
MaxItems | Specifies the maximum number of recipients (that is, the top N most frequently used recipients) to keep synchronized from within the recipient information cache. This element MUST only be included in a request when the value of the CollectionId element (section 2.2.3.30.5) maps to the recipient information cache. The value of the MaxItems element does not specify the maximum estimate of additions and deletions to make to the recipient information cache, it only specifies the number of recipients to keep synchronized. A complete replacement of each recipient would be double the number of MaxItems or items in the store, as each recipient update requires a deletion and an addition.
MIMESupport | Enables MIME support for email items that are sent from the server to the client.
MIMETruncation | Specifies whether the MIME data of the email item SHOULD be truncated when it is sent from the server to the client.
RightsManagementSupport | Specifies how the server returns rights-managed email messages to the client. If the value of this element is TRUE, the server will decompress and decrypt rights-managed email messages before sending them to the client, as specified in section 3.2.4.3. If the value is FALSE (0), the server will not decompress or decrypt rights-managed email messages before sending them to the client. If the RightsManagementSupport element is not defined, a default value of FALSE is assumed.

See Also

SyncOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


BodyPartPreference Property

Aspose.Email

SyncOptions.BodyPartPreference Property

Contains preference information related to the type and size of information that is returned from searching, synchronizing, or fetching a message part.

public BodyPreference} BodyPartPreference {get;}

See Also

SyncOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


BodyPreference Property

Aspose.Email

SyncOptions.BodyPreference Property

Contains preference information related to the type and size of information that is returned from searching, synchronizing, or fetching.

public BodyPreference} BodyPreference {get;}

See Also

SyncOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Class Property

Aspose.Email

SyncOptions.Class Property

Specifies the class of the item being added to the collection.

public AirsyncClass} Class {get; set;}

See Also

SyncOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Conflict Property

Aspose.Email

SyncOptions.Conflict Property

Specifies how to resolve the conflict that occurs when an object has been changed on both the client and the server. The value specifies which object—the client object or the server object—to keep if there is a conflict. If value is not defined, the server object will replace the client object when a conflict occurs.

public BehaviorReplacement} Conflict {get; set;}

See Also

SyncOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


FilterType Property

Aspose.Email

SyncOptions.FilterType Property

Specifies an optional time window for the objects that are sent from the server to the client.

public AirsyncFilterType} FilterType {get; set;}

See Also

SyncOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


MaxItems Property

Aspose.Email

SyncOptions.MaxItems Property

Specifies the maximum number of recipients (that is, the top N most frequently used recipients) to keep synchronized from within the recipient information cache. This element MUST only be included in a request when the value of the CollectionId element (section 2.2.3.30.5) maps to the recipient information cache. The value of the MaxItems element does not specify the maximum estimate of additions and deletions to make to the recipient information cache, it only specifies the number of recipients to keep synchronized. A complete replacement of each recipient would be double the number of MaxItems or items in the store, as each recipient update requires a deletion and an addition.

public Int32} MaxItems {get; set;}

See Also

SyncOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


MIMESupport Property

Aspose.Email

SyncOptions.MIMESupport Property

Enables MIME support for email items that are sent from the server to the client.

public MIMESupport} MIMESupport {get; set;}

See Also

SyncOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


MIMETruncation Property

Aspose.Email

SyncOptions.MIMETruncation Property

Specifies whether the MIME data of the email item SHOULD be truncated when it is sent from the server to the client.

public MIMETruncation} MIMETruncation {get; set;}

See Also

SyncOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


RightsManagementSupport Property

Aspose.Email

SyncOptions.RightsManagementSupport Property

Specifies how the server returns rights-managed email messages to the client. If the value of this element is TRUE, the server will decompress and decrypt rights-managed email messages before sending them to the client, as specified in section 3.2.4.3. If the value is FALSE (0), the server will not decompress or decrypt rights-managed email messages before sending them to the client. If the RightsManagementSupport element is not defined, a default value of FALSE is assumed.

public Boolean} RightsManagementSupport {get; set;}

See Also

SyncOptions Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncRequest Class

Contains Sync request parameters

For a list of all members of this type, see SyncRequest Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.SyncRequest

public class SyncRequest

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SyncRequest Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncRequest Members

SyncRequest overview

Public Instance Constructors

SyncRequest Constructor Initializes a new instance of the SyncRequest class.

Public Instance Properties

Collections | Contains list of objects with commands and options that apply to a particular collection.
HeartbeatInterval | Specifies the number of seconds that the server SHOULD delay a response if no new items are added to the included folders. Valid values for HeartbeatInterval are 60 through 3540 seconds (59 minutes). When the client requests an interval that is outside the acceptable range, the server will send a response that includes a Status value of 14 and a Limit element. Either the HeartbeatInterval or the Wait can be included in a Sync command request, but not both. If both elements are included, the server response will contain a Status value of 4.
Partial | Indicates to the server that the client sent a partial list of collections, in which case the server obtains the rest of the collections from its cache.
Wait | Specifies the number of minutes that the server SHOULD delay a response if no new items are added to the included folders. Valid values for the Wait are 1 through 59. When the client requests a wait interval that is outside the acceptable range, the server will send a response that includes a Status value of 14 and a Limit. Either the Wait or the HeartbeatInterval can be included in a Sync command request, but not both. If both are included, the server response will contain a Status value of 4.
WindowSize | Specifies a maximum number of changed items in a collection or a request that SHOULD be included in the synchronization response. The maximum value for the WindowSize is 512. However, if the WindowSize is set to 512, the server can send Sync response messages that contain less than 512 updates. If the server does not send all the updates in a single message, the Sync response message contains the MoreAvailable, which indicates that there are additional updates on the server to be downloaded to the client. The WindowSize appears only in requests that are sent to the server from the client. If the WindowSize is omitted, the server behaves as if a WindowSize element with a value of 100 were submitted. The server interprets the value 0 (zero) and values above 512 as 512.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyncRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncRequest Constructor

Initializes a new instance of the SyncRequest class.

public SyncRequest();

See Also

SyncRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SyncRequest Properties

The properties of the SyncRequest class are listed below. For a complete list of SyncRequest class members, see the SyncRequest Members topic.

Public Instance Properties

Collections | Contains list of objects with commands and options that apply to a particular collection.
HeartbeatInterval | Specifies the number of seconds that the server SHOULD delay a response if no new items are added to the included folders. Valid values for HeartbeatInterval are 60 through 3540 seconds (59 minutes). When the client requests an interval that is outside the acceptable range, the server will send a response that includes a Status value of 14 and a Limit element. Either the HeartbeatInterval or the Wait can be included in a Sync command request, but not both. If both elements are included, the server response will contain a Status value of 4.
Partial | Indicates to the server that the client sent a partial list of collections, in which case the server obtains the rest of the collections from its cache.
Wait | Specifies the number of minutes that the server SHOULD delay a response if no new items are added to the included folders. Valid values for the Wait are 1 through 59. When the client requests a wait interval that is outside the acceptable range, the server will send a response that includes a Status value of 14 and a Limit. Either the Wait or the HeartbeatInterval can be included in a Sync command request, but not both. If both are included, the server response will contain a Status value of 4.
WindowSize | Specifies a maximum number of changed items in a collection or a request that SHOULD be included in the synchronization response. The maximum value for the WindowSize is 512. However, if the WindowSize is set to 512, the server can send Sync response messages that contain less than 512 updates. If the server does not send all the updates in a single message, the Sync response message contains the MoreAvailable, which indicates that there are additional updates on the server to be downloaded to the client. The WindowSize appears only in requests that are sent to the server from the client. If the WindowSize is omitted, the server behaves as if a WindowSize element with a value of 100 were submitted. The server interprets the value 0 (zero) and values above 512 as 512.

See Also

SyncRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Collections Property

Aspose.Email

SyncRequest.Collections Property

Contains list of objects with commands and options that apply to a particular collection.

public SyncCollectionRequest} Collections {get;}

See Also

SyncRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


HeartbeatInterval Property

Aspose.Email

SyncRequest.HeartbeatInterval Property

Specifies the number of seconds that the server SHOULD delay a response if no new items are added to the included folders. Valid values for HeartbeatInterval are 60 through 3540 seconds (59 minutes). When the client requests an interval that is outside the acceptable range, the server will send a response that includes a Status value of 14 and a Limit element. Either the HeartbeatInterval or the Wait can be included in a Sync command request, but not both. If both elements are included, the server response will contain a Status value of 4.

public Int32} HeartbeatInterval {get; set;}

See Also

SyncRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Partial Property

Aspose.Email

SyncRequest.Partial Property

Indicates to the server that the client sent a partial list of collections, in which case the server obtains the rest of the collections from its cache.

public bool Partial {get; set;}

See Also

SyncRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Wait Property

Aspose.Email

SyncRequest.Wait Property

Specifies the number of minutes that the server SHOULD delay a response if no new items are added to the included folders. Valid values for the Wait are 1 through 59. When the client requests a wait interval that is outside the acceptable range, the server will send a response that includes a Status value of 14 and a Limit. Either the Wait or the HeartbeatInterval can be included in a Sync command request, but not both. If both are included, the server response will contain a Status value of 4.

public Int32} Wait {get; set;}

See Also

SyncRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


WindowSize Property

Aspose.Email

SyncRequest.WindowSize Property

Specifies a maximum number of changed items in a collection or a request that SHOULD be included in the synchronization response. The maximum value for the WindowSize is 512. However, if the WindowSize is set to 512, the server can send Sync response messages that contain less than 512 updates. If the server does not send all the updates in a single message, the Sync response message contains the MoreAvailable, which indicates that there are additional updates on the server to be downloaded to the client. The WindowSize appears only in requests that are sent to the server from the client. If the WindowSize is omitted, the server behaves as if a WindowSize element with a value of 100 were submitted. The server interprets the value 0 (zero) and values above 512 as 512.

public Int32} WindowSize {get; set;}

See Also

SyncRequest Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


UserCreatedFolderTypes Enumeration

Specifies the type of the folder to be created.

public enum UserCreatedFolderTypes

Members

Member Name | Description | Value
UserCreatedFolder | User-created folder (generic) | 1
UserCreatedMailFolder | User-created mail folder | 12
UserCreatedCalendarFolder | User-created Calendar folder | 13
UserCreatedContactsFolder | User-created Contacts folder | 14
UserCreatedTasksFolder | User-created Tasks folder | 15
UserCreatedJournalFolder | User-created Journal folder | 16
UserCreatedNoteFolder | User-created Notes folder | 17

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


UserInformationResponse Class

Contains status of the request and a list of a user’s account information (email addresses).

For a list of all members of this type, see UserInformationResponse Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.UserInformationResponse

public class UserInformationResponse

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

UserInformationResponse Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


UserInformationResponse Members

UserInformationResponse overview

Public Instance Constructors

UserInformationResponse Constructor Initializes a new instance of the UserInformationResponse class.

Public Instance Properties

Accounts | Contains list of objects with users account information.
SMTPAddresses | Specifies one of the user's email addresses. The element is only supported when the protocol version is 12.1 or 14.0.
Status | Indicates the result of the ActiveSync command request.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

UserInformationResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


UserInformationResponse Constructor

Initializes a new instance of the UserInformationResponse class.

public UserInformationResponse();

See Also

UserInformationResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


UserInformationResponse Properties

The properties of the UserInformationResponse class are listed below. For a complete list of UserInformationResponse class members, see the UserInformationResponse Members topic.

Public Instance Properties

Accounts | Contains list of objects with users account information.
SMTPAddresses | Specifies one of the user's email addresses. The element is only supported when the protocol version is 12.1 or 14.0.
Status | Indicates the result of the ActiveSync command request.

See Also

UserInformationResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Accounts Property

Aspose.Email

UserInformationResponse.Accounts Property

Contains list of objects with users account information.

public AccountInformation} Accounts {get;}

See Also

UserInformationResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


SMTPAddresses Property

Aspose.Email

UserInformationResponse.SMTPAddresses Property

Specifies one of the user's email addresses. The element is only supported when the protocol version is 12.1 or 14.0.

public String} SMTPAddresses {get;}

See Also

UserInformationResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Status Property

Aspose.Email

UserInformationResponse.Status Property

Indicates the result of the ActiveSync command request.

public Status Status {get; set;}

See Also

UserInformationResponse Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


UserResponse Enumeration

Indicates whether the meeting is being accepted, tentatively accepted, or declined.

public enum UserResponse

Members

Member Name | Description | Value
Accepted | Meeting is accepted | 1
TentativelyAccepted | Meeting is tentatively accepted | 2
Declined | Meeting is declined | 3

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ValueConverter Class

Class converts ActiveSync protocol version from string representation to enum and back.

For a list of all members of this type, see ValueConverter Members.

System.Object
Aspose.Email.Protocols.ActiveSync.TransportLayer.ValueConverter

public class ValueConverter

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ValueConverter Members | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ValueConverter Members

ValueConverter overview

Public Static Methods

ToASProtocolVersions | Converts ActiveSync protocol version from string representation to enum.
ToString | Overloaded. Converts ActiveSync protocol version from enum to string representation.

Public Instance Constructors

ValueConverter Constructor Initializes a new instance of the ValueConverter class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Overloaded. Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ValueConverter Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ValueConverter Constructor

Initializes a new instance of the ValueConverter class.

public ValueConverter();

See Also

ValueConverter Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ValueConverter Methods

The methods of the ValueConverter class are listed below. For a complete list of ValueConverter class members, see the ValueConverter Members topic.

Public Static Methods

ToASProtocolVersions | Converts ActiveSync protocol version from string representation to enum.
ToString | Overloaded. Converts ActiveSync protocol version from enum to string representation.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Overloaded. Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ValueConverter Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ValueConverter.ToASProtocolVersions Method

Converts ActiveSync protocol version from string representation to enum.

public static ASProtocolVersions ToASProtocolVersions(
string version
);

Parameters

version
String representation of ActiveSync protocol version

Return Value

Returns ActiveSync protocol version.

See Also

ValueConverter Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ToString Method

Aspose.Email

ValueConverter.ToString Method

Converts ActiveSync protocol version from enum to string representation.

Overload List

Inherited from Object.

public virtual string ToString();

Converts ActiveSync protocol version from enum to string representation.

public static string ToString(ASProtocolVersions);

See Also

ValueConverter Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


ValueConverter.ToString Method (ASProtocolVersions)

Converts ActiveSync protocol version from enum to string representation.

public static string ToString(
ASProtocolVersions version
);

Parameters

version
ActiveSync protocol version

Return Value

Returns string representation of ActiveSync protocol version.

See Also

ValueConverter Class | Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace | ValueConverter.ToString Overload List


Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces

Aspose.Email

Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces Namespace

Namespace hierarchy

Enumerations

Enumeration | Description
AirSync | AirSync namespace of the ActiveSync protocol
AirSyncBase | AirSyncBase namespace of the ActiveSync protocol
Calendar | Calendar namespace of the ActiveSync protocol
ComposeMail | ComposeMail namespace of the ActiveSync protocol
Contacts | Contacts namespace of the ActiveSync protocol
Contacts2 | Contacts2 namespace of the ActiveSync protocol
DocumentLibrary | DocumentLibrary namespace of the ActiveSync protocol
Email | Email namespace of the ActiveSync protocol
Email2 | Email2 namespace of the ActiveSync protocol
FolderHierarchy | FolderHierarchy namespace of the ActiveSync protocol
GAL | GAL namespace of the ActiveSync protocol
GetItemEstimate | GetItemEstimate namespace of the ActiveSync protocol
ItemOperations | ItemOperations namespace of the ActiveSync protocol
MeetingResponse | MeetingResponse namespace of the ActiveSync protocol
Move | Move namespace of the ActiveSync protocol
Namespace | ActiveSync Code Pages
Notes | Notes namespace of the ActiveSync protocol
Ping | Ping namespace of the ActiveSync protocol
Provision | Provision namespace of the ActiveSync protocol
ResolveRecipients | ResolveRecipients namespace of the ActiveSync protocol
RightsManagement | RightsManagement namespace of the ActiveSync protocol
Search | Search namespace of the ActiveSync protocol
Settings | Settings namespace of the ActiveSync protocol
Tasks | Tasks namespace of the ActiveSync protocol
ValidateCert | ValidateCert namespace of the ActiveSync protocol


AirSync Enumeration

AirSync namespace of the ActiveSync protocol

public enum AirSync

Members

Member Name | Description | Value
Sync | The Sync element is a required element in Sync command requests and responses that identifies the body of the HTTP POST as containing a Sync command (section 2.2.2.19). It is the top-level element in the XML stream. | 5
Responses | Contains responses to operations that are processed by the server. | 6
Add | Creates a new object in a collection on the client or on the server. | 7
Change | Modifies properties of an existing object on the client device or the server. | 8
Delete | Deletes an object on the client device or the server. The object is identified by its ServerId element. | 9
Fetch | Used to request the application data of an item that was truncated in a synchronization response from the server. | 10
SyncKey | Contains a value that is used by the server to mark the synchronization state of a collection. | 11
ClientId | Contains a unique identifier (typically an integer) that is generated by the client to temporarily identify a new object that is being created by using the Add element. | 12
ServerId | It represents a unique identifier that is assigned by the server to each object that can be synchronized. | 13
Status | Indicates the reason for the failure of a command request. | 14
Collection | Contains commands and options that apply to a particular collection. | 15
Class | Identifies the class of the item being added to the collection. | 16
CollectionId | Specifies the server ID of the folder to be synchronized. | 18
GetChanges | Requests that the server include in its response any pending changes to the collection that is specified by the ServerId element (section 2.2.3.151.6). | 19
MoreAvailable | Indicates there are more changes than the number that are requested in the WindowSize element (section 2.2.3.183). | 20
WindowSize | Specifies a maximum number of changed items in a collection or a request that SHOULD be included in the synchronization response. | 21
Commands | Contains operations that apply to a collection. | 22
Options | Contains elements that control certain aspects of how the synchronization is performed. | 23
FilterType | Specifies an optional time window for the objects that are sent from the server to the client. It applies to email and calendar collections. | 24
Conflict | Specifies how to resolve the conflict that occurs when an object has been changed on both the client and the server. | 27
Collections | Serves as a container for the Collection element. | 28
ApplicationData | Contains data for a particular object, such as a contact, email message, calendar appointment, or task item. Can be used to change items, add items, or fetch items on the client device or server. | 29
DeletesAsMoves | Indicates that any deleted items SHOULD be moved to the Deleted Items folder. | 30
Supported | Specifies which contact and calendar elements in a Sync request are managed by the client. | 32
SoftDelete | Deletes an object from the client when it falls outside the FilterType (section 2.2.3.64.2) results or it is no longer included as part of the SyncOptions (section 2.2.3.115.5) instructions. | 33
MIMESupport | Enables MIME support for email items that are sent from the server to the client. | 34
MIMETruncation | Specifies whether the MIME data of the email item SHOULD be truncated when it is sent from the server to the client. | 35
Wait | Specifies the number of minutes that the server SHOULD delay a response if no new items are added to the included folders, as specified in section 3.1.5.4. | 36
Limit | Specifies either the maximum number of collections that can be synchronized or the maximum/minimum value that is allowed for the Wait interval (section 2.2.3.182) or HeartbeatInterval interval (section 2.2.3.79.2). | 37
Partial | Indicates to the server that the client sent a partial list of collections, in which case the server obtains the rest of the collections from its cache. | 38
ConversationMode | Specifies whether to include items that are included within the conversation modality within the results of the Sync response. | 39
MaxItems | Specifies the maximum number of recipients (that is, the top N most frequently used recipients) to keep synchronized from within the recipient information cache. | 40
HeartbeatInterval | Specifies the number of seconds that the server SHOULD delay a response if no new items are added to the included folders, as specified in section 3.1.5.4. | 41

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces Namespace


AirSyncBase Enumeration

AirSyncBase namespace of the ActiveSync protocol

public enum AirSyncBase

Members

Member Name | Description | Value
BodyPreference | A collection of elements that sets the preference information related to the type and size of information that is returned from searching, synchronizing, or fetching. | 5
Type | The preferred format type of the body content of the item. | 6
TruncationSize | Specifies the size, in bytes, of the content that the client wants to search, synchronize, or fetch. | 7
AllOrNone | Specifies whether to search, synchronize, or retrieve all or none of the content based on the TruncationSize element. | 8
Body | A collection of elements that specifies a free-form, variable-length data field associated with a stored item on the server. | 10
Data | The body of the calendar item, contact, document, e-mail, or task. | 11
EstimatedDataSize | An informational estimate of the size of the data associated with the item's Body element. | 12
Truncated | Specifies whether the body of the item has been truncated according to the BodyPartPreference element indicated by the client. | 13
Attachments | A collection of elements that contains one or more attachment items. | 14
Attachment | Specifies the attachment information for a single attachment item. | 15
DisplayName | The display name of the attachment. | 16
FileReference | A unique identifier that is assigned by the server to each attachment to a message. | 17
Method | Identifies the method in which the attachment was attached. | 18
ContentId | Contains the unique object ID for an attachment. | 19
ContentLocation | Contains the relative URI for an attachment, which is used to match a reference to an inline attachment in an HTML message to the attachment in the attachments table. | 20
IsInline | Specifies whether the attachment is embedded in the message. | 21
NativeBodyType | The original format type of the item. | 22
ContentType | Type of the content | 23
Preview | The preferred length of the message preview to be returned to the client. | 24
BodyPartPreference | A collection of elements that sets the preference information related to the type and size of information that is returned from searching, synchronizing, or fetching a BodyPart. | 25
BodyPart | A collection of elements that contains the message part of the body of an e-mail. | 26
Status | The status of the Data element within the BodyPart response. | 27

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces Namespace


Calendar Enumeration

Calendar namespace of the ActiveSync protocol

public enum Calendar

Members

Member Name | Description | Value
TimeZone | The time zone of the calendar item. | 5
AllDayEvent | Specifies whether the event represented by the calendar item or exception item runs for the entire day. | 6
Attendees | The collection of attendees for the calendar item. | 7
Attendee | An attendee who is invited to the event. | 8
Email | The e-mail address of the attendee. | 9
Name | The name of the attendee. | 10
BusyStatus | Specifies whether the recipient is busy at the specified time. | 13
Categories | The collection of categories for the calendar item or exception item. | 14
Category | A category that is assigned to the calendar item or exception item. | 15
DtStamp | The date and time at which the calendar item was created or modified, or the date and time at which the exception item was created. | 17
EndTime | The end time of the calendar item or exception item. | 18
Exception | An exception to the calendar item's recurrence pattern. | 19
Exceptions | A collection of exceptions to the recurrence pattern of the calendar item. | 20
Deleted | Specifies whether the exception has been deleted. | 21
ExceptionStartTime | The start time of the original recurring meeting. | 22
Location | The place where the event specified by the calendar item or exception item occurs. | 23
MeetingStatus | The status of the meeting. | 24
OrganizerEmail | The e-mail address of the user who created the calendar item. | 25
OrganizerName | The name of the user who created the calendar item. | 26
Recurrence | The recurrence information for the calendar item. | 27
Type | The type of the recurrence. | 28
Until | The end date and time of the recurrence. | 29
Occurrences | The number of recurrences. | 30
Interval | The interval between recurrences. | 31
DayOfWeek | The day of the week for the recurrence. | 32
DayOfMonth | The day of the month of the recurrence. | 33
WeekOfMonth | The week of the month for the recurrence. | 34
MonthOfYear | The month of the year for the recurrence. | 35
Reminder | The number of minutes before the calendar item's start time to display a reminder notice. | 36
Sensitivity | The recommended privacy policy for this calendar item or exception item. | 37
Subject | The subject of the calendar item or exception item. | 38
StartTime | The start time of the calendar item or exception item. | 39
UID | A unique, 300 digit hexadecimal ID generated by the client when the calendar item is created. | 40
AttendeeStatus | The attendee's acceptance status. | 41
AttendeeType | Specifies whether the attendee is required, optional, or a resource. | 42
DisallowNewTimeProposal | Specifies whether recipients of the meeting request can propose a new time for the meeting. | 51
ResponseRequested | Specifies whether a response to the meeting request is required. | 52
AppointmentReplyTime | The date and time that the user responded to the meeting request or to the meeting exception request. | 53
ResponseType | The type of response made by the user to a meeting request. | 54
CalendarType | The calendar system used by the recurrence. | 55
IsLeapMonth | Specifies whether the recurrence of the appointment is to take place on the embolismic (leap) month. | 56
FirstDayOfWeek | Specifies which day is considered the first day of the calendar week for the recurrence. | 57
OnlineMeetingConfLink | A Globally Routable User Agent URI (GRUU) ([MS-SIPRE]) for an online meeting. | 58
OnlineMeetingExternalLink | A Uniform Resource Locator (URL) for an online meeting. | 59

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces Namespace


ComposeMail Enumeration

ComposeMail namespace of the ActiveSync protocol

public enum ComposeMail

Members

Member Name | Description | Value
SendMail | The SendMail element is a required element in SendMail command requests and responses that identifies the body of the HTTP POST as containing a SendMail command (section 2.2.2.15). | 5
SmartForward | The SmartForward element is a required element in SmartForward command requests and responses that identifies the body of the HTTP POST as containing a SmartForward command (section 2.2.2.17). | 6
SmartReply | The SmartReply element is a required element in SmartReply command requests and responses that identifies the body of the HTTP POST as containing a SmartReply command (section 2.2.2.18). | 7
SaveInSentItems | SaveInSentItems element specifies whether a copy of the message will be stored in the Sent Items folder. | 8
ReplaceMime | Specifies whether the client is sending the entire message. | 9
Source | Contains information about the source message. | 11
FolderId | Specifies the folder ID for the source message, which is returned in the FolderSync command response message (section 2.2.2.4.2). | 12
ItemId | Specifies the item ID for the source message, which is returned in the Sync command response message (section 2.2.2.19.2). | 13
LongId | This element specifies the long ID for the source meeting request, which is returned in the Search command response message (section 2.2.2.14.2). | 14
InstanceId | The InstanceId element is an optional child element of the Source element in SmartForward command requests and SmartReply command requests that specifies the instance of a recurrence for the source item. | 15
Mime | Contains the MIME-encoded message. | 16
ClientId | Specifies the client's unique message ID (MID). | 17
Status | Indicates the reason for the failure of a command request. | 18
AccountId | Identifies the account from which an email is sent. | 19

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces Namespace


Contacts Enumeration

Contacts namespace of the ActiveSync protocol

public enum Contacts

Members

Member Name | Description | Value
Anniversary | The wedding anniversary date for the contact. | 5
AssistantName | The name of the contact's assistant. | 6
AssistantPhoneNumber | The phone number of the contact's assistant. | 7
Birthday | The birth date of the contact. | 8
Business2PhoneNumber | The second business telephone number for the contact. | 12
BusinessAddressCity | The business city of the contact. | 13
BusinessAddressCountry | The business country/region for the contact. | 14
BusinessAddressPostalCode | The business postal code for the contact. | 15
BusinessAddressState | The business state for the contact. | 16
BusinessAddressStreet | The business street address for the contact. | 17
BusinessFaxNumber | The business fax number for the contact. | 18
BusinessPhoneNumber | The business telephone number for the contact. | 19
CarPhoneNumber | The car telephone number for the contact. | 20
Categories | A collection of user labels assigned to the contact. | 21
Category | A category that is assigned to the contact. | 22
Children | A collection of the contact's children. | 23
Child | One of the contact’s children. | 24
CompanyName | The company name for the contact. | 25
Department | The department name for the contact. | 26
Email1Address | The first e-mail address for the contact. | 27
Email2Address | The second e-mail address for the contact. | 28
Email3Address | The third e-mail address for the contact. | 29
FileAs | The filing string for the contact. | 30
FirstName | The contact's first name. | 31
Home2PhoneNumber | The second home phone number for the contact. | 32
HomeAddressCity | The home city for the contact. | 33
HomeAddressCountry | The home country/region for the contact. | 34
HomeAddressPostalCode | The home postal code for the contact. | 35
HomeAddressState | The home state for the contact. | 36
HomeAddressStreet | The home street address for the contact. | 37
HomeFaxNumber | The home fax number for the contact. | 38
HomePhoneNumber | The home phone number for the contact. | 39
JobTitle | The contact's job title. | 40
LastName | The contact's last name. | 41
MiddleName | The contact's middle name. | 42
MobilePhoneNumber | The mobile phone number for the contact. | 43
OfficeLocation | The office location for the contact. | 44
OtherAddressCity | The city of the contact's alternative address. | 45
OtherAddressCountry | The country/region of the contact's alternative address. | 46
OtherAddressPostalCode | The postal code of the contact's alternative address. | 47
OtherAddressState | The state of the contact's alternative address. | 48
OtherAddressStreet | The street address of the contact's alternative address. | 49
PagerNumber | The pager number for the contact. | 50
RadioPhoneNumber | The radio telephone number for the contact. | 51
Spouse | The name of the contact's spouse/partner. | 52
Suffix | The suffix for the contact's name. | 53
Title | The contact's business title. | 54
WebPage | The Web site or personal Web page for the contact. | 55
YomiCompanyName | The Japanese phonetic rendering of the company name for the contact. | 56
YomiFirstName | The Japanese phonetic rendering of the first name of the contact. | 57
YomiLastName | The Japanese phonetic rendering of the last name of the contact. | 58
Picture | The file, which is encoded with base64 encoding, containing the picture of the contact. | 60
Alias | The user's alias. | 61
WeightedRank | The rank this entry possesses in the recipient information cache. | 62

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces Namespace


Contacts2 Enumeration

Contacts2 namespace of the ActiveSync protocol

public enum Contacts2

Members

Member Name | Description | Value
CustomerId | The customer identifier (ID) for the contact. | 5
GovernmentId | The government-assigned identifier (ID) for the contact. | 6
IMAddress | The instant messaging address for the contact. | 7
IMAddress2 | The alternative instant messaging address for the contact. | 8
IMAddress3 | The tertiary instant messaging address for the contact. | 9
ManagerName | The distinguished name (DN) of the manager for the contact. | 10
CompanyMainPhone | The main telephone number for the contact's company. | 11
AccountName | The account name and/or number for the contact. | 12
NickName | The nickname for the contact. | 13
MMS | The Multimedia Messaging Service (MMS) address for the contact. | 14

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces Namespace


DocumentLibrary Enumeration

DocumentLibrary namespace of the ActiveSync protocol

public enum DocumentLibrary

Members

Member Name | Description | Value
LinkId | The link to the document, specified as a Uniform Resource Identifier (URI). | 5
DisplayName | The name of the document, as displayed by the client. | 6
IsFolder | Specifies whether the item is a folder or a document. | 7
CreationDate | The date and time when the document was first created. | 8
LastModifiedDate | The date and time when the document or its properties was last modified. | 9
IsHidden | Specifies whether this is a hidden object. | 10
ContentLength | The estimated size of the document, in bytes. | 11
ContentType | The Multipurpose Internet Mail Extensions (MIME) type of the binary-encoded content or content encoded with base64 encoding. | 12

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces Namespace


Email Enumeration

Email namespace of the ActiveSync protocol

public enum Email

Members

Member Name | Description | Value
DateReceived | Specifies the date and time that the message was received on the server. | 15
DisplayTo | Specifies the names of the primary recipients of the message. | 17
Importance | Specifies the importance of the message, as determined by the sender. | 18
MessageClass | Specifies the message class of this e-mail message. | 19
Subject | Specifies the subject of the e-mail message or the subject of the flag as it would appear in a task list. | 20
Read | Specifies whether the message has been read. | 21
To | Specifies the list of recipients | 22
Cc | Specifies the list of secondary recipients. | 23
From | Specifies the e-mail address of the message sender. | 24
ReplyTo | Specifies the e-mail address to which replies will be addressed by default. | 25
AllDayEvent | Specifies whether the calendar item is an all-day event. | 26
Categories | Specifies the user-selected categories for this message. | 27
Category | Specifies the category for this e-mail item. | 28
DtStamp | Specifies the date and time that the calendar item was created. | 29
EndTime | Specifies the date and time that the meeting ends. | 30
InstanceType | Specifies the type of calendar item. | 31
BusyStatus | Specifies the intended busy status for the meeting request. | 32
Location | Specifies the location for the calendar item. | 33
MeetingRequest | Specifies a meeting request accompanying an e-mail message. | 34
Organizer | Specifies the e-mail alias of the meeting organizer. | 35
RecurrenceId | Specifies a specific instance of a recurring calendar item. | 36
Reminder | Specifies the number of seconds prior to the calendar item's start time that a reminder is displayed. | 37
ResponseRequested | Specifies whether the originator of the meeting has requested a response. | 38
Recurrences | Specifies a collection of Recurrence elements. | 39
Recurrence | Specifies a collection of Recurrence elements that describe when and how often this meeting recurs. | 40
Type | Specifies the recurrence type of the recurring meeting. | 41
Until | Specifies the end time of a series of recurrence meetings. | 42
Occurrences | Specifies the number of occurrences before the series of recurring meeting ends. | 43
Interval | Specifies the interval between recurrences of the recurring meeting. | 44
DayOfWeek | Specifies the day of the week of the recurring meeting. | 45
DayOfMonth | Specifies the day of the month of the recurring meeting. | 46
WeekOfMonth | Specifies the week of the month of the recurring meeting. | 47
MonthOfYear | Specifies the month of the year of the recurring meeting. | 48
StartTime | Specifies the date and time that the meeting starts. | 49
Sensitivity | Specifies the confidentiality level of the meeting request. | 50
TimeZone | Specifies the time zone specified when the calendar item was created. | 51
GlobalObjId | Specifies a 76-digit hexadecimal ID generated by the client for the meeting request. | 52
ThreadTopic | Specifies the topic used in conversation reading. | 53
InternetCPID | Specifies the original code page ID from the MIME message. | 57
Flag | Specifies the flag associated with the item, along with the item's current status. | 58
Status | Specifies the current status of the flag. | 59
ContentClass | Specifies the content class of the data. | 60
FlagType | Specifies the type of the flag. | 61
CompleteTime | Specifies the time at which the flagged item was marked as finished. | 62
DisallowNewTimeProposal | Specifies whether recipients can propose a new meeting time. | 63

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces Namespace


Email2 Enumeration

Email2 namespace of the ActiveSync protocol

public enum Email2

Members

Member Name | Description | Value
UmCallerID | Specifies the callback telephone number of the person who called or left an electronic voice message. | 5
UmUserNotes | Specifies user notes related to an electronic voice message. | 6
UmAttDuration | Specifies the duration of electronic voicemail attachments. | 7
UmAttOrder | Specifies the order of electronic voice mail attachments. | 8
ConversationId | Specifies a unique identifier for a conversation. | 9
ConversationIndex | Specifies a set of dates and times used by clients to generate a conversation tree view. | 10
LastVerbExecuted | Specifies the last action, such as reply or forward, which was taken on the message so that the client can display the related icon. | 11
LastVerbExecutionTime | Specifies the time when the email2:LastVerbExecuted was performed on the message. | 12
ReceivedAsBcc | Specifies whether the recipient was blind carbon copied on a message. | 13
Sender | Specifies the user that actually sent the message when the message was not sent by the user identified by From. | 14
CalendarType | Specifies the type of calendar associated with the recurrence. | 15
IsLeapMonth | Specifies whether the recurrence takes place in the leap month of the given year. | 16
AccountId | Specifies the ID of the account that received the message. | 17
FirstDayOfWeek | Specifies the day that is considered the first day of the calendar week for this recurrence. | 18
MeetingMessageType | Specifies the type of the meeting message. | 19

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces Namespace


FolderHierarchy Enumeration

FolderHierarchy namespace of the ActiveSync protocol

public enum FolderHierarchy

Members

Member Name | Description | Value
DisplayName | Specifies the name of the folder that is shown to the user. | 7
ServerId | Identifies a folder on a server. | 8
ParentId | Specifies the server ID of the parent folder of the folder on the server | 9
Type | Specifies the type of the folder to be created. | 10
Status | Indicates the reason for the failure of a command request. | 12
Changes | Contains changes to the folder hierarchy. | 14
Add | Creates a new folder on the client | 15
Delete | Specifies that a folder on the server was deleted since the last folder synchronization. | 16
Update | Identifies a folder on the server that has been updated (renamed or moved). | 17
SyncKey | It is used by the server to track the current state of the client. | 18
FolderCreate | The FolderCreate element is a required element in FolderCreate command requests and FolderCreate command responses that identifies the body of the HTTP POST as containing a FolderCreate command (section 2.2.2.2). | 19
FolderDelete | The FolderDelete element is a required element in FolderDelete command requests and FolderDelete command responses that identifies the body of the HTTP POST as containing a FolderDelete command (section 2.2.2.3). | 20
FolderUpdate | The FolderUpdate element is a required element in FolderUpdate command requests and FolderUpdate command responses that identifies the body of the HTTP POST as containing a FolderUpdate command (section 2.2.2.5). | 21
FolderSync | The FolderSync element is a required element in FolderSync command requests and FolderSync command responses that identifies the body of the HTTP POST as containing a FolderSync command (section 2.2.2.4). | 22
Count | Specifies the number of added, deleted, and updated folders on the server since the last folder synchronization. | 23

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces Namespace


GAL Enumeration

GAL namespace of the ActiveSync protocol

public enum GAL

Members

Member Name | Description | Value
DisplayName | Contains the display name of a recipient in the GAL that matched the search criteria from the corresponding Search command request. | 5
Phone | Contains the phone number of a recipient in the GAL that matched the search criteria from the corresponding Search command request. | 6
Office | Contains the office location or number of a recipient in the GAL that matched the search criteria from the corresponding Search command request. | 7
Title | Contains the title of a recipient in the GAL that matched the search criteria from the corresponding Search command request. | 8
Company | Contains the company of a recipient in the GAL that matched the search criteria from the corresponding Search command request. | 9
Alias | Contains the alias of a recipient in the GAL that matched the search criteria from the corresponding Search command request. | 10
FirstName | Contains the first name of a recipient in the GAL that matched the search criteria from the corresponding Search command request. | 11
LastName | Contains the last name of a recipient in the GAL that matched the search criteria from the corresponding Search command request. | 12
HomePhone | Contains the home phone number of a recipient in the GAL that matched the search criteria from the corresponding Search command request. | 13
MobilePhone | Contains the mobile phone number of a recipient in the GAL that matched the search criteria from the corresponding Search command request. | 14
EmailAddress | Contains the email address of a recipient in the GAL that matched the search criteria from the corresponding Search command request. | 15
Picture | Contains the data related to the contact photos. | 16
Status | Indicates the reason for the failure of a command request. | 17
Data | Contains the binary data of the contact photo. | 18

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces Namespace


GetItemEstimate Enumeration

GetItemEstimate namespace of the ActiveSync protocol

public enum GetItemEstimate

Members

Member Name | Description | Value
GetItemEstimate | The GetItemEstimate element is a required element in GetItemEstimate command requests and GetItemEstimate command responses that identifies the body of the HTTP POST as containing a GetItemEstimate command (section 2.2.2.7). | 5
Version | The Version tag is supported only when the MS-ASProtocolVersion header is set to 12.1. | 6
Collections | Serves as a container for one to 300 Collection elements. | 7
Collection | Contains elements that apply to a particular collection. | 8
Class | Assigns the filters within the airsync:Options container to a given class. | 9
CollectionId | Specifies the server ID of the collection from which the item estimate is being obtained. | 10
DateTime | The DateTime tag is supported only when the MS-ASProtocolVersion header is set to 12.1. | 11
Estimate | Specifies the estimated number of items in the collection or folder that have to be synchronized. | 12
Response | Contains elements that describe estimated changes. | 13
Status | Indicates the reason for the failure of a command request. | 14

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces Namespace


ItemOperations Enumeration

ItemOperations namespace of the ActiveSync protocol

public enum ItemOperations

Members

Member Name | Description | Value
ItemOperations | The ItemOperations element is a required element in ItemOperations command requests and ItemOperations command responses that identifies the body of the HTTP POST as containing an ItemOperations command (section 2.2.2.8). | 5
Fetch | Retrieves an item from the server. | 6
Store | Specifies the name of the store to which the parent operation applies. | 7
Options | Contains the options for the EmptyFolderContents operation, the Fetch operation, or the Move operation. | 8
Range | Specifies the range of bytes that the client can receive in response to the Fetch (section 2.2.3.63.1) operation for a document library item. | 9
Total | Indicates the total size of an item on the server, in bytes. | 10
Properties | Contains the properties that are returned for item(s) in the response. | 11
Data | Contains the item content for inline content responses. | 12
Status | Indicates the result of an operation. | 13
Response | Contains the operation responses. | 14
Version | Indicates the time at which a document item was last modified. | 15
Schema | Specifies the schema of the item to be fetched. | 16
Part | Specifies an integer index into the metadata of the multipart response. | 17
EmptyFolderContents | Identifies the body of the request or response as containing the operation that deletes the contents of a folder. | 18
DeleteSubFolders | Indicates whether to delete the subfolders of the specified folder. | 19
UserName | Specifies the username of the account leveraged to fetch the desired item. | 20
Password | Specifies the password for the given UserName (section 2.2.3.177.1). | 21
Move | Identifies the body of the request or response as containing the operation that moves a given conversation. | 22
DstFldId | Specifies the server ID of the destination folder (that is, the folder to which the items are moved). | 23
ConversationId | Specifies the conversation to be moved. | 24
MoveAlways | Indicates whether to always move the specified conversation, including all future emails in the conversation, to the folder specified by the DstFldId element (section 2.2.3.49.1) value. | 25

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces Namespace


MeetingResponse Enumeration

MeetingResponse namespace of the ActiveSync protocol

public enum MeetingResponse

Members

Member Name | Description | Value
CalendarId | Specifies the server ID of the calendar item. The CalendarId element value can be up to 64 characters in length. | 5
CollectionId | Specifies the folder that contains the meeting request. | 6
MeetingResponse | Identifies the body of the HTTP POST as containing a MeetingResponse command (section 2.2.2.9). | 7
RequestId | Specifies the server ID of the meeting request message item. | 8
Request | Specifies the meeting request that is being responded to, the response to that meeting request, and the folder on the server that the meeting request is located in. | 9
Result | Serves as a container for elements that are sent to the client in the response. | 10
Status | Contains the operation responses. | 11
UserResponse | Indicates whether the meeting is being accepted, tentatively accepted, or declined. | 12
InstanceId | Specifies the instance of the recurring meeting to be modified. | 14

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces Namespace


Move Enumeration

Move namespace of the ActiveSync protocol

public enum Move

Members

Member Name | Description | Value
MoveItems | The MoveItems element is a required element in MoveItems command requests and responses that identifies the body of the HTTP POST as containing a MoveItems command (section 2.2.2.10). | 5
Move | Contains elements that describe details of the items to be moved. | 6
SrcMsgId | Specifies the server ID of the item to be moved. | 7
SrcFldId | Specifies the server ID of the source folder (that is, the folder that contains the items to be moved). | 8
DstFldId | Specifies the server ID of the destination folder (that is, the folder to which the items are moved). | 9
Response | Serves as a container for elements that describe the moved items. | 10
Status | Indicates the result of an operation. | 11
DstMsgId | Specifies the new server ID of the item after the item is moved to the destination folder. | 12

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces Namespace


Namespace Enumeration

ActiveSync Code Pages

public enum Namespace

Members

Member Name | Description | Value
AirSync | AirSync code page | 0
Contacts | Contacts code page | 1
Email | Email code page | 2
AirNotify | AirNotify code page No longer used !!! | 3
Calendar | Calendar code page | 4
Move | Move code page | 5
GetItemEstimate | GetItemEstimate code page | 6
FolderHierarchy | FolderHierarchy code page | 7
MeetingResponse | MeetingResponse code page | 8
Tasks | Tasks code page | 9
ResolveRecipients | ResolveRecipients code page | 10
ValidateCert | ValidateCert code page | 11
Contacts2 | Contacts2 code page | 12
Ping | Ping code page | 13
Provision | Provision code page | 14
Search | Search code page | 15
Gal | Gal code page | 16
AirSyncBase | AirSyncBase code page | 17
Settings | Settings code page | 18
DocumentLibrary | DocumentLibrary code page | 19
ItemOperations | ItemOperations code page | 20
ComposeMail | ComposeMail code page | 21
Email2 | Email2 code page | 22
Notes | Notes code page | 23
RightsManagement | RightsManagement code page | 24

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces Namespace


Notes Enumeration

Notes namespace of the ActiveSync protocol

public enum Notes

Members

Member Name | Description | Value
Subject | The subject of the note. | 5
MessageClass | The form of the message. | 6
LastModifiedDate | The day and time that the note was last changed by the user. | 7
Categories | A collection of labels assigned to the note. | 8
Category | One of the user-assigned labels applied to the note. | 9

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces Namespace


Ping Enumeration

Ping namespace of the ActiveSync protocol

public enum Ping

Members

Member Name | Description | Value
Ping | The Ping element is a required element in Ping command requests and responses that identifies the body of the HTTP POST as containing a Ping command (section 2.2.2.11). | 5
AutdState | Per MS-ASWBXML, this tag is not used by protocol | 6
Status | Indicates the result of an operation. | 7
HeartbeatInterval | Specifies the length of time, in seconds, that the server SHOULD wait before sending a response if no new items are added to the specified set of folders, as specified in section 3.1.5.6. | 8
Folders | Serves as a container for Folder elements. | 9
Folder | Identifies the folder and folder type to be monitored by the client. | 10
Id | Specifies the server ID of the folder to be monitored. | 11
Class | Specifies the content class of the folder to be monitored. | 12
MaxFolders | Specifies the maximum number of folders that can be monitored. | 13

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces Namespace


Provision Enumeration

Provision namespace of the ActiveSync protocol

public enum Provision

Members

Member Name | Description | Value
Provision | The capabilities and permissions for the device. | 5
Policies | A collection of security policies. | 6
Policy | A security policy. | 7
PolicyType | Specifies the format in which the policy settings are to be provided. | 8
PolicyKey | Used by the server to mark the state of policy settings on the client. | 9
Data | The settings for a policy. | 10
Status | Indicates success or failure of specific parts of a command. | 11
RemoteWipe | Specifies either a remote wipe directive from the server or a client's confirmation of a remote wipe directive. | 12
EASProvisionDoc | The collection of security settings for device provisioning. | 13
DevicePasswordEnabled | Indicates whether a client device requires a password. | 14
AlphanumericDevicePasswordRequired | Indicates whether a client device requires an alphanumeric password. | 15
RequireStorageCardEncryption | Indicates whether the device has to encrypt content that is stored on the storage card. | 16
PasswordRecoveryEnabled | Indicates whether to enable a recovery password to be sent to the server by using the Settings command. | 17
AttachmentsEnabled | Indicates whether email attachments are enabled. | 19
MinDevicePasswordLength | The minimum device password length that the user can enter | 20
MaxInactivityTimeDeviceLock | The number of seconds of inactivity before the device locks itself. | 21
MaxDevicePasswordFailedAttempts | The number of password failures that are permitted before the device is wiped. | 22
MaxAttachmentSize | The maximum attachment size, as determined by the security policy. | 23
AllowSimpleDevicePassword | Whether the device allows simple passwords. | 24
DevicePasswordExpiration | Whether the password expires after the specified number of days, as determined by the policy. | 25
DevicePasswordHistory | The minimum number of previously used passwords the client device stores to prevent reuse. | 26
AllowStorageCard | Whether the device allows the use of the storage card. | 27
AllowCamera | Whether the device allows the use of the built-in camera. | 28
RequireDeviceEncryption | Whether the device uses encryption. | 29
AllowUnsignedApplications | Whether the device allows unsigned applications to execute. | 30
AllowUnsignedInstallationPackages | Whether the device allows unsigned cabinet (.cab) files to be installed. | 31
MinDevicePasswordComplexCharacters | The minimum number of complex characters (numbers and symbols) contained within the password. | 32
AllowWiFi | Whether the device allows the use of Wi-Fi connections. | 33
AllowTextMessaging | Whether the device allows Short Message Service (SMS)/text messaging. | 34
AllowPOPIMAPEmail | Whether the device allows access to POP/IMAP email. | 35
AllowBluetooth | Whether Bluetooth and hands-free profiles are allowed on the device. | 36
AllowIrDA | Whether the device allows the use of IrDA (infrared) connections. | 37
RequireManualSyncWhenRoaming | Whether the device requires manual synchronization when the device is roaming. | 38
AllowDesktopSync | Whether the device allows synchronization with Desktop ActiveSync. | 39
MaxCalendarAgeFilter | The maximum number of calendar days that can be synchronized. | 40
AllowHTMLEmail | Whether the device uses HTML-formatted email. | 41
MaxEmailAgeFilter | The email age limit for synchronization. | 42
MaxEmailBodyTruncationSize | The truncation size for plain text–formatted email messages. | 43
MaxEmailHTMLBodyTruncationSize | The truncation size for HTML-formatted email messages. | 44
RequireSignedSMIMEMessages | Whether the device is required to send signed S/MIME messages. | 45
RequireEncryptedSMIMEMessages | Whether the device is required to send encrypted messages. | 46
RequireSignedSMIMEAlgorithm | The algorithm to be used when signing a message. | 47
RequireEncryptionSMIMEAlgorithm | The algorithm to be used when encrypting a message. | 48
AllowSMIMEEncryptionAlgorithmNegotiation | Whether the device can negotiate the encryption algorithm to be used for signing. | 49
AllowSMIMESoftCerts | Whether the device uses soft certificates to sign outgoing messages. | 50
AllowBrowser | Whether the device allows the use of a web browser. | 51
AllowConsumerEmail | Whether the device allows the use of personal email. | 52
AllowRemoteDesktop | Whether the device allows the use of Remote Desktop. | 53
AllowInternetSharing | Whether the device allows the use of Internet Sharing. | 54
UnapprovedInROMApplicationList | A list of in-ROM applications that are not approved for execution. | 55
ApplicationName | The name of an in-ROM application (.exe file) that is not approved for execution. | 56
ApprovedApplicationList | A list of in-RAM applications that are approved for execution. | 57
Hash | The SHA-1 hash of an in-memory application that is approved for execution. | 58

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces Namespace


ResolveRecipients Enumeration

ResolveRecipients namespace of the ActiveSync protocol

public enum ResolveRecipients

Members

Member Name | Description | Value
ResolveRecipients | The ResolveRecipients element is a required element in ResolveRecipients command requests and responses that identifies the body of the HTTP POST as containing a ResolveRecipients command (section 2.2.2.13). | 5
Response | Contains information as to whether the recipient was resolved. | 6
Status | Indicates the result of an operation. | 7
Type | Indicates the type of recipient, either a contact entry (2) or a GAL entry (1). | 8
Recipient | Represents a single recipient that has been resolved. | 9
DisplayName | Contains the display name of the recipient. | 10
EmailAddress | Contains the email address of the recipient, in SMTP format. | 11
Certificates | Contains information about the certificates for a recipient. | 12
Certificate | Contains the X509 certificate binary large object (BLOB) that is encoded with base64 encoding. | 13
MiniCertificate | Contains the mini-certificate BLOB that is encoded with base64 encoding. | 14
Options | Contains the options for resolving the list of recipients. | 15
To | Specifies one or more recipients to be resolved. | 16
CertificateRetrieval | Specifies whether S/MIME certificates SHOULD be returned by the server for each resolved recipient. | 17
RecipientCount | Specifies the number of recipients that are returned in the ResolveRecipients command response. | 18
MaxCertificates | Limits the total number of certificates that are returned by the server. | 19
MaxAmbiguousRecipients | Limits the number of suggestions that are returned for each ambiguous recipient node in the response. | 20
CertificateCount | Specifies the number of valid certificates that were found for the recipient. | 21
Availability | Indicates to the server that free/busy data is being requested by the client and identifies the start time and end time of the free/busy data to retrieve. | 22
StartTime | Identifies the start of the span of free/busy time requested by the client. | 23
EndTime | Identifies the end of the span of free/busy time requested by the client. | 24
MergedFreeBusy | Specifies the free/busy information for the users or distribution list identified in the request. | 25
Picture | Indicates that the client is requesting that contact photos be returned in the server response. | 26
MaxSize | Limits the size of contact photos returned in the server response. | 27
Data | Contains the binary data of the contact photo. | 28
MaxPictures | Limits the number of contact photos returned in the server response. | 29

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces Namespace


RightsManagement Enumeration

RightsManagement namespace of the ActiveSync protocol

public enum RightsManagement

Members

Member Name | Description | Value
RightsManagementSupport | Specifies how the server returns rights-managed email messages to the client. | 5
RightsManagementTemplates | Contains the rights policy templates available to the client. | 6
RightsManagementTemplate | Contains the template identifier, name, and description of a rights policy template available on the client. | 7
RightsManagementLicense | Contains the rights policy template settings for the template applied to the e-mail message being synchronized. | 8
EditAllowed | Specifies whether the content of the original email can be modified by the user when the user forwards, replies, or replies all to the email message. | 9
ReplyAllowed | Specifies whether the user is allowed to reply to the e-mail message. | 10
ReplyAllAllowed | Specifies whether the user can reply to all of the recipients of the original e-mail message. | 11
ForwardAllowed | Specifies whether the user can forward the e-mail message. | 12
ModifyRecipientsAllowed | Specifies whether the user can modify the recipient (1) list when the user forwards, or replies to the e-mail message. | 13
ExtractAllowed | Specifies whether the user can copy content out of the e-mail message. | 14
PrintAllowed | Specifies whether the e-mail can be printed by the user. | 15
ExportAllowed | Specifies whether the IRM protection on the e-mail message can be removed by the user. | 16
ProgrammaticAccessAllowed | Specifies whether the contents of the e-mail message can be accessed programmatically by third party applications. | 17
Owner | Specifies whether the user is the owner of the e-mail message. | 18
ContentExpiryDate | Specifies the expiration date for the license. | 19
TemplateID | Contains a string that identifies the rights policy template. | 20
TemplateName | Specifies the name of the rights policy template. | 21
TemplateDescription | Contains a description of the rights policy template. | 22
ContentOwner | Specifies the e-mail address of the content owner. | 23
RemoveRightsManagementDistribution | Indicates that the client is removing rights management distribution | 24

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces Namespace


Search Enumeration

Search namespace of the ActiveSync protocol

public enum Search

Members

Member Name | Description | Value
Search | Identifies the body of the HTTP POST as containing a Search command (section 2.2.2.14). It is the top-level element in the XML stream. | 5
Store | Contains elements that specify the location, string, and options for the search. | 7
Name | Specifies the store to search. | 8
Query | Specifies the keywords to use for matching the entries in the store that is being searched. | 9
Options | Contains the search options. | 10
Range | Specifies the maximum number of matching entries to return. | 11
Status | Indicates the result of an operation. | 12
Response | Contains the search results that are returned from the server. | 13
Result | Serves a container for an individual matching mailbox item. | 14
Properties | Contains the properties that are returned for item(s) in the response. | 15
Total | Provides an estimate of the total number of mailbox entries that matched the search Query element (section 2.2.3.129) value. | 16
EqualTo | Contains a property and a value that are compared for equality during a search. | 17
Value | Specifies the value that is to be used in a comparison. | 18
And | Specifies items on which to perform an AND operation. | 19
Or | Specifies items on which to perform an OR operation. | 20
FreeText | Specifies a string value for which to search. | 21
DeepTraversal | Indicates that the client wants the server to search all subfolders for the folders that are specified in the query. | 23
LongId | Specifies a unique identifier that is assigned by the server to each result set that is returned. | 24
RebuildResults | Forces the server to rebuild the search folder (2) that corresponds to a given query. | 25
LessThan | Specifies a property and a value that are compared for a "less than" condition during a search. | 26
GreaterThan | Specifies a property and a value that are compared for a "greater than" condition during a search. | 27
UserName | Specifies the user account used to search the document from the document library. | 30
Password | Specifies the password for the given UserName (section 2.2.3.177.2). | 31
ConversationId | Specifies the conversation for which to search. | 32
Picture | Indicates that the client is requesting that contact photos be returned in the server response. | 33
MaxSize | Limits the size of contact photos returned in the server response. | 34
MaxPictures | Limits the number of contact photos returned in the server response. | 35

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces Namespace


Settings Enumeration

Settings namespace of the ActiveSync protocol

public enum Settings

Members

Member Name | Description | Value
Settings | Identifies the body of the HTTP POST as containing a Settings command (section 2.2.2.16). | 5
Status | Indicates the result of an operation. | 6
Get | In requests, the Get element enables the client to retrieve information settings from the server. In responses, the Get element contains information settings retrieved from the server. | 7
Set | Sets information settings on the server. | 8
Oof | Specifies a named property node for retrieving and setting Out of Office (OOF) information. | 9
OofState | Specifies the availability of the Oof property (section 2.2.3.112). | 10
StartTime | It used with the EndTime element to specify the range of time during which the user is out of office. | 11
EndTime | It used with the StartTime element to specify the range of time during which the user is out of office. | 12
OofMessage | Specifies the OOF message for a particular audience. | 13
AppliesToInternal | Indicates that the OOF message applies to internal users. | 14
AppliesToExternalKnown | Indicates that the OOF message applies to known external users. | 15
AppliesToExternalUnknown | Indicates that the OOF message applies to unknown external users. | 16
Enabled | Specifies whether an OOF message is sent to this audience while the sending user is OOF. | 17
ReplyMessage | Specifies the message to be shown to a particular audience when the user is OOF. | 18
BodyType | Specifies the format of the OOF message. | 19
DevicePassword | Used to send the recovery password of the client device to the server. | 20
Password | Specifies the recovery password of the client device, which is stored by the server. | 21
DeviceInformation | Used for sending the client device's properties to the server. | 22
Model | Specifies a name that generally describes the device of the client. | 23
IMEI | Specifies a 15-character code that MUST uniquely identify a device. | 24
FriendlyName | Specifies a name that MUST uniquely describe the client device. | 25
OS | Specifies the operating system of the client device. | 26
OSLanguage | Specifies the language that is used by the operating system of the client device. | 27
PhoneNumber | Specifies a unique number that identifies the client device. | 28
UserInformation | Serves as a container node that is used to request a list of a user's email addresses from the server. | 29
EmailAddresses | Contains one or more email addresses for the user. | 30
SMTPAddress | Specifies one of the user's email addresses. | 31
UserAgent | Specifies the user agent. | 32
EnableOutboundSMS | Specifies whether the server will send outbound SMS messages through the mobile device. | 33
MobileOperator | Specifies the name of the mobile operator to which a mobile device is connected. | 34
PrimarySmtpAddress | Specifies the primary SMTP address for the given account. | 35
Accounts | Contains all aggregate accounts that the user subscribes to. | 36
Account | Contains all account information associated with a single account. | 37
AccountId | Identifies an account. | 38
AccountName | Specifies the friendly name for the given account. | 39
UserDisplayName | Specifies the display name of the user associated with the given account. | 40
SendDisabled | Specifies whether the client can send messages using the given account. | 41
RightsManagementInformation | In Settings command requests, the RightsManagementInformation element is a container node that is used to request rights management information settings. In Settings command responses, the RightsManagementInformation element is a container node that contains rights management information settings retrieved from the server. | 43

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces Namespace


Tasks Enumeration

Tasks namespace of the ActiveSync protocol

public enum Tasks

Members

Member Name | Description | Value
Categories | A collection of user-selected labels assigned to the task. | 8
Category | One of the user-selected labels that has been applied to the task item. | 9
Complete | Whether the task has been completed. | 10
DateCompleted | The date on which the task item was completed. | 11
DueDate | The local due date of the task item. | 12
UtcDueDate | The UTC due date of the task item. | 13
Importance | The importance or priority of the task item. | 14
Recurrence | When and how often this task recurs. | 15
Type | The recurrence type. | 16
Start | The start time of a series of recurrence items. | 17
Until | The end time of a series of recurrence items. | 18
Occurrences | The number of occurrences before the series ends. | 19
Interval | The interval between recurrences. | 20
DayOfMonth | The day of the month for the recurrence. | 21
DayOfWeek | The day of the week for the recurrence. | 22
WeekOfMonth | The week of the month for the recurrence. | 23
MonthOfYear | The month of the year for the recurrence. | 24
Regenerate | Whether the task item regenerates after each task instance is complete. | 25
DeadOccur | Whether the task is a recurring instance. | 26
ReminderSet | Whether a reminder for the task item has been set to appear. | 27
ReminderTime | The time and date at which the reminder for the task item will appear. | 28
Sensitivity | The sensitivity of the task item. | 29
StartDate | The local start date of the task item. | 30
UtcStartDate | The Coordinated Universal Time (UTC) start date of the task item. | 31
Subject | The subject of the task item. | 32
OrdinalDate | The time at which the client set the flag. | 34
SubOrdinalDate | A value that can be used for sorting. | 35
CalendarType | The calendar system used by this recurrence. | 36
IsLeapMonth | Whether this recurrence takes place during a leap month. | 37
FirstDayOfWeek | Specifies which day is considered the first day of the calendar week for this recurrence. | 38

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces Namespace


ValidateCert Enumeration

ValidateCert namespace of the ActiveSync protocol

public enum ValidateCert

Members

Member Name | Description | Value
ValidateCert | Identifies the body of the HTTP POST as containing a ValidateCert command (section 2.2.2.20). | 5
Certificates | Contains the list of certificates to be validated. | 6
Certificate | Contains the X509 certificate BLOB that is encoded with base64 encoding. | 7
CertificateChain | Contains the list of certificates to be validated. | 8
CheckCRL | Specifies whether the server SHOULD ignore an unverifiable revocation status. | 9
Status | Indicates the result of an operation. | 10

Requirements

Namespace: Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces Namespace


Aspose.Email.Protocols.Exchange.ExchangeDav

Aspose.Email

Aspose.Email.Protocols.Exchange.ExchangeDav Namespace

Namespace hierarchy

Classes

Class | Description
WebDavContactSaveOptions | Specifies the contact save options.


WebDavContactSaveOptions Class

Specifies the contact save options.

For a list of all members of this type, see WebDavContactSaveOptions Members.

System.Object
Aspose.Email.Outlook.ContactSaveOptions
Aspose.Email.Protocols.Exchange.ExchangeDav.WebDavContactSaveOptions

public sealed class WebDavContactSaveOptions : ContactSaveOptions

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.Exchange.ExchangeDav

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

WebDavContactSaveOptions Members | Aspose.Email.Protocols.Exchange.ExchangeDav Namespace


WebDavContactSaveOptions Members

WebDavContactSaveOptions overview

Public Static Properties

Default Gets the default options.

Public Instance Constructors

WebDavContactSaveOptions Constructor Initializes a new instance of the WebDavContactSaveOptions class.

Public Instance Properties

SaveFormat (inherited from ContactSaveOptions) Gets a save format

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

WebDavContactSaveOptions Class | Aspose.Email.Protocols.Exchange.ExchangeDav Namespace


WebDavContactSaveOptions Constructor

Initializes a new instance of the WebDavContactSaveOptions class.

public WebDavContactSaveOptions();

See Also

WebDavContactSaveOptions Class | Aspose.Email.Protocols.Exchange.ExchangeDav Namespace


WebDavContactSaveOptions Properties

The properties of the WebDavContactSaveOptions class are listed below. For a complete list of WebDavContactSaveOptions class members, see the WebDavContactSaveOptions Members topic.

Public Static Properties

Default Gets the default options.

Public Instance Properties

SaveFormat (inherited from ContactSaveOptions) Gets a save format

See Also

WebDavContactSaveOptions Class | Aspose.Email.Protocols.Exchange.ExchangeDav Namespace


Default Property

Aspose.Email

WebDavContactSaveOptions.Default Property

Gets the default options.

public static WebDavContactSaveOptions Default {get;}

Property Value

The WebDavContactSaveOptions by default.

See Also

WebDavContactSaveOptions Class | Aspose.Email.Protocols.Exchange.ExchangeDav Namespace


Aspose.Email.Protocols.Proxy

Aspose.Email

Aspose.Email.Protocols.Proxy Namespace

Namespace hierarchy

Classes

Class | Description
SocksProxy | SOCKS proxy client. Supported versions of the protocol are SOCKS4 and SOCKS5.

Enumerations

Enumeration | Description
SocksAuthenticationMethods | The authentication methods supported by the SOCKS protocol
SocksVersion | Versions of the SOCKS protocol


SocksAuthenticationMethods Enumeration

The authentication methods supported by the SOCKS protocol

This enumeration has a FlagsAttribute attribute that allows a bitwise combination of its member values.

public enum SocksAuthenticationMethods

Members

Member Name | Description | Value
NoAuthentication | No authentication | 1
PlainText | Authenticates user with a user name and password. SOCKS5 server only | 2

Requirements

Namespace: Aspose.Email.Protocols.Proxy

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.Proxy Namespace


SocksProxy Class

SOCKS proxy client. Supported versions of the protocol are SOCKS4 and SOCKS5.

For a list of all members of this type, see SocksProxy Members.

System.Object
Aspose.Email.Protocols.Proxy.SocksProxy

public class SocksProxy : IDisposable

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Protocols.Proxy

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SocksProxy Members | Aspose.Email.Protocols.Proxy Namespace


SocksProxy Members

SocksProxy overview

Public Instance Constructors

SocksProxy Overloaded. Initializes a new instance of the SocksProxy class.

Public Instance Properties

Address | The domain name or IP address of the SOCKS server
Password | Password for Socks5 authentication (RFC 1929)
Port | The port number for the SOCKS server
SupportedAuthenticationMethods | The supported authentication methods to connect to SOCKS server
Username | Username for Socks5 authentication (RFC 1929) or UserID for Socks4 Identification Protocol (RFC 1413)
Version | Required SOCKS server version.

Public Instance Methods

Dispose | Disposes this instance and requests that the underlying TCP connection be closed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetStream | Returns configured network stream to transport data to the required host through the proxy server.
GetType (inherited from Object) | Gets the Type of the current instance.
SetUpStream | Configures proxy-server to transport data to the target host.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SocksProxy Class | Aspose.Email.Protocols.Proxy Namespace


SocksProxy Constructor

Initializes a new instance of the SocksProxy class to connect to SOCKS4 server without authentication.

Overload List

Initializes a new instance of the SocksProxy class to connect to SOCKS4 server without authentication.

public SocksProxy(string,int);

Initializes a new instance of the SocksProxy class to connect to SOCKS4 or SOCKS5 server without authentication.

public SocksProxy(string,int,SocksVersion);

Initializes a new instance of the SocksProxy class to connect to SOCKS4 server without authentication.

public SocksProxy(string,int,string);

Initializes a new instance of the SocksProxy class to connect to SOCKS5 server with defined username and password.

public SocksProxy(string,int,string,string);

See Also

SocksProxy Class | Aspose.Email.Protocols.Proxy Namespace


SocksProxy Constructor (String, Int32)

Initializes a new instance of the SocksProxy class to connect to SOCKS4 server without authentication.

public SocksProxy(
string address,
int port
);

Parameters

address
The domain name or IP address of the proxy
port
The port number of the proxy

See Also

SocksProxy Class | Aspose.Email.Protocols.Proxy Namespace | SocksProxy Constructor Overload List


SocksProxy Constructor (String, Int32, SocksVersion)

Initializes a new instance of the SocksProxy class to connect to SOCKS4 or SOCKS5 server without authentication.

public SocksProxy(
string address,
int port,
SocksVersion version
);

Parameters

address
The domain name or IP address of the proxy
port
The port number of the proxy
version
Required SOCKS server version.

See Also

SocksProxy Class | Aspose.Email.Protocols.Proxy Namespace | SocksProxy Constructor Overload List


SocksProxy Constructor (String, Int32, String)

Initializes a new instance of the SocksProxy class to connect to SOCKS4 server without authentication.

public SocksProxy(
string address,
int port,
string userID
);

Parameters

address
The domain name or IP address of the proxy
port
The port number of the proxy
userID
UserID for Socks4 Identification Protocol (RFC 1413)

See Also

SocksProxy Class | Aspose.Email.Protocols.Proxy Namespace | SocksProxy Constructor Overload List


SocksProxy Constructor (String, Int32, String, String)

Initializes a new instance of the SocksProxy class to connect to SOCKS5 server with defined username and password.

public SocksProxy(
string address,
int port,
string username,
string password
);

Parameters

address
The domain name or IP address of the proxy
port
The port number of the proxy
username
Username for authentication
password
Password for authentication

See Also

SocksProxy Class | Aspose.Email.Protocols.Proxy Namespace | SocksProxy Constructor Overload List


SocksProxy Properties

The properties of the SocksProxy class are listed below. For a complete list of SocksProxy class members, see the SocksProxy Members topic.

Public Instance Properties

Address | The domain name or IP address of the SOCKS server
Password | Password for Socks5 authentication (RFC 1929)
Port | The port number for the SOCKS server
SupportedAuthenticationMethods | The supported authentication methods to connect to SOCKS server
Username | Username for Socks5 authentication (RFC 1929) or UserID for Socks4 Identification Protocol (RFC 1413)
Version | Required SOCKS server version.

See Also

SocksProxy Class | Aspose.Email.Protocols.Proxy Namespace


Address Property

Aspose.Email

SocksProxy.Address Property

The domain name or IP address of the SOCKS server

public string Address {get; set;}

See Also

SocksProxy Class | Aspose.Email.Protocols.Proxy Namespace


Password Property

Aspose.Email

SocksProxy.Password Property

Password for Socks5 authentication (RFC 1929)

public string Password {get; set;}

See Also

SocksProxy Class | Aspose.Email.Protocols.Proxy Namespace


Port Property

Aspose.Email

SocksProxy.Port Property

The port number for the SOCKS server

public int Port {get; set;}

See Also

SocksProxy Class | Aspose.Email.Protocols.Proxy Namespace


SupportedAuthenticationMethods Property

Aspose.Email

SocksProxy.SupportedAuthenticationMethods Property

The supported authentication methods to connect to SOCKS server

public SocksAuthenticationMethods SupportedAuthenticationMethods {get; set;}

See Also

SocksProxy Class | Aspose.Email.Protocols.Proxy Namespace


Username Property

Aspose.Email

SocksProxy.Username Property

Username for Socks5 authentication (RFC 1929) or UserID for Socks4 Identification Protocol (RFC 1413)

public string Username {get; set;}

See Also

SocksProxy Class | Aspose.Email.Protocols.Proxy Namespace


Version Property

Aspose.Email

SocksProxy.Version Property

Required SOCKS server version.

public SocksVersion Version {get; set;}

See Also

SocksProxy Class | Aspose.Email.Protocols.Proxy Namespace


SocksProxy Methods

The methods of the SocksProxy class are listed below. For a complete list of SocksProxy class members, see the SocksProxy Members topic.

Public Instance Methods

Dispose | Disposes this instance and requests that the underlying TCP connection be closed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetStream | Returns configured network stream to transport data to the required host through the proxy server.
GetType (inherited from Object) | Gets the Type of the current instance.
SetUpStream | Configures proxy-server to transport data to the target host.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SocksProxy Class | Aspose.Email.Protocols.Proxy Namespace


SocksProxy.Dispose Method

Disposes this instance and requests that the underlying TCP connection be closed.

public virtual void Dispose();

Implements

IDisposable.Dispose

See Also

SocksProxy Class | Aspose.Email.Protocols.Proxy Namespace


SocksProxy.GetStream Method

Returns configured network stream to transport data to the required host through the proxy server.

public Stream GetStream(
string address,
int port
);

Parameters

address
The domain name of the host we want to contact
port
The port number of the host we want to contact

Return Value

Returns configure network stream to connect with required host through the proxy server.

See Also

SocksProxy Class | Aspose.Email.Protocols.Proxy Namespace


SocksProxy.SetUpStream Method

Configures proxy-server to transport data to the target host.

public void SetUpStream(
Stream stream,
string address,
int port
);

Parameters

stream
Stream which is connected to the proxy-server.
address
The network address of the target host we want to contact
port
The port number of the target host we want to contact

See Also

SocksProxy Class | Aspose.Email.Protocols.Proxy Namespace


SocksVersion Enumeration

Versions of the SOCKS protocol

public enum SocksVersion

Members

Member Name | Description | Value
SocksV4 | SOCKS4 and SOCKS4a version SOCKS4a extends the SOCKS4 protocol to allow a client to specify a destination domain name rather than an IPv4 address; this is useful when the client itself cannot resolve the destination host's domain name to an IP address. | 4
SocksV5 | SOCKS5 version The SOCKS5 protocol is defined in RFC 1928. It is an extension of the SOCKS4 protocol; it offers more choices for authentication, and adds support for IPv6 and UDP, the latter of which can be used for DNS lookups. | 5

Requirements

Namespace: Aspose.Email.Protocols.Proxy

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Protocols.Proxy Namespace


Aspose.Email.Services

Aspose.Email

Aspose.Email.Services Namespace

Namespace hierarchy

Interfaces

Interface | Description
IOAuthServiceClient | Obsolete. Represents a base interface for any OAuth service client.


IOAuthServiceClient Interface

NOTE: This interface is now obsolete.

Represents a base interface for any OAuth service client.

For a list of all members of this type, see IOAuthServiceClient Members.

public interface IOAuthServiceClient

Types that implement IOAuthServiceClient

Type | Description
GmailClient | Obsolete. Provides access to gmail account

Requirements

Namespace: Aspose.Email.Services

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

IOAuthServiceClient Members | Aspose.Email.Services Namespace


IOAuthServiceClient Members

IOAuthServiceClient overview

Public Instance Properties

ConsumerKey | Gets or sets the consumer key registered for the application.
ConsumerSecret | Gets or sets the consumer secret key registered for the application,
OAuthToken | Gets or sets the OAuth token used to authenticate a user.
OAuthTokenSecret | Gets or sets the OAuth token secret used to authenticate a user.

Public Instance Methods

AcquireAccessToken | Acquires the access token.
AcquireRequestTokenData | Acquires the request token data, please note the out-of-band workflow is being used.

See Also

IOAuthServiceClient Interface | Aspose.Email.Services Namespace


IOAuthServiceClient Properties

The properties of the IOAuthServiceClient interface are listed below. For a complete list of IOAuthServiceClient interface members, see the IOAuthServiceClient Members topic.

Public Instance Properties

ConsumerKey | Gets or sets the consumer key registered for the application.
ConsumerSecret | Gets or sets the consumer secret key registered for the application,
OAuthToken | Gets or sets the OAuth token used to authenticate a user.
OAuthTokenSecret | Gets or sets the OAuth token secret used to authenticate a user.

See Also

IOAuthServiceClient Interface | Aspose.Email.Services Namespace


ConsumerKey Property

Aspose.Email

IOAuthServiceClient.ConsumerKey Property

Gets or sets the consumer key registered for the application.

string ConsumerKey {get; set;}

Property Value

The consumer key.

See Also

IOAuthServiceClient Interface | Aspose.Email.Services Namespace


ConsumerSecret Property

Aspose.Email

IOAuthServiceClient.ConsumerSecret Property

Gets or sets the consumer secret key registered for the application,

string ConsumerSecret {get; set;}

Property Value

The consumer secret.

See Also

IOAuthServiceClient Interface | Aspose.Email.Services Namespace


OAuthToken Property

Aspose.Email

IOAuthServiceClient.OAuthToken Property

Gets or sets the OAuth token used to authenticate a user.

string OAuthToken {get; set;}

Property Value

The OAuth token.

See Also

IOAuthServiceClient Interface | Aspose.Email.Services Namespace


OAuthTokenSecret Property

Aspose.Email

IOAuthServiceClient.OAuthTokenSecret Property

Gets or sets the OAuth token secret used to authenticate a user.

string OAuthTokenSecret {get; set;}

Property Value

The OAuth token secret.

See Also

IOAuthServiceClient Interface | Aspose.Email.Services Namespace


IOAuthServiceClient Methods

The methods of the IOAuthServiceClient interface are listed below. For a complete list of IOAuthServiceClient interface members, see the IOAuthServiceClient Members topic.

Public Instance Methods

AcquireAccessToken | Acquires the access token.
AcquireRequestTokenData | Acquires the request token data, please note the out-of-band workflow is being used.

See Also

IOAuthServiceClient Interface | Aspose.Email.Services Namespace


IOAuthServiceClient.AcquireAccessToken Method

Acquires the access token.

NameValueCollection AcquireAccessToken(
string oauthToken,
string oauthTokenSecret,
string pin
);

Parameters

oauthToken
The oauth token.
oauthTokenSecret
The oauth token secret.
pin
The pin parameter.

Return Value

A NameValueCollection object which contains parameters used for authorization or null if fails to create one.

See Also

IOAuthServiceClient Interface | Aspose.Email.Services Namespace


IOAuthServiceClient.AcquireRequestTokenData Method

Acquires the request token data, please note the out-of-band workflow is being used.

NameValueCollection AcquireRequestTokenData();

Return Value

A NameValueCollection object which contains parameters needed to complete authorization process or null if fails to create one. You will need oauth_token and oauth_token_secret parameters.

Remarks

Authorization url value that app may present to user should have a key name "authorization_url".

See Also

IOAuthServiceClient Interface | Aspose.Email.Services Namespace


Aspose.Email.Services.Google

Aspose.Email

Aspose.Email.Services.Google Namespace

Namespace hierarchy

Classes

Class | Description
FeedEntryCollection | Represents collection of IFeedEntry objects
GmailClient | Obsolete. Provides access to gmail account
GmailClientException | Exception that is thrown in GmailClient
GmailContact | Represents a contact of gmail
GmailContactEmail | Represents an email address of person
GmailContactGroup | Represents a group which owns the contact
GmailContactIm | Represents an instant messaging address associated with the
GmailContactInfo | Abstract class that represents contact information
GmailContactInfoCollection | Represents collection of GmailContactInfo objects
GmailContactName | Represents family name of the person
GmailContactOrganization | Represents organization, associated with a contact
GmailContactPhoneNumber | Represents a phone number associated with the person
GmailContactPostalAddress | Represents a postal address of person

Interfaces

Interface | Description
IFeedEntry | Represents a child element of the Atom feed format

Enumerations

Enumeration | Description
GmailClientAuthorization | Enumerates the types of gmail client authorization.


FeedEntryCollection Class

Represents collection of IFeedEntry objects

For a list of all members of this type, see FeedEntryCollection Members.

System.Object
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Services.Google.IFeedEntry, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]]
Aspose.Email.Services.Google.FeedEntryCollection

public class FeedEntryCollection : Collection`1

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Services.Google

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FeedEntryCollection Members | Aspose.Email.Services.Google Namespace


FeedEntryCollection Members

FeedEntryCollection overview

Public Instance Constructors

FeedEntryCollection Constructor Initializes a new instance of the FeedEntryCollection class.

Public Instance Properties

Count (inherited from 0, Culture=neutral, PublicKeyToken=null]])
Item (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Items (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Protected Instance Methods

ClearItems |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
InsertItem |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RemoveItem |
SetItem |

See Also

FeedEntryCollection Class | Aspose.Email.Services.Google Namespace


FeedEntryCollection Constructor

Initializes a new instance of the FeedEntryCollection class.

public FeedEntryCollection();

See Also

FeedEntryCollection Class | Aspose.Email.Services.Google Namespace


FeedEntryCollection Methods

The methods of the FeedEntryCollection class are listed below. For a complete list of FeedEntryCollection class members, see the FeedEntryCollection Members topic.

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

ClearItems |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
InsertItem |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RemoveItem |
SetItem |

See Also

FeedEntryCollection Class | Aspose.Email.Services.Google Namespace


FeedEntryCollection.ClearItems Method

protected override void ClearItems();

See Also

FeedEntryCollection Class | Aspose.Email.Services.Google Namespace


FeedEntryCollection.InsertItem Method

protected override void InsertItem(
int index,
IFeedEntry item
);

See Also

FeedEntryCollection Class | Aspose.Email.Services.Google Namespace


FeedEntryCollection.RemoveItem Method

protected override void RemoveItem(
int index
);

See Also

FeedEntryCollection Class | Aspose.Email.Services.Google Namespace


FeedEntryCollection.SetItem Method

protected override void SetItem(
int index,
IFeedEntry item
);

See Also

FeedEntryCollection Class | Aspose.Email.Services.Google Namespace


GmailClient Class

NOTE: This class is now obsolete.

Provides access to gmail account

For a list of all members of this type, see GmailClient Members.

System.Object
Aspose.Email.Services.Google.GmailClient

public sealed class GmailClient : IOAuthServiceClient

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Services.Google

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GmailClient Members | Aspose.Email.Services.Google Namespace


GmailClient Members

GmailClient overview

Public Instance Constructors

GmailClient Overloaded. Initializes a new instance of the GmailClient class.

Public Instance Properties

AuthorizationType | Gets or sets the authorization type.
ConsumerKey | Gets or sets the consumer key registered for the application.
ConsumerSecret | Gets or sets the consumer secret key registered for the application.
OAuthToken | Gets or sets the OAuth token used to authenticate a user.
OAuthTokenSecret | Gets or sets the OAuth token secret used to authenticate a user.
Password | Gets or sets the password to gmail account.
Username | Gets or sets the gmail username.

Public Instance Methods

AcquireAccessToken | Acquires the access token.
AcquireRequestTokenData | Acquires the request token data, please note the out-of-band workflow is being used.
ClientLoginAuthenticate | username/password authentication
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FetchAllContacts | Fetches all contacts.
FetchAllGroups | Fetches all contact groups.
FetchContact | Fetches the contact
FetchContactGroup | Retrieves a single group entry for a group that a given contact belongs to
FetchContactsFromGroup | Overloaded. Fetches contacts belonging to the group specified.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RetrieveContactPhoto | Retrieving a photo for the contact.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

GmailClient Class | Aspose.Email.Services.Google Namespace


GmailClient Constructor

Initializes a new instance of the GmailClient class.

Overload List

Initializes a new instance of the GmailClient class.

public GmailClient();

Initializes a new instance of the GmailClient class.

public GmailClient(GmailClientAuthorization);

Initializes a new instance of the GmailClient class.

public GmailClient(string,string);

Initializes a new instance of the GmailClient class and optionally tries to connect to gmail using the specified credential.

public GmailClient(string,string,bool);

See Also

GmailClient Class | Aspose.Email.Services.Google Namespace


GmailClient Constructor ()

Initializes a new instance of the GmailClient class.

public GmailClient();

See Also

GmailClient Class | Aspose.Email.Services.Google Namespace | GmailClient Constructor Overload List


GmailClient Constructor (GmailClientAuthorization)

Initializes a new instance of the GmailClient class.

public GmailClient(
GmailClientAuthorization authorizationType
);

Parameters

authorizationType
An authorization type.

Exceptions

Exception Type | Condition
ArgumentException | authorizationType is not defined in GmailClientAuthorization

See Also

GmailClient Class | Aspose.Email.Services.Google Namespace | GmailClient Constructor Overload List


GmailClient Constructor (String, String)

Initializes a new instance of the GmailClient class.

public GmailClient(
string username,
string password
);

Parameters

username
String that represents user's gmail address
password
String that represents user's password

Exceptions

Exception Type | Condition
ArgumentNullException | username or password is null or empty.

See Also

GmailClient Class | Aspose.Email.Services.Google Namespace | GmailClient Constructor Overload List


GmailClient Constructor (String, String, Boolean)

Initializes a new instance of the GmailClient class and optionally tries to connect to gmail using the specified credential.

public GmailClient(
string username,
string password,
bool connect
);

Parameters

username
String that represents user's gmail address
password
String that represents user's password
connect
A value indicating whether the client attempt to connect to gmail using the specified username and password

Exceptions

Exception Type | Condition
ArgumentNullException | username or password is null or empty.

See Also

GmailClient Class | Aspose.Email.Services.Google Namespace | GmailClient Constructor Overload List


GmailClient Properties

The properties of the GmailClient class are listed below. For a complete list of GmailClient class members, see the GmailClient Members topic.

Public Instance Properties

AuthorizationType | Gets or sets the authorization type.
ConsumerKey | Gets or sets the consumer key registered for the application.
ConsumerSecret | Gets or sets the consumer secret key registered for the application.
OAuthToken | Gets or sets the OAuth token used to authenticate a user.
OAuthTokenSecret | Gets or sets the OAuth token secret used to authenticate a user.
Password | Gets or sets the password to gmail account.
Username | Gets or sets the gmail username.

See Also

GmailClient Class | Aspose.Email.Services.Google Namespace


AuthorizationType Property

Aspose.Email

GmailClient.AuthorizationType Property

Gets or sets the authorization type.

public GmailClientAuthorization AuthorizationType {get; set;}

Exceptions

Exception Type | Condition
ArgumentException | value is not defined in GmailClientAuthorization.

See Also

GmailClient Class | Aspose.Email.Services.Google Namespace


ConsumerKey Property

Aspose.Email

GmailClient.ConsumerKey Property

Gets or sets the consumer key registered for the application.

public string ConsumerKey {get; set;}

Property Value

The consumer key.

Implements

IOAuthServiceClient.ConsumerKey

See Also

GmailClient Class | Aspose.Email.Services.Google Namespace


ConsumerSecret Property

Aspose.Email

GmailClient.ConsumerSecret Property

Gets or sets the consumer secret key registered for the application.

public string ConsumerSecret {get; set;}

Property Value

The consumer secret.

Implements

IOAuthServiceClient.ConsumerSecret

See Also

GmailClient Class | Aspose.Email.Services.Google Namespace


OAuthToken Property

Aspose.Email

GmailClient.OAuthToken Property

Gets or sets the OAuth token used to authenticate a user.

public string OAuthToken {get; set;}

Property Value

The OAuth token.

Implements

IOAuthServiceClient.OAuthToken

See Also

GmailClient Class | Aspose.Email.Services.Google Namespace


OAuthTokenSecret Property

Aspose.Email

GmailClient.OAuthTokenSecret Property

Gets or sets the OAuth token secret used to authenticate a user.

public string OAuthTokenSecret {get; set;}

Property Value

The OAuth token secret.

Implements

IOAuthServiceClient.OAuthTokenSecret

See Also

GmailClient Class | Aspose.Email.Services.Google Namespace


Password Property

Aspose.Email

GmailClient.Password Property

Gets or sets the password to gmail account.

public string Password {get; set;}

Exceptions

Exception Type | Condition
ArgumentNullException | value is null or empty

See Also

GmailClient Class | Aspose.Email.Services.Google Namespace


Username Property

Aspose.Email

GmailClient.Username Property

Gets or sets the gmail username.

public string Username {get; set;}

Exceptions

Exception Type | Condition
ArgumentNullException | value is null or empty

See Also

GmailClient Class | Aspose.Email.Services.Google Namespace


GmailClient Methods

The methods of the GmailClient class are listed below. For a complete list of GmailClient class members, see the GmailClient Members topic.

Public Instance Methods

AcquireAccessToken | Acquires the access token.
AcquireRequestTokenData | Acquires the request token data, please note the out-of-band workflow is being used.
ClientLoginAuthenticate | username/password authentication
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FetchAllContacts | Fetches all contacts.
FetchAllGroups | Fetches all contact groups.
FetchContact | Fetches the contact
FetchContactGroup | Retrieves a single group entry for a group that a given contact belongs to
FetchContactsFromGroup | Overloaded. Fetches contacts belonging to the group specified.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RetrieveContactPhoto | Retrieving a photo for the contact.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

GmailClient Class | Aspose.Email.Services.Google Namespace


GmailClient.AcquireAccessToken Method

Acquires the access token.

public NameValueCollection AcquireAccessToken(
string oauthToken,
string oauthTokenSecret,
string pin
);

Parameters

oauthToken
The oauth token.
oauthTokenSecret
The oauth token secret.
pin
The pin parameter.

Return Value

A NameValueCollection object which contains parameters used for authorization or null if fails to create one.

Implements

IOAuthServiceClient.AcquireAccessToken

See Also

GmailClient Class | Aspose.Email.Services.Google Namespace


GmailClient.AcquireRequestTokenData Method

Acquires the request token data, please note the out-of-band workflow is being used.

public NameValueCollection AcquireRequestTokenData();

Return Value

A NameValueCollection object which contains parameters needed to complete authorization process or null if fails to create one. You will need oauth_token and oauth_token_secret parameters.

Implements

IOAuthServiceClient.AcquireRequestTokenData

Remarks

Authorization url value that app may present to user should have a key name "authorization_url".

See Also

GmailClient Class | Aspose.Email.Services.Google Namespace


GmailClient.ClientLoginAuthenticate Method

username/password authentication

public void ClientLoginAuthenticate();

Exceptions

Exception Type | Condition
GmailClientException | ClientLogin authentication failed.
InvalidOperationException | Username or Password is null or empty.

See Also

GmailClient Class | Aspose.Email.Services.Google Namespace


GmailClient.FetchAllContacts Method

Fetches all contacts.

public FeedEntryCollection FetchAllContacts();

Return Value

Contacts collection

Exceptions

Exception Type | Condition
WebException | when operation fails

See Also

GmailClient Class | Aspose.Email.Services.Google Namespace


GmailClient.FetchAllGroups Method

Fetches all contact groups.

public FeedEntryCollection FetchAllGroups();

Return Value

Contact groups collection

Exceptions

Exception Type | Condition
WebException | when operation fails

See Also

GmailClient Class | Aspose.Email.Services.Google Namespace


GmailClient.FetchContact Method

Fetches the contact

public GmailContact FetchContact(
string contactId
);

Parameters

contactId
String, that represents contact's Id

Return Value

GmailContact object, that represents a contact of gmail

Exceptions

Exception Type | Condition
ArgumentNullException | contactId is null or empty.
WebException | when operation fails

See Also

GmailClient Class | Aspose.Email.Services.Google Namespace


GmailClient.FetchContactGroup Method

Retrieves a single group entry for a group that a given contact belongs to

public GmailContactGroup FetchContactGroup(
GmailContact contact
);

Parameters

contact
GmailContact object, that represents a contact of gmail

Return Value

GmailContactGroup object that represents group for a contact

Exceptions

Exception Type | Condition
ArgumentNullException | contact is null.
WebException | when operation fails

See Also

GmailClient Class | Aspose.Email.Services.Google Namespace


FetchContactsFromGroup Method

Aspose.Email

GmailClient.FetchContactsFromGroup Method

Fetches contacts belonging to the group specified.

Overload List

Fetches contacts belonging to the group specified.

public FeedEntryCollection FetchContactsFromGroup(GmailContactGroup);

Fetches contacts belonging to the group specified.

public FeedEntryCollection FetchContactsFromGroup(string);

See Also

GmailClient Class | Aspose.Email.Services.Google Namespace


GmailClient.FetchContactsFromGroup Method (GmailContactGroup)

Fetches contacts belonging to the group specified.

public FeedEntryCollection FetchContactsFromGroup(
GmailContactGroup group
);

Parameters

group
GmailContactGroup object that represents group for a contact

Return Value

Contacts collection

Exceptions

Exception Type | Condition
ArgumentNullException | group is null.
WebException | when operation fails

See Also

GmailClient Class | Aspose.Email.Services.Google Namespace | GmailClient.FetchContactsFromGroup Overload List


GmailClient.FetchContactsFromGroup Method (String)

Fetches contacts belonging to the group specified.

public FeedEntryCollection FetchContactsFromGroup(
string groupId
);

Parameters

groupId
string that represents group id for a contact

Return Value

Contacts collection

Exceptions

Exception Type | Condition
ArgumentNullException | groupId is null or empty.
WebException | when operation fails

See Also

GmailClient Class | Aspose.Email.Services.Google Namespace | GmailClient.FetchContactsFromGroup Overload List


GmailClient.RetrieveContactPhoto Method

Retrieving a photo for the contact.

public Stream RetrieveContactPhoto(
GmailContact contact
);

Parameters

contact
GmailContact object, that represents a gmail contact

Return Value

Stream, that contains photo or null if contact has no photo

Exceptions

Exception Type | Condition
ArgumentNullException | contact is null.
InvalidOperationException | Failed to retrieve photo.
WebException | when operation fails

See Also

GmailClient Class | Aspose.Email.Services.Google Namespace


GmailClientAuthorization Enumeration

Enumerates the types of gmail client authorization.

public enum GmailClientAuthorization

Members

Member Name | Description | Value
ClientLogin | Specifies ClientLogin gmail authorization. | 0
OAuth | Specifies OAuth 1.0 gmail authorization. | 1
OAuth2 | Specifies OAuth 2.0 gmail authorization. | 2

Requirements

Namespace: Aspose.Email.Services.Google

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Services.Google Namespace


GmailClientException Class

Exception that is thrown in GmailClient

For a list of all members of this type, see GmailClientException Members.

System.Object
System.Exception
Aspose.Email.Services.Google.GmailClientException

public sealed class GmailClientException : Exception

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Services.Google

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GmailClientException Members | Aspose.Email.Services.Google Namespace


GmailClientException Members

GmailClientException overview

Public Instance Constructors

GmailClientException Overloaded. Initializes a new instance of the GmailClientException class.

Public Instance Properties

Data (inherited from Exception) | Gets a collection of key/value pairs that provide additional, user-defined information about the exception.
HelpLink (inherited from Exception) | Gets or sets a link to the help file associated with this exception.
InnerException (inherited from Exception) | Gets the Exception instance that caused the current exception.
Message (inherited from Exception) | Gets a message that describes the current exception.
Source (inherited from Exception) | Gets or sets the name of the application or the object that causes the error.
StackTrace (inherited from Exception) | Gets a string representation of the frames on the call stack at the time the current exception was thrown.
TargetSite (inherited from Exception) | Gets the method that throws the current exception.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBaseException (inherited from Exception) | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData (inherited from Exception) | When overridden in a derived class, sets the SerializationInfo with information about the exception.
GetType (inherited from Exception) | Gets the runtime type of the current instance.
ToString (inherited from Exception) | Creates and returns a string representation of the current exception.

See Also

GmailClientException Class | Aspose.Email.Services.Google Namespace


GmailClientException Constructor

Initializes a new instance of the GmailClientException class

Overload List

Initializes a new instance of the GmailClientException class

public GmailClientException();

Initializes a new instance of the GmailClientException class with a specified error message.

public GmailClientException(string);

Initializes a new instance of the GmailClientException class with a specified error message.

public GmailClientException(string,Exception);

See Also

GmailClientException Class | Aspose.Email.Services.Google Namespace


GmailClientException Constructor ()

Initializes a new instance of the GmailClientException class

public GmailClientException();

See Also

GmailClientException Class | Aspose.Email.Services.Google Namespace | GmailClientException Constructor Overload List


GmailClientException Constructor (String)

Initializes a new instance of the GmailClientException class with a specified error message.

public GmailClientException(
string message
);

Parameters

message
A message that describes the error.

See Also

GmailClientException Class | Aspose.Email.Services.Google Namespace | GmailClientException Constructor Overload List


GmailClientException Constructor (String, Exception)

Initializes a new instance of the GmailClientException class with a specified error message.

public GmailClientException(
string message,
Exception inner
);

Parameters

message
A message that describes the error.
inner
The exception causing the current exception

See Also

GmailClientException Class | Aspose.Email.Services.Google Namespace | GmailClientException Constructor Overload List


GmailContact Class

Represents a contact of gmail

For a list of all members of this type, see GmailContact Members.

System.Object
Aspose.Email.Services.Google.GmailContact

public sealed class GmailContact : IFeedEntry

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Services.Google

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GmailContact Members | Aspose.Email.Services.Google Namespace


GmailContact Members

GmailContact overview

Public Instance Properties

Birthday | Gets the contact's birthday.
Content | Notes about the contact
Emails | Gets the contact's e-mails.
HasPhoto | Gets a value indicating whether contact has photo.
Id | Gets the unique identifier for an contact entry
Ims | Gets the contact's IM numbers.
Name | Gets the contact's name
Organizations | Gets the organizations.
Phones | Gets the contact's phone numbers.
PostalAddresses | Gets the postal addresses.
PrimaryEmail | Gets the contact's primary e-mail.
Title | Gets the title of contact entry.
Updated | Gets the date indicating the most recent instant in time when an contact entry was modified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

GmailContact Class | Aspose.Email.Services.Google Namespace


GmailContact Properties

The properties of the GmailContact class are listed below. For a complete list of GmailContact class members, see the GmailContact Members topic.

Public Instance Properties

Birthday | Gets the contact's birthday.
Content | Notes about the contact
Emails | Gets the contact's e-mails.
HasPhoto | Gets a value indicating whether contact has photo.
Id | Gets the unique identifier for an contact entry
Ims | Gets the contact's IM numbers.
Name | Gets the contact's name
Organizations | Gets the organizations.
Phones | Gets the contact's phone numbers.
PostalAddresses | Gets the postal addresses.
PrimaryEmail | Gets the contact's primary e-mail.
Title | Gets the title of contact entry.
Updated | Gets the date indicating the most recent instant in time when an contact entry was modified

See Also

GmailContact Class | Aspose.Email.Services.Google Namespace


Birthday Property

Aspose.Email

GmailContact.Birthday Property

Gets the contact's birthday.

public DateTime Birthday {get;}

Property Value

The date of birthday.

See Also

GmailContact Class | Aspose.Email.Services.Google Namespace


Content Property

Aspose.Email

GmailContact.Content Property

Notes about the contact

public string Content {get;}

Property Value

string that represents notes

Implements

IFeedEntry.Content

See Also

GmailContact Class | Aspose.Email.Services.Google Namespace


Emails Property

Aspose.Email

GmailContact.Emails Property

Gets the contact's e-mails.

public GmailContactInfoCollection Emails {get;}

Property Value

Collection of GmailContactEmail objects

See Also

GmailContact Class | Aspose.Email.Services.Google Namespace


HasPhoto Property

Aspose.Email

GmailContact.HasPhoto Property

Gets a value indicating whether contact has photo.

public bool HasPhoto {get;}

Property Value

true if contact has photo; otherwise, false.

See Also

GmailContact Class | Aspose.Email.Services.Google Namespace


Id Property

Aspose.Email

GmailContact.Id Property

Gets the unique identifier for an contact entry

public string Id {get;}

Property Value

string that represents contact entry id

Implements

IFeedEntry.Id

See Also

GmailContact Class | Aspose.Email.Services.Google Namespace


Ims Property

Aspose.Email

GmailContact.Ims Property

Gets the contact's IM numbers.

public GmailContactInfoCollection Ims {get;}

Property Value

Collection of GmailContactIm objects

See Also

GmailContact Class | Aspose.Email.Services.Google Namespace


Name Property

Aspose.Email

GmailContact.Name Property

Gets the contact's name

public GmailContactName Name {get;}

Property Value

GmailContactName that represents contact's name

See Also

GmailContact Class | Aspose.Email.Services.Google Namespace


Organizations Property

Aspose.Email

GmailContact.Organizations Property

Gets the organizations.

public GmailContactInfoCollection Organizations {get;}

Property Value

Collection of GmailContactOrganization objects

See Also

GmailContact Class | Aspose.Email.Services.Google Namespace


Phones Property

Aspose.Email

GmailContact.Phones Property

Gets the contact's phone numbers.

public GmailContactInfoCollection Phones {get;}

Property Value

Collection of GmailContactPhoneNumber objects

See Also

GmailContact Class | Aspose.Email.Services.Google Namespace


PostalAddresses Property

Aspose.Email

GmailContact.PostalAddresses Property

Gets the postal addresses.

public GmailContactInfoCollection PostalAddresses {get;}

Property Value

Collection of GmailContactPostalAddress objects

See Also

GmailContact Class | Aspose.Email.Services.Google Namespace


PrimaryEmail Property

Aspose.Email

GmailContact.PrimaryEmail Property

Gets the contact's primary e-mail.

public GmailContactEmail PrimaryEmail {get;}

Property Value

GmailContact that represents primary email

See Also

GmailContact Class | Aspose.Email.Services.Google Namespace


Title Property

Aspose.Email

GmailContact.Title Property

Gets the title of contact entry.

public string Title {get;}

Property Value

string that represents title

Implements

IFeedEntry.Title

See Also

GmailContact Class | Aspose.Email.Services.Google Namespace


Updated Property

Aspose.Email

GmailContact.Updated Property

Gets the date indicating the most recent instant in time when an contact entry was modified

public DateTime Updated {get;}

Property Value

DateTime that represents an updated date

Implements

IFeedEntry.Updated

See Also

GmailContact Class | Aspose.Email.Services.Google Namespace


GmailContactEmail Class

Represents an email address of person

For a list of all members of this type, see GmailContactEmail Members.

System.Object
Aspose.Email.Services.Google.GmailContactInfo
Aspose.Email.Services.Google.GmailContactEmail

public sealed class GmailContactEmail : GmailContactInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Services.Google

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GmailContactEmail Members | Aspose.Email.Services.Google Namespace


GmailContactEmail Members

GmailContactEmail overview

Public Instance Properties

Address | Gets the Email address.
DisplayName | Gets the display name of the entity (e.g. a person) the email address belongs to
Label (inherited from GmailContactInfo) | Gets the simple string value used to name this entry. It allows UIs to display a label such as "Work", "Personal", "Preferred", etc.
Primary (inherited from GmailContactInfo) | Gets the primary. When multiple entry extensions appear in a contact kind, indicates which is primary. At most one entry may be primary.
Type (inherited from GmailContactInfo) | Gets the value that identifies the type of entry

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

GmailContactEmail Class | Aspose.Email.Services.Google Namespace


GmailContactEmail Properties

The properties of the GmailContactEmail class are listed below. For a complete list of GmailContactEmail class members, see the GmailContactEmail Members topic.

Public Instance Properties

Address | Gets the Email address.
DisplayName | Gets the display name of the entity (e.g. a person) the email address belongs to
Label (inherited from GmailContactInfo) | Gets the simple string value used to name this entry. It allows UIs to display a label such as "Work", "Personal", "Preferred", etc.
Primary (inherited from GmailContactInfo) | Gets the primary. When multiple entry extensions appear in a contact kind, indicates which is primary. At most one entry may be primary.
Type (inherited from GmailContactInfo) | Gets the value that identifies the type of entry

See Also

GmailContactEmail Class | Aspose.Email.Services.Google Namespace


Address Property

Aspose.Email

GmailContactEmail.Address Property

Gets the Email address.

public string Address {get;}

Property Value

The address.

See Also

GmailContactEmail Class | Aspose.Email.Services.Google Namespace


DisplayName Property

Aspose.Email

GmailContactEmail.DisplayName Property

Gets the display name of the entity (e.g. a person) the email address belongs to

public string DisplayName {get;}

Property Value

The display name.

See Also

GmailContactEmail Class | Aspose.Email.Services.Google Namespace


GmailContactGroup Class

Represents a group which owns the contact

For a list of all members of this type, see GmailContactGroup Members.

System.Object
Aspose.Email.Services.Google.GmailContactGroup

public sealed class GmailContactGroup : IFeedEntry

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Services.Google

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GmailContactGroup Members | Aspose.Email.Services.Google Namespace


GmailContactGroup Members

GmailContactGroup overview

Public Instance Properties

Content | Gets the content of the group entry
Id | Gets the unique identifier for a group entry
Title | Gets the human-readable title for a group entry
Updated | Gets the date indicating the most recent instant in time when an group entry was modified

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String which represents the object instance.

See Also

GmailContactGroup Class | Aspose.Email.Services.Google Namespace


GmailContactGroup Properties

The properties of the GmailContactGroup class are listed below. For a complete list of GmailContactGroup class members, see the GmailContactGroup Members topic.

Public Instance Properties

Content | Gets the content of the group entry
Id | Gets the unique identifier for a group entry
Title | Gets the human-readable title for a group entry
Updated | Gets the date indicating the most recent instant in time when an group entry was modified

See Also

GmailContactGroup Class | Aspose.Email.Services.Google Namespace


Content Property

Aspose.Email

GmailContactGroup.Content Property

Gets the content of the group entry

public string Content {get; set;}

Property Value

string that represents content

Implements

IFeedEntry.Content

See Also

GmailContactGroup Class | Aspose.Email.Services.Google Namespace


Id Property

Aspose.Email

GmailContactGroup.Id Property

Gets the unique identifier for a group entry

public string Id {get; set;}

Property Value

string that represents an unique identifier

Implements

IFeedEntry.Id

See Also

GmailContactGroup Class | Aspose.Email.Services.Google Namespace


Title Property

Aspose.Email

GmailContactGroup.Title Property

Gets the human-readable title for a group entry

public string Title {get; set;}

Property Value

The string that represents title for a group entry

Implements

IFeedEntry.Title

See Also

GmailContactGroup Class | Aspose.Email.Services.Google Namespace


Updated Property

Aspose.Email

GmailContactGroup.Updated Property

Gets the date indicating the most recent instant in time when an group entry was modified

public DateTime Updated {get; set;}

Property Value

DateTime value that represents updated date

Implements

IFeedEntry.Updated

See Also

GmailContactGroup Class | Aspose.Email.Services.Google Namespace


GmailContactGroup Methods

The methods of the GmailContactGroup class are listed below. For a complete list of GmailContactGroup class members, see the GmailContactGroup Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString | Returns a String which represents the object instance.

See Also

GmailContactGroup Class | Aspose.Email.Services.Google Namespace


GmailContactGroup.ToString Method

Returns a String which represents the object instance.

public override string ToString();

Return Value

Returns a String which represents the object instance.

See Also

GmailContactGroup Class | Aspose.Email.Services.Google Namespace


GmailContactIm Class

Represents an instant messaging address associated with the

For a list of all members of this type, see GmailContactIm Members.

System.Object
Aspose.Email.Services.Google.GmailContactInfo
Aspose.Email.Services.Google.GmailContactIm

public sealed class GmailContactIm : GmailContactInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Services.Google

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GmailContactIm Members | Aspose.Email.Services.Google Namespace


GmailContactIm Members

GmailContactIm overview

Public Instance Properties

Address | Gets the IM address.
Label (inherited from GmailContactInfo) | Gets the simple string value used to name this entry. It allows UIs to display a label such as "Work", "Personal", "Preferred", etc.
Primary (inherited from GmailContactInfo) | Gets the primary. When multiple entry extensions appear in a contact kind, indicates which is primary. At most one entry may be primary.
Protocol | Gets the identifies the IM network. The value may be either one of the standard values or a URI identifying a proprietary IM network.
Type (inherited from GmailContactInfo) | Gets the value that identifies the type of entry

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

GmailContactIm Class | Aspose.Email.Services.Google Namespace


GmailContactIm Properties

The properties of the GmailContactIm class are listed below. For a complete list of GmailContactIm class members, see the GmailContactIm Members topic.

Public Instance Properties

Address | Gets the IM address.
Label (inherited from GmailContactInfo) | Gets the simple string value used to name this entry. It allows UIs to display a label such as "Work", "Personal", "Preferred", etc.
Primary (inherited from GmailContactInfo) | Gets the primary. When multiple entry extensions appear in a contact kind, indicates which is primary. At most one entry may be primary.
Protocol | Gets the identifies the IM network. The value may be either one of the standard values or a URI identifying a proprietary IM network.
Type (inherited from GmailContactInfo) | Gets the value that identifies the type of entry

See Also

GmailContactIm Class | Aspose.Email.Services.Google Namespace


Address Property

Aspose.Email

GmailContactIm.Address Property

Gets the IM address.

public string Address {get;}

Property Value

The IM address.

See Also

GmailContactIm Class | Aspose.Email.Services.Google Namespace


Protocol Property

Aspose.Email

GmailContactIm.Protocol Property

Gets the identifies the IM network. The value may be either one of the standard values or a URI identifying a proprietary IM network.

public string Protocol {get;}

Property Value

The protocol.

See Also

GmailContactIm Class | Aspose.Email.Services.Google Namespace


GmailContactInfo Class

Abstract class that represents contact information

For a list of all members of this type, see GmailContactInfo Members.

System.Object
Aspose.Email.Services.Google.GmailContactInfo
Aspose.Email.Services.Google.GmailContactEmail
Aspose.Email.Services.Google.GmailContactIm
Aspose.Email.Services.Google.GmailContactOrganization
Aspose.Email.Services.Google.GmailContactPhoneNumber
Aspose.Email.Services.Google.GmailContactPostalAddress

public abstract class GmailContactInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Services.Google

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GmailContactInfo Members | Aspose.Email.Services.Google Namespace


GmailContactInfo Members

GmailContactInfo overview

Public Instance Properties

Label | Gets the simple string value used to name this entry. It allows UIs to display a label such as "Work", "Personal", "Preferred", etc.
Primary | Gets the primary. When multiple entry extensions appear in a contact kind, indicates which is primary. At most one entry may be primary.
Type | Gets the value that identifies the type of entry

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Constructors

GmailContactInfo Constructor

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

GmailContactInfo Class | Aspose.Email.Services.Google Namespace


GmailContactInfo Constructor

protected GmailContactInfo(
XmlNode entry,
XmlNamespaceManager mng
);

See Also

GmailContactInfo Class | Aspose.Email.Services.Google Namespace


GmailContactInfo Properties

The properties of the GmailContactInfo class are listed below. For a complete list of GmailContactInfo class members, see the GmailContactInfo Members topic.

Public Instance Properties

Label | Gets the simple string value used to name this entry. It allows UIs to display a label such as "Work", "Personal", "Preferred", etc.
Primary | Gets the primary. When multiple entry extensions appear in a contact kind, indicates which is primary. At most one entry may be primary.
Type | Gets the value that identifies the type of entry

See Also

GmailContactInfo Class | Aspose.Email.Services.Google Namespace


Label Property

Aspose.Email

GmailContactInfo.Label Property

Gets the simple string value used to name this entry. It allows UIs to display a label such as "Work", "Personal", "Preferred", etc.

public string Label {get;}

Property Value

The label.

See Also

GmailContactInfo Class | Aspose.Email.Services.Google Namespace


Primary Property

Aspose.Email

GmailContactInfo.Primary Property

Gets the primary. When multiple entry extensions appear in a contact kind, indicates which is primary. At most one entry may be primary.

public bool Primary {get;}

Property Value

The primary.

See Also

GmailContactInfo Class | Aspose.Email.Services.Google Namespace


Type Property

Aspose.Email

GmailContactInfo.Type Property

Gets the value that identifies the type of entry

public string Type {get;}

Property Value

The type.

See Also

GmailContactInfo Class | Aspose.Email.Services.Google Namespace


GmailContactInfoCollection Class

Represents collection of GmailContactInfo objects

For a list of all members of this type, see GmailContactInfoCollection Members.

System.Object
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Services.Google.GmailContactInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]]
Aspose.Email.Services.Google.GmailContactInfoCollection

public class GmailContactInfoCollection : Collection`1

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Services.Google

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GmailContactInfoCollection Members | Aspose.Email.Services.Google Namespace


GmailContactInfoCollection Members

GmailContactInfoCollection overview

Public Instance Constructors

GmailContactInfoCollection Constructor Initializes a new instance of the GmailContactInfoCollection class.

Public Instance Properties

Count (inherited from 0, Culture=neutral, PublicKeyToken=null]])
Item (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Items (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Protected Instance Methods

ClearItems |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
InsertItem |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RemoveItem |
SetItem |

See Also

GmailContactInfoCollection Class | Aspose.Email.Services.Google Namespace


GmailContactInfoCollection Constructor

Initializes a new instance of the GmailContactInfoCollection class.

public GmailContactInfoCollection();

See Also

GmailContactInfoCollection Class | Aspose.Email.Services.Google Namespace


GmailContactInfoCollection Methods

The methods of the GmailContactInfoCollection class are listed below. For a complete list of GmailContactInfoCollection class members, see the GmailContactInfoCollection Members topic.

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

ClearItems |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
InsertItem |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RemoveItem |
SetItem |

See Also

GmailContactInfoCollection Class | Aspose.Email.Services.Google Namespace


GmailContactInfoCollection.ClearItems Method

protected override void ClearItems();

See Also

GmailContactInfoCollection Class | Aspose.Email.Services.Google Namespace


GmailContactInfoCollection.InsertItem Method

protected override void InsertItem(
int index,
GmailContactInfo item
);

See Also

GmailContactInfoCollection Class | Aspose.Email.Services.Google Namespace


GmailContactInfoCollection.RemoveItem Method

protected override void RemoveItem(
int index
);

See Also

GmailContactInfoCollection Class | Aspose.Email.Services.Google Namespace


GmailContactInfoCollection.SetItem Method

protected override void SetItem(
int index,
GmailContactInfo item
);

See Also

GmailContactInfoCollection Class | Aspose.Email.Services.Google Namespace


GmailContactName Class

Represents family name of the person

For a list of all members of this type, see GmailContactName Members.

System.Object
Aspose.Email.Services.Google.GmailContactName

public sealed class GmailContactName

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Services.Google

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GmailContactName Members | Aspose.Email.Services.Google Namespace


GmailContactName Members

GmailContactName overview

Public Instance Properties

AdditionalName | Gets the additional name of the person, eg. middle name.
FamilyName | Gets the person's family name.
FullName | Gets the unstructured representation of the name.
GivenName | Gets the Person's given name.
NamePrefix | Gets the honorific prefix, eg. 'Mr' or 'Mrs'.
NameSuffix | Gets the honorific suffix, eg. 'san' or 'III'.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

GmailContactName Class | Aspose.Email.Services.Google Namespace


GmailContactName Properties

The properties of the GmailContactName class are listed below. For a complete list of GmailContactName class members, see the GmailContactName Members topic.

Public Instance Properties

AdditionalName | Gets the additional name of the person, eg. middle name.
FamilyName | Gets the person's family name.
FullName | Gets the unstructured representation of the name.
GivenName | Gets the Person's given name.
NamePrefix | Gets the honorific prefix, eg. 'Mr' or 'Mrs'.
NameSuffix | Gets the honorific suffix, eg. 'san' or 'III'.

See Also

GmailContactName Class | Aspose.Email.Services.Google Namespace


AdditionalName Property

Aspose.Email

GmailContactName.AdditionalName Property

Gets the additional name of the person, eg. middle name.

public string AdditionalName {get;}

Property Value

additional name of the person

See Also

GmailContactName Class | Aspose.Email.Services.Google Namespace


FamilyName Property

Aspose.Email

GmailContactName.FamilyName Property

Gets the person's family name.

public string FamilyName {get;}

Property Value

The person's family name.

See Also

GmailContactName Class | Aspose.Email.Services.Google Namespace


FullName Property

Aspose.Email

GmailContactName.FullName Property

Gets the unstructured representation of the name.

public string FullName {get;}

Property Value

The full name.

See Also

GmailContactName Class | Aspose.Email.Services.Google Namespace


GivenName Property

Aspose.Email

GmailContactName.GivenName Property

Gets the Person's given name.

public string GivenName {get;}

Property Value

Person's given name

See Also

GmailContactName Class | Aspose.Email.Services.Google Namespace


NamePrefix Property

Aspose.Email

GmailContactName.NamePrefix Property

Gets the honorific prefix, eg. 'Mr' or 'Mrs'.

public string NamePrefix {get;}

Property Value

The honorific prefix, eg. 'Mr' or 'Mrs'.

See Also

GmailContactName Class | Aspose.Email.Services.Google Namespace


NameSuffix Property

Aspose.Email

GmailContactName.NameSuffix Property

Gets the honorific suffix, eg. 'san' or 'III'.

public string NameSuffix {get;}

Property Value

The honorific suffix.

See Also

GmailContactName Class | Aspose.Email.Services.Google Namespace


GmailContactOrganization Class

Represents organization, associated with a contact

For a list of all members of this type, see GmailContactOrganization Members.

System.Object
Aspose.Email.Services.Google.GmailContactInfo
Aspose.Email.Services.Google.GmailContactOrganization

public sealed class GmailContactOrganization : GmailContactInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Services.Google

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GmailContactOrganization Members | Aspose.Email.Services.Google Namespace


GmailContactOrganization Members

GmailContactOrganization overview

Public Instance Properties

Department | Gets a department within the organization.
JobDescription | Gets the description of a job within the organization.
Label (inherited from GmailContactInfo) | Gets the simple string value used to name this entry. It allows UIs to display a label such as "Work", "Personal", "Preferred", etc.
Name | Gets the name of the organization.
Primary (inherited from GmailContactInfo) | Gets the primary. When multiple entry extensions appear in a contact kind, indicates which is primary. At most one entry may be primary.
Symbol | Gets the symbol of the organization.
Title | Gets the title of a person within the organization.
Type (inherited from GmailContactInfo) | Gets the value that identifies the type of entry

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

GmailContactOrganization Class | Aspose.Email.Services.Google Namespace


GmailContactOrganization Properties

The properties of the GmailContactOrganization class are listed below. For a complete list of GmailContactOrganization class members, see the GmailContactOrganization Members topic.

Public Instance Properties

Department | Gets a department within the organization.
JobDescription | Gets the description of a job within the organization.
Label (inherited from GmailContactInfo) | Gets the simple string value used to name this entry. It allows UIs to display a label such as "Work", "Personal", "Preferred", etc.
Name | Gets the name of the organization.
Primary (inherited from GmailContactInfo) | Gets the primary. When multiple entry extensions appear in a contact kind, indicates which is primary. At most one entry may be primary.
Symbol | Gets the symbol of the organization.
Title | Gets the title of a person within the organization.
Type (inherited from GmailContactInfo) | Gets the value that identifies the type of entry

See Also

GmailContactOrganization Class | Aspose.Email.Services.Google Namespace


Department Property

Aspose.Email

GmailContactOrganization.Department Property

Gets a department within the organization.

public string Department {get;}

Property Value

The department.

See Also

GmailContactOrganization Class | Aspose.Email.Services.Google Namespace


JobDescription Property

Aspose.Email

GmailContactOrganization.JobDescription Property

Gets the description of a job within the organization.

public string JobDescription {get;}

Property Value

The job description.

See Also

GmailContactOrganization Class | Aspose.Email.Services.Google Namespace


Name Property

Aspose.Email

GmailContactOrganization.Name Property

Gets the name of the organization.

public string Name {get;}

Property Value

The name.

See Also

GmailContactOrganization Class | Aspose.Email.Services.Google Namespace


Symbol Property

Aspose.Email

GmailContactOrganization.Symbol Property

Gets the symbol of the organization.

public string Symbol {get;}

Property Value

The symbol.

See Also

GmailContactOrganization Class | Aspose.Email.Services.Google Namespace


Title Property

Aspose.Email

GmailContactOrganization.Title Property

Gets the title of a person within the organization.

public string Title {get;}

Property Value

The title.

See Also

GmailContactOrganization Class | Aspose.Email.Services.Google Namespace


GmailContactPhoneNumber Class

Represents a phone number associated with the person

For a list of all members of this type, see GmailContactPhoneNumber Members.

System.Object
Aspose.Email.Services.Google.GmailContactInfo
Aspose.Email.Services.Google.GmailContactPhoneNumber

public sealed class GmailContactPhoneNumber : GmailContactInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Services.Google

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GmailContactPhoneNumber Members | Aspose.Email.Services.Google Namespace


GmailContactPhoneNumber Members

GmailContactPhoneNumber overview

Public Instance Properties

Label (inherited from GmailContactInfo) | Gets the simple string value used to name this entry. It allows UIs to display a label such as "Work", "Personal", "Preferred", etc.
Number | Gets the phone number.
Primary (inherited from GmailContactInfo) | Gets the primary. When multiple entry extensions appear in a contact kind, indicates which is primary. At most one entry may be primary.
Type (inherited from GmailContactInfo) | Gets the value that identifies the type of entry

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

GmailContactPhoneNumber Class | Aspose.Email.Services.Google Namespace


GmailContactPhoneNumber Properties

The properties of the GmailContactPhoneNumber class are listed below. For a complete list of GmailContactPhoneNumber class members, see the GmailContactPhoneNumber Members topic.

Public Instance Properties

Label (inherited from GmailContactInfo) | Gets the simple string value used to name this entry. It allows UIs to display a label such as "Work", "Personal", "Preferred", etc.
Number | Gets the phone number.
Primary (inherited from GmailContactInfo) | Gets the primary. When multiple entry extensions appear in a contact kind, indicates which is primary. At most one entry may be primary.
Type (inherited from GmailContactInfo) | Gets the value that identifies the type of entry

See Also

GmailContactPhoneNumber Class | Aspose.Email.Services.Google Namespace


Number Property

Aspose.Email

GmailContactPhoneNumber.Number Property

Gets the phone number.

public string Number {get;}

Property Value

The phone number.

See Also

GmailContactPhoneNumber Class | Aspose.Email.Services.Google Namespace


GmailContactPostalAddress Class

Represents a postal address of person

For a list of all members of this type, see GmailContactPostalAddress Members.

System.Object
Aspose.Email.Services.Google.GmailContactInfo
Aspose.Email.Services.Google.GmailContactPostalAddress

public sealed class GmailContactPostalAddress : GmailContactInfo

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Services.Google

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

GmailContactPostalAddress Members | Aspose.Email.Services.Google Namespace


GmailContactPostalAddress Members

GmailContactPostalAddress overview

Public Instance Properties

Agent | Gets the agent who actually receives the mail. Used in work addresses. Also for 'in care of' or 'c/o'.
City | Gets the name of city. Can be city, village, town, borough, etc. This is the postal town and not necessarily the place of residence or place of business.
Country | Gets the name or code of the country.
FormattedAddress | Gets the full, unstructured postal address.
Housename | Gets the housename. Used in places where houses or buildings have names (and not necessarily numbers), eg. "The Pillars".
Label (inherited from GmailContactInfo) | Gets the simple string value used to name this entry. It allows UIs to display a label such as "Work", "Personal", "Preferred", etc.
MailClass | Gets the classes of mail accepted at the address. Unless specified both is assumed.
Neighborhood | Get the neighborhood name. This is used to disambiguate a street address when a city contains more than one street with the same name, or to specify a small place whose mail is routed through a larger postal town.
Pobox | Gets the value that covers actual P.O. boxes, drawers, locked bags, etc. This is usually but not always mutually exclusive with street.
Postcode | Gets the postal code. Usually country-wide, but sometimes specific to the city (e.g. "2" in "Dublin 2, Ireland" addresses).
Primary (inherited from GmailContactInfo) | Gets the primary. When multiple entry extensions appear in a contact kind, indicates which is primary. At most one entry may be primary.
Region | Gets the region, state, province, county (in Ireland), Land (in Germany), departement (in France), etc.
Street | Gets the street, avenue, road, etc. This value also includes the house number and room/apartment/flat/floor number.
Subregion | Gets the subregion. Handles administrative districts such as U.S. or U.K. counties that are not used for mail addressing purposes. Subregion is not intended for delivery addresses.
Type (inherited from GmailContactInfo) | Gets the value that identifies the type of entry
Usage | Gets the context in which this addess can be used. Local addresses may differ in layout from general addresses, and frequently use local script (as opposed to Latin script) as well, though local script is allowed in general addresses. Unless specified general usage is assumed.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

GmailContactPostalAddress Class | Aspose.Email.Services.Google Namespace


GmailContactPostalAddress Properties

The properties of the GmailContactPostalAddress class are listed below. For a complete list of GmailContactPostalAddress class members, see the GmailContactPostalAddress Members topic.

Public Instance Properties

Agent | Gets the agent who actually receives the mail. Used in work addresses. Also for 'in care of' or 'c/o'.
City | Gets the name of city. Can be city, village, town, borough, etc. This is the postal town and not necessarily the place of residence or place of business.
Country | Gets the name or code of the country.
FormattedAddress | Gets the full, unstructured postal address.
Housename | Gets the housename. Used in places where houses or buildings have names (and not necessarily numbers), eg. "The Pillars".
Label (inherited from GmailContactInfo) | Gets the simple string value used to name this entry. It allows UIs to display a label such as "Work", "Personal", "Preferred", etc.
MailClass | Gets the classes of mail accepted at the address. Unless specified both is assumed.
Neighborhood | Get the neighborhood name. This is used to disambiguate a street address when a city contains more than one street with the same name, or to specify a small place whose mail is routed through a larger postal town.
Pobox | Gets the value that covers actual P.O. boxes, drawers, locked bags, etc. This is usually but not always mutually exclusive with street.
Postcode | Gets the postal code. Usually country-wide, but sometimes specific to the city (e.g. "2" in "Dublin 2, Ireland" addresses).
Primary (inherited from GmailContactInfo) | Gets the primary. When multiple entry extensions appear in a contact kind, indicates which is primary. At most one entry may be primary.
Region | Gets the region, state, province, county (in Ireland), Land (in Germany), departement (in France), etc.
Street | Gets the street, avenue, road, etc. This value also includes the house number and room/apartment/flat/floor number.
Subregion | Gets the subregion. Handles administrative districts such as U.S. or U.K. counties that are not used for mail addressing purposes. Subregion is not intended for delivery addresses.
Type (inherited from GmailContactInfo) | Gets the value that identifies the type of entry
Usage | Gets the context in which this addess can be used. Local addresses may differ in layout from general addresses, and frequently use local script (as opposed to Latin script) as well, though local script is allowed in general addresses. Unless specified general usage is assumed.

See Also

GmailContactPostalAddress Class | Aspose.Email.Services.Google Namespace


Agent Property

Aspose.Email

GmailContactPostalAddress.Agent Property

Gets the agent who actually receives the mail. Used in work addresses. Also for 'in care of' or 'c/o'.

public string Agent {get;}

Property Value

The agent.

See Also

GmailContactPostalAddress Class | Aspose.Email.Services.Google Namespace


City Property

Aspose.Email

GmailContactPostalAddress.City Property

Gets the name of city. Can be city, village, town, borough, etc. This is the postal town and not necessarily the place of residence or place of business.

public string City {get;}

Property Value

The city.

See Also

GmailContactPostalAddress Class | Aspose.Email.Services.Google Namespace


Country Property

Aspose.Email

GmailContactPostalAddress.Country Property

Gets the name or code of the country.

public string Country {get;}

Property Value

The name or code of the country.

See Also

GmailContactPostalAddress Class | Aspose.Email.Services.Google Namespace


FormattedAddress Property

Aspose.Email

GmailContactPostalAddress.FormattedAddress Property

Gets the full, unstructured postal address.

public string FormattedAddress {get;}

Property Value

The formatted address.

See Also

GmailContactPostalAddress Class | Aspose.Email.Services.Google Namespace


Housename Property

Aspose.Email

GmailContactPostalAddress.Housename Property

Gets the housename. Used in places where houses or buildings have names (and not necessarily numbers), eg. "The Pillars".

public string Housename {get;}

Property Value

The housename.

See Also

GmailContactPostalAddress Class | Aspose.Email.Services.Google Namespace


MailClass Property

Aspose.Email

GmailContactPostalAddress.MailClass Property

Gets the classes of mail accepted at the address. Unless specified both is assumed.

public string MailClass {get;}

Property Value

The mail class.

See Also

GmailContactPostalAddress Class | Aspose.Email.Services.Google Namespace


Neighborhood Property

Aspose.Email

GmailContactPostalAddress.Neighborhood Property

Get the neighborhood name. This is used to disambiguate a street address when a city contains more than one street with the same name, or to specify a small place whose mail is routed through a larger postal town.

public string Neighborhood {get;}

Property Value

The neighborhood.

See Also

GmailContactPostalAddress Class | Aspose.Email.Services.Google Namespace


Pobox Property

Aspose.Email

GmailContactPostalAddress.Pobox Property

Gets the value that covers actual P.O. boxes, drawers, locked bags, etc. This is usually but not always mutually exclusive with street.

public string Pobox {get;}

Property Value

The pobox.

See Also

GmailContactPostalAddress Class | Aspose.Email.Services.Google Namespace


Postcode Property

Aspose.Email

GmailContactPostalAddress.Postcode Property

Gets the postal code. Usually country-wide, but sometimes specific to the city (e.g. "2" in "Dublin 2, Ireland" addresses).

public string Postcode {get;}

Property Value

The postal code.

See Also

GmailContactPostalAddress Class | Aspose.Email.Services.Google Namespace


Region Property

Aspose.Email

GmailContactPostalAddress.Region Property

Gets the region, state, province, county (in Ireland), Land (in Germany), departement (in France), etc.

public string Region {get;}

Property Value

The region.

See Also

GmailContactPostalAddress Class | Aspose.Email.Services.Google Namespace


Street Property

Aspose.Email

GmailContactPostalAddress.Street Property

Gets the street, avenue, road, etc. This value also includes the house number and room/apartment/flat/floor number.

public string Street {get;}

Property Value

The street.

See Also

GmailContactPostalAddress Class | Aspose.Email.Services.Google Namespace


Subregion Property

Aspose.Email

GmailContactPostalAddress.Subregion Property

Gets the subregion. Handles administrative districts such as U.S. or U.K. counties that are not used for mail addressing purposes. Subregion is not intended for delivery addresses.

public string Subregion {get;}

Property Value

The subregion.

See Also

GmailContactPostalAddress Class | Aspose.Email.Services.Google Namespace


Usage Property

Aspose.Email

GmailContactPostalAddress.Usage Property

Gets the context in which this addess can be used. Local addresses may differ in layout from general addresses, and frequently use local script (as opposed to Latin script) as well, though local script is allowed in general addresses. Unless specified general usage is assumed.

public string Usage {get;}

Property Value

The usage.

See Also

GmailContactPostalAddress Class | Aspose.Email.Services.Google Namespace


IFeedEntry Interface

Represents a child element of the Atom feed format

For a list of all members of this type, see IFeedEntry Members.

public interface IFeedEntry

Types that implement IFeedEntry

Type | Description
GmailContact | Represents a contact of gmail
GmailContactGroup | Represents a group which owns the contact

Requirements

Namespace: Aspose.Email.Services.Google

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

IFeedEntry Members | Aspose.Email.Services.Google Namespace


IFeedEntry Members

IFeedEntry overview

Public Instance Properties

Content | Gets the content of the entry
Id | Gets the unique identifier for an entry
Title | Gets the human-readable title for an entry
Updated | Gets the date indicating the most recent instant in time when an entry was modified

See Also

IFeedEntry Interface | Aspose.Email.Services.Google Namespace


IFeedEntry Properties

The properties of the IFeedEntry interface are listed below. For a complete list of IFeedEntry interface members, see the IFeedEntry Members topic.

Public Instance Properties

Content | Gets the content of the entry
Id | Gets the unique identifier for an entry
Title | Gets the human-readable title for an entry
Updated | Gets the date indicating the most recent instant in time when an entry was modified

See Also

IFeedEntry Interface | Aspose.Email.Services.Google Namespace


Content Property

Aspose.Email

IFeedEntry.Content Property

Gets the content of the entry

string Content {get;}

Property Value

The content

See Also

IFeedEntry Interface | Aspose.Email.Services.Google Namespace


Id Property

Aspose.Email

IFeedEntry.Id Property

Gets the unique identifier for an entry

string Id {get;}

Property Value

The id

See Also

IFeedEntry Interface | Aspose.Email.Services.Google Namespace


Title Property

Aspose.Email

IFeedEntry.Title Property

Gets the human-readable title for an entry

string Title {get;}

Property Value

The title

See Also

IFeedEntry Interface | Aspose.Email.Services.Google Namespace


Updated Property

Aspose.Email

IFeedEntry.Updated Property

Gets the date indicating the most recent instant in time when an entry was modified

DateTime Updated {get;}

Property Value

The updated.

See Also

IFeedEntry Interface | Aspose.Email.Services.Google Namespace


Aspose.Email.Verify

Aspose.Email

Aspose.Email.Verify Namespace

Namespace hierarchy

Classes

Class | Description
DomainValidatingEventArgs | Provides data for the DomainValidating event.
EmailValidator | EmailValidator class provides the capability to validate e-mail addresses.
MailServerValidatingEventArgs | Provides data for the MailServerValidatingEvent event.
SyntaxValidatingEventArgs | Provides data for the SyntaxValidating event.
ValidationResult | Present the result of the email validating process.

Delegates

Delegate | Description
DomainValidatingEventHandler | Represents the event handler for DomainValidatingEvent.
MailServerValidatingEventHandler | Represents the event handler for MailServerValidatingEvent.
SyntaxValidatingEventHandler | Represents the event handler for SyntaxValidatingEvent.

Enumerations

Enumeration | Description
ValidationPolicy | Presents the policy of validating email address.
ValidationResponseCode | Represents the response status of the mail validating process.


DomainValidatingEventArgs Class

Provides data for the DomainValidating event.

For a list of all members of this type, see DomainValidatingEventArgs Members.

System.Object
System.EventArgs
Aspose.Email.Verify.SyntaxValidatingEventArgs
Aspose.Email.Verify.DomainValidatingEventArgs
Aspose.Email.Verify.MailServerValidatingEventArgs

public class DomainValidatingEventArgs : SyntaxValidatingEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Verify

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DomainValidatingEventArgs Members | Aspose.Email.Verify Namespace


DomainValidatingEventArgs Members

DomainValidatingEventArgs overview

Public Instance Constructors

DomainValidatingEventArgs Constructor Initializes a new instance of the SyntaxValidatingEventArgs class.

Public Instance Properties

Domain | Gets the domain.
Mail (inherited from SyntaxValidatingEventArgs) | Gets the mail address is being validating.
MailAddress | Gets the mail address.
Result (inherited from SyntaxValidatingEventArgs) | Gets or sets the validation result.
Skip (inherited from SyntaxValidatingEventArgs) | Indicates whether to ignore the check.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

DomainValidatingEventArgs Class | Aspose.Email.Verify Namespace


DomainValidatingEventArgs Constructor

Initializes a new instance of the SyntaxValidatingEventArgs class.

public DomainValidatingEventArgs(
string mail,
MailAddress mailaddress
);

Parameters

mail
The mail address.
mailaddress
The mail address.

See Also

DomainValidatingEventArgs Class | Aspose.Email.Verify Namespace


DomainValidatingEventArgs Properties

The properties of the DomainValidatingEventArgs class are listed below. For a complete list of DomainValidatingEventArgs class members, see the DomainValidatingEventArgs Members topic.

Public Instance Properties

Domain | Gets the domain.
Mail (inherited from SyntaxValidatingEventArgs) | Gets the mail address is being validating.
MailAddress | Gets the mail address.
Result (inherited from SyntaxValidatingEventArgs) | Gets or sets the validation result.
Skip (inherited from SyntaxValidatingEventArgs) | Indicates whether to ignore the check.

See Also

DomainValidatingEventArgs Class | Aspose.Email.Verify Namespace


Domain Property

Aspose.Email

DomainValidatingEventArgs.Domain Property

Gets the domain.

public string Domain {get;}

See Also

DomainValidatingEventArgs Class | Aspose.Email.Verify Namespace


MailAddress Property

Aspose.Email

DomainValidatingEventArgs.MailAddress Property

Gets the mail address.

public MailAddress MailAddress {get;}

See Also

DomainValidatingEventArgs Class | Aspose.Email.Verify Namespace


DomainValidatingEventHandler Delegate

Represents the event handler for DomainValidatingEvent.

public delegate void DomainValidatingEventHandler(
object sender,
DomainValidatingEventArgs e
);

Parameters

sender
The sender.
e
The event arguments.

Requirements

Namespace: Aspose.Email.Verify

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Verify Namespace


EmailValidator Class

EmailValidator class provides the capability to validate e-mail addresses.

For a list of all members of this type, see EmailValidator Members.

System.Object
Aspose.Email.Verify.EmailValidator

public sealed class EmailValidator

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Example

The following example demonstrates how to use EmailValidator to validate e-mail addresses.

[C#]

[Visual Basic]

Requirements
Namespace:  Aspose.Email.Verify
Assembly: Aspose.Email (in Aspose.Email.dll)

See Also
EmailValidator Members | Aspose.Email.Verify Namespace


EmailValidator Members

EmailValidator overview

Public Instance Constructors

EmailValidator Constructor Create an instance of EmailValidator.

Public Instance Properties

DnsServers | Gets or sets the Dns server list to use in the email validation.
Timeout | Gets or sets the length of time (in milliseconds) until the request times out.

Public Instance Methods

BeginValidate |
EndValidate |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate | Overloaded.

Public Instance Events

DomainValidating | This event occurs when validating the domain of an email addresss.
MailServerValidating | This event occurs when validating an email addresss on its mail server.
SyntaxValidating | This event occurs when validating the syntax of an email addresss.

See Also

EmailValidator Class | Aspose.Email.Verify Namespace


EmailValidator Constructor

Create an instance of EmailValidator.

public EmailValidator();

See Also

EmailValidator Class | Aspose.Email.Verify Namespace


EmailValidator Properties

The properties of the EmailValidator class are listed below. For a complete list of EmailValidator class members, see the EmailValidator Members topic.

Public Instance Properties

DnsServers | Gets or sets the Dns server list to use in the email validation.
Timeout | Gets or sets the length of time (in milliseconds) until the request times out.

See Also

EmailValidator Class | Aspose.Email.Verify Namespace


DnsServers Property

Aspose.Email

EmailValidator.DnsServers Property

Gets or sets the Dns server list to use in the email validation.

public string[] DnsServers {get; set;}

See Also

EmailValidator Class | Aspose.Email.Verify Namespace


Timeout Property

Aspose.Email

EmailValidator.Timeout Property

Gets or sets the length of time (in milliseconds) until the request times out.

public int Timeout {get; set;}

See Also

EmailValidator Class | Aspose.Email.Verify Namespace


EmailValidator Methods

The methods of the EmailValidator class are listed below. For a complete list of EmailValidator class members, see the EmailValidator Members topic.

Public Instance Methods

BeginValidate |
EndValidate |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.
Validate | Overloaded.

See Also

EmailValidator Class | Aspose.Email.Verify Namespace


EmailValidator.BeginValidate Method

public IAsyncResult BeginValidate(
string mailAddress,
ValidationPolicy policy,
out ValidationResult result,
AsyncCallback asyncCallback,
object stateObject
);

See Also

EmailValidator Class | Aspose.Email.Verify Namespace


EmailValidator.EndValidate Method

public void EndValidate(
out ValidationResult validationResult,
IAsyncResult asyncResult
);

See Also

EmailValidator Class | Aspose.Email.Verify Namespace


Validate Method

Aspose.Email

EmailValidator.Validate Method

Overload List

public void Validate(string,ValidationPolicy,out ValidationResult);

public void Validate(string,out ValidationResult);

See Also

EmailValidator Class | Aspose.Email.Verify Namespace


EmailValidator.Validate Method (String, ValidationPolicy, ValidationResult)

public void Validate(
string mailAddress,
ValidationPolicy policy,
out ValidationResult result
);

See Also

EmailValidator Class | Aspose.Email.Verify Namespace | EmailValidator.Validate Overload List


EmailValidator.Validate Method (String, ValidationResult)

public void Validate(
string mailAddress,
out ValidationResult result
);

See Also

EmailValidator Class | Aspose.Email.Verify Namespace | EmailValidator.Validate Overload List


EmailValidator Events

The events of the EmailValidator class are listed below. For a complete list of EmailValidator class members, see the EmailValidator Members topic.

Public Instance Events

DomainValidating | This event occurs when validating the domain of an email addresss.
MailServerValidating | This event occurs when validating an email addresss on its mail server.
SyntaxValidating | This event occurs when validating the syntax of an email addresss.

See Also

EmailValidator Class | Aspose.Email.Verify Namespace


EmailValidator.DomainValidating Event

This event occurs when validating the domain of an email addresss.

public event DomainValidatingEventHandler DomainValidating;

Event Data

The event handler receives an argument of type DomainValidatingEventArgs containing data related to this event. The following DomainValidatingEventArgs properties provide information specific to this event.

Property | Description
Domain | Gets the domain.
Mail | Gets the mail address is being validating.
MailAddress | Gets the mail address.
Result | Gets or sets the validation result.
Skip | Indicates whether to ignore the check.

See Also

EmailValidator Class | Aspose.Email.Verify Namespace


EmailValidator.MailServerValidating Event

This event occurs when validating an email addresss on its mail server.

public event MailServerValidatingEventHandler MailServerValidating;

Event Data

The event handler receives an argument of type MailServerValidatingEventArgs containing data related to this event. The following MailServerValidatingEventArgs properties provide information specific to this event.

Property | Description
Domain | Gets the domain.
Mail | Gets the mail address is being validating.
MailAddress | Gets the mail address.
MailExchangeServers | Gets the mail exchange server list.
Result | Gets or sets the validation result.
Skip | Indicates whether to ignore the check.

See Also

EmailValidator Class | Aspose.Email.Verify Namespace


EmailValidator.SyntaxValidating Event

This event occurs when validating the syntax of an email addresss.

public event SyntaxValidatingEventHandler SyntaxValidating;

Event Data

The event handler receives an argument of type SyntaxValidatingEventArgs containing data related to this event. The following SyntaxValidatingEventArgs properties provide information specific to this event.

Property | Description
Mail | Gets the mail address is being validating.
Result | Gets or sets the validation result.
Skip | Indicates whether to ignore the check.

See Also

EmailValidator Class | Aspose.Email.Verify Namespace


MailServerValidatingEventArgs Class

Provides data for the MailServerValidatingEvent event.

For a list of all members of this type, see MailServerValidatingEventArgs Members.

System.Object
System.EventArgs
Aspose.Email.Verify.SyntaxValidatingEventArgs
Aspose.Email.Verify.DomainValidatingEventArgs
Aspose.Email.Verify.MailServerValidatingEventArgs

public class MailServerValidatingEventArgs : DomainValidatingEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Verify

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MailServerValidatingEventArgs Members | Aspose.Email.Verify Namespace


MailServerValidatingEventArgs Members

MailServerValidatingEventArgs overview

Public Instance Constructors

MailServerValidatingEventArgs Constructor Initializes a new instance of the SyntaxValidatingEventArgs class.

Public Instance Properties

Domain (inherited from DomainValidatingEventArgs) | Gets the domain.
Mail (inherited from SyntaxValidatingEventArgs) | Gets the mail address is being validating.
MailAddress (inherited from DomainValidatingEventArgs) | Gets the mail address.
MailExchangeServers | Gets the mail exchange server list.
Result (inherited from SyntaxValidatingEventArgs) | Gets or sets the validation result.
Skip (inherited from SyntaxValidatingEventArgs) | Indicates whether to ignore the check.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MailServerValidatingEventArgs Class | Aspose.Email.Verify Namespace


MailServerValidatingEventArgs Constructor

Initializes a new instance of the SyntaxValidatingEventArgs class.

public MailServerValidatingEventArgs(
string mail,
MailAddress mailaddress,
string[] mailExchangeList
);

Parameters

mail
A string contains the original copy of the mail address.
mailaddress
The MailAddress.
mailExchangeList
A set of mail exchange server list.

See Also

MailServerValidatingEventArgs Class | Aspose.Email.Verify Namespace


MailServerValidatingEventArgs Properties

The properties of the MailServerValidatingEventArgs class are listed below. For a complete list of MailServerValidatingEventArgs class members, see the MailServerValidatingEventArgs Members topic.

Public Instance Properties

Domain (inherited from DomainValidatingEventArgs) | Gets the domain.
Mail (inherited from SyntaxValidatingEventArgs) | Gets the mail address is being validating.
MailAddress (inherited from DomainValidatingEventArgs) | Gets the mail address.
MailExchangeServers | Gets the mail exchange server list.
Result (inherited from SyntaxValidatingEventArgs) | Gets or sets the validation result.
Skip (inherited from SyntaxValidatingEventArgs) | Indicates whether to ignore the check.

See Also

MailServerValidatingEventArgs Class | Aspose.Email.Verify Namespace


MailExchangeServers Property

Aspose.Email

MailServerValidatingEventArgs.MailExchangeServers Property

Gets the mail exchange server list.

new public string[] MailExchangeServers {get;}

See Also

MailServerValidatingEventArgs Class | Aspose.Email.Verify Namespace


MailServerValidatingEventHandler Delegate

Represents the event handler for MailServerValidatingEvent.

public delegate void MailServerValidatingEventHandler(
object sender,
MailServerValidatingEventArgs e
);

Parameters

sender
The sender.
e
The event arguments.

Requirements

Namespace: Aspose.Email.Verify

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Verify Namespace


SyntaxValidatingEventArgs Class

Provides data for the SyntaxValidating event.

For a list of all members of this type, see SyntaxValidatingEventArgs Members.

System.Object
System.EventArgs
Aspose.Email.Verify.SyntaxValidatingEventArgs
Aspose.Email.Verify.DomainValidatingEventArgs

public class SyntaxValidatingEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Verify

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

SyntaxValidatingEventArgs Members | Aspose.Email.Verify Namespace


SyntaxValidatingEventArgs Members

SyntaxValidatingEventArgs overview

Public Instance Constructors

SyntaxValidatingEventArgs Constructor Initializes a new instance of the SyntaxValidatingEventArgs class.

Public Instance Properties

Mail | Gets the mail address is being validating.
Result | Gets or sets the validation result.
Skip | Indicates whether to ignore the check.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SyntaxValidatingEventArgs Class | Aspose.Email.Verify Namespace


SyntaxValidatingEventArgs Constructor

Initializes a new instance of the SyntaxValidatingEventArgs class.

public SyntaxValidatingEventArgs(
string mail
);

Parameters

mail
The mail address.

See Also

SyntaxValidatingEventArgs Class | Aspose.Email.Verify Namespace


SyntaxValidatingEventArgs Properties

The properties of the SyntaxValidatingEventArgs class are listed below. For a complete list of SyntaxValidatingEventArgs class members, see the SyntaxValidatingEventArgs Members topic.

Public Instance Properties

Mail | Gets the mail address is being validating.
Result | Gets or sets the validation result.
Skip | Indicates whether to ignore the check.

See Also

SyntaxValidatingEventArgs Class | Aspose.Email.Verify Namespace


Mail Property

Aspose.Email

SyntaxValidatingEventArgs.Mail Property

Gets the mail address is being validating.

public string Mail {get;}

See Also

SyntaxValidatingEventArgs Class | Aspose.Email.Verify Namespace


Result Property

Aspose.Email

SyntaxValidatingEventArgs.Result Property

Gets or sets the validation result.

public ValidationResult Result {get; set;}

See Also

SyntaxValidatingEventArgs Class | Aspose.Email.Verify Namespace


Skip Property

Aspose.Email

SyntaxValidatingEventArgs.Skip Property

Indicates whether to ignore the check.

public bool Skip {get; set;}

See Also

SyntaxValidatingEventArgs Class | Aspose.Email.Verify Namespace


SyntaxValidatingEventHandler Delegate

Represents the event handler for SyntaxValidatingEvent.

public delegate void SyntaxValidatingEventHandler(
object sender,
SyntaxValidatingEventArgs e
);

Parameters

sender
The sender.
e
The event arguments.

Requirements

Namespace: Aspose.Email.Verify

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Verify Namespace


ValidationPolicy Enumeration

Presents the policy of validating email address.

public enum ValidationPolicy

Members

Member Name | Description | Value
SyntaxOnly | Validating the syntax of the email address. | 0
SyntaxAndDomain | Validating the syntax of the email address firstly, and then validate the domain of the email. | 1
MailServer | Validating the email address by trying to connet to the mail server. | 2

Requirements

Namespace: Aspose.Email.Verify

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Verify Namespace


ValidationResponseCode Enumeration

Represents the response status of the mail validating process.

public enum ValidationResponseCode

Members

Member Name | Description | Value
ValidationSuccess | The mail address validating is successful. | 0
SyntaxValidationFailed | The mail address validating process failed at the syntax validation. | -1
DomainValidationFailed | The mail address validating process failed at the domain validation. | -2
MailServerValidationError | The mail address validating process failed at the mail server validation. | -3

Requirements

Namespace: Aspose.Email.Verify

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Email.Verify Namespace


ValidationResult Class

Present the result of the email validating process.

For a list of all members of this type, see ValidationResult Members.

System.Object
Aspose.Email.Verify.ValidationResult

public class ValidationResult

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Verify

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ValidationResult Members | Aspose.Email.Verify Namespace


ValidationResult Members

ValidationResult overview

Public Instance Constructors

ValidationResult Overloaded. Initializes a new instance of the ValidationResult class.

Public Instance Properties

LastException | The last error met in the validating process.
Message | Gets the detail message about the result.
ReturnCode | Gets or ses the response code of the validating process.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ValidationResult Class | Aspose.Email.Verify Namespace


ValidationResult Constructor

Create an instance of the ValidationResult class

Overload List

Create an instance of the ValidationResult class

public ValidationResult();

Create an instance of the ValidationResult class, with the specified ValidationResponseCode

public ValidationResult(ValidationResponseCode);

Create an instance of the ValidationResult class, with the specified ValidationResponseCode, and the last exception.

public ValidationResult(ValidationResponseCode,Exception);

See Also

ValidationResult Class | Aspose.Email.Verify Namespace


ValidationResult Constructor ()

Create an instance of the ValidationResult class

public ValidationResult();

See Also

ValidationResult Class | Aspose.Email.Verify Namespace | ValidationResult Constructor Overload List


ValidationResult Constructor (ValidationResponseCode)

Create an instance of the ValidationResult class, with the specified ValidationResponseCode

public ValidationResult(
ValidationResponseCode responseCode
);

Parameters

responseCode
The response code of the validating process.

See Also

ValidationResult Class | Aspose.Email.Verify Namespace | ValidationResult Constructor Overload List | ValidationResponseCode


ValidationResult Constructor (ValidationResponseCode, Exception)

Create an instance of the ValidationResult class, with the specified ValidationResponseCode, and the last exception.

public ValidationResult(
ValidationResponseCode responseCode,
Exception lastException
);

Parameters

responseCode
The response code of the validating process.
lastException
The last exception met in the validating process.

See Also

ValidationResult Class | Aspose.Email.Verify Namespace | ValidationResult Constructor Overload List | ValidationResponseCode


ValidationResult Properties

The properties of the ValidationResult class are listed below. For a complete list of ValidationResult class members, see the ValidationResult Members topic.

Public Instance Properties

LastException | The last error met in the validating process.
Message | Gets the detail message about the result.
ReturnCode | Gets or ses the response code of the validating process.

See Also

ValidationResult Class | Aspose.Email.Verify Namespace


LastException Property

Aspose.Email

ValidationResult.LastException Property

The last error met in the validating process.

public Exception LastException {get; set;}

See Also

ValidationResult Class | Aspose.Email.Verify Namespace


Message Property

Aspose.Email

ValidationResult.Message Property

Gets the detail message about the result.

public string Message {get;}

See Also

ValidationResult Class | Aspose.Email.Verify Namespace


ReturnCode Property

Aspose.Email

ValidationResult.ReturnCode Property

Gets or ses the response code of the validating process.

public ValidationResponseCode ReturnCode {get; set;}

See Also

ValidationResult Class | Aspose.Email.Verify Namespace


Aspose.Email.Windows.WPF

Aspose.Email

Aspose.Email.Windows.WPF Namespace

Namespace hierarchy

Classes

Class | Description
FileDropEventArgs | Specialized version of EventArgs for FileDropPanel.
FileDropPanel | FileDropPanel provides ability to handle files dragged from Outlook or elsewhere.


FileDropEventArgs Class

Specialized version of EventArgs for FileDropPanel.

For a list of all members of this type, see FileDropEventArgs Members.

System.Object
System.EventArgs
Aspose.Email.Windows.WPF.FileDropEventArgs

public sealed class FileDropEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Email.Windows.WPF

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FileDropEventArgs Members | Aspose.Email.Windows.WPF Namespace


FileDropEventArgs Members

FileDropEventArgs overview

Public Instance Constructors

FileDropEventArgs Constructor Initializes a new instance of the FileDropEventArgs class.

Public Instance Properties

Files Gets dropped files collection.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FileDropEventArgs Class | Aspose.Email.Windows.WPF Namespace


FileDropEventArgs Constructor

Initializes a new instance of the FileDropEventArgs class.

public FileDropEventArgs(
FileDataObjectCollection files
);

Parameters

files
The files.

See Also

FileDropEventArgs Class | Aspose.Email.Windows.WPF Namespace


FileDropEventArgs Properties

The properties of the FileDropEventArgs class are listed below. For a complete list of FileDropEventArgs class members, see the FileDropEventArgs Members topic.

Public Instance Properties

Files Gets dropped files collection.

See Also

FileDropEventArgs Class | Aspose.Email.Windows.WPF Namespace


Files Property

Aspose.Email

FileDropEventArgs.Files Property

Gets dropped files collection.

public FileDataObjectCollection Files {get;}

See Also

FileDropEventArgs Class | Aspose.Email.Windows.WPF Namespace


FileDropPanel Class

FileDropPanel provides ability to handle files dragged from Outlook or elsewhere.

For a list of all members of this type, see FileDropPanel Members.

System.Object
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement
System.Windows.FrameworkElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl
System.Windows.Controls.UserControl
Aspose.Email.Windows.WPF.FileDropPanel

public sealed class FileDropPanel : UserControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

If component is in evaluation mode, evaluation message will be shown.

Requirements

Namespace: Aspose.Email.Windows.WPF

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FileDropPanel Members | Aspose.Email.Windows.WPF Namespace


FileDropPanel Members

FileDropPanel overview

Public Instance Constructors

FileDropPanel Constructor Initializes a new instance of the FileDropPanel class.

Public Instance Properties

ActualHeight (inherited from FrameworkElement) |
ActualWidth (inherited from FrameworkElement) |
AllowDrop (inherited from UIElement) |
Background (inherited from Control) |
BindingGroup (inherited from FrameworkElement) |
BitmapEffect (inherited from UIElement) | Obsolete.
BitmapEffectInput (inherited from UIElement) | Obsolete.
BorderBrush (inherited from Control) |
BorderThickness (inherited from Control) |
Clip (inherited from UIElement) |
ClipToBounds (inherited from UIElement) |
CommandBindings (inherited from UIElement) |
Content (inherited from ContentControl) |
ContentStringFormat (inherited from ContentControl) |
ContentTemplate (inherited from ContentControl) |
ContentTemplateSelector (inherited from ContentControl) |
ContextMenu (inherited from FrameworkElement) |
Cursor (inherited from FrameworkElement) |
DataContext (inherited from FrameworkElement) |
DependencyObjectType (inherited from DependencyObject) |
DesiredSize (inherited from UIElement) |
Dispatcher (inherited from DispatcherObject) |
Effect (inherited from UIElement) |
FlowDirection (inherited from FrameworkElement) |
Focusable (inherited from UIElement) |
FocusVisualStyle (inherited from FrameworkElement) |
FontFamily (inherited from Control) |
FontSize (inherited from Control) |
FontStretch (inherited from Control) |
FontStyle (inherited from Control) |
FontWeight (inherited from Control) |
ForceCursor (inherited from FrameworkElement) |
Foreground (inherited from Control) |
HasAnimatedProperties (inherited from UIElement) |
HasContent (inherited from ContentControl) |
Height (inherited from FrameworkElement) |
HorizontalAlignment (inherited from FrameworkElement) |
HorizontalContentAlignment (inherited from Control) |
InputBindings (inherited from UIElement) |
InputScope (inherited from FrameworkElement) |
IsArrangeValid (inherited from UIElement) |
IsEnabled (inherited from UIElement) |
IsFocused (inherited from UIElement) |
IsHitTestVisible (inherited from UIElement) |
IsInitialized (inherited from FrameworkElement) |
IsInputMethodEnabled (inherited from UIElement) |
IsKeyboardFocused (inherited from UIElement) |
IsKeyboardFocusWithin (inherited from UIElement) |
IsLoaded (inherited from FrameworkElement) |
IsMeasureValid (inherited from UIElement) |
IsMouseCaptured (inherited from UIElement) |
IsMouseCaptureWithin (inherited from UIElement) |
IsMouseDirectlyOver (inherited from UIElement) |
IsMouseOver (inherited from UIElement) |
IsSealed (inherited from DependencyObject) |
IsStylusCaptured (inherited from UIElement) |
IsStylusCaptureWithin (inherited from UIElement) |
IsStylusDirectlyOver (inherited from UIElement) |
IsStylusOver (inherited from UIElement) |
IsTabStop (inherited from Control) |
IsVisible (inherited from UIElement) |
Language (inherited from FrameworkElement) |
LayoutTransform (inherited from FrameworkElement) |
Margin (inherited from FrameworkElement) |
MaxHeight (inherited from FrameworkElement) |
MaxWidth (inherited from FrameworkElement) |
MinHeight (inherited from FrameworkElement) |
MinWidth (inherited from FrameworkElement) |
Name (inherited from FrameworkElement) |
Opacity (inherited from UIElement) |
OpacityMask (inherited from UIElement) |
OverridesDefaultStyle (inherited from FrameworkElement) |
Padding (inherited from Control) |
Parent (inherited from FrameworkElement) |
PersistId (inherited from UIElement) | Obsolete.
RenderSize (inherited from UIElement) |
RenderTransform (inherited from UIElement) |
RenderTransformOrigin (inherited from UIElement) |
Resources (inherited from FrameworkElement) |
SnapsToDevicePixels (inherited from UIElement) |
Style (inherited from FrameworkElement) |
TabIndex (inherited from Control) |
Tag (inherited from FrameworkElement) |
Template (inherited from Control) |
TemplatedParent (inherited from FrameworkElement) |
ToolTip (inherited from FrameworkElement) |
Triggers (inherited from FrameworkElement) |
Uid (inherited from UIElement) |
VerticalAlignment (inherited from FrameworkElement) |
VerticalContentAlignment (inherited from Control) |
Visibility (inherited from UIElement) |
Width (inherited from FrameworkElement) |

Public Instance Methods

AddHandler (inherited from UIElement) | Overloaded.
AddToEventRoute (inherited from UIElement) |
ApplyAnimationClock (inherited from UIElement) | Overloaded.
ApplyTemplate (inherited from FrameworkElement) |
Arrange (inherited from UIElement) |
BeginAnimation (inherited from UIElement) | Overloaded.
BeginInit (inherited from FrameworkElement) |
BeginStoryboard (inherited from FrameworkElement) | Overloaded.
BringIntoView (inherited from FrameworkElement) | Overloaded.
CaptureMouse (inherited from UIElement) |
CaptureStylus (inherited from UIElement) |
CheckAccess (inherited from DispatcherObject) |
ClearValue (inherited from DependencyObject) | Overloaded.
CoerceValue (inherited from DependencyObject) |
EndInit (inherited from FrameworkElement) |
Equals (inherited from DependencyObject) |
FindCommonVisualAncestor (inherited from Visual) |
FindName (inherited from FrameworkElement) |
FindResource (inherited from FrameworkElement) |
Focus (inherited from UIElement) |
GetAnimationBaseValue (inherited from UIElement) |
GetBindingExpression (inherited from FrameworkElement) |
GetHashCode (inherited from DependencyObject) |
GetLocalValueEnumerator (inherited from DependencyObject) |
GetType (inherited from Object) | Gets the Type of the current instance.
GetValue (inherited from DependencyObject) |
InputHitTest (inherited from UIElement) |
InvalidateArrange (inherited from UIElement) |
InvalidateMeasure (inherited from UIElement) |
InvalidateProperty (inherited from DependencyObject) |
InvalidateVisual (inherited from UIElement) |
IsAncestorOf (inherited from Visual) |
IsDescendantOf (inherited from Visual) |
Measure (inherited from UIElement) |
MoveFocus (inherited from FrameworkElement) |
OnApplyTemplate (inherited from FrameworkElement) |
PointFromScreen (inherited from Visual) |
PointToScreen (inherited from Visual) |
PredictFocus (inherited from FrameworkElement) |
RaiseEvent (inherited from UIElement) |
ReadLocalValue (inherited from DependencyObject) |
RegisterName (inherited from FrameworkElement) |
ReleaseMouseCapture (inherited from UIElement) |
ReleaseStylusCapture (inherited from UIElement) |
RemoveHandler (inherited from UIElement) |
SetBinding (inherited from FrameworkElement) | Overloaded.
SetResourceReference (inherited from FrameworkElement) |
SetValue (inherited from DependencyObject) | Overloaded.
ShouldSerializeCommandBindings (inherited from UIElement) |
ShouldSerializeContent (inherited from ContentControl) |
ShouldSerializeInputBindings (inherited from UIElement) |
ShouldSerializeResources (inherited from FrameworkElement) |
ShouldSerializeStyle (inherited from FrameworkElement) |
ShouldSerializeTriggers (inherited from FrameworkElement) |
ToString (inherited from Control) |
TransformToAncestor (inherited from Visual) | Overloaded.
TransformToDescendant (inherited from Visual) |
TransformToVisual (inherited from Visual) |
TranslatePoint (inherited from UIElement) |
TryFindResource (inherited from FrameworkElement) |
UnregisterName (inherited from FrameworkElement) |
UpdateLayout (inherited from UIElement) |
VerifyAccess (inherited from DispatcherObject) |

Public Instance Events

ContextMenuClosing (inherited from FrameworkElement) |
ContextMenuOpening (inherited from FrameworkElement) |
DataContextChanged (inherited from FrameworkElement) |
DragEnter (inherited from UIElement) |
DragLeave (inherited from UIElement) |
DragOver (inherited from UIElement) |
Drop (inherited from UIElement) |
FilesDropped | This event is being raised when files are dropped to the panel.
FocusableChanged (inherited from UIElement) |
GiveFeedback (inherited from UIElement) |
GotFocus (inherited from UIElement) |
GotKeyboardFocus (inherited from UIElement) |
GotMouseCapture (inherited from UIElement) |
GotStylusCapture (inherited from UIElement) |
Initialized (inherited from FrameworkElement) |
IsEnabledChanged (inherited from UIElement) |
IsHitTestVisibleChanged (inherited from UIElement) |
IsKeyboardFocusedChanged (inherited from UIElement) |
IsKeyboardFocusWithinChanged (inherited from UIElement) |
IsMouseCapturedChanged (inherited from UIElement) |
IsMouseCaptureWithinChanged (inherited from UIElement) |
IsMouseDirectlyOverChanged (inherited from UIElement) |
IsStylusCapturedChanged (inherited from UIElement) |
IsStylusCaptureWithinChanged (inherited from UIElement) |
IsStylusDirectlyOverChanged (inherited from UIElement) |
IsVisibleChanged (inherited from UIElement) |
KeyDown (inherited from UIElement) |
KeyUp (inherited from UIElement) |
LayoutUpdated (inherited from UIElement) |
Loaded (inherited from FrameworkElement) |
LostFocus (inherited from UIElement) |
LostKeyboardFocus (inherited from UIElement) |
LostMouseCapture (inherited from UIElement) |
LostStylusCapture (inherited from UIElement) |
MouseDoubleClick (inherited from Control) |
MouseDown (inherited from UIElement) |
MouseEnter (inherited from UIElement) |
MouseLeave (inherited from UIElement) |
MouseLeftButtonDown (inherited from UIElement) |
MouseLeftButtonUp (inherited from UIElement) |
MouseMove (inherited from UIElement) |
MouseRightButtonDown (inherited from UIElement) |
MouseRightButtonUp (inherited from UIElement) |
MouseUp (inherited from UIElement) |
MouseWheel (inherited from UIElement) |
PreviewDragEnter (inherited from UIElement) |
PreviewDragLeave (inherited from UIElement) |
PreviewDragOver (inherited from UIElement) |
PreviewDrop (inherited from UIElement) |
PreviewGiveFeedback (inherited from UIElement) |
PreviewGotKeyboardFocus (inherited from UIElement) |
PreviewKeyDown (inherited from UIElement) |
PreviewKeyUp (inherited from UIElement) |
PreviewLostKeyboardFocus (inherited from UIElement) |
PreviewMouseDoubleClick (inherited from Control) |
PreviewMouseDown (inherited from UIElement) |
PreviewMouseLeftButtonDown (inherited from UIElement) |
PreviewMouseLeftButtonUp (inherited from UIElement) |
PreviewMouseMove (inherited from UIElement) |
PreviewMouseRightButtonDown (inherited from UIElement) |
PreviewMouseRightButtonUp (inherited from UIElement) |
PreviewMouseUp (inherited from UIElement) |
PreviewMouseWheel (inherited from UIElement) |
PreviewQueryContinueDrag (inherited from UIElement) |
PreviewStylusButtonDown (inherited from UIElement) |
PreviewStylusButtonUp (inherited from UIElement) |
PreviewStylusDown (inherited from UIElement) |
PreviewStylusInAirMove (inherited from UIElement) |
PreviewStylusInRange (inherited from UIElement) |
PreviewStylusMove (inherited from UIElement) |
PreviewStylusOutOfRange (inherited from UIElement) |
PreviewStylusSystemGesture (inherited from UIElement) |
PreviewStylusUp (inherited from UIElement) |
PreviewTextInput (inherited from UIElement) |
QueryContinueDrag (inherited from UIElement) |
QueryCursor (inherited from UIElement) |
RequestBringIntoView (inherited from FrameworkElement) |
SizeChanged (inherited from FrameworkElement) |
SourceUpdated (inherited from FrameworkElement) |
StylusButtonDown (inherited from UIElement) |
StylusButtonUp (inherited from UIElement) |
StylusDown (inherited from UIElement) |
StylusEnter (inherited from UIElement) |
StylusInAirMove (inherited from UIElement) |
StylusInRange (inherited from UIElement) |
StylusLeave (inherited from UIElement) |
StylusMove (inherited from UIElement) |
StylusOutOfRange (inherited from UIElement) |
StylusSystemGesture (inherited from UIElement) |
StylusUp (inherited from UIElement) |
TargetUpdated (inherited from FrameworkElement) |
TextInput (inherited from UIElement) |
ToolTipClosing (inherited from FrameworkElement) |
ToolTipOpening (inherited from FrameworkElement) |
Unloaded (inherited from FrameworkElement) |

Protected Internal Instance Properties

DefaultStyleKey (inherited from FrameworkElement) |
HandlesScrolling (inherited from Control) |
InheritanceBehavior (inherited from FrameworkElement) |
LogicalChildren (inherited from ContentControl) |
VisualBitmapEffect (inherited from Visual) | Obsolete.
VisualBitmapEffectInput (inherited from Visual) | Obsolete.
VisualBitmapScalingMode (inherited from Visual) |
VisualClip (inherited from Visual) |
VisualEdgeMode (inherited from Visual) |
VisualEffect (inherited from Visual) |
VisualOffset (inherited from Visual) |
VisualOpacity (inherited from Visual) |
VisualOpacityMask (inherited from Visual) |
VisualTransform (inherited from Visual) |
VisualXSnappingGuidelines (inherited from Visual) |
VisualYSnappingGuidelines (inherited from Visual) |

Protected Internal Instance Methods

AddLogicalChild (inherited from FrameworkElement)
GetTemplateChild (inherited from FrameworkElement)
GetUIParentCore (inherited from FrameworkElement)
OnRenderSizeChanged (inherited from FrameworkElement)
OnStyleChanged (inherited from FrameworkElement)
OnVisualChildrenChanged (inherited from Visual)
OnVisualParentChanged (inherited from FrameworkElement)
ParentLayoutInvalidated (inherited from FrameworkElement)
RemoveLogicalChild (inherited from FrameworkElement)
ShouldSerializeProperty (inherited from DependencyObject)

See Also

FileDropPanel Class | Aspose.Email.Windows.WPF Namespace


FileDropPanel Constructor

Initializes a new instance of the FileDropPanel class.

public FileDropPanel();

See Also

FileDropPanel Class | Aspose.Email.Windows.WPF Namespace


FileDropPanel Events

The events of the FileDropPanel class are listed below. For a complete list of FileDropPanel class members, see the FileDropPanel Members topic.

Public Instance Events

ContextMenuClosing (inherited from FrameworkElement) |
ContextMenuOpening (inherited from FrameworkElement) |
DataContextChanged (inherited from FrameworkElement) |
DragEnter (inherited from UIElement) |
DragLeave (inherited from UIElement) |
DragOver (inherited from UIElement) |
Drop (inherited from UIElement) |
FilesDropped | This event is being raised when files are dropped to the panel.
FocusableChanged (inherited from UIElement) |
GiveFeedback (inherited from UIElement) |
GotFocus (inherited from UIElement) |
GotKeyboardFocus (inherited from UIElement) |
GotMouseCapture (inherited from UIElement) |
GotStylusCapture (inherited from UIElement) |
Initialized (inherited from FrameworkElement) |
IsEnabledChanged (inherited from UIElement) |
IsHitTestVisibleChanged (inherited from UIElement) |
IsKeyboardFocusedChanged (inherited from UIElement) |
IsKeyboardFocusWithinChanged (inherited from UIElement) |
IsMouseCapturedChanged (inherited from UIElement) |
IsMouseCaptureWithinChanged (inherited from UIElement) |
IsMouseDirectlyOverChanged (inherited from UIElement) |
IsStylusCapturedChanged (inherited from UIElement) |
IsStylusCaptureWithinChanged (inherited from UIElement) |
IsStylusDirectlyOverChanged (inherited from UIElement) |
IsVisibleChanged (inherited from UIElement) |
KeyDown (inherited from UIElement) |
KeyUp (inherited from UIElement) |
LayoutUpdated (inherited from UIElement) |
Loaded (inherited from FrameworkElement) |
LostFocus (inherited from UIElement) |
LostKeyboardFocus (inherited from UIElement) |
LostMouseCapture (inherited from UIElement) |
LostStylusCapture (inherited from UIElement) |
MouseDoubleClick (inherited from Control) |
MouseDown (inherited from UIElement) |
MouseEnter (inherited from UIElement) |
MouseLeave (inherited from UIElement) |
MouseLeftButtonDown (inherited from UIElement) |
MouseLeftButtonUp (inherited from UIElement) |
MouseMove (inherited from UIElement) |
MouseRightButtonDown (inherited from UIElement) |
MouseRightButtonUp (inherited from UIElement) |
MouseUp (inherited from UIElement) |
MouseWheel (inherited from UIElement) |
PreviewDragEnter (inherited from UIElement) |
PreviewDragLeave (inherited from UIElement) |
PreviewDragOver (inherited from UIElement) |
PreviewDrop (inherited from UIElement) |
PreviewGiveFeedback (inherited from UIElement) |
PreviewGotKeyboardFocus (inherited from UIElement) |
PreviewKeyDown (inherited from UIElement) |
PreviewKeyUp (inherited from UIElement) |
PreviewLostKeyboardFocus (inherited from UIElement) |
PreviewMouseDoubleClick (inherited from Control) |
PreviewMouseDown (inherited from UIElement) |
PreviewMouseLeftButtonDown (inherited from UIElement) |
PreviewMouseLeftButtonUp (inherited from UIElement) |
PreviewMouseMove (inherited from UIElement) |
PreviewMouseRightButtonDown (inherited from UIElement) |
PreviewMouseRightButtonUp (inherited from UIElement) |
PreviewMouseUp (inherited from UIElement) |
PreviewMouseWheel (inherited from UIElement) |
PreviewQueryContinueDrag (inherited from UIElement) |
PreviewStylusButtonDown (inherited from UIElement) |
PreviewStylusButtonUp (inherited from UIElement) |
PreviewStylusDown (inherited from UIElement) |
PreviewStylusInAirMove (inherited from UIElement) |
PreviewStylusInRange (inherited from UIElement) |
PreviewStylusMove (inherited from UIElement) |
PreviewStylusOutOfRange (inherited from UIElement) |
PreviewStylusSystemGesture (inherited from UIElement) |
PreviewStylusUp (inherited from UIElement) |
PreviewTextInput (inherited from UIElement) |
QueryContinueDrag (inherited from UIElement) |
QueryCursor (inherited from UIElement) |
RequestBringIntoView (inherited from FrameworkElement) |
SizeChanged (inherited from FrameworkElement) |
SourceUpdated (inherited from FrameworkElement) |
StylusButtonDown (inherited from UIElement) |
StylusButtonUp (inherited from UIElement) |
StylusDown (inherited from UIElement) |
StylusEnter (inherited from UIElement) |
StylusInAirMove (inherited from UIElement) |
StylusInRange (inherited from UIElement) |
StylusLeave (inherited from UIElement) |
StylusMove (inherited from UIElement) |
StylusOutOfRange (inherited from UIElement) |
StylusSystemGesture (inherited from UIElement) |
StylusUp (inherited from UIElement) |
TargetUpdated (inherited from FrameworkElement) |
TextInput (inherited from UIElement) |
ToolTipClosing (inherited from FrameworkElement) |
ToolTipOpening (inherited from FrameworkElement) |
Unloaded (inherited from FrameworkElement) |

See Also

FileDropPanel Class | Aspose.Email.Windows.WPF Namespace


FileDropPanel.FilesDropped Event

This event is being raised when files are dropped to the panel.

public event FileDropEventArgs} FilesDropped;

See Also

FileDropPanel Class | Aspose.Email.Windows.WPF Namespace


Aspose.iCalendar

Aspose.Email

Aspose.iCalendar Namespace

Namespace hierarchy

Classes

Class | Description
ByDay | Represents Nth occurrence (or all occurrences) of the specified day of the week.
ByDayCollection | Represents a collection of ByDay objects.
ByNumberCollection | Represents a set of months, weeks, days, hours, minutes or seconds in a recurrence rule.
DateCollection | Represents a collection of DateTime values.
RecurrencePattern | The main class, represents a recurrence pattern.
RecurrenceRule | Represents one recurrence or exception rule in a recurrence pattern.
RecurrenceRuleCollection | Represents a collection of RecurrenceRule objects.

Enumerations

Enumeration | Description
EndType | Specifies how the recurrence rule ends.
Frequency | Specifies frequency of the recurrence rule.


ByDay Class

Represents Nth occurrence (or all occurrences) of the specified day of the week.

For a list of all members of this type, see ByDay Members.

System.Object
Aspose.iCalendar.ByDay

public class ByDay

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Corresponds to one day of the week specified in the BYDAY part of a recurrence rule.

Can be used in a monthly or yearly recurrence rule to specify Nth occurrence (or all occurrences) of the specified day of the week in a month or year.

BYDAY=MO represents all Mondays of the month or year. To represent all occurrences, set NthOccurrence to 0.

BYDAY=2MO represents 2nd Monday in a month or year.

BYDAY=-1MO represents the last Monday of a month or year.

Requirements

Namespace: Aspose.iCalendar

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ByDay Members | Aspose.iCalendar Namespace | ByDayCollection


ByDay Members

ByDay overview

Public Instance Constructors

ByDay Overloaded. Initializes a new instance of the ByDay class.

Public Instance Properties

DayOfWeek | Gets or sets the day of the week.
IsAllOccurrences | Returns True when NthOccurrence is zero (meaning all occurrences of this day of week).
NthOccurrence | Gets or sets the nth occurrence of the day of the week.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ByDay Class | Aspose.iCalendar Namespace | ByDayCollection


ByDay Constructor

Initializes a new instance of ByDay class.

Overload List

Initializes a new instance of ByDay class.

public ByDay(DayOfWeek);

Initializes a new instance of ByDay class.

public ByDay(int,DayOfWeek);

See Also

ByDay Class | Aspose.iCalendar Namespace


ByDay Constructor (DayOfWeek)

Initializes a new instance of ByDay class.

public ByDay(
DayOfWeek dayOfWeek
);

Parameters

dayOfWeek
A day of the week.

See Also

ByDay Class | Aspose.iCalendar Namespace | ByDay Constructor Overload List


ByDay Constructor (Int32, DayOfWeek)

Initializes a new instance of ByDay class.

public ByDay(
int nthOccurrence,
DayOfWeek dayOfWeek
);

Parameters

nthOccurrence
The nth occurrence of the day of the week.
dayOfWeek
A day of the week.

See Also

ByDay Class | Aspose.iCalendar Namespace | ByDay Constructor Overload List


ByDay Properties

The properties of the ByDay class are listed below. For a complete list of ByDay class members, see the ByDay Members topic.

Public Instance Properties

DayOfWeek | Gets or sets the day of the week.
IsAllOccurrences | Returns True when NthOccurrence is zero (meaning all occurrences of this day of week).
NthOccurrence | Gets or sets the nth occurrence of the day of the week.

See Also

ByDay Class | Aspose.iCalendar Namespace | ByDayCollection


DayOfWeek Property

Aspose.Email

ByDay.DayOfWeek Property

Gets or sets the day of the week.

public DayOfWeek DayOfWeek {get; set;}

See Also

ByDay Class | Aspose.iCalendar Namespace


IsAllOccurrences Property

Aspose.Email

ByDay.IsAllOccurrences Property

Returns True when NthOccurrence is zero (meaning all occurrences of this day of week).

public bool IsAllOccurrences {get;}

See Also

ByDay Class | Aspose.iCalendar Namespace


NthOccurrence Property

Aspose.Email

ByDay.NthOccurrence Property

Gets or sets the nth occurrence of the day of the week.

public int NthOccurrence {get; set;}

Remarks

Valid range for this property is from -53 to 53.

Positive values represent Nth occurrence from the beginning of the period, for example NthOccurrence = 1, represents 1st occurrence of the day of the week.

Negative values represent Nth occurrence from the end of the period, for example NthOccurrence = -1, represents last occurrence of the day of the week.

When NthOccurrence is zero, it represents all occurrences of the specified day of the week. For example, BYDAY=MO has NthOccurrence zero and represents all Mondays in the set.

See Also

ByDay Class | Aspose.iCalendar Namespace


ByDayCollection Class

Represents a collection of ByDay objects.

For a list of all members of this type, see ByDayCollection Members.

System.Object
System.Collections.ObjectModel.Collection`1[[Aspose.iCalendar.ByDay, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]]
Aspose.iCalendar.ByDayCollection

public class ByDayCollection : Collection`1

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Corresponds to the BYDAY part of the recurrence rule.

The BYDAY rule specifies a list of days of the week for a monthly or yearly recurrence rule.

For each day of the week, a specific Nth occurrence or all occurrences can be specified.

Requirements

Namespace: Aspose.iCalendar

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ByDayCollection Members | Aspose.iCalendar Namespace


ByDayCollection Members

ByDayCollection overview

Public Instance Properties

Count (inherited from 0, Culture=neutral, PublicKeyToken=null]])
Item (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Public Instance Methods

Add | Overloaded. Adds a ByDay to the collection.
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains | Overloaded. Returns a value indicating whether a specified day of week is present in the collection.
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) | Overloaded.
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Items (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Protected Instance Methods

ClearItems (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
InsertItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RemoveItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
SetItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |

See Also

ByDayCollection Class | Aspose.iCalendar Namespace


ByDayCollection Methods

The methods of the ByDayCollection class are listed below. For a complete list of ByDayCollection class members, see the ByDayCollection Members topic.

Public Instance Methods

Add | Overloaded. Adds a ByDay to the collection.
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains | Overloaded. Returns a value indicating whether a specified day of week is present in the collection.
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) | Overloaded.
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

ClearItems (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
InsertItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RemoveItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
SetItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |

See Also

ByDayCollection Class | Aspose.iCalendar Namespace


Add Method

Aspose.Email

ByDayCollection.Add Method

Adds a ByDay to the collection.

Overload List

Adds a ByDay to the collection.

new public int Add(ByDay);

Creates and adds a ByDay that represents all occurrences of the day of the week to the collection.

public int Add(DayOfWeek);

Creates and adds a ByDay to the collection.

public int Add(int,DayOfWeek);

See Also

ByDayCollection Class | Aspose.iCalendar Namespace


ByDayCollection.Add Method (ByDay)

Adds a ByDay to the collection.

new public int Add(
ByDay byDay
);

Parameters

byDay
The item to add to the collection.

Return Value

The zero-based index of the newly added item.

See Also

ByDayCollection Class | Aspose.iCalendar Namespace | ByDayCollection.Add Overload List


ByDayCollection.Add Method (DayOfWeek)

Creates and adds a ByDay that represents all occurrences of the day of the week to the collection.

public int Add(
DayOfWeek dayOfWeek
);

Parameters

dayOfWeek
A day of the week.

Return Value

The zero-based index of the newly added item.

See Also

ByDayCollection Class | Aspose.iCalendar Namespace | ByDayCollection.Add Overload List


ByDayCollection.Add Method (Int32, DayOfWeek)

Creates and adds a ByDay to the collection.

public int Add(
int nthOccurrence,
DayOfWeek dayOfWeek
);

Parameters

nthOccurrence
The nth occurrence of the day of the week.
dayOfWeek
A day of the week.

Return Value

The zero-based index of the newly added item.

See Also

ByDayCollection Class | Aspose.iCalendar Namespace | ByDayCollection.Add Overload List


Contains Method

Aspose.Email

ByDayCollection.Contains Method

Returns a value indicating whether a specified day of week is present in the collection.

Overload List

Inherited from 0, Culture=neutral, PublicKeyToken=null]].

public bool Contains(ByDay);

Returns a value indicating whether a specified day of week is present in the collection.

public bool Contains(DayOfWeek);

See Also

ByDayCollection Class | Aspose.iCalendar Namespace


ByDayCollection.Contains Method (DayOfWeek)

Returns a value indicating whether a specified day of week is present in the collection.

public bool Contains(
DayOfWeek dayOfWeek
);

Parameters

dayOfWeek
Day of weekDayOfWeek.

Return Value

True if the value parameter exists within this collection, otherwise false.

See Also

ByDayCollection Class | Aspose.iCalendar Namespace | ByDayCollection.Contains Overload List


ByNumberCollection Class

Represents a set of months, weeks, days, hours, minutes or seconds in a recurrence rule.

For a list of all members of this type, see ByNumberCollection Members.

System.Object
System.Collections.ObjectModel.Collection`1[[System.Int32, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]
Aspose.iCalendar.ByNumberCollection

public class ByNumberCollection : Collection`1

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Corresponds to various BYXXX parts such as BYDAY, BYMONTH of a recurrence rule.

Most of the ByXXX properties of RecurrenceRule are implemented as ByNumberCollection.

Requirements

Namespace: Aspose.iCalendar

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

ByNumberCollection Members | Aspose.iCalendar Namespace


ByNumberCollection Members

ByNumberCollection overview

Public Instance Properties

Count (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]])
Item (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]])

Public Instance Methods

Add | Overloaded. Adds a month, week, day, hour, minute or second to the collection.
Clear (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
Sort | Sorts the elements in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Items (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]])

Protected Instance Methods

ClearItems (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
InsertItem (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RemoveItem (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
SetItem (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |

See Also

ByNumberCollection Class | Aspose.iCalendar Namespace


ByNumberCollection Methods

The methods of the ByNumberCollection class are listed below. For a complete list of ByNumberCollection class members, see the ByNumberCollection Members topic.

Public Instance Methods

Add | Overloaded. Adds a month, week, day, hour, minute or second to the collection.
Clear (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
Sort | Sorts the elements in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

ClearItems (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
InsertItem (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RemoveItem (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
SetItem (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |

See Also

ByNumberCollection Class | Aspose.iCalendar Namespace


Add Method

Aspose.Email

ByNumberCollection.Add Method

Adds a month, week, day, hour, minute or second to the collection.

Overload List

Adds a month, week, day, hour, minute or second to the collection.

new public int Add(int);

Adds an array of month, week, day, hour, minute or second to the collection.

public void Add(int[]);

See Also

ByNumberCollection Class | Aspose.iCalendar Namespace


ByNumberCollection.Add Method (Int32)

Adds a month, week, day, hour, minute or second to the collection.

new public int Add(
int value
);

Parameters

value
The value to add.

Return Value

The zero-based index of the newly added item.

Remarks

Throws an exception if the value is outside of the valid range for the time unit of this collection.

See Also

ByNumberCollection Class | Aspose.iCalendar Namespace | ByNumberCollection.Add Overload List


ByNumberCollection.Add Method (Int32[])

Adds an array of month, week, day, hour, minute or second to the collection.

public void Add(
int[] values
);

Parameters

values
The values.

See Also

ByNumberCollection Class | Aspose.iCalendar Namespace | ByNumberCollection.Add Overload List


ByNumberCollection.Sort Method

Sorts the elements in the collection.

public void Sort();

See Also

ByNumberCollection Class | Aspose.iCalendar Namespace


DateCollection Class

Represents a collection of DateTime values.

For a list of all members of this type, see DateCollection Members.

System.Object
System.Collections.ObjectModel.Collection`1[[System.DateTime, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]
Aspose.iCalendar.DateCollection

public class DateCollection : Collection`1

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: Aspose.iCalendar

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

DateCollection Members | Aspose.iCalendar Namespace


DateCollection Members

DateCollection overview

Public Instance Properties

Count (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
Item | Gets or sets the DateTime at the specified index.

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
AddRange | Adds the elements of an System.Collections.ICollection to the end of exiting collection.
Clear (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
Sort | Sorts the elements in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Items (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]])

Protected Instance Methods

ClearItems (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
InsertItem (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RemoveItem (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
SetItem (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |

See Also

DateCollection Class | Aspose.iCalendar Namespace


DateCollection Properties

The properties of the DateCollection class are listed below. For a complete list of DateCollection class members, see the DateCollection Members topic.

Public Instance Properties

Count (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
Item | Gets or sets the DateTime at the specified index.

Protected Instance Properties

Items (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]])

See Also

DateCollection Class | Aspose.iCalendar Namespace


Item Property

Aspose.Email

DateCollection.Item Property

Gets or sets the DateTime at the specified index.

new public DateTime this[
int index
] {get; set;}

Parameters

index
The zero-based indexInt32 of the element to get or set.

Implements

IList`1.Item

See Also

DateCollection Class | Aspose.iCalendar Namespace


DateCollection Methods

The methods of the DateCollection class are listed below. For a complete list of DateCollection class members, see the DateCollection Members topic.

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
AddRange | Adds the elements of an System.Collections.ICollection to the end of exiting collection.
Clear (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
Sort | Sorts the elements in the collection.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

ClearItems (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
InsertItem (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RemoveItem (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |
SetItem (inherited from 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]]) |

See Also

DateCollection Class | Aspose.iCalendar Namespace


DateCollection.AddRange Method

Adds the elements of an System.Collections.ICollection to the end of exiting collection.

public void AddRange(
ICollection c
);

Parameters

c
The ICollection whose elements should be added to the end of this collection.

See Also

DateCollection Class | Aspose.iCalendar Namespace


DateCollection.Sort Method

Sorts the elements in the collection.

public void Sort();

See Also

DateCollection Class | Aspose.iCalendar Namespace


EndType Enumeration

Specifies how the recurrence rule ends.

public enum EndType

Members

Member Name | Description | Value
None | Pattern does not have an end. | 0
Until | Pattern ends on a specified end date. | 1
Count | Pattern ends after specified number of occurrences. | 2

Requirements

Namespace: Aspose.iCalendar

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.iCalendar Namespace


Frequency Enumeration

Specifies frequency of the recurrence rule.

public enum Frequency

Members

Member Name | Description | Value
None | No values are set. | 0
Secondly | Occurrences repeat based on an interval of a second or more. | 1
Minutely | Occurrences repeat based on an interval of a minute or more. | 2
Hourly | Occurrences repeat based on an interval of an hour or more. | 3
Daily | Occurrences repeat based on an interval of a day or more. | 4
Weekly | Occurrences repeat based on an interval of a week or more. | 5
Monthly | Occurrences repeat based on an interval of a month or more. | 6
Yearly | Occurrences repeat based on an interval of a year or more. | 7

Requirements

Namespace: Aspose.iCalendar

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.iCalendar Namespace


RecurrencePattern Class

The main class, represents a recurrence pattern.

For a list of all members of this type, see RecurrencePattern Members.

System.Object
Aspose.iCalendar.RecurrencePattern

public class RecurrencePattern

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.iCalendar

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RecurrencePattern Members | Aspose.iCalendar Namespace


RecurrencePattern Members

RecurrencePattern overview

Public Static Methods

FromiCalendar | Gets a recurrence pattern from iCalendar string.
FromRecurrence | Overloaded. Gets a recurrence pattern from XML pattern string.

Public Instance Constructors

RecurrencePattern Overloaded. Initializes a new instance of the RecurrencePattern class.

Public Instance Properties

EndDate | Gets or sets the end date.
ExDates | Gets the ex dates.
ExRules | Gets the ex rules.
RDates | Gets the R dates.
RRules | Gets the R rules.
StartDate | Gets or sets the start date.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GenerateOccurrences | Overloaded. Generates the occurrences.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToiCalendar | To iCalendar string.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RecurrencePattern Class | Aspose.iCalendar Namespace


RecurrencePattern Constructor

Initializes a new instance of the RecurrencePattern class.

Overload List

Initializes a new instance of the RecurrencePattern class.

public RecurrencePattern();

Initializes a new instance of the RecurrencePattern class.

public RecurrencePattern(string);

See Also

RecurrencePattern Class | Aspose.iCalendar Namespace


RecurrencePattern Constructor ()

Initializes a new instance of the RecurrencePattern class.

public RecurrencePattern();

See Also

RecurrencePattern Class | Aspose.iCalendar Namespace | RecurrencePattern Constructor Overload List


RecurrencePattern Constructor (String)

Initializes a new instance of the RecurrencePattern class.

public RecurrencePattern(
string pattern
);

Parameters

pattern
The pattern.

See Also

RecurrencePattern Class | Aspose.iCalendar Namespace | RecurrencePattern Constructor Overload List


RecurrencePattern Properties

The properties of the RecurrencePattern class are listed below. For a complete list of RecurrencePattern class members, see the RecurrencePattern Members topic.

Public Instance Properties

EndDate | Gets or sets the end date.
ExDates | Gets the ex dates.
ExRules | Gets the ex rules.
RDates | Gets the R dates.
RRules | Gets the R rules.
StartDate | Gets or sets the start date.

See Also

RecurrencePattern Class | Aspose.iCalendar Namespace


EndDate Property

Aspose.Email

RecurrencePattern.EndDate Property

Gets or sets the end date.

public DateTime EndDate {get; set;}

Property Value

The end date.

See Also

RecurrencePattern Class | Aspose.iCalendar Namespace


ExDates Property

Aspose.Email

RecurrencePattern.ExDates Property

Gets the ex dates.

public DateCollection ExDates {get;}

Property Value

The ex dates.

See Also

RecurrencePattern Class | Aspose.iCalendar Namespace


ExRules Property

Aspose.Email

RecurrencePattern.ExRules Property

Gets the ex rules.

public RecurrenceRuleCollection ExRules {get;}

Property Value

The ex rules.

See Also

RecurrencePattern Class | Aspose.iCalendar Namespace


RDates Property

Aspose.Email

RecurrencePattern.RDates Property

Gets the R dates.

public DateCollection RDates {get;}

Property Value

The R dates.

See Also

RecurrencePattern Class | Aspose.iCalendar Namespace


RRules Property

Aspose.Email

RecurrencePattern.RRules Property

Gets the R rules.

public RecurrenceRuleCollection RRules {get;}

Property Value

The R rules.

See Also

RecurrencePattern Class | Aspose.iCalendar Namespace


StartDate Property

Aspose.Email

RecurrencePattern.StartDate Property

Gets or sets the start date.

public DateTime StartDate {get; set;}

Property Value

The start date.

See Also

RecurrencePattern Class | Aspose.iCalendar Namespace


RecurrencePattern Methods

The methods of the RecurrencePattern class are listed below. For a complete list of RecurrencePattern class members, see the RecurrencePattern Members topic.

Public Static Methods

FromiCalendar | Gets a recurrence pattern from iCalendar string.
FromRecurrence | Overloaded. Gets a recurrence pattern from XML pattern string.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GenerateOccurrences | Overloaded. Generates the occurrences.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToiCalendar | To iCalendar string.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RecurrencePattern Class | Aspose.iCalendar Namespace


RecurrencePattern.FromiCalendar Method

Gets a recurrence pattern from iCalendar string.

public static RecurrencePattern FromiCalendar(
string pattern
);

Parameters

pattern
StringString representation of iCalendar.

Return Value

Recurrence patternRecurrencePattern.

See Also

RecurrencePattern Class | Aspose.iCalendar Namespace


FromRecurrence Method

Aspose.Email

RecurrencePattern.FromRecurrence Method

Gets a recurrence pattern from XML pattern string.

Overload List

Gets a recurrence pattern from XML pattern string.

public static RecurrencePattern FromRecurrence(string);

Gets a recurrence pattern from XmlElement.

public static RecurrencePattern FromRecurrence(XmlElement);

See Also

RecurrencePattern Class | Aspose.iCalendar Namespace


RecurrencePattern.FromRecurrence Method (String)

Gets a recurrence pattern from XML pattern string.

public static RecurrencePattern FromRecurrence(
string recurrenceXMLstring
);

Parameters

recurrenceXMLstring
XML stringString of pattern.

Return Value

Recurrence patternRecurrencePattern.

See Also

RecurrencePattern Class | Aspose.iCalendar Namespace | RecurrencePattern.FromRecurrence Overload List


RecurrencePattern.FromRecurrence Method (XmlElement)

Gets a recurrence pattern from XmlElement.

public static RecurrencePattern FromRecurrence(
XmlElement xmlElement
);

Parameters

xmlElement
XmlElementXmlElement of pattern.

Return Value

Recurrence patternRecurrencePattern.

See Also

RecurrencePattern Class | Aspose.iCalendar Namespace | RecurrencePattern.FromRecurrence Overload List


GenerateOccurrences Method

Aspose.Email

RecurrencePattern.GenerateOccurrences Method

Generates the occurrences.

Overload List

Generates the occurrences.

public DateCollection GenerateOccurrences();

Generates the occurrences.

public DateCollection GenerateOccurrences(DateTime,DateTime);

Generates n next occurrences.

public DateCollection GenerateOccurrences(DateTime,DateTime,int);

Generates n next occurrences.

public DateCollection GenerateOccurrences(int);

See Also

RecurrencePattern Class | Aspose.iCalendar Namespace


RecurrencePattern.GenerateOccurrences Method ()

Generates the occurrences.

public DateCollection GenerateOccurrences();

Return Value

Collection of datesDateCollection.

Exceptions

Exception Type | Condition
Exception | throws if StartDate is not set.

See Also

RecurrencePattern Class | Aspose.iCalendar Namespace | RecurrencePattern.GenerateOccurrences Overload List


RecurrencePattern.GenerateOccurrences Method (DateTime, DateTime)

Generates the occurrences.

public DateCollection GenerateOccurrences(
DateTime rangeStart,
DateTime rangeEnd
);

Parameters

rangeStart
The range start.
rangeEnd
The range end.

Return Value

Collection of datesDateCollection.

Exceptions

Exception Type | Condition
Exception | throws if StartDate is not set

See Also

RecurrencePattern Class | Aspose.iCalendar Namespace | RecurrencePattern.GenerateOccurrences Overload List


RecurrencePattern.GenerateOccurrences Method (DateTime, DateTime, Int32)

Generates n next occurrences.

public DateCollection GenerateOccurrences(
DateTime rangeStart,
DateTime rangeEnd,
int nNextOccurrences
);

Parameters

rangeStart
The range start.
rangeEnd
The range end.
nNextOccurrences
The amount of needed occurrences.

Return Value

Collection of datesDateCollection.

Exceptions

Exception Type | Condition
Exception | throws if StartDate is not set.
ArgumentOutOfRangeException | throws if amount of needed occurrences is less or equal zero.

See Also

RecurrencePattern Class | Aspose.iCalendar Namespace | RecurrencePattern.GenerateOccurrences Overload List


RecurrencePattern.GenerateOccurrences Method (Int32)

Generates n next occurrences.

public DateCollection GenerateOccurrences(
int nNextOccurrences
);

Parameters

nNextOccurrences
The amount of needed occurrences.

Return Value

Collection of datesDateCollection.

Exceptions

Exception Type | Condition
Exception | throws if StartDate is not set.
ArgumentOutOfRangeException | throws if amount of needed occurrences is less or equal zero.

See Also

RecurrencePattern Class | Aspose.iCalendar Namespace | RecurrencePattern.GenerateOccurrences Overload List


RecurrencePattern.ToiCalendar Method

To iCalendar string.

public string ToiCalendar();

Return Value

StringString representation of RecurrencePattern.

See Also

RecurrencePattern Class | Aspose.iCalendar Namespace


RecurrenceRule Class

Represents one recurrence or exception rule in a recurrence pattern.

For a list of all members of this type, see RecurrenceRule Members.

System.Object
Aspose.iCalendar.RecurrenceRule

public class RecurrenceRule

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Corresponds to RRULE or EXRULE part in iCalendar.

To construct a recurrence rule, you typically need to:

1. Specify the type of the rule in Frequency.

2. Specify how the recurrence pattern ends using EndType, Count or Until.

3. Specify values in one or more ByXXX collections.

Note, that if ByXXX rule part values are found which are beyond the available scope (ie, BYMONTHDAY=30 in February), they are simply ignored.

Information, not contained in the rule, necessary to determine the various recurrence instance start time and dates are derived from StartDate. For example, "FREQ=YEARLY;BYMONTH=1" doesn't specify a specific day within the month or a time. This information would be the same as what is specified for DTSTART.

ByXXX rule parts modify the recurrence in some manner. ByXXX rule parts for a period of time which is the same or greater than the frequency generally reduce or limit the number of occurrences of the recurrence generated. For example, "FREQ=DAILY;BYMONTH=1" reduces the number of recurrence instances from all days (if BYMONTH tag is not present) to all days in January. ByXXX rule parts for a period of time less than the frequency generally increase or expand the number of occurrences of the recurrence. For example, "FREQ=YEARLY;BYMONTH=1,2" increases the number of days within the yearly recurrence set from 1 (if BYMONTH tag is not present) to 2.

If multiple ByXXX rule parts are specified, then after evaluating the specified Frequency and Interval rule parts, the ByXXX rule parts are applied to the current set of evaluated occurrences in the following order: ByMonth, ByWeekNo, ByYearDay, ByMonthDay, ByDay, ByHour, ByMinute, BySecond and BySetPos; then Count and Until are evaluated.

Requirements

Namespace: Aspose.iCalendar

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RecurrenceRule Members | Aspose.iCalendar Namespace


RecurrenceRule Members

RecurrenceRule overview

Public Instance Constructors

RecurrenceRule Constructor Initializes a new instance of the RecurrenceRule class.

Public Instance Properties

ByDay | Gets the by day.
ByHour | Gets the by hour.
ByMinute | Gets the by minute.
ByMonth | Gets the by month.
ByMonthDay | Gets the by month day.
BySecond | Gets the by second.
BySetPos | Gets the by set pos.
ByWeekNo | Gets the by week no.
ByYearDay | Gets the by year day.
Count | Gets or sets the count.
EndType | Gets or sets the end type.
Frequency | Gets or sets the type of the recurrence rule.
FriendlyText | Gets user friendly text of rule.
Interval | Gets or sets the interval.
Until | Gets or sets the until.
WeekStart | Gets or sets the starting day of the week.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

RecurrenceRule Class | Aspose.iCalendar Namespace


RecurrenceRule Constructor

Initializes a new instance of the RecurrenceRule class.

public RecurrenceRule();

See Also

RecurrenceRule Class | Aspose.iCalendar Namespace


RecurrenceRule Properties

The properties of the RecurrenceRule class are listed below. For a complete list of RecurrenceRule class members, see the RecurrenceRule Members topic.

Public Instance Properties

ByDay | Gets the by day.
ByHour | Gets the by hour.
ByMinute | Gets the by minute.
ByMonth | Gets the by month.
ByMonthDay | Gets the by month day.
BySecond | Gets the by second.
BySetPos | Gets the by set pos.
ByWeekNo | Gets the by week no.
ByYearDay | Gets the by year day.
Count | Gets or sets the count.
EndType | Gets or sets the end type.
Frequency | Gets or sets the type of the recurrence rule.
FriendlyText | Gets user friendly text of rule.
Interval | Gets or sets the interval.
Until | Gets or sets the until.
WeekStart | Gets or sets the starting day of the week.

See Also

RecurrenceRule Class | Aspose.iCalendar Namespace


ByDay Property

Aspose.Email

RecurrenceRule.ByDay Property

Gets the by day.

public ByDayCollection ByDay {get;}

Property Value

The by day.

See Also

RecurrenceRule Class | Aspose.iCalendar Namespace


ByHour Property

Aspose.Email

RecurrenceRule.ByHour Property

Gets the by hour.

public ByNumberCollection ByHour {get;}

Property Value

The by hour.

See Also

RecurrenceRule Class | Aspose.iCalendar Namespace


ByMinute Property

Aspose.Email

RecurrenceRule.ByMinute Property

Gets the by minute.

public ByNumberCollection ByMinute {get;}

Property Value

The by minute.

See Also

RecurrenceRule Class | Aspose.iCalendar Namespace


ByMonth Property

Aspose.Email

RecurrenceRule.ByMonth Property

Gets the by month.

public ByNumberCollection ByMonth {get;}

Property Value

The by month.

See Also

RecurrenceRule Class | Aspose.iCalendar Namespace


ByMonthDay Property

Aspose.Email

RecurrenceRule.ByMonthDay Property

Gets the by month day.

public ByNumberCollection ByMonthDay {get;}

Property Value

The by month day.

See Also

RecurrenceRule Class | Aspose.iCalendar Namespace


BySecond Property

Aspose.Email

RecurrenceRule.BySecond Property

Gets the by second.

public ByNumberCollection BySecond {get;}

Property Value

The by second.

See Also

RecurrenceRule Class | Aspose.iCalendar Namespace


BySetPos Property

Aspose.Email

RecurrenceRule.BySetPos Property

Gets the by set pos.

public ByNumberCollection BySetPos {get;}

Property Value

The by set pos.

See Also

RecurrenceRule Class | Aspose.iCalendar Namespace


ByWeekNo Property

Aspose.Email

RecurrenceRule.ByWeekNo Property

Gets the by week no.

public ByNumberCollection ByWeekNo {get;}

Property Value

The by week no.

See Also

RecurrenceRule Class | Aspose.iCalendar Namespace


ByYearDay Property

Aspose.Email

RecurrenceRule.ByYearDay Property

Gets the by year day.

public ByNumberCollection ByYearDay {get;}

Property Value

The by year day.

See Also

RecurrenceRule Class | Aspose.iCalendar Namespace


Count Property

Aspose.Email

RecurrenceRule.Count Property

Gets or sets the count.

public int Count {get; set;}

Property Value

The count.

See Also

RecurrenceRule Class | Aspose.iCalendar Namespace


EndType Property

Aspose.Email

RecurrenceRule.EndType Property

Gets or sets the end type.

public EndType EndType {get; set;}

Property Value

The end type.

See Also

RecurrenceRule Class | Aspose.iCalendar Namespace


Frequency Property

Aspose.Email

RecurrenceRule.Frequency Property

Gets or sets the type of the recurrence rule.

public Frequency Frequency {get; set;}

Property Value

The frequency.

See Also

RecurrenceRule Class | Aspose.iCalendar Namespace


FriendlyText Property

Aspose.Email

RecurrenceRule.FriendlyText Property

Gets user friendly text of rule.

public string FriendlyText {get;}

See Also

RecurrenceRule Class | Aspose.iCalendar Namespace


Interval Property

Aspose.Email

RecurrenceRule.Interval Property

Gets or sets the interval.

public int Interval {get; set;}

Property Value

The interval.

See Also

RecurrenceRule Class | Aspose.iCalendar Namespace


Until Property

Aspose.Email

RecurrenceRule.Until Property

Gets or sets the until.

public DateTime Until {get; set;}

Property Value

The until.

See Also

RecurrenceRule Class | Aspose.iCalendar Namespace


WeekStart Property

Aspose.Email

RecurrenceRule.WeekStart Property

Gets or sets the starting day of the week.

public DayOfWeek WeekStart {get; set;}

See Also

RecurrenceRule Class | Aspose.iCalendar Namespace


RecurrenceRuleCollection Class

Represents a collection of RecurrenceRule objects.

For a list of all members of this type, see RecurrenceRuleCollection Members.

System.Object
System.Collections.ObjectModel.Collection`1[[Aspose.iCalendar.RecurrenceRule, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]]
Aspose.iCalendar.RecurrenceRuleCollection

public class RecurrenceRuleCollection : Collection`1

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Corresponds to a collection of RRULE or EXRULE parts of a recurrence pattern.

Requirements

Namespace: Aspose.iCalendar

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RecurrenceRuleCollection Members | Aspose.iCalendar Namespace


RecurrenceRuleCollection Members

RecurrenceRuleCollection overview

Public Instance Properties

Count (inherited from 0, Culture=neutral, PublicKeyToken=null]])
Item (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Public Instance Methods

Add | Overloaded. Adds a RecurrenceRule to the collection.
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Items (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Protected Instance Methods

ClearItems (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
InsertItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RemoveItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
SetItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |

See Also

RecurrenceRuleCollection Class | Aspose.iCalendar Namespace


RecurrenceRuleCollection Methods

The methods of the RecurrenceRuleCollection class are listed below. For a complete list of RecurrenceRuleCollection class members, see the RecurrenceRuleCollection Members topic.

Public Instance Methods

Add | Overloaded. Adds a RecurrenceRule to the collection.
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

ClearItems (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
InsertItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RemoveItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
SetItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |

See Also

RecurrenceRuleCollection Class | Aspose.iCalendar Namespace


Add Method

Aspose.Email

RecurrenceRuleCollection.Add Method

Adds a RecurrenceRule to the collection.

Overload List

Adds a RecurrenceRule to the collection.

public RecurrenceRule Add();

Adds a RecurrenceRule to the collection.

new public int Add(RecurrenceRule);

See Also

RecurrenceRuleCollection Class | Aspose.iCalendar Namespace


RecurrenceRuleCollection.Add Method ()

Adds a RecurrenceRule to the collection.

public RecurrenceRule Add();

Return Value

The zero-based index of the newly added item.

See Also

RecurrenceRuleCollection Class | Aspose.iCalendar Namespace | RecurrenceRuleCollection.Add Overload List


RecurrenceRuleCollection.Add Method (RecurrenceRule)

Adds a RecurrenceRule to the collection.

new public int Add(
RecurrenceRule rule
);

Parameters

rule
The RecurrenceRule to add.

Return Value

The zero-based index of the newly added item.

See Also

RecurrenceRuleCollection Class | Aspose.iCalendar Namespace | RecurrenceRuleCollection.Add Overload List


Aspose.Windows.Forms

Aspose.Email

Aspose.Windows.Forms Namespace

Namespace hierarchy

Classes

Class | Description
FileDataObject | Represents the file data.
FileDataObjectCollection | Represents the collection for FileDataObject.
FileDragEventArgs |
FileDropTargetManager | Represents the manager class for file drop target.
FileDropTargetPanel | Represents the file drop target.
MailClientAgent | Represents an email client agent.
Recipient | Represents a Recipient for a MapiMailMessage.
RecipientCollection | Represents a colleciton of recipients for a mail message.

Interfaces

Interface | Description
IFileDropTargetControl |

Delegates

Delegate | Description
FileDragEventHandler |

Enumerations

Enumeration | Description
RecipientType | Specifies the type of recipient.


FileDataObject Class

Represents the file data.

For a list of all members of this type, see FileDataObject Members.

System.Object
Aspose.Windows.Forms.FileDataObject

public sealed class FileDataObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Windows.Forms

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FileDataObject Members | Aspose.Windows.Forms Namespace


FileDataObject Members

FileDataObject overview

Public Instance Properties

FileName Gets the name of the file.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Saves the specified stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FileDataObject Class | Aspose.Windows.Forms Namespace


FileDataObject Properties

The properties of the FileDataObject class are listed below. For a complete list of FileDataObject class members, see the FileDataObject Members topic.

Public Instance Properties

FileName Gets the name of the file.

See Also

FileDataObject Class | Aspose.Windows.Forms Namespace


FileName Property

Aspose.Email

FileDataObject.FileName Property

Gets the name of the file.

public string FileName {get;}

Property Value

The name of the file.

See Also

FileDataObject Class | Aspose.Windows.Forms Namespace


FileDataObject Methods

The methods of the FileDataObject class are listed below. For a complete list of FileDataObject class members, see the FileDataObject Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Save | Saves the specified stream.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FileDataObject Class | Aspose.Windows.Forms Namespace


FileDataObject.Save Method

Saves the specified stream.

public void Save(
Stream stream
);

Parameters

stream
The stream.

See Also

FileDataObject Class | Aspose.Windows.Forms Namespace


FileDataObjectCollection Class

Represents the collection for FileDataObject.

For a list of all members of this type, see FileDataObjectCollection Members.

System.Object
System.Collections.ObjectModel.Collection`1[[Aspose.Windows.Forms.FileDataObject, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]]
Aspose.Windows.Forms.FileDataObjectCollection

public sealed class FileDataObjectCollection : Collection`1

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Windows.Forms

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FileDataObjectCollection Members | Aspose.Windows.Forms Namespace


FileDataObjectCollection Members

FileDataObjectCollection overview

Public Instance Constructors

FileDataObjectCollection Constructor Initializes a new instance of the FileDataObjectCollection class.

Public Instance Properties

Count (inherited from 0, Culture=neutral, PublicKeyToken=null]])
Item (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Public Instance Methods

Add (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FileDataObjectCollection Class | Aspose.Windows.Forms Namespace


FileDataObjectCollection Constructor

Initializes a new instance of the FileDataObjectCollection class.

public FileDataObjectCollection();

See Also

FileDataObjectCollection Class | Aspose.Windows.Forms Namespace


FileDragEventArgs Class

For a list of all members of this type, see FileDragEventArgs Members.

System.Object
System.EventArgs
System.Windows.Forms.DragEventArgs
Aspose.Windows.Forms.FileDragEventArgs

public class FileDragEventArgs : DragEventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Windows.Forms

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FileDragEventArgs Members | Aspose.Windows.Forms Namespace


FileDragEventArgs Members

FileDragEventArgs overview

Public Instance Properties

AllowedEffect (inherited from DragEventArgs) | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data (inherited from DragEventArgs) | Gets the IDataObject that contains the data associated with this event.
Effect (inherited from DragEventArgs) | Gets or sets the target drop effect in a drag-and-drop operation.
Files | Gets the files.
KeyState (inherited from DragEventArgs) | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X (inherited from DragEventArgs) | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y (inherited from DragEventArgs) | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

FileDragEventArgs Class | Aspose.Windows.Forms Namespace


FileDragEventArgs Properties

The properties of the FileDragEventArgs class are listed below. For a complete list of FileDragEventArgs class members, see the FileDragEventArgs Members topic.

Public Instance Properties

AllowedEffect (inherited from DragEventArgs) | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data (inherited from DragEventArgs) | Gets the IDataObject that contains the data associated with this event.
Effect (inherited from DragEventArgs) | Gets or sets the target drop effect in a drag-and-drop operation.
Files | Gets the files.
KeyState (inherited from DragEventArgs) | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X (inherited from DragEventArgs) | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y (inherited from DragEventArgs) | Gets the y-coordinate of the mouse pointer, in screen coordinates.

See Also

FileDragEventArgs Class | Aspose.Windows.Forms Namespace


Files Property

Aspose.Email

FileDragEventArgs.Files Property

Gets the files.

public FileDataObjectCollection Files {get;}

Property Value

The files.

See Also

FileDragEventArgs Class | Aspose.Windows.Forms Namespace


FileDragEventHandler Delegate

public delegate void FileDragEventHandler(
object sender,
FileDragEventArgs e
);

Requirements

Namespace: Aspose.Windows.Forms

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Windows.Forms Namespace


FileDropTargetManager Class

Represents the manager class for file drop target.

For a list of all members of this type, see FileDropTargetManager Members.

System.Object
Aspose.Windows.Forms.FileDropTargetManager

public sealed class FileDropTargetManager : IDropTarget

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Windows.Forms

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FileDropTargetManager Members | Aspose.Windows.Forms Namespace


FileDropTargetManager Members

FileDropTargetManager overview

Public Instance Constructors

FileDropTargetManager Constructor Initializes a new instance of the FileDropTargetManager class.

Public Instance Methods

EnsureRegistered | Ensures the registered.
EnsureUnRegistered | Ensures the un registered.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FileDropTargetManager Class | Aspose.Windows.Forms Namespace


FileDropTargetManager Constructor

Initializes a new instance of the FileDropTargetManager class.

public FileDropTargetManager(
Control owner
);

Parameters

owner
The owner.

See Also

FileDropTargetManager Class | Aspose.Windows.Forms Namespace


FileDropTargetManager Methods

The methods of the FileDropTargetManager class are listed below. For a complete list of FileDropTargetManager class members, see the FileDropTargetManager Members topic.

Public Instance Methods

EnsureRegistered | Ensures the registered.
EnsureUnRegistered | Ensures the un registered.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

FileDropTargetManager Class | Aspose.Windows.Forms Namespace


FileDropTargetManager.EnsureRegistered Method

Ensures the registered.

public void EnsureRegistered(
IDropTarget dropTarget
);

Parameters

dropTarget
The drop target.

See Also

FileDropTargetManager Class | Aspose.Windows.Forms Namespace


FileDropTargetManager.EnsureUnRegistered Method

Ensures the un registered.

public void EnsureUnRegistered(
IDropTarget dropTarget
);

Parameters

dropTarget
The drop target.

See Also

FileDropTargetManager Class | Aspose.Windows.Forms Namespace


FileDropTargetPanel Class

Represents the file drop target.

For a list of all members of this type, see FileDropTargetPanel Members.

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.Panel
Aspose.Windows.Forms.FileDropTargetPanel

public class FileDropTargetPanel : Panel, IFileDropTargetControl

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Windows.Forms

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

FileDropTargetPanel Members | Aspose.Windows.Forms Namespace


FileDropTargetPanel Members

FileDropTargetPanel overview

Public Instance Constructors

FileDropTargetPanel Constructor Initializes a new instance of the FileDropTargetPanel class.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Panel) |
AutoSizeMode (inherited from Panel) | Indicates the automatic sizing behavior of the control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BorderStyle (inherited from Panel) | Indicates the border style for the control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
DropTargetManager | Gets or sets the drop target manager.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Panel) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Panel) | This member is not meaningful for this control.
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) |
PreProcessMessage (inherited from Control) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Panel) | Returns a string representation for this control.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Public Instance Events

AutoSizeChanged (inherited from Panel) | Occurs when the value of the AutoSize property has changed.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FileDragDrop | Occurs when [file drag drop].
FileDragEnter | Occurs when [file drag enter].
FileDragOver | Occurs when [file drag over].
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Panel) | This member is not meaningful for this control.
KeyPress (inherited from Panel) | This member is not meaningful for this control.
KeyUp (inherited from Panel) | This member is not meaningful for this control.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Panel) | This member is not meaningful for this control.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

Protected Instance Properties

CanEnableIme (inherited from Control) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Panel) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Panel) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ScrollableControl) | Adjusts the scroll bars on the container based on the current control positions and the control currently selected.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFileDragDrop |
OnFileDragEnter |
OnFileDragLeave |
OnFileDragOver |
OnFontChanged (inherited from Control) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated |
OnHandleDestroyed |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Panel) | Fires the event indicating that the panel has been resized. Inheriting controls should use this in favor of actually listening to the event, but should still call base.onResize to ensure that the event is fired for external listeners.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from Control) |
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) |
ProcessKeyPreview (inherited from Control) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from ScrollableControl) |

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) |
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

FileDropTargetPanel Class | Aspose.Windows.Forms Namespace


FileDropTargetPanel Constructor

Initializes a new instance of the FileDropTargetPanel class.

public FileDropTargetPanel();

See Also

FileDropTargetPanel Class | Aspose.Windows.Forms Namespace


FileDropTargetPanel Properties

The properties of the FileDropTargetPanel class are listed below. For a complete list of FileDropTargetPanel class members, see the FileDropTargetPanel Members topic.

Public Instance Properties

AccessibilityObject (inherited from Control) | Gets the AccessibleObject assigned to the control.
AccessibleDefaultActionDescription (inherited from Control) | Gets or sets the default action description of the control for use by accessibility client applications.
AccessibleDescription (inherited from Control) | Gets or sets the description of the control used by accessibility client applications.
AccessibleName (inherited from Control) | Gets or sets the name of the control used by accessibility client applications.
AccessibleRole (inherited from Control) | Gets or sets the accessible role of the control
AllowDrop (inherited from Control) | Gets or sets a value indicating whether the control can accept data that the user drags onto it.
Anchor (inherited from Control) | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent.
AutoScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the container enables the user to scroll to any controls placed outside of its visible boundaries.
AutoScrollMargin (inherited from ScrollableControl) | Gets or sets the size of the auto-scroll margin.
AutoScrollMinSize (inherited from ScrollableControl) | Gets or sets the minimum size of the auto-scroll.
AutoScrollOffset (inherited from Control) | Gets or sets where this control is scrolled to in ScrollControlIntoView.
AutoScrollPosition (inherited from ScrollableControl) | Gets or sets the location of the auto-scroll position.
AutoSize (inherited from Panel) |
AutoSizeMode (inherited from Panel) | Indicates the automatic sizing behavior of the control.
BackColor (inherited from Control) | Gets or sets the background color for the control.
BackgroundImage (inherited from Control) | Gets or sets the background image displayed in the control.
BackgroundImageLayout (inherited from Control) | Gets or sets the background image layout as defined in the ImageLayout enumeration.
BindingContext (inherited from Control) | Gets or sets the BindingContext for the control.
BorderStyle (inherited from Panel) | Indicates the border style for the control.
Bottom (inherited from Control) | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area.
Bounds (inherited from Control) | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control.
CanFocus (inherited from Control) | Gets a value indicating whether the control can receive focus.
CanSelect (inherited from Control) | Gets a value indicating whether the control can be selected.
Capture (inherited from Control) | Gets or sets a value indicating whether the control has captured the mouse.
CausesValidation (inherited from Control) | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus.
ClientRectangle (inherited from Control) | Gets the rectangle that represents the client area of the control.
ClientSize (inherited from Control) | Gets or sets the height and width of the client area of the control.
CompanyName (inherited from Control) | Gets the name of the company or creator of the application containing the control.
Container (inherited from Component) | Gets the IContainer that contains the Component.
ContainsFocus (inherited from Control) | Gets a value indicating whether the control, or one of its child controls, currently has the input focus.
ContextMenu (inherited from Control) | Gets or sets the shortcut menu associated with the control.
ContextMenuStrip (inherited from Control) | Gets or sets the ContextMenuStrip associated with this control.
Controls (inherited from Control) | Gets the collection of controls contained within the control.
Created (inherited from Control) | Gets a value indicating whether the control has been created.
Cursor (inherited from Control) | Gets or sets the cursor that is displayed when the mouse pointer is over the control.
DataBindings (inherited from Control) | Gets the data bindings for the control.
DisplayRectangle (inherited from ScrollableControl) | Gets the rectangle that represents the virtual display area of the control.
Disposing (inherited from Control) | Gets a value indicating whether the base Control class is in the process of disposing.
Dock (inherited from Control) | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent.
DockPadding (inherited from ScrollableControl) | Gets the dock padding settings for all edges of the control.
DropTargetManager | Gets or sets the drop target manager.
Enabled (inherited from Control) | Gets or sets a value indicating whether the control can respond to user interaction.
Focused (inherited from Control) | Gets a value indicating whether the control has input focus.
Font (inherited from Control) | Gets or sets the font of the text displayed by the control.
ForeColor (inherited from Control) | Gets or sets the foreground color of the control.
Handle (inherited from Control) | Gets the window handle that the control is bound to.
HasChildren (inherited from Control) | Gets a value indicating whether the control contains one or more child controls.
Height (inherited from Control) | Gets or sets the height of the control.
HorizontalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the horizontal scroll bar.
ImeMode (inherited from Control) | Gets or sets the Input Method Editor (IME) mode of the control.
InvokeRequired (inherited from Control) | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on.
IsAccessible (inherited from Control) | Gets or sets a value indicating whether the control is visible to accessibility applications.
IsDisposed (inherited from Control) | Gets a value indicating whether the control has been disposed of.
IsHandleCreated (inherited from Control) | Gets a value indicating whether the control has a handle associated with it.
IsMirrored (inherited from Control) | Gets a value indicating whether the control is mirrored.
LayoutEngine (inherited from Control) | Gets a cached instance of the control's layout engine.
Left (inherited from Control) | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area.
Location (inherited from Control) | Gets or sets the coordinates of the upper-left corner of the control relative to the upper-left corner of its container.
Margin (inherited from Control) | Gets or sets the space between controls.
MaximumSize (inherited from Control) | Gets or sets the size that is the upper limit that GetPreferredSize can specify.
MinimumSize (inherited from Control) | Gets or sets the size that is the lower limit that GetPreferredSize can specify.
Name (inherited from Control) | Gets or sets the name of the control.
Padding (inherited from Control) | Gets or sets padding within the control.
Parent (inherited from Control) | Gets or sets the parent container of the control.
PreferredSize (inherited from Control) | Gets the size of a rectangular area into which the control can fit.
ProductName (inherited from Control) | Gets the product name of the assembly containing the control.
ProductVersion (inherited from Control) | Gets the version of the assembly containing the control.
RecreatingHandle (inherited from Control) | Gets a value indicating whether the control is currently re-creating its handle.
Region (inherited from Control) | Gets or sets the window region associated with the control.
Right (inherited from Control) | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area.
RightToLeft (inherited from Control) | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts.
Site (inherited from Control) | Gets or sets the site of the control.
Size (inherited from Control) | Gets or sets the height and width of the control.
TabIndex (inherited from Control) | Gets or sets the tab order of the control within its container.
TabStop (inherited from Panel) | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key.
Tag (inherited from Control) | Gets or sets the object that contains data about the control.
Text (inherited from Panel) | This member is not meaningful for this control.
Top (inherited from Control) | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area.
TopLevelControl (inherited from Control) | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in.
UseWaitCursor (inherited from Control) | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls.
VerticalScroll (inherited from ScrollableControl) | Gets the characteristics associated with the vertical scroll bar.
Visible (inherited from Control) | Gets or sets a value indicating whether the control is displayed.
Width (inherited from Control) | Gets or sets the width of the control.
WindowTarget (inherited from Control) |

Protected Instance Properties

CanEnableIme (inherited from Control) |
CanRaiseEvents (inherited from Control) | Determines if events can be raised on the control.
CreateParams (inherited from Panel) |
DefaultCursor (inherited from Control) | Gets or sets the default cursor for the control.
DefaultImeMode (inherited from Control) | Gets the default Input Method Editor (IME) mode supported by the control.
DefaultMargin (inherited from Control) | Gets the space, in pixels, that is specified by default between controls.
DefaultMaximumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default maximum size of a control.
DefaultMinimumSize (inherited from Control) | Gets the length and height, in pixels, that is specified as the default minimum size of a control.
DefaultPadding (inherited from Control) | Gets the internal spacing, in pixels, of the contents of a control.
DefaultSize (inherited from Panel) |
DesignMode (inherited from Component) | Gets a value that indicates whether the Component is currently in design mode.
DoubleBuffered (inherited from Control) | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker.
Events (inherited from Component) | Gets the list of event handlers that are attached to this Component.
FontHeight (inherited from Control) | Gets or sets the height of the font of the control.
HScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the horizontal scroll bar is visible.
ImeModeBase (inherited from Control) |
ResizeRedraw (inherited from Control) | Gets or sets a value indicating whether the control redraws itself when resized.
ScaleChildren (inherited from Control) | Gets a value that determines the scaling of child controls.
VScroll (inherited from ScrollableControl) | Gets or sets a value indicating whether the vertical scroll bar is visible.

Protected Internal Instance Properties

RenderRightToLeft (inherited from Control) | Obsolete.
ShowFocusCues (inherited from Control) | Gets a value indicating whether the control should display focus rectangles.
ShowKeyboardCues (inherited from Control) | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators.

See Also

FileDropTargetPanel Class | Aspose.Windows.Forms Namespace


DropTargetManager Property

Aspose.Email

FileDropTargetPanel.DropTargetManager Property

Gets or sets the drop target manager.

public FileDropTargetManager DropTargetManager {get; set;}

Property Value

The drop target manager.

See Also

FileDropTargetPanel Class | Aspose.Windows.Forms Namespace


FileDropTargetPanel Methods

The methods of the FileDropTargetPanel class are listed below. For a complete list of FileDropTargetPanel class members, see the FileDropTargetPanel Members topic.

Public Instance Methods

BeginInvoke (inherited from Control) | Overloaded. Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on.
BringToFront (inherited from Control) | Brings the control to the front of the z-order.
Contains (inherited from Control) | Retrieves a value indicating whether the specified control is a child of the control.
CreateControl (inherited from Control) | Forces the creation of the control, including the creation of the handle and any child controls.
CreateGraphics (inherited from Control) | Creates the Graphics for the control.
CreateObjRef (inherited from MarshalByRefObject) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object.
Dispose (inherited from Component) | Overloaded. Releases all resources used by the Component.
DoDragDrop (inherited from Control) | Begins a drag-and-drop operation.
DrawToBitmap (inherited from Control) | Supports rendering to the specified bitmap.
EndInvoke (inherited from Control) | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
FindForm (inherited from Control) | Retrieves the form that the control is on.
Focus (inherited from Control) | Sets input focus to the control.
GetChildAtPoint (inherited from Control) | Overloaded. Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type.
GetContainerControl (inherited from Control) | Returns the next ContainerControl up the control's chain of parent controls.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLifetimeService (inherited from MarshalByRefObject) | Retrieves the current lifetime service object that controls the lifetime policy for this instance.
GetNextControl (inherited from Control) | Retrieves the next control forward or back in the tab order of child controls.
GetPreferredSize (inherited from Control) | Retrieves the size of a rectangular area into which a control can be fitted.
GetType (inherited from Object) | Gets the Type of the current instance.
Hide (inherited from Control) | Conceals the control from the user.
InitializeLifetimeService (inherited from MarshalByRefObject) | Obtains a lifetime service object to control the lifetime policy for this instance.
Invalidate (inherited from Control) | Overloaded. Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control.
Invoke (inherited from Control) | Overloaded. Executes the specified delegate on the thread that owns the control's underlying window handle.
PerformLayout (inherited from Control) | Overloaded. Forces the control to apply layout logic to all its child controls.
PointToClient (inherited from Control) | Computes the location of the specified screen point into client coordinates.
PointToScreen (inherited from Control) | Computes the location of the specified client point into screen coordinates.
PreProcessControlMessage (inherited from Control) |
PreProcessMessage (inherited from Control) |
RectangleToClient (inherited from Control) | Computes the size and location of the specified screen rectangle in client coordinates.
RectangleToScreen (inherited from Control) | Computes the size and location of the specified client rectangle in screen coordinates.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
ResetBackColor (inherited from Control) |
ResetBindings (inherited from Control) |
ResetCursor (inherited from Control) |
ResetFont (inherited from Control) |
ResetForeColor (inherited from Control) |
ResetImeMode (inherited from Control) |
ResetRightToLeft (inherited from Control) |
ResetText (inherited from Control) | Resets the Text property to its default value.
ResumeLayout (inherited from Control) | Overloaded. Resumes usual layout logic.
Scale (inherited from Control) | Overloaded.
ScrollControlIntoView (inherited from ScrollableControl) | Scrolls the specified child control into view on an auto-scroll enabled control.
Select (inherited from Control) | Overloaded. Activates the control.
SelectNextControl (inherited from Control) | Activates the next control.
SendToBack (inherited from Control) | Sends the control to the back of the z-order.
SetAutoScrollMargin (inherited from ScrollableControl) | Sets the size of the auto-scroll margins.
SetBounds (inherited from Control) | Overloaded. Sets the bounds of the control to the specified location and size.
Show (inherited from Control) | Displays the control to the user.
SuspendLayout (inherited from Control) | Temporarily suspends the layout logic for the control.
ToString (inherited from Panel) | Returns a string representation for this control.
Update (inherited from Control) | Causes the control to redraw the invalidated regions within its client area.

Protected Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control .
AdjustFormScrollbars (inherited from ScrollableControl) | Adjusts the scroll bars on the container based on the current control positions and the control currently selected.
CreateAccessibilityInstance (inherited from Control) | Creates a new accessibility object for the control.
CreateControlsInstance (inherited from Control) | Creates a new instance of the control collection for the control.
CreateHandle (inherited from Control) | Creates a handle for the control.
DefWndProc (inherited from Control) |
DestroyHandle (inherited from Control) | Destroys the handle associated with the control.
Dispose (inherited from Control) | Overloaded. Releases the unmanaged resources used by the Control and its child controls and optionally releases the managed resources.
Finalize (inherited from Component) | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection.
GetAccessibilityObjectById (inherited from Control) | Retrieves the specified AccessibleObject.
GetAutoSizeMode (inherited from Control) | Retrieves a value indicating how a control will behave when its AutoSize property is enabled.
GetScaledBounds (inherited from Control) | Retrieves the bounds within which the control is scaled.
GetScrollState (inherited from ScrollableControl) | Determines whether the specified flag has been set.
GetService (inherited from Component) | Returns an object that represents a service provided by the Component or by its Container.
GetStyle (inherited from Control) | Retrieves the value of the specified control style bit for the control.
GetTopLevel (inherited from Control) | Determines if the control is a top-level control.
InitLayout (inherited from Control) | Called after the control has been added to another container.
InvokeGotFocus (inherited from Control) | Raises the GotFocus event for the specified control.
InvokeLostFocus (inherited from Control) | Raises the LostFocus event for the specified control.
InvokeOnClick (inherited from Control) | Raises the Click event for the specified control.
InvokePaint (inherited from Control) | Raises the Paint event for the specified control.
InvokePaintBackground (inherited from Control) | Raises the PaintBackground event for the specified control.
IsInputChar (inherited from Control) | Determines if a character is an input character that the control recognizes.
IsInputKey (inherited from Control) | Determines whether the specified key is a regular input key or a special key that requires preprocessing.
MemberwiseClone (inherited from MarshalByRefObject) | Overloaded. Creates a shallow copy of the current MarshalByRefObject object.
MemberwiseClone (inherited from Object) | Overloaded. Creates a shallow copy of the current Object.
NotifyInvalidate (inherited from Control) | Raises the Invalidated event with a specified region of the control to invalidate.
OnAutoSizeChanged (inherited from Control) | Raises the AutoSizeChanged event.
OnBackColorChanged (inherited from Control) | Raises the BackColorChanged event.
OnBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event.
OnBackgroundImageLayoutChanged (inherited from Control) | Raises the BackgroundImageLayoutChanged event.
OnBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event.
OnCausesValidationChanged (inherited from Control) | Raises the CausesValidationChanged event.
OnChangeUICues (inherited from Control) | Raises the ChangeUICues event.
OnClick (inherited from Control) | Raises the Click event.
OnClientSizeChanged (inherited from Control) | Raises the ClientSizeChanged event.
OnContextMenuChanged (inherited from Control) | Raises the ContextMenuChanged event.
OnContextMenuStripChanged (inherited from Control) | Raises the ContextMenuStripChanged event.
OnControlAdded (inherited from Control) | Raises the ControlAdded event.
OnControlRemoved (inherited from Control) | Raises the ControlRemoved event.
OnCreateControl (inherited from Control) | Raises the CreateControl event.
OnCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnDockChanged (inherited from Control) | Raises the DockChanged event.
OnDoubleClick (inherited from Control) | Raises the DoubleClick event.
OnDragDrop (inherited from Control) | Raises the DragDrop event.
OnDragEnter (inherited from Control) | Raises the DragEnter event.
OnDragLeave (inherited from Control) | Raises the DragLeave event.
OnDragOver (inherited from Control) | Raises the DragOver event.
OnEnabledChanged (inherited from Control) | Raises the EnabledChanged event.
OnEnter (inherited from Control) | Raises the Enter event.
OnFileDragDrop |
OnFileDragEnter |
OnFileDragLeave |
OnFileDragOver |
OnFontChanged (inherited from Control) | Raises the FontChanged event.
OnForeColorChanged (inherited from Control) | Raises the ForeColorChanged event.
OnGiveFeedback (inherited from Control) | Raises the GiveFeedback event.
OnGotFocus (inherited from Control) | Raises the GotFocus event.
OnHandleCreated |
OnHandleDestroyed |
OnHelpRequested (inherited from Control) | Raises the HelpRequested event.
OnImeModeChanged (inherited from Control) | Raises the ImeModeChanged event.
OnInvalidated (inherited from Control) | Raises the Invalidated event.
OnKeyDown (inherited from Control) | Raises the KeyDown event.
OnKeyPress (inherited from Control) | Raises the KeyPress event.
OnKeyUp (inherited from Control) | Raises the KeyUp event.
OnLayout (inherited from ScrollableControl) |
OnLeave (inherited from Control) | Raises the Leave event.
OnLocationChanged (inherited from Control) | Raises the LocationChanged event.
OnLostFocus (inherited from Control) | Raises the LostFocus event.
OnMarginChanged (inherited from Control) | Raises the MarginChanged event.
OnMouseCaptureChanged (inherited from Control) | Raises the MouseCaptureChanged event.
OnMouseClick (inherited from Control) | Raises the MouseClick event.
OnMouseDoubleClick (inherited from Control) | Raises the MouseDoubleClick event.
OnMouseDown (inherited from Control) | Raises the MouseDown event.
OnMouseEnter (inherited from Control) | Raises the MouseEnter event.
OnMouseHover (inherited from Control) | Raises the MouseHover event.
OnMouseLeave (inherited from Control) | Raises the MouseLeave event.
OnMouseMove (inherited from Control) | Raises the MouseMove event.
OnMouseUp (inherited from Control) | Raises the MouseUp event.
OnMouseWheel (inherited from ScrollableControl) | Raises the MouseWheel event.
OnMove (inherited from Control) | Raises the Move event.
OnNotifyMessage (inherited from Control) | Notifies the control of Windows messages.
OnPaddingChanged (inherited from ScrollableControl) |
OnPaint (inherited from Control) | Raises the Paint event.
OnPaintBackground (inherited from ScrollableControl) |
OnParentBackColorChanged (inherited from Control) | Raises the BackColorChanged event when the BackColor property value of the control's container changes.
OnParentBackgroundImageChanged (inherited from Control) | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes.
OnParentBindingContextChanged (inherited from Control) | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes.
OnParentChanged (inherited from Control) | Raises the ParentChanged event.
OnParentCursorChanged (inherited from Control) | Raises the CursorChanged event.
OnParentEnabledChanged (inherited from Control) | Raises the EnabledChanged event when the Enabled property value of the control's container changes.
OnParentFontChanged (inherited from Control) | Raises the FontChanged event when the Font property value of the control's container changes.
OnParentForeColorChanged (inherited from Control) | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes.
OnParentRightToLeftChanged (inherited from Control) | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes.
OnParentVisibleChanged (inherited from Control) | Raises the VisibleChanged event when the Visible property value of the control's container changes.
OnPreviewKeyDown (inherited from Control) | Raises the PreviewKeyDown event.
OnPrint (inherited from Control) | Raises the Paint event.
OnQueryContinueDrag (inherited from Control) | Raises the QueryContinueDrag event.
OnRegionChanged (inherited from Control) | Raises the RegionChanged event.
OnResize (inherited from Panel) | Fires the event indicating that the panel has been resized. Inheriting controls should use this in favor of actually listening to the event, but should still call base.onResize to ensure that the event is fired for external listeners.
OnRightToLeftChanged (inherited from ScrollableControl) |
OnScroll (inherited from ScrollableControl) | Raises the Scroll event.
OnSizeChanged (inherited from Control) | Raises the SizeChanged event.
OnStyleChanged (inherited from Control) | Raises the StyleChanged event.
OnSystemColorsChanged (inherited from Control) | Raises the SystemColorsChanged event.
OnTabIndexChanged (inherited from Control) | Raises the TabIndexChanged event.
OnTabStopChanged (inherited from Control) | Raises the TabStopChanged event.
OnTextChanged (inherited from Control) | Raises the TextChanged event.
OnValidated (inherited from Control) | Raises the Validated event.
OnValidating (inherited from Control) | Raises the Validating event.
OnVisibleChanged (inherited from ScrollableControl) |
ProcessCmdKey (inherited from Control) |
ProcessDialogChar (inherited from Control) | Processes a dialog character.
ProcessDialogKey (inherited from Control) | Processes a dialog key.
ProcessKeyEventArgs (inherited from Control) |
ProcessKeyPreview (inherited from Control) |
RaiseDragEvent (inherited from Control) | Raises the appropriate drag event.
RaiseKeyEvent (inherited from Control) | Raises the appropriate key event.
RaiseMouseEvent (inherited from Control) | Raises the appropriate mouse event.
RaisePaintEvent (inherited from Control) | Raises the appropriate paint event.
RecreateHandle (inherited from Control) | Forces the re-creation of the handle for the control.
ResetMouseEventArgs (inherited from Control) | Resets the control to handle the MouseLeave event.
RtlTranslateAlignment (inherited from Control) | Overloaded. Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateHorizontal (inherited from Control) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text.
RtlTranslateLeftRight (inherited from Control) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text.
ScaleControl (inherited from ScrollableControl) |
ScaleCore (inherited from ScrollableControl) |
ScrollToControl (inherited from ScrollableControl) | Calculates the scroll offset to the specified child control.
Select (inherited from Control) | Overloaded. Activates a child control. Optionally specifies the direction in the tab order to select the control from.
SetAutoSizeMode (inherited from Control) | Sets a value indicating how a control will behave when its AutoSize property is enabled.
SetBoundsCore (inherited from Control) | Performs the work of setting the specified bounds of this control.
SetClientSizeCore (inherited from Control) | Sets the size of the client area of the control.
SetDisplayRectLocation (inherited from ScrollableControl) | Positions the display window to the specified value.
SetScrollState (inherited from ScrollableControl) | Sets the specified scroll state flag.
SetStyle (inherited from Control) | Sets the specified style bit to the specified value.
SetTopLevel (inherited from Control) | Sets the control as the top-level control.
SetVisibleCore (inherited from Control) | Sets the control to the specified visible state.
SizeFromClientSize (inherited from Control) | Determines the size of the entire control from the height and width of its client area.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the specified size and location.
UpdateStyles (inherited from Control) | Forces the assigned styles to be reapplied to the control.
UpdateZOrder (inherited from Control) | Updates the control in its parent's z-order.
WndProc (inherited from ScrollableControl) |

Protected Internal Instance Methods

AccessibilityNotifyClients (inherited from Control) | Overloaded. Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control.
ProcessKeyMessage (inherited from Control) |
ProcessMnemonic (inherited from Control) | Processes a mnemonic character.
RtlTranslateContent (inherited from Control) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text.
UpdateBounds (inherited from Control) | Overloaded. Updates the bounds of the control with the current size and location.

See Also

FileDropTargetPanel Class | Aspose.Windows.Forms Namespace


FileDropTargetPanel.OnFileDragDrop Method

protected virtual void OnFileDragDrop(
FileDragEventArgs e
);

See Also

FileDropTargetPanel Class | Aspose.Windows.Forms Namespace


FileDropTargetPanel.OnFileDragEnter Method

protected virtual void OnFileDragEnter(
FileDragEventArgs e
);

See Also

FileDropTargetPanel Class | Aspose.Windows.Forms Namespace


FileDropTargetPanel.OnFileDragLeave Method

protected virtual void OnFileDragLeave(
EventArgs e
);

See Also

FileDropTargetPanel Class | Aspose.Windows.Forms Namespace


FileDropTargetPanel.OnFileDragOver Method

protected virtual void OnFileDragOver(
FileDragEventArgs e
);

See Also

FileDropTargetPanel Class | Aspose.Windows.Forms Namespace


FileDropTargetPanel.OnHandleCreated Method

protected override void OnHandleCreated(
EventArgs e
);

See Also

FileDropTargetPanel Class | Aspose.Windows.Forms Namespace


FileDropTargetPanel.OnHandleDestroyed Method

protected override void OnHandleDestroyed(
EventArgs e
);

See Also

FileDropTargetPanel Class | Aspose.Windows.Forms Namespace


FileDropTargetPanel Events

The events of the FileDropTargetPanel class are listed below. For a complete list of FileDropTargetPanel class members, see the FileDropTargetPanel Members topic.

Public Instance Events

AutoSizeChanged (inherited from Panel) | Occurs when the value of the AutoSize property has changed.
BackColorChanged (inherited from Control) | Occurs when the value of the BackColor property changes.
BackgroundImageChanged (inherited from Control) | Occurs when the value of the BackgroundImage property changes.
BackgroundImageLayoutChanged (inherited from Control) | Occurs when the BackgroundImageLayout property changes.
BindingContextChanged (inherited from Control) | Occurs when the value of the BindingContext property changes.
CausesValidationChanged (inherited from Control) | Occurs when the value of the CausesValidation property changes.
ChangeUICues (inherited from Control) | Occurs when the focus or keyboard user interface (UI) cues change.
Click (inherited from Control) | Occurs when the control is clicked.
ClientSizeChanged (inherited from Control) | Occurs when the value of the ClientSize property changes.
ContextMenuChanged (inherited from Control) | Occurs when the value of the ContextMenu property changes.
ContextMenuStripChanged (inherited from Control) | Occurs when the value of the ContextMenuStrip property changes.
ControlAdded (inherited from Control) | Occurs when a new control is added to the ControlCollection.
ControlRemoved (inherited from Control) | Occurs when a control is removed from the ControlCollection.
CursorChanged (inherited from Control) | Occurs when the value of the Cursor property changes.
Disposed (inherited from Component) | Adds an event handler to listen to the Disposed event on the component.
DockChanged (inherited from Control) | Occurs when the value of the Dock property changes.
DoubleClick (inherited from Control) | Occurs when the control is double-clicked.
DragDrop (inherited from Control) | Occurs when a drag-and-drop operation is completed.
DragEnter (inherited from Control) | Occurs when an object is dragged into the control's bounds.
DragLeave (inherited from Control) | Occurs when an object is dragged out of the control's bounds.
DragOver (inherited from Control) | Occurs when an object is dragged over the control's bounds.
EnabledChanged (inherited from Control) | Occurs when the Enabled property value has changed.
Enter (inherited from Control) | Occurs when the control is entered.
FileDragDrop | Occurs when [file drag drop].
FileDragEnter | Occurs when [file drag enter].
FileDragOver | Occurs when [file drag over].
FontChanged (inherited from Control) | Occurs when the Font property value changes.
ForeColorChanged (inherited from Control) | Occurs when the ForeColor property value changes.
GiveFeedback (inherited from Control) | Occurs during a drag operation.
GotFocus (inherited from Control) | Occurs when the control receives focus.
HandleCreated (inherited from Control) | Occurs when a handle is created for the control.
HandleDestroyed (inherited from Control) | Occurs when the control's handle is in the process of being destroyed.
HelpRequested (inherited from Control) | Occurs when the user requests help for a control.
ImeModeChanged (inherited from Control) | Occurs when the ImeMode property has changed.
Invalidated (inherited from Control) | Occurs when a control's display requires redrawing.
KeyDown (inherited from Panel) | This member is not meaningful for this control.
KeyPress (inherited from Panel) | This member is not meaningful for this control.
KeyUp (inherited from Panel) | This member is not meaningful for this control.
Layout (inherited from Control) | Occurs when a control should reposition its child controls.
Leave (inherited from Control) | Occurs when the input focus leaves the control.
LocationChanged (inherited from Control) | Occurs when the Location property value has changed.
LostFocus (inherited from Control) | Occurs when the control loses focus.
MarginChanged (inherited from Control) | Occurs when the control's margin changes.
MouseCaptureChanged (inherited from Control) | Occurs when the control loses mouse capture.
MouseClick (inherited from Control) | Occurs when the control is clicked by the mouse.
MouseDoubleClick (inherited from Control) | Occurs when the control is double clicked by the mouse.
MouseDown (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is pressed.
MouseEnter (inherited from Control) | Occurs when the mouse pointer enters the control.
MouseHover (inherited from Control) | Occurs when the mouse pointer rests on the control.
MouseLeave (inherited from Control) | Occurs when the mouse pointer leaves the control.
MouseMove (inherited from Control) | Occurs when the mouse pointer is moved over the control.
MouseUp (inherited from Control) | Occurs when the mouse pointer is over the control and a mouse button is released.
MouseWheel (inherited from Control) | Occurs when the mouse wheel moves while the control has focus.
Move (inherited from Control) | Occurs when the control is moved.
PaddingChanged (inherited from Control) | Occurs when the control's padding changes.
Paint (inherited from Control) | Occurs when the control is redrawn.
ParentChanged (inherited from Control) | Occurs when the Parent property value changes.
PreviewKeyDown (inherited from Control) | Occurs before the KeyDown event when a key is pressed while focus is on this control.
QueryAccessibilityHelp (inherited from Control) | Occurs when AccessibleObject is providing help to accessibility applications.
QueryContinueDrag (inherited from Control) | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled.
RegionChanged (inherited from Control) | Occurs when the value of the Region property changes.
Resize (inherited from Control) | Occurs when the control is resized.
RightToLeftChanged (inherited from Control) | Occurs when the RightToLeft property value changes.
Scroll (inherited from ScrollableControl) | Occurs when the user or code scrolls through the client area.
SizeChanged (inherited from Control) | Occurs when the Size property value changes.
StyleChanged (inherited from Control) | Occurs when the control style changes.
SystemColorsChanged (inherited from Control) | Occurs when the system colors change.
TabIndexChanged (inherited from Control) | Occurs when the TabIndex property value changes.
TabStopChanged (inherited from Control) | Occurs when the TabStop property value changes.
TextChanged (inherited from Panel) | This member is not meaningful for this control.
Validated (inherited from Control) | Occurs when the control is finished validating.
Validating (inherited from Control) | Occurs when the control is validating.
VisibleChanged (inherited from Control) | Occurs when the Visible property value changes.

See Also

FileDropTargetPanel Class | Aspose.Windows.Forms Namespace


FileDropTargetPanel.FileDragDrop Event

Occurs when [file drag drop].

public event FileDragEventHandler FileDragDrop;

Event Data

The event handler receives an argument of type FileDragEventArgs containing data related to this event. The following FileDragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
Files | Gets the files.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

See Also

FileDropTargetPanel Class | Aspose.Windows.Forms Namespace


FileDropTargetPanel.FileDragEnter Event

Occurs when [file drag enter].

public event FileDragEventHandler FileDragEnter;

Event Data

The event handler receives an argument of type FileDragEventArgs containing data related to this event. The following FileDragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
Files | Gets the files.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

See Also

FileDropTargetPanel Class | Aspose.Windows.Forms Namespace


FileDropTargetPanel.FileDragOver Event

Occurs when [file drag over].

public event FileDragEventHandler FileDragOver;

Event Data

The event handler receives an argument of type FileDragEventArgs containing data related to this event. The following FileDragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
Files | Gets the files.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

See Also

FileDropTargetPanel Class | Aspose.Windows.Forms Namespace


IFileDropTargetControl Interface

For a list of all members of this type, see IFileDropTargetControl Members.

public interface IFileDropTargetControl

Types that implement IFileDropTargetControl

Type | Description
FileDropTargetPanel | Represents the file drop target.

Requirements

Namespace: Aspose.Windows.Forms

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

IFileDropTargetControl Members | Aspose.Windows.Forms Namespace


IFileDropTargetControl Members

IFileDropTargetControl overview

Public Instance Properties

AllowDrop
Handle

Public Instance Methods

OnDragDrop
OnDragEnter
OnDragLeave
OnDragOver

See Also

IFileDropTargetControl Interface | Aspose.Windows.Forms Namespace


IFileDropTargetControl Properties

The properties of the IFileDropTargetControl interface are listed below. For a complete list of IFileDropTargetControl interface members, see the IFileDropTargetControl Members topic.

Public Instance Properties

AllowDrop
Handle

See Also

IFileDropTargetControl Interface | Aspose.Windows.Forms Namespace


AllowDrop Property

Aspose.Email

IFileDropTargetControl.AllowDrop Property

bool AllowDrop {get;}

See Also

IFileDropTargetControl Interface | Aspose.Windows.Forms Namespace


Handle Property

Aspose.Email

IFileDropTargetControl.Handle Property

IntPtr Handle {get;}

See Also

IFileDropTargetControl Interface | Aspose.Windows.Forms Namespace


IFileDropTargetControl Methods

The methods of the IFileDropTargetControl interface are listed below. For a complete list of IFileDropTargetControl interface members, see the IFileDropTargetControl Members topic.

Public Instance Methods

OnDragDrop
OnDragEnter
OnDragLeave
OnDragOver

See Also

IFileDropTargetControl Interface | Aspose.Windows.Forms Namespace


IFileDropTargetControl.OnDragDrop Method

void OnDragDrop(
DragEventArgs e
);

See Also

IFileDropTargetControl Interface | Aspose.Windows.Forms Namespace


IFileDropTargetControl.OnDragEnter Method

void OnDragEnter(
DragEventArgs e
);

See Also

IFileDropTargetControl Interface | Aspose.Windows.Forms Namespace


IFileDropTargetControl.OnDragLeave Method

void OnDragLeave(
EventArgs e
);

See Also

IFileDropTargetControl Interface | Aspose.Windows.Forms Namespace


IFileDropTargetControl.OnDragOver Method

void OnDragOver(
DragEventArgs e
);

See Also

IFileDropTargetControl Interface | Aspose.Windows.Forms Namespace


MailClientAgent Class

Represents an email client agent.

For a list of all members of this type, see MailClientAgent Members.

System.Object
Aspose.Windows.Forms.MailClientAgent

public class MailClientAgent

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Windows.Forms

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

MailClientAgent Members | Aspose.Windows.Forms Namespace


MailClientAgent Members

MailClientAgent overview

Public Instance Constructors

MailClientAgent Constructor Initializes a new instance of the MailClientAgent class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Launch | Overloaded. Launches the agent.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MailClientAgent Class | Aspose.Windows.Forms Namespace


MailClientAgent Constructor

Initializes a new instance of the MailClientAgent class.

public MailClientAgent();

See Also

MailClientAgent Class | Aspose.Windows.Forms Namespace


MailClientAgent Methods

The methods of the MailClientAgent class are listed below. For a complete list of MailClientAgent class members, see the MailClientAgent Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Launch | Overloaded. Launches the agent.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

MailClientAgent Class | Aspose.Windows.Forms Namespace


Launch Method

Aspose.Email

MailClientAgent.Launch Method

Launches the agent.

Overload List

Launches the agent.

public virtual void Launch(string,string,RecipientCollection);

Launches the agent.

public virtual void Launch(string,string,RecipientCollection,string[]);

See Also

MailClientAgent Class | Aspose.Windows.Forms Namespace


MailClientAgent.Launch Method (String, String, RecipientCollection)

Launches the agent.

public virtual void Launch(
string subject,
string body,
RecipientCollection recipients
);

Parameters

subject
The message subject.
body
The message body.
recipients
The message recipients.

See Also

MailClientAgent Class | Aspose.Windows.Forms Namespace | MailClientAgent.Launch Overload List


MailClientAgent.Launch Method (String, String, RecipientCollection, String[])

Launches the agent.

public virtual void Launch(
string subject,
string body,
RecipientCollection recipients,
string[] attachments
);

Parameters

subject
The message subject.
body
The message body.
recipients
The message recipients.
attachments
The message attachments.

See Also

MailClientAgent Class | Aspose.Windows.Forms Namespace | MailClientAgent.Launch Overload List


Recipient Class

Represents a Recipient for a MapiMailMessage.

For a list of all members of this type, see Recipient Members.

System.Object
Aspose.Windows.Forms.Recipient

public class Recipient

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Windows.Forms

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Recipient Members | Aspose.Windows.Forms Namespace


Recipient Members

Recipient overview

Public Instance Constructors

Recipient Overloaded. Initializes a new instance of the Recipient class.

Public Instance Properties

Address | The email address of this recipient.
DisplayName | The display name of this recipient.
RecipientType | How the recipient will receive this message (To, CC, BCC).

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

Recipient Class | Aspose.Windows.Forms Namespace


Recipient Constructor

Creates a new recipient with the specified address.

Overload List

Creates a new recipient with the specified address.

public Recipient(string);

Creates a new recipient with the specified address and recipient type.

public Recipient(string,RecipientType);

Creates a new recipient with the specified address and display name.

public Recipient(string,string);

Creates a new recipient with the specified address, display name and recipient type.

public Recipient(string,string,RecipientType);

See Also

Recipient Class | Aspose.Windows.Forms Namespace


Recipient Constructor (String)

Creates a new recipient with the specified address.

public Recipient(
string address
);

See Also

Recipient Class | Aspose.Windows.Forms Namespace | Recipient Constructor Overload List


Recipient Constructor (String, String)

Creates a new recipient with the specified address and display name.

public Recipient(
string address,
string displayName
);

See Also

Recipient Class | Aspose.Windows.Forms Namespace | Recipient Constructor Overload List


Recipient Constructor (String, RecipientType)

Creates a new recipient with the specified address and recipient type.

public Recipient(
string address,
RecipientType recipientType
);

See Also

Recipient Class | Aspose.Windows.Forms Namespace | Recipient Constructor Overload List


Recipient Constructor (String, String, RecipientType)

Creates a new recipient with the specified address, display name and recipient type.

public Recipient(
string address,
string displayName,
RecipientType recipientType
);

See Also

Recipient Class | Aspose.Windows.Forms Namespace | Recipient Constructor Overload List


Recipient Properties

The properties of the Recipient class are listed below. For a complete list of Recipient class members, see the Recipient Members topic.

Public Instance Properties

Address | The email address of this recipient.
DisplayName | The display name of this recipient.
RecipientType | How the recipient will receive this message (To, CC, BCC).

See Also

Recipient Class | Aspose.Windows.Forms Namespace


Address Property

Aspose.Email

Recipient.Address Property

The email address of this recipient.

public string Address {get; set;}

See Also

Recipient Class | Aspose.Windows.Forms Namespace


DisplayName Property

Aspose.Email

Recipient.DisplayName Property

The display name of this recipient.

public string DisplayName {get; set;}

See Also

Recipient Class | Aspose.Windows.Forms Namespace


RecipientType Property

Aspose.Email

Recipient.RecipientType Property

How the recipient will receive this message (To, CC, BCC).

public RecipientType RecipientType {get; set;}

See Also

Recipient Class | Aspose.Windows.Forms Namespace


RecipientCollection Class

Represents a colleciton of recipients for a mail message.

For a list of all members of this type, see RecipientCollection Members.

System.Object
System.Collections.ObjectModel.Collection`1[[Aspose.Windows.Forms.Recipient, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]]
Aspose.Windows.Forms.RecipientCollection

public class RecipientCollection : Collection`1

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: Aspose.Windows.Forms

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

RecipientCollection Members | Aspose.Windows.Forms Namespace


RecipientCollection Members

RecipientCollection overview

Public Instance Constructors

RecipientCollection Constructor Initializes a new instance of the RecipientCollection class.

Public Instance Properties

Count (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Item | Returns the recipient stored in this collection at the specified index.

Public Instance Methods

Add | Overloaded. Adds a new recipient with the specified address to this collection.
Add (inherited from 0, Culture=neutral, PublicKeyToken=null]]) | Overloaded.
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Properties

Items (inherited from 0, Culture=neutral, PublicKeyToken=null]])

Protected Instance Methods

ClearItems (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
InsertItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RemoveItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
SetItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |

See Also

RecipientCollection Class | Aspose.Windows.Forms Namespace


RecipientCollection Constructor

Initializes a new instance of the RecipientCollection class.

public RecipientCollection();

See Also

RecipientCollection Class | Aspose.Windows.Forms Namespace


RecipientCollection Properties

The properties of the RecipientCollection class are listed below. For a complete list of RecipientCollection class members, see the RecipientCollection Members topic.

Public Instance Properties

Count (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Item | Returns the recipient stored in this collection at the specified index.

Protected Instance Properties

Items (inherited from 0, Culture=neutral, PublicKeyToken=null]])

See Also

RecipientCollection Class | Aspose.Windows.Forms Namespace


Item Property

Aspose.Email

RecipientCollection.Item Property

Returns the recipient stored in this collection at the specified index.

new public Recipient this[
int index
] {get;}

Implements

IList`1.Item

See Also

RecipientCollection Class | Aspose.Windows.Forms Namespace


RecipientCollection Methods

The methods of the RecipientCollection class are listed below. For a complete list of RecipientCollection class members, see the RecipientCollection Members topic.

Public Instance Methods

Add | Overloaded. Adds a new recipient with the specified address to this collection.
Add (inherited from 0, Culture=neutral, PublicKeyToken=null]]) | Overloaded.
Clear (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Contains (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
CopyTo (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetEnumerator (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IndexOf (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Insert (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Remove (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
RemoveAt (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

ClearItems (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
InsertItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
RemoveItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |
SetItem (inherited from 0, Culture=neutral, PublicKeyToken=null]]) |

See Also

RecipientCollection Class | Aspose.Windows.Forms Namespace


Add Method

Aspose.Email

RecipientCollection.Add Method

Adds a new recipient with the specified address to this collection.

Overload List

Inherited from 0, Culture=neutral, PublicKeyToken=null]].

public void Add(Recipient);

Adds a new recipient with the specified address to this collection.

public void Add(string);

Adds a new recipient with the specified address and recipient type to this collection.

public void Add(string,RecipientType);

Adds a new recipient with the specified address and display name to this collection.

public void Add(string,string);

Adds a new recipient with the specified address, display name and recipient type to this collection.

public void Add(string,string,RecipientType);

See Also

RecipientCollection Class | Aspose.Windows.Forms Namespace


RecipientCollection.Add Method (String)

Adds a new recipient with the specified address to this collection.

public void Add(
string address
);

See Also

RecipientCollection Class | Aspose.Windows.Forms Namespace | RecipientCollection.Add Overload List


RecipientCollection.Add Method (String, RecipientType)

Adds a new recipient with the specified address and recipient type to this collection.

public void Add(
string address,
RecipientType recipientType
);

See Also

RecipientCollection Class | Aspose.Windows.Forms Namespace | RecipientCollection.Add Overload List


RecipientCollection.Add Method (String, String)

Adds a new recipient with the specified address and display name to this collection.

public void Add(
string address,
string displayName
);

See Also

RecipientCollection Class | Aspose.Windows.Forms Namespace | RecipientCollection.Add Overload List


RecipientCollection.Add Method (String, String, RecipientType)

Adds a new recipient with the specified address, display name and recipient type to this collection.

public void Add(
string address,
string displayName,
RecipientType recipientType
);

See Also

RecipientCollection Class | Aspose.Windows.Forms Namespace | RecipientCollection.Add Overload List


RecipientType Enumeration

Specifies the type of recipient.

public enum RecipientType

Members

Member Name | Description | Value
None | No values are set | 0
To | The primary recipient. | 1
CC | The carbon copy recipient. | 2
BCC | The blind carbon copy recipient. | 3

Requirements

Namespace: Aspose.Windows.Forms

Assembly: Aspose.Email (in Aspose.Email.dll)

See Also

Aspose.Windows.Forms Namespace


Aspose.Email for .NET API Reference

The Aspose.Email class library provides the following namespaces:

Aspose.Email
Contains all classes of Aspose.Email
Aspose.Email.Common.Commands
Contains common classes of Aspose.Email commands
Aspose.Email.Exchange
Provides classes for Microsofrt Exchange Server access
Aspose.Email.Exchange.Schema
Provides classes of Aspose.Email.Exchange.Schema
Aspose.Email.Exchange.Schema.Exchange_2013
Provides classes of Aspose.Email.Exchange.Schema.Exchange_2013
Aspose.Email.Formats
Contains classes for email formats handling
Aspose.Email.Formats.Mbox
Provides classes for work with mbox storage format
Aspose.Email.Formats.Outlook
Provides classes for work with Microsoft Outlook
Aspose.Email.Formats.Outlook.Msg
Provides classes for work with Microsoft Outlook message format
Aspose.Email.Formats.VCard
Provides classes for work with VCard format
Aspose.Email.Google
Provides classes for access to Google account
Aspose.Email.Imap
Provides classes to access and manipulate messages by using the Internet Message Access Protocol (IMAP)
Aspose.Email.Logging
Contains classes that represent the logging functionality
Aspose.Email.Mail
Provides classes for work with an eml message format
Aspose.Email.Mail.Calendaring
Provides auxiliary classes for work with calendar
Aspose.Email.Mime
Provides classes that extend the format of email
Aspose.Email.Outlook
Contains classes that represent Outlook messages, contacts, appointments and their items
Aspose.Email.Outlook.Pst
Provides classes for work with Microsoft Outlook pst format
Aspose.Email.Pop3
Provides classes to access and manipulate messages by using the Post Office Protocol Version 3 (POP3)
Aspose.Email.Printing
Contains classes that represent the message printing functionality
Aspose.Email.Protocols.ActiveSync.TransportLayer
Contains classes to access and manipulate messages by using the ActiveSync Protocol
Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces
Contains classes to access and manipulate messages by using the ActiveSync Protocol
Aspose.Email.Protocols.Exchange.ExchangeDav
Provides classes for Microsofrt Exchange Server access
Aspose.Email.Services
Contains common classes of email services
Aspose.Email.Services.Google
Provides classes for access to Google account
Aspose.Email.Verify
Contains classes that represent the message validating functionality
Aspose.Email.Windows.WPF
Contains classes that provide ability to handle files dragged from Outlook
Aspose.iCalendar
Provides auxiliary classes to work with calendar
Aspose.Windows.Forms
Contains classes that provide ability to handle files dragged from Outlook

© 2003-2014 Aspose Pty Ltd. All rights reserved.


AsposeException Hierarchy

System.Object
Exception
AsposeException
ActiveSyncException
ActiveSyncNotSupportedException
AsposeArgumentException
AsposeArgumentNullException
AsposeInvalidDataException
ExchangeException
FileCorruptedException
FormatNotSupportedException
GoogleClientException

See Also

AsposeException Class | AsposeException Members | Aspose.Email Namespace


Aspose.Email.Common.CommandsHierarchy

Aspose.Email

Aspose.Email.Common.Commands Hierarchy

System.Object
Aspose.Email.Common.Commands.BaseCommand ---- Aspose.Email.Common.Commands.ICommand, System.IDisposable
Aspose.Email.Common.Commands.BaseAsyncCommand ---- Aspose.Email.Common.Commands.IAsyncCommand
Aspose.Email.Common.Commands.CommandStatus
Aspose.Email.Common.Commands.IAsyncCommand ---- Aspose.Email.Common.Commands.ICommand, System.IDisposable
Aspose.Email.Common.Commands.ICommand ---- System.IDisposable
System.EventArgs
Aspose.Email.Common.Commands.AsyncCommandResultEventArgs
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Email.Common.Commands.AsyncCommandResults

See Also

Aspose.Email.Common.Commands Namespace


BaseRequestType Hierarchy

System.Object
BaseRequestType
ApplyConversationActionType
BaseDelegateType
BaseMoveCopyFolderType
BaseMoveCopyItemType
ConvertIdType
CreateAttachmentType
CreateFolderType
CreateItemType
CreateManagedFolderRequestType
CreateUserConfigurationType
DeleteAttachmentType
DeleteFolderType
DeleteItemType
DeleteUserConfigurationType
DisconnectPhoneCallType
EmptyFolderType
ExpandDLType
ExportItemsType
FindConversationType
FindFolderType
FindItemType
FindMailboxStatisticsByKeywordsType
FindMessageTrackingReportRequestType
GetAttachmentType
GetEventsType
GetFolderType
GetInboxRulesRequestType
GetItemType
GetMailTipsType
GetMessageTrackingReportRequestType
GetPhoneCallInformationType
GetRoomListsType
GetRoomsType
GetServerTimeZonesType
GetServiceConfigurationType
GetSharingFolderType
GetSharingMetadataType
GetStreamingEventsType
GetUserAvailabilityRequestType
GetUserConfigurationType
GetUserOofSettingsRequest
PlayOnPhoneType
RefreshSharingFolderType
ResolveNamesType
SendItemType
SetUserOofSettingsRequest
SubscribeType
SyncFolderHierarchyType
SyncFolderItemsType
UnsubscribeType
UpdateFolderType
UpdateInboxRulesRequestType
UpdateItemType
UpdateUserConfigurationType
UploadItemsType

See Also

BaseRequestType Class | BaseRequestType Members | Aspose.Email.Exchange.Schema Namespace


BaseResponseMessageType Hierarchy

System.Object
BaseResponseMessageType
ApplyConversationActionResponseType
ConvertIdResponseType
CopyFolderResponseType
CopyItemResponseType
CreateAttachmentResponseType
CreateFolderResponseType
CreateItemResponseType
CreateManagedFolderResponseType
CreateUserConfigurationResponseType
DeleteAttachmentResponseType
DeleteFolderResponseType
DeleteItemResponseType
DeleteUserConfigurationResponseType
EmptyFolderResponseType
ExpandDLResponseType
ExportItemsResponseType
FindFolderResponseType
FindItemResponseType
FindMailboxStatisticsByKeywordsResponseType
GetAttachmentResponseType
GetEventsResponseType
GetFolderResponseType
GetItemResponseType
GetServerTimeZonesResponseType
GetStreamingEventsResponseType
GetUserConfigurationResponseType
MoveFolderResponseType
MoveItemResponseType
ResolveNamesResponseType
SendItemResponseType
SendNotificationResponseType
SubscribeResponseType
SyncFolderHierarchyResponseType
SyncFolderItemsResponseType
UnsubscribeResponseType
UpdateFolderResponseType
UpdateItemResponseType
UpdateUserConfigurationResponseType
UploadItemsResponseType

See Also

BaseResponseMessageType Class | BaseResponseMessageType Members | Aspose.Email.Exchange.Schema Namespace


BaseRequestType Hierarchy

System.Object
BaseRequestType
AddDistributionGroupToImListType
AddImContactToGroupType
AddImGroupType
AddNewImContactToGroupType
AddNewTelUriContactToGroupType
ApplyConversationActionType
ArchiveItemType
BaseDelegateType
BaseMoveCopyFolderType
BaseMoveCopyItemType
CompleteFindInGALSpeechRecognitionType
ConvertIdType
CreateAttachmentType
CreateFolderPathType
CreateFolderType
CreateItemType
CreateManagedFolderRequestType
CreateUMCallDataRecordType
CreateUMPromptType
CreateUserConfigurationType
DeleteAttachmentType
DeleteFolderType
DeleteItemType
DeleteUMPromptsType
DeleteUserConfigurationType
DisableAppType
DisconnectPhoneCallType
EmptyFolderType
ExpandDLType
ExportItemsType
FindConversationType
FindFolderType
FindItemType
FindMailboxStatisticsByKeywordsType
FindMessageTrackingReportRequestType
FindPeopleType
GetAppManifestsType
GetAppMarketplaceUrlType
GetAttachmentType
GetClientAccessTokenType
GetClientExtensionType
GetClientIntentType
GetConversationItemsType
GetDiscoverySearchConfigurationType
GetEventsType
GetFolderType
GetHoldOnMailboxesType
GetImItemListType
GetImItemsType
GetInboxRulesRequestType
GetItemType
GetMailTipsType
GetMessageTrackingReportRequestType
GetNonIndexableItemDetailsType
GetNonIndexableItemStatisticsType
GetPasswordExpirationDateType
GetPersonaType
GetPhoneCallInformationType
GetRemindersType
GetRoomListsType
GetRoomsType
GetSearchableMailboxesType
GetServerTimeZonesType
GetServiceConfigurationType
GetSharingFolderType
GetSharingMetadataType
GetStreamingEventsType
GetUMCallDataRecordsType
GetUMCallSummaryType
GetUMPinType
GetUMPromptNamesType
GetUMPromptType
GetUMSubscriberCallAnsweringDataType
GetUserAvailabilityRequestType
GetUserConfigurationType
GetUserOofSettingsRequest
GetUserPhotoType
GetUserRetentionPolicyTagsType
InitUMMailboxType
InstallAppType
MarkAllItemsAsReadType
MarkAsJunkType
PerformReminderActionType
PlayOnPhoneType
RefreshSharingFolderType
RemoveContactFromImListType
RemoveDistributionGroupFromImListType
RemoveImContactFromGroupType
RemoveImGroupType
ResetUMMailboxType
ResolveNamesType
SaveUMPinType
SearchMailboxesType
SendItemType
SetClientExtensionType
SetHoldOnMailboxesType
SetImGroupType
SetImListMigrationCompletedType
SetTeamMailboxRequestType
SetUserOofSettingsRequest
StartFindInGALSpeechRecognitionType
SubscribeType
SyncFolderHierarchyType
SyncFolderItemsType
UninstallAppType
UnpinTeamMailboxRequestType
UnsubscribeType
UpdateFolderType
UpdateInboxRulesRequestType
UpdateItemInRecoverableItemsType
UpdateItemType
UpdateUserConfigurationType
UploadItemsType
ValidateUMPinType

See Also

BaseRequestType Class | BaseRequestType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


BaseResponseMessageType Hierarchy

System.Object
BaseResponseMessageType
ApplyConversationActionResponseType
ArchiveItemResponseType
ConvertIdResponseType
CopyFolderResponseType
CopyItemResponseType
CreateAttachmentResponseType
CreateFolderPathResponseType
CreateFolderResponseType
CreateItemResponseType
CreateManagedFolderResponseType
CreateUserConfigurationResponseType
DeleteAttachmentResponseType
DeleteFolderResponseType
DeleteItemResponseType
DeleteUserConfigurationResponseType
EmptyFolderResponseType
ExpandDLResponseType
ExportItemsResponseType
FindFolderResponseType
FindItemResponseType
FindMailboxStatisticsByKeywordsResponseType
GetAttachmentResponseType
GetClientAccessTokenResponseType
GetConversationItemsResponseType
GetEventsResponseType
GetFolderResponseType
GetItemResponseType
GetServerTimeZonesResponseType
GetStreamingEventsResponseType
GetUserConfigurationResponseType
GetUserPhotoResponseType
MarkAllItemsAsReadResponseType
MarkAsJunkResponseType
MoveFolderResponseType
MoveItemResponseType
ResolveNamesResponseType
SearchMailboxesResponseType
SendItemResponseType
SendNotificationResponseType
SetClientExtensionResponseType
SubscribeResponseType
SyncFolderHierarchyResponseType
SyncFolderItemsResponseType
UnsubscribeResponseType
UpdateFolderResponseType
UpdateItemInRecoverableItemsResponseType
UpdateItemResponseType
UpdateUserConfigurationResponseType
UploadItemsResponseType

See Also

BaseResponseMessageType Class | BaseResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


EntityType Hierarchy

System.Object
EntityType
AddressEntityType
ContactType
EmailAddressEntityType
MeetingSuggestionType
PhoneEntityType
TaskSuggestionType
UrlEntityType

See Also

EntityType Class | EntityType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemType Hierarchy

System.Object
ItemType
CalendarItemType
ContactItemType
DistributionListType
MessageType
PostItemType
TaskType

See Also

ItemType Class | ItemType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ResponseMessageType Hierarchy

System.Object
ResponseMessageType
AddDistributionGroupToImListResponseMessageType
AddImContactToGroupResponseMessageType
AddImGroupResponseMessageType
AddNewImContactToGroupResponseMessageType
AddNewTelUriContactToGroupResponseMessageType
AttachmentInfoResponseMessageType
BaseDelegateResponseMessageType
ClientExtensionResponseType
CompleteFindInGALSpeechRecognitionResponseMessageType
ConvertIdResponseMessageType
CreateUMCallDataRecordResponseMessageType
CreateUMPromptResponseMessageType
DelegateUserResponseMessageType
DeleteAttachmentResponseMessageType
DeleteUMPromptsResponseMessageType
DisableAppResponseType
DisconnectPhoneCallResponseMessageType
ExpandDLResponseMessageType
ExportItemsResponseMessageType
FindConversationResponseMessageType
FindFolderResponseMessageType
FindItemResponseMessageType
FindMailboxStatisticsByKeywordsResponseMessageType
FindMessageTrackingReportResponseMessageType
FindPeopleResponseMessageType
FolderInfoResponseMessageType
GetAppManifestsResponseType
GetAppMarketplaceUrlResponseMessageType
GetClientAccessTokenResponseMessageType
GetClientIntentResponseMessageType
GetConversationItemsResponseMessageType
GetDiscoverySearchConfigurationResponseMessageType
GetEventsResponseMessageType
GetHoldOnMailboxesResponseMessageType
GetImItemListResponseMessageType
GetImItemsResponseMessageType
GetInboxRulesResponseType
GetMailTipsResponseMessageType
GetMessageTrackingReportResponseMessageType
GetNonIndexableItemDetailsResponseMessageType
GetNonIndexableItemStatisticsResponseMessageType
GetPasswordExpirationDateResponseMessageType
GetPersonaResponseMessageType
GetPhoneCallInformationResponseMessageType
GetRemindersResponseMessageType
GetRoomListsResponseMessageType
GetRoomsResponseMessageType
GetSearchableMailboxesResponseMessageType
GetServerTimeZonesResponseMessageType
GetServiceConfigurationResponseMessageType
GetSharingFolderResponseMessageType
GetSharingMetadataResponseMessageType
GetStreamingEventsResponseMessageType
GetUMCallDataRecordsResponseMessageType
GetUMCallSummaryResponseMessageType
GetUMPinResponseMessageType
GetUMPromptNamesResponseMessageType
GetUMPromptResponseMessageType
GetUMSubscriberCallAnsweringDataResponseMessageType
GetUserConfigurationResponseMessageType
GetUserPhotoResponseMessageType
GetUserRetentionPolicyTagsResponseMessageType
InitUMMailboxResponseMessageType
InstallAppResponseType
ItemInfoResponseMessageType
MailTipsResponseMessageType
MarkAsJunkResponseMessageType
PerformReminderActionResponseMessageType
PlayOnPhoneResponseMessageType
RefreshSharingFolderResponseMessageType
RemoveContactFromImListResponseMessageType
RemoveDistributionGroupFromImListResponseMessageType
RemoveImContactFromGroupResponseMessageType
RemoveImGroupResponseMessageType
ResetUMMailboxResponseMessageType
ResolveNamesResponseMessageType
SaveUMPinResponseMessageType
SearchMailboxesResponseMessageType
SendNotificationResponseMessageType
ServiceConfigurationResponseMessageType
SetHoldOnMailboxesResponseMessageType
SetImGroupResponseMessageType
SetImListMigrationCompletedResponseMessageType
SetTeamMailboxResponseMessageType
StartFindInGALSpeechRecognitionResponseMessageType
SubscribeResponseMessageType
SyncFolderHierarchyResponseMessageType
SyncFolderItemsResponseMessageType
UninstallAppResponseType
UnpinTeamMailboxResponseMessageType
UpdateInboxRulesResponseType
UploadItemsResponseMessageType
ValidateUMPinResponseMessageType

See Also

ResponseMessageType Class | ResponseMessageType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


SearchExpressionType Hierarchy

System.Object
SearchExpressionType
ContainsExpressionType
ExcludesType
ExistsType
MultipleOperandBooleanExpressionType
NotType
TwoOperandExpressionType

See Also

SearchExpressionType Class | SearchExpressionType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


TwoOperandExpressionType Hierarchy

System.Object
SearchExpressionType
TwoOperandExpressionType
IsEqualToType
IsGreaterThanOrEqualToType
IsGreaterThanType
IsLessThanOrEqualToType
IsLessThanType
IsNotEqualToType

See Also

TwoOperandExpressionType Class | TwoOperandExpressionType Members | Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


Aspose.Email.Exchange.Schema.Exchange_2013Hierarchy

Aspose.Email

Aspose.Email.Exchange.Schema.Exchange_2013 Hierarchy

System.Object
Aspose.Email.Exchange.Schema.Exchange_2013.AggregateOnType
Aspose.Email.Exchange.Schema.Exchange_2013.AlternateIdBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.AlternateIdType
Aspose.Email.Exchange.Schema.Exchange_2013.AlternatePublicFolderIdType
Aspose.Email.Exchange.Schema.Exchange_2013.AlternatePublicFolderItemIdType
Aspose.Email.Exchange.Schema.Exchange_2013.ArrayOfDLExpansionType
Aspose.Email.Exchange.Schema.Exchange_2013.ArrayOfGroupedItemsType
Aspose.Email.Exchange.Schema.Exchange_2013.ArrayOfRealItemsType
Aspose.Email.Exchange.Schema.Exchange_2013.ArrayOfResolutionType
Aspose.Email.Exchange.Schema.Exchange_2013.ArrayOfResponseMessagesType
Aspose.Email.Exchange.Schema.Exchange_2013.ArrayOfTimeZoneDefinitionType
Aspose.Email.Exchange.Schema.Exchange_2013.ArrayOfTrackingPropertiesType
Aspose.Email.Exchange.Schema.Exchange_2013.ArrayOfTransitionsType
Aspose.Email.Exchange.Schema.Exchange_2013.AttachmentResponseShapeType
Aspose.Email.Exchange.Schema.Exchange_2013.AttachmentType
Aspose.Email.Exchange.Schema.Exchange_2013.FileAttachmentType
Aspose.Email.Exchange.Schema.Exchange_2013.ItemAttachmentType
Aspose.Email.Exchange.Schema.Exchange_2013.AttendeeConflictData
Aspose.Email.Exchange.Schema.Exchange_2013.GroupAttendeeConflictData
Aspose.Email.Exchange.Schema.Exchange_2013.IndividualAttendeeConflictData
Aspose.Email.Exchange.Schema.Exchange_2013.TooBigGroupAttendeeConflictData
Aspose.Email.Exchange.Schema.Exchange_2013.UnknownAttendeeConflictData
Aspose.Email.Exchange.Schema.Exchange_2013.AttendeeType
Aspose.Email.Exchange.Schema.Exchange_2013.AudioMetricsAverageType
Aspose.Email.Exchange.Schema.Exchange_2013.AudioQualityType
Aspose.Email.Exchange.Schema.Exchange_2013.BaseCalendarItemStateDefinitionType
Aspose.Email.Exchange.Schema.Exchange_2013.DeletedOccurrenceStateDefinitionType
Aspose.Email.Exchange.Schema.Exchange_2013.DeleteFromFolderStateDefinitionType
Aspose.Email.Exchange.Schema.Exchange_2013.LocationBasedStateDefinitionType
Aspose.Email.Exchange.Schema.Exchange_2013.BaseEmailAddressType
Aspose.Email.Exchange.Schema.Exchange_2013.EmailAddressType
Aspose.Email.Exchange.Schema.Exchange_2013.BaseFolderIdType
Aspose.Email.Exchange.Schema.Exchange_2013.AddressListIdType
Aspose.Email.Exchange.Schema.Exchange_2013.DistinguishedFolderIdType
Aspose.Email.Exchange.Schema.Exchange_2013.FolderIdType
Aspose.Email.Exchange.Schema.Exchange_2013.BaseFolderType
Aspose.Email.Exchange.Schema.Exchange_2013.CalendarFolderType
Aspose.Email.Exchange.Schema.Exchange_2013.ContactsFolderType
Aspose.Email.Exchange.Schema.Exchange_2013.FolderType
Aspose.Email.Exchange.Schema.Exchange_2013.SearchFolderType
Aspose.Email.Exchange.Schema.Exchange_2013.TasksFolderType
Aspose.Email.Exchange.Schema.Exchange_2013.BaseGroupByType
Aspose.Email.Exchange.Schema.Exchange_2013.DistinguishedGroupByType
Aspose.Email.Exchange.Schema.Exchange_2013.GroupByType
Aspose.Email.Exchange.Schema.Exchange_2013.BaseItemIdType
Aspose.Email.Exchange.Schema.Exchange_2013.ItemIdType
Aspose.Email.Exchange.Schema.Exchange_2013.RecurringMasterItemIdRangesType
Aspose.Email.Exchange.Schema.Exchange_2013.OccurrenceItemIdType
Aspose.Email.Exchange.Schema.Exchange_2013.RecurringMasterItemIdType
Aspose.Email.Exchange.Schema.Exchange_2013.RequestAttachmentIdType
Aspose.Email.Exchange.Schema.Exchange_2013.AttachmentIdType
Aspose.Email.Exchange.Schema.Exchange_2013.RootItemIdType
Aspose.Email.Exchange.Schema.Exchange_2013.BaseNotificationEventType
Aspose.Email.Exchange.Schema.Exchange_2013.BaseObjectChangedEventType
Aspose.Email.Exchange.Schema.Exchange_2013.ModifiedEventType
Aspose.Email.Exchange.Schema.Exchange_2013.MovedCopiedEventType
Aspose.Email.Exchange.Schema.Exchange_2013.BasePagingType
Aspose.Email.Exchange.Schema.Exchange_2013.CalendarViewType
Aspose.Email.Exchange.Schema.Exchange_2013.ContactsViewType
Aspose.Email.Exchange.Schema.Exchange_2013.FractionalPageViewType
Aspose.Email.Exchange.Schema.Exchange_2013.IndexedPageViewType
Aspose.Email.Exchange.Schema.Exchange_2013.SeekToConditionPageViewType
Aspose.Email.Exchange.Schema.Exchange_2013.BasePathToElementType
Aspose.Email.Exchange.Schema.Exchange_2013.PathToExceptionFieldType
Aspose.Email.Exchange.Schema.Exchange_2013.PathToExtendedFieldType
Aspose.Email.Exchange.Schema.Exchange_2013.PathToIndexedFieldType
Aspose.Email.Exchange.Schema.Exchange_2013.PathToUnindexedFieldType
Aspose.Email.Exchange.Schema.Exchange_2013.BasePermissionType
Aspose.Email.Exchange.Schema.Exchange_2013.CalendarPermissionType
Aspose.Email.Exchange.Schema.Exchange_2013.PermissionType
Aspose.Email.Exchange.Schema.Exchange_2013.BaseRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.AddDistributionGroupToImListType
Aspose.Email.Exchange.Schema.Exchange_2013.AddImContactToGroupType
Aspose.Email.Exchange.Schema.Exchange_2013.AddImGroupType
Aspose.Email.Exchange.Schema.Exchange_2013.AddNewImContactToGroupType
Aspose.Email.Exchange.Schema.Exchange_2013.AddNewTelUriContactToGroupType
Aspose.Email.Exchange.Schema.Exchange_2013.ApplyConversationActionType
Aspose.Email.Exchange.Schema.Exchange_2013.ArchiveItemType
Aspose.Email.Exchange.Schema.Exchange_2013.BaseDelegateType
Aspose.Email.Exchange.Schema.Exchange_2013.AddDelegateType
Aspose.Email.Exchange.Schema.Exchange_2013.GetDelegateType
Aspose.Email.Exchange.Schema.Exchange_2013.RemoveDelegateType
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateDelegateType
Aspose.Email.Exchange.Schema.Exchange_2013.BaseMoveCopyFolderType
Aspose.Email.Exchange.Schema.Exchange_2013.CopyFolderType
Aspose.Email.Exchange.Schema.Exchange_2013.MoveFolderType
Aspose.Email.Exchange.Schema.Exchange_2013.BaseMoveCopyItemType
Aspose.Email.Exchange.Schema.Exchange_2013.CopyItemType
Aspose.Email.Exchange.Schema.Exchange_2013.MoveItemType
Aspose.Email.Exchange.Schema.Exchange_2013.CompleteFindInGALSpeechRecognitionType
Aspose.Email.Exchange.Schema.Exchange_2013.ConvertIdType
Aspose.Email.Exchange.Schema.Exchange_2013.CreateAttachmentType
Aspose.Email.Exchange.Schema.Exchange_2013.CreateFolderPathType
Aspose.Email.Exchange.Schema.Exchange_2013.CreateFolderType
Aspose.Email.Exchange.Schema.Exchange_2013.CreateItemType
Aspose.Email.Exchange.Schema.Exchange_2013.CreateManagedFolderRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.CreateUMCallDataRecordType
Aspose.Email.Exchange.Schema.Exchange_2013.CreateUMPromptType
Aspose.Email.Exchange.Schema.Exchange_2013.CreateUserConfigurationType
Aspose.Email.Exchange.Schema.Exchange_2013.DeleteAttachmentType
Aspose.Email.Exchange.Schema.Exchange_2013.DeleteFolderType
Aspose.Email.Exchange.Schema.Exchange_2013.DeleteItemType
Aspose.Email.Exchange.Schema.Exchange_2013.DeleteUMPromptsType
Aspose.Email.Exchange.Schema.Exchange_2013.DeleteUserConfigurationType
Aspose.Email.Exchange.Schema.Exchange_2013.DisableAppType
Aspose.Email.Exchange.Schema.Exchange_2013.DisconnectPhoneCallType
Aspose.Email.Exchange.Schema.Exchange_2013.EmptyFolderType
Aspose.Email.Exchange.Schema.Exchange_2013.ExpandDLType
Aspose.Email.Exchange.Schema.Exchange_2013.ExportItemsType
Aspose.Email.Exchange.Schema.Exchange_2013.FindConversationType
Aspose.Email.Exchange.Schema.Exchange_2013.FindFolderType
Aspose.Email.Exchange.Schema.Exchange_2013.FindItemType
Aspose.Email.Exchange.Schema.Exchange_2013.FindMailboxStatisticsByKeywordsType
Aspose.Email.Exchange.Schema.Exchange_2013.FindMessageTrackingReportRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.FindPeopleType
Aspose.Email.Exchange.Schema.Exchange_2013.GetAppManifestsType
Aspose.Email.Exchange.Schema.Exchange_2013.GetAppMarketplaceUrlType
Aspose.Email.Exchange.Schema.Exchange_2013.GetAttachmentType
Aspose.Email.Exchange.Schema.Exchange_2013.GetClientAccessTokenType
Aspose.Email.Exchange.Schema.Exchange_2013.GetClientExtensionType
Aspose.Email.Exchange.Schema.Exchange_2013.GetClientIntentType
Aspose.Email.Exchange.Schema.Exchange_2013.GetConversationItemsType
Aspose.Email.Exchange.Schema.Exchange_2013.GetDiscoverySearchConfigurationType
Aspose.Email.Exchange.Schema.Exchange_2013.GetEventsType
Aspose.Email.Exchange.Schema.Exchange_2013.GetFolderType
Aspose.Email.Exchange.Schema.Exchange_2013.GetHoldOnMailboxesType
Aspose.Email.Exchange.Schema.Exchange_2013.GetImItemListType
Aspose.Email.Exchange.Schema.Exchange_2013.GetImItemsType
Aspose.Email.Exchange.Schema.Exchange_2013.GetInboxRulesRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.GetItemType
Aspose.Email.Exchange.Schema.Exchange_2013.GetMailTipsType
Aspose.Email.Exchange.Schema.Exchange_2013.GetMessageTrackingReportRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.GetNonIndexableItemDetailsType
Aspose.Email.Exchange.Schema.Exchange_2013.GetNonIndexableItemStatisticsType
Aspose.Email.Exchange.Schema.Exchange_2013.GetPasswordExpirationDateType
Aspose.Email.Exchange.Schema.Exchange_2013.GetPersonaType
Aspose.Email.Exchange.Schema.Exchange_2013.GetPhoneCallInformationType
Aspose.Email.Exchange.Schema.Exchange_2013.GetRemindersType
Aspose.Email.Exchange.Schema.Exchange_2013.GetRoomListsType
Aspose.Email.Exchange.Schema.Exchange_2013.GetRoomsType
Aspose.Email.Exchange.Schema.Exchange_2013.GetSearchableMailboxesType
Aspose.Email.Exchange.Schema.Exchange_2013.GetServerTimeZonesType
Aspose.Email.Exchange.Schema.Exchange_2013.GetServiceConfigurationType
Aspose.Email.Exchange.Schema.Exchange_2013.GetSharingFolderType
Aspose.Email.Exchange.Schema.Exchange_2013.GetSharingMetadataType
Aspose.Email.Exchange.Schema.Exchange_2013.GetStreamingEventsType
Aspose.Email.Exchange.Schema.Exchange_2013.GetUMCallDataRecordsType
Aspose.Email.Exchange.Schema.Exchange_2013.GetUMCallSummaryType
Aspose.Email.Exchange.Schema.Exchange_2013.GetUMPinType
Aspose.Email.Exchange.Schema.Exchange_2013.GetUMPromptNamesType
Aspose.Email.Exchange.Schema.Exchange_2013.GetUMPromptType
Aspose.Email.Exchange.Schema.Exchange_2013.GetUMSubscriberCallAnsweringDataType
Aspose.Email.Exchange.Schema.Exchange_2013.GetUserAvailabilityRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.GetUserConfigurationType
Aspose.Email.Exchange.Schema.Exchange_2013.GetUserOofSettingsRequest
Aspose.Email.Exchange.Schema.Exchange_2013.GetUserPhotoType
Aspose.Email.Exchange.Schema.Exchange_2013.GetUserRetentionPolicyTagsType
Aspose.Email.Exchange.Schema.Exchange_2013.InitUMMailboxType
Aspose.Email.Exchange.Schema.Exchange_2013.InstallAppType
Aspose.Email.Exchange.Schema.Exchange_2013.MarkAllItemsAsReadType
Aspose.Email.Exchange.Schema.Exchange_2013.MarkAsJunkType
Aspose.Email.Exchange.Schema.Exchange_2013.PerformReminderActionType
Aspose.Email.Exchange.Schema.Exchange_2013.PlayOnPhoneType
Aspose.Email.Exchange.Schema.Exchange_2013.RefreshSharingFolderType
Aspose.Email.Exchange.Schema.Exchange_2013.RemoveContactFromImListType
Aspose.Email.Exchange.Schema.Exchange_2013.RemoveDistributionGroupFromImListType
Aspose.Email.Exchange.Schema.Exchange_2013.RemoveImContactFromGroupType
Aspose.Email.Exchange.Schema.Exchange_2013.RemoveImGroupType
Aspose.Email.Exchange.Schema.Exchange_2013.ResetUMMailboxType
Aspose.Email.Exchange.Schema.Exchange_2013.ResolveNamesType
Aspose.Email.Exchange.Schema.Exchange_2013.SaveUMPinType
Aspose.Email.Exchange.Schema.Exchange_2013.SearchMailboxesType
Aspose.Email.Exchange.Schema.Exchange_2013.SendItemType
Aspose.Email.Exchange.Schema.Exchange_2013.SetClientExtensionType
Aspose.Email.Exchange.Schema.Exchange_2013.SetHoldOnMailboxesType
Aspose.Email.Exchange.Schema.Exchange_2013.SetImGroupType
Aspose.Email.Exchange.Schema.Exchange_2013.SetImListMigrationCompletedType
Aspose.Email.Exchange.Schema.Exchange_2013.SetTeamMailboxRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.SetUserOofSettingsRequest
Aspose.Email.Exchange.Schema.Exchange_2013.StartFindInGALSpeechRecognitionType
Aspose.Email.Exchange.Schema.Exchange_2013.SubscribeType
Aspose.Email.Exchange.Schema.Exchange_2013.SyncFolderHierarchyType
Aspose.Email.Exchange.Schema.Exchange_2013.SyncFolderItemsType
Aspose.Email.Exchange.Schema.Exchange_2013.UninstallAppType
Aspose.Email.Exchange.Schema.Exchange_2013.UnpinTeamMailboxRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.UnsubscribeType
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateFolderType
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateInboxRulesRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateItemInRecoverableItemsType
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateItemType
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateUserConfigurationType
Aspose.Email.Exchange.Schema.Exchange_2013.UploadItemsType
Aspose.Email.Exchange.Schema.Exchange_2013.ValidateUMPinType
Aspose.Email.Exchange.Schema.Exchange_2013.BaseResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.ApplyConversationActionResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.ArchiveItemResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.ConvertIdResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.CopyFolderResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.CopyItemResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.CreateAttachmentResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.CreateFolderPathResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.CreateFolderResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.CreateItemResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.CreateManagedFolderResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.CreateUserConfigurationResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.DeleteAttachmentResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.DeleteFolderResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.DeleteItemResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.DeleteUserConfigurationResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.EmptyFolderResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.ExpandDLResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.ExportItemsResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.FindFolderResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.FindItemResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.FindMailboxStatisticsByKeywordsResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.GetAttachmentResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.GetClientAccessTokenResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.GetConversationItemsResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.GetEventsResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.GetFolderResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.GetItemResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.GetServerTimeZonesResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.GetStreamingEventsResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.GetUserConfigurationResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.GetUserPhotoResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.MarkAllItemsAsReadResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.MarkAsJunkResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.MoveFolderResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.MoveItemResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.ResolveNamesResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.SearchMailboxesResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.SendItemResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.SendNotificationResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.SetClientExtensionResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.SubscribeResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.SyncFolderHierarchyResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.SyncFolderItemsResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.UnsubscribeResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateFolderResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateItemInRecoverableItemsResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateItemResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateUserConfigurationResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.UploadItemsResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.BaseSubscriptionRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.PullSubscriptionRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.PushSubscriptionRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.BodyContentAttributedValueType
Aspose.Email.Exchange.Schema.Exchange_2013.BodyContentType
Aspose.Email.Exchange.Schema.Exchange_2013.BodyType
Aspose.Email.Exchange.Schema.Exchange_2013.CalendarEvent
Aspose.Email.Exchange.Schema.Exchange_2013.CalendarEventDetails
Aspose.Email.Exchange.Schema.Exchange_2013.CalendarPermissionSetType
Aspose.Email.Exchange.Schema.Exchange_2013.CDRDataType
Aspose.Email.Exchange.Schema.Exchange_2013.ChangeDescriptionType
Aspose.Email.Exchange.Schema.Exchange_2013.FolderChangeDescriptionType
Aspose.Email.Exchange.Schema.Exchange_2013.AppendToFolderFieldType
Aspose.Email.Exchange.Schema.Exchange_2013.DeleteFolderFieldType
Aspose.Email.Exchange.Schema.Exchange_2013.SetFolderFieldType
Aspose.Email.Exchange.Schema.Exchange_2013.ItemChangeDescriptionType
Aspose.Email.Exchange.Schema.Exchange_2013.AppendToItemFieldType
Aspose.Email.Exchange.Schema.Exchange_2013.DeleteItemFieldType
Aspose.Email.Exchange.Schema.Exchange_2013.SetItemFieldType
Aspose.Email.Exchange.Schema.Exchange_2013.ChangeHighlightsType
Aspose.Email.Exchange.Schema.Exchange_2013.ClientAccessTokenRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.ClientAccessTokenType
Aspose.Email.Exchange.Schema.Exchange_2013.ClientExtensionType
Aspose.Email.Exchange.Schema.Exchange_2013.ClientIntentType
Aspose.Email.Exchange.Schema.Exchange_2013.CompleteNameType
Aspose.Email.Exchange.Schema.Exchange_2013.ConfigurationRequestDetailsType
Aspose.Email.Exchange.Schema.Exchange_2013.ConflictResultsType
Aspose.Email.Exchange.Schema.Exchange_2013.ConnectingSIDType
Aspose.Email.Exchange.Schema.Exchange_2013.ConstantValueType
Aspose.Email.Exchange.Schema.Exchange_2013.ConversationActionType
Aspose.Email.Exchange.Schema.Exchange_2013.ConversationNodeType
Aspose.Email.Exchange.Schema.Exchange_2013.ConversationRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.ConversationResponseShapeType
Aspose.Email.Exchange.Schema.Exchange_2013.ConversationResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.ConversationType
Aspose.Email.Exchange.Schema.Exchange_2013.DelegatePermissionsType
Aspose.Email.Exchange.Schema.Exchange_2013.DelegateUserType
Aspose.Email.Exchange.Schema.Exchange_2013.DeletedOccurrenceInfoType
Aspose.Email.Exchange.Schema.Exchange_2013.DirectoryEntryType
Aspose.Email.Exchange.Schema.Exchange_2013.RoomType
Aspose.Email.Exchange.Schema.Exchange_2013.DiscoverySearchConfigurationType
Aspose.Email.Exchange.Schema.Exchange_2013.Duration
Aspose.Email.Exchange.Schema.Exchange_2013.EffectiveRightsType
Aspose.Email.Exchange.Schema.Exchange_2013.EmailAddress
Aspose.Email.Exchange.Schema.Exchange_2013.EmailAddressAttributedValueType
Aspose.Email.Exchange.Schema.Exchange_2013.EmailAddressDictionaryEntryType
Aspose.Email.Exchange.Schema.Exchange_2013.EmailUserType
Aspose.Email.Exchange.Schema.Exchange_2013.EncryptedSharedFolderDataType
Aspose.Email.Exchange.Schema.Exchange_2013.EnhancedLocationType
Aspose.Email.Exchange.Schema.Exchange_2013.EntityExtractionResultType
Aspose.Email.Exchange.Schema.Exchange_2013.EntityType
Aspose.Email.Exchange.Schema.Exchange_2013.AddressEntityType
Aspose.Email.Exchange.Schema.Exchange_2013.ContactType
Aspose.Email.Exchange.Schema.Exchange_2013.EmailAddressEntityType
Aspose.Email.Exchange.Schema.Exchange_2013.MeetingSuggestionType
Aspose.Email.Exchange.Schema.Exchange_2013.PhoneEntityType
Aspose.Email.Exchange.Schema.Exchange_2013.TaskSuggestionType
Aspose.Email.Exchange.Schema.Exchange_2013.UrlEntityType
Aspose.Email.Exchange.Schema.Exchange_2013.ExcludesValueType
Aspose.Email.Exchange.Schema.Exchange_2013.ExtendedPropertyAttributedValueType
Aspose.Email.Exchange.Schema.Exchange_2013.ExtendedPropertyType
Aspose.Email.Exchange.Schema.Exchange_2013.FailedSearchMailboxType
Aspose.Email.Exchange.Schema.Exchange_2013.FieldOrderType
Aspose.Email.Exchange.Schema.Exchange_2013.FieldURIOrConstantType
Aspose.Email.Exchange.Schema.Exchange_2013.FindFolderParentType
Aspose.Email.Exchange.Schema.Exchange_2013.FindItemParentType
Aspose.Email.Exchange.Schema.Exchange_2013.FindMessageTrackingSearchResultType
Aspose.Email.Exchange.Schema.Exchange_2013.FlagType
Aspose.Email.Exchange.Schema.Exchange_2013.FolderChangeType
Aspose.Email.Exchange.Schema.Exchange_2013.FolderResponseShapeType
Aspose.Email.Exchange.Schema.Exchange_2013.FreeBusyResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.FreeBusyView
Aspose.Email.Exchange.Schema.Exchange_2013.FreeBusyViewOptionsType
Aspose.Email.Exchange.Schema.Exchange_2013.GetClientExtensionUserParametersType
Aspose.Email.Exchange.Schema.Exchange_2013.GetUserAvailabilityResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.GetUserOofSettingsResponse
Aspose.Email.Exchange.Schema.Exchange_2013.GroupedItemsType
Aspose.Email.Exchange.Schema.Exchange_2013.HighlightTermType
Aspose.Email.Exchange.Schema.Exchange_2013.ImAddressDictionaryEntryType
Aspose.Email.Exchange.Schema.Exchange_2013.ImGroupType
Aspose.Email.Exchange.Schema.Exchange_2013.ImItemListType
Aspose.Email.Exchange.Schema.Exchange_2013.InternetHeaderType
Aspose.Email.Exchange.Schema.Exchange_2013.InvalidRecipientType
Aspose.Email.Exchange.Schema.Exchange_2013.ItemChangeType
Aspose.Email.Exchange.Schema.Exchange_2013.ItemResponseShapeType
Aspose.Email.Exchange.Schema.Exchange_2013.ItemType
Aspose.Email.Exchange.Schema.Exchange_2013.CalendarItemType
Aspose.Email.Exchange.Schema.Exchange_2013.ContactItemType
Aspose.Email.Exchange.Schema.Exchange_2013.DistributionListType
Aspose.Email.Exchange.Schema.Exchange_2013.MessageType
Aspose.Email.Exchange.Schema.Exchange_2013.MeetingMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.MeetingCancellationMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.MeetingRequestMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.MeetingResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseObjectCoreType
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseObjectType
Aspose.Email.Exchange.Schema.Exchange_2013.PostReplyItemBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.PostReplyItemType
Aspose.Email.Exchange.Schema.Exchange_2013.ReferenceItemResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.AcceptSharingInvitationType
Aspose.Email.Exchange.Schema.Exchange_2013.SuppressReadReceiptType
Aspose.Email.Exchange.Schema.Exchange_2013.RemoveItemType
Aspose.Email.Exchange.Schema.Exchange_2013.SmartResponseBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.SmartResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.CancelCalendarItemType
Aspose.Email.Exchange.Schema.Exchange_2013.ForwardItemType
Aspose.Email.Exchange.Schema.Exchange_2013.ReplyAllToItemType
Aspose.Email.Exchange.Schema.Exchange_2013.ReplyToItemType
Aspose.Email.Exchange.Schema.Exchange_2013.WellKnownResponseObjectType
Aspose.Email.Exchange.Schema.Exchange_2013.AcceptItemType
Aspose.Email.Exchange.Schema.Exchange_2013.DeclineItemType
Aspose.Email.Exchange.Schema.Exchange_2013.TentativelyAcceptItemType
Aspose.Email.Exchange.Schema.Exchange_2013.PostItemType
Aspose.Email.Exchange.Schema.Exchange_2013.TaskType
Aspose.Email.Exchange.Schema.Exchange_2013.KeywordStatisticsSearchResultType
Aspose.Email.Exchange.Schema.Exchange_2013.MailboxData
Aspose.Email.Exchange.Schema.Exchange_2013.MailboxHoldResultType
Aspose.Email.Exchange.Schema.Exchange_2013.MailboxHoldStatusType
Aspose.Email.Exchange.Schema.Exchange_2013.MailboxQueryType
Aspose.Email.Exchange.Schema.Exchange_2013.MailboxSearchScopeType
Aspose.Email.Exchange.Schema.Exchange_2013.MailboxStatisticsItemType
Aspose.Email.Exchange.Schema.Exchange_2013.MailboxStatisticsSearchResultType
Aspose.Email.Exchange.Schema.Exchange_2013.MailTips
Aspose.Email.Exchange.Schema.Exchange_2013.ManagedFolderInformationType
Aspose.Email.Exchange.Schema.Exchange_2013.MemberType
Aspose.Email.Exchange.Schema.Exchange_2013.MessageTrackingReportType
Aspose.Email.Exchange.Schema.Exchange_2013.MimeContentType
Aspose.Email.Exchange.Schema.Exchange_2013.NonEmptyArrayOfAllItemsType
Aspose.Email.Exchange.Schema.Exchange_2013.NonEmptyArrayOfExtendedPropertyType
Aspose.Email.Exchange.Schema.Exchange_2013.NonEmptyArrayOfPropertyValuesType
Aspose.Email.Exchange.Schema.Exchange_2013.NonEmptyStateDefinitionType
Aspose.Email.Exchange.Schema.Exchange_2013.NonIndexableItemDetailResultType
Aspose.Email.Exchange.Schema.Exchange_2013.NonIndexableItemDetailType
Aspose.Email.Exchange.Schema.Exchange_2013.NonIndexableItemStatisticType
Aspose.Email.Exchange.Schema.Exchange_2013.NotificationType
Aspose.Email.Exchange.Schema.Exchange_2013.OccurrenceInfoType
Aspose.Email.Exchange.Schema.Exchange_2013.OccurrencesRangeType
Aspose.Email.Exchange.Schema.Exchange_2013.OnlineMeetingSettingsType
Aspose.Email.Exchange.Schema.Exchange_2013.OutOfOfficeMailTip
Aspose.Email.Exchange.Schema.Exchange_2013.PeriodType
Aspose.Email.Exchange.Schema.Exchange_2013.PermissionSetType
Aspose.Email.Exchange.Schema.Exchange_2013.PersonaAttributionType
Aspose.Email.Exchange.Schema.Exchange_2013.PersonaPhoneNumberType
Aspose.Email.Exchange.Schema.Exchange_2013.PersonaPostalAddressType
Aspose.Email.Exchange.Schema.Exchange_2013.PersonaResponseShapeType
Aspose.Email.Exchange.Schema.Exchange_2013.PersonaType
Aspose.Email.Exchange.Schema.Exchange_2013.PhoneCallIdType
Aspose.Email.Exchange.Schema.Exchange_2013.PhoneCallInformationType
Aspose.Email.Exchange.Schema.Exchange_2013.PhoneNumberAttributedValueType
Aspose.Email.Exchange.Schema.Exchange_2013.PhoneNumberDictionaryEntryType
Aspose.Email.Exchange.Schema.Exchange_2013.PhoneType
Aspose.Email.Exchange.Schema.Exchange_2013.PhysicalAddressDictionaryEntryType
Aspose.Email.Exchange.Schema.Exchange_2013.PinInfoType
Aspose.Email.Exchange.Schema.Exchange_2013.PolicyNudgeRulesServiceConfiguration
Aspose.Email.Exchange.Schema.Exchange_2013.PostalAddressAttributedValueType
Aspose.Email.Exchange.Schema.Exchange_2013.PreviewItemMailboxType
Aspose.Email.Exchange.Schema.Exchange_2013.PreviewItemResponseShapeType
Aspose.Email.Exchange.Schema.Exchange_2013.ProtectionRuleActionType
Aspose.Email.Exchange.Schema.Exchange_2013.ProtectionRuleAndType
Aspose.Email.Exchange.Schema.Exchange_2013.ProtectionRuleArgumentType
Aspose.Email.Exchange.Schema.Exchange_2013.ProtectionRuleConditionType
Aspose.Email.Exchange.Schema.Exchange_2013.ProtectionRuleRecipientIsType
Aspose.Email.Exchange.Schema.Exchange_2013.ProtectionRuleSenderDepartmentsType
Aspose.Email.Exchange.Schema.Exchange_2013.ProtectionRuleType
Aspose.Email.Exchange.Schema.Exchange_2013.QueryStringType
Aspose.Email.Exchange.Schema.Exchange_2013.RecipientTrackingEventType
Aspose.Email.Exchange.Schema.Exchange_2013.RecognitionIdType
Aspose.Email.Exchange.Schema.Exchange_2013.RecognitionResultType
Aspose.Email.Exchange.Schema.Exchange_2013.RecurrencePatternBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.AbsoluteYearlyRecurrencePatternType
Aspose.Email.Exchange.Schema.Exchange_2013.IntervalRecurrencePatternBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.AbsoluteMonthlyRecurrencePatternType
Aspose.Email.Exchange.Schema.Exchange_2013.DailyRecurrencePatternType
Aspose.Email.Exchange.Schema.Exchange_2013.RegeneratingPatternBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.DailyRegeneratingPatternType
Aspose.Email.Exchange.Schema.Exchange_2013.MonthlyRegeneratingPatternType
Aspose.Email.Exchange.Schema.Exchange_2013.WeeklyRegeneratingPatternType
Aspose.Email.Exchange.Schema.Exchange_2013.YearlyRegeneratingPatternType
Aspose.Email.Exchange.Schema.Exchange_2013.RelativeMonthlyRecurrencePatternType
Aspose.Email.Exchange.Schema.Exchange_2013.WeeklyRecurrencePatternType
Aspose.Email.Exchange.Schema.Exchange_2013.RelativeYearlyRecurrencePatternType
Aspose.Email.Exchange.Schema.Exchange_2013.RecurrenceRangeBaseType
Aspose.Email.Exchange.Schema.Exchange_2013.EndDateRecurrenceRangeType
Aspose.Email.Exchange.Schema.Exchange_2013.NoEndRecurrenceRangeType
Aspose.Email.Exchange.Schema.Exchange_2013.NumberedRecurrenceRangeType
Aspose.Email.Exchange.Schema.Exchange_2013.RecurrenceType
Aspose.Email.Exchange.Schema.Exchange_2013.ReminderItemActionType
Aspose.Email.Exchange.Schema.Exchange_2013.ReminderType
Aspose.Email.Exchange.Schema.Exchange_2013.ReplyBody
Aspose.Email.Exchange.Schema.Exchange_2013.ResolutionType
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.AddDistributionGroupToImListResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.AddImContactToGroupResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.AddImGroupResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.AddNewImContactToGroupResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.AddNewTelUriContactToGroupResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.AttachmentInfoResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.BaseDelegateResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.AddDelegateResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetDelegateResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.RemoveDelegateResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateDelegateResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.ClientExtensionResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.CompleteFindInGALSpeechRecognitionResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.ConvertIdResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.CreateUMCallDataRecordResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.CreateUMPromptResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.DelegateUserResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.DeleteAttachmentResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.DeleteUMPromptsResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.DisableAppResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.DisconnectPhoneCallResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.ExpandDLResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.ExportItemsResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.FindConversationResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.FindFolderResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.FindItemResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.FindMailboxStatisticsByKeywordsResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.FindMessageTrackingReportResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.FindPeopleResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.FolderInfoResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetAppManifestsResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.GetAppMarketplaceUrlResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetClientAccessTokenResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetClientIntentResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetConversationItemsResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetDiscoverySearchConfigurationResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetEventsResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetHoldOnMailboxesResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetImItemListResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetImItemsResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetInboxRulesResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.GetMailTipsResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetMessageTrackingReportResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetNonIndexableItemDetailsResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetNonIndexableItemStatisticsResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetPasswordExpirationDateResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetPersonaResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetPhoneCallInformationResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetRemindersResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetRoomListsResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetRoomsResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetSearchableMailboxesResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetServerTimeZonesResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetServiceConfigurationResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetSharingFolderResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetSharingMetadataResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetStreamingEventsResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetUMCallDataRecordsResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetUMCallSummaryResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetUMPinResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetUMPromptNamesResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetUMPromptResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetUMSubscriberCallAnsweringDataResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetUserConfigurationResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetUserPhotoResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.GetUserRetentionPolicyTagsResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.InitUMMailboxResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.InstallAppResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.ItemInfoResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateItemInRecoverableItemsResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateItemResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.MailTipsResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.MarkAsJunkResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.PerformReminderActionResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.PlayOnPhoneResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.RefreshSharingFolderResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.RemoveContactFromImListResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.RemoveDistributionGroupFromImListResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.RemoveImContactFromGroupResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.RemoveImGroupResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.ResetUMMailboxResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.ResolveNamesResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.SaveUMPinResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.SearchMailboxesResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.SendNotificationResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.ServiceConfigurationResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.SetHoldOnMailboxesResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.SetImGroupResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.SetImListMigrationCompletedResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.SetTeamMailboxResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.StartFindInGALSpeechRecognitionResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.SubscribeResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.SyncFolderHierarchyResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.SyncFolderItemsResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.UninstallAppResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.UnpinTeamMailboxResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateInboxRulesResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.UploadItemsResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.ValidateUMPinResponseMessageType
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseMessageTypeMessageXml
Aspose.Email.Exchange.Schema.Exchange_2013.RestrictionType
Aspose.Email.Exchange.Schema.Exchange_2013.RetentionPolicyTagType
Aspose.Email.Exchange.Schema.Exchange_2013.RetentionTagType
Aspose.Email.Exchange.Schema.Exchange_2013.RightsManagementLicenseDataType
Aspose.Email.Exchange.Schema.Exchange_2013.RuleActionsType
Aspose.Email.Exchange.Schema.Exchange_2013.RuleOperationErrorType
Aspose.Email.Exchange.Schema.Exchange_2013.RuleOperationType
Aspose.Email.Exchange.Schema.Exchange_2013.CreateRuleOperationType
Aspose.Email.Exchange.Schema.Exchange_2013.DeleteRuleOperationType
Aspose.Email.Exchange.Schema.Exchange_2013.SetRuleOperationType
Aspose.Email.Exchange.Schema.Exchange_2013.RulePredicateDateRangeType
Aspose.Email.Exchange.Schema.Exchange_2013.RulePredicateSizeRangeType
Aspose.Email.Exchange.Schema.Exchange_2013.RulePredicatesType
Aspose.Email.Exchange.Schema.Exchange_2013.RuleType
Aspose.Email.Exchange.Schema.Exchange_2013.RuleValidationErrorType
Aspose.Email.Exchange.Schema.Exchange_2013.SearchableMailboxType
Aspose.Email.Exchange.Schema.Exchange_2013.SearchExpressionType
Aspose.Email.Exchange.Schema.Exchange_2013.ContainsExpressionType
Aspose.Email.Exchange.Schema.Exchange_2013.ExcludesType
Aspose.Email.Exchange.Schema.Exchange_2013.ExistsType
Aspose.Email.Exchange.Schema.Exchange_2013.MultipleOperandBooleanExpressionType
Aspose.Email.Exchange.Schema.Exchange_2013.AndType
Aspose.Email.Exchange.Schema.Exchange_2013.OrType
Aspose.Email.Exchange.Schema.Exchange_2013.NotType
Aspose.Email.Exchange.Schema.Exchange_2013.TwoOperandExpressionType
Aspose.Email.Exchange.Schema.Exchange_2013.IsEqualToType
Aspose.Email.Exchange.Schema.Exchange_2013.IsGreaterThanOrEqualToType
Aspose.Email.Exchange.Schema.Exchange_2013.IsGreaterThanType
Aspose.Email.Exchange.Schema.Exchange_2013.IsLessThanOrEqualToType
Aspose.Email.Exchange.Schema.Exchange_2013.IsLessThanType
Aspose.Email.Exchange.Schema.Exchange_2013.IsNotEqualToType
Aspose.Email.Exchange.Schema.Exchange_2013.SearchMailboxesResultType
Aspose.Email.Exchange.Schema.Exchange_2013.SearchParametersType
Aspose.Email.Exchange.Schema.Exchange_2013.SearchPreviewItemType
Aspose.Email.Exchange.Schema.Exchange_2013.SearchRefinerItemType
Aspose.Email.Exchange.Schema.Exchange_2013.SerializableTimeZone
Aspose.Email.Exchange.Schema.Exchange_2013.SerializableTimeZoneTime
Aspose.Email.Exchange.Schema.Exchange_2013.ServiceConfiguration
Aspose.Email.Exchange.Schema.Exchange_2013.MailTipsServiceConfiguration
Aspose.Email.Exchange.Schema.Exchange_2013.ProtectionRulesServiceConfiguration
Aspose.Email.Exchange.Schema.Exchange_2013.UnifiedMessageServiceConfiguration
Aspose.Email.Exchange.Schema.Exchange_2013.SetClientExtensionActionType
Aspose.Email.Exchange.Schema.Exchange_2013.SetUserOofSettingsResponse
Aspose.Email.Exchange.Schema.Exchange_2013.SingleRecipientType
Aspose.Email.Exchange.Schema.Exchange_2013.SmtpDomain
Aspose.Email.Exchange.Schema.Exchange_2013.StreamingSubscriptionRequestType
Aspose.Email.Exchange.Schema.Exchange_2013.StringArrayAttributedValueType
Aspose.Email.Exchange.Schema.Exchange_2013.StringAttributedValueType
Aspose.Email.Exchange.Schema.Exchange_2013.Suggestion
Aspose.Email.Exchange.Schema.Exchange_2013.SuggestionDayResult
Aspose.Email.Exchange.Schema.Exchange_2013.SuggestionsResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.SuggestionsViewOptionsType
Aspose.Email.Exchange.Schema.Exchange_2013.SyncFolderHierarchyChangesType
Aspose.Email.Exchange.Schema.Exchange_2013.SyncFolderHierarchyCreateOrUpdateType
Aspose.Email.Exchange.Schema.Exchange_2013.SyncFolderHierarchyDeleteType
Aspose.Email.Exchange.Schema.Exchange_2013.SyncFolderItemsChangesType
Aspose.Email.Exchange.Schema.Exchange_2013.SyncFolderItemsCreateOrUpdateType
Aspose.Email.Exchange.Schema.Exchange_2013.SyncFolderItemsDeleteType
Aspose.Email.Exchange.Schema.Exchange_2013.SyncFolderItemsReadFlagType
Aspose.Email.Exchange.Schema.Exchange_2013.TargetFolderIdType
Aspose.Email.Exchange.Schema.Exchange_2013.UserConfigurationNameType
Aspose.Email.Exchange.Schema.Exchange_2013.TaskRecurrenceType
Aspose.Email.Exchange.Schema.Exchange_2013.TimeChangeType
Aspose.Email.Exchange.Schema.Exchange_2013.TimeZoneDefinitionType
Aspose.Email.Exchange.Schema.Exchange_2013.TimeZoneType
Aspose.Email.Exchange.Schema.Exchange_2013.TrackingPropertyType
Aspose.Email.Exchange.Schema.Exchange_2013.TransitionTargetType
Aspose.Email.Exchange.Schema.Exchange_2013.TransitionType
Aspose.Email.Exchange.Schema.Exchange_2013.AbsoluteDateTransitionType
Aspose.Email.Exchange.Schema.Exchange_2013.RecurringTimeTransitionType
Aspose.Email.Exchange.Schema.Exchange_2013.RecurringDateTransitionType
Aspose.Email.Exchange.Schema.Exchange_2013.RecurringDayTransitionType
Aspose.Email.Exchange.Schema.Exchange_2013.UMReportAudioMetricsAverageCountersType
Aspose.Email.Exchange.Schema.Exchange_2013.UMReportRawCountersType
Aspose.Email.Exchange.Schema.Exchange_2013.UploadItemType
Aspose.Email.Exchange.Schema.Exchange_2013.UserConfigurationDictionaryEntryType
Aspose.Email.Exchange.Schema.Exchange_2013.UserConfigurationDictionaryObjectType
Aspose.Email.Exchange.Schema.Exchange_2013.UserConfigurationType
Aspose.Email.Exchange.Schema.Exchange_2013.UserIdType
Aspose.Email.Exchange.Schema.Exchange_2013.UserMailboxType
Aspose.Email.Exchange.Schema.Exchange_2013.UserOofSettings
Aspose.Email.Exchange.Schema.Exchange_2013.WorkingHours
Aspose.Email.Exchange.Schema.Exchange_2013.WorkingPeriod
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
Aspose.Email.Exchange.Schema.Exchange_2013.AddDelegateCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.AddDistributionGroupToImListCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.AddImContactToGroupCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.AddImGroupCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.AddNewImContactToGroupCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.AddNewTelUriContactToGroupCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.ApplyConversationActionCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.ArchiveItemCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.ConvertIdCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.CopyFolderCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.CopyItemCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.CreateAttachmentCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.CreateFolderCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.CreateFolderPathCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.CreateItemCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.CreateManagedFolderCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.CreateUserConfigurationCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.DeleteAttachmentCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.DeleteFolderCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.DeleteItemCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.DeleteUserConfigurationCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.DisableAppCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.DisconnectPhoneCallCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.EmptyFolderCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.ExpandDLCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.ExportItemsCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.FindConversationCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.FindFolderCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.FindItemCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.FindMessageTrackingReportCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.FindPeopleCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.GetAppManifestsCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.GetAppMarketplaceUrlCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.GetAttachmentCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.GetClientAccessTokenCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.GetConversationItemsCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.GetDelegateCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.GetDiscoverySearchConfigurationCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.GetEventsCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.GetFolderCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.GetHoldOnMailboxesCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.GetImItemListCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.GetImItemsCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.GetInboxRulesCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.GetItemCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.GetMailTipsCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.GetMessageTrackingReportCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.GetNonIndexableItemDetailsCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.GetNonIndexableItemStatisticsCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.GetPasswordExpirationDateCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.GetPersonaCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.GetPhoneCallInformationCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.GetRoomListsCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.GetRoomsCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.GetSearchableMailboxesCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.GetServerTimeZonesCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.GetServiceConfigurationCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.GetSharingFolderCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.GetSharingMetadataCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.GetStreamingEventsCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.GetUserAvailabilityCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.GetUserConfigurationCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.GetUserOofSettingsCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.GetUserPhotoCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.GetUserRetentionPolicyTagsCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.InstallAppCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.MarkAllItemsAsReadCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.MarkAsJunkCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.MoveFolderCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.MoveItemCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.PlayOnPhoneCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.RefreshSharingFolderCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.RemoveContactFromImListCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.RemoveDelegateCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.RemoveDistributionGroupFromImListCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.RemoveImContactFromGroupCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.RemoveImGroupCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.ResolveNamesCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.SearchMailboxesCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.SendItemCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.SetHoldOnMailboxesCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.SetImGroupCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.SetImListMigrationCompletedCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.SetTeamMailboxCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.SetUserOofSettingsCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.SubscribeCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.SyncFolderHierarchyCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.SyncFolderItemsCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.UninstallAppCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.UnpinTeamMailboxCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.UnsubscribeCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateDelegateCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateFolderCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateInboxRulesCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateItemCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateItemInRecoverableItemsCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateUserConfigurationCompletedEventHandler
Aspose.Email.Exchange.Schema.Exchange_2013.UploadItemsCompletedEventHandler
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.AddDelegateCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.AddDistributionGroupToImListCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.AddImContactToGroupCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.AddImGroupCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.AddNewImContactToGroupCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.AddNewTelUriContactToGroupCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.ApplyConversationActionCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.ArchiveItemCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.ConvertIdCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.CopyFolderCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.CopyItemCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.CreateAttachmentCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.CreateFolderCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.CreateFolderPathCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.CreateItemCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.CreateManagedFolderCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.CreateUserConfigurationCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.DeleteAttachmentCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.DeleteFolderCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.DeleteItemCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.DeleteUserConfigurationCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.DisableAppCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.DisconnectPhoneCallCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.EmptyFolderCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.ExpandDLCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.ExportItemsCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.FindConversationCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.FindFolderCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.FindItemCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.FindMessageTrackingReportCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.FindPeopleCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetAppManifestsCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetAppMarketplaceUrlCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetAttachmentCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetClientAccessTokenCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetConversationItemsCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetDelegateCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetDiscoverySearchConfigurationCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetEventsCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetFolderCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetHoldOnMailboxesCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetImItemListCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetImItemsCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetInboxRulesCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetItemCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetMailTipsCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetMessageTrackingReportCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetNonIndexableItemDetailsCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetNonIndexableItemStatisticsCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetPasswordExpirationDateCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetPersonaCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetPhoneCallInformationCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetRoomListsCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetRoomsCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetSearchableMailboxesCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetServerTimeZonesCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetServiceConfigurationCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetSharingFolderCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetSharingMetadataCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetStreamingEventsCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetUserAvailabilityCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetUserConfigurationCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetUserOofSettingsCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetUserPhotoCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.GetUserRetentionPolicyTagsCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.InstallAppCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.MarkAllItemsAsReadCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.MarkAsJunkCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.MoveFolderCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.MoveItemCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.PlayOnPhoneCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.RefreshSharingFolderCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.RemoveContactFromImListCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.RemoveDelegateCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.RemoveDistributionGroupFromImListCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.RemoveImContactFromGroupCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.RemoveImGroupCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.ResolveNamesCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.SearchMailboxesCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.SendItemCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.SetHoldOnMailboxesCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.SetImGroupCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.SetImListMigrationCompletedCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.SetTeamMailboxCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.SetUserOofSettingsCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.SubscribeCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.SyncFolderHierarchyCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.SyncFolderItemsCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.UninstallAppCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.UnpinTeamMailboxCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.UnsubscribeCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateDelegateCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateFolderCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateInboxRulesCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateItemCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateItemInRecoverableItemsCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.UpdateUserConfigurationCompletedEventArgs
Aspose.Email.Exchange.Schema.Exchange_2013.UploadItemsCompletedEventArgs
System.MarshalByRefObject
System.ComponentModel.Component ---- System.ComponentModel.IComponent, System.IDisposable
System.Web.Services.Protocols.WebClientProtocol
System.Web.Services.Protocols.HttpWebClientProtocol
System.Web.Services.Protocols.SoapHttpClientProtocol
Aspose.Email.Exchange.Schema.Exchange_2013.ExchangeServiceBinding
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Email.Exchange.Schema.Exchange_2013.AffectedTaskOccurrencesType
Aspose.Email.Exchange.Schema.Exchange_2013.AggregateType
Aspose.Email.Exchange.Schema.Exchange_2013.BodyTypeResponseType
Aspose.Email.Exchange.Schema.Exchange_2013.BodyTypeType
Aspose.Email.Exchange.Schema.Exchange_2013.CalendarItemCreateOrDeleteOperationType
Aspose.Email.Exchange.Schema.Exchange_2013.CalendarItemTypeType
Aspose.Email.Exchange.Schema.Exchange_2013.CalendarItemUpdateOperationType
Aspose.Email.Exchange.Schema.Exchange_2013.CalendarPermissionLevelType
Aspose.Email.Exchange.Schema.Exchange_2013.CalendarPermissionReadAccessType
Aspose.Email.Exchange.Schema.Exchange_2013.ClientAccessTokenTypeType
Aspose.Email.Exchange.Schema.Exchange_2013.ClientExtensionProvidedToType
Aspose.Email.Exchange.Schema.Exchange_2013.ClientExtensionScopeType
Aspose.Email.Exchange.Schema.Exchange_2013.ClientExtensionTypeType
Aspose.Email.Exchange.Schema.Exchange_2013.ClientIntentMeetingInquiryActionType
Aspose.Email.Exchange.Schema.Exchange_2013.ConflictResolutionType
Aspose.Email.Exchange.Schema.Exchange_2013.ConnectionFailureCauseType
Aspose.Email.Exchange.Schema.Exchange_2013.ConnectionStatusType
Aspose.Email.Exchange.Schema.Exchange_2013.ContactSourceType
Aspose.Email.Exchange.Schema.Exchange_2013.ContainmentComparisonType
Aspose.Email.Exchange.Schema.Exchange_2013.ContainmentModeType
Aspose.Email.Exchange.Schema.Exchange_2013.ConversationActionTypeType
Aspose.Email.Exchange.Schema.Exchange_2013.ConversationNodeSortOrder
Aspose.Email.Exchange.Schema.Exchange_2013.ConversationQueryTraversalType
Aspose.Email.Exchange.Schema.Exchange_2013.CreateActionType
Aspose.Email.Exchange.Schema.Exchange_2013.DayOfWeekIndexType
Aspose.Email.Exchange.Schema.Exchange_2013.DayOfWeekType
Aspose.Email.Exchange.Schema.Exchange_2013.DefaultShapeNamesType
Aspose.Email.Exchange.Schema.Exchange_2013.DelegateFolderPermissionLevelType
Aspose.Email.Exchange.Schema.Exchange_2013.DeliverMeetingRequestsType
Aspose.Email.Exchange.Schema.Exchange_2013.DictionaryURIType
Aspose.Email.Exchange.Schema.Exchange_2013.DisableReasonType
Aspose.Email.Exchange.Schema.Exchange_2013.DisposalType
Aspose.Email.Exchange.Schema.Exchange_2013.DistinguishedFolderIdNameType
Aspose.Email.Exchange.Schema.Exchange_2013.DistinguishedPropertySetType
Aspose.Email.Exchange.Schema.Exchange_2013.DistinguishedUserType
Aspose.Email.Exchange.Schema.Exchange_2013.ElcFolderType
Aspose.Email.Exchange.Schema.Exchange_2013.EmailAddressKeyType
Aspose.Email.Exchange.Schema.Exchange_2013.EmailPositionType
Aspose.Email.Exchange.Schema.Exchange_2013.ExceptionPropertyURIType
Aspose.Email.Exchange.Schema.Exchange_2013.ExchangeVersionType
Aspose.Email.Exchange.Schema.Exchange_2013.ExternalAudience
Aspose.Email.Exchange.Schema.Exchange_2013.FileAsMappingType
Aspose.Email.Exchange.Schema.Exchange_2013.FlaggedForActionType
Aspose.Email.Exchange.Schema.Exchange_2013.FlagStatusType
Aspose.Email.Exchange.Schema.Exchange_2013.FolderQueryTraversalType
Aspose.Email.Exchange.Schema.Exchange_2013.FreeBusyViewType
Aspose.Email.Exchange.Schema.Exchange_2013.GetRemindersTypeReminderType
Aspose.Email.Exchange.Schema.Exchange_2013.HoldActionType
Aspose.Email.Exchange.Schema.Exchange_2013.HoldStatusType
Aspose.Email.Exchange.Schema.Exchange_2013.IconIndexType
Aspose.Email.Exchange.Schema.Exchange_2013.IdFormatType
Aspose.Email.Exchange.Schema.Exchange_2013.ImAddressKeyType
Aspose.Email.Exchange.Schema.Exchange_2013.ImportanceChoicesType
Aspose.Email.Exchange.Schema.Exchange_2013.IndexBasePointType
Aspose.Email.Exchange.Schema.Exchange_2013.InvalidRecipientResponseCodeType
Aspose.Email.Exchange.Schema.Exchange_2013.ItemChoiceType
Aspose.Email.Exchange.Schema.Exchange_2013.ItemChoiceType1
Aspose.Email.Exchange.Schema.Exchange_2013.ItemIndexErrorType
Aspose.Email.Exchange.Schema.Exchange_2013.ItemQueryTraversalType
Aspose.Email.Exchange.Schema.Exchange_2013.ItemsChoiceType
Aspose.Email.Exchange.Schema.Exchange_2013.ItemsChoiceType1
Aspose.Email.Exchange.Schema.Exchange_2013.ItemsChoiceType2
Aspose.Email.Exchange.Schema.Exchange_2013.ItemsChoiceType3
Aspose.Email.Exchange.Schema.Exchange_2013.ItemsChoiceType4
Aspose.Email.Exchange.Schema.Exchange_2013.LegacyFreeBusyType
Aspose.Email.Exchange.Schema.Exchange_2013.LobbyBypassType
Aspose.Email.Exchange.Schema.Exchange_2013.LocationSourceType
Aspose.Email.Exchange.Schema.Exchange_2013.MailboxSearchLocationType
Aspose.Email.Exchange.Schema.Exchange_2013.MailboxTypeType
Aspose.Email.Exchange.Schema.Exchange_2013.MailTipTypes
Aspose.Email.Exchange.Schema.Exchange_2013.MapiPropertyTypeType
Aspose.Email.Exchange.Schema.Exchange_2013.MeetingAttendeeType
Aspose.Email.Exchange.Schema.Exchange_2013.MeetingRequestTypeType
Aspose.Email.Exchange.Schema.Exchange_2013.MemberStatusType
Aspose.Email.Exchange.Schema.Exchange_2013.MessageDispositionType
Aspose.Email.Exchange.Schema.Exchange_2013.MessageTrackingReportTemplateType
Aspose.Email.Exchange.Schema.Exchange_2013.MonthNamesType
Aspose.Email.Exchange.Schema.Exchange_2013.NotificationEventTypeType
Aspose.Email.Exchange.Schema.Exchange_2013.OnlineMeetingAccessLevelType
Aspose.Email.Exchange.Schema.Exchange_2013.OofState
Aspose.Email.Exchange.Schema.Exchange_2013.PermissionActionType
Aspose.Email.Exchange.Schema.Exchange_2013.PermissionLevelType
Aspose.Email.Exchange.Schema.Exchange_2013.PermissionReadAccessType
Aspose.Email.Exchange.Schema.Exchange_2013.PhoneCallStateType
Aspose.Email.Exchange.Schema.Exchange_2013.PhoneNumberKeyType
Aspose.Email.Exchange.Schema.Exchange_2013.PhysicalAddressIndexType
Aspose.Email.Exchange.Schema.Exchange_2013.PhysicalAddressKeyType
Aspose.Email.Exchange.Schema.Exchange_2013.PredictedMessageActionType
Aspose.Email.Exchange.Schema.Exchange_2013.PresentersType
Aspose.Email.Exchange.Schema.Exchange_2013.PreviewItemBaseShapeType
Aspose.Email.Exchange.Schema.Exchange_2013.ProtectionRuleActionKindType
Aspose.Email.Exchange.Schema.Exchange_2013.ReminderActionType
Aspose.Email.Exchange.Schema.Exchange_2013.ReminderGroupType
Aspose.Email.Exchange.Schema.Exchange_2013.ResolveNamesSearchScopeType
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseClassType
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseCodeType
Aspose.Email.Exchange.Schema.Exchange_2013.ResponseTypeType
Aspose.Email.Exchange.Schema.Exchange_2013.RetentionActionType
Aspose.Email.Exchange.Schema.Exchange_2013.RetentionType
Aspose.Email.Exchange.Schema.Exchange_2013.RuleFieldURIType
Aspose.Email.Exchange.Schema.Exchange_2013.RuleValidationErrorCodeType
Aspose.Email.Exchange.Schema.Exchange_2013.SearchFolderTraversalType
Aspose.Email.Exchange.Schema.Exchange_2013.SearchItemKindType
Aspose.Email.Exchange.Schema.Exchange_2013.SearchPageDirectionType
Aspose.Email.Exchange.Schema.Exchange_2013.SearchResultType
Aspose.Email.Exchange.Schema.Exchange_2013.SensitivityChoicesType
Aspose.Email.Exchange.Schema.Exchange_2013.ServiceConfigurationType
Aspose.Email.Exchange.Schema.Exchange_2013.SetClientExtensionActionIdType
Aspose.Email.Exchange.Schema.Exchange_2013.SharingDataType
Aspose.Email.Exchange.Schema.Exchange_2013.SortDirectionType
Aspose.Email.Exchange.Schema.Exchange_2013.StandardGroupByType
Aspose.Email.Exchange.Schema.Exchange_2013.SuggestionQuality
Aspose.Email.Exchange.Schema.Exchange_2013.SyncFolderItemsScopeType
Aspose.Email.Exchange.Schema.Exchange_2013.TaskDelegateStateType
Aspose.Email.Exchange.Schema.Exchange_2013.TaskStatusType
Aspose.Email.Exchange.Schema.Exchange_2013.TeamMailboxLifecycleStateType
Aspose.Email.Exchange.Schema.Exchange_2013.TransitionTargetKindType
Aspose.Email.Exchange.Schema.Exchange_2013.UMCDRFilterByType
Aspose.Email.Exchange.Schema.Exchange_2013.UMCDRGroupByType
Aspose.Email.Exchange.Schema.Exchange_2013.UMMailboxTranscriptionEnabledSetting
Aspose.Email.Exchange.Schema.Exchange_2013.UnindexedFieldURIType
Aspose.Email.Exchange.Schema.Exchange_2013.UserConfigurationDictionaryObjectTypesType
Aspose.Email.Exchange.Schema.Exchange_2013.UserConfigurationPropertyType
Aspose.Email.Exchange.Schema.Exchange_2013.UserPhotoSizeType
Aspose.Email.Exchange.Schema.Exchange_2013.ViewFilterType
System.Web.Services.Protocols.SoapHeader
Aspose.Email.Exchange.Schema.Exchange_2013.DateTimePrecisionType
Aspose.Email.Exchange.Schema.Exchange_2013.ExchangeImpersonationType
Aspose.Email.Exchange.Schema.Exchange_2013.MailboxCultureType
Aspose.Email.Exchange.Schema.Exchange_2013.ManagementRoleType
Aspose.Email.Exchange.Schema.Exchange_2013.RequestServerVersion
Aspose.Email.Exchange.Schema.Exchange_2013.ServerVersionInfo
Aspose.Email.Exchange.Schema.Exchange_2013.TimeZoneContextType

See Also

Aspose.Email.Exchange.Schema.Exchange_2013 Namespace


ItemType Hierarchy

System.Object
ItemType
CalendarItemType
ContactItemType
DistributionListType
MessageType
PostItemType
TaskType

See Also

ItemType Class | ItemType Members | Aspose.Email.Exchange.Schema Namespace


ResponseMessageType Hierarchy

System.Object
ResponseMessageType
AttachmentInfoResponseMessageType
BaseDelegateResponseMessageType
ConvertIdResponseMessageType
DelegateUserResponseMessageType
DeleteAttachmentResponseMessageType
DisconnectPhoneCallResponseMessageType
ExpandDLResponseMessageType
ExportItemsResponseMessageType
FindConversationResponseMessageType
FindFolderResponseMessageType
FindItemResponseMessageType
FindMailboxStatisticsByKeywordsResponseMessageType
FindMessageTrackingReportResponseMessageType
FolderInfoResponseMessageType
GetEventsResponseMessageType
GetInboxRulesResponseType
GetMailTipsResponseMessageType
GetMessageTrackingReportResponseMessageType
GetPhoneCallInformationResponseMessageType
GetRoomListsResponseMessageType
GetRoomsResponseMessageType
GetServerTimeZonesResponseMessageType
GetServiceConfigurationResponseMessageType
GetSharingFolderResponseMessageType
GetSharingMetadataResponseMessageType
GetStreamingEventsResponseMessageType
GetUserConfigurationResponseMessageType
ItemInfoResponseMessageType
MailTipsResponseMessageType
PlayOnPhoneResponseMessageType
RefreshSharingFolderResponseMessageType
ResolveNamesResponseMessageType
SendNotificationResponseMessageType
ServiceConfigurationResponseMessageType
SubscribeResponseMessageType
SyncFolderHierarchyResponseMessageType
SyncFolderItemsResponseMessageType
UpdateInboxRulesResponseType
UploadItemsResponseMessageType

See Also

ResponseMessageType Class | ResponseMessageType Members | Aspose.Email.Exchange.Schema Namespace


SearchExpressionType Hierarchy

System.Object
SearchExpressionType
ContainsExpressionType
ExcludesType
ExistsType
MultipleOperandBooleanExpressionType
NotType
TwoOperandExpressionType

See Also

SearchExpressionType Class | SearchExpressionType Members | Aspose.Email.Exchange.Schema Namespace


TwoOperandExpressionType Hierarchy

System.Object
SearchExpressionType
TwoOperandExpressionType
IsEqualToType
IsGreaterThanOrEqualToType
IsGreaterThanType
IsLessThanOrEqualToType
IsLessThanType
IsNotEqualToType

See Also

TwoOperandExpressionType Class | TwoOperandExpressionType Members | Aspose.Email.Exchange.Schema Namespace


Aspose.Email.Exchange.SchemaHierarchy

Aspose.Email

Aspose.Email.Exchange.Schema Hierarchy

System.Object
Aspose.Email.Exchange.Schema.AggregateOnType
Aspose.Email.Exchange.Schema.AlternateIdBaseType
Aspose.Email.Exchange.Schema.AlternateIdType
Aspose.Email.Exchange.Schema.AlternatePublicFolderIdType
Aspose.Email.Exchange.Schema.AlternatePublicFolderItemIdType
Aspose.Email.Exchange.Schema.ArrayOfDLExpansionType
Aspose.Email.Exchange.Schema.ArrayOfGroupedItemsType
Aspose.Email.Exchange.Schema.ArrayOfRealItemsType
Aspose.Email.Exchange.Schema.ArrayOfResolutionType
Aspose.Email.Exchange.Schema.ArrayOfResponseMessagesType
Aspose.Email.Exchange.Schema.ArrayOfTimeZoneDefinitionType
Aspose.Email.Exchange.Schema.ArrayOfTrackingPropertiesType
Aspose.Email.Exchange.Schema.ArrayOfTransitionsType
Aspose.Email.Exchange.Schema.AttachmentResponseShapeType
Aspose.Email.Exchange.Schema.AttachmentType
Aspose.Email.Exchange.Schema.FileAttachmentType
Aspose.Email.Exchange.Schema.ItemAttachmentType
Aspose.Email.Exchange.Schema.AttendeeConflictData
Aspose.Email.Exchange.Schema.GroupAttendeeConflictData
Aspose.Email.Exchange.Schema.IndividualAttendeeConflictData
Aspose.Email.Exchange.Schema.TooBigGroupAttendeeConflictData
Aspose.Email.Exchange.Schema.UnknownAttendeeConflictData
Aspose.Email.Exchange.Schema.AttendeeType
Aspose.Email.Exchange.Schema.BaseEmailAddressType
Aspose.Email.Exchange.Schema.EmailAddressType
Aspose.Email.Exchange.Schema.BaseFolderIdType
Aspose.Email.Exchange.Schema.DistinguishedFolderIdType
Aspose.Email.Exchange.Schema.FolderIdType
Aspose.Email.Exchange.Schema.BaseFolderType
Aspose.Email.Exchange.Schema.CalendarFolderType
Aspose.Email.Exchange.Schema.ContactsFolderType
Aspose.Email.Exchange.Schema.FolderType
Aspose.Email.Exchange.Schema.SearchFolderType
Aspose.Email.Exchange.Schema.TasksFolderType
Aspose.Email.Exchange.Schema.BaseGroupByType
Aspose.Email.Exchange.Schema.DistinguishedGroupByType
Aspose.Email.Exchange.Schema.GroupByType
Aspose.Email.Exchange.Schema.BaseItemIdType
Aspose.Email.Exchange.Schema.ItemIdType
Aspose.Email.Exchange.Schema.OccurrenceItemIdType
Aspose.Email.Exchange.Schema.RecurringMasterItemIdType
Aspose.Email.Exchange.Schema.RequestAttachmentIdType
Aspose.Email.Exchange.Schema.AttachmentIdType
Aspose.Email.Exchange.Schema.RootItemIdType
Aspose.Email.Exchange.Schema.BaseNotificationEventType
Aspose.Email.Exchange.Schema.BaseObjectChangedEventType
Aspose.Email.Exchange.Schema.ModifiedEventType
Aspose.Email.Exchange.Schema.MovedCopiedEventType
Aspose.Email.Exchange.Schema.BasePagingType
Aspose.Email.Exchange.Schema.CalendarViewType
Aspose.Email.Exchange.Schema.ContactsViewType
Aspose.Email.Exchange.Schema.FractionalPageViewType
Aspose.Email.Exchange.Schema.IndexedPageViewType
Aspose.Email.Exchange.Schema.BasePathToElementType
Aspose.Email.Exchange.Schema.PathToExceptionFieldType
Aspose.Email.Exchange.Schema.PathToExtendedFieldType
Aspose.Email.Exchange.Schema.PathToIndexedFieldType
Aspose.Email.Exchange.Schema.PathToUnindexedFieldType
Aspose.Email.Exchange.Schema.BasePermissionType
Aspose.Email.Exchange.Schema.CalendarPermissionType
Aspose.Email.Exchange.Schema.PermissionType
Aspose.Email.Exchange.Schema.BaseRequestType
Aspose.Email.Exchange.Schema.ApplyConversationActionType
Aspose.Email.Exchange.Schema.BaseDelegateType
Aspose.Email.Exchange.Schema.AddDelegateType
Aspose.Email.Exchange.Schema.GetDelegateType
Aspose.Email.Exchange.Schema.RemoveDelegateType
Aspose.Email.Exchange.Schema.UpdateDelegateType
Aspose.Email.Exchange.Schema.BaseMoveCopyFolderType
Aspose.Email.Exchange.Schema.CopyFolderType
Aspose.Email.Exchange.Schema.MoveFolderType
Aspose.Email.Exchange.Schema.BaseMoveCopyItemType
Aspose.Email.Exchange.Schema.CopyItemType
Aspose.Email.Exchange.Schema.MoveItemType
Aspose.Email.Exchange.Schema.ConvertIdType
Aspose.Email.Exchange.Schema.CreateAttachmentType
Aspose.Email.Exchange.Schema.CreateFolderType
Aspose.Email.Exchange.Schema.CreateItemType
Aspose.Email.Exchange.Schema.CreateManagedFolderRequestType
Aspose.Email.Exchange.Schema.CreateUserConfigurationType
Aspose.Email.Exchange.Schema.DeleteAttachmentType
Aspose.Email.Exchange.Schema.DeleteFolderType
Aspose.Email.Exchange.Schema.DeleteItemType
Aspose.Email.Exchange.Schema.DeleteUserConfigurationType
Aspose.Email.Exchange.Schema.DisconnectPhoneCallType
Aspose.Email.Exchange.Schema.EmptyFolderType
Aspose.Email.Exchange.Schema.ExpandDLType
Aspose.Email.Exchange.Schema.ExportItemsType
Aspose.Email.Exchange.Schema.FindConversationType
Aspose.Email.Exchange.Schema.FindFolderType
Aspose.Email.Exchange.Schema.FindItemType
Aspose.Email.Exchange.Schema.FindMailboxStatisticsByKeywordsType
Aspose.Email.Exchange.Schema.FindMessageTrackingReportRequestType
Aspose.Email.Exchange.Schema.GetAttachmentType
Aspose.Email.Exchange.Schema.GetEventsType
Aspose.Email.Exchange.Schema.GetFolderType
Aspose.Email.Exchange.Schema.GetInboxRulesRequestType
Aspose.Email.Exchange.Schema.GetItemType
Aspose.Email.Exchange.Schema.GetMailTipsType
Aspose.Email.Exchange.Schema.GetMessageTrackingReportRequestType
Aspose.Email.Exchange.Schema.GetPhoneCallInformationType
Aspose.Email.Exchange.Schema.GetRoomListsType
Aspose.Email.Exchange.Schema.GetRoomsType
Aspose.Email.Exchange.Schema.GetServerTimeZonesType
Aspose.Email.Exchange.Schema.GetServiceConfigurationType
Aspose.Email.Exchange.Schema.GetSharingFolderType
Aspose.Email.Exchange.Schema.GetSharingMetadataType
Aspose.Email.Exchange.Schema.GetStreamingEventsType
Aspose.Email.Exchange.Schema.GetUserAvailabilityRequestType
Aspose.Email.Exchange.Schema.GetUserConfigurationType
Aspose.Email.Exchange.Schema.GetUserOofSettingsRequest
Aspose.Email.Exchange.Schema.PlayOnPhoneType
Aspose.Email.Exchange.Schema.RefreshSharingFolderType
Aspose.Email.Exchange.Schema.ResolveNamesType
Aspose.Email.Exchange.Schema.SendItemType
Aspose.Email.Exchange.Schema.SetUserOofSettingsRequest
Aspose.Email.Exchange.Schema.SubscribeType
Aspose.Email.Exchange.Schema.SyncFolderHierarchyType
Aspose.Email.Exchange.Schema.SyncFolderItemsType
Aspose.Email.Exchange.Schema.UnsubscribeType
Aspose.Email.Exchange.Schema.UpdateFolderType
Aspose.Email.Exchange.Schema.UpdateInboxRulesRequestType
Aspose.Email.Exchange.Schema.UpdateItemType
Aspose.Email.Exchange.Schema.UpdateUserConfigurationType
Aspose.Email.Exchange.Schema.UploadItemsType
Aspose.Email.Exchange.Schema.BaseResponseMessageType
Aspose.Email.Exchange.Schema.ApplyConversationActionResponseType
Aspose.Email.Exchange.Schema.ConvertIdResponseType
Aspose.Email.Exchange.Schema.CopyFolderResponseType
Aspose.Email.Exchange.Schema.CopyItemResponseType
Aspose.Email.Exchange.Schema.CreateAttachmentResponseType
Aspose.Email.Exchange.Schema.CreateFolderResponseType
Aspose.Email.Exchange.Schema.CreateItemResponseType
Aspose.Email.Exchange.Schema.CreateManagedFolderResponseType
Aspose.Email.Exchange.Schema.CreateUserConfigurationResponseType
Aspose.Email.Exchange.Schema.DeleteAttachmentResponseType
Aspose.Email.Exchange.Schema.DeleteFolderResponseType
Aspose.Email.Exchange.Schema.DeleteItemResponseType
Aspose.Email.Exchange.Schema.DeleteUserConfigurationResponseType
Aspose.Email.Exchange.Schema.EmptyFolderResponseType
Aspose.Email.Exchange.Schema.ExpandDLResponseType
Aspose.Email.Exchange.Schema.ExportItemsResponseType
Aspose.Email.Exchange.Schema.FindFolderResponseType
Aspose.Email.Exchange.Schema.FindItemResponseType
Aspose.Email.Exchange.Schema.FindMailboxStatisticsByKeywordsResponseType
Aspose.Email.Exchange.Schema.GetAttachmentResponseType
Aspose.Email.Exchange.Schema.GetEventsResponseType
Aspose.Email.Exchange.Schema.GetFolderResponseType
Aspose.Email.Exchange.Schema.GetItemResponseType
Aspose.Email.Exchange.Schema.GetServerTimeZonesResponseType
Aspose.Email.Exchange.Schema.GetStreamingEventsResponseType
Aspose.Email.Exchange.Schema.GetUserConfigurationResponseType
Aspose.Email.Exchange.Schema.MoveFolderResponseType
Aspose.Email.Exchange.Schema.MoveItemResponseType
Aspose.Email.Exchange.Schema.ResolveNamesResponseType
Aspose.Email.Exchange.Schema.SendItemResponseType
Aspose.Email.Exchange.Schema.SendNotificationResponseType
Aspose.Email.Exchange.Schema.SubscribeResponseType
Aspose.Email.Exchange.Schema.SyncFolderHierarchyResponseType
Aspose.Email.Exchange.Schema.SyncFolderItemsResponseType
Aspose.Email.Exchange.Schema.UnsubscribeResponseType
Aspose.Email.Exchange.Schema.UpdateFolderResponseType
Aspose.Email.Exchange.Schema.UpdateItemResponseType
Aspose.Email.Exchange.Schema.UpdateUserConfigurationResponseType
Aspose.Email.Exchange.Schema.UploadItemsResponseType
Aspose.Email.Exchange.Schema.BaseSubscriptionRequestType
Aspose.Email.Exchange.Schema.PullSubscriptionRequestType
Aspose.Email.Exchange.Schema.PushSubscriptionRequestType
Aspose.Email.Exchange.Schema.BodyType
Aspose.Email.Exchange.Schema.CalendarEvent
Aspose.Email.Exchange.Schema.CalendarEventDetails
Aspose.Email.Exchange.Schema.CalendarPermissionSetType
Aspose.Email.Exchange.Schema.ChangeDescriptionType
Aspose.Email.Exchange.Schema.FolderChangeDescriptionType
Aspose.Email.Exchange.Schema.AppendToFolderFieldType
Aspose.Email.Exchange.Schema.DeleteFolderFieldType
Aspose.Email.Exchange.Schema.SetFolderFieldType
Aspose.Email.Exchange.Schema.ItemChangeDescriptionType
Aspose.Email.Exchange.Schema.AppendToItemFieldType
Aspose.Email.Exchange.Schema.DeleteItemFieldType
Aspose.Email.Exchange.Schema.SetItemFieldType
Aspose.Email.Exchange.Schema.CompleteNameType
Aspose.Email.Exchange.Schema.ConflictResultsType
Aspose.Email.Exchange.Schema.ConnectingSIDType
Aspose.Email.Exchange.Schema.ConstantValueType
Aspose.Email.Exchange.Schema.ConversationActionType
Aspose.Email.Exchange.Schema.ConversationType
Aspose.Email.Exchange.Schema.DelegatePermissionsType
Aspose.Email.Exchange.Schema.DelegateUserType
Aspose.Email.Exchange.Schema.DeletedOccurrenceInfoType
Aspose.Email.Exchange.Schema.DirectoryEntryType
Aspose.Email.Exchange.Schema.RoomType
Aspose.Email.Exchange.Schema.Duration
Aspose.Email.Exchange.Schema.EffectiveRightsType
Aspose.Email.Exchange.Schema.EmailAddress
Aspose.Email.Exchange.Schema.EmailAddressDictionaryEntryType
Aspose.Email.Exchange.Schema.EncryptedSharedFolderDataType
Aspose.Email.Exchange.Schema.ExcludesValueType
Aspose.Email.Exchange.Schema.ExtendedPropertyType
Aspose.Email.Exchange.Schema.FieldOrderType
Aspose.Email.Exchange.Schema.FieldURIOrConstantType
Aspose.Email.Exchange.Schema.FindFolderParentType
Aspose.Email.Exchange.Schema.FindItemParentType
Aspose.Email.Exchange.Schema.FindMessageTrackingSearchResultType
Aspose.Email.Exchange.Schema.FolderChangeType
Aspose.Email.Exchange.Schema.FolderResponseShapeType
Aspose.Email.Exchange.Schema.FreeBusyResponseType
Aspose.Email.Exchange.Schema.FreeBusyView
Aspose.Email.Exchange.Schema.FreeBusyViewOptionsType
Aspose.Email.Exchange.Schema.GetUserAvailabilityResponseType
Aspose.Email.Exchange.Schema.GetUserOofSettingsResponse
Aspose.Email.Exchange.Schema.GroupedItemsType
Aspose.Email.Exchange.Schema.ImAddressDictionaryEntryType
Aspose.Email.Exchange.Schema.InternetHeaderType
Aspose.Email.Exchange.Schema.InvalidRecipientType
Aspose.Email.Exchange.Schema.ItemChangeType
Aspose.Email.Exchange.Schema.ItemResponseShapeType
Aspose.Email.Exchange.Schema.ItemType
Aspose.Email.Exchange.Schema.CalendarItemType
Aspose.Email.Exchange.Schema.ContactItemType
Aspose.Email.Exchange.Schema.DistributionListType
Aspose.Email.Exchange.Schema.MessageType
Aspose.Email.Exchange.Schema.MeetingMessageType
Aspose.Email.Exchange.Schema.MeetingCancellationMessageType
Aspose.Email.Exchange.Schema.MeetingRequestMessageType
Aspose.Email.Exchange.Schema.MeetingResponseMessageType
Aspose.Email.Exchange.Schema.ResponseObjectCoreType
Aspose.Email.Exchange.Schema.ResponseObjectType
Aspose.Email.Exchange.Schema.PostReplyItemBaseType
Aspose.Email.Exchange.Schema.PostReplyItemType
Aspose.Email.Exchange.Schema.ReferenceItemResponseType
Aspose.Email.Exchange.Schema.AcceptSharingInvitationType
Aspose.Email.Exchange.Schema.SuppressReadReceiptType
Aspose.Email.Exchange.Schema.RemoveItemType
Aspose.Email.Exchange.Schema.SmartResponseBaseType
Aspose.Email.Exchange.Schema.SmartResponseType
Aspose.Email.Exchange.Schema.CancelCalendarItemType
Aspose.Email.Exchange.Schema.ForwardItemType
Aspose.Email.Exchange.Schema.ReplyAllToItemType
Aspose.Email.Exchange.Schema.ReplyToItemType
Aspose.Email.Exchange.Schema.WellKnownResponseObjectType
Aspose.Email.Exchange.Schema.AcceptItemType
Aspose.Email.Exchange.Schema.DeclineItemType
Aspose.Email.Exchange.Schema.TentativelyAcceptItemType
Aspose.Email.Exchange.Schema.PostItemType
Aspose.Email.Exchange.Schema.TaskType
Aspose.Email.Exchange.Schema.KeywordStatisticsSearchResultType
Aspose.Email.Exchange.Schema.MailboxData
Aspose.Email.Exchange.Schema.MailboxStatisticsSearchResultType
Aspose.Email.Exchange.Schema.MailTips
Aspose.Email.Exchange.Schema.ManagedFolderInformationType
Aspose.Email.Exchange.Schema.MemberType
Aspose.Email.Exchange.Schema.MessageTrackingReportType
Aspose.Email.Exchange.Schema.MimeContentType
Aspose.Email.Exchange.Schema.NonEmptyArrayOfAllItemsType
Aspose.Email.Exchange.Schema.NonEmptyArrayOfPropertyValuesType
Aspose.Email.Exchange.Schema.NotificationType
Aspose.Email.Exchange.Schema.OccurrenceInfoType
Aspose.Email.Exchange.Schema.OutOfOfficeMailTip
Aspose.Email.Exchange.Schema.PeriodType
Aspose.Email.Exchange.Schema.PermissionSetType
Aspose.Email.Exchange.Schema.PhoneCallIdType
Aspose.Email.Exchange.Schema.PhoneCallInformationType
Aspose.Email.Exchange.Schema.PhoneNumberDictionaryEntryType
Aspose.Email.Exchange.Schema.PhysicalAddressDictionaryEntryType
Aspose.Email.Exchange.Schema.ProtectionRuleActionType
Aspose.Email.Exchange.Schema.ProtectionRuleAndType
Aspose.Email.Exchange.Schema.ProtectionRuleArgumentType
Aspose.Email.Exchange.Schema.ProtectionRuleConditionType
Aspose.Email.Exchange.Schema.ProtectionRuleRecipientIsType
Aspose.Email.Exchange.Schema.ProtectionRuleSenderDepartmentsType
Aspose.Email.Exchange.Schema.ProtectionRuleType
Aspose.Email.Exchange.Schema.RecipientTrackingEventType
Aspose.Email.Exchange.Schema.RecurrencePatternBaseType
Aspose.Email.Exchange.Schema.AbsoluteYearlyRecurrencePatternType
Aspose.Email.Exchange.Schema.IntervalRecurrencePatternBaseType
Aspose.Email.Exchange.Schema.AbsoluteMonthlyRecurrencePatternType
Aspose.Email.Exchange.Schema.DailyRecurrencePatternType
Aspose.Email.Exchange.Schema.RegeneratingPatternBaseType
Aspose.Email.Exchange.Schema.DailyRegeneratingPatternType
Aspose.Email.Exchange.Schema.MonthlyRegeneratingPatternType
Aspose.Email.Exchange.Schema.WeeklyRegeneratingPatternType
Aspose.Email.Exchange.Schema.YearlyRegeneratingPatternType
Aspose.Email.Exchange.Schema.RelativeMonthlyRecurrencePatternType
Aspose.Email.Exchange.Schema.WeeklyRecurrencePatternType
Aspose.Email.Exchange.Schema.RelativeYearlyRecurrencePatternType
Aspose.Email.Exchange.Schema.RecurrenceRangeBaseType
Aspose.Email.Exchange.Schema.EndDateRecurrenceRangeType
Aspose.Email.Exchange.Schema.NoEndRecurrenceRangeType
Aspose.Email.Exchange.Schema.NumberedRecurrenceRangeType
Aspose.Email.Exchange.Schema.RecurrenceType
Aspose.Email.Exchange.Schema.ReplyBody
Aspose.Email.Exchange.Schema.ResolutionType
Aspose.Email.Exchange.Schema.ResponseMessageType
Aspose.Email.Exchange.Schema.AttachmentInfoResponseMessageType
Aspose.Email.Exchange.Schema.BaseDelegateResponseMessageType
Aspose.Email.Exchange.Schema.AddDelegateResponseMessageType
Aspose.Email.Exchange.Schema.GetDelegateResponseMessageType
Aspose.Email.Exchange.Schema.RemoveDelegateResponseMessageType
Aspose.Email.Exchange.Schema.UpdateDelegateResponseMessageType
Aspose.Email.Exchange.Schema.ConvertIdResponseMessageType
Aspose.Email.Exchange.Schema.DelegateUserResponseMessageType
Aspose.Email.Exchange.Schema.DeleteAttachmentResponseMessageType
Aspose.Email.Exchange.Schema.DisconnectPhoneCallResponseMessageType
Aspose.Email.Exchange.Schema.ExpandDLResponseMessageType
Aspose.Email.Exchange.Schema.ExportItemsResponseMessageType
Aspose.Email.Exchange.Schema.FindConversationResponseMessageType
Aspose.Email.Exchange.Schema.FindFolderResponseMessageType
Aspose.Email.Exchange.Schema.FindItemResponseMessageType
Aspose.Email.Exchange.Schema.FindMailboxStatisticsByKeywordsResponseMessageType
Aspose.Email.Exchange.Schema.FindMessageTrackingReportResponseMessageType
Aspose.Email.Exchange.Schema.FolderInfoResponseMessageType
Aspose.Email.Exchange.Schema.GetEventsResponseMessageType
Aspose.Email.Exchange.Schema.GetInboxRulesResponseType
Aspose.Email.Exchange.Schema.GetMailTipsResponseMessageType
Aspose.Email.Exchange.Schema.GetMessageTrackingReportResponseMessageType
Aspose.Email.Exchange.Schema.GetPhoneCallInformationResponseMessageType
Aspose.Email.Exchange.Schema.GetRoomListsResponseMessageType
Aspose.Email.Exchange.Schema.GetRoomsResponseMessageType
Aspose.Email.Exchange.Schema.GetServerTimeZonesResponseMessageType
Aspose.Email.Exchange.Schema.GetServiceConfigurationResponseMessageType
Aspose.Email.Exchange.Schema.GetSharingFolderResponseMessageType
Aspose.Email.Exchange.Schema.GetSharingMetadataResponseMessageType
Aspose.Email.Exchange.Schema.GetStreamingEventsResponseMessageType
Aspose.Email.Exchange.Schema.GetUserConfigurationResponseMessageType
Aspose.Email.Exchange.Schema.ItemInfoResponseMessageType
Aspose.Email.Exchange.Schema.UpdateItemResponseMessageType
Aspose.Email.Exchange.Schema.MailTipsResponseMessageType
Aspose.Email.Exchange.Schema.PlayOnPhoneResponseMessageType
Aspose.Email.Exchange.Schema.RefreshSharingFolderResponseMessageType
Aspose.Email.Exchange.Schema.ResolveNamesResponseMessageType
Aspose.Email.Exchange.Schema.SendNotificationResponseMessageType
Aspose.Email.Exchange.Schema.ServiceConfigurationResponseMessageType
Aspose.Email.Exchange.Schema.SubscribeResponseMessageType
Aspose.Email.Exchange.Schema.SyncFolderHierarchyResponseMessageType
Aspose.Email.Exchange.Schema.SyncFolderItemsResponseMessageType
Aspose.Email.Exchange.Schema.UpdateInboxRulesResponseType
Aspose.Email.Exchange.Schema.UploadItemsResponseMessageType
Aspose.Email.Exchange.Schema.ResponseMessageTypeMessageXml
Aspose.Email.Exchange.Schema.RestrictionType
Aspose.Email.Exchange.Schema.RuleActionsType
Aspose.Email.Exchange.Schema.RuleOperationErrorType
Aspose.Email.Exchange.Schema.RuleOperationType
Aspose.Email.Exchange.Schema.CreateRuleOperationType
Aspose.Email.Exchange.Schema.DeleteRuleOperationType
Aspose.Email.Exchange.Schema.SetRuleOperationType
Aspose.Email.Exchange.Schema.RulePredicateDateRangeType
Aspose.Email.Exchange.Schema.RulePredicateSizeRangeType
Aspose.Email.Exchange.Schema.RulePredicatesType
Aspose.Email.Exchange.Schema.RuleType
Aspose.Email.Exchange.Schema.RuleValidationErrorType
Aspose.Email.Exchange.Schema.SearchExpressionType
Aspose.Email.Exchange.Schema.ContainsExpressionType
Aspose.Email.Exchange.Schema.ExcludesType
Aspose.Email.Exchange.Schema.ExistsType
Aspose.Email.Exchange.Schema.MultipleOperandBooleanExpressionType
Aspose.Email.Exchange.Schema.AndType
Aspose.Email.Exchange.Schema.OrType
Aspose.Email.Exchange.Schema.NotType
Aspose.Email.Exchange.Schema.TwoOperandExpressionType
Aspose.Email.Exchange.Schema.IsEqualToType
Aspose.Email.Exchange.Schema.IsGreaterThanOrEqualToType
Aspose.Email.Exchange.Schema.IsGreaterThanType
Aspose.Email.Exchange.Schema.IsLessThanOrEqualToType
Aspose.Email.Exchange.Schema.IsLessThanType
Aspose.Email.Exchange.Schema.IsNotEqualToType
Aspose.Email.Exchange.Schema.SearchParametersType
Aspose.Email.Exchange.Schema.SerializableTimeZone
Aspose.Email.Exchange.Schema.SerializableTimeZoneTime
Aspose.Email.Exchange.Schema.ServiceConfiguration
Aspose.Email.Exchange.Schema.MailTipsServiceConfiguration
Aspose.Email.Exchange.Schema.ProtectionRulesServiceConfiguration
Aspose.Email.Exchange.Schema.UnifiedMessageServiceConfiguration
Aspose.Email.Exchange.Schema.SetUserOofSettingsResponse
Aspose.Email.Exchange.Schema.SingleRecipientType
Aspose.Email.Exchange.Schema.SmtpDomain
Aspose.Email.Exchange.Schema.StreamingSubscriptionRequestType
Aspose.Email.Exchange.Schema.Suggestion
Aspose.Email.Exchange.Schema.SuggestionDayResult
Aspose.Email.Exchange.Schema.SuggestionsResponseType
Aspose.Email.Exchange.Schema.SuggestionsViewOptionsType
Aspose.Email.Exchange.Schema.SyncFolderHierarchyChangesType
Aspose.Email.Exchange.Schema.SyncFolderHierarchyCreateOrUpdateType
Aspose.Email.Exchange.Schema.SyncFolderHierarchyDeleteType
Aspose.Email.Exchange.Schema.SyncFolderItemsChangesType
Aspose.Email.Exchange.Schema.SyncFolderItemsCreateOrUpdateType
Aspose.Email.Exchange.Schema.SyncFolderItemsDeleteType
Aspose.Email.Exchange.Schema.SyncFolderItemsReadFlagType
Aspose.Email.Exchange.Schema.TargetFolderIdType
Aspose.Email.Exchange.Schema.UserConfigurationNameType
Aspose.Email.Exchange.Schema.TaskRecurrenceType
Aspose.Email.Exchange.Schema.TimeChangeType
Aspose.Email.Exchange.Schema.TimeZoneDefinitionType
Aspose.Email.Exchange.Schema.TimeZoneType
Aspose.Email.Exchange.Schema.TrackingPropertyType
Aspose.Email.Exchange.Schema.TransitionTargetType
Aspose.Email.Exchange.Schema.TransitionType
Aspose.Email.Exchange.Schema.AbsoluteDateTransitionType
Aspose.Email.Exchange.Schema.RecurringTimeTransitionType
Aspose.Email.Exchange.Schema.RecurringDateTransitionType
Aspose.Email.Exchange.Schema.RecurringDayTransitionType
Aspose.Email.Exchange.Schema.UploadItemType
Aspose.Email.Exchange.Schema.UserConfigurationDictionaryEntryType
Aspose.Email.Exchange.Schema.UserConfigurationDictionaryObjectType
Aspose.Email.Exchange.Schema.UserConfigurationType
Aspose.Email.Exchange.Schema.UserIdType
Aspose.Email.Exchange.Schema.UserMailboxType
Aspose.Email.Exchange.Schema.UserOofSettings
Aspose.Email.Exchange.Schema.WorkingHours
Aspose.Email.Exchange.Schema.WorkingPeriod
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
Aspose.Email.Exchange.Schema.AddDelegateCompletedEventHandler
Aspose.Email.Exchange.Schema.ApplyConversationActionCompletedEventHandler
Aspose.Email.Exchange.Schema.ConvertIdCompletedEventHandler
Aspose.Email.Exchange.Schema.CopyFolderCompletedEventHandler
Aspose.Email.Exchange.Schema.CopyItemCompletedEventHandler
Aspose.Email.Exchange.Schema.CreateAttachmentCompletedEventHandler
Aspose.Email.Exchange.Schema.CreateFolderCompletedEventHandler
Aspose.Email.Exchange.Schema.CreateItemCompletedEventHandler
Aspose.Email.Exchange.Schema.CreateManagedFolderCompletedEventHandler
Aspose.Email.Exchange.Schema.CreateUserConfigurationCompletedEventHandler
Aspose.Email.Exchange.Schema.DeleteAttachmentCompletedEventHandler
Aspose.Email.Exchange.Schema.DeleteFolderCompletedEventHandler
Aspose.Email.Exchange.Schema.DeleteItemCompletedEventHandler
Aspose.Email.Exchange.Schema.DeleteUserConfigurationCompletedEventHandler
Aspose.Email.Exchange.Schema.DisconnectPhoneCallCompletedEventHandler
Aspose.Email.Exchange.Schema.EmptyFolderCompletedEventHandler
Aspose.Email.Exchange.Schema.ExpandDLCompletedEventHandler
Aspose.Email.Exchange.Schema.ExportItemsCompletedEventHandler
Aspose.Email.Exchange.Schema.FindConversationCompletedEventHandler
Aspose.Email.Exchange.Schema.FindFolderCompletedEventHandler
Aspose.Email.Exchange.Schema.FindItemCompletedEventHandler
Aspose.Email.Exchange.Schema.FindMessageTrackingReportCompletedEventHandler
Aspose.Email.Exchange.Schema.GetAttachmentCompletedEventHandler
Aspose.Email.Exchange.Schema.GetDelegateCompletedEventHandler
Aspose.Email.Exchange.Schema.GetEventsCompletedEventHandler
Aspose.Email.Exchange.Schema.GetFolderCompletedEventHandler
Aspose.Email.Exchange.Schema.GetInboxRulesCompletedEventHandler
Aspose.Email.Exchange.Schema.GetItemCompletedEventHandler
Aspose.Email.Exchange.Schema.GetMailTipsCompletedEventHandler
Aspose.Email.Exchange.Schema.GetMessageTrackingReportCompletedEventHandler
Aspose.Email.Exchange.Schema.GetPhoneCallInformationCompletedEventHandler
Aspose.Email.Exchange.Schema.GetRoomListsCompletedEventHandler
Aspose.Email.Exchange.Schema.GetRoomsCompletedEventHandler
Aspose.Email.Exchange.Schema.GetServerTimeZonesCompletedEventHandler
Aspose.Email.Exchange.Schema.GetServiceConfigurationCompletedEventHandler
Aspose.Email.Exchange.Schema.GetSharingFolderCompletedEventHandler
Aspose.Email.Exchange.Schema.GetSharingMetadataCompletedEventHandler
Aspose.Email.Exchange.Schema.GetStreamingEventsCompletedEventHandler
Aspose.Email.Exchange.Schema.GetUserAvailabilityCompletedEventHandler
Aspose.Email.Exchange.Schema.GetUserConfigurationCompletedEventHandler
Aspose.Email.Exchange.Schema.GetUserOofSettingsCompletedEventHandler
Aspose.Email.Exchange.Schema.MoveFolderCompletedEventHandler
Aspose.Email.Exchange.Schema.MoveItemCompletedEventHandler
Aspose.Email.Exchange.Schema.PlayOnPhoneCompletedEventHandler
Aspose.Email.Exchange.Schema.RefreshSharingFolderCompletedEventHandler
Aspose.Email.Exchange.Schema.RemoveDelegateCompletedEventHandler
Aspose.Email.Exchange.Schema.ResolveNamesCompletedEventHandler
Aspose.Email.Exchange.Schema.SendItemCompletedEventHandler
Aspose.Email.Exchange.Schema.SetUserOofSettingsCompletedEventHandler
Aspose.Email.Exchange.Schema.SubscribeCompletedEventHandler
Aspose.Email.Exchange.Schema.SyncFolderHierarchyCompletedEventHandler
Aspose.Email.Exchange.Schema.SyncFolderItemsCompletedEventHandler
Aspose.Email.Exchange.Schema.UnsubscribeCompletedEventHandler
Aspose.Email.Exchange.Schema.UpdateDelegateCompletedEventHandler
Aspose.Email.Exchange.Schema.UpdateFolderCompletedEventHandler
Aspose.Email.Exchange.Schema.UpdateInboxRulesCompletedEventHandler
Aspose.Email.Exchange.Schema.UpdateItemCompletedEventHandler
Aspose.Email.Exchange.Schema.UpdateUserConfigurationCompletedEventHandler
Aspose.Email.Exchange.Schema.UploadItemsCompletedEventHandler
System.EventArgs
System.ComponentModel.AsyncCompletedEventArgs
Aspose.Email.Exchange.Schema.AddDelegateCompletedEventArgs
Aspose.Email.Exchange.Schema.ApplyConversationActionCompletedEventArgs
Aspose.Email.Exchange.Schema.ConvertIdCompletedEventArgs
Aspose.Email.Exchange.Schema.CopyFolderCompletedEventArgs
Aspose.Email.Exchange.Schema.CopyItemCompletedEventArgs
Aspose.Email.Exchange.Schema.CreateAttachmentCompletedEventArgs
Aspose.Email.Exchange.Schema.CreateFolderCompletedEventArgs
Aspose.Email.Exchange.Schema.CreateItemCompletedEventArgs
Aspose.Email.Exchange.Schema.CreateManagedFolderCompletedEventArgs
Aspose.Email.Exchange.Schema.CreateUserConfigurationCompletedEventArgs
Aspose.Email.Exchange.Schema.DeleteAttachmentCompletedEventArgs
Aspose.Email.Exchange.Schema.DeleteFolderCompletedEventArgs
Aspose.Email.Exchange.Schema.DeleteItemCompletedEventArgs
Aspose.Email.Exchange.Schema.DeleteUserConfigurationCompletedEventArgs
Aspose.Email.Exchange.Schema.DisconnectPhoneCallCompletedEventArgs
Aspose.Email.Exchange.Schema.EmptyFolderCompletedEventArgs
Aspose.Email.Exchange.Schema.ExpandDLCompletedEventArgs
Aspose.Email.Exchange.Schema.ExportItemsCompletedEventArgs
Aspose.Email.Exchange.Schema.FindConversationCompletedEventArgs
Aspose.Email.Exchange.Schema.FindFolderCompletedEventArgs
Aspose.Email.Exchange.Schema.FindItemCompletedEventArgs
Aspose.Email.Exchange.Schema.FindMessageTrackingReportCompletedEventArgs
Aspose.Email.Exchange.Schema.GetAttachmentCompletedEventArgs
Aspose.Email.Exchange.Schema.GetDelegateCompletedEventArgs
Aspose.Email.Exchange.Schema.GetEventsCompletedEventArgs
Aspose.Email.Exchange.Schema.GetFolderCompletedEventArgs
Aspose.Email.Exchange.Schema.GetInboxRulesCompletedEventArgs
Aspose.Email.Exchange.Schema.GetItemCompletedEventArgs
Aspose.Email.Exchange.Schema.GetMailTipsCompletedEventArgs
Aspose.Email.Exchange.Schema.GetMessageTrackingReportCompletedEventArgs
Aspose.Email.Exchange.Schema.GetPhoneCallInformationCompletedEventArgs
Aspose.Email.Exchange.Schema.GetRoomListsCompletedEventArgs
Aspose.Email.Exchange.Schema.GetRoomsCompletedEventArgs
Aspose.Email.Exchange.Schema.GetServerTimeZonesCompletedEventArgs
Aspose.Email.Exchange.Schema.GetServiceConfigurationCompletedEventArgs
Aspose.Email.Exchange.Schema.GetSharingFolderCompletedEventArgs
Aspose.Email.Exchange.Schema.GetSharingMetadataCompletedEventArgs
Aspose.Email.Exchange.Schema.GetStreamingEventsCompletedEventArgs
Aspose.Email.Exchange.Schema.GetUserAvailabilityCompletedEventArgs
Aspose.Email.Exchange.Schema.GetUserConfigurationCompletedEventArgs
Aspose.Email.Exchange.Schema.GetUserOofSettingsCompletedEventArgs
Aspose.Email.Exchange.Schema.MoveFolderCompletedEventArgs
Aspose.Email.Exchange.Schema.MoveItemCompletedEventArgs
Aspose.Email.Exchange.Schema.PlayOnPhoneCompletedEventArgs
Aspose.Email.Exchange.Schema.RefreshSharingFolderCompletedEventArgs
Aspose.Email.Exchange.Schema.RemoveDelegateCompletedEventArgs
Aspose.Email.Exchange.Schema.ResolveNamesCompletedEventArgs
Aspose.Email.Exchange.Schema.SendItemCompletedEventArgs
Aspose.Email.Exchange.Schema.SetUserOofSettingsCompletedEventArgs
Aspose.Email.Exchange.Schema.SubscribeCompletedEventArgs
Aspose.Email.Exchange.Schema.SyncFolderHierarchyCompletedEventArgs
Aspose.Email.Exchange.Schema.SyncFolderItemsCompletedEventArgs
Aspose.Email.Exchange.Schema.UnsubscribeCompletedEventArgs
Aspose.Email.Exchange.Schema.UpdateDelegateCompletedEventArgs
Aspose.Email.Exchange.Schema.UpdateFolderCompletedEventArgs
Aspose.Email.Exchange.Schema.UpdateInboxRulesCompletedEventArgs
Aspose.Email.Exchange.Schema.UpdateItemCompletedEventArgs
Aspose.Email.Exchange.Schema.UpdateUserConfigurationCompletedEventArgs
Aspose.Email.Exchange.Schema.UploadItemsCompletedEventArgs
System.MarshalByRefObject
System.ComponentModel.Component ---- System.ComponentModel.IComponent, System.IDisposable
System.Web.Services.Protocols.WebClientProtocol
System.Web.Services.Protocols.HttpWebClientProtocol
System.Web.Services.Protocols.SoapHttpClientProtocol
Aspose.Email.Exchange.Schema.ExchangeServiceBinding
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Email.Exchange.Schema.AffectedTaskOccurrencesType
Aspose.Email.Exchange.Schema.AggregateType
Aspose.Email.Exchange.Schema.BodyTypeResponseType
Aspose.Email.Exchange.Schema.BodyTypeType
Aspose.Email.Exchange.Schema.CalendarItemCreateOrDeleteOperationType
Aspose.Email.Exchange.Schema.CalendarItemTypeType
Aspose.Email.Exchange.Schema.CalendarItemUpdateOperationType
Aspose.Email.Exchange.Schema.CalendarPermissionLevelType
Aspose.Email.Exchange.Schema.CalendarPermissionReadAccessType
Aspose.Email.Exchange.Schema.ConflictResolutionType
Aspose.Email.Exchange.Schema.ConnectionFailureCauseType
Aspose.Email.Exchange.Schema.ConnectionStatusType
Aspose.Email.Exchange.Schema.ContactSourceType
Aspose.Email.Exchange.Schema.ContainmentComparisonType
Aspose.Email.Exchange.Schema.ContainmentModeType
Aspose.Email.Exchange.Schema.ConversationActionTypeType
Aspose.Email.Exchange.Schema.CreateActionType
Aspose.Email.Exchange.Schema.DayOfWeekIndexType
Aspose.Email.Exchange.Schema.DayOfWeekType
Aspose.Email.Exchange.Schema.DefaultShapeNamesType
Aspose.Email.Exchange.Schema.DelegateFolderPermissionLevelType
Aspose.Email.Exchange.Schema.DeliverMeetingRequestsType
Aspose.Email.Exchange.Schema.DictionaryURIType
Aspose.Email.Exchange.Schema.DisposalType
Aspose.Email.Exchange.Schema.DistinguishedFolderIdNameType
Aspose.Email.Exchange.Schema.DistinguishedPropertySetType
Aspose.Email.Exchange.Schema.DistinguishedUserType
Aspose.Email.Exchange.Schema.EmailAddressKeyType
Aspose.Email.Exchange.Schema.ExceptionPropertyURIType
Aspose.Email.Exchange.Schema.ExchangeVersionType
Aspose.Email.Exchange.Schema.ExternalAudience
Aspose.Email.Exchange.Schema.FileAsMappingType
Aspose.Email.Exchange.Schema.FlaggedForActionType
Aspose.Email.Exchange.Schema.FlagStatusType
Aspose.Email.Exchange.Schema.FolderQueryTraversalType
Aspose.Email.Exchange.Schema.FreeBusyViewType
Aspose.Email.Exchange.Schema.IdFormatType
Aspose.Email.Exchange.Schema.ImAddressKeyType
Aspose.Email.Exchange.Schema.ImportanceChoicesType
Aspose.Email.Exchange.Schema.IndexBasePointType
Aspose.Email.Exchange.Schema.InvalidRecipientResponseCodeType
Aspose.Email.Exchange.Schema.ItemChoiceType
Aspose.Email.Exchange.Schema.ItemChoiceType1
Aspose.Email.Exchange.Schema.ItemQueryTraversalType
Aspose.Email.Exchange.Schema.ItemsChoiceType
Aspose.Email.Exchange.Schema.ItemsChoiceType1
Aspose.Email.Exchange.Schema.ItemsChoiceType2
Aspose.Email.Exchange.Schema.ItemsChoiceType3
Aspose.Email.Exchange.Schema.ItemsChoiceType4
Aspose.Email.Exchange.Schema.LegacyFreeBusyType
Aspose.Email.Exchange.Schema.MailboxTypeType
Aspose.Email.Exchange.Schema.MailTipTypes
Aspose.Email.Exchange.Schema.MapiPropertyTypeType
Aspose.Email.Exchange.Schema.MeetingAttendeeType
Aspose.Email.Exchange.Schema.MeetingRequestTypeType
Aspose.Email.Exchange.Schema.MemberStatusType
Aspose.Email.Exchange.Schema.MessageDispositionType
Aspose.Email.Exchange.Schema.MessageTrackingDeliveryStatusType
Aspose.Email.Exchange.Schema.MessageTrackingEventDescriptionType
Aspose.Email.Exchange.Schema.MessageTrackingReportTemplateType
Aspose.Email.Exchange.Schema.MessageTrackingScopeType
Aspose.Email.Exchange.Schema.MonthNamesType
Aspose.Email.Exchange.Schema.NotificationEventTypeType
Aspose.Email.Exchange.Schema.OofState
Aspose.Email.Exchange.Schema.PermissionActionType
Aspose.Email.Exchange.Schema.PermissionLevelType
Aspose.Email.Exchange.Schema.PermissionReadAccessType
Aspose.Email.Exchange.Schema.PhoneCallStateType
Aspose.Email.Exchange.Schema.PhoneNumberKeyType
Aspose.Email.Exchange.Schema.PhysicalAddressIndexType
Aspose.Email.Exchange.Schema.PhysicalAddressKeyType
Aspose.Email.Exchange.Schema.ProtectionRuleActionKindType
Aspose.Email.Exchange.Schema.ResolveNamesSearchScopeType
Aspose.Email.Exchange.Schema.ResponseClassType
Aspose.Email.Exchange.Schema.ResponseCodeType
Aspose.Email.Exchange.Schema.ResponseTypeType
Aspose.Email.Exchange.Schema.RuleFieldURIType
Aspose.Email.Exchange.Schema.RuleValidationErrorCodeType
Aspose.Email.Exchange.Schema.SearchFolderTraversalType
Aspose.Email.Exchange.Schema.SearchItemKindType
Aspose.Email.Exchange.Schema.SensitivityChoicesType
Aspose.Email.Exchange.Schema.ServiceConfigurationType
Aspose.Email.Exchange.Schema.SharingDataType
Aspose.Email.Exchange.Schema.SortDirectionType
Aspose.Email.Exchange.Schema.StandardGroupByType
Aspose.Email.Exchange.Schema.SuggestionQuality
Aspose.Email.Exchange.Schema.SyncFolderItemsScopeType
Aspose.Email.Exchange.Schema.TaskDelegateStateType
Aspose.Email.Exchange.Schema.TaskStatusType
Aspose.Email.Exchange.Schema.TransitionTargetKindType
Aspose.Email.Exchange.Schema.UnindexedFieldURIType
Aspose.Email.Exchange.Schema.UserConfigurationDictionaryObjectTypesType
Aspose.Email.Exchange.Schema.UserConfigurationPropertyType
System.Web.Services.Protocols.SoapHeader
Aspose.Email.Exchange.Schema.ExchangeImpersonationType
Aspose.Email.Exchange.Schema.MailboxCultureType
Aspose.Email.Exchange.Schema.RequestServerVersion
Aspose.Email.Exchange.Schema.ServerVersionInfo
Aspose.Email.Exchange.Schema.TimeZoneContextType

See Also

Aspose.Email.Exchange.Schema Namespace


Aspose.Email.ExchangeHierarchy

Aspose.Email

Aspose.Email.Exchange Hierarchy

System.Object
Aspose.Email.Exchange.CallInformation
Aspose.Email.Exchange.ContentClassType
Aspose.Email.Exchange.DateRange
Aspose.Email.Exchange.ExchangeAttachmentInfo
Aspose.Email.Exchange.ExchangeBasePermission
Aspose.Email.Exchange.ExchangeCalendarPermission
Aspose.Email.Exchange.ExchangeFolderPermission
Aspose.Email.Exchange.ExchangeCalendarEvent
Aspose.Email.Exchange.ExchangeClientBase ---- Aspose.Email.Exchange.IExchangeClientBase, System.IDisposable
Aspose.Email.Exchange.EWSClient
Aspose.Email.Exchange.ExchangeClient
Aspose.Email.Exchange.ExchangeWebServiceClient ---- Aspose.Email.Exchange.IEWSClient
Aspose.Email.Exchange.ExchangeConversation
Aspose.Email.Exchange.ExchangeDelegatePermissions
Aspose.Email.Exchange.ExchangeDelegateUser
Aspose.Email.Exchange.ExchangeFolderInfo
Aspose.Email.Exchange.ExchangeFolderUserInfo
Aspose.Email.Exchange.ExchangeMailboxInfo
Aspose.Email.Exchange.ExchangeMessageInfo
Aspose.Email.Exchange.ExchangeStreamedItem
Aspose.Email.Exchange.ExchangeUploadItemResult
Aspose.Email.Exchange.ExchangeUserAvailability
Aspose.Email.Exchange.ExchangeUserWorkingHours
Aspose.Email.Exchange.FindMessageTrackingReportOptions
Aspose.Email.Exchange.GetMailTipsOptions
Aspose.Email.Exchange.GetMessageTrackingReportOptions
Aspose.Email.Exchange.IEWSClient ---- Aspose.Email.Exchange.IExchangeClientBase, System.IDisposable
Aspose.Email.Exchange.IExchangeClientBase ---- System.IDisposable
Aspose.Email.Exchange.InboxRule
Aspose.Email.Exchange.MailTips
Aspose.Email.Exchange.MessageTrackingReport
Aspose.Email.Exchange.MessageTrackingReportInfo
Aspose.Email.Exchange.OutOfOfficeMailTip
Aspose.Email.Exchange.RecipientTrackingEvent
Aspose.Email.Exchange.ReplyBody
Aspose.Email.Exchange.RuleActions
Aspose.Email.Exchange.RulePredicates
Aspose.Email.Exchange.SizeRange
Aspose.Email.Exchange.UnifiedMessagingConfiguration
Aspose.Email.Exchange.UserConfiguration
Aspose.Email.Exchange.UserConfigurationName
Aspose.Email.Mail.Calendaring.RecurrencePattern
Aspose.Email.Exchange.TaskRegeneratingPattern
Aspose.Email.Mail.Task ---- System.IDisposable
Aspose.Email.Exchange.ExchangeTask
Aspose.Email.MailQueryBuilder
Aspose.Email.Exchange.ExchangeQueryBuilder
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Exchange.ExchangeAttachmentInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]] ---- System.Collections.Generic.ICollection`1[[Aspose.Email.Exchange.ExchangeAttachmentInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IEnumerable`1[[Aspose.Email.Exchange.ExchangeAttachmentInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IList`1[[Aspose.Email.Exchange.ExchangeAttachmentInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Email.Exchange.ExchangeAttachmentInfoCollection
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Exchange.ExchangeBasePermission, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]] ---- System.Collections.Generic.ICollection`1[[Aspose.Email.Exchange.ExchangeBasePermission, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IEnumerable`1[[Aspose.Email.Exchange.ExchangeBasePermission, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IList`1[[Aspose.Email.Exchange.ExchangeBasePermission, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Email.Exchange.ExchangePermissionCollection
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Exchange.ExchangeCalendarEvent, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]] ---- System.Collections.Generic.ICollection`1[[Aspose.Email.Exchange.ExchangeCalendarEvent, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IEnumerable`1[[Aspose.Email.Exchange.ExchangeCalendarEvent, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IList`1[[Aspose.Email.Exchange.ExchangeCalendarEvent, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Email.Exchange.ExchangeCalendarEventCollection
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Exchange.ExchangeDelegateUser, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]] ---- System.Collections.Generic.ICollection`1[[Aspose.Email.Exchange.ExchangeDelegateUser, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IEnumerable`1[[Aspose.Email.Exchange.ExchangeDelegateUser, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IList`1[[Aspose.Email.Exchange.ExchangeDelegateUser, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Email.Exchange.ExchangeDelegateUserCollection
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Exchange.ExchangeFolderInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]] ---- System.Collections.Generic.ICollection`1[[Aspose.Email.Exchange.ExchangeFolderInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IEnumerable`1[[Aspose.Email.Exchange.ExchangeFolderInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IList`1[[Aspose.Email.Exchange.ExchangeFolderInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Email.Exchange.ExchangeFolderInfoCollection
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Exchange.ExchangeFolderPermission, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]] ---- System.Collections.Generic.ICollection`1[[Aspose.Email.Exchange.ExchangeFolderPermission, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IEnumerable`1[[Aspose.Email.Exchange.ExchangeFolderPermission, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IList`1[[Aspose.Email.Exchange.ExchangeFolderPermission, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Email.Exchange.ExchangeFolderPermissionCollection
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Exchange.ExchangeMessageInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]] ---- System.Collections.Generic.ICollection`1[[Aspose.Email.Exchange.ExchangeMessageInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IEnumerable`1[[Aspose.Email.Exchange.ExchangeMessageInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IList`1[[Aspose.Email.Exchange.ExchangeMessageInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Email.Exchange.ExchangeMessageInfoCollection
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Exchange.ExchangeUserAvailability, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]] ---- System.Collections.Generic.ICollection`1[[Aspose.Email.Exchange.ExchangeUserAvailability, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IEnumerable`1[[Aspose.Email.Exchange.ExchangeUserAvailability, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IList`1[[Aspose.Email.Exchange.ExchangeUserAvailability, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Email.Exchange.ExchangeUserAvailabilityCollection
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Exchange.ExchangeUserWorkingHours, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]] ---- System.Collections.Generic.ICollection`1[[Aspose.Email.Exchange.ExchangeUserWorkingHours, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IEnumerable`1[[Aspose.Email.Exchange.ExchangeUserWorkingHours, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IList`1[[Aspose.Email.Exchange.ExchangeUserWorkingHours, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Email.Exchange.ExchangeUserWorkingHoursCollection
System.EventArgs
Aspose.Email.Exchange.ServerNotificationEventArgs
System.Exception ---- System.Runtime.Serialization.ISerializable
Aspose.Email.AsposeException
Aspose.Email.Exchange.ExchangeException
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Email.Exchange.CalendarItemCreateOrDeleteOperation
Aspose.Email.Exchange.ConnectionFailureCause
Aspose.Email.Exchange.DeleteTaskOptions
Aspose.Email.Exchange.EmptyFolderOptions
Aspose.Email.Exchange.EventTypes
Aspose.Email.Exchange.ExchangeCalendarPermissionLevel
Aspose.Email.Exchange.ExchangeCalendarPermissionReadAccess
Aspose.Email.Exchange.ExchangeConversationFlagStatus
Aspose.Email.Exchange.ExchangeDelegateFolderPermissionLevel
Aspose.Email.Exchange.ExchangeDelegateOptions
Aspose.Email.Exchange.ExchangeFolderPermissionAction
Aspose.Email.Exchange.ExchangeFolderPermissionLevel
Aspose.Email.Exchange.ExchangeFolderPermissionReadAccess
Aspose.Email.Exchange.ExchangeFolderUserType
Aspose.Email.Exchange.ExchangeListContactsOptions
Aspose.Email.Exchange.ExchangeListMessagesOptions
Aspose.Email.Exchange.ExchangeMessageFlag
Aspose.Email.Exchange.ExchangeTaskStatus
Aspose.Email.Exchange.ExchangeUserBusyness
Aspose.Email.Exchange.ExchangeVersion
Aspose.Email.Exchange.FlaggedForAction
Aspose.Email.Exchange.ImportanceChoices
Aspose.Email.Exchange.ItemChoice
Aspose.Email.Exchange.KnownFolderTypes
Aspose.Email.Exchange.MailTipsType
Aspose.Email.Exchange.MessageTrackingReportTemplate
Aspose.Email.Exchange.PhoneCallState
Aspose.Email.Exchange.RulePredicateFlags
Aspose.Email.Exchange.SensitivityChoices
Aspose.Email.Exchange.TaskRegeneratingType
Aspose.Email.Exchange.UpdateTaskOptions

See Also

Aspose.Email.Exchange Namespace


Aspose.Email.Formats.MboxHierarchy

Aspose.Email

Aspose.Email.Formats.Mbox Hierarchy

System.Object
Aspose.Email.Formats.Mbox.MboxStorageReader ---- System.IDisposable
Aspose.Email.Formats.Mbox.MboxrdStorageReader
Aspose.Email.Formats.Mbox.MboxStorageWriter ---- System.IDisposable
Aspose.Email.Formats.Mbox.MboxrdStorageWriter

See Also

Aspose.Email.Formats.Mbox Namespace


Aspose.Email.Formats.Outlook.MsgHierarchy

Aspose.Email

Aspose.Email.Formats.Outlook.Msg Hierarchy

System.Object
Aspose.Email.Formats.Outlook.Msg.CustomAttachmentStorage
Aspose.Email.Formats.Outlook.Msg.IMessageObjectPropertyContainer
Aspose.Email.Formats.Outlook.Msg.MapiGuidConstants
Aspose.Email.Formats.Outlook.Msg.MessageObject ---- Aspose.Email.Formats.Outlook.Msg.IMessageObjectPropertyContainer
Aspose.Email.Formats.Outlook.Msg.MessageObjectAttachmentEntity ---- Aspose.Email.Formats.Outlook.Msg.IMessageObjectPropertyContainer
Aspose.Email.Formats.Outlook.Msg.MessageObjectProperty
Aspose.Email.Formats.Outlook.Msg.MessageObjectRecipientEntity ---- Aspose.Email.Formats.Outlook.Msg.IMessageObjectPropertyContainer
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Formats.Outlook.Msg.MessageObjectAttachmentEntity, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]] ---- System.Collections.Generic.ICollection`1[[Aspose.Email.Formats.Outlook.Msg.MessageObjectAttachmentEntity, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IEnumerable`1[[Aspose.Email.Formats.Outlook.Msg.MessageObjectAttachmentEntity, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IList`1[[Aspose.Email.Formats.Outlook.Msg.MessageObjectAttachmentEntity, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Email.Formats.Outlook.Msg.MessageObjectAttachmentsCollection
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Formats.Outlook.Msg.MessageObjectProperty, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]] ---- System.Collections.Generic.ICollection`1[[Aspose.Email.Formats.Outlook.Msg.MessageObjectProperty, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IEnumerable`1[[Aspose.Email.Formats.Outlook.Msg.MessageObjectProperty, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IList`1[[Aspose.Email.Formats.Outlook.Msg.MessageObjectProperty, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
System.Collections.ObjectModel.KeyedCollection`2[[System.Int64, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089],[Aspose.Email.Formats.Outlook.Msg.MessageObjectProperty, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]]
Aspose.Email.Formats.Outlook.Msg.MessageObjectPropertiesCollection
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Formats.Outlook.Msg.MessageObjectRecipientEntity, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]] ---- System.Collections.Generic.ICollection`1[[Aspose.Email.Formats.Outlook.Msg.MessageObjectRecipientEntity, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IEnumerable`1[[Aspose.Email.Formats.Outlook.Msg.MessageObjectRecipientEntity, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IList`1[[Aspose.Email.Formats.Outlook.Msg.MessageObjectRecipientEntity, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Email.Formats.Outlook.Msg.MessageObjectRecipientsCollection
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Email.Formats.Outlook.Msg.MapiPropertyFlags
Aspose.Email.Formats.Outlook.Msg.MapiType
Aspose.Email.Formats.Outlook.Msg.MessageObjectLoadFormat
Aspose.Email.Formats.Outlook.Msg.MessageObjectSaveFormat
Aspose.Email.Formats.Outlook.Msg.NamedPropertyKind

See Also

Aspose.Email.Formats.Outlook.Msg Namespace


Aspose.Email.Formats.OutlookHierarchy

Aspose.Email

Aspose.Email.Formats.Outlook Hierarchy

System.Object
Aspose.Email.Formats.Outlook.InlineAttachmentExtractor

See Also

Aspose.Email.Formats.Outlook Namespace


Aspose.Email.Formats.VCardHierarchy

Aspose.Email

Aspose.Email.Formats.VCard Hierarchy

System.Object
Aspose.Email.Formats.VCard.VCardAgent
Aspose.Email.Formats.VCard.VCardContact
Aspose.Email.Formats.VCard.VCardDeliveryAddress
Aspose.Email.Formats.VCard.VCardEmail
Aspose.Email.Formats.VCard.VCardExplanatoryInfo
Aspose.Email.Formats.VCard.VCardFullName
Aspose.Email.Formats.VCard.VCardGeo
Aspose.Email.Formats.VCard.VCardIdentificationInfo
Aspose.Email.Formats.VCard.VCardOrganization
Aspose.Email.Formats.VCard.VCardPhoto
Aspose.Email.Formats.VCard.VCardSecurity
Aspose.Email.Formats.VCard.VCardSound
Aspose.Email.Formats.VCard.VCardTelephoneNumber
Aspose.Email.Formats.VCard.VCardUrl
Aspose.Email.Outlook.ContactSaveOptions
Aspose.Email.Formats.VCard.VCardSaveOptions
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Formats.VCard.VCardDeliveryAddress, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]] ---- System.Collections.Generic.ICollection`1[[Aspose.Email.Formats.VCard.VCardDeliveryAddress, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IEnumerable`1[[Aspose.Email.Formats.VCard.VCardDeliveryAddress, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IList`1[[Aspose.Email.Formats.VCard.VCardDeliveryAddress, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Email.Formats.VCard.VCardDeliveryAddressCollection
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Formats.VCard.VCardEmail, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]] ---- System.Collections.Generic.ICollection`1[[Aspose.Email.Formats.VCard.VCardEmail, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IEnumerable`1[[Aspose.Email.Formats.VCard.VCardEmail, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IList`1[[Aspose.Email.Formats.VCard.VCardEmail, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Email.Formats.VCard.VCardEmailCollection
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Formats.VCard.VCardTelephoneNumber, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]] ---- System.Collections.Generic.ICollection`1[[Aspose.Email.Formats.VCard.VCardTelephoneNumber, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IEnumerable`1[[Aspose.Email.Formats.VCard.VCardTelephoneNumber, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IList`1[[Aspose.Email.Formats.VCard.VCardTelephoneNumber, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Email.Formats.VCard.VCardTelephoneNumberCollection
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Formats.VCard.VCardUrl, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]] ---- System.Collections.Generic.ICollection`1[[Aspose.Email.Formats.VCard.VCardUrl, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IEnumerable`1[[Aspose.Email.Formats.VCard.VCardUrl, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IList`1[[Aspose.Email.Formats.VCard.VCardUrl, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Email.Formats.VCard.VCardUrlCollection
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Email.Formats.VCard.VCardDeliveryAddressType
Aspose.Email.Formats.VCard.VCardEmailType
Aspose.Email.Formats.VCard.VCardPhotoType
Aspose.Email.Formats.VCard.VCardSoundType
Aspose.Email.Formats.VCard.VCardTelephoneType
Aspose.Email.Formats.VCard.VCardUrlType
Aspose.Email.Formats.VCard.VCardValueLocation
Aspose.Email.Formats.VCard.VCardVersion

See Also

Aspose.Email.Formats.VCard Namespace


Aspose.Email.FormatsHierarchy

Aspose.Email

Aspose.Email.Formats Hierarchy

System.Object
Aspose.Email.Formats.MailStorageConverter

See Also

Aspose.Email.Formats Namespace


Aspose.Email.GoogleHierarchy

Aspose.Email

Aspose.Email.Google Hierarchy

System.Object
Aspose.Email.Google.AclScope
Aspose.Email.Google.BaseDataObject
Aspose.Email.Google.AccessControlRule
Aspose.Email.Google.Calendar
Aspose.Email.Google.ExtendedCalendar
Aspose.Email.Google.Colors
Aspose.Email.Google.ColorsInfo
Aspose.Email.Google.ErrorDetails
Aspose.Email.Google.FreebusyCalendarInfo
Aspose.Email.Google.FreebusyGroupInfo
Aspose.Email.Google.FreebusyQuery
Aspose.Email.Google.FreebusyResponse
Aspose.Email.Google.Gadget
Aspose.Email.Google.GmailClient ---- Aspose.Email.Google.IBaseGmailClient, System.IDisposable
Aspose.Email.Google.IBaseGmailClient ---- System.IDisposable
Aspose.Email.Google.IGmailClient ---- Aspose.Email.Google.IBaseGmailClient, System.IDisposable
Aspose.Email.Google.Range
Aspose.Email.Google.Reminders
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Email.Google.AccessRole
Aspose.Email.Google.AclScopeType
Aspose.Email.Google.NotificationMethod
Aspose.Email.Google.NotificationType
Aspose.Email.Google.ReminderMethods

See Also

Aspose.Email.Google Namespace


Aspose.Email.ImapHierarchy

Aspose.Email

Aspose.Email.Imap Hierarchy

System.Object
Aspose.Email.CredentialsByHostClient ---- System.IDisposable
Aspose.Email.Imap.ImapClient
Aspose.Email.Imap.ImapAuthentication
Aspose.Email.Imap.ImapFolderInfo
Aspose.Email.Imap.ImapMessageFlags
Aspose.Email.Imap.ImapMessageInfo ---- System.IDisposable
Aspose.Email.Imap.ImapResponse
Aspose.Email.Imap.SequenceSetBaseValue
Aspose.Email.Imap.RangeSeqSet
Aspose.Email.Imap.SimpleSeqSet
Aspose.Email.MailQueryBuilder
Aspose.Email.Imap.ImapQueryBuilder
Aspose.Email.QueryField
Aspose.Email.Imap.SequenceSetField
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Imap.ImapFolderInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]] ---- System.Collections.Generic.ICollection`1[[Aspose.Email.Imap.ImapFolderInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IEnumerable`1[[Aspose.Email.Imap.ImapFolderInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IList`1[[Aspose.Email.Imap.ImapFolderInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Email.Imap.ImapFolderInfoCollection
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Imap.ImapMessageInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]] ---- System.Collections.Generic.ICollection`1[[Aspose.Email.Imap.ImapMessageInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IEnumerable`1[[Aspose.Email.Imap.ImapMessageInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IList`1[[Aspose.Email.Imap.ImapMessageInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Email.Imap.ImapMessageInfoCollection
System.Exception ---- System.Runtime.Serialization.ISerializable
Aspose.Email.Imap.FetchTimeoutException
Aspose.Email.Imap.ImapException
Aspose.Email.Imap.ReadLinesTimeoutException
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Email.Imap.ImapCommandResult
Aspose.Email.Imap.ImapSslSecurityMode
Aspose.Email.Imap.ImapStatusCode

See Also

Aspose.Email.Imap Namespace


Aspose.Email.LoggingHierarchy

Aspose.Email

Aspose.Email.Logging Hierarchy

System.Object
Aspose.Email.Logging.Appender ---- Aspose.Email.Logging.IAppender, System.IDisposable
Aspose.Email.Logging.ConsoleAppender
Aspose.Email.Logging.DebugAppender
Aspose.Email.Logging.FileAppender
Aspose.Email.Logging.NullAppender
Aspose.Email.Logging.Formatter ---- Aspose.Email.Logging.IFormatter
Aspose.Email.Logging.SimpleFormatter
Aspose.Email.Logging.StandardFormatter
Aspose.Email.Logging.IAppender
Aspose.Email.Logging.IFormatter
Aspose.Email.Logging.LogEntry ---- System.ICloneable
Aspose.Email.Logging.Logger
Aspose.Email.Logging.LoggerManager
Aspose.Email.Logging.LogLevel ---- System.IComparable
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Logging.IAppender, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]] ---- System.Collections.Generic.ICollection`1[[Aspose.Email.Logging.IAppender, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IEnumerable`1[[Aspose.Email.Logging.IAppender, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IList`1[[Aspose.Email.Logging.IAppender, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Email.Logging.AppenderCollection
System.Exception ---- System.Runtime.Serialization.ISerializable
Aspose.Email.Logging.LoggingException

See Also

Aspose.Email.Logging Namespace


Aspose.Email.Mail.CalendaringHierarchy

Aspose.Email

Aspose.Email.Mail.Calendaring Hierarchy

System.Object
Aspose.Email.Mail.Calendaring.RecurrencePattern
Aspose.Email.Mail.Calendaring.DailyRecurrencePattern
Aspose.Email.Mail.Calendaring.MonthlyRecurrencePattern
Aspose.Email.Mail.Calendaring.WeeklyRecurrencePattern
Aspose.Email.Mail.Calendaring.YearlyRecurrencePattern
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Email.Mail.Calendaring.CalendarDay
Aspose.Email.Mail.Calendaring.CalendarMonth
Aspose.Email.Mail.Calendaring.DayPosition

See Also

Aspose.Email.Mail.Calendaring Namespace


Aspose.Email.MailHierarchy

Aspose.Email

Aspose.Email.Mail Hierarchy

System.Object
Aspose.Email.CredentialsByHostClient ---- System.IDisposable
Aspose.Email.Mail.SmtpClient ---- Aspose.Email.Mail.IMailTransferAgent
Aspose.Email.Mail.Appointment
Aspose.Email.Mail.AppointmentFormattingOptions
Aspose.Email.Mail.AppointmentReminder
Aspose.Email.Mail.AppointmentSaveOptions
Aspose.Email.Mail.IcsSaveOptions
Aspose.Email.Mail.AttachmentBase ---- System.IDisposable
Aspose.Email.Mail.AlternateView
Aspose.Email.Mail.Attachment ---- Aspose.Email.Mail.IAttachment, Aspose.Email.Mime.IPreferredTextEncodingProvider
Aspose.Email.Mail.LinkedResource
Aspose.Email.Mail.EmlValidationError
Aspose.Email.Mail.HeaderType
Aspose.Email.Mail.IAttachment
Aspose.Email.Mail.IMailAddress
Aspose.Email.Mail.IMailTransferAgent ---- System.IDisposable
Aspose.Email.Mail.IMessage
Aspose.Email.Mail.IMessageFormatter
Aspose.Email.Mail.MailAddress ---- Aspose.Email.Mail.IMailAddress
Aspose.Email.Mail.MailboxConverter
Aspose.Email.Mail.MailMessage ---- Aspose.Email.Mail.IMessage, Aspose.Email.Mime.IPreferredTextEncodingProvider, System.Collections.Generic.IEnumerable`1[[Aspose.Email.Mail.MailMessage, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.IEnumerable, System.IDisposable, System.Runtime.Serialization.ISerializable
Aspose.Email.Mail.MailMessageLoadOptions
Aspose.Email.Mail.MailMessageSaveType
Aspose.Email.Mail.MesageLoadOptions
Aspose.Email.Mail.MessageFormat
Aspose.Email.Mail.MhtMessageFormatter ---- Aspose.Email.Mail.IMessageFormatter
Aspose.Email.Mail.ReminderAttachment
Aspose.Email.Mail.ReminderAttendee
Aspose.Email.Mail.ReminderDuration
Aspose.Email.Mail.ReminderTrigger
Aspose.Email.Mail.SmtpAuthentication
Aspose.Email.Mail.SmtpClientBulkSendAgent ---- System.IDisposable
Aspose.Email.Mail.Task ---- System.IDisposable
Aspose.Email.Mail.TemplateEngine
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Mail.AlternateView, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]] ---- System.Collections.Generic.ICollection`1[[Aspose.Email.Mail.AlternateView, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IEnumerable`1[[Aspose.Email.Mail.AlternateView, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IList`1[[Aspose.Email.Mail.AlternateView, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Email.Mail.AlternateViewCollection ---- System.IDisposable
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Mail.AppointmentReminder, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]] ---- System.Collections.Generic.ICollection`1[[Aspose.Email.Mail.AppointmentReminder, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IEnumerable`1[[Aspose.Email.Mail.AppointmentReminder, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IList`1[[Aspose.Email.Mail.AppointmentReminder, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Email.Mail.AppointmentReminderCollection
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Mail.Attachment, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]] ---- System.Collections.Generic.ICollection`1[[Aspose.Email.Mail.Attachment, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IEnumerable`1[[Aspose.Email.Mail.Attachment, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IList`1[[Aspose.Email.Mail.Attachment, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Email.Mail.AttachmentCollection ---- System.IDisposable
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Mail.EmlValidationError, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]] ---- System.Collections.Generic.ICollection`1[[Aspose.Email.Mail.EmlValidationError, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IEnumerable`1[[Aspose.Email.Mail.EmlValidationError, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IList`1[[Aspose.Email.Mail.EmlValidationError, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Email.Mail.EmlValidationErrorCollection
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Mail.LinkedResource, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]] ---- System.Collections.Generic.ICollection`1[[Aspose.Email.Mail.LinkedResource, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IEnumerable`1[[Aspose.Email.Mail.LinkedResource, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IList`1[[Aspose.Email.Mail.LinkedResource, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Email.Mail.LinkedResourceCollection ---- System.IDisposable
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Mail.MailAddress, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]] ---- System.Collections.Generic.ICollection`1[[Aspose.Email.Mail.MailAddress, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IEnumerable`1[[Aspose.Email.Mail.MailAddress, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IList`1[[Aspose.Email.Mail.MailAddress, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Email.Mail.MailAddressCollection
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Mail.MailMessage, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]] ---- System.Collections.Generic.ICollection`1[[Aspose.Email.Mail.MailMessage, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IEnumerable`1[[Aspose.Email.Mail.MailMessage, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IList`1[[Aspose.Email.Mail.MailMessage, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Email.Mail.MailMessageCollection
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Mail.ReminderAttachment, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]] ---- System.Collections.Generic.ICollection`1[[Aspose.Email.Mail.ReminderAttachment, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IEnumerable`1[[Aspose.Email.Mail.ReminderAttachment, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IList`1[[Aspose.Email.Mail.ReminderAttachment, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Email.Mail.ReminderAttachmentCollection
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Mail.ReminderAttendee, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]] ---- System.Collections.Generic.ICollection`1[[Aspose.Email.Mail.ReminderAttendee, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IEnumerable`1[[Aspose.Email.Mail.ReminderAttendee, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IList`1[[Aspose.Email.Mail.ReminderAttendee, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Email.Mail.ReminderAttendeeCollection
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
Aspose.Email.Mail.MessageAcceptanceCallback
Aspose.Email.Mail.SendCompletedEventHandler
Aspose.Email.Mail.TemplateRoutine
System.EventArgs
Aspose.Email.Mail.SmtpClientBulkSendEventArgs
System.Exception ---- System.Runtime.Serialization.ISerializable
Aspose.Email.Mail.MailException
Aspose.Email.Mail.SmtpException
Aspose.Email.Mail.SmtpFailedBulkSendException
Aspose.Email.Mail.SmtpFailedRecipientException
Aspose.Email.Mail.SmtpFailedRecipientsException
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Email.Mail.AppointmentAction
Aspose.Email.Mail.AppointmentFlags
Aspose.Email.Mail.AppointmentMethodType
Aspose.Email.Mail.AppointmentSaveFormat
Aspose.Email.Mail.AppointmentStatus
Aspose.Email.Mail.AppointmentTransparency
Aspose.Email.Mail.DeliveryNotificationOptions
Aspose.Email.Mail.EmlValidationErrorType
Aspose.Email.Mail.FileCompatibilityMode
Aspose.Email.Mail.MailMessageSaveOptions
Aspose.Email.Mail.MailPriority
Aspose.Email.Mail.MailSensitivity
Aspose.Email.Mail.MhtFormatOptions
Aspose.Email.Mail.MSBusyStatus
Aspose.Email.Mail.MSIntendedStatus
Aspose.Email.Mail.ReminderAction
Aspose.Email.Mail.ReminderRelated
Aspose.Email.Mail.SmtpDeliveryMethod
Aspose.Email.Mail.SmtpSslSecurityMode
Aspose.Email.Mail.SmtpStatusCode
Aspose.Email.Mail.TIPMethod

See Also

Aspose.Email.Mail Namespace


Aspose.Email.MimeHierarchy

Aspose.Email

Aspose.Email.Mime Hierarchy

System.Object
Aspose.Email.Mime.ContentDisposition
Aspose.Email.Mime.ContentType
Aspose.Email.Mime.DispositionTypeNames
Aspose.Email.Mime.HeaderCollection ---- System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Email.Mime.HeaderCollection.KeysCollection ---- System.Collections.ICollection, System.Collections.IEnumerable
Aspose.Email.Mime.IPreferredTextEncodingProvider
Aspose.Email.Mime.MediaTypeNames
Aspose.Email.Mime.MediaTypeNames.Application
Aspose.Email.Mime.MediaTypeNames.Image
Aspose.Email.Mime.MediaTypeNames.Text
Aspose.Email.Mime.MimeHeader
System.Exception ---- System.Runtime.Serialization.ISerializable
Aspose.Email.Mime.MimeException
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Email.Mime.TransferEncoding

See Also

Aspose.Email.Mime Namespace


Aspose.Email.OAuthHierarchy

Aspose.Email

Aspose.Email.OAuth Hierarchy

System.Object
Aspose.Email.OAuth.GoogleTokenProvider ---- Aspose.Email.OAuth.ITokenProvider, System.IDisposable
Aspose.Email.OAuth.ITokenProvider ---- System.IDisposable
Aspose.Email.OAuth.OAuthToken
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Email.OAuth.TokenType

See Also

Aspose.Email.OAuth Namespace


Aspose.Email.Outlook.PstHierarchy

Aspose.Email

Aspose.Email.Outlook.Pst Hierarchy

System.Object
Aspose.Email.MailQueryBuilder
Aspose.Email.Outlook.Pst.PersonalStorageQueryBuilder
Aspose.Email.Outlook.Pst.FolderInfo
Aspose.Email.Outlook.Pst.MessageInfo
Aspose.Email.Outlook.Pst.PersonalStorage ---- System.IDisposable
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Outlook.Pst.FolderInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]] ---- System.Collections.Generic.ICollection`1[[Aspose.Email.Outlook.Pst.FolderInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IEnumerable`1[[Aspose.Email.Outlook.Pst.FolderInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IList`1[[Aspose.Email.Outlook.Pst.FolderInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Email.Outlook.Pst.FolderInfoCollection
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Outlook.Pst.MessageInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]] ---- System.Collections.Generic.ICollection`1[[Aspose.Email.Outlook.Pst.MessageInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IEnumerable`1[[Aspose.Email.Outlook.Pst.MessageInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IList`1[[Aspose.Email.Outlook.Pst.MessageInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Email.Outlook.Pst.MessageInfoCollection
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
Aspose.Email.Outlook.Pst.ItemMovedEventHandler
Aspose.Email.Outlook.Pst.MessageAddedEventHandler
System.EventArgs
Aspose.Email.Outlook.Pst.ItemMovedEventArgs
Aspose.Email.Outlook.Pst.MessageAddedEventArgs
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Email.Outlook.Pst.BackupOptions
Aspose.Email.Outlook.Pst.FileFormat
Aspose.Email.Outlook.Pst.FileFormatVersion
Aspose.Email.Outlook.Pst.MapiImportance
Aspose.Email.Outlook.Pst.MapiSensitivity
Aspose.Email.Outlook.Pst.RestoreOptions
Aspose.Email.Outlook.Pst.StandardIpmFolder

See Also

Aspose.Email.Outlook.Pst Namespace


Aspose.Email.OutlookHierarchy

Aspose.Email

Aspose.Email.Outlook Hierarchy

System.Object
Aspose.Email.Outlook.ContactSaveOptions
Aspose.Email.Outlook.FollowUpManager
Aspose.Email.Outlook.FollowUpOptions
Aspose.Email.Outlook.IMapiMessageItem
Aspose.Email.Outlook.MailMessageInterpretor
Aspose.Email.Outlook.ActivityMailMessageInterpretor
Aspose.Email.Outlook.AppointmentMailMessageInterpretor
Aspose.Email.Outlook.ContactMailMessageInterpretor
Aspose.Email.Outlook.NDRReportMailMessageInterpretor
Aspose.Email.Outlook.NormalMessageMailMessageInterpretor
Aspose.Email.Outlook.MailMessageInterpretorFactory
Aspose.Email.Outlook.MapiCalendar ---- Aspose.Email.Outlook.IMapiMessageItem
Aspose.Email.Outlook.MapiCalendarAttendees
Aspose.Email.Outlook.MapiCalendarEventRecurrence
Aspose.Email.Outlook.MapiCalendarRecurrencePattern
Aspose.Email.Outlook.MapiCalendarDailyRecurrencePattern
Aspose.Email.Outlook.MapiCalendarMonthlyNthRecurrencePattern
Aspose.Email.Outlook.MapiCalendarMonthlyRecurrencePattern
Aspose.Email.Outlook.MapiCalendarWeeklyRecurrencePattern
Aspose.Email.Outlook.MapiCalendarTimeZone
Aspose.Email.Outlook.MapiCalendarTimeZoneInfo
Aspose.Email.Outlook.MapiCalendarTimeZoneRule
Aspose.Email.Outlook.MapiContact ---- Aspose.Email.Outlook.IMapiMessageItem
Aspose.Email.Outlook.MapiContactElectronicAddress
Aspose.Email.Outlook.MapiContactElectronicAddressPropertySet
Aspose.Email.Outlook.MapiContactEventPropertySet
Aspose.Email.Outlook.MapiContactNamePropertySet
Aspose.Email.Outlook.MapiContactPersonalInfoPropertySet
Aspose.Email.Outlook.MapiContactPhoto
Aspose.Email.Outlook.MapiContactPhysicalAddress
Aspose.Email.Outlook.MapiContactPhysicalAddressPropertySet
Aspose.Email.Outlook.MapiContactProfessionalPropertySet
Aspose.Email.Outlook.MapiContactTelephonePropertySet
Aspose.Email.Outlook.MapiDistributionList ---- Aspose.Email.Outlook.IMapiMessageItem
Aspose.Email.Outlook.MapiDistributionListMember
Aspose.Email.Outlook.MapiElectronicAddress
Aspose.Email.Outlook.MapiJournal ---- Aspose.Email.Outlook.IMapiMessageItem
Aspose.Email.Outlook.MapiMessageReader ---- System.IDisposable
Aspose.Email.Outlook.MapiNote ---- Aspose.Email.Outlook.IMapiMessageItem
Aspose.Email.Outlook.MapiProperty
Aspose.Email.Outlook.MapiNamedProperty
Aspose.Email.Outlook.MapiObjectProperty
Aspose.Email.Outlook.MapiPropertyCollection ---- System.Collections.ICollection, System.Collections.IDictionary, System.Collections.IEnumerable
Aspose.Email.Outlook.MapiPropertyContainer
Aspose.Email.Outlook.MapiAttachment
Aspose.Email.Outlook.MapiMessage ---- Aspose.Email.Outlook.IMapiMessageItem, System.ICloneable, System.IDisposable
Aspose.Email.Outlook.MapiNamedPropertyMappingStorage
Aspose.Email.Outlook.MapiPropertyStream
Aspose.Email.Outlook.MapiAttachmentPropertyStream
Aspose.Email.Outlook.MapiMessagePropertyStream
Aspose.Email.Outlook.MapiRecipientPropertyStream
Aspose.Email.Outlook.MapiRecipient
Aspose.Email.Outlook.MapiPropertyTag
Aspose.Email.Outlook.MapiTask ---- Aspose.Email.Outlook.IMapiMessageItem
Aspose.Email.Outlook.MapiTaskUsers
Aspose.Email.Outlook.OleDocumentFormat
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Outlook.MapiAttachment, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]] ---- System.Collections.Generic.ICollection`1[[Aspose.Email.Outlook.MapiAttachment, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IEnumerable`1[[Aspose.Email.Outlook.MapiAttachment, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IList`1[[Aspose.Email.Outlook.MapiAttachment, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Email.Outlook.MapiAttachmentCollection
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Outlook.MapiCalendarTimeZoneInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]] ---- System.Collections.Generic.ICollection`1[[Aspose.Email.Outlook.MapiCalendarTimeZoneInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IEnumerable`1[[Aspose.Email.Outlook.MapiCalendarTimeZoneInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IList`1[[Aspose.Email.Outlook.MapiCalendarTimeZoneInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Email.Outlook.MapiCalendarTimeZoneInfoCollection
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Outlook.MapiContact, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]] ---- System.Collections.Generic.ICollection`1[[Aspose.Email.Outlook.MapiContact, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IEnumerable`1[[Aspose.Email.Outlook.MapiContact, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IList`1[[Aspose.Email.Outlook.MapiContact, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Email.Outlook.MapiContactCollection
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Outlook.MapiDistributionListMember, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]] ---- System.Collections.Generic.ICollection`1[[Aspose.Email.Outlook.MapiDistributionListMember, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IEnumerable`1[[Aspose.Email.Outlook.MapiDistributionListMember, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IList`1[[Aspose.Email.Outlook.MapiDistributionListMember, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Email.Outlook.MapiDistributionListMemberCollection
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Outlook.MapiRecipient, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]] ---- System.Collections.Generic.ICollection`1[[Aspose.Email.Outlook.MapiRecipient, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IEnumerable`1[[Aspose.Email.Outlook.MapiRecipient, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IList`1[[Aspose.Email.Outlook.MapiRecipient, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Email.Outlook.MapiRecipientCollection
System.Exception ---- System.Runtime.Serialization.ISerializable
Aspose.Email.Outlook.MapiMessageParseException
System.SystemException
System.IO.IOException
Aspose.Email.Outlook.FileAccessViolationException
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Email.Outlook.BodyContentType
Aspose.Email.Outlook.ContactSaveFormat
Aspose.Email.Outlook.MapiCalendarBusyStatus
Aspose.Email.Outlook.MapiCalendarClientIntent
Aspose.Email.Outlook.MapiCalendarDayOfWeek
Aspose.Email.Outlook.MapiCalendarRecurrenceCalendarType
Aspose.Email.Outlook.MapiCalendarRecurrenceEndType
Aspose.Email.Outlook.MapiCalendarRecurrenceFrequency
Aspose.Email.Outlook.MapiCalendarRecurrencePatternType
Aspose.Email.Outlook.MapiCalendarTimeZoneFlags
Aspose.Email.Outlook.MapiContactGender
Aspose.Email.Outlook.MapiContactPhotoImageFormat
Aspose.Email.Outlook.MapiDistributionListContactAddressType
Aspose.Email.Outlook.MapiDistributionListEntryIdType
Aspose.Email.Outlook.MapiJournalDocumentStatus
Aspose.Email.Outlook.MapiJournalFlags
Aspose.Email.Outlook.MapiMessageFlags
Aspose.Email.Outlook.MapiObjectType
Aspose.Email.Outlook.MapiPropertyType
Aspose.Email.Outlook.MapiRecipientType
Aspose.Email.Outlook.MapiTaskAcceptanceState
Aspose.Email.Outlook.MapiTaskFlags
Aspose.Email.Outlook.MapiTaskHistory
Aspose.Email.Outlook.MapiTaskMode
Aspose.Email.Outlook.MapiTaskOwnership
Aspose.Email.Outlook.MapiTaskState
Aspose.Email.Outlook.MapiTaskStatus
Aspose.Email.Outlook.NoteColor
Aspose.Email.Outlook.NoteSaveFormat
Aspose.Email.Outlook.OutlookMessageFormat
Aspose.Email.Outlook.TaskSaveFormat

See Also

Aspose.Email.Outlook Namespace


Aspose.Email.Pop3Hierarchy

Aspose.Email

Aspose.Email.Pop3 Hierarchy

System.Object
Aspose.Email.CredentialsByHostClient ---- System.IDisposable
Aspose.Email.Pop3.Pop3Client
Aspose.Email.Pop3.Pop3Authentication
Aspose.Email.Pop3.Pop3MailboxInfo
Aspose.Email.Pop3.Pop3MessageInfo ---- System.IDisposable
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Pop3.Pop3MessageInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]] ---- System.Collections.Generic.ICollection`1[[Aspose.Email.Pop3.Pop3MessageInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IEnumerable`1[[Aspose.Email.Pop3.Pop3MessageInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IList`1[[Aspose.Email.Pop3.Pop3MessageInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Email.Pop3.Pop3MessageInfoCollection
System.Exception ---- System.Runtime.Serialization.ISerializable
Aspose.Email.Pop3.Pop3Exception
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Email.Pop3.Pop3ConnectionState
Aspose.Email.Pop3.Pop3ListFields
Aspose.Email.Pop3.Pop3SslSecurityMode

See Also

Aspose.Email.Pop3 Namespace


Aspose.Email.PrintingHierarchy

Aspose.Email

Aspose.Email.Printing Hierarchy

System.Object
Aspose.Email.Printing.IPrintSettingsProvider
Aspose.Email.Printing.MailPrinter ---- Aspose.Email.Printing.IPrintSettingsProvider
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Email.Printing.MessageFormattingFlags
Aspose.Email.Printing.PrinterUnit
Aspose.Email.Printing.PrintFormat

See Also

Aspose.Email.Printing Namespace


Aspose.Email.Protocols.ActiveSync.TransportLayer.NamespacesHierarchy

Aspose.Email

Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces Hierarchy

System.Object
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.AirSync
Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.AirSyncBase
Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.Calendar
Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.ComposeMail
Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.Contacts
Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.Contacts2
Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.DocumentLibrary
Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.Email
Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.Email2
Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.FolderHierarchy
Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.GAL
Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.GetItemEstimate
Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.ItemOperations
Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.MeetingResponse
Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.Move
Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.Namespace
Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.Notes
Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.Ping
Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.Provision
Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.ResolveRecipients
Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.RightsManagement
Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.Search
Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.Settings
Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.Tasks
Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces.ValidateCert

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer.Namespaces Namespace


Aspose.Email.Protocols.ActiveSync.TransportLayerHierarchy

Aspose.Email

Aspose.Email.Protocols.ActiveSync.TransportLayer Hierarchy

System.Object
Aspose.Email.Common.Commands.CommandStatus
Aspose.Email.Protocols.ActiveSync.TransportLayer.Status
Aspose.Email.Protocols.ActiveSync.TransportLayer.AccountInformation
Aspose.Email.Protocols.ActiveSync.TransportLayer.ActiveSyncTLClient ---- Aspose.Email.Protocols.ActiveSync.TransportLayer.IBaseActiveSyncTLClient, System.IDisposable
Aspose.Email.Protocols.ActiveSync.TransportLayer.AutodiscoverResult
Aspose.Email.Protocols.ActiveSync.TransportLayer.Body
Aspose.Email.Protocols.ActiveSync.TransportLayer.BodyPart
Aspose.Email.Protocols.ActiveSync.TransportLayer.BodyPreference
Aspose.Email.Protocols.ActiveSync.TransportLayer.CertificateStatuses
Aspose.Email.Protocols.ActiveSync.TransportLayer.DataContainer ---- System.Collections.Generic.IEnumerable`1[[Aspose.Email.Protocols.ActiveSync.TransportLayer.DataContainer, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.IEnumerable
Aspose.Email.Protocols.ActiveSync.TransportLayer.DeviceInformation
Aspose.Email.Protocols.ActiveSync.TransportLayer.DevicePasswordRequest
Aspose.Email.Protocols.ActiveSync.TransportLayer.EASProvisionDoc
Aspose.Email.Protocols.ActiveSync.TransportLayer.EmptyFolderContentsRequest
Aspose.Email.Protocols.ActiveSync.TransportLayer.FolderInfo
Aspose.Email.Protocols.ActiveSync.TransportLayer.FolderSyncResult
Aspose.Email.Protocols.ActiveSync.TransportLayer.IActiveSyncTLClient ---- Aspose.Email.Protocols.ActiveSync.TransportLayer.IBaseActiveSyncTLClient, System.IDisposable
Aspose.Email.Protocols.ActiveSync.TransportLayer.IBaseActiveSyncTLClient ---- System.IDisposable
Aspose.Email.Protocols.ActiveSync.TransportLayer.ItemEstimate
Aspose.Email.Protocols.ActiveSync.TransportLayer.ItemEstimateOptions
Aspose.Email.Protocols.ActiveSync.TransportLayer.ItemEstimateRequest
Aspose.Email.Protocols.ActiveSync.TransportLayer.ItemOperationsEmptFldrCntntsResponce
Aspose.Email.Protocols.ActiveSync.TransportLayer.ItemOperationsFetchProperties
Aspose.Email.Protocols.ActiveSync.TransportLayer.ItemOperationsFetchRequest
Aspose.Email.Protocols.ActiveSync.TransportLayer.ItemOperationsFetchResponce
Aspose.Email.Protocols.ActiveSync.TransportLayer.ItemOperationsMoveRequest
Aspose.Email.Protocols.ActiveSync.TransportLayer.ItemOperationsMoveResponce
Aspose.Email.Protocols.ActiveSync.TransportLayer.ItemOperationsRequest
Aspose.Email.Protocols.ActiveSync.TransportLayer.ItemOperationsResponse
Aspose.Email.Protocols.ActiveSync.TransportLayer.ItOpEmpFldCntOptions
Aspose.Email.Protocols.ActiveSync.TransportLayer.ItOpFetchOptions
Aspose.Email.Protocols.ActiveSync.TransportLayer.ItOpMoveOptions
Aspose.Email.Protocols.ActiveSync.TransportLayer.MeetingResponseRequest
Aspose.Email.Protocols.ActiveSync.TransportLayer.MeetingResponseResult
Aspose.Email.Protocols.ActiveSync.TransportLayer.MoveItemData
Aspose.Email.Protocols.ActiveSync.TransportLayer.MoveItemResponse
Aspose.Email.Protocols.ActiveSync.TransportLayer.OOFMessage
Aspose.Email.Protocols.ActiveSync.TransportLayer.OOFReqParametrs
Aspose.Email.Protocols.ActiveSync.TransportLayer.OOFRequest
Aspose.Email.Protocols.ActiveSync.TransportLayer.OOFResponse
Aspose.Email.Protocols.ActiveSync.TransportLayer.OOFSettings
Aspose.Email.Protocols.ActiveSync.TransportLayer.PictureRequest
Aspose.Email.Protocols.ActiveSync.TransportLayer.PictureRespose
Aspose.Email.Protocols.ActiveSync.TransportLayer.PingParameter
Aspose.Email.Protocols.ActiveSync.TransportLayer.ProvisionPolicy
Aspose.Email.Protocols.ActiveSync.TransportLayer.ProvisionPolicyData
Aspose.Email.Protocols.ActiveSync.TransportLayer.ProvisionRequest
Aspose.Email.Protocols.ActiveSync.TransportLayer.ProvisionResponse
Aspose.Email.Protocols.ActiveSync.TransportLayer.QueryType
Aspose.Email.Protocols.ActiveSync.TransportLayer.Recipient
Aspose.Email.Protocols.ActiveSync.TransportLayer.ResolveRecipientsAvailabilityRequest
Aspose.Email.Protocols.ActiveSync.TransportLayer.ResolveRecipientsAvailabilityResponse
Aspose.Email.Protocols.ActiveSync.TransportLayer.ResolveRecipientsCertificates
Aspose.Email.Protocols.ActiveSync.TransportLayer.ResolveRecipientsOptions
Aspose.Email.Protocols.ActiveSync.TransportLayer.ResolveRecipientsRequest
Aspose.Email.Protocols.ActiveSync.TransportLayer.ResolveRecipientsResponse
Aspose.Email.Protocols.ActiveSync.TransportLayer.RightsManagementInformationResponce
Aspose.Email.Protocols.ActiveSync.TransportLayer.RightsManagementLicense
Aspose.Email.Protocols.ActiveSync.TransportLayer.RightsManagementTemplate
Aspose.Email.Protocols.ActiveSync.TransportLayer.SearchCondition
Aspose.Email.Protocols.ActiveSync.TransportLayer.SearchOptions
Aspose.Email.Protocols.ActiveSync.TransportLayer.SearchQuery
Aspose.Email.Protocols.ActiveSync.TransportLayer.SearchRequest
Aspose.Email.Protocols.ActiveSync.TransportLayer.SearchRequestStore
Aspose.Email.Protocols.ActiveSync.TransportLayer.SearchResponse
Aspose.Email.Protocols.ActiveSync.TransportLayer.SearchResponseStore
Aspose.Email.Protocols.ActiveSync.TransportLayer.SearchResult
Aspose.Email.Protocols.ActiveSync.TransportLayer.SearchResultProperties
Aspose.Email.Protocols.ActiveSync.TransportLayer.ServerInfo
Aspose.Email.Protocols.ActiveSync.TransportLayer.SettingsRequest
Aspose.Email.Protocols.ActiveSync.TransportLayer.SettingsResponse
Aspose.Email.Protocols.ActiveSync.TransportLayer.SmartRequest
Aspose.Email.Protocols.ActiveSync.TransportLayer.SmartRequestSource
Aspose.Email.Protocols.ActiveSync.TransportLayer.SyncAddClientOperation
Aspose.Email.Protocols.ActiveSync.TransportLayer.SyncAddServerOperation
Aspose.Email.Protocols.ActiveSync.TransportLayer.SyncChangeClientOperation
Aspose.Email.Protocols.ActiveSync.TransportLayer.SyncChangeServerOperation
Aspose.Email.Protocols.ActiveSync.TransportLayer.SyncCollectionRequest
Aspose.Email.Protocols.ActiveSync.TransportLayer.SyncCollectionResponse
Aspose.Email.Protocols.ActiveSync.TransportLayer.SyncCommandsRequest
Aspose.Email.Protocols.ActiveSync.TransportLayer.SyncCommandsResponse
Aspose.Email.Protocols.ActiveSync.TransportLayer.SyncDeleteClientOperation
Aspose.Email.Protocols.ActiveSync.TransportLayer.SyncOperationResponse
Aspose.Email.Protocols.ActiveSync.TransportLayer.SyncAddResponse
Aspose.Email.Protocols.ActiveSync.TransportLayer.SyncChangeResponse
Aspose.Email.Protocols.ActiveSync.TransportLayer.SyncFetchResponse
Aspose.Email.Protocols.ActiveSync.TransportLayer.SyncOperationsResponse
Aspose.Email.Protocols.ActiveSync.TransportLayer.SyncOptions
Aspose.Email.Protocols.ActiveSync.TransportLayer.SyncRequest
Aspose.Email.Protocols.ActiveSync.TransportLayer.UserInformationResponse
Aspose.Email.Protocols.ActiveSync.TransportLayer.ValueConverter
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Email.Protocols.ActiveSync.TransportLayer.ActiveSyncAuthenticationType
Aspose.Email.Protocols.ActiveSync.TransportLayer.AirsyncClass
Aspose.Email.Protocols.ActiveSync.TransportLayer.AirsyncFilterType
Aspose.Email.Protocols.ActiveSync.TransportLayer.AllowBluetooth
Aspose.Email.Protocols.ActiveSync.TransportLayer.ASProtocolVersions
Aspose.Email.Protocols.ActiveSync.TransportLayer.BehaviorReplacement
Aspose.Email.Protocols.ActiveSync.TransportLayer.BodyType
Aspose.Email.Protocols.ActiveSync.TransportLayer.CertificateRetrieval
Aspose.Email.Protocols.ActiveSync.TransportLayer.CommandCodes
Aspose.Email.Protocols.ActiveSync.TransportLayer.CommandParameters
Aspose.Email.Protocols.ActiveSync.TransportLayer.EncryptionSMIMEAlgorithm
Aspose.Email.Protocols.ActiveSync.TransportLayer.FolderClass
Aspose.Email.Protocols.ActiveSync.TransportLayer.FolderTypes
Aspose.Email.Protocols.ActiveSync.TransportLayer.MaxAgeFilter
Aspose.Email.Protocols.ActiveSync.TransportLayer.MergedFreeBusy
Aspose.Email.Protocols.ActiveSync.TransportLayer.MIMESupport
Aspose.Email.Protocols.ActiveSync.TransportLayer.MIMETruncation
Aspose.Email.Protocols.ActiveSync.TransportLayer.MinDevicePasswordComplexCharacters
Aspose.Email.Protocols.ActiveSync.TransportLayer.OofState
Aspose.Email.Protocols.ActiveSync.TransportLayer.ProvisionPolicyStatuses
Aspose.Email.Protocols.ActiveSync.TransportLayer.ProvisionRemoteWipeStatuses
Aspose.Email.Protocols.ActiveSync.TransportLayer.RecipientType
Aspose.Email.Protocols.ActiveSync.TransportLayer.ServerType
Aspose.Email.Protocols.ActiveSync.TransportLayer.SignedSMIMEAlgorithm
Aspose.Email.Protocols.ActiveSync.TransportLayer.SMIMEEncryptionAlgorithmNegotiation
Aspose.Email.Protocols.ActiveSync.TransportLayer.StoreType
Aspose.Email.Protocols.ActiveSync.TransportLayer.UserCreatedFolderTypes
Aspose.Email.Protocols.ActiveSync.TransportLayer.UserResponse

See Also

Aspose.Email.Protocols.ActiveSync.TransportLayer Namespace


Aspose.Email.Protocols.Exchange.ExchangeDavHierarchy

Aspose.Email

Aspose.Email.Protocols.Exchange.ExchangeDav Hierarchy

System.Object
Aspose.Email.Outlook.ContactSaveOptions
Aspose.Email.Protocols.Exchange.ExchangeDav.WebDavContactSaveOptions

See Also

Aspose.Email.Protocols.Exchange.ExchangeDav Namespace


Aspose.Email.Protocols.ProxyHierarchy

Aspose.Email

Aspose.Email.Protocols.Proxy Hierarchy

System.Object
Aspose.Email.Protocols.Proxy.SocksProxy ---- System.IDisposable
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Email.Protocols.Proxy.SocksAuthenticationMethods
Aspose.Email.Protocols.Proxy.SocksVersion

See Also

Aspose.Email.Protocols.Proxy Namespace


Aspose.Email.Services.GoogleHierarchy

Aspose.Email

Aspose.Email.Services.Google Hierarchy

System.Object
Aspose.Email.Services.Google.GmailClient ---- Aspose.Email.Services.IOAuthServiceClient
Aspose.Email.Services.Google.GmailContact ---- Aspose.Email.Services.Google.IFeedEntry
Aspose.Email.Services.Google.GmailContactGroup ---- Aspose.Email.Services.Google.IFeedEntry
Aspose.Email.Services.Google.GmailContactInfo
Aspose.Email.Services.Google.GmailContactEmail
Aspose.Email.Services.Google.GmailContactIm
Aspose.Email.Services.Google.GmailContactOrganization
Aspose.Email.Services.Google.GmailContactPhoneNumber
Aspose.Email.Services.Google.GmailContactPostalAddress
Aspose.Email.Services.Google.GmailContactName
Aspose.Email.Services.Google.IFeedEntry
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Services.Google.GmailContactInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]] ---- System.Collections.Generic.ICollection`1[[Aspose.Email.Services.Google.GmailContactInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IEnumerable`1[[Aspose.Email.Services.Google.GmailContactInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IList`1[[Aspose.Email.Services.Google.GmailContactInfo, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Email.Services.Google.GmailContactInfoCollection
System.Collections.ObjectModel.Collection`1[[Aspose.Email.Services.Google.IFeedEntry, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]] ---- System.Collections.Generic.ICollection`1[[Aspose.Email.Services.Google.IFeedEntry, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IEnumerable`1[[Aspose.Email.Services.Google.IFeedEntry, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IList`1[[Aspose.Email.Services.Google.IFeedEntry, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Email.Services.Google.FeedEntryCollection
System.Exception ---- System.Runtime.Serialization.ISerializable
Aspose.Email.Services.Google.GmailClientException
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Email.Services.Google.GmailClientAuthorization

See Also

Aspose.Email.Services.Google Namespace


Aspose.Email.ServicesHierarchy

Aspose.Email

Aspose.Email.Services Hierarchy

System.Object
Aspose.Email.Services.IOAuthServiceClient

See Also

Aspose.Email.Services Namespace


Aspose.Email.VerifyHierarchy

Aspose.Email

Aspose.Email.Verify Hierarchy

System.Object
Aspose.Email.Verify.EmailValidator
Aspose.Email.Verify.ValidationResult
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
Aspose.Email.Verify.DomainValidatingEventHandler
Aspose.Email.Verify.MailServerValidatingEventHandler
Aspose.Email.Verify.SyntaxValidatingEventHandler
System.EventArgs
Aspose.Email.Verify.SyntaxValidatingEventArgs
Aspose.Email.Verify.DomainValidatingEventArgs
Aspose.Email.Verify.MailServerValidatingEventArgs
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Email.Verify.ValidationPolicy
Aspose.Email.Verify.ValidationResponseCode

See Also

Aspose.Email.Verify Namespace


Aspose.Email.Windows.WPFHierarchy

Aspose.Email

Aspose.Email.Windows.WPF Hierarchy

System.Object
System.EventArgs
Aspose.Email.Windows.WPF.FileDropEventArgs
System.Windows.Threading.DispatcherObject
System.Windows.DependencyObject
System.Windows.Media.Visual
System.Windows.UIElement ---- System.Windows.IInputElement, System.Windows.Media.Animation.IAnimatable
System.Windows.FrameworkElement ---- System.ComponentModel.ISupportInitialize, System.Windows.IFrameworkInputElement
System.Windows.Controls.Control
System.Windows.Controls.ContentControl ---- System.Windows.Markup.IAddChild
System.Windows.Controls.UserControl
Aspose.Email.Windows.WPF.FileDropPanel

See Also

Aspose.Email.Windows.WPF Namespace


Aspose.EmailHierarchy

Aspose.Email

Aspose.Email Hierarchy

System.Object
Aspose.Email.BuildVersionInfo
Aspose.Email.CredentialsByHostClient ---- System.IDisposable
Aspose.Email.License
Aspose.Email.MailQuery ---- System.IEquatable`1[[Aspose.Email.MailQuery, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Xml.Serialization.IXmlSerializable
Aspose.Email.MailQueryBuilder
Aspose.Email.QueryField
Aspose.Email.ComparisonField
Aspose.Email.DateComparisonField
Aspose.Email.IntComparisonField
Aspose.Email.StringComparisonField
System.Exception ---- System.Runtime.Serialization.ISerializable
Aspose.Email.AsposeException
Aspose.Email.ActiveSyncException
Aspose.Email.ActiveSyncNotSupportedException
Aspose.Email.AsposeArgumentException
Aspose.Email.AsposeArgumentNullException
Aspose.Email.AsposeInvalidDataException
Aspose.Email.FileCorruptedException
Aspose.Email.FormatNotSupportedException
Aspose.Email.GoogleClientException
Aspose.Email.NetworkException
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Email.ConnectionState

See Also

Aspose.Email Namespace


Aspose.iCalendarHierarchy

Aspose.Email

Aspose.iCalendar Hierarchy

System.Object
Aspose.iCalendar.ByDay
Aspose.iCalendar.RecurrencePattern
Aspose.iCalendar.RecurrenceRule
System.Collections.ObjectModel.Collection`1[[Aspose.iCalendar.ByDay, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]] ---- System.Collections.Generic.ICollection`1[[Aspose.iCalendar.ByDay, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IEnumerable`1[[Aspose.iCalendar.ByDay, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IList`1[[Aspose.iCalendar.ByDay, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.iCalendar.ByDayCollection
System.Collections.ObjectModel.Collection`1[[Aspose.iCalendar.RecurrenceRule, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]] ---- System.Collections.Generic.ICollection`1[[Aspose.iCalendar.RecurrenceRule, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IEnumerable`1[[Aspose.iCalendar.RecurrenceRule, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IList`1[[Aspose.iCalendar.RecurrenceRule, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.iCalendar.RecurrenceRuleCollection
System.Collections.ObjectModel.Collection`1[[System.DateTime, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]] ---- System.Collections.Generic.ICollection`1[[System.DateTime, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]], System.Collections.Generic.IEnumerable`1[[System.DateTime, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]], System.Collections.Generic.IList`1[[System.DateTime, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]], System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.iCalendar.DateCollection
System.Collections.ObjectModel.Collection`1[[System.Int32, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]] ---- System.Collections.Generic.ICollection`1[[System.Int32, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]], System.Collections.Generic.IEnumerable`1[[System.Int32, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]], System.Collections.Generic.IList`1[[System.Int32, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]], System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.iCalendar.ByNumberCollection
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.iCalendar.EndType
Aspose.iCalendar.Frequency

See Also

Aspose.iCalendar Namespace


Aspose.Windows.FormsHierarchy

Aspose.Email

Aspose.Windows.Forms Hierarchy

System.Object
Aspose.Windows.Forms.FileDataObject
Aspose.Windows.Forms.FileDropTargetManager ---- System.Windows.Forms.IDropTarget
Aspose.Windows.Forms.IFileDropTargetControl
Aspose.Windows.Forms.MailClientAgent
Aspose.Windows.Forms.Recipient
System.Collections.ObjectModel.Collection`1[[Aspose.Windows.Forms.FileDataObject, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]] ---- System.Collections.Generic.ICollection`1[[Aspose.Windows.Forms.FileDataObject, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IEnumerable`1[[Aspose.Windows.Forms.FileDataObject, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IList`1[[Aspose.Windows.Forms.FileDataObject, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Windows.Forms.FileDataObjectCollection
System.Collections.ObjectModel.Collection`1[[Aspose.Windows.Forms.Recipient, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]] ---- System.Collections.Generic.ICollection`1[[Aspose.Windows.Forms.Recipient, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IEnumerable`1[[Aspose.Windows.Forms.Recipient, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.Generic.IList`1[[Aspose.Windows.Forms.Recipient, Aspose.Email, Version=4.2.0.0, Culture=neutral, PublicKeyToken=null]], System.Collections.ICollection, System.Collections.IEnumerable, System.Collections.IList
Aspose.Windows.Forms.RecipientCollection
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
Aspose.Windows.Forms.FileDragEventHandler
System.EventArgs
System.Windows.Forms.DragEventArgs
Aspose.Windows.Forms.FileDragEventArgs
System.MarshalByRefObject
System.ComponentModel.Component ---- System.ComponentModel.IComponent, System.IDisposable
System.Windows.Forms.Control ---- System.ComponentModel.ISynchronizeInvoke, System.Windows.Forms.IBindableComponent, System.Windows.Forms.IDropTarget, System.Windows.Forms.IWin32Window
System.Windows.Forms.ScrollableControl
System.Windows.Forms.Panel
Aspose.Windows.Forms.FileDropTargetPanel ---- Aspose.Windows.Forms.IFileDropTargetControl
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
Aspose.Windows.Forms.RecipientType

See Also

Aspose.Windows.Forms Namespace